StarTeam

Borland StarTeam SDK for .NET

StarTeam Namespace

Namespace hierarchy

Classes

Class | Description
AccessRightsManager

A generalized access rights cache for all types of StarTeam artifacts and Containers For optimized results, the cache should be pre-loaded with ACLs for each and every relevant artifact (or container)

Access rights information is fetched from the server as necessary, using bulk queries to minimize server traffic, and cached to improve performance of subsequent access tests. From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes and helps optimizing server calls. All access tests are in-memory operations This class is thread-safe and supports a multi reader single writer concurrency pattern
AccessRightsManager.AccessTestResults

Represents the results of an access test.

Indicates whether or not access is granted, and provides an explanation in terms of the EffectiveACEs that were relevant for each tested permission.
ACE | An Access Control List entry. An ACE specifies a set of permissions that are either granted or denied to a particular user or group. A collection of such entries makes an ACL or Access Control List.
ACE.WebCacheACE | Base accessor for cached SDK ACEs
Application | The StarTeam SDK's interface to the client application.
Application.ResolveOptions | Options that control the behavior of an Application's resolve operations.
ArtifactCache | An artifact cache is a collection of artifacts of different types The cache creates and maintains a private connection to the StarTeam server, using the credentials specified in the constructor This connection is closed when the cache is discarded. Well behaved applications should call the {@link #close()} api. The cache manages the artifacts requested, and access rights to these artifacts General queries may be constructed of the form Does a given principal have the right to read (or write) to an object in this cache Typically, the cache is built up in the context of an Administrator, but cached objects are shared across less privileged users, depending upon their access rights This is a self-refreshing cache; refreshes are requested on a regular timer With MPX enabled, the refreshes are optimized to execute the fewest possible server commands Note that while it is certainly reasonable and expected for the calling application to have enabled MPX and registered the server object with a CacheAgent, this cache itself attempts to enable MPX, if required. However, the cache makes no attempt to auto locate a cache agent. There are two reasons for this Auto locating a cache agent makes no guarantees about the nearness of the cache agent. Auto location is based solely on which cache agent responds first to a broadcast When used in the context of a web server (the primary motif for this class) it is generally expected that the web service application is network near to the StarTeam server. In this case, a Cache Agent offers little to no performance benefit, and in some cases may even cause a potential degradation in overall performance and throughput. An application can however, explicitly locate a cache agent using {@link Server#locateCacheAgent(String, int)}
ArtifactCacheManager | A collection of ArtifactCache's managed for a given server. The framework owns these caches and the associated baselines, so that all web client applications (if loaded in the same JRE) will be able to access each others cache and share types across caches The managed caches comprise tip and baselines, i.e. rolled back configurations (identified by Context) The Tip Artifact caches all interesting projects, views and types (as determined by the caller) In contrast, each rolled back cache contains all the types for a single rolled back view
ArtifactCacheManager.Client | Establish the context of a Client Application. If interested, each Client Application must provide a unique context uniqueness defined by Application Name, e.g. Caliber, Topaz, Zuma, SCTM, etc A client application will create and retain a single context instance per server. Alternately, a client application may choose to allow the ArtifactCacheManager to hold onto its context (keyed by name). An application should register its Client Context with the ArtifactCacheManager immediately after starting up the Manager, and before requesting baselines. Subsequent baseline registrations will cache the set of types defined by the client
ArtifactCacheManager.Context | Establish the context in which a web application will execute some session specific requirement. The context may be as coarse or fine grained as desired. A context may be resolved to one and only one StarTeam object. The rules will be applied deterministically, to guard against the possibility of conflict The user is responsible for the integrity of the various id's stored in the object
Audit | Represents a StarTeam Audit record
Audit.EventID | EventID of the Audit
Audit.Type | The Audit Type
Audit.Type.ClassID1Property | The property type of the ClassID1 property.
Audit.Type.ClassID2Property | The property type of the ClassID2 property.
Audit.Type.ClassID3Property | The property type of the ClassID3 property.
Audit.Type.ClassName1Property | The property type of the ClassName1 property.
Audit.Type.ClassName2Property | The property type of the Classname2 property.
Audit.Type.ClassName3Property | The property type of the ClassName3 property.
Audit.Type.Descriptor1Property | The property type of the Descriptor1 property.
Audit.Type.Descriptor2Property | The property type of the Descriptor2 property.
Audit.Type.Descriptor3Property | The property type of the Descriptor3 property.
Audit.Type.EventIDProperty | The property type of the EventID property.
Audit.Type.FolderIDProperty | The property type of the FolderID property.
Audit.Type.Info1Property | The property type of the Info1 property.
Audit.Type.Info2Property | The property type of the Info2 property.
Audit.Type.Info3Property | The property type of the Info3 property.
Audit.Type.ObjectID1Property | The property type of the ObjectID1 property.
Audit.Type.ObjectID2Property | The property type of the ObjectID2 property.
Audit.Type.ObjectID3Property | The property type of the objectID3 property.
Audit.Type.PropertyCollection | The PropertyCollection of an Audit.
Audit.Type.RevisionTime1Property | The property type of the RevisionTime1 property.
Audit.Type.RevisionTime2Property | The property type of the RevisionTime2 property.
Audit.Type.RevisionTime3Property | The property type of the RevisionTime3 property.
Audit.Type.UserProperty | The property type of the User property.
BinaryProperty | A BinaryProperty is a Property whose value is a Byte Stream
BinaryProperty.WebCacheBinaryProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
BooleanProperty | A Boolean property is a Property whose value may be either True or False
BooleanProperty.WebCacheBooleanProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
BuildNumber | A simple class that provides access to version information for the starteam SDK. The current version is "StarTeam SDK 17.0, Build 34".
CacheAgent | Describes the features of a Cache Agent, including the type of content it caches, the projects supported, and whether or not it caches object property content.
Catalog | The Catalog class provides "global" access to certain properties of objects from different classes. The catalog provides information about Property values for the primary descriptors of objects. Note that the catalog is highly memory intensive and hence extremely expensive Applications should make every effort to retrieve the primary descriptor of an object using all means available before falling back to the catalog
Catalog.WebCacheCatalog | The Catalog class provides "global" access to certain properties of objects from different classes. The catalog provides information about Property values for the primary descriptors of objects. Note that the catalog is highly memory intensive and hence extremely expensive Applications should make every effort to retrieve the primary descriptor of an object using all means available before falling back to the catalog
Change | A Change is essentially a unit of a ChangePackage. Each Change object describes one item modified during the commit.
Change.ChangeAtomType | a ChangeAtom Type
Change.ChangeType | The value of the Change Type Property
Change.CommitAction | The action that was used to commit a change.
Change.Type | The Type for Change
Change.Type.ActionProperty | The property type of the Action property.
Change.Type.ChangePackageProperty | The property type of the ChangePackage property.
Change.Type.ChangeTypeProperty | The property type of the ChangeType property.
Change.Type.FlagsProperty
Change.Type.ItemTypeProperty | The property type of the ItemType property.
Change.Type.PropertyCollection | The Property Collection of a Change Object
Change.Type.SourceVersionProperty | The property type of the SourceVersion property.
Change.Type.TargetVersionProperty | The property type of the TargetVersion property.
Change.WebCacheChange | Change accessor for cached SDK Changes contained objects are obtained from the artifact cache
ChangeCollection | A collection of change objects.
ChangePackage | A ChangePackage represents a set of changes to a StarTeam view that together form a single logical change. A logical change might be a bug fix, enhancement, etc. The updates made by a ChangePackage are committed in a single, atomic transaction.
ChangePackage.SessionType | The type of VCM or Checkin Session in whose context this Change Package was committed
ChangePackage.State | The current state of the change package.
ChangePackage.Type | The Type of the ChangePackage component.
ChangePackage.Type.CommittedByProperty | The property type of the Committed By property.
ChangePackage.Type.CommittedInBuildProperty | The property type of the Committed In Build property.
ChangePackage.Type.CommittedTimeProperty | The property type of the Committed Time property.
ChangePackage.Type.ExternalBranchURLProperty | The property type of the ExternalBranchURLProperty property
ChangePackage.Type.ExternalCreatedByProperty | The property type of the ExternalCreatedByProperty property
ChangePackage.Type.ExternalCreatedTimeProperty | The property type of the External Created Time property.
ChangePackage.Type.ExternalRepositoryURIProperty | The property type of the ExternalRepositoryURIProperty property
ChangePackage.Type.FullScopeProperty | The property type of the FullScopeProperty property
ChangePackage.Type.PostCommitRevisionLabelProperty | The property type of the Post Commit Revision Label property.
ChangePackage.Type.PostCommitViewLabelProperty | The property type of the Post Commit View Label property.
ChangePackage.Type.PreCommitRevisionLabelProperty | The property type of the Pre Commit Revision Label property.
ChangePackage.Type.PreCommitViewLabelProperty | The property type of the Pre Commit View Label property.
ChangePackage.Type.ProcessItemProperty | The property type of the ProcessItem property
ChangePackage.Type.PropertyCollection | The PropertyCollection of the ChangePackage Type
ChangePackage.Type.SessionTypeProperty | The property type of the Session Type property.
ChangePackage.Type.SourceViewProperty | The property type of the Source View property.
ChangePackage.Type.StateProperty | The property type of the State property.
ChangePackage.Type.TargetViewProperty | The property type of the Target View property.
ChangePackage.WebCacheChangePackage | ChangePackage accessor for cached SDK ChangePackages contained objects are obtained from the artifact cache
ChangePackageCollection | A Collection of Change Packages within a specified view
ChangePackageReplayGraph

Represents the set of replay relationships among a collection of change packages.

The graph contains all change packages that share at least one change with those in a given set.
ChangeRequest | Represents a StarTeam ChangeRequest item.
ChangeRequest.ChangeRequestType | The type of change requested.
ChangeRequest.Platform | The platform on which the need for this request was discovered.
ChangeRequest.Priority | Priority of the ChangeRequest
ChangeRequest.Severity | The severity of the problem that prompted the request.
ChangeRequest.StarFlowStatus | The current status of the change request.
ChangeRequest.Status | The current status of the change request.
ChangeRequest.StreamState | The Info Stream State of the ChangeRequest
ChangeRequest.Type | Type meta-data (schema) for ChangeRequest object instances.
ChangeRequest.Type.AddressedByProperty | The property type of the AddressedBy property.
ChangeRequest.Type.AddressedInProperty | The property type of the AddressedIn property.
ChangeRequest.Type.AddressedInViewProperty | The property type of the AddressedInView property.
ChangeRequest.Type.CategoryProperty | The property type of the Category property.
ChangeRequest.Type.ChangeNumberProperty | The property type of the ChangeNumber property.
ChangeRequest.Type.ChangeRequestTypeProperty | The property type of the RequestType property.
ChangeRequest.Type.ClosedOnProperty | The property type of the ClosedOn property.
ChangeRequest.Type.ComponentProperty | The property type of the Component property.
ChangeRequest.Type.EnteredByProperty | The property type of the EnteredBy property.
ChangeRequest.Type.EnteredOnProperty | The property type of the EnteredOn property.
ChangeRequest.Type.FixProperty | The property type of the Fix property.
ChangeRequest.Type.LastBuildTestedProperty | The property type of the LastBuildTested property.
ChangeRequest.Type.PlatformProperty | The property type of the Platform property.
ChangeRequest.Type.PriorityProperty | The property type of the Priority property.
ChangeRequest.Type.PropertyCollection | The PropertyCollection of a ChangeRequest item.
ChangeRequest.Type.ResolvedOnProperty | The property type of the ResolvedOn property.
ChangeRequest.Type.SeverityProperty | The property type of the Severity property.
ChangeRequest.Type.StarFlowStatusProperty | The property type of the Status property.
ChangeRequest.Type.StatusProperty | The property type of the Status property.
ChangeRequest.Type.StreamStateProperty | The property type of the StreamState property.
ChangeRequest.Type.SynopsisProperty | The property type of the Synopsis property.
ChangeRequest.Type.TestCommandProperty | The property type of the TestCommand property.
ChangeRequest.Type.VerifiedOnProperty | The property type of the VerifiedOn property.
ChangeRequest.Type.WorkAroundProperty | The property type of the WorkAround property.
ChangeRequest.WebCacheChangeRequest | Item accessor for cached SDK ChangeRequest items contained objects are obtained from the artifact cache
ChangeSession | A change session, possibly associated with a change package.
CheckinManager | Provides a way to check in multiple files, applying a consistent set of options across all files. Files may be aggregated or overwritten (using the different flavors of the checkin api's) until ready to commit all the changes Files may also be deleted or moved from their current parent folder to a different folder in the same view The commit() method must be called to save all the changes to the repository The commit consists of a non-transactional phase, followed by a transactional one, which additionally creates a ChangePackage that encompasses the set of changes, i.e. files added, modified, deleted and moved During the non-transactional phase of the commit, events are fired to the calling client application, at which point, the application may still decide to overwrite earlier decisions such as ignoring certain files, force checking in others, checking in from a different stream, etc. Usage CheckinManager cm = myView.createCheckinManager(); cm.checkin(file1); cm.checkinFrom(file2, new java.io.File("c://myprojects//myworkspace//file2.txt"); cm.delete(file3); cm.move(file4, myView.getRootFolder()); if (cm.canCommit()) cm.commit();
CheckinManager.Progress | Information on the progress of a checkin operation from CheckinManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckinManager.getProgress().
CheckinManager.Progress.Phase | Information on the phase of a checkin progress of the checkin operation from CheckinManager.
CheckinManager.WebCacheCheckinManager | Checkin Manager accessor for cached SDK items Contained objects are obtained from the artifact cache a Change Package is created on commit, pursuant to server settings CheckinManager instances are considered stale after commit
CheckinOptions | Maintains the checkin options used by CheckinManager.
CheckinOptions.WebCacheCheckinOptions | Maintains the checkin options used by WebCacheCheckinManager.
CheckoutManager | Provides a way to check out multiple files, applying a consistent set of options across all files. Files may be aggregated or overwritten (using the different flavors of the checkout api's) until ready to commit all the changes The commit() method must be called to save all identified changes to the local file system Files will be checked out either from the StarTeam server or from the closest cache agent If a cache agent is being used, file checkouts are multi-threaded, and are based on the HTTP protocol The commit is non-transactional, and is executed in two primary phases During the first phase of the checkout, events are fired to the calling client application, at which point, the application may decide to overwrite earlier decisions, such as ignoring certain files, force checking out others, checking out to a different stream, etc. Usage CheckoutManager cm = myView.createCheckoutManager(); cm.checkout(file1); cm.checkoutTo(file2, new java.io.File("c://myprojects//myworkspace//file2.txt"); cm.checkout(file3, new CheckoutOptions(myView)); if (cm.canCommit()) cm.commit();
CheckoutManager.Progress | Information on the progress of a checkout operation from CheckoutManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckoutManager.getProgress().
CheckoutManager.Progress.Phase | Information on the phase of a checkout progress of the Checkout operation from CheckoutManager.
CheckoutManager.Progress.Statistics | A Statistical summary that tracks the progress of the checkout
CheckoutManager.WebCacheCheckoutManager | Checkout Manager accessor for cached SDK items Contained objects are obtained from the artifact cache CheckoutManager instances are considered stale after commit
CheckoutOptions | Maintains the checkout options used by CheckoutManager.
CheckoutOptions.WebCacheCheckoutOptions | Maintains the checkout options used by WebCacheCheckoutManager.
ClientContext | The ClientContext class contains the necessary information in order to run the SDK on one machine for a client running on a different machine. This is useful, for example, when running an SDK application within a Web server for a remote browser based client. The information in the ClientContext includes a unique client GUID identifier, the address of the client machine, the client's end-of-line convention, whether or not the client treats file names as case sensitive or not and the string used to delimit directory names within an absolute file path. The Platform class has methods for returning those values on the host running the SDK.
ClientContext.DirectoryOverrides | A class that can parse a StarTeam.xml file and work with the view and folder overrides it specifies.
CommandProcessor | A Command Processor is a class that executes a sequence of commands against a selected server, in the context of a specific project and view. The class maintains a connection to a single view instance
Concept | A Concept is a basic unit of content.
Concept.Type | Type meta-data (schema) for Concept object instances.
Concept.Type.ConceptIDProperty | The property type of the ConceptID property
Concept.Type.ContentProperty | The property type of the RichDescription property.
Concept.Type.PropertyCollection | The PropertyCollection of a Concept
Concept.WebCacheConcept | Item accessor for cached SDK Concept items contained objects are obtained from the artifact cache
ConfigFiles | All client stored configuration file locations for StarTeam can be found using this class.
ConnectionPool | A Connection Pool manages a set of connections targeted at a give StarTeam Server. Typically, one connection (the primary) is used for reading, and pooled connections are available for writing The pool automatically allocates connection on demand Note that the caller is responsible for refreshing the primary session cache and/or other alternate caches which may belong to separate server sessions The model supports multiple connection pools, 1 or more per managed StarTeam server
Content | The value of a ContentProperty. Arbitrary data with an advisory content type.
Content.AcceptedTypes | This class represents an Accept request-header field. It provides methods to parse an Accept request-header field string into individual components.
Content.Type | This class represents a MIME Content-Type value. It provides methods to parse a Content-Type string into individual components and to generate a MIME style Content-Type string.
Content.WebCacheContent | Content accessor for cached SDK content contained objects are obtained from the artifact cache
ContentProperty | This class represents a property whose value is arbitrary content.
ContentProperty.WebCacheContentProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
DateProperty | This class represents a property whose value is a java.util.Date.
DateProperty.WebCacheDateProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
DateTimeProperty | This class represents a property whose value is a DateTime.
DateTimeProperty.WebCacheDateTimeProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
DoubleProperty | This class represents a property whose value is a double.
DoubleProperty.WebCacheDoubleProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
EffectiveACE

An Access Control Entry (ACE) in an Effective Access Control List (ACL).

An EffectiveACE may be an ACE that is explicitly listed in the ACL for an object or for its parent container, or may be implied by group permissions that have been defined, or by object ownership rules, or by the StarTeam access test algorithm itself.

Each EffectiveACE provides information about its origin, including a description in human-readable form.

EffectiveACEs are important with respect to explaining the results of an access test.
EnumeratedProperty | This class represents a property whose value is an enumeration Historically, enumerations were single select, i.e. only a single enumerated value could be sent to or received from the starteam server, in the context of an EnumeratedProperty. However, from StarTeam server 12.0 on, the server supports multi select enumerated lists. i.e. an application may create a custom multi-select enumerated property and send/receive more than one enumerations as the value of the property for the artifact For consistency, the SDK api {@link TypedResource#getValue(Property)} always returns an array of EnumeratedValue's, whether the property type is single or multi-select. For single select, the array will contain 0 or 1 enumerated value's (depending upon whether any value has been selected or not) For multi select lists, the array will contain 0 or more enumerated values. For EnumeratedProperties, the SDK api {@link TypedResource#setValue(Property, Object)} takes either a single Enumerated Value or an array of EnumeratedValues in the second parameter. If a single value is presented, a single value is saved irrespective of whether the list is single or multi select. On the other hand, if an array of values (> 1) is presented, but the property type is single select, an SKDRuntimeException will be thrown
EnumeratedProperty.WebCacheEnumeratedProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
EnumeratedValue | A simple integer/String pair object to be used for adding new custom enumerated fields (Property) and modifying existing enumerated fields (Property).
EventHandlerInfo | The EventHandlerInfo class describes a registered event handler, such as the one for the StarTeam MPX Server.
EventHandlerProfile | The EventHandlerProfile class contains the information of one of profiles of an EventHandlerInfo.
File | Represents a StarTeam File item.
File.AddResult | The class holds return information specific to the file add operation.
File.CharacterSet | The character set of a working file on disk.
File.CheckInResult | The class holds return information specific to the file checkin operation.
File.CheckOutResult | The class holds return information specific to the file checkout operation.
File.Compression | File compression level.
File.EOLFormat | The EOL format of a text file on disk.
File.KeywordFlag | File keyword flag.
File.KeywordReader
File.Operation | An Operation Context for a given File, used by the CPC's Custom Trigger
File.Result | return information common to the file operations of add, checkin and checkout
File.Status | The current status of the file.
File.StorageType | The mechanism used to store this File content in the repository
File.Stream | Provides utility functions for manipulating File streams.
File.SyncRecord | a stock Sync Record Implementation to create sync records in syncdb
File.Type | The Type of File items.
File.Type.ArchiveNameProperty | The property type of the Archive Name property.
File.Type.CharacterSetProperty | The property type of the CharacterSet property.
File.Type.CompressionProperty | The property type of the Compression property.
File.Type.ContentModifiedTimeProperty | The property type of the FileTimeAtCheckin property.
File.Type.ContentVersionProperty | The property type of the ContentVersion property.
File.Type.EOLFormatProperty | The property type of the EOLFormat property.
File.Type.ExtensionProperty | The property type of the Extension property.
File.Type.HiveProperty | The property type of the Hive property.
File.Type.IsExecutableProperty | The property type of the IsExecutable property.
File.Type.IsSyncInRevisionHistoryProperty | The property type of the IsSyncInRevisionHistory property.
File.Type.IsSyncKnownProperty | The property type of the IsSyncKnown property.
File.Type.IsWorkingFileAvailableProperty | The property type of the LocalFileExists property.
File.Type.IsWorkingFileExecutableProperty | The property type of the WorkingFileExecutable property.
File.Type.KeywordFlagProperty | The property type of the KeywordFlag property.
File.Type.MD5Property | The property type of the MD5 property.
File.Type.NotificationUsersProperty | The property type of the NotificationIDs property
File.Type.PropertyCollection | The PropertyCollection of a File item.
File.Type.SizeProperty | The property type of the Size property.
File.Type.StatusProperty | The property type of the Status property.
File.Type.StorageTypeProperty | The property type of the Storage Type property.
File.Type.SymbolicLinkTargetProperty | The property type of the SymbolicLinkTargetProperty property
File.Type.SyncBranchVersionProperty | The property type of the SyncObjectVersion property.
File.Type.SyncContentVersionProperty | The property type of the SyncContentVersion property.
File.Type.SyncMD5Property | The property type of the SyncMD5 property.
File.Type.SyncModifiedTimeProperty | The property type of the SyncTime property.
File.Type.SyncSizeProperty | The property type of the SyncSize property.
File.Type.SyncViewVersionProperty | The property type of the SyncPathVersion property.
File.Type.VaultVersionProperty | The property type of the VautVersion property.
File.Type.ViewVersionProperty | The property type of the View version property.
File.Type.WorkingFileModifiedTimeProperty | The property type of the LocalTimeStamp property.
File.Type.WorkingFileNameProperty | The property type of the LocalName property.
File.Type.WorkingFilePathProperty | The property type of the LocalPath property.
File.Type.WorkingFileSizeProperty | The property type of the LocalSize property.
File.Type.WorkingFolderPathProperty | The property type of the Path property.
File.WebCacheFile | File accessor for cached SDK Items contained objects are obtained from the artifact cache
File.WebCacheWorkSpaceSync | A serializable implementation of WorkspaceSync that can be used to calculate status through the WebCache Interfaces. In this model, the client application (applet?) runs in the context of a browser and connects to a web server or web service via http. The web server in turn holds a shared cache connection to the StarTeam server. This model supports entire file operations (checkin, checkout etc) via a browser.
FileBasedStatusManager | Manages File Status information on the local client workstation.
Filter | The Filter class is used to define criteria for which items (files, change requests) should be displayed to a user. It includes information on which items should be displayed, which properties should be displayed, and how the items should be sorted or grouped. The StarTeam GUI uses filters to determine what items in a folder to display.
Filter.Column | A column in which to display the value of the associated property The display length is defined in screen pixel widths
Filter.Column.WebCacheColumn | A column in which to display the value of the associated property The display length is defined in screen pixel widths
Filter.Context | Context is a specification for what the filter applies to or covers it may be local to the file system, specific to object instance stored on the server or both
Filter.Grouping | A positional indicator for a property in a group meant for sorting and grouping results
Filter.Grouping.WebCacheGrouping | A positional indicator for a property in a group meant for sorting and grouping results
Filter.WebCacheFilter | Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.
Folder | Represents a StarTeam Folder. A folder is an Item, i.e. it does not have a parent id property However, (sub)folders reside within folders, which makes a folder a type of hierarchy tree Folders are also containers, in that, other items reside in folders
Folder.ExcludeFlags | Criteria used to exclude folders from the display
Folder.Status | The status of this folder; a value of the Status Property
Folder.Type | The Type for Folder
Folder.Type.ExcludeFlagsProperty | The property type of the Exclude Flags property.
Folder.Type.ExcludeSpecProperty | The property type of the Exclude Spec property.
Folder.Type.ProjectProperty | The property type of the Project property.
Folder.Type.PropertyCollection | The Property Collection of the Folder Type
Folder.Type.StatusProperty | The property type of the Status property.
Folder.Type.WorkingFolderPathProperty | The property type of the Working Folder Path property.
Folder.WebCacheFolder | Item accessor for cached SDK Items contained objects are obtained from the artifact cache
FolderListManager | Manages a collection of folders created by including and excluding selected folders and their sub-folders. Currently, all folders in the list must belong to the same view. Remembers the set of operations used to create the collection, so that the collection can be refreshed using the latest information from the StarTeam repository.
Group | This class represents a full StarTeam Group. New groups can be added to a StarTeam Server and existing groups can be modified through this class. All users can obtain Group information but only users with the appropriate permissions can access GroupAccount information.
Group.GroupType | Defines the Types of a Group This property is new to 12.0+ servers
Group.Type | The Type of Group.
Group.Type.DescriptionProperty | The property type of the Description property.
Group.Type.NameProperty | The property type of the Name property.
Group.Type.ParentProperty | The property type of the Parent property.
Group.Type.PrivilegeMaskProperty | The property type of the Privilege Mask property.
Group.Type.PropertyCollection | The property collection for the Group Type
Group.Type.TenantProperty
Group.Type.TypeProperty | The property type of the Type property.
Group.WebCacheGroup | User accessor for cached SDK Users contained objects are obtained from the artifact cache
HiveInfo | Describes a vault hive on the server.
HiveInfo.HiveType | Constants identifying the type of archive files stored in a vault hive.
HiveManager | Manages vault hives on the server.
ImpersonateUser | Switch the server to execute in the context of an impersonated user Useful for applications like import utilities or web clients that service multiple users by switching context.
IntegerProperty | This class represents a property whose value is an Integer.
IntegerProperty.WebCacheIntegerProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
IPRange | This class represents a range of TCP/IP addresses and the required level of encryption for clients to connect to the StarTeam server.
Item | Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Description property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.
Item.Type | The Type of Items.
Item.Type.DiagramSourceProperty | The property type of the Diagram property.
Item.Type.ExternalReferenceProperty | The property type of the ExternalReference property.
Item.Type.FolderProperty | The property type of the Folder property.
Item.Type.NewRevisionCommentProperty | The property type of the New Revision Comment property.
Item.Type.NotificationCountProperty | The property type of the NotificationCount property
Item.Type.NotificationIDsProperty | The property type of the NotificationIDs property
Item.Type.PropertyCollection | Property Collection for TreeItem
Item.Type.TagProperty | The Property Type of the Tag Property
Item.Type.TeamProperty | The property type of the Team property.
Item.Type.VersionMetadataIDsProperty | The property type of the VersionMetadataIDs property.
Item.Type.VersionMetadataProperty | The property type of the VersionMetadata property.
Item.Type.WebCacheItemType | Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.
Item.WebCacheItem | Item accessor for cached SDK Items contained objects are obtained from the artifact cache
KanbanBoard | A KanbanBoard is a process
KanbanBoard.InputType | The type of the board according to kanban terminology.
KanbanBoard.ItemType | The type of the board according to kanban terminology.
KanbanBoard.Type | Type meta-data (schema) for KanbanBoard object instances.
KanbanBoard.Type.EnforceAgeProperty | The property type of the EnforceAge property.
KanbanBoard.Type.EnforceWIPProperty | The property type of the EnforceWIP property.
KanbanBoard.Type.InboxLaneProperty | The property type of the InboxLane property
KanbanBoard.Type.InputIDProperty | The property type of the InputId property
KanbanBoard.Type.InputTypeProperty | The property type of the InputType property.
KanbanBoard.Type.InTeamRoomProperty | The property type of the EnforceAge property.
KanbanBoard.Type.ItemTypeProperty | The property type of the ItemType property.
KanbanBoard.Type.PropertyCollection | The PropertyCollection of a KanbanBoard
KanbanBoard.WebCacheKanbanBoard | Item accessor for cached SDK KanbanBoard items contained objects are obtained from the artifact cache
Label | Represents a named configuration of ViewMembers. Labels may be applied to an entire View or to individual item versions.
Label.Scope | When applying a label to a folder, the scope of the operation
Label.Type | The Type for Labels
Label.Type.LabelTimeProperty | The property type of the Label Time property.
Label.Type.MemberIDProperty | The property type of the Member ID property.
Label.Type.PropertyCollection | The PropertyCollection of a Label Type.
Label.WebCacheLabel | Label accessor for cached SDK views contained objects are obtained from the artifact cache
Link | Represents an association between two view members. From StarTeam Server 11.0 onwards, application should use Traces to create associations between view members.
Link.Endpoint | Represents a link reference to a viewMember.
LinkCache | Caches links for a given set of items. One LinkCache may be populated with links from multiple view configurations on multiple servers.
LinkProperty | This class represents a property whose value is a link.
LinkProperty.WebCacheLinkProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
LinkToTraceAdapter

An adapter class that surfaces a Link as if it were a Trace.

Since there are significant differences between the two models, the adapted link will actually be a new Trace (that is, a Trace that has not yet been saved to the StarTeam repository, for which isNew() returns true). Information from the Link is surfaced via the new Trace as described below.

  • Trace.getSource() will return a LinkValue that references the same Item as one of the Link endpoints.
  • Trace.getTarget() will return a LinkValue that references the same Item as the other Link endpoint.
  • Trace.getDescription() will return the same string as Link.getComment().
All other properties of the new Trace are initialized to their default values.

The new Trace can of course be modified by the client application, and/or saved to the StarTeam repository using Item.update(). A Trace saved this way is then unrelated to the original Link.

LinkValue | A value of a LinkProperty.
LinkValue.WebCacheLinkValue | The value of a Link Property
LiveObject | LiveObjects store in the repository the date/time when the object was created, and the ID of the user who created it. LiveObjects are soft deleted; that is, they are marked deleted as of a given time, but can still be seen in rolled back view configurations.
LiveObject.Type | The Type for LiveObject
LiveObject.Type.CreatedByProperty | The property type of the Created By property.
LiveObject.Type.CreatedTimeProperty | The property type of the Created Time property.
LiveObject.Type.DeletedByProperty | The property type of the Deleted By property.
LiveObject.Type.DeletedTimeProperty | The property type of the Deleted Time property.
LiveObject.Type.DescriptionProperty | The property type of the Description property.
LiveObject.Type.FlagsProperty | The property type of the Flags property.
LiveObject.Type.GlobalIDProperty | The property type of the Global ID property.
LiveObject.Type.NameProperty | The property type of the Name property.
LiveObject.Type.SourceProperty | The property type of the Source property.
LiveObject.Type.TargetProperty | The property type of the Target property.
LiveObject.Type.WorkingFolderProperty | The property type of the Working Folder property.
LiveObject.WebCacheLiveObject | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
LongIntegerProperty | This class represents a property whose value is a Long Integer.
LongIntegerProperty.WebCacheLongIntegerProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
MapProperty | A Map Property supports the assignment of a java.util.Map as a StarTeam Property value. The property value is serialized and saved to the StarTeam Server (and the underlying database) as a structured set of Key value Pairs using a simple KVP schema The Map Property supports a wide range of native and SDK value types, including String, Integer, Long, Boolean, Double, Float and java.util.Date It also supports the SDK types Date, DateTime, MD5, GUID, DotNotation, TimeSpan and Content
MapProperty.WebCacheMapProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
MatchedACE

Used when explaining the results of an access test.

Each MatchedACE provides a subset of the permissions that were tested, as well as the corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.
MergePoint | This class provides information about how two item revisions are related with respect to merging. Suppose the file "foo.txt" branches at revision 1.3 to create a new revision 1.3.1.0. A checkin on the main branch will create revision 1.4 and a subsequent checkin on the alternate branch will create revision 1.3.1.1. If the user then merges the changes between 1.3 to 1.4 in to a new branch revision 1.3.1.2 a MergePoint can be used to record the sources used to create this new revision. In this case the MergePoint would have a source Revision corresponding to the 1.4 revision of "foo.txt" and a target Revision corresponding to the 1.3.1.2 revision of "foo.txt".
MergePoint.Revision | A simple class representing a unique revision of an Item in the repository. For items of the same type, revisions can be uniquely identified in the repository by the item's objectID and revision number.
NamedCacheRef | Base implementation of objects that use the SDK's uniform caching mechanism and can be identified by a unique name.
NetMonitor | Displays information about the commands that are being sent to the StarTeam Server. This may be useful in diagnosing performance problems.
Oauth2ServiceProvider | Confidential proprietary property Copyright 2019 Micro Focus or one of its affiliates. All rights reserved. Oauth2 service provider class allows StarTeam clients to connect to Oauth2 provider for authentication/single sign-on. Oauth2 provider should conform to Oauth2/Open ID connect specification.
Oauth2ServiceProvider.WebCacheOauth2ServiceProvider
ObjectArrayProperty | This class represents a property whose value is an Object Array. Custom Object Array Properties can be created starting from Server Release 12.0 However, they are restricted to User and Group Arrays
ObjectArrayProperty.WebCacheObjectArrayProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
ObjectProperty | This class represents a property whose value is an Object.
ObjectProperty.WebCacheObjectProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
Permission | This class defines all the different permission settings used by StarTeam. Note that for historical reasons, permission IDs may overlap. The correct choice of Permission actually depends on the context of the object (ISecurable/ISecurableContainer).
PermissionCollection | A Collection that manages Permissions
Plan | Represents a Starteam Plan item.
Plan.PlanType | The type of the plan according to agile terminology.
Plan.Type | Type meta-data (schema) for Plan object instances.
Plan.Type.EndDateProperty | The property type of the StartDate property.
Plan.Type.PlanIDProperty | The property type of the PlanID property
Plan.Type.PlanTypeProperty | The property type of the PlanType property.
Plan.Type.PropertyCollection | The PropertyCollection of a Plan
Plan.Type.StartDateProperty | The property type of the StartDate property.
Plan.Type.WeeklyCapacityProperty | The property type of the WeeklyCapacity property.
Plan.WebCachePlan | Item accessor for cached SDK Plan items contained objects are obtained from the artifact cache
Principal | A StarTeam Resource with the right to manipulate StarTeam Artifacts. Users and Groups are instances of Principals. Access Rights may be granted or denied.
Principal.Type | The Type of the Principal
Principal.WebCachePrincipal | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
ProcessItem | A process item in the context of a given target view.
Project | Represents a StarTeam project which is essentially just a collection of Views.
Project.Methodology | Defines the development methodology property of the Project. This property is new to 12.5+ servers
Project.Status | Defines the status of a Project This property is new to 12.0+ servers
Project.Type | The Type of the Project
Project.Type.CanCreateCheckinChangePackageProperty
Project.Type.CheckinChangePackageLastUpdateProperty | The property type of the Checkin Change Package Last Update property
Project.Type.CompactionProperty | The property type of the Compaction property.
Project.Type.DefaultTypesProperty | The property type of the Default Types property.
Project.Type.DefaultViewProperty | The property type of the DefaultView property.
Project.Type.EncryptionAlgorithmProperty | The property type of the Encryption Algorithm property.
Project.Type.ForceCheckinReasonProperty | The property type of the Force Checkin Reason property.
Project.Type.GUIDProperty | The property type of the GUID property.
Project.Type.IsProcessItemRequiredProperty | The property type of the Is ProcessItem Required property.
Project.Type.KeywordFileExtensionsProperty | The property type of the KeywordFile Extensions property.
Project.Type.MailProperty | The property type of the Mail property.
Project.Type.MarkUnlockedFilesReadOnlyProperty | The property type of the Mark Unlocked Files ReadOnly property.
Project.Type.MergeHistoryDuringVCMSessionProperty | The property type of the Merge History On Promote property.
Project.Type.MethodologyProperty | The property type of the Methodology property.
Project.Type.PropertyCollection | The PropertyCollection of a Project.
Project.Type.RequireLockForCheckinProperty | The property type of the Require Lock for Checkin property.
Project.Type.StatusProperty | The property type of the Status property.
Project.Type.TenantProperty
Project.Type.UseKeywordsProperty | The property type of the Use Keywords property.
Project.WebCacheProject | Project accessor for cached SDK projects contained objects are obtained from the artifact cache
PromotionModel | This class represents the Promotion model for a view. Each view has a single promotion model. The PromotionModel class primarily acts as the owner of an ordered list of PromotionStates.
PromotionModel.Type | The Type of Promotion Model
PromotionModel.Type.NumberOfStatesProperty | The property type of the Number of States property.
PromotionModel.Type.PromotionStatesProperty | The property type of the Promotion States property.
PromotionModel.Type.PropertyCollection | PropertyCollection for Promotion Model
PromotionModel.WebCachePromotionModel | PromotionModel accessor for cached SDK views contained objects are obtained from the artifact cache
PromotionState | This class represents a promotion state associated with a promotion model. This class has no update() method so to save new or modified promotion states you must use PromotionModel.update()
PromotionState.Type | The Type of Promotion State
PromotionState.Type.LabelProperty | The property type of the Label property.
PromotionState.Type.PropertyCollection | PropertyCollection for PromotionState
PromotionState.WebCachePromotionState | PromotionState accessor for cached SDK views contained objects are obtained from the artifact cache
Property | Each different Type supported by a StarTeam Server (e.g. File, Change Request, Topic...) has an associated set of properties. The Property class provides information about a Type's property.
Property.MetaData
Property.WebCacheProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
PropertyCollection | A Collection of Properties supported by a specific Type
PurgeController | Provides control of the Online Purge service. The service may be configured to start automatically when the server starts up. If configured to do so, it will run a purge in the background while the server is running. This eliminates the requirement for costly down time just to purge the starteam repository. The online purge will not affect any resources deleted during the current active server session. Access the purge log by issuing a writeLogFile command with a logType value of 1.
PurgeController.Status | Describes the current state of the purge service
Query | The Query class implements a query condition to be applied to items of a certain type. Query objects are used in conjunction with Filter objects for describing what items to display to the user and how to display them.
Query.Context | User context for evaluating the query
Query.WebCacheQuery | Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.
QueryNode | A QueryNode represents a boolean expression. The expression is applied to an item to determine if the query is true of the item or not.
QueryNode.Operator | The standard operands OR, AND and NOT
QueryNode.WebCacheQueryNode | A QueryNode represents a boolean expression. The expression is applied to an item to determine if the query is true of the item or not.
QueryPart | A QueryPart object represents a boolean expression on the value of a particular property of an item. For example, it could be used to define query to match file objects whose name starts with a specific string.
QueryPart.Relation | Relations that can be used in the expression
QueryPart.WebCacheQueryPart
RecycleBin | Provides access to the items that have been deleted from a view. The RecycleBin has properties that may be used to control which items are included. For example, IncludeDeletedFolders determines whether or not deleted folders are included in the folder tree. IncludeActiveItems determines whether or not active items are included along with deleted ones. Note that the recycle bin for a View with a rolled back ViewConfiguration (that is, a configuration other than the tip) reflects the state of deleted items as of the configuration time. If an item was active at the configuration time and deleted afterwards, it does not appear deleted in the recycle bin.
Requirement | Represents a StarTeam Requirement item.
Requirement.AtlasWorkflowStatus | The workflow status according to Atlas.
Requirement.Priority | Priority of the Requirement
Requirement.RequirementType | Type of the Requirement
Requirement.Status | Status of the Requirement
Requirement.StreamState | The Info Stream State of the Requirement
Requirement.Type | Type meta-data (schema) for Requirement object instances
Requirement.Type.AmbiguitiesCountProperty | The property type of the AmbiguitiesCount property
Requirement.Type.AmIResponsibleProperty | The property type of the AmIResponsible property
Requirement.Type.AtlasWorkflowStatusProperty | The property type of the AtlasWorkflowStatus property.
Requirement.Type.ChildrenCountProperty | The property type of the ChildrenCount property
Requirement.Type.ChildTypeProperty | The property type of the ChildType property
Requirement.Type.CommentsProperty | The property type of the Comments property
Requirement.Type.ExpectedEffortProperty | The property type of the ExpectedEffort property
Requirement.Type.ExplicitRankProperty | The property type of the ExplicitRank property
Requirement.Type.HighEffortProperty | The property type of the HighEffort property
Requirement.Type.IsDisabledProperty | The property type of the IsDisabled property
Requirement.Type.LowEffortProperty | The property type of the LowEffort property
Requirement.Type.NotesProperty | The property type of the Notes property
Requirement.Type.OrderProperty | The property type of the Order property
Requirement.Type.OwnerProperty | The property type of the Owner property
Requirement.Type.ParentRequirementIDProperty | The property type of the ParentRequirementID property
Requirement.Type.PlanProperty | The property type of the Plan property
Requirement.Type.PriorityProperty | The property type of the Priority property.
Requirement.Type.PropertyCollection | The property collection of the Requirement Type
Requirement.Type.RankProperty | The property type of the Rank property
Requirement.Type.RequirementNumberProperty | The property type of the RequirementNumber property
Requirement.Type.RequirementTypeProperty | The property type of the RequirementType property.
Requirement.Type.ResponsibleCountProperty | The property type of the ResponsibleCount property
Requirement.Type.ResponsibleNamesProperty | The property type of the ResponsibleNames property
Requirement.Type.ResponsibleUsersProperty | The property type of the ResponsibleUsers property
Requirement.Type.ReviewedByProperty | The property type of the ReviewedBy property
Requirement.Type.RevisedDescriptionProperty | The property type of the RevisedDescription property
Requirement.Type.StatusProperty | The property type of the Status property.
Requirement.Type.StreamStateProperty | The property type of the StreamState property.
Requirement.Type.UDAGroupingProperty | The property type of the UDA Grouping property.
Requirement.WebCacheRequirement | Item accessor for cached SDK Requirement items contained objects are obtained from the artifact cache
Review | A Review is an oversight of a code block.
Review.ReviewType | The type of Review
Review.Status | The status of the Review
Review.Type | Type meta-data (schema) for Review object instances.
Review.Type.AcceptorsProperty | The property type of the Acceptors property
Review.Type.AuthorsProperty | The property type of the Authors property
Review.Type.PropertyCollection | The PropertyCollection of a Review
Review.Type.PulseLabelProperty | The property type of the PulseLabel property.
Review.Type.RejectorsProperty | The property type of the Rejectors property
Review.Type.ReviewersProperty | The property type of the Reviewers property
Review.Type.ReviewIDProperty | The property type of the SprintID property
Review.Type.ReviewTypeProperty | The property type of the ReviewType property.
Review.Type.StatusProperty | The property type of the Status property.
Review.Type.WatchersProperty | The property type of the Watchers property
Review.WebCacheReview | Item accessor for cached SDK Review items contained objects are obtained from the artifact cache
RollbackSession | A RollbackSession is created and returned as the output of a ChangePackage rollback. The session contains a set of changes, each change representing a starteam file and a set of content objects, the source (the revision whose delta is to be rolled back) the target (or tip) from which the rollback will occur the common ancestor (the file revision content preceding the revision to be rolled back) and the (rolled back) merged content - the tip after the rollback has been applied. The algorithm runs a first diff between the common ancestor and the rollback revision a second diff between the common ancestor and the tip and rolls back (reverses the changes associated with) each matching Edit between the two diffs.
RollbackSession.Change
RollbackSession.MergeAction | The action used to resolve each change
ScalarProperty | An implementation of a ScalarProperty
ScalarProperty.WebCacheScalarProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
Server | The Server class provides network access to a remote StarTeam Server. It only supports access through TCP/IP sockets and has the ability to encrypt and compress all communication between the client server.
Server.CacheController | For each repository accessed via some Server object, we maintain a local cache that holds data fetched from the repository. Normally, when a given cache is no longer referenced by any Server object, the cache is discarded, freeing up memory used by the cached data objects. However, "server-oriented" applications, which open and close many Server connections on behalf of various clients, may benefit from keeping these local caches around even after they are no longer referenced by any Server object. This is especially true when MPX is enabled. CacheController allows an application to adjust the behavior of the SDK caching mechanisms as appropriate.
Server.EmailAttachment | This class embodies an email attachment.
Server.EncryptionAlgorithm | This class provides a convenient place to refer to the different encryption algorithms that can be used for secure StarTeam connections. This class is used by various encryption methods on the connection and server objects.
Server.ProductCode | This public final class defines constant values for the various StarTeam product codes.
Server.Session | Represents a user's session with the server.
Server.WebCacheServer | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
ServerAdministration | The ServerAdministration class provides a convenient interface to perform various server level administration commands. The current set of operations are for field customization. Ultimately these methods should hang off of the core Type and Property objects but the refresh issues are too complex to deal with at this time. After calling any of the customization methods one should do a FULL refresh by discarding everything including the Server object itself and start over.
ServerAdministration.License | Information about the licenses registered on a StarTeam Server.
ServerAdministration.License.AutoPassLicense | A license managed by the AutoPass License Server.
ServerAdministration.License.BLS | A license managed by the Borland License Server. (BLS and BLS licenses are provided through Embarcadero Software)
ServerAdministration.LockStatus | Information about the lock status of the server. Possible status are "locked", "locked exclusively" or "unlocked".
ServerAdministration.SecurityLogEntry | Information about the security log entries on a StarTeam Server.
ServerAdministration.SecurityLogEntry.AccessCheck | For Access Check events.
ServerAdministration.SecurityLogEntry.ContainerACL | For Container-level security log events.
ServerAdministration.SecurityLogEntry.EventType | Constants that define the type of the Security Event.
ServerAdministration.SecurityLogEntry.ObjectACL | For Object ACL events.
ServerAdministration.SecurityLogEntry.UserGroup | For User-based security log events.
ServerAdministration.SecurityLogEntry.Workstation | Workstation details
ServerAdministration.ServerLogMode | Information about the log mode of the server.
ServerAdministration.ServerLogType | Information about the log type of the server.
ServerConfiguration | Describes Configuration Properties of the connected StarTeam server
ServerConfiguration.AuthenticationType | AuthenticationType used by the server
ServerConfiguration.DatabaseType | Database type used by the server
ServerConfiguration.DirectoryServiceSecurityType | Security type used while connecting to Directory service. Starting 15.1, support for TLS is added in addition to SSL. (eUnsecure = 0, eSSL = 1, eTLS =2 )
ServerConfiguration.NotificationType | Notification type used by the server
ServerConfiguration.WebCacheServerConfiguration | Server Configurations exposed via the Web Cache Object Model
ServerInfo

Description: Server Configuration Parameters including the MPX Profile, and Cache Agent Configuration Applications that intend to use the Cache Agent should provide connectivity information through this class.

ServerInfoCollection | Collection of Server configuration parameters
Share | This class represents the share tree of an item
Share.Type | Type for share
Share.Type.FolderIDProperty | The property type of the FolderID property.
Share.Type.ItemIDProperty | The property type of the ItemID property.
Share.Type.ItemRevisionProperty | The property type of the Item Revision property.
Share.Type.NumberOfDerivedSharesProperty | The property type of the Number of Derived Shares property.
Share.Type.ObjectIDProperty | The property type of the Object ID property.
Share.Type.ProjectNameProperty | The property type of the Project name property.
Share.Type.ProjectProperty | The property type of the Project property.
Share.Type.PropertyCollection | Property Collection class for Share type
Share.Type.ViewPathProperty | The property type of the View path property.
Share.Type.ViewProperty | The property type of the View property.
Share.WebCacheShare | Base accessor for cached SDK Shares
Sprint | An Agile/Scrum Sprint is a basic unit of development. It sums up all work to be accomplished within the sprint period that typically spans from a week to a month.
Sprint.Type | Type meta-data (schema) for Sprint object instances.
Sprint.Type.EndDateProperty | The property type of the StartDate property.
Sprint.Type.OwnerProperty | The property type of the Owner property.
Sprint.Type.PlanProperty | The property type of the Plan property
Sprint.Type.PropertyCollection | The PropertyCollection of a Sprint
Sprint.Type.SprintIDProperty | The property type of the SprintID property
Sprint.Type.StartDateProperty | The property type of the StartDate property.
Sprint.Type.TargetReleasesProperty | The property type of the TargetReleases property.
Sprint.WebCacheSprint | Item accessor for cached SDK Sprint items contained objects are obtained from the artifact cache
StarTeamClientOptions | Client Options maintained in the StarTeamClientOptions.xml file
StarTeamCollection | A stock implementation of an SDK collection. Every object in the collection is required to be unique and of the same class type The Java version implements java.util.Collection The C# version implement System.Collections.IList
StarTeamRepositoryIDs | A local file that keeps track of the last known repository ID of each known StarTeam server.
StarTeamURL

StarTeamURL uses a URL-like syntax to reference a StarTeam Server, Project, View or Item. it provides a convenient way to locate important StarTeam objects.

StarTeamURL supports the following syntax:

starteam://username:password@hostname:port/Project/View/FolderA/FolderB/... (This is the general form of the StarTeam URL naming scheme SCHEME=NAME, which is the default StarTeam URL naming scheme.

StarTeamURL fully supports the generalized StarTeam URL naming scheme by Name or ID. (see the document StarTeam-URL-spec.html) However, URLs in the more generalized form are harder to construct 'by hand' and are best generated using the SDK method Application.toStarTeamURL
StatusMethod

This class provides information about how file status is managed for the client. Prior to StarTeam 5.2 all file status information was stored on the StarTeam Server. In 5.2 this status information moved to the client. There are two ways in which that status information can be stored. These are referred to as "Per folder" and "Central"

"Per folder" status information is stored as close to the source file as possible. Assuming a file under revision control is stored in C:/project/foo.txt then the status information for that file will be stored in C:/project/.sbas/SyncDB. In fact, the status information for all files under C:/project will be stored in the file. There are a number of advantages of storing it in this location. For example, whole local folder structures may be moved or copied to new locations and all the status information will go along with it. The down side to this scheme is that in some cases users will not want the .sbas folders mixed in with the source files they are managing with StarTeam.

"Central" status information is all stored under a single user specified directory on the client's machine. This keeps the status information away from the user's source files. The down side to this approach is that you cannot easily move or copy source directories and have status information go along with it.

Users may specify which of these two methods to use by default along with the location of the central status information. Additionally, users may override this on a per-View basis.
StatusMethod.FileStatus | A FileStatus represents a combination of a file name and its status information from the status database (syncdb) on disk. This status object may be used by tools to help identify issues in status calculation on end user local file systems and is primarily relevant to and targeted at central file systems. Instances of the FileStatus object are returned in an array by the method {@link StatusMethod#getStatusInformation(String)} It may be used to reconcile a file on disk, a FileStatus object and a File in StarTeam to determine the correctness of File.Status calculation
Story | A Story represents an Agile user story. It has a StoryType property to further qualify it as a more specific Agile artifact like Epic, Theme ... . Stories can be hierarchical, that is a parent story can have child stories. Stories may have Tasks to break them up into smaller units of work.
Story.Risk | Risk of the Story
Story.Status | The status of this story
Story.StoryType | The type of the story according to agile terminology.
Story.StoryValue | Value of the Story
Story.StreamState | The Info Stream State of the Story
Story.Type | Type meta-data (schema) for Story object instances.
Story.Type.AcceptanceCriteriaProperty | The property type of the AcceptanceCriteria property.
Story.Type.EstimatedPointsProperty | The property type of the Estimated Points property.
Story.Type.GeneralProperty | The property type of the General property.
Story.Type.IncomingStreamProperty | The Property Type of the IncomingStream Property
Story.Type.IsCarriedOverProperty | The property type of the IsLeaf property
Story.Type.NotesProperty | The property type of the Notes property.
Story.Type.PlanProperty | The property type of the Plan property
Story.Type.PropertyCollection | The PropertyCollection of a Story item.
Story.Type.RankProperty | The property type of the Rank property.
Story.Type.RiskProperty | The property type of the Risk property.
Story.Type.SponsorProperty | The property type of the Sponsor property.
Story.Type.SprintProperty | The property type of the Sprint property
Story.Type.StatusProperty | The property type of the Status property.
Story.Type.StoryIDProperty | The property type of the StoryID property
Story.Type.StoryOrderProperty | The property type of the StoryOrder property.
Story.Type.StoryTypeProperty | The property type of the StoryType property.
Story.Type.StoryValueProperty | The property type of the StoryValue property.
Story.Type.StreamStateProperty | The property type of the StreamState property.
Story.Type.TargetReleasesProperty | The property type of the TargetReleases property.
Story.WebCacheStory | Item accessor for cached SDK Story items contained objects are obtained from the artifact cache
SupportedFeatures | The SupportedFeatures class contains a number of methods that report whether or not a particular feature is available for a StarTeam server.
Swimlane | A Swimlane is a path in Kanban.
Swimlane.Type | Type meta-data (schema) for Swimlane object instances.
Swimlane.Type.AgeLimitProperty | The property type of the AgeLimit property.
Swimlane.Type.ColorProperty | The property type of the Color property
Swimlane.Type.EnabledProperty | The property type of the EnforceAge property.
Swimlane.Type.PropertyCollection | The PropertyCollection of a Swimlane
Swimlane.Type.ScheduleStatusProperty | The property type of the ScheduleStatus property
Swimlane.Type.WorkInProgressProperty | The property type of the WorkInProgress property
Swimlane.WebCacheSwimlane | Item accessor for cached SDK Swimlane items contained objects are obtained from the artifact cache
SystemPolicy | Server wide Policies applied
SystemPolicy.WebCacheSystemPolicy | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
Task | Represents a StarTeam Task item.
Task.Constraint | Task Constraint Type
Task.LifeCycleType | Task LifeCycleType
Task.Origin | Task Origin
Task.Priority | Priority of the Task
Task.ProcessUsage | Indicates the type of operation that created a given process task and its associated process links.
Task.Status | Status of the Task
Task.TaskType | Task Type
Task.Type | Type meta-data (schema) for Task object instances
Task.Type.ActualFinishProperty | The property type of the Actual Finish property.
Task.Type.ActualHoursProperty | The property type of the Actual Hours property.
Task.Type.ActualStartProperty | The property type of the Actual Start property.
Task.Type.AttentionNotesProperty | The property type of the Attention Notes property.
Task.Type.BlockedProperty | The property type of the Blocked property.
Task.Type.ChildrenCountProperty | The property type of the Task Children Count property.
Task.Type.ConstraintDateProperty | The property type of the Constraint Date property.
Task.Type.ConstraintProperty | The property type of the Constraint Type property.
Task.Type.DescriptionProperty | The property type of the Description property.
Task.Type.DurationProperty | The property type of the Duration property.
Task.Type.EstimatedFinishProperty | The property type of the EstimatedFinish property.
Task.Type.EstimatedFinishVarianceProperty | The property type of the Estimated Finish Variance property.
Task.Type.EstimatedHoursProperty | The property type of the Estimated Hours property.
Task.Type.EstimatedHoursVarianceProperty | The property type of the EstimatedHoursVariance property
Task.Type.EstimatedStartProperty | The property type of the Estimated Start property.
Task.Type.EstimatedStartVarianceProperty | The property type of the Estimated Start Variance property.
Task.Type.GUIDProperty | The property type of the GUID property.
Task.Type.IsMyTaskProperty | The property type of the Is My Task property.
Task.Type.IsReplicatedProperty | The property type of the Is Replicated property.
Task.Type.LifeCycleTypeProperty | The property type of the Lifecycle property.
Task.Type.MilestoneProperty | The property type of the MileStone property.
Task.Type.MSProjectFileNameProperty | The property type of the MS Project File Name property.
Task.Type.MSProjectLastUpdateProperty | The property type of the MS Project Last Update property.
Task.Type.NameProperty | The property type of the Name property.
Task.Type.NeedsAttentionProperty | The property type of the Needs Attention property.
Task.Type.NotesProperty | The property type of the Notes property.
Task.Type.NumberProperty | The property type of the Number property.
Task.Type.OrderProperty | The property type of the Order property
Task.Type.OriginProperty | The property type of the Origin property.
Task.Type.ParentTaskIDProperty | The property type of the Parent Task ID property.
Task.Type.PercentCompleteProperty | The property type of the Percent Complete property.
Task.Type.PriorityProperty | The property type of the Priority property.
Task.Type.ProcessUsageProperty | The property type of the ProcessUsage property
Task.Type.PropertyCollection | The PropertyCollection of a Task
Task.Type.ResourceCountProperty | The property type of the Resource Count property.
Task.Type.ResourceNamesProperty | The property type of the Resource Names property.
Task.Type.ResourcesProperty | The property type of the Resources property.
Task.Type.ResponsibilityProperty | The property type of the Responsibility property.
Task.Type.StatusProperty | The property type of the Status property.
Task.Type.StoryProperty | The property type of the Story property
Task.Type.TaskTypeProperty | The property type of the Task Type property.
Task.Type.UniqueIDProperty | The property type of the Unique ID property.
Task.Type.WBSCodeProperty | The property type of the WBS Code property.
Task.Type.WorkDependencyLastUpdateProperty | The property type of the WorkDependency Last Update property.
Task.Type.WorkRecordCountProperty | The property type of the WorkRecord Count property.
Task.WebCacheTask | Item accessor for cached SDK Tasks contained objects are obtained from the artifact cache
TaskDependency | This is a class representing a dependency between two tasks.
TaskDependency.PredecessorType | Task Predecessor type
TaskDependency.Type | The Type of TaskDependency.
TaskDependency.Type.LagTimeProperty | The property type of the Lag Time property.
TaskDependency.Type.PredecessorProperty | The property type of the Predecessor property.
TaskDependency.Type.PredecessorTypeProperty | The property type of the Predecessor Type property.
TaskDependency.Type.PropertyCollection | The PropertyCollection of a Task Dependency.
TaskDependency.Type.TaskProperty | The property type of the Task property.
TaskDependency.WebCacheTaskDependency | Item accessor for cached SDK Task Dependencies contained objects are obtained from the artifact cache
Test | A Test is a basic unit of software testing.
Test.Type | Type meta-data (schema) for Test object instances.
Test.Type.DescriptionProperty | The property type of the RichDescription property.
Test.Type.PathProperty | The property type of the TestID property
Test.Type.PropertyCollection | The PropertyCollection of a Test
Test.Type.TestIDProperty | The property type of the TestID property
Test.WebCacheTest | Item accessor for cached SDK Test items contained objects are obtained from the artifact cache
TestRun | A TestRunRun is the state of a Test after execution.
TestRun.Type | Type meta-data (schema) for TestRun object instances.
TestRun.Type.BuildProperty | The property type of the Build property
TestRun.Type.DescriptionProperty | The property type of the RichDescription property.
TestRun.Type.DurationProperty | The property type of the Duration property.
TestRun.Type.ExecutedAtProperty | The property type of the Created Time property.
TestRun.Type.ExecutedByProperty | The property type of the ExecutedBy property
TestRun.Type.IsBlockedProperty | The property type of the IsBlocked property.
TestRun.Type.ProductProperty | The property type of the Product property
TestRun.Type.PropertyCollection | The PropertyCollection of a TestRun
TestRun.Type.StatusProperty | The property type of the Status property
TestRun.Type.StatusReasonProperty | The property type of the StatusReason property
TestRun.Type.TestNameProperty | The property type of the TestName property
TestRun.Type.TestRunIDProperty | The property type of the TestRunID property
TestRun.Type.TestVersionProperty | The property type of the TestVersion property
TestRun.WebCacheTestRun | Item accessor for cached SDK TestRun items contained objects are obtained from the artifact cache
TextProperty

A base interface for all properties of type Text

TextProperty.WebCacheTextProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
TimeSpanProperty

Description: Represents a TimeSpan Property

TimeSpanProperty.WebCacheTimeSpanProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
Topic | Represents a StarTeam Topic.
Topic.Priority | Priority of the Topic
Topic.Status | Status of the Topic
Topic.TopicType | Type of the Topic
Topic.Type | Type meta-data (schema) for Topic object instances.
Topic.Type.AmIRecipientProperty | The property type of the AmIRecipient property
Topic.Type.ChildrenCountProperty | The property type of the ChildrenCount property
Topic.Type.ContextRangeProperty | The property type of the ContextRange property
Topic.Type.ParentTopicIDProperty | The property type of the ParentTopicID property
Topic.Type.PriorityProperty | The property type of the Priority property
Topic.Type.PropertyCollection | Property Collection for Topic
Topic.Type.RecipientCountProperty | The property type of the RecipientCount property
Topic.Type.RecipientNamesProperty | The property type of the RecipientNames property
Topic.Type.RecipientsProperty | The property type of the Recipients property
Topic.Type.StatusProperty | The property type of the Status property.
Topic.Type.TaxonomyProperty | The Property Type of the Taxonomy Property
Topic.Type.TitleProperty | The property type of the Title property
Topic.Type.TopicNumberProperty | The property type of the TopicNumber property
Topic.Type.TopicTypeProperty | The property type of the TopicType property
Topic.Type.UserDislikesProperty | The property type of the UserDislikes property
Topic.Type.UserLikesProperty | The property type of the UserLikes property
Topic.WebCacheTopic | Item accessor for cached SDK Topic items contained objects are obtained from the artifact cache
Trace | A typed relationship between two artifacts.
Trace.Status | The Status of a Trace
Trace.TraceType | Trace Type
Trace.Type | The type of the Trace
Trace.Type.IsSuspectProperty | The property type of the IsSuspect property
Trace.Type.OrderProperty | The property type of the Order property.
Trace.Type.PropertyCollection | The property collection of the Trace type
Trace.Type.SourceVersionsProperty | The property type of the SourceVersions property.
Trace.Type.StatusProperty | The property type of the Status property
Trace.Type.TraceTypeProperty | The property type of the TraceType property
Trace.WebCacheTrace | Trace accessor for cached SDK Traces contained objects are obtained from the artifact cache
TraceCollection | Caches Traces for a given view. Also provides a Trace query mechanism.
TraceFinder

Searches for Traces across StarTeam servers.

Searches all servers in the application's Servers collection. If two server objects in the collection refer to the same underlying repository, only one of them is searched.
TraceFinder.Direction | Allows a set of traces to be filtered by direction.
TraceFinder.PinType | Allows a set of traces to be filtered by revision. Supported only for endpoints that reference StarTeam items.
TrackedObject | A TrackedObject is a LiveObject that keeps track of the date/time it was last modified, and the ID of the user who modified it.
TrackedObject.Type | The Type for TrackedObject
TrackedObject.Type.EndModifiedTimeProperty | The property type of the End Modified Time property.
TrackedObject.Type.FolderPathProperty | The property type of the Folder Path property.
TrackedObject.Type.ModifiedByProperty | The property type of the Modified By property.
TrackedObject.Type.ModifiedTimeProperty | The property type of the Modified Time property.
TrackedObject.Type.ParentFolderNameProperty | The property type of the Parent Folder Name property.
TrackedObject.Type.TransactionIDProperty | The property type of the Transaction ID property.
TrackedObject.WebCacheTrackedObject | Tracked Object accessor for cached SDK Objects contained objects are obtained from the artifact cache
Transaction | a Transaction is a logical unit of work on the StarTeam Server. It may comprise of a series of operations to add, modify or delete data. If these operations are executed in a transaction, they are committed together, i.e. if one of them fails, then all of them are rolled back.
Transaction.WebCacheTransaction | Transaction accessor for cached SDK Transactions contained objects are obtained from the artifact cache
Translations | The Translations class defines the possible localized translations of a particular resource. There is the notion of a default translation which should be used when no translation exists for a particular language. In addition to the default there may be any number of specific localizations defined on a per-locale basis.
TreeItem | A type of item with children.
TreeItem.MoSCoW | The MoSCoW value for a compliant TreeItem Type
TreeItem.Type | The type of the TreeItem
TreeItem.Type.ExternalTestIDProperty | The property type of the ExternalTestID property
TreeItem.Type.ExternalTestProjectURLProperty | The property type of the ExternalTestProjectURL property
TreeItem.Type.ExternalTestURLProperty | The property type of the ExternalTestURL property
TreeItem.Type.IsLeafProperty | The property type of the IsLeaf property
TreeItem.Type.MoSCoWProperty | The property type of the MoSCoW property.
TreeItem.Type.ParentIDProperty | The property type of the Parent ID property.
TreeItem.Type.RichDescriptionProperty | The property type of the RichDescription property.
TreeItem.Type.WebCacheTreeItemType | Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.
TreeItem.WebCacheTreeItem | TreeItem accessor for cached SDK Items contained objects are obtained from the artifact cache
Type | Information describing certain StarTeam object types.
Type.MetaData | server stored meta data available for a Type. This definition is only useful for application developers who intend to subclass items and properties to create extended type definitions
Type.WebCacheType | Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.
TypeCollection | A Collection of Types supported by the specified server
TypedResource | This is a parent interface for many instances of StarTeam types (e.g. File, ChangeRequest). The interface describes objects that have property/value pairs. Each TypedResource is associated with the properties from a Type object. A TypedResource has a constraint that only valid Type properties may be used for set/get and that type checking for set will be enforced.
TypedResource.BranchState | The branch state of a versioned object.
TypedResource.Type | The TypedResource Type
TypedResource.Type.BranchStateProperty | The property type of the Branch State property.
TypedResource.Type.IDProperty | The property type of the ID property.
TypedResource.Type.ProjectProperty | The property type of the Project property.
TypedResource.Type.ViewProperty | The property type of the View property.
User | Represents a StarTeam User. Some of the information is accessible only to users with appropriate permissions. Applications which require only a subset of user data should use {@link com.starteam.Server#getUsers()}.Applications which require the complete account information for all users should use {@link com.starteam.ServerAdministration#getUsers()}. The logged in user however needs to have permission {@link com.starteam.Permission#SERVER_ADMIN_USER_ACCOUNTS} granted for accessing the complete user account information.
User.DayOfWeek | The day of week
User.GeographicTerritory | The accessible territory for the logged in User Account.
User.License | The current license .
User.LoginHistory | A history of User logins introduced with the 12.0 server release
User.LogOnPolicy | The current logon access policy of the User Account.
User.Status | The current status of the User Account.
User.Type | The Type of the User
User.Type.AccessRestrictionProperty | The property type of the Access Restriction property.
User.Type.AddressProperty | The property type of the Address property.
User.Type.DirectoryServiceIDProperty | The property type of the Last Logout Time property.
User.Type.DistinguishedNameProperty | The property type of the Distinguished Name property.
User.Type.EmailAddressProperty | The property type of the Email Address property.
User.Type.FavoriteProjectsProperty | The property type of the Favorite Projects property.
User.Type.FaxProperty | The property type of the Fax property.
User.Type.FridayAMProperty | The property type of the Friday AM property.
User.Type.FridayPMProperty | The property type of the Friday PM property.
User.Type.IsDirectoryManagedProperty | The property type of the Is Active Directory Managed property.
User.Type.LastLogoutTimeProperty | The property type of the Last Logout Time property.
User.Type.LastPasswordChangeTimeProperty | The property type of the Last Password Change Time property.
User.Type.LastWebLogoutTimeProperty | The property type of the Last Web Logout Time property.
User.Type.LicenseProperty | The property type of the License property.
User.Type.LicenseTypeProperty | The property type of the License Type property.
User.Type.LockOutTimeProperty | The property type of the Lock Out Time property.
User.Type.LoginNameProperty | The property type of the Login Name property.
User.Type.MondayAMProperty | The property type of the Monday AM property.
User.Type.MondayPMProperty | The property type of the Monday PM property.
User.Type.NameProperty | The property type of the Name property.
User.Type.PagerProperty | The property type of the Pager property.
User.Type.PasswordProperty | The property type of the Password property.
User.Type.PhoneProperty | The property type of the Phone property.
User.Type.PropertyCollection | The property collection of the User type
User.Type.ReturnEmailAddressProperty | The property type of the Email Address property.
User.Type.SaturdayAMProperty | The property type of the Saturday AM property.
User.Type.SaturdayPMProperty | The property type of the Saturday PM property.
User.Type.StatusProperty | The property type of the Status property.
User.Type.SundayAMProperty | The property type of the Sunday AM property.
User.Type.SundayPMProperty | The property type of the Sunday PM property.
User.Type.TenantProperty
User.Type.TerritoryProperty | The property type of the Territory property.
User.Type.ThursdayAMProperty | The property type of the Thursday AM property.
User.Type.ThursdayPMProperty | The property type of the Thursday PM property.
User.Type.TimeZoneShiftProperty | The property type of the Time Zone Shift property.
User.Type.TuesdayAMProperty | The property type of the Tuesday AM property.
User.Type.TuesdayPMProperty | The property type of the Tuesday PM property.
User.Type.UserImageProperty | The property type of the Picture property.
User.Type.VoiceMailProperty | The property type of the Voice Mail property.
User.Type.WednesdayAMProperty | The property type of the Wednesday AM property.
User.Type.WednesdayPMProperty | The property type of the Wednesday PM property.
User.WebCacheUser | User accessor for cached SDK Users contained objects are obtained from the artifact cache
VectorProperty | A definition for Vector Properties; subclasses include Arrays, Text etc
VectorProperty.WebCacheVectorProperty | Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.
VersionedObject | A VersionedObject is a TrackedObject that maintains a revision history.
VersionedObject.Type | The Type for VersionedObject
VersionedObject.Type.CommentIDProperty | The property type of the Comment ID property.
VersionedObject.Type.RevisionFlagsProperty | The property type of the Revision Flags property.
VersionedObject.Type.RevisionNumberProperty | The property type of the Revision Number property.
VersionedObject.Type.ShortCommentProperty | The property type of the Short Comment property.
VersionedObject.WebCacheVersionedObject | Tracked Object accessor for cached SDK Objects contained objects are obtained from the artifact cache
View | Represents a StarTeam View.
View.Type | Type for view
View.Type.BaseConfigurationDataProperty | The property type of the BaseConfigurationData property
View.Type.BaseConfigurationTypeProperty | The property type of the BaseConfigurationType property
View.Type.CloneTimeProperty | The property type of the Clone Time property This property is available starting from the 16.3 release of the starteam server
View.Type.EndDateProperty | The property type of the End Date property. This property is available starting from the 12.5 release of the Starteam server.
View.Type.ExcludedGroupsProperty | The property type of the Excluded Groups property
View.Type.ExcludedUsersProperty | The property type of the Excluded Users property
View.Type.IsDeleteCompleteProperty | The property type of the IsDeleteComplete property
View.Type.IsPurgedProperty | The property type of the IsPurged property
View.Type.IsVCMCodeReviewRequiredProperty | The property type of the Require VCM Code Review property
View.Type.IsVCMCommitEnforcedProperty | The property type of the Enforce VCM Commits property
View.Type.ParentViewProperty | The property type of the ParentView property
View.Type.PromotionStateProperty | The property type of the PromotionState property
View.Type.PropertyCollection | The property collection of the View type
View.Type.ResolvedViewProperty | The property type of the ResolvedView property
View.Type.RootFolderIDProperty | The property type of the RootFolderID property
View.Type.ShareFlagsProperty | The property type of the ShareFlags property
View.Type.StartDateProperty | The property type of the Start Date property.. This property is available starting from the 12.5 release of the Starteam server.
View.Type.TenantProperty
View.Type.TypeProperty | The property type of the Type property.
View.Type.WorkspaceModifiedTimeProperty | The property type of the Workspace Modified Time property This property is available starting from the 16.0 release of the starteam server
View.ViewType | Defines the Types of a View This property is new to 12.0+ servers
View.WebCacheView | View accessor for cached SDK views contained objects are obtained from the artifact cache
ViewConfiguration | A class that represents the possible configuration states for a View. A StarTeam View can be in one of four different configurations: Current: all items in the view are the most recent or "tip" versions, Label: all items reference the version with the specified label attached, Time: all items reference the version that was tip as of some time, Promotion: like a label-based view but with respect to some promotion state.
ViewConfiguration.WebCacheViewConfiguration | A class that represents the possible configuration states for a WebCacheView. A StarTeam WebCacheView can be in one of four different configurations: Current: all items in the view are the most recent or "tip" versions, Label: all items reference the version with the specified label attached, Time: all items reference the version that was tip as of some time, Promotion: like a label-based view but with respect to some promotion state.
ViewConfigurationDiffer

Used to compare two configurations of a given view, triggering FolderUpdateEvents, ItemUpdateEvents and ViewMemberUpdateEvents describing the changes detected between the two.

Events are triggered only for differences detectable by comparing the two view configurations. For example, if an item was added sometime after the time represented by the first configuration, and then removed sometime before the time represented by the second configuration, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, and for some types of view configurations, it is not currently possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.
ViewMember | A VersionedObject that lives in a View.
ViewMember.LockType | A representation of the available lock types.
ViewMember.MyLock | The set of enumerations for a Locked View Member
ViewMember.ShareState | The enumeration of all Share States
ViewMember.Type | The type of the View
ViewMember.Type.AttachmentCountProperty | The property type of the AttachmentCount property
ViewMember.Type.AttachmentIDsProperty | The property type of the AttachmentIDs property
ViewMember.Type.AttachmentNamesProperty | The property type of the AttachmentNames property
ViewMember.Type.CommentProperty | The property type of the Comment property
ViewMember.Type.ConfigurationTimeProperty | The property type of the ConfigurationTime property
ViewMember.Type.DotNotationProperty | The property type of the DotNotation property
ViewMember.Type.ExclusiveLockerProperty | The property type of the ExclusiveLocker property
ViewMember.Type.ExternalIDProperty | The property type of the ExternalIDProperty property
ViewMember.Type.ExternalURLProperty | The property type of the ExternalURLProperty property
ViewMember.Type.FlaggedByUsersProperty | The property type of the FlaggedByUsers property
ViewMember.Type.IsBookmarkedProperty | The property type of the IsBookmarked property
ViewMember.Type.IsBranchOnChangeProperty | The property type of the IsBranchOnChange property
ViewMember.Type.IsReadOnlyProperty | The property type of the IsReadOnly property
ViewMember.Type.IsUnreadProperty | The property type of the IsUnread property
ViewMember.Type.ItemDeletedByProperty | The property type of the ItemDeletedBy property
ViewMember.Type.ItemDeletedTimeProperty | The property type of the ItemDeletedTime property
ViewMember.Type.MyLockProperty | The property type of the MyLock property
ViewMember.Type.NonExclusiveLockersProperty | The property type of the NonExclusiveLocker property
ViewMember.Type.ParentBranchLengthProperty | The property type of the ParentBranchLength property
ViewMember.Type.ParentBranchRevisionProperty | The property type of the ParentBranchRevision property
ViewMember.Type.ParentObjectIDProperty | The property type of the ParentObjectID property
ViewMember.Type.PropertyCollection | Property Collection for ViewMember
ViewMember.Type.ResponsibilityProperty | The property type of the Responsibility property.
ViewMember.Type.RootObjectIDProperty | The property type of the RootObjectID property
ViewMember.Type.ShareStateProperty | The property type of the ShareState property
ViewMember.Type.UnreadByUsersProperty | The property type of the UnreadByUsers property
ViewMember.Type.ViewMemberIDProperty | The property type of the ViewMember ID property.
ViewMember.Type.WebCacheViewMemberType | Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.
ViewMember.WebCacheViewMember | ViewMember accessor for cached SDK ViewMembers contained objects are obtained from the artifact cache
ViewMemberBehavior | Represents the behavior of a ViewMember.
ViewMemberCollection | A Collection of ViewMembers. The collection can be built up from different types of ViewMembers, or all instances of the same type.
ViewMemberCollection.BehaviorContainer | A BehaviorContainer can be used to query for ViewMemberBehavior on the underlying collection of ViewMembers. It may also be used to assign Behaviors to a set of ViewMembers. The ViewMembers are queried, retrieved and assigned in bulk. The level of indirection is a requirement of the SDK's contractual obligation, namely, to expose only primitives, native SDK objects, and arrays of objects.
ViewMemberCollection.HistoryContainer | a query for History on the underlying collection of ViewMembers returns a collection of ViewMemberCollections. The collection of historical revisions for any individual ViewMember is accessed by member through this History object. The level of indirection is a requirement of the SDK's contractual obligation, namely, to expose only Java primitives, native SDK objects, and arrays of objects. Note also that a query for history on a server that does not support bulk queries will succeed, but at the cost of several non-bulk queries
ViewMemberCollection.WebCacheViewMemberCollection | A collection to perform transacted operations on web cache view members. Add web cache view members in various states for creation, update, removal, etc in the repository. Call save to actually perform the operations in explicit (or implicit) transactions, as the case may be. Note that the same viewmember should not be added to the collection through multiple api's or through the same api twice. for example, calling {@link #move(com.starteam.Item.WebCacheItem, com.starteam.Folder.WebCacheFolder)} and {@link #update(WebCacheViewMember)} on the same viewmember will throw an exception. by default, a viewmember is updated as part of a move.
ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer | a query for History on an array of WebCacheViewMembers returns a collection of WebCacheViewMember[]'s. The collection of historical revisions for any individual WebCacheViewMember is accessed by member through this HistoryContainer object. The level of indirection is a requirement of the SDK's contractual obligation, namely, to expose only Java primitives, native SDK objects, and arrays of objects. Note also that a query for history on a server that does not support bulk queries will succeed, but at the cost of several non-bulk queries
ViewMemberListManager | Generates and manages a list of ViewMembers. All ViewMembers in the list have a given type. Items are generated from a list of folders determined by a FolderListManager, (non item) ViewMembers are generated from the view The ViewMember list can be filtered, sorted, refreshed, queried, and so on. ViewMembers are retrieved via getViewMembers(), which is optimized to do as little work as possible. For example, if only the sort order has changed since the last time the ViewMember list was retrieved, then the existing ViewMembers in the list are simply resorted.
ViewMemberListManager.GroupNode | Describes a group of objects that may be a subgroup of a larger, indexable group. Maintains a range mapping into the underlying ordered collection. Each Node may be in an expanded or collapsed state. Note that it is the client's responsibility to ensure valid index ranges relative to the underlying collection.
ViewMemberRevision | A ViewMemberRevision represents a View member level revision of an item. Such revisions are created when one modifies the view level properties of a particular share of the item. These would be operations like: 1. changing the item branch behavior 2. changing the item configuration 3. branching the item 4. moving the item
ViewMemberRevision.Type | The type of the ViewMemberRevision
ViewMemberRevision.Type.BranchFlagProperty | The property type of the BranchFlag property
ViewMemberRevision.Type.CreatedByProperty | The property type of the CreatedBy property
ViewMemberRevision.Type.CreatedTimeProperty | The property type of the CreatedTime property
ViewMemberRevision.Type.ObjectIDProperty | The property type of the ObjectID property
ViewMemberRevision.Type.ObjectTimeProperty | The property type of the ObjectTime property
ViewMemberRevision.Type.ParentFolderProperty | The property type of the ParentFolder property
ViewMemberRevision.Type.ParentShareProperty | The property type of the ParentShare property
ViewMemberRevision.Type.PropertyCollection | The property collection of the ViewMemberRevision type
ViewMemberRevision.WebCacheViewMemberRevision | A ViewMemberRevision represents a View member level revision of an item. Such revisions are created when one modifies the view level properties of a particular share of the item. These would be operations like: 1. changing the item branch behavior 2. changing the item configuration 3. branching the item 4. moving the item
ViewPollingAgent

Used to periodically poll a given view for recent changes, triggering FolderUpdateEvents, ItemUpdateEvents and ViewMemberUpdateEvents describing the changes detected since the last poll.

Events are triggered only for differences detectable across the polling interval. For example, if an item is added then removed without an intervening refresh, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, it is not possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.

There are two basic ways to use a ViewPollingAgent. The first way is to create one and keep it around for a long time, periodically calling refresh() to trigger events. This is generally faster than creating a new ViewPollingAgent for each refresh(). However, the ViewPollingAgent consumes memory while it is in use.

The second way is to create a new ViewPollingAgent at each polling interval, call refresh() once to trigger events, and save the time returned by refresh() to use later when creating a ViewPollingAgent for the next poll. This is slower, but uses less memory between polls.
WhiteBoard | A WhiteBoard is a collection of concepts.
WhiteBoard.Type | Type meta-data (schema) for WhiteBoard object instances.
WhiteBoard.Type.ColorProperty | The property type of the Color property
WhiteBoard.Type.PropertyCollection | The PropertyCollection of a WhiteBoard
WhiteBoard.Type.WhiteBoardIDProperty | The property type of the WhiteboardID property
WhiteBoard.WebCacheWhiteBoard | Item accessor for cached SDK WhiteBoard items contained objects are obtained from the artifact cache
Workflow | Workflow specifies a set of states (steps) and state transitions Workflow also specifies a set of rules Some rules are relevant in all states. others are relevant in a particular state Workflow is described in .xml files in the starflow extensions project
Workflow.Step | A Step represents a State in the Workflow State Machine Each step represents an EnmeratedValue from the legal set for the workflow definition's EnumeratedProperty
Workflow.Step.WebCacheStep | A Step Accessor for the Web Cache Object Model
Workflow.WebCacheWorkflow | A Workflow Accessor for the Web Cache Object Model
WorkRecord Record of a period of work expended for a task.
  1. Work records are mutable and versioned, but there is no way to identify a version of a work record since the server does not send this information.
  2. The work record contains the ID of the task it is associated with, but not the version number, so there is no way to deduce the task version it is associated with.
  3. The task ID is a mutable property, but the semantics of changing it is unknown.
WorkRecord.Type | The type of the WorkRecord
WorkRecord.Type.CommentProperty | The property type of the Comment property
WorkRecord.Type.ParentTaskProperty | The property type of the ParentTask property
WorkRecord.Type.PerformedByProperty | The property type of the PerformedBy property
WorkRecord.Type.PropertyCollection | The property collection of the WorkRecord type
WorkRecord.Type.TimeRemainingProperty | The property type of the TimeRemaining property
WorkRecord.Type.TimeWorkedProperty | The property type of the TimeWorked property
WorkRecord.Type.WorkedOnProperty | The property type of the WorkedOn property
WorkRecord.WebCacheWorkRecord | Item accessor for cached SDK WorkRecords contained objects are obtained from the artifact cache

Interfaces

Interface | Description
ArtifactCacheManager.Identifiable |
ArtifactCacheManager.Nameable | An object (artifact) that can provide a name via a name property.
ArtifactCacheManager.Securable | An object that can be secured in the repository. This is a marker interface for WebCache objects that 'wrap' instances of ISecurable
ArtifactCacheManager.SecurableContainer | A container in the repository that can hold secured objects of a given type. This is a marker interface for WebCache objects that 'wrap' instances of ISecurableContainer
CacheService | The CacheService is implemented by StarTeam objects that support caching data locally The data will typically have been fetched from the server, and will probably aggregate across multiple contained object instances. Important Note: This interface is not intended to be implemented by client applications. We reserve the right to add methods in the future. Applications that implement this interface may not be compatible with future versions of the StarTeam SDK.
Change.ScmChangeAtom |
ChangePackage.ScmChangeSet |
CheckoutOptions.ContentFilter | Allows an application to hook into the checkout process at a low level. getOutputStream() is called for each file as it is checked out. OutputStream is the stream where content is written; the application may wrap this stream to transform content as it sees fit.
File.Digest |
File.Keyword | A Keyword object that encapsulates information about a File keyword. When a file is added, checked-in or checked-out of the repository keyword expansion may be applied to the contents of the file. For example, an occurrence of $Author$ in a file might be be replaced with $Author: Fred$ upon checkout. NOTE: This interface is not intended to be implemented by client applications.
File.Revision |
File.WorkspaceSync | The WorkspaceSync interface specifies the pairing of the two important pieces of information needed to know what is on a user's local disk: Revision and Digest. This information is needed to compute a File's status.
ISecurable |
ISecurableContainer |
LocalFileSystemPropertyProvider | This interface provides a mechanism for an SDK application to offer its own instance of Local File System Properties. This interface should be used with caution, if at all. All methods of this interface must be correctly implemented, since the methods on this interface override the methods of the File Object, when set
Lockable |
LockableObject |
Project.ScmSubRepository |
View.ScmBranch |

Copyright 2019 Micro Focus or one of its affiliates. All rights reserved.


AccessRightsManager Class

A generalized access rights cache for all types of StarTeam artifacts and Containers For optimized results, the cache should be pre-loaded with ACLs for each and every relevant artifact (or container)

Access rights information is fetched from the server as necessary, using bulk queries to minimize server traffic, and cached to improve performance of subsequent access tests. From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes and helps optimizing server calls. All access tests are in-memory operations This class is thread-safe and supports a multi reader single writer concurrency pattern

For a list of all members of this type, see AccessRightsManager Members.

System.Object
AccessRightsManager

public class AccessRightsManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

AccessRightsManager Members | StarTeam Namespace

Copyright 2019 Micro Focus or one of its affiliates. All rights reserved.

Generated from assembly StarTeam [17.0.1.34]


AccessRightsManager Members

AccessRightsManager overview

Public Instance Constructors

AccessRightsManager Constructor Creates a new access rights manager for the given server.

Public Instance Methods

AccessTest | Overloaded. Performs an access test against the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.
Discard | Discards cached access rights information. Access rights information will be fetched from the server as needed.
Equals | Delegate Equals() to com.starteam.AccessRightsManager.
GetEffectiveRights | Overloaded. Gets the effective access control list for the given securable object. The effective access control list completely encompasses all information used by the server to perform an access test for the given object. This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.
GetHashCode | Delegate GetHashCode() to com.starteam.AccessRightsManager.
GetRights | Overloaded. Returns the Access Control List for this securable object. The access control list is cached, and subsequent calls will be fetched from the cache
GetType (inherited from Object) | Gets the Type of the current instance.
IsAccessGranted | Overloaded. Determines whether or not the given principal is granted the given permissions to the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.
IsCached | Overloaded. returns true if ACLs for the specified securable have already been cached An access rights test against a securable that has not been cached will still succeed since the manager will issue server calls in the content of the test However, the resultant operation would be fairly expensive
Populate | Overloaded. Populates the access control list for this securable The cache is maintained in memory until cleared by a call to discard
PopulateAll | Populates the access control lists for all the members of this collections, parent containers if any, and effective access control lists for these members and their parent containers
Refresh | Overloaded. Refreshes cached access rights information to reflect recent changes to the server. From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0, since access rights were not MPX enabled, a call to refresh issues server calls to update all the access rights in this manager However, most of these calls are issued in bulk
Remove | Overloaded. Remove a securable from this access rights manager Typically, applications will remove securables that have been deleted
ToString | Delegate ToString() to com.starteam.AccessRightsManager.

See Also

AccessRightsManager Class | StarTeam Namespace


AccessRightsManager Constructor

Creates a new access rights manager for the given server.

public AccessRightsManager(
Server s
);

Parameters

s
The server whose access rights are to be managed.

See Also

AccessRightsManager Class | StarTeam Namespace


AccessRightsManager Methods

The methods of the AccessRightsManager class are listed below. For a complete list of AccessRightsManager class members, see the AccessRightsManager Members topic.

Public Instance Methods

AccessTest | Overloaded. Performs an access test against the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.
Discard | Discards cached access rights information. Access rights information will be fetched from the server as needed.
Equals | Delegate Equals() to com.starteam.AccessRightsManager.
GetEffectiveRights | Overloaded. Gets the effective access control list for the given securable object. The effective access control list completely encompasses all information used by the server to perform an access test for the given object. This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.
GetHashCode | Delegate GetHashCode() to com.starteam.AccessRightsManager.
GetRights | Overloaded. Returns the Access Control List for this securable object. The access control list is cached, and subsequent calls will be fetched from the cache
GetType (inherited from Object) | Gets the Type of the current instance.
IsAccessGranted | Overloaded. Determines whether or not the given principal is granted the given permissions to the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.
IsCached | Overloaded. returns true if ACLs for the specified securable have already been cached An access rights test against a securable that has not been cached will still succeed since the manager will issue server calls in the content of the test However, the resultant operation would be fairly expensive
Populate | Overloaded. Populates the access control list for this securable The cache is maintained in memory until cleared by a call to discard
PopulateAll | Populates the access control lists for all the members of this collections, parent containers if any, and effective access control lists for these members and their parent containers
Refresh | Overloaded. Refreshes cached access rights information to reflect recent changes to the server. From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0, since access rights were not MPX enabled, a call to refresh issues server calls to update all the access rights in this manager However, most of these calls are issued in bulk
Remove | Overloaded. Remove a securable from this access rights manager Typically, applications will remove securables that have been deleted
ToString | Delegate ToString() to com.starteam.AccessRightsManager.

See Also

AccessRightsManager Class | StarTeam Namespace


AccessTest Method

Borland StarTeam SDK for .NET

AccessRightsManager.AccessTest Method

Determines whether or not the given principal is granted the given permissions to a securable object with the given access control list.

Overload List

Determines whether or not the given principal is granted the given permissions to a securable object with the given access control list.

public virtual AccessTestResults AccessTest(Principal,PermissionCollection,EffectiveACE[]);

Performs an access test against the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.

public virtual AccessTestResults AccessTest(Principal,PermissionCollection,ISecurable);

Performs an access test against the given securable container. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.

public virtual AccessTestResults AccessTest(Principal,PermissionCollection,ISecurableContainer,Type);

See Also

AccessRightsManager Class | StarTeam Namespace | EffectiveACE | AccessTestResults | getEffectiveRights


AccessRightsManager.AccessTest Method (Principal, PermissionCollection, EffectiveACE[])

Determines whether or not the given principal is granted the given permissions to a securable object with the given access control list.

public virtual AccessTestResults AccessTest(
Principal principal,
PermissionCollection permissions,
EffectiveACE[] acl
);

Parameters

principal
The principal for which the access test is performed.
permissions
The set of permission flags to be tested.
acl
The access control list against which the test is performed.

Return Value

A detailed explanation of the results of the access test.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.AccessTest Overload List | EffectiveACE | AccessTestResults | getEffectiveRights


AccessRightsManager.AccessTest Method (Principal, PermissionCollection, ISecurable)

Performs an access test against the given securable object.

Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.

public virtual AccessTestResults AccessTest(
Principal principal,
PermissionCollection permissions,
ISecurable obj
);

Parameters

principal
The principalID of the principal for which the access test is performed.
permissions
The set of permission flags to be tested.
obj
The securable object against which the test is performed.

Return Value

A detailed explanation of the results of the access test.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.AccessTest Overload List | AccessTestResults | getEffectiveRights | accessTest


AccessRightsManager.AccessTest Method (Principal, PermissionCollection, ISecurableContainer, Type)

Performs an access test against the given securable container.

Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of accessTest() that takes the effective ACL as a parameter.

public virtual AccessTestResults AccessTest(
Principal principal,
PermissionCollection permissions,
ISecurableContainer container,
Type type
);

Parameters

principal
The principal for which the access test is performed.
permissions
The set of permission flags to be tested.
container
The securable container against which the test is performed.
type
The type of object for which the test is performed.

Return Value

A detailed explanation of the results of the access test.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.AccessTest Overload List | AccessTestResults | getEffectiveRights | accessTest


AccessRightsManager.Discard Method

Discards cached access rights information. Access rights information will be fetched from the server as needed.

public virtual void Discard();

See Also

AccessRightsManager Class | StarTeam Namespace


AccessRightsManager.Equals Method

Delegate Equals() to com.starteam.AccessRightsManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.AccessRightsManager.Equals(obj).

See Also

AccessRightsManager Class | StarTeam Namespace


GetEffectiveRights Method

Borland StarTeam SDK for .NET

AccessRightsManager.GetEffectiveRights Method

Gets the effective access control list for the given securable object.

The effective access control list completely encompasses all information used by the server to perform an access test for the given object.

This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.

Overload List

Gets the effective access control list for the given securable object. The effective access control list completely encompasses all information used by the server to perform an access test for the given object. This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.

public virtual EffectiveACE[] GetEffectiveRights(ISecurable);

Gets the effective access control list for objects of a given type in a given securable container. The effective access control list completely encompasses all information used by the server to perform an access test for the given object. This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.

public virtual EffectiveACE[] GetEffectiveRights(ISecurableContainer,Type);

See Also

AccessRightsManager Class | StarTeam Namespace | EffectiveACE | isAccessGranted | accessTest


AccessRightsManager.GetEffectiveRights Method (ISecurable)

Gets the effective access control list for the given securable object.

The effective access control list completely encompasses all information used by the server to perform an access test for the given object.

This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.

public virtual EffectiveACE[] GetEffectiveRights(
ISecurable obj
);

Parameters

obj
A securable object.

Return Value

The effective access control list for the given securable object.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.GetEffectiveRights Overload List | EffectiveACE | isAccessGranted | accessTest


AccessRightsManager.GetEffectiveRights Method (ISecurableContainer, Type)

Gets the effective access control list for objects of a given type in a given securable container.

The effective access control list completely encompasses all information used by the server to perform an access test for the given object.

This might include an object-level ACL defined for the object itself, or a container-level ACL defined on a parent folder, or on the view or project, as well as implied ACEs resulting from group privileges, object ownership, and so on.

public virtual EffectiveACE[] GetEffectiveRights(
ISecurableContainer container,
Type type
);

Parameters

container
A securable container.
type
The object type.

Return Value

The effective access control list for the given securable object.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.GetEffectiveRights Overload List | EffectiveACE | isAccessGranted | accessTest


AccessRightsManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.AccessRightsManager.

public override int GetHashCode();

Return Value

com.starteam.AccessRightsManager.GetHashCode().

See Also

AccessRightsManager Class | StarTeam Namespace


GetRights Method

Borland StarTeam SDK for .NET

AccessRightsManager.GetRights Method

Returns the Access Control List for this securable object. The access control list is cached, and subsequent calls will be fetched from the cache

Overload List

Returns the Access Control List for this securable object. The access control list is cached, and subsequent calls will be fetched from the cache

public virtual ACE[] GetRights(ISecurable);

Returns the Access Control List for items of the specified type for this container. The access control list is cached, and subsequent calls will be fetched from the cache

public virtual ACE[] GetRights(ISecurableContainer,Type);

See Also

AccessRightsManager Class | StarTeam Namespace | populate


AccessRightsManager.GetRights Method (ISecurable)

Returns the Access Control List for this securable object. The access control list is cached, and subsequent calls will be fetched from the cache

public virtual ACE[] GetRights(
ISecurable securable
);

Parameters

securable
A securable object.

Return Value

the access control list for this securable.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.GetRights Overload List | populate


AccessRightsManager.GetRights Method (ISecurableContainer, Type)

Returns the Access Control List for items of the specified type for this container. The access control list is cached, and subsequent calls will be fetched from the cache

public virtual ACE[] GetRights(
ISecurableContainer securable,
Type type
);

Parameters

securable
A securable container object
type
the type being controlled by the returned ACL

Return Value

the access control list for this container.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.GetRights Overload List | populate | Type


IsAccessGranted Method

Borland StarTeam SDK for .NET

AccessRightsManager.IsAccessGranted Method

Determines whether or not the given principal is granted the given permissions to a securable object with the given access control list.

Overload List

Determines whether or not the given principal is granted the given permissions to a securable object with the given access control list.

public virtual bool IsAccessGranted(Principal,PermissionCollection,EffectiveACE[]);

Determines whether or not the given principal is granted the given permissions to the given securable object. Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.

public virtual bool IsAccessGranted(Principal,PermissionCollection,ISecurable);

Determines whether or not the given principal is granted the given permissions to the given securable container. Determining the effective access control list for a securable container is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.

public virtual bool IsAccessGranted(Principal,PermissionCollection,ISecurableContainer,Type);

See Also

AccessRightsManager Class | StarTeam Namespace | EffectiveACE | getEffectiveRights


AccessRightsManager.IsAccessGranted Method (Principal, PermissionCollection, EffectiveACE[])

Determines whether or not the given principal is granted the given permissions to a securable object with the given access control list.

public virtual bool IsAccessGranted(
Principal principal,
PermissionCollection permissions,
EffectiveACE[] acl
);

Parameters

principal
The principal for which the access test is performed.
permissions
The set of permission flags to be tested.
acl
The access control list against which the test is performed.

Return Value

true if the principal is granted all the requested permissions; false if at least one of the requested permissions is denied.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.IsAccessGranted Overload List | EffectiveACE | getEffectiveRights


AccessRightsManager.IsAccessGranted Method (Principal, PermissionCollection, ISecurable)

Determines whether or not the given principal is granted the given permissions to the given securable object.

Determining the effective access control list for a securable object is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.

public virtual bool IsAccessGranted(
Principal principal,
PermissionCollection permissions,
ISecurable obj
);

Parameters

principal
The principal for which the access test is performed.
permissions
The set of permission flags to be tested.
obj
The securable object against which the test is performed.

Return Value

true if the principal is granted all the requested permissions; false if at least one of the requested permissions is denied.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.IsAccessGranted Overload List | getEffectiveRights | isAccessGranted


AccessRightsManager.IsAccessGranted Method (Principal, PermissionCollection, ISecurableContainer, Type)

Determines whether or not the given principal is granted the given permissions to the given securable container.

Determining the effective access control list for a securable container is a reasonably expensive operation. For applications that need to perform multiple access tests on the same securable object, consider using the form of isAccessGranted() that takes the effective ACL as a parameter.

public virtual bool IsAccessGranted(
Principal principal,
PermissionCollection permissions,
ISecurableContainer container,
Type type
);

Parameters

principal
The principal for which the access test is performed.
permissions
The set of permission flags to be tested.
container
The securable container against which the test is performed.
type
The type of object for which the test is performed.

Return Value

true if the principal is granted all the requested permissions; false if at least one of the requested permissions is denied.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.IsAccessGranted Overload List | getEffectiveRights | isAccessGranted


IsCached Method

Borland StarTeam SDK for .NET

AccessRightsManager.IsCached Method

returns true if ACLs for the specified securable have already been cached An access rights test against a securable that has not been cached will still succeed since the manager will issue server calls in the content of the test However, the resultant operation would be fairly expensive

Overload List

returns true if ACLs for the specified securable have already been cached An access rights test against a securable that has not been cached will still succeed since the manager will issue server calls in the content of the test However, the resultant operation would be fairly expensive

public virtual bool IsCached(ISecurable);

returns true if ACLs for the specified securable container have already been cached An access rights test against a securable container that has not been cached will still succeed since the manager will issue server calls in the content of the test However, the resultant operation would be fairly expensive

public virtual bool IsCached(ISecurableContainer,Type);

See Also

AccessRightsManager Class | StarTeam Namespace


AccessRightsManager.IsCached Method (ISecurable)

returns true if ACLs for the specified securable have already been cached An access rights test against a securable that has not been cached will still succeed since the manager will issue server calls in the content of the test However, the resultant operation would be fairly expensive

public virtual bool IsCached(
ISecurable _object
);

Parameters

_object

Return Value

true if ACLS for this securable have been cached

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.IsCached Overload List


AccessRightsManager.IsCached Method (ISecurableContainer, Type)

returns true if ACLs for the specified securable container have already been cached An access rights test against a securable container that has not been cached will still succeed since the manager will issue server calls in the content of the test However, the resultant operation would be fairly expensive

public virtual bool IsCached(
ISecurableContainer _object,
Type type
);

Parameters

_object
type
the owning type

Return Value

true if ACLS for this securable container have been cached

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.IsCached Overload List


Populate Method

Borland StarTeam SDK for .NET

AccessRightsManager.Populate Method

Populates the access control list for this securable The cache is maintained in memory until cleared by a call to discard

Overload List

Populates the access control list for this securable The cache is maintained in memory until cleared by a call to discard

public virtual void Populate(ISecurable);

Populates the access control list for all the members of this securable collection using the fewest server commands possible The cache is maintained in memory until cleared by a call to discard

public virtual void Populate(ISecurable[]);

Populates the access control list for this securable container

public virtual void Populate(ISecurableContainer,Type);

Populates the access control list for all the members of this securable container collection using the fewest server commands possible The cache is maintained in memory until cleared by a call to discard

public virtual void Populate(ISecurableContainer[],Type);

See Also

AccessRightsManager Class | StarTeam Namespace | getRights | discard


AccessRightsManager.Populate Method (ISecurable)

Populates the access control list for this securable The cache is maintained in memory until cleared by a call to discard

public virtual void Populate(
ISecurable _object
);

Parameters

_object

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Populate Overload List | getRights | discard


AccessRightsManager.Populate Method (ISecurable[])

Populates the access control list for all the members of this securable collection using the fewest server commands possible The cache is maintained in memory until cleared by a call to discard

public virtual void Populate(
ISecurable[] securables
);

Parameters

securables
a collection of securable objects.

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Populate Overload List | getRights | discard


AccessRightsManager.Populate Method (ISecurableContainer, Type)

Populates the access control list for this securable container

public virtual void Populate(
ISecurableContainer securable,
Type type
);

Parameters

securable
a securable container
type
the owning type

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Populate Overload List | getRights | discard


AccessRightsManager.Populate Method (ISecurableContainer[], Type)

Populates the access control list for all the members of this securable container collection using the fewest server commands possible The cache is maintained in memory until cleared by a call to discard

public virtual void Populate(
ISecurableContainer[] securables,
Type type
);

Parameters

securables
a collection of securable containers.
type
the owning type

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Populate Overload List | getRights | discard


AccessRightsManager.PopulateAll Method

Populates the access control lists for all the members of this collections, parent containers if any, and effective access control lists for these members and their parent containers

public virtual void PopulateAll(
ISecurable[] securables
);

Parameters

securables
a collection of securable objects

See Also

AccessRightsManager Class | StarTeam Namespace | populate | populate | getEffectiveRights | getEffectiveRights


Refresh Method

Borland StarTeam SDK for .NET

AccessRightsManager.Refresh Method

Refreshes cached access rights information to reflect recent changes to the server. From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0, since access rights were not MPX enabled, a call to refresh issues server calls to update all the access rights in this manager However, most of these calls are issued in bulk

Overload List

Refreshes cached access rights information to reflect recent changes to the server. From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0, since access rights were not MPX enabled, a call to refresh issues server calls to update all the access rights in this manager However, most of these calls are issued in bulk

public virtual void Refresh();

refresh a single securable to reflect changes made to the object From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0 server, access Rights were not MPX enabled, so access rights changes to a given securable will not propagate to this manager unless explicitly refreshed

public virtual void Refresh(ISecurable);

refresh a set of securables to reflect changes made to the objects From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0 server, access Rights were not MPX enabled, so access rights changes to securables will not propagate to this manager unless explicitly refreshed

public virtual void Refresh(ISecurable[]);

refresh a single securable container to reflect changes made to the object From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0 server, access Rights were not MPX enabled, so access rights changes to a given securable container will not propagate to this manager unless explicitly refreshed

public virtual void Refresh(ISecurableContainer,Type);

refresh a set of securable containers to reflect changes made to the objects From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby optimizing server calls. Prior to 12.0 server, access Rights were not MPX enabled, so access rights changes to securable containers will not propagate to this manager unless explicitly refreshed

public virtual void Refresh(ISecurableContainer[],Type);

See Also

AccessRightsManager Class | StarTeam Namespace


AccessRightsManager.Refresh Method ()

Refreshes cached access rights information to reflect recent changes to the server. From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0, since access rights were not MPX enabled, a call to refresh issues server calls to update all the access rights in this manager However, most of these calls are issued in bulk

public virtual void Refresh();

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Refresh Overload List


AccessRightsManager.Refresh Method (ISecurable)

refresh a single securable to reflect changes made to the object From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0 server, access Rights were not MPX enabled, so access rights changes to a given securable will not propagate to this manager unless explicitly refreshed

public virtual void Refresh(
ISecurable _object
);

Parameters

_object

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Refresh Overload List


AccessRightsManager.Refresh Method (ISecurable[])

refresh a set of securables to reflect changes made to the objects From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0 server, access Rights were not MPX enabled, so access rights changes to securables will not propagate to this manager unless explicitly refreshed

public virtual void Refresh(
ISecurable[] objects
);

Parameters

objects
the securables to refresh in this manager

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Refresh Overload List


AccessRightsManager.Refresh Method (ISecurableContainer, Type)

refresh a single securable container to reflect changes made to the object From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby minimizing server calls. Prior to 12.0 server, access Rights were not MPX enabled, so access rights changes to a given securable container will not propagate to this manager unless explicitly refreshed

public virtual void Refresh(
ISecurableContainer _object,
Type type
);

Parameters

_object
type
the owning type

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Refresh Overload List


AccessRightsManager.Refresh Method (ISecurableContainer[], Type)

refresh a set of securable containers to reflect changes made to the objects From 12.0 release of the server onwards, MPX events are triggered by the server in case of access rights changes thereby optimizing server calls. Prior to 12.0 server, access Rights were not MPX enabled, so access rights changes to securable containers will not propagate to this manager unless explicitly refreshed

public virtual void Refresh(
ISecurableContainer[] objects,
Type type
);

Parameters

objects
the securable containers to refresh in this manager
type
the owning type

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Refresh Overload List


Remove Method

Borland StarTeam SDK for .NET

AccessRightsManager.Remove Method

Remove a securable from this access rights manager Typically, applications will remove securables that have been deleted

Overload List

Remove a securable from this access rights manager Typically, applications will remove securables that have been deleted

public virtual void Remove(ISecurable);

Remove a set of securables from this access rights manager

public virtual void Remove(ISecurable[]);

Remove a Securable Container from this access rights manager

public virtual void Remove(ISecurableContainer,Type);

Remove a set of Securable Containers from this access rights manager

public virtual void Remove(ISecurableContainer[],Type);

See Also

AccessRightsManager Class | StarTeam Namespace


AccessRightsManager.Remove Method (ISecurable)

Remove a securable from this access rights manager Typically, applications will remove securables that have been deleted

public virtual void Remove(
ISecurable _object
);

Parameters

_object

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Remove Overload List


AccessRightsManager.Remove Method (ISecurable[])

Remove a set of securables from this access rights manager

public virtual void Remove(
ISecurable[] objects
);

Parameters

objects
the securables to remove from the manager

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Remove Overload List


AccessRightsManager.Remove Method (ISecurableContainer, Type)

Remove a Securable Container from this access rights manager

public virtual void Remove(
ISecurableContainer _object,
Type type
);

Parameters

_object
type
the type associated with the container

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Remove Overload List


AccessRightsManager.Remove Method (ISecurableContainer[], Type)

Remove a set of Securable Containers from this access rights manager

public virtual void Remove(
ISecurableContainer[] objects,
Type type
);

Parameters

objects
the securable containers to remove from the manager
type
the type associated with the container

See Also

AccessRightsManager Class | StarTeam Namespace | AccessRightsManager.Remove Overload List


AccessRightsManager.ToString Method

Delegate ToString() to com.starteam.AccessRightsManager.

public override string ToString();

Return Value

com.starteam.AccessRightsManager.ToString()

See Also

AccessRightsManager Class | StarTeam Namespace


AccessRightsManager.AccessTestResults Class

Represents the results of an access test.

Indicates whether or not access is granted, and provides an explanation in terms of the EffectiveACEs that were relevant for each tested permission.

For a list of all members of this type, see AccessRightsManager.AccessTestResults Members.

System.Object
AccessRightsManager.AccessTestResults

public class AccessRightsManager.AccessTestResults

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

AccessRightsManager.AccessTestResults Members | StarTeam Namespace


AccessRightsManager.AccessTestResults Members

AccessRightsManager.AccessTestResults overview

Public Instance Properties

Explanation | [read] An explanation of why access was granted or denied, in terms of the EffectiveACEs that were relevant for each tested permission. Each tested permission appears in exactly one of the MatchedACEs.
IsGranted | [read] true if access was granted; false if access was denied.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.AccessRightsManager.AccessTestResults.
GetHashCode | Delegate GetHashCode() to com.starteam.AccessRightsManager.AccessTestResults.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.AccessRightsManager.AccessTestResults.

See Also

AccessRightsManager.AccessTestResults Class | StarTeam Namespace


AccessRightsManager.AccessTestResults Properties

The properties of the AccessRightsManager.AccessTestResults class are listed below. For a complete list of AccessRightsManager.AccessTestResults class members, see the AccessRightsManager.AccessTestResults Members topic.

Public Instance Properties

Explanation | [read] An explanation of why access was granted or denied, in terms of the EffectiveACEs that were relevant for each tested permission. Each tested permission appears in exactly one of the MatchedACEs.
IsGranted | [read] true if access was granted; false if access was denied.

See Also

AccessRightsManager.AccessTestResults Class | StarTeam Namespace


Explanation Property

Borland StarTeam SDK for .NET

AccessRightsManager.AccessTestResults.Explanation Property

[read] An explanation of why access was granted or denied, in terms of the EffectiveACEs that were relevant for each tested permission. Each tested permission appears in exactly one of the MatchedACEs.

public virtual MatchedACE[] Explanation {get;}

Property Value

An explanation of why access was granted or denied, in terms of the EffectiveACEs that were relevant for each tested permission. Each tested permission appears in exactly one of the MatchedACEs.

See Also

AccessRightsManager.AccessTestResults Class | StarTeam Namespace


IsGranted Property

Borland StarTeam SDK for .NET

AccessRightsManager.AccessTestResults.IsGranted Property

[read] true if access was granted; false if access was denied.

public virtual Boolean IsGranted {get;}

Property Value

true if access was granted; false if access was denied.

See Also

AccessRightsManager.AccessTestResults Class | StarTeam Namespace


AccessRightsManager.AccessTestResults Methods

The methods of the AccessRightsManager.AccessTestResults class are listed below. For a complete list of AccessRightsManager.AccessTestResults class members, see the AccessRightsManager.AccessTestResults Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.AccessRightsManager.AccessTestResults.
GetHashCode | Delegate GetHashCode() to com.starteam.AccessRightsManager.AccessTestResults.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.AccessRightsManager.AccessTestResults.

See Also

AccessRightsManager.AccessTestResults Class | StarTeam Namespace


AccessRightsManager.AccessTestResults.Equals Method

Delegate Equals() to com.starteam.AccessRightsManager.AccessTestResults.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.AccessRightsManager.AccessTestResults.Equals(obj).

See Also

AccessRightsManager.AccessTestResults Class | StarTeam Namespace


AccessRightsManager.AccessTestResults.GetHashCode Method

Delegate GetHashCode() to com.starteam.AccessRightsManager.AccessTestResults.

public override int GetHashCode();

Return Value

com.starteam.AccessRightsManager.AccessTestResults.GetHashCode().

See Also

AccessRightsManager.AccessTestResults Class | StarTeam Namespace


AccessRightsManager.AccessTestResults.ToString Method

Delegate ToString() to com.starteam.AccessRightsManager.AccessTestResults.

public override string ToString();

Return Value

com.starteam.AccessRightsManager.AccessTestResults.ToString()

See Also

AccessRightsManager.AccessTestResults Class | StarTeam Namespace


ACE Class

An Access Control List entry. An ACE specifies a set of permissions that are either granted or denied to a particular user or group. A collection of such entries makes an ACL or Access Control List.

For a list of all members of this type, see ACE Members.

System.Object
ACE
EffectiveACE

public class ACE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ACE Members | StarTeam Namespace


ACE Members

ACE overview

Public Instance Constructors

ACE Overloaded. Initializes a new instance of the ACE class.

Public Instance Properties

IsGranted | [read/write] true if the permissions are granted and false if denied.
IsGroup | [read] true if this ACE represents a group.
Permissions | [read] the permissions for this ACE.
Principal | [read] the principal(user or group) for this entry.

Public Instance Methods

AddPermission | Adds the specified permission to this entry.
Equals | Delegate Equals() to com.starteam.ACE.
GetHashCode | Delegate GetHashCode() to com.starteam.ACE.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if the specified permission is a part of this entry.
RemovePermission | Removes the specified permission from this entry.
ToString | Delegate ToString() to com.starteam.ACE.

See Also

ACE Class | StarTeam Namespace


ACE Constructor

Creates a new Access Control Entry (ACE). No permissions are explicitly granted or denied.

Overload List

Creates a new Access Control Entry (ACE).

public ACE(Principal,PermissionCollection,Boolean);

Creates a new Access Control Entry (ACE). No permissions are explicitly granted or denied.

public ACE(Principal,Boolean);

See Also

ACE Class | StarTeam Namespace | addPermission


ACE Constructor (Principal, Boolean)

Creates a new Access Control Entry (ACE). No permissions are explicitly granted or denied.

public ACE(
Principal prncpl,
Boolean isGranted
);

Parameters

prncpl
The user or group for this entry.
isGranted
true if the permissions are to be granted; false if they are to be denied.

See Also

ACE Class | StarTeam Namespace | ACE Constructor Overload List | addPermission


ACE Constructor (Principal, PermissionCollection, Boolean)

Creates a new Access Control Entry (ACE).

public ACE(
Principal prncpl,
PermissionCollection permissions,
Boolean isGranted
);

Parameters

prncpl
The user or group for this entry.
permissions
The permissions to be granted or denied.
isGranted
true if the permissions are to be granted; false if they are to be denied.

See Also

ACE Class | StarTeam Namespace | ACE Constructor Overload List


ACE Properties

The properties of the ACE class are listed below. For a complete list of ACE class members, see the ACE Members topic.

Public Instance Properties

IsGranted | [read/write] true if the permissions are granted and false if denied.
IsGroup | [read] true if this ACE represents a group.
Permissions | [read] the permissions for this ACE.
Principal | [read] the principal(user or group) for this entry.

See Also

ACE Class | StarTeam Namespace


IsGranted Property

Borland StarTeam SDK for .NET

ACE.IsGranted Property

[read/write] true if the permissions are granted and false if denied.

public virtual Boolean IsGranted {get; set;}

Property Value

true if the permissions are granted and false if denied.

See Also

ACE Class | StarTeam Namespace


IsGroup Property

Borland StarTeam SDK for .NET

ACE.IsGroup Property

[read] true if this ACE represents a group.

public virtual Boolean IsGroup {get;}

Property Value

true if this ACE represents a group.

See Also

ACE Class | StarTeam Namespace


Permissions Property

Borland StarTeam SDK for .NET

ACE.Permissions Property

[read] the permissions for this ACE.

public virtual PermissionCollection Permissions {get;}

Property Value

the permissions for this ACE.

See Also

ACE Class | StarTeam Namespace


Principal Property

Borland StarTeam SDK for .NET

ACE.Principal Property

[read] the principal(user or group) for this entry.

public virtual Principal Principal {get;}

Property Value

the principal(user or group) for this entry.

See Also

ACE Class | StarTeam Namespace


ACE Methods

The methods of the ACE class are listed below. For a complete list of ACE class members, see the ACE Members topic.

Public Instance Methods

AddPermission | Adds the specified permission to this entry.
Equals | Delegate Equals() to com.starteam.ACE.
GetHashCode | Delegate GetHashCode() to com.starteam.ACE.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if the specified permission is a part of this entry.
RemovePermission | Removes the specified permission from this entry.
ToString | Delegate ToString() to com.starteam.ACE.

See Also

ACE Class | StarTeam Namespace


ACE.AddPermission Method

Adds the specified permission to this entry.

public virtual void AddPermission(
Permission permission
);

Parameters

permission
the permission to be added

See Also

ACE Class | StarTeam Namespace | Permission


ACE.Equals Method

Delegate Equals() to com.starteam.ACE.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ACE.Equals(obj).

See Also

ACE Class | StarTeam Namespace


ACE.GetHashCode Method

Delegate GetHashCode() to com.starteam.ACE.

public override int GetHashCode();

Return Value

com.starteam.ACE.GetHashCode().

See Also

ACE Class | StarTeam Namespace


ACE.HasPermission Method

Returns true if the specified permission is a part of this entry.

public virtual bool HasPermission(
Permission permission
);

Parameters

permission
the permission code to be checked

Return Value

true if the specified permission if a part of this entry.

See Also

ACE Class | StarTeam Namespace | Permission


ACE.RemovePermission Method

Removes the specified permission from this entry.

public virtual void RemovePermission(
Permission permission
);

Parameters

permission
the permission code to be removed

See Also

ACE Class | StarTeam Namespace | Permission


ACE.ToString Method

Delegate ToString() to com.starteam.ACE.

public override string ToString();

Return Value

com.starteam.ACE.ToString()

See Also

ACE Class | StarTeam Namespace


ACE.WebCacheACE Class

Base accessor for cached SDK ACEs

For a list of all members of this type, see ACE.WebCacheACE Members.

System.Object
ACE.WebCacheACE

public class ACE.WebCacheACE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ACE.WebCacheACE Members | StarTeam Namespace


ACE.WebCacheACE Members

ACE.WebCacheACE overview

Public Instance Constructors

ACE.WebCacheACE Overloaded. Initializes a new instance of the ACE.WebCacheACE class.

Public Instance Properties

Context | [read] the context of this object.
IsGranted | [read/write] true if the permissions are granted and false if denied.
Permissions | [read] the permissions for this ACE.
Principal | [read] the principal(user or group) for this entry.
Server | [read] the Server for this cached object

Public Instance Methods

AddPermission | Adds the specified permission to this entry.
Equals | Delegate Equals() to com.starteam.ACE.WebCacheACE.
GetHashCode | Delegate GetHashCode() to com.starteam.ACE.WebCacheACE.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if the specified permission is a part of this entry.
RemovePermission | Removes the specified permission from this entry.
ToString | Delegate ToString() to com.starteam.ACE.WebCacheACE.

See Also

ACE.WebCacheACE Class | StarTeam Namespace


ACE.WebCacheACE Constructor

Overload List

public ACE.WebCacheACE(Principal.WebCachePrincipal,PermissionCollection,Boolean);

public ACE.WebCacheACE(Principal.WebCachePrincipal,Boolean);

See Also

ACE.WebCacheACE Class | StarTeam Namespace


ACE.WebCacheACE Constructor (Principal#WebCachePrincipal, Boolean)

public ACE.WebCacheACE(
Principal.WebCachePrincipal prncpl,
Boolean isGranted
);

See Also

ACE.WebCacheACE Class | StarTeam Namespace | ACE.WebCacheACE Constructor Overload List


ACE.WebCacheACE Constructor (Principal#WebCachePrincipal, PermissionCollection, Boolean)

public ACE.WebCacheACE(
Principal.WebCachePrincipal prncpl,
PermissionCollection permissions,
Boolean isGranted
);

See Also

ACE.WebCacheACE Class | StarTeam Namespace | ACE.WebCacheACE Constructor Overload List


ACE.WebCacheACE Properties

The properties of the ACE.WebCacheACE class are listed below. For a complete list of ACE.WebCacheACE class members, see the ACE.WebCacheACE Members topic.

Public Instance Properties

Context | [read] the context of this object.
IsGranted | [read/write] true if the permissions are granted and false if denied.
Permissions | [read] the permissions for this ACE.
Principal | [read] the principal(user or group) for this entry.
Server | [read] the Server for this cached object

See Also

ACE.WebCacheACE Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

ACE.WebCacheACE.Context Property

[read] the context of this object.

public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

ACE.WebCacheACE Class | StarTeam Namespace


IsGranted Property

Borland StarTeam SDK for .NET

ACE.WebCacheACE.IsGranted Property

[read/write] true if the permissions are granted and false if denied.

public virtual Boolean IsGranted {get; set;}

Property Value

true if the permissions are granted and false if denied.

See Also

ACE.WebCacheACE Class | StarTeam Namespace


Permissions Property

Borland StarTeam SDK for .NET

ACE.WebCacheACE.Permissions Property

[read] the permissions for this ACE.

public virtual PermissionCollection Permissions {get;}

Property Value

the permissions for this ACE.

See Also

ACE.WebCacheACE Class | StarTeam Namespace


Principal Property

Borland StarTeam SDK for .NET

ACE.WebCacheACE.Principal Property

[read] the principal(user or group) for this entry.

public virtual Principal.WebCachePrincipal Principal {get;}

Property Value

the principal(user or group) for this entry.

See Also

ACE.WebCacheACE Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ACE.WebCacheACE.Server Property

[read] the Server for this cached object

public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

ACE.WebCacheACE Class | StarTeam Namespace


ACE.WebCacheACE Methods

The methods of the ACE.WebCacheACE class are listed below. For a complete list of ACE.WebCacheACE class members, see the ACE.WebCacheACE Members topic.

Public Instance Methods

AddPermission | Adds the specified permission to this entry.
Equals | Delegate Equals() to com.starteam.ACE.WebCacheACE.
GetHashCode | Delegate GetHashCode() to com.starteam.ACE.WebCacheACE.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission | Returns true if the specified permission is a part of this entry.
RemovePermission | Removes the specified permission from this entry.
ToString | Delegate ToString() to com.starteam.ACE.WebCacheACE.

See Also

ACE.WebCacheACE Class | StarTeam Namespace


ACE.WebCacheACE.AddPermission Method

Adds the specified permission to this entry.

public virtual void AddPermission(
Permission permission
);

Parameters

permission
the permission to be added

See Also

ACE.WebCacheACE Class | StarTeam Namespace | Permission


ACE.WebCacheACE.Equals Method

Delegate Equals() to com.starteam.ACE.WebCacheACE.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ACE.WebCacheACE.Equals(obj).

See Also

ACE.WebCacheACE Class | StarTeam Namespace


ACE.WebCacheACE.GetHashCode Method

Delegate GetHashCode() to com.starteam.ACE.WebCacheACE.

public override int GetHashCode();

Return Value

com.starteam.ACE.WebCacheACE.GetHashCode().

See Also

ACE.WebCacheACE Class | StarTeam Namespace


ACE.WebCacheACE.HasPermission Method

Returns true if the specified permission is a part of this entry.

public virtual bool HasPermission(
Permission permission
);

Parameters

permission
the permission code to be checked

Return Value

true if the specified permission if a part of this entry.

See Also

ACE.WebCacheACE Class | StarTeam Namespace | Permission


ACE.WebCacheACE.RemovePermission Method

Removes the specified permission from this entry.

public virtual void RemovePermission(
Permission permission
);

Parameters

permission
the permission code to be removed

See Also

ACE.WebCacheACE Class | StarTeam Namespace | Permission


ACE.WebCacheACE.ToString Method

Delegate ToString() to com.starteam.ACE.WebCacheACE.

public override string ToString();

Return Value

com.starteam.ACE.WebCacheACE.ToString()

See Also

ACE.WebCacheACE Class | StarTeam Namespace


Application Class

The StarTeam SDK's interface to the client application.

For a list of all members of this type, see Application Members.

System.Object
Application

public class Application

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Application Members | StarTeam Namespace


Application Members

Application overview

Public Static Properties

DefaultName [read/write] The client application name. Default is "<Unknown Application>". To report a specific application name to the StarTeam Server for diagnostic purposes, set the application name prior to connecting.

Public Instance Constructors

Application Overloaded. Initializes a new instance of the Application class.

Public Instance Properties

ClientContext | [read] The client context.
Description | [read] A verbose description of the client application.
Name | [read] The client application name.
RepositoryIDs | [read] a StarTeamRepositoryIDs instance, loaded from the local file of server GUIDs
ResolveOptionsValue | [read/write] ResolveOptions that affect resolve operations for this Application
Servers | [read] The application's server collection.
TraceFinder | [read] a TraceFinder that can be used to search for Traces across servers

Public Instance Methods

Close | Closes the client application. Any Server objects remaining in the application's server list are disconnected.
Equals | Delegate Equals() to com.starteam.Application.
FindFile | return a File in a specific folder
FindFolder | Returns a Folder in a folder tree
GetDefaultServerInfo | Creates a default ServerInfo for the server at the given address and port.
GetHashCode | Delegate GetHashCode() to com.starteam.Application.
GetType (inherited from Object) | Gets the Type of the current instance.
NewServer | Overloaded. Creates a new Server object, using the given connection information. The Server is automatically added to the application's server collection by Server.connect(), and is removed from the collection by Server.disconnect().
Resolve | Resolves the given StarTeam URL/ALM URI to the corresponding StarTeam resource. Throws an exception if the URL/URI has the wrong format, or if the referenced resource cannot be resolved.
ResolveFolder | Given a view and a path to a sub-folder return the sub-folder if found. Return null if the specified folder can not be found. The specified path should be relative to the root folder of the view being searched, and should specify the full hierarchy from the root folder to the one being searched. Does a case sensitive comparison of folder names on platforms which support case sensitivity (e.g. Unix)
ResolveProject | Overloaded. Resolves the given project ID to a Project object. The default implementation looks for a matching Project in the server's project collection. If an existing Project cannot be found, and the Application has enabled auto-refresh for projects, then the Server's project collection is refreshed, and searched again. If none of these strategies are successful, then resolveProject() returns null.
ResolveServer Overloaded. Resolves the given address and port to a Server object that has already been connected and logged on as the given user. The default implementation looks for a matching Server in the application's server collection:
 Server server = resolveUsingServerCollection(address, port, userName); if (server != null) { return server; }
If an existing Server cannot be found, then an attempt is made to create a new Server instance:
 ServerInfo info = resolveServerInfo(address, port); return resolveToNewServer(info, null, userName, password);
An application that wants to extend this algorithm will probably override resolveToNewServer().
ResolveServerInfo | Obtains a ServerInfo for the server with the given description. Default implementation searches for a matching ServerInfo in the application's default server-list.xml. If no matching entry is found, it tries to find a matching entry by host address.
ResolveToView | Resolves the given StarTeam URL/ALM URI down to the view. Throws an exception if the URL/URI has the wrong format,
ResolveView | Overloaded. Resolves the given view ID to a View object. The default implementation looks for a matching View in the project's view collection. If an existing View cannot be found, and the Application has enabled auto-refresh for views, then the Project's view collection is refreshed, and searched again. If none of these strategies are successful, then resolveView() returns null.
ToStarTeamURL | Overloaded. Resolves the given StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Application.

See Also

Application Class | StarTeam Namespace


Application Constructor

Create an Application with a default name.

Overload List

Create an Application with a default name.

public Application();

Create an Application with the given name.

public Application(String);

Create an Application with the given name and client context.

public Application(String,ClientContext);

See Also

Application Class | StarTeam Namespace


Application Constructor ()

Create an Application with a default name.

public Application();

See Also

Application Class | StarTeam Namespace | Application Constructor Overload List


Application Constructor (String)

Create an Application with the given name.

public Application(
String name
);

Parameters

name
The client application name. The application name is reported to the StarTeam Server at connect time for diagnostic purposes.

See Also

Application Class | StarTeam Namespace | Application Constructor Overload List


Application Constructor (String, ClientContext)

Create an Application with the given name and client context.

public Application(
String name,
ClientContext context
);

Parameters

name
The client application name. The application name is reported to the StarTeam Server at connect time for diagnostic purposes.
context
Describes aspects of the client runtime environment.

See Also

Application Class | StarTeam Namespace | Application Constructor Overload List


Application Properties

The properties of the Application class are listed below. For a complete list of Application class members, see the Application Members topic.

Public Static Properties

DefaultName [read/write] The client application name. Default is "<Unknown Application>". To report a specific application name to the StarTeam Server for diagnostic purposes, set the application name prior to connecting.

Public Instance Properties

ClientContext | [read] The client context.
Description | [read] A verbose description of the client application.
Name | [read] The client application name.
RepositoryIDs | [read] a StarTeamRepositoryIDs instance, loaded from the local file of server GUIDs
ResolveOptionsValue | [read/write] ResolveOptions that affect resolve operations for this Application
Servers | [read] The application's server collection.
TraceFinder | [read] a TraceFinder that can be used to search for Traces across servers

See Also

Application Class | StarTeam Namespace


ClientContext Property

Borland StarTeam SDK for .NET

Application.ClientContext Property

[read] The client context.

public virtual ClientContext ClientContext {get;}

Property Value

The client context.

See Also

Application Class | StarTeam Namespace


DefaultName Property

Borland StarTeam SDK for .NET

Application.DefaultName Property

[read/write] The client application name. Default is "<Unknown Application>". To report a specific application name to the StarTeam Server for diagnostic purposes, set the application name prior to connecting.

public static String DefaultName {get; set;}

Property Value

The client application name. Default is "<Unknown Application>". To report a specific application name to the StarTeam Server for diagnostic purposes, set the application name prior to connecting.

See Also

Application Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Application.Description Property

[read] A verbose description of the client application.

public virtual String Description {get;}

Property Value

A verbose description of the client application.

See Also

Application Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Application.Name Property

[read] The client application name.

public virtual String Name {get;}

Property Value

The client application name.

See Also

Application Class | StarTeam Namespace


RepositoryIDs Property

Borland StarTeam SDK for .NET

Application.RepositoryIDs Property

[read] a StarTeamRepositoryIDs instance, loaded from the local file of server GUIDs

public virtual StarTeamRepositoryIDs RepositoryIDs {get;}

Property Value

a StarTeamRepositoryIDs instance, loaded from the local file of server GUIDs

See Also

Application Class | StarTeam Namespace


ResolveOptionsValue Property

Borland StarTeam SDK for .NET

Application.ResolveOptionsValue Property

[read/write] ResolveOptions that affect resolve operations for this Application

public virtual Application.ResolveOptions ResolveOptionsValue {get; set;}

Property Value

ResolveOptions that affect resolve operations for this Application

See Also

Application Class | StarTeam Namespace


Servers Property

Borland StarTeam SDK for .NET

Application.Servers Property

[read] The application's server collection.

public virtual Server[] Servers {get;}

Property Value

The application's server collection.

See Also

Application Class | StarTeam Namespace


TraceFinder Property

Borland StarTeam SDK for .NET

Application.TraceFinder Property

[read] a TraceFinder that can be used to search for Traces across servers

public virtual TraceFinder TraceFinder {get;}

Property Value

a TraceFinder that can be used to search for Traces across servers

See Also

Application Class | StarTeam Namespace


Application Methods

The methods of the Application class are listed below. For a complete list of Application class members, see the Application Members topic.

Public Instance Methods

Close | Closes the client application. Any Server objects remaining in the application's server list are disconnected.
Equals | Delegate Equals() to com.starteam.Application.
FindFile | return a File in a specific folder
FindFolder | Returns a Folder in a folder tree
GetDefaultServerInfo | Creates a default ServerInfo for the server at the given address and port.
GetHashCode | Delegate GetHashCode() to com.starteam.Application.
GetType (inherited from Object) | Gets the Type of the current instance.
NewServer | Overloaded. Creates a new Server object, using the given connection information. The Server is automatically added to the application's server collection by Server.connect(), and is removed from the collection by Server.disconnect().
Resolve | Resolves the given StarTeam URL/ALM URI to the corresponding StarTeam resource. Throws an exception if the URL/URI has the wrong format, or if the referenced resource cannot be resolved.
ResolveFolder | Given a view and a path to a sub-folder return the sub-folder if found. Return null if the specified folder can not be found. The specified path should be relative to the root folder of the view being searched, and should specify the full hierarchy from the root folder to the one being searched. Does a case sensitive comparison of folder names on platforms which support case sensitivity (e.g. Unix)
ResolveProject | Overloaded. Resolves the given project ID to a Project object. The default implementation looks for a matching Project in the server's project collection. If an existing Project cannot be found, and the Application has enabled auto-refresh for projects, then the Server's project collection is refreshed, and searched again. If none of these strategies are successful, then resolveProject() returns null.
ResolveServer Overloaded. Resolves the given address and port to a Server object that has already been connected and logged on as the given user. The default implementation looks for a matching Server in the application's server collection:
 Server server = resolveUsingServerCollection(address, port, userName); if (server != null) { return server; }
If an existing Server cannot be found, then an attempt is made to create a new Server instance:
 ServerInfo info = resolveServerInfo(address, port); return resolveToNewServer(info, null, userName, password);
An application that wants to extend this algorithm will probably override resolveToNewServer().
ResolveServerInfo | Obtains a ServerInfo for the server with the given description. Default implementation searches for a matching ServerInfo in the application's default server-list.xml. If no matching entry is found, it tries to find a matching entry by host address.
ResolveToView | Resolves the given StarTeam URL/ALM URI down to the view. Throws an exception if the URL/URI has the wrong format,
ResolveView | Overloaded. Resolves the given view ID to a View object. The default implementation looks for a matching View in the project's view collection. If an existing View cannot be found, and the Application has enabled auto-refresh for views, then the Project's view collection is refreshed, and searched again. If none of these strategies are successful, then resolveView() returns null.
ToStarTeamURL | Overloaded. Resolves the given StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Application.

See Also

Application Class | StarTeam Namespace


Application.Close Method

Closes the client application. Any Server objects remaining in the application's server list are disconnected.

public virtual void Close();

See Also

Application Class | StarTeam Namespace


Application.Equals Method

Delegate Equals() to com.starteam.Application.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Application.Equals(obj).

See Also

Application Class | StarTeam Namespace


Application.FindFile Method

return a File in a specific folder

public virtual File FindFile(
Folder source,
String name,
Boolean matchCase
);

Parameters

source
the folder to search
name
the name of the file to match
matchCase
true if case has to be considered

Return Value

a File or null

See Also

Application Class | StarTeam Namespace


Application.FindFolder Method

Returns a Folder in a folder tree

public virtual Folder FindFolder(
Folder from,
String folderPath
);

Parameters

from
the folder to start the search
folderPath
the path to match

Return Value

a matching folder on server or new folder object, if not found.

See Also

Application Class | StarTeam Namespace


Application.GetDefaultServerInfo Method

Creates a default ServerInfo for the server at the given address and port.

public virtual ServerInfo GetDefaultServerInfo(
String address,
Int32 port
);

Parameters

address
String
port
int

Return Value

ServerInfo

See Also

Application Class | StarTeam Namespace


Application.GetHashCode Method

Delegate GetHashCode() to com.starteam.Application.

public override int GetHashCode();

Return Value

com.starteam.Application.GetHashCode().

See Also

Application Class | StarTeam Namespace


NewServer Method

Borland StarTeam SDK for .NET

Application.NewServer Method

Creates a new Server object, using the given connection information.

The Server is automatically added to the application's server collection by Server.connect(), and is removed from the collection by Server.disconnect().

Overload List

Creates a new Server object, using the given connection information. The Server is automatically added to the application's server collection by Server.connect(), and is removed from the collection by Server.disconnect().

public virtual Server NewServer(ServerInfo);

Looks up the given server name in starteam-servers.xml, and uses the resulting ServerInfo to construct the server. If no ServerInfo with that name is found, assumes that servername is the address, and uses the default port. The Server is automatically added to the application's server collection by Server.connect(), and is removed from the collection by Server.disconnect().

public virtual Server NewServer(String);

Creates a new Server object, using the given host address and port. The Server is automatically added to the application's server collection by Server.connect(), and is removed from the collection by Server.disconnect().

public virtual Server NewServer(String,Int32);

See Also

Application Class | StarTeam Namespace | ServerInfo | connect | disconnect | enableMPX


Application.NewServer Method (ServerInfo)

Creates a new Server object, using the given connection information.

The Server is automatically added to the application's server collection by Server.connect(), and is removed from the collection by Server.disconnect().

public virtual Server NewServer(
ServerInfo info
);

Parameters

info
Server connection information.

See Also

Application Class | StarTeam Namespace | Application.NewServer Overload List | ServerInfo | connect | disconnect | enableMPX


Application.NewServer Method (String)

Looks up the given server name in starteam-servers.xml, and uses the resulting ServerInfo to construct the server. If no ServerInfo with that name is found, assumes that servername is the address, and uses the default port.

The Server is automatically added to the application's server collection by Server.connect(), and is removed from the collection by Server.disconnect().

public virtual Server NewServer(
String serverName
);

Parameters

serverName
A server name in starteam-servers.xml.

See Also

Application Class | StarTeam Namespace | Application.NewServer Overload List


Application.NewServer Method (String, Int32)

Creates a new Server object, using the given host address and port.

The Server is automatically added to the application's server collection by Server.connect(), and is removed from the collection by Server.disconnect().

public virtual Server NewServer(
String address,
Int32 port
);

Parameters

address
The server's host address.
port
The server's TCP/IP port.

See Also

Application Class | StarTeam Namespace | Application.NewServer Overload List


Application.Resolve Method

Resolves the given StarTeam URL/ALM URI to the corresponding StarTeam resource. Throws an exception if the URL/URI has the wrong format, or if the referenced resource cannot be resolved.

public virtual object Resolve(
String url
);

Parameters

url
the StarTeam URL/ALM URI to be resolved

Return Value

Object the resolved StarTeam component

See Also

Application Class | StarTeam Namespace


Application.ResolveFolder Method

Given a view and a path to a sub-folder return the sub-folder if found. Return null if the specified folder can not be found. The specified path should be relative to the root folder of the view being searched, and should specify the full hierarchy from the root folder to the one being searched. Does a case sensitive comparison of folder names on platforms which support case sensitivity (e.g. Unix)

public virtual Folder ResolveFolder(
View view,
String folderPath
);

Parameters

view
the view in which the folder is to be found
folderPath
the path to the sub-folder

Return Value

the specified sub folder or null if not found.

See Also

Application Class | StarTeam Namespace


ResolveProject Method

Borland StarTeam SDK for .NET

Application.ResolveProject Method

Resolves the given project ID to a Project object.

The default implementation looks for a matching Project in the server's project collection.

If an existing Project cannot be found, and the Application has enabled auto-refresh for projects, then the Server's project collection is refreshed, and searched again.

If none of these strategies are successful, then resolveProject() returns null.

Overload List

Resolves the given project ID to a Project object. The default implementation looks for a matching Project in the server's project collection. If an existing Project cannot be found, and the Application has enabled auto-refresh for projects, then the Server's project collection is refreshed, and searched again. If none of these strategies are successful, then resolveProject() returns null.

public virtual Project ResolveProject(Server,Int32);

Resolves the project name to a Project object. The default implementation looks for a matching Project in the server's project collection. If an existing Project cannot be found, and the Application has enabled auto-refresh for projects, then the Server's project collection is refreshed, and searched again. If none of these strategies are successful, then resolveProject() returns null.

public virtual Project ResolveProject(Server,String);

See Also

Application Class | StarTeam Namespace | isAutoRefreshProjectsEnabled


Application.ResolveProject Method (Server, Int32)

Resolves the given project ID to a Project object.

The default implementation looks for a matching Project in the server's project collection.

If an existing Project cannot be found, and the Application has enabled auto-refresh for projects, then the Server's project collection is refreshed, and searched again.

If none of these strategies are successful, then resolveProject() returns null.

public virtual Project ResolveProject(
Server server,
Int32 projectID
);

Parameters

server
The server that contains the desired project.
projectID
The project ID.

Return Value

The resolved Project, or null if it could not be resolved.

See Also

Application Class | StarTeam Namespace | Application.ResolveProject Overload List | isAutoRefreshProjectsEnabled


Application.ResolveProject Method (Server, String)

Resolves the project name to a Project object.

The default implementation looks for a matching Project in the server's project collection.

If an existing Project cannot be found, and the Application has enabled auto-refresh for projects, then the Server's project collection is refreshed, and searched again.

If none of these strategies are successful, then resolveProject() returns null.

public virtual Project ResolveProject(
Server server,
String name
);

Parameters

server
The server that contains the desired project.
name
The project name.

Return Value

The resolved Project, or null if it could not be resolved.

See Also

Application Class | StarTeam Namespace | Application.ResolveProject Overload List | isAutoRefreshProjectsEnabled


ResolveServer Method

Borland StarTeam SDK for .NET

Application.ResolveServer Method

Resolves the given repository ID to a Server object that has already been connected and logged on as the given user.

The default implementation looks for a matching Server in the application's server collection:

 Server server = resolveUsingServerCollection(repositoryID, userName); if (server != null) { return server; }

If an existing Server cannot be found, then an attempt is made to find a connect string for the given repository ID:

 String[] candidates = findRepositoryID(repositoryID);
We iterate over the candidate connect strings, looking for one that we are able to resolve:
 ServerInfo info = resolveServerInfo(candidates[i]); server = resolveToNewServer(info, repositoryID, userName, password);

An application that wants to extend this algorithm will probably override resolveToNewServer().

Overload List

Resolves the given repository ID to a Server object that has already been connected and logged on as the given user. The default implementation looks for a matching Server in the application's server collection:

 Server server = resolveUsingServerCollection(repositoryID, userName); if (server != null) { return server; }
If an existing Server cannot be found, then an attempt is made to find a connect string for the given repository ID:
 String[] candidates = findRepositoryID(repositoryID);
We iterate over the candidate connect strings, looking for one that we are able to resolve:
 ServerInfo info = resolveServerInfo(candidates[i]); server = resolveToNewServer(info, repositoryID, userName, password);
An application that wants to extend this algorithm will probably override resolveToNewServer().

public virtual Server ResolveServer(GUID);

Resolves the given repository ID to a Server object that has already been connected and logged on as the given user. The default implementation looks for a matching Server in the application's server collection:

 Server server = resolveUsingServerCollection(repositoryID, userName); if (server != null) { return server; }
If an existing Server cannot be found, then an attempt is made to find a connect string for the given repository ID:
 String[] candidates = findRepositoryID(repositoryID);
We iterate over the candidate connect strings, looking for one that we are able to resolve:
 ServerInfo info = resolveServerInfo(candidates[i]); server = resolveToNewServer(info, repositoryID, userName, password);
An application that wants to extend this algorithm will probably override resolveToNewServer().

public virtual Server ResolveServer(GUID,String,String);

Resolves the given address and port to a Server object that has already been connected and logged on as the given user. The default implementation looks for a matching Server in the application's server collection:

 Server server = resolveUsingServerCollection(address, port, userName); if (server != null) { return server; }
If an existing Server cannot be found, then an attempt is made to create a new Server instance:
 ServerInfo info = resolveServerInfo(address, port); return resolveToNewServer(info, null, userName, password);
An application that wants to extend this algorithm will probably override resolveToNewServer().

public virtual Server ResolveServer(String,Int32);

Resolves the given address and port to a Server object that has already been connected and logged on as the given user. The default implementation looks for a matching Server in the application's server collection:

 Server server = resolveUsingServerCollection(address, port, userName); if (server != null) { return server; }
If an existing Server cannot be found, then an attempt is made to create a new Server instance:
 ServerInfo info = resolveServerInfo(address, port); return resolveToNewServer(info, null, userName, password);
An application that wants to extend this algorithm will probably override resolveToNewServer().

public virtual Server ResolveServer(String,Int32,String,String);

See Also

Application Class | StarTeam Namespace


Application.ResolveServer Method (GUID)

Resolves the given repository ID to a Server object that has already been connected and logged on as the given user.

The default implementation looks for a matching Server in the application's server collection:

 Server server = resolveUsingServerCollection(repositoryID, userName); if (server != null) { return server; }

If an existing Server cannot be found, then an attempt is made to find a connect string for the given repository ID:

 String[] candidates = findRepositoryID(repositoryID);
We iterate over the candidate connect strings, looking for one that we are able to resolve:
 ServerInfo info = resolveServerInfo(candidates[i]); server = resolveToNewServer(info, repositoryID, userName, password);

An application that wants to extend this algorithm will probably override resolveToNewServer().

public virtual Server ResolveServer(
GUID repositoryID
);

Parameters

repositoryID
The desired server's repository ID.

Return Value

The resolved Server, or null if it could not be resolved.

See Also

Application Class | StarTeam Namespace | Application.ResolveServer Overload List


Application.ResolveServer Method (GUID, String, String)

Resolves the given repository ID to a Server object that has already been connected and logged on as the given user.

The default implementation looks for a matching Server in the application's server collection:

 Server server = resolveUsingServerCollection(repositoryID, userName); if (server != null) { return server; }

If an existing Server cannot be found, then an attempt is made to find a connect string for the given repository ID:

 String[] candidates = findRepositoryID(repositoryID);
We iterate over the candidate connect strings, looking for one that we are able to resolve:
 ServerInfo info = resolveServerInfo(candidates[i]); server = resolveToNewServer(info, repositoryID, userName, password);

An application that wants to extend this algorithm will probably override resolveToNewServer().

public virtual Server ResolveServer(
GUID repositoryID,
String userName,
String password
);

Parameters

repositoryID
The desired server's repository ID.
userName
The desired user name, or null if any logged on user is acceptable.
password
The desired password, or null if not known.

Return Value

The resolved Server, or null if it could not be resolved.

See Also

Application Class | StarTeam Namespace | Application.ResolveServer Overload List


Application.ResolveServer Method (String, Int32)

Resolves the given address and port to a Server object that has already been connected and logged on as the given user.

The default implementation looks for a matching Server in the application's server collection:

 Server server = resolveUsingServerCollection(address, port, userName); if (server != null) { return server; }

If an existing Server cannot be found, then an attempt is made to create a new Server instance:

 ServerInfo info = resolveServerInfo(address, port); return resolveToNewServer(info, null, userName, password);

An application that wants to extend this algorithm will probably override resolveToNewServer().

public virtual Server ResolveServer(
String address,
Int32 port
);

Parameters

address
The desired server's host address.
port
The desired server's port number.

Return Value

The resolved Server, or null if it could not be resolved.

See Also

Application Class | StarTeam Namespace | Application.ResolveServer Overload List


Application.ResolveServer Method (String, Int32, String, String)

Resolves the given address and port to a Server object that has already been connected and logged on as the given user.

The default implementation looks for a matching Server in the application's server collection:

 Server server = resolveUsingServerCollection(address, port, userName); if (server != null) { return server; }

If an existing Server cannot be found, then an attempt is made to create a new Server instance:

 ServerInfo info = resolveServerInfo(address, port); return resolveToNewServer(info, null, userName, password);

An application that wants to extend this algorithm will probably override resolveToNewServer().

public virtual Server ResolveServer(
String address,
Int32 port,
String userName,
String password
);

Parameters

address
The desired server's host address.
port
The desired server's port number.
userName
The desired user name, or null if any logged on user is acceptable.
password
The desired password, or null if not known.

Return Value

The resolved Server, or null if it could not be resolved.

See Also

Application Class | StarTeam Namespace | Application.ResolveServer Overload List


Application.ResolveServerInfo Method

Obtains a ServerInfo for the server with the given description.

Default implementation searches for a matching ServerInfo in the application's default server-list.xml. If no matching entry is found, it tries to find a matching entry by host address.

public virtual ServerInfo ResolveServerInfo(
String servername
);

Parameters

servername
Target server description.

Return Value

The matching ServerInfo, or a default ServerInfo if no matching one was found.

See Also

Application Class | StarTeam Namespace | resolveServerInfo


Application.ResolveToView Method

Resolves the given StarTeam URL/ALM URI down to the view. Throws an exception if the URL/URI has the wrong format,

public virtual View ResolveToView(
String url
);

Parameters

url
the StarTeam URL/ALM URI to be resolved

Return Value

View the resolved StarTeam view, or null if the view could not be resolved.

See Also

Application Class | StarTeam Namespace


ResolveView Method

Borland StarTeam SDK for .NET

Application.ResolveView Method

Resolves the given view ID to a View object.

The default implementation looks for a matching View in the project's view collection.

If an existing View cannot be found, and the Application has enabled auto-refresh for views, then the Project's view collection is refreshed, and searched again.

If none of these strategies are successful, then resolveView() returns null.

Overload List

Resolves the given view ID to a View object. The default implementation looks for a matching View in the project's view collection. If an existing View cannot be found, and the Application has enabled auto-refresh for views, then the Project's view collection is refreshed, and searched again. If none of these strategies are successful, then resolveView() returns null.

public virtual View ResolveView(Project,Int32);

Resolves the view name to a view object. The default implementation looks for a matching View in the project's view collection. If an existing View cannot be found, and the Application has enabled auto-refresh for views, then the Project's view collection is refreshed, and searched again. If none of these strategies are successful, then resolveView() returns null.

public virtual View ResolveView(Project,String);

See Also

Application Class | StarTeam Namespace | isAutoRefreshViewsEnabled


Application.ResolveView Method (Project, Int32)

Resolves the given view ID to a View object.

The default implementation looks for a matching View in the project's view collection.

If an existing View cannot be found, and the Application has enabled auto-refresh for views, then the Project's view collection is refreshed, and searched again.

If none of these strategies are successful, then resolveView() returns null.

public virtual View ResolveView(
Project project,
Int32 viewID
);

Parameters

project
The project that contains the desired view.
viewID
The view ID.

Return Value

The resolved View, or null if it could not be resolved.

See Also

Application Class | StarTeam Namespace | Application.ResolveView Overload List | isAutoRefreshViewsEnabled


Application.ResolveView Method (Project, String)

Resolves the view name to a view object.

The default implementation looks for a matching View in the project's view collection.

If an existing View cannot be found, and the Application has enabled auto-refresh for views, then the Project's view collection is refreshed, and searched again.

If none of these strategies are successful, then resolveView() returns null.

public virtual View ResolveView(
Project project,
String name
);

Parameters

project
The project that contains the desired view.
name
The view name.

Return Value

The resolved View, or null if it could not be resolved.

See Also

Application Class | StarTeam Namespace | Application.ResolveView Overload List | isAutoRefreshViewsEnabled


ToStarTeamURL Method

Borland StarTeam SDK for .NET

Application.ToStarTeamURL Method

Resolves the given StarTeam resource to a corresponding URL using an ID based scheme

Overload List

Resolves the given StarTeam resource to a corresponding URL using an ID based scheme

public virtual string ToStarTeamURL(Object);

Resolves the given StarTeam resource to a corresponding URL

public virtual string ToStarTeamURL(Object,Boolean,Boolean);

See Also

Application Class | StarTeam Namespace


Application.ToStarTeamURL Method (Object)

Resolves the given StarTeam resource to a corresponding URL using an ID based scheme

public virtual string ToStarTeamURL(
Object _object
);

Parameters

_object

Return Value

a String URL that uniquely identifies the resource

See Also

Application Class | StarTeam Namespace | Application.ToStarTeamURL Overload List


Application.ToStarTeamURL Method (Object, Boolean, Boolean)

Resolves the given StarTeam resource to a corresponding URL

public virtual string ToStarTeamURL(
Object _object,
Boolean useIDBasedScheme,
Boolean useGUIDbasedScheme
);

Parameters

_object
useIDBasedScheme
True to use an ID Based Scheme, False to use a Name Based Scheme
useGUIDbasedScheme
True to use a GUID Based Scheme, False to use a {host name, port} Based Scheme

Return Value

a String URL that uniquely identifies the resource

See Also

Application Class | StarTeam Namespace | Application.ToStarTeamURL Overload List


Application.ToString Method

Delegate ToString() to com.starteam.Application.

public override string ToString();

Return Value

com.starteam.Application.ToString()

See Also

Application Class | StarTeam Namespace


Application.ResolveOptions Class

Options that control the behavior of an Application's resolve operations.

For a list of all members of this type, see Application.ResolveOptions Members.

System.Object
Application.ResolveOptions

public class Application.ResolveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Application.ResolveOptions Members | StarTeam Namespace


Application.ResolveOptions Members

Application.ResolveOptions overview

Public Instance Properties

AutoRefreshAllEnabled | [write] Enables or disabled auto-refresh for all supported resource types. If a requested resource is not found in the appropriate collection, and auto-refresh is enabled for that resource, then the collection is automatically refreshed to match the latest resources in the repository, and the search is repeated. Auto-refresh is disabled by default.
IsAutoLogonEnabled | [read/write] true if autologon is enabled, and false otherwise.
IsAutoRefreshProjectsEnabled | [read/write] true if auto-refresh is enabled for projects, and false otherwise.
IsAutoRefreshViewsEnabled | [read/write] true if auto-refresh is enabled for views, and false otherwise.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Application.ResolveOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.Application.ResolveOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Application.ResolveOptions.

See Also

Application.ResolveOptions Class | StarTeam Namespace


Application.ResolveOptions Properties

The properties of the Application.ResolveOptions class are listed below. For a complete list of Application.ResolveOptions class members, see the Application.ResolveOptions Members topic.

Public Instance Properties

AutoRefreshAllEnabled | [write] Enables or disabled auto-refresh for all supported resource types. If a requested resource is not found in the appropriate collection, and auto-refresh is enabled for that resource, then the collection is automatically refreshed to match the latest resources in the repository, and the search is repeated. Auto-refresh is disabled by default.
IsAutoLogonEnabled | [read/write] true if autologon is enabled, and false otherwise.
IsAutoRefreshProjectsEnabled | [read/write] true if auto-refresh is enabled for projects, and false otherwise.
IsAutoRefreshViewsEnabled | [read/write] true if auto-refresh is enabled for views, and false otherwise.

See Also

Application.ResolveOptions Class | StarTeam Namespace


AutoRefreshAllEnabled Property

Borland StarTeam SDK for .NET

Application.ResolveOptions.AutoRefreshAllEnabled Property

[write] Enables or disabled auto-refresh for all supported resource types.

If a requested resource is not found in the appropriate collection, and auto-refresh is enabled for that resource, then the collection is automatically refreshed to match the latest resources in the repository, and the search is repeated.

Auto-refresh is disabled by default.

public virtual Boolean AutoRefreshAllEnabled {set;}

Property Value

Enables or disabled auto-refresh for all supported resource types.

If a requested resource is not found in the appropriate collection, and auto-refresh is enabled for that resource, then the collection is automatically refreshed to match the latest resources in the repository, and the search is repeated.

Auto-refresh is disabled by default.

See Also

Application.ResolveOptions Class | StarTeam Namespace


IsAutoLogonEnabled Property

Borland StarTeam SDK for .NET

Application.ResolveOptions.IsAutoLogonEnabled Property

[read/write] true if autologon is enabled, and false otherwise.

public virtual Boolean IsAutoLogonEnabled {get; set;}

Property Value

true if autologon is enabled, and false otherwise.

See Also

Application.ResolveOptions Class | StarTeam Namespace


IsAutoRefreshProjectsEnabled Property

Borland StarTeam SDK for .NET

Application.ResolveOptions.IsAutoRefreshProjectsEnabled Property

[read/write] true if auto-refresh is enabled for projects, and false otherwise.

public virtual Boolean IsAutoRefreshProjectsEnabled {get; set;}

Property Value

true if auto-refresh is enabled for projects, and false otherwise.

See Also

Application.ResolveOptions Class | StarTeam Namespace


IsAutoRefreshViewsEnabled Property

Borland StarTeam SDK for .NET

Application.ResolveOptions.IsAutoRefreshViewsEnabled Property

[read/write] true if auto-refresh is enabled for views, and false otherwise.

public virtual Boolean IsAutoRefreshViewsEnabled {get; set;}

Property Value

true if auto-refresh is enabled for views, and false otherwise.

See Also

Application.ResolveOptions Class | StarTeam Namespace


Application.ResolveOptions Methods

The methods of the Application.ResolveOptions class are listed below. For a complete list of Application.ResolveOptions class members, see the Application.ResolveOptions Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Application.ResolveOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.Application.ResolveOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Application.ResolveOptions.

See Also

Application.ResolveOptions Class | StarTeam Namespace


Application.ResolveOptions.Equals Method

Delegate Equals() to com.starteam.Application.ResolveOptions.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Application.ResolveOptions.Equals(obj).

See Also

Application.ResolveOptions Class | StarTeam Namespace


Application.ResolveOptions.GetHashCode Method

Delegate GetHashCode() to com.starteam.Application.ResolveOptions.

public override int GetHashCode();

Return Value

com.starteam.Application.ResolveOptions.GetHashCode().

See Also

Application.ResolveOptions Class | StarTeam Namespace


Application.ResolveOptions.ToString Method

Delegate ToString() to com.starteam.Application.ResolveOptions.

public override string ToString();

Return Value

com.starteam.Application.ResolveOptions.ToString()

See Also

Application.ResolveOptions Class | StarTeam Namespace


ArtifactCache Class

An artifact cache is a collection of artifacts of different types The cache creates and maintains a private connection to the StarTeam server, using the credentials specified in the constructor This connection is closed when the cache is discarded. Well behaved applications should call the {@link #close()} api. The cache manages the artifacts requested, and access rights to these artifacts General queries may be constructed of the form Does a given principal have the right to read (or write) to an object in this cache Typically, the cache is built up in the context of an Administrator, but cached objects are shared across less privileged users, depending upon their access rights This is a self-refreshing cache; refreshes are requested on a regular timer With MPX enabled, the refreshes are optimized to execute the fewest possible server commands Note that while it is certainly reasonable and expected for the calling application to have enabled MPX and registered the server object with a CacheAgent, this cache itself attempts to enable MPX, if required. However, the cache makes no attempt to auto locate a cache agent. There are two reasons for this Auto locating a cache agent makes no guarantees about the nearness of the cache agent. Auto location is based solely on which cache agent responds first to a broadcast When used in the context of a web server (the primary motif for this class) it is generally expected that the web service application is network near to the StarTeam server. In this case, a Cache Agent offers little to no performance benefit, and in some cases may even cause a potential degradation in overall performance and throughput. An application can however, explicitly locate a cache agent using {@link Server#locateCacheAgent(String, int)}

For a list of all members of this type, see ArtifactCache Members.

System.Object
ArtifactCache

public class ArtifactCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ArtifactCache Members | StarTeam Namespace


ArtifactCache Members

ArtifactCache overview

Public Instance Properties

BaselineTime | [read] the configuration time of the baseline or NULL
IsBaseline | [read] true if this is a baseline cache
IsOpen | [read] true if this artifact cache is open
LastUsedAt | [read] the time at which this Cache was last used
Manager | [read] the artifact cache manager that owns this cache

Public Instance Methods

CacheViewMembers | Overloaded.
Equals | Delegate Equals() to com.starteam.ArtifactCache.
ForceRefresh | force a full refresh of the cache, spanning all cached projects, views and types. this is an expensive operation that should typically only be performed if the cache is not responding correctly, or out of sync, and after logging all other users out. This is a blocking operation which will return when the refresh is complete. The operation itself is only meaningful on tip caches, and will no-op for rolled back caches
GetHashCode | Delegate GetHashCode() to com.starteam.ArtifactCache.
GetType (inherited from Object) | Gets the Type of the current instance.
IsCached | Overloaded.
NewWebCacheMPXStatusEventSource |
NewWebCacheServerControlEventSource |
Refresh | refresh the cache. This is a self-refreshing cache, and this method fires once per refresh period. However, any application thread may independently request that the cache be refreshed. With MPX enabled, a cache refresh attempts to update the cache in place, with the least possible number of server calls (if any) Refreshing a rolled back (historical cache) does nothing.
Remove | Overloaded.
ToString | Delegate ToString() to com.starteam.ArtifactCache.

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCache Properties

The properties of the ArtifactCache class are listed below. For a complete list of ArtifactCache class members, see the ArtifactCache Members topic.

Public Instance Properties

BaselineTime | [read] the configuration time of the baseline or NULL
IsBaseline | [read] true if this is a baseline cache
IsOpen | [read] true if this artifact cache is open
LastUsedAt | [read] the time at which this Cache was last used
Manager | [read] the artifact cache manager that owns this cache

See Also

ArtifactCache Class | StarTeam Namespace


BaselineTime Property

Borland StarTeam SDK for .NET

ArtifactCache.BaselineTime Property

[read] the configuration time of the baseline or NULL

public virtual DateTime BaselineTime {get;}

Property Value

the configuration time of the baseline or NULL

See Also

ArtifactCache Class | StarTeam Namespace


IsBaseline Property

Borland StarTeam SDK for .NET

ArtifactCache.IsBaseline Property

[read] true if this is a baseline cache

public virtual Boolean IsBaseline {get;}

Property Value

true if this is a baseline cache

See Also

ArtifactCache Class | StarTeam Namespace


IsOpen Property

Borland StarTeam SDK for .NET

ArtifactCache.IsOpen Property

[read] true if this artifact cache is open

public virtual Boolean IsOpen {get;}

Property Value

true if this artifact cache is open

See Also

ArtifactCache Class | StarTeam Namespace


LastUsedAt Property

Borland StarTeam SDK for .NET

ArtifactCache.LastUsedAt Property

[read] the time at which this Cache was last used

public virtual DateTime LastUsedAt {get;}

Property Value

the time at which this Cache was last used

See Also

ArtifactCache Class | StarTeam Namespace


Manager Property

Borland StarTeam SDK for .NET

ArtifactCache.Manager Property

[read] the artifact cache manager that owns this cache

public virtual ArtifactCacheManager Manager {get;}

Property Value

the artifact cache manager that owns this cache

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCache Methods

The methods of the ArtifactCache class are listed below. For a complete list of ArtifactCache class members, see the ArtifactCache Members topic.

Public Instance Methods

CacheViewMembers | Overloaded.
Equals | Delegate Equals() to com.starteam.ArtifactCache.
ForceRefresh | force a full refresh of the cache, spanning all cached projects, views and types. this is an expensive operation that should typically only be performed if the cache is not responding correctly, or out of sync, and after logging all other users out. This is a blocking operation which will return when the refresh is complete. The operation itself is only meaningful on tip caches, and will no-op for rolled back caches
GetHashCode | Delegate GetHashCode() to com.starteam.ArtifactCache.
GetType (inherited from Object) | Gets the Type of the current instance.
IsCached | Overloaded.
NewWebCacheMPXStatusEventSource |
NewWebCacheServerControlEventSource |
Refresh | refresh the cache. This is a self-refreshing cache, and this method fires once per refresh period. However, any application thread may independently request that the cache be refreshed. With MPX enabled, a cache refresh attempts to update the cache in place, with the least possible number of server calls (if any) Refreshing a rolled back (historical cache) does nothing.
Remove | Overloaded.
ToString | Delegate ToString() to com.starteam.ArtifactCache.

See Also

ArtifactCache Class | StarTeam Namespace


CacheViewMembers Method

Borland StarTeam SDK for .NET

ArtifactCache.CacheViewMembers Method

Overload List

public virtual void CacheViewMembers(View.WebCacheView,ViewMember.Type.WebCacheViewMemberType);

public virtual void CacheViewMembers(View.WebCacheView,WebCacheViewMemberType[]);

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCache.CacheViewMembers Method (View#WebCacheView, ViewMember#Type#WebCacheViewMemberType)

public virtual void CacheViewMembers(
View.WebCacheView view,
ViewMember.Type.WebCacheViewMemberType type
);

See Also

ArtifactCache Class | StarTeam Namespace | ArtifactCache.CacheViewMembers Overload List


ArtifactCache.CacheViewMembers Method (View#WebCacheView, ViewMember#Type#WebCacheViewMemberType[])

public virtual void CacheViewMembers(
View.WebCacheView view,
WebCacheViewMemberType[] types
);

See Also

ArtifactCache Class | StarTeam Namespace | ArtifactCache.CacheViewMembers Overload List


ArtifactCache.Equals Method

Delegate Equals() to com.starteam.ArtifactCache.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ArtifactCache.Equals(obj).

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCache.ForceRefresh Method

force a full refresh of the cache, spanning all cached projects, views and types. this is an expensive operation that should typically only be performed if the cache is not responding correctly, or out of sync, and after logging all other users out. This is a blocking operation which will return when the refresh is complete. The operation itself is only meaningful on tip caches, and will no-op for rolled back caches

public virtual void ForceRefresh();

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCache.GetHashCode Method

Delegate GetHashCode() to com.starteam.ArtifactCache.

public override int GetHashCode();

Return Value

com.starteam.ArtifactCache.GetHashCode().

See Also

ArtifactCache Class | StarTeam Namespace


IsCached Method

Borland StarTeam SDK for .NET

ArtifactCache.IsCached Method

Overload List

public virtual bool IsCached(View.WebCacheView);

public virtual bool IsCached(View.WebCacheView,ViewMember.Type.WebCacheViewMemberType);

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCache.IsCached Method (View#WebCacheView)

public virtual bool IsCached(
View.WebCacheView view
);

See Also

ArtifactCache Class | StarTeam Namespace | ArtifactCache.IsCached Overload List


ArtifactCache.IsCached Method (View#WebCacheView, ViewMember#Type#WebCacheViewMemberType)

public virtual bool IsCached(
View.WebCacheView view,
ViewMember.Type.WebCacheViewMemberType type
);

See Also

ArtifactCache Class | StarTeam Namespace | ArtifactCache.IsCached Overload List


ArtifactCache.NewWebCacheMPXStatusEventSource Method

public WebCacheMPXStatusEventSource NewWebCacheMPXStatusEventSource();

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCache.NewWebCacheServerControlEventSource Method

public WebCacheServerControlEventSource NewWebCacheServerControlEventSource();

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCache.Refresh Method

refresh the cache. This is a self-refreshing cache, and this method fires once per refresh period. However, any application thread may independently request that the cache be refreshed. With MPX enabled, a cache refresh attempts to update the cache in place, with the least possible number of server calls (if any) Refreshing a rolled back (historical cache) does nothing.

public virtual void Refresh();

See Also

ArtifactCache Class | StarTeam Namespace


Remove Method

Borland StarTeam SDK for .NET

ArtifactCache.Remove Method

Overload List

public virtual void Remove(Project.WebCacheProject);

public virtual void Remove(View.WebCacheView);

discard all unneeded data that has built up in the ArtifactCache since the last discard the calling application specifies the discard time, a boundary that coincides with the last synchronization time of the StarTeam server w.r.t the target server. Note that a call to this api purges unneeded cached data from memory, spanning all views currently managed by this cache. The goal is to keep the memory footprint of the artifact cache as light weight as possible, for multi-threaded, multi-session bridge applications. It does not remove any artifacts either from the server or the cache itself. It does reduce the cached objects to the bare minimum number of property values required to keep the cache up-to-date but not trigger server commands.

public virtual void Remove(DateTime);

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCache.Remove Method (Project#WebCacheProject)

public virtual void Remove(
Project.WebCacheProject p
);

See Also

ArtifactCache Class | StarTeam Namespace | ArtifactCache.Remove Overload List


ArtifactCache.Remove Method (View#WebCacheView)

public virtual void Remove(
View.WebCacheView vw
);

See Also

ArtifactCache Class | StarTeam Namespace | ArtifactCache.Remove Overload List


ArtifactCache.Remove Method (DateTime)

discard all unneeded data that has built up in the ArtifactCache since the last discard the calling application specifies the discard time, a boundary that coincides with the last synchronization time of the StarTeam server w.r.t the target server. Note that a call to this api purges unneeded cached data from memory, spanning all views currently managed by this cache. The goal is to keep the memory footprint of the artifact cache as light weight as possible, for multi-threaded, multi-session bridge applications. It does not remove any artifacts either from the server or the cache itself. It does reduce the cached objects to the bare minimum number of property values required to keep the cache up-to-date but not trigger server commands.

public virtual void Remove(
DateTime dttm
);

Parameters

dttm
the time upto which cache data should be discarded. The calling application is responsible for determining this time, and using it to weed out processed data across all open views. As time moves forward, it is expected that calling applications will periodically call this api with a more current time that reflects all data processed in the artifact cache so far.

See Also

ArtifactCache Class | StarTeam Namespace | ArtifactCache.Remove Overload List


ArtifactCache.ToString Method

Delegate ToString() to com.starteam.ArtifactCache.

public override string ToString();

Return Value

com.starteam.ArtifactCache.ToString()

See Also

ArtifactCache Class | StarTeam Namespace


ArtifactCacheManager Class

A collection of ArtifactCache's managed for a given server. The framework owns these caches and the associated baselines, so that all web client applications (if loaded in the same JRE) will be able to access each others cache and share types across caches The managed caches comprise tip and baselines, i.e. rolled back configurations (identified by Context) The Tip Artifact caches all interesting projects, views and types (as determined by the caller) In contrast, each rolled back cache contains all the types for a single rolled back view

For a list of all members of this type, see ArtifactCacheManager Members.

System.Object
ArtifactCacheManager

public class ArtifactCacheManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ArtifactCacheManager Members | StarTeam Namespace


ArtifactCacheManager Members

ArtifactCacheManager overview

Public Static Properties

AllArtifactCacheManagers | [read] the set of all artifact cache managers registered in this cache
ApplicationStore |

Public Static Methods

DropUnusedCachesAfter | Drop all Cached Data that is no longer in use after a pre-specified interval of time.
GetManager | returns an artifact cache manager responsible for managing the caches for a server or NULL
Register | Overloaded. Always registers the Artifact Cache for the global system administrative content. This will be used for on-premise applications and for starting up the REST server in a hosted system
ResetRefreshPeriod | Reset the refresh period for the artifact cache managers. The default refresh period is set to 30 seconds.
Unregister | Overloaded. remove an artifact cache manager from the cache. well behaved applications will always call this api on shutdown

Public Instance Properties

AllHistoricalCaches | [read] the set of all historical Artifact Caches
AllRegisteredClients | [read] the set of all registered clients
GUID | [read] the GUID for this ArtifactCacheManager

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ArtifactCacheManager.
GetCache |
GetClient | Return the Client described by the specified Application Name or null if there is no client registered matching this application name Applications may choose to maintain their own Client Context, or allow the ArtifactCacheManager to maintain the Client context on their behalf
GetContext | Overloaded.
GetHashCode | Delegate GetHashCode() to com.starteam.ArtifactCacheManager.
GetType (inherited from Object) | Gets the Type of the current instance.
HasCache |
Register | Overloaded.
RegisterClient | Register a Client for this ArtifactCacheManager. Once registered, whenever a baseline cache is requested through this ArtifactCacheManager, all registered clients will be queried and their types will be cached in the ArtifactCacheManager Attempting to re-register a client with an existing name will throw an IllegalStateException If this client is interested in listening for events, listener interfaces must be attached to the client, and finally the client itself must be registered with the tip artifact cache
ToString | Delegate ToString() to com.starteam.ArtifactCacheManager.
Unregister | Overloaded.

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager Properties

The properties of the ArtifactCacheManager class are listed below. For a complete list of ArtifactCacheManager class members, see the ArtifactCacheManager Members topic.

Public Static Properties

AllArtifactCacheManagers | [read] the set of all artifact cache managers registered in this cache
ApplicationStore |

Public Instance Properties

AllHistoricalCaches | [read] the set of all historical Artifact Caches
AllRegisteredClients | [read] the set of all registered clients
GUID | [read] the GUID for this ArtifactCacheManager

See Also

ArtifactCacheManager Class | StarTeam Namespace


AllArtifactCacheManagers Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.AllArtifactCacheManagers Property

[read] the set of all artifact cache managers registered in this cache

public static ArtifactCacheManager[] AllArtifactCacheManagers {get;}

Property Value

the set of all artifact cache managers registered in this cache

See Also

ArtifactCacheManager Class | StarTeam Namespace


AllHistoricalCaches Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.AllHistoricalCaches Property

[read] the set of all historical Artifact Caches

public virtual ArtifactCache[] AllHistoricalCaches {get;}

Property Value

the set of all historical Artifact Caches

See Also

ArtifactCacheManager Class | StarTeam Namespace


AllRegisteredClients Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.AllRegisteredClients Property

[read] the set of all registered clients

public virtual Client[] AllRegisteredClients {get;}

Property Value

the set of all registered clients

See Also

ArtifactCacheManager Class | StarTeam Namespace


ApplicationStore Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.ApplicationStore Property

public static Hashtable ApplicationStore {get;}

See Also

ArtifactCacheManager Class | StarTeam Namespace


GUID Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.GUID Property

[read] the GUID for this ArtifactCacheManager

public virtual String GUID {get;}

Property Value

the GUID for this ArtifactCacheManager

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager Methods

The methods of the ArtifactCacheManager class are listed below. For a complete list of ArtifactCacheManager class members, see the ArtifactCacheManager Members topic.

Public Static Methods

DropUnusedCachesAfter | Drop all Cached Data that is no longer in use after a pre-specified interval of time.
GetManager | returns an artifact cache manager responsible for managing the caches for a server or NULL
Register | Overloaded. Always registers the Artifact Cache for the global system administrative content. This will be used for on-premise applications and for starting up the REST server in a hosted system
ResetRefreshPeriod | Reset the refresh period for the artifact cache managers. The default refresh period is set to 30 seconds.
Unregister | Overloaded. remove an artifact cache manager from the cache. well behaved applications will always call this api on shutdown

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ArtifactCacheManager.
GetCache |
GetClient | Return the Client described by the specified Application Name or null if there is no client registered matching this application name Applications may choose to maintain their own Client Context, or allow the ArtifactCacheManager to maintain the Client context on their behalf
GetContext | Overloaded.
GetHashCode | Delegate GetHashCode() to com.starteam.ArtifactCacheManager.
GetType (inherited from Object) | Gets the Type of the current instance.
HasCache |
Register | Overloaded.
RegisterClient | Register a Client for this ArtifactCacheManager. Once registered, whenever a baseline cache is requested through this ArtifactCacheManager, all registered clients will be queried and their types will be cached in the ArtifactCacheManager Attempting to re-register a client with an existing name will throw an IllegalStateException If this client is interested in listening for events, listener interfaces must be attached to the client, and finally the client itself must be registered with the tip artifact cache
ToString | Delegate ToString() to com.starteam.ArtifactCacheManager.
Unregister | Overloaded.

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager.DropUnusedCachesAfter Method

Drop all Cached Data that is no longer in use after a pre-specified interval of time.

public static void DropUnusedCachesAfter(
Int32 hours
);

Parameters

hours

See Also

ArtifactCacheManager Class | StarTeam Namespace | isCached | isCached | getAllHistoricalCaches | hasCache


ArtifactCacheManager.Equals Method

Delegate Equals() to com.starteam.ArtifactCacheManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ArtifactCacheManager.Equals(obj).

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager.GetCache Method

public virtual ArtifactCache GetCache(
ArtifactCacheManager.Context ctxt
);

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager.GetClient Method

Return the Client described by the specified Application Name or null if there is no client registered matching this application name Applications may choose to maintain their own Client Context, or allow the ArtifactCacheManager to maintain the Client context on their behalf

public virtual Client GetClient(
String applicationName
);

Parameters

applicationName
the application name

Return Value

the Client described by the specified Application Name

See Also

ArtifactCacheManager Class | StarTeam Namespace


GetContext Method

Borland StarTeam SDK for .NET

ArtifactCacheManager.GetContext Method

Overload List

public virtual Context GetContext(View.WebCacheView,Label.WebCacheLabel);

public virtual Context GetContext(View.WebCacheView,DateTime);

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager.GetContext Method (View#WebCacheView, Label#WebCacheLabel)

public virtual Context GetContext(
View.WebCacheView vw,
Label.WebCacheLabel lbl
);

See Also

ArtifactCacheManager Class | StarTeam Namespace | ArtifactCacheManager.GetContext Overload List


ArtifactCacheManager.GetContext Method (View#WebCacheView, DateTime)

public virtual Context GetContext(
View.WebCacheView vw,
DateTime dt
);

See Also

ArtifactCacheManager Class | StarTeam Namespace | ArtifactCacheManager.GetContext Overload List


ArtifactCacheManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.ArtifactCacheManager.

public override int GetHashCode();

Return Value

com.starteam.ArtifactCacheManager.GetHashCode().

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager.GetManager Method

returns an artifact cache manager responsible for managing the caches for a server or NULL

public static ArtifactCacheManager GetManager(
String guid
);

Parameters

guid
the GUID describing the repository (server)

Return Value

a artifact cache manager or NULL

See Also

ArtifactCacheManager Class | StarTeam Namespace | getRepositoryID


ArtifactCacheManager.HasCache Method

public virtual bool HasCache(
ArtifactCacheManager.Context ctxt
);

See Also

ArtifactCacheManager Class | StarTeam Namespace


Register Method

Borland StarTeam SDK for .NET

ArtifactCacheManager.Register Method

Always registers the Artifact Cache for the global system administrative content. This will be used for on-premise applications and for starting up the REST server in a hosted system

Overload List

Always registers the Artifact Cache for the global system administrative content. This will be used for on-premise applications and for starting up the REST server in a hosted system

public static Context Register(ServerInfo);

create an artifact cache manager with the given connectivity and credentials Tenant Artifact Caches cannot be registered until the global system artifact cache has been registered This requirement ensures that MPX is enabled on a permanently connected global artifact cache and that the global administrative user context has been set up. Multi tenancy is only supported from 14.0+ servers in a hosted environment.

public static Context Register(ServerInfo,Int32);

public virtual Context Register(View.WebCacheView,Label.WebCacheLabel);

public virtual Context Register(View.WebCacheView,DateTime);

public static Context Register(FileInfo);

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager.Register Method (ServerInfo)

Always registers the Artifact Cache for the global system administrative content. This will be used for on-premise applications and for starting up the REST server in a hosted system

public static Context Register(
ServerInfo si
);

Parameters

si
the ServerInfo to register

Return Value

the registered baseline artifact cache manager context representing the logged in user

See Also

ArtifactCacheManager Class | StarTeam Namespace | ArtifactCacheManager.Register Overload List


ArtifactCacheManager.Register Method (ServerInfo, Int32)

create an artifact cache manager with the given connectivity and credentials Tenant Artifact Caches cannot be registered until the global system artifact cache has been registered This requirement ensures that MPX is enabled on a permanently connected global artifact cache and that the global administrative user context has been set up. Multi tenancy is only supported from 14.0+ servers in a hosted environment.

public static Context Register(
ServerInfo si,
Int32 tenantID
);

Parameters

si
the ServerInfo to register
tenantID
the tenant to start up

Return Value

the registered baseline artifact cache manager context representing the tenant administrator

See Also

ArtifactCacheManager Class | StarTeam Namespace | ArtifactCacheManager.Register Overload List


ArtifactCacheManager.Register Method (View#WebCacheView, Label#WebCacheLabel)

public virtual Context Register(
View.WebCacheView vw,
Label.WebCacheLabel lbl
);

See Also

ArtifactCacheManager Class | StarTeam Namespace | ArtifactCacheManager.Register Overload List


ArtifactCacheManager.Register Method (View#WebCacheView, DateTime)

public virtual Context Register(
View.WebCacheView vw,
DateTime dt
);

See Also

ArtifactCacheManager Class | StarTeam Namespace | ArtifactCacheManager.Register Overload List


ArtifactCacheManager.Register Method (FileInfo)

public static Context Register(
FileInfo fl
);

See Also

ArtifactCacheManager Class | StarTeam Namespace | ArtifactCacheManager.Register Overload List


ArtifactCacheManager.RegisterClient Method

Register a Client for this ArtifactCacheManager. Once registered, whenever a baseline cache is requested through this ArtifactCacheManager, all registered clients will be queried and their types will be cached in the ArtifactCacheManager Attempting to re-register a client with an existing name will throw an IllegalStateException If this client is interested in listening for events, listener interfaces must be attached to the client, and finally the client itself must be registered with the tip artifact cache

public virtual Client RegisterClient(
String appName
);

Parameters

appName
the client to register

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager.ResetRefreshPeriod Method

Reset the refresh period for the artifact cache managers. The default refresh period is set to 30 seconds.

public static void ResetRefreshPeriod(
Int32 refreshPeriod
);

Parameters

refreshPeriod
the new refresh period

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager.ToString Method

Delegate ToString() to com.starteam.ArtifactCacheManager.

public override string ToString();

Return Value

com.starteam.ArtifactCacheManager.ToString()

See Also

ArtifactCacheManager Class | StarTeam Namespace


Unregister Method

Borland StarTeam SDK for .NET

ArtifactCacheManager.Unregister Method

Overload List

public virtual void Unregister(ArtifactCacheManager.Context);

remove an artifact cache manager from the cache. well behaved applications will always call this api on shutdown

public static void Unregister(String);

See Also

ArtifactCacheManager Class | StarTeam Namespace


ArtifactCacheManager.Unregister Method (ArtifactCacheManager#Context)

public virtual void Unregister(
ArtifactCacheManager.Context ctxt
);

See Also

ArtifactCacheManager Class | StarTeam Namespace | ArtifactCacheManager.Unregister Overload List


ArtifactCacheManager.Unregister Method (String)

remove an artifact cache manager from the cache. well behaved applications will always call this api on shutdown

public static void Unregister(
String guid
);

Parameters

guid
the GUID describing the repository (server)

See Also

ArtifactCacheManager Class | StarTeam Namespace | ArtifactCacheManager.Unregister Overload List


ArtifactCacheManager.Client Class

Establish the context of a Client Application. If interested, each Client Application must provide a unique context uniqueness defined by Application Name, e.g. Caliber, Topaz, Zuma, SCTM, etc A client application will create and retain a single context instance per server. Alternately, a client application may choose to allow the ArtifactCacheManager to hold onto its context (keyed by name). An application should register its Client Context with the ArtifactCacheManager immediately after starting up the Manager, and before requesting baselines. Subsequent baseline registrations will cache the set of types defined by the client

For a list of all members of this type, see ArtifactCacheManager.Client Members.

System.Object
ArtifactCacheManager.Client

public class ArtifactCacheManager.Client

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ArtifactCacheManager.Client Members | StarTeam Namespace


ArtifactCacheManager.Client Members

ArtifactCacheManager.Client overview

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ArtifactCacheManager.Client.
GetHashCode | Delegate GetHashCode() to com.starteam.ArtifactCacheManager.Client.
GetType (inherited from Object) | Gets the Type of the current instance.
Register | Overloaded.
ToString | Delegate ToString() to com.starteam.ArtifactCacheManager.Client.
Unregister | Overloaded.

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace


ArtifactCacheManager.Client Methods

The methods of the ArtifactCacheManager.Client class are listed below. For a complete list of ArtifactCacheManager.Client class members, see the ArtifactCacheManager.Client Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ArtifactCacheManager.Client.
GetHashCode | Delegate GetHashCode() to com.starteam.ArtifactCacheManager.Client.
GetType (inherited from Object) | Gets the Type of the current instance.
Register | Overloaded.
ToString | Delegate ToString() to com.starteam.ArtifactCacheManager.Client.
Unregister | Overloaded.

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace


ArtifactCacheManager.Client.Equals Method

Delegate Equals() to com.starteam.ArtifactCacheManager.Client.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ArtifactCacheManager.Client.Equals(obj).

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace


ArtifactCacheManager.Client.GetHashCode Method

Delegate GetHashCode() to com.starteam.ArtifactCacheManager.Client.

public override int GetHashCode();

Return Value

com.starteam.ArtifactCacheManager.Client.GetHashCode().

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace


Register Method

Borland StarTeam SDK for .NET

ArtifactCacheManager.Client.Register Method

Overload List

public virtual void Register(ViewMember.Type.WebCacheViewMemberType);

public virtual void Register(WebCacheViewMemberType[]);

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace


ArtifactCacheManager.Client.Register Method (ViewMember#Type#WebCacheViewMemberType)

public virtual void Register(
ViewMember.Type.WebCacheViewMemberType type
);

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace | ArtifactCacheManager.Client.Register Overload List


ArtifactCacheManager.Client.Register Method (ViewMember#Type#WebCacheViewMemberType[])

public virtual void Register(
WebCacheViewMemberType[] types
);

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace | ArtifactCacheManager.Client.Register Overload List


ArtifactCacheManager.Client.ToString Method

Delegate ToString() to com.starteam.ArtifactCacheManager.Client.

public override string ToString();

Return Value

com.starteam.ArtifactCacheManager.Client.ToString()

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace


Unregister Method

Borland StarTeam SDK for .NET

ArtifactCacheManager.Client.Unregister Method

Overload List

public virtual void Unregister(ViewMember.Type.WebCacheViewMemberType);

public virtual void Unregister(WebCacheViewMemberType[]);

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace


ArtifactCacheManager.Client.Unregister Method (ViewMember#Type#WebCacheViewMemberType)

public virtual void Unregister(
ViewMember.Type.WebCacheViewMemberType type
);

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace | ArtifactCacheManager.Client.Unregister Overload List


ArtifactCacheManager.Client.Unregister Method (ViewMember#Type#WebCacheViewMemberType[])

public virtual void Unregister(
WebCacheViewMemberType[] types
);

See Also

ArtifactCacheManager.Client Class | StarTeam Namespace | ArtifactCacheManager.Client.Unregister Overload List


ArtifactCacheManager.Context Class

Establish the context in which a web application will execute some session specific requirement. The context may be as coarse or fine grained as desired. A context may be resolved to one and only one StarTeam object. The rules will be applied deterministically, to guard against the possibility of conflict The user is responsible for the integrity of the various id's stored in the object

For a list of all members of this type, see ArtifactCacheManager.Context Members.

System.Object
ArtifactCacheManager.Context

public class ArtifactCacheManager.Context

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ArtifactCacheManager.Context Members | StarTeam Namespace


ArtifactCacheManager.Context Members

ArtifactCacheManager.Context overview

Public Static Methods

CreateFrom Overloaded. Create a rolled back Context for a user session. A rolled back context targets a view specific rolled back artifact cache and cannot be used against the tip cache (or vice versa)

Public Instance Constructors

ArtifactCacheManager.Context Constructor Create a Tip Context for a user session. Tip Context targets the Tip artifact cache and cannot be used for a rolled back or baseline cache (or vice versa)

Public Instance Properties

ArtifactCache | [read] the ArtifactCache whose context is described by this object
ArtifactCacheManager | [read] the ArtifactCacheManager whose context is described by this object
DateTime | [read] the datetime for this context
GUID | [read] the GUID for this context
ImpersonationTime | [read/write] the impersonation time assigned
IsTip | [read] True if this context represents a Tip Configuration
Label | [read] the label for this context
Server | [read] the Server for this context
User | [read] the user whose context is described by this object
UserID | [read] the userid for this context
View | [read] the View for this context or NULL
ViewID | [read] the viewID for this context

Public Instance Methods

Copy | returns a copy of this Context
Equals | Delegate Equals() to com.starteam.ArtifactCacheManager.Context.
GetHashCode | Delegate GetHashCode() to com.starteam.ArtifactCacheManager.Context.
GetType (inherited from Object) | Gets the Type of the current instance.
Resolve | Resolve a given {hostname, port, ID} based StarTeam URL to an object in the Artifact Cache represented by this context. The URL is expected to be the output of Application.toStarTeamURL(ViewMember), using an ID based scheme Note that if the targeted {view, type} tuple for the resolved artifact is not yet cached in the Artifact Cache, then this implementation will go ahead and cache the corresponding artifact set. In this latter (hopefully rare) case, the call to resolve will block until the caching is completed.
ResolveType | Resolve a given {hostname, port, ID} based StarTeam URL to an object in the Artifact Cache represented by this context. The URL is expected to be the output of Application.toStarTeamURL(ViewMember), using an ID based scheme
ResolveView | Resolve a given {hostname, port, ID} based StarTeam URL to a view in the Artifact Cache represented by this context. The URL is expected to be the output of Application.toStarTeamURL(ViewMember), using an ID based scheme
ToString | Delegate ToString() to com.starteam.ArtifactCacheManager.Context.

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Context Constructor

Create a Tip Context for a user session. Tip Context targets the Tip artifact cache and cannot be used for a rolled back or baseline cache (or vice versa)

public ArtifactCacheManager.Context(
String guid,
Int32 userid
);

Parameters

guid
the server GUID
userid
the user

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Context Properties

The properties of the ArtifactCacheManager.Context class are listed below. For a complete list of ArtifactCacheManager.Context class members, see the ArtifactCacheManager.Context Members topic.

Public Instance Properties

ArtifactCache | [read] the ArtifactCache whose context is described by this object
ArtifactCacheManager | [read] the ArtifactCacheManager whose context is described by this object
DateTime | [read] the datetime for this context
GUID | [read] the GUID for this context
ImpersonationTime | [read/write] the impersonation time assigned
IsTip | [read] True if this context represents a Tip Configuration
Label | [read] the label for this context
Server | [read] the Server for this context
User | [read] the user whose context is described by this object
UserID | [read] the userid for this context
View | [read] the View for this context or NULL
ViewID | [read] the viewID for this context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCache Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.ArtifactCache Property

[read] the ArtifactCache whose context is described by this object

public virtual ArtifactCache ArtifactCache {get;}

Property Value

the ArtifactCache whose context is described by this object

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.ArtifactCacheManager Property

[read] the ArtifactCacheManager whose context is described by this object

public virtual ArtifactCacheManager ArtifactCacheManager {get;}

Property Value

the ArtifactCacheManager whose context is described by this object

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


DateTime Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.DateTime Property

[read] the datetime for this context

public virtual Double DateTime {get;}

Property Value

the datetime for this context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


GUID Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.GUID Property

[read] the GUID for this context

public virtual String GUID {get;}

Property Value

the GUID for this context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ImpersonationTime Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.ImpersonationTime Property

[read/write] the impersonation time assigned

public virtual Double ImpersonationTime {get; set;}

Property Value

the impersonation time assigned

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


IsTip Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.IsTip Property

[read] True if this context represents a Tip Configuration

public virtual Boolean IsTip {get;}

Property Value

True if this context represents a Tip Configuration

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


Label Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.Label Property

[read] the label for this context

public virtual Label.WebCacheLabel Label {get;}

Property Value

the label for this context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.Server Property

[read] the Server for this context

public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


User Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.User Property

[read] the user whose context is described by this object

public virtual User.WebCacheUser User {get;}

Property Value

the user whose context is described by this object

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


UserID Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.UserID Property

[read] the userid for this context

public virtual Int32 UserID {get;}

Property Value

the userid for this context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.View Property

[read] the View for this context or NULL

public virtual View.WebCacheView View {get;}

Property Value

the View for this context or NULL

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ViewID Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.ViewID Property

[read] the viewID for this context

public virtual Int32 ViewID {get;}

Property Value

the viewID for this context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Context Methods

The methods of the ArtifactCacheManager.Context class are listed below. For a complete list of ArtifactCacheManager.Context class members, see the ArtifactCacheManager.Context Members topic.

Public Static Methods

CreateFrom Overloaded. Create a rolled back Context for a user session. A rolled back context targets a view specific rolled back artifact cache and cannot be used against the tip cache (or vice versa)

Public Instance Methods

Copy | returns a copy of this Context
Equals | Delegate Equals() to com.starteam.ArtifactCacheManager.Context.
GetHashCode | Delegate GetHashCode() to com.starteam.ArtifactCacheManager.Context.
GetType (inherited from Object) | Gets the Type of the current instance.
Resolve | Resolve a given {hostname, port, ID} based StarTeam URL to an object in the Artifact Cache represented by this context. The URL is expected to be the output of Application.toStarTeamURL(ViewMember), using an ID based scheme Note that if the targeted {view, type} tuple for the resolved artifact is not yet cached in the Artifact Cache, then this implementation will go ahead and cache the corresponding artifact set. In this latter (hopefully rare) case, the call to resolve will block until the caching is completed.
ResolveType | Resolve a given {hostname, port, ID} based StarTeam URL to an object in the Artifact Cache represented by this context. The URL is expected to be the output of Application.toStarTeamURL(ViewMember), using an ID based scheme
ResolveView | Resolve a given {hostname, port, ID} based StarTeam URL to a view in the Artifact Cache represented by this context. The URL is expected to be the output of Application.toStarTeamURL(ViewMember), using an ID based scheme
ToString | Delegate ToString() to com.starteam.ArtifactCacheManager.Context.

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Context.Copy Method

returns a copy of this Context

public virtual Context Copy();

Return Value

a copy of this Context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


CreateFrom Method

Borland StarTeam SDK for .NET

ArtifactCacheManager.Context.CreateFrom Method

Create a rolled back Context for a user session. A rolled back context targets a view specific rolled back artifact cache and cannot be used against the tip cache (or vice versa)

Overload List

Create a rolled back Context for a user session. A rolled back context targets a view specific rolled back artifact cache and cannot be used against the tip cache (or vice versa)

public static Context CreateFrom(String,Int32,Int32,Double);

Create a rolled back Context for a user session. A rolled back context targets a view specific rolled back artifact cache and cannot be used against the tip cache (or vice versa)

public static Context CreateFrom(String,Int32,Int32,Int32);

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace | register


ArtifactCacheManager.Context.CreateFrom Method (String, Int32, Int32, Double)

Create a rolled back Context for a user session. A rolled back context targets a view specific rolled back artifact cache and cannot be used against the tip cache (or vice versa)

public static Context CreateFrom(
String guid,
Int32 userid,
Int32 viewID,
Double dateTime
);

Parameters

guid
the server GUID
userid
the user
viewID
the rolled back view
dateTime
the rolled back (historical) time

Return Value

a rolled back Context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace | ArtifactCacheManager.Context.CreateFrom Overload List | register


ArtifactCacheManager.Context.CreateFrom Method (String, Int32, Int32, Int32)

Create a rolled back Context for a user session. A rolled back context targets a view specific rolled back artifact cache and cannot be used against the tip cache (or vice versa)

public static Context CreateFrom(
String guid,
Int32 userid,
Int32 viewID,
Int32 labelID
);

Parameters

guid
the server GUID
userid
the user
viewID
the rolled back view
labelID
the label identifying a rolled back (historical) time

Return Value

a rolled back Context

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace | ArtifactCacheManager.Context.CreateFrom Overload List | ArtifactCacheManager


ArtifactCacheManager.Context.Equals Method

Delegate Equals() to com.starteam.ArtifactCacheManager.Context.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ArtifactCacheManager.Context.Equals(obj).

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Context.GetHashCode Method

Delegate GetHashCode() to com.starteam.ArtifactCacheManager.Context.

public override int GetHashCode();

Return Value

com.starteam.ArtifactCacheManager.Context.GetHashCode().

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Context.Resolve Method

Resolve a given {hostname, port, ID} based StarTeam URL to an object in the Artifact Cache represented by this context. The URL is expected to be the output of Application.toStarTeamURL(ViewMember), using an ID based scheme Note that if the targeted {view, type} tuple for the resolved artifact is not yet cached in the Artifact Cache, then this implementation will go ahead and cache the corresponding artifact set. In this latter (hopefully rare) case, the call to resolve will block until the caching is completed.

public virtual WebCacheViewMember Resolve(
String url
);

Parameters

url
the URL to resolve

Return Value

an object cached in this artifact cache

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Context.ResolveType Method

Resolve a given {hostname, port, ID} based StarTeam URL to an object in the Artifact Cache represented by this context. The URL is expected to be the output of Application.toStarTeamURL(ViewMember), using an ID based scheme

public virtual WebCacheType ResolveType(
String url
);

Parameters

url
the URL to resolve

Return Value

the type of artifact

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Context.ResolveView Method

Resolve a given {hostname, port, ID} based StarTeam URL to a view in the Artifact Cache represented by this context. The URL is expected to be the output of Application.toStarTeamURL(ViewMember), using an ID based scheme

public virtual WebCacheView ResolveView(
String url
);

Parameters

url
the URL to resolve

Return Value

the view represented by this URL

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Context.ToString Method

Delegate ToString() to com.starteam.ArtifactCacheManager.Context.

public override string ToString();

Return Value

com.starteam.ArtifactCacheManager.Context.ToString()

See Also

ArtifactCacheManager.Context Class | StarTeam Namespace


ArtifactCacheManager.Identifiable Interface

For a list of all members of this type, see ArtifactCacheManager.Identifiable Members.

public interface ArtifactCacheManager.Identifiable

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ArtifactCacheManager.Identifiable Members | StarTeam Namespace


ArtifactCacheManager.Identifiable Members

ArtifactCacheManager.Identifiable overview

Public Instance Properties

Identifier
IdentifierProperty

See Also

ArtifactCacheManager.Identifiable Interface | StarTeam Namespace


ArtifactCacheManager.Identifiable Properties

The properties of the ArtifactCacheManager.Identifiable interface are listed below. For a complete list of ArtifactCacheManager.Identifiable interface members, see the ArtifactCacheManager.Identifiable Members topic.

Public Instance Properties

Identifier
IdentifierProperty

See Also

ArtifactCacheManager.Identifiable Interface | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Identifiable.Identifier Property

Int32 Identifier {get;}

See Also

ArtifactCacheManager.Identifiable Interface | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Identifiable.IdentifierProperty Property

IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

See Also

ArtifactCacheManager.Identifiable Interface | StarTeam Namespace


ArtifactCacheManager.Nameable Interface

An object (artifact) that can provide a name via a name property.

For a list of all members of this type, see ArtifactCacheManager.Nameable Members.

public interface ArtifactCacheManager.Nameable

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ArtifactCacheManager.Nameable Members | StarTeam Namespace


ArtifactCacheManager.Nameable Members

ArtifactCacheManager.Nameable overview

Public Instance Properties

Name | [read] the name of this instance
NameProperty | [read] the property which provides a name

See Also

ArtifactCacheManager.Nameable Interface | StarTeam Namespace


ArtifactCacheManager.Nameable Properties

The properties of the ArtifactCacheManager.Nameable interface are listed below. For a complete list of ArtifactCacheManager.Nameable interface members, see the ArtifactCacheManager.Nameable Members topic.

Public Instance Properties

Name | [read] the name of this instance
NameProperty | [read] the property which provides a name

See Also

ArtifactCacheManager.Nameable Interface | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Nameable.Name Property

[read] the name of this instance

String Name {get;}

Property Value

the name of this instance

See Also

ArtifactCacheManager.Nameable Interface | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

ArtifactCacheManager.Nameable.NameProperty Property

[read] the property which provides a name

TextProperty.WebCacheTextProperty NameProperty {get;}

Property Value

the property which provides a name

See Also

ArtifactCacheManager.Nameable Interface | StarTeam Namespace


ArtifactCacheManager.Securable Interface

An object that can be secured in the repository. This is a marker interface for WebCache objects that 'wrap' instances of ISecurable

public interface ArtifactCacheManager.Securable

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam Namespace


ArtifactCacheManager.SecurableContainer Interface

A container in the repository that can hold secured objects of a given type. This is a marker interface for WebCache objects that 'wrap' instances of ISecurableContainer

public interface ArtifactCacheManager.SecurableContainer

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam Namespace


Audit Class

Represents a StarTeam Audit record

For a list of all members of this type, see Audit Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Audit

public class Audit : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit Members | StarTeam Namespace


Audit Members

Audit overview

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EventIDValue | [read] The EventID of this Audit.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
Info1Property | [read] auxiliary information for the first "operand" object
Info2Property | [read] auxiliary information for the second "operand" object
Info3Property | [read] auxiliary information for the third "operand" object
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemClass1Name | [read] the name of the audited item's type.
ItemClass2Name | [read] the name of the audited item's type.
ItemClass3Name | [read] the name of the audited item's type.
ItemDescriptor1 | [read] the primary descriptor for the underlying audited object.
ItemDescriptor2 | [read] the primary descriptor for the second "operand" object
ItemDescriptor3 | [read] the primary descriptor for the third "operand" object
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection for this Audit
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
RevisionTime1Property | [read] the revision time for the first "operand" object
RevisionTime2Property | [read] the revision time for the second "operand" object
RevisionTime3Property | [read] the revision time for the third "operand" object
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
UserValue | [read] The user who caused this audit.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Audit Class | StarTeam Namespace


Audit Properties

The properties of the Audit class are listed below. For a complete list of Audit class members, see the Audit Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EventIDValue | [read] The EventID of this Audit.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
Info1Property | [read] auxiliary information for the first "operand" object
Info2Property | [read] auxiliary information for the second "operand" object
Info3Property | [read] auxiliary information for the third "operand" object
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemClass1Name | [read] the name of the audited item's type.
ItemClass2Name | [read] the name of the audited item's type.
ItemClass3Name | [read] the name of the audited item's type.
ItemDescriptor1 | [read] the primary descriptor for the underlying audited object.
ItemDescriptor2 | [read] the primary descriptor for the second "operand" object
ItemDescriptor3 | [read] the primary descriptor for the third "operand" object
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection for this Audit
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
RevisionTime1Property | [read] the revision time for the first "operand" object
RevisionTime2Property | [read] the revision time for the second "operand" object
RevisionTime3Property | [read] the revision time for the third "operand" object
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
UserValue | [read] The user who caused this audit.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Audit Class | StarTeam Namespace


EventIDValue Property

Borland StarTeam SDK for .NET

Audit.EventIDValue Property

[read] The EventID of this Audit.

public virtual Audit.EventID EventIDValue {get;}

Property Value

The EventID of this Audit.

See Also

Audit Class | StarTeam Namespace


Info1Property Property

Borland StarTeam SDK for .NET

Audit.Info1Property Property

[read] auxiliary information for the first "operand" object

public virtual String Info1Property {get;}

Property Value

auxiliary information for the first "operand" object

See Also

Audit Class | StarTeam Namespace


Info2Property Property

Borland StarTeam SDK for .NET

Audit.Info2Property Property

[read] auxiliary information for the second "operand" object

public virtual String Info2Property {get;}

Property Value

auxiliary information for the second "operand" object

See Also

Audit Class | StarTeam Namespace


Info3Property Property

Borland StarTeam SDK for .NET

Audit.Info3Property Property

[read] auxiliary information for the third "operand" object

public virtual String Info3Property {get;}

Property Value

auxiliary information for the third "operand" object

See Also

Audit Class | StarTeam Namespace


ItemClass1Name Property

Borland StarTeam SDK for .NET

Audit.ItemClass1Name Property

[read] the name of the audited item's type.

public virtual String ItemClass1Name {get;}

Property Value

the name of the audited item's type.

See Also

Audit Class | StarTeam Namespace


ItemClass2Name Property

Borland StarTeam SDK for .NET

Audit.ItemClass2Name Property

[read] the name of the audited item's type.

public virtual String ItemClass2Name {get;}

Property Value

the name of the audited item's type.

See Also

Audit Class | StarTeam Namespace


ItemClass3Name Property

Borland StarTeam SDK for .NET

Audit.ItemClass3Name Property

[read] the name of the audited item's type.

public virtual String ItemClass3Name {get;}

Property Value

the name of the audited item's type.

See Also

Audit Class | StarTeam Namespace


ItemDescriptor1 Property

Borland StarTeam SDK for .NET

Audit.ItemDescriptor1 Property

[read] the primary descriptor for the underlying audited object.

public virtual String ItemDescriptor1 {get;}

Property Value

the primary descriptor for the underlying audited object.

See Also

Audit Class | StarTeam Namespace


ItemDescriptor2 Property

Borland StarTeam SDK for .NET

Audit.ItemDescriptor2 Property

[read] the primary descriptor for the second "operand" object

public virtual String ItemDescriptor2 {get;}

Property Value

the primary descriptor for the second "operand" object

See Also

Audit Class | StarTeam Namespace


ItemDescriptor3 Property

Borland StarTeam SDK for .NET

Audit.ItemDescriptor3 Property

[read] the primary descriptor for the third "operand" object

public virtual String ItemDescriptor3 {get;}

Property Value

the primary descriptor for the third "operand" object

See Also

Audit Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Audit.Properties Property

[read] the PropertyCollection for this Audit

public virtual Audit.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection for this Audit

See Also

Audit Class | StarTeam Namespace


RevisionTime1Property Property

Borland StarTeam SDK for .NET

Audit.RevisionTime1Property Property

[read] the revision time for the first "operand" object

public virtual DateTime RevisionTime1Property {get;}

Property Value

the revision time for the first "operand" object

See Also

Audit Class | StarTeam Namespace


RevisionTime2Property Property

Borland StarTeam SDK for .NET

Audit.RevisionTime2Property Property

[read] the revision time for the second "operand" object

public virtual DateTime RevisionTime2Property {get;}

Property Value

the revision time for the second "operand" object

See Also

Audit Class | StarTeam Namespace


RevisionTime3Property Property

Borland StarTeam SDK for .NET

Audit.RevisionTime3Property Property

[read] the revision time for the third "operand" object

public virtual DateTime RevisionTime3Property {get;}

Property Value

the revision time for the third "operand" object

See Also

Audit Class | StarTeam Namespace


UserValue Property

Borland StarTeam SDK for .NET

Audit.UserValue Property

[read] The user who caused this audit.

public virtual User UserValue {get;}

Property Value

The user who caused this audit.

See Also

Audit Class | StarTeam Namespace


Audit.EventID Class

EventID of the Audit

For a list of all members of this type, see Audit.EventID Members.

System.Object
EnumeratedValue
Audit.EventID

public class Audit.EventID : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.EventID Members | StarTeam Namespace


Audit.EventID Members

Audit.EventID overview

Public Static Properties

ADDED
ALL
BRANCHED
CHECKED_IN
CHECKED_OUT
COMMENT_EDITED
CREATED
DELETED
ITEM_OVERWRITTEN
LOCK_BROKEN
LOCKED
MODIFIED
MOVED_FROM
MOVED_TO
SHARED
UNLOCKED
VAULT_CONVERTED

Public Static Methods

FromValue Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this EventID value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Audit.EventID.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.EventID.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Audit.EventID.

See Also

Audit.EventID Class | StarTeam Namespace


Audit.EventID Properties

The properties of the Audit.EventID class are listed below. For a complete list of Audit.EventID class members, see the Audit.EventID Members topic.

Public Static Properties

ADDED
ALL
BRANCHED
CHECKED_IN
CHECKED_OUT
COMMENT_EDITED
CREATED
DELETED
ITEM_OVERWRITTEN
LOCK_BROKEN
LOCKED
MODIFIED
MOVED_FROM
MOVED_TO
SHARED
UNLOCKED
VAULT_CONVERTED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this EventID value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Audit.EventID Class | StarTeam Namespace


ADDED Property

Borland StarTeam SDK for .NET

Audit.EventID.ADDED Property

public static Audit.EventID ADDED {get;}

Property Value

The Added Event

See Also

Audit.EventID Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Audit.EventID.ALL Property

public static EventID[] ALL {get;}

See Also

Audit.EventID Class | StarTeam Namespace


BRANCHED Property

Borland StarTeam SDK for .NET

Audit.EventID.BRANCHED Property

public static Audit.EventID BRANCHED {get;}

Property Value

The Branched Event

See Also

Audit.EventID Class | StarTeam Namespace


CHECKED_IN Property

Borland StarTeam SDK for .NET

Audit.EventID.CHECKED_IN Property

public static Audit.EventID CHECKED_IN {get;}

Property Value

The Checked In Event

See Also

Audit.EventID Class | StarTeam Namespace


CHECKED_OUT Property

Borland StarTeam SDK for .NET

Audit.EventID.CHECKED_OUT Property

public static Audit.EventID CHECKED_OUT {get;}

Property Value

The Checked Out Event

See Also

Audit.EventID Class | StarTeam Namespace


COMMENT_EDITED Property

Borland StarTeam SDK for .NET

Audit.EventID.COMMENT_EDITED Property

public static Audit.EventID COMMENT_EDITED {get;}

Property Value

The Comment Edited Event

See Also

Audit.EventID Class | StarTeam Namespace


CREATED Property

Borland StarTeam SDK for .NET

Audit.EventID.CREATED Property

public static Audit.EventID CREATED {get;}

Property Value

The Created event

See Also

Audit.EventID Class | StarTeam Namespace


DELETED Property

Borland StarTeam SDK for .NET

Audit.EventID.DELETED Property

public static Audit.EventID DELETED {get;}

Property Value

The Deleted Event

See Also

Audit.EventID Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Audit.EventID.ID Property

[read] The ID of this EventID value.

public virtual Int32 ID {get;}

Property Value

The ID of this EventID value.

See Also

Audit.EventID Class | StarTeam Namespace


ITEM_OVERWRITTEN Property

Borland StarTeam SDK for .NET

Audit.EventID.ITEM_OVERWRITTEN Property

public static Audit.EventID ITEM_OVERWRITTEN {get;}

Property Value

The Item Overwritten Event

See Also

Audit.EventID Class | StarTeam Namespace


LOCK_BROKEN Property

Borland StarTeam SDK for .NET

Audit.EventID.LOCK_BROKEN Property

public static Audit.EventID LOCK_BROKEN {get;}

Property Value

The Lock Broken Event

See Also

Audit.EventID Class | StarTeam Namespace


LOCKED Property

Borland StarTeam SDK for .NET

Audit.EventID.LOCKED Property

public static Audit.EventID LOCKED {get;}

Property Value

The Locked Event

See Also

Audit.EventID Class | StarTeam Namespace


MODIFIED Property

Borland StarTeam SDK for .NET

Audit.EventID.MODIFIED Property

public static Audit.EventID MODIFIED {get;}

Property Value

The Modified Event

See Also

Audit.EventID Class | StarTeam Namespace


MOVED_FROM Property

Borland StarTeam SDK for .NET

Audit.EventID.MOVED_FROM Property

public static Audit.EventID MOVED_FROM {get;}

Property Value

The Moved From Event

See Also

Audit.EventID Class | StarTeam Namespace


MOVED_TO Property

Borland StarTeam SDK for .NET

Audit.EventID.MOVED_TO Property

public static Audit.EventID MOVED_TO {get;}

Property Value

The Moved To Event

See Also

Audit.EventID Class | StarTeam Namespace


SHARED Property

Borland StarTeam SDK for .NET

Audit.EventID.SHARED Property

public static Audit.EventID SHARED {get;}

Property Value

The Shared Event

See Also

Audit.EventID Class | StarTeam Namespace


UNLOCKED Property

Borland StarTeam SDK for .NET

Audit.EventID.UNLOCKED Property

public static Audit.EventID UNLOCKED {get;}

Property Value

The Unlocked Event

See Also

Audit.EventID Class | StarTeam Namespace


VAULT_CONVERTED Property

Borland StarTeam SDK for .NET

Audit.EventID.VAULT_CONVERTED Property

public static Audit.EventID VAULT_CONVERTED {get;}

Property Value

The Vault Converted Event

See Also

Audit.EventID Class | StarTeam Namespace


Audit.EventID Methods

The methods of the Audit.EventID class are listed below. For a complete list of Audit.EventID class members, see the Audit.EventID Members topic.

Public Static Methods

FromValue Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Audit.EventID.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.EventID.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Audit.EventID.

See Also

Audit.EventID Class | StarTeam Namespace


Audit.EventID.Equals Method

Delegate Equals() to com.starteam.Audit.EventID.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.EventID.Equals(obj).

See Also

Audit.EventID Class | StarTeam Namespace


Audit.EventID.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static EventID FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

Audit.EventID Class | StarTeam Namespace


Audit.EventID.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.EventID.

public override int GetHashCode();

Return Value

com.starteam.Audit.EventID.GetHashCode().

See Also

Audit.EventID Class | StarTeam Namespace


Audit.EventID.ToString Method

Delegate ToString() to com.starteam.Audit.EventID.

public override string ToString();

Return Value

com.starteam.Audit.EventID.ToString()

See Also

Audit.EventID Class | StarTeam Namespace


Audit.Type Class

The Audit Type

For a list of all members of this type, see Audit.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
Audit.Type

new public class Audit.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type Members | StarTeam Namespace


Audit.Type Members

Audit.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Audit.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Audit.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type Properties

The properties of the Audit.Type class are listed below. For a complete list of Audit.Type class members, see the Audit.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Audit.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Audit.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Audit.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Audit.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Audit.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Audit.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Audit.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Audit.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Audit.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Audit.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Audit.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Audit.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Audit.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Audit.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Audit.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.NAME Property

new public static String NAME {get;}

See Also

Audit.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Audit.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Audit.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Audit.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Audit.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Audit.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Audit.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Audit.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Audit.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Audit.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type Methods

The methods of the Audit.Type class are listed below. For a complete list of Audit.Type class members, see the Audit.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Audit.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Audit.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type.Equals Method

Delegate Equals() to com.starteam.Audit.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.Equals(obj).

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.GetHashCode().

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type.ToString Method

Delegate ToString() to com.starteam.Audit.Type.

public override string ToString();

Return Value

com.starteam.Audit.Type.ToString()

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Audit.Type Class | StarTeam Namespace


Audit.Type.ClassID1Property Class

The property type of the ClassID1 property.

For a list of all members of this type, see Audit.Type.ClassID1Property Members.

System.Object
Property
ScalarProperty
IntegerProperty
Audit.Type.ClassID1Property

public class Audit.Type.ClassID1Property : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.ClassID1Property Members | StarTeam Namespace


Audit.Type.ClassID1Property Members

Audit.Type.ClassID1Property overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassID1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassID1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassID1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassID1Property Class | StarTeam Namespace


Audit.Type.ClassID1Property Properties

The properties of the Audit.Type.ClassID1Property class are listed below. For a complete list of Audit.Type.ClassID1Property class members, see the Audit.Type.ClassID1Property Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.ClassID1Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.ClassID1Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.ClassID1Property Class | StarTeam Namespace


Audit.Type.ClassID1Property Methods

The methods of the Audit.Type.ClassID1Property class are listed below. For a complete list of Audit.Type.ClassID1Property class members, see the Audit.Type.ClassID1Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassID1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassID1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassID1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassID1Property Class | StarTeam Namespace


Audit.Type.ClassID1Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.ClassID1Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.ClassID1Property.Equals(obj).

See Also

Audit.Type.ClassID1Property Class | StarTeam Namespace


Audit.Type.ClassID1Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.ClassID1Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.ClassID1Property.GetHashCode().

See Also

Audit.Type.ClassID1Property Class | StarTeam Namespace


Audit.Type.ClassID1Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.ClassID1Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.ClassID1Property.ToString()

See Also

Audit.Type.ClassID1Property Class | StarTeam Namespace


Audit.Type.ClassID2Property Class

The property type of the ClassID2 property.

For a list of all members of this type, see Audit.Type.ClassID2Property Members.

System.Object
Property
ScalarProperty
IntegerProperty
Audit.Type.ClassID2Property

public class Audit.Type.ClassID2Property : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.ClassID2Property Members | StarTeam Namespace


Audit.Type.ClassID2Property Members

Audit.Type.ClassID2Property overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassID2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassID2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassID2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassID2Property Class | StarTeam Namespace


Audit.Type.ClassID2Property Properties

The properties of the Audit.Type.ClassID2Property class are listed below. For a complete list of Audit.Type.ClassID2Property class members, see the Audit.Type.ClassID2Property Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.ClassID2Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.ClassID2Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.ClassID2Property Class | StarTeam Namespace


Audit.Type.ClassID2Property Methods

The methods of the Audit.Type.ClassID2Property class are listed below. For a complete list of Audit.Type.ClassID2Property class members, see the Audit.Type.ClassID2Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassID2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassID2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassID2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassID2Property Class | StarTeam Namespace


Audit.Type.ClassID2Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.ClassID2Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.ClassID2Property.Equals(obj).

See Also

Audit.Type.ClassID2Property Class | StarTeam Namespace


Audit.Type.ClassID2Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.ClassID2Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.ClassID2Property.GetHashCode().

See Also

Audit.Type.ClassID2Property Class | StarTeam Namespace


Audit.Type.ClassID2Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.ClassID2Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.ClassID2Property.ToString()

See Also

Audit.Type.ClassID2Property Class | StarTeam Namespace


Audit.Type.ClassID3Property Class

The property type of the ClassID3 property.

For a list of all members of this type, see Audit.Type.ClassID3Property Members.

System.Object
Property
ScalarProperty
IntegerProperty
Audit.Type.ClassID3Property

public class Audit.Type.ClassID3Property : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.ClassID3Property Members | StarTeam Namespace


Audit.Type.ClassID3Property Members

Audit.Type.ClassID3Property overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassID3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassID3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassID3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassID3Property Class | StarTeam Namespace


Audit.Type.ClassID3Property Properties

The properties of the Audit.Type.ClassID3Property class are listed below. For a complete list of Audit.Type.ClassID3Property class members, see the Audit.Type.ClassID3Property Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.ClassID3Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.ClassID3Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.ClassID3Property Class | StarTeam Namespace


Audit.Type.ClassID3Property Methods

The methods of the Audit.Type.ClassID3Property class are listed below. For a complete list of Audit.Type.ClassID3Property class members, see the Audit.Type.ClassID3Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassID3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassID3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassID3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassID3Property Class | StarTeam Namespace


Audit.Type.ClassID3Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.ClassID3Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.ClassID3Property.Equals(obj).

See Also

Audit.Type.ClassID3Property Class | StarTeam Namespace


Audit.Type.ClassID3Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.ClassID3Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.ClassID3Property.GetHashCode().

See Also

Audit.Type.ClassID3Property Class | StarTeam Namespace


Audit.Type.ClassID3Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.ClassID3Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.ClassID3Property.ToString()

See Also

Audit.Type.ClassID3Property Class | StarTeam Namespace


Audit.Type.ClassName1Property Class

The property type of the ClassName1 property.

For a list of all members of this type, see Audit.Type.ClassName1Property Members.

System.Object
Property
VectorProperty
TextProperty
Audit.Type.ClassName1Property

public class Audit.Type.ClassName1Property : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.ClassName1Property Members | StarTeam Namespace


Audit.Type.ClassName1Property Members

Audit.Type.ClassName1Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassName1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassName1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassName1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassName1Property Class | StarTeam Namespace


Audit.Type.ClassName1Property Properties

The properties of the Audit.Type.ClassName1Property class are listed below. For a complete list of Audit.Type.ClassName1Property class members, see the Audit.Type.ClassName1Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.ClassName1Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.ClassName1Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.ClassName1Property Class | StarTeam Namespace


Audit.Type.ClassName1Property Methods

The methods of the Audit.Type.ClassName1Property class are listed below. For a complete list of Audit.Type.ClassName1Property class members, see the Audit.Type.ClassName1Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassName1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassName1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassName1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassName1Property Class | StarTeam Namespace


Audit.Type.ClassName1Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.ClassName1Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.ClassName1Property.Equals(obj).

See Also

Audit.Type.ClassName1Property Class | StarTeam Namespace


Audit.Type.ClassName1Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.ClassName1Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.ClassName1Property.GetHashCode().

See Also

Audit.Type.ClassName1Property Class | StarTeam Namespace


Audit.Type.ClassName1Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.ClassName1Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.ClassName1Property.ToString()

See Also

Audit.Type.ClassName1Property Class | StarTeam Namespace


Audit.Type.ClassName2Property Class

The property type of the Classname2 property.

For a list of all members of this type, see Audit.Type.ClassName2Property Members.

System.Object
Property
VectorProperty
TextProperty
Audit.Type.ClassName2Property

public class Audit.Type.ClassName2Property : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.ClassName2Property Members | StarTeam Namespace


Audit.Type.ClassName2Property Members

Audit.Type.ClassName2Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassName2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassName2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassName2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassName2Property Class | StarTeam Namespace


Audit.Type.ClassName2Property Properties

The properties of the Audit.Type.ClassName2Property class are listed below. For a complete list of Audit.Type.ClassName2Property class members, see the Audit.Type.ClassName2Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.ClassName2Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.ClassName2Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.ClassName2Property Class | StarTeam Namespace


Audit.Type.ClassName2Property Methods

The methods of the Audit.Type.ClassName2Property class are listed below. For a complete list of Audit.Type.ClassName2Property class members, see the Audit.Type.ClassName2Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassName2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassName2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassName2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassName2Property Class | StarTeam Namespace


Audit.Type.ClassName2Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.ClassName2Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.ClassName2Property.Equals(obj).

See Also

Audit.Type.ClassName2Property Class | StarTeam Namespace


Audit.Type.ClassName2Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.ClassName2Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.ClassName2Property.GetHashCode().

See Also

Audit.Type.ClassName2Property Class | StarTeam Namespace


Audit.Type.ClassName2Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.ClassName2Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.ClassName2Property.ToString()

See Also

Audit.Type.ClassName2Property Class | StarTeam Namespace


Audit.Type.ClassName3Property Class

The property type of the ClassName3 property.

For a list of all members of this type, see Audit.Type.ClassName3Property Members.

System.Object
Property
VectorProperty
TextProperty
Audit.Type.ClassName3Property

public class Audit.Type.ClassName3Property : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.ClassName3Property Members | StarTeam Namespace


Audit.Type.ClassName3Property Members

Audit.Type.ClassName3Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassName3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassName3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassName3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassName3Property Class | StarTeam Namespace


Audit.Type.ClassName3Property Properties

The properties of the Audit.Type.ClassName3Property class are listed below. For a complete list of Audit.Type.ClassName3Property class members, see the Audit.Type.ClassName3Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.ClassName3Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.ClassName3Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.ClassName3Property Class | StarTeam Namespace


Audit.Type.ClassName3Property Methods

The methods of the Audit.Type.ClassName3Property class are listed below. For a complete list of Audit.Type.ClassName3Property class members, see the Audit.Type.ClassName3Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ClassName3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ClassName3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ClassName3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ClassName3Property Class | StarTeam Namespace


Audit.Type.ClassName3Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.ClassName3Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.ClassName3Property.Equals(obj).

See Also

Audit.Type.ClassName3Property Class | StarTeam Namespace


Audit.Type.ClassName3Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.ClassName3Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.ClassName3Property.GetHashCode().

See Also

Audit.Type.ClassName3Property Class | StarTeam Namespace


Audit.Type.ClassName3Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.ClassName3Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.ClassName3Property.ToString()

See Also

Audit.Type.ClassName3Property Class | StarTeam Namespace


Audit.Type.Descriptor1Property Class

The property type of the Descriptor1 property.

For a list of all members of this type, see Audit.Type.Descriptor1Property Members.

System.Object
Property
VectorProperty
TextProperty
Audit.Type.Descriptor1Property

public class Audit.Type.Descriptor1Property : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.Descriptor1Property Members | StarTeam Namespace


Audit.Type.Descriptor1Property Members

Audit.Type.Descriptor1Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Descriptor1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Descriptor1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Descriptor1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Descriptor1Property Class | StarTeam Namespace


Audit.Type.Descriptor1Property Properties

The properties of the Audit.Type.Descriptor1Property class are listed below. For a complete list of Audit.Type.Descriptor1Property class members, see the Audit.Type.Descriptor1Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.Descriptor1Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.Descriptor1Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.Descriptor1Property Class | StarTeam Namespace


Audit.Type.Descriptor1Property Methods

The methods of the Audit.Type.Descriptor1Property class are listed below. For a complete list of Audit.Type.Descriptor1Property class members, see the Audit.Type.Descriptor1Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Descriptor1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Descriptor1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Descriptor1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Descriptor1Property Class | StarTeam Namespace


Audit.Type.Descriptor1Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.Descriptor1Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.Descriptor1Property.Equals(obj).

See Also

Audit.Type.Descriptor1Property Class | StarTeam Namespace


Audit.Type.Descriptor1Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.Descriptor1Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.Descriptor1Property.GetHashCode().

See Also

Audit.Type.Descriptor1Property Class | StarTeam Namespace


Audit.Type.Descriptor1Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.Descriptor1Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.Descriptor1Property.ToString()

See Also

Audit.Type.Descriptor1Property Class | StarTeam Namespace


Audit.Type.Descriptor2Property Class

The property type of the Descriptor2 property.

For a list of all members of this type, see Audit.Type.Descriptor2Property Members.

System.Object
Property
VectorProperty
TextProperty
Audit.Type.Descriptor2Property

public class Audit.Type.Descriptor2Property : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.Descriptor2Property Members | StarTeam Namespace


Audit.Type.Descriptor2Property Members

Audit.Type.Descriptor2Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Descriptor2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Descriptor2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Descriptor2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Descriptor2Property Class | StarTeam Namespace


Audit.Type.Descriptor2Property Properties

The properties of the Audit.Type.Descriptor2Property class are listed below. For a complete list of Audit.Type.Descriptor2Property class members, see the Audit.Type.Descriptor2Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.Descriptor2Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.Descriptor2Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.Descriptor2Property Class | StarTeam Namespace


Audit.Type.Descriptor2Property Methods

The methods of the Audit.Type.Descriptor2Property class are listed below. For a complete list of Audit.Type.Descriptor2Property class members, see the Audit.Type.Descriptor2Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Descriptor2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Descriptor2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Descriptor2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Descriptor2Property Class | StarTeam Namespace


Audit.Type.Descriptor2Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.Descriptor2Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.Descriptor2Property.Equals(obj).

See Also

Audit.Type.Descriptor2Property Class | StarTeam Namespace


Audit.Type.Descriptor2Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.Descriptor2Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.Descriptor2Property.GetHashCode().

See Also

Audit.Type.Descriptor2Property Class | StarTeam Namespace


Audit.Type.Descriptor2Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.Descriptor2Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.Descriptor2Property.ToString()

See Also

Audit.Type.Descriptor2Property Class | StarTeam Namespace


Audit.Type.Descriptor3Property Class

The property type of the Descriptor3 property.

For a list of all members of this type, see Audit.Type.Descriptor3Property Members.

System.Object
Property
VectorProperty
TextProperty
Audit.Type.Descriptor3Property

public class Audit.Type.Descriptor3Property : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.Descriptor3Property Members | StarTeam Namespace


Audit.Type.Descriptor3Property Members

Audit.Type.Descriptor3Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Descriptor3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Descriptor3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Descriptor3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Descriptor3Property Class | StarTeam Namespace


Audit.Type.Descriptor3Property Properties

The properties of the Audit.Type.Descriptor3Property class are listed below. For a complete list of Audit.Type.Descriptor3Property class members, see the Audit.Type.Descriptor3Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.Descriptor3Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.Descriptor3Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.Descriptor3Property Class | StarTeam Namespace


Audit.Type.Descriptor3Property Methods

The methods of the Audit.Type.Descriptor3Property class are listed below. For a complete list of Audit.Type.Descriptor3Property class members, see the Audit.Type.Descriptor3Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Descriptor3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Descriptor3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Descriptor3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Descriptor3Property Class | StarTeam Namespace


Audit.Type.Descriptor3Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.Descriptor3Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.Descriptor3Property.Equals(obj).

See Also

Audit.Type.Descriptor3Property Class | StarTeam Namespace


Audit.Type.Descriptor3Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.Descriptor3Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.Descriptor3Property.GetHashCode().

See Also

Audit.Type.Descriptor3Property Class | StarTeam Namespace


Audit.Type.Descriptor3Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.Descriptor3Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.Descriptor3Property.ToString()

See Also

Audit.Type.Descriptor3Property Class | StarTeam Namespace


Audit.Type.EventIDProperty Class

The property type of the EventID property.

For a list of all members of this type, see Audit.Type.EventIDProperty Members.

System.Object
Property
EnumeratedProperty
Audit.Type.EventIDProperty

public class Audit.Type.EventIDProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.EventIDProperty Members | StarTeam Namespace


Audit.Type.EventIDProperty Members

Audit.Type.EventIDProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Audit.Type.EventIDProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.EventIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Audit.Type.EventIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.EventIDProperty Class | StarTeam Namespace


Audit.Type.EventIDProperty Properties

The properties of the Audit.Type.EventIDProperty class are listed below. For a complete list of Audit.Type.EventIDProperty class members, see the Audit.Type.EventIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Audit.Type.EventIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.EventIDProperty.NAME Property

public static String NAME {get;}

See Also

Audit.Type.EventIDProperty Class | StarTeam Namespace


Audit.Type.EventIDProperty Methods

The methods of the Audit.Type.EventIDProperty class are listed below. For a complete list of Audit.Type.EventIDProperty class members, see the Audit.Type.EventIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Audit.Type.EventIDProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.EventIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Audit.Type.EventIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.EventIDProperty Class | StarTeam Namespace


Audit.Type.EventIDProperty.Equals Method

Delegate Equals() to com.starteam.Audit.Type.EventIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.EventIDProperty.Equals(obj).

See Also

Audit.Type.EventIDProperty Class | StarTeam Namespace


Audit.Type.EventIDProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Audit.EventID value
);

See Also

Audit.Type.EventIDProperty Class | StarTeam Namespace


Audit.Type.EventIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.EventIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.EventIDProperty.GetHashCode().

See Also

Audit.Type.EventIDProperty Class | StarTeam Namespace


Audit.Type.EventIDProperty.ToString Method

Delegate ToString() to com.starteam.Audit.Type.EventIDProperty.

public override string ToString();

Return Value

com.starteam.Audit.Type.EventIDProperty.ToString()

See Also

Audit.Type.EventIDProperty Class | StarTeam Namespace


Audit.Type.FolderIDProperty Class

The property type of the FolderID property.

For a list of all members of this type, see Audit.Type.FolderIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Audit.Type.FolderIDProperty

public class Audit.Type.FolderIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.FolderIDProperty Members | StarTeam Namespace


Audit.Type.FolderIDProperty Members

Audit.Type.FolderIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.FolderIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.FolderIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.FolderIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.FolderIDProperty Class | StarTeam Namespace


Audit.Type.FolderIDProperty Properties

The properties of the Audit.Type.FolderIDProperty class are listed below. For a complete list of Audit.Type.FolderIDProperty class members, see the Audit.Type.FolderIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.FolderIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.FolderIDProperty.NAME Property

public static String NAME {get;}

See Also

Audit.Type.FolderIDProperty Class | StarTeam Namespace


Audit.Type.FolderIDProperty Methods

The methods of the Audit.Type.FolderIDProperty class are listed below. For a complete list of Audit.Type.FolderIDProperty class members, see the Audit.Type.FolderIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.FolderIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.FolderIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.FolderIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.FolderIDProperty Class | StarTeam Namespace


Audit.Type.FolderIDProperty.Equals Method

Delegate Equals() to com.starteam.Audit.Type.FolderIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.FolderIDProperty.Equals(obj).

See Also

Audit.Type.FolderIDProperty Class | StarTeam Namespace


Audit.Type.FolderIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.FolderIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.FolderIDProperty.GetHashCode().

See Also

Audit.Type.FolderIDProperty Class | StarTeam Namespace


Audit.Type.FolderIDProperty.ToString Method

Delegate ToString() to com.starteam.Audit.Type.FolderIDProperty.

public override string ToString();

Return Value

com.starteam.Audit.Type.FolderIDProperty.ToString()

See Also

Audit.Type.FolderIDProperty Class | StarTeam Namespace


Audit.Type.Info1Property Class

The property type of the Info1 property.

For a list of all members of this type, see Audit.Type.Info1Property Members.

System.Object
Property
VectorProperty
TextProperty
Audit.Type.Info1Property

public class Audit.Type.Info1Property : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.Info1Property Members | StarTeam Namespace


Audit.Type.Info1Property Members

Audit.Type.Info1Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Info1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Info1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Info1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Info1Property Class | StarTeam Namespace


Audit.Type.Info1Property Properties

The properties of the Audit.Type.Info1Property class are listed below. For a complete list of Audit.Type.Info1Property class members, see the Audit.Type.Info1Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.Info1Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.Info1Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.Info1Property Class | StarTeam Namespace


Audit.Type.Info1Property Methods

The methods of the Audit.Type.Info1Property class are listed below. For a complete list of Audit.Type.Info1Property class members, see the Audit.Type.Info1Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Info1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Info1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Info1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Info1Property Class | StarTeam Namespace


Audit.Type.Info1Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.Info1Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.Info1Property.Equals(obj).

See Also

Audit.Type.Info1Property Class | StarTeam Namespace


Audit.Type.Info1Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.Info1Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.Info1Property.GetHashCode().

See Also

Audit.Type.Info1Property Class | StarTeam Namespace


Audit.Type.Info1Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.Info1Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.Info1Property.ToString()

See Also

Audit.Type.Info1Property Class | StarTeam Namespace


Audit.Type.Info2Property Class

The property type of the Info2 property.

For a list of all members of this type, see Audit.Type.Info2Property Members.

System.Object
Property
VectorProperty
TextProperty
Audit.Type.Info2Property

public class Audit.Type.Info2Property : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.Info2Property Members | StarTeam Namespace


Audit.Type.Info2Property Members

Audit.Type.Info2Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Info2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Info2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Info2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Info2Property Class | StarTeam Namespace


Audit.Type.Info2Property Properties

The properties of the Audit.Type.Info2Property class are listed below. For a complete list of Audit.Type.Info2Property class members, see the Audit.Type.Info2Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.Info2Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.Info2Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.Info2Property Class | StarTeam Namespace


Audit.Type.Info2Property Methods

The methods of the Audit.Type.Info2Property class are listed below. For a complete list of Audit.Type.Info2Property class members, see the Audit.Type.Info2Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Info2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Info2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Info2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Info2Property Class | StarTeam Namespace


Audit.Type.Info2Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.Info2Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.Info2Property.Equals(obj).

See Also

Audit.Type.Info2Property Class | StarTeam Namespace


Audit.Type.Info2Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.Info2Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.Info2Property.GetHashCode().

See Also

Audit.Type.Info2Property Class | StarTeam Namespace


Audit.Type.Info2Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.Info2Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.Info2Property.ToString()

See Also

Audit.Type.Info2Property Class | StarTeam Namespace


Audit.Type.Info3Property Class

The property type of the Info3 property.

For a list of all members of this type, see Audit.Type.Info3Property Members.

System.Object
Property
VectorProperty
TextProperty
Audit.Type.Info3Property

public class Audit.Type.Info3Property : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.Info3Property Members | StarTeam Namespace


Audit.Type.Info3Property Members

Audit.Type.Info3Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Info3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Info3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Info3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Info3Property Class | StarTeam Namespace


Audit.Type.Info3Property Properties

The properties of the Audit.Type.Info3Property class are listed below. For a complete list of Audit.Type.Info3Property class members, see the Audit.Type.Info3Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.Info3Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.Info3Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.Info3Property Class | StarTeam Namespace


Audit.Type.Info3Property Methods

The methods of the Audit.Type.Info3Property class are listed below. For a complete list of Audit.Type.Info3Property class members, see the Audit.Type.Info3Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.Info3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.Info3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.Info3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.Info3Property Class | StarTeam Namespace


Audit.Type.Info3Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.Info3Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.Info3Property.Equals(obj).

See Also

Audit.Type.Info3Property Class | StarTeam Namespace


Audit.Type.Info3Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.Info3Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.Info3Property.GetHashCode().

See Also

Audit.Type.Info3Property Class | StarTeam Namespace


Audit.Type.Info3Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.Info3Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.Info3Property.ToString()

See Also

Audit.Type.Info3Property Class | StarTeam Namespace


Audit.Type.ObjectID1Property Class

The property type of the ObjectID1 property.

For a list of all members of this type, see Audit.Type.ObjectID1Property Members.

System.Object
Property
ScalarProperty
IntegerProperty
Audit.Type.ObjectID1Property

public class Audit.Type.ObjectID1Property : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.ObjectID1Property Members | StarTeam Namespace


Audit.Type.ObjectID1Property Members

Audit.Type.ObjectID1Property overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ObjectID1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ObjectID1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ObjectID1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ObjectID1Property Class | StarTeam Namespace


Audit.Type.ObjectID1Property Properties

The properties of the Audit.Type.ObjectID1Property class are listed below. For a complete list of Audit.Type.ObjectID1Property class members, see the Audit.Type.ObjectID1Property Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.ObjectID1Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.ObjectID1Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.ObjectID1Property Class | StarTeam Namespace


Audit.Type.ObjectID1Property Methods

The methods of the Audit.Type.ObjectID1Property class are listed below. For a complete list of Audit.Type.ObjectID1Property class members, see the Audit.Type.ObjectID1Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ObjectID1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ObjectID1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ObjectID1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ObjectID1Property Class | StarTeam Namespace


Audit.Type.ObjectID1Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.ObjectID1Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.ObjectID1Property.Equals(obj).

See Also

Audit.Type.ObjectID1Property Class | StarTeam Namespace


Audit.Type.ObjectID1Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.ObjectID1Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.ObjectID1Property.GetHashCode().

See Also

Audit.Type.ObjectID1Property Class | StarTeam Namespace


Audit.Type.ObjectID1Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.ObjectID1Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.ObjectID1Property.ToString()

See Also

Audit.Type.ObjectID1Property Class | StarTeam Namespace


Audit.Type.ObjectID2Property Class

The property type of the ObjectID2 property.

For a list of all members of this type, see Audit.Type.ObjectID2Property Members.

System.Object
Property
ScalarProperty
IntegerProperty
Audit.Type.ObjectID2Property

public class Audit.Type.ObjectID2Property : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.ObjectID2Property Members | StarTeam Namespace


Audit.Type.ObjectID2Property Members

Audit.Type.ObjectID2Property overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ObjectID2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ObjectID2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ObjectID2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ObjectID2Property Class | StarTeam Namespace


Audit.Type.ObjectID2Property Properties

The properties of the Audit.Type.ObjectID2Property class are listed below. For a complete list of Audit.Type.ObjectID2Property class members, see the Audit.Type.ObjectID2Property Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.ObjectID2Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.ObjectID2Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.ObjectID2Property Class | StarTeam Namespace


Audit.Type.ObjectID2Property Methods

The methods of the Audit.Type.ObjectID2Property class are listed below. For a complete list of Audit.Type.ObjectID2Property class members, see the Audit.Type.ObjectID2Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ObjectID2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ObjectID2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ObjectID2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ObjectID2Property Class | StarTeam Namespace


Audit.Type.ObjectID2Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.ObjectID2Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.ObjectID2Property.Equals(obj).

See Also

Audit.Type.ObjectID2Property Class | StarTeam Namespace


Audit.Type.ObjectID2Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.ObjectID2Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.ObjectID2Property.GetHashCode().

See Also

Audit.Type.ObjectID2Property Class | StarTeam Namespace


Audit.Type.ObjectID2Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.ObjectID2Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.ObjectID2Property.ToString()

See Also

Audit.Type.ObjectID2Property Class | StarTeam Namespace


Audit.Type.ObjectID3Property Class

The property type of the objectID3 property.

For a list of all members of this type, see Audit.Type.ObjectID3Property Members.

System.Object
Property
ScalarProperty
IntegerProperty
Audit.Type.ObjectID3Property

public class Audit.Type.ObjectID3Property : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.ObjectID3Property Members | StarTeam Namespace


Audit.Type.ObjectID3Property Members

Audit.Type.ObjectID3Property overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ObjectID3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ObjectID3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ObjectID3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ObjectID3Property Class | StarTeam Namespace


Audit.Type.ObjectID3Property Properties

The properties of the Audit.Type.ObjectID3Property class are listed below. For a complete list of Audit.Type.ObjectID3Property class members, see the Audit.Type.ObjectID3Property Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.ObjectID3Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.ObjectID3Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.ObjectID3Property Class | StarTeam Namespace


Audit.Type.ObjectID3Property Methods

The methods of the Audit.Type.ObjectID3Property class are listed below. For a complete list of Audit.Type.ObjectID3Property class members, see the Audit.Type.ObjectID3Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.ObjectID3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.ObjectID3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.ObjectID3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.ObjectID3Property Class | StarTeam Namespace


Audit.Type.ObjectID3Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.ObjectID3Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.ObjectID3Property.Equals(obj).

See Also

Audit.Type.ObjectID3Property Class | StarTeam Namespace


Audit.Type.ObjectID3Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.ObjectID3Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.ObjectID3Property.GetHashCode().

See Also

Audit.Type.ObjectID3Property Class | StarTeam Namespace


Audit.Type.ObjectID3Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.ObjectID3Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.ObjectID3Property.ToString()

See Also

Audit.Type.ObjectID3Property Class | StarTeam Namespace


Audit.Type.PropertyCollection Class

The PropertyCollection of an Audit.

For a list of all members of this type, see Audit.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
Audit.Type.PropertyCollection

new public class Audit.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.PropertyCollection Members | StarTeam Namespace


Audit.Type.PropertyCollection Members

Audit.Type.PropertyCollection overview

Public Instance Properties

CLASS_ID_1 |
CLASS_ID_2 |
CLASS_ID_3 |
CLASS_NAME_1 |
CLASS_NAME_2 |
CLASS_NAME_3 |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTOR_1 |
DESCRIPTOR_2 |
DESCRIPTOR_3 |
EVENT_ID |
FOLDER_ID |
FOLDER_PATH |
ID |
INFO_1 |
INFO_2 |
INFO_3 |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MODIFIED_BY |
MODIFIED_TIME |
OBJECT_ID_1 |
OBJECT_ID_2 |
OBJECT_ID_3 |
PARENT_FOLDER_NAME |
PROJECT |
REVISION_TIME_1 |
REVISION_TIME_2 |
REVISION_TIME_3 |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TRANSACTION_ID |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
USER |
VIEW |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Audit.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Audit.Type.PropertyCollection.

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


Audit.Type.PropertyCollection Properties

The properties of the Audit.Type.PropertyCollection class are listed below. For a complete list of Audit.Type.PropertyCollection class members, see the Audit.Type.PropertyCollection Members topic.

Public Instance Properties

CLASS_ID_1 |
CLASS_ID_2 |
CLASS_ID_3 |
CLASS_NAME_1 |
CLASS_NAME_2 |
CLASS_NAME_3 |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTOR_1 |
DESCRIPTOR_2 |
DESCRIPTOR_3 |
EVENT_ID |
FOLDER_ID |
FOLDER_PATH |
ID |
INFO_1 |
INFO_2 |
INFO_3 |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MODIFIED_BY |
MODIFIED_TIME |
OBJECT_ID_1 |
OBJECT_ID_2 |
OBJECT_ID_3 |
PARENT_FOLDER_NAME |
PROJECT |
REVISION_TIME_1 |
REVISION_TIME_2 |
REVISION_TIME_3 |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TRANSACTION_ID |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
USER |
VIEW |

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


CLASS_ID_1 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.CLASS_ID_1 Property

public Audit.Type.ClassID1Property CLASS_ID_1 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


CLASS_ID_2 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.CLASS_ID_2 Property

public Audit.Type.ClassID2Property CLASS_ID_2 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


CLASS_ID_3 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.CLASS_ID_3 Property

public Audit.Type.ClassID3Property CLASS_ID_3 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


CLASS_NAME_1 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.CLASS_NAME_1 Property

public Audit.Type.ClassName1Property CLASS_NAME_1 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


CLASS_NAME_2 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.CLASS_NAME_2 Property

public Audit.Type.ClassName2Property CLASS_NAME_2 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


CLASS_NAME_3 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.CLASS_NAME_3 Property

public Audit.Type.ClassName3Property CLASS_NAME_3 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTOR_1 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.DESCRIPTOR_1 Property

public Audit.Type.Descriptor1Property DESCRIPTOR_1 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTOR_2 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.DESCRIPTOR_2 Property

public Audit.Type.Descriptor2Property DESCRIPTOR_2 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTOR_3 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.DESCRIPTOR_3 Property

public Audit.Type.Descriptor3Property DESCRIPTOR_3 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


EVENT_ID Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.EVENT_ID Property

public Audit.Type.EventIDProperty EVENT_ID {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_ID Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.FOLDER_ID Property

public Audit.Type.FolderIDProperty FOLDER_ID {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_PATH Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.FOLDER_PATH Property

public TrackedObject.Type.FolderPathProperty FOLDER_PATH {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


INFO_1 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.INFO_1 Property

public Audit.Type.Info1Property INFO_1 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


INFO_2 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.INFO_2 Property

public Audit.Type.Info2Property INFO_2 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


INFO_3 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.INFO_3 Property

public Audit.Type.Info3Property INFO_3 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


OBJECT_ID_1 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.OBJECT_ID_1 Property

public Audit.Type.ObjectID1Property OBJECT_ID_1 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


OBJECT_ID_2 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.OBJECT_ID_2 Property

public Audit.Type.ObjectID2Property OBJECT_ID_2 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


OBJECT_ID_3 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.OBJECT_ID_3 Property

public Audit.Type.ObjectID3Property OBJECT_ID_3 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


PARENT_FOLDER_NAME Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.PARENT_FOLDER_NAME Property

public TrackedObject.Type.ParentFolderNameProperty PARENT_FOLDER_NAME {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


PROJECT Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.PROJECT Property

public TypedResource.Type.ProjectProperty PROJECT {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


REVISION_TIME_1 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.REVISION_TIME_1 Property

public Audit.Type.RevisionTime1Property REVISION_TIME_1 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


REVISION_TIME_2 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.REVISION_TIME_2 Property

public Audit.Type.RevisionTime2Property REVISION_TIME_2 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


REVISION_TIME_3 Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.REVISION_TIME_3 Property

public Audit.Type.RevisionTime3Property REVISION_TIME_3 {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


TRANSACTION_ID Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.TRANSACTION_ID Property

public TrackedObject.Type.TransactionIDProperty TRANSACTION_ID {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


USER Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.USER Property

public Audit.Type.UserProperty USER {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Audit.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


Audit.Type.PropertyCollection Methods

The methods of the Audit.Type.PropertyCollection class are listed below. For a complete list of Audit.Type.PropertyCollection class members, see the Audit.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Audit.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Audit.Type.PropertyCollection.

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


Audit.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Audit.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.PropertyCollection.Equals(obj).

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


Audit.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.PropertyCollection.GetHashCode().

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


Audit.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Audit.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Audit.Type.PropertyCollection.ToString()

See Also

Audit.Type.PropertyCollection Class | StarTeam Namespace


Audit.Type.RevisionTime1Property Class

The property type of the RevisionTime1 property.

For a list of all members of this type, see Audit.Type.RevisionTime1Property Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Audit.Type.RevisionTime1Property

public class Audit.Type.RevisionTime1Property : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.RevisionTime1Property Members | StarTeam Namespace


Audit.Type.RevisionTime1Property Members

Audit.Type.RevisionTime1Property overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.RevisionTime1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.RevisionTime1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.RevisionTime1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.RevisionTime1Property Class | StarTeam Namespace


Audit.Type.RevisionTime1Property Properties

The properties of the Audit.Type.RevisionTime1Property class are listed below. For a complete list of Audit.Type.RevisionTime1Property class members, see the Audit.Type.RevisionTime1Property Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.RevisionTime1Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.RevisionTime1Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.RevisionTime1Property Class | StarTeam Namespace


Audit.Type.RevisionTime1Property Methods

The methods of the Audit.Type.RevisionTime1Property class are listed below. For a complete list of Audit.Type.RevisionTime1Property class members, see the Audit.Type.RevisionTime1Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.RevisionTime1Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.RevisionTime1Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.RevisionTime1Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.RevisionTime1Property Class | StarTeam Namespace


Audit.Type.RevisionTime1Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.RevisionTime1Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.RevisionTime1Property.Equals(obj).

See Also

Audit.Type.RevisionTime1Property Class | StarTeam Namespace


Audit.Type.RevisionTime1Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.RevisionTime1Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.RevisionTime1Property.GetHashCode().

See Also

Audit.Type.RevisionTime1Property Class | StarTeam Namespace


Audit.Type.RevisionTime1Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.RevisionTime1Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.RevisionTime1Property.ToString()

See Also

Audit.Type.RevisionTime1Property Class | StarTeam Namespace


Audit.Type.RevisionTime2Property Class

The property type of the RevisionTime2 property.

For a list of all members of this type, see Audit.Type.RevisionTime2Property Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Audit.Type.RevisionTime2Property

public class Audit.Type.RevisionTime2Property : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.RevisionTime2Property Members | StarTeam Namespace


Audit.Type.RevisionTime2Property Members

Audit.Type.RevisionTime2Property overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.RevisionTime2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.RevisionTime2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.RevisionTime2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.RevisionTime2Property Class | StarTeam Namespace


Audit.Type.RevisionTime2Property Properties

The properties of the Audit.Type.RevisionTime2Property class are listed below. For a complete list of Audit.Type.RevisionTime2Property class members, see the Audit.Type.RevisionTime2Property Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.RevisionTime2Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.RevisionTime2Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.RevisionTime2Property Class | StarTeam Namespace


Audit.Type.RevisionTime2Property Methods

The methods of the Audit.Type.RevisionTime2Property class are listed below. For a complete list of Audit.Type.RevisionTime2Property class members, see the Audit.Type.RevisionTime2Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.RevisionTime2Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.RevisionTime2Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.RevisionTime2Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.RevisionTime2Property Class | StarTeam Namespace


Audit.Type.RevisionTime2Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.RevisionTime2Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.RevisionTime2Property.Equals(obj).

See Also

Audit.Type.RevisionTime2Property Class | StarTeam Namespace


Audit.Type.RevisionTime2Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.RevisionTime2Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.RevisionTime2Property.GetHashCode().

See Also

Audit.Type.RevisionTime2Property Class | StarTeam Namespace


Audit.Type.RevisionTime2Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.RevisionTime2Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.RevisionTime2Property.ToString()

See Also

Audit.Type.RevisionTime2Property Class | StarTeam Namespace


Audit.Type.RevisionTime3Property Class

The property type of the RevisionTime3 property.

For a list of all members of this type, see Audit.Type.RevisionTime3Property Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Audit.Type.RevisionTime3Property

public class Audit.Type.RevisionTime3Property : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.RevisionTime3Property Members | StarTeam Namespace


Audit.Type.RevisionTime3Property Members

Audit.Type.RevisionTime3Property overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.RevisionTime3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.RevisionTime3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.RevisionTime3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.RevisionTime3Property Class | StarTeam Namespace


Audit.Type.RevisionTime3Property Properties

The properties of the Audit.Type.RevisionTime3Property class are listed below. For a complete list of Audit.Type.RevisionTime3Property class members, see the Audit.Type.RevisionTime3Property Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Audit.Type.RevisionTime3Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.RevisionTime3Property.NAME Property

public static String NAME {get;}

See Also

Audit.Type.RevisionTime3Property Class | StarTeam Namespace


Audit.Type.RevisionTime3Property Methods

The methods of the Audit.Type.RevisionTime3Property class are listed below. For a complete list of Audit.Type.RevisionTime3Property class members, see the Audit.Type.RevisionTime3Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.RevisionTime3Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.RevisionTime3Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.RevisionTime3Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.RevisionTime3Property Class | StarTeam Namespace


Audit.Type.RevisionTime3Property.Equals Method

Delegate Equals() to com.starteam.Audit.Type.RevisionTime3Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.RevisionTime3Property.Equals(obj).

See Also

Audit.Type.RevisionTime3Property Class | StarTeam Namespace


Audit.Type.RevisionTime3Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.RevisionTime3Property.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.RevisionTime3Property.GetHashCode().

See Also

Audit.Type.RevisionTime3Property Class | StarTeam Namespace


Audit.Type.RevisionTime3Property.ToString Method

Delegate ToString() to com.starteam.Audit.Type.RevisionTime3Property.

public override string ToString();

Return Value

com.starteam.Audit.Type.RevisionTime3Property.ToString()

See Also

Audit.Type.RevisionTime3Property Class | StarTeam Namespace


Audit.Type.UserProperty Class

The property type of the User property.

For a list of all members of this type, see Audit.Type.UserProperty Members.

System.Object
Property
ObjectProperty
Audit.Type.UserProperty

public class Audit.Type.UserProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Audit.Type.UserProperty Members | StarTeam Namespace


Audit.Type.UserProperty Members

Audit.Type.UserProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.UserProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.UserProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.UserProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.UserProperty Class | StarTeam Namespace


Audit.Type.UserProperty Properties

The properties of the Audit.Type.UserProperty class are listed below. For a complete list of Audit.Type.UserProperty class members, see the Audit.Type.UserProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Audit.Type.UserProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Audit.Type.UserProperty.NAME Property

public static String NAME {get;}

See Also

Audit.Type.UserProperty Class | StarTeam Namespace


Audit.Type.UserProperty Methods

The methods of the Audit.Type.UserProperty class are listed below. For a complete list of Audit.Type.UserProperty class members, see the Audit.Type.UserProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Audit.Type.UserProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Audit.Type.UserProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Audit.Type.UserProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Audit.Type.UserProperty Class | StarTeam Namespace


Audit.Type.UserProperty.Equals Method

Delegate Equals() to com.starteam.Audit.Type.UserProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Audit.Type.UserProperty.Equals(obj).

See Also

Audit.Type.UserProperty Class | StarTeam Namespace


Audit.Type.UserProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Audit.Type.UserProperty.

public override int GetHashCode();

Return Value

com.starteam.Audit.Type.UserProperty.GetHashCode().

See Also

Audit.Type.UserProperty Class | StarTeam Namespace


Audit.Type.UserProperty.ToString Method

Delegate ToString() to com.starteam.Audit.Type.UserProperty.

public override string ToString();

Return Value

com.starteam.Audit.Type.UserProperty.ToString()

See Also

Audit.Type.UserProperty Class | StarTeam Namespace


BinaryProperty Class

A BinaryProperty is a Property whose value is a Byte Stream

For a list of all members of this type, see BinaryProperty Members.

System.Object
Property
VectorProperty
BinaryProperty
File.Type.MD5Property
File.Type.SyncMD5Property
User.Type.PasswordProperty

public class BinaryProperty : VectorProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

BinaryProperty Members | StarTeam Namespace


BinaryProperty Members

BinaryProperty overview

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] byte[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

BinaryProperty Class | StarTeam Namespace


BinaryProperty Properties

The properties of the BinaryProperty class are listed below. For a complete list of BinaryProperty class members, see the BinaryProperty Members topic.

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] byte[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

BinaryProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

BinaryProperty.DefaultValue Property

[read/write] byte[]

new public virtual Byte[] DefaultValue {get; set;}

Property Value

byte[]

See Also

BinaryProperty Class | StarTeam Namespace


BinaryProperty Methods

The methods of the BinaryProperty class are listed below. For a complete list of BinaryProperty class members, see the BinaryProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

BinaryProperty Class | StarTeam Namespace


BinaryProperty.NewQueryPart Method

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
Byte[] value
);

See Also

BinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see BinaryProperty.WebCacheBinaryProperty Members.

System.Object
Property.WebCacheProperty
VectorProperty.WebCacheVectorProperty
BinaryProperty.WebCacheBinaryProperty

public class BinaryProperty.WebCacheBinaryProperty : WebCacheVectorProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

BinaryProperty.WebCacheBinaryProperty Members | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty Members

BinaryProperty.WebCacheBinaryProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] byte[]
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.BinaryProperty.WebCacheBinaryProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.BinaryProperty.WebCacheBinaryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.BinaryProperty.WebCacheBinaryProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty Properties

The properties of the BinaryProperty.WebCacheBinaryProperty class are listed below. For a complete list of BinaryProperty.WebCacheBinaryProperty class members, see the BinaryProperty.WebCacheBinaryProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] byte[]
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.DefaultValue Property

[read/write] byte[]

new public virtual Byte[] DefaultValue {get; set;}

Property Value

byte[]

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


MaxLength Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.MaxLength Property

[read/write] The maximum length of a property value.

new public virtual Int32 MaxLength {get; set;}

Property Value

The maximum length of a property value.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


MinLength Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.MinLength Property

[read/write] The minimum length of a property value.

new public virtual Int32 MinLength {get; set;}

Property Value

The minimum length of a property value.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.Name Property

new public virtual String Name {get;}

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

BinaryProperty.WebCacheBinaryProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty Methods

The methods of the BinaryProperty.WebCacheBinaryProperty class are listed below. For a complete list of BinaryProperty.WebCacheBinaryProperty class members, see the BinaryProperty.WebCacheBinaryProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.BinaryProperty.WebCacheBinaryProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.BinaryProperty.WebCacheBinaryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.BinaryProperty.WebCacheBinaryProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.Equals Method

Delegate Equals() to com.starteam.BinaryProperty.WebCacheBinaryProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.BinaryProperty.WebCacheBinaryProperty.Equals(obj).

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.BinaryProperty.WebCacheBinaryProperty.

public override int GetHashCode();

Return Value

com.starteam.BinaryProperty.WebCacheBinaryProperty.GetHashCode().

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.NewQueryPart Method

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
Byte[] value
);

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.ToString Method

Delegate ToString() to com.starteam.BinaryProperty.WebCacheBinaryProperty.

public override string ToString();

Return Value

com.starteam.BinaryProperty.WebCacheBinaryProperty.ToString()

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BinaryProperty.WebCacheBinaryProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

BinaryProperty.WebCacheBinaryProperty Class | StarTeam Namespace


BooleanProperty Class

A Boolean property is a Property whose value may be either True or False

For a list of all members of this type, see BooleanProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Derived types

public class BooleanProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

BooleanProperty Members | StarTeam Namespace


BooleanProperty Members

BooleanProperty overview

Public Static Properties

FALSE_INTERNAL_NAME
TRUE_INTERNAL_NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

BooleanProperty Class | StarTeam Namespace


BooleanProperty Properties

The properties of the BooleanProperty class are listed below. For a complete list of BooleanProperty class members, see the BooleanProperty Members topic.

Public Static Properties

FALSE_INTERNAL_NAME
TRUE_INTERNAL_NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

BooleanProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

BooleanProperty.DefaultValue Property

[read/write] The default value of this property, as a boolean value.

new public virtual Boolean DefaultValue {get; set;}

Property Value

The default value of this property, as a boolean value.

See Also

BooleanProperty Class | StarTeam Namespace


FALSE_INTERNAL_NAME Property

Borland StarTeam SDK for .NET

BooleanProperty.FALSE_INTERNAL_NAME Property

public static String FALSE_INTERNAL_NAME {get;}

See Also

BooleanProperty Class | StarTeam Namespace


FalseValue Property

Borland StarTeam SDK for .NET

BooleanProperty.FalseValue Property

[read/write] EnumeratedValue

public virtual EnumeratedValue FalseValue {get; set;}

Property Value

EnumeratedValue

See Also

BooleanProperty Class | StarTeam Namespace


TRUE_INTERNAL_NAME Property

Borland StarTeam SDK for .NET

BooleanProperty.TRUE_INTERNAL_NAME Property

public static String TRUE_INTERNAL_NAME {get;}

See Also

BooleanProperty Class | StarTeam Namespace


TrueValue Property

Borland StarTeam SDK for .NET

BooleanProperty.TrueValue Property

[read/write] EnumeratedValue

public virtual EnumeratedValue TrueValue {get; set;}

Property Value

EnumeratedValue

See Also

BooleanProperty Class | StarTeam Namespace


BooleanProperty Methods

The methods of the BooleanProperty class are listed below. For a complete list of BooleanProperty class members, see the BooleanProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

BooleanProperty Class | StarTeam Namespace


NewQueryPart Method

Borland StarTeam SDK for .NET

BooleanProperty.NewQueryPart Method

Overload List

Inherited from EnumeratedProperty.

public virtual QueryPart NewQueryPart(QueryPart.Relation,EnumeratedValue);

Inherited from EnumeratedProperty.

public virtual QueryPart NewQueryPart(QueryPart.Relation,EnumeratedValue[]);

Inherited from EnumeratedProperty.

public virtual QueryPart NewQueryPart(QueryPart.Relation,Int32);

public virtual QueryPart NewQueryPart(Boolean);

See Also

BooleanProperty Class | StarTeam Namespace


BooleanProperty.NewQueryPart Method (Boolean)

public virtual QueryPart NewQueryPart(
Boolean value
);

See Also

BooleanProperty Class | StarTeam Namespace | BooleanProperty.NewQueryPart Overload List


BooleanProperty.WebCacheBooleanProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see BooleanProperty.WebCacheBooleanProperty Members.

System.Object
Property.WebCacheProperty
BooleanProperty.WebCacheBooleanProperty

public class BooleanProperty.WebCacheBooleanProperty : WebCacheProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

BooleanProperty.WebCacheBooleanProperty Members | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty Members

BooleanProperty.WebCacheBooleanProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] The default value of this property, as a boolean value.
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.BooleanProperty.WebCacheBooleanProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.BooleanProperty.WebCacheBooleanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart | Constructs a query expression that tests a boolean property value.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.BooleanProperty.WebCacheBooleanProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty Properties

The properties of the BooleanProperty.WebCacheBooleanProperty class are listed below. For a complete list of BooleanProperty.WebCacheBooleanProperty class members, see the BooleanProperty.WebCacheBooleanProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] The default value of this property, as a boolean value.
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.DefaultValue Property

[read/write] The default value of this property, as a boolean value.

new public virtual Boolean DefaultValue {get; set;}

Property Value

The default value of this property, as a boolean value.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.Name Property

new public virtual String Name {get;}

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

BooleanProperty.WebCacheBooleanProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty Methods

The methods of the BooleanProperty.WebCacheBooleanProperty class are listed below. For a complete list of BooleanProperty.WebCacheBooleanProperty class members, see the BooleanProperty.WebCacheBooleanProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.BooleanProperty.WebCacheBooleanProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.BooleanProperty.WebCacheBooleanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart | Constructs a query expression that tests a boolean property value.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.BooleanProperty.WebCacheBooleanProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.Equals Method

Delegate Equals() to com.starteam.BooleanProperty.WebCacheBooleanProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.BooleanProperty.WebCacheBooleanProperty.Equals(obj).

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.BooleanProperty.WebCacheBooleanProperty.

public override int GetHashCode();

Return Value

com.starteam.BooleanProperty.WebCacheBooleanProperty.GetHashCode().

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.NewQueryPart Method

Constructs a query expression that tests a boolean property value.

public virtual WebCacheQueryPart NewQueryPart(
Boolean value
);

Parameters

value
false to construct a query expression that returns true when tested against the current false value of this property; true to construct a query expression that returns true when tested against any value other than the current false value of this property.

Return Value

The new query expression.

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.ToString Method

Delegate ToString() to com.starteam.BooleanProperty.WebCacheBooleanProperty.

public override string ToString();

Return Value

com.starteam.BooleanProperty.WebCacheBooleanProperty.ToString()

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BooleanProperty.WebCacheBooleanProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

BooleanProperty.WebCacheBooleanProperty Class | StarTeam Namespace


BuildNumber Class

A simple class that provides access to version information for the starteam SDK. The current version is "StarTeam SDK 17.0, Build 34".

For a list of all members of this type, see BuildNumber Members.

System.Object
BuildNumber

public class BuildNumber

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

BuildNumber Members | StarTeam Namespace


BuildNumber Members

BuildNumber overview

Public Static Properties

BranchNumber | [read] The internal development branch number (currently 1).
Build | [read] The product build number (currently 34).
BuildString | [read] The full product version string, showing major version, minor version, internal development branch and build number (currently, "17.0.1.34").
DisplayString | [read] A display string showing the full product name, version and build number (currently "StarTeam SDK 17.0, Build 34").
MajorVersion | [read] The product major version number (currently 17).
MinorVersion | [read] The product minor version number (currently 0).
ProductName | [read] The product name (currently "StarTeam SDK").
VersionString | [read] The product version string, showing major and minor version numbers (currently, "17.0").

Public Instance Methods

Equals | Delegate Equals() to com.starteam.BuildNumber.
GetHashCode | Delegate GetHashCode() to com.starteam.BuildNumber.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.BuildNumber.

See Also

BuildNumber Class | StarTeam Namespace


BuildNumber Properties

The properties of the BuildNumber class are listed below. For a complete list of BuildNumber class members, see the BuildNumber Members topic.

Public Static Properties

BranchNumber | [read] The internal development branch number (currently 1).
Build | [read] The product build number (currently 34).
BuildString | [read] The full product version string, showing major version, minor version, internal development branch and build number (currently, "17.0.1.34").
DisplayString | [read] A display string showing the full product name, version and build number (currently "StarTeam SDK 17.0, Build 34").
MajorVersion | [read] The product major version number (currently 17).
MinorVersion | [read] The product minor version number (currently 0).
ProductName | [read] The product name (currently "StarTeam SDK").
VersionString | [read] The product version string, showing major and minor version numbers (currently, "17.0").

See Also

BuildNumber Class | StarTeam Namespace


BranchNumber Property

Borland StarTeam SDK for .NET

BuildNumber.BranchNumber Property

[read] The internal development branch number (currently 1).

public static Int32 BranchNumber {get;}

Property Value

The internal development branch number (currently 1).

See Also

BuildNumber Class | StarTeam Namespace


Build Property

Borland StarTeam SDK for .NET

BuildNumber.Build Property

[read] The product build number (currently 34).

public static Int32 Build {get;}

Property Value

The product build number (currently 34).

See Also

BuildNumber Class | StarTeam Namespace


BuildString Property

Borland StarTeam SDK for .NET

BuildNumber.BuildString Property

[read] The full product version string, showing major version, minor version, internal development branch and build number (currently, "17.0.1.34").

public static String BuildString {get;}

Property Value

The full product version string, showing major version, minor version, internal development branch and build number (currently, "17.0.1.34").

See Also

BuildNumber Class | StarTeam Namespace


DisplayString Property

Borland StarTeam SDK for .NET

BuildNumber.DisplayString Property

[read] A display string showing the full product name, version and build number (currently "StarTeam SDK 17.0, Build 34").

public static String DisplayString {get;}

Property Value

A display string showing the full product name, version and build number (currently "StarTeam SDK 17.0, Build 34").

See Also

BuildNumber Class | StarTeam Namespace


MajorVersion Property

Borland StarTeam SDK for .NET

BuildNumber.MajorVersion Property

[read] The product major version number (currently 17).

public static Int32 MajorVersion {get;}

Property Value

The product major version number (currently 17).

See Also

BuildNumber Class | StarTeam Namespace


MinorVersion Property

Borland StarTeam SDK for .NET

BuildNumber.MinorVersion Property

[read] The product minor version number (currently 0).

public static Int32 MinorVersion {get;}

Property Value

The product minor version number (currently 0).

See Also

BuildNumber Class | StarTeam Namespace


ProductName Property

Borland StarTeam SDK for .NET

BuildNumber.ProductName Property

[read] The product name (currently "StarTeam SDK").

public static String ProductName {get;}

Property Value

The product name (currently "StarTeam SDK").

See Also

BuildNumber Class | StarTeam Namespace


VersionString Property

Borland StarTeam SDK for .NET

BuildNumber.VersionString Property

[read] The product version string, showing major and minor version numbers (currently, "17.0").

public static String VersionString {get;}

Property Value

The product version string, showing major and minor version numbers (currently, "17.0").

See Also

BuildNumber Class | StarTeam Namespace


BuildNumber Methods

The methods of the BuildNumber class are listed below. For a complete list of BuildNumber class members, see the BuildNumber Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.BuildNumber.
GetHashCode | Delegate GetHashCode() to com.starteam.BuildNumber.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.BuildNumber.

See Also

BuildNumber Class | StarTeam Namespace


BuildNumber.Equals Method

Delegate Equals() to com.starteam.BuildNumber.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.BuildNumber.Equals(obj).

See Also

BuildNumber Class | StarTeam Namespace


BuildNumber.GetHashCode Method

Delegate GetHashCode() to com.starteam.BuildNumber.

public override int GetHashCode();

Return Value

com.starteam.BuildNumber.GetHashCode().

See Also

BuildNumber Class | StarTeam Namespace


BuildNumber.ToString Method

Delegate ToString() to com.starteam.BuildNumber.

public override string ToString();

Return Value

com.starteam.BuildNumber.ToString()

See Also

BuildNumber Class | StarTeam Namespace


CacheAgent Class

Describes the features of a Cache Agent, including the type of content it caches, the projects supported, and whether or not it caches object property content.

For a list of all members of this type, see CacheAgent Members.

System.Object
CacheAgent

public class CacheAgent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CacheAgent Members | StarTeam Namespace


CacheAgent Members

CacheAgent overview

Public Instance Properties

HostName | [read] The host address of this cache agent.
IsRoot | [read] boolean true if this a a Root Cache Agent
Port | [read] int the port number at which this cache agent is located
Version | [read] String version information for this Cache Agent

Public Instance Methods

CachesFileContent | returns true if this cache agent caches file content
CachesObjectPropertyContent | returns true if this cache agent caches object property content
CachesProject | Indicate if the Cache Agent is caching content for the given StarTeam server project. The method performs a case-insensitive project name comparison, leveraging the fact that some names cached by the Cache Agent may be patterns with "*" wildcards.
CachesType |
Equals | Delegate Equals() to com.starteam.CacheAgent.
GetHashCode | Delegate GetHashCode() to com.starteam.CacheAgent.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CacheAgent.

See Also

CacheAgent Class | StarTeam Namespace


CacheAgent Properties

The properties of the CacheAgent class are listed below. For a complete list of CacheAgent class members, see the CacheAgent Members topic.

Public Instance Properties

HostName | [read] The host address of this cache agent.
IsRoot | [read] boolean true if this a a Root Cache Agent
Port | [read] int the port number at which this cache agent is located
Version | [read] String version information for this Cache Agent

See Also

CacheAgent Class | StarTeam Namespace


HostName Property

Borland StarTeam SDK for .NET

CacheAgent.HostName Property

[read] The host address of this cache agent.

public virtual String HostName {get;}

Property Value

The host address of this cache agent.

See Also

CacheAgent Class | StarTeam Namespace


IsRoot Property

Borland StarTeam SDK for .NET

CacheAgent.IsRoot Property

[read] boolean true if this a a Root Cache Agent

public virtual Boolean IsRoot {get;}

Property Value

boolean true if this a a Root Cache Agent

See Also

CacheAgent Class | StarTeam Namespace


Port Property

Borland StarTeam SDK for .NET

CacheAgent.Port Property

[read] int the port number at which this cache agent is located

public virtual Int32 Port {get;}

Property Value

int the port number at which this cache agent is located

See Also

CacheAgent Class | StarTeam Namespace


Version Property

Borland StarTeam SDK for .NET

CacheAgent.Version Property

[read] String version information for this Cache Agent

public virtual String Version {get;}

Property Value

String version information for this Cache Agent

See Also

CacheAgent Class | StarTeam Namespace


CacheAgent Methods

The methods of the CacheAgent class are listed below. For a complete list of CacheAgent class members, see the CacheAgent Members topic.

Public Instance Methods

CachesFileContent | returns true if this cache agent caches file content
CachesObjectPropertyContent | returns true if this cache agent caches object property content
CachesProject | Indicate if the Cache Agent is caching content for the given StarTeam server project. The method performs a case-insensitive project name comparison, leveraging the fact that some names cached by the Cache Agent may be patterns with "*" wildcards.
CachesType |
Equals | Delegate Equals() to com.starteam.CacheAgent.
GetHashCode | Delegate GetHashCode() to com.starteam.CacheAgent.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CacheAgent.

See Also

CacheAgent Class | StarTeam Namespace


CacheAgent.CachesFileContent Method

returns true if this cache agent caches file content

public virtual bool CachesFileContent();

Return Value

boolean true if this cache agent caches file content

See Also

CacheAgent Class | StarTeam Namespace


CacheAgent.CachesObjectPropertyContent Method

returns true if this cache agent caches object property content

public virtual bool CachesObjectPropertyContent();

Return Value

boolean true if this cache agent caches object property content

See Also

CacheAgent Class | StarTeam Namespace


CacheAgent.CachesProject Method

Indicate if the Cache Agent is caching content for the given StarTeam server project. The method performs a case-insensitive project name comparison, leveraging the fact that some names cached by the Cache Agent may be patterns with "*" wildcards.

public virtual bool CachesProject(
Project project
);

Parameters

project
A project.

Return Value

boolean

See Also

CacheAgent Class | StarTeam Namespace


CacheAgent.CachesType Method

public virtual bool CachesType(
Item.Type type
);

See Also

CacheAgent Class | StarTeam Namespace


CacheAgent.Equals Method

Delegate Equals() to com.starteam.CacheAgent.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CacheAgent.Equals(obj).

See Also

CacheAgent Class | StarTeam Namespace


CacheAgent.GetHashCode Method

Delegate GetHashCode() to com.starteam.CacheAgent.

public override int GetHashCode();

Return Value

com.starteam.CacheAgent.GetHashCode().

See Also

CacheAgent Class | StarTeam Namespace


CacheAgent.ToString Method

Delegate ToString() to com.starteam.CacheAgent.

public override string ToString();

Return Value

com.starteam.CacheAgent.ToString()

See Also

CacheAgent Class | StarTeam Namespace


CacheService Interface

The CacheService is implemented by StarTeam objects that support caching data locally The data will typically have been fetched from the server, and will probably aggregate across multiple contained object instances. Important Note: This interface is not intended to be implemented by client applications. We reserve the right to add methods in the future. Applications that implement this interface may not be compatible with future versions of the StarTeam SDK.

For a list of all members of this type, see CacheService Members.

public interface CacheService

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CacheService Members | StarTeam Namespace


CacheService Members

CacheService overview

Public Instance Properties

IsDiscarded [read] true if all of the cached properties of the element(s) Item have been discarded

Public Instance Methods

AreElementsPopulated | Determines whether or not this Cache Service has been populated with elements from the repository
Discard | Discards any cached properties and reduces the memory footprint of the element(s)
IsPopulated | Overloaded. Determines whether or not the element(s) have been populated with all available properties this is equivalent to isPopulated(null)
IsRefreshRequired | Overloaded. Determines whether or not any of the available properties need to be refreshed
Populate | Overloaded. Populates all properties, if necessary this is equivalent to populate(null)
Refresh | Overloaded. Refreshes the members of the collection and all available property values, if necessary

See Also

CacheService Interface | StarTeam Namespace


CacheService Properties

The properties of the CacheService interface are listed below. For a complete list of CacheService interface members, see the CacheService Members topic.

Public Instance Properties

IsDiscarded [read] true if all of the cached properties of the element(s) Item have been discarded

See Also

CacheService Interface | StarTeam Namespace


IsDiscarded Property

Borland StarTeam SDK for .NET

CacheService.IsDiscarded Property

[read] true if all of the cached properties of the element(s) Item have been discarded

Boolean IsDiscarded {get;}

Property Value

true if all of the cached properties of the element(s) Item have been discarded

See Also

CacheService Interface | StarTeam Namespace


CacheService Methods

The methods of the CacheService interface are listed below. For a complete list of CacheService interface members, see the CacheService Members topic.

Public Instance Methods

AreElementsPopulated | Determines whether or not this Cache Service has been populated with elements from the repository
Discard | Discards any cached properties and reduces the memory footprint of the element(s)
IsPopulated | Overloaded. Determines whether or not the element(s) have been populated with all available properties this is equivalent to isPopulated(null)
IsRefreshRequired | Overloaded. Determines whether or not any of the available properties need to be refreshed
Populate | Overloaded. Populates all properties, if necessary this is equivalent to populate(null)
Refresh | Overloaded. Refreshes the members of the collection and all available property values, if necessary

See Also

CacheService Interface | StarTeam Namespace


CacheService.AreElementsPopulated Method

Determines whether or not this Cache Service has been populated with elements from the repository

bool AreElementsPopulated();

Return Value

true if this Cache Service has been populated with elements from the repository

See Also

CacheService Interface | StarTeam Namespace


CacheService.Discard Method

Discards any cached properties and reduces the memory footprint of the element(s)

void Discard();

See Also

CacheService Interface | StarTeam Namespace


IsPopulated Method

Borland StarTeam SDK for .NET

CacheService.IsPopulated Method

Determines whether or not the element(s) have been populated with all available properties this is equivalent to isPopulated(null)

Overload List

Determines whether or not the element(s) have been populated with all available properties this is equivalent to isPopulated(null)

bool IsPopulated();

Determines whether or not the element(s) have been populated with the specified properties

bool IsPopulated(PropertyCollection);

See Also

CacheService Interface | StarTeam Namespace | isPopulated


CacheService.IsPopulated Method ()

Determines whether or not the element(s) have been populated with all available properties this is equivalent to isPopulated(null)

bool IsPopulated();

Return Value

true if the element(s) have been populate with all available properties

See Also

CacheService Interface | StarTeam Namespace | CacheService.IsPopulated Overload List | isPopulated


CacheService.IsPopulated Method (PropertyCollection)

Determines whether or not the element(s) have been populated with the specified properties

bool IsPopulated(
PropertyCollection properties
);

Parameters

properties
a specified set of properties

Return Value

true if the element(s) have all been populated with the specified properties

See Also

CacheService Interface | StarTeam Namespace | CacheService.IsPopulated Overload List


IsRefreshRequired Method

Borland StarTeam SDK for .NET

CacheService.IsRefreshRequired Method

Determines whether or not any of the available properties need to be refreshed

Overload List

Determines whether or not any of the available properties need to be refreshed

bool IsRefreshRequired();

Determines whether or not any of the given properties need to be refreshed

bool IsRefreshRequired(PropertyCollection);

See Also

CacheService Interface | StarTeam Namespace | isRefreshRequired


CacheService.IsRefreshRequired Method ()

Determines whether or not any of the available properties need to be refreshed

bool IsRefreshRequired();

Return Value

true if any of the available properties of the element(s) need to be refreshed

See Also

CacheService Interface | StarTeam Namespace | CacheService.IsRefreshRequired Overload List | isRefreshRequired


CacheService.IsRefreshRequired Method (PropertyCollection)

Determines whether or not any of the given properties need to be refreshed

bool IsRefreshRequired(
PropertyCollection properties
);

Parameters

properties
the specified set of properties

Return Value

true if any of these properties need to be refreshed

See Also

CacheService Interface | StarTeam Namespace | CacheService.IsRefreshRequired Overload List


Populate Method

Borland StarTeam SDK for .NET

CacheService.Populate Method

Populates all properties, if necessary this is equivalent to populate(null)

Overload List

Populates all properties, if necessary this is equivalent to populate(null)

void Populate();

Populates the element(s) with the given properties, if necessary

void Populate(PropertyCollection);

See Also

CacheService Interface | StarTeam Namespace | populate


CacheService.Populate Method ()

Populates all properties, if necessary this is equivalent to populate(null)

void Populate();

See Also

CacheService Interface | StarTeam Namespace | CacheService.Populate Overload List | populate


CacheService.Populate Method (PropertyCollection)

Populates the element(s) with the given properties, if necessary

void Populate(
PropertyCollection properties
);

Parameters

properties
the specified set of properties

See Also

CacheService Interface | StarTeam Namespace | CacheService.Populate Overload List


Refresh Method

Borland StarTeam SDK for .NET

CacheService.Refresh Method

Refreshes the members of the collection and all available property values, if necessary

Overload List

Refreshes the members of the collection and all available property values, if necessary

void Refresh();

Refreshes the members of the collection and the given property values, if necessary

void Refresh(PropertyCollection);

See Also

CacheService Interface | StarTeam Namespace | refresh


CacheService.Refresh Method ()

Refreshes the members of the collection and all available property values, if necessary

void Refresh();

See Also

CacheService Interface | StarTeam Namespace | CacheService.Refresh Overload List | refresh


CacheService.Refresh Method (PropertyCollection)

Refreshes the members of the collection and the given property values, if necessary

void Refresh(
PropertyCollection properties
);

Parameters

properties
the specified set of properties

See Also

CacheService Interface | StarTeam Namespace | CacheService.Refresh Overload List


Catalog Class

The Catalog class provides "global" access to certain properties of objects from different classes. The catalog provides information about Property values for the primary descriptors of objects. Note that the catalog is highly memory intensive and hence extremely expensive Applications should make every effort to retrieve the primary descriptor of an object using all means available before falling back to the catalog

For a list of all members of this type, see Catalog Members.

System.Object
Catalog

public class Catalog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Catalog Members | StarTeam Namespace


Catalog Members

Catalog overview

Public Instance Properties

AllIDs | [read] A list of the object IDs currently stored in the catalog.
IsRefreshRequired | [read] true if catalog information may be out of date.
Properties | [read] a collection of properties for this catalog.
Type | [read] The type that owns this catalog.

Public Instance Methods

Discard | Discards all cached data for this Catalog. A subsequent get() will re-fetch the data from the server (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Catalog.
Get | Returns the property value for the specified "object" ID and property. Will throw an IllegalArgumentException if the object ID is not in the catalog. If the specified ID is not cached in the catalog this method will go to the server to get the catalog data for that ID alone. If still not found the exception is thrown.
GetHashCode | Delegate GetHashCode() to com.starteam.Catalog.
GetPrimaryDescriptor | Returns the property value for the "primary descriptor" property of the given "object" ID.
GetType (inherited from Object) | Gets the Type of the current instance.
HasID | Determines whether or not information for specified ObjectID has been cached in this Catalog.
IsRefreshIDsRequired | Returns true if a refresh() operation might have resulted in the catalog information being updated for any of the given object IDs; returns false if and only if it is known that the catalog information had not been changed since the last refresh. If MPX is not enabled, then isRefreshIDsRequired() always returns true.
Populate | Fetch the catalog data if needed. If the data has already been fetched then this is essentially a no-op.
Refresh | Update the contents of the Catalog to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshIDs | Update the contents of the Catalog for the given Object IDs to reflect recent changes to the server. If MPX is enabled, refreshIDs() is optimized to avoid unnecessary server commands.
ToString | Delegate ToString() to com.starteam.Catalog.

See Also

Catalog Class | StarTeam Namespace


Catalog Properties

The properties of the Catalog class are listed below. For a complete list of Catalog class members, see the Catalog Members topic.

Public Instance Properties

AllIDs | [read] A list of the object IDs currently stored in the catalog.
IsRefreshRequired | [read] true if catalog information may be out of date.
Properties | [read] a collection of properties for this catalog.
Type | [read] The type that owns this catalog.

See Also

Catalog Class | StarTeam Namespace


AllIDs Property

Borland StarTeam SDK for .NET

Catalog.AllIDs Property

[read] A list of the object IDs currently stored in the catalog.

public virtual Int32[] AllIDs {get;}

Property Value

A list of the object IDs currently stored in the catalog.

See Also

Catalog Class | StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

Catalog.IsRefreshRequired Property

[read] true if catalog information may be out of date.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if catalog information may be out of date.

See Also

Catalog Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Catalog.Properties Property

[read] a collection of properties for this catalog.

public virtual PropertyCollection Properties {get;}

Property Value

a collection of properties for this catalog.

See Also

Catalog Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Catalog.Type Property

[read] The type that owns this catalog.

public virtual Type Type {get;}

Property Value

The type that owns this catalog.

See Also

Catalog Class | StarTeam Namespace


Catalog Methods

The methods of the Catalog class are listed below. For a complete list of Catalog class members, see the Catalog Members topic.

Public Instance Methods

Discard | Discards all cached data for this Catalog. A subsequent get() will re-fetch the data from the server (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Catalog.
Get | Returns the property value for the specified "object" ID and property. Will throw an IllegalArgumentException if the object ID is not in the catalog. If the specified ID is not cached in the catalog this method will go to the server to get the catalog data for that ID alone. If still not found the exception is thrown.
GetHashCode | Delegate GetHashCode() to com.starteam.Catalog.
GetPrimaryDescriptor | Returns the property value for the "primary descriptor" property of the given "object" ID.
GetType (inherited from Object) | Gets the Type of the current instance.
HasID | Determines whether or not information for specified ObjectID has been cached in this Catalog.
IsRefreshIDsRequired | Returns true if a refresh() operation might have resulted in the catalog information being updated for any of the given object IDs; returns false if and only if it is known that the catalog information had not been changed since the last refresh. If MPX is not enabled, then isRefreshIDsRequired() always returns true.
Populate | Fetch the catalog data if needed. If the data has already been fetched then this is essentially a no-op.
Refresh | Update the contents of the Catalog to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshIDs | Update the contents of the Catalog for the given Object IDs to reflect recent changes to the server. If MPX is enabled, refreshIDs() is optimized to avoid unnecessary server commands.
ToString | Delegate ToString() to com.starteam.Catalog.

See Also

Catalog Class | StarTeam Namespace


Catalog.Discard Method

Discards all cached data for this Catalog. A subsequent get() will re-fetch the data from the server (even when MPX is enabled).

public virtual void Discard();

See Also

Catalog Class | StarTeam Namespace


Catalog.Equals Method

Delegate Equals() to com.starteam.Catalog.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Catalog.Equals(obj).

See Also

Catalog Class | StarTeam Namespace


Catalog.Get Method

Returns the property value for the specified "object" ID and property. Will throw an IllegalArgumentException if the object ID is not in the catalog. If the specified ID is not cached in the catalog this method will go to the server to get the catalog data for that ID alone. If still not found the exception is thrown.

public virtual object Get(
Int32 objectID,
Property prprty
);

Parameters

objectID
the object ID for requested object
prprty
the requested property

Return Value

the specified property's value for the given object or NULL.

See Also

Catalog Class | StarTeam Namespace


Catalog.GetHashCode Method

Delegate GetHashCode() to com.starteam.Catalog.

public override int GetHashCode();

Return Value

com.starteam.Catalog.GetHashCode().

See Also

Catalog Class | StarTeam Namespace


Catalog.GetPrimaryDescriptor Method

Returns the property value for the "primary descriptor" property of the given "object" ID.

public virtual object GetPrimaryDescriptor(
Int32 objectID
);

Parameters

objectID
the object ID for which you want the value.

Return Value

the value of the primary descriptor property or NULL

See Also

Catalog Class | StarTeam Namespace | isPrimaryDescriptor


Catalog.HasID Method

Determines whether or not information for specified ObjectID has been cached in this Catalog.

public virtual bool HasID(
Int32 id
);

Parameters

id
ObjectID to be examined.

Return Value

true if information for specified ID has been cached in this Catalog; false otherwise.

See Also

Catalog Class | StarTeam Namespace


Catalog.IsRefreshIDsRequired Method

Returns true if a refresh() operation might have resulted in the catalog information being updated for any of the given object IDs; returns false if and only if it is known that the catalog information had not been changed since the last refresh. If MPX is not enabled, then isRefreshIDsRequired() always returns true.

public virtual bool IsRefreshIDsRequired(
Int32[] objIDs
);

Parameters

objIDs
List of objectIDs to be tested.

Return Value

true if catalog information may be out of date.

See Also

Catalog Class | StarTeam Namespace


Catalog.Populate Method

Fetch the catalog data if needed. If the data has already been fetched then this is essentially a no-op.

public virtual void Populate();

See Also

Catalog Class | StarTeam Namespace


Catalog.Refresh Method

Update the contents of the Catalog to reflect recent changes to the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

Catalog Class | StarTeam Namespace | enableMPX


Catalog.RefreshIDs Method

Update the contents of the Catalog for the given Object IDs to reflect recent changes to the server. If MPX is enabled, refreshIDs() is optimized to avoid unnecessary server commands.

public virtual void RefreshIDs(
Int32[] objectIDs
);

Parameters

objectIDs
List of objectIDs to be refreshed.

See Also

Catalog Class | StarTeam Namespace | enableMPX


Catalog.ToString Method

Delegate ToString() to com.starteam.Catalog.

public override string ToString();

Return Value

com.starteam.Catalog.ToString()

See Also

Catalog Class | StarTeam Namespace


Catalog.WebCacheCatalog Class

The Catalog class provides "global" access to certain properties of objects from different classes. The catalog provides information about Property values for the primary descriptors of objects. Note that the catalog is highly memory intensive and hence extremely expensive Applications should make every effort to retrieve the primary descriptor of an object using all means available before falling back to the catalog

For a list of all members of this type, see Catalog.WebCacheCatalog Members.

System.Object
Catalog.WebCacheCatalog

public class Catalog.WebCacheCatalog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Catalog.WebCacheCatalog Members | StarTeam Namespace


Catalog.WebCacheCatalog Members

Catalog.WebCacheCatalog overview

Public Instance Properties

Properties | [read] a collection of properties for this catalog.
Type | [read] The type that owns this catalog.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Catalog.WebCacheCatalog.
Get |
GetHashCode | Delegate GetHashCode() to com.starteam.Catalog.WebCacheCatalog.
GetPrimaryDescriptor | Returns the property value for the "primary descriptor" property of the given "object" ID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Catalog.WebCacheCatalog.

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace


Catalog.WebCacheCatalog Properties

The properties of the Catalog.WebCacheCatalog class are listed below. For a complete list of Catalog.WebCacheCatalog class members, see the Catalog.WebCacheCatalog Members topic.

Public Instance Properties

Properties | [read] a collection of properties for this catalog.
Type | [read] The type that owns this catalog.

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Catalog.WebCacheCatalog.Properties Property

[read] a collection of properties for this catalog.

public virtual WebCacheProperty[] Properties {get;}

Property Value

a collection of properties for this catalog.

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Catalog.WebCacheCatalog.Type Property

[read] The type that owns this catalog.

public virtual Type.WebCacheType Type {get;}

Property Value

The type that owns this catalog.

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace


Catalog.WebCacheCatalog Methods

The methods of the Catalog.WebCacheCatalog class are listed below. For a complete list of Catalog.WebCacheCatalog class members, see the Catalog.WebCacheCatalog Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Catalog.WebCacheCatalog.
Get |
GetHashCode | Delegate GetHashCode() to com.starteam.Catalog.WebCacheCatalog.
GetPrimaryDescriptor | Returns the property value for the "primary descriptor" property of the given "object" ID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Catalog.WebCacheCatalog.

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace


Catalog.WebCacheCatalog.Equals Method

Delegate Equals() to com.starteam.Catalog.WebCacheCatalog.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Catalog.WebCacheCatalog.Equals(obj).

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace


Catalog.WebCacheCatalog.Get Method

public virtual object Get(
Int32 objectID,
Property.WebCacheProperty prprty
);

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace


Catalog.WebCacheCatalog.GetHashCode Method

Delegate GetHashCode() to com.starteam.Catalog.WebCacheCatalog.

public override int GetHashCode();

Return Value

com.starteam.Catalog.WebCacheCatalog.GetHashCode().

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace


Catalog.WebCacheCatalog.GetPrimaryDescriptor Method

Returns the property value for the "primary descriptor" property of the given "object" ID.

public virtual object GetPrimaryDescriptor(
Int32 objectID
);

Parameters

objectID
the object ID for which you want the value.

Return Value

the value of the primary descriptor property or NULL

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace | isPrimaryDescriptor


Catalog.WebCacheCatalog.ToString Method

Delegate ToString() to com.starteam.Catalog.WebCacheCatalog.

public override string ToString();

Return Value

com.starteam.Catalog.WebCacheCatalog.ToString()

See Also

Catalog.WebCacheCatalog Class | StarTeam Namespace


Change Class

A Change is essentially a unit of a ChangePackage. Each Change object describes one item modified during the commit.

For a list of all members of this type, see Change Members.

System.Object
TypedResource
LiveObject
Change

public class Change : LiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change Members | StarTeam Namespace


Change Members

Change overview

Public Static Methods

Find | Finds all Change objects for which the given items are the source and/or target. The source item may be null, in which case any source item will do; or, the target item may be null, in which case any target item will do. If both source and target are specified, then they must belong to the same server instance. If the source item is historical from a tip view configuration, the resultant set of changes match the source historical revision, thereby constraining results (from the tip) Similarly, if the target item is historical from a tip view configuration, the resultant set of changes match the target historical revision, thereby constraining results (from the tip) The resulting Change objects may reside in any view on this server. They are always sorted by CreatedTime, with the most recent first.
FindSource | Finds all Change objects for which the given item is the source. If the source item is from history, the resultant set of changes match the source historical revision, thereby constraining results (from the tip) The resulting Change objects may reside in any view on this server. They are always sorted by CreatedTime, with the most recent first.
FindTarget | Finds all Change objects for which the given item is the target. If the target item is from history, the resultant set of changes match the target historical revision, thereby constraining results (from the tip) The resulting Change objects may reside in any view on this server. They are always sorted by CreatedTime, with the most recent first.
HasChanges |

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackage | [read] ChangePackage
ChangeTypeValue | [read] ChangeType
CommitActionValue | [read] EnumeratedValue
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
Description | [read] String
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsEnabled | [read/write] true if this change is enabled
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ItemType | [read] Type
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Properties | [read] the properties of the Change Object Type
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
SourceItem | [read] Item
SourceLink | [read] LinkValue
SourceVersion | [read] The version number of the source item, or null.
TargetItem | [read] Item
TargetLink | [read] LinkValue
TargetVersion | [read] The version number of the target item, or null.
View | [read] View

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

Change Class | StarTeam Namespace


Change Properties

The properties of the Change class are listed below. For a complete list of Change class members, see the Change Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackage | [read] ChangePackage
ChangeTypeValue | [read] ChangeType
CommitActionValue | [read] EnumeratedValue
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
Description | [read] String
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsEnabled | [read/write] true if this change is enabled
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ItemType | [read] Type
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Properties | [read] the properties of the Change Object Type
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
SourceItem | [read] Item
SourceLink | [read] LinkValue
SourceVersion | [read] The version number of the source item, or null.
TargetItem | [read] Item
TargetLink | [read] LinkValue
TargetVersion | [read] The version number of the target item, or null.
View | [read] View

See Also

Change Class | StarTeam Namespace


ChangePackage Property

Borland StarTeam SDK for .NET

Change.ChangePackage Property

[read] ChangePackage

public virtual ChangePackage ChangePackage {get;}

Property Value

ChangePackage

See Also

Change Class | StarTeam Namespace


ChangeTypeValue Property

Borland StarTeam SDK for .NET

Change.ChangeTypeValue Property

[read] ChangeType

public virtual Change.ChangeType ChangeTypeValue {get;}

Property Value

ChangeType

See Also

Change Class | StarTeam Namespace


CommitActionValue Property

Borland StarTeam SDK for .NET

Change.CommitActionValue Property

[read] EnumeratedValue

public virtual Change.CommitAction CommitActionValue {get;}

Property Value

EnumeratedValue

See Also

Change Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Change.Description Property

[read] String

public virtual String Description {get;}

Property Value

String

See Also

Change Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Change.IsEnabled Property

[read/write] true if this change is enabled

public virtual Boolean IsEnabled {get; set;}

Property Value

true if this change is enabled

See Also

Change Class | StarTeam Namespace


ItemType Property

Borland StarTeam SDK for .NET

Change.ItemType Property

[read] Type

public virtual Item.Type ItemType {get;}

Property Value

Type

See Also

Change Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Change.Properties Property

[read] the properties of the Change Object Type

public virtual Change.Type.PropertyCollection Properties {get;}

Property Value

the properties of the Change Object Type

See Also

Change Class | StarTeam Namespace


SourceItem Property

Borland StarTeam SDK for .NET

Change.SourceItem Property

[read] Item

public virtual Item SourceItem {get;}

Property Value

Item

See Also

Change Class | StarTeam Namespace


SourceLink Property

Borland StarTeam SDK for .NET

Change.SourceLink Property

[read] LinkValue

public virtual LinkValue SourceLink {get;}

Property Value

LinkValue

See Also

Change Class | StarTeam Namespace


SourceVersion Property

Borland StarTeam SDK for .NET

Change.SourceVersion Property

[read] The version number of the source item, or null.

public virtual DotNotation SourceVersion {get;}

Property Value

The version number of the source item, or null.

See Also

Change Class | StarTeam Namespace


TargetItem Property

Borland StarTeam SDK for .NET

Change.TargetItem Property

[read] Item

public virtual Item TargetItem {get;}

Property Value

Item

See Also

Change Class | StarTeam Namespace


TargetLink Property

Borland StarTeam SDK for .NET

Change.TargetLink Property

[read] LinkValue

public virtual LinkValue TargetLink {get;}

Property Value

LinkValue

See Also

Change Class | StarTeam Namespace


TargetVersion Property

Borland StarTeam SDK for .NET

Change.TargetVersion Property

[read] The version number of the target item, or null.

public virtual DotNotation TargetVersion {get;}

Property Value

The version number of the target item, or null.

See Also

Change Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Change.View Property

[read] View

public virtual View View {get;}

Property Value

View

See Also

Change Class | StarTeam Namespace


Change Methods

The methods of the Change class are listed below. For a complete list of Change class members, see the Change Members topic.

Public Static Methods

Find | Finds all Change objects for which the given items are the source and/or target. The source item may be null, in which case any source item will do; or, the target item may be null, in which case any target item will do. If both source and target are specified, then they must belong to the same server instance. If the source item is historical from a tip view configuration, the resultant set of changes match the source historical revision, thereby constraining results (from the tip) Similarly, if the target item is historical from a tip view configuration, the resultant set of changes match the target historical revision, thereby constraining results (from the tip) The resulting Change objects may reside in any view on this server. They are always sorted by CreatedTime, with the most recent first.
FindSource | Finds all Change objects for which the given item is the source. If the source item is from history, the resultant set of changes match the source historical revision, thereby constraining results (from the tip) The resulting Change objects may reside in any view on this server. They are always sorted by CreatedTime, with the most recent first.
FindTarget | Finds all Change objects for which the given item is the target. If the target item is from history, the resultant set of changes match the target historical revision, thereby constraining results (from the tip) The resulting Change objects may reside in any view on this server. They are always sorted by CreatedTime, with the most recent first.
HasChanges |

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

Change Class | StarTeam Namespace


Change.Find Method

Finds all Change objects for which the given items are the source and/or target.

The source item may be null, in which case any source item will do; or, the target item may be null, in which case any target item will do. If both source and target are specified, then they must belong to the same server instance. If the source item is historical from a tip view configuration, the resultant set of changes match the source historical revision, thereby constraining results (from the tip) Similarly, if the target item is historical from a tip view configuration, the resultant set of changes match the target historical revision, thereby constraining results (from the tip)

The resulting Change objects may reside in any view on this server. They are always sorted by CreatedTime, with the most recent first.

public static ChangeCollection Find(
Item source,
Item target
);

Parameters

source
Item
target
Item

Return Value

ChangeCollection

See Also

Change Class | StarTeam Namespace


Change.FindSource Method

Finds all Change objects for which the given item is the source. If the source item is from history, the resultant set of changes match the source historical revision, thereby constraining results (from the tip)

The resulting Change objects may reside in any view on this server. They are always sorted by CreatedTime, with the most recent first.

public static ChangeCollection FindSource(
Item source
);

Parameters

source
Item

Return Value

ChangeCollection

See Also

Change Class | StarTeam Namespace


Change.FindTarget Method

Finds all Change objects for which the given item is the target. If the target item is from history, the resultant set of changes match the target historical revision, thereby constraining results (from the tip)

The resulting Change objects may reside in any view on this server. They are always sorted by CreatedTime, with the most recent first.

public static ChangeCollection FindTarget(
Item target
);

Parameters

target
Item

Return Value

ChangeCollection

See Also

Change Class | StarTeam Namespace


Change.HasChanges Method

public static bool[] HasChanges(
Item[] sources,
Item[] targets
);

See Also

Change Class | StarTeam Namespace


Change.ChangeAtomType Class

a ChangeAtom Type

For a list of all members of this type, see Change.ChangeAtomType Members.

System.Object
Change.ChangeAtomType

public class Change.ChangeAtomType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.ChangeAtomType Members | StarTeam Namespace


Change.ChangeAtomType Members

Change.ChangeAtomType overview

Public Static Properties

ADDED
MODIFIED
REMOVED
RENAMED
RENAMED_AND_MODIFIED
UNKNOWN

Public Instance Properties

ID [read] The ID of this ChangeAtom Type value.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Change.ChangeAtomType.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.ChangeAtomType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Change.ChangeAtomType.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


Change.ChangeAtomType Properties

The properties of the Change.ChangeAtomType class are listed below. For a complete list of Change.ChangeAtomType class members, see the Change.ChangeAtomType Members topic.

Public Static Properties

ADDED
MODIFIED
REMOVED
RENAMED
RENAMED_AND_MODIFIED
UNKNOWN

Public Instance Properties

ID [read] The ID of this ChangeAtom Type value.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


ADDED Property

Borland StarTeam SDK for .NET

Change.ChangeAtomType.ADDED Property

public static Change.ChangeAtomType ADDED {get;}

Property Value

Added.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Change.ChangeAtomType.ID Property

[read] The ID of this ChangeAtom Type value.

public virtual Int32 ID {get;}

Property Value

The ID of this ChangeAtom Type value.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


MODIFIED Property

Borland StarTeam SDK for .NET

Change.ChangeAtomType.MODIFIED Property

public static Change.ChangeAtomType MODIFIED {get;}

Property Value

Modified.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


REMOVED Property

Borland StarTeam SDK for .NET

Change.ChangeAtomType.REMOVED Property

public static Change.ChangeAtomType REMOVED {get;}

Property Value

Removed.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


RENAMED Property

Borland StarTeam SDK for .NET

Change.ChangeAtomType.RENAMED Property

public static Change.ChangeAtomType RENAMED {get;}

Property Value

Renamed.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


RENAMED_AND_MODIFIED Property

Borland StarTeam SDK for .NET

Change.ChangeAtomType.RENAMED_AND_MODIFIED Property

public static Change.ChangeAtomType RENAMED_AND_MODIFIED {get;}

Property Value

Renamed and Modified.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

Change.ChangeAtomType.UNKNOWN Property

public static Change.ChangeAtomType UNKNOWN {get;}

Property Value

Unknown.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


Change.ChangeAtomType Methods

The methods of the Change.ChangeAtomType class are listed below. For a complete list of Change.ChangeAtomType class members, see the Change.ChangeAtomType Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Change.ChangeAtomType.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.ChangeAtomType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Change.ChangeAtomType.

See Also

Change.ChangeAtomType Class | StarTeam Namespace


Change.ChangeAtomType.Equals Method

Delegate Equals() to com.starteam.Change.ChangeAtomType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.ChangeAtomType.Equals(obj).

See Also

Change.ChangeAtomType Class | StarTeam Namespace


Change.ChangeAtomType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.ChangeAtomType.

public override int GetHashCode();

Return Value

com.starteam.Change.ChangeAtomType.GetHashCode().

See Also

Change.ChangeAtomType Class | StarTeam Namespace


Change.ChangeAtomType.ToString Method

Delegate ToString() to com.starteam.Change.ChangeAtomType.

public override string ToString();

Return Value

com.starteam.Change.ChangeAtomType.ToString()

See Also

Change.ChangeAtomType Class | StarTeam Namespace


Change.ChangeType Class

The value of the Change Type Property

For a list of all members of this type, see Change.ChangeType Members.

System.Object
EnumeratedValue
Change.ChangeType

public class Change.ChangeType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.ChangeType Members | StarTeam Namespace


Change.ChangeType Members

Change.ChangeType overview

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Change.ChangeType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Change.ChangeType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Change.ChangeType.

See Also

Change.ChangeType Class | StarTeam Namespace


Change.ChangeType Methods

The methods of the Change.ChangeType class are listed below. For a complete list of Change.ChangeType class members, see the Change.ChangeType Members topic.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Change.ChangeType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Change.ChangeType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Change.ChangeType.

See Also

Change.ChangeType Class | StarTeam Namespace


Change.ChangeType.Equals Method

Delegate Equals() to com.starteam.Change.ChangeType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.ChangeType.Equals(obj).

See Also

Change.ChangeType Class | StarTeam Namespace


Change.ChangeType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.ChangeType.

public override int GetHashCode();

Return Value

com.starteam.Change.ChangeType.GetHashCode().

See Also

Change.ChangeType Class | StarTeam Namespace


Change.ChangeType.ToString Method

Delegate ToString() to com.starteam.Change.ChangeType.

public override string ToString();

Return Value

com.starteam.Change.ChangeType.ToString()

See Also

Change.ChangeType Class | StarTeam Namespace


Change.CommitAction Class

The action that was used to commit a change.

For a list of all members of this type, see Change.CommitAction Members.

System.Object
EnumeratedValue
Change.CommitAction

public class Change.CommitAction : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.CommitAction Members | StarTeam Namespace


Change.CommitAction Members

Change.CommitAction overview

Public Static Properties

ID_FILE_ADDED
ID_FILE_MODIFIED
ID_FILE_REMOVED
ID_FILE_RENAMED
ID_FILE_RENAMED_AND_MODIFIED
ID_FILE_UNDEFINED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Change.CommitAction.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Change.CommitAction.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Change.CommitAction.

See Also

Change.CommitAction Class | StarTeam Namespace


Change.CommitAction Properties

The properties of the Change.CommitAction class are listed below. For a complete list of Change.CommitAction class members, see the Change.CommitAction Members topic.

Public Static Properties

ID_FILE_ADDED
ID_FILE_MODIFIED
ID_FILE_REMOVED
ID_FILE_RENAMED
ID_FILE_RENAMED_AND_MODIFIED
ID_FILE_UNDEFINED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Change.CommitAction Class | StarTeam Namespace


ID_FILE_ADDED Property

Borland StarTeam SDK for .NET

Change.CommitAction.ID_FILE_ADDED Property

public static Int32 ID_FILE_ADDED {get;}

See Also

Change.CommitAction Class | StarTeam Namespace


ID_FILE_MODIFIED Property

Borland StarTeam SDK for .NET

Change.CommitAction.ID_FILE_MODIFIED Property

public static Int32 ID_FILE_MODIFIED {get;}

See Also

Change.CommitAction Class | StarTeam Namespace


ID_FILE_REMOVED Property

Borland StarTeam SDK for .NET

Change.CommitAction.ID_FILE_REMOVED Property

public static Int32 ID_FILE_REMOVED {get;}

See Also

Change.CommitAction Class | StarTeam Namespace


ID_FILE_RENAMED Property

Borland StarTeam SDK for .NET

Change.CommitAction.ID_FILE_RENAMED Property

public static Int32 ID_FILE_RENAMED {get;}

See Also

Change.CommitAction Class | StarTeam Namespace


ID_FILE_RENAMED_AND_MODIFIED Property

Borland StarTeam SDK for .NET

Change.CommitAction.ID_FILE_RENAMED_AND_MODIFIED Property

public static Int32 ID_FILE_RENAMED_AND_MODIFIED {get;}

See Also

Change.CommitAction Class | StarTeam Namespace


ID_FILE_UNDEFINED Property

Borland StarTeam SDK for .NET

Change.CommitAction.ID_FILE_UNDEFINED Property

public static Int32 ID_FILE_UNDEFINED {get;}

See Also

Change.CommitAction Class | StarTeam Namespace


Change.CommitAction Methods

The methods of the Change.CommitAction class are listed below. For a complete list of Change.CommitAction class members, see the Change.CommitAction Members topic.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Change.CommitAction.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Change.CommitAction.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Change.CommitAction.

See Also

Change.CommitAction Class | StarTeam Namespace


Change.CommitAction.Equals Method

Delegate Equals() to com.starteam.Change.CommitAction.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.CommitAction.Equals(obj).

See Also

Change.CommitAction Class | StarTeam Namespace


Change.CommitAction.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.CommitAction.

public override int GetHashCode();

Return Value

com.starteam.Change.CommitAction.GetHashCode().

See Also

Change.CommitAction Class | StarTeam Namespace


Change.CommitAction.ToString Method

Delegate ToString() to com.starteam.Change.CommitAction.

public override string ToString();

Return Value

com.starteam.Change.CommitAction.ToString()

See Also

Change.CommitAction Class | StarTeam Namespace


Change.ScmChangeAtom Interface

For a list of all members of this type, see Change.ScmChangeAtom Members.

public interface Change.ScmChangeAtom

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.ScmChangeAtom Members | StarTeam Namespace


Change.ScmChangeAtom Members

Change.ScmChangeAtom overview

Public Instance Properties

AfterDisplayPath
AfterDisplayRevision
AfterIdentifier
AtomType
BeforeDisplayPath
BeforeDisplayRevision
BeforeIdentifier
IsDirectory

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


Change.ScmChangeAtom Properties

The properties of the Change.ScmChangeAtom interface are listed below. For a complete list of Change.ScmChangeAtom interface members, see the Change.ScmChangeAtom Members topic.

Public Instance Properties

AfterDisplayPath
AfterDisplayRevision
AfterIdentifier
AtomType
BeforeDisplayPath
BeforeDisplayRevision
BeforeIdentifier
IsDirectory

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


AfterDisplayPath Property

Borland StarTeam SDK for .NET

Change.ScmChangeAtom.AfterDisplayPath Property

String AfterDisplayPath {get;}

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


AfterDisplayRevision Property

Borland StarTeam SDK for .NET

Change.ScmChangeAtom.AfterDisplayRevision Property

String AfterDisplayRevision {get;}

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


AfterIdentifier Property

Borland StarTeam SDK for .NET

Change.ScmChangeAtom.AfterIdentifier Property

String AfterIdentifier {get;}

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


AtomType Property

Borland StarTeam SDK for .NET

Change.ScmChangeAtom.AtomType Property

Change.ChangeAtomType AtomType {get;}

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


BeforeDisplayPath Property

Borland StarTeam SDK for .NET

Change.ScmChangeAtom.BeforeDisplayPath Property

String BeforeDisplayPath {get;}

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


BeforeDisplayRevision Property

Borland StarTeam SDK for .NET

Change.ScmChangeAtom.BeforeDisplayRevision Property

String BeforeDisplayRevision {get;}

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


BeforeIdentifier Property

Borland StarTeam SDK for .NET

Change.ScmChangeAtom.BeforeIdentifier Property

String BeforeIdentifier {get;}

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


IsDirectory Property

Borland StarTeam SDK for .NET

Change.ScmChangeAtom.IsDirectory Property

Boolean IsDirectory {get;}

See Also

Change.ScmChangeAtom Interface | StarTeam Namespace


Change.Type Class

The Type for Change

For a list of all members of this type, see Change.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
Change.Type

new public class Change.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.Type Members | StarTeam Namespace


Change.Type Members

Change.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Change.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Change.Type.

See Also

Change.Type Class | StarTeam Namespace


Change.Type Properties

The properties of the Change.Type class are listed below. For a complete list of Change.Type class members, see the Change.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

Change.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Change.Type.NAME Property

new public static String NAME {get;}

See Also

Change.Type Class | StarTeam Namespace


Change.Type Methods

The methods of the Change.Type class are listed below. For a complete list of Change.Type class members, see the Change.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Change.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Change.Type.

See Also

Change.Type Class | StarTeam Namespace


Change.Type.Equals Method

Delegate Equals() to com.starteam.Change.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.Type.Equals(obj).

See Also

Change.Type Class | StarTeam Namespace


Change.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.Type.

public override int GetHashCode();

Return Value

com.starteam.Change.Type.GetHashCode().

See Also

Change.Type Class | StarTeam Namespace


Change.Type.ToString Method

Delegate ToString() to com.starteam.Change.Type.

public override string ToString();

Return Value

com.starteam.Change.Type.ToString()

See Also

Change.Type Class | StarTeam Namespace


Change.Type.ActionProperty Class

The property type of the Action property.

For a list of all members of this type, see Change.Type.ActionProperty Members.

System.Object
Property
EnumeratedProperty
Change.Type.ActionProperty

public class Change.Type.ActionProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.Type.ActionProperty Members | StarTeam Namespace


Change.Type.ActionProperty Members

Change.Type.ActionProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Change.Type.ActionProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.ActionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Change.Type.ActionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.ActionProperty Class | StarTeam Namespace


Change.Type.ActionProperty Properties

The properties of the Change.Type.ActionProperty class are listed below. For a complete list of Change.Type.ActionProperty class members, see the Change.Type.ActionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Change.Type.ActionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Change.Type.ActionProperty.NAME Property

public static String NAME {get;}

See Also

Change.Type.ActionProperty Class | StarTeam Namespace


Change.Type.ActionProperty Methods

The methods of the Change.Type.ActionProperty class are listed below. For a complete list of Change.Type.ActionProperty class members, see the Change.Type.ActionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Change.Type.ActionProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.ActionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Change.Type.ActionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.ActionProperty Class | StarTeam Namespace


Change.Type.ActionProperty.Equals Method

Delegate Equals() to com.starteam.Change.Type.ActionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.Type.ActionProperty.Equals(obj).

See Also

Change.Type.ActionProperty Class | StarTeam Namespace


Change.Type.ActionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.Type.ActionProperty.

public override int GetHashCode();

Return Value

com.starteam.Change.Type.ActionProperty.GetHashCode().

See Also

Change.Type.ActionProperty Class | StarTeam Namespace


Change.Type.ActionProperty.ToString Method

Delegate ToString() to com.starteam.Change.Type.ActionProperty.

public override string ToString();

Return Value

com.starteam.Change.Type.ActionProperty.ToString()

See Also

Change.Type.ActionProperty Class | StarTeam Namespace


Change.Type.ChangePackageProperty Class

The property type of the ChangePackage property.

For a list of all members of this type, see Change.Type.ChangePackageProperty Members.

System.Object
Property
ObjectProperty
Change.Type.ChangePackageProperty

public class Change.Type.ChangePackageProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.Type.ChangePackageProperty Members | StarTeam Namespace


Change.Type.ChangePackageProperty Members

Change.Type.ChangePackageProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.ChangePackageProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.ChangePackageProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.ChangePackageProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.ChangePackageProperty Class | StarTeam Namespace


Change.Type.ChangePackageProperty Properties

The properties of the Change.Type.ChangePackageProperty class are listed below. For a complete list of Change.Type.ChangePackageProperty class members, see the Change.Type.ChangePackageProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Change.Type.ChangePackageProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Change.Type.ChangePackageProperty.NAME Property

public static String NAME {get;}

See Also

Change.Type.ChangePackageProperty Class | StarTeam Namespace


Change.Type.ChangePackageProperty Methods

The methods of the Change.Type.ChangePackageProperty class are listed below. For a complete list of Change.Type.ChangePackageProperty class members, see the Change.Type.ChangePackageProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.ChangePackageProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.ChangePackageProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.ChangePackageProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.ChangePackageProperty Class | StarTeam Namespace


Change.Type.ChangePackageProperty.Equals Method

Delegate Equals() to com.starteam.Change.Type.ChangePackageProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.Type.ChangePackageProperty.Equals(obj).

See Also

Change.Type.ChangePackageProperty Class | StarTeam Namespace


Change.Type.ChangePackageProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.Type.ChangePackageProperty.

public override int GetHashCode();

Return Value

com.starteam.Change.Type.ChangePackageProperty.GetHashCode().

See Also

Change.Type.ChangePackageProperty Class | StarTeam Namespace


Change.Type.ChangePackageProperty.ToString Method

Delegate ToString() to com.starteam.Change.Type.ChangePackageProperty.

public override string ToString();

Return Value

com.starteam.Change.Type.ChangePackageProperty.ToString()

See Also

Change.Type.ChangePackageProperty Class | StarTeam Namespace


Change.Type.ChangeTypeProperty Class

The property type of the ChangeType property.

For a list of all members of this type, see Change.Type.ChangeTypeProperty Members.

System.Object
Property
EnumeratedProperty
Change.Type.ChangeTypeProperty

public class Change.Type.ChangeTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.Type.ChangeTypeProperty Members | StarTeam Namespace


Change.Type.ChangeTypeProperty Members

Change.Type.ChangeTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Change.Type.ChangeTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.ChangeTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Change.Type.ChangeTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.ChangeTypeProperty Class | StarTeam Namespace


Change.Type.ChangeTypeProperty Properties

The properties of the Change.Type.ChangeTypeProperty class are listed below. For a complete list of Change.Type.ChangeTypeProperty class members, see the Change.Type.ChangeTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Change.Type.ChangeTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Change.Type.ChangeTypeProperty.NAME Property

public static String NAME {get;}

See Also

Change.Type.ChangeTypeProperty Class | StarTeam Namespace


Change.Type.ChangeTypeProperty Methods

The methods of the Change.Type.ChangeTypeProperty class are listed below. For a complete list of Change.Type.ChangeTypeProperty class members, see the Change.Type.ChangeTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Change.Type.ChangeTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.ChangeTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Change.Type.ChangeTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.ChangeTypeProperty Class | StarTeam Namespace


Change.Type.ChangeTypeProperty.Equals Method

Delegate Equals() to com.starteam.Change.Type.ChangeTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.Type.ChangeTypeProperty.Equals(obj).

See Also

Change.Type.ChangeTypeProperty Class | StarTeam Namespace


Change.Type.ChangeTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.Type.ChangeTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Change.Type.ChangeTypeProperty.GetHashCode().

See Also

Change.Type.ChangeTypeProperty Class | StarTeam Namespace


Change.Type.ChangeTypeProperty.ToString Method

Delegate ToString() to com.starteam.Change.Type.ChangeTypeProperty.

public override string ToString();

Return Value

com.starteam.Change.Type.ChangeTypeProperty.ToString()

See Also

Change.Type.ChangeTypeProperty Class | StarTeam Namespace


Change.Type.FlagsProperty Class

For a list of all members of this type, see Change.Type.FlagsProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Change.Type.FlagsProperty

new public class Change.Type.FlagsProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.Type.FlagsProperty Members | StarTeam Namespace


Change.Type.FlagsProperty Members

Change.Type.FlagsProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.FlagsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.FlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.FlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.FlagsProperty Class | StarTeam Namespace


Change.Type.FlagsProperty Properties

The properties of the Change.Type.FlagsProperty class are listed below. For a complete list of Change.Type.FlagsProperty class members, see the Change.Type.FlagsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Change.Type.FlagsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Change.Type.FlagsProperty.NAME Property

public static String NAME {get;}

See Also

Change.Type.FlagsProperty Class | StarTeam Namespace


Change.Type.FlagsProperty Methods

The methods of the Change.Type.FlagsProperty class are listed below. For a complete list of Change.Type.FlagsProperty class members, see the Change.Type.FlagsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.FlagsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.FlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.FlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.FlagsProperty Class | StarTeam Namespace


Change.Type.FlagsProperty.Equals Method

Delegate Equals() to com.starteam.Change.Type.FlagsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.Type.FlagsProperty.Equals(obj).

See Also

Change.Type.FlagsProperty Class | StarTeam Namespace


Change.Type.FlagsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.Type.FlagsProperty.

public override int GetHashCode();

Return Value

com.starteam.Change.Type.FlagsProperty.GetHashCode().

See Also

Change.Type.FlagsProperty Class | StarTeam Namespace


Change.Type.FlagsProperty.ToString Method

Delegate ToString() to com.starteam.Change.Type.FlagsProperty.

public override string ToString();

Return Value

com.starteam.Change.Type.FlagsProperty.ToString()

See Also

Change.Type.FlagsProperty Class | StarTeam Namespace


Change.Type.ItemTypeProperty Class

The property type of the ItemType property.

For a list of all members of this type, see Change.Type.ItemTypeProperty Members.

System.Object
Property
VectorProperty
TextProperty
Change.Type.ItemTypeProperty

public class Change.Type.ItemTypeProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.Type.ItemTypeProperty Members | StarTeam Namespace


Change.Type.ItemTypeProperty Members

Change.Type.ItemTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.ItemTypeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.ItemTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.ItemTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.ItemTypeProperty Class | StarTeam Namespace


Change.Type.ItemTypeProperty Properties

The properties of the Change.Type.ItemTypeProperty class are listed below. For a complete list of Change.Type.ItemTypeProperty class members, see the Change.Type.ItemTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Change.Type.ItemTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Change.Type.ItemTypeProperty.NAME Property

public static String NAME {get;}

See Also

Change.Type.ItemTypeProperty Class | StarTeam Namespace


Change.Type.ItemTypeProperty Methods

The methods of the Change.Type.ItemTypeProperty class are listed below. For a complete list of Change.Type.ItemTypeProperty class members, see the Change.Type.ItemTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.ItemTypeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.ItemTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.ItemTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.ItemTypeProperty Class | StarTeam Namespace


Change.Type.ItemTypeProperty.Equals Method

Delegate Equals() to com.starteam.Change.Type.ItemTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.Type.ItemTypeProperty.Equals(obj).

See Also

Change.Type.ItemTypeProperty Class | StarTeam Namespace


Change.Type.ItemTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.Type.ItemTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Change.Type.ItemTypeProperty.GetHashCode().

See Also

Change.Type.ItemTypeProperty Class | StarTeam Namespace


Change.Type.ItemTypeProperty.ToString Method

Delegate ToString() to com.starteam.Change.Type.ItemTypeProperty.

public override string ToString();

Return Value

com.starteam.Change.Type.ItemTypeProperty.ToString()

See Also

Change.Type.ItemTypeProperty Class | StarTeam Namespace


Change.Type.PropertyCollection Class

The Property Collection of a Change Object

For a list of all members of this type, see Change.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
Change.Type.PropertyCollection

public class Change.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.Type.PropertyCollection Members | StarTeam Namespace


Change.Type.PropertyCollection Members

Change.Type.PropertyCollection overview

Public Instance Properties

ACTION |
CHANGE_PACKAGE |
CHANGE_TYPE |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
FLAGS |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_TYPE |
SOURCE |
SOURCE_VERSION |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TARGET |
TARGET_VERSION |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Change.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Change.Type.PropertyCollection.

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


Change.Type.PropertyCollection Properties

The properties of the Change.Type.PropertyCollection class are listed below. For a complete list of Change.Type.PropertyCollection class members, see the Change.Type.PropertyCollection Members topic.

Public Instance Properties

ACTION |
CHANGE_PACKAGE |
CHANGE_TYPE |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
FLAGS |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_TYPE |
SOURCE |
SOURCE_VERSION |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TARGET |
TARGET_VERSION |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


ACTION Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.ACTION Property

public Change.Type.ActionProperty ACTION {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


CHANGE_PACKAGE Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.CHANGE_PACKAGE Property

public Change.Type.ChangePackageProperty CHANGE_PACKAGE {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


CHANGE_TYPE Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.CHANGE_TYPE Property

public Change.Type.ChangeTypeProperty CHANGE_TYPE {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


FLAGS Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.FLAGS Property

public Change.Type.FlagsProperty FLAGS {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


ITEM_TYPE Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.ITEM_TYPE Property

public Change.Type.ItemTypeProperty ITEM_TYPE {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


SOURCE Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.SOURCE Property

public LiveObject.Type.SourceProperty SOURCE {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


SOURCE_VERSION Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.SOURCE_VERSION Property

public Change.Type.SourceVersionProperty SOURCE_VERSION {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


TARGET Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.TARGET Property

public LiveObject.Type.TargetProperty TARGET {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


TARGET_VERSION Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.TARGET_VERSION Property

public Change.Type.TargetVersionProperty TARGET_VERSION {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Change.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


Change.Type.PropertyCollection Methods

The methods of the Change.Type.PropertyCollection class are listed below. For a complete list of Change.Type.PropertyCollection class members, see the Change.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Change.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Change.Type.PropertyCollection.

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


Change.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Change.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.Type.PropertyCollection.Equals(obj).

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


Change.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Change.Type.PropertyCollection.GetHashCode().

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


Change.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Change.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Change.Type.PropertyCollection.ToString()

See Also

Change.Type.PropertyCollection Class | StarTeam Namespace


Change.Type.SourceVersionProperty Class

The property type of the SourceVersion property.

For a list of all members of this type, see Change.Type.SourceVersionProperty Members.

System.Object
Property
VectorProperty
TextProperty
Change.Type.SourceVersionProperty

public class Change.Type.SourceVersionProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.Type.SourceVersionProperty Members | StarTeam Namespace


Change.Type.SourceVersionProperty Members

Change.Type.SourceVersionProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.SourceVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.SourceVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.SourceVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.SourceVersionProperty Class | StarTeam Namespace


Change.Type.SourceVersionProperty Properties

The properties of the Change.Type.SourceVersionProperty class are listed below. For a complete list of Change.Type.SourceVersionProperty class members, see the Change.Type.SourceVersionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Change.Type.SourceVersionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Change.Type.SourceVersionProperty.NAME Property

public static String NAME {get;}

See Also

Change.Type.SourceVersionProperty Class | StarTeam Namespace


Change.Type.SourceVersionProperty Methods

The methods of the Change.Type.SourceVersionProperty class are listed below. For a complete list of Change.Type.SourceVersionProperty class members, see the Change.Type.SourceVersionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.SourceVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.SourceVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.SourceVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.SourceVersionProperty Class | StarTeam Namespace


Change.Type.SourceVersionProperty.Equals Method

Delegate Equals() to com.starteam.Change.Type.SourceVersionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.Type.SourceVersionProperty.Equals(obj).

See Also

Change.Type.SourceVersionProperty Class | StarTeam Namespace


Change.Type.SourceVersionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.Type.SourceVersionProperty.

public override int GetHashCode();

Return Value

com.starteam.Change.Type.SourceVersionProperty.GetHashCode().

See Also

Change.Type.SourceVersionProperty Class | StarTeam Namespace


Change.Type.SourceVersionProperty.ToString Method

Delegate ToString() to com.starteam.Change.Type.SourceVersionProperty.

public override string ToString();

Return Value

com.starteam.Change.Type.SourceVersionProperty.ToString()

See Also

Change.Type.SourceVersionProperty Class | StarTeam Namespace


Change.Type.TargetVersionProperty Class

The property type of the TargetVersion property.

For a list of all members of this type, see Change.Type.TargetVersionProperty Members.

System.Object
Property
VectorProperty
TextProperty
Change.Type.TargetVersionProperty

public class Change.Type.TargetVersionProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.Type.TargetVersionProperty Members | StarTeam Namespace


Change.Type.TargetVersionProperty Members

Change.Type.TargetVersionProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.TargetVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.TargetVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.TargetVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.TargetVersionProperty Class | StarTeam Namespace


Change.Type.TargetVersionProperty Properties

The properties of the Change.Type.TargetVersionProperty class are listed below. For a complete list of Change.Type.TargetVersionProperty class members, see the Change.Type.TargetVersionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Change.Type.TargetVersionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Change.Type.TargetVersionProperty.NAME Property

public static String NAME {get;}

See Also

Change.Type.TargetVersionProperty Class | StarTeam Namespace


Change.Type.TargetVersionProperty Methods

The methods of the Change.Type.TargetVersionProperty class are listed below. For a complete list of Change.Type.TargetVersionProperty class members, see the Change.Type.TargetVersionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Change.Type.TargetVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.Type.TargetVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Change.Type.TargetVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Change.Type.TargetVersionProperty Class | StarTeam Namespace


Change.Type.TargetVersionProperty.Equals Method

Delegate Equals() to com.starteam.Change.Type.TargetVersionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.Type.TargetVersionProperty.Equals(obj).

See Also

Change.Type.TargetVersionProperty Class | StarTeam Namespace


Change.Type.TargetVersionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.Type.TargetVersionProperty.

public override int GetHashCode();

Return Value

com.starteam.Change.Type.TargetVersionProperty.GetHashCode().

See Also

Change.Type.TargetVersionProperty Class | StarTeam Namespace


Change.Type.TargetVersionProperty.ToString Method

Delegate ToString() to com.starteam.Change.Type.TargetVersionProperty.

public override string ToString();

Return Value

com.starteam.Change.Type.TargetVersionProperty.ToString()

See Also

Change.Type.TargetVersionProperty Class | StarTeam Namespace


Change.WebCacheChange Class

Change accessor for cached SDK Changes contained objects are obtained from the artifact cache

For a list of all members of this type, see Change.WebCacheChange Members.

System.Object
LiveObject.WebCacheLiveObject
Change.WebCacheChange

public class Change.WebCacheChange : WebCacheLiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Change.WebCacheChange Members | StarTeam Namespace


Change.WebCacheChange Members

Change.WebCacheChange overview

Public Instance Properties

AfterDisplayPath | [read] Human-readable label for the right-hand file content's pathname
AfterDisplayRevision | [read] Human-readable label for the right-hand file content's revision
AfterIdentifier | [read] Unique identifier for retrieving the right-hand file content
AtomType | [read] the type of the change atom
BeforeDisplayPath | [read] Human-readable label for the left-hand file content's pathname
BeforeDisplayRevision | [read] Human-readable label for the left-hand file content's revision
BeforeIdentifier | [read] Unique identifier for retrieving the left-hand file content
ChangePackage | [read] ChangePackage
ChangeTypeValue | [read] ChangeType
CommitActionValue | [read] EnumeratedValue
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
Description | [read] String
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirectory | [read] true If there is no file content change to retrieve
IsDirty | [read] true if this object is dirty
IsEnabled | [read/write] true if this change is enabled
IsNew | [read] true if this resource has not yet been stored in the server.
ItemType | [read] Type
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object
SourceItem | [read] The source endpoint of this change.
SourceLink | [read] LinkValue
SourceVersion | [read] The version number of the source item, or null.
TargetItem | [read] The target endpoint of this change.
TargetLink | [read] LinkValue
TargetVersion | [read] The version number of the target item, or null.
Traces | [read] a Trace[] of applicable Traces
View | [read] View

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.Change.WebCacheChange.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.WebCacheChange.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Change.WebCacheChange.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange Properties

The properties of the Change.WebCacheChange class are listed below. For a complete list of Change.WebCacheChange class members, see the Change.WebCacheChange Members topic.

Public Instance Properties

AfterDisplayPath | [read] Human-readable label for the right-hand file content's pathname
AfterDisplayRevision | [read] Human-readable label for the right-hand file content's revision
AfterIdentifier | [read] Unique identifier for retrieving the right-hand file content
AtomType | [read] the type of the change atom
BeforeDisplayPath | [read] Human-readable label for the left-hand file content's pathname
BeforeDisplayRevision | [read] Human-readable label for the left-hand file content's revision
BeforeIdentifier | [read] Unique identifier for retrieving the left-hand file content
ChangePackage | [read] ChangePackage
ChangeTypeValue | [read] ChangeType
CommitActionValue | [read] EnumeratedValue
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
Description | [read] String
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirectory | [read] true If there is no file content change to retrieve
IsDirty | [read] true if this object is dirty
IsEnabled | [read/write] true if this change is enabled
IsNew | [read] true if this resource has not yet been stored in the server.
ItemType | [read] Type
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object
SourceItem | [read] The source endpoint of this change.
SourceLink | [read] LinkValue
SourceVersion | [read] The version number of the source item, or null.
TargetItem | [read] The target endpoint of this change.
TargetLink | [read] LinkValue
TargetVersion | [read] The version number of the target item, or null.
Traces | [read] a Trace[] of applicable Traces
View | [read] View

See Also

Change.WebCacheChange Class | StarTeam Namespace


AfterDisplayPath Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.AfterDisplayPath Property

[read] Human-readable label for the right-hand file content's pathname

public virtual String AfterDisplayPath {get;}

Property Value

Human-readable label for the right-hand file content's pathname

See Also

Change.WebCacheChange Class | StarTeam Namespace


AfterDisplayRevision Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.AfterDisplayRevision Property

[read] Human-readable label for the right-hand file content's revision

public virtual String AfterDisplayRevision {get;}

Property Value

Human-readable label for the right-hand file content's revision

See Also

Change.WebCacheChange Class | StarTeam Namespace


AfterIdentifier Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.AfterIdentifier Property

[read] Unique identifier for retrieving the right-hand file content

public virtual String AfterIdentifier {get;}

Property Value

Unique identifier for retrieving the right-hand file content

See Also

Change.WebCacheChange Class | StarTeam Namespace


AtomType Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.AtomType Property

[read] the type of the change atom

public virtual Change.ChangeAtomType AtomType {get;}

Property Value

the type of the change atom

See Also

Change.WebCacheChange Class | StarTeam Namespace


BeforeDisplayPath Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.BeforeDisplayPath Property

[read] Human-readable label for the left-hand file content's pathname

public virtual String BeforeDisplayPath {get;}

Property Value

Human-readable label for the left-hand file content's pathname

See Also

Change.WebCacheChange Class | StarTeam Namespace


BeforeDisplayRevision Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.BeforeDisplayRevision Property

[read] Human-readable label for the left-hand file content's revision

public virtual String BeforeDisplayRevision {get;}

Property Value

Human-readable label for the left-hand file content's revision

See Also

Change.WebCacheChange Class | StarTeam Namespace


BeforeIdentifier Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.BeforeIdentifier Property

[read] Unique identifier for retrieving the left-hand file content

public virtual String BeforeIdentifier {get;}

Property Value

Unique identifier for retrieving the left-hand file content

See Also

Change.WebCacheChange Class | StarTeam Namespace


ChangePackage Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.ChangePackage Property

[read] ChangePackage

public virtual ChangePackage.WebCacheChangePackage ChangePackage {get;}

Property Value

ChangePackage

See Also

Change.WebCacheChange Class | StarTeam Namespace


ChangeTypeValue Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.ChangeTypeValue Property

[read] ChangeType

public virtual Change.ChangeType ChangeTypeValue {get;}

Property Value

ChangeType

See Also

Change.WebCacheChange Class | StarTeam Namespace


CommitActionValue Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.CommitActionValue Property

[read] EnumeratedValue

public virtual Change.CommitAction CommitActionValue {get;}

Property Value

EnumeratedValue

See Also

Change.WebCacheChange Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Change.WebCacheChange Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Change.WebCacheChange Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Change.WebCacheChange Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.Description Property

[read] String

public virtual String Description {get;}

Property Value

String

See Also

Change.WebCacheChange Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Change.WebCacheChange Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Change.WebCacheChange Class | StarTeam Namespace


IsDirectory Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.IsDirectory Property

[read] true If there is no file content change to retrieve

public virtual Boolean IsDirectory {get;}

Property Value

true If there is no file content change to retrieve

See Also

Change.WebCacheChange Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Change.WebCacheChange Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.IsEnabled Property

[read/write] true if this change is enabled

public virtual Boolean IsEnabled {get; set;}

Property Value

true if this change is enabled

See Also

Change.WebCacheChange Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Change.WebCacheChange Class | StarTeam Namespace


ItemType Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.ItemType Property

[read] Type

public virtual Item.Type.WebCacheItemType ItemType {get;}

Property Value

Type

See Also

Change.WebCacheChange Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Change.WebCacheChange Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.Name Property

new public virtual String Name {get;}

See Also

Change.WebCacheChange Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Change.WebCacheChange Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Change.WebCacheChange Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Change.WebCacheChange Class | StarTeam Namespace


SourceItem Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.SourceItem Property

[read] The source endpoint of this change.

public virtual Item.WebCacheItem SourceItem {get;}

Property Value

The source endpoint of this change.

See Also

Change.WebCacheChange Class | StarTeam Namespace


SourceLink Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.SourceLink Property

[read] LinkValue

public virtual LinkValue.WebCacheLinkValue SourceLink {get;}

Property Value

LinkValue

See Also

Change.WebCacheChange Class | StarTeam Namespace


SourceVersion Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.SourceVersion Property

[read] The version number of the source item, or null.

public virtual DotNotation SourceVersion {get;}

Property Value

The version number of the source item, or null.

See Also

Change.WebCacheChange Class | StarTeam Namespace


TargetItem Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.TargetItem Property

[read] The target endpoint of this change.

public virtual Item.WebCacheItem TargetItem {get;}

Property Value

The target endpoint of this change.

See Also

Change.WebCacheChange Class | StarTeam Namespace


TargetLink Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.TargetLink Property

[read] LinkValue

public virtual LinkValue.WebCacheLinkValue TargetLink {get;}

Property Value

LinkValue

See Also

Change.WebCacheChange Class | StarTeam Namespace


TargetVersion Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.TargetVersion Property

[read] The version number of the target item, or null.

public virtual DotNotation TargetVersion {get;}

Property Value

The version number of the target item, or null.

See Also

Change.WebCacheChange Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.Traces Property

[read] a Trace[] of applicable Traces

public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Change.WebCacheChange Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Change.WebCacheChange.View Property

[read] View

public virtual View.WebCacheView View {get;}

Property Value

View

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange Methods

The methods of the Change.WebCacheChange class are listed below. For a complete list of Change.WebCacheChange class members, see the Change.WebCacheChange Members topic.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.Change.WebCacheChange.
GetHashCode | Delegate GetHashCode() to com.starteam.Change.WebCacheChange.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Change.WebCacheChange.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange.Equals Method

Delegate Equals() to com.starteam.Change.WebCacheChange.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Change.WebCacheChange.Equals(obj).

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange.GetHashCode Method

Delegate GetHashCode() to com.starteam.Change.WebCacheChange.

public override int GetHashCode();

Return Value

com.starteam.Change.WebCacheChange.GetHashCode().

See Also

Change.WebCacheChange Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Change.WebCacheChange.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Change.WebCacheChange Class | StarTeam Namespace | Change.WebCacheChange.GetValue Overload List


Change.WebCacheChange.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Change.WebCacheChange Class | StarTeam Namespace | Change.WebCacheChange.GetValue Overload List


Change.WebCacheChange.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Change.WebCacheChange Class | StarTeam Namespace | WebCacheViewMemberCollection


Change.WebCacheChange.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Change.WebCacheChange Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Change.WebCacheChange.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Change.WebCacheChange Class | StarTeam Namespace | Change.WebCacheChange.SetValue Overload List


Change.WebCacheChange.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Change.WebCacheChange Class | StarTeam Namespace | Change.WebCacheChange.SetValue Overload List


Change.WebCacheChange.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange.ToString Method

Delegate ToString() to com.starteam.Change.WebCacheChange.

public override string ToString();

Return Value

com.starteam.Change.WebCacheChange.ToString()

See Also

Change.WebCacheChange Class | StarTeam Namespace


Change.WebCacheChange.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Change.WebCacheChange Class | StarTeam Namespace | WebCacheViewMemberCollection


ChangeCollection Class

A collection of change objects.

For a list of all members of this type, see ChangeCollection Members.

System.Object
StarTeamCollection
ChangeCollection

public class ChangeCollection : StarTeamCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeCollection Members | StarTeam Namespace


ChangeCollection Members

ChangeCollection overview

Public Instance Constructors

ChangeCollection Overloaded. Initializes a new instance of the ChangeCollection class.

Public Instance Properties

Cache | [read] CacheService
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Finds a change by object ID.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Reverse | Creates a copy of this collection whose elements are in the reverse order of this one. Note that the new collection is writable, even if the source collection is read-only.
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

ChangeCollection Class | StarTeam Namespace


ChangeCollection Constructor

Constructs a new writable ChangeCollection.

Overload List

Constructs a new writable ChangeCollection.

public ChangeCollection();

Constructs a ChangeCollection that is a copy of an existing one. Note that the new collection is writable, even if the source was read-only.

public ChangeCollection(ChangeCollection);

See Also

ChangeCollection Class | StarTeam Namespace


ChangeCollection Constructor ()

Constructs a new writable ChangeCollection.

public ChangeCollection();

See Also

ChangeCollection Class | StarTeam Namespace | ChangeCollection Constructor Overload List


ChangeCollection Constructor (ChangeCollection)

Constructs a ChangeCollection that is a copy of an existing one. Note that the new collection is writable, even if the source was read-only.

public ChangeCollection(
ChangeCollection source
);

Parameters

source
the collection to copy

See Also

ChangeCollection Class | StarTeam Namespace | ChangeCollection Constructor Overload List


ChangeCollection Properties

The properties of the ChangeCollection class are listed below. For a complete list of ChangeCollection class members, see the ChangeCollection Members topic.

Public Instance Properties

Cache | [read] CacheService
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

See Also

ChangeCollection Class | StarTeam Namespace


Cache Property

Borland StarTeam SDK for .NET

ChangeCollection.Cache Property

[read] CacheService

public virtual CacheService Cache {get;}

Property Value

CacheService

See Also

ChangeCollection Class | StarTeam Namespace


ChangeCollection Methods

The methods of the ChangeCollection class are listed below. For a complete list of ChangeCollection class members, see the ChangeCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Finds a change by object ID.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Reverse | Creates a copy of this collection whose elements are in the reverse order of this one. Note that the new collection is writable, even if the source collection is read-only.
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

ChangeCollection Class | StarTeam Namespace


ChangeCollection.Find Method

Finds a change by object ID.

public virtual Change Find(
Int32 ID
);

Parameters

ID
The object ID.

Return Value

The change with this object ID, or null if no change with the given ID was found in this collection.

See Also

ChangeCollection Class | StarTeam Namespace


ChangeCollection.Reverse Method

Creates a copy of this collection whose elements are in the reverse order of this one. Note that the new collection is writable, even if the source collection is read-only.

public virtual ChangeCollection Reverse();

Return Value

A reversed copy of this collection.

See Also

ChangeCollection Class | StarTeam Namespace


ChangePackage Class

A ChangePackage represents a set of changes to a StarTeam view that together form a single logical change. A logical change might be a bug fix, enhancement, etc. The updates made by a ChangePackage are committed in a single, atomic transaction.

For a list of all members of this type, see ChangePackage Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
ChangePackage

public class ChangePackage : ViewMember

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage Members | StarTeam Namespace


ChangePackage Members

ChangePackage overview

Public Instance Constructors

ChangePackage Constructor create a ChangePackage in this view

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Changes | [read] ChangeCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CommitTransaction | [read] Transaction
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] String
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalBranchURL | [read/write] The external Branch URL of the changeset.
ExternalCreatedBy | [read/write] The external Created By User name describing the committer of the changeset.
ExternalCreatedTime | [read/write] The External Created time of the changeset.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalRepositoryURI | [read/write] The external Repository URI of the changeset.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsActive | [read] true if this is an active ChangePackage
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsCommitted | [read] true if this is a committed ChangePackage
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsFullScope | [read]
IsMyResponsibility | [read] true if the logged in user is responsible for this ChangePackage
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] String
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PostCommitRevisionLabel | [read] The post-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PostCommitViewLabel | [read] The post-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PreCommitRevisionLabel | [read] The pre-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PreCommitViewLabel | [read] The pre-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
ProcessItem | [read]
Properties | [read] the property collection for the ChangePackage Type
ReplaySources | [read] ChangePackageCollection
ReplayTargets | [read] ChangePackageCollection
Responsibility | [read/write] User
ReviewValue | [read] Review a pulse review or null
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
SessionTypeValue | [read] ChangePackage.SessionType
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
SourceView | [read] View
StateValue | [read] ChangePackage.State
TargetView | [read] View
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddChange
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Commit
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindChange | find the change associated with the specified ChangeID
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from ViewMember) | Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Open | Overloaded. Opens the session associated with this change package. If the session is committed, it is opened in read-only mode. Otherwise, an attempt is made to open the session for writing. When opening a session for writing, an exclusive lock is obtained. The lock is optionally released when the session is closed.
PutLock (inherited from ViewMember)
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
Resolve | Gets the item revisions from the target view in the state they were in at the time the change package was committed.
Restart | Open the session associated with this change package The session is opened for writing, and is ready to re-run a compare in the current context of the source and target views
Restore | Opens and restores an uncommitted session associated with this change package. The returned session is in a disconnected state. Operations that do not require a connection to the server will succeed
Rollback | rollback the contents of this change package on disk. only committed change packages can be rolled back. i.e remove strictly the revision content of each file in this change package from the corresponding matching 'tip' file on disk. The outcome of the rollback is a set of files in the local working folders on disk which create the impression that this particular change package was not committed. If this change package resulted in a newly created file in the server, then this file will be removed from the disk. Similarly, if this change package resulted in a file deleted from the server, then this file will be brought back to the disk. (however, this is an expensive operation) Binary files cannot be rolled back, in the sense that the changes made in the context of a particular change package cannot be determined by the StarTeam SDK Merge Engine. This implementation will revert any binary files to the revision prior to this change package. All subsequent edits or changes will be lost. Note specifically that no changes are made to the server. The application developer or user should commit the changed files after testing and verification, (creating a new change package in the process).
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

ChangePackage Class | StarTeam Namespace


ChangePackage Constructor

create a ChangePackage in this view

public ChangePackage(
View view
);

Parameters

view
the view in which to create the change package

See Also

ChangePackage Class | StarTeam Namespace


ChangePackage Properties

The properties of the ChangePackage class are listed below. For a complete list of ChangePackage class members, see the ChangePackage Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Changes | [read] ChangeCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CommitTransaction | [read] Transaction
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] String
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalBranchURL | [read/write] The external Branch URL of the changeset.
ExternalCreatedBy | [read/write] The external Created By User name describing the committer of the changeset.
ExternalCreatedTime | [read/write] The External Created time of the changeset.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalRepositoryURI | [read/write] The external Repository URI of the changeset.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsActive | [read] true if this is an active ChangePackage
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsCommitted | [read] true if this is a committed ChangePackage
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsFullScope | [read]
IsMyResponsibility | [read] true if the logged in user is responsible for this ChangePackage
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] String
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PostCommitRevisionLabel | [read] The post-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PostCommitViewLabel | [read] The post-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PreCommitRevisionLabel | [read] The pre-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PreCommitViewLabel | [read] The pre-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
ProcessItem | [read]
Properties | [read] the property collection for the ChangePackage Type
ReplaySources | [read] ChangePackageCollection
ReplayTargets | [read] ChangePackageCollection
Responsibility | [read/write] User
ReviewValue | [read] Review a pulse review or null
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
SessionTypeValue | [read] ChangePackage.SessionType
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
SourceView | [read] View
StateValue | [read] ChangePackage.State
TargetView | [read] View
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

ChangePackage Class | StarTeam Namespace


Changes Property

Borland StarTeam SDK for .NET

ChangePackage.Changes Property

[read] ChangeCollection

public virtual ChangeCollection Changes {get;}

Property Value

ChangeCollection

See Also

ChangePackage Class | StarTeam Namespace


CommitTransaction Property

Borland StarTeam SDK for .NET

ChangePackage.CommitTransaction Property

[read] Transaction

public virtual Transaction CommitTransaction {get;}

Property Value

Transaction

See Also

ChangePackage Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ChangePackage.Description Property

[read/write] String

public virtual String Description {get; set;}

Property Value

String

See Also

ChangePackage Class | StarTeam Namespace


ExternalBranchURL Property

Borland StarTeam SDK for .NET

ChangePackage.ExternalBranchURL Property

[read/write] The external Branch URL of the changeset.

public virtual String ExternalBranchURL {get; set;}

Property Value

The external Branch URL of the changeset.

See Also

ChangePackage Class | StarTeam Namespace


ExternalCreatedBy Property

Borland StarTeam SDK for .NET

ChangePackage.ExternalCreatedBy Property

[read/write] The external Created By User name describing the committer of the changeset.

public virtual String ExternalCreatedBy {get; set;}

Property Value

The external Created By User name describing the committer of the changeset.

See Also

ChangePackage Class | StarTeam Namespace


ExternalCreatedTime Property

Borland StarTeam SDK for .NET

ChangePackage.ExternalCreatedTime Property

[read/write] The External Created time of the changeset.

public virtual DateTime ExternalCreatedTime {get; set;}

Property Value

The External Created time of the changeset.

See Also

ChangePackage Class | StarTeam Namespace


ExternalRepositoryURI Property

Borland StarTeam SDK for .NET

ChangePackage.ExternalRepositoryURI Property

[read/write] The external Repository URI of the changeset.

public virtual String ExternalRepositoryURI {get; set;}

Property Value

The external Repository URI of the changeset.

See Also

ChangePackage Class | StarTeam Namespace


IsActive Property

Borland StarTeam SDK for .NET

ChangePackage.IsActive Property

[read] true if this is an active ChangePackage

public virtual Boolean IsActive {get;}

Property Value

true if this is an active ChangePackage

See Also

ChangePackage Class | StarTeam Namespace


IsCommitted Property

Borland StarTeam SDK for .NET

ChangePackage.IsCommitted Property

[read] true if this is a committed ChangePackage

public virtual Boolean IsCommitted {get;}

Property Value

true if this is a committed ChangePackage

See Also

ChangePackage Class | StarTeam Namespace


IsFullScope Property

Borland StarTeam SDK for .NET

ChangePackage.IsFullScope Property

[read]

public virtual Boolean IsFullScope {get;}

See Also

ChangePackage Class | StarTeam Namespace


IsMyResponsibility Property

Borland StarTeam SDK for .NET

ChangePackage.IsMyResponsibility Property

[read] true if the logged in user is responsible for this ChangePackage

public virtual Boolean IsMyResponsibility {get;}

Property Value

true if the logged in user is responsible for this ChangePackage

See Also

ChangePackage Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ChangePackage.Name Property

[read/write] String

public virtual String Name {get; set;}

Property Value

String

See Also

ChangePackage Class | StarTeam Namespace


PostCommitRevisionLabel Property

Borland StarTeam SDK for .NET

ChangePackage.PostCommitRevisionLabel Property

[read] The post-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.

public virtual Label PostCommitRevisionLabel {get;}

Property Value

The post-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.

See Also

ChangePackage Class | StarTeam Namespace


PostCommitViewLabel Property

Borland StarTeam SDK for .NET

ChangePackage.PostCommitViewLabel Property

[read] The post-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.

public virtual Label PostCommitViewLabel {get;}

Property Value

The post-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.

See Also

ChangePackage Class | StarTeam Namespace


PreCommitRevisionLabel Property

Borland StarTeam SDK for .NET

ChangePackage.PreCommitRevisionLabel Property

[read] The pre-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.

public virtual Label PreCommitRevisionLabel {get;}

Property Value

The pre-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.

See Also

ChangePackage Class | StarTeam Namespace


PreCommitViewLabel Property

Borland StarTeam SDK for .NET

ChangePackage.PreCommitViewLabel Property

[read] The pre-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.

public virtual Label PreCommitViewLabel {get;}

Property Value

The pre-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.

See Also

ChangePackage Class | StarTeam Namespace


ProcessItem Property

Borland StarTeam SDK for .NET

ChangePackage.ProcessItem Property

[read]

public virtual Item ProcessItem {get;}

See Also

ChangePackage Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

ChangePackage.Properties Property

[read] the property collection for the ChangePackage Type

public virtual ChangePackage.Type.PropertyCollection Properties {get;}

Property Value

the property collection for the ChangePackage Type

See Also

ChangePackage Class | StarTeam Namespace


ReplaySources Property

Borland StarTeam SDK for .NET

ChangePackage.ReplaySources Property

[read] ChangePackageCollection

public virtual ChangePackageCollection ReplaySources {get;}

Property Value

ChangePackageCollection

See Also

ChangePackage Class | StarTeam Namespace


ReplayTargets Property

Borland StarTeam SDK for .NET

ChangePackage.ReplayTargets Property

[read] ChangePackageCollection

public virtual ChangePackageCollection ReplayTargets {get;}

Property Value

ChangePackageCollection

See Also

ChangePackage Class | StarTeam Namespace


Responsibility Property

Borland StarTeam SDK for .NET

ChangePackage.Responsibility Property

[read/write] User

public virtual User Responsibility {get; set;}

Property Value

User

See Also

ChangePackage Class | StarTeam Namespace


ReviewValue Property

Borland StarTeam SDK for .NET

ChangePackage.ReviewValue Property

[read] Review a pulse review or null

public virtual Review ReviewValue {get;}

Property Value

Review a pulse review or null

See Also

ChangePackage Class | StarTeam Namespace


SessionTypeValue Property

Borland StarTeam SDK for .NET

ChangePackage.SessionTypeValue Property

[read] ChangePackage.SessionType

public virtual ChangePackage.SessionType SessionTypeValue {get;}

Property Value

ChangePackage.SessionType

See Also

ChangePackage Class | StarTeam Namespace


SourceView Property

Borland StarTeam SDK for .NET

ChangePackage.SourceView Property

[read] View

public virtual View SourceView {get;}

Property Value

View

See Also

ChangePackage Class | StarTeam Namespace


StateValue Property

Borland StarTeam SDK for .NET

ChangePackage.StateValue Property

[read] ChangePackage.State

public virtual ChangePackage.State StateValue {get;}

Property Value

ChangePackage.State

See Also

ChangePackage Class | StarTeam Namespace


TargetView Property

Borland StarTeam SDK for .NET

ChangePackage.TargetView Property

[read] View

public virtual View TargetView {get;}

Property Value

View

See Also

ChangePackage Class | StarTeam Namespace


ChangePackage Methods

The methods of the ChangePackage class are listed below. For a complete list of ChangePackage class members, see the ChangePackage Members topic.

Public Instance Methods

AddChange
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Commit
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindChange | find the change associated with the specified ChangeID
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from ViewMember) | Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
Open | Overloaded. Opens the session associated with this change package. If the session is committed, it is opened in read-only mode. Otherwise, an attempt is made to open the session for writing. When opening a session for writing, an exclusive lock is obtained. The lock is optionally released when the session is closed.
PutLock (inherited from ViewMember)
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
Resolve | Gets the item revisions from the target view in the state they were in at the time the change package was committed.
Restart | Open the session associated with this change package The session is opened for writing, and is ready to re-run a compare in the current context of the source and target views
Restore | Opens and restores an uncommitted session associated with this change package. The returned session is in a disconnected state. Operations that do not require a connection to the server will succeed
Rollback | rollback the contents of this change package on disk. only committed change packages can be rolled back. i.e remove strictly the revision content of each file in this change package from the corresponding matching 'tip' file on disk. The outcome of the rollback is a set of files in the local working folders on disk which create the impression that this particular change package was not committed. If this change package resulted in a newly created file in the server, then this file will be removed from the disk. Similarly, if this change package resulted in a file deleted from the server, then this file will be brought back to the disk. (however, this is an expensive operation) Binary files cannot be rolled back, in the sense that the changes made in the context of a particular change package cannot be determined by the StarTeam SDK Merge Engine. This implementation will revert any binary files to the revision prior to this change package. All subsequent edits or changes will be lost. Note specifically that no changes are made to the server. The application developer or user should commit the changed files after testing and verification, (creating a new change package in the process).
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

ChangePackage Class | StarTeam Namespace


ChangePackage.AddChange Method

public virtual void AddChange(
LinkValue source,
LinkValue target,
Int32 action,
Boolean isDirectory
);

See Also

ChangePackage Class | StarTeam Namespace


ChangePackage.Commit Method

public virtual void Commit(
Item[] pis
);

See Also

ChangePackage Class | StarTeam Namespace


ChangePackage.FindChange Method

find the change associated with the specified ChangeID

public virtual Change FindChange(
Int32 changeID
);

Parameters

changeID
the ID of the change

Return Value

the Change, if found, or null

See Also

ChangePackage Class | StarTeam Namespace


Open Method

Borland StarTeam SDK for .NET

ChangePackage.Open Method

Opens the session associated with this change package.

If the session is committed, it is opened in read-only mode. Otherwise, an attempt is made to open the session for writing.

When opening a session for writing, an exclusive lock is obtained. The lock is optionally released when the session is closed.

Overload List

Opens the session associated with this change package. If the session is committed, it is opened in read-only mode. Otherwise, an attempt is made to open the session for writing. When opening a session for writing, an exclusive lock is obtained. The lock is optionally released when the session is closed.

public virtual ChangeSession Open();

Opens the session associated with this change package. Note that a committed session can only be opened in read-only mode. When opening a session for writing, an exclusive lock is obtained. The lock is optionally released when the session is closed.

public virtual ChangeSession Open(Boolean);

See Also

ChangePackage Class | StarTeam Namespace | open | close


ChangePackage.Open Method ()

Opens the session associated with this change package.

If the session is committed, it is opened in read-only mode. Otherwise, an attempt is made to open the session for writing.

When opening a session for writing, an exclusive lock is obtained. The lock is optionally released when the session is closed.

public virtual ChangeSession Open();

Return Value

ChangeSession

See Also

ChangePackage Class | StarTeam Namespace | ChangePackage.Open Overload List | open | close


ChangePackage.Open Method (Boolean)

Opens the session associated with this change package.

Note that a committed session can only be opened in read-only mode. When opening a session for writing, an exclusive lock is obtained. The lock is optionally released when the session is closed.

public virtual ChangeSession Open(
Boolean isReadOnly
);

Parameters

isReadOnly
true to open this session in read-only mode; false to open it for writing.

Return Value

ChangeSession

See Also

ChangePackage Class | StarTeam Namespace | ChangePackage.Open Overload List | open | close


ChangePackage.Resolve Method

Gets the item revisions from the target view in the state they were in at the time the change package was committed.

public virtual ViewMemberCollection Resolve();

Return Value

ViewMemberCollection

See Also

ChangePackage Class | StarTeam Namespace


ChangePackage.Restart Method

Open the session associated with this change package The session is opened for writing, and is ready to re-run a compare in the current context of the source and target views

public virtual ChangeSession Restart();

Return Value

ChangeSession

See Also

ChangePackage Class | StarTeam Namespace | open | open


ChangePackage.Restore Method

Opens and restores an uncommitted session associated with this change package.

The returned session is in a disconnected state. Operations that do not require a connection to the server will succeed

public virtual ChangeSession Restore();

Return Value

ChangeSession

See Also

ChangePackage Class | StarTeam Namespace | open | open | restart | close


ChangePackage.Rollback Method

rollback the contents of this change package on disk. only committed change packages can be rolled back. i.e remove strictly the revision content of each file in this change package from the corresponding matching 'tip' file on disk. The outcome of the rollback is a set of files in the local working folders on disk which create the impression that this particular change package was not committed. If this change package resulted in a newly created file in the server, then this file will be removed from the disk. Similarly, if this change package resulted in a file deleted from the server, then this file will be brought back to the disk. (however, this is an expensive operation) Binary files cannot be rolled back, in the sense that the changes made in the context of a particular change package cannot be determined by the StarTeam SDK Merge Engine. This implementation will revert any binary files to the revision prior to this change package. All subsequent edits or changes will be lost. Note specifically that no changes are made to the server. The application developer or user should commit the changed files after testing and verification, (creating a new change package in the process).

public virtual RollbackSession Rollback();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ChangePackage Class | StarTeam Namespace


ChangePackage.ScmChangeSet Interface

For a list of all members of this type, see ChangePackage.ScmChangeSet Members.

public interface ChangePackage.ScmChangeSet

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.ScmChangeSet Members | StarTeam Namespace


ChangePackage.ScmChangeSet Members

ChangePackage.ScmChangeSet overview

Public Instance Properties

BranchURL
ChangeAtoms
CreatedByLoginName
CreatedDate
DisplayName
Identifier
Message
RepositoryURI
Requests
SecondaryDisplayName
SessionTypeValue

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


ChangePackage.ScmChangeSet Properties

The properties of the ChangePackage.ScmChangeSet interface are listed below. For a complete list of ChangePackage.ScmChangeSet interface members, see the ChangePackage.ScmChangeSet Members topic.

Public Instance Properties

BranchURL
ChangeAtoms
CreatedByLoginName
CreatedDate
DisplayName
Identifier
Message
RepositoryURI
Requests
SecondaryDisplayName
SessionTypeValue

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


BranchURL Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.BranchURL Property

String BranchURL {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


ChangeAtoms Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.ChangeAtoms Property

ScmChangeAtom[] ChangeAtoms {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


CreatedByLoginName Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.CreatedByLoginName Property

String CreatedByLoginName {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


CreatedDate Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.CreatedDate Property

DateTime CreatedDate {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.DisplayName Property

String DisplayName {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.Identifier Property

String Identifier {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


Message Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.Message Property

String Message {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


RepositoryURI Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.RepositoryURI Property

String RepositoryURI {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


Requests Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.Requests Property

String[] Requests {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


SecondaryDisplayName Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.SecondaryDisplayName Property

String SecondaryDisplayName {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


SessionTypeValue Property

Borland StarTeam SDK for .NET

ChangePackage.ScmChangeSet.SessionTypeValue Property

ChangePackage.SessionType SessionTypeValue {get;}

See Also

ChangePackage.ScmChangeSet Interface | StarTeam Namespace


ChangePackage.SessionType Class

The type of VCM or Checkin Session in whose context this Change Package was committed

For a list of all members of this type, see ChangePackage.SessionType Members.

System.Object
EnumeratedValue
ChangePackage.SessionType

public class ChangePackage.SessionType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.SessionType Members | StarTeam Namespace


ChangePackage.SessionType Members

ChangePackage.SessionType overview

Public Static Properties

ALL
CHECKIN
EXTERNAL
PROMOTE
REBASE
REPLICATE

Public Static Methods

FromID | Gets the SessionType value corresponding to the given ID.
FromValue | Gets the SessionType value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this SessionType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangePackage.SessionType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.SessionType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangePackage.SessionType.

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ChangePackage.SessionType Properties

The properties of the ChangePackage.SessionType class are listed below. For a complete list of ChangePackage.SessionType class members, see the ChangePackage.SessionType Members topic.

Public Static Properties

ALL
CHECKIN
EXTERNAL
PROMOTE
REBASE
REPLICATE

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this SessionType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ChangePackage.SessionType.ALL Property

public static SessionType[] ALL {get;}

See Also

ChangePackage.SessionType Class | StarTeam Namespace


CHECKIN Property

Borland StarTeam SDK for .NET

ChangePackage.SessionType.CHECKIN Property

public static ChangePackage.SessionType CHECKIN {get;}

Property Value

A Workspace Change (Checkin) Session

See Also

ChangePackage.SessionType Class | StarTeam Namespace


EXTERNAL Property

Borland StarTeam SDK for .NET

ChangePackage.SessionType.EXTERNAL Property

public static ChangePackage.SessionType EXTERNAL {get;}

Property Value

An External Session created by Pulse

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangePackage.SessionType.ID Property

[read] The ID of this SessionType value.

public virtual Int32 ID {get;}

Property Value

The ID of this SessionType value.

See Also

ChangePackage.SessionType Class | StarTeam Namespace


PROMOTE Property

Borland StarTeam SDK for .NET

ChangePackage.SessionType.PROMOTE Property

public static ChangePackage.SessionType PROMOTE {get;}

Property Value

A VCM Promote Session

See Also

ChangePackage.SessionType Class | StarTeam Namespace


REBASE Property

Borland StarTeam SDK for .NET

ChangePackage.SessionType.REBASE Property

public static ChangePackage.SessionType REBASE {get;}

Property Value

A VCM Rebase Session

See Also

ChangePackage.SessionType Class | StarTeam Namespace


REPLICATE Property

Borland StarTeam SDK for .NET

ChangePackage.SessionType.REPLICATE Property

public static ChangePackage.SessionType REPLICATE {get;}

Property Value

A VCM Replicate Session

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ChangePackage.SessionType Methods

The methods of the ChangePackage.SessionType class are listed below. For a complete list of ChangePackage.SessionType class members, see the ChangePackage.SessionType Members topic.

Public Static Methods

FromID | Gets the SessionType value corresponding to the given ID.
FromValue | Gets the SessionType value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangePackage.SessionType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.SessionType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangePackage.SessionType.

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ChangePackage.SessionType.Equals Method

Delegate Equals() to com.starteam.ChangePackage.SessionType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.SessionType.Equals(obj).

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ChangePackage.SessionType.FromID Method

Gets the SessionType value corresponding to the given ID.

public static SessionType FromID(
Int32 id
);

Parameters

id
The ID of a SessionType value.

Return Value

The corresponding SessionType value, or null.

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ChangePackage.SessionType.FromValue Method

Gets the SessionType value corresponding to the given EnumeratedValue.

public static SessionType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a SessionTypeProperty.

Return Value

The corresponding SessionType value, or null.

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ChangePackage.SessionType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.SessionType.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.SessionType.GetHashCode().

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ChangePackage.SessionType.ToString Method

Delegate ToString() to com.starteam.ChangePackage.SessionType.

public override string ToString();

Return Value

com.starteam.ChangePackage.SessionType.ToString()

See Also

ChangePackage.SessionType Class | StarTeam Namespace


ChangePackage.State Class

The current state of the change package.

For a list of all members of this type, see ChangePackage.State Members.

System.Object
EnumeratedValue
ChangePackage.State

public class ChangePackage.State : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.State Members | StarTeam Namespace


ChangePackage.State Members

ChangePackage.State overview

Public Static Properties

ACTIVE
ALL
COMMITTED
COMPARED
NEW

Public Static Methods

FromID | Gets the State value corresponding to the given ID.
FromValue | Gets the State value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this State value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangePackage.State.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.State.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangePackage.State.

See Also

ChangePackage.State Class | StarTeam Namespace


ChangePackage.State Properties

The properties of the ChangePackage.State class are listed below. For a complete list of ChangePackage.State class members, see the ChangePackage.State Members topic.

Public Static Properties

ACTIVE
ALL
COMMITTED
COMPARED
NEW

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this State value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ChangePackage.State Class | StarTeam Namespace


ACTIVE Property

Borland StarTeam SDK for .NET

ChangePackage.State.ACTIVE Property

public static ChangePackage.State ACTIVE {get;}

Property Value

An active ChangePackage.

See Also

ChangePackage.State Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ChangePackage.State.ALL Property

public static State[] ALL {get;}

See Also

ChangePackage.State Class | StarTeam Namespace


COMMITTED Property

Borland StarTeam SDK for .NET

ChangePackage.State.COMMITTED Property

public static ChangePackage.State COMMITTED {get;}

Property Value

A committed ChangePackage.

See Also

ChangePackage.State Class | StarTeam Namespace


COMPARED Property

Borland StarTeam SDK for .NET

ChangePackage.State.COMPARED Property

public static ChangePackage.State COMPARED {get;}

Property Value

A compared ChangePackage.

See Also

ChangePackage.State Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangePackage.State.ID Property

[read] The ID of this State value.

public virtual Int32 ID {get;}

Property Value

The ID of this State value.

See Also

ChangePackage.State Class | StarTeam Namespace


NEW Property

Borland StarTeam SDK for .NET

ChangePackage.State.NEW Property

public static ChangePackage.State NEW {get;}

Property Value

A new ChangePackage.

See Also

ChangePackage.State Class | StarTeam Namespace


ChangePackage.State Methods

The methods of the ChangePackage.State class are listed below. For a complete list of ChangePackage.State class members, see the ChangePackage.State Members topic.

Public Static Methods

FromID | Gets the State value corresponding to the given ID.
FromValue | Gets the State value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangePackage.State.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.State.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangePackage.State.

See Also

ChangePackage.State Class | StarTeam Namespace


ChangePackage.State.Equals Method

Delegate Equals() to com.starteam.ChangePackage.State.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.State.Equals(obj).

See Also

ChangePackage.State Class | StarTeam Namespace


ChangePackage.State.FromID Method

Gets the State value corresponding to the given ID.

public static State FromID(
Int32 id
);

Parameters

id
A State ID.

Return Value

The corresponding State value, or null.

See Also

ChangePackage.State Class | StarTeam Namespace


ChangePackage.State.FromValue Method

Gets the State value corresponding to the given EnumeratedValue.

public static State FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StateProperty.

Return Value

The corresponding State value, or null.

See Also

ChangePackage.State Class | StarTeam Namespace


ChangePackage.State.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.State.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.State.GetHashCode().

See Also

ChangePackage.State Class | StarTeam Namespace


ChangePackage.State.ToString Method

Delegate ToString() to com.starteam.ChangePackage.State.

public override string ToString();

Return Value

com.starteam.ChangePackage.State.ToString()

See Also

ChangePackage.State Class | StarTeam Namespace


ChangePackage.Type Class

The Type of the ChangePackage component.

For a list of all members of this type, see ChangePackage.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
ChangePackage.Type

new public class ChangePackage.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type Members | StarTeam Namespace


ChangePackage.Type Members

ChangePackage.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.

See Also

ChangePackage.Type Class | StarTeam Namespace


ChangePackage.Type Properties

The properties of the ChangePackage.Type class are listed below. For a complete list of ChangePackage.Type class members, see the ChangePackage.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

ChangePackage.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.NAME Property

new public static String NAME {get;}

See Also

ChangePackage.Type Class | StarTeam Namespace


ChangePackage.Type Methods

The methods of the ChangePackage.Type class are listed below. For a complete list of ChangePackage.Type class members, see the ChangePackage.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.

See Also

ChangePackage.Type Class | StarTeam Namespace


ChangePackage.Type.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.Equals(obj).

See Also

ChangePackage.Type Class | StarTeam Namespace


ChangePackage.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.GetHashCode().

See Also

ChangePackage.Type Class | StarTeam Namespace


ChangePackage.Type.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.ToString()

See Also

ChangePackage.Type Class | StarTeam Namespace


ChangePackage.Type.CommittedByProperty Class

The property type of the Committed By property.

For a list of all members of this type, see ChangePackage.Type.CommittedByProperty Members.

System.Object
Property
ObjectProperty
ChangePackage.Type.CommittedByProperty

public class ChangePackage.Type.CommittedByProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.CommittedByProperty Members | StarTeam Namespace


ChangePackage.Type.CommittedByProperty Members

ChangePackage.Type.CommittedByProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.CommittedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.CommittedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.CommittedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.CommittedByProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedByProperty Properties

The properties of the ChangePackage.Type.CommittedByProperty class are listed below. For a complete list of ChangePackage.Type.CommittedByProperty class members, see the ChangePackage.Type.CommittedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangePackage.Type.CommittedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.CommittedByProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.CommittedByProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedByProperty Methods

The methods of the ChangePackage.Type.CommittedByProperty class are listed below. For a complete list of ChangePackage.Type.CommittedByProperty class members, see the ChangePackage.Type.CommittedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.CommittedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.CommittedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.CommittedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.CommittedByProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedByProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.CommittedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.CommittedByProperty.Equals(obj).

See Also

ChangePackage.Type.CommittedByProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.CommittedByProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.CommittedByProperty.GetHashCode().

See Also

ChangePackage.Type.CommittedByProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedByProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.CommittedByProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.CommittedByProperty.ToString()

See Also

ChangePackage.Type.CommittedByProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedInBuildProperty Class

The property type of the Committed In Build property.

For a list of all members of this type, see ChangePackage.Type.CommittedInBuildProperty Members.

System.Object
Property
ObjectProperty
ChangePackage.Type.CommittedInBuildProperty

public class ChangePackage.Type.CommittedInBuildProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.CommittedInBuildProperty Members | StarTeam Namespace


ChangePackage.Type.CommittedInBuildProperty Members

ChangePackage.Type.CommittedInBuildProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.CommittedInBuildProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.CommittedInBuildProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.CommittedInBuildProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.CommittedInBuildProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedInBuildProperty Properties

The properties of the ChangePackage.Type.CommittedInBuildProperty class are listed below. For a complete list of ChangePackage.Type.CommittedInBuildProperty class members, see the ChangePackage.Type.CommittedInBuildProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangePackage.Type.CommittedInBuildProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.CommittedInBuildProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.CommittedInBuildProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedInBuildProperty Methods

The methods of the ChangePackage.Type.CommittedInBuildProperty class are listed below. For a complete list of ChangePackage.Type.CommittedInBuildProperty class members, see the ChangePackage.Type.CommittedInBuildProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.CommittedInBuildProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.CommittedInBuildProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.CommittedInBuildProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.CommittedInBuildProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedInBuildProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.CommittedInBuildProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.CommittedInBuildProperty.Equals(obj).

See Also

ChangePackage.Type.CommittedInBuildProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedInBuildProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.CommittedInBuildProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.CommittedInBuildProperty.GetHashCode().

See Also

ChangePackage.Type.CommittedInBuildProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedInBuildProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.CommittedInBuildProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.CommittedInBuildProperty.ToString()

See Also

ChangePackage.Type.CommittedInBuildProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedTimeProperty Class

The property type of the Committed Time property.

For a list of all members of this type, see ChangePackage.Type.CommittedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ChangePackage.Type.CommittedTimeProperty

public class ChangePackage.Type.CommittedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.CommittedTimeProperty Members | StarTeam Namespace


ChangePackage.Type.CommittedTimeProperty Members

ChangePackage.Type.CommittedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.CommittedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.CommittedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.CommittedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.CommittedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedTimeProperty Properties

The properties of the ChangePackage.Type.CommittedTimeProperty class are listed below. For a complete list of ChangePackage.Type.CommittedTimeProperty class members, see the ChangePackage.Type.CommittedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangePackage.Type.CommittedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.CommittedTimeProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.CommittedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedTimeProperty Methods

The methods of the ChangePackage.Type.CommittedTimeProperty class are listed below. For a complete list of ChangePackage.Type.CommittedTimeProperty class members, see the ChangePackage.Type.CommittedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.CommittedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.CommittedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.CommittedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.CommittedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedTimeProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.CommittedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.CommittedTimeProperty.Equals(obj).

See Also

ChangePackage.Type.CommittedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.CommittedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.CommittedTimeProperty.GetHashCode().

See Also

ChangePackage.Type.CommittedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.CommittedTimeProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.CommittedTimeProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.CommittedTimeProperty.ToString()

See Also

ChangePackage.Type.CommittedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalBranchURLProperty Class

The property type of the ExternalBranchURLProperty property

For a list of all members of this type, see ChangePackage.Type.ExternalBranchURLProperty Members.

System.Object
Property
VectorProperty
TextProperty
ChangePackage.Type.ExternalBranchURLProperty

public class ChangePackage.Type.ExternalBranchURLProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.ExternalBranchURLProperty Members | StarTeam Namespace


ChangePackage.Type.ExternalBranchURLProperty Members

ChangePackage.Type.ExternalBranchURLProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ExternalBranchURLProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalBranchURLProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ExternalBranchURLProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ExternalBranchURLProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalBranchURLProperty Properties

The properties of the ChangePackage.Type.ExternalBranchURLProperty class are listed below. For a complete list of ChangePackage.Type.ExternalBranchURLProperty class members, see the ChangePackage.Type.ExternalBranchURLProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangePackage.Type.ExternalBranchURLProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.ExternalBranchURLProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.ExternalBranchURLProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalBranchURLProperty Methods

The methods of the ChangePackage.Type.ExternalBranchURLProperty class are listed below. For a complete list of ChangePackage.Type.ExternalBranchURLProperty class members, see the ChangePackage.Type.ExternalBranchURLProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ExternalBranchURLProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalBranchURLProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ExternalBranchURLProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ExternalBranchURLProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalBranchURLProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.ExternalBranchURLProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.ExternalBranchURLProperty.Equals(obj).

See Also

ChangePackage.Type.ExternalBranchURLProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalBranchURLProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalBranchURLProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.ExternalBranchURLProperty.GetHashCode().

See Also

ChangePackage.Type.ExternalBranchURLProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalBranchURLProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.ExternalBranchURLProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.ExternalBranchURLProperty.ToString()

See Also

ChangePackage.Type.ExternalBranchURLProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedByProperty Class

The property type of the ExternalCreatedByProperty property

For a list of all members of this type, see ChangePackage.Type.ExternalCreatedByProperty Members.

System.Object
Property
VectorProperty
TextProperty
ChangePackage.Type.ExternalCreatedByProperty

public class ChangePackage.Type.ExternalCreatedByProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.ExternalCreatedByProperty Members | StarTeam Namespace


ChangePackage.Type.ExternalCreatedByProperty Members

ChangePackage.Type.ExternalCreatedByProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ExternalCreatedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalCreatedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ExternalCreatedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ExternalCreatedByProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedByProperty Properties

The properties of the ChangePackage.Type.ExternalCreatedByProperty class are listed below. For a complete list of ChangePackage.Type.ExternalCreatedByProperty class members, see the ChangePackage.Type.ExternalCreatedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangePackage.Type.ExternalCreatedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.ExternalCreatedByProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.ExternalCreatedByProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedByProperty Methods

The methods of the ChangePackage.Type.ExternalCreatedByProperty class are listed below. For a complete list of ChangePackage.Type.ExternalCreatedByProperty class members, see the ChangePackage.Type.ExternalCreatedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ExternalCreatedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalCreatedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ExternalCreatedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ExternalCreatedByProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedByProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.ExternalCreatedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.ExternalCreatedByProperty.Equals(obj).

See Also

ChangePackage.Type.ExternalCreatedByProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalCreatedByProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.ExternalCreatedByProperty.GetHashCode().

See Also

ChangePackage.Type.ExternalCreatedByProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedByProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.ExternalCreatedByProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.ExternalCreatedByProperty.ToString()

See Also

ChangePackage.Type.ExternalCreatedByProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedTimeProperty Class

The property type of the External Created Time property.

For a list of all members of this type, see ChangePackage.Type.ExternalCreatedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ChangePackage.Type.ExternalCreatedTimeProperty

public class ChangePackage.Type.ExternalCreatedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.ExternalCreatedTimeProperty Members | StarTeam Namespace


ChangePackage.Type.ExternalCreatedTimeProperty Members

ChangePackage.Type.ExternalCreatedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ExternalCreatedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedTimeProperty Properties

The properties of the ChangePackage.Type.ExternalCreatedTimeProperty class are listed below. For a complete list of ChangePackage.Type.ExternalCreatedTimeProperty class members, see the ChangePackage.Type.ExternalCreatedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangePackage.Type.ExternalCreatedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.ExternalCreatedTimeProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.ExternalCreatedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedTimeProperty Methods

The methods of the ChangePackage.Type.ExternalCreatedTimeProperty class are listed below. For a complete list of ChangePackage.Type.ExternalCreatedTimeProperty class members, see the ChangePackage.Type.ExternalCreatedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ExternalCreatedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedTimeProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.Equals(obj).

See Also

ChangePackage.Type.ExternalCreatedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.GetHashCode().

See Also

ChangePackage.Type.ExternalCreatedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalCreatedTimeProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.ExternalCreatedTimeProperty.ToString()

See Also

ChangePackage.Type.ExternalCreatedTimeProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalRepositoryURIProperty Class

The property type of the ExternalRepositoryURIProperty property

For a list of all members of this type, see ChangePackage.Type.ExternalRepositoryURIProperty Members.

System.Object
Property
VectorProperty
TextProperty
ChangePackage.Type.ExternalRepositoryURIProperty

public class ChangePackage.Type.ExternalRepositoryURIProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.ExternalRepositoryURIProperty Members | StarTeam Namespace


ChangePackage.Type.ExternalRepositoryURIProperty Members

ChangePackage.Type.ExternalRepositoryURIProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ExternalRepositoryURIProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalRepositoryURIProperty Properties

The properties of the ChangePackage.Type.ExternalRepositoryURIProperty class are listed below. For a complete list of ChangePackage.Type.ExternalRepositoryURIProperty class members, see the ChangePackage.Type.ExternalRepositoryURIProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangePackage.Type.ExternalRepositoryURIProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.ExternalRepositoryURIProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.ExternalRepositoryURIProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalRepositoryURIProperty Methods

The methods of the ChangePackage.Type.ExternalRepositoryURIProperty class are listed below. For a complete list of ChangePackage.Type.ExternalRepositoryURIProperty class members, see the ChangePackage.Type.ExternalRepositoryURIProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ExternalRepositoryURIProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalRepositoryURIProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.Equals(obj).

See Also

ChangePackage.Type.ExternalRepositoryURIProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalRepositoryURIProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.GetHashCode().

See Also

ChangePackage.Type.ExternalRepositoryURIProperty Class | StarTeam Namespace


ChangePackage.Type.ExternalRepositoryURIProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.ExternalRepositoryURIProperty.ToString()

See Also

ChangePackage.Type.ExternalRepositoryURIProperty Class | StarTeam Namespace


ChangePackage.Type.FullScopeProperty Class

The property type of the FullScopeProperty property

For a list of all members of this type, see ChangePackage.Type.FullScopeProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ChangePackage.Type.FullScopeProperty

public class ChangePackage.Type.FullScopeProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.FullScopeProperty Members | StarTeam Namespace


ChangePackage.Type.FullScopeProperty Members

ChangePackage.Type.FullScopeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.FullScopeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.FullScopeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.FullScopeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.FullScopeProperty Class | StarTeam Namespace


ChangePackage.Type.FullScopeProperty Properties

The properties of the ChangePackage.Type.FullScopeProperty class are listed below. For a complete list of ChangePackage.Type.FullScopeProperty class members, see the ChangePackage.Type.FullScopeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangePackage.Type.FullScopeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.FullScopeProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.FullScopeProperty Class | StarTeam Namespace


ChangePackage.Type.FullScopeProperty Methods

The methods of the ChangePackage.Type.FullScopeProperty class are listed below. For a complete list of ChangePackage.Type.FullScopeProperty class members, see the ChangePackage.Type.FullScopeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.FullScopeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.FullScopeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.FullScopeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.FullScopeProperty Class | StarTeam Namespace


ChangePackage.Type.FullScopeProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.FullScopeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.FullScopeProperty.Equals(obj).

See Also

ChangePackage.Type.FullScopeProperty Class | StarTeam Namespace


ChangePackage.Type.FullScopeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.FullScopeProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.FullScopeProperty.GetHashCode().

See Also

ChangePackage.Type.FullScopeProperty Class | StarTeam Namespace


ChangePackage.Type.FullScopeProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.FullScopeProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.FullScopeProperty.ToString()

See Also

ChangePackage.Type.FullScopeProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitRevisionLabelProperty Class

The property type of the Post Commit Revision Label property.

For a list of all members of this type, see ChangePackage.Type.PostCommitRevisionLabelProperty Members.

System.Object
Property
ObjectProperty
ChangePackage.Type.PostCommitRevisionLabelProperty

public class ChangePackage.Type.PostCommitRevisionLabelProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.PostCommitRevisionLabelProperty Members | StarTeam Namespace


ChangePackage.Type.PostCommitRevisionLabelProperty Members

ChangePackage.Type.PostCommitRevisionLabelProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.PostCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitRevisionLabelProperty Properties

The properties of the ChangePackage.Type.PostCommitRevisionLabelProperty class are listed below. For a complete list of ChangePackage.Type.PostCommitRevisionLabelProperty class members, see the ChangePackage.Type.PostCommitRevisionLabelProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangePackage.Type.PostCommitRevisionLabelProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PostCommitRevisionLabelProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.PostCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitRevisionLabelProperty Methods

The methods of the ChangePackage.Type.PostCommitRevisionLabelProperty class are listed below. For a complete list of ChangePackage.Type.PostCommitRevisionLabelProperty class members, see the ChangePackage.Type.PostCommitRevisionLabelProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.PostCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitRevisionLabelProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.Equals(obj).

See Also

ChangePackage.Type.PostCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitRevisionLabelProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.GetHashCode().

See Also

ChangePackage.Type.PostCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitRevisionLabelProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.PostCommitRevisionLabelProperty.ToString()

See Also

ChangePackage.Type.PostCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitViewLabelProperty Class

The property type of the Post Commit View Label property.

For a list of all members of this type, see ChangePackage.Type.PostCommitViewLabelProperty Members.

System.Object
Property
ObjectProperty
ChangePackage.Type.PostCommitViewLabelProperty

public class ChangePackage.Type.PostCommitViewLabelProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.PostCommitViewLabelProperty Members | StarTeam Namespace


ChangePackage.Type.PostCommitViewLabelProperty Members

ChangePackage.Type.PostCommitViewLabelProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.PostCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitViewLabelProperty Properties

The properties of the ChangePackage.Type.PostCommitViewLabelProperty class are listed below. For a complete list of ChangePackage.Type.PostCommitViewLabelProperty class members, see the ChangePackage.Type.PostCommitViewLabelProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangePackage.Type.PostCommitViewLabelProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PostCommitViewLabelProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.PostCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitViewLabelProperty Methods

The methods of the ChangePackage.Type.PostCommitViewLabelProperty class are listed below. For a complete list of ChangePackage.Type.PostCommitViewLabelProperty class members, see the ChangePackage.Type.PostCommitViewLabelProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.PostCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitViewLabelProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.Equals(obj).

See Also

ChangePackage.Type.PostCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitViewLabelProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.GetHashCode().

See Also

ChangePackage.Type.PostCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PostCommitViewLabelProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.PostCommitViewLabelProperty.ToString()

See Also

ChangePackage.Type.PostCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitRevisionLabelProperty Class

The property type of the Pre Commit Revision Label property.

For a list of all members of this type, see ChangePackage.Type.PreCommitRevisionLabelProperty Members.

System.Object
Property
ObjectProperty
ChangePackage.Type.PreCommitRevisionLabelProperty

public class ChangePackage.Type.PreCommitRevisionLabelProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.PreCommitRevisionLabelProperty Members | StarTeam Namespace


ChangePackage.Type.PreCommitRevisionLabelProperty Members

ChangePackage.Type.PreCommitRevisionLabelProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.PreCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitRevisionLabelProperty Properties

The properties of the ChangePackage.Type.PreCommitRevisionLabelProperty class are listed below. For a complete list of ChangePackage.Type.PreCommitRevisionLabelProperty class members, see the ChangePackage.Type.PreCommitRevisionLabelProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangePackage.Type.PreCommitRevisionLabelProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PreCommitRevisionLabelProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.PreCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitRevisionLabelProperty Methods

The methods of the ChangePackage.Type.PreCommitRevisionLabelProperty class are listed below. For a complete list of ChangePackage.Type.PreCommitRevisionLabelProperty class members, see the ChangePackage.Type.PreCommitRevisionLabelProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.PreCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitRevisionLabelProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.Equals(obj).

See Also

ChangePackage.Type.PreCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitRevisionLabelProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.GetHashCode().

See Also

ChangePackage.Type.PreCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitRevisionLabelProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.PreCommitRevisionLabelProperty.ToString()

See Also

ChangePackage.Type.PreCommitRevisionLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitViewLabelProperty Class

The property type of the Pre Commit View Label property.

For a list of all members of this type, see ChangePackage.Type.PreCommitViewLabelProperty Members.

System.Object
Property
ObjectProperty
ChangePackage.Type.PreCommitViewLabelProperty

public class ChangePackage.Type.PreCommitViewLabelProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.PreCommitViewLabelProperty Members | StarTeam Namespace


ChangePackage.Type.PreCommitViewLabelProperty Members

ChangePackage.Type.PreCommitViewLabelProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.PreCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitViewLabelProperty Properties

The properties of the ChangePackage.Type.PreCommitViewLabelProperty class are listed below. For a complete list of ChangePackage.Type.PreCommitViewLabelProperty class members, see the ChangePackage.Type.PreCommitViewLabelProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangePackage.Type.PreCommitViewLabelProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PreCommitViewLabelProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.PreCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitViewLabelProperty Methods

The methods of the ChangePackage.Type.PreCommitViewLabelProperty class are listed below. For a complete list of ChangePackage.Type.PreCommitViewLabelProperty class members, see the ChangePackage.Type.PreCommitViewLabelProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.PreCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitViewLabelProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.Equals(obj).

See Also

ChangePackage.Type.PreCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitViewLabelProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.GetHashCode().

See Also

ChangePackage.Type.PreCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.PreCommitViewLabelProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.PreCommitViewLabelProperty.ToString()

See Also

ChangePackage.Type.PreCommitViewLabelProperty Class | StarTeam Namespace


ChangePackage.Type.ProcessItemProperty Class

The property type of the ProcessItem property

For a list of all members of this type, see ChangePackage.Type.ProcessItemProperty Members.

System.Object
Property
LinkProperty
ChangePackage.Type.ProcessItemProperty

public class ChangePackage.Type.ProcessItemProperty : LinkProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.ProcessItemProperty Members | StarTeam Namespace


ChangePackage.Type.ProcessItemProperty Members

ChangePackage.Type.ProcessItemProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LinkProperty) | [read/write] LinkValue
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ProcessItemProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ProcessItemProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from LinkProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LinkProperty) | Creates a new query expression that tests this property endpoint against a DateTime value.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ProcessItemProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ProcessItemProperty Class | StarTeam Namespace


ChangePackage.Type.ProcessItemProperty Properties

The properties of the ChangePackage.Type.ProcessItemProperty class are listed below. For a complete list of ChangePackage.Type.ProcessItemProperty class members, see the ChangePackage.Type.ProcessItemProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LinkProperty) | [read/write] LinkValue
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangePackage.Type.ProcessItemProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.ProcessItemProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.ProcessItemProperty Class | StarTeam Namespace


ChangePackage.Type.ProcessItemProperty Methods

The methods of the ChangePackage.Type.ProcessItemProperty class are listed below. For a complete list of ChangePackage.Type.ProcessItemProperty class members, see the ChangePackage.Type.ProcessItemProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.ProcessItemProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.ProcessItemProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from LinkProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LinkProperty) | Creates a new query expression that tests this property endpoint against a DateTime value.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.ProcessItemProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.ProcessItemProperty Class | StarTeam Namespace


ChangePackage.Type.ProcessItemProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.ProcessItemProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.ProcessItemProperty.Equals(obj).

See Also

ChangePackage.Type.ProcessItemProperty Class | StarTeam Namespace


ChangePackage.Type.ProcessItemProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.ProcessItemProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.ProcessItemProperty.GetHashCode().

See Also

ChangePackage.Type.ProcessItemProperty Class | StarTeam Namespace


ChangePackage.Type.ProcessItemProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.ProcessItemProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.ProcessItemProperty.ToString()

See Also

ChangePackage.Type.ProcessItemProperty Class | StarTeam Namespace


ChangePackage.Type.PropertyCollection Class

The PropertyCollection of the ChangePackage Type

For a list of all members of this type, see ChangePackage.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
ChangePackage.Type.PropertyCollection

new public class ChangePackage.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.PropertyCollection Members | StarTeam Namespace


ChangePackage.Type.PropertyCollection Members

ChangePackage.Type.PropertyCollection overview

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
COMMENT |
COMMENT_ID |
COMMITTED_BY |
COMMITTED_IN_BUILD |
COMMITTED_TIME |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_BRANCH_URL |
EXTERNAL_CREATED_BY |
EXTERNAL_CREATED_TIME |
EXTERNAL_ID |
EXTERNAL_REPOSITORY_URI |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FULL_SCOPE |
GLOBAL_ID |
ID |
IS_BOOKMARKED |
IS_READ_ONLY |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
POST_COMMIT_REVISION_LABEL |
POST_COMMIT_VIEW_LABEL |
PRE_COMMIT_REVISION_LABEL |
PRE_COMMIT_VIEW_LABEL |
PROCESS_ITEM |
RESPONSIBILITY |
REVISION_FLAGS |
REVISION_NUMBER |
SESSION_TYPE |
SHARE_STATE |
SHORT_COMMENT |
SOURCE_VIEW |
STATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TARGET_VIEW |
TRANSACTION_ID |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PropertyCollection.

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ChangePackage.Type.PropertyCollection Properties

The properties of the ChangePackage.Type.PropertyCollection class are listed below. For a complete list of ChangePackage.Type.PropertyCollection class members, see the ChangePackage.Type.PropertyCollection Members topic.

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
COMMENT |
COMMENT_ID |
COMMITTED_BY |
COMMITTED_IN_BUILD |
COMMITTED_TIME |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_BRANCH_URL |
EXTERNAL_CREATED_BY |
EXTERNAL_CREATED_TIME |
EXTERNAL_ID |
EXTERNAL_REPOSITORY_URI |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FULL_SCOPE |
GLOBAL_ID |
ID |
IS_BOOKMARKED |
IS_READ_ONLY |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
POST_COMMIT_REVISION_LABEL |
POST_COMMIT_VIEW_LABEL |
PRE_COMMIT_REVISION_LABEL |
PRE_COMMIT_VIEW_LABEL |
PROCESS_ITEM |
RESPONSIBILITY |
REVISION_FLAGS |
REVISION_NUMBER |
SESSION_TYPE |
SHARE_STATE |
SHORT_COMMENT |
SOURCE_VIEW |
STATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TARGET_VIEW |
TRANSACTION_ID |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


COMMITTED_BY Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.COMMITTED_BY Property

public ChangePackage.Type.CommittedByProperty COMMITTED_BY {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


COMMITTED_IN_BUILD Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.COMMITTED_IN_BUILD Property

public ChangePackage.Type.CommittedInBuildProperty COMMITTED_IN_BUILD {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


COMMITTED_TIME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.COMMITTED_TIME Property

public ChangePackage.Type.CommittedTimeProperty COMMITTED_TIME {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_BRANCH_URL Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.EXTERNAL_BRANCH_URL Property

public ChangePackage.Type.ExternalBranchURLProperty EXTERNAL_BRANCH_URL {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_CREATED_BY Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.EXTERNAL_CREATED_BY Property

public ChangePackage.Type.ExternalCreatedByProperty EXTERNAL_CREATED_BY {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_CREATED_TIME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.EXTERNAL_CREATED_TIME Property

public ChangePackage.Type.ExternalCreatedTimeProperty EXTERNAL_CREATED_TIME {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_REPOSITORY_URI Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.EXTERNAL_REPOSITORY_URI Property

public ChangePackage.Type.ExternalRepositoryURIProperty EXTERNAL_REPOSITORY_URI {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


FULL_SCOPE Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.FULL_SCOPE Property

public ChangePackage.Type.FullScopeProperty FULL_SCOPE {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


IS_BOOKMARKED Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.IS_BOOKMARKED Property

public ViewMember.Type.IsBookmarkedProperty IS_BOOKMARKED {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


IS_UNREAD Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.IS_UNREAD Property

public ViewMember.Type.IsUnreadProperty IS_UNREAD {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


POST_COMMIT_REVISION_LABEL Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.POST_COMMIT_REVISION_LABEL Property

public ChangePackage.Type.PostCommitRevisionLabelProperty POST_COMMIT_REVISION_LABEL {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


POST_COMMIT_VIEW_LABEL Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.POST_COMMIT_VIEW_LABEL Property

public ChangePackage.Type.PostCommitViewLabelProperty POST_COMMIT_VIEW_LABEL {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


PRE_COMMIT_REVISION_LABEL Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.PRE_COMMIT_REVISION_LABEL Property

public ChangePackage.Type.PreCommitRevisionLabelProperty PRE_COMMIT_REVISION_LABEL {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


PRE_COMMIT_VIEW_LABEL Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.PRE_COMMIT_VIEW_LABEL Property

public ChangePackage.Type.PreCommitViewLabelProperty PRE_COMMIT_VIEW_LABEL {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


PROCESS_ITEM Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.PROCESS_ITEM Property

public ChangePackage.Type.ProcessItemProperty PROCESS_ITEM {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


RESPONSIBILITY Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.RESPONSIBILITY Property

public ViewMember.Type.ResponsibilityProperty RESPONSIBILITY {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


SESSION_TYPE Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.SESSION_TYPE Property

public ChangePackage.Type.SessionTypeProperty SESSION_TYPE {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


SOURCE_VIEW Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.SOURCE_VIEW Property

public ChangePackage.Type.SourceViewProperty SOURCE_VIEW {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


STATE Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.STATE Property

public ChangePackage.Type.StateProperty STATE {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


TARGET_VIEW Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.TARGET_VIEW Property

public ChangePackage.Type.TargetViewProperty TARGET_VIEW {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


TRANSACTION_ID Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.TRANSACTION_ID Property

public TrackedObject.Type.TransactionIDProperty TRANSACTION_ID {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

ChangePackage.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ChangePackage.Type.PropertyCollection Methods

The methods of the ChangePackage.Type.PropertyCollection class are listed below. For a complete list of ChangePackage.Type.PropertyCollection class members, see the ChangePackage.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.PropertyCollection.

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ChangePackage.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.PropertyCollection.Equals(obj).

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ChangePackage.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.PropertyCollection.GetHashCode().

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ChangePackage.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.PropertyCollection.ToString()

See Also

ChangePackage.Type.PropertyCollection Class | StarTeam Namespace


ChangePackage.Type.SessionTypeProperty Class

The property type of the Session Type property.

For a list of all members of this type, see ChangePackage.Type.SessionTypeProperty Members.

System.Object
Property
EnumeratedProperty
ChangePackage.Type.SessionTypeProperty

public class ChangePackage.Type.SessionTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.SessionTypeProperty Members | StarTeam Namespace


ChangePackage.Type.SessionTypeProperty Members

ChangePackage.Type.SessionTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.SessionTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.SessionTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.SessionTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.SessionTypeProperty Class | StarTeam Namespace


ChangePackage.Type.SessionTypeProperty Properties

The properties of the ChangePackage.Type.SessionTypeProperty class are listed below. For a complete list of ChangePackage.Type.SessionTypeProperty class members, see the ChangePackage.Type.SessionTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ChangePackage.Type.SessionTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.SessionTypeProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.SessionTypeProperty Class | StarTeam Namespace


ChangePackage.Type.SessionTypeProperty Methods

The methods of the ChangePackage.Type.SessionTypeProperty class are listed below. For a complete list of ChangePackage.Type.SessionTypeProperty class members, see the ChangePackage.Type.SessionTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.SessionTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.SessionTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.SessionTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.SessionTypeProperty Class | StarTeam Namespace


ChangePackage.Type.SessionTypeProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.SessionTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.SessionTypeProperty.Equals(obj).

See Also

ChangePackage.Type.SessionTypeProperty Class | StarTeam Namespace


ChangePackage.Type.SessionTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ChangePackage.SessionType value
);

See Also

ChangePackage.Type.SessionTypeProperty Class | StarTeam Namespace


ChangePackage.Type.SessionTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.SessionTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.SessionTypeProperty.GetHashCode().

See Also

ChangePackage.Type.SessionTypeProperty Class | StarTeam Namespace


ChangePackage.Type.SessionTypeProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.SessionTypeProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.SessionTypeProperty.ToString()

See Also

ChangePackage.Type.SessionTypeProperty Class | StarTeam Namespace


ChangePackage.Type.SourceViewProperty Class

The property type of the Source View property.

For a list of all members of this type, see ChangePackage.Type.SourceViewProperty Members.

System.Object
Property
ObjectProperty
ChangePackage.Type.SourceViewProperty

public class ChangePackage.Type.SourceViewProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.SourceViewProperty Members | StarTeam Namespace


ChangePackage.Type.SourceViewProperty Members

ChangePackage.Type.SourceViewProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.SourceViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.SourceViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.SourceViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.SourceViewProperty Class | StarTeam Namespace


ChangePackage.Type.SourceViewProperty Properties

The properties of the ChangePackage.Type.SourceViewProperty class are listed below. For a complete list of ChangePackage.Type.SourceViewProperty class members, see the ChangePackage.Type.SourceViewProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangePackage.Type.SourceViewProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.SourceViewProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.SourceViewProperty Class | StarTeam Namespace


ChangePackage.Type.SourceViewProperty Methods

The methods of the ChangePackage.Type.SourceViewProperty class are listed below. For a complete list of ChangePackage.Type.SourceViewProperty class members, see the ChangePackage.Type.SourceViewProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.SourceViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.SourceViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.SourceViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.SourceViewProperty Class | StarTeam Namespace


ChangePackage.Type.SourceViewProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.SourceViewProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.SourceViewProperty.Equals(obj).

See Also

ChangePackage.Type.SourceViewProperty Class | StarTeam Namespace


ChangePackage.Type.SourceViewProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.SourceViewProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.SourceViewProperty.GetHashCode().

See Also

ChangePackage.Type.SourceViewProperty Class | StarTeam Namespace


ChangePackage.Type.SourceViewProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.SourceViewProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.SourceViewProperty.ToString()

See Also

ChangePackage.Type.SourceViewProperty Class | StarTeam Namespace


ChangePackage.Type.StateProperty Class

The property type of the State property.

For a list of all members of this type, see ChangePackage.Type.StateProperty Members.

System.Object
Property
EnumeratedProperty
ChangePackage.Type.StateProperty

public class ChangePackage.Type.StateProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.StateProperty Members | StarTeam Namespace


ChangePackage.Type.StateProperty Members

ChangePackage.Type.StateProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.StateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.StateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.StateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.StateProperty Class | StarTeam Namespace


ChangePackage.Type.StateProperty Properties

The properties of the ChangePackage.Type.StateProperty class are listed below. For a complete list of ChangePackage.Type.StateProperty class members, see the ChangePackage.Type.StateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ChangePackage.Type.StateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.StateProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.StateProperty Class | StarTeam Namespace


ChangePackage.Type.StateProperty Methods

The methods of the ChangePackage.Type.StateProperty class are listed below. For a complete list of ChangePackage.Type.StateProperty class members, see the ChangePackage.Type.StateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.StateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.StateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.StateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.StateProperty Class | StarTeam Namespace


ChangePackage.Type.StateProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.StateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.StateProperty.Equals(obj).

See Also

ChangePackage.Type.StateProperty Class | StarTeam Namespace


ChangePackage.Type.StateProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ChangePackage.State value
);

See Also

ChangePackage.Type.StateProperty Class | StarTeam Namespace


ChangePackage.Type.StateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.StateProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.StateProperty.GetHashCode().

See Also

ChangePackage.Type.StateProperty Class | StarTeam Namespace


ChangePackage.Type.StateProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.StateProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.StateProperty.ToString()

See Also

ChangePackage.Type.StateProperty Class | StarTeam Namespace


ChangePackage.Type.TargetViewProperty Class

The property type of the Target View property.

For a list of all members of this type, see ChangePackage.Type.TargetViewProperty Members.

System.Object
Property
ObjectProperty
ChangePackage.Type.TargetViewProperty

public class ChangePackage.Type.TargetViewProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.Type.TargetViewProperty Members | StarTeam Namespace


ChangePackage.Type.TargetViewProperty Members

ChangePackage.Type.TargetViewProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.TargetViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.TargetViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.TargetViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.TargetViewProperty Class | StarTeam Namespace


ChangePackage.Type.TargetViewProperty Properties

The properties of the ChangePackage.Type.TargetViewProperty class are listed below. For a complete list of ChangePackage.Type.TargetViewProperty class members, see the ChangePackage.Type.TargetViewProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangePackage.Type.TargetViewProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangePackage.Type.TargetViewProperty.NAME Property

public static String NAME {get;}

See Also

ChangePackage.Type.TargetViewProperty Class | StarTeam Namespace


ChangePackage.Type.TargetViewProperty Methods

The methods of the ChangePackage.Type.TargetViewProperty class are listed below. For a complete list of ChangePackage.Type.TargetViewProperty class members, see the ChangePackage.Type.TargetViewProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangePackage.Type.TargetViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.Type.TargetViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangePackage.Type.TargetViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangePackage.Type.TargetViewProperty Class | StarTeam Namespace


ChangePackage.Type.TargetViewProperty.Equals Method

Delegate Equals() to com.starteam.ChangePackage.Type.TargetViewProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.Type.TargetViewProperty.Equals(obj).

See Also

ChangePackage.Type.TargetViewProperty Class | StarTeam Namespace


ChangePackage.Type.TargetViewProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.Type.TargetViewProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.Type.TargetViewProperty.GetHashCode().

See Also

ChangePackage.Type.TargetViewProperty Class | StarTeam Namespace


ChangePackage.Type.TargetViewProperty.ToString Method

Delegate ToString() to com.starteam.ChangePackage.Type.TargetViewProperty.

public override string ToString();

Return Value

com.starteam.ChangePackage.Type.TargetViewProperty.ToString()

See Also

ChangePackage.Type.TargetViewProperty Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage Class

ChangePackage accessor for cached SDK ChangePackages contained objects are obtained from the artifact cache

For a list of all members of this type, see ChangePackage.WebCacheChangePackage Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
ChangePackage.WebCacheChangePackage

public class ChangePackage.WebCacheChangePackage : WebCacheViewMember

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackage.WebCacheChangePackage Members | StarTeam Namespace


ChangePackage.WebCacheChangePackage Members

ChangePackage.WebCacheChangePackage overview

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
BranchURL | [read] The Branch URL of this changeset
ChangeAtoms | [read] the set of change atoms
Changes | [read] ChangeCollection
Comment | [read/write] the Comment attached to this view member
CommitTransaction | [read] Transaction
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedByLoginName | [read] Author of the changeset, aka the user who committed the changeset.
CreatedDate |
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read] String
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalBranchURL | [read/write] The external Branch URL of this changeset
ExternalCreatedBy | [read/write] The external Created By User name describing the committer of this changeset
ExternalCreatedTime | [read/write] The External created time of the changeset.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalRepositoryURI | [read/write] The external Repository URI of this changeset
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] Unique identifier in the context of an instance of a VersionService and hence a VersionRepo.
IsActive | [read] true if this is an active ChangePackage
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsCommitted | [read] true if this is a committed ChangePackage
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsFullScope | [read] true if this is a full scoped ChangePackage
IsMyResponsibility | [read] true if the logged in user is responsible for this ChangePackage
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
Message | [read] Author-entered commit log message (svn), or delivery comment (dcm).
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PostCommitRevisionLabel | [read] The post-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PostCommitViewLabel | [read] The post-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PreCommitRevisionLabel | [read] The pre-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PreCommitViewLabel | [read] The pre-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PresentationID | [read] the unique integer identifier for this resource.
RepositoryURI | [read] The Repository URI of this changeset
Requests | [read] Requests/tickets have labels and identifiers, these may be the same in some systems.
Responsibility | [read] User
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
SecondaryDisplayName | [read] Some SCM systems have more than one way of referring to a changeset
Server | [read] the Server for this cached object
SessionTypeValue | [read] ChangePackage.SessionType
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
SourceView | [read] View
StateValue | [read] ChangePackage.State
TargetView | [read] View
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.ChangePackage.WebCacheChangePackage.
FindChange | Overloaded. find the change associated with the specified ChangeID
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.WebCacheChangePackage.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.ChangePackage.WebCacheChangePackage.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage Properties

The properties of the ChangePackage.WebCacheChangePackage class are listed below. For a complete list of ChangePackage.WebCacheChangePackage class members, see the ChangePackage.WebCacheChangePackage Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
BranchURL | [read] The Branch URL of this changeset
ChangeAtoms | [read] the set of change atoms
Changes | [read] ChangeCollection
Comment | [read/write] the Comment attached to this view member
CommitTransaction | [read] Transaction
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedByLoginName | [read] Author of the changeset, aka the user who committed the changeset.
CreatedDate |
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read] String
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalBranchURL | [read/write] The external Branch URL of this changeset
ExternalCreatedBy | [read/write] The external Created By User name describing the committer of this changeset
ExternalCreatedTime | [read/write] The External created time of the changeset.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalRepositoryURI | [read/write] The external Repository URI of this changeset
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] Unique identifier in the context of an instance of a VersionService and hence a VersionRepo.
IsActive | [read] true if this is an active ChangePackage
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsCommitted | [read] true if this is a committed ChangePackage
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsFullScope | [read] true if this is a full scoped ChangePackage
IsMyResponsibility | [read] true if the logged in user is responsible for this ChangePackage
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
Message | [read] Author-entered commit log message (svn), or delivery comment (dcm).
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PostCommitRevisionLabel | [read] The post-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PostCommitViewLabel | [read] The post-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PreCommitRevisionLabel | [read] The pre-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PreCommitViewLabel | [read] The pre-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.
PresentationID | [read] the unique integer identifier for this resource.
RepositoryURI | [read] The Repository URI of this changeset
Requests | [read] Requests/tickets have labels and identifiers, these may be the same in some systems.
Responsibility | [read] User
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
SecondaryDisplayName | [read] Some SCM systems have more than one way of referring to a changeset
Server | [read] the Server for this cached object
SessionTypeValue | [read] ChangePackage.SessionType
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
SourceView | [read] View
StateValue | [read] ChangePackage.State
TargetView | [read] View
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


BranchURL Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.BranchURL Property

[read] The Branch URL of this changeset

public virtual String BranchURL {get;}

Property Value

The Branch URL of this changeset

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangeAtoms Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ChangeAtoms Property

[read] the set of change atoms

public virtual ScmChangeAtom[] ChangeAtoms {get;}

Property Value

the set of change atoms

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Changes Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Changes Property

[read] ChangeCollection

public virtual WebCacheChange[] Changes {get;}

Property Value

ChangeCollection

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


CommitTransaction Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.CommitTransaction Property

[read] Transaction

public virtual Transaction.WebCacheTransaction CommitTransaction {get;}

Property Value

Transaction

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


CreatedByLoginName Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.CreatedByLoginName Property

[read] Author of the changeset, aka the user who committed the changeset.

public virtual String CreatedByLoginName {get;}

Property Value

Author of the changeset, aka the user who committed the changeset.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


CreatedDate Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.CreatedDate Property

public virtual DateTime CreatedDate {get;}

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Description Property

[read] String

public virtual String Description {get;}

Property Value

String

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ExternalBranchURL Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ExternalBranchURL Property

[read/write] The external Branch URL of this changeset

public virtual String ExternalBranchURL {get; set;}

Property Value

The external Branch URL of this changeset

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ExternalCreatedBy Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ExternalCreatedBy Property

[read/write] The external Created By User name describing the committer of this changeset

public virtual String ExternalCreatedBy {get; set;}

Property Value

The external Created By User name describing the committer of this changeset

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ExternalCreatedTime Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ExternalCreatedTime Property

[read/write] The External created time of the changeset.

public virtual DateTime ExternalCreatedTime {get; set;}

Property Value

The External created time of the changeset.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ExternalRepositoryURI Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ExternalRepositoryURI Property

[read/write] The external Repository URI of this changeset

public virtual String ExternalRepositoryURI {get; set;}

Property Value

The external Repository URI of this changeset

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Identifier Property

[read] Unique identifier in the context of an instance of a VersionService and hence a VersionRepo.

public virtual String Identifier {get;}

Property Value

Unique identifier in the context of an instance of a VersionService and hence a VersionRepo.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsActive Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsActive Property

[read] true if this is an active ChangePackage

public virtual Boolean IsActive {get;}

Property Value

true if this is an active ChangePackage

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsCommitted Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsCommitted Property

[read] true if this is a committed ChangePackage

public virtual Boolean IsCommitted {get;}

Property Value

true if this is a committed ChangePackage

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsFullScope Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsFullScope Property

[read] true if this is a full scoped ChangePackage

public virtual Boolean IsFullScope {get;}

Property Value

true if this is a full scoped ChangePackage

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsMyResponsibility Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsMyResponsibility Property

[read] true if the logged in user is responsible for this ChangePackage

public virtual Boolean IsMyResponsibility {get;}

Property Value

true if the logged in user is responsible for this ChangePackage

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Message Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Message Property

[read] Author-entered commit log message (svn), or delivery comment (dcm).

public virtual String Message {get;}

Property Value

Author-entered commit log message (svn), or delivery comment (dcm).

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Name Property

new public virtual String Name {get;}

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


PostCommitRevisionLabel Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.PostCommitRevisionLabel Property

[read] The post-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.

public virtual Label.WebCacheLabel PostCommitRevisionLabel {get;}

Property Value

The post-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


PostCommitViewLabel Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.PostCommitViewLabel Property

[read] The post-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.

public virtual Label.WebCacheLabel PostCommitViewLabel {get;}

Property Value

The post-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


PreCommitRevisionLabel Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.PreCommitRevisionLabel Property

[read] The pre-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.

public virtual Label.WebCacheLabel PreCommitRevisionLabel {get;}

Property Value

The pre-commit revision label, or null if changes have not been committed or this label was not enabled when the changes were committed.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


PreCommitViewLabel Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.PreCommitViewLabel Property

[read] The pre-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.

public virtual Label.WebCacheLabel PreCommitViewLabel {get;}

Property Value

The pre-commit view label, or null if changes have not been committed or this label was not enabled when the changes were committed.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


RepositoryURI Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.RepositoryURI Property

[read] The Repository URI of this changeset

public virtual String RepositoryURI {get;}

Property Value

The Repository URI of this changeset

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Requests Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Requests Property

[read] Requests/tickets have labels and identifiers, these may be the same in some systems.

public virtual String[] Requests {get;}

Property Value

Requests/tickets have labels and identifiers, these may be the same in some systems.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Responsibility Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Responsibility Property

[read] User

public virtual User.WebCacheUser Responsibility {get;}

Property Value

User

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


SecondaryDisplayName Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.SecondaryDisplayName Property

[read] Some SCM systems have more than one way of referring to a changeset

public virtual String SecondaryDisplayName {get;}

Property Value

Some SCM systems have more than one way of referring to a changeset

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


SessionTypeValue Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.SessionTypeValue Property

[read] ChangePackage.SessionType

public virtual ChangePackage.SessionType SessionTypeValue {get;}

Property Value

ChangePackage.SessionType

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


SourceView Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.SourceView Property

[read] View

public virtual View.WebCacheView SourceView {get;}

Property Value

View

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


StateValue Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.StateValue Property

[read] ChangePackage.State

public virtual ChangePackage.State StateValue {get;}

Property Value

ChangePackage.State

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


TargetView Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.TargetView Property

[read] View

public virtual View.WebCacheView TargetView {get;}

Property Value

View

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage Methods

The methods of the ChangePackage.WebCacheChangePackage class are listed below. For a complete list of ChangePackage.WebCacheChangePackage class members, see the ChangePackage.WebCacheChangePackage Members topic.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.ChangePackage.WebCacheChangePackage.
FindChange | Overloaded. find the change associated with the specified ChangeID
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackage.WebCacheChangePackage.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.ChangePackage.WebCacheChangePackage.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.Equals Method

Delegate Equals() to com.starteam.ChangePackage.WebCacheChangePackage.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackage.WebCacheChangePackage.Equals(obj).

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


FindChange Method

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.FindChange Method

Overload List

public virtual WebCacheChange FindChange(LinkValue.WebCacheLinkValue);

find the change associated with the specified ChangeID

public virtual WebCacheChange FindChange(Int32);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.FindChange Method (LinkValue#WebCacheLinkValue)

public virtual WebCacheChange FindChange(
LinkValue.WebCacheLinkValue lv
);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | ChangePackage.WebCacheChangePackage.FindChange Overload List


ChangePackage.WebCacheChangePackage.FindChange Method (Int32)

find the change associated with the specified ChangeID

public virtual WebCacheChange FindChange(
Int32 changeID
);

Parameters

changeID
the ID of the change

Return Value

the Change, if found, or null

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | ChangePackage.WebCacheChangePackage.FindChange Overload List


ChangePackage.WebCacheChangePackage.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackage.WebCacheChangePackage.

public override int GetHashCode();

Return Value

com.starteam.ChangePackage.WebCacheChangePackage.GetHashCode().

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | ChangePackage.WebCacheChangePackage.GetValue Overload List


ChangePackage.WebCacheChangePackage.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | ChangePackage.WebCacheChangePackage.GetValue Overload List


ChangePackage.WebCacheChangePackage.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | WebCacheViewMemberCollection


ChangePackage.WebCacheChangePackage.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | ChangePackage.WebCacheChangePackage.Lock Overload List | WebCacheViewMemberCollection


ChangePackage.WebCacheChangePackage.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | ChangePackage.WebCacheChangePackage.Lock Overload List


ChangePackage.WebCacheChangePackage.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | NAME


ChangePackage.WebCacheChangePackage.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | NAME


ChangePackage.WebCacheChangePackage.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | isFloating | isPinned | unpin


ChangePackage.WebCacheChangePackage.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | WebCacheViewMemberCollection


ChangePackage.WebCacheChangePackage.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

ChangePackage.WebCacheChangePackage.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | ChangePackage.WebCacheChangePackage.SetValue Overload List


ChangePackage.WebCacheChangePackage.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | ChangePackage.WebCacheChangePackage.SetValue Overload List


ChangePackage.WebCacheChangePackage.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.ToString Method

Delegate ToString() to com.starteam.ChangePackage.WebCacheChangePackage.

public override string ToString();

Return Value

com.starteam.ChangePackage.WebCacheChangePackage.ToString()

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackage.WebCacheChangePackage.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | WebCacheViewMemberCollection


ChangePackage.WebCacheChangePackage.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | isFloating | isPinned | pinTo


ChangePackage.WebCacheChangePackage.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace | WebCacheViewMemberCollection


ChangePackage.WebCacheChangePackage.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

ChangePackage.WebCacheChangePackage Class | StarTeam Namespace


ChangePackageCollection Class

A Collection of Change Packages within a specified view

For a list of all members of this type, see ChangePackageCollection Members.

System.Object
StarTeamCollection
ViewMemberCollection
ChangePackageCollection

public class ChangePackageCollection : ViewMemberCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackageCollection Members | StarTeam Namespace


ChangePackageCollection Members

ChangePackageCollection overview

Public Instance Constructors

ChangePackageCollection Overloaded. Initializes a new instance of the ChangePackageCollection class.

Public Instance Properties

Active | [read] ChangePackageCollection
Cache (inherited from ViewMemberCollection) | [read] CacheService a cache service that can be used to populate, refresh or discard members
ChangeCache | [read] CacheService
Committed | [read] ChangePackageCollection
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
History (inherited from ViewMemberCollection) | [read] a collection of History collections
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MyResponsibility | [read] ChangePackageCollection
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find (inherited from ViewMemberCollection) | Overloaded. find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetAt (inherited from ViewMemberCollection) | Returns the ViewMember at the given index into the virtual array, or null.
GetChangePackagesAfter | returns the set of ChangePackages which were committed after the specified ChangePackage VMID
GetEnumerator (inherited from StarTeamCollection) |
GetFromHistory (inherited from ViewMemberCollection) | Overloaded. Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this Label Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewMember (inherited from ViewMemberCollection) | Overloaded. find an element by its primary descriptor (name), using a case insensitive match. Note that the elements in this collection are expected to have unique primary descriptors. If they do not, then the first one found will be returned.
GetViewMemberBehavior (inherited from ViewMemberCollection) | returns the ViewMemberBehavior for a set of ViewMembers
GetViewMembers (inherited from ViewMemberCollection) | return a set of elements by primary descriptor. For example, files with the same name but in different folders
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
LockExclusive (inherited from ViewMemberCollection) | Overloaded. Obtains an exclusive lock on each member of this collection, without attempting to break an existing lock. A server exception will be thrown if any of the locks cannot be obtained.
LockNonExclusive (inherited from ViewMemberCollection) | Obtains a non-exclusive lock on each member of this collection. Other StarTeam users can also acquire a non-exclusive lock on these resources. A server exception will be thrown if any of the locks cannot be obtained.
ModifyBookmark (inherited from ViewMemberCollection) | Modifies this list of member's book mark for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getBookmark() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyReadStatus (inherited from ViewMemberCollection) | Modifies this list of members's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This command is not supported for File items. All Files in the collection will be ignored
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Reverse (inherited from ViewMemberCollection) | returns a collection whose elements are in the reverse order of this one i.e. the order of elements of a call to toArray() on the returned collection will be in reverse order w.r.t. the order of elements of a call to toArray on this collection
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ShareTo (inherited from ViewMemberCollection) | Share the items from this collection to the target view this should be a different view from the view that the items belong to. All the shares will be committed in a single transaction
Sort (inherited from ViewMemberCollection) | Overloaded. returns an array of ViewMembers whose elements are sorted using the provided comparer. Note that the caller should ensure that the properties used for comparison are pre-populated before calling this api, to avoid the overhead of single round trip queries per view member during the compare itself.
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.
Unlock (inherited from ViewMemberCollection) | Removes the current user's lock from each member of this collection. If another user has an exclusive lock on one of the members, that lock will not be removed.

See Also

ChangePackageCollection Class | StarTeam Namespace


ChangePackageCollection Constructor

Construct an empty ChangePackage collection

Overload List

Construct an empty ChangePackage collection

public ChangePackageCollection();

Construct an ChangePackage collection containing only the given change package.

public ChangePackageCollection(ChangePackage);

Constructs a collection containing all the change packages of the given array

public ChangePackageCollection(ChangePackage[]);

Constructs a collection containing all the change packages of the given array

public ChangePackageCollection(ChangePackageCollection);

See Also

ChangePackageCollection Class | StarTeam Namespace


ChangePackageCollection Constructor ()

Construct an empty ChangePackage collection

public ChangePackageCollection();

See Also

ChangePackageCollection Class | StarTeam Namespace | ChangePackageCollection Constructor Overload List


ChangePackageCollection Constructor (ChangePackage)

Construct an ChangePackage collection containing only the given change package.

public ChangePackageCollection(
ChangePackage changePackage
);

Parameters

changePackage
the change package to add to the collection

See Also

ChangePackageCollection Class | StarTeam Namespace | ChangePackageCollection Constructor Overload List


ChangePackageCollection Constructor (ChangePackageCollection)

Constructs a collection containing all the change packages of the given array

public ChangePackageCollection(
ChangePackageCollection changePackages
);

Parameters

changePackages
the change packages to add to this collection

See Also

ChangePackageCollection Class | StarTeam Namespace | ChangePackageCollection Constructor Overload List


ChangePackageCollection Constructor (ChangePackage[])

Constructs a collection containing all the change packages of the given array

public ChangePackageCollection(
ChangePackage[] changePackages
);

Parameters

changePackages
the change packages to add to this collection

See Also

ChangePackageCollection Class | StarTeam Namespace | ChangePackageCollection Constructor Overload List


ChangePackageCollection Properties

The properties of the ChangePackageCollection class are listed below. For a complete list of ChangePackageCollection class members, see the ChangePackageCollection Members topic.

Public Instance Properties

Active | [read] ChangePackageCollection
Cache (inherited from ViewMemberCollection) | [read] CacheService a cache service that can be used to populate, refresh or discard members
ChangeCache | [read] CacheService
Committed | [read] ChangePackageCollection
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
History (inherited from ViewMemberCollection) | [read] a collection of History collections
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MyResponsibility | [read] ChangePackageCollection
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

See Also

ChangePackageCollection Class | StarTeam Namespace


Active Property

Borland StarTeam SDK for .NET

ChangePackageCollection.Active Property

[read] ChangePackageCollection

public virtual ChangePackageCollection Active {get;}

Property Value

ChangePackageCollection

See Also

ChangePackageCollection Class | StarTeam Namespace


ChangeCache Property

Borland StarTeam SDK for .NET

ChangePackageCollection.ChangeCache Property

[read] CacheService

public virtual CacheService ChangeCache {get;}

Property Value

CacheService

See Also

ChangePackageCollection Class | StarTeam Namespace


Committed Property

Borland StarTeam SDK for .NET

ChangePackageCollection.Committed Property

[read] ChangePackageCollection

public virtual ChangePackageCollection Committed {get;}

Property Value

ChangePackageCollection

See Also

ChangePackageCollection Class | StarTeam Namespace


MyResponsibility Property

Borland StarTeam SDK for .NET

ChangePackageCollection.MyResponsibility Property

[read] ChangePackageCollection

public virtual ChangePackageCollection MyResponsibility {get;}

Property Value

ChangePackageCollection

See Also

ChangePackageCollection Class | StarTeam Namespace


ChangePackageCollection Methods

The methods of the ChangePackageCollection class are listed below. For a complete list of ChangePackageCollection class members, see the ChangePackageCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find (inherited from ViewMemberCollection) | Overloaded. find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetAt (inherited from ViewMemberCollection) | Returns the ViewMember at the given index into the virtual array, or null.
GetChangePackagesAfter | returns the set of ChangePackages which were committed after the specified ChangePackage VMID
GetEnumerator (inherited from StarTeamCollection) |
GetFromHistory (inherited from ViewMemberCollection) | Overloaded. Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this Label Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewMember (inherited from ViewMemberCollection) | Overloaded. find an element by its primary descriptor (name), using a case insensitive match. Note that the elements in this collection are expected to have unique primary descriptors. If they do not, then the first one found will be returned.
GetViewMemberBehavior (inherited from ViewMemberCollection) | returns the ViewMemberBehavior for a set of ViewMembers
GetViewMembers (inherited from ViewMemberCollection) | return a set of elements by primary descriptor. For example, files with the same name but in different folders
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
LockExclusive (inherited from ViewMemberCollection) | Overloaded. Obtains an exclusive lock on each member of this collection, without attempting to break an existing lock. A server exception will be thrown if any of the locks cannot be obtained.
LockNonExclusive (inherited from ViewMemberCollection) | Obtains a non-exclusive lock on each member of this collection. Other StarTeam users can also acquire a non-exclusive lock on these resources. A server exception will be thrown if any of the locks cannot be obtained.
ModifyBookmark (inherited from ViewMemberCollection) | Modifies this list of member's book mark for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getBookmark() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyReadStatus (inherited from ViewMemberCollection) | Modifies this list of members's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This command is not supported for File items. All Files in the collection will be ignored
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Reverse (inherited from ViewMemberCollection) | returns a collection whose elements are in the reverse order of this one i.e. the order of elements of a call to toArray() on the returned collection will be in reverse order w.r.t. the order of elements of a call to toArray on this collection
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ShareTo (inherited from ViewMemberCollection) | Share the items from this collection to the target view this should be a different view from the view that the items belong to. All the shares will be committed in a single transaction
Sort (inherited from ViewMemberCollection) | Overloaded. returns an array of ViewMembers whose elements are sorted using the provided comparer. Note that the caller should ensure that the properties used for comparison are pre-populated before calling this api, to avoid the overhead of single round trip queries per view member during the compare itself.
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.
Unlock (inherited from ViewMemberCollection) | Removes the current user's lock from each member of this collection. If another user has an exclusive lock on one of the members, that lock will not be removed.

See Also

ChangePackageCollection Class | StarTeam Namespace


ChangePackageCollection.GetChangePackagesAfter Method

returns the set of ChangePackages which were committed after the specified ChangePackage VMID

public virtual ChangePackageCollection GetChangePackagesAfter(
Int32 CPVMID
);

Parameters

CPVMID

Return Value

the set of ChangePackages which were committed after the specified VMID

See Also

ChangePackageCollection Class | StarTeam Namespace


ChangePackageReplayGraph Class

Represents the set of replay relationships among a collection of change packages.

The graph contains all change packages that share at least one change with those in a given set.

For a list of all members of this type, see ChangePackageReplayGraph Members.

System.Object
ChangePackageReplayGraph

public class ChangePackageReplayGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackageReplayGraph Members | StarTeam Namespace


ChangePackageReplayGraph Members

ChangePackageReplayGraph overview

Public Instance Constructors

ChangePackageReplayGraph Overloaded. Initializes a new instance of the ChangePackageReplayGraph class.

Public Instance Methods

Contains | Determines whether or not the replay graph contains the given change package.
ContainsAnyChangePackagesFromView | Determines whether or not the replay graph contains any change packages from the given view.
Equals | Delegate Equals() to com.starteam.ChangePackageReplayGraph.
GetChangePackagesFromView | Gets the subset of the change packages in this replay graph that reside in the given view.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackageReplayGraph.
GetReplayPathLength | Gets the length of the replay path from the given source to the given target. If the given target is actually the source, then the length returned is negative. If no replay path exists between the two, then 0 is returned. Also returns zero if either the source or target fall outside the replay graph.
GetReplaySources | Gets the set of change packages from which the given one was derived. Note that some may fall outside this replay graph.
GetReplayTargets | Gets the set of change packages representing replayed instances of the given one. Note that some may fall outside this replay graph.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ChangePackageReplayGraph.

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph Constructor

Builds the replay graph for the change packages in the given view.

Overload List

Builds the replay graph for the given change package.

public ChangePackageReplayGraph(ChangePackage);

Builds the replay graph for the given collection of change packages.

public ChangePackageReplayGraph(ChangePackageCollection);

Builds the replay graph for the change packages in the given view.

public ChangePackageReplayGraph(View);

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph Constructor (View)

Builds the replay graph for the change packages in the given view.

public ChangePackageReplayGraph(
View view
);

Parameters

view
The view containing the change packages.

See Also

ChangePackageReplayGraph Class | StarTeam Namespace | ChangePackageReplayGraph Constructor Overload List


ChangePackageReplayGraph Constructor (ChangePackage)

Builds the replay graph for the given change package.

public ChangePackageReplayGraph(
ChangePackage cp
);

Parameters

cp
The change package.

See Also

ChangePackageReplayGraph Class | StarTeam Namespace | ChangePackageReplayGraph Constructor Overload List


ChangePackageReplayGraph Constructor (ChangePackageCollection)

Builds the replay graph for the given collection of change packages.

public ChangePackageReplayGraph(
ChangePackageCollection cc
);

Parameters

cc
ChangePackageCollection

See Also

ChangePackageReplayGraph Class | StarTeam Namespace | ChangePackageReplayGraph Constructor Overload List


ChangePackageReplayGraph Methods

The methods of the ChangePackageReplayGraph class are listed below. For a complete list of ChangePackageReplayGraph class members, see the ChangePackageReplayGraph Members topic.

Public Instance Methods

Contains | Determines whether or not the replay graph contains the given change package.
ContainsAnyChangePackagesFromView | Determines whether or not the replay graph contains any change packages from the given view.
Equals | Delegate Equals() to com.starteam.ChangePackageReplayGraph.
GetChangePackagesFromView | Gets the subset of the change packages in this replay graph that reside in the given view.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangePackageReplayGraph.
GetReplayPathLength | Gets the length of the replay path from the given source to the given target. If the given target is actually the source, then the length returned is negative. If no replay path exists between the two, then 0 is returned. Also returns zero if either the source or target fall outside the replay graph.
GetReplaySources | Gets the set of change packages from which the given one was derived. Note that some may fall outside this replay graph.
GetReplayTargets | Gets the set of change packages representing replayed instances of the given one. Note that some may fall outside this replay graph.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ChangePackageReplayGraph.

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph.Contains Method

Determines whether or not the replay graph contains the given change package.

public virtual bool Contains(
ChangePackage cp
);

Parameters

cp
ChangePackage

Return Value

boolean true if the replay graph contains the given change package.

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph.ContainsAnyChangePackagesFromView Method

Determines whether or not the replay graph contains any change packages from the given view.

public virtual bool ContainsAnyChangePackagesFromView(
View view
);

Parameters

view
View

Return Value

boolean

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph.Equals Method

Delegate Equals() to com.starteam.ChangePackageReplayGraph.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangePackageReplayGraph.Equals(obj).

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph.GetChangePackagesFromView Method

Gets the subset of the change packages in this replay graph that reside in the given view.

public virtual ChangePackageCollection GetChangePackagesFromView(
View view
);

Parameters

view
View

Return Value

ChangePackageCollection

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangePackageReplayGraph.

public override int GetHashCode();

Return Value

com.starteam.ChangePackageReplayGraph.GetHashCode().

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph.GetReplayPathLength Method

Gets the length of the replay path from the given source to the given target. If the given target is actually the source, then the length returned is negative. If no replay path exists between the two, then 0 is returned. Also returns zero if either the source or target fall outside the replay graph.

public virtual int GetReplayPathLength(
ChangePackage source,
ChangePackage target
);

Parameters

source
The source change package.
target
The target change package.

Return Value

The length of the replay path from the given source to the given target.

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph.GetReplaySources Method

Gets the set of change packages from which the given one was derived. Note that some may fall outside this replay graph.

public virtual ChangePackageCollection GetReplaySources(
ChangePackage cp
);

Parameters

cp
ChangePackage

Return Value

ChangePackageCollection

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph.GetReplayTargets Method

Gets the set of change packages representing replayed instances of the given one. Note that some may fall outside this replay graph.

public virtual ChangePackageCollection GetReplayTargets(
ChangePackage cp
);

Parameters

cp
ChangePackage

Return Value

ChangePackageCollection

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangePackageReplayGraph.ToString Method

Delegate ToString() to com.starteam.ChangePackageReplayGraph.

public override string ToString();

Return Value

com.starteam.ChangePackageReplayGraph.ToString()

See Also

ChangePackageReplayGraph Class | StarTeam Namespace


ChangeRequest Class

Represents a StarTeam ChangeRequest item.

For a list of all members of this type, see ChangeRequest Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
ChangeRequest

public class ChangeRequest : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest Members | StarTeam Namespace


ChangeRequest Members

ChangeRequest overview

Public Static Methods

Create Create a ChangeRequest in the specified parent folder.

Public Instance Properties

AddressedBy | [read/write] the User object that addressed this request.
AddressedIn | [read/write] the label for the build in which this request was addressed
AddressedInView | [read/write] The view from which this Change Request was addressed.
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Category | [read/write] the category of this request.
ClosedOn | [read] the date that this request was given a closed status.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
Component | [read/write] the component this request applies to.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this change request.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EnteredBy | [read/write] the User object that entered this request.
EnteredOn | [read] the date that this request was entered
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalReference | [read/write] the external reference field for this change request
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
Fix | [read/write] the fix for this change request.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
LastBuildTested | [read/write] a label of the build or named configuration that this request was last tested in.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
Number | [read] this change requests CR#
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PlatformValue | [read/write] The platform this Change Request applies to.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The relative priority of this Change Request.
Properties | [read]
RequestTypeValue | [read/write] This change request's type. The type denotes whether this request is a defect report or a feature enhancement.
ResolvedOn | [read] The date that this Change Request was resolved.
Responsibility | [read/write] the User object that is currently responsible for this request.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
SeverityValue | [read/write] The relative severity of the condition that this Change Request represents.
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StarFlowStatusValue | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
StatusValue | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
StreamStateValue | [read/write] Stream State used for this change request
Synopsis | [read/write] the synopsis or brief description of this request.
TestCommand | [read/write] the test command string for this change request.
VerifiedOn | [read] The date that this Change Request was verified.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WorkAround | [read/write] the workaround for this change request.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

ChangeRequest Class | StarTeam Namespace


ChangeRequest Properties

The properties of the ChangeRequest class are listed below. For a complete list of ChangeRequest class members, see the ChangeRequest Members topic.

Public Instance Properties

AddressedBy | [read/write] the User object that addressed this request.
AddressedIn | [read/write] the label for the build in which this request was addressed
AddressedInView | [read/write] The view from which this Change Request was addressed.
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Category | [read/write] the category of this request.
ClosedOn | [read] the date that this request was given a closed status.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
Component | [read/write] the component this request applies to.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this change request.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EnteredBy | [read/write] the User object that entered this request.
EnteredOn | [read] the date that this request was entered
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalReference | [read/write] the external reference field for this change request
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
Fix | [read/write] the fix for this change request.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
LastBuildTested | [read/write] a label of the build or named configuration that this request was last tested in.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
Number | [read] this change requests CR#
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PlatformValue | [read/write] The platform this Change Request applies to.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The relative priority of this Change Request.
Properties | [read]
RequestTypeValue | [read/write] This change request's type. The type denotes whether this request is a defect report or a feature enhancement.
ResolvedOn | [read] The date that this Change Request was resolved.
Responsibility | [read/write] the User object that is currently responsible for this request.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
SeverityValue | [read/write] The relative severity of the condition that this Change Request represents.
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StarFlowStatusValue | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
StatusValue | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
StreamStateValue | [read/write] Stream State used for this change request
Synopsis | [read/write] the synopsis or brief description of this request.
TestCommand | [read/write] the test command string for this change request.
VerifiedOn | [read] The date that this Change Request was verified.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WorkAround | [read/write] the workaround for this change request.

See Also

ChangeRequest Class | StarTeam Namespace


AddressedBy Property

Borland StarTeam SDK for .NET

ChangeRequest.AddressedBy Property

[read/write] the User object that addressed this request.

public virtual User AddressedBy {get; set;}

Property Value

the User object that addressed this request.

See Also

ChangeRequest Class | StarTeam Namespace


AddressedIn Property

Borland StarTeam SDK for .NET

ChangeRequest.AddressedIn Property

[read/write] the label for the build in which this request was addressed

public virtual Label AddressedIn {get; set;}

Property Value

the label for the build in which this request was addressed

See Also

ChangeRequest Class | StarTeam Namespace


AddressedInView Property

Borland StarTeam SDK for .NET

ChangeRequest.AddressedInView Property

[read/write] The view from which this Change Request was addressed.

public virtual View AddressedInView {get; set;}

Property Value

The view from which this Change Request was addressed.

See Also

ChangeRequest Class | StarTeam Namespace


Category Property

Borland StarTeam SDK for .NET

ChangeRequest.Category Property

[read/write] the category of this request.

public virtual String Category {get; set;}

Property Value

the category of this request.

See Also

ChangeRequest Class | StarTeam Namespace


ClosedOn Property

Borland StarTeam SDK for .NET

ChangeRequest.ClosedOn Property

[read] the date that this request was given a closed status.

public virtual DateTime ClosedOn {get;}

Property Value

the date that this request was given a closed status.

See Also

ChangeRequest Class | StarTeam Namespace


Component Property

Borland StarTeam SDK for .NET

ChangeRequest.Component Property

[read/write] the component this request applies to.

public virtual String Component {get; set;}

Property Value

the component this request applies to.

See Also

ChangeRequest Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ChangeRequest.Description Property

[read/write] the description of this change request.

public virtual String Description {get; set;}

Property Value

the description of this change request.

See Also

ChangeRequest Class | StarTeam Namespace


EnteredBy Property

Borland StarTeam SDK for .NET

ChangeRequest.EnteredBy Property

[read/write] the User object that entered this request.

public virtual User EnteredBy {get; set;}

Property Value

the User object that entered this request.

See Also

ChangeRequest Class | StarTeam Namespace


EnteredOn Property

Borland StarTeam SDK for .NET

ChangeRequest.EnteredOn Property

[read] the date that this request was entered

public virtual DateTime EnteredOn {get;}

Property Value

the date that this request was entered

See Also

ChangeRequest Class | StarTeam Namespace


ExternalReference Property

Borland StarTeam SDK for .NET

ChangeRequest.ExternalReference Property

[read/write] the external reference field for this change request

public virtual String ExternalReference {get; set;}

Property Value

the external reference field for this change request

See Also

ChangeRequest Class | StarTeam Namespace


Fix Property

Borland StarTeam SDK for .NET

ChangeRequest.Fix Property

[read/write] the fix for this change request.

public virtual String Fix {get; set;}

Property Value

the fix for this change request.

See Also

ChangeRequest Class | StarTeam Namespace


LastBuildTested Property

Borland StarTeam SDK for .NET

ChangeRequest.LastBuildTested Property

[read/write] a label of the build or named configuration that this request was last tested in.

public virtual Label LastBuildTested {get; set;}

Property Value

a label of the build or named configuration that this request was last tested in.

See Also

ChangeRequest Class | StarTeam Namespace


Number Property

Borland StarTeam SDK for .NET

ChangeRequest.Number Property

[read] this change requests CR#

public virtual Int32 Number {get;}

Property Value

this change requests CR#

See Also

ChangeRequest Class | StarTeam Namespace


PlatformValue Property

Borland StarTeam SDK for .NET

ChangeRequest.PlatformValue Property

[read/write] The platform this Change Request applies to.

public virtual ChangeRequest.Platform PlatformValue {get; set;}

Property Value

The platform this Change Request applies to.

See Also

ChangeRequest Class | StarTeam Namespace


PriorityValue Property

Borland StarTeam SDK for .NET

ChangeRequest.PriorityValue Property

[read/write] The relative priority of this Change Request.

public virtual ChangeRequest.Priority PriorityValue {get; set;}

Property Value

The relative priority of this Change Request.

See Also

ChangeRequest Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

ChangeRequest.Properties Property

[read]

public virtual ChangeRequest.Type.PropertyCollection Properties {get;}

See Also

ChangeRequest Class | StarTeam Namespace


RequestTypeValue Property

Borland StarTeam SDK for .NET

ChangeRequest.RequestTypeValue Property

[read/write] This change request's type. The type denotes whether this request is a defect report or a feature enhancement.

public virtual ChangeRequest.ChangeRequestType RequestTypeValue {get; set;}

Property Value

This change request's type. The type denotes whether this request is a defect report or a feature enhancement.

See Also

ChangeRequest Class | StarTeam Namespace


ResolvedOn Property

Borland StarTeam SDK for .NET

ChangeRequest.ResolvedOn Property

[read] The date that this Change Request was resolved.

public virtual DateTime ResolvedOn {get;}

Property Value

The date that this Change Request was resolved.

See Also

ChangeRequest Class | StarTeam Namespace


Responsibility Property

Borland StarTeam SDK for .NET

ChangeRequest.Responsibility Property

[read/write] the User object that is currently responsible for this request.

public virtual User Responsibility {get; set;}

Property Value

the User object that is currently responsible for this request.

See Also

ChangeRequest Class | StarTeam Namespace


SeverityValue Property

Borland StarTeam SDK for .NET

ChangeRequest.SeverityValue Property

[read/write] The relative severity of the condition that this Change Request represents.

public virtual ChangeRequest.Severity SeverityValue {get; set;}

Property Value

The relative severity of the condition that this Change Request represents.

See Also

ChangeRequest Class | StarTeam Namespace


StarFlowStatusValue Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatusValue Property

[read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.

public virtual ChangeRequest.StarFlowStatus StarFlowStatusValue {get; set;}

Property Value

The status (Open, Fixed, Closed, etc.) of this Change Request.

See Also

ChangeRequest Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

ChangeRequest.StatusValue Property

[read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.

public virtual ChangeRequest.Status StatusValue {get; set;}

Property Value

The status (Open, Fixed, Closed, etc.) of this Change Request.

See Also

ChangeRequest Class | StarTeam Namespace


StreamStateValue Property

Borland StarTeam SDK for .NET

ChangeRequest.StreamStateValue Property

[read/write] Stream State used for this change request

public virtual ChangeRequest.StreamState StreamStateValue {get; set;}

Property Value

Stream State used for this change request

See Also

ChangeRequest Class | StarTeam Namespace


Synopsis Property

Borland StarTeam SDK for .NET

ChangeRequest.Synopsis Property

[read/write] the synopsis or brief description of this request.

public virtual String Synopsis {get; set;}

Property Value

the synopsis or brief description of this request.

See Also

ChangeRequest Class | StarTeam Namespace


TestCommand Property

Borland StarTeam SDK for .NET

ChangeRequest.TestCommand Property

[read/write] the test command string for this change request.

public virtual String TestCommand {get; set;}

Property Value

the test command string for this change request.

See Also

ChangeRequest Class | StarTeam Namespace


VerifiedOn Property

Borland StarTeam SDK for .NET

ChangeRequest.VerifiedOn Property

[read] The date that this Change Request was verified.

public virtual DateTime VerifiedOn {get;}

Property Value

The date that this Change Request was verified.

See Also

ChangeRequest Class | StarTeam Namespace


WorkAround Property

Borland StarTeam SDK for .NET

ChangeRequest.WorkAround Property

[read/write] the workaround for this change request.

public virtual String WorkAround {get; set;}

Property Value

the workaround for this change request.

See Also

ChangeRequest Class | StarTeam Namespace


ChangeRequest Methods

The methods of the ChangeRequest class are listed below. For a complete list of ChangeRequest class members, see the ChangeRequest Members topic.

Public Static Methods

Create Create a ChangeRequest in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

ChangeRequest Class | StarTeam Namespace


ChangeRequest.Create Method

Create a ChangeRequest in the specified parent folder.

public static ChangeRequest Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new ChangeRequest Object.

See Also

ChangeRequest Class | StarTeam Namespace


ChangeRequest.ChangeRequestType Class

The type of change requested.

For a list of all members of this type, see ChangeRequest.ChangeRequestType Members.

System.Object
EnumeratedValue
ChangeRequest.ChangeRequestType

public class ChangeRequest.ChangeRequestType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.ChangeRequestType Members | StarTeam Namespace


ChangeRequest.ChangeRequestType Members

ChangeRequest.ChangeRequestType overview

Public Static Properties

ALL
DEFECT
SUGGESTION

Public Static Methods

FromID | Gets the RequestType value corresponding to the given ID.
FromValue | Gets the RequestType value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.ChangeRequestType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.ChangeRequestType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.ChangeRequestType.

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ChangeRequest.ChangeRequestType Properties

The properties of the ChangeRequest.ChangeRequestType class are listed below. For a complete list of ChangeRequest.ChangeRequestType class members, see the ChangeRequest.ChangeRequestType Members topic.

Public Static Properties

ALL
DEFECT
SUGGESTION

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ChangeRequest.ChangeRequestType.ALL Property

public static ChangeRequestType[] ALL {get;}

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


DEFECT Property

Borland StarTeam SDK for .NET

ChangeRequest.ChangeRequestType.DEFECT Property

public static ChangeRequest.ChangeRequestType DEFECT {get;}

Property Value

The ChangeRequest describes a defect.

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangeRequest.ChangeRequestType.ID Property

[read] The ID of this Type value.

public virtual Int32 ID {get;}

Property Value

The ID of this Type value.

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


SUGGESTION Property

Borland StarTeam SDK for .NET

ChangeRequest.ChangeRequestType.SUGGESTION Property

public static ChangeRequest.ChangeRequestType SUGGESTION {get;}

Property Value

The ChangeRequest describes a suggestion.

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ChangeRequest.ChangeRequestType Methods

The methods of the ChangeRequest.ChangeRequestType class are listed below. For a complete list of ChangeRequest.ChangeRequestType class members, see the ChangeRequest.ChangeRequestType Members topic.

Public Static Methods

FromID | Gets the RequestType value corresponding to the given ID.
FromValue | Gets the RequestType value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.ChangeRequestType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.ChangeRequestType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.ChangeRequestType.

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ChangeRequest.ChangeRequestType.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.ChangeRequestType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.ChangeRequestType.Equals(obj).

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ChangeRequest.ChangeRequestType.FromID Method

Gets the RequestType value corresponding to the given ID.

public static ChangeRequestType FromID(
Int32 id
);

Parameters

id
A RequestType ID.

Return Value

The corresponding RequestType value, or null.

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ChangeRequest.ChangeRequestType.FromValue Method

Gets the RequestType value corresponding to the given EnumeratedValue.

public static ChangeRequestType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a RequestTypeProperty.

Return Value

The corresponding RequestType value, or null.

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ChangeRequest.ChangeRequestType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.ChangeRequestType.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.ChangeRequestType.GetHashCode().

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ChangeRequest.ChangeRequestType.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.ChangeRequestType.

public override string ToString();

Return Value

com.starteam.ChangeRequest.ChangeRequestType.ToString()

See Also

ChangeRequest.ChangeRequestType Class | StarTeam Namespace


ChangeRequest.Platform Class

The platform on which the need for this request was discovered.

For a list of all members of this type, see ChangeRequest.Platform Members.

System.Object
EnumeratedValue
ChangeRequest.Platform

public class ChangeRequest.Platform : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Platform Members | StarTeam Namespace


ChangeRequest.Platform Members

ChangeRequest.Platform overview

Public Static Properties

ALL
ALL_PLATFORMS
MAC_OS
OTHER
UNIX
WINDOWS_2000
WINDOWS_2003
WINDOWS_2008
WINDOWS_95
WINDOWS_98
WINDOWS_NT
WINDOWS_VISTA
WINDOWS_XP

Public Static Methods

FromID | Gets the Platform value corresponding to the given ID.
FromValue | Gets the Platform value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Platform value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.Platform.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Platform.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.Platform.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ChangeRequest.Platform Properties

The properties of the ChangeRequest.Platform class are listed below. For a complete list of ChangeRequest.Platform class members, see the ChangeRequest.Platform Members topic.

Public Static Properties

ALL
ALL_PLATFORMS
MAC_OS
OTHER
UNIX
WINDOWS_2000
WINDOWS_2003
WINDOWS_2008
WINDOWS_95
WINDOWS_98
WINDOWS_NT
WINDOWS_VISTA
WINDOWS_XP

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Platform value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.ALL Property

public static Platform[] ALL {get;}

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ALL_PLATFORMS Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.ALL_PLATFORMS Property

public static ChangeRequest.Platform ALL_PLATFORMS {get;}

Property Value

All platforms.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.ID Property

[read] The ID of this Platform value.

public virtual Int32 ID {get;}

Property Value

The ID of this Platform value.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


MAC_OS Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.MAC_OS Property

public static ChangeRequest.Platform MAC_OS {get;}

Property Value

MacOS.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


OTHER Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.OTHER Property

public static ChangeRequest.Platform OTHER {get;}

Property Value

Other.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


UNIX Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.UNIX Property

public static ChangeRequest.Platform UNIX {get;}

Property Value

Unix.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


WINDOWS_2000 Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.WINDOWS_2000 Property

public static ChangeRequest.Platform WINDOWS_2000 {get;}

Property Value

Windows 2000.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


WINDOWS_2003 Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.WINDOWS_2003 Property

public static ChangeRequest.Platform WINDOWS_2003 {get;}

Property Value

Windows 2003.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


WINDOWS_2008 Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.WINDOWS_2008 Property

public static ChangeRequest.Platform WINDOWS_2008 {get;}

Property Value

Windows 2008.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


WINDOWS_95 Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.WINDOWS_95 Property

public static ChangeRequest.Platform WINDOWS_95 {get;}

Property Value

Windows 95.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


WINDOWS_98 Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.WINDOWS_98 Property

public static ChangeRequest.Platform WINDOWS_98 {get;}

Property Value

Windows 98.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


WINDOWS_NT Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.WINDOWS_NT Property

public static ChangeRequest.Platform WINDOWS_NT {get;}

Property Value

Windows NT.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


WINDOWS_VISTA Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.WINDOWS_VISTA Property

public static ChangeRequest.Platform WINDOWS_VISTA {get;}

Property Value

Windows Vista.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


WINDOWS_XP Property

Borland StarTeam SDK for .NET

ChangeRequest.Platform.WINDOWS_XP Property

public static ChangeRequest.Platform WINDOWS_XP {get;}

Property Value

Windows XP.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ChangeRequest.Platform Methods

The methods of the ChangeRequest.Platform class are listed below. For a complete list of ChangeRequest.Platform class members, see the ChangeRequest.Platform Members topic.

Public Static Methods

FromID | Gets the Platform value corresponding to the given ID.
FromValue | Gets the Platform value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.Platform.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Platform.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.Platform.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ChangeRequest.Platform.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Platform.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Platform.Equals(obj).

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ChangeRequest.Platform.FromID Method

Gets the Platform value corresponding to the given ID.

public static Platform FromID(
Int32 id
);

Parameters

id
A Platform ID.

Return Value

The corresponding Platform value, or null.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ChangeRequest.Platform.FromValue Method

Gets the Platform value corresponding to the given EnumeratedValue.

public static Platform FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a PlatformProperty.

Return Value

The corresponding Platform value, or null.

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ChangeRequest.Platform.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Platform.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Platform.GetHashCode().

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ChangeRequest.Platform.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Platform.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Platform.ToString()

See Also

ChangeRequest.Platform Class | StarTeam Namespace


ChangeRequest.Priority Class

Priority of the ChangeRequest

For a list of all members of this type, see ChangeRequest.Priority Members.

System.Object
EnumeratedValue
ChangeRequest.Priority

public class ChangeRequest.Priority : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Priority Members | StarTeam Namespace


ChangeRequest.Priority Members

ChangeRequest.Priority overview

Public Static Properties

ALL
NOT_PRIORITIZED
PRIORITY_FIVE
PRIORITY_FOUR
PRIORITY_ONE
PRIORITY_SIX
PRIORITY_THREE
PRIORITY_TWO

Public Static Methods

FromID | Gets the Priority value corresponding to the given ID.
FromValue | Gets the Priority value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Priority value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.Priority.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Priority.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.Priority.

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ChangeRequest.Priority Properties

The properties of the ChangeRequest.Priority class are listed below. For a complete list of ChangeRequest.Priority class members, see the ChangeRequest.Priority Members topic.

Public Static Properties

ALL
NOT_PRIORITIZED
PRIORITY_FIVE
PRIORITY_FOUR
PRIORITY_ONE
PRIORITY_SIX
PRIORITY_THREE
PRIORITY_TWO

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Priority value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority.ALL Property

public static Priority[] ALL {get;}

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority.ID Property

[read] The ID of this Priority value.

public virtual Int32 ID {get;}

Property Value

The ID of this Priority value.

See Also

ChangeRequest.Priority Class | StarTeam Namespace


NOT_PRIORITIZED Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority.NOT_PRIORITIZED Property

public static ChangeRequest.Priority NOT_PRIORITIZED {get;}

See Also

ChangeRequest.Priority Class | StarTeam Namespace


PRIORITY_FIVE Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority.PRIORITY_FIVE Property

public static ChangeRequest.Priority PRIORITY_FIVE {get;}

See Also

ChangeRequest.Priority Class | StarTeam Namespace


PRIORITY_FOUR Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority.PRIORITY_FOUR Property

public static ChangeRequest.Priority PRIORITY_FOUR {get;}

See Also

ChangeRequest.Priority Class | StarTeam Namespace


PRIORITY_ONE Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority.PRIORITY_ONE Property

public static ChangeRequest.Priority PRIORITY_ONE {get;}

See Also

ChangeRequest.Priority Class | StarTeam Namespace


PRIORITY_SIX Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority.PRIORITY_SIX Property

public static ChangeRequest.Priority PRIORITY_SIX {get;}

See Also

ChangeRequest.Priority Class | StarTeam Namespace


PRIORITY_THREE Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority.PRIORITY_THREE Property

public static ChangeRequest.Priority PRIORITY_THREE {get;}

See Also

ChangeRequest.Priority Class | StarTeam Namespace


PRIORITY_TWO Property

Borland StarTeam SDK for .NET

ChangeRequest.Priority.PRIORITY_TWO Property

public static ChangeRequest.Priority PRIORITY_TWO {get;}

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ChangeRequest.Priority Methods

The methods of the ChangeRequest.Priority class are listed below. For a complete list of ChangeRequest.Priority class members, see the ChangeRequest.Priority Members topic.

Public Static Methods

FromID | Gets the Priority value corresponding to the given ID.
FromValue | Gets the Priority value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.Priority.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Priority.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.Priority.

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ChangeRequest.Priority.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Priority.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Priority.Equals(obj).

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ChangeRequest.Priority.FromID Method

Gets the Priority value corresponding to the given ID.

public static Priority FromID(
Int32 id
);

Parameters

id
A Priority ID.

Return Value

The corresponding Priority value, or null.

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ChangeRequest.Priority.FromValue Method

Gets the Priority value corresponding to the given EnumeratedValue.

public static Priority FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a PriorityProperty.

Return Value

The corresponding Priority value, or null.

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ChangeRequest.Priority.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Priority.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Priority.GetHashCode().

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ChangeRequest.Priority.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Priority.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Priority.ToString()

See Also

ChangeRequest.Priority Class | StarTeam Namespace


ChangeRequest.Severity Class

The severity of the problem that prompted the request.

For a list of all members of this type, see ChangeRequest.Severity Members.

System.Object
EnumeratedValue
ChangeRequest.Severity

public class ChangeRequest.Severity : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Severity Members | StarTeam Namespace


ChangeRequest.Severity Members

ChangeRequest.Severity overview

Public Static Properties

ALL
HIGH
LOW
MEDIUM

Public Static Methods

FromID | Gets the Severity value corresponding to the given ID.
FromValue | Gets the Severity value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Severity value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.Severity.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Severity.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.Severity.

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ChangeRequest.Severity Properties

The properties of the ChangeRequest.Severity class are listed below. For a complete list of ChangeRequest.Severity class members, see the ChangeRequest.Severity Members topic.

Public Static Properties

ALL
HIGH
LOW
MEDIUM

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Severity value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ChangeRequest.Severity.ALL Property

public static Severity[] ALL {get;}

See Also

ChangeRequest.Severity Class | StarTeam Namespace


HIGH Property

Borland StarTeam SDK for .NET

ChangeRequest.Severity.HIGH Property

public static ChangeRequest.Severity HIGH {get;}

Property Value

High severity.

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Severity.ID Property

[read] The ID of this Severity value.

public virtual Int32 ID {get;}

Property Value

The ID of this Severity value.

See Also

ChangeRequest.Severity Class | StarTeam Namespace


LOW Property

Borland StarTeam SDK for .NET

ChangeRequest.Severity.LOW Property

public static ChangeRequest.Severity LOW {get;}

Property Value

Low severity.

See Also

ChangeRequest.Severity Class | StarTeam Namespace


MEDIUM Property

Borland StarTeam SDK for .NET

ChangeRequest.Severity.MEDIUM Property

public static ChangeRequest.Severity MEDIUM {get;}

Property Value

Medium severity.

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ChangeRequest.Severity Methods

The methods of the ChangeRequest.Severity class are listed below. For a complete list of ChangeRequest.Severity class members, see the ChangeRequest.Severity Members topic.

Public Static Methods

FromID | Gets the Severity value corresponding to the given ID.
FromValue | Gets the Severity value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.Severity.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Severity.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.Severity.

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ChangeRequest.Severity.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Severity.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Severity.Equals(obj).

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ChangeRequest.Severity.FromID Method

Gets the Severity value corresponding to the given ID.

public static Severity FromID(
Int32 id
);

Parameters

id
A Severity ID.

Return Value

The corresponding Severity value, or null.

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ChangeRequest.Severity.FromValue Method

Gets the Severity value corresponding to the given EnumeratedValue.

public static Severity FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a SeverityProperty.

Return Value

The corresponding Severity value, or null.

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ChangeRequest.Severity.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Severity.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Severity.GetHashCode().

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ChangeRequest.Severity.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Severity.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Severity.ToString()

See Also

ChangeRequest.Severity Class | StarTeam Namespace


ChangeRequest.StarFlowStatus Class

The current status of the change request.

For a list of all members of this type, see ChangeRequest.StarFlowStatus Members.

System.Object
EnumeratedValue
ChangeRequest.StarFlowStatus

public class ChangeRequest.StarFlowStatus : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.StarFlowStatus Members | StarTeam Namespace


ChangeRequest.StarFlowStatus Members

ChangeRequest.StarFlowStatus overview

Public Static Properties

ALL
AS_DESIGNED
CANNOT_REPRODUCE
CLOSED_AS_DESIGNED
CLOSED_CANNOT_REPRODUCE
CLOSED_DEFERRED
CLOSED_DOCUMENTED
CLOSED_FIXED
CLOSED_IS_DUPLICATE
DEFERRED
DOCUMENTED
ENTERED
FIXED
IN_PROGRESS
IS_DUPLICATE
NEW
OPEN
VERIFIED_AS_DESIGNED
VERIFIED_CANNOT_REPRODUCE
VERIFIED_DEFERRED
VERIFIED_DOCUMENTED
VERIFIED_FIXED
VERIFIED_IS_DUPLICATE

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.StarFlowStatus.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.StarFlowStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.StarFlowStatus.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ChangeRequest.StarFlowStatus Properties

The properties of the ChangeRequest.StarFlowStatus class are listed below. For a complete list of ChangeRequest.StarFlowStatus class members, see the ChangeRequest.StarFlowStatus Members topic.

Public Static Properties

ALL
AS_DESIGNED
CANNOT_REPRODUCE
CLOSED_AS_DESIGNED
CLOSED_CANNOT_REPRODUCE
CLOSED_DEFERRED
CLOSED_DOCUMENTED
CLOSED_FIXED
CLOSED_IS_DUPLICATE
DEFERRED
DOCUMENTED
ENTERED
FIXED
IN_PROGRESS
IS_DUPLICATE
NEW
OPEN
VERIFIED_AS_DESIGNED
VERIFIED_CANNOT_REPRODUCE
VERIFIED_DEFERRED
VERIFIED_DOCUMENTED
VERIFIED_FIXED
VERIFIED_IS_DUPLICATE

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.ALL Property

public static StarFlowStatus[] ALL {get;}

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


AS_DESIGNED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.AS_DESIGNED Property

public static ChangeRequest.StarFlowStatus AS_DESIGNED {get;}

Property Value

A ChangeRequest whose behavior is as designed.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


CANNOT_REPRODUCE Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.CANNOT_REPRODUCE Property

public static ChangeRequest.StarFlowStatus CANNOT_REPRODUCE {get;}

Property Value

A ChangeRequest the tester has been unable to reproduce.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


CLOSED_AS_DESIGNED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.CLOSED_AS_DESIGNED Property

public static ChangeRequest.StarFlowStatus CLOSED_AS_DESIGNED {get;}

Property Value

A ChangeRequest closed because its behavior is "as designed".

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


CLOSED_CANNOT_REPRODUCE Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.CLOSED_CANNOT_REPRODUCE Property

public static ChangeRequest.StarFlowStatus CLOSED_CANNOT_REPRODUCE {get;}

Property Value

A ChangeRequest closed because it cannot be reproduced.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


CLOSED_DEFERRED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.CLOSED_DEFERRED Property

public static ChangeRequest.StarFlowStatus CLOSED_DEFERRED {get;}

Property Value

A ChangeRequest closed because it has been deferred.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


CLOSED_DOCUMENTED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.CLOSED_DOCUMENTED Property

public static ChangeRequest.StarFlowStatus CLOSED_DOCUMENTED {get;}

Property Value

A ChangeRequest closed as having been documented.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


CLOSED_FIXED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.CLOSED_FIXED Property

public static ChangeRequest.StarFlowStatus CLOSED_FIXED {get;}

Property Value

A ChangeRequest closed because it has been fixed.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


CLOSED_IS_DUPLICATE Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.CLOSED_IS_DUPLICATE Property

public static ChangeRequest.StarFlowStatus CLOSED_IS_DUPLICATE {get;}

Property Value

A ChangeRequest closed because it is a duplicate of another.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


DEFERRED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.DEFERRED Property

public static ChangeRequest.StarFlowStatus DEFERRED {get;}

Property Value

A deferred ChangeRequest.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


DOCUMENTED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.DOCUMENTED Property

public static ChangeRequest.StarFlowStatus DOCUMENTED {get;}

Property Value

A ChangeRequest that has been documented.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ENTERED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.ENTERED Property

public static ChangeRequest.StarFlowStatus ENTERED {get;}

Property Value

An entered (unsaved) ChangeRequest.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


FIXED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.FIXED Property

public static ChangeRequest.StarFlowStatus FIXED {get;}

Property Value

A ChangeRequest believed by the developer to be fixed, but not yet verified.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


IN_PROGRESS Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.IN_PROGRESS Property

public static ChangeRequest.StarFlowStatus IN_PROGRESS {get;}

Property Value

An in-progress ChangeRequest.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


IS_DUPLICATE Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.IS_DUPLICATE Property

public static ChangeRequest.StarFlowStatus IS_DUPLICATE {get;}

Property Value

A ChangeRequest identified as being a duplicate of another ChangeRequest.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


NEW Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.NEW Property

public static ChangeRequest.StarFlowStatus NEW {get;}

Property Value

A new (unsaved) ChangeRequest.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


OPEN Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.OPEN Property

public static ChangeRequest.StarFlowStatus OPEN {get;}

Property Value

An open ChangeRequest.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


VERIFIED_AS_DESIGNED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.VERIFIED_AS_DESIGNED Property

public static ChangeRequest.StarFlowStatus VERIFIED_AS_DESIGNED {get;}

Property Value

A ChangeRequest whose behavior has been verified as being "as designed".

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


VERIFIED_CANNOT_REPRODUCE Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.VERIFIED_CANNOT_REPRODUCE Property

public static ChangeRequest.StarFlowStatus VERIFIED_CANNOT_REPRODUCE {get;}

Property Value

A ChangeRequest that has been verified as not reproducible.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


VERIFIED_DEFERRED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.VERIFIED_DEFERRED Property

public static ChangeRequest.StarFlowStatus VERIFIED_DEFERRED {get;}

Property Value

A ChangeRequest verified to be deferred.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


VERIFIED_DOCUMENTED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.VERIFIED_DOCUMENTED Property

public static ChangeRequest.StarFlowStatus VERIFIED_DOCUMENTED {get;}

Property Value

A ChangeRequest verified to have been documented.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


VERIFIED_FIXED Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.VERIFIED_FIXED Property

public static ChangeRequest.StarFlowStatus VERIFIED_FIXED {get;}

Property Value

A ChangeRequest that has been verified as fixed.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


VERIFIED_IS_DUPLICATE Property

Borland StarTeam SDK for .NET

ChangeRequest.StarFlowStatus.VERIFIED_IS_DUPLICATE Property

public static ChangeRequest.StarFlowStatus VERIFIED_IS_DUPLICATE {get;}

Property Value

A ChangeRequest verified to be a duplicate of another.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ChangeRequest.StarFlowStatus Methods

The methods of the ChangeRequest.StarFlowStatus class are listed below. For a complete list of ChangeRequest.StarFlowStatus class members, see the ChangeRequest.StarFlowStatus Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.StarFlowStatus.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.StarFlowStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.StarFlowStatus.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ChangeRequest.StarFlowStatus.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.StarFlowStatus.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.StarFlowStatus.Equals(obj).

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ChangeRequest.StarFlowStatus.FromID Method

Gets the Status value corresponding to the given ID.

public static StarFlowStatus FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ChangeRequest.StarFlowStatus.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static StarFlowStatus FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ChangeRequest.StarFlowStatus.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.StarFlowStatus.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.StarFlowStatus.GetHashCode().

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ChangeRequest.StarFlowStatus.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.StarFlowStatus.

public override string ToString();

Return Value

com.starteam.ChangeRequest.StarFlowStatus.ToString()

See Also

ChangeRequest.StarFlowStatus Class | StarTeam Namespace


ChangeRequest.Status Class

The current status of the change request.

For a list of all members of this type, see ChangeRequest.Status Members.

System.Object
EnumeratedValue
ChangeRequest.Status

public class ChangeRequest.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Status Members | StarTeam Namespace


ChangeRequest.Status Members

ChangeRequest.Status overview

Public Static Properties

ALL
AS_DESIGNED
CANNOT_REPRODUCE
CLOSED_AS_DESIGNED
CLOSED_CANNOT_REPRODUCE
CLOSED_DEFERRED
CLOSED_DOCUMENTED
CLOSED_FIXED
CLOSED_IS_DUPLICATE
DEFERRED
DOCUMENTED
FIXED
IN_PROGRESS
IS_DUPLICATE
NEW
OPEN
REVIEWED
VERIFIED_AS_DESIGNED
VERIFIED_CANNOT_REPRODUCE
VERIFIED_DEFERRED
VERIFIED_DOCUMENTED
VERIFIED_FIXED
VERIFIED_IS_DUPLICATE
VERIFIED_REVIEWED

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.Status.

See Also

ChangeRequest.Status Class | StarTeam Namespace


ChangeRequest.Status Properties

The properties of the ChangeRequest.Status class are listed below. For a complete list of ChangeRequest.Status class members, see the ChangeRequest.Status Members topic.

Public Static Properties

ALL
AS_DESIGNED
CANNOT_REPRODUCE
CLOSED_AS_DESIGNED
CLOSED_CANNOT_REPRODUCE
CLOSED_DEFERRED
CLOSED_DOCUMENTED
CLOSED_FIXED
CLOSED_IS_DUPLICATE
DEFERRED
DOCUMENTED
FIXED
IN_PROGRESS
IS_DUPLICATE
NEW
OPEN
REVIEWED
VERIFIED_AS_DESIGNED
VERIFIED_CANNOT_REPRODUCE
VERIFIED_DEFERRED
VERIFIED_DOCUMENTED
VERIFIED_FIXED
VERIFIED_IS_DUPLICATE
VERIFIED_REVIEWED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ChangeRequest.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.ALL Property

public static Status[] ALL {get;}

See Also

ChangeRequest.Status Class | StarTeam Namespace


AS_DESIGNED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.AS_DESIGNED Property

public static ChangeRequest.Status AS_DESIGNED {get;}

Property Value

A ChangeRequest whose behavior is as designed.

See Also

ChangeRequest.Status Class | StarTeam Namespace


CANNOT_REPRODUCE Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.CANNOT_REPRODUCE Property

public static ChangeRequest.Status CANNOT_REPRODUCE {get;}

Property Value

A ChangeRequest the tester has been unable to reproduce.

See Also

ChangeRequest.Status Class | StarTeam Namespace


CLOSED_AS_DESIGNED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.CLOSED_AS_DESIGNED Property

public static ChangeRequest.Status CLOSED_AS_DESIGNED {get;}

Property Value

A ChangeRequest closed because its behavior is "as designed".

See Also

ChangeRequest.Status Class | StarTeam Namespace


CLOSED_CANNOT_REPRODUCE Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.CLOSED_CANNOT_REPRODUCE Property

public static ChangeRequest.Status CLOSED_CANNOT_REPRODUCE {get;}

Property Value

A ChangeRequest closed because it cannot be reproduced.

See Also

ChangeRequest.Status Class | StarTeam Namespace


CLOSED_DEFERRED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.CLOSED_DEFERRED Property

public static ChangeRequest.Status CLOSED_DEFERRED {get;}

Property Value

A ChangeRequest closed because it has been deferred.

See Also

ChangeRequest.Status Class | StarTeam Namespace


CLOSED_DOCUMENTED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.CLOSED_DOCUMENTED Property

public static ChangeRequest.Status CLOSED_DOCUMENTED {get;}

Property Value

A ChangeRequest closed as having been documented.

See Also

ChangeRequest.Status Class | StarTeam Namespace


CLOSED_FIXED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.CLOSED_FIXED Property

public static ChangeRequest.Status CLOSED_FIXED {get;}

Property Value

A ChangeRequest closed because it has been fixed.

See Also

ChangeRequest.Status Class | StarTeam Namespace


CLOSED_IS_DUPLICATE Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.CLOSED_IS_DUPLICATE Property

public static ChangeRequest.Status CLOSED_IS_DUPLICATE {get;}

Property Value

A ChangeRequest closed because it is a duplicate of another.

See Also

ChangeRequest.Status Class | StarTeam Namespace


DEFERRED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.DEFERRED Property

public static ChangeRequest.Status DEFERRED {get;}

Property Value

A deferred ChangeRequest.

See Also

ChangeRequest.Status Class | StarTeam Namespace


DOCUMENTED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.DOCUMENTED Property

public static ChangeRequest.Status DOCUMENTED {get;}

Property Value

A ChangeRequest that has been documented.

See Also

ChangeRequest.Status Class | StarTeam Namespace


FIXED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.FIXED Property

public static ChangeRequest.Status FIXED {get;}

Property Value

A ChangeRequest believed by the developer to be fixed, but not yet verified.

See Also

ChangeRequest.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

ChangeRequest.Status Class | StarTeam Namespace


IN_PROGRESS Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.IN_PROGRESS Property

public static ChangeRequest.Status IN_PROGRESS {get;}

Property Value

An in-progress ChangeRequest.

See Also

ChangeRequest.Status Class | StarTeam Namespace


IS_DUPLICATE Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.IS_DUPLICATE Property

public static ChangeRequest.Status IS_DUPLICATE {get;}

Property Value

A ChangeRequest identified as being a duplicate of another ChangeRequest.

See Also

ChangeRequest.Status Class | StarTeam Namespace


NEW Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.NEW Property

public static ChangeRequest.Status NEW {get;}

Property Value

A new (unsaved) ChangeRequest.

See Also

ChangeRequest.Status Class | StarTeam Namespace


OPEN Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.OPEN Property

public static ChangeRequest.Status OPEN {get;}

Property Value

An open ChangeRequest.

See Also

ChangeRequest.Status Class | StarTeam Namespace


REVIEWED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.REVIEWED Property

public static ChangeRequest.Status REVIEWED {get;}

Property Value

A ChangeRequest reviewed.

See Also

ChangeRequest.Status Class | StarTeam Namespace


VERIFIED_AS_DESIGNED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.VERIFIED_AS_DESIGNED Property

public static ChangeRequest.Status VERIFIED_AS_DESIGNED {get;}

Property Value

A ChangeRequest whose behavior has been verified as being "as designed".

See Also

ChangeRequest.Status Class | StarTeam Namespace


VERIFIED_CANNOT_REPRODUCE Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.VERIFIED_CANNOT_REPRODUCE Property

public static ChangeRequest.Status VERIFIED_CANNOT_REPRODUCE {get;}

Property Value

A ChangeRequest that has been verified as not reproducible.

See Also

ChangeRequest.Status Class | StarTeam Namespace


VERIFIED_DEFERRED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.VERIFIED_DEFERRED Property

public static ChangeRequest.Status VERIFIED_DEFERRED {get;}

Property Value

A ChangeRequest verified to be deferred.

See Also

ChangeRequest.Status Class | StarTeam Namespace


VERIFIED_DOCUMENTED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.VERIFIED_DOCUMENTED Property

public static ChangeRequest.Status VERIFIED_DOCUMENTED {get;}

Property Value

A ChangeRequest verified to have been documented.

See Also

ChangeRequest.Status Class | StarTeam Namespace


VERIFIED_FIXED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.VERIFIED_FIXED Property

public static ChangeRequest.Status VERIFIED_FIXED {get;}

Property Value

A ChangeRequest that has been verified as fixed.

See Also

ChangeRequest.Status Class | StarTeam Namespace


VERIFIED_IS_DUPLICATE Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.VERIFIED_IS_DUPLICATE Property

public static ChangeRequest.Status VERIFIED_IS_DUPLICATE {get;}

Property Value

A ChangeRequest verified to be a duplicate of another.

See Also

ChangeRequest.Status Class | StarTeam Namespace


VERIFIED_REVIEWED Property

Borland StarTeam SDK for .NET

ChangeRequest.Status.VERIFIED_REVIEWED Property

public static ChangeRequest.Status VERIFIED_REVIEWED {get;}

Property Value

A ChangeRequest verified reviewed.

See Also

ChangeRequest.Status Class | StarTeam Namespace


ChangeRequest.Status Methods

The methods of the ChangeRequest.Status class are listed below. For a complete list of ChangeRequest.Status class members, see the ChangeRequest.Status Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.Status.

See Also

ChangeRequest.Status Class | StarTeam Namespace


ChangeRequest.Status.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Status.Equals(obj).

See Also

ChangeRequest.Status Class | StarTeam Namespace


ChangeRequest.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

ChangeRequest.Status Class | StarTeam Namespace


ChangeRequest.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

ChangeRequest.Status Class | StarTeam Namespace


ChangeRequest.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Status.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Status.GetHashCode().

See Also

ChangeRequest.Status Class | StarTeam Namespace


ChangeRequest.Status.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Status.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Status.ToString()

See Also

ChangeRequest.Status Class | StarTeam Namespace


ChangeRequest.StreamState Class

The Info Stream State of the ChangeRequest

For a list of all members of this type, see ChangeRequest.StreamState Members.

System.Object
EnumeratedValue
ChangeRequest.StreamState

public class ChangeRequest.StreamState : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.StreamState Members | StarTeam Namespace


ChangeRequest.StreamState Members

ChangeRequest.StreamState overview

Public Static Properties

ACCEPTED
ALL
PENDING
REJECTED

Public Static Methods

FromID | Gets the Stream State corresponding to the given ID.
FromValue | Gets the stream state value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.StreamState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.StreamState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.StreamState.

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ChangeRequest.StreamState Properties

The properties of the ChangeRequest.StreamState class are listed below. For a complete list of ChangeRequest.StreamState class members, see the ChangeRequest.StreamState Members topic.

Public Static Properties

ACCEPTED
ALL
PENDING
REJECTED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ACCEPTED Property

Borland StarTeam SDK for .NET

ChangeRequest.StreamState.ACCEPTED Property

public static ChangeRequest.StreamState ACCEPTED {get;}

Property Value

ChangeRequest info stream set to Accepted

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ChangeRequest.StreamState.ALL Property

public static StreamState[] ALL {get;}

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangeRequest.StreamState.ID Property

[read] the ID of this Value value.

public virtual Int32 ID {get;}

Property Value

the ID of this Value value.

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


PENDING Property

Borland StarTeam SDK for .NET

ChangeRequest.StreamState.PENDING Property

public static ChangeRequest.StreamState PENDING {get;}

Property Value

ChangeRequest info stream set to Pending

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


REJECTED Property

Borland StarTeam SDK for .NET

ChangeRequest.StreamState.REJECTED Property

public static ChangeRequest.StreamState REJECTED {get;}

Property Value

ChangeRequest info stream set to Rejected

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ChangeRequest.StreamState Methods

The methods of the ChangeRequest.StreamState class are listed below. For a complete list of ChangeRequest.StreamState class members, see the ChangeRequest.StreamState Members topic.

Public Static Methods

FromID | Gets the Stream State corresponding to the given ID.
FromValue | Gets the stream state value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ChangeRequest.StreamState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.StreamState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ChangeRequest.StreamState.

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ChangeRequest.StreamState.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.StreamState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.StreamState.Equals(obj).

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ChangeRequest.StreamState.FromID Method

Gets the Stream State corresponding to the given ID.

public static StreamState FromID(
Int32 id
);

Parameters

id
A StreamState ID.

Return Value

the corresponding StreamState value, or null.

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ChangeRequest.StreamState.FromValue Method

Gets the stream state value corresponding to the given EnumeratedValue.

public static StreamState FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a StreamStateProperty.

Return Value

the corresponding StreamState value, or null.

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ChangeRequest.StreamState.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.StreamState.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.StreamState.GetHashCode().

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ChangeRequest.StreamState.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.StreamState.

public override string ToString();

Return Value

com.starteam.ChangeRequest.StreamState.ToString()

See Also

ChangeRequest.StreamState Class | StarTeam Namespace


ChangeRequest.Type Class

Type meta-data (schema) for ChangeRequest object instances.

For a list of all members of this type, see ChangeRequest.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
ChangeRequest.Type

new public class ChangeRequest.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type Members | StarTeam Namespace


ChangeRequest.Type Members

ChangeRequest.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type Properties

The properties of the ChangeRequest.Type class are listed below. For a complete list of ChangeRequest.Type class members, see the ChangeRequest.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

ChangeRequest.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

ChangeRequest.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

ChangeRequest.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

ChangeRequest.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

ChangeRequest.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

ChangeRequest.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

ChangeRequest.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

ChangeRequest.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.NAME Property

new public static String NAME {get;}

See Also

ChangeRequest.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

ChangeRequest.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

ChangeRequest.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

ChangeRequest.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

ChangeRequest.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type Methods

The methods of the ChangeRequest.Type class are listed below. For a complete list of ChangeRequest.Type class members, see the ChangeRequest.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.Equals(obj).

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.GetHashCode().

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.ToString()

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

ChangeRequest.Type Class | StarTeam Namespace


ChangeRequest.Type.AddressedByProperty Class

The property type of the AddressedBy property.

For a list of all members of this type, see ChangeRequest.Type.AddressedByProperty Members.

System.Object
Property
ObjectProperty
ChangeRequest.Type.AddressedByProperty

public class ChangeRequest.Type.AddressedByProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.AddressedByProperty Members | StarTeam Namespace


ChangeRequest.Type.AddressedByProperty Members

ChangeRequest.Type.AddressedByProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.AddressedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.AddressedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.AddressedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.AddressedByProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedByProperty Properties

The properties of the ChangeRequest.Type.AddressedByProperty class are listed below. For a complete list of ChangeRequest.Type.AddressedByProperty class members, see the ChangeRequest.Type.AddressedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangeRequest.Type.AddressedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.AddressedByProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.AddressedByProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedByProperty Methods

The methods of the ChangeRequest.Type.AddressedByProperty class are listed below. For a complete list of ChangeRequest.Type.AddressedByProperty class members, see the ChangeRequest.Type.AddressedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.AddressedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.AddressedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.AddressedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.AddressedByProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedByProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.AddressedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.AddressedByProperty.Equals(obj).

See Also

ChangeRequest.Type.AddressedByProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.AddressedByProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.AddressedByProperty.GetHashCode().

See Also

ChangeRequest.Type.AddressedByProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedByProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.AddressedByProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.AddressedByProperty.ToString()

See Also

ChangeRequest.Type.AddressedByProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInProperty Class

The property type of the AddressedIn property.

For a list of all members of this type, see ChangeRequest.Type.AddressedInProperty Members.

System.Object
Property
ObjectProperty
ChangeRequest.Type.AddressedInProperty

public class ChangeRequest.Type.AddressedInProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.AddressedInProperty Members | StarTeam Namespace


ChangeRequest.Type.AddressedInProperty Members

ChangeRequest.Type.AddressedInProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.AddressedInProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.AddressedInProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.AddressedInProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.AddressedInProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInProperty Properties

The properties of the ChangeRequest.Type.AddressedInProperty class are listed below. For a complete list of ChangeRequest.Type.AddressedInProperty class members, see the ChangeRequest.Type.AddressedInProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangeRequest.Type.AddressedInProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.AddressedInProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.AddressedInProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInProperty Methods

The methods of the ChangeRequest.Type.AddressedInProperty class are listed below. For a complete list of ChangeRequest.Type.AddressedInProperty class members, see the ChangeRequest.Type.AddressedInProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.AddressedInProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.AddressedInProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.AddressedInProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.AddressedInProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.AddressedInProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.AddressedInProperty.Equals(obj).

See Also

ChangeRequest.Type.AddressedInProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.AddressedInProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.AddressedInProperty.GetHashCode().

See Also

ChangeRequest.Type.AddressedInProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.AddressedInProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.AddressedInProperty.ToString()

See Also

ChangeRequest.Type.AddressedInProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInViewProperty Class

The property type of the AddressedInView property.

For a list of all members of this type, see ChangeRequest.Type.AddressedInViewProperty Members.

System.Object
Property
ObjectProperty
ChangeRequest.Type.AddressedInViewProperty

public class ChangeRequest.Type.AddressedInViewProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.AddressedInViewProperty Members | StarTeam Namespace


ChangeRequest.Type.AddressedInViewProperty Members

ChangeRequest.Type.AddressedInViewProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.AddressedInViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.AddressedInViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.AddressedInViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.AddressedInViewProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInViewProperty Properties

The properties of the ChangeRequest.Type.AddressedInViewProperty class are listed below. For a complete list of ChangeRequest.Type.AddressedInViewProperty class members, see the ChangeRequest.Type.AddressedInViewProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangeRequest.Type.AddressedInViewProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.AddressedInViewProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.AddressedInViewProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInViewProperty Methods

The methods of the ChangeRequest.Type.AddressedInViewProperty class are listed below. For a complete list of ChangeRequest.Type.AddressedInViewProperty class members, see the ChangeRequest.Type.AddressedInViewProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.AddressedInViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.AddressedInViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.AddressedInViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.AddressedInViewProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInViewProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.AddressedInViewProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.AddressedInViewProperty.Equals(obj).

See Also

ChangeRequest.Type.AddressedInViewProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInViewProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.AddressedInViewProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.AddressedInViewProperty.GetHashCode().

See Also

ChangeRequest.Type.AddressedInViewProperty Class | StarTeam Namespace


ChangeRequest.Type.AddressedInViewProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.AddressedInViewProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.AddressedInViewProperty.ToString()

See Also

ChangeRequest.Type.AddressedInViewProperty Class | StarTeam Namespace


ChangeRequest.Type.CategoryProperty Class

The property type of the Category property.

For a list of all members of this type, see ChangeRequest.Type.CategoryProperty Members.

System.Object
Property
VectorProperty
TextProperty
ChangeRequest.Type.CategoryProperty

public class ChangeRequest.Type.CategoryProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.CategoryProperty Members | StarTeam Namespace


ChangeRequest.Type.CategoryProperty Members

ChangeRequest.Type.CategoryProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.CategoryProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.CategoryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.CategoryProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.CategoryProperty Class | StarTeam Namespace


ChangeRequest.Type.CategoryProperty Properties

The properties of the ChangeRequest.Type.CategoryProperty class are listed below. For a complete list of ChangeRequest.Type.CategoryProperty class members, see the ChangeRequest.Type.CategoryProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.CategoryProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.CategoryProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.CategoryProperty Class | StarTeam Namespace


ChangeRequest.Type.CategoryProperty Methods

The methods of the ChangeRequest.Type.CategoryProperty class are listed below. For a complete list of ChangeRequest.Type.CategoryProperty class members, see the ChangeRequest.Type.CategoryProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.CategoryProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.CategoryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.CategoryProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.CategoryProperty Class | StarTeam Namespace


ChangeRequest.Type.CategoryProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.CategoryProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.CategoryProperty.Equals(obj).

See Also

ChangeRequest.Type.CategoryProperty Class | StarTeam Namespace


ChangeRequest.Type.CategoryProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.CategoryProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.CategoryProperty.GetHashCode().

See Also

ChangeRequest.Type.CategoryProperty Class | StarTeam Namespace


ChangeRequest.Type.CategoryProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.CategoryProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.CategoryProperty.ToString()

See Also

ChangeRequest.Type.CategoryProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeNumberProperty Class

The property type of the ChangeNumber property.

For a list of all members of this type, see ChangeRequest.Type.ChangeNumberProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ChangeRequest.Type.ChangeNumberProperty

public class ChangeRequest.Type.ChangeNumberProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.ChangeNumberProperty Members | StarTeam Namespace


ChangeRequest.Type.ChangeNumberProperty Members

ChangeRequest.Type.ChangeNumberProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ChangeNumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ChangeNumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ChangeNumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ChangeNumberProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeNumberProperty Properties

The properties of the ChangeRequest.Type.ChangeNumberProperty class are listed below. For a complete list of ChangeRequest.Type.ChangeNumberProperty class members, see the ChangeRequest.Type.ChangeNumberProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.ChangeNumberProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.ChangeNumberProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.ChangeNumberProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeNumberProperty Methods

The methods of the ChangeRequest.Type.ChangeNumberProperty class are listed below. For a complete list of ChangeRequest.Type.ChangeNumberProperty class members, see the ChangeRequest.Type.ChangeNumberProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ChangeNumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ChangeNumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ChangeNumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ChangeNumberProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeNumberProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.ChangeNumberProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.ChangeNumberProperty.Equals(obj).

See Also

ChangeRequest.Type.ChangeNumberProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeNumberProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ChangeNumberProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.ChangeNumberProperty.GetHashCode().

See Also

ChangeRequest.Type.ChangeNumberProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeNumberProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.ChangeNumberProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.ChangeNumberProperty.ToString()

See Also

ChangeRequest.Type.ChangeNumberProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeRequestTypeProperty Class

The property type of the RequestType property.

For a list of all members of this type, see ChangeRequest.Type.ChangeRequestTypeProperty Members.

System.Object
Property
EnumeratedProperty
ChangeRequest.Type.ChangeRequestTypeProperty

public class ChangeRequest.Type.ChangeRequestTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.ChangeRequestTypeProperty Members | StarTeam Namespace


ChangeRequest.Type.ChangeRequestTypeProperty Members

ChangeRequest.Type.ChangeRequestTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ChangeRequestTypeProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeRequestTypeProperty Properties

The properties of the ChangeRequest.Type.ChangeRequestTypeProperty class are listed below. For a complete list of ChangeRequest.Type.ChangeRequestTypeProperty class members, see the ChangeRequest.Type.ChangeRequestTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ChangeRequest.Type.ChangeRequestTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.ChangeRequestTypeProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.ChangeRequestTypeProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeRequestTypeProperty Methods

The methods of the ChangeRequest.Type.ChangeRequestTypeProperty class are listed below. For a complete list of ChangeRequest.Type.ChangeRequestTypeProperty class members, see the ChangeRequest.Type.ChangeRequestTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ChangeRequestTypeProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeRequestTypeProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.Equals(obj).

See Also

ChangeRequest.Type.ChangeRequestTypeProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeRequestTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ChangeRequest.ChangeRequestType value
);

See Also

ChangeRequest.Type.ChangeRequestTypeProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeRequestTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.GetHashCode().

See Also

ChangeRequest.Type.ChangeRequestTypeProperty Class | StarTeam Namespace


ChangeRequest.Type.ChangeRequestTypeProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.ChangeRequestTypeProperty.ToString()

See Also

ChangeRequest.Type.ChangeRequestTypeProperty Class | StarTeam Namespace


ChangeRequest.Type.ClosedOnProperty Class

The property type of the ClosedOn property.

For a list of all members of this type, see ChangeRequest.Type.ClosedOnProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ChangeRequest.Type.ClosedOnProperty

public class ChangeRequest.Type.ClosedOnProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.ClosedOnProperty Members | StarTeam Namespace


ChangeRequest.Type.ClosedOnProperty Members

ChangeRequest.Type.ClosedOnProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ClosedOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ClosedOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ClosedOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ClosedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ClosedOnProperty Properties

The properties of the ChangeRequest.Type.ClosedOnProperty class are listed below. For a complete list of ChangeRequest.Type.ClosedOnProperty class members, see the ChangeRequest.Type.ClosedOnProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.ClosedOnProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.ClosedOnProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.ClosedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ClosedOnProperty Methods

The methods of the ChangeRequest.Type.ClosedOnProperty class are listed below. For a complete list of ChangeRequest.Type.ClosedOnProperty class members, see the ChangeRequest.Type.ClosedOnProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ClosedOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ClosedOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ClosedOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ClosedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ClosedOnProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.ClosedOnProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.ClosedOnProperty.Equals(obj).

See Also

ChangeRequest.Type.ClosedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ClosedOnProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ClosedOnProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.ClosedOnProperty.GetHashCode().

See Also

ChangeRequest.Type.ClosedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ClosedOnProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.ClosedOnProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.ClosedOnProperty.ToString()

See Also

ChangeRequest.Type.ClosedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ComponentProperty Class

The property type of the Component property.

For a list of all members of this type, see ChangeRequest.Type.ComponentProperty Members.

System.Object
Property
VectorProperty
TextProperty
ChangeRequest.Type.ComponentProperty

public class ChangeRequest.Type.ComponentProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.ComponentProperty Members | StarTeam Namespace


ChangeRequest.Type.ComponentProperty Members

ChangeRequest.Type.ComponentProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ComponentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ComponentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ComponentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ComponentProperty Class | StarTeam Namespace


ChangeRequest.Type.ComponentProperty Properties

The properties of the ChangeRequest.Type.ComponentProperty class are listed below. For a complete list of ChangeRequest.Type.ComponentProperty class members, see the ChangeRequest.Type.ComponentProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.ComponentProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.ComponentProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.ComponentProperty Class | StarTeam Namespace


ChangeRequest.Type.ComponentProperty Methods

The methods of the ChangeRequest.Type.ComponentProperty class are listed below. For a complete list of ChangeRequest.Type.ComponentProperty class members, see the ChangeRequest.Type.ComponentProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ComponentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ComponentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ComponentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ComponentProperty Class | StarTeam Namespace


ChangeRequest.Type.ComponentProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.ComponentProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.ComponentProperty.Equals(obj).

See Also

ChangeRequest.Type.ComponentProperty Class | StarTeam Namespace


ChangeRequest.Type.ComponentProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ComponentProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.ComponentProperty.GetHashCode().

See Also

ChangeRequest.Type.ComponentProperty Class | StarTeam Namespace


ChangeRequest.Type.ComponentProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.ComponentProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.ComponentProperty.ToString()

See Also

ChangeRequest.Type.ComponentProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredByProperty Class

The property type of the EnteredBy property.

For a list of all members of this type, see ChangeRequest.Type.EnteredByProperty Members.

System.Object
Property
ObjectProperty
ChangeRequest.Type.EnteredByProperty

public class ChangeRequest.Type.EnteredByProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.EnteredByProperty Members | StarTeam Namespace


ChangeRequest.Type.EnteredByProperty Members

ChangeRequest.Type.EnteredByProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.EnteredByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.EnteredByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.EnteredByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.EnteredByProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredByProperty Properties

The properties of the ChangeRequest.Type.EnteredByProperty class are listed below. For a complete list of ChangeRequest.Type.EnteredByProperty class members, see the ChangeRequest.Type.EnteredByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangeRequest.Type.EnteredByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.EnteredByProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.EnteredByProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredByProperty Methods

The methods of the ChangeRequest.Type.EnteredByProperty class are listed below. For a complete list of ChangeRequest.Type.EnteredByProperty class members, see the ChangeRequest.Type.EnteredByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.EnteredByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.EnteredByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.EnteredByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.EnteredByProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredByProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.EnteredByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.EnteredByProperty.Equals(obj).

See Also

ChangeRequest.Type.EnteredByProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.EnteredByProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.EnteredByProperty.GetHashCode().

See Also

ChangeRequest.Type.EnteredByProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredByProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.EnteredByProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.EnteredByProperty.ToString()

See Also

ChangeRequest.Type.EnteredByProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredOnProperty Class

The property type of the EnteredOn property.

For a list of all members of this type, see ChangeRequest.Type.EnteredOnProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ChangeRequest.Type.EnteredOnProperty

public class ChangeRequest.Type.EnteredOnProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.EnteredOnProperty Members | StarTeam Namespace


ChangeRequest.Type.EnteredOnProperty Members

ChangeRequest.Type.EnteredOnProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.EnteredOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.EnteredOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.EnteredOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.EnteredOnProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredOnProperty Properties

The properties of the ChangeRequest.Type.EnteredOnProperty class are listed below. For a complete list of ChangeRequest.Type.EnteredOnProperty class members, see the ChangeRequest.Type.EnteredOnProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.EnteredOnProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.EnteredOnProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.EnteredOnProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredOnProperty Methods

The methods of the ChangeRequest.Type.EnteredOnProperty class are listed below. For a complete list of ChangeRequest.Type.EnteredOnProperty class members, see the ChangeRequest.Type.EnteredOnProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.EnteredOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.EnteredOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.EnteredOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.EnteredOnProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredOnProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.EnteredOnProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.EnteredOnProperty.Equals(obj).

See Also

ChangeRequest.Type.EnteredOnProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredOnProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.EnteredOnProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.EnteredOnProperty.GetHashCode().

See Also

ChangeRequest.Type.EnteredOnProperty Class | StarTeam Namespace


ChangeRequest.Type.EnteredOnProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.EnteredOnProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.EnteredOnProperty.ToString()

See Also

ChangeRequest.Type.EnteredOnProperty Class | StarTeam Namespace


ChangeRequest.Type.FixProperty Class

The property type of the Fix property.

For a list of all members of this type, see ChangeRequest.Type.FixProperty Members.

System.Object
Property
VectorProperty
TextProperty
ChangeRequest.Type.FixProperty

public class ChangeRequest.Type.FixProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.FixProperty Members | StarTeam Namespace


ChangeRequest.Type.FixProperty Members

ChangeRequest.Type.FixProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.FixProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.FixProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.FixProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.FixProperty Class | StarTeam Namespace


ChangeRequest.Type.FixProperty Properties

The properties of the ChangeRequest.Type.FixProperty class are listed below. For a complete list of ChangeRequest.Type.FixProperty class members, see the ChangeRequest.Type.FixProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.FixProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.FixProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.FixProperty Class | StarTeam Namespace


ChangeRequest.Type.FixProperty Methods

The methods of the ChangeRequest.Type.FixProperty class are listed below. For a complete list of ChangeRequest.Type.FixProperty class members, see the ChangeRequest.Type.FixProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.FixProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.FixProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.FixProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.FixProperty Class | StarTeam Namespace


ChangeRequest.Type.FixProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.FixProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.FixProperty.Equals(obj).

See Also

ChangeRequest.Type.FixProperty Class | StarTeam Namespace


ChangeRequest.Type.FixProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.FixProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.FixProperty.GetHashCode().

See Also

ChangeRequest.Type.FixProperty Class | StarTeam Namespace


ChangeRequest.Type.FixProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.FixProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.FixProperty.ToString()

See Also

ChangeRequest.Type.FixProperty Class | StarTeam Namespace


ChangeRequest.Type.LastBuildTestedProperty Class

The property type of the LastBuildTested property.

For a list of all members of this type, see ChangeRequest.Type.LastBuildTestedProperty Members.

System.Object
Property
ObjectProperty
ChangeRequest.Type.LastBuildTestedProperty

public class ChangeRequest.Type.LastBuildTestedProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.LastBuildTestedProperty Members | StarTeam Namespace


ChangeRequest.Type.LastBuildTestedProperty Members

ChangeRequest.Type.LastBuildTestedProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.LastBuildTestedProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.LastBuildTestedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.LastBuildTestedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.LastBuildTestedProperty Class | StarTeam Namespace


ChangeRequest.Type.LastBuildTestedProperty Properties

The properties of the ChangeRequest.Type.LastBuildTestedProperty class are listed below. For a complete list of ChangeRequest.Type.LastBuildTestedProperty class members, see the ChangeRequest.Type.LastBuildTestedProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ChangeRequest.Type.LastBuildTestedProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.LastBuildTestedProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.LastBuildTestedProperty Class | StarTeam Namespace


ChangeRequest.Type.LastBuildTestedProperty Methods

The methods of the ChangeRequest.Type.LastBuildTestedProperty class are listed below. For a complete list of ChangeRequest.Type.LastBuildTestedProperty class members, see the ChangeRequest.Type.LastBuildTestedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.LastBuildTestedProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.LastBuildTestedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.LastBuildTestedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.LastBuildTestedProperty Class | StarTeam Namespace


ChangeRequest.Type.LastBuildTestedProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.LastBuildTestedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.LastBuildTestedProperty.Equals(obj).

See Also

ChangeRequest.Type.LastBuildTestedProperty Class | StarTeam Namespace


ChangeRequest.Type.LastBuildTestedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.LastBuildTestedProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.LastBuildTestedProperty.GetHashCode().

See Also

ChangeRequest.Type.LastBuildTestedProperty Class | StarTeam Namespace


ChangeRequest.Type.LastBuildTestedProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.LastBuildTestedProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.LastBuildTestedProperty.ToString()

See Also

ChangeRequest.Type.LastBuildTestedProperty Class | StarTeam Namespace


ChangeRequest.Type.PlatformProperty Class

The property type of the Platform property.

For a list of all members of this type, see ChangeRequest.Type.PlatformProperty Members.

System.Object
Property
EnumeratedProperty
ChangeRequest.Type.PlatformProperty

public class ChangeRequest.Type.PlatformProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.PlatformProperty Members | StarTeam Namespace


ChangeRequest.Type.PlatformProperty Members

ChangeRequest.Type.PlatformProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.PlatformProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.PlatformProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.PlatformProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.PlatformProperty Class | StarTeam Namespace


ChangeRequest.Type.PlatformProperty Properties

The properties of the ChangeRequest.Type.PlatformProperty class are listed below. For a complete list of ChangeRequest.Type.PlatformProperty class members, see the ChangeRequest.Type.PlatformProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ChangeRequest.Type.PlatformProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PlatformProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.PlatformProperty Class | StarTeam Namespace


ChangeRequest.Type.PlatformProperty Methods

The methods of the ChangeRequest.Type.PlatformProperty class are listed below. For a complete list of ChangeRequest.Type.PlatformProperty class members, see the ChangeRequest.Type.PlatformProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.PlatformProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.PlatformProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.PlatformProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.PlatformProperty Class | StarTeam Namespace


ChangeRequest.Type.PlatformProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.PlatformProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.PlatformProperty.Equals(obj).

See Also

ChangeRequest.Type.PlatformProperty Class | StarTeam Namespace


ChangeRequest.Type.PlatformProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ChangeRequest.Platform value
);

See Also

ChangeRequest.Type.PlatformProperty Class | StarTeam Namespace


ChangeRequest.Type.PlatformProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.PlatformProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.PlatformProperty.GetHashCode().

See Also

ChangeRequest.Type.PlatformProperty Class | StarTeam Namespace


ChangeRequest.Type.PlatformProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.PlatformProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.PlatformProperty.ToString()

See Also

ChangeRequest.Type.PlatformProperty Class | StarTeam Namespace


ChangeRequest.Type.PriorityProperty Class

The property type of the Priority property.

For a list of all members of this type, see ChangeRequest.Type.PriorityProperty Members.

System.Object
Property
EnumeratedProperty
ChangeRequest.Type.PriorityProperty

public class ChangeRequest.Type.PriorityProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.PriorityProperty Members | StarTeam Namespace


ChangeRequest.Type.PriorityProperty Members

ChangeRequest.Type.PriorityProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.PriorityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.PriorityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.PriorityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.PriorityProperty Class | StarTeam Namespace


ChangeRequest.Type.PriorityProperty Properties

The properties of the ChangeRequest.Type.PriorityProperty class are listed below. For a complete list of ChangeRequest.Type.PriorityProperty class members, see the ChangeRequest.Type.PriorityProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ChangeRequest.Type.PriorityProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PriorityProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.PriorityProperty Class | StarTeam Namespace


ChangeRequest.Type.PriorityProperty Methods

The methods of the ChangeRequest.Type.PriorityProperty class are listed below. For a complete list of ChangeRequest.Type.PriorityProperty class members, see the ChangeRequest.Type.PriorityProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.PriorityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.PriorityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.PriorityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.PriorityProperty Class | StarTeam Namespace


ChangeRequest.Type.PriorityProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.PriorityProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.PriorityProperty.Equals(obj).

See Also

ChangeRequest.Type.PriorityProperty Class | StarTeam Namespace


ChangeRequest.Type.PriorityProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ChangeRequest.Priority value
);

See Also

ChangeRequest.Type.PriorityProperty Class | StarTeam Namespace


ChangeRequest.Type.PriorityProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.PriorityProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.PriorityProperty.GetHashCode().

See Also

ChangeRequest.Type.PriorityProperty Class | StarTeam Namespace


ChangeRequest.Type.PriorityProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.PriorityProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.PriorityProperty.ToString()

See Also

ChangeRequest.Type.PriorityProperty Class | StarTeam Namespace


ChangeRequest.Type.PropertyCollection Class

The PropertyCollection of a ChangeRequest item.

For a list of all members of this type, see ChangeRequest.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
ChangeRequest.Type.PropertyCollection

new public class ChangeRequest.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.PropertyCollection Members | StarTeam Namespace


ChangeRequest.Type.PropertyCollection Members

ChangeRequest.Type.PropertyCollection overview

Public Instance Properties

ADDRESSED_BY |
ADDRESSED_IN |
ADDRESSED_IN_VIEW |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
CATEGORY |
CHANGE_NUMBER |
CHANGE_REQUEST_TYPE |
CLOSED_ON |
COMMENT |
COMMENT_ID |
COMPONENT |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
ENTERED_BY |
ENTERED_ON |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_REFERENCE |
EXTERNAL_URL |
FIX |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
LAST_BUILD_TESTED |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_FOLDER_NAME |
PARENT_OBJECT_ID |
PLATFORM |
PRIORITY |
RESOLVED_ON |
RESPONSIBILITY |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SEVERITY |
SHARE_STATE |
SHORT_COMMENT |
STAR_FLOW_STATUS |
STATUS |
STREAM_STATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
SYNOPSIS |
TEST_COMMAND |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERIFIED_ON |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WORK_AROUND |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.PropertyCollection.

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ChangeRequest.Type.PropertyCollection Properties

The properties of the ChangeRequest.Type.PropertyCollection class are listed below. For a complete list of ChangeRequest.Type.PropertyCollection class members, see the ChangeRequest.Type.PropertyCollection Members topic.

Public Instance Properties

ADDRESSED_BY |
ADDRESSED_IN |
ADDRESSED_IN_VIEW |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
CATEGORY |
CHANGE_NUMBER |
CHANGE_REQUEST_TYPE |
CLOSED_ON |
COMMENT |
COMMENT_ID |
COMPONENT |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
ENTERED_BY |
ENTERED_ON |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_REFERENCE |
EXTERNAL_URL |
FIX |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
LAST_BUILD_TESTED |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_FOLDER_NAME |
PARENT_OBJECT_ID |
PLATFORM |
PRIORITY |
RESOLVED_ON |
RESPONSIBILITY |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SEVERITY |
SHARE_STATE |
SHORT_COMMENT |
STAR_FLOW_STATUS |
STATUS |
STREAM_STATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
SYNOPSIS |
TEST_COMMAND |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERIFIED_ON |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WORK_AROUND |

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ADDRESSED_BY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ADDRESSED_BY Property

public ChangeRequest.Type.AddressedByProperty ADDRESSED_BY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ADDRESSED_IN Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ADDRESSED_IN Property

public ChangeRequest.Type.AddressedInProperty ADDRESSED_IN {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ADDRESSED_IN_VIEW Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ADDRESSED_IN_VIEW Property

public ChangeRequest.Type.AddressedInViewProperty ADDRESSED_IN_VIEW {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


CATEGORY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.CATEGORY Property

public ChangeRequest.Type.CategoryProperty CATEGORY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


CHANGE_NUMBER Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.CHANGE_NUMBER Property

public ChangeRequest.Type.ChangeNumberProperty CHANGE_NUMBER {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


CHANGE_REQUEST_TYPE Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.CHANGE_REQUEST_TYPE Property

public ChangeRequest.Type.ChangeRequestTypeProperty CHANGE_REQUEST_TYPE {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


CLOSED_ON Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.CLOSED_ON Property

public ChangeRequest.Type.ClosedOnProperty CLOSED_ON {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


COMPONENT Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.COMPONENT Property

public ChangeRequest.Type.ComponentProperty COMPONENT {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ENTERED_BY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ENTERED_BY Property

public ChangeRequest.Type.EnteredByProperty ENTERED_BY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ENTERED_ON Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ENTERED_ON Property

public ChangeRequest.Type.EnteredOnProperty ENTERED_ON {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_REFERENCE Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.EXTERNAL_REFERENCE Property

public Item.Type.ExternalReferenceProperty EXTERNAL_REFERENCE {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


FIX Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.FIX Property

public ChangeRequest.Type.FixProperty FIX {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_PATH Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.FOLDER_PATH Property

public TrackedObject.Type.FolderPathProperty FOLDER_PATH {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


IS_BOOKMARKED Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.IS_BOOKMARKED Property

public ViewMember.Type.IsBookmarkedProperty IS_BOOKMARKED {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


IS_UNREAD Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.IS_UNREAD Property

public ViewMember.Type.IsUnreadProperty IS_UNREAD {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


LAST_BUILD_TESTED Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.LAST_BUILD_TESTED Property

public ChangeRequest.Type.LastBuildTestedProperty LAST_BUILD_TESTED {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


NEW_REVISION_COMMENT Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.NEW_REVISION_COMMENT Property

public Item.Type.NewRevisionCommentProperty NEW_REVISION_COMMENT {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


PARENT_FOLDER_NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.PARENT_FOLDER_NAME Property

public TrackedObject.Type.ParentFolderNameProperty PARENT_FOLDER_NAME {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


PLATFORM Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.PLATFORM Property

public ChangeRequest.Type.PlatformProperty PLATFORM {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


PRIORITY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.PRIORITY Property

public ChangeRequest.Type.PriorityProperty PRIORITY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


RESOLVED_ON Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.RESOLVED_ON Property

public ChangeRequest.Type.ResolvedOnProperty RESOLVED_ON {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


RESPONSIBILITY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.RESPONSIBILITY Property

public ViewMember.Type.ResponsibilityProperty RESPONSIBILITY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


SEVERITY Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.SEVERITY Property

public ChangeRequest.Type.SeverityProperty SEVERITY {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


STAR_FLOW_STATUS Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.STAR_FLOW_STATUS Property

public ChangeRequest.Type.StarFlowStatusProperty STAR_FLOW_STATUS {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.STATUS Property

public ChangeRequest.Type.StatusProperty STATUS {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


STREAM_STATE Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.STREAM_STATE Property

public ChangeRequest.Type.StreamStateProperty STREAM_STATE {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


SYNOPSIS Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.SYNOPSIS Property

public ChangeRequest.Type.SynopsisProperty SYNOPSIS {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


TEST_COMMAND Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.TEST_COMMAND Property

public ChangeRequest.Type.TestCommandProperty TEST_COMMAND {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


VERIFIED_ON Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.VERIFIED_ON Property

public ChangeRequest.Type.VerifiedOnProperty VERIFIED_ON {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


WORK_AROUND Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.PropertyCollection.WORK_AROUND Property

public ChangeRequest.Type.WorkAroundProperty WORK_AROUND {get;}

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ChangeRequest.Type.PropertyCollection Methods

The methods of the ChangeRequest.Type.PropertyCollection class are listed below. For a complete list of ChangeRequest.Type.PropertyCollection class members, see the ChangeRequest.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.PropertyCollection.

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ChangeRequest.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.PropertyCollection.Equals(obj).

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ChangeRequest.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.PropertyCollection.GetHashCode().

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ChangeRequest.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.PropertyCollection.ToString()

See Also

ChangeRequest.Type.PropertyCollection Class | StarTeam Namespace


ChangeRequest.Type.ResolvedOnProperty Class

The property type of the ResolvedOn property.

For a list of all members of this type, see ChangeRequest.Type.ResolvedOnProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ChangeRequest.Type.ResolvedOnProperty

public class ChangeRequest.Type.ResolvedOnProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.ResolvedOnProperty Members | StarTeam Namespace


ChangeRequest.Type.ResolvedOnProperty Members

ChangeRequest.Type.ResolvedOnProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ResolvedOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ResolvedOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ResolvedOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ResolvedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ResolvedOnProperty Properties

The properties of the ChangeRequest.Type.ResolvedOnProperty class are listed below. For a complete list of ChangeRequest.Type.ResolvedOnProperty class members, see the ChangeRequest.Type.ResolvedOnProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.ResolvedOnProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.ResolvedOnProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.ResolvedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ResolvedOnProperty Methods

The methods of the ChangeRequest.Type.ResolvedOnProperty class are listed below. For a complete list of ChangeRequest.Type.ResolvedOnProperty class members, see the ChangeRequest.Type.ResolvedOnProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.ResolvedOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ResolvedOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.ResolvedOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.ResolvedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ResolvedOnProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.ResolvedOnProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.ResolvedOnProperty.Equals(obj).

See Also

ChangeRequest.Type.ResolvedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ResolvedOnProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.ResolvedOnProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.ResolvedOnProperty.GetHashCode().

See Also

ChangeRequest.Type.ResolvedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.ResolvedOnProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.ResolvedOnProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.ResolvedOnProperty.ToString()

See Also

ChangeRequest.Type.ResolvedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.SeverityProperty Class

The property type of the Severity property.

For a list of all members of this type, see ChangeRequest.Type.SeverityProperty Members.

System.Object
Property
EnumeratedProperty
ChangeRequest.Type.SeverityProperty

public class ChangeRequest.Type.SeverityProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.SeverityProperty Members | StarTeam Namespace


ChangeRequest.Type.SeverityProperty Members

ChangeRequest.Type.SeverityProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.SeverityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.SeverityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.SeverityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.SeverityProperty Class | StarTeam Namespace


ChangeRequest.Type.SeverityProperty Properties

The properties of the ChangeRequest.Type.SeverityProperty class are listed below. For a complete list of ChangeRequest.Type.SeverityProperty class members, see the ChangeRequest.Type.SeverityProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ChangeRequest.Type.SeverityProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.SeverityProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.SeverityProperty Class | StarTeam Namespace


ChangeRequest.Type.SeverityProperty Methods

The methods of the ChangeRequest.Type.SeverityProperty class are listed below. For a complete list of ChangeRequest.Type.SeverityProperty class members, see the ChangeRequest.Type.SeverityProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.SeverityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.SeverityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.SeverityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.SeverityProperty Class | StarTeam Namespace


ChangeRequest.Type.SeverityProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.SeverityProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.SeverityProperty.Equals(obj).

See Also

ChangeRequest.Type.SeverityProperty Class | StarTeam Namespace


ChangeRequest.Type.SeverityProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ChangeRequest.Severity value
);

See Also

ChangeRequest.Type.SeverityProperty Class | StarTeam Namespace


ChangeRequest.Type.SeverityProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.SeverityProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.SeverityProperty.GetHashCode().

See Also

ChangeRequest.Type.SeverityProperty Class | StarTeam Namespace


ChangeRequest.Type.SeverityProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.SeverityProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.SeverityProperty.ToString()

See Also

ChangeRequest.Type.SeverityProperty Class | StarTeam Namespace


ChangeRequest.Type.StarFlowStatusProperty Class

The property type of the Status property.

For a list of all members of this type, see ChangeRequest.Type.StarFlowStatusProperty Members.

System.Object
Property
EnumeratedProperty
ChangeRequest.Type.StarFlowStatusProperty

public class ChangeRequest.Type.StarFlowStatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.StarFlowStatusProperty Members | StarTeam Namespace


ChangeRequest.Type.StarFlowStatusProperty Members

ChangeRequest.Type.StarFlowStatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.StarFlowStatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.StarFlowStatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.StarFlowStatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.StarFlowStatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StarFlowStatusProperty Properties

The properties of the ChangeRequest.Type.StarFlowStatusProperty class are listed below. For a complete list of ChangeRequest.Type.StarFlowStatusProperty class members, see the ChangeRequest.Type.StarFlowStatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ChangeRequest.Type.StarFlowStatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.StarFlowStatusProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.StarFlowStatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StarFlowStatusProperty Methods

The methods of the ChangeRequest.Type.StarFlowStatusProperty class are listed below. For a complete list of ChangeRequest.Type.StarFlowStatusProperty class members, see the ChangeRequest.Type.StarFlowStatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.StarFlowStatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.StarFlowStatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.StarFlowStatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.StarFlowStatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StarFlowStatusProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.StarFlowStatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.StarFlowStatusProperty.Equals(obj).

See Also

ChangeRequest.Type.StarFlowStatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StarFlowStatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ChangeRequest.StarFlowStatus value
);

See Also

ChangeRequest.Type.StarFlowStatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StarFlowStatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.StarFlowStatusProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.StarFlowStatusProperty.GetHashCode().

See Also

ChangeRequest.Type.StarFlowStatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StarFlowStatusProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.StarFlowStatusProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.StarFlowStatusProperty.ToString()

See Also

ChangeRequest.Type.StarFlowStatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see ChangeRequest.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
ChangeRequest.Type.StatusProperty

public class ChangeRequest.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.StatusProperty Members | StarTeam Namespace


ChangeRequest.Type.StatusProperty Members

ChangeRequest.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.StatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StatusProperty Properties

The properties of the ChangeRequest.Type.StatusProperty class are listed below. For a complete list of ChangeRequest.Type.StatusProperty class members, see the ChangeRequest.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ChangeRequest.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.StatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StatusProperty Methods

The methods of the ChangeRequest.Type.StatusProperty class are listed below. For a complete list of ChangeRequest.Type.StatusProperty class members, see the ChangeRequest.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.StatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.StatusProperty.Equals(obj).

See Also

ChangeRequest.Type.StatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ChangeRequest.Status value
);

See Also

ChangeRequest.Type.StatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.StatusProperty.GetHashCode().

See Also

ChangeRequest.Type.StatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.StatusProperty.ToString()

See Also

ChangeRequest.Type.StatusProperty Class | StarTeam Namespace


ChangeRequest.Type.StreamStateProperty Class

The property type of the StreamState property.

For a list of all members of this type, see ChangeRequest.Type.StreamStateProperty Members.

System.Object
Property
EnumeratedProperty
ChangeRequest.Type.StreamStateProperty

public class ChangeRequest.Type.StreamStateProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.StreamStateProperty Members | StarTeam Namespace


ChangeRequest.Type.StreamStateProperty Members

ChangeRequest.Type.StreamStateProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.StreamStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.StreamStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.StreamStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.StreamStateProperty Class | StarTeam Namespace


ChangeRequest.Type.StreamStateProperty Properties

The properties of the ChangeRequest.Type.StreamStateProperty class are listed below. For a complete list of ChangeRequest.Type.StreamStateProperty class members, see the ChangeRequest.Type.StreamStateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ChangeRequest.Type.StreamStateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.StreamStateProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.StreamStateProperty Class | StarTeam Namespace


ChangeRequest.Type.StreamStateProperty Methods

The methods of the ChangeRequest.Type.StreamStateProperty class are listed below. For a complete list of ChangeRequest.Type.StreamStateProperty class members, see the ChangeRequest.Type.StreamStateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.StreamStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.StreamStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.StreamStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.StreamStateProperty Class | StarTeam Namespace


ChangeRequest.Type.StreamStateProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.StreamStateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.StreamStateProperty.Equals(obj).

See Also

ChangeRequest.Type.StreamStateProperty Class | StarTeam Namespace


ChangeRequest.Type.StreamStateProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ChangeRequest.StreamState value
);

See Also

ChangeRequest.Type.StreamStateProperty Class | StarTeam Namespace


ChangeRequest.Type.StreamStateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.StreamStateProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.StreamStateProperty.GetHashCode().

See Also

ChangeRequest.Type.StreamStateProperty Class | StarTeam Namespace


ChangeRequest.Type.StreamStateProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.StreamStateProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.StreamStateProperty.ToString()

See Also

ChangeRequest.Type.StreamStateProperty Class | StarTeam Namespace


ChangeRequest.Type.SynopsisProperty Class

The property type of the Synopsis property.

For a list of all members of this type, see ChangeRequest.Type.SynopsisProperty Members.

System.Object
Property
VectorProperty
TextProperty
ChangeRequest.Type.SynopsisProperty

public class ChangeRequest.Type.SynopsisProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.SynopsisProperty Members | StarTeam Namespace


ChangeRequest.Type.SynopsisProperty Members

ChangeRequest.Type.SynopsisProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.SynopsisProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.SynopsisProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.SynopsisProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.SynopsisProperty Class | StarTeam Namespace


ChangeRequest.Type.SynopsisProperty Properties

The properties of the ChangeRequest.Type.SynopsisProperty class are listed below. For a complete list of ChangeRequest.Type.SynopsisProperty class members, see the ChangeRequest.Type.SynopsisProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.SynopsisProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.SynopsisProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.SynopsisProperty Class | StarTeam Namespace


ChangeRequest.Type.SynopsisProperty Methods

The methods of the ChangeRequest.Type.SynopsisProperty class are listed below. For a complete list of ChangeRequest.Type.SynopsisProperty class members, see the ChangeRequest.Type.SynopsisProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.SynopsisProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.SynopsisProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.SynopsisProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.SynopsisProperty Class | StarTeam Namespace


ChangeRequest.Type.SynopsisProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.SynopsisProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.SynopsisProperty.Equals(obj).

See Also

ChangeRequest.Type.SynopsisProperty Class | StarTeam Namespace


ChangeRequest.Type.SynopsisProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.SynopsisProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.SynopsisProperty.GetHashCode().

See Also

ChangeRequest.Type.SynopsisProperty Class | StarTeam Namespace


ChangeRequest.Type.SynopsisProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.SynopsisProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.SynopsisProperty.ToString()

See Also

ChangeRequest.Type.SynopsisProperty Class | StarTeam Namespace


ChangeRequest.Type.TestCommandProperty Class

The property type of the TestCommand property.

For a list of all members of this type, see ChangeRequest.Type.TestCommandProperty Members.

System.Object
Property
VectorProperty
TextProperty
ChangeRequest.Type.TestCommandProperty

public class ChangeRequest.Type.TestCommandProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.TestCommandProperty Members | StarTeam Namespace


ChangeRequest.Type.TestCommandProperty Members

ChangeRequest.Type.TestCommandProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.TestCommandProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.TestCommandProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.TestCommandProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.TestCommandProperty Class | StarTeam Namespace


ChangeRequest.Type.TestCommandProperty Properties

The properties of the ChangeRequest.Type.TestCommandProperty class are listed below. For a complete list of ChangeRequest.Type.TestCommandProperty class members, see the ChangeRequest.Type.TestCommandProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.TestCommandProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.TestCommandProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.TestCommandProperty Class | StarTeam Namespace


ChangeRequest.Type.TestCommandProperty Methods

The methods of the ChangeRequest.Type.TestCommandProperty class are listed below. For a complete list of ChangeRequest.Type.TestCommandProperty class members, see the ChangeRequest.Type.TestCommandProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.TestCommandProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.TestCommandProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.TestCommandProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.TestCommandProperty Class | StarTeam Namespace


ChangeRequest.Type.TestCommandProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.TestCommandProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.TestCommandProperty.Equals(obj).

See Also

ChangeRequest.Type.TestCommandProperty Class | StarTeam Namespace


ChangeRequest.Type.TestCommandProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.TestCommandProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.TestCommandProperty.GetHashCode().

See Also

ChangeRequest.Type.TestCommandProperty Class | StarTeam Namespace


ChangeRequest.Type.TestCommandProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.TestCommandProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.TestCommandProperty.ToString()

See Also

ChangeRequest.Type.TestCommandProperty Class | StarTeam Namespace


ChangeRequest.Type.VerifiedOnProperty Class

The property type of the VerifiedOn property.

For a list of all members of this type, see ChangeRequest.Type.VerifiedOnProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ChangeRequest.Type.VerifiedOnProperty

public class ChangeRequest.Type.VerifiedOnProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.VerifiedOnProperty Members | StarTeam Namespace


ChangeRequest.Type.VerifiedOnProperty Members

ChangeRequest.Type.VerifiedOnProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.VerifiedOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.VerifiedOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.VerifiedOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.VerifiedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.VerifiedOnProperty Properties

The properties of the ChangeRequest.Type.VerifiedOnProperty class are listed below. For a complete list of ChangeRequest.Type.VerifiedOnProperty class members, see the ChangeRequest.Type.VerifiedOnProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.VerifiedOnProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.VerifiedOnProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.VerifiedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.VerifiedOnProperty Methods

The methods of the ChangeRequest.Type.VerifiedOnProperty class are listed below. For a complete list of ChangeRequest.Type.VerifiedOnProperty class members, see the ChangeRequest.Type.VerifiedOnProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.VerifiedOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.VerifiedOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.VerifiedOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.VerifiedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.VerifiedOnProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.VerifiedOnProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.VerifiedOnProperty.Equals(obj).

See Also

ChangeRequest.Type.VerifiedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.VerifiedOnProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.VerifiedOnProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.VerifiedOnProperty.GetHashCode().

See Also

ChangeRequest.Type.VerifiedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.VerifiedOnProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.VerifiedOnProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.VerifiedOnProperty.ToString()

See Also

ChangeRequest.Type.VerifiedOnProperty Class | StarTeam Namespace


ChangeRequest.Type.WorkAroundProperty Class

The property type of the WorkAround property.

For a list of all members of this type, see ChangeRequest.Type.WorkAroundProperty Members.

System.Object
Property
VectorProperty
TextProperty
ChangeRequest.Type.WorkAroundProperty

public class ChangeRequest.Type.WorkAroundProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.Type.WorkAroundProperty Members | StarTeam Namespace


ChangeRequest.Type.WorkAroundProperty Members

ChangeRequest.Type.WorkAroundProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.WorkAroundProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.WorkAroundProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.WorkAroundProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.WorkAroundProperty Class | StarTeam Namespace


ChangeRequest.Type.WorkAroundProperty Properties

The properties of the ChangeRequest.Type.WorkAroundProperty class are listed below. For a complete list of ChangeRequest.Type.WorkAroundProperty class members, see the ChangeRequest.Type.WorkAroundProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ChangeRequest.Type.WorkAroundProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ChangeRequest.Type.WorkAroundProperty.NAME Property

public static String NAME {get;}

See Also

ChangeRequest.Type.WorkAroundProperty Class | StarTeam Namespace


ChangeRequest.Type.WorkAroundProperty Methods

The methods of the ChangeRequest.Type.WorkAroundProperty class are listed below. For a complete list of ChangeRequest.Type.WorkAroundProperty class members, see the ChangeRequest.Type.WorkAroundProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ChangeRequest.Type.WorkAroundProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.Type.WorkAroundProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ChangeRequest.Type.WorkAroundProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ChangeRequest.Type.WorkAroundProperty Class | StarTeam Namespace


ChangeRequest.Type.WorkAroundProperty.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.Type.WorkAroundProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.Type.WorkAroundProperty.Equals(obj).

See Also

ChangeRequest.Type.WorkAroundProperty Class | StarTeam Namespace


ChangeRequest.Type.WorkAroundProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.Type.WorkAroundProperty.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.Type.WorkAroundProperty.GetHashCode().

See Also

ChangeRequest.Type.WorkAroundProperty Class | StarTeam Namespace


ChangeRequest.Type.WorkAroundProperty.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.Type.WorkAroundProperty.

public override string ToString();

Return Value

com.starteam.ChangeRequest.Type.WorkAroundProperty.ToString()

See Also

ChangeRequest.Type.WorkAroundProperty Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest Class

Item accessor for cached SDK ChangeRequest items contained objects are obtained from the artifact cache

For a list of all members of this type, see ChangeRequest.WebCacheChangeRequest Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
ChangeRequest.WebCacheChangeRequest

public class ChangeRequest.WebCacheChangeRequest : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeRequest.WebCacheChangeRequest Members | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest Members

ChangeRequest.WebCacheChangeRequest overview

Public Static Methods

Create Overloaded.

Public Instance Properties

AddressedBy | [read/write] the User object that addressed this request.
AddressedIn | [read/write] the label for the build in which this request was addressed
AddressedInView | [read/write] The view from which this Change Request was addressed.
Attachments | [read/write] an array of attachments for this ViewMember
Category | [read/write] the category of this request.
ChangePackages | [read] the Change Packages linked to this process item
ClosedOn | [read] the date that this request was given a closed status.
Comment | [read/write] the Comment attached to this view member
Component | [read/write] the component this request applies to.
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this change request.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EnteredBy | [read/write] the User object that entered this request.
EnteredOn | [read] the date that this request was entered
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalReference | [read/write] the external reference field for this change request
ExternalURL | [read/write] The external URL describing this revision of the item.
Fix | [read/write] the fix for this change request.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
LastBuildTested | [read/write] a label of the build or named configuration that this request was last tested in.
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
Number | [read] this change requests CR#
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PlatformValue | [read/write] The platform this Change Request applies to.
PresentationID | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The relative priority of this Change Request.
RequestTypeValue | [read/write] This change request's type. The type denotes whether this request is a defect report or a feature enhancement.
ResolvedOn | [read] The date that this Change Request was resolved.
Responsibility | [read/write] the User object that is currently responsible for this request.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
SeverityValue | [read/write] The relative severity of the condition that this Change Request represents.
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StarFlowStatusValue | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
StatusValue | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
StreamState | [read/write] streamState of this ChangeRequest
Synopsis | [read/write] the synopsis or brief description of this request.
TestCommand | [read/write] the test command string for this change request.
Traces | [read] a Trace[] of applicable Traces
VerifiedOn | [read] The date that this Change Request was verified.
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WorkAround | [read/write] the workaround for this change request.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.ChangeRequest.WebCacheChangeRequest.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.WebCacheChangeRequest.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.ChangeRequest.WebCacheChangeRequest.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest Properties

The properties of the ChangeRequest.WebCacheChangeRequest class are listed below. For a complete list of ChangeRequest.WebCacheChangeRequest class members, see the ChangeRequest.WebCacheChangeRequest Members topic.

Public Instance Properties

AddressedBy | [read/write] the User object that addressed this request.
AddressedIn | [read/write] the label for the build in which this request was addressed
AddressedInView | [read/write] The view from which this Change Request was addressed.
Attachments | [read/write] an array of attachments for this ViewMember
Category | [read/write] the category of this request.
ChangePackages | [read] the Change Packages linked to this process item
ClosedOn | [read] the date that this request was given a closed status.
Comment | [read/write] the Comment attached to this view member
Component | [read/write] the component this request applies to.
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this change request.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EnteredBy | [read/write] the User object that entered this request.
EnteredOn | [read] the date that this request was entered
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalReference | [read/write] the external reference field for this change request
ExternalURL | [read/write] The external URL describing this revision of the item.
Fix | [read/write] the fix for this change request.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
LastBuildTested | [read/write] a label of the build or named configuration that this request was last tested in.
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
Number | [read] this change requests CR#
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PlatformValue | [read/write] The platform this Change Request applies to.
PresentationID | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The relative priority of this Change Request.
RequestTypeValue | [read/write] This change request's type. The type denotes whether this request is a defect report or a feature enhancement.
ResolvedOn | [read] The date that this Change Request was resolved.
Responsibility | [read/write] the User object that is currently responsible for this request.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
SeverityValue | [read/write] The relative severity of the condition that this Change Request represents.
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StarFlowStatusValue | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
StatusValue | [read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.
StreamState | [read/write] streamState of this ChangeRequest
Synopsis | [read/write] the synopsis or brief description of this request.
TestCommand | [read/write] the test command string for this change request.
Traces | [read] a Trace[] of applicable Traces
VerifiedOn | [read] The date that this Change Request was verified.
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WorkAround | [read/write] the workaround for this change request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


AddressedBy Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.AddressedBy Property

[read/write] the User object that addressed this request.

public virtual User.WebCacheUser AddressedBy {get; set;}

Property Value

the User object that addressed this request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


AddressedIn Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.AddressedIn Property

[read/write] the label for the build in which this request was addressed

public virtual Label.WebCacheLabel AddressedIn {get; set;}

Property Value

the label for the build in which this request was addressed

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


AddressedInView Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.AddressedInView Property

[read/write] The view from which this Change Request was addressed.

public virtual View.WebCacheView AddressedInView {get; set;}

Property Value

The view from which this Change Request was addressed.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Category Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Category Property

[read/write] the category of this request.

public virtual String Category {get; set;}

Property Value

the category of this request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ClosedOn Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ClosedOn Property

[read] the date that this request was given a closed status.

public virtual DateTime ClosedOn {get;}

Property Value

the date that this request was given a closed status.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Component Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Component Property

[read/write] the component this request applies to.

public virtual String Component {get; set;}

Property Value

the component this request applies to.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Description Property

[read/write] the description of this change request.

public virtual String Description {get; set;}

Property Value

the description of this change request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


EnteredBy Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.EnteredBy Property

[read/write] the User object that entered this request.

public virtual User.WebCacheUser EnteredBy {get; set;}

Property Value

the User object that entered this request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


EnteredOn Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.EnteredOn Property

[read] the date that this request was entered

public virtual DateTime EnteredOn {get;}

Property Value

the date that this request was entered

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ExternalReference Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ExternalReference Property

[read/write] the external reference field for this change request

public virtual String ExternalReference {get; set;}

Property Value

the external reference field for this change request

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Fix Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Fix Property

[read/write] the fix for this change request.

public virtual String Fix {get; set;}

Property Value

the fix for this change request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


LastBuildTested Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.LastBuildTested Property

[read/write] a label of the build or named configuration that this request was last tested in.

public virtual Label.WebCacheLabel LastBuildTested {get; set;}

Property Value

a label of the build or named configuration that this request was last tested in.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Name Property

new public virtual String Name {get;}

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Number Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Number Property

[read] this change requests CR#

public virtual Int32 Number {get;}

Property Value

this change requests CR#

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


PlatformValue Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.PlatformValue Property

[read/write] The platform this Change Request applies to.

public virtual ChangeRequest.Platform PlatformValue {get; set;}

Property Value

The platform this Change Request applies to.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


PriorityValue Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.PriorityValue Property

[read/write] The relative priority of this Change Request.

public virtual ChangeRequest.Priority PriorityValue {get; set;}

Property Value

The relative priority of this Change Request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


RequestTypeValue Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.RequestTypeValue Property

[read/write] This change request's type. The type denotes whether this request is a defect report or a feature enhancement.

public virtual ChangeRequest.ChangeRequestType RequestTypeValue {get; set;}

Property Value

This change request's type. The type denotes whether this request is a defect report or a feature enhancement.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ResolvedOn Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ResolvedOn Property

[read] The date that this Change Request was resolved.

public virtual DateTime ResolvedOn {get;}

Property Value

The date that this Change Request was resolved.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Responsibility Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Responsibility Property

[read/write] the User object that is currently responsible for this request.

public virtual User.WebCacheUser Responsibility {get; set;}

Property Value

the User object that is currently responsible for this request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


SeverityValue Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.SeverityValue Property

[read/write] The relative severity of the condition that this Change Request represents.

public virtual ChangeRequest.Severity SeverityValue {get; set;}

Property Value

The relative severity of the condition that this Change Request represents.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


StarFlowStatusValue Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.StarFlowStatusValue Property

[read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.

public virtual ChangeRequest.StarFlowStatus StarFlowStatusValue {get; set;}

Property Value

The status (Open, Fixed, Closed, etc.) of this Change Request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.StatusValue Property

[read/write] The status (Open, Fixed, Closed, etc.) of this Change Request.

public virtual ChangeRequest.Status StatusValue {get; set;}

Property Value

The status (Open, Fixed, Closed, etc.) of this Change Request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


StreamState Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.StreamState Property

[read/write] streamState of this ChangeRequest

public virtual ChangeRequest.StreamState StreamState {get; set;}

Property Value

streamState of this ChangeRequest

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Synopsis Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Synopsis Property

[read/write] the synopsis or brief description of this request.

public virtual String Synopsis {get; set;}

Property Value

the synopsis or brief description of this request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


TestCommand Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.TestCommand Property

[read/write] the test command string for this change request.

public virtual String TestCommand {get; set;}

Property Value

the test command string for this change request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


VerifiedOn Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.VerifiedOn Property

[read] The date that this Change Request was verified.

public virtual DateTime VerifiedOn {get;}

Property Value

The date that this Change Request was verified.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


WorkAround Property

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.WorkAround Property

[read/write] the workaround for this change request.

public virtual String WorkAround {get; set;}

Property Value

the workaround for this change request.

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest Methods

The methods of the ChangeRequest.WebCacheChangeRequest class are listed below. For a complete list of ChangeRequest.WebCacheChangeRequest class members, see the ChangeRequest.WebCacheChangeRequest Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.ChangeRequest.WebCacheChangeRequest.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeRequest.WebCacheChangeRequest.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.ChangeRequest.WebCacheChangeRequest.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Create Method

Overload List

public static WebCacheChangeRequest Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheChangeRequest Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.Create Overload List


ChangeRequest.WebCacheChangeRequest.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.Create Overload List


ChangeRequest.WebCacheChangeRequest.Equals Method

Delegate Equals() to com.starteam.ChangeRequest.WebCacheChangeRequest.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeRequest.WebCacheChangeRequest.Equals(obj).

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeRequest.WebCacheChangeRequest.

public override int GetHashCode();

Return Value

com.starteam.ChangeRequest.WebCacheChangeRequest.GetHashCode().

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.GetValue Overload List


ChangeRequest.WebCacheChangeRequest.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.GetValue Overload List


ChangeRequest.WebCacheChangeRequest.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | WebCacheViewMemberCollection


ChangeRequest.WebCacheChangeRequest.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.Lock Overload List | WebCacheViewMemberCollection


ChangeRequest.WebCacheChangeRequest.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.Lock Overload List


ChangeRequest.WebCacheChangeRequest.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | NAME


ChangeRequest.WebCacheChangeRequest.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.MoveTo Overload List


ChangeRequest.WebCacheChangeRequest.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.MoveTo Overload List


ChangeRequest.WebCacheChangeRequest.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | isFloating | isPinned | unpin


ChangeRequest.WebCacheChangeRequest.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | WebCacheViewMemberCollection


ChangeRequest.WebCacheChangeRequest.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

ChangeRequest.WebCacheChangeRequest.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.SetValue Overload List


ChangeRequest.WebCacheChangeRequest.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | ChangeRequest.WebCacheChangeRequest.SetValue Overload List


ChangeRequest.WebCacheChangeRequest.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.ToString Method

Delegate ToString() to com.starteam.ChangeRequest.WebCacheChangeRequest.

public override string ToString();

Return Value

com.starteam.ChangeRequest.WebCacheChangeRequest.ToString()

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeRequest.WebCacheChangeRequest.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | WebCacheViewMemberCollection


ChangeRequest.WebCacheChangeRequest.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | isFloating | isPinned | pinTo


ChangeRequest.WebCacheChangeRequest.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace | WebCacheViewMemberCollection


ChangeRequest.WebCacheChangeRequest.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

ChangeRequest.WebCacheChangeRequest Class | StarTeam Namespace


ChangeSession Class

A change session, possibly associated with a change package.

For a list of all members of this type, see ChangeSession Members.

System.Object
ChangeSession
Session

public class ChangeSession

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangeSession Members | StarTeam Namespace


ChangeSession Members

ChangeSession overview

Public Instance Properties

ChangePackage | [read] ChangePackage
DefaultName | [read] A default name for this session.
Description | [read/write] The description of the ChangePackage for this session, or a proposed default description.
HasLocks | [read] true if any source or target items are currently locked on behalf of this session.
IsActive | [read] boolean
IsCommitted | [read] boolean
IsReadOnly | [read] boolean
LockCount | [read] The number of source or target items that are currently locked on behalf of this session.
Name | [read/write] The name of the ChangePackage for this session, or a proposed default name.
SourceView | [read] The source view associated with this session.
TargetView | [read] The target view associated with this session.

Public Instance Methods

Close | Overloaded. Closes this change session, and releases the exclusive lock on the corresponding change package, if necessary.
Connect Connects a restored session to a server instance. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link Session#getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
Equals | Delegate Equals() to com.starteam.ChangeSession.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeSession.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveLocks | Unlocks any source or target items that were locked on behalf of this session. If the session is in a disconnected state removeLocks will inspect the XML representation of the session to identify and unlock the locked items
Restart | Restart this session The session is opened for writing, and is ready to re-run a compare in the current context of the source and target views
Save | Saves the current state of this session. The session must be in an active state. If the session was not previously saved, a new active change package is created.
ToString | Delegate ToString() to com.starteam.ChangeSession.

See Also

ChangeSession Class | StarTeam Namespace


ChangeSession Properties

The properties of the ChangeSession class are listed below. For a complete list of ChangeSession class members, see the ChangeSession Members topic.

Public Instance Properties

ChangePackage | [read] ChangePackage
DefaultName | [read] A default name for this session.
Description | [read/write] The description of the ChangePackage for this session, or a proposed default description.
HasLocks | [read] true if any source or target items are currently locked on behalf of this session.
IsActive | [read] boolean
IsCommitted | [read] boolean
IsReadOnly | [read] boolean
LockCount | [read] The number of source or target items that are currently locked on behalf of this session.
Name | [read/write] The name of the ChangePackage for this session, or a proposed default name.
SourceView | [read] The source view associated with this session.
TargetView | [read] The target view associated with this session.

See Also

ChangeSession Class | StarTeam Namespace


ChangePackage Property

Borland StarTeam SDK for .NET

ChangeSession.ChangePackage Property

[read] ChangePackage

public virtual ChangePackage ChangePackage {get;}

Property Value

ChangePackage

See Also

ChangeSession Class | StarTeam Namespace


DefaultName Property

Borland StarTeam SDK for .NET

ChangeSession.DefaultName Property

[read] A default name for this session.

public virtual String DefaultName {get;}

Property Value

A default name for this session.

See Also

ChangeSession Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ChangeSession.Description Property

[read/write] The description of the ChangePackage for this session, or a proposed default description.

public virtual String Description {get; set;}

Property Value

The description of the ChangePackage for this session, or a proposed default description.

See Also

ChangeSession Class | StarTeam Namespace


HasLocks Property

Borland StarTeam SDK for .NET

ChangeSession.HasLocks Property

[read] true if any source or target items are currently locked on behalf of this session.

public virtual Boolean HasLocks {get;}

Property Value

true if any source or target items are currently locked on behalf of this session.

See Also

ChangeSession Class | StarTeam Namespace


IsActive Property

Borland StarTeam SDK for .NET

ChangeSession.IsActive Property

[read] boolean

public virtual Boolean IsActive {get;}

Property Value

boolean

See Also

ChangeSession Class | StarTeam Namespace


IsCommitted Property

Borland StarTeam SDK for .NET

ChangeSession.IsCommitted Property

[read] boolean

public virtual Boolean IsCommitted {get;}

Property Value

boolean

See Also

ChangeSession Class | StarTeam Namespace


IsReadOnly Property

Borland StarTeam SDK for .NET

ChangeSession.IsReadOnly Property

[read] boolean

public virtual Boolean IsReadOnly {get;}

Property Value

boolean

See Also

ChangeSession Class | StarTeam Namespace


LockCount Property

Borland StarTeam SDK for .NET

ChangeSession.LockCount Property

[read] The number of source or target items that are currently locked on behalf of this session.

public virtual Int32 LockCount {get;}

Property Value

The number of source or target items that are currently locked on behalf of this session.

See Also

ChangeSession Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ChangeSession.Name Property

[read/write] The name of the ChangePackage for this session, or a proposed default name.

public virtual String Name {get; set;}

Property Value

The name of the ChangePackage for this session, or a proposed default name.

See Also

ChangeSession Class | StarTeam Namespace


SourceView Property

Borland StarTeam SDK for .NET

ChangeSession.SourceView Property

[read] The source view associated with this session.

public virtual View SourceView {get;}

Property Value

The source view associated with this session.

See Also

ChangeSession Class | StarTeam Namespace


TargetView Property

Borland StarTeam SDK for .NET

ChangeSession.TargetView Property

[read] The target view associated with this session.

public virtual View TargetView {get;}

Property Value

The target view associated with this session.

See Also

ChangeSession Class | StarTeam Namespace


ChangeSession Methods

The methods of the ChangeSession class are listed below. For a complete list of ChangeSession class members, see the ChangeSession Members topic.

Public Instance Methods

Close | Overloaded. Closes this change session, and releases the exclusive lock on the corresponding change package, if necessary.
Connect Connects a restored session to a server instance. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link Session#getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
Equals | Delegate Equals() to com.starteam.ChangeSession.
GetHashCode | Delegate GetHashCode() to com.starteam.ChangeSession.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveLocks | Unlocks any source or target items that were locked on behalf of this session. If the session is in a disconnected state removeLocks will inspect the XML representation of the session to identify and unlock the locked items
Restart | Restart this session The session is opened for writing, and is ready to re-run a compare in the current context of the source and target views
Save | Saves the current state of this session. The session must be in an active state. If the session was not previously saved, a new active change package is created.
ToString | Delegate ToString() to com.starteam.ChangeSession.

See Also

ChangeSession Class | StarTeam Namespace


Close Method

Borland StarTeam SDK for .NET

ChangeSession.Close Method

Closes this change session, and releases the exclusive lock on the corresponding change package, if necessary.

Overload List

Closes this change session, and releases the exclusive lock on the corresponding change package, if necessary.

public virtual void Close();

Closes this change session, optionally releasing the exclusive lock on the corresponding change package.

public virtual void Close(Boolean);

See Also

ChangeSession Class | StarTeam Namespace


ChangeSession.Close Method ()

Closes this change session, and releases the exclusive lock on the corresponding change package, if necessary.

public virtual void Close();

See Also

ChangeSession Class | StarTeam Namespace | ChangeSession.Close Overload List


ChangeSession.Close Method (Boolean)

Closes this change session, optionally releasing the exclusive lock on the corresponding change package.

public virtual void Close(
Boolean unlock
);

Parameters

unlock
true to unlock the corresponding change package.

See Also

ChangeSession Class | StarTeam Namespace | ChangeSession.Close Overload List


ChangeSession.Connect Method

Connects a restored session to a server instance.

When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link Session#getServerInfo getServerInfo}.

For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public virtual void Connect(
Server server
);

Parameters

server
The server instance to be connected. The server must refer to the same StarTeam repository with which the session was created.

See Also

ChangeSession Class | StarTeam Namespace


ChangeSession.Equals Method

Delegate Equals() to com.starteam.ChangeSession.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ChangeSession.Equals(obj).

See Also

ChangeSession Class | StarTeam Namespace


ChangeSession.GetHashCode Method

Delegate GetHashCode() to com.starteam.ChangeSession.

public override int GetHashCode();

Return Value

com.starteam.ChangeSession.GetHashCode().

See Also

ChangeSession Class | StarTeam Namespace


ChangeSession.RemoveLocks Method

Unlocks any source or target items that were locked on behalf of this session. If the session is in a disconnected state removeLocks will inspect the XML representation of the session to identify and unlock the locked items

public virtual void RemoveLocks();

See Also

ChangeSession Class | StarTeam Namespace | hasLocks | getLockCount | getSourceView | getTargetView


ChangeSession.Restart Method

Restart this session The session is opened for writing, and is ready to re-run a compare in the current context of the source and target views

public virtual void Restart(
Server server
);

Parameters

server
the server instance on which this session will run

See Also

ChangeSession Class | StarTeam Namespace | connect


ChangeSession.Save Method

Saves the current state of this session. The session must be in an active state. If the session was not previously saved, a new active change package is created.

public virtual ChangePackage Save();

See Also

ChangeSession Class | StarTeam Namespace


ChangeSession.ToString Method

Delegate ToString() to com.starteam.ChangeSession.

public override string ToString();

Return Value

com.starteam.ChangeSession.ToString()

See Also

ChangeSession Class | StarTeam Namespace


CheckinManager Class

Provides a way to check in multiple files, applying a consistent set of options across all files. Files may be aggregated or overwritten (using the different flavors of the checkin api's) until ready to commit all the changes Files may also be deleted or moved from their current parent folder to a different folder in the same view The commit() method must be called to save all the changes to the repository The commit consists of a non-transactional phase, followed by a transactional one, which additionally creates a ChangePackage that encompasses the set of changes, i.e. files added, modified, deleted and moved During the non-transactional phase of the commit, events are fired to the calling client application, at which point, the application may still decide to overwrite earlier decisions such as ignoring certain files, force checking in others, checking in from a different stream, etc. Usage CheckinManager cm = myView.createCheckinManager(); cm.checkin(file1); cm.checkinFrom(file2, new java.io.File("c://myprojects//myworkspace//file2.txt"); cm.delete(file3); cm.move(file4, myView.getRootFolder()); if (cm.canCommit()) cm.commit();

For a list of all members of this type, see CheckinManager Members.

System.Object
CheckinManager

public class CheckinManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckinManager Members | StarTeam Namespace


CheckinManager Members

CheckinManager overview

Public Instance Properties

ChangePackage | [read] the Change Package created as the outcome of this checkin operation
ExternalCreatedBy | [read/write] The external Created By User name describing the committer of the changeset.
IsCanceled | [read] true if pending checkin operations have been canceled, and false otherwise.
IsRunning | [read] true if there is currently a checkin operation in progress, and false otherwise.
Name | [read/write] the name of the ChangePackage
Options | [read/write] The checkin options currently in effect.
PostCommitViewLabelName | [read/write] The name of the post-commit view label.
ProgressValue | [read] A snapshot of the state of the current checkin operation.
View | [read] the View

Public Instance Methods

BytesTransferred |
CanCommit | returns true if the session can be committed For the session to be in a commit-able state, all files being checked in should be in a relevant state, e.g. NEW or MODIFIED, or else the ForceCheckin option should be specified
Checkin | Overloaded. Checks in a single file from the default location. The file is checked in on commit. Creates a copy of the global options. Subsequent changes to global options do not affect this file
CheckinFrom | Overloaded.
Commit | Overloaded. Commit all the changes to the repository This is an atomic operation running in the context of a ConnectionPool
Equals | Delegate Equals() to com.starteam.CheckinManager.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinManager.
GetType (inherited from Object) | Gets the Type of the current instance.
HasCheckinListeners | Returns true if there is at least one registered listener for checkin events
Ignore | Remove this item from consideration for the commit If the item was to be checked in, it will not be checked in if it was to be deleted, it will not be deleted, if it was to be moved, it will not be moved If the item is a folder, then all child items, descendant folders and child items of descendant folders will be removed from consideration
MoveTo | Move an item from it's current parent folder to the folder specified The specified folder may or may not be a folder in the same view as the item is in, but must be in the same view as the CheckinManager is operating in. The specified folder must exist in the repository, i.e. it should not be deleted. The folder must also be a different folder from the item's current parent folder
NewCheckinEventSource |
Remove | Remove an item from the repository. The item is removed on commit if the item is a folder, remove the folder and all contained items of all types from the repository. If the folder contains sub-folders, the sub-folders and their contained items are all removed from the repository
SetBehavior | Changes the behavior of an item in a transaction.
SetCanceled | Cancels any pending checkin operations.
ShareTo | Share an item from it's current parent folder to the folder specified. The specified folder may (or may not) be a folder in the same view as the item is in, but must be in the view the CheckinManager is operating in. The specified folder must exist in the repository, i.e. it should not be deleted. The folder must also be a different folder from the item's current parent folder
Size | returns a count of the amount of work to be done by this manager
ToString | Delegate ToString() to com.starteam.CheckinManager.
Update | Update an Item in the repository. The update occurs on commit Note that the item may be new or dirty.

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager Properties

The properties of the CheckinManager class are listed below. For a complete list of CheckinManager class members, see the CheckinManager Members topic.

Public Instance Properties

ChangePackage | [read] the Change Package created as the outcome of this checkin operation
ExternalCreatedBy | [read/write] The external Created By User name describing the committer of the changeset.
IsCanceled | [read] true if pending checkin operations have been canceled, and false otherwise.
IsRunning | [read] true if there is currently a checkin operation in progress, and false otherwise.
Name | [read/write] the name of the ChangePackage
Options | [read/write] The checkin options currently in effect.
PostCommitViewLabelName | [read/write] The name of the post-commit view label.
ProgressValue | [read] A snapshot of the state of the current checkin operation.
View | [read] the View

See Also

CheckinManager Class | StarTeam Namespace


ChangePackage Property

Borland StarTeam SDK for .NET

CheckinManager.ChangePackage Property

[read] the Change Package created as the outcome of this checkin operation

public virtual ChangePackage ChangePackage {get;}

Property Value

the Change Package created as the outcome of this checkin operation

See Also

CheckinManager Class | StarTeam Namespace


ExternalCreatedBy Property

Borland StarTeam SDK for .NET

CheckinManager.ExternalCreatedBy Property

[read/write] The external Created By User name describing the committer of the changeset.

public virtual String ExternalCreatedBy {get; set;}

Property Value

The external Created By User name describing the committer of the changeset.

See Also

CheckinManager Class | StarTeam Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CheckinManager.IsCanceled Property

[read] true if pending checkin operations have been canceled, and false otherwise.

public virtual Boolean IsCanceled {get;}

Property Value

true if pending checkin operations have been canceled, and false otherwise.

See Also

CheckinManager Class | StarTeam Namespace


IsRunning Property

Borland StarTeam SDK for .NET

CheckinManager.IsRunning Property

[read] true if there is currently a checkin operation in progress, and false otherwise.

public virtual Boolean IsRunning {get;}

Property Value

true if there is currently a checkin operation in progress, and false otherwise.

See Also

CheckinManager Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

CheckinManager.Name Property

[read/write] the name of the ChangePackage

public virtual String Name {get; set;}

Property Value

the name of the ChangePackage

See Also

CheckinManager Class | StarTeam Namespace


Options Property

Borland StarTeam SDK for .NET

CheckinManager.Options Property

[read/write] The checkin options currently in effect.

public virtual CheckinOptions Options {get; set;}

Property Value

The checkin options currently in effect.

See Also

CheckinManager Class | StarTeam Namespace


PostCommitViewLabelName Property

Borland StarTeam SDK for .NET

CheckinManager.PostCommitViewLabelName Property

[read/write] The name of the post-commit view label.

public virtual String PostCommitViewLabelName {get; set;}

Property Value

The name of the post-commit view label.

See Also

CheckinManager Class | StarTeam Namespace


ProgressValue Property

Borland StarTeam SDK for .NET

CheckinManager.ProgressValue Property

[read] A snapshot of the state of the current checkin operation.

public virtual CheckinManager.Progress ProgressValue {get;}

Property Value

A snapshot of the state of the current checkin operation.

See Also

CheckinManager Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

CheckinManager.View Property

[read] the View

public virtual View View {get;}

Property Value

the View

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager Methods

The methods of the CheckinManager class are listed below. For a complete list of CheckinManager class members, see the CheckinManager Members topic.

Public Instance Methods

BytesTransferred |
CanCommit | returns true if the session can be committed For the session to be in a commit-able state, all files being checked in should be in a relevant state, e.g. NEW or MODIFIED, or else the ForceCheckin option should be specified
Checkin | Overloaded. Checks in a single file from the default location. The file is checked in on commit. Creates a copy of the global options. Subsequent changes to global options do not affect this file
CheckinFrom | Overloaded.
Commit | Overloaded. Commit all the changes to the repository This is an atomic operation running in the context of a ConnectionPool
Equals | Delegate Equals() to com.starteam.CheckinManager.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinManager.
GetType (inherited from Object) | Gets the Type of the current instance.
HasCheckinListeners | Returns true if there is at least one registered listener for checkin events
Ignore | Remove this item from consideration for the commit If the item was to be checked in, it will not be checked in if it was to be deleted, it will not be deleted, if it was to be moved, it will not be moved If the item is a folder, then all child items, descendant folders and child items of descendant folders will be removed from consideration
MoveTo | Move an item from it's current parent folder to the folder specified The specified folder may or may not be a folder in the same view as the item is in, but must be in the same view as the CheckinManager is operating in. The specified folder must exist in the repository, i.e. it should not be deleted. The folder must also be a different folder from the item's current parent folder
NewCheckinEventSource |
Remove | Remove an item from the repository. The item is removed on commit if the item is a folder, remove the folder and all contained items of all types from the repository. If the folder contains sub-folders, the sub-folders and their contained items are all removed from the repository
SetBehavior | Changes the behavior of an item in a transaction.
SetCanceled | Cancels any pending checkin operations.
ShareTo | Share an item from it's current parent folder to the folder specified. The specified folder may (or may not) be a folder in the same view as the item is in, but must be in the view the CheckinManager is operating in. The specified folder must exist in the repository, i.e. it should not be deleted. The folder must also be a different folder from the item's current parent folder
Size | returns a count of the amount of work to be done by this manager
ToString | Delegate ToString() to com.starteam.CheckinManager.
Update | Update an Item in the repository. The update occurs on commit Note that the item may be new or dirty.

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.BytesTransferred Method

public virtual bool BytesTransferred(
Int32 bytes
);

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.CanCommit Method

returns true if the session can be committed For the session to be in a commit-able state, all files being checked in should be in a relevant state, e.g. NEW or MODIFIED, or else the ForceCheckin option should be specified

public virtual bool CanCommit();

Return Value

true if the session can be committed

See Also

CheckinManager Class | StarTeam Namespace


Checkin Method

Borland StarTeam SDK for .NET

CheckinManager.Checkin Method

Checks in a single file from the default location. The file is checked in on commit. Creates a copy of the global options. Subsequent changes to global options do not affect this file

Overload List

Checks in a single file from the default location. The file is checked in on commit. Creates a copy of the global options. Subsequent changes to global options do not affect this file

public virtual void Checkin(File);

Checks in a file with the specified set of options. The file is checked in on commit

public virtual void Checkin(File,CheckinOptions);

Checks in the given set of files. The files are checked in on commit If any of the files are new, they are added to the repository. If some of the files are parented in new folders, then those folders are created in the repository. Creates a copy of the global options. Subsequent changes to global options do not affect these files

public virtual void Checkin(File[]);

Checks in all the files in the given folder. The files are checked in on commit. If this folder is new, i.e. it does not exist in the repository, it is created in the repository Creates a copy of the global options. Subsequent changes to global options do not affect this folder and its files

public virtual void Checkin(Folder);

Checks in all the files in the given folder, and in all sub-folders to the given depth. If not in view folders have been included, then these folders will be created in the repository The files are checked in on commit. Creates a copy of the global options. Subsequent changes to global options do not affect these folders and their files

public virtual void Checkin(Folder,Int32);

See Also

CheckinManager Class | StarTeam Namespace | commit


CheckinManager.Checkin Method (File)

Checks in a single file from the default location. The file is checked in on commit. Creates a copy of the global options. Subsequent changes to global options do not affect this file

public virtual void Checkin(
File starTeamFile
);

Parameters

starTeamFile
The file to be checked in.

See Also

CheckinManager Class | StarTeam Namespace | CheckinManager.Checkin Overload List | commit


CheckinManager.Checkin Method (File, CheckinOptions)

Checks in a file with the specified set of options. The file is checked in on commit

public virtual void Checkin(
File starTeamFile,
CheckinOptions options
);

Parameters

starTeamFile
The file to checkin
options
the checkin options to use. These options override the default options assigned when this checkin manager was created.

See Also

CheckinManager Class | StarTeam Namespace | CheckinManager.Checkin Overload List | commit


CheckinManager.Checkin Method (File[])

Checks in the given set of files. The files are checked in on commit If any of the files are new, they are added to the repository. If some of the files are parented in new folders, then those folders are created in the repository. Creates a copy of the global options. Subsequent changes to global options do not affect these files

public virtual void Checkin(
File[] files
);

Parameters

files
The files to be checked in.

See Also

CheckinManager Class | StarTeam Namespace | CheckinManager.Checkin Overload List | commit | getItems


CheckinManager.Checkin Method (Folder)

Checks in all the files in the given folder. The files are checked in on commit. If this folder is new, i.e. it does not exist in the repository, it is created in the repository Creates a copy of the global options. Subsequent changes to global options do not affect this folder and its files

public virtual void Checkin(
Folder folder
);

Parameters

folder
The StarTeam folder whose files are to be checked in.

See Also

CheckinManager Class | StarTeam Namespace | CheckinManager.Checkin Overload List | commit | Folder | checkin


CheckinManager.Checkin Method (Folder, Int32)

Checks in all the files in the given folder, and in all sub-folders to the given depth. If not in view folders have been included, then these folders will be created in the repository The files are checked in on commit. Creates a copy of the global options. Subsequent changes to global options do not affect these folders and their files

public virtual void Checkin(
Folder folder,
Int32 depth
);

Parameters

folder
The StarTeam folder whose files are to be checked in.
depth
Indicates which sub-folders also contain files to be checked in. Zero indicates that no sub-folders should be included; 1 indicates that this folder and its immediate child folders should be included; -1 indicates that this folder and all child folders at any depth should be included. -2 indicates that only this folder will be included, without any of it's containing files or sub-folders if depth == -2, it is expected that the folder being checked in is a not-in-view folder

See Also

CheckinManager Class | StarTeam Namespace | CheckinManager.Checkin Overload List | commit


CheckinFrom Method

Borland StarTeam SDK for .NET

CheckinManager.CheckinFrom Method

Checks in a file in the context of the specified starTeam File Object. The file is checked in on commit. from the specified file system disk file Creates a copy of the global options. Subsequent changes to global options do not affect this file

Overload List

Checks in a file in the context of the specified starTeam File Object. The file is checked in on commit. from the specified file system disk file Creates a copy of the global options. Subsequent changes to global options do not affect this file

public virtual void CheckinFrom(File,FileInfo);

public virtual void CheckinFrom(File,Stream);

See Also

CheckinManager Class | StarTeam Namespace | commit


CheckinManager.CheckinFrom Method (File, FileInfo)

Checks in a file in the context of the specified starTeam File Object. The file is checked in on commit. from the specified file system disk file Creates a copy of the global options. Subsequent changes to global options do not affect this file

public virtual void CheckinFrom(
File starTeamFile,
FileInfo diskFile
);

Parameters

starTeamFile
File a starTeam File Object instance
diskFile
java.io.File the working file on disk to checkin from

See Also

CheckinManager Class | StarTeam Namespace | CheckinManager.CheckinFrom Overload List | commit


CheckinManager.CheckinFrom Method (File, Stream)

public virtual void CheckinFrom(
File starTeamFile,
Stream stream
);

See Also

CheckinManager Class | StarTeam Namespace | CheckinManager.CheckinFrom Overload List


Commit Method

Borland StarTeam SDK for .NET

CheckinManager.Commit Method

Commit all the changes to the repository

Overload List

Commit all the changes to the repository

public virtual void Commit();

Commit all the changes to the repository This is an atomic operation running in the context of a ConnectionPool

public virtual void Commit(ConnectionPool,User);

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.Commit Method ()

Commit all the changes to the repository

public virtual void Commit();

See Also

CheckinManager Class | StarTeam Namespace | CheckinManager.Commit Overload List


CheckinManager.Commit Method (ConnectionPool, User)

Commit all the changes to the repository This is an atomic operation running in the context of a ConnectionPool

public virtual void Commit(
ConnectionPool cp,
User u
);

Parameters

cp
the connection pool
u
the user t impersonate

See Also

CheckinManager Class | StarTeam Namespace | CheckinManager.Commit Overload List | CheckinManager


CheckinManager.Equals Method

Delegate Equals() to com.starteam.CheckinManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckinManager.Equals(obj).

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckinManager.

public override int GetHashCode();

Return Value

com.starteam.CheckinManager.GetHashCode().

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.HasCheckinListeners Method

Returns true if there is at least one registered listener for checkin events

public virtual bool HasCheckinListeners();

Return Value

boolean true if there is at least one registered listener for checkin events

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.Ignore Method

Remove this item from consideration for the commit If the item was to be checked in, it will not be checked in if it was to be deleted, it will not be deleted, if it was to be moved, it will not be moved If the item is a folder, then all child items, descendant folders and child items of descendant folders will be removed from consideration

public virtual void Ignore(
Item starTeamItem
);

Parameters

starTeamItem

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.MoveTo Method

Move an item from it's current parent folder to the folder specified The specified folder may or may not be a folder in the same view as the item is in, but must be in the same view as the CheckinManager is operating in. The specified folder must exist in the repository, i.e. it should not be deleted. The folder must also be a different folder from the item's current parent folder

public virtual void MoveTo(
Item starTeamItem,
Folder toFolder,
Boolean moveLocal
);

Parameters

starTeamItem
the item to move to a different folder in the repository
toFolder
the folder to move the item to.
moveLocal
if the item is a File, move the local disk file on the file system too

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.NewCheckinEventSource Method

public CheckinEventSource NewCheckinEventSource();

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.Remove Method

Remove an item from the repository. The item is removed on commit if the item is a folder, remove the folder and all contained items of all types from the repository. If the folder contains sub-folders, the sub-folders and their contained items are all removed from the repository

public virtual void Remove(
Item starTeamItem,
Boolean deleteLocal
);

Parameters

starTeamItem
The starTeam item to remove
deleteLocal
if true, and if the item is a file, then delete the local working file

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.SetBehavior Method

Changes the behavior of an item in a transaction.

public virtual void SetBehavior(
Item starTeamItem,
ViewMemberBehavior behavior
);

Parameters

starTeamItem
StarTeam item to update behavior.
behavior
new behavior of the item.

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.SetCanceled Method

Cancels any pending checkin operations.

public virtual void SetCanceled();

See Also

CheckinManager Class | StarTeam Namespace | isCanceled


CheckinManager.ShareTo Method

Share an item from it's current parent folder to the folder specified. The specified folder may (or may not) be a folder in the same view as the item is in, but must be in the view the CheckinManager is operating in. The specified folder must exist in the repository, i.e. it should not be deleted. The folder must also be a different folder from the item's current parent folder

public virtual void ShareTo(
Item starTeamItem,
Folder toFolder
);

Parameters

starTeamItem
the item to move to a different folder in the repository
toFolder
the folder to share the item to.

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.Size Method

returns a count of the amount of work to be done by this manager

public virtual long Size();

Return Value

a count of the amount of work to be done by this manager

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.ToString Method

Delegate ToString() to com.starteam.CheckinManager.

public override string ToString();

Return Value

com.starteam.CheckinManager.ToString()

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.Update Method

Update an Item in the repository. The update occurs on commit Note that the item may be new or dirty.

public virtual void Update(
Item starTeamItem
);

Parameters

starTeamItem
the item to update

See Also

CheckinManager Class | StarTeam Namespace


CheckinManager.Progress Class

Information on the progress of a checkin operation from CheckinManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckinManager.getProgress().

For a list of all members of this type, see CheckinManager.Progress Members.

System.Object
CheckinManager.Progress

public class CheckinManager.Progress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckinManager.Progress Members | StarTeam Namespace


CheckinManager.Progress Members

CheckinManager.Progress overview

Public Instance Properties

CurrentPhase | [read] the Phase associated with this Progress.
CurrentPhaseEstimatedTimeRemaining | [read] the estimated time remaining in milliseconds.
CurrentPhaseUnitsOfWork | [read] Return the total number of units of work.
CurrentPhaseUnitsOfWorkProcessed | [read] the number of units of work that has been processed in this phase.
CurrentPhaseUnitsOfWorkRemaining | [read] Return the total number of units of work that are yet to be done.
CurrentStarteamItem | [read] Return the current StarTeam Item that's being processed in the current phase.
CurrentWorkingFile | [read] the current File object that's being checked in in the specified thread ID.
Description | [read] description of the current state of progress of CheckinManager.
IsInTransaction | [read] true if the transaction has begun for this checkin
LastError |
SnapshotTime | [read] DateTime the snapshot time that is set when the last clone was created.
TotalBytesCheckedIn | [read] the total number of bytes that are checked in.
TotalFilesCheckedIn | [read] the number of files that have been checked in.
TotalFilesFailed | [read] Return the files that failed during checkin.
TotalFilesForCheckin | [read] the total number of files for checkin.
TotalFilesProcessed | [read] the total number of files processed.
TotalFilesRemaining | [read] the number of files remaining to be checked in.
TotalFilesSkipped | [read] the total number of files skipped without being checked in.
TotalTimeSpent | [read] Return the total time spent so far (in milliseconds).

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckinManager.Progress.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinManager.Progress.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckinManager.Progress.

See Also

CheckinManager.Progress Class | StarTeam Namespace


CheckinManager.Progress Properties

The properties of the CheckinManager.Progress class are listed below. For a complete list of CheckinManager.Progress class members, see the CheckinManager.Progress Members topic.

Public Instance Properties

CurrentPhase | [read] the Phase associated with this Progress.
CurrentPhaseEstimatedTimeRemaining | [read] the estimated time remaining in milliseconds.
CurrentPhaseUnitsOfWork | [read] Return the total number of units of work.
CurrentPhaseUnitsOfWorkProcessed | [read] the number of units of work that has been processed in this phase.
CurrentPhaseUnitsOfWorkRemaining | [read] Return the total number of units of work that are yet to be done.
CurrentStarteamItem | [read] Return the current StarTeam Item that's being processed in the current phase.
CurrentWorkingFile | [read] the current File object that's being checked in in the specified thread ID.
Description | [read] description of the current state of progress of CheckinManager.
IsInTransaction | [read] true if the transaction has begun for this checkin
LastError |
SnapshotTime | [read] DateTime the snapshot time that is set when the last clone was created.
TotalBytesCheckedIn | [read] the total number of bytes that are checked in.
TotalFilesCheckedIn | [read] the number of files that have been checked in.
TotalFilesFailed | [read] Return the files that failed during checkin.
TotalFilesForCheckin | [read] the total number of files for checkin.
TotalFilesProcessed | [read] the total number of files processed.
TotalFilesRemaining | [read] the number of files remaining to be checked in.
TotalFilesSkipped | [read] the total number of files skipped without being checked in.
TotalTimeSpent | [read] Return the total time spent so far (in milliseconds).

See Also

CheckinManager.Progress Class | StarTeam Namespace


CurrentPhase Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.CurrentPhase Property

[read] the Phase associated with this Progress.

public virtual CheckinManager.Progress.Phase CurrentPhase {get;}

Property Value

the Phase associated with this Progress.

See Also

CheckinManager.Progress Class | StarTeam Namespace


CurrentPhaseEstimatedTimeRemaining Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.CurrentPhaseEstimatedTimeRemaining Property

[read] the estimated time remaining in milliseconds.

public virtual Int64 CurrentPhaseEstimatedTimeRemaining {get;}

Property Value

the estimated time remaining in milliseconds.

See Also

CheckinManager.Progress Class | StarTeam Namespace


CurrentPhaseUnitsOfWork Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.CurrentPhaseUnitsOfWork Property

[read] Return the total number of units of work.

public virtual Int64 CurrentPhaseUnitsOfWork {get;}

Property Value

Return the total number of units of work.

See Also

CheckinManager.Progress Class | StarTeam Namespace


CurrentPhaseUnitsOfWorkProcessed Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.CurrentPhaseUnitsOfWorkProcessed Property

[read] the number of units of work that has been processed in this phase.

public virtual Int64 CurrentPhaseUnitsOfWorkProcessed {get;}

Property Value

the number of units of work that has been processed in this phase.

See Also

CheckinManager.Progress Class | StarTeam Namespace


CurrentPhaseUnitsOfWorkRemaining Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.CurrentPhaseUnitsOfWorkRemaining Property

[read] Return the total number of units of work that are yet to be done.

public virtual Int64 CurrentPhaseUnitsOfWorkRemaining {get;}

Property Value

Return the total number of units of work that are yet to be done.

See Also

CheckinManager.Progress Class | StarTeam Namespace


CurrentStarteamItem Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.CurrentStarteamItem Property

[read] Return the current StarTeam Item that's being processed in the current phase.

public virtual Item CurrentStarteamItem {get;}

Property Value

Return the current StarTeam Item that's being processed in the current phase.

See Also

CheckinManager.Progress Class | StarTeam Namespace


CurrentWorkingFile Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.CurrentWorkingFile Property

[read] the current File object that's being checked in in the specified thread ID.

public virtual FileInfo CurrentWorkingFile {get;}

Property Value

the current File object that's being checked in in the specified thread ID.

See Also

CheckinManager.Progress Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.Description Property

[read] description of the current state of progress of CheckinManager.

public virtual String Description {get;}

Property Value

description of the current state of progress of CheckinManager.

See Also

CheckinManager.Progress Class | StarTeam Namespace


IsInTransaction Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.IsInTransaction Property

[read] true if the transaction has begun for this checkin

public virtual Boolean IsInTransaction {get;}

Property Value

true if the transaction has begun for this checkin

See Also

CheckinManager.Progress Class | StarTeam Namespace


LastError Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.LastError Property

public virtual Exception LastError {get;}

See Also

CheckinManager.Progress Class | StarTeam Namespace


SnapshotTime Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.SnapshotTime Property

[read] DateTime the snapshot time that is set when the last clone was created.

public virtual DateTime SnapshotTime {get;}

Property Value

DateTime the snapshot time that is set when the last clone was created.

See Also

CheckinManager.Progress Class | StarTeam Namespace


TotalBytesCheckedIn Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.TotalBytesCheckedIn Property

[read] the total number of bytes that are checked in.

public virtual Int64 TotalBytesCheckedIn {get;}

Property Value

the total number of bytes that are checked in.

See Also

CheckinManager.Progress Class | StarTeam Namespace


TotalFilesCheckedIn Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.TotalFilesCheckedIn Property

[read] the number of files that have been checked in.

public virtual Int64 TotalFilesCheckedIn {get;}

Property Value

the number of files that have been checked in.

See Also

CheckinManager.Progress Class | StarTeam Namespace


TotalFilesFailed Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.TotalFilesFailed Property

[read] Return the files that failed during checkin.

public virtual Int64 TotalFilesFailed {get;}

Property Value

Return the files that failed during checkin.

See Also

CheckinManager.Progress Class | StarTeam Namespace


TotalFilesForCheckin Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.TotalFilesForCheckin Property

[read] the total number of files for checkin.

public virtual Int64 TotalFilesForCheckin {get;}

Property Value

the total number of files for checkin.

See Also

CheckinManager.Progress Class | StarTeam Namespace


TotalFilesProcessed Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.TotalFilesProcessed Property

[read] the total number of files processed.

public virtual Int64 TotalFilesProcessed {get;}

Property Value

the total number of files processed.

See Also

CheckinManager.Progress Class | StarTeam Namespace


TotalFilesRemaining Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.TotalFilesRemaining Property

[read] the number of files remaining to be checked in.

public virtual Int64 TotalFilesRemaining {get;}

Property Value

the number of files remaining to be checked in.

See Also

CheckinManager.Progress Class | StarTeam Namespace


TotalFilesSkipped Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.TotalFilesSkipped Property

[read] the total number of files skipped without being checked in.

public virtual Int64 TotalFilesSkipped {get;}

Property Value

the total number of files skipped without being checked in.

See Also

CheckinManager.Progress Class | StarTeam Namespace


TotalTimeSpent Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.TotalTimeSpent Property

[read] Return the total time spent so far (in milliseconds).

public virtual Int64 TotalTimeSpent {get;}

Property Value

Return the total time spent so far (in milliseconds).

See Also

CheckinManager.Progress Class | StarTeam Namespace


CheckinManager.Progress Methods

The methods of the CheckinManager.Progress class are listed below. For a complete list of CheckinManager.Progress class members, see the CheckinManager.Progress Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckinManager.Progress.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinManager.Progress.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckinManager.Progress.

See Also

CheckinManager.Progress Class | StarTeam Namespace


CheckinManager.Progress.Equals Method

Delegate Equals() to com.starteam.CheckinManager.Progress.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckinManager.Progress.Equals(obj).

See Also

CheckinManager.Progress Class | StarTeam Namespace


CheckinManager.Progress.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckinManager.Progress.

public override int GetHashCode();

Return Value

com.starteam.CheckinManager.Progress.GetHashCode().

See Also

CheckinManager.Progress Class | StarTeam Namespace


CheckinManager.Progress.ToString Method

Delegate ToString() to com.starteam.CheckinManager.Progress.

public override string ToString();

Return Value

com.starteam.CheckinManager.Progress.ToString()

See Also

CheckinManager.Progress Class | StarTeam Namespace


CheckinManager.Progress.Phase Class

Information on the phase of a checkin progress of the checkin operation from CheckinManager.

For a list of all members of this type, see CheckinManager.Progress.Phase Members.

System.Object
CheckinManager.Progress.Phase

public class CheckinManager.Progress.Phase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckinManager.Progress.Phase Members | StarTeam Namespace


CheckinManager.Progress.Phase Members

CheckinManager.Progress.Phase overview

Public Static Properties

ABORTING_CHANGES
CANCELED
COMMITTING_CHANGES
LINKING
POST_PROCESSING
PRE_PROCESSING
UPLOADING_CONTENT

Public Instance Properties

Name [read] Return the name of this Phase.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckinManager.Progress.Phase.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinManager.Progress.Phase.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckinManager.Progress.Phase.

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


CheckinManager.Progress.Phase Properties

The properties of the CheckinManager.Progress.Phase class are listed below. For a complete list of CheckinManager.Progress.Phase class members, see the CheckinManager.Progress.Phase Members topic.

Public Static Properties

ABORTING_CHANGES
CANCELED
COMMITTING_CHANGES
LINKING
POST_PROCESSING
PRE_PROCESSING
UPLOADING_CONTENT

Public Instance Properties

Name [read] Return the name of this Phase.

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


ABORTING_CHANGES Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.Phase.ABORTING_CHANGES Property

public static CheckinManager.Progress.Phase ABORTING_CHANGES {get;}

Property Value

The Aborting Phase

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


CANCELED Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.Phase.CANCELED Property

public static CheckinManager.Progress.Phase CANCELED {get;}

Property Value

The Canceled Phase

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


COMMITTING_CHANGES Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.Phase.COMMITTING_CHANGES Property

public static CheckinManager.Progress.Phase COMMITTING_CHANGES {get;}

Property Value

The Committing Change Phase

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


LINKING Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.Phase.LINKING Property

public static CheckinManager.Progress.Phase LINKING {get;}

Property Value

The Linking Phase

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.Phase.Name Property

[read] Return the name of this Phase.

public virtual String Name {get;}

Property Value

Return the name of this Phase.

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


POST_PROCESSING Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.Phase.POST_PROCESSING Property

public static CheckinManager.Progress.Phase POST_PROCESSING {get;}

Property Value

The Post Processing Phase

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


PRE_PROCESSING Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.Phase.PRE_PROCESSING Property

public static CheckinManager.Progress.Phase PRE_PROCESSING {get;}

Property Value

The Pre rocessing Phase

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


UPLOADING_CONTENT Property

Borland StarTeam SDK for .NET

CheckinManager.Progress.Phase.UPLOADING_CONTENT Property

public static CheckinManager.Progress.Phase UPLOADING_CONTENT {get;}

Property Value

The Uploading Content Phase

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


CheckinManager.Progress.Phase Methods

The methods of the CheckinManager.Progress.Phase class are listed below. For a complete list of CheckinManager.Progress.Phase class members, see the CheckinManager.Progress.Phase Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckinManager.Progress.Phase.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinManager.Progress.Phase.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckinManager.Progress.Phase.

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


CheckinManager.Progress.Phase.Equals Method

Delegate Equals() to com.starteam.CheckinManager.Progress.Phase.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckinManager.Progress.Phase.Equals(obj).

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


CheckinManager.Progress.Phase.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckinManager.Progress.Phase.

public override int GetHashCode();

Return Value

com.starteam.CheckinManager.Progress.Phase.GetHashCode().

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


CheckinManager.Progress.Phase.ToString Method

Delegate ToString() to com.starteam.CheckinManager.Progress.Phase.

public override string ToString();

Return Value

com.starteam.CheckinManager.Progress.Phase.ToString()

See Also

CheckinManager.Progress.Phase Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager Class

Checkin Manager accessor for cached SDK items Contained objects are obtained from the artifact cache a Change Package is created on commit, pursuant to server settings CheckinManager instances are considered stale after commit

For a list of all members of this type, see CheckinManager.WebCacheCheckinManager Members.

System.Object
CheckinManager.WebCacheCheckinManager

public class CheckinManager.WebCacheCheckinManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckinManager.WebCacheCheckinManager Members | StarTeam Namespace


CheckinManager.WebCacheCheckinManager Members

CheckinManager.WebCacheCheckinManager overview

Public Instance Properties

ChangePackage | [read] the Change Package created as the outcome of this checkin operation
Name | [write] Sets the name of the ChangePackage for this session.
Options | [read] the options associated with this checkin manager
View | [read] the View

Public Instance Methods

CanCommit | return true if this checkin can be committed
CheckinFrom | Overloaded.
Commit | commit the changes and return the results.
Equals | Delegate Equals() to com.starteam.CheckinManager.WebCacheCheckinManager.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinManager.WebCacheCheckinManager.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveTo |
NewWebCacheCheckinEventSource |
Remove |
ToString | Delegate ToString() to com.starteam.CheckinManager.WebCacheCheckinManager.
Update |

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager Properties

The properties of the CheckinManager.WebCacheCheckinManager class are listed below. For a complete list of CheckinManager.WebCacheCheckinManager class members, see the CheckinManager.WebCacheCheckinManager Members topic.

Public Instance Properties

ChangePackage | [read] the Change Package created as the outcome of this checkin operation
Name | [write] Sets the name of the ChangePackage for this session.
Options | [read] the options associated with this checkin manager
View | [read] the View

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


ChangePackage Property

Borland StarTeam SDK for .NET

CheckinManager.WebCacheCheckinManager.ChangePackage Property

[read] the Change Package created as the outcome of this checkin operation

public virtual ChangePackage.WebCacheChangePackage ChangePackage {get;}

Property Value

the Change Package created as the outcome of this checkin operation

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

CheckinManager.WebCacheCheckinManager.Name Property

[write] Sets the name of the ChangePackage for this session.

public virtual String Name {set;}

Property Value

Sets the name of the ChangePackage for this session.

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


Options Property

Borland StarTeam SDK for .NET

CheckinManager.WebCacheCheckinManager.Options Property

[read] the options associated with this checkin manager

public virtual CheckinOptions.WebCacheCheckinOptions Options {get;}

Property Value

the options associated with this checkin manager

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

CheckinManager.WebCacheCheckinManager.View Property

[read] the View

public virtual View.WebCacheView View {get;}

Property Value

the View

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager Methods

The methods of the CheckinManager.WebCacheCheckinManager class are listed below. For a complete list of CheckinManager.WebCacheCheckinManager class members, see the CheckinManager.WebCacheCheckinManager Members topic.

Public Instance Methods

CanCommit | return true if this checkin can be committed
CheckinFrom | Overloaded.
Commit | commit the changes and return the results.
Equals | Delegate Equals() to com.starteam.CheckinManager.WebCacheCheckinManager.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinManager.WebCacheCheckinManager.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveTo |
NewWebCacheCheckinEventSource |
Remove |
ToString | Delegate ToString() to com.starteam.CheckinManager.WebCacheCheckinManager.
Update |

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager.CanCommit Method

return true if this checkin can be committed

public virtual bool CanCommit();

Return Value

true if this checkin can be committed

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinFrom Method

Borland StarTeam SDK for .NET

CheckinManager.WebCacheCheckinManager.CheckinFrom Method

Overload List

public virtual void CheckinFrom(File.WebCacheFile,FileInfo);

public virtual void CheckinFrom(File.WebCacheFile,Stream);

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager.CheckinFrom Method (File#WebCacheFile, FileInfo)

public virtual void CheckinFrom(
File.WebCacheFile starTeamFile,
FileInfo diskFile
);

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace | CheckinManager.WebCacheCheckinManager.CheckinFrom Overload List


CheckinManager.WebCacheCheckinManager.CheckinFrom Method (File#WebCacheFile, Stream)

public virtual void CheckinFrom(
File.WebCacheFile starTeamFile,
Stream stream
);

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace | CheckinManager.WebCacheCheckinManager.CheckinFrom Overload List


CheckinManager.WebCacheCheckinManager.Commit Method

commit the changes and return the results.

public virtual WebCacheFile[] Commit();

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager.Equals Method

Delegate Equals() to com.starteam.CheckinManager.WebCacheCheckinManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckinManager.WebCacheCheckinManager.Equals(obj).

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckinManager.WebCacheCheckinManager.

public override int GetHashCode();

Return Value

com.starteam.CheckinManager.WebCacheCheckinManager.GetHashCode().

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager.MoveTo Method

public virtual void MoveTo(
Item.WebCacheItem starTeamItem,
Folder.WebCacheFolder toFolder
);

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager.NewWebCacheCheckinEventSource Method

public WebCacheCheckinEventSource NewWebCacheCheckinEventSource();

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager.Remove Method

public virtual void Remove(
Item.WebCacheItem starTeamItem
);

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager.ToString Method

Delegate ToString() to com.starteam.CheckinManager.WebCacheCheckinManager.

public override string ToString();

Return Value

com.starteam.CheckinManager.WebCacheCheckinManager.ToString()

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinManager.WebCacheCheckinManager.Update Method

public virtual void Update(
Item.WebCacheItem starTeamItem
);

See Also

CheckinManager.WebCacheCheckinManager Class | StarTeam Namespace


CheckinOptions Class

Maintains the checkin options used by CheckinManager.

For a list of all members of this type, see CheckinOptions Members.

System.Object
CheckinOptions

public class CheckinOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckinOptions Members | StarTeam Namespace


CheckinOptions Members

CheckinOptions overview

Public Instance Constructors

CheckinOptions Overloaded. Initializes a new instance of the CheckinOptions class.

Public Instance Properties

AttachNewLabelsOnly | [read/write] true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.
BreakLock | [read/write] true if another users lock will be broken during checkin
BuildLabel | [read/write] the build label to attach.
ChangePackageName | [read/write] the name of the change package
CharacterSetValue | [read/write] the character set to be used for this file.
CheckinReason | [read/write] the "Checkin Reason" option value.
CRsToMarkFixed | [read/write] ChangeRequests to mark fixed; an empty array, if none are specified.
DeleteWorkingFile | [read/write] true if "Delete Working File" option is set; false, otherwise.
EnforceGatedCheckin | [read/write]
EOLFormatValue | [read/write] the EOL Format to be used for this file
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
ForceCheckin | [read/write] Returns true if "Force Checkin" option is set; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking in files or the file associated with this CheckinOptions object.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LastChangePackageID | [read/write] the last known 'good' Change Package ID processed by the client
LockTypeValue | [read/write] the type of lock to be used when checking in, one of the values supported by ViewMember.LockType.
MarkProcessItemComplete | [read/write] true if the associated process item is to be marked complete; false, otherwise.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
PinProcessItem | [read/write] Returns true if the process item link endpoint will be pinned; false, otherwise.
ProcessItem | [read/write] the process item to link and pin.
RestoreFileOnError | [read/write] True if the previous working file should be restored if an error occurs during a checkin; otherwise, false.
RevisionLabel | [read/write] the revision label to attach.
UpdateExistingLinks | [read/write] Returns true if "Update Existing Links" option is set; false, otherwise.
UpdateStatus | [read/write] true if status information is to be updated after a successful checkin.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckinOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckinOptions.

See Also

CheckinOptions Class | StarTeam Namespace


CheckinOptions Constructor

Construct a CheckinOptions object with default options from the View.

Overload List

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(CheckinOptions);

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(StarTeamClientOptions);

Construct a CheckinOptions object with default options from the View.

public CheckinOptions(View);

See Also

CheckinOptions Class | StarTeam Namespace | getKeywordExpansionEnabled | setKeywordExpansionEnabled | getMarkProcessItemComplete | setMarkProcessItemComplete | getAttachNewLabelsOnly | setAttachNewLabelsOnly | getFileEncoding | setFileEncoding | getOptions | View


CheckinOptions Constructor (View)

Construct a CheckinOptions object with default options from the View.

public CheckinOptions(
View view
);

Parameters

view
a View object where the values of the options are picked up. The following options are assigned values KeywordExpansionEnabled

See Also

CheckinOptions Class | StarTeam Namespace | CheckinOptions Constructor Overload List | getKeywordExpansionEnabled | setKeywordExpansionEnabled | getMarkProcessItemComplete | setMarkProcessItemComplete | getAttachNewLabelsOnly | setAttachNewLabelsOnly | getFileEncoding | setFileEncoding | getOptions | View


CheckinOptions Constructor (StarTeamClientOptions)

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(
StarTeamClientOptions options
);

Parameters

options
a CheckinOptions where the values of the options are picked up.

See Also

CheckinOptions Class | StarTeam Namespace | CheckinOptions Constructor Overload List | getOptions


CheckinOptions Constructor (CheckinOptions)

Construct a CheckinOptions object with the same options as the given one.

public CheckinOptions(
CheckinOptions options
);

Parameters

options
a CheckinOptions where the values of the options are picked up.

See Also

CheckinOptions Class | StarTeam Namespace | CheckinOptions Constructor Overload List | getOptions


CheckinOptions Properties

The properties of the CheckinOptions class are listed below. For a complete list of CheckinOptions class members, see the CheckinOptions Members topic.

Public Instance Properties

AttachNewLabelsOnly | [read/write] true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.
BreakLock | [read/write] true if another users lock will be broken during checkin
BuildLabel | [read/write] the build label to attach.
ChangePackageName | [read/write] the name of the change package
CharacterSetValue | [read/write] the character set to be used for this file.
CheckinReason | [read/write] the "Checkin Reason" option value.
CRsToMarkFixed | [read/write] ChangeRequests to mark fixed; an empty array, if none are specified.
DeleteWorkingFile | [read/write] true if "Delete Working File" option is set; false, otherwise.
EnforceGatedCheckin | [read/write]
EOLFormatValue | [read/write] the EOL Format to be used for this file
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
ForceCheckin | [read/write] Returns true if "Force Checkin" option is set; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking in files or the file associated with this CheckinOptions object.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LastChangePackageID | [read/write] the last known 'good' Change Package ID processed by the client
LockTypeValue | [read/write] the type of lock to be used when checking in, one of the values supported by ViewMember.LockType.
MarkProcessItemComplete | [read/write] true if the associated process item is to be marked complete; false, otherwise.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
PinProcessItem | [read/write] Returns true if the process item link endpoint will be pinned; false, otherwise.
ProcessItem | [read/write] the process item to link and pin.
RestoreFileOnError | [read/write] True if the previous working file should be restored if an error occurs during a checkin; otherwise, false.
RevisionLabel | [read/write] the revision label to attach.
UpdateExistingLinks | [read/write] Returns true if "Update Existing Links" option is set; false, otherwise.
UpdateStatus | [read/write] true if status information is to be updated after a successful checkin.

See Also

CheckinOptions Class | StarTeam Namespace


AttachNewLabelsOnly Property

Borland StarTeam SDK for .NET

CheckinOptions.AttachNewLabelsOnly Property

[read/write] true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.

public virtual Boolean AttachNewLabelsOnly {get; set;}

Property Value

true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.

See Also

CheckinOptions Class | StarTeam Namespace


BreakLock Property

Borland StarTeam SDK for .NET

CheckinOptions.BreakLock Property

[read/write] true if another users lock will be broken during checkin

public virtual Boolean BreakLock {get; set;}

Property Value

true if another users lock will be broken during checkin

See Also

CheckinOptions Class | StarTeam Namespace


BuildLabel Property

Borland StarTeam SDK for .NET

CheckinOptions.BuildLabel Property

[read/write] the build label to attach.

public virtual Label BuildLabel {get; set;}

Property Value

the build label to attach.

See Also

CheckinOptions Class | StarTeam Namespace


ChangePackageName Property

Borland StarTeam SDK for .NET

CheckinOptions.ChangePackageName Property

[read/write] the name of the change package

public virtual String ChangePackageName {get; set;}

Property Value

the name of the change package

See Also

CheckinOptions Class | StarTeam Namespace


CharacterSetValue Property

Borland StarTeam SDK for .NET

CheckinOptions.CharacterSetValue Property

[read/write] the character set to be used for this file.

public virtual File.CharacterSet CharacterSetValue {get; set;}

Property Value

the character set to be used for this file.

See Also

CheckinOptions Class | StarTeam Namespace


CheckinReason Property

Borland StarTeam SDK for .NET

CheckinOptions.CheckinReason Property

[read/write] the "Checkin Reason" option value.

public virtual String CheckinReason {get; set;}

Property Value

the "Checkin Reason" option value.

See Also

CheckinOptions Class | StarTeam Namespace


CRsToMarkFixed Property

Borland StarTeam SDK for .NET

CheckinOptions.CRsToMarkFixed Property

[read/write] ChangeRequests to mark fixed; an empty array, if none are specified.

public virtual ChangeRequest[] CRsToMarkFixed {get; set;}

Property Value

ChangeRequests to mark fixed; an empty array, if none are specified.

See Also

CheckinOptions Class | StarTeam Namespace


DeleteWorkingFile Property

Borland StarTeam SDK for .NET

CheckinOptions.DeleteWorkingFile Property

[read/write] true if "Delete Working File" option is set; false, otherwise.

public virtual Boolean DeleteWorkingFile {get; set;}

Property Value

true if "Delete Working File" option is set; false, otherwise.

See Also

CheckinOptions Class | StarTeam Namespace


EnforceGatedCheckin Property

Borland StarTeam SDK for .NET

CheckinOptions.EnforceGatedCheckin Property

[read/write]

public virtual Boolean EnforceGatedCheckin {get; set;}

See Also

CheckinOptions Class | StarTeam Namespace


EOLFormatValue Property

Borland StarTeam SDK for .NET

CheckinOptions.EOLFormatValue Property

[read/write] the EOL Format to be used for this file

public virtual File.EOLFormat EOLFormatValue {get; set;}

Property Value

the EOL Format to be used for this file

See Also

CheckinOptions Class | StarTeam Namespace


FileEncoding Property

Borland StarTeam SDK for .NET

CheckinOptions.FileEncoding Property

[read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

public virtual Encoding FileEncoding {get; set;}

Property Value

the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

See Also

CheckinOptions Class | StarTeam Namespace


ForceCheckin Property

Borland StarTeam SDK for .NET

CheckinOptions.ForceCheckin Property

[read/write] Returns true if "Force Checkin" option is set; false, otherwise.

public virtual Boolean ForceCheckin {get; set;}

Property Value

Returns true if "Force Checkin" option is set; false, otherwise.

See Also

CheckinOptions Class | StarTeam Namespace


IsFileSkipped Property

Borland StarTeam SDK for .NET

CheckinOptions.IsFileSkipped Property

[read/write] whether to skip checking in files or the file associated with this CheckinOptions object.

public virtual Boolean IsFileSkipped {get; set;}

Property Value

whether to skip checking in files or the file associated with this CheckinOptions object.

See Also

CheckinOptions Class | StarTeam Namespace


KeywordExpansionEnabled Property

Borland StarTeam SDK for .NET

CheckinOptions.KeywordExpansionEnabled Property

[read/write] Return true if keyword expansion in text files is enabled; false, otherwise.

public virtual Boolean KeywordExpansionEnabled {get; set;}

Property Value

Return true if keyword expansion in text files is enabled; false, otherwise.

See Also

CheckinOptions Class | StarTeam Namespace


LastChangePackageID Property

Borland StarTeam SDK for .NET

CheckinOptions.LastChangePackageID Property

[read/write] the last known 'good' Change Package ID processed by the client

public virtual Int32 LastChangePackageID {get; set;}

Property Value

the last known 'good' Change Package ID processed by the client

See Also

CheckinOptions Class | StarTeam Namespace


LockTypeValue Property

Borland StarTeam SDK for .NET

CheckinOptions.LockTypeValue Property

[read/write] the type of lock to be used when checking in, one of the values supported by ViewMember.LockType.

public virtual ViewMember.LockType LockTypeValue {get; set;}

Property Value

the type of lock to be used when checking in, one of the values supported by ViewMember.LockType.

See Also

CheckinOptions Class | StarTeam Namespace


MarkProcessItemComplete Property

Borland StarTeam SDK for .NET

CheckinOptions.MarkProcessItemComplete Property

[read/write] true if the associated process item is to be marked complete; false, otherwise.

public virtual Boolean MarkProcessItemComplete {get; set;}

Property Value

true if the associated process item is to be marked complete; false, otherwise.

See Also

CheckinOptions Class | StarTeam Namespace


MarkUnlockedFilesReadOnly Property

Borland StarTeam SDK for .NET

CheckinOptions.MarkUnlockedFilesReadOnly Property

[read/write] option value. Default if not defined: false

public virtual Boolean MarkUnlockedFilesReadOnly {get; set;}

Property Value

option value. Default if not defined: false

See Also

CheckinOptions Class | StarTeam Namespace


PinProcessItem Property

Borland StarTeam SDK for .NET

CheckinOptions.PinProcessItem Property

[read/write] Returns true if the process item link endpoint will be pinned; false, otherwise.

public virtual Boolean PinProcessItem {get; set;}

Property Value

Returns true if the process item link endpoint will be pinned; false, otherwise.

See Also

CheckinOptions Class | StarTeam Namespace


ProcessItem Property

Borland StarTeam SDK for .NET

CheckinOptions.ProcessItem Property

[read/write] the process item to link and pin.

public virtual Item ProcessItem {get; set;}

Property Value

the process item to link and pin.

See Also

CheckinOptions Class | StarTeam Namespace


RestoreFileOnError Property

Borland StarTeam SDK for .NET

CheckinOptions.RestoreFileOnError Property

[read/write] True if the previous working file should be restored if an error occurs during a checkin; otherwise, false.

public virtual Boolean RestoreFileOnError {get; set;}

Property Value

True if the previous working file should be restored if an error occurs during a checkin; otherwise, false.

See Also

CheckinOptions Class | StarTeam Namespace


RevisionLabel Property

Borland StarTeam SDK for .NET

CheckinOptions.RevisionLabel Property

[read/write] the revision label to attach.

public virtual Label RevisionLabel {get; set;}

Property Value

the revision label to attach.

See Also

CheckinOptions Class | StarTeam Namespace


UpdateExistingLinks Property

Borland StarTeam SDK for .NET

CheckinOptions.UpdateExistingLinks Property

[read/write] Returns true if "Update Existing Links" option is set; false, otherwise.

public virtual Boolean UpdateExistingLinks {get; set;}

Property Value

Returns true if "Update Existing Links" option is set; false, otherwise.

See Also

CheckinOptions Class | StarTeam Namespace


UpdateStatus Property

Borland StarTeam SDK for .NET

CheckinOptions.UpdateStatus Property

[read/write] true if status information is to be updated after a successful checkin.

public virtual Boolean UpdateStatus {get; set;}

Property Value

true if status information is to be updated after a successful checkin.

See Also

CheckinOptions Class | StarTeam Namespace


CheckinOptions Methods

The methods of the CheckinOptions class are listed below. For a complete list of CheckinOptions class members, see the CheckinOptions Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckinOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckinOptions.

See Also

CheckinOptions Class | StarTeam Namespace


CheckinOptions.Equals Method

Delegate Equals() to com.starteam.CheckinOptions.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckinOptions.Equals(obj).

See Also

CheckinOptions Class | StarTeam Namespace


CheckinOptions.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckinOptions.

public override int GetHashCode();

Return Value

com.starteam.CheckinOptions.GetHashCode().

See Also

CheckinOptions Class | StarTeam Namespace


CheckinOptions.ToString Method

Delegate ToString() to com.starteam.CheckinOptions.

public override string ToString();

Return Value

com.starteam.CheckinOptions.ToString()

See Also

CheckinOptions Class | StarTeam Namespace


CheckinOptions.WebCacheCheckinOptions Class

Maintains the checkin options used by WebCacheCheckinManager.

For a list of all members of this type, see CheckinOptions.WebCacheCheckinOptions Members.

System.Object
CheckinOptions.WebCacheCheckinOptions

public class CheckinOptions.WebCacheCheckinOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckinOptions.WebCacheCheckinOptions Members | StarTeam Namespace


CheckinOptions.WebCacheCheckinOptions Members

CheckinOptions.WebCacheCheckinOptions overview

Public Instance Properties

AttachNewLabelsOnly | [read/write] true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.
BreakLock | [read/write] true if another users lock will be broken during checkin
BuildLabel | [read/write] the build label to attach.
ChangePackageName | [read/write] the name of the change package
CharacterSetValue | [read/write] the character set to be used for this file.
CheckinReason | [read/write] the "Checkin Reason" option value.
CRsToMarkFixed | [read/write] ChangeRequests to mark fixed; an empty array, if none are specified.
DeleteWorkingFile | [read/write] true if "Delete Working File" option is set; false, otherwise.
EOLFormatValue | [read/write] the EOL Format to be used for this file
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
ForceCheckin | [read/write] Returns true if "Force Checkin" option is set; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking in files or the file associated with this CheckinOptions object.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LastChangePackageID | [read/write] the last known 'good' Change Package ID processed by the client
LockTypeValue | [read/write] the type of lock to be used when checking in, one of the values supported by ViewMember.LockType.
MarkProcessItemComplete | [read/write] true if the associated process item is to be marked complete; false, otherwise.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
PinProcessItem | [read/write] Returns true if the process item link endpoint will be pinned; false, otherwise.
ProcessItem | [read/write] the process item to link and pin.
RestoreFileOnError | [read/write] True if the previous working file should be restored if an error occurs during a checkin; otherwise, false.
RevisionLabel | [read/write] the revision label to attach.
UpdateExistingLinks | [read/write] Returns true if "Update Existing Links" option is set; false, otherwise.
UpdateStatus | [read/write] true if status information is to be updated after a successful checkin.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckinOptions.WebCacheCheckinOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinOptions.WebCacheCheckinOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckinOptions.WebCacheCheckinOptions.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


CheckinOptions.WebCacheCheckinOptions Properties

The properties of the CheckinOptions.WebCacheCheckinOptions class are listed below. For a complete list of CheckinOptions.WebCacheCheckinOptions class members, see the CheckinOptions.WebCacheCheckinOptions Members topic.

Public Instance Properties

AttachNewLabelsOnly | [read/write] true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.
BreakLock | [read/write] true if another users lock will be broken during checkin
BuildLabel | [read/write] the build label to attach.
ChangePackageName | [read/write] the name of the change package
CharacterSetValue | [read/write] the character set to be used for this file.
CheckinReason | [read/write] the "Checkin Reason" option value.
CRsToMarkFixed | [read/write] ChangeRequests to mark fixed; an empty array, if none are specified.
DeleteWorkingFile | [read/write] true if "Delete Working File" option is set; false, otherwise.
EOLFormatValue | [read/write] the EOL Format to be used for this file
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
ForceCheckin | [read/write] Returns true if "Force Checkin" option is set; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking in files or the file associated with this CheckinOptions object.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LastChangePackageID | [read/write] the last known 'good' Change Package ID processed by the client
LockTypeValue | [read/write] the type of lock to be used when checking in, one of the values supported by ViewMember.LockType.
MarkProcessItemComplete | [read/write] true if the associated process item is to be marked complete; false, otherwise.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
PinProcessItem | [read/write] Returns true if the process item link endpoint will be pinned; false, otherwise.
ProcessItem | [read/write] the process item to link and pin.
RestoreFileOnError | [read/write] True if the previous working file should be restored if an error occurs during a checkin; otherwise, false.
RevisionLabel | [read/write] the revision label to attach.
UpdateExistingLinks | [read/write] Returns true if "Update Existing Links" option is set; false, otherwise.
UpdateStatus | [read/write] true if status information is to be updated after a successful checkin.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


AttachNewLabelsOnly Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.AttachNewLabelsOnly Property

[read/write] true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.

public virtual Boolean AttachNewLabelsOnly {get; set;}

Property Value

true If the specified revision label is only attached to the new file revision if it is not already attached to an earlier revision; false (the default) if the label is moved to the new revision if it is already attached.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


BreakLock Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.BreakLock Property

[read/write] true if another users lock will be broken during checkin

public virtual Boolean BreakLock {get; set;}

Property Value

true if another users lock will be broken during checkin

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


BuildLabel Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.BuildLabel Property

[read/write] the build label to attach.

public virtual Label.WebCacheLabel BuildLabel {get; set;}

Property Value

the build label to attach.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


ChangePackageName Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.ChangePackageName Property

[read/write] the name of the change package

public virtual String ChangePackageName {get; set;}

Property Value

the name of the change package

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


CharacterSetValue Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.CharacterSetValue Property

[read/write] the character set to be used for this file.

public virtual File.CharacterSet CharacterSetValue {get; set;}

Property Value

the character set to be used for this file.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


CheckinReason Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.CheckinReason Property

[read/write] the "Checkin Reason" option value.

public virtual String CheckinReason {get; set;}

Property Value

the "Checkin Reason" option value.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


CRsToMarkFixed Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.CRsToMarkFixed Property

[read/write] ChangeRequests to mark fixed; an empty array, if none are specified.

public virtual WebCacheChangeRequest[] CRsToMarkFixed {get; set;}

Property Value

ChangeRequests to mark fixed; an empty array, if none are specified.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


DeleteWorkingFile Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.DeleteWorkingFile Property

[read/write] true if "Delete Working File" option is set; false, otherwise.

public virtual Boolean DeleteWorkingFile {get; set;}

Property Value

true if "Delete Working File" option is set; false, otherwise.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


EOLFormatValue Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.EOLFormatValue Property

[read/write] the EOL Format to be used for this file

public virtual File.EOLFormat EOLFormatValue {get; set;}

Property Value

the EOL Format to be used for this file

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


FileEncoding Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.FileEncoding Property

[read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

public virtual Encoding FileEncoding {get; set;}

Property Value

the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


ForceCheckin Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.ForceCheckin Property

[read/write] Returns true if "Force Checkin" option is set; false, otherwise.

public virtual Boolean ForceCheckin {get; set;}

Property Value

Returns true if "Force Checkin" option is set; false, otherwise.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


IsFileSkipped Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.IsFileSkipped Property

[read/write] whether to skip checking in files or the file associated with this CheckinOptions object.

public virtual Boolean IsFileSkipped {get; set;}

Property Value

whether to skip checking in files or the file associated with this CheckinOptions object.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


KeywordExpansionEnabled Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.KeywordExpansionEnabled Property

[read/write] Return true if keyword expansion in text files is enabled; false, otherwise.

public virtual Boolean KeywordExpansionEnabled {get; set;}

Property Value

Return true if keyword expansion in text files is enabled; false, otherwise.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


LastChangePackageID Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.LastChangePackageID Property

[read/write] the last known 'good' Change Package ID processed by the client

public virtual Int32 LastChangePackageID {get; set;}

Property Value

the last known 'good' Change Package ID processed by the client

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


LockTypeValue Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.LockTypeValue Property

[read/write] the type of lock to be used when checking in, one of the values supported by ViewMember.LockType.

public virtual ViewMember.LockType LockTypeValue {get; set;}

Property Value

the type of lock to be used when checking in, one of the values supported by ViewMember.LockType.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


MarkProcessItemComplete Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.MarkProcessItemComplete Property

[read/write] true if the associated process item is to be marked complete; false, otherwise.

public virtual Boolean MarkProcessItemComplete {get; set;}

Property Value

true if the associated process item is to be marked complete; false, otherwise.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


MarkUnlockedFilesReadOnly Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.MarkUnlockedFilesReadOnly Property

[read/write] option value. Default if not defined: false

public virtual Boolean MarkUnlockedFilesReadOnly {get; set;}

Property Value

option value. Default if not defined: false

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


PinProcessItem Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.PinProcessItem Property

[read/write] Returns true if the process item link endpoint will be pinned; false, otherwise.

public virtual Boolean PinProcessItem {get; set;}

Property Value

Returns true if the process item link endpoint will be pinned; false, otherwise.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


ProcessItem Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.ProcessItem Property

[read/write] the process item to link and pin.

public virtual Item.WebCacheItem ProcessItem {get; set;}

Property Value

the process item to link and pin.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


RestoreFileOnError Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.RestoreFileOnError Property

[read/write] True if the previous working file should be restored if an error occurs during a checkin; otherwise, false.

public virtual Boolean RestoreFileOnError {get; set;}

Property Value

True if the previous working file should be restored if an error occurs during a checkin; otherwise, false.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


RevisionLabel Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.RevisionLabel Property

[read/write] the revision label to attach.

public virtual Label.WebCacheLabel RevisionLabel {get; set;}

Property Value

the revision label to attach.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


UpdateExistingLinks Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.UpdateExistingLinks Property

[read/write] Returns true if "Update Existing Links" option is set; false, otherwise.

public virtual Boolean UpdateExistingLinks {get; set;}

Property Value

Returns true if "Update Existing Links" option is set; false, otherwise.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


UpdateStatus Property

Borland StarTeam SDK for .NET

CheckinOptions.WebCacheCheckinOptions.UpdateStatus Property

[read/write] true if status information is to be updated after a successful checkin.

public virtual Boolean UpdateStatus {get; set;}

Property Value

true if status information is to be updated after a successful checkin.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


CheckinOptions.WebCacheCheckinOptions Methods

The methods of the CheckinOptions.WebCacheCheckinOptions class are listed below. For a complete list of CheckinOptions.WebCacheCheckinOptions class members, see the CheckinOptions.WebCacheCheckinOptions Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckinOptions.WebCacheCheckinOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckinOptions.WebCacheCheckinOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckinOptions.WebCacheCheckinOptions.

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


CheckinOptions.WebCacheCheckinOptions.Equals Method

Delegate Equals() to com.starteam.CheckinOptions.WebCacheCheckinOptions.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckinOptions.WebCacheCheckinOptions.Equals(obj).

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


CheckinOptions.WebCacheCheckinOptions.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckinOptions.WebCacheCheckinOptions.

public override int GetHashCode();

Return Value

com.starteam.CheckinOptions.WebCacheCheckinOptions.GetHashCode().

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


CheckinOptions.WebCacheCheckinOptions.ToString Method

Delegate ToString() to com.starteam.CheckinOptions.WebCacheCheckinOptions.

public override string ToString();

Return Value

com.starteam.CheckinOptions.WebCacheCheckinOptions.ToString()

See Also

CheckinOptions.WebCacheCheckinOptions Class | StarTeam Namespace


CheckoutManager Class

Provides a way to check out multiple files, applying a consistent set of options across all files. Files may be aggregated or overwritten (using the different flavors of the checkout api's) until ready to commit all the changes The commit() method must be called to save all identified changes to the local file system Files will be checked out either from the StarTeam server or from the closest cache agent If a cache agent is being used, file checkouts are multi-threaded, and are based on the HTTP protocol The commit is non-transactional, and is executed in two primary phases During the first phase of the checkout, events are fired to the calling client application, at which point, the application may decide to overwrite earlier decisions, such as ignoring certain files, force checking out others, checking out to a different stream, etc. Usage CheckoutManager cm = myView.createCheckoutManager(); cm.checkout(file1); cm.checkoutTo(file2, new java.io.File("c://myprojects//myworkspace//file2.txt"); cm.checkout(file3, new CheckoutOptions(myView)); if (cm.canCommit()) cm.commit();

For a list of all members of this type, see CheckoutManager Members.

System.Object
CheckoutManager

public class CheckoutManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutManager Members | StarTeam Namespace


CheckoutManager Members

CheckoutManager overview

Public Instance Properties

IsCanceled | [read] true if pending checkout operations have been canceled, and false otherwise.
IsRunning | [read] true if there is currently a checkout operation in progress, and false otherwise.
Options | [read/write] The checkout options currently in effect.
ProgressValue | [read] A snapshot of the state of the current checkout operation.
View | [read] View

Public Instance Methods

BytesTransferred |
CanCommit | returns true if the session can be committed For the session to be in a commit-able state, all files being checked out should be in a relevant state, e.g. OUT OF DATE or MISSING, or else the ForceCheckout option should be specified
Checkout | Overloaded.
CheckoutTo | Overloaded. Checks out a file in the context of the specified starTeam File Object to the specified file system disk file. Note that the force checkout flag must be set to true for the actual bytes to get checked out and written to the disk file. If not set, an empty file is created on disk. This is by design to satisfy a backward compatibility constraint. Creates a copy of the global options. Subsequent changes to global options do not affect this file
Commit | Commit all the changes to the local file system. The files will be checked out from the server or the closest cache agent, if one is specified Checkout from CacheAgent is multi-threaded, and uses the HTTP protocol
Equals | Delegate Equals() to com.starteam.CheckoutManager.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.
GetType (inherited from Object) | Gets the Type of the current instance.
HasCheckoutListeners | Returns true if there is at least one registered listener for checkout events
Ignore | Remove this item from consideration for the commit If the item was to be checked out, it will not be checked out If the item is a folder, then all child files, descendant folders and child files of descendant folders will be removed from consideration
NewCheckoutEventSource |
SetCanceled | Cancels any pending checkout operations.
Size | returns a count of the amount of work to be done by this manager
ToString | Delegate ToString() to com.starteam.CheckoutManager.

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager Properties

The properties of the CheckoutManager class are listed below. For a complete list of CheckoutManager class members, see the CheckoutManager Members topic.

Public Instance Properties

IsCanceled | [read] true if pending checkout operations have been canceled, and false otherwise.
IsRunning | [read] true if there is currently a checkout operation in progress, and false otherwise.
Options | [read/write] The checkout options currently in effect.
ProgressValue | [read] A snapshot of the state of the current checkout operation.
View | [read] View

See Also

CheckoutManager Class | StarTeam Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CheckoutManager.IsCanceled Property

[read] true if pending checkout operations have been canceled, and false otherwise.

public virtual Boolean IsCanceled {get;}

Property Value

true if pending checkout operations have been canceled, and false otherwise.

See Also

CheckoutManager Class | StarTeam Namespace


IsRunning Property

Borland StarTeam SDK for .NET

CheckoutManager.IsRunning Property

[read] true if there is currently a checkout operation in progress, and false otherwise.

public virtual Boolean IsRunning {get;}

Property Value

true if there is currently a checkout operation in progress, and false otherwise.

See Also

CheckoutManager Class | StarTeam Namespace


Options Property

Borland StarTeam SDK for .NET

CheckoutManager.Options Property

[read/write] The checkout options currently in effect.

public virtual CheckoutOptions Options {get; set;}

Property Value

The checkout options currently in effect.

See Also

CheckoutManager Class | StarTeam Namespace


ProgressValue Property

Borland StarTeam SDK for .NET

CheckoutManager.ProgressValue Property

[read] A snapshot of the state of the current checkout operation.

public virtual CheckoutManager.Progress ProgressValue {get;}

Property Value

A snapshot of the state of the current checkout operation.

See Also

CheckoutManager Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

CheckoutManager.View Property

[read] View

public virtual View View {get;}

Property Value

View

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager Methods

The methods of the CheckoutManager class are listed below. For a complete list of CheckoutManager class members, see the CheckoutManager Members topic.

Public Instance Methods

BytesTransferred |
CanCommit | returns true if the session can be committed For the session to be in a commit-able state, all files being checked out should be in a relevant state, e.g. OUT OF DATE or MISSING, or else the ForceCheckout option should be specified
Checkout | Overloaded.
CheckoutTo | Overloaded. Checks out a file in the context of the specified starTeam File Object to the specified file system disk file. Note that the force checkout flag must be set to true for the actual bytes to get checked out and written to the disk file. If not set, an empty file is created on disk. This is by design to satisfy a backward compatibility constraint. Creates a copy of the global options. Subsequent changes to global options do not affect this file
Commit | Commit all the changes to the local file system. The files will be checked out from the server or the closest cache agent, if one is specified Checkout from CacheAgent is multi-threaded, and uses the HTTP protocol
Equals | Delegate Equals() to com.starteam.CheckoutManager.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.
GetType (inherited from Object) | Gets the Type of the current instance.
HasCheckoutListeners | Returns true if there is at least one registered listener for checkout events
Ignore | Remove this item from consideration for the commit If the item was to be checked out, it will not be checked out If the item is a folder, then all child files, descendant folders and child files of descendant folders will be removed from consideration
NewCheckoutEventSource |
SetCanceled | Cancels any pending checkout operations.
Size | returns a count of the amount of work to be done by this manager
ToString | Delegate ToString() to com.starteam.CheckoutManager.

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.BytesTransferred Method

public virtual bool BytesTransferred(
Int32 bytes
);

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.CanCommit Method

returns true if the session can be committed For the session to be in a commit-able state, all files being checked out should be in a relevant state, e.g. OUT OF DATE or MISSING, or else the ForceCheckout option should be specified

public virtual bool CanCommit();

Return Value

true if the session can be committed

See Also

CheckoutManager Class | StarTeam Namespace


Checkout Method

Borland StarTeam SDK for .NET

CheckoutManager.Checkout Method

Overload List

public virtual void Checkout(ChangePackage);

Checks out a single file to the default location. The file is checked out on commit. Creates a copy of the global options. Subsequent changes to global options do not affect this file

public virtual void Checkout(File);

Checks out a file with the specified set of options. The file is checked out on commit

public virtual void Checkout(File,CheckoutOptions);

Checks out the given set of files. The files are checked out on commit Creates a copy of the global options. Subsequent changes to global options do not affect these files.

public virtual void Checkout(File[]);

Checks out all the files in the given folder. Creates a copy of the global options. Subsequent changes to global options do not affect this folder and its files

public virtual void Checkout(Folder);

Checks out all the files in the given folder, and in all sub-folders to the given depth. Creates a copy of the global options. Subsequent changes to global options do not affect these folders and their files

public virtual void Checkout(Folder,Int32);

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.Checkout Method (ChangePackage)

public virtual void Checkout(
ChangePackage cp
);

See Also

CheckoutManager Class | StarTeam Namespace | CheckoutManager.Checkout Overload List


CheckoutManager.Checkout Method (File)

Checks out a single file to the default location. The file is checked out on commit. Creates a copy of the global options. Subsequent changes to global options do not affect this file

public virtual void Checkout(
File starTeamFile
);

Parameters

starTeamFile
The file to be checked out.

See Also

CheckoutManager Class | StarTeam Namespace | CheckoutManager.Checkout Overload List | commit


CheckoutManager.Checkout Method (File, CheckoutOptions)

Checks out a file with the specified set of options. The file is checked out on commit

public virtual void Checkout(
File starTeamFile,
CheckoutOptions options
);

Parameters

starTeamFile
The file to checkout
options
the checkout options to use. These options override the default options assigned when this checkout manager was created.

See Also

CheckoutManager Class | StarTeam Namespace | CheckoutManager.Checkout Overload List | commit


CheckoutManager.Checkout Method (File[])

Checks out the given set of files. The files are checked out on commit Creates a copy of the global options. Subsequent changes to global options do not affect these files.

public virtual void Checkout(
File[] files
);

Parameters

files
The files to be checked out.

See Also

CheckoutManager Class | StarTeam Namespace | CheckoutManager.Checkout Overload List | commit | getItems


CheckoutManager.Checkout Method (Folder)

Checks out all the files in the given folder. Creates a copy of the global options. Subsequent changes to global options do not affect this folder and its files

public virtual void Checkout(
Folder folder
);

Parameters

folder
The StarTeam folder whose files are to be checked out.

See Also

CheckoutManager Class | StarTeam Namespace | CheckoutManager.Checkout Overload List | Folder | checkout


CheckoutManager.Checkout Method (Folder, Int32)

Checks out all the files in the given folder, and in all sub-folders to the given depth. Creates a copy of the global options. Subsequent changes to global options do not affect these folders and their files

public virtual void Checkout(
Folder folder,
Int32 depth
);

Parameters

folder
The StarTeam folder whose files are to be checked out.
depth
Indicates which sub-folders also contain files to be checked out. Zero indicates that no sub-folders should be included; 1 indicates that this folder and its immediate child folders should be included; -1 indicates that this folder and all child folders at any depth should be included. -2 indicates that only the folder should be 'checked out'

See Also

CheckoutManager Class | StarTeam Namespace | CheckoutManager.Checkout Overload List


CheckoutTo Method

Borland StarTeam SDK for .NET

CheckoutManager.CheckoutTo Method

Checks out a file in the context of the specified starTeam File Object to the specified file system disk file. Note that the force checkout flag must be set to true for the actual bytes to get checked out and written to the disk file. If not set, an empty file is created on disk. This is by design to satisfy a backward compatibility constraint. Creates a copy of the global options. Subsequent changes to global options do not affect this file

Overload List

Checks out a file in the context of the specified starTeam File Object to the specified file system disk file. Note that the force checkout flag must be set to true for the actual bytes to get checked out and written to the disk file. If not set, an empty file is created on disk. This is by design to satisfy a backward compatibility constraint. Creates a copy of the global options. Subsequent changes to global options do not affect this file

public virtual void CheckoutTo(File,FileInfo);

public virtual void CheckoutTo(File,Stream);

See Also

CheckoutManager Class | StarTeam Namespace | setForceCheckout


CheckoutManager.CheckoutTo Method (File, FileInfo)

Checks out a file in the context of the specified starTeam File Object to the specified file system disk file. Note that the force checkout flag must be set to true for the actual bytes to get checked out and written to the disk file. If not set, an empty file is created on disk. This is by design to satisfy a backward compatibility constraint. Creates a copy of the global options. Subsequent changes to global options do not affect this file

public virtual void CheckoutTo(
File starTeamFile,
FileInfo diskFile
);

Parameters

starTeamFile
File a starTeam File Object instance
diskFile
File a java.io.File to checkout to

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

CheckoutManager Class | StarTeam Namespace | CheckoutManager.CheckoutTo Overload List | setForceCheckout


CheckoutManager.CheckoutTo Method (File, Stream)

public virtual void CheckoutTo(
File starTeamFile,
Stream stream
);

See Also

CheckoutManager Class | StarTeam Namespace | CheckoutManager.CheckoutTo Overload List


CheckoutManager.Commit Method

Commit all the changes to the local file system. The files will be checked out from the server or the closest cache agent, if one is specified Checkout from CacheAgent is multi-threaded, and uses the HTTP protocol

public virtual File[] Commit();

Return Value

the actual revisions whose contents were checked out

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.Equals Method

Delegate Equals() to com.starteam.CheckoutManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckoutManager.Equals(obj).

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckoutManager.

public override int GetHashCode();

Return Value

com.starteam.CheckoutManager.GetHashCode().

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.HasCheckoutListeners Method

Returns true if there is at least one registered listener for checkout events

public virtual bool HasCheckoutListeners();

Return Value

boolean true if there is at least one registered listener for checkout events

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.Ignore Method

Remove this item from consideration for the commit If the item was to be checked out, it will not be checked out If the item is a folder, then all child files, descendant folders and child files of descendant folders will be removed from consideration

public virtual void Ignore(
Item starTeamItem
);

Parameters

starTeamItem

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.NewCheckoutEventSource Method

public CheckoutEventSource NewCheckoutEventSource();

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.SetCanceled Method

Cancels any pending checkout operations.

public virtual void SetCanceled();

See Also

CheckoutManager Class | StarTeam Namespace | isCanceled


CheckoutManager.Size Method

returns a count of the amount of work to be done by this manager

public virtual long Size();

Return Value

a count of the amount of work to be done by this manager

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.ToString Method

Delegate ToString() to com.starteam.CheckoutManager.

public override string ToString();

Return Value

com.starteam.CheckoutManager.ToString()

See Also

CheckoutManager Class | StarTeam Namespace


CheckoutManager.Progress Class

Information on the progress of a checkout operation from CheckoutManager. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use CheckoutManager.getProgress().

For a list of all members of this type, see CheckoutManager.Progress Members.

System.Object
CheckoutManager.Progress

public class CheckoutManager.Progress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutManager.Progress Members | StarTeam Namespace


CheckoutManager.Progress Members

CheckoutManager.Progress overview

Public Instance Properties

CheckoutThreadIndices | [read] an array of thread indices used by the checkout process
CurrentPhase | [read] the Phase associated with this Progress.
CurrentPhaseEstimatedTimeRemaining | [read] the estimated time remaining in milliseconds.
CurrentPhaseUnitsOfWork | [read] the total number of units of work.
CurrentPhaseUnitsOfWorkProcessed | [read] the number of units of work that has been processed in this phase.
CurrentPhaseUnitsOfWorkRemaining | [read] the total number of units of work that are yet to be done.
CurrentWorkingFile | [read] the current File object that's being checked in in the specified thread ID.
Description | [read] a description of the current state of Progress
LastError |
SnapshotTime | [read] DateTime the snapshot time that is set when the last clone was created.
StatisticsForCacheAgentCheckout | [read] aggregated statistics across all Cache Agent Threads.
StatisticsForStarTeamServerCheckout |
SummaryStatistics | [read] aggregated statistics across all threads.
TotalFilesForCheckout | [read] the total number of files for checkout.
TotalTimeSpent | [read] the total time spent so far (in milliseconds).

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutManager.Progress.
GetCurrentFile | Get the current StarTeam Item object that is being processed in the current phase. The return value may be an Item if the current phase is iterating over items. Otherwise, a null is returned. For the most part, these Item's are File Objects. However, there can be phases in which other Items are returned, for instance Process Items during a link phase
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.Progress.
GetStatisticsByThread | // ------------------------------------------------------------------ ------- // Any of the following methods that returns a Statistics object may return null if // the current phase does not support Statistics. However, once a non-null / // Statistics object instance is returned by any of these methods, then the same // instance must be guaranteed to be returned across the rest of the life of the // Progress object instance. // Return the statistics per thread, where the thread index was in the array returned // by getCheckoutThreadIndices().
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckoutManager.Progress.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CheckoutManager.Progress Properties

The properties of the CheckoutManager.Progress class are listed below. For a complete list of CheckoutManager.Progress class members, see the CheckoutManager.Progress Members topic.

Public Instance Properties

CheckoutThreadIndices | [read] an array of thread indices used by the checkout process
CurrentPhase | [read] the Phase associated with this Progress.
CurrentPhaseEstimatedTimeRemaining | [read] the estimated time remaining in milliseconds.
CurrentPhaseUnitsOfWork | [read] the total number of units of work.
CurrentPhaseUnitsOfWorkProcessed | [read] the number of units of work that has been processed in this phase.
CurrentPhaseUnitsOfWorkRemaining | [read] the total number of units of work that are yet to be done.
CurrentWorkingFile | [read] the current File object that's being checked in in the specified thread ID.
Description | [read] a description of the current state of Progress
LastError |
SnapshotTime | [read] DateTime the snapshot time that is set when the last clone was created.
StatisticsForCacheAgentCheckout | [read] aggregated statistics across all Cache Agent Threads.
StatisticsForStarTeamServerCheckout |
SummaryStatistics | [read] aggregated statistics across all threads.
TotalFilesForCheckout | [read] the total number of files for checkout.
TotalTimeSpent | [read] the total time spent so far (in milliseconds).

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CheckoutThreadIndices Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.CheckoutThreadIndices Property

[read] an array of thread indices used by the checkout process

public virtual Int32[] CheckoutThreadIndices {get;}

Property Value

an array of thread indices used by the checkout process

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CurrentPhase Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.CurrentPhase Property

[read] the Phase associated with this Progress.

public virtual CheckoutManager.Progress.Phase CurrentPhase {get;}

Property Value

the Phase associated with this Progress.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CurrentPhaseEstimatedTimeRemaining Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.CurrentPhaseEstimatedTimeRemaining Property

[read] the estimated time remaining in milliseconds.

public virtual Int64 CurrentPhaseEstimatedTimeRemaining {get;}

Property Value

the estimated time remaining in milliseconds.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CurrentPhaseUnitsOfWork Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.CurrentPhaseUnitsOfWork Property

[read] the total number of units of work.

public virtual Int64 CurrentPhaseUnitsOfWork {get;}

Property Value

the total number of units of work.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CurrentPhaseUnitsOfWorkProcessed Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.CurrentPhaseUnitsOfWorkProcessed Property

[read] the number of units of work that has been processed in this phase.

public virtual Int64 CurrentPhaseUnitsOfWorkProcessed {get;}

Property Value

the number of units of work that has been processed in this phase.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CurrentPhaseUnitsOfWorkRemaining Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.CurrentPhaseUnitsOfWorkRemaining Property

[read] the total number of units of work that are yet to be done.

public virtual Int64 CurrentPhaseUnitsOfWorkRemaining {get;}

Property Value

the total number of units of work that are yet to be done.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CurrentWorkingFile Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.CurrentWorkingFile Property

[read] the current File object that's being checked in in the specified thread ID.

public virtual FileInfo CurrentWorkingFile {get;}

Property Value

the current File object that's being checked in in the specified thread ID.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Description Property

[read] a description of the current state of Progress

public virtual String Description {get;}

Property Value

a description of the current state of Progress

See Also

CheckoutManager.Progress Class | StarTeam Namespace


LastError Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.LastError Property

public virtual Exception LastError {get;}

See Also

CheckoutManager.Progress Class | StarTeam Namespace


SnapshotTime Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.SnapshotTime Property

[read] DateTime the snapshot time that is set when the last clone was created.

public virtual DateTime SnapshotTime {get;}

Property Value

DateTime the snapshot time that is set when the last clone was created.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


StatisticsForCacheAgentCheckout Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.StatisticsForCacheAgentCheckout Property

[read] aggregated statistics across all Cache Agent Threads.

public virtual CheckoutManager.Progress.Statistics StatisticsForCacheAgentCheckout {get;}

Property Value

aggregated statistics across all Cache Agent Threads.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


StatisticsForStarTeamServerCheckout Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.StatisticsForStarTeamServerCheckout Property

public virtual CheckoutManager.Progress.Statistics StatisticsForStarTeamServerCheckout {get;}

See Also

CheckoutManager.Progress Class | StarTeam Namespace


SummaryStatistics Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.SummaryStatistics Property

[read] aggregated statistics across all threads.

public virtual CheckoutManager.Progress.Statistics SummaryStatistics {get;}

Property Value

aggregated statistics across all threads.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


TotalFilesForCheckout Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.TotalFilesForCheckout Property

[read] the total number of files for checkout.

public virtual Int64 TotalFilesForCheckout {get;}

Property Value

the total number of files for checkout.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


TotalTimeSpent Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.TotalTimeSpent Property

[read] the total time spent so far (in milliseconds).

public virtual Int64 TotalTimeSpent {get;}

Property Value

the total time spent so far (in milliseconds).

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CheckoutManager.Progress Methods

The methods of the CheckoutManager.Progress class are listed below. For a complete list of CheckoutManager.Progress class members, see the CheckoutManager.Progress Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutManager.Progress.
GetCurrentFile | Get the current StarTeam Item object that is being processed in the current phase. The return value may be an Item if the current phase is iterating over items. Otherwise, a null is returned. For the most part, these Item's are File Objects. However, there can be phases in which other Items are returned, for instance Process Items during a link phase
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.Progress.
GetStatisticsByThread | // ------------------------------------------------------------------ ------- // Any of the following methods that returns a Statistics object may return null if // the current phase does not support Statistics. However, once a non-null / // Statistics object instance is returned by any of these methods, then the same // instance must be guaranteed to be returned across the rest of the life of the // Progress object instance. // Return the statistics per thread, where the thread index was in the array returned // by getCheckoutThreadIndices().
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckoutManager.Progress.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CheckoutManager.Progress.Equals Method

Delegate Equals() to com.starteam.CheckoutManager.Progress.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckoutManager.Progress.Equals(obj).

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CheckoutManager.Progress.GetCurrentFile Method

Get the current StarTeam Item object that is being processed in the current phase. The return value may be an Item if the current phase is iterating over items. Otherwise, a null is returned. For the most part, these Item's are File Objects. However, there can be phases in which other Items are returned, for instance Process Items during a link phase

public virtual File GetCurrentFile(
Int32 threadIndex
);

Parameters

threadIndex
the thread on which this file is being checked out

Return Value

Return the current StarTeam Item that's being processed in the current phase.

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CheckoutManager.Progress.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckoutManager.Progress.

public override int GetHashCode();

Return Value

com.starteam.CheckoutManager.Progress.GetHashCode().

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CheckoutManager.Progress.GetStatisticsByThread Method

// ------------------------------------------------------------------ ------- // Any of the following methods that returns a Statistics object may return null if // the current phase does not support Statistics. However, once a non-null / // Statistics object instance is returned by any of these methods, then the same // instance must be guaranteed to be returned across the rest of the life of the // Progress object instance. // Return the statistics per thread, where the thread index was in the array returned // by getCheckoutThreadIndices().

public virtual Statistics GetStatisticsByThread(
Int32 threadIndex
);

Parameters

threadIndex
the thread used for the checkout

Return Value

the Statistics for that thread

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CheckoutManager.Progress.ToString Method

Delegate ToString() to com.starteam.CheckoutManager.Progress.

public override string ToString();

Return Value

com.starteam.CheckoutManager.Progress.ToString()

See Also

CheckoutManager.Progress Class | StarTeam Namespace


CheckoutManager.Progress.Phase Class

Information on the phase of a checkout progress of the Checkout operation from CheckoutManager.

For a list of all members of this type, see CheckoutManager.Progress.Phase Members.

System.Object
CheckoutManager.Progress.Phase

public class CheckoutManager.Progress.Phase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutManager.Progress.Phase Members | StarTeam Namespace


CheckoutManager.Progress.Phase Members

CheckoutManager.Progress.Phase overview

Public Static Properties

CANCELED
CHECKING_OUT
POST_PROCESSING
PRE_PROCESSING

Public Instance Properties

Name [read] Return the name of this Phase.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutManager.Progress.Phase.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.Progress.Phase.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckoutManager.Progress.Phase.

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


CheckoutManager.Progress.Phase Properties

The properties of the CheckoutManager.Progress.Phase class are listed below. For a complete list of CheckoutManager.Progress.Phase class members, see the CheckoutManager.Progress.Phase Members topic.

Public Static Properties

CANCELED
CHECKING_OUT
POST_PROCESSING
PRE_PROCESSING

Public Instance Properties

Name [read] Return the name of this Phase.

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


CANCELED Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Phase.CANCELED Property

public static CheckoutManager.Progress.Phase CANCELED {get;}

Property Value

The Canceled phase

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


CHECKING_OUT Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Phase.CHECKING_OUT Property

public static CheckoutManager.Progress.Phase CHECKING_OUT {get;}

Property Value

The Checking Out Phase

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Phase.Name Property

[read] Return the name of this Phase.

public virtual String Name {get;}

Property Value

Return the name of this Phase.

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


POST_PROCESSING Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Phase.POST_PROCESSING Property

public static CheckoutManager.Progress.Phase POST_PROCESSING {get;}

Property Value

The Post Processing Phase

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


PRE_PROCESSING Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Phase.PRE_PROCESSING Property

public static CheckoutManager.Progress.Phase PRE_PROCESSING {get;}

Property Value

The Pre Processing Phase

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


CheckoutManager.Progress.Phase Methods

The methods of the CheckoutManager.Progress.Phase class are listed below. For a complete list of CheckoutManager.Progress.Phase class members, see the CheckoutManager.Progress.Phase Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutManager.Progress.Phase.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.Progress.Phase.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckoutManager.Progress.Phase.

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


CheckoutManager.Progress.Phase.Equals Method

Delegate Equals() to com.starteam.CheckoutManager.Progress.Phase.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckoutManager.Progress.Phase.Equals(obj).

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


CheckoutManager.Progress.Phase.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckoutManager.Progress.Phase.

public override int GetHashCode();

Return Value

com.starteam.CheckoutManager.Progress.Phase.GetHashCode().

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


CheckoutManager.Progress.Phase.ToString Method

Delegate ToString() to com.starteam.CheckoutManager.Progress.Phase.

public override string ToString();

Return Value

com.starteam.CheckoutManager.Progress.Phase.ToString()

See Also

CheckoutManager.Progress.Phase Class | StarTeam Namespace


CheckoutManager.Progress.Statistics Class

A Statistical summary that tracks the progress of the checkout

For a list of all members of this type, see CheckoutManager.Progress.Statistics Members.

System.Object
CheckoutManager.Progress.Statistics

public class CheckoutManager.Progress.Statistics

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutManager.Progress.Statistics Members | StarTeam Namespace


CheckoutManager.Progress.Statistics Members

CheckoutManager.Progress.Statistics overview

Public Instance Properties

CurrentFile | [read] the current file
TotalBytesCheckedOut | [read] the total number of bytes that are checked out.
TotalFilesCheckedOut | [read] the number of files that have been checked out.
TotalFilesFailed | [read] the files that failed during checkout.
TotalFilesProcessed | [read] the total number of files processed.
TotalFilesRemaining | [read] the number of files remaining to be checked out.
TotalFilesSkipped | [read] the total number of files skipped without being checked out.
TotalTimeSpent | [read] the total time spent so far (in milliseconds).

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutManager.Progress.Statistics.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.Progress.Statistics.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckoutManager.Progress.Statistics.

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


CheckoutManager.Progress.Statistics Properties

The properties of the CheckoutManager.Progress.Statistics class are listed below. For a complete list of CheckoutManager.Progress.Statistics class members, see the CheckoutManager.Progress.Statistics Members topic.

Public Instance Properties

CurrentFile | [read] the current file
TotalBytesCheckedOut | [read] the total number of bytes that are checked out.
TotalFilesCheckedOut | [read] the number of files that have been checked out.
TotalFilesFailed | [read] the files that failed during checkout.
TotalFilesProcessed | [read] the total number of files processed.
TotalFilesRemaining | [read] the number of files remaining to be checked out.
TotalFilesSkipped | [read] the total number of files skipped without being checked out.
TotalTimeSpent | [read] the total time spent so far (in milliseconds).

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


CurrentFile Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Statistics.CurrentFile Property

[read] the current file

public virtual File CurrentFile {get;}

Property Value

the current file

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


TotalBytesCheckedOut Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Statistics.TotalBytesCheckedOut Property

[read] the total number of bytes that are checked out.

public virtual Int64 TotalBytesCheckedOut {get;}

Property Value

the total number of bytes that are checked out.

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


TotalFilesCheckedOut Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Statistics.TotalFilesCheckedOut Property

[read] the number of files that have been checked out.

public virtual Int64 TotalFilesCheckedOut {get;}

Property Value

the number of files that have been checked out.

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


TotalFilesFailed Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Statistics.TotalFilesFailed Property

[read] the files that failed during checkout.

public virtual Int64 TotalFilesFailed {get;}

Property Value

the files that failed during checkout.

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


TotalFilesProcessed Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Statistics.TotalFilesProcessed Property

[read] the total number of files processed.

public virtual Int64 TotalFilesProcessed {get;}

Property Value

the total number of files processed.

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


TotalFilesRemaining Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Statistics.TotalFilesRemaining Property

[read] the number of files remaining to be checked out.

public virtual Int64 TotalFilesRemaining {get;}

Property Value

the number of files remaining to be checked out.

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


TotalFilesSkipped Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Statistics.TotalFilesSkipped Property

[read] the total number of files skipped without being checked out.

public virtual Int64 TotalFilesSkipped {get;}

Property Value

the total number of files skipped without being checked out.

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


TotalTimeSpent Property

Borland StarTeam SDK for .NET

CheckoutManager.Progress.Statistics.TotalTimeSpent Property

[read] the total time spent so far (in milliseconds).

public virtual Int64 TotalTimeSpent {get;}

Property Value

the total time spent so far (in milliseconds).

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


CheckoutManager.Progress.Statistics Methods

The methods of the CheckoutManager.Progress.Statistics class are listed below. For a complete list of CheckoutManager.Progress.Statistics class members, see the CheckoutManager.Progress.Statistics Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutManager.Progress.Statistics.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.Progress.Statistics.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.CheckoutManager.Progress.Statistics.

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


CheckoutManager.Progress.Statistics.Equals Method

Delegate Equals() to com.starteam.CheckoutManager.Progress.Statistics.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckoutManager.Progress.Statistics.Equals(obj).

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


CheckoutManager.Progress.Statistics.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckoutManager.Progress.Statistics.

public override int GetHashCode();

Return Value

com.starteam.CheckoutManager.Progress.Statistics.GetHashCode().

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


CheckoutManager.Progress.Statistics.ToString Method

Delegate ToString() to com.starteam.CheckoutManager.Progress.Statistics.

public override string ToString();

Return Value

com.starteam.CheckoutManager.Progress.Statistics.ToString()

See Also

CheckoutManager.Progress.Statistics Class | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager Class

Checkout Manager accessor for cached SDK items Contained objects are obtained from the artifact cache CheckoutManager instances are considered stale after commit

For a list of all members of this type, see CheckoutManager.WebCacheCheckoutManager Members.

System.Object
CheckoutManager.WebCacheCheckoutManager

public class CheckoutManager.WebCacheCheckoutManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutManager.WebCacheCheckoutManager Members | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager Members

CheckoutManager.WebCacheCheckoutManager overview

Public Instance Properties

Options | [read] the options associated with this checkin manager
View | [read] the View

Public Instance Methods

CanCommit | return true if this checkin can be committed
CheckoutTo | Overloaded.
Commit | commit the changes
Equals | Delegate Equals() to com.starteam.CheckoutManager.WebCacheCheckoutManager.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.WebCacheCheckoutManager.
GetType (inherited from Object) | Gets the Type of the current instance.
NewWebCacheCheckoutEventSource |
ToString | Delegate ToString() to com.starteam.CheckoutManager.WebCacheCheckoutManager.

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager Properties

The properties of the CheckoutManager.WebCacheCheckoutManager class are listed below. For a complete list of CheckoutManager.WebCacheCheckoutManager class members, see the CheckoutManager.WebCacheCheckoutManager Members topic.

Public Instance Properties

Options | [read] the options associated with this checkin manager
View | [read] the View

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


Options Property

Borland StarTeam SDK for .NET

CheckoutManager.WebCacheCheckoutManager.Options Property

[read] the options associated with this checkin manager

public virtual CheckoutOptions.WebCacheCheckoutOptions Options {get;}

Property Value

the options associated with this checkin manager

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

CheckoutManager.WebCacheCheckoutManager.View Property

[read] the View

public virtual View.WebCacheView View {get;}

Property Value

the View

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager Methods

The methods of the CheckoutManager.WebCacheCheckoutManager class are listed below. For a complete list of CheckoutManager.WebCacheCheckoutManager class members, see the CheckoutManager.WebCacheCheckoutManager Members topic.

Public Instance Methods

CanCommit | return true if this checkin can be committed
CheckoutTo | Overloaded.
Commit | commit the changes
Equals | Delegate Equals() to com.starteam.CheckoutManager.WebCacheCheckoutManager.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutManager.WebCacheCheckoutManager.
GetType (inherited from Object) | Gets the Type of the current instance.
NewWebCacheCheckoutEventSource |
ToString | Delegate ToString() to com.starteam.CheckoutManager.WebCacheCheckoutManager.

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager.CanCommit Method

return true if this checkin can be committed

public virtual bool CanCommit();

Return Value

true if this checkin can be committed

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutTo Method

Borland StarTeam SDK for .NET

CheckoutManager.WebCacheCheckoutManager.CheckoutTo Method

Overload List

public virtual void CheckoutTo(File.WebCacheFile,FileInfo);

public virtual void CheckoutTo(File.WebCacheFile,Stream);

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager.CheckoutTo Method (File#WebCacheFile, FileInfo)

public virtual void CheckoutTo(
File.WebCacheFile starTeamFile,
FileInfo diskFile
);

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace | CheckoutManager.WebCacheCheckoutManager.CheckoutTo Overload List


CheckoutManager.WebCacheCheckoutManager.CheckoutTo Method (File#WebCacheFile, Stream)

public virtual void CheckoutTo(
File.WebCacheFile starTeamFile,
Stream stream
);

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace | CheckoutManager.WebCacheCheckoutManager.CheckoutTo Overload List


CheckoutManager.WebCacheCheckoutManager.Commit Method

commit the changes

public virtual WebCacheFile[] Commit();

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager.Equals Method

Delegate Equals() to com.starteam.CheckoutManager.WebCacheCheckoutManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckoutManager.WebCacheCheckoutManager.Equals(obj).

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckoutManager.WebCacheCheckoutManager.

public override int GetHashCode();

Return Value

com.starteam.CheckoutManager.WebCacheCheckoutManager.GetHashCode().

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager.NewWebCacheCheckoutEventSource Method

public WebCacheCheckoutEventSource NewWebCacheCheckoutEventSource();

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutManager.WebCacheCheckoutManager.ToString Method

Delegate ToString() to com.starteam.CheckoutManager.WebCacheCheckoutManager.

public override string ToString();

Return Value

com.starteam.CheckoutManager.WebCacheCheckoutManager.ToString()

See Also

CheckoutManager.WebCacheCheckoutManager Class | StarTeam Namespace


CheckoutOptions Class

Maintains the checkout options used by CheckoutManager.

For a list of all members of this type, see CheckoutOptions Members.

System.Object
CheckoutOptions

public class CheckoutOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutOptions Members | StarTeam Namespace


CheckoutOptions Members

CheckoutOptions overview

Public Instance Constructors

CheckoutOptions Overloaded. Initializes a new instance of the CheckoutOptions class.

Public Instance Properties

BreakLock | [read/write] true if another users lock will be broken during checkout
CheckoutByDate | [read/write] Return the DateTime value to be used for the "checkout by date" option.
CheckoutByLabel | [read/write] Return the Label to be used for the "checkout by Label" option.
CheckoutByPromotionState | [read/write] Return the PromotionState ID value to be used for the "checkout by PromotionState" option.
CheckoutByViewVersion | [read/write] Return the view version value to be used for the "checkout by view version" option.
ContentFilterValue | [read/write] Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.
EOLFormatValue | [read/write] EOLFormat
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
FolderTimeStampNow | [read/write] Return true if current folder time is used as the last modified time; false, otherwise.
ForceCheckout | [read/write] the "Force Checkout" option value, whose default value is false.
IsByDate | [read] Return true if "checkout by date" option is used; false, otherwise.
IsByLabel | [read] Return true if "checkout by Label" option is used; false, otherwise.
IsByPromotionState | [read] Return true if "checkout by PromotionState" option is used; false, otherwise.
IsByViewVersion | [read] Return true if "checkout by view version" option is used; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking out files or the file associated with this CheckoutOptions object.
IsTip | [read] Return true if the tip is used; false, otherwise.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LockTypeValue | [read/write] Return the type of lock to be used when checking out, one of the values supported by Item.LockType.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
RestoreFileOnError | [read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.
TimeStampNow | [read/write] Return true if current time is used as the last modified time; false, otherwise.
UpdateStatus | [read/write] Return true if status information is to be updated after a successful checkout.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCheckoutTip | Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
ToString | Delegate ToString() to com.starteam.CheckoutOptions.

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutOptions Constructor

Construct a CheckoutOptions object with default options from the View. The following options are assigned values DefaultEOLFormat

Overload List

Construct a CheckoutOptions object from the specified copy.

public CheckoutOptions(CheckoutOptions);

Construct a CheckoutOptions object from the specified copy.

public CheckoutOptions(StarTeamClientOptions);

Construct a CheckoutOptions object with default options from the View. The following options are assigned values DefaultEOLFormat

public CheckoutOptions(View);

See Also

CheckoutOptions Class | StarTeam Namespace | getEOLFormat | setEOLFormat | getKeywordExpansionEnabled | setKeywordExpansionEnabled | getMarkUnlockedFilesReadOnly | setMarkUnlockedFilesReadOnly | getFileEncoding | setFileEncoding | getOptions | View


CheckoutOptions Constructor (View)

Construct a CheckoutOptions object with default options from the View. The following options are assigned values DefaultEOLFormat

public CheckoutOptions(
View view
);

Parameters

view
a View object where the values of the options are picked up.

See Also

CheckoutOptions Class | StarTeam Namespace | CheckoutOptions Constructor Overload List | getEOLFormat | setEOLFormat | getKeywordExpansionEnabled | setKeywordExpansionEnabled | getMarkUnlockedFilesReadOnly | setMarkUnlockedFilesReadOnly | getFileEncoding | setFileEncoding | getOptions | View


CheckoutOptions Constructor (StarTeamClientOptions)

Construct a CheckoutOptions object from the specified copy.

public CheckoutOptions(
StarTeamClientOptions options
);

Parameters

options
a CheckoutOptions copied from another instance.

See Also

CheckoutOptions Class | StarTeam Namespace | CheckoutOptions Constructor Overload List | getOptions


CheckoutOptions Constructor (CheckoutOptions)

Construct a CheckoutOptions object from the specified copy.

public CheckoutOptions(
CheckoutOptions options
);

Parameters

options
a CheckoutOptions copied from another instance.

See Also

CheckoutOptions Class | StarTeam Namespace | CheckoutOptions Constructor Overload List | getOptions


CheckoutOptions Properties

The properties of the CheckoutOptions class are listed below. For a complete list of CheckoutOptions class members, see the CheckoutOptions Members topic.

Public Instance Properties

BreakLock | [read/write] true if another users lock will be broken during checkout
CheckoutByDate | [read/write] Return the DateTime value to be used for the "checkout by date" option.
CheckoutByLabel | [read/write] Return the Label to be used for the "checkout by Label" option.
CheckoutByPromotionState | [read/write] Return the PromotionState ID value to be used for the "checkout by PromotionState" option.
CheckoutByViewVersion | [read/write] Return the view version value to be used for the "checkout by view version" option.
ContentFilterValue | [read/write] Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.
EOLFormatValue | [read/write] EOLFormat
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
FolderTimeStampNow | [read/write] Return true if current folder time is used as the last modified time; false, otherwise.
ForceCheckout | [read/write] the "Force Checkout" option value, whose default value is false.
IsByDate | [read] Return true if "checkout by date" option is used; false, otherwise.
IsByLabel | [read] Return true if "checkout by Label" option is used; false, otherwise.
IsByPromotionState | [read] Return true if "checkout by PromotionState" option is used; false, otherwise.
IsByViewVersion | [read] Return true if "checkout by view version" option is used; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking out files or the file associated with this CheckoutOptions object.
IsTip | [read] Return true if the tip is used; false, otherwise.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LockTypeValue | [read/write] Return the type of lock to be used when checking out, one of the values supported by Item.LockType.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
RestoreFileOnError | [read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.
TimeStampNow | [read/write] Return true if current time is used as the last modified time; false, otherwise.
UpdateStatus | [read/write] Return true if status information is to be updated after a successful checkout.

See Also

CheckoutOptions Class | StarTeam Namespace


BreakLock Property

Borland StarTeam SDK for .NET

CheckoutOptions.BreakLock Property

[read/write] true if another users lock will be broken during checkout

public virtual Boolean BreakLock {get; set;}

Property Value

true if another users lock will be broken during checkout

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutByDate Property

Borland StarTeam SDK for .NET

CheckoutOptions.CheckoutByDate Property

[read/write] Return the DateTime value to be used for the "checkout by date" option.

public virtual DateTime CheckoutByDate {get; set;}

Property Value

Return the DateTime value to be used for the "checkout by date" option.

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutByLabel Property

Borland StarTeam SDK for .NET

CheckoutOptions.CheckoutByLabel Property

[read/write] Return the Label to be used for the "checkout by Label" option.

public virtual Label CheckoutByLabel {get; set;}

Property Value

Return the Label to be used for the "checkout by Label" option.

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutByPromotionState Property

Borland StarTeam SDK for .NET

CheckoutOptions.CheckoutByPromotionState Property

[read/write] Return the PromotionState ID value to be used for the "checkout by PromotionState" option.

public virtual PromotionState CheckoutByPromotionState {get; set;}

Property Value

Return the PromotionState ID value to be used for the "checkout by PromotionState" option.

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutByViewVersion Property

Borland StarTeam SDK for .NET

CheckoutOptions.CheckoutByViewVersion Property

[read/write] Return the view version value to be used for the "checkout by view version" option.

public virtual Int32 CheckoutByViewVersion {get; set;}

Property Value

Return the view version value to be used for the "checkout by view version" option.

See Also

CheckoutOptions Class | StarTeam Namespace


ContentFilterValue Property

Borland StarTeam SDK for .NET

CheckoutOptions.ContentFilterValue Property

[read/write] Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.

public virtual CheckoutOptions.ContentFilter ContentFilterValue {get; set;}

Property Value

Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.

See Also

CheckoutOptions Class | StarTeam Namespace


EOLFormatValue Property

Borland StarTeam SDK for .NET

CheckoutOptions.EOLFormatValue Property

[read/write] EOLFormat

public virtual File.EOLFormat EOLFormatValue {get; set;}

Property Value

EOLFormat

See Also

CheckoutOptions Class | StarTeam Namespace


FileEncoding Property

Borland StarTeam SDK for .NET

CheckoutOptions.FileEncoding Property

[read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

public virtual Encoding FileEncoding {get; set;}

Property Value

the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

See Also

CheckoutOptions Class | StarTeam Namespace


FolderTimeStampNow Property

Borland StarTeam SDK for .NET

CheckoutOptions.FolderTimeStampNow Property

[read/write] Return true if current folder time is used as the last modified time; false, otherwise.

public virtual Boolean FolderTimeStampNow {get; set;}

Property Value

Return true if current folder time is used as the last modified time; false, otherwise.

See Also

CheckoutOptions Class | StarTeam Namespace


ForceCheckout Property

Borland StarTeam SDK for .NET

CheckoutOptions.ForceCheckout Property

[read/write] the "Force Checkout" option value, whose default value is false.

public virtual Boolean ForceCheckout {get; set;}

Property Value

the "Force Checkout" option value, whose default value is false.

See Also

CheckoutOptions Class | StarTeam Namespace


IsByDate Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsByDate Property

[read] Return true if "checkout by date" option is used; false, otherwise.

public virtual Boolean IsByDate {get;}

Property Value

Return true if "checkout by date" option is used; false, otherwise.

See Also

CheckoutOptions Class | StarTeam Namespace


IsByLabel Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsByLabel Property

[read] Return true if "checkout by Label" option is used; false, otherwise.

public virtual Boolean IsByLabel {get;}

Property Value

Return true if "checkout by Label" option is used; false, otherwise.

See Also

CheckoutOptions Class | StarTeam Namespace


IsByPromotionState Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsByPromotionState Property

[read] Return true if "checkout by PromotionState" option is used; false, otherwise.

public virtual Boolean IsByPromotionState {get;}

Property Value

Return true if "checkout by PromotionState" option is used; false, otherwise.

See Also

CheckoutOptions Class | StarTeam Namespace


IsByViewVersion Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsByViewVersion Property

[read] Return true if "checkout by view version" option is used; false, otherwise.

public virtual Boolean IsByViewVersion {get;}

Property Value

Return true if "checkout by view version" option is used; false, otherwise.

See Also

CheckoutOptions Class | StarTeam Namespace


IsFileSkipped Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsFileSkipped Property

[read/write] whether to skip checking out files or the file associated with this CheckoutOptions object.

public virtual Boolean IsFileSkipped {get; set;}

Property Value

whether to skip checking out files or the file associated with this CheckoutOptions object.

See Also

CheckoutOptions Class | StarTeam Namespace


IsTip Property

Borland StarTeam SDK for .NET

CheckoutOptions.IsTip Property

[read] Return true if the tip is used; false, otherwise.

public virtual Boolean IsTip {get;}

Property Value

Return true if the tip is used; false, otherwise.

See Also

CheckoutOptions Class | StarTeam Namespace


KeywordExpansionEnabled Property

Borland StarTeam SDK for .NET

CheckoutOptions.KeywordExpansionEnabled Property

[read/write] Return true if keyword expansion in text files is enabled; false, otherwise.

public virtual Boolean KeywordExpansionEnabled {get; set;}

Property Value

Return true if keyword expansion in text files is enabled; false, otherwise.

See Also

CheckoutOptions Class | StarTeam Namespace


LockTypeValue Property

Borland StarTeam SDK for .NET

CheckoutOptions.LockTypeValue Property

[read/write] Return the type of lock to be used when checking out, one of the values supported by Item.LockType.

public virtual ViewMember.LockType LockTypeValue {get; set;}

Property Value

Return the type of lock to be used when checking out, one of the values supported by Item.LockType.

See Also

CheckoutOptions Class | StarTeam Namespace


MarkUnlockedFilesReadOnly Property

Borland StarTeam SDK for .NET

CheckoutOptions.MarkUnlockedFilesReadOnly Property

[read/write] option value. Default if not defined: false

public virtual Boolean MarkUnlockedFilesReadOnly {get; set;}

Property Value

option value. Default if not defined: false

See Also

CheckoutOptions Class | StarTeam Namespace


RestoreFileOnError Property

Borland StarTeam SDK for .NET

CheckoutOptions.RestoreFileOnError Property

[read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.

public virtual Boolean RestoreFileOnError {get; set;}

Property Value

Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.

See Also

CheckoutOptions Class | StarTeam Namespace


TimeStampNow Property

Borland StarTeam SDK for .NET

CheckoutOptions.TimeStampNow Property

[read/write] Return true if current time is used as the last modified time; false, otherwise.

public virtual Boolean TimeStampNow {get; set;}

Property Value

Return true if current time is used as the last modified time; false, otherwise.

See Also

CheckoutOptions Class | StarTeam Namespace


UpdateStatus Property

Borland StarTeam SDK for .NET

CheckoutOptions.UpdateStatus Property

[read/write] Return true if status information is to be updated after a successful checkout.

public virtual Boolean UpdateStatus {get; set;}

Property Value

Return true if status information is to be updated after a successful checkout.

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutOptions Methods

The methods of the CheckoutOptions class are listed below. For a complete list of CheckoutOptions class members, see the CheckoutOptions Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCheckoutTip | Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
ToString | Delegate ToString() to com.starteam.CheckoutOptions.

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutOptions.Equals Method

Delegate Equals() to com.starteam.CheckoutOptions.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckoutOptions.Equals(obj).

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutOptions.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckoutOptions.

public override int GetHashCode();

Return Value

com.starteam.CheckoutOptions.GetHashCode().

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutOptions.SetCheckoutTip Method

Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.

public virtual void SetCheckoutTip();

See Also

CheckoutOptions Class | StarTeam Namespace | isTip | setCheckoutByDate | setCheckoutByLabel | setCheckoutByPromotionState


CheckoutOptions.ToString Method

Delegate ToString() to com.starteam.CheckoutOptions.

public override string ToString();

Return Value

com.starteam.CheckoutOptions.ToString()

See Also

CheckoutOptions Class | StarTeam Namespace


CheckoutOptions.ContentFilter Interface

Allows an application to hook into the checkout process at a low level. getOutputStream() is called for each file as it is checked out. OutputStream is the stream where content is written; the application may wrap this stream to transform content as it sees fit.

For a list of all members of this type, see CheckoutOptions.ContentFilter Members.

public interface CheckoutOptions.ContentFilter

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutOptions.ContentFilter Members | StarTeam Namespace


CheckoutOptions.ContentFilter Members

CheckoutOptions.ContentFilter overview

Public Instance Methods

GetOutputStream

See Also

CheckoutOptions.ContentFilter Interface | StarTeam Namespace


CheckoutOptions.ContentFilter Methods

The methods of the CheckoutOptions.ContentFilter interface are listed below. For a complete list of CheckoutOptions.ContentFilter interface members, see the CheckoutOptions.ContentFilter Members topic.

Public Instance Methods

GetOutputStream

See Also

CheckoutOptions.ContentFilter Interface | StarTeam Namespace


CheckoutOptions.ContentFilter.GetOutputStream Method

Stream GetOutputStream(
File file,
Stream stream
);

See Also

CheckoutOptions.ContentFilter Interface | StarTeam Namespace


CheckoutOptions.WebCacheCheckoutOptions Class

Maintains the checkout options used by WebCacheCheckoutManager.

For a list of all members of this type, see CheckoutOptions.WebCacheCheckoutOptions Members.

System.Object
CheckoutOptions.WebCacheCheckoutOptions

public class CheckoutOptions.WebCacheCheckoutOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutOptions.WebCacheCheckoutOptions Members | StarTeam Namespace


CheckoutOptions.WebCacheCheckoutOptions Members

CheckoutOptions.WebCacheCheckoutOptions overview

Public Instance Properties

BreakLock | [read/write] true if another users lock will be broken during checkout
CheckoutByDate | [read/write] Return the DateTime value to be used for the "checkout by date" option.
CheckoutByLabel | [read/write] Return the Label to be used for the "checkout by Label" option.
CheckoutByViewVersion | [read/write] Return the view version value to be used for the "checkout by view version" option.
ContentFilterValue | [read/write] Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.
EOLFormatValue | [read/write] EOLFormat
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
FolderTimeStampNow | [read/write] Return true if current time is used as the last modified time; false, otherwise.
ForceCheckout | [read/write] the "Force Checkout" option value, whose default value is false.
IsByDate | [read] Return true if "checkout by date" option is used; false, otherwise.
IsByLabel | [read] Return true if "checkout by Label" option is used; false, otherwise.
IsByPromotionState | [read] Return true if "checkout by PromotionState" option is used; false, otherwise.
IsByViewVersion | [read] Return true if "checkout by view version" option is used; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking out files or the file associated with this CheckoutOptions object.
IsTip | [read] Return true if the tip is used; false, otherwise.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LockTypeValue | [read/write] Return the type of lock to be used when checking out, one of the values supported by Item.LockType.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
RestoreFileOnError | [read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.
TimeStampNow | [read/write] Return true if current time is used as the last modified time; false, otherwise.
UpdateStatus | [read/write] Return true if status information is to be updated after a successful checkout.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutOptions.WebCacheCheckoutOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutOptions.WebCacheCheckoutOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCheckoutTip | Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
ToString | Delegate ToString() to com.starteam.CheckoutOptions.WebCacheCheckoutOptions.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


CheckoutOptions.WebCacheCheckoutOptions Properties

The properties of the CheckoutOptions.WebCacheCheckoutOptions class are listed below. For a complete list of CheckoutOptions.WebCacheCheckoutOptions class members, see the CheckoutOptions.WebCacheCheckoutOptions Members topic.

Public Instance Properties

BreakLock | [read/write] true if another users lock will be broken during checkout
CheckoutByDate | [read/write] Return the DateTime value to be used for the "checkout by date" option.
CheckoutByLabel | [read/write] Return the Label to be used for the "checkout by Label" option.
CheckoutByViewVersion | [read/write] Return the view version value to be used for the "checkout by view version" option.
ContentFilterValue | [read/write] Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.
EOLFormatValue | [read/write] EOLFormat
FileEncoding | [read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"
FolderTimeStampNow | [read/write] Return true if current time is used as the last modified time; false, otherwise.
ForceCheckout | [read/write] the "Force Checkout" option value, whose default value is false.
IsByDate | [read] Return true if "checkout by date" option is used; false, otherwise.
IsByLabel | [read] Return true if "checkout by Label" option is used; false, otherwise.
IsByPromotionState | [read] Return true if "checkout by PromotionState" option is used; false, otherwise.
IsByViewVersion | [read] Return true if "checkout by view version" option is used; false, otherwise.
IsFileSkipped | [read/write] whether to skip checking out files or the file associated with this CheckoutOptions object.
IsTip | [read] Return true if the tip is used; false, otherwise.
KeywordExpansionEnabled | [read/write] Return true if keyword expansion in text files is enabled; false, otherwise.
LockTypeValue | [read/write] Return the type of lock to be used when checking out, one of the values supported by Item.LockType.
MarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
RestoreFileOnError | [read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.
TimeStampNow | [read/write] Return true if current time is used as the last modified time; false, otherwise.
UpdateStatus | [read/write] Return true if status information is to be updated after a successful checkout.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


BreakLock Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.BreakLock Property

[read/write] true if another users lock will be broken during checkout

public virtual Boolean BreakLock {get; set;}

Property Value

true if another users lock will be broken during checkout

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


CheckoutByDate Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.CheckoutByDate Property

[read/write] Return the DateTime value to be used for the "checkout by date" option.

public virtual DateTime CheckoutByDate {get; set;}

Property Value

Return the DateTime value to be used for the "checkout by date" option.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


CheckoutByLabel Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.CheckoutByLabel Property

[read/write] Return the Label to be used for the "checkout by Label" option.

public virtual Label.WebCacheLabel CheckoutByLabel {get; set;}

Property Value

Return the Label to be used for the "checkout by Label" option.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


CheckoutByViewVersion Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.CheckoutByViewVersion Property

[read/write] Return the view version value to be used for the "checkout by view version" option.

public virtual Int32 CheckoutByViewVersion {get; set;}

Property Value

Return the view version value to be used for the "checkout by view version" option.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


ContentFilterValue Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.ContentFilterValue Property

[read/write] Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.

public virtual CheckoutOptions.ContentFilter ContentFilterValue {get; set;}

Property Value

Return the ContentFilter object to be used after performing keyword expansion, eol conversion, etc.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


EOLFormatValue Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.EOLFormatValue Property

[read/write] EOLFormat

public virtual File.EOLFormat EOLFormatValue {get; set;}

Property Value

EOLFormat

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


FileEncoding Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.FileEncoding Property

[read/write] the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

public virtual Encoding FileEncoding {get; set;}

Property Value

the "File Encoding" option value. Default if not defined: the value of the system property "file.encoding"

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


FolderTimeStampNow Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.FolderTimeStampNow Property

[read/write] Return true if current time is used as the last modified time; false, otherwise.

public virtual Boolean FolderTimeStampNow {get; set;}

Property Value

Return true if current time is used as the last modified time; false, otherwise.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


ForceCheckout Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.ForceCheckout Property

[read/write] the "Force Checkout" option value, whose default value is false.

public virtual Boolean ForceCheckout {get; set;}

Property Value

the "Force Checkout" option value, whose default value is false.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


IsByDate Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.IsByDate Property

[read] Return true if "checkout by date" option is used; false, otherwise.

public virtual Boolean IsByDate {get;}

Property Value

Return true if "checkout by date" option is used; false, otherwise.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


IsByLabel Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.IsByLabel Property

[read] Return true if "checkout by Label" option is used; false, otherwise.

public virtual Boolean IsByLabel {get;}

Property Value

Return true if "checkout by Label" option is used; false, otherwise.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


IsByPromotionState Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.IsByPromotionState Property

[read] Return true if "checkout by PromotionState" option is used; false, otherwise.

public virtual Boolean IsByPromotionState {get;}

Property Value

Return true if "checkout by PromotionState" option is used; false, otherwise.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


IsByViewVersion Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.IsByViewVersion Property

[read] Return true if "checkout by view version" option is used; false, otherwise.

public virtual Boolean IsByViewVersion {get;}

Property Value

Return true if "checkout by view version" option is used; false, otherwise.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


IsFileSkipped Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.IsFileSkipped Property

[read/write] whether to skip checking out files or the file associated with this CheckoutOptions object.

public virtual Boolean IsFileSkipped {get; set;}

Property Value

whether to skip checking out files or the file associated with this CheckoutOptions object.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


IsTip Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.IsTip Property

[read] Return true if the tip is used; false, otherwise.

public virtual Boolean IsTip {get;}

Property Value

Return true if the tip is used; false, otherwise.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


KeywordExpansionEnabled Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.KeywordExpansionEnabled Property

[read/write] Return true if keyword expansion in text files is enabled; false, otherwise.

public virtual Boolean KeywordExpansionEnabled {get; set;}

Property Value

Return true if keyword expansion in text files is enabled; false, otherwise.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


LockTypeValue Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.LockTypeValue Property

[read/write] Return the type of lock to be used when checking out, one of the values supported by Item.LockType.

public virtual ViewMember.LockType LockTypeValue {get; set;}

Property Value

Return the type of lock to be used when checking out, one of the values supported by Item.LockType.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


MarkUnlockedFilesReadOnly Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.MarkUnlockedFilesReadOnly Property

[read/write] option value. Default if not defined: false

public virtual Boolean MarkUnlockedFilesReadOnly {get; set;}

Property Value

option value. Default if not defined: false

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


RestoreFileOnError Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.RestoreFileOnError Property

[read/write] Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.

public virtual Boolean RestoreFileOnError {get; set;}

Property Value

Return True if the previous working file should be restored if an error occurs during a checkout; otherwise, false.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


TimeStampNow Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.TimeStampNow Property

[read/write] Return true if current time is used as the last modified time; false, otherwise.

public virtual Boolean TimeStampNow {get; set;}

Property Value

Return true if current time is used as the last modified time; false, otherwise.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


UpdateStatus Property

Borland StarTeam SDK for .NET

CheckoutOptions.WebCacheCheckoutOptions.UpdateStatus Property

[read/write] Return true if status information is to be updated after a successful checkout.

public virtual Boolean UpdateStatus {get; set;}

Property Value

Return true if status information is to be updated after a successful checkout.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


CheckoutOptions.WebCacheCheckoutOptions Methods

The methods of the CheckoutOptions.WebCacheCheckoutOptions class are listed below. For a complete list of CheckoutOptions.WebCacheCheckoutOptions class members, see the CheckoutOptions.WebCacheCheckoutOptions Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.CheckoutOptions.WebCacheCheckoutOptions.
GetHashCode | Delegate GetHashCode() to com.starteam.CheckoutOptions.WebCacheCheckoutOptions.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCheckoutTip | Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.
ToString | Delegate ToString() to com.starteam.CheckoutOptions.WebCacheCheckoutOptions.

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


CheckoutOptions.WebCacheCheckoutOptions.Equals Method

Delegate Equals() to com.starteam.CheckoutOptions.WebCacheCheckoutOptions.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CheckoutOptions.WebCacheCheckoutOptions.Equals(obj).

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


CheckoutOptions.WebCacheCheckoutOptions.GetHashCode Method

Delegate GetHashCode() to com.starteam.CheckoutOptions.WebCacheCheckoutOptions.

public override int GetHashCode();

Return Value

com.starteam.CheckoutOptions.WebCacheCheckoutOptions.GetHashCode().

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


CheckoutOptions.WebCacheCheckoutOptions.SetCheckoutTip Method

Determines which file revision is checked out. Default is the tip; you can also select a historical revision by label, date or promotion state. Files that don't match (e.g., don't have the given label attached) are skipped.

public virtual void SetCheckoutTip();

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace | isTip | setCheckoutByDate | setCheckoutByLabel | setCheckoutByPromotionState


CheckoutOptions.WebCacheCheckoutOptions.ToString Method

Delegate ToString() to com.starteam.CheckoutOptions.WebCacheCheckoutOptions.

public override string ToString();

Return Value

com.starteam.CheckoutOptions.WebCacheCheckoutOptions.ToString()

See Also

CheckoutOptions.WebCacheCheckoutOptions Class | StarTeam Namespace


ClientContext Class

The ClientContext class contains the necessary information in order to run the SDK on one machine for a client running on a different machine. This is useful, for example, when running an SDK application within a Web server for a remote browser based client. The information in the ClientContext includes a unique client GUID identifier, the address of the client machine, the client's end-of-line convention, whether or not the client treats file names as case sensitive or not and the string used to delimit directory names within an absolute file path. The Platform class has methods for returning those values on the host running the SDK.

For a list of all members of this type, see ClientContext Members.

System.Object
ClientContext

public class ClientContext

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ClientContext Members | StarTeam Namespace


ClientContext Members

ClientContext overview

Public Instance Constructors

ClientContext Overloaded. Initializes a new instance of the ClientContext class.

Public Instance Properties

CaseSensitiveFileNames | [read/write] true if the client treats file names as case sensitive.
DirectoryOverridesValue | [read/write] the directory override information for this client context.
EOL | [read/write] the client machine's end-of-line convention.
FilePathDelimiter | [read/write] the string used to delimit directories in a file path.
HostName | [read] the client machine's host name.
WorkStationID | [read] the workstation GUID identifying the client.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ClientContext.
GetHashCode | Delegate GetHashCode() to com.starteam.ClientContext.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ClientContext.

See Also

ClientContext Class | StarTeam Namespace


ClientContext Constructor

Creates a default client context based on properties of the machine actually running the code.

Overload List

Creates a default client context based on properties of the machine actually running the code.

public ClientContext();

Creates a default client context based on properties of the machine actually running the code but using the specified workstation ID. Normally the workstation ID is read out of an .xml file. Passing in null for the workStationID will read the GUID out of the appropriate .xml file.

public ClientContext(GUID);

public ClientContext(GUID,String,Int32,Boolean,String,ClientContext.DirectoryOverrides);

See Also

ClientContext Class | StarTeam Namespace


ClientContext Constructor ()

Creates a default client context based on properties of the machine actually running the code.

public ClientContext();

See Also

ClientContext Class | StarTeam Namespace | ClientContext Constructor Overload List


ClientContext Constructor (GUID)

Creates a default client context based on properties of the machine actually running the code but using the specified workstation ID. Normally the workstation ID is read out of an .xml file. Passing in null for the workStationID will read the GUID out of the appropriate .xml file.

public ClientContext(
GUID workStationID
);

Parameters

workStationID
the workstation GUID associated with the client, the value may be null

See Also

ClientContext Class | StarTeam Namespace | ClientContext Constructor Overload List


ClientContext Constructor (GUID, String, Int32, Boolean, String, ClientContext#DirectoryOverrides)

public ClientContext(
GUID workStationID,
String hostname,
Int32 eol,
Boolean caseSensitive,
String filePathDelim,
ClientContext.DirectoryOverrides overrides
);

See Also

ClientContext Class | StarTeam Namespace | ClientContext Constructor Overload List


ClientContext Properties

The properties of the ClientContext class are listed below. For a complete list of ClientContext class members, see the ClientContext Members topic.

Public Instance Properties

CaseSensitiveFileNames | [read/write] true if the client treats file names as case sensitive.
DirectoryOverridesValue | [read/write] the directory override information for this client context.
EOL | [read/write] the client machine's end-of-line convention.
FilePathDelimiter | [read/write] the string used to delimit directories in a file path.
HostName | [read] the client machine's host name.
WorkStationID | [read] the workstation GUID identifying the client.

See Also

ClientContext Class | StarTeam Namespace


CaseSensitiveFileNames Property

Borland StarTeam SDK for .NET

ClientContext.CaseSensitiveFileNames Property

[read/write] true if the client treats file names as case sensitive.

public virtual Boolean CaseSensitiveFileNames {get; set;}

Property Value

true if the client treats file names as case sensitive.

See Also

ClientContext Class | StarTeam Namespace


DirectoryOverridesValue Property

Borland StarTeam SDK for .NET

ClientContext.DirectoryOverridesValue Property

[read/write] the directory override information for this client context.

public virtual ClientContext.DirectoryOverrides DirectoryOverridesValue {get; set;}

Property Value

the directory override information for this client context.

See Also

ClientContext Class | StarTeam Namespace


EOL Property

Borland StarTeam SDK for .NET

ClientContext.EOL Property

[read/write] the client machine's end-of-line convention.

public virtual Platform.EOL EOL {get; set;}

Property Value

the client machine's end-of-line convention.

See Also

ClientContext Class | StarTeam Namespace


FilePathDelimiter Property

Borland StarTeam SDK for .NET

ClientContext.FilePathDelimiter Property

[read/write] the string used to delimit directories in a file path.

public virtual String FilePathDelimiter {get; set;}

Property Value

the string used to delimit directories in a file path.

See Also

ClientContext Class | StarTeam Namespace


HostName Property

Borland StarTeam SDK for .NET

ClientContext.HostName Property

[read] the client machine's host name.

public virtual String HostName {get;}

Property Value

the client machine's host name.

See Also

ClientContext Class | StarTeam Namespace


WorkStationID Property

Borland StarTeam SDK for .NET

ClientContext.WorkStationID Property

[read] the workstation GUID identifying the client.

public virtual GUID WorkStationID {get;}

Property Value

the workstation GUID identifying the client.

See Also

ClientContext Class | StarTeam Namespace


ClientContext Methods

The methods of the ClientContext class are listed below. For a complete list of ClientContext class members, see the ClientContext Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ClientContext.
GetHashCode | Delegate GetHashCode() to com.starteam.ClientContext.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ClientContext.

See Also

ClientContext Class | StarTeam Namespace


ClientContext.Equals Method

Delegate Equals() to com.starteam.ClientContext.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ClientContext.Equals(obj).

See Also

ClientContext Class | StarTeam Namespace


ClientContext.GetHashCode Method

Delegate GetHashCode() to com.starteam.ClientContext.

public override int GetHashCode();

Return Value

com.starteam.ClientContext.GetHashCode().

See Also

ClientContext Class | StarTeam Namespace


ClientContext.ToString Method

Delegate ToString() to com.starteam.ClientContext.

public override string ToString();

Return Value

com.starteam.ClientContext.ToString()

See Also

ClientContext Class | StarTeam Namespace


ClientContext.DirectoryOverrides Class

A class that can parse a StarTeam.xml file and work with the view and folder overrides it specifies.

For a list of all members of this type, see ClientContext.DirectoryOverrides Members.

System.Object
ClientContext.DirectoryOverrides

public class ClientContext.DirectoryOverrides

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ClientContext.DirectoryOverrides Members | StarTeam Namespace


ClientContext.DirectoryOverrides Members

ClientContext.DirectoryOverrides overview

Public Instance Constructors

ClientContext.DirectoryOverrides Constructor Create a new instance with no overrides specified.

Public Instance Properties

SourceFile [read] the source file specifying the override information.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ClientContext.DirectoryOverrides.
GetHashCode | Delegate GetHashCode() to com.starteam.ClientContext.DirectoryOverrides.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads the specified .xml file. The parsing is very loose so no errors will occur if it is not really a StarTeam.xml file.
LoadDefault | Loads the default .xml file for the client platform. On Windows this is the value of the "StarTeam" environment variable which is usually "StarTeam.xml".
Reload | Re-loads the .xml file.
ReloadIfNeeded | Re-loads the .xml file only if the file's last modified time stamp has changed.
ToString | Delegate ToString() to com.starteam.ClientContext.DirectoryOverrides.

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides Constructor

Create a new instance with no overrides specified.

public ClientContext.DirectoryOverrides();

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides Properties

The properties of the ClientContext.DirectoryOverrides class are listed below. For a complete list of ClientContext.DirectoryOverrides class members, see the ClientContext.DirectoryOverrides Members topic.

Public Instance Properties

SourceFile [read] the source file specifying the override information.

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


SourceFile Property

Borland StarTeam SDK for .NET

ClientContext.DirectoryOverrides.SourceFile Property

[read] the source file specifying the override information.

public virtual FileInfo SourceFile {get;}

Property Value

the source file specifying the override information.

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides Methods

The methods of the ClientContext.DirectoryOverrides class are listed below. For a complete list of ClientContext.DirectoryOverrides class members, see the ClientContext.DirectoryOverrides Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ClientContext.DirectoryOverrides.
GetHashCode | Delegate GetHashCode() to com.starteam.ClientContext.DirectoryOverrides.
GetType (inherited from Object) | Gets the Type of the current instance.
Load | Loads the specified .xml file. The parsing is very loose so no errors will occur if it is not really a StarTeam.xml file.
LoadDefault | Loads the default .xml file for the client platform. On Windows this is the value of the "StarTeam" environment variable which is usually "StarTeam.xml".
Reload | Re-loads the .xml file.
ReloadIfNeeded | Re-loads the .xml file only if the file's last modified time stamp has changed.
ToString | Delegate ToString() to com.starteam.ClientContext.DirectoryOverrides.

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides.Equals Method

Delegate Equals() to com.starteam.ClientContext.DirectoryOverrides.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ClientContext.DirectoryOverrides.Equals(obj).

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides.GetHashCode Method

Delegate GetHashCode() to com.starteam.ClientContext.DirectoryOverrides.

public override int GetHashCode();

Return Value

com.starteam.ClientContext.DirectoryOverrides.GetHashCode().

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides.Load Method

Loads the specified .xml file. The parsing is very loose so no errors will occur if it is not really a StarTeam.xml file.

public virtual void Load(
FileInfo iniFile
);

Parameters

iniFile
the file to load

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides.LoadDefault Method

Loads the default .xml file for the client platform. On Windows this is the value of the "StarTeam" environment variable which is usually "StarTeam.xml".

public virtual void LoadDefault();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides.Reload Method

Re-loads the .xml file.

public virtual void Reload();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides.ReloadIfNeeded Method

Re-loads the .xml file only if the file's last modified time stamp has changed.

public virtual bool ReloadIfNeeded();

Return Value

true if the file was reloaded

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


ClientContext.DirectoryOverrides.ToString Method

Delegate ToString() to com.starteam.ClientContext.DirectoryOverrides.

public override string ToString();

Return Value

com.starteam.ClientContext.DirectoryOverrides.ToString()

See Also

ClientContext.DirectoryOverrides Class | StarTeam Namespace


CommandProcessor Class

A Command Processor is a class that executes a sequence of commands against a selected server, in the context of a specific project and view. The class maintains a connection to a single view instance

For a list of all members of this type, see CommandProcessor Members.

System.Object
CommandProcessor

public class CommandProcessor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

CommandProcessor Members | StarTeam Namespace


CommandProcessor Members

CommandProcessor overview

Public Static Methods

CanParse Returns true if the specified command can be parsed by this processor

Public Instance Constructors

CommandProcessor Overloaded. Initializes a new instance of the CommandProcessor class.

Public Instance Properties

ExecutedCommands | [read] the LIFO set of all commands executed so far
Folder | [read] the folder within which this command processor is executing commands,
Project | [read] the project within which this command processor is executing commands,
Server | [read] the server against which this command processor is executing commands,
View | [read] the view within which this command processor is executing commands,

Public Instance Methods

CanReturnHeader | Returns true if this Command can return a header along with the results false if this command will never return a header (whether or not it returns results)
CanReturnResults | Returns true if this Command can return a result set of 0 or more rows false if this command will never return any results. (e.g. connect)
Equals | Delegate Equals() to com.starteam.CommandProcessor.
Execute | Executes a command Throws an SDKRuntime exception if the command execution fails The error message will indicate the reason for failure. Underlying exceptions will be chained to this exception
GetHashCode | Delegate GetHashCode() to com.starteam.CommandProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
NewCommandProcessorEventSource |
Parse | Parses the command. throws an SDKRuntimeException if the command cannot be parsed. The error message will attempt to identify the suspect syntax
ToString | Delegate ToString() to com.starteam.CommandProcessor.

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor Constructor

Creates a new Command Processor, ready for execution

Overload List

Creates a new Command Processor, ready for execution

public CommandProcessor();

Create a Command Processor, ready for execution on a given view's foder

public CommandProcessor(Folder);

Create a Command Processor, ready for execution on a given server This constructor is appropriate for client integrations that use meta data queries

public CommandProcessor(Server);

Create a Command Processor, ready for execution on a given view This constructor is appropriate for client integrations that use the 'select' statement to provide form based report generation

public CommandProcessor(View);

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor Constructor ()

Creates a new Command Processor, ready for execution

public CommandProcessor();

See Also

CommandProcessor Class | StarTeam Namespace | CommandProcessor Constructor Overload List


CommandProcessor Constructor (View)

Create a Command Processor, ready for execution on a given view This constructor is appropriate for client integrations that use the 'select' statement to provide form based report generation

public CommandProcessor(
View vw
);

Parameters

vw
the view in whose context the processor will run

See Also

CommandProcessor Class | StarTeam Namespace | CommandProcessor Constructor Overload List


CommandProcessor Constructor (Server)

Create a Command Processor, ready for execution on a given server This constructor is appropriate for client integrations that use meta data queries

public CommandProcessor(
Server s
);

Parameters

s
the server in whose context the processor will run

See Also

CommandProcessor Class | StarTeam Namespace | CommandProcessor Constructor Overload List


CommandProcessor Constructor (Folder)

Create a Command Processor, ready for execution on a given view's foder

public CommandProcessor(
Folder fldr
);

Parameters

fldr
the folder in whose context the processor will run

See Also

CommandProcessor Class | StarTeam Namespace | CommandProcessor Constructor Overload List


CommandProcessor Properties

The properties of the CommandProcessor class are listed below. For a complete list of CommandProcessor class members, see the CommandProcessor Members topic.

Public Instance Properties

ExecutedCommands | [read] the LIFO set of all commands executed so far
Folder | [read] the folder within which this command processor is executing commands,
Project | [read] the project within which this command processor is executing commands,
Server | [read] the server against which this command processor is executing commands,
View | [read] the view within which this command processor is executing commands,

See Also

CommandProcessor Class | StarTeam Namespace


ExecutedCommands Property

Borland StarTeam SDK for .NET

CommandProcessor.ExecutedCommands Property

[read] the LIFO set of all commands executed so far

public virtual String[] ExecutedCommands {get;}

Property Value

the LIFO set of all commands executed so far

See Also

CommandProcessor Class | StarTeam Namespace


Folder Property

Borland StarTeam SDK for .NET

CommandProcessor.Folder Property

[read] the folder within which this command processor is executing commands,

public virtual Folder Folder {get;}

Property Value

the folder within which this command processor is executing commands,

See Also

CommandProcessor Class | StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

CommandProcessor.Project Property

[read] the project within which this command processor is executing commands,

public virtual Project Project {get;}

Property Value

the project within which this command processor is executing commands,

See Also

CommandProcessor Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

CommandProcessor.Server Property

[read] the server against which this command processor is executing commands,

public virtual Server Server {get;}

Property Value

the server against which this command processor is executing commands,

See Also

CommandProcessor Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

CommandProcessor.View Property

[read] the view within which this command processor is executing commands,

public virtual View View {get;}

Property Value

the view within which this command processor is executing commands,

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor Methods

The methods of the CommandProcessor class are listed below. For a complete list of CommandProcessor class members, see the CommandProcessor Members topic.

Public Static Methods

CanParse Returns true if the specified command can be parsed by this processor

Public Instance Methods

CanReturnHeader | Returns true if this Command can return a header along with the results false if this command will never return a header (whether or not it returns results)
CanReturnResults | Returns true if this Command can return a result set of 0 or more rows false if this command will never return any results. (e.g. connect)
Equals | Delegate Equals() to com.starteam.CommandProcessor.
Execute | Executes a command Throws an SDKRuntime exception if the command execution fails The error message will indicate the reason for failure. Underlying exceptions will be chained to this exception
GetHashCode | Delegate GetHashCode() to com.starteam.CommandProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
NewCommandProcessorEventSource |
Parse | Parses the command. throws an SDKRuntimeException if the command cannot be parsed. The error message will attempt to identify the suspect syntax
ToString | Delegate ToString() to com.starteam.CommandProcessor.

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor.CanParse Method

Returns true if the specified command can be parsed by this processor

public static bool CanParse(
String command
);

Parameters

command
the command to be parsed

Return Value

true if the specified command can be parsed by this processor

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor.CanReturnHeader Method

Returns true if this Command can return a header along with the results false if this command will never return a header (whether or not it returns results)

public virtual bool CanReturnHeader();

Return Value

true if this Command can return a header along with the results

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor.CanReturnResults Method

Returns true if this Command can return a result set of 0 or more rows false if this command will never return any results. (e.g. connect)

public virtual bool CanReturnResults();

Return Value

true if this Command can return a result set of 0 or more rows

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor.Equals Method

Delegate Equals() to com.starteam.CommandProcessor.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.CommandProcessor.Equals(obj).

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor.Execute Method

Executes a command Throws an SDKRuntime exception if the command execution fails The error message will indicate the reason for failure. Underlying exceptions will be chained to this exception

public virtual string[][] Execute(
String command
);

Parameters

command
the command to execute

Return Value

String[][] if relevant, tabular results of this command execution, or an empty result set

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor.GetHashCode Method

Delegate GetHashCode() to com.starteam.CommandProcessor.

public override int GetHashCode();

Return Value

com.starteam.CommandProcessor.GetHashCode().

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor.NewCommandProcessorEventSource Method

public CommandProcessorEventSource NewCommandProcessorEventSource();

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor.Parse Method

Parses the command. throws an SDKRuntimeException if the command cannot be parsed. The error message will attempt to identify the suspect syntax

public virtual string[] Parse(
String command
);

Parameters

command
the command whose syntax needs to be validated

Return Value

an array of requested options if successful. The leading - or / character will have been stripped off

See Also

CommandProcessor Class | StarTeam Namespace


CommandProcessor.ToString Method

Delegate ToString() to com.starteam.CommandProcessor.

public override string ToString();

Return Value

com.starteam.CommandProcessor.ToString()

See Also

CommandProcessor Class | StarTeam Namespace


Concept Class

A Concept is a basic unit of content.

For a list of all members of this type, see Concept Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Concept

public class Concept : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Concept Members | StarTeam Namespace


Concept Members

Concept overview

Public Static Methods

Create Create a Concept in the specified parent folder.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
ConceptID | [read] the concept id.
Content | [read/write] the content of this Concept.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the text in the "Description" property for this Concept.
DiagramSource | [read/write] the diagram source of this Concept.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Concept.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Tags | [read/write] the tags, if any attached to this story
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Concept Class | StarTeam Namespace


Concept Properties

The properties of the Concept class are listed below. For a complete list of Concept class members, see the Concept Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
ConceptID | [read] the concept id.
Content | [read/write] the content of this Concept.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the text in the "Description" property for this Concept.
DiagramSource | [read/write] the diagram source of this Concept.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Concept.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Tags | [read/write] the tags, if any attached to this story
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Concept Class | StarTeam Namespace


ConceptID Property

Borland StarTeam SDK for .NET

Concept.ConceptID Property

[read] the concept id.

public virtual Int32 ConceptID {get;}

Property Value

the concept id.

See Also

Concept Class | StarTeam Namespace


Content Property

Borland StarTeam SDK for .NET

Concept.Content Property

[read/write] the content of this Concept.

public virtual Content Content {get; set;}

Property Value

the content of this Concept.

See Also

Concept Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Concept.Description Property

[read/write] the text in the "Description" property for this Concept.

public virtual String Description {get; set;}

Property Value

the text in the "Description" property for this Concept.

See Also

Concept Class | StarTeam Namespace


DiagramSource Property

Borland StarTeam SDK for .NET

Concept.DiagramSource Property

[read/write] the diagram source of this Concept.

public virtual Content DiagramSource {get; set;}

Property Value

the diagram source of this Concept.

See Also

Concept Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Concept.Name Property

[read/write] the Name of this Concept.

public virtual String Name {get; set;}

Property Value

the Name of this Concept.

See Also

Concept Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Concept.Properties Property

[read] the PropertyCollection of its Type

public virtual Concept.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

Concept Class | StarTeam Namespace


Tags Property

Borland StarTeam SDK for .NET

Concept.Tags Property

[read/write] the tags, if any attached to this story

public virtual EnumeratedValue[] Tags {get; set;}

Property Value

the tags, if any attached to this story

See Also

Concept Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Concept.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Concept Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Concept.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Concept Class | StarTeam Namespace


Concept Methods

The methods of the Concept class are listed below. For a complete list of Concept class members, see the Concept Members topic.

Public Static Methods

Create Create a Concept in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Concept Class | StarTeam Namespace


Concept.Create Method

Create a Concept in the specified parent folder.

public static Concept Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Concept Object.

See Also

Concept Class | StarTeam Namespace


Concept.Type Class

Type meta-data (schema) for Concept object instances.

For a list of all members of this type, see Concept.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
Concept.Type

new public class Concept.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Concept.Type Members | StarTeam Namespace


Concept.Type Members

Concept.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Concept.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Concept.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type Properties

The properties of the Concept.Type class are listed below. For a complete list of Concept.Type class members, see the Concept.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Concept.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Concept.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Concept.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Concept.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Concept.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Concept.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Concept.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Concept.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Concept.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Concept.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Concept.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Concept.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Concept.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Concept.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Concept.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Concept.Type.NAME Property

new public static String NAME {get;}

See Also

Concept.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Concept.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Concept.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Concept.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Concept.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Concept.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Concept.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Concept.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Concept.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Concept.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type Methods

The methods of the Concept.Type class are listed below. For a complete list of Concept.Type class members, see the Concept.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Concept.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Concept.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type.Equals Method

Delegate Equals() to com.starteam.Concept.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Concept.Type.Equals(obj).

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Concept.Type.

public override int GetHashCode();

Return Value

com.starteam.Concept.Type.GetHashCode().

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type.ToString Method

Delegate ToString() to com.starteam.Concept.Type.

public override string ToString();

Return Value

com.starteam.Concept.Type.ToString()

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Concept.Type Class | StarTeam Namespace


Concept.Type.ConceptIDProperty Class

The property type of the ConceptID property

For a list of all members of this type, see Concept.Type.ConceptIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Concept.Type.ConceptIDProperty

public class Concept.Type.ConceptIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Concept.Type.ConceptIDProperty Members | StarTeam Namespace


Concept.Type.ConceptIDProperty Members

Concept.Type.ConceptIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Concept.Type.ConceptIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.Type.ConceptIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Concept.Type.ConceptIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Concept.Type.ConceptIDProperty Class | StarTeam Namespace


Concept.Type.ConceptIDProperty Properties

The properties of the Concept.Type.ConceptIDProperty class are listed below. For a complete list of Concept.Type.ConceptIDProperty class members, see the Concept.Type.ConceptIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Concept.Type.ConceptIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Concept.Type.ConceptIDProperty.NAME Property

public static String NAME {get;}

See Also

Concept.Type.ConceptIDProperty Class | StarTeam Namespace


Concept.Type.ConceptIDProperty Methods

The methods of the Concept.Type.ConceptIDProperty class are listed below. For a complete list of Concept.Type.ConceptIDProperty class members, see the Concept.Type.ConceptIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Concept.Type.ConceptIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.Type.ConceptIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Concept.Type.ConceptIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Concept.Type.ConceptIDProperty Class | StarTeam Namespace


Concept.Type.ConceptIDProperty.Equals Method

Delegate Equals() to com.starteam.Concept.Type.ConceptIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Concept.Type.ConceptIDProperty.Equals(obj).

See Also

Concept.Type.ConceptIDProperty Class | StarTeam Namespace


Concept.Type.ConceptIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Concept.Type.ConceptIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Concept.Type.ConceptIDProperty.GetHashCode().

See Also

Concept.Type.ConceptIDProperty Class | StarTeam Namespace


Concept.Type.ConceptIDProperty.ToString Method

Delegate ToString() to com.starteam.Concept.Type.ConceptIDProperty.

public override string ToString();

Return Value

com.starteam.Concept.Type.ConceptIDProperty.ToString()

See Also

Concept.Type.ConceptIDProperty Class | StarTeam Namespace


Concept.Type.ContentProperty Class

The property type of the RichDescription property.

For a list of all members of this type, see Concept.Type.ContentProperty Members.

System.Object
Property
ContentProperty
Concept.Type.ContentProperty

public class Concept.Type.ContentProperty : ContentProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Concept.Type.ContentProperty Members | StarTeam Namespace


Concept.Type.ContentProperty Members

Concept.Type.ContentProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Concept.Type.ContentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.Type.ContentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.Concept.Type.ContentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Concept.Type.ContentProperty Class | StarTeam Namespace


Concept.Type.ContentProperty Properties

The properties of the Concept.Type.ContentProperty class are listed below. For a complete list of Concept.Type.ContentProperty class members, see the Concept.Type.ContentProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Concept.Type.ContentProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Concept.Type.ContentProperty.NAME Property

public static String NAME {get;}

See Also

Concept.Type.ContentProperty Class | StarTeam Namespace


Concept.Type.ContentProperty Methods

The methods of the Concept.Type.ContentProperty class are listed below. For a complete list of Concept.Type.ContentProperty class members, see the Concept.Type.ContentProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Concept.Type.ContentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.Type.ContentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.Concept.Type.ContentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Concept.Type.ContentProperty Class | StarTeam Namespace


Concept.Type.ContentProperty.Equals Method

Delegate Equals() to com.starteam.Concept.Type.ContentProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Concept.Type.ContentProperty.Equals(obj).

See Also

Concept.Type.ContentProperty Class | StarTeam Namespace


Concept.Type.ContentProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Concept.Type.ContentProperty.

public override int GetHashCode();

Return Value

com.starteam.Concept.Type.ContentProperty.GetHashCode().

See Also

Concept.Type.ContentProperty Class | StarTeam Namespace


Concept.Type.ContentProperty.ToString Method

Delegate ToString() to com.starteam.Concept.Type.ContentProperty.

public override string ToString();

Return Value

com.starteam.Concept.Type.ContentProperty.ToString()

See Also

Concept.Type.ContentProperty Class | StarTeam Namespace


Concept.Type.PropertyCollection Class

The PropertyCollection of a Concept

For a list of all members of this type, see Concept.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Concept.Type.PropertyCollection

new public class Concept.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Concept.Type.PropertyCollection Members | StarTeam Namespace


Concept.Type.PropertyCollection Members

Concept.Type.PropertyCollection overview

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONCEPT_ID |
CONFIGURATION_TIME |
CONTENT |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIAGRAM_SOURCE |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAG |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Concept.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Concept.Type.PropertyCollection.

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


Concept.Type.PropertyCollection Properties

The properties of the Concept.Type.PropertyCollection class are listed below. For a complete list of Concept.Type.PropertyCollection class members, see the Concept.Type.PropertyCollection Members topic.

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONCEPT_ID |
CONFIGURATION_TIME |
CONTENT |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIAGRAM_SOURCE |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAG |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


CONCEPT_ID Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.CONCEPT_ID Property

public Concept.Type.ConceptIDProperty CONCEPT_ID {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


CONTENT Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.CONTENT Property

public Concept.Type.ContentProperty CONTENT {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


DIAGRAM_SOURCE Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.DIAGRAM_SOURCE Property

public Item.Type.DiagramSourceProperty DIAGRAM_SOURCE {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


TAG Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.TAG Property

public Item.Type.TagProperty TAG {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.VERSION_METADATA Property

public Item.Type.VersionMetadataProperty VERSION_METADATA {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA_IDS Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.VERSION_METADATA_IDS Property

public Item.Type.VersionMetadataIDsProperty VERSION_METADATA_IDS {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Concept.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


Concept.Type.PropertyCollection Methods

The methods of the Concept.Type.PropertyCollection class are listed below. For a complete list of Concept.Type.PropertyCollection class members, see the Concept.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Concept.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Concept.Type.PropertyCollection.

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


Concept.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Concept.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Concept.Type.PropertyCollection.Equals(obj).

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


Concept.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Concept.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Concept.Type.PropertyCollection.GetHashCode().

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


Concept.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Concept.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Concept.Type.PropertyCollection.ToString()

See Also

Concept.Type.PropertyCollection Class | StarTeam Namespace


Concept.WebCacheConcept Class

Item accessor for cached SDK Concept items contained objects are obtained from the artifact cache

For a list of all members of this type, see Concept.WebCacheConcept Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
Concept.WebCacheConcept

public class Concept.WebCacheConcept : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Concept.WebCacheConcept Members | StarTeam Namespace


Concept.WebCacheConcept Members

Concept.WebCacheConcept overview

Public Static Methods

Create Overloaded.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
ConceptID | [read] the concept id.
Content | [read/write] the content of this Concept.
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this concept.
DiagramSource | [read/write] the diagram source of this Concept.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Tags | [read/write] the tags, if any attached to this story instance
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Concept.WebCacheConcept.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.WebCacheConcept.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Concept.WebCacheConcept.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept Properties

The properties of the Concept.WebCacheConcept class are listed below. For a complete list of Concept.WebCacheConcept class members, see the Concept.WebCacheConcept Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
ConceptID | [read] the concept id.
Content | [read/write] the content of this Concept.
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this concept.
DiagramSource | [read/write] the diagram source of this Concept.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Tags | [read/write] the tags, if any attached to this story instance
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ConceptID Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ConceptID Property

[read] the concept id.

public virtual Int32 ConceptID {get;}

Property Value

the concept id.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Content Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Content Property

[read/write] the content of this Concept.

public virtual Content.WebCacheContent Content {get; set;}

Property Value

the content of this Concept.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Description Property

[read/write] the description of this concept.

public virtual String Description {get; set;}

Property Value

the description of this concept.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


DiagramSource Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.DiagramSource Property

[read/write] the diagram source of this Concept.

public virtual Content.WebCacheContent DiagramSource {get; set;}

Property Value

the diagram source of this Concept.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Name Property

new public virtual String Name {get; set;}

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Tags Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Tags Property

[read/write] the tags, if any attached to this story instance

public virtual EnumeratedValue[] Tags {get; set;}

Property Value

the tags, if any attached to this story instance

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept Methods

The methods of the Concept.WebCacheConcept class are listed below. For a complete list of Concept.WebCacheConcept class members, see the Concept.WebCacheConcept Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Concept.WebCacheConcept.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Concept.WebCacheConcept.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Concept.WebCacheConcept.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Create Method

Overload List

public static WebCacheConcept Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheConcept Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.Create Overload List


Concept.WebCacheConcept.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.Create Overload List


Concept.WebCacheConcept.Equals Method

Delegate Equals() to com.starteam.Concept.WebCacheConcept.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Concept.WebCacheConcept.Equals(obj).

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.GetHashCode Method

Delegate GetHashCode() to com.starteam.Concept.WebCacheConcept.

public override int GetHashCode();

Return Value

com.starteam.Concept.WebCacheConcept.GetHashCode().

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.GetValue Overload List


Concept.WebCacheConcept.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.GetValue Overload List


Concept.WebCacheConcept.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | WebCacheViewMemberCollection


Concept.WebCacheConcept.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.Lock Overload List | WebCacheViewMemberCollection


Concept.WebCacheConcept.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.Lock Overload List


Concept.WebCacheConcept.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | NAME


Concept.WebCacheConcept.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.MoveTo Overload List


Concept.WebCacheConcept.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.MoveTo Overload List


Concept.WebCacheConcept.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | isFloating | isPinned | unpin


Concept.WebCacheConcept.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | WebCacheViewMemberCollection


Concept.WebCacheConcept.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Concept.WebCacheConcept.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.SetValue Overload List


Concept.WebCacheConcept.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | Concept.WebCacheConcept.SetValue Overload List


Concept.WebCacheConcept.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.ToString Method

Delegate ToString() to com.starteam.Concept.WebCacheConcept.

public override string ToString();

Return Value

com.starteam.Concept.WebCacheConcept.ToString()

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


Concept.WebCacheConcept.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | WebCacheViewMemberCollection


Concept.WebCacheConcept.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | isFloating | isPinned | pinTo


Concept.WebCacheConcept.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Concept.WebCacheConcept Class | StarTeam Namespace | WebCacheViewMemberCollection


Concept.WebCacheConcept.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Concept.WebCacheConcept Class | StarTeam Namespace


ConfigFiles Class

All client stored configuration file locations for StarTeam can be found using this class.

For a list of all members of this type, see ConfigFiles Members.

System.Object
ConfigFiles

public class ConfigFiles

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ConfigFiles Members | StarTeam Namespace


ConfigFiles Members

ConfigFiles overview

Public Static Properties

ConnectionManagerPath | [read] The full path to ConnectionManager, or null on non-Windows platforms.
DefaultCentralStatusDirectory | [read] The default location of the client's centralized status directory
NonWindowsConfig | [read]
ServerList | [read] The default location of the client's "starteam-servers.xml" file.
StarTeamXML | [read] The default location of the client's "StarTeam.xml" file.
ViewCompareMergeRootDir | [read] the full path to the View Compare/Merge root folder.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ConfigFiles.
GetHashCode | Delegate GetHashCode() to com.starteam.ConfigFiles.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ConfigFiles.

See Also

ConfigFiles Class | StarTeam Namespace


ConfigFiles Properties

The properties of the ConfigFiles class are listed below. For a complete list of ConfigFiles class members, see the ConfigFiles Members topic.

Public Static Properties

ConnectionManagerPath | [read] The full path to ConnectionManager, or null on non-Windows platforms.
DefaultCentralStatusDirectory | [read] The default location of the client's centralized status directory
NonWindowsConfig | [read]
ServerList | [read] The default location of the client's "starteam-servers.xml" file.
StarTeamXML | [read] The default location of the client's "StarTeam.xml" file.
ViewCompareMergeRootDir | [read] the full path to the View Compare/Merge root folder.

See Also

ConfigFiles Class | StarTeam Namespace


ConnectionManagerPath Property

Borland StarTeam SDK for .NET

ConfigFiles.ConnectionManagerPath Property

[read] The full path to ConnectionManager, or null on non-Windows platforms.

public static FileInfo ConnectionManagerPath {get;}

Property Value

The full path to ConnectionManager, or null on non-Windows platforms.

See Also

ConfigFiles Class | StarTeam Namespace


DefaultCentralStatusDirectory Property

Borland StarTeam SDK for .NET

ConfigFiles.DefaultCentralStatusDirectory Property

[read] The default location of the client's centralized status directory

public static FileInfo DefaultCentralStatusDirectory {get;}

Property Value

The default location of the client's centralized status directory

See Also

ConfigFiles Class | StarTeam Namespace


NonWindowsConfig Property

Borland StarTeam SDK for .NET

ConfigFiles.NonWindowsConfig Property

[read]

public static FileInfo NonWindowsConfig {get;}

See Also

ConfigFiles Class | StarTeam Namespace


ServerList Property

Borland StarTeam SDK for .NET

ConfigFiles.ServerList Property

[read] The default location of the client's "starteam-servers.xml" file.

public static FileInfo ServerList {get;}

Property Value

The default location of the client's "starteam-servers.xml" file.

See Also

ConfigFiles Class | StarTeam Namespace


StarTeamXML Property

Borland StarTeam SDK for .NET

ConfigFiles.StarTeamXML Property

[read] The default location of the client's "StarTeam.xml" file.

public static FileInfo StarTeamXML {get;}

Property Value

The default location of the client's "StarTeam.xml" file.

See Also

ConfigFiles Class | StarTeam Namespace


ViewCompareMergeRootDir Property

Borland StarTeam SDK for .NET

ConfigFiles.ViewCompareMergeRootDir Property

[read] the full path to the View Compare/Merge root folder.

public static FileInfo ViewCompareMergeRootDir {get;}

Property Value

the full path to the View Compare/Merge root folder.

See Also

ConfigFiles Class | StarTeam Namespace


ConfigFiles Methods

The methods of the ConfigFiles class are listed below. For a complete list of ConfigFiles class members, see the ConfigFiles Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ConfigFiles.
GetHashCode | Delegate GetHashCode() to com.starteam.ConfigFiles.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ConfigFiles.

See Also

ConfigFiles Class | StarTeam Namespace


ConfigFiles.Equals Method

Delegate Equals() to com.starteam.ConfigFiles.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ConfigFiles.Equals(obj).

See Also

ConfigFiles Class | StarTeam Namespace


ConfigFiles.GetHashCode Method

Delegate GetHashCode() to com.starteam.ConfigFiles.

public override int GetHashCode();

Return Value

com.starteam.ConfigFiles.GetHashCode().

See Also

ConfigFiles Class | StarTeam Namespace


ConfigFiles.ToString Method

Delegate ToString() to com.starteam.ConfigFiles.

public override string ToString();

Return Value

com.starteam.ConfigFiles.ToString()

See Also

ConfigFiles Class | StarTeam Namespace


ConnectionPool Class

A Connection Pool manages a set of connections targeted at a give StarTeam Server. Typically, one connection (the primary) is used for reading, and pooled connections are available for writing The pool automatically allocates connection on demand Note that the caller is responsible for refreshing the primary session cache and/or other alternate caches which may belong to separate server sessions The model supports multiple connection pools, 1 or more per managed StarTeam server

For a list of all members of this type, see ConnectionPool Members.

System.Object
ConnectionPool

public class ConnectionPool

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ConnectionPool Members | StarTeam Namespace


ConnectionPool Members

ConnectionPool overview

Public Static Methods

Register | Register a server instance with a Connection Pool of writing sessions The specified server will typically be the primary session used for reads Write sessions will be allocated on demand The pool will grow as necessary, but will never shrink Write operations will impersonate the users specified via
Unregister | Release the primary server and all sessions in the connection pool

Public Instance Properties

Server [read] the primary server in the connection pool

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ConnectionPool.
GetHashCode | Delegate GetHashCode() to com.starteam.ConnectionPool.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ConnectionPool.

See Also

ConnectionPool Class | StarTeam Namespace


ConnectionPool Properties

The properties of the ConnectionPool class are listed below. For a complete list of ConnectionPool class members, see the ConnectionPool Members topic.

Public Instance Properties

Server [read] the primary server in the connection pool

See Also

ConnectionPool Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ConnectionPool.Server Property

[read] the primary server in the connection pool

public virtual Server Server {get;}

Property Value

the primary server in the connection pool

See Also

ConnectionPool Class | StarTeam Namespace


ConnectionPool Methods

The methods of the ConnectionPool class are listed below. For a complete list of ConnectionPool class members, see the ConnectionPool Members topic.

Public Static Methods

Register | Register a server instance with a Connection Pool of writing sessions The specified server will typically be the primary session used for reads Write sessions will be allocated on demand The pool will grow as necessary, but will never shrink Write operations will impersonate the users specified via
Unregister | Release the primary server and all sessions in the connection pool

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ConnectionPool.
GetHashCode | Delegate GetHashCode() to com.starteam.ConnectionPool.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ConnectionPool.

See Also

ConnectionPool Class | StarTeam Namespace


ConnectionPool.Equals Method

Delegate Equals() to com.starteam.ConnectionPool.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ConnectionPool.Equals(obj).

See Also

ConnectionPool Class | StarTeam Namespace


ConnectionPool.GetHashCode Method

Delegate GetHashCode() to com.starteam.ConnectionPool.

public override int GetHashCode();

Return Value

com.starteam.ConnectionPool.GetHashCode().

See Also

ConnectionPool Class | StarTeam Namespace


ConnectionPool.Register Method

Register a server instance with a Connection Pool of writing sessions The specified server will typically be the primary session used for reads Write sessions will be allocated on demand The pool will grow as necessary, but will never shrink Write operations will impersonate the users specified via

public static ConnectionPool Register(
ServerInfo si
);

Parameters

si
the server info to register

Return Value

the GUID of the connected server

See Also

ConnectionPool Class | StarTeam Namespace | ViewMember | ViewMember


ConnectionPool.ToString Method

Delegate ToString() to com.starteam.ConnectionPool.

public override string ToString();

Return Value

com.starteam.ConnectionPool.ToString()

See Also

ConnectionPool Class | StarTeam Namespace


ConnectionPool.Unregister Method

Release the primary server and all sessions in the connection pool

public static void Unregister(
ConnectionPool cp
);

Parameters

cp
the Connection Pool to discard

See Also

ConnectionPool Class | StarTeam Namespace


Content Class

The value of a ContentProperty. Arbitrary data with an advisory content type.

For a list of all members of this type, see Content Members.

System.Object
Content

public class Content

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Content Members | StarTeam Namespace


Content Members

Content overview

Public Static Properties

VALUE_NOT_SET

Public Static Methods

FromBytes | Overloaded. Creates a content value from a byte array. The content type is assumed to be CONTENT_TYPE_BINARY.
FromFile | Overloaded. Creates a content value from a file on disk. The content type is assumed to be CONTENT_TYPE_BINARY.
FromStream | Overloaded.
FromText |

Public Instance Properties

ContentType | [read] The content type.
ID | [read] the attachment ID or -1 if this is not content associated with an attachment
MD5 | [read] The MD5 signature of the content data. If the content is being extracted from an attachment, the MD5 and size are unknown until the content is actually written out to a disk file
Name | [read/write] the advisory name (or description) of this content
Size | [read] The size of the content data, in bytes. If the content is being extracted from an attachment, the MD5 and size are unknown until the content is actually written out to a disk file

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Content.
EqualsEx |
GetHashCode | Delegate GetHashCode() to com.starteam.Content.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this Content object can be considered identical to the other
ToBytes |
ToFile | Writes the content data to the given file.
ToStream |
ToString | Delegate ToString() to com.starteam.Content.
ToText |

See Also

Content Class | StarTeam Namespace


Content Properties

The properties of the Content class are listed below. For a complete list of Content class members, see the Content Members topic.

Public Static Properties

VALUE_NOT_SET

Public Instance Properties

ContentType | [read] The content type.
ID | [read] the attachment ID or -1 if this is not content associated with an attachment
MD5 | [read] The MD5 signature of the content data. If the content is being extracted from an attachment, the MD5 and size are unknown until the content is actually written out to a disk file
Name | [read/write] the advisory name (or description) of this content
Size | [read] The size of the content data, in bytes. If the content is being extracted from an attachment, the MD5 and size are unknown until the content is actually written out to a disk file

See Also

Content Class | StarTeam Namespace


ContentType Property

Borland StarTeam SDK for .NET

Content.ContentType Property

[read] The content type.

public virtual Content.Type ContentType {get;}

Property Value

The content type.

See Also

Content Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Content.ID Property

[read] the attachment ID or -1 if this is not content associated with an attachment

public virtual Int32 ID {get;}

Property Value

the attachment ID or -1 if this is not content associated with an attachment

See Also

Content Class | StarTeam Namespace


MD5 Property

Borland StarTeam SDK for .NET

Content.MD5 Property

[read] The MD5 signature of the content data. If the content is being extracted from an attachment, the MD5 and size are unknown until the content is actually written out to a disk file

public virtual MD5 MD5 {get;}

Property Value

The MD5 signature of the content data. If the content is being extracted from an attachment, the MD5 and size are unknown until the content is actually written out to a disk file

See Also

Content Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Content.Name Property

[read/write] the advisory name (or description) of this content

public virtual String Name {get; set;}

Property Value

the advisory name (or description) of this content

See Also

Content Class | StarTeam Namespace


Size Property

Borland StarTeam SDK for .NET

Content.Size Property

[read] The size of the content data, in bytes. If the content is being extracted from an attachment, the MD5 and size are unknown until the content is actually written out to a disk file

public virtual Int64 Size {get;}

Property Value

The size of the content data, in bytes. If the content is being extracted from an attachment, the MD5 and size are unknown until the content is actually written out to a disk file

See Also

Content Class | StarTeam Namespace


VALUE_NOT_SET Property

Borland StarTeam SDK for .NET

Content.VALUE_NOT_SET Property

public static Content VALUE_NOT_SET {get;}

Property Value

The "not set" value.

See Also

Content Class | StarTeam Namespace


Content Methods

The methods of the Content class are listed below. For a complete list of Content class members, see the Content Members topic.

Public Static Methods

FromBytes | Overloaded. Creates a content value from a byte array. The content type is assumed to be CONTENT_TYPE_BINARY.
FromFile | Overloaded. Creates a content value from a file on disk. The content type is assumed to be CONTENT_TYPE_BINARY.
FromStream | Overloaded.
FromText |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Content.
EqualsEx |
GetHashCode | Delegate GetHashCode() to com.starteam.Content.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this Content object can be considered identical to the other
ToBytes |
ToFile | Writes the content data to the given file.
ToStream |
ToString | Delegate ToString() to com.starteam.Content.
ToText |

See Also

Content Class | StarTeam Namespace


Content.Equals Method

Delegate Equals() to com.starteam.Content.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Content.Equals(obj).

See Also

Content Class | StarTeam Namespace


Content.EqualsEx Method

public virtual bool EqualsEx(
Content c
);

Parameters

c

See Also

Content Class | StarTeam Namespace


FromBytes Method

Borland StarTeam SDK for .NET

Content.FromBytes Method

Overload List

public static Content FromBytes(Byte[],Content.Type,String);

Creates a content value from a byte array. The content type is assumed to be CONTENT_TYPE_BINARY.

public static Content FromBytes(Byte[],String);

See Also

Content Class | StarTeam Namespace


Content.FromBytes Method (Byte[], Content#Type, String)

public static Content FromBytes(
Byte[] data,
Content.Type contentType,
String name
);

See Also

Content Class | StarTeam Namespace | Content.FromBytes Overload List


Content.FromBytes Method (Byte[], String)

Creates a content value from a byte array. The content type is assumed to be CONTENT_TYPE_BINARY.

public static Content FromBytes(
Byte[] data,
String name
);

Parameters

data
The byte array representing the content data.
name
An advisory name for the content; e.g.training.doc

Return Value

A new content value.

See Also

Content Class | StarTeam Namespace | Content.FromBytes Overload List


FromFile Method

Borland StarTeam SDK for .NET

Content.FromFile Method

Creates a content value from a file on disk. The content type is assumed to be CONTENT_TYPE_BINARY.

Overload List

Creates a content value from a file on disk. The content type is assumed to be CONTENT_TYPE_BINARY.

public static Content FromFile(FileInfo);

public static Content FromFile(FileInfo,Content.Type,String);

See Also

Content Class | StarTeam Namespace


Content.FromFile Method (FileInfo)

Creates a content value from a file on disk. The content type is assumed to be CONTENT_TYPE_BINARY.

public static Content FromFile(
FileInfo file
);

Parameters

file
The file containing the content data. The file name is used as the advisory name of the content

Return Value

A new content value.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException

See Also

Content Class | StarTeam Namespace | Content.FromFile Overload List


Content.FromFile Method (FileInfo, Content#Type, String)

public static Content FromFile(
FileInfo file,
Content.Type contentType,
String name
);

See Also

Content Class | StarTeam Namespace | Content.FromFile Overload List


FromStream Method

Borland StarTeam SDK for .NET

Content.FromStream Method

Overload List

public static Content FromStream(Stream,Content.Type,String);

public static Content FromStream(Stream,String);

See Also

Content Class | StarTeam Namespace


Content.FromStream Method (Stream, Content#Type, String)

public static Content FromStream(
Stream stream,
Content.Type contentType,
String name
);

See Also

Content Class | StarTeam Namespace | Content.FromStream Overload List


Content.FromStream Method (Stream, String)

public static Content FromStream(
Stream stream,
String name
);

See Also

Content Class | StarTeam Namespace | Content.FromStream Overload List


Content.FromText Method

public static Content FromText(
String data,
Content.Type contentType,
Encoding enc
);

See Also

Content Class | StarTeam Namespace


Content.GetHashCode Method

Delegate GetHashCode() to com.starteam.Content.

public override int GetHashCode();

Return Value

com.starteam.Content.GetHashCode().

See Also

Content Class | StarTeam Namespace


Content.IsEqualTo Method

returns true if this Content object can be considered identical to the other

public virtual bool IsEqualTo(
Content c
);

Parameters

c
the Content to compare against

Return Value

true if the two can be considered functionally identical

See Also

Content Class | StarTeam Namespace


Content.ToBytes Method

public virtual byte[] ToBytes();

Return Value

The content data as an array of bytes.

See Also

Content Class | StarTeam Namespace


Content.ToFile Method

Writes the content data to the given file.

public virtual void ToFile(
FileInfo file
);

Parameters

file
The file to which the data is written.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException

See Also

Content Class | StarTeam Namespace


Content.ToStream Method

public virtual void ToStream(
Stream stream
);

See Also

Content Class | StarTeam Namespace


Content.ToString Method

Delegate ToString() to com.starteam.Content.

public override string ToString();

Return Value

com.starteam.Content.ToString()

See Also

Content Class | StarTeam Namespace


Content.ToText Method

public virtual string ToText();

See Also

Content Class | StarTeam Namespace


Content.AcceptedTypes Class

This class represents an Accept request-header field. It provides methods to parse an Accept request-header field string into individual components.

For a list of all members of this type, see Content.AcceptedTypes Members.

System.Object
Content.AcceptedTypes

public class Content.AcceptedTypes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Content.AcceptedTypes Members | StarTeam Namespace


Content.AcceptedTypes Members

Content.AcceptedTypes overview

Public Static Methods

FromString | Creates a AcceptedContentTypes from a string representation of a content-type.
ToString | Overloaded.

Public Instance Constructors

Content.AcceptedTypes Constructor

Public Instance Properties

ContentTypes [read] Content.Type[] the array of Content.Type objects contained in this class.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Content.AcceptedTypes.
GetHashCode | Delegate GetHashCode() to com.starteam.Content.AcceptedTypes.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAccepted |
ToString | Overloaded. Delegate ToString() to com.starteam.Content.AcceptedTypes.

See Also

Content.AcceptedTypes Class | StarTeam Namespace


Content.AcceptedTypes Constructor

public Content.AcceptedTypes(
Type[] contentTypes
);

See Also

Content.AcceptedTypes Class | StarTeam Namespace


Content.AcceptedTypes Properties

The properties of the Content.AcceptedTypes class are listed below. For a complete list of Content.AcceptedTypes class members, see the Content.AcceptedTypes Members topic.

Public Instance Properties

ContentTypes [read] Content.Type[] the array of Content.Type objects contained in this class.

See Also

Content.AcceptedTypes Class | StarTeam Namespace


ContentTypes Property

Borland StarTeam SDK for .NET

Content.AcceptedTypes.ContentTypes Property

[read] Content.Type[] the array of Content.Type objects contained in this class.

public virtual Type[] ContentTypes {get;}

Property Value

Content.Type[] the array of Content.Type objects contained in this class.

See Also

Content.AcceptedTypes Class | StarTeam Namespace


Content.AcceptedTypes Methods

The methods of the Content.AcceptedTypes class are listed below. For a complete list of Content.AcceptedTypes class members, see the Content.AcceptedTypes Members topic.

Public Static Methods

FromString | Creates a AcceptedContentTypes from a string representation of a content-type.
ToString | Overloaded.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Content.AcceptedTypes.
GetHashCode | Delegate GetHashCode() to com.starteam.Content.AcceptedTypes.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAccepted |
ToString | Overloaded. Delegate ToString() to com.starteam.Content.AcceptedTypes.

See Also

Content.AcceptedTypes Class | StarTeam Namespace


Content.AcceptedTypes.Equals Method

Delegate Equals() to com.starteam.Content.AcceptedTypes.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Content.AcceptedTypes.Equals(obj).

See Also

Content.AcceptedTypes Class | StarTeam Namespace


Content.AcceptedTypes.FromString Method

Creates a AcceptedContentTypes from a string representation of a content-type.

public static AcceptedTypes FromString(
String s
);

Parameters

s
String the Content-Type string.

Return Value

A new AcceptedContentTypes.

See Also

Content.AcceptedTypes Class | StarTeam Namespace


Content.AcceptedTypes.GetHashCode Method

Delegate GetHashCode() to com.starteam.Content.AcceptedTypes.

public override int GetHashCode();

Return Value

com.starteam.Content.AcceptedTypes.GetHashCode().

See Also

Content.AcceptedTypes Class | StarTeam Namespace


Content.AcceptedTypes.IsAccepted Method

public virtual bool IsAccepted(
Content.Type type
);

See Also

Content.AcceptedTypes Class | StarTeam Namespace


ToString Method

Borland StarTeam SDK for .NET

Content.AcceptedTypes.ToString Method

Delegate ToString() to com.starteam.Content.AcceptedTypes.

Overload List

Delegate ToString() to com.starteam.Content.AcceptedTypes.

public override string ToString();

public static string ToString(Content.AcceptedTypes);

See Also

Content.AcceptedTypes Class | StarTeam Namespace


Content.AcceptedTypes.ToString Method ()

Delegate ToString() to com.starteam.Content.AcceptedTypes.

public override string ToString();

Return Value

com.starteam.Content.AcceptedTypes.ToString()

See Also

Content.AcceptedTypes Class | StarTeam Namespace | Content.AcceptedTypes.ToString Overload List


Content.AcceptedTypes.ToString Method (Content#AcceptedTypes)

public static string ToString(
Content.AcceptedTypes act
);

See Also

Content.AcceptedTypes Class | StarTeam Namespace | Content.AcceptedTypes.ToString Overload List


Content.Type Class

This class represents a MIME Content-Type value. It provides methods to parse a Content-Type string into individual components and to generate a MIME style Content-Type string.

For a list of all members of this type, see Content.Type Members.

System.Object
Content.Type

public class Content.Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Content.Type Members | StarTeam Namespace


Content.Type Members

Content.Type overview

Public Static Properties

ANY_TEXT
ANY_TYPE
BINARY
HTML_TEXT
PLAIN_TEXT

Public Static Methods

FromString | Creates a Content.Type from a string representation of a content-type.
ToString | Overloaded.

Public Instance Constructors

Content.Type Constructor Constructor.

Public Instance Properties

BaseType | [read] The MIME type string, without the parameters.
PrimaryType | [read] String the primary type.
SubType | [read] String the sub type.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Content.Type.
GetHashCode | Delegate GetHashCode() to com.starteam.Content.Type.
GetParameter | Return the specified parameter value. Returns null if this parameter is absent.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
Match | Overloaded. Match with the specified content-type string. This method compares only the primaryType and subType. The parameters of both operands are ignored. For example, this method will return true when comparing the Content.Type for "text/plain" with "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the Content.Type for "text/plain" with "text/*"
SetParameter | Return a Content.Type object that has the specified parameter added. If the specified parameter exists, then it is replaced in the return ContentTyppe object.
ToString | Overloaded. Delegate ToString() to com.starteam.Content.Type.

See Also

Content.Type Class | StarTeam Namespace


Content.Type Constructor

Constructor.

public Content.Type(
String primaryType,
String subType
);

Parameters

primaryType
String the primary type
subType
String the subtype

See Also

Content.Type Class | StarTeam Namespace


Content.Type Properties

The properties of the Content.Type class are listed below. For a complete list of Content.Type class members, see the Content.Type Members topic.

Public Static Properties

ANY_TEXT
ANY_TYPE
BINARY
HTML_TEXT
PLAIN_TEXT

Public Instance Properties

BaseType | [read] The MIME type string, without the parameters.
PrimaryType | [read] String the primary type.
SubType | [read] String the sub type.

See Also

Content.Type Class | StarTeam Namespace


ANY_TEXT Property

Borland StarTeam SDK for .NET

Content.Type.ANY_TEXT Property

public static Content.Type ANY_TEXT {get;}

Property Value

Content-Type: text/*

See Also

Content.Type Class | StarTeam Namespace


ANY_TYPE Property

Borland StarTeam SDK for .NET

Content.Type.ANY_TYPE Property

public static String ANY_TYPE {get;}

See Also

Content.Type Class | StarTeam Namespace


BaseType Property

Borland StarTeam SDK for .NET

Content.Type.BaseType Property

[read] The MIME type string, without the parameters.

public virtual String BaseType {get;}

Property Value

The MIME type string, without the parameters.

See Also

Content.Type Class | StarTeam Namespace


BINARY Property

Borland StarTeam SDK for .NET

Content.Type.BINARY Property

public static Content.Type BINARY {get;}

Property Value

Content-Type: application/octet-stream

See Also

Content.Type Class | StarTeam Namespace


HTML_TEXT Property

Borland StarTeam SDK for .NET

Content.Type.HTML_TEXT Property

public static Content.Type HTML_TEXT {get;}

Property Value

Content-Type: text/html

See Also

Content.Type Class | StarTeam Namespace


PLAIN_TEXT Property

Borland StarTeam SDK for .NET

Content.Type.PLAIN_TEXT Property

public static Content.Type PLAIN_TEXT {get;}

Property Value

Content-Type: text/plain

See Also

Content.Type Class | StarTeam Namespace


PrimaryType Property

Borland StarTeam SDK for .NET

Content.Type.PrimaryType Property

[read] String the primary type.

public virtual String PrimaryType {get;}

Property Value

String the primary type.

See Also

Content.Type Class | StarTeam Namespace


SubType Property

Borland StarTeam SDK for .NET

Content.Type.SubType Property

[read] String the sub type.

public virtual String SubType {get;}

Property Value

String the sub type.

See Also

Content.Type Class | StarTeam Namespace


Content.Type Methods

The methods of the Content.Type class are listed below. For a complete list of Content.Type class members, see the Content.Type Members topic.

Public Static Methods

FromString | Creates a Content.Type from a string representation of a content-type.
ToString | Overloaded.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Content.Type.
GetHashCode | Delegate GetHashCode() to com.starteam.Content.Type.
GetParameter | Return the specified parameter value. Returns null if this parameter is absent.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
Match | Overloaded. Match with the specified content-type string. This method compares only the primaryType and subType. The parameters of both operands are ignored. For example, this method will return true when comparing the Content.Type for "text/plain" with "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the Content.Type for "text/plain" with "text/*"
SetParameter | Return a Content.Type object that has the specified parameter added. If the specified parameter exists, then it is replaced in the return ContentTyppe object.
ToString | Overloaded. Delegate ToString() to com.starteam.Content.Type.

See Also

Content.Type Class | StarTeam Namespace


Content.Type.Equals Method

Delegate Equals() to com.starteam.Content.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Content.Type.Equals(obj).

See Also

Content.Type Class | StarTeam Namespace


Content.Type.FromString Method

Creates a Content.Type from a string representation of a content-type.

public static Type FromString(
String s
);

Parameters

s
String the Content-Type string.

Return Value

A new Content.Type.

See Also

Content.Type Class | StarTeam Namespace


Content.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Content.Type.

public override int GetHashCode();

Return Value

com.starteam.Content.Type.GetHashCode().

See Also

Content.Type Class | StarTeam Namespace


Content.Type.GetParameter Method

Return the specified parameter value. Returns null if this parameter is absent.

public virtual string GetParameter(
String name
);

Parameters

name
String the parameter whose value is requested

Return Value

String the specified parameter value. Returns null if this parameter is absent.

See Also

Content.Type Class | StarTeam Namespace


Content.Type.IsEqualTo Method

public virtual bool IsEqualTo(
Content.Type contentType
);

See Also

Content.Type Class | StarTeam Namespace


Match Method

Borland StarTeam SDK for .NET

Content.Type.Match Method

Overload List

public virtual bool Match(Content.Type);

Match with the specified content-type string. This method compares only the primaryType and subType. The parameters of both operands are ignored. For example, this method will return true when comparing the Content.Type for "text/plain" with "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the Content.Type for "text/plain" with "text/*"

public virtual bool Match(String);

See Also

Content.Type Class | StarTeam Namespace


Content.Type.Match Method (Content#Type)

public virtual bool Match(
Content.Type cType
);

See Also

Content.Type Class | StarTeam Namespace | Content.Type.Match Overload List


Content.Type.Match Method (String)

Match with the specified content-type string. This method compares only the primaryType and subType. The parameters of both operands are ignored. For example, this method will return true when comparing the Content.Type for "text/plain" with "text/plain; charset=foobar". If the subType of either operand is the special character '*', then the subtype is ignored during the match. For example, this method will return true when comparing the Content.Type for "text/plain" with "text/*"

public virtual bool Match(
String s
);

Parameters

s
String the string representation of the content type to match

Return Value

boolean true if the specified string matches this type

See Also

Content.Type Class | StarTeam Namespace | Content.Type.Match Overload List


Content.Type.SetParameter Method

Return a Content.Type object that has the specified parameter added. If the specified parameter exists, then it is replaced in the return ContentTyppe object.

public virtual Type SetParameter(
String name,
String value
);

Parameters

name
String
value
String

Return Value

Content.Type

See Also

Content.Type Class | StarTeam Namespace


ToString Method

Borland StarTeam SDK for .NET

Content.Type.ToString Method

Delegate ToString() to com.starteam.Content.Type.

Overload List

Delegate ToString() to com.starteam.Content.Type.

public override string ToString();

public static string ToString(Content.Type);

See Also

Content.Type Class | StarTeam Namespace


Content.Type.ToString Method ()

Delegate ToString() to com.starteam.Content.Type.

public override string ToString();

Return Value

com.starteam.Content.Type.ToString()

See Also

Content.Type Class | StarTeam Namespace | Content.Type.ToString Overload List


Content.Type.ToString Method (Content#Type)

public static string ToString(
Content.Type contentType
);

See Also

Content.Type Class | StarTeam Namespace | Content.Type.ToString Overload List


Content.WebCacheContent Class

Content accessor for cached SDK content contained objects are obtained from the artifact cache

For a list of all members of this type, see Content.WebCacheContent Members.

System.Object
Content.WebCacheContent

public class Content.WebCacheContent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Content.WebCacheContent Members | StarTeam Namespace


Content.WebCacheContent Members

Content.WebCacheContent overview

Public Static Methods

FromBytes Overloaded.

Public Instance Properties

ContentType | [read/write] The content type.
ID | [read] the attachment ID or -1 if this is not content associated with an attachment
MD5 | [read] The MD5 signature of the content data.
Name | [read/write] the advisory name (or description) of this content
Size | [read] The size of the content data, in bytes.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Content.WebCacheContent.
GetHashCode | Delegate GetHashCode() to com.starteam.Content.WebCacheContent.
GetType (inherited from Object) | Gets the Type of the current instance.
ToBytes | Given Content from the cache, return a byte[] containing the content data specific to the provided Content object
ToString | Delegate ToString() to com.starteam.Content.WebCacheContent.

See Also

Content.WebCacheContent Class | StarTeam Namespace


Content.WebCacheContent Properties

The properties of the Content.WebCacheContent class are listed below. For a complete list of Content.WebCacheContent class members, see the Content.WebCacheContent Members topic.

Public Instance Properties

ContentType | [read/write] The content type.
ID | [read] the attachment ID or -1 if this is not content associated with an attachment
MD5 | [read] The MD5 signature of the content data.
Name | [read/write] the advisory name (or description) of this content
Size | [read] The size of the content data, in bytes.

See Also

Content.WebCacheContent Class | StarTeam Namespace


ContentType Property

Borland StarTeam SDK for .NET

Content.WebCacheContent.ContentType Property

[read/write] The content type.

public virtual Content.Type ContentType {get; set;}

Property Value

The content type.

See Also

Content.WebCacheContent Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Content.WebCacheContent.ID Property

[read] the attachment ID or -1 if this is not content associated with an attachment

public virtual Int32 ID {get;}

Property Value

the attachment ID or -1 if this is not content associated with an attachment

See Also

Content.WebCacheContent Class | StarTeam Namespace


MD5 Property

Borland StarTeam SDK for .NET

Content.WebCacheContent.MD5 Property

[read] The MD5 signature of the content data.

public virtual MD5 MD5 {get;}

Property Value

The MD5 signature of the content data.

See Also

Content.WebCacheContent Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Content.WebCacheContent.Name Property

[read/write] the advisory name (or description) of this content

public virtual String Name {get; set;}

Property Value

the advisory name (or description) of this content

See Also

Content.WebCacheContent Class | StarTeam Namespace


Size Property

Borland StarTeam SDK for .NET

Content.WebCacheContent.Size Property

[read] The size of the content data, in bytes.

public virtual Int64 Size {get;}

Property Value

The size of the content data, in bytes.

See Also

Content.WebCacheContent Class | StarTeam Namespace


Content.WebCacheContent Methods

The methods of the Content.WebCacheContent class are listed below. For a complete list of Content.WebCacheContent class members, see the Content.WebCacheContent Members topic.

Public Static Methods

FromBytes Overloaded.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Content.WebCacheContent.
GetHashCode | Delegate GetHashCode() to com.starteam.Content.WebCacheContent.
GetType (inherited from Object) | Gets the Type of the current instance.
ToBytes | Given Content from the cache, return a byte[] containing the content data specific to the provided Content object
ToString | Delegate ToString() to com.starteam.Content.WebCacheContent.

See Also

Content.WebCacheContent Class | StarTeam Namespace


Content.WebCacheContent.Equals Method

Delegate Equals() to com.starteam.Content.WebCacheContent.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Content.WebCacheContent.Equals(obj).

See Also

Content.WebCacheContent Class | StarTeam Namespace


FromBytes Method

Borland StarTeam SDK for .NET

Content.WebCacheContent.FromBytes Method

Overload List

public static WebCacheContent FromBytes(ArtifactCacheManager.Context,Byte[]);

public static WebCacheContent FromBytes(ArtifactCacheManager.Context,Byte[],Content.Type);

See Also

Content.WebCacheContent Class | StarTeam Namespace


Content.WebCacheContent.FromBytes Method (ArtifactCacheManager#Context, Byte[])

public static WebCacheContent FromBytes(
ArtifactCacheManager.Context cntxt,
Byte[] bytes
);

See Also

Content.WebCacheContent Class | StarTeam Namespace | Content.WebCacheContent.FromBytes Overload List


Content.WebCacheContent.FromBytes Method (ArtifactCacheManager#Context, Byte[], Content#Type)

public static WebCacheContent FromBytes(
ArtifactCacheManager.Context cntxt,
Byte[] bytes,
Content.Type type
);

See Also

Content.WebCacheContent Class | StarTeam Namespace | Content.WebCacheContent.FromBytes Overload List


Content.WebCacheContent.GetHashCode Method

Delegate GetHashCode() to com.starteam.Content.WebCacheContent.

public override int GetHashCode();

Return Value

com.starteam.Content.WebCacheContent.GetHashCode().

See Also

Content.WebCacheContent Class | StarTeam Namespace


Content.WebCacheContent.ToBytes Method

Given Content from the cache, return a byte[] containing the content data specific to the provided Content object

public virtual byte[] ToBytes();

Return Value

a byte[] containing Content data

See Also

Content.WebCacheContent Class | StarTeam Namespace


Content.WebCacheContent.ToString Method

Delegate ToString() to com.starteam.Content.WebCacheContent.

public override string ToString();

Return Value

com.starteam.Content.WebCacheContent.ToString()

See Also

Content.WebCacheContent Class | StarTeam Namespace


ContentProperty Class

This class represents a property whose value is arbitrary content.

For a list of all members of this type, see ContentProperty Members.

System.Object
Property
ContentProperty
Derived types

public class ContentProperty : Property

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ContentProperty Members | StarTeam Namespace


ContentProperty Members

ContentProperty overview

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ContentProperty Class | StarTeam Namespace


ContentProperty Properties

The properties of the ContentProperty class are listed below. For a complete list of ContentProperty class members, see the ContentProperty Members topic.

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ContentProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

ContentProperty.DefaultValue Property

[read/write] Content

new public virtual Content DefaultValue {get; set;}

Property Value

Content

See Also

ContentProperty Class | StarTeam Namespace


ContentProperty Methods

The methods of the ContentProperty class are listed below. For a complete list of ContentProperty class members, see the ContentProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ContentProperty Class | StarTeam Namespace


ContentProperty.HasDisplayValue Method

Returns true if this property has meaningful display values that may be included, for example, in an item table.

public virtual bool HasDisplayValue();

Return Value

boolean true if this property has meaningful display values

See Also

ContentProperty Class | StarTeam Namespace


ContentProperty.ToContent Method

Converts a property value to the type that is exposed by default to client applications.

Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.

public virtual Content ToContent(
Object value
);

Parameters

value
Object the object to be converted to a Content.

Return Value

The content equivalent of the Object.

See Also

ContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see ContentProperty.WebCacheContentProperty Members.

System.Object
Property.WebCacheProperty
ContentProperty.WebCacheContentProperty

public class ContentProperty.WebCacheContentProperty : WebCacheProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ContentProperty.WebCacheContentProperty Members | StarTeam Namespace


ContentProperty.WebCacheContentProperty Members

ContentProperty.WebCacheContentProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] Content
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ContentProperty.WebCacheContentProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ContentProperty.WebCacheContentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ContentProperty.WebCacheContentProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty Properties

The properties of the ContentProperty.WebCacheContentProperty class are listed below. For a complete list of ContentProperty.WebCacheContentProperty class members, see the ContentProperty.WebCacheContentProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] Content
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.DefaultValue Property

[read/write] Content

new public virtual Content.WebCacheContent DefaultValue {get; set;}

Property Value

Content

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.Name Property

new public virtual String Name {get;}

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

ContentProperty.WebCacheContentProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty Methods

The methods of the ContentProperty.WebCacheContentProperty class are listed below. For a complete list of ContentProperty.WebCacheContentProperty class members, see the ContentProperty.WebCacheContentProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ContentProperty.WebCacheContentProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ContentProperty.WebCacheContentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ContentProperty.WebCacheContentProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.Equals Method

Delegate Equals() to com.starteam.ContentProperty.WebCacheContentProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ContentProperty.WebCacheContentProperty.Equals(obj).

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ContentProperty.WebCacheContentProperty.

public override int GetHashCode();

Return Value

com.starteam.ContentProperty.WebCacheContentProperty.GetHashCode().

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.ToString Method

Delegate ToString() to com.starteam.ContentProperty.WebCacheContentProperty.

public override string ToString();

Return Value

com.starteam.ContentProperty.WebCacheContentProperty.ToString()

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


ContentProperty.WebCacheContentProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

ContentProperty.WebCacheContentProperty Class | StarTeam Namespace


DateProperty Class

This class represents a property whose value is a java.util.Date.

For a list of all members of this type, see DateProperty Members.

System.Object
Property
ScalarProperty
DateProperty
Derived types

public class DateProperty : ScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

DateProperty Members | StarTeam Namespace


DateProperty Members

DateProperty overview

Public Static Properties

MAX_VALUE
MIN_VALUE
VALUE_NOT_SET

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] the maximum Date value for this Property
MinValue | Overloaded. [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

DateProperty Class | StarTeam Namespace


DateProperty Properties

The properties of the DateProperty class are listed below. For a complete list of DateProperty class members, see the DateProperty Members topic.

Public Static Properties

MAX_VALUE
MIN_VALUE
VALUE_NOT_SET

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] the maximum Date value for this Property
MinValue | Overloaded. [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

DateProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

DateProperty.DefaultValue Property

[read/write] the default Date value for this Property

new public virtual Date DefaultValue {get; set;}

Property Value

the default Date value for this Property

See Also

DateProperty Class | StarTeam Namespace


MAX_VALUE Property

Borland StarTeam SDK for .NET

DateProperty.MAX_VALUE Property

public static Date MAX_VALUE {get;}

Property Value

11:59:59 P.M., December 31, 4636 A.D.

See Also

DateProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

DateProperty.MaxValue Property

[read/write] the maximum Date value for this Property

new public virtual Date MaxValue {get; set;}

Property Value

the maximum Date value for this Property

See Also

DateProperty Class | StarTeam Namespace


MIN_VALUE Property

Borland StarTeam SDK for .NET

DateProperty.MIN_VALUE Property

public static Date MIN_VALUE {get;}

Property Value

Jan 1, 1900 AD 12:00:00

See Also

DateProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

DateProperty.MinValue Property

[read/write] the minimum Date value for this Property

new public virtual Date MinValue {get; set;}

Property Value

the minimum Date value for this Property

See Also

DateProperty Class | StarTeam Namespace


VALUE_NOT_SET Property

Borland StarTeam SDK for .NET

DateProperty.VALUE_NOT_SET Property

public static Date VALUE_NOT_SET {get;}

Property Value

Date used in some properties to indicate this date value has not been set.

See Also

DateProperty Class | StarTeam Namespace


DateProperty Methods

The methods of the DateProperty class are listed below. For a complete list of DateProperty class members, see the DateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

DateProperty Class | StarTeam Namespace


NewQueryPart Method

Borland StarTeam SDK for .NET

DateProperty.NewQueryPart Method

Overload List

public virtual QueryPart NewQueryPart(QueryPart.Relation,Date);

public virtual QueryPart NewQueryPart(QueryPart.Relation,TimeSpan);

See Also

DateProperty Class | StarTeam Namespace


DateProperty.NewQueryPart Method (QueryPart#Relation, Date)

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
Date value
);

See Also

DateProperty Class | StarTeam Namespace | DateProperty.NewQueryPart Overload List


DateProperty.NewQueryPart Method (QueryPart#Relation, TimeSpan)

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
TimeSpan value
);

See Also

DateProperty Class | StarTeam Namespace | DateProperty.NewQueryPart Overload List


DateProperty.WebCacheDateProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see DateProperty.WebCacheDateProperty Members.

System.Object
Property.WebCacheProperty
ScalarProperty.WebCacheScalarProperty
DateProperty.WebCacheDateProperty

public class DateProperty.WebCacheDateProperty : WebCacheScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

DateProperty.WebCacheDateProperty Members | StarTeam Namespace


DateProperty.WebCacheDateProperty Members

DateProperty.WebCacheDateProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] the default Date value for this Property
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] the maximum Date value for this Property
MinValue | [read/write] the minimum Date value for this Property
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.DateProperty.WebCacheDateProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.DateProperty.WebCacheDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart | Overloaded.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.DateProperty.WebCacheDateProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty Properties

The properties of the DateProperty.WebCacheDateProperty class are listed below. For a complete list of DateProperty.WebCacheDateProperty class members, see the DateProperty.WebCacheDateProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] the default Date value for this Property
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] the maximum Date value for this Property
MinValue | [read/write] the minimum Date value for this Property
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.DefaultValue Property

[read/write] the default Date value for this Property

new public virtual Date DefaultValue {get; set;}

Property Value

the default Date value for this Property

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.MaxValue Property

[read/write] the maximum Date value for this Property

public virtual Date MaxValue {get; set;}

Property Value

the maximum Date value for this Property

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.MinValue Property

[read/write] the minimum Date value for this Property

public virtual Date MinValue {get; set;}

Property Value

the minimum Date value for this Property

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.Name Property

new public virtual String Name {get;}

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty Methods

The methods of the DateProperty.WebCacheDateProperty class are listed below. For a complete list of DateProperty.WebCacheDateProperty class members, see the DateProperty.WebCacheDateProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.DateProperty.WebCacheDateProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.DateProperty.WebCacheDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart | Overloaded.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.DateProperty.WebCacheDateProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.Equals Method

Delegate Equals() to com.starteam.DateProperty.WebCacheDateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.DateProperty.WebCacheDateProperty.Equals(obj).

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.DateProperty.WebCacheDateProperty.

public override int GetHashCode();

Return Value

com.starteam.DateProperty.WebCacheDateProperty.GetHashCode().

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


NewQueryPart Method

Borland StarTeam SDK for .NET

DateProperty.WebCacheDateProperty.NewQueryPart Method

Overload List

public virtual WebCacheQueryPart NewQueryPart(QueryPart.Relation,Date);

public virtual WebCacheQueryPart NewQueryPart(QueryPart.Relation,TimeSpan);

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.NewQueryPart Method (QueryPart#Relation, Date)

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
Date value
);

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace | DateProperty.WebCacheDateProperty.NewQueryPart Overload List


DateProperty.WebCacheDateProperty.NewQueryPart Method (QueryPart#Relation, TimeSpan)

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
TimeSpan value
);

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace | DateProperty.WebCacheDateProperty.NewQueryPart Overload List


DateProperty.WebCacheDateProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.ToString Method

Delegate ToString() to com.starteam.DateProperty.WebCacheDateProperty.

public override string ToString();

Return Value

com.starteam.DateProperty.WebCacheDateProperty.ToString()

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateProperty.WebCacheDateProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

DateProperty.WebCacheDateProperty Class | StarTeam Namespace


DateTimeProperty Class

This class represents a property whose value is a DateTime.

For a list of all members of this type, see DateTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Derived types

public class DateTimeProperty : ScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

DateTimeProperty Members | StarTeam Namespace


DateTimeProperty Members

DateTimeProperty overview

Public Static Properties

MAX_VALUE
MIN_VALUE
VALUE_NOT_SET

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] the maximum DateTime value for this Property
MinValue | Overloaded. [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

DateTimeProperty Class | StarTeam Namespace


DateTimeProperty Properties

The properties of the DateTimeProperty class are listed below. For a complete list of DateTimeProperty class members, see the DateTimeProperty Members topic.

Public Static Properties

MAX_VALUE
MIN_VALUE
VALUE_NOT_SET

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] the maximum DateTime value for this Property
MinValue | Overloaded. [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

DateTimeProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

DateTimeProperty.DefaultValue Property

[read/write] the default DateTime value for this Property

new public virtual DateTime DefaultValue {get; set;}

Property Value

the default DateTime value for this Property

See Also

DateTimeProperty Class | StarTeam Namespace


MAX_VALUE Property

Borland StarTeam SDK for .NET

DateTimeProperty.MAX_VALUE Property

public static DateTime MAX_VALUE {get;}

See Also

DateTimeProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

DateTimeProperty.MaxValue Property

[read/write] the maximum DateTime value for this Property

new public virtual DateTime MaxValue {get; set;}

Property Value

the maximum DateTime value for this Property

See Also

DateTimeProperty Class | StarTeam Namespace


MIN_VALUE Property

Borland StarTeam SDK for .NET

DateTimeProperty.MIN_VALUE Property

public static DateTime MIN_VALUE {get;}

See Also

DateTimeProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

DateTimeProperty.MinValue Property

[read/write] the minimum DateTime value for this Property

new public virtual DateTime MinValue {get; set;}

Property Value

the minimum DateTime value for this Property

See Also

DateTimeProperty Class | StarTeam Namespace


VALUE_NOT_SET Property

Borland StarTeam SDK for .NET

DateTimeProperty.VALUE_NOT_SET Property

public static DateTime VALUE_NOT_SET {get;}

See Also

DateTimeProperty Class | StarTeam Namespace


DateTimeProperty Methods

The methods of the DateTimeProperty class are listed below. For a complete list of DateTimeProperty class members, see the DateTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

DateTimeProperty Class | StarTeam Namespace


NewQueryPart Method

Borland StarTeam SDK for .NET

DateTimeProperty.NewQueryPart Method

Overload List

public virtual QueryPart NewQueryPart(QueryPart.Relation,DateTime);

public virtual QueryPart NewQueryPart(QueryPart.Relation,TimeSpan);

See Also

DateTimeProperty Class | StarTeam Namespace


DateTimeProperty.NewQueryPart Method (QueryPart#Relation, DateTime)

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
DateTime value
);

See Also

DateTimeProperty Class | StarTeam Namespace | DateTimeProperty.NewQueryPart Overload List


DateTimeProperty.NewQueryPart Method (QueryPart#Relation, TimeSpan)

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
TimeSpan value
);

See Also

DateTimeProperty Class | StarTeam Namespace | DateTimeProperty.NewQueryPart Overload List


DateTimeProperty.WebCacheDateTimeProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see DateTimeProperty.WebCacheDateTimeProperty Members.

System.Object
Property.WebCacheProperty
ScalarProperty.WebCacheScalarProperty
DateTimeProperty.WebCacheDateTimeProperty

public class DateTimeProperty.WebCacheDateTimeProperty : WebCacheScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

DateTimeProperty.WebCacheDateTimeProperty Members | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty Members

DateTimeProperty.WebCacheDateTimeProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] the default DateTime value for this Property
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] the maximum DateTime value for this Property
MinValue | [read/write] the minimum DateTime value for this Property
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.DateTimeProperty.WebCacheDateTimeProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.DateTimeProperty.WebCacheDateTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart | Overloaded.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.DateTimeProperty.WebCacheDateTimeProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty Properties

The properties of the DateTimeProperty.WebCacheDateTimeProperty class are listed below. For a complete list of DateTimeProperty.WebCacheDateTimeProperty class members, see the DateTimeProperty.WebCacheDateTimeProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] the default DateTime value for this Property
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] the maximum DateTime value for this Property
MinValue | [read/write] the minimum DateTime value for this Property
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.DefaultValue Property

[read/write] the default DateTime value for this Property

new public virtual DateTime DefaultValue {get; set;}

Property Value

the default DateTime value for this Property

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.MaxValue Property

[read/write] the maximum DateTime value for this Property

public virtual DateTime MaxValue {get; set;}

Property Value

the maximum DateTime value for this Property

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.MinValue Property

[read/write] the minimum DateTime value for this Property

public virtual DateTime MinValue {get; set;}

Property Value

the minimum DateTime value for this Property

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.Name Property

new public virtual String Name {get;}

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty Methods

The methods of the DateTimeProperty.WebCacheDateTimeProperty class are listed below. For a complete list of DateTimeProperty.WebCacheDateTimeProperty class members, see the DateTimeProperty.WebCacheDateTimeProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.DateTimeProperty.WebCacheDateTimeProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.DateTimeProperty.WebCacheDateTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart | Overloaded.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.DateTimeProperty.WebCacheDateTimeProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.Equals Method

Delegate Equals() to com.starteam.DateTimeProperty.WebCacheDateTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.DateTimeProperty.WebCacheDateTimeProperty.Equals(obj).

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.DateTimeProperty.WebCacheDateTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.DateTimeProperty.WebCacheDateTimeProperty.GetHashCode().

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


NewQueryPart Method

Borland StarTeam SDK for .NET

DateTimeProperty.WebCacheDateTimeProperty.NewQueryPart Method

Overload List

public virtual WebCacheQueryPart NewQueryPart(QueryPart.Relation,DateTime);

public virtual WebCacheQueryPart NewQueryPart(QueryPart.Relation,TimeSpan);

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.NewQueryPart Method (QueryPart#Relation, DateTime)

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
DateTime value
);

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace | DateTimeProperty.WebCacheDateTimeProperty.NewQueryPart Overload List


DateTimeProperty.WebCacheDateTimeProperty.NewQueryPart Method (QueryPart#Relation, TimeSpan)

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
TimeSpan value
);

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace | DateTimeProperty.WebCacheDateTimeProperty.NewQueryPart Overload List


DateTimeProperty.WebCacheDateTimeProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.ToString Method

Delegate ToString() to com.starteam.DateTimeProperty.WebCacheDateTimeProperty.

public override string ToString();

Return Value

com.starteam.DateTimeProperty.WebCacheDateTimeProperty.ToString()

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DateTimeProperty.WebCacheDateTimeProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

DateTimeProperty.WebCacheDateTimeProperty Class | StarTeam Namespace


DoubleProperty Class

This class represents a property whose value is a double.

For a list of all members of this type, see DoubleProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Derived types

public class DoubleProperty : ScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

DoubleProperty Members | StarTeam Namespace


DoubleProperty Members

DoubleProperty overview

Public Static Properties

MAX_VALUE
MIN_VALUE

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] double
MinValue | Overloaded. [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToTimeSpanProperty | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

DoubleProperty Class | StarTeam Namespace


DoubleProperty Properties

The properties of the DoubleProperty class are listed below. For a complete list of DoubleProperty class members, see the DoubleProperty Members topic.

Public Static Properties

MAX_VALUE
MIN_VALUE

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] double
MinValue | Overloaded. [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

DoubleProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

DoubleProperty.DefaultValue Property

[read/write] the default double value

new public virtual Double DefaultValue {get; set;}

Property Value

the default double value

See Also

DoubleProperty Class | StarTeam Namespace


IsRollupProperty Property

Borland StarTeam SDK for .NET

DoubleProperty.IsRollupProperty Property

[read/write] true if this Double Property can be rolled up

public virtual Boolean IsRollupProperty {get; set;}

Property Value

true if this Double Property can be rolled up

See Also

DoubleProperty Class | StarTeam Namespace


MAX_VALUE Property

Borland StarTeam SDK for .NET

DoubleProperty.MAX_VALUE Property

public static Double MAX_VALUE {get;}

See Also

DoubleProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

DoubleProperty.MaxValue Property

[read/write] double

new public virtual Double MaxValue {get; set;}

Property Value

double

See Also

DoubleProperty Class | StarTeam Namespace


MIN_VALUE Property

Borland StarTeam SDK for .NET

DoubleProperty.MIN_VALUE Property

public static Double MIN_VALUE {get;}

See Also

DoubleProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

DoubleProperty.MinValue Property

[read/write] double

new public virtual Double MinValue {get; set;}

Property Value

double

See Also

DoubleProperty Class | StarTeam Namespace


DoubleProperty Methods

The methods of the DoubleProperty class are listed below. For a complete list of DoubleProperty class members, see the DoubleProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToTimeSpanProperty | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

DoubleProperty Class | StarTeam Namespace


DoubleProperty.NewQueryPart Method

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
Double value
);

See Also

DoubleProperty Class | StarTeam Namespace


DoubleProperty.ToTimeSpanProperty Method

Converts this DoubleProperty to a TimeSpanProperty.

The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.

public virtual TimeSpanProperty ToTimeSpanProperty(
TimeSpan units
);

Parameters

units
The amount of time represented by the value 1.0, as stored in the repository

Return Value

The converted TimeSpanProperty.

See Also

DoubleProperty Class | StarTeam Namespace | TimeSpanProperty | update


DoubleProperty.WebCacheDoubleProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see DoubleProperty.WebCacheDoubleProperty Members.

System.Object
Property.WebCacheProperty
ScalarProperty.WebCacheScalarProperty
DoubleProperty.WebCacheDoubleProperty

public class DoubleProperty.WebCacheDoubleProperty : WebCacheScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

DoubleProperty.WebCacheDoubleProperty Members | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty Members

DoubleProperty.WebCacheDoubleProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] the default double value
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Double Property can be rolled up
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] double
MinValue | [read/write] double
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.DoubleProperty.WebCacheDoubleProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.DoubleProperty.WebCacheDoubleProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.DoubleProperty.WebCacheDoubleProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty Properties

The properties of the DoubleProperty.WebCacheDoubleProperty class are listed below. For a complete list of DoubleProperty.WebCacheDoubleProperty class members, see the DoubleProperty.WebCacheDoubleProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] the default double value
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Double Property can be rolled up
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] double
MinValue | [read/write] double
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.DefaultValue Property

[read/write] the default double value

new public virtual Double DefaultValue {get; set;}

Property Value

the default double value

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsRollupProperty Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsRollupProperty Property

[read/write] true if this Double Property can be rolled up

public virtual Boolean IsRollupProperty {get; set;}

Property Value

true if this Double Property can be rolled up

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.MaxValue Property

[read/write] double

public virtual Double MaxValue {get; set;}

Property Value

double

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.MinValue Property

[read/write] double

public virtual Double MinValue {get; set;}

Property Value

double

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.Name Property

new public virtual String Name {get;}

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

DoubleProperty.WebCacheDoubleProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty Methods

The methods of the DoubleProperty.WebCacheDoubleProperty class are listed below. For a complete list of DoubleProperty.WebCacheDoubleProperty class members, see the DoubleProperty.WebCacheDoubleProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.DoubleProperty.WebCacheDoubleProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.DoubleProperty.WebCacheDoubleProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.DoubleProperty.WebCacheDoubleProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.Equals Method

Delegate Equals() to com.starteam.DoubleProperty.WebCacheDoubleProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.DoubleProperty.WebCacheDoubleProperty.Equals(obj).

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.DoubleProperty.WebCacheDoubleProperty.

public override int GetHashCode();

Return Value

com.starteam.DoubleProperty.WebCacheDoubleProperty.GetHashCode().

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.NewQueryPart Method

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
Double value
);

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.ToString Method

Delegate ToString() to com.starteam.DoubleProperty.WebCacheDoubleProperty.

public override string ToString();

Return Value

com.starteam.DoubleProperty.WebCacheDoubleProperty.ToString()

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


DoubleProperty.WebCacheDoubleProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

DoubleProperty.WebCacheDoubleProperty Class | StarTeam Namespace


EffectiveACE Class

An Access Control Entry (ACE) in an Effective Access Control List (ACL).

An EffectiveACE may be an ACE that is explicitly listed in the ACL for an object or for its parent container, or may be implied by group permissions that have been defined, or by object ownership rules, or by the StarTeam access test algorithm itself.

Each EffectiveACE provides information about its origin, including a description in human-readable form.

EffectiveACEs are important with respect to explaining the results of an access test.

For a list of all members of this type, see EffectiveACE Members.

System.Object
ACE
EffectiveACE

public class EffectiveACE : ACE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

EffectiveACE Members | StarTeam Namespace


EffectiveACE Members

EffectiveACE overview

Public Instance Properties

Container | [read] The parent container whose ACL defined this EffectiveACE, or null if this is not an EffectiveACE that was defined in one of the object's parent containers.
Description | [read] A description of this EffectiveACE, explaining its origin in human-readable form.
Group | [read] The Group to which this EffectiveACE applies, or null if this EffectiveACE applies to a specific user instead of a group.
IsExplicitACE | [read] true if this EffectiveACE is explicitly represented in an ACL on the object or one of its parent containers.
IsFromContainerACL | [read] true if this is an EffectiveACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers, and false otherwise.
IsFromGroupPrivileges | [read] true if this is an EffectiveACE that is implied by group privileges, and false otherwise.
IsFromMissingACE | [read] true if this EffectiveACE is implicit in the StarTeam access control algorithm, which dictates that if a given permission is not explicitly specified in an ACL, then access is denied by default.
IsFromMissingACL | [read] true if this EffectiveACE is implicit in the StarTeam access control algorithm, which dictates that if there is no ACL defined on an object or on any parent container, then access is granted by default.
IsFromObjectACL | [read] true if this is an EffectiveACE that is explicitly defined in the object's Access Control List (ACL), and false otherwise.
IsFromObjectOwnership | [read] true if this is an EffectiveACE that is implied by object ownership rules, and false otherwise.
IsGranted (inherited from ACE) | [read/write] true if the permissions are granted and false if denied.
IsGroup (inherited from ACE) | [read] true if this ACE represents a group.
IsImpliedACE | [read] true if this is an implied EffectiveACE that is not explicitly represented in an object or container-level ACL.
Name | [read] The name of the user or group to which this EffectiveACE applies.
Object | [read] The securable object to which this EffectiveACE applies, or null if this EffectiveACE does not apply to a specific securable object.
ObjectType | [read] The type of securable object to which this EffectiveACE applies, or null if this EffectiveACE was not defined in a container-level ACL, and does not apply to a specific securable object.
Permissions (inherited from ACE) | [read] the permissions for this ACE.
Principal (inherited from ACE) | [read] the principal(user or group) for this entry.
User | [read] The User to which this EffectiveACE applies, or null if this EffectiveACE applies to a group instead of a specific user.

Public Instance Methods

AddPermission (inherited from ACE) | Adds the specified permission to this entry.
Equals (inherited from ACE) | Delegate Equals() to com.starteam.ACE.
GetHashCode (inherited from ACE) | Delegate GetHashCode() to com.starteam.ACE.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermission (inherited from ACE) | Returns true if the specified permission is a part of this entry.
RemovePermission (inherited from ACE) | Removes the specified permission from this entry.
ToString (inherited from ACE) | Delegate ToString() to com.starteam.ACE.

See Also

EffectiveACE Class | StarTeam Namespace


EffectiveACE Properties

The properties of the EffectiveACE class are listed below. For a complete list of EffectiveACE class members, see the EffectiveACE Members topic.

Public Instance Properties

Container | [read] The parent container whose ACL defined this EffectiveACE, or null if this is not an EffectiveACE that was defined in one of the object's parent containers.
Description | [read] A description of this EffectiveACE, explaining its origin in human-readable form.
Group | [read] The Group to which this EffectiveACE applies, or null if this EffectiveACE applies to a specific user instead of a group.
IsExplicitACE | [read] true if this EffectiveACE is explicitly represented in an ACL on the object or one of its parent containers.
IsFromContainerACL | [read] true if this is an EffectiveACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers, and false otherwise.
IsFromGroupPrivileges | [read] true if this is an EffectiveACE that is implied by group privileges, and false otherwise.
IsFromMissingACE | [read] true if this EffectiveACE is implicit in the StarTeam access control algorithm, which dictates that if a given permission is not explicitly specified in an ACL, then access is denied by default.
IsFromMissingACL | [read] true if this EffectiveACE is implicit in the StarTeam access control algorithm, which dictates that if there is no ACL defined on an object or on any parent container, then access is granted by default.
IsFromObjectACL | [read] true if this is an EffectiveACE that is explicitly defined in the object's Access Control List (ACL), and false otherwise.
IsFromObjectOwnership | [read] true if this is an EffectiveACE that is implied by object ownership rules, and false otherwise.
IsGranted (inherited from ACE) | [read/write] true if the permissions are granted and false if denied.
IsGroup (inherited from ACE) | [read] true if this ACE represents a group.
IsImpliedACE | [read] true if this is an implied EffectiveACE that is not explicitly represented in an object or container-level ACL.
Name | [read] The name of the user or group to which this EffectiveACE applies.
Object | [read] The securable object to which this EffectiveACE applies, or null if this EffectiveACE does not apply to a specific securable object.
ObjectType | [read] The type of securable object to which this EffectiveACE applies, or null if this EffectiveACE was not defined in a container-level ACL, and does not apply to a specific securable object.
Permissions (inherited from ACE) | [read] the permissions for this ACE.
Principal (inherited from ACE) | [read] the principal(user or group) for this entry.
User | [read] The User to which this EffectiveACE applies, or null if this EffectiveACE applies to a group instead of a specific user.

See Also

EffectiveACE Class | StarTeam Namespace


Container Property

Borland StarTeam SDK for .NET

EffectiveACE.Container Property

[read] The parent container whose ACL defined this EffectiveACE, or null if this is not an EffectiveACE that was defined in one of the object's parent containers.

public virtual ISecurableContainer Container {get;}

Property Value

The parent container whose ACL defined this EffectiveACE, or null if this is not an EffectiveACE that was defined in one of the object's parent containers.

See Also

EffectiveACE Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

EffectiveACE.Description Property

[read] A description of this EffectiveACE, explaining its origin in human-readable form.

public virtual String Description {get;}

Property Value

A description of this EffectiveACE, explaining its origin in human-readable form.

See Also

EffectiveACE Class | StarTeam Namespace


Group Property

Borland StarTeam SDK for .NET

EffectiveACE.Group Property

[read] The Group to which this EffectiveACE applies, or null if this EffectiveACE applies to a specific user instead of a group.

public virtual Group Group {get;}

Property Value

The Group to which this EffectiveACE applies, or null if this EffectiveACE applies to a specific user instead of a group.

See Also

EffectiveACE Class | StarTeam Namespace


IsExplicitACE Property

Borland StarTeam SDK for .NET

EffectiveACE.IsExplicitACE Property

[read] true if this EffectiveACE is explicitly represented in an ACL on the object or one of its parent containers.

public virtual Boolean IsExplicitACE {get;}

Property Value

true if this EffectiveACE is explicitly represented in an ACL on the object or one of its parent containers.

See Also

EffectiveACE Class | StarTeam Namespace


IsFromContainerACL Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromContainerACL Property

[read] true if this is an EffectiveACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers, and false otherwise.

public virtual Boolean IsFromContainerACL {get;}

Property Value

true if this is an EffectiveACE that is explicitly defined in the Access Control List (ACL) of one of the object's parent containers, and false otherwise.

See Also

EffectiveACE Class | StarTeam Namespace


IsFromGroupPrivileges Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromGroupPrivileges Property

[read] true if this is an EffectiveACE that is implied by group privileges, and false otherwise.

public virtual Boolean IsFromGroupPrivileges {get;}

Property Value

true if this is an EffectiveACE that is implied by group privileges, and false otherwise.

See Also

EffectiveACE Class | StarTeam Namespace


IsFromMissingACE Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromMissingACE Property

[read] true if this EffectiveACE is implicit in the StarTeam access control algorithm, which dictates that if a given permission is not explicitly specified in an ACL, then access is denied by default.

public virtual Boolean IsFromMissingACE {get;}

Property Value

true if this EffectiveACE is implicit in the StarTeam access control algorithm, which dictates that if a given permission is not explicitly specified in an ACL, then access is denied by default.

See Also

EffectiveACE Class | StarTeam Namespace


IsFromMissingACL Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromMissingACL Property

[read] true if this EffectiveACE is implicit in the StarTeam access control algorithm, which dictates that if there is no ACL defined on an object or on any parent container, then access is granted by default.

public virtual Boolean IsFromMissingACL {get;}

Property Value

true if this EffectiveACE is implicit in the StarTeam access control algorithm, which dictates that if there is no ACL defined on an object or on any parent container, then access is granted by default.

See Also

EffectiveACE Class | StarTeam Namespace


IsFromObjectACL Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromObjectACL Property

[read] true if this is an EffectiveACE that is explicitly defined in the object's Access Control List (ACL), and false otherwise.

public virtual Boolean IsFromObjectACL {get;}

Property Value

true if this is an EffectiveACE that is explicitly defined in the object's Access Control List (ACL), and false otherwise.

See Also

EffectiveACE Class | StarTeam Namespace


IsFromObjectOwnership Property

Borland StarTeam SDK for .NET

EffectiveACE.IsFromObjectOwnership Property

[read] true if this is an EffectiveACE that is implied by object ownership rules, and false otherwise.

public virtual Boolean IsFromObjectOwnership {get;}

Property Value

true if this is an EffectiveACE that is implied by object ownership rules, and false otherwise.

See Also

EffectiveACE Class | StarTeam Namespace


IsImpliedACE Property

Borland StarTeam SDK for .NET

EffectiveACE.IsImpliedACE Property

[read] true if this is an implied EffectiveACE that is not explicitly represented in an object or container-level ACL.

public virtual Boolean IsImpliedACE {get;}

Property Value

true if this is an implied EffectiveACE that is not explicitly represented in an object or container-level ACL.

See Also

EffectiveACE Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

EffectiveACE.Name Property

[read] The name of the user or group to which this EffectiveACE applies.

public virtual String Name {get;}

Property Value

The name of the user or group to which this EffectiveACE applies.

See Also

EffectiveACE Class | StarTeam Namespace


Object Property

Borland StarTeam SDK for .NET

EffectiveACE.Object Property

[read] The securable object to which this EffectiveACE applies, or null if this EffectiveACE does not apply to a specific securable object.

public virtual ISecurable Object {get;}

Property Value

The securable object to which this EffectiveACE applies, or null if this EffectiveACE does not apply to a specific securable object.

See Also

EffectiveACE Class | StarTeam Namespace


ObjectType Property

Borland StarTeam SDK for .NET

EffectiveACE.ObjectType Property

[read] The type of securable object to which this EffectiveACE applies, or null if this EffectiveACE was not defined in a container-level ACL, and does not apply to a specific securable object.

public virtual Type ObjectType {get;}

Property Value

The type of securable object to which this EffectiveACE applies, or null if this EffectiveACE was not defined in a container-level ACL, and does not apply to a specific securable object.

See Also

EffectiveACE Class | StarTeam Namespace


User Property

Borland StarTeam SDK for .NET

EffectiveACE.User Property

[read] The User to which this EffectiveACE applies, or null if this EffectiveACE applies to a group instead of a specific user.

public virtual User User {get;}

Property Value

The User to which this EffectiveACE applies, or null if this EffectiveACE applies to a group instead of a specific user.

See Also

EffectiveACE Class | StarTeam Namespace


EnumeratedProperty Class

This class represents a property whose value is an enumeration Historically, enumerations were single select, i.e. only a single enumerated value could be sent to or received from the starteam server, in the context of an EnumeratedProperty. However, from StarTeam server 12.0 on, the server supports multi select enumerated lists. i.e. an application may create a custom multi-select enumerated property and send/receive more than one enumerations as the value of the property for the artifact For consistency, the SDK api {@link TypedResource#getValue(Property)} always returns an array of EnumeratedValue's, whether the property type is single or multi-select. For single select, the array will contain 0 or 1 enumerated value's (depending upon whether any value has been selected or not) For multi select lists, the array will contain 0 or more enumerated values. For EnumeratedProperties, the SDK api {@link TypedResource#setValue(Property, Object)} takes either a single Enumerated Value or an array of EnumeratedValues in the second parameter. If a single value is presented, a single value is saved irrespective of whether the list is single or multi select. On the other hand, if an array of values (> 1) is presented, but the property type is single select, an SKDRuntimeException will be thrown

For a list of all members of this type, see EnumeratedProperty Members.

System.Object
Property
EnumeratedProperty
Derived types

public class EnumeratedProperty : Property

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

EnumeratedProperty Members | StarTeam Namespace


EnumeratedProperty Members

EnumeratedProperty overview

Public Static Properties

VALUE_NOT_SET

Public Instance Properties

AllValues | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

EnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty Properties

The properties of the EnumeratedProperty class are listed below. For a complete list of EnumeratedProperty class members, see the EnumeratedProperty Members topic.

Public Static Properties

VALUE_NOT_SET

Public Instance Properties

AllValues | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values | [read/write] An array of the enumerated values of this property.

See Also

EnumeratedProperty Class | StarTeam Namespace


AllValues Property

Borland StarTeam SDK for .NET

EnumeratedProperty.AllValues Property

[read] an array of the possible values for the indicated property

public virtual EnumeratedValue[] AllValues {get;}

Property Value

an array of the possible values for the indicated property

See Also

EnumeratedProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

EnumeratedProperty.DefaultValue Property

[read/write] the default EnumeratedValues

new public virtual EnumeratedValue[] DefaultValue {get; set;}

Property Value

the default EnumeratedValues

See Also

EnumeratedProperty Class | StarTeam Namespace


IsHierarchicalEnumeration Property

Borland StarTeam SDK for .NET

EnumeratedProperty.IsHierarchicalEnumeration Property

[read] boolean true if at least one of the enumerated values has child values

public virtual Boolean IsHierarchicalEnumeration {get;}

Property Value

boolean true if at least one of the enumerated values has child values

See Also

EnumeratedProperty Class | StarTeam Namespace


IsMultiSelectable Property

Borland StarTeam SDK for .NET

EnumeratedProperty.IsMultiSelectable Property

[read] true if this Enumerated Property supports selecting multiple enumerations

public virtual Boolean IsMultiSelectable {get;}

Property Value

true if this Enumerated Property supports selecting multiple enumerations

See Also

EnumeratedProperty Class | StarTeam Namespace


IsStatusProperty Property

Borland StarTeam SDK for .NET

EnumeratedProperty.IsStatusProperty Property

[read/write] true if this Enumerated Property supports selecting multiple enumerations

public virtual Boolean IsStatusProperty {get; set;}

Property Value

true if this Enumerated Property supports selecting multiple enumerations

See Also

EnumeratedProperty Class | StarTeam Namespace


SortedValues Property

Borland StarTeam SDK for .NET

EnumeratedProperty.SortedValues Property

[read] a sorted array of all the enumerated values for this property

public virtual EnumeratedValue[] SortedValues {get;}

Property Value

a sorted array of all the enumerated values for this property

See Also

EnumeratedProperty Class | StarTeam Namespace


VALUE_NOT_SET Property

Borland StarTeam SDK for .NET

EnumeratedProperty.VALUE_NOT_SET Property

public static Int32 VALUE_NOT_SET {get;}

See Also

EnumeratedProperty Class | StarTeam Namespace


Values Property

Borland StarTeam SDK for .NET

EnumeratedProperty.Values Property

[read/write] An array of the enumerated values of this property.

public virtual EnumeratedValue[] Values {get; set;}

Property Value

An array of the enumerated values of this property.

See Also

EnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty Methods

The methods of the EnumeratedProperty class are listed below. For a complete list of EnumeratedProperty class members, see the EnumeratedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

EnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.CreateValue Method

Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values

public virtual EnumeratedValue CreateValue(
String displayName
);

Parameters

displayName
the display name for the new value

Return Value

a new Enumerated Value for this property

See Also

EnumeratedProperty Class | StarTeam Namespace


FindValue Method

Borland StarTeam SDK for .NET

EnumeratedProperty.FindValue Method

Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

Overload List

Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

public virtual EnumeratedValue FindValue(Int32);

Finds an existing EnumeratedValue by internal name. Returns null if there is no such value. Note that there is a distinct difference between the Display Name and the Internal Name of an Enumerated value. The display name can have associated translations in languages like French, German or Japanese. The internal name cannot, and is typically used as a key for lookups. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

public virtual EnumeratedValue FindValue(String);

See Also

EnumeratedProperty Class | StarTeam Namespace | copy


EnumeratedProperty.FindValue Method (Int32)

Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

public virtual EnumeratedValue FindValue(
Int32 enumCode
);

Parameters

enumCode
the code

Return Value

an EnumeratedValue or null

See Also

EnumeratedProperty Class | StarTeam Namespace | EnumeratedProperty.FindValue Overload List | copy


EnumeratedProperty.FindValue Method (String)

Finds an existing EnumeratedValue by internal name. Returns null if there is no such value. Note that there is a distinct difference between the Display Name and the Internal Name of an Enumerated value. The display name can have associated translations in languages like French, German or Japanese. The internal name cannot, and is typically used as a key for lookups. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

public virtual EnumeratedValue FindValue(
String internalName
);

Parameters

internalName
the internal name

Return Value

an EnumeratedValue or null

See Also

EnumeratedProperty Class | StarTeam Namespace | EnumeratedProperty.FindValue Overload List | copy


EnumeratedProperty.GetEnumDisplayName Method

A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.

public virtual string GetEnumDisplayName(
Int32 value
);

Parameters

value
one of the possible enumerated values of the indicated property

Return Value

a user-friendly display name for the given value

See Also

EnumeratedProperty Class | StarTeam Namespace


NewQueryPart Method

Borland StarTeam SDK for .NET

EnumeratedProperty.NewQueryPart Method

Overload List

public virtual QueryPart NewQueryPart(QueryPart.Relation,EnumeratedValue);

public virtual QueryPart NewQueryPart(QueryPart.Relation,EnumeratedValue[]);

public virtual QueryPart NewQueryPart(QueryPart.Relation,Int32);

See Also

EnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.NewQueryPart Method (QueryPart#Relation, EnumeratedValue)

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
EnumeratedValue value
);

See Also

EnumeratedProperty Class | StarTeam Namespace | EnumeratedProperty.NewQueryPart Overload List


EnumeratedProperty.NewQueryPart Method (QueryPart#Relation, EnumeratedValue[])

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
EnumeratedValue[] values
);

See Also

EnumeratedProperty Class | StarTeam Namespace | EnumeratedProperty.NewQueryPart Overload List


EnumeratedProperty.NewQueryPart Method (QueryPart#Relation, Int32)

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
Int32 value
);

See Also

EnumeratedProperty Class | StarTeam Namespace | EnumeratedProperty.NewQueryPart Overload List


EnumeratedProperty.ToBooleanProperty Method

Convert an existing EnumeratedProperty into a BooleanProperty

The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.

public virtual BooleanProperty ToBooleanProperty(
EnumeratedValue falseValue,
EnumeratedValue trueValue
);

Parameters

falseValue
The EnumeratedValue that represents False
trueValue
The EnumeratedValue that represents True

Return Value

The converted BooleanProperty

See Also

EnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see EnumeratedProperty.WebCacheEnumeratedProperty Members.

System.Object
Property.WebCacheProperty
EnumeratedProperty.WebCacheEnumeratedProperty

public class EnumeratedProperty.WebCacheEnumeratedProperty : WebCacheProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Members | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty Members

EnumeratedProperty.WebCacheEnumeratedProperty overview

Public Instance Properties

AllValues | [read] an array of the possible values for the indicated property
Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] the default EnumeratedValues
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsMultiSelectable | [read] true if this Enumerated Property supports selecting multiple enumerations
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStatusProperty | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |
ServerAssignedStates | [read] the subset of enumerated values that are not assigned to any project
Values | [read/write] An array of the enumerated values of this property.

Public Instance Methods

CreateValue | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.
FindValue | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetAllowedStates |
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.
GetStatesAssignedOnlyTo |
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
MakeMultiSelectable | make this property multi selectable. A property can be made multi selectable when it is first created. It cannot subsequently be changed from single select to multi select or vice versa
NewQueryPart | Overloaded.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty Properties

The properties of the EnumeratedProperty.WebCacheEnumeratedProperty class are listed below. For a complete list of EnumeratedProperty.WebCacheEnumeratedProperty class members, see the EnumeratedProperty.WebCacheEnumeratedProperty Members topic.

Public Instance Properties

AllValues | [read] an array of the possible values for the indicated property
Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] the default EnumeratedValues
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsMultiSelectable | [read] true if this Enumerated Property supports selecting multiple enumerations
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStatusProperty | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |
ServerAssignedStates | [read] the subset of enumerated values that are not assigned to any project
Values | [read/write] An array of the enumerated values of this property.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


AllValues Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.AllValues Property

[read] an array of the possible values for the indicated property

public virtual EnumeratedValue[] AllValues {get;}

Property Value

an array of the possible values for the indicated property

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.DefaultValue Property

[read/write] the default EnumeratedValues

new public virtual EnumeratedValue[] DefaultValue {get; set;}

Property Value

the default EnumeratedValues

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsHierarchicalEnumeration Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsHierarchicalEnumeration Property

[read] boolean true if at least one of the enumerated values has child values

public virtual Boolean IsHierarchicalEnumeration {get;}

Property Value

boolean true if at least one of the enumerated values has child values

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsMultiSelectable Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsMultiSelectable Property

[read] true if this Enumerated Property supports selecting multiple enumerations

public virtual Boolean IsMultiSelectable {get;}

Property Value

true if this Enumerated Property supports selecting multiple enumerations

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsStatusProperty Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsStatusProperty Property

[read/write] true if this Enumerated Property supports selecting multiple enumerations

public virtual Boolean IsStatusProperty {get; set;}

Property Value

true if this Enumerated Property supports selecting multiple enumerations

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.Name Property

new public virtual String Name {get;}

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


ServerAssignedStates Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.ServerAssignedStates Property

[read] the subset of enumerated values that are not assigned to any project

public virtual EnumeratedValue[] ServerAssignedStates {get;}

Property Value

the subset of enumerated values that are not assigned to any project

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


Values Property

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.Values Property

[read/write] An array of the enumerated values of this property.

public virtual EnumeratedValue[] Values {get; set;}

Property Value

An array of the enumerated values of this property.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty Methods

The methods of the EnumeratedProperty.WebCacheEnumeratedProperty class are listed below. For a complete list of EnumeratedProperty.WebCacheEnumeratedProperty class members, see the EnumeratedProperty.WebCacheEnumeratedProperty Members topic.

Public Instance Methods

CreateValue | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.
FindValue | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetAllowedStates |
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.
GetStatesAssignedOnlyTo |
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
MakeMultiSelectable | make this property multi selectable. A property can be made multi selectable when it is first created. It cannot subsequently be changed from single select to multi select or vice versa
NewQueryPart | Overloaded.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.CreateValue Method

Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values

public virtual EnumeratedValue CreateValue(
String displayName
);

Parameters

displayName
the display name for the new value

Return Value

a new Enumerated Value for this property

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.Equals Method

Delegate Equals() to com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.Equals(obj).

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


FindValue Method

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.FindValue Method

Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

Overload List

Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

public virtual EnumeratedValue FindValue(Int32);

Finds an existing EnumeratedValue by internal name. Returns null if there is no such value. Note that there is a distinct difference between the Display Name and the Internal Name of an Enumerated value. The display name can have associated translations in languages like French, German or Japanese. The internal name cannot, and is typically used as a key for lookups. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

public virtual EnumeratedValue FindValue(String);

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace | copy


EnumeratedProperty.WebCacheEnumeratedProperty.FindValue Method (Int32)

Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

public virtual EnumeratedValue FindValue(
Int32 enumCode
);

Parameters

enumCode
the code

Return Value

an EnumeratedValue or null

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace | EnumeratedProperty.WebCacheEnumeratedProperty.FindValue Overload List | copy


EnumeratedProperty.WebCacheEnumeratedProperty.FindValue Method (String)

Finds an existing EnumeratedValue by internal name. Returns null if there is no such value. Note that there is a distinct difference between the Display Name and the Internal Name of an Enumerated value. The display name can have associated translations in languages like French, German or Japanese. The internal name cannot, and is typically used as a key for lookups. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}

public virtual EnumeratedValue FindValue(
String internalName
);

Parameters

internalName
the internal name

Return Value

an EnumeratedValue or null

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace | EnumeratedProperty.WebCacheEnumeratedProperty.FindValue Overload List | copy


EnumeratedProperty.WebCacheEnumeratedProperty.GetAllowedStates Method

public virtual EnumeratedValue[] GetAllowedStates(
Project.WebCacheProject prjct
);

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.

public override int GetHashCode();

Return Value

com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.GetHashCode().

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.GetStatesAssignedOnlyTo Method

public virtual EnumeratedValue[] GetStatesAssignedOnlyTo(
Project.WebCacheProject project
);

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.MakeMultiSelectable Method

make this property multi selectable. A property can be made multi selectable when it is first created. It cannot subsequently be changed from single select to multi select or vice versa

public virtual void MakeMultiSelectable();

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


NewQueryPart Method

Borland StarTeam SDK for .NET

EnumeratedProperty.WebCacheEnumeratedProperty.NewQueryPart Method

Overload List

public virtual WebCacheQueryPart NewQueryPart(QueryPart.Relation,EnumeratedValue);

public virtual WebCacheQueryPart NewQueryPart(QueryPart.Relation,EnumeratedValue[]);

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.NewQueryPart Method (QueryPart#Relation, EnumeratedValue)

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
EnumeratedValue value
);

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace | EnumeratedProperty.WebCacheEnumeratedProperty.NewQueryPart Overload List


EnumeratedProperty.WebCacheEnumeratedProperty.NewQueryPart Method (QueryPart#Relation, EnumeratedValue[])

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
EnumeratedValue[] values
);

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace | EnumeratedProperty.WebCacheEnumeratedProperty.NewQueryPart Overload List


EnumeratedProperty.WebCacheEnumeratedProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.ToString Method

Delegate ToString() to com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.

public override string ToString();

Return Value

com.starteam.EnumeratedProperty.WebCacheEnumeratedProperty.ToString()

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedProperty.WebCacheEnumeratedProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

EnumeratedProperty.WebCacheEnumeratedProperty Class | StarTeam Namespace


EnumeratedValue Class

A simple integer/String pair object to be used for adding new custom enumerated fields (Property) and modifying existing enumerated fields (Property).

For a list of all members of this type, see EnumeratedValue Members.

System.Object
EnumeratedValue
Derived types

public class EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

EnumeratedValue Members | StarTeam Namespace


EnumeratedValue Members

EnumeratedValue overview

Public Instance Constructors

EnumeratedValue Overloaded. Initializes a new instance of the EnumeratedValue class.

Public Instance Properties

After | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues | [read/write] EnumeratedValue[] of children
Code | [read] the enum code for this object.
DebugString | [read] a string used mainly for debugging
DepthInHierarchy | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName | [read/write] a locale appropriate display name
DisplayNameTranslations | [read/write] the display name translations for this enumerated value
InternalName | [read/write] the internal name for this object.
IsClosedState | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled | [read] true if this enumerated value is disabled.
IsEnabled | [read/write] true if this enumerated value is enabled.
IsLeafValue | [read] boolean true if this enumerated value has no child values.
IsRootValue | [read] boolean true if this enumerated value has no parent value.
IsSelectable | [read/write] boolean true if this enumerated value is selectable in a display
Name |
NameProperty |
ParentValue | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy | Returns a deep copy of this object.
Disable | Disable this enumerated value
Enable | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.EnumeratedValue.
FindChild | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.EnumeratedValue.

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue Constructor

Creates a new enumerated value with the specified code and translations for its display name. The default sort order is assigned the value of the code Using this constructor requires the caller to specify the enum code and additionally, the newly created EnumeratedValue has not Property context Property context is provided by assigning this enumerated value to an enumerated property using {@link EnumeratedProperty#setValues(EnumeratedValue[])}

Overload List

Creates a new enumerated value with the specified code and translations for its display name. The default sort order is assigned the value of the code Using this constructor requires the caller to specify the enum code and additionally, the newly created EnumeratedValue has not Property context Property context is provided by assigning this enumerated value to an enumerated property using {@link EnumeratedProperty#setValues(EnumeratedValue[])}

public EnumeratedValue(Int32,Translations);

Creates a new enumerated value with the specified code and display name The default sort order is assigned the value of the code The internal name is set to the value of the display name but can subsequently be overridden. The display name may have associated translations, but not the internal name. Using this constructor requires the caller to specify the enum code and additionally, the newly created EnumeratedValue has not Property context Property context is provided by assigning this enumerated value to an enumerated property using {@link EnumeratedProperty#setValues(EnumeratedValue[])}

public EnumeratedValue(Int32,String);

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue Constructor (Int32, Translations)

Creates a new enumerated value with the specified code and translations for its display name. The default sort order is assigned the value of the code Using this constructor requires the caller to specify the enum code and additionally, the newly created EnumeratedValue has not Property context Property context is provided by assigning this enumerated value to an enumerated property using {@link EnumeratedProperty#setValues(EnumeratedValue[])}

public EnumeratedValue(
Int32 code,
Translations translations
);

Parameters

code
the enum code value
translations
the display names for this enumerated value. May not be null.

See Also

EnumeratedValue Class | StarTeam Namespace | EnumeratedValue Constructor Overload List


EnumeratedValue Constructor (Int32, String)

Creates a new enumerated value with the specified code and display name The default sort order is assigned the value of the code The internal name is set to the value of the display name but can subsequently be overridden. The display name may have associated translations, but not the internal name. Using this constructor requires the caller to specify the enum code and additionally, the newly created EnumeratedValue has not Property context Property context is provided by assigning this enumerated value to an enumerated property using {@link EnumeratedProperty#setValues(EnumeratedValue[])}

public EnumeratedValue(
Int32 code,
String displayName
);

Parameters

code
int
displayName
String

See Also

EnumeratedValue Class | StarTeam Namespace | EnumeratedValue Constructor Overload List | setInternalName | setDisplayNameTranslations


EnumeratedValue Properties

The properties of the EnumeratedValue class are listed below. For a complete list of EnumeratedValue class members, see the EnumeratedValue Members topic.

Public Instance Properties

After | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues | [read/write] EnumeratedValue[] of children
Code | [read] the enum code for this object.
DebugString | [read] a string used mainly for debugging
DepthInHierarchy | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName | [read/write] a locale appropriate display name
DisplayNameTranslations | [read/write] the display name translations for this enumerated value
InternalName | [read/write] the internal name for this object.
IsClosedState | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled | [read] true if this enumerated value is disabled.
IsEnabled | [read/write] true if this enumerated value is enabled.
IsLeafValue | [read] boolean true if this enumerated value has no child values.
IsRootValue | [read] boolean true if this enumerated value has no parent value.
IsSelectable | [read/write] boolean true if this enumerated value is selectable in a display
Name |
NameProperty |
ParentValue | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder | [read/write] The sort order of this enumerated value.

See Also

EnumeratedValue Class | StarTeam Namespace


After Property

Borland StarTeam SDK for .NET

EnumeratedValue.After Property

[write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned

public virtual EnumeratedValue After {set;}

Property Value

Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned

See Also

EnumeratedValue Class | StarTeam Namespace


ChildValues Property

Borland StarTeam SDK for .NET

EnumeratedValue.ChildValues Property

[read/write] EnumeratedValue[] of children

public virtual EnumeratedValue[] ChildValues {get; set;}

Property Value

EnumeratedValue[] of children

See Also

EnumeratedValue Class | StarTeam Namespace


Code Property

Borland StarTeam SDK for .NET

EnumeratedValue.Code Property

[read] the enum code for this object.

public virtual Int32 Code {get;}

Property Value

the enum code for this object.

See Also

EnumeratedValue Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

EnumeratedValue.DebugString Property

[read] a string used mainly for debugging

public virtual String DebugString {get;}

Property Value

a string used mainly for debugging

See Also

EnumeratedValue Class | StarTeam Namespace


DepthInHierarchy Property

Borland StarTeam SDK for .NET

EnumeratedValue.DepthInHierarchy Property

[read] int the depth of this enumerated value in the presentation hierarchy

public virtual Int32 DepthInHierarchy {get;}

Property Value

int the depth of this enumerated value in the presentation hierarchy

See Also

EnumeratedValue Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

EnumeratedValue.DisplayName Property

[read/write] a locale appropriate display name

public virtual String DisplayName {get; set;}

Property Value

a locale appropriate display name

See Also

EnumeratedValue Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

EnumeratedValue.DisplayNameTranslations Property

[read/write] the display name translations for this enumerated value

public virtual Translations DisplayNameTranslations {get; set;}

Property Value

the display name translations for this enumerated value

See Also

EnumeratedValue Class | StarTeam Namespace


InternalName Property

Borland StarTeam SDK for .NET

EnumeratedValue.InternalName Property

[read/write] the internal name for this object.

public virtual String InternalName {get; set;}

Property Value

the internal name for this object.

See Also

EnumeratedValue Class | StarTeam Namespace


IsClosedState Property

Borland StarTeam SDK for .NET

EnumeratedValue.IsClosedState Property

[read/write] true if this Enumerated Value represents a Closed State for its Property

public virtual Boolean IsClosedState {get; set;}

Property Value

true if this Enumerated Value represents a Closed State for its Property

See Also

EnumeratedValue Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

EnumeratedValue.IsDisabled Property

[read] true if this enumerated value is disabled.

public virtual Boolean IsDisabled {get;}

Property Value

true if this enumerated value is disabled.

See Also

EnumeratedValue Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

EnumeratedValue.IsEnabled Property

[read/write] true if this enumerated value is enabled.

public virtual Boolean IsEnabled {get; set;}

Property Value

true if this enumerated value is enabled.

See Also

EnumeratedValue Class | StarTeam Namespace


IsLeafValue Property

Borland StarTeam SDK for .NET

EnumeratedValue.IsLeafValue Property

[read] boolean true if this enumerated value has no child values.

public virtual Boolean IsLeafValue {get;}

Property Value

boolean true if this enumerated value has no child values.

See Also

EnumeratedValue Class | StarTeam Namespace


IsRootValue Property

Borland StarTeam SDK for .NET

EnumeratedValue.IsRootValue Property

[read] boolean true if this enumerated value has no parent value.

public virtual Boolean IsRootValue {get;}

Property Value

boolean true if this enumerated value has no parent value.

See Also

EnumeratedValue Class | StarTeam Namespace


IsSelectable Property

Borland StarTeam SDK for .NET

EnumeratedValue.IsSelectable Property

[read/write] boolean true if this enumerated value is selectable in a display

public virtual Boolean IsSelectable {get; set;}

Property Value

boolean true if this enumerated value is selectable in a display

See Also

EnumeratedValue Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

EnumeratedValue.Name Property

public virtual String Name {get;}

See Also

EnumeratedValue Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

EnumeratedValue.NameProperty Property

public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

EnumeratedValue Class | StarTeam Namespace


ParentValue Property

Borland StarTeam SDK for .NET

EnumeratedValue.ParentValue Property

[read] EnumeratedValue the parent value of this enumerated value or null

public virtual EnumeratedValue ParentValue {get;}

Property Value

EnumeratedValue the parent value of this enumerated value or null

See Also

EnumeratedValue Class | StarTeam Namespace


SortOrder Property

Borland StarTeam SDK for .NET

EnumeratedValue.SortOrder Property

[read/write] The sort order of this enumerated value.

public virtual Int32 SortOrder {get; set;}

Property Value

The sort order of this enumerated value.

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue Methods

The methods of the EnumeratedValue class are listed below. For a complete list of EnumeratedValue class members, see the EnumeratedValue Members topic.

Public Instance Methods

AddChild | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy | Returns a deep copy of this object.
Disable | Disable this enumerated value
Enable | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.EnumeratedValue.
FindChild | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.EnumeratedValue.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.EnumeratedValue.

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.AddChild Method

Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()

public virtual void AddChild(
EnumeratedValue child
);

Parameters

child
a child of this enumerated value

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.AssignParent Method

Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.

public virtual void AssignParent(
EnumeratedValue parent
);

Parameters

parent
the new parent of this enumerated value

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.Copy Method

Returns a deep copy of this object.

public virtual EnumeratedValue Copy();

Return Value

a deep copy of this object.

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.Disable Method

Disable this enumerated value

public virtual void Disable();

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.Enable Method

Enable this enumerated value

public virtual void Enable();

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.Equals Method

Delegate Equals() to com.starteam.EnumeratedValue.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.EnumeratedValue.Equals(obj).

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.FindChild Method

return a child with the given internal name

public virtual EnumeratedValue FindChild(
String internalName
);

Parameters

internalName
the name of the child to find

Return Value

the enumerated value or null

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.GetHashCode Method

Delegate GetHashCode() to com.starteam.EnumeratedValue.

public override int GetHashCode();

Return Value

com.starteam.EnumeratedValue.GetHashCode().

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.HasChildValues Method

Returns true if this enumerated value has any child values (that is, if it is not a leaf value).

public virtual bool HasChildValues();

Return Value

boolean true if this enumerated value has any child values

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.IsEqualTo Method

Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise

public virtual bool IsEqualTo(
EnumeratedValue ev
);

Parameters

ev
The other EnumeratedProperty instance

Return Value

boolean true if this EnumeratedValue is equal to the other

See Also

EnumeratedValue Class | StarTeam Namespace


EnumeratedValue.ToString Method

Delegate ToString() to com.starteam.EnumeratedValue.

public override string ToString();

Return Value

com.starteam.EnumeratedValue.ToString()

See Also

EnumeratedValue Class | StarTeam Namespace


EventHandlerInfo Class

The EventHandlerInfo class describes a registered event handler, such as the one for the StarTeam MPX Server.

For a list of all members of this type, see EventHandlerInfo Members.

System.Object
EventHandlerInfo

public class EventHandlerInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

EventHandlerInfo Members | StarTeam Namespace


EventHandlerInfo Members

EventHandlerInfo overview

Public Instance Properties

Description | [read/write] The description of this EventHandlerInfo.
Name | [read] The name of this EventHandlerInfo.
ProfileNames | [read] an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo
PropertyNames | [read] The names of all existing properties of this EventHandlerInfo.

Public Instance Methods

AddProfile | Add an EventHandlerProfile to this EventHandlerInfo object.
DeleteProfile | Remove an EventHandlerProfile from this EventHandlerInfo object.
Equals | Delegate Equals() to com.starteam.EventHandlerInfo.
GetHashCode | Delegate GetHashCode() to com.starteam.EventHandlerInfo.
GetProfile | Returns the specified EventHandlerProfile object. If no such EventhandlerProfile exist, a null is returned.
GetProperty | Gets the value of a named property.
GetType (inherited from Object) | Gets the Type of the current instance.
PutProperty | Sets the value of the named property.
RemoveProperty | Removes the named property.
ToString | Delegate ToString() to com.starteam.EventHandlerInfo.
Update | Stores the existing EventHandlerInfo in the server.

See Also

EventHandlerInfo Class | StarTeam Namespace


EventHandlerInfo Properties

The properties of the EventHandlerInfo class are listed below. For a complete list of EventHandlerInfo class members, see the EventHandlerInfo Members topic.

Public Instance Properties

Description | [read/write] The description of this EventHandlerInfo.
Name | [read] The name of this EventHandlerInfo.
ProfileNames | [read] an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo
PropertyNames | [read] The names of all existing properties of this EventHandlerInfo.

See Also

EventHandlerInfo Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

EventHandlerInfo.Description Property

[read/write] The description of this EventHandlerInfo.

public virtual String Description {get; set;}

Property Value

The description of this EventHandlerInfo.

See Also

EventHandlerInfo Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

EventHandlerInfo.Name Property

[read] The name of this EventHandlerInfo.

public virtual String Name {get;}

Property Value

The name of this EventHandlerInfo.

See Also

EventHandlerInfo Class | StarTeam Namespace


ProfileNames Property

Borland StarTeam SDK for .NET

EventHandlerInfo.ProfileNames Property

[read] an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo

public virtual String[] ProfileNames {get;}

Property Value

an array containing the names of all existing EventHandlerProfiles of this EventHandlerInfo

See Also

EventHandlerInfo Class | StarTeam Namespace


PropertyNames Property

Borland StarTeam SDK for .NET

EventHandlerInfo.PropertyNames Property

[read] The names of all existing properties of this EventHandlerInfo.

public virtual String[] PropertyNames {get;}

Property Value

The names of all existing properties of this EventHandlerInfo.

See Also

EventHandlerInfo Class | StarTeam Namespace


EventHandlerInfo Methods

The methods of the EventHandlerInfo class are listed below. For a complete list of EventHandlerInfo class members, see the EventHandlerInfo Members topic.

Public Instance Methods

AddProfile | Add an EventHandlerProfile to this EventHandlerInfo object.
DeleteProfile | Remove an EventHandlerProfile from this EventHandlerInfo object.
Equals | Delegate Equals() to com.starteam.EventHandlerInfo.
GetHashCode | Delegate GetHashCode() to com.starteam.EventHandlerInfo.
GetProfile | Returns the specified EventHandlerProfile object. If no such EventhandlerProfile exist, a null is returned.
GetProperty | Gets the value of a named property.
GetType (inherited from Object) | Gets the Type of the current instance.
PutProperty | Sets the value of the named property.
RemoveProperty | Removes the named property.
ToString | Delegate ToString() to com.starteam.EventHandlerInfo.
Update | Stores the existing EventHandlerInfo in the server.

See Also

EventHandlerInfo Class | StarTeam Namespace


EventHandlerInfo.AddProfile Method

Add an EventHandlerProfile to this EventHandlerInfo object.

public virtual void AddProfile(
EventHandlerProfile profile
);

Parameters

profile
the EventHandlerProfile to be added.

See Also

EventHandlerInfo Class | StarTeam Namespace


EventHandlerInfo.DeleteProfile Method

Remove an EventHandlerProfile from this EventHandlerInfo object.

public virtual void DeleteProfile(
EventHandlerProfile profile
);

Parameters

profile
the EventHandlerProfile to be removed.

See Also

EventHandlerInfo Class | StarTeam Namespace


EventHandlerInfo.Equals Method

Delegate Equals() to com.starteam.EventHandlerInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.EventHandlerInfo.Equals(obj).

See Also

EventHandlerInfo Class | StarTeam Namespace


EventHandlerInfo.GetHashCode Method

Delegate GetHashCode() to com.starteam.EventHandlerInfo.

public override int GetHashCode();

Return Value

com.starteam.EventHandlerInfo.GetHashCode().

See Also

EventHandlerInfo Class | StarTeam Namespace


EventHandlerInfo.GetProfile Method

Returns the specified EventHandlerProfile object. If no such EventhandlerProfile exist, a null is returned.

public virtual EventHandlerProfile GetProfile(
String profileName
);

Parameters

profileName
the name of the EventHandlerInfo object to be returned

Return Value

the specified EventHandlerProfile object. If no such EventhandlerProfile exist, a null is returned.

See Also

EventHandlerInfo Class | StarTeam Namespace | getProfileNames


EventHandlerInfo.GetProperty Method

Gets the value of a named property.

public virtual object GetProperty(
String propertyName
);

Parameters

propertyName
The name of the property.

Return Value

The value of the named property.

See Also

EventHandlerInfo Class | StarTeam Namespace | getPropertyNames


EventHandlerInfo.PutProperty Method

Sets the value of the named property.

public virtual object PutProperty(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property.
value
the value to be assigned to the property

Return Value

the old value of the named property.

See Also

EventHandlerInfo Class | StarTeam Namespace | getPropertyNames


EventHandlerInfo.RemoveProperty Method

Removes the named property.

public virtual object RemoveProperty(
String propertyName
);

Parameters

propertyName
the name of the property.

Return Value

the old value of the named property.

See Also

EventHandlerInfo Class | StarTeam Namespace | getPropertyNames


EventHandlerInfo.ToString Method

Delegate ToString() to com.starteam.EventHandlerInfo.

public override string ToString();

Return Value

com.starteam.EventHandlerInfo.ToString()

See Also

EventHandlerInfo Class | StarTeam Namespace


EventHandlerInfo.Update Method

Stores the existing EventHandlerInfo in the server.

public virtual void Update();

See Also

EventHandlerInfo Class | StarTeam Namespace


EventHandlerProfile Class

The EventHandlerProfile class contains the information of one of profiles of an EventHandlerInfo.

For a list of all members of this type, see EventHandlerProfile Members.

System.Object
EventHandlerProfile

public class EventHandlerProfile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

EventHandlerProfile Members | StarTeam Namespace


EventHandlerProfile Members

EventHandlerProfile overview

Public Instance Constructors

EventHandlerProfile Constructor Constructs a new Event Handler Profile object. The object returned needs to be added to an EventHandlerInfo by calling EventHandlerInfo.addProfile() before being stored.

Public Instance Properties

Description | [read/write] The description of this EventHandlerProfile.
Name | [read] The name of this EventHandlerProfile.
PropertyNames | [read] The names of all existing properties of this EventHandlerProfile.

Public Instance Methods

Copy | Creates a copy of this EventHandlerProfile. Copies the Name, Description, all the individual properties, and their associated values.
Equals | Delegate Equals() to com.starteam.EventHandlerProfile.
GetHashCode | Delegate GetHashCode() to com.starteam.EventHandlerProfile.
GetProperty | Gets the value of the named property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two EventHandlerProfile objects. Compares the Name, Description, all the individual properties, and their associated values.
PutProperty | Sets the value of the named property.
RemoveProperty | Removes the named property.
ToString | Delegate ToString() to com.starteam.EventHandlerProfile.
Update | Stores the existing EventHandlerProfile in the server. If the EventHandlerProfile is new, EventHandlerInfo.addProfile() should be called instead.

See Also

EventHandlerProfile Class | StarTeam Namespace


EventHandlerProfile Constructor

Constructs a new Event Handler Profile object. The object returned needs to be added to an EventHandlerInfo by calling EventHandlerInfo.addProfile() before being stored.

public EventHandlerProfile(
String name,
String description
);

Parameters

name
the name of the profile
description
the description of the profile

See Also

EventHandlerProfile Class | StarTeam Namespace | addProfile


EventHandlerProfile Properties

The properties of the EventHandlerProfile class are listed below. For a complete list of EventHandlerProfile class members, see the EventHandlerProfile Members topic.

Public Instance Properties

Description | [read/write] The description of this EventHandlerProfile.
Name | [read] The name of this EventHandlerProfile.
PropertyNames | [read] The names of all existing properties of this EventHandlerProfile.

See Also

EventHandlerProfile Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

EventHandlerProfile.Description Property

[read/write] The description of this EventHandlerProfile.

public virtual String Description {get; set;}

Property Value

The description of this EventHandlerProfile.

See Also

EventHandlerProfile Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

EventHandlerProfile.Name Property

[read] The name of this EventHandlerProfile.

public virtual String Name {get;}

Property Value

The name of this EventHandlerProfile.

See Also

EventHandlerProfile Class | StarTeam Namespace


PropertyNames Property

Borland StarTeam SDK for .NET

EventHandlerProfile.PropertyNames Property

[read] The names of all existing properties of this EventHandlerProfile.

public virtual String[] PropertyNames {get;}

Property Value

The names of all existing properties of this EventHandlerProfile.

See Also

EventHandlerProfile Class | StarTeam Namespace


EventHandlerProfile Methods

The methods of the EventHandlerProfile class are listed below. For a complete list of EventHandlerProfile class members, see the EventHandlerProfile Members topic.

Public Instance Methods

Copy | Creates a copy of this EventHandlerProfile. Copies the Name, Description, all the individual properties, and their associated values.
Equals | Delegate Equals() to com.starteam.EventHandlerProfile.
GetHashCode | Delegate GetHashCode() to com.starteam.EventHandlerProfile.
GetProperty | Gets the value of the named property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two EventHandlerProfile objects. Compares the Name, Description, all the individual properties, and their associated values.
PutProperty | Sets the value of the named property.
RemoveProperty | Removes the named property.
ToString | Delegate ToString() to com.starteam.EventHandlerProfile.
Update | Stores the existing EventHandlerProfile in the server. If the EventHandlerProfile is new, EventHandlerInfo.addProfile() should be called instead.

See Also

EventHandlerProfile Class | StarTeam Namespace


EventHandlerProfile.Copy Method

Creates a copy of this EventHandlerProfile. Copies the Name, Description, all the individual properties, and their associated values.

public virtual EventHandlerProfile Copy();

Return Value

A new copy of this EventHandlerProfile.

See Also

EventHandlerProfile Class | StarTeam Namespace | isEqualTo


EventHandlerProfile.Equals Method

Delegate Equals() to com.starteam.EventHandlerProfile.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.EventHandlerProfile.Equals(obj).

See Also

EventHandlerProfile Class | StarTeam Namespace


EventHandlerProfile.GetHashCode Method

Delegate GetHashCode() to com.starteam.EventHandlerProfile.

public override int GetHashCode();

Return Value

com.starteam.EventHandlerProfile.GetHashCode().

See Also

EventHandlerProfile Class | StarTeam Namespace


EventHandlerProfile.GetProperty Method

Gets the value of the named property.

public virtual object GetProperty(
String propertyName
);

Parameters

propertyName
The name of the property.

Return Value

The value of the named property.

See Also

EventHandlerProfile Class | StarTeam Namespace | getPropertyNames


EventHandlerProfile.IsEqualTo Method

Compares two EventHandlerProfile objects. Compares the Name, Description, all the individual properties, and their associated values.

public virtual bool IsEqualTo(
EventHandlerProfile p
);

Parameters

p
The EventHandlerProfile object to be compared to this one.

Return Value

true if no differences were found.

See Also

EventHandlerProfile Class | StarTeam Namespace | copy


EventHandlerProfile.PutProperty Method

Sets the value of the named property.

public virtual object PutProperty(
String propertyName,
Object value
);

Parameters

propertyName
The name of the property.
value
The new value of the property.

Return Value

The old value of the named property.

See Also

EventHandlerProfile Class | StarTeam Namespace | getPropertyNames


EventHandlerProfile.RemoveProperty Method

Removes the named property.

public virtual object RemoveProperty(
String propertyName
);

Parameters

propertyName
The name of the property.

Return Value

The old value of the named property.

See Also

EventHandlerProfile Class | StarTeam Namespace | getPropertyNames


EventHandlerProfile.ToString Method

Delegate ToString() to com.starteam.EventHandlerProfile.

public override string ToString();

Return Value

com.starteam.EventHandlerProfile.ToString()

See Also

EventHandlerProfile Class | StarTeam Namespace


EventHandlerProfile.Update Method

Stores the existing EventHandlerProfile in the server. If the EventHandlerProfile is new, EventHandlerInfo.addProfile() should be called instead.

public virtual void Update();

See Also

EventHandlerProfile Class | StarTeam Namespace | addProfile


File Class

Represents a StarTeam File item.

For a list of all members of this type, see File Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
File

public class File : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File Members | StarTeam Namespace


File Members

File overview

Public Static Properties

BlankKeywords [read] an array of blank StarTeam keywords

Public Static Methods

Create | Create a File in the specified parent folder. When the file name property is set, there is an expectation that there is a working file on disk with this name, whose working path maps to the folder path of the specified parent folder
IsFileContentMixedEOL | Returns true if the file contains a mixed set of CRs, LFs and/or CRLF's Files that contain this pattern are automatically treated as BINARY files iff the Server Configuration Option MixedEOLAsBinary is set to true. The algorithm results in a short walk through the file until two consecutive EOL characters of different types are encountered. The algorithm will walk the entire file if the pattern is not encountered, such as would be the case for a 'regular' binary file with embedded NULLs, ASCII or UNICODE files.
IsInSyncByMD5 |
IsInSyncByTime |
UpdateStatus | Overloaded. This method sets the status for each file item in an array. It uses several techniques to optimize for speed. 1. It is assumed that all status helpers have the correct file attributes set. This avoids local disk access for checking file and folder existence, unless absolutely necessary. 2. The given array should contains all the files for one or more folders, with files of the same folder grouped together. This allows internal tests to be performed on a per folder basis. The caller is responsible for ensuring that files are grouped by folder, to take full advantage of the performance shortcuts being used. for files that have no provider.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
ArchiveName | [read] The file name of this file's archive file in the vault.
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CharacterSetValue | [read/write] The character set used by this file, or null if it is unknown.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CompressionValue | [read] The compression level of the archive file in the vault.
ContentModifiedTime | [read/write] The "last modified" time of the working file when this revision was checked in.
ContentVersion | [read] The content version number for this file
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this file
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EOLFormatValue | [read/write] The end-of-line format, or null if it has not yet been initialized.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
Extension | [read] the file name extension.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
FullName | [read] the local file path to this file
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
HiveID | [read] The ID of the hive where the archive file is stored in the vault.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBinary | [read] true if this repository file has been determined to be binary
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsExecutable | [read/write] true if the file has been marked executable in the repository; false otherwise.
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsSyncInRevisionHistory | [read] true if the last known revision of this file on disk is somewhere in the file's linear revision history.
IsSyncKnown | [read]
IsUnicode | [read] true if this repository file has been determined to be UNICODE
IsUnread (inherited from ViewMember) | [read] boolean
IsWorkingFileAvailable | [read] true if the local working file exists on disk.
IsWorkingFileExecutable | [read] true if the local working file is executable.
ItemID (inherited from Item) | [read] the unique item ID for this item.
KeywordFlagValue | [read] the value of the KeywordFlag property
LastKnownStatusValue | [read] The status code for this file
LocalFileSystemPropertyProvider | [read/write] FilePropertyProvider provider, the file property provider to registered for use by this File object.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MD5 | [read] the MD5 has bytes of the repository contents of this file
MergeHistory (inherited from Item) | [read] the merge points for this item
MergeVersion | [read] the most recent common ancestor of this file and the last known version of this file on disk.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of this file
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection for this File
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Size | [read] the size of this file in the repository
SmartStatusValue | [read] The current status of this file.
StatusNowValue | [read] this file's status after refreshing status information from the server
StatusValue | [read] The current status of this file.
SymbolicLinkTarget | [read/write] the target path of the symbolic link.
SyncBranchVersion | [read] The branch version of the last known revision of this file on disk, or -1 if unknown.
SyncContentVersion | [read] The content version of the last known revision of this file on disk, or -1 if unknown.
SyncMD5 | [read] The MD5 of this file's last known revision on disk, or null if the MD5 is unknown.
SyncModifiedTime | [read] The working modified time of the last known revision of this file on disk, or null if unknown.
SyncSize | [read] The working file size of the last known revision of this file on disk, or -1 if unknown.
SyncViewVersion | [read] The view version of the last known revision of this file on disk, or -1 if unknown.
UsesKeywords | [read] true if this file uses keyword expansion
VaultVersion | [read] the vault version number for this file
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WorkingFileModifiedTime | [read] The local working file's modified time, or {@linkplain com.starteam.util.DateTime#VALUE_NOT_SET VALUE_NOT_SET} if the working file is missing.
WorkingFileName | [read] The name of the local working file, as recognized by the local file system. On case insensitive platforms (like Windows), the working file name can differ in case from the file name property stored in the repository
WorkingFilePath | [read] The full path to the local working file, as recognized by the local file system. On case insensitive platforms (like Windows), the working folder name can differ in case from the folder path property stored in the repository
WorkingFileSize | [read] The local working file's size, in bytes, or -1 if the file doesn't exist.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
ComputeCompareMD5 | Derives an MD5 signature of this file's working file on disk, if it were to be stored in the StarTeam repository. Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.
ConvertArchive | This method causes the server to convert all versions stored in the archives associated with the file to the storage parameters specified. This can not be called for a not-in-view file (an exception will be thrown). A new file revision will be created. Note that archive conversion is irreversible in the sense that the archive cannot be restored to its original state if it contained versions using mixed storage options. Note also that the archive conversion may be a fairly long operation depending on the number and size of versions stored in the archive files.
ConvertToNativeIIArchive | Convert this File's archives to Native II format. Available starting with server release 7.0
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteLocalFile | Deletes the specified local file and has the side effect of deleting sync information from the server about the file.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
DeleteSyncInfo | Removes sync information from this File object's Server. Once it has been called the Status for file will be unknown. Use with caution.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFileSyncInfo | Attempts to determine what version of the file is actually on disk. This method is similar to resyncStatus, except that the status information is returned to the caller, rather than being cached with the Server object. This is useful for server-based applications running on behalf of a remote client, when running against a StarTeam server that supports client-managed status.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetSmartStatusValue | Gets the status of the given working file relative to the latest version of this file in the repository. Status is determined by comparing the current size and last modified time with that of the last known revision on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.
GetStatusValue | Overloaded. Gets the status of the given working file relative to the latest version of this file in the repository. Status is determined by comparing the current size and last modified time with that of the last known revision on disk.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveLocalFile | Moves the local file to the specified folder and has the side effect of moving the status information from the original file to the newly created one Deletes the original file and it's status information at the end of the move
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveAndDeleteLocal | Removes the file item from its parent folder. Note that a file may be shared in another folder in the same or different view. This method will merely remove the one instance (or shared copy) that the method is called on. In addition, this method will delete the corresponding working file.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Rename | Renames this file to a new name along with the side effect of changing the corresponding local file's name as well. This method does the same work as update() but also maintains the status information so that the newly renamed file will have the same status it did prior to the renaming. Simply using setName() and update() will not change the local file name consequently status information would be lost. NOTE: in the case where a file already exists with the new name, but it is not the same file as the old one [e.g., on Unix systems where only the case of the filenames differ], the local file will not be renamed, to avoid loss of data for users.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResyncStatus | Attempts to update the repository information about what version of the file is actually on disk. This method is similar to updateStatus, except that information about the working file is provided explicitly by the caller. The working file itself is not used, and in fact does not need to be accessible. This is useful, for example, if the actual working file resides on a remote client workstation.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
Rollback | rollback the contents of the specified revision of this file on disk. Binary files cannot be rolled back, since the changes made cannot be determined by the StarTeam SDK Merge Engine.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.
UpdateStatus | Overloaded. Attempts to update the repository information about what version of the file is actually on disk. This method will send the MD5 checksum of the file to the server to see if the contents exactly match any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged. Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".
UpdateStatusAfterMerge | Updates the status information to reflect the fact that the local file's contents were derived from this file's contents. You would most commonly want to call this after merging in changes. This file's status will be "Modified" after a call to this method if this file is the tip version of the file.

See Also

File Class | StarTeam Namespace


File Properties

The properties of the File class are listed below. For a complete list of File class members, see the File Members topic.

Public Static Properties

BlankKeywords [read] an array of blank StarTeam keywords

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
ArchiveName | [read] The file name of this file's archive file in the vault.
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CharacterSetValue | [read/write] The character set used by this file, or null if it is unknown.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CompressionValue | [read] The compression level of the archive file in the vault.
ContentModifiedTime | [read/write] The "last modified" time of the working file when this revision was checked in.
ContentVersion | [read] The content version number for this file
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this file
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EOLFormatValue | [read/write] The end-of-line format, or null if it has not yet been initialized.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
Extension | [read] the file name extension.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
FullName | [read] the local file path to this file
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
HiveID | [read] The ID of the hive where the archive file is stored in the vault.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBinary | [read] true if this repository file has been determined to be binary
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsExecutable | [read/write] true if the file has been marked executable in the repository; false otherwise.
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsSyncInRevisionHistory | [read] true if the last known revision of this file on disk is somewhere in the file's linear revision history.
IsSyncKnown | [read]
IsUnicode | [read] true if this repository file has been determined to be UNICODE
IsUnread (inherited from ViewMember) | [read] boolean
IsWorkingFileAvailable | [read] true if the local working file exists on disk.
IsWorkingFileExecutable | [read] true if the local working file is executable.
ItemID (inherited from Item) | [read] the unique item ID for this item.
KeywordFlagValue | [read] the value of the KeywordFlag property
LastKnownStatusValue | [read] The status code for this file
LocalFileSystemPropertyProvider | [read/write] FilePropertyProvider provider, the file property provider to registered for use by this File object.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MD5 | [read] the MD5 has bytes of the repository contents of this file
MergeHistory (inherited from Item) | [read] the merge points for this item
MergeVersion | [read] the most recent common ancestor of this file and the last known version of this file on disk.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of this file
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection for this File
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Size | [read] the size of this file in the repository
SmartStatusValue | [read] The current status of this file.
StatusNowValue | [read] this file's status after refreshing status information from the server
StatusValue | [read] The current status of this file.
SymbolicLinkTarget | [read/write] the target path of the symbolic link.
SyncBranchVersion | [read] The branch version of the last known revision of this file on disk, or -1 if unknown.
SyncContentVersion | [read] The content version of the last known revision of this file on disk, or -1 if unknown.
SyncMD5 | [read] The MD5 of this file's last known revision on disk, or null if the MD5 is unknown.
SyncModifiedTime | [read] The working modified time of the last known revision of this file on disk, or null if unknown.
SyncSize | [read] The working file size of the last known revision of this file on disk, or -1 if unknown.
SyncViewVersion | [read] The view version of the last known revision of this file on disk, or -1 if unknown.
UsesKeywords | [read] true if this file uses keyword expansion
VaultVersion | [read] the vault version number for this file
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WorkingFileModifiedTime | [read] The local working file's modified time, or {@linkplain com.starteam.util.DateTime#VALUE_NOT_SET VALUE_NOT_SET} if the working file is missing.
WorkingFileName | [read] The name of the local working file, as recognized by the local file system. On case insensitive platforms (like Windows), the working file name can differ in case from the file name property stored in the repository
WorkingFilePath | [read] The full path to the local working file, as recognized by the local file system. On case insensitive platforms (like Windows), the working folder name can differ in case from the folder path property stored in the repository
WorkingFileSize | [read] The local working file's size, in bytes, or -1 if the file doesn't exist.

See Also

File Class | StarTeam Namespace


ArchiveName Property

Borland StarTeam SDK for .NET

File.ArchiveName Property

[read] The file name of this file's archive file in the vault.

public virtual String ArchiveName {get;}

Property Value

The file name of this file's archive file in the vault.

See Also

File Class | StarTeam Namespace


BlankKeywords Property

Borland StarTeam SDK for .NET

File.BlankKeywords Property

[read] an array of blank StarTeam keywords

public static Keyword[] BlankKeywords {get;}

Property Value

an array of blank StarTeam keywords

See Also

File Class | StarTeam Namespace


CharacterSetValue Property

Borland StarTeam SDK for .NET

File.CharacterSetValue Property

[read/write] The character set used by this file, or null if it is unknown.

public virtual File.CharacterSet CharacterSetValue {get; set;}

Property Value

The character set used by this file, or null if it is unknown.

See Also

File Class | StarTeam Namespace


CompressionValue Property

Borland StarTeam SDK for .NET

File.CompressionValue Property

[read] The compression level of the archive file in the vault.

public virtual File.Compression CompressionValue {get;}

Property Value

The compression level of the archive file in the vault.

See Also

File Class | StarTeam Namespace


ContentModifiedTime Property

Borland StarTeam SDK for .NET

File.ContentModifiedTime Property

[read/write] The "last modified" time of the working file when this revision was checked in.

public virtual DateTime ContentModifiedTime {get; set;}

Property Value

The "last modified" time of the working file when this revision was checked in.

See Also

File Class | StarTeam Namespace


ContentVersion Property

Borland StarTeam SDK for .NET

File.ContentVersion Property

[read] The content version number for this file

public virtual Int32 ContentVersion {get;}

Property Value

The content version number for this file

See Also

File Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

File.Description Property

[read/write] the description of this file

public virtual String Description {get; set;}

Property Value

the description of this file

See Also

File Class | StarTeam Namespace


EOLFormatValue Property

Borland StarTeam SDK for .NET

File.EOLFormatValue Property

[read/write] The end-of-line format, or null if it has not yet been initialized.

public virtual File.EOLFormat EOLFormatValue {get; set;}

Property Value

The end-of-line format, or null if it has not yet been initialized.

See Also

File Class | StarTeam Namespace


Extension Property

Borland StarTeam SDK for .NET

File.Extension Property

[read] the file name extension.

public virtual String Extension {get;}

Property Value

the file name extension.

See Also

File Class | StarTeam Namespace


FullName Property

Borland StarTeam SDK for .NET

File.FullName Property

[read] the local file path to this file

public virtual String FullName {get;}

Property Value

the local file path to this file

See Also

File Class | StarTeam Namespace


HiveID Property

Borland StarTeam SDK for .NET

File.HiveID Property

[read] The ID of the hive where the archive file is stored in the vault.

public virtual Int32 HiveID {get;}

Property Value

The ID of the hive where the archive file is stored in the vault.

See Also

File Class | StarTeam Namespace


IsBinary Property

Borland StarTeam SDK for .NET

File.IsBinary Property

[read] true if this repository file has been determined to be binary

public virtual Boolean IsBinary {get;}

Property Value

true if this repository file has been determined to be binary

See Also

File Class | StarTeam Namespace


IsExecutable Property

Borland StarTeam SDK for .NET

File.IsExecutable Property

[read/write] true if the file has been marked executable in the repository; false otherwise.

public virtual Boolean IsExecutable {get; set;}

Property Value

true if the file has been marked executable in the repository; false otherwise.

See Also

File Class | StarTeam Namespace


IsSyncInRevisionHistory Property

Borland StarTeam SDK for .NET

File.IsSyncInRevisionHistory Property

[read] true if the last known revision of this file on disk is somewhere in the file's linear revision history.

public virtual Boolean IsSyncInRevisionHistory {get;}

Property Value

true if the last known revision of this file on disk is somewhere in the file's linear revision history.

See Also

File Class | StarTeam Namespace


IsSyncKnown Property

Borland StarTeam SDK for .NET

File.IsSyncKnown Property

[read]

public virtual Boolean IsSyncKnown {get;}

See Also

File Class | StarTeam Namespace


IsUnicode Property

Borland StarTeam SDK for .NET

File.IsUnicode Property

[read] true if this repository file has been determined to be UNICODE

public virtual Boolean IsUnicode {get;}

Property Value

true if this repository file has been determined to be UNICODE

See Also

File Class | StarTeam Namespace


IsWorkingFileAvailable Property

Borland StarTeam SDK for .NET

File.IsWorkingFileAvailable Property

[read] true if the local working file exists on disk.

public virtual Boolean IsWorkingFileAvailable {get;}

Property Value

true if the local working file exists on disk.

See Also

File Class | StarTeam Namespace


IsWorkingFileExecutable Property

Borland StarTeam SDK for .NET

File.IsWorkingFileExecutable Property

[read] true if the local working file is executable.

public virtual Boolean IsWorkingFileExecutable {get;}

Property Value

true if the local working file is executable.

See Also

File Class | StarTeam Namespace


KeywordFlagValue Property

Borland StarTeam SDK for .NET

File.KeywordFlagValue Property

[read] the value of the KeywordFlag property

public virtual File.KeywordFlag KeywordFlagValue {get;}

Property Value

the value of the KeywordFlag property

See Also

File Class | StarTeam Namespace


LastKnownStatusValue Property

Borland StarTeam SDK for .NET

File.LastKnownStatusValue Property

[read] The status code for this file

public virtual File.Status LastKnownStatusValue {get;}

Property Value

The status code for this file

See Also

File Class | StarTeam Namespace


LocalFileSystemPropertyProvider Property

Borland StarTeam SDK for .NET

File.LocalFileSystemPropertyProvider Property

[read/write] FilePropertyProvider provider, the file property provider to registered for use by this File object.

public virtual LocalFileSystemPropertyProvider LocalFileSystemPropertyProvider {get; set;}

Property Value

FilePropertyProvider provider, the file property provider to registered for use by this File object.

See Also

File Class | StarTeam Namespace


MD5 Property

Borland StarTeam SDK for .NET

File.MD5 Property

[read] the MD5 has bytes of the repository contents of this file

public virtual MD5 MD5 {get;}

Property Value

the MD5 has bytes of the repository contents of this file

See Also

File Class | StarTeam Namespace


MergeVersion Property

Borland StarTeam SDK for .NET

File.MergeVersion Property

[read] the most recent common ancestor of this file and the last known version of this file on disk.

public virtual File MergeVersion {get;}

Property Value

the most recent common ancestor of this file and the last known version of this file on disk.

See Also

File Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

File.Name Property

[read/write] the name of this file

public virtual String Name {get; set;}

Property Value

the name of this file

See Also

File Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

File.Properties Property

[read] the PropertyCollection for this File

public virtual File.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection for this File

See Also

File Class | StarTeam Namespace


Size Property

Borland StarTeam SDK for .NET

File.Size Property

[read] the size of this file in the repository

public virtual Int64 Size {get;}

Property Value

the size of this file in the repository

See Also

File Class | StarTeam Namespace


SmartStatusValue Property

Borland StarTeam SDK for .NET

File.SmartStatusValue Property

[read] The current status of this file.

public virtual File.Status SmartStatusValue {get;}

Property Value

The current status of this file.

See Also

File Class | StarTeam Namespace


StatusNowValue Property

Borland StarTeam SDK for .NET

File.StatusNowValue Property

[read] this file's status after refreshing status information from the server

public virtual File.Status StatusNowValue {get;}

Property Value

this file's status after refreshing status information from the server

See Also

File Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

File.StatusValue Property

[read] The current status of this file.

public virtual File.Status StatusValue {get;}

Property Value

The current status of this file.

See Also

File Class | StarTeam Namespace


SymbolicLinkTarget Property

Borland StarTeam SDK for .NET

File.SymbolicLinkTarget Property

[read/write] the target path of the symbolic link.

public virtual String SymbolicLinkTarget {get; set;}

Property Value

the target path of the symbolic link.

See Also

File Class | StarTeam Namespace


SyncBranchVersion Property

Borland StarTeam SDK for .NET

File.SyncBranchVersion Property

[read] The branch version of the last known revision of this file on disk, or -1 if unknown.

public virtual Int32 SyncBranchVersion {get;}

Property Value

The branch version of the last known revision of this file on disk, or -1 if unknown.

See Also

File Class | StarTeam Namespace


SyncContentVersion Property

Borland StarTeam SDK for .NET

File.SyncContentVersion Property

[read] The content version of the last known revision of this file on disk, or -1 if unknown.

public virtual Int32 SyncContentVersion {get;}

Property Value

The content version of the last known revision of this file on disk, or -1 if unknown.

See Also

File Class | StarTeam Namespace


SyncMD5 Property

Borland StarTeam SDK for .NET

File.SyncMD5 Property

[read] The MD5 of this file's last known revision on disk, or null if the MD5 is unknown.

public virtual MD5 SyncMD5 {get;}

Property Value

The MD5 of this file's last known revision on disk, or null if the MD5 is unknown.

See Also

File Class | StarTeam Namespace


SyncModifiedTime Property

Borland StarTeam SDK for .NET

File.SyncModifiedTime Property

[read] The working modified time of the last known revision of this file on disk, or null if unknown.

public virtual DateTime SyncModifiedTime {get;}

Property Value

The working modified time of the last known revision of this file on disk, or null if unknown.

See Also

File Class | StarTeam Namespace


SyncSize Property

Borland StarTeam SDK for .NET

File.SyncSize Property

[read] The working file size of the last known revision of this file on disk, or -1 if unknown.

public virtual Int64 SyncSize {get;}

Property Value

The working file size of the last known revision of this file on disk, or -1 if unknown.

See Also

File Class | StarTeam Namespace


SyncViewVersion Property

Borland StarTeam SDK for .NET

File.SyncViewVersion Property

[read] The view version of the last known revision of this file on disk, or -1 if unknown.

public virtual Int32 SyncViewVersion {get;}

Property Value

The view version of the last known revision of this file on disk, or -1 if unknown.

See Also

File Class | StarTeam Namespace


UsesKeywords Property

Borland StarTeam SDK for .NET

File.UsesKeywords Property

[read] true if this file uses keyword expansion

public virtual Boolean UsesKeywords {get;}

Property Value

true if this file uses keyword expansion

See Also

File Class | StarTeam Namespace


VaultVersion Property

Borland StarTeam SDK for .NET

File.VaultVersion Property

[read] the vault version number for this file

public virtual Int32 VaultVersion {get;}

Property Value

the vault version number for this file

See Also

File Class | StarTeam Namespace


WorkingFileModifiedTime Property

Borland StarTeam SDK for .NET

File.WorkingFileModifiedTime Property

[read] The local working file's modified time, or {@linkplain com.starteam.util.DateTime#VALUE_NOT_SET VALUE_NOT_SET} if the working file is missing.

public virtual DateTime WorkingFileModifiedTime {get;}

Property Value

The local working file's modified time, or {@linkplain com.starteam.util.DateTime#VALUE_NOT_SET VALUE_NOT_SET} if the working file is missing.

See Also

File Class | StarTeam Namespace


WorkingFileName Property

Borland StarTeam SDK for .NET

File.WorkingFileName Property

[read] The name of the local working file, as recognized by the local file system. On case insensitive platforms (like Windows), the working file name can differ in case from the file name property stored in the repository

public virtual String WorkingFileName {get;}

Property Value

The name of the local working file, as recognized by the local file system. On case insensitive platforms (like Windows), the working file name can differ in case from the file name property stored in the repository

See Also

File Class | StarTeam Namespace


WorkingFilePath Property

Borland StarTeam SDK for .NET

File.WorkingFilePath Property

[read] The full path to the local working file, as recognized by the local file system. On case insensitive platforms (like Windows), the working folder name can differ in case from the folder path property stored in the repository

public virtual String WorkingFilePath {get;}

Property Value

The full path to the local working file, as recognized by the local file system. On case insensitive platforms (like Windows), the working folder name can differ in case from the folder path property stored in the repository

See Also

File Class | StarTeam Namespace


WorkingFileSize Property

Borland StarTeam SDK for .NET

File.WorkingFileSize Property

[read] The local working file's size, in bytes, or -1 if the file doesn't exist.

public virtual Int64 WorkingFileSize {get;}

Property Value

The local working file's size, in bytes, or -1 if the file doesn't exist.

See Also

File Class | StarTeam Namespace


File Methods

The methods of the File class are listed below. For a complete list of File class members, see the File Members topic.

Public Static Methods

Create | Create a File in the specified parent folder. When the file name property is set, there is an expectation that there is a working file on disk with this name, whose working path maps to the folder path of the specified parent folder
IsFileContentMixedEOL | Returns true if the file contains a mixed set of CRs, LFs and/or CRLF's Files that contain this pattern are automatically treated as BINARY files iff the Server Configuration Option MixedEOLAsBinary is set to true. The algorithm results in a short walk through the file until two consecutive EOL characters of different types are encountered. The algorithm will walk the entire file if the pattern is not encountered, such as would be the case for a 'regular' binary file with embedded NULLs, ASCII or UNICODE files.
IsInSyncByMD5 |
IsInSyncByTime |
UpdateStatus | Overloaded. This method sets the status for each file item in an array. It uses several techniques to optimize for speed. 1. It is assumed that all status helpers have the correct file attributes set. This avoids local disk access for checking file and folder existence, unless absolutely necessary. 2. The given array should contains all the files for one or more folders, with files of the same folder grouped together. This allows internal tests to be performed on a per folder basis. The caller is responsible for ensuring that files are grouped by folder, to take full advantage of the performance shortcuts being used. for files that have no provider.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
ComputeCompareMD5 | Derives an MD5 signature of this file's working file on disk, if it were to be stored in the StarTeam repository. Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.
ConvertArchive | This method causes the server to convert all versions stored in the archives associated with the file to the storage parameters specified. This can not be called for a not-in-view file (an exception will be thrown). A new file revision will be created. Note that archive conversion is irreversible in the sense that the archive cannot be restored to its original state if it contained versions using mixed storage options. Note also that the archive conversion may be a fairly long operation depending on the number and size of versions stored in the archive files.
ConvertToNativeIIArchive | Convert this File's archives to Native II format. Available starting with server release 7.0
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteLocalFile | Deletes the specified local file and has the side effect of deleting sync information from the server about the file.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
DeleteSyncInfo | Removes sync information from this File object's Server. Once it has been called the Status for file will be unknown. Use with caution.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFileSyncInfo | Attempts to determine what version of the file is actually on disk. This method is similar to resyncStatus, except that the status information is returned to the caller, rather than being cached with the Server object. This is useful for server-based applications running on behalf of a remote client, when running against a StarTeam server that supports client-managed status.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetSmartStatusValue | Gets the status of the given working file relative to the latest version of this file in the repository. Status is determined by comparing the current size and last modified time with that of the last known revision on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.
GetStatusValue | Overloaded. Gets the status of the given working file relative to the latest version of this file in the repository. Status is determined by comparing the current size and last modified time with that of the last known revision on disk.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveLocalFile | Moves the local file to the specified folder and has the side effect of moving the status information from the original file to the newly created one Deletes the original file and it's status information at the end of the move
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveAndDeleteLocal | Removes the file item from its parent folder. Note that a file may be shared in another folder in the same or different view. This method will merely remove the one instance (or shared copy) that the method is called on. In addition, this method will delete the corresponding working file.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Rename | Renames this file to a new name along with the side effect of changing the corresponding local file's name as well. This method does the same work as update() but also maintains the status information so that the newly renamed file will have the same status it did prior to the renaming. Simply using setName() and update() will not change the local file name consequently status information would be lost. NOTE: in the case where a file already exists with the new name, but it is not the same file as the old one [e.g., on Unix systems where only the case of the filenames differ], the local file will not be renamed, to avoid loss of data for users.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResyncStatus | Attempts to update the repository information about what version of the file is actually on disk. This method is similar to updateStatus, except that information about the working file is provided explicitly by the caller. The working file itself is not used, and in fact does not need to be accessible. This is useful, for example, if the actual working file resides on a remote client workstation.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
Rollback | rollback the contents of the specified revision of this file on disk. Binary files cannot be rolled back, since the changes made cannot be determined by the StarTeam SDK Merge Engine.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.
UpdateStatus | Overloaded. Attempts to update the repository information about what version of the file is actually on disk. This method will send the MD5 checksum of the file to the server to see if the contents exactly match any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged. Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".
UpdateStatusAfterMerge | Updates the status information to reflect the fact that the local file's contents were derived from this file's contents. You would most commonly want to call this after merging in changes. This file's status will be "Modified" after a call to this method if this file is the tip version of the file.

See Also

File Class | StarTeam Namespace


File.ComputeCompareMD5 Method

Derives an MD5 signature of this file's working file on disk, if it were to be stored in the StarTeam repository.

Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.

public virtual long ComputeCompareMD5(
FileInfo workingFile,
MD5 md5
);

Parameters

workingFile
The working file whose MD5 is to be calculated, or null to use the default working file.
md5
A newly initialized MD5 signature. On output, contains the MD5 signature calculated from the file's content, adjusted as determined by bUsesKeywords and bConvertEOL.

Return Value

The number of bytes in the as it would be stored in the StarTeam repository. #getMD5

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace | resyncStatus | Status


File.ConvertArchive Method

This method causes the server to convert all versions stored in the archives associated with the file to the storage parameters specified. This can not be called for a not-in-view file (an exception will be thrown). A new file revision will be created. Note that archive conversion is irreversible in the sense that the archive cannot be restored to its original state if it contained versions using mixed storage options. Note also that the archive conversion may be a fairly long operation depending on the number and size of versions stored in the archive files.

public virtual void ConvertArchive(
Boolean useDeltaStorage,
Int32 compressionLevel
);

Parameters

useDeltaStorage
true if the archive should use delta storage
compressionLevel
desired compression level. This value must be one of the possible values for the Compression enumerated property.

See Also

File Class | StarTeam Namespace


File.ConvertToNativeIIArchive Method

Convert this File's archives to Native II format. Available starting with server release 7.0

public virtual void ConvertToNativeIIArchive(
Boolean bDeleteOldArchives
);

Parameters

bDeleteOldArchives
True if old archives should be deleted, otherwise false.

See Also

File Class | StarTeam Namespace


File.Create Method

Create a File in the specified parent folder. When the file name property is set, there is an expectation that there is a working file on disk with this name, whose working path maps to the folder path of the specified parent folder

public static File Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new File Object.

See Also

File Class | StarTeam Namespace


File.DeleteLocalFile Method

Deletes the specified local file and has the side effect of deleting sync information from the server about the file.

public virtual bool DeleteLocalFile(
FileInfo file
);

Parameters

file
the local file to delete

Return Value

true if the file was deleted and false otherwise

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace | isDisembodied


File.DeleteSyncInfo Method

Removes sync information from this File object's Server. Once it has been called the Status for file will be unknown. Use with caution.

public virtual void DeleteSyncInfo(
FileInfo file
);

Parameters

file
the local file for which to delete status information

See Also

File Class | StarTeam Namespace | isDisembodied


File.GetFileSyncInfo Method

Attempts to determine what version of the file is actually on disk.

This method is similar to resyncStatus, except that the status information is returned to the caller, rather than being cached with the Server object. This is useful for server-based applications running on behalf of a remote client, when running against a StarTeam server that supports client-managed status.

public virtual WorkspaceSync GetFileSyncInfo(
MD5 compareMD5,
Int64 compareSize,
MD5 syncMD5,
Int64 syncSize,
DateTime syncTime
);

Parameters

compareMD5
The original MD5 signature of this file, as stored in the StarTeam repository. This is the signature that is compared against the signatures of the various revisions of this file, looking for a match. The compareMD5 signature may be different from the syncMD5 signature as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout. The compareMD5 signature is typically derived using File.Stream.computeCompareMD5().
compareSize
The original size of this file, as stored in the StarTeam repository. This may be different from syncSize as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout.
syncMD5
The MD5 signature of the actual working file on disk. Typically derived using File.Stream.computeSyncMD5().
syncSize
The size of the actual working file on disk.
syncTime
The last modified date of the actual working file on disk.

Return Value

The file status information describing which version of the file is actually on disk. Returns null if the status information could not be determined.

See Also

File Class | StarTeam Namespace | isDisembodied | resyncStatus | computeCompareMD5 | computeSyncMD5 | Status


File.GetSmartStatusValue Method

Gets the status of the given working file relative to the latest version of this file in the repository.

Status is determined by comparing the current size and last modified time with that of the last known revision on disk. However, if the working file differs only in modified time, then the equivalent of an "Update Status" is performed. This gives a more accurate status in cases where the file content has not actually changed.

public virtual Status GetSmartStatusValue(
FileInfo file
);

Parameters

file
The working file whose status is to be determined.

Return Value

The current status of this file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace | Status | getStatus


GetStatusValue Method

Borland StarTeam SDK for .NET

File.GetStatusValue Method

Returns the status of the default working file relative to the file in the repository, using the given size MD5 signature of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

Overload List

Returns the status of the default working file relative to the file in the repository, using the given size MD5 signature of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

public virtual Status GetStatusValue(MD5);

Returns the status of the default working file relative to the file in the repository, using the given size and last modified date of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

public virtual Status GetStatusValue(Int64,DateTime);

Gets the status of the given working file relative to the latest version of this file in the repository. Status is determined by comparing the current size and last modified time with that of the last known revision on disk.

public virtual Status GetStatusValue(FileInfo);

See Also

File Class | StarTeam Namespace | getStatus | updateStatus | resyncStatus | Status


File.GetStatusValue Method (MD5)

Returns the status of the default working file relative to the file in the repository, using the given size MD5 signature of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

public virtual Status GetStatusValue(
MD5 md5
);

Parameters

md5
The MD5 signature of the working file, or null if the signature is unknown or unchanged.

Return Value

The status code for this file.

See Also

File Class | StarTeam Namespace | File.GetStatusValue Overload List | getStatus | updateStatus | resyncStatus | Status


File.GetStatusValue Method (Int64, DateTime)

Returns the status of the default working file relative to the file in the repository, using the given size and last modified date of the file. Assumes the working file is not available locally (for example, it might reside on a remote client workstation).

public virtual Status GetStatusValue(
Int64 size,
DateTime lastModified
);

Parameters

size
The size of the working file on disk.
lastModified
The last modified date of the working file.

Return Value

The status code for this file.

See Also

File Class | StarTeam Namespace | File.GetStatusValue Overload List | getStatus | updateStatus | resyncStatus | Status


File.GetStatusValue Method (FileInfo)

Gets the status of the given working file relative to the latest version of this file in the repository.

Status is determined by comparing the current size and last modified time with that of the last known revision on disk.

public virtual Status GetStatusValue(
FileInfo file
);

Parameters

file
The working file whose status is to be determined.

Return Value

The current status of this file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace | File.GetStatusValue Overload List | Status | getSmartStatus


File.IsFileContentMixedEOL Method

Returns true if the file contains a mixed set of CRs, LFs and/or CRLF's Files that contain this pattern are automatically treated as BINARY files iff the Server Configuration Option MixedEOLAsBinary is set to true. The algorithm results in a short walk through the file until two consecutive EOL characters of different types are encountered. The algorithm will walk the entire file if the pattern is not encountered, such as would be the case for a 'regular' binary file with embedded NULLs, ASCII or UNICODE files.

public static bool IsFileContentMixedEOL(
FileInfo f
);

Parameters

f
the file whose content is to be tested

Return Value

true if the file contains a mixed bag of EOL characters

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace


File.IsInSyncByMD5 Method

public static bool IsInSyncByMD5(
FileInfo file,
File.WorkspaceSync syncInfo
);

See Also

File Class | StarTeam Namespace


File.IsInSyncByTime Method

public static bool IsInSyncByTime(
FileInfo file,
File.WorkspaceSync syncInfo
);

See Also

File Class | StarTeam Namespace


File.MoveLocalFile Method

Moves the local file to the specified folder and has the side effect of moving the status information from the original file to the newly created one Deletes the original file and it's status information at the end of the move

public virtual FileInfo MoveLocalFile(
FileInfo fromFile,
String toFolderPath
);

Parameters

fromFile
the local file to be moved
toFolderPath
the folder to move it to.

Return Value

the file, after it has been moved to the new location

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace


File.RemoveAndDeleteLocal Method

Removes the file item from its parent folder. Note that a file may be shared in another folder in the same or different view. This method will merely remove the one instance (or shared copy) that the method is called on. In addition, this method will delete the corresponding working file.

public virtual void RemoveAndDeleteLocal();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace | isDisembodied


File.Rename Method

Renames this file to a new name along with the side effect of changing the corresponding local file's name as well. This method does the same work as update() but also maintains the status information so that the newly renamed file will have the same status it did prior to the renaming. Simply using setName() and update() will not change the local file name consequently status information would be lost. NOTE: in the case where a file already exists with the new name, but it is not the same file as the old one [e.g., on Unix systems where only the case of the filenames differ], the local file will not be renamed, to avoid loss of data for users.

public virtual void Rename(
String newName
);

Parameters

newName
the file's new name

See Also

File Class | StarTeam Namespace


File.ResyncStatus Method

Attempts to update the repository information about what version of the file is actually on disk.

This method is similar to updateStatus, except that information about the working file is provided explicitly by the caller. The working file itself is not used, and in fact does not need to be accessible. This is useful, for example, if the actual working file resides on a remote client workstation.

public virtual void ResyncStatus(
MD5 compareMD5,
Int64 compareSize,
MD5 syncMD5,
Int64 syncSize,
DateTime syncTime
);

Parameters

compareMD5
The original MD5 signature of this file, as stored in the StarTeam repository. This is the signature that is compared against the signatures of the various revisions of this file, looking for a match. The compareMD5 signature may be different from the syncMD5 signature as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout. The compareMD5 signature is typically derived using File.Stream.computeCompareMD5().
compareSize
The original size of this file, as stored in the StarTeam repository. This may be different from syncSize as a result of compensating for the effects of expanding keywords and performing end-of-line conversion on checkout.
syncMD5
The MD5 signature of the actual working file on disk. Typically derived using File.Stream.computeSyncMD5().
syncSize
The size of the actual working file on disk.
syncTime
The last modified date of the actual working file on disk.

See Also

File Class | StarTeam Namespace | isDisembodied | updateStatus | getStatus | computeCompareMD5 | computeSyncMD5 | Status


File.Rollback Method

rollback the contents of the specified revision of this file on disk. Binary files cannot be rolled back, since the changes made cannot be determined by the StarTeam SDK Merge Engine.

public virtual RollbackSession Rollback();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace


UpdateStatus Method

Borland StarTeam SDK for .NET

File.UpdateStatus Method

Attempts to update the repository information about what version of the file is actually on disk. This method will send the MD5 checksum of the file to the server to see if the contents exactly match any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged.

Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".

Overload List

Attempts to update the repository information about what version of the file is actually on disk. This method will send the MD5 checksum of the file to the server to see if the contents exactly match any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged. Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".

public virtual Status UpdateStatus();

This method sets the status for each file item in an array. It uses several techniques to optimize for speed. 1. It is assumed that all status helpers have the correct file attributes set. This avoids local disk access for checking file and folder existence, unless absolutely necessary. 2. The given array should contains all the files for one or more folders, with files of the same folder grouped together. This allows internal tests to be performed on a per folder basis. The caller is responsible for ensuring that files are grouped by folder, to take full advantage of the performance shortcuts being used. for files that have no provider.

public static void UpdateStatus(File[],LocalFileSystemPropertyProvider);

Updates the server's status information to reflect the fact that the local file's content has the given MD5 signature. The file size and last modified date are assumed to be unknown. Any previously specified values will remain unchanged. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatus(MD5);

Updates the server's status information to reflect the fact that the local file's content has the given size and last modified date. The MD5 signature is assumed to be unknown, and any previously specified value will remain unchanged. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatus(Int64,DateTime);

Updates the server's status information to reflect the fact that the local file's content has the given size, last modified date, and MD5 signature. This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatus(Int64,DateTime,MD5);

See Also

File Class | StarTeam Namespace | isDisembodied | getStatus


File.UpdateStatus Method ()

Attempts to update the repository information about what version of the file is actually on disk. This method will send the MD5 checksum of the file to the server to see if the contents exactly match any known version of the file. If it does match then the StarTeam Server will use that information for status computation. If the contents do not match any known version then the server's status information will remain unchanged.

Example uses of this would be if you copied the file to its new location through the OS rather than StarTeam the file's status would be "Unknown" If the local file had the same contents as the tip version of the file in the repository then further status computations would report the file as "Current".

public virtual Status UpdateStatus();

Return Value

Status the status after the sync up, or NULL if the status cannot be predicted

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace | File.UpdateStatus Overload List | isDisembodied | getStatus


File.UpdateStatus Method (File[], LocalFileSystemPropertyProvider)

This method sets the status for each file item in an array. It uses several techniques to optimize for speed. 1. It is assumed that all status helpers have the correct file attributes set. This avoids local disk access for checking file and folder existence, unless absolutely necessary. 2. The given array should contains all the files for one or more folders, with files of the same folder grouped together. This allows internal tests to be performed on a per folder basis. The caller is responsible for ensuring that files are grouped by folder, to take full advantage of the performance shortcuts being used. for files that have no provider.

public static void UpdateStatus(
File[] files,
LocalFileSystemPropertyProvider aProvider
);

Parameters

files
the files to be processed for changed attributes.
aProvider
the LocalFileSystemPropertyProvider whose status needs updating

See Also

File Class | StarTeam Namespace | File.UpdateStatus Overload List


File.UpdateStatus Method (MD5)

Updates the server's status information to reflect the fact that the local file's content has the given MD5 signature.

The file size and last modified date are assumed to be unknown. Any previously specified values will remain unchanged.

This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatus(
MD5 signature
);

Parameters

signature
The MD5 signature of the working file.

See Also

File Class | StarTeam Namespace | File.UpdateStatus Overload List | isDisembodied | getStatus | updateStatus | resyncStatus | Status


File.UpdateStatus Method (Int64, DateTime)

Updates the server's status information to reflect the fact that the local file's content has the given size and last modified date.

The MD5 signature is assumed to be unknown, and any previously specified value will remain unchanged.

This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatus(
Int64 size,
DateTime lastModified
);

Parameters

size
The size of the working file on disk.
lastModified
The last modified date of the working file.

See Also

File Class | StarTeam Namespace | File.UpdateStatus Overload List | isDisembodied | getStatus | updateStatus | resyncStatus | Status


File.UpdateStatus Method (Int64, DateTime, MD5)

Updates the server's status information to reflect the fact that the local file's content has the given size, last modified date, and MD5 signature.

This is useful when the working file resides on a remote workstation, and the remote client is able to calculate the status parameters.

public virtual void UpdateStatus(
Int64 fileSize,
DateTime lastModified,
MD5 signature
);

Parameters

fileSize
The size of the working file on disk. A negative value indicates that the size is unknown.
lastModified
The last modified date of the working file. null indicates that the last modified date is unknown.
signature
The MD5 signature of the working file. null indicates that the signature is unknown. Use null DateTime to indicate last modified time is unknown.

See Also

File Class | StarTeam Namespace | File.UpdateStatus Overload List | isDisembodied | updateStatus | resyncStatus | Status


File.UpdateStatusAfterMerge Method

Updates the status information to reflect the fact that the local file's contents were derived from this file's contents. You would most commonly want to call this after merging in changes. This file's status will be "Modified" after a call to this method if this file is the tip version of the file.

public virtual void UpdateStatusAfterMerge();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File Class | StarTeam Namespace | isDisembodied


File.AddResult Class

The class holds return information specific to the file add operation.

For a list of all members of this type, see File.AddResult Members.

System.Object
File.Result
File.AddResult

public class File.AddResult : Result

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.AddResult Members | StarTeam Namespace


File.AddResult Members

File.AddResult overview

Public Instance Properties

Keywords [read] the keywords used for the file operation.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.AddResult.
GetHashCode | Delegate GetHashCode() to com.starteam.File.AddResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.AddResult.

See Also

File.AddResult Class | StarTeam Namespace


File.AddResult Properties

The properties of the File.AddResult class are listed below. For a complete list of File.AddResult class members, see the File.AddResult Members topic.

Public Instance Properties

Keywords [read] the keywords used for the file operation.

See Also

File.AddResult Class | StarTeam Namespace


Keywords Property

Borland StarTeam SDK for .NET

File.AddResult.Keywords Property

[read] the keywords used for the file operation.

new public virtual Keyword[] Keywords {get;}

Property Value

the keywords used for the file operation.

See Also

File.AddResult Class | StarTeam Namespace


File.AddResult Methods

The methods of the File.AddResult class are listed below. For a complete list of File.AddResult class members, see the File.AddResult Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.AddResult.
GetHashCode | Delegate GetHashCode() to com.starteam.File.AddResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.AddResult.

See Also

File.AddResult Class | StarTeam Namespace


File.AddResult.Equals Method

Delegate Equals() to com.starteam.File.AddResult.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.AddResult.Equals(obj).

See Also

File.AddResult Class | StarTeam Namespace


File.AddResult.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.AddResult.

public override int GetHashCode();

Return Value

com.starteam.File.AddResult.GetHashCode().

See Also

File.AddResult Class | StarTeam Namespace


File.AddResult.ToString Method

Delegate ToString() to com.starteam.File.AddResult.

public override string ToString();

Return Value

com.starteam.File.AddResult.ToString()

See Also

File.AddResult Class | StarTeam Namespace


File.CharacterSet Class

The character set of a working file on disk.

For a list of all members of this type, see File.CharacterSet Members.

System.Object
EnumeratedValue
File.CharacterSet

public class File.CharacterSet : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.CharacterSet Members | StarTeam Namespace


File.CharacterSet Members

File.CharacterSet overview

Public Static Properties

ALL
ASCII
BINARY
UNICODE

Public Static Methods

FromID | Gets the CharacterSet value corresponding to the given ID.
FromValue | Gets the CharacterSet value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this CharacterSet value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.CharacterSet.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.CharacterSet.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.CharacterSet.

See Also

File.CharacterSet Class | StarTeam Namespace


File.CharacterSet Properties

The properties of the File.CharacterSet class are listed below. For a complete list of File.CharacterSet class members, see the File.CharacterSet Members topic.

Public Static Properties

ALL
ASCII
BINARY
UNICODE

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this CharacterSet value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

File.CharacterSet Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

File.CharacterSet.ALL Property

public static CharacterSet[] ALL {get;}

See Also

File.CharacterSet Class | StarTeam Namespace


ASCII Property

Borland StarTeam SDK for .NET

File.CharacterSet.ASCII Property

public static File.CharacterSet ASCII {get;}

Property Value

The working file on disk has ASCII content.

See Also

File.CharacterSet Class | StarTeam Namespace


BINARY Property

Borland StarTeam SDK for .NET

File.CharacterSet.BINARY Property

public static File.CharacterSet BINARY {get;}

Property Value

The working file on disk has Binary content.

See Also

File.CharacterSet Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

File.CharacterSet.ID Property

[read] The ID of this CharacterSet value.

public virtual Int32 ID {get;}

Property Value

The ID of this CharacterSet value.

See Also

File.CharacterSet Class | StarTeam Namespace


UNICODE Property

Borland StarTeam SDK for .NET

File.CharacterSet.UNICODE Property

public static File.CharacterSet UNICODE {get;}

Property Value

The working file on disk has Unicode content.

See Also

File.CharacterSet Class | StarTeam Namespace


File.CharacterSet Methods

The methods of the File.CharacterSet class are listed below. For a complete list of File.CharacterSet class members, see the File.CharacterSet Members topic.

Public Static Methods

FromID | Gets the CharacterSet value corresponding to the given ID.
FromValue | Gets the CharacterSet value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.CharacterSet.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.CharacterSet.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.CharacterSet.

See Also

File.CharacterSet Class | StarTeam Namespace


File.CharacterSet.Equals Method

Delegate Equals() to com.starteam.File.CharacterSet.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.CharacterSet.Equals(obj).

See Also

File.CharacterSet Class | StarTeam Namespace


File.CharacterSet.FromID Method

Gets the CharacterSet value corresponding to the given ID.

public static CharacterSet FromID(
Int32 id
);

Parameters

id
A CharacterSet ID.

Return Value

The corresponding CharacterSet value, or null.

See Also

File.CharacterSet Class | StarTeam Namespace


File.CharacterSet.FromValue Method

Gets the CharacterSet value corresponding to the given EnumeratedValue.

public static CharacterSet FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a CharacterSetProperty.

Return Value

The corresponding CharacterSet value, or null.

See Also

File.CharacterSet Class | StarTeam Namespace


File.CharacterSet.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.CharacterSet.

public override int GetHashCode();

Return Value

com.starteam.File.CharacterSet.GetHashCode().

See Also

File.CharacterSet Class | StarTeam Namespace


File.CharacterSet.ToString Method

Delegate ToString() to com.starteam.File.CharacterSet.

public override string ToString();

Return Value

com.starteam.File.CharacterSet.ToString()

See Also

File.CharacterSet Class | StarTeam Namespace


File.CheckInResult Class

The class holds return information specific to the file checkin operation.

For a list of all members of this type, see File.CheckInResult Members.

System.Object
File.Result
File.CheckInResult

public class File.CheckInResult : Result

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.CheckInResult Members | StarTeam Namespace


File.CheckInResult Members

File.CheckInResult overview

Public Instance Properties

Keywords [read] the keywords used for the file operation.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.CheckInResult.
GetHashCode | Delegate GetHashCode() to com.starteam.File.CheckInResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.CheckInResult.

See Also

File.CheckInResult Class | StarTeam Namespace


File.CheckInResult Properties

The properties of the File.CheckInResult class are listed below. For a complete list of File.CheckInResult class members, see the File.CheckInResult Members topic.

Public Instance Properties

Keywords [read] the keywords used for the file operation.

See Also

File.CheckInResult Class | StarTeam Namespace


Keywords Property

Borland StarTeam SDK for .NET

File.CheckInResult.Keywords Property

[read] the keywords used for the file operation.

new public virtual Keyword[] Keywords {get;}

Property Value

the keywords used for the file operation.

See Also

File.CheckInResult Class | StarTeam Namespace


File.CheckInResult Methods

The methods of the File.CheckInResult class are listed below. For a complete list of File.CheckInResult class members, see the File.CheckInResult Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.CheckInResult.
GetHashCode | Delegate GetHashCode() to com.starteam.File.CheckInResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.CheckInResult.

See Also

File.CheckInResult Class | StarTeam Namespace


File.CheckInResult.Equals Method

Delegate Equals() to com.starteam.File.CheckInResult.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.CheckInResult.Equals(obj).

See Also

File.CheckInResult Class | StarTeam Namespace


File.CheckInResult.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.CheckInResult.

public override int GetHashCode();

Return Value

com.starteam.File.CheckInResult.GetHashCode().

See Also

File.CheckInResult Class | StarTeam Namespace


File.CheckInResult.ToString Method

Delegate ToString() to com.starteam.File.CheckInResult.

public override string ToString();

Return Value

com.starteam.File.CheckInResult.ToString()

See Also

File.CheckInResult Class | StarTeam Namespace


File.CheckOutResult Class

The class holds return information specific to the file checkout operation.

For a list of all members of this type, see File.CheckOutResult Members.

System.Object
File.Result
File.CheckOutResult

public class File.CheckOutResult : Result

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.CheckOutResult Members | StarTeam Namespace


File.CheckOutResult Members

File.CheckOutResult overview

Public Instance Properties

ExclusiveLocker | [read] the User object who has an exclusive lock on the file.
Keywords | [read] the keywords used for the file operation.
MyLockValue | [read] the lock state of the file for the user performing the checkout.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.CheckOutResult.
GetHashCode | Delegate GetHashCode() to com.starteam.File.CheckOutResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.CheckOutResult.

See Also

File.CheckOutResult Class | StarTeam Namespace


File.CheckOutResult Properties

The properties of the File.CheckOutResult class are listed below. For a complete list of File.CheckOutResult class members, see the File.CheckOutResult Members topic.

Public Instance Properties

ExclusiveLocker | [read] the User object who has an exclusive lock on the file.
Keywords | [read] the keywords used for the file operation.
MyLockValue | [read] the lock state of the file for the user performing the checkout.

See Also

File.CheckOutResult Class | StarTeam Namespace


ExclusiveLocker Property

Borland StarTeam SDK for .NET

File.CheckOutResult.ExclusiveLocker Property

[read] the User object who has an exclusive lock on the file.

public virtual User ExclusiveLocker {get;}

Property Value

the User object who has an exclusive lock on the file.

See Also

File.CheckOutResult Class | StarTeam Namespace


Keywords Property

Borland StarTeam SDK for .NET

File.CheckOutResult.Keywords Property

[read] the keywords used for the file operation.

new public virtual Keyword[] Keywords {get;}

Property Value

the keywords used for the file operation.

See Also

File.CheckOutResult Class | StarTeam Namespace


MyLockValue Property

Borland StarTeam SDK for .NET

File.CheckOutResult.MyLockValue Property

[read] the lock state of the file for the user performing the checkout.

public virtual ViewMember.MyLock MyLockValue {get;}

Property Value

the lock state of the file for the user performing the checkout.

See Also

File.CheckOutResult Class | StarTeam Namespace


File.CheckOutResult Methods

The methods of the File.CheckOutResult class are listed below. For a complete list of File.CheckOutResult class members, see the File.CheckOutResult Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.CheckOutResult.
GetHashCode | Delegate GetHashCode() to com.starteam.File.CheckOutResult.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.CheckOutResult.

See Also

File.CheckOutResult Class | StarTeam Namespace


File.CheckOutResult.Equals Method

Delegate Equals() to com.starteam.File.CheckOutResult.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.CheckOutResult.Equals(obj).

See Also

File.CheckOutResult Class | StarTeam Namespace


File.CheckOutResult.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.CheckOutResult.

public override int GetHashCode();

Return Value

com.starteam.File.CheckOutResult.GetHashCode().

See Also

File.CheckOutResult Class | StarTeam Namespace


File.CheckOutResult.ToString Method

Delegate ToString() to com.starteam.File.CheckOutResult.

public override string ToString();

Return Value

com.starteam.File.CheckOutResult.ToString()

See Also

File.CheckOutResult Class | StarTeam Namespace


File.Compression Class

File compression level.

For a list of all members of this type, see File.Compression Members.

System.Object
EnumeratedValue
File.Compression

public class File.Compression : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Compression Members | StarTeam Namespace


File.Compression Members

File.Compression overview

Public Static Properties

ALL
DEFAULT
FAST
NONE
SMALL

Public Static Methods

FromID | Gets the Compression value corresponding to the given ID.
FromValue | Gets the Compression value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Compression value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.Compression.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.Compression.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.Compression.

See Also

File.Compression Class | StarTeam Namespace


File.Compression Properties

The properties of the File.Compression class are listed below. For a complete list of File.Compression class members, see the File.Compression Members topic.

Public Static Properties

ALL
DEFAULT
FAST
NONE
SMALL

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Compression value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

File.Compression Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

File.Compression.ALL Property

public static Compression[] ALL {get;}

See Also

File.Compression Class | StarTeam Namespace


DEFAULT Property

Borland StarTeam SDK for .NET

File.Compression.DEFAULT Property

public static File.Compression DEFAULT {get;}

Property Value

Default compression algorithm is a compromise between speed and size.

See Also

File.Compression Class | StarTeam Namespace


FAST Property

Borland StarTeam SDK for .NET

File.Compression.FAST Property

public static File.Compression FAST {get;}

Property Value

Compression algorithm that maximizes speed.

See Also

File.Compression Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

File.Compression.ID Property

[read] The ID of this Compression value.

public virtual Int32 ID {get;}

Property Value

The ID of this Compression value.

See Also

File.Compression Class | StarTeam Namespace


NONE Property

Borland StarTeam SDK for .NET

File.Compression.NONE Property

public static File.Compression NONE {get;}

Property Value

No compression.

See Also

File.Compression Class | StarTeam Namespace


SMALL Property

Borland StarTeam SDK for .NET

File.Compression.SMALL Property

public static File.Compression SMALL {get;}

Property Value

Compression algorithm that minimizes size of the compressed file.

See Also

File.Compression Class | StarTeam Namespace


File.Compression Methods

The methods of the File.Compression class are listed below. For a complete list of File.Compression class members, see the File.Compression Members topic.

Public Static Methods

FromID | Gets the Compression value corresponding to the given ID.
FromValue | Gets the Compression value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.Compression.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.Compression.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.Compression.

See Also

File.Compression Class | StarTeam Namespace


File.Compression.Equals Method

Delegate Equals() to com.starteam.File.Compression.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Compression.Equals(obj).

See Also

File.Compression Class | StarTeam Namespace


File.Compression.FromID Method

Gets the Compression value corresponding to the given ID.

public static Compression FromID(
Int32 id
);

Parameters

id
The ID of a Compression value.

Return Value

The corresponding Compression value, or null.

See Also

File.Compression Class | StarTeam Namespace


File.Compression.FromValue Method

Gets the Compression value corresponding to the given EnumeratedValue.

public static Compression FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a CompressionProperty.

Return Value

The corresponding Compression value, or null.

See Also

File.Compression Class | StarTeam Namespace


File.Compression.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Compression.

public override int GetHashCode();

Return Value

com.starteam.File.Compression.GetHashCode().

See Also

File.Compression Class | StarTeam Namespace


File.Compression.ToString Method

Delegate ToString() to com.starteam.File.Compression.

public override string ToString();

Return Value

com.starteam.File.Compression.ToString()

See Also

File.Compression Class | StarTeam Namespace


File.Digest Interface

For a list of all members of this type, see File.Digest Members.

public interface File.Digest

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Digest Members | StarTeam Namespace


File.Digest Members

File.Digest overview

Public Instance Properties

FileMD5
FileSize
FileTime

See Also

File.Digest Interface | StarTeam Namespace


File.Digest Properties

The properties of the File.Digest interface are listed below. For a complete list of File.Digest interface members, see the File.Digest Members topic.

Public Instance Properties

FileMD5
FileSize
FileTime

See Also

File.Digest Interface | StarTeam Namespace


FileMD5 Property

Borland StarTeam SDK for .NET

File.Digest.FileMD5 Property

MD5 FileMD5 {get; set;}

See Also

File.Digest Interface | StarTeam Namespace


FileSize Property

Borland StarTeam SDK for .NET

File.Digest.FileSize Property

Int64 FileSize {get; set;}

See Also

File.Digest Interface | StarTeam Namespace


FileTime Property

Borland StarTeam SDK for .NET

File.Digest.FileTime Property

DateTime FileTime {get; set;}

See Also

File.Digest Interface | StarTeam Namespace


File.EOLFormat Class

The EOL format of a text file on disk.

For a list of all members of this type, see File.EOLFormat Members.

System.Object
EnumeratedValue
File.EOLFormat

public class File.EOLFormat : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.EOLFormat Members | StarTeam Namespace


File.EOLFormat Members

File.EOLFormat overview

Public Static Properties

ALL
CLIENT_DEFINED
FIXED_CR
FIXED_CRLF
FIXED_LF
PLATFORM

Public Static Methods

FromEOL | Determines the EOLFormat whose end-of-line character sequence matches the given one. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.
FromEOLFormatID | Determines the EOLFormat whose end-of-line character sequence matches the given LineReader EOL ID. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.
FromID | Gets the EOLFormat value corresponding to the given ID.
FromValue | Gets the EOLFormat value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
EOL | [read] String
ID | [read] The ID of this EOL format.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsFixed | [read] boolean
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
PlatformEOL | [read] Platform#EOL
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.EOLFormat.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.EOLFormat.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToPropertyValue | Gets the EOLFormat used as the default value of the FILE_EOL_CHARACTER property for files whose actual EOLFormat is this one. Returns CLIENT_DEFINED if this EOLFormat matches the PLATFORM EOLFormat; otherwise, returns this EOLFormat itself.
ToString | Delegate ToString() to com.starteam.File.EOLFormat.

See Also

File.EOLFormat Class | StarTeam Namespace


File.EOLFormat Properties

The properties of the File.EOLFormat class are listed below. For a complete list of File.EOLFormat class members, see the File.EOLFormat Members topic.

Public Static Properties

ALL
CLIENT_DEFINED
FIXED_CR
FIXED_CRLF
FIXED_LF
PLATFORM

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
EOL | [read] String
ID | [read] The ID of this EOL format.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsFixed | [read] boolean
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
PlatformEOL | [read] Platform#EOL
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

File.EOLFormat Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

File.EOLFormat.ALL Property

public static EOLFormat[] ALL {get;}

See Also

File.EOLFormat Class | StarTeam Namespace


CLIENT_DEFINED Property

Borland StarTeam SDK for .NET

File.EOLFormat.CLIENT_DEFINED Property

public static File.EOLFormat CLIENT_DEFINED {get;}

Property Value

The EOL format of the working file on disk is determined by the client.

See Also

File.EOLFormat Class | StarTeam Namespace


EOL Property

Borland StarTeam SDK for .NET

File.EOLFormat.EOL Property

[read] String

public virtual String EOL {get;}

Property Value

String

See Also

File.EOLFormat Class | StarTeam Namespace


FIXED_CR Property

Borland StarTeam SDK for .NET

File.EOLFormat.FIXED_CR Property

public static File.EOLFormat FIXED_CR {get;}

Property Value

The working file on disk always uses a carriage return to denote end-of-line.

See Also

File.EOLFormat Class | StarTeam Namespace


FIXED_CRLF Property

Borland StarTeam SDK for .NET

File.EOLFormat.FIXED_CRLF Property

public static File.EOLFormat FIXED_CRLF {get;}

Property Value

The working file on disk always uses a carriage return / line feed sequence to denote end-of-line.

See Also

File.EOLFormat Class | StarTeam Namespace


FIXED_LF Property

Borland StarTeam SDK for .NET

File.EOLFormat.FIXED_LF Property

public static File.EOLFormat FIXED_LF {get;}

Property Value

The working file on disk always uses a line feed to denote end-of-line.

See Also

File.EOLFormat Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

File.EOLFormat.ID Property

[read] The ID of this EOL format.

public virtual Int32 ID {get;}

Property Value

The ID of this EOL format.

See Also

File.EOLFormat Class | StarTeam Namespace


IsFixed Property

Borland StarTeam SDK for .NET

File.EOLFormat.IsFixed Property

[read] boolean

public virtual Boolean IsFixed {get;}

Property Value

boolean

See Also

File.EOLFormat Class | StarTeam Namespace


PLATFORM Property

Borland StarTeam SDK for .NET

File.EOLFormat.PLATFORM Property

public static File.EOLFormat PLATFORM {get;}

Property Value

The native EOLFormat for this platform; one of FIXED_CRLF, FIXED_LF or FIXED_CR.

See Also

File.EOLFormat Class | StarTeam Namespace


PlatformEOL Property

Borland StarTeam SDK for .NET

File.EOLFormat.PlatformEOL Property

[read] Platform#EOL

public virtual Platform.EOL PlatformEOL {get;}

Property Value

Platform#EOL

See Also

File.EOLFormat Class | StarTeam Namespace


File.EOLFormat Methods

The methods of the File.EOLFormat class are listed below. For a complete list of File.EOLFormat class members, see the File.EOLFormat Members topic.

Public Static Methods

FromEOL | Determines the EOLFormat whose end-of-line character sequence matches the given one. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.
FromEOLFormatID | Determines the EOLFormat whose end-of-line character sequence matches the given LineReader EOL ID. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.
FromID | Gets the EOLFormat value corresponding to the given ID.
FromValue | Gets the EOLFormat value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.EOLFormat.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.EOLFormat.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToPropertyValue | Gets the EOLFormat used as the default value of the FILE_EOL_CHARACTER property for files whose actual EOLFormat is this one. Returns CLIENT_DEFINED if this EOLFormat matches the PLATFORM EOLFormat; otherwise, returns this EOLFormat itself.
ToString | Delegate ToString() to com.starteam.File.EOLFormat.

See Also

File.EOLFormat Class | StarTeam Namespace


File.EOLFormat.Equals Method

Delegate Equals() to com.starteam.File.EOLFormat.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.EOLFormat.Equals(obj).

See Also

File.EOLFormat Class | StarTeam Namespace


File.EOLFormat.FromEOL Method

Determines the EOLFormat whose end-of-line character sequence matches the given one. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.

public static EOLFormat FromEOL(
String eol
);

Parameters

eol
String

Return Value

EOLFormat

See Also

File.EOLFormat Class | StarTeam Namespace | getEOL


File.EOLFormat.FromEOLFormatID Method

Determines the EOLFormat whose end-of-line character sequence matches the given LineReader EOL ID. Considers only the fixed EOLFormat; that is, fromEOL() never returns CLIENT_DEFAULT. Returns null if the given eol doesn't match any of the known EOLFormats.

public static EOLFormat FromEOLFormatID(
Int32 id
);

Parameters

id
int

Return Value

EOLFormat

See Also

File.EOLFormat Class | StarTeam Namespace | getEOLFormat


File.EOLFormat.FromID Method

Gets the EOLFormat value corresponding to the given ID.

public static EOLFormat FromID(
Int32 id
);

Parameters

id
The ID of an EOLFormat.

Return Value

The corresponding EOLFormat value, or null.

See Also

File.EOLFormat Class | StarTeam Namespace


File.EOLFormat.FromValue Method

Gets the EOLFormat value corresponding to the given EnumeratedValue.

public static EOLFormat FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of an EOLFormatProperty.

Return Value

The corresponding EOLFormat value, or null.

See Also

File.EOLFormat Class | StarTeam Namespace


File.EOLFormat.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.EOLFormat.

public override int GetHashCode();

Return Value

com.starteam.File.EOLFormat.GetHashCode().

See Also

File.EOLFormat Class | StarTeam Namespace


File.EOLFormat.ToPropertyValue Method

Gets the EOLFormat used as the default value of the FILE_EOL_CHARACTER property for files whose actual EOLFormat is this one.

Returns CLIENT_DEFINED if this EOLFormat matches the PLATFORM EOLFormat; otherwise, returns this EOLFormat itself.

public virtual EOLFormat ToPropertyValue();

Return Value

EOLFormat

See Also

File.EOLFormat Class | StarTeam Namespace


File.EOLFormat.ToString Method

Delegate ToString() to com.starteam.File.EOLFormat.

public override string ToString();

Return Value

com.starteam.File.EOLFormat.ToString()

See Also

File.EOLFormat Class | StarTeam Namespace


File.Keyword Interface

A Keyword object that encapsulates information about a File keyword. When a file is added, checked-in or checked-out of the repository keyword expansion may be applied to the contents of the file. For example, an occurrence of $Author$ in a file might be be replaced with $Author: Fred$ upon checkout. NOTE: This interface is not intended to be implemented by client applications.

For a list of all members of this type, see File.Keyword Members.

public interface File.Keyword

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Keyword Members | StarTeam Namespace


File.Keyword Members

File.Keyword overview

Public Instance Properties

IsMultiLine | [read] true if this keyword spans multiple lines.
Name | [read] the keyword name.
StopExpanding | [read] true if keyword expansion should stop in a file after encountering this keyword.
Value | [read] the keyword value
XMLString | [read] an XML representation of the keyword.

Public Instance Methods

Expand | Returns the expanded or unexpanded version of this keyword. For example, if the keyword is "Author" then expanding this should return "Author: Fred$". Note that the leading $ is not returned, it is handled elsehwere. Unexpand would return "Author$"
Matches | Returns true of this keyword is found in the specified line. If found then the endPos parameter is treated as an output parameter and the value of endPos[0] should be the position in the line where the ending $ occurs.

See Also

File.Keyword Interface | StarTeam Namespace


File.Keyword Properties

The properties of the File.Keyword interface are listed below. For a complete list of File.Keyword interface members, see the File.Keyword Members topic.

Public Instance Properties

IsMultiLine | [read] true if this keyword spans multiple lines.
Name | [read] the keyword name.
StopExpanding | [read] true if keyword expansion should stop in a file after encountering this keyword.
Value | [read] the keyword value
XMLString | [read] an XML representation of the keyword.

See Also

File.Keyword Interface | StarTeam Namespace


IsMultiLine Property

Borland StarTeam SDK for .NET

File.Keyword.IsMultiLine Property

[read] true if this keyword spans multiple lines.

Boolean IsMultiLine {get;}

Property Value

true if this keyword spans multiple lines.

See Also

File.Keyword Interface | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

File.Keyword.Name Property

[read] the keyword name.

String Name {get;}

Property Value

the keyword name.

See Also

File.Keyword Interface | StarTeam Namespace


StopExpanding Property

Borland StarTeam SDK for .NET

File.Keyword.StopExpanding Property

[read] true if keyword expansion should stop in a file after encountering this keyword.

Boolean StopExpanding {get;}

Property Value

true if keyword expansion should stop in a file after encountering this keyword.

See Also

File.Keyword Interface | StarTeam Namespace


Value Property

Borland StarTeam SDK for .NET

File.Keyword.Value Property

[read] the keyword value

String Value {get;}

Property Value

the keyword value

See Also

File.Keyword Interface | StarTeam Namespace


XMLString Property

Borland StarTeam SDK for .NET

File.Keyword.XMLString Property

[read] an XML representation of the keyword.

String XMLString {get;}

Property Value

an XML representation of the keyword.

See Also

File.Keyword Interface | StarTeam Namespace


File.Keyword Methods

The methods of the File.Keyword interface are listed below. For a complete list of File.Keyword interface members, see the File.Keyword Members topic.

Public Instance Methods

Expand | Returns the expanded or unexpanded version of this keyword. For example, if the keyword is "Author" then expanding this should return "Author: Fred$". Note that the leading $ is not returned, it is handled elsehwere. Unexpand would return "Author$"
Matches | Returns true of this keyword is found in the specified line. If found then the endPos parameter is treated as an output parameter and the value of endPos[0] should be the position in the line where the ending $ occurs.

See Also

File.Keyword Interface | StarTeam Namespace


File.Keyword.Expand Method

Returns the expanded or unexpanded version of this keyword. For example, if the keyword is "Author" then expanding this should return "Author: Fred$". Note that the leading $ is not returned, it is handled elsehwere. Unexpand would return "Author$"

string Expand(
String linePrefix,
String eol,
Boolean expand
);

Parameters

linePrefix
the begining of the line in the souce leading up to the keyword
eol
the end-of-line convention used in the source file
expand
true if the keyword is to be expanded and false for unexpand

Return Value

the appropriately expanded or unexpanded keyword.

See Also

File.Keyword Interface | StarTeam Namespace


File.Keyword.Matches Method

Returns true of this keyword is found in the specified line. If found then the endPos parameter is treated as an output parameter and the value of endPos[0] should be the position in the line where the ending $ occurs.

bool Matches(
String line,
Int32 start,
Int32[] endPos
);

Parameters

line
the line to search for this keyword
start
the position in the line (zero based) to start searching
endPos
and "output" array where the end of the keyword occurs.

Return Value

true if the keyword is found on the specified line

See Also

File.Keyword Interface | StarTeam Namespace


File.KeywordFlag Class

File keyword flag.

For a list of all members of this type, see File.KeywordFlag Members.

System.Object
EnumeratedValue
File.KeywordFlag

public class File.KeywordFlag : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.KeywordFlag Members | StarTeam Namespace


File.KeywordFlag Members

File.KeywordFlag overview

Public Static Properties

ALL
ALWAYS_EXPAND
NEVER_EXPAND
PROJECT_SETTINGS

Public Static Methods

FromID | Gets the KeywordFlag value corresponding to the given ID.
FromValue | Gets the KeywordFlag value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Keyword Flag value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.KeywordFlag.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.KeywordFlag.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.KeywordFlag.

See Also

File.KeywordFlag Class | StarTeam Namespace


File.KeywordFlag Properties

The properties of the File.KeywordFlag class are listed below. For a complete list of File.KeywordFlag class members, see the File.KeywordFlag Members topic.

Public Static Properties

ALL
ALWAYS_EXPAND
NEVER_EXPAND
PROJECT_SETTINGS

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Keyword Flag value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

File.KeywordFlag Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

File.KeywordFlag.ALL Property

public static KeywordFlag[] ALL {get;}

See Also

File.KeywordFlag Class | StarTeam Namespace


ALWAYS_EXPAND Property

Borland StarTeam SDK for .NET

File.KeywordFlag.ALWAYS_EXPAND Property

public static File.KeywordFlag ALWAYS_EXPAND {get;}

Property Value

Always Expand Keywords.

See Also

File.KeywordFlag Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

File.KeywordFlag.ID Property

[read] The ID of this Keyword Flag value.

public virtual Int32 ID {get;}

Property Value

The ID of this Keyword Flag value.

See Also

File.KeywordFlag Class | StarTeam Namespace


NEVER_EXPAND Property

Borland StarTeam SDK for .NET

File.KeywordFlag.NEVER_EXPAND Property

public static File.KeywordFlag NEVER_EXPAND {get;}

Property Value

Never expand Keywords.

See Also

File.KeywordFlag Class | StarTeam Namespace


PROJECT_SETTINGS Property

Borland StarTeam SDK for .NET

File.KeywordFlag.PROJECT_SETTINGS Property

public static File.KeywordFlag PROJECT_SETTINGS {get;}

Property Value

Use project Settings.

See Also

File.KeywordFlag Class | StarTeam Namespace


File.KeywordFlag Methods

The methods of the File.KeywordFlag class are listed below. For a complete list of File.KeywordFlag class members, see the File.KeywordFlag Members topic.

Public Static Methods

FromID | Gets the KeywordFlag value corresponding to the given ID.
FromValue | Gets the KeywordFlag value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.KeywordFlag.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.KeywordFlag.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.KeywordFlag.

See Also

File.KeywordFlag Class | StarTeam Namespace


File.KeywordFlag.Equals Method

Delegate Equals() to com.starteam.File.KeywordFlag.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.KeywordFlag.Equals(obj).

See Also

File.KeywordFlag Class | StarTeam Namespace


File.KeywordFlag.FromID Method

Gets the KeywordFlag value corresponding to the given ID.

public static KeywordFlag FromID(
Int32 id
);

Parameters

id
The ID of a KeywordFlag value.

Return Value

The corresponding KeywordFlag value, or null.

See Also

File.KeywordFlag Class | StarTeam Namespace


File.KeywordFlag.FromValue Method

Gets the KeywordFlag value corresponding to the given EnumeratedValue.

public static KeywordFlag FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a KeywordFlagProperty.

Return Value

The corresponding KeywordFlag value, or null.

See Also

File.KeywordFlag Class | StarTeam Namespace


File.KeywordFlag.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.KeywordFlag.

public override int GetHashCode();

Return Value

com.starteam.File.KeywordFlag.GetHashCode().

See Also

File.KeywordFlag Class | StarTeam Namespace


File.KeywordFlag.ToString Method

Delegate ToString() to com.starteam.File.KeywordFlag.

public override string ToString();

Return Value

com.starteam.File.KeywordFlag.ToString()

See Also

File.KeywordFlag Class | StarTeam Namespace


File.KeywordReader Class

For a list of all members of this type, see File.KeywordReader Members.

System.Object
LineProcessor
File.KeywordReader

public class File.KeywordReader : LineProcessor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.KeywordReader Members | StarTeam Namespace


File.KeywordReader Members

File.KeywordReader overview

Public Instance Constructors

File.KeywordReader Overloaded. Initializes a new instance of the File.KeywordReader class.

Public Instance Properties

Append
Encoding

Public Instance Methods

EndofInput (inherited from LineProcessor) |
Equals | Delegate Equals() to com.starteam.File.KeywordReader.
GetHashCode | Delegate GetHashCode() to com.starteam.File.KeywordReader.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine (inherited from LineProcessor) |
ToString | Delegate ToString() to com.starteam.File.KeywordReader.

See Also

File.KeywordReader Class | StarTeam Namespace


File.KeywordReader Constructor

Overload List

public File.KeywordReader(LineReader,Keyword[],Boolean);

public File.KeywordReader(LineReader,Keyword[],Boolean,Encoding);

See Also

File.KeywordReader Class | StarTeam Namespace


File.KeywordReader Constructor (LineReader, File#Keyword[], Boolean)

public File.KeywordReader(
LineReader source,
Keyword[] keywords,
Boolean expand
);

See Also

File.KeywordReader Class | StarTeam Namespace | File.KeywordReader Constructor Overload List


File.KeywordReader Constructor (LineReader, File#Keyword[], Boolean, Encoding)

public File.KeywordReader(
LineReader source,
Keyword[] keywords,
Boolean expand,
Encoding encoding
);

See Also

File.KeywordReader Class | StarTeam Namespace | File.KeywordReader Constructor Overload List


File.KeywordReader Properties

The properties of the File.KeywordReader class are listed below. For a complete list of File.KeywordReader class members, see the File.KeywordReader Members topic.

Public Instance Properties

Append
Encoding

See Also

File.KeywordReader Class | StarTeam Namespace


Append Property

Borland StarTeam SDK for .NET

File.KeywordReader.Append Property

public virtual Boolean Append {set;}

See Also

File.KeywordReader Class | StarTeam Namespace


Encoding Property

Borland StarTeam SDK for .NET

File.KeywordReader.Encoding Property

public virtual Encoding Encoding {set;}

See Also

File.KeywordReader Class | StarTeam Namespace


File.KeywordReader Methods

The methods of the File.KeywordReader class are listed below. For a complete list of File.KeywordReader class members, see the File.KeywordReader Members topic.

Public Instance Methods

EndofInput (inherited from LineProcessor) |
Equals | Delegate Equals() to com.starteam.File.KeywordReader.
GetHashCode | Delegate GetHashCode() to com.starteam.File.KeywordReader.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine (inherited from LineProcessor) |
ToString | Delegate ToString() to com.starteam.File.KeywordReader.

See Also

File.KeywordReader Class | StarTeam Namespace


File.KeywordReader.Equals Method

Delegate Equals() to com.starteam.File.KeywordReader.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.KeywordReader.Equals(obj).

See Also

File.KeywordReader Class | StarTeam Namespace


File.KeywordReader.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.KeywordReader.

public override int GetHashCode();

Return Value

com.starteam.File.KeywordReader.GetHashCode().

See Also

File.KeywordReader Class | StarTeam Namespace


File.KeywordReader.ToString Method

Delegate ToString() to com.starteam.File.KeywordReader.

public override string ToString();

Return Value

com.starteam.File.KeywordReader.ToString()

See Also

File.KeywordReader Class | StarTeam Namespace


File.Operation Class

An Operation Context for a given File, used by the CPC's Custom Trigger

For a list of all members of this type, see File.Operation Members.

System.Object
File.Operation

public class File.Operation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Operation Members | StarTeam Namespace


File.Operation Members

File.Operation overview

Public Static Properties

ATTACH_LABEL
CHECKIN
CHECKOUT
DETACH_LABEL

Public Instance Properties

ID [read] The ID of this Operation.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.Operation.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Operation.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.Operation.

See Also

File.Operation Class | StarTeam Namespace


File.Operation Properties

The properties of the File.Operation class are listed below. For a complete list of File.Operation class members, see the File.Operation Members topic.

Public Static Properties

ATTACH_LABEL
CHECKIN
CHECKOUT
DETACH_LABEL

Public Instance Properties

ID [read] The ID of this Operation.

See Also

File.Operation Class | StarTeam Namespace


ATTACH_LABEL Property

Borland StarTeam SDK for .NET

File.Operation.ATTACH_LABEL Property

public static File.Operation ATTACH_LABEL {get;}

Property Value

An 'Attach Label' Operation is in progress

See Also

File.Operation Class | StarTeam Namespace


CHECKIN Property

Borland StarTeam SDK for .NET

File.Operation.CHECKIN Property

public static File.Operation CHECKIN {get;}

Property Value

A 'Checkin' Operation is in progress

See Also

File.Operation Class | StarTeam Namespace


CHECKOUT Property

Borland StarTeam SDK for .NET

File.Operation.CHECKOUT Property

public static File.Operation CHECKOUT {get;}

Property Value

A 'Checkout' Operation is in progress

See Also

File.Operation Class | StarTeam Namespace


DETACH_LABEL Property

Borland StarTeam SDK for .NET

File.Operation.DETACH_LABEL Property

public static File.Operation DETACH_LABEL {get;}

Property Value

A 'Detach Label' Operation is in progress

See Also

File.Operation Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

File.Operation.ID Property

[read] The ID of this Operation.

public virtual Int32 ID {get;}

Property Value

The ID of this Operation.

See Also

File.Operation Class | StarTeam Namespace


File.Operation Methods

The methods of the File.Operation class are listed below. For a complete list of File.Operation class members, see the File.Operation Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.Operation.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Operation.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.Operation.

See Also

File.Operation Class | StarTeam Namespace


File.Operation.Equals Method

Delegate Equals() to com.starteam.File.Operation.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Operation.Equals(obj).

See Also

File.Operation Class | StarTeam Namespace


File.Operation.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Operation.

public override int GetHashCode();

Return Value

com.starteam.File.Operation.GetHashCode().

See Also

File.Operation Class | StarTeam Namespace


File.Operation.ToString Method

Delegate ToString() to com.starteam.File.Operation.

public override string ToString();

Return Value

com.starteam.File.Operation.ToString()

See Also

File.Operation Class | StarTeam Namespace


File.Result Class

return information common to the file operations of add, checkin and checkout

For a list of all members of this type, see File.Result Members.

System.Object
File.Result
File.AddResult
File.CheckInResult
File.CheckOutResult

public class File.Result

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Result Members | StarTeam Namespace


File.Result Members

File.Result overview

Public Instance Properties

Keywords [read] the keywords used for the file operation.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.Result.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Result.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.Result.

See Also

File.Result Class | StarTeam Namespace


File.Result Properties

The properties of the File.Result class are listed below. For a complete list of File.Result class members, see the File.Result Members topic.

Public Instance Properties

Keywords [read] the keywords used for the file operation.

See Also

File.Result Class | StarTeam Namespace


Keywords Property

Borland StarTeam SDK for .NET

File.Result.Keywords Property

[read] the keywords used for the file operation.

public virtual Keyword[] Keywords {get;}

Property Value

the keywords used for the file operation.

See Also

File.Result Class | StarTeam Namespace


File.Result Methods

The methods of the File.Result class are listed below. For a complete list of File.Result class members, see the File.Result Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.Result.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Result.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.Result.

See Also

File.Result Class | StarTeam Namespace


File.Result.Equals Method

Delegate Equals() to com.starteam.File.Result.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Result.Equals(obj).

See Also

File.Result Class | StarTeam Namespace


File.Result.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Result.

public override int GetHashCode();

Return Value

com.starteam.File.Result.GetHashCode().

See Also

File.Result Class | StarTeam Namespace


File.Result.ToString Method

Delegate ToString() to com.starteam.File.Result.

public override string ToString();

Return Value

com.starteam.File.Result.ToString()

See Also

File.Result Class | StarTeam Namespace


File.Revision Interface

For a list of all members of this type, see File.Revision Members.

public interface File.Revision

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Revision Members | StarTeam Namespace


File.Revision Members

File.Revision overview

Public Instance Properties

ContentRevision
DotNotation
ObjectID
RepositoryID
RevisionNumber
RootObjectID

See Also

File.Revision Interface | StarTeam Namespace


File.Revision Properties

The properties of the File.Revision interface are listed below. For a complete list of File.Revision interface members, see the File.Revision Members topic.

Public Instance Properties

ContentRevision
DotNotation
ObjectID
RepositoryID
RevisionNumber
RootObjectID

See Also

File.Revision Interface | StarTeam Namespace


ContentRevision Property

Borland StarTeam SDK for .NET

File.Revision.ContentRevision Property

Int32 ContentRevision {get; set;}

See Also

File.Revision Interface | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

File.Revision.DotNotation Property

DotNotation DotNotation {get; set;}

See Also

File.Revision Interface | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

File.Revision.ObjectID Property

Int32 ObjectID {get; set;}

See Also

File.Revision Interface | StarTeam Namespace


RepositoryID Property

Borland StarTeam SDK for .NET

File.Revision.RepositoryID Property

GUID RepositoryID {get;}

See Also

File.Revision Interface | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

File.Revision.RevisionNumber Property

Int32 RevisionNumber {get; set;}

See Also

File.Revision Interface | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

File.Revision.RootObjectID Property

Int32 RootObjectID {get; set;}

See Also

File.Revision Interface | StarTeam Namespace


File.Status Class

The current status of the file.

For a list of all members of this type, see File.Status Members.

System.Object
EnumeratedValue
File.Status

public class File.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Status Members | StarTeam Namespace


File.Status Members

File.Status overview

Public Static Properties

ALL
CURRENT
MERGE
MISSING
MODIFIED
NEW
OUT_OF_DATE
UNKNOWN

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.Status.

See Also

File.Status Class | StarTeam Namespace


File.Status Properties

The properties of the File.Status class are listed below. For a complete list of File.Status class members, see the File.Status Members topic.

Public Static Properties

ALL
CURRENT
MERGE
MISSING
MODIFIED
NEW
OUT_OF_DATE
UNKNOWN

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

File.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

File.Status.ALL Property

public static Status[] ALL {get;}

See Also

File.Status Class | StarTeam Namespace


CURRENT Property

Borland StarTeam SDK for .NET

File.Status.CURRENT Property

public static File.Status CURRENT {get;}

Property Value

The working file on disk is CURRENT w.r.t. the repository

See Also

File.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

File.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

File.Status Class | StarTeam Namespace


MERGE Property

Borland StarTeam SDK for .NET

File.Status.MERGE Property

public static File.Status MERGE {get;}

Property Value

The working file on disk needs to be merged with the file in the repository

See Also

File.Status Class | StarTeam Namespace


MISSING Property

Borland StarTeam SDK for .NET

File.Status.MISSING Property

public static File.Status MISSING {get;}

Property Value

There is a file in the repository that is missing on disk

See Also

File.Status Class | StarTeam Namespace


MODIFIED Property

Borland StarTeam SDK for .NET

File.Status.MODIFIED Property

public static File.Status MODIFIED {get;}

Property Value

The working file on disk has been modified

See Also

File.Status Class | StarTeam Namespace


NEW Property

Borland StarTeam SDK for .NET

File.Status.NEW Property

public static File.Status NEW {get;}

Property Value

The working file on disk does not exist in the repository

See Also

File.Status Class | StarTeam Namespace


OUT_OF_DATE Property

Borland StarTeam SDK for .NET

File.Status.OUT_OF_DATE Property

public static File.Status OUT_OF_DATE {get;}

Property Value

The file in the repository has newer content than the working file on disk

See Also

File.Status Class | StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

File.Status.UNKNOWN Property

public static File.Status UNKNOWN {get;}

Property Value

The state of the file on disk w.r.t. the content in the repository cannot be determined

See Also

File.Status Class | StarTeam Namespace


File.Status Methods

The methods of the File.Status class are listed below. For a complete list of File.Status class members, see the File.Status Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.Status.

See Also

File.Status Class | StarTeam Namespace


File.Status.Equals Method

Delegate Equals() to com.starteam.File.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Status.Equals(obj).

See Also

File.Status Class | StarTeam Namespace


File.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

File.Status Class | StarTeam Namespace


File.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

File.Status Class | StarTeam Namespace


File.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Status.

public override int GetHashCode();

Return Value

com.starteam.File.Status.GetHashCode().

See Also

File.Status Class | StarTeam Namespace


File.Status.ToString Method

Delegate ToString() to com.starteam.File.Status.

public override string ToString();

Return Value

com.starteam.File.Status.ToString()

See Also

File.Status Class | StarTeam Namespace


File.StorageType Class

The mechanism used to store this File content in the repository

For a list of all members of this type, see File.StorageType Members.

System.Object
EnumeratedValue
File.StorageType

public class File.StorageType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.StorageType Members | StarTeam Namespace


File.StorageType Members

File.StorageType overview

Public Static Properties

ALL
DELTA
FULL_VERSIONS

Public Static Methods

FromID | Gets the StorageType value corresponding to the given ID.
FromValue | Gets the StorageType value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this StorageType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.StorageType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.StorageType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.StorageType.

See Also

File.StorageType Class | StarTeam Namespace


File.StorageType Properties

The properties of the File.StorageType class are listed below. For a complete list of File.StorageType class members, see the File.StorageType Members topic.

Public Static Properties

ALL
DELTA
FULL_VERSIONS

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this StorageType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

File.StorageType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

File.StorageType.ALL Property

public static StorageType[] ALL {get;}

See Also

File.StorageType Class | StarTeam Namespace


DELTA Property

Borland StarTeam SDK for .NET

File.StorageType.DELTA Property

public static File.StorageType DELTA {get;}

Property Value

Only the differences between this and the previous version are stored

See Also

File.StorageType Class | StarTeam Namespace


FULL_VERSIONS Property

Borland StarTeam SDK for .NET

File.StorageType.FULL_VERSIONS Property

public static File.StorageType FULL_VERSIONS {get;}

Property Value

Each new version of the file checked in is stored in full

See Also

File.StorageType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

File.StorageType.ID Property

[read] The ID of this StorageType value.

public virtual Int32 ID {get;}

Property Value

The ID of this StorageType value.

See Also

File.StorageType Class | StarTeam Namespace


File.StorageType Methods

The methods of the File.StorageType class are listed below. For a complete list of File.StorageType class members, see the File.StorageType Members topic.

Public Static Methods

FromID | Gets the StorageType value corresponding to the given ID.
FromValue | Gets the StorageType value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.File.StorageType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.File.StorageType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.File.StorageType.

See Also

File.StorageType Class | StarTeam Namespace


File.StorageType.Equals Method

Delegate Equals() to com.starteam.File.StorageType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.StorageType.Equals(obj).

See Also

File.StorageType Class | StarTeam Namespace


File.StorageType.FromID Method

Gets the StorageType value corresponding to the given ID.

public static StorageType FromID(
Int32 id
);

Parameters

id
A StorageType ID.

Return Value

The corresponding StorageType value, or null.

See Also

File.StorageType Class | StarTeam Namespace


File.StorageType.FromValue Method

Gets the StorageType value corresponding to the given EnumeratedValue.

public static StorageType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StorageTypeProperty.

Return Value

The corresponding StorageType value, or null.

See Also

File.StorageType Class | StarTeam Namespace


File.StorageType.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.StorageType.

public override int GetHashCode();

Return Value

com.starteam.File.StorageType.GetHashCode().

See Also

File.StorageType Class | StarTeam Namespace


File.StorageType.ToString Method

Delegate ToString() to com.starteam.File.StorageType.

public override string ToString();

Return Value

com.starteam.File.StorageType.ToString()

See Also

File.StorageType Class | StarTeam Namespace


File.Stream Class

Provides utility functions for manipulating File streams.

For a list of all members of this type, see File.Stream Members.

System.Object
File.Stream

public class File.Stream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Stream Members | StarTeam Namespace


File.Stream Members

File.Stream overview

Public Static Methods

ComputeCompareMD5 | Derives an MD5 signature representing what the content of the given file would be if stored in the StarTeam repository. Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.
ComputeSyncMD5 | Derives an MD5 signature representing an actual working file on disk.

Public Instance Constructors

File.Stream Constructor Initializes a new instance of the File.Stream class.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.Stream.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Stream.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.Stream.

See Also

File.Stream Class | StarTeam Namespace


File.Stream Constructor

Initializes a new instance of the File.Stream class.

public File.Stream();

See Also

File.Stream Class | StarTeam Namespace


File.Stream Methods

The methods of the File.Stream class are listed below. For a complete list of File.Stream class members, see the File.Stream Members topic.

Public Static Methods

ComputeCompareMD5 | Derives an MD5 signature representing what the content of the given file would be if stored in the StarTeam repository. Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.
ComputeSyncMD5 | Derives an MD5 signature representing an actual working file on disk.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.Stream.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Stream.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.Stream.

See Also

File.Stream Class | StarTeam Namespace


File.Stream.ComputeCompareMD5 Method

Derives an MD5 signature representing what the content of the given file would be if stored in the StarTeam repository.

Compensates for the effects of expanding keywords and performing end-of-line conversion on checkout.

public static long ComputeCompareMD5(
FileInfo file,
Boolean bUsesKeywords,
Boolean bConvertEOL,
MD5 md5
);

Parameters

file
The working file on disk. An exception will be thrown if the file does not exist or cannot be read.
bUsesKeywords
A newly initialized MD5 signature. On output, contains the MD5 signature calculated from the file's content, adjusted as determined by bUsesKeywords and bConvertEOL.
bConvertEOL
True if this file uses keywords. If true, then the signature is adjusted to compensate for any keyword expansion that would occur on a checkin. If this is a binary file (that is, if it contains at least one '\0' character), bUsesKeywords is ignored, and no adjustment is made to the signature.
md5
True if this is a text file (as opposed to a binary file). The end-of-line characters of text files are always converted to a canonical format in the repository. To specify the desired end-of-line sequence for the working file, see {@link File#setEOLFormat setEOLFormat}.

Return Value

The number of bytes in the as it would be stored in the StarTeam repository.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File.Stream Class | StarTeam Namespace | computeSyncMD5 | resyncStatus | Status


File.Stream.ComputeSyncMD5 Method

Derives an MD5 signature representing an actual working file on disk.

public static long ComputeSyncMD5(
FileInfo file,
MD5 md5
);

Parameters

file
The working file on disk. An exception will be thrown if the file does not exist or cannot be read.
md5
A newly initialized MD5 signature. On output, contains the MD5 signature calculated from the file's content.

Return Value

The number of bytes in the working file on disk.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

File.Stream Class | StarTeam Namespace | computeCompareMD5 | resyncStatus | Status


File.Stream.Equals Method

Delegate Equals() to com.starteam.File.Stream.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Stream.Equals(obj).

See Also

File.Stream Class | StarTeam Namespace


File.Stream.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Stream.

public override int GetHashCode();

Return Value

com.starteam.File.Stream.GetHashCode().

See Also

File.Stream Class | StarTeam Namespace


File.Stream.ToString Method

Delegate ToString() to com.starteam.File.Stream.

public override string ToString();

Return Value

com.starteam.File.Stream.ToString()

See Also

File.Stream Class | StarTeam Namespace


File.SyncRecord Class

a stock Sync Record Implementation to create sync records in syncdb

For a list of all members of this type, see File.SyncRecord Members.

System.Object
File.SyncRecord

public class File.SyncRecord : File.WorkspaceSync

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.SyncRecord Members | StarTeam Namespace


File.SyncRecord Members

File.SyncRecord overview

Public Instance Constructors

File.SyncRecord Constructor default constructor

Public Instance Properties

ContentRevision | [read/write]
DotNotation | [read/write]
FileDigest |
FileMD5 | [read/write]
FileSize | [read/write]
FileTime | [read/write]
IsValid | [read] true if this sync record is valid
LocalFileInfo | [write] set file information from a disk file
ObjectID | [read/write]
RecordID | [read/write] the record id
RecordTime | [read] the record time
RepositoryID | [read]
RevisionIdentifier |
RevisionNumber | [read/write]
RootObjectID | [read/write]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.SyncRecord.
GetHashCode | Delegate GetHashCode() to com.starteam.File.SyncRecord.
GetType (inherited from Object) | Gets the Type of the current instance.
InitFromFile | initialize this record from a File instance
ToString | Delegate ToString() to com.starteam.File.SyncRecord.

See Also

File.SyncRecord Class | StarTeam Namespace


File.SyncRecord Constructor

default constructor

public File.SyncRecord(
GUID serverID
);

Parameters

serverID
the server GUID

See Also

File.SyncRecord Class | StarTeam Namespace


File.SyncRecord Properties

The properties of the File.SyncRecord class are listed below. For a complete list of File.SyncRecord class members, see the File.SyncRecord Members topic.

Public Instance Properties

ContentRevision | [read/write]
DotNotation | [read/write]
FileDigest |
FileMD5 | [read/write]
FileSize | [read/write]
FileTime | [read/write]
IsValid | [read] true if this sync record is valid
LocalFileInfo | [write] set file information from a disk file
ObjectID | [read/write]
RecordID | [read/write] the record id
RecordTime | [read] the record time
RepositoryID | [read]
RevisionIdentifier |
RevisionNumber | [read/write]
RootObjectID | [read/write]

See Also

File.SyncRecord Class | StarTeam Namespace


ContentRevision Property

Borland StarTeam SDK for .NET

File.SyncRecord.ContentRevision Property

[read/write]

public virtual Int32 ContentRevision {get; set;}

See Also

File.SyncRecord Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

File.SyncRecord.DotNotation Property

[read/write]

public virtual DotNotation DotNotation {get; set;}

See Also

File.SyncRecord Class | StarTeam Namespace


FileDigest Property

Borland StarTeam SDK for .NET

File.SyncRecord.FileDigest Property

public virtual File.Digest FileDigest {get;}

Implements

WorkspaceSync.FileDigest

See Also

File.SyncRecord Class | StarTeam Namespace


FileMD5 Property

Borland StarTeam SDK for .NET

File.SyncRecord.FileMD5 Property

[read/write]

public virtual MD5 FileMD5 {get; set;}

See Also

File.SyncRecord Class | StarTeam Namespace


FileSize Property

Borland StarTeam SDK for .NET

File.SyncRecord.FileSize Property

[read/write]

public virtual Int64 FileSize {get; set;}

See Also

File.SyncRecord Class | StarTeam Namespace


FileTime Property

Borland StarTeam SDK for .NET

File.SyncRecord.FileTime Property

[read/write]

public virtual DateTime FileTime {get; set;}

See Also

File.SyncRecord Class | StarTeam Namespace


IsValid Property

Borland StarTeam SDK for .NET

File.SyncRecord.IsValid Property

[read] true if this sync record is valid

public virtual Boolean IsValid {get;}

Property Value

true if this sync record is valid

See Also

File.SyncRecord Class | StarTeam Namespace


LocalFileInfo Property

Borland StarTeam SDK for .NET

File.SyncRecord.LocalFileInfo Property

[write] set file information from a disk file

public virtual FileInfo LocalFileInfo {set;}

Property Value

set file information from a disk file

See Also

File.SyncRecord Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

File.SyncRecord.ObjectID Property

[read/write]

public virtual Int32 ObjectID {get; set;}

See Also

File.SyncRecord Class | StarTeam Namespace


RecordID Property

Borland StarTeam SDK for .NET

File.SyncRecord.RecordID Property

[read/write] the record id

public virtual Int32 RecordID {get; set;}

Property Value

the record id

See Also

File.SyncRecord Class | StarTeam Namespace


RecordTime Property

Borland StarTeam SDK for .NET

File.SyncRecord.RecordTime Property

[read] the record time

public virtual Double RecordTime {get;}

Property Value

the record time

See Also

File.SyncRecord Class | StarTeam Namespace


RepositoryID Property

Borland StarTeam SDK for .NET

File.SyncRecord.RepositoryID Property

[read]

public virtual GUID RepositoryID {get;}

See Also

File.SyncRecord Class | StarTeam Namespace


RevisionIdentifier Property

Borland StarTeam SDK for .NET

File.SyncRecord.RevisionIdentifier Property

public virtual File.Revision RevisionIdentifier {get;}

Implements

WorkspaceSync.RevisionIdentifier

See Also

File.SyncRecord Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

File.SyncRecord.RevisionNumber Property

[read/write]

public virtual Int32 RevisionNumber {get; set;}

See Also

File.SyncRecord Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

File.SyncRecord.RootObjectID Property

[read/write]

public virtual Int32 RootObjectID {get; set;}

See Also

File.SyncRecord Class | StarTeam Namespace


File.SyncRecord Methods

The methods of the File.SyncRecord class are listed below. For a complete list of File.SyncRecord class members, see the File.SyncRecord Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.SyncRecord.
GetHashCode | Delegate GetHashCode() to com.starteam.File.SyncRecord.
GetType (inherited from Object) | Gets the Type of the current instance.
InitFromFile | initialize this record from a File instance
ToString | Delegate ToString() to com.starteam.File.SyncRecord.

See Also

File.SyncRecord Class | StarTeam Namespace


File.SyncRecord.Equals Method

Delegate Equals() to com.starteam.File.SyncRecord.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.SyncRecord.Equals(obj).

See Also

File.SyncRecord Class | StarTeam Namespace


File.SyncRecord.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.SyncRecord.

public override int GetHashCode();

Return Value

com.starteam.File.SyncRecord.GetHashCode().

See Also

File.SyncRecord Class | StarTeam Namespace


File.SyncRecord.InitFromFile Method

initialize this record from a File instance

public virtual void InitFromFile(
File file
);

Parameters

file
the file

See Also

File.SyncRecord Class | StarTeam Namespace


File.SyncRecord.ToString Method

Delegate ToString() to com.starteam.File.SyncRecord.

public override string ToString();

Return Value

com.starteam.File.SyncRecord.ToString()

See Also

File.SyncRecord Class | StarTeam Namespace


File.Type Class

The Type of File items.

For a list of all members of this type, see File.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
File.Type

new public class File.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type Members | StarTeam Namespace


File.Type Members

File.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.File.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.File.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

File.Type Class | StarTeam Namespace


File.Type Properties

The properties of the File.Type class are listed below. For a complete list of File.Type class members, see the File.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

File.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

File.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

File.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

File.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

File.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

File.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

File.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

File.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

File.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

File.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

File.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

File.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

File.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

File.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

File.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.NAME Property

new public static String NAME {get;}

See Also

File.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

File.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

File.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

File.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

File.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

File.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

File.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

File.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

File.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

File.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

File.Type Class | StarTeam Namespace


File.Type Methods

The methods of the File.Type class are listed below. For a complete list of File.Type class members, see the File.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.File.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.File.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

File.Type Class | StarTeam Namespace


File.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

File.Type Class | StarTeam Namespace


File.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

File.Type Class | StarTeam Namespace


File.Type.Equals Method

Delegate Equals() to com.starteam.File.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.Equals(obj).

See Also

File.Type Class | StarTeam Namespace


File.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

File.Type Class | StarTeam Namespace


File.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.

public override int GetHashCode();

Return Value

com.starteam.File.Type.GetHashCode().

See Also

File.Type Class | StarTeam Namespace


File.Type.ToString Method

Delegate ToString() to com.starteam.File.Type.

public override string ToString();

Return Value

com.starteam.File.Type.ToString()

See Also

File.Type Class | StarTeam Namespace


File.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

File.Type Class | StarTeam Namespace


File.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

File.Type Class | StarTeam Namespace


File.Type.ArchiveNameProperty Class

The property type of the Archive Name property.

For a list of all members of this type, see File.Type.ArchiveNameProperty Members.

System.Object
Property
VectorProperty
TextProperty
File.Type.ArchiveNameProperty

public class File.Type.ArchiveNameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.ArchiveNameProperty Members | StarTeam Namespace


File.Type.ArchiveNameProperty Members

File.Type.ArchiveNameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ArchiveNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ArchiveNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ArchiveNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ArchiveNameProperty Class | StarTeam Namespace


File.Type.ArchiveNameProperty Properties

The properties of the File.Type.ArchiveNameProperty class are listed below. For a complete list of File.Type.ArchiveNameProperty class members, see the File.Type.ArchiveNameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.ArchiveNameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.ArchiveNameProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.ArchiveNameProperty Class | StarTeam Namespace


File.Type.ArchiveNameProperty Methods

The methods of the File.Type.ArchiveNameProperty class are listed below. For a complete list of File.Type.ArchiveNameProperty class members, see the File.Type.ArchiveNameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ArchiveNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ArchiveNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ArchiveNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ArchiveNameProperty Class | StarTeam Namespace


File.Type.ArchiveNameProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.ArchiveNameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.ArchiveNameProperty.Equals(obj).

See Also

File.Type.ArchiveNameProperty Class | StarTeam Namespace


File.Type.ArchiveNameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.ArchiveNameProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.ArchiveNameProperty.GetHashCode().

See Also

File.Type.ArchiveNameProperty Class | StarTeam Namespace


File.Type.ArchiveNameProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.ArchiveNameProperty.

public override string ToString();

Return Value

com.starteam.File.Type.ArchiveNameProperty.ToString()

See Also

File.Type.ArchiveNameProperty Class | StarTeam Namespace


File.Type.CharacterSetProperty Class

The property type of the CharacterSet property.

For a list of all members of this type, see File.Type.CharacterSetProperty Members.

System.Object
Property
EnumeratedProperty
File.Type.CharacterSetProperty

public class File.Type.CharacterSetProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.CharacterSetProperty Members | StarTeam Namespace


File.Type.CharacterSetProperty Members

File.Type.CharacterSetProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.CharacterSetProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.CharacterSetProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.CharacterSetProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.CharacterSetProperty Class | StarTeam Namespace


File.Type.CharacterSetProperty Properties

The properties of the File.Type.CharacterSetProperty class are listed below. For a complete list of File.Type.CharacterSetProperty class members, see the File.Type.CharacterSetProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.CharacterSetProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.CharacterSetProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.CharacterSetProperty Class | StarTeam Namespace


File.Type.CharacterSetProperty Methods

The methods of the File.Type.CharacterSetProperty class are listed below. For a complete list of File.Type.CharacterSetProperty class members, see the File.Type.CharacterSetProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.CharacterSetProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.CharacterSetProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.CharacterSetProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.CharacterSetProperty Class | StarTeam Namespace


File.Type.CharacterSetProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.CharacterSetProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.CharacterSetProperty.Equals(obj).

See Also

File.Type.CharacterSetProperty Class | StarTeam Namespace


File.Type.CharacterSetProperty.FromValue Method

public virtual EnumeratedValue FromValue(
File.CharacterSet value
);

See Also

File.Type.CharacterSetProperty Class | StarTeam Namespace


File.Type.CharacterSetProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.CharacterSetProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.CharacterSetProperty.GetHashCode().

See Also

File.Type.CharacterSetProperty Class | StarTeam Namespace


File.Type.CharacterSetProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.CharacterSetProperty.

public override string ToString();

Return Value

com.starteam.File.Type.CharacterSetProperty.ToString()

See Also

File.Type.CharacterSetProperty Class | StarTeam Namespace


File.Type.CompressionProperty Class

The property type of the Compression property.

For a list of all members of this type, see File.Type.CompressionProperty Members.

System.Object
Property
EnumeratedProperty
File.Type.CompressionProperty

public class File.Type.CompressionProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.CompressionProperty Members | StarTeam Namespace


File.Type.CompressionProperty Members

File.Type.CompressionProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.CompressionProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.CompressionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.CompressionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.CompressionProperty Class | StarTeam Namespace


File.Type.CompressionProperty Properties

The properties of the File.Type.CompressionProperty class are listed below. For a complete list of File.Type.CompressionProperty class members, see the File.Type.CompressionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.CompressionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.CompressionProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.CompressionProperty Class | StarTeam Namespace


File.Type.CompressionProperty Methods

The methods of the File.Type.CompressionProperty class are listed below. For a complete list of File.Type.CompressionProperty class members, see the File.Type.CompressionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.CompressionProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.CompressionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.CompressionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.CompressionProperty Class | StarTeam Namespace


File.Type.CompressionProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.CompressionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.CompressionProperty.Equals(obj).

See Also

File.Type.CompressionProperty Class | StarTeam Namespace


File.Type.CompressionProperty.FromValue Method

public virtual EnumeratedValue FromValue(
File.Compression value
);

See Also

File.Type.CompressionProperty Class | StarTeam Namespace


File.Type.CompressionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.CompressionProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.CompressionProperty.GetHashCode().

See Also

File.Type.CompressionProperty Class | StarTeam Namespace


File.Type.CompressionProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.CompressionProperty.

public override string ToString();

Return Value

com.starteam.File.Type.CompressionProperty.ToString()

See Also

File.Type.CompressionProperty Class | StarTeam Namespace


File.Type.ContentModifiedTimeProperty Class

The property type of the FileTimeAtCheckin property.

For a list of all members of this type, see File.Type.ContentModifiedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
File.Type.ContentModifiedTimeProperty

public class File.Type.ContentModifiedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.ContentModifiedTimeProperty Members | StarTeam Namespace


File.Type.ContentModifiedTimeProperty Members

File.Type.ContentModifiedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ContentModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ContentModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ContentModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ContentModifiedTimeProperty Class | StarTeam Namespace


File.Type.ContentModifiedTimeProperty Properties

The properties of the File.Type.ContentModifiedTimeProperty class are listed below. For a complete list of File.Type.ContentModifiedTimeProperty class members, see the File.Type.ContentModifiedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.ContentModifiedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.ContentModifiedTimeProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.ContentModifiedTimeProperty Class | StarTeam Namespace


File.Type.ContentModifiedTimeProperty Methods

The methods of the File.Type.ContentModifiedTimeProperty class are listed below. For a complete list of File.Type.ContentModifiedTimeProperty class members, see the File.Type.ContentModifiedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ContentModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ContentModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ContentModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ContentModifiedTimeProperty Class | StarTeam Namespace


File.Type.ContentModifiedTimeProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.ContentModifiedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.ContentModifiedTimeProperty.Equals(obj).

See Also

File.Type.ContentModifiedTimeProperty Class | StarTeam Namespace


File.Type.ContentModifiedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.ContentModifiedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.ContentModifiedTimeProperty.GetHashCode().

See Also

File.Type.ContentModifiedTimeProperty Class | StarTeam Namespace


File.Type.ContentModifiedTimeProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.ContentModifiedTimeProperty.

public override string ToString();

Return Value

com.starteam.File.Type.ContentModifiedTimeProperty.ToString()

See Also

File.Type.ContentModifiedTimeProperty Class | StarTeam Namespace


File.Type.ContentVersionProperty Class

The property type of the ContentVersion property.

For a list of all members of this type, see File.Type.ContentVersionProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
File.Type.ContentVersionProperty

public class File.Type.ContentVersionProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.ContentVersionProperty Members | StarTeam Namespace


File.Type.ContentVersionProperty Members

File.Type.ContentVersionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ContentVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ContentVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ContentVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ContentVersionProperty Class | StarTeam Namespace


File.Type.ContentVersionProperty Properties

The properties of the File.Type.ContentVersionProperty class are listed below. For a complete list of File.Type.ContentVersionProperty class members, see the File.Type.ContentVersionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.ContentVersionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.ContentVersionProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.ContentVersionProperty Class | StarTeam Namespace


File.Type.ContentVersionProperty Methods

The methods of the File.Type.ContentVersionProperty class are listed below. For a complete list of File.Type.ContentVersionProperty class members, see the File.Type.ContentVersionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ContentVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ContentVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ContentVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ContentVersionProperty Class | StarTeam Namespace


File.Type.ContentVersionProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.ContentVersionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.ContentVersionProperty.Equals(obj).

See Also

File.Type.ContentVersionProperty Class | StarTeam Namespace


File.Type.ContentVersionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.ContentVersionProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.ContentVersionProperty.GetHashCode().

See Also

File.Type.ContentVersionProperty Class | StarTeam Namespace


File.Type.ContentVersionProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.ContentVersionProperty.

public override string ToString();

Return Value

com.starteam.File.Type.ContentVersionProperty.ToString()

See Also

File.Type.ContentVersionProperty Class | StarTeam Namespace


File.Type.EOLFormatProperty Class

The property type of the EOLFormat property.

For a list of all members of this type, see File.Type.EOLFormatProperty Members.

System.Object
Property
EnumeratedProperty
File.Type.EOLFormatProperty

public class File.Type.EOLFormatProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.EOLFormatProperty Members | StarTeam Namespace


File.Type.EOLFormatProperty Members

File.Type.EOLFormatProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.EOLFormatProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.EOLFormatProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.EOLFormatProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.EOLFormatProperty Class | StarTeam Namespace


File.Type.EOLFormatProperty Properties

The properties of the File.Type.EOLFormatProperty class are listed below. For a complete list of File.Type.EOLFormatProperty class members, see the File.Type.EOLFormatProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.EOLFormatProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.EOLFormatProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.EOLFormatProperty Class | StarTeam Namespace


File.Type.EOLFormatProperty Methods

The methods of the File.Type.EOLFormatProperty class are listed below. For a complete list of File.Type.EOLFormatProperty class members, see the File.Type.EOLFormatProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.EOLFormatProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.EOLFormatProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.EOLFormatProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.EOLFormatProperty Class | StarTeam Namespace


File.Type.EOLFormatProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.EOLFormatProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.EOLFormatProperty.Equals(obj).

See Also

File.Type.EOLFormatProperty Class | StarTeam Namespace


File.Type.EOLFormatProperty.FromValue Method

public virtual EnumeratedValue FromValue(
File.EOLFormat value
);

See Also

File.Type.EOLFormatProperty Class | StarTeam Namespace


File.Type.EOLFormatProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.EOLFormatProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.EOLFormatProperty.GetHashCode().

See Also

File.Type.EOLFormatProperty Class | StarTeam Namespace


File.Type.EOLFormatProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.EOLFormatProperty.

public override string ToString();

Return Value

com.starteam.File.Type.EOLFormatProperty.ToString()

See Also

File.Type.EOLFormatProperty Class | StarTeam Namespace


File.Type.ExtensionProperty Class

The property type of the Extension property.

For a list of all members of this type, see File.Type.ExtensionProperty Members.

System.Object
Property
VectorProperty
TextProperty
File.Type.ExtensionProperty

public class File.Type.ExtensionProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.ExtensionProperty Members | StarTeam Namespace


File.Type.ExtensionProperty Members

File.Type.ExtensionProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ExtensionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ExtensionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ExtensionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ExtensionProperty Class | StarTeam Namespace


File.Type.ExtensionProperty Properties

The properties of the File.Type.ExtensionProperty class are listed below. For a complete list of File.Type.ExtensionProperty class members, see the File.Type.ExtensionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.ExtensionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.ExtensionProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.ExtensionProperty Class | StarTeam Namespace


File.Type.ExtensionProperty Methods

The methods of the File.Type.ExtensionProperty class are listed below. For a complete list of File.Type.ExtensionProperty class members, see the File.Type.ExtensionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ExtensionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ExtensionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ExtensionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ExtensionProperty Class | StarTeam Namespace


File.Type.ExtensionProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.ExtensionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.ExtensionProperty.Equals(obj).

See Also

File.Type.ExtensionProperty Class | StarTeam Namespace


File.Type.ExtensionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.ExtensionProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.ExtensionProperty.GetHashCode().

See Also

File.Type.ExtensionProperty Class | StarTeam Namespace


File.Type.ExtensionProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.ExtensionProperty.

public override string ToString();

Return Value

com.starteam.File.Type.ExtensionProperty.ToString()

See Also

File.Type.ExtensionProperty Class | StarTeam Namespace


File.Type.HiveProperty Class

The property type of the Hive property.

For a list of all members of this type, see File.Type.HiveProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
File.Type.HiveProperty

public class File.Type.HiveProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.HiveProperty Members | StarTeam Namespace


File.Type.HiveProperty Members

File.Type.HiveProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.HiveProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.HiveProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.HiveProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.HiveProperty Class | StarTeam Namespace


File.Type.HiveProperty Properties

The properties of the File.Type.HiveProperty class are listed below. For a complete list of File.Type.HiveProperty class members, see the File.Type.HiveProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.HiveProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.HiveProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.HiveProperty Class | StarTeam Namespace


File.Type.HiveProperty Methods

The methods of the File.Type.HiveProperty class are listed below. For a complete list of File.Type.HiveProperty class members, see the File.Type.HiveProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.HiveProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.HiveProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.HiveProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.HiveProperty Class | StarTeam Namespace


File.Type.HiveProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.HiveProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.HiveProperty.Equals(obj).

See Also

File.Type.HiveProperty Class | StarTeam Namespace


File.Type.HiveProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.HiveProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.HiveProperty.GetHashCode().

See Also

File.Type.HiveProperty Class | StarTeam Namespace


File.Type.HiveProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.HiveProperty.

public override string ToString();

Return Value

com.starteam.File.Type.HiveProperty.ToString()

See Also

File.Type.HiveProperty Class | StarTeam Namespace


File.Type.IsExecutableProperty Class

The property type of the IsExecutable property.

For a list of all members of this type, see File.Type.IsExecutableProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
File.Type.IsExecutableProperty

public class File.Type.IsExecutableProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.IsExecutableProperty Members | StarTeam Namespace


File.Type.IsExecutableProperty Members

File.Type.IsExecutableProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsExecutableProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsExecutableProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsExecutableProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsExecutableProperty Class | StarTeam Namespace


File.Type.IsExecutableProperty Properties

The properties of the File.Type.IsExecutableProperty class are listed below. For a complete list of File.Type.IsExecutableProperty class members, see the File.Type.IsExecutableProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.IsExecutableProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.IsExecutableProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.IsExecutableProperty Class | StarTeam Namespace


File.Type.IsExecutableProperty Methods

The methods of the File.Type.IsExecutableProperty class are listed below. For a complete list of File.Type.IsExecutableProperty class members, see the File.Type.IsExecutableProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsExecutableProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsExecutableProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsExecutableProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsExecutableProperty Class | StarTeam Namespace


File.Type.IsExecutableProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.IsExecutableProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.IsExecutableProperty.Equals(obj).

See Also

File.Type.IsExecutableProperty Class | StarTeam Namespace


File.Type.IsExecutableProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.IsExecutableProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.IsExecutableProperty.GetHashCode().

See Also

File.Type.IsExecutableProperty Class | StarTeam Namespace


File.Type.IsExecutableProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.IsExecutableProperty.

public override string ToString();

Return Value

com.starteam.File.Type.IsExecutableProperty.ToString()

See Also

File.Type.IsExecutableProperty Class | StarTeam Namespace


File.Type.IsSyncInRevisionHistoryProperty Class

The property type of the IsSyncInRevisionHistory property.

For a list of all members of this type, see File.Type.IsSyncInRevisionHistoryProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
File.Type.IsSyncInRevisionHistoryProperty

public class File.Type.IsSyncInRevisionHistoryProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.IsSyncInRevisionHistoryProperty Members | StarTeam Namespace


File.Type.IsSyncInRevisionHistoryProperty Members

File.Type.IsSyncInRevisionHistoryProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsSyncInRevisionHistoryProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsSyncInRevisionHistoryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsSyncInRevisionHistoryProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsSyncInRevisionHistoryProperty Class | StarTeam Namespace


File.Type.IsSyncInRevisionHistoryProperty Properties

The properties of the File.Type.IsSyncInRevisionHistoryProperty class are listed below. For a complete list of File.Type.IsSyncInRevisionHistoryProperty class members, see the File.Type.IsSyncInRevisionHistoryProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.IsSyncInRevisionHistoryProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.IsSyncInRevisionHistoryProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.IsSyncInRevisionHistoryProperty Class | StarTeam Namespace


File.Type.IsSyncInRevisionHistoryProperty Methods

The methods of the File.Type.IsSyncInRevisionHistoryProperty class are listed below. For a complete list of File.Type.IsSyncInRevisionHistoryProperty class members, see the File.Type.IsSyncInRevisionHistoryProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsSyncInRevisionHistoryProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsSyncInRevisionHistoryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsSyncInRevisionHistoryProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsSyncInRevisionHistoryProperty Class | StarTeam Namespace


File.Type.IsSyncInRevisionHistoryProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.IsSyncInRevisionHistoryProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.IsSyncInRevisionHistoryProperty.Equals(obj).

See Also

File.Type.IsSyncInRevisionHistoryProperty Class | StarTeam Namespace


File.Type.IsSyncInRevisionHistoryProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.IsSyncInRevisionHistoryProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.IsSyncInRevisionHistoryProperty.GetHashCode().

See Also

File.Type.IsSyncInRevisionHistoryProperty Class | StarTeam Namespace


File.Type.IsSyncInRevisionHistoryProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.IsSyncInRevisionHistoryProperty.

public override string ToString();

Return Value

com.starteam.File.Type.IsSyncInRevisionHistoryProperty.ToString()

See Also

File.Type.IsSyncInRevisionHistoryProperty Class | StarTeam Namespace


File.Type.IsSyncKnownProperty Class

The property type of the IsSyncKnown property.

For a list of all members of this type, see File.Type.IsSyncKnownProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
File.Type.IsSyncKnownProperty

public class File.Type.IsSyncKnownProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.IsSyncKnownProperty Members | StarTeam Namespace


File.Type.IsSyncKnownProperty Members

File.Type.IsSyncKnownProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsSyncKnownProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsSyncKnownProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsSyncKnownProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsSyncKnownProperty Class | StarTeam Namespace


File.Type.IsSyncKnownProperty Properties

The properties of the File.Type.IsSyncKnownProperty class are listed below. For a complete list of File.Type.IsSyncKnownProperty class members, see the File.Type.IsSyncKnownProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.IsSyncKnownProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.IsSyncKnownProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.IsSyncKnownProperty Class | StarTeam Namespace


File.Type.IsSyncKnownProperty Methods

The methods of the File.Type.IsSyncKnownProperty class are listed below. For a complete list of File.Type.IsSyncKnownProperty class members, see the File.Type.IsSyncKnownProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsSyncKnownProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsSyncKnownProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsSyncKnownProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsSyncKnownProperty Class | StarTeam Namespace


File.Type.IsSyncKnownProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.IsSyncKnownProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.IsSyncKnownProperty.Equals(obj).

See Also

File.Type.IsSyncKnownProperty Class | StarTeam Namespace


File.Type.IsSyncKnownProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.IsSyncKnownProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.IsSyncKnownProperty.GetHashCode().

See Also

File.Type.IsSyncKnownProperty Class | StarTeam Namespace


File.Type.IsSyncKnownProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.IsSyncKnownProperty.

public override string ToString();

Return Value

com.starteam.File.Type.IsSyncKnownProperty.ToString()

See Also

File.Type.IsSyncKnownProperty Class | StarTeam Namespace


File.Type.IsWorkingFileAvailableProperty Class

The property type of the LocalFileExists property.

For a list of all members of this type, see File.Type.IsWorkingFileAvailableProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
File.Type.IsWorkingFileAvailableProperty

public class File.Type.IsWorkingFileAvailableProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.IsWorkingFileAvailableProperty Members | StarTeam Namespace


File.Type.IsWorkingFileAvailableProperty Members

File.Type.IsWorkingFileAvailableProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsWorkingFileAvailableProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsWorkingFileAvailableProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsWorkingFileAvailableProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsWorkingFileAvailableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileAvailableProperty Properties

The properties of the File.Type.IsWorkingFileAvailableProperty class are listed below. For a complete list of File.Type.IsWorkingFileAvailableProperty class members, see the File.Type.IsWorkingFileAvailableProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.IsWorkingFileAvailableProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.IsWorkingFileAvailableProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.IsWorkingFileAvailableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileAvailableProperty Methods

The methods of the File.Type.IsWorkingFileAvailableProperty class are listed below. For a complete list of File.Type.IsWorkingFileAvailableProperty class members, see the File.Type.IsWorkingFileAvailableProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsWorkingFileAvailableProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsWorkingFileAvailableProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsWorkingFileAvailableProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsWorkingFileAvailableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileAvailableProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.IsWorkingFileAvailableProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.IsWorkingFileAvailableProperty.Equals(obj).

See Also

File.Type.IsWorkingFileAvailableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileAvailableProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.IsWorkingFileAvailableProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.IsWorkingFileAvailableProperty.GetHashCode().

See Also

File.Type.IsWorkingFileAvailableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileAvailableProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.IsWorkingFileAvailableProperty.

public override string ToString();

Return Value

com.starteam.File.Type.IsWorkingFileAvailableProperty.ToString()

See Also

File.Type.IsWorkingFileAvailableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileExecutableProperty Class

The property type of the WorkingFileExecutable property.

For a list of all members of this type, see File.Type.IsWorkingFileExecutableProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
File.Type.IsWorkingFileExecutableProperty

public class File.Type.IsWorkingFileExecutableProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.IsWorkingFileExecutableProperty Members | StarTeam Namespace


File.Type.IsWorkingFileExecutableProperty Members

File.Type.IsWorkingFileExecutableProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsWorkingFileExecutableProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsWorkingFileExecutableProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsWorkingFileExecutableProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsWorkingFileExecutableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileExecutableProperty Properties

The properties of the File.Type.IsWorkingFileExecutableProperty class are listed below. For a complete list of File.Type.IsWorkingFileExecutableProperty class members, see the File.Type.IsWorkingFileExecutableProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.IsWorkingFileExecutableProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.IsWorkingFileExecutableProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.IsWorkingFileExecutableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileExecutableProperty Methods

The methods of the File.Type.IsWorkingFileExecutableProperty class are listed below. For a complete list of File.Type.IsWorkingFileExecutableProperty class members, see the File.Type.IsWorkingFileExecutableProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.IsWorkingFileExecutableProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.IsWorkingFileExecutableProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.IsWorkingFileExecutableProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.IsWorkingFileExecutableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileExecutableProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.IsWorkingFileExecutableProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.IsWorkingFileExecutableProperty.Equals(obj).

See Also

File.Type.IsWorkingFileExecutableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileExecutableProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.IsWorkingFileExecutableProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.IsWorkingFileExecutableProperty.GetHashCode().

See Also

File.Type.IsWorkingFileExecutableProperty Class | StarTeam Namespace


File.Type.IsWorkingFileExecutableProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.IsWorkingFileExecutableProperty.

public override string ToString();

Return Value

com.starteam.File.Type.IsWorkingFileExecutableProperty.ToString()

See Also

File.Type.IsWorkingFileExecutableProperty Class | StarTeam Namespace


File.Type.KeywordFlagProperty Class

The property type of the KeywordFlag property.

For a list of all members of this type, see File.Type.KeywordFlagProperty Members.

System.Object
Property
EnumeratedProperty
File.Type.KeywordFlagProperty

public class File.Type.KeywordFlagProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.KeywordFlagProperty Members | StarTeam Namespace


File.Type.KeywordFlagProperty Members

File.Type.KeywordFlagProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.KeywordFlagProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.KeywordFlagProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.KeywordFlagProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.KeywordFlagProperty Class | StarTeam Namespace


File.Type.KeywordFlagProperty Properties

The properties of the File.Type.KeywordFlagProperty class are listed below. For a complete list of File.Type.KeywordFlagProperty class members, see the File.Type.KeywordFlagProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.KeywordFlagProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.KeywordFlagProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.KeywordFlagProperty Class | StarTeam Namespace


File.Type.KeywordFlagProperty Methods

The methods of the File.Type.KeywordFlagProperty class are listed below. For a complete list of File.Type.KeywordFlagProperty class members, see the File.Type.KeywordFlagProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.KeywordFlagProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.KeywordFlagProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.KeywordFlagProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.KeywordFlagProperty Class | StarTeam Namespace


File.Type.KeywordFlagProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.KeywordFlagProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.KeywordFlagProperty.Equals(obj).

See Also

File.Type.KeywordFlagProperty Class | StarTeam Namespace


File.Type.KeywordFlagProperty.FromValue Method

public virtual EnumeratedValue FromValue(
File.KeywordFlag value
);

See Also

File.Type.KeywordFlagProperty Class | StarTeam Namespace


File.Type.KeywordFlagProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.KeywordFlagProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.KeywordFlagProperty.GetHashCode().

See Also

File.Type.KeywordFlagProperty Class | StarTeam Namespace


File.Type.KeywordFlagProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.KeywordFlagProperty.

public override string ToString();

Return Value

com.starteam.File.Type.KeywordFlagProperty.ToString()

See Also

File.Type.KeywordFlagProperty Class | StarTeam Namespace


File.Type.MD5Property Class

The property type of the MD5 property.

For a list of all members of this type, see File.Type.MD5Property Members.

System.Object
Property
VectorProperty
BinaryProperty
File.Type.MD5Property

public class File.Type.MD5Property : BinaryProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.MD5Property Members | StarTeam Namespace


File.Type.MD5Property Members

File.Type.MD5Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BinaryProperty) | [read/write] byte[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.MD5Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.MD5Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BinaryProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.MD5Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.MD5Property Class | StarTeam Namespace


File.Type.MD5Property Properties

The properties of the File.Type.MD5Property class are listed below. For a complete list of File.Type.MD5Property class members, see the File.Type.MD5Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BinaryProperty) | [read/write] byte[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.MD5Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.MD5Property.NAME Property

public static String NAME {get;}

See Also

File.Type.MD5Property Class | StarTeam Namespace


File.Type.MD5Property Methods

The methods of the File.Type.MD5Property class are listed below. For a complete list of File.Type.MD5Property class members, see the File.Type.MD5Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.MD5Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.MD5Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BinaryProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.MD5Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.MD5Property Class | StarTeam Namespace


File.Type.MD5Property.Equals Method

Delegate Equals() to com.starteam.File.Type.MD5Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.MD5Property.Equals(obj).

See Also

File.Type.MD5Property Class | StarTeam Namespace


File.Type.MD5Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.MD5Property.

public override int GetHashCode();

Return Value

com.starteam.File.Type.MD5Property.GetHashCode().

See Also

File.Type.MD5Property Class | StarTeam Namespace


File.Type.MD5Property.ToString Method

Delegate ToString() to com.starteam.File.Type.MD5Property.

public override string ToString();

Return Value

com.starteam.File.Type.MD5Property.ToString()

See Also

File.Type.MD5Property Class | StarTeam Namespace


File.Type.NotificationUsersProperty Class

The property type of the NotificationIDs property

For a list of all members of this type, see File.Type.NotificationUsersProperty Members.

System.Object
Property
VectorProperty
TextProperty
File.Type.NotificationUsersProperty

public class File.Type.NotificationUsersProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.NotificationUsersProperty Members | StarTeam Namespace


File.Type.NotificationUsersProperty Members

File.Type.NotificationUsersProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.NotificationUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.NotificationUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.NotificationUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.NotificationUsersProperty Class | StarTeam Namespace


File.Type.NotificationUsersProperty Properties

The properties of the File.Type.NotificationUsersProperty class are listed below. For a complete list of File.Type.NotificationUsersProperty class members, see the File.Type.NotificationUsersProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.NotificationUsersProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.NotificationUsersProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.NotificationUsersProperty Class | StarTeam Namespace


File.Type.NotificationUsersProperty Methods

The methods of the File.Type.NotificationUsersProperty class are listed below. For a complete list of File.Type.NotificationUsersProperty class members, see the File.Type.NotificationUsersProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.NotificationUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.NotificationUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.NotificationUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.NotificationUsersProperty Class | StarTeam Namespace


File.Type.NotificationUsersProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.NotificationUsersProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.NotificationUsersProperty.Equals(obj).

See Also

File.Type.NotificationUsersProperty Class | StarTeam Namespace


File.Type.NotificationUsersProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.NotificationUsersProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.NotificationUsersProperty.GetHashCode().

See Also

File.Type.NotificationUsersProperty Class | StarTeam Namespace


File.Type.NotificationUsersProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.NotificationUsersProperty.

public override string ToString();

Return Value

com.starteam.File.Type.NotificationUsersProperty.ToString()

See Also

File.Type.NotificationUsersProperty Class | StarTeam Namespace


File.Type.PropertyCollection Class

The PropertyCollection of a File item.

For a list of all members of this type, see File.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
File.Type.PropertyCollection

new public class File.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.PropertyCollection Members | StarTeam Namespace


File.Type.PropertyCollection Members

File.Type.PropertyCollection overview

Public Instance Properties

ARCHIVE_NAME |
BRANCH_STATE |
CHARACTER_SET |
COMMENT |
COMMENT_ID |
COMPRESSION |
CONFIGURATION_TIME |
CONTENT_MODIFIED_TIME |
CONTENT_VERSION |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EOL_FORMAT |
EXCLUSIVE_LOCKER |
EXTENSION |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
HIVE |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_EXECUTABLE |
IS_READ_ONLY |
IS_SYNC_IN_HISTORY |
IS_SYNC_KNOWN |
IS_WORKING_FILE_AVAILABLE |
IS_WORKING_FILE_EXECUTABLE |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
KEYWORD_FLAG |
MD5 |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_USERS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_FOLDER_NAME |
PARENT_OBJECT_ID |
PROJECT |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SIZE |
STATUS |
STORAGE_TYPE |
SYMBOLIC_LINK_TARGET |
SYNC_BRANCH_VERSION |
SYNC_CONTENT_VERSION |
SYNC_MD5 |
SYNC_SIZE |
SYNC_TIME |
SYNC_VIEW_VERSION |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VAULT_VERSION |
VIEW |
VIEW_VERSION |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WORKING_FILE_NAME |
WORKING_FILE_PATH |
WORKING_FILE_SIZE |
WORKING_FILE_TIME |
WORKING_FOLDER_PATH |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.File.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.File.Type.PropertyCollection.

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


File.Type.PropertyCollection Properties

The properties of the File.Type.PropertyCollection class are listed below. For a complete list of File.Type.PropertyCollection class members, see the File.Type.PropertyCollection Members topic.

Public Instance Properties

ARCHIVE_NAME |
BRANCH_STATE |
CHARACTER_SET |
COMMENT |
COMMENT_ID |
COMPRESSION |
CONFIGURATION_TIME |
CONTENT_MODIFIED_TIME |
CONTENT_VERSION |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EOL_FORMAT |
EXCLUSIVE_LOCKER |
EXTENSION |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
HIVE |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_EXECUTABLE |
IS_READ_ONLY |
IS_SYNC_IN_HISTORY |
IS_SYNC_KNOWN |
IS_WORKING_FILE_AVAILABLE |
IS_WORKING_FILE_EXECUTABLE |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
KEYWORD_FLAG |
MD5 |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_USERS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_FOLDER_NAME |
PARENT_OBJECT_ID |
PROJECT |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SIZE |
STATUS |
STORAGE_TYPE |
SYMBOLIC_LINK_TARGET |
SYNC_BRANCH_VERSION |
SYNC_CONTENT_VERSION |
SYNC_MD5 |
SYNC_SIZE |
SYNC_TIME |
SYNC_VIEW_VERSION |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VAULT_VERSION |
VIEW |
VIEW_VERSION |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WORKING_FILE_NAME |
WORKING_FILE_PATH |
WORKING_FILE_SIZE |
WORKING_FILE_TIME |
WORKING_FOLDER_PATH |

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


ARCHIVE_NAME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.ARCHIVE_NAME Property

public File.Type.ArchiveNameProperty ARCHIVE_NAME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


CHARACTER_SET Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.CHARACTER_SET Property

public File.Type.CharacterSetProperty CHARACTER_SET {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


COMPRESSION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.COMPRESSION Property

public File.Type.CompressionProperty COMPRESSION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


CONTENT_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.CONTENT_MODIFIED_TIME Property

public File.Type.ContentModifiedTimeProperty CONTENT_MODIFIED_TIME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


CONTENT_VERSION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.CONTENT_VERSION Property

public File.Type.ContentVersionProperty CONTENT_VERSION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


EOL_FORMAT Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.EOL_FORMAT Property

public File.Type.EOLFormatProperty EOL_FORMAT {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


EXTENSION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.EXTENSION Property

public File.Type.ExtensionProperty EXTENSION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_PATH Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.FOLDER_PATH Property

public TrackedObject.Type.FolderPathProperty FOLDER_PATH {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


HIVE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.HIVE Property

public File.Type.HiveProperty HIVE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


IS_BOOKMARKED Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.IS_BOOKMARKED Property

public ViewMember.Type.IsBookmarkedProperty IS_BOOKMARKED {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


IS_EXECUTABLE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.IS_EXECUTABLE Property

public File.Type.IsExecutableProperty IS_EXECUTABLE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


IS_SYNC_IN_HISTORY Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.IS_SYNC_IN_HISTORY Property

public File.Type.IsSyncInRevisionHistoryProperty IS_SYNC_IN_HISTORY {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


IS_SYNC_KNOWN Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.IS_SYNC_KNOWN Property

public File.Type.IsSyncKnownProperty IS_SYNC_KNOWN {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


IS_WORKING_FILE_AVAILABLE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.IS_WORKING_FILE_AVAILABLE Property

public File.Type.IsWorkingFileAvailableProperty IS_WORKING_FILE_AVAILABLE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


IS_WORKING_FILE_EXECUTABLE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.IS_WORKING_FILE_EXECUTABLE Property

public File.Type.IsWorkingFileExecutableProperty IS_WORKING_FILE_EXECUTABLE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


KEYWORD_FLAG Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.KEYWORD_FLAG Property

public File.Type.KeywordFlagProperty KEYWORD_FLAG {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


MD5 Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.MD5 Property

public File.Type.MD5Property MD5 {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


NEW_REVISION_COMMENT Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.NEW_REVISION_COMMENT Property

public Item.Type.NewRevisionCommentProperty NEW_REVISION_COMMENT {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_USERS Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.NOTIFICATION_USERS Property

public File.Type.NotificationUsersProperty NOTIFICATION_USERS {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


PARENT_FOLDER_NAME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.PARENT_FOLDER_NAME Property

public TrackedObject.Type.ParentFolderNameProperty PARENT_FOLDER_NAME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


PROJECT Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.PROJECT Property

public TypedResource.Type.ProjectProperty PROJECT {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SIZE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SIZE Property

public File.Type.SizeProperty SIZE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.STATUS Property

public File.Type.StatusProperty STATUS {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


STORAGE_TYPE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.STORAGE_TYPE Property

public File.Type.StorageTypeProperty STORAGE_TYPE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SYMBOLIC_LINK_TARGET Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SYMBOLIC_LINK_TARGET Property

public File.Type.SymbolicLinkTargetProperty SYMBOLIC_LINK_TARGET {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SYNC_BRANCH_VERSION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SYNC_BRANCH_VERSION Property

public File.Type.SyncBranchVersionProperty SYNC_BRANCH_VERSION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SYNC_CONTENT_VERSION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SYNC_CONTENT_VERSION Property

public File.Type.SyncContentVersionProperty SYNC_CONTENT_VERSION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SYNC_MD5 Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SYNC_MD5 Property

public File.Type.SyncMD5Property SYNC_MD5 {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SYNC_SIZE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SYNC_SIZE Property

public File.Type.SyncSizeProperty SYNC_SIZE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SYNC_TIME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SYNC_TIME Property

public File.Type.SyncModifiedTimeProperty SYNC_TIME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


SYNC_VIEW_VERSION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.SYNC_VIEW_VERSION Property

public File.Type.SyncViewVersionProperty SYNC_VIEW_VERSION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


VAULT_VERSION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.VAULT_VERSION Property

public File.Type.VaultVersionProperty VAULT_VERSION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


VIEW_VERSION Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.VIEW_VERSION Property

public File.Type.ViewVersionProperty VIEW_VERSION {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


WORKING_FILE_NAME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.WORKING_FILE_NAME Property

public File.Type.WorkingFileNameProperty WORKING_FILE_NAME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


WORKING_FILE_PATH Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.WORKING_FILE_PATH Property

public File.Type.WorkingFilePathProperty WORKING_FILE_PATH {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


WORKING_FILE_SIZE Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.WORKING_FILE_SIZE Property

public File.Type.WorkingFileSizeProperty WORKING_FILE_SIZE {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


WORKING_FILE_TIME Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.WORKING_FILE_TIME Property

public File.Type.WorkingFileModifiedTimeProperty WORKING_FILE_TIME {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


WORKING_FOLDER_PATH Property

Borland StarTeam SDK for .NET

File.Type.PropertyCollection.WORKING_FOLDER_PATH Property

public File.Type.WorkingFolderPathProperty WORKING_FOLDER_PATH {get;}

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


File.Type.PropertyCollection Methods

The methods of the File.Type.PropertyCollection class are listed below. For a complete list of File.Type.PropertyCollection class members, see the File.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.File.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.File.Type.PropertyCollection.

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


File.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.File.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.PropertyCollection.Equals(obj).

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


File.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.File.Type.PropertyCollection.GetHashCode().

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


File.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.File.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.File.Type.PropertyCollection.ToString()

See Also

File.Type.PropertyCollection Class | StarTeam Namespace


File.Type.SizeProperty Class

The property type of the Size property.

For a list of all members of this type, see File.Type.SizeProperty Members.

System.Object
Property
ScalarProperty
LongIntegerProperty
File.Type.SizeProperty

public class File.Type.SizeProperty : LongIntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.SizeProperty Members | StarTeam Namespace


File.Type.SizeProperty Members

File.Type.SizeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LongIntegerProperty) | [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from LongIntegerProperty) | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from LongIntegerProperty) | [read/write] long
MinValue (inherited from LongIntegerProperty) | [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SizeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SizeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LongIntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SizeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SizeProperty Class | StarTeam Namespace


File.Type.SizeProperty Properties

The properties of the File.Type.SizeProperty class are listed below. For a complete list of File.Type.SizeProperty class members, see the File.Type.SizeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LongIntegerProperty) | [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from LongIntegerProperty) | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from LongIntegerProperty) | [read/write] long
MinValue (inherited from LongIntegerProperty) | [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.SizeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.SizeProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.SizeProperty Class | StarTeam Namespace


File.Type.SizeProperty Methods

The methods of the File.Type.SizeProperty class are listed below. For a complete list of File.Type.SizeProperty class members, see the File.Type.SizeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SizeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SizeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LongIntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SizeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SizeProperty Class | StarTeam Namespace


File.Type.SizeProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.SizeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.SizeProperty.Equals(obj).

See Also

File.Type.SizeProperty Class | StarTeam Namespace


File.Type.SizeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.SizeProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.SizeProperty.GetHashCode().

See Also

File.Type.SizeProperty Class | StarTeam Namespace


File.Type.SizeProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.SizeProperty.

public override string ToString();

Return Value

com.starteam.File.Type.SizeProperty.ToString()

See Also

File.Type.SizeProperty Class | StarTeam Namespace


File.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see File.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
File.Type.StatusProperty

public class File.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.StatusProperty Members | StarTeam Namespace


File.Type.StatusProperty Members

File.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.StatusProperty Class | StarTeam Namespace


File.Type.StatusProperty Properties

The properties of the File.Type.StatusProperty class are listed below. For a complete list of File.Type.StatusProperty class members, see the File.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.StatusProperty Class | StarTeam Namespace


File.Type.StatusProperty Methods

The methods of the File.Type.StatusProperty class are listed below. For a complete list of File.Type.StatusProperty class members, see the File.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.StatusProperty Class | StarTeam Namespace


File.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.StatusProperty.Equals(obj).

See Also

File.Type.StatusProperty Class | StarTeam Namespace


File.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
File.Status value
);

See Also

File.Type.StatusProperty Class | StarTeam Namespace


File.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.StatusProperty.GetHashCode().

See Also

File.Type.StatusProperty Class | StarTeam Namespace


File.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.File.Type.StatusProperty.ToString()

See Also

File.Type.StatusProperty Class | StarTeam Namespace


File.Type.StorageTypeProperty Class

The property type of the Storage Type property.

For a list of all members of this type, see File.Type.StorageTypeProperty Members.

System.Object
Property
EnumeratedProperty
File.Type.StorageTypeProperty

public class File.Type.StorageTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.StorageTypeProperty Members | StarTeam Namespace


File.Type.StorageTypeProperty Members

File.Type.StorageTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.StorageTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.StorageTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.StorageTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.StorageTypeProperty Class | StarTeam Namespace


File.Type.StorageTypeProperty Properties

The properties of the File.Type.StorageTypeProperty class are listed below. For a complete list of File.Type.StorageTypeProperty class members, see the File.Type.StorageTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

File.Type.StorageTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.StorageTypeProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.StorageTypeProperty Class | StarTeam Namespace


File.Type.StorageTypeProperty Methods

The methods of the File.Type.StorageTypeProperty class are listed below. For a complete list of File.Type.StorageTypeProperty class members, see the File.Type.StorageTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.File.Type.StorageTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.StorageTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.File.Type.StorageTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.StorageTypeProperty Class | StarTeam Namespace


File.Type.StorageTypeProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.StorageTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.StorageTypeProperty.Equals(obj).

See Also

File.Type.StorageTypeProperty Class | StarTeam Namespace


File.Type.StorageTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
File.StorageType value
);

See Also

File.Type.StorageTypeProperty Class | StarTeam Namespace


File.Type.StorageTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.StorageTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.StorageTypeProperty.GetHashCode().

See Also

File.Type.StorageTypeProperty Class | StarTeam Namespace


File.Type.StorageTypeProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.StorageTypeProperty.

public override string ToString();

Return Value

com.starteam.File.Type.StorageTypeProperty.ToString()

See Also

File.Type.StorageTypeProperty Class | StarTeam Namespace


File.Type.SymbolicLinkTargetProperty Class

The property type of the SymbolicLinkTargetProperty property

For a list of all members of this type, see File.Type.SymbolicLinkTargetProperty Members.

System.Object
Property
VectorProperty
TextProperty
File.Type.SymbolicLinkTargetProperty

public class File.Type.SymbolicLinkTargetProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.SymbolicLinkTargetProperty Members | StarTeam Namespace


File.Type.SymbolicLinkTargetProperty Members

File.Type.SymbolicLinkTargetProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SymbolicLinkTargetProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SymbolicLinkTargetProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SymbolicLinkTargetProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SymbolicLinkTargetProperty Class | StarTeam Namespace


File.Type.SymbolicLinkTargetProperty Properties

The properties of the File.Type.SymbolicLinkTargetProperty class are listed below. For a complete list of File.Type.SymbolicLinkTargetProperty class members, see the File.Type.SymbolicLinkTargetProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.SymbolicLinkTargetProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.SymbolicLinkTargetProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.SymbolicLinkTargetProperty Class | StarTeam Namespace


File.Type.SymbolicLinkTargetProperty Methods

The methods of the File.Type.SymbolicLinkTargetProperty class are listed below. For a complete list of File.Type.SymbolicLinkTargetProperty class members, see the File.Type.SymbolicLinkTargetProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SymbolicLinkTargetProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SymbolicLinkTargetProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SymbolicLinkTargetProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SymbolicLinkTargetProperty Class | StarTeam Namespace


File.Type.SymbolicLinkTargetProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.SymbolicLinkTargetProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.SymbolicLinkTargetProperty.Equals(obj).

See Also

File.Type.SymbolicLinkTargetProperty Class | StarTeam Namespace


File.Type.SymbolicLinkTargetProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.SymbolicLinkTargetProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.SymbolicLinkTargetProperty.GetHashCode().

See Also

File.Type.SymbolicLinkTargetProperty Class | StarTeam Namespace


File.Type.SymbolicLinkTargetProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.SymbolicLinkTargetProperty.

public override string ToString();

Return Value

com.starteam.File.Type.SymbolicLinkTargetProperty.ToString()

See Also

File.Type.SymbolicLinkTargetProperty Class | StarTeam Namespace


File.Type.SyncBranchVersionProperty Class

The property type of the SyncObjectVersion property.

For a list of all members of this type, see File.Type.SyncBranchVersionProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
File.Type.SyncBranchVersionProperty

public class File.Type.SyncBranchVersionProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.SyncBranchVersionProperty Members | StarTeam Namespace


File.Type.SyncBranchVersionProperty Members

File.Type.SyncBranchVersionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncBranchVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncBranchVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncBranchVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncBranchVersionProperty Class | StarTeam Namespace


File.Type.SyncBranchVersionProperty Properties

The properties of the File.Type.SyncBranchVersionProperty class are listed below. For a complete list of File.Type.SyncBranchVersionProperty class members, see the File.Type.SyncBranchVersionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.SyncBranchVersionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.SyncBranchVersionProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.SyncBranchVersionProperty Class | StarTeam Namespace


File.Type.SyncBranchVersionProperty Methods

The methods of the File.Type.SyncBranchVersionProperty class are listed below. For a complete list of File.Type.SyncBranchVersionProperty class members, see the File.Type.SyncBranchVersionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncBranchVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncBranchVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncBranchVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncBranchVersionProperty Class | StarTeam Namespace


File.Type.SyncBranchVersionProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.SyncBranchVersionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.SyncBranchVersionProperty.Equals(obj).

See Also

File.Type.SyncBranchVersionProperty Class | StarTeam Namespace


File.Type.SyncBranchVersionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.SyncBranchVersionProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.SyncBranchVersionProperty.GetHashCode().

See Also

File.Type.SyncBranchVersionProperty Class | StarTeam Namespace


File.Type.SyncBranchVersionProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.SyncBranchVersionProperty.

public override string ToString();

Return Value

com.starteam.File.Type.SyncBranchVersionProperty.ToString()

See Also

File.Type.SyncBranchVersionProperty Class | StarTeam Namespace


File.Type.SyncContentVersionProperty Class

The property type of the SyncContentVersion property.

For a list of all members of this type, see File.Type.SyncContentVersionProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
File.Type.SyncContentVersionProperty

public class File.Type.SyncContentVersionProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.SyncContentVersionProperty Members | StarTeam Namespace


File.Type.SyncContentVersionProperty Members

File.Type.SyncContentVersionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncContentVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncContentVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncContentVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncContentVersionProperty Class | StarTeam Namespace


File.Type.SyncContentVersionProperty Properties

The properties of the File.Type.SyncContentVersionProperty class are listed below. For a complete list of File.Type.SyncContentVersionProperty class members, see the File.Type.SyncContentVersionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.SyncContentVersionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.SyncContentVersionProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.SyncContentVersionProperty Class | StarTeam Namespace


File.Type.SyncContentVersionProperty Methods

The methods of the File.Type.SyncContentVersionProperty class are listed below. For a complete list of File.Type.SyncContentVersionProperty class members, see the File.Type.SyncContentVersionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncContentVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncContentVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncContentVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncContentVersionProperty Class | StarTeam Namespace


File.Type.SyncContentVersionProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.SyncContentVersionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.SyncContentVersionProperty.Equals(obj).

See Also

File.Type.SyncContentVersionProperty Class | StarTeam Namespace


File.Type.SyncContentVersionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.SyncContentVersionProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.SyncContentVersionProperty.GetHashCode().

See Also

File.Type.SyncContentVersionProperty Class | StarTeam Namespace


File.Type.SyncContentVersionProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.SyncContentVersionProperty.

public override string ToString();

Return Value

com.starteam.File.Type.SyncContentVersionProperty.ToString()

See Also

File.Type.SyncContentVersionProperty Class | StarTeam Namespace


File.Type.SyncMD5Property Class

The property type of the SyncMD5 property.

For a list of all members of this type, see File.Type.SyncMD5Property Members.

System.Object
Property
VectorProperty
BinaryProperty
File.Type.SyncMD5Property

public class File.Type.SyncMD5Property : BinaryProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.SyncMD5Property Members | StarTeam Namespace


File.Type.SyncMD5Property Members

File.Type.SyncMD5Property overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BinaryProperty) | [read/write] byte[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncMD5Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncMD5Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BinaryProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncMD5Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncMD5Property Class | StarTeam Namespace


File.Type.SyncMD5Property Properties

The properties of the File.Type.SyncMD5Property class are listed below. For a complete list of File.Type.SyncMD5Property class members, see the File.Type.SyncMD5Property Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BinaryProperty) | [read/write] byte[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.SyncMD5Property Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.SyncMD5Property.NAME Property

public static String NAME {get;}

See Also

File.Type.SyncMD5Property Class | StarTeam Namespace


File.Type.SyncMD5Property Methods

The methods of the File.Type.SyncMD5Property class are listed below. For a complete list of File.Type.SyncMD5Property class members, see the File.Type.SyncMD5Property Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncMD5Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncMD5Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BinaryProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncMD5Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncMD5Property Class | StarTeam Namespace


File.Type.SyncMD5Property.Equals Method

Delegate Equals() to com.starteam.File.Type.SyncMD5Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.SyncMD5Property.Equals(obj).

See Also

File.Type.SyncMD5Property Class | StarTeam Namespace


File.Type.SyncMD5Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.SyncMD5Property.

public override int GetHashCode();

Return Value

com.starteam.File.Type.SyncMD5Property.GetHashCode().

See Also

File.Type.SyncMD5Property Class | StarTeam Namespace


File.Type.SyncMD5Property.ToString Method

Delegate ToString() to com.starteam.File.Type.SyncMD5Property.

public override string ToString();

Return Value

com.starteam.File.Type.SyncMD5Property.ToString()

See Also

File.Type.SyncMD5Property Class | StarTeam Namespace


File.Type.SyncModifiedTimeProperty Class

The property type of the SyncTime property.

For a list of all members of this type, see File.Type.SyncModifiedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
File.Type.SyncModifiedTimeProperty

public class File.Type.SyncModifiedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.SyncModifiedTimeProperty Members | StarTeam Namespace


File.Type.SyncModifiedTimeProperty Members

File.Type.SyncModifiedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncModifiedTimeProperty Class | StarTeam Namespace


File.Type.SyncModifiedTimeProperty Properties

The properties of the File.Type.SyncModifiedTimeProperty class are listed below. For a complete list of File.Type.SyncModifiedTimeProperty class members, see the File.Type.SyncModifiedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.SyncModifiedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.SyncModifiedTimeProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.SyncModifiedTimeProperty Class | StarTeam Namespace


File.Type.SyncModifiedTimeProperty Methods

The methods of the File.Type.SyncModifiedTimeProperty class are listed below. For a complete list of File.Type.SyncModifiedTimeProperty class members, see the File.Type.SyncModifiedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncModifiedTimeProperty Class | StarTeam Namespace


File.Type.SyncModifiedTimeProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.SyncModifiedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.SyncModifiedTimeProperty.Equals(obj).

See Also

File.Type.SyncModifiedTimeProperty Class | StarTeam Namespace


File.Type.SyncModifiedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.SyncModifiedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.SyncModifiedTimeProperty.GetHashCode().

See Also

File.Type.SyncModifiedTimeProperty Class | StarTeam Namespace


File.Type.SyncModifiedTimeProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.SyncModifiedTimeProperty.

public override string ToString();

Return Value

com.starteam.File.Type.SyncModifiedTimeProperty.ToString()

See Also

File.Type.SyncModifiedTimeProperty Class | StarTeam Namespace


File.Type.SyncSizeProperty Class

The property type of the SyncSize property.

For a list of all members of this type, see File.Type.SyncSizeProperty Members.

System.Object
Property
ScalarProperty
LongIntegerProperty
File.Type.SyncSizeProperty

public class File.Type.SyncSizeProperty : LongIntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.SyncSizeProperty Members | StarTeam Namespace


File.Type.SyncSizeProperty Members

File.Type.SyncSizeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LongIntegerProperty) | [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from LongIntegerProperty) | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from LongIntegerProperty) | [read/write] long
MinValue (inherited from LongIntegerProperty) | [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncSizeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncSizeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LongIntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncSizeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncSizeProperty Class | StarTeam Namespace


File.Type.SyncSizeProperty Properties

The properties of the File.Type.SyncSizeProperty class are listed below. For a complete list of File.Type.SyncSizeProperty class members, see the File.Type.SyncSizeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LongIntegerProperty) | [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from LongIntegerProperty) | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from LongIntegerProperty) | [read/write] long
MinValue (inherited from LongIntegerProperty) | [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.SyncSizeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.SyncSizeProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.SyncSizeProperty Class | StarTeam Namespace


File.Type.SyncSizeProperty Methods

The methods of the File.Type.SyncSizeProperty class are listed below. For a complete list of File.Type.SyncSizeProperty class members, see the File.Type.SyncSizeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncSizeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncSizeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LongIntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncSizeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncSizeProperty Class | StarTeam Namespace


File.Type.SyncSizeProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.SyncSizeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.SyncSizeProperty.Equals(obj).

See Also

File.Type.SyncSizeProperty Class | StarTeam Namespace


File.Type.SyncSizeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.SyncSizeProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.SyncSizeProperty.GetHashCode().

See Also

File.Type.SyncSizeProperty Class | StarTeam Namespace


File.Type.SyncSizeProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.SyncSizeProperty.

public override string ToString();

Return Value

com.starteam.File.Type.SyncSizeProperty.ToString()

See Also

File.Type.SyncSizeProperty Class | StarTeam Namespace


File.Type.SyncViewVersionProperty Class

The property type of the SyncPathVersion property.

For a list of all members of this type, see File.Type.SyncViewVersionProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
File.Type.SyncViewVersionProperty

public class File.Type.SyncViewVersionProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.SyncViewVersionProperty Members | StarTeam Namespace


File.Type.SyncViewVersionProperty Members

File.Type.SyncViewVersionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncViewVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncViewVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncViewVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncViewVersionProperty Class | StarTeam Namespace


File.Type.SyncViewVersionProperty Properties

The properties of the File.Type.SyncViewVersionProperty class are listed below. For a complete list of File.Type.SyncViewVersionProperty class members, see the File.Type.SyncViewVersionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.SyncViewVersionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.SyncViewVersionProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.SyncViewVersionProperty Class | StarTeam Namespace


File.Type.SyncViewVersionProperty Methods

The methods of the File.Type.SyncViewVersionProperty class are listed below. For a complete list of File.Type.SyncViewVersionProperty class members, see the File.Type.SyncViewVersionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.SyncViewVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.SyncViewVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.SyncViewVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.SyncViewVersionProperty Class | StarTeam Namespace


File.Type.SyncViewVersionProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.SyncViewVersionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.SyncViewVersionProperty.Equals(obj).

See Also

File.Type.SyncViewVersionProperty Class | StarTeam Namespace


File.Type.SyncViewVersionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.SyncViewVersionProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.SyncViewVersionProperty.GetHashCode().

See Also

File.Type.SyncViewVersionProperty Class | StarTeam Namespace


File.Type.SyncViewVersionProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.SyncViewVersionProperty.

public override string ToString();

Return Value

com.starteam.File.Type.SyncViewVersionProperty.ToString()

See Also

File.Type.SyncViewVersionProperty Class | StarTeam Namespace


File.Type.VaultVersionProperty Class

The property type of the VautVersion property.

For a list of all members of this type, see File.Type.VaultVersionProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
File.Type.VaultVersionProperty

public class File.Type.VaultVersionProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.VaultVersionProperty Members | StarTeam Namespace


File.Type.VaultVersionProperty Members

File.Type.VaultVersionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.VaultVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.VaultVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.VaultVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.VaultVersionProperty Class | StarTeam Namespace


File.Type.VaultVersionProperty Properties

The properties of the File.Type.VaultVersionProperty class are listed below. For a complete list of File.Type.VaultVersionProperty class members, see the File.Type.VaultVersionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.VaultVersionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.VaultVersionProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.VaultVersionProperty Class | StarTeam Namespace


File.Type.VaultVersionProperty Methods

The methods of the File.Type.VaultVersionProperty class are listed below. For a complete list of File.Type.VaultVersionProperty class members, see the File.Type.VaultVersionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.VaultVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.VaultVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.VaultVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.VaultVersionProperty Class | StarTeam Namespace


File.Type.VaultVersionProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.VaultVersionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.VaultVersionProperty.Equals(obj).

See Also

File.Type.VaultVersionProperty Class | StarTeam Namespace


File.Type.VaultVersionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.VaultVersionProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.VaultVersionProperty.GetHashCode().

See Also

File.Type.VaultVersionProperty Class | StarTeam Namespace


File.Type.VaultVersionProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.VaultVersionProperty.

public override string ToString();

Return Value

com.starteam.File.Type.VaultVersionProperty.ToString()

See Also

File.Type.VaultVersionProperty Class | StarTeam Namespace


File.Type.ViewVersionProperty Class

The property type of the View version property.

For a list of all members of this type, see File.Type.ViewVersionProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
File.Type.ViewVersionProperty

public class File.Type.ViewVersionProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.ViewVersionProperty Members | StarTeam Namespace


File.Type.ViewVersionProperty Members

File.Type.ViewVersionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ViewVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ViewVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ViewVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ViewVersionProperty Class | StarTeam Namespace


File.Type.ViewVersionProperty Properties

The properties of the File.Type.ViewVersionProperty class are listed below. For a complete list of File.Type.ViewVersionProperty class members, see the File.Type.ViewVersionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.ViewVersionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.ViewVersionProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.ViewVersionProperty Class | StarTeam Namespace


File.Type.ViewVersionProperty Methods

The methods of the File.Type.ViewVersionProperty class are listed below. For a complete list of File.Type.ViewVersionProperty class members, see the File.Type.ViewVersionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.ViewVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.ViewVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.ViewVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.ViewVersionProperty Class | StarTeam Namespace


File.Type.ViewVersionProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.ViewVersionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.ViewVersionProperty.Equals(obj).

See Also

File.Type.ViewVersionProperty Class | StarTeam Namespace


File.Type.ViewVersionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.ViewVersionProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.ViewVersionProperty.GetHashCode().

See Also

File.Type.ViewVersionProperty Class | StarTeam Namespace


File.Type.ViewVersionProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.ViewVersionProperty.

public override string ToString();

Return Value

com.starteam.File.Type.ViewVersionProperty.ToString()

See Also

File.Type.ViewVersionProperty Class | StarTeam Namespace


File.Type.WorkingFileModifiedTimeProperty Class

The property type of the LocalTimeStamp property.

For a list of all members of this type, see File.Type.WorkingFileModifiedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
File.Type.WorkingFileModifiedTimeProperty

public class File.Type.WorkingFileModifiedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.WorkingFileModifiedTimeProperty Members | StarTeam Namespace


File.Type.WorkingFileModifiedTimeProperty Members

File.Type.WorkingFileModifiedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFileModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFileModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFileModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFileModifiedTimeProperty Class | StarTeam Namespace


File.Type.WorkingFileModifiedTimeProperty Properties

The properties of the File.Type.WorkingFileModifiedTimeProperty class are listed below. For a complete list of File.Type.WorkingFileModifiedTimeProperty class members, see the File.Type.WorkingFileModifiedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.WorkingFileModifiedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.WorkingFileModifiedTimeProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.WorkingFileModifiedTimeProperty Class | StarTeam Namespace


File.Type.WorkingFileModifiedTimeProperty Methods

The methods of the File.Type.WorkingFileModifiedTimeProperty class are listed below. For a complete list of File.Type.WorkingFileModifiedTimeProperty class members, see the File.Type.WorkingFileModifiedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFileModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFileModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFileModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFileModifiedTimeProperty Class | StarTeam Namespace


File.Type.WorkingFileModifiedTimeProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.WorkingFileModifiedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.WorkingFileModifiedTimeProperty.Equals(obj).

See Also

File.Type.WorkingFileModifiedTimeProperty Class | StarTeam Namespace


File.Type.WorkingFileModifiedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.WorkingFileModifiedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.WorkingFileModifiedTimeProperty.GetHashCode().

See Also

File.Type.WorkingFileModifiedTimeProperty Class | StarTeam Namespace


File.Type.WorkingFileModifiedTimeProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.WorkingFileModifiedTimeProperty.

public override string ToString();

Return Value

com.starteam.File.Type.WorkingFileModifiedTimeProperty.ToString()

See Also

File.Type.WorkingFileModifiedTimeProperty Class | StarTeam Namespace


File.Type.WorkingFileNameProperty Class

The property type of the LocalName property.

For a list of all members of this type, see File.Type.WorkingFileNameProperty Members.

System.Object
Property
VectorProperty
TextProperty
File.Type.WorkingFileNameProperty

public class File.Type.WorkingFileNameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.WorkingFileNameProperty Members | StarTeam Namespace


File.Type.WorkingFileNameProperty Members

File.Type.WorkingFileNameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFileNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFileNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFileNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFileNameProperty Class | StarTeam Namespace


File.Type.WorkingFileNameProperty Properties

The properties of the File.Type.WorkingFileNameProperty class are listed below. For a complete list of File.Type.WorkingFileNameProperty class members, see the File.Type.WorkingFileNameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.WorkingFileNameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.WorkingFileNameProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.WorkingFileNameProperty Class | StarTeam Namespace


File.Type.WorkingFileNameProperty Methods

The methods of the File.Type.WorkingFileNameProperty class are listed below. For a complete list of File.Type.WorkingFileNameProperty class members, see the File.Type.WorkingFileNameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFileNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFileNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFileNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFileNameProperty Class | StarTeam Namespace


File.Type.WorkingFileNameProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.WorkingFileNameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.WorkingFileNameProperty.Equals(obj).

See Also

File.Type.WorkingFileNameProperty Class | StarTeam Namespace


File.Type.WorkingFileNameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.WorkingFileNameProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.WorkingFileNameProperty.GetHashCode().

See Also

File.Type.WorkingFileNameProperty Class | StarTeam Namespace


File.Type.WorkingFileNameProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.WorkingFileNameProperty.

public override string ToString();

Return Value

com.starteam.File.Type.WorkingFileNameProperty.ToString()

See Also

File.Type.WorkingFileNameProperty Class | StarTeam Namespace


File.Type.WorkingFilePathProperty Class

The property type of the LocalPath property.

For a list of all members of this type, see File.Type.WorkingFilePathProperty Members.

System.Object
Property
VectorProperty
TextProperty
File.Type.WorkingFilePathProperty

public class File.Type.WorkingFilePathProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.WorkingFilePathProperty Members | StarTeam Namespace


File.Type.WorkingFilePathProperty Members

File.Type.WorkingFilePathProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFilePathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFilePathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFilePathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFilePathProperty Class | StarTeam Namespace


File.Type.WorkingFilePathProperty Properties

The properties of the File.Type.WorkingFilePathProperty class are listed below. For a complete list of File.Type.WorkingFilePathProperty class members, see the File.Type.WorkingFilePathProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.WorkingFilePathProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.WorkingFilePathProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.WorkingFilePathProperty Class | StarTeam Namespace


File.Type.WorkingFilePathProperty Methods

The methods of the File.Type.WorkingFilePathProperty class are listed below. For a complete list of File.Type.WorkingFilePathProperty class members, see the File.Type.WorkingFilePathProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFilePathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFilePathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFilePathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFilePathProperty Class | StarTeam Namespace


File.Type.WorkingFilePathProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.WorkingFilePathProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.WorkingFilePathProperty.Equals(obj).

See Also

File.Type.WorkingFilePathProperty Class | StarTeam Namespace


File.Type.WorkingFilePathProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.WorkingFilePathProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.WorkingFilePathProperty.GetHashCode().

See Also

File.Type.WorkingFilePathProperty Class | StarTeam Namespace


File.Type.WorkingFilePathProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.WorkingFilePathProperty.

public override string ToString();

Return Value

com.starteam.File.Type.WorkingFilePathProperty.ToString()

See Also

File.Type.WorkingFilePathProperty Class | StarTeam Namespace


File.Type.WorkingFileSizeProperty Class

The property type of the LocalSize property.

For a list of all members of this type, see File.Type.WorkingFileSizeProperty Members.

System.Object
Property
ScalarProperty
LongIntegerProperty
File.Type.WorkingFileSizeProperty

public class File.Type.WorkingFileSizeProperty : LongIntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.WorkingFileSizeProperty Members | StarTeam Namespace


File.Type.WorkingFileSizeProperty Members

File.Type.WorkingFileSizeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LongIntegerProperty) | [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from LongIntegerProperty) | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from LongIntegerProperty) | [read/write] long
MinValue (inherited from LongIntegerProperty) | [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFileSizeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFileSizeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LongIntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFileSizeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFileSizeProperty Class | StarTeam Namespace


File.Type.WorkingFileSizeProperty Properties

The properties of the File.Type.WorkingFileSizeProperty class are listed below. For a complete list of File.Type.WorkingFileSizeProperty class members, see the File.Type.WorkingFileSizeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LongIntegerProperty) | [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from LongIntegerProperty) | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from LongIntegerProperty) | [read/write] long
MinValue (inherited from LongIntegerProperty) | [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.WorkingFileSizeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.WorkingFileSizeProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.WorkingFileSizeProperty Class | StarTeam Namespace


File.Type.WorkingFileSizeProperty Methods

The methods of the File.Type.WorkingFileSizeProperty class are listed below. For a complete list of File.Type.WorkingFileSizeProperty class members, see the File.Type.WorkingFileSizeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFileSizeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFileSizeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LongIntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFileSizeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFileSizeProperty Class | StarTeam Namespace


File.Type.WorkingFileSizeProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.WorkingFileSizeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.WorkingFileSizeProperty.Equals(obj).

See Also

File.Type.WorkingFileSizeProperty Class | StarTeam Namespace


File.Type.WorkingFileSizeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.WorkingFileSizeProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.WorkingFileSizeProperty.GetHashCode().

See Also

File.Type.WorkingFileSizeProperty Class | StarTeam Namespace


File.Type.WorkingFileSizeProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.WorkingFileSizeProperty.

public override string ToString();

Return Value

com.starteam.File.Type.WorkingFileSizeProperty.ToString()

See Also

File.Type.WorkingFileSizeProperty Class | StarTeam Namespace


File.Type.WorkingFolderPathProperty Class

The property type of the Path property.

For a list of all members of this type, see File.Type.WorkingFolderPathProperty Members.

System.Object
Property
VectorProperty
TextProperty
File.Type.WorkingFolderPathProperty

public class File.Type.WorkingFolderPathProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.Type.WorkingFolderPathProperty Members | StarTeam Namespace


File.Type.WorkingFolderPathProperty Members

File.Type.WorkingFolderPathProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFolderPathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFolderPathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFolderPathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFolderPathProperty Class | StarTeam Namespace


File.Type.WorkingFolderPathProperty Properties

The properties of the File.Type.WorkingFolderPathProperty class are listed below. For a complete list of File.Type.WorkingFolderPathProperty class members, see the File.Type.WorkingFolderPathProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

File.Type.WorkingFolderPathProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

File.Type.WorkingFolderPathProperty.NAME Property

public static String NAME {get;}

See Also

File.Type.WorkingFolderPathProperty Class | StarTeam Namespace


File.Type.WorkingFolderPathProperty Methods

The methods of the File.Type.WorkingFolderPathProperty class are listed below. For a complete list of File.Type.WorkingFolderPathProperty class members, see the File.Type.WorkingFolderPathProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.File.Type.WorkingFolderPathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.File.Type.WorkingFolderPathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.File.Type.WorkingFolderPathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

File.Type.WorkingFolderPathProperty Class | StarTeam Namespace


File.Type.WorkingFolderPathProperty.Equals Method

Delegate Equals() to com.starteam.File.Type.WorkingFolderPathProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.Type.WorkingFolderPathProperty.Equals(obj).

See Also

File.Type.WorkingFolderPathProperty Class | StarTeam Namespace


File.Type.WorkingFolderPathProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.Type.WorkingFolderPathProperty.

public override int GetHashCode();

Return Value

com.starteam.File.Type.WorkingFolderPathProperty.GetHashCode().

See Also

File.Type.WorkingFolderPathProperty Class | StarTeam Namespace


File.Type.WorkingFolderPathProperty.ToString Method

Delegate ToString() to com.starteam.File.Type.WorkingFolderPathProperty.

public override string ToString();

Return Value

com.starteam.File.Type.WorkingFolderPathProperty.ToString()

See Also

File.Type.WorkingFolderPathProperty Class | StarTeam Namespace


File.WebCacheFile Class

File accessor for cached SDK Items contained objects are obtained from the artifact cache

For a list of all members of this type, see File.WebCacheFile Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
File.WebCacheFile

public class File.WebCacheFile : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.WebCacheFile Members | StarTeam Namespace


File.WebCacheFile Members

File.WebCacheFile overview

Public Static Methods

Create | Overloaded.
GetStatus | Overloaded.

Public Instance Properties

ArchiveName | [read] The file name of this file's archive file in the vault.
Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
CharacterSetValue | [read/write] The character set used by this file, or null if it is unknown.
Comment | [read/write] the Comment attached to this view member
CompressionValue | [read] The compression level of the archive file in the vault.
ContentModifiedTime | [read/write] The "last modified" time of the working file when this revision was checked in.
ContentVersion | [read] The content version number for this file
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this file
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EOLFormatValue | [read/write] The end-of-line format, or null if it has not yet been initialized.
Extension | [read] the file name extension.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
HiveID | [read] The ID of the hive where the archive file is stored in the vault.
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBinary | [read] true if this repository file has been determined to be binary
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsExecutable | [read/write] true if the file has been marked executable in the repository; false otherwise.
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnicode | [read] true if this repository file has been determined to be UNICODE
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
KeywordFlagValue | [read] the value of the KeywordFlag property
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
MD5 | [read] the MD5 has bytes of the repository contents of this file
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Size | [read] the size of this file in the repository
SymbolicLinkTarget | [read/write] the target of symbolic link.
Traces | [read] a Trace[] of applicable Traces
UsesKeywords | [read] true if this file uses keyword expansion
VaultVersion | [read] the vault version number for this file
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WorkspaceSync | [read] a workspace sync representing the content as checked into the repository

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.File.WebCacheFile.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.File.WebCacheFile.
GetMergeVersion |
GetStatus | Overloaded.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.File.WebCacheFile.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile Properties

The properties of the File.WebCacheFile class are listed below. For a complete list of File.WebCacheFile class members, see the File.WebCacheFile Members topic.

Public Instance Properties

ArchiveName | [read] The file name of this file's archive file in the vault.
Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
CharacterSetValue | [read/write] The character set used by this file, or null if it is unknown.
Comment | [read/write] the Comment attached to this view member
CompressionValue | [read] The compression level of the archive file in the vault.
ContentModifiedTime | [read/write] The "last modified" time of the working file when this revision was checked in.
ContentVersion | [read] The content version number for this file
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this file
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EOLFormatValue | [read/write] The end-of-line format, or null if it has not yet been initialized.
Extension | [read] the file name extension.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
HiveID | [read] The ID of the hive where the archive file is stored in the vault.
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBinary | [read] true if this repository file has been determined to be binary
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsExecutable | [read/write] true if the file has been marked executable in the repository; false otherwise.
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnicode | [read] true if this repository file has been determined to be UNICODE
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
KeywordFlagValue | [read] the value of the KeywordFlag property
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
MD5 | [read] the MD5 has bytes of the repository contents of this file
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Size | [read] the size of this file in the repository
SymbolicLinkTarget | [read/write] the target of symbolic link.
Traces | [read] a Trace[] of applicable Traces
UsesKeywords | [read] true if this file uses keyword expansion
VaultVersion | [read] the vault version number for this file
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WorkspaceSync | [read] a workspace sync representing the content as checked into the repository

See Also

File.WebCacheFile Class | StarTeam Namespace


ArchiveName Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ArchiveName Property

[read] The file name of this file's archive file in the vault.

public virtual String ArchiveName {get;}

Property Value

The file name of this file's archive file in the vault.

See Also

File.WebCacheFile Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

File.WebCacheFile Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

File.WebCacheFile Class | StarTeam Namespace


CharacterSetValue Property

Borland StarTeam SDK for .NET

File.WebCacheFile.CharacterSetValue Property

[read/write] The character set used by this file, or null if it is unknown.

public virtual File.CharacterSet CharacterSetValue {get; set;}

Property Value

The character set used by this file, or null if it is unknown.

See Also

File.WebCacheFile Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

File.WebCacheFile Class | StarTeam Namespace


CompressionValue Property

Borland StarTeam SDK for .NET

File.WebCacheFile.CompressionValue Property

[read] The compression level of the archive file in the vault.

public virtual File.Compression CompressionValue {get;}

Property Value

The compression level of the archive file in the vault.

See Also

File.WebCacheFile Class | StarTeam Namespace


ContentModifiedTime Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ContentModifiedTime Property

[read/write] The "last modified" time of the working file when this revision was checked in.

public virtual DateTime ContentModifiedTime {get; set;}

Property Value

The "last modified" time of the working file when this revision was checked in.

See Also

File.WebCacheFile Class | StarTeam Namespace


ContentVersion Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ContentVersion Property

[read] The content version number for this file

public virtual Int32 ContentVersion {get;}

Property Value

The content version number for this file

See Also

File.WebCacheFile Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

File.WebCacheFile Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

File.WebCacheFile.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

File.WebCacheFile Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

File.WebCacheFile.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

File.WebCacheFile Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

File.WebCacheFile.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

File.WebCacheFile Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

File.WebCacheFile.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

File.WebCacheFile Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Description Property

[read/write] the description of this file

public virtual String Description {get; set;}

Property Value

the description of this file

See Also

File.WebCacheFile Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

File.WebCacheFile.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

File.WebCacheFile Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

File.WebCacheFile.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

File.WebCacheFile Class | StarTeam Namespace


EOLFormatValue Property

Borland StarTeam SDK for .NET

File.WebCacheFile.EOLFormatValue Property

[read/write] The end-of-line format, or null if it has not yet been initialized.

public virtual File.EOLFormat EOLFormatValue {get; set;}

Property Value

The end-of-line format, or null if it has not yet been initialized.

See Also

File.WebCacheFile Class | StarTeam Namespace


Extension Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Extension Property

[read] the file name extension.

public virtual String Extension {get;}

Property Value

the file name extension.

See Also

File.WebCacheFile Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

File.WebCacheFile Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

File.WebCacheFile Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

File.WebCacheFile.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

File.WebCacheFile Class | StarTeam Namespace


HiveID Property

Borland StarTeam SDK for .NET

File.WebCacheFile.HiveID Property

[read] The ID of the hive where the archive file is stored in the vault.

public virtual Int32 HiveID {get;}

Property Value

The ID of the hive where the archive file is stored in the vault.

See Also

File.WebCacheFile Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

File.WebCacheFile Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

File.WebCacheFile Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

File.WebCacheFile Class | StarTeam Namespace


IsBinary Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsBinary Property

[read] true if this repository file has been determined to be binary

public virtual Boolean IsBinary {get;}

Property Value

true if this repository file has been determined to be binary

See Also

File.WebCacheFile Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

File.WebCacheFile Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

File.WebCacheFile Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

File.WebCacheFile Class | StarTeam Namespace


IsExecutable Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsExecutable Property

[read/write] true if the file has been marked executable in the repository; false otherwise.

public virtual Boolean IsExecutable {get; set;}

Property Value

true if the file has been marked executable in the repository; false otherwise.

See Also

File.WebCacheFile Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

File.WebCacheFile Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

File.WebCacheFile Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

File.WebCacheFile Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

File.WebCacheFile Class | StarTeam Namespace


IsUnicode Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsUnicode Property

[read] true if this repository file has been determined to be UNICODE

public virtual Boolean IsUnicode {get;}

Property Value

true if this repository file has been determined to be UNICODE

See Also

File.WebCacheFile Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

File.WebCacheFile.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

File.WebCacheFile Class | StarTeam Namespace


KeywordFlagValue Property

Borland StarTeam SDK for .NET

File.WebCacheFile.KeywordFlagValue Property

[read] the value of the KeywordFlag property

public virtual File.KeywordFlag KeywordFlagValue {get;}

Property Value

the value of the KeywordFlag property

See Also

File.WebCacheFile Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

File.WebCacheFile Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

File.WebCacheFile Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

File.WebCacheFile Class | StarTeam Namespace


MD5 Property

Borland StarTeam SDK for .NET

File.WebCacheFile.MD5 Property

[read] the MD5 has bytes of the repository contents of this file

public virtual MD5 MD5 {get;}

Property Value

the MD5 has bytes of the repository contents of this file

See Also

File.WebCacheFile Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

File.WebCacheFile Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

File.WebCacheFile Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

File.WebCacheFile.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

File.WebCacheFile Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Name Property

new public virtual String Name {get; set;}

See Also

File.WebCacheFile Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

File.WebCacheFile.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

File.WebCacheFile Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

File.WebCacheFile.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

File.WebCacheFile Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

File.WebCacheFile Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

File.WebCacheFile Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

File.WebCacheFile.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

File.WebCacheFile Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

File.WebCacheFile.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

File.WebCacheFile Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

File.WebCacheFile.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

File.WebCacheFile Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

File.WebCacheFile Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

File.WebCacheFile.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

File.WebCacheFile Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

File.WebCacheFile Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

File.WebCacheFile Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

File.WebCacheFile Class | StarTeam Namespace


Size Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Size Property

[read] the size of this file in the repository

public virtual Int64 Size {get;}

Property Value

the size of this file in the repository

See Also

File.WebCacheFile Class | StarTeam Namespace


SymbolicLinkTarget Property

Borland StarTeam SDK for .NET

File.WebCacheFile.SymbolicLinkTarget Property

[read/write] the target of symbolic link.

public virtual String SymbolicLinkTarget {get; set;}

Property Value

the target of symbolic link.

See Also

File.WebCacheFile Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

File.WebCacheFile.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

File.WebCacheFile Class | StarTeam Namespace


UsesKeywords Property

Borland StarTeam SDK for .NET

File.WebCacheFile.UsesKeywords Property

[read] true if this file uses keyword expansion

public virtual Boolean UsesKeywords {get;}

Property Value

true if this file uses keyword expansion

See Also

File.WebCacheFile Class | StarTeam Namespace


VaultVersion Property

Borland StarTeam SDK for .NET

File.WebCacheFile.VaultVersion Property

[read] the vault version number for this file

public virtual Int32 VaultVersion {get;}

Property Value

the vault version number for this file

See Also

File.WebCacheFile Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

File.WebCacheFile.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

File.WebCacheFile Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

File.WebCacheFile Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

File.WebCacheFile.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

File.WebCacheFile Class | StarTeam Namespace


WorkspaceSync Property

Borland StarTeam SDK for .NET

File.WebCacheFile.WorkspaceSync Property

[read] a workspace sync representing the content as checked into the repository

public virtual File.WebCacheWorkSpaceSync WorkspaceSync {get;}

Property Value

a workspace sync representing the content as checked into the repository

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile Methods

The methods of the File.WebCacheFile class are listed below. For a complete list of File.WebCacheFile class members, see the File.WebCacheFile Members topic.

Public Static Methods

Create | Overloaded.
GetStatus | Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.File.WebCacheFile.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.File.WebCacheFile.
GetMergeVersion |
GetStatus | Overloaded.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.File.WebCacheFile.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

File.WebCacheFile Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

File.WebCacheFile.Create Method

Overload List

public static WebCacheFile Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheFile Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.Create Overload List


File.WebCacheFile.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.Create Overload List


File.WebCacheFile.Equals Method

Delegate Equals() to com.starteam.File.WebCacheFile.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.WebCacheFile.Equals(obj).

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.WebCacheFile.

public override int GetHashCode();

Return Value

com.starteam.File.WebCacheFile.GetHashCode().

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.GetMergeVersion Method

public virtual WebCacheFile GetMergeVersion(
File.WebCacheWorkSpaceSync localSync
);

See Also

File.WebCacheFile Class | StarTeam Namespace


GetStatus Method

Borland StarTeam SDK for .NET

File.WebCacheFile.GetStatus Method

Overload List

public static Status GetStatus(File.WebCacheWorkSpaceSync,File.WebCacheWorkSpaceSync,MD5);

public static Status GetStatus(File.WebCacheWorkSpaceSync,File.WebCacheWorkSpaceSync,Int64,DateTime);

public virtual Status GetStatus(File.WebCacheWorkSpaceSync,MD5);

public virtual Status GetStatus(File.WebCacheWorkSpaceSync,Int64,DateTime);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.GetStatus Method (File#WebCacheWorkSpaceSync, File#WebCacheWorkSpaceSync, MD5)

public static Status GetStatus(
File.WebCacheWorkSpaceSync remoteSync,
File.WebCacheWorkSpaceSync localSync,
MD5 md5
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.GetStatus Overload List


File.WebCacheFile.GetStatus Method (File#WebCacheWorkSpaceSync, File#WebCacheWorkSpaceSync, Int64, DateTime)

public static Status GetStatus(
File.WebCacheWorkSpaceSync remoteSync,
File.WebCacheWorkSpaceSync localSync,
Int64 size,
DateTime lastModified
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.GetStatus Overload List


File.WebCacheFile.GetStatus Method (File#WebCacheWorkSpaceSync, MD5)

public virtual Status GetStatus(
File.WebCacheWorkSpaceSync sync,
MD5 md5
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.GetStatus Overload List


File.WebCacheFile.GetStatus Method (File#WebCacheWorkSpaceSync, Int64, DateTime)

public virtual Status GetStatus(
File.WebCacheWorkSpaceSync sync,
Int64 size,
DateTime lastModified
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.GetStatus Overload List


File.WebCacheFile.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

File.WebCacheFile Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

File.WebCacheFile.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.GetValue Overload List


File.WebCacheFile.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.GetValue Overload List


File.WebCacheFile.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

File.WebCacheFile Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

File.WebCacheFile.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

File.WebCacheFile Class | StarTeam Namespace | WebCacheViewMemberCollection


File.WebCacheFile.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.Lock Overload List | WebCacheViewMemberCollection


File.WebCacheFile.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.Lock Overload List


File.WebCacheFile.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

File.WebCacheFile Class | StarTeam Namespace | NAME


File.WebCacheFile.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

File.WebCacheFile Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

File.WebCacheFile.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.MoveTo Overload List


File.WebCacheFile.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.MoveTo Overload List


File.WebCacheFile.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

File.WebCacheFile Class | StarTeam Namespace | isFloating | isPinned | unpin


File.WebCacheFile.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

File.WebCacheFile Class | StarTeam Namespace | WebCacheViewMemberCollection


File.WebCacheFile.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

File.WebCacheFile Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

File.WebCacheFile.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.SetValue Overload List


File.WebCacheFile.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

File.WebCacheFile Class | StarTeam Namespace | File.WebCacheFile.SetValue Overload List


File.WebCacheFile.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.ToString Method

Delegate ToString() to com.starteam.File.WebCacheFile.

public override string ToString();

Return Value

com.starteam.File.WebCacheFile.ToString()

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheFile.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

File.WebCacheFile Class | StarTeam Namespace | WebCacheViewMemberCollection


File.WebCacheFile.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

File.WebCacheFile Class | StarTeam Namespace | isFloating | isPinned | pinTo


File.WebCacheFile.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

File.WebCacheFile Class | StarTeam Namespace | WebCacheViewMemberCollection


File.WebCacheFile.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

File.WebCacheFile Class | StarTeam Namespace


File.WebCacheWorkSpaceSync Class

A serializable implementation of WorkspaceSync that can be used to calculate status through the WebCache Interfaces. In this model, the client application (applet?) runs in the context of a browser and connects to a web server or web service via http. The web server in turn holds a shared cache connection to the StarTeam server. This model supports entire file operations (checkin, checkout etc) via a browser.

For a list of all members of this type, see File.WebCacheWorkSpaceSync Members.

System.Object
File.WebCacheWorkSpaceSync

public class File.WebCacheWorkSpaceSync : File.WorkspaceSync

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.WebCacheWorkSpaceSync Members | StarTeam Namespace


File.WebCacheWorkSpaceSync Members

File.WebCacheWorkSpaceSync overview

Public Instance Constructors

File.WebCacheWorkSpaceSync Overloaded. Initializes a new instance of the File.WebCacheWorkSpaceSync class.

Public Instance Properties

ContentRevision | [read/write] the content revision for this file
DotNotation | [read/write] the dot notation of this file
FileDigest |
FileMD5 | [read/write] the md5 of this file
FileSize | [read/write] the size of this file
FileTime | [read/write] the file tme of this file
ObjectID | [read/write] the object id of this file
RepositoryID | [read] the repository the file is in
RevisionIdentifier |
RevisionNumber | [read/write] the revision number of this file
RootObjectID | [read/write] the root object id of the file

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.WebCacheWorkSpaceSync.
GetHashCode | Delegate GetHashCode() to com.starteam.File.WebCacheWorkSpaceSync.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.WebCacheWorkSpaceSync.

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


File.WebCacheWorkSpaceSync Constructor

Overload List

public File.WebCacheWorkSpaceSync(File.Revision,File.Digest);

public File.WebCacheWorkSpaceSync(File.WorkspaceSync);

create a new, empty WebCacheWorkspaceSync

public File.WebCacheWorkSpaceSync(GUID);

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


File.WebCacheWorkSpaceSync Constructor (File#Revision, File#Digest)

public File.WebCacheWorkSpaceSync(
File.Revision r,
File.Digest d
);

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace | File.WebCacheWorkSpaceSync Constructor Overload List


File.WebCacheWorkSpaceSync Constructor (GUID)

create a new, empty WebCacheWorkspaceSync

public File.WebCacheWorkSpaceSync(
GUID guid
);

Parameters

guid

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace | File.WebCacheWorkSpaceSync Constructor Overload List


File.WebCacheWorkSpaceSync Constructor (File#WorkspaceSync)

public File.WebCacheWorkSpaceSync(
File.WorkspaceSync wss
);

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace | File.WebCacheWorkSpaceSync Constructor Overload List


File.WebCacheWorkSpaceSync Properties

The properties of the File.WebCacheWorkSpaceSync class are listed below. For a complete list of File.WebCacheWorkSpaceSync class members, see the File.WebCacheWorkSpaceSync Members topic.

Public Instance Properties

ContentRevision | [read/write] the content revision for this file
DotNotation | [read/write] the dot notation of this file
FileDigest |
FileMD5 | [read/write] the md5 of this file
FileSize | [read/write] the size of this file
FileTime | [read/write] the file tme of this file
ObjectID | [read/write] the object id of this file
RepositoryID | [read] the repository the file is in
RevisionIdentifier |
RevisionNumber | [read/write] the revision number of this file
RootObjectID | [read/write] the root object id of the file

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


ContentRevision Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.ContentRevision Property

[read/write] the content revision for this file

public virtual Int32 ContentRevision {get; set;}

Property Value

the content revision for this file

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.DotNotation Property

[read/write] the dot notation of this file

public virtual DotNotation DotNotation {get; set;}

Property Value

the dot notation of this file

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


FileDigest Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.FileDigest Property

public virtual File.Digest FileDigest {get;}

Implements

WorkspaceSync.FileDigest

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


FileMD5 Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.FileMD5 Property

[read/write] the md5 of this file

public virtual MD5 FileMD5 {get; set;}

Property Value

the md5 of this file

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


FileSize Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.FileSize Property

[read/write] the size of this file

public virtual Int64 FileSize {get; set;}

Property Value

the size of this file

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


FileTime Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.FileTime Property

[read/write] the file tme of this file

public virtual DateTime FileTime {get; set;}

Property Value

the file tme of this file

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.ObjectID Property

[read/write] the object id of this file

public virtual Int32 ObjectID {get; set;}

Property Value

the object id of this file

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


RepositoryID Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.RepositoryID Property

[read] the repository the file is in

public virtual GUID RepositoryID {get;}

Property Value

the repository the file is in

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


RevisionIdentifier Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.RevisionIdentifier Property

public virtual File.Revision RevisionIdentifier {get;}

Implements

WorkspaceSync.RevisionIdentifier

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.RevisionNumber Property

[read/write] the revision number of this file

public virtual Int32 RevisionNumber {get; set;}

Property Value

the revision number of this file

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

File.WebCacheWorkSpaceSync.RootObjectID Property

[read/write] the root object id of the file

public virtual Int32 RootObjectID {get; set;}

Property Value

the root object id of the file

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


File.WebCacheWorkSpaceSync Methods

The methods of the File.WebCacheWorkSpaceSync class are listed below. For a complete list of File.WebCacheWorkSpaceSync class members, see the File.WebCacheWorkSpaceSync Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.File.WebCacheWorkSpaceSync.
GetHashCode | Delegate GetHashCode() to com.starteam.File.WebCacheWorkSpaceSync.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.File.WebCacheWorkSpaceSync.

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


File.WebCacheWorkSpaceSync.Equals Method

Delegate Equals() to com.starteam.File.WebCacheWorkSpaceSync.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.File.WebCacheWorkSpaceSync.Equals(obj).

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


File.WebCacheWorkSpaceSync.GetHashCode Method

Delegate GetHashCode() to com.starteam.File.WebCacheWorkSpaceSync.

public override int GetHashCode();

Return Value

com.starteam.File.WebCacheWorkSpaceSync.GetHashCode().

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


File.WebCacheWorkSpaceSync.ToString Method

Delegate ToString() to com.starteam.File.WebCacheWorkSpaceSync.

public override string ToString();

Return Value

com.starteam.File.WebCacheWorkSpaceSync.ToString()

See Also

File.WebCacheWorkSpaceSync Class | StarTeam Namespace


File.WorkspaceSync Interface

The WorkspaceSync interface specifies the pairing of the two important pieces of information needed to know what is on a user's local disk: Revision and Digest. This information is needed to compute a File's status.

For a list of all members of this type, see File.WorkspaceSync Members.

public interface File.WorkspaceSync

Types that implement File.WorkspaceSync

Type | Description
File.SyncRecord | a stock Sync Record Implementation to create sync records in syncdb
File.WebCacheWorkSpaceSync | A serializable implementation of WorkspaceSync that can be used to calculate status through the WebCache Interfaces. In this model, the client application (applet?) runs in the context of a browser and connects to a web server or web service via http. The web server in turn holds a shared cache connection to the StarTeam server. This model supports entire file operations (checkin, checkout etc) via a browser.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

File.WorkspaceSync Members | StarTeam Namespace


File.WorkspaceSync Members

File.WorkspaceSync overview

Public Instance Properties

FileDigest | [read] The Digest for the file in question.
RevisionIdentifier | [read] The Revision for the file in question.

See Also

File.WorkspaceSync Interface | StarTeam Namespace


File.WorkspaceSync Properties

The properties of the File.WorkspaceSync interface are listed below. For a complete list of File.WorkspaceSync interface members, see the File.WorkspaceSync Members topic.

Public Instance Properties

FileDigest | [read] The Digest for the file in question.
RevisionIdentifier | [read] The Revision for the file in question.

See Also

File.WorkspaceSync Interface | StarTeam Namespace


FileDigest Property

Borland StarTeam SDK for .NET

File.WorkspaceSync.FileDigest Property

[read] The Digest for the file in question.

File.Digest FileDigest {get;}

Property Value

The Digest for the file in question.

See Also

File.WorkspaceSync Interface | StarTeam Namespace


RevisionIdentifier Property

Borland StarTeam SDK for .NET

File.WorkspaceSync.RevisionIdentifier Property

[read] The Revision for the file in question.

File.Revision RevisionIdentifier {get;}

Property Value

The Revision for the file in question.

See Also

File.WorkspaceSync Interface | StarTeam Namespace


FileBasedStatusManager Class

Manages File Status information on the local client workstation.

For a list of all members of this type, see FileBasedStatusManager Members.

System.Object
FileBasedStatusManager

public class FileBasedStatusManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

FileBasedStatusManager Members | StarTeam Namespace


FileBasedStatusManager Members

FileBasedStatusManager overview

Public Instance Properties

IsCentral | [read] True if status information is stored in a central location; false if it is managed on a per-folder basis.
IsPerFolder | [read] True if status information is managed on a per-folder basis; false if it is stored in a central location.

Public Instance Methods

DeleteStatusInformation | Deletes File Status information for the given working file.
Equals | Delegate Equals() to com.starteam.FileBasedStatusManager.
GetHashCode | Delegate GetHashCode() to com.starteam.FileBasedStatusManager.
GetStatusInformation |
GetType (inherited from Object) | Gets the Type of the current instance.
MoveStatusInformation | Moves File Status Information from the oldFile to the newFile The move will fail if either of the two specified files do not exist.
SetStatusInformation |
ToString | Delegate ToString() to com.starteam.FileBasedStatusManager.

See Also

FileBasedStatusManager Class | StarTeam Namespace


FileBasedStatusManager Properties

The properties of the FileBasedStatusManager class are listed below. For a complete list of FileBasedStatusManager class members, see the FileBasedStatusManager Members topic.

Public Instance Properties

IsCentral | [read] True if status information is stored in a central location; false if it is managed on a per-folder basis.
IsPerFolder | [read] True if status information is managed on a per-folder basis; false if it is stored in a central location.

See Also

FileBasedStatusManager Class | StarTeam Namespace


IsCentral Property

Borland StarTeam SDK for .NET

FileBasedStatusManager.IsCentral Property

[read] True if status information is stored in a central location; false if it is managed on a per-folder basis.

public virtual Boolean IsCentral {get;}

Property Value

True if status information is stored in a central location; false if it is managed on a per-folder basis.

See Also

FileBasedStatusManager Class | StarTeam Namespace


IsPerFolder Property

Borland StarTeam SDK for .NET

FileBasedStatusManager.IsPerFolder Property

[read] True if status information is managed on a per-folder basis; false if it is stored in a central location.

public virtual Boolean IsPerFolder {get;}

Property Value

True if status information is managed on a per-folder basis; false if it is stored in a central location.

See Also

FileBasedStatusManager Class | StarTeam Namespace


FileBasedStatusManager Methods

The methods of the FileBasedStatusManager class are listed below. For a complete list of FileBasedStatusManager class members, see the FileBasedStatusManager Members topic.

Public Instance Methods

DeleteStatusInformation | Deletes File Status information for the given working file.
Equals | Delegate Equals() to com.starteam.FileBasedStatusManager.
GetHashCode | Delegate GetHashCode() to com.starteam.FileBasedStatusManager.
GetStatusInformation |
GetType (inherited from Object) | Gets the Type of the current instance.
MoveStatusInformation | Moves File Status Information from the oldFile to the newFile The move will fail if either of the two specified files do not exist.
SetStatusInformation |
ToString | Delegate ToString() to com.starteam.FileBasedStatusManager.

See Also

FileBasedStatusManager Class | StarTeam Namespace


FileBasedStatusManager.DeleteStatusInformation Method

Deletes File Status information for the given working file.

public virtual void DeleteStatusInformation(
FileInfo file,
Boolean cs
);

Parameters

file
A working file.
cs
True if paths are case sensitive; false otherwise.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileBasedStatusManager Class | StarTeam Namespace | StatusMethod


FileBasedStatusManager.Equals Method

Delegate Equals() to com.starteam.FileBasedStatusManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.FileBasedStatusManager.Equals(obj).

See Also

FileBasedStatusManager Class | StarTeam Namespace


FileBasedStatusManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.FileBasedStatusManager.

public override int GetHashCode();

Return Value

com.starteam.FileBasedStatusManager.GetHashCode().

See Also

FileBasedStatusManager Class | StarTeam Namespace


FileBasedStatusManager.GetStatusInformation Method

public virtual WorkspaceSync GetStatusInformation(
FileInfo file,
Boolean cs
);

See Also

FileBasedStatusManager Class | StarTeam Namespace


FileBasedStatusManager.MoveStatusInformation Method

Moves File Status Information from the oldFile to the newFile The move will fail if either of the two specified files do not exist.

public virtual bool MoveStatusInformation(
FileInfo oldFile,
FileInfo newFile,
Boolean caseSensitive
);

Parameters

oldFile
File a file for which status information is recorded; this status will be deleted as a result of the move
newFile
File a file to which the status information is being transferred
caseSensitive
boolean True if paths are case sensitive; false otherwise

Return Value

true if the move succeeded

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileBasedStatusManager Class | StarTeam Namespace | WorkspaceSync | StatusMethod


FileBasedStatusManager.SetStatusInformation Method

public virtual void SetStatusInformation(
File.WorkspaceSync rec,
FileInfo file,
Boolean cs
);

See Also

FileBasedStatusManager Class | StarTeam Namespace


FileBasedStatusManager.ToString Method

Delegate ToString() to com.starteam.FileBasedStatusManager.

public override string ToString();

Return Value

com.starteam.FileBasedStatusManager.ToString()

See Also

FileBasedStatusManager Class | StarTeam Namespace


Filter Class

The Filter class is used to define criteria for which items (files, change requests) should be displayed to a user. It includes information on which items should be displayed, which properties should be displayed, and how the items should be sorted or grouped. The StarTeam GUI uses filters to determine what items in a folder to display.

For a list of all members of this type, see Filter Members.

System.Object
NamedCacheRef
Filter

public class Filter : NamedCacheRef, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Filter Members | StarTeam Namespace


Filter Members

Filter overview

Public Instance Constructors

Filter Constructor

Public Instance Properties

Columns | [read/write] all the Columns in this filter
ContextValue | [read/write] the context specified for this filter
CreatedBy | [read] the user who created this filter.
CreatedTime | [read] the created time for this filter.
DebugString | [read] a debug representation of this filter
GroupingDepth | [read] the number of grouping levels specified for the Filter.
Groupings | [read/write] the set of groupings for this filter
ID | [read] the internal ID of the filter
IsDeleted | [read] true if this filter has been deleted
IsDirty | [read] true if the filter has unsaved modifications.
IsNew | [read] true if this filter is new
IsPublic | [read] true if the filter is visible to all users.
ModifiedBy | [read] the who last modified this filter.
ModifiedTime | [read] the modified time for this filter.
MyType | [read] the Type this Filter was created for.
Name | [read/write] the display name of the filter.
OwnedBy | [read] the user who own the filter or NULL
ParentContainer | [read] This object's parent container.
PresentationID | [read] the unique integer identifier for this filter.
Projects | [read/write] the set of projects associated with this filter
Properties | [read] an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.
Query | [read/write] the query associated with the filter or NULL
Rights | [read/write] the access control list for this filter or NULL.
Server | [read] Server the Server instance for this Filter

Public Instance Methods

AppendColumn | A convenience method to add a new column at the end of the column list.
AppendGrouping | A convenience method to append a Grouping to the list of Groupings
ClearAllColumns | A convenience method to remove all column display information.
ClearAllGroupings | A convenience method to remove all sort and group information.
Copy | Creates a copy of this Filter object. Useful to applications that want to save a snapshot of the filter in a given state, for example, before calling Type.refreshFiltersAndQueries(). The copied filter will have the same parent Type as the original property. The Type object is not copied.
Delete | Remove this filter from the repository
Equals (inherited from NamedCacheRef) | Delegate Equals() to com.starteam.NamedCacheRef.
GetHashCode (inherited from NamedCacheRef) | Delegate GetHashCode() to com.starteam.NamedCacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermissions | Returns true if desired permissions are granted for this filter.
IsEqualTo | Compares two Filter objects.
MakePrivate | Make this filter public. You must call update() to make the change take effect
MakePublic | Make this filter public. You must call update() to make the change take effect
ToString (inherited from NamedCacheRef) | Delegate ToString() to com.starteam.NamedCacheRef.
Update | Save this filter to the repository

See Also

Filter Class | StarTeam Namespace


Filter Constructor

public Filter(
ViewMember.Type type,
String name,
Filter.Context context,
Boolean publicFilter
);

See Also

Filter Class | StarTeam Namespace


Filter Properties

The properties of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Properties

Columns | [read/write] all the Columns in this filter
ContextValue | [read/write] the context specified for this filter
CreatedBy | [read] the user who created this filter.
CreatedTime | [read] the created time for this filter.
DebugString | [read] a debug representation of this filter
GroupingDepth | [read] the number of grouping levels specified for the Filter.
Groupings | [read/write] the set of groupings for this filter
ID | [read] the internal ID of the filter
IsDeleted | [read] true if this filter has been deleted
IsDirty | [read] true if the filter has unsaved modifications.
IsNew | [read] true if this filter is new
IsPublic | [read] true if the filter is visible to all users.
ModifiedBy | [read] the who last modified this filter.
ModifiedTime | [read] the modified time for this filter.
MyType | [read] the Type this Filter was created for.
Name | [read/write] the display name of the filter.
OwnedBy | [read] the user who own the filter or NULL
ParentContainer | [read] This object's parent container.
PresentationID | [read] the unique integer identifier for this filter.
Projects | [read/write] the set of projects associated with this filter
Properties | [read] an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.
Query | [read/write] the query associated with the filter or NULL
Rights | [read/write] the access control list for this filter or NULL.
Server | [read] Server the Server instance for this Filter

See Also

Filter Class | StarTeam Namespace


Columns Property

Borland StarTeam SDK for .NET

Filter.Columns Property

[read/write] all the Columns in this filter

public virtual Column[] Columns {get; set;}

Property Value

all the Columns in this filter

See Also

Filter Class | StarTeam Namespace


ContextValue Property

Borland StarTeam SDK for .NET

Filter.ContextValue Property

[read/write] the context specified for this filter

public virtual Filter.Context ContextValue {get; set;}

Property Value

the context specified for this filter

See Also

Filter Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Filter.CreatedBy Property

[read] the user who created this filter.

public virtual User CreatedBy {get;}

Property Value

the user who created this filter.

See Also

Filter Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Filter.CreatedTime Property

[read] the created time for this filter.

public virtual DateTime CreatedTime {get;}

Property Value

the created time for this filter.

See Also

Filter Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Filter.DebugString Property

[read] a debug representation of this filter

public virtual String DebugString {get;}

Property Value

a debug representation of this filter

See Also

Filter Class | StarTeam Namespace


GroupingDepth Property

Borland StarTeam SDK for .NET

Filter.GroupingDepth Property

[read] the number of grouping levels specified for the Filter.

public virtual Int32 GroupingDepth {get;}

Property Value

the number of grouping levels specified for the Filter.

See Also

Filter Class | StarTeam Namespace


Groupings Property

Borland StarTeam SDK for .NET

Filter.Groupings Property

[read/write] the set of groupings for this filter

public virtual Grouping[] Groupings {get; set;}

Property Value

the set of groupings for this filter

See Also

Filter Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Filter.ID Property

[read] the internal ID of the filter

public virtual Int32 ID {get;}

Property Value

the internal ID of the filter

Implements

ISecurable.ID

See Also

Filter Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Filter.IsDeleted Property

[read] true if this filter has been deleted

public virtual Boolean IsDeleted {get;}

Property Value

true if this filter has been deleted

Implements

ISecurable.IsDeleted

See Also

Filter Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Filter.IsDirty Property

[read] true if the filter has unsaved modifications.

public virtual Boolean IsDirty {get;}

Property Value

true if the filter has unsaved modifications.

See Also

Filter Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Filter.IsNew Property

[read] true if this filter is new

public virtual Boolean IsNew {get;}

Property Value

true if this filter is new

See Also

Filter Class | StarTeam Namespace


IsPublic Property

Borland StarTeam SDK for .NET

Filter.IsPublic Property

[read] true if the filter is visible to all users.

public virtual Boolean IsPublic {get;}

Property Value

true if the filter is visible to all users.

See Also

Filter Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Filter.ModifiedBy Property

[read] the who last modified this filter.

public virtual User ModifiedBy {get;}

Property Value

the who last modified this filter.

See Also

Filter Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Filter.ModifiedTime Property

[read] the modified time for this filter.

public virtual DateTime ModifiedTime {get;}

Property Value

the modified time for this filter.

See Also

Filter Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Filter.MyType Property

[read] the Type this Filter was created for.

public virtual Type MyType {get;}

Property Value

the Type this Filter was created for.

Implements

ISecurable.MyType

See Also

Filter Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Filter.Name Property

[read/write] the display name of the filter.

public virtual String Name {get; set;}

Property Value

the display name of the filter.

See Also

Filter Class | StarTeam Namespace


OwnedBy Property

Borland StarTeam SDK for .NET

Filter.OwnedBy Property

[read] the user who own the filter or NULL

public virtual User OwnedBy {get;}

Property Value

the user who own the filter or NULL

See Also

Filter Class | StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

Filter.ParentContainer Property

[read] This object's parent container.

public virtual ISecurableContainer ParentContainer {get;}

Property Value

This object's parent container.

Implements

ISecurable.ParentContainer

See Also

Filter Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Filter.PresentationID Property

[read] the unique integer identifier for this filter.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this filter.

See Also

Filter Class | StarTeam Namespace


Projects Property

Borland StarTeam SDK for .NET

Filter.Projects Property

[read/write] the set of projects associated with this filter

public virtual Project[] Projects {get; set;}

Property Value

the set of projects associated with this filter

See Also

Filter Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Filter.Properties Property

[read] an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.

public virtual PropertyCollection Properties {get;}

Property Value

an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.

See Also

Filter Class | StarTeam Namespace


Query Property

Borland StarTeam SDK for .NET

Filter.Query Property

[read/write] the query associated with the filter or NULL

public virtual Query Query {get; set;}

Property Value

the query associated with the filter or NULL

See Also

Filter Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Filter.Rights Property

[read/write] the access control list for this filter or NULL.

public virtual ACE[] Rights {get; set;}

Property Value

the access control list for this filter or NULL.

Implements

ISecurable.Rights

See Also

Filter Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Filter.Server Property

[read] Server the Server instance for this Filter

public virtual Server Server {get;}

Property Value

Server the Server instance for this Filter

Implements

ISecurable.Server

See Also

Filter Class | StarTeam Namespace


Filter Methods

The methods of the Filter class are listed below. For a complete list of Filter class members, see the Filter Members topic.

Public Instance Methods

AppendColumn | A convenience method to add a new column at the end of the column list.
AppendGrouping | A convenience method to append a Grouping to the list of Groupings
ClearAllColumns | A convenience method to remove all column display information.
ClearAllGroupings | A convenience method to remove all sort and group information.
Copy | Creates a copy of this Filter object. Useful to applications that want to save a snapshot of the filter in a given state, for example, before calling Type.refreshFiltersAndQueries(). The copied filter will have the same parent Type as the original property. The Type object is not copied.
Delete | Remove this filter from the repository
Equals (inherited from NamedCacheRef) | Delegate Equals() to com.starteam.NamedCacheRef.
GetHashCode (inherited from NamedCacheRef) | Delegate GetHashCode() to com.starteam.NamedCacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermissions | Returns true if desired permissions are granted for this filter.
IsEqualTo | Compares two Filter objects.
MakePrivate | Make this filter public. You must call update() to make the change take effect
MakePublic | Make this filter public. You must call update() to make the change take effect
ToString (inherited from NamedCacheRef) | Delegate ToString() to com.starteam.NamedCacheRef.
Update | Save this filter to the repository

See Also

Filter Class | StarTeam Namespace


Filter.AppendColumn Method

A convenience method to add a new column at the end of the column list.

public virtual Column AppendColumn(
Property property,
Int32 pixelWidth
);

Parameters

property
the property
pixelWidth
the pixel width

Return Value

a new Column

See Also

Filter Class | StarTeam Namespace


Filter.AppendGrouping Method

A convenience method to append a Grouping to the list of Groupings

public virtual Grouping AppendGrouping(
Property prprty,
Boolean group
);

Parameters

prprty
Property the property
group
boolean true if the property is part of a group sort

Return Value

a new Grouping

See Also

Filter Class | StarTeam Namespace


Filter.ClearAllColumns Method

A convenience method to remove all column display information.

public virtual void ClearAllColumns();

See Also

Filter Class | StarTeam Namespace


Filter.ClearAllGroupings Method

A convenience method to remove all sort and group information.

public virtual void ClearAllGroupings();

See Also

Filter Class | StarTeam Namespace


Filter.Copy Method

Creates a copy of this Filter object. Useful to applications that want to save a snapshot of the filter in a given state, for example, before calling Type.refreshFiltersAndQueries().

The copied filter will have the same parent Type as the original property. The Type object is not copied.

public virtual Filter Copy();

Return Value

A copy of this Filter object.

See Also

Filter Class | StarTeam Namespace | isEqualTo


Filter.Delete Method

Remove this filter from the repository

public virtual void Delete();

See Also

Filter Class | StarTeam Namespace


Filter.HasPermissions Method

Returns true if desired permissions are granted for this filter.

public virtual bool HasPermissions(
PermissionCollection permissions
);

Parameters

permissions
the desired permissions

Implements

ISecurable.HasPermissions

See Also

Filter Class | StarTeam Namespace | Permission


Filter.IsEqualTo Method

Compares two Filter objects.

public virtual bool IsEqualTo(
Filter filter
);

Parameters

filter
The Filter to be compared with this one.

Return Value

true if no differences were found.

See Also

Filter Class | StarTeam Namespace | copy


Filter.MakePrivate Method

Make this filter public. You must call update() to make the change take effect

public virtual void MakePrivate(
User u
);

Parameters

u

See Also

Filter Class | StarTeam Namespace


Filter.MakePublic Method

Make this filter public. You must call update() to make the change take effect

public virtual void MakePublic();

See Also

Filter Class | StarTeam Namespace


Filter.Update Method

Save this filter to the repository

public virtual void Update();

See Also

Filter Class | StarTeam Namespace


Filter.Column Class

A column in which to display the value of the associated property The display length is defined in screen pixel widths

For a list of all members of this type, see Filter.Column Members.

System.Object
Filter.Column

public class Filter.Column

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Filter.Column Members | StarTeam Namespace


Filter.Column Members

Filter.Column overview

Public Instance Constructors

Filter.Column Constructor Create a column, i.e. an object with two members a property and a defined screen pixel width The property value will be displayed in a table whose column width is defined by the number of pixels specified

Public Instance Properties

DebugString | [read] a debug representation of this column
PixelWidth | [read/write] the display resolution for this column
Property | [read/write]

Public Instance Methods

Copy | returns a copy of this column
Equals | Delegate Equals() to com.starteam.Filter.Column.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Column.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
ToString | Delegate ToString() to com.starteam.Filter.Column.

See Also

Filter.Column Class | StarTeam Namespace


Filter.Column Constructor

Create a column, i.e. an object with two members a property and a defined screen pixel width The property value will be displayed in a table whose column width is defined by the number of pixels specified

public Filter.Column(
Property prprty,
Int32 pixelWidth
);

Parameters

prprty
the property
pixelWidth
screen display information

See Also

Filter.Column Class | StarTeam Namespace


Filter.Column Properties

The properties of the Filter.Column class are listed below. For a complete list of Filter.Column class members, see the Filter.Column Members topic.

Public Instance Properties

DebugString | [read] a debug representation of this column
PixelWidth | [read/write] the display resolution for this column
Property | [read/write]

See Also

Filter.Column Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Filter.Column.DebugString Property

[read] a debug representation of this column

public virtual String DebugString {get;}

Property Value

a debug representation of this column

See Also

Filter.Column Class | StarTeam Namespace


PixelWidth Property

Borland StarTeam SDK for .NET

Filter.Column.PixelWidth Property

[read/write] the display resolution for this column

public virtual Int32 PixelWidth {get; set;}

Property Value

the display resolution for this column

See Also

Filter.Column Class | StarTeam Namespace


Property Property

Borland StarTeam SDK for .NET

Filter.Column.Property Property

[read/write]

public virtual Property Property {get; set;}

See Also

Filter.Column Class | StarTeam Namespace


Filter.Column Methods

The methods of the Filter.Column class are listed below. For a complete list of Filter.Column class members, see the Filter.Column Members topic.

Public Instance Methods

Copy | returns a copy of this column
Equals | Delegate Equals() to com.starteam.Filter.Column.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Column.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
ToString | Delegate ToString() to com.starteam.Filter.Column.

See Also

Filter.Column Class | StarTeam Namespace


Filter.Column.Copy Method

returns a copy of this column

public virtual object Copy();

Return Value

a copy of this column

See Also

Filter.Column Class | StarTeam Namespace


Filter.Column.Equals Method

Delegate Equals() to com.starteam.Filter.Column.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Filter.Column.Equals(obj).

See Also

Filter.Column Class | StarTeam Namespace


Filter.Column.GetHashCode Method

Delegate GetHashCode() to com.starteam.Filter.Column.

public override int GetHashCode();

Return Value

com.starteam.Filter.Column.GetHashCode().

See Also

Filter.Column Class | StarTeam Namespace


Filter.Column.IsEqualTo Method

public virtual bool IsEqualTo(
Filter.Column other
);

See Also

Filter.Column Class | StarTeam Namespace


Filter.Column.ToString Method

Delegate ToString() to com.starteam.Filter.Column.

public override string ToString();

Return Value

com.starteam.Filter.Column.ToString()

See Also

Filter.Column Class | StarTeam Namespace


Filter.Column.WebCacheColumn Class

A column in which to display the value of the associated property The display length is defined in screen pixel widths

For a list of all members of this type, see Filter.Column.WebCacheColumn Members.

System.Object
Filter.Column.WebCacheColumn

public class Filter.Column.WebCacheColumn

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Filter.Column.WebCacheColumn Members | StarTeam Namespace


Filter.Column.WebCacheColumn Members

Filter.Column.WebCacheColumn overview

Public Instance Constructors

Filter.Column.WebCacheColumn Constructor

Public Instance Properties

PixelWidth | [read/write] the display resolution for this column
Property | [read/write]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Filter.Column.WebCacheColumn.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Column.WebCacheColumn.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Filter.Column.WebCacheColumn.

See Also

Filter.Column.WebCacheColumn Class | StarTeam Namespace


Filter.Column.WebCacheColumn Constructor

public Filter.Column.WebCacheColumn(
ArtifactCacheManager.Context cntxt,
Property.WebCacheProperty prprty,
Int32 pixelWidth
);

See Also

Filter.Column.WebCacheColumn Class | StarTeam Namespace


Filter.Column.WebCacheColumn Properties

The properties of the Filter.Column.WebCacheColumn class are listed below. For a complete list of Filter.Column.WebCacheColumn class members, see the Filter.Column.WebCacheColumn Members topic.

Public Instance Properties

PixelWidth | [read/write] the display resolution for this column
Property | [read/write]

See Also

Filter.Column.WebCacheColumn Class | StarTeam Namespace


PixelWidth Property

Borland StarTeam SDK for .NET

Filter.Column.WebCacheColumn.PixelWidth Property

[read/write] the display resolution for this column

public virtual Int32 PixelWidth {get; set;}

Property Value

the display resolution for this column

See Also

Filter.Column.WebCacheColumn Class | StarTeam Namespace


Property Property

Borland StarTeam SDK for .NET

Filter.Column.WebCacheColumn.Property Property

[read/write]

public virtual Property.WebCacheProperty Property {get; set;}

See Also

Filter.Column.WebCacheColumn Class | StarTeam Namespace


Filter.Column.WebCacheColumn Methods

The methods of the Filter.Column.WebCacheColumn class are listed below. For a complete list of Filter.Column.WebCacheColumn class members, see the Filter.Column.WebCacheColumn Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Filter.Column.WebCacheColumn.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Column.WebCacheColumn.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Filter.Column.WebCacheColumn.

See Also

Filter.Column.WebCacheColumn Class | StarTeam Namespace


Filter.Column.WebCacheColumn.Equals Method

Delegate Equals() to com.starteam.Filter.Column.WebCacheColumn.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Filter.Column.WebCacheColumn.Equals(obj).

See Also

Filter.Column.WebCacheColumn Class | StarTeam Namespace


Filter.Column.WebCacheColumn.GetHashCode Method

Delegate GetHashCode() to com.starteam.Filter.Column.WebCacheColumn.

public override int GetHashCode();

Return Value

com.starteam.Filter.Column.WebCacheColumn.GetHashCode().

See Also

Filter.Column.WebCacheColumn Class | StarTeam Namespace


Filter.Column.WebCacheColumn.ToString Method

Delegate ToString() to com.starteam.Filter.Column.WebCacheColumn.

public override string ToString();

Return Value

com.starteam.Filter.Column.WebCacheColumn.ToString()

See Also

Filter.Column.WebCacheColumn Class | StarTeam Namespace


Filter.Context Class

Context is a specification for what the filter applies to or covers it may be local to the file system, specific to object instance stored on the server or both

For a list of all members of this type, see Filter.Context Members.

System.Object
Filter.Context

public class Filter.Context

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Filter.Context Members | StarTeam Namespace


Filter.Context Members

Filter.Context overview

Public Static Properties

BOTH
LOCAL
SERVER

Public Static Methods

FromID Gets the Context value corresponding to the given ID.

Public Instance Properties

ID [read] the id of this context instance

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Filter.Context.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Context.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Filter.Context.

See Also

Filter.Context Class | StarTeam Namespace


Filter.Context Properties

The properties of the Filter.Context class are listed below. For a complete list of Filter.Context class members, see the Filter.Context Members topic.

Public Static Properties

BOTH
LOCAL
SERVER

Public Instance Properties

ID [read] the id of this context instance

See Also

Filter.Context Class | StarTeam Namespace


BOTH Property

Borland StarTeam SDK for .NET

Filter.Context.BOTH Property

public static Filter.Context BOTH {get;}

Property Value

Specifies both local and server items should be displayed.

See Also

Filter.Context Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Filter.Context.ID Property

[read] the id of this context instance

public virtual Int32 ID {get;}

Property Value

the id of this context instance

See Also

Filter.Context Class | StarTeam Namespace


LOCAL Property

Borland StarTeam SDK for .NET

Filter.Context.LOCAL Property

public static Filter.Context LOCAL {get;}

Property Value

Specifies only local items should be displayed.

See Also

Filter.Context Class | StarTeam Namespace


SERVER Property

Borland StarTeam SDK for .NET

Filter.Context.SERVER Property

public static Filter.Context SERVER {get;}

Property Value

Specifies only server items should be displayed.

See Also

Filter.Context Class | StarTeam Namespace


Filter.Context Methods

The methods of the Filter.Context class are listed below. For a complete list of Filter.Context class members, see the Filter.Context Members topic.

Public Static Methods

FromID Gets the Context value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Filter.Context.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Context.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Filter.Context.

See Also

Filter.Context Class | StarTeam Namespace


Filter.Context.Equals Method

Delegate Equals() to com.starteam.Filter.Context.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Filter.Context.Equals(obj).

See Also

Filter.Context Class | StarTeam Namespace


Filter.Context.FromID Method

Gets the Context value corresponding to the given ID.

public static Context FromID(
Int32 id
);

Parameters

id
The ID of a Context value.

Return Value

The corresponding Context value, or null.

See Also

Filter.Context Class | StarTeam Namespace


Filter.Context.GetHashCode Method

Delegate GetHashCode() to com.starteam.Filter.Context.

public override int GetHashCode();

Return Value

com.starteam.Filter.Context.GetHashCode().

See Also

Filter.Context Class | StarTeam Namespace


Filter.Context.ToString Method

Delegate ToString() to com.starteam.Filter.Context.

public override string ToString();

Return Value

com.starteam.Filter.Context.ToString()

See Also

Filter.Context Class | StarTeam Namespace


Filter.Grouping Class

A positional indicator for a property in a group meant for sorting and grouping results

For a list of all members of this type, see Filter.Grouping Members.

System.Object
Filter.Grouping

public class Filter.Grouping

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Filter.Grouping Members | StarTeam Namespace


Filter.Grouping Members

Filter.Grouping overview

Public Instance Constructors

Filter.Grouping Constructor Create a new Grouping

Public Instance Properties

DebugString | [read] a debug representation of this Grouping
IsAscending | [read/write] true if the sort is ascending
IsByDateOnly | [read/write] true if sort order is by date
IsByTextValue | [read/write] true if the sort order is determined by text value
IsCaseSensitive | [read/write] true if sorting is case sensitive
IsGroup | [read] true if this property participates in a group
IsSort | [read] true if this property participates in a sort, not in a group
Property | [read/write] the property in this grouping

Public Instance Methods

Copy | Returns a copy of this object
Equals | Delegate Equals() to com.starteam.Filter.Grouping.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Grouping.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
ToString | Delegate ToString() to com.starteam.Filter.Grouping.

See Also

Filter.Grouping Class | StarTeam Namespace


Filter.Grouping Constructor

Create a new Grouping

public Filter.Grouping(
Property prprty,
Boolean group
);

Parameters

prprty
the property
group
true if part of a group

See Also

Filter.Grouping Class | StarTeam Namespace


Filter.Grouping Properties

The properties of the Filter.Grouping class are listed below. For a complete list of Filter.Grouping class members, see the Filter.Grouping Members topic.

Public Instance Properties

DebugString | [read] a debug representation of this Grouping
IsAscending | [read/write] true if the sort is ascending
IsByDateOnly | [read/write] true if sort order is by date
IsByTextValue | [read/write] true if the sort order is determined by text value
IsCaseSensitive | [read/write] true if sorting is case sensitive
IsGroup | [read] true if this property participates in a group
IsSort | [read] true if this property participates in a sort, not in a group
Property | [read/write] the property in this grouping

See Also

Filter.Grouping Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Filter.Grouping.DebugString Property

[read] a debug representation of this Grouping

public virtual String DebugString {get;}

Property Value

a debug representation of this Grouping

See Also

Filter.Grouping Class | StarTeam Namespace


IsAscending Property

Borland StarTeam SDK for .NET

Filter.Grouping.IsAscending Property

[read/write] true if the sort is ascending

public virtual Boolean IsAscending {get; set;}

Property Value

true if the sort is ascending

See Also

Filter.Grouping Class | StarTeam Namespace


IsByDateOnly Property

Borland StarTeam SDK for .NET

Filter.Grouping.IsByDateOnly Property

[read/write] true if sort order is by date

public virtual Boolean IsByDateOnly {get; set;}

Property Value

true if sort order is by date

See Also

Filter.Grouping Class | StarTeam Namespace


IsByTextValue Property

Borland StarTeam SDK for .NET

Filter.Grouping.IsByTextValue Property

[read/write] true if the sort order is determined by text value

public virtual Boolean IsByTextValue {get; set;}

Property Value

true if the sort order is determined by text value

See Also

Filter.Grouping Class | StarTeam Namespace


IsCaseSensitive Property

Borland StarTeam SDK for .NET

Filter.Grouping.IsCaseSensitive Property

[read/write] true if sorting is case sensitive

public virtual Boolean IsCaseSensitive {get; set;}

Property Value

true if sorting is case sensitive

See Also

Filter.Grouping Class | StarTeam Namespace


IsGroup Property

Borland StarTeam SDK for .NET

Filter.Grouping.IsGroup Property

[read] true if this property participates in a group

public virtual Boolean IsGroup {get;}

Property Value

true if this property participates in a group

See Also

Filter.Grouping Class | StarTeam Namespace


IsSort Property

Borland StarTeam SDK for .NET

Filter.Grouping.IsSort Property

[read] true if this property participates in a sort, not in a group

public virtual Boolean IsSort {get;}

Property Value

true if this property participates in a sort, not in a group

See Also

Filter.Grouping Class | StarTeam Namespace


Property Property

Borland StarTeam SDK for .NET

Filter.Grouping.Property Property

[read/write] the property in this grouping

public virtual Property Property {get; set;}

Property Value

the property in this grouping

See Also

Filter.Grouping Class | StarTeam Namespace


Filter.Grouping Methods

The methods of the Filter.Grouping class are listed below. For a complete list of Filter.Grouping class members, see the Filter.Grouping Members topic.

Public Instance Methods

Copy | Returns a copy of this object
Equals | Delegate Equals() to com.starteam.Filter.Grouping.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Grouping.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
ToString | Delegate ToString() to com.starteam.Filter.Grouping.

See Also

Filter.Grouping Class | StarTeam Namespace


Filter.Grouping.Copy Method

Returns a copy of this object

public virtual object Copy();

Return Value

a copy of this object

See Also

Filter.Grouping Class | StarTeam Namespace


Filter.Grouping.Equals Method

Delegate Equals() to com.starteam.Filter.Grouping.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Filter.Grouping.Equals(obj).

See Also

Filter.Grouping Class | StarTeam Namespace


Filter.Grouping.GetHashCode Method

Delegate GetHashCode() to com.starteam.Filter.Grouping.

public override int GetHashCode();

Return Value

com.starteam.Filter.Grouping.GetHashCode().

See Also

Filter.Grouping Class | StarTeam Namespace


Filter.Grouping.IsEqualTo Method

public virtual bool IsEqualTo(
Filter.Grouping other
);

See Also

Filter.Grouping Class | StarTeam Namespace


Filter.Grouping.ToString Method

Delegate ToString() to com.starteam.Filter.Grouping.

public override string ToString();

Return Value

com.starteam.Filter.Grouping.ToString()

See Also

Filter.Grouping Class | StarTeam Namespace


Filter.Grouping.WebCacheGrouping Class

A positional indicator for a property in a group meant for sorting and grouping results

For a list of all members of this type, see Filter.Grouping.WebCacheGrouping Members.

System.Object
Filter.Grouping.WebCacheGrouping

public class Filter.Grouping.WebCacheGrouping

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Filter.Grouping.WebCacheGrouping Members | StarTeam Namespace


Filter.Grouping.WebCacheGrouping Members

Filter.Grouping.WebCacheGrouping overview

Public Instance Constructors

Filter.Grouping.WebCacheGrouping Constructor

Public Instance Properties

IsAscending | [read/write] true if the sort is ascending
IsByDateOnly | [read/write] true if sort order is by date
IsByTextValue | [read/write] true if the sort order is determined by text value
IsCaseSensitive | [read/write] true if sorting is case sensitive
IsGroup | [read] true if this property participates in a group
IsSort | [read] true if this property participates in a sort, not in a group
Property | [read/write] the property in this grouping

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Filter.Grouping.WebCacheGrouping.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Grouping.WebCacheGrouping.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Filter.Grouping.WebCacheGrouping.

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


Filter.Grouping.WebCacheGrouping Constructor

public Filter.Grouping.WebCacheGrouping(
ArtifactCacheManager.Context cntxt,
Property.WebCacheProperty prprty,
Boolean group
);

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


Filter.Grouping.WebCacheGrouping Properties

The properties of the Filter.Grouping.WebCacheGrouping class are listed below. For a complete list of Filter.Grouping.WebCacheGrouping class members, see the Filter.Grouping.WebCacheGrouping Members topic.

Public Instance Properties

IsAscending | [read/write] true if the sort is ascending
IsByDateOnly | [read/write] true if sort order is by date
IsByTextValue | [read/write] true if the sort order is determined by text value
IsCaseSensitive | [read/write] true if sorting is case sensitive
IsGroup | [read] true if this property participates in a group
IsSort | [read] true if this property participates in a sort, not in a group
Property | [read/write] the property in this grouping

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


IsAscending Property

Borland StarTeam SDK for .NET

Filter.Grouping.WebCacheGrouping.IsAscending Property

[read/write] true if the sort is ascending

public virtual Boolean IsAscending {get; set;}

Property Value

true if the sort is ascending

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


IsByDateOnly Property

Borland StarTeam SDK for .NET

Filter.Grouping.WebCacheGrouping.IsByDateOnly Property

[read/write] true if sort order is by date

public virtual Boolean IsByDateOnly {get; set;}

Property Value

true if sort order is by date

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


IsByTextValue Property

Borland StarTeam SDK for .NET

Filter.Grouping.WebCacheGrouping.IsByTextValue Property

[read/write] true if the sort order is determined by text value

public virtual Boolean IsByTextValue {get; set;}

Property Value

true if the sort order is determined by text value

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


IsCaseSensitive Property

Borland StarTeam SDK for .NET

Filter.Grouping.WebCacheGrouping.IsCaseSensitive Property

[read/write] true if sorting is case sensitive

public virtual Boolean IsCaseSensitive {get; set;}

Property Value

true if sorting is case sensitive

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


IsGroup Property

Borland StarTeam SDK for .NET

Filter.Grouping.WebCacheGrouping.IsGroup Property

[read] true if this property participates in a group

public virtual Boolean IsGroup {get;}

Property Value

true if this property participates in a group

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


IsSort Property

Borland StarTeam SDK for .NET

Filter.Grouping.WebCacheGrouping.IsSort Property

[read] true if this property participates in a sort, not in a group

public virtual Boolean IsSort {get;}

Property Value

true if this property participates in a sort, not in a group

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


Property Property

Borland StarTeam SDK for .NET

Filter.Grouping.WebCacheGrouping.Property Property

[read/write] the property in this grouping

public virtual Property.WebCacheProperty Property {get; set;}

Property Value

the property in this grouping

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


Filter.Grouping.WebCacheGrouping Methods

The methods of the Filter.Grouping.WebCacheGrouping class are listed below. For a complete list of Filter.Grouping.WebCacheGrouping class members, see the Filter.Grouping.WebCacheGrouping Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Filter.Grouping.WebCacheGrouping.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.Grouping.WebCacheGrouping.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Filter.Grouping.WebCacheGrouping.

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


Filter.Grouping.WebCacheGrouping.Equals Method

Delegate Equals() to com.starteam.Filter.Grouping.WebCacheGrouping.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Filter.Grouping.WebCacheGrouping.Equals(obj).

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


Filter.Grouping.WebCacheGrouping.GetHashCode Method

Delegate GetHashCode() to com.starteam.Filter.Grouping.WebCacheGrouping.

public override int GetHashCode();

Return Value

com.starteam.Filter.Grouping.WebCacheGrouping.GetHashCode().

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


Filter.Grouping.WebCacheGrouping.ToString Method

Delegate ToString() to com.starteam.Filter.Grouping.WebCacheGrouping.

public override string ToString();

Return Value

com.starteam.Filter.Grouping.WebCacheGrouping.ToString()

See Also

Filter.Grouping.WebCacheGrouping Class | StarTeam Namespace


Filter.WebCacheFilter Class

Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see Filter.WebCacheFilter Members.

System.Object
Filter.WebCacheFilter

public class Filter.WebCacheFilter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Filter.WebCacheFilter Members | StarTeam Namespace


Filter.WebCacheFilter Members

Filter.WebCacheFilter overview

Public Static Methods

Create

Public Instance Properties

Columns | [read/write] all the Columns in this filter
Context | [read] the context of this object.
ContextValue | [write] Set the context in which this filter should be applied
CreatedBy | [read] the user who created this filter.
CreatedTime | [read] the created time of this filter.
GroupingDepth | [read] the number of grouping levels specified for the Filter.
Groupings | [read/write] the set of groupings for this filter
ID | [read] the internal ID of the filter
IsDeleted | [read] true if this filter has been deleted
IsDirty | [read] true if this object is dirty
IsPublic | [read] true if the filter is visible to all users.
ModifiedBy | [read] the user who last modified this filter.
ModifiedTime | [read] the last modified time of this filter.
Name | [read/write] the display name of the filter.
OwnedBy | [read] the user who owns the filter or NULL
PresentationID | [read] the unique integer identifier for this filter.
Projects | [read/write] projects (associated with this filter) visible in the current user context
Properties | [read] an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.
Query | [read/write] the query associated with the filter or NULL
Rights | [read/write] the access rights assigned to this filter
Server | [read] the Server for this cached object
Type | [read] the Type this Filter was created for.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Filter.WebCacheFilter.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.WebCacheFilter.
GetType (inherited from Object) | Gets the Type of the current instance.
MakePrivate |
MakePublic | Make this filter public. You must call update() to make the change take take effect.
Remove | Remove this Filter from the repository This is an atomic operation, and cannot be executed in a transaction
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Filter.WebCacheFilter.
Update | Save this dirty Filter to the Repository This is an atomic operation, not executed in a transaction

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter Properties

The properties of the Filter.WebCacheFilter class are listed below. For a complete list of Filter.WebCacheFilter class members, see the Filter.WebCacheFilter Members topic.

Public Instance Properties

Columns | [read/write] all the Columns in this filter
Context | [read] the context of this object.
ContextValue | [write] Set the context in which this filter should be applied
CreatedBy | [read] the user who created this filter.
CreatedTime | [read] the created time of this filter.
GroupingDepth | [read] the number of grouping levels specified for the Filter.
Groupings | [read/write] the set of groupings for this filter
ID | [read] the internal ID of the filter
IsDeleted | [read] true if this filter has been deleted
IsDirty | [read] true if this object is dirty
IsPublic | [read] true if the filter is visible to all users.
ModifiedBy | [read] the user who last modified this filter.
ModifiedTime | [read] the last modified time of this filter.
Name | [read/write] the display name of the filter.
OwnedBy | [read] the user who owns the filter or NULL
PresentationID | [read] the unique integer identifier for this filter.
Projects | [read/write] projects (associated with this filter) visible in the current user context
Properties | [read] an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.
Query | [read/write] the query associated with the filter or NULL
Rights | [read/write] the access rights assigned to this filter
Server | [read] the Server for this cached object
Type | [read] the Type this Filter was created for.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Columns Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Columns Property

[read/write] all the Columns in this filter

public virtual WebCacheColumn[] Columns {get; set;}

Property Value

all the Columns in this filter

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Context Property

[read] the context of this object.

public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


ContextValue Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.ContextValue Property

[write] Set the context in which this filter should be applied

public virtual Filter.Context ContextValue {set;}

Property Value

Set the context in which this filter should be applied

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.CreatedBy Property

[read] the user who created this filter.

public virtual User.WebCacheUser CreatedBy {get;}

Property Value

the user who created this filter.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.CreatedTime Property

[read] the created time of this filter.

public virtual DateTime CreatedTime {get;}

Property Value

the created time of this filter.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


GroupingDepth Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.GroupingDepth Property

[read] the number of grouping levels specified for the Filter.

public virtual Int32 GroupingDepth {get;}

Property Value

the number of grouping levels specified for the Filter.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Groupings Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Groupings Property

[read/write] the set of groupings for this filter

public virtual WebCacheGrouping[] Groupings {get; set;}

Property Value

the set of groupings for this filter

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.ID Property

[read] the internal ID of the filter

public virtual Int32 ID {get;}

Property Value

the internal ID of the filter

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.IsDeleted Property

[read] true if this filter has been deleted

public virtual Boolean IsDeleted {get;}

Property Value

true if this filter has been deleted

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.IsDirty Property

[read] true if this object is dirty

public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


IsPublic Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.IsPublic Property

[read] true if the filter is visible to all users.

public virtual Boolean IsPublic {get;}

Property Value

true if the filter is visible to all users.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.ModifiedBy Property

[read] the user who last modified this filter.

public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

the user who last modified this filter.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.ModifiedTime Property

[read] the last modified time of this filter.

public virtual DateTime ModifiedTime {get;}

Property Value

the last modified time of this filter.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Name Property

[read/write] the display name of the filter.

public virtual String Name {get; set;}

Property Value

the display name of the filter.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


OwnedBy Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.OwnedBy Property

[read] the user who owns the filter or NULL

public virtual User.WebCacheUser OwnedBy {get;}

Property Value

the user who owns the filter or NULL

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.PresentationID Property

[read] the unique integer identifier for this filter.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this filter.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Projects Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Projects Property

[read/write] projects (associated with this filter) visible in the current user context

public virtual WebCacheProject[] Projects {get; set;}

Property Value

projects (associated with this filter) visible in the current user context

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Properties Property

[read] an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.

public virtual WebCacheProperty[] Properties {get;}

Property Value

an array of all Properties that are relevant to the Filter, including dependencies for client-calculated properties.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Query Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Query Property

[read/write] the query associated with the filter or NULL

public virtual Query.WebCacheQuery Query {get; set;}

Property Value

the query associated with the filter or NULL

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Rights Property

[read/write] the access rights assigned to this filter

public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Server Property

[read] the Server for this cached object

public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Filter.WebCacheFilter.Type Property

[read] the Type this Filter was created for.

public virtual Type.WebCacheType Type {get;}

Property Value

the Type this Filter was created for.

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter Methods

The methods of the Filter.WebCacheFilter class are listed below. For a complete list of Filter.WebCacheFilter class members, see the Filter.WebCacheFilter Members topic.

Public Static Methods

Create

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Filter.WebCacheFilter.
GetHashCode | Delegate GetHashCode() to com.starteam.Filter.WebCacheFilter.
GetType (inherited from Object) | Gets the Type of the current instance.
MakePrivate |
MakePublic | Make this filter public. You must call update() to make the change take take effect.
Remove | Remove this Filter from the repository This is an atomic operation, and cannot be executed in a transaction
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Filter.WebCacheFilter.
Update | Save this dirty Filter to the Repository This is an atomic operation, not executed in a transaction

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter.Create Method

public static WebCacheFilter Create(
ArtifactCacheManager.Context cntxt,
ViewMember.Type.WebCacheViewMemberType type,
String name,
Filter.Context context,
Boolean isPublic
);

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter.Equals Method

Delegate Equals() to com.starteam.Filter.WebCacheFilter.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Filter.WebCacheFilter.Equals(obj).

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter.GetHashCode Method

Delegate GetHashCode() to com.starteam.Filter.WebCacheFilter.

public override int GetHashCode();

Return Value

com.starteam.Filter.WebCacheFilter.GetHashCode().

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter.MakePrivate Method

public virtual void MakePrivate(
User.WebCacheUser wcu
);

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter.MakePublic Method

Make this filter public. You must call update() to make the change take take effect.

public virtual void MakePublic();

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter.Remove Method

Remove this Filter from the repository This is an atomic operation, and cannot be executed in a transaction

public virtual void Remove();

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter.ToString Method

Delegate ToString() to com.starteam.Filter.WebCacheFilter.

public override string ToString();

Return Value

com.starteam.Filter.WebCacheFilter.ToString()

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Filter.WebCacheFilter.Update Method

Save this dirty Filter to the Repository This is an atomic operation, not executed in a transaction

public virtual void Update();

See Also

Filter.WebCacheFilter Class | StarTeam Namespace


Folder Class

Represents a StarTeam Folder. A folder is an Item, i.e. it does not have a parent id property However, (sub)folders reside within folders, which makes a folder a type of hierarchy tree Folders are also containers, in that, other items reside in folders

For a list of all members of this type, see Folder Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Folder
VCMFolder

public class Folder : Item, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder Members | StarTeam Namespace


Folder Members

Folder overview

Public Instance Constructors

Folder Overloaded. Initializes a new instance of the Folder class.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AlternatePathFragment | [read/write] the alternate or overridden working path for this folder.
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CaseSensitiveFileNames | [read] True if the names of files in this folder are case sensitive, and false otherwise.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DefaultPathFragment | [read/write] this folder's specified working path.
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this folder.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EffectiveExcludeList | [read] the fully resolved exclude list for this folder.
EffectiveUserVisible | [read] false if this folder or any parent is set to be not visible
ExcludeFlagsValue | [read/write] the exclude type being used for this folder's exclude list
ExcludeList | [read/write] the portion of the exclude list that this folder contributes.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
FileEOL | [read] The end-of-line character sequence to be used for text files in this folder.
FolderHierarchy | [read] The fully-qualified name of this folder.
HasParentFolder | [read] true if this folder has a parent folder.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of the folder.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
NotInViewFiles | [read] an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder |
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
Path | [read] the local working folder path being used for this folder.
PathFragment | [read] the path fragment to use for this folder.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the properties for the folder type
QualifiedName | [read] The fully-qualified name of this folder.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read] The current status of this folder.
SubFolders | [read] the sub-folders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
UserVisible | [read/write]
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CopyFolderTree | Copies a folder tree. Does not populate any properties or copy any cached items.
CountItems
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
DiscardItems
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
FindSubFolder | Find an immediate sub folder with the given name
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFilePath | For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.
GetFolderTree
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetItems
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetRights | Returns the Access Control List for items of the specified type for this folder. This will return null if this folder has no access control list for the specified type. The access control list is not cached, and will be fetched from the server on demand Cached lists are accessible via the AccessRightsManager
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions | Overloaded. Returns true if desired permissions are granted for items of the specified type for this Folder
HasPermissions (inherited from ViewMember) | Overloaded. Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsDescendantOf | Returns true if this folder is a child of the specified ancestor
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsExcluded | Determines if the given file name is one that will be excluded (Matches the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.
IsPopulated
IsRefreshItemsRequired
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
NewFolderEventSource
NewFolderTreeEventSource
NewFolderUpdateEventSource
NewItemEventSource | Overloaded.
NewItemIDEventSource | Overloaded.
NewItemListEventSource | Overloaded.
NewItemUpdateEventSource
NewNotificationEventSource | Overloaded.
Populate | Overloaded.
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
RefreshItems
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo | Overloaded. Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights | Modifies the Access Control List for items of the specified type for this folder. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo | Overloaded. Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ShareTo (inherited from Item) | Overloaded. Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update | Overloaded.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateFolderTree | Calls update() on itself, and recursively calls Folder.updateFolderTree() on Folders returned from getSubFolders().
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Folder Class | StarTeam Namespace


Folder Constructor

Special constructor for the root folder of a view, to be used during the creation of a project. This is the only way to create the root of an initial folder tree, to be passed as a parameter to the project constructor

Overload List

Creates a new folder specifying in which folder it is to reside. Note that a valid name is required prior to update.

public Folder(Folder);

Creates a new folder specifying in which folder it is to reside, its name and its working path relative to the working path of its parent folder.

public Folder(Folder,String,String);

Special constructor for the root folder of a view, to be used during the creation of a project. This is the only way to create the root of an initial folder tree, to be passed as a parameter to the project constructor

public Folder(Server);

See Also

Folder Class | StarTeam Namespace


Folder Constructor (Server)

Special constructor for the root folder of a view, to be used during the creation of a project. This is the only way to create the root of an initial folder tree, to be passed as a parameter to the project constructor

public Folder(
Server server
);

Parameters

server
the server on which the root folder of this view is being constructed

See Also

Folder Class | StarTeam Namespace | Folder Constructor Overload List


Folder Constructor (Folder)

Creates a new folder specifying in which folder it is to reside. Note that a valid name is required prior to update.

public Folder(
Folder parent
);

Parameters

parent
the parent folder in which this new folder will reside.

See Also

Folder Class | StarTeam Namespace | Folder Constructor Overload List


Folder Constructor (Folder, String, String)

Creates a new folder specifying in which folder it is to reside, its name and its working path relative to the working path of its parent folder.

public Folder(
Folder parent,
String name,
String workingFolder
);

Parameters

parent
the parent folder in which this new folder will reside.
name
the name of this folder.
workingFolder
the working path for this folder, relative to its parent's working path.

See Also

Folder Class | StarTeam Namespace | Folder Constructor Overload List


Folder Properties

The properties of the Folder class are listed below. For a complete list of Folder class members, see the Folder Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AlternatePathFragment | [read/write] the alternate or overridden working path for this folder.
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CaseSensitiveFileNames | [read] True if the names of files in this folder are case sensitive, and false otherwise.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DefaultPathFragment | [read/write] this folder's specified working path.
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this folder.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EffectiveExcludeList | [read] the fully resolved exclude list for this folder.
EffectiveUserVisible | [read] false if this folder or any parent is set to be not visible
ExcludeFlagsValue | [read/write] the exclude type being used for this folder's exclude list
ExcludeList | [read/write] the portion of the exclude list that this folder contributes.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
FileEOL | [read] The end-of-line character sequence to be used for text files in this folder.
FolderHierarchy | [read] The fully-qualified name of this folder.
HasParentFolder | [read] true if this folder has a parent folder.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of the folder.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
NotInViewFiles | [read] an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder |
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
Path | [read] the local working folder path being used for this folder.
PathFragment | [read] the path fragment to use for this folder.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the properties for the folder type
QualifiedName | [read] The fully-qualified name of this folder.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read] The current status of this folder.
SubFolders | [read] the sub-folders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
UserVisible | [read/write]
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Folder Class | StarTeam Namespace


AlternatePathFragment Property

Borland StarTeam SDK for .NET

Folder.AlternatePathFragment Property

[read/write] the alternate or overridden working path for this folder.

public virtual String AlternatePathFragment {get; set;}

Property Value

the alternate or overridden working path for this folder.

See Also

Folder Class | StarTeam Namespace


CaseSensitiveFileNames Property

Borland StarTeam SDK for .NET

Folder.CaseSensitiveFileNames Property

[read] True if the names of files in this folder are case sensitive, and false otherwise.

public virtual Boolean CaseSensitiveFileNames {get;}

Property Value

True if the names of files in this folder are case sensitive, and false otherwise.

See Also

Folder Class | StarTeam Namespace


DefaultPathFragment Property

Borland StarTeam SDK for .NET

Folder.DefaultPathFragment Property

[read/write] this folder's specified working path.

public virtual String DefaultPathFragment {get; set;}

Property Value

this folder's specified working path.

See Also

Folder Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Folder.Description Property

[read/write] the description of this folder.

public virtual String Description {get; set;}

Property Value

the description of this folder.

See Also

Folder Class | StarTeam Namespace


EffectiveExcludeList Property

Borland StarTeam SDK for .NET

Folder.EffectiveExcludeList Property

[read] the fully resolved exclude list for this folder.

public virtual String EffectiveExcludeList {get;}

Property Value

the fully resolved exclude list for this folder.

See Also

Folder Class | StarTeam Namespace


EffectiveUserVisible Property

Borland StarTeam SDK for .NET

Folder.EffectiveUserVisible Property

[read] false if this folder or any parent is set to be not visible

public virtual Boolean EffectiveUserVisible {get;}

Property Value

false if this folder or any parent is set to be not visible

See Also

Folder Class | StarTeam Namespace


ExcludeFlagsValue Property

Borland StarTeam SDK for .NET

Folder.ExcludeFlagsValue Property

[read/write] the exclude type being used for this folder's exclude list

public virtual Folder.ExcludeFlags ExcludeFlagsValue {get; set;}

Property Value

the exclude type being used for this folder's exclude list

See Also

Folder Class | StarTeam Namespace


ExcludeList Property

Borland StarTeam SDK for .NET

Folder.ExcludeList Property

[read/write] the portion of the exclude list that this folder contributes.

public virtual String ExcludeList {get; set;}

Property Value

the portion of the exclude list that this folder contributes.

See Also

Folder Class | StarTeam Namespace


FileEOL Property

Borland StarTeam SDK for .NET

Folder.FileEOL Property

[read] The end-of-line character sequence to be used for text files in this folder.

public virtual String FileEOL {get;}

Property Value

The end-of-line character sequence to be used for text files in this folder.

See Also

Folder Class | StarTeam Namespace


FolderHierarchy Property

Borland StarTeam SDK for .NET

Folder.FolderHierarchy Property

[read] The fully-qualified name of this folder.

public virtual String FolderHierarchy {get;}

Property Value

The fully-qualified name of this folder.

See Also

Folder Class | StarTeam Namespace


HasParentFolder Property

Borland StarTeam SDK for .NET

Folder.HasParentFolder Property

[read] true if this folder has a parent folder.

public virtual Boolean HasParentFolder {get;}

Property Value

true if this folder has a parent folder.

See Also

Folder Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Folder.Name Property

[read/write] the name of the folder.

public virtual String Name {get; set;}

Property Value

the name of the folder.

See Also

Folder Class | StarTeam Namespace


NotInViewFiles Property

Borland StarTeam SDK for .NET

Folder.NotInViewFiles Property

[read] an array of "not in view" File objects in this Folder, applying exclusions as appropriate.

public virtual File[] NotInViewFiles {get;}

Property Value

an array of "not in view" File objects in this Folder, applying exclusions as appropriate.

See Also

Folder Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Folder.ParentFolder Property

new public virtual Folder ParentFolder {get;}

See Also

Folder Class | StarTeam Namespace


Path Property

Borland StarTeam SDK for .NET

Folder.Path Property

[read] the local working folder path being used for this folder.

public virtual String Path {get;}

Property Value

the local working folder path being used for this folder.

See Also

Folder Class | StarTeam Namespace


PathFragment Property

Borland StarTeam SDK for .NET

Folder.PathFragment Property

[read] the path fragment to use for this folder.

public virtual String PathFragment {get;}

Property Value

the path fragment to use for this folder.

See Also

Folder Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Folder.Properties Property

[read] the properties for the folder type

public virtual Folder.Type.PropertyCollection Properties {get;}

Property Value

the properties for the folder type

See Also

Folder Class | StarTeam Namespace


QualifiedName Property

Borland StarTeam SDK for .NET

Folder.QualifiedName Property

[read] The fully-qualified name of this folder.

public virtual String QualifiedName {get;}

Property Value

The fully-qualified name of this folder.

See Also

Folder Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Folder.StatusValue Property

[read] The current status of this folder.

public virtual Folder.Status StatusValue {get;}

Property Value

The current status of this folder.

See Also

Folder Class | StarTeam Namespace


SubFolders Property

Borland StarTeam SDK for .NET

Folder.SubFolders Property

[read] the sub-folders of this folder. Will not return null but may return an empty array if the folder has no subfolders.

public virtual Folder[] SubFolders {get;}

Property Value

the sub-folders of this folder. Will not return null but may return an empty array if the folder has no subfolders.

See Also

Folder Class | StarTeam Namespace


UserVisible Property

Borland StarTeam SDK for .NET

Folder.UserVisible Property

[read/write]

public virtual Boolean UserVisible {get; set;}

See Also

Folder Class | StarTeam Namespace


Folder Methods

The methods of the Folder class are listed below. For a complete list of Folder class members, see the Folder Members topic.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CopyFolderTree | Copies a folder tree. Does not populate any properties or copy any cached items.
CountItems
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
DiscardItems
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
FindSubFolder | Find an immediate sub folder with the given name
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFilePath | For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.
GetFolderTree
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetItems
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetRights | Returns the Access Control List for items of the specified type for this folder. This will return null if this folder has no access control list for the specified type. The access control list is not cached, and will be fetched from the server on demand Cached lists are accessible via the AccessRightsManager
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions | Overloaded. Returns true if desired permissions are granted for items of the specified type for this Folder
HasPermissions (inherited from ViewMember) | Overloaded. Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsDescendantOf | Returns true if this folder is a child of the specified ancestor
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsExcluded | Determines if the given file name is one that will be excluded (Matches the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.
IsPopulated
IsRefreshItemsRequired
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
NewFolderEventSource
NewFolderTreeEventSource
NewFolderUpdateEventSource
NewItemEventSource | Overloaded.
NewItemIDEventSource | Overloaded.
NewItemListEventSource | Overloaded.
NewItemUpdateEventSource
NewNotificationEventSource | Overloaded.
Populate | Overloaded.
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
RefreshItems
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo | Overloaded. Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights | Modifies the Access Control List for items of the specified type for this folder. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo | Overloaded. Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ShareTo (inherited from Item) | Overloaded. Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update | Overloaded.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateFolderTree | Calls update() on itself, and recursively calls Folder.updateFolderTree() on Folders returned from getSubFolders().
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Folder Class | StarTeam Namespace


Folder.CopyFolderTree Method

Copies a folder tree. Does not populate any properties or copy any cached items.

public virtual Folder CopyFolderTree();

Return Value

A copy of this folder and its sub-folders.

See Also

Folder Class | StarTeam Namespace | copy


Folder.CountItems Method

public virtual long CountItems(
Item.Type type,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace


Folder.DiscardItems Method

public virtual void DiscardItems(
Item.Type type,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace


Folder.FindSubFolder Method

Find an immediate sub folder with the given name

public virtual Folder FindSubFolder(
String name
);

Parameters

name
the name of the subfolder

Return Value

a sub folder with the given name or NULL

See Also

Folder Class | StarTeam Namespace


Folder.GetFilePath Method

For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.

public virtual string GetFilePath(
String fileName
);

Parameters

fileName
the name of the local file.

Return Value

the full local working path to the specified file name

See Also

Folder Class | StarTeam Namespace


Folder.GetFolderTree Method

public virtual Folder GetFolderTree(
Filter.Context context,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace


Folder.GetItems Method

public virtual ViewMemberCollection GetItems(
Item.Type type
);

See Also

Folder Class | StarTeam Namespace


Folder.GetRights Method

Returns the Access Control List for items of the specified type for this folder. This will return null if this folder has no access control list for the specified type. The access control list is not cached, and will be fetched from the server on demand Cached lists are accessible via the AccessRightsManager

public virtual ACE[] GetRights(
Type type
);

Parameters

type
the name of the type being controlled by the returned ACL

Return Value

the access control list for this folder or NULL.

Implements

ISecurableContainer.GetRights

See Also

Folder Class | StarTeam Namespace | getRights | isDisembodied | Type


HasPermissions Method

Borland StarTeam SDK for .NET

Folder.HasPermissions Method

Returns true if desired permissions are granted for items of the specified type for this Folder

Overload List

Inherited from ViewMember.

public virtual bool HasPermissions(PermissionCollection);

Returns true if desired permissions are granted for items of the specified type for this Folder

public virtual bool HasPermissions(PermissionCollection,Type);

See Also

Folder Class | StarTeam Namespace | Permission


Folder.HasPermissions Method (PermissionCollection, Type)

Returns true if desired permissions are granted for items of the specified type for this Folder

public virtual bool HasPermissions(
PermissionCollection permissions,
Type type
);

Parameters

permissions
the desired permissions
type
the type for access to be tested on

Implements

ISecurableContainer.HasPermissions

See Also

Folder Class | StarTeam Namespace | Folder.HasPermissions Overload List | Permission


Folder.IsDescendantOf Method

Returns true if this folder is a child of the specified ancestor

public virtual bool IsDescendantOf(
Folder ancestor
);

Parameters

ancestor
the target ancestor to test against

Return Value

true if this folder is a child of the specified ancestor

See Also

Folder Class | StarTeam Namespace


Folder.IsExcluded Method

Determines if the given file name is one that will be excluded (Matches the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.

public virtual bool IsExcluded(
String filename
);

Parameters

filename
the name of the file to be checked for exclusion

Return Value

true if the specified file name should be considered as excluded from being added to the StarTeam repository/

See Also

Folder Class | StarTeam Namespace | getEffectiveExcludeList


Folder.IsPopulated Method

public virtual bool IsPopulated(
Item.Type type
);

See Also

Folder Class | StarTeam Namespace


Folder.IsRefreshItemsRequired Method

public virtual bool IsRefreshItemsRequired(
Item.Type type,
PropertyCollection properties,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace


Folder.NewFolderEventSource Method

public FolderEventSource NewFolderEventSource(
Int32 depth
);

See Also

Folder Class | StarTeam Namespace


Folder.NewFolderTreeEventSource Method

public FolderTreeEventSource NewFolderTreeEventSource(
Int32 depth
);

See Also

Folder Class | StarTeam Namespace


Folder.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource(
Int32 depth
);

See Also

Folder Class | StarTeam Namespace


NewItemEventSource Method

Borland StarTeam SDK for .NET

Folder.NewItemEventSource Method

Overload List

public ItemEventSource NewItemEventSource(Item.Type,PropertyCollection,Int32);

public ItemEventSource NewItemEventSource(Item.Type,Int32);

See Also

Folder Class | StarTeam Namespace


Folder.NewItemEventSource Method (Item#Type, PropertyCollection, Int32)

public ItemEventSource NewItemEventSource(
Item.Type type,
PropertyCollection properties,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.NewItemEventSource Overload List


Folder.NewItemEventSource Method (Item#Type, Int32)

public ItemEventSource NewItemEventSource(
Item.Type type,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.NewItemEventSource Overload List


NewItemIDEventSource Method

Borland StarTeam SDK for .NET

Folder.NewItemIDEventSource Method

Overload List

public ItemIDEventSource NewItemIDEventSource(Item.Type,PropertyCollection,Int32);

public ItemIDEventSource NewItemIDEventSource(Item.Type,Int32);

See Also

Folder Class | StarTeam Namespace


Folder.NewItemIDEventSource Method (Item#Type, PropertyCollection, Int32)

public ItemIDEventSource NewItemIDEventSource(
Item.Type type,
PropertyCollection properties,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.NewItemIDEventSource Overload List


Folder.NewItemIDEventSource Method (Item#Type, Int32)

public ItemIDEventSource NewItemIDEventSource(
Item.Type type,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.NewItemIDEventSource Overload List


NewItemListEventSource Method

Borland StarTeam SDK for .NET

Folder.NewItemListEventSource Method

Overload List

public ItemListEventSource NewItemListEventSource(Item.Type,PropertyCollection,Int32);

public ItemListEventSource NewItemListEventSource(Item.Type,Int32);

See Also

Folder Class | StarTeam Namespace


Folder.NewItemListEventSource Method (Item#Type, PropertyCollection, Int32)

public ItemListEventSource NewItemListEventSource(
Item.Type type,
PropertyCollection properties,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.NewItemListEventSource Overload List


Folder.NewItemListEventSource Method (Item#Type, Int32)

public ItemListEventSource NewItemListEventSource(
Item.Type type,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.NewItemListEventSource Overload List


Folder.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource(
Item.Type type,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace


NewNotificationEventSource Method

Borland StarTeam SDK for .NET

Folder.NewNotificationEventSource Method

Overload List

public NotificationEventSource NewNotificationEventSource(Item.Type,PropertyCollection,Int32);

public NotificationEventSource NewNotificationEventSource(Item.Type,Int32);

See Also

Folder Class | StarTeam Namespace


Folder.NewNotificationEventSource Method (Item#Type, PropertyCollection, Int32)

public NotificationEventSource NewNotificationEventSource(
Item.Type type,
PropertyCollection properties,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.NewNotificationEventSource Overload List


Folder.NewNotificationEventSource Method (Item#Type, Int32)

public NotificationEventSource NewNotificationEventSource(
Item.Type type,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.NewNotificationEventSource Overload List


Populate Method

Borland StarTeam SDK for .NET

Folder.Populate Method

Overload List

public virtual void Populate(Item.Type,PropertyCollection,Int32);

public virtual void Populate(Item.Type,Int32);

See Also

Folder Class | StarTeam Namespace


Folder.Populate Method (Item#Type, PropertyCollection, Int32)

public virtual void Populate(
Item.Type type,
PropertyCollection properties,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.Populate Overload List


Folder.Populate Method (Item#Type, Int32)

public virtual void Populate(
Item.Type type,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace | Folder.Populate Overload List


Folder.RefreshItems Method

public virtual void RefreshItems(
Item.Type type,
PropertyCollection properties,
Int32 depth
);

See Also

Folder Class | StarTeam Namespace


ReverseShareTo Method

Borland StarTeam SDK for .NET

Folder.ReverseShareTo Method

Reverse shares this folder to a new parent folder.

If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

Overload List

Inherited from Item.

public virtual Item ReverseShareTo(Folder);

Inherited from Item.

public virtual Item ReverseShareTo(Folder,View);

Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

public virtual Folder ReverseShareTo(Folder,Boolean);

See Also

Folder Class | StarTeam Namespace | reverseShareTo


Folder.ReverseShareTo Method (Folder, Boolean)

Reverse shares this folder to a new parent folder.

If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

public virtual Folder ReverseShareTo(
Folder toFolder,
Boolean bThisFolderOnly
);

Parameters

toFolder
The new parent folder.
bThisFolderOnly
true to share this folder only; false to share this folder, all of its children to any depth, and all of the items contained within those folders.

Return Value

The folder object representing the newly shared folder.

See Also

Folder Class | StarTeam Namespace | Folder.ReverseShareTo Overload List | reverseShareTo


Folder.SetRights Method

Modifies the Access Control List for items of the specified type for this folder. If the ACL is null then the access control list for items of the specified type will be dropped.

public virtual void SetRights(
Type type,
ACE[] acl
);

Parameters

type
the name of the type being controlled by the returned ACL
acl
the new access control list for items of the specified type in this folder

Implements

ISecurableContainer.SetRights

See Also

Folder Class | StarTeam Namespace | isDisembodied


ShareTo Method

Borland StarTeam SDK for .NET

Folder.ShareTo Method

Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one.

If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

Overload List

Inherited from Item.

public virtual Item ShareTo(Folder);

Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

public virtual Folder ShareTo(Folder,Boolean);

See Also

Folder Class | StarTeam Namespace | shareTo


Folder.ShareTo Method (Folder, Boolean)

Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one.

If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.

public virtual Folder ShareTo(
Folder toFolder,
Boolean bThisFolderOnly
);

Parameters

toFolder
The new parent folder.
bThisFolderOnly
true to share this folder only; false to share this folder, all of its children to any depth, and all of the items contained within those folders.

Return Value

The folder object representing the newly shared folder.

See Also

Folder Class | StarTeam Namespace | Folder.ShareTo Overload List | shareTo


Update Method

Borland StarTeam SDK for .NET

Folder.Update Method

Overload List

Inherited from ViewMember.

public virtual void Update();

Inherited from ViewMember.

public virtual void Update(ConnectionPool,User);

public virtual void Update(Boolean);

See Also

Folder Class | StarTeam Namespace


Folder.Update Method (Boolean)

public virtual void Update(
Boolean bRecursive
);

See Also

Folder Class | StarTeam Namespace | Folder.Update Overload List


Folder.UpdateFolderTree Method

Calls update() on itself, and recursively calls Folder.updateFolderTree() on Folders returned from getSubFolders().

public virtual void UpdateFolderTree(
Int32 depth
);

Parameters

depth
the depth of levels of Folders that's affected.

See Also

Folder Class | StarTeam Namespace | getSubFolders


Folder.ExcludeFlags Class

Criteria used to exclude folders from the display

For a list of all members of this type, see Folder.ExcludeFlags Members.

System.Object
EnumeratedValue
Folder.ExcludeFlags

public class Folder.ExcludeFlags : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.ExcludeFlags Members | StarTeam Namespace


Folder.ExcludeFlags Members

Folder.ExcludeFlags overview

Public Static Properties

ALL
INHERIT
LOCAL
NONE

Public Static Methods

FromID | Gets the ExcludeFlags value corresponding to the given ID.
FromValue | Gets the ExcludeFlags value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this ExcludeFlags value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Folder.ExcludeFlags.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.ExcludeFlags.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Folder.ExcludeFlags.

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


Folder.ExcludeFlags Properties

The properties of the Folder.ExcludeFlags class are listed below. For a complete list of Folder.ExcludeFlags class members, see the Folder.ExcludeFlags Members topic.

Public Static Properties

ALL
INHERIT
LOCAL
NONE

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this ExcludeFlags value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Folder.ExcludeFlags.ALL Property

public static ExcludeFlags[] ALL {get;}

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Folder.ExcludeFlags.ID Property

[read] The ID of this ExcludeFlags value.

public virtual Int32 ID {get;}

Property Value

The ID of this ExcludeFlags value.

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


INHERIT Property

Borland StarTeam SDK for .NET

Folder.ExcludeFlags.INHERIT Property

public static Folder.ExcludeFlags INHERIT {get;}

Property Value

Inherited folders are excluded

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


LOCAL Property

Borland StarTeam SDK for .NET

Folder.ExcludeFlags.LOCAL Property

public static Folder.ExcludeFlags LOCAL {get;}

Property Value

Local working folders are excluded

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


NONE Property

Borland StarTeam SDK for .NET

Folder.ExcludeFlags.NONE Property

public static Folder.ExcludeFlags NONE {get;}

Property Value

No folders are excluded

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


Folder.ExcludeFlags Methods

The methods of the Folder.ExcludeFlags class are listed below. For a complete list of Folder.ExcludeFlags class members, see the Folder.ExcludeFlags Members topic.

Public Static Methods

FromID | Gets the ExcludeFlags value corresponding to the given ID.
FromValue | Gets the ExcludeFlags value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Folder.ExcludeFlags.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.ExcludeFlags.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Folder.ExcludeFlags.

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


Folder.ExcludeFlags.Equals Method

Delegate Equals() to com.starteam.Folder.ExcludeFlags.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.ExcludeFlags.Equals(obj).

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


Folder.ExcludeFlags.FromID Method

Gets the ExcludeFlags value corresponding to the given ID.

public static ExcludeFlags FromID(
Int32 id
);

Parameters

id
A ExcludeFlags ID.

Return Value

The corresponding ExcludeFlags value, or null.

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


Folder.ExcludeFlags.FromValue Method

Gets the ExcludeFlags value corresponding to the given EnumeratedValue.

public static ExcludeFlags FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a ExcludeFlagsProperty.

Return Value

The corresponding ExcludeFlags value, or null.

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


Folder.ExcludeFlags.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.ExcludeFlags.

public override int GetHashCode();

Return Value

com.starteam.Folder.ExcludeFlags.GetHashCode().

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


Folder.ExcludeFlags.ToString Method

Delegate ToString() to com.starteam.Folder.ExcludeFlags.

public override string ToString();

Return Value

com.starteam.Folder.ExcludeFlags.ToString()

See Also

Folder.ExcludeFlags Class | StarTeam Namespace


Folder.Status Class

The status of this folder; a value of the Status Property

For a list of all members of this type, see Folder.Status Members.

System.Object
EnumeratedValue
Folder.Status

public class Folder.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.Status Members | StarTeam Namespace


Folder.Status Members

Folder.Status overview

Public Static Properties

ALL
CURRENT
MISSING
NEW

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Folder.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Folder.Status.

See Also

Folder.Status Class | StarTeam Namespace


Folder.Status Properties

The properties of the Folder.Status class are listed below. For a complete list of Folder.Status class members, see the Folder.Status Members topic.

Public Static Properties

ALL
CURRENT
MISSING
NEW

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Folder.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Folder.Status.ALL Property

public static Status[] ALL {get;}

See Also

Folder.Status Class | StarTeam Namespace


CURRENT Property

Borland StarTeam SDK for .NET

Folder.Status.CURRENT Property

public static Folder.Status CURRENT {get;}

Property Value

The working folder on disk is current w.r.t. the repository

See Also

Folder.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Folder.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

Folder.Status Class | StarTeam Namespace


MISSING Property

Borland StarTeam SDK for .NET

Folder.Status.MISSING Property

public static Folder.Status MISSING {get;}

Property Value

The Folder in the repository (and any File content) is missing on disk

See Also

Folder.Status Class | StarTeam Namespace


NEW Property

Borland StarTeam SDK for .NET

Folder.Status.NEW Property

public static Folder.Status NEW {get;}

Property Value

This folder is new on disk, and has not been added to the repository

See Also

Folder.Status Class | StarTeam Namespace


Folder.Status Methods

The methods of the Folder.Status class are listed below. For a complete list of Folder.Status class members, see the Folder.Status Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Folder.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Folder.Status.

See Also

Folder.Status Class | StarTeam Namespace


Folder.Status.Equals Method

Delegate Equals() to com.starteam.Folder.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.Status.Equals(obj).

See Also

Folder.Status Class | StarTeam Namespace


Folder.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

Folder.Status Class | StarTeam Namespace


Folder.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

Folder.Status Class | StarTeam Namespace


Folder.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.Status.

public override int GetHashCode();

Return Value

com.starteam.Folder.Status.GetHashCode().

See Also

Folder.Status Class | StarTeam Namespace


Folder.Status.ToString Method

Delegate ToString() to com.starteam.Folder.Status.

public override string ToString();

Return Value

com.starteam.Folder.Status.ToString()

See Also

Folder.Status Class | StarTeam Namespace


Folder.Type Class

The Type for Folder

For a list of all members of this type, see Folder.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
Folder.Type

new public class Folder.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.Type Members | StarTeam Namespace


Folder.Type Members

Folder.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Folder.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Folder.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type Properties

The properties of the Folder.Type class are listed below. For a complete list of Folder.Type class members, see the Folder.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Folder.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Folder.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Folder.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Folder.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Folder.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Folder.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Folder.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Folder.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Folder.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Folder.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Folder.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Folder.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Folder.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Folder.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Folder.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Folder.Type.NAME Property

new public static String NAME {get;}

See Also

Folder.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Folder.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Folder.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Folder.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Folder.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Folder.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Folder.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Folder.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Folder.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Folder.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type Methods

The methods of the Folder.Type class are listed below. For a complete list of Folder.Type class members, see the Folder.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Folder.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Folder.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type.Equals Method

Delegate Equals() to com.starteam.Folder.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.Type.Equals(obj).

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.Type.

public override int GetHashCode();

Return Value

com.starteam.Folder.Type.GetHashCode().

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type.ToString Method

Delegate ToString() to com.starteam.Folder.Type.

public override string ToString();

Return Value

com.starteam.Folder.Type.ToString()

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Folder.Type Class | StarTeam Namespace


Folder.Type.ExcludeFlagsProperty Class

The property type of the Exclude Flags property.

For a list of all members of this type, see Folder.Type.ExcludeFlagsProperty Members.

System.Object
Property
EnumeratedProperty
Folder.Type.ExcludeFlagsProperty

public class Folder.Type.ExcludeFlagsProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.Type.ExcludeFlagsProperty Members | StarTeam Namespace


Folder.Type.ExcludeFlagsProperty Members

Folder.Type.ExcludeFlagsProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Folder.Type.ExcludeFlagsProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.ExcludeFlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Folder.Type.ExcludeFlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.ExcludeFlagsProperty Class | StarTeam Namespace


Folder.Type.ExcludeFlagsProperty Properties

The properties of the Folder.Type.ExcludeFlagsProperty class are listed below. For a complete list of Folder.Type.ExcludeFlagsProperty class members, see the Folder.Type.ExcludeFlagsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Folder.Type.ExcludeFlagsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Folder.Type.ExcludeFlagsProperty.NAME Property

public static String NAME {get;}

See Also

Folder.Type.ExcludeFlagsProperty Class | StarTeam Namespace


Folder.Type.ExcludeFlagsProperty Methods

The methods of the Folder.Type.ExcludeFlagsProperty class are listed below. For a complete list of Folder.Type.ExcludeFlagsProperty class members, see the Folder.Type.ExcludeFlagsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Folder.Type.ExcludeFlagsProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.ExcludeFlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Folder.Type.ExcludeFlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.ExcludeFlagsProperty Class | StarTeam Namespace


Folder.Type.ExcludeFlagsProperty.Equals Method

Delegate Equals() to com.starteam.Folder.Type.ExcludeFlagsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.Type.ExcludeFlagsProperty.Equals(obj).

See Also

Folder.Type.ExcludeFlagsProperty Class | StarTeam Namespace


Folder.Type.ExcludeFlagsProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Folder.ExcludeFlags value
);

See Also

Folder.Type.ExcludeFlagsProperty Class | StarTeam Namespace


Folder.Type.ExcludeFlagsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.Type.ExcludeFlagsProperty.

public override int GetHashCode();

Return Value

com.starteam.Folder.Type.ExcludeFlagsProperty.GetHashCode().

See Also

Folder.Type.ExcludeFlagsProperty Class | StarTeam Namespace


Folder.Type.ExcludeFlagsProperty.ToString Method

Delegate ToString() to com.starteam.Folder.Type.ExcludeFlagsProperty.

public override string ToString();

Return Value

com.starteam.Folder.Type.ExcludeFlagsProperty.ToString()

See Also

Folder.Type.ExcludeFlagsProperty Class | StarTeam Namespace


Folder.Type.ExcludeSpecProperty Class

The property type of the Exclude Spec property.

For a list of all members of this type, see Folder.Type.ExcludeSpecProperty Members.

System.Object
Property
VectorProperty
TextProperty
Folder.Type.ExcludeSpecProperty

public class Folder.Type.ExcludeSpecProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.Type.ExcludeSpecProperty Members | StarTeam Namespace


Folder.Type.ExcludeSpecProperty Members

Folder.Type.ExcludeSpecProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Folder.Type.ExcludeSpecProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.ExcludeSpecProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Folder.Type.ExcludeSpecProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.ExcludeSpecProperty Class | StarTeam Namespace


Folder.Type.ExcludeSpecProperty Properties

The properties of the Folder.Type.ExcludeSpecProperty class are listed below. For a complete list of Folder.Type.ExcludeSpecProperty class members, see the Folder.Type.ExcludeSpecProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Folder.Type.ExcludeSpecProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Folder.Type.ExcludeSpecProperty.NAME Property

public static String NAME {get;}

See Also

Folder.Type.ExcludeSpecProperty Class | StarTeam Namespace


Folder.Type.ExcludeSpecProperty Methods

The methods of the Folder.Type.ExcludeSpecProperty class are listed below. For a complete list of Folder.Type.ExcludeSpecProperty class members, see the Folder.Type.ExcludeSpecProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Folder.Type.ExcludeSpecProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.ExcludeSpecProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Folder.Type.ExcludeSpecProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.ExcludeSpecProperty Class | StarTeam Namespace


Folder.Type.ExcludeSpecProperty.Equals Method

Delegate Equals() to com.starteam.Folder.Type.ExcludeSpecProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.Type.ExcludeSpecProperty.Equals(obj).

See Also

Folder.Type.ExcludeSpecProperty Class | StarTeam Namespace


Folder.Type.ExcludeSpecProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.Type.ExcludeSpecProperty.

public override int GetHashCode();

Return Value

com.starteam.Folder.Type.ExcludeSpecProperty.GetHashCode().

See Also

Folder.Type.ExcludeSpecProperty Class | StarTeam Namespace


Folder.Type.ExcludeSpecProperty.ToString Method

Delegate ToString() to com.starteam.Folder.Type.ExcludeSpecProperty.

public override string ToString();

Return Value

com.starteam.Folder.Type.ExcludeSpecProperty.ToString()

See Also

Folder.Type.ExcludeSpecProperty Class | StarTeam Namespace


Folder.Type.ProjectProperty Class

The property type of the Project property.

For a list of all members of this type, see Folder.Type.ProjectProperty Members.

System.Object
Property
ObjectProperty
Folder.Type.ProjectProperty

public class Folder.Type.ProjectProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.Type.ProjectProperty Members | StarTeam Namespace


Folder.Type.ProjectProperty Members

Folder.Type.ProjectProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Folder.Type.ProjectProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.ProjectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Folder.Type.ProjectProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.ProjectProperty Class | StarTeam Namespace


Folder.Type.ProjectProperty Properties

The properties of the Folder.Type.ProjectProperty class are listed below. For a complete list of Folder.Type.ProjectProperty class members, see the Folder.Type.ProjectProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Folder.Type.ProjectProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Folder.Type.ProjectProperty.NAME Property

public static String NAME {get;}

See Also

Folder.Type.ProjectProperty Class | StarTeam Namespace


Folder.Type.ProjectProperty Methods

The methods of the Folder.Type.ProjectProperty class are listed below. For a complete list of Folder.Type.ProjectProperty class members, see the Folder.Type.ProjectProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Folder.Type.ProjectProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.ProjectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Folder.Type.ProjectProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.ProjectProperty Class | StarTeam Namespace


Folder.Type.ProjectProperty.Equals Method

Delegate Equals() to com.starteam.Folder.Type.ProjectProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.Type.ProjectProperty.Equals(obj).

See Also

Folder.Type.ProjectProperty Class | StarTeam Namespace


Folder.Type.ProjectProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.Type.ProjectProperty.

public override int GetHashCode();

Return Value

com.starteam.Folder.Type.ProjectProperty.GetHashCode().

See Also

Folder.Type.ProjectProperty Class | StarTeam Namespace


Folder.Type.ProjectProperty.ToString Method

Delegate ToString() to com.starteam.Folder.Type.ProjectProperty.

public override string ToString();

Return Value

com.starteam.Folder.Type.ProjectProperty.ToString()

See Also

Folder.Type.ProjectProperty Class | StarTeam Namespace


Folder.Type.PropertyCollection Class

The Property Collection of the Folder Type

For a list of all members of this type, see Folder.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Folder.Type.PropertyCollection

new public class Folder.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.Type.PropertyCollection Members | StarTeam Namespace


Folder.Type.PropertyCollection Members

Folder.Type.PropertyCollection overview

Public Instance Properties

BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUDE_FLAGS |
EXCLUDE_SPEC |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FOLDER_PATH |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PROJECT |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WORKING_FOLDER |
WORKING_FOLDER_PATH |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Folder.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Folder.Type.PropertyCollection.

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


Folder.Type.PropertyCollection Properties

The properties of the Folder.Type.PropertyCollection class are listed below. For a complete list of Folder.Type.PropertyCollection class members, see the Folder.Type.PropertyCollection Members topic.

Public Instance Properties

BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUDE_FLAGS |
EXCLUDE_SPEC |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FOLDER_PATH |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PROJECT |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WORKING_FOLDER |
WORKING_FOLDER_PATH |

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


EXCLUDE_FLAGS Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.EXCLUDE_FLAGS Property

public Folder.Type.ExcludeFlagsProperty EXCLUDE_FLAGS {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


EXCLUDE_SPEC Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.EXCLUDE_SPEC Property

public Folder.Type.ExcludeSpecProperty EXCLUDE_SPEC {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_PATH Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.FOLDER_PATH Property

public TrackedObject.Type.FolderPathProperty FOLDER_PATH {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


NEW_REVISION_COMMENT Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.NEW_REVISION_COMMENT Property

public Item.Type.NewRevisionCommentProperty NEW_REVISION_COMMENT {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


PROJECT Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.PROJECT Property

public Folder.Type.ProjectProperty PROJECT {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.STATUS Property

public Folder.Type.StatusProperty STATUS {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


WORKING_FOLDER Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.WORKING_FOLDER Property

public LiveObject.Type.WorkingFolderProperty WORKING_FOLDER {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


WORKING_FOLDER_PATH Property

Borland StarTeam SDK for .NET

Folder.Type.PropertyCollection.WORKING_FOLDER_PATH Property

public Folder.Type.WorkingFolderPathProperty WORKING_FOLDER_PATH {get;}

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


Folder.Type.PropertyCollection Methods

The methods of the Folder.Type.PropertyCollection class are listed below. For a complete list of Folder.Type.PropertyCollection class members, see the Folder.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Folder.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Folder.Type.PropertyCollection.

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


Folder.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Folder.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.Type.PropertyCollection.Equals(obj).

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


Folder.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Folder.Type.PropertyCollection.GetHashCode().

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


Folder.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Folder.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Folder.Type.PropertyCollection.ToString()

See Also

Folder.Type.PropertyCollection Class | StarTeam Namespace


Folder.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see Folder.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
Folder.Type.StatusProperty

public class Folder.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.Type.StatusProperty Members | StarTeam Namespace


Folder.Type.StatusProperty Members

Folder.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Folder.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Folder.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.StatusProperty Class | StarTeam Namespace


Folder.Type.StatusProperty Properties

The properties of the Folder.Type.StatusProperty class are listed below. For a complete list of Folder.Type.StatusProperty class members, see the Folder.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Folder.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Folder.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

Folder.Type.StatusProperty Class | StarTeam Namespace


Folder.Type.StatusProperty Methods

The methods of the Folder.Type.StatusProperty class are listed below. For a complete list of Folder.Type.StatusProperty class members, see the Folder.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Folder.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Folder.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.StatusProperty Class | StarTeam Namespace


Folder.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.Folder.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.Type.StatusProperty.Equals(obj).

See Also

Folder.Type.StatusProperty Class | StarTeam Namespace


Folder.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Folder.Status value
);

See Also

Folder.Type.StatusProperty Class | StarTeam Namespace


Folder.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Folder.Type.StatusProperty.GetHashCode().

See Also

Folder.Type.StatusProperty Class | StarTeam Namespace


Folder.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.Folder.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.Folder.Type.StatusProperty.ToString()

See Also

Folder.Type.StatusProperty Class | StarTeam Namespace


Folder.Type.WorkingFolderPathProperty Class

The property type of the Working Folder Path property.

For a list of all members of this type, see Folder.Type.WorkingFolderPathProperty Members.

System.Object
Property
VectorProperty
TextProperty
Folder.Type.WorkingFolderPathProperty

public class Folder.Type.WorkingFolderPathProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.Type.WorkingFolderPathProperty Members | StarTeam Namespace


Folder.Type.WorkingFolderPathProperty Members

Folder.Type.WorkingFolderPathProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Folder.Type.WorkingFolderPathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.WorkingFolderPathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Folder.Type.WorkingFolderPathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.WorkingFolderPathProperty Class | StarTeam Namespace


Folder.Type.WorkingFolderPathProperty Properties

The properties of the Folder.Type.WorkingFolderPathProperty class are listed below. For a complete list of Folder.Type.WorkingFolderPathProperty class members, see the Folder.Type.WorkingFolderPathProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Folder.Type.WorkingFolderPathProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Folder.Type.WorkingFolderPathProperty.NAME Property

public static String NAME {get;}

See Also

Folder.Type.WorkingFolderPathProperty Class | StarTeam Namespace


Folder.Type.WorkingFolderPathProperty Methods

The methods of the Folder.Type.WorkingFolderPathProperty class are listed below. For a complete list of Folder.Type.WorkingFolderPathProperty class members, see the Folder.Type.WorkingFolderPathProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Folder.Type.WorkingFolderPathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.Type.WorkingFolderPathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Folder.Type.WorkingFolderPathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Folder.Type.WorkingFolderPathProperty Class | StarTeam Namespace


Folder.Type.WorkingFolderPathProperty.Equals Method

Delegate Equals() to com.starteam.Folder.Type.WorkingFolderPathProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.Type.WorkingFolderPathProperty.Equals(obj).

See Also

Folder.Type.WorkingFolderPathProperty Class | StarTeam Namespace


Folder.Type.WorkingFolderPathProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.Type.WorkingFolderPathProperty.

public override int GetHashCode();

Return Value

com.starteam.Folder.Type.WorkingFolderPathProperty.GetHashCode().

See Also

Folder.Type.WorkingFolderPathProperty Class | StarTeam Namespace


Folder.Type.WorkingFolderPathProperty.ToString Method

Delegate ToString() to com.starteam.Folder.Type.WorkingFolderPathProperty.

public override string ToString();

Return Value

com.starteam.Folder.Type.WorkingFolderPathProperty.ToString()

See Also

Folder.Type.WorkingFolderPathProperty Class | StarTeam Namespace


Folder.WebCacheFolder Class

Item accessor for cached SDK Items contained objects are obtained from the artifact cache

For a list of all members of this type, see Folder.WebCacheFolder Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
Folder.WebCacheFolder

public class Folder.WebCacheFolder : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Folder.WebCacheFolder Members | StarTeam Namespace


Folder.WebCacheFolder Members

Folder.WebCacheFolder overview

Public Static Methods

Create Overloaded.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DefaultPathFragment | [read/write] this folder's specified working path.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this folder.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EffectiveExcludeList | [read] the fully resolved exclude list for this folder.
ExcludeFlagsValue | [read/write] the exclude type being used for this folder's exclude list
ExcludeList | [read/write] the portion of the exclude list that this folder contributes.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
FolderHierarchy | [read] The fully-qualified name of this folder.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Folder.WebCacheFolder.
FindSubFolder | Find an immediate sub folder with the given name
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.WebCacheFolder.
GetItems |
GetRights |
GetRootTreeItems |
GetSubFolders |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetRights |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Folder.WebCacheFolder.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder Properties

The properties of the Folder.WebCacheFolder class are listed below. For a complete list of Folder.WebCacheFolder class members, see the Folder.WebCacheFolder Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DefaultPathFragment | [read/write] this folder's specified working path.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this folder.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EffectiveExcludeList | [read] the fully resolved exclude list for this folder.
ExcludeFlagsValue | [read/write] the exclude type being used for this folder's exclude list
ExcludeList | [read/write] the portion of the exclude list that this folder contributes.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
FolderHierarchy | [read] The fully-qualified name of this folder.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


DefaultPathFragment Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.DefaultPathFragment Property

[read/write] this folder's specified working path.

public virtual String DefaultPathFragment {get; set;}

Property Value

this folder's specified working path.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Description Property

[read/write] the description of this folder.

public virtual String Description {get; set;}

Property Value

the description of this folder.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


EffectiveExcludeList Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.EffectiveExcludeList Property

[read] the fully resolved exclude list for this folder.

public virtual String EffectiveExcludeList {get;}

Property Value

the fully resolved exclude list for this folder.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ExcludeFlagsValue Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ExcludeFlagsValue Property

[read/write] the exclude type being used for this folder's exclude list

public virtual Folder.ExcludeFlags ExcludeFlagsValue {get; set;}

Property Value

the exclude type being used for this folder's exclude list

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ExcludeList Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ExcludeList Property

[read/write] the portion of the exclude list that this folder contributes.

public virtual String ExcludeList {get; set;}

Property Value

the portion of the exclude list that this folder contributes.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


FolderHierarchy Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.FolderHierarchy Property

[read] The fully-qualified name of this folder.

public virtual String FolderHierarchy {get;}

Property Value

The fully-qualified name of this folder.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Name Property

new public virtual String Name {get; set;}

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder Methods

The methods of the Folder.WebCacheFolder class are listed below. For a complete list of Folder.WebCacheFolder class members, see the Folder.WebCacheFolder Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Folder.WebCacheFolder.
FindSubFolder | Find an immediate sub folder with the given name
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Folder.WebCacheFolder.
GetItems |
GetRights |
GetRootTreeItems |
GetSubFolders |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetRights |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Folder.WebCacheFolder.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Create Method

Overload List

public static WebCacheFolder Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheFolder Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.Create Overload List


Folder.WebCacheFolder.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.Create Overload List


Folder.WebCacheFolder.Equals Method

Delegate Equals() to com.starteam.Folder.WebCacheFolder.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Folder.WebCacheFolder.Equals(obj).

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.FindSubFolder Method

Find an immediate sub folder with the given name

public virtual WebCacheFolder FindSubFolder(
String name
);

Parameters

name
the name of the subfolder

Return Value

a sub folder with the given name or NULL

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.GetHashCode Method

Delegate GetHashCode() to com.starteam.Folder.WebCacheFolder.

public override int GetHashCode();

Return Value

com.starteam.Folder.WebCacheFolder.GetHashCode().

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.GetItems Method

public virtual WebCacheItem[] GetItems(
Item.Type.WebCacheItemType typ,
Filter.WebCacheFilter fltr,
Boolean dscndnts
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.GetRights Method

public virtual WebCacheACE[] GetRights(
Type.WebCacheType typ
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.GetRootTreeItems Method

public virtual WebCacheTreeItem[] GetRootTreeItems(
TreeItem.Type.WebCacheTreeItemType typ,
Filter.WebCacheFilter fltr
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.GetSubFolders Method

public virtual WebCacheFolder[] GetSubFolders(
Filter.WebCacheFilter fltr
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.GetValue Overload List


Folder.WebCacheFolder.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.GetValue Overload List


Folder.WebCacheFolder.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | WebCacheViewMemberCollection


Folder.WebCacheFolder.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.Lock Overload List | WebCacheViewMemberCollection


Folder.WebCacheFolder.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.Lock Overload List


Folder.WebCacheFolder.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | NAME


Folder.WebCacheFolder.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.MoveTo Overload List


Folder.WebCacheFolder.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.MoveTo Overload List


Folder.WebCacheFolder.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | isFloating | isPinned | unpin


Folder.WebCacheFolder.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | WebCacheViewMemberCollection


Folder.WebCacheFolder.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.SetRights Method

public virtual void SetRights(
Type.WebCacheType typ,
WebCacheACE[] aces
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Folder.WebCacheFolder.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.SetValue Overload List


Folder.WebCacheFolder.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | Folder.WebCacheFolder.SetValue Overload List


Folder.WebCacheFolder.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.ToString Method

Delegate ToString() to com.starteam.Folder.WebCacheFolder.

public override string ToString();

Return Value

com.starteam.Folder.WebCacheFolder.ToString()

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


Folder.WebCacheFolder.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | WebCacheViewMemberCollection


Folder.WebCacheFolder.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | isFloating | isPinned | pinTo


Folder.WebCacheFolder.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Folder.WebCacheFolder Class | StarTeam Namespace | WebCacheViewMemberCollection


Folder.WebCacheFolder.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Folder.WebCacheFolder Class | StarTeam Namespace


FolderListManager Class

Manages a collection of folders created by including and excluding selected folders and their sub-folders. Currently, all folders in the list must belong to the same view. Remembers the set of operations used to create the collection, so that the collection can be refreshed using the latest information from the StarTeam repository.

For a list of all members of this type, see FolderListManager Members.

System.Object
FolderListManager

public class FolderListManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

FolderListManager Members | StarTeam Namespace


FolderListManager Members

FolderListManager overview

Public Instance Constructors

FolderListManager Overloaded. Initializes a new instance of the FolderListManager class.

Public Instance Properties

Folders | [read] The list of folders in the folder list.
IsFullScope | [read] true if all folders are included by definition; false otherwise.
IsRefreshRequired | [read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.
View | [read] the view for this FolderListManager.

Public Instance Methods

Clear | Removes all folders from the folder list.
Discard | Discards cached folder information. It will be re-fetched from the server the next time the folder list is retrieved (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.FolderListManager.
ExcludeFolder | Excludes the given folder from the folder list.
ExcludeFolders | Overloaded. Excludes the given folder, and optionally its sub-folders, from the folder list.
FindFolders | return the (sub-)set of included folders that have the same name no matter what their full path in the folder tree
GetFolderID | Returns the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.
GetHashCode | Delegate GetHashCode() to com.starteam.FolderListManager.
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeFolder | Includes the given folder in the folder list.
IncludeFolders | Overloaded. Includes the given folder, and optionally its sub-folders, in the folder list.
IsFolderIncluded | Determines whether or not the given folder is included in the folder list.
NewFolderEventSource |
NewFolderTreeEventSource |
NewFolderUpdateEventSource |
Refresh | Refreshes the list of folders using the latest information available from the repository. The result is similar to refreshing the folders in the underlying view, emptying the folder list, and re-issuing the sequence of include and exclude calls that were used to construct the original folder list. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
ToString | Delegate ToString() to com.starteam.FolderListManager.

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager Constructor

Constructs a new folder list.

Overload List

Creates a new folder list with the same folders as an existing folder list.

public FolderListManager(FolderListManager);

Constructs a new folder list.

public FolderListManager(View);

Creates a new folder list with the same folders as an existing folder list.

public FolderListManager(View,FolderListManager);

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager Constructor (View)

Constructs a new folder list.

public FolderListManager(
View view
);

Parameters

view
The view from which the folders will be added.

See Also

FolderListManager Class | StarTeam Namespace | FolderListManager Constructor Overload List


FolderListManager Constructor (FolderListManager)

Creates a new folder list with the same folders as an existing folder list.

public FolderListManager(
FolderListManager folderList
);

Parameters

folderList
A folder list to be copied.

See Also

FolderListManager Class | StarTeam Namespace | FolderListManager Constructor Overload List


FolderListManager Constructor (View, FolderListManager)

Creates a new folder list with the same folders as an existing folder list.

public FolderListManager(
View view,
FolderListManager folderList
);

Parameters

view
The view from which the folders will be added.
folderList
A folder list to be copied.

See Also

FolderListManager Class | StarTeam Namespace | FolderListManager Constructor Overload List


FolderListManager Properties

The properties of the FolderListManager class are listed below. For a complete list of FolderListManager class members, see the FolderListManager Members topic.

Public Instance Properties

Folders | [read] The list of folders in the folder list.
IsFullScope | [read] true if all folders are included by definition; false otherwise.
IsRefreshRequired | [read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.
View | [read] the view for this FolderListManager.

See Also

FolderListManager Class | StarTeam Namespace


Folders Property

Borland StarTeam SDK for .NET

FolderListManager.Folders Property

[read] The list of folders in the folder list.

public virtual ViewMemberCollection Folders {get;}

Property Value

The list of folders in the folder list.

See Also

FolderListManager Class | StarTeam Namespace


IsFullScope Property

Borland StarTeam SDK for .NET

FolderListManager.IsFullScope Property

[read] true if all folders are included by definition; false otherwise.

public virtual Boolean IsFullScope {get;}

Property Value

true if all folders are included by definition; false otherwise.

See Also

FolderListManager Class | StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

FolderListManager.IsRefreshRequired Property

[read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.

See Also

FolderListManager Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

FolderListManager.View Property

[read] the view for this FolderListManager.

public virtual View View {get;}

Property Value

the view for this FolderListManager.

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager Methods

The methods of the FolderListManager class are listed below. For a complete list of FolderListManager class members, see the FolderListManager Members topic.

Public Instance Methods

Clear | Removes all folders from the folder list.
Discard | Discards cached folder information. It will be re-fetched from the server the next time the folder list is retrieved (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.FolderListManager.
ExcludeFolder | Excludes the given folder from the folder list.
ExcludeFolders | Overloaded. Excludes the given folder, and optionally its sub-folders, from the folder list.
FindFolders | return the (sub-)set of included folders that have the same name no matter what their full path in the folder tree
GetFolderID | Returns the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.
GetHashCode | Delegate GetHashCode() to com.starteam.FolderListManager.
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeFolder | Includes the given folder in the folder list.
IncludeFolders | Overloaded. Includes the given folder, and optionally its sub-folders, in the folder list.
IsFolderIncluded | Determines whether or not the given folder is included in the folder list.
NewFolderEventSource |
NewFolderTreeEventSource |
NewFolderUpdateEventSource |
Refresh | Refreshes the list of folders using the latest information available from the repository. The result is similar to refreshing the folders in the underlying view, emptying the folder list, and re-issuing the sequence of include and exclude calls that were used to construct the original folder list. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
ToString | Delegate ToString() to com.starteam.FolderListManager.

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.Clear Method

Removes all folders from the folder list.

public virtual void Clear();

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.Discard Method

Discards cached folder information. It will be re-fetched from the server the next time the folder list is retrieved (even when MPX is enabled).

public virtual void Discard();

See Also

FolderListManager Class | StarTeam Namespace | refresh


FolderListManager.Equals Method

Delegate Equals() to com.starteam.FolderListManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.FolderListManager.Equals(obj).

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.ExcludeFolder Method

Excludes the given folder from the folder list.

public virtual void ExcludeFolder(
Folder folder
);

Parameters

folder
A folder to be excluded from the folder list.

See Also

FolderListManager Class | StarTeam Namespace | excludeFolders | includeFolder | getFolders | isFolderIncluded | Folder


ExcludeFolders Method

Borland StarTeam SDK for .NET

FolderListManager.ExcludeFolders Method

Overload List

public virtual void ExcludeFolders(Folder,Filter.Context,Int32);

Excludes the given folder, and optionally its sub-folders, from the folder list.

public virtual void ExcludeFolders(Folder,Int32);

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.ExcludeFolders Method (Folder, Filter#Context, Int32)

public virtual void ExcludeFolders(
Folder folder,
Filter.Context context,
Int32 depth
);

See Also

FolderListManager Class | StarTeam Namespace | FolderListManager.ExcludeFolders Overload List


FolderListManager.ExcludeFolders Method (Folder, Int32)

Excludes the given folder, and optionally its sub-folders, from the folder list.

public virtual void ExcludeFolders(
Folder folder,
Int32 depth
);

Parameters

folder
A folder to be excluded from the folder list.
depth
Determines the depth to which sub-folders are also excluded. If depth is 0, only the folder itself is excluded. If depth is 1, only the immediate sub-folders are excluded; if depth is 2, two levels are excluded; and so on. If depth is -1, all sub-folders at any depth are excluded.

See Also

FolderListManager Class | StarTeam Namespace | FolderListManager.ExcludeFolders Overload List | excludeFolder | includeFolder | getFolders | isFolderIncluded | Folder


FolderListManager.FindFolders Method

return the (sub-)set of included folders that have the same name no matter what their full path in the folder tree

public virtual Folder[] FindFolders(
String name,
Boolean ignoreCase
);

Parameters

name
the name of the folder
ignoreCase
true to do a case insensitive comparison

Return Value

the (sub-)set of folders with a given name but different paths

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.GetFolderID Method

Returns the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.

public virtual int GetFolderID(
Folder folder
);

Parameters

folder
The folder whose ItemID is returned.

Return Value

the ItemID for a folder; if we're managing not-in-view folders, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view folder object until it's been added to the repository.

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.FolderListManager.

public override int GetHashCode();

Return Value

com.starteam.FolderListManager.GetHashCode().

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.IncludeFolder Method

Includes the given folder in the folder list.

public virtual void IncludeFolder(
Folder folder
);

Parameters

folder
A folder to be included in the folder list.

See Also

FolderListManager Class | StarTeam Namespace | includeFolders | excludeFolder | getFolders | isFolderIncluded | Folder


IncludeFolders Method

Borland StarTeam SDK for .NET

FolderListManager.IncludeFolders Method

Overload List

public virtual void IncludeFolders(Folder,Filter.Context,Int32);

Includes the given folder, and optionally its sub-folders, in the folder list.

public virtual void IncludeFolders(Folder,Int32);

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.IncludeFolders Method (Folder, Filter#Context, Int32)

public virtual void IncludeFolders(
Folder folder,
Filter.Context context,
Int32 depth
);

See Also

FolderListManager Class | StarTeam Namespace | FolderListManager.IncludeFolders Overload List


FolderListManager.IncludeFolders Method (Folder, Int32)

Includes the given folder, and optionally its sub-folders, in the folder list.

public virtual void IncludeFolders(
Folder folder,
Int32 depth
);

Parameters

folder
A folder to be included in the folder list.
depth
Determines the depth to which sub-folders are also included. If depth is 0, only the folder itself is included. If depth is 1, only the immediate sub-folders are included; if depth is 2, two levels are included; and so on. If depth is -1, all sub-folders at any depth are included.

See Also

FolderListManager Class | StarTeam Namespace | FolderListManager.IncludeFolders Overload List | includeFolder | excludeFolder | getFolders | isFolderIncluded | Folder


FolderListManager.IsFolderIncluded Method

Determines whether or not the given folder is included in the folder list.

public virtual bool IsFolderIncluded(
Folder folder
);

Parameters

folder
The folder to be tested.

Return Value

true if the folder is included, and false otherwise.

See Also

FolderListManager Class | StarTeam Namespace | includeFolder | excludeFolder | getFolders | Folder


FolderListManager.NewFolderEventSource Method

public FolderEventSource NewFolderEventSource();

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.NewFolderTreeEventSource Method

public FolderTreeEventSource NewFolderTreeEventSource();

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource();

See Also

FolderListManager Class | StarTeam Namespace


FolderListManager.Refresh Method

Refreshes the list of folders using the latest information available from the repository. The result is similar to refreshing the folders in the underlying view, emptying the folder list, and re-issuing the sequence of include and exclude calls that were used to construct the original folder list. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

FolderListManager Class | StarTeam Namespace | isRefreshRequired | discard | enableMPX | refreshFolders


FolderListManager.ToString Method

Delegate ToString() to com.starteam.FolderListManager.

public override string ToString();

Return Value

com.starteam.FolderListManager.ToString()

See Also

FolderListManager Class | StarTeam Namespace


Group Class

This class represents a full StarTeam Group. New groups can be added to a StarTeam Server and existing groups can be modified through this class. All users can obtain Group information but only users with the appropriate permissions can access GroupAccount information.

For a list of all members of this type, see Group Members.

System.Object
TypedResource
LiveObject
TrackedObject
Principal
Group

public class Group : Principal

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group Members | StarTeam Namespace


Group Members

Group overview

Public Static Properties

ADMINISTRATORS
ALL_USERS

Public Instance Constructors

Group Constructor Creates a new StarTeam Group object. It is initially not a subgroup of any existing group and one should call setParent to change this. The name is initially the empty string. To create this group in the StarTeam server you must call update.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CanRemove | [read] true if this Group and all of its descendants can be deleted without leaving any users with no group membership.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
Description | [read/write] the group description.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
FullName | [read] A qualified name for the group, showing both the group and its parents.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsAdministrator | [read] true if this is the 'Administrators' Group.
IsBuiltin | [read] true if this is a builtin Group.
IsDeleted (inherited from Principal) | [read] true if the Principal has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsRoot | [read] true if this is a top-level group with no parent group.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name (inherited from Principal) | [read/write] the name of this principal
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Parent | [read/write] the parent for this group.
Permissions | [read] the permissions for this group.
PresentationID | [read] the unique integer identifier for this group.
Properties | [read] the properties for the Group Type
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
SubGroups | [read] the sub Groups of this Group
TypeValue | [read/write] type (Team, User, Unknown) of this Group
Users | [read] the User objects directly belonging to this group.

Public Instance Methods

AddPermission | Add this permission to the set of permissions for this Group.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this GroupAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FetchMembers | Returns the users that belong to this group. The information is retrieved directly from the StarTeam Server, and is not cached. Requires admin privileges on 5.2 and earlier servers.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermission | Returns true if this Group has the specified permission.
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares two Group objects, and their member User IDs. Requires admin privileges on 5.2 and earlier servers. The parent Servers are not compared.
IsMember | Return true if the specified user can be considered a member of this Group. A user is defined to be a member of a Group if it is directly a member of the Group or recursively of any sub-Group of this Group., i.e. membership is implied
Remove (inherited from Principal) | Removes this principal from the StarTeam server, plus any direct or indirect members of this principal.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemovePermission | Removes the specified permission from this Group.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update (inherited from Principal) | Persistently saves the changes to this principal in the server. If the principal is new it will be added, otherwise it will be modified.

See Also

Group Class | StarTeam Namespace


Group Constructor

Creates a new StarTeam Group object. It is initially not a subgroup of any existing group and one should call setParent to change this. The name is initially the empty string. To create this group in the StarTeam server you must call update.

public Group(
Server server
);

Parameters

server
the StarTeam Server to which this group belongs.

See Also

Group Class | StarTeam Namespace


Group Properties

The properties of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Static Properties

ADMINISTRATORS
ALL_USERS

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CanRemove | [read] true if this Group and all of its descendants can be deleted without leaving any users with no group membership.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
Description | [read/write] the group description.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
FullName | [read] A qualified name for the group, showing both the group and its parents.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsAdministrator | [read] true if this is the 'Administrators' Group.
IsBuiltin | [read] true if this is a builtin Group.
IsDeleted (inherited from Principal) | [read] true if the Principal has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsRoot | [read] true if this is a top-level group with no parent group.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name (inherited from Principal) | [read/write] the name of this principal
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Parent | [read/write] the parent for this group.
Permissions | [read] the permissions for this group.
PresentationID | [read] the unique integer identifier for this group.
Properties | [read] the properties for the Group Type
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
SubGroups | [read] the sub Groups of this Group
TypeValue | [read/write] type (Team, User, Unknown) of this Group
Users | [read] the User objects directly belonging to this group.

See Also

Group Class | StarTeam Namespace


ADMINISTRATORS Property

Borland StarTeam SDK for .NET

Group.ADMINISTRATORS Property

public static Group ADMINISTRATORS {get;}

Property Value

The built-in "Administrators" Group.

See Also

Group Class | StarTeam Namespace


ALL_USERS Property

Borland StarTeam SDK for .NET

Group.ALL_USERS Property

public static Group ALL_USERS {get;}

Property Value

The built-in "All Users" group.

See Also

Group Class | StarTeam Namespace


CanRemove Property

Borland StarTeam SDK for .NET

Group.CanRemove Property

[read] true if this Group and all of its descendants can be deleted without leaving any users with no group membership.

public virtual Boolean CanRemove {get;}

Property Value

true if this Group and all of its descendants can be deleted without leaving any users with no group membership.

See Also

Group Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Group.Description Property

[read/write] the group description.

public virtual String Description {get; set;}

Property Value

the group description.

See Also

Group Class | StarTeam Namespace


FullName Property

Borland StarTeam SDK for .NET

Group.FullName Property

[read] A qualified name for the group, showing both the group and its parents.

public virtual String FullName {get;}

Property Value

A qualified name for the group, showing both the group and its parents.

See Also

Group Class | StarTeam Namespace


IsAdministrator Property

Borland StarTeam SDK for .NET

Group.IsAdministrator Property

[read] true if this is the 'Administrators' Group.

public virtual Boolean IsAdministrator {get;}

Property Value

true if this is the 'Administrators' Group.

See Also

Group Class | StarTeam Namespace


IsBuiltin Property

Borland StarTeam SDK for .NET

Group.IsBuiltin Property

[read] true if this is a builtin Group.

public virtual Boolean IsBuiltin {get;}

Property Value

true if this is a builtin Group.

See Also

Group Class | StarTeam Namespace


IsRoot Property

Borland StarTeam SDK for .NET

Group.IsRoot Property

[read] true if this is a top-level group with no parent group.

public virtual Boolean IsRoot {get;}

Property Value

true if this is a top-level group with no parent group.

See Also

Group Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

Group.Parent Property

[read/write] the parent for this group.

public virtual Group Parent {get; set;}

Property Value

the parent for this group.

See Also

Group Class | StarTeam Namespace


Permissions Property

Borland StarTeam SDK for .NET

Group.Permissions Property

[read] the permissions for this group.

public virtual PermissionCollection Permissions {get;}

Property Value

the permissions for this group.

See Also

Group Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Group.PresentationID Property

[read] the unique integer identifier for this group.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this group.

See Also

Group Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Group.Properties Property

[read] the properties for the Group Type

public virtual Group.Type.PropertyCollection Properties {get;}

Property Value

the properties for the Group Type

See Also

Group Class | StarTeam Namespace


SubGroups Property

Borland StarTeam SDK for .NET

Group.SubGroups Property

[read] the sub Groups of this Group

public virtual Group[] SubGroups {get;}

Property Value

the sub Groups of this Group

See Also

Group Class | StarTeam Namespace


TypeValue Property

Borland StarTeam SDK for .NET

Group.TypeValue Property

[read/write] type (Team, User, Unknown) of this Group

public virtual Group.GroupType TypeValue {get; set;}

Property Value

type (Team, User, Unknown) of this Group

See Also

Group Class | StarTeam Namespace


Users Property

Borland StarTeam SDK for .NET

Group.Users Property

[read] the User objects directly belonging to this group.

public virtual User[] Users {get;}

Property Value

the User objects directly belonging to this group.

See Also

Group Class | StarTeam Namespace


Group Methods

The methods of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Instance Methods

AddPermission | Add this permission to the set of permissions for this Group.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this GroupAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FetchMembers | Returns the users that belong to this group. The information is retrieved directly from the StarTeam Server, and is not cached. Requires admin privileges on 5.2 and earlier servers.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermission | Returns true if this Group has the specified permission.
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares two Group objects, and their member User IDs. Requires admin privileges on 5.2 and earlier servers. The parent Servers are not compared.
IsMember | Return true if the specified user can be considered a member of this Group. A user is defined to be a member of a Group if it is directly a member of the Group or recursively of any sub-Group of this Group., i.e. membership is implied
Remove (inherited from Principal) | Removes this principal from the StarTeam server, plus any direct or indirect members of this principal.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemovePermission | Removes the specified permission from this Group.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update (inherited from Principal) | Persistently saves the changes to this principal in the server. If the principal is new it will be added, otherwise it will be modified.

See Also

Group Class | StarTeam Namespace


Group.AddPermission Method

Add this permission to the set of permissions for this Group.

public virtual void AddPermission(
Permission permission
);

Parameters

permission
the permission to add

See Also

Group Class | StarTeam Namespace | Permission


Group.Copy Method

Creates a copy of this GroupAccount object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().

public virtual Group Copy();

Return Value

A new copy of this GroupAccount object.

See Also

Group Class | StarTeam Namespace | isEqualTo


Group.FetchMembers Method

Returns the users that belong to this group. The information is retrieved directly from the StarTeam Server, and is not cached. Requires admin privileges on 5.2 and earlier servers.

public virtual User[] FetchMembers(
Boolean bDescendants
);

Parameters

bDescendants
true = plus all descendants of group; false = this group only

Return Value

the Users who belong to this group.

See Also

Group Class | StarTeam Namespace


Group.HasPermission Method

Returns true if this Group has the specified permission.

public virtual bool HasPermission(
Permission permission
);

Parameters

permission
the permission in question

Return Value

true if this Group has the specified permission.

See Also

Group Class | StarTeam Namespace | Permission


Group.IsEqualTo Method

Compares two Group objects, and their member User IDs. Requires admin privileges on 5.2 and earlier servers.

The parent Servers are not compared.

public virtual bool IsEqualTo(
Group group
);

Parameters

group
The Group to be compared with this one.

Return Value

true if no differences were found.

See Also

Group Class | StarTeam Namespace | copy


Group.IsMember Method

Return true if the specified user can be considered a member of this Group. A user is defined to be a member of a Group if it is directly a member of the Group or recursively of any sub-Group of this Group., i.e. membership is implied

public virtual bool IsMember(
User user
);

Parameters

user
the user being checked for group membership

Return Value

true if the specified user ID is a member of this or any sub group

See Also

Group Class | StarTeam Namespace


Group.RemovePermission Method

Removes the specified permission from this Group.

public virtual void RemovePermission(
Permission permission
);

Parameters

permission
the permission to remove

See Also

Group Class | StarTeam Namespace | Permission


Group.GroupType Class

Defines the Types of a Group This property is new to 12.0+ servers

For a list of all members of this type, see Group.GroupType Members.

System.Object
EnumeratedValue
Group.GroupType

public class Group.GroupType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.GroupType Members | StarTeam Namespace


Group.GroupType Members

Group.GroupType overview

Public Static Properties

ALL
TEAM
UNKNOWN
USER

Public Static Methods

FromID | returns a Type from an integer ID
FromValue | Gets the Type value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Group.GroupType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Group.GroupType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Group.GroupType.

See Also

Group.GroupType Class | StarTeam Namespace


Group.GroupType Properties

The properties of the Group.GroupType class are listed below. For a complete list of Group.GroupType class members, see the Group.GroupType Members topic.

Public Static Properties

ALL
TEAM
UNKNOWN
USER

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Group.GroupType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Group.GroupType.ALL Property

public static GroupType[] ALL {get;}

See Also

Group.GroupType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Group.GroupType.ID Property

[read] The ID of this Type value.

public virtual Int32 ID {get;}

Property Value

The ID of this Type value.

See Also

Group.GroupType Class | StarTeam Namespace


TEAM Property

Borland StarTeam SDK for .NET

Group.GroupType.TEAM Property

public static Group.GroupType TEAM {get;}

Property Value

Defines a "Team" Group

See Also

Group.GroupType Class | StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

Group.GroupType.UNKNOWN Property

public static Group.GroupType UNKNOWN {get;}

Property Value

Defines an "Unknown" Group

See Also

Group.GroupType Class | StarTeam Namespace


USER Property

Borland StarTeam SDK for .NET

Group.GroupType.USER Property

public static Group.GroupType USER {get;}

Property Value

Defines a "User" Group

See Also

Group.GroupType Class | StarTeam Namespace


Group.GroupType Methods

The methods of the Group.GroupType class are listed below. For a complete list of Group.GroupType class members, see the Group.GroupType Members topic.

Public Static Methods

FromID | returns a Type from an integer ID
FromValue | Gets the Type value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Group.GroupType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Group.GroupType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Group.GroupType.

See Also

Group.GroupType Class | StarTeam Namespace


Group.GroupType.Equals Method

Delegate Equals() to com.starteam.Group.GroupType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.GroupType.Equals(obj).

See Also

Group.GroupType Class | StarTeam Namespace


Group.GroupType.FromID Method

returns a Type from an integer ID

public static GroupType FromID(
Int32 id
);

Parameters

id
the id of the Type to look for

Return Value

the equivalent Type

See Also

Group.GroupType Class | StarTeam Namespace


Group.GroupType.FromValue Method

Gets the Type value corresponding to the given EnumeratedValue.

public static GroupType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a Type.

Return Value

The corresponding Type value, or null.

See Also

Group.GroupType Class | StarTeam Namespace


Group.GroupType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.GroupType.

public override int GetHashCode();

Return Value

com.starteam.Group.GroupType.GetHashCode().

See Also

Group.GroupType Class | StarTeam Namespace


Group.GroupType.ToString Method

Delegate ToString() to com.starteam.Group.GroupType.

public override string ToString();

Return Value

com.starteam.Group.GroupType.ToString()

See Also

Group.GroupType Class | StarTeam Namespace


Group.Type Class

The Type of Group.

For a list of all members of this type, see Group.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
Principal.Type
Group.Type

new public class Group.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.Type Members | StarTeam Namespace


Group.Type Members

Group.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Group.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Group.Type.

See Also

Group.Type Class | StarTeam Namespace


Group.Type Properties

The properties of the Group.Type class are listed below. For a complete list of Group.Type class members, see the Group.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

Group.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Group.Type.NAME Property

public static String NAME {get;}

See Also

Group.Type Class | StarTeam Namespace


Group.Type Methods

The methods of the Group.Type class are listed below. For a complete list of Group.Type class members, see the Group.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Group.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Group.Type.

See Also

Group.Type Class | StarTeam Namespace


Group.Type.Equals Method

Delegate Equals() to com.starteam.Group.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.Type.Equals(obj).

See Also

Group.Type Class | StarTeam Namespace


Group.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.Type.

public override int GetHashCode();

Return Value

com.starteam.Group.Type.GetHashCode().

See Also

Group.Type Class | StarTeam Namespace


Group.Type.ToString Method

Delegate ToString() to com.starteam.Group.Type.

public override string ToString();

Return Value

com.starteam.Group.Type.ToString()

See Also

Group.Type Class | StarTeam Namespace


Group.Type.DescriptionProperty Class

The property type of the Description property.

For a list of all members of this type, see Group.Type.DescriptionProperty Members.

System.Object
Property
VectorProperty
TextProperty
Group.Type.DescriptionProperty

public class Group.Type.DescriptionProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.Type.DescriptionProperty Members | StarTeam Namespace


Group.Type.DescriptionProperty Members

Group.Type.DescriptionProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.DescriptionProperty Class | StarTeam Namespace


Group.Type.DescriptionProperty Properties

The properties of the Group.Type.DescriptionProperty class are listed below. For a complete list of Group.Type.DescriptionProperty class members, see the Group.Type.DescriptionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Group.Type.DescriptionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Group.Type.DescriptionProperty.NAME Property

public static String NAME {get;}

See Also

Group.Type.DescriptionProperty Class | StarTeam Namespace


Group.Type.DescriptionProperty Methods

The methods of the Group.Type.DescriptionProperty class are listed below. For a complete list of Group.Type.DescriptionProperty class members, see the Group.Type.DescriptionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.DescriptionProperty Class | StarTeam Namespace


Group.Type.DescriptionProperty.Equals Method

Delegate Equals() to com.starteam.Group.Type.DescriptionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.Type.DescriptionProperty.Equals(obj).

See Also

Group.Type.DescriptionProperty Class | StarTeam Namespace


Group.Type.DescriptionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.Type.DescriptionProperty.

public override int GetHashCode();

Return Value

com.starteam.Group.Type.DescriptionProperty.GetHashCode().

See Also

Group.Type.DescriptionProperty Class | StarTeam Namespace


Group.Type.DescriptionProperty.ToString Method

Delegate ToString() to com.starteam.Group.Type.DescriptionProperty.

public override string ToString();

Return Value

com.starteam.Group.Type.DescriptionProperty.ToString()

See Also

Group.Type.DescriptionProperty Class | StarTeam Namespace


Group.Type.NameProperty Class

The property type of the Name property.

For a list of all members of this type, see Group.Type.NameProperty Members.

System.Object
Property
VectorProperty
TextProperty
Group.Type.NameProperty

public class Group.Type.NameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.Type.NameProperty Members | StarTeam Namespace


Group.Type.NameProperty Members

Group.Type.NameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.NameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.NameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.NameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.NameProperty Class | StarTeam Namespace


Group.Type.NameProperty Properties

The properties of the Group.Type.NameProperty class are listed below. For a complete list of Group.Type.NameProperty class members, see the Group.Type.NameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Group.Type.NameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Group.Type.NameProperty.NAME Property

public static String NAME {get;}

See Also

Group.Type.NameProperty Class | StarTeam Namespace


Group.Type.NameProperty Methods

The methods of the Group.Type.NameProperty class are listed below. For a complete list of Group.Type.NameProperty class members, see the Group.Type.NameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.NameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.NameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.NameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.NameProperty Class | StarTeam Namespace


Group.Type.NameProperty.Equals Method

Delegate Equals() to com.starteam.Group.Type.NameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.Type.NameProperty.Equals(obj).

See Also

Group.Type.NameProperty Class | StarTeam Namespace


Group.Type.NameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.Type.NameProperty.

public override int GetHashCode();

Return Value

com.starteam.Group.Type.NameProperty.GetHashCode().

See Also

Group.Type.NameProperty Class | StarTeam Namespace


Group.Type.NameProperty.ToString Method

Delegate ToString() to com.starteam.Group.Type.NameProperty.

public override string ToString();

Return Value

com.starteam.Group.Type.NameProperty.ToString()

See Also

Group.Type.NameProperty Class | StarTeam Namespace


Group.Type.ParentProperty Class

The property type of the Parent property.

For a list of all members of this type, see Group.Type.ParentProperty Members.

System.Object
Property
ObjectProperty
Group.Type.ParentProperty

public class Group.Type.ParentProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.Type.ParentProperty Members | StarTeam Namespace


Group.Type.ParentProperty Members

Group.Type.ParentProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.ParentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.ParentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.ParentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.ParentProperty Class | StarTeam Namespace


Group.Type.ParentProperty Properties

The properties of the Group.Type.ParentProperty class are listed below. For a complete list of Group.Type.ParentProperty class members, see the Group.Type.ParentProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Group.Type.ParentProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Group.Type.ParentProperty.NAME Property

public static String NAME {get;}

See Also

Group.Type.ParentProperty Class | StarTeam Namespace


Group.Type.ParentProperty Methods

The methods of the Group.Type.ParentProperty class are listed below. For a complete list of Group.Type.ParentProperty class members, see the Group.Type.ParentProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.ParentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.ParentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.ParentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.ParentProperty Class | StarTeam Namespace


Group.Type.ParentProperty.Equals Method

Delegate Equals() to com.starteam.Group.Type.ParentProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.Type.ParentProperty.Equals(obj).

See Also

Group.Type.ParentProperty Class | StarTeam Namespace


Group.Type.ParentProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.Type.ParentProperty.

public override int GetHashCode();

Return Value

com.starteam.Group.Type.ParentProperty.GetHashCode().

See Also

Group.Type.ParentProperty Class | StarTeam Namespace


Group.Type.ParentProperty.ToString Method

Delegate ToString() to com.starteam.Group.Type.ParentProperty.

public override string ToString();

Return Value

com.starteam.Group.Type.ParentProperty.ToString()

See Also

Group.Type.ParentProperty Class | StarTeam Namespace


Group.Type.PrivilegeMaskProperty Class

The property type of the Privilege Mask property.

For a list of all members of this type, see Group.Type.PrivilegeMaskProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Group.Type.PrivilegeMaskProperty

public class Group.Type.PrivilegeMaskProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.Type.PrivilegeMaskProperty Members | StarTeam Namespace


Group.Type.PrivilegeMaskProperty Members

Group.Type.PrivilegeMaskProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.PrivilegeMaskProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.PrivilegeMaskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.PrivilegeMaskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.PrivilegeMaskProperty Class | StarTeam Namespace


Group.Type.PrivilegeMaskProperty Properties

The properties of the Group.Type.PrivilegeMaskProperty class are listed below. For a complete list of Group.Type.PrivilegeMaskProperty class members, see the Group.Type.PrivilegeMaskProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Group.Type.PrivilegeMaskProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Group.Type.PrivilegeMaskProperty.NAME Property

public static String NAME {get;}

See Also

Group.Type.PrivilegeMaskProperty Class | StarTeam Namespace


Group.Type.PrivilegeMaskProperty Methods

The methods of the Group.Type.PrivilegeMaskProperty class are listed below. For a complete list of Group.Type.PrivilegeMaskProperty class members, see the Group.Type.PrivilegeMaskProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.PrivilegeMaskProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.PrivilegeMaskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.PrivilegeMaskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.PrivilegeMaskProperty Class | StarTeam Namespace


Group.Type.PrivilegeMaskProperty.Equals Method

Delegate Equals() to com.starteam.Group.Type.PrivilegeMaskProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.Type.PrivilegeMaskProperty.Equals(obj).

See Also

Group.Type.PrivilegeMaskProperty Class | StarTeam Namespace


Group.Type.PrivilegeMaskProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.Type.PrivilegeMaskProperty.

public override int GetHashCode();

Return Value

com.starteam.Group.Type.PrivilegeMaskProperty.GetHashCode().

See Also

Group.Type.PrivilegeMaskProperty Class | StarTeam Namespace


Group.Type.PrivilegeMaskProperty.ToString Method

Delegate ToString() to com.starteam.Group.Type.PrivilegeMaskProperty.

public override string ToString();

Return Value

com.starteam.Group.Type.PrivilegeMaskProperty.ToString()

See Also

Group.Type.PrivilegeMaskProperty Class | StarTeam Namespace


Group.Type.PropertyCollection Class

The property collection for the Group Type

For a list of all members of this type, see Group.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
Group.Type.PropertyCollection

public class Group.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.Type.PropertyCollection Members | StarTeam Namespace


Group.Type.PropertyCollection Members

Group.Type.PropertyCollection overview

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
FLAGS |
GLOBAL_ID |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MODIFIED_BY |
MODIFIED_TIME |
NAME |
PARENT |
PRIVILEGE_MASK |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TENANT |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
TYPE |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Group.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Group.Type.PropertyCollection.

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


Group.Type.PropertyCollection Properties

The properties of the Group.Type.PropertyCollection class are listed below. For a complete list of Group.Type.PropertyCollection class members, see the Group.Type.PropertyCollection Members topic.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
FLAGS |
GLOBAL_ID |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MODIFIED_BY |
MODIFIED_TIME |
NAME |
PARENT |
PRIVILEGE_MASK |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TENANT |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
TYPE |

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.DESCRIPTION Property

public Group.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


FLAGS Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.FLAGS Property

public LiveObject.Type.FlagsProperty FLAGS {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.NAME Property

public Group.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


PARENT Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.PARENT Property

public Group.Type.ParentProperty PARENT {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


PRIVILEGE_MASK Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.PRIVILEGE_MASK Property

public Group.Type.PrivilegeMaskProperty PRIVILEGE_MASK {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


TENANT Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.TENANT Property

public Group.Type.TenantProperty TENANT {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


TYPE Property

Borland StarTeam SDK for .NET

Group.Type.PropertyCollection.TYPE Property

public Group.Type.TypeProperty TYPE {get;}

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


Group.Type.PropertyCollection Methods

The methods of the Group.Type.PropertyCollection class are listed below. For a complete list of Group.Type.PropertyCollection class members, see the Group.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Group.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Group.Type.PropertyCollection.

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


Group.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Group.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.Type.PropertyCollection.Equals(obj).

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


Group.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Group.Type.PropertyCollection.GetHashCode().

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


Group.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Group.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Group.Type.PropertyCollection.ToString()

See Also

Group.Type.PropertyCollection Class | StarTeam Namespace


Group.Type.TenantProperty Class

For a list of all members of this type, see Group.Type.TenantProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Group.Type.TenantProperty

public class Group.Type.TenantProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.Type.TenantProperty Members | StarTeam Namespace


Group.Type.TenantProperty Members

Group.Type.TenantProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.TenantProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.TenantProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.TenantProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.TenantProperty Class | StarTeam Namespace


Group.Type.TenantProperty Properties

The properties of the Group.Type.TenantProperty class are listed below. For a complete list of Group.Type.TenantProperty class members, see the Group.Type.TenantProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Group.Type.TenantProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Group.Type.TenantProperty.NAME Property

public static String NAME {get;}

See Also

Group.Type.TenantProperty Class | StarTeam Namespace


Group.Type.TenantProperty Methods

The methods of the Group.Type.TenantProperty class are listed below. For a complete list of Group.Type.TenantProperty class members, see the Group.Type.TenantProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Group.Type.TenantProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.TenantProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Group.Type.TenantProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.TenantProperty Class | StarTeam Namespace


Group.Type.TenantProperty.Equals Method

Delegate Equals() to com.starteam.Group.Type.TenantProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.Type.TenantProperty.Equals(obj).

See Also

Group.Type.TenantProperty Class | StarTeam Namespace


Group.Type.TenantProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.Type.TenantProperty.

public override int GetHashCode();

Return Value

com.starteam.Group.Type.TenantProperty.GetHashCode().

See Also

Group.Type.TenantProperty Class | StarTeam Namespace


Group.Type.TenantProperty.ToString Method

Delegate ToString() to com.starteam.Group.Type.TenantProperty.

public override string ToString();

Return Value

com.starteam.Group.Type.TenantProperty.ToString()

See Also

Group.Type.TenantProperty Class | StarTeam Namespace


Group.Type.TypeProperty Class

The property type of the Type property.

For a list of all members of this type, see Group.Type.TypeProperty Members.

System.Object
Property
EnumeratedProperty
Group.Type.TypeProperty

public class Group.Type.TypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.Type.TypeProperty Members | StarTeam Namespace


Group.Type.TypeProperty Members

Group.Type.TypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Group.Type.TypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.TypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Group.Type.TypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.TypeProperty Class | StarTeam Namespace


Group.Type.TypeProperty Properties

The properties of the Group.Type.TypeProperty class are listed below. For a complete list of Group.Type.TypeProperty class members, see the Group.Type.TypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Group.Type.TypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Group.Type.TypeProperty.NAME Property

public static String NAME {get;}

See Also

Group.Type.TypeProperty Class | StarTeam Namespace


Group.Type.TypeProperty Methods

The methods of the Group.Type.TypeProperty class are listed below. For a complete list of Group.Type.TypeProperty class members, see the Group.Type.TypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Group.Type.TypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Group.Type.TypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Group.Type.TypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Group.Type.TypeProperty Class | StarTeam Namespace


Group.Type.TypeProperty.Equals Method

Delegate Equals() to com.starteam.Group.Type.TypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.Type.TypeProperty.Equals(obj).

See Also

Group.Type.TypeProperty Class | StarTeam Namespace


Group.Type.TypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Group.Type value
);

See Also

Group.Type.TypeProperty Class | StarTeam Namespace


Group.Type.TypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.Type.TypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Group.Type.TypeProperty.GetHashCode().

See Also

Group.Type.TypeProperty Class | StarTeam Namespace


Group.Type.TypeProperty.ToString Method

Delegate ToString() to com.starteam.Group.Type.TypeProperty.

public override string ToString();

Return Value

com.starteam.Group.Type.TypeProperty.ToString()

See Also

Group.Type.TypeProperty Class | StarTeam Namespace


Group.WebCacheGroup Class

User accessor for cached SDK Users contained objects are obtained from the artifact cache

For a list of all members of this type, see Group.WebCacheGroup Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
Principal.WebCachePrincipal
Group.WebCacheGroup

public class Group.WebCacheGroup : WebCachePrincipal

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Group.WebCacheGroup Members | StarTeam Namespace


Group.WebCacheGroup Members

Group.WebCacheGroup overview

Public Static Methods

Create

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
Description | [read/write] the group description.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
FullName | [read] A qualified name for the group, showing both the group and its parents.
ID | [read] the ID of the underlying object
IsAdministrator | [read] true if this is the 'Administrators' Group.
IsBuiltin | [read] true if this is a builtin Group.
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
IsRoot | [read] true if this is a top-level group with no parent group.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Parent | [read/write] the parent for this group.
Permissions | [read] the permissions for this group.
PresentationID | [read] the unique integer identifier for this group.
Server | [read] the Server for this cached object
SubGroups | [read] the sub Groups of this Group
TypeValue | [read/write] type (Team, User, Unknown) of this Group
Users | [read] the User objects directly belonging to this group.

Public Instance Methods

AddPermission | Add this permission to the set of permissions for this Group.
AddTo |
CanAccessContainerForReading |
CanAccessForReading |
CanCreateArtifactType |
Equals | Delegate Equals() to com.starteam.Group.WebCacheGroup.
FindSubGroup | Returns a sub group of this group, identified by name
FindUser | Returns a user (who is a) member of this group, identified by logon name
GetHashCode | Delegate GetHashCode() to com.starteam.Group.WebCacheGroup.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasContainerRight | Overloaded.
HasContainerRights |
HasPermission | Returns true if this Group has the specified permission.
HasRight |
HasRights |
HasValue |
IsMember |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemovePermission | Removes the specified permission from this Group.
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Group.WebCacheGroup.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup Properties

The properties of the Group.WebCacheGroup class are listed below. For a complete list of Group.WebCacheGroup class members, see the Group.WebCacheGroup Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
Description | [read/write] the group description.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
FullName | [read] A qualified name for the group, showing both the group and its parents.
ID | [read] the ID of the underlying object
IsAdministrator | [read] true if this is the 'Administrators' Group.
IsBuiltin | [read] true if this is a builtin Group.
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
IsRoot | [read] true if this is a top-level group with no parent group.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Parent | [read/write] the parent for this group.
Permissions | [read] the permissions for this group.
PresentationID | [read] the unique integer identifier for this group.
Server | [read] the Server for this cached object
SubGroups | [read] the sub Groups of this Group
TypeValue | [read/write] type (Team, User, Unknown) of this Group
Users | [read] the User objects directly belonging to this group.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.Description Property

[read/write] the group description.

public virtual String Description {get; set;}

Property Value

the group description.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


FullName Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.FullName Property

[read] A qualified name for the group, showing both the group and its parents.

public virtual String FullName {get;}

Property Value

A qualified name for the group, showing both the group and its parents.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Group.WebCacheGroup Class | StarTeam Namespace


IsAdministrator Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.IsAdministrator Property

[read] true if this is the 'Administrators' Group.

public virtual Boolean IsAdministrator {get;}

Property Value

true if this is the 'Administrators' Group.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


IsBuiltin Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.IsBuiltin Property

[read] true if this is a builtin Group.

public virtual Boolean IsBuiltin {get;}

Property Value

true if this is a builtin Group.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Group.WebCacheGroup Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


IsRoot Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.IsRoot Property

[read] true if this is a top-level group with no parent group.

public virtual Boolean IsRoot {get;}

Property Value

true if this is a top-level group with no parent group.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.Name Property

new public virtual String Name {get; set;}

See Also

Group.WebCacheGroup Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Group.WebCacheGroup Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.Parent Property

[read/write] the parent for this group.

public virtual Group.WebCacheGroup Parent {get; set;}

Property Value

the parent for this group.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Permissions Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.Permissions Property

[read] the permissions for this group.

public virtual PermissionCollection Permissions {get;}

Property Value

the permissions for this group.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.PresentationID Property

[read] the unique integer identifier for this group.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this group.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Group.WebCacheGroup Class | StarTeam Namespace


SubGroups Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.SubGroups Property

[read] the sub Groups of this Group

public virtual WebCacheGroup[] SubGroups {get;}

Property Value

the sub Groups of this Group

See Also

Group.WebCacheGroup Class | StarTeam Namespace


TypeValue Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.TypeValue Property

[read/write] type (Team, User, Unknown) of this Group

public virtual Group.GroupType TypeValue {get; set;}

Property Value

type (Team, User, Unknown) of this Group

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Users Property

Borland StarTeam SDK for .NET

Group.WebCacheGroup.Users Property

[read] the User objects directly belonging to this group.

public virtual WebCacheUser[] Users {get;}

Property Value

the User objects directly belonging to this group.

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup Methods

The methods of the Group.WebCacheGroup class are listed below. For a complete list of Group.WebCacheGroup class members, see the Group.WebCacheGroup Members topic.

Public Static Methods

Create

Public Instance Methods

AddPermission | Add this permission to the set of permissions for this Group.
AddTo |
CanAccessContainerForReading |
CanAccessForReading |
CanCreateArtifactType |
Equals | Delegate Equals() to com.starteam.Group.WebCacheGroup.
FindSubGroup | Returns a sub group of this group, identified by name
FindUser | Returns a user (who is a) member of this group, identified by logon name
GetHashCode | Delegate GetHashCode() to com.starteam.Group.WebCacheGroup.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasContainerRight | Overloaded.
HasContainerRights |
HasPermission | Returns true if this Group has the specified permission.
HasRight |
HasRights |
HasValue |
IsMember |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemovePermission | Removes the specified permission from this Group.
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Group.WebCacheGroup.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.AddPermission Method

Add this permission to the set of permissions for this Group.

public virtual void AddPermission(
Permission permission
);

Parameters

permission
the permission to add

See Also

Group.WebCacheGroup Class | StarTeam Namespace | Permission


Group.WebCacheGroup.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.CanAccessContainerForReading Method

new public virtual bool CanAccessContainerForReading(
ArtifactCacheManager.Securable s
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.CanAccessForReading Method

new public virtual bool CanAccessForReading(
ArtifactCacheManager.Securable s
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.CanCreateArtifactType Method

new public virtual bool CanCreateArtifactType(
ArtifactCacheManager.SecurableContainer sc,
Type.WebCacheType t
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.Create Method

public static WebCacheGroup Create(
ArtifactCacheManager.Context cntxt
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.Equals Method

Delegate Equals() to com.starteam.Group.WebCacheGroup.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Group.WebCacheGroup.Equals(obj).

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.FindSubGroup Method

Returns a sub group of this group, identified by name

public virtual WebCacheGroup FindSubGroup(
String name
);

Parameters

name
the name to match

Return Value

a subgroup with this name or null

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.FindUser Method

Returns a user (who is a) member of this group, identified by logon name

public virtual WebCacheUser FindUser(
String logonName
);

Parameters

logonName
the logon name to match

Return Value

a user with this logon name or null

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.GetHashCode Method

Delegate GetHashCode() to com.starteam.Group.WebCacheGroup.

public override int GetHashCode();

Return Value

com.starteam.Group.WebCacheGroup.GetHashCode().

See Also

Group.WebCacheGroup Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Group.WebCacheGroup.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace | Group.WebCacheGroup.GetValue Overload List


Group.WebCacheGroup.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Group.WebCacheGroup Class | StarTeam Namespace | Group.WebCacheGroup.GetValue Overload List


HasContainerRight Method

Borland StarTeam SDK for .NET

Group.WebCacheGroup.HasContainerRight Method

Overload List

new public virtual bool HasContainerRight(ArtifactCacheManager.Securable,Permission);

new public virtual bool HasContainerRight(ArtifactCacheManager.SecurableContainer,Type.WebCacheType,Permission);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.HasContainerRight Method (ArtifactCacheManager#Securable, Permission)

new public virtual bool HasContainerRight(
ArtifactCacheManager.Securable s,
Permission p
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace | Group.WebCacheGroup.HasContainerRight Overload List


Group.WebCacheGroup.HasContainerRight Method (ArtifactCacheManager#SecurableContainer, Type#WebCacheType, Permission)

new public virtual bool HasContainerRight(
ArtifactCacheManager.SecurableContainer sc,
Type.WebCacheType t,
Permission p
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace | Group.WebCacheGroup.HasContainerRight Overload List


Group.WebCacheGroup.HasContainerRights Method

new public virtual bool HasContainerRights(
ArtifactCacheManager.Securable s,
PermissionCollection pc
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.HasPermission Method

Returns true if this Group has the specified permission.

public virtual bool HasPermission(
Permission permission
);

Parameters

permission
the permission in question

Return Value

true if this Group has the specified permission.

See Also

Group.WebCacheGroup Class | StarTeam Namespace | Permission


Group.WebCacheGroup.HasRight Method

new public virtual bool HasRight(
ArtifactCacheManager.Securable s,
Permission p
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.HasRights Method

new public virtual bool HasRights(
ArtifactCacheManager.Securable s,
PermissionCollection pc
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.IsMember Method

public virtual bool IsMember(
User.WebCacheUser user
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Group.WebCacheGroup Class | StarTeam Namespace | WebCacheViewMemberCollection


Group.WebCacheGroup.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.RemovePermission Method

Removes the specified permission from this Group.

public virtual void RemovePermission(
Permission permission
);

Parameters

permission
the permission to remove

See Also

Group.WebCacheGroup Class | StarTeam Namespace | Permission


SetValue Method

Borland StarTeam SDK for .NET

Group.WebCacheGroup.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Group.WebCacheGroup Class | StarTeam Namespace | Group.WebCacheGroup.SetValue Overload List


Group.WebCacheGroup.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Group.WebCacheGroup Class | StarTeam Namespace | Group.WebCacheGroup.SetValue Overload List


Group.WebCacheGroup.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.ToString Method

Delegate ToString() to com.starteam.Group.WebCacheGroup.

public override string ToString();

Return Value

com.starteam.Group.WebCacheGroup.ToString()

See Also

Group.WebCacheGroup Class | StarTeam Namespace


Group.WebCacheGroup.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Group.WebCacheGroup Class | StarTeam Namespace | WebCacheViewMemberCollection


HiveInfo Class

Describes a vault hive on the server.

For a list of all members of this type, see HiveInfo Members.

System.Object
HiveInfo

public class HiveInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

HiveInfo Members | StarTeam Namespace


HiveInfo Members

HiveInfo overview

Public Instance Constructors

HiveInfo Overloaded. Initializes a new instance of the HiveInfo class.

Public Instance Properties

AllowNewArchives | [read/write] Indication of whether new archive files can be added to the hive. The default is TRUE.
ArchiveDirectory | [read/write] The path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.
CacheCleanupInterval | [read/write] The number of seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).
CacheDirectory | [read/write] The path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.
ID | [read] The number assigned by StarTeam to identify the hive
MaxCacheSize | [read/write] The maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.
Name | [read/write] The name of the hive. Note that on UNIX-based systems the name should not include any spaces.
RootCacheAgentArchiveDirectory | [read/write] The path to the hive's Root Cache Agent Archive directory. This is the same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.
RootDirectory | [read/write] The shortcut to creating path to Cache and Archive directories. When set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.
StorageLimitThreshold | [read/write] The percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.
Type | [read] The HiveType assigned by StarTeam to identify the the type of archive files stored in the hive:

Public Instance Methods

Copy | return a copy of this HiveInfo instance
Equals | Delegate Equals() to com.starteam.HiveInfo.
GetHashCode | Delegate GetHashCode() to com.starteam.HiveInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the Object passed in is a HiveInfo instance, with the same set of values as this HiveInfo instance
ToString | Delegate ToString() to com.starteam.HiveInfo.

See Also

HiveInfo Class | StarTeam Namespace


HiveInfo Constructor

Overload List

public HiveInfo(HiveInfo.HiveType);

construct a new HiveInfo from the source

public HiveInfo(HiveInfo);

Constructor for the case when we already know the hive object's ID.

public HiveInfo(Int32,Int32,String,String,String,String,String,Boolean,Int32,Int64,Int32);

See Also

HiveInfo Class | StarTeam Namespace


HiveInfo Constructor (HiveInfo#HiveType)

public HiveInfo(
HiveInfo.HiveType hiveType
);

See Also

HiveInfo Class | StarTeam Namespace | HiveInfo Constructor Overload List


HiveInfo Constructor (Int32, Int32, String, String, String, String, String, Boolean, Int32, Int64, Int32)

Constructor for the case when we already know the hive object's ID.

public HiveInfo(
Int32 ID,
Int32 hiveType,
String name,
String rootDirectory,
String cacheDirectory,
String archiveDirectory,
String rootCacheAgentArchiveDirectory,
Boolean bAllowNewArchives,
Int32 storageLimitThreshold,
Int64 maxCacheSize,
Int32 cacheCleanupInterval
);

Parameters

ID
The ID of this hive object.
hiveType
One of the HiveType values described above.
name
Name of the hive.
rootDirectory
Root directory of the hive.
cacheDirectory
Cache directory of the hive.
archiveDirectory
Archive directory of the hive.
rootCacheAgentArchiveDirectory
Directory for the root cache agent of the hive.
bAllowNewArchives
true = allow new archives, false = do not allow.
storageLimitThreshold
Hive's storage limit threshold.
maxCacheSize
64-bit value specifying the hive's maximum cache size.
cacheCleanupInterval
Timespan between cache refresh operations.

See Also

HiveInfo Class | StarTeam Namespace | HiveInfo Constructor Overload List


HiveInfo Constructor (HiveInfo)

construct a new HiveInfo from the source

public HiveInfo(
HiveInfo source
);

Parameters

source
HiveInfo the HiveInfo to copy

See Also

HiveInfo Class | StarTeam Namespace | HiveInfo Constructor Overload List


HiveInfo Properties

The properties of the HiveInfo class are listed below. For a complete list of HiveInfo class members, see the HiveInfo Members topic.

Public Instance Properties

AllowNewArchives | [read/write] Indication of whether new archive files can be added to the hive. The default is TRUE.
ArchiveDirectory | [read/write] The path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.
CacheCleanupInterval | [read/write] The number of seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).
CacheDirectory | [read/write] The path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.
ID | [read] The number assigned by StarTeam to identify the hive
MaxCacheSize | [read/write] The maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.
Name | [read/write] The name of the hive. Note that on UNIX-based systems the name should not include any spaces.
RootCacheAgentArchiveDirectory | [read/write] The path to the hive's Root Cache Agent Archive directory. This is the same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.
RootDirectory | [read/write] The shortcut to creating path to Cache and Archive directories. When set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.
StorageLimitThreshold | [read/write] The percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.
Type | [read] The HiveType assigned by StarTeam to identify the the type of archive files stored in the hive:

See Also

HiveInfo Class | StarTeam Namespace


AllowNewArchives Property

Borland StarTeam SDK for .NET

HiveInfo.AllowNewArchives Property

[read/write] Indication of whether new archive files can be added to the hive. The default is TRUE.

public virtual Boolean AllowNewArchives {get; set;}

Property Value

Indication of whether new archive files can be added to the hive. The default is TRUE.

See Also

HiveInfo Class | StarTeam Namespace


ArchiveDirectory Property

Borland StarTeam SDK for .NET

HiveInfo.ArchiveDirectory Property

[read/write] The path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.

public virtual String ArchiveDirectory {get; set;}

Property Value

The path to the hive's Archive directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Archives.

See Also

HiveInfo Class | StarTeam Namespace


CacheCleanupInterval Property

Borland StarTeam SDK for .NET

HiveInfo.CacheCleanupInterval Property

[read/write] The number of seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).

public virtual Int32 CacheCleanupInterval {get; set;}

Property Value

The number of seconds between cache cleanup operations. The default value is 600. The range is 60 (1 minute) to 3153600 (1 year).

See Also

HiveInfo Class | StarTeam Namespace


CacheDirectory Property

Borland StarTeam SDK for .NET

HiveInfo.CacheDirectory Property

[read/write] The path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.

public virtual String CacheDirectory {get; set;}

Property Value

The path to the hive's Cache directory. When set, it overrides the value of RootDirectory. The default is [repository_path]\DefaultHive\Cache.

See Also

HiveInfo Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

HiveInfo.ID Property

[read] The number assigned by StarTeam to identify the hive

public virtual Int32 ID {get;}

Property Value

The number assigned by StarTeam to identify the hive

See Also

HiveInfo Class | StarTeam Namespace


MaxCacheSize Property

Borland StarTeam SDK for .NET

HiveInfo.MaxCacheSize Property

[read/write] The maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.

public virtual Int64 MaxCacheSize {get; set;}

Property Value

The maximum number of megabytes of hard disk space that the cache can use. -1 is the default and represents 20 percent of the available disk space at the time the option is set. The range is -1 to 9,223,372,036,854,775,807.

See Also

HiveInfo Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

HiveInfo.Name Property

[read/write] The name of the hive. Note that on UNIX-based systems the name should not include any spaces.

public virtual String Name {get; set;}

Property Value

The name of the hive. Note that on UNIX-based systems the name should not include any spaces.

See Also

HiveInfo Class | StarTeam Namespace


RootCacheAgentArchiveDirectory Property

Borland StarTeam SDK for .NET

HiveInfo.RootCacheAgentArchiveDirectory Property

[read/write] The path to the hive's Root Cache Agent Archive directory. This is the same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.

public virtual String RootCacheAgentArchiveDirectory {get; set;}

Property Value

The path to the hive's Root Cache Agent Archive directory. This is the same folder path as for ArchiveDirectory but from the perspective of the computer on which the Root Cache Agent is installed. If the Root Cache Agent is installed on the same computer as the StarTeam Server, this can be empty or the same setting as the ArchiveDirectory.

See Also

HiveInfo Class | StarTeam Namespace


RootDirectory Property

Borland StarTeam SDK for .NET

HiveInfo.RootDirectory Property

[read/write] The shortcut to creating path to Cache and Archive directories. When set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.

public virtual String RootDirectory {get; set;}

Property Value

The shortcut to creating path to Cache and Archive directories. When set, CacheDirectory and ArchiveDirectory do not need to be set. The default is [repository_path]\DefaultHive.

See Also

HiveInfo Class | StarTeam Namespace


StorageLimitThreshold Property

Borland StarTeam SDK for .NET

HiveInfo.StorageLimitThreshold Property

[read/write] The percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.

public virtual Int32 StorageLimitThreshold {get; set;}

Property Value

The percentage of total disk space allowed for hive. When this percentage of total disk space has been used, no more archives can be added to the hive. -1 is the default and represents 95 percent of total disk space. The range is -1 to 100.

See Also

HiveInfo Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

HiveInfo.Type Property

[read] The HiveType assigned by StarTeam to identify the the type of archive files stored in the hive:

public virtual HiveInfo.HiveType Type {get;}

Property Value

The HiveType assigned by StarTeam to identify the the type of archive files stored in the hive:

See Also

HiveInfo Class | StarTeam Namespace


HiveInfo Methods

The methods of the HiveInfo class are listed below. For a complete list of HiveInfo class members, see the HiveInfo Members topic.

Public Instance Methods

Copy | return a copy of this HiveInfo instance
Equals | Delegate Equals() to com.starteam.HiveInfo.
GetHashCode | Delegate GetHashCode() to com.starteam.HiveInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the Object passed in is a HiveInfo instance, with the same set of values as this HiveInfo instance
ToString | Delegate ToString() to com.starteam.HiveInfo.

See Also

HiveInfo Class | StarTeam Namespace


HiveInfo.Copy Method

return a copy of this HiveInfo instance

public virtual HiveInfo Copy();

Return Value

HiveInfo a copy of this HiveInfo instance

See Also

HiveInfo Class | StarTeam Namespace


HiveInfo.Equals Method

Delegate Equals() to com.starteam.HiveInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.HiveInfo.Equals(obj).

See Also

HiveInfo Class | StarTeam Namespace


HiveInfo.GetHashCode Method

Delegate GetHashCode() to com.starteam.HiveInfo.

public override int GetHashCode();

Return Value

com.starteam.HiveInfo.GetHashCode().

See Also

HiveInfo Class | StarTeam Namespace


HiveInfo.IsEqualTo Method

returns true if the Object passed in is a HiveInfo instance, with the same set of values as this HiveInfo instance

public virtual bool IsEqualTo(
HiveInfo other
);

Parameters

other
Object another instance of a HiveInfo object

Return Value

boolean true if the HiveInfo parameter has the same set of values as this one

See Also

HiveInfo Class | StarTeam Namespace


HiveInfo.ToString Method

Delegate ToString() to com.starteam.HiveInfo.

public override string ToString();

Return Value

com.starteam.HiveInfo.ToString()

See Also

HiveInfo Class | StarTeam Namespace


HiveInfo.HiveType Class

Constants identifying the type of archive files stored in a vault hive.

For a list of all members of this type, see HiveInfo.HiveType Members.

System.Object
HiveInfo.HiveType

public class HiveInfo.HiveType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

HiveInfo.HiveType Members | StarTeam Namespace


HiveInfo.HiveType Members

HiveInfo.HiveType overview

Public Static Properties

ALL
NATIVE_II
UNKNOWN

Public Static Methods

FromID Gets the HiveType value corresponding to the given ID.

Public Instance Properties

ID [read] the ID of this HiveInfo instance

Public Instance Methods

Equals | Delegate Equals() to com.starteam.HiveInfo.HiveType.
GetHashCode | Delegate GetHashCode() to com.starteam.HiveInfo.HiveType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.HiveInfo.HiveType.

See Also

HiveInfo.HiveType Class | StarTeam Namespace


HiveInfo.HiveType Properties

The properties of the HiveInfo.HiveType class are listed below. For a complete list of HiveInfo.HiveType class members, see the HiveInfo.HiveType Members topic.

Public Static Properties

ALL
NATIVE_II
UNKNOWN

Public Instance Properties

ID [read] the ID of this HiveInfo instance

See Also

HiveInfo.HiveType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

HiveInfo.HiveType.ALL Property

public static HiveType[] ALL {get;}

See Also

HiveInfo.HiveType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

HiveInfo.HiveType.ID Property

[read] the ID of this HiveInfo instance

public virtual Int32 ID {get;}

Property Value

the ID of this HiveInfo instance

See Also

HiveInfo.HiveType Class | StarTeam Namespace


NATIVE_II Property

Borland StarTeam SDK for .NET

HiveInfo.HiveType.NATIVE_II Property

public static HiveInfo.HiveType NATIVE_II {get;}

Property Value

NativeII hive.

See Also

HiveInfo.HiveType Class | StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

HiveInfo.HiveType.UNKNOWN Property

public static HiveInfo.HiveType UNKNOWN {get;}

Property Value

Unknown (uninitialized type)

See Also

HiveInfo.HiveType Class | StarTeam Namespace


HiveInfo.HiveType Methods

The methods of the HiveInfo.HiveType class are listed below. For a complete list of HiveInfo.HiveType class members, see the HiveInfo.HiveType Members topic.

Public Static Methods

FromID Gets the HiveType value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.HiveInfo.HiveType.
GetHashCode | Delegate GetHashCode() to com.starteam.HiveInfo.HiveType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.HiveInfo.HiveType.

See Also

HiveInfo.HiveType Class | StarTeam Namespace


HiveInfo.HiveType.Equals Method

Delegate Equals() to com.starteam.HiveInfo.HiveType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.HiveInfo.HiveType.Equals(obj).

See Also

HiveInfo.HiveType Class | StarTeam Namespace


HiveInfo.HiveType.FromID Method

Gets the HiveType value corresponding to the given ID.

public static HiveType FromID(
Int32 id
);

Parameters

id
A HiveType ID.

Return Value

The corresponding HiveType value, or null.

See Also

HiveInfo.HiveType Class | StarTeam Namespace


HiveInfo.HiveType.GetHashCode Method

Delegate GetHashCode() to com.starteam.HiveInfo.HiveType.

public override int GetHashCode();

Return Value

com.starteam.HiveInfo.HiveType.GetHashCode().

See Also

HiveInfo.HiveType Class | StarTeam Namespace


HiveInfo.HiveType.ToString Method

Delegate ToString() to com.starteam.HiveInfo.HiveType.

public override string ToString();

Return Value

com.starteam.HiveInfo.HiveType.ToString()

See Also

HiveInfo.HiveType Class | StarTeam Namespace


HiveManager Class

Manages vault hives on the server.

For a list of all members of this type, see HiveManager Members.

System.Object
HiveManager

public class HiveManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

HiveManager Members | StarTeam Namespace


HiveManager Members

HiveManager overview

Public Instance Constructors

HiveManager Constructor Constructor a new HiveManager for this server

Public Instance Properties

HiveInfo [read/write] the current set of HiveInfo's from the server, or null if new vault format is not supported on this server.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.HiveManager.
GetHashCode | Delegate GetHashCode() to com.starteam.HiveManager.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.HiveManager.

See Also

HiveManager Class | StarTeam Namespace


HiveManager Constructor

Constructor a new HiveManager for this server

public HiveManager(
Server server
);

Parameters

server
the StarTeam Server

See Also

HiveManager Class | StarTeam Namespace


HiveManager Properties

The properties of the HiveManager class are listed below. For a complete list of HiveManager class members, see the HiveManager Members topic.

Public Instance Properties

HiveInfo [read/write] the current set of HiveInfo's from the server, or null if new vault format is not supported on this server.

See Also

HiveManager Class | StarTeam Namespace


HiveInfo Property

Borland StarTeam SDK for .NET

HiveManager.HiveInfo Property

[read/write] the current set of HiveInfo's from the server, or null if new vault format is not supported on this server.

public virtual HiveInfo[] HiveInfo {get; set;}

Property Value

the current set of HiveInfo's from the server, or null if new vault format is not supported on this server.

See Also

HiveManager Class | StarTeam Namespace


HiveManager Methods

The methods of the HiveManager class are listed below. For a complete list of HiveManager class members, see the HiveManager Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.HiveManager.
GetHashCode | Delegate GetHashCode() to com.starteam.HiveManager.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.HiveManager.

See Also

HiveManager Class | StarTeam Namespace


HiveManager.Equals Method

Delegate Equals() to com.starteam.HiveManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.HiveManager.Equals(obj).

See Also

HiveManager Class | StarTeam Namespace


HiveManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.HiveManager.

public override int GetHashCode();

Return Value

com.starteam.HiveManager.GetHashCode().

See Also

HiveManager Class | StarTeam Namespace


HiveManager.ToString Method

Delegate ToString() to com.starteam.HiveManager.

public override string ToString();

Return Value

com.starteam.HiveManager.ToString()

See Also

HiveManager Class | StarTeam Namespace


ImpersonateUser Class

Switch the server to execute in the context of an impersonated user Useful for applications like import utilities or web clients that service multiple users by switching context.

For a list of all members of this type, see ImpersonateUser Members.

System.Object
ImpersonateUser

public class ImpersonateUser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ImpersonateUser Members | StarTeam Namespace


ImpersonateUser Members

ImpersonateUser overview

Public Instance Constructors

ImpersonateUser Constructor Creates a new ImpersonateUser object for the specified server.

Public Instance Properties

CommandTime | [write] Warning: This method is potentially very dangerous and should be used with extreme caution. Each command issued to a StarTeam Server can have an optional override time. The override time will be interpreted as the time at which the operation occurred rather than the true current time. This is useful when implementing an import utility (for instance) so that, for example, a revision of a file can be checked in to the repository and it will appear to have been checked in at some point in the past rather than at the time the import tool actually performed the checkin. Once the value is set it will be used on all subsequent commands. To revert to using the current time this method should be called with a value of DateTime.CURRENT_SERVER_TIME.
CommandUser | [write] Warning: This method is potentially very dangerous and should be used with extreme caution. This can only be called when in impersonation mode and is used to impersonate a user for subsequent commands. Note that the command will be executed at the privilege level of the impersonated user

Public Instance Methods

EnableImpersonation | Warning: This method is potentially very dangerous and should be used with extreme caution. Calling this method will put the server into a state in which the same server object can be used to perform operations for different users. Once the server has been put into impersonation mode it cannot be put out of that mode
Equals | Delegate Equals() to com.starteam.ImpersonateUser.
GetHashCode | Delegate GetHashCode() to com.starteam.ImpersonateUser.
GetType (inherited from Object) | Gets the Type of the current instance.
Lock | lock the underlying server connection. The caller is responsible for unlocking it after completing the command sequence
SwitchContext | Warning: This method is potentially very dangerous and should be used with extreme caution. This can only be called when in impersonation mode and is used to specify which user will be used for subsequent operations. Note that the user (to whose context the session is being switched) should already have been logged on
ToString | Delegate ToString() to com.starteam.ImpersonateUser.
Unlock | unlock the underlying server connection. The caller is responsible for relocking it before issuing another command sequence

See Also

ImpersonateUser Class | StarTeam Namespace


ImpersonateUser Constructor

Creates a new ImpersonateUser object for the specified server.

public ImpersonateUser(
Server server
);

Parameters

server
the server object

See Also

ImpersonateUser Class | StarTeam Namespace


ImpersonateUser Properties

The properties of the ImpersonateUser class are listed below. For a complete list of ImpersonateUser class members, see the ImpersonateUser Members topic.

Public Instance Properties

CommandTime | [write] Warning: This method is potentially very dangerous and should be used with extreme caution. Each command issued to a StarTeam Server can have an optional override time. The override time will be interpreted as the time at which the operation occurred rather than the true current time. This is useful when implementing an import utility (for instance) so that, for example, a revision of a file can be checked in to the repository and it will appear to have been checked in at some point in the past rather than at the time the import tool actually performed the checkin. Once the value is set it will be used on all subsequent commands. To revert to using the current time this method should be called with a value of DateTime.CURRENT_SERVER_TIME.
CommandUser | [write] Warning: This method is potentially very dangerous and should be used with extreme caution. This can only be called when in impersonation mode and is used to impersonate a user for subsequent commands. Note that the command will be executed at the privilege level of the impersonated user

See Also

ImpersonateUser Class | StarTeam Namespace


CommandTime Property

Borland StarTeam SDK for .NET

ImpersonateUser.CommandTime Property

[write] Warning: This method is potentially very dangerous and should be used with extreme caution. Each command issued to a StarTeam Server can have an optional override time. The override time will be interpreted as the time at which the operation occurred rather than the true current time. This is useful when implementing an import utility (for instance) so that, for example, a revision of a file can be checked in to the repository and it will appear to have been checked in at some point in the past rather than at the time the import tool actually performed the checkin.

Once the value is set it will be used on all subsequent commands. To revert to using the current time this method should be called with a value of DateTime.CURRENT_SERVER_TIME.

public virtual DateTime CommandTime {set;}

Property Value

Warning: This method is potentially very dangerous and should be used with extreme caution. Each command issued to a StarTeam Server can have an optional override time. The override time will be interpreted as the time at which the operation occurred rather than the true current time. This is useful when implementing an import utility (for instance) so that, for example, a revision of a file can be checked in to the repository and it will appear to have been checked in at some point in the past rather than at the time the import tool actually performed the checkin.

Once the value is set it will be used on all subsequent commands. To revert to using the current time this method should be called with a value of DateTime.CURRENT_SERVER_TIME.

See Also

ImpersonateUser Class | StarTeam Namespace


CommandUser Property

Borland StarTeam SDK for .NET

ImpersonateUser.CommandUser Property

[write] Warning: This method is potentially very dangerous and should be used with extreme caution. This can only be called when in impersonation mode and is used to impersonate a user for subsequent commands. Note that the command will be executed at the privilege level of the impersonated user

public virtual User CommandUser {set;}

Property Value

Warning: This method is potentially very dangerous and should be used with extreme caution. This can only be called when in impersonation mode and is used to impersonate a user for subsequent commands. Note that the command will be executed at the privilege level of the impersonated user

See Also

ImpersonateUser Class | StarTeam Namespace


ImpersonateUser Methods

The methods of the ImpersonateUser class are listed below. For a complete list of ImpersonateUser class members, see the ImpersonateUser Members topic.

Public Instance Methods

EnableImpersonation | Warning: This method is potentially very dangerous and should be used with extreme caution. Calling this method will put the server into a state in which the same server object can be used to perform operations for different users. Once the server has been put into impersonation mode it cannot be put out of that mode
Equals | Delegate Equals() to com.starteam.ImpersonateUser.
GetHashCode | Delegate GetHashCode() to com.starteam.ImpersonateUser.
GetType (inherited from Object) | Gets the Type of the current instance.
Lock | lock the underlying server connection. The caller is responsible for unlocking it after completing the command sequence
SwitchContext | Warning: This method is potentially very dangerous and should be used with extreme caution. This can only be called when in impersonation mode and is used to specify which user will be used for subsequent operations. Note that the user (to whose context the session is being switched) should already have been logged on
ToString | Delegate ToString() to com.starteam.ImpersonateUser.
Unlock | unlock the underlying server connection. The caller is responsible for relocking it before issuing another command sequence

See Also

ImpersonateUser Class | StarTeam Namespace


ImpersonateUser.EnableImpersonation Method

Warning: This method is potentially very dangerous and should be used with extreme caution. Calling this method will put the server into a state in which the same server object can be used to perform operations for different users. Once the server has been put into impersonation mode it cannot be put out of that mode

public virtual void EnableImpersonation();

See Also

ImpersonateUser Class | StarTeam Namespace | switchContext


ImpersonateUser.Equals Method

Delegate Equals() to com.starteam.ImpersonateUser.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ImpersonateUser.Equals(obj).

See Also

ImpersonateUser Class | StarTeam Namespace


ImpersonateUser.GetHashCode Method

Delegate GetHashCode() to com.starteam.ImpersonateUser.

public override int GetHashCode();

Return Value

com.starteam.ImpersonateUser.GetHashCode().

See Also

ImpersonateUser Class | StarTeam Namespace


ImpersonateUser.Lock Method

lock the underlying server connection. The caller is responsible for unlocking it after completing the command sequence

public virtual void Lock();

See Also

ImpersonateUser Class | StarTeam Namespace


ImpersonateUser.SwitchContext Method

Warning: This method is potentially very dangerous and should be used with extreme caution. This can only be called when in impersonation mode and is used to specify which user will be used for subsequent operations. Note that the user (to whose context the session is being switched) should already have been logged on

public virtual void SwitchContext(
User user
);

Parameters

user
the user for whom new actions will be performed.

See Also

ImpersonateUser Class | StarTeam Namespace | enableImpersonation


ImpersonateUser.ToString Method

Delegate ToString() to com.starteam.ImpersonateUser.

public override string ToString();

Return Value

com.starteam.ImpersonateUser.ToString()

See Also

ImpersonateUser Class | StarTeam Namespace


ImpersonateUser.Unlock Method

unlock the underlying server connection. The caller is responsible for relocking it before issuing another command sequence

public virtual void Unlock();

See Also

ImpersonateUser Class | StarTeam Namespace


IntegerProperty Class

This class represents a property whose value is an Integer.

For a list of all members of this type, see IntegerProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Derived types

public class IntegerProperty : ScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

IntegerProperty Members | StarTeam Namespace


IntegerProperty Members

IntegerProperty overview

Public Static Properties

MAX_VALUE
MIN_VALUE

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] int the maximum integer value
MinValue | Overloaded. [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

IntegerProperty Class | StarTeam Namespace


IntegerProperty Properties

The properties of the IntegerProperty class are listed below. For a complete list of IntegerProperty class members, see the IntegerProperty Members topic.

Public Static Properties

MAX_VALUE
MIN_VALUE

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] int the maximum integer value
MinValue | Overloaded. [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

IntegerProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

IntegerProperty.DefaultValue Property

[read/write] int the default integer value

new public virtual Int32 DefaultValue {get; set;}

Property Value

int the default integer value

See Also

IntegerProperty Class | StarTeam Namespace


IsRollupProperty Property

Borland StarTeam SDK for .NET

IntegerProperty.IsRollupProperty Property

[read/write] true if this Integer Property can be rolled up

public virtual Boolean IsRollupProperty {get; set;}

Property Value

true if this Integer Property can be rolled up

See Also

IntegerProperty Class | StarTeam Namespace


MAX_VALUE Property

Borland StarTeam SDK for .NET

IntegerProperty.MAX_VALUE Property

public static Int32 MAX_VALUE {get;}

See Also

IntegerProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

IntegerProperty.MaxValue Property

[read/write] int the maximum integer value

new public virtual Int32 MaxValue {get; set;}

Property Value

int the maximum integer value

See Also

IntegerProperty Class | StarTeam Namespace


MIN_VALUE Property

Borland StarTeam SDK for .NET

IntegerProperty.MIN_VALUE Property

public static Int32 MIN_VALUE {get;}

See Also

IntegerProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

IntegerProperty.MinValue Property

[read/write] int the minimum integer value for this Property

new public virtual Int32 MinValue {get; set;}

Property Value

int the minimum integer value for this Property

See Also

IntegerProperty Class | StarTeam Namespace


IntegerProperty Methods

The methods of the IntegerProperty class are listed below. For a complete list of IntegerProperty class members, see the IntegerProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

IntegerProperty Class | StarTeam Namespace


IntegerProperty.NewQueryPart Method

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
Int32 value
);

See Also

IntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see IntegerProperty.WebCacheIntegerProperty Members.

System.Object
Property.WebCacheProperty
ScalarProperty.WebCacheScalarProperty
IntegerProperty.WebCacheIntegerProperty

public class IntegerProperty.WebCacheIntegerProperty : WebCacheScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

IntegerProperty.WebCacheIntegerProperty Members | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty Members

IntegerProperty.WebCacheIntegerProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] int the default integer value
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Integer Property can be rolled up
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] int the maximum integer value
MinValue | [read/write] int the minimum integer value for this Property
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.IntegerProperty.WebCacheIntegerProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.IntegerProperty.WebCacheIntegerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.IntegerProperty.WebCacheIntegerProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty Properties

The properties of the IntegerProperty.WebCacheIntegerProperty class are listed below. For a complete list of IntegerProperty.WebCacheIntegerProperty class members, see the IntegerProperty.WebCacheIntegerProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] int the default integer value
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Integer Property can be rolled up
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] int the maximum integer value
MinValue | [read/write] int the minimum integer value for this Property
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.DefaultValue Property

[read/write] int the default integer value

new public virtual Int32 DefaultValue {get; set;}

Property Value

int the default integer value

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsRollupProperty Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsRollupProperty Property

[read/write] true if this Integer Property can be rolled up

public virtual Boolean IsRollupProperty {get; set;}

Property Value

true if this Integer Property can be rolled up

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.MaxValue Property

[read/write] int the maximum integer value

public virtual Int32 MaxValue {get; set;}

Property Value

int the maximum integer value

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.MinValue Property

[read/write] int the minimum integer value for this Property

public virtual Int32 MinValue {get; set;}

Property Value

int the minimum integer value for this Property

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.Name Property

new public virtual String Name {get;}

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

IntegerProperty.WebCacheIntegerProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty Methods

The methods of the IntegerProperty.WebCacheIntegerProperty class are listed below. For a complete list of IntegerProperty.WebCacheIntegerProperty class members, see the IntegerProperty.WebCacheIntegerProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.IntegerProperty.WebCacheIntegerProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.IntegerProperty.WebCacheIntegerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.IntegerProperty.WebCacheIntegerProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.Equals Method

Delegate Equals() to com.starteam.IntegerProperty.WebCacheIntegerProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.IntegerProperty.WebCacheIntegerProperty.Equals(obj).

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.IntegerProperty.WebCacheIntegerProperty.

public override int GetHashCode();

Return Value

com.starteam.IntegerProperty.WebCacheIntegerProperty.GetHashCode().

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.NewQueryPart Method

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
Int32 value
);

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.ToString Method

Delegate ToString() to com.starteam.IntegerProperty.WebCacheIntegerProperty.

public override string ToString();

Return Value

com.starteam.IntegerProperty.WebCacheIntegerProperty.ToString()

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IntegerProperty.WebCacheIntegerProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

IntegerProperty.WebCacheIntegerProperty Class | StarTeam Namespace


IPRange Class

This class represents a range of TCP/IP addresses and the required level of encryption for clients to connect to the StarTeam server.

For a list of all members of this type, see IPRange Members.

System.Object
IPRange

public class IPRange

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

IPRange Members | StarTeam Namespace


IPRange Members

IPRange overview

Public Instance Constructors

IPRange Overloaded. Initializes a new instance of the IPRange class.

Public Instance Properties

Algorithm | [read/write] the minimum required level of encryption for this range.
MaxIP | [read/write] the maximum IP address for this range. The form will be "0.0.0.0" for IPV4 addresses, 0:0:0:0:0:0:0:0 for IPV6 addresses.
MinIP | [read/write] the minimum IP address for this range. The form will be "0.0.0.0" for IPV4 addresses, 0:0:0:0:0:0:0:0 for IPV6 addresses

Public Instance Methods

Copy | return a copy of this IPRange instance
Equals | Delegate Equals() to com.starteam.IPRange.
GetHashCode | Delegate GetHashCode() to com.starteam.IPRange.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the Object passed in is a IPRange instance, with the same set of values as this IPRange instance
ToString | Delegate ToString() to com.starteam.IPRange.

See Also

IPRange Class | StarTeam Namespace


IPRange Constructor

Overload List

construct a new IPRange from the source

public IPRange(IPRange);

public IPRange(String,String,Server.EncryptionAlgorithm);

See Also

IPRange Class | StarTeam Namespace


IPRange Constructor (String, String, Server#EncryptionAlgorithm)

public IPRange(
String min,
String max,
Server.EncryptionAlgorithm required
);

See Also

IPRange Class | StarTeam Namespace | IPRange Constructor Overload List


IPRange Constructor (IPRange)

construct a new IPRange from the source

public IPRange(
IPRange source
);

Parameters

source
IPRange the IPRange to copy

See Also

IPRange Class | StarTeam Namespace | IPRange Constructor Overload List


IPRange Properties

The properties of the IPRange class are listed below. For a complete list of IPRange class members, see the IPRange Members topic.

Public Instance Properties

Algorithm | [read/write] the minimum required level of encryption for this range.
MaxIP | [read/write] the maximum IP address for this range. The form will be "0.0.0.0" for IPV4 addresses, 0:0:0:0:0:0:0:0 for IPV6 addresses.
MinIP | [read/write] the minimum IP address for this range. The form will be "0.0.0.0" for IPV4 addresses, 0:0:0:0:0:0:0:0 for IPV6 addresses

See Also

IPRange Class | StarTeam Namespace


Algorithm Property

Borland StarTeam SDK for .NET

IPRange.Algorithm Property

[read/write] the minimum required level of encryption for this range.

public virtual Server.EncryptionAlgorithm Algorithm {get; set;}

Property Value

the minimum required level of encryption for this range.

See Also

IPRange Class | StarTeam Namespace


MaxIP Property

Borland StarTeam SDK for .NET

IPRange.MaxIP Property

[read/write] the maximum IP address for this range. The form will be "0.0.0.0" for IPV4 addresses, 0:0:0:0:0:0:0:0 for IPV6 addresses.

public virtual String MaxIP {get; set;}

Property Value

the maximum IP address for this range. The form will be "0.0.0.0" for IPV4 addresses, 0:0:0:0:0:0:0:0 for IPV6 addresses.

See Also

IPRange Class | StarTeam Namespace


MinIP Property

Borland StarTeam SDK for .NET

IPRange.MinIP Property

[read/write] the minimum IP address for this range. The form will be "0.0.0.0" for IPV4 addresses, 0:0:0:0:0:0:0:0 for IPV6 addresses

public virtual String MinIP {get; set;}

Property Value

the minimum IP address for this range. The form will be "0.0.0.0" for IPV4 addresses, 0:0:0:0:0:0:0:0 for IPV6 addresses

See Also

IPRange Class | StarTeam Namespace


IPRange Methods

The methods of the IPRange class are listed below. For a complete list of IPRange class members, see the IPRange Members topic.

Public Instance Methods

Copy | return a copy of this IPRange instance
Equals | Delegate Equals() to com.starteam.IPRange.
GetHashCode | Delegate GetHashCode() to com.starteam.IPRange.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the Object passed in is a IPRange instance, with the same set of values as this IPRange instance
ToString | Delegate ToString() to com.starteam.IPRange.

See Also

IPRange Class | StarTeam Namespace


IPRange.Copy Method

return a copy of this IPRange instance

public virtual IPRange Copy();

Return Value

IPRange a copy of this IPRange instance

See Also

IPRange Class | StarTeam Namespace


IPRange.Equals Method

Delegate Equals() to com.starteam.IPRange.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.IPRange.Equals(obj).

See Also

IPRange Class | StarTeam Namespace


IPRange.GetHashCode Method

Delegate GetHashCode() to com.starteam.IPRange.

public override int GetHashCode();

Return Value

com.starteam.IPRange.GetHashCode().

See Also

IPRange Class | StarTeam Namespace


IPRange.IsEqualTo Method

returns true if the Object passed in is a IPRange instance, with the same set of values as this IPRange instance

public virtual bool IsEqualTo(
IPRange other
);

Parameters

other
Object another instance of a IPRange object

Return Value

boolean true if the IPRange parameter has the same set of values as this one

See Also

IPRange Class | StarTeam Namespace


IPRange.ToString Method

Delegate ToString() to com.starteam.IPRange.

public override string ToString();

Return Value

com.starteam.IPRange.ToString()

See Also

IPRange Class | StarTeam Namespace


ISecurable Interface

For a list of all members of this type, see ISecurable Members.

public interface ISecurable

Types that implement ISecurable

Type | Description
Audit | Represents a StarTeam Audit record
ChangePackage | A ChangePackage represents a set of changes to a StarTeam view that together form a single logical change. A logical change might be a bug fix, enhancement, etc. The updates made by a ChangePackage are committed in a single, atomic transaction.
ChangeRequest | Represents a StarTeam ChangeRequest item.
Concept | A Concept is a basic unit of content.
File | Represents a StarTeam File item.
Filter | The Filter class is used to define criteria for which items (files, change requests) should be displayed to a user. It includes information on which items should be displayed, which properties should be displayed, and how the items should be sorted or grouped. The StarTeam GUI uses filters to determine what items in a folder to display.
Folder | Represents a StarTeam Folder. A folder is an Item, i.e. it does not have a parent id property However, (sub)folders reside within folders, which makes a folder a type of hierarchy tree Folders are also containers, in that, other items reside in folders
Item | Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Description property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.
KanbanBoard | A KanbanBoard is a process
LinkToTraceAdapter

An adapter class that surfaces a Link as if it were a Trace.

Since there are significant differences between the two models, the adapted link will actually be a new Trace (that is, a Trace that has not yet been saved to the StarTeam repository, for which isNew() returns true). Information from the Link is surfaced via the new Trace as described below.

  • Trace.getSource() will return a LinkValue that references the same Item as one of the Link endpoints.
  • Trace.getTarget() will return a LinkValue that references the same Item as the other Link endpoint.
  • Trace.getDescription() will return the same string as Link.getComment().
All other properties of the new Trace are initialized to their default values.

The new Trace can of course be modified by the client application, and/or saved to the StarTeam repository using Item.update(). A Trace saved this way is then unrelated to the original Link.

Plan | Represents a Starteam Plan item.
Project | Represents a StarTeam project which is essentially just a collection of Views.
PromotionState | This class represents a promotion state associated with a promotion model. This class has no update() method so to save new or modified promotion states you must use PromotionModel.update()
Query | The Query class implements a query condition to be applied to items of a certain type. Query objects are used in conjunction with Filter objects for describing what items to display to the user and how to display them.
RecycleBin | Provides access to the items that have been deleted from a view. The RecycleBin has properties that may be used to control which items are included. For example, IncludeDeletedFolders determines whether or not deleted folders are included in the folder tree. IncludeActiveItems determines whether or not active items are included along with deleted ones. Note that the recycle bin for a View with a rolled back ViewConfiguration (that is, a configuration other than the tip) reflects the state of deleted items as of the configuration time. If an item was active at the configuration time and deleted afterwards, it does not appear deleted in the recycle bin.
Requirement | Represents a StarTeam Requirement item.
Review | A Review is an oversight of a code block.
Sprint | An Agile/Scrum Sprint is a basic unit of development. It sums up all work to be accomplished within the sprint period that typically spans from a week to a month.
Story | A Story represents an Agile user story. It has a StoryType property to further qualify it as a more specific Agile artifact like Epic, Theme ... . Stories can be hierarchical, that is a parent story can have child stories. Stories may have Tasks to break them up into smaller units of work.
Swimlane | A Swimlane is a path in Kanban.
Task | Represents a StarTeam Task item.
Test | A Test is a basic unit of software testing.
TestRun | A TestRunRun is the state of a Test after execution.
Topic | Represents a StarTeam Topic.
Trace | A typed relationship between two artifacts.
TreeItem | A type of item with children.
View | Represents a StarTeam View.
MergePreview

Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides

VCMFolder | A folder belonging to the Merge Preview It has all the characteristics of a regular StarTeam Folder, and describes the Preview State of its constituent Items and/or Sub-Folders
ViewMember | A VersionedObject that lives in a View.
WhiteBoard | A WhiteBoard is a collection of concepts.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ISecurable Members | StarTeam Namespace


ISecurable Members

ISecurable overview

Public Instance Properties

ID
IsDeleted
MyType
ParentContainer
Rights
Server

Public Instance Methods

HasPermissions

See Also

ISecurable Interface | StarTeam Namespace


ISecurable Properties

The properties of the ISecurable interface are listed below. For a complete list of ISecurable interface members, see the ISecurable Members topic.

Public Instance Properties

ID
IsDeleted
MyType
ParentContainer
Rights
Server

See Also

ISecurable Interface | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ISecurable.ID Property

Int32 ID {get;}

See Also

ISecurable Interface | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

ISecurable.IsDeleted Property

Boolean IsDeleted {get;}

See Also

ISecurable Interface | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

ISecurable.MyType Property

Type MyType {get;}

See Also

ISecurable Interface | StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

ISecurable.ParentContainer Property

ISecurableContainer ParentContainer {get;}

See Also

ISecurable Interface | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

ISecurable.Rights Property

ACE[] Rights {get; set;}

See Also

ISecurable Interface | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ISecurable.Server Property

Server Server {get;}

See Also

ISecurable Interface | StarTeam Namespace


ISecurable Methods

The methods of the ISecurable interface are listed below. For a complete list of ISecurable interface members, see the ISecurable Members topic.

Public Instance Methods

HasPermissions

See Also

ISecurable Interface | StarTeam Namespace


ISecurable.HasPermissions Method

bool HasPermissions(
PermissionCollection permissions
);

See Also

ISecurable Interface | StarTeam Namespace


ISecurableContainer Interface

For a list of all members of this type, see ISecurableContainer Members.

public interface ISecurableContainer

Types that implement ISecurableContainer

Type | Description
Audit.Type | The Audit Type
Change.Type | The Type for Change
ChangePackage.Type | The Type of the ChangePackage component.
ChangeRequest.Type | Type meta-data (schema) for ChangeRequest object instances.
Concept.Type | Type meta-data (schema) for Concept object instances.
File.Type | The Type of File items.
Folder | Represents a StarTeam Folder. A folder is an Item, i.e. it does not have a parent id property However, (sub)folders reside within folders, which makes a folder a type of hierarchy tree Folders are also containers, in that, other items reside in folders
Folder.Type | The Type for Folder
Group.Type | The Type of Group.
Item.Type | The Type of Items.
KanbanBoard.Type | Type meta-data (schema) for KanbanBoard object instances.
Label.Type | The Type for Labels
LiveObject.Type | The Type for LiveObject
Plan.Type | Type meta-data (schema) for Plan object instances.
Principal.Type | The Type of the Principal
Project | Represents a StarTeam project which is essentially just a collection of Views.
Project.Type | The Type of the Project
PromotionModel.Type | The Type of Promotion Model
PromotionState.Type | The Type of Promotion State
RecycleBin | Provides access to the items that have been deleted from a view. The RecycleBin has properties that may be used to control which items are included. For example, IncludeDeletedFolders determines whether or not deleted folders are included in the folder tree. IncludeActiveItems determines whether or not active items are included along with deleted ones. Note that the recycle bin for a View with a rolled back ViewConfiguration (that is, a configuration other than the tip) reflects the state of deleted items as of the configuration time. If an item was active at the configuration time and deleted afterwards, it does not appear deleted in the recycle bin.
Requirement.Type | Type meta-data (schema) for Requirement object instances
Review.Type | Type meta-data (schema) for Review object instances.
Share.Type | Type for share
Sprint.Type | Type meta-data (schema) for Sprint object instances.
Story.Type | Type meta-data (schema) for Story object instances.
Swimlane.Type | Type meta-data (schema) for Swimlane object instances.
Task.Type | Type meta-data (schema) for Task object instances
TaskDependency.Type | The Type of TaskDependency.
Test.Type | Type meta-data (schema) for Test object instances.
TestRun.Type | Type meta-data (schema) for TestRun object instances.
Topic.Type | Type meta-data (schema) for Topic object instances.
Trace.Type | The type of the Trace
TrackedObject.Type | The Type for TrackedObject
TreeItem.Type | The type of the TreeItem
Type | Information describing certain StarTeam object types.
TypedResource.Type | The TypedResource Type
User.Type | The Type of the User
VersionedObject.Type | The Type for VersionedObject
View | Represents a StarTeam View.
View.Type | Type for view
MergePreview | Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides
VCMFolder | A folder belonging to the Merge Preview It has all the characteristics of a regular StarTeam Folder, and describes the Preview State of its constituent Items and/or Sub-Folders
ViewMember.Type | The type of the View
ViewMemberRevision.Type | The type of the ViewMemberRevision
WhiteBoard.Type | Type meta-data (schema) for WhiteBoard object instances.
WorkRecord.Type | The type of the WorkRecord

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ISecurableContainer Members | StarTeam Namespace


ISecurableContainer Members

ISecurableContainer overview

Public Instance Properties

ID
IsDeleted
ParentContainer
Server

Public Instance Methods

GetRights
HasPermissions
SetRights

See Also

ISecurableContainer Interface | StarTeam Namespace


ISecurableContainer Properties

The properties of the ISecurableContainer interface are listed below. For a complete list of ISecurableContainer interface members, see the ISecurableContainer Members topic.

Public Instance Properties

ID
IsDeleted
ParentContainer
Server

See Also

ISecurableContainer Interface | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ISecurableContainer.ID Property

Int32 ID {get;}

See Also

ISecurableContainer Interface | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

ISecurableContainer.IsDeleted Property

Boolean IsDeleted {get;}

See Also

ISecurableContainer Interface | StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

ISecurableContainer.ParentContainer Property

ISecurableContainer ParentContainer {get;}

See Also

ISecurableContainer Interface | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ISecurableContainer.Server Property

Server Server {get;}

See Also

ISecurableContainer Interface | StarTeam Namespace


ISecurableContainer Methods

The methods of the ISecurableContainer interface are listed below. For a complete list of ISecurableContainer interface members, see the ISecurableContainer Members topic.

Public Instance Methods

GetRights
HasPermissions
SetRights

See Also

ISecurableContainer Interface | StarTeam Namespace


ISecurableContainer.GetRights Method

ACE[] GetRights(
Type type
);

See Also

ISecurableContainer Interface | StarTeam Namespace


ISecurableContainer.HasPermissions Method

bool HasPermissions(
PermissionCollection permissions,
Type type
);

See Also

ISecurableContainer Interface | StarTeam Namespace


ISecurableContainer.SetRights Method

void SetRights(
Type type,
ACE[] acl
);

See Also

ISecurableContainer Interface | StarTeam Namespace


Item Class

Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Description property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.

For a list of all members of this type, see Item Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Derived types

public class Item : ViewMember

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item Members | StarTeam Namespace


Item Members

Item overview

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment | [read] the empty string.
NotifiedUsers | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder | [read] the folder in which this item exists.
ParentFolderHierarchy | [read] The fully-qualified name of this item's parent folder.
ParentFolderName | [read] the name of the item's parent folder.
ParentFolderPath | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Overloaded.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser | Removes the specified user object as one to be notified.
Resolve | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Item Class | StarTeam Namespace


Item Properties

The properties of the Item class are listed below. For a complete list of Item class members, see the Item Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment | [read] the empty string.
NotifiedUsers | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder | [read] the folder in which this item exists.
ParentFolderHierarchy | [read] The fully-qualified name of this item's parent folder.
ParentFolderName | [read] the name of the item's parent folder.
ParentFolderPath | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Item Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Item.DebugString Property

[read] a debug string for this item

public virtual String DebugString {get;}

Property Value

a debug string for this item

See Also

Item Class | StarTeam Namespace


DisplayableProperties Property

Borland StarTeam SDK for .NET

Item.DisplayableProperties Property

[read] the set of displayable properties

public virtual PropertyCollection DisplayableProperties {get;}

Property Value

the set of displayable properties

See Also

Item Class | StarTeam Namespace


ItemID Property

Borland StarTeam SDK for .NET

Item.ItemID Property

[read] the unique item ID for this item.

public virtual Int32 ItemID {get;}

Property Value

the unique item ID for this item.

See Also

Item Class | StarTeam Namespace


MergeHistory Property

Borland StarTeam SDK for .NET

Item.MergeHistory Property

[read] the merge points for this item

public virtual MergePoint[] MergeHistory {get;}

Property Value

the merge points for this item

See Also

Item Class | StarTeam Namespace


NewRevisionComment Property

Borland StarTeam SDK for .NET

Item.NewRevisionComment Property

[read] the empty string.

public virtual String NewRevisionComment {get;}

Property Value

the empty string.

See Also

Item Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Item.NotifiedUsers Property

[read] The users who are notified.

public virtual User[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Item Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Item.ParentFolder Property

[read] the folder in which this item exists.

public virtual Folder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Item Class | StarTeam Namespace


ParentFolderHierarchy Property

Borland StarTeam SDK for .NET

Item.ParentFolderHierarchy Property

[read] The fully-qualified name of this item's parent folder.

public virtual String ParentFolderHierarchy {get;}

Property Value

The fully-qualified name of this item's parent folder.

See Also

Item Class | StarTeam Namespace


ParentFolderName Property

Borland StarTeam SDK for .NET

Item.ParentFolderName Property

[read] the name of the item's parent folder.

public virtual String ParentFolderName {get;}

Property Value

the name of the item's parent folder.

See Also

Item Class | StarTeam Namespace


ParentFolderPath Property

Borland StarTeam SDK for .NET

Item.ParentFolderPath Property

[read] the working directory path for the item's parent folder.

public virtual String ParentFolderPath {get;}

Property Value

the working directory path for the item's parent folder.

See Also

Item Class | StarTeam Namespace


ParentFolderQualifiedName Property

Borland StarTeam SDK for .NET

Item.ParentFolderQualifiedName Property

[read] The fully-qualified name of this item's parent folder.

public virtual String ParentFolderQualifiedName {get;}

Property Value

The fully-qualified name of this item's parent folder.

See Also

Item Class | StarTeam Namespace


Item Methods

The methods of the Item class are listed below. For a complete list of Item class members, see the Item Members topic.

Public Instance Methods

AddNotifiedUser | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Overloaded.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser | Removes the specified user object as one to be notified.
Resolve | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Item Class | StarTeam Namespace


Item.AddNotifiedUser Method

Adds the specified user object as one to be notified.

public virtual void AddNotifiedUser(
User user
);

Parameters

user
the user object to add as one to be notified

See Also

Item Class | StarTeam Namespace


Item.DeleteMergePoint Method

Deletes the specified merge point for this item.

public virtual void DeleteMergePoint(
MergePoint mergePoint
);

Parameters

mergePoint
the merge point to be deleted

See Also

Item Class | StarTeam Namespace


Item.GetCommonAncestor Method

Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.

public virtual Item GetCommonAncestor(
Item other
);

Parameters

other
The item to be compared with this one.

Return Value

The most recent common ancestor between this item and the given item, or null if the two items have no common ancestor.

See Also

Item Class | StarTeam Namespace | isBranchable


Item.GetSharedChangePackages Method

Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.

public virtual ChangePackageCollection GetSharedChangePackages(
View[] targets,
Boolean direction
);

Parameters

targets
the set of views from which ChangePackages are requested specify project.getAccessibleViews() for all views
direction
the direction of the changes; TRUE for Changes with the item as Source, FALSE for Changes with the Item as Target, NULL for Changes in both directions.

Return Value

the set of visible ChangePackages returns the ChangePackages in this view if targets is null or an empty array

See Also

Item Class | StarTeam Namespace | getAccessibleViews | getTraces


Item.GetSharedTraces Method

Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.

public virtual TraceCollection GetSharedTraces(
View[] targets
);

Parameters

targets
the set of views from which traces are requested specify project.getAccessibleViews() for all views

Return Value

the set of visible traces returns the visible traces in this view if targets is null or an empty array

See Also

Item Class | StarTeam Namespace | getAccessibleViews | getTraces


IsEqualTo Method

Borland StarTeam SDK for .NET

Item.IsEqualTo Method

Overload List

public virtual bool IsEqualTo(Item);

Inherited from ViewMember.

public virtual bool IsEqualTo(ViewMember);

See Also

Item Class | StarTeam Namespace


Item.IsEqualTo Method (Item)

public virtual bool IsEqualTo(
Item item
);

See Also

Item Class | StarTeam Namespace | Item.IsEqualTo Overload List


Item.IsReverseShareRecommended Method

Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.

public virtual bool IsReverseShareRecommended(
Folder target
);

Parameters

target
The target folder.

Return Value

true if a reverse-share is appropriate; false otherwise.

See Also

Item Class | StarTeam Namespace | smartShareTo


MoveTo Method

Borland StarTeam SDK for .NET

Item.MoveTo Method

Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about

Overload List

Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about

public virtual void MoveTo(Folder);

Move this Item to the target folder. This is an atomic operation, not executed in a transaction but running in the context of a ConnectionPool

public virtual void MoveTo(Folder,ConnectionPool,User);

See Also

Item Class | StarTeam Namespace | isDisembodied


Item.MoveTo Method (Folder)

Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about

public virtual void MoveTo(
Folder toFolder
);

Parameters

toFolder
the new folder to which this item is to be moved.

See Also

Item Class | StarTeam Namespace | Item.MoveTo Overload List | isDisembodied


Item.MoveTo Method (Folder, ConnectionPool, User)

Move this Item to the target folder. This is an atomic operation, not executed in a transaction but running in the context of a ConnectionPool

public virtual void MoveTo(
Folder toFolder,
ConnectionPool cp,
User u
);

Parameters

toFolder
the parent folder to move to
cp
the connection pool
u
the user in whose context the move occurs

See Also

Item Class | StarTeam Namespace | Item.MoveTo Overload List | Item


Item.RecordMergePoint Method

Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.

public virtual MergePoint RecordMergePoint(
Item source
);

Parameters

source
the source Item that is to be the "merge" origin of the revision specified by this item.

Return Value

the merge point used to create this revision

See Also

Item Class | StarTeam Namespace


Item.RemoveNotifiedUser Method

Removes the specified user object as one to be notified.

public virtual void RemoveNotifiedUser(
User user
);

Parameters

user
the user object to remove as one to be notified.

See Also

Item Class | StarTeam Namespace


Item.Resolve Method

Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands

public virtual Item Resolve();

Return Value

a full-resolved version of this item

See Also

Item Class | StarTeam Namespace


Item.ResolveMergePoint Method

Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.

public virtual MergePoint ResolveMergePoint(
Item source
);

Parameters

source
the source Item that was the "merge" origin of the revision specified by this item.

Return Value

the merge point used to create this revision of the item with respect to the specified source item.

See Also

Item Class | StarTeam Namespace


Item.ResolveMergePointEx Method

Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.

public virtual MergePoint ResolveMergePointEx(
Item source
);

Parameters

source
the source Item that was the "merge" origin of the revision specified by this item.

Return Value

the merge point used to create this revision of the item with respect to the specified source item.

See Also

Item Class | StarTeam Namespace


ReverseShareTo Method

Borland StarTeam SDK for .NET

Item.ReverseShareTo Method

Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location.

In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one.

When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision.

Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.

Overload List

Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.

public virtual Item ReverseShareTo(Folder);

A variation of reverseShareTo() that is preferred in the case where many items may be shared from a rolled-back view configuration. Such shares can be expensive, due to the cost of opening the tip configuration of the view, and resolving the shared item in the tip. This cost can be minimized over multiple reverse share operations by opening the tip configuration once in the client application, and re-using it for each share.

public virtual Item ReverseShareTo(Folder,View);

See Also

Item Class | StarTeam Namespace | isDisembodied | moveTo | shareTo | reverseShareTo


Item.ReverseShareTo Method (Folder)

Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location.

In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one.

When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision.

Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.

public virtual Item ReverseShareTo(
Folder toFolder
);

Parameters

toFolder
The new parent folder.

Return Value

The item object representing the new item in the target folder.

See Also

Item Class | StarTeam Namespace | Item.ReverseShareTo Overload List | isDisembodied | moveTo | shareTo | reverseShareTo


Item.ReverseShareTo Method (Folder, View)

A variation of reverseShareTo() that is preferred in the case where many items may be shared from a rolled-back view configuration.

Such shares can be expensive, due to the cost of opening the tip configuration of the view, and resolving the shared item in the tip. This cost can be minimized over multiple reverse share operations by opening the tip configuration once in the client application, and re-using it for each share.

public virtual Item ReverseShareTo(
Folder toFolder,
View fromView
);

Parameters

toFolder
The new parent folder.
fromView
The tip configuration of the view in which this item resides.

Return Value

The item object representing the new item in the target folder.

See Also

Item Class | StarTeam Namespace | Item.ReverseShareTo Overload List | isDisembodied | moveTo | shareTo | reverseShareTo


Item.ShareTo Method

Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one.

If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.

public virtual Item ShareTo(
Folder toFolder
);

Parameters

toFolder
The new parent folder.

Return Value

The item object representing the newly shared item.

See Also

Item Class | StarTeam Namespace | isDisembodied | moveTo | reverseShareTo | isDeleted | RecycleBin


Item.SmartShareTo Method

Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.

public virtual Item SmartShareTo(
Folder target
);

Parameters

target
The target folder.

Return Value

The shared item.

See Also

Item Class | StarTeam Namespace | isReverseShareRecommended


Item.Type Class

The Type of Items.

For a list of all members of this type, see Item.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
Derived types

new public class Item.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type Members | StarTeam Namespace


Item.Type Members

Item.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Item.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Item.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Item.Type Class | StarTeam Namespace


Item.Type Properties

The properties of the Item.Type class are listed below. For a complete list of Item.Type class members, see the Item.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Item.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Item.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Item.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Item.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Item.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Item.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Item.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Item.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Item.Type.IsEnabled Property

[read/write] true if this type is enabled

public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Item.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Item.Type.IsNew Property

[read] true if this is a new type

public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Item.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Item.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Item.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.NAME Property

new public static String NAME {get;}

See Also

Item.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Item.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Item.Type.PropertiesEx Property

[write]

public virtual PropertyCollection PropertiesEx {set;}

See Also

Item.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Item.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Item.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Item.Type Class | StarTeam Namespace


Item.Type Methods

The methods of the Item.Type class are listed below. For a complete list of Item.Type class members, see the Item.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Item.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Item.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Item.Type Class | StarTeam Namespace


Item.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Item.Type Class | StarTeam Namespace


Item.Type.CreateItem Method

Creates a new StarTeam item of this type.

public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Item.Type Class | StarTeam Namespace


Item.Type.Equals Method

Delegate Equals() to com.starteam.Item.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.Equals(obj).

See Also

Item.Type Class | StarTeam Namespace


Item.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Item.Type Class | StarTeam Namespace


Item.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.GetHashCode().

See Also

Item.Type Class | StarTeam Namespace


Item.Type.ToString Method

Delegate ToString() to com.starteam.Item.Type.

public override string ToString();

Return Value

com.starteam.Item.Type.ToString()

See Also

Item.Type Class | StarTeam Namespace


Item.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Item.Type Class | StarTeam Namespace


Item.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

public virtual void Update();

See Also

Item.Type Class | StarTeam Namespace


Item.Type.DiagramSourceProperty Class

The property type of the Diagram property.

For a list of all members of this type, see Item.Type.DiagramSourceProperty Members.

System.Object
Property
ContentProperty
Item.Type.DiagramSourceProperty

public class Item.Type.DiagramSourceProperty : ContentProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.DiagramSourceProperty Members | StarTeam Namespace


Item.Type.DiagramSourceProperty Members

Item.Type.DiagramSourceProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.DiagramSourceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.DiagramSourceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.Item.Type.DiagramSourceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.DiagramSourceProperty Class | StarTeam Namespace


Item.Type.DiagramSourceProperty Properties

The properties of the Item.Type.DiagramSourceProperty class are listed below. For a complete list of Item.Type.DiagramSourceProperty class members, see the Item.Type.DiagramSourceProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Item.Type.DiagramSourceProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.DiagramSourceProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.DiagramSourceProperty Class | StarTeam Namespace


Item.Type.DiagramSourceProperty Methods

The methods of the Item.Type.DiagramSourceProperty class are listed below. For a complete list of Item.Type.DiagramSourceProperty class members, see the Item.Type.DiagramSourceProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.DiagramSourceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.DiagramSourceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.Item.Type.DiagramSourceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.DiagramSourceProperty Class | StarTeam Namespace


Item.Type.DiagramSourceProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.DiagramSourceProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.DiagramSourceProperty.Equals(obj).

See Also

Item.Type.DiagramSourceProperty Class | StarTeam Namespace


Item.Type.DiagramSourceProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.DiagramSourceProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.DiagramSourceProperty.GetHashCode().

See Also

Item.Type.DiagramSourceProperty Class | StarTeam Namespace


Item.Type.DiagramSourceProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.DiagramSourceProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.DiagramSourceProperty.ToString()

See Also

Item.Type.DiagramSourceProperty Class | StarTeam Namespace


Item.Type.ExternalReferenceProperty Class

The property type of the ExternalReference property.

For a list of all members of this type, see Item.Type.ExternalReferenceProperty Members.

System.Object
Property
VectorProperty
TextProperty
Item.Type.ExternalReferenceProperty

public class Item.Type.ExternalReferenceProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.ExternalReferenceProperty Members | StarTeam Namespace


Item.Type.ExternalReferenceProperty Members

Item.Type.ExternalReferenceProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.ExternalReferenceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.ExternalReferenceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.ExternalReferenceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.ExternalReferenceProperty Class | StarTeam Namespace


Item.Type.ExternalReferenceProperty Properties

The properties of the Item.Type.ExternalReferenceProperty class are listed below. For a complete list of Item.Type.ExternalReferenceProperty class members, see the Item.Type.ExternalReferenceProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Item.Type.ExternalReferenceProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.ExternalReferenceProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.ExternalReferenceProperty Class | StarTeam Namespace


Item.Type.ExternalReferenceProperty Methods

The methods of the Item.Type.ExternalReferenceProperty class are listed below. For a complete list of Item.Type.ExternalReferenceProperty class members, see the Item.Type.ExternalReferenceProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.ExternalReferenceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.ExternalReferenceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.ExternalReferenceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.ExternalReferenceProperty Class | StarTeam Namespace


Item.Type.ExternalReferenceProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.ExternalReferenceProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.ExternalReferenceProperty.Equals(obj).

See Also

Item.Type.ExternalReferenceProperty Class | StarTeam Namespace


Item.Type.ExternalReferenceProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.ExternalReferenceProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.ExternalReferenceProperty.GetHashCode().

See Also

Item.Type.ExternalReferenceProperty Class | StarTeam Namespace


Item.Type.ExternalReferenceProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.ExternalReferenceProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.ExternalReferenceProperty.ToString()

See Also

Item.Type.ExternalReferenceProperty Class | StarTeam Namespace


Item.Type.FolderProperty Class

The property type of the Folder property.

For a list of all members of this type, see Item.Type.FolderProperty Members.

System.Object
Property
VectorProperty
TextProperty
Item.Type.FolderProperty

public class Item.Type.FolderProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.FolderProperty Members | StarTeam Namespace


Item.Type.FolderProperty Members

Item.Type.FolderProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.FolderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.FolderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.FolderProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.FolderProperty Class | StarTeam Namespace


Item.Type.FolderProperty Properties

The properties of the Item.Type.FolderProperty class are listed below. For a complete list of Item.Type.FolderProperty class members, see the Item.Type.FolderProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Item.Type.FolderProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.FolderProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.FolderProperty Class | StarTeam Namespace


Item.Type.FolderProperty Methods

The methods of the Item.Type.FolderProperty class are listed below. For a complete list of Item.Type.FolderProperty class members, see the Item.Type.FolderProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.FolderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.FolderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.FolderProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.FolderProperty Class | StarTeam Namespace


Item.Type.FolderProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.FolderProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.FolderProperty.Equals(obj).

See Also

Item.Type.FolderProperty Class | StarTeam Namespace


Item.Type.FolderProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.FolderProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.FolderProperty.GetHashCode().

See Also

Item.Type.FolderProperty Class | StarTeam Namespace


Item.Type.FolderProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.FolderProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.FolderProperty.ToString()

See Also

Item.Type.FolderProperty Class | StarTeam Namespace


Item.Type.NewRevisionCommentProperty Class

The property type of the New Revision Comment property.

For a list of all members of this type, see Item.Type.NewRevisionCommentProperty Members.

System.Object
Property
VectorProperty
TextProperty
Item.Type.NewRevisionCommentProperty

public class Item.Type.NewRevisionCommentProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.NewRevisionCommentProperty Members | StarTeam Namespace


Item.Type.NewRevisionCommentProperty Members

Item.Type.NewRevisionCommentProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.NewRevisionCommentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.NewRevisionCommentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.NewRevisionCommentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.NewRevisionCommentProperty Class | StarTeam Namespace


Item.Type.NewRevisionCommentProperty Properties

The properties of the Item.Type.NewRevisionCommentProperty class are listed below. For a complete list of Item.Type.NewRevisionCommentProperty class members, see the Item.Type.NewRevisionCommentProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Item.Type.NewRevisionCommentProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.NewRevisionCommentProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.NewRevisionCommentProperty Class | StarTeam Namespace


Item.Type.NewRevisionCommentProperty Methods

The methods of the Item.Type.NewRevisionCommentProperty class are listed below. For a complete list of Item.Type.NewRevisionCommentProperty class members, see the Item.Type.NewRevisionCommentProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.NewRevisionCommentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.NewRevisionCommentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.NewRevisionCommentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.NewRevisionCommentProperty Class | StarTeam Namespace


Item.Type.NewRevisionCommentProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.NewRevisionCommentProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.NewRevisionCommentProperty.Equals(obj).

See Also

Item.Type.NewRevisionCommentProperty Class | StarTeam Namespace


Item.Type.NewRevisionCommentProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.NewRevisionCommentProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.NewRevisionCommentProperty.GetHashCode().

See Also

Item.Type.NewRevisionCommentProperty Class | StarTeam Namespace


Item.Type.NewRevisionCommentProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.NewRevisionCommentProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.NewRevisionCommentProperty.ToString()

See Also

Item.Type.NewRevisionCommentProperty Class | StarTeam Namespace


Item.Type.NotificationCountProperty Class

The property type of the NotificationCount property

For a list of all members of this type, see Item.Type.NotificationCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Item.Type.NotificationCountProperty

public class Item.Type.NotificationCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.NotificationCountProperty Members | StarTeam Namespace


Item.Type.NotificationCountProperty Members

Item.Type.NotificationCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.NotificationCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.NotificationCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.NotificationCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.NotificationCountProperty Class | StarTeam Namespace


Item.Type.NotificationCountProperty Properties

The properties of the Item.Type.NotificationCountProperty class are listed below. For a complete list of Item.Type.NotificationCountProperty class members, see the Item.Type.NotificationCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Item.Type.NotificationCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.NotificationCountProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.NotificationCountProperty Class | StarTeam Namespace


Item.Type.NotificationCountProperty Methods

The methods of the Item.Type.NotificationCountProperty class are listed below. For a complete list of Item.Type.NotificationCountProperty class members, see the Item.Type.NotificationCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.NotificationCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.NotificationCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.NotificationCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.NotificationCountProperty Class | StarTeam Namespace


Item.Type.NotificationCountProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.NotificationCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.NotificationCountProperty.Equals(obj).

See Also

Item.Type.NotificationCountProperty Class | StarTeam Namespace


Item.Type.NotificationCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.NotificationCountProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.NotificationCountProperty.GetHashCode().

See Also

Item.Type.NotificationCountProperty Class | StarTeam Namespace


Item.Type.NotificationCountProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.NotificationCountProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.NotificationCountProperty.ToString()

See Also

Item.Type.NotificationCountProperty Class | StarTeam Namespace


Item.Type.NotificationIDsProperty Class

The property type of the NotificationIDs property

For a list of all members of this type, see Item.Type.NotificationIDsProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Item.Type.NotificationIDsProperty

public class Item.Type.NotificationIDsProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.NotificationIDsProperty Members | StarTeam Namespace


Item.Type.NotificationIDsProperty Members

Item.Type.NotificationIDsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.NotificationIDsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.NotificationIDsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.NotificationIDsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.NotificationIDsProperty Class | StarTeam Namespace


Item.Type.NotificationIDsProperty Properties

The properties of the Item.Type.NotificationIDsProperty class are listed below. For a complete list of Item.Type.NotificationIDsProperty class members, see the Item.Type.NotificationIDsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Item.Type.NotificationIDsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.NotificationIDsProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.NotificationIDsProperty Class | StarTeam Namespace


Item.Type.NotificationIDsProperty Methods

The methods of the Item.Type.NotificationIDsProperty class are listed below. For a complete list of Item.Type.NotificationIDsProperty class members, see the Item.Type.NotificationIDsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.NotificationIDsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.NotificationIDsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.NotificationIDsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.NotificationIDsProperty Class | StarTeam Namespace


Item.Type.NotificationIDsProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.NotificationIDsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.NotificationIDsProperty.Equals(obj).

See Also

Item.Type.NotificationIDsProperty Class | StarTeam Namespace


Item.Type.NotificationIDsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.NotificationIDsProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.NotificationIDsProperty.GetHashCode().

See Also

Item.Type.NotificationIDsProperty Class | StarTeam Namespace


Item.Type.NotificationIDsProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.NotificationIDsProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.NotificationIDsProperty.ToString()

See Also

Item.Type.NotificationIDsProperty Class | StarTeam Namespace


Item.Type.PropertyCollection Class

Property Collection for TreeItem

For a list of all members of this type, see Item.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Derived types

new public class Item.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.PropertyCollection Members | StarTeam Namespace


Item.Type.PropertyCollection Members

Item.Type.PropertyCollection overview

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
DEFAULT_ACTION |
DIFFERENCE_TYPE |
IS_ACTION_OVERRIDDEN |
IS_CHECKED |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MERGE_ACTION |
MERGE_STATUS |
MY_LOCK (inherited from PropertyCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Item.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Item.Type.PropertyCollection.

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


Item.Type.PropertyCollection Properties

The properties of the Item.Type.PropertyCollection class are listed below. For a complete list of Item.Type.PropertyCollection class members, see the Item.Type.PropertyCollection Members topic.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
DEFAULT_ACTION |
DIFFERENCE_TYPE |
IS_ACTION_OVERRIDDEN |
IS_CHECKED |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MERGE_ACTION |
MERGE_STATUS |
MY_LOCK (inherited from PropertyCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


DEFAULT_ACTION Property

Borland StarTeam SDK for .NET

Item.Type.PropertyCollection.DEFAULT_ACTION Property

public DefaultActionProperty DEFAULT_ACTION {get;}

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


DIFFERENCE_TYPE Property

Borland StarTeam SDK for .NET

Item.Type.PropertyCollection.DIFFERENCE_TYPE Property

public DifferenceTypeProperty DIFFERENCE_TYPE {get;}

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


IS_ACTION_OVERRIDDEN Property

Borland StarTeam SDK for .NET

Item.Type.PropertyCollection.IS_ACTION_OVERRIDDEN Property

public IsActionOverriddenProperty IS_ACTION_OVERRIDDEN {get;}

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


IS_CHECKED Property

Borland StarTeam SDK for .NET

Item.Type.PropertyCollection.IS_CHECKED Property

public IsCheckedProperty IS_CHECKED {get;}

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


MERGE_ACTION Property

Borland StarTeam SDK for .NET

Item.Type.PropertyCollection.MERGE_ACTION Property

public MergeActionProperty MERGE_ACTION {get;}

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


MERGE_STATUS Property

Borland StarTeam SDK for .NET

Item.Type.PropertyCollection.MERGE_STATUS Property

public MergeStatusProperty MERGE_STATUS {get;}

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


Item.Type.PropertyCollection Methods

The methods of the Item.Type.PropertyCollection class are listed below. For a complete list of Item.Type.PropertyCollection class members, see the Item.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Item.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Item.Type.PropertyCollection.

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


Item.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Item.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.PropertyCollection.Equals(obj).

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


Item.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.PropertyCollection.GetHashCode().

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


Item.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Item.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Item.Type.PropertyCollection.ToString()

See Also

Item.Type.PropertyCollection Class | StarTeam Namespace


Item.Type.TagProperty Class

The Property Type of the Tag Property

For a list of all members of this type, see Item.Type.TagProperty Members.

System.Object
Property
EnumeratedProperty
Item.Type.TagProperty

public class Item.Type.TagProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.TagProperty Members | StarTeam Namespace


Item.Type.TagProperty Members

Item.Type.TagProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Item.Type.TagProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.TagProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Item.Type.TagProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.TagProperty Class | StarTeam Namespace


Item.Type.TagProperty Properties

The properties of the Item.Type.TagProperty class are listed below. For a complete list of Item.Type.TagProperty class members, see the Item.Type.TagProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Item.Type.TagProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.TagProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.TagProperty Class | StarTeam Namespace


Item.Type.TagProperty Methods

The methods of the Item.Type.TagProperty class are listed below. For a complete list of Item.Type.TagProperty class members, see the Item.Type.TagProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Item.Type.TagProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.TagProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Item.Type.TagProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.TagProperty Class | StarTeam Namespace


Item.Type.TagProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.TagProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.TagProperty.Equals(obj).

See Also

Item.Type.TagProperty Class | StarTeam Namespace


Item.Type.TagProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.TagProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.TagProperty.GetHashCode().

See Also

Item.Type.TagProperty Class | StarTeam Namespace


Item.Type.TagProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.TagProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.TagProperty.ToString()

See Also

Item.Type.TagProperty Class | StarTeam Namespace


Item.Type.TeamProperty Class

The property type of the Team property.

For a list of all members of this type, see Item.Type.TeamProperty Members.

System.Object
Property
VectorProperty
TextProperty
Item.Type.TeamProperty

public class Item.Type.TeamProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.TeamProperty Members | StarTeam Namespace


Item.Type.TeamProperty Members

Item.Type.TeamProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.TeamProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.TeamProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.TeamProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.TeamProperty Class | StarTeam Namespace


Item.Type.TeamProperty Properties

The properties of the Item.Type.TeamProperty class are listed below. For a complete list of Item.Type.TeamProperty class members, see the Item.Type.TeamProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Item.Type.TeamProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.TeamProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.TeamProperty Class | StarTeam Namespace


Item.Type.TeamProperty Methods

The methods of the Item.Type.TeamProperty class are listed below. For a complete list of Item.Type.TeamProperty class members, see the Item.Type.TeamProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.TeamProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.TeamProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.TeamProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.TeamProperty Class | StarTeam Namespace


Item.Type.TeamProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.TeamProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.TeamProperty.Equals(obj).

See Also

Item.Type.TeamProperty Class | StarTeam Namespace


Item.Type.TeamProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.TeamProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.TeamProperty.GetHashCode().

See Also

Item.Type.TeamProperty Class | StarTeam Namespace


Item.Type.TeamProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.TeamProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.TeamProperty.ToString()

See Also

Item.Type.TeamProperty Class | StarTeam Namespace


Item.Type.VersionMetadataIDsProperty Class

The property type of the VersionMetadataIDs property.

For a list of all members of this type, see Item.Type.VersionMetadataIDsProperty Members.

System.Object
Property
VectorProperty
TextProperty
Item.Type.VersionMetadataIDsProperty

public class Item.Type.VersionMetadataIDsProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.VersionMetadataIDsProperty Members | StarTeam Namespace


Item.Type.VersionMetadataIDsProperty Members

Item.Type.VersionMetadataIDsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.VersionMetadataIDsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.VersionMetadataIDsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.VersionMetadataIDsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.VersionMetadataIDsProperty Class | StarTeam Namespace


Item.Type.VersionMetadataIDsProperty Properties

The properties of the Item.Type.VersionMetadataIDsProperty class are listed below. For a complete list of Item.Type.VersionMetadataIDsProperty class members, see the Item.Type.VersionMetadataIDsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Item.Type.VersionMetadataIDsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.VersionMetadataIDsProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.VersionMetadataIDsProperty Class | StarTeam Namespace


Item.Type.VersionMetadataIDsProperty Methods

The methods of the Item.Type.VersionMetadataIDsProperty class are listed below. For a complete list of Item.Type.VersionMetadataIDsProperty class members, see the Item.Type.VersionMetadataIDsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.VersionMetadataIDsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.VersionMetadataIDsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.VersionMetadataIDsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.VersionMetadataIDsProperty Class | StarTeam Namespace


Item.Type.VersionMetadataIDsProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.VersionMetadataIDsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.VersionMetadataIDsProperty.Equals(obj).

See Also

Item.Type.VersionMetadataIDsProperty Class | StarTeam Namespace


Item.Type.VersionMetadataIDsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.VersionMetadataIDsProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.VersionMetadataIDsProperty.GetHashCode().

See Also

Item.Type.VersionMetadataIDsProperty Class | StarTeam Namespace


Item.Type.VersionMetadataIDsProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.VersionMetadataIDsProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.VersionMetadataIDsProperty.ToString()

See Also

Item.Type.VersionMetadataIDsProperty Class | StarTeam Namespace


Item.Type.VersionMetadataProperty Class

The property type of the VersionMetadata property.

For a list of all members of this type, see Item.Type.VersionMetadataProperty Members.

System.Object
Property
VectorProperty
TextProperty
Item.Type.VersionMetadataProperty

public class Item.Type.VersionMetadataProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.VersionMetadataProperty Members | StarTeam Namespace


Item.Type.VersionMetadataProperty Members

Item.Type.VersionMetadataProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.VersionMetadataProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.VersionMetadataProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.VersionMetadataProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.VersionMetadataProperty Class | StarTeam Namespace


Item.Type.VersionMetadataProperty Properties

The properties of the Item.Type.VersionMetadataProperty class are listed below. For a complete list of Item.Type.VersionMetadataProperty class members, see the Item.Type.VersionMetadataProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Item.Type.VersionMetadataProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Item.Type.VersionMetadataProperty.NAME Property

public static String NAME {get;}

See Also

Item.Type.VersionMetadataProperty Class | StarTeam Namespace


Item.Type.VersionMetadataProperty Methods

The methods of the Item.Type.VersionMetadataProperty class are listed below. For a complete list of Item.Type.VersionMetadataProperty class members, see the Item.Type.VersionMetadataProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Item.Type.VersionMetadataProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.VersionMetadataProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Item.Type.VersionMetadataProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Item.Type.VersionMetadataProperty Class | StarTeam Namespace


Item.Type.VersionMetadataProperty.Equals Method

Delegate Equals() to com.starteam.Item.Type.VersionMetadataProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.VersionMetadataProperty.Equals(obj).

See Also

Item.Type.VersionMetadataProperty Class | StarTeam Namespace


Item.Type.VersionMetadataProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.VersionMetadataProperty.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.VersionMetadataProperty.GetHashCode().

See Also

Item.Type.VersionMetadataProperty Class | StarTeam Namespace


Item.Type.VersionMetadataProperty.ToString Method

Delegate ToString() to com.starteam.Item.Type.VersionMetadataProperty.

public override string ToString();

Return Value

com.starteam.Item.Type.VersionMetadataProperty.ToString()

See Also

Item.Type.VersionMetadataProperty Class | StarTeam Namespace


Item.Type.WebCacheItemType Class

Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see Item.Type.WebCacheItemType Members.

System.Object
Type.WebCacheType
ViewMember.Type.WebCacheViewMemberType
Item.Type.WebCacheItemType
TreeItem.Type.WebCacheTreeItemType

public class Item.Type.WebCacheItemType : WebCacheViewMemberType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.Type.WebCacheItemType Members | StarTeam Namespace


Item.Type.WebCacheItemType Members

Item.Type.WebCacheItemType overview

Public Static Methods

Create
FromXml

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog | [read] the Catalog for this type
ComponentGUID | [read] the Component GUID of this type
Context | [read] the context of this object.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [read/write] a display name for this type.
DisplayNameTranslations | [read]
Filters | [read] the set of filters
ID | [read] the class ID for this type.
Identifier | [read] the integer identifier value of the identifier property
IdentifierProperty | [read] the identifier property for this item type
IsEnabled | [read/write] true if this type is enabled
IsNew | [read] true if this is a new type
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name |
NameProperty |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries | [read] the set of queries
SecondaryDescriptor | [read] The secondary descriptor of this type, or null if this type has no secondary descriptor.
Server | [read] the Server for this cached object
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Item.Type.WebCacheItemType.
FindFilter | Overloaded. find a Filter by ID, visible in the user context
FindProperty | Overloaded. Find and return a property by int iD
FindQuery | Overloaded. find a Query by ID, visible in the user context
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.WebCacheItemType.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
NewBooleanProperty | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty | Creates a new DateProperty
NewDateTimeProperty | Creates a new DateTimeProperty
NewDoubleProperty | Creates a new DoubleProperty
NewEnumeratedProperty | Create a new Enumerated Property
NewGroupArrayProperty | Creates a property on the server.
NewGroupProperty | Creates a property on the server.
NewIntegerProperty | Creates a new IntegerProperty
NewLongIntegerProperty | Creates a new LongIntegerProperty. The new property is dirty; to save changes, you must call Property.update().
NewMapProperty | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewTextProperty | Creates a new TextProperty
NewTimeSpanProperty | Creates a new TimeSpanProperty
NewUserArrayProperty | Creates a property on the server.
NewUserProperty | Creates a property on the server.
NewWebCacheFilterEventSource (inherited from WebCacheType) |
NewWebCacheQueryEventSource (inherited from WebCacheType) |
Refresh | replace the (possibly out-dated) instance of the contained type with an appropriate read only instance from the ArtifactCache
SetRights |
ToString | Delegate ToString() to com.starteam.Item.Type.WebCacheItemType.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components
Update | Save this dirty Type to the Repository Unlike the rest of the sdk objects, types are created from a single parameter, namely an XML string. This is an atomic operation, not executed in a transaction

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType Properties

The properties of the Item.Type.WebCacheItemType class are listed below. For a complete list of Item.Type.WebCacheItemType class members, see the Item.Type.WebCacheItemType Members topic.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog | [read] the Catalog for this type
ComponentGUID | [read] the Component GUID of this type
Context | [read] the context of this object.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [read/write] a display name for this type.
DisplayNameTranslations | [read]
Filters | [read] the set of filters
ID | [read] the class ID for this type.
Identifier | [read] the integer identifier value of the identifier property
IdentifierProperty | [read] the identifier property for this item type
IsEnabled | [read/write] true if this type is enabled
IsNew | [read] true if this is a new type
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name |
NameProperty |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries | [read] the set of queries
SecondaryDescriptor | [read] The secondary descriptor of this type, or null if this type has no secondary descriptor.
Server | [read] the Server for this cached object
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.AssignableProperty Property

[read] a user property if this type is assignable or NULL

public virtual Property.WebCacheProperty AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Catalog Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.Catalog Property

[read] the Catalog for this type

new public virtual Catalog.WebCacheCatalog Catalog {get;}

Property Value

the Catalog for this type

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


ComponentGUID Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.ComponentGUID Property

[read] the Component GUID of this type

new public virtual GUID ComponentGUID {get;}

Property Value

the Component GUID of this type

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

public virtual TextProperty.WebCacheTextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.DisplayName Property

[read/write] a display name for this type.

new public virtual String DisplayName {get; set;}

Property Value

a display name for this type.

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.DisplayNameTranslations Property

[read]

new public virtual Translations DisplayNameTranslations {get;}

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Filters Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.Filters Property

[read] the set of filters

new public virtual WebCacheFilter[] Filters {get;}

Property Value

the set of filters

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.ID Property

[read] the class ID for this type.

new public virtual Int32 ID {get;}

Property Value

the class ID for this type.

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.Identifier Property

[read] the integer identifier value of the identifier property

public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of the identifier property

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.IdentifierProperty Property

[read] the identifier property for this item type

public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.IsEnabled Property

[read/write] true if this type is enabled

public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.IsNew Property

[read] true if this is a new type

public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.Name Property

new public virtual String Name {get;}

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


PrimaryDescriptor Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.PrimaryDescriptor Property

[read] The primary descriptor of this type, or null if this type has no primary descriptor.

new public virtual Property.WebCacheProperty PrimaryDescriptor {get;}

Property Value

The primary descriptor of this type, or null if this type has no primary descriptor.

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

public virtual Property.WebCacheProperty PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.Properties Property

[read] an array of all properties belonging to this type.

new public virtual WebCacheProperty[] Properties {get;}

Property Value

an array of all properties belonging to this type.

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.PropertiesEx Property

[write]

public virtual WebCacheProperty[] PropertiesEx {set;}

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Queries Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.Queries Property

[read] the set of queries

new public virtual WebCacheQuery[] Queries {get;}

Property Value

the set of queries

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


SecondaryDescriptor Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.SecondaryDescriptor Property

[read] The secondary descriptor of this type, or null if this type has no secondary descriptor.

new public virtual Property.WebCacheProperty SecondaryDescriptor {get;}

Property Value

The secondary descriptor of this type, or null if this type has no secondary descriptor.

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

public virtual EnumeratedProperty.WebCacheEnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

public virtual Property.WebCacheProperty SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

public virtual TextProperty.WebCacheTextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType Methods

The methods of the Item.Type.WebCacheItemType class are listed below. For a complete list of Item.Type.WebCacheItemType class members, see the Item.Type.WebCacheItemType Members topic.

Public Static Methods

Create
FromXml

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Item.Type.WebCacheItemType.
FindFilter | Overloaded. find a Filter by ID, visible in the user context
FindProperty | Overloaded. Find and return a property by int iD
FindQuery | Overloaded. find a Query by ID, visible in the user context
GetHashCode | Delegate GetHashCode() to com.starteam.Item.Type.WebCacheItemType.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
NewBooleanProperty | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty | Creates a new DateProperty
NewDateTimeProperty | Creates a new DateTimeProperty
NewDoubleProperty | Creates a new DoubleProperty
NewEnumeratedProperty | Create a new Enumerated Property
NewGroupArrayProperty | Creates a property on the server.
NewGroupProperty | Creates a property on the server.
NewIntegerProperty | Creates a new IntegerProperty
NewLongIntegerProperty | Creates a new LongIntegerProperty. The new property is dirty; to save changes, you must call Property.update().
NewMapProperty | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewTextProperty | Creates a new TextProperty
NewTimeSpanProperty | Creates a new TimeSpanProperty
NewUserArrayProperty | Creates a property on the server.
NewUserProperty | Creates a property on the server.
NewWebCacheFilterEventSource (inherited from WebCacheType) |
NewWebCacheQueryEventSource (inherited from WebCacheType) |
Refresh | replace the (possibly out-dated) instance of the contained type with an appropriate read only instance from the ArtifactCache
SetRights |
ToString | Delegate ToString() to com.starteam.Item.Type.WebCacheItemType.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components
Update | Save this dirty Type to the Repository Unlike the rest of the sdk objects, types are created from a single parameter, namely an XML string. This is an atomic operation, not executed in a transaction

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.Create Method

public static WebCacheItemType Create(
ArtifactCacheManager.Context cntxt,
String name
);

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.Equals Method

Delegate Equals() to com.starteam.Item.Type.WebCacheItemType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.Type.WebCacheItemType.Equals(obj).

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


FindFilter Method

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.FindFilter Method

find a Filter by ID, visible in the user context

Overload List

find a Filter by ID, visible in the user context

new public virtual WebCacheFilter FindFilter(Int32);

find a Filter by name, visible in the user context

new public virtual WebCacheFilter FindFilter(String);

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.FindFilter Method (Int32)

find a Filter by ID, visible in the user context

new public virtual WebCacheFilter FindFilter(
Int32 filterID
);

Parameters

filterID
the ID

Return Value

a filter with the specified ID or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace | Item.Type.WebCacheItemType.FindFilter Overload List


Item.Type.WebCacheItemType.FindFilter Method (String)

find a Filter by name, visible in the user context

new public virtual WebCacheFilter FindFilter(
String filterName
);

Parameters

filterName
the name

Return Value

a filter with the specified name or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace | Item.Type.WebCacheItemType.FindFilter Overload List


FindProperty Method

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.FindProperty Method

Find and return a property by int iD

Overload List

Find and return a property by int iD

new public virtual WebCacheProperty FindProperty(Int32);

Find and return a property by name

new public virtual WebCacheProperty FindProperty(String);

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.FindProperty Method (Int32)

Find and return a property by int iD

new public virtual WebCacheProperty FindProperty(
Int32 propertyID
);

Parameters

propertyID
the integer ID of the property

Return Value

a property with the given ID or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace | Item.Type.WebCacheItemType.FindProperty Overload List


Item.Type.WebCacheItemType.FindProperty Method (String)

Find and return a property by name

new public virtual WebCacheProperty FindProperty(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

a property with the given name or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace | Item.Type.WebCacheItemType.FindProperty Overload List


FindQuery Method

Borland StarTeam SDK for .NET

Item.Type.WebCacheItemType.FindQuery Method

find a Query by ID, visible in the user context

Overload List

find a Query by ID, visible in the user context

new public virtual WebCacheQuery FindQuery(Int32);

find a Query by name, visible in the user context

new public virtual WebCacheQuery FindQuery(String);

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.FindQuery Method (Int32)

find a Query by ID, visible in the user context

new public virtual WebCacheQuery FindQuery(
Int32 queryID
);

Parameters

queryID
the ID

Return Value

a query with the specified ID or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace | Item.Type.WebCacheItemType.FindQuery Overload List


Item.Type.WebCacheItemType.FindQuery Method (String)

find a Query by name, visible in the user context

new public virtual WebCacheQuery FindQuery(
String queryName
);

Parameters

queryName
the name

Return Value

a query with the specified name or NULL

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace | Item.Type.WebCacheItemType.FindQuery Overload List


Item.Type.WebCacheItemType.FromXml Method

public static WebCacheItemType FromXml(
ArtifactCacheManager.Context cntxt,
String xmlDefinition
);

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.Type.WebCacheItemType.

public override int GetHashCode();

Return Value

com.starteam.Item.Type.WebCacheItemType.GetHashCode().

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.GetRights Method

new public virtual WebCacheACE[] GetRights(
Type.WebCacheType typ
);

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewBooleanProperty Method

Create a new Boolean Property Assigns default display names such that 0=False and 1=True.

new public virtual WebCacheBooleanProperty NewBooleanProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new BooleanProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewContentProperty Method

Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().

new public virtual WebCacheContentProperty NewContentProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new ContentProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewDateProperty Method

Creates a new DateProperty

new public virtual WebCacheDateProperty NewDateProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DateProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewDateTimeProperty Method

Creates a new DateTimeProperty

new public virtual WebCacheDateTimeProperty NewDateTimeProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DateTimeProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewDoubleProperty Method

Creates a new DoubleProperty

new public virtual WebCacheDoubleProperty NewDoubleProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DoubleProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewEnumeratedProperty Method

Create a new Enumerated Property

new public virtual WebCacheEnumeratedProperty NewEnumeratedProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new EnumeratedProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewGroupArrayProperty Method

Creates a property on the server.

new public virtual WebCacheObjectArrayProperty NewGroupArrayProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewGroupProperty Method

Creates a property on the server.

new public virtual WebCacheObjectProperty NewGroupProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewIntegerProperty Method

Creates a new IntegerProperty

new public virtual WebCacheIntegerProperty NewIntegerProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new IntegerProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewLongIntegerProperty Method

Creates a new LongIntegerProperty. The new property is dirty; to save changes, you must call Property.update().

new public virtual WebCacheLongIntegerProperty NewLongIntegerProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new LongIntegerProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewMapProperty Method

Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema

new public virtual WebCacheMapProperty NewMapProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new MapProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewTextProperty Method

Creates a new TextProperty

new public virtual WebCacheTextProperty NewTextProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new TextProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewTimeSpanProperty Method

Creates a new TimeSpanProperty

new public virtual WebCacheTimeSpanProperty NewTimeSpanProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new TimeSpanProperty instance

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewUserArrayProperty Method

Creates a property on the server.

new public virtual WebCacheObjectArrayProperty NewUserArrayProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.NewUserProperty Method

Creates a property on the server.

new public virtual WebCacheObjectProperty NewUserProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.Refresh Method

replace the (possibly out-dated) instance of the contained type with an appropriate read only instance from the ArtifactCache

public virtual void Refresh();

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.SetRights Method

new public virtual void SetRights(
Type.WebCacheType typ,
WebCacheACE[] aces
);

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.ToString Method

Delegate ToString() to com.starteam.Item.Type.WebCacheItemType.

public override string ToString();

Return Value

com.starteam.Item.Type.WebCacheItemType.ToString()

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components

public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.Type.WebCacheItemType.Update Method

Save this dirty Type to the Repository Unlike the rest of the sdk objects, types are created from a single parameter, namely an XML string. This is an atomic operation, not executed in a transaction

public virtual void Update();

See Also

Item.Type.WebCacheItemType Class | StarTeam Namespace


Item.WebCacheItem Class

Item accessor for cached SDK Items contained objects are obtained from the artifact cache

For a list of all members of this type, see Item.WebCacheItem Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
Derived types

public class Item.WebCacheItem : WebCacheViewMember

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Item.WebCacheItem Members | StarTeam Namespace


Item.WebCacheItem Members

Item.WebCacheItem overview

Public Static Methods

Create

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Item.WebCacheItem.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Item.WebCacheItem.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Item.WebCacheItem.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem Properties

The properties of the Item.WebCacheItem class are listed below. For a complete list of Item.WebCacheItem class members, see the Item.WebCacheItem Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

Item.WebCacheItem Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Item.WebCacheItem Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ChangePackages Property

[read] the Change Packages linked to this process item

public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Item.WebCacheItem Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Item.WebCacheItem Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Item.WebCacheItem Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Item.WebCacheItem Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Item.WebCacheItem Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Item.WebCacheItem Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Item.WebCacheItem Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Item.WebCacheItem Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Item.WebCacheItem Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Item.WebCacheItem Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Item.WebCacheItem Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Item.WebCacheItem Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Item.WebCacheItem Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Identifier Property

[read] the integer identifier value of this live object instance

public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Item.WebCacheItem Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.IdentifierProperty Property

[read] the identifier property for this item type

public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Item.WebCacheItem Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Item.WebCacheItem Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Item.WebCacheItem Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Item.WebCacheItem Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Item.WebCacheItem Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Item.WebCacheItem Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Item.WebCacheItem Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Item.WebCacheItem Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Item.WebCacheItem Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Item.WebCacheItem Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Item.WebCacheItem Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Item.WebCacheItem Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Item.WebCacheItem Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Item.WebCacheItem Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Item.WebCacheItem Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Name Property

new public virtual String Name {get;}

See Also

Item.WebCacheItem Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Item.WebCacheItem Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.NotifiedUsers Property

[read] The users who are notified.

public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Item.WebCacheItem Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Item.WebCacheItem Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ParentFolder Property

[read] the folder in which this item exists.

public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Item.WebCacheItem Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Item.WebCacheItem Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Item.WebCacheItem Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Item.WebCacheItem Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Item.WebCacheItem Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Item.WebCacheItem Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Item.WebCacheItem Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Item.WebCacheItem Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Item.WebCacheItem Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Item.WebCacheItem Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Item.WebCacheItem Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Item.WebCacheItem Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Item.WebCacheItem.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem Methods

The methods of the Item.WebCacheItem class are listed below. For a complete list of Item.WebCacheItem class members, see the Item.WebCacheItem Members topic.

Public Static Methods

Create

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Item.WebCacheItem.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Item.WebCacheItem.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Item.WebCacheItem.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.AddNotifiedUser Method

public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.Copy Method

public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.Create Method

public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.Equals Method

Delegate Equals() to com.starteam.Item.WebCacheItem.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Item.WebCacheItem.Equals(obj).

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.GetHashCode Method

Delegate GetHashCode() to com.starteam.Item.WebCacheItem.

public override int GetHashCode();

Return Value

com.starteam.Item.WebCacheItem.GetHashCode().

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Item.WebCacheItem.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Item.WebCacheItem Class | StarTeam Namespace | Item.WebCacheItem.GetValue Overload List


Item.WebCacheItem.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Item.WebCacheItem Class | StarTeam Namespace | Item.WebCacheItem.GetValue Overload List


Item.WebCacheItem.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Item.WebCacheItem.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Item.WebCacheItem Class | StarTeam Namespace | WebCacheViewMemberCollection


Item.WebCacheItem.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Item.WebCacheItem Class | StarTeam Namespace | Item.WebCacheItem.Lock Overload List | WebCacheViewMemberCollection


Item.WebCacheItem.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Item.WebCacheItem Class | StarTeam Namespace | Item.WebCacheItem.Lock Overload List


Item.WebCacheItem.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Item.WebCacheItem Class | StarTeam Namespace | NAME


Item.WebCacheItem.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Item.WebCacheItem Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Item.WebCacheItem.MoveTo Method

Overload List

public virtual void MoveTo(Folder.WebCacheFolder);

public virtual void MoveTo(View.WebCacheView);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.MoveTo Method (Folder#WebCacheFolder)

public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Item.WebCacheItem Class | StarTeam Namespace | Item.WebCacheItem.MoveTo Overload List


Item.WebCacheItem.MoveTo Method (View#WebCacheView)

public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Item.WebCacheItem Class | StarTeam Namespace | Item.WebCacheItem.MoveTo Overload List


Item.WebCacheItem.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Item.WebCacheItem Class | StarTeam Namespace | isFloating | isPinned | unpin


Item.WebCacheItem.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Item.WebCacheItem Class | StarTeam Namespace | WebCacheViewMemberCollection


Item.WebCacheItem.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.RemoveNotifiedUser Method

public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Item.WebCacheItem.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Item.WebCacheItem Class | StarTeam Namespace | Item.WebCacheItem.SetValue Overload List


Item.WebCacheItem.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Item.WebCacheItem Class | StarTeam Namespace | Item.WebCacheItem.SetValue Overload List


Item.WebCacheItem.ShareTo Method

public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.ToString Method

Delegate ToString() to com.starteam.Item.WebCacheItem.

public override string ToString();

Return Value

com.starteam.Item.WebCacheItem.ToString()

See Also

Item.WebCacheItem Class | StarTeam Namespace


Item.WebCacheItem.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Item.WebCacheItem Class | StarTeam Namespace | WebCacheViewMemberCollection


Item.WebCacheItem.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Item.WebCacheItem Class | StarTeam Namespace | isFloating | isPinned | pinTo


Item.WebCacheItem.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Item.WebCacheItem Class | StarTeam Namespace | WebCacheViewMemberCollection


Item.WebCacheItem.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Item.WebCacheItem Class | StarTeam Namespace


KanbanBoard Class

A KanbanBoard is a process

For a list of all members of this type, see KanbanBoard Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
KanbanBoard

public class KanbanBoard : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard Members | StarTeam Namespace


KanbanBoard Members

KanbanBoard overview

Public Static Methods

Create Create a KanbanBoard in the specified parent folder.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EnforceAge | [read/write] A value indicating whether or not this this board enforces Age
EnforceWIP | [read/write] A value indicating whether or not this this board enforces WIP
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
InboxLane | [read/write] the InboxLane of this KanbanBoard.
InputID | [read/write] the input id.
InputTypeValue | [read/write] input type used for this plan
InTeamRoom | [read/write] A value indicating whether or not this this board is in a team room
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemTypeValue | [read/write] item type used for this plan
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this KanbanBoard.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

KanbanBoard Class | StarTeam Namespace


KanbanBoard Properties

The properties of the KanbanBoard class are listed below. For a complete list of KanbanBoard class members, see the KanbanBoard Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EnforceAge | [read/write] A value indicating whether or not this this board enforces Age
EnforceWIP | [read/write] A value indicating whether or not this this board enforces WIP
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
InboxLane | [read/write] the InboxLane of this KanbanBoard.
InputID | [read/write] the input id.
InputTypeValue | [read/write] input type used for this plan
InTeamRoom | [read/write] A value indicating whether or not this this board is in a team room
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
ItemTypeValue | [read/write] item type used for this plan
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this KanbanBoard.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

KanbanBoard Class | StarTeam Namespace


EnforceAge Property

Borland StarTeam SDK for .NET

KanbanBoard.EnforceAge Property

[read/write] A value indicating whether or not this this board enforces Age

public virtual Boolean EnforceAge {get; set;}

Property Value

A value indicating whether or not this this board enforces Age

See Also

KanbanBoard Class | StarTeam Namespace


EnforceWIP Property

Borland StarTeam SDK for .NET

KanbanBoard.EnforceWIP Property

[read/write] A value indicating whether or not this this board enforces WIP

public virtual Boolean EnforceWIP {get; set;}

Property Value

A value indicating whether or not this this board enforces WIP

See Also

KanbanBoard Class | StarTeam Namespace


InboxLane Property

Borland StarTeam SDK for .NET

KanbanBoard.InboxLane Property

[read/write] the InboxLane of this KanbanBoard.

public virtual String InboxLane {get; set;}

Property Value

the InboxLane of this KanbanBoard.

See Also

KanbanBoard Class | StarTeam Namespace


InputID Property

Borland StarTeam SDK for .NET

KanbanBoard.InputID Property

[read/write] the input id.

public virtual Int32 InputID {get; set;}

Property Value

the input id.

See Also

KanbanBoard Class | StarTeam Namespace


InputTypeValue Property

Borland StarTeam SDK for .NET

KanbanBoard.InputTypeValue Property

[read/write] input type used for this plan

public virtual KanbanBoard.InputType InputTypeValue {get; set;}

Property Value

input type used for this plan

See Also

KanbanBoard Class | StarTeam Namespace


InTeamRoom Property

Borland StarTeam SDK for .NET

KanbanBoard.InTeamRoom Property

[read/write] A value indicating whether or not this this board is in a team room

public virtual Boolean InTeamRoom {get; set;}

Property Value

A value indicating whether or not this this board is in a team room

See Also

KanbanBoard Class | StarTeam Namespace


ItemTypeValue Property

Borland StarTeam SDK for .NET

KanbanBoard.ItemTypeValue Property

[read/write] item type used for this plan

public virtual KanbanBoard.ItemType ItemTypeValue {get; set;}

Property Value

item type used for this plan

See Also

KanbanBoard Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

KanbanBoard.Name Property

[read/write] the Name of this KanbanBoard.

public virtual String Name {get; set;}

Property Value

the Name of this KanbanBoard.

See Also

KanbanBoard Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

KanbanBoard.Properties Property

[read] the PropertyCollection of its Type

public virtual KanbanBoard.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

KanbanBoard Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

KanbanBoard.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

KanbanBoard Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

KanbanBoard.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

KanbanBoard Class | StarTeam Namespace


KanbanBoard Methods

The methods of the KanbanBoard class are listed below. For a complete list of KanbanBoard class members, see the KanbanBoard Members topic.

Public Static Methods

Create Create a KanbanBoard in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

KanbanBoard Class | StarTeam Namespace


KanbanBoard.Create Method

Create a KanbanBoard in the specified parent folder.

public static KanbanBoard Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new KanbanBoard Object.

See Also

KanbanBoard Class | StarTeam Namespace


KanbanBoard.InputType Class

The type of the board according to kanban terminology.

For a list of all members of this type, see KanbanBoard.InputType Members.

System.Object
EnumeratedValue
KanbanBoard.InputType

public class KanbanBoard.InputType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.InputType Members | StarTeam Namespace


KanbanBoard.InputType Members

KanbanBoard.InputType overview

Public Static Properties

ALL
FILTER
PLAN
SPRINT

Public Static Methods

FromID | Gets the input type corresponding to the given ID.
FromValue | Gets the InputType corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.KanbanBoard.InputType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.InputType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.KanbanBoard.InputType.

See Also

KanbanBoard.InputType Class | StarTeam Namespace


KanbanBoard.InputType Properties

The properties of the KanbanBoard.InputType class are listed below. For a complete list of KanbanBoard.InputType class members, see the KanbanBoard.InputType Members topic.

Public Static Properties

ALL
FILTER
PLAN
SPRINT

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

KanbanBoard.InputType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

KanbanBoard.InputType.ALL Property

public static InputType[] ALL {get;}

See Also

KanbanBoard.InputType Class | StarTeam Namespace


FILTER Property

Borland StarTeam SDK for .NET

KanbanBoard.InputType.FILTER Property

public static KanbanBoard.InputType FILTER {get;}

Property Value

Specifies a filter type.

See Also

KanbanBoard.InputType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

KanbanBoard.InputType.ID Property

[read] the ID of this Type value.

public virtual Int32 ID {get;}

Property Value

the ID of this Type value.

See Also

KanbanBoard.InputType Class | StarTeam Namespace


PLAN Property

Borland StarTeam SDK for .NET

KanbanBoard.InputType.PLAN Property

public static KanbanBoard.InputType PLAN {get;}

Property Value

Describes a Plan.

See Also

KanbanBoard.InputType Class | StarTeam Namespace


SPRINT Property

Borland StarTeam SDK for .NET

KanbanBoard.InputType.SPRINT Property

public static KanbanBoard.InputType SPRINT {get;}

Property Value

Describes a Sprint.

See Also

KanbanBoard.InputType Class | StarTeam Namespace


KanbanBoard.InputType Methods

The methods of the KanbanBoard.InputType class are listed below. For a complete list of KanbanBoard.InputType class members, see the KanbanBoard.InputType Members topic.

Public Static Methods

FromID | Gets the input type corresponding to the given ID.
FromValue | Gets the InputType corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.KanbanBoard.InputType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.InputType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.KanbanBoard.InputType.

See Also

KanbanBoard.InputType Class | StarTeam Namespace


KanbanBoard.InputType.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.InputType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.InputType.Equals(obj).

See Also

KanbanBoard.InputType Class | StarTeam Namespace


KanbanBoard.InputType.FromID Method

Gets the input type corresponding to the given ID.

public static InputType FromID(
Int32 id
);

Parameters

id
A InputType ID.

Return Value

the corresponding InputType Type, or null.

See Also

KanbanBoard.InputType Class | StarTeam Namespace


KanbanBoard.InputType.FromValue Method

Gets the InputType corresponding to the given EnumeratedValue.

public static InputType FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a InputTypeProperty.

Return Value

the corresponding InputType value, or null.

See Also

KanbanBoard.InputType Class | StarTeam Namespace


KanbanBoard.InputType.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.InputType.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.InputType.GetHashCode().

See Also

KanbanBoard.InputType Class | StarTeam Namespace


KanbanBoard.InputType.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.InputType.

public override string ToString();

Return Value

com.starteam.KanbanBoard.InputType.ToString()

See Also

KanbanBoard.InputType Class | StarTeam Namespace


KanbanBoard.ItemType Class

The type of the board according to kanban terminology.

For a list of all members of this type, see KanbanBoard.ItemType Members.

System.Object
EnumeratedValue
KanbanBoard.ItemType

public class KanbanBoard.ItemType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.ItemType Members | StarTeam Namespace


KanbanBoard.ItemType Members

KanbanBoard.ItemType overview

Public Static Properties

ALL
STORY

Public Static Methods

FromID | Gets the item type corresponding to the given ID.
FromValue | Gets the ItemType corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.KanbanBoard.ItemType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.ItemType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.KanbanBoard.ItemType.

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


KanbanBoard.ItemType Properties

The properties of the KanbanBoard.ItemType class are listed below. For a complete list of KanbanBoard.ItemType class members, see the KanbanBoard.ItemType Members topic.

Public Static Properties

ALL
STORY

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

KanbanBoard.ItemType.ALL Property

public static ItemType[] ALL {get;}

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

KanbanBoard.ItemType.ID Property

[read] the ID of this Type value.

public virtual Int32 ID {get;}

Property Value

the ID of this Type value.

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


STORY Property

Borland StarTeam SDK for .NET

KanbanBoard.ItemType.STORY Property

public static KanbanBoard.ItemType STORY {get;}

Property Value

Specifies a story type.

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


KanbanBoard.ItemType Methods

The methods of the KanbanBoard.ItemType class are listed below. For a complete list of KanbanBoard.ItemType class members, see the KanbanBoard.ItemType Members topic.

Public Static Methods

FromID | Gets the item type corresponding to the given ID.
FromValue | Gets the ItemType corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.KanbanBoard.ItemType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.ItemType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.KanbanBoard.ItemType.

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


KanbanBoard.ItemType.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.ItemType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.ItemType.Equals(obj).

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


KanbanBoard.ItemType.FromID Method

Gets the item type corresponding to the given ID.

public static ItemType FromID(
Int32 id
);

Parameters

id
A ItemType ID.

Return Value

the corresponding ItemType Type, or null.

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


KanbanBoard.ItemType.FromValue Method

Gets the ItemType corresponding to the given EnumeratedValue.

public static ItemType FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a ItemTypeProperty.

Return Value

the corresponding ItemType value, or null.

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


KanbanBoard.ItemType.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.ItemType.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.ItemType.GetHashCode().

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


KanbanBoard.ItemType.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.ItemType.

public override string ToString();

Return Value

com.starteam.KanbanBoard.ItemType.ToString()

See Also

KanbanBoard.ItemType Class | StarTeam Namespace


KanbanBoard.Type Class

Type meta-data (schema) for KanbanBoard object instances.

For a list of all members of this type, see KanbanBoard.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
KanbanBoard.Type

new public class KanbanBoard.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.Type Members | StarTeam Namespace


KanbanBoard.Type Members

KanbanBoard.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type Properties

The properties of the KanbanBoard.Type class are listed below. For a complete list of KanbanBoard.Type class members, see the KanbanBoard.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

KanbanBoard.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

KanbanBoard.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

KanbanBoard.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

KanbanBoard.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

KanbanBoard.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

KanbanBoard.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

KanbanBoard.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

KanbanBoard.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.NAME Property

new public static String NAME {get;}

See Also

KanbanBoard.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

KanbanBoard.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

KanbanBoard.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

KanbanBoard.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

KanbanBoard.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type Methods

The methods of the KanbanBoard.Type class are listed below. For a complete list of KanbanBoard.Type class members, see the KanbanBoard.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.Type.Equals(obj).

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.Type.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.Type.GetHashCode().

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.Type.

public override string ToString();

Return Value

com.starteam.KanbanBoard.Type.ToString()

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

KanbanBoard.Type Class | StarTeam Namespace


KanbanBoard.Type.EnforceAgeProperty Class

The property type of the EnforceAge property.

For a list of all members of this type, see KanbanBoard.Type.EnforceAgeProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
KanbanBoard.Type.EnforceAgeProperty

public class KanbanBoard.Type.EnforceAgeProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.Type.EnforceAgeProperty Members | StarTeam Namespace


KanbanBoard.Type.EnforceAgeProperty Members

KanbanBoard.Type.EnforceAgeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.EnforceAgeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.EnforceAgeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.EnforceAgeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.EnforceAgeProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceAgeProperty Properties

The properties of the KanbanBoard.Type.EnforceAgeProperty class are listed below. For a complete list of KanbanBoard.Type.EnforceAgeProperty class members, see the KanbanBoard.Type.EnforceAgeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

KanbanBoard.Type.EnforceAgeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.EnforceAgeProperty.NAME Property

public static String NAME {get;}

See Also

KanbanBoard.Type.EnforceAgeProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceAgeProperty Methods

The methods of the KanbanBoard.Type.EnforceAgeProperty class are listed below. For a complete list of KanbanBoard.Type.EnforceAgeProperty class members, see the KanbanBoard.Type.EnforceAgeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.EnforceAgeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.EnforceAgeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.EnforceAgeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.EnforceAgeProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceAgeProperty.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.Type.EnforceAgeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.Type.EnforceAgeProperty.Equals(obj).

See Also

KanbanBoard.Type.EnforceAgeProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceAgeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.Type.EnforceAgeProperty.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.Type.EnforceAgeProperty.GetHashCode().

See Also

KanbanBoard.Type.EnforceAgeProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceAgeProperty.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.Type.EnforceAgeProperty.

public override string ToString();

Return Value

com.starteam.KanbanBoard.Type.EnforceAgeProperty.ToString()

See Also

KanbanBoard.Type.EnforceAgeProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceWIPProperty Class

The property type of the EnforceWIP property.

For a list of all members of this type, see KanbanBoard.Type.EnforceWIPProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
KanbanBoard.Type.EnforceWIPProperty

public class KanbanBoard.Type.EnforceWIPProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.Type.EnforceWIPProperty Members | StarTeam Namespace


KanbanBoard.Type.EnforceWIPProperty Members

KanbanBoard.Type.EnforceWIPProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.EnforceWIPProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.EnforceWIPProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.EnforceWIPProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.EnforceWIPProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceWIPProperty Properties

The properties of the KanbanBoard.Type.EnforceWIPProperty class are listed below. For a complete list of KanbanBoard.Type.EnforceWIPProperty class members, see the KanbanBoard.Type.EnforceWIPProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

KanbanBoard.Type.EnforceWIPProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.EnforceWIPProperty.NAME Property

public static String NAME {get;}

See Also

KanbanBoard.Type.EnforceWIPProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceWIPProperty Methods

The methods of the KanbanBoard.Type.EnforceWIPProperty class are listed below. For a complete list of KanbanBoard.Type.EnforceWIPProperty class members, see the KanbanBoard.Type.EnforceWIPProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.EnforceWIPProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.EnforceWIPProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.EnforceWIPProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.EnforceWIPProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceWIPProperty.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.Type.EnforceWIPProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.Type.EnforceWIPProperty.Equals(obj).

See Also

KanbanBoard.Type.EnforceWIPProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceWIPProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.Type.EnforceWIPProperty.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.Type.EnforceWIPProperty.GetHashCode().

See Also

KanbanBoard.Type.EnforceWIPProperty Class | StarTeam Namespace


KanbanBoard.Type.EnforceWIPProperty.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.Type.EnforceWIPProperty.

public override string ToString();

Return Value

com.starteam.KanbanBoard.Type.EnforceWIPProperty.ToString()

See Also

KanbanBoard.Type.EnforceWIPProperty Class | StarTeam Namespace


KanbanBoard.Type.InboxLaneProperty Class

The property type of the InboxLane property

For a list of all members of this type, see KanbanBoard.Type.InboxLaneProperty Members.

System.Object
Property
VectorProperty
TextProperty
KanbanBoard.Type.InboxLaneProperty

public class KanbanBoard.Type.InboxLaneProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.Type.InboxLaneProperty Members | StarTeam Namespace


KanbanBoard.Type.InboxLaneProperty Members

KanbanBoard.Type.InboxLaneProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.InboxLaneProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InboxLaneProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.InboxLaneProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.InboxLaneProperty Class | StarTeam Namespace


KanbanBoard.Type.InboxLaneProperty Properties

The properties of the KanbanBoard.Type.InboxLaneProperty class are listed below. For a complete list of KanbanBoard.Type.InboxLaneProperty class members, see the KanbanBoard.Type.InboxLaneProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

KanbanBoard.Type.InboxLaneProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.InboxLaneProperty.NAME Property

public static String NAME {get;}

See Also

KanbanBoard.Type.InboxLaneProperty Class | StarTeam Namespace


KanbanBoard.Type.InboxLaneProperty Methods

The methods of the KanbanBoard.Type.InboxLaneProperty class are listed below. For a complete list of KanbanBoard.Type.InboxLaneProperty class members, see the KanbanBoard.Type.InboxLaneProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.InboxLaneProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InboxLaneProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.InboxLaneProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.InboxLaneProperty Class | StarTeam Namespace


KanbanBoard.Type.InboxLaneProperty.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.Type.InboxLaneProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.Type.InboxLaneProperty.Equals(obj).

See Also

KanbanBoard.Type.InboxLaneProperty Class | StarTeam Namespace


KanbanBoard.Type.InboxLaneProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InboxLaneProperty.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.Type.InboxLaneProperty.GetHashCode().

See Also

KanbanBoard.Type.InboxLaneProperty Class | StarTeam Namespace


KanbanBoard.Type.InboxLaneProperty.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.Type.InboxLaneProperty.

public override string ToString();

Return Value

com.starteam.KanbanBoard.Type.InboxLaneProperty.ToString()

See Also

KanbanBoard.Type.InboxLaneProperty Class | StarTeam Namespace


KanbanBoard.Type.InputIDProperty Class

The property type of the InputId property

For a list of all members of this type, see KanbanBoard.Type.InputIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
KanbanBoard.Type.InputIDProperty

public class KanbanBoard.Type.InputIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.Type.InputIDProperty Members | StarTeam Namespace


KanbanBoard.Type.InputIDProperty Members

KanbanBoard.Type.InputIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.InputIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InputIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.InputIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.InputIDProperty Class | StarTeam Namespace


KanbanBoard.Type.InputIDProperty Properties

The properties of the KanbanBoard.Type.InputIDProperty class are listed below. For a complete list of KanbanBoard.Type.InputIDProperty class members, see the KanbanBoard.Type.InputIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

KanbanBoard.Type.InputIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.InputIDProperty.NAME Property

public static String NAME {get;}

See Also

KanbanBoard.Type.InputIDProperty Class | StarTeam Namespace


KanbanBoard.Type.InputIDProperty Methods

The methods of the KanbanBoard.Type.InputIDProperty class are listed below. For a complete list of KanbanBoard.Type.InputIDProperty class members, see the KanbanBoard.Type.InputIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.InputIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InputIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.InputIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.InputIDProperty Class | StarTeam Namespace


KanbanBoard.Type.InputIDProperty.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.Type.InputIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.Type.InputIDProperty.Equals(obj).

See Also

KanbanBoard.Type.InputIDProperty Class | StarTeam Namespace


KanbanBoard.Type.InputIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InputIDProperty.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.Type.InputIDProperty.GetHashCode().

See Also

KanbanBoard.Type.InputIDProperty Class | StarTeam Namespace


KanbanBoard.Type.InputIDProperty.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.Type.InputIDProperty.

public override string ToString();

Return Value

com.starteam.KanbanBoard.Type.InputIDProperty.ToString()

See Also

KanbanBoard.Type.InputIDProperty Class | StarTeam Namespace


KanbanBoard.Type.InputTypeProperty Class

The property type of the InputType property.

For a list of all members of this type, see KanbanBoard.Type.InputTypeProperty Members.

System.Object
Property
EnumeratedProperty
KanbanBoard.Type.InputTypeProperty

public class KanbanBoard.Type.InputTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.Type.InputTypeProperty Members | StarTeam Namespace


KanbanBoard.Type.InputTypeProperty Members

KanbanBoard.Type.InputTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.InputTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InputTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.InputTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.InputTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.InputTypeProperty Properties

The properties of the KanbanBoard.Type.InputTypeProperty class are listed below. For a complete list of KanbanBoard.Type.InputTypeProperty class members, see the KanbanBoard.Type.InputTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

KanbanBoard.Type.InputTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.InputTypeProperty.NAME Property

public static String NAME {get;}

See Also

KanbanBoard.Type.InputTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.InputTypeProperty Methods

The methods of the KanbanBoard.Type.InputTypeProperty class are listed below. For a complete list of KanbanBoard.Type.InputTypeProperty class members, see the KanbanBoard.Type.InputTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.InputTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InputTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.InputTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.InputTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.InputTypeProperty.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.Type.InputTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.Type.InputTypeProperty.Equals(obj).

See Also

KanbanBoard.Type.InputTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.InputTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
KanbanBoard.InputType value
);

See Also

KanbanBoard.Type.InputTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.InputTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InputTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.Type.InputTypeProperty.GetHashCode().

See Also

KanbanBoard.Type.InputTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.InputTypeProperty.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.Type.InputTypeProperty.

public override string ToString();

Return Value

com.starteam.KanbanBoard.Type.InputTypeProperty.ToString()

See Also

KanbanBoard.Type.InputTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.InTeamRoomProperty Class

The property type of the EnforceAge property.

For a list of all members of this type, see KanbanBoard.Type.InTeamRoomProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
KanbanBoard.Type.InTeamRoomProperty

public class KanbanBoard.Type.InTeamRoomProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.Type.InTeamRoomProperty Members | StarTeam Namespace


KanbanBoard.Type.InTeamRoomProperty Members

KanbanBoard.Type.InTeamRoomProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.InTeamRoomProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InTeamRoomProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.InTeamRoomProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.InTeamRoomProperty Class | StarTeam Namespace


KanbanBoard.Type.InTeamRoomProperty Properties

The properties of the KanbanBoard.Type.InTeamRoomProperty class are listed below. For a complete list of KanbanBoard.Type.InTeamRoomProperty class members, see the KanbanBoard.Type.InTeamRoomProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

KanbanBoard.Type.InTeamRoomProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.InTeamRoomProperty.NAME Property

public static String NAME {get;}

See Also

KanbanBoard.Type.InTeamRoomProperty Class | StarTeam Namespace


KanbanBoard.Type.InTeamRoomProperty Methods

The methods of the KanbanBoard.Type.InTeamRoomProperty class are listed below. For a complete list of KanbanBoard.Type.InTeamRoomProperty class members, see the KanbanBoard.Type.InTeamRoomProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.InTeamRoomProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InTeamRoomProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.InTeamRoomProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.InTeamRoomProperty Class | StarTeam Namespace


KanbanBoard.Type.InTeamRoomProperty.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.Type.InTeamRoomProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.Type.InTeamRoomProperty.Equals(obj).

See Also

KanbanBoard.Type.InTeamRoomProperty Class | StarTeam Namespace


KanbanBoard.Type.InTeamRoomProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.Type.InTeamRoomProperty.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.Type.InTeamRoomProperty.GetHashCode().

See Also

KanbanBoard.Type.InTeamRoomProperty Class | StarTeam Namespace


KanbanBoard.Type.InTeamRoomProperty.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.Type.InTeamRoomProperty.

public override string ToString();

Return Value

com.starteam.KanbanBoard.Type.InTeamRoomProperty.ToString()

See Also

KanbanBoard.Type.InTeamRoomProperty Class | StarTeam Namespace


KanbanBoard.Type.ItemTypeProperty Class

The property type of the ItemType property.

For a list of all members of this type, see KanbanBoard.Type.ItemTypeProperty Members.

System.Object
Property
EnumeratedProperty
KanbanBoard.Type.ItemTypeProperty

public class KanbanBoard.Type.ItemTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.Type.ItemTypeProperty Members | StarTeam Namespace


KanbanBoard.Type.ItemTypeProperty Members

KanbanBoard.Type.ItemTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.ItemTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.ItemTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.ItemTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.ItemTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.ItemTypeProperty Properties

The properties of the KanbanBoard.Type.ItemTypeProperty class are listed below. For a complete list of KanbanBoard.Type.ItemTypeProperty class members, see the KanbanBoard.Type.ItemTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

KanbanBoard.Type.ItemTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.ItemTypeProperty.NAME Property

public static String NAME {get;}

See Also

KanbanBoard.Type.ItemTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.ItemTypeProperty Methods

The methods of the KanbanBoard.Type.ItemTypeProperty class are listed below. For a complete list of KanbanBoard.Type.ItemTypeProperty class members, see the KanbanBoard.Type.ItemTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.ItemTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.ItemTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.ItemTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

KanbanBoard.Type.ItemTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.ItemTypeProperty.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.Type.ItemTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.Type.ItemTypeProperty.Equals(obj).

See Also

KanbanBoard.Type.ItemTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.ItemTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
KanbanBoard.ItemType value
);

See Also

KanbanBoard.Type.ItemTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.ItemTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.Type.ItemTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.Type.ItemTypeProperty.GetHashCode().

See Also

KanbanBoard.Type.ItemTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.ItemTypeProperty.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.Type.ItemTypeProperty.

public override string ToString();

Return Value

com.starteam.KanbanBoard.Type.ItemTypeProperty.ToString()

See Also

KanbanBoard.Type.ItemTypeProperty Class | StarTeam Namespace


KanbanBoard.Type.PropertyCollection Class

The PropertyCollection of a KanbanBoard

For a list of all members of this type, see KanbanBoard.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
KanbanBoard.Type.PropertyCollection

new public class KanbanBoard.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.Type.PropertyCollection Members | StarTeam Namespace


KanbanBoard.Type.PropertyCollection Members

KanbanBoard.Type.PropertyCollection overview

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
ENFORCE_AGE |
ENFORCE_WIP |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IN_BOX_LANE |
IN_TEAM_ROOM |
INPUT_ID |
INPUT_TYPE |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
ITEM_TYPE |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.PropertyCollection.

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


KanbanBoard.Type.PropertyCollection Properties

The properties of the KanbanBoard.Type.PropertyCollection class are listed below. For a complete list of KanbanBoard.Type.PropertyCollection class members, see the KanbanBoard.Type.PropertyCollection Members topic.

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
ENFORCE_AGE |
ENFORCE_WIP |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IN_BOX_LANE |
IN_TEAM_ROOM |
INPUT_ID |
INPUT_TYPE |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
ITEM_TYPE |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ENFORCE_AGE Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ENFORCE_AGE Property

public KanbanBoard.Type.EnforceAgeProperty ENFORCE_AGE {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ENFORCE_WIP Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ENFORCE_WIP Property

public KanbanBoard.Type.EnforceWIPProperty ENFORCE_WIP {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


IN_BOX_LANE Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.IN_BOX_LANE Property

public KanbanBoard.Type.InboxLaneProperty IN_BOX_LANE {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


IN_TEAM_ROOM Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.IN_TEAM_ROOM Property

public KanbanBoard.Type.InTeamRoomProperty IN_TEAM_ROOM {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


INPUT_ID Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.INPUT_ID Property

public KanbanBoard.Type.InputIDProperty INPUT_ID {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


INPUT_TYPE Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.INPUT_TYPE Property

public KanbanBoard.Type.InputTypeProperty INPUT_TYPE {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ITEM_TYPE Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ITEM_TYPE Property

public KanbanBoard.Type.ItemTypeProperty ITEM_TYPE {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.VERSION_METADATA Property

public Item.Type.VersionMetadataProperty VERSION_METADATA {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA_IDS Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.VERSION_METADATA_IDS Property

public Item.Type.VersionMetadataIDsProperty VERSION_METADATA_IDS {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

KanbanBoard.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


KanbanBoard.Type.PropertyCollection Methods

The methods of the KanbanBoard.Type.PropertyCollection class are listed below. For a complete list of KanbanBoard.Type.PropertyCollection class members, see the KanbanBoard.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.KanbanBoard.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.KanbanBoard.Type.PropertyCollection.

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


KanbanBoard.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.Type.PropertyCollection.Equals(obj).

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


KanbanBoard.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.Type.PropertyCollection.GetHashCode().

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


KanbanBoard.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.KanbanBoard.Type.PropertyCollection.ToString()

See Also

KanbanBoard.Type.PropertyCollection Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard Class

Item accessor for cached SDK KanbanBoard items contained objects are obtained from the artifact cache

For a list of all members of this type, see KanbanBoard.WebCacheKanbanBoard Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
KanbanBoard.WebCacheKanbanBoard

public class KanbanBoard.WebCacheKanbanBoard : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

KanbanBoard.WebCacheKanbanBoard Members | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard Members

KanbanBoard.WebCacheKanbanBoard overview

Public Static Methods

Create Overloaded.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EnforceAge | [read/write] A value indicating whether or not this this board enforces Age
EnforceWIP | [read/write] A value indicating whether or not this this board enforces WIP
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
InboxLane | [read/write] the InboxLane of this KanbanBoard.
InputID | [read/write] the input id.
InputType | [read/write] input type used for this board
InTeamRoom | [read/write] A value indicating whether or not this this board is in a team room
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
ItemType | [read/write] item type used for this board
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.KanbanBoard.WebCacheKanbanBoard.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.WebCacheKanbanBoard.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.KanbanBoard.WebCacheKanbanBoard.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard Properties

The properties of the KanbanBoard.WebCacheKanbanBoard class are listed below. For a complete list of KanbanBoard.WebCacheKanbanBoard class members, see the KanbanBoard.WebCacheKanbanBoard Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EnforceAge | [read/write] A value indicating whether or not this this board enforces Age
EnforceWIP | [read/write] A value indicating whether or not this this board enforces WIP
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
InboxLane | [read/write] the InboxLane of this KanbanBoard.
InputID | [read/write] the input id.
InputType | [read/write] input type used for this board
InTeamRoom | [read/write] A value indicating whether or not this this board is in a team room
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
ItemType | [read/write] item type used for this board
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


EnforceAge Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.EnforceAge Property

[read/write] A value indicating whether or not this this board enforces Age

public virtual Boolean EnforceAge {get; set;}

Property Value

A value indicating whether or not this this board enforces Age

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


EnforceWIP Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.EnforceWIP Property

[read/write] A value indicating whether or not this this board enforces WIP

public virtual Boolean EnforceWIP {get; set;}

Property Value

A value indicating whether or not this this board enforces WIP

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


InboxLane Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.InboxLane Property

[read/write] the InboxLane of this KanbanBoard.

public virtual String InboxLane {get; set;}

Property Value

the InboxLane of this KanbanBoard.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


InputID Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.InputID Property

[read/write] the input id.

public virtual Int32 InputID {get; set;}

Property Value

the input id.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


InputType Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.InputType Property

[read/write] input type used for this board

public virtual KanbanBoard.InputType InputType {get; set;}

Property Value

input type used for this board

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


InTeamRoom Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.InTeamRoom Property

[read/write] A value indicating whether or not this this board is in a team room

public virtual Boolean InTeamRoom {get; set;}

Property Value

A value indicating whether or not this this board is in a team room

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ItemType Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ItemType Property

[read/write] item type used for this board

public virtual KanbanBoard.ItemType ItemType {get; set;}

Property Value

item type used for this board

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Name Property

new public virtual String Name {get; set;}

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard Methods

The methods of the KanbanBoard.WebCacheKanbanBoard class are listed below. For a complete list of KanbanBoard.WebCacheKanbanBoard class members, see the KanbanBoard.WebCacheKanbanBoard Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.KanbanBoard.WebCacheKanbanBoard.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.KanbanBoard.WebCacheKanbanBoard.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.KanbanBoard.WebCacheKanbanBoard.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Create Method

Overload List

public static WebCacheKanbanBoard Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheKanbanBoard Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.Create Overload List


KanbanBoard.WebCacheKanbanBoard.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.Create Overload List


KanbanBoard.WebCacheKanbanBoard.Equals Method

Delegate Equals() to com.starteam.KanbanBoard.WebCacheKanbanBoard.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.KanbanBoard.WebCacheKanbanBoard.Equals(obj).

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.GetHashCode Method

Delegate GetHashCode() to com.starteam.KanbanBoard.WebCacheKanbanBoard.

public override int GetHashCode();

Return Value

com.starteam.KanbanBoard.WebCacheKanbanBoard.GetHashCode().

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.GetValue Overload List


KanbanBoard.WebCacheKanbanBoard.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.GetValue Overload List


KanbanBoard.WebCacheKanbanBoard.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | WebCacheViewMemberCollection


KanbanBoard.WebCacheKanbanBoard.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.Lock Overload List | WebCacheViewMemberCollection


KanbanBoard.WebCacheKanbanBoard.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.Lock Overload List


KanbanBoard.WebCacheKanbanBoard.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | NAME


KanbanBoard.WebCacheKanbanBoard.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.MoveTo Overload List


KanbanBoard.WebCacheKanbanBoard.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.MoveTo Overload List


KanbanBoard.WebCacheKanbanBoard.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | isFloating | isPinned | unpin


KanbanBoard.WebCacheKanbanBoard.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | WebCacheViewMemberCollection


KanbanBoard.WebCacheKanbanBoard.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

KanbanBoard.WebCacheKanbanBoard.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.SetValue Overload List


KanbanBoard.WebCacheKanbanBoard.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | KanbanBoard.WebCacheKanbanBoard.SetValue Overload List


KanbanBoard.WebCacheKanbanBoard.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.ToString Method

Delegate ToString() to com.starteam.KanbanBoard.WebCacheKanbanBoard.

public override string ToString();

Return Value

com.starteam.KanbanBoard.WebCacheKanbanBoard.ToString()

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


KanbanBoard.WebCacheKanbanBoard.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | WebCacheViewMemberCollection


KanbanBoard.WebCacheKanbanBoard.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | isFloating | isPinned | pinTo


KanbanBoard.WebCacheKanbanBoard.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace | WebCacheViewMemberCollection


KanbanBoard.WebCacheKanbanBoard.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

KanbanBoard.WebCacheKanbanBoard Class | StarTeam Namespace


Label Class

Represents a named configuration of ViewMembers. Labels may be applied to an entire View or to individual item versions.

For a list of all members of this type, see Label Members.

System.Object
TypedResource
LiveObject
TrackedObject
Label

public class Label : TrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Label Members | StarTeam Namespace


Label Members

Label overview

Public Static Properties

NEXT_BUILD

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString | [read] a string containing various properties of this label.
DeletedBy | [read] the User who deleted this Label.
DeletedTime | [read] the deleted time for this object.
Description | [read/write] the label's description.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBuildLabel | [read] true if this "view label" is a build label.
IsDeleted | [read] true if this label has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsLocked | [read/write] true if the label is locked or frozen.
IsModified | [read] true if this label has been modified but not yet saved.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsRevisionLabel | [read] true is the label is a revision label.
IsViewLabel | [read] true if the label is a view label.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the label's name.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
OwningView | [read] the view that owns this label
Properties | [read] the properties of the label type
RevisionTime | [read] the label's revision time.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Time | [read/write] the label's primary rollback time.
View | [read] this label's View.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AttachTo | Overloaded. Associate a new viewMember with this label. To attach a label to a historical revision of a viewMember, first retrieve the appropriate revision from the viewMember's history (using, for example, viewMember.getFromHistory), then call this method with the resulting historical viewMember.
Copy | Creates a copy of this Label object. Useful to applications that want to save a snapshot of the label in a given state, for example, before calling View.refreshLabels().
DetachFrom | Overloaded. Detaches this label from a collection of items.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLabeledItems | Determines which items from a given list have been labeled with this label in the current view.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares two Label objects.
MoveItem | Overloaded. Associates the label with a different version of an item.
Remove | Removes (deletes) this label from the view. It will still appear in the list of labels returned from the view but it will be marked as deleted.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Stores all changes to a new or modified label to the StarTeam repository. You can only change the name, description and lock/frozen state after the label has been created. If those properties have not been changed then this method will immediately return.

See Also

Label Class | StarTeam Namespace


Label Properties

The properties of the Label class are listed below. For a complete list of Label class members, see the Label Members topic.

Public Static Properties

NEXT_BUILD

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString | [read] a string containing various properties of this label.
DeletedBy | [read] the User who deleted this Label.
DeletedTime | [read] the deleted time for this object.
Description | [read/write] the label's description.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBuildLabel | [read] true if this "view label" is a build label.
IsDeleted | [read] true if this label has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsLocked | [read/write] true if the label is locked or frozen.
IsModified | [read] true if this label has been modified but not yet saved.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsRevisionLabel | [read] true is the label is a revision label.
IsViewLabel | [read] true if the label is a view label.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the label's name.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
OwningView | [read] the view that owns this label
Properties | [read] the properties of the label type
RevisionTime | [read] the label's revision time.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Time | [read/write] the label's primary rollback time.
View | [read] this label's View.

See Also

Label Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Label.DebugString Property

[read] a string containing various properties of this label.

public virtual String DebugString {get;}

Property Value

a string containing various properties of this label.

See Also

Label Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Label.DeletedBy Property

[read] the User who deleted this Label.

public virtual User DeletedBy {get;}

Property Value

the User who deleted this Label.

See Also

Label Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Label.DeletedTime Property

[read] the deleted time for this object.

public virtual DateTime DeletedTime {get;}

Property Value

the deleted time for this object.

See Also

Label Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Label.Description Property

[read/write] the label's description.

public virtual String Description {get; set;}

Property Value

the label's description.

See Also

Label Class | StarTeam Namespace


IsBuildLabel Property

Borland StarTeam SDK for .NET

Label.IsBuildLabel Property

[read] true if this "view label" is a build label.

public virtual Boolean IsBuildLabel {get;}

Property Value

true if this "view label" is a build label.

See Also

Label Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Label.IsDeleted Property

[read] true if this label has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if this label has been deleted.

See Also

Label Class | StarTeam Namespace


IsLocked Property

Borland StarTeam SDK for .NET

Label.IsLocked Property

[read/write] true if the label is locked or frozen.

public virtual Boolean IsLocked {get; set;}

Property Value

true if the label is locked or frozen.

See Also

Label Class | StarTeam Namespace


IsModified Property

Borland StarTeam SDK for .NET

Label.IsModified Property

[read] true if this label has been modified but not yet saved.

public virtual Boolean IsModified {get;}

Property Value

true if this label has been modified but not yet saved.

See Also

Label Class | StarTeam Namespace


IsRevisionLabel Property

Borland StarTeam SDK for .NET

Label.IsRevisionLabel Property

[read] true is the label is a revision label.

public virtual Boolean IsRevisionLabel {get;}

Property Value

true is the label is a revision label.

See Also

Label Class | StarTeam Namespace


IsViewLabel Property

Borland StarTeam SDK for .NET

Label.IsViewLabel Property

[read] true if the label is a view label.

public virtual Boolean IsViewLabel {get;}

Property Value

true if the label is a view label.

See Also

Label Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Label.Name Property

[read/write] the label's name.

public virtual String Name {get; set;}

Property Value

the label's name.

See Also

Label Class | StarTeam Namespace


NEXT_BUILD Property

Borland StarTeam SDK for .NET

Label.NEXT_BUILD Property

public static Label NEXT_BUILD {get;}

Property Value

The value of this field is the "magic" value (-2) to provide for Item properties such as a ChangeRequest's "Addressed In" whose value represents a label.

See Also

Label Class | StarTeam Namespace


OwningView Property

Borland StarTeam SDK for .NET

Label.OwningView Property

[read] the view that owns this label

public virtual View OwningView {get;}

Property Value

the view that owns this label

See Also

Label Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Label.Properties Property

[read] the properties of the label type

public virtual Label.Type.PropertyCollection Properties {get;}

Property Value

the properties of the label type

See Also

Label Class | StarTeam Namespace


RevisionTime Property

Borland StarTeam SDK for .NET

Label.RevisionTime Property

[read] the label's revision time.

public virtual DateTime RevisionTime {get;}

Property Value

the label's revision time.

See Also

Label Class | StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

Label.Time Property

[read/write] the label's primary rollback time.

public virtual DateTime Time {get; set;}

Property Value

the label's primary rollback time.

See Also

Label Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Label.View Property

[read] this label's View.

public virtual View View {get;}

Property Value

this label's View.

See Also

Label Class | StarTeam Namespace


Label Methods

The methods of the Label class are listed below. For a complete list of Label class members, see the Label Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AttachTo | Overloaded. Associate a new viewMember with this label. To attach a label to a historical revision of a viewMember, first retrieve the appropriate revision from the viewMember's history (using, for example, viewMember.getFromHistory), then call this method with the resulting historical viewMember.
Copy | Creates a copy of this Label object. Useful to applications that want to save a snapshot of the label in a given state, for example, before calling View.refreshLabels().
DetachFrom | Overloaded. Detaches this label from a collection of items.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLabeledItems | Determines which items from a given list have been labeled with this label in the current view.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares two Label objects.
MoveItem | Overloaded. Associates the label with a different version of an item.
Remove | Removes (deletes) this label from the view. It will still appear in the list of labels returned from the view but it will be marked as deleted.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Stores all changes to a new or modified label to the StarTeam repository. You can only change the name, description and lock/frozen state after the label has been created. If those properties have not been changed then this method will immediately return.

See Also

Label Class | StarTeam Namespace


AttachTo Method

Borland StarTeam SDK for .NET

Label.AttachTo Method

Overload List

public virtual void AttachTo(Folder,Label.Scope);

Associate a new viewMember with this label. To attach a label to a historical revision of a viewMember, first retrieve the appropriate revision from the viewMember's history (using, for example, viewMember.getFromHistory), then call this method with the resulting historical viewMember.

public virtual void AttachTo(ViewMember);

Associate a set of viewMembers with this label. To attach a label to historical revisions of a viewMember, first retrieve the appropriate revisions from the viewMember's history (using, for example, viewMember.getFromHistory), then call this method with the resulting historical viewMembers. Optimized to execute the least possible number of server commands

public virtual void AttachTo(ViewMemberCollection);

Attach this label to the specified items as of the specified configuration. This is available only in server releases 4.1 and higher.

public virtual void AttachTo(ViewMemberCollection,ViewConfiguration);

See Also

Label Class | StarTeam Namespace


Label.AttachTo Method (Folder, Label#Scope)

public virtual void AttachTo(
Folder folder,
Label.Scope scope
);

See Also

Label Class | StarTeam Namespace | Label.AttachTo Overload List


Label.AttachTo Method (ViewMember)

Associate a new viewMember with this label. To attach a label to a historical revision of a viewMember, first retrieve the appropriate revision from the viewMember's history (using, for example, viewMember.getFromHistory), then call this method with the resulting historical viewMember.

public virtual void AttachTo(
ViewMember vm
);

Parameters

vm
the viewMember to which the label is to be attached

See Also

Label Class | StarTeam Namespace | Label.AttachTo Overload List


Label.AttachTo Method (ViewMemberCollection)

Associate a set of viewMembers with this label. To attach a label to historical revisions of a viewMember, first retrieve the appropriate revisions from the viewMember's history (using, for example, viewMember.getFromHistory), then call this method with the resulting historical viewMembers. Optimized to execute the least possible number of server commands

public virtual void AttachTo(
ViewMemberCollection vmc
);

Parameters

vmc
a collection of viewMembers to which the label will be attached

See Also

Label Class | StarTeam Namespace | Label.AttachTo Overload List


Label.AttachTo Method (ViewMemberCollection, ViewConfiguration)

Attach this label to the specified items as of the specified configuration. This is available only in server releases 4.1 and higher.

public virtual void AttachTo(
ViewMemberCollection vmc,
ViewConfiguration configuration
);

Parameters

vmc
the collection of items to which the label should be attached
configuration
the view configuration specifying what revision to attach to (may not be null)

See Also

Label Class | StarTeam Namespace | Label.AttachTo Overload List


Label.Copy Method

Creates a copy of this Label object. Useful to applications that want to save a snapshot of the label in a given state, for example, before calling View.refreshLabels().

public virtual Label Copy();

Return Value

A copy of this Label.

See Also

Label Class | StarTeam Namespace


DetachFrom Method

Borland StarTeam SDK for .NET

Label.DetachFrom Method

Overload List

public virtual void DetachFrom(Folder,Label.Scope);

Removes the label from the specified viewMember.

public virtual void DetachFrom(ViewMember);

Detaches this label from a collection of items.

public virtual void DetachFrom(ViewMemberCollection);

See Also

Label Class | StarTeam Namespace


Label.DetachFrom Method (Folder, Label#Scope)

public virtual void DetachFrom(
Folder item,
Label.Scope scope
);

See Also

Label Class | StarTeam Namespace | Label.DetachFrom Overload List


Label.DetachFrom Method (ViewMember)

Removes the label from the specified viewMember.

public virtual void DetachFrom(
ViewMember vm
);

Parameters

vm
the viewMember from which the label is to be removed.

See Also

Label Class | StarTeam Namespace | Label.DetachFrom Overload List


Label.DetachFrom Method (ViewMemberCollection)

Detaches this label from a collection of items.

public virtual void DetachFrom(
ViewMemberCollection vmc
);

Parameters

vmc
the collection of items to which the label should be detached (may not be null)

See Also

Label Class | StarTeam Namespace | Label.DetachFrom Overload List


Label.GetLabeledItems Method

Determines which items from a given list have been labeled with this label in the current view.

public virtual ViewMemberCollection GetLabeledItems(
ViewMemberCollection vmc
);

Parameters

vmc
A collection of items.

Return Value

The subset of those items that represent items which have been labeled with this label.

See Also

Label Class | StarTeam Namespace


Label.IsEqualTo Method

Compares two Label objects.

public virtual bool IsEqualTo(
Label label
);

Parameters

label
The Label to be compared with this one.

Return Value

true if no differences were found.

See Also

Label Class | StarTeam Namespace | copy


MoveItem Method

Borland StarTeam SDK for .NET

Label.MoveItem Method

Associates the label with a different version of an item. To move the label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

Overload List

Associates the label with a different version of an item. To move the label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

public virtual void MoveItem(Item);

Associates the label with a different version of an item.

public virtual void MoveItem(Item,Int32,DateTime);

See Also

Label Class | StarTeam Namespace


Label.MoveItem Method (Item)

Associates the label with a different version of an item. To move the label to a historical revision of an item, first retrieve the appropriate revision from the item's history (using, for example, Item.getFromHistoryByDate), then call this method with the resulting historical item.

public virtual void MoveItem(
Item item
);

Parameters

item
the item to which the label is to be attached

See Also

Label Class | StarTeam Namespace | Label.MoveItem Overload List


Label.MoveItem Method (Item, Int32, DateTime)

Associates the label with a different version of an item.

public virtual void MoveItem(
Item item,
Int32 objectID,
DateTime revisionTime
);

Parameters

item
the item to which the label is to be attached
objectID
the object ID of the item being labeled
revisionTime
the time specifying to which revision the label should be attached

See Also

Label Class | StarTeam Namespace | Label.MoveItem Overload List | getObjectID | getModifiedTime


Label.Remove Method

Removes (deletes) this label from the view. It will still appear in the list of labels returned from the view but it will be marked as deleted.

public virtual void Remove();

See Also

Label Class | StarTeam Namespace


Label.Update Method

Stores all changes to a new or modified label to the StarTeam repository. You can only change the name, description and lock/frozen state after the label has been created. If those properties have not been changed then this method will immediately return.

public virtual void Update();

See Also

Label Class | StarTeam Namespace | setName | setDescription | setLocked


Label.Scope Class

When applying a label to a folder, the scope of the operation

For a list of all members of this type, see Label.Scope Members.

System.Object
Label.Scope

public class Label.Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Label.Scope Members | StarTeam Namespace


Label.Scope Members

Label.Scope overview

Public Static Properties

ALL
ITEM_AND_CONTENTS
ITEM_ONLY
ITEM_TREE

Public Static Methods

FromID Gets the Scope value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this Scope value.
Name | [read] a user friendly name for the scope

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Label.Scope.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Label.Scope.

See Also

Label.Scope Class | StarTeam Namespace


Label.Scope Properties

The properties of the Label.Scope class are listed below. For a complete list of Label.Scope class members, see the Label.Scope Members topic.

Public Static Properties

ALL
ITEM_AND_CONTENTS
ITEM_ONLY
ITEM_TREE

Public Instance Properties

ID | [read] The ID of this Scope value.
Name | [read] a user friendly name for the scope

See Also

Label.Scope Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Label.Scope.ALL Property

public static Scope[] ALL {get;}

See Also

Label.Scope Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Label.Scope.ID Property

[read] The ID of this Scope value.

public virtual Int32 ID {get;}

Property Value

The ID of this Scope value.

See Also

Label.Scope Class | StarTeam Namespace


ITEM_AND_CONTENTS Property

Borland StarTeam SDK for .NET

Label.Scope.ITEM_AND_CONTENTS Property

public static Label.Scope ITEM_AND_CONTENTS {get;}

Property Value

When applying a label to a folder you can specify the scope of the operation.

See Also

Label.Scope Class | StarTeam Namespace


ITEM_ONLY Property

Borland StarTeam SDK for .NET

Label.Scope.ITEM_ONLY Property

public static Label.Scope ITEM_ONLY {get;}

Property Value

When applying a label to a folder you can specify the scope of the operation.

See Also

Label.Scope Class | StarTeam Namespace


ITEM_TREE Property

Borland StarTeam SDK for .NET

Label.Scope.ITEM_TREE Property

public static Label.Scope ITEM_TREE {get;}

Property Value

When applying a label to a folder you can specify the scope of the operation.

See Also

Label.Scope Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Label.Scope.Name Property

[read] a user friendly name for the scope

public virtual String Name {get;}

Property Value

a user friendly name for the scope

See Also

Label.Scope Class | StarTeam Namespace


Label.Scope Methods

The methods of the Label.Scope class are listed below. For a complete list of Label.Scope class members, see the Label.Scope Members topic.

Public Static Methods

FromID Gets the Scope value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Label.Scope.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Scope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Label.Scope.

See Also

Label.Scope Class | StarTeam Namespace


Label.Scope.Equals Method

Delegate Equals() to com.starteam.Label.Scope.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Label.Scope.Equals(obj).

See Also

Label.Scope Class | StarTeam Namespace


Label.Scope.FromID Method

Gets the Scope value corresponding to the given ID.

public static Scope FromID(
Int32 id
);

Parameters

id
A Scope ID.

Return Value

The corresponding Scope value, or null.

See Also

Label.Scope Class | StarTeam Namespace


Label.Scope.GetHashCode Method

Delegate GetHashCode() to com.starteam.Label.Scope.

public override int GetHashCode();

Return Value

com.starteam.Label.Scope.GetHashCode().

See Also

Label.Scope Class | StarTeam Namespace


Label.Scope.ToString Method

Delegate ToString() to com.starteam.Label.Scope.

public override string ToString();

Return Value

com.starteam.Label.Scope.ToString()

See Also

Label.Scope Class | StarTeam Namespace


Label.Type Class

The Type for Labels

For a list of all members of this type, see Label.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
Label.Type

new public class Label.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Label.Type Members | StarTeam Namespace


Label.Type Members

Label.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Label.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Label.Type.

See Also

Label.Type Class | StarTeam Namespace


Label.Type Properties

The properties of the Label.Type class are listed below. For a complete list of Label.Type class members, see the Label.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

Label.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Label.Type.NAME Property

new public static String NAME {get;}

See Also

Label.Type Class | StarTeam Namespace


Label.Type Methods

The methods of the Label.Type class are listed below. For a complete list of Label.Type class members, see the Label.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Label.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Label.Type.

See Also

Label.Type Class | StarTeam Namespace


Label.Type.Equals Method

Delegate Equals() to com.starteam.Label.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Label.Type.Equals(obj).

See Also

Label.Type Class | StarTeam Namespace


Label.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Label.Type.

public override int GetHashCode();

Return Value

com.starteam.Label.Type.GetHashCode().

See Also

Label.Type Class | StarTeam Namespace


Label.Type.ToString Method

Delegate ToString() to com.starteam.Label.Type.

public override string ToString();

Return Value

com.starteam.Label.Type.ToString()

See Also

Label.Type Class | StarTeam Namespace


Label.Type.LabelTimeProperty Class

The property type of the Label Time property.

For a list of all members of this type, see Label.Type.LabelTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Label.Type.LabelTimeProperty

public class Label.Type.LabelTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Label.Type.LabelTimeProperty Members | StarTeam Namespace


Label.Type.LabelTimeProperty Members

Label.Type.LabelTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Label.Type.LabelTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Type.LabelTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Label.Type.LabelTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Label.Type.LabelTimeProperty Class | StarTeam Namespace


Label.Type.LabelTimeProperty Properties

The properties of the Label.Type.LabelTimeProperty class are listed below. For a complete list of Label.Type.LabelTimeProperty class members, see the Label.Type.LabelTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Label.Type.LabelTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Label.Type.LabelTimeProperty.NAME Property

public static String NAME {get;}

See Also

Label.Type.LabelTimeProperty Class | StarTeam Namespace


Label.Type.LabelTimeProperty Methods

The methods of the Label.Type.LabelTimeProperty class are listed below. For a complete list of Label.Type.LabelTimeProperty class members, see the Label.Type.LabelTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Label.Type.LabelTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Type.LabelTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Label.Type.LabelTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Label.Type.LabelTimeProperty Class | StarTeam Namespace


Label.Type.LabelTimeProperty.Equals Method

Delegate Equals() to com.starteam.Label.Type.LabelTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Label.Type.LabelTimeProperty.Equals(obj).

See Also

Label.Type.LabelTimeProperty Class | StarTeam Namespace


Label.Type.LabelTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Label.Type.LabelTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.Label.Type.LabelTimeProperty.GetHashCode().

See Also

Label.Type.LabelTimeProperty Class | StarTeam Namespace


Label.Type.LabelTimeProperty.ToString Method

Delegate ToString() to com.starteam.Label.Type.LabelTimeProperty.

public override string ToString();

Return Value

com.starteam.Label.Type.LabelTimeProperty.ToString()

See Also

Label.Type.LabelTimeProperty Class | StarTeam Namespace


Label.Type.MemberIDProperty Class

The property type of the Member ID property.

For a list of all members of this type, see Label.Type.MemberIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Label.Type.MemberIDProperty

public class Label.Type.MemberIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Label.Type.MemberIDProperty Members | StarTeam Namespace


Label.Type.MemberIDProperty Members

Label.Type.MemberIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Label.Type.MemberIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Type.MemberIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Label.Type.MemberIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Label.Type.MemberIDProperty Class | StarTeam Namespace


Label.Type.MemberIDProperty Properties

The properties of the Label.Type.MemberIDProperty class are listed below. For a complete list of Label.Type.MemberIDProperty class members, see the Label.Type.MemberIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Label.Type.MemberIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Label.Type.MemberIDProperty.NAME Property

public static String NAME {get;}

See Also

Label.Type.MemberIDProperty Class | StarTeam Namespace


Label.Type.MemberIDProperty Methods

The methods of the Label.Type.MemberIDProperty class are listed below. For a complete list of Label.Type.MemberIDProperty class members, see the Label.Type.MemberIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Label.Type.MemberIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Type.MemberIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Label.Type.MemberIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Label.Type.MemberIDProperty Class | StarTeam Namespace


Label.Type.MemberIDProperty.Equals Method

Delegate Equals() to com.starteam.Label.Type.MemberIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Label.Type.MemberIDProperty.Equals(obj).

See Also

Label.Type.MemberIDProperty Class | StarTeam Namespace


Label.Type.MemberIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Label.Type.MemberIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Label.Type.MemberIDProperty.GetHashCode().

See Also

Label.Type.MemberIDProperty Class | StarTeam Namespace


Label.Type.MemberIDProperty.ToString Method

Delegate ToString() to com.starteam.Label.Type.MemberIDProperty.

public override string ToString();

Return Value

com.starteam.Label.Type.MemberIDProperty.ToString()

See Also

Label.Type.MemberIDProperty Class | StarTeam Namespace


Label.Type.PropertyCollection Class

The PropertyCollection of a Label Type.

For a list of all members of this type, see Label.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
Label.Type.PropertyCollection

public class Label.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Label.Type.PropertyCollection Members | StarTeam Namespace


Label.Type.PropertyCollection Members

Label.Type.PropertyCollection overview

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
FLAGS |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
LABEL_TIME |
MEMBER_ID |
MODIFIED_BY |
MODIFIED_TIME |
NAME |
PROJECT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Label.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Label.Type.PropertyCollection.

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


Label.Type.PropertyCollection Properties

The properties of the Label.Type.PropertyCollection class are listed below. For a complete list of Label.Type.PropertyCollection class members, see the Label.Type.PropertyCollection Members topic.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
FLAGS |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
LABEL_TIME |
MEMBER_ID |
MODIFIED_BY |
MODIFIED_TIME |
NAME |
PROJECT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


FLAGS Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.FLAGS Property

public LiveObject.Type.FlagsProperty FLAGS {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


LABEL_TIME Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.LABEL_TIME Property

public Label.Type.LabelTimeProperty LABEL_TIME {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


MEMBER_ID Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.MEMBER_ID Property

public Label.Type.MemberIDProperty MEMBER_ID {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


PROJECT Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.PROJECT Property

public TypedResource.Type.ProjectProperty PROJECT {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Label.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


Label.Type.PropertyCollection Methods

The methods of the Label.Type.PropertyCollection class are listed below. For a complete list of Label.Type.PropertyCollection class members, see the Label.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Label.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Label.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Label.Type.PropertyCollection.

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


Label.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Label.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Label.Type.PropertyCollection.Equals(obj).

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


Label.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Label.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Label.Type.PropertyCollection.GetHashCode().

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


Label.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Label.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Label.Type.PropertyCollection.ToString()

See Also

Label.Type.PropertyCollection Class | StarTeam Namespace


Label.WebCacheLabel Class

Label accessor for cached SDK views contained objects are obtained from the artifact cache

For a list of all members of this type, see Label.WebCacheLabel Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
Label.WebCacheLabel

public class Label.WebCacheLabel : WebCacheTrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Label.WebCacheLabel Members | StarTeam Namespace


Label.WebCacheLabel Members

Label.WebCacheLabel overview

Public Static Methods

Create

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
Description | [read/write] the label's description.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsBuildLabel | [read/write] true if this "view label" is a build label.
IsDeleted | [read] true if this label has been deleted.
IsDirty | [read] true if this object is dirty
IsLocked | [read/write] true if the label is locked or frozen.
IsNew | [read] true if this resource has not yet been stored in the server.
IsRevisionLabel | [read] true is the label is a revision label.
IsViewLabel | [read] true if the label is a view label.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
OwningView | [read] the view that owns this label
RevisionTime | [read] the label's revision time.
Server | [read] the Server for this cached object
Time | [read/write] the label's primary rollback time.
View | [read] this label's View.

Public Instance Methods

AddTo |
AttachTo |
DetachFrom |
Equals | Delegate Equals() to com.starteam.Label.WebCacheLabel.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.WebCacheLabel.
GetLabeledViewMembers |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Label.WebCacheLabel.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel Properties

The properties of the Label.WebCacheLabel class are listed below. For a complete list of Label.WebCacheLabel class members, see the Label.WebCacheLabel Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
Description | [read/write] the label's description.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsBuildLabel | [read/write] true if this "view label" is a build label.
IsDeleted | [read] true if this label has been deleted.
IsDirty | [read] true if this object is dirty
IsLocked | [read/write] true if the label is locked or frozen.
IsNew | [read] true if this resource has not yet been stored in the server.
IsRevisionLabel | [read] true is the label is a revision label.
IsViewLabel | [read] true if the label is a view label.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
OwningView | [read] the view that owns this label
RevisionTime | [read] the label's revision time.
Server | [read] the Server for this cached object
Time | [read/write] the label's primary rollback time.
View | [read] this label's View.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.Description Property

[read/write] the label's description.

public virtual String Description {get; set;}

Property Value

the label's description.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Label.WebCacheLabel Class | StarTeam Namespace


IsBuildLabel Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.IsBuildLabel Property

[read/write] true if this "view label" is a build label.

public virtual Boolean IsBuildLabel {get; set;}

Property Value

true if this "view label" is a build label.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.IsDeleted Property

[read] true if this label has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if this label has been deleted.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Label.WebCacheLabel Class | StarTeam Namespace


IsLocked Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.IsLocked Property

[read/write] true if the label is locked or frozen.

public virtual Boolean IsLocked {get; set;}

Property Value

true if the label is locked or frozen.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


IsRevisionLabel Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.IsRevisionLabel Property

[read] true is the label is a revision label.

public virtual Boolean IsRevisionLabel {get;}

Property Value

true is the label is a revision label.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


IsViewLabel Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.IsViewLabel Property

[read] true if the label is a view label.

public virtual Boolean IsViewLabel {get;}

Property Value

true if the label is a view label.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.Name Property

new public virtual String Name {get; set;}

See Also

Label.WebCacheLabel Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Label.WebCacheLabel Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


OwningView Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.OwningView Property

[read] the view that owns this label

public virtual View.WebCacheView OwningView {get;}

Property Value

the view that owns this label

See Also

Label.WebCacheLabel Class | StarTeam Namespace


RevisionTime Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.RevisionTime Property

[read] the label's revision time.

public virtual DateTime RevisionTime {get;}

Property Value

the label's revision time.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.Time Property

[read/write] the label's primary rollback time.

public virtual DateTime Time {get; set;}

Property Value

the label's primary rollback time.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Label.WebCacheLabel.View Property

[read] this label's View.

public virtual View.WebCacheView View {get;}

Property Value

this label's View.

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel Methods

The methods of the Label.WebCacheLabel class are listed below. For a complete list of Label.WebCacheLabel class members, see the Label.WebCacheLabel Members topic.

Public Static Methods

Create

Public Instance Methods

AddTo |
AttachTo |
DetachFrom |
Equals | Delegate Equals() to com.starteam.Label.WebCacheLabel.
GetHashCode | Delegate GetHashCode() to com.starteam.Label.WebCacheLabel.
GetLabeledViewMembers |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Label.WebCacheLabel.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.AttachTo Method

public virtual void AttachTo(
WebCacheViewMember[] mm
);

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.Create Method

public static WebCacheLabel Create(
ArtifactCacheManager.Context cntxt,
View.WebCacheView parent,
String labelName,
String labelDescription,
DateTime labelDateTime,
Boolean isRevisionLabel
);

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.DetachFrom Method

public virtual void DetachFrom(
WebCacheViewMember[] mm
);

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.Equals Method

Delegate Equals() to com.starteam.Label.WebCacheLabel.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Label.WebCacheLabel.Equals(obj).

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.GetHashCode Method

Delegate GetHashCode() to com.starteam.Label.WebCacheLabel.

public override int GetHashCode();

Return Value

com.starteam.Label.WebCacheLabel.GetHashCode().

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.GetLabeledViewMembers Method

public virtual WebCacheViewMember[] GetLabeledViewMembers(
WebCacheViewMember[] mm
);

See Also

Label.WebCacheLabel Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Label.WebCacheLabel.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Label.WebCacheLabel Class | StarTeam Namespace | Label.WebCacheLabel.GetValue Overload List


Label.WebCacheLabel.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Label.WebCacheLabel Class | StarTeam Namespace | Label.WebCacheLabel.GetValue Overload List


Label.WebCacheLabel.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Label.WebCacheLabel Class | StarTeam Namespace | WebCacheViewMemberCollection


Label.WebCacheLabel.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Label.WebCacheLabel Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Label.WebCacheLabel.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Label.WebCacheLabel Class | StarTeam Namespace | Label.WebCacheLabel.SetValue Overload List


Label.WebCacheLabel.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Label.WebCacheLabel Class | StarTeam Namespace | Label.WebCacheLabel.SetValue Overload List


Label.WebCacheLabel.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.ToString Method

Delegate ToString() to com.starteam.Label.WebCacheLabel.

public override string ToString();

Return Value

com.starteam.Label.WebCacheLabel.ToString()

See Also

Label.WebCacheLabel Class | StarTeam Namespace


Label.WebCacheLabel.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Label.WebCacheLabel Class | StarTeam Namespace | WebCacheViewMemberCollection


Link Class

Represents an association between two view members. From StarTeam Server 11.0 onwards, application should use Traces to create associations between view members.

For a list of all members of this type, see Link Members.

System.Object
Link

public class Link

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Link Members | StarTeam Namespace


Link Members

Link overview

Public Instance Constructors

Link Overloaded. Initializes a new instance of the Link class.

Public Instance Properties

ChildEndpoint | [read] a reference to the "child" viewMember in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the viewMember from which this link was enumerated.
Comment | [read/write] the comment associated with this link.
CreatedBy | [read] the User object who who created this link.
CreatedTime | [read] the time at which this link was created.
DebugString | [read] the debug string associated this link
DisembodiedChild | [read] A disembodied item representing the resolved child endpoint.
DisembodiedParent | [read] A disembodied item representing the resolved parent endpoint.
ID | [read] an integer that identifies this link.
ParentEndpoint | [read] a reference to the "parent" viewMember in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the viewMember from which this link was enumerated.
ParentFolderItemID | [read] the ItemID of the linked Item's parent Folder or -1 if unavailable.
Server | [read] the server object to which the parent endpoint of this link belongs.
View | [read] the view to which the parent endpoint of this link belongs.

Public Instance Methods

Copy | Copies this link, creating a new one with the same content.
Delete | Terminates the association of the linked items.
Equals | Delegate Equals() to com.starteam.Link.
GetHashCode | Delegate GetHashCode() to com.starteam.Link.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Determines whether or not the contents of two links are the same.
PinChild | Pin the child endpoint of the link.
PinParent | Pin the parent endpoint of the link.
ResolveChild | Gets a fully resolved version of the child viewMember. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveParent | Gets a fully resolved version of the parent viewMember. This is a potentially expensive API, possibly involving the execution of several server commands
ToString | Delegate ToString() to com.starteam.Link.
UnpinChild | Unpin the child endpoint of the link.
UnpinParent | Unpin the parent endpoint of the link.
Update | Persists the link.

See Also

Link Class | StarTeam Namespace


Link Constructor

Creates a new link object.

Overload List

Creates a new link object.

public Link(ViewMember,ViewMember);

Creates a new link object.

public Link(ViewMember,Int32,ViewMember,Int32);

See Also

Link Class | StarTeam Namespace


Link Constructor (ViewMember, Int32, ViewMember, Int32)

Creates a new link object.

public Link(
ViewMember parent,
Int32 parentRevision,
ViewMember child,
Int32 childRevision
);

Parameters

parent
The parent end of the link.
parentRevision
The revision number of the first revision in the parent item's history for which this link is visible. If the value is -1, defaults to the first revision in the parent item's branch.
child
The child end of the link.
childRevision
The revision number of the first revision in the child item's history for which this link is visible. If the value is -1, defaults to the first revision in the child item's branch.

See Also

Link Class | StarTeam Namespace | Link Constructor Overload List


Link Constructor (ViewMember, ViewMember)

Creates a new link object.

public Link(
ViewMember parent,
ViewMember child
);

Parameters

parent
The parent end of the link. The link becomes visible at the first revision of this item's branch.
child
The child end of the link. The link becomes visible at the first revision of this item's branch.

See Also

Link Class | StarTeam Namespace | Link Constructor Overload List


Link Properties

The properties of the Link class are listed below. For a complete list of Link class members, see the Link Members topic.

Public Instance Properties

ChildEndpoint | [read] a reference to the "child" viewMember in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the viewMember from which this link was enumerated.
Comment | [read/write] the comment associated with this link.
CreatedBy | [read] the User object who who created this link.
CreatedTime | [read] the time at which this link was created.
DebugString | [read] the debug string associated this link
DisembodiedChild | [read] A disembodied item representing the resolved child endpoint.
DisembodiedParent | [read] A disembodied item representing the resolved parent endpoint.
ID | [read] an integer that identifies this link.
ParentEndpoint | [read] a reference to the "parent" viewMember in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the viewMember from which this link was enumerated.
ParentFolderItemID | [read] the ItemID of the linked Item's parent Folder or -1 if unavailable.
Server | [read] the server object to which the parent endpoint of this link belongs.
View | [read] the view to which the parent endpoint of this link belongs.

See Also

Link Class | StarTeam Namespace


ChildEndpoint Property

Borland StarTeam SDK for .NET

Link.ChildEndpoint Property

[read] a reference to the "child" viewMember in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the viewMember from which this link was enumerated.

public virtual Link.Endpoint ChildEndpoint {get;}

Property Value

a reference to the "child" viewMember in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the viewMember from which this link was enumerated.

See Also

Link Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Link.Comment Property

[read/write] the comment associated with this link.

public virtual String Comment {get; set;}

Property Value

the comment associated with this link.

See Also

Link Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Link.CreatedBy Property

[read] the User object who who created this link.

public virtual User CreatedBy {get;}

Property Value

the User object who who created this link.

See Also

Link Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Link.CreatedTime Property

[read] the time at which this link was created.

public virtual DateTime CreatedTime {get;}

Property Value

the time at which this link was created.

See Also

Link Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Link.DebugString Property

[read] the debug string associated this link

public virtual String DebugString {get;}

Property Value

the debug string associated this link

See Also

Link Class | StarTeam Namespace


DisembodiedChild Property

Borland StarTeam SDK for .NET

Link.DisembodiedChild Property

[read] A disembodied item representing the resolved child endpoint.

public virtual ViewMember DisembodiedChild {get;}

Property Value

A disembodied item representing the resolved child endpoint.

See Also

Link Class | StarTeam Namespace


DisembodiedParent Property

Borland StarTeam SDK for .NET

Link.DisembodiedParent Property

[read] A disembodied item representing the resolved parent endpoint.

public virtual ViewMember DisembodiedParent {get;}

Property Value

A disembodied item representing the resolved parent endpoint.

See Also

Link Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Link.ID Property

[read] an integer that identifies this link.

public virtual Int32 ID {get;}

Property Value

an integer that identifies this link.

See Also

Link Class | StarTeam Namespace


ParentEndpoint Property

Borland StarTeam SDK for .NET

Link.ParentEndpoint Property

[read] a reference to the "parent" viewMember in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the viewMember from which this link was enumerated.

public virtual Link.Endpoint ParentEndpoint {get;}

Property Value

a reference to the "parent" viewMember in this link. Since links are not directional, the terms parent and child are arbitrary. Parent refers to the viewMember from which this link was enumerated.

See Also

Link Class | StarTeam Namespace


ParentFolderItemID Property

Borland StarTeam SDK for .NET

Link.ParentFolderItemID Property

[read] the ItemID of the linked Item's parent Folder or -1 if unavailable.

public virtual Int32 ParentFolderItemID {get;}

Property Value

the ItemID of the linked Item's parent Folder or -1 if unavailable.

See Also

Link Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Link.Server Property

[read] the server object to which the parent endpoint of this link belongs.

public virtual Server Server {get;}

Property Value

the server object to which the parent endpoint of this link belongs.

See Also

Link Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Link.View Property

[read] the view to which the parent endpoint of this link belongs.

public virtual View View {get;}

Property Value

the view to which the parent endpoint of this link belongs.

See Also

Link Class | StarTeam Namespace


Link Methods

The methods of the Link class are listed below. For a complete list of Link class members, see the Link Members topic.

Public Instance Methods

Copy | Copies this link, creating a new one with the same content.
Delete | Terminates the association of the linked items.
Equals | Delegate Equals() to com.starteam.Link.
GetHashCode | Delegate GetHashCode() to com.starteam.Link.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Determines whether or not the contents of two links are the same.
PinChild | Pin the child endpoint of the link.
PinParent | Pin the parent endpoint of the link.
ResolveChild | Gets a fully resolved version of the child viewMember. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveParent | Gets a fully resolved version of the parent viewMember. This is a potentially expensive API, possibly involving the execution of several server commands
ToString | Delegate ToString() to com.starteam.Link.
UnpinChild | Unpin the child endpoint of the link.
UnpinParent | Unpin the parent endpoint of the link.
Update | Persists the link.

See Also

Link Class | StarTeam Namespace


Link.Copy Method

Copies this link, creating a new one with the same content.

public virtual Link Copy();

Return Value

A new copy of this link.

See Also

Link Class | StarTeam Namespace


Link.Delete Method

Terminates the association of the linked items.

public virtual void Delete();

See Also

Link Class | StarTeam Namespace


Link.Equals Method

Delegate Equals() to com.starteam.Link.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Link.Equals(obj).

See Also

Link Class | StarTeam Namespace


Link.GetHashCode Method

Delegate GetHashCode() to com.starteam.Link.

public override int GetHashCode();

Return Value

com.starteam.Link.GetHashCode().

See Also

Link Class | StarTeam Namespace


Link.IsEqualTo Method

Determines whether or not the contents of two links are the same.

public virtual bool IsEqualTo(
Link other
);

Parameters

other
The link to be compared to this one.

Return Value

true if the links are the same; false otherwise.

See Also

Link Class | StarTeam Namespace


Link.PinChild Method

Pin the child endpoint of the link.

public virtual void PinChild(
ViewMember newChild
);

Parameters

newChild
the ViewMember to which this endpoint should be pinned. Note that this item must lie in the history path of the original item for the endpoint, and cannot be an earlier revision than the earliest revision for the endpoint.

See Also

Link Class | StarTeam Namespace


Link.PinParent Method

Pin the parent endpoint of the link.

public virtual void PinParent(
ViewMember newParent
);

Parameters

newParent
the ViewMember to which this endpoint should be pinned. Note that this item must lie in the history path of the original item for the endpoint, and cannot be an earlier revision than the earliest revision for the endpoint.

See Also

Link Class | StarTeam Namespace


Link.ResolveChild Method

Gets a fully resolved version of the child viewMember. This is a potentially expensive API, possibly involving the execution of several server commands

public virtual ViewMember ResolveChild();

Return Value

a fully resolved version of the child viewMember

See Also

Link Class | StarTeam Namespace


Link.ResolveParent Method

Gets a fully resolved version of the parent viewMember. This is a potentially expensive API, possibly involving the execution of several server commands

public virtual ViewMember ResolveParent();

Return Value

a fully resolved version of the parent viewMember.

See Also

Link Class | StarTeam Namespace


Link.ToString Method

Delegate ToString() to com.starteam.Link.

public override string ToString();

Return Value

com.starteam.Link.ToString()

See Also

Link Class | StarTeam Namespace


Link.UnpinChild Method

Unpin the child endpoint of the link.

public virtual void UnpinChild();

See Also

Link Class | StarTeam Namespace


Link.UnpinParent Method

Unpin the parent endpoint of the link.

public virtual void UnpinParent();

See Also

Link Class | StarTeam Namespace


Link.Update Method

Persists the link.

public virtual void Update();

See Also

Link Class | StarTeam Namespace


Link.Endpoint Class

Represents a link reference to a viewMember.

For a list of all members of this type, see Link.Endpoint Members.

System.Object
Link.Endpoint

public class Link.Endpoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Link.Endpoint Members | StarTeam Namespace


Link.Endpoint Members

Link.Endpoint overview

Public Instance Properties

DebugString | [read] a debug string representation of this link endpoint.
DisembodiedViewMember | [read] The link endpoint, resolved to a new "disembodied" view member.
DotNotation | [read] the dot notation for the viewMember referenced by this link if the endpoint is pinned. Not meaningful if the endpoint is not pinned.
FolderObjectID | [read] the object ID for the parent folder of the linked viewMember.
IsPinned | [read] true if this link endpoint is pinned to a specific revision.
ObjectID | [read] the object ID for the referenced viewMember. Note that this value is only meaningful if the endpoint is pinned. The value may be -1 if the endpoint is not pinned, or may in fact be an object ID if this is the "child" endpoint of the link. In any case, always check the value of the"Pinned" property to determine whether the endpoint is pinned before relying on this value.
RevisionNumber | [read] the revision number for the specific revision of a pinned endpoint, or -1 if the endpoint is not pinned.
Type | [read] the type of viewMember being referenced
ViewID | [read] the view ID in which the referenced viewMember exists.
VMID | [read] The ID of the view member being referenced.

Public Instance Methods

Copy | Copies this link endpoint, creating a new one with the same content.
Equals | Delegate Equals() to com.starteam.Link.Endpoint.
GetHashCode | Delegate GetHashCode() to com.starteam.Link.Endpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
Resolve | Gets a fully resolved version of the referenced view member. This is a potentially expensive API, possibly involving the execution of several server commands
ToString | Delegate ToString() to com.starteam.Link.Endpoint.

See Also

Link.Endpoint Class | StarTeam Namespace


Link.Endpoint Properties

The properties of the Link.Endpoint class are listed below. For a complete list of Link.Endpoint class members, see the Link.Endpoint Members topic.

Public Instance Properties

DebugString | [read] a debug string representation of this link endpoint.
DisembodiedViewMember | [read] The link endpoint, resolved to a new "disembodied" view member.
DotNotation | [read] the dot notation for the viewMember referenced by this link if the endpoint is pinned. Not meaningful if the endpoint is not pinned.
FolderObjectID | [read] the object ID for the parent folder of the linked viewMember.
IsPinned | [read] true if this link endpoint is pinned to a specific revision.
ObjectID | [read] the object ID for the referenced viewMember. Note that this value is only meaningful if the endpoint is pinned. The value may be -1 if the endpoint is not pinned, or may in fact be an object ID if this is the "child" endpoint of the link. In any case, always check the value of the"Pinned" property to determine whether the endpoint is pinned before relying on this value.
RevisionNumber | [read] the revision number for the specific revision of a pinned endpoint, or -1 if the endpoint is not pinned.
Type | [read] the type of viewMember being referenced
ViewID | [read] the view ID in which the referenced viewMember exists.
VMID | [read] The ID of the view member being referenced.

See Also

Link.Endpoint Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Link.Endpoint.DebugString Property

[read] a debug string representation of this link endpoint.

public virtual String DebugString {get;}

Property Value

a debug string representation of this link endpoint.

See Also

Link.Endpoint Class | StarTeam Namespace


DisembodiedViewMember Property

Borland StarTeam SDK for .NET

Link.Endpoint.DisembodiedViewMember Property

[read] The link endpoint, resolved to a new "disembodied" view member.

public virtual ViewMember DisembodiedViewMember {get;}

Property Value

The link endpoint, resolved to a new "disembodied" view member.

See Also

Link.Endpoint Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Link.Endpoint.DotNotation Property

[read] the dot notation for the viewMember referenced by this link if the endpoint is pinned. Not meaningful if the endpoint is not pinned.

public virtual DotNotation DotNotation {get;}

Property Value

the dot notation for the viewMember referenced by this link if the endpoint is pinned. Not meaningful if the endpoint is not pinned.

See Also

Link.Endpoint Class | StarTeam Namespace


FolderObjectID Property

Borland StarTeam SDK for .NET

Link.Endpoint.FolderObjectID Property

[read] the object ID for the parent folder of the linked viewMember.

public virtual Int32 FolderObjectID {get;}

Property Value

the object ID for the parent folder of the linked viewMember.

See Also

Link.Endpoint Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Link.Endpoint.IsPinned Property

[read] true if this link endpoint is pinned to a specific revision.

public virtual Boolean IsPinned {get;}

Property Value

true if this link endpoint is pinned to a specific revision.

See Also

Link.Endpoint Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Link.Endpoint.ObjectID Property

[read] the object ID for the referenced viewMember. Note that this value is only meaningful if the endpoint is pinned. The value may be -1 if the endpoint is not pinned, or may in fact be an object ID if this is the "child" endpoint of the link. In any case, always check the value of the"Pinned" property to determine whether the endpoint is pinned before relying on this value.

public virtual Int32 ObjectID {get;}

Property Value

the object ID for the referenced viewMember. Note that this value is only meaningful if the endpoint is pinned. The value may be -1 if the endpoint is not pinned, or may in fact be an object ID if this is the "child" endpoint of the link. In any case, always check the value of the"Pinned" property to determine whether the endpoint is pinned before relying on this value.

See Also

Link.Endpoint Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Link.Endpoint.RevisionNumber Property

[read] the revision number for the specific revision of a pinned endpoint, or -1 if the endpoint is not pinned.

public virtual Int32 RevisionNumber {get;}

Property Value

the revision number for the specific revision of a pinned endpoint, or -1 if the endpoint is not pinned.

See Also

Link.Endpoint Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Link.Endpoint.Type Property

[read] the type of viewMember being referenced

public virtual ViewMember.Type Type {get;}

Property Value

the type of viewMember being referenced

See Also

Link.Endpoint Class | StarTeam Namespace


ViewID Property

Borland StarTeam SDK for .NET

Link.Endpoint.ViewID Property

[read] the view ID in which the referenced viewMember exists.

public virtual Int32 ViewID {get;}

Property Value

the view ID in which the referenced viewMember exists.

See Also

Link.Endpoint Class | StarTeam Namespace


VMID Property

Borland StarTeam SDK for .NET

Link.Endpoint.VMID Property

[read] The ID of the view member being referenced.

public virtual Int32 VMID {get;}

Property Value

The ID of the view member being referenced.

See Also

Link.Endpoint Class | StarTeam Namespace


Link.Endpoint Methods

The methods of the Link.Endpoint class are listed below. For a complete list of Link.Endpoint class members, see the Link.Endpoint Members topic.

Public Instance Methods

Copy | Copies this link endpoint, creating a new one with the same content.
Equals | Delegate Equals() to com.starteam.Link.Endpoint.
GetHashCode | Delegate GetHashCode() to com.starteam.Link.Endpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo |
Resolve | Gets a fully resolved version of the referenced view member. This is a potentially expensive API, possibly involving the execution of several server commands
ToString | Delegate ToString() to com.starteam.Link.Endpoint.

See Also

Link.Endpoint Class | StarTeam Namespace


Link.Endpoint.Copy Method

Copies this link endpoint, creating a new one with the same content.

public virtual Endpoint Copy();

Return Value

A new copy of this link endpoint.

See Also

Link.Endpoint Class | StarTeam Namespace


Link.Endpoint.Equals Method

Delegate Equals() to com.starteam.Link.Endpoint.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Link.Endpoint.Equals(obj).

See Also

Link.Endpoint Class | StarTeam Namespace


Link.Endpoint.GetHashCode Method

Delegate GetHashCode() to com.starteam.Link.Endpoint.

public override int GetHashCode();

Return Value

com.starteam.Link.Endpoint.GetHashCode().

See Also

Link.Endpoint Class | StarTeam Namespace


Link.Endpoint.IsEqualTo Method

public virtual bool IsEqualTo(
Link.Endpoint other
);

See Also

Link.Endpoint Class | StarTeam Namespace


Link.Endpoint.Resolve Method

Gets a fully resolved version of the referenced view member. This is a potentially expensive API, possibly involving the execution of several server commands

public virtual ViewMember Resolve();

Return Value

a fully resolved version of the referenced view member.

See Also

Link.Endpoint Class | StarTeam Namespace


Link.Endpoint.ToString Method

Delegate ToString() to com.starteam.Link.Endpoint.

public override string ToString();

Return Value

com.starteam.Link.Endpoint.ToString()

See Also

Link.Endpoint Class | StarTeam Namespace


LinkCache Class

Caches links for a given set of items. One LinkCache may be populated with links from multiple view configurations on multiple servers.

For a list of all members of this type, see LinkCache Members.

System.Object
LinkCache

public class LinkCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LinkCache Members | StarTeam Namespace


LinkCache Members

LinkCache overview

Public Instance Constructors

LinkCache Constructor Constructs a new link cache. The cache is initially empty.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LinkCache.
GetHashCode | Delegate GetHashCode() to com.starteam.LinkCache.
GetLinks | Gets the links for the given ViewMember. If the links were not previously cached, they are fetched from the server and cached now. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPopulated | Determines whether of not the given view member's links have already been cached.
NewLinkUpdateEventSource |
Populate | Overloaded.
Refresh | Overloaded.
ToString | Delegate ToString() to com.starteam.LinkCache.

See Also

LinkCache Class | StarTeam Namespace


LinkCache Constructor

Constructs a new link cache. The cache is initially empty.

public LinkCache();

See Also

LinkCache Class | StarTeam Namespace


LinkCache Methods

The methods of the LinkCache class are listed below. For a complete list of LinkCache class members, see the LinkCache Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LinkCache.
GetHashCode | Delegate GetHashCode() to com.starteam.LinkCache.
GetLinks | Gets the links for the given ViewMember. If the links were not previously cached, they are fetched from the server and cached now. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.
GetType (inherited from Object) | Gets the Type of the current instance.
IsPopulated | Determines whether of not the given view member's links have already been cached.
NewLinkUpdateEventSource |
Populate | Overloaded.
Refresh | Overloaded.
ToString | Delegate ToString() to com.starteam.LinkCache.

See Also

LinkCache Class | StarTeam Namespace


LinkCache.Equals Method

Delegate Equals() to com.starteam.LinkCache.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LinkCache.Equals(obj).

See Also

LinkCache Class | StarTeam Namespace


LinkCache.GetHashCode Method

Delegate GetHashCode() to com.starteam.LinkCache.

public override int GetHashCode();

Return Value

com.starteam.LinkCache.GetHashCode().

See Also

LinkCache Class | StarTeam Namespace


LinkCache.GetLinks Method

Gets the links for the given ViewMember. If the links were not previously cached, they are fetched from the server and cached now.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual Link[] GetLinks(
ViewMember vm
);

Parameters

vm
The ViewMember whose links are to be fetched.

Return Value

The set of links whose parent is the given ViewMember.

See Also

LinkCache Class | StarTeam Namespace


LinkCache.IsPopulated Method

Determines whether of not the given view member's links have already been cached.

public virtual bool IsPopulated(
ViewMember vm
);

Parameters

vm
The view member to be tested.

Return Value

true if the given view members's links have been cached, and false otherwise.

See Also

LinkCache Class | StarTeam Namespace


LinkCache.NewLinkUpdateEventSource Method

public LinkUpdateEventSource NewLinkUpdateEventSource();

See Also

LinkCache Class | StarTeam Namespace


Populate Method

Borland StarTeam SDK for .NET

LinkCache.Populate Method

Overload List

public virtual void Populate(Folder,Item.Type,Int32);

public virtual void Populate(View,Item.Type);

Ensures that the links are cached for all of the given view members. If the links for some of the view members have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void Populate(ViewMemberCollection);

See Also

LinkCache Class | StarTeam Namespace


LinkCache.Populate Method (Folder, Item#Type, Int32)

public virtual void Populate(
Folder folder,
Item.Type itemType,
Int32 depth
);

See Also

LinkCache Class | StarTeam Namespace | LinkCache.Populate Overload List


LinkCache.Populate Method (View, Item#Type)

public virtual void Populate(
View view,
Item.Type type
);

See Also

LinkCache Class | StarTeam Namespace | LinkCache.Populate Overload List


LinkCache.Populate Method (ViewMemberCollection)

Ensures that the links are cached for all of the given view members.

If the links for some of the view members have not yet been cached, then they are retrieved from the StarTeam server. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache.

public virtual void Populate(
ViewMemberCollection list
);

Parameters

list
The list of view members whose links are to be cached.

See Also

LinkCache Class | StarTeam Namespace | LinkCache.Populate Overload List


Refresh Method

Borland StarTeam SDK for .NET

LinkCache.Refresh Method

Overload List

public virtual void Refresh(Folder,Item.Type,Int32);

Ensures that the latest links are available for the given item. Existing Link objects are modified in place whenever possible. Note that since links are not currently MPX-aware, this re-fetches the links for the given item. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(Item);

public virtual void Refresh(View,Item.Type);

Ensures that the latest links are available for all of the given view members. Existing Link objects are modified in place whenever possible. Note that since links are not currently MPX-aware, this re-fetches the links for all of the given view members. Links are fetched in bulk for servers that support it. If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(ViewMemberCollection);

See Also

LinkCache Class | StarTeam Namespace


LinkCache.Refresh Method (Folder, Item#Type, Int32)

public virtual void Refresh(
Folder folder,
Item.Type itemType,
Int32 depth
);

See Also

LinkCache Class | StarTeam Namespace | LinkCache.Refresh Overload List


LinkCache.Refresh Method (Item)

Ensures that the latest links are available for the given item.

Existing Link objects are modified in place whenever possible.

Note that since links are not currently MPX-aware, this re-fetches the links for the given item.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(
Item item
);

Parameters

item
The item whose links are to be refreshed.

See Also

LinkCache Class | StarTeam Namespace | LinkCache.Refresh Overload List


LinkCache.Refresh Method (View, Item#Type)

public virtual void Refresh(
View view,
Item.Type itemType
);

See Also

LinkCache Class | StarTeam Namespace | LinkCache.Refresh Overload List


LinkCache.Refresh Method (ViewMemberCollection)

Ensures that the latest links are available for all of the given view members.

Existing Link objects are modified in place whenever possible.

Note that since links are not currently MPX-aware, this re-fetches the links for all of the given view members. Links are fetched in bulk for servers that support it.

If there are any LinkUpdateListeners registered, they will each receive a linkAdded() event for each new link added to the cache, a linkRemoved() event for each old link removed from the cache, and a linkChanged() event for each cached link modified during the refresh.

public virtual void Refresh(
ViewMemberCollection list
);

Parameters

list
The list of view members whose links are to be refreshed.

See Also

LinkCache Class | StarTeam Namespace | LinkCache.Refresh Overload List


LinkCache.ToString Method

Delegate ToString() to com.starteam.LinkCache.

public override string ToString();

Return Value

com.starteam.LinkCache.ToString()

See Also

LinkCache Class | StarTeam Namespace


LinkProperty Class

This class represents a property whose value is a link.

For a list of all members of this type, see LinkProperty Members.

System.Object
Property
LinkProperty
ChangePackage.Type.ProcessItemProperty
LiveObject.Type.SourceProperty
LiveObject.Type.TargetProperty

public class LinkProperty : Property

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LinkProperty Members | StarTeam Namespace


LinkProperty Members

LinkProperty overview

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] LinkValue
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Creates a new query expression that tests this property endpoint against a DateTime value.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LinkProperty Class | StarTeam Namespace


LinkProperty Properties

The properties of the LinkProperty class are listed below. For a complete list of LinkProperty class members, see the LinkProperty Members topic.

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] LinkValue
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LinkProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

LinkProperty.DefaultValue Property

[read/write] LinkValue

new public virtual LinkValue DefaultValue {get; set;}

Property Value

LinkValue

See Also

LinkProperty Class | StarTeam Namespace


LinkProperty Methods

The methods of the LinkProperty class are listed below. For a complete list of LinkProperty class members, see the LinkProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Creates a new query expression that tests this property endpoint against a DateTime value.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LinkProperty Class | StarTeam Namespace


LinkProperty.HasDisplayValue Method

Returns true if this property has meaningful display values that may be included, for example, in an item table.

public virtual bool HasDisplayValue();

Return Value

boolean

See Also

LinkProperty Class | StarTeam Namespace


LinkProperty.NewQueryPart Method

Creates a new query expression that tests this property endpoint against a DateTime value.

public virtual QueryPart NewQueryPart(
DateTime value
);

Parameters

value
The DateTime value to be tested.

Return Value

A new query expression.

See Also

LinkProperty Class | StarTeam Namespace | MODIFIED_AFTER


LinkProperty.WebCacheLinkProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see LinkProperty.WebCacheLinkProperty Members.

System.Object
Property.WebCacheProperty
LinkProperty.WebCacheLinkProperty

public class LinkProperty.WebCacheLinkProperty : WebCacheProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LinkProperty.WebCacheLinkProperty Members | StarTeam Namespace


LinkProperty.WebCacheLinkProperty Members

LinkProperty.WebCacheLinkProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] LinkValue
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LinkProperty.WebCacheLinkProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LinkProperty.WebCacheLinkProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart | Creates a new query expression that tests this property endpoint against a DateTime value.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LinkProperty.WebCacheLinkProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty Properties

The properties of the LinkProperty.WebCacheLinkProperty class are listed below. For a complete list of LinkProperty.WebCacheLinkProperty class members, see the LinkProperty.WebCacheLinkProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] LinkValue
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.DefaultValue Property

[read/write] LinkValue

new public virtual LinkValue DefaultValue {get; set;}

Property Value

LinkValue

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.Name Property

new public virtual String Name {get;}

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

LinkProperty.WebCacheLinkProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty Methods

The methods of the LinkProperty.WebCacheLinkProperty class are listed below. For a complete list of LinkProperty.WebCacheLinkProperty class members, see the LinkProperty.WebCacheLinkProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LinkProperty.WebCacheLinkProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LinkProperty.WebCacheLinkProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart | Creates a new query expression that tests this property endpoint against a DateTime value.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LinkProperty.WebCacheLinkProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.Equals Method

Delegate Equals() to com.starteam.LinkProperty.WebCacheLinkProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LinkProperty.WebCacheLinkProperty.Equals(obj).

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LinkProperty.WebCacheLinkProperty.

public override int GetHashCode();

Return Value

com.starteam.LinkProperty.WebCacheLinkProperty.GetHashCode().

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.NewQueryPart Method

Creates a new query expression that tests this property endpoint against a DateTime value.

public virtual WebCacheQueryPart NewQueryPart(
DateTime value
);

Parameters

value
The DateTime value to be tested.

Return Value

A new query expression.

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace | MODIFIED_AFTER


LinkProperty.WebCacheLinkProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.ToString Method

Delegate ToString() to com.starteam.LinkProperty.WebCacheLinkProperty.

public override string ToString();

Return Value

com.starteam.LinkProperty.WebCacheLinkProperty.ToString()

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkProperty.WebCacheLinkProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

LinkProperty.WebCacheLinkProperty Class | StarTeam Namespace


LinkToTraceAdapter Class

An adapter class that surfaces a Link as if it were a Trace.

Since there are significant differences between the two models, the adapted link will actually be a new Trace (that is, a Trace that has not yet been saved to the StarTeam repository, for which isNew() returns true). Information from the Link is surfaced via the new Trace as described below.

  • Trace.getSource() will return a LinkValue that references the same Item as one of the Link endpoints.
  • Trace.getTarget() will return a LinkValue that references the same Item as the other Link endpoint.
  • Trace.getDescription() will return the same string as Link.getComment().
All other properties of the new Trace are initialized to their default values.

The new Trace can of course be modified by the client application, and/or saved to the StarTeam repository using Item.update(). A Trace saved this way is then unrelated to the original Link.

For a list of all members of this type, see LinkToTraceAdapter Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Trace
LinkToTraceAdapter

public class LinkToTraceAdapter : Trace

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LinkToTraceAdapter Members | StarTeam Namespace


LinkToTraceAdapter Members

LinkToTraceAdapter overview

Public Instance Constructors

LinkToTraceAdapter Constructor

Creates a new Trace that represents the information in the given Link as closely as possible.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description (inherited from Trace) | [read/write] The description of this trace.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsSuspect (inherited from Trace) | [read/write] true if the trace is suspect
IsUnread (inherited from ViewMember) | [read] boolean
Link | [read] Link
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order (inherited from Trace) | [read/write] the order in which the trace should be executed.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties (inherited from Trace) | [read] Collection of properties
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Source (inherited from Trace) | [read/write] The source endpoint of this trace.
StatusValue (inherited from Trace) | [read/write] Status
Target (inherited from Trace) | [read/write] The target endpoint of this trace.
TraceTypeValue (inherited from Trace) | [read/write] Trace.TraceType
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSourceVersions (inherited from Trace)
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from ViewMember) | Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Trace) | Determines whether share or reverse-share is the more appropriate operation when sharing this trace to the given target view.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
PinSource (inherited from Trace) | Set the source end-point of this trace to pinned. i.e. the source will match the specified revision of the ViewMember
PinTarget (inherited from Trace) | Set the target end-point of this trace to pinned. i.e. the target will match the specified revision of the ViewMember
PutLock (inherited from ViewMember)
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ReverseShareTo (inherited from Trace) | Transfers ownership of the root share of a trace to a new view, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding trace in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired trace revision in the target is not the tip revision of the trace being shared. The reverse share operation compensates for this by moving the trace to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original trace in the source view with a new share of the same underlying object. Since this is a new trace with a new VMID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new trace. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetSourceVersions (inherited from Trace)
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Trace) | Shares this trace to a new view. The shared trace will still exist in its original view as well as in the new one.
SmartShareTo (inherited from Trace) | Shares or reverse-shares this trace to the given target view, as appropriate. The new share uses a time-based configuration, and is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
UnpinSource (inherited from Trace) | Set the source end-point of this trace to float. i.e. the source will always match the tip ViewMember of the configuration
UnpinTarget (inherited from Trace) | Set the target end-point of this trace to float. i.e. the target will always match the tip ViewMember of the configuration
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

LinkToTraceAdapter Class | StarTeam Namespace


LinkToTraceAdapter Constructor

Creates a new Trace that represents the information in the given Link as closely as possible.

public LinkToTraceAdapter(
Link link
);

Parameters

link
The link to be adapted.

See Also

LinkToTraceAdapter Class | StarTeam Namespace


LinkToTraceAdapter Properties

The properties of the LinkToTraceAdapter class are listed below. For a complete list of LinkToTraceAdapter class members, see the LinkToTraceAdapter Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description (inherited from Trace) | [read/write] The description of this trace.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsSuspect (inherited from Trace) | [read/write] true if the trace is suspect
IsUnread (inherited from ViewMember) | [read] boolean
Link | [read] Link
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order (inherited from Trace) | [read/write] the order in which the trace should be executed.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties (inherited from Trace) | [read] Collection of properties
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Source (inherited from Trace) | [read/write] The source endpoint of this trace.
StatusValue (inherited from Trace) | [read/write] Status
Target (inherited from Trace) | [read/write] The target endpoint of this trace.
TraceTypeValue (inherited from Trace) | [read/write] Trace.TraceType
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

LinkToTraceAdapter Class | StarTeam Namespace


Link Property

Borland StarTeam SDK for .NET

LinkToTraceAdapter.Link Property

[read] Link

public virtual Link Link {get;}

Property Value

Link

See Also

LinkToTraceAdapter Class | StarTeam Namespace


LinkValue Class

A value of a LinkProperty.

For a list of all members of this type, see LinkValue Members.

System.Object
LinkValue

public class LinkValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LinkValue Members | StarTeam Namespace


LinkValue Members

LinkValue overview

Public Static Properties

VALUE_NOT_SET

Public Static Methods

ForExternalLink | Creates a LinkValue representing an external link to the given liveobject.
ForURL | Creates a LinkValue for the given URL.
ForViewMember | Creates a LinkValue representing a link to the given viewmember, relative to the given source view. Creates an internal link if possible, and an external link otherwise.
GetExternalLinkTo | Creates a LinkValue representing an external link to the given liveobject.
GetInternalLinkTo | return a LinkValue representing an internal link to the specified liveobject This linkValue has not been saved to the StarTeam server
GetLinkTo | Creates a LinkValue representing a link to the given liveobject, relative to the given source view. Creates an internal link if possible, and an external link otherwise.

Public Instance Constructors

LinkValue Overloaded. Initializes a new instance of the LinkValue class.

Public Instance Properties

ClassID | [read] the 'raw' classID describing the Type associated with this link value
Description | [read] A description of the linked item.
DotNotation | [read] A DotNotation, or null if the VersionID is not in the above format.
ExternalID | [read] String the versionID
IsFloating | [read] true if this LinkValue is floating w.r.t. its Trace
IsInternalLink | [read] boolean true if this LinkValue is an internal reference to a StarTeam view member on the same server; false otherwise.
IsPinned | [read] true if this LinkValue is pinned to its Trace
IsStarTeamLink | [read] boolean true if this LinkValue references a StarTeam item, either on this server or some other one.
ProjectID | [read] the 'raw' project ID associated with this link value
RootObjectID | [read] the root object ID of the underlying StarTeam Item
TimeStamp | [read] DateTime the revision timestamp
Type | [read] the Type of the link value for internal links
URL | [read] A URL that refers to the linked item.
Version | [read] String the link version
VersionID | [read] String the versionID
ViewID | [read] the 'raw' view ID associated with this link value
VMID | [read] int the VMID of the item or -1

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LinkValue.
GetHashCode | Delegate GetHashCode() to com.starteam.LinkValue.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Similar to equals().
IsInternalTo | Overloaded. Determines whether or not this is an internal link to a StarTeam item in the same view as the given one.
ToStarTeamItem | Gets a full-resolved version of the referenced view member. Throws an exception if this LinkValue does not reference a StarTeam artifact, or if the referenced item cannot be resolved. returns null if this is not a viewmember (e.g. a project or a change)
ToString | Delegate ToString() to com.starteam.LinkValue.

See Also

LinkValue Class | StarTeam Namespace


LinkValue Constructor

Create a LinkValue from another one

Overload List

Create a LinkValue from another one

public LinkValue(LinkValue);

Construct an External LinkValue representing a Pulse Changeset i.e. File or Folder artifacts from external (non StarTeam) systems

public LinkValue(String,String,String);

See Also

LinkValue Class | StarTeam Namespace


LinkValue Constructor (LinkValue)

Create a LinkValue from another one

public LinkValue(
LinkValue other
);

Parameters

other
the other linkValue to use as the source

See Also

LinkValue Class | StarTeam Namespace | LinkValue Constructor Overload List


LinkValue Constructor (String, String, String)

Construct an External LinkValue representing a Pulse Changeset i.e. File or Folder artifacts from external (non StarTeam) systems

public LinkValue(
String identifier,
String revision,
String displayPath
);

Parameters

identifier
an identifier
revision
a revision
displayPath
a display path

See Also

LinkValue Class | StarTeam Namespace | LinkValue Constructor Overload List


LinkValue Properties

The properties of the LinkValue class are listed below. For a complete list of LinkValue class members, see the LinkValue Members topic.

Public Static Properties

VALUE_NOT_SET

Public Instance Properties

ClassID | [read] the 'raw' classID describing the Type associated with this link value
Description | [read] A description of the linked item.
DotNotation | [read] A DotNotation, or null if the VersionID is not in the above format.
ExternalID | [read] String the versionID
IsFloating | [read] true if this LinkValue is floating w.r.t. its Trace
IsInternalLink | [read] boolean true if this LinkValue is an internal reference to a StarTeam view member on the same server; false otherwise.
IsPinned | [read] true if this LinkValue is pinned to its Trace
IsStarTeamLink | [read] boolean true if this LinkValue references a StarTeam item, either on this server or some other one.
ProjectID | [read] the 'raw' project ID associated with this link value
RootObjectID | [read] the root object ID of the underlying StarTeam Item
TimeStamp | [read] DateTime the revision timestamp
Type | [read] the Type of the link value for internal links
URL | [read] A URL that refers to the linked item.
Version | [read] String the link version
VersionID | [read] String the versionID
ViewID | [read] the 'raw' view ID associated with this link value
VMID | [read] int the VMID of the item or -1

See Also

LinkValue Class | StarTeam Namespace


ClassID Property

Borland StarTeam SDK for .NET

LinkValue.ClassID Property

[read] the 'raw' classID describing the Type associated with this link value

public virtual Int32 ClassID {get;}

Property Value

the 'raw' classID describing the Type associated with this link value

See Also

LinkValue Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

LinkValue.Description Property

[read] A description of the linked item.

public virtual String Description {get;}

Property Value

A description of the linked item.

See Also

LinkValue Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

LinkValue.DotNotation Property

[read] A DotNotation, or null if the VersionID is not in the above format.

public virtual DotNotation DotNotation {get;}

Property Value

A DotNotation, or null if the VersionID is not in the above format.

See Also

LinkValue Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

LinkValue.ExternalID Property

[read] String the versionID

public virtual String ExternalID {get;}

Property Value

String the versionID

See Also

LinkValue Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

LinkValue.IsFloating Property

[read] true if this LinkValue is floating w.r.t. its Trace

public virtual Boolean IsFloating {get;}

Property Value

true if this LinkValue is floating w.r.t. its Trace

See Also

LinkValue Class | StarTeam Namespace


IsInternalLink Property

Borland StarTeam SDK for .NET

LinkValue.IsInternalLink Property

[read] boolean true if this LinkValue is an internal reference to a StarTeam view member on the same server; false otherwise.

public virtual Boolean IsInternalLink {get;}

Property Value

boolean true if this LinkValue is an internal reference to a StarTeam view member on the same server; false otherwise.

See Also

LinkValue Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

LinkValue.IsPinned Property

[read] true if this LinkValue is pinned to its Trace

public virtual Boolean IsPinned {get;}

Property Value

true if this LinkValue is pinned to its Trace

See Also

LinkValue Class | StarTeam Namespace


IsStarTeamLink Property

Borland StarTeam SDK for .NET

LinkValue.IsStarTeamLink Property

[read] boolean true if this LinkValue references a StarTeam item, either on this server or some other one.

public virtual Boolean IsStarTeamLink {get;}

Property Value

boolean true if this LinkValue references a StarTeam item, either on this server or some other one.

See Also

LinkValue Class | StarTeam Namespace


ProjectID Property

Borland StarTeam SDK for .NET

LinkValue.ProjectID Property

[read] the 'raw' project ID associated with this link value

public virtual Int32 ProjectID {get;}

Property Value

the 'raw' project ID associated with this link value

See Also

LinkValue Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

LinkValue.RootObjectID Property

[read] the root object ID of the underlying StarTeam Item

public virtual Int32 RootObjectID {get;}

Property Value

the root object ID of the underlying StarTeam Item

See Also

LinkValue Class | StarTeam Namespace


TimeStamp Property

Borland StarTeam SDK for .NET

LinkValue.TimeStamp Property

[read] DateTime the revision timestamp

public virtual DateTime TimeStamp {get;}

Property Value

DateTime the revision timestamp

See Also

LinkValue Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

LinkValue.Type Property

[read] the Type of the link value for internal links

public virtual ViewMember.Type Type {get;}

Property Value

the Type of the link value for internal links

See Also

LinkValue Class | StarTeam Namespace


URL Property

Borland StarTeam SDK for .NET

LinkValue.URL Property

[read] A URL that refers to the linked item.

public virtual String URL {get;}

Property Value

A URL that refers to the linked item.

See Also

LinkValue Class | StarTeam Namespace


VALUE_NOT_SET Property

Borland StarTeam SDK for .NET

LinkValue.VALUE_NOT_SET Property

public static LinkValue VALUE_NOT_SET {get;}

Property Value

The "not set" value.

See Also

LinkValue Class | StarTeam Namespace


Version Property

Borland StarTeam SDK for .NET

LinkValue.Version Property

[read] String the link version

public virtual String Version {get;}

Property Value

String the link version

See Also

LinkValue Class | StarTeam Namespace


VersionID Property

Borland StarTeam SDK for .NET

LinkValue.VersionID Property

[read] String the versionID

public virtual String VersionID {get;}

Property Value

String the versionID

See Also

LinkValue Class | StarTeam Namespace


ViewID Property

Borland StarTeam SDK for .NET

LinkValue.ViewID Property

[read] the 'raw' view ID associated with this link value

public virtual Int32 ViewID {get;}

Property Value

the 'raw' view ID associated with this link value

See Also

LinkValue Class | StarTeam Namespace


VMID Property

Borland StarTeam SDK for .NET

LinkValue.VMID Property

[read] int the VMID of the item or -1

public virtual Int32 VMID {get;}

Property Value

int the VMID of the item or -1

See Also

LinkValue Class | StarTeam Namespace


LinkValue Methods

The methods of the LinkValue class are listed below. For a complete list of LinkValue class members, see the LinkValue Members topic.

Public Static Methods

ForExternalLink | Creates a LinkValue representing an external link to the given liveobject.
ForURL | Creates a LinkValue for the given URL.
ForViewMember | Creates a LinkValue representing a link to the given viewmember, relative to the given source view. Creates an internal link if possible, and an external link otherwise.
GetExternalLinkTo | Creates a LinkValue representing an external link to the given liveobject.
GetInternalLinkTo | return a LinkValue representing an internal link to the specified liveobject This linkValue has not been saved to the StarTeam server
GetLinkTo | Creates a LinkValue representing a link to the given liveobject, relative to the given source view. Creates an internal link if possible, and an external link otherwise.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LinkValue.
GetHashCode | Delegate GetHashCode() to com.starteam.LinkValue.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Similar to equals().
IsInternalTo | Overloaded. Determines whether or not this is an internal link to a StarTeam item in the same view as the given one.
ToStarTeamItem | Gets a full-resolved version of the referenced view member. Throws an exception if this LinkValue does not reference a StarTeam artifact, or if the referenced item cannot be resolved. returns null if this is not a viewmember (e.g. a project or a change)
ToString | Delegate ToString() to com.starteam.LinkValue.

See Also

LinkValue Class | StarTeam Namespace


LinkValue.Equals Method

Delegate Equals() to com.starteam.LinkValue.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LinkValue.Equals(obj).

See Also

LinkValue Class | StarTeam Namespace


LinkValue.ForExternalLink Method

Creates a LinkValue representing an external link to the given liveobject.

public static LinkValue ForExternalLink(
LiveObject vm
);

Parameters

vm
ViewMember

Return Value

LinkValue

See Also

LinkValue Class | StarTeam Namespace


LinkValue.ForURL Method

Creates a LinkValue for the given URL.

public static LinkValue ForURL(
String url,
String description
);

Parameters

url
String
description
String

Return Value

LinkValue

See Also

LinkValue Class | StarTeam Namespace


LinkValue.ForViewMember Method

Creates a LinkValue representing a link to the given viewmember, relative to the given source view. Creates an internal link if possible, and an external link otherwise.

public static LinkValue ForViewMember(
ViewMember vm,
View source
);

Parameters

vm
ViewMember
source
View

Return Value

LinkValue

See Also

LinkValue Class | StarTeam Namespace


LinkValue.GetExternalLinkTo Method

Creates a LinkValue representing an external link to the given liveobject.

public static LinkValue GetExternalLinkTo(
LiveObject vm
);

Parameters

vm
ViewMember

Return Value

LinkValue

See Also

LinkValue Class | StarTeam Namespace


LinkValue.GetHashCode Method

Delegate GetHashCode() to com.starteam.LinkValue.

public override int GetHashCode();

Return Value

com.starteam.LinkValue.GetHashCode().

See Also

LinkValue Class | StarTeam Namespace


LinkValue.GetInternalLinkTo Method

return a LinkValue representing an internal link to the specified liveobject This linkValue has not been saved to the StarTeam server

public static LinkValue GetInternalLinkTo(
LiveObject vm
);

Parameters

vm
the liveobject

Return Value

a newly created internal link value

See Also

LinkValue Class | StarTeam Namespace


LinkValue.GetLinkTo Method

Creates a LinkValue representing a link to the given liveobject, relative to the given source view. Creates an internal link if possible, and an external link otherwise.

public static LinkValue GetLinkTo(
LiveObject vm,
View source
);

Parameters

vm
ViewMember
source
View

Return Value

LinkValue

See Also

LinkValue Class | StarTeam Namespace


LinkValue.IsEqualTo Method

Similar to equals().

public virtual bool IsEqualTo(
LinkValue v
);

Parameters

v
LinkValue

Return Value

boolean

See Also

LinkValue Class | StarTeam Namespace


IsInternalTo Method

Borland StarTeam SDK for .NET

LinkValue.IsInternalTo Method

Determines whether or not this is an internal link to a StarTeam item in the same project as the given one.

Overload List

Determines whether or not this is an internal link to a StarTeam item in the same project as the given one.

public virtual bool IsInternalTo(Project);

Determines whether or not this is an internal link to a StarTeam item in the same view as the given one.

public virtual bool IsInternalTo(View);

See Also

LinkValue Class | StarTeam Namespace | isInternalLink | isInternalTo


LinkValue.IsInternalTo Method (Project)

Determines whether or not this is an internal link to a StarTeam item in the same project as the given one.

public virtual bool IsInternalTo(
Project project
);

Parameters

project
the Project to test

Return Value

boolean true if internal to this project

See Also

LinkValue Class | StarTeam Namespace | LinkValue.IsInternalTo Overload List | isInternalLink | isInternalTo


LinkValue.IsInternalTo Method (View)

Determines whether or not this is an internal link to a StarTeam item in the same view as the given one.

public virtual bool IsInternalTo(
View view
);

Parameters

view
the View to test

Return Value

boolean true if internal to this view

See Also

LinkValue Class | StarTeam Namespace | LinkValue.IsInternalTo Overload List | isInternalLink | isInternalTo


LinkValue.ToStarTeamItem Method

Gets a full-resolved version of the referenced view member. Throws an exception if this LinkValue does not reference a StarTeam artifact, or if the referenced item cannot be resolved. returns null if this is not a viewmember (e.g. a project or a change)

public virtual ViewMember ToStarTeamItem();

See Also

LinkValue Class | StarTeam Namespace


LinkValue.ToString Method

Delegate ToString() to com.starteam.LinkValue.

public override string ToString();

Return Value

com.starteam.LinkValue.ToString()

See Also

LinkValue Class | StarTeam Namespace


LinkValue.WebCacheLinkValue Class

The value of a Link Property

For a list of all members of this type, see LinkValue.WebCacheLinkValue Members.

System.Object
LinkValue.WebCacheLinkValue

public class LinkValue.WebCacheLinkValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LinkValue.WebCacheLinkValue Members | StarTeam Namespace


LinkValue.WebCacheLinkValue Members

LinkValue.WebCacheLinkValue overview

Public Static Methods

Create
ForViewMember
GetTargets

Public Instance Properties

Description | [read] A description of the linked item.
DotNotation | [read] A DotNotation, or null if the VersionID is not in the above format.
ExternalID | [read] String the versionID
ID | [read] int the ID of the linked item
IsFloating | [read] true if this LinkValue is floating w.r.t. its Trace
IsInternalLink | [read] boolean true if this LinkValue is an internal reference to a StarTeam view member on the same server; false otherwise.
IsPinned | [read] true if this LinkValue is pinned to its Trace
IsStarTeamLink | [read] boolean true if this LinkValue references a StarTeam item, either on this server or some other one.
Project | [read] the project targeted by the StarTeam Item represented by this link value
TimeStamp | [read] DateTime the revision timestamp or NULL
Type | [read] the Type of the link value for internal links
URL | [read] A URL that refers to the linked item.
Version | [read] String
VersionID | [read] String
View | [read] the view targeted by the StarTeam Item represented by this link value

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LinkValue.WebCacheLinkValue.
GetHashCode | Delegate GetHashCode() to com.starteam.LinkValue.WebCacheLinkValue.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInternalTo | Overloaded.
ToString | Delegate ToString() to com.starteam.LinkValue.WebCacheLinkValue.

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


LinkValue.WebCacheLinkValue Properties

The properties of the LinkValue.WebCacheLinkValue class are listed below. For a complete list of LinkValue.WebCacheLinkValue class members, see the LinkValue.WebCacheLinkValue Members topic.

Public Instance Properties

Description | [read] A description of the linked item.
DotNotation | [read] A DotNotation, or null if the VersionID is not in the above format.
ExternalID | [read] String the versionID
ID | [read] int the ID of the linked item
IsFloating | [read] true if this LinkValue is floating w.r.t. its Trace
IsInternalLink | [read] boolean true if this LinkValue is an internal reference to a StarTeam view member on the same server; false otherwise.
IsPinned | [read] true if this LinkValue is pinned to its Trace
IsStarTeamLink | [read] boolean true if this LinkValue references a StarTeam item, either on this server or some other one.
Project | [read] the project targeted by the StarTeam Item represented by this link value
TimeStamp | [read] DateTime the revision timestamp or NULL
Type | [read] the Type of the link value for internal links
URL | [read] A URL that refers to the linked item.
Version | [read] String
VersionID | [read] String
View | [read] the view targeted by the StarTeam Item represented by this link value

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.Description Property

[read] A description of the linked item.

public virtual String Description {get;}

Property Value

A description of the linked item.

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.DotNotation Property

[read] A DotNotation, or null if the VersionID is not in the above format.

public virtual DotNotation DotNotation {get;}

Property Value

A DotNotation, or null if the VersionID is not in the above format.

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.ExternalID Property

[read] String the versionID

public virtual String ExternalID {get;}

Property Value

String the versionID

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.ID Property

[read] int the ID of the linked item

public virtual Int32 ID {get;}

Property Value

int the ID of the linked item

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.IsFloating Property

[read] true if this LinkValue is floating w.r.t. its Trace

public virtual Boolean IsFloating {get;}

Property Value

true if this LinkValue is floating w.r.t. its Trace

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


IsInternalLink Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.IsInternalLink Property

[read] boolean true if this LinkValue is an internal reference to a StarTeam view member on the same server; false otherwise.

public virtual Boolean IsInternalLink {get;}

Property Value

boolean true if this LinkValue is an internal reference to a StarTeam view member on the same server; false otherwise.

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.IsPinned Property

[read] true if this LinkValue is pinned to its Trace

public virtual Boolean IsPinned {get;}

Property Value

true if this LinkValue is pinned to its Trace

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


IsStarTeamLink Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.IsStarTeamLink Property

[read] boolean true if this LinkValue references a StarTeam item, either on this server or some other one.

public virtual Boolean IsStarTeamLink {get;}

Property Value

boolean true if this LinkValue references a StarTeam item, either on this server or some other one.

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.Project Property

[read] the project targeted by the StarTeam Item represented by this link value

public virtual Project.WebCacheProject Project {get;}

Property Value

the project targeted by the StarTeam Item represented by this link value

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


TimeStamp Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.TimeStamp Property

[read] DateTime the revision timestamp or NULL

public virtual DateTime TimeStamp {get;}

Property Value

DateTime the revision timestamp or NULL

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.Type Property

[read] the Type of the link value for internal links

public virtual ViewMember.Type.WebCacheViewMemberType Type {get;}

Property Value

the Type of the link value for internal links

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


URL Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.URL Property

[read] A URL that refers to the linked item.

public virtual String URL {get;}

Property Value

A URL that refers to the linked item.

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


Version Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.Version Property

[read] String

public virtual String Version {get;}

Property Value

String

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


VersionID Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.VersionID Property

[read] String

public virtual String VersionID {get;}

Property Value

String

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.View Property

[read] the view targeted by the StarTeam Item represented by this link value

public virtual View.WebCacheView View {get;}

Property Value

the view targeted by the StarTeam Item represented by this link value

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


LinkValue.WebCacheLinkValue Methods

The methods of the LinkValue.WebCacheLinkValue class are listed below. For a complete list of LinkValue.WebCacheLinkValue class members, see the LinkValue.WebCacheLinkValue Members topic.

Public Static Methods

Create
ForViewMember
GetTargets

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LinkValue.WebCacheLinkValue.
GetHashCode | Delegate GetHashCode() to com.starteam.LinkValue.WebCacheLinkValue.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInternalTo | Overloaded.
ToString | Delegate ToString() to com.starteam.LinkValue.WebCacheLinkValue.

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


LinkValue.WebCacheLinkValue.Create Method

public static WebCacheLinkValue Create(
ArtifactCacheManager.Context cntxt,
String url,
String description
);

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


LinkValue.WebCacheLinkValue.Equals Method

Delegate Equals() to com.starteam.LinkValue.WebCacheLinkValue.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LinkValue.WebCacheLinkValue.Equals(obj).

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


LinkValue.WebCacheLinkValue.ForViewMember Method

public static WebCacheLinkValue ForViewMember(
ViewMember.WebCacheViewMember vm,
View.WebCacheView vw
);

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


LinkValue.WebCacheLinkValue.GetHashCode Method

Delegate GetHashCode() to com.starteam.LinkValue.WebCacheLinkValue.

public override int GetHashCode();

Return Value

com.starteam.LinkValue.WebCacheLinkValue.GetHashCode().

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


LinkValue.WebCacheLinkValue.GetTargets Method

public static object GetTargets(
WebCacheLinkValue[] sources
);

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


IsInternalTo Method

Borland StarTeam SDK for .NET

LinkValue.WebCacheLinkValue.IsInternalTo Method

Overload List

public virtual bool IsInternalTo(Project.WebCacheProject);

public virtual bool IsInternalTo(View.WebCacheView);

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


LinkValue.WebCacheLinkValue.IsInternalTo Method (Project#WebCacheProject)

public virtual bool IsInternalTo(
Project.WebCacheProject project
);

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace | LinkValue.WebCacheLinkValue.IsInternalTo Overload List


LinkValue.WebCacheLinkValue.IsInternalTo Method (View#WebCacheView)

public virtual bool IsInternalTo(
View.WebCacheView view
);

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace | LinkValue.WebCacheLinkValue.IsInternalTo Overload List


LinkValue.WebCacheLinkValue.ToString Method

Delegate ToString() to com.starteam.LinkValue.WebCacheLinkValue.

public override string ToString();

Return Value

com.starteam.LinkValue.WebCacheLinkValue.ToString()

See Also

LinkValue.WebCacheLinkValue Class | StarTeam Namespace


LiveObject Class

LiveObjects store in the repository the date/time when the object was created, and the ID of the user who created it. LiveObjects are soft deleted; that is, they are marked deleted as of a given time, but can still be seen in rolled back view configurations.

For a list of all members of this type, see LiveObject Members.

System.Object
TypedResource
LiveObject
Derived types

public class LiveObject : TypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject Members | StarTeam Namespace


LiveObject Members

LiveObject overview

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

LiveObject Class | StarTeam Namespace


LiveObject Properties

The properties of the LiveObject class are listed below. For a complete list of LiveObject class members, see the LiveObject Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource

See Also

LiveObject Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

LiveObject.CreatedBy Property

[read] The user who created this object.

public virtual User CreatedBy {get;}

Property Value

The user who created this object.

See Also

LiveObject Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

LiveObject.CreatedTime Property

[read] The date and time at which this object was created.

public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

LiveObject Class | StarTeam Namespace


LiveObject Methods

The methods of the LiveObject class are listed below. For a complete list of LiveObject class members, see the LiveObject Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

LiveObject Class | StarTeam Namespace


LiveObject.ToStarTeamURL Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies the resource

See Also

LiveObject Class | StarTeam Namespace


LiveObject.Type Class

The Type for LiveObject

For a list of all members of this type, see LiveObject.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
Derived types

new public class LiveObject.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type Members | StarTeam Namespace


LiveObject.Type Members

LiveObject.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.LiveObject.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.LiveObject.Type.

See Also

LiveObject.Type Class | StarTeam Namespace


LiveObject.Type Properties

The properties of the LiveObject.Type class are listed below. For a complete list of LiveObject.Type class members, see the LiveObject.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

LiveObject.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.NAME Property

new public static String NAME {get;}

See Also

LiveObject.Type Class | StarTeam Namespace


LiveObject.Type Methods

The methods of the LiveObject.Type class are listed below. For a complete list of LiveObject.Type class members, see the LiveObject.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.LiveObject.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.LiveObject.Type.

See Also

LiveObject.Type Class | StarTeam Namespace


LiveObject.Type.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.Equals(obj).

See Also

LiveObject.Type Class | StarTeam Namespace


LiveObject.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.GetHashCode().

See Also

LiveObject.Type Class | StarTeam Namespace


LiveObject.Type.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.ToString()

See Also

LiveObject.Type Class | StarTeam Namespace


LiveObject.Type.CreatedByProperty Class

The property type of the Created By property.

For a list of all members of this type, see LiveObject.Type.CreatedByProperty Members.

System.Object
Property
ObjectProperty
LiveObject.Type.CreatedByProperty

public class LiveObject.Type.CreatedByProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.CreatedByProperty Members | StarTeam Namespace


LiveObject.Type.CreatedByProperty Members

LiveObject.Type.CreatedByProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.CreatedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.CreatedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.CreatedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.CreatedByProperty Class | StarTeam Namespace


LiveObject.Type.CreatedByProperty Properties

The properties of the LiveObject.Type.CreatedByProperty class are listed below. For a complete list of LiveObject.Type.CreatedByProperty class members, see the LiveObject.Type.CreatedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

LiveObject.Type.CreatedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.CreatedByProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.CreatedByProperty Class | StarTeam Namespace


LiveObject.Type.CreatedByProperty Methods

The methods of the LiveObject.Type.CreatedByProperty class are listed below. For a complete list of LiveObject.Type.CreatedByProperty class members, see the LiveObject.Type.CreatedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.CreatedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.CreatedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.CreatedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.CreatedByProperty Class | StarTeam Namespace


LiveObject.Type.CreatedByProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.CreatedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.CreatedByProperty.Equals(obj).

See Also

LiveObject.Type.CreatedByProperty Class | StarTeam Namespace


LiveObject.Type.CreatedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.CreatedByProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.CreatedByProperty.GetHashCode().

See Also

LiveObject.Type.CreatedByProperty Class | StarTeam Namespace


LiveObject.Type.CreatedByProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.CreatedByProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.CreatedByProperty.ToString()

See Also

LiveObject.Type.CreatedByProperty Class | StarTeam Namespace


LiveObject.Type.CreatedTimeProperty Class

The property type of the Created Time property.

For a list of all members of this type, see LiveObject.Type.CreatedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
LiveObject.Type.CreatedTimeProperty

public class LiveObject.Type.CreatedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.CreatedTimeProperty Members | StarTeam Namespace


LiveObject.Type.CreatedTimeProperty Members

LiveObject.Type.CreatedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.CreatedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.CreatedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.CreatedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.CreatedTimeProperty Class | StarTeam Namespace


LiveObject.Type.CreatedTimeProperty Properties

The properties of the LiveObject.Type.CreatedTimeProperty class are listed below. For a complete list of LiveObject.Type.CreatedTimeProperty class members, see the LiveObject.Type.CreatedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LiveObject.Type.CreatedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.CreatedTimeProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.CreatedTimeProperty Class | StarTeam Namespace


LiveObject.Type.CreatedTimeProperty Methods

The methods of the LiveObject.Type.CreatedTimeProperty class are listed below. For a complete list of LiveObject.Type.CreatedTimeProperty class members, see the LiveObject.Type.CreatedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.CreatedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.CreatedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.CreatedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.CreatedTimeProperty Class | StarTeam Namespace


LiveObject.Type.CreatedTimeProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.CreatedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.CreatedTimeProperty.Equals(obj).

See Also

LiveObject.Type.CreatedTimeProperty Class | StarTeam Namespace


LiveObject.Type.CreatedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.CreatedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.CreatedTimeProperty.GetHashCode().

See Also

LiveObject.Type.CreatedTimeProperty Class | StarTeam Namespace


LiveObject.Type.CreatedTimeProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.CreatedTimeProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.CreatedTimeProperty.ToString()

See Also

LiveObject.Type.CreatedTimeProperty Class | StarTeam Namespace


LiveObject.Type.DeletedByProperty Class

The property type of the Deleted By property.

For a list of all members of this type, see LiveObject.Type.DeletedByProperty Members.

System.Object
Property
ObjectProperty
LiveObject.Type.DeletedByProperty

public class LiveObject.Type.DeletedByProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.DeletedByProperty Members | StarTeam Namespace


LiveObject.Type.DeletedByProperty Members

LiveObject.Type.DeletedByProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.DeletedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.DeletedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.DeletedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.DeletedByProperty Class | StarTeam Namespace


LiveObject.Type.DeletedByProperty Properties

The properties of the LiveObject.Type.DeletedByProperty class are listed below. For a complete list of LiveObject.Type.DeletedByProperty class members, see the LiveObject.Type.DeletedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

LiveObject.Type.DeletedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.DeletedByProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.DeletedByProperty Class | StarTeam Namespace


LiveObject.Type.DeletedByProperty Methods

The methods of the LiveObject.Type.DeletedByProperty class are listed below. For a complete list of LiveObject.Type.DeletedByProperty class members, see the LiveObject.Type.DeletedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.DeletedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.DeletedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.DeletedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.DeletedByProperty Class | StarTeam Namespace


LiveObject.Type.DeletedByProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.DeletedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.DeletedByProperty.Equals(obj).

See Also

LiveObject.Type.DeletedByProperty Class | StarTeam Namespace


LiveObject.Type.DeletedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.DeletedByProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.DeletedByProperty.GetHashCode().

See Also

LiveObject.Type.DeletedByProperty Class | StarTeam Namespace


LiveObject.Type.DeletedByProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.DeletedByProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.DeletedByProperty.ToString()

See Also

LiveObject.Type.DeletedByProperty Class | StarTeam Namespace


LiveObject.Type.DeletedTimeProperty Class

The property type of the Deleted Time property.

For a list of all members of this type, see LiveObject.Type.DeletedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
LiveObject.Type.DeletedTimeProperty

public class LiveObject.Type.DeletedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.DeletedTimeProperty Members | StarTeam Namespace


LiveObject.Type.DeletedTimeProperty Members

LiveObject.Type.DeletedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.DeletedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.DeletedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.DeletedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.DeletedTimeProperty Class | StarTeam Namespace


LiveObject.Type.DeletedTimeProperty Properties

The properties of the LiveObject.Type.DeletedTimeProperty class are listed below. For a complete list of LiveObject.Type.DeletedTimeProperty class members, see the LiveObject.Type.DeletedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LiveObject.Type.DeletedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.DeletedTimeProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.DeletedTimeProperty Class | StarTeam Namespace


LiveObject.Type.DeletedTimeProperty Methods

The methods of the LiveObject.Type.DeletedTimeProperty class are listed below. For a complete list of LiveObject.Type.DeletedTimeProperty class members, see the LiveObject.Type.DeletedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.DeletedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.DeletedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.DeletedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.DeletedTimeProperty Class | StarTeam Namespace


LiveObject.Type.DeletedTimeProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.DeletedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.DeletedTimeProperty.Equals(obj).

See Also

LiveObject.Type.DeletedTimeProperty Class | StarTeam Namespace


LiveObject.Type.DeletedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.DeletedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.DeletedTimeProperty.GetHashCode().

See Also

LiveObject.Type.DeletedTimeProperty Class | StarTeam Namespace


LiveObject.Type.DeletedTimeProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.DeletedTimeProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.DeletedTimeProperty.ToString()

See Also

LiveObject.Type.DeletedTimeProperty Class | StarTeam Namespace


LiveObject.Type.DescriptionProperty Class

The property type of the Description property.

For a list of all members of this type, see LiveObject.Type.DescriptionProperty Members.

System.Object
Property
VectorProperty
TextProperty
LiveObject.Type.DescriptionProperty

public class LiveObject.Type.DescriptionProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.DescriptionProperty Members | StarTeam Namespace


LiveObject.Type.DescriptionProperty Members

LiveObject.Type.DescriptionProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.DescriptionProperty Class | StarTeam Namespace


LiveObject.Type.DescriptionProperty Properties

The properties of the LiveObject.Type.DescriptionProperty class are listed below. For a complete list of LiveObject.Type.DescriptionProperty class members, see the LiveObject.Type.DescriptionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LiveObject.Type.DescriptionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.DescriptionProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.DescriptionProperty Class | StarTeam Namespace


LiveObject.Type.DescriptionProperty Methods

The methods of the LiveObject.Type.DescriptionProperty class are listed below. For a complete list of LiveObject.Type.DescriptionProperty class members, see the LiveObject.Type.DescriptionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.DescriptionProperty Class | StarTeam Namespace


LiveObject.Type.DescriptionProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.DescriptionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.DescriptionProperty.Equals(obj).

See Also

LiveObject.Type.DescriptionProperty Class | StarTeam Namespace


LiveObject.Type.DescriptionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.DescriptionProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.DescriptionProperty.GetHashCode().

See Also

LiveObject.Type.DescriptionProperty Class | StarTeam Namespace


LiveObject.Type.DescriptionProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.DescriptionProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.DescriptionProperty.ToString()

See Also

LiveObject.Type.DescriptionProperty Class | StarTeam Namespace


LiveObject.Type.FlagsProperty Class

The property type of the Flags property.

For a list of all members of this type, see LiveObject.Type.FlagsProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
LiveObject.Type.FlagsProperty

public class LiveObject.Type.FlagsProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.FlagsProperty Members | StarTeam Namespace


LiveObject.Type.FlagsProperty Members

LiveObject.Type.FlagsProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.FlagsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.FlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.FlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.FlagsProperty Class | StarTeam Namespace


LiveObject.Type.FlagsProperty Properties

The properties of the LiveObject.Type.FlagsProperty class are listed below. For a complete list of LiveObject.Type.FlagsProperty class members, see the LiveObject.Type.FlagsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LiveObject.Type.FlagsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.FlagsProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.FlagsProperty Class | StarTeam Namespace


LiveObject.Type.FlagsProperty Methods

The methods of the LiveObject.Type.FlagsProperty class are listed below. For a complete list of LiveObject.Type.FlagsProperty class members, see the LiveObject.Type.FlagsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.FlagsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.FlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.FlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.FlagsProperty Class | StarTeam Namespace


LiveObject.Type.FlagsProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.FlagsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.FlagsProperty.Equals(obj).

See Also

LiveObject.Type.FlagsProperty Class | StarTeam Namespace


LiveObject.Type.FlagsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.FlagsProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.FlagsProperty.GetHashCode().

See Also

LiveObject.Type.FlagsProperty Class | StarTeam Namespace


LiveObject.Type.FlagsProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.FlagsProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.FlagsProperty.ToString()

See Also

LiveObject.Type.FlagsProperty Class | StarTeam Namespace


LiveObject.Type.GlobalIDProperty Class

The property type of the Global ID property.

For a list of all members of this type, see LiveObject.Type.GlobalIDProperty Members.

System.Object
Property
ScalarProperty
LongIntegerProperty
LiveObject.Type.GlobalIDProperty

public class LiveObject.Type.GlobalIDProperty : LongIntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.GlobalIDProperty Members | StarTeam Namespace


LiveObject.Type.GlobalIDProperty Members

LiveObject.Type.GlobalIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LongIntegerProperty) | [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from LongIntegerProperty) | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from LongIntegerProperty) | [read/write] long
MinValue (inherited from LongIntegerProperty) | [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.GlobalIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.GlobalIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LongIntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.GlobalIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.GlobalIDProperty Class | StarTeam Namespace


LiveObject.Type.GlobalIDProperty Properties

The properties of the LiveObject.Type.GlobalIDProperty class are listed below. For a complete list of LiveObject.Type.GlobalIDProperty class members, see the LiveObject.Type.GlobalIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LongIntegerProperty) | [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from LongIntegerProperty) | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from LongIntegerProperty) | [read/write] long
MinValue (inherited from LongIntegerProperty) | [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LiveObject.Type.GlobalIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.GlobalIDProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.GlobalIDProperty Class | StarTeam Namespace


LiveObject.Type.GlobalIDProperty Methods

The methods of the LiveObject.Type.GlobalIDProperty class are listed below. For a complete list of LiveObject.Type.GlobalIDProperty class members, see the LiveObject.Type.GlobalIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.GlobalIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.GlobalIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LongIntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.GlobalIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.GlobalIDProperty Class | StarTeam Namespace


LiveObject.Type.GlobalIDProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.GlobalIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.GlobalIDProperty.Equals(obj).

See Also

LiveObject.Type.GlobalIDProperty Class | StarTeam Namespace


LiveObject.Type.GlobalIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.GlobalIDProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.GlobalIDProperty.GetHashCode().

See Also

LiveObject.Type.GlobalIDProperty Class | StarTeam Namespace


LiveObject.Type.GlobalIDProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.GlobalIDProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.GlobalIDProperty.ToString()

See Also

LiveObject.Type.GlobalIDProperty Class | StarTeam Namespace


LiveObject.Type.NameProperty Class

The property type of the Name property.

For a list of all members of this type, see LiveObject.Type.NameProperty Members.

System.Object
Property
VectorProperty
TextProperty
LiveObject.Type.NameProperty

public class LiveObject.Type.NameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.NameProperty Members | StarTeam Namespace


LiveObject.Type.NameProperty Members

LiveObject.Type.NameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.NameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.NameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.NameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.NameProperty Class | StarTeam Namespace


LiveObject.Type.NameProperty Properties

The properties of the LiveObject.Type.NameProperty class are listed below. For a complete list of LiveObject.Type.NameProperty class members, see the LiveObject.Type.NameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LiveObject.Type.NameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.NameProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.NameProperty Class | StarTeam Namespace


LiveObject.Type.NameProperty Methods

The methods of the LiveObject.Type.NameProperty class are listed below. For a complete list of LiveObject.Type.NameProperty class members, see the LiveObject.Type.NameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.NameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.NameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.NameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.NameProperty Class | StarTeam Namespace


LiveObject.Type.NameProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.NameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.NameProperty.Equals(obj).

See Also

LiveObject.Type.NameProperty Class | StarTeam Namespace


LiveObject.Type.NameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.NameProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.NameProperty.GetHashCode().

See Also

LiveObject.Type.NameProperty Class | StarTeam Namespace


LiveObject.Type.NameProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.NameProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.NameProperty.ToString()

See Also

LiveObject.Type.NameProperty Class | StarTeam Namespace


LiveObject.Type.SourceProperty Class

The property type of the Source property.

For a list of all members of this type, see LiveObject.Type.SourceProperty Members.

System.Object
Property
LinkProperty
LiveObject.Type.SourceProperty

public class LiveObject.Type.SourceProperty : LinkProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.SourceProperty Members | StarTeam Namespace


LiveObject.Type.SourceProperty Members

LiveObject.Type.SourceProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LinkProperty) | [read/write] LinkValue
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.SourceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.SourceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from LinkProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LinkProperty) | Creates a new query expression that tests this property endpoint against a DateTime value.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.SourceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.SourceProperty Class | StarTeam Namespace


LiveObject.Type.SourceProperty Properties

The properties of the LiveObject.Type.SourceProperty class are listed below. For a complete list of LiveObject.Type.SourceProperty class members, see the LiveObject.Type.SourceProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LinkProperty) | [read/write] LinkValue
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LiveObject.Type.SourceProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.SourceProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.SourceProperty Class | StarTeam Namespace


LiveObject.Type.SourceProperty Methods

The methods of the LiveObject.Type.SourceProperty class are listed below. For a complete list of LiveObject.Type.SourceProperty class members, see the LiveObject.Type.SourceProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.SourceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.SourceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from LinkProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LinkProperty) | Creates a new query expression that tests this property endpoint against a DateTime value.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.SourceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.SourceProperty Class | StarTeam Namespace


LiveObject.Type.SourceProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.SourceProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.SourceProperty.Equals(obj).

See Also

LiveObject.Type.SourceProperty Class | StarTeam Namespace


LiveObject.Type.SourceProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.SourceProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.SourceProperty.GetHashCode().

See Also

LiveObject.Type.SourceProperty Class | StarTeam Namespace


LiveObject.Type.SourceProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.SourceProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.SourceProperty.ToString()

See Also

LiveObject.Type.SourceProperty Class | StarTeam Namespace


LiveObject.Type.TargetProperty Class

The property type of the Target property.

For a list of all members of this type, see LiveObject.Type.TargetProperty Members.

System.Object
Property
LinkProperty
LiveObject.Type.TargetProperty

public class LiveObject.Type.TargetProperty : LinkProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.TargetProperty Members | StarTeam Namespace


LiveObject.Type.TargetProperty Members

LiveObject.Type.TargetProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LinkProperty) | [read/write] LinkValue
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.TargetProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.TargetProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from LinkProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LinkProperty) | Creates a new query expression that tests this property endpoint against a DateTime value.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.TargetProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.TargetProperty Class | StarTeam Namespace


LiveObject.Type.TargetProperty Properties

The properties of the LiveObject.Type.TargetProperty class are listed below. For a complete list of LiveObject.Type.TargetProperty class members, see the LiveObject.Type.TargetProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from LinkProperty) | [read/write] LinkValue
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LiveObject.Type.TargetProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.TargetProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.TargetProperty Class | StarTeam Namespace


LiveObject.Type.TargetProperty Methods

The methods of the LiveObject.Type.TargetProperty class are listed below. For a complete list of LiveObject.Type.TargetProperty class members, see the LiveObject.Type.TargetProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.TargetProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.TargetProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from LinkProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from LinkProperty) | Creates a new query expression that tests this property endpoint against a DateTime value.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.TargetProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.TargetProperty Class | StarTeam Namespace


LiveObject.Type.TargetProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.TargetProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.TargetProperty.Equals(obj).

See Also

LiveObject.Type.TargetProperty Class | StarTeam Namespace


LiveObject.Type.TargetProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.TargetProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.TargetProperty.GetHashCode().

See Also

LiveObject.Type.TargetProperty Class | StarTeam Namespace


LiveObject.Type.TargetProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.TargetProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.TargetProperty.ToString()

See Also

LiveObject.Type.TargetProperty Class | StarTeam Namespace


LiveObject.Type.WorkingFolderProperty Class

The property type of the Working Folder property.

For a list of all members of this type, see LiveObject.Type.WorkingFolderProperty Members.

System.Object
Property
VectorProperty
TextProperty
LiveObject.Type.WorkingFolderProperty

public class LiveObject.Type.WorkingFolderProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.Type.WorkingFolderProperty Members | StarTeam Namespace


LiveObject.Type.WorkingFolderProperty Members

LiveObject.Type.WorkingFolderProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.WorkingFolderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.WorkingFolderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.WorkingFolderProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.WorkingFolderProperty Class | StarTeam Namespace


LiveObject.Type.WorkingFolderProperty Properties

The properties of the LiveObject.Type.WorkingFolderProperty class are listed below. For a complete list of LiveObject.Type.WorkingFolderProperty class members, see the LiveObject.Type.WorkingFolderProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LiveObject.Type.WorkingFolderProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

LiveObject.Type.WorkingFolderProperty.NAME Property

public static String NAME {get;}

See Also

LiveObject.Type.WorkingFolderProperty Class | StarTeam Namespace


LiveObject.Type.WorkingFolderProperty Methods

The methods of the LiveObject.Type.WorkingFolderProperty class are listed below. For a complete list of LiveObject.Type.WorkingFolderProperty class members, see the LiveObject.Type.WorkingFolderProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.LiveObject.Type.WorkingFolderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.Type.WorkingFolderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LiveObject.Type.WorkingFolderProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LiveObject.Type.WorkingFolderProperty Class | StarTeam Namespace


LiveObject.Type.WorkingFolderProperty.Equals Method

Delegate Equals() to com.starteam.LiveObject.Type.WorkingFolderProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.Type.WorkingFolderProperty.Equals(obj).

See Also

LiveObject.Type.WorkingFolderProperty Class | StarTeam Namespace


LiveObject.Type.WorkingFolderProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.Type.WorkingFolderProperty.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.Type.WorkingFolderProperty.GetHashCode().

See Also

LiveObject.Type.WorkingFolderProperty Class | StarTeam Namespace


LiveObject.Type.WorkingFolderProperty.ToString Method

Delegate ToString() to com.starteam.LiveObject.Type.WorkingFolderProperty.

public override string ToString();

Return Value

com.starteam.LiveObject.Type.WorkingFolderProperty.ToString()

See Also

LiveObject.Type.WorkingFolderProperty Class | StarTeam Namespace


LiveObject.WebCacheLiveObject Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see LiveObject.WebCacheLiveObject Members.

System.Object
LiveObject.WebCacheLiveObject
Derived types

public class LiveObject.WebCacheLiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LiveObject.WebCacheLiveObject Members | StarTeam Namespace


LiveObject.WebCacheLiveObject Members

LiveObject.WebCacheLiveObject overview

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.LiveObject.WebCacheLiveObject.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.WebCacheLiveObject.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.LiveObject.WebCacheLiveObject.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject Properties

The properties of the LiveObject.WebCacheLiveObject class are listed below. For a complete list of LiveObject.WebCacheLiveObject class members, see the LiveObject.WebCacheLiveObject Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.Context Property

[read] the context of this object.

public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.CreatedBy Property

[read] The user who created this object.

public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.CreatedTime Property

[read] The date and time at which this object was created.

public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.ID Property

[read] the ID of the underlying object

public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.IsDirty Property

[read] true if this object is dirty

public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.IsNew Property

[read] true if this resource has not yet been stored in the server.

public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.MyType Property

[read] the type of this resource.

public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.Name Property

public virtual String Name {get;}

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.NameProperty Property

public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.ObjectID Property

[read] The unique identifier for the underlying object.

public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.Server Property

[read] the Server for this cached object

public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject Methods

The methods of the LiveObject.WebCacheLiveObject class are listed below. For a complete list of LiveObject.WebCacheLiveObject class members, see the LiveObject.WebCacheLiveObject Members topic.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.LiveObject.WebCacheLiveObject.
GetHashCode | Delegate GetHashCode() to com.starteam.LiveObject.WebCacheLiveObject.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.LiveObject.WebCacheLiveObject.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject.AddTo Method

public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject.Equals Method

Delegate Equals() to com.starteam.LiveObject.WebCacheLiveObject.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LiveObject.WebCacheLiveObject.Equals(obj).

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject.GetHashCode Method

Delegate GetHashCode() to com.starteam.LiveObject.WebCacheLiveObject.

public override int GetHashCode();

Return Value

com.starteam.LiveObject.WebCacheLiveObject.GetHashCode().

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.GetValue Method

Overload List

public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

public virtual object GetValue(String);

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject.GetValue Method (Property#WebCacheProperty)

public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace | LiveObject.WebCacheLiveObject.GetValue Overload List


LiveObject.WebCacheLiveObject.GetValue Method (String)

get the value of the property as specified by name

public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace | LiveObject.WebCacheLiveObject.GetValue Overload List


LiveObject.WebCacheLiveObject.HasValue Method

public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

public virtual void Refresh();

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

public virtual void Remove();

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace | WebCacheViewMemberCollection


LiveObject.WebCacheLiveObject.RemoveFrom Method

public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

LiveObject.WebCacheLiveObject.SetValue Method

Overload List

public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

public virtual void SetValue(String,Object);

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject.SetValue Method (Property#WebCacheProperty, Object)

public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace | LiveObject.WebCacheLiveObject.SetValue Overload List


LiveObject.WebCacheLiveObject.SetValue Method (String, Object)

set the value of the property as specified by name

public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace | LiveObject.WebCacheLiveObject.SetValue Overload List


LiveObject.WebCacheLiveObject.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject.ToString Method

Delegate ToString() to com.starteam.LiveObject.WebCacheLiveObject.

public override string ToString();

Return Value

com.starteam.LiveObject.WebCacheLiveObject.ToString()

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace


LiveObject.WebCacheLiveObject.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

public virtual void Update();

See Also

LiveObject.WebCacheLiveObject Class | StarTeam Namespace | WebCacheViewMemberCollection


LocalFileSystemPropertyProvider Interface

This interface provides a mechanism for an SDK application to offer its own instance of Local File System Properties. This interface should be used with caution, if at all. All methods of this interface must be correctly implemented, since the methods on this interface override the methods of the File Object, when set

For a list of all members of this type, see LocalFileSystemPropertyProvider Members.

public interface LocalFileSystemPropertyProvider

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LocalFileSystemPropertyProvider Members | StarTeam Namespace


LocalFileSystemPropertyProvider Members

LocalFileSystemPropertyProvider overview

Public Instance Properties

Executable | [read/write] True if the local file is an executable
Exists | [read/write] True if the local file exists
File | [read] the StarTeam File object associated with this instance
LastModified | [read/write] the date/time that this file was last modified
Length | [read/write] the size of the local file
Name | [read/write] the name of the local file
Path | [read/write] the fully qualified path to the local file
Status | [read/write] the status of this file w.r.t. the repository
StatusKnown | [read] True if the status of this file is known

Public Instance Methods

Clear | Reset the state of this instance
Clone | Clone an instance of the implementor

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


LocalFileSystemPropertyProvider Properties

The properties of the LocalFileSystemPropertyProvider interface are listed below. For a complete list of LocalFileSystemPropertyProvider interface members, see the LocalFileSystemPropertyProvider Members topic.

Public Instance Properties

Executable | [read/write] True if the local file is an executable
Exists | [read/write] True if the local file exists
File | [read] the StarTeam File object associated with this instance
LastModified | [read/write] the date/time that this file was last modified
Length | [read/write] the size of the local file
Name | [read/write] the name of the local file
Path | [read/write] the fully qualified path to the local file
Status | [read/write] the status of this file w.r.t. the repository
StatusKnown | [read] True if the status of this file is known

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


Executable Property

Borland StarTeam SDK for .NET

LocalFileSystemPropertyProvider.Executable Property

[read/write] True if the local file is an executable

Boolean Executable {get; set;}

Property Value

True if the local file is an executable

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


Exists Property

Borland StarTeam SDK for .NET

LocalFileSystemPropertyProvider.Exists Property

[read/write] True if the local file exists

Boolean Exists {get; set;}

Property Value

True if the local file exists

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


File Property

Borland StarTeam SDK for .NET

LocalFileSystemPropertyProvider.File Property

[read] the StarTeam File object associated with this instance

File File {get;}

Property Value

the StarTeam File object associated with this instance

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


LastModified Property

Borland StarTeam SDK for .NET

LocalFileSystemPropertyProvider.LastModified Property

[read/write] the date/time that this file was last modified

DateTime LastModified {get; set;}

Property Value

the date/time that this file was last modified

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


Length Property

Borland StarTeam SDK for .NET

LocalFileSystemPropertyProvider.Length Property

[read/write] the size of the local file

Int64 Length {get; set;}

Property Value

the size of the local file

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

LocalFileSystemPropertyProvider.Name Property

[read/write] the name of the local file

String Name {get; set;}

Property Value

the name of the local file

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


Path Property

Borland StarTeam SDK for .NET

LocalFileSystemPropertyProvider.Path Property

[read/write] the fully qualified path to the local file

String Path {get; set;}

Property Value

the fully qualified path to the local file

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

LocalFileSystemPropertyProvider.Status Property

[read/write] the status of this file w.r.t. the repository

File.Status Status {get; set;}

Property Value

the status of this file w.r.t. the repository

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


StatusKnown Property

Borland StarTeam SDK for .NET

LocalFileSystemPropertyProvider.StatusKnown Property

[read] True if the status of this file is known

Boolean StatusKnown {get;}

Property Value

True if the status of this file is known

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


LocalFileSystemPropertyProvider Methods

The methods of the LocalFileSystemPropertyProvider interface are listed below. For a complete list of LocalFileSystemPropertyProvider interface members, see the LocalFileSystemPropertyProvider Members topic.

Public Instance Methods

Clear | Reset the state of this instance
Clone | Clone an instance of the implementor

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


LocalFileSystemPropertyProvider.Clear Method

Reset the state of this instance

void Clear();

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


LocalFileSystemPropertyProvider.Clone Method

Clone an instance of the implementor

LocalFileSystemPropertyProvider Clone(
File f
);

Parameters

f
the File in whose context the clone is created

Return Value

a cloned instance of the implementor

See Also

LocalFileSystemPropertyProvider Interface | StarTeam Namespace


Lockable Interface

For a list of all members of this type, see Lockable Members.

StarTeam.Lockable
LockableObject

public interface Lockable

Types that implement Lockable

Type | Description
Audit | Represents a StarTeam Audit record
ChangePackage | A ChangePackage represents a set of changes to a StarTeam view that together form a single logical change. A logical change might be a bug fix, enhancement, etc. The updates made by a ChangePackage are committed in a single, atomic transaction.
ChangePackageCollection | A Collection of Change Packages within a specified view
ChangeRequest | Represents a StarTeam ChangeRequest item.
Concept | A Concept is a basic unit of content.
File | Represents a StarTeam File item.
Folder | Represents a StarTeam Folder. A folder is an Item, i.e. it does not have a parent id property However, (sub)folders reside within folders, which makes a folder a type of hierarchy tree Folders are also containers, in that, other items reside in folders
Item | Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Description property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.
KanbanBoard | A KanbanBoard is a process
LinkToTraceAdapter

An adapter class that surfaces a Link as if it were a Trace.

Since there are significant differences between the two models, the adapted link will actually be a new Trace (that is, a Trace that has not yet been saved to the StarTeam repository, for which isNew() returns true). Information from the Link is surfaced via the new Trace as described below.

  • Trace.getSource() will return a LinkValue that references the same Item as one of the Link endpoints.
  • Trace.getTarget() will return a LinkValue that references the same Item as the other Link endpoint.
  • Trace.getDescription() will return the same string as Link.getComment().
All other properties of the new Trace are initialized to their default values.

The new Trace can of course be modified by the client application, and/or saved to the StarTeam repository using Item.update(). A Trace saved this way is then unrelated to the original Link.

Plan | Represents a Starteam Plan item.
Requirement | Represents a StarTeam Requirement item.
Review | A Review is an oversight of a code block.
Sprint | An Agile/Scrum Sprint is a basic unit of development. It sums up all work to be accomplished within the sprint period that typically spans from a week to a month.
Story | A Story represents an Agile user story. It has a StoryType property to further qualify it as a more specific Agile artifact like Epic, Theme ... . Stories can be hierarchical, that is a parent story can have child stories. Stories may have Tasks to break them up into smaller units of work.
Swimlane | A Swimlane is a path in Kanban.
Task | Represents a StarTeam Task item.
Test | A Test is a basic unit of software testing.
TestRun | A TestRunRun is the state of a Test after execution.
Topic | Represents a StarTeam Topic.
Trace | A typed relationship between two artifacts.
TraceCollection | Caches Traces for a given view. Also provides a Trace query mechanism.
TreeItem | A type of item with children.
VCMFolder | A folder belonging to the Merge Preview It has all the characteristics of a regular StarTeam Folder, and describes the Preview State of its constituent Items and/or Sub-Folders
ViewMember | A VersionedObject that lives in a View.
ViewMemberCollection | A Collection of ViewMembers. The collection can be built up from different types of ViewMembers, or all instances of the same type.
WhiteBoard | A WhiteBoard is a collection of concepts.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Lockable Members | StarTeam Namespace


Lockable Members

Lockable overview

Public Instance Methods

LockExclusive | Overloaded.
LockNonExclusive |
Unlock |

See Also

Lockable Interface | StarTeam Namespace


Lockable Methods

The methods of the Lockable interface are listed below. For a complete list of Lockable interface members, see the Lockable Members topic.

Public Instance Methods

LockExclusive | Overloaded.
LockNonExclusive |
Unlock |

See Also

Lockable Interface | StarTeam Namespace


LockExclusive Method

Borland StarTeam SDK for .NET

Lockable.LockExclusive Method

Overload List

void LockExclusive();

void LockExclusive(Boolean);

See Also

Lockable Interface | StarTeam Namespace


Lockable.LockExclusive Method ()

void LockExclusive();

See Also

Lockable Interface | StarTeam Namespace | Lockable.LockExclusive Overload List


Lockable.LockExclusive Method (Boolean)

void LockExclusive(
Boolean breakLock
);

See Also

Lockable Interface | StarTeam Namespace | Lockable.LockExclusive Overload List


Lockable.LockNonExclusive Method

void LockNonExclusive();

See Also

Lockable Interface | StarTeam Namespace


Lockable.Unlock Method

void Unlock();

See Also

Lockable Interface | StarTeam Namespace


LockableObject Interface

For a list of all members of this type, see LockableObject Members.

public interface LockableObject : Lockable

Types that implement LockableObject

Type | Description
Audit | Represents a StarTeam Audit record
ChangePackage | A ChangePackage represents a set of changes to a StarTeam view that together form a single logical change. A logical change might be a bug fix, enhancement, etc. The updates made by a ChangePackage are committed in a single, atomic transaction.
ChangeRequest | Represents a StarTeam ChangeRequest item.
Concept | A Concept is a basic unit of content.
File | Represents a StarTeam File item.
Folder | Represents a StarTeam Folder. A folder is an Item, i.e. it does not have a parent id property However, (sub)folders reside within folders, which makes a folder a type of hierarchy tree Folders are also containers, in that, other items reside in folders
Item | Contextual reference to an object in a StarTeam repository. Items provide transparent access to the underlying entity (e.g., modifying the description of an item by calling Item.put("Description", "some text") actually modifies the Description property of the underlying entity the Item references. An Item consists of the underlying entity and its context within a view. Therefore, an Item has direct knowledge of the items to which it is related. Items also maintain state information to determine if the underlying object is new or modified relative to instances of the object stored in the repository. An Item also has a temporal aspect in that it represents a single development path (linear history) of the underlying object as of a moment in time.
KanbanBoard | A KanbanBoard is a process
LinkToTraceAdapter

An adapter class that surfaces a Link as if it were a Trace.

Since there are significant differences between the two models, the adapted link will actually be a new Trace (that is, a Trace that has not yet been saved to the StarTeam repository, for which isNew() returns true). Information from the Link is surfaced via the new Trace as described below.

  • Trace.getSource() will return a LinkValue that references the same Item as one of the Link endpoints.
  • Trace.getTarget() will return a LinkValue that references the same Item as the other Link endpoint.
  • Trace.getDescription() will return the same string as Link.getComment().
All other properties of the new Trace are initialized to their default values.

The new Trace can of course be modified by the client application, and/or saved to the StarTeam repository using Item.update(). A Trace saved this way is then unrelated to the original Link.

Plan | Represents a Starteam Plan item.
Requirement | Represents a StarTeam Requirement item.
Review | A Review is an oversight of a code block.
Sprint | An Agile/Scrum Sprint is a basic unit of development. It sums up all work to be accomplished within the sprint period that typically spans from a week to a month.
Story | A Story represents an Agile user story. It has a StoryType property to further qualify it as a more specific Agile artifact like Epic, Theme ... . Stories can be hierarchical, that is a parent story can have child stories. Stories may have Tasks to break them up into smaller units of work.
Swimlane | A Swimlane is a path in Kanban.
Task | Represents a StarTeam Task item.
Test | A Test is a basic unit of software testing.
TestRun | A TestRunRun is the state of a Test after execution.
Topic | Represents a StarTeam Topic.
Trace | A typed relationship between two artifacts.
TreeItem | A type of item with children.
VCMFolder | A folder belonging to the Merge Preview It has all the characteristics of a regular StarTeam Folder, and describes the Preview State of its constituent Items and/or Sub-Folders
ViewMember | A VersionedObject that lives in a View.
WhiteBoard | A WhiteBoard is a collection of concepts.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LockableObject Members | StarTeam Namespace


LockableObject Members

LockableObject overview

Public Instance Properties

Locker
MyLockTypeValue

See Also

LockableObject Interface | StarTeam Namespace


LockableObject Properties

The properties of the LockableObject interface are listed below. For a complete list of LockableObject interface members, see the LockableObject Members topic.

Public Instance Properties

Locker
MyLockTypeValue

See Also

LockableObject Interface | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

LockableObject.Locker Property

User Locker {get;}

See Also

LockableObject Interface | StarTeam Namespace


MyLockTypeValue Property

Borland StarTeam SDK for .NET

LockableObject.MyLockTypeValue Property

ViewMember.LockType MyLockTypeValue {get;}

See Also

LockableObject Interface | StarTeam Namespace


LongIntegerProperty Class

This class represents a property whose value is a Long Integer.

For a list of all members of this type, see LongIntegerProperty Members.

System.Object
Property
ScalarProperty
LongIntegerProperty
File.Type.SizeProperty
File.Type.SyncSizeProperty
File.Type.WorkingFileSizeProperty
LiveObject.Type.GlobalIDProperty

public class LongIntegerProperty : ScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LongIntegerProperty Members | StarTeam Namespace


LongIntegerProperty Members

LongIntegerProperty overview

Public Static Properties

MAX_VALUE
MIN_VALUE

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] long
MinValue | Overloaded. [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty Properties

The properties of the LongIntegerProperty class are listed below. For a complete list of LongIntegerProperty class members, see the LongIntegerProperty Members topic.

Public Static Properties

MAX_VALUE
MIN_VALUE

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] long
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this Long Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] long
MinValue | Overloaded. [read/write] long
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

LongIntegerProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

LongIntegerProperty.DefaultValue Property

[read/write] long

new public virtual Int64 DefaultValue {get; set;}

Property Value

long

See Also

LongIntegerProperty Class | StarTeam Namespace


IsRollupProperty Property

Borland StarTeam SDK for .NET

LongIntegerProperty.IsRollupProperty Property

[read/write] true if this Long Property can be rolled up

public virtual Boolean IsRollupProperty {get; set;}

Property Value

true if this Long Property can be rolled up

See Also

LongIntegerProperty Class | StarTeam Namespace


MAX_VALUE Property

Borland StarTeam SDK for .NET

LongIntegerProperty.MAX_VALUE Property

public static Int64 MAX_VALUE {get;}

See Also

LongIntegerProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

LongIntegerProperty.MaxValue Property

[read/write] long

new public virtual Int64 MaxValue {get; set;}

Property Value

long

See Also

LongIntegerProperty Class | StarTeam Namespace


MIN_VALUE Property

Borland StarTeam SDK for .NET

LongIntegerProperty.MIN_VALUE Property

public static Int64 MIN_VALUE {get;}

See Also

LongIntegerProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

LongIntegerProperty.MinValue Property

[read/write] long

new public virtual Int64 MinValue {get; set;}

Property Value

long

See Also

LongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty Methods

The methods of the LongIntegerProperty class are listed below. For a complete list of LongIntegerProperty class members, see the LongIntegerProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

LongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.NewQueryPart Method

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
Int64 value
);

See Also

LongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see LongIntegerProperty.WebCacheLongIntegerProperty Members.

System.Object
Property.WebCacheProperty
ScalarProperty.WebCacheScalarProperty
LongIntegerProperty.WebCacheLongIntegerProperty

public class LongIntegerProperty.WebCacheLongIntegerProperty : WebCacheScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Members | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty Members

LongIntegerProperty.WebCacheLongIntegerProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] long
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this LongInteger Property can be rolled up
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] int the maximum integer value
MinValue | [read/write] int the minimum integer value for this Property
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty Properties

The properties of the LongIntegerProperty.WebCacheLongIntegerProperty class are listed below. For a complete list of LongIntegerProperty.WebCacheLongIntegerProperty class members, see the LongIntegerProperty.WebCacheLongIntegerProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] long
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty | [read/write] true if this LongInteger Property can be rolled up
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] int the maximum integer value
MinValue | [read/write] int the minimum integer value for this Property
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.DefaultValue Property

[read/write] long

new public virtual Int64 DefaultValue {get; set;}

Property Value

long

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsRollupProperty Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsRollupProperty Property

[read/write] true if this LongInteger Property can be rolled up

public virtual Boolean IsRollupProperty {get; set;}

Property Value

true if this LongInteger Property can be rolled up

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.MaxValue Property

[read/write] int the maximum integer value

public virtual Int64 MaxValue {get; set;}

Property Value

int the maximum integer value

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.MinValue Property

[read/write] int the minimum integer value for this Property

public virtual Int64 MinValue {get; set;}

Property Value

int the minimum integer value for this Property

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.Name Property

new public virtual String Name {get;}

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

LongIntegerProperty.WebCacheLongIntegerProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty Methods

The methods of the LongIntegerProperty.WebCacheLongIntegerProperty class are listed below. For a complete list of LongIntegerProperty.WebCacheLongIntegerProperty class members, see the LongIntegerProperty.WebCacheLongIntegerProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.Equals Method

Delegate Equals() to com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.Equals(obj).

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.

public override int GetHashCode();

Return Value

com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.GetHashCode().

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.NewQueryPart Method

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
Int64 value
);

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.ToString Method

Delegate ToString() to com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.

public override string ToString();

Return Value

com.starteam.LongIntegerProperty.WebCacheLongIntegerProperty.ToString()

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


LongIntegerProperty.WebCacheLongIntegerProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

LongIntegerProperty.WebCacheLongIntegerProperty Class | StarTeam Namespace


MapProperty Class

A Map Property supports the assignment of a java.util.Map as a StarTeam Property value. The property value is serialized and saved to the StarTeam Server (and the underlying database) as a structured set of Key value Pairs using a simple KVP schema The Map Property supports a wide range of native and SDK value types, including String, Integer, Long, Boolean, Double, Float and java.util.Date It also supports the SDK types Date, DateTime, MD5, GUID, DotNotation, TimeSpan and Content

For a list of all members of this type, see MapProperty Members.

System.Object
Property
VectorProperty
MapProperty

public class MapProperty : VectorProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

MapProperty Members | StarTeam Namespace


MapProperty Members

MapProperty overview

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

MapProperty Class | StarTeam Namespace


MapProperty Properties

The properties of the MapProperty class are listed below. For a complete list of MapProperty class members, see the MapProperty Members topic.

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

MapProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

MapProperty.DefaultValue Property

[read] String

new public virtual String DefaultValue {get;}

Property Value

String

See Also

MapProperty Class | StarTeam Namespace


MapProperty Methods

The methods of the MapProperty class are listed below. For a complete list of MapProperty class members, see the MapProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

MapProperty Class | StarTeam Namespace


MapProperty.NewQueryPart Method

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
Object value
);

See Also

MapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see MapProperty.WebCacheMapProperty Members.

System.Object
Property.WebCacheProperty
VectorProperty.WebCacheVectorProperty
MapProperty.WebCacheMapProperty

public class MapProperty.WebCacheMapProperty : WebCacheVectorProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

MapProperty.WebCacheMapProperty Members | StarTeam Namespace


MapProperty.WebCacheMapProperty Members

MapProperty.WebCacheMapProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] String
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.MapProperty.WebCacheMapProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.MapProperty.WebCacheMapProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.MapProperty.WebCacheMapProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty Properties

The properties of the MapProperty.WebCacheMapProperty class are listed below. For a complete list of MapProperty.WebCacheMapProperty class members, see the MapProperty.WebCacheMapProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] String
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.DefaultValue Property

[read/write] String

new public virtual String DefaultValue {get; set;}

Property Value

String

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MaxLength Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.MaxLength Property

[read/write] The maximum length of a property value.

new public virtual Int32 MaxLength {get; set;}

Property Value

The maximum length of a property value.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MinLength Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.MinLength Property

[read/write] The minimum length of a property value.

new public virtual Int32 MinLength {get; set;}

Property Value

The minimum length of a property value.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.Name Property

new public virtual String Name {get;}

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

MapProperty.WebCacheMapProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty Methods

The methods of the MapProperty.WebCacheMapProperty class are listed below. For a complete list of MapProperty.WebCacheMapProperty class members, see the MapProperty.WebCacheMapProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.MapProperty.WebCacheMapProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.MapProperty.WebCacheMapProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.MapProperty.WebCacheMapProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.Equals Method

Delegate Equals() to com.starteam.MapProperty.WebCacheMapProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.MapProperty.WebCacheMapProperty.Equals(obj).

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.MapProperty.WebCacheMapProperty.

public override int GetHashCode();

Return Value

com.starteam.MapProperty.WebCacheMapProperty.GetHashCode().

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.NewQueryPart Method

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
Object value
);

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.ToString Method

Delegate ToString() to com.starteam.MapProperty.WebCacheMapProperty.

public override string ToString();

Return Value

com.starteam.MapProperty.WebCacheMapProperty.ToString()

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MapProperty.WebCacheMapProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

MapProperty.WebCacheMapProperty Class | StarTeam Namespace


MatchedACE Class

Used when explaining the results of an access test.

Each MatchedACE provides a subset of the permissions that were tested, as well as the corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.

For a list of all members of this type, see MatchedACE Members.

System.Object
MatchedACE

public class MatchedACE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

MatchedACE Members | StarTeam Namespace


MatchedACE Members

MatchedACE overview

Public Instance Properties

EffectiveACE | [read] The corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.
IndexInACL | [read] The index of this ACEManager in its Effective Access Control List, or -1 if this ACEManager does not appear in the Effective ACL.
Permissions | [read] A subset of the permissions that were tested.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.MatchedACE.
GetHashCode | Delegate GetHashCode() to com.starteam.MatchedACE.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.MatchedACE.

See Also

MatchedACE Class | StarTeam Namespace


MatchedACE Properties

The properties of the MatchedACE class are listed below. For a complete list of MatchedACE class members, see the MatchedACE Members topic.

Public Instance Properties

EffectiveACE | [read] The corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.
IndexInACL | [read] The index of this ACEManager in its Effective Access Control List, or -1 if this ACEManager does not appear in the Effective ACL.
Permissions | [read] A subset of the permissions that were tested.

See Also

MatchedACE Class | StarTeam Namespace


EffectiveACE Property

Borland StarTeam SDK for .NET

MatchedACE.EffectiveACE Property

[read] The corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.

public virtual EffectiveACE EffectiveACE {get;}

Property Value

The corresponding EffectiveACE that was relevant in determining whether those permissions were granted or denied.

See Also

MatchedACE Class | StarTeam Namespace


IndexInACL Property

Borland StarTeam SDK for .NET

MatchedACE.IndexInACL Property

[read] The index of this ACEManager in its Effective Access Control List, or -1 if this ACEManager does not appear in the Effective ACL.

public virtual Int32 IndexInACL {get;}

Property Value

The index of this ACEManager in its Effective Access Control List, or -1 if this ACEManager does not appear in the Effective ACL.

See Also

MatchedACE Class | StarTeam Namespace


Permissions Property

Borland StarTeam SDK for .NET

MatchedACE.Permissions Property

[read] A subset of the permissions that were tested.

public virtual PermissionCollection Permissions {get;}

Property Value

A subset of the permissions that were tested.

See Also

MatchedACE Class | StarTeam Namespace


MatchedACE Methods

The methods of the MatchedACE class are listed below. For a complete list of MatchedACE class members, see the MatchedACE Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.MatchedACE.
GetHashCode | Delegate GetHashCode() to com.starteam.MatchedACE.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.MatchedACE.

See Also

MatchedACE Class | StarTeam Namespace


MatchedACE.Equals Method

Delegate Equals() to com.starteam.MatchedACE.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.MatchedACE.Equals(obj).

See Also

MatchedACE Class | StarTeam Namespace


MatchedACE.GetHashCode Method

Delegate GetHashCode() to com.starteam.MatchedACE.

public override int GetHashCode();

Return Value

com.starteam.MatchedACE.GetHashCode().

See Also

MatchedACE Class | StarTeam Namespace


MatchedACE.ToString Method

Delegate ToString() to com.starteam.MatchedACE.

public override string ToString();

Return Value

com.starteam.MatchedACE.ToString()

See Also

MatchedACE Class | StarTeam Namespace


MergePoint Class

This class provides information about how two item revisions are related with respect to merging. Suppose the file "foo.txt" branches at revision 1.3 to create a new revision 1.3.1.0. A checkin on the main branch will create revision 1.4 and a subsequent checkin on the alternate branch will create revision 1.3.1.1. If the user then merges the changes between 1.3 to 1.4 in to a new branch revision 1.3.1.2 a MergePoint can be used to record the sources used to create this new revision. In this case the MergePoint would have a source Revision corresponding to the 1.4 revision of "foo.txt" and a target Revision corresponding to the 1.3.1.2 revision of "foo.txt".

For a list of all members of this type, see MergePoint Members.

System.Object
MergePoint

public class MergePoint

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

MergePoint Members | StarTeam Namespace


MergePoint Members

MergePoint overview

Public Instance Properties

Source | [read] the Revision of the merge source.
Target | [read] the Revision of the merge target.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.MergePoint.
GetHashCode | Delegate GetHashCode() to com.starteam.MergePoint.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.MergePoint.

See Also

MergePoint Class | StarTeam Namespace


MergePoint Properties

The properties of the MergePoint class are listed below. For a complete list of MergePoint class members, see the MergePoint Members topic.

Public Instance Properties

Source | [read] the Revision of the merge source.
Target | [read] the Revision of the merge target.

See Also

MergePoint Class | StarTeam Namespace


Source Property

Borland StarTeam SDK for .NET

MergePoint.Source Property

[read] the Revision of the merge source.

public virtual MergePoint.Revision Source {get;}

Property Value

the Revision of the merge source.

See Also

MergePoint Class | StarTeam Namespace


Target Property

Borland StarTeam SDK for .NET

MergePoint.Target Property

[read] the Revision of the merge target.

public virtual MergePoint.Revision Target {get;}

Property Value

the Revision of the merge target.

See Also

MergePoint Class | StarTeam Namespace


MergePoint Methods

The methods of the MergePoint class are listed below. For a complete list of MergePoint class members, see the MergePoint Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.MergePoint.
GetHashCode | Delegate GetHashCode() to com.starteam.MergePoint.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.MergePoint.

See Also

MergePoint Class | StarTeam Namespace


MergePoint.Equals Method

Delegate Equals() to com.starteam.MergePoint.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.MergePoint.Equals(obj).

See Also

MergePoint Class | StarTeam Namespace


MergePoint.GetHashCode Method

Delegate GetHashCode() to com.starteam.MergePoint.

public override int GetHashCode();

Return Value

com.starteam.MergePoint.GetHashCode().

See Also

MergePoint Class | StarTeam Namespace


MergePoint.ToString Method

Delegate ToString() to com.starteam.MergePoint.

public override string ToString();

Return Value

com.starteam.MergePoint.ToString()

See Also

MergePoint Class | StarTeam Namespace


MergePoint.Revision Class

A simple class representing a unique revision of an Item in the repository. For items of the same type, revisions can be uniquely identified in the repository by the item's objectID and revision number.

For a list of all members of this type, see MergePoint.Revision Members.

System.Object
MergePoint.Revision

public class MergePoint.Revision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

MergePoint.Revision Members | StarTeam Namespace


MergePoint.Revision Members

MergePoint.Revision overview

Public Instance Properties

IsTip | [read] true if the revision identifier represents the "tip" revision of a branch.
ObjectID | [read] the revision identifier's object ID.
RevisionNumber | [read] the revision identifier's revision number.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.MergePoint.Revision.
GetHashCode | Delegate GetHashCode() to com.starteam.MergePoint.Revision.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.MergePoint.Revision.

See Also

MergePoint.Revision Class | StarTeam Namespace


MergePoint.Revision Properties

The properties of the MergePoint.Revision class are listed below. For a complete list of MergePoint.Revision class members, see the MergePoint.Revision Members topic.

Public Instance Properties

IsTip | [read] true if the revision identifier represents the "tip" revision of a branch.
ObjectID | [read] the revision identifier's object ID.
RevisionNumber | [read] the revision identifier's revision number.

See Also

MergePoint.Revision Class | StarTeam Namespace


IsTip Property

Borland StarTeam SDK for .NET

MergePoint.Revision.IsTip Property

[read] true if the revision identifier represents the "tip" revision of a branch.

public virtual Boolean IsTip {get;}

Property Value

true if the revision identifier represents the "tip" revision of a branch.

See Also

MergePoint.Revision Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

MergePoint.Revision.ObjectID Property

[read] the revision identifier's object ID.

public virtual Int32 ObjectID {get;}

Property Value

the revision identifier's object ID.

See Also

MergePoint.Revision Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

MergePoint.Revision.RevisionNumber Property

[read] the revision identifier's revision number.

public virtual Int32 RevisionNumber {get;}

Property Value

the revision identifier's revision number.

See Also

MergePoint.Revision Class | StarTeam Namespace


MergePoint.Revision Methods

The methods of the MergePoint.Revision class are listed below. For a complete list of MergePoint.Revision class members, see the MergePoint.Revision Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.MergePoint.Revision.
GetHashCode | Delegate GetHashCode() to com.starteam.MergePoint.Revision.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.MergePoint.Revision.

See Also

MergePoint.Revision Class | StarTeam Namespace


MergePoint.Revision.Equals Method

Delegate Equals() to com.starteam.MergePoint.Revision.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.MergePoint.Revision.Equals(obj).

See Also

MergePoint.Revision Class | StarTeam Namespace


MergePoint.Revision.GetHashCode Method

Delegate GetHashCode() to com.starteam.MergePoint.Revision.

public override int GetHashCode();

Return Value

com.starteam.MergePoint.Revision.GetHashCode().

See Also

MergePoint.Revision Class | StarTeam Namespace


MergePoint.Revision.ToString Method

Delegate ToString() to com.starteam.MergePoint.Revision.

public override string ToString();

Return Value

com.starteam.MergePoint.Revision.ToString()

See Also

MergePoint.Revision Class | StarTeam Namespace


NamedCacheRef Class

Base implementation of objects that use the SDK's uniform caching mechanism and can be identified by a unique name.

For a list of all members of this type, see NamedCacheRef Members.

System.Object
NamedCacheRef
Filter
Query
Type

public class NamedCacheRef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

NamedCacheRef Members | StarTeam Namespace


NamedCacheRef Members

NamedCacheRef overview

Public Instance Methods

Equals | Delegate Equals() to com.starteam.NamedCacheRef.
GetHashCode | Delegate GetHashCode() to com.starteam.NamedCacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.NamedCacheRef.

See Also

NamedCacheRef Class | StarTeam Namespace


NamedCacheRef Methods

The methods of the NamedCacheRef class are listed below. For a complete list of NamedCacheRef class members, see the NamedCacheRef Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.NamedCacheRef.
GetHashCode | Delegate GetHashCode() to com.starteam.NamedCacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.NamedCacheRef.

See Also

NamedCacheRef Class | StarTeam Namespace


NamedCacheRef.Equals Method

Delegate Equals() to com.starteam.NamedCacheRef.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.NamedCacheRef.Equals(obj).

See Also

NamedCacheRef Class | StarTeam Namespace


NamedCacheRef.GetHashCode Method

Delegate GetHashCode() to com.starteam.NamedCacheRef.

public override int GetHashCode();

Return Value

com.starteam.NamedCacheRef.GetHashCode().

See Also

NamedCacheRef Class | StarTeam Namespace


NamedCacheRef.ToString Method

Delegate ToString() to com.starteam.NamedCacheRef.

public override string ToString();

Return Value

com.starteam.NamedCacheRef.ToString()

See Also

NamedCacheRef Class | StarTeam Namespace


NetMonitor Class

Displays information about the commands that are being sent to the StarTeam Server. This may be useful in diagnosing performance problems.

For a list of all members of this type, see NetMonitor Members.

System.Object
NetMonitor

public class NetMonitor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

NetMonitor Members | StarTeam Namespace


NetMonitor Members

NetMonitor overview

Public Static Properties

RunningCommandCount [read] The total number of server commands currently being executed across all threads.

Public Static Methods

Kill | Turns off the NetMonitor.
NewCacheAgentEventSource |
NewMPXMessageEventSource |
NewServerCommandEventSource |
OnConsole | Turns on the NetMonitor, sending output to the system console.
OnFile | Turns on the NetMonitor, sending output to the given file.
Println | Writes a message to the NetMonitor output. Useful for debugging.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.NetMonitor.
GetHashCode | Delegate GetHashCode() to com.starteam.NetMonitor.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.NetMonitor.

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor Properties

The properties of the NetMonitor class are listed below. For a complete list of NetMonitor class members, see the NetMonitor Members topic.

Public Static Properties

RunningCommandCount [read] The total number of server commands currently being executed across all threads.

See Also

NetMonitor Class | StarTeam Namespace


RunningCommandCount Property

Borland StarTeam SDK for .NET

NetMonitor.RunningCommandCount Property

[read] The total number of server commands currently being executed across all threads.

public static Int32 RunningCommandCount {get;}

Property Value

The total number of server commands currently being executed across all threads.

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor Methods

The methods of the NetMonitor class are listed below. For a complete list of NetMonitor class members, see the NetMonitor Members topic.

Public Static Methods

Kill | Turns off the NetMonitor.
NewCacheAgentEventSource |
NewMPXMessageEventSource |
NewServerCommandEventSource |
OnConsole | Turns on the NetMonitor, sending output to the system console.
OnFile | Turns on the NetMonitor, sending output to the given file.
Println | Writes a message to the NetMonitor output. Useful for debugging.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.NetMonitor.
GetHashCode | Delegate GetHashCode() to com.starteam.NetMonitor.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.NetMonitor.

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.Equals Method

Delegate Equals() to com.starteam.NetMonitor.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.NetMonitor.Equals(obj).

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.GetHashCode Method

Delegate GetHashCode() to com.starteam.NetMonitor.

public override int GetHashCode();

Return Value

com.starteam.NetMonitor.GetHashCode().

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.Kill Method

Turns off the NetMonitor.

public static void Kill();

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.NewCacheAgentEventSource Method

public static CacheAgentEventSource NewCacheAgentEventSource();

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.NewMPXMessageEventSource Method

public static MPXMessageEventSource NewMPXMessageEventSource();

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.NewServerCommandEventSource Method

public static ServerCommandEventSource NewServerCommandEventSource();

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.OnConsole Method

Turns on the NetMonitor, sending output to the system console.

public static void OnConsole();

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.OnFile Method

Turns on the NetMonitor, sending output to the given file.

public static void OnFile(
FileInfo file
);

Parameters

file
The output file.

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.Println Method

Writes a message to the NetMonitor output. Useful for debugging.

public static void Println(
String info
);

Parameters

info
The message to be written.

See Also

NetMonitor Class | StarTeam Namespace


NetMonitor.ToString Method

Delegate ToString() to com.starteam.NetMonitor.

public override string ToString();

Return Value

com.starteam.NetMonitor.ToString()

See Also

NetMonitor Class | StarTeam Namespace


Oauth2ServiceProvider Class

Confidential proprietary property Copyright 2019 Micro Focus or one of its affiliates. All rights reserved. Oauth2 service provider class allows StarTeam clients to connect to Oauth2 provider for authentication/single sign-on. Oauth2 provider should conform to Oauth2/Open ID connect specification.

For a list of all members of this type, see Oauth2ServiceProvider Members.

System.Object
Oauth2ServiceProvider

public class Oauth2ServiceProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Oauth2ServiceProvider Members | StarTeam Namespace


Oauth2ServiceProvider Members

Oauth2ServiceProvider overview

Public Instance Constructors

Oauth2ServiceProvider Constructor Oauth2 provider should implement the first step of "Authorization code grant" flow which is to fetch the authorization code.

Public Instance Properties

AuthorizationEndPoint | [read] Oauth2 Provider Authorization endpoint URL.
IssuerURL | [read] Oauth2 provider Issuer URL.
RedirectURI | [read] redirect callback URI.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Oauth2ServiceProvider.
GetHashCode | Delegate GetHashCode() to com.starteam.Oauth2ServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Oauth2ServiceProvider.

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider Constructor

Oauth2 provider should implement the first step of "Authorization code grant" flow which is to fetch the authorization code.

public Oauth2ServiceProvider(
Server s
);

Parameters

s
The server instance

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider Properties

The properties of the Oauth2ServiceProvider class are listed below. For a complete list of Oauth2ServiceProvider class members, see the Oauth2ServiceProvider Members topic.

Public Instance Properties

AuthorizationEndPoint | [read] Oauth2 Provider Authorization endpoint URL.
IssuerURL | [read] Oauth2 provider Issuer URL.
RedirectURI | [read] redirect callback URI.

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


AuthorizationEndPoint Property

Borland StarTeam SDK for .NET

Oauth2ServiceProvider.AuthorizationEndPoint Property

[read] Oauth2 Provider Authorization endpoint URL.

public virtual String AuthorizationEndPoint {get;}

Property Value

Oauth2 Provider Authorization endpoint URL.

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


IssuerURL Property

Borland StarTeam SDK for .NET

Oauth2ServiceProvider.IssuerURL Property

[read] Oauth2 provider Issuer URL.

public virtual String IssuerURL {get;}

Property Value

Oauth2 provider Issuer URL.

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


RedirectURI Property

Borland StarTeam SDK for .NET

Oauth2ServiceProvider.RedirectURI Property

[read] redirect callback URI.

public virtual String RedirectURI {get;}

Property Value

redirect callback URI.

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider Methods

The methods of the Oauth2ServiceProvider class are listed below. For a complete list of Oauth2ServiceProvider class members, see the Oauth2ServiceProvider Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Oauth2ServiceProvider.
GetHashCode | Delegate GetHashCode() to com.starteam.Oauth2ServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Oauth2ServiceProvider.

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.Equals Method

Delegate Equals() to com.starteam.Oauth2ServiceProvider.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Oauth2ServiceProvider.Equals(obj).

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.GetHashCode Method

Delegate GetHashCode() to com.starteam.Oauth2ServiceProvider.

public override int GetHashCode();

Return Value

com.starteam.Oauth2ServiceProvider.GetHashCode().

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.ToString Method

Delegate ToString() to com.starteam.Oauth2ServiceProvider.

public override string ToString();

Return Value

com.starteam.Oauth2ServiceProvider.ToString()

See Also

Oauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class

For a list of all members of this type, see Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Members.

System.Object
Oauth2ServiceProvider.WebCacheOauth2ServiceProvider

public class Oauth2ServiceProvider.WebCacheOauth2ServiceProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Members | StarTeam Namespace


Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Members

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider overview

Public Instance Constructors

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Constructor

Public Instance Properties

AuthorizationEndPoint | [read] Oauth2 Provider Authorization endpoint URL.
IssuerURL | [read] Oauth2 provider Issuer URL.
RedirectURI | [read] redirect callback URI.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.
GetHashCode | Delegate GetHashCode() to com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Constructor

public Oauth2ServiceProvider.WebCacheOauth2ServiceProvider(
Server.WebCacheServer s
);

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Properties

The properties of the Oauth2ServiceProvider.WebCacheOauth2ServiceProvider class are listed below. For a complete list of Oauth2ServiceProvider.WebCacheOauth2ServiceProvider class members, see the Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Members topic.

Public Instance Properties

AuthorizationEndPoint | [read] Oauth2 Provider Authorization endpoint URL.
IssuerURL | [read] Oauth2 provider Issuer URL.
RedirectURI | [read] redirect callback URI.

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


AuthorizationEndPoint Property

Borland StarTeam SDK for .NET

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.AuthorizationEndPoint Property

[read] Oauth2 Provider Authorization endpoint URL.

public virtual String AuthorizationEndPoint {get;}

Property Value

Oauth2 Provider Authorization endpoint URL.

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


IssuerURL Property

Borland StarTeam SDK for .NET

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.IssuerURL Property

[read] Oauth2 provider Issuer URL.

public virtual String IssuerURL {get;}

Property Value

Oauth2 provider Issuer URL.

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


RedirectURI Property

Borland StarTeam SDK for .NET

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.RedirectURI Property

[read] redirect callback URI.

public virtual String RedirectURI {get;}

Property Value

redirect callback URI.

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Methods

The methods of the Oauth2ServiceProvider.WebCacheOauth2ServiceProvider class are listed below. For a complete list of Oauth2ServiceProvider.WebCacheOauth2ServiceProvider class members, see the Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.
GetHashCode | Delegate GetHashCode() to com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.Equals Method

Delegate Equals() to com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.Equals(obj).

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.GetHashCode Method

Delegate GetHashCode() to com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.

public override int GetHashCode();

Return Value

com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.GetHashCode().

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.ToString Method

Delegate ToString() to com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.

public override string ToString();

Return Value

com.starteam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider.ToString()

See Also

Oauth2ServiceProvider.WebCacheOauth2ServiceProvider Class | StarTeam Namespace


ObjectArrayProperty Class

This class represents a property whose value is an Object Array. Custom Object Array Properties can be created starting from Server Release 12.0 However, they are restricted to User and Group Arrays

For a list of all members of this type, see ObjectArrayProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Derived types

public class ObjectArrayProperty : VectorProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ObjectArrayProperty Members | StarTeam Namespace


ObjectArrayProperty Members

ObjectArrayProperty overview

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty Properties

The properties of the ObjectArrayProperty class are listed below. For a complete list of ObjectArrayProperty class members, see the ObjectArrayProperty Members topic.

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

ObjectArrayProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.DefaultValue Property

[read/write] int[]

new public virtual Int32[] DefaultValue {get; set;}

Property Value

int[]

See Also

ObjectArrayProperty Class | StarTeam Namespace


TypeOfMembers Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.TypeOfMembers Property

[read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

public virtual Type TypeOfMembers {get;}

Property Value

The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

ObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty Methods

The methods of the ObjectArrayProperty class are listed below. For a complete list of ObjectArrayProperty class members, see the ObjectArrayProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.NewQueryPart Method

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
Int32[] value
);

See Also

ObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see ObjectArrayProperty.WebCacheObjectArrayProperty Members.

System.Object
Property.WebCacheProperty
VectorProperty.WebCacheVectorProperty
ObjectArrayProperty.WebCacheObjectArrayProperty

public class ObjectArrayProperty.WebCacheObjectArrayProperty : WebCacheVectorProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Members | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty Members

ObjectArrayProperty.WebCacheObjectArrayProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] int[]
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |
TypeOfMembers | [read] The type of member object referenced by this property value, or null if there is no explicit type

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty Properties

The properties of the ObjectArrayProperty.WebCacheObjectArrayProperty class are listed below. For a complete list of ObjectArrayProperty.WebCacheObjectArrayProperty class members, see the ObjectArrayProperty.WebCacheObjectArrayProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] int[]
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |
TypeOfMembers | [read] The type of member object referenced by this property value, or null if there is no explicit type

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.DefaultValue Property

[read/write] int[]

new public virtual Int32[] DefaultValue {get; set;}

Property Value

int[]

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


MaxLength Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.MaxLength Property

[read/write] The maximum length of a property value.

new public virtual Int32 MaxLength {get; set;}

Property Value

The maximum length of a property value.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


MinLength Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.MinLength Property

[read/write] The minimum length of a property value.

new public virtual Int32 MinLength {get; set;}

Property Value

The minimum length of a property value.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.Name Property

new public virtual String Name {get;}

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


TypeOfMembers Property

Borland StarTeam SDK for .NET

ObjectArrayProperty.WebCacheObjectArrayProperty.TypeOfMembers Property

[read] The type of member object referenced by this property value, or null if there is no explicit type

public virtual Type.WebCacheType TypeOfMembers {get;}

Property Value

The type of member object referenced by this property value, or null if there is no explicit type

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty Methods

The methods of the ObjectArrayProperty.WebCacheObjectArrayProperty class are listed below. For a complete list of ObjectArrayProperty.WebCacheObjectArrayProperty class members, see the ObjectArrayProperty.WebCacheObjectArrayProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.Equals Method

Delegate Equals() to com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.Equals(obj).

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.

public override int GetHashCode();

Return Value

com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.GetHashCode().

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.NewQueryPart Method

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
Int32[] value
);

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.ToString Method

Delegate ToString() to com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.

public override string ToString();

Return Value

com.starteam.ObjectArrayProperty.WebCacheObjectArrayProperty.ToString()

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectArrayProperty.WebCacheObjectArrayProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

ObjectArrayProperty.WebCacheObjectArrayProperty Class | StarTeam Namespace


ObjectProperty Class

This class represents a property whose value is an Object.

For a list of all members of this type, see ObjectProperty Members.

System.Object
Property
ObjectProperty
Derived types

public class ObjectProperty : Property

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ObjectProperty Members | StarTeam Namespace


ObjectProperty Members

ObjectProperty overview

Public Static Properties

VALUE_NOT_SET

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ObjectProperty Class | StarTeam Namespace


ObjectProperty Properties

The properties of the ObjectProperty class are listed below. For a complete list of ObjectProperty class members, see the ObjectProperty Members topic.

Public Static Properties

VALUE_NOT_SET

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue | [read] Type the Type object representing the type of a property value.

See Also

ObjectProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

ObjectProperty.DefaultValue Property

[read/write] int

new public virtual Int32 DefaultValue {get; set;}

Property Value

int

See Also

ObjectProperty Class | StarTeam Namespace


TypeOfValue Property

Borland StarTeam SDK for .NET

ObjectProperty.TypeOfValue Property

[read] Type the Type object representing the type of a property value.

public virtual Type TypeOfValue {get;}

Property Value

Type the Type object representing the type of a property value.

See Also

ObjectProperty Class | StarTeam Namespace


VALUE_NOT_SET Property

Borland StarTeam SDK for .NET

ObjectProperty.VALUE_NOT_SET Property

public static Int32 VALUE_NOT_SET {get;}

See Also

ObjectProperty Class | StarTeam Namespace


ObjectProperty Methods

The methods of the ObjectProperty class are listed below. For a complete list of ObjectProperty class members, see the ObjectProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ObjectProperty Class | StarTeam Namespace


ObjectProperty.NewQueryPart Method

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
Int32 objectID
);

See Also

ObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see ObjectProperty.WebCacheObjectProperty Members.

System.Object
Property.WebCacheProperty
ObjectProperty.WebCacheObjectProperty

public class ObjectProperty.WebCacheObjectProperty : WebCacheProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ObjectProperty.WebCacheObjectProperty Members | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty Members

ObjectProperty.WebCacheObjectProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] int
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |
TypeOfValue | [read] Type the Type object representing the type of a property value

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ObjectProperty.WebCacheObjectProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ObjectProperty.WebCacheObjectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ObjectProperty.WebCacheObjectProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty Properties

The properties of the ObjectProperty.WebCacheObjectProperty class are listed below. For a complete list of ObjectProperty.WebCacheObjectProperty class members, see the ObjectProperty.WebCacheObjectProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] int
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |
TypeOfValue | [read] Type the Type object representing the type of a property value

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.DefaultValue Property

[read/write] int

new public virtual Int32 DefaultValue {get; set;}

Property Value

int

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.Name Property

new public virtual String Name {get;}

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


TypeOfValue Property

Borland StarTeam SDK for .NET

ObjectProperty.WebCacheObjectProperty.TypeOfValue Property

[read] Type the Type object representing the type of a property value

public virtual Type.WebCacheType TypeOfValue {get;}

Property Value

Type the Type object representing the type of a property value

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty Methods

The methods of the ObjectProperty.WebCacheObjectProperty class are listed below. For a complete list of ObjectProperty.WebCacheObjectProperty class members, see the ObjectProperty.WebCacheObjectProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ObjectProperty.WebCacheObjectProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ObjectProperty.WebCacheObjectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ObjectProperty.WebCacheObjectProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.Equals Method

Delegate Equals() to com.starteam.ObjectProperty.WebCacheObjectProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ObjectProperty.WebCacheObjectProperty.Equals(obj).

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ObjectProperty.WebCacheObjectProperty.

public override int GetHashCode();

Return Value

com.starteam.ObjectProperty.WebCacheObjectProperty.GetHashCode().

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.NewQueryPart Method

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
Int32 objectID
);

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.ToString Method

Delegate ToString() to com.starteam.ObjectProperty.WebCacheObjectProperty.

public override string ToString();

Return Value

com.starteam.ObjectProperty.WebCacheObjectProperty.ToString()

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


ObjectProperty.WebCacheObjectProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

ObjectProperty.WebCacheObjectProperty Class | StarTeam Namespace


Permission Class

This class defines all the different permission settings used by StarTeam. Note that for historical reasons, permission IDs may overlap. The correct choice of Permission actually depends on the context of the object (ISecurable/ISecurableContainer).

For a list of all members of this type, see Permission Members.

System.Object
Permission

public class Permission

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Permission Members | StarTeam Namespace


Permission Members

Permission overview

Public Static Properties

ALL
ALL_PERMISSIONS
COMPONENT_CREATE_FILTERS
COMPONENT_CREATE_PUBLIC_PROJECT_FILTERS
COMPONENT_CREATE_PUBLIC_PROJECT_QUERIES
COMPONENT_CREATE_QUERIES
FILE_CHECKIN
FILE_CHECKOUT
GENERIC_AQUIRE_OWNERSHIP
GENERIC_CHANGE_ACCESS_RIGHTS
GENERIC_CREATE_NEW_OBJECT
GENERIC_DELETE_OBJECT
GENERIC_MODIFY_OBJECT
GENERIC_PURGE_OBJECT
GENERIC_SEE_OBJECT
ITEM_ADD_TO_REVISION_LABEL
ITEM_ADD_TO_VIEW_LABEL
ITEM_BREAK_EXCLUSIVE_LOCK
ITEM_CREATE_LINKS
ITEM_DELETE_LINKS
ITEM_DETACH_FROM_REVISION_LABEL
ITEM_DETACH_FROM_VIEW_LABEL
ITEM_LOCK_EXCLUSIVELY
ITEM_MODIFY_BEHAVIOR
ITEM_MODIFY_LINKS
ITEM_MOVE
ITEM_PERFORM_MAINTENANCE
ITEM_SEE_HISTORY
ITEM_SEE_LINKS
ITEM_SHARE
PROMOTION_STATE_MODIFY_STATUS
SERVER_ADD_COLLABORATION_USER
SERVER_ADMIN_REMOTELY
SERVER_ADMIN_USER_ACCOUNTS
SERVER_ADMINISTER_COMPONENT_RIGHTS
SERVER_CREATE_PROJECT
SERVER_MODIFY_CONFIGURATION
SERVER_MODIFY_SCHEMA
SERVER_MODIFY_SYSTEM_POLICY
SERVER_REPLICATION_RIGHTS
SERVER_VIEW_COMMAND_STATS
SERVER_VIEW_CONFIGURATION
SERVER_VIEW_DIAGNOSTICS
SERVER_VIEW_LOG
SERVER_VIEW_SECURITY_LOG
SERVER_VIEW_SYSTEM_POLICY
VIEW_CREATE_REVISION_LABEL
VIEW_CREATE_VIEW_LABEL
VIEW_DEFINE_PROMOTION_MODEL
VIEW_DELETE_REVISION_LABEL
VIEW_DELETE_VIEW_LABEL
VIEW_EDIT_REVISION_LABEL
VIEW_EDIT_VIEW_LABEL
VIEW_MODIFY_PROMOTION_STATUS
VIEW_OVERRIDE_DEFAULT_TYPES
VIEW_UNFREEZE_VIEW_LABEL

Public Static Methods

FromID Gets the first Permission value corresponding to the given ID. since several permission bitmasks are shared across different objects. Use extreme caution when using this method. The returned permission object has no context; i.e it has no advisory name

Public Instance Properties

AdvisoryNames | [read] a set of advisory user friendly descriptions for this permission
ID | [read] the ID of this Permission instance
Name | [read] the advisory description of this permission

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Permission.
GetHashCode | Delegate GetHashCode() to com.starteam.Permission.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Permission.

See Also

Permission Class | StarTeam Namespace


Permission Properties

The properties of the Permission class are listed below. For a complete list of Permission class members, see the Permission Members topic.

Public Static Properties

ALL
ALL_PERMISSIONS
COMPONENT_CREATE_FILTERS
COMPONENT_CREATE_PUBLIC_PROJECT_FILTERS
COMPONENT_CREATE_PUBLIC_PROJECT_QUERIES
COMPONENT_CREATE_QUERIES
FILE_CHECKIN
FILE_CHECKOUT
GENERIC_AQUIRE_OWNERSHIP
GENERIC_CHANGE_ACCESS_RIGHTS
GENERIC_CREATE_NEW_OBJECT
GENERIC_DELETE_OBJECT
GENERIC_MODIFY_OBJECT
GENERIC_PURGE_OBJECT
GENERIC_SEE_OBJECT
ITEM_ADD_TO_REVISION_LABEL
ITEM_ADD_TO_VIEW_LABEL
ITEM_BREAK_EXCLUSIVE_LOCK
ITEM_CREATE_LINKS
ITEM_DELETE_LINKS
ITEM_DETACH_FROM_REVISION_LABEL
ITEM_DETACH_FROM_VIEW_LABEL
ITEM_LOCK_EXCLUSIVELY
ITEM_MODIFY_BEHAVIOR
ITEM_MODIFY_LINKS
ITEM_MOVE
ITEM_PERFORM_MAINTENANCE
ITEM_SEE_HISTORY
ITEM_SEE_LINKS
ITEM_SHARE
PROMOTION_STATE_MODIFY_STATUS
SERVER_ADD_COLLABORATION_USER
SERVER_ADMIN_REMOTELY
SERVER_ADMIN_USER_ACCOUNTS
SERVER_ADMINISTER_COMPONENT_RIGHTS
SERVER_CREATE_PROJECT
SERVER_MODIFY_CONFIGURATION
SERVER_MODIFY_SCHEMA
SERVER_MODIFY_SYSTEM_POLICY
SERVER_REPLICATION_RIGHTS
SERVER_VIEW_COMMAND_STATS
SERVER_VIEW_CONFIGURATION
SERVER_VIEW_DIAGNOSTICS
SERVER_VIEW_LOG
SERVER_VIEW_SECURITY_LOG
SERVER_VIEW_SYSTEM_POLICY
VIEW_CREATE_REVISION_LABEL
VIEW_CREATE_VIEW_LABEL
VIEW_DEFINE_PROMOTION_MODEL
VIEW_DELETE_REVISION_LABEL
VIEW_DELETE_VIEW_LABEL
VIEW_EDIT_REVISION_LABEL
VIEW_EDIT_VIEW_LABEL
VIEW_MODIFY_PROMOTION_STATUS
VIEW_OVERRIDE_DEFAULT_TYPES
VIEW_UNFREEZE_VIEW_LABEL

Public Instance Properties

AdvisoryNames | [read] a set of advisory user friendly descriptions for this permission
ID | [read] the ID of this Permission instance
Name | [read] the advisory description of this permission

See Also

Permission Class | StarTeam Namespace


AdvisoryNames Property

Borland StarTeam SDK for .NET

Permission.AdvisoryNames Property

[read] a set of advisory user friendly descriptions for this permission

public virtual String[] AdvisoryNames {get;}

Property Value

a set of advisory user friendly descriptions for this permission

See Also

Permission Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Permission.ALL Property

public static Permission[] ALL {get;}

See Also

Permission Class | StarTeam Namespace


ALL_PERMISSIONS Property

Borland StarTeam SDK for .NET

Permission.ALL_PERMISSIONS Property

public static Permission ALL_PERMISSIONS {get;}

Property Value

All permissions.

See Also

Permission Class | StarTeam Namespace


COMPONENT_CREATE_FILTERS Property

Borland StarTeam SDK for .NET

Permission.COMPONENT_CREATE_FILTERS Property

public static Permission COMPONENT_CREATE_FILTERS {get;}

Property Value

The right to create filters

See Also

Permission Class | StarTeam Namespace


COMPONENT_CREATE_PUBLIC_PROJECT_FILTERS Property

Borland StarTeam SDK for .NET

Permission.COMPONENT_CREATE_PUBLIC_PROJECT_FILTERS Property

public static Permission COMPONENT_CREATE_PUBLIC_PROJECT_FILTERS {get;}

Property Value

The right to create public project filters.

See Also

Permission Class | StarTeam Namespace


COMPONENT_CREATE_PUBLIC_PROJECT_QUERIES Property

Borland StarTeam SDK for .NET

Permission.COMPONENT_CREATE_PUBLIC_PROJECT_QUERIES Property

public static Permission COMPONENT_CREATE_PUBLIC_PROJECT_QUERIES {get;}

Property Value

The right to create public project queries.ID 0x02000000 is reused across multiple permissions.

See Also

Permission Class | StarTeam Namespace


COMPONENT_CREATE_QUERIES Property

Borland StarTeam SDK for .NET

Permission.COMPONENT_CREATE_QUERIES Property

public static Permission COMPONENT_CREATE_QUERIES {get;}

Property Value

The right to create queries ID 0x00400000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


FILE_CHECKIN Property

Borland StarTeam SDK for .NET

Permission.FILE_CHECKIN Property

public static Permission FILE_CHECKIN {get;}

Property Value

The right to check in a file.

See Also

Permission Class | StarTeam Namespace


FILE_CHECKOUT Property

Borland StarTeam SDK for .NET

Permission.FILE_CHECKOUT Property

public static Permission FILE_CHECKOUT {get;}

Property Value

The right to check out a file.

See Also

Permission Class | StarTeam Namespace


GENERIC_AQUIRE_OWNERSHIP Property

Borland StarTeam SDK for .NET

Permission.GENERIC_AQUIRE_OWNERSHIP Property

public static Permission GENERIC_AQUIRE_OWNERSHIP {get;}

Property Value

The right to acquire object ownership.

See Also

Permission Class | StarTeam Namespace


GENERIC_CHANGE_ACCESS_RIGHTS Property

Borland StarTeam SDK for .NET

Permission.GENERIC_CHANGE_ACCESS_RIGHTS Property

public static Permission GENERIC_CHANGE_ACCESS_RIGHTS {get;}

Property Value

The right to change security settings of an object.

See Also

Permission Class | StarTeam Namespace


GENERIC_CREATE_NEW_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_CREATE_NEW_OBJECT Property

public static Permission GENERIC_CREATE_NEW_OBJECT {get;}

Property Value

The right to create a new object and place it in the container.

See Also

Permission Class | StarTeam Namespace


GENERIC_DELETE_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_DELETE_OBJECT Property

public static Permission GENERIC_DELETE_OBJECT {get;}

Property Value

The right to remove an object from a container (this will be required when an object is being moved from one container to another and may be required when the object is being deleted); this is equivalent to the right to delete (soft-delete) an object.

See Also

Permission Class | StarTeam Namespace


GENERIC_MODIFY_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_MODIFY_OBJECT Property

public static Permission GENERIC_MODIFY_OBJECT {get;}

Property Value

The right to modify object properties (the extent of the right may differ from one object class to the next).

See Also

Permission Class | StarTeam Namespace


GENERIC_PURGE_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_PURGE_OBJECT Property

public static Permission GENERIC_PURGE_OBJECT {get;}

Property Value

The right to purge (hard-delete) an object.

See Also

Permission Class | StarTeam Namespace


GENERIC_SEE_OBJECT Property

Borland StarTeam SDK for .NET

Permission.GENERIC_SEE_OBJECT Property

public static Permission GENERIC_SEE_OBJECT {get;}

Property Value

The right to see an object and its properties (but not necessarily the physical contents).

See Also

Permission Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Permission.ID Property

[read] the ID of this Permission instance

public virtual Int32 ID {get;}

Property Value

the ID of this Permission instance

See Also

Permission Class | StarTeam Namespace


ITEM_ADD_TO_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_ADD_TO_REVISION_LABEL Property

public static Permission ITEM_ADD_TO_REVISION_LABEL {get;}

Property Value

The right to add object to a revision label; ID 0x04000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


ITEM_ADD_TO_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_ADD_TO_VIEW_LABEL Property

public static Permission ITEM_ADD_TO_VIEW_LABEL {get;}

Property Value

The right to add object to a view label;

See Also

Permission Class | StarTeam Namespace


ITEM_BREAK_EXCLUSIVE_LOCK Property

Borland StarTeam SDK for .NET

Permission.ITEM_BREAK_EXCLUSIVE_LOCK Property

public static Permission ITEM_BREAK_EXCLUSIVE_LOCK {get;}

Property Value

The right to break an exclusive lock

See Also

Permission Class | StarTeam Namespace


ITEM_CREATE_LINKS Property

Borland StarTeam SDK for .NET

Permission.ITEM_CREATE_LINKS Property

public static Permission ITEM_CREATE_LINKS {get;}

Property Value

The right to create links for the object.

See Also

Permission Class | StarTeam Namespace


ITEM_DELETE_LINKS Property

Borland StarTeam SDK for .NET

Permission.ITEM_DELETE_LINKS Property

public static Permission ITEM_DELETE_LINKS {get;}

Property Value

The right to delete links for the object; ID 0x00080000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


ITEM_DETACH_FROM_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_DETACH_FROM_REVISION_LABEL Property

public static Permission ITEM_DETACH_FROM_REVISION_LABEL {get;}

Property Value

The right to exclude object from a revision label; ID 0x08000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


ITEM_DETACH_FROM_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.ITEM_DETACH_FROM_VIEW_LABEL Property

public static Permission ITEM_DETACH_FROM_VIEW_LABEL {get;}

Property Value

The right to exclude object from a view label; ID 0x00010000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


ITEM_LOCK_EXCLUSIVELY Property

Borland StarTeam SDK for .NET

Permission.ITEM_LOCK_EXCLUSIVELY Property

public static Permission ITEM_LOCK_EXCLUSIVELY {get;}

Property Value

The right to set an exclusive lock

See Also

Permission Class | StarTeam Namespace


ITEM_MODIFY_BEHAVIOR Property

Borland StarTeam SDK for .NET

Permission.ITEM_MODIFY_BEHAVIOR Property

public static Permission ITEM_MODIFY_BEHAVIOR {get;}

Property Value

The right to modify object behavior.

See Also

Permission Class | StarTeam Namespace


ITEM_MODIFY_LINKS Property

Borland StarTeam SDK for .NET

Permission.ITEM_MODIFY_LINKS Property

public static Permission ITEM_MODIFY_LINKS {get;}

Property Value

The right to modify the links for an object.

See Also

Permission Class | StarTeam Namespace


ITEM_MOVE Property

Borland StarTeam SDK for .NET

Permission.ITEM_MOVE Property

public static Permission ITEM_MOVE {get;}

Property Value

The right to move objects out of the folder (this right is important if the objects themselves are not protected by their own ACLs).

See Also

Permission Class | StarTeam Namespace


ITEM_PERFORM_MAINTENANCE Property

Borland StarTeam SDK for .NET

Permission.ITEM_PERFORM_MAINTENANCE Property

public static Permission ITEM_PERFORM_MAINTENANCE {get;}

Property Value

The right to edit comments etc

See Also

Permission Class | StarTeam Namespace


ITEM_SEE_HISTORY Property

Borland StarTeam SDK for .NET

Permission.ITEM_SEE_HISTORY Property

public static Permission ITEM_SEE_HISTORY {get;}

Property Value

The right to see object history (if it has any); ID 0x00001000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


ITEM_SEE_LINKS Property

Borland StarTeam SDK for .NET

Permission.ITEM_SEE_LINKS Property

public static Permission ITEM_SEE_LINKS {get;}

Property Value

The right to see object links (if it has any);

See Also

Permission Class | StarTeam Namespace


ITEM_SHARE Property

Borland StarTeam SDK for .NET

Permission.ITEM_SHARE Property

public static Permission ITEM_SHARE {get;}

Property Value

The right to share objects out of the folder (this right is important if the objects themselves are not protected by their own ACLs).

See Also

Permission Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Permission.Name Property

[read] the advisory description of this permission

public virtual String Name {get;}

Property Value

the advisory description of this permission

See Also

Permission Class | StarTeam Namespace


PROMOTION_STATE_MODIFY_STATUS Property

Borland StarTeam SDK for .NET

Permission.PROMOTION_STATE_MODIFY_STATUS Property

public static Permission PROMOTION_STATE_MODIFY_STATUS {get;}

Property Value

The right to modify promotion status ID 0x00020000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_ADD_COLLABORATION_USER Property

Borland StarTeam SDK for .NET

Permission.SERVER_ADD_COLLABORATION_USER Property

public static Permission SERVER_ADD_COLLABORATION_USER {get;}

Property Value

The right to add new user to collaboration user group

See Also

Permission Class | StarTeam Namespace


SERVER_ADMIN_REMOTELY Property

Borland StarTeam SDK for .NET

Permission.SERVER_ADMIN_REMOTELY Property

public static Permission SERVER_ADMIN_REMOTELY {get;}

Property Value

The right to administer server remotely ID 0x04000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_ADMIN_USER_ACCOUNTS Property

Borland StarTeam SDK for .NET

Permission.SERVER_ADMIN_USER_ACCOUNTS Property

public static Permission SERVER_ADMIN_USER_ACCOUNTS {get;}

Property Value

The right to administer user accounts ID 0x08000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_ADMINISTER_COMPONENT_RIGHTS Property

Borland StarTeam SDK for .NET

Permission.SERVER_ADMINISTER_COMPONENT_RIGHTS Property

public static Permission SERVER_ADMINISTER_COMPONENT_RIGHTS {get;}

Property Value

The right to administer component rights ID 0x00020000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_CREATE_PROJECT Property

Borland StarTeam SDK for .NET

Permission.SERVER_CREATE_PROJECT Property

public static Permission SERVER_CREATE_PROJECT {get;}

Property Value

The right to create projects ID 0x00010000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_MODIFY_CONFIGURATION Property

Borland StarTeam SDK for .NET

Permission.SERVER_MODIFY_CONFIGURATION Property

public static Permission SERVER_MODIFY_CONFIGURATION {get;}

Property Value

The right to modify server settings

See Also

Permission Class | StarTeam Namespace


SERVER_MODIFY_SCHEMA Property

Borland StarTeam SDK for .NET

Permission.SERVER_MODIFY_SCHEMA Property

public static Permission SERVER_MODIFY_SCHEMA {get;}

Property Value

The right to add/modify property definitions of the objects in the components ID 0x00001000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_MODIFY_SYSTEM_POLICY Property

Borland StarTeam SDK for .NET

Permission.SERVER_MODIFY_SYSTEM_POLICY Property

public static Permission SERVER_MODIFY_SYSTEM_POLICY {get;}

Property Value

The right to modify system policy ID 0x02000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_REPLICATION_RIGHTS Property

Borland StarTeam SDK for .NET

Permission.SERVER_REPLICATION_RIGHTS Property

public static Permission SERVER_REPLICATION_RIGHTS {get;}

Property Value

The right to allow user impersonation ID 0x00080000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_VIEW_COMMAND_STATS Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_COMMAND_STATS Property

public static Permission SERVER_VIEW_COMMAND_STATS {get;}

Property Value

The right to view server command statistics

See Also

Permission Class | StarTeam Namespace


SERVER_VIEW_CONFIGURATION Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_CONFIGURATION Property

public static Permission SERVER_VIEW_CONFIGURATION {get;}

Property Value

The right to view server settings ID 0x00400000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_VIEW_DIAGNOSTICS Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_DIAGNOSTICS Property

public static Permission SERVER_VIEW_DIAGNOSTICS {get;}

Property Value

The right to view server diagnostics ID 0x00200000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_VIEW_LOG Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_LOG Property

public static Permission SERVER_VIEW_LOG {get;}

Property Value

The right to view server log ID 0x00100000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_VIEW_SECURITY_LOG Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_SECURITY_LOG Property

public static Permission SERVER_VIEW_SECURITY_LOG {get;}

Property Value

The right to view security log ID 0x10000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


SERVER_VIEW_SYSTEM_POLICY Property

Borland StarTeam SDK for .NET

Permission.SERVER_VIEW_SYSTEM_POLICY Property

public static Permission SERVER_VIEW_SYSTEM_POLICY {get;}

Property Value

The right to view system policy ID 0x01000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


VIEW_CREATE_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_CREATE_REVISION_LABEL Property

public static Permission VIEW_CREATE_REVISION_LABEL {get;}

Property Value

The right to create a revision label; ID 0x00010000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


VIEW_CREATE_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_CREATE_VIEW_LABEL Property

public static Permission VIEW_CREATE_VIEW_LABEL {get;}

Property Value

The right to create a view label;

See Also

Permission Class | StarTeam Namespace


VIEW_DEFINE_PROMOTION_MODEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_DEFINE_PROMOTION_MODEL Property

public static Permission VIEW_DEFINE_PROMOTION_MODEL {get;}

Property Value

The right to define the promotion model ID 0x01000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


VIEW_DELETE_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_DELETE_REVISION_LABEL Property

public static Permission VIEW_DELETE_REVISION_LABEL {get;}

Property Value

The right to delete revision labels;

See Also

Permission Class | StarTeam Namespace


VIEW_DELETE_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_DELETE_VIEW_LABEL Property

public static Permission VIEW_DELETE_VIEW_LABEL {get;}

Property Value

The right to delete view labels; on servers prior to version 5.1, same as VIEW_DELETE_LABEL.

See Also

Permission Class | StarTeam Namespace


VIEW_EDIT_REVISION_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_EDIT_REVISION_LABEL Property

public static Permission VIEW_EDIT_REVISION_LABEL {get;}

Property Value

The right to edit revision labels;

See Also

Permission Class | StarTeam Namespace


VIEW_EDIT_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_EDIT_VIEW_LABEL Property

public static Permission VIEW_EDIT_VIEW_LABEL {get;}

Property Value

The right to edit view labels;

See Also

Permission Class | StarTeam Namespace


VIEW_MODIFY_PROMOTION_STATUS Property

Borland StarTeam SDK for .NET

Permission.VIEW_MODIFY_PROMOTION_STATUS Property

public static Permission VIEW_MODIFY_PROMOTION_STATUS {get;}

Property Value

The right to modify promotion status ID 0x02000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


VIEW_OVERRIDE_DEFAULT_TYPES Property

Borland StarTeam SDK for .NET

Permission.VIEW_OVERRIDE_DEFAULT_TYPES Property

public static Permission VIEW_OVERRIDE_DEFAULT_TYPES {get;}

Property Value

The right to override project defaults when specifying which item types are initially shared at view creation (for variant views only); ID 0x10000000 is reused across multiple permissions

See Also

Permission Class | StarTeam Namespace


VIEW_UNFREEZE_VIEW_LABEL Property

Borland StarTeam SDK for .NET

Permission.VIEW_UNFREEZE_VIEW_LABEL Property

public static Permission VIEW_UNFREEZE_VIEW_LABEL {get;}

Property Value

The right to unfreeze view labels;

See Also

Permission Class | StarTeam Namespace


Permission Methods

The methods of the Permission class are listed below. For a complete list of Permission class members, see the Permission Members topic.

Public Static Methods

FromID Gets the first Permission value corresponding to the given ID. since several permission bitmasks are shared across different objects. Use extreme caution when using this method. The returned permission object has no context; i.e it has no advisory name

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Permission.
GetHashCode | Delegate GetHashCode() to com.starteam.Permission.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Permission.

See Also

Permission Class | StarTeam Namespace


Permission.Equals Method

Delegate Equals() to com.starteam.Permission.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Permission.Equals(obj).

See Also

Permission Class | StarTeam Namespace


Permission.FromID Method

Gets the first Permission value corresponding to the given ID. since several permission bitmasks are shared across different objects. Use extreme caution when using this method. The returned permission object has no context; i.e it has no advisory name

public static Permission FromID(
Int32 id
);

Parameters

id
The ID of a Permission value.

Return Value

The corresponding Permission value, or null.

See Also

Permission Class | StarTeam Namespace


Permission.GetHashCode Method

Delegate GetHashCode() to com.starteam.Permission.

public override int GetHashCode();

Return Value

com.starteam.Permission.GetHashCode().

See Also

Permission Class | StarTeam Namespace


Permission.ToString Method

Delegate ToString() to com.starteam.Permission.

public override string ToString();

Return Value

com.starteam.Permission.ToString()

See Also

Permission Class | StarTeam Namespace


PermissionCollection Class

A Collection that manages Permissions

For a list of all members of this type, see PermissionCollection Members.

System.Object
StarTeamCollection
PermissionCollection

public class PermissionCollection : StarTeamCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PermissionCollection Members | StarTeam Namespace


PermissionCollection Members

PermissionCollection overview

Public Instance Constructors

PermissionCollection Overloaded. Initializes a new instance of the PermissionCollection class.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

PermissionCollection Class | StarTeam Namespace


PermissionCollection Constructor

Construct a new Permission Collection

Overload List

Construct a new Permission Collection

public PermissionCollection();

Construct a Permission Collection with a specific permission

public PermissionCollection(Permission);

Construct a Permission Collection from an array of permissions

public PermissionCollection(Permission[]);

Construct a new Permission Collection from another

public PermissionCollection(PermissionCollection);

See Also

PermissionCollection Class | StarTeam Namespace


PermissionCollection Constructor ()

Construct a new Permission Collection

public PermissionCollection();

See Also

PermissionCollection Class | StarTeam Namespace | PermissionCollection Constructor Overload List


PermissionCollection Constructor (PermissionCollection)

Construct a new Permission Collection from another

public PermissionCollection(
PermissionCollection source
);

Parameters

source
the collection to copy

See Also

PermissionCollection Class | StarTeam Namespace | PermissionCollection Constructor Overload List


PermissionCollection Constructor (Permission)

Construct a Permission Collection with a specific permission

public PermissionCollection(
Permission permission
);

Parameters

permission
a single permission to add to the collection

See Also

PermissionCollection Class | StarTeam Namespace | PermissionCollection Constructor Overload List


PermissionCollection Constructor (Permission[])

Construct a Permission Collection from an array of permissions

public PermissionCollection(
Permission[] permissions
);

Parameters

permissions
an array of permissions to add to the collection

See Also

PermissionCollection Class | StarTeam Namespace | PermissionCollection Constructor Overload List


Plan Class

Represents a Starteam Plan item.

For a list of all members of this type, see Plan Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Plan

public class Plan : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan Members | StarTeam Namespace


Plan Members

Plan overview

Public Static Methods

Create Create a Plan in the specified parent folder.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EndDate | [read/write] the End Date of this Plan.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Plan.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PlanID | [read] the Plan id.
PlanTypeValue | [read/write] plan type used for this plan
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
Requirements | [read] the linked requirements.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Sprints | [read] the linked sprints.
StartDate | [read/write] the Start Date of this Plan.
Stories | [read] the linked stories.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WeeklyCapacity | [read/write] the weekly capacity for the Plan

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Plan Class | StarTeam Namespace


Plan Properties

The properties of the Plan class are listed below. For a complete list of Plan class members, see the Plan Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EndDate | [read/write] the End Date of this Plan.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Plan.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PlanID | [read] the Plan id.
PlanTypeValue | [read/write] plan type used for this plan
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
Requirements | [read] the linked requirements.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Sprints | [read] the linked sprints.
StartDate | [read/write] the Start Date of this Plan.
Stories | [read] the linked stories.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WeeklyCapacity | [read/write] the weekly capacity for the Plan

See Also

Plan Class | StarTeam Namespace


EndDate Property

Borland StarTeam SDK for .NET

Plan.EndDate Property

[read/write] the End Date of this Plan.

public virtual DateTime EndDate {get; set;}

Property Value

the End Date of this Plan.

See Also

Plan Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Plan.Name Property

[read/write] the Name of this Plan.

public virtual String Name {get; set;}

Property Value

the Name of this Plan.

See Also

Plan Class | StarTeam Namespace


PlanID Property

Borland StarTeam SDK for .NET

Plan.PlanID Property

[read] the Plan id.

public virtual Int32 PlanID {get;}

Property Value

the Plan id.

See Also

Plan Class | StarTeam Namespace


PlanTypeValue Property

Borland StarTeam SDK for .NET

Plan.PlanTypeValue Property

[read/write] plan type used for this plan

public virtual Plan.PlanType PlanTypeValue {get; set;}

Property Value

plan type used for this plan

See Also

Plan Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Plan.Properties Property

[read] the PropertyCollection of its Type

public virtual Plan.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

Plan Class | StarTeam Namespace


Requirements Property

Borland StarTeam SDK for .NET

Plan.Requirements Property

[read] the linked requirements.

public virtual Requirement[] Requirements {get;}

Property Value

the linked requirements.

See Also

Plan Class | StarTeam Namespace


Sprints Property

Borland StarTeam SDK for .NET

Plan.Sprints Property

[read] the linked sprints.

public virtual Sprint[] Sprints {get;}

Property Value

the linked sprints.

See Also

Plan Class | StarTeam Namespace


StartDate Property

Borland StarTeam SDK for .NET

Plan.StartDate Property

[read/write] the Start Date of this Plan.

public virtual DateTime StartDate {get; set;}

Property Value

the Start Date of this Plan.

See Also

Plan Class | StarTeam Namespace


Stories Property

Borland StarTeam SDK for .NET

Plan.Stories Property

[read] the linked stories.

public virtual Story[] Stories {get;}

Property Value

the linked stories.

See Also

Plan Class | StarTeam Namespace


WeeklyCapacity Property

Borland StarTeam SDK for .NET

Plan.WeeklyCapacity Property

[read/write] the weekly capacity for the Plan

public virtual Double WeeklyCapacity {get; set;}

Property Value

the weekly capacity for the Plan

See Also

Plan Class | StarTeam Namespace


Plan Methods

The methods of the Plan class are listed below. For a complete list of Plan class members, see the Plan Members topic.

Public Static Methods

Create Create a Plan in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Plan Class | StarTeam Namespace


Plan.Create Method

Create a Plan in the specified parent folder.

public static Plan Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Plan Object.

See Also

Plan Class | StarTeam Namespace


Plan.PlanType Class

The type of the plan according to agile terminology.

For a list of all members of this type, see Plan.PlanType Members.

System.Object
EnumeratedValue
Plan.PlanType

public class Plan.PlanType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan.PlanType Members | StarTeam Namespace


Plan.PlanType Members

Plan.PlanType overview

Public Static Properties

ALL
PLAN
RELEASE

Public Static Methods

FromID | Gets the plan type corresponding to the given ID.
FromValue | Gets the plan Type corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Plan.PlanType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.PlanType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Plan.PlanType.

See Also

Plan.PlanType Class | StarTeam Namespace


Plan.PlanType Properties

The properties of the Plan.PlanType class are listed below. For a complete list of Plan.PlanType class members, see the Plan.PlanType Members topic.

Public Static Properties

ALL
PLAN
RELEASE

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Plan.PlanType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Plan.PlanType.ALL Property

public static PlanType[] ALL {get;}

See Also

Plan.PlanType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Plan.PlanType.ID Property

[read] the ID of this Type value.

public virtual Int32 ID {get;}

Property Value

the ID of this Type value.

See Also

Plan.PlanType Class | StarTeam Namespace


PLAN Property

Borland StarTeam SDK for .NET

Plan.PlanType.PLAN Property

public static Plan.PlanType PLAN {get;}

Property Value

Specifies a regular plan.

See Also

Plan.PlanType Class | StarTeam Namespace


RELEASE Property

Borland StarTeam SDK for .NET

Plan.PlanType.RELEASE Property

public static Plan.PlanType RELEASE {get;}

Property Value

Describes a release.

See Also

Plan.PlanType Class | StarTeam Namespace


Plan.PlanType Methods

The methods of the Plan.PlanType class are listed below. For a complete list of Plan.PlanType class members, see the Plan.PlanType Members topic.

Public Static Methods

FromID | Gets the plan type corresponding to the given ID.
FromValue | Gets the plan Type corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Plan.PlanType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.PlanType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Plan.PlanType.

See Also

Plan.PlanType Class | StarTeam Namespace


Plan.PlanType.Equals Method

Delegate Equals() to com.starteam.Plan.PlanType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Plan.PlanType.Equals(obj).

See Also

Plan.PlanType Class | StarTeam Namespace


Plan.PlanType.FromID Method

Gets the plan type corresponding to the given ID.

public static PlanType FromID(
Int32 id
);

Parameters

id
A PlanType ID.

Return Value

the corresponding PlanType Type, or null.

See Also

Plan.PlanType Class | StarTeam Namespace


Plan.PlanType.FromValue Method

Gets the plan Type corresponding to the given EnumeratedValue.

public static PlanType FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a PlanTypeProperty.

Return Value

the corresponding StoryType value, or null.

See Also

Plan.PlanType Class | StarTeam Namespace


Plan.PlanType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Plan.PlanType.

public override int GetHashCode();

Return Value

com.starteam.Plan.PlanType.GetHashCode().

See Also

Plan.PlanType Class | StarTeam Namespace


Plan.PlanType.ToString Method

Delegate ToString() to com.starteam.Plan.PlanType.

public override string ToString();

Return Value

com.starteam.Plan.PlanType.ToString()

See Also

Plan.PlanType Class | StarTeam Namespace


Plan.Type Class

Type meta-data (schema) for Plan object instances.

For a list of all members of this type, see Plan.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
Plan.Type

new public class Plan.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan.Type Members | StarTeam Namespace


Plan.Type Members

Plan.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Plan.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Plan.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type Properties

The properties of the Plan.Type class are listed below. For a complete list of Plan.Type class members, see the Plan.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Plan.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Plan.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Plan.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Plan.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Plan.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Plan.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Plan.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Plan.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Plan.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Plan.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Plan.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Plan.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Plan.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Plan.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Plan.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Plan.Type.NAME Property

new public static String NAME {get;}

See Also

Plan.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Plan.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Plan.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Plan.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Plan.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Plan.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Plan.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Plan.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Plan.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Plan.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type Methods

The methods of the Plan.Type class are listed below. For a complete list of Plan.Type class members, see the Plan.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Plan.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Plan.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type.Equals Method

Delegate Equals() to com.starteam.Plan.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Plan.Type.Equals(obj).

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Plan.Type.

public override int GetHashCode();

Return Value

com.starteam.Plan.Type.GetHashCode().

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type.ToString Method

Delegate ToString() to com.starteam.Plan.Type.

public override string ToString();

Return Value

com.starteam.Plan.Type.ToString()

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Plan.Type Class | StarTeam Namespace


Plan.Type.EndDateProperty Class

The property type of the StartDate property.

For a list of all members of this type, see Plan.Type.EndDateProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Plan.Type.EndDateProperty

public class Plan.Type.EndDateProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan.Type.EndDateProperty Members | StarTeam Namespace


Plan.Type.EndDateProperty Members

Plan.Type.EndDateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Plan.Type.EndDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.EndDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Plan.Type.EndDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.EndDateProperty Class | StarTeam Namespace


Plan.Type.EndDateProperty Properties

The properties of the Plan.Type.EndDateProperty class are listed below. For a complete list of Plan.Type.EndDateProperty class members, see the Plan.Type.EndDateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Plan.Type.EndDateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Plan.Type.EndDateProperty.NAME Property

public static String NAME {get;}

See Also

Plan.Type.EndDateProperty Class | StarTeam Namespace


Plan.Type.EndDateProperty Methods

The methods of the Plan.Type.EndDateProperty class are listed below. For a complete list of Plan.Type.EndDateProperty class members, see the Plan.Type.EndDateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Plan.Type.EndDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.EndDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Plan.Type.EndDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.EndDateProperty Class | StarTeam Namespace


Plan.Type.EndDateProperty.Equals Method

Delegate Equals() to com.starteam.Plan.Type.EndDateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Plan.Type.EndDateProperty.Equals(obj).

See Also

Plan.Type.EndDateProperty Class | StarTeam Namespace


Plan.Type.EndDateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Plan.Type.EndDateProperty.

public override int GetHashCode();

Return Value

com.starteam.Plan.Type.EndDateProperty.GetHashCode().

See Also

Plan.Type.EndDateProperty Class | StarTeam Namespace


Plan.Type.EndDateProperty.ToString Method

Delegate ToString() to com.starteam.Plan.Type.EndDateProperty.

public override string ToString();

Return Value

com.starteam.Plan.Type.EndDateProperty.ToString()

See Also

Plan.Type.EndDateProperty Class | StarTeam Namespace


Plan.Type.PlanIDProperty Class

The property type of the PlanID property

For a list of all members of this type, see Plan.Type.PlanIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Plan.Type.PlanIDProperty

public class Plan.Type.PlanIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan.Type.PlanIDProperty Members | StarTeam Namespace


Plan.Type.PlanIDProperty Members

Plan.Type.PlanIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Plan.Type.PlanIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.PlanIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Plan.Type.PlanIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.PlanIDProperty Class | StarTeam Namespace


Plan.Type.PlanIDProperty Properties

The properties of the Plan.Type.PlanIDProperty class are listed below. For a complete list of Plan.Type.PlanIDProperty class members, see the Plan.Type.PlanIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Plan.Type.PlanIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Plan.Type.PlanIDProperty.NAME Property

public static String NAME {get;}

See Also

Plan.Type.PlanIDProperty Class | StarTeam Namespace


Plan.Type.PlanIDProperty Methods

The methods of the Plan.Type.PlanIDProperty class are listed below. For a complete list of Plan.Type.PlanIDProperty class members, see the Plan.Type.PlanIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Plan.Type.PlanIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.PlanIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Plan.Type.PlanIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.PlanIDProperty Class | StarTeam Namespace


Plan.Type.PlanIDProperty.Equals Method

Delegate Equals() to com.starteam.Plan.Type.PlanIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Plan.Type.PlanIDProperty.Equals(obj).

See Also

Plan.Type.PlanIDProperty Class | StarTeam Namespace


Plan.Type.PlanIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Plan.Type.PlanIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Plan.Type.PlanIDProperty.GetHashCode().

See Also

Plan.Type.PlanIDProperty Class | StarTeam Namespace


Plan.Type.PlanIDProperty.ToString Method

Delegate ToString() to com.starteam.Plan.Type.PlanIDProperty.

public override string ToString();

Return Value

com.starteam.Plan.Type.PlanIDProperty.ToString()

See Also

Plan.Type.PlanIDProperty Class | StarTeam Namespace


Plan.Type.PlanTypeProperty Class

The property type of the PlanType property.

For a list of all members of this type, see Plan.Type.PlanTypeProperty Members.

System.Object
Property
EnumeratedProperty
Plan.Type.PlanTypeProperty

public class Plan.Type.PlanTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan.Type.PlanTypeProperty Members | StarTeam Namespace


Plan.Type.PlanTypeProperty Members

Plan.Type.PlanTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Plan.Type.PlanTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.PlanTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Plan.Type.PlanTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.PlanTypeProperty Class | StarTeam Namespace


Plan.Type.PlanTypeProperty Properties

The properties of the Plan.Type.PlanTypeProperty class are listed below. For a complete list of Plan.Type.PlanTypeProperty class members, see the Plan.Type.PlanTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Plan.Type.PlanTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Plan.Type.PlanTypeProperty.NAME Property

public static String NAME {get;}

See Also

Plan.Type.PlanTypeProperty Class | StarTeam Namespace


Plan.Type.PlanTypeProperty Methods

The methods of the Plan.Type.PlanTypeProperty class are listed below. For a complete list of Plan.Type.PlanTypeProperty class members, see the Plan.Type.PlanTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Plan.Type.PlanTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.PlanTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Plan.Type.PlanTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.PlanTypeProperty Class | StarTeam Namespace


Plan.Type.PlanTypeProperty.Equals Method

Delegate Equals() to com.starteam.Plan.Type.PlanTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Plan.Type.PlanTypeProperty.Equals(obj).

See Also

Plan.Type.PlanTypeProperty Class | StarTeam Namespace


Plan.Type.PlanTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Plan.PlanType value
);

See Also

Plan.Type.PlanTypeProperty Class | StarTeam Namespace


Plan.Type.PlanTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Plan.Type.PlanTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Plan.Type.PlanTypeProperty.GetHashCode().

See Also

Plan.Type.PlanTypeProperty Class | StarTeam Namespace


Plan.Type.PlanTypeProperty.ToString Method

Delegate ToString() to com.starteam.Plan.Type.PlanTypeProperty.

public override string ToString();

Return Value

com.starteam.Plan.Type.PlanTypeProperty.ToString()

See Also

Plan.Type.PlanTypeProperty Class | StarTeam Namespace


Plan.Type.PropertyCollection Class

The PropertyCollection of a Plan

For a list of all members of this type, see Plan.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Plan.Type.PropertyCollection

new public class Plan.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan.Type.PropertyCollection Members | StarTeam Namespace


Plan.Type.PropertyCollection Members

Plan.Type.PropertyCollection overview

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_DATE |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PLAN_ID |
PLAN_TYPE |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
START_DATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WEEKLY_CAPACITY |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Plan.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Plan.Type.PropertyCollection.

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


Plan.Type.PropertyCollection Properties

The properties of the Plan.Type.PropertyCollection class are listed below. For a complete list of Plan.Type.PropertyCollection class members, see the Plan.Type.PropertyCollection Members topic.

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_DATE |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PLAN_ID |
PLAN_TYPE |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
START_DATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WEEKLY_CAPACITY |

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


END_DATE Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.END_DATE Property

public Plan.Type.EndDateProperty END_DATE {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


PLAN_ID Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.PLAN_ID Property

public Plan.Type.PlanIDProperty PLAN_ID {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


PLAN_TYPE Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.PLAN_TYPE Property

public Plan.Type.PlanTypeProperty PLAN_TYPE {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


START_DATE Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.START_DATE Property

public Plan.Type.StartDateProperty START_DATE {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


WEEKLY_CAPACITY Property

Borland StarTeam SDK for .NET

Plan.Type.PropertyCollection.WEEKLY_CAPACITY Property

public Plan.Type.WeeklyCapacityProperty WEEKLY_CAPACITY {get;}

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


Plan.Type.PropertyCollection Methods

The methods of the Plan.Type.PropertyCollection class are listed below. For a complete list of Plan.Type.PropertyCollection class members, see the Plan.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Plan.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Plan.Type.PropertyCollection.

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


Plan.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Plan.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Plan.Type.PropertyCollection.Equals(obj).

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


Plan.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Plan.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Plan.Type.PropertyCollection.GetHashCode().

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


Plan.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Plan.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Plan.Type.PropertyCollection.ToString()

See Also

Plan.Type.PropertyCollection Class | StarTeam Namespace


Plan.Type.StartDateProperty Class

The property type of the StartDate property.

For a list of all members of this type, see Plan.Type.StartDateProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Plan.Type.StartDateProperty

public class Plan.Type.StartDateProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan.Type.StartDateProperty Members | StarTeam Namespace


Plan.Type.StartDateProperty Members

Plan.Type.StartDateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Plan.Type.StartDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.StartDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Plan.Type.StartDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.StartDateProperty Class | StarTeam Namespace


Plan.Type.StartDateProperty Properties

The properties of the Plan.Type.StartDateProperty class are listed below. For a complete list of Plan.Type.StartDateProperty class members, see the Plan.Type.StartDateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Plan.Type.StartDateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Plan.Type.StartDateProperty.NAME Property

public static String NAME {get;}

See Also

Plan.Type.StartDateProperty Class | StarTeam Namespace


Plan.Type.StartDateProperty Methods

The methods of the Plan.Type.StartDateProperty class are listed below. For a complete list of Plan.Type.StartDateProperty class members, see the Plan.Type.StartDateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Plan.Type.StartDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.StartDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Plan.Type.StartDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.StartDateProperty Class | StarTeam Namespace


Plan.Type.StartDateProperty.Equals Method

Delegate Equals() to com.starteam.Plan.Type.StartDateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Plan.Type.StartDateProperty.Equals(obj).

See Also

Plan.Type.StartDateProperty Class | StarTeam Namespace


Plan.Type.StartDateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Plan.Type.StartDateProperty.

public override int GetHashCode();

Return Value

com.starteam.Plan.Type.StartDateProperty.GetHashCode().

See Also

Plan.Type.StartDateProperty Class | StarTeam Namespace


Plan.Type.StartDateProperty.ToString Method

Delegate ToString() to com.starteam.Plan.Type.StartDateProperty.

public override string ToString();

Return Value

com.starteam.Plan.Type.StartDateProperty.ToString()

See Also

Plan.Type.StartDateProperty Class | StarTeam Namespace


Plan.Type.WeeklyCapacityProperty Class

The property type of the WeeklyCapacity property.

For a list of all members of this type, see Plan.Type.WeeklyCapacityProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Plan.Type.WeeklyCapacityProperty

public class Plan.Type.WeeklyCapacityProperty : DoubleProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan.Type.WeeklyCapacityProperty Members | StarTeam Namespace


Plan.Type.WeeklyCapacityProperty Members

Plan.Type.WeeklyCapacityProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Plan.Type.WeeklyCapacityProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.WeeklyCapacityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Plan.Type.WeeklyCapacityProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.WeeklyCapacityProperty Class | StarTeam Namespace


Plan.Type.WeeklyCapacityProperty Properties

The properties of the Plan.Type.WeeklyCapacityProperty class are listed below. For a complete list of Plan.Type.WeeklyCapacityProperty class members, see the Plan.Type.WeeklyCapacityProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Plan.Type.WeeklyCapacityProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Plan.Type.WeeklyCapacityProperty.NAME Property

public static String NAME {get;}

See Also

Plan.Type.WeeklyCapacityProperty Class | StarTeam Namespace


Plan.Type.WeeklyCapacityProperty Methods

The methods of the Plan.Type.WeeklyCapacityProperty class are listed below. For a complete list of Plan.Type.WeeklyCapacityProperty class members, see the Plan.Type.WeeklyCapacityProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Plan.Type.WeeklyCapacityProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.Type.WeeklyCapacityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Plan.Type.WeeklyCapacityProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Plan.Type.WeeklyCapacityProperty Class | StarTeam Namespace


Plan.Type.WeeklyCapacityProperty.Equals Method

Delegate Equals() to com.starteam.Plan.Type.WeeklyCapacityProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Plan.Type.WeeklyCapacityProperty.Equals(obj).

See Also

Plan.Type.WeeklyCapacityProperty Class | StarTeam Namespace


Plan.Type.WeeklyCapacityProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Plan.Type.WeeklyCapacityProperty.

public override int GetHashCode();

Return Value

com.starteam.Plan.Type.WeeklyCapacityProperty.GetHashCode().

See Also

Plan.Type.WeeklyCapacityProperty Class | StarTeam Namespace


Plan.Type.WeeklyCapacityProperty.ToString Method

Delegate ToString() to com.starteam.Plan.Type.WeeklyCapacityProperty.

public override string ToString();

Return Value

com.starteam.Plan.Type.WeeklyCapacityProperty.ToString()

See Also

Plan.Type.WeeklyCapacityProperty Class | StarTeam Namespace


Plan.WebCachePlan Class

Item accessor for cached SDK Plan items contained objects are obtained from the artifact cache

For a list of all members of this type, see Plan.WebCachePlan Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
Plan.WebCachePlan

public class Plan.WebCachePlan : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Plan.WebCachePlan Members | StarTeam Namespace


Plan.WebCachePlan Members

Plan.WebCachePlan overview

Public Static Methods

Create Overloaded.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EndDate | [read/write] the End Date of this Plan.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PlanID | [read] the Plan id.
PlanType | [read/write] plan type used for this story
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StartDate | [read/write] the Start Date of this Plan.
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WeeklyCapacity | [read/write] the weekly capacity for the Plan

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Plan.WebCachePlan.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.WebCachePlan.
GetRequirements |
GetSprints |
GetStories |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Plan.WebCachePlan.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan Properties

The properties of the Plan.WebCachePlan class are listed below. For a complete list of Plan.WebCachePlan class members, see the Plan.WebCachePlan Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EndDate | [read/write] the End Date of this Plan.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PlanID | [read] the Plan id.
PlanType | [read/write] plan type used for this story
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StartDate | [read/write] the Start Date of this Plan.
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WeeklyCapacity | [read/write] the weekly capacity for the Plan

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


EndDate Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.EndDate Property

[read/write] the End Date of this Plan.

public virtual DateTime EndDate {get; set;}

Property Value

the End Date of this Plan.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Plan.WebCachePlan Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Plan.WebCachePlan Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Plan.WebCachePlan Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Plan.WebCachePlan Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Plan.WebCachePlan Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Plan.WebCachePlan Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Name Property

new public virtual String Name {get; set;}

See Also

Plan.WebCachePlan Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Plan.WebCachePlan Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


PlanID Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.PlanID Property

[read] the Plan id.

public virtual Int32 PlanID {get;}

Property Value

the Plan id.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


PlanType Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.PlanType Property

[read/write] plan type used for this story

public virtual Plan.PlanType PlanType {get; set;}

Property Value

plan type used for this story

See Also

Plan.WebCachePlan Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Plan.WebCachePlan Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Plan.WebCachePlan Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Plan.WebCachePlan Class | StarTeam Namespace


StartDate Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.StartDate Property

[read/write] the Start Date of this Plan.

public virtual DateTime StartDate {get; set;}

Property Value

the Start Date of this Plan.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Plan.WebCachePlan Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Plan.WebCachePlan Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Plan.WebCachePlan Class | StarTeam Namespace


WeeklyCapacity Property

Borland StarTeam SDK for .NET

Plan.WebCachePlan.WeeklyCapacity Property

[read/write] the weekly capacity for the Plan

public virtual Double WeeklyCapacity {get; set;}

Property Value

the weekly capacity for the Plan

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan Methods

The methods of the Plan.WebCachePlan class are listed below. For a complete list of Plan.WebCachePlan class members, see the Plan.WebCachePlan Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Plan.WebCachePlan.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Plan.WebCachePlan.
GetRequirements |
GetSprints |
GetStories |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Plan.WebCachePlan.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Create Method

Overload List

public static WebCachePlan Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCachePlan Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.Create Overload List


Plan.WebCachePlan.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.Create Overload List


Plan.WebCachePlan.Equals Method

Delegate Equals() to com.starteam.Plan.WebCachePlan.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Plan.WebCachePlan.Equals(obj).

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.GetHashCode Method

Delegate GetHashCode() to com.starteam.Plan.WebCachePlan.

public override int GetHashCode();

Return Value

com.starteam.Plan.WebCachePlan.GetHashCode().

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.GetRequirements Method

public virtual WebCacheRequirement[] GetRequirements(
Filter.WebCacheFilter fltr
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.GetSprints Method

public virtual WebCacheSprint[] GetSprints(
Filter.WebCacheFilter fltr
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.GetStories Method

public virtual WebCacheStory[] GetStories(
Filter.WebCacheFilter fltr
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Plan.WebCachePlan.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.GetValue Overload List


Plan.WebCachePlan.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.GetValue Overload List


Plan.WebCachePlan.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Plan.WebCachePlan.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Plan.WebCachePlan Class | StarTeam Namespace | WebCacheViewMemberCollection


Plan.WebCachePlan.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.Lock Overload List | WebCacheViewMemberCollection


Plan.WebCachePlan.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.Lock Overload List


Plan.WebCachePlan.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Plan.WebCachePlan Class | StarTeam Namespace | NAME


Plan.WebCachePlan.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Plan.WebCachePlan Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Plan.WebCachePlan.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.MoveTo Overload List


Plan.WebCachePlan.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.MoveTo Overload List


Plan.WebCachePlan.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Plan.WebCachePlan Class | StarTeam Namespace | isFloating | isPinned | unpin


Plan.WebCachePlan.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Plan.WebCachePlan Class | StarTeam Namespace | WebCacheViewMemberCollection


Plan.WebCachePlan.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Plan.WebCachePlan.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.SetValue Overload List


Plan.WebCachePlan.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Plan.WebCachePlan Class | StarTeam Namespace | Plan.WebCachePlan.SetValue Overload List


Plan.WebCachePlan.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.ToString Method

Delegate ToString() to com.starteam.Plan.WebCachePlan.

public override string ToString();

Return Value

com.starteam.Plan.WebCachePlan.ToString()

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Plan.WebCachePlan.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Plan.WebCachePlan Class | StarTeam Namespace | WebCacheViewMemberCollection


Plan.WebCachePlan.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Plan.WebCachePlan Class | StarTeam Namespace | isFloating | isPinned | pinTo


Plan.WebCachePlan.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Plan.WebCachePlan Class | StarTeam Namespace | WebCacheViewMemberCollection


Plan.WebCachePlan.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Plan.WebCachePlan Class | StarTeam Namespace


Principal Class

A StarTeam Resource with the right to manipulate StarTeam Artifacts. Users and Groups are instances of Principals. Access Rights may be granted or denied.

For a list of all members of this type, see Principal Members.

System.Object
TypedResource
LiveObject
TrackedObject
Principal
Group
User

public class Principal : TrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Principal Members | StarTeam Namespace


Principal Members

Principal overview

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDeleted | [read] true if the Principal has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of this principal
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
Remove | Removes this principal from the StarTeam server, plus any direct or indirect members of this principal.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Persistently saves the changes to this principal in the server. If the principal is new it will be added, otherwise it will be modified.

See Also

Principal Class | StarTeam Namespace


Principal Properties

The properties of the Principal class are listed below. For a complete list of Principal class members, see the Principal Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDeleted | [read] true if the Principal has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of this principal
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource

See Also

Principal Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Principal.IsDeleted Property

[read] true if the Principal has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if the Principal has been deleted.

See Also

Principal Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Principal.Name Property

[read/write] the name of this principal

public virtual String Name {get; set;}

Property Value

the name of this principal

See Also

Principal Class | StarTeam Namespace


Principal Methods

The methods of the Principal class are listed below. For a complete list of Principal class members, see the Principal Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
Remove | Removes this principal from the StarTeam server, plus any direct or indirect members of this principal.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Persistently saves the changes to this principal in the server. If the principal is new it will be added, otherwise it will be modified.

See Also

Principal Class | StarTeam Namespace


Principal.Remove Method

Removes this principal from the StarTeam server, plus any direct or indirect members of this principal.

public virtual void Remove();

Exceptions

Exception Type | Condition
 | System.InvalidOperationException

See Also

Principal Class | StarTeam Namespace


Principal.Update Method

Persistently saves the changes to this principal in the server. If the principal is new it will be added, otherwise it will be modified.

public virtual void Update();

See Also

Principal Class | StarTeam Namespace


Principal.Type Class

The Type of the Principal

For a list of all members of this type, see Principal.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
Principal.Type
Group.Type
User.Type

new public class Principal.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Principal.Type Members | StarTeam Namespace


Principal.Type Members

Principal.Type overview

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Principal.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Principal.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Principal.Type.

See Also

Principal.Type Class | StarTeam Namespace


Principal.Type Methods

The methods of the Principal.Type class are listed below. For a complete list of Principal.Type class members, see the Principal.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Principal.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Principal.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Principal.Type.

See Also

Principal.Type Class | StarTeam Namespace


Principal.Type.Equals Method

Delegate Equals() to com.starteam.Principal.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Principal.Type.Equals(obj).

See Also

Principal.Type Class | StarTeam Namespace


Principal.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Principal.Type.

public override int GetHashCode();

Return Value

com.starteam.Principal.Type.GetHashCode().

See Also

Principal.Type Class | StarTeam Namespace


Principal.Type.ToString Method

Delegate ToString() to com.starteam.Principal.Type.

public override string ToString();

Return Value

com.starteam.Principal.Type.ToString()

See Also

Principal.Type Class | StarTeam Namespace


Principal.WebCachePrincipal Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see Principal.WebCachePrincipal Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
Principal.WebCachePrincipal
Group.WebCacheGroup
User.WebCacheUser

public class Principal.WebCachePrincipal : WebCacheTrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Principal.WebCachePrincipal Members | StarTeam Namespace


Principal.WebCachePrincipal Members

Principal.WebCachePrincipal overview

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object

Public Instance Methods

AddTo |
CanAccessContainerForReading |
CanAccessForReading |
CanCreateArtifactType |
Equals | Delegate Equals() to com.starteam.Principal.WebCachePrincipal.
GetHashCode | Delegate GetHashCode() to com.starteam.Principal.WebCachePrincipal.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasContainerRight | Overloaded.
HasContainerRights |
HasRight |
HasRights |
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Principal.WebCachePrincipal.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal Properties

The properties of the Principal.WebCachePrincipal class are listed below. For a complete list of Principal.WebCachePrincipal class members, see the Principal.WebCachePrincipal Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.Name Property

new public virtual String Name {get;}

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal Methods

The methods of the Principal.WebCachePrincipal class are listed below. For a complete list of Principal.WebCachePrincipal class members, see the Principal.WebCachePrincipal Members topic.

Public Instance Methods

AddTo |
CanAccessContainerForReading |
CanAccessForReading |
CanCreateArtifactType |
Equals | Delegate Equals() to com.starteam.Principal.WebCachePrincipal.
GetHashCode | Delegate GetHashCode() to com.starteam.Principal.WebCachePrincipal.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasContainerRight | Overloaded.
HasContainerRights |
HasRight |
HasRights |
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Principal.WebCachePrincipal.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.CanAccessContainerForReading Method

public virtual bool CanAccessContainerForReading(
ArtifactCacheManager.Securable s
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.CanAccessForReading Method

public virtual bool CanAccessForReading(
ArtifactCacheManager.Securable s
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.CanCreateArtifactType Method

public virtual bool CanCreateArtifactType(
ArtifactCacheManager.SecurableContainer sc,
Type.WebCacheType t
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.Equals Method

Delegate Equals() to com.starteam.Principal.WebCachePrincipal.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Principal.WebCachePrincipal.Equals(obj).

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.GetHashCode Method

Delegate GetHashCode() to com.starteam.Principal.WebCachePrincipal.

public override int GetHashCode();

Return Value

com.starteam.Principal.WebCachePrincipal.GetHashCode().

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace | Principal.WebCachePrincipal.GetValue Overload List


Principal.WebCachePrincipal.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace | Principal.WebCachePrincipal.GetValue Overload List


HasContainerRight Method

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.HasContainerRight Method

Overload List

public virtual bool HasContainerRight(ArtifactCacheManager.Securable,Permission);

public virtual bool HasContainerRight(ArtifactCacheManager.SecurableContainer,Type.WebCacheType,Permission);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.HasContainerRight Method (ArtifactCacheManager#Securable, Permission)

public virtual bool HasContainerRight(
ArtifactCacheManager.Securable s,
Permission p
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace | Principal.WebCachePrincipal.HasContainerRight Overload List


Principal.WebCachePrincipal.HasContainerRight Method (ArtifactCacheManager#SecurableContainer, Type#WebCacheType, Permission)

public virtual bool HasContainerRight(
ArtifactCacheManager.SecurableContainer sc,
Type.WebCacheType t,
Permission p
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace | Principal.WebCachePrincipal.HasContainerRight Overload List


Principal.WebCachePrincipal.HasContainerRights Method

public virtual bool HasContainerRights(
ArtifactCacheManager.Securable s,
PermissionCollection pc
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.HasRight Method

public virtual bool HasRight(
ArtifactCacheManager.Securable s,
Permission p
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.HasRights Method

public virtual bool HasRights(
ArtifactCacheManager.Securable s,
PermissionCollection pc
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace | WebCacheViewMemberCollection


Principal.WebCachePrincipal.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Principal.WebCachePrincipal.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace | Principal.WebCachePrincipal.SetValue Overload List


Principal.WebCachePrincipal.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace | Principal.WebCachePrincipal.SetValue Overload List


Principal.WebCachePrincipal.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.ToString Method

Delegate ToString() to com.starteam.Principal.WebCachePrincipal.

public override string ToString();

Return Value

com.starteam.Principal.WebCachePrincipal.ToString()

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace


Principal.WebCachePrincipal.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Principal.WebCachePrincipal Class | StarTeam Namespace | WebCacheViewMemberCollection


ProcessItem Class

A process item in the context of a given target view.

For a list of all members of this type, see ProcessItem Members.

System.Object
ProcessItem

public class ProcessItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ProcessItem Members | StarTeam Namespace


ProcessItem Members

ProcessItem overview

Public Instance Constructors

ProcessItem Overloaded. Initializes a new instance of the ProcessItem class.

Public Instance Properties

ChangePackages | [read] ChangePackageCollection
IsActiveState | [read] true if this is a legal process item in a legal state to be selected as an active process item for its target view, or false otherwise.
IsLegalType | [read] true if this is a legal type of process item for its target view, or false otherwise.
Item | [read] The underlying item.
Rollup | [read/write] true if rollup is assigned
TargetView | [read] The target view.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ProcessItem.
GetHashCode | Delegate GetHashCode() to com.starteam.ProcessItem.
GetType (inherited from Object) | Gets the Type of the current instance.
Resolve | Overloaded. Resolves this process item in the context of its target view and the specified target file item, returning any/all file item instances at identified different revisions.
ResolveEx | A specialized implementation of {@link #resolve()} which prunes the resultant aggregated set of view members, eliminating duplicates at equal or lesser revisions.
ToString | Delegate ToString() to com.starteam.ProcessItem.

See Also

ProcessItem Class | StarTeam Namespace


ProcessItem Constructor

Constructs a process item. Assumes that the view member resides in the target view.

Overload List

Constructs a process item in the context of a given target view.

public ProcessItem(Item,View);

Constructs a process item. Assumes that the view member resides in the target view.

public ProcessItem(ViewMember);

See Also

ProcessItem Class | StarTeam Namespace


ProcessItem Constructor (ViewMember)

Constructs a process item. Assumes that the view member resides in the target view.

public ProcessItem(
ViewMember vm
);

Parameters

vm
The ViewMember to be treated as a process item. The view member is not necessarily a valid type for the target view.

See Also

ProcessItem Class | StarTeam Namespace | ProcessItem Constructor Overload List


ProcessItem Constructor (Item, View)

Constructs a process item in the context of a given target view.

public ProcessItem(
Item item,
View target
);

Parameters

item
The item to be treated as a process item. The item is not necessarily a valid type for the target view.
target
The target view.

See Also

ProcessItem Class | StarTeam Namespace | ProcessItem Constructor Overload List


ProcessItem Properties

The properties of the ProcessItem class are listed below. For a complete list of ProcessItem class members, see the ProcessItem Members topic.

Public Instance Properties

ChangePackages | [read] ChangePackageCollection
IsActiveState | [read] true if this is a legal process item in a legal state to be selected as an active process item for its target view, or false otherwise.
IsLegalType | [read] true if this is a legal type of process item for its target view, or false otherwise.
Item | [read] The underlying item.
Rollup | [read/write] true if rollup is assigned
TargetView | [read] The target view.

See Also

ProcessItem Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

ProcessItem.ChangePackages Property

[read] ChangePackageCollection

public virtual ChangePackageCollection ChangePackages {get;}

Property Value

ChangePackageCollection

See Also

ProcessItem Class | StarTeam Namespace


IsActiveState Property

Borland StarTeam SDK for .NET

ProcessItem.IsActiveState Property

[read] true if this is a legal process item in a legal state to be selected as an active process item for its target view, or false otherwise.

public virtual Boolean IsActiveState {get;}

Property Value

true if this is a legal process item in a legal state to be selected as an active process item for its target view, or false otherwise.

See Also

ProcessItem Class | StarTeam Namespace


IsLegalType Property

Borland StarTeam SDK for .NET

ProcessItem.IsLegalType Property

[read] true if this is a legal type of process item for its target view, or false otherwise.

public virtual Boolean IsLegalType {get;}

Property Value

true if this is a legal type of process item for its target view, or false otherwise.

See Also

ProcessItem Class | StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

ProcessItem.Item Property

[read] The underlying item.

public virtual Item Item {get;}

Property Value

The underlying item.

See Also

ProcessItem Class | StarTeam Namespace


Rollup Property

Borland StarTeam SDK for .NET

ProcessItem.Rollup Property

[read/write] true if rollup is assigned

public virtual Boolean Rollup {get; set;}

Property Value

true if rollup is assigned

See Also

ProcessItem Class | StarTeam Namespace


TargetView Property

Borland StarTeam SDK for .NET

ProcessItem.TargetView Property

[read] The target view.

public virtual View TargetView {get;}

Property Value

The target view.

See Also

ProcessItem Class | StarTeam Namespace


ProcessItem Methods

The methods of the ProcessItem class are listed below. For a complete list of ProcessItem class members, see the ProcessItem Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ProcessItem.
GetHashCode | Delegate GetHashCode() to com.starteam.ProcessItem.
GetType (inherited from Object) | Gets the Type of the current instance.
Resolve | Overloaded. Resolves this process item in the context of its target view and the specified target file item, returning any/all file item instances at identified different revisions.
ResolveEx | A specialized implementation of {@link #resolve()} which prunes the resultant aggregated set of view members, eliminating duplicates at equal or lesser revisions.
ToString | Delegate ToString() to com.starteam.ProcessItem.

See Also

ProcessItem Class | StarTeam Namespace


ProcessItem.Equals Method

Delegate Equals() to com.starteam.ProcessItem.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ProcessItem.Equals(obj).

See Also

ProcessItem Class | StarTeam Namespace


ProcessItem.GetHashCode Method

Delegate GetHashCode() to com.starteam.ProcessItem.

public override int GetHashCode();

Return Value

com.starteam.ProcessItem.GetHashCode().

See Also

ProcessItem Class | StarTeam Namespace


Resolve Method

Borland StarTeam SDK for .NET

ProcessItem.Resolve Method

Overload List

public virtual ViewMemberCollection Resolve();

Resolves this process item in the context of its target view and the specified target file item, returning any/all file item instances at identified different revisions.

public virtual ViewMemberCollection Resolve(File);

See Also

ProcessItem Class | StarTeam Namespace


ProcessItem.Resolve Method ()

public virtual ViewMemberCollection Resolve();

See Also

ProcessItem Class | StarTeam Namespace | ProcessItem.Resolve Overload List


ProcessItem.Resolve Method (File)

Resolves this process item in the context of its target view and the specified target file item, returning any/all file item instances at identified different revisions.

public virtual ViewMemberCollection Resolve(
File itm
);

Parameters

itm
the file whose revisions are of interest

Return Value

The list of associated file item revisions representing changes associated with this process item in the target view.

See Also

ProcessItem Class | StarTeam Namespace | ProcessItem.Resolve Overload List | resolve


ProcessItem.ResolveEx Method

A specialized implementation of {@link #resolve()} which prunes the resultant aggregated set of view members, eliminating duplicates at equal or lesser revisions.

public virtual ViewMemberCollection ResolveEx();

Return Value

a unique set of resolved view members at the highest appropriate revisions

See Also

ProcessItem Class | StarTeam Namespace | resolve


ProcessItem.ToString Method

Delegate ToString() to com.starteam.ProcessItem.

public override string ToString();

Return Value

com.starteam.ProcessItem.ToString()

See Also

ProcessItem Class | StarTeam Namespace


Project Class

Represents a StarTeam project which is essentially just a collection of Views.

For a list of all members of this type, see Project Members.

System.Object
TypedResource
LiveObject
Project

public class Project : LiveObject, ISecurable, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project Members | StarTeam Namespace


Project Members

Project overview

Public Instance Constructors

Project Constructor Constructs a new project.

Public Instance Properties

AccessibleViews | [read] The set of Views accessible from this Project. May be empty (but is never null).
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CheckinChangePackageLastUpdate | [read] the last time the checkin change package property was modified
CreateCheckinChangePackage | [read/write] true if checkin change packages should be created by the SDK
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DefaultItemTypes | [read/write] TypeCollection the set of item types that will be shared upon creation of a variant view.
DefaultView | [read] The default View for this Project.
Description | [read/write] the description of this project.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EncryptionAlgorithm | [read/write] encryption algorithm used for this project
ExpandKeywords | [read/write] true if keywords are expanded when files are checked out.
GUID | [read/write] GUID
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDeleted | [read] True if the project has been deleted from the server; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsForceCheckinReasonRequired | [read/write] true if a comment must be included with file check in operations.
IsMailUsed | [read] true if email is used in this project.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsProcessItemRequired | [read/write]
IsRefreshRequired | [read] true if project properties may be out of date.
IsRefreshViewsRequired | [read] true if a refresh is required; false otherwise.
IsRequireLockForCheckin | [read/write] true if files must be locked before they are checked in.
KeywordExpansionFileExtensions | [read/write] the list of file extensions for keyword expansion
MarkUnlockedWorkingFilesReadOnly | [read/write] boolean true if unlocked working files should be marked read only
MergeHistoryDuringVCMSession | [read/write] true if History Merges during VCM Sessions are required.
MethodologyValue | [read/write] The project methodology (Agile, Kanban, Waterfall, Migration).
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of this project.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer | [read] null.
PresentationID | [read] the unique integer identifier for this project.
ProcessItemTypes | [read] the set of (stock or custom) Item Types that may be used as process items
Properties | [read] the PropertyCollection for the Project type
Rights | [read/write] the access control list for this project or NULL.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
StatusValue | [read/write] The status (Active, Parked, etc.) of this Project.
Views | [read] The project's view list.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this Project object, with project properties fully populated. Useful to applications that want to save a snapshot of the Project in a given state, for example, before calling refresh().
Discard | Discards all of the cached properties for this project. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a project are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardViews | Discards the list of cached views. A subsequent call to getViews() will re-fetch the views from the server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindView | Overloaded. Finds a view in the project's view collection.
GetActiveProcessItemStates |
GetAllowedStates | Return the subset of enumerated values that are visible for the specified Enumerated property in the context of this project. Note that Enumerated Properties are (and continue to be) type specific. However, an application can choose to store a subset of the values as applicable (legal) to a given type. This subset may be disjoint or may overlap. The application decides Other than storing the relationships between a project, an enumerated property and its values the SDK makes no attempt to (and in reality cannot) validate the usage of Enumerated Values for item types in the context of a given project An application should make no assumption about the returned order of EnumeratedValues, or for that matter, about parent child hierarchies in a multi-select hierarchy
GetAlternateEditorPath |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetCRStatus |
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFilters | returns the set of filters associated with this project
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetQueries | returns the set of queries associated with this project
GetRights | Returns the Access Control List for items of the specified type for this project. This will return null if this project has no access control list for the specified type.
GetStatus |
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUDAGroupings |
GetValue (inherited from TypedResource) | Gets the value of the specified property.
GetVisibleProperties | Return the subset of properties that are visible in the context of the specified Enumerated Value
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions | Overloaded. Returns true if desired permissions are granted for this project
HasSavedCRStatus |
HasSavedStatus |
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsActiveProcessItemStateEnabled | Determines whether or not a given status value of a given type, is one that can be used for an active process item of that type.
IsEqualTo | Compares the properties of two Projects.
IsProcessItemTypeEnabled |
NewProjectEventSource |
NewViewEventSource |
Populate | Populates project properties, if they have not already been populated.
Refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshAllViews | Targeted for the artifact cache, all view properties for a given project are loaded in bulk, unlike refreshViews()
RefreshViews | Ensures that the latest list of views for this project has been retrieved from the server and cached locally. Also ensures that any previously cached view property values are up-to-date. refreshViews() re-uses existing View objects whenever possible, changing cached property values as necessary to bring older Views up-to-date. When MPX is enabled, refreshViews() is optimized to avoid unnecessary server commands.
Remove | Removes the project from the server.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetActiveProcessItemStateEnabled | Defines the specified state as a legal 'Active' state for this project for it's type The set of legal active states is a subset of the set of all open states for the given enumerated property that represents the process item property For 11.0 servers, the types and the status properties are fixed. (Requirement, Task, ChangeRequest) So are their Closed States. Their open states are either all or a restricted but fixed subset of states. Hence, for 11.0 servers, to specify all states as active, specify any state but the restricted ones
SetAllowedState | Set an enumerated value of a given property as an allowed or legal state for this project. Note that Enumerated Properties are (and continue to be) type specific. However, an application can choose to store a subset of the values as applicable (legal) to a given type. Other than storing the relationships between a project, an enumerated property and its values the SDK makes no attempt to (and in reality cannot) validate the usage of Enumerated Values for item types in the context of a given project Note that this api is not supported for pre 12.5 servers
SetAlternateEditorPath |
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetCRStatus |
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights | Modifies the Access Control List for items of the specified type for this project. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStatus |
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetUDAGroupings |
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
SetVisibleProperties | Define a subset of properties of a given type that are marked visible
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Persists this project's properties to its Server. If this project wraps around a foreign archive, Folder hierarchy will be created according to the configuration file and archive path of the foreign archive specified.

See Also

Project Class | StarTeam Namespace


Project Constructor

Constructs a new project.

public Project(
Server server,
String name,
String rootDirectory,
Folder folderTree
);

Parameters

server
the repository in which to create this project
name
the name of the project
rootDirectory
path to be used as the default root directory may be NULL or "", in which case the file system root directory is assumed
folderTree
the root folder of the initial folder tree, may be null

See Also

Project Class | StarTeam Namespace


Project Properties

The properties of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Instance Properties

AccessibleViews | [read] The set of Views accessible from this Project. May be empty (but is never null).
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CheckinChangePackageLastUpdate | [read] the last time the checkin change package property was modified
CreateCheckinChangePackage | [read/write] true if checkin change packages should be created by the SDK
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DefaultItemTypes | [read/write] TypeCollection the set of item types that will be shared upon creation of a variant view.
DefaultView | [read] The default View for this Project.
Description | [read/write] the description of this project.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EncryptionAlgorithm | [read/write] encryption algorithm used for this project
ExpandKeywords | [read/write] true if keywords are expanded when files are checked out.
GUID | [read/write] GUID
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDeleted | [read] True if the project has been deleted from the server; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsForceCheckinReasonRequired | [read/write] true if a comment must be included with file check in operations.
IsMailUsed | [read] true if email is used in this project.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsProcessItemRequired | [read/write]
IsRefreshRequired | [read] true if project properties may be out of date.
IsRefreshViewsRequired | [read] true if a refresh is required; false otherwise.
IsRequireLockForCheckin | [read/write] true if files must be locked before they are checked in.
KeywordExpansionFileExtensions | [read/write] the list of file extensions for keyword expansion
MarkUnlockedWorkingFilesReadOnly | [read/write] boolean true if unlocked working files should be marked read only
MergeHistoryDuringVCMSession | [read/write] true if History Merges during VCM Sessions are required.
MethodologyValue | [read/write] The project methodology (Agile, Kanban, Waterfall, Migration).
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of this project.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer | [read] null.
PresentationID | [read] the unique integer identifier for this project.
ProcessItemTypes | [read] the set of (stock or custom) Item Types that may be used as process items
Properties | [read] the PropertyCollection for the Project type
Rights | [read/write] the access control list for this project or NULL.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
StatusValue | [read/write] The status (Active, Parked, etc.) of this Project.
Views | [read] The project's view list.

See Also

Project Class | StarTeam Namespace


AccessibleViews Property

Borland StarTeam SDK for .NET

Project.AccessibleViews Property

[read] The set of Views accessible from this Project. May be empty (but is never null).

public virtual View[] AccessibleViews {get;}

Property Value

The set of Views accessible from this Project. May be empty (but is never null).

See Also

Project Class | StarTeam Namespace


CheckinChangePackageLastUpdate Property

Borland StarTeam SDK for .NET

Project.CheckinChangePackageLastUpdate Property

[read] the last time the checkin change package property was modified

public virtual DateTime CheckinChangePackageLastUpdate {get;}

Property Value

the last time the checkin change package property was modified

See Also

Project Class | StarTeam Namespace


CreateCheckinChangePackage Property

Borland StarTeam SDK for .NET

Project.CreateCheckinChangePackage Property

[read/write] true if checkin change packages should be created by the SDK

public virtual Boolean CreateCheckinChangePackage {get; set;}

Property Value

true if checkin change packages should be created by the SDK

See Also

Project Class | StarTeam Namespace


DefaultItemTypes Property

Borland StarTeam SDK for .NET

Project.DefaultItemTypes Property

[read/write] TypeCollection the set of item types that will be shared upon creation of a variant view.

public virtual TypeCollection DefaultItemTypes {get; set;}

Property Value

TypeCollection the set of item types that will be shared upon creation of a variant view.

See Also

Project Class | StarTeam Namespace


DefaultView Property

Borland StarTeam SDK for .NET

Project.DefaultView Property

[read] The default View for this Project.

public virtual View DefaultView {get;}

Property Value

The default View for this Project.

See Also

Project Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Project.Description Property

[read/write] the description of this project.

public virtual String Description {get; set;}

Property Value

the description of this project.

See Also

Project Class | StarTeam Namespace


EncryptionAlgorithm Property

Borland StarTeam SDK for .NET

Project.EncryptionAlgorithm Property

[read/write] encryption algorithm used for this project

public virtual Server.EncryptionAlgorithm EncryptionAlgorithm {get; set;}

Property Value

encryption algorithm used for this project

See Also

Project Class | StarTeam Namespace


ExpandKeywords Property

Borland StarTeam SDK for .NET

Project.ExpandKeywords Property

[read/write] true if keywords are expanded when files are checked out.

public virtual Boolean ExpandKeywords {get; set;}

Property Value

true if keywords are expanded when files are checked out.

See Also

Project Class | StarTeam Namespace


GUID Property

Borland StarTeam SDK for .NET

Project.GUID Property

[read/write] GUID

public virtual String GUID {get; set;}

Property Value

GUID

See Also

Project Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Project.IsDeleted Property

[read] True if the project has been deleted from the server; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if the project has been deleted from the server; false otherwise.

Implements

ISecurableContainer.IsDeleted

See Also

Project Class | StarTeam Namespace


IsForceCheckinReasonRequired Property

Borland StarTeam SDK for .NET

Project.IsForceCheckinReasonRequired Property

[read/write] true if a comment must be included with file check in operations.

public virtual Boolean IsForceCheckinReasonRequired {get; set;}

Property Value

true if a comment must be included with file check in operations.

See Also

Project Class | StarTeam Namespace


IsMailUsed Property

Borland StarTeam SDK for .NET

Project.IsMailUsed Property

[read] true if email is used in this project.

public virtual Boolean IsMailUsed {get;}

Property Value

true if email is used in this project.

See Also

Project Class | StarTeam Namespace


IsProcessItemRequired Property

Borland StarTeam SDK for .NET

Project.IsProcessItemRequired Property

[read/write]

public virtual Boolean IsProcessItemRequired {get; set;}

See Also

Project Class | StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

Project.IsRefreshRequired Property

[read] true if project properties may be out of date.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if project properties may be out of date.

See Also

Project Class | StarTeam Namespace


IsRefreshViewsRequired Property

Borland StarTeam SDK for .NET

Project.IsRefreshViewsRequired Property

[read] true if a refresh is required; false otherwise.

public virtual Boolean IsRefreshViewsRequired {get;}

Property Value

true if a refresh is required; false otherwise.

See Also

Project Class | StarTeam Namespace


IsRequireLockForCheckin Property

Borland StarTeam SDK for .NET

Project.IsRequireLockForCheckin Property

[read/write] true if files must be locked before they are checked in.

public virtual Boolean IsRequireLockForCheckin {get; set;}

Property Value

true if files must be locked before they are checked in.

See Also

Project Class | StarTeam Namespace


KeywordExpansionFileExtensions Property

Borland StarTeam SDK for .NET

Project.KeywordExpansionFileExtensions Property

[read/write] the list of file extensions for keyword expansion

public virtual String KeywordExpansionFileExtensions {get; set;}

Property Value

the list of file extensions for keyword expansion

See Also

Project Class | StarTeam Namespace


MarkUnlockedWorkingFilesReadOnly Property

Borland StarTeam SDK for .NET

Project.MarkUnlockedWorkingFilesReadOnly Property

[read/write] boolean true if unlocked working files should be marked read only

public virtual Boolean MarkUnlockedWorkingFilesReadOnly {get; set;}

Property Value

boolean true if unlocked working files should be marked read only

See Also

Project Class | StarTeam Namespace


MergeHistoryDuringVCMSession Property

Borland StarTeam SDK for .NET

Project.MergeHistoryDuringVCMSession Property

[read/write] true if History Merges during VCM Sessions are required.

public virtual Boolean MergeHistoryDuringVCMSession {get; set;}

Property Value

true if History Merges during VCM Sessions are required.

See Also

Project Class | StarTeam Namespace


MethodologyValue Property

Borland StarTeam SDK for .NET

Project.MethodologyValue Property

[read/write] The project methodology (Agile, Kanban, Waterfall, Migration).

public virtual Project.Methodology MethodologyValue {get; set;}

Property Value

The project methodology (Agile, Kanban, Waterfall, Migration).

See Also

Project Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Project.Name Property

[read/write] the name of this project.

public virtual String Name {get; set;}

Property Value

the name of this project.

See Also

Project Class | StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

Project.ParentContainer Property

[read] null.

public virtual ISecurableContainer ParentContainer {get;}

Property Value

null.

Implements

ISecurableContainer.ParentContainer

See Also

Project Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Project.PresentationID Property

[read] the unique integer identifier for this project.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this project.

See Also

Project Class | StarTeam Namespace


ProcessItemTypes Property

Borland StarTeam SDK for .NET

Project.ProcessItemTypes Property

[read] the set of (stock or custom) Item Types that may be used as process items

public virtual Type[] ProcessItemTypes {get;}

Property Value

the set of (stock or custom) Item Types that may be used as process items

See Also

Project Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Project.Properties Property

[read] the PropertyCollection for the Project type

public virtual Project.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection for the Project type

See Also

Project Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Project.Rights Property

[read/write] the access control list for this project or NULL.

public virtual ACE[] Rights {get; set;}

Property Value

the access control list for this project or NULL.

Implements

ISecurable.Rights

See Also

Project Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Project.StatusValue Property

[read/write] The status (Active, Parked, etc.) of this Project.

public virtual Project.Status StatusValue {get; set;}

Property Value

The status (Active, Parked, etc.) of this Project.

See Also

Project Class | StarTeam Namespace


Views Property

Borland StarTeam SDK for .NET

Project.Views Property

[read] The project's view list.

public virtual View[] Views {get;}

Property Value

The project's view list.

See Also

Project Class | StarTeam Namespace


Project Methods

The methods of the Project class are listed below. For a complete list of Project class members, see the Project Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this Project object, with project properties fully populated. Useful to applications that want to save a snapshot of the Project in a given state, for example, before calling refresh().
Discard | Discards all of the cached properties for this project. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a project are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardViews | Discards the list of cached views. A subsequent call to getViews() will re-fetch the views from the server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindView | Overloaded. Finds a view in the project's view collection.
GetActiveProcessItemStates |
GetAllowedStates | Return the subset of enumerated values that are visible for the specified Enumerated property in the context of this project. Note that Enumerated Properties are (and continue to be) type specific. However, an application can choose to store a subset of the values as applicable (legal) to a given type. This subset may be disjoint or may overlap. The application decides Other than storing the relationships between a project, an enumerated property and its values the SDK makes no attempt to (and in reality cannot) validate the usage of Enumerated Values for item types in the context of a given project An application should make no assumption about the returned order of EnumeratedValues, or for that matter, about parent child hierarchies in a multi-select hierarchy
GetAlternateEditorPath |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetCRStatus |
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFilters | returns the set of filters associated with this project
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetQueries | returns the set of queries associated with this project
GetRights | Returns the Access Control List for items of the specified type for this project. This will return null if this project has no access control list for the specified type.
GetStatus |
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUDAGroupings |
GetValue (inherited from TypedResource) | Gets the value of the specified property.
GetVisibleProperties | Return the subset of properties that are visible in the context of the specified Enumerated Value
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions | Overloaded. Returns true if desired permissions are granted for this project
HasSavedCRStatus |
HasSavedStatus |
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsActiveProcessItemStateEnabled | Determines whether or not a given status value of a given type, is one that can be used for an active process item of that type.
IsEqualTo | Compares the properties of two Projects.
IsProcessItemTypeEnabled |
NewProjectEventSource |
NewViewEventSource |
Populate | Populates project properties, if they have not already been populated.
Refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshAllViews | Targeted for the artifact cache, all view properties for a given project are loaded in bulk, unlike refreshViews()
RefreshViews | Ensures that the latest list of views for this project has been retrieved from the server and cached locally. Also ensures that any previously cached view property values are up-to-date. refreshViews() re-uses existing View objects whenever possible, changing cached property values as necessary to bring older Views up-to-date. When MPX is enabled, refreshViews() is optimized to avoid unnecessary server commands.
Remove | Removes the project from the server.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetActiveProcessItemStateEnabled | Defines the specified state as a legal 'Active' state for this project for it's type The set of legal active states is a subset of the set of all open states for the given enumerated property that represents the process item property For 11.0 servers, the types and the status properties are fixed. (Requirement, Task, ChangeRequest) So are their Closed States. Their open states are either all or a restricted but fixed subset of states. Hence, for 11.0 servers, to specify all states as active, specify any state but the restricted ones
SetAllowedState | Set an enumerated value of a given property as an allowed or legal state for this project. Note that Enumerated Properties are (and continue to be) type specific. However, an application can choose to store a subset of the values as applicable (legal) to a given type. Other than storing the relationships between a project, an enumerated property and its values the SDK makes no attempt to (and in reality cannot) validate the usage of Enumerated Values for item types in the context of a given project Note that this api is not supported for pre 12.5 servers
SetAlternateEditorPath |
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetCRStatus |
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights | Modifies the Access Control List for items of the specified type for this project. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStatus |
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetUDAGroupings |
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
SetVisibleProperties | Define a subset of properties of a given type that are marked visible
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Persists this project's properties to its Server. If this project wraps around a foreign archive, Folder hierarchy will be created according to the configuration file and archive path of the foreign archive specified.

See Also

Project Class | StarTeam Namespace


Project.Copy Method

Creates a copy of this Project object, with project properties fully populated. Useful to applications that want to save a snapshot of the Project in a given state, for example, before calling refresh().

public virtual Project Copy();

Return Value

A new copy of this Project object.

See Also

Project Class | StarTeam Namespace | isEqualTo


Project.Discard Method

Discards all of the cached properties for this project. They will be re-fetched from the server on demand (even when MPX is enabled).

If the properties of a project are changed, and discard() is called without first calling update(), the changes will be lost.

public virtual void Discard();

See Also

Project Class | StarTeam Namespace | refresh


Project.DiscardViews Method

Discards the list of cached views. A subsequent call to getViews() will re-fetch the views from the server (even when MPX is enabled).

public virtual void DiscardViews();

See Also

Project Class | StarTeam Namespace | getViews | refreshViews | enableMPX


FindView Method

Borland StarTeam SDK for .NET

Project.FindView Method

Finds a view in the project's view collection.

Overload List

Finds a view in the project's view collection.

public virtual View FindView(Int32);

Finds a view in the project's view collection. View name can either be a simple name or a view hierarchy. Use the colon (:) or slash(/) as a delimiter between view names in a hierarchy. The view hierarchy should always include the root view.

public virtual View FindView(String);

See Also

Project Class | StarTeam Namespace


Project.FindView Method (Int32)

Finds a view in the project's view collection.

public virtual View FindView(
Int32 viewID
);

Parameters

viewID
The view ID of the desired view.

Return Value

The view with the given ID, or null if no such view was found.

See Also

Project Class | StarTeam Namespace | Project.FindView Overload List


Project.FindView Method (String)

Finds a view in the project's view collection. View name can either be a simple name or a view hierarchy. Use the colon (:) or slash(/) as a delimiter between view names in a hierarchy. The view hierarchy should always include the root view.

public virtual View FindView(
String name
);

Parameters

name
The name of the desired view.

Return Value

The view with the given name, or null if no such view was found.

See Also

Project Class | StarTeam Namespace | Project.FindView Overload List


Project.GetActiveProcessItemStates Method

public virtual EnumeratedValue[] GetActiveProcessItemStates(
Item.Type typ
);

See Also

Project Class | StarTeam Namespace


Project.GetAllowedStates Method

Return the subset of enumerated values that are visible for the specified Enumerated property in the context of this project. Note that Enumerated Properties are (and continue to be) type specific. However, an application can choose to store a subset of the values as applicable (legal) to a given type. This subset may be disjoint or may overlap. The application decides Other than storing the relationships between a project, an enumerated property and its values the SDK makes no attempt to (and in reality cannot) validate the usage of Enumerated Values for item types in the context of a given project An application should make no assumption about the returned order of EnumeratedValues, or for that matter, about parent child hierarchies in a multi-select hierarchy

public virtual EnumeratedValue[] GetAllowedStates(
EnumeratedProperty prprty
);

Parameters

prprty
the property whose allowed states are of interest

Return Value

the set of allowed enumerated values (if specified).

See Also

Project Class | StarTeam Namespace | getAllValues


Project.GetAlternateEditorPath Method

public virtual string GetAlternateEditorPath(
Item.Type typ
);

See Also

Project Class | StarTeam Namespace


Project.GetCRStatus Method

public virtual EnumeratedValue GetCRStatus(
Story.Status sts
);

See Also

Project Class | StarTeam Namespace


Project.GetFilters Method

returns the set of filters associated with this project

public virtual Filter[] GetFilters(
Type typ
);

Parameters

typ
the type whose filters are desired

Return Value

the set of filters associated with this project

See Also

Project Class | StarTeam Namespace


Project.GetQueries Method

returns the set of queries associated with this project

public virtual Query[] GetQueries(
Type typ
);

Parameters

typ
the type whose queries are desired

Return Value

the set of queries associated with this project

See Also

Project Class | StarTeam Namespace


Project.GetRights Method

Returns the Access Control List for items of the specified type for this project. This will return null if this project has no access control list for the specified type.

public virtual ACE[] GetRights(
Type type
);

Parameters

type
the type being controlled by the returned ACL

Return Value

the access control list for this project or NULL.

Implements

ISecurableContainer.GetRights

See Also

Project Class | StarTeam Namespace | Type


Project.GetStatus Method

public virtual Status[] GetStatus(
Story.Status sts
);

See Also

Project Class | StarTeam Namespace


Project.GetUDAGroupings Method

public virtual EnumeratedValue[] GetUDAGroupings(
Requirement.RequirementType typ
);

See Also

Project Class | StarTeam Namespace


Project.GetVisibleProperties Method

Return the subset of properties that are visible in the context of the specified Enumerated Value

public virtual PropertyCollection GetVisibleProperties(
EnumeratedValue value
);

Parameters

value
an Enumerated Value for a specific Enumerated Property of a chosen type

Return Value

the subset of properties of the same Type that are marked visible in the context of this enum

See Also

Project Class | StarTeam Namespace


HasPermissions Method

Borland StarTeam SDK for .NET

Project.HasPermissions Method

Returns true if desired permissions are granted for this project

Overload List

Returns true if desired permissions are granted for this project

public virtual bool HasPermissions(PermissionCollection);

Returns true if desired permissions are granted for items of the specified type for this project

public virtual bool HasPermissions(PermissionCollection,Type);

See Also

Project Class | StarTeam Namespace | Permission


Project.HasPermissions Method (PermissionCollection)

Returns true if desired permissions are granted for this project

public virtual bool HasPermissions(
PermissionCollection permissions
);

Parameters

permissions
the desired permissions

Implements

ISecurable.HasPermissions

See Also

Project Class | StarTeam Namespace | Project.HasPermissions Overload List | Permission


Project.HasPermissions Method (PermissionCollection, Type)

Returns true if desired permissions are granted for items of the specified type for this project

public virtual bool HasPermissions(
PermissionCollection permissions,
Type type
);

Parameters

permissions
the desired permissions
type
the type for access to be tested on

Implements

ISecurableContainer.HasPermissions

See Also

Project Class | StarTeam Namespace | Project.HasPermissions Overload List | Permission | Type


Project.HasSavedCRStatus Method

public virtual bool HasSavedCRStatus(
Story.Status sts
);

See Also

Project Class | StarTeam Namespace


Project.HasSavedStatus Method

public virtual bool HasSavedStatus(
Story.Status sts
);

See Also

Project Class | StarTeam Namespace


Project.IsActiveProcessItemStateEnabled Method

Determines whether or not a given status value of a given type, is one that can be used for an active process item of that type.

public virtual bool IsActiveProcessItemStateEnabled(
EnumeratedValue value
);

Parameters

value
The status value to be tested.

Return Value

true if the given status value is legal for an active process item, of a given type and false otherwise.

See Also

Project Class | StarTeam Namespace


Project.IsEqualTo Method

Compares the properties of two Projects.

public virtual bool IsEqualTo(
Project project
);

Parameters

project
The project to be compared to this one.

Return Value

true if no differences were found.

See Also

Project Class | StarTeam Namespace | copy


Project.IsProcessItemTypeEnabled Method

public virtual bool IsProcessItemTypeEnabled(
Item.Type type
);

See Also

Project Class | StarTeam Namespace


Project.NewProjectEventSource Method

public ProjectEventSource NewProjectEventSource();

See Also

Project Class | StarTeam Namespace


Project.NewViewEventSource Method

public ViewEventSource NewViewEventSource();

See Also

Project Class | StarTeam Namespace


Project.Populate Method

Populates project properties, if they have not already been populated.

public virtual void Populate();

See Also

Project Class | StarTeam Namespace | refresh


Project.Refresh Method

Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

Project Class | StarTeam Namespace | isRefreshRequired | populate | enableMPX


Project.RefreshAllViews Method

Targeted for the artifact cache, all view properties for a given project are loaded in bulk, unlike refreshViews()

public virtual void RefreshAllViews();

See Also

Project Class | StarTeam Namespace


Project.RefreshViews Method

Ensures that the latest list of views for this project has been retrieved from the server and cached locally. Also ensures that any previously cached view property values are up-to-date. refreshViews() re-uses existing View objects whenever possible, changing cached property values as necessary to bring older Views up-to-date. When MPX is enabled, refreshViews() is optimized to avoid unnecessary server commands.

public virtual void RefreshViews();

See Also

Project Class | StarTeam Namespace | getViews | isRefreshViewsRequired | discardViews | enableMPX


Project.Remove Method

Removes the project from the server.

public virtual void Remove();

See Also

Project Class | StarTeam Namespace


Project.SetActiveProcessItemStateEnabled Method

Defines the specified state as a legal 'Active' state for this project for it's type The set of legal active states is a subset of the set of all open states for the given enumerated property that represents the process item property For 11.0 servers, the types and the status properties are fixed. (Requirement, Task, ChangeRequest) So are their Closed States. Their open states are either all or a restricted but fixed subset of states. Hence, for 11.0 servers, to specify all states as active, specify any state but the restricted ones

public virtual void SetActiveProcessItemStateEnabled(
EnumeratedValue activeState,
Boolean enabled
);

Parameters

activeState
a supported active state for the enumerated property
enabled
true to enable the state

See Also

Project Class | StarTeam Namespace


Project.SetAllowedState Method

Set an enumerated value of a given property as an allowed or legal state for this project. Note that Enumerated Properties are (and continue to be) type specific. However, an application can choose to store a subset of the values as applicable (legal) to a given type. Other than storing the relationships between a project, an enumerated property and its values the SDK makes no attempt to (and in reality cannot) validate the usage of Enumerated Values for item types in the context of a given project Note that this api is not supported for pre 12.5 servers

public virtual void SetAllowedState(
EnumeratedValue value,
Boolean isAllowed
);

Parameters

value
the selected value
isAllowed
true to turn this state on, false to turn it off

See Also

Project Class | StarTeam Namespace


Project.SetAlternateEditorPath Method

public virtual void SetAlternateEditorPath(
Item.Type typ,
String alternatePath
);

See Also

Project Class | StarTeam Namespace


Project.SetCRStatus Method

public virtual void SetCRStatus(
Story.Status rfrnc,
EnumeratedValue trgt
);

See Also

Project Class | StarTeam Namespace


Project.SetRights Method

Modifies the Access Control List for items of the specified type for this project. If the ACL is null then the access control list for items of the specified type will be dropped.

public virtual void SetRights(
Type type,
ACE[] acl
);

Parameters

type
the type being controlled by the returned ACL
acl
the access control list for this project

Implements

ISecurableContainer.SetRights

See Also

Project Class | StarTeam Namespace | Type


Project.SetStatus Method

public virtual void SetStatus(
Story.Status rfrnc,
Status[] mppdSts
);

See Also

Project Class | StarTeam Namespace


Project.SetUDAGroupings Method

public virtual void SetUDAGroupings(
Requirement.RequirementType typ,
EnumeratedValue[] udas
);

See Also

Project Class | StarTeam Namespace


Project.SetVisibleProperties Method

Define a subset of properties of a given type that are marked visible

public virtual void SetVisibleProperties(
EnumeratedValue value,
PropertyCollection properties
);

Parameters

value
an Enumerated Value for a specific Enumerated Property of a chosen type
properties
the set of properties marked visible in the context of the specified enum

See Also

Project Class | StarTeam Namespace


Project.Update Method

Persists this project's properties to its Server. If this project wraps around a foreign archive, Folder hierarchy will be created according to the configuration file and archive path of the foreign archive specified.

public virtual void Update();

See Also

Project Class | StarTeam Namespace


Project.Methodology Class

Defines the development methodology property of the Project. This property is new to 12.5+ servers

For a list of all members of this type, see Project.Methodology Members.

System.Object
EnumeratedValue
Project.Methodology

public class Project.Methodology : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Methodology Members | StarTeam Namespace


Project.Methodology Members

Project.Methodology overview

Public Static Properties

AGILE
ALL
KANBAN
MIGRATION
WATERFALL

Public Static Methods

FromID | returns a methodology object corresponding to the given integer ID
FromValue | Gets the development methodology value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Methodology value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Project.Methodology.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Methodology.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Project.Methodology.

See Also

Project.Methodology Class | StarTeam Namespace


Project.Methodology Properties

The properties of the Project.Methodology class are listed below. For a complete list of Project.Methodology class members, see the Project.Methodology Members topic.

Public Static Properties

AGILE
ALL
KANBAN
MIGRATION
WATERFALL

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Methodology value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Project.Methodology Class | StarTeam Namespace


AGILE Property

Borland StarTeam SDK for .NET

Project.Methodology.AGILE Property

public static Project.Methodology AGILE {get;}

Property Value

Defines the agile development methodology for the project.

See Also

Project.Methodology Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Project.Methodology.ALL Property

public static Methodology[] ALL {get;}

See Also

Project.Methodology Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Project.Methodology.ID Property

[read] The ID of this Methodology value.

public virtual Int32 ID {get;}

Property Value

The ID of this Methodology value.

See Also

Project.Methodology Class | StarTeam Namespace


KANBAN Property

Borland StarTeam SDK for .NET

Project.Methodology.KANBAN Property

public static Project.Methodology KANBAN {get;}

Property Value

Defines the kanban development methodology for the project.

See Also

Project.Methodology Class | StarTeam Namespace


MIGRATION Property

Borland StarTeam SDK for .NET

Project.Methodology.MIGRATION Property

public static Project.Methodology MIGRATION {get;}

Property Value

Defines the migration development methodology for the project.

See Also

Project.Methodology Class | StarTeam Namespace


WATERFALL Property

Borland StarTeam SDK for .NET

Project.Methodology.WATERFALL Property

public static Project.Methodology WATERFALL {get;}

Property Value

Defines the waterfall development methodology for the project.

See Also

Project.Methodology Class | StarTeam Namespace


Project.Methodology Methods

The methods of the Project.Methodology class are listed below. For a complete list of Project.Methodology class members, see the Project.Methodology Members topic.

Public Static Methods

FromID | returns a methodology object corresponding to the given integer ID
FromValue | Gets the development methodology value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Project.Methodology.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Methodology.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Project.Methodology.

See Also

Project.Methodology Class | StarTeam Namespace


Project.Methodology.Equals Method

Delegate Equals() to com.starteam.Project.Methodology.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Methodology.Equals(obj).

See Also

Project.Methodology Class | StarTeam Namespace


Project.Methodology.FromID Method

returns a methodology object corresponding to the given integer ID

public static Methodology FromID(
Int32 id
);

Parameters

id
the id of the Methodology to look for

Return Value

the equivalent Status

See Also

Project.Methodology Class | StarTeam Namespace


Project.Methodology.FromValue Method

Gets the development methodology value corresponding to the given EnumeratedValue.

public static Methodology FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a Methodology.

Return Value

The corresponding Methodology value, or null.

See Also

Project.Methodology Class | StarTeam Namespace


Project.Methodology.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Methodology.

public override int GetHashCode();

Return Value

com.starteam.Project.Methodology.GetHashCode().

See Also

Project.Methodology Class | StarTeam Namespace


Project.Methodology.ToString Method

Delegate ToString() to com.starteam.Project.Methodology.

public override string ToString();

Return Value

com.starteam.Project.Methodology.ToString()

See Also

Project.Methodology Class | StarTeam Namespace


Project.ScmSubRepository Interface

For a list of all members of this type, see Project.ScmSubRepository Members.

public interface Project.ScmSubRepository

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.ScmSubRepository Members | StarTeam Namespace


Project.ScmSubRepository Members

Project.ScmSubRepository overview

Public Instance Properties

Branches
Id
Name

See Also

Project.ScmSubRepository Interface | StarTeam Namespace


Project.ScmSubRepository Properties

The properties of the Project.ScmSubRepository interface are listed below. For a complete list of Project.ScmSubRepository interface members, see the Project.ScmSubRepository Members topic.

Public Instance Properties

Branches
Id
Name

See Also

Project.ScmSubRepository Interface | StarTeam Namespace


Branches Property

Borland StarTeam SDK for .NET

Project.ScmSubRepository.Branches Property

ScmBranch[] Branches {get;}

See Also

Project.ScmSubRepository Interface | StarTeam Namespace


Id Property

Borland StarTeam SDK for .NET

Project.ScmSubRepository.Id Property

String Id {get;}

See Also

Project.ScmSubRepository Interface | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Project.ScmSubRepository.Name Property

String Name {get;}

See Also

Project.ScmSubRepository Interface | StarTeam Namespace


Project.Status Class

Defines the status of a Project This property is new to 12.0+ servers

For a list of all members of this type, see Project.Status Members.

System.Object
EnumeratedValue
Project.Status

public class Project.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Status Members | StarTeam Namespace


Project.Status Members

Project.Status overview

Public Static Properties

ACTIVE
ALL
PARKED

Public Static Methods

FromID | returns a Status from an integer ID
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Project.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Project.Status.

See Also

Project.Status Class | StarTeam Namespace


Project.Status Properties

The properties of the Project.Status class are listed below. For a complete list of Project.Status class members, see the Project.Status Members topic.

Public Static Properties

ACTIVE
ALL
PARKED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Project.Status Class | StarTeam Namespace


ACTIVE Property

Borland StarTeam SDK for .NET

Project.Status.ACTIVE Property

public static Project.Status ACTIVE {get;}

Property Value

Defines an active project

See Also

Project.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Project.Status.ALL Property

public static Status[] ALL {get;}

See Also

Project.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Project.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

Project.Status Class | StarTeam Namespace


PARKED Property

Borland StarTeam SDK for .NET

Project.Status.PARKED Property

public static Project.Status PARKED {get;}

Property Value

Defines a parked (inactive) project

See Also

Project.Status Class | StarTeam Namespace


Project.Status Methods

The methods of the Project.Status class are listed below. For a complete list of Project.Status class members, see the Project.Status Members topic.

Public Static Methods

FromID | returns a Status from an integer ID
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Project.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Project.Status.

See Also

Project.Status Class | StarTeam Namespace


Project.Status.Equals Method

Delegate Equals() to com.starteam.Project.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Status.Equals(obj).

See Also

Project.Status Class | StarTeam Namespace


Project.Status.FromID Method

returns a Status from an integer ID

public static Status FromID(
Int32 id
);

Parameters

id
the id of the Status to look for

Return Value

the equivalent Status

See Also

Project.Status Class | StarTeam Namespace


Project.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a Status.

Return Value

The corresponding Status value, or null.

See Also

Project.Status Class | StarTeam Namespace


Project.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Status.

public override int GetHashCode();

Return Value

com.starteam.Project.Status.GetHashCode().

See Also

Project.Status Class | StarTeam Namespace


Project.Status.ToString Method

Delegate ToString() to com.starteam.Project.Status.

public override string ToString();

Return Value

com.starteam.Project.Status.ToString()

See Also

Project.Status Class | StarTeam Namespace


Project.Type Class

The Type of the Project

For a list of all members of this type, see Project.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
Project.Type

new public class Project.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type Members | StarTeam Namespace


Project.Type Members

Project.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Project.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Project.Type.

See Also

Project.Type Class | StarTeam Namespace


Project.Type Properties

The properties of the Project.Type class are listed below. For a complete list of Project.Type class members, see the Project.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

Project.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.NAME Property

new public static String NAME {get;}

See Also

Project.Type Class | StarTeam Namespace


Project.Type Methods

The methods of the Project.Type class are listed below. For a complete list of Project.Type class members, see the Project.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Project.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Project.Type.

See Also

Project.Type Class | StarTeam Namespace


Project.Type.Equals Method

Delegate Equals() to com.starteam.Project.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.Equals(obj).

See Also

Project.Type Class | StarTeam Namespace


Project.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.GetHashCode().

See Also

Project.Type Class | StarTeam Namespace


Project.Type.ToString Method

Delegate ToString() to com.starteam.Project.Type.

public override string ToString();

Return Value

com.starteam.Project.Type.ToString()

See Also

Project.Type Class | StarTeam Namespace


Project.Type.CanCreateCheckinChangePackageProperty Class

For a list of all members of this type, see Project.Type.CanCreateCheckinChangePackageProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Project.Type.CanCreateCheckinChangePackageProperty

public class Project.Type.CanCreateCheckinChangePackageProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.CanCreateCheckinChangePackageProperty Members | StarTeam Namespace


Project.Type.CanCreateCheckinChangePackageProperty Members

Project.Type.CanCreateCheckinChangePackageProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.CanCreateCheckinChangePackageProperty Class | StarTeam Namespace


Project.Type.CanCreateCheckinChangePackageProperty Properties

The properties of the Project.Type.CanCreateCheckinChangePackageProperty class are listed below. For a complete list of Project.Type.CanCreateCheckinChangePackageProperty class members, see the Project.Type.CanCreateCheckinChangePackageProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Project.Type.CanCreateCheckinChangePackageProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.CanCreateCheckinChangePackageProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.CanCreateCheckinChangePackageProperty Class | StarTeam Namespace


Project.Type.CanCreateCheckinChangePackageProperty Methods

The methods of the Project.Type.CanCreateCheckinChangePackageProperty class are listed below. For a complete list of Project.Type.CanCreateCheckinChangePackageProperty class members, see the Project.Type.CanCreateCheckinChangePackageProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.CanCreateCheckinChangePackageProperty Class | StarTeam Namespace


Project.Type.CanCreateCheckinChangePackageProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.Equals(obj).

See Also

Project.Type.CanCreateCheckinChangePackageProperty Class | StarTeam Namespace


Project.Type.CanCreateCheckinChangePackageProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.GetHashCode().

See Also

Project.Type.CanCreateCheckinChangePackageProperty Class | StarTeam Namespace


Project.Type.CanCreateCheckinChangePackageProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.CanCreateCheckinChangePackageProperty.ToString()

See Also

Project.Type.CanCreateCheckinChangePackageProperty Class | StarTeam Namespace


Project.Type.CheckinChangePackageLastUpdateProperty Class

The property type of the Checkin Change Package Last Update property

For a list of all members of this type, see Project.Type.CheckinChangePackageLastUpdateProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Project.Type.CheckinChangePackageLastUpdateProperty

public class Project.Type.CheckinChangePackageLastUpdateProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.CheckinChangePackageLastUpdateProperty Members | StarTeam Namespace


Project.Type.CheckinChangePackageLastUpdateProperty Members

Project.Type.CheckinChangePackageLastUpdateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.CheckinChangePackageLastUpdateProperty Class | StarTeam Namespace


Project.Type.CheckinChangePackageLastUpdateProperty Properties

The properties of the Project.Type.CheckinChangePackageLastUpdateProperty class are listed below. For a complete list of Project.Type.CheckinChangePackageLastUpdateProperty class members, see the Project.Type.CheckinChangePackageLastUpdateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Project.Type.CheckinChangePackageLastUpdateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.CheckinChangePackageLastUpdateProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.CheckinChangePackageLastUpdateProperty Class | StarTeam Namespace


Project.Type.CheckinChangePackageLastUpdateProperty Methods

The methods of the Project.Type.CheckinChangePackageLastUpdateProperty class are listed below. For a complete list of Project.Type.CheckinChangePackageLastUpdateProperty class members, see the Project.Type.CheckinChangePackageLastUpdateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.CheckinChangePackageLastUpdateProperty Class | StarTeam Namespace


Project.Type.CheckinChangePackageLastUpdateProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.Equals(obj).

See Also

Project.Type.CheckinChangePackageLastUpdateProperty Class | StarTeam Namespace


Project.Type.CheckinChangePackageLastUpdateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.GetHashCode().

See Also

Project.Type.CheckinChangePackageLastUpdateProperty Class | StarTeam Namespace


Project.Type.CheckinChangePackageLastUpdateProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.CheckinChangePackageLastUpdateProperty.ToString()

See Also

Project.Type.CheckinChangePackageLastUpdateProperty Class | StarTeam Namespace


Project.Type.CompactionProperty Class

The property type of the Compaction property.

For a list of all members of this type, see Project.Type.CompactionProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Project.Type.CompactionProperty

public class Project.Type.CompactionProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.CompactionProperty Members | StarTeam Namespace


Project.Type.CompactionProperty Members

Project.Type.CompactionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.CompactionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.CompactionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.CompactionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.CompactionProperty Class | StarTeam Namespace


Project.Type.CompactionProperty Properties

The properties of the Project.Type.CompactionProperty class are listed below. For a complete list of Project.Type.CompactionProperty class members, see the Project.Type.CompactionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Project.Type.CompactionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.CompactionProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.CompactionProperty Class | StarTeam Namespace


Project.Type.CompactionProperty Methods

The methods of the Project.Type.CompactionProperty class are listed below. For a complete list of Project.Type.CompactionProperty class members, see the Project.Type.CompactionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.CompactionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.CompactionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.CompactionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.CompactionProperty Class | StarTeam Namespace


Project.Type.CompactionProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.CompactionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.CompactionProperty.Equals(obj).

See Also

Project.Type.CompactionProperty Class | StarTeam Namespace


Project.Type.CompactionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.CompactionProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.CompactionProperty.GetHashCode().

See Also

Project.Type.CompactionProperty Class | StarTeam Namespace


Project.Type.CompactionProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.CompactionProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.CompactionProperty.ToString()

See Also

Project.Type.CompactionProperty Class | StarTeam Namespace


Project.Type.DefaultTypesProperty Class

The property type of the Default Types property.

For a list of all members of this type, see Project.Type.DefaultTypesProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Project.Type.DefaultTypesProperty

public class Project.Type.DefaultTypesProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.DefaultTypesProperty Members | StarTeam Namespace


Project.Type.DefaultTypesProperty Members

Project.Type.DefaultTypesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.DefaultTypesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.DefaultTypesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.DefaultTypesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.DefaultTypesProperty Class | StarTeam Namespace


Project.Type.DefaultTypesProperty Properties

The properties of the Project.Type.DefaultTypesProperty class are listed below. For a complete list of Project.Type.DefaultTypesProperty class members, see the Project.Type.DefaultTypesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Project.Type.DefaultTypesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.DefaultTypesProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.DefaultTypesProperty Class | StarTeam Namespace


Project.Type.DefaultTypesProperty Methods

The methods of the Project.Type.DefaultTypesProperty class are listed below. For a complete list of Project.Type.DefaultTypesProperty class members, see the Project.Type.DefaultTypesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.DefaultTypesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.DefaultTypesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.DefaultTypesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.DefaultTypesProperty Class | StarTeam Namespace


Project.Type.DefaultTypesProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.DefaultTypesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.DefaultTypesProperty.Equals(obj).

See Also

Project.Type.DefaultTypesProperty Class | StarTeam Namespace


Project.Type.DefaultTypesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.DefaultTypesProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.DefaultTypesProperty.GetHashCode().

See Also

Project.Type.DefaultTypesProperty Class | StarTeam Namespace


Project.Type.DefaultTypesProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.DefaultTypesProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.DefaultTypesProperty.ToString()

See Also

Project.Type.DefaultTypesProperty Class | StarTeam Namespace


Project.Type.DefaultViewProperty Class

The property type of the DefaultView property.

For a list of all members of this type, see Project.Type.DefaultViewProperty Members.

System.Object
Property
ObjectProperty
Project.Type.DefaultViewProperty

public class Project.Type.DefaultViewProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.DefaultViewProperty Members | StarTeam Namespace


Project.Type.DefaultViewProperty Members

Project.Type.DefaultViewProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.DefaultViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.DefaultViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.DefaultViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.DefaultViewProperty Class | StarTeam Namespace


Project.Type.DefaultViewProperty Properties

The properties of the Project.Type.DefaultViewProperty class are listed below. For a complete list of Project.Type.DefaultViewProperty class members, see the Project.Type.DefaultViewProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Project.Type.DefaultViewProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.DefaultViewProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.DefaultViewProperty Class | StarTeam Namespace


Project.Type.DefaultViewProperty Methods

The methods of the Project.Type.DefaultViewProperty class are listed below. For a complete list of Project.Type.DefaultViewProperty class members, see the Project.Type.DefaultViewProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.DefaultViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.DefaultViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.DefaultViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.DefaultViewProperty Class | StarTeam Namespace


Project.Type.DefaultViewProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.DefaultViewProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.DefaultViewProperty.Equals(obj).

See Also

Project.Type.DefaultViewProperty Class | StarTeam Namespace


Project.Type.DefaultViewProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.DefaultViewProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.DefaultViewProperty.GetHashCode().

See Also

Project.Type.DefaultViewProperty Class | StarTeam Namespace


Project.Type.DefaultViewProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.DefaultViewProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.DefaultViewProperty.ToString()

See Also

Project.Type.DefaultViewProperty Class | StarTeam Namespace


Project.Type.EncryptionAlgorithmProperty Class

The property type of the Encryption Algorithm property.

For a list of all members of this type, see Project.Type.EncryptionAlgorithmProperty Members.

System.Object
Property
EnumeratedProperty
Project.Type.EncryptionAlgorithmProperty

public class Project.Type.EncryptionAlgorithmProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.EncryptionAlgorithmProperty Members | StarTeam Namespace


Project.Type.EncryptionAlgorithmProperty Members

Project.Type.EncryptionAlgorithmProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.EncryptionAlgorithmProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.EncryptionAlgorithmProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.EncryptionAlgorithmProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.EncryptionAlgorithmProperty Class | StarTeam Namespace


Project.Type.EncryptionAlgorithmProperty Properties

The properties of the Project.Type.EncryptionAlgorithmProperty class are listed below. For a complete list of Project.Type.EncryptionAlgorithmProperty class members, see the Project.Type.EncryptionAlgorithmProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Project.Type.EncryptionAlgorithmProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.EncryptionAlgorithmProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.EncryptionAlgorithmProperty Class | StarTeam Namespace


Project.Type.EncryptionAlgorithmProperty Methods

The methods of the Project.Type.EncryptionAlgorithmProperty class are listed below. For a complete list of Project.Type.EncryptionAlgorithmProperty class members, see the Project.Type.EncryptionAlgorithmProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.EncryptionAlgorithmProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.EncryptionAlgorithmProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.EncryptionAlgorithmProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.EncryptionAlgorithmProperty Class | StarTeam Namespace


Project.Type.EncryptionAlgorithmProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.EncryptionAlgorithmProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.EncryptionAlgorithmProperty.Equals(obj).

See Also

Project.Type.EncryptionAlgorithmProperty Class | StarTeam Namespace


Project.Type.EncryptionAlgorithmProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Server.EncryptionAlgorithm value
);

See Also

Project.Type.EncryptionAlgorithmProperty Class | StarTeam Namespace


Project.Type.EncryptionAlgorithmProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.EncryptionAlgorithmProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.EncryptionAlgorithmProperty.GetHashCode().

See Also

Project.Type.EncryptionAlgorithmProperty Class | StarTeam Namespace


Project.Type.EncryptionAlgorithmProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.EncryptionAlgorithmProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.EncryptionAlgorithmProperty.ToString()

See Also

Project.Type.EncryptionAlgorithmProperty Class | StarTeam Namespace


Project.Type.ForceCheckinReasonProperty Class

The property type of the Force Checkin Reason property.

For a list of all members of this type, see Project.Type.ForceCheckinReasonProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Project.Type.ForceCheckinReasonProperty

public class Project.Type.ForceCheckinReasonProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.ForceCheckinReasonProperty Members | StarTeam Namespace


Project.Type.ForceCheckinReasonProperty Members

Project.Type.ForceCheckinReasonProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.ForceCheckinReasonProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.ForceCheckinReasonProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.ForceCheckinReasonProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.ForceCheckinReasonProperty Class | StarTeam Namespace


Project.Type.ForceCheckinReasonProperty Properties

The properties of the Project.Type.ForceCheckinReasonProperty class are listed below. For a complete list of Project.Type.ForceCheckinReasonProperty class members, see the Project.Type.ForceCheckinReasonProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Project.Type.ForceCheckinReasonProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.ForceCheckinReasonProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.ForceCheckinReasonProperty Class | StarTeam Namespace


Project.Type.ForceCheckinReasonProperty Methods

The methods of the Project.Type.ForceCheckinReasonProperty class are listed below. For a complete list of Project.Type.ForceCheckinReasonProperty class members, see the Project.Type.ForceCheckinReasonProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.ForceCheckinReasonProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.ForceCheckinReasonProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.ForceCheckinReasonProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.ForceCheckinReasonProperty Class | StarTeam Namespace


Project.Type.ForceCheckinReasonProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.ForceCheckinReasonProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.ForceCheckinReasonProperty.Equals(obj).

See Also

Project.Type.ForceCheckinReasonProperty Class | StarTeam Namespace


Project.Type.ForceCheckinReasonProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.ForceCheckinReasonProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.ForceCheckinReasonProperty.GetHashCode().

See Also

Project.Type.ForceCheckinReasonProperty Class | StarTeam Namespace


Project.Type.ForceCheckinReasonProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.ForceCheckinReasonProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.ForceCheckinReasonProperty.ToString()

See Also

Project.Type.ForceCheckinReasonProperty Class | StarTeam Namespace


Project.Type.GUIDProperty Class

The property type of the GUID property.

For a list of all members of this type, see Project.Type.GUIDProperty Members.

System.Object
Property
VectorProperty
TextProperty
Project.Type.GUIDProperty

public class Project.Type.GUIDProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.GUIDProperty Members | StarTeam Namespace


Project.Type.GUIDProperty Members

Project.Type.GUIDProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.GUIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.GUIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.GUIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.GUIDProperty Class | StarTeam Namespace


Project.Type.GUIDProperty Properties

The properties of the Project.Type.GUIDProperty class are listed below. For a complete list of Project.Type.GUIDProperty class members, see the Project.Type.GUIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Project.Type.GUIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.GUIDProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.GUIDProperty Class | StarTeam Namespace


Project.Type.GUIDProperty Methods

The methods of the Project.Type.GUIDProperty class are listed below. For a complete list of Project.Type.GUIDProperty class members, see the Project.Type.GUIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.GUIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.GUIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.GUIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.GUIDProperty Class | StarTeam Namespace


Project.Type.GUIDProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.GUIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.GUIDProperty.Equals(obj).

See Also

Project.Type.GUIDProperty Class | StarTeam Namespace


Project.Type.GUIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.GUIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.GUIDProperty.GetHashCode().

See Also

Project.Type.GUIDProperty Class | StarTeam Namespace


Project.Type.GUIDProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.GUIDProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.GUIDProperty.ToString()

See Also

Project.Type.GUIDProperty Class | StarTeam Namespace


Project.Type.IsProcessItemRequiredProperty Class

The property type of the Is ProcessItem Required property.

For a list of all members of this type, see Project.Type.IsProcessItemRequiredProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Project.Type.IsProcessItemRequiredProperty

public class Project.Type.IsProcessItemRequiredProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.IsProcessItemRequiredProperty Members | StarTeam Namespace


Project.Type.IsProcessItemRequiredProperty Members

Project.Type.IsProcessItemRequiredProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.IsProcessItemRequiredProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.IsProcessItemRequiredProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.IsProcessItemRequiredProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.IsProcessItemRequiredProperty Class | StarTeam Namespace


Project.Type.IsProcessItemRequiredProperty Properties

The properties of the Project.Type.IsProcessItemRequiredProperty class are listed below. For a complete list of Project.Type.IsProcessItemRequiredProperty class members, see the Project.Type.IsProcessItemRequiredProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Project.Type.IsProcessItemRequiredProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.IsProcessItemRequiredProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.IsProcessItemRequiredProperty Class | StarTeam Namespace


Project.Type.IsProcessItemRequiredProperty Methods

The methods of the Project.Type.IsProcessItemRequiredProperty class are listed below. For a complete list of Project.Type.IsProcessItemRequiredProperty class members, see the Project.Type.IsProcessItemRequiredProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.IsProcessItemRequiredProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.IsProcessItemRequiredProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.IsProcessItemRequiredProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.IsProcessItemRequiredProperty Class | StarTeam Namespace


Project.Type.IsProcessItemRequiredProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.IsProcessItemRequiredProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.IsProcessItemRequiredProperty.Equals(obj).

See Also

Project.Type.IsProcessItemRequiredProperty Class | StarTeam Namespace


Project.Type.IsProcessItemRequiredProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.IsProcessItemRequiredProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.IsProcessItemRequiredProperty.GetHashCode().

See Also

Project.Type.IsProcessItemRequiredProperty Class | StarTeam Namespace


Project.Type.IsProcessItemRequiredProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.IsProcessItemRequiredProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.IsProcessItemRequiredProperty.ToString()

See Also

Project.Type.IsProcessItemRequiredProperty Class | StarTeam Namespace


Project.Type.KeywordFileExtensionsProperty Class

The property type of the KeywordFile Extensions property.

For a list of all members of this type, see Project.Type.KeywordFileExtensionsProperty Members.

System.Object
Property
VectorProperty
TextProperty
Project.Type.KeywordFileExtensionsProperty

public class Project.Type.KeywordFileExtensionsProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.KeywordFileExtensionsProperty Members | StarTeam Namespace


Project.Type.KeywordFileExtensionsProperty Members

Project.Type.KeywordFileExtensionsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.KeywordFileExtensionsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.KeywordFileExtensionsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.KeywordFileExtensionsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.KeywordFileExtensionsProperty Class | StarTeam Namespace


Project.Type.KeywordFileExtensionsProperty Properties

The properties of the Project.Type.KeywordFileExtensionsProperty class are listed below. For a complete list of Project.Type.KeywordFileExtensionsProperty class members, see the Project.Type.KeywordFileExtensionsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Project.Type.KeywordFileExtensionsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.KeywordFileExtensionsProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.KeywordFileExtensionsProperty Class | StarTeam Namespace


Project.Type.KeywordFileExtensionsProperty Methods

The methods of the Project.Type.KeywordFileExtensionsProperty class are listed below. For a complete list of Project.Type.KeywordFileExtensionsProperty class members, see the Project.Type.KeywordFileExtensionsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.KeywordFileExtensionsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.KeywordFileExtensionsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.KeywordFileExtensionsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.KeywordFileExtensionsProperty Class | StarTeam Namespace


Project.Type.KeywordFileExtensionsProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.KeywordFileExtensionsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.KeywordFileExtensionsProperty.Equals(obj).

See Also

Project.Type.KeywordFileExtensionsProperty Class | StarTeam Namespace


Project.Type.KeywordFileExtensionsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.KeywordFileExtensionsProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.KeywordFileExtensionsProperty.GetHashCode().

See Also

Project.Type.KeywordFileExtensionsProperty Class | StarTeam Namespace


Project.Type.KeywordFileExtensionsProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.KeywordFileExtensionsProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.KeywordFileExtensionsProperty.ToString()

See Also

Project.Type.KeywordFileExtensionsProperty Class | StarTeam Namespace


Project.Type.MailProperty Class

The property type of the Mail property.

For a list of all members of this type, see Project.Type.MailProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Project.Type.MailProperty

public class Project.Type.MailProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.MailProperty Members | StarTeam Namespace


Project.Type.MailProperty Members

Project.Type.MailProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.MailProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.MailProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.MailProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.MailProperty Class | StarTeam Namespace


Project.Type.MailProperty Properties

The properties of the Project.Type.MailProperty class are listed below. For a complete list of Project.Type.MailProperty class members, see the Project.Type.MailProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Project.Type.MailProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.MailProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.MailProperty Class | StarTeam Namespace


Project.Type.MailProperty Methods

The methods of the Project.Type.MailProperty class are listed below. For a complete list of Project.Type.MailProperty class members, see the Project.Type.MailProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.MailProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.MailProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.MailProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.MailProperty Class | StarTeam Namespace


Project.Type.MailProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.MailProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.MailProperty.Equals(obj).

See Also

Project.Type.MailProperty Class | StarTeam Namespace


Project.Type.MailProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.MailProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.MailProperty.GetHashCode().

See Also

Project.Type.MailProperty Class | StarTeam Namespace


Project.Type.MailProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.MailProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.MailProperty.ToString()

See Also

Project.Type.MailProperty Class | StarTeam Namespace


Project.Type.MarkUnlockedFilesReadOnlyProperty Class

The property type of the Mark Unlocked Files ReadOnly property.

For a list of all members of this type, see Project.Type.MarkUnlockedFilesReadOnlyProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Project.Type.MarkUnlockedFilesReadOnlyProperty

public class Project.Type.MarkUnlockedFilesReadOnlyProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.MarkUnlockedFilesReadOnlyProperty Members | StarTeam Namespace


Project.Type.MarkUnlockedFilesReadOnlyProperty Members

Project.Type.MarkUnlockedFilesReadOnlyProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.MarkUnlockedFilesReadOnlyProperty Class | StarTeam Namespace


Project.Type.MarkUnlockedFilesReadOnlyProperty Properties

The properties of the Project.Type.MarkUnlockedFilesReadOnlyProperty class are listed below. For a complete list of Project.Type.MarkUnlockedFilesReadOnlyProperty class members, see the Project.Type.MarkUnlockedFilesReadOnlyProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Project.Type.MarkUnlockedFilesReadOnlyProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.MarkUnlockedFilesReadOnlyProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.MarkUnlockedFilesReadOnlyProperty Class | StarTeam Namespace


Project.Type.MarkUnlockedFilesReadOnlyProperty Methods

The methods of the Project.Type.MarkUnlockedFilesReadOnlyProperty class are listed below. For a complete list of Project.Type.MarkUnlockedFilesReadOnlyProperty class members, see the Project.Type.MarkUnlockedFilesReadOnlyProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.MarkUnlockedFilesReadOnlyProperty Class | StarTeam Namespace


Project.Type.MarkUnlockedFilesReadOnlyProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.Equals(obj).

See Also

Project.Type.MarkUnlockedFilesReadOnlyProperty Class | StarTeam Namespace


Project.Type.MarkUnlockedFilesReadOnlyProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.GetHashCode().

See Also

Project.Type.MarkUnlockedFilesReadOnlyProperty Class | StarTeam Namespace


Project.Type.MarkUnlockedFilesReadOnlyProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.MarkUnlockedFilesReadOnlyProperty.ToString()

See Also

Project.Type.MarkUnlockedFilesReadOnlyProperty Class | StarTeam Namespace


Project.Type.MergeHistoryDuringVCMSessionProperty Class

The property type of the Merge History On Promote property.

For a list of all members of this type, see Project.Type.MergeHistoryDuringVCMSessionProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Project.Type.MergeHistoryDuringVCMSessionProperty

public class Project.Type.MergeHistoryDuringVCMSessionProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.MergeHistoryDuringVCMSessionProperty Members | StarTeam Namespace


Project.Type.MergeHistoryDuringVCMSessionProperty Members

Project.Type.MergeHistoryDuringVCMSessionProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.MergeHistoryDuringVCMSessionProperty Class | StarTeam Namespace


Project.Type.MergeHistoryDuringVCMSessionProperty Properties

The properties of the Project.Type.MergeHistoryDuringVCMSessionProperty class are listed below. For a complete list of Project.Type.MergeHistoryDuringVCMSessionProperty class members, see the Project.Type.MergeHistoryDuringVCMSessionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Project.Type.MergeHistoryDuringVCMSessionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.MergeHistoryDuringVCMSessionProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.MergeHistoryDuringVCMSessionProperty Class | StarTeam Namespace


Project.Type.MergeHistoryDuringVCMSessionProperty Methods

The methods of the Project.Type.MergeHistoryDuringVCMSessionProperty class are listed below. For a complete list of Project.Type.MergeHistoryDuringVCMSessionProperty class members, see the Project.Type.MergeHistoryDuringVCMSessionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.MergeHistoryDuringVCMSessionProperty Class | StarTeam Namespace


Project.Type.MergeHistoryDuringVCMSessionProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.Equals(obj).

See Also

Project.Type.MergeHistoryDuringVCMSessionProperty Class | StarTeam Namespace


Project.Type.MergeHistoryDuringVCMSessionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.GetHashCode().

See Also

Project.Type.MergeHistoryDuringVCMSessionProperty Class | StarTeam Namespace


Project.Type.MergeHistoryDuringVCMSessionProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.MergeHistoryDuringVCMSessionProperty.ToString()

See Also

Project.Type.MergeHistoryDuringVCMSessionProperty Class | StarTeam Namespace


Project.Type.MethodologyProperty Class

The property type of the Methodology property.

For a list of all members of this type, see Project.Type.MethodologyProperty Members.

System.Object
Property
EnumeratedProperty
Project.Type.MethodologyProperty

public class Project.Type.MethodologyProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.MethodologyProperty Members | StarTeam Namespace


Project.Type.MethodologyProperty Members

Project.Type.MethodologyProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.MethodologyProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.MethodologyProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.MethodologyProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.MethodologyProperty Class | StarTeam Namespace


Project.Type.MethodologyProperty Properties

The properties of the Project.Type.MethodologyProperty class are listed below. For a complete list of Project.Type.MethodologyProperty class members, see the Project.Type.MethodologyProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Project.Type.MethodologyProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.MethodologyProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.MethodologyProperty Class | StarTeam Namespace


Project.Type.MethodologyProperty Methods

The methods of the Project.Type.MethodologyProperty class are listed below. For a complete list of Project.Type.MethodologyProperty class members, see the Project.Type.MethodologyProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.MethodologyProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.MethodologyProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.MethodologyProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.MethodologyProperty Class | StarTeam Namespace


Project.Type.MethodologyProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.MethodologyProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.MethodologyProperty.Equals(obj).

See Also

Project.Type.MethodologyProperty Class | StarTeam Namespace


Project.Type.MethodologyProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Project.Methodology value
);

See Also

Project.Type.MethodologyProperty Class | StarTeam Namespace


Project.Type.MethodologyProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.MethodologyProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.MethodologyProperty.GetHashCode().

See Also

Project.Type.MethodologyProperty Class | StarTeam Namespace


Project.Type.MethodologyProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.MethodologyProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.MethodologyProperty.ToString()

See Also

Project.Type.MethodologyProperty Class | StarTeam Namespace


Project.Type.PropertyCollection Class

The PropertyCollection of a Project.

For a list of all members of this type, see Project.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
Project.Type.PropertyCollection

public class Project.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.PropertyCollection Members | StarTeam Namespace


Project.Type.PropertyCollection Members

Project.Type.PropertyCollection overview

Public Instance Properties

CAN_CREATE_CHECKIN_CHANGE_PACKAGE |
CHECKIN_CHANGE_PACKAGE_LAST_UPDATE |
COMPACTION |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_TYPES |
DEFAULT_VIEW |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
ENCRYPTION_ALGORITHM |
FORCE_CHECKIN_REASON |
GLOBAL_ID |
GUID |
ID |
IS_PROCESS_ITEM_REQUIRED |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
KEYWORD_FILE_EXTENSIONS |
MAIL |
MARK_UNLOCKED_FILES_READ_ONLY |
MERGE_HISTORY_DURING_VCM_SESSION |
METHODOLOGY |
NAME |
REQUIRE_LOCK_FOR_CHECKIN |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TENANT |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
USE_KEYWORDS |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Project.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Project.Type.PropertyCollection.

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


Project.Type.PropertyCollection Properties

The properties of the Project.Type.PropertyCollection class are listed below. For a complete list of Project.Type.PropertyCollection class members, see the Project.Type.PropertyCollection Members topic.

Public Instance Properties

CAN_CREATE_CHECKIN_CHANGE_PACKAGE |
CHECKIN_CHANGE_PACKAGE_LAST_UPDATE |
COMPACTION |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_TYPES |
DEFAULT_VIEW |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
ENCRYPTION_ALGORITHM |
FORCE_CHECKIN_REASON |
GLOBAL_ID |
GUID |
ID |
IS_PROCESS_ITEM_REQUIRED |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
KEYWORD_FILE_EXTENSIONS |
MAIL |
MARK_UNLOCKED_FILES_READ_ONLY |
MERGE_HISTORY_DURING_VCM_SESSION |
METHODOLOGY |
NAME |
REQUIRE_LOCK_FOR_CHECKIN |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TENANT |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
USE_KEYWORDS |

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


CAN_CREATE_CHECKIN_CHANGE_PACKAGE Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.CAN_CREATE_CHECKIN_CHANGE_PACKAGE Property

public Project.Type.CanCreateCheckinChangePackageProperty CAN_CREATE_CHECKIN_CHANGE_PACKAGE {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


CHECKIN_CHANGE_PACKAGE_LAST_UPDATE Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.CHECKIN_CHANGE_PACKAGE_LAST_UPDATE Property

public Project.Type.CheckinChangePackageLastUpdateProperty CHECKIN_CHANGE_PACKAGE_LAST_UPDATE {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


COMPACTION Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.COMPACTION Property

public Project.Type.CompactionProperty COMPACTION {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


DEFAULT_TYPES Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.DEFAULT_TYPES Property

public Project.Type.DefaultTypesProperty DEFAULT_TYPES {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


DEFAULT_VIEW Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.DEFAULT_VIEW Property

public Project.Type.DefaultViewProperty DEFAULT_VIEW {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


ENCRYPTION_ALGORITHM Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.ENCRYPTION_ALGORITHM Property

public Project.Type.EncryptionAlgorithmProperty ENCRYPTION_ALGORITHM {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


FORCE_CHECKIN_REASON Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.FORCE_CHECKIN_REASON Property

public Project.Type.ForceCheckinReasonProperty FORCE_CHECKIN_REASON {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


GUID Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.GUID Property

public Project.Type.GUIDProperty GUID {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


IS_PROCESS_ITEM_REQUIRED Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.IS_PROCESS_ITEM_REQUIRED Property

public Project.Type.IsProcessItemRequiredProperty IS_PROCESS_ITEM_REQUIRED {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


KEYWORD_FILE_EXTENSIONS Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.KEYWORD_FILE_EXTENSIONS Property

public Project.Type.KeywordFileExtensionsProperty KEYWORD_FILE_EXTENSIONS {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


MAIL Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.MAIL Property

public Project.Type.MailProperty MAIL {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


MARK_UNLOCKED_FILES_READ_ONLY Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.MARK_UNLOCKED_FILES_READ_ONLY Property

public Project.Type.MarkUnlockedFilesReadOnlyProperty MARK_UNLOCKED_FILES_READ_ONLY {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


MERGE_HISTORY_DURING_VCM_SESSION Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.MERGE_HISTORY_DURING_VCM_SESSION Property

public Project.Type.MergeHistoryDuringVCMSessionProperty MERGE_HISTORY_DURING_VCM_SESSION {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


METHODOLOGY Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.METHODOLOGY Property

public Project.Type.MethodologyProperty METHODOLOGY {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


REQUIRE_LOCK_FOR_CHECKIN Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.REQUIRE_LOCK_FOR_CHECKIN Property

public Project.Type.RequireLockForCheckinProperty REQUIRE_LOCK_FOR_CHECKIN {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.STATUS Property

public Project.Type.StatusProperty STATUS {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


TENANT Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.TENANT Property

public Project.Type.TenantProperty TENANT {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


USE_KEYWORDS Property

Borland StarTeam SDK for .NET

Project.Type.PropertyCollection.USE_KEYWORDS Property

public Project.Type.UseKeywordsProperty USE_KEYWORDS {get;}

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


Project.Type.PropertyCollection Methods

The methods of the Project.Type.PropertyCollection class are listed below. For a complete list of Project.Type.PropertyCollection class members, see the Project.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Project.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Project.Type.PropertyCollection.

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


Project.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Project.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.PropertyCollection.Equals(obj).

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


Project.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.PropertyCollection.GetHashCode().

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


Project.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Project.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Project.Type.PropertyCollection.ToString()

See Also

Project.Type.PropertyCollection Class | StarTeam Namespace


Project.Type.RequireLockForCheckinProperty Class

The property type of the Require Lock for Checkin property.

For a list of all members of this type, see Project.Type.RequireLockForCheckinProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Project.Type.RequireLockForCheckinProperty

public class Project.Type.RequireLockForCheckinProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.RequireLockForCheckinProperty Members | StarTeam Namespace


Project.Type.RequireLockForCheckinProperty Members

Project.Type.RequireLockForCheckinProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.RequireLockForCheckinProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.RequireLockForCheckinProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.RequireLockForCheckinProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.RequireLockForCheckinProperty Class | StarTeam Namespace


Project.Type.RequireLockForCheckinProperty Properties

The properties of the Project.Type.RequireLockForCheckinProperty class are listed below. For a complete list of Project.Type.RequireLockForCheckinProperty class members, see the Project.Type.RequireLockForCheckinProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Project.Type.RequireLockForCheckinProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.RequireLockForCheckinProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.RequireLockForCheckinProperty Class | StarTeam Namespace


Project.Type.RequireLockForCheckinProperty Methods

The methods of the Project.Type.RequireLockForCheckinProperty class are listed below. For a complete list of Project.Type.RequireLockForCheckinProperty class members, see the Project.Type.RequireLockForCheckinProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.RequireLockForCheckinProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.RequireLockForCheckinProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.RequireLockForCheckinProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.RequireLockForCheckinProperty Class | StarTeam Namespace


Project.Type.RequireLockForCheckinProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.RequireLockForCheckinProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.RequireLockForCheckinProperty.Equals(obj).

See Also

Project.Type.RequireLockForCheckinProperty Class | StarTeam Namespace


Project.Type.RequireLockForCheckinProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.RequireLockForCheckinProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.RequireLockForCheckinProperty.GetHashCode().

See Also

Project.Type.RequireLockForCheckinProperty Class | StarTeam Namespace


Project.Type.RequireLockForCheckinProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.RequireLockForCheckinProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.RequireLockForCheckinProperty.ToString()

See Also

Project.Type.RequireLockForCheckinProperty Class | StarTeam Namespace


Project.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see Project.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
Project.Type.StatusProperty

public class Project.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.StatusProperty Members | StarTeam Namespace


Project.Type.StatusProperty Members

Project.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.StatusProperty Class | StarTeam Namespace


Project.Type.StatusProperty Properties

The properties of the Project.Type.StatusProperty class are listed below. For a complete list of Project.Type.StatusProperty class members, see the Project.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Project.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.StatusProperty Class | StarTeam Namespace


Project.Type.StatusProperty Methods

The methods of the Project.Type.StatusProperty class are listed below. For a complete list of Project.Type.StatusProperty class members, see the Project.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.StatusProperty Class | StarTeam Namespace


Project.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.StatusProperty.Equals(obj).

See Also

Project.Type.StatusProperty Class | StarTeam Namespace


Project.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Project.Status value
);

See Also

Project.Type.StatusProperty Class | StarTeam Namespace


Project.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.StatusProperty.GetHashCode().

See Also

Project.Type.StatusProperty Class | StarTeam Namespace


Project.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.StatusProperty.ToString()

See Also

Project.Type.StatusProperty Class | StarTeam Namespace


Project.Type.TenantProperty Class

For a list of all members of this type, see Project.Type.TenantProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Project.Type.TenantProperty

public class Project.Type.TenantProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.TenantProperty Members | StarTeam Namespace


Project.Type.TenantProperty Members

Project.Type.TenantProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.TenantProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.TenantProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.TenantProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.TenantProperty Class | StarTeam Namespace


Project.Type.TenantProperty Properties

The properties of the Project.Type.TenantProperty class are listed below. For a complete list of Project.Type.TenantProperty class members, see the Project.Type.TenantProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Project.Type.TenantProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.TenantProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.TenantProperty Class | StarTeam Namespace


Project.Type.TenantProperty Methods

The methods of the Project.Type.TenantProperty class are listed below. For a complete list of Project.Type.TenantProperty class members, see the Project.Type.TenantProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Project.Type.TenantProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.TenantProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Project.Type.TenantProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.TenantProperty Class | StarTeam Namespace


Project.Type.TenantProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.TenantProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.TenantProperty.Equals(obj).

See Also

Project.Type.TenantProperty Class | StarTeam Namespace


Project.Type.TenantProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.TenantProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.TenantProperty.GetHashCode().

See Also

Project.Type.TenantProperty Class | StarTeam Namespace


Project.Type.TenantProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.TenantProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.TenantProperty.ToString()

See Also

Project.Type.TenantProperty Class | StarTeam Namespace


Project.Type.UseKeywordsProperty Class

The property type of the Use Keywords property.

For a list of all members of this type, see Project.Type.UseKeywordsProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Project.Type.UseKeywordsProperty

public class Project.Type.UseKeywordsProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.Type.UseKeywordsProperty Members | StarTeam Namespace


Project.Type.UseKeywordsProperty Members

Project.Type.UseKeywordsProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.UseKeywordsProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.UseKeywordsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.UseKeywordsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.UseKeywordsProperty Class | StarTeam Namespace


Project.Type.UseKeywordsProperty Properties

The properties of the Project.Type.UseKeywordsProperty class are listed below. For a complete list of Project.Type.UseKeywordsProperty class members, see the Project.Type.UseKeywordsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Project.Type.UseKeywordsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Project.Type.UseKeywordsProperty.NAME Property

public static String NAME {get;}

See Also

Project.Type.UseKeywordsProperty Class | StarTeam Namespace


Project.Type.UseKeywordsProperty Methods

The methods of the Project.Type.UseKeywordsProperty class are listed below. For a complete list of Project.Type.UseKeywordsProperty class members, see the Project.Type.UseKeywordsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Project.Type.UseKeywordsProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Project.Type.UseKeywordsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Project.Type.UseKeywordsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Project.Type.UseKeywordsProperty Class | StarTeam Namespace


Project.Type.UseKeywordsProperty.Equals Method

Delegate Equals() to com.starteam.Project.Type.UseKeywordsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.Type.UseKeywordsProperty.Equals(obj).

See Also

Project.Type.UseKeywordsProperty Class | StarTeam Namespace


Project.Type.UseKeywordsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.Type.UseKeywordsProperty.

public override int GetHashCode();

Return Value

com.starteam.Project.Type.UseKeywordsProperty.GetHashCode().

See Also

Project.Type.UseKeywordsProperty Class | StarTeam Namespace


Project.Type.UseKeywordsProperty.ToString Method

Delegate ToString() to com.starteam.Project.Type.UseKeywordsProperty.

public override string ToString();

Return Value

com.starteam.Project.Type.UseKeywordsProperty.ToString()

See Also

Project.Type.UseKeywordsProperty Class | StarTeam Namespace


Project.WebCacheProject Class

Project accessor for cached SDK projects contained objects are obtained from the artifact cache

For a list of all members of this type, see Project.WebCacheProject Members.

System.Object
LiveObject.WebCacheLiveObject
Project.WebCacheProject

public class Project.WebCacheProject : WebCacheLiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Project.WebCacheProject Members | StarTeam Namespace


Project.WebCacheProject Members

Project.WebCacheProject overview

Public Static Methods

Create

Public Instance Properties

Branches | [read] Accessible branches for this sub repository
CheckinChangePackageLastUpdate | [read] the last time the checkin change package property was modified
Context | [read] the context of this object.
CreateCheckinChangePackage | [read] true if checkin change packages should be created by the SDK
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DefaultView | [read] The default WebCacheView for this WebCacheProject.
Description | [read/write] the description of this project.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ExpandKeywords | [read/write] true if keywords are expanded when files are checked out.
Id | [read] VersionService identifier for the sub repository.
ID | [read] the ID of the underlying object
IsDeleted | [read] True if the project has been deleted from the server; false otherwise.
IsDirty | [read] true if this object is dirty
IsForceCheckinReasonRequired | [read/write] true if a comment must be included with file check in operations.
IsNew | [read] true if this resource has not yet been stored in the server.
IsProcessItemRequired | [read]
IsRequireLockForCheckin | [read/write] true if files must be locked before they are checked in.
KeywordExpansionFileExtensions | [read/write] the list of file extensions for keyword expansion
MergeHistoryDuringVCMSession | [read/write] true if History Merges during VCM Sessions are required.
MethodologyValue | [read/write] The project methodology (Agile, Kanban, Waterfall, Migration).
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PresentationID | [read] the unique integer identifier for this resource.
ProcessItemTypes | [read] the set of (stock or custom) Item Types that may be used as process items
Rights | [read/write] the access rights assigned to this project
Server | [read] the Server for this cached object
StatusValue | [read/write] The status (Active, Parked, etc.) of this Project.
Traces | [read] the set of Traces mapped directly from this project, saved as URLs.
Views | [read] the set of views accessible by this User

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.Project.WebCacheProject.
FindView | Overloaded. return an accessible view on this project or NULL Note that the view will be accessible to the user in this session context and that this view may not have been cached by the ArtifactCache If it is however, the cached view is returned in preference to the unacached one
GetActiveProcessItemStates |
GetAllowedStates |
GetAlternateEditorPath |
GetCRStatus |
GetFilters |
GetGroups | Return the set of Groups that have access rights to this project as defined by the specified permissions
GetHashCode | Delegate GetHashCode() to com.starteam.Project.WebCacheProject.
GetQueries |
GetRights |
GetStatus |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUDAGroupings |
GetValue | Overloaded. get the value of the property as specified by name
GetVisibleProperties | Return the subset of properties that are visible in the context of the specified Enumerated Value
HasSavedCRStatus |
HasSavedStatus |
HasValue |
IsCached | Returns true if the view has been cached in the ArtifactCache and is visible in this user context. Note that views cached in the ArtifactCache need not be visible in the context of a user without the appropriate access rights. In other words, it is possible for this api to return true in the administrator context, but false in an unauthorized user context
IsProcessItemTypeEnabled |
NewWebCacheViewEventSource |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetAllowedState | Set an enumerated value of a given property as an allowed or legal state for this project. Note that Enumerated Properties are (and continue to be) type specific. However, an application can choose to store a subset of the values as applicable (legal) to a given type. Other than storing the relationships between a project, an enumerated property and its values the SDK makes no attempt to (and in reality cannot) validate the usage of Enumerated Values for item types in the context of a given project Note that this api is not supported for pre 12.5 servers
SetAlternateEditorPath |
SetCRStatus |
SetRights |
SetStatus |
SetUDAGroupings |
SetValue | Overloaded. set the value of the property as specified by name
SetVisibleProperties |
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Project.WebCacheProject.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject Properties

The properties of the Project.WebCacheProject class are listed below. For a complete list of Project.WebCacheProject class members, see the Project.WebCacheProject Members topic.

Public Instance Properties

Branches | [read] Accessible branches for this sub repository
CheckinChangePackageLastUpdate | [read] the last time the checkin change package property was modified
Context | [read] the context of this object.
CreateCheckinChangePackage | [read] true if checkin change packages should be created by the SDK
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DefaultView | [read] The default WebCacheView for this WebCacheProject.
Description | [read/write] the description of this project.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ExpandKeywords | [read/write] true if keywords are expanded when files are checked out.
Id | [read] VersionService identifier for the sub repository.
ID | [read] the ID of the underlying object
IsDeleted | [read] True if the project has been deleted from the server; false otherwise.
IsDirty | [read] true if this object is dirty
IsForceCheckinReasonRequired | [read/write] true if a comment must be included with file check in operations.
IsNew | [read] true if this resource has not yet been stored in the server.
IsProcessItemRequired | [read]
IsRequireLockForCheckin | [read/write] true if files must be locked before they are checked in.
KeywordExpansionFileExtensions | [read/write] the list of file extensions for keyword expansion
MergeHistoryDuringVCMSession | [read/write] true if History Merges during VCM Sessions are required.
MethodologyValue | [read/write] The project methodology (Agile, Kanban, Waterfall, Migration).
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PresentationID | [read] the unique integer identifier for this resource.
ProcessItemTypes | [read] the set of (stock or custom) Item Types that may be used as process items
Rights | [read/write] the access rights assigned to this project
Server | [read] the Server for this cached object
StatusValue | [read/write] The status (Active, Parked, etc.) of this Project.
Traces | [read] the set of Traces mapped directly from this project, saved as URLs.
Views | [read] the set of views accessible by this User

See Also

Project.WebCacheProject Class | StarTeam Namespace


Branches Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.Branches Property

[read] Accessible branches for this sub repository

public virtual ScmBranch[] Branches {get;}

Property Value

Accessible branches for this sub repository

See Also

Project.WebCacheProject Class | StarTeam Namespace


CheckinChangePackageLastUpdate Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.CheckinChangePackageLastUpdate Property

[read] the last time the checkin change package property was modified

public virtual DateTime CheckinChangePackageLastUpdate {get;}

Property Value

the last time the checkin change package property was modified

See Also

Project.WebCacheProject Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Project.WebCacheProject Class | StarTeam Namespace


CreateCheckinChangePackage Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.CreateCheckinChangePackage Property

[read] true if checkin change packages should be created by the SDK

public virtual Boolean CreateCheckinChangePackage {get;}

Property Value

true if checkin change packages should be created by the SDK

See Also

Project.WebCacheProject Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Project.WebCacheProject Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Project.WebCacheProject Class | StarTeam Namespace


DefaultView Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.DefaultView Property

[read] The default WebCacheView for this WebCacheProject.

public virtual View.WebCacheView DefaultView {get;}

Property Value

The default WebCacheView for this WebCacheProject.

See Also

Project.WebCacheProject Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.Description Property

[read/write] the description of this project.

public virtual String Description {get; set;}

Property Value

the description of this project.

See Also

Project.WebCacheProject Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Project.WebCacheProject Class | StarTeam Namespace


ExpandKeywords Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.ExpandKeywords Property

[read/write] true if keywords are expanded when files are checked out.

public virtual Boolean ExpandKeywords {get; set;}

Property Value

true if keywords are expanded when files are checked out.

See Also

Project.WebCacheProject Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Project.WebCacheProject Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.IsDeleted Property

[read] True if the project has been deleted from the server; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if the project has been deleted from the server; false otherwise.

See Also

Project.WebCacheProject Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Project.WebCacheProject Class | StarTeam Namespace


IsForceCheckinReasonRequired Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.IsForceCheckinReasonRequired Property

[read/write] true if a comment must be included with file check in operations.

public virtual Boolean IsForceCheckinReasonRequired {get; set;}

Property Value

true if a comment must be included with file check in operations.

See Also

Project.WebCacheProject Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Project.WebCacheProject Class | StarTeam Namespace


IsProcessItemRequired Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.IsProcessItemRequired Property

[read]

public virtual Boolean IsProcessItemRequired {get;}

See Also

Project.WebCacheProject Class | StarTeam Namespace


IsRequireLockForCheckin Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.IsRequireLockForCheckin Property

[read/write] true if files must be locked before they are checked in.

public virtual Boolean IsRequireLockForCheckin {get; set;}

Property Value

true if files must be locked before they are checked in.

See Also

Project.WebCacheProject Class | StarTeam Namespace


KeywordExpansionFileExtensions Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.KeywordExpansionFileExtensions Property

[read/write] the list of file extensions for keyword expansion

public virtual String KeywordExpansionFileExtensions {get; set;}

Property Value

the list of file extensions for keyword expansion

See Also

Project.WebCacheProject Class | StarTeam Namespace


MergeHistoryDuringVCMSession Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.MergeHistoryDuringVCMSession Property

[read/write] true if History Merges during VCM Sessions are required.

public virtual Boolean MergeHistoryDuringVCMSession {get; set;}

Property Value

true if History Merges during VCM Sessions are required.

See Also

Project.WebCacheProject Class | StarTeam Namespace


MethodologyValue Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.MethodologyValue Property

[read/write] The project methodology (Agile, Kanban, Waterfall, Migration).

public virtual Project.Methodology MethodologyValue {get; set;}

Property Value

The project methodology (Agile, Kanban, Waterfall, Migration).

See Also

Project.WebCacheProject Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Project.WebCacheProject Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.Name Property

new public virtual String Name {get; set;}

See Also

Project.WebCacheProject Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Project.WebCacheProject Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Project.WebCacheProject Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.PresentationID Property

[read] the unique integer identifier for this resource.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Project.WebCacheProject Class | StarTeam Namespace


ProcessItemTypes Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.ProcessItemTypes Property

[read] the set of (stock or custom) Item Types that may be used as process items

public virtual WebCacheItemType[] ProcessItemTypes {get;}

Property Value

the set of (stock or custom) Item Types that may be used as process items

See Also

Project.WebCacheProject Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.Rights Property

[read/write] the access rights assigned to this project

public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this project

See Also

Project.WebCacheProject Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Project.WebCacheProject Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.StatusValue Property

[read/write] The status (Active, Parked, etc.) of this Project.

public virtual Project.Status StatusValue {get; set;}

Property Value

The status (Active, Parked, etc.) of this Project.

See Also

Project.WebCacheProject Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.Traces Property

[read] the set of Traces mapped directly from this project, saved as URLs.

public virtual WebCacheTrace[] Traces {get;}

Property Value

the set of Traces mapped directly from this project, saved as URLs.

See Also

Project.WebCacheProject Class | StarTeam Namespace


Views Property

Borland StarTeam SDK for .NET

Project.WebCacheProject.Views Property

[read] the set of views accessible by this User

public virtual WebCacheView[] Views {get;}

Property Value

the set of views accessible by this User

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject Methods

The methods of the Project.WebCacheProject class are listed below. For a complete list of Project.WebCacheProject class members, see the Project.WebCacheProject Members topic.

Public Static Methods

Create

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.Project.WebCacheProject.
FindView | Overloaded. return an accessible view on this project or NULL Note that the view will be accessible to the user in this session context and that this view may not have been cached by the ArtifactCache If it is however, the cached view is returned in preference to the unacached one
GetActiveProcessItemStates |
GetAllowedStates |
GetAlternateEditorPath |
GetCRStatus |
GetFilters |
GetGroups | Return the set of Groups that have access rights to this project as defined by the specified permissions
GetHashCode | Delegate GetHashCode() to com.starteam.Project.WebCacheProject.
GetQueries |
GetRights |
GetStatus |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUDAGroupings |
GetValue | Overloaded. get the value of the property as specified by name
GetVisibleProperties | Return the subset of properties that are visible in the context of the specified Enumerated Value
HasSavedCRStatus |
HasSavedStatus |
HasValue |
IsCached | Returns true if the view has been cached in the ArtifactCache and is visible in this user context. Note that views cached in the ArtifactCache need not be visible in the context of a user without the appropriate access rights. In other words, it is possible for this api to return true in the administrator context, but false in an unauthorized user context
IsProcessItemTypeEnabled |
NewWebCacheViewEventSource |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetAllowedState | Set an enumerated value of a given property as an allowed or legal state for this project. Note that Enumerated Properties are (and continue to be) type specific. However, an application can choose to store a subset of the values as applicable (legal) to a given type. Other than storing the relationships between a project, an enumerated property and its values the SDK makes no attempt to (and in reality cannot) validate the usage of Enumerated Values for item types in the context of a given project Note that this api is not supported for pre 12.5 servers
SetAlternateEditorPath |
SetCRStatus |
SetRights |
SetStatus |
SetUDAGroupings |
SetValue | Overloaded. set the value of the property as specified by name
SetVisibleProperties |
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Project.WebCacheProject.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.Create Method

public static WebCacheProject Create(
ArtifactCacheManager.Context cntxt,
String name,
String defaultFolder
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.Equals Method

Delegate Equals() to com.starteam.Project.WebCacheProject.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Project.WebCacheProject.Equals(obj).

See Also

Project.WebCacheProject Class | StarTeam Namespace


FindView Method

Borland StarTeam SDK for .NET

Project.WebCacheProject.FindView Method

return an accessible view on this project or NULL Note that the view will be accessible to the user in this session context and that this view may not have been cached by the ArtifactCache If it is however, the cached view is returned in preference to the unacached one

Overload List

return an accessible view on this project or NULL Note that the view will be accessible to the user in this session context and that this view may not have been cached by the ArtifactCache If it is however, the cached view is returned in preference to the unacached one

public virtual WebCacheView FindView(Int32);

return an accessible view on this project or NULL Note that the view will be accessible to the user in this session context and that this view may not have been cached by the ArtifactCache If it is however, the cached view is returned in preference to the unacached one

public virtual WebCacheView FindView(String);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.FindView Method (Int32)

return an accessible view on this project or NULL Note that the view will be accessible to the user in this session context and that this view may not have been cached by the ArtifactCache If it is however, the cached view is returned in preference to the unacached one

public virtual WebCacheView FindView(
Int32 viewID
);

Parameters

viewID
the id of the view

Return Value

an accessible view or NULL

See Also

Project.WebCacheProject Class | StarTeam Namespace | Project.WebCacheProject.FindView Overload List


Project.WebCacheProject.FindView Method (String)

return an accessible view on this project or NULL Note that the view will be accessible to the user in this session context and that this view may not have been cached by the ArtifactCache If it is however, the cached view is returned in preference to the unacached one

public virtual WebCacheView FindView(
String name
);

Parameters

name
the name of the view

Return Value

an accessible view or NULL

See Also

Project.WebCacheProject Class | StarTeam Namespace | Project.WebCacheProject.FindView Overload List


Project.WebCacheProject.GetActiveProcessItemStates Method

public virtual EnumeratedValue[] GetActiveProcessItemStates(
Item.Type.WebCacheItemType type
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetAllowedStates Method

public virtual EnumeratedValue[] GetAllowedStates(
EnumeratedProperty.WebCacheEnumeratedProperty prprty
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetAlternateEditorPath Method

public virtual string GetAlternateEditorPath(
Item.Type.WebCacheItemType typ
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetCRStatus Method

public virtual EnumeratedValue GetCRStatus(
Story.Status sts
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetFilters Method

public virtual WebCacheFilter[] GetFilters(
Type.WebCacheType wct
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetGroups Method

Return the set of Groups that have access rights to this project as defined by the specified permissions

public virtual WebCacheGroup[] GetGroups(
PermissionCollection permissions
);

Parameters

permissions
the permissions needing to be satisfied

Return Value

the set of Groups that can access this project

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetHashCode Method

Delegate GetHashCode() to com.starteam.Project.WebCacheProject.

public override int GetHashCode();

Return Value

com.starteam.Project.WebCacheProject.GetHashCode().

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetQueries Method

public virtual WebCacheQuery[] GetQueries(
Type.WebCacheType wct
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetRights Method

public virtual WebCacheACE[] GetRights(
Type.WebCacheType typ
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetStatus Method

public virtual Status[] GetStatus(
Story.Status sts
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetUDAGroupings Method

public virtual EnumeratedValue[] GetUDAGroupings(
Requirement.RequirementType typ
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Project.WebCacheProject.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Project.WebCacheProject Class | StarTeam Namespace | Project.WebCacheProject.GetValue Overload List


Project.WebCacheProject.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Project.WebCacheProject Class | StarTeam Namespace | Project.WebCacheProject.GetValue Overload List


Project.WebCacheProject.GetVisibleProperties Method

Return the subset of properties that are visible in the context of the specified Enumerated Value

public virtual WebCacheProperty[] GetVisibleProperties(
EnumeratedValue value
);

Parameters

value
an Enumerated Value for a specific Enumerated Property of a chosen type

Return Value

the subset of properties of the same Type that are marked visible in the context of this enum

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.HasSavedCRStatus Method

public virtual bool HasSavedCRStatus(
Story.Status sts
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.HasSavedStatus Method

public virtual bool HasSavedStatus(
Story.Status sts
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.IsCached Method

Returns true if the view has been cached in the ArtifactCache and is visible in this user context. Note that views cached in the ArtifactCache need not be visible in the context of a user without the appropriate access rights. In other words, it is possible for this api to return true in the administrator context, but false in an unauthorized user context

public virtual bool IsCached(
Int32 viewID
);

Parameters

viewID
the view to check for

Return Value

true if the view is cached in the Artifact Cache

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.IsProcessItemTypeEnabled Method

public virtual bool IsProcessItemTypeEnabled(
Item.Type.WebCacheItemType type
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.NewWebCacheViewEventSource Method

public WebCacheViewEventSource NewWebCacheViewEventSource();

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Project.WebCacheProject Class | StarTeam Namespace | WebCacheViewMemberCollection


Project.WebCacheProject.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.SetAllowedState Method

Set an enumerated value of a given property as an allowed or legal state for this project. Note that Enumerated Properties are (and continue to be) type specific. However, an application can choose to store a subset of the values as applicable (legal) to a given type. Other than storing the relationships between a project, an enumerated property and its values the SDK makes no attempt to (and in reality cannot) validate the usage of Enumerated Values for item types in the context of a given project Note that this api is not supported for pre 12.5 servers

public virtual void SetAllowedState(
EnumeratedValue value,
Boolean isAllowed
);

Parameters

value
the selected value
isAllowed
true to turn this state on, false to turn it off

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.SetAlternateEditorPath Method

public virtual void SetAlternateEditorPath(
Item.Type.WebCacheItemType typ,
String alternatePath
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.SetCRStatus Method

public virtual void SetCRStatus(
Story.Status rfrnc,
EnumeratedValue trgt
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.SetRights Method

public virtual void SetRights(
Type.WebCacheType typ,
WebCacheACE[] aces
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.SetStatus Method

public virtual void SetStatus(
Story.Status rfrnc,
Status[] mppdSts
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.SetUDAGroupings Method

public virtual void SetUDAGroupings(
Requirement.RequirementType typ,
EnumeratedValue[] udas
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Project.WebCacheProject.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Project.WebCacheProject Class | StarTeam Namespace | Project.WebCacheProject.SetValue Overload List


Project.WebCacheProject.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Project.WebCacheProject Class | StarTeam Namespace | Project.WebCacheProject.SetValue Overload List


Project.WebCacheProject.SetVisibleProperties Method

public virtual void SetVisibleProperties(
EnumeratedValue value,
WebCacheProperty[] properties
);

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.ToString Method

Delegate ToString() to com.starteam.Project.WebCacheProject.

public override string ToString();

Return Value

com.starteam.Project.WebCacheProject.ToString()

See Also

Project.WebCacheProject Class | StarTeam Namespace


Project.WebCacheProject.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Project.WebCacheProject Class | StarTeam Namespace | WebCacheViewMemberCollection


PromotionModel Class

This class represents the Promotion model for a view. Each view has a single promotion model. The PromotionModel class primarily acts as the owner of an ordered list of PromotionStates.

For a list of all members of this type, see PromotionModel Members.

System.Object
TypedResource
LiveObject
PromotionModel

public class PromotionModel : LiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionModel Members | StarTeam Namespace


PromotionModel Members

PromotionModel overview

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedOn | [read] the time at which this model was created
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString | [read] a debug string for this model.
Description | [read/write] a description string for this model
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of the model
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
PromotionStates | [read/write] an array of promotion states defining this model
Properties | [read] the PropertyCollection for this Promotion Model.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
View | [read] the view for this model.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindPromotionState | Overloaded. Find a Promotion State with this ID
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Stores the modified PromotionModel in the repository. Until this is called all changes to the model are local.

See Also

PromotionModel Class | StarTeam Namespace


PromotionModel Properties

The properties of the PromotionModel class are listed below. For a complete list of PromotionModel class members, see the PromotionModel Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedOn | [read] the time at which this model was created
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString | [read] a debug string for this model.
Description | [read/write] a description string for this model
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of the model
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
PromotionStates | [read/write] an array of promotion states defining this model
Properties | [read] the PropertyCollection for this Promotion Model.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
View | [read] the view for this model.

See Also

PromotionModel Class | StarTeam Namespace


CreatedOn Property

Borland StarTeam SDK for .NET

PromotionModel.CreatedOn Property

[read] the time at which this model was created

public virtual DateTime CreatedOn {get;}

Property Value

the time at which this model was created

See Also

PromotionModel Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

PromotionModel.DebugString Property

[read] a debug string for this model.

public virtual String DebugString {get;}

Property Value

a debug string for this model.

See Also

PromotionModel Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

PromotionModel.Description Property

[read/write] a description string for this model

public virtual String Description {get; set;}

Property Value

a description string for this model

See Also

PromotionModel Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

PromotionModel.Name Property

[read/write] the name of the model

public virtual String Name {get; set;}

Property Value

the name of the model

See Also

PromotionModel Class | StarTeam Namespace


PromotionStates Property

Borland StarTeam SDK for .NET

PromotionModel.PromotionStates Property

[read/write] an array of promotion states defining this model

public virtual PromotionState[] PromotionStates {get; set;}

Property Value

an array of promotion states defining this model

See Also

PromotionModel Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

PromotionModel.Properties Property

[read] the PropertyCollection for this Promotion Model.

public virtual PromotionModel.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection for this Promotion Model.

See Also

PromotionModel Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

PromotionModel.View Property

[read] the view for this model.

public virtual View View {get;}

Property Value

the view for this model.

See Also

PromotionModel Class | StarTeam Namespace


PromotionModel Methods

The methods of the PromotionModel class are listed below. For a complete list of PromotionModel class members, see the PromotionModel Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindPromotionState | Overloaded. Find a Promotion State with this ID
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Stores the modified PromotionModel in the repository. Until this is called all changes to the model are local.

See Also

PromotionModel Class | StarTeam Namespace


FindPromotionState Method

Borland StarTeam SDK for .NET

PromotionModel.FindPromotionState Method

Find a Promotion State with this ID

Overload List

Find a Promotion State with this ID

public virtual PromotionState FindPromotionState(Int32);

find a Promotion State by Name. This is a case sensitive match

public virtual PromotionState FindPromotionState(String);

See Also

PromotionModel Class | StarTeam Namespace


PromotionModel.FindPromotionState Method (Int32)

Find a Promotion State with this ID

public virtual PromotionState FindPromotionState(
Int32 ID
);

Parameters

ID
the ID of the Promotion State

Return Value

a PromotionState if one exists, or NULL

See Also

PromotionModel Class | StarTeam Namespace | PromotionModel.FindPromotionState Overload List


PromotionModel.FindPromotionState Method (String)

find a Promotion State by Name. This is a case sensitive match

public virtual PromotionState FindPromotionState(
String name
);

Parameters

name
the name of the promotion state

Return Value

a PromotionState if one exists, or NULL

See Also

PromotionModel Class | StarTeam Namespace | PromotionModel.FindPromotionState Overload List


PromotionModel.Update Method

Stores the modified PromotionModel in the repository. Until this is called all changes to the model are local.

public virtual void Update();

See Also

PromotionModel Class | StarTeam Namespace


PromotionModel.Type Class

The Type of Promotion Model

For a list of all members of this type, see PromotionModel.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
PromotionModel.Type

new public class PromotionModel.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionModel.Type Members | StarTeam Namespace


PromotionModel.Type Members

PromotionModel.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.PromotionModel.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.PromotionModel.Type.

See Also

PromotionModel.Type Class | StarTeam Namespace


PromotionModel.Type Properties

The properties of the PromotionModel.Type class are listed below. For a complete list of PromotionModel.Type class members, see the PromotionModel.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

PromotionModel.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

PromotionModel.Type.NAME Property

new public static String NAME {get;}

See Also

PromotionModel.Type Class | StarTeam Namespace


PromotionModel.Type Methods

The methods of the PromotionModel.Type class are listed below. For a complete list of PromotionModel.Type class members, see the PromotionModel.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.PromotionModel.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.PromotionModel.Type.

See Also

PromotionModel.Type Class | StarTeam Namespace


PromotionModel.Type.Equals Method

Delegate Equals() to com.starteam.PromotionModel.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PromotionModel.Type.Equals(obj).

See Also

PromotionModel.Type Class | StarTeam Namespace


PromotionModel.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.PromotionModel.Type.

public override int GetHashCode();

Return Value

com.starteam.PromotionModel.Type.GetHashCode().

See Also

PromotionModel.Type Class | StarTeam Namespace


PromotionModel.Type.ToString Method

Delegate ToString() to com.starteam.PromotionModel.Type.

public override string ToString();

Return Value

com.starteam.PromotionModel.Type.ToString()

See Also

PromotionModel.Type Class | StarTeam Namespace


PromotionModel.Type.NumberOfStatesProperty Class

The property type of the Number of States property.

For a list of all members of this type, see PromotionModel.Type.NumberOfStatesProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
PromotionModel.Type.NumberOfStatesProperty

public class PromotionModel.Type.NumberOfStatesProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionModel.Type.NumberOfStatesProperty Members | StarTeam Namespace


PromotionModel.Type.NumberOfStatesProperty Members

PromotionModel.Type.NumberOfStatesProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.PromotionModel.Type.NumberOfStatesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.Type.NumberOfStatesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.PromotionModel.Type.NumberOfStatesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

PromotionModel.Type.NumberOfStatesProperty Class | StarTeam Namespace


PromotionModel.Type.NumberOfStatesProperty Properties

The properties of the PromotionModel.Type.NumberOfStatesProperty class are listed below. For a complete list of PromotionModel.Type.NumberOfStatesProperty class members, see the PromotionModel.Type.NumberOfStatesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

PromotionModel.Type.NumberOfStatesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

PromotionModel.Type.NumberOfStatesProperty.NAME Property

public static String NAME {get;}

See Also

PromotionModel.Type.NumberOfStatesProperty Class | StarTeam Namespace


PromotionModel.Type.NumberOfStatesProperty Methods

The methods of the PromotionModel.Type.NumberOfStatesProperty class are listed below. For a complete list of PromotionModel.Type.NumberOfStatesProperty class members, see the PromotionModel.Type.NumberOfStatesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.PromotionModel.Type.NumberOfStatesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.Type.NumberOfStatesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.PromotionModel.Type.NumberOfStatesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

PromotionModel.Type.NumberOfStatesProperty Class | StarTeam Namespace


PromotionModel.Type.NumberOfStatesProperty.Equals Method

Delegate Equals() to com.starteam.PromotionModel.Type.NumberOfStatesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PromotionModel.Type.NumberOfStatesProperty.Equals(obj).

See Also

PromotionModel.Type.NumberOfStatesProperty Class | StarTeam Namespace


PromotionModel.Type.NumberOfStatesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.PromotionModel.Type.NumberOfStatesProperty.

public override int GetHashCode();

Return Value

com.starteam.PromotionModel.Type.NumberOfStatesProperty.GetHashCode().

See Also

PromotionModel.Type.NumberOfStatesProperty Class | StarTeam Namespace


PromotionModel.Type.NumberOfStatesProperty.ToString Method

Delegate ToString() to com.starteam.PromotionModel.Type.NumberOfStatesProperty.

public override string ToString();

Return Value

com.starteam.PromotionModel.Type.NumberOfStatesProperty.ToString()

See Also

PromotionModel.Type.NumberOfStatesProperty Class | StarTeam Namespace


PromotionModel.Type.PromotionStatesProperty Class

The property type of the Promotion States property.

For a list of all members of this type, see PromotionModel.Type.PromotionStatesProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
PromotionModel.Type.PromotionStatesProperty

public class PromotionModel.Type.PromotionStatesProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionModel.Type.PromotionStatesProperty Members | StarTeam Namespace


PromotionModel.Type.PromotionStatesProperty Members

PromotionModel.Type.PromotionStatesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.PromotionModel.Type.PromotionStatesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.Type.PromotionStatesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.PromotionModel.Type.PromotionStatesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

PromotionModel.Type.PromotionStatesProperty Class | StarTeam Namespace


PromotionModel.Type.PromotionStatesProperty Properties

The properties of the PromotionModel.Type.PromotionStatesProperty class are listed below. For a complete list of PromotionModel.Type.PromotionStatesProperty class members, see the PromotionModel.Type.PromotionStatesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

PromotionModel.Type.PromotionStatesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PromotionStatesProperty.NAME Property

public static String NAME {get;}

See Also

PromotionModel.Type.PromotionStatesProperty Class | StarTeam Namespace


PromotionModel.Type.PromotionStatesProperty Methods

The methods of the PromotionModel.Type.PromotionStatesProperty class are listed below. For a complete list of PromotionModel.Type.PromotionStatesProperty class members, see the PromotionModel.Type.PromotionStatesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.PromotionModel.Type.PromotionStatesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.Type.PromotionStatesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.PromotionModel.Type.PromotionStatesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

PromotionModel.Type.PromotionStatesProperty Class | StarTeam Namespace


PromotionModel.Type.PromotionStatesProperty.Equals Method

Delegate Equals() to com.starteam.PromotionModel.Type.PromotionStatesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PromotionModel.Type.PromotionStatesProperty.Equals(obj).

See Also

PromotionModel.Type.PromotionStatesProperty Class | StarTeam Namespace


PromotionModel.Type.PromotionStatesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.PromotionModel.Type.PromotionStatesProperty.

public override int GetHashCode();

Return Value

com.starteam.PromotionModel.Type.PromotionStatesProperty.GetHashCode().

See Also

PromotionModel.Type.PromotionStatesProperty Class | StarTeam Namespace


PromotionModel.Type.PromotionStatesProperty.ToString Method

Delegate ToString() to com.starteam.PromotionModel.Type.PromotionStatesProperty.

public override string ToString();

Return Value

com.starteam.PromotionModel.Type.PromotionStatesProperty.ToString()

See Also

PromotionModel.Type.PromotionStatesProperty Class | StarTeam Namespace


PromotionModel.Type.PropertyCollection Class

PropertyCollection for Promotion Model

For a list of all members of this type, see PromotionModel.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
PromotionModel.Type.PropertyCollection

public class PromotionModel.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionModel.Type.PropertyCollection Members | StarTeam Namespace


PromotionModel.Type.PropertyCollection Members

PromotionModel.Type.PropertyCollection overview

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
NAME |
NUMBER_OF_STATES |
PROMOTION_STATES |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.PromotionModel.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.PromotionModel.Type.PropertyCollection.

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


PromotionModel.Type.PropertyCollection Properties

The properties of the PromotionModel.Type.PropertyCollection class are listed below. For a complete list of PromotionModel.Type.PropertyCollection class members, see the PromotionModel.Type.PropertyCollection Members topic.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
NAME |
NUMBER_OF_STATES |
PROMOTION_STATES |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


NUMBER_OF_STATES Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PropertyCollection.NUMBER_OF_STATES Property

public PromotionModel.Type.NumberOfStatesProperty NUMBER_OF_STATES {get;}

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


PROMOTION_STATES Property

Borland StarTeam SDK for .NET

PromotionModel.Type.PropertyCollection.PROMOTION_STATES Property

public PromotionModel.Type.PromotionStatesProperty PROMOTION_STATES {get;}

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


PromotionModel.Type.PropertyCollection Methods

The methods of the PromotionModel.Type.PropertyCollection class are listed below. For a complete list of PromotionModel.Type.PropertyCollection class members, see the PromotionModel.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.PromotionModel.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.PromotionModel.Type.PropertyCollection.

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


PromotionModel.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.PromotionModel.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PromotionModel.Type.PropertyCollection.Equals(obj).

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


PromotionModel.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.PromotionModel.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.PromotionModel.Type.PropertyCollection.GetHashCode().

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


PromotionModel.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.PromotionModel.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.PromotionModel.Type.PropertyCollection.ToString()

See Also

PromotionModel.Type.PropertyCollection Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel Class

PromotionModel accessor for cached SDK views contained objects are obtained from the artifact cache

For a list of all members of this type, see PromotionModel.WebCachePromotionModel Members.

System.Object
LiveObject.WebCacheLiveObject
PromotionModel.WebCachePromotionModel

public class PromotionModel.WebCachePromotionModel : WebCacheLiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionModel.WebCachePromotionModel Members | StarTeam Namespace


PromotionModel.WebCachePromotionModel Members

PromotionModel.WebCachePromotionModel overview

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedOn | [read] the time at which this model was created
CreatedTime | [read] The date and time at which this object was created.
Description | [read/write] a description string for this model
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PromotionStates | [read/write] an array of promotion states defining this model
Server | [read] the Server for this cached object
View | [read] the view for this model.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.PromotionModel.WebCachePromotionModel.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.WebCachePromotionModel.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.PromotionModel.WebCachePromotionModel.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel Properties

The properties of the PromotionModel.WebCachePromotionModel class are listed below. For a complete list of PromotionModel.WebCachePromotionModel class members, see the PromotionModel.WebCachePromotionModel Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedOn | [read] the time at which this model was created
CreatedTime | [read] The date and time at which this object was created.
Description | [read/write] a description string for this model
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PromotionStates | [read/write] an array of promotion states defining this model
Server | [read] the Server for this cached object
View | [read] the view for this model.

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


CreatedOn Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.CreatedOn Property

[read] the time at which this model was created

public virtual DateTime CreatedOn {get;}

Property Value

the time at which this model was created

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.Description Property

[read/write] a description string for this model

public virtual String Description {get; set;}

Property Value

a description string for this model

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.Name Property

new public virtual String Name {get; set;}

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionStates Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.PromotionStates Property

[read/write] an array of promotion states defining this model

public virtual WebCachePromotionState[] PromotionStates {get; set;}

Property Value

an array of promotion states defining this model

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.View Property

[read] the view for this model.

public virtual View.WebCacheView View {get;}

Property Value

the view for this model.

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel Methods

The methods of the PromotionModel.WebCachePromotionModel class are listed below. For a complete list of PromotionModel.WebCachePromotionModel class members, see the PromotionModel.WebCachePromotionModel Members topic.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.PromotionModel.WebCachePromotionModel.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionModel.WebCachePromotionModel.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.PromotionModel.WebCachePromotionModel.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel.Equals Method

Delegate Equals() to com.starteam.PromotionModel.WebCachePromotionModel.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PromotionModel.WebCachePromotionModel.Equals(obj).

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel.GetHashCode Method

Delegate GetHashCode() to com.starteam.PromotionModel.WebCachePromotionModel.

public override int GetHashCode();

Return Value

com.starteam.PromotionModel.WebCachePromotionModel.GetHashCode().

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace | PromotionModel.WebCachePromotionModel.GetValue Overload List


PromotionModel.WebCachePromotionModel.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace | PromotionModel.WebCachePromotionModel.GetValue Overload List


PromotionModel.WebCachePromotionModel.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace | WebCacheViewMemberCollection


PromotionModel.WebCachePromotionModel.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

PromotionModel.WebCachePromotionModel.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace | PromotionModel.WebCachePromotionModel.SetValue Overload List


PromotionModel.WebCachePromotionModel.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace | PromotionModel.WebCachePromotionModel.SetValue Overload List


PromotionModel.WebCachePromotionModel.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel.ToString Method

Delegate ToString() to com.starteam.PromotionModel.WebCachePromotionModel.

public override string ToString();

Return Value

com.starteam.PromotionModel.WebCachePromotionModel.ToString()

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace


PromotionModel.WebCachePromotionModel.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

PromotionModel.WebCachePromotionModel Class | StarTeam Namespace | WebCacheViewMemberCollection


PromotionState Class

This class represents a promotion state associated with a promotion model. This class has no update() method so to save new or modified promotion states you must use PromotionModel.update()

For a list of all members of this type, see PromotionState Members.

System.Object
TypedResource
LiveObject
PromotionState

public class PromotionState : LiveObject, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionState Members | StarTeam Namespace


PromotionState Members

PromotionState overview

Public Instance Constructors

PromotionState Constructor Create a new PromotionState for the specified model.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedOn | [read] the time at which the state was created.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy | [read] the user who deleted this state
DeletedOn | [read] the time at which the state was deleted.
Description | [read/write] this state's description
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDeleted | [read] true if this promotion state has been deleted
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
Label | [read/write] the label for this state
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of the PromotionState.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer | [read] This object's parent container.
PromotionModel | [read] the "owning" PromotionModel object for this PromotionState.
Properties | [read] the PropertyCollection for this Promotion State.
Rights | [read/write] the access control list for this item or NULL.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

PromotionState Class | StarTeam Namespace


PromotionState Constructor

Create a new PromotionState for the specified model.

public PromotionState(
PromotionModel model
);

Parameters

model
the owning PromotionModel

See Also

PromotionState Class | StarTeam Namespace


PromotionState Properties

The properties of the PromotionState class are listed below. For a complete list of PromotionState class members, see the PromotionState Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedOn | [read] the time at which the state was created.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy | [read] the user who deleted this state
DeletedOn | [read] the time at which the state was deleted.
Description | [read/write] this state's description
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDeleted | [read] true if this promotion state has been deleted
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
Label | [read/write] the label for this state
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of the PromotionState.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer | [read] This object's parent container.
PromotionModel | [read] the "owning" PromotionModel object for this PromotionState.
Properties | [read] the PropertyCollection for this Promotion State.
Rights | [read/write] the access control list for this item or NULL.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource

See Also

PromotionState Class | StarTeam Namespace


CreatedOn Property

Borland StarTeam SDK for .NET

PromotionState.CreatedOn Property

[read] the time at which the state was created.

public virtual DateTime CreatedOn {get;}

Property Value

the time at which the state was created.

See Also

PromotionState Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

PromotionState.DeletedBy Property

[read] the user who deleted this state

public virtual User DeletedBy {get;}

Property Value

the user who deleted this state

See Also

PromotionState Class | StarTeam Namespace


DeletedOn Property

Borland StarTeam SDK for .NET

PromotionState.DeletedOn Property

[read] the time at which the state was deleted.

public virtual DateTime DeletedOn {get;}

Property Value

the time at which the state was deleted.

See Also

PromotionState Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

PromotionState.Description Property

[read/write] this state's description

public virtual String Description {get; set;}

Property Value

this state's description

See Also

PromotionState Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

PromotionState.IsDeleted Property

[read] true if this promotion state has been deleted

public virtual Boolean IsDeleted {get;}

Property Value

true if this promotion state has been deleted

Implements

ISecurable.IsDeleted

See Also

PromotionState Class | StarTeam Namespace


Label Property

Borland StarTeam SDK for .NET

PromotionState.Label Property

[read/write] the label for this state

public virtual Label Label {get; set;}

Property Value

the label for this state

See Also

PromotionState Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

PromotionState.Name Property

[read/write] the name of the PromotionState.

public virtual String Name {get; set;}

Property Value

the name of the PromotionState.

See Also

PromotionState Class | StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

PromotionState.ParentContainer Property

[read] This object's parent container.

public virtual ISecurableContainer ParentContainer {get;}

Property Value

This object's parent container.

Implements

ISecurable.ParentContainer

See Also

PromotionState Class | StarTeam Namespace


PromotionModel Property

Borland StarTeam SDK for .NET

PromotionState.PromotionModel Property

[read] the "owning" PromotionModel object for this PromotionState.

public virtual PromotionModel PromotionModel {get;}

Property Value

the "owning" PromotionModel object for this PromotionState.

See Also

PromotionState Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

PromotionState.Properties Property

[read] the PropertyCollection for this Promotion State.

public virtual PromotionState.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection for this Promotion State.

See Also

PromotionState Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

PromotionState.Rights Property

[read/write] the access control list for this item or NULL.

public virtual ACE[] Rights {get; set;}

Property Value

the access control list for this item or NULL.

Implements

ISecurable.Rights

See Also

PromotionState Class | StarTeam Namespace


PromotionState Methods

The methods of the PromotionState class are listed below. For a complete list of PromotionState class members, see the PromotionState Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

PromotionState Class | StarTeam Namespace


PromotionState.HasPermissions Method

Returns true if desired permissions are granted

public virtual bool HasPermissions(
PermissionCollection permissions
);

Parameters

permissions
the desired permissions

Implements

ISecurable.HasPermissions

See Also

PromotionState Class | StarTeam Namespace | Permission


PromotionState.Type Class

The Type of Promotion State

For a list of all members of this type, see PromotionState.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
PromotionState.Type

new public class PromotionState.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionState.Type Members | StarTeam Namespace


PromotionState.Type Members

PromotionState.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.PromotionState.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionState.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.PromotionState.Type.

See Also

PromotionState.Type Class | StarTeam Namespace


PromotionState.Type Properties

The properties of the PromotionState.Type class are listed below. For a complete list of PromotionState.Type class members, see the PromotionState.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

PromotionState.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

PromotionState.Type.NAME Property

new public static String NAME {get;}

See Also

PromotionState.Type Class | StarTeam Namespace


PromotionState.Type Methods

The methods of the PromotionState.Type class are listed below. For a complete list of PromotionState.Type class members, see the PromotionState.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.PromotionState.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionState.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.PromotionState.Type.

See Also

PromotionState.Type Class | StarTeam Namespace


PromotionState.Type.Equals Method

Delegate Equals() to com.starteam.PromotionState.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PromotionState.Type.Equals(obj).

See Also

PromotionState.Type Class | StarTeam Namespace


PromotionState.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.PromotionState.Type.

public override int GetHashCode();

Return Value

com.starteam.PromotionState.Type.GetHashCode().

See Also

PromotionState.Type Class | StarTeam Namespace


PromotionState.Type.ToString Method

Delegate ToString() to com.starteam.PromotionState.Type.

public override string ToString();

Return Value

com.starteam.PromotionState.Type.ToString()

See Also

PromotionState.Type Class | StarTeam Namespace


PromotionState.Type.LabelProperty Class

The property type of the Label property.

For a list of all members of this type, see PromotionState.Type.LabelProperty Members.

System.Object
Property
ObjectProperty
PromotionState.Type.LabelProperty

public class PromotionState.Type.LabelProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionState.Type.LabelProperty Members | StarTeam Namespace


PromotionState.Type.LabelProperty Members

PromotionState.Type.LabelProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.PromotionState.Type.LabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionState.Type.LabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.PromotionState.Type.LabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

PromotionState.Type.LabelProperty Class | StarTeam Namespace


PromotionState.Type.LabelProperty Properties

The properties of the PromotionState.Type.LabelProperty class are listed below. For a complete list of PromotionState.Type.LabelProperty class members, see the PromotionState.Type.LabelProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

PromotionState.Type.LabelProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

PromotionState.Type.LabelProperty.NAME Property

public static String NAME {get;}

See Also

PromotionState.Type.LabelProperty Class | StarTeam Namespace


PromotionState.Type.LabelProperty Methods

The methods of the PromotionState.Type.LabelProperty class are listed below. For a complete list of PromotionState.Type.LabelProperty class members, see the PromotionState.Type.LabelProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.PromotionState.Type.LabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionState.Type.LabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.PromotionState.Type.LabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

PromotionState.Type.LabelProperty Class | StarTeam Namespace


PromotionState.Type.LabelProperty.Equals Method

Delegate Equals() to com.starteam.PromotionState.Type.LabelProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PromotionState.Type.LabelProperty.Equals(obj).

See Also

PromotionState.Type.LabelProperty Class | StarTeam Namespace


PromotionState.Type.LabelProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.PromotionState.Type.LabelProperty.

public override int GetHashCode();

Return Value

com.starteam.PromotionState.Type.LabelProperty.GetHashCode().

See Also

PromotionState.Type.LabelProperty Class | StarTeam Namespace


PromotionState.Type.LabelProperty.ToString Method

Delegate ToString() to com.starteam.PromotionState.Type.LabelProperty.

public override string ToString();

Return Value

com.starteam.PromotionState.Type.LabelProperty.ToString()

See Also

PromotionState.Type.LabelProperty Class | StarTeam Namespace


PromotionState.Type.PropertyCollection Class

PropertyCollection for PromotionState

For a list of all members of this type, see PromotionState.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
PromotionState.Type.PropertyCollection

public class PromotionState.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionState.Type.PropertyCollection Members | StarTeam Namespace


PromotionState.Type.PropertyCollection Members

PromotionState.Type.PropertyCollection overview

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
LABEL |
NAME |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.PromotionState.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionState.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.PromotionState.Type.PropertyCollection.

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


PromotionState.Type.PropertyCollection Properties

The properties of the PromotionState.Type.PropertyCollection class are listed below. For a complete list of PromotionState.Type.PropertyCollection class members, see the PromotionState.Type.PropertyCollection Members topic.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
LABEL |
NAME |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

PromotionState.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

PromotionState.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

PromotionState.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

PromotionState.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

PromotionState.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

PromotionState.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


LABEL Property

Borland StarTeam SDK for .NET

PromotionState.Type.PropertyCollection.LABEL Property

public PromotionState.Type.LabelProperty LABEL {get;}

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

PromotionState.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


PromotionState.Type.PropertyCollection Methods

The methods of the PromotionState.Type.PropertyCollection class are listed below. For a complete list of PromotionState.Type.PropertyCollection class members, see the PromotionState.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.PromotionState.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionState.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.PromotionState.Type.PropertyCollection.

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


PromotionState.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.PromotionState.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PromotionState.Type.PropertyCollection.Equals(obj).

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


PromotionState.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.PromotionState.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.PromotionState.Type.PropertyCollection.GetHashCode().

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


PromotionState.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.PromotionState.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.PromotionState.Type.PropertyCollection.ToString()

See Also

PromotionState.Type.PropertyCollection Class | StarTeam Namespace


PromotionState.WebCachePromotionState Class

PromotionState accessor for cached SDK views contained objects are obtained from the artifact cache

For a list of all members of this type, see PromotionState.WebCachePromotionState Members.

System.Object
LiveObject.WebCacheLiveObject
PromotionState.WebCachePromotionState

public class PromotionState.WebCachePromotionState : WebCacheLiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PromotionState.WebCachePromotionState Members | StarTeam Namespace


PromotionState.WebCachePromotionState Members

PromotionState.WebCachePromotionState overview

Public Static Methods

Create

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedOn | [read] the time at which the state was created.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] the user who deleted this state
DeletedOn | [read] the time at which the state was deleted.
Description | [read/write] this state's description
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDeleted | [read] true if this promotion state has been deleted
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
Label | [read/write] the label for this state
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Rights | [read/write] the access rights assigned to this promotion state
Server | [read] the Server for this cached object

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.PromotionState.WebCachePromotionState.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionState.WebCachePromotionState.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.PromotionState.WebCachePromotionState.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState Properties

The properties of the PromotionState.WebCachePromotionState class are listed below. For a complete list of PromotionState.WebCachePromotionState class members, see the PromotionState.WebCachePromotionState Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedOn | [read] the time at which the state was created.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] the user who deleted this state
DeletedOn | [read] the time at which the state was deleted.
Description | [read/write] this state's description
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDeleted | [read] true if this promotion state has been deleted
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
Label | [read/write] the label for this state
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Rights | [read/write] the access rights assigned to this promotion state
Server | [read] the Server for this cached object

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


CreatedOn Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.CreatedOn Property

[read] the time at which the state was created.

public virtual DateTime CreatedOn {get;}

Property Value

the time at which the state was created.

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.DeletedBy Property

[read] the user who deleted this state

public virtual User.WebCacheUser DeletedBy {get;}

Property Value

the user who deleted this state

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


DeletedOn Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.DeletedOn Property

[read] the time at which the state was deleted.

public virtual DateTime DeletedOn {get;}

Property Value

the time at which the state was deleted.

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.Description Property

[read/write] this state's description

public virtual String Description {get; set;}

Property Value

this state's description

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.IsDeleted Property

[read] true if this promotion state has been deleted

public virtual Boolean IsDeleted {get;}

Property Value

true if this promotion state has been deleted

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


Label Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.Label Property

[read/write] the label for this state

public virtual Label.WebCacheLabel Label {get; set;}

Property Value

the label for this state

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.Name Property

new public virtual String Name {get; set;}

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.Rights Property

[read/write] the access rights assigned to this promotion state

public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this promotion state

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState Methods

The methods of the PromotionState.WebCachePromotionState class are listed below. For a complete list of PromotionState.WebCachePromotionState class members, see the PromotionState.WebCachePromotionState Members topic.

Public Static Methods

Create

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.PromotionState.WebCachePromotionState.
GetHashCode | Delegate GetHashCode() to com.starteam.PromotionState.WebCachePromotionState.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.PromotionState.WebCachePromotionState.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.Create Method

public static WebCachePromotionState Create(
ArtifactCacheManager.Context cntxt,
PromotionModel.WebCachePromotionModel model
);

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.Equals Method

Delegate Equals() to com.starteam.PromotionState.WebCachePromotionState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PromotionState.WebCachePromotionState.Equals(obj).

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.GetHashCode Method

Delegate GetHashCode() to com.starteam.PromotionState.WebCachePromotionState.

public override int GetHashCode();

Return Value

com.starteam.PromotionState.WebCachePromotionState.GetHashCode().

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace | PromotionState.WebCachePromotionState.GetValue Overload List


PromotionState.WebCachePromotionState.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace | PromotionState.WebCachePromotionState.GetValue Overload List


PromotionState.WebCachePromotionState.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace | WebCacheViewMemberCollection


PromotionState.WebCachePromotionState.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

PromotionState.WebCachePromotionState.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace | PromotionState.WebCachePromotionState.SetValue Overload List


PromotionState.WebCachePromotionState.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace | PromotionState.WebCachePromotionState.SetValue Overload List


PromotionState.WebCachePromotionState.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.ToString Method

Delegate ToString() to com.starteam.PromotionState.WebCachePromotionState.

public override string ToString();

Return Value

com.starteam.PromotionState.WebCachePromotionState.ToString()

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace


PromotionState.WebCachePromotionState.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

PromotionState.WebCachePromotionState Class | StarTeam Namespace | WebCacheViewMemberCollection


Property Class

Each different Type supported by a StarTeam Server (e.g. File, Change Request, Topic...) has an associated set of properties. The Property class provides information about a Type's property.

For a list of all members of this type, see Property Members.

System.Object
Property
Derived types

public class Property

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Property Members | StarTeam Namespace


Property Members

Property overview

Public Static Methods

AreValuesEqual | Compares two property values for equality. Handles all StarTeam data types in a "natural" fashion. For example, two IDARRAY values are considered equal if they contain the same IDs in the same order.
FromXml | Create a property from a specified xml definition. The returned property object is new, i.e. it is not a server object. It simply represents a data structure mapping the property to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of properties out to disk and back, until ready to actually create the property on the server. Note that once a property has been created on the server, its rendering .xml can no longer be used to manipulate that same property. It could however be used (with appropriate changes to property name, display name, etc) to create a completely different property.
ResolveAllDependencies | This will return the full set of dependent properties based on the specified set. The returned set will include the specified properties. The returned set will not have duplicate elements.

Public Instance Properties

DebugString | [read] a debug string for this property.
DefaultValue | [read/write] the property's default value.
DependentProperties | [read] the properties that this property depends upon
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] this property's internal ID.
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if the property is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsNew | [read] true if the property is new
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name | [read] this property's internal name.
Server | [read] the Server that this property belongs to
Type | [read] the Type object that "owns" this property.

Public Instance Methods

Copy | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Property.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Property.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | If this property is new or dirty, saves changes to the repository

See Also

Property Class | StarTeam Namespace


Property Properties

The properties of the Property class are listed below. For a complete list of Property class members, see the Property Members topic.

Public Instance Properties

DebugString | [read] a debug string for this property.
DefaultValue | [read/write] the property's default value.
DependentProperties | [read] the properties that this property depends upon
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] this property's internal ID.
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if the property is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsNew | [read] true if the property is new
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name | [read] this property's internal name.
Server | [read] the Server that this property belongs to
Type | [read] the Type object that "owns" this property.

See Also

Property Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Property.DebugString Property

[read] a debug string for this property.

public virtual String DebugString {get;}

Property Value

a debug string for this property.

See Also

Property Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

Property.DefaultValue Property

[read/write] the property's default value.

public virtual Object DefaultValue {get; set;}

Property Value

the property's default value.

See Also

Property Class | StarTeam Namespace


DependentProperties Property

Borland StarTeam SDK for .NET

Property.DependentProperties Property

[read] the properties that this property depends upon

public virtual PropertyCollection DependentProperties {get;}

Property Value

the properties that this property depends upon

See Also

Property Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Property.DisplayName Property

[read/write] this property's display name.

public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

Property Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Property.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

Property Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Property.ID Property

[read] this property's internal ID.

public virtual Int32 ID {get;}

Property Value

this property's internal ID.

See Also

Property Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

Property.IsAdvanced Property

[read] true if the property is considered advanced.

public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

Property Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

Property.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

Property Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

Property.IsClientCalculated Property

[read] true if the property is client calculated.

public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

Property Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

Property.IsDescriptor Property

[read] true is this property is a descriptor.

public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

Property Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Property.IsDirty Property

[read] true if the property is dirty

public virtual Boolean IsDirty {get;}

Property Value

true if the property is dirty

See Also

Property Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

Property.IsDisabled Property

[read] true is the property is flagged as disabled.

public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

Property Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Property.IsEnabled Property

[read/write] true is the property is flagged as enabled.

public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

Property Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

Property.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

Property Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

Property.IsHeader Property

[read] true if this property is stored in a header field in the database

public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

Property Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

Property.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

Property Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Property.IsNew Property

[read] true if the property is new

public virtual Boolean IsNew {get;}

Property Value

true if the property is new

See Also

Property Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

Property.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

Property Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

Property.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

Property Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

Property.IsRestricted Property

[read] true if this is a restricted property.

public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

Property Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

Property.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

Property Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

Property.IsServerCalculated Property

[read] true if the property if server calculated.

public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

Property Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

Property.IsSortByTextValueSupported Property

[read] boolean

public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

Property Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

Property.IsStored Property

[read] true if the property is stored in the server's database.

public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

Property Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

Property.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

Property Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

Property.IsUserCustomized Property

[read] true if this property is a user defined property.

public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

Property Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

Property.IsUserDefined Property

[read] true if the property is user defined.

public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

Property Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

Property.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

Property Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

Property.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

Property Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Property.Name Property

[read] this property's internal name.

public virtual String Name {get;}

Property Value

this property's internal name.

See Also

Property Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Property.Server Property

[read] the Server that this property belongs to

public virtual Server Server {get;}

Property Value

the Server that this property belongs to

See Also

Property Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Property.Type Property

[read] the Type object that "owns" this property.

public virtual Type Type {get;}

Property Value

the Type object that "owns" this property.

See Also

Property Class | StarTeam Namespace


Property Methods

The methods of the Property class are listed below. For a complete list of Property class members, see the Property Members topic.

Public Static Methods

AreValuesEqual | Compares two property values for equality. Handles all StarTeam data types in a "natural" fashion. For example, two IDARRAY values are considered equal if they contain the same IDs in the same order.
FromXml | Create a property from a specified xml definition. The returned property object is new, i.e. it is not a server object. It simply represents a data structure mapping the property to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of properties out to disk and back, until ready to actually create the property on the server. Note that once a property has been created on the server, its rendering .xml can no longer be used to manipulate that same property. It could however be used (with appropriate changes to property name, display name, etc) to create a completely different property.
ResolveAllDependencies | This will return the full set of dependent properties based on the specified set. The returned set will include the specified properties. The returned set will not have duplicate elements.

Public Instance Methods

Copy | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Property.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Property.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | If this property is new or dirty, saves changes to the repository

See Also

Property Class | StarTeam Namespace


Property.AreValuesEqual Method

Compares two property values for equality. Handles all StarTeam data types in a "natural" fashion. For example, two IDARRAY values are considered equal if they contain the same IDs in the same order.

public static bool AreValuesEqual(
Object v1,
Object v2
);

Parameters

v1
Property value.
v2
Another property value.

Return Value

true if the two values are equal.

See Also

Property Class | StarTeam Namespace


Property.Copy Method

Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes().

The copied property will have the same parent Type as the original property. The Type object is not copied.

For enumerated properties, the enumerated values are copied.

For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.

public virtual Property Copy();

Return Value

A copy of this property object.

See Also

Property Class | StarTeam Namespace | isEqualTo


Property.Equals Method

Delegate Equals() to com.starteam.Property.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Property.Equals(obj).

See Also

Property Class | StarTeam Namespace


Property.FromXml Method

Create a property from a specified xml definition. The returned property object is new, i.e. it is not a server object. It simply represents a data structure mapping the property to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of properties out to disk and back, until ready to actually create the property on the server. Note that once a property has been created on the server, its rendering .xml can no longer be used to manipulate that same property. It could however be used (with appropriate changes to property name, display name, etc) to create a completely different property.

public static Property FromXml(
Type t,
String xmlDefinition
);

Parameters

t
The type in whose context the property is being defined
xmlDefinition
an xml representation of the property then serialized out as an .xml file to disk

Return Value

an appropriately derived property instance

See Also

Property Class | StarTeam Namespace


Property.GetDisplayValue Method

Converts the given property value to a string suitable for display.

public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

Property Class | StarTeam Namespace


Property.GetHashCode Method

Delegate GetHashCode() to com.starteam.Property.

public override int GetHashCode();

Return Value

com.starteam.Property.GetHashCode().

See Also

Property Class | StarTeam Namespace


Property.IsEqualTo Method

Compares two Property objects.

The parent Types are compared by ClassID.

For enumerated properties, the enumerated values are compared using a deep comparison.

For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.

public virtual bool IsEqualTo(
Property property
);

Parameters

property
the property to compare

Return Value

true if no differences were found.

See Also

Property Class | StarTeam Namespace | copy


Property.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

Property Class | StarTeam Namespace


Property.IsQueryRelationSupported Method

public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

Property Class | StarTeam Namespace


Property.ResolveAllDependencies Method

This will return the full set of dependent properties based on the specified set. The returned set will include the specified properties. The returned set will not have duplicate elements.

public static PropertyCollection ResolveAllDependencies(
PropertyCollection props
);

Parameters

props
the properties whose dependencies are to be computed

See Also

Property Class | StarTeam Namespace | getDependentProperties


Property.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

public virtual void SetDescriptor();

See Also

Property Class | StarTeam Namespace


Property.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

public virtual void SetPrimaryDescriptor();

See Also

Property Class | StarTeam Namespace


Property.ToString Method

Delegate ToString() to com.starteam.Property.

public override string ToString();

Return Value

com.starteam.Property.ToString()

See Also

Property Class | StarTeam Namespace


Property.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

public virtual string ToXml();

Return Value

an xml representation of this property

See Also

Property Class | StarTeam Namespace


Property.Update Method

If this property is new or dirty, saves changes to the repository

public virtual void Update();

See Also

Property Class | StarTeam Namespace


Property.MetaData Class

For a list of all members of this type, see Property.MetaData Members.

System.Object
Property.MetaData

public class Property.MetaData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Property.MetaData Members | StarTeam Namespace


Property.MetaData Members

Property.MetaData overview

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Property.MetaData.
GetHashCode | Delegate GetHashCode() to com.starteam.Property.MetaData.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Property.MetaData.

See Also

Property.MetaData Class | StarTeam Namespace


Property.MetaData Methods

The methods of the Property.MetaData class are listed below. For a complete list of Property.MetaData class members, see the Property.MetaData Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Property.MetaData.
GetHashCode | Delegate GetHashCode() to com.starteam.Property.MetaData.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Property.MetaData.

See Also

Property.MetaData Class | StarTeam Namespace


Property.MetaData.Equals Method

Delegate Equals() to com.starteam.Property.MetaData.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Property.MetaData.Equals(obj).

See Also

Property.MetaData Class | StarTeam Namespace


Property.MetaData.GetHashCode Method

Delegate GetHashCode() to com.starteam.Property.MetaData.

public override int GetHashCode();

Return Value

com.starteam.Property.MetaData.GetHashCode().

See Also

Property.MetaData Class | StarTeam Namespace


Property.MetaData.ToString Method

Delegate ToString() to com.starteam.Property.MetaData.

public override string ToString();

Return Value

com.starteam.Property.MetaData.ToString()

See Also

Property.MetaData Class | StarTeam Namespace


Property.WebCacheProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see Property.WebCacheProperty Members.

System.Object
Property.WebCacheProperty
Derived types

public class Property.WebCacheProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Property.WebCacheProperty Members | StarTeam Namespace


Property.WebCacheProperty Members

Property.WebCacheProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | [read/write] the property's default value.
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Property.WebCacheProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Property.WebCacheProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Property.WebCacheProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty Properties

The properties of the Property.WebCacheProperty class are listed below. For a complete list of Property.WebCacheProperty class members, see the Property.WebCacheProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | [read/write] the property's default value.
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.Context Property

[read] the context of this object.

public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.DefaultValue Property

[read/write] the property's default value.

public virtual Object DefaultValue {get; set;}

Property Value

the property's default value.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.DisplayName Property

[read/write] this property's display name.

public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

Property.WebCacheProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.ID Property

[read] the ID of the underlying object

public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsAdvanced Property

[read] true if the property is considered advanced.

public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsClientCalculated Property

[read] true if the property is client calculated.

public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsDescriptor Property

[read] true is this property is a descriptor.

public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsDirty Property

[read] true if this object is dirty

public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsRestricted Property

[read] true if this is a restricted property.

public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsServerCalculated Property

[read] true if the property if server calculated.

public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsSortByTextValueSupported Property

[read] boolean

public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsStored Property

[read] true if the property is stored in the server's database.

public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsUserDefined Property

[read] true if the property is user defined.

public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.MyType Property

[read] the type of this resource.

public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.Name Property

public virtual String Name {get;}

See Also

Property.WebCacheProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Property.WebCacheProperty.NameProperty Property

public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty Methods

The methods of the Property.WebCacheProperty class are listed below. For a complete list of Property.WebCacheProperty class members, see the Property.WebCacheProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Property.WebCacheProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Property.WebCacheProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Property.WebCacheProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.Equals Method

Delegate Equals() to com.starteam.Property.WebCacheProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Property.WebCacheProperty.Equals(obj).

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Property.WebCacheProperty.

public override int GetHashCode();

Return Value

com.starteam.Property.WebCacheProperty.GetHashCode().

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.IsQueryRelationSupported Method

public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

public virtual void Refresh();

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

public virtual void SetDescriptor();

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

public virtual void SetPrimaryDescriptor();

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.ToString Method

Delegate ToString() to com.starteam.Property.WebCacheProperty.

public override string ToString();

Return Value

com.starteam.Property.WebCacheProperty.ToString()

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

public virtual string ToXml();

Return Value

an xml representation of this property

See Also

Property.WebCacheProperty Class | StarTeam Namespace


Property.WebCacheProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

public virtual void Update();

See Also

Property.WebCacheProperty Class | StarTeam Namespace


PropertyCollection Class

A Collection of Properties supported by a specific Type

For a list of all members of this type, see PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
Derived types

public class PropertyCollection : StarTeamCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PropertyCollection Members | StarTeam Namespace


PropertyCollection Members

PropertyCollection overview

Public Instance Constructors

PropertyCollection Overloaded. Initializes a new instance of the PropertyCollection class.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type | [read] the Type associated with this set of properties

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

PropertyCollection Class | StarTeam Namespace


PropertyCollection Constructor

Construct a empty collection of properties

Overload List

Construct a empty collection of properties

public PropertyCollection();

Construct a collection of properties containing only the given property

public PropertyCollection(Property);

Construct a collection of properties consisting of all the properties in the given array

public PropertyCollection(Property[]);

See Also

PropertyCollection Class | StarTeam Namespace


PropertyCollection Constructor ()

Construct a empty collection of properties

public PropertyCollection();

See Also

PropertyCollection Class | StarTeam Namespace | PropertyCollection Constructor Overload List


PropertyCollection Constructor (Property)

Construct a collection of properties containing only the given property

public PropertyCollection(
Property p
);

Parameters

p
the property to add to the collection

See Also

PropertyCollection Class | StarTeam Namespace | PropertyCollection Constructor Overload List


PropertyCollection Constructor (Property[])

Construct a collection of properties consisting of all the properties in the given array

public PropertyCollection(
Property[] pp
);

Parameters

pp
an array of properties to add to the collection

See Also

PropertyCollection Class | StarTeam Namespace | PropertyCollection Constructor Overload List


PropertyCollection Properties

The properties of the PropertyCollection class are listed below. For a complete list of PropertyCollection class members, see the PropertyCollection Members topic.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type | [read] the Type associated with this set of properties

See Also

PropertyCollection Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

PropertyCollection.Type Property

[read] the Type associated with this set of properties

public virtual Type Type {get;}

Property Value

the Type associated with this set of properties

See Also

PropertyCollection Class | StarTeam Namespace


PropertyCollection Methods

The methods of the PropertyCollection class are listed below. For a complete list of PropertyCollection class members, see the PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

PropertyCollection Class | StarTeam Namespace


Find Method

Borland StarTeam SDK for .NET

PropertyCollection.Find Method

Return the Property object belonging to this type with the specified property ID. This will return null if the property is not found.

Overload List

Return the Property object belonging to this type with the specified property ID. This will return null if the property is not found.

public virtual Property Find(Int32);

Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.

public virtual Property Find(String);

See Also

PropertyCollection Class | StarTeam Namespace | getID


PropertyCollection.Find Method (Int32)

Return the Property object belonging to this type with the specified property ID. This will return null if the property is not found.

public virtual Property Find(
Int32 propertyID
);

Parameters

propertyID
the property ID of the desired Property object

Return Value

the property with the specified ID or NULL if none exists

See Also

PropertyCollection Class | StarTeam Namespace | PropertyCollection.Find Overload List | getID


PropertyCollection.Find Method (String)

Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.

public virtual Property Find(
String propertyName
);

Parameters

propertyName
the name of the desired Property object

Return Value

the property with the specified name or NULL if none exists

Exceptions

Exception Type | Condition
 | System.ArgumentException

See Also

PropertyCollection Class | StarTeam Namespace | PropertyCollection.Find Overload List | getName


PurgeController Class

Provides control of the Online Purge service. The service may be configured to start automatically when the server starts up. If configured to do so, it will run a purge in the background while the server is running. This eliminates the requirement for costly down time just to purge the starteam repository. The online purge will not affect any resources deleted during the current active server session. Access the purge log by issuing a writeLogFile command with a logType value of 1.

For a list of all members of this type, see PurgeController Members.

System.Object
PurgeController

public class PurgeController

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PurgeController Members | StarTeam Namespace


PurgeController Members

PurgeController overview

Public Instance Properties

PurgeStatus [read] the status of the Purge Service (Ready , In Progress, Completed, Error)

Public Instance Methods

Equals | Delegate Equals() to com.starteam.PurgeController.
GetHashCode | Delegate GetHashCode() to com.starteam.PurgeController.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Start the online purge service
Stop | Stop the online purge service.
ToString | Delegate ToString() to com.starteam.PurgeController.

See Also

PurgeController Class | StarTeam Namespace


PurgeController Properties

The properties of the PurgeController class are listed below. For a complete list of PurgeController class members, see the PurgeController Members topic.

Public Instance Properties

PurgeStatus [read] the status of the Purge Service (Ready , In Progress, Completed, Error)

See Also

PurgeController Class | StarTeam Namespace


PurgeStatus Property

Borland StarTeam SDK for .NET

PurgeController.PurgeStatus Property

[read] the status of the Purge Service (Ready , In Progress, Completed, Error)

public virtual PurgeController.Status PurgeStatus {get;}

Property Value

the status of the Purge Service (Ready , In Progress, Completed, Error)

See Also

PurgeController Class | StarTeam Namespace


PurgeController Methods

The methods of the PurgeController class are listed below. For a complete list of PurgeController class members, see the PurgeController Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.PurgeController.
GetHashCode | Delegate GetHashCode() to com.starteam.PurgeController.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Start the online purge service
Stop | Stop the online purge service.
ToString | Delegate ToString() to com.starteam.PurgeController.

See Also

PurgeController Class | StarTeam Namespace


PurgeController.Equals Method

Delegate Equals() to com.starteam.PurgeController.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PurgeController.Equals(obj).

See Also

PurgeController Class | StarTeam Namespace


PurgeController.GetHashCode Method

Delegate GetHashCode() to com.starteam.PurgeController.

public override int GetHashCode();

Return Value

com.starteam.PurgeController.GetHashCode().

See Also

PurgeController Class | StarTeam Namespace


PurgeController.Start Method

Start the online purge service

public virtual Status Start();

Return Value

the status of the start request

See Also

PurgeController Class | StarTeam Namespace


PurgeController.Stop Method

Stop the online purge service.

public virtual Status Stop();

Return Value

the status of the stop request

See Also

PurgeController Class | StarTeam Namespace


PurgeController.ToString Method

Delegate ToString() to com.starteam.PurgeController.

public override string ToString();

Return Value

com.starteam.PurgeController.ToString()

See Also

PurgeController Class | StarTeam Namespace


PurgeController.Status Class

Describes the current state of the purge service

For a list of all members of this type, see PurgeController.Status Members.

System.Object
PurgeController.Status

public class PurgeController.Status

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

PurgeController.Status Members | StarTeam Namespace


PurgeController.Status Members

PurgeController.Status overview

Public Static Properties

All | [read] MergeAction[] an array of all Status instances
COMPLETED |
FAILED |
IN_PROGRESS |
READY |
STOPPING |

Public Instance Properties

Name | [read] a description of the status of the purge.
Value | [read] the status of the purge.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.PurgeController.Status.
GetHashCode | Delegate GetHashCode() to com.starteam.PurgeController.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.PurgeController.Status.

See Also

PurgeController.Status Class | StarTeam Namespace


PurgeController.Status Properties

The properties of the PurgeController.Status class are listed below. For a complete list of PurgeController.Status class members, see the PurgeController.Status Members topic.

Public Static Properties

All | [read] MergeAction[] an array of all Status instances
COMPLETED |
FAILED |
IN_PROGRESS |
READY |
STOPPING |

Public Instance Properties

Name | [read] a description of the status of the purge.
Value | [read] the status of the purge.

See Also

PurgeController.Status Class | StarTeam Namespace


All Property

Borland StarTeam SDK for .NET

PurgeController.Status.All Property

[read] MergeAction[] an array of all Status instances

public static Status[] All {get;}

Property Value

MergeAction[] an array of all Status instances

See Also

PurgeController.Status Class | StarTeam Namespace


COMPLETED Property

Borland StarTeam SDK for .NET

PurgeController.Status.COMPLETED Property

public static PurgeController.Status COMPLETED {get;}

Property Value

Specifies that the service has completed.

See Also

PurgeController.Status Class | StarTeam Namespace


FAILED Property

Borland StarTeam SDK for .NET

PurgeController.Status.FAILED Property

public static PurgeController.Status FAILED {get;}

Property Value

Specifies that the service has failed.

See Also

PurgeController.Status Class | StarTeam Namespace


IN_PROGRESS Property

Borland StarTeam SDK for .NET

PurgeController.Status.IN_PROGRESS Property

public static PurgeController.Status IN_PROGRESS {get;}

Property Value

Specifies that the service is running.

See Also

PurgeController.Status Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

PurgeController.Status.Name Property

[read] a description of the status of the purge.

public virtual String Name {get;}

Property Value

a description of the status of the purge.

See Also

PurgeController.Status Class | StarTeam Namespace


READY Property

Borland StarTeam SDK for .NET

PurgeController.Status.READY Property

public static PurgeController.Status READY {get;}

Property Value

Specifies that the service is ready to start.

See Also

PurgeController.Status Class | StarTeam Namespace


STOPPING Property

Borland StarTeam SDK for .NET

PurgeController.Status.STOPPING Property

public static PurgeController.Status STOPPING {get;}

Property Value

Specifies that the service is stopping.

See Also

PurgeController.Status Class | StarTeam Namespace


Value Property

Borland StarTeam SDK for .NET

PurgeController.Status.Value Property

[read] the status of the purge.

public virtual Int32 Value {get;}

Property Value

the status of the purge.

See Also

PurgeController.Status Class | StarTeam Namespace


PurgeController.Status Methods

The methods of the PurgeController.Status class are listed below. For a complete list of PurgeController.Status class members, see the PurgeController.Status Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.PurgeController.Status.
GetHashCode | Delegate GetHashCode() to com.starteam.PurgeController.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.PurgeController.Status.

See Also

PurgeController.Status Class | StarTeam Namespace


PurgeController.Status.Equals Method

Delegate Equals() to com.starteam.PurgeController.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.PurgeController.Status.Equals(obj).

See Also

PurgeController.Status Class | StarTeam Namespace


PurgeController.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.PurgeController.Status.

public override int GetHashCode();

Return Value

com.starteam.PurgeController.Status.GetHashCode().

See Also

PurgeController.Status Class | StarTeam Namespace


PurgeController.Status.ToString Method

Delegate ToString() to com.starteam.PurgeController.Status.

public override string ToString();

Return Value

com.starteam.PurgeController.Status.ToString()

See Also

PurgeController.Status Class | StarTeam Namespace


Query Class

The Query class implements a query condition to be applied to items of a certain type. Query objects are used in conjunction with Filter objects for describing what items to display to the user and how to display them.

For a list of all members of this type, see Query Members.

System.Object
NamedCacheRef
Query

public class Query : NamedCacheRef, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Query Members | StarTeam Namespace


Query Members

Query overview

Public Instance Constructors

Query Constructor

Public Instance Properties

CreatedBy | [read] the User Object who created this query.
CreatedTime | [read] the created time of this query.
DebugString | [read] a debug string for this query.
ID | [read] internal query ID
IsDeleted | [read] true if this query has been deleted.
IsDirty | [read] true if the query has unsaved modifications.
IsNew | [read] true if this query is newly created and not yet saved in the repository.
IsPublic | [read] true if the query is publicly visible.
ModifiedBy | [read] the user who last modified this query. This property is available starting from the 12.5 release of the Starteam server.
ModifiedTime | [read] the last modified time of this query. This property is available starting from the 12.5 release of the Starteam server.
MyType | [read] the type for this query.
Name | [read/write] the name of the query.
OwnedBy | [read] the user who owns this query.
ParentContainer | [read] This object's parent container.
PresentationID | [read] the unique integer identifier for this query.
Projects | [read/write] the set of projects associated with this query
Properties | [read]
QueryNode | [read/write] the boolean expression defining this query.
Rights | [read/write] the access control list for this query or NULL.
Server | [read] Server the Server instance for this Query

Public Instance Methods

Copy | Creates a copy of this Query object. Useful to applications that want to save a snapshot of the query in a given state, for example, before calling Type.refreshFiltersAndQueries().
Delete | Deletes this query from the repository.
Equals (inherited from NamedCacheRef) | Delegate Equals() to com.starteam.NamedCacheRef.
Evaluate |
GetHashCode (inherited from NamedCacheRef) | Delegate GetHashCode() to com.starteam.NamedCacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermissions | Returns true if desired permissions are granted for this query.
IsEqualTo | Compares two Query objects.
MakePrivate | Make this query public. You must call update() to make the change take take effect.
MakePublic | Make this query public. You must call update() to make the change take take effect.
ToString (inherited from NamedCacheRef) | Delegate ToString() to com.starteam.NamedCacheRef.
Update | Store this query in the repository. If the query is new then a new query will be added, if it exists then it will be modified. It is possible that the ID (getID()) for the query will change after calling this method even for an existing query. This method cannot be called on a deleted query.

See Also

Query Class | StarTeam Namespace


Query Constructor

public Query(
ViewMember.Type type,
Boolean bPublic,
String name,
QueryNode node
);

See Also

Query Class | StarTeam Namespace


Query Properties

The properties of the Query class are listed below. For a complete list of Query class members, see the Query Members topic.

Public Instance Properties

CreatedBy | [read] the User Object who created this query.
CreatedTime | [read] the created time of this query.
DebugString | [read] a debug string for this query.
ID | [read] internal query ID
IsDeleted | [read] true if this query has been deleted.
IsDirty | [read] true if the query has unsaved modifications.
IsNew | [read] true if this query is newly created and not yet saved in the repository.
IsPublic | [read] true if the query is publicly visible.
ModifiedBy | [read] the user who last modified this query. This property is available starting from the 12.5 release of the Starteam server.
ModifiedTime | [read] the last modified time of this query. This property is available starting from the 12.5 release of the Starteam server.
MyType | [read] the type for this query.
Name | [read/write] the name of the query.
OwnedBy | [read] the user who owns this query.
ParentContainer | [read] This object's parent container.
PresentationID | [read] the unique integer identifier for this query.
Projects | [read/write] the set of projects associated with this query
Properties | [read]
QueryNode | [read/write] the boolean expression defining this query.
Rights | [read/write] the access control list for this query or NULL.
Server | [read] Server the Server instance for this Query

See Also

Query Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Query.CreatedBy Property

[read] the User Object who created this query.

public virtual User CreatedBy {get;}

Property Value

the User Object who created this query.

See Also

Query Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Query.CreatedTime Property

[read] the created time of this query.

public virtual DateTime CreatedTime {get;}

Property Value

the created time of this query.

See Also

Query Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Query.DebugString Property

[read] a debug string for this query.

public virtual String DebugString {get;}

Property Value

a debug string for this query.

See Also

Query Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Query.ID Property

[read] internal query ID

public virtual Int32 ID {get;}

Property Value

internal query ID

Implements

ISecurable.ID

See Also

Query Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Query.IsDeleted Property

[read] true if this query has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if this query has been deleted.

Implements

ISecurable.IsDeleted

See Also

Query Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Query.IsDirty Property

[read] true if the query has unsaved modifications.

public virtual Boolean IsDirty {get;}

Property Value

true if the query has unsaved modifications.

See Also

Query Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Query.IsNew Property

[read] true if this query is newly created and not yet saved in the repository.

public virtual Boolean IsNew {get;}

Property Value

true if this query is newly created and not yet saved in the repository.

See Also

Query Class | StarTeam Namespace


IsPublic Property

Borland StarTeam SDK for .NET

Query.IsPublic Property

[read] true if the query is publicly visible.

public virtual Boolean IsPublic {get;}

Property Value

true if the query is publicly visible.

See Also

Query Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Query.ModifiedBy Property

[read] the user who last modified this query. This property is available starting from the 12.5 release of the Starteam server.

public virtual User ModifiedBy {get;}

Property Value

the user who last modified this query. This property is available starting from the 12.5 release of the Starteam server.

See Also

Query Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Query.ModifiedTime Property

[read] the last modified time of this query. This property is available starting from the 12.5 release of the Starteam server.

public virtual DateTime ModifiedTime {get;}

Property Value

the last modified time of this query. This property is available starting from the 12.5 release of the Starteam server.

See Also

Query Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Query.MyType Property

[read] the type for this query.

public virtual Type MyType {get;}

Property Value

the type for this query.

Implements

ISecurable.MyType

See Also

Query Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Query.Name Property

[read/write] the name of the query.

public virtual String Name {get; set;}

Property Value

the name of the query.

See Also

Query Class | StarTeam Namespace


OwnedBy Property

Borland StarTeam SDK for .NET

Query.OwnedBy Property

[read] the user who owns this query.

public virtual User OwnedBy {get;}

Property Value

the user who owns this query.

See Also

Query Class | StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

Query.ParentContainer Property

[read] This object's parent container.

public virtual ISecurableContainer ParentContainer {get;}

Property Value

This object's parent container.

Implements

ISecurable.ParentContainer

See Also

Query Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Query.PresentationID Property

[read] the unique integer identifier for this query.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this query.

See Also

Query Class | StarTeam Namespace


Projects Property

Borland StarTeam SDK for .NET

Query.Projects Property

[read/write] the set of projects associated with this query

public virtual Project[] Projects {get; set;}

Property Value

the set of projects associated with this query

See Also

Query Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Query.Properties Property

[read]

public virtual PropertyCollection Properties {get;}

See Also

Query Class | StarTeam Namespace


QueryNode Property

Borland StarTeam SDK for .NET

Query.QueryNode Property

[read/write] the boolean expression defining this query.

public virtual QueryNode QueryNode {get; set;}

Property Value

the boolean expression defining this query.

See Also

Query Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Query.Rights Property

[read/write] the access control list for this query or NULL.

public virtual ACE[] Rights {get; set;}

Property Value

the access control list for this query or NULL.

Implements

ISecurable.Rights

See Also

Query Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Query.Server Property

[read] Server the Server instance for this Query

public virtual Server Server {get;}

Property Value

Server the Server instance for this Query

Implements

ISecurable.Server

See Also

Query Class | StarTeam Namespace


Query Methods

The methods of the Query class are listed below. For a complete list of Query class members, see the Query Members topic.

Public Instance Methods

Copy | Creates a copy of this Query object. Useful to applications that want to save a snapshot of the query in a given state, for example, before calling Type.refreshFiltersAndQueries().
Delete | Deletes this query from the repository.
Equals (inherited from NamedCacheRef) | Delegate Equals() to com.starteam.NamedCacheRef.
Evaluate |
GetHashCode (inherited from NamedCacheRef) | Delegate GetHashCode() to com.starteam.NamedCacheRef.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermissions | Returns true if desired permissions are granted for this query.
IsEqualTo | Compares two Query objects.
MakePrivate | Make this query public. You must call update() to make the change take take effect.
MakePublic | Make this query public. You must call update() to make the change take take effect.
ToString (inherited from NamedCacheRef) | Delegate ToString() to com.starteam.NamedCacheRef.
Update | Store this query in the repository. If the query is new then a new query will be added, if it exists then it will be modified. It is possible that the ID (getID()) for the query will change after calling this method even for an existing query. This method cannot be called on a deleted query.

See Also

Query Class | StarTeam Namespace


Query.Copy Method

Creates a copy of this Query object. Useful to applications that want to save a snapshot of the query in a given state, for example, before calling Type.refreshFiltersAndQueries().

public virtual Query Copy();

Return Value

A copy of this Query object.

See Also

Query Class | StarTeam Namespace | isEqualTo


Query.Delete Method

Deletes this query from the repository.

public virtual void Delete();

See Also

Query Class | StarTeam Namespace


Query.Evaluate Method

public virtual bool Evaluate(
Query.Context context,
ViewMember viewMember
);

See Also

Query Class | StarTeam Namespace


Query.HasPermissions Method

Returns true if desired permissions are granted for this query.

public virtual bool HasPermissions(
PermissionCollection permissions
);

Parameters

permissions
the desired permissions

Implements

ISecurable.HasPermissions

See Also

Query Class | StarTeam Namespace | Permission


Query.IsEqualTo Method

Compares two Query objects.

public virtual bool IsEqualTo(
Query query
);

Parameters

query
The Query to be compared with this one.

Return Value

true if no differences were found.

See Also

Query Class | StarTeam Namespace | copy


Query.MakePrivate Method

Make this query public. You must call update() to make the change take take effect.

public virtual void MakePrivate(
User u
);

Parameters

u

See Also

Query Class | StarTeam Namespace


Query.MakePublic Method

Make this query public. You must call update() to make the change take take effect.

public virtual void MakePublic();

See Also

Query Class | StarTeam Namespace


Query.Update Method

Store this query in the repository. If the query is new then a new query will be added, if it exists then it will be modified. It is possible that the ID (getID()) for the query will change after calling this method even for an existing query. This method cannot be called on a deleted query.

public virtual void Update();

See Also

Query Class | StarTeam Namespace


Query.Context Class

User context for evaluating the query

For a list of all members of this type, see Query.Context Members.

System.Object
Query.Context

public class Query.Context

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Query.Context Members | StarTeam Namespace


Query.Context Members

Query.Context overview

Public Instance Constructors

Query.Context Constructor Create a Context in which this query may be executed This is particularly useful for evaluating queries specific to a user such as 'All Change Requests Assigned to me'

Public Instance Properties

Me [read] User the user context to be used when evaluating "me" queries.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Query.Context.
GetHashCode | Delegate GetHashCode() to com.starteam.Query.Context.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Query.Context.

See Also

Query.Context Class | StarTeam Namespace


Query.Context Constructor

Create a Context in which this query may be executed This is particularly useful for evaluating queries specific to a user such as 'All Change Requests Assigned to me'

public Query.Context(
User user
);

Parameters

user
a user in whose context the query will be executed

See Also

Query.Context Class | StarTeam Namespace


Query.Context Properties

The properties of the Query.Context class are listed below. For a complete list of Query.Context class members, see the Query.Context Members topic.

Public Instance Properties

Me [read] User the user context to be used when evaluating "me" queries.

See Also

Query.Context Class | StarTeam Namespace


Me Property

Borland StarTeam SDK for .NET

Query.Context.Me Property

[read] User the user context to be used when evaluating "me" queries.

public virtual User Me {get;}

Property Value

User the user context to be used when evaluating "me" queries.

See Also

Query.Context Class | StarTeam Namespace


Query.Context Methods

The methods of the Query.Context class are listed below. For a complete list of Query.Context class members, see the Query.Context Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Query.Context.
GetHashCode | Delegate GetHashCode() to com.starteam.Query.Context.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Query.Context.

See Also

Query.Context Class | StarTeam Namespace


Query.Context.Equals Method

Delegate Equals() to com.starteam.Query.Context.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Query.Context.Equals(obj).

See Also

Query.Context Class | StarTeam Namespace


Query.Context.GetHashCode Method

Delegate GetHashCode() to com.starteam.Query.Context.

public override int GetHashCode();

Return Value

com.starteam.Query.Context.GetHashCode().

See Also

Query.Context Class | StarTeam Namespace


Query.Context.ToString Method

Delegate ToString() to com.starteam.Query.Context.

public override string ToString();

Return Value

com.starteam.Query.Context.ToString()

See Also

Query.Context Class | StarTeam Namespace


Query.WebCacheQuery Class

Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see Query.WebCacheQuery Members.

System.Object
Query.WebCacheQuery

public class Query.WebCacheQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Query.WebCacheQuery Members | StarTeam Namespace


Query.WebCacheQuery Members

Query.WebCacheQuery overview

Public Static Methods

Create

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] the user who created this query.
CreatedTime | [read] the created time of this query.
ID | [read] the internal ID of the filter
IsDeleted | [read] true if this query has been deleted
IsDirty | [read] true if this object is dirty
IsPublic | [read] true if the query is publicly visible.
ModifiedBy | [read] the user who last modified this query.
ModifiedTime | [read] the last modified time of this query.
MyType | [read] the type for this query.
Name | [read/write] the display name of the query.
OwnedBy | [read] the user who owns this query.
PresentationID | [read] the unique integer identifier for this query.
Projects | [read/write] projects (associated with this query) visible in the current user context
Properties | [read]
QueryNode | [read/write] the boolean expression defining this query.
Rights | [read/write] the access rights assigned to this query
Server | [read] the Server for this cached object

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Query.WebCacheQuery.
Evaluate |
GetHashCode | Delegate GetHashCode() to com.starteam.Query.WebCacheQuery.
GetType (inherited from Object) | Gets the Type of the current instance.
MakePrivate |
MakePublic | Make this query public. You must call update() to make the change take take effect.
Remove | Remove this Query from the repository This is an atomic operation, and cannot be executed in a transaction
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Query.WebCacheQuery.
Update | Save this dirty Filter to the Repository This is an atomic operation, not executed in a transaction

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery Properties

The properties of the Query.WebCacheQuery class are listed below. For a complete list of Query.WebCacheQuery class members, see the Query.WebCacheQuery Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] the user who created this query.
CreatedTime | [read] the created time of this query.
ID | [read] the internal ID of the filter
IsDeleted | [read] true if this query has been deleted
IsDirty | [read] true if this object is dirty
IsPublic | [read] true if the query is publicly visible.
ModifiedBy | [read] the user who last modified this query.
ModifiedTime | [read] the last modified time of this query.
MyType | [read] the type for this query.
Name | [read/write] the display name of the query.
OwnedBy | [read] the user who owns this query.
PresentationID | [read] the unique integer identifier for this query.
Projects | [read/write] projects (associated with this query) visible in the current user context
Properties | [read]
QueryNode | [read/write] the boolean expression defining this query.
Rights | [read/write] the access rights assigned to this query
Server | [read] the Server for this cached object

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.Context Property

[read] the context of this object.

public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.CreatedBy Property

[read] the user who created this query.

public virtual User.WebCacheUser CreatedBy {get;}

Property Value

the user who created this query.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.CreatedTime Property

[read] the created time of this query.

public virtual DateTime CreatedTime {get;}

Property Value

the created time of this query.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.ID Property

[read] the internal ID of the filter

public virtual Int32 ID {get;}

Property Value

the internal ID of the filter

See Also

Query.WebCacheQuery Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.IsDeleted Property

[read] true if this query has been deleted

public virtual Boolean IsDeleted {get;}

Property Value

true if this query has been deleted

See Also

Query.WebCacheQuery Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.IsDirty Property

[read] true if this object is dirty

public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Query.WebCacheQuery Class | StarTeam Namespace


IsPublic Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.IsPublic Property

[read] true if the query is publicly visible.

public virtual Boolean IsPublic {get;}

Property Value

true if the query is publicly visible.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.ModifiedBy Property

[read] the user who last modified this query.

public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

the user who last modified this query.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.ModifiedTime Property

[read] the last modified time of this query.

public virtual DateTime ModifiedTime {get;}

Property Value

the last modified time of this query.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.MyType Property

[read] the type for this query.

public virtual Type.WebCacheType MyType {get;}

Property Value

the type for this query.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.Name Property

[read/write] the display name of the query.

public virtual String Name {get; set;}

Property Value

the display name of the query.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


OwnedBy Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.OwnedBy Property

[read] the user who owns this query.

public virtual User.WebCacheUser OwnedBy {get;}

Property Value

the user who owns this query.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.PresentationID Property

[read] the unique integer identifier for this query.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this query.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Projects Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.Projects Property

[read/write] projects (associated with this query) visible in the current user context

public virtual WebCacheProject[] Projects {get; set;}

Property Value

projects (associated with this query) visible in the current user context

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.Properties Property

[read]

public virtual WebCacheProperty[] Properties {get;}

See Also

Query.WebCacheQuery Class | StarTeam Namespace


QueryNode Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.QueryNode Property

[read/write] the boolean expression defining this query.

public virtual QueryNode.WebCacheQueryNode QueryNode {get; set;}

Property Value

the boolean expression defining this query.

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.Rights Property

[read/write] the access rights assigned to this query

public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this query

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Query.WebCacheQuery.Server Property

[read] the Server for this cached object

public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery Methods

The methods of the Query.WebCacheQuery class are listed below. For a complete list of Query.WebCacheQuery class members, see the Query.WebCacheQuery Members topic.

Public Static Methods

Create

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Query.WebCacheQuery.
Evaluate |
GetHashCode | Delegate GetHashCode() to com.starteam.Query.WebCacheQuery.
GetType (inherited from Object) | Gets the Type of the current instance.
MakePrivate |
MakePublic | Make this query public. You must call update() to make the change take take effect.
Remove | Remove this Query from the repository This is an atomic operation, and cannot be executed in a transaction
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Query.WebCacheQuery.
Update | Save this dirty Filter to the Repository This is an atomic operation, not executed in a transaction

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.Create Method

public static WebCacheQuery Create(
ArtifactCacheManager.Context cntxt,
ViewMember.Type.WebCacheViewMemberType type,
Boolean isPublic,
String name,
QueryNode.WebCacheQueryNode node
);

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.Equals Method

Delegate Equals() to com.starteam.Query.WebCacheQuery.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Query.WebCacheQuery.Equals(obj).

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.Evaluate Method

public virtual bool Evaluate(
ViewMember.WebCacheViewMember vm
);

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.GetHashCode Method

Delegate GetHashCode() to com.starteam.Query.WebCacheQuery.

public override int GetHashCode();

Return Value

com.starteam.Query.WebCacheQuery.GetHashCode().

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.MakePrivate Method

public virtual void MakePrivate(
User.WebCacheUser wcu
);

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.MakePublic Method

Make this query public. You must call update() to make the change take take effect.

public virtual void MakePublic();

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.Remove Method

Remove this Query from the repository This is an atomic operation, and cannot be executed in a transaction

public virtual void Remove();

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.ToString Method

Delegate ToString() to com.starteam.Query.WebCacheQuery.

public override string ToString();

Return Value

com.starteam.Query.WebCacheQuery.ToString()

See Also

Query.WebCacheQuery Class | StarTeam Namespace


Query.WebCacheQuery.Update Method

Save this dirty Filter to the Repository This is an atomic operation, not executed in a transaction

public virtual void Update();

See Also

Query.WebCacheQuery Class | StarTeam Namespace


QueryNode Class

A QueryNode represents a boolean expression. The expression is applied to an item to determine if the query is true of the item or not.

For a list of all members of this type, see QueryNode Members.

System.Object
QueryNode

public class QueryNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

QueryNode Members | StarTeam Namespace


QueryNode Members

QueryNode overview

Public Instance Constructors

QueryNode Constructor

Public Instance Properties

DebugString | [read] a debug string for this QueryNode.
OperatorValue | [read/write]
QueryNodes | [read/write] the QueryNodes associated with this QueryNode.
QueryParts | [read/write] the QueryParts associated with this QueryNode.

Public Instance Methods

AppendQueryNode | A convenience method to add a QueryNode at the end of the list.
AppendQueryPart | A convenience method to add a QueryParts at the end of the list.
ClearQueryNodes | A convenience method to remove all query nodes.
ClearQueryParts | A convenience method to remove all query parts.
CopyQueryNode | Returns a deep copy of this QueryNode.
Equals | Delegate Equals() to com.starteam.QueryNode.
Evaluate |
GetHashCode | Delegate GetHashCode() to com.starteam.QueryNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToDebugStringDepth | Returns a String with debug information about this QueryNode. You can specify the current indentation depth to use.
ToString | Delegate ToString() to com.starteam.QueryNode.

See Also

QueryNode Class | StarTeam Namespace


QueryNode Constructor

public QueryNode(
QueryNode.Operator anOperator
);

See Also

QueryNode Class | StarTeam Namespace


QueryNode Properties

The properties of the QueryNode class are listed below. For a complete list of QueryNode class members, see the QueryNode Members topic.

Public Instance Properties

DebugString | [read] a debug string for this QueryNode.
OperatorValue | [read/write]
QueryNodes | [read/write] the QueryNodes associated with this QueryNode.
QueryParts | [read/write] the QueryParts associated with this QueryNode.

See Also

QueryNode Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

QueryNode.DebugString Property

[read] a debug string for this QueryNode.

public virtual String DebugString {get;}

Property Value

a debug string for this QueryNode.

See Also

QueryNode Class | StarTeam Namespace


OperatorValue Property

Borland StarTeam SDK for .NET

QueryNode.OperatorValue Property

[read/write]

public virtual QueryNode.Operator OperatorValue {get; set;}

See Also

QueryNode Class | StarTeam Namespace


QueryNodes Property

Borland StarTeam SDK for .NET

QueryNode.QueryNodes Property

[read/write] the QueryNodes associated with this QueryNode.

public virtual QueryNode[] QueryNodes {get; set;}

Property Value

the QueryNodes associated with this QueryNode.

See Also

QueryNode Class | StarTeam Namespace


QueryParts Property

Borland StarTeam SDK for .NET

QueryNode.QueryParts Property

[read/write] the QueryParts associated with this QueryNode.

public virtual QueryPart[] QueryParts {get; set;}

Property Value

the QueryParts associated with this QueryNode.

See Also

QueryNode Class | StarTeam Namespace


QueryNode Methods

The methods of the QueryNode class are listed below. For a complete list of QueryNode class members, see the QueryNode Members topic.

Public Instance Methods

AppendQueryNode | A convenience method to add a QueryNode at the end of the list.
AppendQueryPart | A convenience method to add a QueryParts at the end of the list.
ClearQueryNodes | A convenience method to remove all query nodes.
ClearQueryParts | A convenience method to remove all query parts.
CopyQueryNode | Returns a deep copy of this QueryNode.
Equals | Delegate Equals() to com.starteam.QueryNode.
Evaluate |
GetHashCode | Delegate GetHashCode() to com.starteam.QueryNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToDebugStringDepth | Returns a String with debug information about this QueryNode. You can specify the current indentation depth to use.
ToString | Delegate ToString() to com.starteam.QueryNode.

See Also

QueryNode Class | StarTeam Namespace


QueryNode.AppendQueryNode Method

A convenience method to add a QueryNode at the end of the list.

public virtual void AppendQueryNode(
QueryNode node
);

Parameters

node
the QueryNode to append.

See Also

QueryNode Class | StarTeam Namespace


QueryNode.AppendQueryPart Method

A convenience method to add a QueryParts at the end of the list.

public virtual void AppendQueryPart(
QueryPart part
);

Parameters

part
the QueryPart to append

See Also

QueryNode Class | StarTeam Namespace


QueryNode.ClearQueryNodes Method

A convenience method to remove all query nodes.

public virtual void ClearQueryNodes();

See Also

QueryNode Class | StarTeam Namespace


QueryNode.ClearQueryParts Method

A convenience method to remove all query parts.

public virtual void ClearQueryParts();

See Also

QueryNode Class | StarTeam Namespace


QueryNode.CopyQueryNode Method

Returns a deep copy of this QueryNode.

public virtual QueryNode CopyQueryNode();

Return Value

a deep copy of this QueryNode

See Also

QueryNode Class | StarTeam Namespace


QueryNode.Equals Method

Delegate Equals() to com.starteam.QueryNode.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.QueryNode.Equals(obj).

See Also

QueryNode Class | StarTeam Namespace


QueryNode.Evaluate Method

public virtual bool Evaluate(
Query.Context context,
ViewMember viewMember
);

See Also

QueryNode Class | StarTeam Namespace


QueryNode.GetHashCode Method

Delegate GetHashCode() to com.starteam.QueryNode.

public override int GetHashCode();

Return Value

com.starteam.QueryNode.GetHashCode().

See Also

QueryNode Class | StarTeam Namespace


QueryNode.ToDebugStringDepth Method

Returns a String with debug information about this QueryNode. You can specify the current indentation depth to use.

public virtual string ToDebugStringDepth(
Int32 depth
);

Parameters

depth
the indentation depth to use. Typically you would pass int 0 for a top-level QueryNode.

Return Value

a debug string for this QueryNode.

See Also

QueryNode Class | StarTeam Namespace


QueryNode.ToString Method

Delegate ToString() to com.starteam.QueryNode.

public override string ToString();

Return Value

com.starteam.QueryNode.ToString()

See Also

QueryNode Class | StarTeam Namespace


QueryNode.Operator Class

The standard operands OR, AND and NOT

For a list of all members of this type, see QueryNode.Operator Members.

System.Object
QueryNode.Operator

public class QueryNode.Operator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

QueryNode.Operator Members | StarTeam Namespace


QueryNode.Operator Members

QueryNode.Operator overview

Public Static Properties

ALL
AND
NOT
OR

Public Static Methods

FromID Gets the Query Node operator corresponding to the given ID.

Public Instance Properties

ID [read] The ID of this Operator value.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.QueryNode.Operator.
GetHashCode | Delegate GetHashCode() to com.starteam.QueryNode.Operator.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryNode.Operator.

See Also

QueryNode.Operator Class | StarTeam Namespace


QueryNode.Operator Properties

The properties of the QueryNode.Operator class are listed below. For a complete list of QueryNode.Operator class members, see the QueryNode.Operator Members topic.

Public Static Properties

ALL
AND
NOT
OR

Public Instance Properties

ID [read] The ID of this Operator value.

See Also

QueryNode.Operator Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

QueryNode.Operator.ALL Property

public static Operator[] ALL {get;}

See Also

QueryNode.Operator Class | StarTeam Namespace


AND Property

Borland StarTeam SDK for .NET

QueryNode.Operator.AND Property

public static QueryNode.Operator AND {get;}

Property Value

A constant defining an AND query expression.

See Also

QueryNode.Operator Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

QueryNode.Operator.ID Property

[read] The ID of this Operator value.

public virtual Int32 ID {get;}

Property Value

The ID of this Operator value.

See Also

QueryNode.Operator Class | StarTeam Namespace


NOT Property

Borland StarTeam SDK for .NET

QueryNode.Operator.NOT Property

public static QueryNode.Operator NOT {get;}

Property Value

A constant defining a NOT query expression.

See Also

QueryNode.Operator Class | StarTeam Namespace


OR Property

Borland StarTeam SDK for .NET

QueryNode.Operator.OR Property

public static QueryNode.Operator OR {get;}

Property Value

A constant defining an OR query expression.

See Also

QueryNode.Operator Class | StarTeam Namespace


QueryNode.Operator Methods

The methods of the QueryNode.Operator class are listed below. For a complete list of QueryNode.Operator class members, see the QueryNode.Operator Members topic.

Public Static Methods

FromID Gets the Query Node operator corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.QueryNode.Operator.
GetHashCode | Delegate GetHashCode() to com.starteam.QueryNode.Operator.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryNode.Operator.

See Also

QueryNode.Operator Class | StarTeam Namespace


QueryNode.Operator.Equals Method

Delegate Equals() to com.starteam.QueryNode.Operator.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.QueryNode.Operator.Equals(obj).

See Also

QueryNode.Operator Class | StarTeam Namespace


QueryNode.Operator.FromID Method

Gets the Query Node operator corresponding to the given ID.

public static Operator FromID(
Int32 id
);

Parameters

id
The ID of an QueryNode.Operator#AND.

Return Value

The corresponding QueryNode.Operator#AND value, or null.

See Also

QueryNode.Operator Class | StarTeam Namespace


QueryNode.Operator.GetHashCode Method

Delegate GetHashCode() to com.starteam.QueryNode.Operator.

public override int GetHashCode();

Return Value

com.starteam.QueryNode.Operator.GetHashCode().

See Also

QueryNode.Operator Class | StarTeam Namespace


QueryNode.Operator.ToString Method

Delegate ToString() to com.starteam.QueryNode.Operator.

public override string ToString();

Return Value

com.starteam.QueryNode.Operator.ToString()

See Also

QueryNode.Operator Class | StarTeam Namespace


QueryNode.WebCacheQueryNode Class

A QueryNode represents a boolean expression. The expression is applied to an item to determine if the query is true of the item or not.

For a list of all members of this type, see QueryNode.WebCacheQueryNode Members.

System.Object
QueryNode.WebCacheQueryNode

public class QueryNode.WebCacheQueryNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

QueryNode.WebCacheQueryNode Members | StarTeam Namespace


QueryNode.WebCacheQueryNode Members

QueryNode.WebCacheQueryNode overview

Public Instance Constructors

QueryNode.WebCacheQueryNode Constructor

Public Instance Properties

OperatorValue | [read/write]
QueryNodes | [read/write] the QueryParts associated with this QueryNode.
QueryParts | [read/write] the QueryParts associated with this QueryNode.

Public Instance Methods

AppendQueryNode |
AppendQueryPart |
ClearQueryNodes | A convenience method to remove all query nodes.
ClearQueryParts | A convenience method to remove all query parts.
Equals | Delegate Equals() to com.starteam.QueryNode.WebCacheQueryNode.
GetHashCode | Delegate GetHashCode() to com.starteam.QueryNode.WebCacheQueryNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryNode.WebCacheQueryNode.

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode Constructor

public QueryNode.WebCacheQueryNode(
ArtifactCacheManager.Context cntxt,
QueryNode.Operator anOperator
);

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode Properties

The properties of the QueryNode.WebCacheQueryNode class are listed below. For a complete list of QueryNode.WebCacheQueryNode class members, see the QueryNode.WebCacheQueryNode Members topic.

Public Instance Properties

OperatorValue | [read/write]
QueryNodes | [read/write] the QueryParts associated with this QueryNode.
QueryParts | [read/write] the QueryParts associated with this QueryNode.

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


OperatorValue Property

Borland StarTeam SDK for .NET

QueryNode.WebCacheQueryNode.OperatorValue Property

[read/write]

public virtual QueryNode.Operator OperatorValue {get; set;}

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNodes Property

Borland StarTeam SDK for .NET

QueryNode.WebCacheQueryNode.QueryNodes Property

[read/write] the QueryParts associated with this QueryNode.

public virtual WebCacheQueryNode[] QueryNodes {get; set;}

Property Value

the QueryParts associated with this QueryNode.

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryParts Property

Borland StarTeam SDK for .NET

QueryNode.WebCacheQueryNode.QueryParts Property

[read/write] the QueryParts associated with this QueryNode.

public virtual WebCacheQueryPart[] QueryParts {get; set;}

Property Value

the QueryParts associated with this QueryNode.

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode Methods

The methods of the QueryNode.WebCacheQueryNode class are listed below. For a complete list of QueryNode.WebCacheQueryNode class members, see the QueryNode.WebCacheQueryNode Members topic.

Public Instance Methods

AppendQueryNode |
AppendQueryPart |
ClearQueryNodes | A convenience method to remove all query nodes.
ClearQueryParts | A convenience method to remove all query parts.
Equals | Delegate Equals() to com.starteam.QueryNode.WebCacheQueryNode.
GetHashCode | Delegate GetHashCode() to com.starteam.QueryNode.WebCacheQueryNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryNode.WebCacheQueryNode.

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode.AppendQueryNode Method

public virtual void AppendQueryNode(
QueryNode.WebCacheQueryNode node
);

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode.AppendQueryPart Method

public virtual void AppendQueryPart(
QueryPart.WebCacheQueryPart part
);

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode.ClearQueryNodes Method

A convenience method to remove all query nodes.

public virtual void ClearQueryNodes();

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode.ClearQueryParts Method

A convenience method to remove all query parts.

public virtual void ClearQueryParts();

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode.Equals Method

Delegate Equals() to com.starteam.QueryNode.WebCacheQueryNode.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.QueryNode.WebCacheQueryNode.Equals(obj).

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode.GetHashCode Method

Delegate GetHashCode() to com.starteam.QueryNode.WebCacheQueryNode.

public override int GetHashCode();

Return Value

com.starteam.QueryNode.WebCacheQueryNode.GetHashCode().

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryNode.WebCacheQueryNode.ToString Method

Delegate ToString() to com.starteam.QueryNode.WebCacheQueryNode.

public override string ToString();

Return Value

com.starteam.QueryNode.WebCacheQueryNode.ToString()

See Also

QueryNode.WebCacheQueryNode Class | StarTeam Namespace


QueryPart Class

A QueryPart object represents a boolean expression on the value of a particular property of an item. For example, it could be used to define query to match file objects whose name starts with a specific string.

For a list of all members of this type, see QueryPart Members.

System.Object
QueryPart

public class QueryPart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

QueryPart Members | StarTeam Namespace


QueryPart Members

QueryPart overview

Public Instance Properties

DebugString | [read] a debug string representation of this QueryPart.
IsCaseIgnored | [read/write] if case has been ignored while evaluating the expression
Property | [read] The property being tested by this query part.
RelationValue | [read/write]
Value | [read] value of the item property

Public Instance Methods

CopyQueryPart | Returns a copy of this QueryPart. It is a deep copy so the new one may be freely modified without affecting the original. The copy will be identical but for the ID which will be -1 for the new copy.
Equals | Delegate Equals() to com.starteam.QueryPart.
Evaluate |
EvaluateAgainst | Evaluate this QueryPart with respect to the specified value. The value must be of the appropriate type for the relation type. The possible types are Integer, Double, Date, DateTime, String, byte[] int[] and Map
GetHashCode | Delegate GetHashCode() to com.starteam.QueryPart.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryPart.

See Also

QueryPart Class | StarTeam Namespace


QueryPart Properties

The properties of the QueryPart class are listed below. For a complete list of QueryPart class members, see the QueryPart Members topic.

Public Instance Properties

DebugString | [read] a debug string representation of this QueryPart.
IsCaseIgnored | [read/write] if case has been ignored while evaluating the expression
Property | [read] The property being tested by this query part.
RelationValue | [read/write]
Value | [read] value of the item property

See Also

QueryPart Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

QueryPart.DebugString Property

[read] a debug string representation of this QueryPart.

public virtual String DebugString {get;}

Property Value

a debug string representation of this QueryPart.

See Also

QueryPart Class | StarTeam Namespace


IsCaseIgnored Property

Borland StarTeam SDK for .NET

QueryPart.IsCaseIgnored Property

[read/write] if case has been ignored while evaluating the expression

public virtual Boolean IsCaseIgnored {get; set;}

Property Value

if case has been ignored while evaluating the expression

See Also

QueryPart Class | StarTeam Namespace


Property Property

Borland StarTeam SDK for .NET

QueryPart.Property Property

[read] The property being tested by this query part.

public virtual Property Property {get;}

Property Value

The property being tested by this query part.

See Also

QueryPart Class | StarTeam Namespace


RelationValue Property

Borland StarTeam SDK for .NET

QueryPart.RelationValue Property

[read/write]

public virtual QueryPart.Relation RelationValue {get; set;}

See Also

QueryPart Class | StarTeam Namespace


Value Property

Borland StarTeam SDK for .NET

QueryPart.Value Property

[read] value of the item property

public virtual Object Value {get;}

Property Value

value of the item property

See Also

QueryPart Class | StarTeam Namespace


QueryPart Methods

The methods of the QueryPart class are listed below. For a complete list of QueryPart class members, see the QueryPart Members topic.

Public Instance Methods

CopyQueryPart | Returns a copy of this QueryPart. It is a deep copy so the new one may be freely modified without affecting the original. The copy will be identical but for the ID which will be -1 for the new copy.
Equals | Delegate Equals() to com.starteam.QueryPart.
Evaluate |
EvaluateAgainst | Evaluate this QueryPart with respect to the specified value. The value must be of the appropriate type for the relation type. The possible types are Integer, Double, Date, DateTime, String, byte[] int[] and Map
GetHashCode | Delegate GetHashCode() to com.starteam.QueryPart.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryPart.

See Also

QueryPart Class | StarTeam Namespace


QueryPart.CopyQueryPart Method

Returns a copy of this QueryPart. It is a deep copy so the new one may be freely modified without affecting the original. The copy will be identical but for the ID which will be -1 for the new copy.

public virtual QueryPart CopyQueryPart();

Return Value

a copy of this QueryPart

See Also

QueryPart Class | StarTeam Namespace


QueryPart.Equals Method

Delegate Equals() to com.starteam.QueryPart.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.QueryPart.Equals(obj).

See Also

QueryPart Class | StarTeam Namespace


QueryPart.Evaluate Method

public virtual bool Evaluate(
Query.Context context,
ViewMember viewMember
);

See Also

QueryPart Class | StarTeam Namespace


QueryPart.EvaluateAgainst Method

Evaluate this QueryPart with respect to the specified value. The value must be of the appropriate type for the relation type. The possible types are Integer, Double, Date, DateTime, String, byte[] int[] and Map

public virtual bool EvaluateAgainst(
Object value
);

Parameters

value
the value to test against

Return Value

true if the item satisfies the query and false otherwise.

See Also

QueryPart Class | StarTeam Namespace


QueryPart.GetHashCode Method

Delegate GetHashCode() to com.starteam.QueryPart.

public override int GetHashCode();

Return Value

com.starteam.QueryPart.GetHashCode().

See Also

QueryPart Class | StarTeam Namespace


QueryPart.ToString Method

Delegate ToString() to com.starteam.QueryPart.

public override string ToString();

Return Value

com.starteam.QueryPart.ToString()

See Also

QueryPart Class | StarTeam Namespace


QueryPart.Relation Class

Relations that can be used in the expression

For a list of all members of this type, see QueryPart.Relation Members.

System.Object
QueryPart.Relation

public class QueryPart.Relation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

QueryPart.Relation Members | StarTeam Namespace


QueryPart.Relation Members

QueryPart.Relation overview

Public Static Properties

ALL
CONTAINS
CONTAINS_KEY
CONTAINS_VALUE
DATE_OLDER_THAN_DAYS
DATE_OLDER_THAN_WEEKS
DATE_WITHIN_LAST_DAYS
DATE_WITHIN_LAST_WEEKS
EQUAL_TO
EXCLUDES
GREATER_THAN
GREATER_THAN_OR_EQUAL_TO
KEY_CONTAINS_VALUE
LESS_THAN
LESS_THAN_OR_EQUAL_TO
MODIFIED_AFTER
NOT_EQUAL_TO
STRING_CONTAINS_TEXT
STRING_ENDS_WITH_TEXT
STRING_STARTS_WITH_TEXT

Public Static Methods

FromID Gets the Relation value corresponding to the given ID.

Public Instance Properties

ID [read] The ID of this Relation value.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.QueryPart.Relation.
GetHashCode | Delegate GetHashCode() to com.starteam.QueryPart.Relation.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryPart.Relation.

See Also

QueryPart.Relation Class | StarTeam Namespace


QueryPart.Relation Properties

The properties of the QueryPart.Relation class are listed below. For a complete list of QueryPart.Relation class members, see the QueryPart.Relation Members topic.

Public Static Properties

ALL
CONTAINS
CONTAINS_KEY
CONTAINS_VALUE
DATE_OLDER_THAN_DAYS
DATE_OLDER_THAN_WEEKS
DATE_WITHIN_LAST_DAYS
DATE_WITHIN_LAST_WEEKS
EQUAL_TO
EXCLUDES
GREATER_THAN
GREATER_THAN_OR_EQUAL_TO
KEY_CONTAINS_VALUE
LESS_THAN
LESS_THAN_OR_EQUAL_TO
MODIFIED_AFTER
NOT_EQUAL_TO
STRING_CONTAINS_TEXT
STRING_ENDS_WITH_TEXT
STRING_STARTS_WITH_TEXT

Public Instance Properties

ID [read] The ID of this Relation value.

See Also

QueryPart.Relation Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

QueryPart.Relation.ALL Property

public static Relation[] ALL {get;}

See Also

QueryPart.Relation Class | StarTeam Namespace


CONTAINS Property

Borland StarTeam SDK for .NET

QueryPart.Relation.CONTAINS Property

public static QueryPart.Relation CONTAINS {get;}

Property Value

Tests if a map or multi-select enumerated valued property contains the specified object.

See Also

QueryPart.Relation Class | StarTeam Namespace


CONTAINS_KEY Property

Borland StarTeam SDK for .NET

QueryPart.Relation.CONTAINS_KEY Property

public static QueryPart.Relation CONTAINS_KEY {get;}

Property Value

Tests if a map valued property contains the specified key.

See Also

QueryPart.Relation Class | StarTeam Namespace


CONTAINS_VALUE Property

Borland StarTeam SDK for .NET

QueryPart.Relation.CONTAINS_VALUE Property

public static QueryPart.Relation CONTAINS_VALUE {get;}

Property Value

Tests if a map valued property contains the specified value.

See Also

QueryPart.Relation Class | StarTeam Namespace


DATE_OLDER_THAN_DAYS Property

Borland StarTeam SDK for .NET

QueryPart.Relation.DATE_OLDER_THAN_DAYS Property

public static QueryPart.Relation DATE_OLDER_THAN_DAYS {get;}

Property Value

True if the date is older than the specified number of days.

See Also

QueryPart.Relation Class | StarTeam Namespace


DATE_OLDER_THAN_WEEKS Property

Borland StarTeam SDK for .NET

QueryPart.Relation.DATE_OLDER_THAN_WEEKS Property

public static QueryPart.Relation DATE_OLDER_THAN_WEEKS {get;}

Property Value

True if the date is older than the specified number of weeks.

See Also

QueryPart.Relation Class | StarTeam Namespace


DATE_WITHIN_LAST_DAYS Property

Borland StarTeam SDK for .NET

QueryPart.Relation.DATE_WITHIN_LAST_DAYS Property

public static QueryPart.Relation DATE_WITHIN_LAST_DAYS {get;}

Property Value

True if the date falls within the last specified number of days.

See Also

QueryPart.Relation Class | StarTeam Namespace


DATE_WITHIN_LAST_WEEKS Property

Borland StarTeam SDK for .NET

QueryPart.Relation.DATE_WITHIN_LAST_WEEKS Property

public static QueryPart.Relation DATE_WITHIN_LAST_WEEKS {get;}

Property Value

True if the date falls within the last specified number of weeks.

See Also

QueryPart.Relation Class | StarTeam Namespace


EQUAL_TO Property

Borland StarTeam SDK for .NET

QueryPart.Relation.EQUAL_TO Property

public static QueryPart.Relation EQUAL_TO {get;}

Property Value

The "equal-to" relation.

See Also

QueryPart.Relation Class | StarTeam Namespace


EXCLUDES Property

Borland StarTeam SDK for .NET

QueryPart.Relation.EXCLUDES Property

public static QueryPart.Relation EXCLUDES {get;}

Property Value

Tests if a multi-select enumerated valued property excludes the specified object.

See Also

QueryPart.Relation Class | StarTeam Namespace


GREATER_THAN Property

Borland StarTeam SDK for .NET

QueryPart.Relation.GREATER_THAN Property

public static QueryPart.Relation GREATER_THAN {get;}

Property Value

The "greater-than" relation.

See Also

QueryPart.Relation Class | StarTeam Namespace


GREATER_THAN_OR_EQUAL_TO Property

Borland StarTeam SDK for .NET

QueryPart.Relation.GREATER_THAN_OR_EQUAL_TO Property

public static QueryPart.Relation GREATER_THAN_OR_EQUAL_TO {get;}

Property Value

The "greater-than-or-equal-to" relation.

See Also

QueryPart.Relation Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

QueryPart.Relation.ID Property

[read] The ID of this Relation value.

public virtual Int32 ID {get;}

Property Value

The ID of this Relation value.

See Also

QueryPart.Relation Class | StarTeam Namespace


KEY_CONTAINS_VALUE Property

Borland StarTeam SDK for .NET

QueryPart.Relation.KEY_CONTAINS_VALUE Property

public static QueryPart.Relation KEY_CONTAINS_VALUE {get;}

Property Value

Tests if a map valued property contains the specified key value pair.

See Also

QueryPart.Relation Class | StarTeam Namespace


LESS_THAN Property

Borland StarTeam SDK for .NET

QueryPart.Relation.LESS_THAN Property

public static QueryPart.Relation LESS_THAN {get;}

Property Value

The "less-than" relation.

See Also

QueryPart.Relation Class | StarTeam Namespace


LESS_THAN_OR_EQUAL_TO Property

Borland StarTeam SDK for .NET

QueryPart.Relation.LESS_THAN_OR_EQUAL_TO Property

public static QueryPart.Relation LESS_THAN_OR_EQUAL_TO {get;}

Property Value

The "less-than-or-equal-to" relation.

See Also

QueryPart.Relation Class | StarTeam Namespace


MODIFIED_AFTER Property

Borland StarTeam SDK for .NET

QueryPart.Relation.MODIFIED_AFTER Property

public static QueryPart.Relation MODIFIED_AFTER {get;}

Property Value

Tests if a link valued property endpoint is modified after a specific date/time.

See Also

QueryPart.Relation Class | StarTeam Namespace


NOT_EQUAL_TO Property

Borland StarTeam SDK for .NET

QueryPart.Relation.NOT_EQUAL_TO Property

public static QueryPart.Relation NOT_EQUAL_TO {get;}

Property Value

The "not-equal" relation.

See Also

QueryPart.Relation Class | StarTeam Namespace


STRING_CONTAINS_TEXT Property

Borland StarTeam SDK for .NET

QueryPart.Relation.STRING_CONTAINS_TEXT Property

public static QueryPart.Relation STRING_CONTAINS_TEXT {get;}

Property Value

Tests if a string valued property contains the specified string.

See Also

QueryPart.Relation Class | StarTeam Namespace


STRING_ENDS_WITH_TEXT Property

Borland StarTeam SDK for .NET

QueryPart.Relation.STRING_ENDS_WITH_TEXT Property

public static QueryPart.Relation STRING_ENDS_WITH_TEXT {get;}

Property Value

Tests if a string valued property ends with the specified string.

See Also

QueryPart.Relation Class | StarTeam Namespace


STRING_STARTS_WITH_TEXT Property

Borland StarTeam SDK for .NET

QueryPart.Relation.STRING_STARTS_WITH_TEXT Property

public static QueryPart.Relation STRING_STARTS_WITH_TEXT {get;}

Property Value

Tests if a string valued property starts with the specified string.

See Also

QueryPart.Relation Class | StarTeam Namespace


QueryPart.Relation Methods

The methods of the QueryPart.Relation class are listed below. For a complete list of QueryPart.Relation class members, see the QueryPart.Relation Members topic.

Public Static Methods

FromID Gets the Relation value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.QueryPart.Relation.
GetHashCode | Delegate GetHashCode() to com.starteam.QueryPart.Relation.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryPart.Relation.

See Also

QueryPart.Relation Class | StarTeam Namespace


QueryPart.Relation.Equals Method

Delegate Equals() to com.starteam.QueryPart.Relation.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.QueryPart.Relation.Equals(obj).

See Also

QueryPart.Relation Class | StarTeam Namespace


QueryPart.Relation.FromID Method

Gets the Relation value corresponding to the given ID.

public static Relation FromID(
Int32 id
);

Parameters

id
The ID of a Relation.

Return Value

The corresponding Relation value, or null.

See Also

QueryPart.Relation Class | StarTeam Namespace


QueryPart.Relation.GetHashCode Method

Delegate GetHashCode() to com.starteam.QueryPart.Relation.

public override int GetHashCode();

Return Value

com.starteam.QueryPart.Relation.GetHashCode().

See Also

QueryPart.Relation Class | StarTeam Namespace


QueryPart.Relation.ToString Method

Delegate ToString() to com.starteam.QueryPart.Relation.

public override string ToString();

Return Value

com.starteam.QueryPart.Relation.ToString()

See Also

QueryPart.Relation Class | StarTeam Namespace


QueryPart.WebCacheQueryPart Class

For a list of all members of this type, see QueryPart.WebCacheQueryPart Members.

System.Object
QueryPart.WebCacheQueryPart

public class QueryPart.WebCacheQueryPart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

QueryPart.WebCacheQueryPart Members | StarTeam Namespace


QueryPart.WebCacheQueryPart Members

QueryPart.WebCacheQueryPart overview

Public Instance Properties

IsCaseIgnored | [read/write] if case has been ignored while evaluating the expression
Property | [read] The property being tested by this query part.
RelationValue | [read/write]
Value | [read] value of the item property

Public Instance Methods

Equals | Delegate Equals() to com.starteam.QueryPart.WebCacheQueryPart.
GetHashCode | Delegate GetHashCode() to com.starteam.QueryPart.WebCacheQueryPart.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryPart.WebCacheQueryPart.

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


QueryPart.WebCacheQueryPart Properties

The properties of the QueryPart.WebCacheQueryPart class are listed below. For a complete list of QueryPart.WebCacheQueryPart class members, see the QueryPart.WebCacheQueryPart Members topic.

Public Instance Properties

IsCaseIgnored | [read/write] if case has been ignored while evaluating the expression
Property | [read] The property being tested by this query part.
RelationValue | [read/write]
Value | [read] value of the item property

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


IsCaseIgnored Property

Borland StarTeam SDK for .NET

QueryPart.WebCacheQueryPart.IsCaseIgnored Property

[read/write] if case has been ignored while evaluating the expression

public virtual Boolean IsCaseIgnored {get; set;}

Property Value

if case has been ignored while evaluating the expression

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


Property Property

Borland StarTeam SDK for .NET

QueryPart.WebCacheQueryPart.Property Property

[read] The property being tested by this query part.

public virtual Property.WebCacheProperty Property {get;}

Property Value

The property being tested by this query part.

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


RelationValue Property

Borland StarTeam SDK for .NET

QueryPart.WebCacheQueryPart.RelationValue Property

[read/write]

public virtual QueryPart.Relation RelationValue {get; set;}

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


Value Property

Borland StarTeam SDK for .NET

QueryPart.WebCacheQueryPart.Value Property

[read] value of the item property

public virtual Object Value {get;}

Property Value

value of the item property

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


QueryPart.WebCacheQueryPart Methods

The methods of the QueryPart.WebCacheQueryPart class are listed below. For a complete list of QueryPart.WebCacheQueryPart class members, see the QueryPart.WebCacheQueryPart Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.QueryPart.WebCacheQueryPart.
GetHashCode | Delegate GetHashCode() to com.starteam.QueryPart.WebCacheQueryPart.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.QueryPart.WebCacheQueryPart.

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


QueryPart.WebCacheQueryPart.Equals Method

Delegate Equals() to com.starteam.QueryPart.WebCacheQueryPart.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.QueryPart.WebCacheQueryPart.Equals(obj).

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


QueryPart.WebCacheQueryPart.GetHashCode Method

Delegate GetHashCode() to com.starteam.QueryPart.WebCacheQueryPart.

public override int GetHashCode();

Return Value

com.starteam.QueryPart.WebCacheQueryPart.GetHashCode().

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


QueryPart.WebCacheQueryPart.ToString Method

Delegate ToString() to com.starteam.QueryPart.WebCacheQueryPart.

public override string ToString();

Return Value

com.starteam.QueryPart.WebCacheQueryPart.ToString()

See Also

QueryPart.WebCacheQueryPart Class | StarTeam Namespace


RecycleBin Class

Provides access to the items that have been deleted from a view. The RecycleBin has properties that may be used to control which items are included. For example, IncludeDeletedFolders determines whether or not deleted folders are included in the folder tree. IncludeActiveItems determines whether or not active items are included along with deleted ones. Note that the recycle bin for a View with a rolled back ViewConfiguration (that is, a configuration other than the tip) reflects the state of deleted items as of the configuration time. If an item was active at the configuration time and deleted afterwards, it does not appear deleted in the recycle bin.

For a list of all members of this type, see RecycleBin Members.

System.Object
TypedResource
LiveObject
View
RecycleBin

public class RecycleBin : View

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

RecycleBin Members | StarTeam Namespace


RecycleBin Members

RecycleBin overview

Public Instance Properties

ActiveLabels (inherited from View) | [read] The active (non-deleted) labels for this view.
AlternatePath (inherited from View) | [read/write] the alternate working file path to be used for this view.
BaseConfiguration (inherited from View) | [read] the ViewConfiguration from which this View was derived.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackages (inherited from View) | [read] ChangePackageCollection
CloneTime (inherited from View) | [read/write] clone time of this View
Configuration (inherited from View) | [read] this view's configuration.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DefaultPath (inherited from View) | [read/write] the default working file path to be used for this view.
DeletedAsOf | [read/write] The deletion time. Only folders and/or item deleted after this time are included. Default value is null, indicating that all deleted folders and/or items are included.
DerivedViews (inherited from View) | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description (inherited from View) | [read/write] the description of this view.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EndDate (inherited from View) | [read/write] end date of this View
ExcludedGroups (inherited from View) | [read] The groups who are excluded from VCM Commits.
ExcludedUsers (inherited from View) | [read] The users who are excluded from VCM Commits.
FileStatusManager (inherited from View) | [read] The FileBasedStatusManager for this View.
FullName (inherited from View) | [read] the full hierarchical name of this view.
HighestChangePackageID (inherited from View) | [read] the value of the most recent change package
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IncludeActiveItems | [read/write] true if the resulting folders may contain active items; false if they may contain only deleted items. Default value is false. At least one of IncludeDeletedItems and IncludeActiveItems is always set.
IncludeDeletedFolders | [read/write] true if deleted folders are included in the folder tree; false if only active folders are included. Default value is true.
IncludeDeletedItems | [read/write] true if the resulting folders may contain deleted items; false if they may contain only active items. Default value is true. At least one of IncludeDeletedItems and IncludeActiveItems is always set.
IsAccessible (inherited from View) | [read] true if the logged on user has access to this view.
IsBranch (inherited from View) | [read] true if this view is a Branch view.
IsBranchAll (inherited from View) | [read] true if this view's original branching default was set "All".
IsBranchNone (inherited from View) | [read] true if this view's original branching default was set "None".
IsBranchOnShare (inherited from View) | [read/write] true if this view is set to branch shared items.
IsDeleted (inherited from View) | [read] True if the view has been deleted from the server; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsLightWeightWorkView (inherited from View) | [read] true if this view is lightweight work view.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsNonDerived (inherited from View) | [read] true if this view is Non-Derived view.
IsReadOnly (inherited from View) | [read] true if this view is ReadOnly, otherwise false.
IsReference (inherited from View) | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired (inherited from View) | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired (inherited from View) | [read] true if folder information may be out of date.
IsRefreshLabelsRequired (inherited from View) | [read] true if label information may be out of date.
IsRefreshRequired (inherited from View) | [read] true if view properties may be out of date.
IsRoot (inherited from View) | [read] true if this view is a Root view.
IsVCMCodeReviewRequired (inherited from View) | [read/write] whether VCM Code reviews are required
IsVCMCommitEnforced (inherited from View) | [read/write] whether VCM Commits are enforced for this View
Labels (inherited from View) | [read] The labels (both active and deleted) that exist in this view.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name (inherited from View) | [read/write] the name of this view.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from View) | [read] This object's parent container.
ParentView (inherited from View) | [read] the parent of this view, or null if there is no parent.
Path (inherited from View) | [read] the working file path being used for this view.
PresentationID (inherited from View) | [read] the unique integer identifier for this view.
Project (inherited from View) | [read] the project to which this view belongs.
PromotionModel (inherited from View) | [read] the promotion model associated with this view.
Properties (inherited from View) | [read]
RecycleBin (inherited from View) | [read] The recycle bin associated with this view.
Rights (inherited from View) | [read/write] the access control list for this view or NULL.
RootFolder (inherited from View) | [read] The root folder of this view.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
StartDate (inherited from View) | [read/write] start date of this View
StatusMethodOverride (inherited from View) | [read/write]
Traces (inherited from View) | [read] TraceCollection
TypeValue (inherited from View) | [read/write] type (Unknown, Main, Sandbox, Release) of this View
ViewID (inherited from View) | [read] the unique integer identifier for this view.
WorkspaceModifiedTime (inherited from View) | [read] workspace modified time of this View

Public Instance Methods

AddExcludedGroup (inherited from View) | Adds the specified group object as an excluded group from VCM Commits.
AddExcludedUser (inherited from View) | Adds the specified user object as an excluded user from VCM Commits.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel (inherited from View) | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed. A cloned revision label is supported across projects. This provides a mechanism to attach the correct historical revisions to a cloned label in a view that is the target of cross project or cross view folder tree moves.
CloneViewLabel (inherited from View) | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed. View labels may only be cloned from other labels in the same view
Close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems (inherited from View) | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateLightWeightWorkView (inherited from View) | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. Supported on servers beginning with release 16.4
CreateLightWeightWorkViewWithPulsePullRequests (inherited from View) | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. This work view also supports Pull Requests for code reviews in Pulse Supported on servers beginning with release 17.1
CreateRevisionLabel (inherited from View) | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel (inherited from View) | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed. Use a DateTime created with the special value 0.0 to create the label as of the current server time.
Discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FetchAllLabels (inherited from View) | Overloaded. Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FindDerivedView (inherited from View) | Return an immediate derived view with the specified name or NULL if none exist
FindFolder (inherited from View) | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem (inherited from View) | Overloaded.
FindLabel (inherited from View) | Overloaded. find and return a label given its name
FindViewMember (inherited from View) |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisembodiedItem (inherited from View) |
GetDisembodiedViewMember (inherited from View) |
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetNewNotificationItems (inherited from View) |
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetRights (inherited from View) | Returns the Access Control List for items of the specified type for this view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
GetViewMembers (inherited from View) |
GetWorkflow (inherited from View) |
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasNewNotificationItems (inherited from View) |
HasPermissions (inherited from View) | Overloaded. Returns true if desired permissions are granted for this view
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from View) | Compares the properties of two Views.
NewFolderEventSource (inherited from View) |
NewFolderTreeEventSource (inherited from View) |
NewFolderUpdateEventSource (inherited from View) |
NewItemEventSource (inherited from View) | Overloaded.
NewItemIDEventSource (inherited from View) | Overloaded.
NewItemListEventSource (inherited from View) | Overloaded.
NewItemUpdateEventSource (inherited from View) |
NewLabelEventSource (inherited from View) |
NewNotificationEventSource (inherited from View) | Overloaded.
NewViewEventSource (inherited from View) |
NewViewMemberEventSource (inherited from View) | Overloaded.
NewViewMemberUpdateEventSource (inherited from View) |
Populate (inherited from View) | Populates view properties, if they have not already been populated.
Refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
Remove (inherited from View) | Removes the view from the server.
RemoveExcludedGroup (inherited from View) | Removes the specified group object as an excluded group from VCM Commits.
RemoveExcludedUser (inherited from View) | Removes the specified user object as an excluded user from VCM Commits.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveWorkflow (inherited from View) | remove all workflow definitions for this view
ResolveLinkEndpoint (inherited from View) |
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights (inherited from View) | Modifies the Access Control List for items of the specified type for this view. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
SupportsPullRequests (inherited from View) | Return true if this view supports pull requests.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update (inherited from View) | Persists this view's properties to its Server.

See Also

RecycleBin Class | StarTeam Namespace


RecycleBin Properties

The properties of the RecycleBin class are listed below. For a complete list of RecycleBin class members, see the RecycleBin Members topic.

Public Instance Properties

ActiveLabels (inherited from View) | [read] The active (non-deleted) labels for this view.
AlternatePath (inherited from View) | [read/write] the alternate working file path to be used for this view.
BaseConfiguration (inherited from View) | [read] the ViewConfiguration from which this View was derived.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackages (inherited from View) | [read] ChangePackageCollection
CloneTime (inherited from View) | [read/write] clone time of this View
Configuration (inherited from View) | [read] this view's configuration.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DefaultPath (inherited from View) | [read/write] the default working file path to be used for this view.
DeletedAsOf | [read/write] The deletion time. Only folders and/or item deleted after this time are included. Default value is null, indicating that all deleted folders and/or items are included.
DerivedViews (inherited from View) | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description (inherited from View) | [read/write] the description of this view.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EndDate (inherited from View) | [read/write] end date of this View
ExcludedGroups (inherited from View) | [read] The groups who are excluded from VCM Commits.
ExcludedUsers (inherited from View) | [read] The users who are excluded from VCM Commits.
FileStatusManager (inherited from View) | [read] The FileBasedStatusManager for this View.
FullName (inherited from View) | [read] the full hierarchical name of this view.
HighestChangePackageID (inherited from View) | [read] the value of the most recent change package
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IncludeActiveItems | [read/write] true if the resulting folders may contain active items; false if they may contain only deleted items. Default value is false. At least one of IncludeDeletedItems and IncludeActiveItems is always set.
IncludeDeletedFolders | [read/write] true if deleted folders are included in the folder tree; false if only active folders are included. Default value is true.
IncludeDeletedItems | [read/write] true if the resulting folders may contain deleted items; false if they may contain only active items. Default value is true. At least one of IncludeDeletedItems and IncludeActiveItems is always set.
IsAccessible (inherited from View) | [read] true if the logged on user has access to this view.
IsBranch (inherited from View) | [read] true if this view is a Branch view.
IsBranchAll (inherited from View) | [read] true if this view's original branching default was set "All".
IsBranchNone (inherited from View) | [read] true if this view's original branching default was set "None".
IsBranchOnShare (inherited from View) | [read/write] true if this view is set to branch shared items.
IsDeleted (inherited from View) | [read] True if the view has been deleted from the server; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsLightWeightWorkView (inherited from View) | [read] true if this view is lightweight work view.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsNonDerived (inherited from View) | [read] true if this view is Non-Derived view.
IsReadOnly (inherited from View) | [read] true if this view is ReadOnly, otherwise false.
IsReference (inherited from View) | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired (inherited from View) | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired (inherited from View) | [read] true if folder information may be out of date.
IsRefreshLabelsRequired (inherited from View) | [read] true if label information may be out of date.
IsRefreshRequired (inherited from View) | [read] true if view properties may be out of date.
IsRoot (inherited from View) | [read] true if this view is a Root view.
IsVCMCodeReviewRequired (inherited from View) | [read/write] whether VCM Code reviews are required
IsVCMCommitEnforced (inherited from View) | [read/write] whether VCM Commits are enforced for this View
Labels (inherited from View) | [read] The labels (both active and deleted) that exist in this view.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name (inherited from View) | [read/write] the name of this view.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from View) | [read] This object's parent container.
ParentView (inherited from View) | [read] the parent of this view, or null if there is no parent.
Path (inherited from View) | [read] the working file path being used for this view.
PresentationID (inherited from View) | [read] the unique integer identifier for this view.
Project (inherited from View) | [read] the project to which this view belongs.
PromotionModel (inherited from View) | [read] the promotion model associated with this view.
Properties (inherited from View) | [read]
RecycleBin (inherited from View) | [read] The recycle bin associated with this view.
Rights (inherited from View) | [read/write] the access control list for this view or NULL.
RootFolder (inherited from View) | [read] The root folder of this view.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
StartDate (inherited from View) | [read/write] start date of this View
StatusMethodOverride (inherited from View) | [read/write]
Traces (inherited from View) | [read] TraceCollection
TypeValue (inherited from View) | [read/write] type (Unknown, Main, Sandbox, Release) of this View
ViewID (inherited from View) | [read] the unique integer identifier for this view.
WorkspaceModifiedTime (inherited from View) | [read] workspace modified time of this View

See Also

RecycleBin Class | StarTeam Namespace


DeletedAsOf Property

Borland StarTeam SDK for .NET

RecycleBin.DeletedAsOf Property

[read/write] The deletion time. Only folders and/or item deleted after this time are included. Default value is null, indicating that all deleted folders and/or items are included.

public virtual DateTime DeletedAsOf {get; set;}

Property Value

The deletion time. Only folders and/or item deleted after this time are included. Default value is null, indicating that all deleted folders and/or items are included.

See Also

RecycleBin Class | StarTeam Namespace


IncludeActiveItems Property

Borland StarTeam SDK for .NET

RecycleBin.IncludeActiveItems Property

[read/write] true if the resulting folders may contain active items; false if they may contain only deleted items. Default value is false. At least one of IncludeDeletedItems and IncludeActiveItems is always set.

public virtual Boolean IncludeActiveItems {get; set;}

Property Value

true if the resulting folders may contain active items; false if they may contain only deleted items. Default value is false. At least one of IncludeDeletedItems and IncludeActiveItems is always set.

See Also

RecycleBin Class | StarTeam Namespace


IncludeDeletedFolders Property

Borland StarTeam SDK for .NET

RecycleBin.IncludeDeletedFolders Property

[read/write] true if deleted folders are included in the folder tree; false if only active folders are included. Default value is true.

public virtual Boolean IncludeDeletedFolders {get; set;}

Property Value

true if deleted folders are included in the folder tree; false if only active folders are included. Default value is true.

See Also

RecycleBin Class | StarTeam Namespace


IncludeDeletedItems Property

Borland StarTeam SDK for .NET

RecycleBin.IncludeDeletedItems Property

[read/write] true if the resulting folders may contain deleted items; false if they may contain only active items. Default value is true. At least one of IncludeDeletedItems and IncludeActiveItems is always set.

public virtual Boolean IncludeDeletedItems {get; set;}

Property Value

true if the resulting folders may contain deleted items; false if they may contain only active items. Default value is true. At least one of IncludeDeletedItems and IncludeActiveItems is always set.

See Also

RecycleBin Class | StarTeam Namespace


Requirement Class

Represents a StarTeam Requirement item.

For a list of all members of this type, see Requirement Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
TreeItem
Requirement

public class Requirement : TreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement Members | StarTeam Namespace


Requirement Members

Requirement overview

Public Static Methods

Create Create a Requirement in the specified parent folder.

Public Instance Constructors

Requirement Constructor Creates a new requirement that is a child of an existing requirement.

Public Instance Properties

After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AmbiguitiesCount | [read/write] the number of ambiguities found for the requirement.
AtlasWorkflowStatusValue | [read/write] the AtlasWorkflowStatus of the requirement
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
Comments | [read/write] the comments recorded for the requirement
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this requirement.
DiagramSource | [read/write] the diagram source of this Requirement.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExpectedEffort | [read/write] the estimated effort expected for completing the requirement.
ExplicitRank | [read/write] This requirements rank
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalReference | [read/write] the external reference field for this requirement
ExternalTestID | [read/write] the external test ID for this requirement
ExternalTestProjectURL | [read/write] the external test project URL for this requirement
ExternalTestURL | [read/write] the external test URL for this requirement
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
HighEffort | [read/write] the highest effort expected for completing the requirement.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
LowEffort | [read/write] the minimum effort expected for completing the requirement.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MoSCoWValue | [read/write] the MoSCoW of the requirement
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of the requirement
NewRevisionComment (inherited from Item) | [read] the empty string.
Notes | [read/write] the notes recorded for the requirement
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order | [read/write] The order in which the requirement should be worked on.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
Owner | [read/write] the owner of the requirement
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentPlan | [read] the Plan containing this Requirement
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] the priority of the requirement
Properties | [read]
Rank | [read/write] This requirements rank
RequirementNumber | [read] the requirement number
RequirementTypeValue | [read/write] the type of the requirement
ResponsibleUsers | [read/write] the users responsible for the requirement
ReviewedBy | [read/write] the users who reviewed the requirement
RevisedDescription | [read/write] the revised description for the requirement
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
RichDescription | [read/write] Rich Description used for this requirement
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The status (Draft, Submitted, Pending, Accepted, etc.) of the requirement.
StreamStateValue | [read/write] Stream State used for this requirement
Tags | [read/write] the tags, if any attached to this story
UDAGrouping | [read/write] the UDA Grouping of the requirement
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AmIResponsible | Tests if the logged in user is responsible for the requirement
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasParent | Tests if the Requirement has a parent
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Requirement Class | StarTeam Namespace


Requirement Constructor

Creates a new requirement that is a child of an existing requirement.

public Requirement(
Requirement parent
);

Parameters

parent
The parent requirement.

See Also

Requirement Class | StarTeam Namespace


Requirement Properties

The properties of the Requirement class are listed below. For a complete list of Requirement class members, see the Requirement Members topic.

Public Instance Properties

After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AmbiguitiesCount | [read/write] the number of ambiguities found for the requirement.
AtlasWorkflowStatusValue | [read/write] the AtlasWorkflowStatus of the requirement
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
Comments | [read/write] the comments recorded for the requirement
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this requirement.
DiagramSource | [read/write] the diagram source of this Requirement.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExpectedEffort | [read/write] the estimated effort expected for completing the requirement.
ExplicitRank | [read/write] This requirements rank
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalReference | [read/write] the external reference field for this requirement
ExternalTestID | [read/write] the external test ID for this requirement
ExternalTestProjectURL | [read/write] the external test project URL for this requirement
ExternalTestURL | [read/write] the external test URL for this requirement
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
HighEffort | [read/write] the highest effort expected for completing the requirement.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
LowEffort | [read/write] the minimum effort expected for completing the requirement.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MoSCoWValue | [read/write] the MoSCoW of the requirement
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of the requirement
NewRevisionComment (inherited from Item) | [read] the empty string.
Notes | [read/write] the notes recorded for the requirement
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order | [read/write] The order in which the requirement should be worked on.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
Owner | [read/write] the owner of the requirement
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentPlan | [read] the Plan containing this Requirement
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] the priority of the requirement
Properties | [read]
Rank | [read/write] This requirements rank
RequirementNumber | [read] the requirement number
RequirementTypeValue | [read/write] the type of the requirement
ResponsibleUsers | [read/write] the users responsible for the requirement
ReviewedBy | [read/write] the users who reviewed the requirement
RevisedDescription | [read/write] the revised description for the requirement
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
RichDescription | [read/write] Rich Description used for this requirement
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The status (Draft, Submitted, Pending, Accepted, etc.) of the requirement.
StreamStateValue | [read/write] Stream State used for this requirement
Tags | [read/write] the tags, if any attached to this story
UDAGrouping | [read/write] the UDA Grouping of the requirement
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Requirement Class | StarTeam Namespace


AmbiguitiesCount Property

Borland StarTeam SDK for .NET

Requirement.AmbiguitiesCount Property

[read/write] the number of ambiguities found for the requirement.

public virtual Int32 AmbiguitiesCount {get; set;}

Property Value

the number of ambiguities found for the requirement.

See Also

Requirement Class | StarTeam Namespace


AtlasWorkflowStatusValue Property

Borland StarTeam SDK for .NET

Requirement.AtlasWorkflowStatusValue Property

[read/write] the AtlasWorkflowStatus of the requirement

public virtual Requirement.AtlasWorkflowStatus AtlasWorkflowStatusValue {get; set;}

Property Value

the AtlasWorkflowStatus of the requirement

See Also

Requirement Class | StarTeam Namespace


Comments Property

Borland StarTeam SDK for .NET

Requirement.Comments Property

[read/write] the comments recorded for the requirement

public virtual String Comments {get; set;}

Property Value

the comments recorded for the requirement

See Also

Requirement Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Requirement.Description Property

[read/write] the description of this requirement.

public virtual String Description {get; set;}

Property Value

the description of this requirement.

See Also

Requirement Class | StarTeam Namespace


DiagramSource Property

Borland StarTeam SDK for .NET

Requirement.DiagramSource Property

[read/write] the diagram source of this Requirement.

public virtual Content DiagramSource {get; set;}

Property Value

the diagram source of this Requirement.

See Also

Requirement Class | StarTeam Namespace


ExpectedEffort Property

Borland StarTeam SDK for .NET

Requirement.ExpectedEffort Property

[read/write] the estimated effort expected for completing the requirement.

public virtual Int32 ExpectedEffort {get; set;}

Property Value

the estimated effort expected for completing the requirement.

See Also

Requirement Class | StarTeam Namespace


ExplicitRank Property

Borland StarTeam SDK for .NET

Requirement.ExplicitRank Property

[read/write] This requirements rank

public virtual Int32 ExplicitRank {get; set;}

Property Value

This requirements rank

See Also

Requirement Class | StarTeam Namespace


ExternalReference Property

Borland StarTeam SDK for .NET

Requirement.ExternalReference Property

[read/write] the external reference field for this requirement

public virtual String ExternalReference {get; set;}

Property Value

the external reference field for this requirement

See Also

Requirement Class | StarTeam Namespace


ExternalTestID Property

Borland StarTeam SDK for .NET

Requirement.ExternalTestID Property

[read/write] the external test ID for this requirement

public virtual String ExternalTestID {get; set;}

Property Value

the external test ID for this requirement

See Also

Requirement Class | StarTeam Namespace


ExternalTestProjectURL Property

Borland StarTeam SDK for .NET

Requirement.ExternalTestProjectURL Property

[read/write] the external test project URL for this requirement

public virtual String ExternalTestProjectURL {get; set;}

Property Value

the external test project URL for this requirement

See Also

Requirement Class | StarTeam Namespace


ExternalTestURL Property

Borland StarTeam SDK for .NET

Requirement.ExternalTestURL Property

[read/write] the external test URL for this requirement

public virtual String ExternalTestURL {get; set;}

Property Value

the external test URL for this requirement

See Also

Requirement Class | StarTeam Namespace


HighEffort Property

Borland StarTeam SDK for .NET

Requirement.HighEffort Property

[read/write] the highest effort expected for completing the requirement.

public virtual Int32 HighEffort {get; set;}

Property Value

the highest effort expected for completing the requirement.

See Also

Requirement Class | StarTeam Namespace


LowEffort Property

Borland StarTeam SDK for .NET

Requirement.LowEffort Property

[read/write] the minimum effort expected for completing the requirement.

public virtual Int32 LowEffort {get; set;}

Property Value

the minimum effort expected for completing the requirement.

See Also

Requirement Class | StarTeam Namespace


MoSCoWValue Property

Borland StarTeam SDK for .NET

Requirement.MoSCoWValue Property

[read/write] the MoSCoW of the requirement

public virtual TreeItem.MoSCoW MoSCoWValue {get; set;}

Property Value

the MoSCoW of the requirement

See Also

Requirement Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Requirement.Name Property

[read/write] the name of the requirement

public virtual String Name {get; set;}

Property Value

the name of the requirement

See Also

Requirement Class | StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

Requirement.Notes Property

[read/write] the notes recorded for the requirement

public virtual String Notes {get; set;}

Property Value

the notes recorded for the requirement

See Also

Requirement Class | StarTeam Namespace


Order Property

Borland StarTeam SDK for .NET

Requirement.Order Property

[read/write] The order in which the requirement should be worked on.

public virtual Double Order {get; set;}

Property Value

The order in which the requirement should be worked on.

See Also

Requirement Class | StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

Requirement.Owner Property

[read/write] the owner of the requirement

public virtual User Owner {get; set;}

Property Value

the owner of the requirement

See Also

Requirement Class | StarTeam Namespace


ParentPlan Property

Borland StarTeam SDK for .NET

Requirement.ParentPlan Property

[read] the Plan containing this Requirement

public virtual Plan ParentPlan {get;}

Property Value

the Plan containing this Requirement

See Also

Requirement Class | StarTeam Namespace


PriorityValue Property

Borland StarTeam SDK for .NET

Requirement.PriorityValue Property

[read/write] the priority of the requirement

public virtual Requirement.Priority PriorityValue {get; set;}

Property Value

the priority of the requirement

See Also

Requirement Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Requirement.Properties Property

[read]

public virtual Requirement.Type.PropertyCollection Properties {get;}

See Also

Requirement Class | StarTeam Namespace


Rank Property

Borland StarTeam SDK for .NET

Requirement.Rank Property

[read/write] This requirements rank

public virtual Double Rank {get; set;}

Property Value

This requirements rank

See Also

Requirement Class | StarTeam Namespace


RequirementNumber Property

Borland StarTeam SDK for .NET

Requirement.RequirementNumber Property

[read] the requirement number

public virtual Int32 RequirementNumber {get;}

Property Value

the requirement number

See Also

Requirement Class | StarTeam Namespace


RequirementTypeValue Property

Borland StarTeam SDK for .NET

Requirement.RequirementTypeValue Property

[read/write] the type of the requirement

public virtual Requirement.RequirementType RequirementTypeValue {get; set;}

Property Value

the type of the requirement

See Also

Requirement Class | StarTeam Namespace


ResponsibleUsers Property

Borland StarTeam SDK for .NET

Requirement.ResponsibleUsers Property

[read/write] the users responsible for the requirement

public virtual User[] ResponsibleUsers {get; set;}

Property Value

the users responsible for the requirement

See Also

Requirement Class | StarTeam Namespace


ReviewedBy Property

Borland StarTeam SDK for .NET

Requirement.ReviewedBy Property

[read/write] the users who reviewed the requirement

public virtual User[] ReviewedBy {get; set;}

Property Value

the users who reviewed the requirement

See Also

Requirement Class | StarTeam Namespace


RevisedDescription Property

Borland StarTeam SDK for .NET

Requirement.RevisedDescription Property

[read/write] the revised description for the requirement

public virtual String RevisedDescription {get; set;}

Property Value

the revised description for the requirement

See Also

Requirement Class | StarTeam Namespace


RichDescription Property

Borland StarTeam SDK for .NET

Requirement.RichDescription Property

[read/write] Rich Description used for this requirement

public virtual Content RichDescription {get; set;}

Property Value

Rich Description used for this requirement

See Also

Requirement Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Requirement.StatusValue Property

[read/write] The status (Draft, Submitted, Pending, Accepted, etc.) of the requirement.

public virtual Requirement.Status StatusValue {get; set;}

Property Value

The status (Draft, Submitted, Pending, Accepted, etc.) of the requirement.

See Also

Requirement Class | StarTeam Namespace


StreamStateValue Property

Borland StarTeam SDK for .NET

Requirement.StreamStateValue Property

[read/write] Stream State used for this requirement

public virtual Requirement.StreamState StreamStateValue {get; set;}

Property Value

Stream State used for this requirement

See Also

Requirement Class | StarTeam Namespace


Tags Property

Borland StarTeam SDK for .NET

Requirement.Tags Property

[read/write] the tags, if any attached to this story

public virtual EnumeratedValue[] Tags {get; set;}

Property Value

the tags, if any attached to this story

See Also

Requirement Class | StarTeam Namespace


UDAGrouping Property

Borland StarTeam SDK for .NET

Requirement.UDAGrouping Property

[read/write] the UDA Grouping of the requirement

public virtual EnumeratedValue UDAGrouping {get; set;}

Property Value

the UDA Grouping of the requirement

See Also

Requirement Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Requirement.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Requirement Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Requirement.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Requirement Class | StarTeam Namespace


Requirement Methods

The methods of the Requirement class are listed below. For a complete list of Requirement class members, see the Requirement Members topic.

Public Static Methods

Create Create a Requirement in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AmIResponsible | Tests if the logged in user is responsible for the requirement
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasParent | Tests if the Requirement has a parent
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Requirement Class | StarTeam Namespace


Requirement.AmIResponsible Method

Tests if the logged in user is responsible for the requirement

public virtual bool AmIResponsible();

Return Value

true if the logged in user is responsible for the requirement.

See Also

Requirement Class | StarTeam Namespace


Requirement.Create Method

Create a Requirement in the specified parent folder.

public static Requirement Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Requirement Object.

See Also

Requirement Class | StarTeam Namespace


Requirement.HasParent Method

Tests if the Requirement has a parent

public virtual bool HasParent();

Return Value

true if the requirement has a parent.

See Also

Requirement Class | StarTeam Namespace


Requirement.AtlasWorkflowStatus Class

The workflow status according to Atlas.

For a list of all members of this type, see Requirement.AtlasWorkflowStatus Members.

System.Object
EnumeratedValue
Requirement.AtlasWorkflowStatus

public class Requirement.AtlasWorkflowStatus : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.AtlasWorkflowStatus Members | StarTeam Namespace


Requirement.AtlasWorkflowStatus Members

Requirement.AtlasWorkflowStatus overview

Public Static Properties

ALL
COMMITTED
COMPLETE
DELIVERABLE
DRAFT
PLANNED
QUEUED

Public Static Methods

FromID | Gets the story type corresponding to the given ID.
FromValue | Gets the AtlasWorkflowStatus corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.AtlasWorkflowStatus.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.AtlasWorkflowStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.AtlasWorkflowStatus.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


Requirement.AtlasWorkflowStatus Properties

The properties of the Requirement.AtlasWorkflowStatus class are listed below. For a complete list of Requirement.AtlasWorkflowStatus class members, see the Requirement.AtlasWorkflowStatus Members topic.

Public Static Properties

ALL
COMMITTED
COMPLETE
DELIVERABLE
DRAFT
PLANNED
QUEUED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Requirement.AtlasWorkflowStatus.ALL Property

public static AtlasWorkflowStatus[] ALL {get;}

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


COMMITTED Property

Borland StarTeam SDK for .NET

Requirement.AtlasWorkflowStatus.COMMITTED Property

public static Requirement.AtlasWorkflowStatus COMMITTED {get;}

Property Value

Use the committed status.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


COMPLETE Property

Borland StarTeam SDK for .NET

Requirement.AtlasWorkflowStatus.COMPLETE Property

public static Requirement.AtlasWorkflowStatus COMPLETE {get;}

Property Value

Use the complete status.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


DELIVERABLE Property

Borland StarTeam SDK for .NET

Requirement.AtlasWorkflowStatus.DELIVERABLE Property

public static Requirement.AtlasWorkflowStatus DELIVERABLE {get;}

Property Value

Use the deliverable status.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


DRAFT Property

Borland StarTeam SDK for .NET

Requirement.AtlasWorkflowStatus.DRAFT Property

public static Requirement.AtlasWorkflowStatus DRAFT {get;}

Property Value

Specifies a draft status.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Requirement.AtlasWorkflowStatus.ID Property

[read] the ID of this Type value.

public virtual Int32 ID {get;}

Property Value

the ID of this Type value.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


PLANNED Property

Borland StarTeam SDK for .NET

Requirement.AtlasWorkflowStatus.PLANNED Property

public static Requirement.AtlasWorkflowStatus PLANNED {get;}

Property Value

Use the planned status.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


QUEUED Property

Borland StarTeam SDK for .NET

Requirement.AtlasWorkflowStatus.QUEUED Property

public static Requirement.AtlasWorkflowStatus QUEUED {get;}

Property Value

Use the queued status.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


Requirement.AtlasWorkflowStatus Methods

The methods of the Requirement.AtlasWorkflowStatus class are listed below. For a complete list of Requirement.AtlasWorkflowStatus class members, see the Requirement.AtlasWorkflowStatus Members topic.

Public Static Methods

FromID | Gets the story type corresponding to the given ID.
FromValue | Gets the AtlasWorkflowStatus corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.AtlasWorkflowStatus.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.AtlasWorkflowStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.AtlasWorkflowStatus.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


Requirement.AtlasWorkflowStatus.Equals Method

Delegate Equals() to com.starteam.Requirement.AtlasWorkflowStatus.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.AtlasWorkflowStatus.Equals(obj).

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


Requirement.AtlasWorkflowStatus.FromID Method

Gets the story type corresponding to the given ID.

public static AtlasWorkflowStatus FromID(
Int32 id
);

Parameters

id
A AtlasWorkflowStatus ID.

Return Value

the corresponding AtlasWorkflowStatus Type, or null.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


Requirement.AtlasWorkflowStatus.FromValue Method

Gets the AtlasWorkflowStatus corresponding to the given EnumeratedValue.

public static AtlasWorkflowStatus FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a AtlasWorkflowStatusProperty.

Return Value

the corresponding AtlasWorkflowStatus value, or null.

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


Requirement.AtlasWorkflowStatus.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.AtlasWorkflowStatus.

public override int GetHashCode();

Return Value

com.starteam.Requirement.AtlasWorkflowStatus.GetHashCode().

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


Requirement.AtlasWorkflowStatus.ToString Method

Delegate ToString() to com.starteam.Requirement.AtlasWorkflowStatus.

public override string ToString();

Return Value

com.starteam.Requirement.AtlasWorkflowStatus.ToString()

See Also

Requirement.AtlasWorkflowStatus Class | StarTeam Namespace


Requirement.Priority Class

Priority of the Requirement

For a list of all members of this type, see Requirement.Priority Members.

System.Object
EnumeratedValue
Requirement.Priority

public class Requirement.Priority : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Priority Members | StarTeam Namespace


Requirement.Priority Members

Requirement.Priority overview

Public Static Properties

ALL
DESIRABLE
ESSENTIAL
UNASSIGNED
USEFUL

Public Static Methods

FromID | Gets the Priority value corresponding to the given ID.
FromValue | Gets the Priority value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Priority value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.Priority.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Priority.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.Priority.

See Also

Requirement.Priority Class | StarTeam Namespace


Requirement.Priority Properties

The properties of the Requirement.Priority class are listed below. For a complete list of Requirement.Priority class members, see the Requirement.Priority Members topic.

Public Static Properties

ALL
DESIRABLE
ESSENTIAL
UNASSIGNED
USEFUL

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Priority value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Requirement.Priority Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Requirement.Priority.ALL Property

public static Priority[] ALL {get;}

See Also

Requirement.Priority Class | StarTeam Namespace


DESIRABLE Property

Borland StarTeam SDK for .NET

Requirement.Priority.DESIRABLE Property

public static Requirement.Priority DESIRABLE {get;}

Property Value

Priority of the requirement is desirable

See Also

Requirement.Priority Class | StarTeam Namespace


ESSENTIAL Property

Borland StarTeam SDK for .NET

Requirement.Priority.ESSENTIAL Property

public static Requirement.Priority ESSENTIAL {get;}

Property Value

Priority of the requirement is essential

See Also

Requirement.Priority Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Requirement.Priority.ID Property

[read] The ID of this Priority value.

public virtual Int32 ID {get;}

Property Value

The ID of this Priority value.

See Also

Requirement.Priority Class | StarTeam Namespace


UNASSIGNED Property

Borland StarTeam SDK for .NET

Requirement.Priority.UNASSIGNED Property

public static Requirement.Priority UNASSIGNED {get;}

Property Value

Priority of the requirement is unassigned

See Also

Requirement.Priority Class | StarTeam Namespace


USEFUL Property

Borland StarTeam SDK for .NET

Requirement.Priority.USEFUL Property

public static Requirement.Priority USEFUL {get;}

Property Value

Priority of the requirement is useful

See Also

Requirement.Priority Class | StarTeam Namespace


Requirement.Priority Methods

The methods of the Requirement.Priority class are listed below. For a complete list of Requirement.Priority class members, see the Requirement.Priority Members topic.

Public Static Methods

FromID | Gets the Priority value corresponding to the given ID.
FromValue | Gets the Priority value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.Priority.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Priority.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.Priority.

See Also

Requirement.Priority Class | StarTeam Namespace


Requirement.Priority.Equals Method

Delegate Equals() to com.starteam.Requirement.Priority.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Priority.Equals(obj).

See Also

Requirement.Priority Class | StarTeam Namespace


Requirement.Priority.FromID Method

Gets the Priority value corresponding to the given ID.

public static Priority FromID(
Int32 id
);

Parameters

id
A Priority ID.

Return Value

The corresponding Priority value, or null.

See Also

Requirement.Priority Class | StarTeam Namespace


Requirement.Priority.FromValue Method

Gets the Priority value corresponding to the given EnumeratedValue.

public static Priority FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a PriorityProperty.

Return Value

The corresponding Priority value, or null.

See Also

Requirement.Priority Class | StarTeam Namespace


Requirement.Priority.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Priority.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Priority.GetHashCode().

See Also

Requirement.Priority Class | StarTeam Namespace


Requirement.Priority.ToString Method

Delegate ToString() to com.starteam.Requirement.Priority.

public override string ToString();

Return Value

com.starteam.Requirement.Priority.ToString()

See Also

Requirement.Priority Class | StarTeam Namespace


Requirement.RequirementType Class

Type of the Requirement

For a list of all members of this type, see Requirement.RequirementType Members.

System.Object
EnumeratedValue
Requirement.RequirementType

public class Requirement.RequirementType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.RequirementType Members | StarTeam Namespace


Requirement.RequirementType Members

Requirement.RequirementType overview

Public Static Properties

ALL
BUSINESS_REQUIREMENT
BUSINESS_SPECIFICATION
DIAGRAM
HARDWARE_REQUIREMENT
HARDWARE_SPECIFICATION
HUMAN_RESOURCES
INFORMATION_TECHNOLOGY
SOFTWARE_REQUIREMENT
SOFTWARE_SPECIFICATION

Public Static Methods

FromID | Gets the RequirementTypeProperty value corresponding to the given ID.
FromValue | Gets the RequirementType value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of the requirementType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.RequirementType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.RequirementType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.RequirementType.

See Also

Requirement.RequirementType Class | StarTeam Namespace


Requirement.RequirementType Properties

The properties of the Requirement.RequirementType class are listed below. For a complete list of Requirement.RequirementType class members, see the Requirement.RequirementType Members topic.

Public Static Properties

ALL
BUSINESS_REQUIREMENT
BUSINESS_SPECIFICATION
DIAGRAM
HARDWARE_REQUIREMENT
HARDWARE_SPECIFICATION
HUMAN_RESOURCES
INFORMATION_TECHNOLOGY
SOFTWARE_REQUIREMENT
SOFTWARE_SPECIFICATION

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of the requirementType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Requirement.RequirementType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.ALL Property

public static RequirementType[] ALL {get;}

See Also

Requirement.RequirementType Class | StarTeam Namespace


BUSINESS_REQUIREMENT Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.BUSINESS_REQUIREMENT Property

public static Requirement.RequirementType BUSINESS_REQUIREMENT {get;}

Property Value

Requirement is a business requirement

See Also

Requirement.RequirementType Class | StarTeam Namespace


BUSINESS_SPECIFICATION Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.BUSINESS_SPECIFICATION Property

public static Requirement.RequirementType BUSINESS_SPECIFICATION {get;}

Property Value

Requirement is a business specification

See Also

Requirement.RequirementType Class | StarTeam Namespace


DIAGRAM Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.DIAGRAM Property

public static Requirement.RequirementType DIAGRAM {get;}

Property Value

Requirement is a diagram

See Also

Requirement.RequirementType Class | StarTeam Namespace


HARDWARE_REQUIREMENT Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.HARDWARE_REQUIREMENT Property

public static Requirement.RequirementType HARDWARE_REQUIREMENT {get;}

Property Value

Requirement is a hardware requirement

See Also

Requirement.RequirementType Class | StarTeam Namespace


HARDWARE_SPECIFICATION Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.HARDWARE_SPECIFICATION Property

public static Requirement.RequirementType HARDWARE_SPECIFICATION {get;}

Property Value

Requirement is a hardware specification

See Also

Requirement.RequirementType Class | StarTeam Namespace


HUMAN_RESOURCES Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.HUMAN_RESOURCES Property

public static Requirement.RequirementType HUMAN_RESOURCES {get;}

Property Value

Requirement is from human resources

See Also

Requirement.RequirementType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.ID Property

[read] The ID of the requirementType value.

public virtual Int32 ID {get;}

Property Value

The ID of the requirementType value.

See Also

Requirement.RequirementType Class | StarTeam Namespace


INFORMATION_TECHNOLOGY Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.INFORMATION_TECHNOLOGY Property

public static Requirement.RequirementType INFORMATION_TECHNOLOGY {get;}

Property Value

Requirement is for information technology

See Also

Requirement.RequirementType Class | StarTeam Namespace


SOFTWARE_REQUIREMENT Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.SOFTWARE_REQUIREMENT Property

public static Requirement.RequirementType SOFTWARE_REQUIREMENT {get;}

Property Value

Requirement is a software requirement

See Also

Requirement.RequirementType Class | StarTeam Namespace


SOFTWARE_SPECIFICATION Property

Borland StarTeam SDK for .NET

Requirement.RequirementType.SOFTWARE_SPECIFICATION Property

public static Requirement.RequirementType SOFTWARE_SPECIFICATION {get;}

Property Value

Requirement is a software specification

See Also

Requirement.RequirementType Class | StarTeam Namespace


Requirement.RequirementType Methods

The methods of the Requirement.RequirementType class are listed below. For a complete list of Requirement.RequirementType class members, see the Requirement.RequirementType Members topic.

Public Static Methods

FromID | Gets the RequirementTypeProperty value corresponding to the given ID.
FromValue | Gets the RequirementType value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.RequirementType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.RequirementType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.RequirementType.

See Also

Requirement.RequirementType Class | StarTeam Namespace


Requirement.RequirementType.Equals Method

Delegate Equals() to com.starteam.Requirement.RequirementType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.RequirementType.Equals(obj).

See Also

Requirement.RequirementType Class | StarTeam Namespace


Requirement.RequirementType.FromID Method

Gets the RequirementTypeProperty value corresponding to the given ID.

public static RequirementType FromID(
Int32 id
);

Parameters

id
The ID of a RequirementTypeProperty value.

Return Value

The corresponding RequirementTypeProperty value, or null.

See Also

Requirement.RequirementType Class | StarTeam Namespace


Requirement.RequirementType.FromValue Method

Gets the RequirementType value corresponding to the given EnumeratedValue.

public static RequirementType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a RequirementTypeProperty.

Return Value

The corresponding RequirementType value, or null.

See Also

Requirement.RequirementType Class | StarTeam Namespace


Requirement.RequirementType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.RequirementType.

public override int GetHashCode();

Return Value

com.starteam.Requirement.RequirementType.GetHashCode().

See Also

Requirement.RequirementType Class | StarTeam Namespace


Requirement.RequirementType.ToString Method

Delegate ToString() to com.starteam.Requirement.RequirementType.

public override string ToString();

Return Value

com.starteam.Requirement.RequirementType.ToString()

See Also

Requirement.RequirementType Class | StarTeam Namespace


Requirement.Status Class

Status of the Requirement

For a list of all members of this type, see Requirement.Status Members.

System.Object
EnumeratedValue
Requirement.Status

public class Requirement.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Status Members | StarTeam Namespace


Requirement.Status Members

Requirement.Status overview

Public Static Properties

ACCEPTED
ALL
APPROVED
COMPLETE
DEFERRED
DRAFT
PENDING
READY
REJECTED
REVIEW
SUBMITTED

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.Status.

See Also

Requirement.Status Class | StarTeam Namespace


Requirement.Status Properties

The properties of the Requirement.Status class are listed below. For a complete list of Requirement.Status class members, see the Requirement.Status Members topic.

Public Static Properties

ACCEPTED
ALL
APPROVED
COMPLETE
DEFERRED
DRAFT
PENDING
READY
REJECTED
REVIEW
SUBMITTED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Requirement.Status Class | StarTeam Namespace


ACCEPTED Property

Borland StarTeam SDK for .NET

Requirement.Status.ACCEPTED Property

public static Requirement.Status ACCEPTED {get;}

Property Value

Requirement has been Accepted

See Also

Requirement.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Requirement.Status.ALL Property

public static Status[] ALL {get;}

See Also

Requirement.Status Class | StarTeam Namespace


APPROVED Property

Borland StarTeam SDK for .NET

Requirement.Status.APPROVED Property

public static Requirement.Status APPROVED {get;}

Property Value

Requirement is Approved

See Also

Requirement.Status Class | StarTeam Namespace


COMPLETE Property

Borland StarTeam SDK for .NET

Requirement.Status.COMPLETE Property

public static Requirement.Status COMPLETE {get;}

Property Value

Requirement is Complete

See Also

Requirement.Status Class | StarTeam Namespace


DEFERRED Property

Borland StarTeam SDK for .NET

Requirement.Status.DEFERRED Property

public static Requirement.Status DEFERRED {get;}

Property Value

Requirement is Deferred

See Also

Requirement.Status Class | StarTeam Namespace


DRAFT Property

Borland StarTeam SDK for .NET

Requirement.Status.DRAFT Property

public static Requirement.Status DRAFT {get;}

Property Value

Requirement is in a Draft form

See Also

Requirement.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Requirement.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

Requirement.Status Class | StarTeam Namespace


PENDING Property

Borland StarTeam SDK for .NET

Requirement.Status.PENDING Property

public static Requirement.Status PENDING {get;}

Property Value

Requirement is Pending

See Also

Requirement.Status Class | StarTeam Namespace


READY Property

Borland StarTeam SDK for .NET

Requirement.Status.READY Property

public static Requirement.Status READY {get;}

Property Value

Requirement is Ready

See Also

Requirement.Status Class | StarTeam Namespace


REJECTED Property

Borland StarTeam SDK for .NET

Requirement.Status.REJECTED Property

public static Requirement.Status REJECTED {get;}

Property Value

Requirement is Rejected

See Also

Requirement.Status Class | StarTeam Namespace


REVIEW Property

Borland StarTeam SDK for .NET

Requirement.Status.REVIEW Property

public static Requirement.Status REVIEW {get;}

Property Value

Requirement is under Review

See Also

Requirement.Status Class | StarTeam Namespace


SUBMITTED Property

Borland StarTeam SDK for .NET

Requirement.Status.SUBMITTED Property

public static Requirement.Status SUBMITTED {get;}

Property Value

Requirement is submitted

See Also

Requirement.Status Class | StarTeam Namespace


Requirement.Status Methods

The methods of the Requirement.Status class are listed below. For a complete list of Requirement.Status class members, see the Requirement.Status Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.Status.

See Also

Requirement.Status Class | StarTeam Namespace


Requirement.Status.Equals Method

Delegate Equals() to com.starteam.Requirement.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Status.Equals(obj).

See Also

Requirement.Status Class | StarTeam Namespace


Requirement.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

Requirement.Status Class | StarTeam Namespace


Requirement.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

Requirement.Status Class | StarTeam Namespace


Requirement.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Status.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Status.GetHashCode().

See Also

Requirement.Status Class | StarTeam Namespace


Requirement.Status.ToString Method

Delegate ToString() to com.starteam.Requirement.Status.

public override string ToString();

Return Value

com.starteam.Requirement.Status.ToString()

See Also

Requirement.Status Class | StarTeam Namespace


Requirement.StreamState Class

The Info Stream State of the Requirement

For a list of all members of this type, see Requirement.StreamState Members.

System.Object
EnumeratedValue
Requirement.StreamState

public class Requirement.StreamState : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.StreamState Members | StarTeam Namespace


Requirement.StreamState Members

Requirement.StreamState overview

Public Static Properties

ACCEPTED
ALL
PENDING
REJECTED

Public Static Methods

FromID | Gets the Stream State corresponding to the given ID.
FromValue | Gets the stream state value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.StreamState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.StreamState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.StreamState.

See Also

Requirement.StreamState Class | StarTeam Namespace


Requirement.StreamState Properties

The properties of the Requirement.StreamState class are listed below. For a complete list of Requirement.StreamState class members, see the Requirement.StreamState Members topic.

Public Static Properties

ACCEPTED
ALL
PENDING
REJECTED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Requirement.StreamState Class | StarTeam Namespace


ACCEPTED Property

Borland StarTeam SDK for .NET

Requirement.StreamState.ACCEPTED Property

public static Requirement.StreamState ACCEPTED {get;}

Property Value

Requirement info stream set to Accepted

See Also

Requirement.StreamState Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Requirement.StreamState.ALL Property

public static StreamState[] ALL {get;}

See Also

Requirement.StreamState Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Requirement.StreamState.ID Property

[read] the ID of this Value value.

public virtual Int32 ID {get;}

Property Value

the ID of this Value value.

See Also

Requirement.StreamState Class | StarTeam Namespace


PENDING Property

Borland StarTeam SDK for .NET

Requirement.StreamState.PENDING Property

public static Requirement.StreamState PENDING {get;}

Property Value

Requirement info stream set to Pending

See Also

Requirement.StreamState Class | StarTeam Namespace


REJECTED Property

Borland StarTeam SDK for .NET

Requirement.StreamState.REJECTED Property

public static Requirement.StreamState REJECTED {get;}

Property Value

Requirement info stream set to Rejected

See Also

Requirement.StreamState Class | StarTeam Namespace


Requirement.StreamState Methods

The methods of the Requirement.StreamState class are listed below. For a complete list of Requirement.StreamState class members, see the Requirement.StreamState Members topic.

Public Static Methods

FromID | Gets the Stream State corresponding to the given ID.
FromValue | Gets the stream state value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Requirement.StreamState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.StreamState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Requirement.StreamState.

See Also

Requirement.StreamState Class | StarTeam Namespace


Requirement.StreamState.Equals Method

Delegate Equals() to com.starteam.Requirement.StreamState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.StreamState.Equals(obj).

See Also

Requirement.StreamState Class | StarTeam Namespace


Requirement.StreamState.FromID Method

Gets the Stream State corresponding to the given ID.

public static StreamState FromID(
Int32 id
);

Parameters

id
A StreamState ID.

Return Value

the corresponding StreamState value, or null.

See Also

Requirement.StreamState Class | StarTeam Namespace


Requirement.StreamState.FromValue Method

Gets the stream state value corresponding to the given EnumeratedValue.

public static StreamState FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a StreamStateProperty.

Return Value

the corresponding StreamState value, or null.

See Also

Requirement.StreamState Class | StarTeam Namespace


Requirement.StreamState.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.StreamState.

public override int GetHashCode();

Return Value

com.starteam.Requirement.StreamState.GetHashCode().

See Also

Requirement.StreamState Class | StarTeam Namespace


Requirement.StreamState.ToString Method

Delegate ToString() to com.starteam.Requirement.StreamState.

public override string ToString();

Return Value

com.starteam.Requirement.StreamState.ToString()

See Also

Requirement.StreamState Class | StarTeam Namespace


Requirement.Type Class

Type meta-data (schema) for Requirement object instances

For a list of all members of this type, see Requirement.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
TreeItem.Type
Requirement.Type

new public class Requirement.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type Members | StarTeam Namespace


Requirement.Type Members

Requirement.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Requirement.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Requirement.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type Properties

The properties of the Requirement.Type class are listed below. For a complete list of Requirement.Type class members, see the Requirement.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Requirement.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Requirement.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Requirement.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Requirement.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Requirement.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Requirement.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Requirement.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Requirement.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Requirement.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Requirement.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Requirement.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Requirement.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Requirement.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Requirement.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Requirement.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.NAME Property

new public static String NAME {get;}

See Also

Requirement.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Requirement.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Requirement.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Requirement.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Requirement.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Requirement.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Requirement.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Requirement.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Requirement.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type Methods

The methods of the Requirement.Type class are listed below. For a complete list of Requirement.Type class members, see the Requirement.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Requirement.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Requirement.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.Equals(obj).

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.GetHashCode().

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ToString()

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Requirement.Type Class | StarTeam Namespace


Requirement.Type.AmbiguitiesCountProperty Class

The property type of the AmbiguitiesCount property

For a list of all members of this type, see Requirement.Type.AmbiguitiesCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.AmbiguitiesCountProperty

public class Requirement.Type.AmbiguitiesCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.AmbiguitiesCountProperty Members | StarTeam Namespace


Requirement.Type.AmbiguitiesCountProperty Members

Requirement.Type.AmbiguitiesCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.AmbiguitiesCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.AmbiguitiesCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.AmbiguitiesCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.AmbiguitiesCountProperty Class | StarTeam Namespace


Requirement.Type.AmbiguitiesCountProperty Properties

The properties of the Requirement.Type.AmbiguitiesCountProperty class are listed below. For a complete list of Requirement.Type.AmbiguitiesCountProperty class members, see the Requirement.Type.AmbiguitiesCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.AmbiguitiesCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.AmbiguitiesCountProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.AmbiguitiesCountProperty Class | StarTeam Namespace


Requirement.Type.AmbiguitiesCountProperty Methods

The methods of the Requirement.Type.AmbiguitiesCountProperty class are listed below. For a complete list of Requirement.Type.AmbiguitiesCountProperty class members, see the Requirement.Type.AmbiguitiesCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.AmbiguitiesCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.AmbiguitiesCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.AmbiguitiesCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.AmbiguitiesCountProperty Class | StarTeam Namespace


Requirement.Type.AmbiguitiesCountProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.AmbiguitiesCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.AmbiguitiesCountProperty.Equals(obj).

See Also

Requirement.Type.AmbiguitiesCountProperty Class | StarTeam Namespace


Requirement.Type.AmbiguitiesCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.AmbiguitiesCountProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.AmbiguitiesCountProperty.GetHashCode().

See Also

Requirement.Type.AmbiguitiesCountProperty Class | StarTeam Namespace


Requirement.Type.AmbiguitiesCountProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.AmbiguitiesCountProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.AmbiguitiesCountProperty.ToString()

See Also

Requirement.Type.AmbiguitiesCountProperty Class | StarTeam Namespace


Requirement.Type.AmIResponsibleProperty Class

The property type of the AmIResponsible property

For a list of all members of this type, see Requirement.Type.AmIResponsibleProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Requirement.Type.AmIResponsibleProperty

public class Requirement.Type.AmIResponsibleProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.AmIResponsibleProperty Members | StarTeam Namespace


Requirement.Type.AmIResponsibleProperty Members

Requirement.Type.AmIResponsibleProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.AmIResponsibleProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.AmIResponsibleProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.AmIResponsibleProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.AmIResponsibleProperty Class | StarTeam Namespace


Requirement.Type.AmIResponsibleProperty Properties

The properties of the Requirement.Type.AmIResponsibleProperty class are listed below. For a complete list of Requirement.Type.AmIResponsibleProperty class members, see the Requirement.Type.AmIResponsibleProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Requirement.Type.AmIResponsibleProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.AmIResponsibleProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.AmIResponsibleProperty Class | StarTeam Namespace


Requirement.Type.AmIResponsibleProperty Methods

The methods of the Requirement.Type.AmIResponsibleProperty class are listed below. For a complete list of Requirement.Type.AmIResponsibleProperty class members, see the Requirement.Type.AmIResponsibleProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.AmIResponsibleProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.AmIResponsibleProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.AmIResponsibleProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.AmIResponsibleProperty Class | StarTeam Namespace


Requirement.Type.AmIResponsibleProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.AmIResponsibleProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.AmIResponsibleProperty.Equals(obj).

See Also

Requirement.Type.AmIResponsibleProperty Class | StarTeam Namespace


Requirement.Type.AmIResponsibleProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.AmIResponsibleProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.AmIResponsibleProperty.GetHashCode().

See Also

Requirement.Type.AmIResponsibleProperty Class | StarTeam Namespace


Requirement.Type.AmIResponsibleProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.AmIResponsibleProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.AmIResponsibleProperty.ToString()

See Also

Requirement.Type.AmIResponsibleProperty Class | StarTeam Namespace


Requirement.Type.AtlasWorkflowStatusProperty Class

The property type of the AtlasWorkflowStatus property.

For a list of all members of this type, see Requirement.Type.AtlasWorkflowStatusProperty Members.

System.Object
Property
EnumeratedProperty
Requirement.Type.AtlasWorkflowStatusProperty

public class Requirement.Type.AtlasWorkflowStatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.AtlasWorkflowStatusProperty Members | StarTeam Namespace


Requirement.Type.AtlasWorkflowStatusProperty Members

Requirement.Type.AtlasWorkflowStatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.AtlasWorkflowStatusProperty Class | StarTeam Namespace


Requirement.Type.AtlasWorkflowStatusProperty Properties

The properties of the Requirement.Type.AtlasWorkflowStatusProperty class are listed below. For a complete list of Requirement.Type.AtlasWorkflowStatusProperty class members, see the Requirement.Type.AtlasWorkflowStatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Requirement.Type.AtlasWorkflowStatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.AtlasWorkflowStatusProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.AtlasWorkflowStatusProperty Class | StarTeam Namespace


Requirement.Type.AtlasWorkflowStatusProperty Methods

The methods of the Requirement.Type.AtlasWorkflowStatusProperty class are listed below. For a complete list of Requirement.Type.AtlasWorkflowStatusProperty class members, see the Requirement.Type.AtlasWorkflowStatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.AtlasWorkflowStatusProperty Class | StarTeam Namespace


Requirement.Type.AtlasWorkflowStatusProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.Equals(obj).

See Also

Requirement.Type.AtlasWorkflowStatusProperty Class | StarTeam Namespace


Requirement.Type.AtlasWorkflowStatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Requirement.AtlasWorkflowStatus value
);

See Also

Requirement.Type.AtlasWorkflowStatusProperty Class | StarTeam Namespace


Requirement.Type.AtlasWorkflowStatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.GetHashCode().

See Also

Requirement.Type.AtlasWorkflowStatusProperty Class | StarTeam Namespace


Requirement.Type.AtlasWorkflowStatusProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.AtlasWorkflowStatusProperty.ToString()

See Also

Requirement.Type.AtlasWorkflowStatusProperty Class | StarTeam Namespace


Requirement.Type.ChildrenCountProperty Class

The property type of the ChildrenCount property

For a list of all members of this type, see Requirement.Type.ChildrenCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.ChildrenCountProperty

public class Requirement.Type.ChildrenCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.ChildrenCountProperty Members | StarTeam Namespace


Requirement.Type.ChildrenCountProperty Members

Requirement.Type.ChildrenCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ChildrenCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ChildrenCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ChildrenCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ChildrenCountProperty Class | StarTeam Namespace


Requirement.Type.ChildrenCountProperty Properties

The properties of the Requirement.Type.ChildrenCountProperty class are listed below. For a complete list of Requirement.Type.ChildrenCountProperty class members, see the Requirement.Type.ChildrenCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.ChildrenCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.ChildrenCountProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.ChildrenCountProperty Class | StarTeam Namespace


Requirement.Type.ChildrenCountProperty Methods

The methods of the Requirement.Type.ChildrenCountProperty class are listed below. For a complete list of Requirement.Type.ChildrenCountProperty class members, see the Requirement.Type.ChildrenCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ChildrenCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ChildrenCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ChildrenCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ChildrenCountProperty Class | StarTeam Namespace


Requirement.Type.ChildrenCountProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.ChildrenCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.ChildrenCountProperty.Equals(obj).

See Also

Requirement.Type.ChildrenCountProperty Class | StarTeam Namespace


Requirement.Type.ChildrenCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.ChildrenCountProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.ChildrenCountProperty.GetHashCode().

See Also

Requirement.Type.ChildrenCountProperty Class | StarTeam Namespace


Requirement.Type.ChildrenCountProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.ChildrenCountProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ChildrenCountProperty.ToString()

See Also

Requirement.Type.ChildrenCountProperty Class | StarTeam Namespace


Requirement.Type.ChildTypeProperty Class

The property type of the ChildType property

For a list of all members of this type, see Requirement.Type.ChildTypeProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.ChildTypeProperty

public class Requirement.Type.ChildTypeProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.ChildTypeProperty Members | StarTeam Namespace


Requirement.Type.ChildTypeProperty Members

Requirement.Type.ChildTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ChildTypeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ChildTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ChildTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ChildTypeProperty Class | StarTeam Namespace


Requirement.Type.ChildTypeProperty Properties

The properties of the Requirement.Type.ChildTypeProperty class are listed below. For a complete list of Requirement.Type.ChildTypeProperty class members, see the Requirement.Type.ChildTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.ChildTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.ChildTypeProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.ChildTypeProperty Class | StarTeam Namespace


Requirement.Type.ChildTypeProperty Methods

The methods of the Requirement.Type.ChildTypeProperty class are listed below. For a complete list of Requirement.Type.ChildTypeProperty class members, see the Requirement.Type.ChildTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ChildTypeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ChildTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ChildTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ChildTypeProperty Class | StarTeam Namespace


Requirement.Type.ChildTypeProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.ChildTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.ChildTypeProperty.Equals(obj).

See Also

Requirement.Type.ChildTypeProperty Class | StarTeam Namespace


Requirement.Type.ChildTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.ChildTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.ChildTypeProperty.GetHashCode().

See Also

Requirement.Type.ChildTypeProperty Class | StarTeam Namespace


Requirement.Type.ChildTypeProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.ChildTypeProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ChildTypeProperty.ToString()

See Also

Requirement.Type.ChildTypeProperty Class | StarTeam Namespace


Requirement.Type.CommentsProperty Class

The property type of the Comments property

For a list of all members of this type, see Requirement.Type.CommentsProperty Members.

System.Object
Property
VectorProperty
TextProperty
Requirement.Type.CommentsProperty

public class Requirement.Type.CommentsProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.CommentsProperty Members | StarTeam Namespace


Requirement.Type.CommentsProperty Members

Requirement.Type.CommentsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.CommentsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.CommentsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.CommentsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.CommentsProperty Class | StarTeam Namespace


Requirement.Type.CommentsProperty Properties

The properties of the Requirement.Type.CommentsProperty class are listed below. For a complete list of Requirement.Type.CommentsProperty class members, see the Requirement.Type.CommentsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.CommentsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.CommentsProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.CommentsProperty Class | StarTeam Namespace


Requirement.Type.CommentsProperty Methods

The methods of the Requirement.Type.CommentsProperty class are listed below. For a complete list of Requirement.Type.CommentsProperty class members, see the Requirement.Type.CommentsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.CommentsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.CommentsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.CommentsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.CommentsProperty Class | StarTeam Namespace


Requirement.Type.CommentsProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.CommentsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.CommentsProperty.Equals(obj).

See Also

Requirement.Type.CommentsProperty Class | StarTeam Namespace


Requirement.Type.CommentsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.CommentsProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.CommentsProperty.GetHashCode().

See Also

Requirement.Type.CommentsProperty Class | StarTeam Namespace


Requirement.Type.CommentsProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.CommentsProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.CommentsProperty.ToString()

See Also

Requirement.Type.CommentsProperty Class | StarTeam Namespace


Requirement.Type.ExpectedEffortProperty Class

The property type of the ExpectedEffort property

For a list of all members of this type, see Requirement.Type.ExpectedEffortProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.ExpectedEffortProperty

public class Requirement.Type.ExpectedEffortProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.ExpectedEffortProperty Members | StarTeam Namespace


Requirement.Type.ExpectedEffortProperty Members

Requirement.Type.ExpectedEffortProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ExpectedEffortProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ExpectedEffortProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ExpectedEffortProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ExpectedEffortProperty Class | StarTeam Namespace


Requirement.Type.ExpectedEffortProperty Properties

The properties of the Requirement.Type.ExpectedEffortProperty class are listed below. For a complete list of Requirement.Type.ExpectedEffortProperty class members, see the Requirement.Type.ExpectedEffortProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.ExpectedEffortProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.ExpectedEffortProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.ExpectedEffortProperty Class | StarTeam Namespace


Requirement.Type.ExpectedEffortProperty Methods

The methods of the Requirement.Type.ExpectedEffortProperty class are listed below. For a complete list of Requirement.Type.ExpectedEffortProperty class members, see the Requirement.Type.ExpectedEffortProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ExpectedEffortProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ExpectedEffortProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ExpectedEffortProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ExpectedEffortProperty Class | StarTeam Namespace


Requirement.Type.ExpectedEffortProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.ExpectedEffortProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.ExpectedEffortProperty.Equals(obj).

See Also

Requirement.Type.ExpectedEffortProperty Class | StarTeam Namespace


Requirement.Type.ExpectedEffortProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.ExpectedEffortProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.ExpectedEffortProperty.GetHashCode().

See Also

Requirement.Type.ExpectedEffortProperty Class | StarTeam Namespace


Requirement.Type.ExpectedEffortProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.ExpectedEffortProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ExpectedEffortProperty.ToString()

See Also

Requirement.Type.ExpectedEffortProperty Class | StarTeam Namespace


Requirement.Type.ExplicitRankProperty Class

The property type of the ExplicitRank property

For a list of all members of this type, see Requirement.Type.ExplicitRankProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.ExplicitRankProperty

public class Requirement.Type.ExplicitRankProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.ExplicitRankProperty Members | StarTeam Namespace


Requirement.Type.ExplicitRankProperty Members

Requirement.Type.ExplicitRankProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ExplicitRankProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ExplicitRankProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ExplicitRankProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ExplicitRankProperty Class | StarTeam Namespace


Requirement.Type.ExplicitRankProperty Properties

The properties of the Requirement.Type.ExplicitRankProperty class are listed below. For a complete list of Requirement.Type.ExplicitRankProperty class members, see the Requirement.Type.ExplicitRankProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.ExplicitRankProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.ExplicitRankProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.ExplicitRankProperty Class | StarTeam Namespace


Requirement.Type.ExplicitRankProperty Methods

The methods of the Requirement.Type.ExplicitRankProperty class are listed below. For a complete list of Requirement.Type.ExplicitRankProperty class members, see the Requirement.Type.ExplicitRankProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ExplicitRankProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ExplicitRankProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ExplicitRankProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ExplicitRankProperty Class | StarTeam Namespace


Requirement.Type.ExplicitRankProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.ExplicitRankProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.ExplicitRankProperty.Equals(obj).

See Also

Requirement.Type.ExplicitRankProperty Class | StarTeam Namespace


Requirement.Type.ExplicitRankProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.ExplicitRankProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.ExplicitRankProperty.GetHashCode().

See Also

Requirement.Type.ExplicitRankProperty Class | StarTeam Namespace


Requirement.Type.ExplicitRankProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.ExplicitRankProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ExplicitRankProperty.ToString()

See Also

Requirement.Type.ExplicitRankProperty Class | StarTeam Namespace


Requirement.Type.HighEffortProperty Class

The property type of the HighEffort property

For a list of all members of this type, see Requirement.Type.HighEffortProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.HighEffortProperty

public class Requirement.Type.HighEffortProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.HighEffortProperty Members | StarTeam Namespace


Requirement.Type.HighEffortProperty Members

Requirement.Type.HighEffortProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.HighEffortProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.HighEffortProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.HighEffortProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.HighEffortProperty Class | StarTeam Namespace


Requirement.Type.HighEffortProperty Properties

The properties of the Requirement.Type.HighEffortProperty class are listed below. For a complete list of Requirement.Type.HighEffortProperty class members, see the Requirement.Type.HighEffortProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.HighEffortProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.HighEffortProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.HighEffortProperty Class | StarTeam Namespace


Requirement.Type.HighEffortProperty Methods

The methods of the Requirement.Type.HighEffortProperty class are listed below. For a complete list of Requirement.Type.HighEffortProperty class members, see the Requirement.Type.HighEffortProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.HighEffortProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.HighEffortProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.HighEffortProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.HighEffortProperty Class | StarTeam Namespace


Requirement.Type.HighEffortProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.HighEffortProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.HighEffortProperty.Equals(obj).

See Also

Requirement.Type.HighEffortProperty Class | StarTeam Namespace


Requirement.Type.HighEffortProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.HighEffortProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.HighEffortProperty.GetHashCode().

See Also

Requirement.Type.HighEffortProperty Class | StarTeam Namespace


Requirement.Type.HighEffortProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.HighEffortProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.HighEffortProperty.ToString()

See Also

Requirement.Type.HighEffortProperty Class | StarTeam Namespace


Requirement.Type.IsDisabledProperty Class

The property type of the IsDisabled property

For a list of all members of this type, see Requirement.Type.IsDisabledProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Requirement.Type.IsDisabledProperty

public class Requirement.Type.IsDisabledProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.IsDisabledProperty Members | StarTeam Namespace


Requirement.Type.IsDisabledProperty Members

Requirement.Type.IsDisabledProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.IsDisabledProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.IsDisabledProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.IsDisabledProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.IsDisabledProperty Class | StarTeam Namespace


Requirement.Type.IsDisabledProperty Properties

The properties of the Requirement.Type.IsDisabledProperty class are listed below. For a complete list of Requirement.Type.IsDisabledProperty class members, see the Requirement.Type.IsDisabledProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Requirement.Type.IsDisabledProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.IsDisabledProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.IsDisabledProperty Class | StarTeam Namespace


Requirement.Type.IsDisabledProperty Methods

The methods of the Requirement.Type.IsDisabledProperty class are listed below. For a complete list of Requirement.Type.IsDisabledProperty class members, see the Requirement.Type.IsDisabledProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.IsDisabledProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.IsDisabledProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.IsDisabledProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.IsDisabledProperty Class | StarTeam Namespace


Requirement.Type.IsDisabledProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.IsDisabledProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.IsDisabledProperty.Equals(obj).

See Also

Requirement.Type.IsDisabledProperty Class | StarTeam Namespace


Requirement.Type.IsDisabledProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.IsDisabledProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.IsDisabledProperty.GetHashCode().

See Also

Requirement.Type.IsDisabledProperty Class | StarTeam Namespace


Requirement.Type.IsDisabledProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.IsDisabledProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.IsDisabledProperty.ToString()

See Also

Requirement.Type.IsDisabledProperty Class | StarTeam Namespace


Requirement.Type.LowEffortProperty Class

The property type of the LowEffort property

For a list of all members of this type, see Requirement.Type.LowEffortProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.LowEffortProperty

public class Requirement.Type.LowEffortProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.LowEffortProperty Members | StarTeam Namespace


Requirement.Type.LowEffortProperty Members

Requirement.Type.LowEffortProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.LowEffortProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.LowEffortProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.LowEffortProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.LowEffortProperty Class | StarTeam Namespace


Requirement.Type.LowEffortProperty Properties

The properties of the Requirement.Type.LowEffortProperty class are listed below. For a complete list of Requirement.Type.LowEffortProperty class members, see the Requirement.Type.LowEffortProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.LowEffortProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.LowEffortProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.LowEffortProperty Class | StarTeam Namespace


Requirement.Type.LowEffortProperty Methods

The methods of the Requirement.Type.LowEffortProperty class are listed below. For a complete list of Requirement.Type.LowEffortProperty class members, see the Requirement.Type.LowEffortProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.LowEffortProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.LowEffortProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.LowEffortProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.LowEffortProperty Class | StarTeam Namespace


Requirement.Type.LowEffortProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.LowEffortProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.LowEffortProperty.Equals(obj).

See Also

Requirement.Type.LowEffortProperty Class | StarTeam Namespace


Requirement.Type.LowEffortProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.LowEffortProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.LowEffortProperty.GetHashCode().

See Also

Requirement.Type.LowEffortProperty Class | StarTeam Namespace


Requirement.Type.LowEffortProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.LowEffortProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.LowEffortProperty.ToString()

See Also

Requirement.Type.LowEffortProperty Class | StarTeam Namespace


Requirement.Type.NotesProperty Class

The property type of the Notes property

For a list of all members of this type, see Requirement.Type.NotesProperty Members.

System.Object
Property
VectorProperty
TextProperty
Requirement.Type.NotesProperty

public class Requirement.Type.NotesProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.NotesProperty Members | StarTeam Namespace


Requirement.Type.NotesProperty Members

Requirement.Type.NotesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.NotesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.NotesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.NotesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.NotesProperty Class | StarTeam Namespace


Requirement.Type.NotesProperty Properties

The properties of the Requirement.Type.NotesProperty class are listed below. For a complete list of Requirement.Type.NotesProperty class members, see the Requirement.Type.NotesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.NotesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.NotesProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.NotesProperty Class | StarTeam Namespace


Requirement.Type.NotesProperty Methods

The methods of the Requirement.Type.NotesProperty class are listed below. For a complete list of Requirement.Type.NotesProperty class members, see the Requirement.Type.NotesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.NotesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.NotesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.NotesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.NotesProperty Class | StarTeam Namespace


Requirement.Type.NotesProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.NotesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.NotesProperty.Equals(obj).

See Also

Requirement.Type.NotesProperty Class | StarTeam Namespace


Requirement.Type.NotesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.NotesProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.NotesProperty.GetHashCode().

See Also

Requirement.Type.NotesProperty Class | StarTeam Namespace


Requirement.Type.NotesProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.NotesProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.NotesProperty.ToString()

See Also

Requirement.Type.NotesProperty Class | StarTeam Namespace


Requirement.Type.OrderProperty Class

The property type of the Order property

For a list of all members of this type, see Requirement.Type.OrderProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Requirement.Type.OrderProperty

public class Requirement.Type.OrderProperty : DoubleProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.OrderProperty Members | StarTeam Namespace


Requirement.Type.OrderProperty Members

Requirement.Type.OrderProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.OrderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.OrderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.OrderProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.OrderProperty Class | StarTeam Namespace


Requirement.Type.OrderProperty Properties

The properties of the Requirement.Type.OrderProperty class are listed below. For a complete list of Requirement.Type.OrderProperty class members, see the Requirement.Type.OrderProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.OrderProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.OrderProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.OrderProperty Class | StarTeam Namespace


Requirement.Type.OrderProperty Methods

The methods of the Requirement.Type.OrderProperty class are listed below. For a complete list of Requirement.Type.OrderProperty class members, see the Requirement.Type.OrderProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.OrderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.OrderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.OrderProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.OrderProperty Class | StarTeam Namespace


Requirement.Type.OrderProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.OrderProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.OrderProperty.Equals(obj).

See Also

Requirement.Type.OrderProperty Class | StarTeam Namespace


Requirement.Type.OrderProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.OrderProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.OrderProperty.GetHashCode().

See Also

Requirement.Type.OrderProperty Class | StarTeam Namespace


Requirement.Type.OrderProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.OrderProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.OrderProperty.ToString()

See Also

Requirement.Type.OrderProperty Class | StarTeam Namespace


Requirement.Type.OwnerProperty Class

The property type of the Owner property

For a list of all members of this type, see Requirement.Type.OwnerProperty Members.

System.Object
Property
ObjectProperty
Requirement.Type.OwnerProperty

public class Requirement.Type.OwnerProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.OwnerProperty Members | StarTeam Namespace


Requirement.Type.OwnerProperty Members

Requirement.Type.OwnerProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.OwnerProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.OwnerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.OwnerProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.OwnerProperty Class | StarTeam Namespace


Requirement.Type.OwnerProperty Properties

The properties of the Requirement.Type.OwnerProperty class are listed below. For a complete list of Requirement.Type.OwnerProperty class members, see the Requirement.Type.OwnerProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Requirement.Type.OwnerProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.OwnerProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.OwnerProperty Class | StarTeam Namespace


Requirement.Type.OwnerProperty Methods

The methods of the Requirement.Type.OwnerProperty class are listed below. For a complete list of Requirement.Type.OwnerProperty class members, see the Requirement.Type.OwnerProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.OwnerProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.OwnerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.OwnerProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.OwnerProperty Class | StarTeam Namespace


Requirement.Type.OwnerProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.OwnerProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.OwnerProperty.Equals(obj).

See Also

Requirement.Type.OwnerProperty Class | StarTeam Namespace


Requirement.Type.OwnerProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.OwnerProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.OwnerProperty.GetHashCode().

See Also

Requirement.Type.OwnerProperty Class | StarTeam Namespace


Requirement.Type.OwnerProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.OwnerProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.OwnerProperty.ToString()

See Also

Requirement.Type.OwnerProperty Class | StarTeam Namespace


Requirement.Type.ParentRequirementIDProperty Class

The property type of the ParentRequirementID property

For a list of all members of this type, see Requirement.Type.ParentRequirementIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.ParentRequirementIDProperty

public class Requirement.Type.ParentRequirementIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.ParentRequirementIDProperty Members | StarTeam Namespace


Requirement.Type.ParentRequirementIDProperty Members

Requirement.Type.ParentRequirementIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ParentRequirementIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ParentRequirementIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ParentRequirementIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ParentRequirementIDProperty Class | StarTeam Namespace


Requirement.Type.ParentRequirementIDProperty Properties

The properties of the Requirement.Type.ParentRequirementIDProperty class are listed below. For a complete list of Requirement.Type.ParentRequirementIDProperty class members, see the Requirement.Type.ParentRequirementIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.ParentRequirementIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.ParentRequirementIDProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.ParentRequirementIDProperty Class | StarTeam Namespace


Requirement.Type.ParentRequirementIDProperty Methods

The methods of the Requirement.Type.ParentRequirementIDProperty class are listed below. For a complete list of Requirement.Type.ParentRequirementIDProperty class members, see the Requirement.Type.ParentRequirementIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ParentRequirementIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ParentRequirementIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ParentRequirementIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ParentRequirementIDProperty Class | StarTeam Namespace


Requirement.Type.ParentRequirementIDProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.ParentRequirementIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.ParentRequirementIDProperty.Equals(obj).

See Also

Requirement.Type.ParentRequirementIDProperty Class | StarTeam Namespace


Requirement.Type.ParentRequirementIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.ParentRequirementIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.ParentRequirementIDProperty.GetHashCode().

See Also

Requirement.Type.ParentRequirementIDProperty Class | StarTeam Namespace


Requirement.Type.ParentRequirementIDProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.ParentRequirementIDProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ParentRequirementIDProperty.ToString()

See Also

Requirement.Type.ParentRequirementIDProperty Class | StarTeam Namespace


Requirement.Type.PlanProperty Class

The property type of the Plan property

For a list of all members of this type, see Requirement.Type.PlanProperty Members.

System.Object
Property
ObjectProperty
Requirement.Type.PlanProperty

public class Requirement.Type.PlanProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.PlanProperty Members | StarTeam Namespace


Requirement.Type.PlanProperty Members

Requirement.Type.PlanProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.PlanProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.PlanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.PlanProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.PlanProperty Class | StarTeam Namespace


Requirement.Type.PlanProperty Properties

The properties of the Requirement.Type.PlanProperty class are listed below. For a complete list of Requirement.Type.PlanProperty class members, see the Requirement.Type.PlanProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Requirement.Type.PlanProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.PlanProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.PlanProperty Class | StarTeam Namespace


Requirement.Type.PlanProperty Methods

The methods of the Requirement.Type.PlanProperty class are listed below. For a complete list of Requirement.Type.PlanProperty class members, see the Requirement.Type.PlanProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.PlanProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.PlanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.PlanProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.PlanProperty Class | StarTeam Namespace


Requirement.Type.PlanProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.PlanProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.PlanProperty.Equals(obj).

See Also

Requirement.Type.PlanProperty Class | StarTeam Namespace


Requirement.Type.PlanProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.PlanProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.PlanProperty.GetHashCode().

See Also

Requirement.Type.PlanProperty Class | StarTeam Namespace


Requirement.Type.PlanProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.PlanProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.PlanProperty.ToString()

See Also

Requirement.Type.PlanProperty Class | StarTeam Namespace


Requirement.Type.PriorityProperty Class

The property type of the Priority property.

For a list of all members of this type, see Requirement.Type.PriorityProperty Members.

System.Object
Property
EnumeratedProperty
Requirement.Type.PriorityProperty

public class Requirement.Type.PriorityProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.PriorityProperty Members | StarTeam Namespace


Requirement.Type.PriorityProperty Members

Requirement.Type.PriorityProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.PriorityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.PriorityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.PriorityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.PriorityProperty Class | StarTeam Namespace


Requirement.Type.PriorityProperty Properties

The properties of the Requirement.Type.PriorityProperty class are listed below. For a complete list of Requirement.Type.PriorityProperty class members, see the Requirement.Type.PriorityProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Requirement.Type.PriorityProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.PriorityProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.PriorityProperty Class | StarTeam Namespace


Requirement.Type.PriorityProperty Methods

The methods of the Requirement.Type.PriorityProperty class are listed below. For a complete list of Requirement.Type.PriorityProperty class members, see the Requirement.Type.PriorityProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.PriorityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.PriorityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.PriorityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.PriorityProperty Class | StarTeam Namespace


Requirement.Type.PriorityProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.PriorityProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.PriorityProperty.Equals(obj).

See Also

Requirement.Type.PriorityProperty Class | StarTeam Namespace


Requirement.Type.PriorityProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Requirement.Priority value
);

See Also

Requirement.Type.PriorityProperty Class | StarTeam Namespace


Requirement.Type.PriorityProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.PriorityProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.PriorityProperty.GetHashCode().

See Also

Requirement.Type.PriorityProperty Class | StarTeam Namespace


Requirement.Type.PriorityProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.PriorityProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.PriorityProperty.ToString()

See Also

Requirement.Type.PriorityProperty Class | StarTeam Namespace


Requirement.Type.PropertyCollection Class

The property collection of the Requirement Type

For a list of all members of this type, see Requirement.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Requirement.Type.PropertyCollection

public class Requirement.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.PropertyCollection Members | StarTeam Namespace


Requirement.Type.PropertyCollection Members

Requirement.Type.PropertyCollection overview

Public Instance Properties

AM_I_RESPONSIBLE |
AMBIGUITIES_COUNT |
ATLAS_WORKFLOW_STATUS |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
CHILD_TYPE |
CHILDREN_COUNT |
COMMENT |
COMMENT_ID |
COMMENTS |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIAGRAM_SOURCE |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXPECTED_EFFORT |
EXPLICIT_RANK |
EXTERNAL_ID |
EXTERNAL_REFERENCE |
EXTERNAL_TEST_ID |
EXTERNAL_TEST_PROJECT_URL |
EXTERNAL_TEST_URL |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
HIGH_EFFORT |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_CHECKED (inherited from PropertyCollection) |
IS_DISABLED |
IS_LEAF |
IS_READ_ONLY |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
LOW_EFFORT |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_TIME |
MODIFIED_USER_ID |
MOSCOW |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
NOTES |
ORDER |
OWNER |
PARENT_REQUIREMENT_ID |
PLAN |
PRIORITY |
RANK |
REQUIREMENT_NUMBER |
REQUIREMENT_TYPE |
RESPONSIBLE_COUNT |
RESPONSIBLE_NAMES |
RESPONSIBLE_USERS |
REVIEWED_BY |
REVISED_DESCRIPTION |
REVISION_FLAGS |
REVISION_NUMBER |
RICH_DESCRIPTION |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
STREAM_STATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAG |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UDA_GROUPING |
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Requirement.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Requirement.Type.PropertyCollection.

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


Requirement.Type.PropertyCollection Properties

The properties of the Requirement.Type.PropertyCollection class are listed below. For a complete list of Requirement.Type.PropertyCollection class members, see the Requirement.Type.PropertyCollection Members topic.

Public Instance Properties

AM_I_RESPONSIBLE |
AMBIGUITIES_COUNT |
ATLAS_WORKFLOW_STATUS |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
CHILD_TYPE |
CHILDREN_COUNT |
COMMENT |
COMMENT_ID |
COMMENTS |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIAGRAM_SOURCE |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXPECTED_EFFORT |
EXPLICIT_RANK |
EXTERNAL_ID |
EXTERNAL_REFERENCE |
EXTERNAL_TEST_ID |
EXTERNAL_TEST_PROJECT_URL |
EXTERNAL_TEST_URL |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
HIGH_EFFORT |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_CHECKED (inherited from PropertyCollection) |
IS_DISABLED |
IS_LEAF |
IS_READ_ONLY |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
LOW_EFFORT |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_TIME |
MODIFIED_USER_ID |
MOSCOW |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
NOTES |
ORDER |
OWNER |
PARENT_REQUIREMENT_ID |
PLAN |
PRIORITY |
RANK |
REQUIREMENT_NUMBER |
REQUIREMENT_TYPE |
RESPONSIBLE_COUNT |
RESPONSIBLE_NAMES |
RESPONSIBLE_USERS |
REVIEWED_BY |
REVISED_DESCRIPTION |
REVISION_FLAGS |
REVISION_NUMBER |
RICH_DESCRIPTION |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
STREAM_STATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAG |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UDA_GROUPING |
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


AM_I_RESPONSIBLE Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.AM_I_RESPONSIBLE Property

public Requirement.Type.AmIResponsibleProperty AM_I_RESPONSIBLE {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


AMBIGUITIES_COUNT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.AMBIGUITIES_COUNT Property

public Requirement.Type.AmbiguitiesCountProperty AMBIGUITIES_COUNT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


ATLAS_WORKFLOW_STATUS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.ATLAS_WORKFLOW_STATUS Property

public Requirement.Type.AtlasWorkflowStatusProperty ATLAS_WORKFLOW_STATUS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


CHILD_TYPE Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.CHILD_TYPE Property

public Requirement.Type.ChildTypeProperty CHILD_TYPE {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


CHILDREN_COUNT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.CHILDREN_COUNT Property

public Requirement.Type.ChildrenCountProperty CHILDREN_COUNT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


COMMENTS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.COMMENTS Property

public Requirement.Type.CommentsProperty COMMENTS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


DIAGRAM_SOURCE Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.DIAGRAM_SOURCE Property

public Item.Type.DiagramSourceProperty DIAGRAM_SOURCE {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


EXPECTED_EFFORT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.EXPECTED_EFFORT Property

public Requirement.Type.ExpectedEffortProperty EXPECTED_EFFORT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


EXPLICIT_RANK Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.EXPLICIT_RANK Property

public Requirement.Type.ExplicitRankProperty EXPLICIT_RANK {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_REFERENCE Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.EXTERNAL_REFERENCE Property

public Item.Type.ExternalReferenceProperty EXTERNAL_REFERENCE {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_TEST_ID Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.EXTERNAL_TEST_ID Property

public TreeItem.Type.ExternalTestIDProperty EXTERNAL_TEST_ID {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_TEST_PROJECT_URL Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.EXTERNAL_TEST_PROJECT_URL Property

public TreeItem.Type.ExternalTestProjectURLProperty EXTERNAL_TEST_PROJECT_URL {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_TEST_URL Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.EXTERNAL_TEST_URL Property

public TreeItem.Type.ExternalTestURLProperty EXTERNAL_TEST_URL {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_PATH Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.FOLDER_PATH Property

public TrackedObject.Type.FolderPathProperty FOLDER_PATH {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


HIGH_EFFORT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.HIGH_EFFORT Property

public Requirement.Type.HighEffortProperty HIGH_EFFORT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


IS_BOOKMARKED Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.IS_BOOKMARKED Property

public ViewMember.Type.IsBookmarkedProperty IS_BOOKMARKED {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


IS_DISABLED Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.IS_DISABLED Property

public Requirement.Type.IsDisabledProperty IS_DISABLED {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


IS_LEAF Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.IS_LEAF Property

public TreeItem.Type.IsLeafProperty IS_LEAF {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


IS_UNREAD Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.IS_UNREAD Property

public ViewMember.Type.IsUnreadProperty IS_UNREAD {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


LOW_EFFORT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.LOW_EFFORT Property

public Requirement.Type.LowEffortProperty LOW_EFFORT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_USER_ID Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.MODIFIED_USER_ID Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_USER_ID {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


MOSCOW Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.MOSCOW Property

public TreeItem.Type.MoSCoWProperty MOSCOW {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


NEW_REVISION_COMMENT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.NEW_REVISION_COMMENT Property

public Item.Type.NewRevisionCommentProperty NEW_REVISION_COMMENT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


NOTES Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.NOTES Property

public Requirement.Type.NotesProperty NOTES {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


ORDER Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.ORDER Property

public Requirement.Type.OrderProperty ORDER {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


OWNER Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.OWNER Property

public Requirement.Type.OwnerProperty OWNER {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


PARENT_REQUIREMENT_ID Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.PARENT_REQUIREMENT_ID Property

public Requirement.Type.ParentRequirementIDProperty PARENT_REQUIREMENT_ID {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


PLAN Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.PLAN Property

public Requirement.Type.PlanProperty PLAN {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


PRIORITY Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.PRIORITY Property

public Requirement.Type.PriorityProperty PRIORITY {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


RANK Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.RANK Property

public Requirement.Type.RankProperty RANK {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


REQUIREMENT_NUMBER Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.REQUIREMENT_NUMBER Property

public Requirement.Type.RequirementNumberProperty REQUIREMENT_NUMBER {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


REQUIREMENT_TYPE Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.REQUIREMENT_TYPE Property

public Requirement.Type.RequirementTypeProperty REQUIREMENT_TYPE {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


RESPONSIBLE_COUNT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.RESPONSIBLE_COUNT Property

public Requirement.Type.ResponsibleCountProperty RESPONSIBLE_COUNT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


RESPONSIBLE_NAMES Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.RESPONSIBLE_NAMES Property

public Requirement.Type.ResponsibleNamesProperty RESPONSIBLE_NAMES {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


RESPONSIBLE_USERS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.RESPONSIBLE_USERS Property

public Requirement.Type.ResponsibleUsersProperty RESPONSIBLE_USERS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


REVIEWED_BY Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.REVIEWED_BY Property

public Requirement.Type.ReviewedByProperty REVIEWED_BY {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


REVISED_DESCRIPTION Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.REVISED_DESCRIPTION Property

public Requirement.Type.RevisedDescriptionProperty REVISED_DESCRIPTION {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


RICH_DESCRIPTION Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.RICH_DESCRIPTION Property

public TreeItem.Type.RichDescriptionProperty RICH_DESCRIPTION {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.STATUS Property

public Requirement.Type.StatusProperty STATUS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


STREAM_STATE Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.STREAM_STATE Property

public Requirement.Type.StreamStateProperty STREAM_STATE {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


TAG Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.TAG Property

public Item.Type.TagProperty TAG {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


UDA_GROUPING Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.UDA_GROUPING Property

public Requirement.Type.UDAGroupingProperty UDA_GROUPING {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.VERSION_METADATA Property

public Item.Type.VersionMetadataProperty VERSION_METADATA {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA_IDS Property

Borland StarTeam SDK for .NET

Requirement.Type.PropertyCollection.VERSION_METADATA_IDS Property

public Item.Type.VersionMetadataIDsProperty VERSION_METADATA_IDS {get;}

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


Requirement.Type.PropertyCollection Methods

The methods of the Requirement.Type.PropertyCollection class are listed below. For a complete list of Requirement.Type.PropertyCollection class members, see the Requirement.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Requirement.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Requirement.Type.PropertyCollection.

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


Requirement.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.PropertyCollection.Equals(obj).

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


Requirement.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.PropertyCollection.GetHashCode().

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


Requirement.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Requirement.Type.PropertyCollection.ToString()

See Also

Requirement.Type.PropertyCollection Class | StarTeam Namespace


Requirement.Type.RankProperty Class

The property type of the Rank property

For a list of all members of this type, see Requirement.Type.RankProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Requirement.Type.RankProperty

public class Requirement.Type.RankProperty : DoubleProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.RankProperty Members | StarTeam Namespace


Requirement.Type.RankProperty Members

Requirement.Type.RankProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.RankProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.RankProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.RankProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.RankProperty Class | StarTeam Namespace


Requirement.Type.RankProperty Properties

The properties of the Requirement.Type.RankProperty class are listed below. For a complete list of Requirement.Type.RankProperty class members, see the Requirement.Type.RankProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.RankProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.RankProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.RankProperty Class | StarTeam Namespace


Requirement.Type.RankProperty Methods

The methods of the Requirement.Type.RankProperty class are listed below. For a complete list of Requirement.Type.RankProperty class members, see the Requirement.Type.RankProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.RankProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.RankProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.RankProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.RankProperty Class | StarTeam Namespace


Requirement.Type.RankProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.RankProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.RankProperty.Equals(obj).

See Also

Requirement.Type.RankProperty Class | StarTeam Namespace


Requirement.Type.RankProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.RankProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.RankProperty.GetHashCode().

See Also

Requirement.Type.RankProperty Class | StarTeam Namespace


Requirement.Type.RankProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.RankProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.RankProperty.ToString()

See Also

Requirement.Type.RankProperty Class | StarTeam Namespace


Requirement.Type.RequirementNumberProperty Class

The property type of the RequirementNumber property

For a list of all members of this type, see Requirement.Type.RequirementNumberProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.RequirementNumberProperty

public class Requirement.Type.RequirementNumberProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.RequirementNumberProperty Members | StarTeam Namespace


Requirement.Type.RequirementNumberProperty Members

Requirement.Type.RequirementNumberProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.RequirementNumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.RequirementNumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.RequirementNumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.RequirementNumberProperty Class | StarTeam Namespace


Requirement.Type.RequirementNumberProperty Properties

The properties of the Requirement.Type.RequirementNumberProperty class are listed below. For a complete list of Requirement.Type.RequirementNumberProperty class members, see the Requirement.Type.RequirementNumberProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.RequirementNumberProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.RequirementNumberProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.RequirementNumberProperty Class | StarTeam Namespace


Requirement.Type.RequirementNumberProperty Methods

The methods of the Requirement.Type.RequirementNumberProperty class are listed below. For a complete list of Requirement.Type.RequirementNumberProperty class members, see the Requirement.Type.RequirementNumberProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.RequirementNumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.RequirementNumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.RequirementNumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.RequirementNumberProperty Class | StarTeam Namespace


Requirement.Type.RequirementNumberProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.RequirementNumberProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.RequirementNumberProperty.Equals(obj).

See Also

Requirement.Type.RequirementNumberProperty Class | StarTeam Namespace


Requirement.Type.RequirementNumberProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.RequirementNumberProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.RequirementNumberProperty.GetHashCode().

See Also

Requirement.Type.RequirementNumberProperty Class | StarTeam Namespace


Requirement.Type.RequirementNumberProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.RequirementNumberProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.RequirementNumberProperty.ToString()

See Also

Requirement.Type.RequirementNumberProperty Class | StarTeam Namespace


Requirement.Type.RequirementTypeProperty Class

The property type of the RequirementType property.

For a list of all members of this type, see Requirement.Type.RequirementTypeProperty Members.

System.Object
Property
EnumeratedProperty
Requirement.Type.RequirementTypeProperty

public class Requirement.Type.RequirementTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.RequirementTypeProperty Members | StarTeam Namespace


Requirement.Type.RequirementTypeProperty Members

Requirement.Type.RequirementTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.RequirementTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.RequirementTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.RequirementTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.RequirementTypeProperty Class | StarTeam Namespace


Requirement.Type.RequirementTypeProperty Properties

The properties of the Requirement.Type.RequirementTypeProperty class are listed below. For a complete list of Requirement.Type.RequirementTypeProperty class members, see the Requirement.Type.RequirementTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Requirement.Type.RequirementTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.RequirementTypeProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.RequirementTypeProperty Class | StarTeam Namespace


Requirement.Type.RequirementTypeProperty Methods

The methods of the Requirement.Type.RequirementTypeProperty class are listed below. For a complete list of Requirement.Type.RequirementTypeProperty class members, see the Requirement.Type.RequirementTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.RequirementTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.RequirementTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.RequirementTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.RequirementTypeProperty Class | StarTeam Namespace


Requirement.Type.RequirementTypeProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.RequirementTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.RequirementTypeProperty.Equals(obj).

See Also

Requirement.Type.RequirementTypeProperty Class | StarTeam Namespace


Requirement.Type.RequirementTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Requirement.RequirementType value
);

See Also

Requirement.Type.RequirementTypeProperty Class | StarTeam Namespace


Requirement.Type.RequirementTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.RequirementTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.RequirementTypeProperty.GetHashCode().

See Also

Requirement.Type.RequirementTypeProperty Class | StarTeam Namespace


Requirement.Type.RequirementTypeProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.RequirementTypeProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.RequirementTypeProperty.ToString()

See Also

Requirement.Type.RequirementTypeProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleCountProperty Class

The property type of the ResponsibleCount property

For a list of all members of this type, see Requirement.Type.ResponsibleCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Requirement.Type.ResponsibleCountProperty

public class Requirement.Type.ResponsibleCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.ResponsibleCountProperty Members | StarTeam Namespace


Requirement.Type.ResponsibleCountProperty Members

Requirement.Type.ResponsibleCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ResponsibleCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ResponsibleCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ResponsibleCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ResponsibleCountProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleCountProperty Properties

The properties of the Requirement.Type.ResponsibleCountProperty class are listed below. For a complete list of Requirement.Type.ResponsibleCountProperty class members, see the Requirement.Type.ResponsibleCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.ResponsibleCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.ResponsibleCountProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.ResponsibleCountProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleCountProperty Methods

The methods of the Requirement.Type.ResponsibleCountProperty class are listed below. For a complete list of Requirement.Type.ResponsibleCountProperty class members, see the Requirement.Type.ResponsibleCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ResponsibleCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ResponsibleCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ResponsibleCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ResponsibleCountProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleCountProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.ResponsibleCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.ResponsibleCountProperty.Equals(obj).

See Also

Requirement.Type.ResponsibleCountProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.ResponsibleCountProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.ResponsibleCountProperty.GetHashCode().

See Also

Requirement.Type.ResponsibleCountProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleCountProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.ResponsibleCountProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ResponsibleCountProperty.ToString()

See Also

Requirement.Type.ResponsibleCountProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleNamesProperty Class

The property type of the ResponsibleNames property

For a list of all members of this type, see Requirement.Type.ResponsibleNamesProperty Members.

System.Object
Property
VectorProperty
TextProperty
Requirement.Type.ResponsibleNamesProperty

public class Requirement.Type.ResponsibleNamesProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.ResponsibleNamesProperty Members | StarTeam Namespace


Requirement.Type.ResponsibleNamesProperty Members

Requirement.Type.ResponsibleNamesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ResponsibleNamesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ResponsibleNamesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ResponsibleNamesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ResponsibleNamesProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleNamesProperty Properties

The properties of the Requirement.Type.ResponsibleNamesProperty class are listed below. For a complete list of Requirement.Type.ResponsibleNamesProperty class members, see the Requirement.Type.ResponsibleNamesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.ResponsibleNamesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.ResponsibleNamesProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.ResponsibleNamesProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleNamesProperty Methods

The methods of the Requirement.Type.ResponsibleNamesProperty class are listed below. For a complete list of Requirement.Type.ResponsibleNamesProperty class members, see the Requirement.Type.ResponsibleNamesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ResponsibleNamesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ResponsibleNamesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ResponsibleNamesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ResponsibleNamesProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleNamesProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.ResponsibleNamesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.ResponsibleNamesProperty.Equals(obj).

See Also

Requirement.Type.ResponsibleNamesProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleNamesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.ResponsibleNamesProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.ResponsibleNamesProperty.GetHashCode().

See Also

Requirement.Type.ResponsibleNamesProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleNamesProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.ResponsibleNamesProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ResponsibleNamesProperty.ToString()

See Also

Requirement.Type.ResponsibleNamesProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleUsersProperty Class

The property type of the ResponsibleUsers property

For a list of all members of this type, see Requirement.Type.ResponsibleUsersProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Requirement.Type.ResponsibleUsersProperty

public class Requirement.Type.ResponsibleUsersProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.ResponsibleUsersProperty Members | StarTeam Namespace


Requirement.Type.ResponsibleUsersProperty Members

Requirement.Type.ResponsibleUsersProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ResponsibleUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ResponsibleUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ResponsibleUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ResponsibleUsersProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleUsersProperty Properties

The properties of the Requirement.Type.ResponsibleUsersProperty class are listed below. For a complete list of Requirement.Type.ResponsibleUsersProperty class members, see the Requirement.Type.ResponsibleUsersProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Requirement.Type.ResponsibleUsersProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.ResponsibleUsersProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.ResponsibleUsersProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleUsersProperty Methods

The methods of the Requirement.Type.ResponsibleUsersProperty class are listed below. For a complete list of Requirement.Type.ResponsibleUsersProperty class members, see the Requirement.Type.ResponsibleUsersProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ResponsibleUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ResponsibleUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ResponsibleUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ResponsibleUsersProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleUsersProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.ResponsibleUsersProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.ResponsibleUsersProperty.Equals(obj).

See Also

Requirement.Type.ResponsibleUsersProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleUsersProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.ResponsibleUsersProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.ResponsibleUsersProperty.GetHashCode().

See Also

Requirement.Type.ResponsibleUsersProperty Class | StarTeam Namespace


Requirement.Type.ResponsibleUsersProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.ResponsibleUsersProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ResponsibleUsersProperty.ToString()

See Also

Requirement.Type.ResponsibleUsersProperty Class | StarTeam Namespace


Requirement.Type.ReviewedByProperty Class

The property type of the ReviewedBy property

For a list of all members of this type, see Requirement.Type.ReviewedByProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Requirement.Type.ReviewedByProperty

public class Requirement.Type.ReviewedByProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.ReviewedByProperty Members | StarTeam Namespace


Requirement.Type.ReviewedByProperty Members

Requirement.Type.ReviewedByProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ReviewedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ReviewedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ReviewedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ReviewedByProperty Class | StarTeam Namespace


Requirement.Type.ReviewedByProperty Properties

The properties of the Requirement.Type.ReviewedByProperty class are listed below. For a complete list of Requirement.Type.ReviewedByProperty class members, see the Requirement.Type.ReviewedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Requirement.Type.ReviewedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.ReviewedByProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.ReviewedByProperty Class | StarTeam Namespace


Requirement.Type.ReviewedByProperty Methods

The methods of the Requirement.Type.ReviewedByProperty class are listed below. For a complete list of Requirement.Type.ReviewedByProperty class members, see the Requirement.Type.ReviewedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.ReviewedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.ReviewedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.ReviewedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.ReviewedByProperty Class | StarTeam Namespace


Requirement.Type.ReviewedByProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.ReviewedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.ReviewedByProperty.Equals(obj).

See Also

Requirement.Type.ReviewedByProperty Class | StarTeam Namespace


Requirement.Type.ReviewedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.ReviewedByProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.ReviewedByProperty.GetHashCode().

See Also

Requirement.Type.ReviewedByProperty Class | StarTeam Namespace


Requirement.Type.ReviewedByProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.ReviewedByProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.ReviewedByProperty.ToString()

See Also

Requirement.Type.ReviewedByProperty Class | StarTeam Namespace


Requirement.Type.RevisedDescriptionProperty Class

The property type of the RevisedDescription property

For a list of all members of this type, see Requirement.Type.RevisedDescriptionProperty Members.

System.Object
Property
VectorProperty
TextProperty
Requirement.Type.RevisedDescriptionProperty

public class Requirement.Type.RevisedDescriptionProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.RevisedDescriptionProperty Members | StarTeam Namespace


Requirement.Type.RevisedDescriptionProperty Members

Requirement.Type.RevisedDescriptionProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.RevisedDescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.RevisedDescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.RevisedDescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.RevisedDescriptionProperty Class | StarTeam Namespace


Requirement.Type.RevisedDescriptionProperty Properties

The properties of the Requirement.Type.RevisedDescriptionProperty class are listed below. For a complete list of Requirement.Type.RevisedDescriptionProperty class members, see the Requirement.Type.RevisedDescriptionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Requirement.Type.RevisedDescriptionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.RevisedDescriptionProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.RevisedDescriptionProperty Class | StarTeam Namespace


Requirement.Type.RevisedDescriptionProperty Methods

The methods of the Requirement.Type.RevisedDescriptionProperty class are listed below. For a complete list of Requirement.Type.RevisedDescriptionProperty class members, see the Requirement.Type.RevisedDescriptionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Requirement.Type.RevisedDescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.RevisedDescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Requirement.Type.RevisedDescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.RevisedDescriptionProperty Class | StarTeam Namespace


Requirement.Type.RevisedDescriptionProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.RevisedDescriptionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.RevisedDescriptionProperty.Equals(obj).

See Also

Requirement.Type.RevisedDescriptionProperty Class | StarTeam Namespace


Requirement.Type.RevisedDescriptionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.RevisedDescriptionProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.RevisedDescriptionProperty.GetHashCode().

See Also

Requirement.Type.RevisedDescriptionProperty Class | StarTeam Namespace


Requirement.Type.RevisedDescriptionProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.RevisedDescriptionProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.RevisedDescriptionProperty.ToString()

See Also

Requirement.Type.RevisedDescriptionProperty Class | StarTeam Namespace


Requirement.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see Requirement.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
Requirement.Type.StatusProperty

public class Requirement.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.StatusProperty Members | StarTeam Namespace


Requirement.Type.StatusProperty Members

Requirement.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.StatusProperty Class | StarTeam Namespace


Requirement.Type.StatusProperty Properties

The properties of the Requirement.Type.StatusProperty class are listed below. For a complete list of Requirement.Type.StatusProperty class members, see the Requirement.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Requirement.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.StatusProperty Class | StarTeam Namespace


Requirement.Type.StatusProperty Methods

The methods of the Requirement.Type.StatusProperty class are listed below. For a complete list of Requirement.Type.StatusProperty class members, see the Requirement.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.StatusProperty Class | StarTeam Namespace


Requirement.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.StatusProperty.Equals(obj).

See Also

Requirement.Type.StatusProperty Class | StarTeam Namespace


Requirement.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Requirement.Status value
);

See Also

Requirement.Type.StatusProperty Class | StarTeam Namespace


Requirement.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.StatusProperty.GetHashCode().

See Also

Requirement.Type.StatusProperty Class | StarTeam Namespace


Requirement.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.StatusProperty.ToString()

See Also

Requirement.Type.StatusProperty Class | StarTeam Namespace


Requirement.Type.StreamStateProperty Class

The property type of the StreamState property.

For a list of all members of this type, see Requirement.Type.StreamStateProperty Members.

System.Object
Property
EnumeratedProperty
Requirement.Type.StreamStateProperty

public class Requirement.Type.StreamStateProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.StreamStateProperty Members | StarTeam Namespace


Requirement.Type.StreamStateProperty Members

Requirement.Type.StreamStateProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.StreamStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.StreamStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.StreamStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.StreamStateProperty Class | StarTeam Namespace


Requirement.Type.StreamStateProperty Properties

The properties of the Requirement.Type.StreamStateProperty class are listed below. For a complete list of Requirement.Type.StreamStateProperty class members, see the Requirement.Type.StreamStateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Requirement.Type.StreamStateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.StreamStateProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.StreamStateProperty Class | StarTeam Namespace


Requirement.Type.StreamStateProperty Methods

The methods of the Requirement.Type.StreamStateProperty class are listed below. For a complete list of Requirement.Type.StreamStateProperty class members, see the Requirement.Type.StreamStateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.StreamStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.StreamStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.StreamStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.StreamStateProperty Class | StarTeam Namespace


Requirement.Type.StreamStateProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.StreamStateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.StreamStateProperty.Equals(obj).

See Also

Requirement.Type.StreamStateProperty Class | StarTeam Namespace


Requirement.Type.StreamStateProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Requirement.StreamState value
);

See Also

Requirement.Type.StreamStateProperty Class | StarTeam Namespace


Requirement.Type.StreamStateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.StreamStateProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.StreamStateProperty.GetHashCode().

See Also

Requirement.Type.StreamStateProperty Class | StarTeam Namespace


Requirement.Type.StreamStateProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.StreamStateProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.StreamStateProperty.ToString()

See Also

Requirement.Type.StreamStateProperty Class | StarTeam Namespace


Requirement.Type.UDAGroupingProperty Class

The property type of the UDA Grouping property.

For a list of all members of this type, see Requirement.Type.UDAGroupingProperty Members.

System.Object
Property
EnumeratedProperty
Requirement.Type.UDAGroupingProperty

public class Requirement.Type.UDAGroupingProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.Type.UDAGroupingProperty Members | StarTeam Namespace


Requirement.Type.UDAGroupingProperty Members

Requirement.Type.UDAGroupingProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.UDAGroupingProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.UDAGroupingProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.UDAGroupingProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.UDAGroupingProperty Class | StarTeam Namespace


Requirement.Type.UDAGroupingProperty Properties

The properties of the Requirement.Type.UDAGroupingProperty class are listed below. For a complete list of Requirement.Type.UDAGroupingProperty class members, see the Requirement.Type.UDAGroupingProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Requirement.Type.UDAGroupingProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Requirement.Type.UDAGroupingProperty.NAME Property

public static String NAME {get;}

See Also

Requirement.Type.UDAGroupingProperty Class | StarTeam Namespace


Requirement.Type.UDAGroupingProperty Methods

The methods of the Requirement.Type.UDAGroupingProperty class are listed below. For a complete list of Requirement.Type.UDAGroupingProperty class members, see the Requirement.Type.UDAGroupingProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Requirement.Type.UDAGroupingProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.Type.UDAGroupingProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Requirement.Type.UDAGroupingProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Requirement.Type.UDAGroupingProperty Class | StarTeam Namespace


Requirement.Type.UDAGroupingProperty.Equals Method

Delegate Equals() to com.starteam.Requirement.Type.UDAGroupingProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.Type.UDAGroupingProperty.Equals(obj).

See Also

Requirement.Type.UDAGroupingProperty Class | StarTeam Namespace


Requirement.Type.UDAGroupingProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.Type.UDAGroupingProperty.

public override int GetHashCode();

Return Value

com.starteam.Requirement.Type.UDAGroupingProperty.GetHashCode().

See Also

Requirement.Type.UDAGroupingProperty Class | StarTeam Namespace


Requirement.Type.UDAGroupingProperty.ToString Method

Delegate ToString() to com.starteam.Requirement.Type.UDAGroupingProperty.

public override string ToString();

Return Value

com.starteam.Requirement.Type.UDAGroupingProperty.ToString()

See Also

Requirement.Type.UDAGroupingProperty Class | StarTeam Namespace


Requirement.WebCacheRequirement Class

Item accessor for cached SDK Requirement items contained objects are obtained from the artifact cache

For a list of all members of this type, see Requirement.WebCacheRequirement Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
TreeItem.WebCacheTreeItem
Requirement.WebCacheRequirement

public class Requirement.WebCacheRequirement : WebCacheTreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Requirement.WebCacheRequirement Members | StarTeam Namespace


Requirement.WebCacheRequirement Members

Requirement.WebCacheRequirement overview

Public Static Methods

Create Overloaded.

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
AmbiguitiesCount | [read/write] the number of ambiguities found for the requirement.
AtlasWorkflowStatusValue | [read/write] the AtlasWorkflowStatus of the requirement
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Comments | [read/write] the comments recorded for the requirement
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this requirement.
DiagramSource | [read/write] the diagram source of this Requirement.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExpectedEffort | [read/write] the estimated effort expected for completing the requirement.
ExplicitRank | [read/write] This requirement's rank.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalReference | [read/write] the external reference field for this requirement
ExternalTestID | [read/write] the external test ID for this requirement
ExternalTestProjectURL | [read/write] the external test Project URL for this requirement
ExternalTestURL | [read/write] the external test URL for this requirement
ExternalURL | [read/write] The external URL describing this revision of the item.
HighEffort | [read/write] the highest effort expected for completing the requirement.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
LowEffort | [read/write] the minimum effort expected for completing the requirement.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MoSCoWValue | [read/write] the MoSCoW of the requirement
MyType | [read] the type of this resource.
Name |
NameProperty |
Notes | [read/write] the notes recorded for the requirement
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Order | [read/write] The order in which the requirement should be worked on.
Owner | [read/write] the owner of the requirement
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
ParentPlan | [read] The plan set as parent of this requirement or null
PresentationID | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] the priority of the requirement
Rank | [read/write] This requirement's rank.
RequirementNumber | [read] the requirement number
RequirementTypeValue | [read/write] the type of the requirement
ResponsibleUsers | [read/write] the users responsible for the requirement
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
ReviewedBy | [read/write] the users who reviewed the requirement
RevisedDescription | [read/write] the revised description for the requirement
RevisionNumber | [read] The revision number for this object revision.
RichDescription | [read/write] the rich description of this requirement.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The status (Draft, Submitted, Pending, Accepted, etc.) of the requirement.
StreamState | [read/write] streamState of this Requirement
Tags | [read/write] the tags, if any attached to this story instance
Traces | [read] a Trace[] of applicable Traces
UDAGrouping | [read/write] the UDA Grouping of the requirement
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Requirement.WebCacheRequirement.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.WebCacheRequirement.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Requirement.WebCacheRequirement.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement Properties

The properties of the Requirement.WebCacheRequirement class are listed below. For a complete list of Requirement.WebCacheRequirement class members, see the Requirement.WebCacheRequirement Members topic.

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
AmbiguitiesCount | [read/write] the number of ambiguities found for the requirement.
AtlasWorkflowStatusValue | [read/write] the AtlasWorkflowStatus of the requirement
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Comments | [read/write] the comments recorded for the requirement
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this requirement.
DiagramSource | [read/write] the diagram source of this Requirement.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExpectedEffort | [read/write] the estimated effort expected for completing the requirement.
ExplicitRank | [read/write] This requirement's rank.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalReference | [read/write] the external reference field for this requirement
ExternalTestID | [read/write] the external test ID for this requirement
ExternalTestProjectURL | [read/write] the external test Project URL for this requirement
ExternalTestURL | [read/write] the external test URL for this requirement
ExternalURL | [read/write] The external URL describing this revision of the item.
HighEffort | [read/write] the highest effort expected for completing the requirement.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
LowEffort | [read/write] the minimum effort expected for completing the requirement.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MoSCoWValue | [read/write] the MoSCoW of the requirement
MyType | [read] the type of this resource.
Name |
NameProperty |
Notes | [read/write] the notes recorded for the requirement
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Order | [read/write] The order in which the requirement should be worked on.
Owner | [read/write] the owner of the requirement
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
ParentPlan | [read] The plan set as parent of this requirement or null
PresentationID | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] the priority of the requirement
Rank | [read/write] This requirement's rank.
RequirementNumber | [read] the requirement number
RequirementTypeValue | [read/write] the type of the requirement
ResponsibleUsers | [read/write] the users responsible for the requirement
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
ReviewedBy | [read/write] the users who reviewed the requirement
RevisedDescription | [read/write] the revised description for the requirement
RevisionNumber | [read] The revision number for this object revision.
RichDescription | [read/write] the rich description of this requirement.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The status (Draft, Submitted, Pending, Accepted, etc.) of the requirement.
StreamState | [read/write] streamState of this Requirement
Tags | [read/write] the tags, if any attached to this story instance
Traces | [read] a Trace[] of applicable Traces
UDAGrouping | [read/write] the UDA Grouping of the requirement
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


After Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.After Property

[write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem After {set;}

Property Value

place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


AmbiguitiesCount Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.AmbiguitiesCount Property

[read/write] the number of ambiguities found for the requirement.

public virtual Int32 AmbiguitiesCount {get; set;}

Property Value

the number of ambiguities found for the requirement.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


AtlasWorkflowStatusValue Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.AtlasWorkflowStatusValue Property

[read/write] the AtlasWorkflowStatus of the requirement

public virtual Requirement.AtlasWorkflowStatus AtlasWorkflowStatusValue {get; set;}

Property Value

the AtlasWorkflowStatus of the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Before Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Before Property

[write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem Before {set;}

Property Value

place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Comments Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Comments Property

[read/write] the comments recorded for the requirement

public virtual String Comments {get; set;}

Property Value

the comments recorded for the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Description Property

[read/write] the description of this requirement.

public virtual String Description {get; set;}

Property Value

the description of this requirement.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


DiagramSource Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.DiagramSource Property

[read/write] the diagram source of this Requirement.

public virtual Content.WebCacheContent DiagramSource {get; set;}

Property Value

the diagram source of this Requirement.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ExpectedEffort Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ExpectedEffort Property

[read/write] the estimated effort expected for completing the requirement.

public virtual Int32 ExpectedEffort {get; set;}

Property Value

the estimated effort expected for completing the requirement.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ExplicitRank Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ExplicitRank Property

[read/write] This requirement's rank.

public virtual Int32 ExplicitRank {get; set;}

Property Value

This requirement's rank.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ExternalReference Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ExternalReference Property

[read/write] the external reference field for this requirement

public virtual String ExternalReference {get; set;}

Property Value

the external reference field for this requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ExternalTestID Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ExternalTestID Property

[read/write] the external test ID for this requirement

public virtual String ExternalTestID {get; set;}

Property Value

the external test ID for this requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ExternalTestProjectURL Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ExternalTestProjectURL Property

[read/write] the external test Project URL for this requirement

public virtual String ExternalTestProjectURL {get; set;}

Property Value

the external test Project URL for this requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ExternalTestURL Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ExternalTestURL Property

[read/write] the external test URL for this requirement

public virtual String ExternalTestURL {get; set;}

Property Value

the external test URL for this requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


HighEffort Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.HighEffort Property

[read/write] the highest effort expected for completing the requirement.

public virtual Int32 HighEffort {get; set;}

Property Value

the highest effort expected for completing the requirement.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IsLeaf Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IsLeaf Property

[read] true if this tree item is a leaf

new public virtual Boolean IsLeaf {get;}

Property Value

true if this tree item is a leaf

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


LowEffort Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.LowEffort Property

[read/write] the minimum effort expected for completing the requirement.

public virtual Int32 LowEffort {get; set;}

Property Value

the minimum effort expected for completing the requirement.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


MoSCoWValue Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.MoSCoWValue Property

[read/write] the MoSCoW of the requirement

public virtual TreeItem.MoSCoW MoSCoWValue {get; set;}

Property Value

the MoSCoW of the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Name Property

new public virtual String Name {get; set;}

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Notes Property

[read/write] the notes recorded for the requirement

public virtual String Notes {get; set;}

Property Value

the notes recorded for the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Order Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Order Property

[read/write] The order in which the requirement should be worked on.

public virtual Double Order {get; set;}

Property Value

The order in which the requirement should be worked on.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Owner Property

[read/write] the owner of the requirement

public virtual User.WebCacheUser Owner {get; set;}

Property Value

the owner of the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Parent Property

[read] the TreeItem which is the Parent of this instance, or NULL if this is a root

new public virtual TreeItem.WebCacheTreeItem Parent {get;}

Property Value

the TreeItem which is the Parent of this instance, or NULL if this is a root

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ParentPlan Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ParentPlan Property

[read] The plan set as parent of this requirement or null

public virtual Plan.WebCachePlan ParentPlan {get;}

Property Value

The plan set as parent of this requirement or null

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


PriorityValue Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.PriorityValue Property

[read/write] the priority of the requirement

public virtual Requirement.Priority PriorityValue {get; set;}

Property Value

the priority of the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Rank Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Rank Property

[read/write] This requirement's rank.

public virtual Double Rank {get; set;}

Property Value

This requirement's rank.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


RequirementNumber Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.RequirementNumber Property

[read] the requirement number

public virtual Int32 RequirementNumber {get;}

Property Value

the requirement number

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


RequirementTypeValue Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.RequirementTypeValue Property

[read/write] the type of the requirement

public virtual Requirement.RequirementType RequirementTypeValue {get; set;}

Property Value

the type of the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ResponsibleUsers Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ResponsibleUsers Property

[read/write] the users responsible for the requirement

public virtual WebCacheUser[] ResponsibleUsers {get; set;}

Property Value

the users responsible for the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ReviewedBy Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ReviewedBy Property

[read/write] the users who reviewed the requirement

public virtual WebCacheUser[] ReviewedBy {get; set;}

Property Value

the users who reviewed the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


RevisedDescription Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.RevisedDescription Property

[read/write] the revised description for the requirement

public virtual String RevisedDescription {get; set;}

Property Value

the revised description for the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


RichDescription Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.RichDescription Property

[read/write] the rich description of this requirement.

public virtual Content.WebCacheContent RichDescription {get; set;}

Property Value

the rich description of this requirement.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.StatusValue Property

[read/write] The status (Draft, Submitted, Pending, Accepted, etc.) of the requirement.

public virtual Requirement.Status StatusValue {get; set;}

Property Value

The status (Draft, Submitted, Pending, Accepted, etc.) of the requirement.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


StreamState Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.StreamState Property

[read/write] streamState of this Requirement

public virtual Requirement.StreamState StreamState {get; set;}

Property Value

streamState of this Requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Tags Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Tags Property

[read/write] the tags, if any attached to this story instance

public virtual EnumeratedValue[] Tags {get; set;}

Property Value

the tags, if any attached to this story instance

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


UDAGrouping Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.UDAGrouping Property

[read/write] the UDA Grouping of the requirement

public virtual EnumeratedValue UDAGrouping {get; set;}

Property Value

the UDA Grouping of the requirement

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement Methods

The methods of the Requirement.WebCacheRequirement class are listed below. For a complete list of Requirement.WebCacheRequirement class members, see the Requirement.WebCacheRequirement Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Requirement.WebCacheRequirement.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Requirement.WebCacheRequirement.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Requirement.WebCacheRequirement.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Create Method

Overload List

public static WebCacheRequirement Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,TreeItem.Type.WebCacheTreeItemType);

public static WebCacheRequirement Create(ArtifactCacheManager.Context,Requirement.WebCacheRequirement);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,TreeItem.WebCacheTreeItem);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheRequirement Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.Create Overload List


Requirement.WebCacheRequirement.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.Create Overload List


Requirement.WebCacheRequirement.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, TreeItem#Type#WebCacheTreeItemType)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
TreeItem.Type.WebCacheTreeItemType typ
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.Create Overload List


Requirement.WebCacheRequirement.Create Method (ArtifactCacheManager#Context, Requirement#WebCacheRequirement)

public static WebCacheRequirement Create(
ArtifactCacheManager.Context cntxt,
Requirement.WebCacheRequirement parent
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.Create Overload List


Requirement.WebCacheRequirement.Create Method (ArtifactCacheManager#Context, TreeItem#WebCacheTreeItem)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
TreeItem.WebCacheTreeItem parent
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.Create Overload List


Requirement.WebCacheRequirement.Equals Method

Delegate Equals() to com.starteam.Requirement.WebCacheRequirement.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Requirement.WebCacheRequirement.Equals(obj).

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.GetChildren Method

new public virtual WebCacheTreeItem[] GetChildren(
Filter.WebCacheFilter fltr
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.GetHashCode Method

Delegate GetHashCode() to com.starteam.Requirement.WebCacheRequirement.

public override int GetHashCode();

Return Value

com.starteam.Requirement.WebCacheRequirement.GetHashCode().

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.GetValue Overload List


Requirement.WebCacheRequirement.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.GetValue Overload List


Requirement.WebCacheRequirement.HasChildren Method

Returns true if the TreeItem has at least one child.

new public virtual bool HasChildren();

Return Value

True if at least one child exists, false if no children

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | isDisembodied


Requirement.WebCacheRequirement.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | WebCacheViewMemberCollection


Requirement.WebCacheRequirement.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.Lock Overload List | WebCacheViewMemberCollection


Requirement.WebCacheRequirement.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.Lock Overload List


Requirement.WebCacheRequirement.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | NAME


Requirement.WebCacheRequirement.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(TreeItem.WebCacheTreeItem);

new public virtual void MoveTo(View.WebCacheView);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.MoveTo Overload List


Requirement.WebCacheRequirement.MoveTo Method (TreeItem#WebCacheTreeItem)

new public virtual void MoveTo(
TreeItem.WebCacheTreeItem parent
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.MoveTo Overload List


Requirement.WebCacheRequirement.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.MoveTo Overload List


Requirement.WebCacheRequirement.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | isFloating | isPinned | unpin


Requirement.WebCacheRequirement.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | WebCacheViewMemberCollection


Requirement.WebCacheRequirement.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.SetBetween Method

new public virtual void SetBetween(
TreeItem.WebCacheTreeItem prev,
TreeItem.WebCacheTreeItem next
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.SetFirst Method

place this tree item at the head of the set of all children of its parent treeitem or folder

new public virtual void SetFirst();

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.SetLast Method

place this tree item at the end of the set of all children of its parent treeitem or folder

new public virtual void SetLast();

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Requirement.WebCacheRequirement.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.SetValue Overload List


Requirement.WebCacheRequirement.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | Requirement.WebCacheRequirement.SetValue Overload List


Requirement.WebCacheRequirement.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.ToString Method

Delegate ToString() to com.starteam.Requirement.WebCacheRequirement.

public override string ToString();

Return Value

com.starteam.Requirement.WebCacheRequirement.ToString()

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Requirement.WebCacheRequirement.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | WebCacheViewMemberCollection


Requirement.WebCacheRequirement.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | isFloating | isPinned | pinTo


Requirement.WebCacheRequirement.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace | WebCacheViewMemberCollection


Requirement.WebCacheRequirement.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Requirement.WebCacheRequirement Class | StarTeam Namespace


Review Class

A Review is an oversight of a code block.

For a list of all members of this type, see Review Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Review

public class Review : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review Members | StarTeam Namespace


Review Members

Review overview

Public Static Methods

Create Create a Review in the specified parent folder.

Public Instance Properties

Acceptors | [read] The users who are acceptors of this review.
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Authors | [read] The users who are authors of this review.
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackages | [read] all change packages or an empty array
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Review.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
PulseLabel | [read/write] the Pulse Labe of this Review.
Rejectors | [read] The users who are rejectors of this review.
Reviewers | [read] The users who are reviewers of this review.
ReviewID | [read] the review id.
ReviewTypeValue | [read/write] The review type of the review
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The status of the review
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
Watchers | [read] The users who are watchers of this review.

Public Instance Methods

AddAcceptor | Adds the specified user object as a acceptor of this review.
AddAuthor | Adds the specified user object as an author of this review.
AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddRejector | Adds the specified user object as a rejector of this review.
AddReviewer | Adds the specified user object as a reviewer of this review.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AddWatcher | Adds the specified user object as a watcher of this review.
CanCommitLinkedSession | Returns true if the associated ChangePackage(s) session can be committed
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveAcceptor | Removes the specified user object as a acceptor of this review.
RemoveAuthor | Removes the specified user object as an author of this review.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
RemoveRejector | Removes the specified user object as a rejector of this review.
RemoveReviewer | Removes the specified user object as a reviewer of this review.
RemoveWatcher | Removes the specified user object as a watcher of this review.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Review Class | StarTeam Namespace


Review Properties

The properties of the Review class are listed below. For a complete list of Review class members, see the Review Members topic.

Public Instance Properties

Acceptors | [read] The users who are acceptors of this review.
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Authors | [read] The users who are authors of this review.
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackages | [read] all change packages or an empty array
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Review.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
PulseLabel | [read/write] the Pulse Labe of this Review.
Rejectors | [read] The users who are rejectors of this review.
Reviewers | [read] The users who are reviewers of this review.
ReviewID | [read] the review id.
ReviewTypeValue | [read/write] The review type of the review
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The status of the review
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
Watchers | [read] The users who are watchers of this review.

See Also

Review Class | StarTeam Namespace


Acceptors Property

Borland StarTeam SDK for .NET

Review.Acceptors Property

[read] The users who are acceptors of this review.

public virtual User[] Acceptors {get;}

Property Value

The users who are acceptors of this review.

See Also

Review Class | StarTeam Namespace


Authors Property

Borland StarTeam SDK for .NET

Review.Authors Property

[read] The users who are authors of this review.

public virtual User[] Authors {get;}

Property Value

The users who are authors of this review.

See Also

Review Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Review.ChangePackages Property

[read] all change packages or an empty array

public virtual ChangePackage[] ChangePackages {get;}

Property Value

all change packages or an empty array

See Also

Review Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Review.Name Property

[read/write] the Name of this Review.

public virtual String Name {get; set;}

Property Value

the Name of this Review.

See Also

Review Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Review.Properties Property

[read] the PropertyCollection of its Type

public virtual Review.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

Review Class | StarTeam Namespace


PulseLabel Property

Borland StarTeam SDK for .NET

Review.PulseLabel Property

[read/write] the Pulse Labe of this Review.

public virtual String PulseLabel {get; set;}

Property Value

the Pulse Labe of this Review.

See Also

Review Class | StarTeam Namespace


Rejectors Property

Borland StarTeam SDK for .NET

Review.Rejectors Property

[read] The users who are rejectors of this review.

public virtual User[] Rejectors {get;}

Property Value

The users who are rejectors of this review.

See Also

Review Class | StarTeam Namespace


Reviewers Property

Borland StarTeam SDK for .NET

Review.Reviewers Property

[read] The users who are reviewers of this review.

public virtual User[] Reviewers {get;}

Property Value

The users who are reviewers of this review.

See Also

Review Class | StarTeam Namespace


ReviewID Property

Borland StarTeam SDK for .NET

Review.ReviewID Property

[read] the review id.

public virtual Int32 ReviewID {get;}

Property Value

the review id.

See Also

Review Class | StarTeam Namespace


ReviewTypeValue Property

Borland StarTeam SDK for .NET

Review.ReviewTypeValue Property

[read/write] The review type of the review

public virtual Review.ReviewType ReviewTypeValue {get; set;}

Property Value

The review type of the review

See Also

Review Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Review.StatusValue Property

[read/write] The status of the review

public virtual Review.Status StatusValue {get; set;}

Property Value

The status of the review

See Also

Review Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Review.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Review Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Review.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Review Class | StarTeam Namespace


Watchers Property

Borland StarTeam SDK for .NET

Review.Watchers Property

[read] The users who are watchers of this review.

public virtual User[] Watchers {get;}

Property Value

The users who are watchers of this review.

See Also

Review Class | StarTeam Namespace


Review Methods

The methods of the Review class are listed below. For a complete list of Review class members, see the Review Members topic.

Public Static Methods

Create Create a Review in the specified parent folder.

Public Instance Methods

AddAcceptor | Adds the specified user object as a acceptor of this review.
AddAuthor | Adds the specified user object as an author of this review.
AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddRejector | Adds the specified user object as a rejector of this review.
AddReviewer | Adds the specified user object as a reviewer of this review.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AddWatcher | Adds the specified user object as a watcher of this review.
CanCommitLinkedSession | Returns true if the associated ChangePackage(s) session can be committed
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveAcceptor | Removes the specified user object as a acceptor of this review.
RemoveAuthor | Removes the specified user object as an author of this review.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
RemoveRejector | Removes the specified user object as a rejector of this review.
RemoveReviewer | Removes the specified user object as a reviewer of this review.
RemoveWatcher | Removes the specified user object as a watcher of this review.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Review Class | StarTeam Namespace


Review.AddAcceptor Method

Adds the specified user object as a acceptor of this review.

public virtual void AddAcceptor(
User user
);

Parameters

user
the user object to add as a acceptor of this review

See Also

Review Class | StarTeam Namespace


Review.AddAuthor Method

Adds the specified user object as an author of this review.

public virtual void AddAuthor(
User user
);

Parameters

user
the user object to add as an author of this review

See Also

Review Class | StarTeam Namespace


Review.AddRejector Method

Adds the specified user object as a rejector of this review.

public virtual void AddRejector(
User user
);

Parameters

user
the user object to add as a rejector of this review

See Also

Review Class | StarTeam Namespace


Review.AddReviewer Method

Adds the specified user object as a reviewer of this review.

public virtual void AddReviewer(
User user
);

Parameters

user
the user object to add as a reviewer of this review

See Also

Review Class | StarTeam Namespace


Review.AddWatcher Method

Adds the specified user object as a watcher of this review.

public virtual void AddWatcher(
User user
);

Parameters

user
the user object to add as a watcher of this review

See Also

Review Class | StarTeam Namespace


Review.CanCommitLinkedSession Method

Returns true if the associated ChangePackage(s) session can be committed

public virtual bool CanCommitLinkedSession();

Return Value

true if the associated ChangePackage(s) session can be committed

See Also

Review Class | StarTeam Namespace


Review.Create Method

Create a Review in the specified parent folder.

public static Review Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Review Object.

See Also

Review Class | StarTeam Namespace


Review.RemoveAcceptor Method

Removes the specified user object as a acceptor of this review.

public virtual void RemoveAcceptor(
User user
);

Parameters

user
the user object to remove as a acceptor of this review.

See Also

Review Class | StarTeam Namespace


Review.RemoveAuthor Method

Removes the specified user object as an author of this review.

public virtual void RemoveAuthor(
User user
);

Parameters

user
the user object to remove as an author of this review.

See Also

Review Class | StarTeam Namespace


Review.RemoveRejector Method

Removes the specified user object as a rejector of this review.

public virtual void RemoveRejector(
User user
);

Parameters

user
the user object to remove as a rejector of this review.

See Also

Review Class | StarTeam Namespace


Review.RemoveReviewer Method

Removes the specified user object as a reviewer of this review.

public virtual void RemoveReviewer(
User user
);

Parameters

user
the user object to remove as a reviewer of this review.

See Also

Review Class | StarTeam Namespace


Review.RemoveWatcher Method

Removes the specified user object as a watcher of this review.

public virtual void RemoveWatcher(
User user
);

Parameters

user
the user object to remove as a watcher of this review.

See Also

Review Class | StarTeam Namespace


Review.ReviewType Class

The type of Review

For a list of all members of this type, see Review.ReviewType Members.

System.Object
EnumeratedValue
Review.ReviewType

public class Review.ReviewType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.ReviewType Members | StarTeam Namespace


Review.ReviewType Members

Review.ReviewType overview

Public Static Properties

ALL
CHANGE_PACKAGE
CODE
PULL_REQUEST

Public Static Methods

FromID | Gets the Review Type value corresponding to the given ID.
FromValue | Gets the Review Type value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Review Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Review.ReviewType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Review.ReviewType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Review.ReviewType.

See Also

Review.ReviewType Class | StarTeam Namespace


Review.ReviewType Properties

The properties of the Review.ReviewType class are listed below. For a complete list of Review.ReviewType class members, see the Review.ReviewType Members topic.

Public Static Properties

ALL
CHANGE_PACKAGE
CODE
PULL_REQUEST

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Review Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Review.ReviewType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Review.ReviewType.ALL Property

public static ReviewType[] ALL {get;}

See Also

Review.ReviewType Class | StarTeam Namespace


CHANGE_PACKAGE Property

Borland StarTeam SDK for .NET

Review.ReviewType.CHANGE_PACKAGE Property

public static Review.ReviewType CHANGE_PACKAGE {get;}

Property Value

A change package review

See Also

Review.ReviewType Class | StarTeam Namespace


CODE Property

Borland StarTeam SDK for .NET

Review.ReviewType.CODE Property

public static Review.ReviewType CODE {get;}

Property Value

A code review

See Also

Review.ReviewType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Review.ReviewType.ID Property

[read] the ID of this Review Type value.

public virtual Int32 ID {get;}

Property Value

the ID of this Review Type value.

See Also

Review.ReviewType Class | StarTeam Namespace


PULL_REQUEST Property

Borland StarTeam SDK for .NET

Review.ReviewType.PULL_REQUEST Property

public static Review.ReviewType PULL_REQUEST {get;}

Property Value

A pull request review

See Also

Review.ReviewType Class | StarTeam Namespace


Review.ReviewType Methods

The methods of the Review.ReviewType class are listed below. For a complete list of Review.ReviewType class members, see the Review.ReviewType Members topic.

Public Static Methods

FromID | Gets the Review Type value corresponding to the given ID.
FromValue | Gets the Review Type value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Review.ReviewType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Review.ReviewType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Review.ReviewType.

See Also

Review.ReviewType Class | StarTeam Namespace


Review.ReviewType.Equals Method

Delegate Equals() to com.starteam.Review.ReviewType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.ReviewType.Equals(obj).

See Also

Review.ReviewType Class | StarTeam Namespace


Review.ReviewType.FromID Method

Gets the Review Type value corresponding to the given ID.

public static ReviewType FromID(
Int32 id
);

Parameters

id
A Review Type ID.

Return Value

the corresponding Review Type value, or null.

See Also

Review.ReviewType Class | StarTeam Namespace


Review.ReviewType.FromValue Method

Gets the Review Type value corresponding to the given EnumeratedValue.

public static ReviewType FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a ReviewTypeProperty.

Return Value

the corresponding ReviewType value, or null.

See Also

Review.ReviewType Class | StarTeam Namespace


Review.ReviewType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.ReviewType.

public override int GetHashCode();

Return Value

com.starteam.Review.ReviewType.GetHashCode().

See Also

Review.ReviewType Class | StarTeam Namespace


Review.ReviewType.ToString Method

Delegate ToString() to com.starteam.Review.ReviewType.

public override string ToString();

Return Value

com.starteam.Review.ReviewType.ToString()

See Also

Review.ReviewType Class | StarTeam Namespace


Review.Status Class

The status of the Review

For a list of all members of this type, see Review.Status Members.

System.Object
EnumeratedValue
Review.Status

public class Review.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Status Members | StarTeam Namespace


Review.Status Members

Review.Status overview

Public Static Properties

ABANDONED
ACTIVE
ALL
APPROVED
APPROVED_IN_MERGE
APPROVED_MERGE_FAILURE
CANCELED
CLOSED
COMPLETED
DRAFT
IN_REVIEW
NEW
NOT_AVAILABLE
REWORK

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Review.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Review.Status.

See Also

Review.Status Class | StarTeam Namespace


Review.Status Properties

The properties of the Review.Status class are listed below. For a complete list of Review.Status class members, see the Review.Status Members topic.

Public Static Properties

ABANDONED
ACTIVE
ALL
APPROVED
APPROVED_IN_MERGE
APPROVED_MERGE_FAILURE
CANCELED
CLOSED
COMPLETED
DRAFT
IN_REVIEW
NEW
NOT_AVAILABLE
REWORK

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Review.Status Class | StarTeam Namespace


ABANDONED Property

Borland StarTeam SDK for .NET

Review.Status.ABANDONED Property

public static Review.Status ABANDONED {get;}

Property Value

Abandoned

See Also

Review.Status Class | StarTeam Namespace


ACTIVE Property

Borland StarTeam SDK for .NET

Review.Status.ACTIVE Property

public static Review.Status ACTIVE {get;}

Property Value

Active

See Also

Review.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Review.Status.ALL Property

public static Status[] ALL {get;}

See Also

Review.Status Class | StarTeam Namespace


APPROVED Property

Borland StarTeam SDK for .NET

Review.Status.APPROVED Property

public static Review.Status APPROVED {get;}

Property Value

Approved

See Also

Review.Status Class | StarTeam Namespace


APPROVED_IN_MERGE Property

Borland StarTeam SDK for .NET

Review.Status.APPROVED_IN_MERGE Property

public static Review.Status APPROVED_IN_MERGE {get;}

Property Value

Approved In Merge

See Also

Review.Status Class | StarTeam Namespace


APPROVED_MERGE_FAILURE Property

Borland StarTeam SDK for .NET

Review.Status.APPROVED_MERGE_FAILURE Property

public static Review.Status APPROVED_MERGE_FAILURE {get;}

Property Value

Approved In Merge Failure

See Also

Review.Status Class | StarTeam Namespace


CANCELED Property

Borland StarTeam SDK for .NET

Review.Status.CANCELED Property

public static Review.Status CANCELED {get;}

Property Value

Canceled

See Also

Review.Status Class | StarTeam Namespace


CLOSED Property

Borland StarTeam SDK for .NET

Review.Status.CLOSED Property

public static Review.Status CLOSED {get;}

Property Value

Closed

See Also

Review.Status Class | StarTeam Namespace


COMPLETED Property

Borland StarTeam SDK for .NET

Review.Status.COMPLETED Property

public static Review.Status COMPLETED {get;}

Property Value

Completed

See Also

Review.Status Class | StarTeam Namespace


DRAFT Property

Borland StarTeam SDK for .NET

Review.Status.DRAFT Property

public static Review.Status DRAFT {get;}

Property Value

Draft

See Also

Review.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Review.Status.ID Property

[read] the ID of this Status value.

public virtual Int32 ID {get;}

Property Value

the ID of this Status value.

See Also

Review.Status Class | StarTeam Namespace


IN_REVIEW Property

Borland StarTeam SDK for .NET

Review.Status.IN_REVIEW Property

public static Review.Status IN_REVIEW {get;}

Property Value

In Review

See Also

Review.Status Class | StarTeam Namespace


NEW Property

Borland StarTeam SDK for .NET

Review.Status.NEW Property

public static Review.Status NEW {get;}

Property Value

New

See Also

Review.Status Class | StarTeam Namespace


NOT_AVAILABLE Property

Borland StarTeam SDK for .NET

Review.Status.NOT_AVAILABLE Property

public static Review.Status NOT_AVAILABLE {get;}

Property Value

Not Available

See Also

Review.Status Class | StarTeam Namespace


REWORK Property

Borland StarTeam SDK for .NET

Review.Status.REWORK Property

public static Review.Status REWORK {get;}

Property Value

Rework

See Also

Review.Status Class | StarTeam Namespace


Review.Status Methods

The methods of the Review.Status class are listed below. For a complete list of Review.Status class members, see the Review.Status Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Review.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Review.Status.

See Also

Review.Status Class | StarTeam Namespace


Review.Status.Equals Method

Delegate Equals() to com.starteam.Review.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Status.Equals(obj).

See Also

Review.Status Class | StarTeam Namespace


Review.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

the corresponding Status value, or null.

See Also

Review.Status Class | StarTeam Namespace


Review.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a StatusProperty.

Return Value

the corresponding Status value, or null.

See Also

Review.Status Class | StarTeam Namespace


Review.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Status.

public override int GetHashCode();

Return Value

com.starteam.Review.Status.GetHashCode().

See Also

Review.Status Class | StarTeam Namespace


Review.Status.ToString Method

Delegate ToString() to com.starteam.Review.Status.

public override string ToString();

Return Value

com.starteam.Review.Status.ToString()

See Also

Review.Status Class | StarTeam Namespace


Review.Type Class

Type meta-data (schema) for Review object instances.

For a list of all members of this type, see Review.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
Review.Type

new public class Review.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type Members | StarTeam Namespace


Review.Type Members

Review.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Review.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Review.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Review.Type Class | StarTeam Namespace


Review.Type Properties

The properties of the Review.Type class are listed below. For a complete list of Review.Type class members, see the Review.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Review.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Review.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Review.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Review.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Review.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Review.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Review.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Review.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Review.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Review.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Review.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Review.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Review.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Review.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Review.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.NAME Property

new public static String NAME {get;}

See Also

Review.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Review.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Review.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Review.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Review.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Review.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Review.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Review.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Review.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Review.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Review.Type Class | StarTeam Namespace


Review.Type Methods

The methods of the Review.Type class are listed below. For a complete list of Review.Type class members, see the Review.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Review.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Review.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Review.Type Class | StarTeam Namespace


Review.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Review.Type Class | StarTeam Namespace


Review.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Review.Type Class | StarTeam Namespace


Review.Type.Equals Method

Delegate Equals() to com.starteam.Review.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.Equals(obj).

See Also

Review.Type Class | StarTeam Namespace


Review.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Review.Type Class | StarTeam Namespace


Review.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.GetHashCode().

See Also

Review.Type Class | StarTeam Namespace


Review.Type.ToString Method

Delegate ToString() to com.starteam.Review.Type.

public override string ToString();

Return Value

com.starteam.Review.Type.ToString()

See Also

Review.Type Class | StarTeam Namespace


Review.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Review.Type Class | StarTeam Namespace


Review.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Review.Type Class | StarTeam Namespace


Review.Type.AcceptorsProperty Class

The property type of the Acceptors property

For a list of all members of this type, see Review.Type.AcceptorsProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Review.Type.AcceptorsProperty

public class Review.Type.AcceptorsProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.AcceptorsProperty Members | StarTeam Namespace


Review.Type.AcceptorsProperty Members

Review.Type.AcceptorsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.AcceptorsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.AcceptorsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.AcceptorsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.AcceptorsProperty Class | StarTeam Namespace


Review.Type.AcceptorsProperty Properties

The properties of the Review.Type.AcceptorsProperty class are listed below. For a complete list of Review.Type.AcceptorsProperty class members, see the Review.Type.AcceptorsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Review.Type.AcceptorsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.AcceptorsProperty.NAME Property

public static String NAME {get;}

See Also

Review.Type.AcceptorsProperty Class | StarTeam Namespace


Review.Type.AcceptorsProperty Methods

The methods of the Review.Type.AcceptorsProperty class are listed below. For a complete list of Review.Type.AcceptorsProperty class members, see the Review.Type.AcceptorsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.AcceptorsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.AcceptorsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.AcceptorsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.AcceptorsProperty Class | StarTeam Namespace


Review.Type.AcceptorsProperty.Equals Method

Delegate Equals() to com.starteam.Review.Type.AcceptorsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.AcceptorsProperty.Equals(obj).

See Also

Review.Type.AcceptorsProperty Class | StarTeam Namespace


Review.Type.AcceptorsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.AcceptorsProperty.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.AcceptorsProperty.GetHashCode().

See Also

Review.Type.AcceptorsProperty Class | StarTeam Namespace


Review.Type.AcceptorsProperty.ToString Method

Delegate ToString() to com.starteam.Review.Type.AcceptorsProperty.

public override string ToString();

Return Value

com.starteam.Review.Type.AcceptorsProperty.ToString()

See Also

Review.Type.AcceptorsProperty Class | StarTeam Namespace


Review.Type.AuthorsProperty Class

The property type of the Authors property

For a list of all members of this type, see Review.Type.AuthorsProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Review.Type.AuthorsProperty

public class Review.Type.AuthorsProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.AuthorsProperty Members | StarTeam Namespace


Review.Type.AuthorsProperty Members

Review.Type.AuthorsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.AuthorsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.AuthorsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.AuthorsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.AuthorsProperty Class | StarTeam Namespace


Review.Type.AuthorsProperty Properties

The properties of the Review.Type.AuthorsProperty class are listed below. For a complete list of Review.Type.AuthorsProperty class members, see the Review.Type.AuthorsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Review.Type.AuthorsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.AuthorsProperty.NAME Property

public static String NAME {get;}

See Also

Review.Type.AuthorsProperty Class | StarTeam Namespace


Review.Type.AuthorsProperty Methods

The methods of the Review.Type.AuthorsProperty class are listed below. For a complete list of Review.Type.AuthorsProperty class members, see the Review.Type.AuthorsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.AuthorsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.AuthorsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.AuthorsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.AuthorsProperty Class | StarTeam Namespace


Review.Type.AuthorsProperty.Equals Method

Delegate Equals() to com.starteam.Review.Type.AuthorsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.AuthorsProperty.Equals(obj).

See Also

Review.Type.AuthorsProperty Class | StarTeam Namespace


Review.Type.AuthorsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.AuthorsProperty.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.AuthorsProperty.GetHashCode().

See Also

Review.Type.AuthorsProperty Class | StarTeam Namespace


Review.Type.AuthorsProperty.ToString Method

Delegate ToString() to com.starteam.Review.Type.AuthorsProperty.

public override string ToString();

Return Value

com.starteam.Review.Type.AuthorsProperty.ToString()

See Also

Review.Type.AuthorsProperty Class | StarTeam Namespace


Review.Type.PropertyCollection Class

The PropertyCollection of a Review

For a list of all members of this type, see Review.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Review.Type.PropertyCollection

new public class Review.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.PropertyCollection Members | StarTeam Namespace


Review.Type.PropertyCollection Members

Review.Type.PropertyCollection overview

Public Instance Properties

ACCEPTORS |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
AUTHORS |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PULSE_LABEL |
REJECTORS |
REVIEW_ID |
REVIEW_TYPE |
REVIEWERS |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WATCHERS |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Review.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Review.Type.PropertyCollection.

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


Review.Type.PropertyCollection Properties

The properties of the Review.Type.PropertyCollection class are listed below. For a complete list of Review.Type.PropertyCollection class members, see the Review.Type.PropertyCollection Members topic.

Public Instance Properties

ACCEPTORS |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
AUTHORS |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PULSE_LABEL |
REJECTORS |
REVIEW_ID |
REVIEW_TYPE |
REVIEWERS |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WATCHERS |

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


ACCEPTORS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.ACCEPTORS Property

public Review.Type.AcceptorsProperty ACCEPTORS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


AUTHORS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.AUTHORS Property

public Review.Type.AuthorsProperty AUTHORS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


PULSE_LABEL Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.PULSE_LABEL Property

public Review.Type.PulseLabelProperty PULSE_LABEL {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


REJECTORS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.REJECTORS Property

public Review.Type.RejectorsProperty REJECTORS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


REVIEW_ID Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.REVIEW_ID Property

public Review.Type.ReviewIDProperty REVIEW_ID {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


REVIEW_TYPE Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.REVIEW_TYPE Property

public Review.Type.ReviewTypeProperty REVIEW_TYPE {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


REVIEWERS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.REVIEWERS Property

public Review.Type.ReviewersProperty REVIEWERS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.STATUS Property

public Review.Type.StatusProperty STATUS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.VERSION_METADATA Property

public Item.Type.VersionMetadataProperty VERSION_METADATA {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA_IDS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.VERSION_METADATA_IDS Property

public Item.Type.VersionMetadataIDsProperty VERSION_METADATA_IDS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


WATCHERS Property

Borland StarTeam SDK for .NET

Review.Type.PropertyCollection.WATCHERS Property

public Review.Type.WatchersProperty WATCHERS {get;}

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


Review.Type.PropertyCollection Methods

The methods of the Review.Type.PropertyCollection class are listed below. For a complete list of Review.Type.PropertyCollection class members, see the Review.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Review.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Review.Type.PropertyCollection.

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


Review.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Review.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.PropertyCollection.Equals(obj).

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


Review.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.PropertyCollection.GetHashCode().

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


Review.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Review.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Review.Type.PropertyCollection.ToString()

See Also

Review.Type.PropertyCollection Class | StarTeam Namespace


Review.Type.PulseLabelProperty Class

The property type of the PulseLabel property.

For a list of all members of this type, see Review.Type.PulseLabelProperty Members.

System.Object
Property
VectorProperty
TextProperty
Review.Type.PulseLabelProperty

public class Review.Type.PulseLabelProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.PulseLabelProperty Members | StarTeam Namespace


Review.Type.PulseLabelProperty Members

Review.Type.PulseLabelProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.PulseLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.PulseLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.PulseLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.PulseLabelProperty Class | StarTeam Namespace


Review.Type.PulseLabelProperty Properties

The properties of the Review.Type.PulseLabelProperty class are listed below. For a complete list of Review.Type.PulseLabelProperty class members, see the Review.Type.PulseLabelProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Review.Type.PulseLabelProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.PulseLabelProperty.NAME Property

public static String NAME {get;}

See Also

Review.Type.PulseLabelProperty Class | StarTeam Namespace


Review.Type.PulseLabelProperty Methods

The methods of the Review.Type.PulseLabelProperty class are listed below. For a complete list of Review.Type.PulseLabelProperty class members, see the Review.Type.PulseLabelProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.PulseLabelProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.PulseLabelProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.PulseLabelProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.PulseLabelProperty Class | StarTeam Namespace


Review.Type.PulseLabelProperty.Equals Method

Delegate Equals() to com.starteam.Review.Type.PulseLabelProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.PulseLabelProperty.Equals(obj).

See Also

Review.Type.PulseLabelProperty Class | StarTeam Namespace


Review.Type.PulseLabelProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.PulseLabelProperty.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.PulseLabelProperty.GetHashCode().

See Also

Review.Type.PulseLabelProperty Class | StarTeam Namespace


Review.Type.PulseLabelProperty.ToString Method

Delegate ToString() to com.starteam.Review.Type.PulseLabelProperty.

public override string ToString();

Return Value

com.starteam.Review.Type.PulseLabelProperty.ToString()

See Also

Review.Type.PulseLabelProperty Class | StarTeam Namespace


Review.Type.RejectorsProperty Class

The property type of the Rejectors property

For a list of all members of this type, see Review.Type.RejectorsProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Review.Type.RejectorsProperty

public class Review.Type.RejectorsProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.RejectorsProperty Members | StarTeam Namespace


Review.Type.RejectorsProperty Members

Review.Type.RejectorsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.RejectorsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.RejectorsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.RejectorsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.RejectorsProperty Class | StarTeam Namespace


Review.Type.RejectorsProperty Properties

The properties of the Review.Type.RejectorsProperty class are listed below. For a complete list of Review.Type.RejectorsProperty class members, see the Review.Type.RejectorsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Review.Type.RejectorsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.RejectorsProperty.NAME Property

public static String NAME {get;}

See Also

Review.Type.RejectorsProperty Class | StarTeam Namespace


Review.Type.RejectorsProperty Methods

The methods of the Review.Type.RejectorsProperty class are listed below. For a complete list of Review.Type.RejectorsProperty class members, see the Review.Type.RejectorsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.RejectorsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.RejectorsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.RejectorsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.RejectorsProperty Class | StarTeam Namespace


Review.Type.RejectorsProperty.Equals Method

Delegate Equals() to com.starteam.Review.Type.RejectorsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.RejectorsProperty.Equals(obj).

See Also

Review.Type.RejectorsProperty Class | StarTeam Namespace


Review.Type.RejectorsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.RejectorsProperty.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.RejectorsProperty.GetHashCode().

See Also

Review.Type.RejectorsProperty Class | StarTeam Namespace


Review.Type.RejectorsProperty.ToString Method

Delegate ToString() to com.starteam.Review.Type.RejectorsProperty.

public override string ToString();

Return Value

com.starteam.Review.Type.RejectorsProperty.ToString()

See Also

Review.Type.RejectorsProperty Class | StarTeam Namespace


Review.Type.ReviewersProperty Class

The property type of the Reviewers property

For a list of all members of this type, see Review.Type.ReviewersProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Review.Type.ReviewersProperty

public class Review.Type.ReviewersProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.ReviewersProperty Members | StarTeam Namespace


Review.Type.ReviewersProperty Members

Review.Type.ReviewersProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.ReviewersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.ReviewersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.ReviewersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.ReviewersProperty Class | StarTeam Namespace


Review.Type.ReviewersProperty Properties

The properties of the Review.Type.ReviewersProperty class are listed below. For a complete list of Review.Type.ReviewersProperty class members, see the Review.Type.ReviewersProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Review.Type.ReviewersProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.ReviewersProperty.NAME Property

public static String NAME {get;}

See Also

Review.Type.ReviewersProperty Class | StarTeam Namespace


Review.Type.ReviewersProperty Methods

The methods of the Review.Type.ReviewersProperty class are listed below. For a complete list of Review.Type.ReviewersProperty class members, see the Review.Type.ReviewersProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.ReviewersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.ReviewersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.ReviewersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.ReviewersProperty Class | StarTeam Namespace


Review.Type.ReviewersProperty.Equals Method

Delegate Equals() to com.starteam.Review.Type.ReviewersProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.ReviewersProperty.Equals(obj).

See Also

Review.Type.ReviewersProperty Class | StarTeam Namespace


Review.Type.ReviewersProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.ReviewersProperty.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.ReviewersProperty.GetHashCode().

See Also

Review.Type.ReviewersProperty Class | StarTeam Namespace


Review.Type.ReviewersProperty.ToString Method

Delegate ToString() to com.starteam.Review.Type.ReviewersProperty.

public override string ToString();

Return Value

com.starteam.Review.Type.ReviewersProperty.ToString()

See Also

Review.Type.ReviewersProperty Class | StarTeam Namespace


Review.Type.ReviewIDProperty Class

The property type of the SprintID property

For a list of all members of this type, see Review.Type.ReviewIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Review.Type.ReviewIDProperty

public class Review.Type.ReviewIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.ReviewIDProperty Members | StarTeam Namespace


Review.Type.ReviewIDProperty Members

Review.Type.ReviewIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.ReviewIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.ReviewIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.ReviewIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.ReviewIDProperty Class | StarTeam Namespace


Review.Type.ReviewIDProperty Properties

The properties of the Review.Type.ReviewIDProperty class are listed below. For a complete list of Review.Type.ReviewIDProperty class members, see the Review.Type.ReviewIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Review.Type.ReviewIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.ReviewIDProperty.NAME Property

public static String NAME {get;}

See Also

Review.Type.ReviewIDProperty Class | StarTeam Namespace


Review.Type.ReviewIDProperty Methods

The methods of the Review.Type.ReviewIDProperty class are listed below. For a complete list of Review.Type.ReviewIDProperty class members, see the Review.Type.ReviewIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.ReviewIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.ReviewIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.ReviewIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.ReviewIDProperty Class | StarTeam Namespace


Review.Type.ReviewIDProperty.Equals Method

Delegate Equals() to com.starteam.Review.Type.ReviewIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.ReviewIDProperty.Equals(obj).

See Also

Review.Type.ReviewIDProperty Class | StarTeam Namespace


Review.Type.ReviewIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.ReviewIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.ReviewIDProperty.GetHashCode().

See Also

Review.Type.ReviewIDProperty Class | StarTeam Namespace


Review.Type.ReviewIDProperty.ToString Method

Delegate ToString() to com.starteam.Review.Type.ReviewIDProperty.

public override string ToString();

Return Value

com.starteam.Review.Type.ReviewIDProperty.ToString()

See Also

Review.Type.ReviewIDProperty Class | StarTeam Namespace


Review.Type.ReviewTypeProperty Class

The property type of the ReviewType property.

For a list of all members of this type, see Review.Type.ReviewTypeProperty Members.

System.Object
Property
EnumeratedProperty
Review.Type.ReviewTypeProperty

public class Review.Type.ReviewTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.ReviewTypeProperty Members | StarTeam Namespace


Review.Type.ReviewTypeProperty Members

Review.Type.ReviewTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Review.Type.ReviewTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.ReviewTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Review.Type.ReviewTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.ReviewTypeProperty Class | StarTeam Namespace


Review.Type.ReviewTypeProperty Properties

The properties of the Review.Type.ReviewTypeProperty class are listed below. For a complete list of Review.Type.ReviewTypeProperty class members, see the Review.Type.ReviewTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Review.Type.ReviewTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.ReviewTypeProperty.NAME Property

public static String NAME {get;}

See Also

Review.Type.ReviewTypeProperty Class | StarTeam Namespace


Review.Type.ReviewTypeProperty Methods

The methods of the Review.Type.ReviewTypeProperty class are listed below. For a complete list of Review.Type.ReviewTypeProperty class members, see the Review.Type.ReviewTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Review.Type.ReviewTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.ReviewTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Review.Type.ReviewTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.ReviewTypeProperty Class | StarTeam Namespace


Review.Type.ReviewTypeProperty.Equals Method

Delegate Equals() to com.starteam.Review.Type.ReviewTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.ReviewTypeProperty.Equals(obj).

See Also

Review.Type.ReviewTypeProperty Class | StarTeam Namespace


Review.Type.ReviewTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Review.ReviewType value
);

See Also

Review.Type.ReviewTypeProperty Class | StarTeam Namespace


Review.Type.ReviewTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.ReviewTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.ReviewTypeProperty.GetHashCode().

See Also

Review.Type.ReviewTypeProperty Class | StarTeam Namespace


Review.Type.ReviewTypeProperty.ToString Method

Delegate ToString() to com.starteam.Review.Type.ReviewTypeProperty.

public override string ToString();

Return Value

com.starteam.Review.Type.ReviewTypeProperty.ToString()

See Also

Review.Type.ReviewTypeProperty Class | StarTeam Namespace


Review.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see Review.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
Review.Type.StatusProperty

public class Review.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.StatusProperty Members | StarTeam Namespace


Review.Type.StatusProperty Members

Review.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Review.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Review.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.StatusProperty Class | StarTeam Namespace


Review.Type.StatusProperty Properties

The properties of the Review.Type.StatusProperty class are listed below. For a complete list of Review.Type.StatusProperty class members, see the Review.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Review.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

Review.Type.StatusProperty Class | StarTeam Namespace


Review.Type.StatusProperty Methods

The methods of the Review.Type.StatusProperty class are listed below. For a complete list of Review.Type.StatusProperty class members, see the Review.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Review.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Review.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.StatusProperty Class | StarTeam Namespace


Review.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.Review.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.StatusProperty.Equals(obj).

See Also

Review.Type.StatusProperty Class | StarTeam Namespace


Review.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Review.Status value
);

See Also

Review.Type.StatusProperty Class | StarTeam Namespace


Review.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.StatusProperty.GetHashCode().

See Also

Review.Type.StatusProperty Class | StarTeam Namespace


Review.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.Review.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.Review.Type.StatusProperty.ToString()

See Also

Review.Type.StatusProperty Class | StarTeam Namespace


Review.Type.WatchersProperty Class

The property type of the Watchers property

For a list of all members of this type, see Review.Type.WatchersProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Review.Type.WatchersProperty

public class Review.Type.WatchersProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.Type.WatchersProperty Members | StarTeam Namespace


Review.Type.WatchersProperty Members

Review.Type.WatchersProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.WatchersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.WatchersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.WatchersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.WatchersProperty Class | StarTeam Namespace


Review.Type.WatchersProperty Properties

The properties of the Review.Type.WatchersProperty class are listed below. For a complete list of Review.Type.WatchersProperty class members, see the Review.Type.WatchersProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Review.Type.WatchersProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Review.Type.WatchersProperty.NAME Property

public static String NAME {get;}

See Also

Review.Type.WatchersProperty Class | StarTeam Namespace


Review.Type.WatchersProperty Methods

The methods of the Review.Type.WatchersProperty class are listed below. For a complete list of Review.Type.WatchersProperty class members, see the Review.Type.WatchersProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Review.Type.WatchersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Review.Type.WatchersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Review.Type.WatchersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Review.Type.WatchersProperty Class | StarTeam Namespace


Review.Type.WatchersProperty.Equals Method

Delegate Equals() to com.starteam.Review.Type.WatchersProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.Type.WatchersProperty.Equals(obj).

See Also

Review.Type.WatchersProperty Class | StarTeam Namespace


Review.Type.WatchersProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.Type.WatchersProperty.

public override int GetHashCode();

Return Value

com.starteam.Review.Type.WatchersProperty.GetHashCode().

See Also

Review.Type.WatchersProperty Class | StarTeam Namespace


Review.Type.WatchersProperty.ToString Method

Delegate ToString() to com.starteam.Review.Type.WatchersProperty.

public override string ToString();

Return Value

com.starteam.Review.Type.WatchersProperty.ToString()

See Also

Review.Type.WatchersProperty Class | StarTeam Namespace


Review.WebCacheReview Class

Item accessor for cached SDK Review items contained objects are obtained from the artifact cache

For a list of all members of this type, see Review.WebCacheReview Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
Review.WebCacheReview

public class Review.WebCacheReview : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Review.WebCacheReview Members | StarTeam Namespace


Review.WebCacheReview Members

Review.WebCacheReview overview

Public Static Methods

Create Overloaded.

Public Instance Properties

Acceptors | [read] The acceptors of this review.
Attachments | [read/write] an array of attachments for this ViewMember
Authors | [read] The authors of this review.
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
PulseLabel | [read/write] the Pulse Labe of this Review.
Rejectors | [read] The rejectors of this review.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
Reviewers | [read] The reviewers of this review.
ReviewID | [read] the review id.
ReviewTypeValue | [read/write] The review type of this review
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The status of this review
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
Watchers | [read] The watchers of this review.

Public Instance Methods

AddAcceptor |
AddAuthor |
AddNotifiedUser |
AddRejector |
AddReviewer |
AddTo |
AddWatcher |
Copy |
Equals | Delegate Equals() to com.starteam.Review.WebCacheReview.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Review.WebCacheReview.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveAcceptor |
RemoveAuthor |
RemoveFrom |
RemoveNotifiedUser |
RemoveRejector |
RemoveReviewer |
RemoveWatcher |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Review.WebCacheReview.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview Properties

The properties of the Review.WebCacheReview class are listed below. For a complete list of Review.WebCacheReview class members, see the Review.WebCacheReview Members topic.

Public Instance Properties

Acceptors | [read] The acceptors of this review.
Attachments | [read/write] an array of attachments for this ViewMember
Authors | [read] The authors of this review.
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
PulseLabel | [read/write] the Pulse Labe of this Review.
Rejectors | [read] The rejectors of this review.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
Reviewers | [read] The reviewers of this review.
ReviewID | [read] the review id.
ReviewTypeValue | [read/write] The review type of this review
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The status of this review
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
Watchers | [read] The watchers of this review.

See Also

Review.WebCacheReview Class | StarTeam Namespace


Acceptors Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Acceptors Property

[read] The acceptors of this review.

public virtual WebCacheUser[] Acceptors {get;}

Property Value

The acceptors of this review.

See Also

Review.WebCacheReview Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Review.WebCacheReview Class | StarTeam Namespace


Authors Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Authors Property

[read] The authors of this review.

public virtual WebCacheUser[] Authors {get;}

Property Value

The authors of this review.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Review.WebCacheReview Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Review.WebCacheReview Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Review.WebCacheReview Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Review.WebCacheReview Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Review.WebCacheReview Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Review.WebCacheReview Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Review.WebCacheReview Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Review.WebCacheReview Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Review.WebCacheReview Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Review.WebCacheReview Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Review.WebCacheReview Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Review.WebCacheReview Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Review.WebCacheReview Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Review.WebCacheReview Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Review.WebCacheReview Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Review.WebCacheReview Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Review.WebCacheReview Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Review.WebCacheReview Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Review.WebCacheReview Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Review.WebCacheReview Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Review.WebCacheReview Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Review.WebCacheReview Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Review.WebCacheReview Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Review.WebCacheReview Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Review.WebCacheReview Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Name Property

new public virtual String Name {get; set;}

See Also

Review.WebCacheReview Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Review.WebCacheReview Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Review.WebCacheReview Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Review.WebCacheReview Class | StarTeam Namespace


PulseLabel Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.PulseLabel Property

[read/write] the Pulse Labe of this Review.

public virtual String PulseLabel {get; set;}

Property Value

the Pulse Labe of this Review.

See Also

Review.WebCacheReview Class | StarTeam Namespace


Rejectors Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Rejectors Property

[read] The rejectors of this review.

public virtual WebCacheUser[] Rejectors {get;}

Property Value

The rejectors of this review.

See Also

Review.WebCacheReview Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Review.WebCacheReview Class | StarTeam Namespace


Reviewers Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Reviewers Property

[read] The reviewers of this review.

public virtual WebCacheUser[] Reviewers {get;}

Property Value

The reviewers of this review.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ReviewID Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ReviewID Property

[read] the review id.

public virtual Int32 ReviewID {get;}

Property Value

the review id.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ReviewTypeValue Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ReviewTypeValue Property

[read/write] The review type of this review

public virtual Review.ReviewType ReviewTypeValue {get; set;}

Property Value

The review type of this review

See Also

Review.WebCacheReview Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Review.WebCacheReview Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Review.WebCacheReview Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Review.WebCacheReview Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Review.WebCacheReview Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Review.WebCacheReview Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Review.WebCacheReview Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.StatusValue Property

[read/write] The status of this review

public virtual Review.Status StatusValue {get; set;}

Property Value

The status of this review

See Also

Review.WebCacheReview Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Review.WebCacheReview Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Review.WebCacheReview Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Review.WebCacheReview Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Review.WebCacheReview Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Review.WebCacheReview Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Review.WebCacheReview Class | StarTeam Namespace


Watchers Property

Borland StarTeam SDK for .NET

Review.WebCacheReview.Watchers Property

[read] The watchers of this review.

public virtual WebCacheUser[] Watchers {get;}

Property Value

The watchers of this review.

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview Methods

The methods of the Review.WebCacheReview class are listed below. For a complete list of Review.WebCacheReview class members, see the Review.WebCacheReview Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddAcceptor |
AddAuthor |
AddNotifiedUser |
AddRejector |
AddReviewer |
AddTo |
AddWatcher |
Copy |
Equals | Delegate Equals() to com.starteam.Review.WebCacheReview.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Review.WebCacheReview.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveAcceptor |
RemoveAuthor |
RemoveFrom |
RemoveNotifiedUser |
RemoveRejector |
RemoveReviewer |
RemoveWatcher |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Review.WebCacheReview.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.AddAcceptor Method

public virtual void AddAcceptor(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.AddAuthor Method

public virtual void AddAuthor(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.AddRejector Method

public virtual void AddRejector(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.AddReviewer Method

public virtual void AddReviewer(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.AddWatcher Method

public virtual void AddWatcher(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Review.WebCacheReview.Create Method

Overload List

public static WebCacheReview Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheReview Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.Create Overload List


Review.WebCacheReview.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.Create Overload List


Review.WebCacheReview.Equals Method

Delegate Equals() to com.starteam.Review.WebCacheReview.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Review.WebCacheReview.Equals(obj).

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.GetHashCode Method

Delegate GetHashCode() to com.starteam.Review.WebCacheReview.

public override int GetHashCode();

Return Value

com.starteam.Review.WebCacheReview.GetHashCode().

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Review.WebCacheReview.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.GetValue Overload List


Review.WebCacheReview.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.GetValue Overload List


Review.WebCacheReview.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Review.WebCacheReview.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Review.WebCacheReview Class | StarTeam Namespace | WebCacheViewMemberCollection


Review.WebCacheReview.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.Lock Overload List | WebCacheViewMemberCollection


Review.WebCacheReview.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.Lock Overload List


Review.WebCacheReview.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Review.WebCacheReview Class | StarTeam Namespace | NAME


Review.WebCacheReview.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Review.WebCacheReview Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Review.WebCacheReview.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.MoveTo Overload List


Review.WebCacheReview.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.MoveTo Overload List


Review.WebCacheReview.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Review.WebCacheReview Class | StarTeam Namespace | isFloating | isPinned | unpin


Review.WebCacheReview.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Review.WebCacheReview Class | StarTeam Namespace | WebCacheViewMemberCollection


Review.WebCacheReview.RemoveAcceptor Method

public virtual void RemoveAcceptor(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.RemoveAuthor Method

public virtual void RemoveAuthor(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.RemoveRejector Method

public virtual void RemoveRejector(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.RemoveReviewer Method

public virtual void RemoveReviewer(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.RemoveWatcher Method

public virtual void RemoveWatcher(
User.WebCacheUser user
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Review.WebCacheReview.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.SetValue Overload List


Review.WebCacheReview.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Review.WebCacheReview Class | StarTeam Namespace | Review.WebCacheReview.SetValue Overload List


Review.WebCacheReview.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.ToString Method

Delegate ToString() to com.starteam.Review.WebCacheReview.

public override string ToString();

Return Value

com.starteam.Review.WebCacheReview.ToString()

See Also

Review.WebCacheReview Class | StarTeam Namespace


Review.WebCacheReview.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Review.WebCacheReview Class | StarTeam Namespace | WebCacheViewMemberCollection


Review.WebCacheReview.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Review.WebCacheReview Class | StarTeam Namespace | isFloating | isPinned | pinTo


Review.WebCacheReview.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Review.WebCacheReview Class | StarTeam Namespace | WebCacheViewMemberCollection


Review.WebCacheReview.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Review.WebCacheReview Class | StarTeam Namespace


RollbackSession Class

A RollbackSession is created and returned as the output of a ChangePackage rollback. The session contains a set of changes, each change representing a starteam file and a set of content objects, the source (the revision whose delta is to be rolled back) the target (or tip) from which the rollback will occur the common ancestor (the file revision content preceding the revision to be rolled back) and the (rolled back) merged content - the tip after the rollback has been applied. The algorithm runs a first diff between the common ancestor and the rollback revision a second diff between the common ancestor and the tip and rolls back (reverses the changes associated with) each matching Edit between the two diffs.

For a list of all members of this type, see RollbackSession Members.

System.Object
RollbackSession

public class RollbackSession

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

RollbackSession Members | StarTeam Namespace


RollbackSession Members

RollbackSession overview

Public Instance Properties

Changes [read]

Public Instance Methods

CanCommit | returns true if this rollback session can be committed, false otherwise will return true when all contained changes indicate no conflict false if all changes are marked IGNORE
Checkout | checkout (copy over) all the merged (rolled back) files to the working folders mapped via the view path. meant to build, test and validate the rollback prior to committing
Commit | commit this rollback session to the repository, create a committed checkin (workspace) change package as a result (internally use a checkin manager primed with the StarTeam files and the merged files from the session)
Equals | Delegate Equals() to com.starteam.RollbackSession.
GetHashCode | Delegate GetHashCode() to com.starteam.RollbackSession.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | close and remove the rollback session from disk
ToString | Delegate ToString() to com.starteam.RollbackSession.

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession Properties

The properties of the RollbackSession class are listed below. For a complete list of RollbackSession class members, see the RollbackSession Members topic.

Public Instance Properties

Changes [read]

See Also

RollbackSession Class | StarTeam Namespace


Changes Property

Borland StarTeam SDK for .NET

RollbackSession.Changes Property

[read]

public virtual Change[] Changes {get;}

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession Methods

The methods of the RollbackSession class are listed below. For a complete list of RollbackSession class members, see the RollbackSession Members topic.

Public Instance Methods

CanCommit | returns true if this rollback session can be committed, false otherwise will return true when all contained changes indicate no conflict false if all changes are marked IGNORE
Checkout | checkout (copy over) all the merged (rolled back) files to the working folders mapped via the view path. meant to build, test and validate the rollback prior to committing
Commit | commit this rollback session to the repository, create a committed checkin (workspace) change package as a result (internally use a checkin manager primed with the StarTeam files and the merged files from the session)
Equals | Delegate Equals() to com.starteam.RollbackSession.
GetHashCode | Delegate GetHashCode() to com.starteam.RollbackSession.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | close and remove the rollback session from disk
ToString | Delegate ToString() to com.starteam.RollbackSession.

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession.CanCommit Method

returns true if this rollback session can be committed, false otherwise will return true when all contained changes indicate no conflict false if all changes are marked IGNORE

public virtual bool CanCommit();

Return Value

true if this change package can be committed

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession.Checkout Method

checkout (copy over) all the merged (rolled back) files to the working folders mapped via the view path. meant to build, test and validate the rollback prior to committing

public virtual void Checkout();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession.Commit Method

commit this rollback session to the repository, create a committed checkin (workspace) change package as a result (internally use a checkin manager primed with the StarTeam files and the merged files from the session)

public virtual ChangePackage Commit(
CheckinOptions co,
ChangePackage cp
);

Parameters

co
optional Checkin Options which may be provided
cp
optional uncommitted ChangePackage which may be provided

Return Value

the ChangePackage resulting from the checkin

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession.Equals Method

Delegate Equals() to com.starteam.RollbackSession.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.RollbackSession.Equals(obj).

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession.GetHashCode Method

Delegate GetHashCode() to com.starteam.RollbackSession.

public override int GetHashCode();

Return Value

com.starteam.RollbackSession.GetHashCode().

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession.Remove Method

close and remove the rollback session from disk

public virtual void Remove();

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession.ToString Method

Delegate ToString() to com.starteam.RollbackSession.

public override string ToString();

Return Value

com.starteam.RollbackSession.ToString()

See Also

RollbackSession Class | StarTeam Namespace


RollbackSession.Change Class

For a list of all members of this type, see RollbackSession.Change Members.

System.Object
RollbackSession.Change

public class RollbackSession.Change

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

RollbackSession.Change Members | StarTeam Namespace


RollbackSession.Change Members

RollbackSession.Change overview

Public Instance Properties

Action | [read/write] the Merge Action associated with this change
Ancestor | [read]
AncestorRevision | [read]
DefaultAction | [read] the default Merge Action associated with this change
IsRollbackConflictDetected | [read/write]
Merged | [read/write]
Rollback | [read]
RollbackRevision | [read]
Target | [read]
TargetRevision | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.RollbackSession.Change.
GetHashCode | Delegate GetHashCode() to com.starteam.RollbackSession.Change.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.RollbackSession.Change.

See Also

RollbackSession.Change Class | StarTeam Namespace


RollbackSession.Change Properties

The properties of the RollbackSession.Change class are listed below. For a complete list of RollbackSession.Change class members, see the RollbackSession.Change Members topic.

Public Instance Properties

Action | [read/write] the Merge Action associated with this change
Ancestor | [read]
AncestorRevision | [read]
DefaultAction | [read] the default Merge Action associated with this change
IsRollbackConflictDetected | [read/write]
Merged | [read/write]
Rollback | [read]
RollbackRevision | [read]
Target | [read]
TargetRevision | [read]

See Also

RollbackSession.Change Class | StarTeam Namespace


Action Property

Borland StarTeam SDK for .NET

RollbackSession.Change.Action Property

[read/write] the Merge Action associated with this change

public virtual RollbackSession.MergeAction Action {get; set;}

Property Value

the Merge Action associated with this change

See Also

RollbackSession.Change Class | StarTeam Namespace


Ancestor Property

Borland StarTeam SDK for .NET

RollbackSession.Change.Ancestor Property

[read]

public virtual FileInfo Ancestor {get;}

See Also

RollbackSession.Change Class | StarTeam Namespace


AncestorRevision Property

Borland StarTeam SDK for .NET

RollbackSession.Change.AncestorRevision Property

[read]

public virtual File AncestorRevision {get;}

See Also

RollbackSession.Change Class | StarTeam Namespace


DefaultAction Property

Borland StarTeam SDK for .NET

RollbackSession.Change.DefaultAction Property

[read] the default Merge Action associated with this change

public virtual RollbackSession.MergeAction DefaultAction {get;}

Property Value

the default Merge Action associated with this change

See Also

RollbackSession.Change Class | StarTeam Namespace


IsRollbackConflictDetected Property

Borland StarTeam SDK for .NET

RollbackSession.Change.IsRollbackConflictDetected Property

[read/write]

public virtual Boolean IsRollbackConflictDetected {get; set;}

See Also

RollbackSession.Change Class | StarTeam Namespace


Merged Property

Borland StarTeam SDK for .NET

RollbackSession.Change.Merged Property

[read/write]

public virtual FileInfo Merged {get; set;}

See Also

RollbackSession.Change Class | StarTeam Namespace


Rollback Property

Borland StarTeam SDK for .NET

RollbackSession.Change.Rollback Property

[read]

public virtual FileInfo Rollback {get;}

See Also

RollbackSession.Change Class | StarTeam Namespace


RollbackRevision Property

Borland StarTeam SDK for .NET

RollbackSession.Change.RollbackRevision Property

[read]

public virtual File RollbackRevision {get;}

See Also

RollbackSession.Change Class | StarTeam Namespace


Target Property

Borland StarTeam SDK for .NET

RollbackSession.Change.Target Property

[read]

public virtual FileInfo Target {get;}

See Also

RollbackSession.Change Class | StarTeam Namespace


TargetRevision Property

Borland StarTeam SDK for .NET

RollbackSession.Change.TargetRevision Property

[read]

public virtual File TargetRevision {get;}

See Also

RollbackSession.Change Class | StarTeam Namespace


RollbackSession.Change Methods

The methods of the RollbackSession.Change class are listed below. For a complete list of RollbackSession.Change class members, see the RollbackSession.Change Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.RollbackSession.Change.
GetHashCode | Delegate GetHashCode() to com.starteam.RollbackSession.Change.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.RollbackSession.Change.

See Also

RollbackSession.Change Class | StarTeam Namespace


RollbackSession.Change.Equals Method

Delegate Equals() to com.starteam.RollbackSession.Change.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.RollbackSession.Change.Equals(obj).

See Also

RollbackSession.Change Class | StarTeam Namespace


RollbackSession.Change.GetHashCode Method

Delegate GetHashCode() to com.starteam.RollbackSession.Change.

public override int GetHashCode();

Return Value

com.starteam.RollbackSession.Change.GetHashCode().

See Also

RollbackSession.Change Class | StarTeam Namespace


RollbackSession.Change.ToString Method

Delegate ToString() to com.starteam.RollbackSession.Change.

public override string ToString();

Return Value

com.starteam.RollbackSession.Change.ToString()

See Also

RollbackSession.Change Class | StarTeam Namespace


RollbackSession.MergeAction Class

The action used to resolve each change

For a list of all members of this type, see RollbackSession.MergeAction Members.

System.Object
RollbackSession.MergeAction

public class RollbackSession.MergeAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

RollbackSession.MergeAction Members | StarTeam Namespace


RollbackSession.MergeAction Members

RollbackSession.MergeAction overview

Public Static Properties

ADD
DELETE
IGNORE
MERGE
OVERWRITE

Public Instance Properties

ID | [read] The unique ID associated with this action.
Name | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.RollbackSession.MergeAction.
GetHashCode | Delegate GetHashCode() to com.starteam.RollbackSession.MergeAction.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.RollbackSession.MergeAction.

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


RollbackSession.MergeAction Properties

The properties of the RollbackSession.MergeAction class are listed below. For a complete list of RollbackSession.MergeAction class members, see the RollbackSession.MergeAction Members topic.

Public Static Properties

ADD
DELETE
IGNORE
MERGE
OVERWRITE

Public Instance Properties

ID | [read] The unique ID associated with this action.
Name | [read]

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


ADD Property

Borland StarTeam SDK for .NET

RollbackSession.MergeAction.ADD Property

public static RollbackSession.MergeAction ADD {get;}

Property Value

ADD

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


DELETE Property

Borland StarTeam SDK for .NET

RollbackSession.MergeAction.DELETE Property

public static RollbackSession.MergeAction DELETE {get;}

Property Value

DELETE

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

RollbackSession.MergeAction.ID Property

[read] The unique ID associated with this action.

public virtual Int32 ID {get;}

Property Value

The unique ID associated with this action.

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


IGNORE Property

Borland StarTeam SDK for .NET

RollbackSession.MergeAction.IGNORE Property

public static RollbackSession.MergeAction IGNORE {get;}

Property Value

IGNORE

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


MERGE Property

Borland StarTeam SDK for .NET

RollbackSession.MergeAction.MERGE Property

public static RollbackSession.MergeAction MERGE {get;}

Property Value

MERGE

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

RollbackSession.MergeAction.Name Property

[read]

public virtual String Name {get;}

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


OVERWRITE Property

Borland StarTeam SDK for .NET

RollbackSession.MergeAction.OVERWRITE Property

public static RollbackSession.MergeAction OVERWRITE {get;}

Property Value

OVERWRITE

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


RollbackSession.MergeAction Methods

The methods of the RollbackSession.MergeAction class are listed below. For a complete list of RollbackSession.MergeAction class members, see the RollbackSession.MergeAction Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.RollbackSession.MergeAction.
GetHashCode | Delegate GetHashCode() to com.starteam.RollbackSession.MergeAction.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.RollbackSession.MergeAction.

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


RollbackSession.MergeAction.Equals Method

Delegate Equals() to com.starteam.RollbackSession.MergeAction.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.RollbackSession.MergeAction.Equals(obj).

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


RollbackSession.MergeAction.GetHashCode Method

Delegate GetHashCode() to com.starteam.RollbackSession.MergeAction.

public override int GetHashCode();

Return Value

com.starteam.RollbackSession.MergeAction.GetHashCode().

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


RollbackSession.MergeAction.ToString Method

Delegate ToString() to com.starteam.RollbackSession.MergeAction.

public override string ToString();

Return Value

com.starteam.RollbackSession.MergeAction.ToString()

See Also

RollbackSession.MergeAction Class | StarTeam Namespace


ScalarProperty Class

An implementation of a ScalarProperty

For a list of all members of this type, see ScalarProperty Members.

System.Object
Property
ScalarProperty
Derived types

public class ScalarProperty : Property

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ScalarProperty Members | StarTeam Namespace


ScalarProperty Members

ScalarProperty overview

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from Property) | [read/write] the property's default value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] The maximum allowable value of this property.
MinValue | [read/write] The minimum allowable value of this property.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ScalarProperty Class | StarTeam Namespace


ScalarProperty Properties

The properties of the ScalarProperty class are listed below. For a complete list of ScalarProperty class members, see the ScalarProperty Members topic.

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from Property) | [read/write] the property's default value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] The maximum allowable value of this property.
MinValue | [read/write] The minimum allowable value of this property.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ScalarProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

ScalarProperty.MaxValue Property

[read/write] The maximum allowable value of this property.

public virtual Object MaxValue {get; set;}

Property Value

The maximum allowable value of this property.

See Also

ScalarProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

ScalarProperty.MinValue Property

[read/write] The minimum allowable value of this property.

public virtual Object MinValue {get; set;}

Property Value

The minimum allowable value of this property.

See Also

ScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see ScalarProperty.WebCacheScalarProperty Members.

System.Object
Property.WebCacheProperty
ScalarProperty.WebCacheScalarProperty
Derived types

public class ScalarProperty.WebCacheScalarProperty : WebCacheProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ScalarProperty.WebCacheScalarProperty Members | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty Members

ScalarProperty.WebCacheScalarProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | [read/write] the property's default value.
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ScalarProperty.WebCacheScalarProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ScalarProperty.WebCacheScalarProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ScalarProperty.WebCacheScalarProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty Properties

The properties of the ScalarProperty.WebCacheScalarProperty class are listed below. For a complete list of ScalarProperty.WebCacheScalarProperty class members, see the ScalarProperty.WebCacheScalarProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | [read/write] the property's default value.
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.DefaultValue Property

[read/write] the property's default value.

new public virtual Object DefaultValue {get; set;}

Property Value

the property's default value.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.Name Property

new public virtual String Name {get;}

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

ScalarProperty.WebCacheScalarProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty Methods

The methods of the ScalarProperty.WebCacheScalarProperty class are listed below. For a complete list of ScalarProperty.WebCacheScalarProperty class members, see the ScalarProperty.WebCacheScalarProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ScalarProperty.WebCacheScalarProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ScalarProperty.WebCacheScalarProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ScalarProperty.WebCacheScalarProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.Equals Method

Delegate Equals() to com.starteam.ScalarProperty.WebCacheScalarProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ScalarProperty.WebCacheScalarProperty.Equals(obj).

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ScalarProperty.WebCacheScalarProperty.

public override int GetHashCode();

Return Value

com.starteam.ScalarProperty.WebCacheScalarProperty.GetHashCode().

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.ToString Method

Delegate ToString() to com.starteam.ScalarProperty.WebCacheScalarProperty.

public override string ToString();

Return Value

com.starteam.ScalarProperty.WebCacheScalarProperty.ToString()

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

ScalarProperty.WebCacheScalarProperty Class | StarTeam Namespace


Server Class

The Server class provides network access to a remote StarTeam Server. It only supports access through TCP/IP sockets and has the ability to encrypt and compress all communication between the client server.

For a list of all members of this type, see Server Members.

System.Object
Server

public class Server

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Server Members | StarTeam Namespace


Server Members

Server overview

Public Static Properties

CachedCredentials | [read] a collection of ServerInfo Objects representing Cached Credentials.
CONNECT_AS_120 |
CONNECT_AS_125 |
CONNECT_AS_130 |
CONNECT_AS_140 |
IsCredentialCachingAvailable | [read] true if the credential caching feature is available on this workstation, and false otherwise.
IsCredentialCachingEnabled | [read] true if the credential caching feature is enabled on this workstation, and false otherwise.
SEPARATE_SERVER_SESSIONS |

Public Static Methods

CacheCredentials | Cache server specific credentials, if credential caching is available.
DeclareComponentDefinition |
DeclareComponentDefinitions |
DecryptPassword | Decrypt the specified password and return its clear text equivalent
EnableCredentialCaching | Enables credential caching on this workstation, if it is available and not already enabled.
EncryptPasswordToFile | Encrypt and save the specified clear text password to a file Return the file to the caller when done
FetchCachedPassword | Fetch the cached password, if credential caching is available
FetchCachedUserName | Fetch the cached user name for the given serverName/port combination, if any
UncacheCredentials | remove Cached Credentials, if any

Public Instance Constructors

Server Overloaded. Initializes a new instance of the Server class.

Public Instance Properties

ActiveGroups | [read] All of the active (non-deleted) groups in this Server.
ActiveUsers | [read] All of the active (non-deleted) users in this Server.
Address | [read] string representing the network address
Administration | [read] the ServerAdministration object for this server.
AdministratorsGroup | [read] "Administrators" group on this server.
AllUsersGroup | [read] "AllUsers" group on this server.
Application | [read] The client application that owns this Server instance.
AutoReconnectAttempts | [read/write] If automatic reconnect is enabled, the maximum number of attempts to reconnect that will be made while executing a single server command. Default value is 1.
AutoReconnectWait | [read/write] If automatic reconnect is enabled, the number of seconds that we will wait before each reconnect attempt. Default value is 2 seconds.
ClientContext | [read] the ClientContext associated when logged in to the Server. May return null if not logged in.
CommandAPIRevisionLevel | [read] the command API revision level of this server.
CommandCount | [read] The number of commands sent to the StarTeam server since the connection was established.
Compression | [write] Sets whether or not to compress data on transmission
CurrentCacheAgent | [read] CacheAgent the CacheAgent currently in use by this server, or null
CurrentMPXProfile | [read] The EventHandlerProfile of the MPX message broker, or null if MPX is not currently enabled.
CurrentTime | [read] The current server time or NULL if this server instance is not connected to the StarTeam Server
EnableCacheAgentForObjectProperties | [write] enable or disable object property caching
EncryptionAlgorithmValue | [read] The level of EncryptionAlgorithm requested for the connection.
EventHandlerInfoNames | [read] an array containing the names of all existing EventHandlerInfos on this server.
Groups | [read] All of the groups on this server.
IsAutoLogOnAvailable | [read] true if logon credentials for this server have been cached on this workstation, and false otherwise.
IsAutoReconnectEnabled | [read/write] true if a reconnect is automatically attempted whenever a connection problem is detected while executing a server command. Automatic reconnect is enabled by default.
IsCompressed | [read] true if the connection is compressed; false otherwise.
IsConnected | [read] true if a network connection to the StarTeam server has been established.
IsKeepAliveEnabled | [read] true if keep-alive mode is in effect; false otherwise. In keep-alive mode, a background thread periodically pings the server to keep the connection alive. Keep-alive is off by default.
IsLoggedOn | [read] true if someone has logged on through this server object.
IsMailAvailable | [read] true if the server supports email or false if this server instance is not connected to the StarTeam Server
IsMPXAvailable | [read] true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).
IsMPXEnabled | [read] true if MPX has been enabled for this server, and false otherwise.
IsMPXResponding | [read] true if the MPX server is running properly, and false otherwise.
IsMPXUsingActiveMQ | [read]
IsRefreshAccountsRequired | [read] true if User or Group information may be out of date.
IsRefreshGroupsRequired | [read] true if Group information may be out of date.
IsRefreshProjectsRequired | [read] true if a refresh is required; false otherwise.
IsRefreshUsersRequired | [read] true if User information may be out of date.
IsSingleSignOnAuthenticationEnabled | [read] true if Single Sign-On Authentication has been enabled on the StarTeam server, false otherwise.
KeepAlive | [write] Enables or disables keep-alive mode.
KeepAliveInterval | [read/write] The current keep-alive interval, in minutes.
KeepTraceRouteAlive | [write] Enables or disables keep-alive mode.
LoggedInUser | [read] The user object of the logged in user, or null if no one has logged in.
MPXMessageCount | [read] The number of MPX messages received since MPX was enabled; 0 if not enabled.
MPXTransmitterName | [read] StarTeam MPX Transmitter name
NotificationMessage | [read] a Notification message
Oauth2AccessToken | [read]
Oauth2IssuerURL | [read] Oauth2 provider Issuer URL or null.
Oauth2RedirectURI | [read] Oauth2 Redirect URI or null.
Port | [read] server's TCP/IP port
ProductCodesValue | [read] The product codes licensed for this server.
Projects | [read] The server's project list.
Protocol | [read] The protocol used to connect to the server.
RepositoryID | [read] com.starteam.util.GUID
RequiredEncryptionLevel | [read] level of EncryptionAlgorithm required to connect to the server or NULL if this server instance is not connected to the StarTeam Server
RevisionLevel | [read] the revision level of this server.
ServerBuild | [read] The server build number.
ServerBuildDescription | [read] The server build description.
ServerInfo | [read] A copy of serverInfo object used to construct this server session
SessionValue | [read] session information for the currently logged on user.
SupportedFeatures | [read] An instance of the SupportedFeatures class that can tell which features are available for this StarTeam server
Types | [read] a collection of Types instances
Users | [read] All of the active and deleted users in this Server.

Public Instance Methods

AutoLocateCacheAgent | autoLocate a Cache Agent, return null if none found Attempts to autolocate can be expensive
AutoLogOn | Log on to this server using credentials that have been cached on this workstation.
CacheLogOnCredentials | Saves logon credentials for this server so that they may be used in future calls to autoLogOn().
CanCreateCheckinChangePackages | Returns true if the server supports creating Change Packages on File Checkin This server configuration setting has been in force since the 12.5 server release. With this setting turned OFF, Change Packages are not created for checkin Additionally, old style links are created between files and process items, if any
ChangePassword | Changes the password to the specified new password upon a successful login to the server, and immediately logs out. New password is immediately effective upon a successful change of password.
Connect | Overloaded. Establishes a network connection to the remote server process. If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.
CreateTenant | Create a new tenant in an environment that supports multi-tenant hosting Will throw a server exception for on-premise servers
CreateType | create a custom component (a new type) on the server. Support for Custom Components has been introduced in the 12.0 release
DisableMPX | Disables MPX, if it was enabled for this server.
DiscardAccounts | Discards all cached User and Group information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardGroups | Discards cached Group information. The next call to getGroups() will re-fetch the group information from the StarTeam Server.
DiscardProjects | Discards the list of cached projects. A subsequent call to getProjects() will re-fetch the projects from the server (even when MPX is enabled).
DiscardUsers | Discards cached User information. The next call to getUsers() will re-fetch the user information from the StarTeam Server (even when MPX is enabled).
Disconnect
EnableMPX | Overloaded. Enables MPX using the default client MPX profile.
Equals | Delegate Equals() to com.starteam.Server.
FetchEmailUsers | This method issues a command to the server to return the list of users who are able to receive email messages. returns an empty array if this server instance is not connected to the StarTeam Server
FindGroup | Returns the Group object for the given ID.
FindProject | Overloaded. Finds a project in the server's project collection.
FindUser | Returns the User object for the given ID. The user returned will contain only a limited subset of the account information. Returns null if userID is not found.
GetCRStatus
GetEventHandlerInfo | Returns the specified EventHandlerInfo object on this server. If no such EventhandlerInfo exist, a null is returned.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.
GetStatus
GetType (inherited from Object) | Gets the Type of the current instance.
GetUDAGroupings
GetVisibleProperties | Return the subset of properties that are visible in the context of the specified Enumerated Value
HandleEvents | Places the current thread in an event-handling state. While in an event-handling state, the thread is usually asleep, waking occasionally just long enough to ping the server (keeping the connection alive). The event-handling loop continues until some other thread (presumably, the event-handling thread for this Server object) calls interruptHandleEvents(). An application does not need to call handleEvents() in order to handle events; this is just a convenience method for applications that have nothing else they need to do while waiting for an event to occur. Only one thread may call handleEvents() per Server object at any given time. After handleEvents() exits (as a result of a call to interruptHandleEvents), then handleEvents() may be called again by the same thread or by some other thread. handleEvents() will fail if MPX is not enabled, or if there are no event-handlers running. handleEvents() should not be called from within an event handler. (This would put the event-handling thread to sleep.)
HasInactivityTimeout | Returns true if the server has an inactivity timeout interval specified
HasProductCode
HasSavedCRStatus
HasSavedStatus
InterruptHandleEvents | Interrupts a handleEvents() loop, if there is one running. Usually called from within an event-handler, running in the event-handling thread for this Server object.
LocateCacheAgent | locate a CacheAgent at a given address and port
LogOn | Overloaded. Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied user credentials.
NewGroupEventSource
NewMPXStatusEventSource
NewProjectEventSource
NewServerControlEventSource
NewTypedResourceEventSource
NewTypeEventSource
NewUserEventSource
Oauth2logOn | Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied Oauth2 Authorization code.
ObtainLicense | Overloaded. Get/Consume a license for the specified User, using this Server's session ID to obtain the license. Returns the SessionID (GUID) that was used to obtain the license.
Ping | Verifies that the server is responding and informs the server that this connection/user session is still active.
PingMPXServer | Throws an appropriate MPXException if the MPX server is not running properly.
Reconnect | Overloaded. Attempts to re-establish the connection to the server, re-opening any existing view sessions. Uses the user credentials provided at logon time.
RefreshAccounts | Refreshes cached User and Group information. Existing User and Group objects are modified in place whenever possible.
RefreshGroups | Refreshes cached Group information to reflect recent changes to the repository. Modifies existing Group objects in place whenever possible.
RefreshProjects | Ensures that the latest list of projects has been retrieved from the server and cached locally. Also ensures that any previously cached project property values are up-to-date. refreshProjects() re-uses existing Project objects whenever possible, changing cached property values as necessary to bring older Projects up-to-date. When MPX is enabled, refreshProjects() is optimized to avoid unnecessary server commands.
RefreshUsers | Refreshes cached User information to reflect recent changes to the repository. Modifies existing User objects in place whenever possible. If MPX is enabled, refreshUsers() is optimized to avoid unnecessary server commands.
ReleaseLicense | Overloaded. Release a license owned by the specified User, where this Server's session ID was used to obtain the license.
SendMail | Overloaded. Directs the StarTeam Server to send mail to the specified StarTeam users.
SetCRStatus
SetStatus
SetUDAGroupings
SetVisibleProperties | Define a subset of properties of a given type that are marked visible
SingleSignOnLogon | Single sign-on login to StarTeam server, using a valid JWT access tokens, which were passed on by a logged in StarTeam client /3rd party application. This will be used in the Pulse bridge implementation.
SupportsInfoStreamCRStatus | Returns true if the server supports setting CR Status when the Story Status Changes
SupportsTraceVersioning
Synchronize | Add or release a set of keys, i.e. acquire a lock for these named keys The server will synchronize access to an internal hash table across any/all threads which attempt key acquisitions. The first thread wins and acquires the key all subsequent threads lose and a server exception will be thrown If this method fails, a server exception will be thrown Well behaved applications that acquire a locked key should release it as quickly as possible
ToString | Delegate ToString() to com.starteam.Server.
ValidateClient

See Also

Server Class | StarTeam Namespace


Server Constructor

Looks up the given server name in starteam-servers.xml, and uses the resulting ServerInfo to construct the server. If no ServerInfo with that name is found, assumes that servername is the address, and uses the default port.

Overload List

Creates a new Server object, using the given connection information. The ServerInfo must specify a supported protocol; otherwise, an IllegalArgumentException will be thrown. If ServerInfo specifies an MPXProfileName, then later, after the Server connection itself is established, an attempt will be made to automatically enable MPX.

public Server(ServerInfo);

Looks up the given server name in starteam-servers.xml, and uses the resulting ServerInfo to construct the server. If no ServerInfo with that name is found, assumes that servername is the address, and uses the default port.

public Server(String);

public Server(String,Int32);

See Also

Server Class | StarTeam Namespace


Server Constructor (String)

Looks up the given server name in starteam-servers.xml, and uses the resulting ServerInfo to construct the server. If no ServerInfo with that name is found, assumes that servername is the address, and uses the default port.

public Server(
String serverName
);

Parameters

serverName
String a server name in starteam-servers.xml

See Also

Server Class | StarTeam Namespace | Server Constructor Overload List


Server Constructor (String, Int32)

public Server(
String address,
Int32 port
);

See Also

Server Class | StarTeam Namespace | Server Constructor Overload List


Server Constructor (ServerInfo)

Creates a new Server object, using the given connection information.

The ServerInfo must specify a supported protocol; otherwise, an IllegalArgumentException will be thrown.

If ServerInfo specifies an MPXProfileName, then later, after the Server connection itself is established, an attempt will be made to automatically enable MPX.

public Server(
ServerInfo info
);

Parameters

info
Server connection information.

See Also

Server Class | StarTeam Namespace | Server Constructor Overload List | ServerInfo | connect | enableMPX


Server Properties

The properties of the Server class are listed below. For a complete list of Server class members, see the Server Members topic.

Public Static Properties

CachedCredentials | [read] a collection of ServerInfo Objects representing Cached Credentials.
CONNECT_AS_120 |
CONNECT_AS_125 |
CONNECT_AS_130 |
CONNECT_AS_140 |
IsCredentialCachingAvailable | [read] true if the credential caching feature is available on this workstation, and false otherwise.
IsCredentialCachingEnabled | [read] true if the credential caching feature is enabled on this workstation, and false otherwise.
SEPARATE_SERVER_SESSIONS |

Public Instance Properties

ActiveGroups | [read] All of the active (non-deleted) groups in this Server.
ActiveUsers | [read] All of the active (non-deleted) users in this Server.
Address | [read] string representing the network address
Administration | [read] the ServerAdministration object for this server.
AdministratorsGroup | [read] "Administrators" group on this server.
AllUsersGroup | [read] "AllUsers" group on this server.
Application | [read] The client application that owns this Server instance.
AutoReconnectAttempts | [read/write] If automatic reconnect is enabled, the maximum number of attempts to reconnect that will be made while executing a single server command. Default value is 1.
AutoReconnectWait | [read/write] If automatic reconnect is enabled, the number of seconds that we will wait before each reconnect attempt. Default value is 2 seconds.
ClientContext | [read] the ClientContext associated when logged in to the Server. May return null if not logged in.
CommandAPIRevisionLevel | [read] the command API revision level of this server.
CommandCount | [read] The number of commands sent to the StarTeam server since the connection was established.
Compression | [write] Sets whether or not to compress data on transmission
CurrentCacheAgent | [read] CacheAgent the CacheAgent currently in use by this server, or null
CurrentMPXProfile | [read] The EventHandlerProfile of the MPX message broker, or null if MPX is not currently enabled.
CurrentTime | [read] The current server time or NULL if this server instance is not connected to the StarTeam Server
EnableCacheAgentForObjectProperties | [write] enable or disable object property caching
EncryptionAlgorithmValue | [read] The level of EncryptionAlgorithm requested for the connection.
EventHandlerInfoNames | [read] an array containing the names of all existing EventHandlerInfos on this server.
Groups | [read] All of the groups on this server.
IsAutoLogOnAvailable | [read] true if logon credentials for this server have been cached on this workstation, and false otherwise.
IsAutoReconnectEnabled | [read/write] true if a reconnect is automatically attempted whenever a connection problem is detected while executing a server command. Automatic reconnect is enabled by default.
IsCompressed | [read] true if the connection is compressed; false otherwise.
IsConnected | [read] true if a network connection to the StarTeam server has been established.
IsKeepAliveEnabled | [read] true if keep-alive mode is in effect; false otherwise. In keep-alive mode, a background thread periodically pings the server to keep the connection alive. Keep-alive is off by default.
IsLoggedOn | [read] true if someone has logged on through this server object.
IsMailAvailable | [read] true if the server supports email or false if this server instance is not connected to the StarTeam Server
IsMPXAvailable | [read] true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).
IsMPXEnabled | [read] true if MPX has been enabled for this server, and false otherwise.
IsMPXResponding | [read] true if the MPX server is running properly, and false otherwise.
IsMPXUsingActiveMQ | [read]
IsRefreshAccountsRequired | [read] true if User or Group information may be out of date.
IsRefreshGroupsRequired | [read] true if Group information may be out of date.
IsRefreshProjectsRequired | [read] true if a refresh is required; false otherwise.
IsRefreshUsersRequired | [read] true if User information may be out of date.
IsSingleSignOnAuthenticationEnabled | [read] true if Single Sign-On Authentication has been enabled on the StarTeam server, false otherwise.
KeepAlive | [write] Enables or disables keep-alive mode.
KeepAliveInterval | [read/write] The current keep-alive interval, in minutes.
KeepTraceRouteAlive | [write] Enables or disables keep-alive mode.
LoggedInUser | [read] The user object of the logged in user, or null if no one has logged in.
MPXMessageCount | [read] The number of MPX messages received since MPX was enabled; 0 if not enabled.
MPXTransmitterName | [read] StarTeam MPX Transmitter name
NotificationMessage | [read] a Notification message
Oauth2AccessToken | [read]
Oauth2IssuerURL | [read] Oauth2 provider Issuer URL or null.
Oauth2RedirectURI | [read] Oauth2 Redirect URI or null.
Port | [read] server's TCP/IP port
ProductCodesValue | [read] The product codes licensed for this server.
Projects | [read] The server's project list.
Protocol | [read] The protocol used to connect to the server.
RepositoryID | [read] com.starteam.util.GUID
RequiredEncryptionLevel | [read] level of EncryptionAlgorithm required to connect to the server or NULL if this server instance is not connected to the StarTeam Server
RevisionLevel | [read] the revision level of this server.
ServerBuild | [read] The server build number.
ServerBuildDescription | [read] The server build description.
ServerInfo | [read] A copy of serverInfo object used to construct this server session
SessionValue | [read] session information for the currently logged on user.
SupportedFeatures | [read] An instance of the SupportedFeatures class that can tell which features are available for this StarTeam server
Types | [read] a collection of Types instances
Users | [read] All of the active and deleted users in this Server.

See Also

Server Class | StarTeam Namespace


ActiveGroups Property

Borland StarTeam SDK for .NET

Server.ActiveGroups Property

[read] All of the active (non-deleted) groups in this Server.

public virtual Group[] ActiveGroups {get;}

Property Value

All of the active (non-deleted) groups in this Server.

See Also

Server Class | StarTeam Namespace


ActiveUsers Property

Borland StarTeam SDK for .NET

Server.ActiveUsers Property

[read] All of the active (non-deleted) users in this Server.

public virtual User[] ActiveUsers {get;}

Property Value

All of the active (non-deleted) users in this Server.

See Also

Server Class | StarTeam Namespace


Address Property

Borland StarTeam SDK for .NET

Server.Address Property

[read] string representing the network address

public virtual String Address {get;}

Property Value

string representing the network address

See Also

Server Class | StarTeam Namespace


Administration Property

Borland StarTeam SDK for .NET

Server.Administration Property

[read] the ServerAdministration object for this server.

public virtual ServerAdministration Administration {get;}

Property Value

the ServerAdministration object for this server.

See Also

Server Class | StarTeam Namespace


AdministratorsGroup Property

Borland StarTeam SDK for .NET

Server.AdministratorsGroup Property

[read] "Administrators" group on this server.

public virtual Group AdministratorsGroup {get;}

Property Value

"Administrators" group on this server.

See Also

Server Class | StarTeam Namespace


AllUsersGroup Property

Borland StarTeam SDK for .NET

Server.AllUsersGroup Property

[read] "AllUsers" group on this server.

public virtual Group AllUsersGroup {get;}

Property Value

"AllUsers" group on this server.

See Also

Server Class | StarTeam Namespace


Application Property

Borland StarTeam SDK for .NET

Server.Application Property

[read] The client application that owns this Server instance.

public virtual Application Application {get;}

Property Value

The client application that owns this Server instance.

See Also

Server Class | StarTeam Namespace


AutoReconnectAttempts Property

Borland StarTeam SDK for .NET

Server.AutoReconnectAttempts Property

[read/write] If automatic reconnect is enabled, the maximum number of attempts to reconnect that will be made while executing a single server command. Default value is 1.

public virtual Int32 AutoReconnectAttempts {get; set;}

Property Value

If automatic reconnect is enabled, the maximum number of attempts to reconnect that will be made while executing a single server command. Default value is 1.

See Also

Server Class | StarTeam Namespace


AutoReconnectWait Property

Borland StarTeam SDK for .NET

Server.AutoReconnectWait Property

[read/write] If automatic reconnect is enabled, the number of seconds that we will wait before each reconnect attempt. Default value is 2 seconds.

public virtual Int32 AutoReconnectWait {get; set;}

Property Value

If automatic reconnect is enabled, the number of seconds that we will wait before each reconnect attempt. Default value is 2 seconds.

See Also

Server Class | StarTeam Namespace


CachedCredentials Property

Borland StarTeam SDK for .NET

Server.CachedCredentials Property

[read] a collection of ServerInfo Objects representing Cached Credentials.

public static ServerInfoCollection CachedCredentials {get;}

Property Value

a collection of ServerInfo Objects representing Cached Credentials.

See Also

Server Class | StarTeam Namespace


ClientContext Property

Borland StarTeam SDK for .NET

Server.ClientContext Property

[read] the ClientContext associated when logged in to the Server. May return null if not logged in.

public virtual ClientContext ClientContext {get;}

Property Value

the ClientContext associated when logged in to the Server. May return null if not logged in.

See Also

Server Class | StarTeam Namespace


CommandAPIRevisionLevel Property

Borland StarTeam SDK for .NET

Server.CommandAPIRevisionLevel Property

[read] the command API revision level of this server.

public virtual String CommandAPIRevisionLevel {get;}

Property Value

the command API revision level of this server.

See Also

Server Class | StarTeam Namespace


CommandCount Property

Borland StarTeam SDK for .NET

Server.CommandCount Property

[read] The number of commands sent to the StarTeam server since the connection was established.

public virtual Int32 CommandCount {get;}

Property Value

The number of commands sent to the StarTeam server since the connection was established.

See Also

Server Class | StarTeam Namespace


Compression Property

Borland StarTeam SDK for .NET

Server.Compression Property

[write] Sets whether or not to compress data on transmission

public virtual Boolean Compression {set;}

Property Value

Sets whether or not to compress data on transmission

See Also

Server Class | StarTeam Namespace


CONNECT_AS_120 Property

Borland StarTeam SDK for .NET

Server.CONNECT_AS_120 Property

public static DotNotation CONNECT_AS_120 {get;}

See Also

Server Class | StarTeam Namespace


CONNECT_AS_125 Property

Borland StarTeam SDK for .NET

Server.CONNECT_AS_125 Property

public static DotNotation CONNECT_AS_125 {get;}

See Also

Server Class | StarTeam Namespace


CONNECT_AS_130 Property

Borland StarTeam SDK for .NET

Server.CONNECT_AS_130 Property

public static DotNotation CONNECT_AS_130 {get;}

See Also

Server Class | StarTeam Namespace


CONNECT_AS_140 Property

Borland StarTeam SDK for .NET

Server.CONNECT_AS_140 Property

public static DotNotation CONNECT_AS_140 {get;}

See Also

Server Class | StarTeam Namespace


CurrentCacheAgent Property

Borland StarTeam SDK for .NET

Server.CurrentCacheAgent Property

[read] CacheAgent the CacheAgent currently in use by this server, or null

public virtual CacheAgent CurrentCacheAgent {get;}

Property Value

CacheAgent the CacheAgent currently in use by this server, or null

See Also

Server Class | StarTeam Namespace


CurrentMPXProfile Property

Borland StarTeam SDK for .NET

Server.CurrentMPXProfile Property

[read] The EventHandlerProfile of the MPX message broker, or null if MPX is not currently enabled.

public virtual EventHandlerProfile CurrentMPXProfile {get;}

Property Value

The EventHandlerProfile of the MPX message broker, or null if MPX is not currently enabled.

See Also

Server Class | StarTeam Namespace


CurrentTime Property

Borland StarTeam SDK for .NET

Server.CurrentTime Property

[read] The current server time or NULL if this server instance is not connected to the StarTeam Server

public virtual DateTime CurrentTime {get;}

Property Value

The current server time or NULL if this server instance is not connected to the StarTeam Server

See Also

Server Class | StarTeam Namespace


EnableCacheAgentForObjectProperties Property

Borland StarTeam SDK for .NET

Server.EnableCacheAgentForObjectProperties Property

[write] enable or disable object property caching

public virtual Boolean EnableCacheAgentForObjectProperties {set;}

Property Value

enable or disable object property caching

See Also

Server Class | StarTeam Namespace


EncryptionAlgorithmValue Property

Borland StarTeam SDK for .NET

Server.EncryptionAlgorithmValue Property

[read] The level of EncryptionAlgorithm requested for the connection.

public virtual Server.EncryptionAlgorithm EncryptionAlgorithmValue {get;}

Property Value

The level of EncryptionAlgorithm requested for the connection.

See Also

Server Class | StarTeam Namespace


EventHandlerInfoNames Property

Borland StarTeam SDK for .NET

Server.EventHandlerInfoNames Property

[read] an array containing the names of all existing EventHandlerInfos on this server.

public virtual String[] EventHandlerInfoNames {get;}

Property Value

an array containing the names of all existing EventHandlerInfos on this server.

See Also

Server Class | StarTeam Namespace


Groups Property

Borland StarTeam SDK for .NET

Server.Groups Property

[read] All of the groups on this server.

public virtual Group[] Groups {get;}

Property Value

All of the groups on this server.

See Also

Server Class | StarTeam Namespace


IsAutoLogOnAvailable Property

Borland StarTeam SDK for .NET

Server.IsAutoLogOnAvailable Property

[read] true if logon credentials for this server have been cached on this workstation, and false otherwise.

public virtual Boolean IsAutoLogOnAvailable {get;}

Property Value

true if logon credentials for this server have been cached on this workstation, and false otherwise.

See Also

Server Class | StarTeam Namespace


IsAutoReconnectEnabled Property

Borland StarTeam SDK for .NET

Server.IsAutoReconnectEnabled Property

[read/write] true if a reconnect is automatically attempted whenever a connection problem is detected while executing a server command. Automatic reconnect is enabled by default.

public virtual Boolean IsAutoReconnectEnabled {get; set;}

Property Value

true if a reconnect is automatically attempted whenever a connection problem is detected while executing a server command. Automatic reconnect is enabled by default.

See Also

Server Class | StarTeam Namespace


IsCompressed Property

Borland StarTeam SDK for .NET

Server.IsCompressed Property

[read] true if the connection is compressed; false otherwise.

public virtual Boolean IsCompressed {get;}

Property Value

true if the connection is compressed; false otherwise.

See Also

Server Class | StarTeam Namespace


IsConnected Property

Borland StarTeam SDK for .NET

Server.IsConnected Property

[read] true if a network connection to the StarTeam server has been established.

public virtual Boolean IsConnected {get;}

Property Value

true if a network connection to the StarTeam server has been established.

See Also

Server Class | StarTeam Namespace


IsCredentialCachingAvailable Property

Borland StarTeam SDK for .NET

Server.IsCredentialCachingAvailable Property

[read] true if the credential caching feature is available on this workstation, and false otherwise.

public static Boolean IsCredentialCachingAvailable {get;}

Property Value

true if the credential caching feature is available on this workstation, and false otherwise.

See Also

Server Class | StarTeam Namespace


IsCredentialCachingEnabled Property

Borland StarTeam SDK for .NET

Server.IsCredentialCachingEnabled Property

[read] true if the credential caching feature is enabled on this workstation, and false otherwise.

public static Boolean IsCredentialCachingEnabled {get;}

Property Value

true if the credential caching feature is enabled on this workstation, and false otherwise.

See Also

Server Class | StarTeam Namespace


IsKeepAliveEnabled Property

Borland StarTeam SDK for .NET

Server.IsKeepAliveEnabled Property

[read] true if keep-alive mode is in effect; false otherwise. In keep-alive mode, a background thread periodically pings the server to keep the connection alive. Keep-alive is off by default.

public virtual Boolean IsKeepAliveEnabled {get;}

Property Value

true if keep-alive mode is in effect; false otherwise. In keep-alive mode, a background thread periodically pings the server to keep the connection alive. Keep-alive is off by default.

See Also

Server Class | StarTeam Namespace


IsLoggedOn Property

Borland StarTeam SDK for .NET

Server.IsLoggedOn Property

[read] true if someone has logged on through this server object.

public virtual Boolean IsLoggedOn {get;}

Property Value

true if someone has logged on through this server object.

See Also

Server Class | StarTeam Namespace


IsMailAvailable Property

Borland StarTeam SDK for .NET

Server.IsMailAvailable Property

[read] true if the server supports email or false if this server instance is not connected to the StarTeam Server

public virtual Boolean IsMailAvailable {get;}

Property Value

true if the server supports email or false if this server instance is not connected to the StarTeam Server

See Also

Server Class | StarTeam Namespace


IsMPXAvailable Property

Borland StarTeam SDK for .NET

Server.IsMPXAvailable Property

[read] true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).

public virtual Boolean IsMPXAvailable {get;}

Property Value

true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).

See Also

Server Class | StarTeam Namespace


IsMPXEnabled Property

Borland StarTeam SDK for .NET

Server.IsMPXEnabled Property

[read] true if MPX has been enabled for this server, and false otherwise.

public virtual Boolean IsMPXEnabled {get;}

Property Value

true if MPX has been enabled for this server, and false otherwise.

See Also

Server Class | StarTeam Namespace


IsMPXResponding Property

Borland StarTeam SDK for .NET

Server.IsMPXResponding Property

[read] true if the MPX server is running properly, and false otherwise.

public virtual Boolean IsMPXResponding {get;}

Property Value

true if the MPX server is running properly, and false otherwise.

See Also

Server Class | StarTeam Namespace


IsMPXUsingActiveMQ Property

Borland StarTeam SDK for .NET

Server.IsMPXUsingActiveMQ Property

[read]

public virtual Boolean IsMPXUsingActiveMQ {get;}

See Also

Server Class | StarTeam Namespace


IsRefreshAccountsRequired Property

Borland StarTeam SDK for .NET

Server.IsRefreshAccountsRequired Property

[read] true if User or Group information may be out of date.

public virtual Boolean IsRefreshAccountsRequired {get;}

Property Value

true if User or Group information may be out of date.

See Also

Server Class | StarTeam Namespace


IsRefreshGroupsRequired Property

Borland StarTeam SDK for .NET

Server.IsRefreshGroupsRequired Property

[read] true if Group information may be out of date.

public virtual Boolean IsRefreshGroupsRequired {get;}

Property Value

true if Group information may be out of date.

See Also

Server Class | StarTeam Namespace


IsRefreshProjectsRequired Property

Borland StarTeam SDK for .NET

Server.IsRefreshProjectsRequired Property

[read] true if a refresh is required; false otherwise.

public virtual Boolean IsRefreshProjectsRequired {get;}

Property Value

true if a refresh is required; false otherwise.

See Also

Server Class | StarTeam Namespace


IsRefreshUsersRequired Property

Borland StarTeam SDK for .NET

Server.IsRefreshUsersRequired Property

[read] true if User information may be out of date.

public virtual Boolean IsRefreshUsersRequired {get;}

Property Value

true if User information may be out of date.

See Also

Server Class | StarTeam Namespace


IsSingleSignOnAuthenticationEnabled Property

Borland StarTeam SDK for .NET

Server.IsSingleSignOnAuthenticationEnabled Property

[read] true if Single Sign-On Authentication has been enabled on the StarTeam server, false otherwise.

public virtual Boolean IsSingleSignOnAuthenticationEnabled {get;}

Property Value

true if Single Sign-On Authentication has been enabled on the StarTeam server, false otherwise.

See Also

Server Class | StarTeam Namespace


KeepAlive Property

Borland StarTeam SDK for .NET

Server.KeepAlive Property

[write] Enables or disables keep-alive mode.

public virtual Boolean KeepAlive {set;}

Property Value

Enables or disables keep-alive mode.

See Also

Server Class | StarTeam Namespace


KeepAliveInterval Property

Borland StarTeam SDK for .NET

Server.KeepAliveInterval Property

[read/write] The current keep-alive interval, in minutes.

public virtual Int32 KeepAliveInterval {get; set;}

Property Value

The current keep-alive interval, in minutes.

See Also

Server Class | StarTeam Namespace


KeepTraceRouteAlive Property

Borland StarTeam SDK for .NET

Server.KeepTraceRouteAlive Property

[write] Enables or disables keep-alive mode.

public virtual Int32 KeepTraceRouteAlive {set;}

Property Value

Enables or disables keep-alive mode.

See Also

Server Class | StarTeam Namespace


LoggedInUser Property

Borland StarTeam SDK for .NET

Server.LoggedInUser Property

[read] The user object of the logged in user, or null if no one has logged in.

public virtual User LoggedInUser {get;}

Property Value

The user object of the logged in user, or null if no one has logged in.

See Also

Server Class | StarTeam Namespace


MPXMessageCount Property

Borland StarTeam SDK for .NET

Server.MPXMessageCount Property

[read] The number of MPX messages received since MPX was enabled; 0 if not enabled.

public virtual Int32 MPXMessageCount {get;}

Property Value

The number of MPX messages received since MPX was enabled; 0 if not enabled.

See Also

Server Class | StarTeam Namespace


MPXTransmitterName Property

Borland StarTeam SDK for .NET

Server.MPXTransmitterName Property

[read] StarTeam MPX Transmitter name

public virtual String MPXTransmitterName {get;}

Property Value

StarTeam MPX Transmitter name

See Also

Server Class | StarTeam Namespace


NotificationMessage Property

Borland StarTeam SDK for .NET

Server.NotificationMessage Property

[read] a Notification message

public virtual String NotificationMessage {get;}

Property Value

a Notification message

See Also

Server Class | StarTeam Namespace


Oauth2AccessToken Property

Borland StarTeam SDK for .NET

Server.Oauth2AccessToken Property

[read]

public virtual String Oauth2AccessToken {get;}

See Also

Server Class | StarTeam Namespace


Oauth2IssuerURL Property

Borland StarTeam SDK for .NET

Server.Oauth2IssuerURL Property

[read] Oauth2 provider Issuer URL or null.

public virtual String Oauth2IssuerURL {get;}

Property Value

Oauth2 provider Issuer URL or null.

See Also

Server Class | StarTeam Namespace


Oauth2RedirectURI Property

Borland StarTeam SDK for .NET

Server.Oauth2RedirectURI Property

[read] Oauth2 Redirect URI or null.

public virtual String Oauth2RedirectURI {get;}

Property Value

Oauth2 Redirect URI or null.

See Also

Server Class | StarTeam Namespace


Port Property

Borland StarTeam SDK for .NET

Server.Port Property

[read] server's TCP/IP port

public virtual Int32 Port {get;}

Property Value

server's TCP/IP port

See Also

Server Class | StarTeam Namespace


ProductCodesValue Property

Borland StarTeam SDK for .NET

Server.ProductCodesValue Property

[read] The product codes licensed for this server.

public virtual ProductCode[] ProductCodesValue {get;}

Property Value

The product codes licensed for this server.

See Also

Server Class | StarTeam Namespace


Projects Property

Borland StarTeam SDK for .NET

Server.Projects Property

[read] The server's project list.

public virtual Project[] Projects {get;}

Property Value

The server's project list.

See Also

Server Class | StarTeam Namespace


Protocol Property

Borland StarTeam SDK for .NET

Server.Protocol Property

[read] The protocol used to connect to the server.

public virtual Int32 Protocol {get;}

Property Value

The protocol used to connect to the server.

See Also

Server Class | StarTeam Namespace


RepositoryID Property

Borland StarTeam SDK for .NET

Server.RepositoryID Property

[read] com.starteam.util.GUID

public virtual GUID RepositoryID {get;}

Property Value

com.starteam.util.GUID

See Also

Server Class | StarTeam Namespace


RequiredEncryptionLevel Property

Borland StarTeam SDK for .NET

Server.RequiredEncryptionLevel Property

[read] level of EncryptionAlgorithm required to connect to the server or NULL if this server instance is not connected to the StarTeam Server

public virtual Server.EncryptionAlgorithm RequiredEncryptionLevel {get;}

Property Value

level of EncryptionAlgorithm required to connect to the server or NULL if this server instance is not connected to the StarTeam Server

See Also

Server Class | StarTeam Namespace


RevisionLevel Property

Borland StarTeam SDK for .NET

Server.RevisionLevel Property

[read] the revision level of this server.

public virtual Int16 RevisionLevel {get;}

Property Value

the revision level of this server.

See Also

Server Class | StarTeam Namespace


SEPARATE_SERVER_SESSIONS Property

Borland StarTeam SDK for .NET

Server.SEPARATE_SERVER_SESSIONS Property

public static Boolean SEPARATE_SERVER_SESSIONS {get; set;}

See Also

Server Class | StarTeam Namespace


ServerBuild Property

Borland StarTeam SDK for .NET

Server.ServerBuild Property

[read] The server build number.

public virtual String ServerBuild {get;}

Property Value

The server build number.

See Also

Server Class | StarTeam Namespace


ServerBuildDescription Property

Borland StarTeam SDK for .NET

Server.ServerBuildDescription Property

[read] The server build description.

public virtual String ServerBuildDescription {get;}

Property Value

The server build description.

See Also

Server Class | StarTeam Namespace


ServerInfo Property

Borland StarTeam SDK for .NET

Server.ServerInfo Property

[read] A copy of serverInfo object used to construct this server session

public virtual ServerInfo ServerInfo {get;}

Property Value

A copy of serverInfo object used to construct this server session

See Also

Server Class | StarTeam Namespace


SessionValue Property

Borland StarTeam SDK for .NET

Server.SessionValue Property

[read] session information for the currently logged on user.

public virtual Server.Session SessionValue {get;}

Property Value

session information for the currently logged on user.

See Also

Server Class | StarTeam Namespace


SupportedFeatures Property

Borland StarTeam SDK for .NET

Server.SupportedFeatures Property

[read] An instance of the SupportedFeatures class that can tell which features are available for this StarTeam server

public virtual SupportedFeatures SupportedFeatures {get;}

Property Value

An instance of the SupportedFeatures class that can tell which features are available for this StarTeam server

See Also

Server Class | StarTeam Namespace


Types Property

Borland StarTeam SDK for .NET

Server.Types Property

[read] a collection of Types instances

public virtual TypeCollection Types {get;}

Property Value

a collection of Types instances

See Also

Server Class | StarTeam Namespace


Users Property

Borland StarTeam SDK for .NET

Server.Users Property

[read] All of the active and deleted users in this Server.

public virtual User[] Users {get;}

Property Value

All of the active and deleted users in this Server.

See Also

Server Class | StarTeam Namespace


Server Methods

The methods of the Server class are listed below. For a complete list of Server class members, see the Server Members topic.

Public Static Methods

CacheCredentials | Cache server specific credentials, if credential caching is available.
DeclareComponentDefinition |
DeclareComponentDefinitions |
DecryptPassword | Decrypt the specified password and return its clear text equivalent
EnableCredentialCaching | Enables credential caching on this workstation, if it is available and not already enabled.
EncryptPasswordToFile | Encrypt and save the specified clear text password to a file Return the file to the caller when done
FetchCachedPassword | Fetch the cached password, if credential caching is available
FetchCachedUserName | Fetch the cached user name for the given serverName/port combination, if any
UncacheCredentials | remove Cached Credentials, if any

Public Instance Methods

AutoLocateCacheAgent | autoLocate a Cache Agent, return null if none found Attempts to autolocate can be expensive
AutoLogOn | Log on to this server using credentials that have been cached on this workstation.
CacheLogOnCredentials | Saves logon credentials for this server so that they may be used in future calls to autoLogOn().
CanCreateCheckinChangePackages | Returns true if the server supports creating Change Packages on File Checkin This server configuration setting has been in force since the 12.5 server release. With this setting turned OFF, Change Packages are not created for checkin Additionally, old style links are created between files and process items, if any
ChangePassword | Changes the password to the specified new password upon a successful login to the server, and immediately logs out. New password is immediately effective upon a successful change of password.
Connect | Overloaded. Establishes a network connection to the remote server process. If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.
CreateTenant | Create a new tenant in an environment that supports multi-tenant hosting Will throw a server exception for on-premise servers
CreateType | create a custom component (a new type) on the server. Support for Custom Components has been introduced in the 12.0 release
DisableMPX | Disables MPX, if it was enabled for this server.
DiscardAccounts | Discards all cached User and Group information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardGroups | Discards cached Group information. The next call to getGroups() will re-fetch the group information from the StarTeam Server.
DiscardProjects | Discards the list of cached projects. A subsequent call to getProjects() will re-fetch the projects from the server (even when MPX is enabled).
DiscardUsers | Discards cached User information. The next call to getUsers() will re-fetch the user information from the StarTeam Server (even when MPX is enabled).
Disconnect
EnableMPX | Overloaded. Enables MPX using the default client MPX profile.
Equals | Delegate Equals() to com.starteam.Server.
FetchEmailUsers | This method issues a command to the server to return the list of users who are able to receive email messages. returns an empty array if this server instance is not connected to the StarTeam Server
FindGroup | Returns the Group object for the given ID.
FindProject | Overloaded. Finds a project in the server's project collection.
FindUser | Returns the User object for the given ID. The user returned will contain only a limited subset of the account information. Returns null if userID is not found.
GetCRStatus
GetEventHandlerInfo | Returns the specified EventHandlerInfo object on this server. If no such EventhandlerInfo exist, a null is returned.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.
GetStatus
GetType (inherited from Object) | Gets the Type of the current instance.
GetUDAGroupings
GetVisibleProperties | Return the subset of properties that are visible in the context of the specified Enumerated Value
HandleEvents | Places the current thread in an event-handling state. While in an event-handling state, the thread is usually asleep, waking occasionally just long enough to ping the server (keeping the connection alive). The event-handling loop continues until some other thread (presumably, the event-handling thread for this Server object) calls interruptHandleEvents(). An application does not need to call handleEvents() in order to handle events; this is just a convenience method for applications that have nothing else they need to do while waiting for an event to occur. Only one thread may call handleEvents() per Server object at any given time. After handleEvents() exits (as a result of a call to interruptHandleEvents), then handleEvents() may be called again by the same thread or by some other thread. handleEvents() will fail if MPX is not enabled, or if there are no event-handlers running. handleEvents() should not be called from within an event handler. (This would put the event-handling thread to sleep.)
HasInactivityTimeout | Returns true if the server has an inactivity timeout interval specified
HasProductCode
HasSavedCRStatus
HasSavedStatus
InterruptHandleEvents | Interrupts a handleEvents() loop, if there is one running. Usually called from within an event-handler, running in the event-handling thread for this Server object.
LocateCacheAgent | locate a CacheAgent at a given address and port
LogOn | Overloaded. Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied user credentials.
NewGroupEventSource
NewMPXStatusEventSource
NewProjectEventSource
NewServerControlEventSource
NewTypedResourceEventSource
NewTypeEventSource
NewUserEventSource
Oauth2logOn | Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied Oauth2 Authorization code.
ObtainLicense | Overloaded. Get/Consume a license for the specified User, using this Server's session ID to obtain the license. Returns the SessionID (GUID) that was used to obtain the license.
Ping | Verifies that the server is responding and informs the server that this connection/user session is still active.
PingMPXServer | Throws an appropriate MPXException if the MPX server is not running properly.
Reconnect | Overloaded. Attempts to re-establish the connection to the server, re-opening any existing view sessions. Uses the user credentials provided at logon time.
RefreshAccounts | Refreshes cached User and Group information. Existing User and Group objects are modified in place whenever possible.
RefreshGroups | Refreshes cached Group information to reflect recent changes to the repository. Modifies existing Group objects in place whenever possible.
RefreshProjects | Ensures that the latest list of projects has been retrieved from the server and cached locally. Also ensures that any previously cached project property values are up-to-date. refreshProjects() re-uses existing Project objects whenever possible, changing cached property values as necessary to bring older Projects up-to-date. When MPX is enabled, refreshProjects() is optimized to avoid unnecessary server commands.
RefreshUsers | Refreshes cached User information to reflect recent changes to the repository. Modifies existing User objects in place whenever possible. If MPX is enabled, refreshUsers() is optimized to avoid unnecessary server commands.
ReleaseLicense | Overloaded. Release a license owned by the specified User, where this Server's session ID was used to obtain the license.
SendMail | Overloaded. Directs the StarTeam Server to send mail to the specified StarTeam users.
SetCRStatus
SetStatus
SetUDAGroupings
SetVisibleProperties | Define a subset of properties of a given type that are marked visible
SingleSignOnLogon | Single sign-on login to StarTeam server, using a valid JWT access tokens, which were passed on by a logged in StarTeam client /3rd party application. This will be used in the Pulse bridge implementation.
SupportsInfoStreamCRStatus | Returns true if the server supports setting CR Status when the Story Status Changes
SupportsTraceVersioning
Synchronize | Add or release a set of keys, i.e. acquire a lock for these named keys The server will synchronize access to an internal hash table across any/all threads which attempt key acquisitions. The first thread wins and acquires the key all subsequent threads lose and a server exception will be thrown If this method fails, a server exception will be thrown Well behaved applications that acquire a locked key should release it as quickly as possible
ToString | Delegate ToString() to com.starteam.Server.
ValidateClient

See Also

Server Class | StarTeam Namespace


Server.AutoLocateCacheAgent Method

autoLocate a Cache Agent, return null if none found Attempts to autolocate can be expensive

public virtual CacheAgent AutoLocateCacheAgent();

Return Value

CacheAgent a CacheAgent if found, or null

See Also

Server Class | StarTeam Namespace | getAutoLocateCacheAgent


Server.AutoLogOn Method

Log on to this server using credentials that have been cached on this workstation.

public virtual User AutoLogOn();

Return Value

the logged on user object

See Also

Server Class | StarTeam Namespace | isAutoLogOnAvailable | cacheLogOnCredentials


Server.CacheCredentials Method

Cache server specific credentials, if credential caching is available.

public static void CacheCredentials(
String serverName,
Int32 port,
String username,
String password
);

Parameters

serverName
the server address
port
the port
username
the user
password
the password

See Also

Server Class | StarTeam Namespace


Server.CacheLogOnCredentials Method

Saves logon credentials for this server so that they may be used in future calls to autoLogOn().

public virtual void CacheLogOnCredentials(
String username,
String password
);

Parameters

username
the user name to save.
password
the password to save.

See Also

Server Class | StarTeam Namespace | autoLogOn | isAutoLogOnAvailable | isCredentialCachingEnabled


Server.CanCreateCheckinChangePackages Method

Returns true if the server supports creating Change Packages on File Checkin This server configuration setting has been in force since the 12.5 server release. With this setting turned OFF, Change Packages are not created for checkin Additionally, old style links are created between files and process items, if any

public virtual bool CanCreateCheckinChangePackages();

Return Value

true if the server supports creating Change Packages on File Checkin, false otherwise

See Also

Server Class | StarTeam Namespace


Server.ChangePassword Method

Changes the password to the specified new password upon a successful login to the server, and immediately logs out. New password is immediately effective upon a successful change of password.

public virtual User ChangePassword(
String logOnName,
String password,
String newPassword
);

Parameters

logOnName
The user's logon name.
password
The user's old password.
newPassword
The user's new password.

See Also

Server Class | StarTeam Namespace


Connect Method

Borland StarTeam SDK for .NET

Server.Connect Method

Establishes a network connection to the remote server process.

If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.

Overload List

Establishes a network connection to the remote server process. If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.

public virtual void Connect();

Establishes a network connection to the remote server process. This variation of connect() allows the client application to request a specific version of the server's command API. For example, requesting CONNECT_AS_110 would make a more recent server behave as if it were connecting to a StarTeam 11.0 client.

public virtual void Connect(DotNotation);

See Also

Server Class | StarTeam Namespace | Server | enableMPX | isMPXEnabled


Server.Connect Method ()

Establishes a network connection to the remote server process.

If the network connection is successfully established, and an MPXProfileName was specified in the Server constructor, then an attempt is made to automatically enable MPX. If an MPXException is thrown, it will be ignored, and will not cause the connect() to fail. An application can use isMPXEnabled() to determine whether or not MPX was properly enabled.

public virtual void Connect();

See Also

Server Class | StarTeam Namespace | Server.Connect Overload List | Server | enableMPX | isMPXEnabled


Server.Connect Method (DotNotation)

Establishes a network connection to the remote server process.

This variation of connect() allows the client application to request a specific version of the server's command API. For example, requesting CONNECT_AS_110 would make a more recent server behave as if it were connecting to a StarTeam 11.0 client.

public virtual void Connect(
DotNotation clientVersion
);

Parameters

clientVersion
a representation of the specific version of the command api requested

See Also

Server Class | StarTeam Namespace | Server.Connect Overload List | connect


Server.CreateTenant Method

Create a new tenant in an environment that supports multi-tenant hosting Will throw a server exception for on-premise servers

public virtual void CreateTenant(
Int32 tenantID,
String tenantName,
String tenantAdminLoginName,
String tenantAdminPassword
);

Parameters

tenantID
the tenant ID
tenantName
the tenant Name
tenantAdminLoginName
the Login Name of the Tenant Administrator
tenantAdminPassword
a clear text password for the Tenant Administrator

See Also

Server Class | StarTeam Namespace


Server.CreateType Method

create a custom component (a new type) on the server. Support for Custom Components has been introduced in the 12.0 release

public virtual Type CreateType(
String xmlDefinition,
Boolean toCreate
);

Parameters

xmlDefinition
the xml definition describing the schema of the new Type
toCreate
true to create the Component, false to verify the schema

Return Value

the Type matching the component definition or NULL if the schema is being verified

See Also

Server Class | StarTeam Namespace


Server.DeclareComponentDefinition Method

public static void DeclareComponentDefinition(
String typeName,
Type componentClass
);

See Also

Server Class | StarTeam Namespace


Server.DeclareComponentDefinitions Method

public static void DeclareComponentDefinitions(
String typeName,
String propertyName,
Type[] clazz
);

See Also

Server Class | StarTeam Namespace


Server.DecryptPassword Method

Decrypt the specified password and return its clear text equivalent

public static string DecryptPassword(
Byte[] password
);

Parameters

password
the password encrypted into a byte[]

Return Value

the clear text password as a String.

See Also

Server Class | StarTeam Namespace


Server.DisableMPX Method

Disables MPX, if it was enabled for this server.

public virtual void DisableMPX();

See Also

Server Class | StarTeam Namespace


Server.DiscardAccounts Method

Discards all cached User and Group information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void DiscardAccounts();

See Also

Server Class | StarTeam Namespace | refreshAccounts


Server.DiscardGroups Method

Discards cached Group information. The next call to getGroups() will re-fetch the group information from the StarTeam Server.

public virtual void DiscardGroups();

See Also

Server Class | StarTeam Namespace | getGroups | refreshGroups


Server.DiscardProjects Method

Discards the list of cached projects. A subsequent call to getProjects() will re-fetch the projects from the server (even when MPX is enabled).

public virtual void DiscardProjects();

See Also

Server Class | StarTeam Namespace | getProjects | refreshProjects | enableMPX


Server.DiscardUsers Method

Discards cached User information. The next call to getUsers() will re-fetch the user information from the StarTeam Server (even when MPX is enabled).

public virtual void DiscardUsers();

See Also

Server Class | StarTeam Namespace | getUsers | refreshUsers


Server.Disconnect Method

public virtual void Disconnect();

See Also

Server Class | StarTeam Namespace


Server.EnableCredentialCaching Method

Enables credential caching on this workstation, if it is available and not already enabled.

public static void EnableCredentialCaching();

See Also

Server Class | StarTeam Namespace | autoLogOn | isCredentialCachingAvailable | isCredentialCachingEnabled | cacheLogOnCredentials


EnableMPX Method

Borland StarTeam SDK for .NET

Server.EnableMPX Method

Enables MPX using the default client MPX profile.

Overload List

Enables MPX using the default client MPX profile.

public virtual void EnableMPX();

Enables MPX using the given MPX profile.

public virtual void EnableMPX(EventHandlerProfile);

Enables MPX using the MPX profile with the given name.

public virtual void EnableMPX(String);

See Also

Server Class | StarTeam Namespace | enableMPX | enableMPX


Server.EnableMPX Method ()

Enables MPX using the default client MPX profile.

public virtual void EnableMPX();

Exceptions

Exception Type | Condition
 | com.starteam.exceptions.MPXException

See Also

Server Class | StarTeam Namespace | Server.EnableMPX Overload List | enableMPX | enableMPX


Server.EnableMPX Method (EventHandlerProfile)

Enables MPX using the given MPX profile.

public virtual void EnableMPX(
EventHandlerProfile profile
);

Parameters

profile
An MPX profile.

Exceptions

Exception Type | Condition
 | com.starteam.exceptions.MPXException

See Also

Server Class | StarTeam Namespace | Server.EnableMPX Overload List | enableMPX | enableMPX | isMPXAvailable | isMPXEnabled | isMPXResponding | pingMPXServer | disableMPX


Server.EnableMPX Method (String)

Enables MPX using the MPX profile with the given name.

public virtual void EnableMPX(
String strProfileName
);

Parameters

strProfileName
The name of an MPX profile on this server.

Exceptions

Exception Type | Condition
 | com.starteam.exceptions.MPXException

See Also

Server Class | StarTeam Namespace | Server.EnableMPX Overload List | enableMPX | enableMPX


Server.EncryptPasswordToFile Method

Encrypt and save the specified clear text password to a file Return the file to the caller when done

public static FileInfo EncryptPasswordToFile(
String password,
String fileName
);

Parameters

password
the clear text password
fileName
the fully qualified path to a file If fileName is null or empty, a temporary file with the prefix "pwd" will be created The returned file with the encrypted password can be used by the method {@link #logOn(String, java.io.File)} or through the CommandProcessor

Return Value

a file containing the encrypted string

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Server Class | StarTeam Namespace | CommandProcessor


Server.Equals Method

Delegate Equals() to com.starteam.Server.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Server.Equals(obj).

See Also

Server Class | StarTeam Namespace


Server.FetchCachedPassword Method

Fetch the cached password, if credential caching is available

public static string FetchCachedPassword(
String serverName,
Int32 port
);

Parameters

serverName
the server address
port
the port

Return Value

cached password for the given serverName/port.

See Also

Server Class | StarTeam Namespace


Server.FetchCachedUserName Method

Fetch the cached user name for the given serverName/port combination, if any

public static string FetchCachedUserName(
String serverName,
Int32 port
);

Parameters

serverName
the server address
port
the port

Return Value

cached user name.

See Also

Server Class | StarTeam Namespace


Server.FetchEmailUsers Method

This method issues a command to the server to return the list of users who are able to receive email messages. returns an empty array if this server instance is not connected to the StarTeam Server

public virtual User[] FetchEmailUsers();

See Also

Server Class | StarTeam Namespace


Server.FindGroup Method

Returns the Group object for the given ID.

public virtual Group FindGroup(
Int32 groupID
);

Parameters

groupID
the group ID in question

Return Value

the Group object with the given ID. Will return null if not found.

See Also

Server Class | StarTeam Namespace | getGroups


FindProject Method

Borland StarTeam SDK for .NET

Server.FindProject Method

Finds a project in the server's project collection.

Overload List

Finds a project in the server's project collection.

public virtual Project FindProject(Int32);

Finds a project in the server's project collection.

public virtual Project FindProject(String);

See Also

Server Class | StarTeam Namespace


Server.FindProject Method (Int32)

Finds a project in the server's project collection.

public virtual Project FindProject(
Int32 projectID
);

Parameters

projectID
The project ID of the desired project.

Return Value

The project with the given ID, or null if no such project was found.

See Also

Server Class | StarTeam Namespace | Server.FindProject Overload List


Server.FindProject Method (String)

Finds a project in the server's project collection.

public virtual Project FindProject(
String name
);

Parameters

name
The name of the desired project.

Return Value

The project with the given ID, or null if no such project was found.

See Also

Server Class | StarTeam Namespace | Server.FindProject Overload List


Server.FindUser Method

Returns the User object for the given ID. The user returned will contain only a limited subset of the account information. Returns null if userID is not found.

public virtual User FindUser(
Int32 userID
);

Parameters

userID
the user ID in question

Return Value

the User object with the given ID.Will return null if not found.

See Also

Server Class | StarTeam Namespace | getUsers


Server.GetCRStatus Method

public virtual EnumeratedValue GetCRStatus(
Story.Status sts
);

See Also

Server Class | StarTeam Namespace


Server.GetEventHandlerInfo Method

Returns the specified EventHandlerInfo object on this server. If no such EventhandlerInfo exist, a null is returned.

public virtual EventHandlerInfo GetEventHandlerInfo(
String eventHandlerInfoName
);

Parameters

eventHandlerInfoName
The name of the EventHandlerInfo object to be returned.

Return Value

the specified EventHandlerInfo object on this server. If no such EventhandlerInfo exist, a null is returned.

See Also

Server Class | StarTeam Namespace | getEventHandlerInfoNames


Server.GetHashCode Method

Delegate GetHashCode() to com.starteam.Server.

public override int GetHashCode();

Return Value

com.starteam.Server.GetHashCode().

See Also

Server Class | StarTeam Namespace


Server.GetStatus Method

public virtual Status[] GetStatus(
Story.Status sts
);

See Also

Server Class | StarTeam Namespace


Server.GetUDAGroupings Method

public virtual EnumeratedValue[] GetUDAGroupings(
Requirement.RequirementType typ
);

See Also

Server Class | StarTeam Namespace


Server.GetVisibleProperties Method

Return the subset of properties that are visible in the context of the specified Enumerated Value

public virtual PropertyCollection GetVisibleProperties(
EnumeratedValue value
);

Parameters

value
an Enumerated Value for a specific Enumerated Property of a chosen type

Return Value

the subset of properties of the same Type that are marked visible in the context of this enum

See Also

Server Class | StarTeam Namespace


Server.HandleEvents Method

Places the current thread in an event-handling state.

While in an event-handling state, the thread is usually asleep, waking occasionally just long enough to ping the server (keeping the connection alive). The event-handling loop continues until some other thread (presumably, the event-handling thread for this Server object) calls interruptHandleEvents().

An application does not need to call handleEvents() in order to handle events; this is just a convenience method for applications that have nothing else they need to do while waiting for an event to occur.

Only one thread may call handleEvents() per Server object at any given time. After handleEvents() exits (as a result of a call to interruptHandleEvents), then handleEvents() may be called again by the same thread or by some other thread.

handleEvents() will fail if MPX is not enabled, or if there are no event-handlers running.

handleEvents() should not be called from within an event handler. (This would put the event-handling thread to sleep.)

public virtual void HandleEvents();

See Also

Server Class | StarTeam Namespace | interruptHandleEvents | enableMPX


Server.HasInactivityTimeout Method

Returns true if the server has an inactivity timeout interval specified

public virtual bool HasInactivityTimeout();

Return Value

True if the server has an Inactivity Timeout Interval specified

See Also

Server Class | StarTeam Namespace


Server.HasProductCode Method

public virtual bool HasProductCode(
Server.ProductCode code
);

See Also

Server Class | StarTeam Namespace


Server.HasSavedCRStatus Method

public virtual bool HasSavedCRStatus(
Story.Status sts
);

See Also

Server Class | StarTeam Namespace


Server.HasSavedStatus Method

public virtual bool HasSavedStatus(
Story.Status sts
);

See Also

Server Class | StarTeam Namespace


Server.InterruptHandleEvents Method

Interrupts a handleEvents() loop, if there is one running. Usually called from within an event-handler, running in the event-handling thread for this Server object.

public virtual void InterruptHandleEvents();

See Also

Server Class | StarTeam Namespace | handleEvents


Server.LocateCacheAgent Method

locate a CacheAgent at a given address and port

public virtual CacheAgent LocateCacheAgent(
String hostName,
Int32 port
);

Parameters

hostName
String the address at which to look for a cache agent
port
int the port the cache agent is running on

Return Value

CacheAgent a CacheAgent if found, or null

See Also

Server Class | StarTeam Namespace | getMPXCacheAgentAddress | getMPXCacheAgentPort


LogOn Method

Borland StarTeam SDK for .NET

Server.LogOn Method

Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied user credentials.

Overload List

Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied user credentials.

public virtual User LogOn(String,FileInfo);

Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied user credentials.

public virtual User LogOn(String,String);

Establishes a user-session with the remote server process, on behalf of the specified ClientContext. This is useful when running on behalf of a remote client workstation.

public virtual User LogOn(String,String,ClientContext);

Establishes a user-session with the remote server process, on behalf of the workstation with the given ID. This is useful when running on behalf of a remote client workstation. Will create a separate server session per logged in user, so that the caches are isolated

public virtual User LogOn(String,String,GUID);

Establishes a user-session with the remote server process. The connection is created using the administrative credentials, then switched over to impersonate the user specified and the user license is validated as well. Each session created using this api occupies it's own private cache This api introduces a poor man's StarTeam sso object model. If the validation fails for any reason, this method will return NULL.

public virtual User LogOn(String,String,Int32,GUID);

See Also

Server Class | StarTeam Namespace | CommandProcessor


Server.LogOn Method (String, FileInfo)

Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied user credentials.

public virtual User LogOn(
String logOnName,
FileInfo passwordFile
);

Parameters

logOnName
the user's logon name
passwordFile
the encrypted user's password saved in a file via the StarTeam Command Line or using the static method {@link #encryptPasswordToFile(String, String)}

Return Value

the logged on user

See Also

Server Class | StarTeam Namespace | Server.LogOn Overload List | CommandProcessor


Server.LogOn Method (String, String)

Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied user credentials.

public virtual User LogOn(
String logOnName,
String password
);

Parameters

logOnName
the user's logon name
password
the user's password

Return Value

the logged on user

See Also

Server Class | StarTeam Namespace | Server.LogOn Overload List


Server.LogOn Method (String, String, ClientContext)

Establishes a user-session with the remote server process, on behalf of the specified ClientContext. This is useful when running on behalf of a remote client workstation.

public virtual User LogOn(
String logOnName,
String password,
ClientContext context
);

Parameters

logOnName
The user's logon name.
password
The user's password.
context
The ClientContext of the client workstation.

Return Value

The logged on user.

See Also

Server Class | StarTeam Namespace | Server.LogOn Overload List | GUID


Server.LogOn Method (String, String, GUID)

Establishes a user-session with the remote server process, on behalf of the workstation with the given ID. This is useful when running on behalf of a remote client workstation. Will create a separate server session per logged in user, so that the caches are isolated

public virtual User LogOn(
String logOnName,
String password,
GUID workStationID
);

Parameters

logOnName
The user's logon name.
password
The user's password.
workStationID
The GUID of the client workstation.

Return Value

The logged on user.

See Also

Server Class | StarTeam Namespace | Server.LogOn Overload List | GUID


Server.LogOn Method (String, String, Int32, GUID)

Establishes a user-session with the remote server process. The connection is created using the administrative credentials, then switched over to impersonate the user specified and the user license is validated as well. Each session created using this api occupies it's own private cache This api introduces a poor man's StarTeam sso object model. If the validation fails for any reason, this method will return NULL.

public virtual User LogOn(
String adminLogOnName,
String adminPassword,
Int32 impersonateUserID,
GUID licenseID
);

Parameters

adminLogOnName
the username of the administrator used to create the session
adminPassword
the password of the administrator used to create the session
impersonateUserID
the user in whose context the session will be run
licenseID
the user license, which is guaranteed to be in use, current and consumed

Return Value

the user being impersonated or NULL

See Also

Server Class | StarTeam Namespace | Server.LogOn Overload List


Server.NewGroupEventSource Method

public GroupEventSource NewGroupEventSource();

See Also

Server Class | StarTeam Namespace


Server.NewMPXStatusEventSource Method

public MPXStatusEventSource NewMPXStatusEventSource();

See Also

Server Class | StarTeam Namespace


Server.NewProjectEventSource Method

public ProjectEventSource NewProjectEventSource();

See Also

Server Class | StarTeam Namespace


Server.NewServerControlEventSource Method

public ServerControlEventSource NewServerControlEventSource();

See Also

Server Class | StarTeam Namespace


Server.NewTypedResourceEventSource Method

public TypedResourceEventSource NewTypedResourceEventSource(
LiveObject container,
TypeCollection types
);

See Also

Server Class | StarTeam Namespace


Server.NewTypeEventSource Method

public TypeEventSource NewTypeEventSource();

See Also

Server Class | StarTeam Namespace


Server.NewUserEventSource Method

public UserEventSource NewUserEventSource();

See Also

Server Class | StarTeam Namespace


Server.Oauth2logOn Method

Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied Oauth2 Authorization code.

public virtual User Oauth2logOn(
String authorizationCode,
String oauth2redirectURI
);

Parameters

authorizationCode
Oauth2 authorization code.
oauth2redirectURI

Return Value

the logged on user

See Also

Server Class | StarTeam Namespace


ObtainLicense Method

Borland StarTeam SDK for .NET

Server.ObtainLicense Method

Get/Consume a license for the specified User, using this Server's session ID to obtain the license. Returns the SessionID (GUID) that was used to obtain the license.

Overload List

Get/Consume a license for the specified User, using this Server's session ID to obtain the license. Returns the SessionID (GUID) that was used to obtain the license.

public virtual GUID ObtainLicense(User);

Get/Consume a license for the specified User, using the specified Server's session ID to obtain the license. Returns the SessionID (GUID) that was used to obtain the license.

public virtual GUID ObtainLicense(User,Server);

See Also

Server Class | StarTeam Namespace


Server.ObtainLicense Method (User)

Get/Consume a license for the specified User, using this Server's session ID to obtain the license. Returns the SessionID (GUID) that was used to obtain the license.

public virtual GUID ObtainLicense(
User user
);

Parameters

user
the user who will "own" the license.

Return Value

the GUID that was used to obtain the license.

See Also

Server Class | StarTeam Namespace | Server.ObtainLicense Overload List


Server.ObtainLicense Method (User, Server)

Get/Consume a license for the specified User, using the specified Server's session ID to obtain the license. Returns the SessionID (GUID) that was used to obtain the license.

public virtual GUID ObtainLicense(
User user,
Server server
);

Parameters

user
the user who will "own" the license.
server
the server whose session ID will be used to obtain the license.

Return Value

the GUID that was used to obtain the license.

See Also

Server Class | StarTeam Namespace | Server.ObtainLicense Overload List


Server.Ping Method

Verifies that the server is responding and informs the server that this connection/user session is still active.

public virtual bool Ping();

Return Value

true if the server responds, false if the server fails to respond for any reason, including not being connected

See Also

Server Class | StarTeam Namespace


Server.PingMPXServer Method

Throws an appropriate MPXException if the MPX server is not running properly.

public virtual void PingMPXServer();

Exceptions

Exception Type | Condition
 | com.starteam.exceptions.MPXException

See Also

Server Class | StarTeam Namespace


Reconnect Method

Borland StarTeam SDK for .NET

Server.Reconnect Method

Attempts to re-establish the connection to the server, re-opening any existing view sessions.

Uses the user credentials provided at logon time.

Overload List

Attempts to re-establish the connection to the server, re-opening any existing view sessions. Uses the user credentials provided at logon time.

public virtual void Reconnect();

Attempts to re-establish the connection to the server, re-opening any existing view sessions. The server will re-authenticate the connection using the user name provided at logon time and the given password.

public virtual void Reconnect(String);

See Also

Server Class | StarTeam Namespace | isAutoReconnectEnabled


Server.Reconnect Method ()

Attempts to re-establish the connection to the server, re-opening any existing view sessions.

Uses the user credentials provided at logon time.

public virtual void Reconnect();

See Also

Server Class | StarTeam Namespace | Server.Reconnect Overload List | isAutoReconnectEnabled


Server.Reconnect Method (String)

Attempts to re-establish the connection to the server, re-opening any existing view sessions.

The server will re-authenticate the connection using the user name provided at logon time and the given password.

public virtual void Reconnect(
String password
);

Parameters

password
The password used to re-authenticate the connection.

See Also

Server Class | StarTeam Namespace | Server.Reconnect Overload List


Server.RefreshAccounts Method

Refreshes cached User and Group information. Existing User and Group objects are modified in place whenever possible.

public virtual void RefreshAccounts();

See Also

Server Class | StarTeam Namespace | isRefreshAccountsRequired | refreshUsers | refreshGroups | discardAccounts


Server.RefreshGroups Method

Refreshes cached Group information to reflect recent changes to the repository. Modifies existing Group objects in place whenever possible.

public virtual void RefreshGroups();

See Also

Server Class | StarTeam Namespace | isRefreshGroupsRequired | getGroups | discardGroups


Server.RefreshProjects Method

Ensures that the latest list of projects has been retrieved from the server and cached locally. Also ensures that any previously cached project property values are up-to-date. refreshProjects() re-uses existing Project objects whenever possible, changing cached property values as necessary to bring older Projects up-to-date. When MPX is enabled, refreshProjects() is optimized to avoid unnecessary server commands.

public virtual void RefreshProjects();

See Also

Server Class | StarTeam Namespace | getProjects | isRefreshProjectsRequired | discardProjects | enableMPX


Server.RefreshUsers Method

Refreshes cached User information to reflect recent changes to the repository. Modifies existing User objects in place whenever possible. If MPX is enabled, refreshUsers() is optimized to avoid unnecessary server commands.

public virtual void RefreshUsers();

See Also

Server Class | StarTeam Namespace | isRefreshUsersRequired | getUsers | discardUsers | enableMPX


ReleaseLicense Method

Borland StarTeam SDK for .NET

Server.ReleaseLicense Method

Release a license owned by the specified User, where this Server's session ID was used to obtain the license.

Overload List

Release a license owned by the specified User, where this Server's session ID was used to obtain the license.

public virtual void ReleaseLicense(User);

Release a license owned by the specified User, where the specified Server's session ID was used to obtain the license.

public virtual void ReleaseLicense(User,Server);

Release the license obtained for the specified User via the specified GUID.

public virtual void ReleaseLicense(User,GUID);

See Also

Server Class | StarTeam Namespace


Server.ReleaseLicense Method (User)

Release a license owned by the specified User, where this Server's session ID was used to obtain the license.

public virtual void ReleaseLicense(
User user
);

Parameters

user
the user who "owns" the license.

See Also

Server Class | StarTeam Namespace | Server.ReleaseLicense Overload List


Server.ReleaseLicense Method (User, Server)

Release a license owned by the specified User, where the specified Server's session ID was used to obtain the license.

public virtual void ReleaseLicense(
User user,
Server server
);

Parameters

user
the user who "owns" the license.
server
the server whose session ID was used to obtain the license.

See Also

Server Class | StarTeam Namespace | Server.ReleaseLicense Overload List


Server.ReleaseLicense Method (User, GUID)

Release the license obtained for the specified User via the specified GUID.

public virtual void ReleaseLicense(
User user,
GUID sessionID
);

Parameters

user
the User who "owns" the license.
sessionID
the GUID that was used to obtain the license.

See Also

Server Class | StarTeam Namespace | Server.ReleaseLicense Overload List


SendMail Method

Borland StarTeam SDK for .NET

Server.SendMail Method

Directs the StarTeam Server to send mail to the specified StarTeam users.

Overload List

Directs the StarTeam Server to send mail to the specified StarTeam users.

public virtual void SendMail(View,User[],User[],User[],String,String);

public virtual void SendMail(View,User[],User[],User[],String,String,EmailAttachment[]);

See Also

Server Class | StarTeam Namespace


Server.SendMail Method (View, User[], User[], User[], String, String)

Directs the StarTeam Server to send mail to the specified StarTeam users.

public virtual void SendMail(
View view,
User[] to,
User[] cc,
User[] bcc,
String subject,
String body
);

Parameters

view
a valid view the sender has access to
to
the user IDs to whom the mail should be sent (To:)
cc
the user IDs to whom the mail should be cc'd (Cc:)
bcc
the user IDs to whom the mail should be blind-cc'd (Bcc:)
subject
the subject text for the mail message
body
the body of the mail message

See Also

Server Class | StarTeam Namespace | Server.SendMail Overload List


Server.SendMail Method (View, User[], User[], User[], String, String, Server#EmailAttachment[])

public virtual void SendMail(
View view,
User[] to,
User[] cc,
User[] bcc,
String subject,
String body,
EmailAttachment[] attachments
);

See Also

Server Class | StarTeam Namespace | Server.SendMail Overload List


Server.SetCRStatus Method

public virtual void SetCRStatus(
Story.Status rfrnc,
EnumeratedValue trgt
);

See Also

Server Class | StarTeam Namespace


Server.SetStatus Method

public virtual void SetStatus(
Story.Status rfrnc,
Status[] mppdSts
);

See Also

Server Class | StarTeam Namespace


Server.SetUDAGroupings Method

public virtual void SetUDAGroupings(
Requirement.RequirementType typ,
EnumeratedValue[] udas
);

See Also

Server Class | StarTeam Namespace


Server.SetVisibleProperties Method

Define a subset of properties of a given type that are marked visible

public virtual void SetVisibleProperties(
EnumeratedValue value,
PropertyCollection properties
);

Parameters

value
an Enumerated Value for a specific Enumerated Property of a chosen type
properties
the set of properties marked visible in the context of the specified enum

See Also

Server Class | StarTeam Namespace


Server.SingleSignOnLogon Method

Single sign-on login to StarTeam server, using a valid JWT access tokens, which were passed on by a logged in StarTeam client /3rd party application. This will be used in the Pulse bridge implementation.

public virtual User SingleSignOnLogon(
String oauth2AccessToken
);

Parameters

oauth2AccessToken
Valid JWT access token.

Return Value

the logged on user

See Also

Server Class | StarTeam Namespace


Server.SupportsInfoStreamCRStatus Method

Returns true if the server supports setting CR Status when the Story Status Changes

public virtual bool SupportsInfoStreamCRStatus();

Return Value

true if the server supports setting CR Status when the Story Status Changes

See Also

Server Class | StarTeam Namespace


Server.SupportsTraceVersioning Method

public virtual bool SupportsTraceVersioning(
Item.Type typ
);

See Also

Server Class | StarTeam Namespace


Server.Synchronize Method

Add or release a set of keys, i.e. acquire a lock for these named keys The server will synchronize access to an internal hash table across any/all threads which attempt key acquisitions. The first thread wins and acquires the key all subsequent threads lose and a server exception will be thrown If this method fails, a server exception will be thrown Well behaved applications that acquire a locked key should release it as quickly as possible

public virtual void Synchronize(
String[] keys,
Boolean acquire
);

Parameters

keys
the keys to be acquired or released
acquire
true to acquire the keys, false to release them

See Also

Server Class | StarTeam Namespace


Server.ToString Method

Delegate ToString() to com.starteam.Server.

public override string ToString();

Return Value

com.starteam.Server.ToString()

See Also

Server Class | StarTeam Namespace


Server.UncacheCredentials Method

remove Cached Credentials, if any

public static void UncacheCredentials(
String serverName,
Int32 port
);

Parameters

serverName
the server address
port
the port

See Also

Server Class | StarTeam Namespace


Server.ValidateClient Method

public virtual bool ValidateClient(
GUID clientGuid,
User user
);

Parameters

clientGuid
user
the user who owns the guid

Return Value

true if the client is logged in with this guid Returns true, if the input client guid is valid for the input user i.e. a currently logged in user session???s id on the server.

See Also

Server Class | StarTeam Namespace


Server.CacheController Class

For each repository accessed via some Server object, we maintain a local cache that holds data fetched from the repository. Normally, when a given cache is no longer referenced by any Server object, the cache is discarded, freeing up memory used by the cached data objects. However, "server-oriented" applications, which open and close many Server connections on behalf of various clients, may benefit from keeping these local caches around even after they are no longer referenced by any Server object. This is especially true when MPX is enabled. CacheController allows an application to adjust the behavior of the SDK caching mechanisms as appropriate.

For a list of all members of this type, see Server.CacheController Members.

System.Object
Server.CacheController

public class Server.CacheController

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Server.CacheController Members | StarTeam Namespace


Server.CacheController Members

Server.CacheController overview

Public Static Properties

MaxCaches [read/write] The maximum number of server caches that are permitted to remain in memory even after they are no longer referenced by any Server object.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Server.CacheController.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.CacheController.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Server.CacheController.

See Also

Server.CacheController Class | StarTeam Namespace


Server.CacheController Properties

The properties of the Server.CacheController class are listed below. For a complete list of Server.CacheController class members, see the Server.CacheController Members topic.

Public Static Properties

MaxCaches [read/write] The maximum number of server caches that are permitted to remain in memory even after they are no longer referenced by any Server object.

See Also

Server.CacheController Class | StarTeam Namespace


MaxCaches Property

Borland StarTeam SDK for .NET

Server.CacheController.MaxCaches Property

[read/write] The maximum number of server caches that are permitted to remain in memory even after they are no longer referenced by any Server object.

public static Int32 MaxCaches {get; set;}

Property Value

The maximum number of server caches that are permitted to remain in memory even after they are no longer referenced by any Server object.

See Also

Server.CacheController Class | StarTeam Namespace


Server.CacheController Methods

The methods of the Server.CacheController class are listed below. For a complete list of Server.CacheController class members, see the Server.CacheController Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Server.CacheController.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.CacheController.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Server.CacheController.

See Also

Server.CacheController Class | StarTeam Namespace


Server.CacheController.Equals Method

Delegate Equals() to com.starteam.Server.CacheController.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Server.CacheController.Equals(obj).

See Also

Server.CacheController Class | StarTeam Namespace


Server.CacheController.GetHashCode Method

Delegate GetHashCode() to com.starteam.Server.CacheController.

public override int GetHashCode();

Return Value

com.starteam.Server.CacheController.GetHashCode().

See Also

Server.CacheController Class | StarTeam Namespace


Server.CacheController.ToString Method

Delegate ToString() to com.starteam.Server.CacheController.

public override string ToString();

Return Value

com.starteam.Server.CacheController.ToString()

See Also

Server.CacheController Class | StarTeam Namespace


Server.EmailAttachment Class

This class embodies an email attachment.

For a list of all members of this type, see Server.EmailAttachment Members.

System.Object
Server.EmailAttachment

public class Server.EmailAttachment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Server.EmailAttachment Members | StarTeam Namespace


Server.EmailAttachment Members

Server.EmailAttachment overview

Public Instance Constructors

Server.EmailAttachment Constructor Creates a new email attachment based on the specified input file. You must also supply a name for the attachment and the MIME content-type. For example, content-type might be "text/html"

Public Instance Properties

ContentType | [read]
Name | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Server.EmailAttachment.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.EmailAttachment.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Server.EmailAttachment.

See Also

Server.EmailAttachment Class | StarTeam Namespace


Server.EmailAttachment Constructor

Creates a new email attachment based on the specified input file. You must also supply a name for the attachment and the MIME content-type. For example, content-type might be "text/html"

public Server.EmailAttachment(
FileInfo source,
String name,
String contentType
);

Parameters

source
the file to be attached, may not be null
name
the name to call the attachment, may not be null
contentType
the attachment's content type, may not be null

See Also

Server.EmailAttachment Class | StarTeam Namespace


Server.EmailAttachment Properties

The properties of the Server.EmailAttachment class are listed below. For a complete list of Server.EmailAttachment class members, see the Server.EmailAttachment Members topic.

Public Instance Properties

ContentType | [read]
Name | [read]

See Also

Server.EmailAttachment Class | StarTeam Namespace


ContentType Property

Borland StarTeam SDK for .NET

Server.EmailAttachment.ContentType Property

[read]

public virtual String ContentType {get;}

See Also

Server.EmailAttachment Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Server.EmailAttachment.Name Property

[read]

public virtual String Name {get;}

See Also

Server.EmailAttachment Class | StarTeam Namespace


Server.EmailAttachment Methods

The methods of the Server.EmailAttachment class are listed below. For a complete list of Server.EmailAttachment class members, see the Server.EmailAttachment Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Server.EmailAttachment.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.EmailAttachment.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Server.EmailAttachment.

See Also

Server.EmailAttachment Class | StarTeam Namespace


Server.EmailAttachment.Equals Method

Delegate Equals() to com.starteam.Server.EmailAttachment.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Server.EmailAttachment.Equals(obj).

See Also

Server.EmailAttachment Class | StarTeam Namespace


Server.EmailAttachment.GetHashCode Method

Delegate GetHashCode() to com.starteam.Server.EmailAttachment.

public override int GetHashCode();

Return Value

com.starteam.Server.EmailAttachment.GetHashCode().

See Also

Server.EmailAttachment Class | StarTeam Namespace


Server.EmailAttachment.ToString Method

Delegate ToString() to com.starteam.Server.EmailAttachment.

public override string ToString();

Return Value

com.starteam.Server.EmailAttachment.ToString()

See Also

Server.EmailAttachment Class | StarTeam Namespace


Server.EncryptionAlgorithm Class

This class provides a convenient place to refer to the different encryption algorithms that can be used for secure StarTeam connections. This class is used by various encryption methods on the connection and server objects.

For a list of all members of this type, see Server.EncryptionAlgorithm Members.

System.Object
EnumeratedValue
Server.EncryptionAlgorithm

public class Server.EncryptionAlgorithm : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Server.EncryptionAlgorithm Members | StarTeam Namespace


Server.EncryptionAlgorithm Members

Server.EncryptionAlgorithm overview

Public Static Properties

ALL
NULL
RC2_CBC
RC2_CFB
RC2_ECB
RC4

Public Static Methods

FromID | Gets the EncryptionAlgorithm value corresponding to the given ID.
MaxSecurity |

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read]
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Server.EncryptionAlgorithm.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Server.EncryptionAlgorithm.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Server.EncryptionAlgorithm.

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


Server.EncryptionAlgorithm Properties

The properties of the Server.EncryptionAlgorithm class are listed below. For a complete list of Server.EncryptionAlgorithm class members, see the Server.EncryptionAlgorithm Members topic.

Public Static Properties

ALL
NULL
RC2_CBC
RC2_CFB
RC2_ECB
RC4

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read]
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Server.EncryptionAlgorithm.ALL Property

public static EncryptionAlgorithm[] ALL {get;}

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Server.EncryptionAlgorithm.ID Property

[read]

public virtual Int32 ID {get;}

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


NULL Property

Borland StarTeam SDK for .NET

Server.EncryptionAlgorithm.NULL Property

public static Server.EncryptionAlgorithm NULL {get;}

Property Value

Specifies that no encryption be used.

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


RC2_CBC Property

Borland StarTeam SDK for .NET

Server.EncryptionAlgorithm.RC2_CBC Property

public static Server.EncryptionAlgorithm RC2_CBC {get;}

Property Value

Use RC2 block cipher in Cipher Block Chaining mode.

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


RC2_CFB Property

Borland StarTeam SDK for .NET

Server.EncryptionAlgorithm.RC2_CFB Property

public static Server.EncryptionAlgorithm RC2_CFB {get;}

Property Value

Use RC2 block cipher in Cipher Feedback mode.

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


RC2_ECB Property

Borland StarTeam SDK for .NET

Server.EncryptionAlgorithm.RC2_ECB Property

public static Server.EncryptionAlgorithm RC2_ECB {get;}

Property Value

Use RC2 block cipher in Electronic Codebook mode.

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


RC4 Property

Borland StarTeam SDK for .NET

Server.EncryptionAlgorithm.RC4 Property

public static Server.EncryptionAlgorithm RC4 {get;}

Property Value

Use the RC4 stream cipher.

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


Server.EncryptionAlgorithm Methods

The methods of the Server.EncryptionAlgorithm class are listed below. For a complete list of Server.EncryptionAlgorithm class members, see the Server.EncryptionAlgorithm Members topic.

Public Static Methods

FromID | Gets the EncryptionAlgorithm value corresponding to the given ID.
MaxSecurity |

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Server.EncryptionAlgorithm.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Server.EncryptionAlgorithm.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Server.EncryptionAlgorithm.

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


Server.EncryptionAlgorithm.Equals Method

Delegate Equals() to com.starteam.Server.EncryptionAlgorithm.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Server.EncryptionAlgorithm.Equals(obj).

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


Server.EncryptionAlgorithm.FromID Method

Gets the EncryptionAlgorithm value corresponding to the given ID.

public static EncryptionAlgorithm FromID(
Int32 id
);

Parameters

id
The ID of an EncryptionAlgorithm value.

Return Value

The corresponding EncryptionAlgorithm value, or null.

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


Server.EncryptionAlgorithm.GetHashCode Method

Delegate GetHashCode() to com.starteam.Server.EncryptionAlgorithm.

public override int GetHashCode();

Return Value

com.starteam.Server.EncryptionAlgorithm.GetHashCode().

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


Server.EncryptionAlgorithm.MaxSecurity Method

public static EncryptionAlgorithm MaxSecurity(
Server.EncryptionAlgorithm algA,
Server.EncryptionAlgorithm algB
);

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


Server.EncryptionAlgorithm.ToString Method

Delegate ToString() to com.starteam.Server.EncryptionAlgorithm.

public override string ToString();

Return Value

com.starteam.Server.EncryptionAlgorithm.ToString()

See Also

Server.EncryptionAlgorithm Class | StarTeam Namespace


Server.ProductCode Class

This public final class defines constant values for the various StarTeam product codes.

For a list of all members of this type, see Server.ProductCode Members.

System.Object
Server.ProductCode

public class Server.ProductCode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Server.ProductCode Members | StarTeam Namespace


Server.ProductCode Members

Server.ProductCode overview

Public Static Properties

AGILE
ALL
ATLAS
CUSTOMIZATION
ELITE
ENTERPRISE
EXPRESS
MPX
REQUIREMENTS
STANDARD
STARDISK
TASKS

Public Static Methods

FromID Gets the Product code value corresponding to the given ID.

Public Instance Properties

ID [read]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Server.ProductCode.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.ProductCode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Server.ProductCode.

See Also

Server.ProductCode Class | StarTeam Namespace


Server.ProductCode Properties

The properties of the Server.ProductCode class are listed below. For a complete list of Server.ProductCode class members, see the Server.ProductCode Members topic.

Public Static Properties

AGILE
ALL
ATLAS
CUSTOMIZATION
ELITE
ENTERPRISE
EXPRESS
MPX
REQUIREMENTS
STANDARD
STARDISK
TASKS

Public Instance Properties

ID [read]

See Also

Server.ProductCode Class | StarTeam Namespace


AGILE Property

Borland StarTeam SDK for .NET

Server.ProductCode.AGILE Property

public static Server.ProductCode AGILE {get;}

Property Value

Agile

See Also

Server.ProductCode Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Server.ProductCode.ALL Property

public static ProductCode[] ALL {get;}

See Also

Server.ProductCode Class | StarTeam Namespace


ATLAS Property

Borland StarTeam SDK for .NET

Server.ProductCode.ATLAS Property

public static Server.ProductCode ATLAS {get;}

Property Value

Atlas

See Also

Server.ProductCode Class | StarTeam Namespace


CUSTOMIZATION Property

Borland StarTeam SDK for .NET

Server.ProductCode.CUSTOMIZATION Property

public static Server.ProductCode CUSTOMIZATION {get;}

Property Value

Customization.

See Also

Server.ProductCode Class | StarTeam Namespace


ELITE Property

Borland StarTeam SDK for .NET

Server.ProductCode.ELITE Property

public static Server.ProductCode ELITE {get;}

Property Value

StarTeam "Elite" (Enterprise Advantage)

See Also

Server.ProductCode Class | StarTeam Namespace


ENTERPRISE Property

Borland StarTeam SDK for .NET

Server.ProductCode.ENTERPRISE Property

public static Server.ProductCode ENTERPRISE {get;}

Property Value

The StarTeam "Enterprise" product.

See Also

Server.ProductCode Class | StarTeam Namespace


EXPRESS Property

Borland StarTeam SDK for .NET

Server.ProductCode.EXPRESS Property

public static Server.ProductCode EXPRESS {get;}

Property Value

Express

See Also

Server.ProductCode Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Server.ProductCode.ID Property

[read]

public virtual Int32 ID {get;}

See Also

Server.ProductCode Class | StarTeam Namespace


MPX Property

Borland StarTeam SDK for .NET

Server.ProductCode.MPX Property

public static Server.ProductCode MPX {get;}

Property Value

MPX

See Also

Server.ProductCode Class | StarTeam Namespace


REQUIREMENTS Property

Borland StarTeam SDK for .NET

Server.ProductCode.REQUIREMENTS Property

public static Server.ProductCode REQUIREMENTS {get;}

Property Value

Support for the "Requirement" component.

See Also

Server.ProductCode Class | StarTeam Namespace


STANDARD Property

Borland StarTeam SDK for .NET

Server.ProductCode.STANDARD Property

public static Server.ProductCode STANDARD {get;}

Property Value

The "Standard" StarTeam product.

See Also

Server.ProductCode Class | StarTeam Namespace


STARDISK Property

Borland StarTeam SDK for .NET

Server.ProductCode.STARDISK Property

public static Server.ProductCode STARDISK {get;}

Property Value

StarDisk

See Also

Server.ProductCode Class | StarTeam Namespace


TASKS Property

Borland StarTeam SDK for .NET

Server.ProductCode.TASKS Property

public static Server.ProductCode TASKS {get;}

Property Value

Support for the "Task" component.

See Also

Server.ProductCode Class | StarTeam Namespace


Server.ProductCode Methods

The methods of the Server.ProductCode class are listed below. For a complete list of Server.ProductCode class members, see the Server.ProductCode Members topic.

Public Static Methods

FromID Gets the Product code value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Server.ProductCode.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.ProductCode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Server.ProductCode.

See Also

Server.ProductCode Class | StarTeam Namespace


Server.ProductCode.Equals Method

Delegate Equals() to com.starteam.Server.ProductCode.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Server.ProductCode.Equals(obj).

See Also

Server.ProductCode Class | StarTeam Namespace


Server.ProductCode.FromID Method

Gets the Product code value corresponding to the given ID.

public static ProductCode FromID(
Int32 id
);

Parameters

id
The ID of an Product code value.

Return Value

The corresponding Product code value, or null.

See Also

Server.ProductCode Class | StarTeam Namespace


Server.ProductCode.GetHashCode Method

Delegate GetHashCode() to com.starteam.Server.ProductCode.

public override int GetHashCode();

Return Value

com.starteam.Server.ProductCode.GetHashCode().

See Also

Server.ProductCode Class | StarTeam Namespace


Server.ProductCode.ToString Method

Delegate ToString() to com.starteam.Server.ProductCode.

public override string ToString();

Return Value

com.starteam.Server.ProductCode.ToString()

See Also

Server.ProductCode Class | StarTeam Namespace


Server.Session Class

Represents a user's session with the server.

For a list of all members of this type, see Server.Session Members.

System.Object
Server.Session

public class Server.Session

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Server.Session Members | StarTeam Namespace


Server.Session Members

Server.Session overview

Public Instance Properties

ID | [read] GUID
User | [read] user

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Server.Session.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.Session.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Server.Session.

See Also

Server.Session Class | StarTeam Namespace


Server.Session Properties

The properties of the Server.Session class are listed below. For a complete list of Server.Session class members, see the Server.Session Members topic.

Public Instance Properties

ID | [read] GUID
User | [read] user

See Also

Server.Session Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Server.Session.ID Property

[read] GUID

public virtual GUID ID {get;}

Property Value

GUID

See Also

Server.Session Class | StarTeam Namespace


User Property

Borland StarTeam SDK for .NET

Server.Session.User Property

[read] user

public virtual User User {get;}

Property Value

user

See Also

Server.Session Class | StarTeam Namespace


Server.Session Methods

The methods of the Server.Session class are listed below. For a complete list of Server.Session class members, see the Server.Session Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Server.Session.
GetHashCode | Delegate GetHashCode() to com.starteam.Server.Session.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Server.Session.

See Also

Server.Session Class | StarTeam Namespace


Server.Session.Equals Method

Delegate Equals() to com.starteam.Server.Session.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Server.Session.Equals(obj).

See Also

Server.Session Class | StarTeam Namespace


Server.Session.GetHashCode Method

Delegate GetHashCode() to com.starteam.Server.Session.

public override int GetHashCode();

Return Value

com.starteam.Server.Session.GetHashCode().

See Also

Server.Session Class | StarTeam Namespace


Server.Session.ToString Method

Delegate ToString() to com.starteam.Server.Session.

public override string ToString();

Return Value

com.starteam.Server.Session.ToString()

See Also

Server.Session Class | StarTeam Namespace


Server.WebCacheServer Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see Server.WebCacheServer Members.

System.Object
Server.WebCacheServer

public class Server.WebCacheServer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Server.WebCacheServer Members | StarTeam Namespace


Server.WebCacheServer Members

Server.WebCacheServer overview

Public Static Methods

DeclareWebCacheDefinitions |
EncryptPassword | Encrypt the specified clear text password. Return the encrypted results

Public Instance Properties

Address | [read] string representing the network address
AdministratorsGroup | [read] "Administrators" group on this server.
AllLoggedOnUsers | [read] all the users currently logged into this cache manager
AllUsersGroup | [read] "AllUsers" group on this server.
Configuration | [read] the Server Configuration options for this server
Context | [read] the context of this object.
CurrentTime | [read] The current server time
Groups | [read] All of the groups on this server.
InactivityTimeout | [read] the inactivity timeout for the server
IsConnected | [read] true if a network connection to the StarTeam server has been established.
IsMPXAvailable | [read] true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).
IsMPXEnabled | [read] true if MPX has been enabled for this server, false otherwise.
IsMPXResponding | [read] true if the MPX server is running properly, and false otherwise.
IsSingleSignOnAuthenticationEnabled | [read] true if Single Sign-On Authentication has been enabled on the StarTeam server, false otherwise.
LicenseInformation | [read] Information about the licenses registered on this server, or null if the license information is not available.
LoggedInUser | [read] The user object of the logged in user, or null if no one has logged in. The logged in user is the Administrator in whose context this artifact cache has been loaded up.
Oauth2IssuerURL | [read] Oauth2 provider Issuer URL or null.
Oauth2RedirectURI | [read] Oauth2 Redirect URI or null.
Port | [read] server's TCP/IP port
Projects | [read] the set of projects accessible by this User
RepositoryID | [read] com.starteam.util.GUID
ServerBuild | [read] The server build number.
ServerInfo | [read] A copy of serverInfo object used to construct this server session
SystemPolicy | [read] the System Policy rules set for this server
Types | [read] a collection of Types instances
Users | [read] the set of all users cached by this ArtifactCacheManager

Public Instance Methods

CanCreateCheckinChangePackages | Returns true if the server supports creating Change Packages on File Checkin This server configuration setting has been in force since the 12.5 server release. With this setting turned OFF, Change Packages are not created for checkin Additionally, old style links are created between files and process items, if any
ChangePassword | Change the user's password
CreateType | create a custom component (a new type) on the server. Support for Custom Components has been introduced in the 12.0 release
Equals | Delegate Equals() to com.starteam.Server.WebCacheServer.
FindGroup | Overloaded. return an accessible group on this server or NULL
FindPrincipal | return an accessible principal (user or group) on this server or NULL
FindProject | Overloaded. return an accessible Project on this server or NULL Note that accessible projects need not yet have been cached in the artifact cache However, if it has been cached ,and is accessible, the cached project will be returned
FindType | Overloaded. return an accessible type on this server or NULL
FindUser | Overloaded. return an accessible user on this server or NULL
GetCRStatus |
GetHashCode | Delegate GetHashCode() to com.starteam.Server.WebCacheServer.
GetStatus |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUDAGroupings |
GetVisibleProperties | Return the subset of properties that are visible in the context of the specified Enumerated Value
HasSavedCRStatus |
HasSavedStatus |
IsCached | Returns true if the project has been cached in the ArtifactCache and is visible in this user context. Note that projects cached in the ArtifactCache need not be visible in the context of a user without the appropriate access rights. In other words, it is possible for this api to return true in the administrator context, but false in an unauthorized user context
IsLoggedOn |
Logoff |
Logon | Overloaded. Logon a User with a specified user name and password, return the User Object or throw a logon exception If the logon is successful, consume a license for this user This api may only be used for logging in users in on-premise systems or for logging in additional global administrators in the hosted system's global cache.
NewWebCacheAccessRightsEventSource |
NewWebCacheGroupEventSource |
NewWebCacheLiveObjectEventSource |
NewWebCacheProjectEventSource |
NewWebCacheTypeEventSource |
NewWebCacheUserEventSource |
Oauth2logon | Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied Oauth2 Authorization code.
Ping | Verifies that the server is responding and informs the server that this connection/user session is still active. This method is expensive. It issues an immediate network command to the starteam server.
RemoveAccessRightsListener | remove the registered access rights listener
RemoveLightWeightListener | Removes the listener for lightweight LiveObject events.
SendMail |
SetCRStatus |
SetStatus |
SetUDAGroupings |
SetVisibleProperties |
SupportsInfoStreamCRStatus | Returns true if the server supports setting CR Status when the Story Status Changes
SupportsTraceVersioning |
Synchronize | Add or release a set of keys, i.e. acquire a lock for these named keys The server will synchronize access to an internal hash table across any/all threads which attempt key acquisitions. The first thread wins and acquires the key all subsequent threads lose and a server exception will be thrown If this method fails, a server exception will be thrown Well behaved applications that acquire a locked key should release it as quickly as possible
ToString | Delegate ToString() to com.starteam.Server.WebCacheServer.
ValidateClient |

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer Properties

The properties of the Server.WebCacheServer class are listed below. For a complete list of Server.WebCacheServer class members, see the Server.WebCacheServer Members topic.

Public Instance Properties

Address | [read] string representing the network address
AdministratorsGroup | [read] "Administrators" group on this server.
AllLoggedOnUsers | [read] all the users currently logged into this cache manager
AllUsersGroup | [read] "AllUsers" group on this server.
Configuration | [read] the Server Configuration options for this server
Context | [read] the context of this object.
CurrentTime | [read] The current server time
Groups | [read] All of the groups on this server.
InactivityTimeout | [read] the inactivity timeout for the server
IsConnected | [read] true if a network connection to the StarTeam server has been established.
IsMPXAvailable | [read] true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).
IsMPXEnabled | [read] true if MPX has been enabled for this server, false otherwise.
IsMPXResponding | [read] true if the MPX server is running properly, and false otherwise.
IsSingleSignOnAuthenticationEnabled | [read] true if Single Sign-On Authentication has been enabled on the StarTeam server, false otherwise.
LicenseInformation | [read] Information about the licenses registered on this server, or null if the license information is not available.
LoggedInUser | [read] The user object of the logged in user, or null if no one has logged in. The logged in user is the Administrator in whose context this artifact cache has been loaded up.
Oauth2IssuerURL | [read] Oauth2 provider Issuer URL or null.
Oauth2RedirectURI | [read] Oauth2 Redirect URI or null.
Port | [read] server's TCP/IP port
Projects | [read] the set of projects accessible by this User
RepositoryID | [read] com.starteam.util.GUID
ServerBuild | [read] The server build number.
ServerInfo | [read] A copy of serverInfo object used to construct this server session
SystemPolicy | [read] the System Policy rules set for this server
Types | [read] a collection of Types instances
Users | [read] the set of all users cached by this ArtifactCacheManager

See Also

Server.WebCacheServer Class | StarTeam Namespace


Address Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Address Property

[read] string representing the network address

public virtual String Address {get;}

Property Value

string representing the network address

See Also

Server.WebCacheServer Class | StarTeam Namespace


AdministratorsGroup Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.AdministratorsGroup Property

[read] "Administrators" group on this server.

public virtual Group.WebCacheGroup AdministratorsGroup {get;}

Property Value

"Administrators" group on this server.

See Also

Server.WebCacheServer Class | StarTeam Namespace


AllLoggedOnUsers Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.AllLoggedOnUsers Property

[read] all the users currently logged into this cache manager

public virtual WebCacheUser[] AllLoggedOnUsers {get;}

Property Value

all the users currently logged into this cache manager

See Also

Server.WebCacheServer Class | StarTeam Namespace


AllUsersGroup Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.AllUsersGroup Property

[read] "AllUsers" group on this server.

public virtual Group.WebCacheGroup AllUsersGroup {get;}

Property Value

"AllUsers" group on this server.

See Also

Server.WebCacheServer Class | StarTeam Namespace


Configuration Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Configuration Property

[read] the Server Configuration options for this server

public virtual ServerConfiguration.WebCacheServerConfiguration Configuration {get;}

Property Value

the Server Configuration options for this server

See Also

Server.WebCacheServer Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Context Property

[read] the context of this object.

public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Server.WebCacheServer Class | StarTeam Namespace


CurrentTime Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.CurrentTime Property

[read] The current server time

public virtual DateTime CurrentTime {get;}

Property Value

The current server time

See Also

Server.WebCacheServer Class | StarTeam Namespace


Groups Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Groups Property

[read] All of the groups on this server.

public virtual WebCacheGroup[] Groups {get;}

Property Value

All of the groups on this server.

See Also

Server.WebCacheServer Class | StarTeam Namespace


InactivityTimeout Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.InactivityTimeout Property

[read] the inactivity timeout for the server

public virtual Int64 InactivityTimeout {get;}

Property Value

the inactivity timeout for the server

See Also

Server.WebCacheServer Class | StarTeam Namespace


IsConnected Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.IsConnected Property

[read] true if a network connection to the StarTeam server has been established.

public virtual Boolean IsConnected {get;}

Property Value

true if a network connection to the StarTeam server has been established.

See Also

Server.WebCacheServer Class | StarTeam Namespace


IsMPXAvailable Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.IsMPXAvailable Property

[read] true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).

public virtual Boolean IsMPXAvailable {get;}

Property Value

true if MPX is installed on this server, and false otherwise. Note that if MPX is installed, that does not necessarily mean that you can successfully enable MPX (for example, the Message Broker might not be running).

See Also

Server.WebCacheServer Class | StarTeam Namespace


IsMPXEnabled Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.IsMPXEnabled Property

[read] true if MPX has been enabled for this server, false otherwise.

public virtual Boolean IsMPXEnabled {get;}

Property Value

true if MPX has been enabled for this server, false otherwise.

See Also

Server.WebCacheServer Class | StarTeam Namespace


IsMPXResponding Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.IsMPXResponding Property

[read] true if the MPX server is running properly, and false otherwise.

public virtual Boolean IsMPXResponding {get;}

Property Value

true if the MPX server is running properly, and false otherwise.

See Also

Server.WebCacheServer Class | StarTeam Namespace


IsSingleSignOnAuthenticationEnabled Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.IsSingleSignOnAuthenticationEnabled Property

[read] true if Single Sign-On Authentication has been enabled on the StarTeam server, false otherwise.

public virtual Boolean IsSingleSignOnAuthenticationEnabled {get;}

Property Value

true if Single Sign-On Authentication has been enabled on the StarTeam server, false otherwise.

See Also

Server.WebCacheServer Class | StarTeam Namespace


LicenseInformation Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.LicenseInformation Property

[read] Information about the licenses registered on this server, or null if the license information is not available.

public virtual ServerAdministration.License LicenseInformation {get;}

Property Value

Information about the licenses registered on this server, or null if the license information is not available.

See Also

Server.WebCacheServer Class | StarTeam Namespace


LoggedInUser Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.LoggedInUser Property

[read] The user object of the logged in user, or null if no one has logged in. The logged in user is the Administrator in whose context this artifact cache has been loaded up.

public virtual User.WebCacheUser LoggedInUser {get;}

Property Value

The user object of the logged in user, or null if no one has logged in. The logged in user is the Administrator in whose context this artifact cache has been loaded up.

See Also

Server.WebCacheServer Class | StarTeam Namespace


Oauth2IssuerURL Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Oauth2IssuerURL Property

[read] Oauth2 provider Issuer URL or null.

public virtual String Oauth2IssuerURL {get;}

Property Value

Oauth2 provider Issuer URL or null.

See Also

Server.WebCacheServer Class | StarTeam Namespace


Oauth2RedirectURI Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Oauth2RedirectURI Property

[read] Oauth2 Redirect URI or null.

public virtual String Oauth2RedirectURI {get;}

Property Value

Oauth2 Redirect URI or null.

See Also

Server.WebCacheServer Class | StarTeam Namespace


Port Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Port Property

[read] server's TCP/IP port

public virtual Int32 Port {get;}

Property Value

server's TCP/IP port

See Also

Server.WebCacheServer Class | StarTeam Namespace


Projects Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Projects Property

[read] the set of projects accessible by this User

public virtual WebCacheProject[] Projects {get;}

Property Value

the set of projects accessible by this User

See Also

Server.WebCacheServer Class | StarTeam Namespace


RepositoryID Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.RepositoryID Property

[read] com.starteam.util.GUID

public virtual GUID RepositoryID {get;}

Property Value

com.starteam.util.GUID

See Also

Server.WebCacheServer Class | StarTeam Namespace


ServerBuild Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.ServerBuild Property

[read] The server build number.

public virtual String ServerBuild {get;}

Property Value

The server build number.

See Also

Server.WebCacheServer Class | StarTeam Namespace


ServerInfo Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.ServerInfo Property

[read] A copy of serverInfo object used to construct this server session

public virtual ServerInfo ServerInfo {get;}

Property Value

A copy of serverInfo object used to construct this server session

See Also

Server.WebCacheServer Class | StarTeam Namespace


SystemPolicy Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.SystemPolicy Property

[read] the System Policy rules set for this server

public virtual SystemPolicy.WebCacheSystemPolicy SystemPolicy {get;}

Property Value

the System Policy rules set for this server

See Also

Server.WebCacheServer Class | StarTeam Namespace


Types Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Types Property

[read] a collection of Types instances

public virtual WebCacheType[] Types {get;}

Property Value

a collection of Types instances

See Also

Server.WebCacheServer Class | StarTeam Namespace


Users Property

Borland StarTeam SDK for .NET

Server.WebCacheServer.Users Property

[read] the set of all users cached by this ArtifactCacheManager

public virtual WebCacheUser[] Users {get;}

Property Value

the set of all users cached by this ArtifactCacheManager

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer Methods

The methods of the Server.WebCacheServer class are listed below. For a complete list of Server.WebCacheServer class members, see the Server.WebCacheServer Members topic.

Public Static Methods

DeclareWebCacheDefinitions |
EncryptPassword | Encrypt the specified clear text password. Return the encrypted results

Public Instance Methods

CanCreateCheckinChangePackages | Returns true if the server supports creating Change Packages on File Checkin This server configuration setting has been in force since the 12.5 server release. With this setting turned OFF, Change Packages are not created for checkin Additionally, old style links are created between files and process items, if any
ChangePassword | Change the user's password
CreateType | create a custom component (a new type) on the server. Support for Custom Components has been introduced in the 12.0 release
Equals | Delegate Equals() to com.starteam.Server.WebCacheServer.
FindGroup | Overloaded. return an accessible group on this server or NULL
FindPrincipal | return an accessible principal (user or group) on this server or NULL
FindProject | Overloaded. return an accessible Project on this server or NULL Note that accessible projects need not yet have been cached in the artifact cache However, if it has been cached ,and is accessible, the cached project will be returned
FindType | Overloaded. return an accessible type on this server or NULL
FindUser | Overloaded. return an accessible user on this server or NULL
GetCRStatus |
GetHashCode | Delegate GetHashCode() to com.starteam.Server.WebCacheServer.
GetStatus |
GetType (inherited from Object) | Gets the Type of the current instance.
GetUDAGroupings |
GetVisibleProperties | Return the subset of properties that are visible in the context of the specified Enumerated Value
HasSavedCRStatus |
HasSavedStatus |
IsCached | Returns true if the project has been cached in the ArtifactCache and is visible in this user context. Note that projects cached in the ArtifactCache need not be visible in the context of a user without the appropriate access rights. In other words, it is possible for this api to return true in the administrator context, but false in an unauthorized user context
IsLoggedOn |
Logoff |
Logon | Overloaded. Logon a User with a specified user name and password, return the User Object or throw a logon exception If the logon is successful, consume a license for this user This api may only be used for logging in users in on-premise systems or for logging in additional global administrators in the hosted system's global cache.
NewWebCacheAccessRightsEventSource |
NewWebCacheGroupEventSource |
NewWebCacheLiveObjectEventSource |
NewWebCacheProjectEventSource |
NewWebCacheTypeEventSource |
NewWebCacheUserEventSource |
Oauth2logon | Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied Oauth2 Authorization code.
Ping | Verifies that the server is responding and informs the server that this connection/user session is still active. This method is expensive. It issues an immediate network command to the starteam server.
RemoveAccessRightsListener | remove the registered access rights listener
RemoveLightWeightListener | Removes the listener for lightweight LiveObject events.
SendMail |
SetCRStatus |
SetStatus |
SetUDAGroupings |
SetVisibleProperties |
SupportsInfoStreamCRStatus | Returns true if the server supports setting CR Status when the Story Status Changes
SupportsTraceVersioning |
Synchronize | Add or release a set of keys, i.e. acquire a lock for these named keys The server will synchronize access to an internal hash table across any/all threads which attempt key acquisitions. The first thread wins and acquires the key all subsequent threads lose and a server exception will be thrown If this method fails, a server exception will be thrown Well behaved applications that acquire a locked key should release it as quickly as possible
ToString | Delegate ToString() to com.starteam.Server.WebCacheServer.
ValidateClient |

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.CanCreateCheckinChangePackages Method

Returns true if the server supports creating Change Packages on File Checkin This server configuration setting has been in force since the 12.5 server release. With this setting turned OFF, Change Packages are not created for checkin Additionally, old style links are created between files and process items, if any

public virtual bool CanCreateCheckinChangePackages();

Return Value

true if the server supports creating Change Packages on File Checkin, false otherwise

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.ChangePassword Method

Change the user's password

public virtual WebCacheUser ChangePassword(
String logonName,
String oldPassword,
String newPassword
);

Parameters

logonName
the user whose password is being changed
oldPassword
the old password
newPassword
the new password

Return Value

the user object, logged on with the new password

See Also

Server.WebCacheServer Class | StarTeam Namespace | changePassword


Server.WebCacheServer.CreateType Method

create a custom component (a new type) on the server. Support for Custom Components has been introduced in the 12.0 release

public virtual WebCacheItemType CreateType(
String xmlDefinition,
Boolean toCreate
);

Parameters

xmlDefinition
the xml definition describing the schema of the new Type
toCreate
true to create the Component, false to verify the schema

Return Value

the Type matching the component definition or NULL if the schema is being verified

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.DeclareWebCacheDefinitions Method

public static void DeclareWebCacheDefinitions(
String typeName,
String propertyName,
Type[] clazz
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.EncryptPassword Method

Encrypt the specified clear text password. Return the encrypted results

public static byte[] EncryptPassword(
String password
);

Parameters

password
the clear text password

Return Value

the encrypted result

See Also

Server.WebCacheServer Class | StarTeam Namespace | CommandProcessor


Server.WebCacheServer.Equals Method

Delegate Equals() to com.starteam.Server.WebCacheServer.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Server.WebCacheServer.Equals(obj).

See Also

Server.WebCacheServer Class | StarTeam Namespace


FindGroup Method

Borland StarTeam SDK for .NET

Server.WebCacheServer.FindGroup Method

return an accessible group on this server or NULL

Overload List

return an accessible group on this server or NULL

public virtual WebCacheGroup FindGroup(Int32);

return an accessible group on this server or NULL

public virtual WebCacheGroup FindGroup(String);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.FindGroup Method (Int32)

return an accessible group on this server or NULL

public virtual WebCacheGroup FindGroup(
Int32 groupID
);

Parameters

groupID
the id of the group

Return Value

an accessible Group on this server or NULL

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.FindGroup Overload List


Server.WebCacheServer.FindGroup Method (String)

return an accessible group on this server or NULL

public virtual WebCacheGroup FindGroup(
String groupName
);

Parameters

groupName
the case sensitive name of the group

Return Value

an accessible group on this server, or NULL

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.FindGroup Overload List


Server.WebCacheServer.FindPrincipal Method

return an accessible principal (user or group) on this server or NULL

public virtual WebCachePrincipal FindPrincipal(
Int32 principalID
);

Parameters

principalID
the id of the principal

Return Value

an accessible Principal on this server or NULL

See Also

Server.WebCacheServer Class | StarTeam Namespace


FindProject Method

Borland StarTeam SDK for .NET

Server.WebCacheServer.FindProject Method

return an accessible Project on this server or NULL Note that accessible projects need not yet have been cached in the artifact cache However, if it has been cached ,and is accessible, the cached project will be returned

Overload List

return an accessible Project on this server or NULL Note that accessible projects need not yet have been cached in the artifact cache However, if it has been cached ,and is accessible, the cached project will be returned

public virtual WebCacheProject FindProject(Int32);

return an accessible Project on this server or NULL Note that accessible projects need not yet have been cached in the artifact cache However, if it has been cached ,and is accessible, the cached project will be returned

public virtual WebCacheProject FindProject(String);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.FindProject Method (Int32)

return an accessible Project on this server or NULL Note that accessible projects need not yet have been cached in the artifact cache However, if it has been cached ,and is accessible, the cached project will be returned

public virtual WebCacheProject FindProject(
Int32 projectID
);

Parameters

projectID
the id of the project

Return Value

an accessible Project on this server or NULL

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.FindProject Overload List


Server.WebCacheServer.FindProject Method (String)

return an accessible Project on this server or NULL Note that accessible projects need not yet have been cached in the artifact cache However, if it has been cached ,and is accessible, the cached project will be returned

public virtual WebCacheProject FindProject(
String projectName
);

Parameters

projectName
the name of the project

Return Value

an accessible Project on this server or NULL

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.FindProject Overload List


FindType Method

Borland StarTeam SDK for .NET

Server.WebCacheServer.FindType Method

return an accessible type on this server or NULL

Overload List

return an accessible type on this server or NULL

public virtual WebCacheType FindType(Int32);

return an accessible type on this server or NULL

public virtual WebCacheType FindType(String);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.FindType Method (Int32)

return an accessible type on this server or NULL

public virtual WebCacheType FindType(
Int32 typeID
);

Parameters

typeID
the id of the type

Return Value

an accessible Type on this server or NULL

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.FindType Overload List


Server.WebCacheServer.FindType Method (String)

return an accessible type on this server or NULL

public virtual WebCacheType FindType(
String typeName
);

Parameters

typeName
the name of the type

Return Value

an accessible Type on this server or NULL

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.FindType Overload List


FindUser Method

Borland StarTeam SDK for .NET

Server.WebCacheServer.FindUser Method

return an accessible user on this server or NULL

Overload List

return an accessible user on this server or NULL

public virtual WebCacheUser FindUser(Int32);

return an accessible user on this server or NULL

public virtual WebCacheUser FindUser(String);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.FindUser Method (Int32)

return an accessible user on this server or NULL

public virtual WebCacheUser FindUser(
Int32 userID
);

Parameters

userID
the id of the user

Return Value

an accessible User on this server or NULL

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.FindUser Overload List


Server.WebCacheServer.FindUser Method (String)

return an accessible user on this server or NULL

public virtual WebCacheUser FindUser(
String logonName
);

Parameters

logonName
the case sensitive logon name of the user note that user.logonName is not the same as user.name

Return Value

an accessible user on this server, or NULL

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.FindUser Overload List


Server.WebCacheServer.GetCRStatus Method

public virtual EnumeratedValue GetCRStatus(
Story.Status sts
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.GetHashCode Method

Delegate GetHashCode() to com.starteam.Server.WebCacheServer.

public override int GetHashCode();

Return Value

com.starteam.Server.WebCacheServer.GetHashCode().

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.GetStatus Method

public virtual Status[] GetStatus(
Story.Status sts
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.GetUDAGroupings Method

public virtual EnumeratedValue[] GetUDAGroupings(
Requirement.RequirementType typ
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.GetVisibleProperties Method

Return the subset of properties that are visible in the context of the specified Enumerated Value

public virtual WebCacheProperty[] GetVisibleProperties(
EnumeratedValue value
);

Parameters

value
an Enumerated Value for a specific Enumerated Property of a chosen type

Return Value

the subset of properties of the same Type that are marked visible in the context of this enum

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.HasSavedCRStatus Method

public virtual bool HasSavedCRStatus(
Story.Status sts
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.HasSavedStatus Method

public virtual bool HasSavedStatus(
Story.Status sts
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.IsCached Method

Returns true if the project has been cached in the ArtifactCache and is visible in this user context. Note that projects cached in the ArtifactCache need not be visible in the context of a user without the appropriate access rights. In other words, it is possible for this api to return true in the administrator context, but false in an unauthorized user context

public virtual bool IsCached(
Int32 projectID
);

Parameters

projectID
the project to check for

Return Value

true if the project is cached in the Artifact Cache

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.IsLoggedOn Method

public virtual bool IsLoggedOn(
User.WebCacheUser u
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.Logoff Method

public virtual void Logoff(
User.WebCacheUser u
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Logon Method

Borland StarTeam SDK for .NET

Server.WebCacheServer.Logon Method

Logon a User with a specified user name and password, return the User Object or throw a logon exception If the logon is successful, consume a license for this user This api may only be used for logging in users in on-premise systems or for logging in additional global administrators in the hosted system's global cache.

Overload List

Logon a User with a specified user name and password, return the User Object or throw a logon exception If the logon is successful, consume a license for this user This api may only be used for logging in users in on-premise systems or for logging in additional global administrators in the hosted system's global cache.

public virtual WebCacheUser Logon(String,String);

Logon a Tenant User with a specified user name, return the User Object or throw a logon exception If the logon is successful, consume a license for this user

public virtual WebCacheUser Logon(String,String,String);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.Logon Method (String, String)

Logon a User with a specified user name and password, return the User Object or throw a logon exception If the logon is successful, consume a license for this user This api may only be used for logging in users in on-premise systems or for logging in additional global administrators in the hosted system's global cache.

public virtual WebCacheUser Logon(
String logonUserName,
String password
);

Parameters

logonUserName
The logon user name
password
the password to use for logging on

Return Value

a User object if the logon is successful

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.Logon Overload List


Server.WebCacheServer.Logon Method (String, String, String)

Logon a Tenant User with a specified user name, return the User Object or throw a logon exception If the logon is successful, consume a license for this user

public virtual WebCacheUser Logon(
String globalUserName,
String globalUserPassword,
String tenantUserName
);

Parameters

globalUserName
globalUserPassword
The global logon administrator password
tenantUserName
The tenant user to be logged on. Note that in the hosted context, the tenant user has already been authenticated via the login portal Logging in the user through the artifact cache is a separate requirement of the web application

Return Value

a User object if the logon is successful

See Also

Server.WebCacheServer Class | StarTeam Namespace | Server.WebCacheServer.Logon Overload List


Server.WebCacheServer.NewWebCacheAccessRightsEventSource Method

public WebCacheAccessRightsEventSource NewWebCacheAccessRightsEventSource();

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.NewWebCacheGroupEventSource Method

public WebCacheGroupEventSource NewWebCacheGroupEventSource();

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.NewWebCacheLiveObjectEventSource Method

public WebCacheLiveObjectEventSource NewWebCacheLiveObjectEventSource();

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.NewWebCacheProjectEventSource Method

public WebCacheProjectEventSource NewWebCacheProjectEventSource();

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.NewWebCacheTypeEventSource Method

public WebCacheTypeEventSource NewWebCacheTypeEventSource();

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.NewWebCacheUserEventSource Method

public WebCacheUserEventSource NewWebCacheUserEventSource();

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.Oauth2logon Method

Establishes a user-session with the remote server process. All subsequent user operations will be performed within the constraints of the privileges associated with the supplied Oauth2 Authorization code.

public virtual WebCacheUser Oauth2logon(
String oauth2AuthorizationCode,
String oauth2RedirectURI
);

Parameters

oauth2AuthorizationCode
oauth2RedirectURI

Return Value

the logged on user

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.Ping Method

Verifies that the server is responding and informs the server that this connection/user session is still active. This method is expensive. It issues an immediate network command to the starteam server.

public virtual bool Ping();

Return Value

true if the server responds, false if the server fails to respond for any reason, including not being connected

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.RemoveAccessRightsListener Method

remove the registered access rights listener

public virtual void RemoveAccessRightsListener();

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.RemoveLightWeightListener Method

Removes the listener for lightweight LiveObject events.

public virtual void RemoveLightWeightListener();

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.SendMail Method

public virtual void SendMail(
View.WebCacheView view,
WebCacheUser[] to,
WebCacheUser[] cc,
WebCacheUser[] bcc,
String subject,
String body,
EmailAttachment[] attachments
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.SetCRStatus Method

public virtual void SetCRStatus(
Story.Status rfrnc,
EnumeratedValue trgt
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.SetStatus Method

public virtual void SetStatus(
Story.Status rfrnc,
Status[] mppdSts
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.SetUDAGroupings Method

public virtual void SetUDAGroupings(
Requirement.RequirementType typ,
EnumeratedValue[] udas
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.SetVisibleProperties Method

public virtual void SetVisibleProperties(
EnumeratedValue value,
WebCacheProperty[] properties
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.SupportsInfoStreamCRStatus Method

Returns true if the server supports setting CR Status when the Story Status Changes

public virtual bool SupportsInfoStreamCRStatus();

Return Value

true if the server supports setting CR Status when the Story Status Changes

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.SupportsTraceVersioning Method

public virtual bool SupportsTraceVersioning(
Item.Type.WebCacheItemType typ
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.Synchronize Method

Add or release a set of keys, i.e. acquire a lock for these named keys The server will synchronize access to an internal hash table across any/all threads which attempt key acquisitions. The first thread wins and acquires the key all subsequent threads lose and a server exception will be thrown If this method fails, a server exception will be thrown Well behaved applications that acquire a locked key should release it as quickly as possible

public virtual void Synchronize(
String[] keys,
Boolean acquire
);

Parameters

keys
the keys to be acquired or released
acquire
true to acquire the keys, false to release them

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.ToString Method

Delegate ToString() to com.starteam.Server.WebCacheServer.

public override string ToString();

Return Value

com.starteam.Server.WebCacheServer.ToString()

See Also

Server.WebCacheServer Class | StarTeam Namespace


Server.WebCacheServer.ValidateClient Method

public virtual bool ValidateClient(
GUID clientGuid,
User.WebCacheUser user
);

See Also

Server.WebCacheServer Class | StarTeam Namespace


ServerAdministration Class

The ServerAdministration class provides a convenient interface to perform various server level administration commands. The current set of operations are for field customization. Ultimately these methods should hang off of the core Type and Property objects but the refresh issues are too complex to deal with at this time. After calling any of the customization methods one should do a FULL refresh by discarding everything including the Server object itself and start over.

For a list of all members of this type, see ServerAdministration Members.

System.Object
ServerAdministration

public class ServerAdministration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration Members | StarTeam Namespace


ServerAdministration Members

ServerAdministration overview

Public Instance Properties

Configuration | [read/write] The current server configuration options.
Groups | [read] all of the active group accounts on the server.
HiveManager | [read] the HiveManager.
IsRefreshRequired | [read] true if account information may be out of date.
LicenseInformation | [read] Information about the licenses registered on this server, or null if the license information is not available.
Log | [read] the server log.
Policy | [read/write] The current system policy options.
PurgeController | [read] PurgeControl
Rights | [read/write] the access control list for this server or NULL.
Server | [read] a reference to the Server
ServerLockStatus | [read] the "locked", "locked exclusively" or "unlocked" status of the server.
Users | [read] all of the active user accounts on the server.

Public Instance Methods

Discard | Discards all cached UserAccount and GroupAccount information. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ServerAdministration.
FindGroup | Overloaded. Returns the Group object for the given ID.
FindUser | Overloaded. Returns the User object with the given logonName. The user returned will contain all the account information. Returns null if logonName is not found.
GenerateDiagnosticDump | Creates a diagnostic file and places it in the server configurations' log path. While creating the file, the server does no other processing This may take several minutes Use only at the direction of Borland Technical Support. Throws an SDKRuntimeException if the call fails
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.
GetNamedConfigOptions | Return a String array of values that matches the input String array of option names. This method is supported by server release 6.0 and later; ignored for earlier releases.
GetSecurityLog |
GetServerCommandStats |
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermissions | Returns true if desired permissions are granted
LockServer | Puts the server in "Locked" mode. No one can perform operations. Useful for freezing server for database backups.
LockServerExclusively | Puts the server in "LockedExclusively" mode: only the locker can perform operations. Useful for restricting server access during replication operations.
PopulateGroupMembershipForAllUsers | A single server command to populate the group membership for all active users on this server. Logged in user requires administrator privileges to execute this command This command is available only for server release 12.0 or after
Refresh | Updates cached Users and Groups account information to reflect recent changes to the repository. Existing UserAccount and GroupAccount objects are modified in place whenever possible.
RestartServer | Shuts down and restarts the server. This has the side-effect of making the associated Server instance rather useless as the StarTeam Server it was connected to will be shut down and restarted.
SetNamedConfigOptions | Set a group of named configuration options. This method is supported by server release 6.0 and later; ignored for earlier releases.
ShutdownServer | Shuts down the server. This has the obvious side-effect of making the associated Server instance rather useless, as the StarTeam Server it was connected to will be shut down.
TestDirectoryServiceSettings |
TestOauth2ProviderSettings | Tests is the given Oauth2 issuer URL is valid.
TestSMTPSettings |
ToString | Delegate ToString() to com.starteam.ServerAdministration.
TreatMixedEOLFileContentAsBinary | True if MixedEOL content should be treated as BINARY files This is a CAE use case and has associated rules which require all EOL computation to be contained entirely within the SDK.
UnlockServer | Unlocks a server in "Locked" mode.
WriteLogFile | Overloaded.
WriteServerCommandStats | Retrieves the server's command statistics and writes it to the specified file.

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration Properties

The properties of the ServerAdministration class are listed below. For a complete list of ServerAdministration class members, see the ServerAdministration Members topic.

Public Instance Properties

Configuration | [read/write] The current server configuration options.
Groups | [read] all of the active group accounts on the server.
HiveManager | [read] the HiveManager.
IsRefreshRequired | [read] true if account information may be out of date.
LicenseInformation | [read] Information about the licenses registered on this server, or null if the license information is not available.
Log | [read] the server log.
Policy | [read/write] The current system policy options.
PurgeController | [read] PurgeControl
Rights | [read/write] the access control list for this server or NULL.
Server | [read] a reference to the Server
ServerLockStatus | [read] the "locked", "locked exclusively" or "unlocked" status of the server.
Users | [read] all of the active user accounts on the server.

See Also

ServerAdministration Class | StarTeam Namespace


Configuration Property

Borland StarTeam SDK for .NET

ServerAdministration.Configuration Property

[read/write] The current server configuration options.

public virtual ServerConfiguration Configuration {get; set;}

Property Value

The current server configuration options.

See Also

ServerAdministration Class | StarTeam Namespace


Groups Property

Borland StarTeam SDK for .NET

ServerAdministration.Groups Property

[read] all of the active group accounts on the server.

public virtual Group[] Groups {get;}

Property Value

all of the active group accounts on the server.

See Also

ServerAdministration Class | StarTeam Namespace


HiveManager Property

Borland StarTeam SDK for .NET

ServerAdministration.HiveManager Property

[read] the HiveManager.

public virtual HiveManager HiveManager {get;}

Property Value

the HiveManager.

See Also

ServerAdministration Class | StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

ServerAdministration.IsRefreshRequired Property

[read] true if account information may be out of date.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if account information may be out of date.

See Also

ServerAdministration Class | StarTeam Namespace


LicenseInformation Property

Borland StarTeam SDK for .NET

ServerAdministration.LicenseInformation Property

[read] Information about the licenses registered on this server, or null if the license information is not available.

public virtual ServerAdministration.License LicenseInformation {get;}

Property Value

Information about the licenses registered on this server, or null if the license information is not available.

See Also

ServerAdministration Class | StarTeam Namespace


Log Property

Borland StarTeam SDK for .NET

ServerAdministration.Log Property

[read] the server log.

public virtual String Log {get;}

Property Value

the server log.

See Also

ServerAdministration Class | StarTeam Namespace


Policy Property

Borland StarTeam SDK for .NET

ServerAdministration.Policy Property

[read/write] The current system policy options.

public virtual SystemPolicy Policy {get; set;}

Property Value

The current system policy options.

See Also

ServerAdministration Class | StarTeam Namespace


PurgeController Property

Borland StarTeam SDK for .NET

ServerAdministration.PurgeController Property

[read] PurgeControl

public virtual PurgeController PurgeController {get;}

Property Value

PurgeControl

See Also

ServerAdministration Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

ServerAdministration.Rights Property

[read/write] the access control list for this server or NULL.

public virtual ACE[] Rights {get; set;}

Property Value

the access control list for this server or NULL.

See Also

ServerAdministration Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ServerAdministration.Server Property

[read] a reference to the Server

public virtual Server Server {get;}

Property Value

a reference to the Server

See Also

ServerAdministration Class | StarTeam Namespace


ServerLockStatus Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLockStatus Property

[read] the "locked", "locked exclusively" or "unlocked" status of the server.

public virtual ServerAdministration.LockStatus ServerLockStatus {get;}

Property Value

the "locked", "locked exclusively" or "unlocked" status of the server.

See Also

ServerAdministration Class | StarTeam Namespace


Users Property

Borland StarTeam SDK for .NET

ServerAdministration.Users Property

[read] all of the active user accounts on the server.

public virtual User[] Users {get;}

Property Value

all of the active user accounts on the server.

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration Methods

The methods of the ServerAdministration class are listed below. For a complete list of ServerAdministration class members, see the ServerAdministration Members topic.

Public Instance Methods

Discard | Discards all cached UserAccount and GroupAccount information. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ServerAdministration.
FindGroup | Overloaded. Returns the Group object for the given ID.
FindUser | Overloaded. Returns the User object with the given logonName. The user returned will contain all the account information. Returns null if logonName is not found.
GenerateDiagnosticDump | Creates a diagnostic file and places it in the server configurations' log path. While creating the file, the server does no other processing This may take several minutes Use only at the direction of Borland Technical Support. Throws an SDKRuntimeException if the call fails
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.
GetNamedConfigOptions | Return a String array of values that matches the input String array of option names. This method is supported by server release 6.0 and later; ignored for earlier releases.
GetSecurityLog |
GetServerCommandStats |
GetType (inherited from Object) | Gets the Type of the current instance.
HasPermissions | Returns true if desired permissions are granted
LockServer | Puts the server in "Locked" mode. No one can perform operations. Useful for freezing server for database backups.
LockServerExclusively | Puts the server in "LockedExclusively" mode: only the locker can perform operations. Useful for restricting server access during replication operations.
PopulateGroupMembershipForAllUsers | A single server command to populate the group membership for all active users on this server. Logged in user requires administrator privileges to execute this command This command is available only for server release 12.0 or after
Refresh | Updates cached Users and Groups account information to reflect recent changes to the repository. Existing UserAccount and GroupAccount objects are modified in place whenever possible.
RestartServer | Shuts down and restarts the server. This has the side-effect of making the associated Server instance rather useless as the StarTeam Server it was connected to will be shut down and restarted.
SetNamedConfigOptions | Set a group of named configuration options. This method is supported by server release 6.0 and later; ignored for earlier releases.
ShutdownServer | Shuts down the server. This has the obvious side-effect of making the associated Server instance rather useless, as the StarTeam Server it was connected to will be shut down.
TestDirectoryServiceSettings |
TestOauth2ProviderSettings | Tests is the given Oauth2 issuer URL is valid.
TestSMTPSettings |
ToString | Delegate ToString() to com.starteam.ServerAdministration.
TreatMixedEOLFileContentAsBinary | True if MixedEOL content should be treated as BINARY files This is a CAE use case and has associated rules which require all EOL computation to be contained entirely within the SDK.
UnlockServer | Unlocks a server in "Locked" mode.
WriteLogFile | Overloaded.
WriteServerCommandStats | Retrieves the server's command statistics and writes it to the specified file.

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.Discard Method

Discards all cached UserAccount and GroupAccount information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void Discard();

See Also

ServerAdministration Class | StarTeam Namespace | getUsers | getGroups | refresh


ServerAdministration.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.Equals(obj).

See Also

ServerAdministration Class | StarTeam Namespace


FindGroup Method

Borland StarTeam SDK for .NET

ServerAdministration.FindGroup Method

Returns the Group object for the given ID.

Overload List

Returns the Group object for the given ID.

public virtual Group FindGroup(Int32);

Returns the Group object with the given name. The group returned will contain all the account information. Returns null if the group is not found.

public virtual Group FindGroup(String);

See Also

ServerAdministration Class | StarTeam Namespace | getGroups


ServerAdministration.FindGroup Method (Int32)

Returns the Group object for the given ID.

public virtual Group FindGroup(
Int32 groupID
);

Parameters

groupID
the Group ID in question

Return Value

the Group object with the given ID. Will return null if not found.

See Also

ServerAdministration Class | StarTeam Namespace | ServerAdministration.FindGroup Overload List | getGroups


ServerAdministration.FindGroup Method (String)

Returns the Group object with the given name. The group returned will contain all the account information. Returns null if the group is not found.

public virtual Group FindGroup(
String groupName
);

Parameters

groupName
the group name in question

Return Value

the Group object with the given name. Will return null if not found.

See Also

ServerAdministration Class | StarTeam Namespace | ServerAdministration.FindGroup Overload List | getUsers


FindUser Method

Borland StarTeam SDK for .NET

ServerAdministration.FindUser Method

Returns the User object for the given ID.

Overload List

Returns the User object for the given ID.

public virtual User FindUser(Int32);

Returns the User object with the given logonName. The user returned will contain all the account information. Returns null if logonName is not found.

public virtual User FindUser(String);

See Also

ServerAdministration Class | StarTeam Namespace | getUsers


ServerAdministration.FindUser Method (Int32)

Returns the User object for the given ID.

public virtual User FindUser(
Int32 userID
);

Parameters

userID
the user ID in question

Return Value

the UserAccount object with the given ID. Will return null if not found.

See Also

ServerAdministration Class | StarTeam Namespace | ServerAdministration.FindUser Overload List | getUsers


ServerAdministration.FindUser Method (String)

Returns the User object with the given logonName. The user returned will contain all the account information. Returns null if logonName is not found.

public virtual User FindUser(
String logonName
);

Parameters

logonName
the logonName in question

Return Value

the User object with the given name. Will return null if not found.

See Also

ServerAdministration Class | StarTeam Namespace | ServerAdministration.FindUser Overload List | getUsers


ServerAdministration.GenerateDiagnosticDump Method

Creates a diagnostic file and places it in the server configurations' log path. While creating the file, the server does no other processing This may take several minutes Use only at the direction of Borland Technical Support. Throws an SDKRuntimeException if the call fails

public virtual string GenerateDiagnosticDump(
Int32 minidumpType
);

Parameters

minidumpType
A mini-dump type

Return Value

the result of the dump command being executed

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.GetHashCode().

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.GetNamedConfigOptions Method

Return a String array of values that matches the input String array of option names. This method is supported by server release 6.0 and later; ignored for earlier releases.

public virtual string[] GetNamedConfigOptions(
String[] names
);

Parameters

names
the key values of the options to retrieve.

Return Value

a String array of values that matches the input String array of option names.

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.GetSecurityLog Method

public virtual SecurityLogEntry[] GetSecurityLog(
ServerAdministration.SecurityLogEntry.EventType eventType
);

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.GetServerCommandStats Method

public virtual void GetServerCommandStats(
Stream _out
);

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.HasPermissions Method

Returns true if desired permissions are granted

public virtual bool HasPermissions(
PermissionCollection permissions
);

Parameters

permissions
the desired permissions

See Also

ServerAdministration Class | StarTeam Namespace | Permission | PermissionCollection


ServerAdministration.LockServer Method

Puts the server in "Locked" mode. No one can perform operations. Useful for freezing server for database backups.

public virtual void LockServer();

See Also

ServerAdministration Class | StarTeam Namespace | getServerLockStatus | lockServerExclusively | unlockServer


ServerAdministration.LockServerExclusively Method

Puts the server in "LockedExclusively" mode: only the locker can perform operations. Useful for restricting server access during replication operations.

public virtual void LockServerExclusively();

See Also

ServerAdministration Class | StarTeam Namespace | getServerLockStatus | lockServer | unlockServer


ServerAdministration.PopulateGroupMembershipForAllUsers Method

A single server command to populate the group membership for all active users on this server. Logged in user requires administrator privileges to execute this command This command is available only for server release 12.0 or after

public virtual void PopulateGroupMembershipForAllUsers();

See Also

ServerAdministration Class | StarTeam Namespace | getGroups


ServerAdministration.Refresh Method

Updates cached Users and Groups account information to reflect recent changes to the repository. Existing UserAccount and GroupAccount objects are modified in place whenever possible.

public virtual void Refresh();

See Also

ServerAdministration Class | StarTeam Namespace | discard


ServerAdministration.RestartServer Method

Shuts down and restarts the server. This has the side-effect of making the associated Server instance rather useless as the StarTeam Server it was connected to will be shut down and restarted.

public virtual void RestartServer();

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.SetNamedConfigOptions Method

Set a group of named configuration options. This method is supported by server release 6.0 and later; ignored for earlier releases.

public virtual void SetNamedConfigOptions(
String[] names,
String[] values
);

Parameters

names
names of the options whose values are set.
values
values of the options to be set, in same sequence a names.

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.ShutdownServer Method

Shuts down the server. This has the obvious side-effect of making the associated Server instance rather useless, as the StarTeam Server it was connected to will be shut down.

public virtual void ShutdownServer();

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.TestDirectoryServiceSettings Method

public virtual bool TestDirectoryServiceSettings(
String URL,
Int32 port,
ServerConfiguration.DirectoryServiceSecurityType securityType
);

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.TestOauth2ProviderSettings Method

Tests is the given Oauth2 issuer URL is valid.

public virtual bool TestOauth2ProviderSettings(
String oauth2IssuerURL
);

Parameters

oauth2IssuerURL

Return Value

true if the test succeeds, throws an exception with error message if test fails.

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.TestSMTPSettings Method

public virtual bool TestSMTPSettings(
String address,
Int32 port,
ServerConfiguration.DirectoryServiceSecurityType secTyp,
String hostName,
String certificateName,
String loginName,
String password
);

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.

public override string ToString();

Return Value

com.starteam.ServerAdministration.ToString()

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.TreatMixedEOLFileContentAsBinary Method

True if MixedEOL content should be treated as BINARY files This is a CAE use case and has associated rules which require all EOL computation to be contained entirely within the SDK.

public virtual bool TreatMixedEOLFileContentAsBinary();

Return Value

True if MixedEOL content should be treated as BINARY files

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.UnlockServer Method

Unlocks a server in "Locked" mode.

public virtual void UnlockServer();

See Also

ServerAdministration Class | StarTeam Namespace | getServerLockStatus | lockServer | lockServerExclusively


WriteLogFile Method

Borland StarTeam SDK for .NET

ServerAdministration.WriteLogFile Method

Overload List

public virtual void WriteLogFile(FileInfo,ServerAdministration.ServerLogType,ServerLogMode[]);

public virtual long WriteLogFile(Stream,ServerAdministration.ServerLogType,ServerLogMode[],Int32);

public virtual long WriteLogFile(Stream,ServerAdministration.ServerLogType,ServerLogMode[],Int32,Int32);

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.WriteLogFile Method (FileInfo, ServerAdministration#ServerLogType, ServerAdministration#ServerLogMode[])

public virtual void WriteLogFile(
FileInfo _out,
ServerAdministration.ServerLogType logType,
ServerLogMode[] logModes
);

See Also

ServerAdministration Class | StarTeam Namespace | ServerAdministration.WriteLogFile Overload List


ServerAdministration.WriteLogFile Method (Stream, ServerAdministration#ServerLogType, ServerAdministration#ServerLogMode[], Int32)

public virtual long WriteLogFile(
Stream _out,
ServerAdministration.ServerLogType logType,
ServerLogMode[] logModes,
Int32 lastNLog
);

See Also

ServerAdministration Class | StarTeam Namespace | ServerAdministration.WriteLogFile Overload List


ServerAdministration.WriteLogFile Method (Stream, ServerAdministration#ServerLogType, ServerAdministration#ServerLogMode[], Int32, Int32)

public virtual long WriteLogFile(
Stream _out,
ServerAdministration.ServerLogType logType,
ServerLogMode[] logModes,
Int32 lastNLog,
Int32 locale
);

See Also

ServerAdministration Class | StarTeam Namespace | ServerAdministration.WriteLogFile Overload List


ServerAdministration.WriteServerCommandStats Method

Retrieves the server's command statistics and writes it to the specified file.

public virtual void WriteServerCommandStats(
FileInfo file
);

Parameters

file
the file to which the commands statistics will be written.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ServerAdministration Class | StarTeam Namespace


ServerAdministration.License Class

Information about the licenses registered on a StarTeam Server.

For a list of all members of this type, see ServerAdministration.License Members.

System.Object
ServerAdministration.License

public class ServerAdministration.License

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.License Members | StarTeam Namespace


ServerAdministration.License Members

ServerAdministration.License overview

Public Instance Properties

AutoPassConcurrentLicenseCapacity | [read] The number of users currently assigned to the AutoPass concurrent license.
AutoPassLicenseEx | [read] The licenses managed by the AutoPass License Server.
AutoPassNamedLicenseCapacity | [read] The number of users currently assigned to the AutoPass named license.
AvailableFixedLicenses | [read] The number of fixed (named-user) licenses currently available on the server.
AvailableFloatingLicenses | [read] The number of floating (concurrent) licenses currently available on the server.
BLSLicenses | [read] The licenses managed by the Borland License Server.
BLSSlipGUIDs | [read] The Slip IDs of the licenses managed by the Borland License Server.
TotalFixedLicenses | [read] The total number of fixed (named-user) licenses registered on the server.
TotalFloatingLicenses | [read] The total number of floating (concurrent) licenses registered on the server.
UnassignedLicenseUsers | [read] The number of users without an assigned license on the server.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.License.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.License.
GetNumUsersForBLSLicense | Gets the number of users currently assigned to the BLS license with the given Slip ID. (BLS and BLS licenses are provided through Embarcadero Software)
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.License.

See Also

ServerAdministration.License Class | StarTeam Namespace


ServerAdministration.License Properties

The properties of the ServerAdministration.License class are listed below. For a complete list of ServerAdministration.License class members, see the ServerAdministration.License Members topic.

Public Instance Properties

AutoPassConcurrentLicenseCapacity | [read] The number of users currently assigned to the AutoPass concurrent license.
AutoPassLicenseEx | [read] The licenses managed by the AutoPass License Server.
AutoPassNamedLicenseCapacity | [read] The number of users currently assigned to the AutoPass named license.
AvailableFixedLicenses | [read] The number of fixed (named-user) licenses currently available on the server.
AvailableFloatingLicenses | [read] The number of floating (concurrent) licenses currently available on the server.
BLSLicenses | [read] The licenses managed by the Borland License Server.
BLSSlipGUIDs | [read] The Slip IDs of the licenses managed by the Borland License Server.
TotalFixedLicenses | [read] The total number of fixed (named-user) licenses registered on the server.
TotalFloatingLicenses | [read] The total number of floating (concurrent) licenses registered on the server.
UnassignedLicenseUsers | [read] The number of users without an assigned license on the server.

See Also

ServerAdministration.License Class | StarTeam Namespace


AutoPassConcurrentLicenseCapacity Property

Borland StarTeam SDK for .NET

ServerAdministration.License.AutoPassConcurrentLicenseCapacity Property

[read] The number of users currently assigned to the AutoPass concurrent license.

public virtual Int32 AutoPassConcurrentLicenseCapacity {get;}

Property Value

The number of users currently assigned to the AutoPass concurrent license.

See Also

ServerAdministration.License Class | StarTeam Namespace


AutoPassLicenseEx Property

Borland StarTeam SDK for .NET

ServerAdministration.License.AutoPassLicenseEx Property

[read] The licenses managed by the AutoPass License Server.

public virtual ServerAdministration.License.AutoPassLicense AutoPassLicenseEx {get;}

Property Value

The licenses managed by the AutoPass License Server.

See Also

ServerAdministration.License Class | StarTeam Namespace


AutoPassNamedLicenseCapacity Property

Borland StarTeam SDK for .NET

ServerAdministration.License.AutoPassNamedLicenseCapacity Property

[read] The number of users currently assigned to the AutoPass named license.

public virtual Int32 AutoPassNamedLicenseCapacity {get;}

Property Value

The number of users currently assigned to the AutoPass named license.

See Also

ServerAdministration.License Class | StarTeam Namespace


AvailableFixedLicenses Property

Borland StarTeam SDK for .NET

ServerAdministration.License.AvailableFixedLicenses Property

[read] The number of fixed (named-user) licenses currently available on the server.

public virtual Int32 AvailableFixedLicenses {get;}

Property Value

The number of fixed (named-user) licenses currently available on the server.

See Also

ServerAdministration.License Class | StarTeam Namespace


AvailableFloatingLicenses Property

Borland StarTeam SDK for .NET

ServerAdministration.License.AvailableFloatingLicenses Property

[read] The number of floating (concurrent) licenses currently available on the server.

public virtual Int32 AvailableFloatingLicenses {get;}

Property Value

The number of floating (concurrent) licenses currently available on the server.

See Also

ServerAdministration.License Class | StarTeam Namespace


BLSLicenses Property

Borland StarTeam SDK for .NET

ServerAdministration.License.BLSLicenses Property

[read] The licenses managed by the Borland License Server.

public virtual BLS[] BLSLicenses {get;}

Property Value

The licenses managed by the Borland License Server.

See Also

ServerAdministration.License Class | StarTeam Namespace


BLSSlipGUIDs Property

Borland StarTeam SDK for .NET

ServerAdministration.License.BLSSlipGUIDs Property

[read] The Slip IDs of the licenses managed by the Borland License Server.

public virtual Int32[] BLSSlipGUIDs {get;}

Property Value

The Slip IDs of the licenses managed by the Borland License Server.

See Also

ServerAdministration.License Class | StarTeam Namespace


TotalFixedLicenses Property

Borland StarTeam SDK for .NET

ServerAdministration.License.TotalFixedLicenses Property

[read] The total number of fixed (named-user) licenses registered on the server.

public virtual Int32 TotalFixedLicenses {get;}

Property Value

The total number of fixed (named-user) licenses registered on the server.

See Also

ServerAdministration.License Class | StarTeam Namespace


TotalFloatingLicenses Property

Borland StarTeam SDK for .NET

ServerAdministration.License.TotalFloatingLicenses Property

[read] The total number of floating (concurrent) licenses registered on the server.

public virtual Int32 TotalFloatingLicenses {get;}

Property Value

The total number of floating (concurrent) licenses registered on the server.

See Also

ServerAdministration.License Class | StarTeam Namespace


UnassignedLicenseUsers Property

Borland StarTeam SDK for .NET

ServerAdministration.License.UnassignedLicenseUsers Property

[read] The number of users without an assigned license on the server.

public virtual Int32 UnassignedLicenseUsers {get;}

Property Value

The number of users without an assigned license on the server.

See Also

ServerAdministration.License Class | StarTeam Namespace


ServerAdministration.License Methods

The methods of the ServerAdministration.License class are listed below. For a complete list of ServerAdministration.License class members, see the ServerAdministration.License Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.License.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.License.
GetNumUsersForBLSLicense | Gets the number of users currently assigned to the BLS license with the given Slip ID. (BLS and BLS licenses are provided through Embarcadero Software)
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.License.

See Also

ServerAdministration.License Class | StarTeam Namespace


ServerAdministration.License.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.License.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.License.Equals(obj).

See Also

ServerAdministration.License Class | StarTeam Namespace


ServerAdministration.License.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.License.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.License.GetHashCode().

See Also

ServerAdministration.License Class | StarTeam Namespace


ServerAdministration.License.GetNumUsersForBLSLicense Method

Gets the number of users currently assigned to the BLS license with the given Slip ID. (BLS and BLS licenses are provided through Embarcadero Software)

public virtual int GetNumUsersForBLSLicense(
Int32 slipGuid
);

Parameters

slipGuid
The Slip ID of a BLS license.

Return Value

The number of users currently assigned to the BLS license with the given Slip ID, or 0 if the given Slip ID does not refer to a valid BLS license.

See Also

ServerAdministration.License Class | StarTeam Namespace


ServerAdministration.License.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.License.

public override string ToString();

Return Value

com.starteam.ServerAdministration.License.ToString()

See Also

ServerAdministration.License Class | StarTeam Namespace


ServerAdministration.License.AutoPassLicense Class

A license managed by the AutoPass License Server.

For a list of all members of this type, see ServerAdministration.License.AutoPassLicense Members.

System.Object
ServerAdministration.License.AutoPassLicense

public class ServerAdministration.License.AutoPassLicense

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.License.AutoPassLicense Members | StarTeam Namespace


ServerAdministration.License.AutoPassLicense Members

ServerAdministration.License.AutoPassLicense overview

Public Instance Properties

NumberOfConcurrentLicenses | [read]
NumberOfNamedLicenses | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.License.AutoPassLicense.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.License.AutoPassLicense.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.License.AutoPassLicense.

See Also

ServerAdministration.License.AutoPassLicense Class | StarTeam Namespace


ServerAdministration.License.AutoPassLicense Properties

The properties of the ServerAdministration.License.AutoPassLicense class are listed below. For a complete list of ServerAdministration.License.AutoPassLicense class members, see the ServerAdministration.License.AutoPassLicense Members topic.

Public Instance Properties

NumberOfConcurrentLicenses | [read]
NumberOfNamedLicenses | [read]

See Also

ServerAdministration.License.AutoPassLicense Class | StarTeam Namespace


NumberOfConcurrentLicenses Property

Borland StarTeam SDK for .NET

ServerAdministration.License.AutoPassLicense.NumberOfConcurrentLicenses Property

[read]

public virtual Int32 NumberOfConcurrentLicenses {get;}

See Also

ServerAdministration.License.AutoPassLicense Class | StarTeam Namespace


NumberOfNamedLicenses Property

Borland StarTeam SDK for .NET

ServerAdministration.License.AutoPassLicense.NumberOfNamedLicenses Property

[read]

public virtual Int32 NumberOfNamedLicenses {get;}

See Also

ServerAdministration.License.AutoPassLicense Class | StarTeam Namespace


ServerAdministration.License.AutoPassLicense Methods

The methods of the ServerAdministration.License.AutoPassLicense class are listed below. For a complete list of ServerAdministration.License.AutoPassLicense class members, see the ServerAdministration.License.AutoPassLicense Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.License.AutoPassLicense.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.License.AutoPassLicense.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.License.AutoPassLicense.

See Also

ServerAdministration.License.AutoPassLicense Class | StarTeam Namespace


ServerAdministration.License.AutoPassLicense.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.License.AutoPassLicense.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.License.AutoPassLicense.Equals(obj).

See Also

ServerAdministration.License.AutoPassLicense Class | StarTeam Namespace


ServerAdministration.License.AutoPassLicense.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.License.AutoPassLicense.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.License.AutoPassLicense.GetHashCode().

See Also

ServerAdministration.License.AutoPassLicense Class | StarTeam Namespace


ServerAdministration.License.AutoPassLicense.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.License.AutoPassLicense.

public override string ToString();

Return Value

com.starteam.ServerAdministration.License.AutoPassLicense.ToString()

See Also

ServerAdministration.License.AutoPassLicense Class | StarTeam Namespace


ServerAdministration.License.BLS Class

A license managed by the Borland License Server. (BLS and BLS licenses are provided through Embarcadero Software)

For a list of all members of this type, see ServerAdministration.License.BLS Members.

System.Object
ServerAdministration.License.BLS

public class ServerAdministration.License.BLS

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.License.BLS Members | StarTeam Namespace


ServerAdministration.License.BLS Members

ServerAdministration.License.BLS overview

Public Instance Properties

Description | [read] The description of this license.
SlipGuid | [read] The Slip ID assigned by the Borland License Server to identify this license.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.License.BLS.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.License.BLS.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.License.BLS.

See Also

ServerAdministration.License.BLS Class | StarTeam Namespace


ServerAdministration.License.BLS Properties

The properties of the ServerAdministration.License.BLS class are listed below. For a complete list of ServerAdministration.License.BLS class members, see the ServerAdministration.License.BLS Members topic.

Public Instance Properties

Description | [read] The description of this license.
SlipGuid | [read] The Slip ID assigned by the Borland License Server to identify this license.

See Also

ServerAdministration.License.BLS Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ServerAdministration.License.BLS.Description Property

[read] The description of this license.

public virtual String Description {get;}

Property Value

The description of this license.

See Also

ServerAdministration.License.BLS Class | StarTeam Namespace


SlipGuid Property

Borland StarTeam SDK for .NET

ServerAdministration.License.BLS.SlipGuid Property

[read] The Slip ID assigned by the Borland License Server to identify this license.

public virtual Int32 SlipGuid {get;}

Property Value

The Slip ID assigned by the Borland License Server to identify this license.

See Also

ServerAdministration.License.BLS Class | StarTeam Namespace


ServerAdministration.License.BLS Methods

The methods of the ServerAdministration.License.BLS class are listed below. For a complete list of ServerAdministration.License.BLS class members, see the ServerAdministration.License.BLS Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.License.BLS.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.License.BLS.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.License.BLS.

See Also

ServerAdministration.License.BLS Class | StarTeam Namespace


ServerAdministration.License.BLS.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.License.BLS.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.License.BLS.Equals(obj).

See Also

ServerAdministration.License.BLS Class | StarTeam Namespace


ServerAdministration.License.BLS.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.License.BLS.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.License.BLS.GetHashCode().

See Also

ServerAdministration.License.BLS Class | StarTeam Namespace


ServerAdministration.License.BLS.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.License.BLS.

public override string ToString();

Return Value

com.starteam.ServerAdministration.License.BLS.ToString()

See Also

ServerAdministration.License.BLS Class | StarTeam Namespace


ServerAdministration.LockStatus Class

Information about the lock status of the server. Possible status are "locked", "locked exclusively" or "unlocked".

For a list of all members of this type, see ServerAdministration.LockStatus Members.

System.Object
ServerAdministration.LockStatus

public class ServerAdministration.LockStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.LockStatus Members | StarTeam Namespace


ServerAdministration.LockStatus Members

ServerAdministration.LockStatus overview

Public Static Properties

ALL
LOCKED
LOCKED_EXCLUSIVELY
UNLOCKED

Public Static Methods

FromID Gets the Status value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this Status value.
Name | [read] The name of Lock Status

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.LockStatus.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.LockStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.LockStatus.

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


ServerAdministration.LockStatus Properties

The properties of the ServerAdministration.LockStatus class are listed below. For a complete list of ServerAdministration.LockStatus class members, see the ServerAdministration.LockStatus Members topic.

Public Static Properties

ALL
LOCKED
LOCKED_EXCLUSIVELY
UNLOCKED

Public Instance Properties

ID | [read] The ID of this Status value.
Name | [read] The name of Lock Status

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ServerAdministration.LockStatus.ALL Property

public static LockStatus[] ALL {get;}

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerAdministration.LockStatus.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


LOCKED Property

Borland StarTeam SDK for .NET

ServerAdministration.LockStatus.LOCKED Property

public static ServerAdministration.LockStatus LOCKED {get;}

Property Value

Server is locked

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


LOCKED_EXCLUSIVELY Property

Borland StarTeam SDK for .NET

ServerAdministration.LockStatus.LOCKED_EXCLUSIVELY Property

public static ServerAdministration.LockStatus LOCKED_EXCLUSIVELY {get;}

Property Value

Server is locked exclusively

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ServerAdministration.LockStatus.Name Property

[read] The name of Lock Status

public virtual String Name {get;}

Property Value

The name of Lock Status

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


UNLOCKED Property

Borland StarTeam SDK for .NET

ServerAdministration.LockStatus.UNLOCKED Property

public static ServerAdministration.LockStatus UNLOCKED {get;}

Property Value

Server is unlocked

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


ServerAdministration.LockStatus Methods

The methods of the ServerAdministration.LockStatus class are listed below. For a complete list of ServerAdministration.LockStatus class members, see the ServerAdministration.LockStatus Members topic.

Public Static Methods

FromID Gets the Status value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.LockStatus.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.LockStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.LockStatus.

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


ServerAdministration.LockStatus.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.LockStatus.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.LockStatus.Equals(obj).

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


ServerAdministration.LockStatus.FromID Method

Gets the Status value corresponding to the given ID.

public static LockStatus FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


ServerAdministration.LockStatus.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.LockStatus.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.LockStatus.GetHashCode().

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


ServerAdministration.LockStatus.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.LockStatus.

public override string ToString();

Return Value

com.starteam.ServerAdministration.LockStatus.ToString()

See Also

ServerAdministration.LockStatus Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry Class

Information about the security log entries on a StarTeam Server.

For a list of all members of this type, see ServerAdministration.SecurityLogEntry Members.

System.Object
ServerAdministration.SecurityLogEntry

public class ServerAdministration.SecurityLogEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.SecurityLogEntry Members | StarTeam Namespace


ServerAdministration.SecurityLogEntry Members

ServerAdministration.SecurityLogEntry overview

Public Instance Properties

AccessCheckSecLogIDValue | [read] The AccessCheck or null.
ContainerACLValue | [read] The ContainerACL or null.
IsFailure | [read] true if this event was a failure, otherwise false.
ObjectACLValue | [read] The ObjectACL or null.
ObjectDisplayText | [read] The display text for the security event.
SecurityEventTypeValue | [read] the EventType that caused this event
Timestamp | [read] The timestamp.
User | [read] The User object that represents the user id.
UserGroupValue | [read] The UserGroup or null.
WorkstationValue | [read] The Workstation object that represents the workstation id.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry Properties

The properties of the ServerAdministration.SecurityLogEntry class are listed below. For a complete list of ServerAdministration.SecurityLogEntry class members, see the ServerAdministration.SecurityLogEntry Members topic.

Public Instance Properties

AccessCheckSecLogIDValue | [read] The AccessCheck or null.
ContainerACLValue | [read] The ContainerACL or null.
IsFailure | [read] true if this event was a failure, otherwise false.
ObjectACLValue | [read] The ObjectACL or null.
ObjectDisplayText | [read] The display text for the security event.
SecurityEventTypeValue | [read] the EventType that caused this event
Timestamp | [read] The timestamp.
User | [read] The User object that represents the user id.
UserGroupValue | [read] The UserGroup or null.
WorkstationValue | [read] The Workstation object that represents the workstation id.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


AccessCheckSecLogIDValue Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.AccessCheckSecLogIDValue Property

[read] The AccessCheck or null.

public virtual ServerAdministration.SecurityLogEntry.AccessCheck AccessCheckSecLogIDValue {get;}

Property Value

The AccessCheck or null.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


ContainerACLValue Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.ContainerACLValue Property

[read] The ContainerACL or null.

public virtual ServerAdministration.SecurityLogEntry.ContainerACL ContainerACLValue {get;}

Property Value

The ContainerACL or null.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


IsFailure Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.IsFailure Property

[read] true if this event was a failure, otherwise false.

public virtual Boolean IsFailure {get;}

Property Value

true if this event was a failure, otherwise false.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


ObjectACLValue Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.ObjectACLValue Property

[read] The ObjectACL or null.

public virtual ServerAdministration.SecurityLogEntry.ObjectACL ObjectACLValue {get;}

Property Value

The ObjectACL or null.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


ObjectDisplayText Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.ObjectDisplayText Property

[read] The display text for the security event.

public virtual String ObjectDisplayText {get;}

Property Value

The display text for the security event.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


SecurityEventTypeValue Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.SecurityEventTypeValue Property

[read] the EventType that caused this event

public virtual ServerAdministration.SecurityLogEntry.EventType SecurityEventTypeValue {get;}

Property Value

the EventType that caused this event

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


Timestamp Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.Timestamp Property

[read] The timestamp.

public virtual DateTime Timestamp {get;}

Property Value

The timestamp.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


User Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.User Property

[read] The User object that represents the user id.

public virtual User User {get;}

Property Value

The User object that represents the user id.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


UserGroupValue Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.UserGroupValue Property

[read] The UserGroup or null.

public virtual ServerAdministration.SecurityLogEntry.UserGroup UserGroupValue {get;}

Property Value

The UserGroup or null.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


WorkstationValue Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.WorkstationValue Property

[read] The Workstation object that represents the workstation id.

public virtual ServerAdministration.SecurityLogEntry.Workstation WorkstationValue {get;}

Property Value

The Workstation object that represents the workstation id.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry Methods

The methods of the ServerAdministration.SecurityLogEntry class are listed below. For a complete list of ServerAdministration.SecurityLogEntry class members, see the ServerAdministration.SecurityLogEntry Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.Equals(obj).

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.GetHashCode().

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.

public override string ToString();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.ToString()

See Also

ServerAdministration.SecurityLogEntry Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.AccessCheck Class

For Access Check events.

For a list of all members of this type, see ServerAdministration.SecurityLogEntry.AccessCheck Members.

System.Object
ServerAdministration.SecurityLogEntry.AccessCheck

public class ServerAdministration.SecurityLogEntry.AccessCheck

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.SecurityLogEntry.AccessCheck Members | StarTeam Namespace


ServerAdministration.SecurityLogEntry.AccessCheck Members

ServerAdministration.SecurityLogEntry.AccessCheck overview

Public Instance Properties

ClassID | [read] The class id.
ObjectID | [read] The object id.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.

See Also

ServerAdministration.SecurityLogEntry.AccessCheck Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.AccessCheck Properties

The properties of the ServerAdministration.SecurityLogEntry.AccessCheck class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.AccessCheck class members, see the ServerAdministration.SecurityLogEntry.AccessCheck Members topic.

Public Instance Properties

ClassID | [read] The class id.
ObjectID | [read] The object id.

See Also

ServerAdministration.SecurityLogEntry.AccessCheck Class | StarTeam Namespace


ClassID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.AccessCheck.ClassID Property

[read] The class id.

public virtual Int32 ClassID {get;}

Property Value

The class id.

See Also

ServerAdministration.SecurityLogEntry.AccessCheck Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.AccessCheck.ObjectID Property

[read] The object id.

public virtual Int32 ObjectID {get;}

Property Value

The object id.

See Also

ServerAdministration.SecurityLogEntry.AccessCheck Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.AccessCheck Methods

The methods of the ServerAdministration.SecurityLogEntry.AccessCheck class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.AccessCheck class members, see the ServerAdministration.SecurityLogEntry.AccessCheck Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.

See Also

ServerAdministration.SecurityLogEntry.AccessCheck Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.AccessCheck.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.Equals(obj).

See Also

ServerAdministration.SecurityLogEntry.AccessCheck Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.AccessCheck.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.GetHashCode().

See Also

ServerAdministration.SecurityLogEntry.AccessCheck Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.AccessCheck.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.

public override string ToString();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.AccessCheck.ToString()

See Also

ServerAdministration.SecurityLogEntry.AccessCheck Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ContainerACL Class

For Container-level security log events.

For a list of all members of this type, see ServerAdministration.SecurityLogEntry.ContainerACL Members.

System.Object
ServerAdministration.SecurityLogEntry.ContainerACL

public class ServerAdministration.SecurityLogEntry.ContainerACL

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Members | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ContainerACL Members

ServerAdministration.SecurityLogEntry.ContainerACL overview

Public Instance Properties

ClassID | [read] The class id.
ContainerID | [read] The container id.
ObjectID | [read] The object id.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ContainerACL Properties

The properties of the ServerAdministration.SecurityLogEntry.ContainerACL class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.ContainerACL class members, see the ServerAdministration.SecurityLogEntry.ContainerACL Members topic.

Public Instance Properties

ClassID | [read] The class id.
ContainerID | [read] The container id.
ObjectID | [read] The object id.

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Class | StarTeam Namespace


ClassID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.ContainerACL.ClassID Property

[read] The class id.

public virtual Int32 ClassID {get;}

Property Value

The class id.

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Class | StarTeam Namespace


ContainerID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.ContainerACL.ContainerID Property

[read] The container id.

public virtual Int32 ContainerID {get;}

Property Value

The container id.

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.ContainerACL.ObjectID Property

[read] The object id.

public virtual Int32 ObjectID {get;}

Property Value

The object id.

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ContainerACL Methods

The methods of the ServerAdministration.SecurityLogEntry.ContainerACL class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.ContainerACL class members, see the ServerAdministration.SecurityLogEntry.ContainerACL Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ContainerACL.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.Equals(obj).

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ContainerACL.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.GetHashCode().

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ContainerACL.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.

public override string ToString();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.ContainerACL.ToString()

See Also

ServerAdministration.SecurityLogEntry.ContainerACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.EventType Class

Constants that define the type of the Security Event.

For a list of all members of this type, see ServerAdministration.SecurityLogEntry.EventType Members.

System.Object
ServerAdministration.SecurityLogEntry.EventType

public class ServerAdministration.SecurityLogEntry.EventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.SecurityLogEntry.EventType Members | StarTeam Namespace


ServerAdministration.SecurityLogEntry.EventType Members

ServerAdministration.SecurityLogEntry.EventType overview

Public Static Properties

ACCESS_TIMES_RESTRICTED
ACCOUNT_SUSPENDED
ALL
CONTAINER_ACL_ADDED_OR_EDITED
CONTAINER_ACL_DELETED
LOCKED_OUT
LOGIN
LOGIN_FAILURE
LOGOUT
NO_SUCH_LOGIN_NAME
OBJECT_ACCESS_CHECKED
OBJECT_ACL_ACQUIRED_OWNERSHIP
OBJECT_ACL_ADDED_OR_EDITED
OBJECT_ACL_ADDED_TO_OWNER
OBJECT_ACL_DELETED
OBJECT_ACL_DROPPED_FROM_OWNER
PASSWORD_EXPIRED
POLICY_CHANGED
UNKNOWN
USER_CHANGED
USER_GROUP_ADDED
USER_GROUP_DROPPED
USER_GROUP_EDITED
USER_GROUP_FORCED_LOGOUT
USER_GROUP_STATUS_CHANGED

Public Static Methods

FromID Gets the Event type value corresponding to the given ID.

Public Instance Properties

ID [read]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.EventType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.EventType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.EventType.

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.EventType Properties

The properties of the ServerAdministration.SecurityLogEntry.EventType class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.EventType class members, see the ServerAdministration.SecurityLogEntry.EventType Members topic.

Public Static Properties

ACCESS_TIMES_RESTRICTED
ACCOUNT_SUSPENDED
ALL
CONTAINER_ACL_ADDED_OR_EDITED
CONTAINER_ACL_DELETED
LOCKED_OUT
LOGIN
LOGIN_FAILURE
LOGOUT
NO_SUCH_LOGIN_NAME
OBJECT_ACCESS_CHECKED
OBJECT_ACL_ACQUIRED_OWNERSHIP
OBJECT_ACL_ADDED_OR_EDITED
OBJECT_ACL_ADDED_TO_OWNER
OBJECT_ACL_DELETED
OBJECT_ACL_DROPPED_FROM_OWNER
PASSWORD_EXPIRED
POLICY_CHANGED
UNKNOWN
USER_CHANGED
USER_GROUP_ADDED
USER_GROUP_DROPPED
USER_GROUP_EDITED
USER_GROUP_FORCED_LOGOUT
USER_GROUP_STATUS_CHANGED

Public Instance Properties

ID [read]

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ACCESS_TIMES_RESTRICTED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.ACCESS_TIMES_RESTRICTED Property

public static ServerAdministration.SecurityLogEntry.EventType ACCESS_TIMES_RESTRICTED {get;}

Property Value

Access times restricted event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ACCOUNT_SUSPENDED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.ACCOUNT_SUSPENDED Property

public static ServerAdministration.SecurityLogEntry.EventType ACCOUNT_SUSPENDED {get;}

Property Value

Account Suspended event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.ALL Property

public static EventType[] ALL {get;}

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


CONTAINER_ACL_ADDED_OR_EDITED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.CONTAINER_ACL_ADDED_OR_EDITED Property

public static ServerAdministration.SecurityLogEntry.EventType CONTAINER_ACL_ADDED_OR_EDITED {get;}

Property Value

Object ACL added or edited event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


CONTAINER_ACL_DELETED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.CONTAINER_ACL_DELETED Property

public static ServerAdministration.SecurityLogEntry.EventType CONTAINER_ACL_DELETED {get;}

Property Value

container acl deleted event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.ID Property

[read]

public virtual Int32 ID {get;}

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


LOCKED_OUT Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.LOCKED_OUT Property

public static ServerAdministration.SecurityLogEntry.EventType LOCKED_OUT {get;}

Property Value

Locked out event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


LOGIN Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.LOGIN Property

public static ServerAdministration.SecurityLogEntry.EventType LOGIN {get;}

Property Value

Login event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


LOGIN_FAILURE Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.LOGIN_FAILURE Property

public static ServerAdministration.SecurityLogEntry.EventType LOGIN_FAILURE {get;}

Property Value

Login failure event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


LOGOUT Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.LOGOUT Property

public static ServerAdministration.SecurityLogEntry.EventType LOGOUT {get;}

Property Value

Logout event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


NO_SUCH_LOGIN_NAME Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.NO_SUCH_LOGIN_NAME Property

public static ServerAdministration.SecurityLogEntry.EventType NO_SUCH_LOGIN_NAME {get;}

Property Value

Invalid Login Name event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


OBJECT_ACCESS_CHECKED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.OBJECT_ACCESS_CHECKED Property

public static ServerAdministration.SecurityLogEntry.EventType OBJECT_ACCESS_CHECKED {get;}

Property Value

Object access checked event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


OBJECT_ACL_ACQUIRED_OWNERSHIP Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.OBJECT_ACL_ACQUIRED_OWNERSHIP Property

public static ServerAdministration.SecurityLogEntry.EventType OBJECT_ACL_ACQUIRED_OWNERSHIP {get;}

Property Value

Object ACL acquired ownership event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


OBJECT_ACL_ADDED_OR_EDITED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.OBJECT_ACL_ADDED_OR_EDITED Property

public static ServerAdministration.SecurityLogEntry.EventType OBJECT_ACL_ADDED_OR_EDITED {get;}

Property Value

Object ACL added or edited event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


OBJECT_ACL_ADDED_TO_OWNER Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.OBJECT_ACL_ADDED_TO_OWNER Property

public static ServerAdministration.SecurityLogEntry.EventType OBJECT_ACL_ADDED_TO_OWNER {get;}

Property Value

Object ACL added to owner event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


OBJECT_ACL_DELETED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.OBJECT_ACL_DELETED Property

public static ServerAdministration.SecurityLogEntry.EventType OBJECT_ACL_DELETED {get;}

Property Value

Object ACL deleted event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


OBJECT_ACL_DROPPED_FROM_OWNER Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.OBJECT_ACL_DROPPED_FROM_OWNER Property

public static ServerAdministration.SecurityLogEntry.EventType OBJECT_ACL_DROPPED_FROM_OWNER {get;}

Property Value

Object ACL dropped from owner event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


PASSWORD_EXPIRED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.PASSWORD_EXPIRED Property

public static ServerAdministration.SecurityLogEntry.EventType PASSWORD_EXPIRED {get;}

Property Value

Password expired event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


POLICY_CHANGED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.POLICY_CHANGED Property

public static ServerAdministration.SecurityLogEntry.EventType POLICY_CHANGED {get;}

Property Value

Policy changed event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.UNKNOWN Property

public static ServerAdministration.SecurityLogEntry.EventType UNKNOWN {get;}

Property Value

Unknown event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


USER_CHANGED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.USER_CHANGED Property

public static ServerAdministration.SecurityLogEntry.EventType USER_CHANGED {get;}

Property Value

User changed event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


USER_GROUP_ADDED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.USER_GROUP_ADDED Property

public static ServerAdministration.SecurityLogEntry.EventType USER_GROUP_ADDED {get;}

Property Value

User Group added event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


USER_GROUP_DROPPED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.USER_GROUP_DROPPED Property

public static ServerAdministration.SecurityLogEntry.EventType USER_GROUP_DROPPED {get;}

Property Value

User Group dropped event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


USER_GROUP_EDITED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.USER_GROUP_EDITED Property

public static ServerAdministration.SecurityLogEntry.EventType USER_GROUP_EDITED {get;}

Property Value

User Group edited event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


USER_GROUP_FORCED_LOGOUT Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.USER_GROUP_FORCED_LOGOUT Property

public static ServerAdministration.SecurityLogEntry.EventType USER_GROUP_FORCED_LOGOUT {get;}

Property Value

User Group forced logout event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


USER_GROUP_STATUS_CHANGED Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.EventType.USER_GROUP_STATUS_CHANGED Property

public static ServerAdministration.SecurityLogEntry.EventType USER_GROUP_STATUS_CHANGED {get;}

Property Value

User Group status changed event

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.EventType Methods

The methods of the ServerAdministration.SecurityLogEntry.EventType class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.EventType class members, see the ServerAdministration.SecurityLogEntry.EventType Members topic.

Public Static Methods

FromID Gets the Event type value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.EventType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.EventType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.EventType.

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.EventType.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.EventType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.EventType.Equals(obj).

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.EventType.FromID Method

Gets the Event type value corresponding to the given ID.

public static EventType FromID(
Int32 ID
);

Parameters

ID
an EventType ID.

Return Value

The corresponding EventType value, or null.

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.EventType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.EventType.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.EventType.GetHashCode().

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.EventType.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.EventType.

public override string ToString();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.EventType.ToString()

See Also

ServerAdministration.SecurityLogEntry.EventType Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ObjectACL Class

For Object ACL events.

For a list of all members of this type, see ServerAdministration.SecurityLogEntry.ObjectACL Members.

System.Object
ServerAdministration.SecurityLogEntry.ObjectACL

public class ServerAdministration.SecurityLogEntry.ObjectACL

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.SecurityLogEntry.ObjectACL Members | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ObjectACL Members

ServerAdministration.SecurityLogEntry.ObjectACL overview

Public Instance Properties

ClassID | [read] The class id.
ObjectID | [read] The object id.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.

See Also

ServerAdministration.SecurityLogEntry.ObjectACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ObjectACL Properties

The properties of the ServerAdministration.SecurityLogEntry.ObjectACL class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.ObjectACL class members, see the ServerAdministration.SecurityLogEntry.ObjectACL Members topic.

Public Instance Properties

ClassID | [read] The class id.
ObjectID | [read] The object id.

See Also

ServerAdministration.SecurityLogEntry.ObjectACL Class | StarTeam Namespace


ClassID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.ObjectACL.ClassID Property

[read] The class id.

public virtual Int32 ClassID {get;}

Property Value

The class id.

See Also

ServerAdministration.SecurityLogEntry.ObjectACL Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.ObjectACL.ObjectID Property

[read] The object id.

public virtual Int32 ObjectID {get;}

Property Value

The object id.

See Also

ServerAdministration.SecurityLogEntry.ObjectACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ObjectACL Methods

The methods of the ServerAdministration.SecurityLogEntry.ObjectACL class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.ObjectACL class members, see the ServerAdministration.SecurityLogEntry.ObjectACL Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.

See Also

ServerAdministration.SecurityLogEntry.ObjectACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ObjectACL.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.Equals(obj).

See Also

ServerAdministration.SecurityLogEntry.ObjectACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ObjectACL.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.GetHashCode().

See Also

ServerAdministration.SecurityLogEntry.ObjectACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.ObjectACL.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.

public override string ToString();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.ObjectACL.ToString()

See Also

ServerAdministration.SecurityLogEntry.ObjectACL Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.UserGroup Class

For User-based security log events.

For a list of all members of this type, see ServerAdministration.SecurityLogEntry.UserGroup Members.

System.Object
ServerAdministration.SecurityLogEntry.UserGroup

public class ServerAdministration.SecurityLogEntry.UserGroup

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.SecurityLogEntry.UserGroup Members | StarTeam Namespace


ServerAdministration.SecurityLogEntry.UserGroup Members

ServerAdministration.SecurityLogEntry.UserGroup overview

Public Instance Properties

UserGroupID [read] The user group id.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.

See Also

ServerAdministration.SecurityLogEntry.UserGroup Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.UserGroup Properties

The properties of the ServerAdministration.SecurityLogEntry.UserGroup class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.UserGroup class members, see the ServerAdministration.SecurityLogEntry.UserGroup Members topic.

Public Instance Properties

UserGroupID [read] The user group id.

See Also

ServerAdministration.SecurityLogEntry.UserGroup Class | StarTeam Namespace


UserGroupID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.UserGroup.UserGroupID Property

[read] The user group id.

public virtual Int32 UserGroupID {get;}

Property Value

The user group id.

See Also

ServerAdministration.SecurityLogEntry.UserGroup Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.UserGroup Methods

The methods of the ServerAdministration.SecurityLogEntry.UserGroup class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.UserGroup class members, see the ServerAdministration.SecurityLogEntry.UserGroup Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.

See Also

ServerAdministration.SecurityLogEntry.UserGroup Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.UserGroup.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.Equals(obj).

See Also

ServerAdministration.SecurityLogEntry.UserGroup Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.UserGroup.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.GetHashCode().

See Also

ServerAdministration.SecurityLogEntry.UserGroup Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.UserGroup.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.

public override string ToString();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.UserGroup.ToString()

See Also

ServerAdministration.SecurityLogEntry.UserGroup Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.Workstation Class

Workstation details

For a list of all members of this type, see ServerAdministration.SecurityLogEntry.Workstation Members.

System.Object
ServerAdministration.SecurityLogEntry.Workstation

public class ServerAdministration.SecurityLogEntry.Workstation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.SecurityLogEntry.Workstation Members | StarTeam Namespace


ServerAdministration.SecurityLogEntry.Workstation Members

ServerAdministration.SecurityLogEntry.Workstation overview

Public Instance Properties

ID | [read] The number assigned by the server to this workstation.
Name | [read] The name of the workstation.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.Workstation.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.Workstation.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.Workstation.

See Also

ServerAdministration.SecurityLogEntry.Workstation Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.Workstation Properties

The properties of the ServerAdministration.SecurityLogEntry.Workstation class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.Workstation class members, see the ServerAdministration.SecurityLogEntry.Workstation Members topic.

Public Instance Properties

ID | [read] The number assigned by the server to this workstation.
Name | [read] The name of the workstation.

See Also

ServerAdministration.SecurityLogEntry.Workstation Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.Workstation.ID Property

[read] The number assigned by the server to this workstation.

public virtual Int32 ID {get;}

Property Value

The number assigned by the server to this workstation.

See Also

ServerAdministration.SecurityLogEntry.Workstation Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ServerAdministration.SecurityLogEntry.Workstation.Name Property

[read] The name of the workstation.

public virtual String Name {get;}

Property Value

The name of the workstation.

See Also

ServerAdministration.SecurityLogEntry.Workstation Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.Workstation Methods

The methods of the ServerAdministration.SecurityLogEntry.Workstation class are listed below. For a complete list of ServerAdministration.SecurityLogEntry.Workstation class members, see the ServerAdministration.SecurityLogEntry.Workstation Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.Workstation.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.Workstation.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.Workstation.

See Also

ServerAdministration.SecurityLogEntry.Workstation Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.Workstation.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.SecurityLogEntry.Workstation.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.Workstation.Equals(obj).

See Also

ServerAdministration.SecurityLogEntry.Workstation Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.Workstation.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.SecurityLogEntry.Workstation.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.Workstation.GetHashCode().

See Also

ServerAdministration.SecurityLogEntry.Workstation Class | StarTeam Namespace


ServerAdministration.SecurityLogEntry.Workstation.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.SecurityLogEntry.Workstation.

public override string ToString();

Return Value

com.starteam.ServerAdministration.SecurityLogEntry.Workstation.ToString()

See Also

ServerAdministration.SecurityLogEntry.Workstation Class | StarTeam Namespace


ServerAdministration.ServerLogMode Class

Information about the log mode of the server.

For a list of all members of this type, see ServerAdministration.ServerLogMode Members.

System.Object
ServerAdministration.ServerLogMode

public class ServerAdministration.ServerLogMode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.ServerLogMode Members | StarTeam Namespace


ServerAdministration.ServerLogMode Members

ServerAdministration.ServerLogMode overview

Public Static Properties

ALL
LOG_ALL
LOG_ASSERTIONS
LOG_EXCEPTIONS
LOG_MESSAGES
LOG_WARNINGS

Public Static Methods

FromID Gets the LogMode value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this Status value.
Name | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.ServerLogMode.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.ServerLogMode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.ServerLogMode.

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


ServerAdministration.ServerLogMode Properties

The properties of the ServerAdministration.ServerLogMode class are listed below. For a complete list of ServerAdministration.ServerLogMode class members, see the ServerAdministration.ServerLogMode Members topic.

Public Static Properties

ALL
LOG_ALL
LOG_ASSERTIONS
LOG_EXCEPTIONS
LOG_MESSAGES
LOG_WARNINGS

Public Instance Properties

ID | [read] The ID of this Status value.
Name | [read]

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogMode.ALL Property

public static ServerLogMode[] ALL {get;}

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogMode.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


LOG_ALL Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogMode.LOG_ALL Property

public static ServerAdministration.ServerLogMode LOG_ALL {get;}

Property Value

Log everything

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


LOG_ASSERTIONS Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogMode.LOG_ASSERTIONS Property

public static ServerAdministration.ServerLogMode LOG_ASSERTIONS {get;}

Property Value

Log the assertions

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


LOG_EXCEPTIONS Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogMode.LOG_EXCEPTIONS Property

public static ServerAdministration.ServerLogMode LOG_EXCEPTIONS {get;}

Property Value

Log the exceptions

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


LOG_MESSAGES Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogMode.LOG_MESSAGES Property

public static ServerAdministration.ServerLogMode LOG_MESSAGES {get;}

Property Value

Log messages

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


LOG_WARNINGS Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogMode.LOG_WARNINGS Property

public static ServerAdministration.ServerLogMode LOG_WARNINGS {get;}

Property Value

Log the warnings

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogMode.Name Property

[read]

public virtual String Name {get;}

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


ServerAdministration.ServerLogMode Methods

The methods of the ServerAdministration.ServerLogMode class are listed below. For a complete list of ServerAdministration.ServerLogMode class members, see the ServerAdministration.ServerLogMode Members topic.

Public Static Methods

FromID Gets the LogMode value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.ServerLogMode.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.ServerLogMode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.ServerLogMode.

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


ServerAdministration.ServerLogMode.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.ServerLogMode.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.ServerLogMode.Equals(obj).

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


ServerAdministration.ServerLogMode.FromID Method

Gets the LogMode value corresponding to the given ID.

public static ServerLogMode FromID(
Int32 id
);

Parameters

id
A LogMode ID.

Return Value

The corresponding LogMode value, or null.

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


ServerAdministration.ServerLogMode.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.ServerLogMode.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.ServerLogMode.GetHashCode().

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


ServerAdministration.ServerLogMode.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.ServerLogMode.

public override string ToString();

Return Value

com.starteam.ServerAdministration.ServerLogMode.ToString()

See Also

ServerAdministration.ServerLogMode Class | StarTeam Namespace


ServerAdministration.ServerLogType Class

Information about the log type of the server.

For a list of all members of this type, see ServerAdministration.ServerLogType Members.

System.Object
ServerAdministration.ServerLogType

public class ServerAdministration.ServerLogType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerAdministration.ServerLogType Members | StarTeam Namespace


ServerAdministration.ServerLogType Members

ServerAdministration.ServerLogType overview

Public Static Properties

ALL
LOG_TYPE_PURGE
LOG_TYPE_SERVER

Public Static Methods

FromID Gets the LogType value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this Status value.
Name | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.ServerLogType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.ServerLogType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.ServerLogType.

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


ServerAdministration.ServerLogType Properties

The properties of the ServerAdministration.ServerLogType class are listed below. For a complete list of ServerAdministration.ServerLogType class members, see the ServerAdministration.ServerLogType Members topic.

Public Static Properties

ALL
LOG_TYPE_PURGE
LOG_TYPE_SERVER

Public Instance Properties

ID | [read] The ID of this Status value.
Name | [read]

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogType.ALL Property

public static ServerLogType[] ALL {get;}

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogType.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


LOG_TYPE_PURGE Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogType.LOG_TYPE_PURGE Property

public static ServerAdministration.ServerLogType LOG_TYPE_PURGE {get;}

Property Value

Purge Log type

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


LOG_TYPE_SERVER Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogType.LOG_TYPE_SERVER Property

public static ServerAdministration.ServerLogType LOG_TYPE_SERVER {get;}

Property Value

Server Log type

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ServerAdministration.ServerLogType.Name Property

[read]

public virtual String Name {get;}

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


ServerAdministration.ServerLogType Methods

The methods of the ServerAdministration.ServerLogType class are listed below. For a complete list of ServerAdministration.ServerLogType class members, see the ServerAdministration.ServerLogType Members topic.

Public Static Methods

FromID Gets the LogType value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerAdministration.ServerLogType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerAdministration.ServerLogType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerAdministration.ServerLogType.

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


ServerAdministration.ServerLogType.Equals Method

Delegate Equals() to com.starteam.ServerAdministration.ServerLogType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerAdministration.ServerLogType.Equals(obj).

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


ServerAdministration.ServerLogType.FromID Method

Gets the LogType value corresponding to the given ID.

public static ServerLogType FromID(
Int32 id
);

Parameters

id
A LogType ID.

Return Value

The corresponding LogType value, or null.

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


ServerAdministration.ServerLogType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerAdministration.ServerLogType.

public override int GetHashCode();

Return Value

com.starteam.ServerAdministration.ServerLogType.GetHashCode().

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


ServerAdministration.ServerLogType.ToString Method

Delegate ToString() to com.starteam.ServerAdministration.ServerLogType.

public override string ToString();

Return Value

com.starteam.ServerAdministration.ServerLogType.ToString()

See Also

ServerAdministration.ServerLogType Class | StarTeam Namespace


ServerConfiguration Class

Describes Configuration Properties of the connected StarTeam server

For a list of all members of this type, see ServerConfiguration Members.

System.Object
ServerConfiguration

public class ServerConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerConfiguration Members | StarTeam Namespace


ServerConfiguration Members

ServerConfiguration overview

Public Static Properties

PROTOCOL_TCP_IP_SOCKETS

Public Instance Constructors

ServerConfiguration Constructor construct a new ServerConfiguration from the source

Public Instance Properties

AlmServiceUrl | [read/write] A string form of the URL used to locate the ALM Trace Service.
ArchiveDirectory | [read/write] The path to the server's archive directory.
AttachmentDirectory | [read/write] The path to the server's attachment directory.
AuditsAutoPurgeDays | [read/write] The number of days after which audit information is purged from the server.
AuditsEnabled | [read/write] true if auditing is enabled on the server.
CacheDirectory | [read/write] The path to the server's vault directory.
CheckoutUseRevisionFileName | [read] true if files with different names at older revisions need to be checked out using the old file name
Cipher | [read/write] The server's cipher string.
CreateCheckinChangePackage | [read/write] true if checkin change packages should be created by the SDK
DBAutoRecovery | [read/write] true if the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.
DBPooledConnections | [read/write] The number of pooled connections to the server database.
DBPort | [read/write] The port number that the server database is connected to.
DBServerName | [read/write] The database server name.
DBServiceName | [read/write] The service name that the server database is connected to.
DBSid | [read/write] The Sid of the database that the StarTeam server is connected to.
DBTransactionsEnabled | [read/write] true if database transactions are enabled.
DBType | [read/write] The server database type.
DBVerifyOnStartup | [read/write] true if the server database is verified on startup. This property is supported by StarTeam 4.1 and later.
DefaultBinaryExtensions | [read] the set of default binary extension types
DiagnosticStatisticsReportingInterval | [read/write] The frequency, in seconds, with which the server will report diagnostic statistics. The default value is zero, which disables reporting.
DirectoryServiceEnabled | [read/write] true if Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServiceHost | [read/write] the name or IP Address of the Directory Service host. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServicePort | [read/write] the Directory Service SSL port. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServiceSecurityTypeValue | [read] the security type for connecting to Directory services.
DisableCustomTools | [read] true if custom tools can be disabled, false otherwise
DumpAsserts | [read/write] whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.
DumpErrors | [read/write] whether the server will create a diagnostic dump when errors are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.
DumpType | [read/write] int the mini dump type used for diagnostic dumps
EnableDiagnostics | [read/write] true if server diagnostics are enabled.
EnableSDKWorkflow | [read] TRUE if SDK Workflow should be turned ON automatically
EncryptionRequirements | [read/write] the required encryption levels for various ranges of TCP/IP addresses.
ExpensiveOperationMinimum | [read/write] the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes. Meaningful for server release 6.0 and later; returns -1 for earlier releases.
FederatedTraceServer | [read] the GUID corresponding to a Server used to store just Traces in a multi configuration StarTeam environment
FileStatusAutoPurgeDays | [read/write] The number of days after which a file's status information will be purged.
InactivityTimeout | [read/write] The server's inactivity timeout, in seconds.
IsAdvancedViewsDisabled | [read/write] whether the server is configured to disable advanced views. Meaningful for server release 10.0 and later; always false for earlier releases.
IsAtomicTransactionsDisabled | [read/write] whether the server is configured to disable atomic transactions. Meaningful for server release 10.0 and later; always false for earlier releases.
IsMultiCommandTransactionsDisabled | [read] true if multi-command transactions are disabled at runtime during a vcm commit This request will always force a server command to be executed.
LogFile | [read/write] The path to the server's log file.
LogonTimeout | [read/write] The server's logon timeout, in seconds.
MailEnabled | [read/write] true if email is enabled on the server.
MultiPartDirectory | [read/write] The path to the server's multi-part directory.
NotificationEndTime | [read/write] the notification end time
NotificationMessage | [read/write] a configured notification message
NotificationStartTime | [read/write] the notification start time
NotifyBy | [read/write] The method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.
NoTimeoutNamedLicenses | [read/write] the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.
Oauth2ClientID | [read/write] Oauth2 client id required for Single sign-on/ Multi-factor authentication.
Oauth2ClientSecret | [write] Sets the Oauth2 client secret. This property is supported by server release 17.1 and later; ignored for earlier releases.
Oauth2IssuerURL | [read/write] Oauth2 Issuer URL.
Oauth2RedirectURI | [read/write] Oauth2 redirect URI.
ReconnectTimeout | [read/write] The server's reconnect timeout, in seconds. Available for StarTeam 6.0 servers and later.
RepositoryPath | [read/write] The path to the server's data repository.
RESTServicePort | [read] the search service port
SecondaryDirectoryServiceEnabled | [read/write] true if Directory Service is enabled on this server. This property is supported by server release 16.4 and later; ignored for earlier releases.
SecondaryDirectoryServiceHost | [read/write] the name or IP Address of the Directory Service host. This property is supported by server release 16.4 and later; ignored for earlier releases.
SecondaryDirectoryServicePort | [read/write] the Directory Service SSL port. This property is supported by server release 16.4 and later; ignored for earlier releases.
SecondaryDirectoryServiceSecurityTypeValue | [read] the security type for connecting to Directory services.
ServerGUID | [read/write] The server's globally unique identifier.
SMTPAddress | [read/write] The SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
SMTPCertificateName | [read/write] The SMTP certificate name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.
SMTPHostName | [read/write] The SMTP host name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.
SMTPLoginName | [read/write] The SMTP login name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.
SMTPPassword | [write] Sets the SMTP password of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.
SMTPPort | [read/write] The SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
SMTPSecurityType | [read/write] The SMTP security type of the mail server that handles outbound email requests for this StarTeam server.
StarteamAgileWebAddress | [read/write] A Starteam Agile Web address
StopServerOnErrors | [read/write] true if the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.
TNSNames | [read/write] The TNS Names of the database that the StarTeam server is connected to.
TraceExpensiveOperations | [read/write] whether the server will trace expensive operations. Meaningful for server release 6.0 and later; always false for earlier releases.
TypeOfAuthentication | [read/write] authentication type.
UsingSecondarySecureDirectoryService | [write] Sets the security type for connecting to Directory services. Starting 16.4, the Starteam server supports TLS for directory services in addition to SSL.
UsingSecureDirectoryService | [write] Sets the security type for connecting to Directory services. Starting 15.1, the Starteam server supports TLS for directory services in addition to SSL.
VaultCacheMaxSize | [read/write] The server's vault cache size limit, in megabytes.
VaultCacheRefreshInterval | [read/write] The server's vault cache refresh interval, in seconds.
VaultDirectory | [read/write] The path to the server's vault directory.
VaultLockTimeLimit | [read/write] The server's vault lock time limit, in seconds.

Public Instance Methods

Copy | return a copy of this ServerConfiguration instance
Equals | Delegate Equals() to com.starteam.ServerConfiguration.
GetEnabled | Returns true if the specified protocol is enabled.
GetEndPoint | Returns the endpoint for the specified protocol.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the Object passed in is a ServerConfiguration instance, with the same set of values as this ServerConfiguration instance
IsProtocolAvailable | Returns true if the server supports the specified protocol.
SetEnabled | Enable or disable the specified communication procotol.
SetEndPoint | Modifies the specified protocol's endpoint. The endpoint is protocol specific.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration Constructor

construct a new ServerConfiguration from the source

public ServerConfiguration(
ServerConfiguration source
);

Parameters

source
ServerConfiguration the ServerConfiguration to copy

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration Properties

The properties of the ServerConfiguration class are listed below. For a complete list of ServerConfiguration class members, see the ServerConfiguration Members topic.

Public Static Properties

PROTOCOL_TCP_IP_SOCKETS

Public Instance Properties

AlmServiceUrl | [read/write] A string form of the URL used to locate the ALM Trace Service.
ArchiveDirectory | [read/write] The path to the server's archive directory.
AttachmentDirectory | [read/write] The path to the server's attachment directory.
AuditsAutoPurgeDays | [read/write] The number of days after which audit information is purged from the server.
AuditsEnabled | [read/write] true if auditing is enabled on the server.
CacheDirectory | [read/write] The path to the server's vault directory.
CheckoutUseRevisionFileName | [read] true if files with different names at older revisions need to be checked out using the old file name
Cipher | [read/write] The server's cipher string.
CreateCheckinChangePackage | [read/write] true if checkin change packages should be created by the SDK
DBAutoRecovery | [read/write] true if the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.
DBPooledConnections | [read/write] The number of pooled connections to the server database.
DBPort | [read/write] The port number that the server database is connected to.
DBServerName | [read/write] The database server name.
DBServiceName | [read/write] The service name that the server database is connected to.
DBSid | [read/write] The Sid of the database that the StarTeam server is connected to.
DBTransactionsEnabled | [read/write] true if database transactions are enabled.
DBType | [read/write] The server database type.
DBVerifyOnStartup | [read/write] true if the server database is verified on startup. This property is supported by StarTeam 4.1 and later.
DefaultBinaryExtensions | [read] the set of default binary extension types
DiagnosticStatisticsReportingInterval | [read/write] The frequency, in seconds, with which the server will report diagnostic statistics. The default value is zero, which disables reporting.
DirectoryServiceEnabled | [read/write] true if Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServiceHost | [read/write] the name or IP Address of the Directory Service host. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServicePort | [read/write] the Directory Service SSL port. This property is supported by server release 6.0 and later; ignored for earlier releases.
DirectoryServiceSecurityTypeValue | [read] the security type for connecting to Directory services.
DisableCustomTools | [read] true if custom tools can be disabled, false otherwise
DumpAsserts | [read/write] whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.
DumpErrors | [read/write] whether the server will create a diagnostic dump when errors are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.
DumpType | [read/write] int the mini dump type used for diagnostic dumps
EnableDiagnostics | [read/write] true if server diagnostics are enabled.
EnableSDKWorkflow | [read] TRUE if SDK Workflow should be turned ON automatically
EncryptionRequirements | [read/write] the required encryption levels for various ranges of TCP/IP addresses.
ExpensiveOperationMinimum | [read/write] the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes. Meaningful for server release 6.0 and later; returns -1 for earlier releases.
FederatedTraceServer | [read] the GUID corresponding to a Server used to store just Traces in a multi configuration StarTeam environment
FileStatusAutoPurgeDays | [read/write] The number of days after which a file's status information will be purged.
InactivityTimeout | [read/write] The server's inactivity timeout, in seconds.
IsAdvancedViewsDisabled | [read/write] whether the server is configured to disable advanced views. Meaningful for server release 10.0 and later; always false for earlier releases.
IsAtomicTransactionsDisabled | [read/write] whether the server is configured to disable atomic transactions. Meaningful for server release 10.0 and later; always false for earlier releases.
IsMultiCommandTransactionsDisabled | [read] true if multi-command transactions are disabled at runtime during a vcm commit This request will always force a server command to be executed.
LogFile | [read/write] The path to the server's log file.
LogonTimeout | [read/write] The server's logon timeout, in seconds.
MailEnabled | [read/write] true if email is enabled on the server.
MultiPartDirectory | [read/write] The path to the server's multi-part directory.
NotificationEndTime | [read/write] the notification end time
NotificationMessage | [read/write] a configured notification message
NotificationStartTime | [read/write] the notification start time
NotifyBy | [read/write] The method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.
NoTimeoutNamedLicenses | [read/write] the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.
Oauth2ClientID | [read/write] Oauth2 client id required for Single sign-on/ Multi-factor authentication.
Oauth2ClientSecret | [write] Sets the Oauth2 client secret. This property is supported by server release 17.1 and later; ignored for earlier releases.
Oauth2IssuerURL | [read/write] Oauth2 Issuer URL.
Oauth2RedirectURI | [read/write] Oauth2 redirect URI.
ReconnectTimeout | [read/write] The server's reconnect timeout, in seconds. Available for StarTeam 6.0 servers and later.
RepositoryPath | [read/write] The path to the server's data repository.
RESTServicePort | [read] the search service port
SecondaryDirectoryServiceEnabled | [read/write] true if Directory Service is enabled on this server. This property is supported by server release 16.4 and later; ignored for earlier releases.
SecondaryDirectoryServiceHost | [read/write] the name or IP Address of the Directory Service host. This property is supported by server release 16.4 and later; ignored for earlier releases.
SecondaryDirectoryServicePort | [read/write] the Directory Service SSL port. This property is supported by server release 16.4 and later; ignored for earlier releases.
SecondaryDirectoryServiceSecurityTypeValue | [read] the security type for connecting to Directory services.
ServerGUID | [read/write] The server's globally unique identifier.
SMTPAddress | [read/write] The SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
SMTPCertificateName | [read/write] The SMTP certificate name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.
SMTPHostName | [read/write] The SMTP host name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.
SMTPLoginName | [read/write] The SMTP login name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.
SMTPPassword | [write] Sets the SMTP password of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.
SMTPPort | [read/write] The SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.
SMTPSecurityType | [read/write] The SMTP security type of the mail server that handles outbound email requests for this StarTeam server.
StarteamAgileWebAddress | [read/write] A Starteam Agile Web address
StopServerOnErrors | [read/write] true if the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.
TNSNames | [read/write] The TNS Names of the database that the StarTeam server is connected to.
TraceExpensiveOperations | [read/write] whether the server will trace expensive operations. Meaningful for server release 6.0 and later; always false for earlier releases.
TypeOfAuthentication | [read/write] authentication type.
UsingSecondarySecureDirectoryService | [write] Sets the security type for connecting to Directory services. Starting 16.4, the Starteam server supports TLS for directory services in addition to SSL.
UsingSecureDirectoryService | [write] Sets the security type for connecting to Directory services. Starting 15.1, the Starteam server supports TLS for directory services in addition to SSL.
VaultCacheMaxSize | [read/write] The server's vault cache size limit, in megabytes.
VaultCacheRefreshInterval | [read/write] The server's vault cache refresh interval, in seconds.
VaultDirectory | [read/write] The path to the server's vault directory.
VaultLockTimeLimit | [read/write] The server's vault lock time limit, in seconds.

See Also

ServerConfiguration Class | StarTeam Namespace


AlmServiceUrl Property

Borland StarTeam SDK for .NET

ServerConfiguration.AlmServiceUrl Property

[read/write] A string form of the URL used to locate the ALM Trace Service.

public virtual String AlmServiceUrl {get; set;}

Property Value

A string form of the URL used to locate the ALM Trace Service.

See Also

ServerConfiguration Class | StarTeam Namespace


ArchiveDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.ArchiveDirectory Property

[read/write] The path to the server's archive directory.

public virtual String ArchiveDirectory {get; set;}

Property Value

The path to the server's archive directory.

See Also

ServerConfiguration Class | StarTeam Namespace


AttachmentDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.AttachmentDirectory Property

[read/write] The path to the server's attachment directory.

public virtual String AttachmentDirectory {get; set;}

Property Value

The path to the server's attachment directory.

See Also

ServerConfiguration Class | StarTeam Namespace


AuditsAutoPurgeDays Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuditsAutoPurgeDays Property

[read/write] The number of days after which audit information is purged from the server.

public virtual Int32 AuditsAutoPurgeDays {get; set;}

Property Value

The number of days after which audit information is purged from the server.

See Also

ServerConfiguration Class | StarTeam Namespace


AuditsEnabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuditsEnabled Property

[read/write] true if auditing is enabled on the server.

public virtual Boolean AuditsEnabled {get; set;}

Property Value

true if auditing is enabled on the server.

See Also

ServerConfiguration Class | StarTeam Namespace


CacheDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.CacheDirectory Property

[read/write] The path to the server's vault directory.

public virtual String CacheDirectory {get; set;}

Property Value

The path to the server's vault directory.

See Also

ServerConfiguration Class | StarTeam Namespace


CheckoutUseRevisionFileName Property

Borland StarTeam SDK for .NET

ServerConfiguration.CheckoutUseRevisionFileName Property

[read] true if files with different names at older revisions need to be checked out using the old file name

public virtual Boolean CheckoutUseRevisionFileName {get;}

Property Value

true if files with different names at older revisions need to be checked out using the old file name

See Also

ServerConfiguration Class | StarTeam Namespace


Cipher Property

Borland StarTeam SDK for .NET

ServerConfiguration.Cipher Property

[read/write] The server's cipher string.

public virtual String Cipher {get; set;}

Property Value

The server's cipher string.

See Also

ServerConfiguration Class | StarTeam Namespace


CreateCheckinChangePackage Property

Borland StarTeam SDK for .NET

ServerConfiguration.CreateCheckinChangePackage Property

[read/write] true if checkin change packages should be created by the SDK

public virtual Boolean CreateCheckinChangePackage {get; set;}

Property Value

true if checkin change packages should be created by the SDK

See Also

ServerConfiguration Class | StarTeam Namespace


DBAutoRecovery Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBAutoRecovery Property

[read/write] true if the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.

public virtual Boolean DBAutoRecovery {get; set;}

Property Value

true if the server automatically recovers from errors. This property is supported by StarTeam 4.1 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


DBPooledConnections Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBPooledConnections Property

[read/write] The number of pooled connections to the server database.

public virtual Int32 DBPooledConnections {get; set;}

Property Value

The number of pooled connections to the server database.

See Also

ServerConfiguration Class | StarTeam Namespace


DBPort Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBPort Property

[read/write] The port number that the server database is connected to.

public virtual String DBPort {get; set;}

Property Value

The port number that the server database is connected to.

See Also

ServerConfiguration Class | StarTeam Namespace


DBServerName Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBServerName Property

[read/write] The database server name.

public virtual String DBServerName {get; set;}

Property Value

The database server name.

See Also

ServerConfiguration Class | StarTeam Namespace


DBServiceName Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBServiceName Property

[read/write] The service name that the server database is connected to.

public virtual String DBServiceName {get; set;}

Property Value

The service name that the server database is connected to.

See Also

ServerConfiguration Class | StarTeam Namespace


DBSid Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBSid Property

[read/write] The Sid of the database that the StarTeam server is connected to.

public virtual String DBSid {get; set;}

Property Value

The Sid of the database that the StarTeam server is connected to.

See Also

ServerConfiguration Class | StarTeam Namespace


DBTransactionsEnabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBTransactionsEnabled Property

[read/write] true if database transactions are enabled.

public virtual Boolean DBTransactionsEnabled {get; set;}

Property Value

true if database transactions are enabled.

See Also

ServerConfiguration Class | StarTeam Namespace


DBType Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBType Property

[read/write] The server database type.

public virtual ServerConfiguration.DatabaseType DBType {get; set;}

Property Value

The server database type.

See Also

ServerConfiguration Class | StarTeam Namespace


DBVerifyOnStartup Property

Borland StarTeam SDK for .NET

ServerConfiguration.DBVerifyOnStartup Property

[read/write] true if the server database is verified on startup. This property is supported by StarTeam 4.1 and later.

public virtual Boolean DBVerifyOnStartup {get; set;}

Property Value

true if the server database is verified on startup. This property is supported by StarTeam 4.1 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


DefaultBinaryExtensions Property

Borland StarTeam SDK for .NET

ServerConfiguration.DefaultBinaryExtensions Property

[read] the set of default binary extension types

public virtual String[] DefaultBinaryExtensions {get;}

Property Value

the set of default binary extension types

See Also

ServerConfiguration Class | StarTeam Namespace


DiagnosticStatisticsReportingInterval Property

Borland StarTeam SDK for .NET

ServerConfiguration.DiagnosticStatisticsReportingInterval Property

[read/write] The frequency, in seconds, with which the server will report diagnostic statistics. The default value is zero, which disables reporting.

public virtual Int32 DiagnosticStatisticsReportingInterval {get; set;}

Property Value

The frequency, in seconds, with which the server will report diagnostic statistics. The default value is zero, which disables reporting.

See Also

ServerConfiguration Class | StarTeam Namespace


DirectoryServiceEnabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceEnabled Property

[read/write] true if Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual Boolean DirectoryServiceEnabled {get; set;}

Property Value

true if Directory Service is enabled on this server. This property is supported by server release 6.0 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


DirectoryServiceHost Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceHost Property

[read/write] the name or IP Address of the Directory Service host. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual String DirectoryServiceHost {get; set;}

Property Value

the name or IP Address of the Directory Service host. This property is supported by server release 6.0 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


DirectoryServicePort Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServicePort Property

[read/write] the Directory Service SSL port. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual Int32 DirectoryServicePort {get; set;}

Property Value

the Directory Service SSL port. This property is supported by server release 6.0 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


DirectoryServiceSecurityTypeValue Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceSecurityTypeValue Property

[read] the security type for connecting to Directory services.

public virtual ServerConfiguration.DirectoryServiceSecurityType DirectoryServiceSecurityTypeValue {get;}

Property Value

the security type for connecting to Directory services.

See Also

ServerConfiguration Class | StarTeam Namespace


DisableCustomTools Property

Borland StarTeam SDK for .NET

ServerConfiguration.DisableCustomTools Property

[read] true if custom tools can be disabled, false otherwise

public virtual Boolean DisableCustomTools {get;}

Property Value

true if custom tools can be disabled, false otherwise

See Also

ServerConfiguration Class | StarTeam Namespace


DumpAsserts Property

Borland StarTeam SDK for .NET

ServerConfiguration.DumpAsserts Property

[read/write] whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.

public virtual Boolean DumpAsserts {get; set;}

Property Value

whether the server will create a diagnostic dump when unexpected conditions [i.e., asserts] are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


DumpErrors Property

Borland StarTeam SDK for .NET

ServerConfiguration.DumpErrors Property

[read/write] whether the server will create a diagnostic dump when errors are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.

public virtual Boolean DumpErrors {get; set;}

Property Value

whether the server will create a diagnostic dump when errors are discovered. Meaningful for server release 6.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


DumpType Property

Borland StarTeam SDK for .NET

ServerConfiguration.DumpType Property

[read/write] int the mini dump type used for diagnostic dumps

public virtual Int32 DumpType {get; set;}

Property Value

int the mini dump type used for diagnostic dumps

See Also

ServerConfiguration Class | StarTeam Namespace


EnableDiagnostics Property

Borland StarTeam SDK for .NET

ServerConfiguration.EnableDiagnostics Property

[read/write] true if server diagnostics are enabled.

public virtual Boolean EnableDiagnostics {get; set;}

Property Value

true if server diagnostics are enabled.

See Also

ServerConfiguration Class | StarTeam Namespace


EnableSDKWorkflow Property

Borland StarTeam SDK for .NET

ServerConfiguration.EnableSDKWorkflow Property

[read] TRUE if SDK Workflow should be turned ON automatically

public virtual Boolean EnableSDKWorkflow {get;}

Property Value

TRUE if SDK Workflow should be turned ON automatically

See Also

ServerConfiguration Class | StarTeam Namespace


EncryptionRequirements Property

Borland StarTeam SDK for .NET

ServerConfiguration.EncryptionRequirements Property

[read/write] the required encryption levels for various ranges of TCP/IP addresses.

public virtual IPRange[] EncryptionRequirements {get; set;}

Property Value

the required encryption levels for various ranges of TCP/IP addresses.

See Also

ServerConfiguration Class | StarTeam Namespace


ExpensiveOperationMinimum Property

Borland StarTeam SDK for .NET

ServerConfiguration.ExpensiveOperationMinimum Property

[read/write] the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes. Meaningful for server release 6.0 and later; returns -1 for earlier releases.

public virtual Int32 ExpensiveOperationMinimum {get; set;}

Property Value

the minimum number of milliseconds used to determine what is an expensive operation for tracing purposes. Meaningful for server release 6.0 and later; returns -1 for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


FederatedTraceServer Property

Borland StarTeam SDK for .NET

ServerConfiguration.FederatedTraceServer Property

[read] the GUID corresponding to a Server used to store just Traces in a multi configuration StarTeam environment

public virtual GUID FederatedTraceServer {get;}

Property Value

the GUID corresponding to a Server used to store just Traces in a multi configuration StarTeam environment

See Also

ServerConfiguration Class | StarTeam Namespace


FileStatusAutoPurgeDays Property

Borland StarTeam SDK for .NET

ServerConfiguration.FileStatusAutoPurgeDays Property

[read/write] The number of days after which a file's status information will be purged.

public virtual Int32 FileStatusAutoPurgeDays {get; set;}

Property Value

The number of days after which a file's status information will be purged.

See Also

ServerConfiguration Class | StarTeam Namespace


InactivityTimeout Property

Borland StarTeam SDK for .NET

ServerConfiguration.InactivityTimeout Property

[read/write] The server's inactivity timeout, in seconds.

public virtual Int32 InactivityTimeout {get; set;}

Property Value

The server's inactivity timeout, in seconds.

See Also

ServerConfiguration Class | StarTeam Namespace


IsAdvancedViewsDisabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.IsAdvancedViewsDisabled Property

[read/write] whether the server is configured to disable advanced views. Meaningful for server release 10.0 and later; always false for earlier releases.

public virtual Boolean IsAdvancedViewsDisabled {get; set;}

Property Value

whether the server is configured to disable advanced views. Meaningful for server release 10.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


IsAtomicTransactionsDisabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.IsAtomicTransactionsDisabled Property

[read/write] whether the server is configured to disable atomic transactions. Meaningful for server release 10.0 and later; always false for earlier releases.

public virtual Boolean IsAtomicTransactionsDisabled {get; set;}

Property Value

whether the server is configured to disable atomic transactions. Meaningful for server release 10.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


IsMultiCommandTransactionsDisabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.IsMultiCommandTransactionsDisabled Property

[read] true if multi-command transactions are disabled at runtime during a vcm commit This request will always force a server command to be executed.

public virtual Boolean IsMultiCommandTransactionsDisabled {get;}

Property Value

true if multi-command transactions are disabled at runtime during a vcm commit This request will always force a server command to be executed.

See Also

ServerConfiguration Class | StarTeam Namespace


LogFile Property

Borland StarTeam SDK for .NET

ServerConfiguration.LogFile Property

[read/write] The path to the server's log file.

public virtual String LogFile {get; set;}

Property Value

The path to the server's log file.

See Also

ServerConfiguration Class | StarTeam Namespace


LogonTimeout Property

Borland StarTeam SDK for .NET

ServerConfiguration.LogonTimeout Property

[read/write] The server's logon timeout, in seconds.

public virtual Int32 LogonTimeout {get; set;}

Property Value

The server's logon timeout, in seconds.

See Also

ServerConfiguration Class | StarTeam Namespace


MailEnabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.MailEnabled Property

[read/write] true if email is enabled on the server.

public virtual Boolean MailEnabled {get; set;}

Property Value

true if email is enabled on the server.

See Also

ServerConfiguration Class | StarTeam Namespace


MultiPartDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.MultiPartDirectory Property

[read/write] The path to the server's multi-part directory.

public virtual String MultiPartDirectory {get; set;}

Property Value

The path to the server's multi-part directory.

See Also

ServerConfiguration Class | StarTeam Namespace


NotificationEndTime Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotificationEndTime Property

[read/write] the notification end time

public virtual DateTime NotificationEndTime {get; set;}

Property Value

the notification end time

See Also

ServerConfiguration Class | StarTeam Namespace


NotificationMessage Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotificationMessage Property

[read/write] a configured notification message

public virtual String NotificationMessage {get; set;}

Property Value

a configured notification message

See Also

ServerConfiguration Class | StarTeam Namespace


NotificationStartTime Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotificationStartTime Property

[read/write] the notification start time

public virtual DateTime NotificationStartTime {get; set;}

Property Value

the notification start time

See Also

ServerConfiguration Class | StarTeam Namespace


NotifyBy Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotifyBy Property

[read/write] The method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.

public virtual ServerConfiguration.NotificationType NotifyBy {get; set;}

Property Value

The method by which notification messages are sent to StarTeam users. This property is supported by StarTeam 4.2 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


NoTimeoutNamedLicenses Property

Borland StarTeam SDK for .NET

ServerConfiguration.NoTimeoutNamedLicenses Property

[read/write] the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.

public virtual Boolean NoTimeoutNamedLicenses {get; set;}

Property Value

the server's "NoTimeoutNamedLicenses" setting for servers 7.0 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


Oauth2ClientID Property

Borland StarTeam SDK for .NET

ServerConfiguration.Oauth2ClientID Property

[read/write] Oauth2 client id required for Single sign-on/ Multi-factor authentication.

public virtual String Oauth2ClientID {get; set;}

Property Value

Oauth2 client id required for Single sign-on/ Multi-factor authentication.

See Also

ServerConfiguration Class | StarTeam Namespace


Oauth2ClientSecret Property

Borland StarTeam SDK for .NET

ServerConfiguration.Oauth2ClientSecret Property

[write] Sets the Oauth2 client secret. This property is supported by server release 17.1 and later; ignored for earlier releases.

public virtual String Oauth2ClientSecret {set;}

Property Value

Sets the Oauth2 client secret. This property is supported by server release 17.1 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


Oauth2IssuerURL Property

Borland StarTeam SDK for .NET

ServerConfiguration.Oauth2IssuerURL Property

[read/write] Oauth2 Issuer URL.

public virtual String Oauth2IssuerURL {get; set;}

Property Value

Oauth2 Issuer URL.

See Also

ServerConfiguration Class | StarTeam Namespace


Oauth2RedirectURI Property

Borland StarTeam SDK for .NET

ServerConfiguration.Oauth2RedirectURI Property

[read/write] Oauth2 redirect URI.

public virtual String Oauth2RedirectURI {get; set;}

Property Value

Oauth2 redirect URI.

See Also

ServerConfiguration Class | StarTeam Namespace


PROTOCOL_TCP_IP_SOCKETS Property

Borland StarTeam SDK for .NET

ServerConfiguration.PROTOCOL_TCP_IP_SOCKETS Property

public static Int32 PROTOCOL_TCP_IP_SOCKETS {get;}

See Also

ServerConfiguration Class | StarTeam Namespace


ReconnectTimeout Property

Borland StarTeam SDK for .NET

ServerConfiguration.ReconnectTimeout Property

[read/write] The server's reconnect timeout, in seconds. Available for StarTeam 6.0 servers and later.

public virtual Int32 ReconnectTimeout {get; set;}

Property Value

The server's reconnect timeout, in seconds. Available for StarTeam 6.0 servers and later.

See Also

ServerConfiguration Class | StarTeam Namespace


RepositoryPath Property

Borland StarTeam SDK for .NET

ServerConfiguration.RepositoryPath Property

[read/write] The path to the server's data repository.

public virtual String RepositoryPath {get; set;}

Property Value

The path to the server's data repository.

See Also

ServerConfiguration Class | StarTeam Namespace


RESTServicePort Property

Borland StarTeam SDK for .NET

ServerConfiguration.RESTServicePort Property

[read] the search service port

public virtual Int32 RESTServicePort {get;}

Property Value

the search service port

See Also

ServerConfiguration Class | StarTeam Namespace


SecondaryDirectoryServiceEnabled Property

Borland StarTeam SDK for .NET

ServerConfiguration.SecondaryDirectoryServiceEnabled Property

[read/write] true if Directory Service is enabled on this server. This property is supported by server release 16.4 and later; ignored for earlier releases.

public virtual Boolean SecondaryDirectoryServiceEnabled {get; set;}

Property Value

true if Directory Service is enabled on this server. This property is supported by server release 16.4 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


SecondaryDirectoryServiceHost Property

Borland StarTeam SDK for .NET

ServerConfiguration.SecondaryDirectoryServiceHost Property

[read/write] the name or IP Address of the Directory Service host. This property is supported by server release 16.4 and later; ignored for earlier releases.

public virtual String SecondaryDirectoryServiceHost {get; set;}

Property Value

the name or IP Address of the Directory Service host. This property is supported by server release 16.4 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


SecondaryDirectoryServicePort Property

Borland StarTeam SDK for .NET

ServerConfiguration.SecondaryDirectoryServicePort Property

[read/write] the Directory Service SSL port. This property is supported by server release 16.4 and later; ignored for earlier releases.

public virtual Int32 SecondaryDirectoryServicePort {get; set;}

Property Value

the Directory Service SSL port. This property is supported by server release 16.4 and later; ignored for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


SecondaryDirectoryServiceSecurityTypeValue Property

Borland StarTeam SDK for .NET

ServerConfiguration.SecondaryDirectoryServiceSecurityTypeValue Property

[read] the security type for connecting to Directory services.

public virtual ServerConfiguration.DirectoryServiceSecurityType SecondaryDirectoryServiceSecurityTypeValue {get;}

Property Value

the security type for connecting to Directory services.

See Also

ServerConfiguration Class | StarTeam Namespace


ServerGUID Property

Borland StarTeam SDK for .NET

ServerConfiguration.ServerGUID Property

[read/write] The server's globally unique identifier.

public virtual String ServerGUID {get; set;}

Property Value

The server's globally unique identifier.

See Also

ServerConfiguration Class | StarTeam Namespace


SMTPAddress Property

Borland StarTeam SDK for .NET

ServerConfiguration.SMTPAddress Property

[read/write] The SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

public virtual String SMTPAddress {get; set;}

Property Value

The SMTP address of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


SMTPCertificateName Property

Borland StarTeam SDK for .NET

ServerConfiguration.SMTPCertificateName Property

[read/write] The SMTP certificate name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.

public virtual String SMTPCertificateName {get; set;}

Property Value

The SMTP certificate name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


SMTPHostName Property

Borland StarTeam SDK for .NET

ServerConfiguration.SMTPHostName Property

[read/write] The SMTP host name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.

public virtual String SMTPHostName {get; set;}

Property Value

The SMTP host name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


SMTPLoginName Property

Borland StarTeam SDK for .NET

ServerConfiguration.SMTPLoginName Property

[read/write] The SMTP login name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.

public virtual String SMTPLoginName {get; set;}

Property Value

The SMTP login name of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


SMTPPassword Property

Borland StarTeam SDK for .NET

ServerConfiguration.SMTPPassword Property

[write] Sets the SMTP password of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.

public virtual String SMTPPassword {set;}

Property Value

Sets the SMTP password of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 15.1 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


SMTPPort Property

Borland StarTeam SDK for .NET

ServerConfiguration.SMTPPort Property

[read/write] The SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

public virtual Int32 SMTPPort {get; set;}

Property Value

The SMTP port of the mail server that handles outbound email requests for this StarTeam server. This property is supported by StarTeam 4.2 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


SMTPSecurityType Property

Borland StarTeam SDK for .NET

ServerConfiguration.SMTPSecurityType Property

[read/write] The SMTP security type of the mail server that handles outbound email requests for this StarTeam server.

public virtual ServerConfiguration.DirectoryServiceSecurityType SMTPSecurityType {get; set;}

Property Value

The SMTP security type of the mail server that handles outbound email requests for this StarTeam server.

See Also

ServerConfiguration Class | StarTeam Namespace


StarteamAgileWebAddress Property

Borland StarTeam SDK for .NET

ServerConfiguration.StarteamAgileWebAddress Property

[read/write] A Starteam Agile Web address

public virtual String StarteamAgileWebAddress {get; set;}

Property Value

A Starteam Agile Web address

See Also

ServerConfiguration Class | StarTeam Namespace


StopServerOnErrors Property

Borland StarTeam SDK for .NET

ServerConfiguration.StopServerOnErrors Property

[read/write] true if the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.

public virtual Boolean StopServerOnErrors {get; set;}

Property Value

true if the server automatically stops after an error. This property is supported by StarTeam 4.1 and later.

See Also

ServerConfiguration Class | StarTeam Namespace


TNSNames Property

Borland StarTeam SDK for .NET

ServerConfiguration.TNSNames Property

[read/write] The TNS Names of the database that the StarTeam server is connected to.

public virtual String TNSNames {get; set;}

Property Value

The TNS Names of the database that the StarTeam server is connected to.

See Also

ServerConfiguration Class | StarTeam Namespace


TraceExpensiveOperations Property

Borland StarTeam SDK for .NET

ServerConfiguration.TraceExpensiveOperations Property

[read/write] whether the server will trace expensive operations. Meaningful for server release 6.0 and later; always false for earlier releases.

public virtual Boolean TraceExpensiveOperations {get; set;}

Property Value

whether the server will trace expensive operations. Meaningful for server release 6.0 and later; always false for earlier releases.

See Also

ServerConfiguration Class | StarTeam Namespace


TypeOfAuthentication Property

Borland StarTeam SDK for .NET

ServerConfiguration.TypeOfAuthentication Property

[read/write] authentication type.

public virtual ServerConfiguration.AuthenticationType TypeOfAuthentication {get; set;}

Property Value

authentication type.

See Also

ServerConfiguration Class | StarTeam Namespace


UsingSecondarySecureDirectoryService Property

Borland StarTeam SDK for .NET

ServerConfiguration.UsingSecondarySecureDirectoryService Property

[write] Sets the security type for connecting to Directory services. Starting 16.4, the Starteam server supports TLS for directory services in addition to SSL.

public virtual ServerConfiguration.DirectoryServiceSecurityType UsingSecondarySecureDirectoryService {set;}

Property Value

Sets the security type for connecting to Directory services. Starting 16.4, the Starteam server supports TLS for directory services in addition to SSL.

See Also

ServerConfiguration Class | StarTeam Namespace


UsingSecureDirectoryService Property

Borland StarTeam SDK for .NET

ServerConfiguration.UsingSecureDirectoryService Property

[write] Sets the security type for connecting to Directory services. Starting 15.1, the Starteam server supports TLS for directory services in addition to SSL.

public virtual ServerConfiguration.DirectoryServiceSecurityType UsingSecureDirectoryService {set;}

Property Value

Sets the security type for connecting to Directory services. Starting 15.1, the Starteam server supports TLS for directory services in addition to SSL.

See Also

ServerConfiguration Class | StarTeam Namespace


VaultCacheMaxSize Property

Borland StarTeam SDK for .NET

ServerConfiguration.VaultCacheMaxSize Property

[read/write] The server's vault cache size limit, in megabytes.

public virtual Int32 VaultCacheMaxSize {get; set;}

Property Value

The server's vault cache size limit, in megabytes.

See Also

ServerConfiguration Class | StarTeam Namespace


VaultCacheRefreshInterval Property

Borland StarTeam SDK for .NET

ServerConfiguration.VaultCacheRefreshInterval Property

[read/write] The server's vault cache refresh interval, in seconds.

public virtual Int32 VaultCacheRefreshInterval {get; set;}

Property Value

The server's vault cache refresh interval, in seconds.

See Also

ServerConfiguration Class | StarTeam Namespace


VaultDirectory Property

Borland StarTeam SDK for .NET

ServerConfiguration.VaultDirectory Property

[read/write] The path to the server's vault directory.

public virtual String VaultDirectory {get; set;}

Property Value

The path to the server's vault directory.

See Also

ServerConfiguration Class | StarTeam Namespace


VaultLockTimeLimit Property

Borland StarTeam SDK for .NET

ServerConfiguration.VaultLockTimeLimit Property

[read/write] The server's vault lock time limit, in seconds.

public virtual Int32 VaultLockTimeLimit {get; set;}

Property Value

The server's vault lock time limit, in seconds.

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration Methods

The methods of the ServerConfiguration class are listed below. For a complete list of ServerConfiguration class members, see the ServerConfiguration Members topic.

Public Instance Methods

Copy | return a copy of this ServerConfiguration instance
Equals | Delegate Equals() to com.starteam.ServerConfiguration.
GetEnabled | Returns true if the specified protocol is enabled.
GetEndPoint | Returns the endpoint for the specified protocol.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the Object passed in is a ServerConfiguration instance, with the same set of values as this ServerConfiguration instance
IsProtocolAvailable | Returns true if the server supports the specified protocol.
SetEnabled | Enable or disable the specified communication procotol.
SetEndPoint | Modifies the specified protocol's endpoint. The endpoint is protocol specific.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.Copy Method

return a copy of this ServerConfiguration instance

public virtual ServerConfiguration Copy();

Return Value

ServerConfiguration a copy of this ServerConfiguration instance

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.Equals Method

Delegate Equals() to com.starteam.ServerConfiguration.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerConfiguration.Equals(obj).

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.GetEnabled Method

Returns true if the specified protocol is enabled.

public virtual bool GetEnabled(
Int32 protocol
);

Parameters

protocol
the protocol identifier

Return Value

true if the specified protocol is enabled.

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.GetEndPoint Method

Returns the endpoint for the specified protocol.

public virtual string GetEndPoint(
Int32 protocol
);

Parameters

protocol
the protocol identifier

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerConfiguration.

public override int GetHashCode();

Return Value

com.starteam.ServerConfiguration.GetHashCode().

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.IsEqualTo Method

returns true if the Object passed in is a ServerConfiguration instance, with the same set of values as this ServerConfiguration instance

public virtual bool IsEqualTo(
ServerConfiguration source
);

Parameters

source
Object another instance of a ServerConfiguration object

Return Value

boolean true if the ServerConfiguration parameter has the same set of values as this one

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.IsProtocolAvailable Method

Returns true if the server supports the specified protocol.

public virtual bool IsProtocolAvailable(
Int32 protocol
);

Parameters

protocol
the protocol identifier

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.SetEnabled Method

Enable or disable the specified communication procotol.

public virtual void SetEnabled(
Int32 protocol,
Boolean enabled
);

Parameters

protocol
the protocol identifier
enabled
true if the protocol should be enabled

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.SetEndPoint Method

Modifies the specified protocol's endpoint. The endpoint is protocol specific.

public virtual void SetEndPoint(
Int32 protocol,
String endpoint
);

Parameters

protocol
the protocol identifier
endpoint
the new endpoint for the specified protocol

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.ToString Method

Delegate ToString() to com.starteam.ServerConfiguration.

public override string ToString();

Return Value

com.starteam.ServerConfiguration.ToString()

See Also

ServerConfiguration Class | StarTeam Namespace


ServerConfiguration.AuthenticationType Class

AuthenticationType used by the server

For a list of all members of this type, see ServerConfiguration.AuthenticationType Members.

System.Object
ServerConfiguration.AuthenticationType

public class ServerConfiguration.AuthenticationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerConfiguration.AuthenticationType Members | StarTeam Namespace


ServerConfiguration.AuthenticationType Members

ServerConfiguration.AuthenticationType overview

Public Static Properties

ALL
MULTI_FACTOR_AUTHENTICATION
PASSWORD_AUTHENTICATION
SINGLE_SIGN_ON_AUTHENTICATION

Public Static Methods

FromID Gets the Authentication Type value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this AuthenticationType Type value.
Name | [read] The ID of this AuthenticationType Type value.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.AuthenticationType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.AuthenticationType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.AuthenticationType.

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


ServerConfiguration.AuthenticationType Properties

The properties of the ServerConfiguration.AuthenticationType class are listed below. For a complete list of ServerConfiguration.AuthenticationType class members, see the ServerConfiguration.AuthenticationType Members topic.

Public Static Properties

ALL
MULTI_FACTOR_AUTHENTICATION
PASSWORD_AUTHENTICATION
SINGLE_SIGN_ON_AUTHENTICATION

Public Instance Properties

ID | [read] The ID of this AuthenticationType Type value.
Name | [read] The ID of this AuthenticationType Type value.

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuthenticationType.ALL Property

public static AuthenticationType[] ALL {get;}

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuthenticationType.ID Property

[read] The ID of this AuthenticationType Type value.

public virtual Int32 ID {get;}

Property Value

The ID of this AuthenticationType Type value.

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


MULTI_FACTOR_AUTHENTICATION Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuthenticationType.MULTI_FACTOR_AUTHENTICATION Property

public static ServerConfiguration.AuthenticationType MULTI_FACTOR_AUTHENTICATION {get;}

Property Value

Multi-Factor authentication using OAuth2 provider (OSP) and Advanced Authentication (AA) server.

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuthenticationType.Name Property

[read] The ID of this AuthenticationType Type value.

public virtual String Name {get;}

Property Value

The ID of this AuthenticationType Type value.

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


PASSWORD_AUTHENTICATION Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuthenticationType.PASSWORD_AUTHENTICATION Property

public static ServerConfiguration.AuthenticationType PASSWORD_AUTHENTICATION {get;}

Property Value

Password based authentication done by StarTeam server.

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


SINGLE_SIGN_ON_AUTHENTICATION Property

Borland StarTeam SDK for .NET

ServerConfiguration.AuthenticationType.SINGLE_SIGN_ON_AUTHENTICATION Property

public static ServerConfiguration.AuthenticationType SINGLE_SIGN_ON_AUTHENTICATION {get;}

Property Value

Single Sign-On authentication using OAuth2 provider (OSP)

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


ServerConfiguration.AuthenticationType Methods

The methods of the ServerConfiguration.AuthenticationType class are listed below. For a complete list of ServerConfiguration.AuthenticationType class members, see the ServerConfiguration.AuthenticationType Members topic.

Public Static Methods

FromID Gets the Authentication Type value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.AuthenticationType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.AuthenticationType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.AuthenticationType.

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


ServerConfiguration.AuthenticationType.Equals Method

Delegate Equals() to com.starteam.ServerConfiguration.AuthenticationType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerConfiguration.AuthenticationType.Equals(obj).

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


ServerConfiguration.AuthenticationType.FromID Method

Gets the Authentication Type value corresponding to the given ID.

public static AuthenticationType FromID(
Int32 id
);

Parameters

id
A Authentication Type ID.

Return Value

The corresponding Database Type value, or null.

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


ServerConfiguration.AuthenticationType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerConfiguration.AuthenticationType.

public override int GetHashCode();

Return Value

com.starteam.ServerConfiguration.AuthenticationType.GetHashCode().

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


ServerConfiguration.AuthenticationType.ToString Method

Delegate ToString() to com.starteam.ServerConfiguration.AuthenticationType.

public override string ToString();

Return Value

com.starteam.ServerConfiguration.AuthenticationType.ToString()

See Also

ServerConfiguration.AuthenticationType Class | StarTeam Namespace


ServerConfiguration.DatabaseType Class

Database type used by the server

For a list of all members of this type, see ServerConfiguration.DatabaseType Members.

System.Object
ServerConfiguration.DatabaseType

public class ServerConfiguration.DatabaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerConfiguration.DatabaseType Members | StarTeam Namespace


ServerConfiguration.DatabaseType Members

ServerConfiguration.DatabaseType overview

Public Static Properties

ALL
ORACLE
POSTGRESQL
SQL_SERVER
UNKNOWN

Public Static Methods

FromID Gets the Database Type value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this Database Type value.
Name | [read] The ID of this Database Type value.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.DatabaseType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.DatabaseType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.DatabaseType.

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ServerConfiguration.DatabaseType Properties

The properties of the ServerConfiguration.DatabaseType class are listed below. For a complete list of ServerConfiguration.DatabaseType class members, see the ServerConfiguration.DatabaseType Members topic.

Public Static Properties

ALL
ORACLE
POSTGRESQL
SQL_SERVER
UNKNOWN

Public Instance Properties

ID | [read] The ID of this Database Type value.
Name | [read] The ID of this Database Type value.

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ServerConfiguration.DatabaseType.ALL Property

public static DatabaseType[] ALL {get;}

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerConfiguration.DatabaseType.ID Property

[read] The ID of this Database Type value.

public virtual Int32 ID {get;}

Property Value

The ID of this Database Type value.

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ServerConfiguration.DatabaseType.Name Property

[read] The ID of this Database Type value.

public virtual String Name {get;}

Property Value

The ID of this Database Type value.

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ORACLE Property

Borland StarTeam SDK for .NET

ServerConfiguration.DatabaseType.ORACLE Property

public static ServerConfiguration.DatabaseType ORACLE {get;}

Property Value

Database type is Oracle

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


POSTGRESQL Property

Borland StarTeam SDK for .NET

ServerConfiguration.DatabaseType.POSTGRESQL Property

public static ServerConfiguration.DatabaseType POSTGRESQL {get;}

Property Value

Database type is PostgreSQL

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


SQL_SERVER Property

Borland StarTeam SDK for .NET

ServerConfiguration.DatabaseType.SQL_SERVER Property

public static ServerConfiguration.DatabaseType SQL_SERVER {get;}

Property Value

Database type is SQL Server

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

ServerConfiguration.DatabaseType.UNKNOWN Property

public static ServerConfiguration.DatabaseType UNKNOWN {get;}

Property Value

Unknown database type

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ServerConfiguration.DatabaseType Methods

The methods of the ServerConfiguration.DatabaseType class are listed below. For a complete list of ServerConfiguration.DatabaseType class members, see the ServerConfiguration.DatabaseType Members topic.

Public Static Methods

FromID Gets the Database Type value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.DatabaseType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.DatabaseType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.DatabaseType.

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ServerConfiguration.DatabaseType.Equals Method

Delegate Equals() to com.starteam.ServerConfiguration.DatabaseType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerConfiguration.DatabaseType.Equals(obj).

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ServerConfiguration.DatabaseType.FromID Method

Gets the Database Type value corresponding to the given ID.

public static DatabaseType FromID(
Int32 id
);

Parameters

id
A Database Type ID.

Return Value

The corresponding Database Type value, or null.

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ServerConfiguration.DatabaseType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerConfiguration.DatabaseType.

public override int GetHashCode();

Return Value

com.starteam.ServerConfiguration.DatabaseType.GetHashCode().

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ServerConfiguration.DatabaseType.ToString Method

Delegate ToString() to com.starteam.ServerConfiguration.DatabaseType.

public override string ToString();

Return Value

com.starteam.ServerConfiguration.DatabaseType.ToString()

See Also

ServerConfiguration.DatabaseType Class | StarTeam Namespace


ServerConfiguration.DirectoryServiceSecurityType Class

Security type used while connecting to Directory service. Starting 15.1, support for TLS is added in addition to SSL. (eUnsecure = 0, eSSL = 1, eTLS =2 )

For a list of all members of this type, see ServerConfiguration.DirectoryServiceSecurityType Members.

System.Object
ServerConfiguration.DirectoryServiceSecurityType

public class ServerConfiguration.DirectoryServiceSecurityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerConfiguration.DirectoryServiceSecurityType Members | StarTeam Namespace


ServerConfiguration.DirectoryServiceSecurityType Members

ServerConfiguration.DirectoryServiceSecurityType overview

Public Static Properties

ALL
SSL
TLS
UNSECURE

Public Static Methods

FromID Gets the Directory service's security type value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this directory service's security type.
SecurityType | [read] security type.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.DirectoryServiceSecurityType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.DirectoryServiceSecurityType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.DirectoryServiceSecurityType.

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


ServerConfiguration.DirectoryServiceSecurityType Properties

The properties of the ServerConfiguration.DirectoryServiceSecurityType class are listed below. For a complete list of ServerConfiguration.DirectoryServiceSecurityType class members, see the ServerConfiguration.DirectoryServiceSecurityType Members topic.

Public Static Properties

ALL
SSL
TLS
UNSECURE

Public Instance Properties

ID | [read] The ID of this directory service's security type.
SecurityType | [read] security type.

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceSecurityType.ALL Property

public static DirectoryServiceSecurityType[] ALL {get;}

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceSecurityType.ID Property

[read] The ID of this directory service's security type.

public virtual Int32 ID {get;}

Property Value

The ID of this directory service's security type.

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


SecurityType Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceSecurityType.SecurityType Property

[read] security type.

public virtual String SecurityType {get;}

Property Value

security type.

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


SSL Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceSecurityType.SSL Property

public static ServerConfiguration.DirectoryServiceSecurityType SSL {get;}

Property Value

SSL connection to directory service.

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


TLS Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceSecurityType.TLS Property

public static ServerConfiguration.DirectoryServiceSecurityType TLS {get;}

Property Value

TLS connection to directory service.

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


UNSECURE Property

Borland StarTeam SDK for .NET

ServerConfiguration.DirectoryServiceSecurityType.UNSECURE Property

public static ServerConfiguration.DirectoryServiceSecurityType UNSECURE {get;}

Property Value

Unsecure connection to directory service.

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


ServerConfiguration.DirectoryServiceSecurityType Methods

The methods of the ServerConfiguration.DirectoryServiceSecurityType class are listed below. For a complete list of ServerConfiguration.DirectoryServiceSecurityType class members, see the ServerConfiguration.DirectoryServiceSecurityType Members topic.

Public Static Methods

FromID Gets the Directory service's security type value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.DirectoryServiceSecurityType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.DirectoryServiceSecurityType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.DirectoryServiceSecurityType.

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


ServerConfiguration.DirectoryServiceSecurityType.Equals Method

Delegate Equals() to com.starteam.ServerConfiguration.DirectoryServiceSecurityType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerConfiguration.DirectoryServiceSecurityType.Equals(obj).

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


ServerConfiguration.DirectoryServiceSecurityType.FromID Method

Gets the Directory service's security type value corresponding to the given ID.

public static DirectoryServiceSecurityType FromID(
Int32 id
);

Parameters

id
A Directory service's security type ID.

Return Value

The corresponding Directory service's security type value, or null.

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


ServerConfiguration.DirectoryServiceSecurityType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerConfiguration.DirectoryServiceSecurityType.

public override int GetHashCode();

Return Value

com.starteam.ServerConfiguration.DirectoryServiceSecurityType.GetHashCode().

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


ServerConfiguration.DirectoryServiceSecurityType.ToString Method

Delegate ToString() to com.starteam.ServerConfiguration.DirectoryServiceSecurityType.

public override string ToString();

Return Value

com.starteam.ServerConfiguration.DirectoryServiceSecurityType.ToString()

See Also

ServerConfiguration.DirectoryServiceSecurityType Class | StarTeam Namespace


ServerConfiguration.NotificationType Class

Notification type used by the server

For a list of all members of this type, see ServerConfiguration.NotificationType Members.

System.Object
ServerConfiguration.NotificationType

public class ServerConfiguration.NotificationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerConfiguration.NotificationType Members | StarTeam Namespace


ServerConfiguration.NotificationType Members

ServerConfiguration.NotificationType overview

Public Static Properties

ALL
BOTH
EMAIL
SYS_TRAY

Public Static Methods

FromID Gets the NotificationType Type value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this Database Type value.
Name | [read] name

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.NotificationType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.NotificationType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.NotificationType.

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


ServerConfiguration.NotificationType Properties

The properties of the ServerConfiguration.NotificationType class are listed below. For a complete list of ServerConfiguration.NotificationType class members, see the ServerConfiguration.NotificationType Members topic.

Public Static Properties

ALL
BOTH
EMAIL
SYS_TRAY

Public Instance Properties

ID | [read] The ID of this Database Type value.
Name | [read] name

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotificationType.ALL Property

public static NotificationType[] ALL {get;}

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


BOTH Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotificationType.BOTH Property

public static ServerConfiguration.NotificationType BOTH {get;}

Property Value

Both System tray and email notification

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


EMAIL Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotificationType.EMAIL Property

public static ServerConfiguration.NotificationType EMAIL {get;}

Property Value

Email notification

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotificationType.ID Property

[read] The ID of this Database Type value.

public virtual Int32 ID {get;}

Property Value

The ID of this Database Type value.

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotificationType.Name Property

[read] name

public virtual String Name {get;}

Property Value

name

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


SYS_TRAY Property

Borland StarTeam SDK for .NET

ServerConfiguration.NotificationType.SYS_TRAY Property

public static ServerConfiguration.NotificationType SYS_TRAY {get;}

Property Value

System tray notification

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


ServerConfiguration.NotificationType Methods

The methods of the ServerConfiguration.NotificationType class are listed below. For a complete list of ServerConfiguration.NotificationType class members, see the ServerConfiguration.NotificationType Members topic.

Public Static Methods

FromID Gets the NotificationType Type value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.NotificationType.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.NotificationType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerConfiguration.NotificationType.

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


ServerConfiguration.NotificationType.Equals Method

Delegate Equals() to com.starteam.ServerConfiguration.NotificationType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerConfiguration.NotificationType.Equals(obj).

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


ServerConfiguration.NotificationType.FromID Method

Gets the NotificationType Type value corresponding to the given ID.

public static NotificationType FromID(
Int32 id
);

Parameters

id
A NotificationType Type ID.

Return Value

The corresponding NotificationType Type value, or null.

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


ServerConfiguration.NotificationType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerConfiguration.NotificationType.

public override int GetHashCode();

Return Value

com.starteam.ServerConfiguration.NotificationType.GetHashCode().

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


ServerConfiguration.NotificationType.ToString Method

Delegate ToString() to com.starteam.ServerConfiguration.NotificationType.

public override string ToString();

Return Value

com.starteam.ServerConfiguration.NotificationType.ToString()

See Also

ServerConfiguration.NotificationType Class | StarTeam Namespace


ServerConfiguration.WebCacheServerConfiguration Class

Server Configurations exposed via the Web Cache Object Model

For a list of all members of this type, see ServerConfiguration.WebCacheServerConfiguration Members.

System.Object
ServerConfiguration.WebCacheServerConfiguration

public class ServerConfiguration.WebCacheServerConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerConfiguration.WebCacheServerConfiguration Members | StarTeam Namespace


ServerConfiguration.WebCacheServerConfiguration Members

ServerConfiguration.WebCacheServerConfiguration overview

Public Instance Properties

AlmServiceUrl | [read/write] A string form of the URL used to locate the ALM Trace Service.
RESTServicePort | [read] the search service port

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.WebCacheServerConfiguration.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.WebCacheServerConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the given server configuration options. Note that this command requires Administrative privilege
ToString | Delegate ToString() to com.starteam.ServerConfiguration.WebCacheServerConfiguration.

See Also

ServerConfiguration.WebCacheServerConfiguration Class | StarTeam Namespace


ServerConfiguration.WebCacheServerConfiguration Properties

The properties of the ServerConfiguration.WebCacheServerConfiguration class are listed below. For a complete list of ServerConfiguration.WebCacheServerConfiguration class members, see the ServerConfiguration.WebCacheServerConfiguration Members topic.

Public Instance Properties

AlmServiceUrl | [read/write] A string form of the URL used to locate the ALM Trace Service.
RESTServicePort | [read] the search service port

See Also

ServerConfiguration.WebCacheServerConfiguration Class | StarTeam Namespace


AlmServiceUrl Property

Borland StarTeam SDK for .NET

ServerConfiguration.WebCacheServerConfiguration.AlmServiceUrl Property

[read/write] A string form of the URL used to locate the ALM Trace Service.

public virtual String AlmServiceUrl {get; set;}

Property Value

A string form of the URL used to locate the ALM Trace Service.

See Also

ServerConfiguration.WebCacheServerConfiguration Class | StarTeam Namespace


RESTServicePort Property

Borland StarTeam SDK for .NET

ServerConfiguration.WebCacheServerConfiguration.RESTServicePort Property

[read] the search service port

public virtual Int32 RESTServicePort {get;}

Property Value

the search service port

See Also

ServerConfiguration.WebCacheServerConfiguration Class | StarTeam Namespace


ServerConfiguration.WebCacheServerConfiguration Methods

The methods of the ServerConfiguration.WebCacheServerConfiguration class are listed below. For a complete list of ServerConfiguration.WebCacheServerConfiguration class members, see the ServerConfiguration.WebCacheServerConfiguration Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ServerConfiguration.WebCacheServerConfiguration.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerConfiguration.WebCacheServerConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the given server configuration options. Note that this command requires Administrative privilege
ToString | Delegate ToString() to com.starteam.ServerConfiguration.WebCacheServerConfiguration.

See Also

ServerConfiguration.WebCacheServerConfiguration Class | StarTeam Namespace


ServerConfiguration.WebCacheServerConfiguration.Equals Method

Delegate Equals() to com.starteam.ServerConfiguration.WebCacheServerConfiguration.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerConfiguration.WebCacheServerConfiguration.Equals(obj).

See Also

ServerConfiguration.WebCacheServerConfiguration Class | StarTeam Namespace


ServerConfiguration.WebCacheServerConfiguration.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerConfiguration.WebCacheServerConfiguration.

public override int GetHashCode();

Return Value

com.starteam.ServerConfiguration.WebCacheServerConfiguration.GetHashCode().

See Also

ServerConfiguration.WebCacheServerConfiguration Class | StarTeam Namespace


ServerConfiguration.WebCacheServerConfiguration.Save Method

Saves the given server configuration options. Note that this command requires Administrative privilege

public virtual void Save();

See Also

ServerConfiguration.WebCacheServerConfiguration Class | StarTeam Namespace | ServerConfiguration


ServerConfiguration.WebCacheServerConfiguration.ToString Method

Delegate ToString() to com.starteam.ServerConfiguration.WebCacheServerConfiguration.

public override string ToString();

Return Value

com.starteam.ServerConfiguration.WebCacheServerConfiguration.ToString()

See Also

ServerConfiguration.WebCacheServerConfiguration Class | StarTeam Namespace


ServerInfo Class

Description: Server Configuration Parameters including the MPX Profile, and Cache Agent Configuration Applications that intend to use the Cache Agent should provide connectivity information through this class.

For a list of all members of this type, see ServerInfo Members.

System.Object
ServerInfo

public class ServerInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerInfo Members | StarTeam Namespace


ServerInfo Members

ServerInfo overview

Public Static Properties

DEFAULT_PORT

Public Instance Constructors

ServerInfo Overloaded. Initializes a new instance of the ServerInfo class.

Public Instance Properties

AutoLocateCacheAgent | [read/write] true to autolocate a cache agent, or false to use the cache agent at the specified address and port.
ConnectionType | [read/write] the connection type to be used.
DebugString | [read] a debug string representation of this server info.
Description | [read/write] the description for this server info entry.
DisableSingleSignOnAuthentication | [write] When Single Sign-On authentication (SSO) is enabled on the server, this client side option allows the user revert back to using regular password based authentication to StarTeam server.
EnableCacheAgentForFileContent | [read/write] boolean true to use a cache agent for file content checkout false to force all checkouts to use the StarTeam server directly.
EnableCacheAgentForObjectProperties | [read/write] boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server
Encryption | [read/write] the EncryptionAlgorithm algorithm to use for connections to the server.
Host | [read/write] the host name for the server info.
IsCompression | [read/write] true if compression is to be used when communicating with the server.
IsSingleSignOnAuthenticationDisabled | [read] true, if SSO authentication has been disabled on the client side, false if not.
MPXCacheAgentAddress | [read/write] The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.
MPXCacheAgentPort | [read/write] The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.
MPXCacheAgentThreadCount | [read/write] The number of threads used by the MPX cache agent to fetch file content. The default value is 3.
MPXProfileName | [read/write] The name of the MPX profile to be used when connecting to this server, or the empty string if MPX should not be enabled.
Owner | [read] the owning ServerInfoCollection.
Password | [read/write] the specified password
Port | [read/write] the protocol endpoint for the server info.
UserName | [read/write] the specified user name

Public Instance Methods

Copy | return a copy of this ServerInfo
EnableAnonymousImpersonation | turn on anonymous impersonation. when on, artifact cache users can be specified as impersonation targets without having been explicitly logged on.
EnableMPXImpersonation | turn on MPX impersonation for the 'cloud'; i.e. a controlled, hosted StarTeam environment. in this mode, this instance of the running ArtifactCache assumes that it is the ONLY instance of an SDK targeting a specific StarTeam server. The SDK will assume that it does not need to rely upon MPX for refreshes, since all changes will emanate directly from this Artifact Cache. The SDK has no way of verifying the authenticity of this assumnption, and will accept it at face value.
Equals | Delegate Equals() to com.starteam.ServerInfo.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerInfo.

See Also

ServerInfo Class | StarTeam Namespace


ServerInfo Constructor

Construct a ServerInfo instance

Overload List

Construct a ServerInfo instance

public ServerInfo();

Create a copy of a ServerInfo from another one

public ServerInfo(ServerInfo);

See Also

ServerInfo Class | StarTeam Namespace


ServerInfo Constructor ()

Construct a ServerInfo instance

public ServerInfo();

See Also

ServerInfo Class | StarTeam Namespace | ServerInfo Constructor Overload List


ServerInfo Constructor (ServerInfo)

Create a copy of a ServerInfo from another one

public ServerInfo(
ServerInfo copyFrom
);

Parameters

copyFrom
ServerInfo a copy of a ServerInfo

See Also

ServerInfo Class | StarTeam Namespace | ServerInfo Constructor Overload List


ServerInfo Properties

The properties of the ServerInfo class are listed below. For a complete list of ServerInfo class members, see the ServerInfo Members topic.

Public Static Properties

DEFAULT_PORT

Public Instance Properties

AutoLocateCacheAgent | [read/write] true to autolocate a cache agent, or false to use the cache agent at the specified address and port.
ConnectionType | [read/write] the connection type to be used.
DebugString | [read] a debug string representation of this server info.
Description | [read/write] the description for this server info entry.
DisableSingleSignOnAuthentication | [write] When Single Sign-On authentication (SSO) is enabled on the server, this client side option allows the user revert back to using regular password based authentication to StarTeam server.
EnableCacheAgentForFileContent | [read/write] boolean true to use a cache agent for file content checkout false to force all checkouts to use the StarTeam server directly.
EnableCacheAgentForObjectProperties | [read/write] boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server
Encryption | [read/write] the EncryptionAlgorithm algorithm to use for connections to the server.
Host | [read/write] the host name for the server info.
IsCompression | [read/write] true if compression is to be used when communicating with the server.
IsSingleSignOnAuthenticationDisabled | [read] true, if SSO authentication has been disabled on the client side, false if not.
MPXCacheAgentAddress | [read/write] The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.
MPXCacheAgentPort | [read/write] The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.
MPXCacheAgentThreadCount | [read/write] The number of threads used by the MPX cache agent to fetch file content. The default value is 3.
MPXProfileName | [read/write] The name of the MPX profile to be used when connecting to this server, or the empty string if MPX should not be enabled.
Owner | [read] the owning ServerInfoCollection.
Password | [read/write] the specified password
Port | [read/write] the protocol endpoint for the server info.
UserName | [read/write] the specified user name

See Also

ServerInfo Class | StarTeam Namespace


AutoLocateCacheAgent Property

Borland StarTeam SDK for .NET

ServerInfo.AutoLocateCacheAgent Property

[read/write] true to autolocate a cache agent, or false to use the cache agent at the specified address and port.

public virtual Boolean AutoLocateCacheAgent {get; set;}

Property Value

true to autolocate a cache agent, or false to use the cache agent at the specified address and port.

See Also

ServerInfo Class | StarTeam Namespace


ConnectionType Property

Borland StarTeam SDK for .NET

ServerInfo.ConnectionType Property

[read/write] the connection type to be used.

public virtual Int32 ConnectionType {get; set;}

Property Value

the connection type to be used.

See Also

ServerInfo Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

ServerInfo.DebugString Property

[read] a debug string representation of this server info.

public virtual String DebugString {get;}

Property Value

a debug string representation of this server info.

See Also

ServerInfo Class | StarTeam Namespace


DEFAULT_PORT Property

Borland StarTeam SDK for .NET

ServerInfo.DEFAULT_PORT Property

public static Int32 DEFAULT_PORT {get;}

See Also

ServerInfo Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

ServerInfo.Description Property

[read/write] the description for this server info entry.

public virtual String Description {get; set;}

Property Value

the description for this server info entry.

See Also

ServerInfo Class | StarTeam Namespace


DisableSingleSignOnAuthentication Property

Borland StarTeam SDK for .NET

ServerInfo.DisableSingleSignOnAuthentication Property

[write] When Single Sign-On authentication (SSO) is enabled on the server, this client side option allows the user revert back to using regular password based authentication to StarTeam server.

public virtual Boolean DisableSingleSignOnAuthentication {set;}

Property Value

When Single Sign-On authentication (SSO) is enabled on the server, this client side option allows the user revert back to using regular password based authentication to StarTeam server.

See Also

ServerInfo Class | StarTeam Namespace


EnableCacheAgentForFileContent Property

Borland StarTeam SDK for .NET

ServerInfo.EnableCacheAgentForFileContent Property

[read/write] boolean true to use a cache agent for file content checkout false to force all checkouts to use the StarTeam server directly.

public virtual Boolean EnableCacheAgentForFileContent {get; set;}

Property Value

boolean true to use a cache agent for file content checkout false to force all checkouts to use the StarTeam server directly.

See Also

ServerInfo Class | StarTeam Namespace


EnableCacheAgentForObjectProperties Property

Borland StarTeam SDK for .NET

ServerInfo.EnableCacheAgentForObjectProperties Property

[read/write] boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server

public virtual Boolean EnableCacheAgentForObjectProperties {get; set;}

Property Value

boolean true to fetch object properties from a cache agent false to fetch all properties from the star team server

See Also

ServerInfo Class | StarTeam Namespace


Encryption Property

Borland StarTeam SDK for .NET

ServerInfo.Encryption Property

[read/write] the EncryptionAlgorithm algorithm to use for connections to the server.

public virtual Server.EncryptionAlgorithm Encryption {get; set;}

Property Value

the EncryptionAlgorithm algorithm to use for connections to the server.

See Also

ServerInfo Class | StarTeam Namespace


Host Property

Borland StarTeam SDK for .NET

ServerInfo.Host Property

[read/write] the host name for the server info.

public virtual String Host {get; set;}

Property Value

the host name for the server info.

See Also

ServerInfo Class | StarTeam Namespace


IsCompression Property

Borland StarTeam SDK for .NET

ServerInfo.IsCompression Property

[read/write] true if compression is to be used when communicating with the server.

public virtual Boolean IsCompression {get; set;}

Property Value

true if compression is to be used when communicating with the server.

See Also

ServerInfo Class | StarTeam Namespace


IsSingleSignOnAuthenticationDisabled Property

Borland StarTeam SDK for .NET

ServerInfo.IsSingleSignOnAuthenticationDisabled Property

[read] true, if SSO authentication has been disabled on the client side, false if not.

public virtual Boolean IsSingleSignOnAuthenticationDisabled {get;}

Property Value

true, if SSO authentication has been disabled on the client side, false if not.

See Also

ServerInfo Class | StarTeam Namespace


MPXCacheAgentAddress Property

Borland StarTeam SDK for .NET

ServerInfo.MPXCacheAgentAddress Property

[read/write] The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.

public virtual String MPXCacheAgentAddress {get; set;}

Property Value

The host address of the MPX cache agent. Note that if checkouts via the MPX cache agent are enabled, but no host address is explicitly specified, then an attempt is made to automatically locate the nearest cache agent on the network.

See Also

ServerInfo Class | StarTeam Namespace


MPXCacheAgentPort Property

Borland StarTeam SDK for .NET

ServerInfo.MPXCacheAgentPort Property

[read/write] The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.

public virtual Int32 MPXCacheAgentPort {get; set;}

Property Value

The port number of the MPX cache agent. Note that if host address is specified but no port number is specified, then the default cache agent port is assumed.

See Also

ServerInfo Class | StarTeam Namespace


MPXCacheAgentThreadCount Property

Borland StarTeam SDK for .NET

ServerInfo.MPXCacheAgentThreadCount Property

[read/write] The number of threads used by the MPX cache agent to fetch file content. The default value is 3.

public virtual Int32 MPXCacheAgentThreadCount {get; set;}

Property Value

The number of threads used by the MPX cache agent to fetch file content. The default value is 3.

See Also

ServerInfo Class | StarTeam Namespace


MPXProfileName Property

Borland StarTeam SDK for .NET

ServerInfo.MPXProfileName Property

[read/write] The name of the MPX profile to be used when connecting to this server, or the empty string if MPX should not be enabled.

public virtual String MPXProfileName {get; set;}

Property Value

The name of the MPX profile to be used when connecting to this server, or the empty string if MPX should not be enabled.

See Also

ServerInfo Class | StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

ServerInfo.Owner Property

[read] the owning ServerInfoCollection.

public virtual ServerInfoCollection Owner {get;}

Property Value

the owning ServerInfoCollection.

See Also

ServerInfo Class | StarTeam Namespace


Password Property

Borland StarTeam SDK for .NET

ServerInfo.Password Property

[read/write] the specified password

public virtual String Password {get; set;}

Property Value

the specified password

See Also

ServerInfo Class | StarTeam Namespace


Port Property

Borland StarTeam SDK for .NET

ServerInfo.Port Property

[read/write] the protocol endpoint for the server info.

public virtual Int32 Port {get; set;}

Property Value

the protocol endpoint for the server info.

See Also

ServerInfo Class | StarTeam Namespace


UserName Property

Borland StarTeam SDK for .NET

ServerInfo.UserName Property

[read/write] the specified user name

public virtual String UserName {get; set;}

Property Value

the specified user name

See Also

ServerInfo Class | StarTeam Namespace


ServerInfo Methods

The methods of the ServerInfo class are listed below. For a complete list of ServerInfo class members, see the ServerInfo Members topic.

Public Instance Methods

Copy | return a copy of this ServerInfo
EnableAnonymousImpersonation | turn on anonymous impersonation. when on, artifact cache users can be specified as impersonation targets without having been explicitly logged on.
EnableMPXImpersonation | turn on MPX impersonation for the 'cloud'; i.e. a controlled, hosted StarTeam environment. in this mode, this instance of the running ArtifactCache assumes that it is the ONLY instance of an SDK targeting a specific StarTeam server. The SDK will assume that it does not need to rely upon MPX for refreshes, since all changes will emanate directly from this Artifact Cache. The SDK has no way of verifying the authenticity of this assumnption, and will accept it at face value.
Equals | Delegate Equals() to com.starteam.ServerInfo.
GetHashCode | Delegate GetHashCode() to com.starteam.ServerInfo.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ServerInfo.

See Also

ServerInfo Class | StarTeam Namespace


ServerInfo.Copy Method

return a copy of this ServerInfo

public virtual ServerInfo Copy();

Return Value

ServerInfo a copy of this ServerInfo

See Also

ServerInfo Class | StarTeam Namespace


ServerInfo.EnableAnonymousImpersonation Method

turn on anonymous impersonation. when on, artifact cache users can be specified as impersonation targets without having been explicitly logged on.

public virtual void EnableAnonymousImpersonation();

See Also

ServerInfo Class | StarTeam Namespace


ServerInfo.EnableMPXImpersonation Method

turn on MPX impersonation for the 'cloud'; i.e. a controlled, hosted StarTeam environment. in this mode, this instance of the running ArtifactCache assumes that it is the ONLY instance of an SDK targeting a specific StarTeam server. The SDK will assume that it does not need to rely upon MPX for refreshes, since all changes will emanate directly from this Artifact Cache. The SDK has no way of verifying the authenticity of this assumnption, and will accept it at face value.

public virtual void EnableMPXImpersonation();

See Also

ServerInfo Class | StarTeam Namespace


ServerInfo.Equals Method

Delegate Equals() to com.starteam.ServerInfo.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ServerInfo.Equals(obj).

See Also

ServerInfo Class | StarTeam Namespace


ServerInfo.GetHashCode Method

Delegate GetHashCode() to com.starteam.ServerInfo.

public override int GetHashCode();

Return Value

com.starteam.ServerInfo.GetHashCode().

See Also

ServerInfo Class | StarTeam Namespace


ServerInfo.ToString Method

Delegate ToString() to com.starteam.ServerInfo.

public override string ToString();

Return Value

com.starteam.ServerInfo.ToString()

See Also

ServerInfo Class | StarTeam Namespace


ServerInfoCollection Class

Collection of Server configuration parameters

For a list of all members of this type, see ServerInfoCollection Members.

System.Object
StarTeamCollection
ServerInfoCollection

public class ServerInfoCollection : StarTeamCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerInfoCollection Members | StarTeam Namespace


ServerInfoCollection Members

ServerInfoCollection overview

Public Static Properties

DefaultFile [read] The default location that StarTeam applications should use for the server list. The default file name is "starteam-servers.xml".

Public Instance Constructors

ServerInfoCollection Overloaded. Initializes a new instance of the ServerInfoCollection class.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Find a ServerInfo by description.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
SaveTo | Writes the server list out to the specified file.
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

ServerInfoCollection Class | StarTeam Namespace


ServerInfoCollection Constructor

Start with an empty server info collection

Overload List

Start with an empty server info collection

public ServerInfoCollection();

Loads the server list from the specified file. This will throw an exception if there are any problems reading the file or if the file is not a properly formatted server list file.

public ServerInfoCollection(FileInfo);

See Also

ServerInfoCollection Class | StarTeam Namespace


ServerInfoCollection Constructor ()

Start with an empty server info collection

public ServerInfoCollection();

See Also

ServerInfoCollection Class | StarTeam Namespace | ServerInfoCollection Constructor Overload List


ServerInfoCollection Constructor (FileInfo)

Loads the server list from the specified file. This will throw an exception if there are any problems reading the file or if the file is not a properly formatted server list file.

public ServerInfoCollection(
FileInfo file
);

Parameters

file
the from which to load the server list.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ServerInfoCollection Class | StarTeam Namespace | ServerInfoCollection Constructor Overload List


ServerInfoCollection Properties

The properties of the ServerInfoCollection class are listed below. For a complete list of ServerInfoCollection class members, see the ServerInfoCollection Members topic.

Public Static Properties

DefaultFile [read] The default location that StarTeam applications should use for the server list. The default file name is "starteam-servers.xml".

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

See Also

ServerInfoCollection Class | StarTeam Namespace


DefaultFile Property

Borland StarTeam SDK for .NET

ServerInfoCollection.DefaultFile Property

[read] The default location that StarTeam applications should use for the server list. The default file name is "starteam-servers.xml".

public static FileInfo DefaultFile {get;}

Property Value

The default location that StarTeam applications should use for the server list. The default file name is "starteam-servers.xml".

See Also

ServerInfoCollection Class | StarTeam Namespace


ServerInfoCollection Methods

The methods of the ServerInfoCollection class are listed below. For a complete list of ServerInfoCollection class members, see the ServerInfoCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Find a ServerInfo by description.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
SaveTo | Writes the server list out to the specified file.
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

ServerInfoCollection Class | StarTeam Namespace


ServerInfoCollection.Find Method

Find a ServerInfo by description.

public virtual ServerInfo Find(
String description
);

Parameters

description
the description to match

Return Value

a ServerInfo object with the given description, or null

See Also

ServerInfoCollection Class | StarTeam Namespace


ServerInfoCollection.SaveTo Method

Writes the server list out to the specified file.

public virtual void SaveTo(
FileInfo file
);

Parameters

file
the file to save the list to

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ServerInfoCollection Class | StarTeam Namespace


Share Class

This class represents the share tree of an item

For a list of all members of this type, see Share Members.

System.Object
TypedResource
LiveObject
TrackedObject
Share

public class Share : TrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share Members | StarTeam Namespace


Share Members

Share overview

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChildShares | [read] an array of Shares that are direct children of this Share, or an empty array if there are none.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy | [read] the User who deleted this item, only available on server versions 5.2 and higher.
DeletedTime | [read] the DeletedTime of this item, only available on server versions 5.2 and higher.
DerivedCount | [read] the number of shares directly derived from this item.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] the revision number in dot notation form.
EndModifiedTime | [read] the EndModifiedTime of this item, only available on server versions 5.2 and higher.
FolderItemID | [read] the Item ID of the referenced Item's parent Folder.
FolderPath | [read] the folder path of the referenced Item's parent Folder.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDeleted | [read] true if the Item has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsFirstOfItsBranch | [read] true if this share is the first share of its branch; false if its parent share (or an ancestor share) is on the same branch.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsRelated | [read] true if this item contains the revision queried by Item.getReferences() in its history.
IsViewDeleted | [read] true if the item's View has been deleted.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentShare | [read] the parent of this Share, or null if this is the root of the share tree.
Project | [read] the project that contains this reference.
ProjectName | [read] the containing Project's name.
Properties | [read] Collection of Share properties
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
View | [read] the View for this share, or NULL if the View has been deleted
ViewPath | [read] the View path (in this format: "parent\child\grandchild...").
VMID | [read] the shared ViewMember's VMID.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetAttachedLabels |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetHistory |
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

Share Class | StarTeam Namespace


Share Properties

The properties of the Share class are listed below. For a complete list of Share class members, see the Share Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChildShares | [read] an array of Shares that are direct children of this Share, or an empty array if there are none.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy | [read] the User who deleted this item, only available on server versions 5.2 and higher.
DeletedTime | [read] the DeletedTime of this item, only available on server versions 5.2 and higher.
DerivedCount | [read] the number of shares directly derived from this item.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] the revision number in dot notation form.
EndModifiedTime | [read] the EndModifiedTime of this item, only available on server versions 5.2 and higher.
FolderItemID | [read] the Item ID of the referenced Item's parent Folder.
FolderPath | [read] the folder path of the referenced Item's parent Folder.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDeleted | [read] true if the Item has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsFirstOfItsBranch | [read] true if this share is the first share of its branch; false if its parent share (or an ancestor share) is on the same branch.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsRelated | [read] true if this item contains the revision queried by Item.getReferences() in its history.
IsViewDeleted | [read] true if the item's View has been deleted.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentShare | [read] the parent of this Share, or null if this is the root of the share tree.
Project | [read] the project that contains this reference.
ProjectName | [read] the containing Project's name.
Properties | [read] Collection of Share properties
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
View | [read] the View for this share, or NULL if the View has been deleted
ViewPath | [read] the View path (in this format: "parent\child\grandchild...").
VMID | [read] the shared ViewMember's VMID.

See Also

Share Class | StarTeam Namespace


ChildShares Property

Borland StarTeam SDK for .NET

Share.ChildShares Property

[read] an array of Shares that are direct children of this Share, or an empty array if there are none.

public virtual Share[] ChildShares {get;}

Property Value

an array of Shares that are direct children of this Share, or an empty array if there are none.

See Also

Share Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Share.DeletedBy Property

[read] the User who deleted this item, only available on server versions 5.2 and higher.

public virtual User DeletedBy {get;}

Property Value

the User who deleted this item, only available on server versions 5.2 and higher.

See Also

Share Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Share.DeletedTime Property

[read] the DeletedTime of this item, only available on server versions 5.2 and higher.

public virtual DateTime DeletedTime {get;}

Property Value

the DeletedTime of this item, only available on server versions 5.2 and higher.

See Also

Share Class | StarTeam Namespace


DerivedCount Property

Borland StarTeam SDK for .NET

Share.DerivedCount Property

[read] the number of shares directly derived from this item.

public virtual Int32 DerivedCount {get;}

Property Value

the number of shares directly derived from this item.

See Also

Share Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Share.DotNotation Property

[read] the revision number in dot notation form.

public virtual DotNotation DotNotation {get;}

Property Value

the revision number in dot notation form.

See Also

Share Class | StarTeam Namespace


EndModifiedTime Property

Borland StarTeam SDK for .NET

Share.EndModifiedTime Property

[read] the EndModifiedTime of this item, only available on server versions 5.2 and higher.

public virtual DateTime EndModifiedTime {get;}

Property Value

the EndModifiedTime of this item, only available on server versions 5.2 and higher.

See Also

Share Class | StarTeam Namespace


FolderItemID Property

Borland StarTeam SDK for .NET

Share.FolderItemID Property

[read] the Item ID of the referenced Item's parent Folder.

public virtual Int32 FolderItemID {get;}

Property Value

the Item ID of the referenced Item's parent Folder.

See Also

Share Class | StarTeam Namespace


FolderPath Property

Borland StarTeam SDK for .NET

Share.FolderPath Property

[read] the folder path of the referenced Item's parent Folder.

public virtual String FolderPath {get;}

Property Value

the folder path of the referenced Item's parent Folder.

See Also

Share Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Share.IsDeleted Property

[read] true if the Item has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if the Item has been deleted.

See Also

Share Class | StarTeam Namespace


IsFirstOfItsBranch Property

Borland StarTeam SDK for .NET

Share.IsFirstOfItsBranch Property

[read] true if this share is the first share of its branch; false if its parent share (or an ancestor share) is on the same branch.

public virtual Boolean IsFirstOfItsBranch {get;}

Property Value

true if this share is the first share of its branch; false if its parent share (or an ancestor share) is on the same branch.

See Also

Share Class | StarTeam Namespace


IsRelated Property

Borland StarTeam SDK for .NET

Share.IsRelated Property

[read] true if this item contains the revision queried by Item.getReferences() in its history.

public virtual Boolean IsRelated {get;}

Property Value

true if this item contains the revision queried by Item.getReferences() in its history.

See Also

Share Class | StarTeam Namespace


IsViewDeleted Property

Borland StarTeam SDK for .NET

Share.IsViewDeleted Property

[read] true if the item's View has been deleted.

public virtual Boolean IsViewDeleted {get;}

Property Value

true if the item's View has been deleted.

See Also

Share Class | StarTeam Namespace


ParentShare Property

Borland StarTeam SDK for .NET

Share.ParentShare Property

[read] the parent of this Share, or null if this is the root of the share tree.

public virtual Share ParentShare {get;}

Property Value

the parent of this Share, or null if this is the root of the share tree.

See Also

Share Class | StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

Share.Project Property

[read] the project that contains this reference.

public virtual Project Project {get;}

Property Value

the project that contains this reference.

See Also

Share Class | StarTeam Namespace


ProjectName Property

Borland StarTeam SDK for .NET

Share.ProjectName Property

[read] the containing Project's name.

public virtual String ProjectName {get;}

Property Value

the containing Project's name.

See Also

Share Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Share.Properties Property

[read] Collection of Share properties

public virtual Share.Type.PropertyCollection Properties {get;}

Property Value

Collection of Share properties

See Also

Share Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Share.View Property

[read] the View for this share, or NULL if the View has been deleted

public virtual View View {get;}

Property Value

the View for this share, or NULL if the View has been deleted

See Also

Share Class | StarTeam Namespace


ViewPath Property

Borland StarTeam SDK for .NET

Share.ViewPath Property

[read] the View path (in this format: "parent\child\grandchild...").

public virtual String ViewPath {get;}

Property Value

the View path (in this format: "parent\child\grandchild...").

See Also

Share Class | StarTeam Namespace


VMID Property

Borland StarTeam SDK for .NET

Share.VMID Property

[read] the shared ViewMember's VMID.

public virtual Int32 VMID {get;}

Property Value

the shared ViewMember's VMID.

See Also

Share Class | StarTeam Namespace


Share Methods

The methods of the Share class are listed below. For a complete list of Share class members, see the Share Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetAttachedLabels |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetHistory |
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

Share Class | StarTeam Namespace


Share.GetAttachedLabels Method

public virtual Label[] GetAttachedLabels(
ViewMember.Type typ
);

See Also

Share Class | StarTeam Namespace


Share.GetHistory Method

public virtual ViewMemberCollection GetHistory(
ViewMember.Type typ
);

See Also

Share Class | StarTeam Namespace


Share.Type Class

Type for share

For a list of all members of this type, see Share.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
Share.Type

new public class Share.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type Members | StarTeam Namespace


Share.Type Members

Share.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Share.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Share.Type.

See Also

Share.Type Class | StarTeam Namespace


Share.Type Properties

The properties of the Share.Type class are listed below. For a complete list of Share.Type class members, see the Share.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

Share.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.NAME Property

new public static String NAME {get;}

See Also

Share.Type Class | StarTeam Namespace


Share.Type Methods

The methods of the Share.Type class are listed below. For a complete list of Share.Type class members, see the Share.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Share.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Share.Type.

See Also

Share.Type Class | StarTeam Namespace


Share.Type.Equals Method

Delegate Equals() to com.starteam.Share.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.Equals(obj).

See Also

Share.Type Class | StarTeam Namespace


Share.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.GetHashCode().

See Also

Share.Type Class | StarTeam Namespace


Share.Type.ToString Method

Delegate ToString() to com.starteam.Share.Type.

public override string ToString();

Return Value

com.starteam.Share.Type.ToString()

See Also

Share.Type Class | StarTeam Namespace


Share.Type.FolderIDProperty Class

The property type of the FolderID property.

For a list of all members of this type, see Share.Type.FolderIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Share.Type.FolderIDProperty

public class Share.Type.FolderIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.FolderIDProperty Members | StarTeam Namespace


Share.Type.FolderIDProperty Members

Share.Type.FolderIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.FolderIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.FolderIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.FolderIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.FolderIDProperty Class | StarTeam Namespace


Share.Type.FolderIDProperty Properties

The properties of the Share.Type.FolderIDProperty class are listed below. For a complete list of Share.Type.FolderIDProperty class members, see the Share.Type.FolderIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Share.Type.FolderIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.FolderIDProperty.NAME Property

public static String NAME {get;}

See Also

Share.Type.FolderIDProperty Class | StarTeam Namespace


Share.Type.FolderIDProperty Methods

The methods of the Share.Type.FolderIDProperty class are listed below. For a complete list of Share.Type.FolderIDProperty class members, see the Share.Type.FolderIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.FolderIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.FolderIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.FolderIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.FolderIDProperty Class | StarTeam Namespace


Share.Type.FolderIDProperty.Equals Method

Delegate Equals() to com.starteam.Share.Type.FolderIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.FolderIDProperty.Equals(obj).

See Also

Share.Type.FolderIDProperty Class | StarTeam Namespace


Share.Type.FolderIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.FolderIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.FolderIDProperty.GetHashCode().

See Also

Share.Type.FolderIDProperty Class | StarTeam Namespace


Share.Type.FolderIDProperty.ToString Method

Delegate ToString() to com.starteam.Share.Type.FolderIDProperty.

public override string ToString();

Return Value

com.starteam.Share.Type.FolderIDProperty.ToString()

See Also

Share.Type.FolderIDProperty Class | StarTeam Namespace


Share.Type.ItemIDProperty Class

The property type of the ItemID property.

For a list of all members of this type, see Share.Type.ItemIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Share.Type.ItemIDProperty

public class Share.Type.ItemIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.ItemIDProperty Members | StarTeam Namespace


Share.Type.ItemIDProperty Members

Share.Type.ItemIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ItemIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ItemIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ItemIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ItemIDProperty Class | StarTeam Namespace


Share.Type.ItemIDProperty Properties

The properties of the Share.Type.ItemIDProperty class are listed below. For a complete list of Share.Type.ItemIDProperty class members, see the Share.Type.ItemIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Share.Type.ItemIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.ItemIDProperty.NAME Property

public static String NAME {get;}

See Also

Share.Type.ItemIDProperty Class | StarTeam Namespace


Share.Type.ItemIDProperty Methods

The methods of the Share.Type.ItemIDProperty class are listed below. For a complete list of Share.Type.ItemIDProperty class members, see the Share.Type.ItemIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ItemIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ItemIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ItemIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ItemIDProperty Class | StarTeam Namespace


Share.Type.ItemIDProperty.Equals Method

Delegate Equals() to com.starteam.Share.Type.ItemIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.ItemIDProperty.Equals(obj).

See Also

Share.Type.ItemIDProperty Class | StarTeam Namespace


Share.Type.ItemIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.ItemIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.ItemIDProperty.GetHashCode().

See Also

Share.Type.ItemIDProperty Class | StarTeam Namespace


Share.Type.ItemIDProperty.ToString Method

Delegate ToString() to com.starteam.Share.Type.ItemIDProperty.

public override string ToString();

Return Value

com.starteam.Share.Type.ItemIDProperty.ToString()

See Also

Share.Type.ItemIDProperty Class | StarTeam Namespace


Share.Type.ItemRevisionProperty Class

The property type of the Item Revision property.

For a list of all members of this type, see Share.Type.ItemRevisionProperty Members.

System.Object
Property
VectorProperty
TextProperty
Share.Type.ItemRevisionProperty

public class Share.Type.ItemRevisionProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.ItemRevisionProperty Members | StarTeam Namespace


Share.Type.ItemRevisionProperty Members

Share.Type.ItemRevisionProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ItemRevisionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ItemRevisionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ItemRevisionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ItemRevisionProperty Class | StarTeam Namespace


Share.Type.ItemRevisionProperty Properties

The properties of the Share.Type.ItemRevisionProperty class are listed below. For a complete list of Share.Type.ItemRevisionProperty class members, see the Share.Type.ItemRevisionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Share.Type.ItemRevisionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.ItemRevisionProperty.NAME Property

public static String NAME {get;}

See Also

Share.Type.ItemRevisionProperty Class | StarTeam Namespace


Share.Type.ItemRevisionProperty Methods

The methods of the Share.Type.ItemRevisionProperty class are listed below. For a complete list of Share.Type.ItemRevisionProperty class members, see the Share.Type.ItemRevisionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ItemRevisionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ItemRevisionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ItemRevisionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ItemRevisionProperty Class | StarTeam Namespace


Share.Type.ItemRevisionProperty.Equals Method

Delegate Equals() to com.starteam.Share.Type.ItemRevisionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.ItemRevisionProperty.Equals(obj).

See Also

Share.Type.ItemRevisionProperty Class | StarTeam Namespace


Share.Type.ItemRevisionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.ItemRevisionProperty.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.ItemRevisionProperty.GetHashCode().

See Also

Share.Type.ItemRevisionProperty Class | StarTeam Namespace


Share.Type.ItemRevisionProperty.ToString Method

Delegate ToString() to com.starteam.Share.Type.ItemRevisionProperty.

public override string ToString();

Return Value

com.starteam.Share.Type.ItemRevisionProperty.ToString()

See Also

Share.Type.ItemRevisionProperty Class | StarTeam Namespace


Share.Type.NumberOfDerivedSharesProperty Class

The property type of the Number of Derived Shares property.

For a list of all members of this type, see Share.Type.NumberOfDerivedSharesProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Share.Type.NumberOfDerivedSharesProperty

public class Share.Type.NumberOfDerivedSharesProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.NumberOfDerivedSharesProperty Members | StarTeam Namespace


Share.Type.NumberOfDerivedSharesProperty Members

Share.Type.NumberOfDerivedSharesProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.NumberOfDerivedSharesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.NumberOfDerivedSharesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.NumberOfDerivedSharesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.NumberOfDerivedSharesProperty Class | StarTeam Namespace


Share.Type.NumberOfDerivedSharesProperty Properties

The properties of the Share.Type.NumberOfDerivedSharesProperty class are listed below. For a complete list of Share.Type.NumberOfDerivedSharesProperty class members, see the Share.Type.NumberOfDerivedSharesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Share.Type.NumberOfDerivedSharesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.NumberOfDerivedSharesProperty.NAME Property

public static String NAME {get;}

See Also

Share.Type.NumberOfDerivedSharesProperty Class | StarTeam Namespace


Share.Type.NumberOfDerivedSharesProperty Methods

The methods of the Share.Type.NumberOfDerivedSharesProperty class are listed below. For a complete list of Share.Type.NumberOfDerivedSharesProperty class members, see the Share.Type.NumberOfDerivedSharesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.NumberOfDerivedSharesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.NumberOfDerivedSharesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.NumberOfDerivedSharesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.NumberOfDerivedSharesProperty Class | StarTeam Namespace


Share.Type.NumberOfDerivedSharesProperty.Equals Method

Delegate Equals() to com.starteam.Share.Type.NumberOfDerivedSharesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.NumberOfDerivedSharesProperty.Equals(obj).

See Also

Share.Type.NumberOfDerivedSharesProperty Class | StarTeam Namespace


Share.Type.NumberOfDerivedSharesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.NumberOfDerivedSharesProperty.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.NumberOfDerivedSharesProperty.GetHashCode().

See Also

Share.Type.NumberOfDerivedSharesProperty Class | StarTeam Namespace


Share.Type.NumberOfDerivedSharesProperty.ToString Method

Delegate ToString() to com.starteam.Share.Type.NumberOfDerivedSharesProperty.

public override string ToString();

Return Value

com.starteam.Share.Type.NumberOfDerivedSharesProperty.ToString()

See Also

Share.Type.NumberOfDerivedSharesProperty Class | StarTeam Namespace


Share.Type.ObjectIDProperty Class

The property type of the Object ID property.

For a list of all members of this type, see Share.Type.ObjectIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Share.Type.ObjectIDProperty

public class Share.Type.ObjectIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.ObjectIDProperty Members | StarTeam Namespace


Share.Type.ObjectIDProperty Members

Share.Type.ObjectIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ObjectIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ObjectIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ObjectIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ObjectIDProperty Class | StarTeam Namespace


Share.Type.ObjectIDProperty Properties

The properties of the Share.Type.ObjectIDProperty class are listed below. For a complete list of Share.Type.ObjectIDProperty class members, see the Share.Type.ObjectIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Share.Type.ObjectIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.ObjectIDProperty.NAME Property

public static String NAME {get;}

See Also

Share.Type.ObjectIDProperty Class | StarTeam Namespace


Share.Type.ObjectIDProperty Methods

The methods of the Share.Type.ObjectIDProperty class are listed below. For a complete list of Share.Type.ObjectIDProperty class members, see the Share.Type.ObjectIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ObjectIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ObjectIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ObjectIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ObjectIDProperty Class | StarTeam Namespace


Share.Type.ObjectIDProperty.Equals Method

Delegate Equals() to com.starteam.Share.Type.ObjectIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.ObjectIDProperty.Equals(obj).

See Also

Share.Type.ObjectIDProperty Class | StarTeam Namespace


Share.Type.ObjectIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.ObjectIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.ObjectIDProperty.GetHashCode().

See Also

Share.Type.ObjectIDProperty Class | StarTeam Namespace


Share.Type.ObjectIDProperty.ToString Method

Delegate ToString() to com.starteam.Share.Type.ObjectIDProperty.

public override string ToString();

Return Value

com.starteam.Share.Type.ObjectIDProperty.ToString()

See Also

Share.Type.ObjectIDProperty Class | StarTeam Namespace


Share.Type.ProjectNameProperty Class

The property type of the Project name property.

For a list of all members of this type, see Share.Type.ProjectNameProperty Members.

System.Object
Property
VectorProperty
TextProperty
Share.Type.ProjectNameProperty

public class Share.Type.ProjectNameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.ProjectNameProperty Members | StarTeam Namespace


Share.Type.ProjectNameProperty Members

Share.Type.ProjectNameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ProjectNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ProjectNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ProjectNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ProjectNameProperty Class | StarTeam Namespace


Share.Type.ProjectNameProperty Properties

The properties of the Share.Type.ProjectNameProperty class are listed below. For a complete list of Share.Type.ProjectNameProperty class members, see the Share.Type.ProjectNameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Share.Type.ProjectNameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.ProjectNameProperty.NAME Property

public static String NAME {get;}

See Also

Share.Type.ProjectNameProperty Class | StarTeam Namespace


Share.Type.ProjectNameProperty Methods

The methods of the Share.Type.ProjectNameProperty class are listed below. For a complete list of Share.Type.ProjectNameProperty class members, see the Share.Type.ProjectNameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ProjectNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ProjectNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ProjectNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ProjectNameProperty Class | StarTeam Namespace


Share.Type.ProjectNameProperty.Equals Method

Delegate Equals() to com.starteam.Share.Type.ProjectNameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.ProjectNameProperty.Equals(obj).

See Also

Share.Type.ProjectNameProperty Class | StarTeam Namespace


Share.Type.ProjectNameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.ProjectNameProperty.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.ProjectNameProperty.GetHashCode().

See Also

Share.Type.ProjectNameProperty Class | StarTeam Namespace


Share.Type.ProjectNameProperty.ToString Method

Delegate ToString() to com.starteam.Share.Type.ProjectNameProperty.

public override string ToString();

Return Value

com.starteam.Share.Type.ProjectNameProperty.ToString()

See Also

Share.Type.ProjectNameProperty Class | StarTeam Namespace


Share.Type.ProjectProperty Class

The property type of the Project property.

For a list of all members of this type, see Share.Type.ProjectProperty Members.

System.Object
Property
ObjectProperty
Share.Type.ProjectProperty

public class Share.Type.ProjectProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.ProjectProperty Members | StarTeam Namespace


Share.Type.ProjectProperty Members

Share.Type.ProjectProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ProjectProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ProjectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ProjectProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ProjectProperty Class | StarTeam Namespace


Share.Type.ProjectProperty Properties

The properties of the Share.Type.ProjectProperty class are listed below. For a complete list of Share.Type.ProjectProperty class members, see the Share.Type.ProjectProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Share.Type.ProjectProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.ProjectProperty.NAME Property

public static String NAME {get;}

See Also

Share.Type.ProjectProperty Class | StarTeam Namespace


Share.Type.ProjectProperty Methods

The methods of the Share.Type.ProjectProperty class are listed below. For a complete list of Share.Type.ProjectProperty class members, see the Share.Type.ProjectProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ProjectProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ProjectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ProjectProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ProjectProperty Class | StarTeam Namespace


Share.Type.ProjectProperty.Equals Method

Delegate Equals() to com.starteam.Share.Type.ProjectProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.ProjectProperty.Equals(obj).

See Also

Share.Type.ProjectProperty Class | StarTeam Namespace


Share.Type.ProjectProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.ProjectProperty.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.ProjectProperty.GetHashCode().

See Also

Share.Type.ProjectProperty Class | StarTeam Namespace


Share.Type.ProjectProperty.ToString Method

Delegate ToString() to com.starteam.Share.Type.ProjectProperty.

public override string ToString();

Return Value

com.starteam.Share.Type.ProjectProperty.ToString()

See Also

Share.Type.ProjectProperty Class | StarTeam Namespace


Share.Type.PropertyCollection Class

Property Collection class for Share type

For a list of all members of this type, see Share.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
Share.Type.PropertyCollection

public class Share.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.PropertyCollection Members | StarTeam Namespace


Share.Type.PropertyCollection Members

Share.Type.PropertyCollection overview

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
END_MODIFIED_TIME |
FLAGS |
FOLDER_ID |
FOLDER_PATH |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_ID |
ITEM_REVISION |
MODIFIED_BY |
MODIFIED_TIME |
NUMBER_OF_DERIVED_SHARES |
OBJECT_ID |
PROJECT |
PROJECT_NAME |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |
VIEW_PATH |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Share.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Share.Type.PropertyCollection.

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


Share.Type.PropertyCollection Properties

The properties of the Share.Type.PropertyCollection class are listed below. For a complete list of Share.Type.PropertyCollection class members, see the Share.Type.PropertyCollection Members topic.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
END_MODIFIED_TIME |
FLAGS |
FOLDER_ID |
FOLDER_PATH |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_ID |
ITEM_REVISION |
MODIFIED_BY |
MODIFIED_TIME |
NUMBER_OF_DERIVED_SHARES |
OBJECT_ID |
PROJECT |
PROJECT_NAME |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |
VIEW_PATH |

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


FLAGS Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.FLAGS Property

public LiveObject.Type.FlagsProperty FLAGS {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_ID Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.FOLDER_ID Property

public Share.Type.FolderIDProperty FOLDER_ID {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_PATH Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.FOLDER_PATH Property

public TrackedObject.Type.FolderPathProperty FOLDER_PATH {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


ITEM_ID Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.ITEM_ID Property

public Share.Type.ItemIDProperty ITEM_ID {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


ITEM_REVISION Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.ITEM_REVISION Property

public Share.Type.ItemRevisionProperty ITEM_REVISION {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


NUMBER_OF_DERIVED_SHARES Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.NUMBER_OF_DERIVED_SHARES Property

public Share.Type.NumberOfDerivedSharesProperty NUMBER_OF_DERIVED_SHARES {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


OBJECT_ID Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.OBJECT_ID Property

public Share.Type.ObjectIDProperty OBJECT_ID {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


PROJECT Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.PROJECT Property

public Share.Type.ProjectProperty PROJECT {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


PROJECT_NAME Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.PROJECT_NAME Property

public Share.Type.ProjectNameProperty PROJECT_NAME {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.VIEW Property

public Share.Type.ViewProperty VIEW {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


VIEW_PATH Property

Borland StarTeam SDK for .NET

Share.Type.PropertyCollection.VIEW_PATH Property

public Share.Type.ViewPathProperty VIEW_PATH {get;}

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


Share.Type.PropertyCollection Methods

The methods of the Share.Type.PropertyCollection class are listed below. For a complete list of Share.Type.PropertyCollection class members, see the Share.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Share.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Share.Type.PropertyCollection.

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


Share.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Share.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.PropertyCollection.Equals(obj).

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


Share.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.PropertyCollection.GetHashCode().

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


Share.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Share.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Share.Type.PropertyCollection.ToString()

See Also

Share.Type.PropertyCollection Class | StarTeam Namespace


Share.Type.ViewPathProperty Class

The property type of the View path property.

For a list of all members of this type, see Share.Type.ViewPathProperty Members.

System.Object
Property
VectorProperty
TextProperty
Share.Type.ViewPathProperty

public class Share.Type.ViewPathProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.ViewPathProperty Members | StarTeam Namespace


Share.Type.ViewPathProperty Members

Share.Type.ViewPathProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ViewPathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ViewPathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ViewPathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ViewPathProperty Class | StarTeam Namespace


Share.Type.ViewPathProperty Properties

The properties of the Share.Type.ViewPathProperty class are listed below. For a complete list of Share.Type.ViewPathProperty class members, see the Share.Type.ViewPathProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Share.Type.ViewPathProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.ViewPathProperty.NAME Property

public static String NAME {get;}

See Also

Share.Type.ViewPathProperty Class | StarTeam Namespace


Share.Type.ViewPathProperty Methods

The methods of the Share.Type.ViewPathProperty class are listed below. For a complete list of Share.Type.ViewPathProperty class members, see the Share.Type.ViewPathProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ViewPathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ViewPathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ViewPathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ViewPathProperty Class | StarTeam Namespace


Share.Type.ViewPathProperty.Equals Method

Delegate Equals() to com.starteam.Share.Type.ViewPathProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.ViewPathProperty.Equals(obj).

See Also

Share.Type.ViewPathProperty Class | StarTeam Namespace


Share.Type.ViewPathProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.ViewPathProperty.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.ViewPathProperty.GetHashCode().

See Also

Share.Type.ViewPathProperty Class | StarTeam Namespace


Share.Type.ViewPathProperty.ToString Method

Delegate ToString() to com.starteam.Share.Type.ViewPathProperty.

public override string ToString();

Return Value

com.starteam.Share.Type.ViewPathProperty.ToString()

See Also

Share.Type.ViewPathProperty Class | StarTeam Namespace


Share.Type.ViewProperty Class

The property type of the View property.

For a list of all members of this type, see Share.Type.ViewProperty Members.

System.Object
Property
ObjectProperty
Share.Type.ViewProperty

public class Share.Type.ViewProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.Type.ViewProperty Members | StarTeam Namespace


Share.Type.ViewProperty Members

Share.Type.ViewProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ViewProperty Class | StarTeam Namespace


Share.Type.ViewProperty Properties

The properties of the Share.Type.ViewProperty class are listed below. For a complete list of Share.Type.ViewProperty class members, see the Share.Type.ViewProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Share.Type.ViewProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Share.Type.ViewProperty.NAME Property

public static String NAME {get;}

See Also

Share.Type.ViewProperty Class | StarTeam Namespace


Share.Type.ViewProperty Methods

The methods of the Share.Type.ViewProperty class are listed below. For a complete list of Share.Type.ViewProperty class members, see the Share.Type.ViewProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Share.Type.ViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.Type.ViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Share.Type.ViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Share.Type.ViewProperty Class | StarTeam Namespace


Share.Type.ViewProperty.Equals Method

Delegate Equals() to com.starteam.Share.Type.ViewProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.Type.ViewProperty.Equals(obj).

See Also

Share.Type.ViewProperty Class | StarTeam Namespace


Share.Type.ViewProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.Type.ViewProperty.

public override int GetHashCode();

Return Value

com.starteam.Share.Type.ViewProperty.GetHashCode().

See Also

Share.Type.ViewProperty Class | StarTeam Namespace


Share.Type.ViewProperty.ToString Method

Delegate ToString() to com.starteam.Share.Type.ViewProperty.

public override string ToString();

Return Value

com.starteam.Share.Type.ViewProperty.ToString()

See Also

Share.Type.ViewProperty Class | StarTeam Namespace


Share.WebCacheShare Class

Base accessor for cached SDK Shares

For a list of all members of this type, see Share.WebCacheShare Members.

System.Object
Share.WebCacheShare

public class Share.WebCacheShare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Share.WebCacheShare Members | StarTeam Namespace


Share.WebCacheShare Members

Share.WebCacheShare overview

Public Instance Properties

ChildShares | [read] an array of Shares that are direct children of this Share, or an empty array if there are none.
CreatedBy | [read] the User who created this item, only available on server versions 5.2 and higher.
CreatedTime | [read] the CreatedTime for this item, only available on server versions 5.2 and higher.
DeletedBy | [read] the User who deleted this item, only available on server versions 5.2 and higher.
DeletedTime | [read] the DeletedTime of this item, only available on server versions 5.2 and higher.
DerivedCount | [read] the number of shares directly derived from this item.
DotNotation | [read] the revision number in dot notation form.
EndModifiedTime | [read] the EndModifiedTime of this item, only available on server versions 5.2 and higher.
FolderItemID | [read] the Item ID of the referenced Item's parent Folder.
FolderPath | [read] the folder path of the referenced Item's parent Folder.
IsDeleted | [read] true if the Item has been deleted.
IsFirstOfItsBranch | [read] true if this share is the first share of its branch; false if its parent share (or an ancestor share) is on the same branch.
IsRelated | [read] true if this item contains the revision queried by Item.getReferences() in its history.
IsViewDeleted | [read] true if the item's View has been deleted.
ModifiedBy | [read] the User who last modified this item, only available on server versions 5.2 and higher.
ModifiedTime | [read] the ModifiedTime of this item, only available on server versions 5.2 and higher.
ObjectID | [read] the item's object ID.
ParentShare | [read] the parent of this Share, or null if this is the root of the share tree.
Project | [read] the project that contains this reference.
ProjectName | [read] the containing Project's name.
View | [read] the View for this share, or NULL if the View has been deleted
ViewPath | [read] the View path (in this format: "parent\child\grandchild...").
VMID | [read] the shared ViewMember's VMID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Share.WebCacheShare.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.WebCacheShare.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Share.WebCacheShare.

See Also

Share.WebCacheShare Class | StarTeam Namespace


Share.WebCacheShare Properties

The properties of the Share.WebCacheShare class are listed below. For a complete list of Share.WebCacheShare class members, see the Share.WebCacheShare Members topic.

Public Instance Properties

ChildShares | [read] an array of Shares that are direct children of this Share, or an empty array if there are none.
CreatedBy | [read] the User who created this item, only available on server versions 5.2 and higher.
CreatedTime | [read] the CreatedTime for this item, only available on server versions 5.2 and higher.
DeletedBy | [read] the User who deleted this item, only available on server versions 5.2 and higher.
DeletedTime | [read] the DeletedTime of this item, only available on server versions 5.2 and higher.
DerivedCount | [read] the number of shares directly derived from this item.
DotNotation | [read] the revision number in dot notation form.
EndModifiedTime | [read] the EndModifiedTime of this item, only available on server versions 5.2 and higher.
FolderItemID | [read] the Item ID of the referenced Item's parent Folder.
FolderPath | [read] the folder path of the referenced Item's parent Folder.
IsDeleted | [read] true if the Item has been deleted.
IsFirstOfItsBranch | [read] true if this share is the first share of its branch; false if its parent share (or an ancestor share) is on the same branch.
IsRelated | [read] true if this item contains the revision queried by Item.getReferences() in its history.
IsViewDeleted | [read] true if the item's View has been deleted.
ModifiedBy | [read] the User who last modified this item, only available on server versions 5.2 and higher.
ModifiedTime | [read] the ModifiedTime of this item, only available on server versions 5.2 and higher.
ObjectID | [read] the item's object ID.
ParentShare | [read] the parent of this Share, or null if this is the root of the share tree.
Project | [read] the project that contains this reference.
ProjectName | [read] the containing Project's name.
View | [read] the View for this share, or NULL if the View has been deleted
ViewPath | [read] the View path (in this format: "parent\child\grandchild...").
VMID | [read] the shared ViewMember's VMID.

See Also

Share.WebCacheShare Class | StarTeam Namespace


ChildShares Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.ChildShares Property

[read] an array of Shares that are direct children of this Share, or an empty array if there are none.

public virtual WebCacheShare[] ChildShares {get;}

Property Value

an array of Shares that are direct children of this Share, or an empty array if there are none.

See Also

Share.WebCacheShare Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.CreatedBy Property

[read] the User who created this item, only available on server versions 5.2 and higher.

public virtual User.WebCacheUser CreatedBy {get;}

Property Value

the User who created this item, only available on server versions 5.2 and higher.

See Also

Share.WebCacheShare Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.CreatedTime Property

[read] the CreatedTime for this item, only available on server versions 5.2 and higher.

public virtual DateTime CreatedTime {get;}

Property Value

the CreatedTime for this item, only available on server versions 5.2 and higher.

See Also

Share.WebCacheShare Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.DeletedBy Property

[read] the User who deleted this item, only available on server versions 5.2 and higher.

public virtual User.WebCacheUser DeletedBy {get;}

Property Value

the User who deleted this item, only available on server versions 5.2 and higher.

See Also

Share.WebCacheShare Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.DeletedTime Property

[read] the DeletedTime of this item, only available on server versions 5.2 and higher.

public virtual DateTime DeletedTime {get;}

Property Value

the DeletedTime of this item, only available on server versions 5.2 and higher.

See Also

Share.WebCacheShare Class | StarTeam Namespace


DerivedCount Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.DerivedCount Property

[read] the number of shares directly derived from this item.

public virtual Int32 DerivedCount {get;}

Property Value

the number of shares directly derived from this item.

See Also

Share.WebCacheShare Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.DotNotation Property

[read] the revision number in dot notation form.

public virtual DotNotation DotNotation {get;}

Property Value

the revision number in dot notation form.

See Also

Share.WebCacheShare Class | StarTeam Namespace


EndModifiedTime Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.EndModifiedTime Property

[read] the EndModifiedTime of this item, only available on server versions 5.2 and higher.

public virtual DateTime EndModifiedTime {get;}

Property Value

the EndModifiedTime of this item, only available on server versions 5.2 and higher.

See Also

Share.WebCacheShare Class | StarTeam Namespace


FolderItemID Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.FolderItemID Property

[read] the Item ID of the referenced Item's parent Folder.

public virtual Int32 FolderItemID {get;}

Property Value

the Item ID of the referenced Item's parent Folder.

See Also

Share.WebCacheShare Class | StarTeam Namespace


FolderPath Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.FolderPath Property

[read] the folder path of the referenced Item's parent Folder.

public virtual String FolderPath {get;}

Property Value

the folder path of the referenced Item's parent Folder.

See Also

Share.WebCacheShare Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.IsDeleted Property

[read] true if the Item has been deleted.

public virtual Boolean IsDeleted {get;}

Property Value

true if the Item has been deleted.

See Also

Share.WebCacheShare Class | StarTeam Namespace


IsFirstOfItsBranch Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.IsFirstOfItsBranch Property

[read] true if this share is the first share of its branch; false if its parent share (or an ancestor share) is on the same branch.

public virtual Boolean IsFirstOfItsBranch {get;}

Property Value

true if this share is the first share of its branch; false if its parent share (or an ancestor share) is on the same branch.

See Also

Share.WebCacheShare Class | StarTeam Namespace


IsRelated Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.IsRelated Property

[read] true if this item contains the revision queried by Item.getReferences() in its history.

public virtual Boolean IsRelated {get;}

Property Value

true if this item contains the revision queried by Item.getReferences() in its history.

See Also

Share.WebCacheShare Class | StarTeam Namespace


IsViewDeleted Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.IsViewDeleted Property

[read] true if the item's View has been deleted.

public virtual Boolean IsViewDeleted {get;}

Property Value

true if the item's View has been deleted.

See Also

Share.WebCacheShare Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.ModifiedBy Property

[read] the User who last modified this item, only available on server versions 5.2 and higher.

public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

the User who last modified this item, only available on server versions 5.2 and higher.

See Also

Share.WebCacheShare Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.ModifiedTime Property

[read] the ModifiedTime of this item, only available on server versions 5.2 and higher.

public virtual DateTime ModifiedTime {get;}

Property Value

the ModifiedTime of this item, only available on server versions 5.2 and higher.

See Also

Share.WebCacheShare Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.ObjectID Property

[read] the item's object ID.

public virtual Int32 ObjectID {get;}

Property Value

the item's object ID.

See Also

Share.WebCacheShare Class | StarTeam Namespace


ParentShare Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.ParentShare Property

[read] the parent of this Share, or null if this is the root of the share tree.

public virtual Share.WebCacheShare ParentShare {get;}

Property Value

the parent of this Share, or null if this is the root of the share tree.

See Also

Share.WebCacheShare Class | StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.Project Property

[read] the project that contains this reference.

public virtual Project.WebCacheProject Project {get;}

Property Value

the project that contains this reference.

See Also

Share.WebCacheShare Class | StarTeam Namespace


ProjectName Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.ProjectName Property

[read] the containing Project's name.

public virtual String ProjectName {get;}

Property Value

the containing Project's name.

See Also

Share.WebCacheShare Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.View Property

[read] the View for this share, or NULL if the View has been deleted

public virtual View.WebCacheView View {get;}

Property Value

the View for this share, or NULL if the View has been deleted

See Also

Share.WebCacheShare Class | StarTeam Namespace


ViewPath Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.ViewPath Property

[read] the View path (in this format: "parent\child\grandchild...").

public virtual String ViewPath {get;}

Property Value

the View path (in this format: "parent\child\grandchild...").

See Also

Share.WebCacheShare Class | StarTeam Namespace


VMID Property

Borland StarTeam SDK for .NET

Share.WebCacheShare.VMID Property

[read] the shared ViewMember's VMID.

public virtual Int32 VMID {get;}

Property Value

the shared ViewMember's VMID.

See Also

Share.WebCacheShare Class | StarTeam Namespace


Share.WebCacheShare Methods

The methods of the Share.WebCacheShare class are listed below. For a complete list of Share.WebCacheShare class members, see the Share.WebCacheShare Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Share.WebCacheShare.
GetHashCode | Delegate GetHashCode() to com.starteam.Share.WebCacheShare.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Share.WebCacheShare.

See Also

Share.WebCacheShare Class | StarTeam Namespace


Share.WebCacheShare.Equals Method

Delegate Equals() to com.starteam.Share.WebCacheShare.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Share.WebCacheShare.Equals(obj).

See Also

Share.WebCacheShare Class | StarTeam Namespace


Share.WebCacheShare.GetHashCode Method

Delegate GetHashCode() to com.starteam.Share.WebCacheShare.

public override int GetHashCode();

Return Value

com.starteam.Share.WebCacheShare.GetHashCode().

See Also

Share.WebCacheShare Class | StarTeam Namespace


Share.WebCacheShare.ToString Method

Delegate ToString() to com.starteam.Share.WebCacheShare.

public override string ToString();

Return Value

com.starteam.Share.WebCacheShare.ToString()

See Also

Share.WebCacheShare Class | StarTeam Namespace


Sprint Class

An Agile/Scrum Sprint is a basic unit of development. It sums up all work to be accomplished within the sprint period that typically spans from a week to a month.

For a list of all members of this type, see Sprint Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Sprint

public class Sprint : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint Members | StarTeam Namespace


Sprint Members

Sprint overview

Public Static Methods

Create Create a Sprint in the specified parent folder.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the text in the "Description" property for this sprint.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EndDate | [read/write] the End Date of this sprint.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this sprint.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Owner | [read/write] the User object who owns this sprint.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentPlan | [read] the Plan containing this Story
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
SprintID | [read] the sprint id.
StartDate | [read/write] the Start Date of this sprint.
Stories | [read] a possibly empty array of Story
TargetReleases | [read/write] the target releases that this sprint may be mapped to
Team | [read/write] The team for this sprint.
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCapacity | return the capacity for the specified user
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasCapacity | Return true if this sprint has an assigned capacity for the specified user
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetCapacity | set the capacity for a given user
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Sprint Class | StarTeam Namespace


Sprint Properties

The properties of the Sprint class are listed below. For a complete list of Sprint class members, see the Sprint Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the text in the "Description" property for this sprint.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EndDate | [read/write] the End Date of this sprint.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this sprint.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Owner | [read/write] the User object who owns this sprint.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentPlan | [read] the Plan containing this Story
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
SprintID | [read] the sprint id.
StartDate | [read/write] the Start Date of this sprint.
Stories | [read] a possibly empty array of Story
TargetReleases | [read/write] the target releases that this sprint may be mapped to
Team | [read/write] The team for this sprint.
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Sprint Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Sprint.Description Property

[read/write] the text in the "Description" property for this sprint.

public virtual String Description {get; set;}

Property Value

the text in the "Description" property for this sprint.

See Also

Sprint Class | StarTeam Namespace


EndDate Property

Borland StarTeam SDK for .NET

Sprint.EndDate Property

[read/write] the End Date of this sprint.

public virtual Date EndDate {get; set;}

Property Value

the End Date of this sprint.

See Also

Sprint Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Sprint.Name Property

[read/write] the Name of this sprint.

public virtual String Name {get; set;}

Property Value

the Name of this sprint.

See Also

Sprint Class | StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

Sprint.Owner Property

[read/write] the User object who owns this sprint.

public virtual User Owner {get; set;}

Property Value

the User object who owns this sprint.

See Also

Sprint Class | StarTeam Namespace


ParentPlan Property

Borland StarTeam SDK for .NET

Sprint.ParentPlan Property

[read] the Plan containing this Story

public virtual Plan ParentPlan {get;}

Property Value

the Plan containing this Story

See Also

Sprint Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Sprint.Properties Property

[read] the PropertyCollection of its Type

public virtual Sprint.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

Sprint Class | StarTeam Namespace


SprintID Property

Borland StarTeam SDK for .NET

Sprint.SprintID Property

[read] the sprint id.

public virtual Int32 SprintID {get;}

Property Value

the sprint id.

See Also

Sprint Class | StarTeam Namespace


StartDate Property

Borland StarTeam SDK for .NET

Sprint.StartDate Property

[read/write] the Start Date of this sprint.

public virtual Date StartDate {get; set;}

Property Value

the Start Date of this sprint.

See Also

Sprint Class | StarTeam Namespace


Stories Property

Borland StarTeam SDK for .NET

Sprint.Stories Property

[read] a possibly empty array of Story

public virtual Story[] Stories {get;}

Property Value

a possibly empty array of Story

See Also

Sprint Class | StarTeam Namespace


TargetReleases Property

Borland StarTeam SDK for .NET

Sprint.TargetReleases Property

[read/write] the target releases that this sprint may be mapped to

public virtual View[] TargetReleases {get; set;}

Property Value

the target releases that this sprint may be mapped to

See Also

Sprint Class | StarTeam Namespace


Team Property

Borland StarTeam SDK for .NET

Sprint.Team Property

[read/write] The team for this sprint.

public virtual String Team {get; set;}

Property Value

The team for this sprint.

See Also

Sprint Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Sprint.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Sprint Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Sprint.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Sprint Class | StarTeam Namespace


Sprint Methods

The methods of the Sprint class are listed below. For a complete list of Sprint class members, see the Sprint Members topic.

Public Static Methods

Create Create a Sprint in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCapacity | return the capacity for the specified user
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasCapacity | Return true if this sprint has an assigned capacity for the specified user
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetCapacity | set the capacity for a given user
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Sprint Class | StarTeam Namespace


Sprint.Create Method

Create a Sprint in the specified parent folder.

public static Sprint Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Sprint Object.

See Also

Sprint Class | StarTeam Namespace


Sprint.GetCapacity Method

return the capacity for the specified user

public virtual double GetCapacity(
User u
);

Parameters

u
the user to test against

Return Value

the capacity for the specified user or -1 if the user has no capacity

See Also

Sprint Class | StarTeam Namespace


Sprint.HasCapacity Method

Return true if this sprint has an assigned capacity for the specified user

public virtual bool HasCapacity(
User u
);

Parameters

u
the user to test against

Return Value

true if this sprint has an assigned capacity for the specified user

See Also

Sprint Class | StarTeam Namespace


Sprint.SetCapacity Method

set the capacity for a given user

public virtual void SetCapacity(
User u,
Double capacity
);

Parameters

u
the user
capacity
the capacity to set

See Also

Sprint Class | StarTeam Namespace


Sprint.Type Class

Type meta-data (schema) for Sprint object instances.

For a list of all members of this type, see Sprint.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
Sprint.Type

new public class Sprint.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint.Type Members | StarTeam Namespace


Sprint.Type Members

Sprint.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Sprint.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Sprint.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type Properties

The properties of the Sprint.Type class are listed below. For a complete list of Sprint.Type class members, see the Sprint.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Sprint.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Sprint.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Sprint.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Sprint.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Sprint.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Sprint.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Sprint.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Sprint.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Sprint.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Sprint.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Sprint.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Sprint.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Sprint.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Sprint.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Sprint.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Sprint.Type.NAME Property

new public static String NAME {get;}

See Also

Sprint.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Sprint.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Sprint.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Sprint.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Sprint.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Sprint.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Sprint.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Sprint.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Sprint.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type Methods

The methods of the Sprint.Type class are listed below. For a complete list of Sprint.Type class members, see the Sprint.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Sprint.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Sprint.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type.Equals Method

Delegate Equals() to com.starteam.Sprint.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Sprint.Type.Equals(obj).

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Sprint.Type.

public override int GetHashCode();

Return Value

com.starteam.Sprint.Type.GetHashCode().

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type.ToString Method

Delegate ToString() to com.starteam.Sprint.Type.

public override string ToString();

Return Value

com.starteam.Sprint.Type.ToString()

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Sprint.Type Class | StarTeam Namespace


Sprint.Type.EndDateProperty Class

The property type of the StartDate property.

For a list of all members of this type, see Sprint.Type.EndDateProperty Members.

System.Object
Property
ScalarProperty
DateProperty
Sprint.Type.EndDateProperty

public class Sprint.Type.EndDateProperty : DateProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint.Type.EndDateProperty Members | StarTeam Namespace


Sprint.Type.EndDateProperty Members

Sprint.Type.EndDateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.EndDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.EndDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.EndDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.EndDateProperty Class | StarTeam Namespace


Sprint.Type.EndDateProperty Properties

The properties of the Sprint.Type.EndDateProperty class are listed below. For a complete list of Sprint.Type.EndDateProperty class members, see the Sprint.Type.EndDateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Sprint.Type.EndDateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Sprint.Type.EndDateProperty.NAME Property

public static String NAME {get;}

See Also

Sprint.Type.EndDateProperty Class | StarTeam Namespace


Sprint.Type.EndDateProperty Methods

The methods of the Sprint.Type.EndDateProperty class are listed below. For a complete list of Sprint.Type.EndDateProperty class members, see the Sprint.Type.EndDateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.EndDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.EndDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.EndDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.EndDateProperty Class | StarTeam Namespace


Sprint.Type.EndDateProperty.Equals Method

Delegate Equals() to com.starteam.Sprint.Type.EndDateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Sprint.Type.EndDateProperty.Equals(obj).

See Also

Sprint.Type.EndDateProperty Class | StarTeam Namespace


Sprint.Type.EndDateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Sprint.Type.EndDateProperty.

public override int GetHashCode();

Return Value

com.starteam.Sprint.Type.EndDateProperty.GetHashCode().

See Also

Sprint.Type.EndDateProperty Class | StarTeam Namespace


Sprint.Type.EndDateProperty.ToString Method

Delegate ToString() to com.starteam.Sprint.Type.EndDateProperty.

public override string ToString();

Return Value

com.starteam.Sprint.Type.EndDateProperty.ToString()

See Also

Sprint.Type.EndDateProperty Class | StarTeam Namespace


Sprint.Type.OwnerProperty Class

The property type of the Owner property.

For a list of all members of this type, see Sprint.Type.OwnerProperty Members.

System.Object
Property
ObjectProperty
Sprint.Type.OwnerProperty

public class Sprint.Type.OwnerProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint.Type.OwnerProperty Members | StarTeam Namespace


Sprint.Type.OwnerProperty Members

Sprint.Type.OwnerProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.OwnerProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.OwnerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.OwnerProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.OwnerProperty Class | StarTeam Namespace


Sprint.Type.OwnerProperty Properties

The properties of the Sprint.Type.OwnerProperty class are listed below. For a complete list of Sprint.Type.OwnerProperty class members, see the Sprint.Type.OwnerProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Sprint.Type.OwnerProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Sprint.Type.OwnerProperty.NAME Property

public static String NAME {get;}

See Also

Sprint.Type.OwnerProperty Class | StarTeam Namespace


Sprint.Type.OwnerProperty Methods

The methods of the Sprint.Type.OwnerProperty class are listed below. For a complete list of Sprint.Type.OwnerProperty class members, see the Sprint.Type.OwnerProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.OwnerProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.OwnerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.OwnerProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.OwnerProperty Class | StarTeam Namespace


Sprint.Type.OwnerProperty.Equals Method

Delegate Equals() to com.starteam.Sprint.Type.OwnerProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Sprint.Type.OwnerProperty.Equals(obj).

See Also

Sprint.Type.OwnerProperty Class | StarTeam Namespace


Sprint.Type.OwnerProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Sprint.Type.OwnerProperty.

public override int GetHashCode();

Return Value

com.starteam.Sprint.Type.OwnerProperty.GetHashCode().

See Also

Sprint.Type.OwnerProperty Class | StarTeam Namespace


Sprint.Type.OwnerProperty.ToString Method

Delegate ToString() to com.starteam.Sprint.Type.OwnerProperty.

public override string ToString();

Return Value

com.starteam.Sprint.Type.OwnerProperty.ToString()

See Also

Sprint.Type.OwnerProperty Class | StarTeam Namespace


Sprint.Type.PlanProperty Class

The property type of the Plan property

For a list of all members of this type, see Sprint.Type.PlanProperty Members.

System.Object
Property
ObjectProperty
Sprint.Type.PlanProperty

public class Sprint.Type.PlanProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint.Type.PlanProperty Members | StarTeam Namespace


Sprint.Type.PlanProperty Members

Sprint.Type.PlanProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.PlanProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.PlanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.PlanProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.PlanProperty Class | StarTeam Namespace


Sprint.Type.PlanProperty Properties

The properties of the Sprint.Type.PlanProperty class are listed below. For a complete list of Sprint.Type.PlanProperty class members, see the Sprint.Type.PlanProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Sprint.Type.PlanProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Sprint.Type.PlanProperty.NAME Property

public static String NAME {get;}

See Also

Sprint.Type.PlanProperty Class | StarTeam Namespace


Sprint.Type.PlanProperty Methods

The methods of the Sprint.Type.PlanProperty class are listed below. For a complete list of Sprint.Type.PlanProperty class members, see the Sprint.Type.PlanProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.PlanProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.PlanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.PlanProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.PlanProperty Class | StarTeam Namespace


Sprint.Type.PlanProperty.Equals Method

Delegate Equals() to com.starteam.Sprint.Type.PlanProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Sprint.Type.PlanProperty.Equals(obj).

See Also

Sprint.Type.PlanProperty Class | StarTeam Namespace


Sprint.Type.PlanProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Sprint.Type.PlanProperty.

public override int GetHashCode();

Return Value

com.starteam.Sprint.Type.PlanProperty.GetHashCode().

See Also

Sprint.Type.PlanProperty Class | StarTeam Namespace


Sprint.Type.PlanProperty.ToString Method

Delegate ToString() to com.starteam.Sprint.Type.PlanProperty.

public override string ToString();

Return Value

com.starteam.Sprint.Type.PlanProperty.ToString()

See Also

Sprint.Type.PlanProperty Class | StarTeam Namespace


Sprint.Type.PropertyCollection Class

The PropertyCollection of a Sprint

For a list of all members of this type, see Sprint.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Sprint.Type.PropertyCollection

new public class Sprint.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint.Type.PropertyCollection Members | StarTeam Namespace


Sprint.Type.PropertyCollection Members

Sprint.Type.PropertyCollection overview

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_DATE |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
OWNER |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PLAN |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SPRINT_ID |
START_DATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TARGET_RELEASES |
TEAM |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Sprint.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Sprint.Type.PropertyCollection.

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


Sprint.Type.PropertyCollection Properties

The properties of the Sprint.Type.PropertyCollection class are listed below. For a complete list of Sprint.Type.PropertyCollection class members, see the Sprint.Type.PropertyCollection Members topic.

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_DATE |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
OWNER |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PLAN |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SPRINT_ID |
START_DATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TARGET_RELEASES |
TEAM |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


END_DATE Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.END_DATE Property

public Sprint.Type.EndDateProperty END_DATE {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


OWNER Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.OWNER Property

public Sprint.Type.OwnerProperty OWNER {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


PLAN Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.PLAN Property

public Sprint.Type.PlanProperty PLAN {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


SPRINT_ID Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.SPRINT_ID Property

public Sprint.Type.SprintIDProperty SPRINT_ID {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


START_DATE Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.START_DATE Property

public Sprint.Type.StartDateProperty START_DATE {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


TARGET_RELEASES Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.TARGET_RELEASES Property

public Sprint.Type.TargetReleasesProperty TARGET_RELEASES {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


TEAM Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.TEAM Property

public Item.Type.TeamProperty TEAM {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.VERSION_METADATA Property

public Item.Type.VersionMetadataProperty VERSION_METADATA {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA_IDS Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.VERSION_METADATA_IDS Property

public Item.Type.VersionMetadataIDsProperty VERSION_METADATA_IDS {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Sprint.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


Sprint.Type.PropertyCollection Methods

The methods of the Sprint.Type.PropertyCollection class are listed below. For a complete list of Sprint.Type.PropertyCollection class members, see the Sprint.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Sprint.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Sprint.Type.PropertyCollection.

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


Sprint.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Sprint.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Sprint.Type.PropertyCollection.Equals(obj).

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


Sprint.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Sprint.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Sprint.Type.PropertyCollection.GetHashCode().

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


Sprint.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Sprint.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Sprint.Type.PropertyCollection.ToString()

See Also

Sprint.Type.PropertyCollection Class | StarTeam Namespace


Sprint.Type.SprintIDProperty Class

The property type of the SprintID property

For a list of all members of this type, see Sprint.Type.SprintIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Sprint.Type.SprintIDProperty

public class Sprint.Type.SprintIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint.Type.SprintIDProperty Members | StarTeam Namespace


Sprint.Type.SprintIDProperty Members

Sprint.Type.SprintIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.SprintIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.SprintIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.SprintIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.SprintIDProperty Class | StarTeam Namespace


Sprint.Type.SprintIDProperty Properties

The properties of the Sprint.Type.SprintIDProperty class are listed below. For a complete list of Sprint.Type.SprintIDProperty class members, see the Sprint.Type.SprintIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Sprint.Type.SprintIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Sprint.Type.SprintIDProperty.NAME Property

public static String NAME {get;}

See Also

Sprint.Type.SprintIDProperty Class | StarTeam Namespace


Sprint.Type.SprintIDProperty Methods

The methods of the Sprint.Type.SprintIDProperty class are listed below. For a complete list of Sprint.Type.SprintIDProperty class members, see the Sprint.Type.SprintIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.SprintIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.SprintIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.SprintIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.SprintIDProperty Class | StarTeam Namespace


Sprint.Type.SprintIDProperty.Equals Method

Delegate Equals() to com.starteam.Sprint.Type.SprintIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Sprint.Type.SprintIDProperty.Equals(obj).

See Also

Sprint.Type.SprintIDProperty Class | StarTeam Namespace


Sprint.Type.SprintIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Sprint.Type.SprintIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Sprint.Type.SprintIDProperty.GetHashCode().

See Also

Sprint.Type.SprintIDProperty Class | StarTeam Namespace


Sprint.Type.SprintIDProperty.ToString Method

Delegate ToString() to com.starteam.Sprint.Type.SprintIDProperty.

public override string ToString();

Return Value

com.starteam.Sprint.Type.SprintIDProperty.ToString()

See Also

Sprint.Type.SprintIDProperty Class | StarTeam Namespace


Sprint.Type.StartDateProperty Class

The property type of the StartDate property.

For a list of all members of this type, see Sprint.Type.StartDateProperty Members.

System.Object
Property
ScalarProperty
DateProperty
Sprint.Type.StartDateProperty

public class Sprint.Type.StartDateProperty : DateProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint.Type.StartDateProperty Members | StarTeam Namespace


Sprint.Type.StartDateProperty Members

Sprint.Type.StartDateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.StartDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.StartDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.StartDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.StartDateProperty Class | StarTeam Namespace


Sprint.Type.StartDateProperty Properties

The properties of the Sprint.Type.StartDateProperty class are listed below. For a complete list of Sprint.Type.StartDateProperty class members, see the Sprint.Type.StartDateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Sprint.Type.StartDateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Sprint.Type.StartDateProperty.NAME Property

public static String NAME {get;}

See Also

Sprint.Type.StartDateProperty Class | StarTeam Namespace


Sprint.Type.StartDateProperty Methods

The methods of the Sprint.Type.StartDateProperty class are listed below. For a complete list of Sprint.Type.StartDateProperty class members, see the Sprint.Type.StartDateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.StartDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.StartDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.StartDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.StartDateProperty Class | StarTeam Namespace


Sprint.Type.StartDateProperty.Equals Method

Delegate Equals() to com.starteam.Sprint.Type.StartDateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Sprint.Type.StartDateProperty.Equals(obj).

See Also

Sprint.Type.StartDateProperty Class | StarTeam Namespace


Sprint.Type.StartDateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Sprint.Type.StartDateProperty.

public override int GetHashCode();

Return Value

com.starteam.Sprint.Type.StartDateProperty.GetHashCode().

See Also

Sprint.Type.StartDateProperty Class | StarTeam Namespace


Sprint.Type.StartDateProperty.ToString Method

Delegate ToString() to com.starteam.Sprint.Type.StartDateProperty.

public override string ToString();

Return Value

com.starteam.Sprint.Type.StartDateProperty.ToString()

See Also

Sprint.Type.StartDateProperty Class | StarTeam Namespace


Sprint.Type.TargetReleasesProperty Class

The property type of the TargetReleases property.

For a list of all members of this type, see Sprint.Type.TargetReleasesProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Sprint.Type.TargetReleasesProperty

public class Sprint.Type.TargetReleasesProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint.Type.TargetReleasesProperty Members | StarTeam Namespace


Sprint.Type.TargetReleasesProperty Members

Sprint.Type.TargetReleasesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.TargetReleasesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.TargetReleasesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.TargetReleasesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.TargetReleasesProperty Class | StarTeam Namespace


Sprint.Type.TargetReleasesProperty Properties

The properties of the Sprint.Type.TargetReleasesProperty class are listed below. For a complete list of Sprint.Type.TargetReleasesProperty class members, see the Sprint.Type.TargetReleasesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Sprint.Type.TargetReleasesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Sprint.Type.TargetReleasesProperty.NAME Property

public static String NAME {get;}

See Also

Sprint.Type.TargetReleasesProperty Class | StarTeam Namespace


Sprint.Type.TargetReleasesProperty Methods

The methods of the Sprint.Type.TargetReleasesProperty class are listed below. For a complete list of Sprint.Type.TargetReleasesProperty class members, see the Sprint.Type.TargetReleasesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Sprint.Type.TargetReleasesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.Type.TargetReleasesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Sprint.Type.TargetReleasesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Sprint.Type.TargetReleasesProperty Class | StarTeam Namespace


Sprint.Type.TargetReleasesProperty.Equals Method

Delegate Equals() to com.starteam.Sprint.Type.TargetReleasesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Sprint.Type.TargetReleasesProperty.Equals(obj).

See Also

Sprint.Type.TargetReleasesProperty Class | StarTeam Namespace


Sprint.Type.TargetReleasesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Sprint.Type.TargetReleasesProperty.

public override int GetHashCode();

Return Value

com.starteam.Sprint.Type.TargetReleasesProperty.GetHashCode().

See Also

Sprint.Type.TargetReleasesProperty Class | StarTeam Namespace


Sprint.Type.TargetReleasesProperty.ToString Method

Delegate ToString() to com.starteam.Sprint.Type.TargetReleasesProperty.

public override string ToString();

Return Value

com.starteam.Sprint.Type.TargetReleasesProperty.ToString()

See Also

Sprint.Type.TargetReleasesProperty Class | StarTeam Namespace


Sprint.WebCacheSprint Class

Item accessor for cached SDK Sprint items contained objects are obtained from the artifact cache

For a list of all members of this type, see Sprint.WebCacheSprint Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
Sprint.WebCacheSprint

public class Sprint.WebCacheSprint : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Sprint.WebCacheSprint Members | StarTeam Namespace


Sprint.WebCacheSprint Members

Sprint.WebCacheSprint overview

Public Static Methods

Create Overloaded.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this sprint.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EndDate | [read/write] the End Date of this sprint.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Owner | [read/write] the User object who owns this sprint.
ParentFolder | [read] the folder in which this item exists.
ParentPlan | [read] The plan being set as parent of this or null
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
SprintID | [read] the sprint id.
StartDate | [read/write] the Start Date of this sprint.
TargetReleases | [read/write] the target releases that this sprint may be mapped to
Team | [read/write] The team for this sprint.
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Sprint.WebCacheSprint.
GetCapacity |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.WebCacheSprint.
GetStories |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasCapacity |
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetCapacity |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Sprint.WebCacheSprint.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint Properties

The properties of the Sprint.WebCacheSprint class are listed below. For a complete list of Sprint.WebCacheSprint class members, see the Sprint.WebCacheSprint Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this sprint.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EndDate | [read/write] the End Date of this sprint.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Owner | [read/write] the User object who owns this sprint.
ParentFolder | [read] the folder in which this item exists.
ParentPlan | [read] The plan being set as parent of this or null
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
SprintID | [read] the sprint id.
StartDate | [read/write] the Start Date of this sprint.
TargetReleases | [read/write] the target releases that this sprint may be mapped to
Team | [read/write] The team for this sprint.
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Description Property

[read/write] the description of this sprint.

public virtual String Description {get; set;}

Property Value

the description of this sprint.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


EndDate Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.EndDate Property

[read/write] the End Date of this sprint.

public virtual Date EndDate {get; set;}

Property Value

the End Date of this sprint.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Name Property

new public virtual String Name {get; set;}

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Owner Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Owner Property

[read/write] the User object who owns this sprint.

public virtual User.WebCacheUser Owner {get; set;}

Property Value

the User object who owns this sprint.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ParentPlan Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ParentPlan Property

[read] The plan being set as parent of this or null

public virtual Plan.WebCachePlan ParentPlan {get;}

Property Value

The plan being set as parent of this or null

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


SprintID Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.SprintID Property

[read] the sprint id.

public virtual Int32 SprintID {get;}

Property Value

the sprint id.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


StartDate Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.StartDate Property

[read/write] the Start Date of this sprint.

public virtual Date StartDate {get; set;}

Property Value

the Start Date of this sprint.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


TargetReleases Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.TargetReleases Property

[read/write] the target releases that this sprint may be mapped to

public virtual WebCacheView[] TargetReleases {get; set;}

Property Value

the target releases that this sprint may be mapped to

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Team Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Team Property

[read/write] The team for this sprint.

public virtual String Team {get; set;}

Property Value

The team for this sprint.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint Methods

The methods of the Sprint.WebCacheSprint class are listed below. For a complete list of Sprint.WebCacheSprint class members, see the Sprint.WebCacheSprint Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Sprint.WebCacheSprint.
GetCapacity |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Sprint.WebCacheSprint.
GetStories |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasCapacity |
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetCapacity |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Sprint.WebCacheSprint.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Create Method

Overload List

public static WebCacheSprint Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheSprint Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.Create Overload List


Sprint.WebCacheSprint.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.Create Overload List


Sprint.WebCacheSprint.Equals Method

Delegate Equals() to com.starteam.Sprint.WebCacheSprint.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Sprint.WebCacheSprint.Equals(obj).

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.GetCapacity Method

public virtual double GetCapacity(
User.WebCacheUser u
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.GetHashCode Method

Delegate GetHashCode() to com.starteam.Sprint.WebCacheSprint.

public override int GetHashCode();

Return Value

com.starteam.Sprint.WebCacheSprint.GetHashCode().

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.GetStories Method

public virtual WebCacheStory[] GetStories(
Filter.WebCacheFilter fltr
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.GetValue Overload List


Sprint.WebCacheSprint.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.GetValue Overload List


Sprint.WebCacheSprint.HasCapacity Method

public virtual bool HasCapacity(
User.WebCacheUser u
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | WebCacheViewMemberCollection


Sprint.WebCacheSprint.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.Lock Overload List | WebCacheViewMemberCollection


Sprint.WebCacheSprint.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.Lock Overload List


Sprint.WebCacheSprint.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | NAME


Sprint.WebCacheSprint.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.MoveTo Overload List


Sprint.WebCacheSprint.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.MoveTo Overload List


Sprint.WebCacheSprint.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | isFloating | isPinned | unpin


Sprint.WebCacheSprint.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | WebCacheViewMemberCollection


Sprint.WebCacheSprint.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.SetCapacity Method

public virtual void SetCapacity(
User.WebCacheUser u,
Double capacity
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Sprint.WebCacheSprint.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.SetValue Overload List


Sprint.WebCacheSprint.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | Sprint.WebCacheSprint.SetValue Overload List


Sprint.WebCacheSprint.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.ToString Method

Delegate ToString() to com.starteam.Sprint.WebCacheSprint.

public override string ToString();

Return Value

com.starteam.Sprint.WebCacheSprint.ToString()

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


Sprint.WebCacheSprint.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | WebCacheViewMemberCollection


Sprint.WebCacheSprint.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | isFloating | isPinned | pinTo


Sprint.WebCacheSprint.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace | WebCacheViewMemberCollection


Sprint.WebCacheSprint.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Sprint.WebCacheSprint Class | StarTeam Namespace


StarTeamClientOptions Class

Client Options maintained in the StarTeamClientOptions.xml file

For a list of all members of this type, see StarTeamClientOptions Members.

System.Object
StarTeamClientOptions

public class StarTeamClientOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeamClientOptions Members | StarTeam Namespace


StarTeamClientOptions Members

StarTeamClientOptions overview

Public Static Properties

Default | [read] the singleton default StarTeamClientOptions object
DefaultFile | [read] the default StarTeamClientOptions file
FILE_CENTRAL_STATUS_DIRECTORY |
FILE_CLEAR_LOCKS_ON_CHECK_IN |
FILE_COMPARE_OPTIONS |
FILE_COMPARE_PATH |
FILE_DEFAULT_ENCODING |
FILE_DEFAULT_EOL |
FILE_DEFAULT_STATUS_METHOD |
FILE_EDITOR_OPTIONS |
FILE_EDITOR_PATH |
FILE_LOCALDIRECTORYWATCH |
FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT |
FILE_MARK_UNLOCKED_FILES_READ_ONLY |
FILE_MERGE_OPTIONS |
FILE_MERGE_PATH |
FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS |
FILE_PERFORM_EOL_CONVERSION |
FILE_POPUP_VISMERGE_ALWAYS |
FILE_TRACK_ACTIVE_PROCESS_ITEM |
FILE_USE_ALTERNATE_COMPARE |
FILE_USE_ALTERNATE_EDITOR |
FILE_USE_ALTERNATE_MERGE |
FILE_USE_MD5_TO_CALCULATE_STATUS |
FILE_USE_MODIFIED_TIME_STAMP |
FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS |
FOLDER_USE_MODIFIED_TIME_STAMP |
WORKSPACE_AUTO_REFRESH |
WORKSPACE_CACHE_CREDENTIALS |
WORKSPACE_CHANGE_SCOPE_FOLDER |
WORKSPACE_CONFIRM_DELETE |
WORKSPACE_CONFIRM_MOVE |
WORKSPACE_DATE_TIME_FORMAT |
WORKSPACE_ENABLE_FILE_SYSTEM_WATCHING |
WORKSPACE_FALCON |
WORKSPACE_FOLDER_CONTEXT |
WORKSPACE_HISTORY_UTC |
WORKSPACE_INSTANT_REFRESH |
WORKSPACE_INSTANT_REFRESH_MAX_TIME |
WORKSPACE_INSTANT_REFRESH_MIN_TIME |
WORKSPACE_LOCALE |
WORKSPACE_LOG_COMMAND_DETAILS |
WORKSPACE_LOG_COMMANDS |
WORKSPACE_LOG_ERRORS |
WORKSPACE_LOG_EVENTS |
WORKSPACE_LOG_OUTPUT_PATH |
WORKSPACE_LOG_THRESHOLD |
WORKSPACE_LOG_UI_OPERATIONS |
WORKSPACE_MAINTAIN_GROUP_STATE |
WORKSPACE_PING |
WORKSPACE_REFRESH_TIME |
WORKSPACE_REPORT_DIRECTORY_PATH |
WORKSPACE_REPORT_OUTPUT_PATH |
WORKSPACE_RESTORE_SHORTCUTS |
WORKSPACE_SHOW_STATUSBAR |
WORKSPACE_SHOW_TOOLBARS |
WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS |
WORKSPACE_TIME_SPAN_FORMAT |
WORKSPACE_WARNINGS |

Public Static Methods

FromStarFlowExtensions | Update the client options on disk from StarFlow Extensions, if available. Set the in memory extensions to the server wide values as well. Return the locked option set, if any, in a hashtable, where the keys are the componentName::optionName, the values are saved to the client options.xml file, hence irrelevant to the UI
IsLocked | returns true if the specified option is locked if so, the GUI (CPC) will disable the control

Public Instance Constructors

StarTeamClientOptions Constructor Creates a new StarTeamClientOptions instance which can be used to get/set client side options used by StarTeam clients.

Public Instance Properties

CacheCredentialsLocally | [read] option value. Default if not defined: true
CentralStatusDirectory | [read/write] path for storing centralized status.
ComponentNames | [read] The names of all components for which at least one option has been set.
DefaultStatusMethod | [read/write] the default status method to be used by the client. If not set in these options then this method CENTRAL.
FileClearLocksOnCheckIn | [read/write] option value. Default if not defined: false
FileCompareOptions | [read/write] option value. Default if not defined: ""
FileComparePath | [read/write] option value. Default if not defined: ""
FileDefaultEncoding | [read/write] option value. Default if not defined: the value of the system property "file.encoding"
FileDefaultEOL | [read/write] option value. Default if not defined: the platform definition of EOL
FileEditorOptions | [read/write] option value. Default if not defined: ""
FileEditorPath | [read/write] option value. Default if not defined: ""
FileLocalDirectoryWatch | [read/write] option value. Default if not defined: true
FileLockFilesExclusivelyOnCheckOut | [read/write] option value. Default if not defined: false
FileMarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
FileMergeOptions | [read/write] option value. Default if not defined: ""
FileMergePath | [read/write] option value. Default if not defined: ""
FileOptimizeForSlowConnections | [read/write] option value. Default if not defined: false
FilePerformEOLConversion | [read/write] option value. Default if not defined: true
FilePopupVisMergeAlways | [read/write] option value. Default if not defined: true
FileTrackActiveProcessItem | [read/write] option value. Default if not defined: false
FileUseAlternateCompare | [read/write] option value. Default if not defined: false
FileUseAlternateEditor | [read/write] option value. Default if not defined: false
FileUseAlternateMerge | [read/write] option value. Default if not defined: false
FileUseMD5ToCalculateStatus | [read/write] option value. Default if not defined: false
FileUseModifiedTimeStamp | [read/write] option value. Default if not defined: false
FileUseNonExclusiveLocksInIntegrations | [read/write] option value. Default if not defined: true
FolderUseModifiedTimeStamp | [read/write] option value. Default if not defined: false
MPXEnabled | [read/write] option value. Default if not defined: true
ShowNotInViewFoldersByDefault | [read] true if not in view folders are to be shown by default
WorkspaceAutoRefresh | [read/write] option value. Default if not defined: false
WorkspaceChangeScopeFolder | [read/write] option value. Default if not defined: false
WorkspaceConfirmDelete | [read/write] option value. Default if not defined: true
WorkspaceConfirmMove | [read/write] option value. Default if not defined: true
WorkspaceDateTimeFormat | [read/write] option value. Default if not defined: ""
WorkspaceEnableFileSystemWatching | [read/write] option value. Default if not defined: true
WorkspaceFolderContext | [read/write] option value. Default if not defined: true
WorkspaceHistoryUTC | [read/write] option value. Default if not defined: false
WorkspaceInstantRefresh | [read/write] option value. Default if not defined: true
WorkspaceInstantRefreshMaxTime | [read/write] option value. Default if not defined: 30
WorkspaceInstantRefreshMinTime | [read/write] option value. Default if not defined: 5
WorkspaceLocale | [read/write] option value. Default if not defined: ""
WorkspaceLogCommandDetails | [read/write] option value. Default if not defined: false
WorkspaceLogCommands | [read/write] option value. Default if not defined: false
WorkspaceLogErrors | [read/write] option value. Default if not defined: true
WorkspaceLogEvents | [read/write] option value. Default if not defined: false
WorkspaceLogOutputPath | [read/write] option value. Default if not defined: ""
WorkspaceLogThreshold | [read/write] option value. Default if not defined: 10
WorkspaceLogUIOperations | [read/write] option value. Default if not defined: false
WorkspaceMaintainGroupState | [read/write] option value. Default if not defined: true
WorkspacePing | [read/write] option value. Default if not defined: -1
WorkspaceRefreshTime | [read/write] option value.
WorkspaceReportDirectoryPath | [read/write] option value. Default if not defined: ""
WorkspaceReportOutputPath | [read/write] option value. Default if not defined: ""
WorkspaceRestoreShortcuts | [read/write] option value. Default if not defined: true
WorkspaceShowStatusBar | [read/write] option value. Default if not defined: true
WorkspaceShowToolbars | [read/write] option value. Default if not defined: true
WorkspaceShowVirtualMeetingOptions | [read/write] option value. Default if not defined: false
WorkspaceTimeSpanFormat | [read/write] option value. Default if not defined: EMPTY
WorkspaceWarnings | [read/write] option value. Default if not defined: true

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StarTeamClientOptions.
GetAllProcessItems | Gets the list of items that have been set as the current process item for at least one view on the given server.
GetCheckNewItemActivated | Returns the workstation option value.
GetCheckNewItemInterval | Returns the workstation option value.
GetComponentOption | Returns the specified workstation option. If the option is not set then the specified default value is returned.
GetFolderAlternatePath | Overloaded. Returns the alternate working directory for the specified folder. This may return null.
GetFolderAlternatePathEnabled | Overloaded. Return true if the alternate working directory is enabled for this folder.
GetFolderUserVisible | Overloaded. Return true if the specified folder is user visible. A UI should not display items in an invisible folder.
GetHashCode | Delegate GetHashCode() to com.starteam.StarTeamClientOptions.
GetOption | Returns the specified workstation option. If the option is not set then the specified default value is returned.
GetOptionNames | Gets the names of all options that have been set for a given component.
GetProcessItem | Gets the current process item in the given target view.
GetReadOnSelectChangeActivated | Returns the workstation option value.
GetSelectedItemTimerActivated | Returns the workstation option value.
GetSelectedItemTimerInterval | Returns the workstation option value.
GetShowNotInViewFolders | Returns true if not in view folders in the specified view are to be shown
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewAlternatePath | Overloaded. Returns the alternate working directory for the specified view. This may return null.
GetViewAlternatePathEnabled | Overloaded. Return true if the alternate working directory is enabled for this view.
GetViewStatusMethodOverride | Returns the option value stored for the specified View's status method.
Load | Load the options from the specified file. This file becomes the new underlying file for this StarTeamClientOptions object.
LoadDefault | Loads the options from the default file.
Reload | Re-loads the underlying options file.
ReloadIfNeeded | Re-loads the file only if its last modified time stamp has changed. Returns true if the file was reloaded, false if not.
Save | Writes the options to the underlying file.
SaveTo | Saves the options to the new file. This becomes the new underlying file for this StarTeamClientOptions object.
SetCheckNewItemActivated | Sets the workstation option value.
SetCheckNewItemInterval | Sets the workstation option value.
SetComponentOption | Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.
SetFolderAlternatePath | Overloaded. Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.
SetFolderAlternatePathEnabled | Overloaded. Change whether or not the alternate working directory should be used for the specified folder.
SetFolderUserVisible | Overloaded. Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.
SetOption | Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.
SetProcessItem | Sets the current process item for the given target view.
SetReadOnSelectChangeActivated | Sets the workstation option value.
SetSelectedItemTimerActivated | Sets the workstation option value.
SetSelectedItemTimerInterval | Sets the workstation option value.
SetViewAlternatePath | Overloaded. Change the option value stored for the specified View's alternate working directory. This does not modify the view object.
SetViewAlternatePathEnabled | Overloaded. Change whether or not the alternate working directory should be used for the specified view.
SetViewStatusMethodOverride | Change the option value stored for the specified View's status method This does not modify the view object.
ToString | Delegate ToString() to com.starteam.StarTeamClientOptions.

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions Constructor

Creates a new StarTeamClientOptions instance which can be used to get/set client side options used by StarTeam clients.

public StarTeamClientOptions();

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions Properties

The properties of the StarTeamClientOptions class are listed below. For a complete list of StarTeamClientOptions class members, see the StarTeamClientOptions Members topic.

Public Static Properties

Default | [read] the singleton default StarTeamClientOptions object
DefaultFile | [read] the default StarTeamClientOptions file
FILE_CENTRAL_STATUS_DIRECTORY |
FILE_CLEAR_LOCKS_ON_CHECK_IN |
FILE_COMPARE_OPTIONS |
FILE_COMPARE_PATH |
FILE_DEFAULT_ENCODING |
FILE_DEFAULT_EOL |
FILE_DEFAULT_STATUS_METHOD |
FILE_EDITOR_OPTIONS |
FILE_EDITOR_PATH |
FILE_LOCALDIRECTORYWATCH |
FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT |
FILE_MARK_UNLOCKED_FILES_READ_ONLY |
FILE_MERGE_OPTIONS |
FILE_MERGE_PATH |
FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS |
FILE_PERFORM_EOL_CONVERSION |
FILE_POPUP_VISMERGE_ALWAYS |
FILE_TRACK_ACTIVE_PROCESS_ITEM |
FILE_USE_ALTERNATE_COMPARE |
FILE_USE_ALTERNATE_EDITOR |
FILE_USE_ALTERNATE_MERGE |
FILE_USE_MD5_TO_CALCULATE_STATUS |
FILE_USE_MODIFIED_TIME_STAMP |
FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS |
FOLDER_USE_MODIFIED_TIME_STAMP |
WORKSPACE_AUTO_REFRESH |
WORKSPACE_CACHE_CREDENTIALS |
WORKSPACE_CHANGE_SCOPE_FOLDER |
WORKSPACE_CONFIRM_DELETE |
WORKSPACE_CONFIRM_MOVE |
WORKSPACE_DATE_TIME_FORMAT |
WORKSPACE_ENABLE_FILE_SYSTEM_WATCHING |
WORKSPACE_FALCON |
WORKSPACE_FOLDER_CONTEXT |
WORKSPACE_HISTORY_UTC |
WORKSPACE_INSTANT_REFRESH |
WORKSPACE_INSTANT_REFRESH_MAX_TIME |
WORKSPACE_INSTANT_REFRESH_MIN_TIME |
WORKSPACE_LOCALE |
WORKSPACE_LOG_COMMAND_DETAILS |
WORKSPACE_LOG_COMMANDS |
WORKSPACE_LOG_ERRORS |
WORKSPACE_LOG_EVENTS |
WORKSPACE_LOG_OUTPUT_PATH |
WORKSPACE_LOG_THRESHOLD |
WORKSPACE_LOG_UI_OPERATIONS |
WORKSPACE_MAINTAIN_GROUP_STATE |
WORKSPACE_PING |
WORKSPACE_REFRESH_TIME |
WORKSPACE_REPORT_DIRECTORY_PATH |
WORKSPACE_REPORT_OUTPUT_PATH |
WORKSPACE_RESTORE_SHORTCUTS |
WORKSPACE_SHOW_STATUSBAR |
WORKSPACE_SHOW_TOOLBARS |
WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS |
WORKSPACE_TIME_SPAN_FORMAT |
WORKSPACE_WARNINGS |

Public Instance Properties

CacheCredentialsLocally | [read] option value. Default if not defined: true
CentralStatusDirectory | [read/write] path for storing centralized status.
ComponentNames | [read] The names of all components for which at least one option has been set.
DefaultStatusMethod | [read/write] the default status method to be used by the client. If not set in these options then this method CENTRAL.
FileClearLocksOnCheckIn | [read/write] option value. Default if not defined: false
FileCompareOptions | [read/write] option value. Default if not defined: ""
FileComparePath | [read/write] option value. Default if not defined: ""
FileDefaultEncoding | [read/write] option value. Default if not defined: the value of the system property "file.encoding"
FileDefaultEOL | [read/write] option value. Default if not defined: the platform definition of EOL
FileEditorOptions | [read/write] option value. Default if not defined: ""
FileEditorPath | [read/write] option value. Default if not defined: ""
FileLocalDirectoryWatch | [read/write] option value. Default if not defined: true
FileLockFilesExclusivelyOnCheckOut | [read/write] option value. Default if not defined: false
FileMarkUnlockedFilesReadOnly | [read/write] option value. Default if not defined: false
FileMergeOptions | [read/write] option value. Default if not defined: ""
FileMergePath | [read/write] option value. Default if not defined: ""
FileOptimizeForSlowConnections | [read/write] option value. Default if not defined: false
FilePerformEOLConversion | [read/write] option value. Default if not defined: true
FilePopupVisMergeAlways | [read/write] option value. Default if not defined: true
FileTrackActiveProcessItem | [read/write] option value. Default if not defined: false
FileUseAlternateCompare | [read/write] option value. Default if not defined: false
FileUseAlternateEditor | [read/write] option value. Default if not defined: false
FileUseAlternateMerge | [read/write] option value. Default if not defined: false
FileUseMD5ToCalculateStatus | [read/write] option value. Default if not defined: false
FileUseModifiedTimeStamp | [read/write] option value. Default if not defined: false
FileUseNonExclusiveLocksInIntegrations | [read/write] option value. Default if not defined: true
FolderUseModifiedTimeStamp | [read/write] option value. Default if not defined: false
MPXEnabled | [read/write] option value. Default if not defined: true
ShowNotInViewFoldersByDefault | [read] true if not in view folders are to be shown by default
WorkspaceAutoRefresh | [read/write] option value. Default if not defined: false
WorkspaceChangeScopeFolder | [read/write] option value. Default if not defined: false
WorkspaceConfirmDelete | [read/write] option value. Default if not defined: true
WorkspaceConfirmMove | [read/write] option value. Default if not defined: true
WorkspaceDateTimeFormat | [read/write] option value. Default if not defined: ""
WorkspaceEnableFileSystemWatching | [read/write] option value. Default if not defined: true
WorkspaceFolderContext | [read/write] option value. Default if not defined: true
WorkspaceHistoryUTC | [read/write] option value. Default if not defined: false
WorkspaceInstantRefresh | [read/write] option value. Default if not defined: true
WorkspaceInstantRefreshMaxTime | [read/write] option value. Default if not defined: 30
WorkspaceInstantRefreshMinTime | [read/write] option value. Default if not defined: 5
WorkspaceLocale | [read/write] option value. Default if not defined: ""
WorkspaceLogCommandDetails | [read/write] option value. Default if not defined: false
WorkspaceLogCommands | [read/write] option value. Default if not defined: false
WorkspaceLogErrors | [read/write] option value. Default if not defined: true
WorkspaceLogEvents | [read/write] option value. Default if not defined: false
WorkspaceLogOutputPath | [read/write] option value. Default if not defined: ""
WorkspaceLogThreshold | [read/write] option value. Default if not defined: 10
WorkspaceLogUIOperations | [read/write] option value. Default if not defined: false
WorkspaceMaintainGroupState | [read/write] option value. Default if not defined: true
WorkspacePing | [read/write] option value. Default if not defined: -1
WorkspaceRefreshTime | [read/write] option value.
WorkspaceReportDirectoryPath | [read/write] option value. Default if not defined: ""
WorkspaceReportOutputPath | [read/write] option value. Default if not defined: ""
WorkspaceRestoreShortcuts | [read/write] option value. Default if not defined: true
WorkspaceShowStatusBar | [read/write] option value. Default if not defined: true
WorkspaceShowToolbars | [read/write] option value. Default if not defined: true
WorkspaceShowVirtualMeetingOptions | [read/write] option value. Default if not defined: false
WorkspaceTimeSpanFormat | [read/write] option value. Default if not defined: EMPTY
WorkspaceWarnings | [read/write] option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


CacheCredentialsLocally Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.CacheCredentialsLocally Property

[read] option value. Default if not defined: true

public virtual Boolean CacheCredentialsLocally {get;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


CentralStatusDirectory Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.CentralStatusDirectory Property

[read/write] path for storing centralized status.

public virtual String CentralStatusDirectory {get; set;}

Property Value

path for storing centralized status.

See Also

StarTeamClientOptions Class | StarTeam Namespace


ComponentNames Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.ComponentNames Property

[read] The names of all components for which at least one option has been set.

public virtual String[] ComponentNames {get;}

Property Value

The names of all components for which at least one option has been set.

See Also

StarTeamClientOptions Class | StarTeam Namespace


Default Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.Default Property

[read] the singleton default StarTeamClientOptions object

public static StarTeamClientOptions Default {get;}

Property Value

the singleton default StarTeamClientOptions object

See Also

StarTeamClientOptions Class | StarTeam Namespace


DefaultFile Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.DefaultFile Property

[read] the default StarTeamClientOptions file

public static FileInfo DefaultFile {get;}

Property Value

the default StarTeamClientOptions file

See Also

StarTeamClientOptions Class | StarTeam Namespace


DefaultStatusMethod Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.DefaultStatusMethod Property

[read/write] the default status method to be used by the client. If not set in these options then this method CENTRAL.

public virtual StatusMethod DefaultStatusMethod {get; set;}

Property Value

the default status method to be used by the client. If not set in these options then this method CENTRAL.

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_CENTRAL_STATUS_DIRECTORY Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_CENTRAL_STATUS_DIRECTORY Property

public static String FILE_CENTRAL_STATUS_DIRECTORY {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_CLEAR_LOCKS_ON_CHECK_IN Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_CLEAR_LOCKS_ON_CHECK_IN Property

public static String FILE_CLEAR_LOCKS_ON_CHECK_IN {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_COMPARE_OPTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_COMPARE_OPTIONS Property

public static String FILE_COMPARE_OPTIONS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_COMPARE_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_COMPARE_PATH Property

public static String FILE_COMPARE_PATH {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_DEFAULT_ENCODING Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_DEFAULT_ENCODING Property

public static String FILE_DEFAULT_ENCODING {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_DEFAULT_EOL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_DEFAULT_EOL Property

public static String FILE_DEFAULT_EOL {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_DEFAULT_STATUS_METHOD Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_DEFAULT_STATUS_METHOD Property

public static String FILE_DEFAULT_STATUS_METHOD {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_EDITOR_OPTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_EDITOR_OPTIONS Property

public static String FILE_EDITOR_OPTIONS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_EDITOR_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_EDITOR_PATH Property

public static String FILE_EDITOR_PATH {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_LOCALDIRECTORYWATCH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_LOCALDIRECTORYWATCH Property

public static String FILE_LOCALDIRECTORYWATCH {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT Property

public static String FILE_LOCK_FILES_EXCLUSIVELY_ON_CHECK_OUT {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_MARK_UNLOCKED_FILES_READ_ONLY Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_MARK_UNLOCKED_FILES_READ_ONLY Property

public static String FILE_MARK_UNLOCKED_FILES_READ_ONLY {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_MERGE_OPTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_MERGE_OPTIONS Property

public static String FILE_MERGE_OPTIONS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_MERGE_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_MERGE_PATH Property

public static String FILE_MERGE_PATH {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS Property

public static String FILE_OPTIMIZE_FOR_SLOW_CONNECTIONS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_PERFORM_EOL_CONVERSION Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_PERFORM_EOL_CONVERSION Property

public static String FILE_PERFORM_EOL_CONVERSION {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_POPUP_VISMERGE_ALWAYS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_POPUP_VISMERGE_ALWAYS Property

public static String FILE_POPUP_VISMERGE_ALWAYS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_TRACK_ACTIVE_PROCESS_ITEM Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_TRACK_ACTIVE_PROCESS_ITEM Property

public static String FILE_TRACK_ACTIVE_PROCESS_ITEM {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_USE_ALTERNATE_COMPARE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_ALTERNATE_COMPARE Property

public static String FILE_USE_ALTERNATE_COMPARE {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_USE_ALTERNATE_EDITOR Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_ALTERNATE_EDITOR Property

public static String FILE_USE_ALTERNATE_EDITOR {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_USE_ALTERNATE_MERGE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_ALTERNATE_MERGE Property

public static String FILE_USE_ALTERNATE_MERGE {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_USE_MD5_TO_CALCULATE_STATUS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_MD5_TO_CALCULATE_STATUS Property

public static String FILE_USE_MD5_TO_CALCULATE_STATUS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_USE_MODIFIED_TIME_STAMP Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_MODIFIED_TIME_STAMP Property

public static String FILE_USE_MODIFIED_TIME_STAMP {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS Property

public static String FILE_USE_NON_EXCLUSIVE_LOCKS_IN_INTEGRATIONS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileClearLocksOnCheckIn Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileClearLocksOnCheckIn Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileClearLocksOnCheckIn {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileCompareOptions Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileCompareOptions Property

[read/write] option value. Default if not defined: ""

public virtual String FileCompareOptions {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileComparePath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileComparePath Property

[read/write] option value. Default if not defined: ""

public virtual String FileComparePath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileDefaultEncoding Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileDefaultEncoding Property

[read/write] option value. Default if not defined: the value of the system property "file.encoding"

public virtual Encoding FileDefaultEncoding {get; set;}

Property Value

option value. Default if not defined: the value of the system property "file.encoding"

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileDefaultEOL Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileDefaultEOL Property

[read/write] option value. Default if not defined: the platform definition of EOL

public virtual Int32 FileDefaultEOL {get; set;}

Property Value

option value. Default if not defined: the platform definition of EOL

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileEditorOptions Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileEditorOptions Property

[read/write] option value. Default if not defined: ""

public virtual String FileEditorOptions {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileEditorPath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileEditorPath Property

[read/write] option value. Default if not defined: ""

public virtual String FileEditorPath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileLocalDirectoryWatch Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileLocalDirectoryWatch Property

[read/write] option value. Default if not defined: true

public virtual Boolean FileLocalDirectoryWatch {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileLockFilesExclusivelyOnCheckOut Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileLockFilesExclusivelyOnCheckOut Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileLockFilesExclusivelyOnCheckOut {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileMarkUnlockedFilesReadOnly Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileMarkUnlockedFilesReadOnly Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileMarkUnlockedFilesReadOnly {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileMergeOptions Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileMergeOptions Property

[read/write] option value. Default if not defined: ""

public virtual String FileMergeOptions {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileMergePath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileMergePath Property

[read/write] option value. Default if not defined: ""

public virtual String FileMergePath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileOptimizeForSlowConnections Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileOptimizeForSlowConnections Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileOptimizeForSlowConnections {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FilePerformEOLConversion Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FilePerformEOLConversion Property

[read/write] option value. Default if not defined: true

public virtual Boolean FilePerformEOLConversion {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


FilePopupVisMergeAlways Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FilePopupVisMergeAlways Property

[read/write] option value. Default if not defined: true

public virtual Boolean FilePopupVisMergeAlways {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileTrackActiveProcessItem Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileTrackActiveProcessItem Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileTrackActiveProcessItem {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileUseAlternateCompare Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseAlternateCompare Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseAlternateCompare {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileUseAlternateEditor Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseAlternateEditor Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseAlternateEditor {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileUseAlternateMerge Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseAlternateMerge Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseAlternateMerge {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileUseMD5ToCalculateStatus Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseMD5ToCalculateStatus Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseMD5ToCalculateStatus {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileUseModifiedTimeStamp Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseModifiedTimeStamp Property

[read/write] option value. Default if not defined: false

public virtual Boolean FileUseModifiedTimeStamp {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


FileUseNonExclusiveLocksInIntegrations Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FileUseNonExclusiveLocksInIntegrations Property

[read/write] option value. Default if not defined: true

public virtual Boolean FileUseNonExclusiveLocksInIntegrations {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


FOLDER_USE_MODIFIED_TIME_STAMP Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FOLDER_USE_MODIFIED_TIME_STAMP Property

public static String FOLDER_USE_MODIFIED_TIME_STAMP {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


FolderUseModifiedTimeStamp Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.FolderUseModifiedTimeStamp Property

[read/write] option value. Default if not defined: false

public virtual Boolean FolderUseModifiedTimeStamp {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


MPXEnabled Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.MPXEnabled Property

[read/write] option value. Default if not defined: true

public virtual Boolean MPXEnabled {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


ShowNotInViewFoldersByDefault Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.ShowNotInViewFoldersByDefault Property

[read] true if not in view folders are to be shown by default

public virtual Boolean ShowNotInViewFoldersByDefault {get;}

Property Value

true if not in view folders are to be shown by default

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_AUTO_REFRESH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_AUTO_REFRESH Property

public static String WORKSPACE_AUTO_REFRESH {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_CACHE_CREDENTIALS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_CACHE_CREDENTIALS Property

public static String WORKSPACE_CACHE_CREDENTIALS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_CHANGE_SCOPE_FOLDER Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_CHANGE_SCOPE_FOLDER Property

public static String WORKSPACE_CHANGE_SCOPE_FOLDER {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_CONFIRM_DELETE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_CONFIRM_DELETE Property

public static String WORKSPACE_CONFIRM_DELETE {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_CONFIRM_MOVE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_CONFIRM_MOVE Property

public static String WORKSPACE_CONFIRM_MOVE {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_DATE_TIME_FORMAT Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_DATE_TIME_FORMAT Property

public static String WORKSPACE_DATE_TIME_FORMAT {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_ENABLE_FILE_SYSTEM_WATCHING Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_ENABLE_FILE_SYSTEM_WATCHING Property

public static String WORKSPACE_ENABLE_FILE_SYSTEM_WATCHING {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_FALCON Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_FALCON Property

public static String WORKSPACE_FALCON {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_FOLDER_CONTEXT Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_FOLDER_CONTEXT Property

public static String WORKSPACE_FOLDER_CONTEXT {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_HISTORY_UTC Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_HISTORY_UTC Property

public static String WORKSPACE_HISTORY_UTC {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_INSTANT_REFRESH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_INSTANT_REFRESH Property

public static String WORKSPACE_INSTANT_REFRESH {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_INSTANT_REFRESH_MAX_TIME Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_INSTANT_REFRESH_MAX_TIME Property

public static String WORKSPACE_INSTANT_REFRESH_MAX_TIME {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_INSTANT_REFRESH_MIN_TIME Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_INSTANT_REFRESH_MIN_TIME Property

public static String WORKSPACE_INSTANT_REFRESH_MIN_TIME {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_LOCALE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOCALE Property

public static String WORKSPACE_LOCALE {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_LOG_COMMAND_DETAILS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_COMMAND_DETAILS Property

public static String WORKSPACE_LOG_COMMAND_DETAILS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_LOG_COMMANDS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_COMMANDS Property

public static String WORKSPACE_LOG_COMMANDS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_LOG_ERRORS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_ERRORS Property

public static String WORKSPACE_LOG_ERRORS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_LOG_EVENTS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_EVENTS Property

public static String WORKSPACE_LOG_EVENTS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_LOG_OUTPUT_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_OUTPUT_PATH Property

public static String WORKSPACE_LOG_OUTPUT_PATH {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_LOG_THRESHOLD Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_THRESHOLD Property

public static String WORKSPACE_LOG_THRESHOLD {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_LOG_UI_OPERATIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_LOG_UI_OPERATIONS Property

public static String WORKSPACE_LOG_UI_OPERATIONS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_MAINTAIN_GROUP_STATE Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_MAINTAIN_GROUP_STATE Property

public static String WORKSPACE_MAINTAIN_GROUP_STATE {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_PING Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_PING Property

public static String WORKSPACE_PING {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_REFRESH_TIME Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_REFRESH_TIME Property

public static String WORKSPACE_REFRESH_TIME {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_REPORT_DIRECTORY_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_REPORT_DIRECTORY_PATH Property

public static String WORKSPACE_REPORT_DIRECTORY_PATH {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_REPORT_OUTPUT_PATH Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_REPORT_OUTPUT_PATH Property

public static String WORKSPACE_REPORT_OUTPUT_PATH {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_RESTORE_SHORTCUTS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_RESTORE_SHORTCUTS Property

public static String WORKSPACE_RESTORE_SHORTCUTS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_SHOW_STATUSBAR Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_SHOW_STATUSBAR Property

public static String WORKSPACE_SHOW_STATUSBAR {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_SHOW_TOOLBARS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_SHOW_TOOLBARS Property

public static String WORKSPACE_SHOW_TOOLBARS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS Property

public static String WORKSPACE_SHOW_VIRTUAL_MEETING_OPTIONS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_TIME_SPAN_FORMAT Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_TIME_SPAN_FORMAT Property

public static String WORKSPACE_TIME_SPAN_FORMAT {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WORKSPACE_WARNINGS Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WORKSPACE_WARNINGS Property

public static String WORKSPACE_WARNINGS {get;}

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceAutoRefresh Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceAutoRefresh Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceAutoRefresh {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceChangeScopeFolder Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceChangeScopeFolder Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceChangeScopeFolder {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceConfirmDelete Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceConfirmDelete Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceConfirmDelete {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceConfirmMove Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceConfirmMove Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceConfirmMove {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceDateTimeFormat Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceDateTimeFormat Property

[read/write] option value. Default if not defined: ""

public virtual String WorkspaceDateTimeFormat {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceEnableFileSystemWatching Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceEnableFileSystemWatching Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceEnableFileSystemWatching {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceFolderContext Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceFolderContext Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceFolderContext {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceHistoryUTC Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceHistoryUTC Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceHistoryUTC {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceInstantRefresh Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceInstantRefresh Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceInstantRefresh {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceInstantRefreshMaxTime Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceInstantRefreshMaxTime Property

[read/write] option value. Default if not defined: 30

public virtual Int32 WorkspaceInstantRefreshMaxTime {get; set;}

Property Value

option value. Default if not defined: 30

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceInstantRefreshMinTime Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceInstantRefreshMinTime Property

[read/write] option value. Default if not defined: 5

public virtual Int32 WorkspaceInstantRefreshMinTime {get; set;}

Property Value

option value. Default if not defined: 5

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceLocale Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLocale Property

[read/write] option value. Default if not defined: ""

public virtual String WorkspaceLocale {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceLogCommandDetails Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogCommandDetails Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceLogCommandDetails {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceLogCommands Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogCommands Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceLogCommands {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceLogErrors Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogErrors Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceLogErrors {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceLogEvents Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogEvents Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceLogEvents {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceLogOutputPath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogOutputPath Property

[read/write] option value. Default if not defined: ""

public virtual String WorkspaceLogOutputPath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceLogThreshold Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogThreshold Property

[read/write] option value. Default if not defined: 10

public virtual Int32 WorkspaceLogThreshold {get; set;}

Property Value

option value. Default if not defined: 10

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceLogUIOperations Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceLogUIOperations Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceLogUIOperations {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceMaintainGroupState Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceMaintainGroupState Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceMaintainGroupState {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspacePing Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspacePing Property

[read/write] option value. Default if not defined: -1

public virtual Int32 WorkspacePing {get; set;}

Property Value

option value. Default if not defined: -1

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceRefreshTime Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceRefreshTime Property

[read/write] option value.

public virtual Int32 WorkspaceRefreshTime {get; set;}

Property Value

option value.

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceReportDirectoryPath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceReportDirectoryPath Property

[read/write] option value. Default if not defined: ""

public virtual String WorkspaceReportDirectoryPath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceReportOutputPath Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceReportOutputPath Property

[read/write] option value. Default if not defined: ""

public virtual String WorkspaceReportOutputPath {get; set;}

Property Value

option value. Default if not defined: ""

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceRestoreShortcuts Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceRestoreShortcuts Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceRestoreShortcuts {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceShowStatusBar Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceShowStatusBar Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceShowStatusBar {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceShowToolbars Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceShowToolbars Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceShowToolbars {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceShowVirtualMeetingOptions Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceShowVirtualMeetingOptions Property

[read/write] option value. Default if not defined: false

public virtual Boolean WorkspaceShowVirtualMeetingOptions {get; set;}

Property Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceTimeSpanFormat Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceTimeSpanFormat Property

[read/write] option value. Default if not defined: EMPTY

public virtual String WorkspaceTimeSpanFormat {get; set;}

Property Value

option value. Default if not defined: EMPTY

See Also

StarTeamClientOptions Class | StarTeam Namespace


WorkspaceWarnings Property

Borland StarTeam SDK for .NET

StarTeamClientOptions.WorkspaceWarnings Property

[read/write] option value. Default if not defined: true

public virtual Boolean WorkspaceWarnings {get; set;}

Property Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions Methods

The methods of the StarTeamClientOptions class are listed below. For a complete list of StarTeamClientOptions class members, see the StarTeamClientOptions Members topic.

Public Static Methods

FromStarFlowExtensions | Update the client options on disk from StarFlow Extensions, if available. Set the in memory extensions to the server wide values as well. Return the locked option set, if any, in a hashtable, where the keys are the componentName::optionName, the values are saved to the client options.xml file, hence irrelevant to the UI
IsLocked | returns true if the specified option is locked if so, the GUI (CPC) will disable the control

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StarTeamClientOptions.
GetAllProcessItems | Gets the list of items that have been set as the current process item for at least one view on the given server.
GetCheckNewItemActivated | Returns the workstation option value.
GetCheckNewItemInterval | Returns the workstation option value.
GetComponentOption | Returns the specified workstation option. If the option is not set then the specified default value is returned.
GetFolderAlternatePath | Overloaded. Returns the alternate working directory for the specified folder. This may return null.
GetFolderAlternatePathEnabled | Overloaded. Return true if the alternate working directory is enabled for this folder.
GetFolderUserVisible | Overloaded. Return true if the specified folder is user visible. A UI should not display items in an invisible folder.
GetHashCode | Delegate GetHashCode() to com.starteam.StarTeamClientOptions.
GetOption | Returns the specified workstation option. If the option is not set then the specified default value is returned.
GetOptionNames | Gets the names of all options that have been set for a given component.
GetProcessItem | Gets the current process item in the given target view.
GetReadOnSelectChangeActivated | Returns the workstation option value.
GetSelectedItemTimerActivated | Returns the workstation option value.
GetSelectedItemTimerInterval | Returns the workstation option value.
GetShowNotInViewFolders | Returns true if not in view folders in the specified view are to be shown
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewAlternatePath | Overloaded. Returns the alternate working directory for the specified view. This may return null.
GetViewAlternatePathEnabled | Overloaded. Return true if the alternate working directory is enabled for this view.
GetViewStatusMethodOverride | Returns the option value stored for the specified View's status method.
Load | Load the options from the specified file. This file becomes the new underlying file for this StarTeamClientOptions object.
LoadDefault | Loads the options from the default file.
Reload | Re-loads the underlying options file.
ReloadIfNeeded | Re-loads the file only if its last modified time stamp has changed. Returns true if the file was reloaded, false if not.
Save | Writes the options to the underlying file.
SaveTo | Saves the options to the new file. This becomes the new underlying file for this StarTeamClientOptions object.
SetCheckNewItemActivated | Sets the workstation option value.
SetCheckNewItemInterval | Sets the workstation option value.
SetComponentOption | Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.
SetFolderAlternatePath | Overloaded. Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.
SetFolderAlternatePathEnabled | Overloaded. Change whether or not the alternate working directory should be used for the specified folder.
SetFolderUserVisible | Overloaded. Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.
SetOption | Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.
SetProcessItem | Sets the current process item for the given target view.
SetReadOnSelectChangeActivated | Sets the workstation option value.
SetSelectedItemTimerActivated | Sets the workstation option value.
SetSelectedItemTimerInterval | Sets the workstation option value.
SetViewAlternatePath | Overloaded. Change the option value stored for the specified View's alternate working directory. This does not modify the view object.
SetViewAlternatePathEnabled | Overloaded. Change whether or not the alternate working directory should be used for the specified view.
SetViewStatusMethodOverride | Change the option value stored for the specified View's status method This does not modify the view object.
ToString | Delegate ToString() to com.starteam.StarTeamClientOptions.

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.Equals Method

Delegate Equals() to com.starteam.StarTeamClientOptions.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.StarTeamClientOptions.Equals(obj).

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.FromStarFlowExtensions Method

Update the client options on disk from StarFlow Extensions, if available. Set the in memory extensions to the server wide values as well. Return the locked option set, if any, in a hashtable, where the keys are the componentName::optionName, the values are saved to the client options.xml file, hence irrelevant to the UI

public static void FromStarFlowExtensions(
Server s
);

Parameters

s
the server to connect to.

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetAllProcessItems Method

Gets the list of items that have been set as the current process item for at least one view on the given server.

public virtual ViewMemberCollection GetAllProcessItems(
Server s
);

Parameters

s
A StarTeam server.

Return Value

ViewMemberCollection The list of items that have been set as the current process item for at least one view on the given server.

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetCheckNewItemActivated Method

Returns the workstation option value.

public virtual bool GetCheckNewItemActivated(
String componentName
);

Parameters

componentName
the component for which this option is being set

Return Value

option value. Default if not defined: true

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetCheckNewItemInterval Method

Returns the workstation option value.

public virtual int GetCheckNewItemInterval(
String componentName
);

Parameters

componentName
the component for which this option is being set

Return Value

option value. Default if not defined: 600

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetComponentOption Method

Returns the specified workstation option. If the option is not set then the specified default value is returned.

public virtual string GetComponentOption(
String componentName,
String optionName,
String defaultValue
);

Parameters

componentName
the component name of the option
optionName
the component specific options name
defaultValue
the default value to return if the option is not set

Return Value

the specified workstation option

See Also

StarTeamClientOptions Class | StarTeam Namespace


GetFolderAlternatePath Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.GetFolderAlternatePath Method

Returns the alternate working directory for the specified folder. This may return null.

Overload List

Returns the alternate working directory for the specified folder. This may return null.

public virtual string GetFolderAlternatePath(Folder);

Returns the alternate working directory for the specified folder. This may return null.

public virtual string GetFolderAlternatePath(GUID,Int32);

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetFolderAlternatePath Method (Folder)

Returns the alternate working directory for the specified folder. This may return null.

public virtual string GetFolderAlternatePath(
Folder folder
);

Parameters

folder
the folder whose alternate working directory path is desired

Return Value

alternate working directory for the given folder

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetFolderAlternatePath Overload List


StarTeamClientOptions.GetFolderAlternatePath Method (GUID, Int32)

Returns the alternate working directory for the specified folder. This may return null.

public virtual string GetFolderAlternatePath(
GUID repository,
Int32 folderID
);

Parameters

repository
the GUID of the StarTeam server
folderID
the folder whose alternate working directory path is required

Return Value

alternate working directory for the given folder

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetFolderAlternatePath Overload List


GetFolderAlternatePathEnabled Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.GetFolderAlternatePathEnabled Method

Return true if the alternate working directory is enabled for this folder.

Overload List

Return true if the alternate working directory is enabled for this folder.

public virtual bool GetFolderAlternatePathEnabled(Folder);

Return true if the alternate working directory is enabled for this folder.

public virtual bool GetFolderAlternatePathEnabled(GUID,Int32);

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetFolderAlternatePathEnabled Method (Folder)

Return true if the alternate working directory is enabled for this folder.

public virtual bool GetFolderAlternatePathEnabled(
Folder folder
);

Parameters

folder
the folder to check

Return Value

true if the alternate working directory is enabled for this folder.

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetFolderAlternatePathEnabled Overload List


StarTeamClientOptions.GetFolderAlternatePathEnabled Method (GUID, Int32)

Return true if the alternate working directory is enabled for this folder.

public virtual bool GetFolderAlternatePathEnabled(
GUID repository,
Int32 folderID
);

Parameters

repository
the GUID of the StarTeam server
folderID
the folder whose alternate working directory path is required

Return Value

true if the alternate working directory is enabled for this folder.

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetFolderAlternatePathEnabled Overload List


GetFolderUserVisible Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.GetFolderUserVisible Method

Return true if the specified folder is user visible. A UI should not display items in an invisible folder.

Overload List

Return true if the specified folder is user visible. A UI should not display items in an invisible folder.

public virtual bool GetFolderUserVisible(Folder);

Return true if the specified folder is user visible. A UI should not display items in an invisible folder.

public virtual bool GetFolderUserVisible(GUID,Int32);

See Also

StarTeamClientOptions Class | StarTeam Namespace | getUserVisible | setUserVisible


StarTeamClientOptions.GetFolderUserVisible Method (Folder)

Return true if the specified folder is user visible. A UI should not display items in an invisible folder.

public virtual bool GetFolderUserVisible(
Folder folder
);

Parameters

folder
the folder whose visibility is to be determined

Return Value

true if this Folder is user visible.

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetFolderUserVisible Overload List | getUserVisible | setUserVisible


StarTeamClientOptions.GetFolderUserVisible Method (GUID, Int32)

Return true if the specified folder is user visible. A UI should not display items in an invisible folder.

public virtual bool GetFolderUserVisible(
GUID repository,
Int32 folderID
);

Parameters

repository
the GUID of the StarTeam server
folderID
the folder whose alternate working directory path is required

Return Value

true if this Folder is user visible.

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetFolderUserVisible Overload List | getUserVisible | setUserVisible


StarTeamClientOptions.GetHashCode Method

Delegate GetHashCode() to com.starteam.StarTeamClientOptions.

public override int GetHashCode();

Return Value

com.starteam.StarTeamClientOptions.GetHashCode().

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetOption Method

Returns the specified workstation option. If the option is not set then the specified default value is returned.

public virtual string GetOption(
String optionName,
String defaultValue
);

Parameters

optionName
the option name
defaultValue
the default value to return if the option is not set

Return Value

the specified workstation option

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetOptionNames Method

Gets the names of all options that have been set for a given component.

public virtual string[] GetOptionNames(
String componentName
);

Parameters

componentName
A component name.

Return Value

The names of all options that have been set for the given component.

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetProcessItem Method

Gets the current process item in the given target view.

public virtual Item GetProcessItem(
View target
);

Parameters

target
The target view.

Return Value

The current process item in the given target view, or null if there is no current process item in that view.

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetReadOnSelectChangeActivated Method

Returns the workstation option value.

public virtual bool GetReadOnSelectChangeActivated(
String componentName
);

Parameters

componentName
the component for which this option is being set

Return Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetSelectedItemTimerActivated Method

Returns the workstation option value.

public virtual bool GetSelectedItemTimerActivated(
String componentName
);

Parameters

componentName
the component for which this option is being set

Return Value

option value. Default if not defined: false

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetSelectedItemTimerInterval Method

Returns the workstation option value.

public virtual int GetSelectedItemTimerInterval(
String componentName
);

Parameters

componentName
the component for which this option is being set

Return Value

option value. Default if not defined: 45

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetShowNotInViewFolders Method

Returns true if not in view folders in the specified view are to be shown

public virtual bool GetShowNotInViewFolders(
View vw
);

Parameters

vw
the view to test for

Return Value

true if not in view folders in the specified view are to be shown

See Also

StarTeamClientOptions Class | StarTeam Namespace


GetViewAlternatePath Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.GetViewAlternatePath Method

Returns the alternate working directory for the specified view. This may return null.

Overload List

Returns the alternate working directory for the specified view. This may return null.

public virtual string GetViewAlternatePath(GUID,Int32);

Returns the alternate working directory for the specified view. This may return null.

public virtual string GetViewAlternatePath(View);

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetViewAlternatePath Method (GUID, Int32)

Returns the alternate working directory for the specified view. This may return null.

public virtual string GetViewAlternatePath(
GUID repository,
Int32 viewID
);

Parameters

repository
the GUID of the StarTeam server
viewID

Return Value

alternate working directory for the specified view

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetViewAlternatePath Overload List


StarTeamClientOptions.GetViewAlternatePath Method (View)

Returns the alternate working directory for the specified view. This may return null.

public virtual string GetViewAlternatePath(
View view
);

Parameters

view
the view whose alternate working directory path is required

Return Value

alternate working directory for the given view

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetViewAlternatePath Overload List


GetViewAlternatePathEnabled Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.GetViewAlternatePathEnabled Method

Return true if the alternate working directory is enabled for this view.

Overload List

Return true if the alternate working directory is enabled for this view.

public virtual bool GetViewAlternatePathEnabled(GUID,Int32);

Return true if the alternate working directory is enabled for this view.

public virtual bool GetViewAlternatePathEnabled(View);

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.GetViewAlternatePathEnabled Method (GUID, Int32)

Return true if the alternate working directory is enabled for this view.

public virtual bool GetViewAlternatePathEnabled(
GUID repository,
Int32 viewID
);

Parameters

repository
the GUID of the StarTeam server
viewID
the view to be checked

Return Value

true if the alternate working directory is enabled for this view.

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetViewAlternatePathEnabled Overload List


StarTeamClientOptions.GetViewAlternatePathEnabled Method (View)

Return true if the alternate working directory is enabled for this view.

public virtual bool GetViewAlternatePathEnabled(
View view
);

Parameters

view
the view to be checked

Return Value

true if the alternate working directory is enabled for this view.

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.GetViewAlternatePathEnabled Overload List


StarTeamClientOptions.GetViewStatusMethodOverride Method

Returns the option value stored for the specified View's status method.

public virtual StatusMethod GetViewStatusMethodOverride(
View view
);

Parameters

view
the view whose status method is to be returned

Return Value

Status method object

See Also

StarTeamClientOptions Class | StarTeam Namespace | getStatusMethodOverride | setStatusMethodOverride


StarTeamClientOptions.IsLocked Method

returns true if the specified option is locked if so, the GUI (CPC) will disable the control

public static bool IsLocked(
String option
);

Parameters

option
the option to check for

Return Value

true if locked

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.Load Method

Load the options from the specified file. This file becomes the new underlying file for this StarTeamClientOptions object.

public virtual void Load(
FileInfo file
);

Parameters

file
the file from which the options will be loaded

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.LoadDefault Method

Loads the options from the default file.

public virtual void LoadDefault();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.Reload Method

Re-loads the underlying options file.

public virtual void Reload();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.ReloadIfNeeded Method

Re-loads the file only if its last modified time stamp has changed. Returns true if the file was reloaded, false if not.

public virtual bool ReloadIfNeeded();

Return Value

true if the file was re-loaded

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.Save Method

Writes the options to the underlying file.

public virtual void Save();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SaveTo Method

Saves the options to the new file. This becomes the new underlying file for this StarTeamClientOptions object.

public virtual void SaveTo(
FileInfo newfile
);

Parameters

newfile
the new file to which the options will be saved

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetCheckNewItemActivated Method

Sets the workstation option value.

public virtual void SetCheckNewItemActivated(
String componentName,
Boolean value
);

Parameters

componentName
the component for which this option is being set
value
the new option value

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetCheckNewItemInterval Method

Sets the workstation option value.

public virtual void SetCheckNewItemInterval(
String componentName,
Int32 value
);

Parameters

componentName
the component for which this option is being set
value
the new option value

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetComponentOption Method

Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.

public virtual void SetComponentOption(
String componentName,
String optionName,
String value
);

Parameters

componentName
the component name of the option
optionName
the component specific options name
value
the new option value

See Also

StarTeamClientOptions Class | StarTeam Namespace


SetFolderAlternatePath Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.SetFolderAlternatePath Method

Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.

Overload List

Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.

public virtual void SetFolderAlternatePath(Folder,String);

Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.

public virtual void SetFolderAlternatePath(GUID,Int32,String);

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetFolderAlternatePath Method (Folder, String)

Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.

public virtual void SetFolderAlternatePath(
Folder folder,
String path
);

Parameters

folder
the folder whose working directory is to be overridden
path
the new alternate working directory for the folder

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetFolderAlternatePath Overload List


StarTeamClientOptions.SetFolderAlternatePath Method (GUID, Int32, String)

Change the option value stored for the specified Folder's alternate working directory. This does not modify the folder object.

public virtual void SetFolderAlternatePath(
GUID repository,
Int32 folderID,
String path
);

Parameters

repository
the GUID of the StarTeam server
folderID
the folder whose working directory is to be overridden
path
the new alternate working directory for the folder

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetFolderAlternatePath Overload List


SetFolderAlternatePathEnabled Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.SetFolderAlternatePathEnabled Method

Change whether or not the alternate working directory should be used for the specified folder.

Overload List

Change whether or not the alternate working directory should be used for the specified folder.

public virtual void SetFolderAlternatePathEnabled(Folder,Boolean);

Change whether or not the alternate working directory should be used for the specified folder.

public virtual void SetFolderAlternatePathEnabled(GUID,Int32,Boolean);

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetFolderAlternatePathEnabled Method (Folder, Boolean)

Change whether or not the alternate working directory should be used for the specified folder.

public virtual void SetFolderAlternatePathEnabled(
Folder folder,
Boolean enabled
);

Parameters

folder
the folder whose working directory is to be overridden
enabled
true if the alternate path is to be applied

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetFolderAlternatePathEnabled Overload List


StarTeamClientOptions.SetFolderAlternatePathEnabled Method (GUID, Int32, Boolean)

Change whether or not the alternate working directory should be used for the specified folder.

public virtual void SetFolderAlternatePathEnabled(
GUID repository,
Int32 folderID,
Boolean enabled
);

Parameters

repository
the GUID of the StarTeam server
folderID
the folder whose working directory is to be overridden
enabled
true if the alternate path is to be applied

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetFolderAlternatePathEnabled Overload List


SetFolderUserVisible Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.SetFolderUserVisible Method

Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.

Overload List

Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.

public virtual void SetFolderUserVisible(Folder,Boolean);

Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.

public virtual void SetFolderUserVisible(GUID,Int32,Boolean);

See Also

StarTeamClientOptions Class | StarTeam Namespace | getUserVisible | setUserVisible


StarTeamClientOptions.SetFolderUserVisible Method (Folder, Boolean)

Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.

public virtual void SetFolderUserVisible(
Folder folder,
Boolean visible
);

Parameters

folder
the folder whose working directory is to be overridden
visible
true if the folder should be visible, false otherwise

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetFolderUserVisible Overload List | getUserVisible | setUserVisible


StarTeamClientOptions.SetFolderUserVisible Method (GUID, Int32, Boolean)

Change whether or not the specified folder should be visible. Typically, a UI should not display items in an invisible folder.

public virtual void SetFolderUserVisible(
GUID repository,
Int32 folderID,
Boolean visible
);

Parameters

repository
the GUID of the StarTeam server
folderID
the folder whose working directory is to be overridden
visible
true if the folder should be visible, false otherwise

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetFolderUserVisible Overload List | getUserVisible | setUserVisible


StarTeamClientOptions.SetOption Method

Sets the specified workstation option. This does not automatically save the changes to the underlying file. You need to explicitly call one of the save methods.

public virtual void SetOption(
String optionName,
String value
);

Parameters

optionName
the option name
value
the new option value

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetProcessItem Method

Sets the current process item for the given target view.

public virtual void SetProcessItem(
Item item,
View target
);

Parameters

item
A process item, or null to clear the process item in the given target view.
target
The target view.

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetReadOnSelectChangeActivated Method

Sets the workstation option value.

public virtual void SetReadOnSelectChangeActivated(
String componentName,
Boolean value
);

Parameters

componentName
the component for which this option is being set
value
the new option value

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetSelectedItemTimerActivated Method

Sets the workstation option value.

public virtual void SetSelectedItemTimerActivated(
String componentName,
Boolean value
);

Parameters

componentName
the component for which this option is being set
value
the new option value

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetSelectedItemTimerInterval Method

Sets the workstation option value.

public virtual void SetSelectedItemTimerInterval(
String componentName,
Int32 value
);

Parameters

componentName
the component for which this option is being set
value
the new option value

See Also

StarTeamClientOptions Class | StarTeam Namespace


SetViewAlternatePath Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.SetViewAlternatePath Method

Change the option value stored for the specified View's alternate working directory.

Overload List

Change the option value stored for the specified View's alternate working directory.

public virtual void SetViewAlternatePath(GUID,Int32,String);

Change the option value stored for the specified View's alternate working directory. This does not modify the view object.

public virtual void SetViewAlternatePath(View,String);

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetViewAlternatePath Method (GUID, Int32, String)

Change the option value stored for the specified View's alternate working directory.

public virtual void SetViewAlternatePath(
GUID repository,
Int32 viewID,
String path
);

Parameters

repository
the GUID of the StarTeam server
viewID
the view whose alternate working directory path is to be overridden
path
the new alternate working directory for the view

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetViewAlternatePath Overload List


StarTeamClientOptions.SetViewAlternatePath Method (View, String)

Change the option value stored for the specified View's alternate working directory. This does not modify the view object.

public virtual void SetViewAlternatePath(
View view,
String path
);

Parameters

view
the view whose working directory is to be overridden
path
the new alternate working directory for the view

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetViewAlternatePath Overload List


SetViewAlternatePathEnabled Method

Borland StarTeam SDK for .NET

StarTeamClientOptions.SetViewAlternatePathEnabled Method

Change whether or not the alternate working directory should be used for the specified view.

Overload List

Change whether or not the alternate working directory should be used for the specified view.

public virtual void SetViewAlternatePathEnabled(GUID,Int32,Boolean);

Change whether or not the alternate working directory should be used for the specified view.

public virtual void SetViewAlternatePathEnabled(View,Boolean);

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamClientOptions.SetViewAlternatePathEnabled Method (GUID, Int32, Boolean)

Change whether or not the alternate working directory should be used for the specified view.

public virtual void SetViewAlternatePathEnabled(
GUID repository,
Int32 viewID,
Boolean enabled
);

Parameters

repository
the GUID of the StarTeam server
viewID
the view whose alternate working directory path is to be overridden
enabled
true if the alternate path is to be applied

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetViewAlternatePathEnabled Overload List


StarTeamClientOptions.SetViewAlternatePathEnabled Method (View, Boolean)

Change whether or not the alternate working directory should be used for the specified view.

public virtual void SetViewAlternatePathEnabled(
View view,
Boolean enabled
);

Parameters

view
the view whose working directory is to be overridden
enabled
true if the alternate path is to be applied

See Also

StarTeamClientOptions Class | StarTeam Namespace | StarTeamClientOptions.SetViewAlternatePathEnabled Overload List


StarTeamClientOptions.SetViewStatusMethodOverride Method

Change the option value stored for the specified View's status method This does not modify the view object.

public virtual void SetViewStatusMethodOverride(
View view,
StatusMethod method
);

Parameters

view
the view whose status method is to be overridden
method
the new status method to use for files in this view

See Also

StarTeamClientOptions Class | StarTeam Namespace | setStatusMethodOverride | getStatusMethodOverride


StarTeamClientOptions.ToString Method

Delegate ToString() to com.starteam.StarTeamClientOptions.

public override string ToString();

Return Value

com.starteam.StarTeamClientOptions.ToString()

See Also

StarTeamClientOptions Class | StarTeam Namespace


StarTeamCollection Class

A stock implementation of an SDK collection. Every object in the collection is required to be unique and of the same class type The Java version implements java.util.Collection The C# version implement System.Collections.IList

For a list of all members of this type, see StarTeamCollection Members.

System.Object
StarTeamCollection
Derived types

public class StarTeamCollection : IList, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeamCollection Members | StarTeam Namespace


StarTeamCollection Members

StarTeamCollection overview

Public Instance Properties

Count | [read] the number of elements in this collection
IsEmpty | [read] true if this collection contains no elements
IsFixedSize | [read] true if this collection has a fixed size
IsModified | [read] true if this collection has been modified
IsReadOnly | [read] true if this collection is read only
IsSynchronized | [read] true if access to this collection is synchronized
Item |
SyncRoot | [read] an object that can be used to synchronize this collection

Public Instance Methods

Add | add an object to this collection
AddTo | Add the specified element to the collection.
Clear | Removes all of the elements from this collection.
Contains | Returns true if the specified object is a member of this collection
CopyTo | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.StarTeamCollection.
Get | Gets the object at the given index.
GetEnumerator |
GetHashCode | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | returns the index of the object in this collection
Insert | insert the object into the collection at the specified index
PositionOf | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove | remove the object from the collection
RemoveAt | remove the object at the specified index
ResetCapacity | Reset the collection, and change its initial loading capacity
Set | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection Properties

The properties of the StarTeamCollection class are listed below. For a complete list of StarTeamCollection class members, see the StarTeamCollection Members topic.

Public Instance Properties

Count | [read] the number of elements in this collection
IsEmpty | [read] true if this collection contains no elements
IsFixedSize | [read] true if this collection has a fixed size
IsModified | [read] true if this collection has been modified
IsReadOnly | [read] true if this collection is read only
IsSynchronized | [read] true if access to this collection is synchronized
Item |
SyncRoot | [read] an object that can be used to synchronize this collection

See Also

StarTeamCollection Class | StarTeam Namespace


Count Property

Borland StarTeam SDK for .NET

StarTeamCollection.Count Property

[read] the number of elements in this collection

public virtual Int32 Count {get;}

Property Value

the number of elements in this collection

Implements

ICollection.Count

See Also

StarTeamCollection Class | StarTeam Namespace


IsEmpty Property

Borland StarTeam SDK for .NET

StarTeamCollection.IsEmpty Property

[read] true if this collection contains no elements

public virtual Boolean IsEmpty {get;}

Property Value

true if this collection contains no elements

See Also

StarTeamCollection Class | StarTeam Namespace


IsFixedSize Property

Borland StarTeam SDK for .NET

StarTeamCollection.IsFixedSize Property

[read] true if this collection has a fixed size

public virtual Boolean IsFixedSize {get;}

Property Value

true if this collection has a fixed size

Implements

IList.IsFixedSize

See Also

StarTeamCollection Class | StarTeam Namespace


IsModified Property

Borland StarTeam SDK for .NET

StarTeamCollection.IsModified Property

[read] true if this collection has been modified

public virtual Boolean IsModified {get;}

Property Value

true if this collection has been modified

See Also

StarTeamCollection Class | StarTeam Namespace


IsReadOnly Property

Borland StarTeam SDK for .NET

StarTeamCollection.IsReadOnly Property

[read] true if this collection is read only

public virtual Boolean IsReadOnly {get;}

Property Value

true if this collection is read only

Implements

IList.IsReadOnly

See Also

StarTeamCollection Class | StarTeam Namespace


IsSynchronized Property

Borland StarTeam SDK for .NET

StarTeamCollection.IsSynchronized Property

[read] true if access to this collection is synchronized

public virtual Boolean IsSynchronized {get;}

Property Value

true if access to this collection is synchronized

Implements

ICollection.IsSynchronized

See Also

StarTeamCollection Class | StarTeam Namespace


Item Property

Borland StarTeam SDK for .NET

StarTeamCollection.Item Property

public Object this[
Int32 index
] {get; set;}

Implements

IList.Item

See Also

StarTeamCollection Class | StarTeam Namespace


SyncRoot Property

Borland StarTeam SDK for .NET

StarTeamCollection.SyncRoot Property

[read] an object that can be used to synchronize this collection

public virtual Object SyncRoot {get;}

Property Value

an object that can be used to synchronize this collection

Implements

ICollection.SyncRoot

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection Methods

The methods of the StarTeamCollection class are listed below. For a complete list of StarTeamCollection class members, see the StarTeamCollection Members topic.

Public Instance Methods

Add | add an object to this collection
AddTo | Add the specified element to the collection.
Clear | Removes all of the elements from this collection.
Contains | Returns true if the specified object is a member of this collection
CopyTo | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.StarTeamCollection.
Get | Gets the object at the given index.
GetEnumerator |
GetHashCode | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | returns the index of the object in this collection
Insert | insert the object into the collection at the specified index
PositionOf | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove | remove the object from the collection
RemoveAt | remove the object at the specified index
ResetCapacity | Reset the collection, and change its initial loading capacity
Set | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.Add Method

add an object to this collection

public virtual int Add(
Object o
);

Parameters

o
the object to add

Return Value

the index of the object in the collection

Implements

IList.Add

See Also

StarTeamCollection Class | StarTeam Namespace | add


StarTeamCollection.AddTo Method

Add the specified element to the collection.

public virtual StarTeamCollection AddTo(
Object o
);

Parameters

o
The Object to add to the collection

Return Value

this collection itself, including the newly added object

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.Clear Method

Removes all of the elements from this collection.

public virtual void Clear();

Implements

IList.Clear

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.Contains Method

Returns true if the specified object is a member of this collection

public virtual bool Contains(
Object o
);

Parameters

o
the object to test for

Return Value

true if the specified object is a member of this collection

Implements

IList.Contains

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.CopyTo Method

Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array

public virtual void CopyTo(
Array a,
Int32 index
);

Parameters

a
The destination array
index
The start index within the destination array.

Implements

ICollection.CopyTo

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.Equals Method

Delegate Equals() to com.starteam.StarTeamCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.StarTeamCollection.Equals(obj).

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.Get Method

Gets the object at the given index.

public virtual object Get(
Int32 index
);

Parameters

index
A valid index into the collection.

Return Value

The object at that given index.

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.StarTeamCollection.

public override int GetHashCode();

Return Value

com.starteam.StarTeamCollection.GetHashCode().

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.IndexOf Method

returns the index of the object in this collection

public virtual int IndexOf(
Object o
);

Parameters

o
the object to test for

Return Value

it's index in the collection, or -1 if not found

Implements

IList.IndexOf

See Also

StarTeamCollection Class | StarTeam Namespace | positionOf


StarTeamCollection.Insert Method

insert the object into the collection at the specified index

public virtual void Insert(
Int32 index,
Object o
);

Parameters

index
the position at which the object should be inserted
o
the object to insert

Implements

IList.Insert

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.PositionOf Method

returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection

public virtual int PositionOf(
Object o
);

Parameters

o
the object to test for

Return Value

it's position in the collection, or -1 if not found

See Also

StarTeamCollection Class | StarTeam Namespace | indexOf


StarTeamCollection.Remove Method

remove the object from the collection

public virtual void Remove(
Object o
);

Parameters

o
the object to remove

Implements

IList.Remove

See Also

StarTeamCollection Class | StarTeam Namespace | remove


StarTeamCollection.RemoveAt Method

remove the object at the specified index

public virtual void RemoveAt(
Int32 index
);

Parameters

index
the index at which the object should be removed

Implements

IList.RemoveAt

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.ResetCapacity Method

Reset the collection, and change its initial loading capacity

public virtual void ResetCapacity(
Int32 newCapacity
);

Parameters

newCapacity
the new capacity

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.Set Method

Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection

public virtual void Set(
Int32 index,
Object o
);

Parameters

index
A valid index into the collection.
o
The object to be set.

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamCollection.ToString Method

Delegate ToString() to com.starteam.StarTeamCollection.

public override string ToString();

Return Value

com.starteam.StarTeamCollection.ToString()

See Also

StarTeamCollection Class | StarTeam Namespace


StarTeamRepositoryIDs Class

A local file that keeps track of the last known repository ID of each known StarTeam server.

For a list of all members of this type, see StarTeamRepositoryIDs Members.

System.Object
StarTeamRepositoryIDs

public class StarTeamRepositoryIDs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeamRepositoryIDs Members | StarTeam Namespace


StarTeamRepositoryIDs Members

StarTeamRepositoryIDs overview

Public Static Properties

DefaultFile [read] The default location of the file where information about repostory IDs is stored.

Public Instance Constructors

StarTeamRepositoryIDs Overloaded. Initializes a new instance of the StarTeamRepositoryIDs class.

Public Instance Properties

AllKnownIDs [read] The list of all known repository IDs.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StarTeamRepositoryIDs.
Find | Finds the set of StarTeam servers that were last known to have the given repository ID.
GetHashCode | Delegate GetHashCode() to com.starteam.StarTeamRepositoryIDs.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Remembers the repository ID for the indicated server.
ToString | Delegate ToString() to com.starteam.StarTeamRepositoryIDs.

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


StarTeamRepositoryIDs Constructor

Constructs a new StarTeamRepositoryIDs. Assumes repository information is stored in the default location.

Overload List

Constructs a new StarTeamRepositoryIDs. Assumes repository information is stored in the default location.

public StarTeamRepositoryIDs();

Constructs a new StarTeamRepositoryIDs. Repository information is stored in the given location.

public StarTeamRepositoryIDs(FileInfo);

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace | getDefaultFile


StarTeamRepositoryIDs Constructor ()

Constructs a new StarTeamRepositoryIDs. Assumes repository information is stored in the default location.

public StarTeamRepositoryIDs();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace | StarTeamRepositoryIDs Constructor Overload List | getDefaultFile


StarTeamRepositoryIDs Constructor (FileInfo)

Constructs a new StarTeamRepositoryIDs. Repository information is stored in the given location.

public StarTeamRepositoryIDs(
FileInfo file
);

Parameters

file
The file where information about repository IDs is stored.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace | StarTeamRepositoryIDs Constructor Overload List


StarTeamRepositoryIDs Properties

The properties of the StarTeamRepositoryIDs class are listed below. For a complete list of StarTeamRepositoryIDs class members, see the StarTeamRepositoryIDs Members topic.

Public Static Properties

DefaultFile [read] The default location of the file where information about repostory IDs is stored.

Public Instance Properties

AllKnownIDs [read] The list of all known repository IDs.

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


AllKnownIDs Property

Borland StarTeam SDK for .NET

StarTeamRepositoryIDs.AllKnownIDs Property

[read] The list of all known repository IDs.

public virtual GUID[] AllKnownIDs {get;}

Property Value

The list of all known repository IDs.

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


DefaultFile Property

Borland StarTeam SDK for .NET

StarTeamRepositoryIDs.DefaultFile Property

[read] The default location of the file where information about repostory IDs is stored.

public static FileInfo DefaultFile {get;}

Property Value

The default location of the file where information about repostory IDs is stored.

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


StarTeamRepositoryIDs Methods

The methods of the StarTeamRepositoryIDs class are listed below. For a complete list of StarTeamRepositoryIDs class members, see the StarTeamRepositoryIDs Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StarTeamRepositoryIDs.
Find | Finds the set of StarTeam servers that were last known to have the given repository ID.
GetHashCode | Delegate GetHashCode() to com.starteam.StarTeamRepositoryIDs.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Remembers the repository ID for the indicated server.
ToString | Delegate ToString() to com.starteam.StarTeamRepositoryIDs.

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


StarTeamRepositoryIDs.Equals Method

Delegate Equals() to com.starteam.StarTeamRepositoryIDs.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.StarTeamRepositoryIDs.Equals(obj).

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


StarTeamRepositoryIDs.Find Method

Finds the set of StarTeam servers that were last known to have the given repository ID.

public virtual string[] Find(
GUID repositoryID
);

Parameters

repositoryID
The repository ID to be found.

Return Value

The list of host:port connection strings for servers that were last known to have the given repository ID. The list is empty if the repositoryID was not found.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


StarTeamRepositoryIDs.GetHashCode Method

Delegate GetHashCode() to com.starteam.StarTeamRepositoryIDs.

public override int GetHashCode();

Return Value

com.starteam.StarTeamRepositoryIDs.GetHashCode().

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


StarTeamRepositoryIDs.Save Method

Remembers the repository ID for the indicated server.

public virtual void Save(
String host,
Int32 port,
GUID repositoryID
);

Parameters

host
The server's host address.
port
The server's TCP/IP port.
repositoryID
The last known repository ID of this server.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


StarTeamRepositoryIDs.ToString Method

Delegate ToString() to com.starteam.StarTeamRepositoryIDs.

public override string ToString();

Return Value

com.starteam.StarTeamRepositoryIDs.ToString()

See Also

StarTeamRepositoryIDs Class | StarTeam Namespace


StarTeamURL Class

StarTeamURL uses a URL-like syntax to reference a StarTeam Server, Project, View or Item. it provides a convenient way to locate important StarTeam objects.

StarTeamURL supports the following syntax:

starteam://username:password@hostname:port/Project/View/FolderA/FolderB/... (This is the general form of the StarTeam URL naming scheme SCHEME=NAME, which is the default StarTeam URL naming scheme.

StarTeamURL fully supports the generalized StarTeam URL naming scheme by Name or ID. (see the document StarTeam-URL-spec.html) However, URLs in the more generalized form are harder to construct 'by hand' and are best generated using the SDK method Application.toStarTeamURL

For a list of all members of this type, see StarTeamURL Members.

System.Object
StarTeamURL

public class StarTeamURL

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeamURL Members | StarTeam Namespace


StarTeamURL Members

StarTeamURL overview

Public Instance Constructors

StarTeamURL Constructor Construct a new StarTeamURL with the given specifier. The most general form of the URL is: "starteam://username:password@hostname:port/projectname/view/folder/folder/"

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StarTeamURL.
GetHashCode | Delegate GetHashCode() to com.starteam.StarTeamURL.
GetType (inherited from Object) | Gets the Type of the current instance.
ResolveFolder | Connects to and logs on to the specified server and finds the specified folder. The url must contain the username, password, host address and port, project, view name and folder path. For example: "starteam://fred:password@localhost:49201/Project/ViewName/FolderA/FolderB" Note that the password cannot contain the '@' symbol
ResolveProject | Connects to and logs on to the specified server and finds the specified project. The url must contain at least the username, password, host address and port, and project name. For example: "starteam://fred:password@localhost:49201/Project" The url may additionally include view and folder information but those will be ignored. Note that the password cannot contain the '@' symbol
ResolveServer | Connect to and log on to a server object specified by the StarTeam url string. The form of the url must at least include the username, password, host address and port. For example: "starteam://fred:password@localhost:49201" Any additional information in the URL (e.g. project, view or folder) namespace identifiers will be ignored. Note that the password cannot contain the '@' symbol
ResolveView | Connects to and logs on to the specified server and finds the specified view. The url must contain at least the username, password, host address and port, project and view name. For example: "starteam://fred:password@localhost:49201/Project/ViewName{!subViewName}" The url may additionally include folder information but it will be ignored. Note that the password cannot contain the '@' symbol
ToString | Delegate ToString() to com.starteam.StarTeamURL.

See Also

StarTeamURL Class | StarTeam Namespace


StarTeamURL Constructor

Construct a new StarTeamURL with the given specifier. The most general form of the URL is: "starteam://username:password@hostname:port/projectname/view/folder/folder/"

public StarTeamURL(
Application app,
String url
);

Parameters

app
the Application in whose context the URL will be resolved
url
the string specifier of the StarTeamURL.

See Also

StarTeamURL Class | StarTeam Namespace


StarTeamURL Methods

The methods of the StarTeamURL class are listed below. For a complete list of StarTeamURL class members, see the StarTeamURL Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StarTeamURL.
GetHashCode | Delegate GetHashCode() to com.starteam.StarTeamURL.
GetType (inherited from Object) | Gets the Type of the current instance.
ResolveFolder | Connects to and logs on to the specified server and finds the specified folder. The url must contain the username, password, host address and port, project, view name and folder path. For example: "starteam://fred:password@localhost:49201/Project/ViewName/FolderA/FolderB" Note that the password cannot contain the '@' symbol
ResolveProject | Connects to and logs on to the specified server and finds the specified project. The url must contain at least the username, password, host address and port, and project name. For example: "starteam://fred:password@localhost:49201/Project" The url may additionally include view and folder information but those will be ignored. Note that the password cannot contain the '@' symbol
ResolveServer | Connect to and log on to a server object specified by the StarTeam url string. The form of the url must at least include the username, password, host address and port. For example: "starteam://fred:password@localhost:49201" Any additional information in the URL (e.g. project, view or folder) namespace identifiers will be ignored. Note that the password cannot contain the '@' symbol
ResolveView | Connects to and logs on to the specified server and finds the specified view. The url must contain at least the username, password, host address and port, project and view name. For example: "starteam://fred:password@localhost:49201/Project/ViewName{!subViewName}" The url may additionally include folder information but it will be ignored. Note that the password cannot contain the '@' symbol
ToString | Delegate ToString() to com.starteam.StarTeamURL.

See Also

StarTeamURL Class | StarTeam Namespace


StarTeamURL.Equals Method

Delegate Equals() to com.starteam.StarTeamURL.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.StarTeamURL.Equals(obj).

See Also

StarTeamURL Class | StarTeam Namespace


StarTeamURL.GetHashCode Method

Delegate GetHashCode() to com.starteam.StarTeamURL.

public override int GetHashCode();

Return Value

com.starteam.StarTeamURL.GetHashCode().

See Also

StarTeamURL Class | StarTeam Namespace


StarTeamURL.ResolveFolder Method

Connects to and logs on to the specified server and finds the specified folder. The url must contain the username, password, host address and port, project, view name and folder path. For example: "starteam://fred:password@localhost:49201/Project/ViewName/FolderA/FolderB" Note that the password cannot contain the '@' symbol

public virtual Folder ResolveFolder();

Return Value

the specified Folder object

See Also

StarTeamURL Class | StarTeam Namespace


StarTeamURL.ResolveProject Method

Connects to and logs on to the specified server and finds the specified project. The url must contain at least the username, password, host address and port, and project name. For example: "starteam://fred:password@localhost:49201/Project" The url may additionally include view and folder information but those will be ignored. Note that the password cannot contain the '@' symbol

public virtual Project ResolveProject();

Return Value

the specified Project object

See Also

StarTeamURL Class | StarTeam Namespace


StarTeamURL.ResolveServer Method

Connect to and log on to a server object specified by the StarTeam url string. The form of the url must at least include the username, password, host address and port. For example: "starteam://fred:password@localhost:49201" Any additional information in the URL (e.g. project, view or folder) namespace identifiers will be ignored. Note that the password cannot contain the '@' symbol

public virtual Server ResolveServer();

Return Value

a logged in Server object

See Also

StarTeamURL Class | StarTeam Namespace


StarTeamURL.ResolveView Method

Connects to and logs on to the specified server and finds the specified view. The url must contain at least the username, password, host address and port, project and view name. For example: "starteam://fred:password@localhost:49201/Project/ViewName{!subViewName}" The url may additionally include folder information but it will be ignored. Note that the password cannot contain the '@' symbol

public virtual View ResolveView();

Return Value

the specified View object

See Also

StarTeamURL Class | StarTeam Namespace


StarTeamURL.ToString Method

Delegate ToString() to com.starteam.StarTeamURL.

public override string ToString();

Return Value

com.starteam.StarTeamURL.ToString()

See Also

StarTeamURL Class | StarTeam Namespace


StatusMethod Class

This class provides information about how file status is managed for the client. Prior to StarTeam 5.2 all file status information was stored on the StarTeam Server. In 5.2 this status information moved to the client. There are two ways in which that status information can be stored. These are referred to as "Per folder" and "Central"

"Per folder" status information is stored as close to the source file as possible. Assuming a file under revision control is stored in C:/project/foo.txt then the status information for that file will be stored in C:/project/.sbas/SyncDB. In fact, the status information for all files under C:/project will be stored in the file. There are a number of advantages of storing it in this location. For example, whole local folder structures may be moved or copied to new locations and all the status information will go along with it. The down side to this scheme is that in some cases users will not want the .sbas folders mixed in with the source files they are managing with StarTeam.

"Central" status information is all stored under a single user specified directory on the client's machine. This keeps the status information away from the user's source files. The down side to this approach is that you cannot easily move or copy source directories and have status information go along with it.

Users may specify which of these two methods to use by default along with the location of the central status information. Additionally, users may override this on a per-View basis.

For a list of all members of this type, see StatusMethod Members.

System.Object
StatusMethod

public class StatusMethod

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

StatusMethod Members | StarTeam Namespace


StatusMethod Members

StatusMethod overview

Public Static Properties

CENTRAL |
CentralStatusDirectory | [read/write]
CentralStatusManager | [read] A FileBasedStatusManager for managing status in the central location for this workstation.
DEFAULT |
DefaultStatusManager | [read] The default FileBasedStatusManager for this workstation.
DefaultStatusMethod | [read/write]
PER_FOLDER |
PerFolderStatusManager | [read] A FileBasedStatusManager for managing status on a per-folder basis for this workstation.
WORKSPACE |

Public Static Methods

DeleteSyncDB | Deletes all the status information for the specified directory path. The value for the "key" parameter must be a path in the proper format, one that would be returned from the getSourceDirs method.
GetSourceDirs | Given a root directory which contains centrally managed status data, this method will return an enumeration of all the local directory paths for which there is status data. The values in the enumeration will be String objects which are paths to local folders. The paths are in a platform independent format in which all directory delimiters are specified using the backslash (\) character.
GetSourceDirsCount | Returns the number of local directories that the specified centrally managed status directory is maintaining. This method is optimized to walk just the directory lists so that the algorithm takes a fraction of the time taken by a call to {@link #getSourceDirs(java.io.File)}
GetStatusInformation | Given a directory path for which there is centrally managed status data, return the collection of all FileStatuses representing cached status data for files in this path
GetStatusManager | Overloaded. Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.
GetWorkspaceStatusManager | Gets a FileBasedStatusManager for managing status on a workspace basis.

Public Instance Properties

DisplayName | [read] A display name for this StatusMethod.
Name | [read] The internal name of this StatusMethod.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StatusMethod.
GetHashCode | Delegate GetHashCode() to com.starteam.StatusMethod.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.StatusMethod.

See Also

StatusMethod Class | StarTeam Namespace


StatusMethod Properties

The properties of the StatusMethod class are listed below. For a complete list of StatusMethod class members, see the StatusMethod Members topic.

Public Static Properties

CENTRAL |
CentralStatusDirectory | [read/write]
CentralStatusManager | [read] A FileBasedStatusManager for managing status in the central location for this workstation.
DEFAULT |
DefaultStatusManager | [read] The default FileBasedStatusManager for this workstation.
DefaultStatusMethod | [read/write]
PER_FOLDER |
PerFolderStatusManager | [read] A FileBasedStatusManager for managing status on a per-folder basis for this workstation.
WORKSPACE |

Public Instance Properties

DisplayName | [read] A display name for this StatusMethod.
Name | [read] The internal name of this StatusMethod.

See Also

StatusMethod Class | StarTeam Namespace


CENTRAL Property

Borland StarTeam SDK for .NET

StatusMethod.CENTRAL Property

public static StatusMethod CENTRAL {get;}

Property Value

Identifies the "Central" status management method.

See Also

StatusMethod Class | StarTeam Namespace


CentralStatusDirectory Property

Borland StarTeam SDK for .NET

StatusMethod.CentralStatusDirectory Property

[read/write]

public static String CentralStatusDirectory {get; set;}

See Also

StatusMethod Class | StarTeam Namespace


CentralStatusManager Property

Borland StarTeam SDK for .NET

StatusMethod.CentralStatusManager Property

[read] A FileBasedStatusManager for managing status in the central location for this workstation.

public static FileBasedStatusManager CentralStatusManager {get;}

Property Value

A FileBasedStatusManager for managing status in the central location for this workstation.

See Also

StatusMethod Class | StarTeam Namespace


DEFAULT Property

Borland StarTeam SDK for .NET

StatusMethod.DEFAULT Property

public static StatusMethod DEFAULT {get;}

Property Value

Used for specifying a View's status method.

See Also

StatusMethod Class | StarTeam Namespace


DefaultStatusManager Property

Borland StarTeam SDK for .NET

StatusMethod.DefaultStatusManager Property

[read] The default FileBasedStatusManager for this workstation.

public static FileBasedStatusManager DefaultStatusManager {get;}

Property Value

The default FileBasedStatusManager for this workstation.

See Also

StatusMethod Class | StarTeam Namespace


DefaultStatusMethod Property

Borland StarTeam SDK for .NET

StatusMethod.DefaultStatusMethod Property

[read/write]

public static StatusMethod DefaultStatusMethod {get; set;}

See Also

StatusMethod Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

StatusMethod.DisplayName Property

[read] A display name for this StatusMethod.

public virtual String DisplayName {get;}

Property Value

A display name for this StatusMethod.

See Also

StatusMethod Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

StatusMethod.Name Property

[read] The internal name of this StatusMethod.

public virtual String Name {get;}

Property Value

The internal name of this StatusMethod.

See Also

StatusMethod Class | StarTeam Namespace


PER_FOLDER Property

Borland StarTeam SDK for .NET

StatusMethod.PER_FOLDER Property

public static StatusMethod PER_FOLDER {get;}

Property Value

Identifies the "Per folder" status management method.

See Also

StatusMethod Class | StarTeam Namespace


PerFolderStatusManager Property

Borland StarTeam SDK for .NET

StatusMethod.PerFolderStatusManager Property

[read] A FileBasedStatusManager for managing status on a per-folder basis for this workstation.

public static FileBasedStatusManager PerFolderStatusManager {get;}

Property Value

A FileBasedStatusManager for managing status on a per-folder basis for this workstation.

See Also

StatusMethod Class | StarTeam Namespace


WORKSPACE Property

Borland StarTeam SDK for .NET

StatusMethod.WORKSPACE Property

public static StatusMethod WORKSPACE {get;}

Property Value

Identifies a "Custom" central status management method.

See Also

StatusMethod Class | StarTeam Namespace


StatusMethod Methods

The methods of the StatusMethod class are listed below. For a complete list of StatusMethod class members, see the StatusMethod Members topic.

Public Static Methods

DeleteSyncDB | Deletes all the status information for the specified directory path. The value for the "key" parameter must be a path in the proper format, one that would be returned from the getSourceDirs method.
GetSourceDirs | Given a root directory which contains centrally managed status data, this method will return an enumeration of all the local directory paths for which there is status data. The values in the enumeration will be String objects which are paths to local folders. The paths are in a platform independent format in which all directory delimiters are specified using the backslash (\) character.
GetSourceDirsCount | Returns the number of local directories that the specified centrally managed status directory is maintaining. This method is optimized to walk just the directory lists so that the algorithm takes a fraction of the time taken by a call to {@link #getSourceDirs(java.io.File)}
GetStatusInformation | Given a directory path for which there is centrally managed status data, return the collection of all FileStatuses representing cached status data for files in this path
GetStatusManager | Overloaded. Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.
GetWorkspaceStatusManager | Gets a FileBasedStatusManager for managing status on a workspace basis.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StatusMethod.
GetHashCode | Delegate GetHashCode() to com.starteam.StatusMethod.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.StatusMethod.

See Also

StatusMethod Class | StarTeam Namespace


StatusMethod.DeleteSyncDB Method

Deletes all the status information for the specified directory path. The value for the "key" parameter must be a path in the proper format, one that would be returned from the getSourceDirs method.

public static void DeleteSyncDB(
FileInfo syncDirRoot,
String key
);

Parameters

syncDirRoot
the root of the centrally managed status directory
key
the platform independent directory path whose status will be deleted.

See Also

StatusMethod Class | StarTeam Namespace


StatusMethod.Equals Method

Delegate Equals() to com.starteam.StatusMethod.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.StatusMethod.Equals(obj).

See Also

StatusMethod Class | StarTeam Namespace


StatusMethod.GetHashCode Method

Delegate GetHashCode() to com.starteam.StatusMethod.

public override int GetHashCode();

Return Value

com.starteam.StatusMethod.GetHashCode().

See Also

StatusMethod Class | StarTeam Namespace


StatusMethod.GetSourceDirs Method

Given a root directory which contains centrally managed status data, this method will return an enumeration of all the local directory paths for which there is status data. The values in the enumeration will be String objects which are paths to local folders. The paths are in a platform independent format in which all directory delimiters are specified using the backslash (\) character.

public static string[] GetSourceDirs(
FileInfo syncDirRoot
);

Parameters

syncDirRoot
the root of the centrally managed status directory

Return Value

an enumeration of all the local directory paths that have status information

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StatusMethod Class | StarTeam Namespace | getSourceDirsCount


StatusMethod.GetSourceDirsCount Method

Returns the number of local directories that the specified centrally managed status directory is maintaining. This method is optimized to walk just the directory lists so that the algorithm takes a fraction of the time taken by a call to {@link #getSourceDirs(java.io.File)}

public static int GetSourceDirsCount(
FileInfo syncDirRoot
);

Parameters

syncDirRoot
the root of the centrally managed status directory

Return Value

the total number of local directories that have status information

See Also

StatusMethod Class | StarTeam Namespace


StatusMethod.GetStatusInformation Method

Given a directory path for which there is centrally managed status data, return the collection of all FileStatuses representing cached status data for files in this path

public static FileStatus[] GetStatusInformation(
String path
);

Parameters

path
a directory path for which there is status data

Return Value

a collection of all FileStatuses representing cached status data

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StatusMethod Class | StarTeam Namespace | getSourceDirs


GetStatusManager Method

Borland StarTeam SDK for .NET

StatusMethod.GetStatusManager Method

Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.

Overload List

Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.

public static FileBasedStatusManager GetStatusManager(View);

Gets the FileBasedStatusManager that manages file status information for the given View and Server ID.

public static FileBasedStatusManager GetStatusManager(View,GUID);

See Also

StatusMethod Class | StarTeam Namespace | getFileStatusManager | FileBasedStatusManager


StatusMethod.GetStatusManager Method (View)

Gets the FileBasedStatusManager that manages file status information for the given View. The corresponding StarTeam Server must support client-managed status.

public static FileBasedStatusManager GetStatusManager(
View view
);

Parameters

view
the view whose status manager is requested

Return Value

The FileBasedStatusManager for the given View.

See Also

StatusMethod Class | StarTeam Namespace | StatusMethod.GetStatusManager Overload List | getFileStatusManager | FileBasedStatusManager


StatusMethod.GetStatusManager Method (View, GUID)

Gets the FileBasedStatusManager that manages file status information for the given View and Server ID.

public static FileBasedStatusManager GetStatusManager(
View view,
GUID serverGUID
);

Parameters

view
the given view
serverGUID
server's repository id (which is a GUID) in string form.

Return Value

The FileBasedStatusManager for the given View.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StatusMethod Class | StarTeam Namespace | StatusMethod.GetStatusManager Overload List | getFileStatusManager | FileBasedStatusManager


StatusMethod.GetWorkspaceStatusManager Method

Gets a FileBasedStatusManager for managing status on a workspace basis.

public static FileBasedStatusManager GetWorkspaceStatusManager(
String path
);

Parameters

path
the fully qualified path to the workspace

Return Value

A FileBasedStatusManager for managing status in a workspace location on this workstation.

See Also

StatusMethod Class | StarTeam Namespace | WORKSPACE | FileBasedStatusManager


StatusMethod.ToString Method

Delegate ToString() to com.starteam.StatusMethod.

public override string ToString();

Return Value

com.starteam.StatusMethod.ToString()

See Also

StatusMethod Class | StarTeam Namespace


StatusMethod.FileStatus Class

A FileStatus represents a combination of a file name and its status information from the status database (syncdb) on disk. This status object may be used by tools to help identify issues in status calculation on end user local file systems and is primarily relevant to and targeted at central file systems. Instances of the FileStatus object are returned in an array by the method {@link StatusMethod#getStatusInformation(String)} It may be used to reconcile a file on disk, a FileStatus object and a File in StarTeam to determine the correctness of File.Status calculation

For a list of all members of this type, see StatusMethod.FileStatus Members.

System.Object
StatusMethod.FileStatus

public class StatusMethod.FileStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

StatusMethod.FileStatus Members | StarTeam Namespace


StatusMethod.FileStatus Members

StatusMethod.FileStatus overview

Public Instance Properties

Name | [read]
Status | [read]

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StatusMethod.FileStatus.
GetHashCode | Delegate GetHashCode() to com.starteam.StatusMethod.FileStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.StatusMethod.FileStatus.

See Also

StatusMethod.FileStatus Class | StarTeam Namespace


StatusMethod.FileStatus Properties

The properties of the StatusMethod.FileStatus class are listed below. For a complete list of StatusMethod.FileStatus class members, see the StatusMethod.FileStatus Members topic.

Public Instance Properties

Name | [read]
Status | [read]

See Also

StatusMethod.FileStatus Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

StatusMethod.FileStatus.Name Property

[read]

public virtual String Name {get;}

See Also

StatusMethod.FileStatus Class | StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

StatusMethod.FileStatus.Status Property

[read]

public virtual File.WorkspaceSync Status {get;}

See Also

StatusMethod.FileStatus Class | StarTeam Namespace


StatusMethod.FileStatus Methods

The methods of the StatusMethod.FileStatus class are listed below. For a complete list of StatusMethod.FileStatus class members, see the StatusMethod.FileStatus Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.StatusMethod.FileStatus.
GetHashCode | Delegate GetHashCode() to com.starteam.StatusMethod.FileStatus.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.StatusMethod.FileStatus.

See Also

StatusMethod.FileStatus Class | StarTeam Namespace


StatusMethod.FileStatus.Equals Method

Delegate Equals() to com.starteam.StatusMethod.FileStatus.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.StatusMethod.FileStatus.Equals(obj).

See Also

StatusMethod.FileStatus Class | StarTeam Namespace


StatusMethod.FileStatus.GetHashCode Method

Delegate GetHashCode() to com.starteam.StatusMethod.FileStatus.

public override int GetHashCode();

Return Value

com.starteam.StatusMethod.FileStatus.GetHashCode().

See Also

StatusMethod.FileStatus Class | StarTeam Namespace


StatusMethod.FileStatus.ToString Method

Delegate ToString() to com.starteam.StatusMethod.FileStatus.

public override string ToString();

Return Value

com.starteam.StatusMethod.FileStatus.ToString()

See Also

StatusMethod.FileStatus Class | StarTeam Namespace


Story Class

A Story represents an Agile user story. It has a StoryType property to further qualify it as a more specific Agile artifact like Epic, Theme ... . Stories can be hierarchical, that is a parent story can have child stories. Stories may have Tasks to break them up into smaller units of work.

For a list of all members of this type, see Story Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
TreeItem
Story

public class Story : TreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story Members | StarTeam Namespace


Story Members

Story overview

Public Static Methods

Create Create a Story in the specified parent folder.

Public Instance Constructors

Story Constructor Creates a child-Story under this parent Story.

Public Instance Properties

AcceptanceCriteria | [read/write] the text in the "AcceptanceCriteria" for this story.
After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this story.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EstimatedPoints | [read/write] A estimated points indicating how long it might take for the story to be completed.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalTestID | [read/write] the external test ID for this requirement
ExternalTestProjectURL | [read/write] the external test project URL for this requirement
ExternalTestURL | [read/write] the external test URL for this requirement
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
General | [read/write] the text in the "General" for this story.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IncomingStreams | [read/write] the incoming streams, if any attached to this story
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsCarriedOver | [read] true if this story has been carried over
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MoSCoWValue | [read/write] the MoSCoW of the story
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this story.
NewRevisionComment (inherited from Item) | [read] the empty string.
Notes | [read/write] the text in the "Notes" for this story.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order | [read/write] the order in which the story should be executed.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentPlan | [read] the Plan containing this Story
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
ParentSprint | [read] the Sprint containing this Story
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
Rank | [read/write] the rank in which the story should be viewed.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
RichDescription | [read/write] Rich Description used for this story
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RiskValue | [read/write] risk used for this story
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Sponsor | [read/write] the sponsor of the story
StatusValue | [read/write] A status reflecting the statuses of its tasks
StoryID | [read] the story id.
StoryTypeValue | [read/write] story type used for this story
StoryValueValue | [read/write] storyValue of this story
StreamStateValue | [read/write] Stream State used for this story
Tags | [read/write] the tags, if any attached to this story
TargetReleases | [read/write] the target releases that this story may be mapped to
Tasks | [read] a possibly empty array of Task
Team | [read/write] The team for this story.
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IgnoreLinkedChangeRequest | If invoked, then updating this Story status does not affect the status of a linked ChangeRequest The caller is responsible for ensuring that ChangeRequest and linked Story states are consistent.
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Story Class | StarTeam Namespace


Story Constructor

Creates a child-Story under this parent Story.

public Story(
Story parent
);

Parameters

parent

See Also

Story Class | StarTeam Namespace


Story Properties

The properties of the Story class are listed below. For a complete list of Story class members, see the Story Members topic.

Public Instance Properties

AcceptanceCriteria | [read/write] the text in the "AcceptanceCriteria" for this story.
After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this story.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EstimatedPoints | [read/write] A estimated points indicating how long it might take for the story to be completed.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalTestID | [read/write] the external test ID for this requirement
ExternalTestProjectURL | [read/write] the external test project URL for this requirement
ExternalTestURL | [read/write] the external test URL for this requirement
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
General | [read/write] the text in the "General" for this story.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IncomingStreams | [read/write] the incoming streams, if any attached to this story
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsCarriedOver | [read] true if this story has been carried over
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MoSCoWValue | [read/write] the MoSCoW of the story
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this story.
NewRevisionComment (inherited from Item) | [read] the empty string.
Notes | [read/write] the text in the "Notes" for this story.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order | [read/write] the order in which the story should be executed.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentPlan | [read] the Plan containing this Story
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
ParentSprint | [read] the Sprint containing this Story
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
Rank | [read/write] the rank in which the story should be viewed.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
RichDescription | [read/write] Rich Description used for this story
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RiskValue | [read/write] risk used for this story
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Sponsor | [read/write] the sponsor of the story
StatusValue | [read/write] A status reflecting the statuses of its tasks
StoryID | [read] the story id.
StoryTypeValue | [read/write] story type used for this story
StoryValueValue | [read/write] storyValue of this story
StreamStateValue | [read/write] Stream State used for this story
Tags | [read/write] the tags, if any attached to this story
TargetReleases | [read/write] the target releases that this story may be mapped to
Tasks | [read] a possibly empty array of Task
Team | [read/write] The team for this story.
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Story Class | StarTeam Namespace


AcceptanceCriteria Property

Borland StarTeam SDK for .NET

Story.AcceptanceCriteria Property

[read/write] the text in the "AcceptanceCriteria" for this story.

public virtual String AcceptanceCriteria {get; set;}

Property Value

the text in the "AcceptanceCriteria" for this story.

See Also

Story Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Story.Description Property

[read/write] the description of this story.

public virtual String Description {get; set;}

Property Value

the description of this story.

See Also

Story Class | StarTeam Namespace


EstimatedPoints Property

Borland StarTeam SDK for .NET

Story.EstimatedPoints Property

[read/write] A estimated points indicating how long it might take for the story to be completed.

public virtual Double EstimatedPoints {get; set;}

Property Value

A estimated points indicating how long it might take for the story to be completed.

See Also

Story Class | StarTeam Namespace


ExternalTestID Property

Borland StarTeam SDK for .NET

Story.ExternalTestID Property

[read/write] the external test ID for this requirement

public virtual String ExternalTestID {get; set;}

Property Value

the external test ID for this requirement

See Also

Story Class | StarTeam Namespace


ExternalTestProjectURL Property

Borland StarTeam SDK for .NET

Story.ExternalTestProjectURL Property

[read/write] the external test project URL for this requirement

public virtual String ExternalTestProjectURL {get; set;}

Property Value

the external test project URL for this requirement

See Also

Story Class | StarTeam Namespace


ExternalTestURL Property

Borland StarTeam SDK for .NET

Story.ExternalTestURL Property

[read/write] the external test URL for this requirement

public virtual String ExternalTestURL {get; set;}

Property Value

the external test URL for this requirement

See Also

Story Class | StarTeam Namespace


General Property

Borland StarTeam SDK for .NET

Story.General Property

[read/write] the text in the "General" for this story.

public virtual String General {get; set;}

Property Value

the text in the "General" for this story.

See Also

Story Class | StarTeam Namespace


IncomingStreams Property

Borland StarTeam SDK for .NET

Story.IncomingStreams Property

[read/write] the incoming streams, if any attached to this story

public virtual EnumeratedValue[] IncomingStreams {get; set;}

Property Value

the incoming streams, if any attached to this story

See Also

Story Class | StarTeam Namespace


IsCarriedOver Property

Borland StarTeam SDK for .NET

Story.IsCarriedOver Property

[read] true if this story has been carried over

public virtual Boolean IsCarriedOver {get;}

Property Value

true if this story has been carried over

See Also

Story Class | StarTeam Namespace


MoSCoWValue Property

Borland StarTeam SDK for .NET

Story.MoSCoWValue Property

[read/write] the MoSCoW of the story

public virtual TreeItem.MoSCoW MoSCoWValue {get; set;}

Property Value

the MoSCoW of the story

See Also

Story Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Story.Name Property

[read/write] the Name of this story.

public virtual String Name {get; set;}

Property Value

the Name of this story.

See Also

Story Class | StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

Story.Notes Property

[read/write] the text in the "Notes" for this story.

public virtual String Notes {get; set;}

Property Value

the text in the "Notes" for this story.

See Also

Story Class | StarTeam Namespace


Order Property

Borland StarTeam SDK for .NET

Story.Order Property

[read/write] the order in which the story should be executed.

public virtual Double Order {get; set;}

Property Value

the order in which the story should be executed.

See Also

Story Class | StarTeam Namespace


ParentPlan Property

Borland StarTeam SDK for .NET

Story.ParentPlan Property

[read] the Plan containing this Story

public virtual Plan ParentPlan {get;}

Property Value

the Plan containing this Story

See Also

Story Class | StarTeam Namespace


ParentSprint Property

Borland StarTeam SDK for .NET

Story.ParentSprint Property

[read] the Sprint containing this Story

public virtual Sprint ParentSprint {get;}

Property Value

the Sprint containing this Story

See Also

Story Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Story.Properties Property

[read] the PropertyCollection of its Type

public virtual Story.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

Story Class | StarTeam Namespace


Rank Property

Borland StarTeam SDK for .NET

Story.Rank Property

[read/write] the rank in which the story should be viewed.

public virtual Double Rank {get; set;}

Property Value

the rank in which the story should be viewed.

See Also

Story Class | StarTeam Namespace


RichDescription Property

Borland StarTeam SDK for .NET

Story.RichDescription Property

[read/write] Rich Description used for this story

public virtual Content RichDescription {get; set;}

Property Value

Rich Description used for this story

See Also

Story Class | StarTeam Namespace


RiskValue Property

Borland StarTeam SDK for .NET

Story.RiskValue Property

[read/write] risk used for this story

public virtual Story.Risk RiskValue {get; set;}

Property Value

risk used for this story

See Also

Story Class | StarTeam Namespace


Sponsor Property

Borland StarTeam SDK for .NET

Story.Sponsor Property

[read/write] the sponsor of the story

public virtual User Sponsor {get; set;}

Property Value

the sponsor of the story

See Also

Story Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Story.StatusValue Property

[read/write] A status reflecting the statuses of its tasks

public virtual Story.Status StatusValue {get; set;}

Property Value

A status reflecting the statuses of its tasks

See Also

Story Class | StarTeam Namespace


StoryID Property

Borland StarTeam SDK for .NET

Story.StoryID Property

[read] the story id.

public virtual Int32 StoryID {get;}

Property Value

the story id.

See Also

Story Class | StarTeam Namespace


StoryTypeValue Property

Borland StarTeam SDK for .NET

Story.StoryTypeValue Property

[read/write] story type used for this story

public virtual Story.StoryType StoryTypeValue {get; set;}

Property Value

story type used for this story

See Also

Story Class | StarTeam Namespace


StoryValueValue Property

Borland StarTeam SDK for .NET

Story.StoryValueValue Property

[read/write] storyValue of this story

public virtual Story.StoryValue StoryValueValue {get; set;}

Property Value

storyValue of this story

See Also

Story Class | StarTeam Namespace


StreamStateValue Property

Borland StarTeam SDK for .NET

Story.StreamStateValue Property

[read/write] Stream State used for this story

public virtual Story.StreamState StreamStateValue {get; set;}

Property Value

Stream State used for this story

See Also

Story Class | StarTeam Namespace


Tags Property

Borland StarTeam SDK for .NET

Story.Tags Property

[read/write] the tags, if any attached to this story

public virtual EnumeratedValue[] Tags {get; set;}

Property Value

the tags, if any attached to this story

See Also

Story Class | StarTeam Namespace


TargetReleases Property

Borland StarTeam SDK for .NET

Story.TargetReleases Property

[read/write] the target releases that this story may be mapped to

public virtual View[] TargetReleases {get; set;}

Property Value

the target releases that this story may be mapped to

See Also

Story Class | StarTeam Namespace


Tasks Property

Borland StarTeam SDK for .NET

Story.Tasks Property

[read] a possibly empty array of Task

public virtual Task[] Tasks {get;}

Property Value

a possibly empty array of Task

See Also

Story Class | StarTeam Namespace


Team Property

Borland StarTeam SDK for .NET

Story.Team Property

[read/write] The team for this story.

public virtual String Team {get; set;}

Property Value

The team for this story.

See Also

Story Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Story.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Story Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Story.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Story Class | StarTeam Namespace


Story Methods

The methods of the Story class are listed below. For a complete list of Story class members, see the Story Members topic.

Public Static Methods

Create Create a Story in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IgnoreLinkedChangeRequest | If invoked, then updating this Story status does not affect the status of a linked ChangeRequest The caller is responsible for ensuring that ChangeRequest and linked Story states are consistent.
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Story Class | StarTeam Namespace


Story.Create Method

Create a Story in the specified parent folder.

public static Story Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Story Object.

See Also

Story Class | StarTeam Namespace


Story.IgnoreLinkedChangeRequest Method

If invoked, then updating this Story status does not affect the status of a linked ChangeRequest The caller is responsible for ensuring that ChangeRequest and linked Story states are consistent.

public virtual void IgnoreLinkedChangeRequest();

See Also

Story Class | StarTeam Namespace


Story.Risk Class

Risk of the Story

For a list of all members of this type, see Story.Risk Members.

System.Object
EnumeratedValue
Story.Risk

public class Story.Risk : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Risk Members | StarTeam Namespace


Story.Risk Members

Story.Risk overview

Public Static Properties

ALL
HIGH
LOW
MEDIUM

Public Static Methods

FromID | Gets the Risk value corresponding to the given ID.
FromValue | Gets the Risk value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Risk value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.Risk.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Risk.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.Risk.

See Also

Story.Risk Class | StarTeam Namespace


Story.Risk Properties

The properties of the Story.Risk class are listed below. For a complete list of Story.Risk class members, see the Story.Risk Members topic.

Public Static Properties

ALL
HIGH
LOW
MEDIUM

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Risk value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Story.Risk Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Story.Risk.ALL Property

public static Risk[] ALL {get;}

See Also

Story.Risk Class | StarTeam Namespace


HIGH Property

Borland StarTeam SDK for .NET

Story.Risk.HIGH Property

public static Story.Risk HIGH {get;}

Property Value

Story's Risk is high

See Also

Story.Risk Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Story.Risk.ID Property

[read] the ID of this Risk value.

public virtual Int32 ID {get;}

Property Value

the ID of this Risk value.

See Also

Story.Risk Class | StarTeam Namespace


LOW Property

Borland StarTeam SDK for .NET

Story.Risk.LOW Property

public static Story.Risk LOW {get;}

Property Value

Story's Risk is low

See Also

Story.Risk Class | StarTeam Namespace


MEDIUM Property

Borland StarTeam SDK for .NET

Story.Risk.MEDIUM Property

public static Story.Risk MEDIUM {get;}

Property Value

Story is of medium Risk

See Also

Story.Risk Class | StarTeam Namespace


Story.Risk Methods

The methods of the Story.Risk class are listed below. For a complete list of Story.Risk class members, see the Story.Risk Members topic.

Public Static Methods

FromID | Gets the Risk value corresponding to the given ID.
FromValue | Gets the Risk value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.Risk.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Risk.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.Risk.

See Also

Story.Risk Class | StarTeam Namespace


Story.Risk.Equals Method

Delegate Equals() to com.starteam.Story.Risk.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Risk.Equals(obj).

See Also

Story.Risk Class | StarTeam Namespace


Story.Risk.FromID Method

Gets the Risk value corresponding to the given ID.

public static Risk FromID(
Int32 id
);

Parameters

id
A Risk ID.

Return Value

the corresponding Risk value, or null.

See Also

Story.Risk Class | StarTeam Namespace


Story.Risk.FromValue Method

Gets the Risk value corresponding to the given EnumeratedValue.

public static Risk FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a RiskProperty.

Return Value

the corresponding Risk value, or null.

See Also

Story.Risk Class | StarTeam Namespace


Story.Risk.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Risk.

public override int GetHashCode();

Return Value

com.starteam.Story.Risk.GetHashCode().

See Also

Story.Risk Class | StarTeam Namespace


Story.Risk.ToString Method

Delegate ToString() to com.starteam.Story.Risk.

public override string ToString();

Return Value

com.starteam.Story.Risk.ToString()

See Also

Story.Risk Class | StarTeam Namespace


Story.Status Class

The status of this story

For a list of all members of this type, see Story.Status Members.

System.Object
EnumeratedValue
Story.Status

public class Story.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Status Members | StarTeam Namespace


Story.Status Members

Story.Status overview

Public Static Properties

ACCEPTED
ALL
COMPLETED
IN_REVIEW
NOT_STARTED
REJECTED
STARTED

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.Status.

See Also

Story.Status Class | StarTeam Namespace


Story.Status Properties

The properties of the Story.Status class are listed below. For a complete list of Story.Status class members, see the Story.Status Members topic.

Public Static Properties

ACCEPTED
ALL
COMPLETED
IN_REVIEW
NOT_STARTED
REJECTED
STARTED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Story.Status Class | StarTeam Namespace


ACCEPTED Property

Borland StarTeam SDK for .NET

Story.Status.ACCEPTED Property

public static Story.Status ACCEPTED {get;}

Property Value

All of its tasks are "accepted"

See Also

Story.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Story.Status.ALL Property

public static Status[] ALL {get;}

See Also

Story.Status Class | StarTeam Namespace


COMPLETED Property

Borland StarTeam SDK for .NET

Story.Status.COMPLETED Property

public static Story.Status COMPLETED {get;}

Property Value

All of its tasks are "completed"

See Also

Story.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Story.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

Story.Status Class | StarTeam Namespace


IN_REVIEW Property

Borland StarTeam SDK for .NET

Story.Status.IN_REVIEW Property

public static Story.Status IN_REVIEW {get;}

Property Value

All of its tasks are "in review"

See Also

Story.Status Class | StarTeam Namespace


NOT_STARTED Property

Borland StarTeam SDK for .NET

Story.Status.NOT_STARTED Property

public static Story.Status NOT_STARTED {get;}

Property Value

All of its tasks are "not started"

See Also

Story.Status Class | StarTeam Namespace


REJECTED Property

Borland StarTeam SDK for .NET

Story.Status.REJECTED Property

public static Story.Status REJECTED {get;}

Property Value

All of its tasks are "rejected"

See Also

Story.Status Class | StarTeam Namespace


STARTED Property

Borland StarTeam SDK for .NET

Story.Status.STARTED Property

public static Story.Status STARTED {get;}

Property Value

At least one of its tasks is "started"

See Also

Story.Status Class | StarTeam Namespace


Story.Status Methods

The methods of the Story.Status class are listed below. For a complete list of Story.Status class members, see the Story.Status Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.Status.

See Also

Story.Status Class | StarTeam Namespace


Story.Status.Equals Method

Delegate Equals() to com.starteam.Story.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Status.Equals(obj).

See Also

Story.Status Class | StarTeam Namespace


Story.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

Story.Status Class | StarTeam Namespace


Story.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

Story.Status Class | StarTeam Namespace


Story.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Status.

public override int GetHashCode();

Return Value

com.starteam.Story.Status.GetHashCode().

See Also

Story.Status Class | StarTeam Namespace


Story.Status.ToString Method

Delegate ToString() to com.starteam.Story.Status.

public override string ToString();

Return Value

com.starteam.Story.Status.ToString()

See Also

Story.Status Class | StarTeam Namespace


Story.StoryType Class

The type of the story according to agile terminology.

For a list of all members of this type, see Story.StoryType Members.

System.Object
EnumeratedValue
Story.StoryType

public class Story.StoryType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.StoryType Members | StarTeam Namespace


Story.StoryType Members

Story.StoryType overview

Public Static Properties

ALL
DEFECT
EPIC
TECHNICAL_TODO
THEME
USER_STORY

Public Static Methods

FromID | Gets the story type corresponding to the given ID.
FromValue | Gets the story Type corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.StoryType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.StoryType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.StoryType.

See Also

Story.StoryType Class | StarTeam Namespace


Story.StoryType Properties

The properties of the Story.StoryType class are listed below. For a complete list of Story.StoryType class members, see the Story.StoryType Members topic.

Public Static Properties

ALL
DEFECT
EPIC
TECHNICAL_TODO
THEME
USER_STORY

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Story.StoryType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Story.StoryType.ALL Property

public static StoryType[] ALL {get;}

See Also

Story.StoryType Class | StarTeam Namespace


DEFECT Property

Borland StarTeam SDK for .NET

Story.StoryType.DEFECT Property

public static Story.StoryType DEFECT {get;}

Property Value

Use the defect story type.

See Also

Story.StoryType Class | StarTeam Namespace


EPIC Property

Borland StarTeam SDK for .NET

Story.StoryType.EPIC Property

public static Story.StoryType EPIC {get;}

Property Value

Use the epic story type.

See Also

Story.StoryType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Story.StoryType.ID Property

[read] the ID of this Type value.

public virtual Int32 ID {get;}

Property Value

the ID of this Type value.

See Also

Story.StoryType Class | StarTeam Namespace


TECHNICAL_TODO Property

Borland StarTeam SDK for .NET

Story.StoryType.TECHNICAL_TODO Property

public static Story.StoryType TECHNICAL_TODO {get;}

Property Value

Use the technical to-do story type.

See Also

Story.StoryType Class | StarTeam Namespace


THEME Property

Borland StarTeam SDK for .NET

Story.StoryType.THEME Property

public static Story.StoryType THEME {get;}

Property Value

Use the theme story type.

See Also

Story.StoryType Class | StarTeam Namespace


USER_STORY Property

Borland StarTeam SDK for .NET

Story.StoryType.USER_STORY Property

public static Story.StoryType USER_STORY {get;}

Property Value

Specifies a regular user story.

See Also

Story.StoryType Class | StarTeam Namespace


Story.StoryType Methods

The methods of the Story.StoryType class are listed below. For a complete list of Story.StoryType class members, see the Story.StoryType Members topic.

Public Static Methods

FromID | Gets the story type corresponding to the given ID.
FromValue | Gets the story Type corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.StoryType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.StoryType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.StoryType.

See Also

Story.StoryType Class | StarTeam Namespace


Story.StoryType.Equals Method

Delegate Equals() to com.starteam.Story.StoryType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.StoryType.Equals(obj).

See Also

Story.StoryType Class | StarTeam Namespace


Story.StoryType.FromID Method

Gets the story type corresponding to the given ID.

public static StoryType FromID(
Int32 id
);

Parameters

id
A StoryType ID.

Return Value

the corresponding StoryType Type, or null.

See Also

Story.StoryType Class | StarTeam Namespace


Story.StoryType.FromValue Method

Gets the story Type corresponding to the given EnumeratedValue.

public static StoryType FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a StoryTypeProperty.

Return Value

the corresponding StoryType value, or null.

See Also

Story.StoryType Class | StarTeam Namespace


Story.StoryType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.StoryType.

public override int GetHashCode();

Return Value

com.starteam.Story.StoryType.GetHashCode().

See Also

Story.StoryType Class | StarTeam Namespace


Story.StoryType.ToString Method

Delegate ToString() to com.starteam.Story.StoryType.

public override string ToString();

Return Value

com.starteam.Story.StoryType.ToString()

See Also

Story.StoryType Class | StarTeam Namespace


Story.StoryValue Class

Value of the Story

For a list of all members of this type, see Story.StoryValue Members.

System.Object
EnumeratedValue
Story.StoryValue

public class Story.StoryValue : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.StoryValue Members | StarTeam Namespace


Story.StoryValue Members

Story.StoryValue overview

Public Static Properties

ALL
HIGH
LOW
MEDIUM

Public Static Methods

FromID | Gets the story value corresponding to the given ID.
FromValue | Gets the story value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.StoryValue.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.StoryValue.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.StoryValue.

See Also

Story.StoryValue Class | StarTeam Namespace


Story.StoryValue Properties

The properties of the Story.StoryValue class are listed below. For a complete list of Story.StoryValue class members, see the Story.StoryValue Members topic.

Public Static Properties

ALL
HIGH
LOW
MEDIUM

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Story.StoryValue Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Story.StoryValue.ALL Property

public static StoryValue[] ALL {get;}

See Also

Story.StoryValue Class | StarTeam Namespace


HIGH Property

Borland StarTeam SDK for .NET

Story.StoryValue.HIGH Property

public static Story.StoryValue HIGH {get;}

Property Value

Story's value is high

See Also

Story.StoryValue Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Story.StoryValue.ID Property

[read] the ID of this Value value.

public virtual Int32 ID {get;}

Property Value

the ID of this Value value.

See Also

Story.StoryValue Class | StarTeam Namespace


LOW Property

Borland StarTeam SDK for .NET

Story.StoryValue.LOW Property

public static Story.StoryValue LOW {get;}

Property Value

Story's value is low

See Also

Story.StoryValue Class | StarTeam Namespace


MEDIUM Property

Borland StarTeam SDK for .NET

Story.StoryValue.MEDIUM Property

public static Story.StoryValue MEDIUM {get;}

Property Value

Story is of medium StoryValue

See Also

Story.StoryValue Class | StarTeam Namespace


Story.StoryValue Methods

The methods of the Story.StoryValue class are listed below. For a complete list of Story.StoryValue class members, see the Story.StoryValue Members topic.

Public Static Methods

FromID | Gets the story value corresponding to the given ID.
FromValue | Gets the story value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.StoryValue.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.StoryValue.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.StoryValue.

See Also

Story.StoryValue Class | StarTeam Namespace


Story.StoryValue.Equals Method

Delegate Equals() to com.starteam.Story.StoryValue.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.StoryValue.Equals(obj).

See Also

Story.StoryValue Class | StarTeam Namespace


Story.StoryValue.FromID Method

Gets the story value corresponding to the given ID.

public static StoryValue FromID(
Int32 id
);

Parameters

id
A StoryValue ID.

Return Value

the corresponding StoryValue value, or null.

See Also

Story.StoryValue Class | StarTeam Namespace


Story.StoryValue.FromValue Method

Gets the story value corresponding to the given EnumeratedValue.

public static StoryValue FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a StoryValueProperty.

Return Value

the corresponding StoryValue value, or null.

See Also

Story.StoryValue Class | StarTeam Namespace


Story.StoryValue.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.StoryValue.

public override int GetHashCode();

Return Value

com.starteam.Story.StoryValue.GetHashCode().

See Also

Story.StoryValue Class | StarTeam Namespace


Story.StoryValue.ToString Method

Delegate ToString() to com.starteam.Story.StoryValue.

public override string ToString();

Return Value

com.starteam.Story.StoryValue.ToString()

See Also

Story.StoryValue Class | StarTeam Namespace


Story.StreamState Class

The Info Stream State of the Story

For a list of all members of this type, see Story.StreamState Members.

System.Object
EnumeratedValue
Story.StreamState

public class Story.StreamState : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.StreamState Members | StarTeam Namespace


Story.StreamState Members

Story.StreamState overview

Public Static Properties

ACCEPTED
ALL
NOT_STREAMED
PENDING
REJECTED

Public Static Methods

FromID | Gets the Stream State corresponding to the given ID.
FromValue | Gets the story value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.StreamState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.StreamState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.StreamState.

See Also

Story.StreamState Class | StarTeam Namespace


Story.StreamState Properties

The properties of the Story.StreamState class are listed below. For a complete list of Story.StreamState class members, see the Story.StreamState Members topic.

Public Static Properties

ACCEPTED
ALL
NOT_STREAMED
PENDING
REJECTED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Story.StreamState Class | StarTeam Namespace


ACCEPTED Property

Borland StarTeam SDK for .NET

Story.StreamState.ACCEPTED Property

public static Story.StreamState ACCEPTED {get;}

Property Value

Story's info stream set to Accepted

See Also

Story.StreamState Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Story.StreamState.ALL Property

public static StreamState[] ALL {get;}

See Also

Story.StreamState Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Story.StreamState.ID Property

[read] the ID of this Value value.

public virtual Int32 ID {get;}

Property Value

the ID of this Value value.

See Also

Story.StreamState Class | StarTeam Namespace


NOT_STREAMED Property

Borland StarTeam SDK for .NET

Story.StreamState.NOT_STREAMED Property

public static Story.StreamState NOT_STREAMED {get;}

Property Value

Story's info stream is not streamed

See Also

Story.StreamState Class | StarTeam Namespace


PENDING Property

Borland StarTeam SDK for .NET

Story.StreamState.PENDING Property

public static Story.StreamState PENDING {get;}

Property Value

Story info stream set to Pending

See Also

Story.StreamState Class | StarTeam Namespace


REJECTED Property

Borland StarTeam SDK for .NET

Story.StreamState.REJECTED Property

public static Story.StreamState REJECTED {get;}

Property Value

Story's info stream set to Rejected

See Also

Story.StreamState Class | StarTeam Namespace


Story.StreamState Methods

The methods of the Story.StreamState class are listed below. For a complete list of Story.StreamState class members, see the Story.StreamState Members topic.

Public Static Methods

FromID | Gets the Stream State corresponding to the given ID.
FromValue | Gets the story value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Story.StreamState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Story.StreamState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Story.StreamState.

See Also

Story.StreamState Class | StarTeam Namespace


Story.StreamState.Equals Method

Delegate Equals() to com.starteam.Story.StreamState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.StreamState.Equals(obj).

See Also

Story.StreamState Class | StarTeam Namespace


Story.StreamState.FromID Method

Gets the Stream State corresponding to the given ID.

public static StreamState FromID(
Int32 id
);

Parameters

id
A StreamState ID.

Return Value

the corresponding StreamState value, or null.

See Also

Story.StreamState Class | StarTeam Namespace


Story.StreamState.FromValue Method

Gets the story value corresponding to the given EnumeratedValue.

public static StreamState FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a StreamStateProperty.

Return Value

the corresponding StreamState value, or null.

See Also

Story.StreamState Class | StarTeam Namespace


Story.StreamState.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.StreamState.

public override int GetHashCode();

Return Value

com.starteam.Story.StreamState.GetHashCode().

See Also

Story.StreamState Class | StarTeam Namespace


Story.StreamState.ToString Method

Delegate ToString() to com.starteam.Story.StreamState.

public override string ToString();

Return Value

com.starteam.Story.StreamState.ToString()

See Also

Story.StreamState Class | StarTeam Namespace


Story.Type Class

Type meta-data (schema) for Story object instances.

For a list of all members of this type, see Story.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
TreeItem.Type
Story.Type

new public class Story.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type Members | StarTeam Namespace


Story.Type Members

Story.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Story.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Story.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Story.Type Class | StarTeam Namespace


Story.Type Properties

The properties of the Story.Type class are listed below. For a complete list of Story.Type class members, see the Story.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Story.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Story.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Story.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Story.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Story.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Story.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Story.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Story.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Story.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Story.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Story.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Story.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Story.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Story.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Story.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.NAME Property

new public static String NAME {get;}

See Also

Story.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Story.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Story.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Story.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Story.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Story.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Story.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Story.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Story.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Story.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Story.Type Class | StarTeam Namespace


Story.Type Methods

The methods of the Story.Type class are listed below. For a complete list of Story.Type class members, see the Story.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Story.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Story.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Story.Type Class | StarTeam Namespace


Story.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Story.Type Class | StarTeam Namespace


Story.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Story.Type Class | StarTeam Namespace


Story.Type.Equals Method

Delegate Equals() to com.starteam.Story.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.Equals(obj).

See Also

Story.Type Class | StarTeam Namespace


Story.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Story.Type Class | StarTeam Namespace


Story.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.GetHashCode().

See Also

Story.Type Class | StarTeam Namespace


Story.Type.ToString Method

Delegate ToString() to com.starteam.Story.Type.

public override string ToString();

Return Value

com.starteam.Story.Type.ToString()

See Also

Story.Type Class | StarTeam Namespace


Story.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Story.Type Class | StarTeam Namespace


Story.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Story.Type Class | StarTeam Namespace


Story.Type.AcceptanceCriteriaProperty Class

The property type of the AcceptanceCriteria property.

For a list of all members of this type, see Story.Type.AcceptanceCriteriaProperty Members.

System.Object
Property
VectorProperty
TextProperty
Story.Type.AcceptanceCriteriaProperty

public class Story.Type.AcceptanceCriteriaProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.AcceptanceCriteriaProperty Members | StarTeam Namespace


Story.Type.AcceptanceCriteriaProperty Members

Story.Type.AcceptanceCriteriaProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.AcceptanceCriteriaProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.AcceptanceCriteriaProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.AcceptanceCriteriaProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.AcceptanceCriteriaProperty Class | StarTeam Namespace


Story.Type.AcceptanceCriteriaProperty Properties

The properties of the Story.Type.AcceptanceCriteriaProperty class are listed below. For a complete list of Story.Type.AcceptanceCriteriaProperty class members, see the Story.Type.AcceptanceCriteriaProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Story.Type.AcceptanceCriteriaProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.AcceptanceCriteriaProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.AcceptanceCriteriaProperty Class | StarTeam Namespace


Story.Type.AcceptanceCriteriaProperty Methods

The methods of the Story.Type.AcceptanceCriteriaProperty class are listed below. For a complete list of Story.Type.AcceptanceCriteriaProperty class members, see the Story.Type.AcceptanceCriteriaProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.AcceptanceCriteriaProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.AcceptanceCriteriaProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.AcceptanceCriteriaProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.AcceptanceCriteriaProperty Class | StarTeam Namespace


Story.Type.AcceptanceCriteriaProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.AcceptanceCriteriaProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.AcceptanceCriteriaProperty.Equals(obj).

See Also

Story.Type.AcceptanceCriteriaProperty Class | StarTeam Namespace


Story.Type.AcceptanceCriteriaProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.AcceptanceCriteriaProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.AcceptanceCriteriaProperty.GetHashCode().

See Also

Story.Type.AcceptanceCriteriaProperty Class | StarTeam Namespace


Story.Type.AcceptanceCriteriaProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.AcceptanceCriteriaProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.AcceptanceCriteriaProperty.ToString()

See Also

Story.Type.AcceptanceCriteriaProperty Class | StarTeam Namespace


Story.Type.EstimatedPointsProperty Class

The property type of the Estimated Points property.

For a list of all members of this type, see Story.Type.EstimatedPointsProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Story.Type.EstimatedPointsProperty

public class Story.Type.EstimatedPointsProperty : DoubleProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.EstimatedPointsProperty Members | StarTeam Namespace


Story.Type.EstimatedPointsProperty Members

Story.Type.EstimatedPointsProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.EstimatedPointsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.EstimatedPointsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.EstimatedPointsProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.EstimatedPointsProperty Class | StarTeam Namespace


Story.Type.EstimatedPointsProperty Properties

The properties of the Story.Type.EstimatedPointsProperty class are listed below. For a complete list of Story.Type.EstimatedPointsProperty class members, see the Story.Type.EstimatedPointsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Story.Type.EstimatedPointsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.EstimatedPointsProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.EstimatedPointsProperty Class | StarTeam Namespace


Story.Type.EstimatedPointsProperty Methods

The methods of the Story.Type.EstimatedPointsProperty class are listed below. For a complete list of Story.Type.EstimatedPointsProperty class members, see the Story.Type.EstimatedPointsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.EstimatedPointsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.EstimatedPointsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.EstimatedPointsProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.EstimatedPointsProperty Class | StarTeam Namespace


Story.Type.EstimatedPointsProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.EstimatedPointsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.EstimatedPointsProperty.Equals(obj).

See Also

Story.Type.EstimatedPointsProperty Class | StarTeam Namespace


Story.Type.EstimatedPointsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.EstimatedPointsProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.EstimatedPointsProperty.GetHashCode().

See Also

Story.Type.EstimatedPointsProperty Class | StarTeam Namespace


Story.Type.EstimatedPointsProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.EstimatedPointsProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.EstimatedPointsProperty.ToString()

See Also

Story.Type.EstimatedPointsProperty Class | StarTeam Namespace


Story.Type.GeneralProperty Class

The property type of the General property.

For a list of all members of this type, see Story.Type.GeneralProperty Members.

System.Object
Property
VectorProperty
TextProperty
Story.Type.GeneralProperty

public class Story.Type.GeneralProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.GeneralProperty Members | StarTeam Namespace


Story.Type.GeneralProperty Members

Story.Type.GeneralProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.GeneralProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.GeneralProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.GeneralProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.GeneralProperty Class | StarTeam Namespace


Story.Type.GeneralProperty Properties

The properties of the Story.Type.GeneralProperty class are listed below. For a complete list of Story.Type.GeneralProperty class members, see the Story.Type.GeneralProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Story.Type.GeneralProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.GeneralProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.GeneralProperty Class | StarTeam Namespace


Story.Type.GeneralProperty Methods

The methods of the Story.Type.GeneralProperty class are listed below. For a complete list of Story.Type.GeneralProperty class members, see the Story.Type.GeneralProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.GeneralProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.GeneralProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.GeneralProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.GeneralProperty Class | StarTeam Namespace


Story.Type.GeneralProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.GeneralProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.GeneralProperty.Equals(obj).

See Also

Story.Type.GeneralProperty Class | StarTeam Namespace


Story.Type.GeneralProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.GeneralProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.GeneralProperty.GetHashCode().

See Also

Story.Type.GeneralProperty Class | StarTeam Namespace


Story.Type.GeneralProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.GeneralProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.GeneralProperty.ToString()

See Also

Story.Type.GeneralProperty Class | StarTeam Namespace


Story.Type.IncomingStreamProperty Class

The Property Type of the IncomingStream Property

For a list of all members of this type, see Story.Type.IncomingStreamProperty Members.

System.Object
Property
EnumeratedProperty
Story.Type.IncomingStreamProperty

public class Story.Type.IncomingStreamProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.IncomingStreamProperty Members | StarTeam Namespace


Story.Type.IncomingStreamProperty Members

Story.Type.IncomingStreamProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.IncomingStreamProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.IncomingStreamProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.IncomingStreamProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.IncomingStreamProperty Class | StarTeam Namespace


Story.Type.IncomingStreamProperty Properties

The properties of the Story.Type.IncomingStreamProperty class are listed below. For a complete list of Story.Type.IncomingStreamProperty class members, see the Story.Type.IncomingStreamProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Story.Type.IncomingStreamProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.IncomingStreamProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.IncomingStreamProperty Class | StarTeam Namespace


Story.Type.IncomingStreamProperty Methods

The methods of the Story.Type.IncomingStreamProperty class are listed below. For a complete list of Story.Type.IncomingStreamProperty class members, see the Story.Type.IncomingStreamProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.IncomingStreamProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.IncomingStreamProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.IncomingStreamProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.IncomingStreamProperty Class | StarTeam Namespace


Story.Type.IncomingStreamProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.IncomingStreamProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.IncomingStreamProperty.Equals(obj).

See Also

Story.Type.IncomingStreamProperty Class | StarTeam Namespace


Story.Type.IncomingStreamProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.IncomingStreamProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.IncomingStreamProperty.GetHashCode().

See Also

Story.Type.IncomingStreamProperty Class | StarTeam Namespace


Story.Type.IncomingStreamProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.IncomingStreamProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.IncomingStreamProperty.ToString()

See Also

Story.Type.IncomingStreamProperty Class | StarTeam Namespace


Story.Type.IsCarriedOverProperty Class

The property type of the IsLeaf property

For a list of all members of this type, see Story.Type.IsCarriedOverProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Story.Type.IsCarriedOverProperty

public class Story.Type.IsCarriedOverProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.IsCarriedOverProperty Members | StarTeam Namespace


Story.Type.IsCarriedOverProperty Members

Story.Type.IsCarriedOverProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.IsCarriedOverProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.IsCarriedOverProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.IsCarriedOverProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.IsCarriedOverProperty Class | StarTeam Namespace


Story.Type.IsCarriedOverProperty Properties

The properties of the Story.Type.IsCarriedOverProperty class are listed below. For a complete list of Story.Type.IsCarriedOverProperty class members, see the Story.Type.IsCarriedOverProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Story.Type.IsCarriedOverProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.IsCarriedOverProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.IsCarriedOverProperty Class | StarTeam Namespace


Story.Type.IsCarriedOverProperty Methods

The methods of the Story.Type.IsCarriedOverProperty class are listed below. For a complete list of Story.Type.IsCarriedOverProperty class members, see the Story.Type.IsCarriedOverProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.IsCarriedOverProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.IsCarriedOverProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.IsCarriedOverProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.IsCarriedOverProperty Class | StarTeam Namespace


Story.Type.IsCarriedOverProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.IsCarriedOverProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.IsCarriedOverProperty.Equals(obj).

See Also

Story.Type.IsCarriedOverProperty Class | StarTeam Namespace


Story.Type.IsCarriedOverProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.IsCarriedOverProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.IsCarriedOverProperty.GetHashCode().

See Also

Story.Type.IsCarriedOverProperty Class | StarTeam Namespace


Story.Type.IsCarriedOverProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.IsCarriedOverProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.IsCarriedOverProperty.ToString()

See Also

Story.Type.IsCarriedOverProperty Class | StarTeam Namespace


Story.Type.NotesProperty Class

The property type of the Notes property.

For a list of all members of this type, see Story.Type.NotesProperty Members.

System.Object
Property
VectorProperty
TextProperty
Story.Type.NotesProperty

public class Story.Type.NotesProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.NotesProperty Members | StarTeam Namespace


Story.Type.NotesProperty Members

Story.Type.NotesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.NotesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.NotesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.NotesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.NotesProperty Class | StarTeam Namespace


Story.Type.NotesProperty Properties

The properties of the Story.Type.NotesProperty class are listed below. For a complete list of Story.Type.NotesProperty class members, see the Story.Type.NotesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Story.Type.NotesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.NotesProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.NotesProperty Class | StarTeam Namespace


Story.Type.NotesProperty Methods

The methods of the Story.Type.NotesProperty class are listed below. For a complete list of Story.Type.NotesProperty class members, see the Story.Type.NotesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.NotesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.NotesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.NotesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.NotesProperty Class | StarTeam Namespace


Story.Type.NotesProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.NotesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.NotesProperty.Equals(obj).

See Also

Story.Type.NotesProperty Class | StarTeam Namespace


Story.Type.NotesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.NotesProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.NotesProperty.GetHashCode().

See Also

Story.Type.NotesProperty Class | StarTeam Namespace


Story.Type.NotesProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.NotesProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.NotesProperty.ToString()

See Also

Story.Type.NotesProperty Class | StarTeam Namespace


Story.Type.PlanProperty Class

The property type of the Plan property

For a list of all members of this type, see Story.Type.PlanProperty Members.

System.Object
Property
ObjectProperty
Story.Type.PlanProperty

public class Story.Type.PlanProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.PlanProperty Members | StarTeam Namespace


Story.Type.PlanProperty Members

Story.Type.PlanProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.PlanProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.PlanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.PlanProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.PlanProperty Class | StarTeam Namespace


Story.Type.PlanProperty Properties

The properties of the Story.Type.PlanProperty class are listed below. For a complete list of Story.Type.PlanProperty class members, see the Story.Type.PlanProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Story.Type.PlanProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.PlanProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.PlanProperty Class | StarTeam Namespace


Story.Type.PlanProperty Methods

The methods of the Story.Type.PlanProperty class are listed below. For a complete list of Story.Type.PlanProperty class members, see the Story.Type.PlanProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.PlanProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.PlanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.PlanProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.PlanProperty Class | StarTeam Namespace


Story.Type.PlanProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.PlanProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.PlanProperty.Equals(obj).

See Also

Story.Type.PlanProperty Class | StarTeam Namespace


Story.Type.PlanProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.PlanProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.PlanProperty.GetHashCode().

See Also

Story.Type.PlanProperty Class | StarTeam Namespace


Story.Type.PlanProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.PlanProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.PlanProperty.ToString()

See Also

Story.Type.PlanProperty Class | StarTeam Namespace


Story.Type.PropertyCollection Class

The PropertyCollection of a Story item.

For a list of all members of this type, see Story.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Story.Type.PropertyCollection

public class Story.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.PropertyCollection Members | StarTeam Namespace


Story.Type.PropertyCollection Members

Story.Type.PropertyCollection overview

Public Instance Properties

ACCEPTANCE_CRITERIA |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
ESTIMATED_POINTS |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_TEST_ID |
EXTERNAL_TEST_PROJECT_URL |
EXTERNAL_TEST_URL |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GENERAL |
GLOBAL_ID |
ID |
INCOMING_STREAM |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_CARRIED_OVER |
IS_CHECKED (inherited from PropertyCollection) |
IS_LEAF |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MOSCOW |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTES |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_ID |
PLAN |
RANK |
REVISION_FLAGS |
REVISION_NUMBER |
RICH_DESCRIPTION |
RISK |
SHARE_STATE |
SHORT_COMMENT |
SPONSOR |
SPRINT |
STATUS |
STORY_ID |
STORY_ORDER |
STORY_TYPE |
STORY_VALUE |
STREAM_STATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAG |
TARGET_RELEASES |
TEAM |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Story.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Story.Type.PropertyCollection.

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


Story.Type.PropertyCollection Properties

The properties of the Story.Type.PropertyCollection class are listed below. For a complete list of Story.Type.PropertyCollection class members, see the Story.Type.PropertyCollection Members topic.

Public Instance Properties

ACCEPTANCE_CRITERIA |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
ESTIMATED_POINTS |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_TEST_ID |
EXTERNAL_TEST_PROJECT_URL |
EXTERNAL_TEST_URL |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GENERAL |
GLOBAL_ID |
ID |
INCOMING_STREAM |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_CARRIED_OVER |
IS_CHECKED (inherited from PropertyCollection) |
IS_LEAF |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MOSCOW |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTES |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_ID |
PLAN |
RANK |
REVISION_FLAGS |
REVISION_NUMBER |
RICH_DESCRIPTION |
RISK |
SHARE_STATE |
SHORT_COMMENT |
SPONSOR |
SPRINT |
STATUS |
STORY_ID |
STORY_ORDER |
STORY_TYPE |
STORY_VALUE |
STREAM_STATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAG |
TARGET_RELEASES |
TEAM |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


ACCEPTANCE_CRITERIA Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.ACCEPTANCE_CRITERIA Property

public Story.Type.AcceptanceCriteriaProperty ACCEPTANCE_CRITERIA {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


ESTIMATED_POINTS Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.ESTIMATED_POINTS Property

public Story.Type.EstimatedPointsProperty ESTIMATED_POINTS {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_TEST_ID Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.EXTERNAL_TEST_ID Property

public TreeItem.Type.ExternalTestIDProperty EXTERNAL_TEST_ID {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_TEST_PROJECT_URL Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.EXTERNAL_TEST_PROJECT_URL Property

public TreeItem.Type.ExternalTestProjectURLProperty EXTERNAL_TEST_PROJECT_URL {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_TEST_URL Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.EXTERNAL_TEST_URL Property

public TreeItem.Type.ExternalTestURLProperty EXTERNAL_TEST_URL {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


GENERAL Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.GENERAL Property

public Story.Type.GeneralProperty GENERAL {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


INCOMING_STREAM Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.INCOMING_STREAM Property

public Story.Type.IncomingStreamProperty INCOMING_STREAM {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


IS_CARRIED_OVER Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.IS_CARRIED_OVER Property

public Story.Type.IsCarriedOverProperty IS_CARRIED_OVER {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


IS_LEAF Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.IS_LEAF Property

public TreeItem.Type.IsLeafProperty IS_LEAF {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


MOSCOW Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.MOSCOW Property

public TreeItem.Type.MoSCoWProperty MOSCOW {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


NOTES Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.NOTES Property

public Story.Type.NotesProperty NOTES {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


PARENT_ID Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.PARENT_ID Property

public TreeItem.Type.ParentIDProperty PARENT_ID {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


PLAN Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.PLAN Property

public Story.Type.PlanProperty PLAN {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


RANK Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.RANK Property

public Story.Type.RankProperty RANK {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


RICH_DESCRIPTION Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.RICH_DESCRIPTION Property

public TreeItem.Type.RichDescriptionProperty RICH_DESCRIPTION {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


RISK Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.RISK Property

public Story.Type.RiskProperty RISK {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


SPONSOR Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.SPONSOR Property

public Story.Type.SponsorProperty SPONSOR {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


SPRINT Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.SPRINT Property

public Story.Type.SprintProperty SPRINT {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.STATUS Property

public Story.Type.StatusProperty STATUS {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


STORY_ID Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.STORY_ID Property

public Story.Type.StoryIDProperty STORY_ID {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


STORY_ORDER Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.STORY_ORDER Property

public Story.Type.StoryOrderProperty STORY_ORDER {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


STORY_TYPE Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.STORY_TYPE Property

public Story.Type.StoryTypeProperty STORY_TYPE {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


STORY_VALUE Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.STORY_VALUE Property

public Story.Type.StoryValueProperty STORY_VALUE {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


STREAM_STATE Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.STREAM_STATE Property

public Story.Type.StreamStateProperty STREAM_STATE {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


TAG Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.TAG Property

public Item.Type.TagProperty TAG {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


TARGET_RELEASES Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.TARGET_RELEASES Property

public Story.Type.TargetReleasesProperty TARGET_RELEASES {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


TEAM Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.TEAM Property

public Item.Type.TeamProperty TEAM {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.VERSION_METADATA Property

public Item.Type.VersionMetadataProperty VERSION_METADATA {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA_IDS Property

Borland StarTeam SDK for .NET

Story.Type.PropertyCollection.VERSION_METADATA_IDS Property

public Item.Type.VersionMetadataIDsProperty VERSION_METADATA_IDS {get;}

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


Story.Type.PropertyCollection Methods

The methods of the Story.Type.PropertyCollection class are listed below. For a complete list of Story.Type.PropertyCollection class members, see the Story.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Story.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Story.Type.PropertyCollection.

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


Story.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Story.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.PropertyCollection.Equals(obj).

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


Story.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.PropertyCollection.GetHashCode().

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


Story.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Story.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Story.Type.PropertyCollection.ToString()

See Also

Story.Type.PropertyCollection Class | StarTeam Namespace


Story.Type.RankProperty Class

The property type of the Rank property.

For a list of all members of this type, see Story.Type.RankProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Story.Type.RankProperty

public class Story.Type.RankProperty : DoubleProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.RankProperty Members | StarTeam Namespace


Story.Type.RankProperty Members

Story.Type.RankProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.RankProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.RankProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.RankProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.RankProperty Class | StarTeam Namespace


Story.Type.RankProperty Properties

The properties of the Story.Type.RankProperty class are listed below. For a complete list of Story.Type.RankProperty class members, see the Story.Type.RankProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Story.Type.RankProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.RankProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.RankProperty Class | StarTeam Namespace


Story.Type.RankProperty Methods

The methods of the Story.Type.RankProperty class are listed below. For a complete list of Story.Type.RankProperty class members, see the Story.Type.RankProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.RankProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.RankProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.RankProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.RankProperty Class | StarTeam Namespace


Story.Type.RankProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.RankProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.RankProperty.Equals(obj).

See Also

Story.Type.RankProperty Class | StarTeam Namespace


Story.Type.RankProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.RankProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.RankProperty.GetHashCode().

See Also

Story.Type.RankProperty Class | StarTeam Namespace


Story.Type.RankProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.RankProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.RankProperty.ToString()

See Also

Story.Type.RankProperty Class | StarTeam Namespace


Story.Type.RiskProperty Class

The property type of the Risk property.

For a list of all members of this type, see Story.Type.RiskProperty Members.

System.Object
Property
EnumeratedProperty
Story.Type.RiskProperty

public class Story.Type.RiskProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.RiskProperty Members | StarTeam Namespace


Story.Type.RiskProperty Members

Story.Type.RiskProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.RiskProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.RiskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.RiskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.RiskProperty Class | StarTeam Namespace


Story.Type.RiskProperty Properties

The properties of the Story.Type.RiskProperty class are listed below. For a complete list of Story.Type.RiskProperty class members, see the Story.Type.RiskProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Story.Type.RiskProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.RiskProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.RiskProperty Class | StarTeam Namespace


Story.Type.RiskProperty Methods

The methods of the Story.Type.RiskProperty class are listed below. For a complete list of Story.Type.RiskProperty class members, see the Story.Type.RiskProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.RiskProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.RiskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.RiskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.RiskProperty Class | StarTeam Namespace


Story.Type.RiskProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.RiskProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.RiskProperty.Equals(obj).

See Also

Story.Type.RiskProperty Class | StarTeam Namespace


Story.Type.RiskProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Story.Risk value
);

See Also

Story.Type.RiskProperty Class | StarTeam Namespace


Story.Type.RiskProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.RiskProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.RiskProperty.GetHashCode().

See Also

Story.Type.RiskProperty Class | StarTeam Namespace


Story.Type.RiskProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.RiskProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.RiskProperty.ToString()

See Also

Story.Type.RiskProperty Class | StarTeam Namespace


Story.Type.SponsorProperty Class

The property type of the Sponsor property.

For a list of all members of this type, see Story.Type.SponsorProperty Members.

System.Object
Property
ObjectProperty
Story.Type.SponsorProperty

public class Story.Type.SponsorProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.SponsorProperty Members | StarTeam Namespace


Story.Type.SponsorProperty Members

Story.Type.SponsorProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.SponsorProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.SponsorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.SponsorProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.SponsorProperty Class | StarTeam Namespace


Story.Type.SponsorProperty Properties

The properties of the Story.Type.SponsorProperty class are listed below. For a complete list of Story.Type.SponsorProperty class members, see the Story.Type.SponsorProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Story.Type.SponsorProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.SponsorProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.SponsorProperty Class | StarTeam Namespace


Story.Type.SponsorProperty Methods

The methods of the Story.Type.SponsorProperty class are listed below. For a complete list of Story.Type.SponsorProperty class members, see the Story.Type.SponsorProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.SponsorProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.SponsorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.SponsorProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.SponsorProperty Class | StarTeam Namespace


Story.Type.SponsorProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.SponsorProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.SponsorProperty.Equals(obj).

See Also

Story.Type.SponsorProperty Class | StarTeam Namespace


Story.Type.SponsorProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.SponsorProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.SponsorProperty.GetHashCode().

See Also

Story.Type.SponsorProperty Class | StarTeam Namespace


Story.Type.SponsorProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.SponsorProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.SponsorProperty.ToString()

See Also

Story.Type.SponsorProperty Class | StarTeam Namespace


Story.Type.SprintProperty Class

The property type of the Sprint property

For a list of all members of this type, see Story.Type.SprintProperty Members.

System.Object
Property
ObjectProperty
Story.Type.SprintProperty

public class Story.Type.SprintProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.SprintProperty Members | StarTeam Namespace


Story.Type.SprintProperty Members

Story.Type.SprintProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.SprintProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.SprintProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.SprintProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.SprintProperty Class | StarTeam Namespace


Story.Type.SprintProperty Properties

The properties of the Story.Type.SprintProperty class are listed below. For a complete list of Story.Type.SprintProperty class members, see the Story.Type.SprintProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Story.Type.SprintProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.SprintProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.SprintProperty Class | StarTeam Namespace


Story.Type.SprintProperty Methods

The methods of the Story.Type.SprintProperty class are listed below. For a complete list of Story.Type.SprintProperty class members, see the Story.Type.SprintProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.SprintProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.SprintProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.SprintProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.SprintProperty Class | StarTeam Namespace


Story.Type.SprintProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.SprintProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.SprintProperty.Equals(obj).

See Also

Story.Type.SprintProperty Class | StarTeam Namespace


Story.Type.SprintProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.SprintProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.SprintProperty.GetHashCode().

See Also

Story.Type.SprintProperty Class | StarTeam Namespace


Story.Type.SprintProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.SprintProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.SprintProperty.ToString()

See Also

Story.Type.SprintProperty Class | StarTeam Namespace


Story.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see Story.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
Story.Type.StatusProperty

public class Story.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.StatusProperty Members | StarTeam Namespace


Story.Type.StatusProperty Members

Story.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StatusProperty Class | StarTeam Namespace


Story.Type.StatusProperty Properties

The properties of the Story.Type.StatusProperty class are listed below. For a complete list of Story.Type.StatusProperty class members, see the Story.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Story.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.StatusProperty Class | StarTeam Namespace


Story.Type.StatusProperty Methods

The methods of the Story.Type.StatusProperty class are listed below. For a complete list of Story.Type.StatusProperty class members, see the Story.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StatusProperty Class | StarTeam Namespace


Story.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.StatusProperty.Equals(obj).

See Also

Story.Type.StatusProperty Class | StarTeam Namespace


Story.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Story.Status value
);

See Also

Story.Type.StatusProperty Class | StarTeam Namespace


Story.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.StatusProperty.GetHashCode().

See Also

Story.Type.StatusProperty Class | StarTeam Namespace


Story.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.StatusProperty.ToString()

See Also

Story.Type.StatusProperty Class | StarTeam Namespace


Story.Type.StoryIDProperty Class

The property type of the StoryID property

For a list of all members of this type, see Story.Type.StoryIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Story.Type.StoryIDProperty

public class Story.Type.StoryIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.StoryIDProperty Members | StarTeam Namespace


Story.Type.StoryIDProperty Members

Story.Type.StoryIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.StoryIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StoryIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.StoryIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StoryIDProperty Class | StarTeam Namespace


Story.Type.StoryIDProperty Properties

The properties of the Story.Type.StoryIDProperty class are listed below. For a complete list of Story.Type.StoryIDProperty class members, see the Story.Type.StoryIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Story.Type.StoryIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.StoryIDProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.StoryIDProperty Class | StarTeam Namespace


Story.Type.StoryIDProperty Methods

The methods of the Story.Type.StoryIDProperty class are listed below. For a complete list of Story.Type.StoryIDProperty class members, see the Story.Type.StoryIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.StoryIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StoryIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.StoryIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StoryIDProperty Class | StarTeam Namespace


Story.Type.StoryIDProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.StoryIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.StoryIDProperty.Equals(obj).

See Also

Story.Type.StoryIDProperty Class | StarTeam Namespace


Story.Type.StoryIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.StoryIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.StoryIDProperty.GetHashCode().

See Also

Story.Type.StoryIDProperty Class | StarTeam Namespace


Story.Type.StoryIDProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.StoryIDProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.StoryIDProperty.ToString()

See Also

Story.Type.StoryIDProperty Class | StarTeam Namespace


Story.Type.StoryOrderProperty Class

The property type of the StoryOrder property.

For a list of all members of this type, see Story.Type.StoryOrderProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Story.Type.StoryOrderProperty

public class Story.Type.StoryOrderProperty : DoubleProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.StoryOrderProperty Members | StarTeam Namespace


Story.Type.StoryOrderProperty Members

Story.Type.StoryOrderProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.StoryOrderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StoryOrderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.StoryOrderProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StoryOrderProperty Class | StarTeam Namespace


Story.Type.StoryOrderProperty Properties

The properties of the Story.Type.StoryOrderProperty class are listed below. For a complete list of Story.Type.StoryOrderProperty class members, see the Story.Type.StoryOrderProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Story.Type.StoryOrderProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.StoryOrderProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.StoryOrderProperty Class | StarTeam Namespace


Story.Type.StoryOrderProperty Methods

The methods of the Story.Type.StoryOrderProperty class are listed below. For a complete list of Story.Type.StoryOrderProperty class members, see the Story.Type.StoryOrderProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.StoryOrderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StoryOrderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.StoryOrderProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StoryOrderProperty Class | StarTeam Namespace


Story.Type.StoryOrderProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.StoryOrderProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.StoryOrderProperty.Equals(obj).

See Also

Story.Type.StoryOrderProperty Class | StarTeam Namespace


Story.Type.StoryOrderProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.StoryOrderProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.StoryOrderProperty.GetHashCode().

See Also

Story.Type.StoryOrderProperty Class | StarTeam Namespace


Story.Type.StoryOrderProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.StoryOrderProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.StoryOrderProperty.ToString()

See Also

Story.Type.StoryOrderProperty Class | StarTeam Namespace


Story.Type.StoryTypeProperty Class

The property type of the StoryType property.

For a list of all members of this type, see Story.Type.StoryTypeProperty Members.

System.Object
Property
EnumeratedProperty
Story.Type.StoryTypeProperty

public class Story.Type.StoryTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.StoryTypeProperty Members | StarTeam Namespace


Story.Type.StoryTypeProperty Members

Story.Type.StoryTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.StoryTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StoryTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.StoryTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StoryTypeProperty Class | StarTeam Namespace


Story.Type.StoryTypeProperty Properties

The properties of the Story.Type.StoryTypeProperty class are listed below. For a complete list of Story.Type.StoryTypeProperty class members, see the Story.Type.StoryTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Story.Type.StoryTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.StoryTypeProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.StoryTypeProperty Class | StarTeam Namespace


Story.Type.StoryTypeProperty Methods

The methods of the Story.Type.StoryTypeProperty class are listed below. For a complete list of Story.Type.StoryTypeProperty class members, see the Story.Type.StoryTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.StoryTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StoryTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.StoryTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StoryTypeProperty Class | StarTeam Namespace


Story.Type.StoryTypeProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.StoryTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.StoryTypeProperty.Equals(obj).

See Also

Story.Type.StoryTypeProperty Class | StarTeam Namespace


Story.Type.StoryTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Story.StoryType value
);

See Also

Story.Type.StoryTypeProperty Class | StarTeam Namespace


Story.Type.StoryTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.StoryTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.StoryTypeProperty.GetHashCode().

See Also

Story.Type.StoryTypeProperty Class | StarTeam Namespace


Story.Type.StoryTypeProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.StoryTypeProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.StoryTypeProperty.ToString()

See Also

Story.Type.StoryTypeProperty Class | StarTeam Namespace


Story.Type.StoryValueProperty Class

The property type of the StoryValue property.

For a list of all members of this type, see Story.Type.StoryValueProperty Members.

System.Object
Property
EnumeratedProperty
Story.Type.StoryValueProperty

public class Story.Type.StoryValueProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.StoryValueProperty Members | StarTeam Namespace


Story.Type.StoryValueProperty Members

Story.Type.StoryValueProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.StoryValueProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StoryValueProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.StoryValueProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StoryValueProperty Class | StarTeam Namespace


Story.Type.StoryValueProperty Properties

The properties of the Story.Type.StoryValueProperty class are listed below. For a complete list of Story.Type.StoryValueProperty class members, see the Story.Type.StoryValueProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Story.Type.StoryValueProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.StoryValueProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.StoryValueProperty Class | StarTeam Namespace


Story.Type.StoryValueProperty Methods

The methods of the Story.Type.StoryValueProperty class are listed below. For a complete list of Story.Type.StoryValueProperty class members, see the Story.Type.StoryValueProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.StoryValueProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StoryValueProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.StoryValueProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StoryValueProperty Class | StarTeam Namespace


Story.Type.StoryValueProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.StoryValueProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.StoryValueProperty.Equals(obj).

See Also

Story.Type.StoryValueProperty Class | StarTeam Namespace


Story.Type.StoryValueProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Story.StoryValue value
);

See Also

Story.Type.StoryValueProperty Class | StarTeam Namespace


Story.Type.StoryValueProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.StoryValueProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.StoryValueProperty.GetHashCode().

See Also

Story.Type.StoryValueProperty Class | StarTeam Namespace


Story.Type.StoryValueProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.StoryValueProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.StoryValueProperty.ToString()

See Also

Story.Type.StoryValueProperty Class | StarTeam Namespace


Story.Type.StreamStateProperty Class

The property type of the StreamState property.

For a list of all members of this type, see Story.Type.StreamStateProperty Members.

System.Object
Property
EnumeratedProperty
Story.Type.StreamStateProperty

public class Story.Type.StreamStateProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.StreamStateProperty Members | StarTeam Namespace


Story.Type.StreamStateProperty Members

Story.Type.StreamStateProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.StreamStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StreamStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.StreamStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StreamStateProperty Class | StarTeam Namespace


Story.Type.StreamStateProperty Properties

The properties of the Story.Type.StreamStateProperty class are listed below. For a complete list of Story.Type.StreamStateProperty class members, see the Story.Type.StreamStateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Story.Type.StreamStateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.StreamStateProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.StreamStateProperty Class | StarTeam Namespace


Story.Type.StreamStateProperty Methods

The methods of the Story.Type.StreamStateProperty class are listed below. For a complete list of Story.Type.StreamStateProperty class members, see the Story.Type.StreamStateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Story.Type.StreamStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.StreamStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Story.Type.StreamStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.StreamStateProperty Class | StarTeam Namespace


Story.Type.StreamStateProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.StreamStateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.StreamStateProperty.Equals(obj).

See Also

Story.Type.StreamStateProperty Class | StarTeam Namespace


Story.Type.StreamStateProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Story.StreamState value
);

See Also

Story.Type.StreamStateProperty Class | StarTeam Namespace


Story.Type.StreamStateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.StreamStateProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.StreamStateProperty.GetHashCode().

See Also

Story.Type.StreamStateProperty Class | StarTeam Namespace


Story.Type.StreamStateProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.StreamStateProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.StreamStateProperty.ToString()

See Also

Story.Type.StreamStateProperty Class | StarTeam Namespace


Story.Type.TargetReleasesProperty Class

The property type of the TargetReleases property.

For a list of all members of this type, see Story.Type.TargetReleasesProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Story.Type.TargetReleasesProperty

public class Story.Type.TargetReleasesProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.Type.TargetReleasesProperty Members | StarTeam Namespace


Story.Type.TargetReleasesProperty Members

Story.Type.TargetReleasesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.TargetReleasesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.TargetReleasesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.TargetReleasesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.TargetReleasesProperty Class | StarTeam Namespace


Story.Type.TargetReleasesProperty Properties

The properties of the Story.Type.TargetReleasesProperty class are listed below. For a complete list of Story.Type.TargetReleasesProperty class members, see the Story.Type.TargetReleasesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Story.Type.TargetReleasesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Story.Type.TargetReleasesProperty.NAME Property

public static String NAME {get;}

See Also

Story.Type.TargetReleasesProperty Class | StarTeam Namespace


Story.Type.TargetReleasesProperty Methods

The methods of the Story.Type.TargetReleasesProperty class are listed below. For a complete list of Story.Type.TargetReleasesProperty class members, see the Story.Type.TargetReleasesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Story.Type.TargetReleasesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Story.Type.TargetReleasesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Story.Type.TargetReleasesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Story.Type.TargetReleasesProperty Class | StarTeam Namespace


Story.Type.TargetReleasesProperty.Equals Method

Delegate Equals() to com.starteam.Story.Type.TargetReleasesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.Type.TargetReleasesProperty.Equals(obj).

See Also

Story.Type.TargetReleasesProperty Class | StarTeam Namespace


Story.Type.TargetReleasesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.Type.TargetReleasesProperty.

public override int GetHashCode();

Return Value

com.starteam.Story.Type.TargetReleasesProperty.GetHashCode().

See Also

Story.Type.TargetReleasesProperty Class | StarTeam Namespace


Story.Type.TargetReleasesProperty.ToString Method

Delegate ToString() to com.starteam.Story.Type.TargetReleasesProperty.

public override string ToString();

Return Value

com.starteam.Story.Type.TargetReleasesProperty.ToString()

See Also

Story.Type.TargetReleasesProperty Class | StarTeam Namespace


Story.WebCacheStory Class

Item accessor for cached SDK Story items contained objects are obtained from the artifact cache

For a list of all members of this type, see Story.WebCacheStory Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
TreeItem.WebCacheTreeItem
Story.WebCacheStory

public class Story.WebCacheStory : WebCacheTreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Story.WebCacheStory Members | StarTeam Namespace


Story.WebCacheStory Members

Story.WebCacheStory overview

Public Static Methods

Create Overloaded.

Public Instance Properties

AcceptanceCriteria | [read/write] the text in the "AcceptanceCriteria" for this story.
After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this story.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EstimatedPoints | [read/write] A estimated points indicating how long it might take for the story to be completed.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalTestID | [read/write] the external test ID for this requirement
ExternalTestProjectURL | [read/write] the external test Project URL for this requirement
ExternalTestURL | [read/write] the external test URL for this requirement
ExternalURL | [read/write] The external URL describing this revision of the item.
General | [read/write] the text in the "General" for this story.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IncomingStreams | [read/write] the Incoming Streams, if any attached to this story instance
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsCarriedOver | [read] true if this story has been carried over
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MoSCoWValue | [read/write] the MoSCoW of the story
MyType | [read] the type of this resource.
Name |
NameProperty |
Notes | [read/write] the text in the "Notes" for this story.
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Order | [read/write] the order in which the story should be executed.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
ParentPlan | [read] The plan being set as parent of this or null
ParentSprint | [read] The sprint being set as parent of this or null
PresentationID | [read] the unique integer identifier for this resource.
Rank | [read/write] the rank in which the story should be viewed.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
RichDescription | [read/write] the rich description of this story.
Rights | [read/write] the access rights assigned to this filter
Risk | [read/write] risk used for this story
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Sponsor | [read/write] the sponsor of the story
StatusValue | [read/write] A status reflecting the statuses of its tasks
StoryID | [read] the story id.
StoryType | [read/write] story type used for this story
StoryValue | [read/write] storyValue of this story
StreamState | [read/write] streamState of this story
Tags | [read/write] the tags, if any attached to this story instance
TargetReleases | [read/write] the target releases that this story may be mapped to
Team | [read/write] The team for this story.
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Story.WebCacheStory.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Story.WebCacheStory.
GetTasks |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Story.WebCacheStory.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory Properties

The properties of the Story.WebCacheStory class are listed below. For a complete list of Story.WebCacheStory class members, see the Story.WebCacheStory Members topic.

Public Instance Properties

AcceptanceCriteria | [read/write] the text in the "AcceptanceCriteria" for this story.
After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this story.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EstimatedPoints | [read/write] A estimated points indicating how long it might take for the story to be completed.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalTestID | [read/write] the external test ID for this requirement
ExternalTestProjectURL | [read/write] the external test Project URL for this requirement
ExternalTestURL | [read/write] the external test URL for this requirement
ExternalURL | [read/write] The external URL describing this revision of the item.
General | [read/write] the text in the "General" for this story.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IncomingStreams | [read/write] the Incoming Streams, if any attached to this story instance
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsCarriedOver | [read] true if this story has been carried over
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MoSCoWValue | [read/write] the MoSCoW of the story
MyType | [read] the type of this resource.
Name |
NameProperty |
Notes | [read/write] the text in the "Notes" for this story.
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Order | [read/write] the order in which the story should be executed.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
ParentPlan | [read] The plan being set as parent of this or null
ParentSprint | [read] The sprint being set as parent of this or null
PresentationID | [read] the unique integer identifier for this resource.
Rank | [read/write] the rank in which the story should be viewed.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
RichDescription | [read/write] the rich description of this story.
Rights | [read/write] the access rights assigned to this filter
Risk | [read/write] risk used for this story
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Sponsor | [read/write] the sponsor of the story
StatusValue | [read/write] A status reflecting the statuses of its tasks
StoryID | [read] the story id.
StoryType | [read/write] story type used for this story
StoryValue | [read/write] storyValue of this story
StreamState | [read/write] streamState of this story
Tags | [read/write] the tags, if any attached to this story instance
TargetReleases | [read/write] the target releases that this story may be mapped to
Team | [read/write] The team for this story.
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

Story.WebCacheStory Class | StarTeam Namespace


AcceptanceCriteria Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.AcceptanceCriteria Property

[read/write] the text in the "AcceptanceCriteria" for this story.

public virtual String AcceptanceCriteria {get; set;}

Property Value

the text in the "AcceptanceCriteria" for this story.

See Also

Story.WebCacheStory Class | StarTeam Namespace


After Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.After Property

[write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem After {set;}

Property Value

place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Story.WebCacheStory Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Story.WebCacheStory Class | StarTeam Namespace


Before Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Before Property

[write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem Before {set;}

Property Value

place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Story.WebCacheStory Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Story.WebCacheStory Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Story.WebCacheStory Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Story.WebCacheStory Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Story.WebCacheStory Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Story.WebCacheStory Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Story.WebCacheStory Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Story.WebCacheStory Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Description Property

[read/write] the description of this story.

public virtual String Description {get; set;}

Property Value

the description of this story.

See Also

Story.WebCacheStory Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Story.WebCacheStory Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Story.WebCacheStory Class | StarTeam Namespace


EstimatedPoints Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.EstimatedPoints Property

[read/write] A estimated points indicating how long it might take for the story to be completed.

public virtual Double EstimatedPoints {get; set;}

Property Value

A estimated points indicating how long it might take for the story to be completed.

See Also

Story.WebCacheStory Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Story.WebCacheStory Class | StarTeam Namespace


ExternalTestID Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ExternalTestID Property

[read/write] the external test ID for this requirement

public virtual String ExternalTestID {get; set;}

Property Value

the external test ID for this requirement

See Also

Story.WebCacheStory Class | StarTeam Namespace


ExternalTestProjectURL Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ExternalTestProjectURL Property

[read/write] the external test Project URL for this requirement

public virtual String ExternalTestProjectURL {get; set;}

Property Value

the external test Project URL for this requirement

See Also

Story.WebCacheStory Class | StarTeam Namespace


ExternalTestURL Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ExternalTestURL Property

[read/write] the external test URL for this requirement

public virtual String ExternalTestURL {get; set;}

Property Value

the external test URL for this requirement

See Also

Story.WebCacheStory Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Story.WebCacheStory Class | StarTeam Namespace


General Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.General Property

[read/write] the text in the "General" for this story.

public virtual String General {get; set;}

Property Value

the text in the "General" for this story.

See Also

Story.WebCacheStory Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Story.WebCacheStory Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Story.WebCacheStory Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Story.WebCacheStory Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Story.WebCacheStory Class | StarTeam Namespace


IncomingStreams Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IncomingStreams Property

[read/write] the Incoming Streams, if any attached to this story instance

public virtual EnumeratedValue[] IncomingStreams {get; set;}

Property Value

the Incoming Streams, if any attached to this story instance

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsCarriedOver Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsCarriedOver Property

[read] true if this story has been carried over

public virtual Boolean IsCarriedOver {get;}

Property Value

true if this story has been carried over

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsLeaf Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsLeaf Property

[read] true if this tree item is a leaf

new public virtual Boolean IsLeaf {get;}

Property Value

true if this tree item is a leaf

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Story.WebCacheStory Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Story.WebCacheStory Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Story.WebCacheStory Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Story.WebCacheStory Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Story.WebCacheStory Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Story.WebCacheStory Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Story.WebCacheStory Class | StarTeam Namespace


MoSCoWValue Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.MoSCoWValue Property

[read/write] the MoSCoW of the story

public virtual TreeItem.MoSCoW MoSCoWValue {get; set;}

Property Value

the MoSCoW of the story

See Also

Story.WebCacheStory Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Story.WebCacheStory Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Name Property

new public virtual String Name {get; set;}

See Also

Story.WebCacheStory Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Story.WebCacheStory Class | StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Notes Property

[read/write] the text in the "Notes" for this story.

public virtual String Notes {get; set;}

Property Value

the text in the "Notes" for this story.

See Also

Story.WebCacheStory Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Story.WebCacheStory Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Story.WebCacheStory Class | StarTeam Namespace


Order Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Order Property

[read/write] the order in which the story should be executed.

public virtual Double Order {get; set;}

Property Value

the order in which the story should be executed.

See Also

Story.WebCacheStory Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Parent Property

[read] the TreeItem which is the Parent of this instance, or NULL if this is a root

new public virtual TreeItem.WebCacheTreeItem Parent {get;}

Property Value

the TreeItem which is the Parent of this instance, or NULL if this is a root

See Also

Story.WebCacheStory Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Story.WebCacheStory Class | StarTeam Namespace


ParentPlan Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ParentPlan Property

[read] The plan being set as parent of this or null

public virtual Plan.WebCachePlan ParentPlan {get;}

Property Value

The plan being set as parent of this or null

See Also

Story.WebCacheStory Class | StarTeam Namespace


ParentSprint Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ParentSprint Property

[read] The sprint being set as parent of this or null

public virtual Sprint.WebCacheSprint ParentSprint {get;}

Property Value

The sprint being set as parent of this or null

See Also

Story.WebCacheStory Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Story.WebCacheStory Class | StarTeam Namespace


Rank Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Rank Property

[read/write] the rank in which the story should be viewed.

public virtual Double Rank {get; set;}

Property Value

the rank in which the story should be viewed.

See Also

Story.WebCacheStory Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Story.WebCacheStory Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Story.WebCacheStory Class | StarTeam Namespace


RichDescription Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.RichDescription Property

[read/write] the rich description of this story.

public virtual Content.WebCacheContent RichDescription {get; set;}

Property Value

the rich description of this story.

See Also

Story.WebCacheStory Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Story.WebCacheStory Class | StarTeam Namespace


Risk Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Risk Property

[read/write] risk used for this story

public virtual Story.Risk Risk {get; set;}

Property Value

risk used for this story

See Also

Story.WebCacheStory Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Story.WebCacheStory Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Story.WebCacheStory Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Story.WebCacheStory Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Story.WebCacheStory Class | StarTeam Namespace


Sponsor Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Sponsor Property

[read/write] the sponsor of the story

public virtual User.WebCacheUser Sponsor {get; set;}

Property Value

the sponsor of the story

See Also

Story.WebCacheStory Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.StatusValue Property

[read/write] A status reflecting the statuses of its tasks

public virtual Story.Status StatusValue {get; set;}

Property Value

A status reflecting the statuses of its tasks

See Also

Story.WebCacheStory Class | StarTeam Namespace


StoryID Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.StoryID Property

[read] the story id.

public virtual Int32 StoryID {get;}

Property Value

the story id.

See Also

Story.WebCacheStory Class | StarTeam Namespace


StoryType Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.StoryType Property

[read/write] story type used for this story

public virtual Story.StoryType StoryType {get; set;}

Property Value

story type used for this story

See Also

Story.WebCacheStory Class | StarTeam Namespace


StoryValue Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.StoryValue Property

[read/write] storyValue of this story

public virtual Story.StoryValue StoryValue {get; set;}

Property Value

storyValue of this story

See Also

Story.WebCacheStory Class | StarTeam Namespace


StreamState Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.StreamState Property

[read/write] streamState of this story

public virtual Story.StreamState StreamState {get; set;}

Property Value

streamState of this story

See Also

Story.WebCacheStory Class | StarTeam Namespace


Tags Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Tags Property

[read/write] the tags, if any attached to this story instance

public virtual EnumeratedValue[] Tags {get; set;}

Property Value

the tags, if any attached to this story instance

See Also

Story.WebCacheStory Class | StarTeam Namespace


TargetReleases Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.TargetReleases Property

[read/write] the target releases that this story may be mapped to

public virtual WebCacheView[] TargetReleases {get; set;}

Property Value

the target releases that this story may be mapped to

See Also

Story.WebCacheStory Class | StarTeam Namespace


Team Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Team Property

[read/write] The team for this story.

public virtual String Team {get; set;}

Property Value

The team for this story.

See Also

Story.WebCacheStory Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Story.WebCacheStory Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Story.WebCacheStory Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Story.WebCacheStory Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Story.WebCacheStory Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Story.WebCacheStory Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Story.WebCacheStory.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory Methods

The methods of the Story.WebCacheStory class are listed below. For a complete list of Story.WebCacheStory class members, see the Story.WebCacheStory Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Story.WebCacheStory.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Story.WebCacheStory.
GetTasks |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Story.WebCacheStory.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Story.WebCacheStory.Create Method

Overload List

public static WebCacheStory Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,TreeItem.Type.WebCacheTreeItemType);

public static WebCacheStory Create(ArtifactCacheManager.Context,Story.WebCacheStory);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,TreeItem.WebCacheTreeItem);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheStory Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.Create Overload List


Story.WebCacheStory.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.Create Overload List


Story.WebCacheStory.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, TreeItem#Type#WebCacheTreeItemType)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
TreeItem.Type.WebCacheTreeItemType typ
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.Create Overload List


Story.WebCacheStory.Create Method (ArtifactCacheManager#Context, Story#WebCacheStory)

public static WebCacheStory Create(
ArtifactCacheManager.Context cntxt,
Story.WebCacheStory parent
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.Create Overload List


Story.WebCacheStory.Create Method (ArtifactCacheManager#Context, TreeItem#WebCacheTreeItem)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
TreeItem.WebCacheTreeItem parent
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.Create Overload List


Story.WebCacheStory.Equals Method

Delegate Equals() to com.starteam.Story.WebCacheStory.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Story.WebCacheStory.Equals(obj).

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.GetChildren Method

new public virtual WebCacheTreeItem[] GetChildren(
Filter.WebCacheFilter fltr
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.GetHashCode Method

Delegate GetHashCode() to com.starteam.Story.WebCacheStory.

public override int GetHashCode();

Return Value

com.starteam.Story.WebCacheStory.GetHashCode().

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.GetTasks Method

public virtual WebCacheTask[] GetTasks(
Filter.WebCacheFilter fltr
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Story.WebCacheStory.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.GetValue Overload List


Story.WebCacheStory.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.GetValue Overload List


Story.WebCacheStory.HasChildren Method

Returns true if the TreeItem has at least one child.

new public virtual bool HasChildren();

Return Value

True if at least one child exists, false if no children

See Also

Story.WebCacheStory Class | StarTeam Namespace | isDisembodied


Story.WebCacheStory.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Story.WebCacheStory.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Story.WebCacheStory Class | StarTeam Namespace | WebCacheViewMemberCollection


Story.WebCacheStory.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.Lock Overload List | WebCacheViewMemberCollection


Story.WebCacheStory.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.Lock Overload List


Story.WebCacheStory.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Story.WebCacheStory Class | StarTeam Namespace | NAME


Story.WebCacheStory.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Story.WebCacheStory Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Story.WebCacheStory.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(TreeItem.WebCacheTreeItem);

new public virtual void MoveTo(View.WebCacheView);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.MoveTo Overload List


Story.WebCacheStory.MoveTo Method (TreeItem#WebCacheTreeItem)

new public virtual void MoveTo(
TreeItem.WebCacheTreeItem parent
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.MoveTo Overload List


Story.WebCacheStory.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.MoveTo Overload List


Story.WebCacheStory.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Story.WebCacheStory Class | StarTeam Namespace | isFloating | isPinned | unpin


Story.WebCacheStory.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Story.WebCacheStory Class | StarTeam Namespace | WebCacheViewMemberCollection


Story.WebCacheStory.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.SetBetween Method

new public virtual void SetBetween(
TreeItem.WebCacheTreeItem prev,
TreeItem.WebCacheTreeItem next
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.SetFirst Method

place this tree item at the head of the set of all children of its parent treeitem or folder

new public virtual void SetFirst();

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.SetLast Method

place this tree item at the end of the set of all children of its parent treeitem or folder

new public virtual void SetLast();

See Also

Story.WebCacheStory Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Story.WebCacheStory.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.SetValue Overload List


Story.WebCacheStory.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Story.WebCacheStory Class | StarTeam Namespace | Story.WebCacheStory.SetValue Overload List


Story.WebCacheStory.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.ToString Method

Delegate ToString() to com.starteam.Story.WebCacheStory.

public override string ToString();

Return Value

com.starteam.Story.WebCacheStory.ToString()

See Also

Story.WebCacheStory Class | StarTeam Namespace


Story.WebCacheStory.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Story.WebCacheStory Class | StarTeam Namespace | WebCacheViewMemberCollection


Story.WebCacheStory.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Story.WebCacheStory Class | StarTeam Namespace | isFloating | isPinned | pinTo


Story.WebCacheStory.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Story.WebCacheStory Class | StarTeam Namespace | WebCacheViewMemberCollection


Story.WebCacheStory.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Story.WebCacheStory Class | StarTeam Namespace


SupportedFeatures Class

The SupportedFeatures class contains a number of methods that report whether or not a particular feature is available for a StarTeam server.

For a list of all members of this type, see SupportedFeatures Members.

System.Object
SupportedFeatures

public class SupportedFeatures

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

SupportedFeatures Members | StarTeam Namespace


SupportedFeatures Members

SupportedFeatures overview

Public Instance Methods

CanConvertPropertyType |
CanCreatePropertyType |
Equals | Delegate Equals() to com.starteam.SupportedFeatures.
GetHashCode | Delegate GetHashCode() to com.starteam.SupportedFeatures.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPropertyType |
SupportsReleaseFifteenOneFeatures | Determines whether the server supports the features of 15.1 Release.
SupportsReleaseFifteenZeroFeatures | Determines whether the server supports the features of 15.0 Release.
SupportsReleaseFourteenZeroFeatures | Determines whether the server supports the features of 14.0 Release The 14.0 release introduces multi-tenancy capabilities for MicroFocus hosted deployment
SupportsReleaseFourteenZeroUpdateFourFeatures | Determines whether the server supports the features of 14.0 Release Update Four The 14.0 Update 4 release introduces dynamic BIRT Reports in the client
SupportsReleaseFourteenZeroUpdateThreeFeatures | Determines whether the server supports the features of 14.0 Release Update Three The 14.0 Update 3 release introduces StarTeam Search capabilities
SupportsReleaseSeventeenOneFeatures | Determines whether the server supports the features of 17.1 Release.
SupportsReleaseSeventeenZeroFeatures | Determines whether the server supports the features of 17.0 Release.
SupportsReleaseSixteenThreeFeatures | Determines whether the server supports the features of 16.3 Release.
SupportsReleaseSixteenTwoFeatures | Determines whether the server supports the features of 16.2 Release.
SupportsReleaseSixteenZeroFeatures | Determines whether the server supports the features of 16.0 Release.
SupportsReleaseThirteenZeroFeatures | Determines whether the server supports the features of 13.0 Release The 13.0 release of the server supports Rich Text Descriptions for Tasks, enforcing Link access rights on Trace end points.
SupportsReleaseTwelveFiveFeatures | Determines whether the server supports the features of 12.5 Release The 12.5 release of the server supports project and view property fetches in bulk
ToString | Delegate ToString() to com.starteam.SupportedFeatures.

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures Methods

The methods of the SupportedFeatures class are listed below. For a complete list of SupportedFeatures class members, see the SupportedFeatures Members topic.

Public Instance Methods

CanConvertPropertyType |
CanCreatePropertyType |
Equals | Delegate Equals() to com.starteam.SupportedFeatures.
GetHashCode | Delegate GetHashCode() to com.starteam.SupportedFeatures.
GetType (inherited from Object) | Gets the Type of the current instance.
HasPropertyType |
SupportsReleaseFifteenOneFeatures | Determines whether the server supports the features of 15.1 Release.
SupportsReleaseFifteenZeroFeatures | Determines whether the server supports the features of 15.0 Release.
SupportsReleaseFourteenZeroFeatures | Determines whether the server supports the features of 14.0 Release The 14.0 release introduces multi-tenancy capabilities for MicroFocus hosted deployment
SupportsReleaseFourteenZeroUpdateFourFeatures | Determines whether the server supports the features of 14.0 Release Update Four The 14.0 Update 4 release introduces dynamic BIRT Reports in the client
SupportsReleaseFourteenZeroUpdateThreeFeatures | Determines whether the server supports the features of 14.0 Release Update Three The 14.0 Update 3 release introduces StarTeam Search capabilities
SupportsReleaseSeventeenOneFeatures | Determines whether the server supports the features of 17.1 Release.
SupportsReleaseSeventeenZeroFeatures | Determines whether the server supports the features of 17.0 Release.
SupportsReleaseSixteenThreeFeatures | Determines whether the server supports the features of 16.3 Release.
SupportsReleaseSixteenTwoFeatures | Determines whether the server supports the features of 16.2 Release.
SupportsReleaseSixteenZeroFeatures | Determines whether the server supports the features of 16.0 Release.
SupportsReleaseThirteenZeroFeatures | Determines whether the server supports the features of 13.0 Release The 13.0 release of the server supports Rich Text Descriptions for Tasks, enforcing Link access rights on Trace end points.
SupportsReleaseTwelveFiveFeatures | Determines whether the server supports the features of 12.5 Release The 12.5 release of the server supports project and view property fetches in bulk
ToString | Delegate ToString() to com.starteam.SupportedFeatures.

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.CanConvertPropertyType Method

public virtual bool CanConvertPropertyType(
Type fromType,
Type toType
);

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.CanCreatePropertyType Method

public virtual bool CanCreatePropertyType(
Type propertyType
);

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.Equals Method

Delegate Equals() to com.starteam.SupportedFeatures.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.SupportedFeatures.Equals(obj).

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.GetHashCode Method

Delegate GetHashCode() to com.starteam.SupportedFeatures.

public override int GetHashCode();

Return Value

com.starteam.SupportedFeatures.GetHashCode().

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.HasPropertyType Method

public virtual bool HasPropertyType(
Type propertyType
);

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseFifteenOneFeatures Method

Determines whether the server supports the features of 15.1 Release.

public virtual bool SupportsReleaseFifteenOneFeatures();

Return Value

true if server supports the 15.1 release.

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseFifteenZeroFeatures Method

Determines whether the server supports the features of 15.0 Release.

public virtual bool SupportsReleaseFifteenZeroFeatures();

Return Value

true if server supports the 15.0 release.

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseFourteenZeroFeatures Method

Determines whether the server supports the features of 14.0 Release The 14.0 release introduces multi-tenancy capabilities for MicroFocus hosted deployment

public virtual bool SupportsReleaseFourteenZeroFeatures();

Return Value

true if server supports the 14.0 release

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseFourteenZeroUpdateFourFeatures Method

Determines whether the server supports the features of 14.0 Release Update Four The 14.0 Update 4 release introduces dynamic BIRT Reports in the client

public virtual bool SupportsReleaseFourteenZeroUpdateFourFeatures();

Return Value

true if server supports the 14.0U4 release

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseFourteenZeroUpdateThreeFeatures Method

Determines whether the server supports the features of 14.0 Release Update Three The 14.0 Update 3 release introduces StarTeam Search capabilities

public virtual bool SupportsReleaseFourteenZeroUpdateThreeFeatures();

Return Value

true if server supports the 14.0U3 release

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseSeventeenOneFeatures Method

Determines whether the server supports the features of 17.1 Release.

public virtual bool SupportsReleaseSeventeenOneFeatures();

Return Value

true if server supports the 17.1 release.

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseSeventeenZeroFeatures Method

Determines whether the server supports the features of 17.0 Release.

public virtual bool SupportsReleaseSeventeenZeroFeatures();

Return Value

true if server supports the 17.0 release.

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseSixteenThreeFeatures Method

Determines whether the server supports the features of 16.3 Release.

public virtual bool SupportsReleaseSixteenThreeFeatures();

Return Value

true if server supports the 16.3 release.

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseSixteenTwoFeatures Method

Determines whether the server supports the features of 16.2 Release.

public virtual bool SupportsReleaseSixteenTwoFeatures();

Return Value

true if server supports the 16.2 release.

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseSixteenZeroFeatures Method

Determines whether the server supports the features of 16.0 Release.

public virtual bool SupportsReleaseSixteenZeroFeatures();

Return Value

true if server supports the 16.0 release.

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseThirteenZeroFeatures Method

Determines whether the server supports the features of 13.0 Release The 13.0 release of the server supports Rich Text Descriptions for Tasks, enforcing Link access rights on Trace end points.

public virtual bool SupportsReleaseThirteenZeroFeatures();

Return Value

true if server supports the 13.0 release

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.SupportsReleaseTwelveFiveFeatures Method

Determines whether the server supports the features of 12.5 Release The 12.5 release of the server supports project and view property fetches in bulk

public virtual bool SupportsReleaseTwelveFiveFeatures();

Return Value

true if server supports the 12.5 release

See Also

SupportedFeatures Class | StarTeam Namespace


SupportedFeatures.ToString Method

Delegate ToString() to com.starteam.SupportedFeatures.

public override string ToString();

Return Value

com.starteam.SupportedFeatures.ToString()

See Also

SupportedFeatures Class | StarTeam Namespace


Swimlane Class

A Swimlane is a path in Kanban.

For a list of all members of this type, see Swimlane Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Swimlane

public class Swimlane : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Swimlane Members | StarTeam Namespace


Swimlane Members

Swimlane overview

Public Static Methods

Create Create a Swimlane in the specified parent folder.

Public Instance Properties

AgeLimit | [read/write] The age limit.
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Color | [read/write] the Color of this Swimlane.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this swimlane.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
Enabled | [read/write] A value indicating whether or not this this board is in a team room
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Swimlane.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
ScheduleStatus | [read/write] the schedule status.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WorkInProgress | [read/write] the work in progress.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Swimlane Class | StarTeam Namespace


Swimlane Properties

The properties of the Swimlane class are listed below. For a complete list of Swimlane class members, see the Swimlane Members topic.

Public Instance Properties

AgeLimit | [read/write] The age limit.
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Color | [read/write] the Color of this Swimlane.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this swimlane.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
Enabled | [read/write] A value indicating whether or not this this board is in a team room
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Swimlane.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
ScheduleStatus | [read/write] the schedule status.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WorkInProgress | [read/write] the work in progress.

See Also

Swimlane Class | StarTeam Namespace


AgeLimit Property

Borland StarTeam SDK for .NET

Swimlane.AgeLimit Property

[read/write] The age limit.

public virtual TimeSpan AgeLimit {get; set;}

Property Value

The age limit.

See Also

Swimlane Class | StarTeam Namespace


Color Property

Borland StarTeam SDK for .NET

Swimlane.Color Property

[read/write] the Color of this Swimlane.

public virtual String Color {get; set;}

Property Value

the Color of this Swimlane.

See Also

Swimlane Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Swimlane.Description Property

[read/write] the description of this swimlane.

public virtual String Description {get; set;}

Property Value

the description of this swimlane.

See Also

Swimlane Class | StarTeam Namespace


Enabled Property

Borland StarTeam SDK for .NET

Swimlane.Enabled Property

[read/write] A value indicating whether or not this this board is in a team room

public virtual Boolean Enabled {get; set;}

Property Value

A value indicating whether or not this this board is in a team room

See Also

Swimlane Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Swimlane.Name Property

[read/write] the Name of this Swimlane.

public virtual String Name {get; set;}

Property Value

the Name of this Swimlane.

See Also

Swimlane Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Swimlane.Properties Property

[read] the PropertyCollection of its Type

public virtual Swimlane.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

Swimlane Class | StarTeam Namespace


ScheduleStatus Property

Borland StarTeam SDK for .NET

Swimlane.ScheduleStatus Property

[read/write] the schedule status.

public virtual Int32 ScheduleStatus {get; set;}

Property Value

the schedule status.

See Also

Swimlane Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Swimlane.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Swimlane Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Swimlane.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Swimlane Class | StarTeam Namespace


WorkInProgress Property

Borland StarTeam SDK for .NET

Swimlane.WorkInProgress Property

[read/write] the work in progress.

public virtual Int32 WorkInProgress {get; set;}

Property Value

the work in progress.

See Also

Swimlane Class | StarTeam Namespace


Swimlane Methods

The methods of the Swimlane class are listed below. For a complete list of Swimlane class members, see the Swimlane Members topic.

Public Static Methods

Create Create a Swimlane in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Swimlane Class | StarTeam Namespace


Swimlane.Create Method

Create a Swimlane in the specified parent folder.

public static Swimlane Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Swimlane Object.

See Also

Swimlane Class | StarTeam Namespace


Swimlane.Type Class

Type meta-data (schema) for Swimlane object instances.

For a list of all members of this type, see Swimlane.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
Swimlane.Type

new public class Swimlane.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Swimlane.Type Members | StarTeam Namespace


Swimlane.Type Members

Swimlane.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Swimlane.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Swimlane.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type Properties

The properties of the Swimlane.Type class are listed below. For a complete list of Swimlane.Type class members, see the Swimlane.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Swimlane.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Swimlane.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Swimlane.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Swimlane.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Swimlane.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Swimlane.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Swimlane.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Swimlane.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Swimlane.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Swimlane.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Swimlane.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Swimlane.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Swimlane.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Swimlane.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Swimlane.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Swimlane.Type.NAME Property

new public static String NAME {get;}

See Also

Swimlane.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Swimlane.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Swimlane.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Swimlane.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Swimlane.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Swimlane.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Swimlane.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Swimlane.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Swimlane.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type Methods

The methods of the Swimlane.Type class are listed below. For a complete list of Swimlane.Type class members, see the Swimlane.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Swimlane.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Swimlane.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type.Equals Method

Delegate Equals() to com.starteam.Swimlane.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Swimlane.Type.Equals(obj).

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Swimlane.Type.

public override int GetHashCode();

Return Value

com.starteam.Swimlane.Type.GetHashCode().

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type.ToString Method

Delegate ToString() to com.starteam.Swimlane.Type.

public override string ToString();

Return Value

com.starteam.Swimlane.Type.ToString()

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Swimlane.Type Class | StarTeam Namespace


Swimlane.Type.AgeLimitProperty Class

The property type of the AgeLimit property.

For a list of all members of this type, see Swimlane.Type.AgeLimitProperty Members.

System.Object
Property
ScalarProperty
TimeSpanProperty
Swimlane.Type.AgeLimitProperty

public class Swimlane.Type.AgeLimitProperty : TimeSpanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Swimlane.Type.AgeLimitProperty Members | StarTeam Namespace


Swimlane.Type.AgeLimitProperty Members

Swimlane.Type.AgeLimitProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Swimlane.Type.AgeLimitProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.AgeLimitProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Swimlane.Type.AgeLimitProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.AgeLimitProperty Class | StarTeam Namespace


Swimlane.Type.AgeLimitProperty Properties

The properties of the Swimlane.Type.AgeLimitProperty class are listed below. For a complete list of Swimlane.Type.AgeLimitProperty class members, see the Swimlane.Type.AgeLimitProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

See Also

Swimlane.Type.AgeLimitProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Swimlane.Type.AgeLimitProperty.NAME Property

public static String NAME {get;}

See Also

Swimlane.Type.AgeLimitProperty Class | StarTeam Namespace


Swimlane.Type.AgeLimitProperty Methods

The methods of the Swimlane.Type.AgeLimitProperty class are listed below. For a complete list of Swimlane.Type.AgeLimitProperty class members, see the Swimlane.Type.AgeLimitProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Swimlane.Type.AgeLimitProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.AgeLimitProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Swimlane.Type.AgeLimitProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.AgeLimitProperty Class | StarTeam Namespace


Swimlane.Type.AgeLimitProperty.Equals Method

Delegate Equals() to com.starteam.Swimlane.Type.AgeLimitProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Swimlane.Type.AgeLimitProperty.Equals(obj).

See Also

Swimlane.Type.AgeLimitProperty Class | StarTeam Namespace


Swimlane.Type.AgeLimitProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Swimlane.Type.AgeLimitProperty.

public override int GetHashCode();

Return Value

com.starteam.Swimlane.Type.AgeLimitProperty.GetHashCode().

See Also

Swimlane.Type.AgeLimitProperty Class | StarTeam Namespace


Swimlane.Type.AgeLimitProperty.ToString Method

Delegate ToString() to com.starteam.Swimlane.Type.AgeLimitProperty.

public override string ToString();

Return Value

com.starteam.Swimlane.Type.AgeLimitProperty.ToString()

See Also

Swimlane.Type.AgeLimitProperty Class | StarTeam Namespace


Swimlane.Type.ColorProperty Class

The property type of the Color property

For a list of all members of this type, see Swimlane.Type.ColorProperty Members.

System.Object
Property
VectorProperty
TextProperty
Swimlane.Type.ColorProperty

public class Swimlane.Type.ColorProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Swimlane.Type.ColorProperty Members | StarTeam Namespace


Swimlane.Type.ColorProperty Members

Swimlane.Type.ColorProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Swimlane.Type.ColorProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.ColorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Swimlane.Type.ColorProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.ColorProperty Class | StarTeam Namespace


Swimlane.Type.ColorProperty Properties

The properties of the Swimlane.Type.ColorProperty class are listed below. For a complete list of Swimlane.Type.ColorProperty class members, see the Swimlane.Type.ColorProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Swimlane.Type.ColorProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Swimlane.Type.ColorProperty.NAME Property

public static String NAME {get;}

See Also

Swimlane.Type.ColorProperty Class | StarTeam Namespace


Swimlane.Type.ColorProperty Methods

The methods of the Swimlane.Type.ColorProperty class are listed below. For a complete list of Swimlane.Type.ColorProperty class members, see the Swimlane.Type.ColorProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Swimlane.Type.ColorProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.ColorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Swimlane.Type.ColorProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.ColorProperty Class | StarTeam Namespace


Swimlane.Type.ColorProperty.Equals Method

Delegate Equals() to com.starteam.Swimlane.Type.ColorProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Swimlane.Type.ColorProperty.Equals(obj).

See Also

Swimlane.Type.ColorProperty Class | StarTeam Namespace


Swimlane.Type.ColorProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Swimlane.Type.ColorProperty.

public override int GetHashCode();

Return Value

com.starteam.Swimlane.Type.ColorProperty.GetHashCode().

See Also

Swimlane.Type.ColorProperty Class | StarTeam Namespace


Swimlane.Type.ColorProperty.ToString Method

Delegate ToString() to com.starteam.Swimlane.Type.ColorProperty.

public override string ToString();

Return Value

com.starteam.Swimlane.Type.ColorProperty.ToString()

See Also

Swimlane.Type.ColorProperty Class | StarTeam Namespace


Swimlane.Type.EnabledProperty Class

The property type of the EnforceAge property.

For a list of all members of this type, see Swimlane.Type.EnabledProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Swimlane.Type.EnabledProperty

public class Swimlane.Type.EnabledProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Swimlane.Type.EnabledProperty Members | StarTeam Namespace


Swimlane.Type.EnabledProperty Members

Swimlane.Type.EnabledProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Swimlane.Type.EnabledProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.EnabledProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Swimlane.Type.EnabledProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.EnabledProperty Class | StarTeam Namespace


Swimlane.Type.EnabledProperty Properties

The properties of the Swimlane.Type.EnabledProperty class are listed below. For a complete list of Swimlane.Type.EnabledProperty class members, see the Swimlane.Type.EnabledProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Swimlane.Type.EnabledProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Swimlane.Type.EnabledProperty.NAME Property

public static String NAME {get;}

See Also

Swimlane.Type.EnabledProperty Class | StarTeam Namespace


Swimlane.Type.EnabledProperty Methods

The methods of the Swimlane.Type.EnabledProperty class are listed below. For a complete list of Swimlane.Type.EnabledProperty class members, see the Swimlane.Type.EnabledProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Swimlane.Type.EnabledProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.EnabledProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Swimlane.Type.EnabledProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.EnabledProperty Class | StarTeam Namespace


Swimlane.Type.EnabledProperty.Equals Method

Delegate Equals() to com.starteam.Swimlane.Type.EnabledProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Swimlane.Type.EnabledProperty.Equals(obj).

See Also

Swimlane.Type.EnabledProperty Class | StarTeam Namespace


Swimlane.Type.EnabledProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Swimlane.Type.EnabledProperty.

public override int GetHashCode();

Return Value

com.starteam.Swimlane.Type.EnabledProperty.GetHashCode().

See Also

Swimlane.Type.EnabledProperty Class | StarTeam Namespace


Swimlane.Type.EnabledProperty.ToString Method

Delegate ToString() to com.starteam.Swimlane.Type.EnabledProperty.

public override string ToString();

Return Value

com.starteam.Swimlane.Type.EnabledProperty.ToString()

See Also

Swimlane.Type.EnabledProperty Class | StarTeam Namespace


Swimlane.Type.PropertyCollection Class

The PropertyCollection of a Swimlane

For a list of all members of this type, see Swimlane.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Swimlane.Type.PropertyCollection

new public class Swimlane.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Swimlane.Type.PropertyCollection Members | StarTeam Namespace


Swimlane.Type.PropertyCollection Members

Swimlane.Type.PropertyCollection overview

Public Instance Properties

AGE_LIMIT |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COLOR |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
ENABLED |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SCHEDULE_STATUS |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WORK_IN_PROGRESS |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Swimlane.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Swimlane.Type.PropertyCollection.

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


Swimlane.Type.PropertyCollection Properties

The properties of the Swimlane.Type.PropertyCollection class are listed below. For a complete list of Swimlane.Type.PropertyCollection class members, see the Swimlane.Type.PropertyCollection Members topic.

Public Instance Properties

AGE_LIMIT |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COLOR |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
ENABLED |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SCHEDULE_STATUS |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WORK_IN_PROGRESS |

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


AGE_LIMIT Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.AGE_LIMIT Property

public Swimlane.Type.AgeLimitProperty AGE_LIMIT {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


COLOR Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.COLOR Property

public Swimlane.Type.ColorProperty COLOR {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


ENABLED Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.ENABLED Property

public Swimlane.Type.EnabledProperty ENABLED {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


SCHEDULE_STATUS Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.SCHEDULE_STATUS Property

public Swimlane.Type.ScheduleStatusProperty SCHEDULE_STATUS {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.VERSION_METADATA Property

public Item.Type.VersionMetadataProperty VERSION_METADATA {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA_IDS Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.VERSION_METADATA_IDS Property

public Item.Type.VersionMetadataIDsProperty VERSION_METADATA_IDS {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


WORK_IN_PROGRESS Property

Borland StarTeam SDK for .NET

Swimlane.Type.PropertyCollection.WORK_IN_PROGRESS Property

public Swimlane.Type.WorkInProgressProperty WORK_IN_PROGRESS {get;}

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


Swimlane.Type.PropertyCollection Methods

The methods of the Swimlane.Type.PropertyCollection class are listed below. For a complete list of Swimlane.Type.PropertyCollection class members, see the Swimlane.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Swimlane.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Swimlane.Type.PropertyCollection.

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


Swimlane.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Swimlane.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Swimlane.Type.PropertyCollection.Equals(obj).

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


Swimlane.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Swimlane.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Swimlane.Type.PropertyCollection.GetHashCode().

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


Swimlane.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Swimlane.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Swimlane.Type.PropertyCollection.ToString()

See Also

Swimlane.Type.PropertyCollection Class | StarTeam Namespace


Swimlane.Type.ScheduleStatusProperty Class

The property type of the ScheduleStatus property

For a list of all members of this type, see Swimlane.Type.ScheduleStatusProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Swimlane.Type.ScheduleStatusProperty

public class Swimlane.Type.ScheduleStatusProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Swimlane.Type.ScheduleStatusProperty Members | StarTeam Namespace


Swimlane.Type.ScheduleStatusProperty Members

Swimlane.Type.ScheduleStatusProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Swimlane.Type.ScheduleStatusProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.ScheduleStatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Swimlane.Type.ScheduleStatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.ScheduleStatusProperty Class | StarTeam Namespace


Swimlane.Type.ScheduleStatusProperty Properties

The properties of the Swimlane.Type.ScheduleStatusProperty class are listed below. For a complete list of Swimlane.Type.ScheduleStatusProperty class members, see the Swimlane.Type.ScheduleStatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Swimlane.Type.ScheduleStatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Swimlane.Type.ScheduleStatusProperty.NAME Property

public static String NAME {get;}

See Also

Swimlane.Type.ScheduleStatusProperty Class | StarTeam Namespace


Swimlane.Type.ScheduleStatusProperty Methods

The methods of the Swimlane.Type.ScheduleStatusProperty class are listed below. For a complete list of Swimlane.Type.ScheduleStatusProperty class members, see the Swimlane.Type.ScheduleStatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Swimlane.Type.ScheduleStatusProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.ScheduleStatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Swimlane.Type.ScheduleStatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.ScheduleStatusProperty Class | StarTeam Namespace


Swimlane.Type.ScheduleStatusProperty.Equals Method

Delegate Equals() to com.starteam.Swimlane.Type.ScheduleStatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Swimlane.Type.ScheduleStatusProperty.Equals(obj).

See Also

Swimlane.Type.ScheduleStatusProperty Class | StarTeam Namespace


Swimlane.Type.ScheduleStatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Swimlane.Type.ScheduleStatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Swimlane.Type.ScheduleStatusProperty.GetHashCode().

See Also

Swimlane.Type.ScheduleStatusProperty Class | StarTeam Namespace


Swimlane.Type.ScheduleStatusProperty.ToString Method

Delegate ToString() to com.starteam.Swimlane.Type.ScheduleStatusProperty.

public override string ToString();

Return Value

com.starteam.Swimlane.Type.ScheduleStatusProperty.ToString()

See Also

Swimlane.Type.ScheduleStatusProperty Class | StarTeam Namespace


Swimlane.Type.WorkInProgressProperty Class

The property type of the WorkInProgress property

For a list of all members of this type, see Swimlane.Type.WorkInProgressProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Swimlane.Type.WorkInProgressProperty

public class Swimlane.Type.WorkInProgressProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Swimlane.Type.WorkInProgressProperty Members | StarTeam Namespace


Swimlane.Type.WorkInProgressProperty Members

Swimlane.Type.WorkInProgressProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Swimlane.Type.WorkInProgressProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.WorkInProgressProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Swimlane.Type.WorkInProgressProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.WorkInProgressProperty Class | StarTeam Namespace


Swimlane.Type.WorkInProgressProperty Properties

The properties of the Swimlane.Type.WorkInProgressProperty class are listed below. For a complete list of Swimlane.Type.WorkInProgressProperty class members, see the Swimlane.Type.WorkInProgressProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Swimlane.Type.WorkInProgressProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Swimlane.Type.WorkInProgressProperty.NAME Property

public static String NAME {get;}

See Also

Swimlane.Type.WorkInProgressProperty Class | StarTeam Namespace


Swimlane.Type.WorkInProgressProperty Methods

The methods of the Swimlane.Type.WorkInProgressProperty class are listed below. For a complete list of Swimlane.Type.WorkInProgressProperty class members, see the Swimlane.Type.WorkInProgressProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Swimlane.Type.WorkInProgressProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.Type.WorkInProgressProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Swimlane.Type.WorkInProgressProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Swimlane.Type.WorkInProgressProperty Class | StarTeam Namespace


Swimlane.Type.WorkInProgressProperty.Equals Method

Delegate Equals() to com.starteam.Swimlane.Type.WorkInProgressProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Swimlane.Type.WorkInProgressProperty.Equals(obj).

See Also

Swimlane.Type.WorkInProgressProperty Class | StarTeam Namespace


Swimlane.Type.WorkInProgressProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Swimlane.Type.WorkInProgressProperty.

public override int GetHashCode();

Return Value

com.starteam.Swimlane.Type.WorkInProgressProperty.GetHashCode().

See Also

Swimlane.Type.WorkInProgressProperty Class | StarTeam Namespace


Swimlane.Type.WorkInProgressProperty.ToString Method

Delegate ToString() to com.starteam.Swimlane.Type.WorkInProgressProperty.

public override string ToString();

Return Value

com.starteam.Swimlane.Type.WorkInProgressProperty.ToString()

See Also

Swimlane.Type.WorkInProgressProperty Class | StarTeam Namespace


Swimlane.WebCacheSwimlane Class

Item accessor for cached SDK Swimlane items contained objects are obtained from the artifact cache

For a list of all members of this type, see Swimlane.WebCacheSwimlane Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
Swimlane.WebCacheSwimlane

public class Swimlane.WebCacheSwimlane : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Swimlane.WebCacheSwimlane Members | StarTeam Namespace


Swimlane.WebCacheSwimlane Members

Swimlane.WebCacheSwimlane overview

Public Static Methods

Create Overloaded.

Public Instance Properties

AgeLimit | [read/write] the age limit of this swim lane.
Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Color | [read/write] the Color of this Swimlane.
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this swimlane.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
Enabled | [read/write] A value indicating whether or not this this board is in a team room
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
ScheduleStatus | [read/write] the schedule status.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WorkInProgress | [read/write] the work in progress.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Swimlane.WebCacheSwimlane.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.WebCacheSwimlane.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Swimlane.WebCacheSwimlane.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane Properties

The properties of the Swimlane.WebCacheSwimlane class are listed below. For a complete list of Swimlane.WebCacheSwimlane class members, see the Swimlane.WebCacheSwimlane Members topic.

Public Instance Properties

AgeLimit | [read/write] the age limit of this swim lane.
Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Color | [read/write] the Color of this Swimlane.
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this swimlane.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
Enabled | [read/write] A value indicating whether or not this this board is in a team room
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
ScheduleStatus | [read/write] the schedule status.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WorkInProgress | [read/write] the work in progress.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


AgeLimit Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.AgeLimit Property

[read/write] the age limit of this swim lane.

public virtual TimeSpan AgeLimit {get; set;}

Property Value

the age limit of this swim lane.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Color Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Color Property

[read/write] the Color of this Swimlane.

public virtual String Color {get; set;}

Property Value

the Color of this Swimlane.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Description Property

[read/write] the description of this swimlane.

public virtual String Description {get; set;}

Property Value

the description of this swimlane.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Enabled Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Enabled Property

[read/write] A value indicating whether or not this this board is in a team room

public virtual Boolean Enabled {get; set;}

Property Value

A value indicating whether or not this this board is in a team room

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Name Property

new public virtual String Name {get; set;}

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ScheduleStatus Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ScheduleStatus Property

[read/write] the schedule status.

public virtual Int32 ScheduleStatus {get; set;}

Property Value

the schedule status.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


WorkInProgress Property

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.WorkInProgress Property

[read/write] the work in progress.

public virtual Int32 WorkInProgress {get; set;}

Property Value

the work in progress.

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane Methods

The methods of the Swimlane.WebCacheSwimlane class are listed below. For a complete list of Swimlane.WebCacheSwimlane class members, see the Swimlane.WebCacheSwimlane Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Swimlane.WebCacheSwimlane.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Swimlane.WebCacheSwimlane.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Swimlane.WebCacheSwimlane.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Create Method

Overload List

public static WebCacheSwimlane Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheSwimlane Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.Create Overload List


Swimlane.WebCacheSwimlane.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.Create Overload List


Swimlane.WebCacheSwimlane.Equals Method

Delegate Equals() to com.starteam.Swimlane.WebCacheSwimlane.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Swimlane.WebCacheSwimlane.Equals(obj).

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.GetHashCode Method

Delegate GetHashCode() to com.starteam.Swimlane.WebCacheSwimlane.

public override int GetHashCode();

Return Value

com.starteam.Swimlane.WebCacheSwimlane.GetHashCode().

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.GetValue Overload List


Swimlane.WebCacheSwimlane.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.GetValue Overload List


Swimlane.WebCacheSwimlane.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | WebCacheViewMemberCollection


Swimlane.WebCacheSwimlane.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.Lock Overload List | WebCacheViewMemberCollection


Swimlane.WebCacheSwimlane.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.Lock Overload List


Swimlane.WebCacheSwimlane.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | NAME


Swimlane.WebCacheSwimlane.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.MoveTo Overload List


Swimlane.WebCacheSwimlane.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.MoveTo Overload List


Swimlane.WebCacheSwimlane.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | isFloating | isPinned | unpin


Swimlane.WebCacheSwimlane.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | WebCacheViewMemberCollection


Swimlane.WebCacheSwimlane.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Swimlane.WebCacheSwimlane.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.SetValue Overload List


Swimlane.WebCacheSwimlane.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | Swimlane.WebCacheSwimlane.SetValue Overload List


Swimlane.WebCacheSwimlane.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.ToString Method

Delegate ToString() to com.starteam.Swimlane.WebCacheSwimlane.

public override string ToString();

Return Value

com.starteam.Swimlane.WebCacheSwimlane.ToString()

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


Swimlane.WebCacheSwimlane.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | WebCacheViewMemberCollection


Swimlane.WebCacheSwimlane.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | isFloating | isPinned | pinTo


Swimlane.WebCacheSwimlane.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace | WebCacheViewMemberCollection


Swimlane.WebCacheSwimlane.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Swimlane.WebCacheSwimlane Class | StarTeam Namespace


SystemPolicy Class

Server wide Policies applied

For a list of all members of this type, see SystemPolicy Members.

System.Object
SystemPolicy

public class SystemPolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

SystemPolicy Members | StarTeam Namespace


SystemPolicy Members

SystemPolicy overview

Public Static Properties

ALLOW_BLANK_PASSWORDS
FAILED_LOGIN_NO_LIMIT
LOCKOUT_FOREVER
PASSWORDS_NEVER_EXPIRE
SECURITYLOG_AUTOPURGE_DEFAULT
SECURITYLOG_AUTOPURGE_NEVER

Public Instance Constructors

SystemPolicy Constructor construct a SystemPolicy instance from the specified source

Public Instance Properties

FailedLoginLimit | [read/write] The number of acceptable failed login attempts.
FailedLoginLockout | [read/write] The number of minutes a user will be locked out after exceeding the failed login limit.
MinimumPasswordLength | [read/write] The minimum password length.
NotifyByEmail | [read/write] true if security administrators will be notified by email.
PasswordExpirationPeriod | [read/write] The number of days after which a password will expire.
SecurityLogAutoPurgeDays | [read/write] The number of days of information that will be saved.
SkipGroupPrivilegesCheck | [read/write] true if access validation will ignore group privileges, and false otherwise.
StrongPasswordRulesEnforced | [read/write] true if strong password rules are enforced, and false otherwise.

Public Instance Methods

Copy | returns a copy of this SystemPolicy instance
Equals | Delegate Equals() to com.starteam.SystemPolicy.
GetHashCode | Delegate GetHashCode() to com.starteam.SystemPolicy.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the paramter is a System Policy whose values are identical to those of this instance
ToString | Delegate ToString() to com.starteam.SystemPolicy.

See Also

SystemPolicy Class | StarTeam Namespace


SystemPolicy Constructor

construct a SystemPolicy instance from the specified source

public SystemPolicy(
SystemPolicy source
);

Parameters

source
SystemPolicy a SystemPolicy instance to copy from

See Also

SystemPolicy Class | StarTeam Namespace


SystemPolicy Properties

The properties of the SystemPolicy class are listed below. For a complete list of SystemPolicy class members, see the SystemPolicy Members topic.

Public Static Properties

ALLOW_BLANK_PASSWORDS
FAILED_LOGIN_NO_LIMIT
LOCKOUT_FOREVER
PASSWORDS_NEVER_EXPIRE
SECURITYLOG_AUTOPURGE_DEFAULT
SECURITYLOG_AUTOPURGE_NEVER

Public Instance Properties

FailedLoginLimit | [read/write] The number of acceptable failed login attempts.
FailedLoginLockout | [read/write] The number of minutes a user will be locked out after exceeding the failed login limit.
MinimumPasswordLength | [read/write] The minimum password length.
NotifyByEmail | [read/write] true if security administrators will be notified by email.
PasswordExpirationPeriod | [read/write] The number of days after which a password will expire.
SecurityLogAutoPurgeDays | [read/write] The number of days of information that will be saved.
SkipGroupPrivilegesCheck | [read/write] true if access validation will ignore group privileges, and false otherwise.
StrongPasswordRulesEnforced | [read/write] true if strong password rules are enforced, and false otherwise.

See Also

SystemPolicy Class | StarTeam Namespace


ALLOW_BLANK_PASSWORDS Property

Borland StarTeam SDK for .NET

SystemPolicy.ALLOW_BLANK_PASSWORDS Property

public static Int32 ALLOW_BLANK_PASSWORDS {get;}

See Also

SystemPolicy Class | StarTeam Namespace


FAILED_LOGIN_NO_LIMIT Property

Borland StarTeam SDK for .NET

SystemPolicy.FAILED_LOGIN_NO_LIMIT Property

public static Int32 FAILED_LOGIN_NO_LIMIT {get;}

See Also

SystemPolicy Class | StarTeam Namespace


FailedLoginLimit Property

Borland StarTeam SDK for .NET

SystemPolicy.FailedLoginLimit Property

[read/write] The number of acceptable failed login attempts.

public virtual Int32 FailedLoginLimit {get; set;}

Property Value

The number of acceptable failed login attempts.

See Also

SystemPolicy Class | StarTeam Namespace


FailedLoginLockout Property

Borland StarTeam SDK for .NET

SystemPolicy.FailedLoginLockout Property

[read/write] The number of minutes a user will be locked out after exceeding the failed login limit.

public virtual Int32 FailedLoginLockout {get; set;}

Property Value

The number of minutes a user will be locked out after exceeding the failed login limit.

See Also

SystemPolicy Class | StarTeam Namespace


LOCKOUT_FOREVER Property

Borland StarTeam SDK for .NET

SystemPolicy.LOCKOUT_FOREVER Property

public static Int32 LOCKOUT_FOREVER {get;}

See Also

SystemPolicy Class | StarTeam Namespace


MinimumPasswordLength Property

Borland StarTeam SDK for .NET

SystemPolicy.MinimumPasswordLength Property

[read/write] The minimum password length.

public virtual Int32 MinimumPasswordLength {get; set;}

Property Value

The minimum password length.

See Also

SystemPolicy Class | StarTeam Namespace


NotifyByEmail Property

Borland StarTeam SDK for .NET

SystemPolicy.NotifyByEmail Property

[read/write] true if security administrators will be notified by email.

public virtual Boolean NotifyByEmail {get; set;}

Property Value

true if security administrators will be notified by email.

See Also

SystemPolicy Class | StarTeam Namespace


PasswordExpirationPeriod Property

Borland StarTeam SDK for .NET

SystemPolicy.PasswordExpirationPeriod Property

[read/write] The number of days after which a password will expire.

public virtual Int32 PasswordExpirationPeriod {get; set;}

Property Value

The number of days after which a password will expire.

See Also

SystemPolicy Class | StarTeam Namespace


PASSWORDS_NEVER_EXPIRE Property

Borland StarTeam SDK for .NET

SystemPolicy.PASSWORDS_NEVER_EXPIRE Property

public static Int32 PASSWORDS_NEVER_EXPIRE {get;}

See Also

SystemPolicy Class | StarTeam Namespace


SECURITYLOG_AUTOPURGE_DEFAULT Property

Borland StarTeam SDK for .NET

SystemPolicy.SECURITYLOG_AUTOPURGE_DEFAULT Property

public static Int32 SECURITYLOG_AUTOPURGE_DEFAULT {get;}

See Also

SystemPolicy Class | StarTeam Namespace


SECURITYLOG_AUTOPURGE_NEVER Property

Borland StarTeam SDK for .NET

SystemPolicy.SECURITYLOG_AUTOPURGE_NEVER Property

public static Int32 SECURITYLOG_AUTOPURGE_NEVER {get;}

See Also

SystemPolicy Class | StarTeam Namespace


SecurityLogAutoPurgeDays Property

Borland StarTeam SDK for .NET

SystemPolicy.SecurityLogAutoPurgeDays Property

[read/write] The number of days of information that will be saved.

public virtual Int32 SecurityLogAutoPurgeDays {get; set;}

Property Value

The number of days of information that will be saved.

See Also

SystemPolicy Class | StarTeam Namespace


SkipGroupPrivilegesCheck Property

Borland StarTeam SDK for .NET

SystemPolicy.SkipGroupPrivilegesCheck Property

[read/write] true if access validation will ignore group privileges, and false otherwise.

public virtual Boolean SkipGroupPrivilegesCheck {get; set;}

Property Value

true if access validation will ignore group privileges, and false otherwise.

See Also

SystemPolicy Class | StarTeam Namespace


StrongPasswordRulesEnforced Property

Borland StarTeam SDK for .NET

SystemPolicy.StrongPasswordRulesEnforced Property

[read/write] true if strong password rules are enforced, and false otherwise.

public virtual Boolean StrongPasswordRulesEnforced {get; set;}

Property Value

true if strong password rules are enforced, and false otherwise.

See Also

SystemPolicy Class | StarTeam Namespace


SystemPolicy Methods

The methods of the SystemPolicy class are listed below. For a complete list of SystemPolicy class members, see the SystemPolicy Members topic.

Public Instance Methods

Copy | returns a copy of this SystemPolicy instance
Equals | Delegate Equals() to com.starteam.SystemPolicy.
GetHashCode | Delegate GetHashCode() to com.starteam.SystemPolicy.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if the paramter is a System Policy whose values are identical to those of this instance
ToString | Delegate ToString() to com.starteam.SystemPolicy.

See Also

SystemPolicy Class | StarTeam Namespace


SystemPolicy.Copy Method

returns a copy of this SystemPolicy instance

public virtual SystemPolicy Copy();

Return Value

SystemPolicy a copy of this SystemPolicy instance

See Also

SystemPolicy Class | StarTeam Namespace


SystemPolicy.Equals Method

Delegate Equals() to com.starteam.SystemPolicy.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.SystemPolicy.Equals(obj).

See Also

SystemPolicy Class | StarTeam Namespace


SystemPolicy.GetHashCode Method

Delegate GetHashCode() to com.starteam.SystemPolicy.

public override int GetHashCode();

Return Value

com.starteam.SystemPolicy.GetHashCode().

See Also

SystemPolicy Class | StarTeam Namespace


SystemPolicy.IsEqualTo Method

returns true if the paramter is a System Policy whose values are identical to those of this instance

public virtual bool IsEqualTo(
SystemPolicy source
);

Parameters

source
Object the other System Policy instance to be evaluated

Return Value

boolean true if the the other System Policy has values identical to those of this instance

See Also

SystemPolicy Class | StarTeam Namespace


SystemPolicy.ToString Method

Delegate ToString() to com.starteam.SystemPolicy.

public override string ToString();

Return Value

com.starteam.SystemPolicy.ToString()

See Also

SystemPolicy Class | StarTeam Namespace


SystemPolicy.WebCacheSystemPolicy Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see SystemPolicy.WebCacheSystemPolicy Members.

System.Object
SystemPolicy.WebCacheSystemPolicy

public class SystemPolicy.WebCacheSystemPolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

SystemPolicy.WebCacheSystemPolicy Members | StarTeam Namespace


SystemPolicy.WebCacheSystemPolicy Members

SystemPolicy.WebCacheSystemPolicy overview

Public Instance Properties

Context | [read] the context of this object.
FailedLoginLimit | [read] The number of acceptable failed login attempts.
FailedLoginLockout | [read] The number of minutes a user will be locked out after exceeding the failed login limit.
MinimumPasswordLength | [read] The minimum password length.
NotifyByEmail | [read] true if security administrators will be notified by email.
PasswordExpirationPeriod | [read] The number of days after which a password will expire.
SecurityLogAutoPurgeDays | [read] The number of days of information that will be saved.
SkipGroupPrivilegesCheck | [read] true if access validation will ignore group privileges, and false otherwise.
StrongPasswordRulesEnforced | [read] true if strong password rules are enforced, and false otherwise.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.SystemPolicy.WebCacheSystemPolicy.
GetHashCode | Delegate GetHashCode() to com.starteam.SystemPolicy.WebCacheSystemPolicy.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.SystemPolicy.WebCacheSystemPolicy.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


SystemPolicy.WebCacheSystemPolicy Properties

The properties of the SystemPolicy.WebCacheSystemPolicy class are listed below. For a complete list of SystemPolicy.WebCacheSystemPolicy class members, see the SystemPolicy.WebCacheSystemPolicy Members topic.

Public Instance Properties

Context | [read] the context of this object.
FailedLoginLimit | [read] The number of acceptable failed login attempts.
FailedLoginLockout | [read] The number of minutes a user will be locked out after exceeding the failed login limit.
MinimumPasswordLength | [read] The minimum password length.
NotifyByEmail | [read] true if security administrators will be notified by email.
PasswordExpirationPeriod | [read] The number of days after which a password will expire.
SecurityLogAutoPurgeDays | [read] The number of days of information that will be saved.
SkipGroupPrivilegesCheck | [read] true if access validation will ignore group privileges, and false otherwise.
StrongPasswordRulesEnforced | [read] true if strong password rules are enforced, and false otherwise.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

SystemPolicy.WebCacheSystemPolicy.Context Property

[read] the context of this object.

public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


FailedLoginLimit Property

Borland StarTeam SDK for .NET

SystemPolicy.WebCacheSystemPolicy.FailedLoginLimit Property

[read] The number of acceptable failed login attempts.

public virtual Int32 FailedLoginLimit {get;}

Property Value

The number of acceptable failed login attempts.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


FailedLoginLockout Property

Borland StarTeam SDK for .NET

SystemPolicy.WebCacheSystemPolicy.FailedLoginLockout Property

[read] The number of minutes a user will be locked out after exceeding the failed login limit.

public virtual Int32 FailedLoginLockout {get;}

Property Value

The number of minutes a user will be locked out after exceeding the failed login limit.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


MinimumPasswordLength Property

Borland StarTeam SDK for .NET

SystemPolicy.WebCacheSystemPolicy.MinimumPasswordLength Property

[read] The minimum password length.

public virtual Int32 MinimumPasswordLength {get;}

Property Value

The minimum password length.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


NotifyByEmail Property

Borland StarTeam SDK for .NET

SystemPolicy.WebCacheSystemPolicy.NotifyByEmail Property

[read] true if security administrators will be notified by email.

public virtual Boolean NotifyByEmail {get;}

Property Value

true if security administrators will be notified by email.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


PasswordExpirationPeriod Property

Borland StarTeam SDK for .NET

SystemPolicy.WebCacheSystemPolicy.PasswordExpirationPeriod Property

[read] The number of days after which a password will expire.

public virtual Int32 PasswordExpirationPeriod {get;}

Property Value

The number of days after which a password will expire.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


SecurityLogAutoPurgeDays Property

Borland StarTeam SDK for .NET

SystemPolicy.WebCacheSystemPolicy.SecurityLogAutoPurgeDays Property

[read] The number of days of information that will be saved.

public virtual Int32 SecurityLogAutoPurgeDays {get;}

Property Value

The number of days of information that will be saved.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


SkipGroupPrivilegesCheck Property

Borland StarTeam SDK for .NET

SystemPolicy.WebCacheSystemPolicy.SkipGroupPrivilegesCheck Property

[read] true if access validation will ignore group privileges, and false otherwise.

public virtual Boolean SkipGroupPrivilegesCheck {get;}

Property Value

true if access validation will ignore group privileges, and false otherwise.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


StrongPasswordRulesEnforced Property

Borland StarTeam SDK for .NET

SystemPolicy.WebCacheSystemPolicy.StrongPasswordRulesEnforced Property

[read] true if strong password rules are enforced, and false otherwise.

public virtual Boolean StrongPasswordRulesEnforced {get;}

Property Value

true if strong password rules are enforced, and false otherwise.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


SystemPolicy.WebCacheSystemPolicy Methods

The methods of the SystemPolicy.WebCacheSystemPolicy class are listed below. For a complete list of SystemPolicy.WebCacheSystemPolicy class members, see the SystemPolicy.WebCacheSystemPolicy Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.SystemPolicy.WebCacheSystemPolicy.
GetHashCode | Delegate GetHashCode() to com.starteam.SystemPolicy.WebCacheSystemPolicy.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.SystemPolicy.WebCacheSystemPolicy.

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


SystemPolicy.WebCacheSystemPolicy.Equals Method

Delegate Equals() to com.starteam.SystemPolicy.WebCacheSystemPolicy.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.SystemPolicy.WebCacheSystemPolicy.Equals(obj).

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


SystemPolicy.WebCacheSystemPolicy.GetHashCode Method

Delegate GetHashCode() to com.starteam.SystemPolicy.WebCacheSystemPolicy.

public override int GetHashCode();

Return Value

com.starteam.SystemPolicy.WebCacheSystemPolicy.GetHashCode().

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


SystemPolicy.WebCacheSystemPolicy.ToString Method

Delegate ToString() to com.starteam.SystemPolicy.WebCacheSystemPolicy.

public override string ToString();

Return Value

com.starteam.SystemPolicy.WebCacheSystemPolicy.ToString()

See Also

SystemPolicy.WebCacheSystemPolicy Class | StarTeam Namespace


Task Class

Represents a StarTeam Task item.

For a list of all members of this type, see Task Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
TreeItem
Task

public class Task : TreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task Members | StarTeam Namespace


Task Members

Task overview

Public Static Methods

Create | Create a Task in the specified parent folder.
PopulateTaskDependencies | Fetches the dependencies(predecessor/successors) that are associated with the given set of tasks in bulk using a single server command. This command is supported only on servers from 12.0 release onwards.
PopulateWorkRecords | Fetches the work records that are associated with the given set of tasks in bulk using a single server command.This command is supported only on servers from 12.0 release onwards.

Public Instance Constructors

Task Constructor Creates a new task that is a subtask of an existing task.

Public Instance Properties

ActualFinishDate | [read/write] The actual finish date of this task.
ActualStartDate | [read/write] The actual start date of this task.
ActualWorkToDate | [read] The actual number of hours spent on this task.
After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
AttentionNotes | [read/write] The text in the "Needs Attention" note for this task.
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
ConstraintDate | [read] The task's Constraint Date from MS Project.
ConstraintValue | [read] The MS Project Constraint Type of this task.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DependencyLastUpdate | [read] The date that a work record or task dependency (predecessor or successor) was last added to this task.
Description | [read/write] The description for this task.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EstimatedFinishDate | [read/write] The estimated date at which this task will be completed.
EstimatedFinishVariance | [read] The Estimated Finish Variance of this task.
EstimatedHoursVariance | [read] The Estimated Hours Variance of this task.
EstimatedStartDate | [read/write] The estimated start date of this task.
EstimatedStartVariance | [read] The Estimated Start Variance of this task.
EstimatedTotalWork | [read/write] An estimate of the number of hours that will be spent completing this task.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
GUID | [read] The MS Project GUID of this task.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsAttentionRequired | [read/write] A value that indicates whether or not this task needs attention.
IsBlocked | [read/write] A value indicating whether or not this task is blocked
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsMilestone | [read/write] A value indicating whether or not this task represents a milestone.
IsMyTask | [read] A value indicating whether the logged on user is responsible for this task.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsProcessTask | [read] true if this task is a process task; false otherwise.
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsReplicated | [read/write] true if this task is replicated in MS Project.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
LicenseTypeValue | [read/write] A value indicating the lifecycle type (e.g., Development, QA, Documentation or unknown) of this task.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MSProjectFileName | [read] The MS Project FileName of this task.
MSProjectLastUpdate | [read] The date that this task was last updated from MS Project.
MSProjectTaskType | [read] The task's type in MS Project.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] The Name of this task.
NewRevisionComment (inherited from Item) | [read] the empty string.
Notes | [read/write] The text in the "Notes" for this task.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
Number | [read] The number assigned to this task.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order | [read/write] The order in which the task should be worked on.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
OriginValue | [read/write] A value indicating the origin (e.g., StarTeam or MS Project) of this task.
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
ParentStory | [read] the Story containing this Task
PercentComplete | [read/write] A percentage indicating how much of the task has been completed.
PredecessorLinks | [read] The predecessor tasks to this this task.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The Priority of this task.
Properties | [read]
ResourceCount | [read] The number of resources assigned to this task.
ResourceNames | [read] The names of the users assigned as resources of this task.
Resources | [read] The User assigned as resources of this task.
Responsibility | [read/write] The User object who is responsible for this task.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
RichDescription | [read/write] Rich Description used for this task
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
ScheduledCalendarTime | [read/write] The TimeSpan during which at least one user is working on this task.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The Status of this task.
SuccessorLinks | [read] The successor tasks to this this task.
Team | [read/write] The team for this task.
UniqueID | [read] The MS Project UniqueID of this task.
Usage | [read/write] The task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links.
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WBSCode | [read] The MS Project WBS Code of this task.
WorkRecordCount | [read] The number of work records that have been added to this task.
WorkRecords | [read] The work records associates with this task.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddPredecessorLink | Adds a new predecessor to this task.
AddResource | Adds the specified User object as a resource for this Task.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
CreateWorkRecord | Creates a new WorkRecord for the specified Task and user.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard | This will discard all cached data associated with this task including changes made but not yet saved.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IgnoreLinkedStory | If invoked, then updating this Task status does not affect the status of a linked Story The caller is responsible for ensuring that Task and linked Story states are consistent.
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveDependency | Removed the specified task dependency from this task. The dependency must be either a successor or predecessor to this task or an exception will be thrown.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
RemoveResource | Removes the specified User object as a resource from this task.
RemoveWorkRecord | Removes the work record from this task. The work record must already be associated with this task or an exception will be thrown.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveAsCrossViewProcessItem | Returns the set of workspace Change Packages directly reachable from this task used as a cross (project/) view process item These changepackages represent workspace changes (file checkins) in their respective view(s). Returns an empty array if no cross view change packages are found
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Task Class | StarTeam Namespace


Task Constructor

Creates a new task that is a subtask of an existing task.

public Task(
Task parentTask
);

Parameters

parentTask
The parent task.

See Also

Task Class | StarTeam Namespace


Task Properties

The properties of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Properties

ActualFinishDate | [read/write] The actual finish date of this task.
ActualStartDate | [read/write] The actual start date of this task.
ActualWorkToDate | [read] The actual number of hours spent on this task.
After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
AttentionNotes | [read/write] The text in the "Needs Attention" note for this task.
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
ConstraintDate | [read] The task's Constraint Date from MS Project.
ConstraintValue | [read] The MS Project Constraint Type of this task.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DependencyLastUpdate | [read] The date that a work record or task dependency (predecessor or successor) was last added to this task.
Description | [read/write] The description for this task.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EstimatedFinishDate | [read/write] The estimated date at which this task will be completed.
EstimatedFinishVariance | [read] The Estimated Finish Variance of this task.
EstimatedHoursVariance | [read] The Estimated Hours Variance of this task.
EstimatedStartDate | [read/write] The estimated start date of this task.
EstimatedStartVariance | [read] The Estimated Start Variance of this task.
EstimatedTotalWork | [read/write] An estimate of the number of hours that will be spent completing this task.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
GUID | [read] The MS Project GUID of this task.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsAttentionRequired | [read/write] A value that indicates whether or not this task needs attention.
IsBlocked | [read/write] A value indicating whether or not this task is blocked
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsMilestone | [read/write] A value indicating whether or not this task represents a milestone.
IsMyTask | [read] A value indicating whether the logged on user is responsible for this task.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsProcessTask | [read] true if this task is a process task; false otherwise.
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsReplicated | [read/write] true if this task is replicated in MS Project.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
LicenseTypeValue | [read/write] A value indicating the lifecycle type (e.g., Development, QA, Documentation or unknown) of this task.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MSProjectFileName | [read] The MS Project FileName of this task.
MSProjectLastUpdate | [read] The date that this task was last updated from MS Project.
MSProjectTaskType | [read] The task's type in MS Project.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] The Name of this task.
NewRevisionComment (inherited from Item) | [read] the empty string.
Notes | [read/write] The text in the "Notes" for this task.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
Number | [read] The number assigned to this task.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order | [read/write] The order in which the task should be worked on.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
OriginValue | [read/write] A value indicating the origin (e.g., StarTeam or MS Project) of this task.
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
ParentStory | [read] the Story containing this Task
PercentComplete | [read/write] A percentage indicating how much of the task has been completed.
PredecessorLinks | [read] The predecessor tasks to this this task.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The Priority of this task.
Properties | [read]
ResourceCount | [read] The number of resources assigned to this task.
ResourceNames | [read] The names of the users assigned as resources of this task.
Resources | [read] The User assigned as resources of this task.
Responsibility | [read/write] The User object who is responsible for this task.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
RichDescription | [read/write] Rich Description used for this task
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
ScheduledCalendarTime | [read/write] The TimeSpan during which at least one user is working on this task.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The Status of this task.
SuccessorLinks | [read] The successor tasks to this this task.
Team | [read/write] The team for this task.
UniqueID | [read] The MS Project UniqueID of this task.
Usage | [read/write] The task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links.
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WBSCode | [read] The MS Project WBS Code of this task.
WorkRecordCount | [read] The number of work records that have been added to this task.
WorkRecords | [read] The work records associates with this task.

See Also

Task Class | StarTeam Namespace


ActualFinishDate Property

Borland StarTeam SDK for .NET

Task.ActualFinishDate Property

[read/write] The actual finish date of this task.

public virtual Date ActualFinishDate {get; set;}

Property Value

The actual finish date of this task.

See Also

Task Class | StarTeam Namespace


ActualStartDate Property

Borland StarTeam SDK for .NET

Task.ActualStartDate Property

[read/write] The actual start date of this task.

public virtual Date ActualStartDate {get; set;}

Property Value

The actual start date of this task.

See Also

Task Class | StarTeam Namespace


ActualWorkToDate Property

Borland StarTeam SDK for .NET

Task.ActualWorkToDate Property

[read] The actual number of hours spent on this task.

public virtual TimeSpan ActualWorkToDate {get;}

Property Value

The actual number of hours spent on this task.

See Also

Task Class | StarTeam Namespace


AttentionNotes Property

Borland StarTeam SDK for .NET

Task.AttentionNotes Property

[read/write] The text in the "Needs Attention" note for this task.

public virtual String AttentionNotes {get; set;}

Property Value

The text in the "Needs Attention" note for this task.

See Also

Task Class | StarTeam Namespace


ConstraintDate Property

Borland StarTeam SDK for .NET

Task.ConstraintDate Property

[read] The task's Constraint Date from MS Project.

public virtual DateTime ConstraintDate {get;}

Property Value

The task's Constraint Date from MS Project.

See Also

Task Class | StarTeam Namespace


ConstraintValue Property

Borland StarTeam SDK for .NET

Task.ConstraintValue Property

[read] The MS Project Constraint Type of this task.

public virtual Task.Constraint ConstraintValue {get;}

Property Value

The MS Project Constraint Type of this task.

See Also

Task Class | StarTeam Namespace


DependencyLastUpdate Property

Borland StarTeam SDK for .NET

Task.DependencyLastUpdate Property

[read] The date that a work record or task dependency (predecessor or successor) was last added to this task.

public virtual DateTime DependencyLastUpdate {get;}

Property Value

The date that a work record or task dependency (predecessor or successor) was last added to this task.

See Also

Task Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Task.Description Property

[read/write] The description for this task.

public virtual String Description {get; set;}

Property Value

The description for this task.

See Also

Task Class | StarTeam Namespace


EstimatedFinishDate Property

Borland StarTeam SDK for .NET

Task.EstimatedFinishDate Property

[read/write] The estimated date at which this task will be completed.

public virtual Date EstimatedFinishDate {get; set;}

Property Value

The estimated date at which this task will be completed.

See Also

Task Class | StarTeam Namespace


EstimatedFinishVariance Property

Borland StarTeam SDK for .NET

Task.EstimatedFinishVariance Property

[read] The Estimated Finish Variance of this task.

public virtual Int32 EstimatedFinishVariance {get;}

Property Value

The Estimated Finish Variance of this task.

See Also

Task Class | StarTeam Namespace


EstimatedHoursVariance Property

Borland StarTeam SDK for .NET

Task.EstimatedHoursVariance Property

[read] The Estimated Hours Variance of this task.

public virtual TimeSpan EstimatedHoursVariance {get;}

Property Value

The Estimated Hours Variance of this task.

See Also

Task Class | StarTeam Namespace


EstimatedStartDate Property

Borland StarTeam SDK for .NET

Task.EstimatedStartDate Property

[read/write] The estimated start date of this task.

public virtual Date EstimatedStartDate {get; set;}

Property Value

The estimated start date of this task.

See Also

Task Class | StarTeam Namespace


EstimatedStartVariance Property

Borland StarTeam SDK for .NET

Task.EstimatedStartVariance Property

[read] The Estimated Start Variance of this task.

public virtual Int32 EstimatedStartVariance {get;}

Property Value

The Estimated Start Variance of this task.

See Also

Task Class | StarTeam Namespace


EstimatedTotalWork Property

Borland StarTeam SDK for .NET

Task.EstimatedTotalWork Property

[read/write] An estimate of the number of hours that will be spent completing this task.

public virtual TimeSpan EstimatedTotalWork {get; set;}

Property Value

An estimate of the number of hours that will be spent completing this task.

See Also

Task Class | StarTeam Namespace


GUID Property

Borland StarTeam SDK for .NET

Task.GUID Property

[read] The MS Project GUID of this task.

public virtual GUID GUID {get;}

Property Value

The MS Project GUID of this task.

See Also

Task Class | StarTeam Namespace


IsAttentionRequired Property

Borland StarTeam SDK for .NET

Task.IsAttentionRequired Property

[read/write] A value that indicates whether or not this task needs attention.

public virtual Boolean IsAttentionRequired {get; set;}

Property Value

A value that indicates whether or not this task needs attention.

See Also

Task Class | StarTeam Namespace


IsBlocked Property

Borland StarTeam SDK for .NET

Task.IsBlocked Property

[read/write] A value indicating whether or not this task is blocked

public virtual Boolean IsBlocked {get; set;}

Property Value

A value indicating whether or not this task is blocked

See Also

Task Class | StarTeam Namespace


IsMilestone Property

Borland StarTeam SDK for .NET

Task.IsMilestone Property

[read/write] A value indicating whether or not this task represents a milestone.

public virtual Boolean IsMilestone {get; set;}

Property Value

A value indicating whether or not this task represents a milestone.

See Also

Task Class | StarTeam Namespace


IsMyTask Property

Borland StarTeam SDK for .NET

Task.IsMyTask Property

[read] A value indicating whether the logged on user is responsible for this task.

public virtual Boolean IsMyTask {get;}

Property Value

A value indicating whether the logged on user is responsible for this task.

See Also

Task Class | StarTeam Namespace


IsProcessTask Property

Borland StarTeam SDK for .NET

Task.IsProcessTask Property

[read] true if this task is a process task; false otherwise.

public virtual Boolean IsProcessTask {get;}

Property Value

true if this task is a process task; false otherwise.

See Also

Task Class | StarTeam Namespace


IsReplicated Property

Borland StarTeam SDK for .NET

Task.IsReplicated Property

[read/write] true if this task is replicated in MS Project.

public virtual Boolean IsReplicated {get; set;}

Property Value

true if this task is replicated in MS Project.

See Also

Task Class | StarTeam Namespace


LicenseTypeValue Property

Borland StarTeam SDK for .NET

Task.LicenseTypeValue Property

[read/write] A value indicating the lifecycle type (e.g., Development, QA, Documentation or unknown) of this task.

public virtual Task.LifeCycleType LicenseTypeValue {get; set;}

Property Value

A value indicating the lifecycle type (e.g., Development, QA, Documentation or unknown) of this task.

See Also

Task Class | StarTeam Namespace


MSProjectFileName Property

Borland StarTeam SDK for .NET

Task.MSProjectFileName Property

[read] The MS Project FileName of this task.

public virtual String MSProjectFileName {get;}

Property Value

The MS Project FileName of this task.

See Also

Task Class | StarTeam Namespace


MSProjectLastUpdate Property

Borland StarTeam SDK for .NET

Task.MSProjectLastUpdate Property

[read] The date that this task was last updated from MS Project.

public virtual DateTime MSProjectLastUpdate {get;}

Property Value

The date that this task was last updated from MS Project.

See Also

Task Class | StarTeam Namespace


MSProjectTaskType Property

Borland StarTeam SDK for .NET

Task.MSProjectTaskType Property

[read] The task's type in MS Project.

public virtual Task.TaskType MSProjectTaskType {get;}

Property Value

The task's type in MS Project.

See Also

Task Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Task.Name Property

[read/write] The Name of this task.

public virtual String Name {get; set;}

Property Value

The Name of this task.

See Also

Task Class | StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

Task.Notes Property

[read/write] The text in the "Notes" for this task.

public virtual String Notes {get; set;}

Property Value

The text in the "Notes" for this task.

See Also

Task Class | StarTeam Namespace


Number Property

Borland StarTeam SDK for .NET

Task.Number Property

[read] The number assigned to this task.

public virtual Int32 Number {get;}

Property Value

The number assigned to this task.

See Also

Task Class | StarTeam Namespace


Order Property

Borland StarTeam SDK for .NET

Task.Order Property

[read/write] The order in which the task should be worked on.

public virtual Double Order {get; set;}

Property Value

The order in which the task should be worked on.

See Also

Task Class | StarTeam Namespace


OriginValue Property

Borland StarTeam SDK for .NET

Task.OriginValue Property

[read/write] A value indicating the origin (e.g., StarTeam or MS Project) of this task.

public virtual Task.Origin OriginValue {get; set;}

Property Value

A value indicating the origin (e.g., StarTeam or MS Project) of this task.

See Also

Task Class | StarTeam Namespace


ParentStory Property

Borland StarTeam SDK for .NET

Task.ParentStory Property

[read] the Story containing this Task

public virtual Story ParentStory {get;}

Property Value

the Story containing this Task

See Also

Task Class | StarTeam Namespace


PercentComplete Property

Borland StarTeam SDK for .NET

Task.PercentComplete Property

[read/write] A percentage indicating how much of the task has been completed.

public virtual Int32 PercentComplete {get; set;}

Property Value

A percentage indicating how much of the task has been completed.

See Also

Task Class | StarTeam Namespace


PredecessorLinks Property

Borland StarTeam SDK for .NET

Task.PredecessorLinks Property

[read] The predecessor tasks to this this task.

public virtual TaskDependency[] PredecessorLinks {get;}

Property Value

The predecessor tasks to this this task.

See Also

Task Class | StarTeam Namespace


PriorityValue Property

Borland StarTeam SDK for .NET

Task.PriorityValue Property

[read/write] The Priority of this task.

public virtual Task.Priority PriorityValue {get; set;}

Property Value

The Priority of this task.

See Also

Task Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Task.Properties Property

[read]

public virtual Task.Type.PropertyCollection Properties {get;}

See Also

Task Class | StarTeam Namespace


ResourceCount Property

Borland StarTeam SDK for .NET

Task.ResourceCount Property

[read] The number of resources assigned to this task.

public virtual Int32 ResourceCount {get;}

Property Value

The number of resources assigned to this task.

See Also

Task Class | StarTeam Namespace


ResourceNames Property

Borland StarTeam SDK for .NET

Task.ResourceNames Property

[read] The names of the users assigned as resources of this task.

public virtual String[] ResourceNames {get;}

Property Value

The names of the users assigned as resources of this task.

See Also

Task Class | StarTeam Namespace


Resources Property

Borland StarTeam SDK for .NET

Task.Resources Property

[read] The User assigned as resources of this task.

public virtual User[] Resources {get;}

Property Value

The User assigned as resources of this task.

See Also

Task Class | StarTeam Namespace


Responsibility Property

Borland StarTeam SDK for .NET

Task.Responsibility Property

[read/write] The User object who is responsible for this task.

public virtual User Responsibility {get; set;}

Property Value

The User object who is responsible for this task.

See Also

Task Class | StarTeam Namespace


RichDescription Property

Borland StarTeam SDK for .NET

Task.RichDescription Property

[read/write] Rich Description used for this task

public virtual Content RichDescription {get; set;}

Property Value

Rich Description used for this task

See Also

Task Class | StarTeam Namespace


ScheduledCalendarTime Property

Borland StarTeam SDK for .NET

Task.ScheduledCalendarTime Property

[read/write] The TimeSpan during which at least one user is working on this task.

public virtual TimeSpan ScheduledCalendarTime {get; set;}

Property Value

The TimeSpan during which at least one user is working on this task.

See Also

Task Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Task.StatusValue Property

[read/write] The Status of this task.

public virtual Task.Status StatusValue {get; set;}

Property Value

The Status of this task.

See Also

Task Class | StarTeam Namespace


SuccessorLinks Property

Borland StarTeam SDK for .NET

Task.SuccessorLinks Property

[read] The successor tasks to this this task.

public virtual TaskDependency[] SuccessorLinks {get;}

Property Value

The successor tasks to this this task.

See Also

Task Class | StarTeam Namespace


Team Property

Borland StarTeam SDK for .NET

Task.Team Property

[read/write] The team for this task.

public virtual String Team {get; set;}

Property Value

The team for this task.

See Also

Task Class | StarTeam Namespace


UniqueID Property

Borland StarTeam SDK for .NET

Task.UniqueID Property

[read] The MS Project UniqueID of this task.

public virtual Int32 UniqueID {get;}

Property Value

The MS Project UniqueID of this task.

See Also

Task Class | StarTeam Namespace


Usage Property

Borland StarTeam SDK for .NET

Task.Usage Property

[read/write] The task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links.

public virtual Task.ProcessUsage Usage {get; set;}

Property Value

The task usage. The usage determines whether or not this is a process task and, if so, the type of operation that created the task and its process links.

See Also

Task Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Task.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Task Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Task.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Task Class | StarTeam Namespace


WBSCode Property

Borland StarTeam SDK for .NET

Task.WBSCode Property

[read] The MS Project WBS Code of this task.

public virtual String WBSCode {get;}

Property Value

The MS Project WBS Code of this task.

See Also

Task Class | StarTeam Namespace


WorkRecordCount Property

Borland StarTeam SDK for .NET

Task.WorkRecordCount Property

[read] The number of work records that have been added to this task.

public virtual Int32 WorkRecordCount {get;}

Property Value

The number of work records that have been added to this task.

See Also

Task Class | StarTeam Namespace


WorkRecords Property

Borland StarTeam SDK for .NET

Task.WorkRecords Property

[read] The work records associates with this task.

public virtual WorkRecord[] WorkRecords {get;}

Property Value

The work records associates with this task.

See Also

Task Class | StarTeam Namespace


Task Methods

The methods of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Static Methods

Create | Create a Task in the specified parent folder.
PopulateTaskDependencies | Fetches the dependencies(predecessor/successors) that are associated with the given set of tasks in bulk using a single server command. This command is supported only on servers from 12.0 release onwards.
PopulateWorkRecords | Fetches the work records that are associated with the given set of tasks in bulk using a single server command.This command is supported only on servers from 12.0 release onwards.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddPredecessorLink | Adds a new predecessor to this task.
AddResource | Adds the specified User object as a resource for this Task.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
CreateWorkRecord | Creates a new WorkRecord for the specified Task and user.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Discard | This will discard all cached data associated with this task including changes made but not yet saved.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IgnoreLinkedStory | If invoked, then updating this Task status does not affect the status of a linked Story The caller is responsible for ensuring that Task and linked Story states are consistent.
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveDependency | Removed the specified task dependency from this task. The dependency must be either a successor or predecessor to this task or an exception will be thrown.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
RemoveResource | Removes the specified User object as a resource from this task.
RemoveWorkRecord | Removes the work record from this task. The work record must already be associated with this task or an exception will be thrown.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveAsCrossViewProcessItem | Returns the set of workspace Change Packages directly reachable from this task used as a cross (project/) view process item These changepackages represent workspace changes (file checkins) in their respective view(s). Returns an empty array if no cross view change packages are found
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Task Class | StarTeam Namespace


Task.AddPredecessorLink Method

Adds a new predecessor to this task.

public virtual void AddPredecessorLink(
Int32 predecessorID,
Int32 lagTime,
Int32 depType
);

Parameters

predecessorID
the task id of the predecessor task
lagTime
the lag time for this dependency
depType
the dependency type.

See Also

Task Class | StarTeam Namespace


Task.AddResource Method

Adds the specified User object as a resource for this Task.

public virtual void AddResource(
User user
);

Parameters

user
the User object to add as a resource for this task,

See Also

Task Class | StarTeam Namespace


Task.Create Method

Create a Task in the specified parent folder.

public static Task Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Task Object.

See Also

Task Class | StarTeam Namespace


Task.CreateWorkRecord Method

Creates a new WorkRecord for the specified Task and user.

public virtual WorkRecord CreateWorkRecord(
User user
);

Parameters

user
the the user that performs the work

See Also

Task Class | StarTeam Namespace


Task.Discard Method

This will discard all cached data associated with this task including changes made but not yet saved.

public virtual void Discard();

See Also

Task Class | StarTeam Namespace | discard


Task.IgnoreLinkedStory Method

If invoked, then updating this Task status does not affect the status of a linked Story The caller is responsible for ensuring that Task and linked Story states are consistent.

public virtual void IgnoreLinkedStory();

See Also

Task Class | StarTeam Namespace


Task.PopulateTaskDependencies Method

Fetches the dependencies(predecessor/successors) that are associated with the given set of tasks in bulk using a single server command. This command is supported only on servers from 12.0 release onwards.

public static void PopulateTaskDependencies(
Task[] tasks
);

Parameters

tasks
list of tasks whose work records are required

See Also

Task Class | StarTeam Namespace


Task.PopulateWorkRecords Method

Fetches the work records that are associated with the given set of tasks in bulk using a single server command.This command is supported only on servers from 12.0 release onwards.

public static void PopulateWorkRecords(
Task[] tasks
);

Parameters

tasks
list of tasks whose work records are required

See Also

Task Class | StarTeam Namespace


Task.RemoveDependency Method

Removed the specified task dependency from this task. The dependency must be either a successor or predecessor to this task or an exception will be thrown.

public virtual void RemoveDependency(
TaskDependency dependency
);

Parameters

dependency
the task dependency to remove

See Also

Task Class | StarTeam Namespace


Task.RemoveResource Method

Removes the specified User object as a resource from this task.

public virtual void RemoveResource(
User user
);

Parameters

user
the User object resource to remove from this task.

See Also

Task Class | StarTeam Namespace


Task.RemoveWorkRecord Method

Removes the work record from this task. The work record must already be associated with this task or an exception will be thrown.

public virtual void RemoveWorkRecord(
WorkRecord record
);

Parameters

record
the work record to be removed.

See Also

Task Class | StarTeam Namespace


Task.ResolveAsCrossViewProcessItem Method

Returns the set of workspace Change Packages directly reachable from this task used as a cross (project/) view process item These changepackages represent workspace changes (file checkins) in their respective view(s). Returns an empty array if no cross view change packages are found

public virtual ChangePackage[] ResolveAsCrossViewProcessItem();

See Also

Task Class | StarTeam Namespace


Task.Constraint Class

Task Constraint Type

For a list of all members of this type, see Task.Constraint Members.

System.Object
EnumeratedValue
Task.Constraint

public class Task.Constraint : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Constraint Members | StarTeam Namespace


Task.Constraint Members

Task.Constraint overview

Public Static Properties

ALL
AS_LATE_AS_POSSIBLE
AS_SOON_AS_POSSIBLE
FINISH_NO_EARLIER_THAN
FINISH_NO_LATER_THAN
MUST_FINISH_ON
MUST_START_ON
START_NO_EARLIER_THAN
START_NO_LATER_THAN

Public Static Methods

FromID | Gets the Constraint value corresponding to the given ID.
FromValue | Gets the Constraint value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Constraint value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.Constraint.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Constraint.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.Constraint.

See Also

Task.Constraint Class | StarTeam Namespace


Task.Constraint Properties

The properties of the Task.Constraint class are listed below. For a complete list of Task.Constraint class members, see the Task.Constraint Members topic.

Public Static Properties

ALL
AS_LATE_AS_POSSIBLE
AS_SOON_AS_POSSIBLE
FINISH_NO_EARLIER_THAN
FINISH_NO_LATER_THAN
MUST_FINISH_ON
MUST_START_ON
START_NO_EARLIER_THAN
START_NO_LATER_THAN

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Constraint value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Task.Constraint Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Task.Constraint.ALL Property

public static Constraint[] ALL {get;}

See Also

Task.Constraint Class | StarTeam Namespace


AS_LATE_AS_POSSIBLE Property

Borland StarTeam SDK for .NET

Task.Constraint.AS_LATE_AS_POSSIBLE Property

public static Task.Constraint AS_LATE_AS_POSSIBLE {get;}

Property Value

Task constrained to finish as late as possible

See Also

Task.Constraint Class | StarTeam Namespace


AS_SOON_AS_POSSIBLE Property

Borland StarTeam SDK for .NET

Task.Constraint.AS_SOON_AS_POSSIBLE Property

public static Task.Constraint AS_SOON_AS_POSSIBLE {get;}

Property Value

Task constrained to finish as soon as possible

See Also

Task.Constraint Class | StarTeam Namespace


FINISH_NO_EARLIER_THAN Property

Borland StarTeam SDK for .NET

Task.Constraint.FINISH_NO_EARLIER_THAN Property

public static Task.Constraint FINISH_NO_EARLIER_THAN {get;}

Property Value

Task constrained to finish no earlier than

See Also

Task.Constraint Class | StarTeam Namespace


FINISH_NO_LATER_THAN Property

Borland StarTeam SDK for .NET

Task.Constraint.FINISH_NO_LATER_THAN Property

public static Task.Constraint FINISH_NO_LATER_THAN {get;}

Property Value

Task constrained to finish no later than

See Also

Task.Constraint Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Task.Constraint.ID Property

[read] The ID of this Constraint value.

public virtual Int32 ID {get;}

Property Value

The ID of this Constraint value.

See Also

Task.Constraint Class | StarTeam Namespace


MUST_FINISH_ON Property

Borland StarTeam SDK for .NET

Task.Constraint.MUST_FINISH_ON Property

public static Task.Constraint MUST_FINISH_ON {get;}

Property Value

Task constrained must finish on

See Also

Task.Constraint Class | StarTeam Namespace


MUST_START_ON Property

Borland StarTeam SDK for .NET

Task.Constraint.MUST_START_ON Property

public static Task.Constraint MUST_START_ON {get;}

Property Value

Task must start on.

See Also

Task.Constraint Class | StarTeam Namespace


START_NO_EARLIER_THAN Property

Borland StarTeam SDK for .NET

Task.Constraint.START_NO_EARLIER_THAN Property

public static Task.Constraint START_NO_EARLIER_THAN {get;}

Property Value

Task should start no ealier than

See Also

Task.Constraint Class | StarTeam Namespace


START_NO_LATER_THAN Property

Borland StarTeam SDK for .NET

Task.Constraint.START_NO_LATER_THAN Property

public static Task.Constraint START_NO_LATER_THAN {get;}

Property Value

Task should start no later than

See Also

Task.Constraint Class | StarTeam Namespace


Task.Constraint Methods

The methods of the Task.Constraint class are listed below. For a complete list of Task.Constraint class members, see the Task.Constraint Members topic.

Public Static Methods

FromID | Gets the Constraint value corresponding to the given ID.
FromValue | Gets the Constraint value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.Constraint.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Constraint.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.Constraint.

See Also

Task.Constraint Class | StarTeam Namespace


Task.Constraint.Equals Method

Delegate Equals() to com.starteam.Task.Constraint.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Constraint.Equals(obj).

See Also

Task.Constraint Class | StarTeam Namespace


Task.Constraint.FromID Method

Gets the Constraint value corresponding to the given ID.

public static Constraint FromID(
Int32 id
);

Parameters

id
The ID of a Constraint value.

Return Value

The corresponding Constraint value, or null.

See Also

Task.Constraint Class | StarTeam Namespace


Task.Constraint.FromValue Method

Gets the Constraint value corresponding to the given EnumeratedValue.

public static Constraint FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a ConstraintProperty.

Return Value

The corresponding Constraint value, or null.

See Also

Task.Constraint Class | StarTeam Namespace


Task.Constraint.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Constraint.

public override int GetHashCode();

Return Value

com.starteam.Task.Constraint.GetHashCode().

See Also

Task.Constraint Class | StarTeam Namespace


Task.Constraint.ToString Method

Delegate ToString() to com.starteam.Task.Constraint.

public override string ToString();

Return Value

com.starteam.Task.Constraint.ToString()

See Also

Task.Constraint Class | StarTeam Namespace


Task.LifeCycleType Class

Task LifeCycleType

For a list of all members of this type, see Task.LifeCycleType Members.

System.Object
EnumeratedValue
Task.LifeCycleType

public class Task.LifeCycleType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.LifeCycleType Members | StarTeam Namespace


Task.LifeCycleType Members

Task.LifeCycleType overview

Public Static Properties

ALL
DEVELOPMENT
DOCUMENTATION
QA
UNKNOWN

Public Static Methods

FromID | Gets the LifeCycleType value corresponding to the given ID.
FromValue | Gets the LifeCycleType value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this LifeCycleType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.LifeCycleType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.LifeCycleType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.LifeCycleType.

See Also

Task.LifeCycleType Class | StarTeam Namespace


Task.LifeCycleType Properties

The properties of the Task.LifeCycleType class are listed below. For a complete list of Task.LifeCycleType class members, see the Task.LifeCycleType Members topic.

Public Static Properties

ALL
DEVELOPMENT
DOCUMENTATION
QA
UNKNOWN

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this LifeCycleType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Task.LifeCycleType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Task.LifeCycleType.ALL Property

public static LifeCycleType[] ALL {get;}

See Also

Task.LifeCycleType Class | StarTeam Namespace


DEVELOPMENT Property

Borland StarTeam SDK for .NET

Task.LifeCycleType.DEVELOPMENT Property

public static Task.LifeCycleType DEVELOPMENT {get;}

Property Value

Lifecycle type for Task is Development.

See Also

Task.LifeCycleType Class | StarTeam Namespace


DOCUMENTATION Property

Borland StarTeam SDK for .NET

Task.LifeCycleType.DOCUMENTATION Property

public static Task.LifeCycleType DOCUMENTATION {get;}

Property Value

Lifecycle type for Task is Documentation.

See Also

Task.LifeCycleType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Task.LifeCycleType.ID Property

[read] The ID of this LifeCycleType value.

public virtual Int32 ID {get;}

Property Value

The ID of this LifeCycleType value.

See Also

Task.LifeCycleType Class | StarTeam Namespace


QA Property

Borland StarTeam SDK for .NET

Task.LifeCycleType.QA Property

public static Task.LifeCycleType QA {get;}

Property Value

Lifecycle type for Task is QA.

See Also

Task.LifeCycleType Class | StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

Task.LifeCycleType.UNKNOWN Property

public static Task.LifeCycleType UNKNOWN {get;}

Property Value

Lifecycle type for Task is Unknown.

See Also

Task.LifeCycleType Class | StarTeam Namespace


Task.LifeCycleType Methods

The methods of the Task.LifeCycleType class are listed below. For a complete list of Task.LifeCycleType class members, see the Task.LifeCycleType Members topic.

Public Static Methods

FromID | Gets the LifeCycleType value corresponding to the given ID.
FromValue | Gets the LifeCycleType value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.LifeCycleType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.LifeCycleType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.LifeCycleType.

See Also

Task.LifeCycleType Class | StarTeam Namespace


Task.LifeCycleType.Equals Method

Delegate Equals() to com.starteam.Task.LifeCycleType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.LifeCycleType.Equals(obj).

See Also

Task.LifeCycleType Class | StarTeam Namespace


Task.LifeCycleType.FromID Method

Gets the LifeCycleType value corresponding to the given ID.

public static LifeCycleType FromID(
Int32 id
);

Parameters

id
An LifeCycleType ID.

Return Value

The corresponding LifeCycleType value, or null.

See Also

Task.LifeCycleType Class | StarTeam Namespace


Task.LifeCycleType.FromValue Method

Gets the LifeCycleType value corresponding to the given EnumeratedValue.

public static LifeCycleType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a LifeCycleTypeProperty.

Return Value

The corresponding LifeCycleType value, or null.

See Also

Task.LifeCycleType Class | StarTeam Namespace


Task.LifeCycleType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.LifeCycleType.

public override int GetHashCode();

Return Value

com.starteam.Task.LifeCycleType.GetHashCode().

See Also

Task.LifeCycleType Class | StarTeam Namespace


Task.LifeCycleType.ToString Method

Delegate ToString() to com.starteam.Task.LifeCycleType.

public override string ToString();

Return Value

com.starteam.Task.LifeCycleType.ToString()

See Also

Task.LifeCycleType Class | StarTeam Namespace


Task.Origin Class

Task Origin

For a list of all members of this type, see Task.Origin Members.

System.Object
EnumeratedValue
Task.Origin

public class Task.Origin : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Origin Members | StarTeam Namespace


Task.Origin Members

Task.Origin overview

Public Static Properties

ALL
MSPROJECT
STARTEAM

Public Static Methods

FromID | Gets the Origin value corresponding to the given ID.
FromValue | Gets the Origin value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Origin value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.Origin.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Origin.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.Origin.

See Also

Task.Origin Class | StarTeam Namespace


Task.Origin Properties

The properties of the Task.Origin class are listed below. For a complete list of Task.Origin class members, see the Task.Origin Members topic.

Public Static Properties

ALL
MSPROJECT
STARTEAM

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Origin value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Task.Origin Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Task.Origin.ALL Property

public static Origin[] ALL {get;}

See Also

Task.Origin Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Task.Origin.ID Property

[read] The ID of this Origin value.

public virtual Int32 ID {get;}

Property Value

The ID of this Origin value.

See Also

Task.Origin Class | StarTeam Namespace


MSPROJECT Property

Borland StarTeam SDK for .NET

Task.Origin.MSPROJECT Property

public static Task.Origin MSPROJECT {get;}

Property Value

Task was created in the application or exported to the application from Microsoft Project.

See Also

Task.Origin Class | StarTeam Namespace


STARTEAM Property

Borland StarTeam SDK for .NET

Task.Origin.STARTEAM Property

public static Task.Origin STARTEAM {get;}

Property Value

Task created in StarTeam

See Also

Task.Origin Class | StarTeam Namespace


Task.Origin Methods

The methods of the Task.Origin class are listed below. For a complete list of Task.Origin class members, see the Task.Origin Members topic.

Public Static Methods

FromID | Gets the Origin value corresponding to the given ID.
FromValue | Gets the Origin value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.Origin.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Origin.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.Origin.

See Also

Task.Origin Class | StarTeam Namespace


Task.Origin.Equals Method

Delegate Equals() to com.starteam.Task.Origin.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Origin.Equals(obj).

See Also

Task.Origin Class | StarTeam Namespace


Task.Origin.FromID Method

Gets the Origin value corresponding to the given ID.

public static Origin FromID(
Int32 id
);

Parameters

id
An Origin ID.

Return Value

The corresponding Origin value, or null.

See Also

Task.Origin Class | StarTeam Namespace


Task.Origin.FromValue Method

Gets the Origin value corresponding to the given EnumeratedValue.

public static Origin FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a OriginProperty.

Return Value

The corresponding Origin value, or null.

See Also

Task.Origin Class | StarTeam Namespace


Task.Origin.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Origin.

public override int GetHashCode();

Return Value

com.starteam.Task.Origin.GetHashCode().

See Also

Task.Origin Class | StarTeam Namespace


Task.Origin.ToString Method

Delegate ToString() to com.starteam.Task.Origin.

public override string ToString();

Return Value

com.starteam.Task.Origin.ToString()

See Also

Task.Origin Class | StarTeam Namespace


Task.Priority Class

Priority of the Task

For a list of all members of this type, see Task.Priority Members.

System.Object
EnumeratedValue
Task.Priority

public class Task.Priority : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Priority Members | StarTeam Namespace


Task.Priority Members

Task.Priority overview

Public Static Properties

ALL
DO_NOT_LEVEL
HIGH
HIGHER
HIGHEST
LOW
LOWER
LOWEST
MEDIUM
VERY_HIGH
VERY_LOW

Public Static Methods

FromID | Gets the Priority value corresponding to the given ID.
FromValue | Gets the Priority value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Priority value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.Priority.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Priority.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.Priority.

See Also

Task.Priority Class | StarTeam Namespace


Task.Priority Properties

The properties of the Task.Priority class are listed below. For a complete list of Task.Priority class members, see the Task.Priority Members topic.

Public Static Properties

ALL
DO_NOT_LEVEL
HIGH
HIGHER
HIGHEST
LOW
LOWER
LOWEST
MEDIUM
VERY_HIGH
VERY_LOW

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Priority value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Task.Priority Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Task.Priority.ALL Property

public static Priority[] ALL {get;}

See Also

Task.Priority Class | StarTeam Namespace


DO_NOT_LEVEL Property

Borland StarTeam SDK for .NET

Task.Priority.DO_NOT_LEVEL Property

public static Task.Priority DO_NOT_LEVEL {get;}

Property Value

Task's priority should be ignored

See Also

Task.Priority Class | StarTeam Namespace


HIGH Property

Borland StarTeam SDK for .NET

Task.Priority.HIGH Property

public static Task.Priority HIGH {get;}

Property Value

Task's priority is high

See Also

Task.Priority Class | StarTeam Namespace


HIGHER Property

Borland StarTeam SDK for .NET

Task.Priority.HIGHER Property

public static Task.Priority HIGHER {get;}

Property Value

Task's priority is higher

See Also

Task.Priority Class | StarTeam Namespace


HIGHEST Property

Borland StarTeam SDK for .NET

Task.Priority.HIGHEST Property

public static Task.Priority HIGHEST {get;}

Property Value

Task is of the highest priority

See Also

Task.Priority Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Task.Priority.ID Property

[read] The ID of this Priority value.

public virtual Int32 ID {get;}

Property Value

The ID of this Priority value.

See Also

Task.Priority Class | StarTeam Namespace


LOW Property

Borland StarTeam SDK for .NET

Task.Priority.LOW Property

public static Task.Priority LOW {get;}

Property Value

Task's priority is low

See Also

Task.Priority Class | StarTeam Namespace


LOWER Property

Borland StarTeam SDK for .NET

Task.Priority.LOWER Property

public static Task.Priority LOWER {get;}

Property Value

Task's priority is lower

See Also

Task.Priority Class | StarTeam Namespace


LOWEST Property

Borland StarTeam SDK for .NET

Task.Priority.LOWEST Property

public static Task.Priority LOWEST {get;}

Property Value

Task's priority is the lowest

See Also

Task.Priority Class | StarTeam Namespace


MEDIUM Property

Borland StarTeam SDK for .NET

Task.Priority.MEDIUM Property

public static Task.Priority MEDIUM {get;}

Property Value

Task is of medium priority

See Also

Task.Priority Class | StarTeam Namespace


VERY_HIGH Property

Borland StarTeam SDK for .NET

Task.Priority.VERY_HIGH Property

public static Task.Priority VERY_HIGH {get;}

Property Value

Task is of very high Priority

See Also

Task.Priority Class | StarTeam Namespace


VERY_LOW Property

Borland StarTeam SDK for .NET

Task.Priority.VERY_LOW Property

public static Task.Priority VERY_LOW {get;}

Property Value

Task's priority is very low

See Also

Task.Priority Class | StarTeam Namespace


Task.Priority Methods

The methods of the Task.Priority class are listed below. For a complete list of Task.Priority class members, see the Task.Priority Members topic.

Public Static Methods

FromID | Gets the Priority value corresponding to the given ID.
FromValue | Gets the Priority value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.Priority.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Priority.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.Priority.

See Also

Task.Priority Class | StarTeam Namespace


Task.Priority.Equals Method

Delegate Equals() to com.starteam.Task.Priority.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Priority.Equals(obj).

See Also

Task.Priority Class | StarTeam Namespace


Task.Priority.FromID Method

Gets the Priority value corresponding to the given ID.

public static Priority FromID(
Int32 id
);

Parameters

id
A Priority ID.

Return Value

The corresponding Priority value, or null.

See Also

Task.Priority Class | StarTeam Namespace


Task.Priority.FromValue Method

Gets the Priority value corresponding to the given EnumeratedValue.

public static Priority FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a PriorityProperty.

Return Value

The corresponding Priority value, or null.

See Also

Task.Priority Class | StarTeam Namespace


Task.Priority.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Priority.

public override int GetHashCode();

Return Value

com.starteam.Task.Priority.GetHashCode().

See Also

Task.Priority Class | StarTeam Namespace


Task.Priority.ToString Method

Delegate ToString() to com.starteam.Task.Priority.

public override string ToString();

Return Value

com.starteam.Task.Priority.ToString()

See Also

Task.Priority Class | StarTeam Namespace


Task.ProcessUsage Class

Indicates the type of operation that created a given process task and its associated process links.

For a list of all members of this type, see Task.ProcessUsage Members.

System.Object
EnumeratedValue
Task.ProcessUsage

public class Task.ProcessUsage : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.ProcessUsage Members | StarTeam Namespace


Task.ProcessUsage Members

Task.ProcessUsage overview

Public Static Properties

ALL
CHECKIN
OTHER
PROMOTE
REBASE
REPLICATE

Public Static Methods

FromID | Gets the ProcessUsage value corresponding to the given ID.
FromValue | Gets the Compression value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.ProcessUsage.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.ProcessUsage.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.ProcessUsage.

See Also

Task.ProcessUsage Class | StarTeam Namespace


Task.ProcessUsage Properties

The properties of the Task.ProcessUsage class are listed below. For a complete list of Task.ProcessUsage class members, see the Task.ProcessUsage Members topic.

Public Static Properties

ALL
CHECKIN
OTHER
PROMOTE
REBASE
REPLICATE

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Task.ProcessUsage Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Task.ProcessUsage.ALL Property

public static ProcessUsage[] ALL {get;}

See Also

Task.ProcessUsage Class | StarTeam Namespace


CHECKIN Property

Borland StarTeam SDK for .NET

Task.ProcessUsage.CHECKIN Property

public static Task.ProcessUsage CHECKIN {get;}

Property Value

For adding and checking in files.

See Also

Task.ProcessUsage Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Task.ProcessUsage.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

Task.ProcessUsage Class | StarTeam Namespace


OTHER Property

Borland StarTeam SDK for .NET

Task.ProcessUsage.OTHER Property

public static Task.ProcessUsage OTHER {get;}

Property Value

Not a process task.

See Also

Task.ProcessUsage Class | StarTeam Namespace


PROMOTE Property

Borland StarTeam SDK for .NET

Task.ProcessUsage.PROMOTE Property

public static Task.ProcessUsage PROMOTE {get;}

Property Value

For a Promote view compare/merge session.

See Also

Task.ProcessUsage Class | StarTeam Namespace


REBASE Property

Borland StarTeam SDK for .NET

Task.ProcessUsage.REBASE Property

public static Task.ProcessUsage REBASE {get;}

Property Value

For a Rebase view compare/merge session.

See Also

Task.ProcessUsage Class | StarTeam Namespace


REPLICATE Property

Borland StarTeam SDK for .NET

Task.ProcessUsage.REPLICATE Property

public static Task.ProcessUsage REPLICATE {get;}

Property Value

For a Replicate view compare/merge session.

See Also

Task.ProcessUsage Class | StarTeam Namespace


Task.ProcessUsage Methods

The methods of the Task.ProcessUsage class are listed below. For a complete list of Task.ProcessUsage class members, see the Task.ProcessUsage Members topic.

Public Static Methods

FromID | Gets the ProcessUsage value corresponding to the given ID.
FromValue | Gets the Compression value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.ProcessUsage.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.ProcessUsage.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.ProcessUsage.

See Also

Task.ProcessUsage Class | StarTeam Namespace


Task.ProcessUsage.Equals Method

Delegate Equals() to com.starteam.Task.ProcessUsage.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.ProcessUsage.Equals(obj).

See Also

Task.ProcessUsage Class | StarTeam Namespace


Task.ProcessUsage.FromID Method

Gets the ProcessUsage value corresponding to the given ID.

public static ProcessUsage FromID(
Int32 id
);

Parameters

id
The ID of a Compression value.

Return Value

The corresponding Compression value, or null.

See Also

Task.ProcessUsage Class | StarTeam Namespace


Task.ProcessUsage.FromValue Method

Gets the Compression value corresponding to the given EnumeratedValue.

public static ProcessUsage FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a ProcessUsageProperty.

Return Value

The corresponding ProcessUsage value, or null.

See Also

Task.ProcessUsage Class | StarTeam Namespace


Task.ProcessUsage.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.ProcessUsage.

public override int GetHashCode();

Return Value

com.starteam.Task.ProcessUsage.GetHashCode().

See Also

Task.ProcessUsage Class | StarTeam Namespace


Task.ProcessUsage.ToString Method

Delegate ToString() to com.starteam.Task.ProcessUsage.

public override string ToString();

Return Value

com.starteam.Task.ProcessUsage.ToString()

See Also

Task.ProcessUsage Class | StarTeam Namespace


Task.Status Class

Status of the Task

For a list of all members of this type, see Task.Status Members.

System.Object
EnumeratedValue
Task.Status

public class Task.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Status Members | StarTeam Namespace


Task.Status Members

Task.Status overview

Public Static Properties

ALL
CLOSED
FINISHED
HOLD
IN_PROGRESS
PENDING
READY_TO_START

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.Status.

See Also

Task.Status Class | StarTeam Namespace


Task.Status Properties

The properties of the Task.Status class are listed below. For a complete list of Task.Status class members, see the Task.Status Members topic.

Public Static Properties

ALL
CLOSED
FINISHED
HOLD
IN_PROGRESS
PENDING
READY_TO_START

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Task.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Task.Status.ALL Property

public static Status[] ALL {get;}

See Also

Task.Status Class | StarTeam Namespace


CLOSED Property

Borland StarTeam SDK for .NET

Task.Status.CLOSED Property

public static Task.Status CLOSED {get;}

Property Value

Task is closed

See Also

Task.Status Class | StarTeam Namespace


FINISHED Property

Borland StarTeam SDK for .NET

Task.Status.FINISHED Property

public static Task.Status FINISHED {get;}

Property Value

Task is finished

See Also

Task.Status Class | StarTeam Namespace


HOLD Property

Borland StarTeam SDK for .NET

Task.Status.HOLD Property

public static Task.Status HOLD {get;}

Property Value

Task is on Hold

See Also

Task.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Task.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

Task.Status Class | StarTeam Namespace


IN_PROGRESS Property

Borland StarTeam SDK for .NET

Task.Status.IN_PROGRESS Property

public static Task.Status IN_PROGRESS {get;}

Property Value

Task is in Progress

See Also

Task.Status Class | StarTeam Namespace


PENDING Property

Borland StarTeam SDK for .NET

Task.Status.PENDING Property

public static Task.Status PENDING {get;}

Property Value

Task is pending

See Also

Task.Status Class | StarTeam Namespace


READY_TO_START Property

Borland StarTeam SDK for .NET

Task.Status.READY_TO_START Property

public static Task.Status READY_TO_START {get;}

Property Value

Task is Ready to Start

See Also

Task.Status Class | StarTeam Namespace


Task.Status Methods

The methods of the Task.Status class are listed below. For a complete list of Task.Status class members, see the Task.Status Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.Status.

See Also

Task.Status Class | StarTeam Namespace


Task.Status.Equals Method

Delegate Equals() to com.starteam.Task.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Status.Equals(obj).

See Also

Task.Status Class | StarTeam Namespace


Task.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

Task.Status Class | StarTeam Namespace


Task.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

Task.Status Class | StarTeam Namespace


Task.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Status.

public override int GetHashCode();

Return Value

com.starteam.Task.Status.GetHashCode().

See Also

Task.Status Class | StarTeam Namespace


Task.Status.ToString Method

Delegate ToString() to com.starteam.Task.Status.

public override string ToString();

Return Value

com.starteam.Task.Status.ToString()

See Also

Task.Status Class | StarTeam Namespace


Task.TaskType Class

Task Type

For a list of all members of this type, see Task.TaskType Members.

System.Object
EnumeratedValue
Task.TaskType

public class Task.TaskType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.TaskType Members | StarTeam Namespace


Task.TaskType Members

Task.TaskType overview

Public Static Properties

ALL
FIXED_DURATION
FIXED_UNITS
FIXED_WORK

Public Static Methods

FromID | Gets the TaskType value corresponding to the given ID.
FromValue | Gets the TaskType value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this TaskType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.TaskType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.TaskType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.TaskType.

See Also

Task.TaskType Class | StarTeam Namespace


Task.TaskType Properties

The properties of the Task.TaskType class are listed below. For a complete list of Task.TaskType class members, see the Task.TaskType Members topic.

Public Static Properties

ALL
FIXED_DURATION
FIXED_UNITS
FIXED_WORK

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this TaskType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Task.TaskType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Task.TaskType.ALL Property

public static TaskType[] ALL {get;}

See Also

Task.TaskType Class | StarTeam Namespace


FIXED_DURATION Property

Borland StarTeam SDK for .NET

Task.TaskType.FIXED_DURATION Property

public static Task.TaskType FIXED_DURATION {get;}

Property Value

Task Type in MS Project is of Fixed Duration

See Also

Task.TaskType Class | StarTeam Namespace


FIXED_UNITS Property

Borland StarTeam SDK for .NET

Task.TaskType.FIXED_UNITS Property

public static Task.TaskType FIXED_UNITS {get;}

Property Value

Task Type in MS Project is of Fixed Units

See Also

Task.TaskType Class | StarTeam Namespace


FIXED_WORK Property

Borland StarTeam SDK for .NET

Task.TaskType.FIXED_WORK Property

public static Task.TaskType FIXED_WORK {get;}

Property Value

Task Type in MS Project is of Fixed work

See Also

Task.TaskType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Task.TaskType.ID Property

[read] The ID of this TaskType value.

public virtual Int32 ID {get;}

Property Value

The ID of this TaskType value.

See Also

Task.TaskType Class | StarTeam Namespace


Task.TaskType Methods

The methods of the Task.TaskType class are listed below. For a complete list of Task.TaskType class members, see the Task.TaskType Members topic.

Public Static Methods

FromID | Gets the TaskType value corresponding to the given ID.
FromValue | Gets the TaskType value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Task.TaskType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Task.TaskType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Task.TaskType.

See Also

Task.TaskType Class | StarTeam Namespace


Task.TaskType.Equals Method

Delegate Equals() to com.starteam.Task.TaskType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.TaskType.Equals(obj).

See Also

Task.TaskType Class | StarTeam Namespace


Task.TaskType.FromID Method

Gets the TaskType value corresponding to the given ID.

public static TaskType FromID(
Int32 id
);

Parameters

id
The ID of a TaskType value.

Return Value

The corresponding TaskType value, or null.

See Also

Task.TaskType Class | StarTeam Namespace


Task.TaskType.FromValue Method

Gets the TaskType value corresponding to the given EnumeratedValue.

public static TaskType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a TaskTypeProperty.

Return Value

The corresponding TaskType value, or null.

See Also

Task.TaskType Class | StarTeam Namespace


Task.TaskType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.TaskType.

public override int GetHashCode();

Return Value

com.starteam.Task.TaskType.GetHashCode().

See Also

Task.TaskType Class | StarTeam Namespace


Task.TaskType.ToString Method

Delegate ToString() to com.starteam.Task.TaskType.

public override string ToString();

Return Value

com.starteam.Task.TaskType.ToString()

See Also

Task.TaskType Class | StarTeam Namespace


Task.Type Class

Type meta-data (schema) for Task object instances

For a list of all members of this type, see Task.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
TreeItem.Type
Task.Type

new public class Task.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type Members | StarTeam Namespace


Task.Type Members

Task.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Task.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Task.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Task.Type Class | StarTeam Namespace


Task.Type Properties

The properties of the Task.Type class are listed below. For a complete list of Task.Type class members, see the Task.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Task.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Task.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Task.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Task.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Task.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Task.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Task.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Task.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Task.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Task.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Task.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Task.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Task.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Task.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Task.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.NAME Property

new public static String NAME {get;}

See Also

Task.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Task.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Task.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Task.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Task.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Task.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Task.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Task.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Task.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Task.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Task.Type Class | StarTeam Namespace


Task.Type Methods

The methods of the Task.Type class are listed below. For a complete list of Task.Type class members, see the Task.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Task.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Task.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Task.Type Class | StarTeam Namespace


Task.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Task.Type Class | StarTeam Namespace


Task.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Task.Type Class | StarTeam Namespace


Task.Type.Equals Method

Delegate Equals() to com.starteam.Task.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.Equals(obj).

See Also

Task.Type Class | StarTeam Namespace


Task.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Task.Type Class | StarTeam Namespace


Task.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.GetHashCode().

See Also

Task.Type Class | StarTeam Namespace


Task.Type.ToString Method

Delegate ToString() to com.starteam.Task.Type.

public override string ToString();

Return Value

com.starteam.Task.Type.ToString()

See Also

Task.Type Class | StarTeam Namespace


Task.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Task.Type Class | StarTeam Namespace


Task.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Task.Type Class | StarTeam Namespace


Task.Type.ActualFinishProperty Class

The property type of the Actual Finish property.

For a list of all members of this type, see Task.Type.ActualFinishProperty Members.

System.Object
Property
ScalarProperty
DateProperty
Task.Type.ActualFinishProperty

public class Task.Type.ActualFinishProperty : DateProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ActualFinishProperty Members | StarTeam Namespace


Task.Type.ActualFinishProperty Members

Task.Type.ActualFinishProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ActualFinishProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ActualFinishProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ActualFinishProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ActualFinishProperty Class | StarTeam Namespace


Task.Type.ActualFinishProperty Properties

The properties of the Task.Type.ActualFinishProperty class are listed below. For a complete list of Task.Type.ActualFinishProperty class members, see the Task.Type.ActualFinishProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.ActualFinishProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ActualFinishProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ActualFinishProperty Class | StarTeam Namespace


Task.Type.ActualFinishProperty Methods

The methods of the Task.Type.ActualFinishProperty class are listed below. For a complete list of Task.Type.ActualFinishProperty class members, see the Task.Type.ActualFinishProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ActualFinishProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ActualFinishProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ActualFinishProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ActualFinishProperty Class | StarTeam Namespace


Task.Type.ActualFinishProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ActualFinishProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ActualFinishProperty.Equals(obj).

See Also

Task.Type.ActualFinishProperty Class | StarTeam Namespace


Task.Type.ActualFinishProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ActualFinishProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ActualFinishProperty.GetHashCode().

See Also

Task.Type.ActualFinishProperty Class | StarTeam Namespace


Task.Type.ActualFinishProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ActualFinishProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ActualFinishProperty.ToString()

See Also

Task.Type.ActualFinishProperty Class | StarTeam Namespace


Task.Type.ActualHoursProperty Class

The property type of the Actual Hours property.

For a list of all members of this type, see Task.Type.ActualHoursProperty Members.

System.Object
Property
ScalarProperty
TimeSpanProperty
Task.Type.ActualHoursProperty

public class Task.Type.ActualHoursProperty : TimeSpanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ActualHoursProperty Members | StarTeam Namespace


Task.Type.ActualHoursProperty Members

Task.Type.ActualHoursProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ActualHoursProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ActualHoursProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ActualHoursProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ActualHoursProperty Class | StarTeam Namespace


Task.Type.ActualHoursProperty Properties

The properties of the Task.Type.ActualHoursProperty class are listed below. For a complete list of Task.Type.ActualHoursProperty class members, see the Task.Type.ActualHoursProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

See Also

Task.Type.ActualHoursProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ActualHoursProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ActualHoursProperty Class | StarTeam Namespace


Task.Type.ActualHoursProperty Methods

The methods of the Task.Type.ActualHoursProperty class are listed below. For a complete list of Task.Type.ActualHoursProperty class members, see the Task.Type.ActualHoursProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ActualHoursProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ActualHoursProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ActualHoursProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ActualHoursProperty Class | StarTeam Namespace


Task.Type.ActualHoursProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ActualHoursProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ActualHoursProperty.Equals(obj).

See Also

Task.Type.ActualHoursProperty Class | StarTeam Namespace


Task.Type.ActualHoursProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ActualHoursProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ActualHoursProperty.GetHashCode().

See Also

Task.Type.ActualHoursProperty Class | StarTeam Namespace


Task.Type.ActualHoursProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ActualHoursProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ActualHoursProperty.ToString()

See Also

Task.Type.ActualHoursProperty Class | StarTeam Namespace


Task.Type.ActualStartProperty Class

The property type of the Actual Start property.

For a list of all members of this type, see Task.Type.ActualStartProperty Members.

System.Object
Property
ScalarProperty
DateProperty
Task.Type.ActualStartProperty

public class Task.Type.ActualStartProperty : DateProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ActualStartProperty Members | StarTeam Namespace


Task.Type.ActualStartProperty Members

Task.Type.ActualStartProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ActualStartProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ActualStartProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ActualStartProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ActualStartProperty Class | StarTeam Namespace


Task.Type.ActualStartProperty Properties

The properties of the Task.Type.ActualStartProperty class are listed below. For a complete list of Task.Type.ActualStartProperty class members, see the Task.Type.ActualStartProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.ActualStartProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ActualStartProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ActualStartProperty Class | StarTeam Namespace


Task.Type.ActualStartProperty Methods

The methods of the Task.Type.ActualStartProperty class are listed below. For a complete list of Task.Type.ActualStartProperty class members, see the Task.Type.ActualStartProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ActualStartProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ActualStartProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ActualStartProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ActualStartProperty Class | StarTeam Namespace


Task.Type.ActualStartProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ActualStartProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ActualStartProperty.Equals(obj).

See Also

Task.Type.ActualStartProperty Class | StarTeam Namespace


Task.Type.ActualStartProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ActualStartProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ActualStartProperty.GetHashCode().

See Also

Task.Type.ActualStartProperty Class | StarTeam Namespace


Task.Type.ActualStartProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ActualStartProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ActualStartProperty.ToString()

See Also

Task.Type.ActualStartProperty Class | StarTeam Namespace


Task.Type.AttentionNotesProperty Class

The property type of the Attention Notes property.

For a list of all members of this type, see Task.Type.AttentionNotesProperty Members.

System.Object
Property
VectorProperty
TextProperty
Task.Type.AttentionNotesProperty

public class Task.Type.AttentionNotesProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.AttentionNotesProperty Members | StarTeam Namespace


Task.Type.AttentionNotesProperty Members

Task.Type.AttentionNotesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.AttentionNotesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.AttentionNotesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.AttentionNotesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.AttentionNotesProperty Class | StarTeam Namespace


Task.Type.AttentionNotesProperty Properties

The properties of the Task.Type.AttentionNotesProperty class are listed below. For a complete list of Task.Type.AttentionNotesProperty class members, see the Task.Type.AttentionNotesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.AttentionNotesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.AttentionNotesProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.AttentionNotesProperty Class | StarTeam Namespace


Task.Type.AttentionNotesProperty Methods

The methods of the Task.Type.AttentionNotesProperty class are listed below. For a complete list of Task.Type.AttentionNotesProperty class members, see the Task.Type.AttentionNotesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.AttentionNotesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.AttentionNotesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.AttentionNotesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.AttentionNotesProperty Class | StarTeam Namespace


Task.Type.AttentionNotesProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.AttentionNotesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.AttentionNotesProperty.Equals(obj).

See Also

Task.Type.AttentionNotesProperty Class | StarTeam Namespace


Task.Type.AttentionNotesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.AttentionNotesProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.AttentionNotesProperty.GetHashCode().

See Also

Task.Type.AttentionNotesProperty Class | StarTeam Namespace


Task.Type.AttentionNotesProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.AttentionNotesProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.AttentionNotesProperty.ToString()

See Also

Task.Type.AttentionNotesProperty Class | StarTeam Namespace


Task.Type.BlockedProperty Class

The property type of the Blocked property.

For a list of all members of this type, see Task.Type.BlockedProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Task.Type.BlockedProperty

public class Task.Type.BlockedProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.BlockedProperty Members | StarTeam Namespace


Task.Type.BlockedProperty Members

Task.Type.BlockedProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.BlockedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.BlockedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.BlockedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.BlockedProperty Class | StarTeam Namespace


Task.Type.BlockedProperty Properties

The properties of the Task.Type.BlockedProperty class are listed below. For a complete list of Task.Type.BlockedProperty class members, see the Task.Type.BlockedProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.BlockedProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.BlockedProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.BlockedProperty Class | StarTeam Namespace


Task.Type.BlockedProperty Methods

The methods of the Task.Type.BlockedProperty class are listed below. For a complete list of Task.Type.BlockedProperty class members, see the Task.Type.BlockedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.BlockedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.BlockedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.BlockedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.BlockedProperty Class | StarTeam Namespace


Task.Type.BlockedProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.BlockedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.BlockedProperty.Equals(obj).

See Also

Task.Type.BlockedProperty Class | StarTeam Namespace


Task.Type.BlockedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.BlockedProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.BlockedProperty.GetHashCode().

See Also

Task.Type.BlockedProperty Class | StarTeam Namespace


Task.Type.BlockedProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.BlockedProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.BlockedProperty.ToString()

See Also

Task.Type.BlockedProperty Class | StarTeam Namespace


Task.Type.ChildrenCountProperty Class

The property type of the Task Children Count property.

For a list of all members of this type, see Task.Type.ChildrenCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.ChildrenCountProperty

public class Task.Type.ChildrenCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ChildrenCountProperty Members | StarTeam Namespace


Task.Type.ChildrenCountProperty Members

Task.Type.ChildrenCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ChildrenCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ChildrenCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ChildrenCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ChildrenCountProperty Class | StarTeam Namespace


Task.Type.ChildrenCountProperty Properties

The properties of the Task.Type.ChildrenCountProperty class are listed below. For a complete list of Task.Type.ChildrenCountProperty class members, see the Task.Type.ChildrenCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.ChildrenCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ChildrenCountProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ChildrenCountProperty Class | StarTeam Namespace


Task.Type.ChildrenCountProperty Methods

The methods of the Task.Type.ChildrenCountProperty class are listed below. For a complete list of Task.Type.ChildrenCountProperty class members, see the Task.Type.ChildrenCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ChildrenCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ChildrenCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ChildrenCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ChildrenCountProperty Class | StarTeam Namespace


Task.Type.ChildrenCountProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ChildrenCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ChildrenCountProperty.Equals(obj).

See Also

Task.Type.ChildrenCountProperty Class | StarTeam Namespace


Task.Type.ChildrenCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ChildrenCountProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ChildrenCountProperty.GetHashCode().

See Also

Task.Type.ChildrenCountProperty Class | StarTeam Namespace


Task.Type.ChildrenCountProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ChildrenCountProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ChildrenCountProperty.ToString()

See Also

Task.Type.ChildrenCountProperty Class | StarTeam Namespace


Task.Type.ConstraintDateProperty Class

The property type of the Constraint Date property.

For a list of all members of this type, see Task.Type.ConstraintDateProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Task.Type.ConstraintDateProperty

public class Task.Type.ConstraintDateProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ConstraintDateProperty Members | StarTeam Namespace


Task.Type.ConstraintDateProperty Members

Task.Type.ConstraintDateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ConstraintDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ConstraintDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ConstraintDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ConstraintDateProperty Class | StarTeam Namespace


Task.Type.ConstraintDateProperty Properties

The properties of the Task.Type.ConstraintDateProperty class are listed below. For a complete list of Task.Type.ConstraintDateProperty class members, see the Task.Type.ConstraintDateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.ConstraintDateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ConstraintDateProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ConstraintDateProperty Class | StarTeam Namespace


Task.Type.ConstraintDateProperty Methods

The methods of the Task.Type.ConstraintDateProperty class are listed below. For a complete list of Task.Type.ConstraintDateProperty class members, see the Task.Type.ConstraintDateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ConstraintDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ConstraintDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ConstraintDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ConstraintDateProperty Class | StarTeam Namespace


Task.Type.ConstraintDateProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ConstraintDateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ConstraintDateProperty.Equals(obj).

See Also

Task.Type.ConstraintDateProperty Class | StarTeam Namespace


Task.Type.ConstraintDateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ConstraintDateProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ConstraintDateProperty.GetHashCode().

See Also

Task.Type.ConstraintDateProperty Class | StarTeam Namespace


Task.Type.ConstraintDateProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ConstraintDateProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ConstraintDateProperty.ToString()

See Also

Task.Type.ConstraintDateProperty Class | StarTeam Namespace


Task.Type.ConstraintProperty Class

The property type of the Constraint Type property.

For a list of all members of this type, see Task.Type.ConstraintProperty Members.

System.Object
Property
EnumeratedProperty
Task.Type.ConstraintProperty

public class Task.Type.ConstraintProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ConstraintProperty Members | StarTeam Namespace


Task.Type.ConstraintProperty Members

Task.Type.ConstraintProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.ConstraintProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ConstraintProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.ConstraintProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ConstraintProperty Class | StarTeam Namespace


Task.Type.ConstraintProperty Properties

The properties of the Task.Type.ConstraintProperty class are listed below. For a complete list of Task.Type.ConstraintProperty class members, see the Task.Type.ConstraintProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.ConstraintProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ConstraintProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ConstraintProperty Class | StarTeam Namespace


Task.Type.ConstraintProperty Methods

The methods of the Task.Type.ConstraintProperty class are listed below. For a complete list of Task.Type.ConstraintProperty class members, see the Task.Type.ConstraintProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.ConstraintProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ConstraintProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.ConstraintProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ConstraintProperty Class | StarTeam Namespace


Task.Type.ConstraintProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ConstraintProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ConstraintProperty.Equals(obj).

See Also

Task.Type.ConstraintProperty Class | StarTeam Namespace


Task.Type.ConstraintProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Task.Constraint value
);

See Also

Task.Type.ConstraintProperty Class | StarTeam Namespace


Task.Type.ConstraintProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ConstraintProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ConstraintProperty.GetHashCode().

See Also

Task.Type.ConstraintProperty Class | StarTeam Namespace


Task.Type.ConstraintProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ConstraintProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ConstraintProperty.ToString()

See Also

Task.Type.ConstraintProperty Class | StarTeam Namespace


Task.Type.DescriptionProperty Class

The property type of the Description property.

For a list of all members of this type, see Task.Type.DescriptionProperty Members.

System.Object
Property
VectorProperty
TextProperty
Task.Type.DescriptionProperty

public class Task.Type.DescriptionProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.DescriptionProperty Members | StarTeam Namespace


Task.Type.DescriptionProperty Members

Task.Type.DescriptionProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.DescriptionProperty Class | StarTeam Namespace


Task.Type.DescriptionProperty Properties

The properties of the Task.Type.DescriptionProperty class are listed below. For a complete list of Task.Type.DescriptionProperty class members, see the Task.Type.DescriptionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.DescriptionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.DescriptionProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.DescriptionProperty Class | StarTeam Namespace


Task.Type.DescriptionProperty Methods

The methods of the Task.Type.DescriptionProperty class are listed below. For a complete list of Task.Type.DescriptionProperty class members, see the Task.Type.DescriptionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.DescriptionProperty Class | StarTeam Namespace


Task.Type.DescriptionProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.DescriptionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.DescriptionProperty.Equals(obj).

See Also

Task.Type.DescriptionProperty Class | StarTeam Namespace


Task.Type.DescriptionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.DescriptionProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.DescriptionProperty.GetHashCode().

See Also

Task.Type.DescriptionProperty Class | StarTeam Namespace


Task.Type.DescriptionProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.DescriptionProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.DescriptionProperty.ToString()

See Also

Task.Type.DescriptionProperty Class | StarTeam Namespace


Task.Type.DurationProperty Class

The property type of the Duration property.

For a list of all members of this type, see Task.Type.DurationProperty Members.

System.Object
Property
ScalarProperty
TimeSpanProperty
Task.Type.DurationProperty

public class Task.Type.DurationProperty : TimeSpanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.DurationProperty Members | StarTeam Namespace


Task.Type.DurationProperty Members

Task.Type.DurationProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.DurationProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.DurationProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.DurationProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.DurationProperty Class | StarTeam Namespace


Task.Type.DurationProperty Properties

The properties of the Task.Type.DurationProperty class are listed below. For a complete list of Task.Type.DurationProperty class members, see the Task.Type.DurationProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

See Also

Task.Type.DurationProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.DurationProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.DurationProperty Class | StarTeam Namespace


Task.Type.DurationProperty Methods

The methods of the Task.Type.DurationProperty class are listed below. For a complete list of Task.Type.DurationProperty class members, see the Task.Type.DurationProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.DurationProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.DurationProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.DurationProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.DurationProperty Class | StarTeam Namespace


Task.Type.DurationProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.DurationProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.DurationProperty.Equals(obj).

See Also

Task.Type.DurationProperty Class | StarTeam Namespace


Task.Type.DurationProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.DurationProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.DurationProperty.GetHashCode().

See Also

Task.Type.DurationProperty Class | StarTeam Namespace


Task.Type.DurationProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.DurationProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.DurationProperty.ToString()

See Also

Task.Type.DurationProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishProperty Class

The property type of the EstimatedFinish property.

For a list of all members of this type, see Task.Type.EstimatedFinishProperty Members.

System.Object
Property
ScalarProperty
DateProperty
Task.Type.EstimatedFinishProperty

public class Task.Type.EstimatedFinishProperty : DateProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.EstimatedFinishProperty Members | StarTeam Namespace


Task.Type.EstimatedFinishProperty Members

Task.Type.EstimatedFinishProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedFinishProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedFinishProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedFinishProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedFinishProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishProperty Properties

The properties of the Task.Type.EstimatedFinishProperty class are listed below. For a complete list of Task.Type.EstimatedFinishProperty class members, see the Task.Type.EstimatedFinishProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.EstimatedFinishProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.EstimatedFinishProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.EstimatedFinishProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishProperty Methods

The methods of the Task.Type.EstimatedFinishProperty class are listed below. For a complete list of Task.Type.EstimatedFinishProperty class members, see the Task.Type.EstimatedFinishProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedFinishProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedFinishProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedFinishProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedFinishProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.EstimatedFinishProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.EstimatedFinishProperty.Equals(obj).

See Also

Task.Type.EstimatedFinishProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.EstimatedFinishProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.EstimatedFinishProperty.GetHashCode().

See Also

Task.Type.EstimatedFinishProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.EstimatedFinishProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.EstimatedFinishProperty.ToString()

See Also

Task.Type.EstimatedFinishProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishVarianceProperty Class

The property type of the Estimated Finish Variance property.

For a list of all members of this type, see Task.Type.EstimatedFinishVarianceProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.EstimatedFinishVarianceProperty

public class Task.Type.EstimatedFinishVarianceProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.EstimatedFinishVarianceProperty Members | StarTeam Namespace


Task.Type.EstimatedFinishVarianceProperty Members

Task.Type.EstimatedFinishVarianceProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedFinishVarianceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedFinishVarianceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedFinishVarianceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedFinishVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishVarianceProperty Properties

The properties of the Task.Type.EstimatedFinishVarianceProperty class are listed below. For a complete list of Task.Type.EstimatedFinishVarianceProperty class members, see the Task.Type.EstimatedFinishVarianceProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.EstimatedFinishVarianceProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.EstimatedFinishVarianceProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.EstimatedFinishVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishVarianceProperty Methods

The methods of the Task.Type.EstimatedFinishVarianceProperty class are listed below. For a complete list of Task.Type.EstimatedFinishVarianceProperty class members, see the Task.Type.EstimatedFinishVarianceProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedFinishVarianceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedFinishVarianceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedFinishVarianceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedFinishVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishVarianceProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.EstimatedFinishVarianceProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.EstimatedFinishVarianceProperty.Equals(obj).

See Also

Task.Type.EstimatedFinishVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishVarianceProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.EstimatedFinishVarianceProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.EstimatedFinishVarianceProperty.GetHashCode().

See Also

Task.Type.EstimatedFinishVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedFinishVarianceProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.EstimatedFinishVarianceProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.EstimatedFinishVarianceProperty.ToString()

See Also

Task.Type.EstimatedFinishVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursProperty Class

The property type of the Estimated Hours property.

For a list of all members of this type, see Task.Type.EstimatedHoursProperty Members.

System.Object
Property
ScalarProperty
TimeSpanProperty
Task.Type.EstimatedHoursProperty

public class Task.Type.EstimatedHoursProperty : TimeSpanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.EstimatedHoursProperty Members | StarTeam Namespace


Task.Type.EstimatedHoursProperty Members

Task.Type.EstimatedHoursProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedHoursProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedHoursProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedHoursProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedHoursProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursProperty Properties

The properties of the Task.Type.EstimatedHoursProperty class are listed below. For a complete list of Task.Type.EstimatedHoursProperty class members, see the Task.Type.EstimatedHoursProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

See Also

Task.Type.EstimatedHoursProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.EstimatedHoursProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.EstimatedHoursProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursProperty Methods

The methods of the Task.Type.EstimatedHoursProperty class are listed below. For a complete list of Task.Type.EstimatedHoursProperty class members, see the Task.Type.EstimatedHoursProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedHoursProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedHoursProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedHoursProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedHoursProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.EstimatedHoursProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.EstimatedHoursProperty.Equals(obj).

See Also

Task.Type.EstimatedHoursProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.EstimatedHoursProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.EstimatedHoursProperty.GetHashCode().

See Also

Task.Type.EstimatedHoursProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.EstimatedHoursProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.EstimatedHoursProperty.ToString()

See Also

Task.Type.EstimatedHoursProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursVarianceProperty Class

The property type of the EstimatedHoursVariance property

For a list of all members of this type, see Task.Type.EstimatedHoursVarianceProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Task.Type.EstimatedHoursVarianceProperty

public class Task.Type.EstimatedHoursVarianceProperty : DoubleProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.EstimatedHoursVarianceProperty Members | StarTeam Namespace


Task.Type.EstimatedHoursVarianceProperty Members

Task.Type.EstimatedHoursVarianceProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedHoursVarianceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedHoursVarianceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedHoursVarianceProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedHoursVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursVarianceProperty Properties

The properties of the Task.Type.EstimatedHoursVarianceProperty class are listed below. For a complete list of Task.Type.EstimatedHoursVarianceProperty class members, see the Task.Type.EstimatedHoursVarianceProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.EstimatedHoursVarianceProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.EstimatedHoursVarianceProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.EstimatedHoursVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursVarianceProperty Methods

The methods of the Task.Type.EstimatedHoursVarianceProperty class are listed below. For a complete list of Task.Type.EstimatedHoursVarianceProperty class members, see the Task.Type.EstimatedHoursVarianceProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedHoursVarianceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedHoursVarianceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedHoursVarianceProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedHoursVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursVarianceProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.EstimatedHoursVarianceProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.EstimatedHoursVarianceProperty.Equals(obj).

See Also

Task.Type.EstimatedHoursVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursVarianceProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.EstimatedHoursVarianceProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.EstimatedHoursVarianceProperty.GetHashCode().

See Also

Task.Type.EstimatedHoursVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedHoursVarianceProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.EstimatedHoursVarianceProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.EstimatedHoursVarianceProperty.ToString()

See Also

Task.Type.EstimatedHoursVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedStartProperty Class

The property type of the Estimated Start property.

For a list of all members of this type, see Task.Type.EstimatedStartProperty Members.

System.Object
Property
ScalarProperty
DateProperty
Task.Type.EstimatedStartProperty

public class Task.Type.EstimatedStartProperty : DateProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.EstimatedStartProperty Members | StarTeam Namespace


Task.Type.EstimatedStartProperty Members

Task.Type.EstimatedStartProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedStartProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedStartProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedStartProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedStartProperty Class | StarTeam Namespace


Task.Type.EstimatedStartProperty Properties

The properties of the Task.Type.EstimatedStartProperty class are listed below. For a complete list of Task.Type.EstimatedStartProperty class members, see the Task.Type.EstimatedStartProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.EstimatedStartProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.EstimatedStartProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.EstimatedStartProperty Class | StarTeam Namespace


Task.Type.EstimatedStartProperty Methods

The methods of the Task.Type.EstimatedStartProperty class are listed below. For a complete list of Task.Type.EstimatedStartProperty class members, see the Task.Type.EstimatedStartProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedStartProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedStartProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedStartProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedStartProperty Class | StarTeam Namespace


Task.Type.EstimatedStartProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.EstimatedStartProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.EstimatedStartProperty.Equals(obj).

See Also

Task.Type.EstimatedStartProperty Class | StarTeam Namespace


Task.Type.EstimatedStartProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.EstimatedStartProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.EstimatedStartProperty.GetHashCode().

See Also

Task.Type.EstimatedStartProperty Class | StarTeam Namespace


Task.Type.EstimatedStartProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.EstimatedStartProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.EstimatedStartProperty.ToString()

See Also

Task.Type.EstimatedStartProperty Class | StarTeam Namespace


Task.Type.EstimatedStartVarianceProperty Class

The property type of the Estimated Start Variance property.

For a list of all members of this type, see Task.Type.EstimatedStartVarianceProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.EstimatedStartVarianceProperty

public class Task.Type.EstimatedStartVarianceProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.EstimatedStartVarianceProperty Members | StarTeam Namespace


Task.Type.EstimatedStartVarianceProperty Members

Task.Type.EstimatedStartVarianceProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedStartVarianceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedStartVarianceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedStartVarianceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedStartVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedStartVarianceProperty Properties

The properties of the Task.Type.EstimatedStartVarianceProperty class are listed below. For a complete list of Task.Type.EstimatedStartVarianceProperty class members, see the Task.Type.EstimatedStartVarianceProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.EstimatedStartVarianceProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.EstimatedStartVarianceProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.EstimatedStartVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedStartVarianceProperty Methods

The methods of the Task.Type.EstimatedStartVarianceProperty class are listed below. For a complete list of Task.Type.EstimatedStartVarianceProperty class members, see the Task.Type.EstimatedStartVarianceProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.EstimatedStartVarianceProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.EstimatedStartVarianceProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.EstimatedStartVarianceProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.EstimatedStartVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedStartVarianceProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.EstimatedStartVarianceProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.EstimatedStartVarianceProperty.Equals(obj).

See Also

Task.Type.EstimatedStartVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedStartVarianceProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.EstimatedStartVarianceProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.EstimatedStartVarianceProperty.GetHashCode().

See Also

Task.Type.EstimatedStartVarianceProperty Class | StarTeam Namespace


Task.Type.EstimatedStartVarianceProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.EstimatedStartVarianceProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.EstimatedStartVarianceProperty.ToString()

See Also

Task.Type.EstimatedStartVarianceProperty Class | StarTeam Namespace


Task.Type.GUIDProperty Class

The property type of the GUID property.

For a list of all members of this type, see Task.Type.GUIDProperty Members.

System.Object
Property
VectorProperty
TextProperty
Task.Type.GUIDProperty

public class Task.Type.GUIDProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.GUIDProperty Members | StarTeam Namespace


Task.Type.GUIDProperty Members

Task.Type.GUIDProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.GUIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.GUIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.GUIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.GUIDProperty Class | StarTeam Namespace


Task.Type.GUIDProperty Properties

The properties of the Task.Type.GUIDProperty class are listed below. For a complete list of Task.Type.GUIDProperty class members, see the Task.Type.GUIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.GUIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.GUIDProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.GUIDProperty Class | StarTeam Namespace


Task.Type.GUIDProperty Methods

The methods of the Task.Type.GUIDProperty class are listed below. For a complete list of Task.Type.GUIDProperty class members, see the Task.Type.GUIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.GUIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.GUIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.GUIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.GUIDProperty Class | StarTeam Namespace


Task.Type.GUIDProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.GUIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.GUIDProperty.Equals(obj).

See Also

Task.Type.GUIDProperty Class | StarTeam Namespace


Task.Type.GUIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.GUIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.GUIDProperty.GetHashCode().

See Also

Task.Type.GUIDProperty Class | StarTeam Namespace


Task.Type.GUIDProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.GUIDProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.GUIDProperty.ToString()

See Also

Task.Type.GUIDProperty Class | StarTeam Namespace


Task.Type.IsMyTaskProperty Class

The property type of the Is My Task property.

For a list of all members of this type, see Task.Type.IsMyTaskProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Task.Type.IsMyTaskProperty

public class Task.Type.IsMyTaskProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.IsMyTaskProperty Members | StarTeam Namespace


Task.Type.IsMyTaskProperty Members

Task.Type.IsMyTaskProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.IsMyTaskProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.IsMyTaskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.IsMyTaskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.IsMyTaskProperty Class | StarTeam Namespace


Task.Type.IsMyTaskProperty Properties

The properties of the Task.Type.IsMyTaskProperty class are listed below. For a complete list of Task.Type.IsMyTaskProperty class members, see the Task.Type.IsMyTaskProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.IsMyTaskProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.IsMyTaskProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.IsMyTaskProperty Class | StarTeam Namespace


Task.Type.IsMyTaskProperty Methods

The methods of the Task.Type.IsMyTaskProperty class are listed below. For a complete list of Task.Type.IsMyTaskProperty class members, see the Task.Type.IsMyTaskProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.IsMyTaskProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.IsMyTaskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.IsMyTaskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.IsMyTaskProperty Class | StarTeam Namespace


Task.Type.IsMyTaskProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.IsMyTaskProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.IsMyTaskProperty.Equals(obj).

See Also

Task.Type.IsMyTaskProperty Class | StarTeam Namespace


Task.Type.IsMyTaskProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.IsMyTaskProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.IsMyTaskProperty.GetHashCode().

See Also

Task.Type.IsMyTaskProperty Class | StarTeam Namespace


Task.Type.IsMyTaskProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.IsMyTaskProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.IsMyTaskProperty.ToString()

See Also

Task.Type.IsMyTaskProperty Class | StarTeam Namespace


Task.Type.IsReplicatedProperty Class

The property type of the Is Replicated property.

For a list of all members of this type, see Task.Type.IsReplicatedProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.IsReplicatedProperty

public class Task.Type.IsReplicatedProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.IsReplicatedProperty Members | StarTeam Namespace


Task.Type.IsReplicatedProperty Members

Task.Type.IsReplicatedProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.IsReplicatedProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.IsReplicatedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.IsReplicatedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.IsReplicatedProperty Class | StarTeam Namespace


Task.Type.IsReplicatedProperty Properties

The properties of the Task.Type.IsReplicatedProperty class are listed below. For a complete list of Task.Type.IsReplicatedProperty class members, see the Task.Type.IsReplicatedProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.IsReplicatedProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.IsReplicatedProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.IsReplicatedProperty Class | StarTeam Namespace


Task.Type.IsReplicatedProperty Methods

The methods of the Task.Type.IsReplicatedProperty class are listed below. For a complete list of Task.Type.IsReplicatedProperty class members, see the Task.Type.IsReplicatedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.IsReplicatedProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.IsReplicatedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.IsReplicatedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.IsReplicatedProperty Class | StarTeam Namespace


Task.Type.IsReplicatedProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.IsReplicatedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.IsReplicatedProperty.Equals(obj).

See Also

Task.Type.IsReplicatedProperty Class | StarTeam Namespace


Task.Type.IsReplicatedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.IsReplicatedProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.IsReplicatedProperty.GetHashCode().

See Also

Task.Type.IsReplicatedProperty Class | StarTeam Namespace


Task.Type.IsReplicatedProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.IsReplicatedProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.IsReplicatedProperty.ToString()

See Also

Task.Type.IsReplicatedProperty Class | StarTeam Namespace


Task.Type.LifeCycleTypeProperty Class

The property type of the Lifecycle property.

For a list of all members of this type, see Task.Type.LifeCycleTypeProperty Members.

System.Object
Property
EnumeratedProperty
Task.Type.LifeCycleTypeProperty

public class Task.Type.LifeCycleTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.LifeCycleTypeProperty Members | StarTeam Namespace


Task.Type.LifeCycleTypeProperty Members

Task.Type.LifeCycleTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.LifeCycleTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.LifeCycleTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.LifeCycleTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.LifeCycleTypeProperty Class | StarTeam Namespace


Task.Type.LifeCycleTypeProperty Properties

The properties of the Task.Type.LifeCycleTypeProperty class are listed below. For a complete list of Task.Type.LifeCycleTypeProperty class members, see the Task.Type.LifeCycleTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.LifeCycleTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.LifeCycleTypeProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.LifeCycleTypeProperty Class | StarTeam Namespace


Task.Type.LifeCycleTypeProperty Methods

The methods of the Task.Type.LifeCycleTypeProperty class are listed below. For a complete list of Task.Type.LifeCycleTypeProperty class members, see the Task.Type.LifeCycleTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.LifeCycleTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.LifeCycleTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.LifeCycleTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.LifeCycleTypeProperty Class | StarTeam Namespace


Task.Type.LifeCycleTypeProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.LifeCycleTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.LifeCycleTypeProperty.Equals(obj).

See Also

Task.Type.LifeCycleTypeProperty Class | StarTeam Namespace


Task.Type.LifeCycleTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Task.LifeCycleType value
);

See Also

Task.Type.LifeCycleTypeProperty Class | StarTeam Namespace


Task.Type.LifeCycleTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.LifeCycleTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.LifeCycleTypeProperty.GetHashCode().

See Also

Task.Type.LifeCycleTypeProperty Class | StarTeam Namespace


Task.Type.LifeCycleTypeProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.LifeCycleTypeProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.LifeCycleTypeProperty.ToString()

See Also

Task.Type.LifeCycleTypeProperty Class | StarTeam Namespace


Task.Type.MilestoneProperty Class

The property type of the MileStone property.

For a list of all members of this type, see Task.Type.MilestoneProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Task.Type.MilestoneProperty

public class Task.Type.MilestoneProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.MilestoneProperty Members | StarTeam Namespace


Task.Type.MilestoneProperty Members

Task.Type.MilestoneProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.MilestoneProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.MilestoneProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.MilestoneProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.MilestoneProperty Class | StarTeam Namespace


Task.Type.MilestoneProperty Properties

The properties of the Task.Type.MilestoneProperty class are listed below. For a complete list of Task.Type.MilestoneProperty class members, see the Task.Type.MilestoneProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.MilestoneProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.MilestoneProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.MilestoneProperty Class | StarTeam Namespace


Task.Type.MilestoneProperty Methods

The methods of the Task.Type.MilestoneProperty class are listed below. For a complete list of Task.Type.MilestoneProperty class members, see the Task.Type.MilestoneProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.MilestoneProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.MilestoneProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.MilestoneProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.MilestoneProperty Class | StarTeam Namespace


Task.Type.MilestoneProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.MilestoneProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.MilestoneProperty.Equals(obj).

See Also

Task.Type.MilestoneProperty Class | StarTeam Namespace


Task.Type.MilestoneProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.MilestoneProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.MilestoneProperty.GetHashCode().

See Also

Task.Type.MilestoneProperty Class | StarTeam Namespace


Task.Type.MilestoneProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.MilestoneProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.MilestoneProperty.ToString()

See Also

Task.Type.MilestoneProperty Class | StarTeam Namespace


Task.Type.MSProjectFileNameProperty Class

The property type of the MS Project File Name property.

For a list of all members of this type, see Task.Type.MSProjectFileNameProperty Members.

System.Object
Property
VectorProperty
TextProperty
Task.Type.MSProjectFileNameProperty

public class Task.Type.MSProjectFileNameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.MSProjectFileNameProperty Members | StarTeam Namespace


Task.Type.MSProjectFileNameProperty Members

Task.Type.MSProjectFileNameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.MSProjectFileNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.MSProjectFileNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.MSProjectFileNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.MSProjectFileNameProperty Class | StarTeam Namespace


Task.Type.MSProjectFileNameProperty Properties

The properties of the Task.Type.MSProjectFileNameProperty class are listed below. For a complete list of Task.Type.MSProjectFileNameProperty class members, see the Task.Type.MSProjectFileNameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.MSProjectFileNameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.MSProjectFileNameProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.MSProjectFileNameProperty Class | StarTeam Namespace


Task.Type.MSProjectFileNameProperty Methods

The methods of the Task.Type.MSProjectFileNameProperty class are listed below. For a complete list of Task.Type.MSProjectFileNameProperty class members, see the Task.Type.MSProjectFileNameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.MSProjectFileNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.MSProjectFileNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.MSProjectFileNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.MSProjectFileNameProperty Class | StarTeam Namespace


Task.Type.MSProjectFileNameProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.MSProjectFileNameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.MSProjectFileNameProperty.Equals(obj).

See Also

Task.Type.MSProjectFileNameProperty Class | StarTeam Namespace


Task.Type.MSProjectFileNameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.MSProjectFileNameProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.MSProjectFileNameProperty.GetHashCode().

See Also

Task.Type.MSProjectFileNameProperty Class | StarTeam Namespace


Task.Type.MSProjectFileNameProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.MSProjectFileNameProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.MSProjectFileNameProperty.ToString()

See Also

Task.Type.MSProjectFileNameProperty Class | StarTeam Namespace


Task.Type.MSProjectLastUpdateProperty Class

The property type of the MS Project Last Update property.

For a list of all members of this type, see Task.Type.MSProjectLastUpdateProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Task.Type.MSProjectLastUpdateProperty

public class Task.Type.MSProjectLastUpdateProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.MSProjectLastUpdateProperty Members | StarTeam Namespace


Task.Type.MSProjectLastUpdateProperty Members

Task.Type.MSProjectLastUpdateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.MSProjectLastUpdateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.MSProjectLastUpdateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.MSProjectLastUpdateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.MSProjectLastUpdateProperty Class | StarTeam Namespace


Task.Type.MSProjectLastUpdateProperty Properties

The properties of the Task.Type.MSProjectLastUpdateProperty class are listed below. For a complete list of Task.Type.MSProjectLastUpdateProperty class members, see the Task.Type.MSProjectLastUpdateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.MSProjectLastUpdateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.MSProjectLastUpdateProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.MSProjectLastUpdateProperty Class | StarTeam Namespace


Task.Type.MSProjectLastUpdateProperty Methods

The methods of the Task.Type.MSProjectLastUpdateProperty class are listed below. For a complete list of Task.Type.MSProjectLastUpdateProperty class members, see the Task.Type.MSProjectLastUpdateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.MSProjectLastUpdateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.MSProjectLastUpdateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.MSProjectLastUpdateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.MSProjectLastUpdateProperty Class | StarTeam Namespace


Task.Type.MSProjectLastUpdateProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.MSProjectLastUpdateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.MSProjectLastUpdateProperty.Equals(obj).

See Also

Task.Type.MSProjectLastUpdateProperty Class | StarTeam Namespace


Task.Type.MSProjectLastUpdateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.MSProjectLastUpdateProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.MSProjectLastUpdateProperty.GetHashCode().

See Also

Task.Type.MSProjectLastUpdateProperty Class | StarTeam Namespace


Task.Type.MSProjectLastUpdateProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.MSProjectLastUpdateProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.MSProjectLastUpdateProperty.ToString()

See Also

Task.Type.MSProjectLastUpdateProperty Class | StarTeam Namespace


Task.Type.NameProperty Class

The property type of the Name property.

For a list of all members of this type, see Task.Type.NameProperty Members.

System.Object
Property
VectorProperty
TextProperty
Task.Type.NameProperty

public class Task.Type.NameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.NameProperty Members | StarTeam Namespace


Task.Type.NameProperty Members

Task.Type.NameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.NameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.NameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.NameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.NameProperty Class | StarTeam Namespace


Task.Type.NameProperty Properties

The properties of the Task.Type.NameProperty class are listed below. For a complete list of Task.Type.NameProperty class members, see the Task.Type.NameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.NameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.NameProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.NameProperty Class | StarTeam Namespace


Task.Type.NameProperty Methods

The methods of the Task.Type.NameProperty class are listed below. For a complete list of Task.Type.NameProperty class members, see the Task.Type.NameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.NameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.NameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.NameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.NameProperty Class | StarTeam Namespace


Task.Type.NameProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.NameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.NameProperty.Equals(obj).

See Also

Task.Type.NameProperty Class | StarTeam Namespace


Task.Type.NameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.NameProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.NameProperty.GetHashCode().

See Also

Task.Type.NameProperty Class | StarTeam Namespace


Task.Type.NameProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.NameProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.NameProperty.ToString()

See Also

Task.Type.NameProperty Class | StarTeam Namespace


Task.Type.NeedsAttentionProperty Class

The property type of the Needs Attention property.

For a list of all members of this type, see Task.Type.NeedsAttentionProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Task.Type.NeedsAttentionProperty

public class Task.Type.NeedsAttentionProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.NeedsAttentionProperty Members | StarTeam Namespace


Task.Type.NeedsAttentionProperty Members

Task.Type.NeedsAttentionProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.NeedsAttentionProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.NeedsAttentionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.NeedsAttentionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.NeedsAttentionProperty Class | StarTeam Namespace


Task.Type.NeedsAttentionProperty Properties

The properties of the Task.Type.NeedsAttentionProperty class are listed below. For a complete list of Task.Type.NeedsAttentionProperty class members, see the Task.Type.NeedsAttentionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.NeedsAttentionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.NeedsAttentionProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.NeedsAttentionProperty Class | StarTeam Namespace


Task.Type.NeedsAttentionProperty Methods

The methods of the Task.Type.NeedsAttentionProperty class are listed below. For a complete list of Task.Type.NeedsAttentionProperty class members, see the Task.Type.NeedsAttentionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.NeedsAttentionProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.NeedsAttentionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.NeedsAttentionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.NeedsAttentionProperty Class | StarTeam Namespace


Task.Type.NeedsAttentionProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.NeedsAttentionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.NeedsAttentionProperty.Equals(obj).

See Also

Task.Type.NeedsAttentionProperty Class | StarTeam Namespace


Task.Type.NeedsAttentionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.NeedsAttentionProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.NeedsAttentionProperty.GetHashCode().

See Also

Task.Type.NeedsAttentionProperty Class | StarTeam Namespace


Task.Type.NeedsAttentionProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.NeedsAttentionProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.NeedsAttentionProperty.ToString()

See Also

Task.Type.NeedsAttentionProperty Class | StarTeam Namespace


Task.Type.NotesProperty Class

The property type of the Notes property.

For a list of all members of this type, see Task.Type.NotesProperty Members.

System.Object
Property
VectorProperty
TextProperty
Task.Type.NotesProperty

public class Task.Type.NotesProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.NotesProperty Members | StarTeam Namespace


Task.Type.NotesProperty Members

Task.Type.NotesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.NotesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.NotesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.NotesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.NotesProperty Class | StarTeam Namespace


Task.Type.NotesProperty Properties

The properties of the Task.Type.NotesProperty class are listed below. For a complete list of Task.Type.NotesProperty class members, see the Task.Type.NotesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.NotesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.NotesProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.NotesProperty Class | StarTeam Namespace


Task.Type.NotesProperty Methods

The methods of the Task.Type.NotesProperty class are listed below. For a complete list of Task.Type.NotesProperty class members, see the Task.Type.NotesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.NotesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.NotesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.NotesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.NotesProperty Class | StarTeam Namespace


Task.Type.NotesProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.NotesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.NotesProperty.Equals(obj).

See Also

Task.Type.NotesProperty Class | StarTeam Namespace


Task.Type.NotesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.NotesProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.NotesProperty.GetHashCode().

See Also

Task.Type.NotesProperty Class | StarTeam Namespace


Task.Type.NotesProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.NotesProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.NotesProperty.ToString()

See Also

Task.Type.NotesProperty Class | StarTeam Namespace


Task.Type.NumberProperty Class

The property type of the Number property.

For a list of all members of this type, see Task.Type.NumberProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.NumberProperty

public class Task.Type.NumberProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.NumberProperty Members | StarTeam Namespace


Task.Type.NumberProperty Members

Task.Type.NumberProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.NumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.NumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.NumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.NumberProperty Class | StarTeam Namespace


Task.Type.NumberProperty Properties

The properties of the Task.Type.NumberProperty class are listed below. For a complete list of Task.Type.NumberProperty class members, see the Task.Type.NumberProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.NumberProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.NumberProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.NumberProperty Class | StarTeam Namespace


Task.Type.NumberProperty Methods

The methods of the Task.Type.NumberProperty class are listed below. For a complete list of Task.Type.NumberProperty class members, see the Task.Type.NumberProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.NumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.NumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.NumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.NumberProperty Class | StarTeam Namespace


Task.Type.NumberProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.NumberProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.NumberProperty.Equals(obj).

See Also

Task.Type.NumberProperty Class | StarTeam Namespace


Task.Type.NumberProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.NumberProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.NumberProperty.GetHashCode().

See Also

Task.Type.NumberProperty Class | StarTeam Namespace


Task.Type.NumberProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.NumberProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.NumberProperty.ToString()

See Also

Task.Type.NumberProperty Class | StarTeam Namespace


Task.Type.OrderProperty Class

The property type of the Order property

For a list of all members of this type, see Task.Type.OrderProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Task.Type.OrderProperty

public class Task.Type.OrderProperty : DoubleProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.OrderProperty Members | StarTeam Namespace


Task.Type.OrderProperty Members

Task.Type.OrderProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.OrderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.OrderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.OrderProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.OrderProperty Class | StarTeam Namespace


Task.Type.OrderProperty Properties

The properties of the Task.Type.OrderProperty class are listed below. For a complete list of Task.Type.OrderProperty class members, see the Task.Type.OrderProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.OrderProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.OrderProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.OrderProperty Class | StarTeam Namespace


Task.Type.OrderProperty Methods

The methods of the Task.Type.OrderProperty class are listed below. For a complete list of Task.Type.OrderProperty class members, see the Task.Type.OrderProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.OrderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.OrderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.OrderProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.OrderProperty Class | StarTeam Namespace


Task.Type.OrderProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.OrderProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.OrderProperty.Equals(obj).

See Also

Task.Type.OrderProperty Class | StarTeam Namespace


Task.Type.OrderProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.OrderProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.OrderProperty.GetHashCode().

See Also

Task.Type.OrderProperty Class | StarTeam Namespace


Task.Type.OrderProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.OrderProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.OrderProperty.ToString()

See Also

Task.Type.OrderProperty Class | StarTeam Namespace


Task.Type.OriginProperty Class

The property type of the Origin property.

For a list of all members of this type, see Task.Type.OriginProperty Members.

System.Object
Property
EnumeratedProperty
Task.Type.OriginProperty

public class Task.Type.OriginProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.OriginProperty Members | StarTeam Namespace


Task.Type.OriginProperty Members

Task.Type.OriginProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.OriginProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.OriginProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.OriginProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.OriginProperty Class | StarTeam Namespace


Task.Type.OriginProperty Properties

The properties of the Task.Type.OriginProperty class are listed below. For a complete list of Task.Type.OriginProperty class members, see the Task.Type.OriginProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.OriginProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.OriginProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.OriginProperty Class | StarTeam Namespace


Task.Type.OriginProperty Methods

The methods of the Task.Type.OriginProperty class are listed below. For a complete list of Task.Type.OriginProperty class members, see the Task.Type.OriginProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.OriginProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.OriginProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.OriginProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.OriginProperty Class | StarTeam Namespace


Task.Type.OriginProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.OriginProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.OriginProperty.Equals(obj).

See Also

Task.Type.OriginProperty Class | StarTeam Namespace


Task.Type.OriginProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Task.Origin value
);

See Also

Task.Type.OriginProperty Class | StarTeam Namespace


Task.Type.OriginProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.OriginProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.OriginProperty.GetHashCode().

See Also

Task.Type.OriginProperty Class | StarTeam Namespace


Task.Type.OriginProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.OriginProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.OriginProperty.ToString()

See Also

Task.Type.OriginProperty Class | StarTeam Namespace


Task.Type.ParentTaskIDProperty Class

The property type of the Parent Task ID property.

For a list of all members of this type, see Task.Type.ParentTaskIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.ParentTaskIDProperty

public class Task.Type.ParentTaskIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ParentTaskIDProperty Members | StarTeam Namespace


Task.Type.ParentTaskIDProperty Members

Task.Type.ParentTaskIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ParentTaskIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ParentTaskIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ParentTaskIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ParentTaskIDProperty Class | StarTeam Namespace


Task.Type.ParentTaskIDProperty Properties

The properties of the Task.Type.ParentTaskIDProperty class are listed below. For a complete list of Task.Type.ParentTaskIDProperty class members, see the Task.Type.ParentTaskIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.ParentTaskIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ParentTaskIDProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ParentTaskIDProperty Class | StarTeam Namespace


Task.Type.ParentTaskIDProperty Methods

The methods of the Task.Type.ParentTaskIDProperty class are listed below. For a complete list of Task.Type.ParentTaskIDProperty class members, see the Task.Type.ParentTaskIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ParentTaskIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ParentTaskIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ParentTaskIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ParentTaskIDProperty Class | StarTeam Namespace


Task.Type.ParentTaskIDProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ParentTaskIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ParentTaskIDProperty.Equals(obj).

See Also

Task.Type.ParentTaskIDProperty Class | StarTeam Namespace


Task.Type.ParentTaskIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ParentTaskIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ParentTaskIDProperty.GetHashCode().

See Also

Task.Type.ParentTaskIDProperty Class | StarTeam Namespace


Task.Type.ParentTaskIDProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ParentTaskIDProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ParentTaskIDProperty.ToString()

See Also

Task.Type.ParentTaskIDProperty Class | StarTeam Namespace


Task.Type.PercentCompleteProperty Class

The property type of the Percent Complete property.

For a list of all members of this type, see Task.Type.PercentCompleteProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.PercentCompleteProperty

public class Task.Type.PercentCompleteProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.PercentCompleteProperty Members | StarTeam Namespace


Task.Type.PercentCompleteProperty Members

Task.Type.PercentCompleteProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.PercentCompleteProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.PercentCompleteProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.PercentCompleteProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.PercentCompleteProperty Class | StarTeam Namespace


Task.Type.PercentCompleteProperty Properties

The properties of the Task.Type.PercentCompleteProperty class are listed below. For a complete list of Task.Type.PercentCompleteProperty class members, see the Task.Type.PercentCompleteProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.PercentCompleteProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.PercentCompleteProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.PercentCompleteProperty Class | StarTeam Namespace


Task.Type.PercentCompleteProperty Methods

The methods of the Task.Type.PercentCompleteProperty class are listed below. For a complete list of Task.Type.PercentCompleteProperty class members, see the Task.Type.PercentCompleteProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.PercentCompleteProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.PercentCompleteProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.PercentCompleteProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.PercentCompleteProperty Class | StarTeam Namespace


Task.Type.PercentCompleteProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.PercentCompleteProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.PercentCompleteProperty.Equals(obj).

See Also

Task.Type.PercentCompleteProperty Class | StarTeam Namespace


Task.Type.PercentCompleteProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.PercentCompleteProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.PercentCompleteProperty.GetHashCode().

See Also

Task.Type.PercentCompleteProperty Class | StarTeam Namespace


Task.Type.PercentCompleteProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.PercentCompleteProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.PercentCompleteProperty.ToString()

See Also

Task.Type.PercentCompleteProperty Class | StarTeam Namespace


Task.Type.PriorityProperty Class

The property type of the Priority property.

For a list of all members of this type, see Task.Type.PriorityProperty Members.

System.Object
Property
EnumeratedProperty
Task.Type.PriorityProperty

public class Task.Type.PriorityProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.PriorityProperty Members | StarTeam Namespace


Task.Type.PriorityProperty Members

Task.Type.PriorityProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.PriorityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.PriorityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.PriorityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.PriorityProperty Class | StarTeam Namespace


Task.Type.PriorityProperty Properties

The properties of the Task.Type.PriorityProperty class are listed below. For a complete list of Task.Type.PriorityProperty class members, see the Task.Type.PriorityProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.PriorityProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.PriorityProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.PriorityProperty Class | StarTeam Namespace


Task.Type.PriorityProperty Methods

The methods of the Task.Type.PriorityProperty class are listed below. For a complete list of Task.Type.PriorityProperty class members, see the Task.Type.PriorityProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.PriorityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.PriorityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.PriorityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.PriorityProperty Class | StarTeam Namespace


Task.Type.PriorityProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.PriorityProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.PriorityProperty.Equals(obj).

See Also

Task.Type.PriorityProperty Class | StarTeam Namespace


Task.Type.PriorityProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Task.Priority value
);

See Also

Task.Type.PriorityProperty Class | StarTeam Namespace


Task.Type.PriorityProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.PriorityProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.PriorityProperty.GetHashCode().

See Also

Task.Type.PriorityProperty Class | StarTeam Namespace


Task.Type.PriorityProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.PriorityProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.PriorityProperty.ToString()

See Also

Task.Type.PriorityProperty Class | StarTeam Namespace


Task.Type.ProcessUsageProperty Class

The property type of the ProcessUsage property

For a list of all members of this type, see Task.Type.ProcessUsageProperty Members.

System.Object
Property
EnumeratedProperty
Task.Type.ProcessUsageProperty

public class Task.Type.ProcessUsageProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ProcessUsageProperty Members | StarTeam Namespace


Task.Type.ProcessUsageProperty Members

Task.Type.ProcessUsageProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.ProcessUsageProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ProcessUsageProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.ProcessUsageProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ProcessUsageProperty Class | StarTeam Namespace


Task.Type.ProcessUsageProperty Properties

The properties of the Task.Type.ProcessUsageProperty class are listed below. For a complete list of Task.Type.ProcessUsageProperty class members, see the Task.Type.ProcessUsageProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.ProcessUsageProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ProcessUsageProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ProcessUsageProperty Class | StarTeam Namespace


Task.Type.ProcessUsageProperty Methods

The methods of the Task.Type.ProcessUsageProperty class are listed below. For a complete list of Task.Type.ProcessUsageProperty class members, see the Task.Type.ProcessUsageProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.ProcessUsageProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ProcessUsageProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.ProcessUsageProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ProcessUsageProperty Class | StarTeam Namespace


Task.Type.ProcessUsageProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ProcessUsageProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ProcessUsageProperty.Equals(obj).

See Also

Task.Type.ProcessUsageProperty Class | StarTeam Namespace


Task.Type.ProcessUsageProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Task.ProcessUsage value
);

See Also

Task.Type.ProcessUsageProperty Class | StarTeam Namespace


Task.Type.ProcessUsageProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ProcessUsageProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ProcessUsageProperty.GetHashCode().

See Also

Task.Type.ProcessUsageProperty Class | StarTeam Namespace


Task.Type.ProcessUsageProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ProcessUsageProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ProcessUsageProperty.ToString()

See Also

Task.Type.ProcessUsageProperty Class | StarTeam Namespace


Task.Type.PropertyCollection Class

The PropertyCollection of a Task

For a list of all members of this type, see Task.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Task.Type.PropertyCollection

public class Task.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.PropertyCollection Members | StarTeam Namespace


Task.Type.PropertyCollection Members

Task.Type.PropertyCollection overview

Public Instance Properties

ACTUAL_FINISH |
ACTUAL_HOURS |
ACTUAL_START |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
ATTENTION_NOTES |
BLOCKED |
CHILDREN_COUNT |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
CONSTRAINT |
CONSTRAINT_DATE |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
DURATION |
END_MODIFIED_TIME |
ESTIMATED_FINISH |
ESTIMATED_FINISH_VARIANCE |
ESTIMATED_HOURS |
ESTIMATED_HOURS_VARIANCE |
ESTIMATED_START |
ESTIMATED_START_VARIANCE |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
GUID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_CHECKED (inherited from PropertyCollection) |
IS_LEAF |
IS_MY_TASK |
IS_READ_ONLY |
IS_REPLICATED |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
LIFECYCLETYPE |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MILESTONE |
MODIFIED_TIME |
MODIFIED_USER_ID |
MSPROJECT_FILENAME |
MSPROJECT_LAST_UPDATE |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NEEDS_ATTENTION |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
NOTES |
NUMBER |
ORDER |
ORIGIN |
PARENT_TASK_ID |
PERCENT_COMPLETE |
PRIORITY |
PROCESS_USAGE |
RESOURCE_COUNT |
RESOURCE_NAMES |
RESOURCES |
RESPONSIBILITY |
REVISION_FLAGS |
REVISION_NUMBER |
RICH_DESCRIPTION |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
STORY |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TASK_TYPE |
TEAM |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNIQUE_ID |
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WBS_CODE |
WORK_DEPENDENCY_LAST_UPDATE |
WORK_RECORD_COUNT |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Task.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Task.Type.PropertyCollection.

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


Task.Type.PropertyCollection Properties

The properties of the Task.Type.PropertyCollection class are listed below. For a complete list of Task.Type.PropertyCollection class members, see the Task.Type.PropertyCollection Members topic.

Public Instance Properties

ACTUAL_FINISH |
ACTUAL_HOURS |
ACTUAL_START |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
ATTENTION_NOTES |
BLOCKED |
CHILDREN_COUNT |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
CONSTRAINT |
CONSTRAINT_DATE |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
DURATION |
END_MODIFIED_TIME |
ESTIMATED_FINISH |
ESTIMATED_FINISH_VARIANCE |
ESTIMATED_HOURS |
ESTIMATED_HOURS_VARIANCE |
ESTIMATED_START |
ESTIMATED_START_VARIANCE |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
GUID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_CHECKED (inherited from PropertyCollection) |
IS_LEAF |
IS_MY_TASK |
IS_READ_ONLY |
IS_REPLICATED |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
LIFECYCLETYPE |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MILESTONE |
MODIFIED_TIME |
MODIFIED_USER_ID |
MSPROJECT_FILENAME |
MSPROJECT_LAST_UPDATE |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NEEDS_ATTENTION |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
NOTES |
NUMBER |
ORDER |
ORIGIN |
PARENT_TASK_ID |
PERCENT_COMPLETE |
PRIORITY |
PROCESS_USAGE |
RESOURCE_COUNT |
RESOURCE_NAMES |
RESOURCES |
RESPONSIBILITY |
REVISION_FLAGS |
REVISION_NUMBER |
RICH_DESCRIPTION |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
STORY |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TASK_TYPE |
TEAM |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNIQUE_ID |
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WBS_CODE |
WORK_DEPENDENCY_LAST_UPDATE |
WORK_RECORD_COUNT |

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ACTUAL_FINISH Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ACTUAL_FINISH Property

public Task.Type.ActualFinishProperty ACTUAL_FINISH {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ACTUAL_HOURS Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ACTUAL_HOURS Property

public Task.Type.ActualHoursProperty ACTUAL_HOURS {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ACTUAL_START Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ACTUAL_START Property

public Task.Type.ActualStartProperty ACTUAL_START {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ATTENTION_NOTES Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ATTENTION_NOTES Property

public Task.Type.AttentionNotesProperty ATTENTION_NOTES {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


BLOCKED Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.BLOCKED Property

public Task.Type.BlockedProperty BLOCKED {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


CHILDREN_COUNT Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.CHILDREN_COUNT Property

public Task.Type.ChildrenCountProperty CHILDREN_COUNT {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


CONSTRAINT Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.CONSTRAINT Property

public Task.Type.ConstraintProperty CONSTRAINT {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


CONSTRAINT_DATE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.CONSTRAINT_DATE Property

public Task.Type.ConstraintDateProperty CONSTRAINT_DATE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.DESCRIPTION Property

public Task.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


DURATION Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.DURATION Property

public Task.Type.DurationProperty DURATION {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ESTIMATED_FINISH Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ESTIMATED_FINISH Property

public Task.Type.EstimatedFinishProperty ESTIMATED_FINISH {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ESTIMATED_FINISH_VARIANCE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ESTIMATED_FINISH_VARIANCE Property

public Task.Type.EstimatedFinishVarianceProperty ESTIMATED_FINISH_VARIANCE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ESTIMATED_HOURS Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ESTIMATED_HOURS Property

public Task.Type.EstimatedHoursProperty ESTIMATED_HOURS {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ESTIMATED_HOURS_VARIANCE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ESTIMATED_HOURS_VARIANCE Property

public Task.Type.EstimatedHoursVarianceProperty ESTIMATED_HOURS_VARIANCE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ESTIMATED_START Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ESTIMATED_START Property

public Task.Type.EstimatedStartProperty ESTIMATED_START {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ESTIMATED_START_VARIANCE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ESTIMATED_START_VARIANCE Property

public Task.Type.EstimatedStartVarianceProperty ESTIMATED_START_VARIANCE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_PATH Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.FOLDER_PATH Property

public TrackedObject.Type.FolderPathProperty FOLDER_PATH {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


GUID Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.GUID Property

public Task.Type.GUIDProperty GUID {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


IS_BOOKMARKED Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.IS_BOOKMARKED Property

public ViewMember.Type.IsBookmarkedProperty IS_BOOKMARKED {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


IS_LEAF Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.IS_LEAF Property

public TreeItem.Type.IsLeafProperty IS_LEAF {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


IS_MY_TASK Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.IS_MY_TASK Property

public Task.Type.IsMyTaskProperty IS_MY_TASK {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


IS_REPLICATED Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.IS_REPLICATED Property

public Task.Type.IsReplicatedProperty IS_REPLICATED {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


IS_UNREAD Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.IS_UNREAD Property

public ViewMember.Type.IsUnreadProperty IS_UNREAD {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


LIFECYCLETYPE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.LIFECYCLETYPE Property

public Task.Type.LifeCycleTypeProperty LIFECYCLETYPE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


MILESTONE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.MILESTONE Property

public Task.Type.MilestoneProperty MILESTONE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_USER_ID Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.MODIFIED_USER_ID Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_USER_ID {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


MSPROJECT_FILENAME Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.MSPROJECT_FILENAME Property

public Task.Type.MSProjectFileNameProperty MSPROJECT_FILENAME {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


MSPROJECT_LAST_UPDATE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.MSPROJECT_LAST_UPDATE Property

public Task.Type.MSProjectLastUpdateProperty MSPROJECT_LAST_UPDATE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.NAME Property

public Task.Type.NameProperty NAME {get;}

Property Value

internal name for this property

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


NEEDS_ATTENTION Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.NEEDS_ATTENTION Property

public Task.Type.NeedsAttentionProperty NEEDS_ATTENTION {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


NEW_REVISION_COMMENT Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.NEW_REVISION_COMMENT Property

public Item.Type.NewRevisionCommentProperty NEW_REVISION_COMMENT {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


NOTES Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.NOTES Property

public Task.Type.NotesProperty NOTES {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


NUMBER Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.NUMBER Property

public Task.Type.NumberProperty NUMBER {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ORDER Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ORDER Property

public Task.Type.OrderProperty ORDER {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


ORIGIN Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.ORIGIN Property

public Task.Type.OriginProperty ORIGIN {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


PARENT_TASK_ID Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.PARENT_TASK_ID Property

public Task.Type.ParentTaskIDProperty PARENT_TASK_ID {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


PERCENT_COMPLETE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.PERCENT_COMPLETE Property

public Task.Type.PercentCompleteProperty PERCENT_COMPLETE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


PRIORITY Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.PRIORITY Property

public Task.Type.PriorityProperty PRIORITY {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


PROCESS_USAGE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.PROCESS_USAGE Property

public Task.Type.ProcessUsageProperty PROCESS_USAGE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


RESOURCE_COUNT Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.RESOURCE_COUNT Property

public Task.Type.ResourceCountProperty RESOURCE_COUNT {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


RESOURCE_NAMES Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.RESOURCE_NAMES Property

public Task.Type.ResourceNamesProperty RESOURCE_NAMES {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


RESOURCES Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.RESOURCES Property

public Task.Type.ResourcesProperty RESOURCES {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


RESPONSIBILITY Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.RESPONSIBILITY Property

public Task.Type.ResponsibilityProperty RESPONSIBILITY {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


RICH_DESCRIPTION Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.RICH_DESCRIPTION Property

public TreeItem.Type.RichDescriptionProperty RICH_DESCRIPTION {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.STATUS Property

public Task.Type.StatusProperty STATUS {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


STORY Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.STORY Property

public Task.Type.StoryProperty STORY {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


TASK_TYPE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.TASK_TYPE Property

public Task.Type.TaskTypeProperty TASK_TYPE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


TEAM Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.TEAM Property

public Item.Type.TeamProperty TEAM {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


UNIQUE_ID Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.UNIQUE_ID Property

public Task.Type.UniqueIDProperty UNIQUE_ID {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.VERSION_METADATA Property

public Item.Type.VersionMetadataProperty VERSION_METADATA {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA_IDS Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.VERSION_METADATA_IDS Property

public Item.Type.VersionMetadataIDsProperty VERSION_METADATA_IDS {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


WBS_CODE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.WBS_CODE Property

public Task.Type.WBSCodeProperty WBS_CODE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


WORK_DEPENDENCY_LAST_UPDATE Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.WORK_DEPENDENCY_LAST_UPDATE Property

public Task.Type.WorkDependencyLastUpdateProperty WORK_DEPENDENCY_LAST_UPDATE {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


WORK_RECORD_COUNT Property

Borland StarTeam SDK for .NET

Task.Type.PropertyCollection.WORK_RECORD_COUNT Property

public Task.Type.WorkRecordCountProperty WORK_RECORD_COUNT {get;}

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


Task.Type.PropertyCollection Methods

The methods of the Task.Type.PropertyCollection class are listed below. For a complete list of Task.Type.PropertyCollection class members, see the Task.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Task.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Task.Type.PropertyCollection.

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


Task.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Task.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.PropertyCollection.Equals(obj).

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


Task.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.PropertyCollection.GetHashCode().

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


Task.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Task.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Task.Type.PropertyCollection.ToString()

See Also

Task.Type.PropertyCollection Class | StarTeam Namespace


Task.Type.ResourceCountProperty Class

The property type of the Resource Count property.

For a list of all members of this type, see Task.Type.ResourceCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.ResourceCountProperty

public class Task.Type.ResourceCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ResourceCountProperty Members | StarTeam Namespace


Task.Type.ResourceCountProperty Members

Task.Type.ResourceCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ResourceCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ResourceCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ResourceCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ResourceCountProperty Class | StarTeam Namespace


Task.Type.ResourceCountProperty Properties

The properties of the Task.Type.ResourceCountProperty class are listed below. For a complete list of Task.Type.ResourceCountProperty class members, see the Task.Type.ResourceCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.ResourceCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ResourceCountProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ResourceCountProperty Class | StarTeam Namespace


Task.Type.ResourceCountProperty Methods

The methods of the Task.Type.ResourceCountProperty class are listed below. For a complete list of Task.Type.ResourceCountProperty class members, see the Task.Type.ResourceCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ResourceCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ResourceCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ResourceCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ResourceCountProperty Class | StarTeam Namespace


Task.Type.ResourceCountProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ResourceCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ResourceCountProperty.Equals(obj).

See Also

Task.Type.ResourceCountProperty Class | StarTeam Namespace


Task.Type.ResourceCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ResourceCountProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ResourceCountProperty.GetHashCode().

See Also

Task.Type.ResourceCountProperty Class | StarTeam Namespace


Task.Type.ResourceCountProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ResourceCountProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ResourceCountProperty.ToString()

See Also

Task.Type.ResourceCountProperty Class | StarTeam Namespace


Task.Type.ResourceNamesProperty Class

The property type of the Resource Names property.

For a list of all members of this type, see Task.Type.ResourceNamesProperty Members.

System.Object
Property
VectorProperty
TextProperty
Task.Type.ResourceNamesProperty

public class Task.Type.ResourceNamesProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ResourceNamesProperty Members | StarTeam Namespace


Task.Type.ResourceNamesProperty Members

Task.Type.ResourceNamesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ResourceNamesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ResourceNamesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ResourceNamesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ResourceNamesProperty Class | StarTeam Namespace


Task.Type.ResourceNamesProperty Properties

The properties of the Task.Type.ResourceNamesProperty class are listed below. For a complete list of Task.Type.ResourceNamesProperty class members, see the Task.Type.ResourceNamesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.ResourceNamesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ResourceNamesProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ResourceNamesProperty Class | StarTeam Namespace


Task.Type.ResourceNamesProperty Methods

The methods of the Task.Type.ResourceNamesProperty class are listed below. For a complete list of Task.Type.ResourceNamesProperty class members, see the Task.Type.ResourceNamesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ResourceNamesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ResourceNamesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ResourceNamesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ResourceNamesProperty Class | StarTeam Namespace


Task.Type.ResourceNamesProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ResourceNamesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ResourceNamesProperty.Equals(obj).

See Also

Task.Type.ResourceNamesProperty Class | StarTeam Namespace


Task.Type.ResourceNamesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ResourceNamesProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ResourceNamesProperty.GetHashCode().

See Also

Task.Type.ResourceNamesProperty Class | StarTeam Namespace


Task.Type.ResourceNamesProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ResourceNamesProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ResourceNamesProperty.ToString()

See Also

Task.Type.ResourceNamesProperty Class | StarTeam Namespace


Task.Type.ResourcesProperty Class

The property type of the Resources property.

For a list of all members of this type, see Task.Type.ResourcesProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Task.Type.ResourcesProperty

public class Task.Type.ResourcesProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ResourcesProperty Members | StarTeam Namespace


Task.Type.ResourcesProperty Members

Task.Type.ResourcesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ResourcesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ResourcesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ResourcesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ResourcesProperty Class | StarTeam Namespace


Task.Type.ResourcesProperty Properties

The properties of the Task.Type.ResourcesProperty class are listed below. For a complete list of Task.Type.ResourcesProperty class members, see the Task.Type.ResourcesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Task.Type.ResourcesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ResourcesProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ResourcesProperty Class | StarTeam Namespace


Task.Type.ResourcesProperty Methods

The methods of the Task.Type.ResourcesProperty class are listed below. For a complete list of Task.Type.ResourcesProperty class members, see the Task.Type.ResourcesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ResourcesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ResourcesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ResourcesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ResourcesProperty Class | StarTeam Namespace


Task.Type.ResourcesProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ResourcesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ResourcesProperty.Equals(obj).

See Also

Task.Type.ResourcesProperty Class | StarTeam Namespace


Task.Type.ResourcesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ResourcesProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ResourcesProperty.GetHashCode().

See Also

Task.Type.ResourcesProperty Class | StarTeam Namespace


Task.Type.ResourcesProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ResourcesProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ResourcesProperty.ToString()

See Also

Task.Type.ResourcesProperty Class | StarTeam Namespace


Task.Type.ResponsibilityProperty Class

The property type of the Responsibility property.

For a list of all members of this type, see Task.Type.ResponsibilityProperty Members.

System.Object
Property
ObjectProperty
Task.Type.ResponsibilityProperty

public class Task.Type.ResponsibilityProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.ResponsibilityProperty Members | StarTeam Namespace


Task.Type.ResponsibilityProperty Members

Task.Type.ResponsibilityProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ResponsibilityProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ResponsibilityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ResponsibilityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ResponsibilityProperty Class | StarTeam Namespace


Task.Type.ResponsibilityProperty Properties

The properties of the Task.Type.ResponsibilityProperty class are listed below. For a complete list of Task.Type.ResponsibilityProperty class members, see the Task.Type.ResponsibilityProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Task.Type.ResponsibilityProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.ResponsibilityProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.ResponsibilityProperty Class | StarTeam Namespace


Task.Type.ResponsibilityProperty Methods

The methods of the Task.Type.ResponsibilityProperty class are listed below. For a complete list of Task.Type.ResponsibilityProperty class members, see the Task.Type.ResponsibilityProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.ResponsibilityProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.ResponsibilityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.ResponsibilityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.ResponsibilityProperty Class | StarTeam Namespace


Task.Type.ResponsibilityProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.ResponsibilityProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.ResponsibilityProperty.Equals(obj).

See Also

Task.Type.ResponsibilityProperty Class | StarTeam Namespace


Task.Type.ResponsibilityProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.ResponsibilityProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.ResponsibilityProperty.GetHashCode().

See Also

Task.Type.ResponsibilityProperty Class | StarTeam Namespace


Task.Type.ResponsibilityProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.ResponsibilityProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.ResponsibilityProperty.ToString()

See Also

Task.Type.ResponsibilityProperty Class | StarTeam Namespace


Task.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see Task.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
Task.Type.StatusProperty

public class Task.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.StatusProperty Members | StarTeam Namespace


Task.Type.StatusProperty Members

Task.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.StatusProperty Class | StarTeam Namespace


Task.Type.StatusProperty Properties

The properties of the Task.Type.StatusProperty class are listed below. For a complete list of Task.Type.StatusProperty class members, see the Task.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.StatusProperty Class | StarTeam Namespace


Task.Type.StatusProperty Methods

The methods of the Task.Type.StatusProperty class are listed below. For a complete list of Task.Type.StatusProperty class members, see the Task.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.StatusProperty Class | StarTeam Namespace


Task.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.StatusProperty.Equals(obj).

See Also

Task.Type.StatusProperty Class | StarTeam Namespace


Task.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Task.Status value
);

See Also

Task.Type.StatusProperty Class | StarTeam Namespace


Task.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.StatusProperty.GetHashCode().

See Also

Task.Type.StatusProperty Class | StarTeam Namespace


Task.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.StatusProperty.ToString()

See Also

Task.Type.StatusProperty Class | StarTeam Namespace


Task.Type.StoryProperty Class

The property type of the Story property

For a list of all members of this type, see Task.Type.StoryProperty Members.

System.Object
Property
ObjectProperty
Task.Type.StoryProperty

public class Task.Type.StoryProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.StoryProperty Members | StarTeam Namespace


Task.Type.StoryProperty Members

Task.Type.StoryProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.StoryProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.StoryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.StoryProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.StoryProperty Class | StarTeam Namespace


Task.Type.StoryProperty Properties

The properties of the Task.Type.StoryProperty class are listed below. For a complete list of Task.Type.StoryProperty class members, see the Task.Type.StoryProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

Task.Type.StoryProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.StoryProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.StoryProperty Class | StarTeam Namespace


Task.Type.StoryProperty Methods

The methods of the Task.Type.StoryProperty class are listed below. For a complete list of Task.Type.StoryProperty class members, see the Task.Type.StoryProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.StoryProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.StoryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.StoryProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.StoryProperty Class | StarTeam Namespace


Task.Type.StoryProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.StoryProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.StoryProperty.Equals(obj).

See Also

Task.Type.StoryProperty Class | StarTeam Namespace


Task.Type.StoryProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.StoryProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.StoryProperty.GetHashCode().

See Also

Task.Type.StoryProperty Class | StarTeam Namespace


Task.Type.StoryProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.StoryProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.StoryProperty.ToString()

See Also

Task.Type.StoryProperty Class | StarTeam Namespace


Task.Type.TaskTypeProperty Class

The property type of the Task Type property.

For a list of all members of this type, see Task.Type.TaskTypeProperty Members.

System.Object
Property
EnumeratedProperty
Task.Type.TaskTypeProperty

public class Task.Type.TaskTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.TaskTypeProperty Members | StarTeam Namespace


Task.Type.TaskTypeProperty Members

Task.Type.TaskTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.TaskTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.TaskTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.TaskTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.TaskTypeProperty Class | StarTeam Namespace


Task.Type.TaskTypeProperty Properties

The properties of the Task.Type.TaskTypeProperty class are listed below. For a complete list of Task.Type.TaskTypeProperty class members, see the Task.Type.TaskTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Task.Type.TaskTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.TaskTypeProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.TaskTypeProperty Class | StarTeam Namespace


Task.Type.TaskTypeProperty Methods

The methods of the Task.Type.TaskTypeProperty class are listed below. For a complete list of Task.Type.TaskTypeProperty class members, see the Task.Type.TaskTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Task.Type.TaskTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.TaskTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Task.Type.TaskTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.TaskTypeProperty Class | StarTeam Namespace


Task.Type.TaskTypeProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.TaskTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.TaskTypeProperty.Equals(obj).

See Also

Task.Type.TaskTypeProperty Class | StarTeam Namespace


Task.Type.TaskTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Task.TaskType value
);

See Also

Task.Type.TaskTypeProperty Class | StarTeam Namespace


Task.Type.TaskTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.TaskTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.TaskTypeProperty.GetHashCode().

See Also

Task.Type.TaskTypeProperty Class | StarTeam Namespace


Task.Type.TaskTypeProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.TaskTypeProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.TaskTypeProperty.ToString()

See Also

Task.Type.TaskTypeProperty Class | StarTeam Namespace


Task.Type.UniqueIDProperty Class

The property type of the Unique ID property.

For a list of all members of this type, see Task.Type.UniqueIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.UniqueIDProperty

public class Task.Type.UniqueIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.UniqueIDProperty Members | StarTeam Namespace


Task.Type.UniqueIDProperty Members

Task.Type.UniqueIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.UniqueIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.UniqueIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.UniqueIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.UniqueIDProperty Class | StarTeam Namespace


Task.Type.UniqueIDProperty Properties

The properties of the Task.Type.UniqueIDProperty class are listed below. For a complete list of Task.Type.UniqueIDProperty class members, see the Task.Type.UniqueIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.UniqueIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.UniqueIDProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.UniqueIDProperty Class | StarTeam Namespace


Task.Type.UniqueIDProperty Methods

The methods of the Task.Type.UniqueIDProperty class are listed below. For a complete list of Task.Type.UniqueIDProperty class members, see the Task.Type.UniqueIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.UniqueIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.UniqueIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.UniqueIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.UniqueIDProperty Class | StarTeam Namespace


Task.Type.UniqueIDProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.UniqueIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.UniqueIDProperty.Equals(obj).

See Also

Task.Type.UniqueIDProperty Class | StarTeam Namespace


Task.Type.UniqueIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.UniqueIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.UniqueIDProperty.GetHashCode().

See Also

Task.Type.UniqueIDProperty Class | StarTeam Namespace


Task.Type.UniqueIDProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.UniqueIDProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.UniqueIDProperty.ToString()

See Also

Task.Type.UniqueIDProperty Class | StarTeam Namespace


Task.Type.WBSCodeProperty Class

The property type of the WBS Code property.

For a list of all members of this type, see Task.Type.WBSCodeProperty Members.

System.Object
Property
VectorProperty
TextProperty
Task.Type.WBSCodeProperty

public class Task.Type.WBSCodeProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.WBSCodeProperty Members | StarTeam Namespace


Task.Type.WBSCodeProperty Members

Task.Type.WBSCodeProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.WBSCodeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.WBSCodeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.WBSCodeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.WBSCodeProperty Class | StarTeam Namespace


Task.Type.WBSCodeProperty Properties

The properties of the Task.Type.WBSCodeProperty class are listed below. For a complete list of Task.Type.WBSCodeProperty class members, see the Task.Type.WBSCodeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.WBSCodeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.WBSCodeProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.WBSCodeProperty Class | StarTeam Namespace


Task.Type.WBSCodeProperty Methods

The methods of the Task.Type.WBSCodeProperty class are listed below. For a complete list of Task.Type.WBSCodeProperty class members, see the Task.Type.WBSCodeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.WBSCodeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.WBSCodeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.WBSCodeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.WBSCodeProperty Class | StarTeam Namespace


Task.Type.WBSCodeProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.WBSCodeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.WBSCodeProperty.Equals(obj).

See Also

Task.Type.WBSCodeProperty Class | StarTeam Namespace


Task.Type.WBSCodeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.WBSCodeProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.WBSCodeProperty.GetHashCode().

See Also

Task.Type.WBSCodeProperty Class | StarTeam Namespace


Task.Type.WBSCodeProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.WBSCodeProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.WBSCodeProperty.ToString()

See Also

Task.Type.WBSCodeProperty Class | StarTeam Namespace


Task.Type.WorkDependencyLastUpdateProperty Class

The property type of the WorkDependency Last Update property.

For a list of all members of this type, see Task.Type.WorkDependencyLastUpdateProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
Task.Type.WorkDependencyLastUpdateProperty

public class Task.Type.WorkDependencyLastUpdateProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.WorkDependencyLastUpdateProperty Members | StarTeam Namespace


Task.Type.WorkDependencyLastUpdateProperty Members

Task.Type.WorkDependencyLastUpdateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.WorkDependencyLastUpdateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.WorkDependencyLastUpdateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.WorkDependencyLastUpdateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.WorkDependencyLastUpdateProperty Class | StarTeam Namespace


Task.Type.WorkDependencyLastUpdateProperty Properties

The properties of the Task.Type.WorkDependencyLastUpdateProperty class are listed below. For a complete list of Task.Type.WorkDependencyLastUpdateProperty class members, see the Task.Type.WorkDependencyLastUpdateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.WorkDependencyLastUpdateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.WorkDependencyLastUpdateProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.WorkDependencyLastUpdateProperty Class | StarTeam Namespace


Task.Type.WorkDependencyLastUpdateProperty Methods

The methods of the Task.Type.WorkDependencyLastUpdateProperty class are listed below. For a complete list of Task.Type.WorkDependencyLastUpdateProperty class members, see the Task.Type.WorkDependencyLastUpdateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.WorkDependencyLastUpdateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.WorkDependencyLastUpdateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.WorkDependencyLastUpdateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.WorkDependencyLastUpdateProperty Class | StarTeam Namespace


Task.Type.WorkDependencyLastUpdateProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.WorkDependencyLastUpdateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.WorkDependencyLastUpdateProperty.Equals(obj).

See Also

Task.Type.WorkDependencyLastUpdateProperty Class | StarTeam Namespace


Task.Type.WorkDependencyLastUpdateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.WorkDependencyLastUpdateProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.WorkDependencyLastUpdateProperty.GetHashCode().

See Also

Task.Type.WorkDependencyLastUpdateProperty Class | StarTeam Namespace


Task.Type.WorkDependencyLastUpdateProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.WorkDependencyLastUpdateProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.WorkDependencyLastUpdateProperty.ToString()

See Also

Task.Type.WorkDependencyLastUpdateProperty Class | StarTeam Namespace


Task.Type.WorkRecordCountProperty Class

The property type of the WorkRecord Count property.

For a list of all members of this type, see Task.Type.WorkRecordCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Task.Type.WorkRecordCountProperty

public class Task.Type.WorkRecordCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.Type.WorkRecordCountProperty Members | StarTeam Namespace


Task.Type.WorkRecordCountProperty Members

Task.Type.WorkRecordCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.WorkRecordCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.WorkRecordCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.WorkRecordCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.WorkRecordCountProperty Class | StarTeam Namespace


Task.Type.WorkRecordCountProperty Properties

The properties of the Task.Type.WorkRecordCountProperty class are listed below. For a complete list of Task.Type.WorkRecordCountProperty class members, see the Task.Type.WorkRecordCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Task.Type.WorkRecordCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Task.Type.WorkRecordCountProperty.NAME Property

public static String NAME {get;}

See Also

Task.Type.WorkRecordCountProperty Class | StarTeam Namespace


Task.Type.WorkRecordCountProperty Methods

The methods of the Task.Type.WorkRecordCountProperty class are listed below. For a complete list of Task.Type.WorkRecordCountProperty class members, see the Task.Type.WorkRecordCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Task.Type.WorkRecordCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Task.Type.WorkRecordCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Task.Type.WorkRecordCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Task.Type.WorkRecordCountProperty Class | StarTeam Namespace


Task.Type.WorkRecordCountProperty.Equals Method

Delegate Equals() to com.starteam.Task.Type.WorkRecordCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.Type.WorkRecordCountProperty.Equals(obj).

See Also

Task.Type.WorkRecordCountProperty Class | StarTeam Namespace


Task.Type.WorkRecordCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.Type.WorkRecordCountProperty.

public override int GetHashCode();

Return Value

com.starteam.Task.Type.WorkRecordCountProperty.GetHashCode().

See Also

Task.Type.WorkRecordCountProperty Class | StarTeam Namespace


Task.Type.WorkRecordCountProperty.ToString Method

Delegate ToString() to com.starteam.Task.Type.WorkRecordCountProperty.

public override string ToString();

Return Value

com.starteam.Task.Type.WorkRecordCountProperty.ToString()

See Also

Task.Type.WorkRecordCountProperty Class | StarTeam Namespace


Task.WebCacheTask Class

Item accessor for cached SDK Tasks contained objects are obtained from the artifact cache

For a list of all members of this type, see Task.WebCacheTask Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
TreeItem.WebCacheTreeItem
Task.WebCacheTask

public class Task.WebCacheTask : WebCacheTreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Task.WebCacheTask Members | StarTeam Namespace


Task.WebCacheTask Members

Task.WebCacheTask overview

Public Static Methods

Create Overloaded.

Public Instance Properties

ActualFinishDate | [read/write] The actual finish date of this task.
ActualStartDate | [read/write] The actual start date of this task.
ActualWorkToDate | [read] The actual number of hours spent on this task.
After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
AttentionNotes | [read/write] The text in the "Needs Attention" note for this task.
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
ConstraintDate | [read] The task's Constraint Date from MS Project.
ConstraintValue | [read] The MS Project Constraint Type of this task.
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] The description for this task.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EstimatedFinishDate | [read/write] The estimated date at which this task will be completed.
EstimatedStartDate | [read/write] The estimated start date of this task.
EstimatedTotalWork | [read/write] An estimate of the number of hours that will be spent completing this task.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBlocked | [read/write] A value indicating whether or not this task is blocked
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
LicenseTypeValue | [read/write] A value indicating the lifecycle type (e.g., Development, QA, Documentation or unknown) of this task.
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MSProjectFileName | [read] The MS Project FileName of this task.
MSProjectLastUpdate | [read] The date that this task was last updated from MS Project.
MyType | [read] the type of this resource.
Name |
NameProperty |
Notes | [read/write] The text in the "Notes" for this task.
NotifiedUsers | [read] The users who are notified.
Number | [read] The number assigned to this task.
ObjectID | [read] The unique identifier for the underlying object.
Order | [read/write] The order in which the task should be worked on.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
ParentStory | [read] The story being set as parent of this or null
PercentComplete | [read/write] A percentage indicating how much of the task has been completed.
PredecessorLinks | [read] The predecessor tasks to this this task.
PresentationID | [read] the unique integer identifier for this resource.
Priority | [read/write] The Priority of this task.
Resources | [read] The User assigned as resources of this task.
Responsibility | [read/write] The User object who is responsible for this task.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
RichDescription | [read/write] the rich description of this task.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Status | [read/write] The Status of this task.
SuccessorLinks | [read] The successor tasks to this this task.
Team | [read/write] The team for this task.
Traces | [read] a Trace[] of applicable Traces
UniqueID | [read] The MS Project UniqueID of this task.
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WorkRecords | [read] The work records associates with this task.

Public Instance Methods

AddNotifiedUser |
AddPredecessorLink | Adds a new predecessor to this task.
AddResource |
AddTo |
Copy |
CreateWorkRecord |
Equals | Delegate Equals() to com.starteam.Task.WebCacheTask.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Task.WebCacheTask.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveDependency |
RemoveFrom |
RemoveNotifiedUser |
RemoveResource |
RemoveWorkRecord |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Task.WebCacheTask.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask Properties

The properties of the Task.WebCacheTask class are listed below. For a complete list of Task.WebCacheTask class members, see the Task.WebCacheTask Members topic.

Public Instance Properties

ActualFinishDate | [read/write] The actual finish date of this task.
ActualStartDate | [read/write] The actual start date of this task.
ActualWorkToDate | [read] The actual number of hours spent on this task.
After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
AttentionNotes | [read/write] The text in the "Needs Attention" note for this task.
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
ConstraintDate | [read] The task's Constraint Date from MS Project.
ConstraintValue | [read] The MS Project Constraint Type of this task.
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] The description for this task.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
EstimatedFinishDate | [read/write] The estimated date at which this task will be completed.
EstimatedStartDate | [read/write] The estimated start date of this task.
EstimatedTotalWork | [read/write] An estimate of the number of hours that will be spent completing this task.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBlocked | [read/write] A value indicating whether or not this task is blocked
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
LicenseTypeValue | [read/write] A value indicating the lifecycle type (e.g., Development, QA, Documentation or unknown) of this task.
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MSProjectFileName | [read] The MS Project FileName of this task.
MSProjectLastUpdate | [read] The date that this task was last updated from MS Project.
MyType | [read] the type of this resource.
Name |
NameProperty |
Notes | [read/write] The text in the "Notes" for this task.
NotifiedUsers | [read] The users who are notified.
Number | [read] The number assigned to this task.
ObjectID | [read] The unique identifier for the underlying object.
Order | [read/write] The order in which the task should be worked on.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
ParentStory | [read] The story being set as parent of this or null
PercentComplete | [read/write] A percentage indicating how much of the task has been completed.
PredecessorLinks | [read] The predecessor tasks to this this task.
PresentationID | [read] the unique integer identifier for this resource.
Priority | [read/write] The Priority of this task.
Resources | [read] The User assigned as resources of this task.
Responsibility | [read/write] The User object who is responsible for this task.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
RichDescription | [read/write] the rich description of this task.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Status | [read/write] The Status of this task.
SuccessorLinks | [read] The successor tasks to this this task.
Team | [read/write] The team for this task.
Traces | [read] a Trace[] of applicable Traces
UniqueID | [read] The MS Project UniqueID of this task.
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WorkRecords | [read] The work records associates with this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ActualFinishDate Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ActualFinishDate Property

[read/write] The actual finish date of this task.

public virtual Date ActualFinishDate {get; set;}

Property Value

The actual finish date of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ActualStartDate Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ActualStartDate Property

[read/write] The actual start date of this task.

public virtual Date ActualStartDate {get; set;}

Property Value

The actual start date of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ActualWorkToDate Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ActualWorkToDate Property

[read] The actual number of hours spent on this task.

public virtual TimeSpan ActualWorkToDate {get;}

Property Value

The actual number of hours spent on this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


After Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.After Property

[write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem After {set;}

Property Value

place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Task.WebCacheTask Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Task.WebCacheTask Class | StarTeam Namespace


AttentionNotes Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.AttentionNotes Property

[read/write] The text in the "Needs Attention" note for this task.

public virtual String AttentionNotes {get; set;}

Property Value

The text in the "Needs Attention" note for this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Before Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Before Property

[write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem Before {set;}

Property Value

place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Task.WebCacheTask Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Task.WebCacheTask Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Task.WebCacheTask Class | StarTeam Namespace


ConstraintDate Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ConstraintDate Property

[read] The task's Constraint Date from MS Project.

public virtual DateTime ConstraintDate {get;}

Property Value

The task's Constraint Date from MS Project.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ConstraintValue Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ConstraintValue Property

[read] The MS Project Constraint Type of this task.

public virtual Task.Constraint ConstraintValue {get;}

Property Value

The MS Project Constraint Type of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Task.WebCacheTask Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Task.WebCacheTask Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Task.WebCacheTask Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Task.WebCacheTask Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Description Property

[read/write] The description for this task.

public virtual String Description {get; set;}

Property Value

The description for this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Task.WebCacheTask Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Task.WebCacheTask Class | StarTeam Namespace


EstimatedFinishDate Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.EstimatedFinishDate Property

[read/write] The estimated date at which this task will be completed.

public virtual Date EstimatedFinishDate {get; set;}

Property Value

The estimated date at which this task will be completed.

See Also

Task.WebCacheTask Class | StarTeam Namespace


EstimatedStartDate Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.EstimatedStartDate Property

[read/write] The estimated start date of this task.

public virtual Date EstimatedStartDate {get; set;}

Property Value

The estimated start date of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


EstimatedTotalWork Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.EstimatedTotalWork Property

[read/write] An estimate of the number of hours that will be spent completing this task.

public virtual TimeSpan EstimatedTotalWork {get; set;}

Property Value

An estimate of the number of hours that will be spent completing this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Task.WebCacheTask Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Task.WebCacheTask Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Task.WebCacheTask Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Task.WebCacheTask Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsBlocked Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsBlocked Property

[read/write] A value indicating whether or not this task is blocked

public virtual Boolean IsBlocked {get; set;}

Property Value

A value indicating whether or not this task is blocked

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsLeaf Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsLeaf Property

[read] true if this tree item is a leaf

new public virtual Boolean IsLeaf {get;}

Property Value

true if this tree item is a leaf

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Task.WebCacheTask Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Task.WebCacheTask Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Task.WebCacheTask Class | StarTeam Namespace


LicenseTypeValue Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.LicenseTypeValue Property

[read/write] A value indicating the lifecycle type (e.g., Development, QA, Documentation or unknown) of this task.

public virtual Task.LifeCycleType LicenseTypeValue {get; set;}

Property Value

A value indicating the lifecycle type (e.g., Development, QA, Documentation or unknown) of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Task.WebCacheTask Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Task.WebCacheTask Class | StarTeam Namespace


MSProjectFileName Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.MSProjectFileName Property

[read] The MS Project FileName of this task.

public virtual String MSProjectFileName {get;}

Property Value

The MS Project FileName of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


MSProjectLastUpdate Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.MSProjectLastUpdate Property

[read] The date that this task was last updated from MS Project.

public virtual DateTime MSProjectLastUpdate {get;}

Property Value

The date that this task was last updated from MS Project.

See Also

Task.WebCacheTask Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Name Property

new public virtual String Name {get; set;}

See Also

Task.WebCacheTask Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Task.WebCacheTask Class | StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Notes Property

[read/write] The text in the "Notes" for this task.

public virtual String Notes {get; set;}

Property Value

The text in the "Notes" for this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Number Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Number Property

[read] The number assigned to this task.

public virtual Int32 Number {get;}

Property Value

The number assigned to this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Order Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Order Property

[read/write] The order in which the task should be worked on.

public virtual Double Order {get; set;}

Property Value

The order in which the task should be worked on.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Parent Property

[read] the TreeItem which is the Parent of this instance, or NULL if this is a root

new public virtual TreeItem.WebCacheTreeItem Parent {get;}

Property Value

the TreeItem which is the Parent of this instance, or NULL if this is a root

See Also

Task.WebCacheTask Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ParentStory Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ParentStory Property

[read] The story being set as parent of this or null

public virtual Story.WebCacheStory ParentStory {get;}

Property Value

The story being set as parent of this or null

See Also

Task.WebCacheTask Class | StarTeam Namespace


PercentComplete Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.PercentComplete Property

[read/write] A percentage indicating how much of the task has been completed.

public virtual Int32 PercentComplete {get; set;}

Property Value

A percentage indicating how much of the task has been completed.

See Also

Task.WebCacheTask Class | StarTeam Namespace


PredecessorLinks Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.PredecessorLinks Property

[read] The predecessor tasks to this this task.

public virtual WebCacheTaskDependency[] PredecessorLinks {get;}

Property Value

The predecessor tasks to this this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Priority Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Priority Property

[read/write] The Priority of this task.

public virtual Task.Priority Priority {get; set;}

Property Value

The Priority of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Resources Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Resources Property

[read] The User assigned as resources of this task.

public virtual WebCacheUser[] Resources {get;}

Property Value

The User assigned as resources of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Responsibility Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Responsibility Property

[read/write] The User object who is responsible for this task.

public virtual User.WebCacheUser Responsibility {get; set;}

Property Value

The User object who is responsible for this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Task.WebCacheTask Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Task.WebCacheTask Class | StarTeam Namespace


RichDescription Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.RichDescription Property

[read/write] the rich description of this task.

public virtual Content.WebCacheContent RichDescription {get; set;}

Property Value

the rich description of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Task.WebCacheTask Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Task.WebCacheTask Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Task.WebCacheTask Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Task.WebCacheTask Class | StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Status Property

[read/write] The Status of this task.

public virtual Task.Status Status {get; set;}

Property Value

The Status of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


SuccessorLinks Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.SuccessorLinks Property

[read] The successor tasks to this this task.

public virtual WebCacheTaskDependency[] SuccessorLinks {get;}

Property Value

The successor tasks to this this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Team Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Team Property

[read/write] The team for this task.

public virtual String Team {get; set;}

Property Value

The team for this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Task.WebCacheTask Class | StarTeam Namespace


UniqueID Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.UniqueID Property

[read] The MS Project UniqueID of this task.

public virtual Int32 UniqueID {get;}

Property Value

The MS Project UniqueID of this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

Task.WebCacheTask Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

Task.WebCacheTask Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Task.WebCacheTask Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Task.WebCacheTask Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Task.WebCacheTask Class | StarTeam Namespace


WorkRecords Property

Borland StarTeam SDK for .NET

Task.WebCacheTask.WorkRecords Property

[read] The work records associates with this task.

public virtual WebCacheWorkRecord[] WorkRecords {get;}

Property Value

The work records associates with this task.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask Methods

The methods of the Task.WebCacheTask class are listed below. For a complete list of Task.WebCacheTask class members, see the Task.WebCacheTask Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddPredecessorLink | Adds a new predecessor to this task.
AddResource |
AddTo |
Copy |
CreateWorkRecord |
Equals | Delegate Equals() to com.starteam.Task.WebCacheTask.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Task.WebCacheTask.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveDependency |
RemoveFrom |
RemoveNotifiedUser |
RemoveResource |
RemoveWorkRecord |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Task.WebCacheTask.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.AddPredecessorLink Method

Adds a new predecessor to this task.

public virtual void AddPredecessorLink(
Int32 predecessorID,
Int32 lagTime,
Int32 depType
);

Parameters

predecessorID
the task id of the predecessor task
lagTime
the lag time for this dependency
depType
the dependency type.

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.AddResource Method

public virtual void AddResource(
User.WebCacheUser user
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Task.WebCacheTask.Create Method

Overload List

public static WebCacheTask Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,TreeItem.Type.WebCacheTreeItemType);

public static WebCacheTask Create(ArtifactCacheManager.Context,Task.WebCacheTask);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,TreeItem.WebCacheTreeItem);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheTask Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.Create Overload List


Task.WebCacheTask.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.Create Overload List


Task.WebCacheTask.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, TreeItem#Type#WebCacheTreeItemType)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
TreeItem.Type.WebCacheTreeItemType typ
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.Create Overload List


Task.WebCacheTask.Create Method (ArtifactCacheManager#Context, Task#WebCacheTask)

public static WebCacheTask Create(
ArtifactCacheManager.Context cntxt,
Task.WebCacheTask parent
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.Create Overload List


Task.WebCacheTask.Create Method (ArtifactCacheManager#Context, TreeItem#WebCacheTreeItem)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
TreeItem.WebCacheTreeItem parent
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.Create Overload List


Task.WebCacheTask.CreateWorkRecord Method

public virtual WebCacheWorkRecord CreateWorkRecord(
User.WebCacheUser user
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.Equals Method

Delegate Equals() to com.starteam.Task.WebCacheTask.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Task.WebCacheTask.Equals(obj).

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.GetChildren Method

new public virtual WebCacheTreeItem[] GetChildren(
Filter.WebCacheFilter fltr
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.GetHashCode Method

Delegate GetHashCode() to com.starteam.Task.WebCacheTask.

public override int GetHashCode();

Return Value

com.starteam.Task.WebCacheTask.GetHashCode().

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Task.WebCacheTask.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.GetValue Overload List


Task.WebCacheTask.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.GetValue Overload List


Task.WebCacheTask.HasChildren Method

Returns true if the TreeItem has at least one child.

new public virtual bool HasChildren();

Return Value

True if at least one child exists, false if no children

See Also

Task.WebCacheTask Class | StarTeam Namespace | isDisembodied


Task.WebCacheTask.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Task.WebCacheTask.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Task.WebCacheTask Class | StarTeam Namespace | WebCacheViewMemberCollection


Task.WebCacheTask.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.Lock Overload List | WebCacheViewMemberCollection


Task.WebCacheTask.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.Lock Overload List


Task.WebCacheTask.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Task.WebCacheTask Class | StarTeam Namespace | NAME


Task.WebCacheTask.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Task.WebCacheTask Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Task.WebCacheTask.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(TreeItem.WebCacheTreeItem);

new public virtual void MoveTo(View.WebCacheView);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.MoveTo Overload List


Task.WebCacheTask.MoveTo Method (TreeItem#WebCacheTreeItem)

new public virtual void MoveTo(
TreeItem.WebCacheTreeItem parent
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.MoveTo Overload List


Task.WebCacheTask.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.MoveTo Overload List


Task.WebCacheTask.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Task.WebCacheTask Class | StarTeam Namespace | isFloating | isPinned | unpin


Task.WebCacheTask.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Task.WebCacheTask Class | StarTeam Namespace | WebCacheViewMemberCollection


Task.WebCacheTask.RemoveDependency Method

public virtual void RemoveDependency(
TaskDependency.WebCacheTaskDependency dependency
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.RemoveResource Method

public virtual void RemoveResource(
User.WebCacheUser user
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.RemoveWorkRecord Method

public virtual void RemoveWorkRecord(
WorkRecord.WebCacheWorkRecord record
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.SetBetween Method

new public virtual void SetBetween(
TreeItem.WebCacheTreeItem prev,
TreeItem.WebCacheTreeItem next
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.SetFirst Method

place this tree item at the head of the set of all children of its parent treeitem or folder

new public virtual void SetFirst();

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.SetLast Method

place this tree item at the end of the set of all children of its parent treeitem or folder

new public virtual void SetLast();

See Also

Task.WebCacheTask Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Task.WebCacheTask.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.SetValue Overload List


Task.WebCacheTask.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Task.WebCacheTask Class | StarTeam Namespace | Task.WebCacheTask.SetValue Overload List


Task.WebCacheTask.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.ToString Method

Delegate ToString() to com.starteam.Task.WebCacheTask.

public override string ToString();

Return Value

com.starteam.Task.WebCacheTask.ToString()

See Also

Task.WebCacheTask Class | StarTeam Namespace


Task.WebCacheTask.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Task.WebCacheTask Class | StarTeam Namespace | WebCacheViewMemberCollection


Task.WebCacheTask.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Task.WebCacheTask Class | StarTeam Namespace | isFloating | isPinned | pinTo


Task.WebCacheTask.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Task.WebCacheTask Class | StarTeam Namespace | WebCacheViewMemberCollection


Task.WebCacheTask.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Task.WebCacheTask Class | StarTeam Namespace


TaskDependency Class

This is a class representing a dependency between two tasks.

For a list of all members of this type, see TaskDependency Members.

System.Object
TypedResource
LiveObject
TrackedObject
TaskDependency

public class TaskDependency : TrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TaskDependency Members | StarTeam Namespace


TaskDependency Members

TaskDependency overview

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
LagTime | [read/write] the lag time for this task dependency.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
PredecessorID | [read] The ObjectID of the predecessor Task.
PredecessorTypeValue | [read/write] the PredecessorType of this task dependency.
Properties | [read]
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
TaskID | [read] The ObjectID of the successor Task.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this task dependency object.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

TaskDependency Class | StarTeam Namespace


TaskDependency Properties

The properties of the TaskDependency class are listed below. For a complete list of TaskDependency class members, see the TaskDependency Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
LagTime | [read/write] the lag time for this task dependency.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
PredecessorID | [read] The ObjectID of the predecessor Task.
PredecessorTypeValue | [read/write] the PredecessorType of this task dependency.
Properties | [read]
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
TaskID | [read] The ObjectID of the successor Task.

See Also

TaskDependency Class | StarTeam Namespace


LagTime Property

Borland StarTeam SDK for .NET

TaskDependency.LagTime Property

[read/write] the lag time for this task dependency.

public virtual Int32 LagTime {get; set;}

Property Value

the lag time for this task dependency.

See Also

TaskDependency Class | StarTeam Namespace


PredecessorID Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorID Property

[read] The ObjectID of the predecessor Task.

public virtual Int32 PredecessorID {get;}

Property Value

The ObjectID of the predecessor Task.

See Also

TaskDependency Class | StarTeam Namespace


PredecessorTypeValue Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorTypeValue Property

[read/write] the PredecessorType of this task dependency.

public virtual TaskDependency.PredecessorType PredecessorTypeValue {get; set;}

Property Value

the PredecessorType of this task dependency.

See Also

TaskDependency Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

TaskDependency.Properties Property

[read]

public virtual TaskDependency.Type.PropertyCollection Properties {get;}

See Also

TaskDependency Class | StarTeam Namespace


TaskID Property

Borland StarTeam SDK for .NET

TaskDependency.TaskID Property

[read] The ObjectID of the successor Task.

public virtual Int32 TaskID {get;}

Property Value

The ObjectID of the successor Task.

See Also

TaskDependency Class | StarTeam Namespace


TaskDependency Methods

The methods of the TaskDependency class are listed below. For a complete list of TaskDependency class members, see the TaskDependency Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this task dependency object.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

TaskDependency Class | StarTeam Namespace


TaskDependency.Copy Method

Creates a copy of this task dependency object.

public virtual TaskDependency Copy();

Return Value

A new copy of this task dependency object.

See Also

TaskDependency Class | StarTeam Namespace | isEqualTo


TaskDependency.PredecessorType Class

Task Predecessor type

For a list of all members of this type, see TaskDependency.PredecessorType Members.

System.Object
EnumeratedValue
TaskDependency.PredecessorType

public class TaskDependency.PredecessorType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TaskDependency.PredecessorType Members | StarTeam Namespace


TaskDependency.PredecessorType Members

TaskDependency.PredecessorType overview

Public Static Properties

ALL
FINISH_FINISH
FINISH_START
START_FINISH
START_START

Public Static Methods

FromID | Gets the PredecessorType value corresponding to the given ID.
FromValue | Gets the PredecessorType value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this PredecessorType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.TaskDependency.PredecessorType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.PredecessorType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.TaskDependency.PredecessorType.

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


TaskDependency.PredecessorType Properties

The properties of the TaskDependency.PredecessorType class are listed below. For a complete list of TaskDependency.PredecessorType class members, see the TaskDependency.PredecessorType Members topic.

Public Static Properties

ALL
FINISH_FINISH
FINISH_START
START_FINISH
START_START

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this PredecessorType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorType.ALL Property

public static PredecessorType[] ALL {get;}

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


FINISH_FINISH Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorType.FINISH_FINISH Property

public static TaskDependency.PredecessorType FINISH_FINISH {get;}

Property Value

FF Task PredecessorType

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


FINISH_START Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorType.FINISH_START Property

public static TaskDependency.PredecessorType FINISH_START {get;}

Property Value

FS Task Dependency

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorType.ID Property

[read] The ID of this PredecessorType value.

public virtual Int32 ID {get;}

Property Value

The ID of this PredecessorType value.

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


START_FINISH Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorType.START_FINISH Property

public static TaskDependency.PredecessorType START_FINISH {get;}

Property Value

SS Task PredecessorType

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


START_START Property

Borland StarTeam SDK for .NET

TaskDependency.PredecessorType.START_START Property

public static TaskDependency.PredecessorType START_START {get;}

Property Value

SF Task PredecessorType

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


TaskDependency.PredecessorType Methods

The methods of the TaskDependency.PredecessorType class are listed below. For a complete list of TaskDependency.PredecessorType class members, see the TaskDependency.PredecessorType Members topic.

Public Static Methods

FromID | Gets the PredecessorType value corresponding to the given ID.
FromValue | Gets the PredecessorType value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.TaskDependency.PredecessorType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.PredecessorType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.TaskDependency.PredecessorType.

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


TaskDependency.PredecessorType.Equals Method

Delegate Equals() to com.starteam.TaskDependency.PredecessorType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TaskDependency.PredecessorType.Equals(obj).

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


TaskDependency.PredecessorType.FromID Method

Gets the PredecessorType value corresponding to the given ID.

public static PredecessorType FromID(
Int32 id
);

Parameters

id
The ID of a PredecessorType value.

Return Value

The corresponding PredecessorType value, or null.

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


TaskDependency.PredecessorType.FromValue Method

Gets the PredecessorType value corresponding to the given EnumeratedValue.

public static PredecessorType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a PredecessorType.

Return Value

The corresponding PredecessorType value, or null.

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


TaskDependency.PredecessorType.GetHashCode Method

Delegate GetHashCode() to com.starteam.TaskDependency.PredecessorType.

public override int GetHashCode();

Return Value

com.starteam.TaskDependency.PredecessorType.GetHashCode().

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


TaskDependency.PredecessorType.ToString Method

Delegate ToString() to com.starteam.TaskDependency.PredecessorType.

public override string ToString();

Return Value

com.starteam.TaskDependency.PredecessorType.ToString()

See Also

TaskDependency.PredecessorType Class | StarTeam Namespace


TaskDependency.Type Class

The Type of TaskDependency.

For a list of all members of this type, see TaskDependency.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
TaskDependency.Type

new public class TaskDependency.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TaskDependency.Type Members | StarTeam Namespace


TaskDependency.Type Members

TaskDependency.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.

See Also

TaskDependency.Type Class | StarTeam Namespace


TaskDependency.Type Properties

The properties of the TaskDependency.Type class are listed below. For a complete list of TaskDependency.Type class members, see the TaskDependency.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

TaskDependency.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.NAME Property

new public static String NAME {get;}

See Also

TaskDependency.Type Class | StarTeam Namespace


TaskDependency.Type Methods

The methods of the TaskDependency.Type class are listed below. For a complete list of TaskDependency.Type class members, see the TaskDependency.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.

See Also

TaskDependency.Type Class | StarTeam Namespace


TaskDependency.Type.Equals Method

Delegate Equals() to com.starteam.TaskDependency.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TaskDependency.Type.Equals(obj).

See Also

TaskDependency.Type Class | StarTeam Namespace


TaskDependency.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.TaskDependency.Type.

public override int GetHashCode();

Return Value

com.starteam.TaskDependency.Type.GetHashCode().

See Also

TaskDependency.Type Class | StarTeam Namespace


TaskDependency.Type.ToString Method

Delegate ToString() to com.starteam.TaskDependency.Type.

public override string ToString();

Return Value

com.starteam.TaskDependency.Type.ToString()

See Also

TaskDependency.Type Class | StarTeam Namespace


TaskDependency.Type.LagTimeProperty Class

The property type of the Lag Time property.

For a list of all members of this type, see TaskDependency.Type.LagTimeProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
TaskDependency.Type.LagTimeProperty

public class TaskDependency.Type.LagTimeProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TaskDependency.Type.LagTimeProperty Members | StarTeam Namespace


TaskDependency.Type.LagTimeProperty Members

TaskDependency.Type.LagTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.LagTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.LagTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.LagTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TaskDependency.Type.LagTimeProperty Class | StarTeam Namespace


TaskDependency.Type.LagTimeProperty Properties

The properties of the TaskDependency.Type.LagTimeProperty class are listed below. For a complete list of TaskDependency.Type.LagTimeProperty class members, see the TaskDependency.Type.LagTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TaskDependency.Type.LagTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.LagTimeProperty.NAME Property

public static String NAME {get;}

See Also

TaskDependency.Type.LagTimeProperty Class | StarTeam Namespace


TaskDependency.Type.LagTimeProperty Methods

The methods of the TaskDependency.Type.LagTimeProperty class are listed below. For a complete list of TaskDependency.Type.LagTimeProperty class members, see the TaskDependency.Type.LagTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.LagTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.LagTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.LagTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TaskDependency.Type.LagTimeProperty Class | StarTeam Namespace


TaskDependency.Type.LagTimeProperty.Equals Method

Delegate Equals() to com.starteam.TaskDependency.Type.LagTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TaskDependency.Type.LagTimeProperty.Equals(obj).

See Also

TaskDependency.Type.LagTimeProperty Class | StarTeam Namespace


TaskDependency.Type.LagTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TaskDependency.Type.LagTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.TaskDependency.Type.LagTimeProperty.GetHashCode().

See Also

TaskDependency.Type.LagTimeProperty Class | StarTeam Namespace


TaskDependency.Type.LagTimeProperty.ToString Method

Delegate ToString() to com.starteam.TaskDependency.Type.LagTimeProperty.

public override string ToString();

Return Value

com.starteam.TaskDependency.Type.LagTimeProperty.ToString()

See Also

TaskDependency.Type.LagTimeProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorProperty Class

The property type of the Predecessor property.

For a list of all members of this type, see TaskDependency.Type.PredecessorProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
TaskDependency.Type.PredecessorProperty

public class TaskDependency.Type.PredecessorProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TaskDependency.Type.PredecessorProperty Members | StarTeam Namespace


TaskDependency.Type.PredecessorProperty Members

TaskDependency.Type.PredecessorProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.PredecessorProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.PredecessorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.PredecessorProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TaskDependency.Type.PredecessorProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorProperty Properties

The properties of the TaskDependency.Type.PredecessorProperty class are listed below. For a complete list of TaskDependency.Type.PredecessorProperty class members, see the TaskDependency.Type.PredecessorProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TaskDependency.Type.PredecessorProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PredecessorProperty.NAME Property

public static String NAME {get;}

See Also

TaskDependency.Type.PredecessorProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorProperty Methods

The methods of the TaskDependency.Type.PredecessorProperty class are listed below. For a complete list of TaskDependency.Type.PredecessorProperty class members, see the TaskDependency.Type.PredecessorProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.PredecessorProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.PredecessorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.PredecessorProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TaskDependency.Type.PredecessorProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorProperty.Equals Method

Delegate Equals() to com.starteam.TaskDependency.Type.PredecessorProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TaskDependency.Type.PredecessorProperty.Equals(obj).

See Also

TaskDependency.Type.PredecessorProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TaskDependency.Type.PredecessorProperty.

public override int GetHashCode();

Return Value

com.starteam.TaskDependency.Type.PredecessorProperty.GetHashCode().

See Also

TaskDependency.Type.PredecessorProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorProperty.ToString Method

Delegate ToString() to com.starteam.TaskDependency.Type.PredecessorProperty.

public override string ToString();

Return Value

com.starteam.TaskDependency.Type.PredecessorProperty.ToString()

See Also

TaskDependency.Type.PredecessorProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorTypeProperty Class

The property type of the Predecessor Type property.

For a list of all members of this type, see TaskDependency.Type.PredecessorTypeProperty Members.

System.Object
Property
EnumeratedProperty
TaskDependency.Type.PredecessorTypeProperty

public class TaskDependency.Type.PredecessorTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TaskDependency.Type.PredecessorTypeProperty Members | StarTeam Namespace


TaskDependency.Type.PredecessorTypeProperty Members

TaskDependency.Type.PredecessorTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.PredecessorTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.PredecessorTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.PredecessorTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TaskDependency.Type.PredecessorTypeProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorTypeProperty Properties

The properties of the TaskDependency.Type.PredecessorTypeProperty class are listed below. For a complete list of TaskDependency.Type.PredecessorTypeProperty class members, see the TaskDependency.Type.PredecessorTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

TaskDependency.Type.PredecessorTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PredecessorTypeProperty.NAME Property

public static String NAME {get;}

See Also

TaskDependency.Type.PredecessorTypeProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorTypeProperty Methods

The methods of the TaskDependency.Type.PredecessorTypeProperty class are listed below. For a complete list of TaskDependency.Type.PredecessorTypeProperty class members, see the TaskDependency.Type.PredecessorTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.PredecessorTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.PredecessorTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.PredecessorTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TaskDependency.Type.PredecessorTypeProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorTypeProperty.Equals Method

Delegate Equals() to com.starteam.TaskDependency.Type.PredecessorTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TaskDependency.Type.PredecessorTypeProperty.Equals(obj).

See Also

TaskDependency.Type.PredecessorTypeProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
TaskDependency.PredecessorType value
);

See Also

TaskDependency.Type.PredecessorTypeProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TaskDependency.Type.PredecessorTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.TaskDependency.Type.PredecessorTypeProperty.GetHashCode().

See Also

TaskDependency.Type.PredecessorTypeProperty Class | StarTeam Namespace


TaskDependency.Type.PredecessorTypeProperty.ToString Method

Delegate ToString() to com.starteam.TaskDependency.Type.PredecessorTypeProperty.

public override string ToString();

Return Value

com.starteam.TaskDependency.Type.PredecessorTypeProperty.ToString()

See Also

TaskDependency.Type.PredecessorTypeProperty Class | StarTeam Namespace


TaskDependency.Type.PropertyCollection Class

The PropertyCollection of a Task Dependency.

For a list of all members of this type, see TaskDependency.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
TaskDependency.Type.PropertyCollection

public class TaskDependency.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TaskDependency.Type.PropertyCollection Members | StarTeam Namespace


TaskDependency.Type.PropertyCollection Members

TaskDependency.Type.PropertyCollection overview

Public Instance Properties

COMMENT_ID |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
END_MODIFIED_TIME |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
LAG_TIME |
MODIFIED_BY |
MODIFIED_TIME |
PREDECESSOR |
PREDECESSOR_TYPE |
REVISION_FLAGS |
REVISION_NUMBER |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TASK |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.PropertyCollection.

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


TaskDependency.Type.PropertyCollection Properties

The properties of the TaskDependency.Type.PropertyCollection class are listed below. For a complete list of TaskDependency.Type.PropertyCollection class members, see the TaskDependency.Type.PropertyCollection Members topic.

Public Instance Properties

COMMENT_ID |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
END_MODIFIED_TIME |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
LAG_TIME |
MODIFIED_BY |
MODIFIED_TIME |
PREDECESSOR |
PREDECESSOR_TYPE |
REVISION_FLAGS |
REVISION_NUMBER |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TASK |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


LAG_TIME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.LAG_TIME Property

public TaskDependency.Type.LagTimeProperty LAG_TIME {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


PREDECESSOR Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.PREDECESSOR Property

public TaskDependency.Type.PredecessorProperty PREDECESSOR {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


PREDECESSOR_TYPE Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.PREDECESSOR_TYPE Property

public TaskDependency.Type.PredecessorTypeProperty PREDECESSOR_TYPE {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


TASK Property

Borland StarTeam SDK for .NET

TaskDependency.Type.PropertyCollection.TASK Property

public TaskDependency.Type.TaskProperty TASK {get;}

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


TaskDependency.Type.PropertyCollection Methods

The methods of the TaskDependency.Type.PropertyCollection class are listed below. For a complete list of TaskDependency.Type.PropertyCollection class members, see the TaskDependency.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.PropertyCollection.

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


TaskDependency.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.TaskDependency.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TaskDependency.Type.PropertyCollection.Equals(obj).

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


TaskDependency.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.TaskDependency.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.TaskDependency.Type.PropertyCollection.GetHashCode().

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


TaskDependency.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.TaskDependency.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.TaskDependency.Type.PropertyCollection.ToString()

See Also

TaskDependency.Type.PropertyCollection Class | StarTeam Namespace


TaskDependency.Type.TaskProperty Class

The property type of the Task property.

For a list of all members of this type, see TaskDependency.Type.TaskProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
TaskDependency.Type.TaskProperty

public class TaskDependency.Type.TaskProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TaskDependency.Type.TaskProperty Members | StarTeam Namespace


TaskDependency.Type.TaskProperty Members

TaskDependency.Type.TaskProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.TaskProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.TaskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.TaskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TaskDependency.Type.TaskProperty Class | StarTeam Namespace


TaskDependency.Type.TaskProperty Properties

The properties of the TaskDependency.Type.TaskProperty class are listed below. For a complete list of TaskDependency.Type.TaskProperty class members, see the TaskDependency.Type.TaskProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TaskDependency.Type.TaskProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TaskDependency.Type.TaskProperty.NAME Property

public static String NAME {get;}

See Also

TaskDependency.Type.TaskProperty Class | StarTeam Namespace


TaskDependency.Type.TaskProperty Methods

The methods of the TaskDependency.Type.TaskProperty class are listed below. For a complete list of TaskDependency.Type.TaskProperty class members, see the TaskDependency.Type.TaskProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TaskDependency.Type.TaskProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.Type.TaskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TaskDependency.Type.TaskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TaskDependency.Type.TaskProperty Class | StarTeam Namespace


TaskDependency.Type.TaskProperty.Equals Method

Delegate Equals() to com.starteam.TaskDependency.Type.TaskProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TaskDependency.Type.TaskProperty.Equals(obj).

See Also

TaskDependency.Type.TaskProperty Class | StarTeam Namespace


TaskDependency.Type.TaskProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TaskDependency.Type.TaskProperty.

public override int GetHashCode();

Return Value

com.starteam.TaskDependency.Type.TaskProperty.GetHashCode().

See Also

TaskDependency.Type.TaskProperty Class | StarTeam Namespace


TaskDependency.Type.TaskProperty.ToString Method

Delegate ToString() to com.starteam.TaskDependency.Type.TaskProperty.

public override string ToString();

Return Value

com.starteam.TaskDependency.Type.TaskProperty.ToString()

See Also

TaskDependency.Type.TaskProperty Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency Class

Item accessor for cached SDK Task Dependencies contained objects are obtained from the artifact cache

For a list of all members of this type, see TaskDependency.WebCacheTaskDependency Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
TaskDependency.WebCacheTaskDependency

public class TaskDependency.WebCacheTaskDependency : WebCacheTrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TaskDependency.WebCacheTaskDependency Members | StarTeam Namespace


TaskDependency.WebCacheTaskDependency Members

TaskDependency.WebCacheTaskDependency overview

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
LagTime | [read/write] the lag time for this task dependency.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PredecessorID | [read] The ObjectID of the predecessor Task.
PredecessorTypeValue | [read/write] the PredecessorType of this task dependency.
Server | [read] the Server for this cached object
TaskID | [read] The ObjectID of the successor Task.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.TaskDependency.WebCacheTaskDependency.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.WebCacheTaskDependency.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.TaskDependency.WebCacheTaskDependency.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency Properties

The properties of the TaskDependency.WebCacheTaskDependency class are listed below. For a complete list of TaskDependency.WebCacheTaskDependency class members, see the TaskDependency.WebCacheTaskDependency Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
LagTime | [read/write] the lag time for this task dependency.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PredecessorID | [read] The ObjectID of the predecessor Task.
PredecessorTypeValue | [read/write] the PredecessorType of this task dependency.
Server | [read] the Server for this cached object
TaskID | [read] The ObjectID of the successor Task.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


LagTime Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.LagTime Property

[read/write] the lag time for this task dependency.

public virtual Int32 LagTime {get; set;}

Property Value

the lag time for this task dependency.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.Name Property

new public virtual String Name {get;}

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


PredecessorID Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.PredecessorID Property

[read] The ObjectID of the predecessor Task.

public virtual Int32 PredecessorID {get;}

Property Value

The ObjectID of the predecessor Task.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


PredecessorTypeValue Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.PredecessorTypeValue Property

[read/write] the PredecessorType of this task dependency.

public virtual TaskDependency.PredecessorType PredecessorTypeValue {get; set;}

Property Value

the PredecessorType of this task dependency.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskID Property

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.TaskID Property

[read] The ObjectID of the successor Task.

public virtual Int32 TaskID {get;}

Property Value

The ObjectID of the successor Task.

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency Methods

The methods of the TaskDependency.WebCacheTaskDependency class are listed below. For a complete list of TaskDependency.WebCacheTaskDependency class members, see the TaskDependency.WebCacheTaskDependency Members topic.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.TaskDependency.WebCacheTaskDependency.
GetHashCode | Delegate GetHashCode() to com.starteam.TaskDependency.WebCacheTaskDependency.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.TaskDependency.WebCacheTaskDependency.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency.Equals Method

Delegate Equals() to com.starteam.TaskDependency.WebCacheTaskDependency.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TaskDependency.WebCacheTaskDependency.Equals(obj).

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency.GetHashCode Method

Delegate GetHashCode() to com.starteam.TaskDependency.WebCacheTaskDependency.

public override int GetHashCode();

Return Value

com.starteam.TaskDependency.WebCacheTaskDependency.GetHashCode().

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace | TaskDependency.WebCacheTaskDependency.GetValue Overload List


TaskDependency.WebCacheTaskDependency.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace | TaskDependency.WebCacheTaskDependency.GetValue Overload List


TaskDependency.WebCacheTaskDependency.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace | WebCacheViewMemberCollection


TaskDependency.WebCacheTaskDependency.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

TaskDependency.WebCacheTaskDependency.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace | TaskDependency.WebCacheTaskDependency.SetValue Overload List


TaskDependency.WebCacheTaskDependency.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace | TaskDependency.WebCacheTaskDependency.SetValue Overload List


TaskDependency.WebCacheTaskDependency.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency.ToString Method

Delegate ToString() to com.starteam.TaskDependency.WebCacheTaskDependency.

public override string ToString();

Return Value

com.starteam.TaskDependency.WebCacheTaskDependency.ToString()

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace


TaskDependency.WebCacheTaskDependency.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

TaskDependency.WebCacheTaskDependency Class | StarTeam Namespace | WebCacheViewMemberCollection


Test Class

A Test is a basic unit of software testing.

For a list of all members of this type, see Test Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
TreeItem
Test

public class Test : TreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Test Members | StarTeam Namespace


Test Members

Test overview

Public Static Methods

Create Create a Test in the specified parent folder.

Public Instance Constructors

Test Constructor Creates a child-test under this parent test.

Public Instance Properties

After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the content of this Test.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Test.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
Path | [read/write] the Path.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
TestID | [read] the test id.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Test Class | StarTeam Namespace


Test Constructor

Creates a child-test under this parent test.

public Test(
Test parent
);

Parameters

parent

See Also

Test Class | StarTeam Namespace


Test Properties

The properties of the Test class are listed below. For a complete list of Test class members, see the Test Members topic.

Public Instance Properties

After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the content of this Test.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this Test.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
Path | [read/write] the Path.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
TestID | [read] the test id.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Test Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Test.Description Property

[read/write] the content of this Test.

public virtual Content Description {get; set;}

Property Value

the content of this Test.

See Also

Test Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Test.Name Property

[read/write] the Name of this Test.

public virtual String Name {get; set;}

Property Value

the Name of this Test.

See Also

Test Class | StarTeam Namespace


Path Property

Borland StarTeam SDK for .NET

Test.Path Property

[read/write] the Path.

public virtual String Path {get; set;}

Property Value

the Path.

See Also

Test Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Test.Properties Property

[read] the PropertyCollection of its Type

public virtual Test.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

Test Class | StarTeam Namespace


TestID Property

Borland StarTeam SDK for .NET

Test.TestID Property

[read] the test id.

public virtual Int32 TestID {get;}

Property Value

the test id.

See Also

Test Class | StarTeam Namespace


Test Methods

The methods of the Test class are listed below. For a complete list of Test class members, see the Test Members topic.

Public Static Methods

Create Create a Test in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Test Class | StarTeam Namespace


Test.Create Method

Create a Test in the specified parent folder.

public static Test Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Test Object.

See Also

Test Class | StarTeam Namespace


Test.Type Class

Type meta-data (schema) for Test object instances.

For a list of all members of this type, see Test.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
TreeItem.Type
Test.Type

new public class Test.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Test.Type Members | StarTeam Namespace


Test.Type Members

Test.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Test.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Test.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Test.Type Class | StarTeam Namespace


Test.Type Properties

The properties of the Test.Type class are listed below. For a complete list of Test.Type class members, see the Test.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Test.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Test.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Test.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Test.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Test.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Test.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Test.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Test.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Test.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Test.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Test.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Test.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Test.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Test.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Test.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Test.Type.NAME Property

new public static String NAME {get;}

See Also

Test.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Test.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Test.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Test.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Test.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Test.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Test.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Test.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Test.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Test.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Test.Type Class | StarTeam Namespace


Test.Type Methods

The methods of the Test.Type class are listed below. For a complete list of Test.Type class members, see the Test.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Test.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Test.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Test.Type Class | StarTeam Namespace


Test.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Test.Type Class | StarTeam Namespace


Test.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Test.Type Class | StarTeam Namespace


Test.Type.Equals Method

Delegate Equals() to com.starteam.Test.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Test.Type.Equals(obj).

See Also

Test.Type Class | StarTeam Namespace


Test.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Test.Type Class | StarTeam Namespace


Test.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Test.Type.

public override int GetHashCode();

Return Value

com.starteam.Test.Type.GetHashCode().

See Also

Test.Type Class | StarTeam Namespace


Test.Type.ToString Method

Delegate ToString() to com.starteam.Test.Type.

public override string ToString();

Return Value

com.starteam.Test.Type.ToString()

See Also

Test.Type Class | StarTeam Namespace


Test.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Test.Type Class | StarTeam Namespace


Test.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Test.Type Class | StarTeam Namespace


Test.Type.DescriptionProperty Class

The property type of the RichDescription property.

For a list of all members of this type, see Test.Type.DescriptionProperty Members.

System.Object
Property
ContentProperty
Test.Type.DescriptionProperty

public class Test.Type.DescriptionProperty : ContentProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Test.Type.DescriptionProperty Members | StarTeam Namespace


Test.Type.DescriptionProperty Members

Test.Type.DescriptionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Test.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.Test.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Test.Type.DescriptionProperty Class | StarTeam Namespace


Test.Type.DescriptionProperty Properties

The properties of the Test.Type.DescriptionProperty class are listed below. For a complete list of Test.Type.DescriptionProperty class members, see the Test.Type.DescriptionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Test.Type.DescriptionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Test.Type.DescriptionProperty.NAME Property

public static String NAME {get;}

See Also

Test.Type.DescriptionProperty Class | StarTeam Namespace


Test.Type.DescriptionProperty Methods

The methods of the Test.Type.DescriptionProperty class are listed below. For a complete list of Test.Type.DescriptionProperty class members, see the Test.Type.DescriptionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Test.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.Test.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Test.Type.DescriptionProperty Class | StarTeam Namespace


Test.Type.DescriptionProperty.Equals Method

Delegate Equals() to com.starteam.Test.Type.DescriptionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Test.Type.DescriptionProperty.Equals(obj).

See Also

Test.Type.DescriptionProperty Class | StarTeam Namespace


Test.Type.DescriptionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Test.Type.DescriptionProperty.

public override int GetHashCode();

Return Value

com.starteam.Test.Type.DescriptionProperty.GetHashCode().

See Also

Test.Type.DescriptionProperty Class | StarTeam Namespace


Test.Type.DescriptionProperty.ToString Method

Delegate ToString() to com.starteam.Test.Type.DescriptionProperty.

public override string ToString();

Return Value

com.starteam.Test.Type.DescriptionProperty.ToString()

See Also

Test.Type.DescriptionProperty Class | StarTeam Namespace


Test.Type.PathProperty Class

The property type of the TestID property

For a list of all members of this type, see Test.Type.PathProperty Members.

System.Object
Property
VectorProperty
TextProperty
Test.Type.PathProperty

public class Test.Type.PathProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Test.Type.PathProperty Members | StarTeam Namespace


Test.Type.PathProperty Members

Test.Type.PathProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Test.Type.PathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.PathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Test.Type.PathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Test.Type.PathProperty Class | StarTeam Namespace


Test.Type.PathProperty Properties

The properties of the Test.Type.PathProperty class are listed below. For a complete list of Test.Type.PathProperty class members, see the Test.Type.PathProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Test.Type.PathProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Test.Type.PathProperty.NAME Property

public static String NAME {get;}

See Also

Test.Type.PathProperty Class | StarTeam Namespace


Test.Type.PathProperty Methods

The methods of the Test.Type.PathProperty class are listed below. For a complete list of Test.Type.PathProperty class members, see the Test.Type.PathProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Test.Type.PathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.PathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Test.Type.PathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Test.Type.PathProperty Class | StarTeam Namespace


Test.Type.PathProperty.Equals Method

Delegate Equals() to com.starteam.Test.Type.PathProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Test.Type.PathProperty.Equals(obj).

See Also

Test.Type.PathProperty Class | StarTeam Namespace


Test.Type.PathProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Test.Type.PathProperty.

public override int GetHashCode();

Return Value

com.starteam.Test.Type.PathProperty.GetHashCode().

See Also

Test.Type.PathProperty Class | StarTeam Namespace


Test.Type.PathProperty.ToString Method

Delegate ToString() to com.starteam.Test.Type.PathProperty.

public override string ToString();

Return Value

com.starteam.Test.Type.PathProperty.ToString()

See Also

Test.Type.PathProperty Class | StarTeam Namespace


Test.Type.PropertyCollection Class

The PropertyCollection of a Test

For a list of all members of this type, see Test.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Test.Type.PropertyCollection

public class Test.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Test.Type.PropertyCollection Members | StarTeam Namespace


Test.Type.PropertyCollection Members

Test.Type.PropertyCollection overview

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_ID |
PATH |
REVISION_FLAGS |
REVISION_NUMBER |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TEST_ID |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Test.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Test.Type.PropertyCollection.

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


Test.Type.PropertyCollection Properties

The properties of the Test.Type.PropertyCollection class are listed below. For a complete list of Test.Type.PropertyCollection class members, see the Test.Type.PropertyCollection Members topic.

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_ID |
PATH |
REVISION_FLAGS |
REVISION_NUMBER |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TEST_ID |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.DESCRIPTION Property

public ContentProperty DESCRIPTION {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


PARENT_ID Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.PARENT_ID Property

public TreeItem.Type.ParentIDProperty PARENT_ID {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


PATH Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.PATH Property

public Test.Type.PathProperty PATH {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


TEST_ID Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.TEST_ID Property

public Test.Type.TestIDProperty TEST_ID {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Test.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


Test.Type.PropertyCollection Methods

The methods of the Test.Type.PropertyCollection class are listed below. For a complete list of Test.Type.PropertyCollection class members, see the Test.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Test.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Test.Type.PropertyCollection.

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


Test.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Test.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Test.Type.PropertyCollection.Equals(obj).

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


Test.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Test.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Test.Type.PropertyCollection.GetHashCode().

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


Test.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Test.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Test.Type.PropertyCollection.ToString()

See Also

Test.Type.PropertyCollection Class | StarTeam Namespace


Test.Type.TestIDProperty Class

The property type of the TestID property

For a list of all members of this type, see Test.Type.TestIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Test.Type.TestIDProperty

public class Test.Type.TestIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Test.Type.TestIDProperty Members | StarTeam Namespace


Test.Type.TestIDProperty Members

Test.Type.TestIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Test.Type.TestIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.TestIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Test.Type.TestIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Test.Type.TestIDProperty Class | StarTeam Namespace


Test.Type.TestIDProperty Properties

The properties of the Test.Type.TestIDProperty class are listed below. For a complete list of Test.Type.TestIDProperty class members, see the Test.Type.TestIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Test.Type.TestIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Test.Type.TestIDProperty.NAME Property

public static String NAME {get;}

See Also

Test.Type.TestIDProperty Class | StarTeam Namespace


Test.Type.TestIDProperty Methods

The methods of the Test.Type.TestIDProperty class are listed below. For a complete list of Test.Type.TestIDProperty class members, see the Test.Type.TestIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Test.Type.TestIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Test.Type.TestIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Test.Type.TestIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Test.Type.TestIDProperty Class | StarTeam Namespace


Test.Type.TestIDProperty.Equals Method

Delegate Equals() to com.starteam.Test.Type.TestIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Test.Type.TestIDProperty.Equals(obj).

See Also

Test.Type.TestIDProperty Class | StarTeam Namespace


Test.Type.TestIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Test.Type.TestIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Test.Type.TestIDProperty.GetHashCode().

See Also

Test.Type.TestIDProperty Class | StarTeam Namespace


Test.Type.TestIDProperty.ToString Method

Delegate ToString() to com.starteam.Test.Type.TestIDProperty.

public override string ToString();

Return Value

com.starteam.Test.Type.TestIDProperty.ToString()

See Also

Test.Type.TestIDProperty Class | StarTeam Namespace


Test.WebCacheTest Class

Item accessor for cached SDK Test items contained objects are obtained from the artifact cache

For a list of all members of this type, see Test.WebCacheTest Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
TreeItem.WebCacheTreeItem
Test.WebCacheTest

public class Test.WebCacheTest : WebCacheTreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Test.WebCacheTest Members | StarTeam Namespace


Test.WebCacheTest Members

Test.WebCacheTest overview

Public Static Methods

Create Overloaded.

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this Test.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
Path | [read/write] the Path.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
TestID | [read] the test id.
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Test.WebCacheTest.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Test.WebCacheTest.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Test.WebCacheTest.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest Properties

The properties of the Test.WebCacheTest class are listed below. For a complete list of Test.WebCacheTest class members, see the Test.WebCacheTest Members topic.

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this Test.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
Path | [read/write] the Path.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
TestID | [read] the test id.
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

Test.WebCacheTest Class | StarTeam Namespace


After Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.After Property

[write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem After {set;}

Property Value

place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Test.WebCacheTest Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Test.WebCacheTest Class | StarTeam Namespace


Before Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Before Property

[write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem Before {set;}

Property Value

place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Test.WebCacheTest Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Test.WebCacheTest Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Test.WebCacheTest Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Test.WebCacheTest Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Test.WebCacheTest Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Test.WebCacheTest Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Test.WebCacheTest Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Test.WebCacheTest Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Description Property

[read/write] the description of this Test.

public virtual Content.WebCacheContent Description {get; set;}

Property Value

the description of this Test.

See Also

Test.WebCacheTest Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Test.WebCacheTest Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Test.WebCacheTest Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Test.WebCacheTest Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Test.WebCacheTest Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Test.WebCacheTest Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Test.WebCacheTest Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Test.WebCacheTest Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Test.WebCacheTest Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Test.WebCacheTest Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Test.WebCacheTest Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Test.WebCacheTest Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Test.WebCacheTest Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Test.WebCacheTest Class | StarTeam Namespace


IsLeaf Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IsLeaf Property

[read] true if this tree item is a leaf

new public virtual Boolean IsLeaf {get;}

Property Value

true if this tree item is a leaf

See Also

Test.WebCacheTest Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Test.WebCacheTest Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Test.WebCacheTest Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Test.WebCacheTest Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Test.WebCacheTest Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Test.WebCacheTest Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Test.WebCacheTest Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Test.WebCacheTest Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Test.WebCacheTest Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Test.WebCacheTest Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Name Property

new public virtual String Name {get; set;}

See Also

Test.WebCacheTest Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Test.WebCacheTest Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Test.WebCacheTest Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Test.WebCacheTest Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Parent Property

[read] the TreeItem which is the Parent of this instance, or NULL if this is a root

new public virtual TreeItem.WebCacheTreeItem Parent {get;}

Property Value

the TreeItem which is the Parent of this instance, or NULL if this is a root

See Also

Test.WebCacheTest Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Test.WebCacheTest Class | StarTeam Namespace


Path Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Path Property

[read/write] the Path.

public virtual String Path {get; set;}

Property Value

the Path.

See Also

Test.WebCacheTest Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Test.WebCacheTest Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Test.WebCacheTest Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Test.WebCacheTest Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Test.WebCacheTest Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Test.WebCacheTest Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Test.WebCacheTest Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Test.WebCacheTest Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Test.WebCacheTest Class | StarTeam Namespace


TestID Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.TestID Property

[read] the test id.

public virtual Int32 TestID {get;}

Property Value

the test id.

See Also

Test.WebCacheTest Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Test.WebCacheTest Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Test.WebCacheTest Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Test.WebCacheTest Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Test.WebCacheTest.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest Methods

The methods of the Test.WebCacheTest class are listed below. For a complete list of Test.WebCacheTest class members, see the Test.WebCacheTest Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Test.WebCacheTest.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Test.WebCacheTest.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Test.WebCacheTest.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Test.WebCacheTest.Create Method

Overload List

public static WebCacheTest Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,TreeItem.Type.WebCacheTreeItemType);

public static WebCacheTest Create(ArtifactCacheManager.Context,Test.WebCacheTest);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,TreeItem.WebCacheTreeItem);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheTest Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.Create Overload List


Test.WebCacheTest.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.Create Overload List


Test.WebCacheTest.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, TreeItem#Type#WebCacheTreeItemType)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
TreeItem.Type.WebCacheTreeItemType typ
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.Create Overload List


Test.WebCacheTest.Create Method (ArtifactCacheManager#Context, Test#WebCacheTest)

public static WebCacheTest Create(
ArtifactCacheManager.Context cntxt,
Test.WebCacheTest parent
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.Create Overload List


Test.WebCacheTest.Create Method (ArtifactCacheManager#Context, TreeItem#WebCacheTreeItem)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
TreeItem.WebCacheTreeItem parent
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.Create Overload List


Test.WebCacheTest.Equals Method

Delegate Equals() to com.starteam.Test.WebCacheTest.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Test.WebCacheTest.Equals(obj).

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.GetChildren Method

new public virtual WebCacheTreeItem[] GetChildren(
Filter.WebCacheFilter fltr
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.GetHashCode Method

Delegate GetHashCode() to com.starteam.Test.WebCacheTest.

public override int GetHashCode();

Return Value

com.starteam.Test.WebCacheTest.GetHashCode().

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Test.WebCacheTest.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.GetValue Overload List


Test.WebCacheTest.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.GetValue Overload List


Test.WebCacheTest.HasChildren Method

Returns true if the TreeItem has at least one child.

new public virtual bool HasChildren();

Return Value

True if at least one child exists, false if no children

See Also

Test.WebCacheTest Class | StarTeam Namespace | isDisembodied


Test.WebCacheTest.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Test.WebCacheTest.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Test.WebCacheTest Class | StarTeam Namespace | WebCacheViewMemberCollection


Test.WebCacheTest.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.Lock Overload List | WebCacheViewMemberCollection


Test.WebCacheTest.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.Lock Overload List


Test.WebCacheTest.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Test.WebCacheTest Class | StarTeam Namespace | NAME


Test.WebCacheTest.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Test.WebCacheTest Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Test.WebCacheTest.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(TreeItem.WebCacheTreeItem);

new public virtual void MoveTo(View.WebCacheView);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.MoveTo Overload List


Test.WebCacheTest.MoveTo Method (TreeItem#WebCacheTreeItem)

new public virtual void MoveTo(
TreeItem.WebCacheTreeItem parent
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.MoveTo Overload List


Test.WebCacheTest.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.MoveTo Overload List


Test.WebCacheTest.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Test.WebCacheTest Class | StarTeam Namespace | isFloating | isPinned | unpin


Test.WebCacheTest.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Test.WebCacheTest Class | StarTeam Namespace | WebCacheViewMemberCollection


Test.WebCacheTest.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.SetBetween Method

new public virtual void SetBetween(
TreeItem.WebCacheTreeItem prev,
TreeItem.WebCacheTreeItem next
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.SetFirst Method

place this tree item at the head of the set of all children of its parent treeitem or folder

new public virtual void SetFirst();

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.SetLast Method

place this tree item at the end of the set of all children of its parent treeitem or folder

new public virtual void SetLast();

See Also

Test.WebCacheTest Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Test.WebCacheTest.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.SetValue Overload List


Test.WebCacheTest.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Test.WebCacheTest Class | StarTeam Namespace | Test.WebCacheTest.SetValue Overload List


Test.WebCacheTest.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.ToString Method

Delegate ToString() to com.starteam.Test.WebCacheTest.

public override string ToString();

Return Value

com.starteam.Test.WebCacheTest.ToString()

See Also

Test.WebCacheTest Class | StarTeam Namespace


Test.WebCacheTest.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Test.WebCacheTest Class | StarTeam Namespace | WebCacheViewMemberCollection


Test.WebCacheTest.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Test.WebCacheTest Class | StarTeam Namespace | isFloating | isPinned | pinTo


Test.WebCacheTest.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Test.WebCacheTest Class | StarTeam Namespace | WebCacheViewMemberCollection


Test.WebCacheTest.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Test.WebCacheTest Class | StarTeam Namespace


TestRun Class

A TestRunRun is the state of a Test after execution.

For a list of all members of this type, see TestRun Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
TestRun

public class TestRun : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun Members | StarTeam Namespace


TestRun Members

TestRun overview

Public Static Methods

Create Create a TestRun in the specified parent folder.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Build | [read/write] the Build of this TestRun.
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this TestRun.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
Duration | [read/write] The duration.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExecutedAt | [read/write] the Executed At of this TestRun.
ExecutedBy | [read/write] the Executed By of this TestRun.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBlocked | [read/write] A value indicating whether or not this test run is blocked
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this TestRun.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Product | [read/write] the Product of this TestRun.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Status | [read/write] the Status of this TestRun.
StatusReason | [read/write] the Status Reason of this TestRun.
TestName | [read/write] the Test Name.
TestRunID | [read] the test run id.
TestVersion | [read/write] the Test Version of this TestRun.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

TestRun Class | StarTeam Namespace


TestRun Properties

The properties of the TestRun class are listed below. For a complete list of TestRun class members, see the TestRun Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Build | [read/write] the Build of this TestRun.
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this TestRun.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
Duration | [read/write] The duration.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExecutedAt | [read/write] the Executed At of this TestRun.
ExecutedBy | [read/write] the Executed By of this TestRun.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBlocked | [read/write] A value indicating whether or not this test run is blocked
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this TestRun.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Product | [read/write] the Product of this TestRun.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Status | [read/write] the Status of this TestRun.
StatusReason | [read/write] the Status Reason of this TestRun.
TestName | [read/write] the Test Name.
TestRunID | [read] the test run id.
TestVersion | [read/write] the Test Version of this TestRun.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

TestRun Class | StarTeam Namespace


Build Property

Borland StarTeam SDK for .NET

TestRun.Build Property

[read/write] the Build of this TestRun.

public virtual String Build {get; set;}

Property Value

the Build of this TestRun.

See Also

TestRun Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

TestRun.Description Property

[read/write] the description of this TestRun.

public virtual Content Description {get; set;}

Property Value

the description of this TestRun.

See Also

TestRun Class | StarTeam Namespace


Duration Property

Borland StarTeam SDK for .NET

TestRun.Duration Property

[read/write] The duration.

public virtual TimeSpan Duration {get; set;}

Property Value

The duration.

See Also

TestRun Class | StarTeam Namespace


ExecutedAt Property

Borland StarTeam SDK for .NET

TestRun.ExecutedAt Property

[read/write] the Executed At of this TestRun.

public virtual DateTime ExecutedAt {get; set;}

Property Value

the Executed At of this TestRun.

See Also

TestRun Class | StarTeam Namespace


ExecutedBy Property

Borland StarTeam SDK for .NET

TestRun.ExecutedBy Property

[read/write] the Executed By of this TestRun.

public virtual String ExecutedBy {get; set;}

Property Value

the Executed By of this TestRun.

See Also

TestRun Class | StarTeam Namespace


IsBlocked Property

Borland StarTeam SDK for .NET

TestRun.IsBlocked Property

[read/write] A value indicating whether or not this test run is blocked

public virtual Boolean IsBlocked {get; set;}

Property Value

A value indicating whether or not this test run is blocked

See Also

TestRun Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

TestRun.Name Property

[read/write] the Name of this TestRun.

public virtual String Name {get; set;}

Property Value

the Name of this TestRun.

See Also

TestRun Class | StarTeam Namespace


Product Property

Borland StarTeam SDK for .NET

TestRun.Product Property

[read/write] the Product of this TestRun.

public virtual String Product {get; set;}

Property Value

the Product of this TestRun.

See Also

TestRun Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

TestRun.Properties Property

[read] the PropertyCollection of its Type

public virtual TestRun.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

TestRun Class | StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

TestRun.Status Property

[read/write] the Status of this TestRun.

public virtual String Status {get; set;}

Property Value

the Status of this TestRun.

See Also

TestRun Class | StarTeam Namespace


StatusReason Property

Borland StarTeam SDK for .NET

TestRun.StatusReason Property

[read/write] the Status Reason of this TestRun.

public virtual String StatusReason {get; set;}

Property Value

the Status Reason of this TestRun.

See Also

TestRun Class | StarTeam Namespace


TestName Property

Borland StarTeam SDK for .NET

TestRun.TestName Property

[read/write] the Test Name.

public virtual String TestName {get; set;}

Property Value

the Test Name.

See Also

TestRun Class | StarTeam Namespace


TestRunID Property

Borland StarTeam SDK for .NET

TestRun.TestRunID Property

[read] the test run id.

public virtual Int32 TestRunID {get;}

Property Value

the test run id.

See Also

TestRun Class | StarTeam Namespace


TestVersion Property

Borland StarTeam SDK for .NET

TestRun.TestVersion Property

[read/write] the Test Version of this TestRun.

public virtual String TestVersion {get; set;}

Property Value

the Test Version of this TestRun.

See Also

TestRun Class | StarTeam Namespace


TestRun Methods

The methods of the TestRun class are listed below. For a complete list of TestRun class members, see the TestRun Members topic.

Public Static Methods

Create Create a TestRun in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

TestRun Class | StarTeam Namespace


TestRun.Create Method

Create a TestRun in the specified parent folder.

public static TestRun Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new TestRun Object.

See Also

TestRun Class | StarTeam Namespace


TestRun.Type Class

Type meta-data (schema) for TestRun object instances.

For a list of all members of this type, see TestRun.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
TestRun.Type

new public class TestRun.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type Members | StarTeam Namespace


TestRun.Type Members

TestRun.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TestRun.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TestRun.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type Properties

The properties of the TestRun.Type class are listed below. For a complete list of TestRun.Type class members, see the TestRun.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

TestRun.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

TestRun.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

TestRun.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

TestRun.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

TestRun.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TestRun.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

TestRun.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

TestRun.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

TestRun.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

TestRun.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

TestRun.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

TestRun.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

TestRun.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

TestRun.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

TestRun.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.NAME Property

new public static String NAME {get;}

See Also

TestRun.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

TestRun.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

TestRun.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

TestRun.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

TestRun.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

TestRun.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

TestRun.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

TestRun.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

TestRun.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type Methods

The methods of the TestRun.Type class are listed below. For a complete list of TestRun.Type class members, see the TestRun.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TestRun.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TestRun.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.Equals(obj).

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.GetHashCode().

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.

public override string ToString();

Return Value

com.starteam.TestRun.Type.ToString()

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

TestRun.Type Class | StarTeam Namespace


TestRun.Type.BuildProperty Class

The property type of the Build property

For a list of all members of this type, see TestRun.Type.BuildProperty Members.

System.Object
Property
VectorProperty
TextProperty
TestRun.Type.BuildProperty

public class TestRun.Type.BuildProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.BuildProperty Members | StarTeam Namespace


TestRun.Type.BuildProperty Members

TestRun.Type.BuildProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.BuildProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.BuildProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.BuildProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.BuildProperty Class | StarTeam Namespace


TestRun.Type.BuildProperty Properties

The properties of the TestRun.Type.BuildProperty class are listed below. For a complete list of TestRun.Type.BuildProperty class members, see the TestRun.Type.BuildProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.BuildProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.BuildProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.BuildProperty Class | StarTeam Namespace


TestRun.Type.BuildProperty Methods

The methods of the TestRun.Type.BuildProperty class are listed below. For a complete list of TestRun.Type.BuildProperty class members, see the TestRun.Type.BuildProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.BuildProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.BuildProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.BuildProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.BuildProperty Class | StarTeam Namespace


TestRun.Type.BuildProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.BuildProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.BuildProperty.Equals(obj).

See Also

TestRun.Type.BuildProperty Class | StarTeam Namespace


TestRun.Type.BuildProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.BuildProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.BuildProperty.GetHashCode().

See Also

TestRun.Type.BuildProperty Class | StarTeam Namespace


TestRun.Type.BuildProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.BuildProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.BuildProperty.ToString()

See Also

TestRun.Type.BuildProperty Class | StarTeam Namespace


TestRun.Type.DescriptionProperty Class

The property type of the RichDescription property.

For a list of all members of this type, see TestRun.Type.DescriptionProperty Members.

System.Object
Property
ContentProperty
TestRun.Type.DescriptionProperty

public class TestRun.Type.DescriptionProperty : ContentProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.DescriptionProperty Members | StarTeam Namespace


TestRun.Type.DescriptionProperty Members

TestRun.Type.DescriptionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.TestRun.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.DescriptionProperty Class | StarTeam Namespace


TestRun.Type.DescriptionProperty Properties

The properties of the TestRun.Type.DescriptionProperty class are listed below. For a complete list of TestRun.Type.DescriptionProperty class members, see the TestRun.Type.DescriptionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.DescriptionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.DescriptionProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.DescriptionProperty Class | StarTeam Namespace


TestRun.Type.DescriptionProperty Methods

The methods of the TestRun.Type.DescriptionProperty class are listed below. For a complete list of TestRun.Type.DescriptionProperty class members, see the TestRun.Type.DescriptionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.DescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.DescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.TestRun.Type.DescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.DescriptionProperty Class | StarTeam Namespace


TestRun.Type.DescriptionProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.DescriptionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.DescriptionProperty.Equals(obj).

See Also

TestRun.Type.DescriptionProperty Class | StarTeam Namespace


TestRun.Type.DescriptionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.DescriptionProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.DescriptionProperty.GetHashCode().

See Also

TestRun.Type.DescriptionProperty Class | StarTeam Namespace


TestRun.Type.DescriptionProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.DescriptionProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.DescriptionProperty.ToString()

See Also

TestRun.Type.DescriptionProperty Class | StarTeam Namespace


TestRun.Type.DurationProperty Class

The property type of the Duration property.

For a list of all members of this type, see TestRun.Type.DurationProperty Members.

System.Object
Property
ScalarProperty
TimeSpanProperty
TestRun.Type.DurationProperty

public class TestRun.Type.DurationProperty : TimeSpanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.DurationProperty Members | StarTeam Namespace


TestRun.Type.DurationProperty Members

TestRun.Type.DurationProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.DurationProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.DurationProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.DurationProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.DurationProperty Class | StarTeam Namespace


TestRun.Type.DurationProperty Properties

The properties of the TestRun.Type.DurationProperty class are listed below. For a complete list of TestRun.Type.DurationProperty class members, see the TestRun.Type.DurationProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

See Also

TestRun.Type.DurationProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.DurationProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.DurationProperty Class | StarTeam Namespace


TestRun.Type.DurationProperty Methods

The methods of the TestRun.Type.DurationProperty class are listed below. For a complete list of TestRun.Type.DurationProperty class members, see the TestRun.Type.DurationProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.DurationProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.DurationProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.DurationProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.DurationProperty Class | StarTeam Namespace


TestRun.Type.DurationProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.DurationProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.DurationProperty.Equals(obj).

See Also

TestRun.Type.DurationProperty Class | StarTeam Namespace


TestRun.Type.DurationProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.DurationProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.DurationProperty.GetHashCode().

See Also

TestRun.Type.DurationProperty Class | StarTeam Namespace


TestRun.Type.DurationProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.DurationProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.DurationProperty.ToString()

See Also

TestRun.Type.DurationProperty Class | StarTeam Namespace


TestRun.Type.ExecutedAtProperty Class

The property type of the Created Time property.

For a list of all members of this type, see TestRun.Type.ExecutedAtProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
TestRun.Type.ExecutedAtProperty

public class TestRun.Type.ExecutedAtProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.ExecutedAtProperty Members | StarTeam Namespace


TestRun.Type.ExecutedAtProperty Members

TestRun.Type.ExecutedAtProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.ExecutedAtProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.ExecutedAtProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.ExecutedAtProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.ExecutedAtProperty Class | StarTeam Namespace


TestRun.Type.ExecutedAtProperty Properties

The properties of the TestRun.Type.ExecutedAtProperty class are listed below. For a complete list of TestRun.Type.ExecutedAtProperty class members, see the TestRun.Type.ExecutedAtProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.ExecutedAtProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.ExecutedAtProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.ExecutedAtProperty Class | StarTeam Namespace


TestRun.Type.ExecutedAtProperty Methods

The methods of the TestRun.Type.ExecutedAtProperty class are listed below. For a complete list of TestRun.Type.ExecutedAtProperty class members, see the TestRun.Type.ExecutedAtProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.ExecutedAtProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.ExecutedAtProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.ExecutedAtProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.ExecutedAtProperty Class | StarTeam Namespace


TestRun.Type.ExecutedAtProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.ExecutedAtProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.ExecutedAtProperty.Equals(obj).

See Also

TestRun.Type.ExecutedAtProperty Class | StarTeam Namespace


TestRun.Type.ExecutedAtProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.ExecutedAtProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.ExecutedAtProperty.GetHashCode().

See Also

TestRun.Type.ExecutedAtProperty Class | StarTeam Namespace


TestRun.Type.ExecutedAtProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.ExecutedAtProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.ExecutedAtProperty.ToString()

See Also

TestRun.Type.ExecutedAtProperty Class | StarTeam Namespace


TestRun.Type.ExecutedByProperty Class

The property type of the ExecutedBy property

For a list of all members of this type, see TestRun.Type.ExecutedByProperty Members.

System.Object
Property
VectorProperty
TextProperty
TestRun.Type.ExecutedByProperty

public class TestRun.Type.ExecutedByProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.ExecutedByProperty Members | StarTeam Namespace


TestRun.Type.ExecutedByProperty Members

TestRun.Type.ExecutedByProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.ExecutedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.ExecutedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.ExecutedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.ExecutedByProperty Class | StarTeam Namespace


TestRun.Type.ExecutedByProperty Properties

The properties of the TestRun.Type.ExecutedByProperty class are listed below. For a complete list of TestRun.Type.ExecutedByProperty class members, see the TestRun.Type.ExecutedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.ExecutedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.ExecutedByProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.ExecutedByProperty Class | StarTeam Namespace


TestRun.Type.ExecutedByProperty Methods

The methods of the TestRun.Type.ExecutedByProperty class are listed below. For a complete list of TestRun.Type.ExecutedByProperty class members, see the TestRun.Type.ExecutedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.ExecutedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.ExecutedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.ExecutedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.ExecutedByProperty Class | StarTeam Namespace


TestRun.Type.ExecutedByProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.ExecutedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.ExecutedByProperty.Equals(obj).

See Also

TestRun.Type.ExecutedByProperty Class | StarTeam Namespace


TestRun.Type.ExecutedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.ExecutedByProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.ExecutedByProperty.GetHashCode().

See Also

TestRun.Type.ExecutedByProperty Class | StarTeam Namespace


TestRun.Type.ExecutedByProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.ExecutedByProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.ExecutedByProperty.ToString()

See Also

TestRun.Type.ExecutedByProperty Class | StarTeam Namespace


TestRun.Type.IsBlockedProperty Class

The property type of the IsBlocked property.

For a list of all members of this type, see TestRun.Type.IsBlockedProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
TestRun.Type.IsBlockedProperty

public class TestRun.Type.IsBlockedProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.IsBlockedProperty Members | StarTeam Namespace


TestRun.Type.IsBlockedProperty Members

TestRun.Type.IsBlockedProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TestRun.Type.IsBlockedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.IsBlockedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TestRun.Type.IsBlockedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.IsBlockedProperty Class | StarTeam Namespace


TestRun.Type.IsBlockedProperty Properties

The properties of the TestRun.Type.IsBlockedProperty class are listed below. For a complete list of TestRun.Type.IsBlockedProperty class members, see the TestRun.Type.IsBlockedProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

TestRun.Type.IsBlockedProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.IsBlockedProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.IsBlockedProperty Class | StarTeam Namespace


TestRun.Type.IsBlockedProperty Methods

The methods of the TestRun.Type.IsBlockedProperty class are listed below. For a complete list of TestRun.Type.IsBlockedProperty class members, see the TestRun.Type.IsBlockedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TestRun.Type.IsBlockedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.IsBlockedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TestRun.Type.IsBlockedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.IsBlockedProperty Class | StarTeam Namespace


TestRun.Type.IsBlockedProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.IsBlockedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.IsBlockedProperty.Equals(obj).

See Also

TestRun.Type.IsBlockedProperty Class | StarTeam Namespace


TestRun.Type.IsBlockedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.IsBlockedProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.IsBlockedProperty.GetHashCode().

See Also

TestRun.Type.IsBlockedProperty Class | StarTeam Namespace


TestRun.Type.IsBlockedProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.IsBlockedProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.IsBlockedProperty.ToString()

See Also

TestRun.Type.IsBlockedProperty Class | StarTeam Namespace


TestRun.Type.ProductProperty Class

The property type of the Product property

For a list of all members of this type, see TestRun.Type.ProductProperty Members.

System.Object
Property
VectorProperty
TextProperty
TestRun.Type.ProductProperty

public class TestRun.Type.ProductProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.ProductProperty Members | StarTeam Namespace


TestRun.Type.ProductProperty Members

TestRun.Type.ProductProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.ProductProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.ProductProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.ProductProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.ProductProperty Class | StarTeam Namespace


TestRun.Type.ProductProperty Properties

The properties of the TestRun.Type.ProductProperty class are listed below. For a complete list of TestRun.Type.ProductProperty class members, see the TestRun.Type.ProductProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.ProductProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.ProductProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.ProductProperty Class | StarTeam Namespace


TestRun.Type.ProductProperty Methods

The methods of the TestRun.Type.ProductProperty class are listed below. For a complete list of TestRun.Type.ProductProperty class members, see the TestRun.Type.ProductProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.ProductProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.ProductProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.ProductProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.ProductProperty Class | StarTeam Namespace


TestRun.Type.ProductProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.ProductProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.ProductProperty.Equals(obj).

See Also

TestRun.Type.ProductProperty Class | StarTeam Namespace


TestRun.Type.ProductProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.ProductProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.ProductProperty.GetHashCode().

See Also

TestRun.Type.ProductProperty Class | StarTeam Namespace


TestRun.Type.ProductProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.ProductProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.ProductProperty.ToString()

See Also

TestRun.Type.ProductProperty Class | StarTeam Namespace


TestRun.Type.PropertyCollection Class

The PropertyCollection of a TestRun

For a list of all members of this type, see TestRun.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
TestRun.Type.PropertyCollection

new public class TestRun.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.PropertyCollection Members | StarTeam Namespace


TestRun.Type.PropertyCollection Members

TestRun.Type.PropertyCollection overview

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
BUILD |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
DURATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXECUTED_AT |
EXECUTED_BY |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BLOCKED |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PRODUCT |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
STATUS_REASON |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TEST_NAME |
TEST_RUN_ID |
TEST_VERSION |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.TestRun.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.TestRun.Type.PropertyCollection.

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


TestRun.Type.PropertyCollection Properties

The properties of the TestRun.Type.PropertyCollection class are listed below. For a complete list of TestRun.Type.PropertyCollection class members, see the TestRun.Type.PropertyCollection Members topic.

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
BUILD |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
DURATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXECUTED_AT |
EXECUTED_BY |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BLOCKED |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
PRODUCT |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
STATUS_REASON |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TEST_NAME |
TEST_RUN_ID |
TEST_VERSION |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


BUILD Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.BUILD Property

public TestRun.Type.BuildProperty BUILD {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.DESCRIPTION Property

public ContentProperty DESCRIPTION {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


DURATION Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.DURATION Property

public TestRun.Type.DurationProperty DURATION {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


EXECUTED_AT Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.EXECUTED_AT Property

public TestRun.Type.ExecutedAtProperty EXECUTED_AT {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


EXECUTED_BY Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.EXECUTED_BY Property

public TestRun.Type.ExecutedByProperty EXECUTED_BY {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


IS_BLOCKED Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.IS_BLOCKED Property

public TestRun.Type.IsBlockedProperty IS_BLOCKED {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


PRODUCT Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.PRODUCT Property

public TestRun.Type.ProductProperty PRODUCT {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.STATUS Property

public TestRun.Type.StatusProperty STATUS {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


STATUS_REASON Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.STATUS_REASON Property

public TestRun.Type.StatusReasonProperty STATUS_REASON {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


TEST_NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.TEST_NAME Property

public TestRun.Type.TestNameProperty TEST_NAME {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


TEST_RUN_ID Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.TEST_RUN_ID Property

public TestRun.Type.TestRunIDProperty TEST_RUN_ID {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


TEST_VERSION Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.TEST_VERSION Property

public TestRun.Type.TestVersionProperty TEST_VERSION {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

TestRun.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


TestRun.Type.PropertyCollection Methods

The methods of the TestRun.Type.PropertyCollection class are listed below. For a complete list of TestRun.Type.PropertyCollection class members, see the TestRun.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.TestRun.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.TestRun.Type.PropertyCollection.

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


TestRun.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.PropertyCollection.Equals(obj).

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


TestRun.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.PropertyCollection.GetHashCode().

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


TestRun.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.TestRun.Type.PropertyCollection.ToString()

See Also

TestRun.Type.PropertyCollection Class | StarTeam Namespace


TestRun.Type.StatusProperty Class

The property type of the Status property

For a list of all members of this type, see TestRun.Type.StatusProperty Members.

System.Object
Property
VectorProperty
TextProperty
TestRun.Type.StatusProperty

public class TestRun.Type.StatusProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.StatusProperty Members | StarTeam Namespace


TestRun.Type.StatusProperty Members

TestRun.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.StatusProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.StatusProperty Class | StarTeam Namespace


TestRun.Type.StatusProperty Properties

The properties of the TestRun.Type.StatusProperty class are listed below. For a complete list of TestRun.Type.StatusProperty class members, see the TestRun.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.StatusProperty Class | StarTeam Namespace


TestRun.Type.StatusProperty Methods

The methods of the TestRun.Type.StatusProperty class are listed below. For a complete list of TestRun.Type.StatusProperty class members, see the TestRun.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.StatusProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.StatusProperty Class | StarTeam Namespace


TestRun.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.StatusProperty.Equals(obj).

See Also

TestRun.Type.StatusProperty Class | StarTeam Namespace


TestRun.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.StatusProperty.GetHashCode().

See Also

TestRun.Type.StatusProperty Class | StarTeam Namespace


TestRun.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.StatusProperty.ToString()

See Also

TestRun.Type.StatusProperty Class | StarTeam Namespace


TestRun.Type.StatusReasonProperty Class

The property type of the StatusReason property

For a list of all members of this type, see TestRun.Type.StatusReasonProperty Members.

System.Object
Property
VectorProperty
TextProperty
TestRun.Type.StatusReasonProperty

public class TestRun.Type.StatusReasonProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.StatusReasonProperty Members | StarTeam Namespace


TestRun.Type.StatusReasonProperty Members

TestRun.Type.StatusReasonProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.StatusReasonProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.StatusReasonProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.StatusReasonProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.StatusReasonProperty Class | StarTeam Namespace


TestRun.Type.StatusReasonProperty Properties

The properties of the TestRun.Type.StatusReasonProperty class are listed below. For a complete list of TestRun.Type.StatusReasonProperty class members, see the TestRun.Type.StatusReasonProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.StatusReasonProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.StatusReasonProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.StatusReasonProperty Class | StarTeam Namespace


TestRun.Type.StatusReasonProperty Methods

The methods of the TestRun.Type.StatusReasonProperty class are listed below. For a complete list of TestRun.Type.StatusReasonProperty class members, see the TestRun.Type.StatusReasonProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.StatusReasonProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.StatusReasonProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.StatusReasonProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.StatusReasonProperty Class | StarTeam Namespace


TestRun.Type.StatusReasonProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.StatusReasonProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.StatusReasonProperty.Equals(obj).

See Also

TestRun.Type.StatusReasonProperty Class | StarTeam Namespace


TestRun.Type.StatusReasonProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.StatusReasonProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.StatusReasonProperty.GetHashCode().

See Also

TestRun.Type.StatusReasonProperty Class | StarTeam Namespace


TestRun.Type.StatusReasonProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.StatusReasonProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.StatusReasonProperty.ToString()

See Also

TestRun.Type.StatusReasonProperty Class | StarTeam Namespace


TestRun.Type.TestNameProperty Class

The property type of the TestName property

For a list of all members of this type, see TestRun.Type.TestNameProperty Members.

System.Object
Property
VectorProperty
TextProperty
TestRun.Type.TestNameProperty

public class TestRun.Type.TestNameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.TestNameProperty Members | StarTeam Namespace


TestRun.Type.TestNameProperty Members

TestRun.Type.TestNameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.TestNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.TestNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.TestNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.TestNameProperty Class | StarTeam Namespace


TestRun.Type.TestNameProperty Properties

The properties of the TestRun.Type.TestNameProperty class are listed below. For a complete list of TestRun.Type.TestNameProperty class members, see the TestRun.Type.TestNameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.TestNameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.TestNameProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.TestNameProperty Class | StarTeam Namespace


TestRun.Type.TestNameProperty Methods

The methods of the TestRun.Type.TestNameProperty class are listed below. For a complete list of TestRun.Type.TestNameProperty class members, see the TestRun.Type.TestNameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.TestNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.TestNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.TestNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.TestNameProperty Class | StarTeam Namespace


TestRun.Type.TestNameProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.TestNameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.TestNameProperty.Equals(obj).

See Also

TestRun.Type.TestNameProperty Class | StarTeam Namespace


TestRun.Type.TestNameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.TestNameProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.TestNameProperty.GetHashCode().

See Also

TestRun.Type.TestNameProperty Class | StarTeam Namespace


TestRun.Type.TestNameProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.TestNameProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.TestNameProperty.ToString()

See Also

TestRun.Type.TestNameProperty Class | StarTeam Namespace


TestRun.Type.TestRunIDProperty Class

The property type of the TestRunID property

For a list of all members of this type, see TestRun.Type.TestRunIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
TestRun.Type.TestRunIDProperty

public class TestRun.Type.TestRunIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.TestRunIDProperty Members | StarTeam Namespace


TestRun.Type.TestRunIDProperty Members

TestRun.Type.TestRunIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.TestRunIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.TestRunIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.TestRunIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.TestRunIDProperty Class | StarTeam Namespace


TestRun.Type.TestRunIDProperty Properties

The properties of the TestRun.Type.TestRunIDProperty class are listed below. For a complete list of TestRun.Type.TestRunIDProperty class members, see the TestRun.Type.TestRunIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.TestRunIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.TestRunIDProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.TestRunIDProperty Class | StarTeam Namespace


TestRun.Type.TestRunIDProperty Methods

The methods of the TestRun.Type.TestRunIDProperty class are listed below. For a complete list of TestRun.Type.TestRunIDProperty class members, see the TestRun.Type.TestRunIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.TestRunIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.TestRunIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.TestRunIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.TestRunIDProperty Class | StarTeam Namespace


TestRun.Type.TestRunIDProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.TestRunIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.TestRunIDProperty.Equals(obj).

See Also

TestRun.Type.TestRunIDProperty Class | StarTeam Namespace


TestRun.Type.TestRunIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.TestRunIDProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.TestRunIDProperty.GetHashCode().

See Also

TestRun.Type.TestRunIDProperty Class | StarTeam Namespace


TestRun.Type.TestRunIDProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.TestRunIDProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.TestRunIDProperty.ToString()

See Also

TestRun.Type.TestRunIDProperty Class | StarTeam Namespace


TestRun.Type.TestVersionProperty Class

The property type of the TestVersion property

For a list of all members of this type, see TestRun.Type.TestVersionProperty Members.

System.Object
Property
VectorProperty
TextProperty
TestRun.Type.TestVersionProperty

public class TestRun.Type.TestVersionProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.Type.TestVersionProperty Members | StarTeam Namespace


TestRun.Type.TestVersionProperty Members

TestRun.Type.TestVersionProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.TestVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.TestVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.TestVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.TestVersionProperty Class | StarTeam Namespace


TestRun.Type.TestVersionProperty Properties

The properties of the TestRun.Type.TestVersionProperty class are listed below. For a complete list of TestRun.Type.TestVersionProperty class members, see the TestRun.Type.TestVersionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TestRun.Type.TestVersionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TestRun.Type.TestVersionProperty.NAME Property

public static String NAME {get;}

See Also

TestRun.Type.TestVersionProperty Class | StarTeam Namespace


TestRun.Type.TestVersionProperty Methods

The methods of the TestRun.Type.TestVersionProperty class are listed below. For a complete list of TestRun.Type.TestVersionProperty class members, see the TestRun.Type.TestVersionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TestRun.Type.TestVersionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.Type.TestVersionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TestRun.Type.TestVersionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TestRun.Type.TestVersionProperty Class | StarTeam Namespace


TestRun.Type.TestVersionProperty.Equals Method

Delegate Equals() to com.starteam.TestRun.Type.TestVersionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.Type.TestVersionProperty.Equals(obj).

See Also

TestRun.Type.TestVersionProperty Class | StarTeam Namespace


TestRun.Type.TestVersionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.Type.TestVersionProperty.

public override int GetHashCode();

Return Value

com.starteam.TestRun.Type.TestVersionProperty.GetHashCode().

See Also

TestRun.Type.TestVersionProperty Class | StarTeam Namespace


TestRun.Type.TestVersionProperty.ToString Method

Delegate ToString() to com.starteam.TestRun.Type.TestVersionProperty.

public override string ToString();

Return Value

com.starteam.TestRun.Type.TestVersionProperty.ToString()

See Also

TestRun.Type.TestVersionProperty Class | StarTeam Namespace


TestRun.WebCacheTestRun Class

Item accessor for cached SDK TestRun items contained objects are obtained from the artifact cache

For a list of all members of this type, see TestRun.WebCacheTestRun Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
TestRun.WebCacheTestRun

public class TestRun.WebCacheTestRun : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TestRun.WebCacheTestRun Members | StarTeam Namespace


TestRun.WebCacheTestRun Members

TestRun.WebCacheTestRun overview

Public Static Methods

Create Overloaded.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
Build | [read/write] the build of this TestRun.
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this TestRun.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
Duration | [read/write] the Duration of this TestRun.
ExecutedAt | [read/write] the Executed At of this TestRun.
ExecutedBy | [read/write] the Executed By of this TestRun.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBlocked | [read/write] A value indicating whether or not this test run is blocked
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
Product | [read/write] the product of this TestRun.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Status | [read/write] the status of this TestRun.
StatusReason | [read/write] the status reason of this TestRun.
TestName | [read/write] the Test Name.
TestRunID | [read] the test run id.
TestVersion | [read/write] the test version of this TestRun.
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.TestRun.WebCacheTestRun.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.WebCacheTestRun.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.TestRun.WebCacheTestRun.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun Properties

The properties of the TestRun.WebCacheTestRun class are listed below. For a complete list of TestRun.WebCacheTestRun class members, see the TestRun.WebCacheTestRun Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
Build | [read/write] the build of this TestRun.
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this TestRun.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
Duration | [read/write] the Duration of this TestRun.
ExecutedAt | [read/write] the Executed At of this TestRun.
ExecutedBy | [read/write] the Executed By of this TestRun.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBlocked | [read/write] A value indicating whether or not this test run is blocked
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
Product | [read/write] the product of this TestRun.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Status | [read/write] the status of this TestRun.
StatusReason | [read/write] the status reason of this TestRun.
TestName | [read/write] the Test Name.
TestRunID | [read] the test run id.
TestVersion | [read/write] the test version of this TestRun.
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Build Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Build Property

[read/write] the build of this TestRun.

public virtual String Build {get; set;}

Property Value

the build of this TestRun.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Description Property

[read/write] the description of this TestRun.

public virtual Content.WebCacheContent Description {get; set;}

Property Value

the description of this TestRun.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Duration Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Duration Property

[read/write] the Duration of this TestRun.

public virtual TimeSpan Duration {get; set;}

Property Value

the Duration of this TestRun.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ExecutedAt Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ExecutedAt Property

[read/write] the Executed At of this TestRun.

public virtual DateTime ExecutedAt {get; set;}

Property Value

the Executed At of this TestRun.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ExecutedBy Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ExecutedBy Property

[read/write] the Executed By of this TestRun.

public virtual String ExecutedBy {get; set;}

Property Value

the Executed By of this TestRun.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IsBlocked Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IsBlocked Property

[read/write] A value indicating whether or not this test run is blocked

public virtual Boolean IsBlocked {get; set;}

Property Value

A value indicating whether or not this test run is blocked

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Name Property

new public virtual String Name {get; set;}

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Product Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Product Property

[read/write] the product of this TestRun.

public virtual String Product {get; set;}

Property Value

the product of this TestRun.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Status Property

[read/write] the status of this TestRun.

public virtual String Status {get; set;}

Property Value

the status of this TestRun.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


StatusReason Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.StatusReason Property

[read/write] the status reason of this TestRun.

public virtual String StatusReason {get; set;}

Property Value

the status reason of this TestRun.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestName Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.TestName Property

[read/write] the Test Name.

public virtual String TestName {get; set;}

Property Value

the Test Name.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRunID Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.TestRunID Property

[read] the test run id.

public virtual Int32 TestRunID {get;}

Property Value

the test run id.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestVersion Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.TestVersion Property

[read/write] the test version of this TestRun.

public virtual String TestVersion {get; set;}

Property Value

the test version of this TestRun.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun Methods

The methods of the TestRun.WebCacheTestRun class are listed below. For a complete list of TestRun.WebCacheTestRun class members, see the TestRun.WebCacheTestRun Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.TestRun.WebCacheTestRun.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.TestRun.WebCacheTestRun.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.TestRun.WebCacheTestRun.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Create Method

Overload List

public static WebCacheTestRun Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheTestRun Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.Create Overload List


TestRun.WebCacheTestRun.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.Create Overload List


TestRun.WebCacheTestRun.Equals Method

Delegate Equals() to com.starteam.TestRun.WebCacheTestRun.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TestRun.WebCacheTestRun.Equals(obj).

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.GetHashCode Method

Delegate GetHashCode() to com.starteam.TestRun.WebCacheTestRun.

public override int GetHashCode();

Return Value

com.starteam.TestRun.WebCacheTestRun.GetHashCode().

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.GetValue Overload List


TestRun.WebCacheTestRun.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.GetValue Overload List


TestRun.WebCacheTestRun.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | WebCacheViewMemberCollection


TestRun.WebCacheTestRun.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.Lock Overload List | WebCacheViewMemberCollection


TestRun.WebCacheTestRun.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.Lock Overload List


TestRun.WebCacheTestRun.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | NAME


TestRun.WebCacheTestRun.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.MoveTo Overload List


TestRun.WebCacheTestRun.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.MoveTo Overload List


TestRun.WebCacheTestRun.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | isFloating | isPinned | unpin


TestRun.WebCacheTestRun.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | WebCacheViewMemberCollection


TestRun.WebCacheTestRun.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

TestRun.WebCacheTestRun.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.SetValue Overload List


TestRun.WebCacheTestRun.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | TestRun.WebCacheTestRun.SetValue Overload List


TestRun.WebCacheTestRun.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.ToString Method

Delegate ToString() to com.starteam.TestRun.WebCacheTestRun.

public override string ToString();

Return Value

com.starteam.TestRun.WebCacheTestRun.ToString()

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TestRun.WebCacheTestRun.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | WebCacheViewMemberCollection


TestRun.WebCacheTestRun.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | isFloating | isPinned | pinTo


TestRun.WebCacheTestRun.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace | WebCacheViewMemberCollection


TestRun.WebCacheTestRun.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

TestRun.WebCacheTestRun Class | StarTeam Namespace


TextProperty Class

A base interface for all properties of type Text

For a list of all members of this type, see TextProperty Members.

System.Object
Property
VectorProperty
TextProperty
Derived types

public class TextProperty : VectorProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TextProperty Members | StarTeam Namespace


TextProperty Members

TextProperty overview

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TextProperty Class | StarTeam Namespace


TextProperty Properties

The properties of the TextProperty class are listed below. For a complete list of TextProperty class members, see the TextProperty Members topic.

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TextProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

TextProperty.DefaultValue Property

[read/write] String

new public virtual String DefaultValue {get; set;}

Property Value

String

See Also

TextProperty Class | StarTeam Namespace


TextProperty Methods

The methods of the TextProperty class are listed below. For a complete list of TextProperty class members, see the TextProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TextProperty Class | StarTeam Namespace


NewQueryPart Method

Borland StarTeam SDK for .NET

TextProperty.NewQueryPart Method

Overload List

public virtual QueryPart NewQueryPart(QueryPart.Relation,String);

public virtual QueryPart NewQueryPart(QueryPart.Relation,String,Boolean);

See Also

TextProperty Class | StarTeam Namespace


TextProperty.NewQueryPart Method (QueryPart#Relation, String)

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
String value
);

See Also

TextProperty Class | StarTeam Namespace | TextProperty.NewQueryPart Overload List


TextProperty.NewQueryPart Method (QueryPart#Relation, String, Boolean)

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
String value,
Boolean bIgnoreCase
);

See Also

TextProperty Class | StarTeam Namespace | TextProperty.NewQueryPart Overload List


TextProperty.WebCacheTextProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see TextProperty.WebCacheTextProperty Members.

System.Object
Property.WebCacheProperty
VectorProperty.WebCacheVectorProperty
TextProperty.WebCacheTextProperty

public class TextProperty.WebCacheTextProperty : WebCacheVectorProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TextProperty.WebCacheTextProperty Members | StarTeam Namespace


TextProperty.WebCacheTextProperty Members

TextProperty.WebCacheTextProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] String
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TextProperty.WebCacheTextProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TextProperty.WebCacheTextProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TextProperty.WebCacheTextProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty Properties

The properties of the TextProperty.WebCacheTextProperty class are listed below. For a complete list of TextProperty.WebCacheTextProperty class members, see the TextProperty.WebCacheTextProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] String
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.DefaultValue Property

[read/write] String

new public virtual String DefaultValue {get; set;}

Property Value

String

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


MaxLength Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.MaxLength Property

[read/write] The maximum length of a property value.

new public virtual Int32 MaxLength {get; set;}

Property Value

The maximum length of a property value.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


MinLength Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.MinLength Property

[read/write] The minimum length of a property value.

new public virtual Int32 MinLength {get; set;}

Property Value

The minimum length of a property value.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.Name Property

new public virtual String Name {get;}

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

TextProperty.WebCacheTextProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty Methods

The methods of the TextProperty.WebCacheTextProperty class are listed below. For a complete list of TextProperty.WebCacheTextProperty class members, see the TextProperty.WebCacheTextProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TextProperty.WebCacheTextProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TextProperty.WebCacheTextProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TextProperty.WebCacheTextProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.Equals Method

Delegate Equals() to com.starteam.TextProperty.WebCacheTextProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TextProperty.WebCacheTextProperty.Equals(obj).

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TextProperty.WebCacheTextProperty.

public override int GetHashCode();

Return Value

com.starteam.TextProperty.WebCacheTextProperty.GetHashCode().

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.NewQueryPart Method

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
String value,
Boolean bIgnoreCase
);

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.ToString Method

Delegate ToString() to com.starteam.TextProperty.WebCacheTextProperty.

public override string ToString();

Return Value

com.starteam.TextProperty.WebCacheTextProperty.ToString()

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TextProperty.WebCacheTextProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

TextProperty.WebCacheTextProperty Class | StarTeam Namespace


TimeSpanProperty Class

Description: Represents a TimeSpan Property

For a list of all members of this type, see TimeSpanProperty Members.

System.Object
Property
ScalarProperty
TimeSpanProperty
Derived types

public class TimeSpanProperty : ScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TimeSpanProperty Members | StarTeam Namespace


TimeSpanProperty Members

TimeSpanProperty overview

Public Static Properties

DEFAULT_TIMESPAN_DISPLAYFORMAT
DEFAULT_TIMESPAN_UNITS
MAX_VALUE
MIN_VALUE
ZERO

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] TimeSpan
MinValue | Overloaded. [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units | [read/write] TimeSpan

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty Properties

The properties of the TimeSpanProperty class are listed below. For a complete list of TimeSpanProperty class members, see the TimeSpanProperty Members topic.

Public Static Properties

DEFAULT_TIMESPAN_DISPLAYFORMAT
DEFAULT_TIMESPAN_UNITS
MAX_VALUE
MIN_VALUE
ZERO

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue | Overloaded. [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | Overloaded. [read/write] TimeSpan
MinValue | Overloaded. [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units | [read/write] TimeSpan

See Also

TimeSpanProperty Class | StarTeam Namespace


DEFAULT_TIMESPAN_DISPLAYFORMAT Property

Borland StarTeam SDK for .NET

TimeSpanProperty.DEFAULT_TIMESPAN_DISPLAYFORMAT Property

public static String DEFAULT_TIMESPAN_DISPLAYFORMAT {get;}

See Also

TimeSpanProperty Class | StarTeam Namespace


DEFAULT_TIMESPAN_UNITS Property

Borland StarTeam SDK for .NET

TimeSpanProperty.DEFAULT_TIMESPAN_UNITS Property

public static TimeSpan DEFAULT_TIMESPAN_UNITS {get;}

See Also

TimeSpanProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

TimeSpanProperty.DefaultValue Property

[read/write] TimeSpan

new public virtual TimeSpan DefaultValue {get; set;}

Property Value

TimeSpan

See Also

TimeSpanProperty Class | StarTeam Namespace


DisplayFormat Property

Borland StarTeam SDK for .NET

TimeSpanProperty.DisplayFormat Property

[read/write] String

public virtual String DisplayFormat {get; set;}

Property Value

String

See Also

TimeSpanProperty Class | StarTeam Namespace


MAX_VALUE Property

Borland StarTeam SDK for .NET

TimeSpanProperty.MAX_VALUE Property

public static TimeSpan MAX_VALUE {get;}

Property Value

The largest value of a TimeSpan (DoubleProperty.MAX_VALUE)

See Also

TimeSpanProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

TimeSpanProperty.MaxValue Property

[read/write] TimeSpan

new public virtual TimeSpan MaxValue {get; set;}

Property Value

TimeSpan

See Also

TimeSpanProperty Class | StarTeam Namespace


MIN_VALUE Property

Borland StarTeam SDK for .NET

TimeSpanProperty.MIN_VALUE Property

public static TimeSpan MIN_VALUE {get;}

Property Value

The smallest value of a TimeSpan (DoubleProperty.MIN_VALUE)

See Also

TimeSpanProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

TimeSpanProperty.MinValue Property

[read/write] TimeSpan

new public virtual TimeSpan MinValue {get; set;}

Property Value

TimeSpan

See Also

TimeSpanProperty Class | StarTeam Namespace


Units Property

Borland StarTeam SDK for .NET

TimeSpanProperty.Units Property

[read/write] TimeSpan

public virtual TimeSpan Units {get; set;}

Property Value

TimeSpan

See Also

TimeSpanProperty Class | StarTeam Namespace


ZERO Property

Borland StarTeam SDK for .NET

TimeSpanProperty.ZERO Property

public static TimeSpan ZERO {get;}

Property Value

A TimeSpan of value 0.0

See Also

TimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty Methods

The methods of the TimeSpanProperty class are listed below. For a complete list of TimeSpanProperty class members, see the TimeSpanProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.NewQueryPart Method

public virtual QueryPart NewQueryPart(
QueryPart.Relation relation,
TimeSpan value
);

See Also

TimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see TimeSpanProperty.WebCacheTimeSpanProperty Members.

System.Object
Property.WebCacheProperty
ScalarProperty.WebCacheScalarProperty
TimeSpanProperty.WebCacheTimeSpanProperty

public class TimeSpanProperty.WebCacheTimeSpanProperty : WebCacheScalarProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Members | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty Members

TimeSpanProperty.WebCacheTimeSpanProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] TimeSpan
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] TimeSpan
MinValue | [read/write] TimeSpan
MyType | [read] the type of this resource.
Name |
NameProperty |
Units | [read/write] TimeSpan

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty Properties

The properties of the TimeSpanProperty.WebCacheTimeSpanProperty class are listed below. For a complete list of TimeSpanProperty.WebCacheTimeSpanProperty class members, see the TimeSpanProperty.WebCacheTimeSpanProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | Overloaded. [read/write] TimeSpan
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue | [read/write] TimeSpan
MinValue | [read/write] TimeSpan
MyType | [read] the type of this resource.
Name |
NameProperty |
Units | [read/write] TimeSpan

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.DefaultValue Property

[read/write] TimeSpan

new public virtual TimeSpan DefaultValue {get; set;}

Property Value

TimeSpan

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


MaxValue Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.MaxValue Property

[read/write] TimeSpan

public virtual TimeSpan MaxValue {get; set;}

Property Value

TimeSpan

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


MinValue Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.MinValue Property

[read/write] TimeSpan

public virtual TimeSpan MinValue {get; set;}

Property Value

TimeSpan

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.Name Property

new public virtual String Name {get;}

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


Units Property

Borland StarTeam SDK for .NET

TimeSpanProperty.WebCacheTimeSpanProperty.Units Property

[read/write] TimeSpan

public virtual TimeSpan Units {get; set;}

Property Value

TimeSpan

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty Methods

The methods of the TimeSpanProperty.WebCacheTimeSpanProperty class are listed below. For a complete list of TimeSpanProperty.WebCacheTimeSpanProperty class members, see the TimeSpanProperty.WebCacheTimeSpanProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
NewQueryPart |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.Equals Method

Delegate Equals() to com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.Equals(obj).

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.

public override int GetHashCode();

Return Value

com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.GetHashCode().

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.NewQueryPart Method

public virtual WebCacheQueryPart NewQueryPart(
QueryPart.Relation relation,
TimeSpan value
);

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.ToString Method

Delegate ToString() to com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.

public override string ToString();

Return Value

com.starteam.TimeSpanProperty.WebCacheTimeSpanProperty.ToString()

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


TimeSpanProperty.WebCacheTimeSpanProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

TimeSpanProperty.WebCacheTimeSpanProperty Class | StarTeam Namespace


Topic Class

Represents a StarTeam Topic.

For a list of all members of this type, see Topic Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
TreeItem
Topic

public class Topic : TreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic Members | StarTeam Namespace


Topic Members

Topic overview

Public Static Methods

Create Create a Topic in the specified parent folder.

Public Instance Constructors

Topic Constructor Creates a new topic that is a subtopic of an existing topic.

Public Instance Properties

After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
ContextRange | [read/write] The context range of the topic.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Dislikes | [read] The users who have expressed a dislike for this topic.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Likes | [read] The users who have expressed a like for this topic.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
Number | [read] The topic number of this topic.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
ParentTopic | [read] The ObjectID of this topic's parent topic, or -1 if this is a root topic.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The Priority of this topic.
Properties | [read]
RecipientCount | [read] The number of recipients assigned to this topic.
Recipients | [read] The users assigned as recipients of this topic.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The Status of this topic.
Taxonomies | [read/write] the taxonomy, if any attached to this topic
Text | [read/write] The text or body of the topic.
Title | [read/write] The title or subject of the topic.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddDislike | Adds the specified user object as a disliker of this topic.
AddLike | Adds the specified user object as a liker of this topic.
AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddRecipient | Adds the specified user object as a recipient for this topic.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AmIRecipient | Returns a value indicating whether the logged on user is a recipient of this topic.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveDislike | Removes the specified user object as a disliker of this topic.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveLike | Removes the specified user object as a liker of this topic.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
RemoveRecipient | Removes the specified user object as a recipient from this topic.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Topic Class | StarTeam Namespace


Topic Constructor

Creates a new topic that is a subtopic of an existing topic.

public Topic(
Topic parentTopic
);

Parameters

parentTopic
The parent topic.

See Also

Topic Class | StarTeam Namespace


Topic Properties

The properties of the Topic class are listed below. For a complete list of Topic class members, see the Topic Members topic.

Public Instance Properties

After (inherited from TreeItem) | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before (inherited from TreeItem) | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children (inherited from TreeItem) | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
ContextRange | [read/write] The context range of the topic.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Dislikes | [read] The users who have expressed a dislike for this topic.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf (inherited from TreeItem) | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Likes | [read] The users who have expressed a like for this topic.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
Number | [read] The topic number of this topic.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
OrderProperty (inherited from TreeItem) | [read] a DoubleProperty used for ordering tree item instances
Parent (inherited from TreeItem) | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID (inherited from TreeItem) | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
ParentTopic | [read] The ObjectID of this topic's parent topic, or -1 if this is a root topic.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The Priority of this topic.
Properties | [read]
RecipientCount | [read] The number of recipients assigned to this topic.
Recipients | [read] The users assigned as recipients of this topic.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The Status of this topic.
Taxonomies | [read/write] the taxonomy, if any attached to this topic
Text | [read/write] The text or body of the topic.
Title | [read/write] The title or subject of the topic.
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Topic Class | StarTeam Namespace


ContextRange Property

Borland StarTeam SDK for .NET

Topic.ContextRange Property

[read/write] The context range of the topic.

public virtual String ContextRange {get; set;}

Property Value

The context range of the topic.

See Also

Topic Class | StarTeam Namespace


Dislikes Property

Borland StarTeam SDK for .NET

Topic.Dislikes Property

[read] The users who have expressed a dislike for this topic.

public virtual User[] Dislikes {get;}

Property Value

The users who have expressed a dislike for this topic.

See Also

Topic Class | StarTeam Namespace


Likes Property

Borland StarTeam SDK for .NET

Topic.Likes Property

[read] The users who have expressed a like for this topic.

public virtual User[] Likes {get;}

Property Value

The users who have expressed a like for this topic.

See Also

Topic Class | StarTeam Namespace


Number Property

Borland StarTeam SDK for .NET

Topic.Number Property

[read] The topic number of this topic.

public virtual Int32 Number {get;}

Property Value

The topic number of this topic.

See Also

Topic Class | StarTeam Namespace


ParentTopic Property

Borland StarTeam SDK for .NET

Topic.ParentTopic Property

[read] The ObjectID of this topic's parent topic, or -1 if this is a root topic.

public virtual Int32 ParentTopic {get;}

Property Value

The ObjectID of this topic's parent topic, or -1 if this is a root topic.

See Also

Topic Class | StarTeam Namespace


PriorityValue Property

Borland StarTeam SDK for .NET

Topic.PriorityValue Property

[read/write] The Priority of this topic.

public virtual Topic.Priority PriorityValue {get; set;}

Property Value

The Priority of this topic.

See Also

Topic Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Topic.Properties Property

[read]

public virtual Topic.Type.PropertyCollection Properties {get;}

See Also

Topic Class | StarTeam Namespace


RecipientCount Property

Borland StarTeam SDK for .NET

Topic.RecipientCount Property

[read] The number of recipients assigned to this topic.

public virtual Int32 RecipientCount {get;}

Property Value

The number of recipients assigned to this topic.

See Also

Topic Class | StarTeam Namespace


Recipients Property

Borland StarTeam SDK for .NET

Topic.Recipients Property

[read] The users assigned as recipients of this topic.

public virtual User[] Recipients {get;}

Property Value

The users assigned as recipients of this topic.

See Also

Topic Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Topic.StatusValue Property

[read/write] The Status of this topic.

public virtual Topic.Status StatusValue {get; set;}

Property Value

The Status of this topic.

See Also

Topic Class | StarTeam Namespace


Taxonomies Property

Borland StarTeam SDK for .NET

Topic.Taxonomies Property

[read/write] the taxonomy, if any attached to this topic

public virtual EnumeratedValue[] Taxonomies {get; set;}

Property Value

the taxonomy, if any attached to this topic

See Also

Topic Class | StarTeam Namespace


Text Property

Borland StarTeam SDK for .NET

Topic.Text Property

[read/write] The text or body of the topic.

public virtual String Text {get; set;}

Property Value

The text or body of the topic.

See Also

Topic Class | StarTeam Namespace


Title Property

Borland StarTeam SDK for .NET

Topic.Title Property

[read/write] The title or subject of the topic.

public virtual String Title {get; set;}

Property Value

The title or subject of the topic.

See Also

Topic Class | StarTeam Namespace


Topic Methods

The methods of the Topic class are listed below. For a complete list of Topic class members, see the Topic Members topic.

Public Static Methods

Create Create a Topic in the specified parent folder.

Public Instance Methods

AddDislike | Adds the specified user object as a disliker of this topic.
AddLike | Adds the specified user object as a liker of this topic.
AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddRecipient | Adds the specified user object as a recipient for this topic.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
AmIRecipient | Returns a value indicating whether the logged on user is a recipient of this topic.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild (inherited from TreeItem) | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren (inherited from TreeItem) | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from TreeItem) | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from TreeItem) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveDislike | Removes the specified user object as a disliker of this topic.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveLike | Removes the specified user object as a liker of this topic.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
RemoveRecipient | Removes the specified user object as a recipient from this topic.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween (inherited from TreeItem) | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst (inherited from TreeItem) | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast (inherited from TreeItem) | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Topic Class | StarTeam Namespace


Topic.AddDislike Method

Adds the specified user object as a disliker of this topic.

public virtual void AddDislike(
User user
);

Parameters

user
the user object to add as a disliker of this topic

See Also

Topic Class | StarTeam Namespace


Topic.AddLike Method

Adds the specified user object as a liker of this topic.

public virtual void AddLike(
User user
);

Parameters

user
the user object to add as a liker of this topic

See Also

Topic Class | StarTeam Namespace


Topic.AddRecipient Method

Adds the specified user object as a recipient for this topic.

public virtual void AddRecipient(
User user
);

Parameters

user
the user object to add as a recipient for this topic,

See Also

Topic Class | StarTeam Namespace


Topic.AmIRecipient Method

Returns a value indicating whether the logged on user is a recipient of this topic.

public virtual bool AmIRecipient();

Return Value

A value indicating whether the logged on user is a recipient of this topic.

See Also

Topic Class | StarTeam Namespace | NAME | addRecipient | removeRecipient | getRecipients


Topic.Create Method

Create a Topic in the specified parent folder.

public static Topic Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new Topic Object.

See Also

Topic Class | StarTeam Namespace


Topic.RemoveDislike Method

Removes the specified user object as a disliker of this topic.

public virtual void RemoveDislike(
User user
);

Parameters

user
the user object to remove as a disliker of this topic.

See Also

Topic Class | StarTeam Namespace


Topic.RemoveLike Method

Removes the specified user object as a liker of this topic.

public virtual void RemoveLike(
User user
);

Parameters

user
the user object to remove as a liker of this topic.

See Also

Topic Class | StarTeam Namespace


Topic.RemoveRecipient Method

Removes the specified user object as a recipient from this topic.

public virtual void RemoveRecipient(
User user
);

Parameters

user
the user object recipient to remove from this topic.

See Also

Topic Class | StarTeam Namespace


Topic.Priority Class

Priority of the Topic

For a list of all members of this type, see Topic.Priority Members.

System.Object
EnumeratedValue
Topic.Priority

public class Topic.Priority : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Priority Members | StarTeam Namespace


Topic.Priority Members

Topic.Priority overview

Public Static Properties

ALL
HIGH
LOW
NORMAL

Public Static Methods

FromID | Gets the Priority value corresponding to the given ID.
FromValue | Gets the Priority value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Priority value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Topic.Priority.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Priority.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Topic.Priority.

See Also

Topic.Priority Class | StarTeam Namespace


Topic.Priority Properties

The properties of the Topic.Priority class are listed below. For a complete list of Topic.Priority class members, see the Topic.Priority Members topic.

Public Static Properties

ALL
HIGH
LOW
NORMAL

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Priority value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Topic.Priority Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Topic.Priority.ALL Property

public static Priority[] ALL {get;}

See Also

Topic.Priority Class | StarTeam Namespace


HIGH Property

Borland StarTeam SDK for .NET

Topic.Priority.HIGH Property

public static Topic.Priority HIGH {get;}

Property Value

Topic priority is high

See Also

Topic.Priority Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Topic.Priority.ID Property

[read] The ID of this Priority value.

public virtual Int32 ID {get;}

Property Value

The ID of this Priority value.

See Also

Topic.Priority Class | StarTeam Namespace


LOW Property

Borland StarTeam SDK for .NET

Topic.Priority.LOW Property

public static Topic.Priority LOW {get;}

Property Value

Topic priority is low

See Also

Topic.Priority Class | StarTeam Namespace


NORMAL Property

Borland StarTeam SDK for .NET

Topic.Priority.NORMAL Property

public static Topic.Priority NORMAL {get;}

Property Value

Topic priority is lower

See Also

Topic.Priority Class | StarTeam Namespace


Topic.Priority Methods

The methods of the Topic.Priority class are listed below. For a complete list of Topic.Priority class members, see the Topic.Priority Members topic.

Public Static Methods

FromID | Gets the Priority value corresponding to the given ID.
FromValue | Gets the Priority value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Topic.Priority.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Priority.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Topic.Priority.

See Also

Topic.Priority Class | StarTeam Namespace


Topic.Priority.Equals Method

Delegate Equals() to com.starteam.Topic.Priority.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Priority.Equals(obj).

See Also

Topic.Priority Class | StarTeam Namespace


Topic.Priority.FromID Method

Gets the Priority value corresponding to the given ID.

public static Priority FromID(
Int32 id
);

Parameters

id
A Priority ID.

Return Value

The corresponding Priority value, or null.

See Also

Topic.Priority Class | StarTeam Namespace


Topic.Priority.FromValue Method

Gets the Priority value corresponding to the given EnumeratedValue.

public static Priority FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a PriorityProperty.

Return Value

The corresponding Priority value, or null.

See Also

Topic.Priority Class | StarTeam Namespace


Topic.Priority.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Priority.

public override int GetHashCode();

Return Value

com.starteam.Topic.Priority.GetHashCode().

See Also

Topic.Priority Class | StarTeam Namespace


Topic.Priority.ToString Method

Delegate ToString() to com.starteam.Topic.Priority.

public override string ToString();

Return Value

com.starteam.Topic.Priority.ToString()

See Also

Topic.Priority Class | StarTeam Namespace


Topic.Status Class

Status of the Topic

For a list of all members of this type, see Topic.Status Members.

System.Object
EnumeratedValue
Topic.Status

public class Topic.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Status Members | StarTeam Namespace


Topic.Status Members

Topic.Status overview

Public Static Properties

ACCEPTED
ACTIVE
ALL
INACTIVE
REJECTED

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Topic.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Topic.Status.

See Also

Topic.Status Class | StarTeam Namespace


Topic.Status Properties

The properties of the Topic.Status class are listed below. For a complete list of Topic.Status class members, see the Topic.Status Members topic.

Public Static Properties

ACCEPTED
ACTIVE
ALL
INACTIVE
REJECTED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Topic.Status Class | StarTeam Namespace


ACCEPTED Property

Borland StarTeam SDK for .NET

Topic.Status.ACCEPTED Property

public static Topic.Status ACCEPTED {get;}

Property Value

Topic is Accepted

See Also

Topic.Status Class | StarTeam Namespace


ACTIVE Property

Borland StarTeam SDK for .NET

Topic.Status.ACTIVE Property

public static Topic.Status ACTIVE {get;}

Property Value

Topic is active

See Also

Topic.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Topic.Status.ALL Property

public static Status[] ALL {get;}

See Also

Topic.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Topic.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

Topic.Status Class | StarTeam Namespace


INACTIVE Property

Borland StarTeam SDK for .NET

Topic.Status.INACTIVE Property

public static Topic.Status INACTIVE {get;}

Property Value

Topic is Inactive

See Also

Topic.Status Class | StarTeam Namespace


REJECTED Property

Borland StarTeam SDK for .NET

Topic.Status.REJECTED Property

public static Topic.Status REJECTED {get;}

Property Value

Topic is Rejected

See Also

Topic.Status Class | StarTeam Namespace


Topic.Status Methods

The methods of the Topic.Status class are listed below. For a complete list of Topic.Status class members, see the Topic.Status Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Topic.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Topic.Status.

See Also

Topic.Status Class | StarTeam Namespace


Topic.Status.Equals Method

Delegate Equals() to com.starteam.Topic.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Status.Equals(obj).

See Also

Topic.Status Class | StarTeam Namespace


Topic.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

Topic.Status Class | StarTeam Namespace


Topic.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

Topic.Status Class | StarTeam Namespace


Topic.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Status.

public override int GetHashCode();

Return Value

com.starteam.Topic.Status.GetHashCode().

See Also

Topic.Status Class | StarTeam Namespace


Topic.Status.ToString Method

Delegate ToString() to com.starteam.Topic.Status.

public override string ToString();

Return Value

com.starteam.Topic.Status.ToString()

See Also

Topic.Status Class | StarTeam Namespace


Topic.TopicType Class

Type of the Topic

For a list of all members of this type, see Topic.TopicType Members.

System.Object
EnumeratedValue
Topic.TopicType

public class Topic.TopicType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.TopicType Members | StarTeam Namespace


Topic.TopicType Members

Topic.TopicType overview

Public Static Properties

ALL
RESPONSE
TOPIC

Public Static Methods

FromID | Gets the TopicType value corresponding to the given ID.
FromValue | Gets the TopicType value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this TopicType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Topic.TopicType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.TopicType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Topic.TopicType.

See Also

Topic.TopicType Class | StarTeam Namespace


Topic.TopicType Properties

The properties of the Topic.TopicType class are listed below. For a complete list of Topic.TopicType class members, see the Topic.TopicType Members topic.

Public Static Properties

ALL
RESPONSE
TOPIC

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this TopicType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Topic.TopicType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Topic.TopicType.ALL Property

public static TopicType[] ALL {get;}

See Also

Topic.TopicType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Topic.TopicType.ID Property

[read] The ID of this TopicType value.

public virtual Int32 ID {get;}

Property Value

The ID of this TopicType value.

See Also

Topic.TopicType Class | StarTeam Namespace


RESPONSE Property

Borland StarTeam SDK for .NET

Topic.TopicType.RESPONSE Property

public static Topic.TopicType RESPONSE {get;}

Property Value

Response type

See Also

Topic.TopicType Class | StarTeam Namespace


TOPIC Property

Borland StarTeam SDK for .NET

Topic.TopicType.TOPIC Property

public static Topic.TopicType TOPIC {get;}

Property Value

TopicType

See Also

Topic.TopicType Class | StarTeam Namespace


Topic.TopicType Methods

The methods of the Topic.TopicType class are listed below. For a complete list of Topic.TopicType class members, see the Topic.TopicType Members topic.

Public Static Methods

FromID | Gets the TopicType value corresponding to the given ID.
FromValue | Gets the TopicType value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Topic.TopicType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.TopicType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Topic.TopicType.

See Also

Topic.TopicType Class | StarTeam Namespace


Topic.TopicType.Equals Method

Delegate Equals() to com.starteam.Topic.TopicType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.TopicType.Equals(obj).

See Also

Topic.TopicType Class | StarTeam Namespace


Topic.TopicType.FromID Method

Gets the TopicType value corresponding to the given ID.

public static TopicType FromID(
Int32 id
);

Parameters

id
A topicType ID.

Return Value

The corresponding topicType value, or null.

See Also

Topic.TopicType Class | StarTeam Namespace


Topic.TopicType.FromValue Method

Gets the TopicType value corresponding to the given EnumeratedValue.

public static TopicType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a TopicTypeProperty.

Return Value

The corresponding TopicType value, or null.

See Also

Topic.TopicType Class | StarTeam Namespace


Topic.TopicType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.TopicType.

public override int GetHashCode();

Return Value

com.starteam.Topic.TopicType.GetHashCode().

See Also

Topic.TopicType Class | StarTeam Namespace


Topic.TopicType.ToString Method

Delegate ToString() to com.starteam.Topic.TopicType.

public override string ToString();

Return Value

com.starteam.Topic.TopicType.ToString()

See Also

Topic.TopicType Class | StarTeam Namespace


Topic.Type Class

Type meta-data (schema) for Topic object instances.

For a list of all members of this type, see Topic.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
TreeItem.Type
Topic.Type

new public class Topic.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type Members | StarTeam Namespace


Topic.Type Members

Topic.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Topic.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Topic.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type Properties

The properties of the Topic.Type class are listed below. For a complete list of Topic.Type class members, see the Topic.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

Topic.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

Topic.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

Topic.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

Topic.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

Topic.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Topic.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

Topic.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Topic.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

Topic.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

Topic.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

Topic.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Topic.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

Topic.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

Topic.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

Topic.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.NAME Property

new public static String NAME {get;}

See Also

Topic.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

Topic.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

Topic.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

Topic.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

Topic.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

Topic.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

Topic.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

Topic.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

Topic.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

Topic.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type Methods

The methods of the Topic.Type class are listed below. For a complete list of Topic.Type class members, see the Topic.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Topic.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Topic.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type.Equals Method

Delegate Equals() to com.starteam.Topic.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.Equals(obj).

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.GetHashCode().

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type.ToString Method

Delegate ToString() to com.starteam.Topic.Type.

public override string ToString();

Return Value

com.starteam.Topic.Type.ToString()

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

Topic.Type Class | StarTeam Namespace


Topic.Type.AmIRecipientProperty Class

The property type of the AmIRecipient property

For a list of all members of this type, see Topic.Type.AmIRecipientProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Topic.Type.AmIRecipientProperty

public class Topic.Type.AmIRecipientProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.AmIRecipientProperty Members | StarTeam Namespace


Topic.Type.AmIRecipientProperty Members

Topic.Type.AmIRecipientProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.AmIRecipientProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.AmIRecipientProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.AmIRecipientProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.AmIRecipientProperty Class | StarTeam Namespace


Topic.Type.AmIRecipientProperty Properties

The properties of the Topic.Type.AmIRecipientProperty class are listed below. For a complete list of Topic.Type.AmIRecipientProperty class members, see the Topic.Type.AmIRecipientProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Topic.Type.AmIRecipientProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.AmIRecipientProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.AmIRecipientProperty Class | StarTeam Namespace


Topic.Type.AmIRecipientProperty Methods

The methods of the Topic.Type.AmIRecipientProperty class are listed below. For a complete list of Topic.Type.AmIRecipientProperty class members, see the Topic.Type.AmIRecipientProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.AmIRecipientProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.AmIRecipientProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.AmIRecipientProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.AmIRecipientProperty Class | StarTeam Namespace


Topic.Type.AmIRecipientProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.AmIRecipientProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.AmIRecipientProperty.Equals(obj).

See Also

Topic.Type.AmIRecipientProperty Class | StarTeam Namespace


Topic.Type.AmIRecipientProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.AmIRecipientProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.AmIRecipientProperty.GetHashCode().

See Also

Topic.Type.AmIRecipientProperty Class | StarTeam Namespace


Topic.Type.AmIRecipientProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.AmIRecipientProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.AmIRecipientProperty.ToString()

See Also

Topic.Type.AmIRecipientProperty Class | StarTeam Namespace


Topic.Type.ChildrenCountProperty Class

The property type of the ChildrenCount property

For a list of all members of this type, see Topic.Type.ChildrenCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Topic.Type.ChildrenCountProperty

public class Topic.Type.ChildrenCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.ChildrenCountProperty Members | StarTeam Namespace


Topic.Type.ChildrenCountProperty Members

Topic.Type.ChildrenCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.ChildrenCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.ChildrenCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.ChildrenCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.ChildrenCountProperty Class | StarTeam Namespace


Topic.Type.ChildrenCountProperty Properties

The properties of the Topic.Type.ChildrenCountProperty class are listed below. For a complete list of Topic.Type.ChildrenCountProperty class members, see the Topic.Type.ChildrenCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Topic.Type.ChildrenCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.ChildrenCountProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.ChildrenCountProperty Class | StarTeam Namespace


Topic.Type.ChildrenCountProperty Methods

The methods of the Topic.Type.ChildrenCountProperty class are listed below. For a complete list of Topic.Type.ChildrenCountProperty class members, see the Topic.Type.ChildrenCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.ChildrenCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.ChildrenCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.ChildrenCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.ChildrenCountProperty Class | StarTeam Namespace


Topic.Type.ChildrenCountProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.ChildrenCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.ChildrenCountProperty.Equals(obj).

See Also

Topic.Type.ChildrenCountProperty Class | StarTeam Namespace


Topic.Type.ChildrenCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.ChildrenCountProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.ChildrenCountProperty.GetHashCode().

See Also

Topic.Type.ChildrenCountProperty Class | StarTeam Namespace


Topic.Type.ChildrenCountProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.ChildrenCountProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.ChildrenCountProperty.ToString()

See Also

Topic.Type.ChildrenCountProperty Class | StarTeam Namespace


Topic.Type.ContextRangeProperty Class

The property type of the ContextRange property

For a list of all members of this type, see Topic.Type.ContextRangeProperty Members.

System.Object
Property
VectorProperty
TextProperty
Topic.Type.ContextRangeProperty

public class Topic.Type.ContextRangeProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.ContextRangeProperty Members | StarTeam Namespace


Topic.Type.ContextRangeProperty Members

Topic.Type.ContextRangeProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.ContextRangeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.ContextRangeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.ContextRangeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.ContextRangeProperty Class | StarTeam Namespace


Topic.Type.ContextRangeProperty Properties

The properties of the Topic.Type.ContextRangeProperty class are listed below. For a complete list of Topic.Type.ContextRangeProperty class members, see the Topic.Type.ContextRangeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Topic.Type.ContextRangeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.ContextRangeProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.ContextRangeProperty Class | StarTeam Namespace


Topic.Type.ContextRangeProperty Methods

The methods of the Topic.Type.ContextRangeProperty class are listed below. For a complete list of Topic.Type.ContextRangeProperty class members, see the Topic.Type.ContextRangeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.ContextRangeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.ContextRangeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.ContextRangeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.ContextRangeProperty Class | StarTeam Namespace


Topic.Type.ContextRangeProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.ContextRangeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.ContextRangeProperty.Equals(obj).

See Also

Topic.Type.ContextRangeProperty Class | StarTeam Namespace


Topic.Type.ContextRangeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.ContextRangeProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.ContextRangeProperty.GetHashCode().

See Also

Topic.Type.ContextRangeProperty Class | StarTeam Namespace


Topic.Type.ContextRangeProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.ContextRangeProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.ContextRangeProperty.ToString()

See Also

Topic.Type.ContextRangeProperty Class | StarTeam Namespace


Topic.Type.ParentTopicIDProperty Class

The property type of the ParentTopicID property

For a list of all members of this type, see Topic.Type.ParentTopicIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Topic.Type.ParentTopicIDProperty

public class Topic.Type.ParentTopicIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.ParentTopicIDProperty Members | StarTeam Namespace


Topic.Type.ParentTopicIDProperty Members

Topic.Type.ParentTopicIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.ParentTopicIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.ParentTopicIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.ParentTopicIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.ParentTopicIDProperty Class | StarTeam Namespace


Topic.Type.ParentTopicIDProperty Properties

The properties of the Topic.Type.ParentTopicIDProperty class are listed below. For a complete list of Topic.Type.ParentTopicIDProperty class members, see the Topic.Type.ParentTopicIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Topic.Type.ParentTopicIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.ParentTopicIDProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.ParentTopicIDProperty Class | StarTeam Namespace


Topic.Type.ParentTopicIDProperty Methods

The methods of the Topic.Type.ParentTopicIDProperty class are listed below. For a complete list of Topic.Type.ParentTopicIDProperty class members, see the Topic.Type.ParentTopicIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.ParentTopicIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.ParentTopicIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.ParentTopicIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.ParentTopicIDProperty Class | StarTeam Namespace


Topic.Type.ParentTopicIDProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.ParentTopicIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.ParentTopicIDProperty.Equals(obj).

See Also

Topic.Type.ParentTopicIDProperty Class | StarTeam Namespace


Topic.Type.ParentTopicIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.ParentTopicIDProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.ParentTopicIDProperty.GetHashCode().

See Also

Topic.Type.ParentTopicIDProperty Class | StarTeam Namespace


Topic.Type.ParentTopicIDProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.ParentTopicIDProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.ParentTopicIDProperty.ToString()

See Also

Topic.Type.ParentTopicIDProperty Class | StarTeam Namespace


Topic.Type.PriorityProperty Class

The property type of the Priority property

For a list of all members of this type, see Topic.Type.PriorityProperty Members.

System.Object
Property
EnumeratedProperty
Topic.Type.PriorityProperty

public class Topic.Type.PriorityProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.PriorityProperty Members | StarTeam Namespace


Topic.Type.PriorityProperty Members

Topic.Type.PriorityProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.PriorityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.PriorityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.PriorityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.PriorityProperty Class | StarTeam Namespace


Topic.Type.PriorityProperty Properties

The properties of the Topic.Type.PriorityProperty class are listed below. For a complete list of Topic.Type.PriorityProperty class members, see the Topic.Type.PriorityProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Topic.Type.PriorityProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.PriorityProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.PriorityProperty Class | StarTeam Namespace


Topic.Type.PriorityProperty Methods

The methods of the Topic.Type.PriorityProperty class are listed below. For a complete list of Topic.Type.PriorityProperty class members, see the Topic.Type.PriorityProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.PriorityProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.PriorityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.PriorityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.PriorityProperty Class | StarTeam Namespace


Topic.Type.PriorityProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.PriorityProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.PriorityProperty.Equals(obj).

See Also

Topic.Type.PriorityProperty Class | StarTeam Namespace


Topic.Type.PriorityProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Topic.Priority value
);

See Also

Topic.Type.PriorityProperty Class | StarTeam Namespace


Topic.Type.PriorityProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.PriorityProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.PriorityProperty.GetHashCode().

See Also

Topic.Type.PriorityProperty Class | StarTeam Namespace


Topic.Type.PriorityProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.PriorityProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.PriorityProperty.ToString()

See Also

Topic.Type.PriorityProperty Class | StarTeam Namespace


Topic.Type.PropertyCollection Class

Property Collection for Topic

For a list of all members of this type, see Topic.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
Topic.Type.PropertyCollection

public class Topic.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.PropertyCollection Members | StarTeam Namespace


Topic.Type.PropertyCollection Members

Topic.Type.PropertyCollection overview

Public Instance Properties

AM_I_RECIPIENT |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
CHILDREN_COUNT |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
CONTEXT_RANGE |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DISLIKES |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_CHECKED (inherited from PropertyCollection) |
IS_LEAF |
IS_READ_ONLY |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
LIKES |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_TIME |
MODIFIED_USER_ID |
MY_LOCK (inherited from PropertyCollection) |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
PARENT_TOPIC_ID |
PRIORITY |
RECIPIENT_COUNT |
RECIPIENT_NAMES |
RECIPIENTS |
REVISION_FLAGS |
REVISION_NUMBER |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAXONOMY |
TITLE |
TOPIC_NUMBER |
TOPIC_TYPE |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Topic.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Topic.Type.PropertyCollection.

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


Topic.Type.PropertyCollection Properties

The properties of the Topic.Type.PropertyCollection class are listed below. For a complete list of Topic.Type.PropertyCollection class members, see the Topic.Type.PropertyCollection Members topic.

Public Instance Properties

AM_I_RECIPIENT |
ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
CHILDREN_COUNT |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
CONTEXT_RANGE |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DISLIKES |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
FOLDER_PATH |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BOOKMARKED |
IS_CHECKED (inherited from PropertyCollection) |
IS_LEAF |
IS_READ_ONLY |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
LIKES |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_TIME |
MODIFIED_USER_ID |
MY_LOCK (inherited from PropertyCollection) |
NEW_REVISION_COMMENT |
NON_EXCLUSIVE_LOCKERS |
PARENT_TOPIC_ID |
PRIORITY |
RECIPIENT_COUNT |
RECIPIENT_NAMES |
RECIPIENTS |
REVISION_FLAGS |
REVISION_NUMBER |
SHARE_STATE |
SHORT_COMMENT |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAXONOMY |
TITLE |
TOPIC_NUMBER |
TOPIC_TYPE |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


AM_I_RECIPIENT Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.AM_I_RECIPIENT Property

public Topic.Type.AmIRecipientProperty AM_I_RECIPIENT {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


CHILDREN_COUNT Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.CHILDREN_COUNT Property

public Topic.Type.ChildrenCountProperty CHILDREN_COUNT {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


CONTEXT_RANGE Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.CONTEXT_RANGE Property

public Topic.Type.ContextRangeProperty CONTEXT_RANGE {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


DISLIKES Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.DISLIKES Property

public Topic.Type.UserDislikesProperty DISLIKES {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


FOLDER_PATH Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.FOLDER_PATH Property

public TrackedObject.Type.FolderPathProperty FOLDER_PATH {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


IS_BOOKMARKED Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.IS_BOOKMARKED Property

public ViewMember.Type.IsBookmarkedProperty IS_BOOKMARKED {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


IS_LEAF Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.IS_LEAF Property

public TreeItem.Type.IsLeafProperty IS_LEAF {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


IS_UNREAD Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.IS_UNREAD Property

public ViewMember.Type.IsUnreadProperty IS_UNREAD {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


LIKES Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.LIKES Property

public Topic.Type.UserLikesProperty LIKES {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_USER_ID Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.MODIFIED_USER_ID Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_USER_ID {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


NEW_REVISION_COMMENT Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.NEW_REVISION_COMMENT Property

public Item.Type.NewRevisionCommentProperty NEW_REVISION_COMMENT {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


PARENT_TOPIC_ID Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.PARENT_TOPIC_ID Property

public Topic.Type.ParentTopicIDProperty PARENT_TOPIC_ID {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


PRIORITY Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.PRIORITY Property

public Topic.Type.PriorityProperty PRIORITY {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


RECIPIENT_COUNT Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.RECIPIENT_COUNT Property

public Topic.Type.RecipientCountProperty RECIPIENT_COUNT {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


RECIPIENT_NAMES Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.RECIPIENT_NAMES Property

public Topic.Type.RecipientNamesProperty RECIPIENT_NAMES {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


RECIPIENTS Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.RECIPIENTS Property

public Topic.Type.RecipientsProperty RECIPIENTS {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.STATUS Property

public Topic.Type.StatusProperty STATUS {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


TAXONOMY Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.TAXONOMY Property

public Topic.Type.TaxonomyProperty TAXONOMY {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


TITLE Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.TITLE Property

public Topic.Type.TitleProperty TITLE {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


TOPIC_NUMBER Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.TOPIC_NUMBER Property

public Topic.Type.TopicNumberProperty TOPIC_NUMBER {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


TOPIC_TYPE Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.TOPIC_TYPE Property

public Topic.Type.TopicTypeProperty TOPIC_TYPE {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Topic.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


Topic.Type.PropertyCollection Methods

The methods of the Topic.Type.PropertyCollection class are listed below. For a complete list of Topic.Type.PropertyCollection class members, see the Topic.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Topic.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Topic.Type.PropertyCollection.

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


Topic.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Topic.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.PropertyCollection.Equals(obj).

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


Topic.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.PropertyCollection.GetHashCode().

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


Topic.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Topic.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Topic.Type.PropertyCollection.ToString()

See Also

Topic.Type.PropertyCollection Class | StarTeam Namespace


Topic.Type.RecipientCountProperty Class

The property type of the RecipientCount property

For a list of all members of this type, see Topic.Type.RecipientCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Topic.Type.RecipientCountProperty

public class Topic.Type.RecipientCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.RecipientCountProperty Members | StarTeam Namespace


Topic.Type.RecipientCountProperty Members

Topic.Type.RecipientCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.RecipientCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.RecipientCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.RecipientCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.RecipientCountProperty Class | StarTeam Namespace


Topic.Type.RecipientCountProperty Properties

The properties of the Topic.Type.RecipientCountProperty class are listed below. For a complete list of Topic.Type.RecipientCountProperty class members, see the Topic.Type.RecipientCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Topic.Type.RecipientCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.RecipientCountProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.RecipientCountProperty Class | StarTeam Namespace


Topic.Type.RecipientCountProperty Methods

The methods of the Topic.Type.RecipientCountProperty class are listed below. For a complete list of Topic.Type.RecipientCountProperty class members, see the Topic.Type.RecipientCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.RecipientCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.RecipientCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.RecipientCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.RecipientCountProperty Class | StarTeam Namespace


Topic.Type.RecipientCountProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.RecipientCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.RecipientCountProperty.Equals(obj).

See Also

Topic.Type.RecipientCountProperty Class | StarTeam Namespace


Topic.Type.RecipientCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.RecipientCountProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.RecipientCountProperty.GetHashCode().

See Also

Topic.Type.RecipientCountProperty Class | StarTeam Namespace


Topic.Type.RecipientCountProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.RecipientCountProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.RecipientCountProperty.ToString()

See Also

Topic.Type.RecipientCountProperty Class | StarTeam Namespace


Topic.Type.RecipientNamesProperty Class

The property type of the RecipientNames property

For a list of all members of this type, see Topic.Type.RecipientNamesProperty Members.

System.Object
Property
VectorProperty
TextProperty
Topic.Type.RecipientNamesProperty

public class Topic.Type.RecipientNamesProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.RecipientNamesProperty Members | StarTeam Namespace


Topic.Type.RecipientNamesProperty Members

Topic.Type.RecipientNamesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.RecipientNamesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.RecipientNamesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.RecipientNamesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.RecipientNamesProperty Class | StarTeam Namespace


Topic.Type.RecipientNamesProperty Properties

The properties of the Topic.Type.RecipientNamesProperty class are listed below. For a complete list of Topic.Type.RecipientNamesProperty class members, see the Topic.Type.RecipientNamesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Topic.Type.RecipientNamesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.RecipientNamesProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.RecipientNamesProperty Class | StarTeam Namespace


Topic.Type.RecipientNamesProperty Methods

The methods of the Topic.Type.RecipientNamesProperty class are listed below. For a complete list of Topic.Type.RecipientNamesProperty class members, see the Topic.Type.RecipientNamesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.RecipientNamesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.RecipientNamesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.RecipientNamesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.RecipientNamesProperty Class | StarTeam Namespace


Topic.Type.RecipientNamesProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.RecipientNamesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.RecipientNamesProperty.Equals(obj).

See Also

Topic.Type.RecipientNamesProperty Class | StarTeam Namespace


Topic.Type.RecipientNamesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.RecipientNamesProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.RecipientNamesProperty.GetHashCode().

See Also

Topic.Type.RecipientNamesProperty Class | StarTeam Namespace


Topic.Type.RecipientNamesProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.RecipientNamesProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.RecipientNamesProperty.ToString()

See Also

Topic.Type.RecipientNamesProperty Class | StarTeam Namespace


Topic.Type.RecipientsProperty Class

The property type of the Recipients property

For a list of all members of this type, see Topic.Type.RecipientsProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Topic.Type.RecipientsProperty

public class Topic.Type.RecipientsProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.RecipientsProperty Members | StarTeam Namespace


Topic.Type.RecipientsProperty Members

Topic.Type.RecipientsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.RecipientsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.RecipientsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.RecipientsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.RecipientsProperty Class | StarTeam Namespace


Topic.Type.RecipientsProperty Properties

The properties of the Topic.Type.RecipientsProperty class are listed below. For a complete list of Topic.Type.RecipientsProperty class members, see the Topic.Type.RecipientsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Topic.Type.RecipientsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.RecipientsProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.RecipientsProperty Class | StarTeam Namespace


Topic.Type.RecipientsProperty Methods

The methods of the Topic.Type.RecipientsProperty class are listed below. For a complete list of Topic.Type.RecipientsProperty class members, see the Topic.Type.RecipientsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.RecipientsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.RecipientsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.RecipientsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.RecipientsProperty Class | StarTeam Namespace


Topic.Type.RecipientsProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.RecipientsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.RecipientsProperty.Equals(obj).

See Also

Topic.Type.RecipientsProperty Class | StarTeam Namespace


Topic.Type.RecipientsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.RecipientsProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.RecipientsProperty.GetHashCode().

See Also

Topic.Type.RecipientsProperty Class | StarTeam Namespace


Topic.Type.RecipientsProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.RecipientsProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.RecipientsProperty.ToString()

See Also

Topic.Type.RecipientsProperty Class | StarTeam Namespace


Topic.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see Topic.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
Topic.Type.StatusProperty

public class Topic.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.StatusProperty Members | StarTeam Namespace


Topic.Type.StatusProperty Members

Topic.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.StatusProperty Class | StarTeam Namespace


Topic.Type.StatusProperty Properties

The properties of the Topic.Type.StatusProperty class are listed below. For a complete list of Topic.Type.StatusProperty class members, see the Topic.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Topic.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.StatusProperty Class | StarTeam Namespace


Topic.Type.StatusProperty Methods

The methods of the Topic.Type.StatusProperty class are listed below. For a complete list of Topic.Type.StatusProperty class members, see the Topic.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.StatusProperty Class | StarTeam Namespace


Topic.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.StatusProperty.Equals(obj).

See Also

Topic.Type.StatusProperty Class | StarTeam Namespace


Topic.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Topic.Status value
);

See Also

Topic.Type.StatusProperty Class | StarTeam Namespace


Topic.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.StatusProperty.GetHashCode().

See Also

Topic.Type.StatusProperty Class | StarTeam Namespace


Topic.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.StatusProperty.ToString()

See Also

Topic.Type.StatusProperty Class | StarTeam Namespace


Topic.Type.TaxonomyProperty Class

The Property Type of the Taxonomy Property

For a list of all members of this type, see Topic.Type.TaxonomyProperty Members.

System.Object
Property
EnumeratedProperty
Topic.Type.TaxonomyProperty

public class Topic.Type.TaxonomyProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.TaxonomyProperty Members | StarTeam Namespace


Topic.Type.TaxonomyProperty Members

Topic.Type.TaxonomyProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.TaxonomyProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.TaxonomyProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.TaxonomyProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.TaxonomyProperty Class | StarTeam Namespace


Topic.Type.TaxonomyProperty Properties

The properties of the Topic.Type.TaxonomyProperty class are listed below. For a complete list of Topic.Type.TaxonomyProperty class members, see the Topic.Type.TaxonomyProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Topic.Type.TaxonomyProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.TaxonomyProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.TaxonomyProperty Class | StarTeam Namespace


Topic.Type.TaxonomyProperty Methods

The methods of the Topic.Type.TaxonomyProperty class are listed below. For a complete list of Topic.Type.TaxonomyProperty class members, see the Topic.Type.TaxonomyProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.TaxonomyProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.TaxonomyProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.TaxonomyProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.TaxonomyProperty Class | StarTeam Namespace


Topic.Type.TaxonomyProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.TaxonomyProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.TaxonomyProperty.Equals(obj).

See Also

Topic.Type.TaxonomyProperty Class | StarTeam Namespace


Topic.Type.TaxonomyProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.TaxonomyProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.TaxonomyProperty.GetHashCode().

See Also

Topic.Type.TaxonomyProperty Class | StarTeam Namespace


Topic.Type.TaxonomyProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.TaxonomyProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.TaxonomyProperty.ToString()

See Also

Topic.Type.TaxonomyProperty Class | StarTeam Namespace


Topic.Type.TitleProperty Class

The property type of the Title property

For a list of all members of this type, see Topic.Type.TitleProperty Members.

System.Object
Property
VectorProperty
TextProperty
Topic.Type.TitleProperty

public class Topic.Type.TitleProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.TitleProperty Members | StarTeam Namespace


Topic.Type.TitleProperty Members

Topic.Type.TitleProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.TitleProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.TitleProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.TitleProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.TitleProperty Class | StarTeam Namespace


Topic.Type.TitleProperty Properties

The properties of the Topic.Type.TitleProperty class are listed below. For a complete list of Topic.Type.TitleProperty class members, see the Topic.Type.TitleProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Topic.Type.TitleProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.TitleProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.TitleProperty Class | StarTeam Namespace


Topic.Type.TitleProperty Methods

The methods of the Topic.Type.TitleProperty class are listed below. For a complete list of Topic.Type.TitleProperty class members, see the Topic.Type.TitleProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.TitleProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.TitleProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.TitleProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.TitleProperty Class | StarTeam Namespace


Topic.Type.TitleProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.TitleProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.TitleProperty.Equals(obj).

See Also

Topic.Type.TitleProperty Class | StarTeam Namespace


Topic.Type.TitleProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.TitleProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.TitleProperty.GetHashCode().

See Also

Topic.Type.TitleProperty Class | StarTeam Namespace


Topic.Type.TitleProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.TitleProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.TitleProperty.ToString()

See Also

Topic.Type.TitleProperty Class | StarTeam Namespace


Topic.Type.TopicNumberProperty Class

The property type of the TopicNumber property

For a list of all members of this type, see Topic.Type.TopicNumberProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
Topic.Type.TopicNumberProperty

public class Topic.Type.TopicNumberProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.TopicNumberProperty Members | StarTeam Namespace


Topic.Type.TopicNumberProperty Members

Topic.Type.TopicNumberProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.TopicNumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.TopicNumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.TopicNumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.TopicNumberProperty Class | StarTeam Namespace


Topic.Type.TopicNumberProperty Properties

The properties of the Topic.Type.TopicNumberProperty class are listed below. For a complete list of Topic.Type.TopicNumberProperty class members, see the Topic.Type.TopicNumberProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Topic.Type.TopicNumberProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.TopicNumberProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.TopicNumberProperty Class | StarTeam Namespace


Topic.Type.TopicNumberProperty Methods

The methods of the Topic.Type.TopicNumberProperty class are listed below. For a complete list of Topic.Type.TopicNumberProperty class members, see the Topic.Type.TopicNumberProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.TopicNumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.TopicNumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.TopicNumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.TopicNumberProperty Class | StarTeam Namespace


Topic.Type.TopicNumberProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.TopicNumberProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.TopicNumberProperty.Equals(obj).

See Also

Topic.Type.TopicNumberProperty Class | StarTeam Namespace


Topic.Type.TopicNumberProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.TopicNumberProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.TopicNumberProperty.GetHashCode().

See Also

Topic.Type.TopicNumberProperty Class | StarTeam Namespace


Topic.Type.TopicNumberProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.TopicNumberProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.TopicNumberProperty.ToString()

See Also

Topic.Type.TopicNumberProperty Class | StarTeam Namespace


Topic.Type.TopicTypeProperty Class

The property type of the TopicType property

For a list of all members of this type, see Topic.Type.TopicTypeProperty Members.

System.Object
Property
EnumeratedProperty
Topic.Type.TopicTypeProperty

public class Topic.Type.TopicTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.TopicTypeProperty Members | StarTeam Namespace


Topic.Type.TopicTypeProperty Members

Topic.Type.TopicTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.TopicTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.TopicTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.TopicTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.TopicTypeProperty Class | StarTeam Namespace


Topic.Type.TopicTypeProperty Properties

The properties of the Topic.Type.TopicTypeProperty class are listed below. For a complete list of Topic.Type.TopicTypeProperty class members, see the Topic.Type.TopicTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Topic.Type.TopicTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.TopicTypeProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.TopicTypeProperty Class | StarTeam Namespace


Topic.Type.TopicTypeProperty Methods

The methods of the Topic.Type.TopicTypeProperty class are listed below. For a complete list of Topic.Type.TopicTypeProperty class members, see the Topic.Type.TopicTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Topic.Type.TopicTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.TopicTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Topic.Type.TopicTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.TopicTypeProperty Class | StarTeam Namespace


Topic.Type.TopicTypeProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.TopicTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.TopicTypeProperty.Equals(obj).

See Also

Topic.Type.TopicTypeProperty Class | StarTeam Namespace


Topic.Type.TopicTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Topic.TopicType value
);

See Also

Topic.Type.TopicTypeProperty Class | StarTeam Namespace


Topic.Type.TopicTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.TopicTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.TopicTypeProperty.GetHashCode().

See Also

Topic.Type.TopicTypeProperty Class | StarTeam Namespace


Topic.Type.TopicTypeProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.TopicTypeProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.TopicTypeProperty.ToString()

See Also

Topic.Type.TopicTypeProperty Class | StarTeam Namespace


Topic.Type.UserDislikesProperty Class

The property type of the UserDislikes property

For a list of all members of this type, see Topic.Type.UserDislikesProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Topic.Type.UserDislikesProperty

public class Topic.Type.UserDislikesProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.UserDislikesProperty Members | StarTeam Namespace


Topic.Type.UserDislikesProperty Members

Topic.Type.UserDislikesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.UserDislikesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.UserDislikesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.UserDislikesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.UserDislikesProperty Class | StarTeam Namespace


Topic.Type.UserDislikesProperty Properties

The properties of the Topic.Type.UserDislikesProperty class are listed below. For a complete list of Topic.Type.UserDislikesProperty class members, see the Topic.Type.UserDislikesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Topic.Type.UserDislikesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.UserDislikesProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.UserDislikesProperty Class | StarTeam Namespace


Topic.Type.UserDislikesProperty Methods

The methods of the Topic.Type.UserDislikesProperty class are listed below. For a complete list of Topic.Type.UserDislikesProperty class members, see the Topic.Type.UserDislikesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.UserDislikesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.UserDislikesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.UserDislikesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.UserDislikesProperty Class | StarTeam Namespace


Topic.Type.UserDislikesProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.UserDislikesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.UserDislikesProperty.Equals(obj).

See Also

Topic.Type.UserDislikesProperty Class | StarTeam Namespace


Topic.Type.UserDislikesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.UserDislikesProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.UserDislikesProperty.GetHashCode().

See Also

Topic.Type.UserDislikesProperty Class | StarTeam Namespace


Topic.Type.UserDislikesProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.UserDislikesProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.UserDislikesProperty.ToString()

See Also

Topic.Type.UserDislikesProperty Class | StarTeam Namespace


Topic.Type.UserLikesProperty Class

The property type of the UserLikes property

For a list of all members of this type, see Topic.Type.UserLikesProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
Topic.Type.UserLikesProperty

public class Topic.Type.UserLikesProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.Type.UserLikesProperty Members | StarTeam Namespace


Topic.Type.UserLikesProperty Members

Topic.Type.UserLikesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.UserLikesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.UserLikesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.UserLikesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.UserLikesProperty Class | StarTeam Namespace


Topic.Type.UserLikesProperty Properties

The properties of the Topic.Type.UserLikesProperty class are listed below. For a complete list of Topic.Type.UserLikesProperty class members, see the Topic.Type.UserLikesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

Topic.Type.UserLikesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Topic.Type.UserLikesProperty.NAME Property

public static String NAME {get;}

See Also

Topic.Type.UserLikesProperty Class | StarTeam Namespace


Topic.Type.UserLikesProperty Methods

The methods of the Topic.Type.UserLikesProperty class are listed below. For a complete list of Topic.Type.UserLikesProperty class members, see the Topic.Type.UserLikesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Topic.Type.UserLikesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.Type.UserLikesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Topic.Type.UserLikesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Topic.Type.UserLikesProperty Class | StarTeam Namespace


Topic.Type.UserLikesProperty.Equals Method

Delegate Equals() to com.starteam.Topic.Type.UserLikesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.Type.UserLikesProperty.Equals(obj).

See Also

Topic.Type.UserLikesProperty Class | StarTeam Namespace


Topic.Type.UserLikesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.Type.UserLikesProperty.

public override int GetHashCode();

Return Value

com.starteam.Topic.Type.UserLikesProperty.GetHashCode().

See Also

Topic.Type.UserLikesProperty Class | StarTeam Namespace


Topic.Type.UserLikesProperty.ToString Method

Delegate ToString() to com.starteam.Topic.Type.UserLikesProperty.

public override string ToString();

Return Value

com.starteam.Topic.Type.UserLikesProperty.ToString()

See Also

Topic.Type.UserLikesProperty Class | StarTeam Namespace


Topic.WebCacheTopic Class

Item accessor for cached SDK Topic items contained objects are obtained from the artifact cache

For a list of all members of this type, see Topic.WebCacheTopic Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
TreeItem.WebCacheTreeItem
Topic.WebCacheTopic

public class Topic.WebCacheTopic : WebCacheTreeItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Topic.WebCacheTopic Members | StarTeam Namespace


Topic.WebCacheTopic Members

Topic.WebCacheTopic overview

Public Static Methods

Create Overloaded.

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
ContextRange | [read/write] The context range of the topic.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Dislikes | [read] The users expressing dislikes for this topic.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Likes | [read] The users expressing likes for this topic.
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
Number | [read] The topic number of this topic.
ObjectID | [read] The unique identifier for the underlying object.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The Priority of this topic.
Recipients | [read] The users assigned as recipients of this topic.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The Status of this topic.
Taxonomies | [read/write] the taxonomy, if any attached to this topic
Text | [read/write] The text or body of the topic.
Title | [read/write] The title or subject of the topic.
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddDislike |
AddLike |
AddNotifiedUser |
AddRecipient |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Topic.WebCacheTopic.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.WebCacheTopic.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveDislike |
RemoveFrom |
RemoveLike |
RemoveNotifiedUser |
RemoveRecipient |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Topic.WebCacheTopic.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic Properties

The properties of the Topic.WebCacheTopic class are listed below. For a complete list of Topic.WebCacheTopic class members, see the Topic.WebCacheTopic Members topic.

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
ContextRange | [read/write] The context range of the topic.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Dislikes | [read] The users expressing dislikes for this topic.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Likes | [read] The users expressing likes for this topic.
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
Number | [read] The topic number of this topic.
ObjectID | [read] The unique identifier for the underlying object.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
PriorityValue | [read/write] The Priority of this topic.
Recipients | [read] The users assigned as recipients of this topic.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
StatusValue | [read/write] The Status of this topic.
Taxonomies | [read/write] the taxonomy, if any attached to this topic
Text | [read/write] The text or body of the topic.
Title | [read/write] The title or subject of the topic.
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


After Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.After Property

[write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem After {set;}

Property Value

place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Before Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Before Property

[write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

new public virtual TreeItem.WebCacheTreeItem Before {set;}

Property Value

place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ContextRange Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ContextRange Property

[read/write] The context range of the topic.

public virtual String ContextRange {get; set;}

Property Value

The context range of the topic.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Dislikes Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Dislikes Property

[read] The users expressing dislikes for this topic.

public virtual WebCacheUser[] Dislikes {get;}

Property Value

The users expressing dislikes for this topic.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IsLeaf Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IsLeaf Property

[read] true if this tree item is a leaf

new public virtual Boolean IsLeaf {get;}

Property Value

true if this tree item is a leaf

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Likes Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Likes Property

[read] The users expressing likes for this topic.

public virtual WebCacheUser[] Likes {get;}

Property Value

The users expressing likes for this topic.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Name Property

new public virtual String Name {get;}

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Number Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Number Property

[read] The topic number of this topic.

public virtual Int32 Number {get;}

Property Value

The topic number of this topic.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Parent Property

[read] the TreeItem which is the Parent of this instance, or NULL if this is a root

new public virtual TreeItem.WebCacheTreeItem Parent {get;}

Property Value

the TreeItem which is the Parent of this instance, or NULL if this is a root

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


PriorityValue Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.PriorityValue Property

[read/write] The Priority of this topic.

public virtual Topic.Priority PriorityValue {get; set;}

Property Value

The Priority of this topic.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Recipients Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Recipients Property

[read] The users assigned as recipients of this topic.

public virtual WebCacheUser[] Recipients {get;}

Property Value

The users assigned as recipients of this topic.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.StatusValue Property

[read/write] The Status of this topic.

public virtual Topic.Status StatusValue {get; set;}

Property Value

The Status of this topic.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Taxonomies Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Taxonomies Property

[read/write] the taxonomy, if any attached to this topic

public virtual EnumeratedValue[] Taxonomies {get; set;}

Property Value

the taxonomy, if any attached to this topic

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Text Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Text Property

[read/write] The text or body of the topic.

public virtual String Text {get; set;}

Property Value

The text or body of the topic.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Title Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Title Property

[read/write] The title or subject of the topic.

public virtual String Title {get; set;}

Property Value

The title or subject of the topic.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic Methods

The methods of the Topic.WebCacheTopic class are listed below. For a complete list of Topic.WebCacheTopic class members, see the Topic.WebCacheTopic Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddDislike |
AddLike |
AddNotifiedUser |
AddRecipient |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.Topic.WebCacheTopic.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Topic.WebCacheTopic.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveDislike |
RemoveFrom |
RemoveLike |
RemoveNotifiedUser |
RemoveRecipient |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Topic.WebCacheTopic.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.AddDislike Method

public virtual void AddDislike(
User.WebCacheUser user
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.AddLike Method

public virtual void AddLike(
User.WebCacheUser user
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.AddRecipient Method

public virtual void AddRecipient(
User.WebCacheUser user
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Create Method

Overload List

public static WebCacheTopic Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,TreeItem.Type.WebCacheTreeItemType);

public static WebCacheTopic Create(ArtifactCacheManager.Context,Topic.WebCacheTopic);

new public static WebCacheTreeItem Create(ArtifactCacheManager.Context,TreeItem.WebCacheTreeItem);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheTopic Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.Create Overload List


Topic.WebCacheTopic.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.Create Overload List


Topic.WebCacheTopic.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, TreeItem#Type#WebCacheTreeItemType)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
TreeItem.Type.WebCacheTreeItemType typ
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.Create Overload List


Topic.WebCacheTopic.Create Method (ArtifactCacheManager#Context, Topic#WebCacheTopic)

public static WebCacheTopic Create(
ArtifactCacheManager.Context cntxt,
Topic.WebCacheTopic parent
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.Create Overload List


Topic.WebCacheTopic.Create Method (ArtifactCacheManager#Context, TreeItem#WebCacheTreeItem)

new public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
TreeItem.WebCacheTreeItem parent
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.Create Overload List


Topic.WebCacheTopic.Equals Method

Delegate Equals() to com.starteam.Topic.WebCacheTopic.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Topic.WebCacheTopic.Equals(obj).

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.GetChildren Method

new public virtual WebCacheTreeItem[] GetChildren(
Filter.WebCacheFilter fltr
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.GetHashCode Method

Delegate GetHashCode() to com.starteam.Topic.WebCacheTopic.

public override int GetHashCode();

Return Value

com.starteam.Topic.WebCacheTopic.GetHashCode().

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.GetValue Overload List


Topic.WebCacheTopic.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.GetValue Overload List


Topic.WebCacheTopic.HasChildren Method

Returns true if the TreeItem has at least one child.

new public virtual bool HasChildren();

Return Value

True if at least one child exists, false if no children

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | isDisembodied


Topic.WebCacheTopic.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | WebCacheViewMemberCollection


Topic.WebCacheTopic.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.Lock Overload List | WebCacheViewMemberCollection


Topic.WebCacheTopic.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.Lock Overload List


Topic.WebCacheTopic.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | NAME


Topic.WebCacheTopic.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(TreeItem.WebCacheTreeItem);

new public virtual void MoveTo(View.WebCacheView);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.MoveTo Overload List


Topic.WebCacheTopic.MoveTo Method (TreeItem#WebCacheTreeItem)

new public virtual void MoveTo(
TreeItem.WebCacheTreeItem parent
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.MoveTo Overload List


Topic.WebCacheTopic.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.MoveTo Overload List


Topic.WebCacheTopic.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | isFloating | isPinned | unpin


Topic.WebCacheTopic.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | WebCacheViewMemberCollection


Topic.WebCacheTopic.RemoveDislike Method

public virtual void RemoveDislike(
User.WebCacheUser user
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.RemoveLike Method

public virtual void RemoveLike(
User.WebCacheUser user
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.RemoveRecipient Method

public virtual void RemoveRecipient(
User.WebCacheUser user
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.SetBetween Method

new public virtual void SetBetween(
TreeItem.WebCacheTreeItem prev,
TreeItem.WebCacheTreeItem next
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.SetFirst Method

place this tree item at the head of the set of all children of its parent treeitem or folder

new public virtual void SetFirst();

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.SetLast Method

place this tree item at the end of the set of all children of its parent treeitem or folder

new public virtual void SetLast();

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Topic.WebCacheTopic.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.SetValue Overload List


Topic.WebCacheTopic.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | Topic.WebCacheTopic.SetValue Overload List


Topic.WebCacheTopic.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.ToString Method

Delegate ToString() to com.starteam.Topic.WebCacheTopic.

public override string ToString();

Return Value

com.starteam.Topic.WebCacheTopic.ToString()

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Topic.WebCacheTopic.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | WebCacheViewMemberCollection


Topic.WebCacheTopic.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | isFloating | isPinned | pinTo


Topic.WebCacheTopic.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Topic.WebCacheTopic Class | StarTeam Namespace | WebCacheViewMemberCollection


Topic.WebCacheTopic.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Topic.WebCacheTopic Class | StarTeam Namespace


Trace Class

A typed relationship between two artifacts.

For a list of all members of this type, see Trace Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Trace
LinkToTraceAdapter

public class Trace : ViewMember

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace Members | StarTeam Namespace


Trace Members

Trace overview

Public Instance Constructors

Trace Constructor Creates a new trace in the specified view.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] The description of this trace.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsSuspect | [read/write] true if the trace is suspect
IsUnread (inherited from ViewMember) | [read] boolean
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order | [read/write] the order in which the trace should be executed.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] Collection of properties
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Source | [read/write] The source endpoint of this trace.
StatusValue | [read/write] Status
Target | [read/write] The target endpoint of this trace.
TraceTypeValue | [read/write] Trace.TraceType
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSourceVersions
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from ViewMember) | Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended | Determines whether share or reverse-share is the more appropriate operation when sharing this trace to the given target view.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
PinSource | Set the source end-point of this trace to pinned. i.e. the source will match the specified revision of the ViewMember
PinTarget | Set the target end-point of this trace to pinned. i.e. the target will match the specified revision of the ViewMember
PutLock (inherited from ViewMember)
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ReverseShareTo | Transfers ownership of the root share of a trace to a new view, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding trace in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired trace revision in the target is not the tip revision of the trace being shared. The reverse share operation compensates for this by moving the trace to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original trace in the source view with a new share of the same underlying object. Since this is a new trace with a new VMID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new trace. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetSourceVersions
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo | Shares this trace to a new view. The shared trace will still exist in its original view as well as in the new one.
SmartShareTo | Shares or reverse-shares this trace to the given target view, as appropriate. The new share uses a time-based configuration, and is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
UnpinSource | Set the source end-point of this trace to float. i.e. the source will always match the tip ViewMember of the configuration
UnpinTarget | Set the target end-point of this trace to float. i.e. the target will always match the tip ViewMember of the configuration
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Trace Class | StarTeam Namespace


Trace Constructor

Creates a new trace in the specified view.

public Trace(
View view
);

Parameters

view
The view to which this new trace will be added.

See Also

Trace Class | StarTeam Namespace


Trace Properties

The properties of the Trace class are listed below. For a complete list of Trace class members, see the Trace Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] The description of this trace.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsSuspect | [read/write] true if the trace is suspect
IsUnread (inherited from ViewMember) | [read] boolean
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Order | [read/write] the order in which the trace should be executed.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] Collection of properties
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Source | [read/write] The source endpoint of this trace.
StatusValue | [read/write] Status
Target | [read/write] The target endpoint of this trace.
TraceTypeValue | [read/write] Trace.TraceType
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

Trace Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Trace.Description Property

[read/write] The description of this trace.

public virtual String Description {get; set;}

Property Value

The description of this trace.

See Also

Trace Class | StarTeam Namespace


IsSuspect Property

Borland StarTeam SDK for .NET

Trace.IsSuspect Property

[read/write] true if the trace is suspect

public virtual Boolean IsSuspect {get; set;}

Property Value

true if the trace is suspect

See Also

Trace Class | StarTeam Namespace


Order Property

Borland StarTeam SDK for .NET

Trace.Order Property

[read/write] the order in which the trace should be executed.

public virtual Double Order {get; set;}

Property Value

the order in which the trace should be executed.

See Also

Trace Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Trace.Properties Property

[read] Collection of properties

public virtual Trace.Type.PropertyCollection Properties {get;}

Property Value

Collection of properties

See Also

Trace Class | StarTeam Namespace


Source Property

Borland StarTeam SDK for .NET

Trace.Source Property

[read/write] The source endpoint of this trace.

public virtual LinkValue Source {get; set;}

Property Value

The source endpoint of this trace.

See Also

Trace Class | StarTeam Namespace


StatusValue Property

Borland StarTeam SDK for .NET

Trace.StatusValue Property

[read/write] Status

public virtual Trace.Status StatusValue {get; set;}

Property Value

Status

See Also

Trace Class | StarTeam Namespace


Target Property

Borland StarTeam SDK for .NET

Trace.Target Property

[read/write] The target endpoint of this trace.

public virtual LinkValue Target {get; set;}

Property Value

The target endpoint of this trace.

See Also

Trace Class | StarTeam Namespace


TraceTypeValue Property

Borland StarTeam SDK for .NET

Trace.TraceTypeValue Property

[read/write] Trace.TraceType

public virtual Trace.TraceType TraceTypeValue {get; set;}

Property Value

Trace.TraceType

See Also

Trace Class | StarTeam Namespace


Trace Methods

The methods of the Trace class are listed below. For a complete list of Trace class members, see the Trace Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSourceVersions
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from ViewMember) | Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended | Determines whether share or reverse-share is the more appropriate operation when sharing this trace to the given target view.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
PinSource | Set the source end-point of this trace to pinned. i.e. the source will match the specified revision of the ViewMember
PinTarget | Set the target end-point of this trace to pinned. i.e. the target will match the specified revision of the ViewMember
PutLock (inherited from ViewMember)
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
ReverseShareTo | Transfers ownership of the root share of a trace to a new view, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding trace in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired trace revision in the target is not the tip revision of the trace being shared. The reverse share operation compensates for this by moving the trace to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original trace in the source view with a new share of the same underlying object. Since this is a new trace with a new VMID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new trace. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetSourceVersions
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo | Shares this trace to a new view. The shared trace will still exist in its original view as well as in the new one.
SmartShareTo | Shares or reverse-shares this trace to the given target view, as appropriate. The new share uses a time-based configuration, and is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
UnpinSource | Set the source end-point of this trace to float. i.e. the source will always match the tip ViewMember of the configuration
UnpinTarget | Set the target end-point of this trace to float. i.e. the target will always match the tip ViewMember of the configuration
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

Trace Class | StarTeam Namespace


Trace.GetSourceVersions Method

public virtual string GetSourceVersions(
Trace.Status statusValue
);

See Also

Trace Class | StarTeam Namespace


Trace.IsReverseShareRecommended Method

Determines whether share or reverse-share is the more appropriate operation when sharing this trace to the given target view.

public virtual bool IsReverseShareRecommended(
View target
);

Parameters

target
The target view.

Return Value

true if a reverse-share is appropriate; false otherwise.

See Also

Trace Class | StarTeam Namespace | smartShareTo


Trace.PinSource Method

Set the source end-point of this trace to pinned. i.e. the source will match the specified revision of the ViewMember

public virtual void PinSource();

See Also

Trace Class | StarTeam Namespace


Trace.PinTarget Method

Set the target end-point of this trace to pinned. i.e. the target will match the specified revision of the ViewMember

public virtual void PinTarget();

See Also

Trace Class | StarTeam Namespace


Trace.ReverseShareTo Method

Transfers ownership of the root share of a trace to a new view, sharing a copy back to the original location.

In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding trace in the tip view configuration, and reverse sharing that one.

When reverse sharing from a rolled back view, it is possible that the desired trace revision in the target is not the tip revision of the trace being shared. The reverse share operation compensates for this by moving the trace to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision.

Sharing replaces the original trace in the source view with a new share of the same underlying object. Since this is a new trace with a new VMID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new trace. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.

public virtual Trace ReverseShareTo(
View target
);

Parameters

target
The new view.

Return Value

The new trace in the target view.

See Also

Trace Class | StarTeam Namespace | shareTo


Trace.SetSourceVersions Method

public virtual void SetSourceVersions(
Trace.Status statusValue,
String version
);

See Also

Trace Class | StarTeam Namespace


Trace.ShareTo Method

Shares this trace to a new view. The shared trace will still exist in its original view as well as in the new one.

public virtual Trace ShareTo(
View target
);

Parameters

target
The new view.

Return Value

The newly shared trace.

See Also

Trace Class | StarTeam Namespace | reverseShareTo


Trace.SmartShareTo Method

Shares or reverse-shares this trace to the given target view, as appropriate. The new share uses a time-based configuration, and is set to branch on change.

public virtual Trace SmartShareTo(
View target
);

Parameters

target
The target view.

Return Value

The shared trace.

See Also

Trace Class | StarTeam Namespace | isReverseShareRecommended


Trace.UnpinSource Method

Set the source end-point of this trace to float. i.e. the source will always match the tip ViewMember of the configuration

public virtual void UnpinSource();

See Also

Trace Class | StarTeam Namespace


Trace.UnpinTarget Method

Set the target end-point of this trace to float. i.e. the target will always match the tip ViewMember of the configuration

public virtual void UnpinTarget();

See Also

Trace Class | StarTeam Namespace


Trace.Status Class

The Status of a Trace

For a list of all members of this type, see Trace.Status Members.

System.Object
EnumeratedValue
Trace.Status

public class Trace.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.Status Members | StarTeam Namespace


Trace.Status Members

Trace.Status overview

Public Static Properties

ALL
DEFERRED
SUSPECT
UP_TO_DATE

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Trace.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Trace.Status.

See Also

Trace.Status Class | StarTeam Namespace


Trace.Status Properties

The properties of the Trace.Status class are listed below. For a complete list of Trace.Status class members, see the Trace.Status Members topic.

Public Static Properties

ALL
DEFERRED
SUSPECT
UP_TO_DATE

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Trace.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Trace.Status.ALL Property

public static Status[] ALL {get;}

See Also

Trace.Status Class | StarTeam Namespace


DEFERRED Property

Borland StarTeam SDK for .NET

Trace.Status.DEFERRED Property

public static Trace.Status DEFERRED {get;}

Property Value

This Trace status is deferred

See Also

Trace.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Trace.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

Trace.Status Class | StarTeam Namespace


SUSPECT Property

Borland StarTeam SDK for .NET

Trace.Status.SUSPECT Property

public static Trace.Status SUSPECT {get;}

Property Value

This Trace status is suspect

See Also

Trace.Status Class | StarTeam Namespace


UP_TO_DATE Property

Borland StarTeam SDK for .NET

Trace.Status.UP_TO_DATE Property

public static Trace.Status UP_TO_DATE {get;}

Property Value

This Trace status is undefined

See Also

Trace.Status Class | StarTeam Namespace


Trace.Status Methods

The methods of the Trace.Status class are listed below. For a complete list of Trace.Status class members, see the Trace.Status Members topic.

Public Static Methods

FromID | Gets the Status value corresponding to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Trace.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Trace.Status.

See Also

Trace.Status Class | StarTeam Namespace


Trace.Status.Equals Method

Delegate Equals() to com.starteam.Trace.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.Status.Equals(obj).

See Also

Trace.Status Class | StarTeam Namespace


Trace.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
The ID of a Status value.

Return Value

The corresponding Status value, or null.

See Also

Trace.Status Class | StarTeam Namespace


Trace.Status.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static Status FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

Trace.Status Class | StarTeam Namespace


Trace.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.Status.

public override int GetHashCode();

Return Value

com.starteam.Trace.Status.GetHashCode().

See Also

Trace.Status Class | StarTeam Namespace


Trace.Status.ToString Method

Delegate ToString() to com.starteam.Trace.Status.

public override string ToString();

Return Value

com.starteam.Trace.Status.ToString()

See Also

Trace.Status Class | StarTeam Namespace


Trace.TraceType Class

Trace Type

For a list of all members of this type, see Trace.TraceType Members.

System.Object
EnumeratedValue
Trace.TraceType

public class Trace.TraceType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.TraceType Members | StarTeam Namespace


Trace.TraceType Members

Trace.TraceType overview

Public Static Properties

ALL
BACKLOG_STREAM
BREAKDOWN
CARRY_OVER
CODE_REVIEW_ITEM
CONTAINMENT
COPY
DEFECT_STREAM
DEFINE
EXECUTION
FASTFORWARD_MERGE
FLOW
MANUAL
NON_FASTFORWARD_MERGE
PROCESS_ITEM
REQUIREMENT_DEPENDENCY
REQUIREMENT_STREAM
REQUIREMENT_SYNC
RESOLUTION_POINT
TASK_DEPENDENCY
UNDEFINED
VALIDATION_TEST
WHITEBOARD
WORK_ITEM

Public Static Methods

FromID | Gets the TraceType value corresponding to the given ID.
FromValue | Gets the TraceType value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this TraceType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Trace.TraceType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.TraceType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Trace.TraceType.

See Also

Trace.TraceType Class | StarTeam Namespace


Trace.TraceType Properties

The properties of the Trace.TraceType class are listed below. For a complete list of Trace.TraceType class members, see the Trace.TraceType Members topic.

Public Static Properties

ALL
BACKLOG_STREAM
BREAKDOWN
CARRY_OVER
CODE_REVIEW_ITEM
CONTAINMENT
COPY
DEFECT_STREAM
DEFINE
EXECUTION
FASTFORWARD_MERGE
FLOW
MANUAL
NON_FASTFORWARD_MERGE
PROCESS_ITEM
REQUIREMENT_DEPENDENCY
REQUIREMENT_STREAM
REQUIREMENT_SYNC
RESOLUTION_POINT
TASK_DEPENDENCY
UNDEFINED
VALIDATION_TEST
WHITEBOARD
WORK_ITEM

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this TraceType value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

Trace.TraceType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

Trace.TraceType.ALL Property

public static TraceType[] ALL {get;}

See Also

Trace.TraceType Class | StarTeam Namespace


BACKLOG_STREAM Property

Borland StarTeam SDK for .NET

Trace.TraceType.BACKLOG_STREAM Property

public static Trace.TraceType BACKLOG_STREAM {get;}

Property Value

This is a backlog info stream

See Also

Trace.TraceType Class | StarTeam Namespace


BREAKDOWN Property

Borland StarTeam SDK for .NET

Trace.TraceType.BREAKDOWN Property

public static Trace.TraceType BREAKDOWN {get;}

Property Value

This is a breakdown trace

See Also

Trace.TraceType Class | StarTeam Namespace


CARRY_OVER Property

Borland StarTeam SDK for .NET

Trace.TraceType.CARRY_OVER Property

public static Trace.TraceType CARRY_OVER {get;}

Property Value

This is a carry over trace

See Also

Trace.TraceType Class | StarTeam Namespace


CODE_REVIEW_ITEM Property

Borland StarTeam SDK for .NET

Trace.TraceType.CODE_REVIEW_ITEM Property

public static Trace.TraceType CODE_REVIEW_ITEM {get;}

Property Value

This is a code review trace

See Also

Trace.TraceType Class | StarTeam Namespace


CONTAINMENT Property

Borland StarTeam SDK for .NET

Trace.TraceType.CONTAINMENT Property

public static Trace.TraceType CONTAINMENT {get;}

Property Value

This is a containment trace

See Also

Trace.TraceType Class | StarTeam Namespace


COPY Property

Borland StarTeam SDK for .NET

Trace.TraceType.COPY Property

public static Trace.TraceType COPY {get;}

Property Value

This is a copy trace

See Also

Trace.TraceType Class | StarTeam Namespace


DEFECT_STREAM Property

Borland StarTeam SDK for .NET

Trace.TraceType.DEFECT_STREAM Property

public static Trace.TraceType DEFECT_STREAM {get;}

Property Value

This is a defect info stream

See Also

Trace.TraceType Class | StarTeam Namespace


DEFINE Property

Borland StarTeam SDK for .NET

Trace.TraceType.DEFINE Property

public static Trace.TraceType DEFINE {get;}

Property Value

This is a define trace

See Also

Trace.TraceType Class | StarTeam Namespace


EXECUTION Property

Borland StarTeam SDK for .NET

Trace.TraceType.EXECUTION Property

public static Trace.TraceType EXECUTION {get;}

Property Value

This is an execution trace

See Also

Trace.TraceType Class | StarTeam Namespace


FASTFORWARD_MERGE Property

Borland StarTeam SDK for .NET

Trace.TraceType.FASTFORWARD_MERGE Property

public static Trace.TraceType FASTFORWARD_MERGE {get;}

Property Value

This is a fast forward merge type (used by GIT connector)

See Also

Trace.TraceType Class | StarTeam Namespace


FLOW Property

Borland StarTeam SDK for .NET

Trace.TraceType.FLOW Property

public static Trace.TraceType FLOW {get;}

Property Value

This is a flow trace

See Also

Trace.TraceType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Trace.TraceType.ID Property

[read] The ID of this TraceType value.

public virtual Int32 ID {get;}

Property Value

The ID of this TraceType value.

See Also

Trace.TraceType Class | StarTeam Namespace


MANUAL Property

Borland StarTeam SDK for .NET

Trace.TraceType.MANUAL Property

public static Trace.TraceType MANUAL {get;}

Property Value

This is a manual trace

See Also

Trace.TraceType Class | StarTeam Namespace


NON_FASTFORWARD_MERGE Property

Borland StarTeam SDK for .NET

Trace.TraceType.NON_FASTFORWARD_MERGE Property

public static Trace.TraceType NON_FASTFORWARD_MERGE {get;}

Property Value

This is a non fast forward merge type (used by GIT connector)

See Also

Trace.TraceType Class | StarTeam Namespace


PROCESS_ITEM Property

Borland StarTeam SDK for .NET

Trace.TraceType.PROCESS_ITEM Property

public static Trace.TraceType PROCESS_ITEM {get;}

Property Value

This is a process item trace

See Also

Trace.TraceType Class | StarTeam Namespace


REQUIREMENT_DEPENDENCY Property

Borland StarTeam SDK for .NET

Trace.TraceType.REQUIREMENT_DEPENDENCY Property

public static Trace.TraceType REQUIREMENT_DEPENDENCY {get;}

Property Value

This Trace is a Requirement Dependency

See Also

Trace.TraceType Class | StarTeam Namespace


REQUIREMENT_STREAM Property

Borland StarTeam SDK for .NET

Trace.TraceType.REQUIREMENT_STREAM Property

public static Trace.TraceType REQUIREMENT_STREAM {get;}

Property Value

This is a requirement info stream

See Also

Trace.TraceType Class | StarTeam Namespace


REQUIREMENT_SYNC Property

Borland StarTeam SDK for .NET

Trace.TraceType.REQUIREMENT_SYNC Property

public static Trace.TraceType REQUIREMENT_SYNC {get;}

Property Value

This is a requirement sync trace

See Also

Trace.TraceType Class | StarTeam Namespace


RESOLUTION_POINT Property

Borland StarTeam SDK for .NET

Trace.TraceType.RESOLUTION_POINT Property

public static Trace.TraceType RESOLUTION_POINT {get;}

Property Value

This Trace is a Resolution Point

See Also

Trace.TraceType Class | StarTeam Namespace


TASK_DEPENDENCY Property

Borland StarTeam SDK for .NET

Trace.TraceType.TASK_DEPENDENCY Property

public static Trace.TraceType TASK_DEPENDENCY {get;}

Property Value

This Trace is a Task Dependency

See Also

Trace.TraceType Class | StarTeam Namespace


UNDEFINED Property

Borland StarTeam SDK for .NET

Trace.TraceType.UNDEFINED Property

public static Trace.TraceType UNDEFINED {get;}

Property Value

This Trace type is undefined

See Also

Trace.TraceType Class | StarTeam Namespace


VALIDATION_TEST Property

Borland StarTeam SDK for .NET

Trace.TraceType.VALIDATION_TEST Property

public static Trace.TraceType VALIDATION_TEST {get;}

Property Value

This Trace is a Validation Test

See Also

Trace.TraceType Class | StarTeam Namespace


WHITEBOARD Property

Borland StarTeam SDK for .NET

Trace.TraceType.WHITEBOARD Property

public static Trace.TraceType WHITEBOARD {get;}

Property Value

This is a whiteboard trace

See Also

Trace.TraceType Class | StarTeam Namespace


WORK_ITEM Property

Borland StarTeam SDK for .NET

Trace.TraceType.WORK_ITEM Property

public static Trace.TraceType WORK_ITEM {get;}

Property Value

This Trace is a Work Item

See Also

Trace.TraceType Class | StarTeam Namespace


Trace.TraceType Methods

The methods of the Trace.TraceType class are listed below. For a complete list of Trace.TraceType class members, see the Trace.TraceType Members topic.

Public Static Methods

FromID | Gets the TraceType value corresponding to the given ID.
FromValue | Gets the TraceType value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.Trace.TraceType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.TraceType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.Trace.TraceType.

See Also

Trace.TraceType Class | StarTeam Namespace


Trace.TraceType.Equals Method

Delegate Equals() to com.starteam.Trace.TraceType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.TraceType.Equals(obj).

See Also

Trace.TraceType Class | StarTeam Namespace


Trace.TraceType.FromID Method

Gets the TraceType value corresponding to the given ID.

public static TraceType FromID(
Int32 id
);

Parameters

id
The ID of a TraceType value.

Return Value

The corresponding TraceType value, or null.

See Also

Trace.TraceType Class | StarTeam Namespace


Trace.TraceType.FromValue Method

Gets the TraceType value corresponding to the given EnumeratedValue.

public static TraceType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a TraceTypeProperty.

Return Value

The corresponding TraceType value, or null.

See Also

Trace.TraceType Class | StarTeam Namespace


Trace.TraceType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.TraceType.

public override int GetHashCode();

Return Value

com.starteam.Trace.TraceType.GetHashCode().

See Also

Trace.TraceType Class | StarTeam Namespace


Trace.TraceType.ToString Method

Delegate ToString() to com.starteam.Trace.TraceType.

public override string ToString();

Return Value

com.starteam.Trace.TraceType.ToString()

See Also

Trace.TraceType Class | StarTeam Namespace


Trace.Type Class

The type of the Trace

For a list of all members of this type, see Trace.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Trace.Type

new public class Trace.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.Type Members | StarTeam Namespace


Trace.Type Members

Trace.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Trace.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Trace.Type.

See Also

Trace.Type Class | StarTeam Namespace


Trace.Type Properties

The properties of the Trace.Type class are listed below. For a complete list of Trace.Type class members, see the Trace.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

Trace.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Trace.Type.NAME Property

new public static String NAME {get;}

See Also

Trace.Type Class | StarTeam Namespace


Trace.Type Methods

The methods of the Trace.Type class are listed below. For a complete list of Trace.Type class members, see the Trace.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.Trace.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.Trace.Type.

See Also

Trace.Type Class | StarTeam Namespace


Trace.Type.Equals Method

Delegate Equals() to com.starteam.Trace.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.Type.Equals(obj).

See Also

Trace.Type Class | StarTeam Namespace


Trace.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.Type.

public override int GetHashCode();

Return Value

com.starteam.Trace.Type.GetHashCode().

See Also

Trace.Type Class | StarTeam Namespace


Trace.Type.ToString Method

Delegate ToString() to com.starteam.Trace.Type.

public override string ToString();

Return Value

com.starteam.Trace.Type.ToString()

See Also

Trace.Type Class | StarTeam Namespace


Trace.Type.IsSuspectProperty Class

The property type of the IsSuspect property

For a list of all members of this type, see Trace.Type.IsSuspectProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
Trace.Type.IsSuspectProperty

public class Trace.Type.IsSuspectProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.Type.IsSuspectProperty Members | StarTeam Namespace


Trace.Type.IsSuspectProperty Members

Trace.Type.IsSuspectProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Trace.Type.IsSuspectProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.IsSuspectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Trace.Type.IsSuspectProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.IsSuspectProperty Class | StarTeam Namespace


Trace.Type.IsSuspectProperty Properties

The properties of the Trace.Type.IsSuspectProperty class are listed below. For a complete list of Trace.Type.IsSuspectProperty class members, see the Trace.Type.IsSuspectProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Trace.Type.IsSuspectProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Trace.Type.IsSuspectProperty.NAME Property

public static String NAME {get;}

See Also

Trace.Type.IsSuspectProperty Class | StarTeam Namespace


Trace.Type.IsSuspectProperty Methods

The methods of the Trace.Type.IsSuspectProperty class are listed below. For a complete list of Trace.Type.IsSuspectProperty class members, see the Trace.Type.IsSuspectProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Trace.Type.IsSuspectProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.IsSuspectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Trace.Type.IsSuspectProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.IsSuspectProperty Class | StarTeam Namespace


Trace.Type.IsSuspectProperty.Equals Method

Delegate Equals() to com.starteam.Trace.Type.IsSuspectProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.Type.IsSuspectProperty.Equals(obj).

See Also

Trace.Type.IsSuspectProperty Class | StarTeam Namespace


Trace.Type.IsSuspectProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.Type.IsSuspectProperty.

public override int GetHashCode();

Return Value

com.starteam.Trace.Type.IsSuspectProperty.GetHashCode().

See Also

Trace.Type.IsSuspectProperty Class | StarTeam Namespace


Trace.Type.IsSuspectProperty.ToString Method

Delegate ToString() to com.starteam.Trace.Type.IsSuspectProperty.

public override string ToString();

Return Value

com.starteam.Trace.Type.IsSuspectProperty.ToString()

See Also

Trace.Type.IsSuspectProperty Class | StarTeam Namespace


Trace.Type.OrderProperty Class

The property type of the Order property.

For a list of all members of this type, see Trace.Type.OrderProperty Members.

System.Object
Property
ScalarProperty
DoubleProperty
Trace.Type.OrderProperty

public class Trace.Type.OrderProperty : DoubleProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.Type.OrderProperty Members | StarTeam Namespace


Trace.Type.OrderProperty Members

Trace.Type.OrderProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Trace.Type.OrderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.OrderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Trace.Type.OrderProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.OrderProperty Class | StarTeam Namespace


Trace.Type.OrderProperty Properties

The properties of the Trace.Type.OrderProperty class are listed below. For a complete list of Trace.Type.OrderProperty class members, see the Trace.Type.OrderProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DoubleProperty) | [read/write] the default double value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from DoubleProperty) | [read/write] true if this Double Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DoubleProperty) | [read/write] double
MinValue (inherited from DoubleProperty) | [read/write] double
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Trace.Type.OrderProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Trace.Type.OrderProperty.NAME Property

public static String NAME {get;}

See Also

Trace.Type.OrderProperty Class | StarTeam Namespace


Trace.Type.OrderProperty Methods

The methods of the Trace.Type.OrderProperty class are listed below. For a complete list of Trace.Type.OrderProperty class members, see the Trace.Type.OrderProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Trace.Type.OrderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.OrderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DoubleProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Trace.Type.OrderProperty.
ToTimeSpanProperty (inherited from DoubleProperty) | Converts this DoubleProperty to a TimeSpanProperty. The old DoubleProperty is replaced by the new TimeSpanProperty within the properties collection of the parent Type. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.OrderProperty Class | StarTeam Namespace


Trace.Type.OrderProperty.Equals Method

Delegate Equals() to com.starteam.Trace.Type.OrderProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.Type.OrderProperty.Equals(obj).

See Also

Trace.Type.OrderProperty Class | StarTeam Namespace


Trace.Type.OrderProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.Type.OrderProperty.

public override int GetHashCode();

Return Value

com.starteam.Trace.Type.OrderProperty.GetHashCode().

See Also

Trace.Type.OrderProperty Class | StarTeam Namespace


Trace.Type.OrderProperty.ToString Method

Delegate ToString() to com.starteam.Trace.Type.OrderProperty.

public override string ToString();

Return Value

com.starteam.Trace.Type.OrderProperty.ToString()

See Also

Trace.Type.OrderProperty Class | StarTeam Namespace


Trace.Type.PropertyCollection Class

The property collection of the Trace type

For a list of all members of this type, see Trace.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Trace.Type.PropertyCollection

new public class Trace.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.Type.PropertyCollection Members | StarTeam Namespace


Trace.Type.PropertyCollection Members

Trace.Type.PropertyCollection overview

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_BOOKMARKED |
IS_BRANCH_ON_CHANGE |
IS_READ_ONLY |
IS_SUSPECT |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NON_EXCLUSIVE_LOCKERS |
ORDER |
PARENT_BRANCH_LENGTH_REVISION |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SOURCE |
SOURCE_VERSIONS |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TARGET |
TRACE_TYPE |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Trace.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Trace.Type.PropertyCollection.

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


Trace.Type.PropertyCollection Properties

The properties of the Trace.Type.PropertyCollection class are listed below. For a complete list of Trace.Type.PropertyCollection class members, see the Trace.Type.PropertyCollection Members topic.

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_BOOKMARKED |
IS_BRANCH_ON_CHANGE |
IS_READ_ONLY |
IS_SUSPECT |
IS_UNREAD |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NON_EXCLUSIVE_LOCKERS |
ORDER |
PARENT_BRANCH_LENGTH_REVISION |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SOURCE |
SOURCE_VERSIONS |
STATUS |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TARGET |
TRACE_TYPE |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


IS_BOOKMARKED Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.IS_BOOKMARKED Property

public ViewMember.Type.IsBookmarkedProperty IS_BOOKMARKED {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


IS_SUSPECT Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.IS_SUSPECT Property

public Trace.Type.IsSuspectProperty IS_SUSPECT {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


IS_UNREAD Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.IS_UNREAD Property

public ViewMember.Type.IsUnreadProperty IS_UNREAD {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


ORDER Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.ORDER Property

public Trace.Type.OrderProperty ORDER {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH_REVISION Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.PARENT_BRANCH_LENGTH_REVISION Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH_REVISION {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


SOURCE Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.SOURCE Property

public LiveObject.Type.SourceProperty SOURCE {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


SOURCE_VERSIONS Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.SOURCE_VERSIONS Property

public Trace.Type.SourceVersionsProperty SOURCE_VERSIONS {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.STATUS Property

public Trace.Type.StatusProperty STATUS {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


TARGET Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.TARGET Property

public LiveObject.Type.TargetProperty TARGET {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


TRACE_TYPE Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.TRACE_TYPE Property

public Trace.Type.TraceTypeProperty TRACE_TYPE {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

Trace.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


Trace.Type.PropertyCollection Methods

The methods of the Trace.Type.PropertyCollection class are listed below. For a complete list of Trace.Type.PropertyCollection class members, see the Trace.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.Trace.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.Trace.Type.PropertyCollection.

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


Trace.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.Trace.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.Type.PropertyCollection.Equals(obj).

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


Trace.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.Trace.Type.PropertyCollection.GetHashCode().

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


Trace.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.Trace.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.Trace.Type.PropertyCollection.ToString()

See Also

Trace.Type.PropertyCollection Class | StarTeam Namespace


Trace.Type.SourceVersionsProperty Class

The property type of the SourceVersions property.

For a list of all members of this type, see Trace.Type.SourceVersionsProperty Members.

System.Object
Property
VectorProperty
TextProperty
Trace.Type.SourceVersionsProperty

public class Trace.Type.SourceVersionsProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.Type.SourceVersionsProperty Members | StarTeam Namespace


Trace.Type.SourceVersionsProperty Members

Trace.Type.SourceVersionsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Trace.Type.SourceVersionsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.SourceVersionsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Trace.Type.SourceVersionsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.SourceVersionsProperty Class | StarTeam Namespace


Trace.Type.SourceVersionsProperty Properties

The properties of the Trace.Type.SourceVersionsProperty class are listed below. For a complete list of Trace.Type.SourceVersionsProperty class members, see the Trace.Type.SourceVersionsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

Trace.Type.SourceVersionsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Trace.Type.SourceVersionsProperty.NAME Property

public static String NAME {get;}

See Also

Trace.Type.SourceVersionsProperty Class | StarTeam Namespace


Trace.Type.SourceVersionsProperty Methods

The methods of the Trace.Type.SourceVersionsProperty class are listed below. For a complete list of Trace.Type.SourceVersionsProperty class members, see the Trace.Type.SourceVersionsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.Trace.Type.SourceVersionsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.SourceVersionsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.Trace.Type.SourceVersionsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.SourceVersionsProperty Class | StarTeam Namespace


Trace.Type.SourceVersionsProperty.Equals Method

Delegate Equals() to com.starteam.Trace.Type.SourceVersionsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.Type.SourceVersionsProperty.Equals(obj).

See Also

Trace.Type.SourceVersionsProperty Class | StarTeam Namespace


Trace.Type.SourceVersionsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.Type.SourceVersionsProperty.

public override int GetHashCode();

Return Value

com.starteam.Trace.Type.SourceVersionsProperty.GetHashCode().

See Also

Trace.Type.SourceVersionsProperty Class | StarTeam Namespace


Trace.Type.SourceVersionsProperty.ToString Method

Delegate ToString() to com.starteam.Trace.Type.SourceVersionsProperty.

public override string ToString();

Return Value

com.starteam.Trace.Type.SourceVersionsProperty.ToString()

See Also

Trace.Type.SourceVersionsProperty Class | StarTeam Namespace


Trace.Type.StatusProperty Class

The property type of the Status property

For a list of all members of this type, see Trace.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
Trace.Type.StatusProperty

public class Trace.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.Type.StatusProperty Members | StarTeam Namespace


Trace.Type.StatusProperty Members

Trace.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Trace.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Trace.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.StatusProperty Class | StarTeam Namespace


Trace.Type.StatusProperty Properties

The properties of the Trace.Type.StatusProperty class are listed below. For a complete list of Trace.Type.StatusProperty class members, see the Trace.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Trace.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Trace.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

Trace.Type.StatusProperty Class | StarTeam Namespace


Trace.Type.StatusProperty Methods

The methods of the Trace.Type.StatusProperty class are listed below. For a complete list of Trace.Type.StatusProperty class members, see the Trace.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Trace.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Trace.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.StatusProperty Class | StarTeam Namespace


Trace.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.Trace.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.Type.StatusProperty.Equals(obj).

See Also

Trace.Type.StatusProperty Class | StarTeam Namespace


Trace.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Trace.Status value
);

See Also

Trace.Type.StatusProperty Class | StarTeam Namespace


Trace.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.Trace.Type.StatusProperty.GetHashCode().

See Also

Trace.Type.StatusProperty Class | StarTeam Namespace


Trace.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.Trace.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.Trace.Type.StatusProperty.ToString()

See Also

Trace.Type.StatusProperty Class | StarTeam Namespace


Trace.Type.TraceTypeProperty Class

The property type of the TraceType property

For a list of all members of this type, see Trace.Type.TraceTypeProperty Members.

System.Object
Property
EnumeratedProperty
Trace.Type.TraceTypeProperty

public class Trace.Type.TraceTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.Type.TraceTypeProperty Members | StarTeam Namespace


Trace.Type.TraceTypeProperty Members

Trace.Type.TraceTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Trace.Type.TraceTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.TraceTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Trace.Type.TraceTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.TraceTypeProperty Class | StarTeam Namespace


Trace.Type.TraceTypeProperty Properties

The properties of the Trace.Type.TraceTypeProperty class are listed below. For a complete list of Trace.Type.TraceTypeProperty class members, see the Trace.Type.TraceTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

Trace.Type.TraceTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Trace.Type.TraceTypeProperty.NAME Property

public static String NAME {get;}

See Also

Trace.Type.TraceTypeProperty Class | StarTeam Namespace


Trace.Type.TraceTypeProperty Methods

The methods of the Trace.Type.TraceTypeProperty class are listed below. For a complete list of Trace.Type.TraceTypeProperty class members, see the Trace.Type.TraceTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.Trace.Type.TraceTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.Type.TraceTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.Trace.Type.TraceTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

Trace.Type.TraceTypeProperty Class | StarTeam Namespace


Trace.Type.TraceTypeProperty.Equals Method

Delegate Equals() to com.starteam.Trace.Type.TraceTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.Type.TraceTypeProperty.Equals(obj).

See Also

Trace.Type.TraceTypeProperty Class | StarTeam Namespace


Trace.Type.TraceTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
Trace.TraceType value
);

See Also

Trace.Type.TraceTypeProperty Class | StarTeam Namespace


Trace.Type.TraceTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.Type.TraceTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.Trace.Type.TraceTypeProperty.GetHashCode().

See Also

Trace.Type.TraceTypeProperty Class | StarTeam Namespace


Trace.Type.TraceTypeProperty.ToString Method

Delegate ToString() to com.starteam.Trace.Type.TraceTypeProperty.

public override string ToString();

Return Value

com.starteam.Trace.Type.TraceTypeProperty.ToString()

See Also

Trace.Type.TraceTypeProperty Class | StarTeam Namespace


Trace.WebCacheTrace Class

Trace accessor for cached SDK Traces contained objects are obtained from the artifact cache

For a list of all members of this type, see Trace.WebCacheTrace Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Trace.WebCacheTrace

public class Trace.WebCacheTrace : WebCacheViewMember

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Trace.WebCacheTrace Members | StarTeam Namespace


Trace.WebCacheTrace Members

Trace.WebCacheTrace overview

Public Static Methods

Create

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] The description of this trace.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsSuspect | [read/write] true if the trace is suspect
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Order | [read/write] the order in which the trace should be executed.
PresentationID | [read] the unique integer identifier for this resource.
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Source | [read/write] The source endpoint of this trace.
SourceChange | [read]
SourceLink | [read] The source endpoint of this trace.
SourceTip | [read] The tip source endpoint of this trace.
Status | [read/write] Status
Target | [read/write] The target endpoint of this trace.
TargetChange | [read]
TargetLink | [read] The target endpoint of this trace.
TargetTip | [read] The tip target endpoint of this trace.
Traces | [read] a Trace[] of applicable Traces
TraceType | [read/write] Trace.TraceType
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.Trace.WebCacheTrace.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.WebCacheTrace.
GetSourceVersions |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
PinSource | Set the source end-point of this trace to pinned. i.e. the source will match the specified revision of the ViewMember
PinTarget | Set the target end-point of this trace to pinned. i.e. the target will match the specified revision of the ViewMember
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetSourceVersions |
SetValue | Overloaded. set the value of the property as specified by name
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Trace.WebCacheTrace.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
UnpinSource | Set the source end-point of this trace to float. i.e. the source will always match the tip ViewMember of the configuration
UnpinTarget | Set the target end-point of this trace to float. i.e. the target will always match the tip ViewMember of the configuration
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace Properties

The properties of the Trace.WebCacheTrace class are listed below. For a complete list of Trace.WebCacheTrace class members, see the Trace.WebCacheTrace Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] The description of this trace.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsSuspect | [read/write] true if the trace is suspect
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Order | [read/write] the order in which the trace should be executed.
PresentationID | [read] the unique integer identifier for this resource.
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Source | [read/write] The source endpoint of this trace.
SourceChange | [read]
SourceLink | [read] The source endpoint of this trace.
SourceTip | [read] The tip source endpoint of this trace.
Status | [read/write] Status
Target | [read/write] The target endpoint of this trace.
TargetChange | [read]
TargetLink | [read] The target endpoint of this trace.
TargetTip | [read] The tip target endpoint of this trace.
Traces | [read] a Trace[] of applicable Traces
TraceType | [read/write] Trace.TraceType
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Description Property

[read/write] The description of this trace.

public virtual String Description {get; set;}

Property Value

The description of this trace.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


IsSuspect Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.IsSuspect Property

[read/write] true if the trace is suspect

public virtual Boolean IsSuspect {get; set;}

Property Value

true if the trace is suspect

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Name Property

new public virtual String Name {get;}

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Order Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Order Property

[read/write] the order in which the trace should be executed.

public virtual Double Order {get; set;}

Property Value

the order in which the trace should be executed.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Source Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Source Property

[read/write] The source endpoint of this trace.

public virtual ViewMember.WebCacheViewMember Source {get; set;}

Property Value

The source endpoint of this trace.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


SourceChange Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.SourceChange Property

[read]

public virtual Change.WebCacheChange SourceChange {get;}

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


SourceLink Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.SourceLink Property

[read] The source endpoint of this trace.

public virtual LinkValue.WebCacheLinkValue SourceLink {get;}

Property Value

The source endpoint of this trace.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


SourceTip Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.SourceTip Property

[read] The tip source endpoint of this trace.

public virtual ViewMember.WebCacheViewMember SourceTip {get;}

Property Value

The tip source endpoint of this trace.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Status Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Status Property

[read/write] Status

public virtual Trace.Status Status {get; set;}

Property Value

Status

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Target Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Target Property

[read/write] The target endpoint of this trace.

public virtual ViewMember.WebCacheViewMember Target {get; set;}

Property Value

The target endpoint of this trace.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


TargetChange Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.TargetChange Property

[read]

public virtual Change.WebCacheChange TargetChange {get;}

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


TargetLink Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.TargetLink Property

[read] The target endpoint of this trace.

public virtual LinkValue.WebCacheLinkValue TargetLink {get;}

Property Value

The target endpoint of this trace.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


TargetTip Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.TargetTip Property

[read] The tip target endpoint of this trace.

public virtual ViewMember.WebCacheViewMember TargetTip {get;}

Property Value

The tip target endpoint of this trace.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


TraceType Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.TraceType Property

[read/write] Trace.TraceType

public virtual Trace.TraceType TraceType {get; set;}

Property Value

Trace.TraceType

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace Methods

The methods of the Trace.WebCacheTrace class are listed below. For a complete list of Trace.WebCacheTrace class members, see the Trace.WebCacheTrace Members topic.

Public Static Methods

Create

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.Trace.WebCacheTrace.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Trace.WebCacheTrace.
GetSourceVersions |
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
PinSource | Set the source end-point of this trace to pinned. i.e. the source will match the specified revision of the ViewMember
PinTarget | Set the target end-point of this trace to pinned. i.e. the target will match the specified revision of the ViewMember
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetSourceVersions |
SetValue | Overloaded. set the value of the property as specified by name
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.Trace.WebCacheTrace.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
UnpinSource | Set the source end-point of this trace to float. i.e. the source will always match the tip ViewMember of the configuration
UnpinTarget | Set the target end-point of this trace to float. i.e. the target will always match the tip ViewMember of the configuration
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.Create Method

public static WebCacheTrace Create(
ArtifactCacheManager.Context cntxt,
View.WebCacheView parent
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.Equals Method

Delegate Equals() to com.starteam.Trace.WebCacheTrace.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Trace.WebCacheTrace.Equals(obj).

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.GetHashCode Method

Delegate GetHashCode() to com.starteam.Trace.WebCacheTrace.

public override int GetHashCode();

Return Value

com.starteam.Trace.WebCacheTrace.GetHashCode().

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.GetSourceVersions Method

public virtual string GetSourceVersions(
Trace.Status statusValue
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | Trace.WebCacheTrace.GetValue Overload List


Trace.WebCacheTrace.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | Trace.WebCacheTrace.GetValue Overload List


Trace.WebCacheTrace.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | WebCacheViewMemberCollection


Trace.WebCacheTrace.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | Trace.WebCacheTrace.Lock Overload List | WebCacheViewMemberCollection


Trace.WebCacheTrace.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | Trace.WebCacheTrace.Lock Overload List


Trace.WebCacheTrace.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | NAME


Trace.WebCacheTrace.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | NAME


Trace.WebCacheTrace.PinSource Method

Set the source end-point of this trace to pinned. i.e. the source will match the specified revision of the ViewMember

public virtual void PinSource();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.PinTarget Method

Set the target end-point of this trace to pinned. i.e. the target will match the specified revision of the ViewMember

public virtual void PinTarget();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | isFloating | isPinned | unpin


Trace.WebCacheTrace.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | WebCacheViewMemberCollection


Trace.WebCacheTrace.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.SetSourceVersions Method

public virtual void SetSourceVersions(
Trace.Status statusValue,
String version
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

Trace.WebCacheTrace.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | Trace.WebCacheTrace.SetValue Overload List


Trace.WebCacheTrace.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | Trace.WebCacheTrace.SetValue Overload List


Trace.WebCacheTrace.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.ToString Method

Delegate ToString() to com.starteam.Trace.WebCacheTrace.

public override string ToString();

Return Value

com.starteam.Trace.WebCacheTrace.ToString()

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | WebCacheViewMemberCollection


Trace.WebCacheTrace.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | isFloating | isPinned | pinTo


Trace.WebCacheTrace.UnpinSource Method

Set the source end-point of this trace to float. i.e. the source will always match the tip ViewMember of the configuration

public virtual void UnpinSource();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.UnpinTarget Method

Set the target end-point of this trace to float. i.e. the target will always match the tip ViewMember of the configuration

public virtual void UnpinTarget();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


Trace.WebCacheTrace.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

Trace.WebCacheTrace Class | StarTeam Namespace | WebCacheViewMemberCollection


Trace.WebCacheTrace.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

Trace.WebCacheTrace Class | StarTeam Namespace


TraceCollection Class

Caches Traces for a given view. Also provides a Trace query mechanism.

For a list of all members of this type, see TraceCollection Members.

System.Object
StarTeamCollection
ViewMemberCollection
TraceCollection

public class TraceCollection : ViewMemberCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TraceCollection Members | StarTeam Namespace


TraceCollection Members

TraceCollection overview

Public Instance Constructors

TraceCollection Overloaded. Initializes a new instance of the TraceCollection class.

Public Instance Properties

Cache (inherited from ViewMemberCollection) | [read] CacheService a cache service that can be used to populate, refresh or discard members
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
History (inherited from ViewMemberCollection) | [read] a collection of History collections
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find (inherited from ViewMemberCollection) | Overloaded. find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetAt (inherited from ViewMemberCollection) | Returns the ViewMember at the given index into the virtual array, or null.
GetEnumerator (inherited from StarTeamCollection) |
GetFromHistory (inherited from ViewMemberCollection) | Overloaded. Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this Label Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetTraces | Overloaded. Gets all traces that reference any revision of the given StarTeam item either as the source or the target.
GetTracesFrom | Gets all traces that reference any revision of the given StarTeam item as the source endpoint.
GetTracesTo | Gets all traces that reference any revision of the given StarTeam item as the target endpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewMember (inherited from ViewMemberCollection) | Overloaded. find an element by its primary descriptor (name), using a case insensitive match. Note that the elements in this collection are expected to have unique primary descriptors. If they do not, then the first one found will be returned.
GetViewMemberBehavior (inherited from ViewMemberCollection) | returns the ViewMemberBehavior for a set of ViewMembers
GetViewMembers (inherited from ViewMemberCollection) | return a set of elements by primary descriptor. For example, files with the same name but in different folders
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
LockExclusive (inherited from ViewMemberCollection) | Overloaded. Obtains an exclusive lock on each member of this collection, without attempting to break an existing lock. A server exception will be thrown if any of the locks cannot be obtained.
LockNonExclusive (inherited from ViewMemberCollection) | Obtains a non-exclusive lock on each member of this collection. Other StarTeam users can also acquire a non-exclusive lock on these resources. A server exception will be thrown if any of the locks cannot be obtained.
ModifyBookmark (inherited from ViewMemberCollection) | Modifies this list of member's book mark for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getBookmark() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyReadStatus (inherited from ViewMemberCollection) | Modifies this list of members's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This command is not supported for File items. All Files in the collection will be ignored
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Reverse (inherited from ViewMemberCollection) | returns a collection whose elements are in the reverse order of this one i.e. the order of elements of a call to toArray() on the returned collection will be in reverse order w.r.t. the order of elements of a call to toArray on this collection
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ShareTo (inherited from ViewMemberCollection) | Share the items from this collection to the target view this should be a different view from the view that the items belong to. All the shares will be committed in a single transaction
Sort (inherited from ViewMemberCollection) | Overloaded. returns an array of ViewMembers whose elements are sorted using the provided comparer. Note that the caller should ensure that the properties used for comparison are pre-populated before calling this api, to avoid the overhead of single round trip queries per view member during the compare itself.
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.
Unlock (inherited from ViewMemberCollection) | Removes the current user's lock from each member of this collection. If another user has an exclusive lock on one of the members, that lock will not be removed.
Update |

See Also

TraceCollection Class | StarTeam Namespace


TraceCollection Constructor

Constructs an empty collection capable of holding trace objects

Overload List

Constructs an empty collection capable of holding trace objects

public TraceCollection();

Constructs a trace collection containing only the specified trace

public TraceCollection(Trace);

Constructs a trace collection containing all the traces of the specified array.

public TraceCollection(Trace[]);

Constructs a trace collection containing all the traces of the specified trace collection.

public TraceCollection(TraceCollection);

See Also

TraceCollection Class | StarTeam Namespace


TraceCollection Constructor ()

Constructs an empty collection capable of holding trace objects

public TraceCollection();

See Also

TraceCollection Class | StarTeam Namespace | TraceCollection Constructor Overload List


TraceCollection Constructor (TraceCollection)

Constructs a trace collection containing all the traces of the specified trace collection.

public TraceCollection(
TraceCollection c
);

Parameters

c
the TraceCollection whose elements are to be placed into this collection.

See Also

TraceCollection Class | StarTeam Namespace | TraceCollection Constructor Overload List


TraceCollection Constructor (Trace[])

Constructs a trace collection containing all the traces of the specified array.

public TraceCollection(
Trace[] a
);

Parameters

a
the trace array whose elements are to be placed into this collection.

See Also

TraceCollection Class | StarTeam Namespace | TraceCollection Constructor Overload List


TraceCollection Constructor (Trace)

Constructs a trace collection containing only the specified trace

public TraceCollection(
Trace t
);

Parameters

t
the trace object to be placed into this collection.

See Also

TraceCollection Class | StarTeam Namespace | TraceCollection Constructor Overload List


TraceCollection Methods

The methods of the TraceCollection class are listed below. For a complete list of TraceCollection class members, see the TraceCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find (inherited from ViewMemberCollection) | Overloaded. find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetAt (inherited from ViewMemberCollection) | Returns the ViewMember at the given index into the virtual array, or null.
GetEnumerator (inherited from StarTeamCollection) |
GetFromHistory (inherited from ViewMemberCollection) | Overloaded. Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this Label Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetTraces | Overloaded. Gets all traces that reference any revision of the given StarTeam item either as the source or the target.
GetTracesFrom | Gets all traces that reference any revision of the given StarTeam item as the source endpoint.
GetTracesTo | Gets all traces that reference any revision of the given StarTeam item as the target endpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewMember (inherited from ViewMemberCollection) | Overloaded. find an element by its primary descriptor (name), using a case insensitive match. Note that the elements in this collection are expected to have unique primary descriptors. If they do not, then the first one found will be returned.
GetViewMemberBehavior (inherited from ViewMemberCollection) | returns the ViewMemberBehavior for a set of ViewMembers
GetViewMembers (inherited from ViewMemberCollection) | return a set of elements by primary descriptor. For example, files with the same name but in different folders
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
LockExclusive (inherited from ViewMemberCollection) | Overloaded. Obtains an exclusive lock on each member of this collection, without attempting to break an existing lock. A server exception will be thrown if any of the locks cannot be obtained.
LockNonExclusive (inherited from ViewMemberCollection) | Obtains a non-exclusive lock on each member of this collection. Other StarTeam users can also acquire a non-exclusive lock on these resources. A server exception will be thrown if any of the locks cannot be obtained.
ModifyBookmark (inherited from ViewMemberCollection) | Modifies this list of member's book mark for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getBookmark() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyReadStatus (inherited from ViewMemberCollection) | Modifies this list of members's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This command is not supported for File items. All Files in the collection will be ignored
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Reverse (inherited from ViewMemberCollection) | returns a collection whose elements are in the reverse order of this one i.e. the order of elements of a call to toArray() on the returned collection will be in reverse order w.r.t. the order of elements of a call to toArray on this collection
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ShareTo (inherited from ViewMemberCollection) | Share the items from this collection to the target view this should be a different view from the view that the items belong to. All the shares will be committed in a single transaction
Sort (inherited from ViewMemberCollection) | Overloaded. returns an array of ViewMembers whose elements are sorted using the provided comparer. Note that the caller should ensure that the properties used for comparison are pre-populated before calling this api, to avoid the overhead of single round trip queries per view member during the compare itself.
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.
Unlock (inherited from ViewMemberCollection) | Removes the current user's lock from each member of this collection. If another user has an exclusive lock on one of the members, that lock will not be removed.
Update |

See Also

TraceCollection Class | StarTeam Namespace


GetTraces Method

Borland StarTeam SDK for .NET

TraceCollection.GetTraces Method

Overload List

public virtual TraceCollection GetTraces(LinkValue,TraceFinder.Direction,TraceFinder.PinType);

Gets all traces that reference any revision of the given StarTeam item either as the source or the target.

public virtual TraceCollection GetTraces(ViewMember);

public virtual TraceCollection GetTraces(ViewMember,TraceFinder.Direction,TraceFinder.PinType);

public virtual TraceCollection GetTraces(String,TraceFinder.Direction,TraceFinder.PinType);

See Also

TraceCollection Class | StarTeam Namespace


TraceCollection.GetTraces Method (LinkValue, TraceFinder#Direction, TraceFinder#PinType)

public virtual TraceCollection GetTraces(
LinkValue value,
TraceFinder.Direction direction,
TraceFinder.PinType pin
);

See Also

TraceCollection Class | StarTeam Namespace | TraceCollection.GetTraces Overload List


TraceCollection.GetTraces Method (ViewMember)

Gets all traces that reference any revision of the given StarTeam item either as the source or the target.

public virtual TraceCollection GetTraces(
ViewMember item
);

Parameters

item
endpoint starTeam item.

Return Value

TraceCollection that reference the given item.

See Also

TraceCollection Class | StarTeam Namespace | TraceCollection.GetTraces Overload List


TraceCollection.GetTraces Method (ViewMember, TraceFinder#Direction, TraceFinder#PinType)

public virtual TraceCollection GetTraces(
ViewMember item,
TraceFinder.Direction direction,
TraceFinder.PinType pin
);

See Also

TraceCollection Class | StarTeam Namespace | TraceCollection.GetTraces Overload List


TraceCollection.GetTraces Method (String, TraceFinder#Direction, TraceFinder#PinType)

public virtual TraceCollection GetTraces(
String url,
TraceFinder.Direction direction,
TraceFinder.PinType pin
);

See Also

TraceCollection Class | StarTeam Namespace | TraceCollection.GetTraces Overload List


TraceCollection.GetTracesFrom Method

Gets all traces that reference any revision of the given StarTeam item as the source endpoint.

public virtual TraceCollection GetTracesFrom(
ViewMember source
);

Parameters

source
The StarTeam item.

Return Value

The TraceCollection that reference the given source endpoint.

See Also

TraceCollection Class | StarTeam Namespace


TraceCollection.GetTracesTo Method

Gets all traces that reference any revision of the given StarTeam item as the target endpoint.

public virtual TraceCollection GetTracesTo(
ViewMember target
);

Parameters

target
The StarTeam item.

Return Value

The TraceCollection that reference the given target endpoint.

See Also

TraceCollection Class | StarTeam Namespace


TraceCollection.Update Method

public virtual void Update();

See Also

TraceCollection Class | StarTeam Namespace


TraceFinder Class

Searches for Traces across StarTeam servers.

Searches all servers in the application's Servers collection. If two server objects in the collection refer to the same underlying repository, only one of them is searched.

For a list of all members of this type, see TraceFinder Members.

System.Object
TraceFinder

public class TraceFinder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TraceFinder Members | StarTeam Namespace


TraceFinder Members

TraceFinder overview

Public Instance Properties

ServersSearched [read] Collection of servers that were searched for traces.

Public Instance Methods

Cancel | Cancels a running trace finder.Stops all query threads as soon as possible. The cancel() method returns when the threads have stopped. The invoked query returns partial results.
Equals | Delegate Equals() to com.starteam.TraceFinder.
GetHashCode | Delegate GetHashCode() to com.starteam.TraceFinder.
GetTraces | Overloaded. Gets all traces that reference the given revision or any historical revision of the given StarTeam item either as the source or the target.
GetTracesFrom | Gets all traces that reference the given revision or any historical revision of the given StarTeam item as source endpoint.
GetTracesTo | Gets all traces that referenceGets all traces that reference the given revision or any historical revision of the given StarTeam item as target endpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
NewTraceEventSource |
RequestTraceProperties | Requests the set of properties for which the values are desired to be returned by the server command for the traces found
ToString | Delegate ToString() to com.starteam.TraceFinder.

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder Properties

The properties of the TraceFinder class are listed below. For a complete list of TraceFinder class members, see the TraceFinder Members topic.

Public Instance Properties

ServersSearched [read] Collection of servers that were searched for traces.

See Also

TraceFinder Class | StarTeam Namespace


ServersSearched Property

Borland StarTeam SDK for .NET

TraceFinder.ServersSearched Property

[read] Collection of servers that were searched for traces.

public virtual Server[] ServersSearched {get;}

Property Value

Collection of servers that were searched for traces.

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder Methods

The methods of the TraceFinder class are listed below. For a complete list of TraceFinder class members, see the TraceFinder Members topic.

Public Instance Methods

Cancel | Cancels a running trace finder.Stops all query threads as soon as possible. The cancel() method returns when the threads have stopped. The invoked query returns partial results.
Equals | Delegate Equals() to com.starteam.TraceFinder.
GetHashCode | Delegate GetHashCode() to com.starteam.TraceFinder.
GetTraces | Overloaded. Gets all traces that reference the given revision or any historical revision of the given StarTeam item either as the source or the target.
GetTracesFrom | Gets all traces that reference the given revision or any historical revision of the given StarTeam item as source endpoint.
GetTracesTo | Gets all traces that referenceGets all traces that reference the given revision or any historical revision of the given StarTeam item as target endpoint.
GetType (inherited from Object) | Gets the Type of the current instance.
NewTraceEventSource |
RequestTraceProperties | Requests the set of properties for which the values are desired to be returned by the server command for the traces found
ToString | Delegate ToString() to com.starteam.TraceFinder.

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder.Cancel Method

Cancels a running trace finder.Stops all query threads as soon as possible. The cancel() method returns when the threads have stopped. The invoked query returns partial results.

public virtual void Cancel();

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder.Equals Method

Delegate Equals() to com.starteam.TraceFinder.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TraceFinder.Equals(obj).

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder.GetHashCode Method

Delegate GetHashCode() to com.starteam.TraceFinder.

public override int GetHashCode();

Return Value

com.starteam.TraceFinder.GetHashCode().

See Also

TraceFinder Class | StarTeam Namespace


GetTraces Method

Borland StarTeam SDK for .NET

TraceFinder.GetTraces Method

Overload List

public virtual TraceCollection GetTraces(LinkValue,TraceFinder.Direction,TraceFinder.PinType);

Gets all traces that reference the given revision or any historical revision of the given StarTeam item either as the source or the target.

public virtual TraceCollection GetTraces(ViewMember);

public virtual TraceCollection GetTraces(ViewMember,TraceFinder.Direction,TraceFinder.PinType);

public virtual TraceCollection GetTraces(String,TraceFinder.Direction,TraceFinder.PinType);

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder.GetTraces Method (LinkValue, TraceFinder#Direction, TraceFinder#PinType)

public virtual TraceCollection GetTraces(
LinkValue value,
TraceFinder.Direction direction,
TraceFinder.PinType pin
);

See Also

TraceFinder Class | StarTeam Namespace | TraceFinder.GetTraces Overload List


TraceFinder.GetTraces Method (ViewMember)

Gets all traces that reference the given revision or any historical revision of the given StarTeam item either as the source or the target.

public virtual TraceCollection GetTraces(
ViewMember item
);

Parameters

item
The endpoint StarTeam item.

Return Value

TraceCollection that reference the given item.

See Also

TraceFinder Class | StarTeam Namespace | TraceFinder.GetTraces Overload List


TraceFinder.GetTraces Method (ViewMember, TraceFinder#Direction, TraceFinder#PinType)

public virtual TraceCollection GetTraces(
ViewMember item,
TraceFinder.Direction direction,
TraceFinder.PinType pin
);

See Also

TraceFinder Class | StarTeam Namespace | TraceFinder.GetTraces Overload List


TraceFinder.GetTraces Method (String, TraceFinder#Direction, TraceFinder#PinType)

public virtual TraceCollection GetTraces(
String url,
TraceFinder.Direction direction,
TraceFinder.PinType pin
);

See Also

TraceFinder Class | StarTeam Namespace | TraceFinder.GetTraces Overload List


TraceFinder.GetTracesFrom Method

Gets all traces that reference the given revision or any historical revision of the given StarTeam item as source endpoint.

public virtual TraceCollection GetTracesFrom(
ViewMember source
);

Parameters

source
The StarTeam item.

Return Value

The TraceCollection that reference the given source endpoint.

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder.GetTracesTo Method

Gets all traces that referenceGets all traces that reference the given revision or any historical revision of the given StarTeam item as target endpoint.

public virtual TraceCollection GetTracesTo(
ViewMember target
);

Parameters

target
The StarTeam item.

Return Value

The TraceCollection that reference the given target endpoint.

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder.NewTraceEventSource Method

public TraceEventSource NewTraceEventSource();

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder.RequestTraceProperties Method

Requests the set of properties for which the values are desired to be returned by the server command for the traces found

public virtual void RequestTraceProperties(
PropertyCollection properties
);

Parameters

properties
- an array of trace properties

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder.ToString Method

Delegate ToString() to com.starteam.TraceFinder.

public override string ToString();

Return Value

com.starteam.TraceFinder.ToString()

See Also

TraceFinder Class | StarTeam Namespace


TraceFinder.Direction Class

Allows a set of traces to be filtered by direction.

For a list of all members of this type, see TraceFinder.Direction Members.

System.Object
TraceFinder.Direction

public class TraceFinder.Direction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TraceFinder.Direction Members | StarTeam Namespace


TraceFinder.Direction Members

TraceFinder.Direction overview

Public Static Properties

ALL
ANY
FROM
TO

Public Static Methods

FromID Gets the Direction for a given ID.

Public Instance Properties

ID [read] The ID of this Direction.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TraceFinder.Direction.
GetHashCode | Delegate GetHashCode() to com.starteam.TraceFinder.Direction.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.TraceFinder.Direction.

See Also

TraceFinder.Direction Class | StarTeam Namespace


TraceFinder.Direction Properties

The properties of the TraceFinder.Direction class are listed below. For a complete list of TraceFinder.Direction class members, see the TraceFinder.Direction Members topic.

Public Static Properties

ALL
ANY
FROM
TO

Public Instance Properties

ID [read] The ID of this Direction.

See Also

TraceFinder.Direction Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

TraceFinder.Direction.ALL Property

public static Direction[] ALL {get;}

See Also

TraceFinder.Direction Class | StarTeam Namespace


ANY Property

Borland StarTeam SDK for .NET

TraceFinder.Direction.ANY Property

public static TraceFinder.Direction ANY {get;}

Property Value

Does not filter by direction.

See Also

TraceFinder.Direction Class | StarTeam Namespace


FROM Property

Borland StarTeam SDK for .NET

TraceFinder.Direction.FROM Property

public static TraceFinder.Direction FROM {get;}

Property Value

The requested item must be the source of the trace.

See Also

TraceFinder.Direction Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TraceFinder.Direction.ID Property

[read] The ID of this Direction.

public virtual Int32 ID {get;}

Property Value

The ID of this Direction.

See Also

TraceFinder.Direction Class | StarTeam Namespace


TO Property

Borland StarTeam SDK for .NET

TraceFinder.Direction.TO Property

public static TraceFinder.Direction TO {get;}

Property Value

The requested item must be the target of the trace.

See Also

TraceFinder.Direction Class | StarTeam Namespace


TraceFinder.Direction Methods

The methods of the TraceFinder.Direction class are listed below. For a complete list of TraceFinder.Direction class members, see the TraceFinder.Direction Members topic.

Public Static Methods

FromID Gets the Direction for a given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TraceFinder.Direction.
GetHashCode | Delegate GetHashCode() to com.starteam.TraceFinder.Direction.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.TraceFinder.Direction.

See Also

TraceFinder.Direction Class | StarTeam Namespace


TraceFinder.Direction.Equals Method

Delegate Equals() to com.starteam.TraceFinder.Direction.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TraceFinder.Direction.Equals(obj).

See Also

TraceFinder.Direction Class | StarTeam Namespace


TraceFinder.Direction.FromID Method

Gets the Direction for a given ID.

public static Direction FromID(
Int32 id
);

Parameters

id
An integer ID.

Return Value

The Direction with the given ID.

See Also

TraceFinder.Direction Class | StarTeam Namespace


TraceFinder.Direction.GetHashCode Method

Delegate GetHashCode() to com.starteam.TraceFinder.Direction.

public override int GetHashCode();

Return Value

com.starteam.TraceFinder.Direction.GetHashCode().

See Also

TraceFinder.Direction Class | StarTeam Namespace


TraceFinder.Direction.ToString Method

Delegate ToString() to com.starteam.TraceFinder.Direction.

public override string ToString();

Return Value

com.starteam.TraceFinder.Direction.ToString()

See Also

TraceFinder.Direction Class | StarTeam Namespace


TraceFinder.PinType Class

Allows a set of traces to be filtered by revision. Supported only for endpoints that reference StarTeam items.

For a list of all members of this type, see TraceFinder.PinType Members.

System.Object
TraceFinder.PinType

public class TraceFinder.PinType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TraceFinder.PinType Members | StarTeam Namespace


TraceFinder.PinType Members

TraceFinder.PinType overview

Public Static Properties

ALL
ANY
EARLIER
HISTORY
LATER
NEXT
PREVIOUS
THIS

Public Static Methods

FromID Gets the PinType for a given ID.

Public Instance Properties

ID [read] The ID of this PinType.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TraceFinder.PinType.
GetHashCode | Delegate GetHashCode() to com.starteam.TraceFinder.PinType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.TraceFinder.PinType.

See Also

TraceFinder.PinType Class | StarTeam Namespace


TraceFinder.PinType Properties

The properties of the TraceFinder.PinType class are listed below. For a complete list of TraceFinder.PinType class members, see the TraceFinder.PinType Members topic.

Public Static Properties

ALL
ANY
EARLIER
HISTORY
LATER
NEXT
PREVIOUS
THIS

Public Instance Properties

ID [read] The ID of this PinType.

See Also

TraceFinder.PinType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

TraceFinder.PinType.ALL Property

public static PinType[] ALL {get;}

See Also

TraceFinder.PinType Class | StarTeam Namespace


ANY Property

Borland StarTeam SDK for .NET

TraceFinder.PinType.ANY Property

public static TraceFinder.PinType ANY {get;}

Property Value

Does not filter by revision.

See Also

TraceFinder.PinType Class | StarTeam Namespace


EARLIER Property

Borland StarTeam SDK for .NET

TraceFinder.PinType.EARLIER Property

public static TraceFinder.PinType EARLIER {get;}

Property Value

The trace must match a revision of the item that was created before the given one.

See Also

TraceFinder.PinType Class | StarTeam Namespace


HISTORY Property

Borland StarTeam SDK for .NET

TraceFinder.PinType.HISTORY Property

public static TraceFinder.PinType HISTORY {get;}

Property Value

The trace must match the given revision of the item, or any historical revision of the item.

See Also

TraceFinder.PinType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TraceFinder.PinType.ID Property

[read] The ID of this PinType.

public virtual Int32 ID {get;}

Property Value

The ID of this PinType.

See Also

TraceFinder.PinType Class | StarTeam Namespace


LATER Property

Borland StarTeam SDK for .NET

TraceFinder.PinType.LATER Property

public static TraceFinder.PinType LATER {get;}

Property Value

The trace must match a revision of the item that was created after the given one.

See Also

TraceFinder.PinType Class | StarTeam Namespace


NEXT Property

Borland StarTeam SDK for .NET

TraceFinder.PinType.NEXT Property

public static TraceFinder.PinType NEXT {get;}

Property Value

The trace must match the next revision of the given item.

See Also

TraceFinder.PinType Class | StarTeam Namespace


PREVIOUS Property

Borland StarTeam SDK for .NET

TraceFinder.PinType.PREVIOUS Property

public static TraceFinder.PinType PREVIOUS {get;}

Property Value

The trace must match the previous revision of the given item.

See Also

TraceFinder.PinType Class | StarTeam Namespace


THIS Property

Borland StarTeam SDK for .NET

TraceFinder.PinType.THIS Property

public static TraceFinder.PinType THIS {get;}

Property Value

The trace must reference exactly the given revision of the item.

See Also

TraceFinder.PinType Class | StarTeam Namespace


TraceFinder.PinType Methods

The methods of the TraceFinder.PinType class are listed below. For a complete list of TraceFinder.PinType class members, see the TraceFinder.PinType Members topic.

Public Static Methods

FromID Gets the PinType for a given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TraceFinder.PinType.
GetHashCode | Delegate GetHashCode() to com.starteam.TraceFinder.PinType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.TraceFinder.PinType.

See Also

TraceFinder.PinType Class | StarTeam Namespace


TraceFinder.PinType.Equals Method

Delegate Equals() to com.starteam.TraceFinder.PinType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TraceFinder.PinType.Equals(obj).

See Also

TraceFinder.PinType Class | StarTeam Namespace


TraceFinder.PinType.FromID Method

Gets the PinType for a given ID.

public static PinType FromID(
Int32 id
);

Parameters

id
An integer ID.

Return Value

The PinType with the given ID.

See Also

TraceFinder.PinType Class | StarTeam Namespace


TraceFinder.PinType.GetHashCode Method

Delegate GetHashCode() to com.starteam.TraceFinder.PinType.

public override int GetHashCode();

Return Value

com.starteam.TraceFinder.PinType.GetHashCode().

See Also

TraceFinder.PinType Class | StarTeam Namespace


TraceFinder.PinType.ToString Method

Delegate ToString() to com.starteam.TraceFinder.PinType.

public override string ToString();

Return Value

com.starteam.TraceFinder.PinType.ToString()

See Also

TraceFinder.PinType Class | StarTeam Namespace


TrackedObject Class

A TrackedObject is a LiveObject that keeps track of the date/time it was last modified, and the ID of the user who modified it.

For a list of all members of this type, see TrackedObject Members.

System.Object
TypedResource
LiveObject
TrackedObject
Derived types

public class TrackedObject : LiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TrackedObject Members | StarTeam Namespace


TrackedObject Members

TrackedObject overview

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

TrackedObject Class | StarTeam Namespace


TrackedObject Properties

The properties of the TrackedObject class are listed below. For a complete list of TrackedObject class members, see the TrackedObject Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource

See Also

TrackedObject Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

TrackedObject.ModifiedBy Property

[read] The user who last modified this object.

public virtual User ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

TrackedObject Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

TrackedObject.ModifiedTime Property

[read] The date and time at which this object was last modified.

public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

TrackedObject Class | StarTeam Namespace


TrackedObject.Type Class

The Type for TrackedObject

For a list of all members of this type, see TrackedObject.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
Label.Type
Principal.Type
Share.Type
VersionedObject.Type

new public class TrackedObject.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TrackedObject.Type Members | StarTeam Namespace


TrackedObject.Type Members

TrackedObject.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.

See Also

TrackedObject.Type Class | StarTeam Namespace


TrackedObject.Type Properties

The properties of the TrackedObject.Type class are listed below. For a complete list of TrackedObject.Type class members, see the TrackedObject.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

TrackedObject.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TrackedObject.Type.NAME Property

new public static String NAME {get;}

See Also

TrackedObject.Type Class | StarTeam Namespace


TrackedObject.Type Methods

The methods of the TrackedObject.Type class are listed below. For a complete list of TrackedObject.Type class members, see the TrackedObject.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.

See Also

TrackedObject.Type Class | StarTeam Namespace


TrackedObject.Type.Equals Method

Delegate Equals() to com.starteam.TrackedObject.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TrackedObject.Type.Equals(obj).

See Also

TrackedObject.Type Class | StarTeam Namespace


TrackedObject.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.TrackedObject.Type.

public override int GetHashCode();

Return Value

com.starteam.TrackedObject.Type.GetHashCode().

See Also

TrackedObject.Type Class | StarTeam Namespace


TrackedObject.Type.ToString Method

Delegate ToString() to com.starteam.TrackedObject.Type.

public override string ToString();

Return Value

com.starteam.TrackedObject.Type.ToString()

See Also

TrackedObject.Type Class | StarTeam Namespace


TrackedObject.Type.EndModifiedTimeProperty Class

The property type of the End Modified Time property.

For a list of all members of this type, see TrackedObject.Type.EndModifiedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
TrackedObject.Type.EndModifiedTimeProperty

public class TrackedObject.Type.EndModifiedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TrackedObject.Type.EndModifiedTimeProperty Members | StarTeam Namespace


TrackedObject.Type.EndModifiedTimeProperty Members

TrackedObject.Type.EndModifiedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.EndModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.EndModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.EndModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.EndModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.EndModifiedTimeProperty Properties

The properties of the TrackedObject.Type.EndModifiedTimeProperty class are listed below. For a complete list of TrackedObject.Type.EndModifiedTimeProperty class members, see the TrackedObject.Type.EndModifiedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TrackedObject.Type.EndModifiedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TrackedObject.Type.EndModifiedTimeProperty.NAME Property

public static String NAME {get;}

See Also

TrackedObject.Type.EndModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.EndModifiedTimeProperty Methods

The methods of the TrackedObject.Type.EndModifiedTimeProperty class are listed below. For a complete list of TrackedObject.Type.EndModifiedTimeProperty class members, see the TrackedObject.Type.EndModifiedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.EndModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.EndModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.EndModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.EndModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.EndModifiedTimeProperty.Equals Method

Delegate Equals() to com.starteam.TrackedObject.Type.EndModifiedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TrackedObject.Type.EndModifiedTimeProperty.Equals(obj).

See Also

TrackedObject.Type.EndModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.EndModifiedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TrackedObject.Type.EndModifiedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.TrackedObject.Type.EndModifiedTimeProperty.GetHashCode().

See Also

TrackedObject.Type.EndModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.EndModifiedTimeProperty.ToString Method

Delegate ToString() to com.starteam.TrackedObject.Type.EndModifiedTimeProperty.

public override string ToString();

Return Value

com.starteam.TrackedObject.Type.EndModifiedTimeProperty.ToString()

See Also

TrackedObject.Type.EndModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.FolderPathProperty Class

The property type of the Folder Path property.

For a list of all members of this type, see TrackedObject.Type.FolderPathProperty Members.

System.Object
Property
VectorProperty
TextProperty
TrackedObject.Type.FolderPathProperty

public class TrackedObject.Type.FolderPathProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TrackedObject.Type.FolderPathProperty Members | StarTeam Namespace


TrackedObject.Type.FolderPathProperty Members

TrackedObject.Type.FolderPathProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.FolderPathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.FolderPathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.FolderPathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.FolderPathProperty Class | StarTeam Namespace


TrackedObject.Type.FolderPathProperty Properties

The properties of the TrackedObject.Type.FolderPathProperty class are listed below. For a complete list of TrackedObject.Type.FolderPathProperty class members, see the TrackedObject.Type.FolderPathProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TrackedObject.Type.FolderPathProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TrackedObject.Type.FolderPathProperty.NAME Property

public static String NAME {get;}

See Also

TrackedObject.Type.FolderPathProperty Class | StarTeam Namespace


TrackedObject.Type.FolderPathProperty Methods

The methods of the TrackedObject.Type.FolderPathProperty class are listed below. For a complete list of TrackedObject.Type.FolderPathProperty class members, see the TrackedObject.Type.FolderPathProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.FolderPathProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.FolderPathProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.FolderPathProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.FolderPathProperty Class | StarTeam Namespace


TrackedObject.Type.FolderPathProperty.Equals Method

Delegate Equals() to com.starteam.TrackedObject.Type.FolderPathProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TrackedObject.Type.FolderPathProperty.Equals(obj).

See Also

TrackedObject.Type.FolderPathProperty Class | StarTeam Namespace


TrackedObject.Type.FolderPathProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TrackedObject.Type.FolderPathProperty.

public override int GetHashCode();

Return Value

com.starteam.TrackedObject.Type.FolderPathProperty.GetHashCode().

See Also

TrackedObject.Type.FolderPathProperty Class | StarTeam Namespace


TrackedObject.Type.FolderPathProperty.ToString Method

Delegate ToString() to com.starteam.TrackedObject.Type.FolderPathProperty.

public override string ToString();

Return Value

com.starteam.TrackedObject.Type.FolderPathProperty.ToString()

See Also

TrackedObject.Type.FolderPathProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedByProperty Class

The property type of the Modified By property.

For a list of all members of this type, see TrackedObject.Type.ModifiedByProperty Members.

System.Object
Property
ObjectProperty
TrackedObject.Type.ModifiedByProperty

public class TrackedObject.Type.ModifiedByProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TrackedObject.Type.ModifiedByProperty Members | StarTeam Namespace


TrackedObject.Type.ModifiedByProperty Members

TrackedObject.Type.ModifiedByProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.ModifiedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.ModifiedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.ModifiedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.ModifiedByProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedByProperty Properties

The properties of the TrackedObject.Type.ModifiedByProperty class are listed below. For a complete list of TrackedObject.Type.ModifiedByProperty class members, see the TrackedObject.Type.ModifiedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

TrackedObject.Type.ModifiedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TrackedObject.Type.ModifiedByProperty.NAME Property

public static String NAME {get;}

See Also

TrackedObject.Type.ModifiedByProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedByProperty Methods

The methods of the TrackedObject.Type.ModifiedByProperty class are listed below. For a complete list of TrackedObject.Type.ModifiedByProperty class members, see the TrackedObject.Type.ModifiedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.ModifiedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.ModifiedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.ModifiedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.ModifiedByProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedByProperty.Equals Method

Delegate Equals() to com.starteam.TrackedObject.Type.ModifiedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TrackedObject.Type.ModifiedByProperty.Equals(obj).

See Also

TrackedObject.Type.ModifiedByProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TrackedObject.Type.ModifiedByProperty.

public override int GetHashCode();

Return Value

com.starteam.TrackedObject.Type.ModifiedByProperty.GetHashCode().

See Also

TrackedObject.Type.ModifiedByProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedByProperty.ToString Method

Delegate ToString() to com.starteam.TrackedObject.Type.ModifiedByProperty.

public override string ToString();

Return Value

com.starteam.TrackedObject.Type.ModifiedByProperty.ToString()

See Also

TrackedObject.Type.ModifiedByProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedTimeProperty Class

The property type of the Modified Time property.

For a list of all members of this type, see TrackedObject.Type.ModifiedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
TrackedObject.Type.ModifiedTimeProperty

public class TrackedObject.Type.ModifiedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TrackedObject.Type.ModifiedTimeProperty Members | StarTeam Namespace


TrackedObject.Type.ModifiedTimeProperty Members

TrackedObject.Type.ModifiedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.ModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.ModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.ModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.ModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedTimeProperty Properties

The properties of the TrackedObject.Type.ModifiedTimeProperty class are listed below. For a complete list of TrackedObject.Type.ModifiedTimeProperty class members, see the TrackedObject.Type.ModifiedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TrackedObject.Type.ModifiedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TrackedObject.Type.ModifiedTimeProperty.NAME Property

public static String NAME {get;}

See Also

TrackedObject.Type.ModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedTimeProperty Methods

The methods of the TrackedObject.Type.ModifiedTimeProperty class are listed below. For a complete list of TrackedObject.Type.ModifiedTimeProperty class members, see the TrackedObject.Type.ModifiedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.ModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.ModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.ModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.ModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedTimeProperty.Equals Method

Delegate Equals() to com.starteam.TrackedObject.Type.ModifiedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TrackedObject.Type.ModifiedTimeProperty.Equals(obj).

See Also

TrackedObject.Type.ModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TrackedObject.Type.ModifiedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.TrackedObject.Type.ModifiedTimeProperty.GetHashCode().

See Also

TrackedObject.Type.ModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.ModifiedTimeProperty.ToString Method

Delegate ToString() to com.starteam.TrackedObject.Type.ModifiedTimeProperty.

public override string ToString();

Return Value

com.starteam.TrackedObject.Type.ModifiedTimeProperty.ToString()

See Also

TrackedObject.Type.ModifiedTimeProperty Class | StarTeam Namespace


TrackedObject.Type.ParentFolderNameProperty Class

The property type of the Parent Folder Name property.

For a list of all members of this type, see TrackedObject.Type.ParentFolderNameProperty Members.

System.Object
Property
VectorProperty
TextProperty
TrackedObject.Type.ParentFolderNameProperty

public class TrackedObject.Type.ParentFolderNameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TrackedObject.Type.ParentFolderNameProperty Members | StarTeam Namespace


TrackedObject.Type.ParentFolderNameProperty Members

TrackedObject.Type.ParentFolderNameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.ParentFolderNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.ParentFolderNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.ParentFolderNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.ParentFolderNameProperty Class | StarTeam Namespace


TrackedObject.Type.ParentFolderNameProperty Properties

The properties of the TrackedObject.Type.ParentFolderNameProperty class are listed below. For a complete list of TrackedObject.Type.ParentFolderNameProperty class members, see the TrackedObject.Type.ParentFolderNameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TrackedObject.Type.ParentFolderNameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TrackedObject.Type.ParentFolderNameProperty.NAME Property

public static String NAME {get;}

See Also

TrackedObject.Type.ParentFolderNameProperty Class | StarTeam Namespace


TrackedObject.Type.ParentFolderNameProperty Methods

The methods of the TrackedObject.Type.ParentFolderNameProperty class are listed below. For a complete list of TrackedObject.Type.ParentFolderNameProperty class members, see the TrackedObject.Type.ParentFolderNameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.ParentFolderNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.ParentFolderNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.ParentFolderNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.ParentFolderNameProperty Class | StarTeam Namespace


TrackedObject.Type.ParentFolderNameProperty.Equals Method

Delegate Equals() to com.starteam.TrackedObject.Type.ParentFolderNameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TrackedObject.Type.ParentFolderNameProperty.Equals(obj).

See Also

TrackedObject.Type.ParentFolderNameProperty Class | StarTeam Namespace


TrackedObject.Type.ParentFolderNameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TrackedObject.Type.ParentFolderNameProperty.

public override int GetHashCode();

Return Value

com.starteam.TrackedObject.Type.ParentFolderNameProperty.GetHashCode().

See Also

TrackedObject.Type.ParentFolderNameProperty Class | StarTeam Namespace


TrackedObject.Type.ParentFolderNameProperty.ToString Method

Delegate ToString() to com.starteam.TrackedObject.Type.ParentFolderNameProperty.

public override string ToString();

Return Value

com.starteam.TrackedObject.Type.ParentFolderNameProperty.ToString()

See Also

TrackedObject.Type.ParentFolderNameProperty Class | StarTeam Namespace


TrackedObject.Type.TransactionIDProperty Class

The property type of the Transaction ID property.

For a list of all members of this type, see TrackedObject.Type.TransactionIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
TrackedObject.Type.TransactionIDProperty

public class TrackedObject.Type.TransactionIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TrackedObject.Type.TransactionIDProperty Members | StarTeam Namespace


TrackedObject.Type.TransactionIDProperty Members

TrackedObject.Type.TransactionIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.TransactionIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.TransactionIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.TransactionIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.TransactionIDProperty Class | StarTeam Namespace


TrackedObject.Type.TransactionIDProperty Properties

The properties of the TrackedObject.Type.TransactionIDProperty class are listed below. For a complete list of TrackedObject.Type.TransactionIDProperty class members, see the TrackedObject.Type.TransactionIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TrackedObject.Type.TransactionIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TrackedObject.Type.TransactionIDProperty.NAME Property

public static String NAME {get;}

See Also

TrackedObject.Type.TransactionIDProperty Class | StarTeam Namespace


TrackedObject.Type.TransactionIDProperty Methods

The methods of the TrackedObject.Type.TransactionIDProperty class are listed below. For a complete list of TrackedObject.Type.TransactionIDProperty class members, see the TrackedObject.Type.TransactionIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TrackedObject.Type.TransactionIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.Type.TransactionIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TrackedObject.Type.TransactionIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TrackedObject.Type.TransactionIDProperty Class | StarTeam Namespace


TrackedObject.Type.TransactionIDProperty.Equals Method

Delegate Equals() to com.starteam.TrackedObject.Type.TransactionIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TrackedObject.Type.TransactionIDProperty.Equals(obj).

See Also

TrackedObject.Type.TransactionIDProperty Class | StarTeam Namespace


TrackedObject.Type.TransactionIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TrackedObject.Type.TransactionIDProperty.

public override int GetHashCode();

Return Value

com.starteam.TrackedObject.Type.TransactionIDProperty.GetHashCode().

See Also

TrackedObject.Type.TransactionIDProperty Class | StarTeam Namespace


TrackedObject.Type.TransactionIDProperty.ToString Method

Delegate ToString() to com.starteam.TrackedObject.Type.TransactionIDProperty.

public override string ToString();

Return Value

com.starteam.TrackedObject.Type.TransactionIDProperty.ToString()

See Also

TrackedObject.Type.TransactionIDProperty Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject Class

Tracked Object accessor for cached SDK Objects contained objects are obtained from the artifact cache

For a list of all members of this type, see TrackedObject.WebCacheTrackedObject Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
Label.WebCacheLabel
Principal.WebCachePrincipal
TaskDependency.WebCacheTaskDependency
VersionedObject.WebCacheVersionedObject
WorkRecord.WebCacheWorkRecord

public class TrackedObject.WebCacheTrackedObject : WebCacheLiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TrackedObject.WebCacheTrackedObject Members | StarTeam Namespace


TrackedObject.WebCacheTrackedObject Members

TrackedObject.WebCacheTrackedObject overview

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.TrackedObject.WebCacheTrackedObject.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.WebCacheTrackedObject.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.TrackedObject.WebCacheTrackedObject.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject Properties

The properties of the TrackedObject.WebCacheTrackedObject class are listed below. For a complete list of TrackedObject.WebCacheTrackedObject class members, see the TrackedObject.WebCacheTrackedObject Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.ModifiedBy Property

[read] The user who last modified this object.

public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.ModifiedTime Property

[read] The date and time at which this object was last modified.

public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.Name Property

new public virtual String Name {get;}

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject Methods

The methods of the TrackedObject.WebCacheTrackedObject class are listed below. For a complete list of TrackedObject.WebCacheTrackedObject class members, see the TrackedObject.WebCacheTrackedObject Members topic.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.TrackedObject.WebCacheTrackedObject.
GetHashCode | Delegate GetHashCode() to com.starteam.TrackedObject.WebCacheTrackedObject.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.TrackedObject.WebCacheTrackedObject.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject.Equals Method

Delegate Equals() to com.starteam.TrackedObject.WebCacheTrackedObject.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TrackedObject.WebCacheTrackedObject.Equals(obj).

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject.GetHashCode Method

Delegate GetHashCode() to com.starteam.TrackedObject.WebCacheTrackedObject.

public override int GetHashCode();

Return Value

com.starteam.TrackedObject.WebCacheTrackedObject.GetHashCode().

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace | TrackedObject.WebCacheTrackedObject.GetValue Overload List


TrackedObject.WebCacheTrackedObject.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace | TrackedObject.WebCacheTrackedObject.GetValue Overload List


TrackedObject.WebCacheTrackedObject.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace | WebCacheViewMemberCollection


TrackedObject.WebCacheTrackedObject.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

TrackedObject.WebCacheTrackedObject.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace | TrackedObject.WebCacheTrackedObject.SetValue Overload List


TrackedObject.WebCacheTrackedObject.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace | TrackedObject.WebCacheTrackedObject.SetValue Overload List


TrackedObject.WebCacheTrackedObject.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject.ToString Method

Delegate ToString() to com.starteam.TrackedObject.WebCacheTrackedObject.

public override string ToString();

Return Value

com.starteam.TrackedObject.WebCacheTrackedObject.ToString()

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace


TrackedObject.WebCacheTrackedObject.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

TrackedObject.WebCacheTrackedObject Class | StarTeam Namespace | WebCacheViewMemberCollection


Transaction Class

a Transaction is a logical unit of work on the StarTeam Server. It may comprise of a series of operations to add, modify or delete data. If these operations are executed in a transaction, they are committed together, i.e. if one of them fails, then all of them are rolled back.

For a list of all members of this type, see Transaction Members.

System.Object
Transaction

public class Transaction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Transaction Members | StarTeam Namespace


Transaction Members

Transaction overview

Public Instance Constructors

Transaction Constructor Start a Transaction on the specified server

Public Instance Properties

ID | [read] the Transaction ID assigned by the server if this Transaction has been committed or -1 if this Transaction has not yet begun
Server | [read] the Server on which this Transaction is running or has been run
Time | [read] the DateTime at which this Transaction was committed or null if the Transaction has not yet been committed
User | [read] the StarTeam user who committed this transaction or null if the Transaction has not yet been committed

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Transaction.
Execute | Overloaded. Commit the entire set of view members defined by this transaction to the StarTeam repository. All operations are performed in a transaction, i.e. either everything succeeds or everything fails. If the transaction fails, a server exception is thrown back to the caller.
GetHashCode | Delegate GetHashCode() to com.starteam.Transaction.
GetType (inherited from Object) | Gets the Type of the current instance.
Move | Set up an Item to be moved to the specified destination
Remove | Set up a ViewMeber to be removed
Save | Set up a ViewMember to be saved (created or updated)
ToString | Delegate ToString() to com.starteam.Transaction.

See Also

Transaction Class | StarTeam Namespace


Transaction Constructor

Start a Transaction on the specified server

public Transaction(
Server s
);

Parameters

s
the server of interest

See Also

Transaction Class | StarTeam Namespace


Transaction Properties

The properties of the Transaction class are listed below. For a complete list of Transaction class members, see the Transaction Members topic.

Public Instance Properties

ID | [read] the Transaction ID assigned by the server if this Transaction has been committed or -1 if this Transaction has not yet begun
Server | [read] the Server on which this Transaction is running or has been run
Time | [read] the DateTime at which this Transaction was committed or null if the Transaction has not yet been committed
User | [read] the StarTeam user who committed this transaction or null if the Transaction has not yet been committed

See Also

Transaction Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Transaction.ID Property

[read] the Transaction ID assigned by the server if this Transaction has been committed or -1 if this Transaction has not yet begun

public virtual Int32 ID {get;}

Property Value

the Transaction ID assigned by the server if this Transaction has been committed or -1 if this Transaction has not yet begun

See Also

Transaction Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Transaction.Server Property

[read] the Server on which this Transaction is running or has been run

public virtual Server Server {get;}

Property Value

the Server on which this Transaction is running or has been run

See Also

Transaction Class | StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

Transaction.Time Property

[read] the DateTime at which this Transaction was committed or null if the Transaction has not yet been committed

public virtual DateTime Time {get;}

Property Value

the DateTime at which this Transaction was committed or null if the Transaction has not yet been committed

See Also

Transaction Class | StarTeam Namespace


User Property

Borland StarTeam SDK for .NET

Transaction.User Property

[read] the StarTeam user who committed this transaction or null if the Transaction has not yet been committed

public virtual User User {get;}

Property Value

the StarTeam user who committed this transaction or null if the Transaction has not yet been committed

See Also

Transaction Class | StarTeam Namespace


Transaction Methods

The methods of the Transaction class are listed below. For a complete list of Transaction class members, see the Transaction Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Transaction.
Execute | Overloaded. Commit the entire set of view members defined by this transaction to the StarTeam repository. All operations are performed in a transaction, i.e. either everything succeeds or everything fails. If the transaction fails, a server exception is thrown back to the caller.
GetHashCode | Delegate GetHashCode() to com.starteam.Transaction.
GetType (inherited from Object) | Gets the Type of the current instance.
Move | Set up an Item to be moved to the specified destination
Remove | Set up a ViewMeber to be removed
Save | Set up a ViewMember to be saved (created or updated)
ToString | Delegate ToString() to com.starteam.Transaction.

See Also

Transaction Class | StarTeam Namespace


Transaction.Equals Method

Delegate Equals() to com.starteam.Transaction.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Transaction.Equals(obj).

See Also

Transaction Class | StarTeam Namespace


Execute Method

Borland StarTeam SDK for .NET

Transaction.Execute Method

Commit the entire set of view members defined by this transaction to the StarTeam repository. All operations are performed in a transaction, i.e. either everything succeeds or everything fails. If the transaction fails, a server exception is thrown back to the caller.

Overload List

Commit the entire set of view members defined by this transaction to the StarTeam repository. All operations are performed in a transaction, i.e. either everything succeeds or everything fails. If the transaction fails, a server exception is thrown back to the caller.

public virtual void Execute();

Commit all the changes to the repository This is an atomic operation, executed in a transaction, and running in the context of a ConnectionPool

public virtual void Execute(ConnectionPool,User);

See Also

Transaction Class | StarTeam Namespace


Transaction.Execute Method ()

Commit the entire set of view members defined by this transaction to the StarTeam repository. All operations are performed in a transaction, i.e. either everything succeeds or everything fails. If the transaction fails, a server exception is thrown back to the caller.

public virtual void Execute();

Return Value

on success, the view members that have been operated on in the transaction have their internal caches updated to reflect their new states. specifically, new view members mutate into StarTeam artifacts with positive IDs, and all view member caches are marked clean. removed view members will be marked deleted

See Also

Transaction Class | StarTeam Namespace | Transaction.Execute Overload List


Transaction.Execute Method (ConnectionPool, User)

Commit all the changes to the repository This is an atomic operation, executed in a transaction, and running in the context of a ConnectionPool

public virtual void Execute(
ConnectionPool cp,
User u
);

Parameters

cp
the ConnectionPool used to execute the transaction
u
the user to impersonate

See Also

Transaction Class | StarTeam Namespace | Transaction.Execute Overload List | Transaction


Transaction.GetHashCode Method

Delegate GetHashCode() to com.starteam.Transaction.

public override int GetHashCode();

Return Value

com.starteam.Transaction.GetHashCode().

See Also

Transaction Class | StarTeam Namespace


Transaction.Move Method

Set up an Item to be moved to the specified destination

public virtual void Move(
Item itm,
Folder destination
);

Parameters

itm
the item to move
destination
the destination folder

See Also

Transaction Class | StarTeam Namespace | execute


Transaction.Remove Method

Set up a ViewMeber to be removed

public virtual void Remove(
ViewMember vm
);

Parameters

vm
the view member to be removed

See Also

Transaction Class | StarTeam Namespace | execute


Transaction.Save Method

Set up a ViewMember to be saved (created or updated)

public virtual void Save(
ViewMember vm
);

Parameters

vm
the view member to save

See Also

Transaction Class | StarTeam Namespace | execute


Transaction.ToString Method

Delegate ToString() to com.starteam.Transaction.

public override string ToString();

Return Value

com.starteam.Transaction.ToString()

See Also

Transaction Class | StarTeam Namespace


Transaction.WebCacheTransaction Class

Transaction accessor for cached SDK Transactions contained objects are obtained from the artifact cache

For a list of all members of this type, see Transaction.WebCacheTransaction Members.

System.Object
Transaction.WebCacheTransaction

public class Transaction.WebCacheTransaction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Transaction.WebCacheTransaction Members | StarTeam Namespace


Transaction.WebCacheTransaction Members

Transaction.WebCacheTransaction overview

Public Instance Properties

ID | [read] the Transaction ID assigned by the server if this Transaction has been committed or -1 if this Transaction has not yet begun
Time | [read] the DateTime at which this Transaction was committed or null if the Transaction has not yet been committed
User | [read] the StarTeam user who committed this transaction or null if the Transaction has not yet been committed

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Transaction.WebCacheTransaction.
GetHashCode | Delegate GetHashCode() to com.starteam.Transaction.WebCacheTransaction.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Transaction.WebCacheTransaction.

See Also

Transaction.WebCacheTransaction Class | StarTeam Namespace


Transaction.WebCacheTransaction Properties

The properties of the Transaction.WebCacheTransaction class are listed below. For a complete list of Transaction.WebCacheTransaction class members, see the Transaction.WebCacheTransaction Members topic.

Public Instance Properties

ID | [read] the Transaction ID assigned by the server if this Transaction has been committed or -1 if this Transaction has not yet begun
Time | [read] the DateTime at which this Transaction was committed or null if the Transaction has not yet been committed
User | [read] the StarTeam user who committed this transaction or null if the Transaction has not yet been committed

See Also

Transaction.WebCacheTransaction Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Transaction.WebCacheTransaction.ID Property

[read] the Transaction ID assigned by the server if this Transaction has been committed or -1 if this Transaction has not yet begun

public virtual Int32 ID {get;}

Property Value

the Transaction ID assigned by the server if this Transaction has been committed or -1 if this Transaction has not yet begun

See Also

Transaction.WebCacheTransaction Class | StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

Transaction.WebCacheTransaction.Time Property

[read] the DateTime at which this Transaction was committed or null if the Transaction has not yet been committed

public virtual DateTime Time {get;}

Property Value

the DateTime at which this Transaction was committed or null if the Transaction has not yet been committed

See Also

Transaction.WebCacheTransaction Class | StarTeam Namespace


User Property

Borland StarTeam SDK for .NET

Transaction.WebCacheTransaction.User Property

[read] the StarTeam user who committed this transaction or null if the Transaction has not yet been committed

public virtual User.WebCacheUser User {get;}

Property Value

the StarTeam user who committed this transaction or null if the Transaction has not yet been committed

See Also

Transaction.WebCacheTransaction Class | StarTeam Namespace


Transaction.WebCacheTransaction Methods

The methods of the Transaction.WebCacheTransaction class are listed below. For a complete list of Transaction.WebCacheTransaction class members, see the Transaction.WebCacheTransaction Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Transaction.WebCacheTransaction.
GetHashCode | Delegate GetHashCode() to com.starteam.Transaction.WebCacheTransaction.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Transaction.WebCacheTransaction.

See Also

Transaction.WebCacheTransaction Class | StarTeam Namespace


Transaction.WebCacheTransaction.Equals Method

Delegate Equals() to com.starteam.Transaction.WebCacheTransaction.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Transaction.WebCacheTransaction.Equals(obj).

See Also

Transaction.WebCacheTransaction Class | StarTeam Namespace


Transaction.WebCacheTransaction.GetHashCode Method

Delegate GetHashCode() to com.starteam.Transaction.WebCacheTransaction.

public override int GetHashCode();

Return Value

com.starteam.Transaction.WebCacheTransaction.GetHashCode().

See Also

Transaction.WebCacheTransaction Class | StarTeam Namespace


Transaction.WebCacheTransaction.ToString Method

Delegate ToString() to com.starteam.Transaction.WebCacheTransaction.

public override string ToString();

Return Value

com.starteam.Transaction.WebCacheTransaction.ToString()

See Also

Transaction.WebCacheTransaction Class | StarTeam Namespace


Translations Class

The Translations class defines the possible localized translations of a particular resource. There is the notion of a default translation which should be used when no translation exists for a particular language. In addition to the default there may be any number of specific localizations defined on a per-locale basis.

For a list of all members of this type, see Translations Members.

System.Object
Translations

public class Translations

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Translations Members | StarTeam Namespace


Translations Members

Translations overview

Public Static Properties

FALSE
NO
OFF
ON
TRUE
YES

Public Static Methods

ParseLocale |
ToString | Overloaded.

Public Instance Constructors

Translations Overloaded. Initializes a new instance of the Translations class.

Public Instance Properties

DebugString | [read] a string representation of the Locale, useful for debugging
Default | [read/write]
LocaleNames | [read] the locale names for which a translation exists.
Locales |

Public Instance Methods

ClosestDefined |
Copy | Makes a copy of the specified translation
Equals | Delegate Equals() to com.starteam.Translations.
GetHashCode | Delegate GetHashCode() to com.starteam.Translations.
GetTranslation | Overloaded. Return the translation for the specified locale.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | compares two translations
RemoveLocale | Overloaded. Remove this the translation for the specified locale.
SetTranslation | Overloaded. Create or modify an existing translation.
ToString | Overloaded. Delegate ToString() to com.starteam.Translations.
Translate | Overloaded. Returns the most appropriate translation for this resource for the specified locale.

See Also

Translations Class | StarTeam Namespace


Translations Constructor

Create a new Translations object with only a default set to the empty string.

Overload List

Create a new Translations object with only a default set to the empty string.

public Translations();

Create a new Translations object with the default set to the specified string.

public Translations(String);

See Also

Translations Class | StarTeam Namespace


Translations Constructor ()

Create a new Translations object with only a default set to the empty string.

public Translations();

See Also

Translations Class | StarTeam Namespace | Translations Constructor Overload List


Translations Constructor (String)

Create a new Translations object with the default set to the specified string.

public Translations(
String defaultValue
);

Parameters

defaultValue
the default display name. May not be null.

See Also

Translations Class | StarTeam Namespace | Translations Constructor Overload List


Translations Properties

The properties of the Translations class are listed below. For a complete list of Translations class members, see the Translations Members topic.

Public Static Properties

FALSE
NO
OFF
ON
TRUE
YES

Public Instance Properties

DebugString | [read] a string representation of the Locale, useful for debugging
Default | [read/write]
LocaleNames | [read] the locale names for which a translation exists.
Locales |

See Also

Translations Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Translations.DebugString Property

[read] a string representation of the Locale, useful for debugging

public virtual String DebugString {get;}

Property Value

a string representation of the Locale, useful for debugging

See Also

Translations Class | StarTeam Namespace


Default Property

Borland StarTeam SDK for .NET

Translations.Default Property

[read/write]

public virtual String Default {get; set;}

See Also

Translations Class | StarTeam Namespace


FALSE Property

Borland StarTeam SDK for .NET

Translations.FALSE Property

public static Translations FALSE {get;}

Property Value

Known translations of "false".

See Also

Translations Class | StarTeam Namespace


LocaleNames Property

Borland StarTeam SDK for .NET

Translations.LocaleNames Property

[read] the locale names for which a translation exists.

public virtual String[] LocaleNames {get;}

Property Value

the locale names for which a translation exists.

See Also

Translations Class | StarTeam Namespace


Locales Property

Borland StarTeam SDK for .NET

Translations.Locales Property

public virtual CultureInfo[] Locales {get;}

See Also

Translations Class | StarTeam Namespace


NO Property

Borland StarTeam SDK for .NET

Translations.NO Property

public static Translations NO {get;}

Property Value

Known translations of "no".

See Also

Translations Class | StarTeam Namespace


OFF Property

Borland StarTeam SDK for .NET

Translations.OFF Property

public static Translations OFF {get;}

Property Value

Known translations of "off".

See Also

Translations Class | StarTeam Namespace


ON Property

Borland StarTeam SDK for .NET

Translations.ON Property

public static Translations ON {get;}

Property Value

Known translations of "on".

See Also

Translations Class | StarTeam Namespace


TRUE Property

Borland StarTeam SDK for .NET

Translations.TRUE Property

public static Translations TRUE {get;}

Property Value

Known translations of "true".

See Also

Translations Class | StarTeam Namespace


YES Property

Borland StarTeam SDK for .NET

Translations.YES Property

public static Translations YES {get;}

Property Value

Known translations of "yes".

See Also

Translations Class | StarTeam Namespace


Translations Methods

The methods of the Translations class are listed below. For a complete list of Translations class members, see the Translations Members topic.

Public Static Methods

ParseLocale |
ToString | Overloaded.

Public Instance Methods

ClosestDefined |
Copy | Makes a copy of the specified translation
Equals | Delegate Equals() to com.starteam.Translations.
GetHashCode | Delegate GetHashCode() to com.starteam.Translations.
GetTranslation | Overloaded. Return the translation for the specified locale.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | compares two translations
RemoveLocale | Overloaded. Remove this the translation for the specified locale.
SetTranslation | Overloaded. Create or modify an existing translation.
ToString | Overloaded. Delegate ToString() to com.starteam.Translations.
Translate | Overloaded. Returns the most appropriate translation for this resource for the specified locale.

See Also

Translations Class | StarTeam Namespace


Translations.ClosestDefined Method

public virtual CultureInfo ClosestDefined(
CultureInfo locale
);

See Also

Translations Class | StarTeam Namespace


Translations.Copy Method

Makes a copy of the specified translation

public virtual Translations Copy();

Return Value

a copy of the given translation

See Also

Translations Class | StarTeam Namespace


Translations.Equals Method

Delegate Equals() to com.starteam.Translations.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Translations.Equals(obj).

See Also

Translations Class | StarTeam Namespace


Translations.GetHashCode Method

Delegate GetHashCode() to com.starteam.Translations.

public override int GetHashCode();

Return Value

com.starteam.Translations.GetHashCode().

See Also

Translations Class | StarTeam Namespace


GetTranslation Method

Borland StarTeam SDK for .NET

Translations.GetTranslation Method

Return the translation for the specified locale.

Overload List

Return the translation for the specified locale.

public virtual string GetTranslation(CultureInfo);

Return the translation for the specified locale.

public virtual string GetTranslation(String);

See Also

Translations Class | StarTeam Namespace


Translations.GetTranslation Method (CultureInfo)

Return the translation for the specified locale.

public virtual string GetTranslation(
CultureInfo locale
);

Parameters

locale
the locale of the desired translation. May not be null.

Return Value

returns the translation for the specified locale or null if none exists.

See Also

Translations Class | StarTeam Namespace | Translations.GetTranslation Overload List


Translations.GetTranslation Method (String)

Return the translation for the specified locale.

public virtual string GetTranslation(
String locale
);

Parameters

locale
the locale of the desired translation. May not be null.

Return Value

returns the translation for the specified locale or null if none exists.

See Also

Translations Class | StarTeam Namespace | Translations.GetTranslation Overload List


Translations.IsEqualTo Method

compares two translations

public virtual bool IsEqualTo(
Translations other
);

Parameters

other
the other translation

Return Value

true if the two translations are considered equal

See Also

Translations Class | StarTeam Namespace


Translations.ParseLocale Method

public static CultureInfo ParseLocale(
String pattern
);

See Also

Translations Class | StarTeam Namespace


RemoveLocale Method

Borland StarTeam SDK for .NET

Translations.RemoveLocale Method

Remove this the translation for the specified locale.

Overload List

Remove this the translation for the specified locale.

public virtual void RemoveLocale(CultureInfo);

Remove this the translation for the specified locale.

public virtual void RemoveLocale(String);

See Also

Translations Class | StarTeam Namespace


Translations.RemoveLocale Method (CultureInfo)

Remove this the translation for the specified locale.

public virtual void RemoveLocale(
CultureInfo locale
);

Parameters

locale
the locale to be removed

See Also

Translations Class | StarTeam Namespace | Translations.RemoveLocale Overload List


Translations.RemoveLocale Method (String)

Remove this the translation for the specified locale.

public virtual void RemoveLocale(
String locale
);

Parameters

locale
the locale to be removed

See Also

Translations Class | StarTeam Namespace | Translations.RemoveLocale Overload List


SetTranslation Method

Borland StarTeam SDK for .NET

Translations.SetTranslation Method

Create or modify an existing translation.

Overload List

Create or modify an existing translation.

public virtual string SetTranslation(CultureInfo,String);

Create or modify an existing translation.

public virtual string SetTranslation(String,String);

See Also

Translations Class | StarTeam Namespace


Translations.SetTranslation Method (CultureInfo, String)

Create or modify an existing translation.

public virtual string SetTranslation(
CultureInfo locale,
String value
);

Parameters

locale
the locale for the new translation
value
the locale specific translation

Return Value

the previous translation or null if there was none.

See Also

Translations Class | StarTeam Namespace | Translations.SetTranslation Overload List


Translations.SetTranslation Method (String, String)

Create or modify an existing translation.

public virtual string SetTranslation(
String locale,
String value
);

Parameters

locale
the locale for the new translation
value
the locale specific translation

Return Value

the previous translation or null if there was none.

See Also

Translations Class | StarTeam Namespace | Translations.SetTranslation Overload List


ToString Method

Borland StarTeam SDK for .NET

Translations.ToString Method

Delegate ToString() to com.starteam.Translations.

Overload List

Delegate ToString() to com.starteam.Translations.

public override string ToString();

public static string ToString(CultureInfo);

See Also

Translations Class | StarTeam Namespace


Translations.ToString Method ()

Delegate ToString() to com.starteam.Translations.

public override string ToString();

Return Value

com.starteam.Translations.ToString()

See Also

Translations Class | StarTeam Namespace | Translations.ToString Overload List


Translations.ToString Method (CultureInfo)

public static string ToString(
CultureInfo locale
);

See Also

Translations Class | StarTeam Namespace | Translations.ToString Overload List


Translate Method

Borland StarTeam SDK for .NET

Translations.Translate Method

Returns the most appropriate translation for this resource based on the default locale.

Overload List

Returns the most appropriate translation for this resource based on the default locale.

public virtual string Translate();

Returns the most appropriate translation for this resource for the specified locale.

public virtual string Translate(CultureInfo);

Returns the most appropriate translation for this resource for the specified locale.

public virtual string Translate(String);

See Also

Translations Class | StarTeam Namespace


Translations.Translate Method ()

Returns the most appropriate translation for this resource based on the default locale.

public virtual string Translate();

See Also

Translations Class | StarTeam Namespace | Translations.Translate Overload List


Translations.Translate Method (CultureInfo)

Returns the most appropriate translation for this resource for the specified locale.

public virtual string Translate(
CultureInfo locale
);

Parameters

locale
the locale of the desired translation. A null value will return the default translation.

See Also

Translations Class | StarTeam Namespace | Translations.Translate Overload List


Translations.Translate Method (String)

Returns the most appropriate translation for this resource for the specified locale.

public virtual string Translate(
String locale
);

Parameters

locale
the locale of the desired translation. A null value will return the default translation.

See Also

Translations Class | StarTeam Namespace | Translations.Translate Overload List


TreeItem Class

A type of item with children.

For a list of all members of this type, see TreeItem Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
TreeItem
Requirement
Story
Task
Test
Topic

public class TreeItem : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem Members | StarTeam Namespace


TreeItem Members

TreeItem overview

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
OrderProperty | [read] a DoubleProperty used for ordering tree item instances
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo | Overloaded.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

TreeItem Class | StarTeam Namespace


TreeItem Properties

The properties of the TreeItem class are listed below. For a complete list of TreeItem class members, see the TreeItem Members topic.

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent
AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Children | [read] The tree items that are children of this one.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
OrderProperty | [read] a DoubleProperty used for ordering tree item instances
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentID | [read] The ObjectID of this item's parent, or -1 if this is a root item.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

See Also

TreeItem Class | StarTeam Namespace


After Property

Borland StarTeam SDK for .NET

TreeItem.After Property

[write] place this tree item after prev this and prev must both be children of a common parent

public virtual TreeItem After {set;}

Property Value

place this tree item after prev this and prev must both be children of a common parent

See Also

TreeItem Class | StarTeam Namespace


Before Property

Borland StarTeam SDK for .NET

TreeItem.Before Property

[write] place this tree item before next this and next must both be children of a common parent

public virtual TreeItem Before {set;}

Property Value

place this tree item before next this and next must both be children of a common parent

See Also

TreeItem Class | StarTeam Namespace


Children Property

Borland StarTeam SDK for .NET

TreeItem.Children Property

[read] The tree items that are children of this one.

public virtual TreeItem[] Children {get;}

Property Value

The tree items that are children of this one.

See Also

TreeItem Class | StarTeam Namespace


IsLeaf Property

Borland StarTeam SDK for .NET

TreeItem.IsLeaf Property

[read] true if this tree item is a leaf

public virtual Boolean IsLeaf {get;}

Property Value

true if this tree item is a leaf

See Also

TreeItem Class | StarTeam Namespace


OrderProperty Property

Borland StarTeam SDK for .NET

TreeItem.OrderProperty Property

[read] a DoubleProperty used for ordering tree item instances

public virtual DoubleProperty OrderProperty {get;}

Property Value

a DoubleProperty used for ordering tree item instances

See Also

TreeItem Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

TreeItem.Parent Property

[read] the TreeItem which is the Parent of this instance, or NULL if this is a root

public virtual TreeItem Parent {get;}

Property Value

the TreeItem which is the Parent of this instance, or NULL if this is a root

See Also

TreeItem Class | StarTeam Namespace


ParentID Property

Borland StarTeam SDK for .NET

TreeItem.ParentID Property

[read] The ObjectID of this item's parent, or -1 if this is a root item.

public virtual Int32 ParentID {get;}

Property Value

The ObjectID of this item's parent, or -1 if this is a root item.

See Also

TreeItem Class | StarTeam Namespace


TreeItem Methods

The methods of the TreeItem class are listed below. For a complete list of TreeItem class members, see the TreeItem Members topic.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CreateChild | Creates a new child item.
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasChildren | Returns true if the TreeItem has at least one child.
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Overloaded.
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo | Overloaded.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBetween | place this tree item in between prev and next. this, prev, next must all be children of a common parent
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFirst | place this tree item at the head of the set of all children of its parent
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLast | place this tree item at the end of the set of all children of its parent
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

TreeItem Class | StarTeam Namespace


TreeItem.CreateChild Method

Creates a new child item.

public virtual TreeItem CreateChild();

Return Value

A new child item of the appropriate type. The item is not saved to the repository until update() is called.

See Also

TreeItem Class | StarTeam Namespace


TreeItem.HasChildren Method

Returns true if the TreeItem has at least one child.

public virtual bool HasChildren();

Return Value

True if at least one child exists, false if no children

See Also

TreeItem Class | StarTeam Namespace | isDisembodied


IsEqualTo Method

Borland StarTeam SDK for .NET

TreeItem.IsEqualTo Method

Overload List

Inherited from Item.

public virtual bool IsEqualTo(Item);

public virtual bool IsEqualTo(TreeItem);

Inherited from ViewMember.

public virtual bool IsEqualTo(ViewMember);

See Also

TreeItem Class | StarTeam Namespace


TreeItem.IsEqualTo Method (TreeItem)

public virtual bool IsEqualTo(
TreeItem item
);

See Also

TreeItem Class | StarTeam Namespace | TreeItem.IsEqualTo Overload List


MoveTo Method

Borland StarTeam SDK for .NET

TreeItem.MoveTo Method

Overload List

Inherited from Item.

public virtual void MoveTo(Folder);

Inherited from Item.

public virtual void MoveTo(Folder,ConnectionPool,User);

public virtual void MoveTo(TreeItem);

public virtual void MoveTo(TreeItem,ConnectionPool,User);

See Also

TreeItem Class | StarTeam Namespace


TreeItem.MoveTo Method (TreeItem)

public virtual void MoveTo(
TreeItem parent
);

See Also

TreeItem Class | StarTeam Namespace | TreeItem.MoveTo Overload List


TreeItem.MoveTo Method (TreeItem, ConnectionPool, User)

public virtual void MoveTo(
TreeItem parent,
ConnectionPool cp,
User u
);

See Also

TreeItem Class | StarTeam Namespace | TreeItem.MoveTo Overload List


TreeItem.SetBetween Method

place this tree item in between prev and next. this, prev, next must all be children of a common parent

public virtual void SetBetween(
TreeItem prev,
TreeItem next
);

Parameters

prev
the tree item to precede this one
next
the tree item to succeed this one

See Also

TreeItem Class | StarTeam Namespace


TreeItem.SetFirst Method

place this tree item at the head of the set of all children of its parent

public virtual void SetFirst();

See Also

TreeItem Class | StarTeam Namespace


TreeItem.SetLast Method

place this tree item at the end of the set of all children of its parent

public virtual void SetLast();

See Also

TreeItem Class | StarTeam Namespace


TreeItem.MoSCoW Class

The MoSCoW value for a compliant TreeItem Type

For a list of all members of this type, see TreeItem.MoSCoW Members.

System.Object
EnumeratedValue
TreeItem.MoSCoW

public class TreeItem.MoSCoW : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.MoSCoW Members | StarTeam Namespace


TreeItem.MoSCoW Members

TreeItem.MoSCoW overview

Public Static Properties

ALL
COULD_HAVE
MUST_HAVE
SHOULD_HAVE
WONT_HAVE

Public Static Methods

FromID | Gets the MoSCoW corresponding to the given ID.
FromValue | Gets the story value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.TreeItem.MoSCoW.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.MoSCoW.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.TreeItem.MoSCoW.

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


TreeItem.MoSCoW Properties

The properties of the TreeItem.MoSCoW class are listed below. For a complete list of TreeItem.MoSCoW class members, see the TreeItem.MoSCoW Members topic.

Public Static Properties

ALL
COULD_HAVE
MUST_HAVE
SHOULD_HAVE
WONT_HAVE

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] the ID of this Value value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

TreeItem.MoSCoW.ALL Property

public static MoSCoW[] ALL {get;}

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


COULD_HAVE Property

Borland StarTeam SDK for .NET

TreeItem.MoSCoW.COULD_HAVE Property

public static TreeItem.MoSCoW COULD_HAVE {get;}

Property Value

Could Have

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TreeItem.MoSCoW.ID Property

[read] the ID of this Value value.

public virtual Int32 ID {get;}

Property Value

the ID of this Value value.

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


MUST_HAVE Property

Borland StarTeam SDK for .NET

TreeItem.MoSCoW.MUST_HAVE Property

public static TreeItem.MoSCoW MUST_HAVE {get;}

Property Value

Must Have

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


SHOULD_HAVE Property

Borland StarTeam SDK for .NET

TreeItem.MoSCoW.SHOULD_HAVE Property

public static TreeItem.MoSCoW SHOULD_HAVE {get;}

Property Value

Should Have

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


WONT_HAVE Property

Borland StarTeam SDK for .NET

TreeItem.MoSCoW.WONT_HAVE Property

public static TreeItem.MoSCoW WONT_HAVE {get;}

Property Value

Could Have

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


TreeItem.MoSCoW Methods

The methods of the TreeItem.MoSCoW class are listed below. For a complete list of TreeItem.MoSCoW class members, see the TreeItem.MoSCoW Members topic.

Public Static Methods

FromID | Gets the MoSCoW corresponding to the given ID.
FromValue | Gets the story value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.TreeItem.MoSCoW.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.MoSCoW.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.TreeItem.MoSCoW.

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


TreeItem.MoSCoW.Equals Method

Delegate Equals() to com.starteam.TreeItem.MoSCoW.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.MoSCoW.Equals(obj).

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


TreeItem.MoSCoW.FromID Method

Gets the MoSCoW corresponding to the given ID.

public static MoSCoW FromID(
Int32 id
);

Parameters

id
A MoSCoW ID.

Return Value

the corresponding MoSCoW value, or null.

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


TreeItem.MoSCoW.FromValue Method

Gets the story value corresponding to the given EnumeratedValue.

public static MoSCoW FromValue(
EnumeratedValue value
);

Parameters

value
one of the EnumeratedValues of a StreamStateProperty.

Return Value

the corresponding StreamState value, or null.

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


TreeItem.MoSCoW.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.MoSCoW.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.MoSCoW.GetHashCode().

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


TreeItem.MoSCoW.ToString Method

Delegate ToString() to com.starteam.TreeItem.MoSCoW.

public override string ToString();

Return Value

com.starteam.TreeItem.MoSCoW.ToString()

See Also

TreeItem.MoSCoW Class | StarTeam Namespace


TreeItem.Type Class

The type of the TreeItem

For a list of all members of this type, see TreeItem.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
TreeItem.Type
Requirement.Type
Story.Type
Task.Type
Test.Type
Topic.Type

new public class TreeItem.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.Type Members | StarTeam Namespace


TreeItem.Type Members

TreeItem.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TreeItem.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TreeItem.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type Properties

The properties of the TreeItem.Type class are listed below. For a complete list of TreeItem.Type class members, see the TreeItem.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

TreeItem.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

TreeItem.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

TreeItem.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

TreeItem.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TreeItem.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

TreeItem.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

TreeItem.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

TreeItem.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

TreeItem.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

TreeItem.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

TreeItem.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

TreeItem.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

TreeItem.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

TreeItem.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TreeItem.Type.NAME Property

new public static String NAME {get;}

See Also

TreeItem.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

TreeItem.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

TreeItem.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

TreeItem.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

TreeItem.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type Methods

The methods of the TreeItem.Type class are listed below. For a complete list of TreeItem.Type class members, see the TreeItem.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TreeItem.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TreeItem.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type.Equals Method

Delegate Equals() to com.starteam.TreeItem.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.Type.Equals(obj).

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.Type.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.Type.GetHashCode().

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type.ToString Method

Delegate ToString() to com.starteam.TreeItem.Type.

public override string ToString();

Return Value

com.starteam.TreeItem.Type.ToString()

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

TreeItem.Type Class | StarTeam Namespace


TreeItem.Type.ExternalTestIDProperty Class

The property type of the ExternalTestID property

For a list of all members of this type, see TreeItem.Type.ExternalTestIDProperty Members.

System.Object
Property
VectorProperty
TextProperty
TreeItem.Type.ExternalTestIDProperty

public class TreeItem.Type.ExternalTestIDProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.Type.ExternalTestIDProperty Members | StarTeam Namespace


TreeItem.Type.ExternalTestIDProperty Members

TreeItem.Type.ExternalTestIDProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.ExternalTestIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.ExternalTestIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TreeItem.Type.ExternalTestIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.ExternalTestIDProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestIDProperty Properties

The properties of the TreeItem.Type.ExternalTestIDProperty class are listed below. For a complete list of TreeItem.Type.ExternalTestIDProperty class members, see the TreeItem.Type.ExternalTestIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TreeItem.Type.ExternalTestIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TreeItem.Type.ExternalTestIDProperty.NAME Property

public static String NAME {get;}

See Also

TreeItem.Type.ExternalTestIDProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestIDProperty Methods

The methods of the TreeItem.Type.ExternalTestIDProperty class are listed below. For a complete list of TreeItem.Type.ExternalTestIDProperty class members, see the TreeItem.Type.ExternalTestIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.ExternalTestIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.ExternalTestIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TreeItem.Type.ExternalTestIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.ExternalTestIDProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestIDProperty.Equals Method

Delegate Equals() to com.starteam.TreeItem.Type.ExternalTestIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.Type.ExternalTestIDProperty.Equals(obj).

See Also

TreeItem.Type.ExternalTestIDProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.Type.ExternalTestIDProperty.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.Type.ExternalTestIDProperty.GetHashCode().

See Also

TreeItem.Type.ExternalTestIDProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestIDProperty.ToString Method

Delegate ToString() to com.starteam.TreeItem.Type.ExternalTestIDProperty.

public override string ToString();

Return Value

com.starteam.TreeItem.Type.ExternalTestIDProperty.ToString()

See Also

TreeItem.Type.ExternalTestIDProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestProjectURLProperty Class

The property type of the ExternalTestProjectURL property

For a list of all members of this type, see TreeItem.Type.ExternalTestProjectURLProperty Members.

System.Object
Property
VectorProperty
TextProperty
TreeItem.Type.ExternalTestProjectURLProperty

public class TreeItem.Type.ExternalTestProjectURLProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.Type.ExternalTestProjectURLProperty Members | StarTeam Namespace


TreeItem.Type.ExternalTestProjectURLProperty Members

TreeItem.Type.ExternalTestProjectURLProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.ExternalTestProjectURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestProjectURLProperty Properties

The properties of the TreeItem.Type.ExternalTestProjectURLProperty class are listed below. For a complete list of TreeItem.Type.ExternalTestProjectURLProperty class members, see the TreeItem.Type.ExternalTestProjectURLProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TreeItem.Type.ExternalTestProjectURLProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TreeItem.Type.ExternalTestProjectURLProperty.NAME Property

public static String NAME {get;}

See Also

TreeItem.Type.ExternalTestProjectURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestProjectURLProperty Methods

The methods of the TreeItem.Type.ExternalTestProjectURLProperty class are listed below. For a complete list of TreeItem.Type.ExternalTestProjectURLProperty class members, see the TreeItem.Type.ExternalTestProjectURLProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.ExternalTestProjectURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestProjectURLProperty.Equals Method

Delegate Equals() to com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.Equals(obj).

See Also

TreeItem.Type.ExternalTestProjectURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestProjectURLProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.GetHashCode().

See Also

TreeItem.Type.ExternalTestProjectURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestProjectURLProperty.ToString Method

Delegate ToString() to com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.

public override string ToString();

Return Value

com.starteam.TreeItem.Type.ExternalTestProjectURLProperty.ToString()

See Also

TreeItem.Type.ExternalTestProjectURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestURLProperty Class

The property type of the ExternalTestURL property

For a list of all members of this type, see TreeItem.Type.ExternalTestURLProperty Members.

System.Object
Property
VectorProperty
TextProperty
TreeItem.Type.ExternalTestURLProperty

public class TreeItem.Type.ExternalTestURLProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.Type.ExternalTestURLProperty Members | StarTeam Namespace


TreeItem.Type.ExternalTestURLProperty Members

TreeItem.Type.ExternalTestURLProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.ExternalTestURLProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.ExternalTestURLProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TreeItem.Type.ExternalTestURLProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.ExternalTestURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestURLProperty Properties

The properties of the TreeItem.Type.ExternalTestURLProperty class are listed below. For a complete list of TreeItem.Type.ExternalTestURLProperty class members, see the TreeItem.Type.ExternalTestURLProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TreeItem.Type.ExternalTestURLProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TreeItem.Type.ExternalTestURLProperty.NAME Property

public static String NAME {get;}

See Also

TreeItem.Type.ExternalTestURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestURLProperty Methods

The methods of the TreeItem.Type.ExternalTestURLProperty class are listed below. For a complete list of TreeItem.Type.ExternalTestURLProperty class members, see the TreeItem.Type.ExternalTestURLProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.ExternalTestURLProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.ExternalTestURLProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TreeItem.Type.ExternalTestURLProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.ExternalTestURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestURLProperty.Equals Method

Delegate Equals() to com.starteam.TreeItem.Type.ExternalTestURLProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.Type.ExternalTestURLProperty.Equals(obj).

See Also

TreeItem.Type.ExternalTestURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestURLProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.Type.ExternalTestURLProperty.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.Type.ExternalTestURLProperty.GetHashCode().

See Also

TreeItem.Type.ExternalTestURLProperty Class | StarTeam Namespace


TreeItem.Type.ExternalTestURLProperty.ToString Method

Delegate ToString() to com.starteam.TreeItem.Type.ExternalTestURLProperty.

public override string ToString();

Return Value

com.starteam.TreeItem.Type.ExternalTestURLProperty.ToString()

See Also

TreeItem.Type.ExternalTestURLProperty Class | StarTeam Namespace


TreeItem.Type.IsLeafProperty Class

The property type of the IsLeaf property

For a list of all members of this type, see TreeItem.Type.IsLeafProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
TreeItem.Type.IsLeafProperty

public class TreeItem.Type.IsLeafProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.Type.IsLeafProperty Members | StarTeam Namespace


TreeItem.Type.IsLeafProperty Members

TreeItem.Type.IsLeafProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TreeItem.Type.IsLeafProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.IsLeafProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TreeItem.Type.IsLeafProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.IsLeafProperty Class | StarTeam Namespace


TreeItem.Type.IsLeafProperty Properties

The properties of the TreeItem.Type.IsLeafProperty class are listed below. For a complete list of TreeItem.Type.IsLeafProperty class members, see the TreeItem.Type.IsLeafProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

TreeItem.Type.IsLeafProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TreeItem.Type.IsLeafProperty.NAME Property

public static String NAME {get;}

See Also

TreeItem.Type.IsLeafProperty Class | StarTeam Namespace


TreeItem.Type.IsLeafProperty Methods

The methods of the TreeItem.Type.IsLeafProperty class are listed below. For a complete list of TreeItem.Type.IsLeafProperty class members, see the TreeItem.Type.IsLeafProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TreeItem.Type.IsLeafProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.IsLeafProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TreeItem.Type.IsLeafProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.IsLeafProperty Class | StarTeam Namespace


TreeItem.Type.IsLeafProperty.Equals Method

Delegate Equals() to com.starteam.TreeItem.Type.IsLeafProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.Type.IsLeafProperty.Equals(obj).

See Also

TreeItem.Type.IsLeafProperty Class | StarTeam Namespace


TreeItem.Type.IsLeafProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.Type.IsLeafProperty.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.Type.IsLeafProperty.GetHashCode().

See Also

TreeItem.Type.IsLeafProperty Class | StarTeam Namespace


TreeItem.Type.IsLeafProperty.ToString Method

Delegate ToString() to com.starteam.TreeItem.Type.IsLeafProperty.

public override string ToString();

Return Value

com.starteam.TreeItem.Type.IsLeafProperty.ToString()

See Also

TreeItem.Type.IsLeafProperty Class | StarTeam Namespace


TreeItem.Type.MoSCoWProperty Class

The property type of the MoSCoW property.

For a list of all members of this type, see TreeItem.Type.MoSCoWProperty Members.

System.Object
Property
EnumeratedProperty
TreeItem.Type.MoSCoWProperty

public class TreeItem.Type.MoSCoWProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.Type.MoSCoWProperty Members | StarTeam Namespace


TreeItem.Type.MoSCoWProperty Members

TreeItem.Type.MoSCoWProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TreeItem.Type.MoSCoWProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.MoSCoWProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TreeItem.Type.MoSCoWProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.MoSCoWProperty Class | StarTeam Namespace


TreeItem.Type.MoSCoWProperty Properties

The properties of the TreeItem.Type.MoSCoWProperty class are listed below. For a complete list of TreeItem.Type.MoSCoWProperty class members, see the TreeItem.Type.MoSCoWProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

TreeItem.Type.MoSCoWProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TreeItem.Type.MoSCoWProperty.NAME Property

public static String NAME {get;}

See Also

TreeItem.Type.MoSCoWProperty Class | StarTeam Namespace


TreeItem.Type.MoSCoWProperty Methods

The methods of the TreeItem.Type.MoSCoWProperty class are listed below. For a complete list of TreeItem.Type.MoSCoWProperty class members, see the TreeItem.Type.MoSCoWProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TreeItem.Type.MoSCoWProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.MoSCoWProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TreeItem.Type.MoSCoWProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.MoSCoWProperty Class | StarTeam Namespace


TreeItem.Type.MoSCoWProperty.Equals Method

Delegate Equals() to com.starteam.TreeItem.Type.MoSCoWProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.Type.MoSCoWProperty.Equals(obj).

See Also

TreeItem.Type.MoSCoWProperty Class | StarTeam Namespace


TreeItem.Type.MoSCoWProperty.FromValue Method

public virtual EnumeratedValue FromValue(
TreeItem.MoSCoW value
);

See Also

TreeItem.Type.MoSCoWProperty Class | StarTeam Namespace


TreeItem.Type.MoSCoWProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.Type.MoSCoWProperty.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.Type.MoSCoWProperty.GetHashCode().

See Also

TreeItem.Type.MoSCoWProperty Class | StarTeam Namespace


TreeItem.Type.MoSCoWProperty.ToString Method

Delegate ToString() to com.starteam.TreeItem.Type.MoSCoWProperty.

public override string ToString();

Return Value

com.starteam.TreeItem.Type.MoSCoWProperty.ToString()

See Also

TreeItem.Type.MoSCoWProperty Class | StarTeam Namespace


TreeItem.Type.ParentIDProperty Class

The property type of the Parent ID property.

For a list of all members of this type, see TreeItem.Type.ParentIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
TreeItem.Type.ParentIDProperty

public class TreeItem.Type.ParentIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.Type.ParentIDProperty Members | StarTeam Namespace


TreeItem.Type.ParentIDProperty Members

TreeItem.Type.ParentIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.ParentIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.ParentIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TreeItem.Type.ParentIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.ParentIDProperty Class | StarTeam Namespace


TreeItem.Type.ParentIDProperty Properties

The properties of the TreeItem.Type.ParentIDProperty class are listed below. For a complete list of TreeItem.Type.ParentIDProperty class members, see the TreeItem.Type.ParentIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TreeItem.Type.ParentIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TreeItem.Type.ParentIDProperty.NAME Property

public static String NAME {get;}

See Also

TreeItem.Type.ParentIDProperty Class | StarTeam Namespace


TreeItem.Type.ParentIDProperty Methods

The methods of the TreeItem.Type.ParentIDProperty class are listed below. For a complete list of TreeItem.Type.ParentIDProperty class members, see the TreeItem.Type.ParentIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.ParentIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.ParentIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TreeItem.Type.ParentIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.ParentIDProperty Class | StarTeam Namespace


TreeItem.Type.ParentIDProperty.Equals Method

Delegate Equals() to com.starteam.TreeItem.Type.ParentIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.Type.ParentIDProperty.Equals(obj).

See Also

TreeItem.Type.ParentIDProperty Class | StarTeam Namespace


TreeItem.Type.ParentIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.Type.ParentIDProperty.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.Type.ParentIDProperty.GetHashCode().

See Also

TreeItem.Type.ParentIDProperty Class | StarTeam Namespace


TreeItem.Type.ParentIDProperty.ToString Method

Delegate ToString() to com.starteam.TreeItem.Type.ParentIDProperty.

public override string ToString();

Return Value

com.starteam.TreeItem.Type.ParentIDProperty.ToString()

See Also

TreeItem.Type.ParentIDProperty Class | StarTeam Namespace


TreeItem.Type.RichDescriptionProperty Class

The property type of the RichDescription property.

For a list of all members of this type, see TreeItem.Type.RichDescriptionProperty Members.

System.Object
Property
ContentProperty
TreeItem.Type.RichDescriptionProperty

public class TreeItem.Type.RichDescriptionProperty : ContentProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.Type.RichDescriptionProperty Members | StarTeam Namespace


TreeItem.Type.RichDescriptionProperty Members

TreeItem.Type.RichDescriptionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.RichDescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.RichDescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.TreeItem.Type.RichDescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.RichDescriptionProperty Class | StarTeam Namespace


TreeItem.Type.RichDescriptionProperty Properties

The properties of the TreeItem.Type.RichDescriptionProperty class are listed below. For a complete list of TreeItem.Type.RichDescriptionProperty class members, see the TreeItem.Type.RichDescriptionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TreeItem.Type.RichDescriptionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TreeItem.Type.RichDescriptionProperty.NAME Property

public static String NAME {get;}

See Also

TreeItem.Type.RichDescriptionProperty Class | StarTeam Namespace


TreeItem.Type.RichDescriptionProperty Methods

The methods of the TreeItem.Type.RichDescriptionProperty class are listed below. For a complete list of TreeItem.Type.RichDescriptionProperty class members, see the TreeItem.Type.RichDescriptionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TreeItem.Type.RichDescriptionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.RichDescriptionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.TreeItem.Type.RichDescriptionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TreeItem.Type.RichDescriptionProperty Class | StarTeam Namespace


TreeItem.Type.RichDescriptionProperty.Equals Method

Delegate Equals() to com.starteam.TreeItem.Type.RichDescriptionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.Type.RichDescriptionProperty.Equals(obj).

See Also

TreeItem.Type.RichDescriptionProperty Class | StarTeam Namespace


TreeItem.Type.RichDescriptionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.Type.RichDescriptionProperty.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.Type.RichDescriptionProperty.GetHashCode().

See Also

TreeItem.Type.RichDescriptionProperty Class | StarTeam Namespace


TreeItem.Type.RichDescriptionProperty.ToString Method

Delegate ToString() to com.starteam.TreeItem.Type.RichDescriptionProperty.

public override string ToString();

Return Value

com.starteam.TreeItem.Type.RichDescriptionProperty.ToString()

See Also

TreeItem.Type.RichDescriptionProperty Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType Class

Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see TreeItem.Type.WebCacheTreeItemType Members.

System.Object
Type.WebCacheType
ViewMember.Type.WebCacheViewMemberType
Item.Type.WebCacheItemType
TreeItem.Type.WebCacheTreeItemType

public class TreeItem.Type.WebCacheTreeItemType : WebCacheItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.Type.WebCacheTreeItemType Members | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType Members

TreeItem.Type.WebCacheTreeItemType overview

Public Static Methods

Create
FromXml

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog | [read] the Catalog for this type
ComponentGUID | [read] the Component GUID of this type
Context | [read] the context of this object.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [read/write] a display name for this type.
DisplayNameTranslations | [read]
Filters | [read] the set of filters
ID | [read] the class ID for this type.
Identifier | [read] the integer identifier value of the identifier property
IdentifierProperty | [read] the identifier property for this item type
IsEnabled | [read/write] true if this type is enabled
IsNew | [read] true if this is a new type
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name |
NameProperty |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries | [read] the set of queries
SecondaryDescriptor | [read] The secondary descriptor of this type, or null if this type has no secondary descriptor.
Server | [read] the Server for this cached object
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TreeItem.Type.WebCacheTreeItemType.
FindFilter | Overloaded. find a Filter by ID, visible in the user context
FindProperty | Overloaded. Find and return a property by int iD
FindQuery | Overloaded. find a Query by ID, visible in the user context
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.WebCacheTreeItemType.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
NewBooleanProperty | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty | Creates a new DateProperty
NewDateTimeProperty | Creates a new DateTimeProperty
NewDoubleProperty | Creates a new DoubleProperty
NewEnumeratedProperty | Create a new Enumerated Property
NewGroupArrayProperty | Creates a property on the server.
NewGroupProperty | Creates a property on the server.
NewIntegerProperty | Creates a new IntegerProperty
NewLongIntegerProperty | Creates a new LongIntegerProperty. The new property is dirty; to save changes, you must call Property.update().
NewMapProperty | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewTextProperty | Creates a new TextProperty
NewTimeSpanProperty | Creates a new TimeSpanProperty
NewUserArrayProperty | Creates a property on the server.
NewUserProperty | Creates a property on the server.
NewWebCacheFilterEventSource (inherited from WebCacheType) |
NewWebCacheQueryEventSource (inherited from WebCacheType) |
Refresh | replace the (possibly out-dated) instance of the contained type with an appropriate read only instance from the ArtifactCache
SetRights |
ToString | Delegate ToString() to com.starteam.TreeItem.Type.WebCacheTreeItemType.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components
Update | Save this dirty Type to the Repository Unlike the rest of the sdk objects, types are created from a single parameter, namely an XML string. This is an atomic operation, not executed in a transaction

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType Properties

The properties of the TreeItem.Type.WebCacheTreeItemType class are listed below. For a complete list of TreeItem.Type.WebCacheTreeItemType class members, see the TreeItem.Type.WebCacheTreeItemType Members topic.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog | [read] the Catalog for this type
ComponentGUID | [read] the Component GUID of this type
Context | [read] the context of this object.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [read/write] a display name for this type.
DisplayNameTranslations | [read]
Filters | [read] the set of filters
ID | [read] the class ID for this type.
Identifier | [read] the integer identifier value of the identifier property
IdentifierProperty | [read] the identifier property for this item type
IsEnabled | [read/write] true if this type is enabled
IsNew | [read] true if this is a new type
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name |
NameProperty |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries | [read] the set of queries
SecondaryDescriptor | [read] The secondary descriptor of this type, or null if this type has no secondary descriptor.
Server | [read] the Server for this cached object
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property.WebCacheProperty AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


Catalog Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.Catalog Property

[read] the Catalog for this type

new public virtual Catalog.WebCacheCatalog Catalog {get;}

Property Value

the Catalog for this type

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


ComponentGUID Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.ComponentGUID Property

[read] the Component GUID of this type

new public virtual GUID ComponentGUID {get;}

Property Value

the Component GUID of this type

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty.WebCacheTextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.DisplayName Property

[read/write] a display name for this type.

new public virtual String DisplayName {get; set;}

Property Value

a display name for this type.

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.DisplayNameTranslations Property

[read]

new public virtual Translations DisplayNameTranslations {get;}

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


Filters Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.Filters Property

[read] the set of filters

new public virtual WebCacheFilter[] Filters {get;}

Property Value

the set of filters

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.ID Property

[read] the class ID for this type.

new public virtual Int32 ID {get;}

Property Value

the class ID for this type.

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.Identifier Property

[read] the integer identifier value of the identifier property

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of the identifier property

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.Name Property

new public virtual String Name {get;}

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


PrimaryDescriptor Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.PrimaryDescriptor Property

[read] The primary descriptor of this type, or null if this type has no primary descriptor.

new public virtual Property.WebCacheProperty PrimaryDescriptor {get;}

Property Value

The primary descriptor of this type, or null if this type has no primary descriptor.

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property.WebCacheProperty PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.Properties Property

[read] an array of all properties belonging to this type.

new public virtual WebCacheProperty[] Properties {get;}

Property Value

an array of all properties belonging to this type.

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.PropertiesEx Property

[write]

new public virtual WebCacheProperty[] PropertiesEx {set;}

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


Queries Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.Queries Property

[read] the set of queries

new public virtual WebCacheQuery[] Queries {get;}

Property Value

the set of queries

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


SecondaryDescriptor Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.SecondaryDescriptor Property

[read] The secondary descriptor of this type, or null if this type has no secondary descriptor.

new public virtual Property.WebCacheProperty SecondaryDescriptor {get;}

Property Value

The secondary descriptor of this type, or null if this type has no secondary descriptor.

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty.WebCacheEnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property.WebCacheProperty SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty.WebCacheTextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType Methods

The methods of the TreeItem.Type.WebCacheTreeItemType class are listed below. For a complete list of TreeItem.Type.WebCacheTreeItemType class members, see the TreeItem.Type.WebCacheTreeItemType Members topic.

Public Static Methods

Create
FromXml

Public Instance Methods

Equals | Delegate Equals() to com.starteam.TreeItem.Type.WebCacheTreeItemType.
FindFilter | Overloaded. find a Filter by ID, visible in the user context
FindProperty | Overloaded. Find and return a property by int iD
FindQuery | Overloaded. find a Query by ID, visible in the user context
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.Type.WebCacheTreeItemType.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
NewBooleanProperty | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty | Creates a new DateProperty
NewDateTimeProperty | Creates a new DateTimeProperty
NewDoubleProperty | Creates a new DoubleProperty
NewEnumeratedProperty | Create a new Enumerated Property
NewGroupArrayProperty | Creates a property on the server.
NewGroupProperty | Creates a property on the server.
NewIntegerProperty | Creates a new IntegerProperty
NewLongIntegerProperty | Creates a new LongIntegerProperty. The new property is dirty; to save changes, you must call Property.update().
NewMapProperty | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewTextProperty | Creates a new TextProperty
NewTimeSpanProperty | Creates a new TimeSpanProperty
NewUserArrayProperty | Creates a property on the server.
NewUserProperty | Creates a property on the server.
NewWebCacheFilterEventSource (inherited from WebCacheType) |
NewWebCacheQueryEventSource (inherited from WebCacheType) |
Refresh | replace the (possibly out-dated) instance of the contained type with an appropriate read only instance from the ArtifactCache
SetRights |
ToString | Delegate ToString() to com.starteam.TreeItem.Type.WebCacheTreeItemType.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components
Update | Save this dirty Type to the Repository Unlike the rest of the sdk objects, types are created from a single parameter, namely an XML string. This is an atomic operation, not executed in a transaction

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.Create Method

new public static WebCacheItemType Create(
ArtifactCacheManager.Context cntxt,
String name
);

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.Equals Method

Delegate Equals() to com.starteam.TreeItem.Type.WebCacheTreeItemType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.Type.WebCacheTreeItemType.Equals(obj).

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


FindFilter Method

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.FindFilter Method

find a Filter by ID, visible in the user context

Overload List

find a Filter by ID, visible in the user context

new public virtual WebCacheFilter FindFilter(Int32);

find a Filter by name, visible in the user context

new public virtual WebCacheFilter FindFilter(String);

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.FindFilter Method (Int32)

find a Filter by ID, visible in the user context

new public virtual WebCacheFilter FindFilter(
Int32 filterID
);

Parameters

filterID
the ID

Return Value

a filter with the specified ID or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace | TreeItem.Type.WebCacheTreeItemType.FindFilter Overload List


TreeItem.Type.WebCacheTreeItemType.FindFilter Method (String)

find a Filter by name, visible in the user context

new public virtual WebCacheFilter FindFilter(
String filterName
);

Parameters

filterName
the name

Return Value

a filter with the specified name or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace | TreeItem.Type.WebCacheTreeItemType.FindFilter Overload List


FindProperty Method

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.FindProperty Method

Find and return a property by int iD

Overload List

Find and return a property by int iD

new public virtual WebCacheProperty FindProperty(Int32);

Find and return a property by name

new public virtual WebCacheProperty FindProperty(String);

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.FindProperty Method (Int32)

Find and return a property by int iD

new public virtual WebCacheProperty FindProperty(
Int32 propertyID
);

Parameters

propertyID
the integer ID of the property

Return Value

a property with the given ID or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace | TreeItem.Type.WebCacheTreeItemType.FindProperty Overload List


TreeItem.Type.WebCacheTreeItemType.FindProperty Method (String)

Find and return a property by name

new public virtual WebCacheProperty FindProperty(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

a property with the given name or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace | TreeItem.Type.WebCacheTreeItemType.FindProperty Overload List


FindQuery Method

Borland StarTeam SDK for .NET

TreeItem.Type.WebCacheTreeItemType.FindQuery Method

find a Query by ID, visible in the user context

Overload List

find a Query by ID, visible in the user context

new public virtual WebCacheQuery FindQuery(Int32);

find a Query by name, visible in the user context

new public virtual WebCacheQuery FindQuery(String);

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.FindQuery Method (Int32)

find a Query by ID, visible in the user context

new public virtual WebCacheQuery FindQuery(
Int32 queryID
);

Parameters

queryID
the ID

Return Value

a query with the specified ID or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace | TreeItem.Type.WebCacheTreeItemType.FindQuery Overload List


TreeItem.Type.WebCacheTreeItemType.FindQuery Method (String)

find a Query by name, visible in the user context

new public virtual WebCacheQuery FindQuery(
String queryName
);

Parameters

queryName
the name

Return Value

a query with the specified name or NULL

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace | TreeItem.Type.WebCacheTreeItemType.FindQuery Overload List


TreeItem.Type.WebCacheTreeItemType.FromXml Method

new public static WebCacheItemType FromXml(
ArtifactCacheManager.Context cntxt,
String xmlDefinition
);

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.Type.WebCacheTreeItemType.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.Type.WebCacheTreeItemType.GetHashCode().

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.GetRights Method

new public virtual WebCacheACE[] GetRights(
Type.WebCacheType typ
);

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewBooleanProperty Method

Create a new Boolean Property Assigns default display names such that 0=False and 1=True.

new public virtual WebCacheBooleanProperty NewBooleanProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new BooleanProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewContentProperty Method

Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().

new public virtual WebCacheContentProperty NewContentProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new ContentProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewDateProperty Method

Creates a new DateProperty

new public virtual WebCacheDateProperty NewDateProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DateProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewDateTimeProperty Method

Creates a new DateTimeProperty

new public virtual WebCacheDateTimeProperty NewDateTimeProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DateTimeProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewDoubleProperty Method

Creates a new DoubleProperty

new public virtual WebCacheDoubleProperty NewDoubleProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DoubleProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewEnumeratedProperty Method

Create a new Enumerated Property

new public virtual WebCacheEnumeratedProperty NewEnumeratedProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new EnumeratedProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewGroupArrayProperty Method

Creates a property on the server.

new public virtual WebCacheObjectArrayProperty NewGroupArrayProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewGroupProperty Method

Creates a property on the server.

new public virtual WebCacheObjectProperty NewGroupProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewIntegerProperty Method

Creates a new IntegerProperty

new public virtual WebCacheIntegerProperty NewIntegerProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new IntegerProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewLongIntegerProperty Method

Creates a new LongIntegerProperty. The new property is dirty; to save changes, you must call Property.update().

new public virtual WebCacheLongIntegerProperty NewLongIntegerProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new LongIntegerProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewMapProperty Method

Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema

new public virtual WebCacheMapProperty NewMapProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new MapProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewTextProperty Method

Creates a new TextProperty

new public virtual WebCacheTextProperty NewTextProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new TextProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewTimeSpanProperty Method

Creates a new TimeSpanProperty

new public virtual WebCacheTimeSpanProperty NewTimeSpanProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new TimeSpanProperty instance

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewUserArrayProperty Method

Creates a property on the server.

new public virtual WebCacheObjectArrayProperty NewUserArrayProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.NewUserProperty Method

Creates a property on the server.

new public virtual WebCacheObjectProperty NewUserProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.Refresh Method

replace the (possibly out-dated) instance of the contained type with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.SetRights Method

new public virtual void SetRights(
Type.WebCacheType typ,
WebCacheACE[] aces
);

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.ToString Method

Delegate ToString() to com.starteam.TreeItem.Type.WebCacheTreeItemType.

public override string ToString();

Return Value

com.starteam.TreeItem.Type.WebCacheTreeItemType.ToString()

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.Type.WebCacheTreeItemType.Update Method

Save this dirty Type to the Repository Unlike the rest of the sdk objects, types are created from a single parameter, namely an XML string. This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

TreeItem.Type.WebCacheTreeItemType Class | StarTeam Namespace


TreeItem.WebCacheTreeItem Class

TreeItem accessor for cached SDK Items contained objects are obtained from the artifact cache

For a list of all members of this type, see TreeItem.WebCacheTreeItem Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
TreeItem.WebCacheTreeItem
Requirement.WebCacheRequirement
Story.WebCacheStory
Task.WebCacheTask
Test.WebCacheTest
Topic.WebCacheTopic

public class TreeItem.WebCacheTreeItem : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TreeItem.WebCacheTreeItem Members | StarTeam Namespace


TreeItem.WebCacheTreeItem Members

TreeItem.WebCacheTreeItem overview

Public Static Methods

Create Overloaded.

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.TreeItem.WebCacheTreeItem.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.WebCacheTreeItem.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.TreeItem.WebCacheTreeItem.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem Properties

The properties of the TreeItem.WebCacheTreeItem class are listed below. For a complete list of TreeItem.WebCacheTreeItem class members, see the TreeItem.WebCacheTreeItem Members topic.

Public Instance Properties

After | [write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder
Attachments | [read/write] an array of attachments for this ViewMember
Before | [write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder
ChangePackages | [read] the Change Packages linked to this process item
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsLeaf | [read] true if this tree item is a leaf
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
Parent | [read] the TreeItem which is the Parent of this instance, or NULL if this is a root
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


After Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.After Property

[write] place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

public virtual TreeItem.WebCacheTreeItem After {set;}

Property Value

place this tree item after prev this and prev must both be children of a common parent tree item or must be root tree items in the same folder

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Before Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Before Property

[write] place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

public virtual TreeItem.WebCacheTreeItem Before {set;}

Property Value

place this tree item before next this and next must both be children of a common parent tree item or must be root tree items in the same folder

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IsLeaf Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IsLeaf Property

[read] true if this tree item is a leaf

public virtual Boolean IsLeaf {get;}

Property Value

true if this tree item is a leaf

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Name Property

new public virtual String Name {get;}

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Parent Property

[read] the TreeItem which is the Parent of this instance, or NULL if this is a root

public virtual TreeItem.WebCacheTreeItem Parent {get;}

Property Value

the TreeItem which is the Parent of this instance, or NULL if this is a root

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem Methods

The methods of the TreeItem.WebCacheTreeItem class are listed below. For a complete list of TreeItem.WebCacheTreeItem class members, see the TreeItem.WebCacheTreeItem Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.TreeItem.WebCacheTreeItem.
GetChildren |
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.TreeItem.WebCacheTreeItem.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasChildren | Returns true if the TreeItem has at least one child.
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetBetween |
SetFirst | place this tree item at the head of the set of all children of its parent treeitem or folder
SetLast | place this tree item at the end of the set of all children of its parent treeitem or folder
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.TreeItem.WebCacheTreeItem.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Create Method

Overload List

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

public static WebCacheTreeItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,TreeItem.Type.WebCacheTreeItemType);

public static WebCacheTreeItem Create(ArtifactCacheManager.Context,TreeItem.WebCacheTreeItem);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.Create Overload List


TreeItem.WebCacheTreeItem.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, TreeItem#Type#WebCacheTreeItemType)

public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
TreeItem.Type.WebCacheTreeItemType typ
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.Create Overload List


TreeItem.WebCacheTreeItem.Create Method (ArtifactCacheManager#Context, TreeItem#WebCacheTreeItem)

public static WebCacheTreeItem Create(
ArtifactCacheManager.Context cntxt,
TreeItem.WebCacheTreeItem parent
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.Create Overload List


TreeItem.WebCacheTreeItem.Equals Method

Delegate Equals() to com.starteam.TreeItem.WebCacheTreeItem.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TreeItem.WebCacheTreeItem.Equals(obj).

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.GetChildren Method

public virtual WebCacheTreeItem[] GetChildren(
Filter.WebCacheFilter fltr
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.GetHashCode Method

Delegate GetHashCode() to com.starteam.TreeItem.WebCacheTreeItem.

public override int GetHashCode();

Return Value

com.starteam.TreeItem.WebCacheTreeItem.GetHashCode().

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.GetValue Overload List


TreeItem.WebCacheTreeItem.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.GetValue Overload List


TreeItem.WebCacheTreeItem.HasChildren Method

Returns true if the TreeItem has at least one child.

public virtual bool HasChildren();

Return Value

True if at least one child exists, false if no children

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | isDisembodied


TreeItem.WebCacheTreeItem.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | WebCacheViewMemberCollection


TreeItem.WebCacheTreeItem.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.Lock Overload List | WebCacheViewMemberCollection


TreeItem.WebCacheTreeItem.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.Lock Overload List


TreeItem.WebCacheTreeItem.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | NAME


TreeItem.WebCacheTreeItem.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

public virtual void MoveTo(TreeItem.WebCacheTreeItem);

new public virtual void MoveTo(View.WebCacheView);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.MoveTo Overload List


TreeItem.WebCacheTreeItem.MoveTo Method (TreeItem#WebCacheTreeItem)

public virtual void MoveTo(
TreeItem.WebCacheTreeItem parent
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.MoveTo Overload List


TreeItem.WebCacheTreeItem.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.MoveTo Overload List


TreeItem.WebCacheTreeItem.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | isFloating | isPinned | unpin


TreeItem.WebCacheTreeItem.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | WebCacheViewMemberCollection


TreeItem.WebCacheTreeItem.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.SetBetween Method

public virtual void SetBetween(
TreeItem.WebCacheTreeItem prev,
TreeItem.WebCacheTreeItem next
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.SetFirst Method

place this tree item at the head of the set of all children of its parent treeitem or folder

public virtual void SetFirst();

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.SetLast Method

place this tree item at the end of the set of all children of its parent treeitem or folder

public virtual void SetLast();

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

TreeItem.WebCacheTreeItem.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.SetValue Overload List


TreeItem.WebCacheTreeItem.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | TreeItem.WebCacheTreeItem.SetValue Overload List


TreeItem.WebCacheTreeItem.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.ToString Method

Delegate ToString() to com.starteam.TreeItem.WebCacheTreeItem.

public override string ToString();

Return Value

com.starteam.TreeItem.WebCacheTreeItem.ToString()

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


TreeItem.WebCacheTreeItem.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | WebCacheViewMemberCollection


TreeItem.WebCacheTreeItem.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | isFloating | isPinned | pinTo


TreeItem.WebCacheTreeItem.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace | WebCacheViewMemberCollection


TreeItem.WebCacheTreeItem.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

TreeItem.WebCacheTreeItem Class | StarTeam Namespace


Type Class

Information describing certain StarTeam object types.

For a list of all members of this type, see Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type

public class Type : NamedCacheRef, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Type Members | StarTeam Namespace


Type Members

Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID | [read] the class ID for this type.
ComponentACL | [read/write] the access control list for this type. May return null.
ComponentGUID | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString | [read] a debug string for this type.
DisplayName | [read] a display name for this type.
DisplayNameTranslations | [read]
FilterACL | [read/write] the access control list for this type. May return null.
Filters | [read] an array of all Filters for this type.
ID | [read] the class ID for this type.
IsAttachmentContainer | [read] true if this type can have attachments.
IsBranchable | [read] true if this type is branchable.
IsComponentType | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted | [read]
IsMPXSupported | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired | [read] true if Filter or QueryManager information may be out of date.
Name | [read] the name of this type
ParentContainer | [read] null.
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties | [read] an array of all properties belonging to this type.
Queries | [read] an array of all Query for this type.
QueryACL | [read/write] the access control list for this type. May return null.
SecondaryDescriptor | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors | [read] the set of all secondary descriptors for this type
Server | [read] the Server object containing this Type.

Public Instance Methods

Copy | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard | discards local changes made to cached properties
DiscardFiltersAndQueries | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals (inherited from NamedCacheRef) | Delegate Equals() to com.starteam.NamedCacheRef.
GetFilter | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode (inherited from NamedCacheRef) | Delegate GetHashCode() to com.starteam.NamedCacheRef.
GetQuery | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions | Overloaded.
HasQuery | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty | Creates a new DateProperty
NewDateTimeProperty | Creates a new DateTimeProperty
NewDoubleProperty | Creates a new DoubleProperty
NewEnumeratedProperty | Create a new Enumerated Property
NewFilterEventSource |
NewIntegerProperty | Creates a new IntegerProperty
NewLongIntegerProperty | Creates a new LongIntegerProperty
NewMapProperty | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty |
NewObjectProperty |
NewOnOffProperty | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource |
NewTextProperty | Creates a new TextProperty
NewTimeSpanProperty | Creates a new TimeSpanProperty
NewTypeEventSource |
NewYesNoProperty | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString (inherited from NamedCacheRef) | Delegate ToString() to com.starteam.NamedCacheRef.

See Also

Type Class | StarTeam Namespace


Type Properties

The properties of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID | [read] the class ID for this type.
ComponentACL | [read/write] the access control list for this type. May return null.
ComponentGUID | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString | [read] a debug string for this type.
DisplayName | [read] a display name for this type.
DisplayNameTranslations | [read]
FilterACL | [read/write] the access control list for this type. May return null.
Filters | [read] an array of all Filters for this type.
ID | [read] the class ID for this type.
IsAttachmentContainer | [read] true if this type can have attachments.
IsBranchable | [read] true if this type is branchable.
IsComponentType | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted | [read]
IsMPXSupported | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired | [read] true if Filter or QueryManager information may be out of date.
Name | [read] the name of this type
ParentContainer | [read] null.
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties | [read] an array of all properties belonging to this type.
Queries | [read] an array of all Query for this type.
QueryACL | [read/write] the access control list for this type. May return null.
SecondaryDescriptor | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors | [read] the set of all secondary descriptors for this type
Server | [read] the Server object containing this Type.

See Also

Type Class | StarTeam Namespace


Catalog Property

Borland StarTeam SDK for .NET

Type.Catalog Property

[read] the catalog for this type or null if this Type does not have a Catalog

public virtual Catalog Catalog {get;}

Property Value

the catalog for this type or null if this Type does not have a Catalog

See Also

Type Class | StarTeam Namespace


ClassID Property

Borland StarTeam SDK for .NET

Type.ClassID Property

[read] the class ID for this type.

public virtual Int32 ClassID {get;}

Property Value

the class ID for this type.

See Also

Type Class | StarTeam Namespace


ComponentACL Property

Borland StarTeam SDK for .NET

Type.ComponentACL Property

[read/write] the access control list for this type. May return null.

public virtual ACE[] ComponentACL {get; set;}

Property Value

the access control list for this type. May return null.

See Also

Type Class | StarTeam Namespace


ComponentGUID Property

Borland StarTeam SDK for .NET

Type.ComponentGUID Property

[read] The server-defined component GUID, or null if this Type does not represent a component type.

public virtual GUID ComponentGUID {get;}

Property Value

The server-defined component GUID, or null if this Type does not represent a component type.

See Also

Type Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

Type.DebugString Property

[read] a debug string for this type.

public virtual String DebugString {get;}

Property Value

a debug string for this type.

See Also

Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Type.DisplayName Property

[read] a display name for this type.

public virtual String DisplayName {get;}

Property Value

a display name for this type.

See Also

Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Type.DisplayNameTranslations Property

[read]

public virtual Translations DisplayNameTranslations {get;}

See Also

Type Class | StarTeam Namespace


FilterACL Property

Borland StarTeam SDK for .NET

Type.FilterACL Property

[read/write] the access control list for this type. May return null.

public virtual ACE[] FilterACL {get; set;}

Property Value

the access control list for this type. May return null.

See Also

Type Class | StarTeam Namespace


Filters Property

Borland StarTeam SDK for .NET

Type.Filters Property

[read] an array of all Filters for this type.

public virtual Filter[] Filters {get;}

Property Value

an array of all Filters for this type.

See Also

Type Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Type.ID Property

[read] the class ID for this type.

public virtual Int32 ID {get;}

Property Value

the class ID for this type.

Implements

ISecurableContainer.ID

See Also

Type Class | StarTeam Namespace


IsAttachmentContainer Property

Borland StarTeam SDK for .NET

Type.IsAttachmentContainer Property

[read] true if this type can have attachments.

public virtual Boolean IsAttachmentContainer {get;}

Property Value

true if this type can have attachments.

See Also

Type Class | StarTeam Namespace


IsBranchable Property

Borland StarTeam SDK for .NET

Type.IsBranchable Property

[read] true if this type is branchable.

public virtual Boolean IsBranchable {get;}

Property Value

true if this type is branchable.

See Also

Type Class | StarTeam Namespace


IsComponentType Property

Borland StarTeam SDK for .NET

Type.IsComponentType Property

[read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).

public virtual Boolean IsComponentType {get;}

Property Value

true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).

See Also

Type Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

Type.IsDeleted Property

[read]

public virtual Boolean IsDeleted {get;}

Implements

ISecurableContainer.IsDeleted

See Also

Type Class | StarTeam Namespace


IsMPXSupported Property

Borland StarTeam SDK for .NET

Type.IsMPXSupported Property

[read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).

public virtual Boolean IsMPXSupported {get;}

Property Value

true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).

See Also

Type Class | StarTeam Namespace


IsRefreshFiltersAndQueriesRequired Property

Borland StarTeam SDK for .NET

Type.IsRefreshFiltersAndQueriesRequired Property

[read] true if Filter or QueryManager information may be out of date.

public virtual Boolean IsRefreshFiltersAndQueriesRequired {get;}

Property Value

true if Filter or QueryManager information may be out of date.

See Also

Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

Type.NAME Property

public static String NAME {get;}

See Also

Type Class | StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

Type.ParentContainer Property

[read] null.

public virtual ISecurableContainer ParentContainer {get;}

Property Value

null.

Implements

ISecurableContainer.ParentContainer

See Also

Type Class | StarTeam Namespace


PrimaryDescriptor Property

Borland StarTeam SDK for .NET

Type.PrimaryDescriptor Property

[read] The primary descriptor of this type, or null if this type has no primary descriptor.

public virtual Property PrimaryDescriptor {get;}

Property Value

The primary descriptor of this type, or null if this type has no primary descriptor.

See Also

Type Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Type.Properties Property

[read] an array of all properties belonging to this type.

public virtual PropertyCollection Properties {get;}

Property Value

an array of all properties belonging to this type.

See Also

Type Class | StarTeam Namespace


Queries Property

Borland StarTeam SDK for .NET

Type.Queries Property

[read] an array of all Query for this type.

public virtual Query[] Queries {get;}

Property Value

an array of all Query for this type.

See Also

Type Class | StarTeam Namespace


QueryACL Property

Borland StarTeam SDK for .NET

Type.QueryACL Property

[read/write] the access control list for this type. May return null.

public virtual ACE[] QueryACL {get; set;}

Property Value

the access control list for this type. May return null.

See Also

Type Class | StarTeam Namespace


SecondaryDescriptor Property

Borland StarTeam SDK for .NET

Type.SecondaryDescriptor Property

[read] A secondary descriptor of this type, or null if this type has no secondary descriptor.

public virtual Property SecondaryDescriptor {get;}

Property Value

A secondary descriptor of this type, or null if this type has no secondary descriptor.

See Also

Type Class | StarTeam Namespace


SecondaryDescriptors Property

Borland StarTeam SDK for .NET

Type.SecondaryDescriptors Property

[read] the set of all secondary descriptors for this type

public virtual PropertyCollection SecondaryDescriptors {get;}

Property Value

the set of all secondary descriptors for this type

See Also

Type Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Type.Server Property

[read] the Server object containing this Type.

public virtual Server Server {get;}

Property Value

the Server object containing this Type.

Implements

ISecurableContainer.Server

See Also

Type Class | StarTeam Namespace


Type Methods

The methods of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public Instance Methods

Copy | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard | discards local changes made to cached properties
DiscardFiltersAndQueries | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals (inherited from NamedCacheRef) | Delegate Equals() to com.starteam.NamedCacheRef.
GetFilter | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode (inherited from NamedCacheRef) | Delegate GetHashCode() to com.starteam.NamedCacheRef.
GetQuery | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions | Overloaded.
HasQuery | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty | Creates a new DateProperty
NewDateTimeProperty | Creates a new DateTimeProperty
NewDoubleProperty | Creates a new DoubleProperty
NewEnumeratedProperty | Create a new Enumerated Property
NewFilterEventSource |
NewIntegerProperty | Creates a new IntegerProperty
NewLongIntegerProperty | Creates a new LongIntegerProperty
NewMapProperty | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty |
NewObjectProperty |
NewOnOffProperty | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource |
NewTextProperty | Creates a new TextProperty
NewTimeSpanProperty | Creates a new TimeSpanProperty
NewTypeEventSource |
NewYesNoProperty | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString (inherited from NamedCacheRef) | Delegate ToString() to com.starteam.NamedCacheRef.

See Also

Type Class | StarTeam Namespace


Type.Copy Method

Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().

public virtual Type Copy();

Return Value

A copy of this Type.

See Also

Type Class | StarTeam Namespace | isEqualTo


Type.Discard Method

discards local changes made to cached properties

public virtual void Discard();

See Also

Type Class | StarTeam Namespace


Type.DiscardFiltersAndQueries Method

Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void DiscardFiltersAndQueries();

See Also

Type Class | StarTeam Namespace | refreshFiltersAndQueries


GetFilter Method

Borland StarTeam SDK for .NET

Type.GetFilter Method

Returns the cached Filter object belonging to this type with the specified filter ID. This will not return null, but will throw an IllegalArgumentException if the filter is not found.

Overload List

Returns the cached Filter object belonging to this type with the specified filter ID. This will not return null, but will throw an IllegalArgumentException if the filter is not found.

public virtual Filter GetFilter(Int32);

Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.

public virtual Filter GetFilter(String);

See Also

Type Class | StarTeam Namespace | refreshFiltersAndQueries | Filter


Type.GetFilter Method (Int32)

Returns the cached Filter object belonging to this type with the specified filter ID. This will not return null, but will throw an IllegalArgumentException if the filter is not found.

public virtual Filter GetFilter(
Int32 ID
);

Parameters

ID
A filter ID.

Return Value

the Filter object belonging to this type with the specified filter ID.

See Also

Type Class | StarTeam Namespace | Type.GetFilter Overload List | refreshFiltersAndQueries | Filter


Type.GetFilter Method (String)

Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.

public virtual Filter GetFilter(
String name
);

Parameters

name
A filter name.

Return Value

the Filter object belonging to this type with the specified filter name.

See Also

Type Class | StarTeam Namespace | Type.GetFilter Overload List | refreshFiltersAndQueries | Filter


GetQuery Method

Borland StarTeam SDK for .NET

Type.GetQuery Method

Returns the cached Query object belonging to this type with the specified Query ID. This will not return null, but will throw an IllegalArgumentException if the Query is not found.

Overload List

Returns the cached Query object belonging to this type with the specified Query ID. This will not return null, but will throw an IllegalArgumentException if the Query is not found.

public virtual Query GetQuery(Int32);

Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.

public virtual Query GetQuery(String);

See Also

Type Class | StarTeam Namespace | refreshFiltersAndQueries | Query


Type.GetQuery Method (Int32)

Returns the cached Query object belonging to this type with the specified Query ID. This will not return null, but will throw an IllegalArgumentException if the Query is not found.

public virtual Query GetQuery(
Int32 ID
);

Parameters

ID
A QueryManager ID.

Return Value

the Query object belonging to this type with the specified Query ID.

See Also

Type Class | StarTeam Namespace | Type.GetQuery Overload List | refreshFiltersAndQueries | Query


Type.GetQuery Method (String)

Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.

public virtual Query GetQuery(
String name
);

Parameters

name
A QueryManager name.

Return Value

the Query object belonging to this type with the specified Query name.

See Also

Type Class | StarTeam Namespace | Type.GetQuery Overload List | refreshFiltersAndQueries | Query


Type.GetRights Method

Returns the Access Control List for items of the specified type for this type.

public virtual ACE[] GetRights(
Type type
);

Parameters

type
the name of the type being controlled by the returned ACL

Return Value

the access control list for this type or NULL.

Implements

ISecurableContainer.GetRights

See Also

Type Class | StarTeam Namespace


HasFilter Method

Borland StarTeam SDK for .NET

Type.HasFilter Method

Returns true if the cache contains a Filter with the provided ID.

Overload List

Returns true if the cache contains a Filter with the provided ID.

public virtual bool HasFilter(Int32);

Returns true if the cache contains a Filter with the provided name.

public virtual bool HasFilter(String);

See Also

Type Class | StarTeam Namespace | refreshFiltersAndQueries | Filter


Type.HasFilter Method (Int32)

Returns true if the cache contains a Filter with the provided ID.

public virtual bool HasFilter(
Int32 ID
);

Parameters

ID
A filter ID.

Return Value

true if the cache contains a Filter with the provided ID.

See Also

Type Class | StarTeam Namespace | Type.HasFilter Overload List | refreshFiltersAndQueries | Filter


Type.HasFilter Method (String)

Returns true if the cache contains a Filter with the provided name.

public virtual bool HasFilter(
String name
);

Parameters

name
A filter name.

Return Value

true if the cache contains a Filter with the provided name.

See Also

Type Class | StarTeam Namespace | Type.HasFilter Overload List | refreshFiltersAndQueries | Filter


HasPermissions Method

Borland StarTeam SDK for .NET

Type.HasPermissions Method

Overload List

public virtual bool HasPermissions(PermissionCollection);

Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.

public virtual bool HasPermissions(PermissionCollection,Type);

See Also

Type Class | StarTeam Namespace


Type.HasPermissions Method (PermissionCollection)

public virtual bool HasPermissions(
PermissionCollection permissions
);

See Also

Type Class | StarTeam Namespace | Type.HasPermissions Overload List


Type.HasPermissions Method (PermissionCollection, Type)

Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.

public virtual bool HasPermissions(
PermissionCollection permissions,
Type type
);

Parameters

permissions
the desired permissions
type
the type for access to be tested on

Implements

ISecurableContainer.HasPermissions

See Also

Type Class | StarTeam Namespace | Type.HasPermissions Overload List | Permission


HasQuery Method

Borland StarTeam SDK for .NET

Type.HasQuery Method

Returns true if the cache contains a Query with the provided ID.

Overload List

Returns true if the cache contains a Query with the provided ID.

public virtual bool HasQuery(Int32);

Returns true if the cache contains a Query with the provided name.

public virtual bool HasQuery(String);

See Also

Type Class | StarTeam Namespace | refreshFiltersAndQueries | Query


Type.HasQuery Method (Int32)

Returns true if the cache contains a Query with the provided ID.

public virtual bool HasQuery(
Int32 ID
);

Parameters

ID
A QueryManager ID.

Return Value

true if the cache contains a Query with the provided ID.

See Also

Type Class | StarTeam Namespace | Type.HasQuery Overload List | refreshFiltersAndQueries | Query


Type.HasQuery Method (String)

Returns true if the cache contains a Query with the provided name.

public virtual bool HasQuery(
String name
);

Parameters

name
A QueryManager name.

Return Value

true if the cache contains a Query with the provided name.

See Also

Type Class | StarTeam Namespace | Type.HasQuery Overload List | refreshFiltersAndQueries | Query


Type.IsEqualTo Method

Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.

public virtual bool IsEqualTo(
Type type
);

Parameters

type
A Type object to be compared with this one.

Return Value

true if no differences are found.

See Also

Type Class | StarTeam Namespace | copy


Type.NewBooleanProperty Method

Create a new Boolean Property Assigns default display names such that 0=False and 1=True.

public virtual BooleanProperty NewBooleanProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new BooleanProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewContentProperty Method

Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().

public virtual ContentProperty NewContentProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new ContentProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewDateProperty Method

Creates a new DateProperty

public virtual DateProperty NewDateProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DateProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewDateTimeProperty Method

Creates a new DateTimeProperty

public virtual DateTimeProperty NewDateTimeProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DateTimeProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewDoubleProperty Method

Creates a new DoubleProperty

public virtual DoubleProperty NewDoubleProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DoubleProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewEnumeratedProperty Method

Create a new Enumerated Property

public virtual EnumeratedProperty NewEnumeratedProperty(
String name,
EnumeratedValue[] values,
Boolean isMultiSelectable
);

Parameters

name
- the name of the property
values
EnumeratedValue[] a default set of enumerated values NULL, or an empty array for a property with no starting values.
isMultiSelectable
true if more than one enumeration is selectable from the list

Return Value

new EnumeratedProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewFilterEventSource Method

public FilterEventSource NewFilterEventSource();

See Also

Type Class | StarTeam Namespace


Type.NewIntegerProperty Method

Creates a new IntegerProperty

public virtual IntegerProperty NewIntegerProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new IntegerProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewLongIntegerProperty Method

Creates a new LongIntegerProperty

public virtual LongIntegerProperty NewLongIntegerProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new LongIntegerProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewMapProperty Method

Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema

public virtual MapProperty NewMapProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new MapProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewObjectArrayProperty Method

public virtual ObjectArrayProperty NewObjectArrayProperty(
String name,
Principal.Type typeOfValue
);

See Also

Type Class | StarTeam Namespace


Type.NewObjectProperty Method

public virtual ObjectProperty NewObjectProperty(
String name,
LiveObject.Type typeOfValue
);

See Also

Type Class | StarTeam Namespace


Type.NewOnOffProperty Method

Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.

public virtual BooleanProperty NewOnOffProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new BooleanProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewQueryEventSource Method

public QueryEventSource NewQueryEventSource();

See Also

Type Class | StarTeam Namespace


Type.NewTextProperty Method

Creates a new TextProperty

public virtual TextProperty NewTextProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new TextProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewTimeSpanProperty Method

Creates a new TimeSpanProperty

public virtual TimeSpanProperty NewTimeSpanProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new TimeSpanProperty instance

See Also

Type Class | StarTeam Namespace


Type.NewTypeEventSource Method

public TypeEventSource NewTypeEventSource();

See Also

Type Class | StarTeam Namespace


Type.NewYesNoProperty Method

Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.

public virtual BooleanProperty NewYesNoProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new BooleanProperty instance

See Also

Type Class | StarTeam Namespace


Type.Refresh Method

Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command

public virtual void Refresh();

See Also

Type Class | StarTeam Namespace


Type.RefreshFiltersAndQueries Method

Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.

public virtual void RefreshFiltersAndQueries();

See Also

Type Class | StarTeam Namespace | getFilters | getQueries | isRefreshFiltersAndQueriesRequired | discardFiltersAndQueries | enableMPX


Type.SetRights Method

Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.

public virtual void SetRights(
Type type,
ACE[] acl
);

Parameters

type
the type being controlled by the returned ACL
acl
the new access control list or null if to be dropped

Implements

ISecurableContainer.SetRights

See Also

Type Class | StarTeam Namespace


Type.SupportsTraceVersioning Method

Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server

public virtual bool SupportsTraceVersioning();

Return Value

true if this type supports endpoint versioning with traces, false othrwise

See Also

Type Class | StarTeam Namespace


Type.MetaData Class

server stored meta data available for a Type. This definition is only useful for application developers who intend to subclass items and properties to create extended type definitions

For a list of all members of this type, see Type.MetaData Members.

System.Object
Type.MetaData

public class Type.MetaData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Type.MetaData Members | StarTeam Namespace


Type.MetaData Members

Type.MetaData overview

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Type.MetaData.
GetHashCode | Delegate GetHashCode() to com.starteam.Type.MetaData.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Type.MetaData.

See Also

Type.MetaData Class | StarTeam Namespace


Type.MetaData Methods

The methods of the Type.MetaData class are listed below. For a complete list of Type.MetaData class members, see the Type.MetaData Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Type.MetaData.
GetHashCode | Delegate GetHashCode() to com.starteam.Type.MetaData.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Type.MetaData.

See Also

Type.MetaData Class | StarTeam Namespace


Type.MetaData.Equals Method

Delegate Equals() to com.starteam.Type.MetaData.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Type.MetaData.Equals(obj).

See Also

Type.MetaData Class | StarTeam Namespace


Type.MetaData.GetHashCode Method

Delegate GetHashCode() to com.starteam.Type.MetaData.

public override int GetHashCode();

Return Value

com.starteam.Type.MetaData.GetHashCode().

See Also

Type.MetaData Class | StarTeam Namespace


Type.MetaData.ToString Method

Delegate ToString() to com.starteam.Type.MetaData.

public override string ToString();

Return Value

com.starteam.Type.MetaData.ToString()

See Also

Type.MetaData Class | StarTeam Namespace


Type.WebCacheType Class

Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see Type.WebCacheType Members.

System.Object
Type.WebCacheType
ViewMember.Type.WebCacheViewMemberType

public class Type.WebCacheType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Type.WebCacheType Members | StarTeam Namespace


Type.WebCacheType Members

Type.WebCacheType overview

Public Instance Properties

Catalog | [read] the Catalog for this type
ComponentGUID | [read] the Component GUID of this type
Context | [read] the context of this object.
DisplayName | [read] a display name for this type.
DisplayNameTranslations | [read]
Filters | [read] the set of filters
ID | [read] the class ID for this type.
Name |
NameProperty |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties | [read] an array of all properties belonging to this type.
Queries | [read] the set of queries
SecondaryDescriptor | [read] The secondary descriptor of this type, or null if this type has no secondary descriptor.
Server | [read] the Server for this cached object

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Type.WebCacheType.
FindFilter | Overloaded. find a Filter by ID, visible in the user context
FindProperty | Overloaded. Find and return a property by int iD
FindQuery | Overloaded. find a Query by ID, visible in the user context
GetHashCode | Delegate GetHashCode() to com.starteam.Type.WebCacheType.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
NewWebCacheFilterEventSource |
NewWebCacheQueryEventSource |
SetRights |
ToString | Delegate ToString() to com.starteam.Type.WebCacheType.

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType Properties

The properties of the Type.WebCacheType class are listed below. For a complete list of Type.WebCacheType class members, see the Type.WebCacheType Members topic.

Public Instance Properties

Catalog | [read] the Catalog for this type
ComponentGUID | [read] the Component GUID of this type
Context | [read] the context of this object.
DisplayName | [read] a display name for this type.
DisplayNameTranslations | [read]
Filters | [read] the set of filters
ID | [read] the class ID for this type.
Name |
NameProperty |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties | [read] an array of all properties belonging to this type.
Queries | [read] the set of queries
SecondaryDescriptor | [read] The secondary descriptor of this type, or null if this type has no secondary descriptor.
Server | [read] the Server for this cached object

See Also

Type.WebCacheType Class | StarTeam Namespace


Catalog Property

Borland StarTeam SDK for .NET

Type.WebCacheType.Catalog Property

[read] the Catalog for this type

public virtual Catalog.WebCacheCatalog Catalog {get;}

Property Value

the Catalog for this type

See Also

Type.WebCacheType Class | StarTeam Namespace


ComponentGUID Property

Borland StarTeam SDK for .NET

Type.WebCacheType.ComponentGUID Property

[read] the Component GUID of this type

public virtual GUID ComponentGUID {get;}

Property Value

the Component GUID of this type

See Also

Type.WebCacheType Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

Type.WebCacheType.Context Property

[read] the context of this object.

public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

Type.WebCacheType Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

Type.WebCacheType.DisplayName Property

[read] a display name for this type.

public virtual String DisplayName {get;}

Property Value

a display name for this type.

See Also

Type.WebCacheType Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

Type.WebCacheType.DisplayNameTranslations Property

[read]

public virtual Translations DisplayNameTranslations {get;}

See Also

Type.WebCacheType Class | StarTeam Namespace


Filters Property

Borland StarTeam SDK for .NET

Type.WebCacheType.Filters Property

[read] the set of filters

public virtual WebCacheFilter[] Filters {get;}

Property Value

the set of filters

See Also

Type.WebCacheType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

Type.WebCacheType.ID Property

[read] the class ID for this type.

public virtual Int32 ID {get;}

Property Value

the class ID for this type.

See Also

Type.WebCacheType Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

Type.WebCacheType.Name Property

public virtual String Name {get;}

See Also

Type.WebCacheType Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

Type.WebCacheType.NameProperty Property

public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

Type.WebCacheType Class | StarTeam Namespace


PrimaryDescriptor Property

Borland StarTeam SDK for .NET

Type.WebCacheType.PrimaryDescriptor Property

[read] The primary descriptor of this type, or null if this type has no primary descriptor.

public virtual Property.WebCacheProperty PrimaryDescriptor {get;}

Property Value

The primary descriptor of this type, or null if this type has no primary descriptor.

See Also

Type.WebCacheType Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

Type.WebCacheType.Properties Property

[read] an array of all properties belonging to this type.

public virtual WebCacheProperty[] Properties {get;}

Property Value

an array of all properties belonging to this type.

See Also

Type.WebCacheType Class | StarTeam Namespace


Queries Property

Borland StarTeam SDK for .NET

Type.WebCacheType.Queries Property

[read] the set of queries

public virtual WebCacheQuery[] Queries {get;}

Property Value

the set of queries

See Also

Type.WebCacheType Class | StarTeam Namespace


SecondaryDescriptor Property

Borland StarTeam SDK for .NET

Type.WebCacheType.SecondaryDescriptor Property

[read] The secondary descriptor of this type, or null if this type has no secondary descriptor.

public virtual Property.WebCacheProperty SecondaryDescriptor {get;}

Property Value

The secondary descriptor of this type, or null if this type has no secondary descriptor.

See Also

Type.WebCacheType Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

Type.WebCacheType.Server Property

[read] the Server for this cached object

public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType Methods

The methods of the Type.WebCacheType class are listed below. For a complete list of Type.WebCacheType class members, see the Type.WebCacheType Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Type.WebCacheType.
FindFilter | Overloaded. find a Filter by ID, visible in the user context
FindProperty | Overloaded. Find and return a property by int iD
FindQuery | Overloaded. find a Query by ID, visible in the user context
GetHashCode | Delegate GetHashCode() to com.starteam.Type.WebCacheType.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
NewWebCacheFilterEventSource |
NewWebCacheQueryEventSource |
SetRights |
ToString | Delegate ToString() to com.starteam.Type.WebCacheType.

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType.Equals Method

Delegate Equals() to com.starteam.Type.WebCacheType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Type.WebCacheType.Equals(obj).

See Also

Type.WebCacheType Class | StarTeam Namespace


FindFilter Method

Borland StarTeam SDK for .NET

Type.WebCacheType.FindFilter Method

find a Filter by ID, visible in the user context

Overload List

find a Filter by ID, visible in the user context

public virtual WebCacheFilter FindFilter(Int32);

find a Filter by name, visible in the user context

public virtual WebCacheFilter FindFilter(String);

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType.FindFilter Method (Int32)

find a Filter by ID, visible in the user context

public virtual WebCacheFilter FindFilter(
Int32 filterID
);

Parameters

filterID
the ID

Return Value

a filter with the specified ID or NULL

See Also

Type.WebCacheType Class | StarTeam Namespace | Type.WebCacheType.FindFilter Overload List


Type.WebCacheType.FindFilter Method (String)

find a Filter by name, visible in the user context

public virtual WebCacheFilter FindFilter(
String filterName
);

Parameters

filterName
the name

Return Value

a filter with the specified name or NULL

See Also

Type.WebCacheType Class | StarTeam Namespace | Type.WebCacheType.FindFilter Overload List


FindProperty Method

Borland StarTeam SDK for .NET

Type.WebCacheType.FindProperty Method

Find and return a property by int iD

Overload List

Find and return a property by int iD

public virtual WebCacheProperty FindProperty(Int32);

Find and return a property by name

public virtual WebCacheProperty FindProperty(String);

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType.FindProperty Method (Int32)

Find and return a property by int iD

public virtual WebCacheProperty FindProperty(
Int32 propertyID
);

Parameters

propertyID
the integer ID of the property

Return Value

a property with the given ID or NULL

See Also

Type.WebCacheType Class | StarTeam Namespace | Type.WebCacheType.FindProperty Overload List


Type.WebCacheType.FindProperty Method (String)

Find and return a property by name

public virtual WebCacheProperty FindProperty(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

a property with the given name or NULL

See Also

Type.WebCacheType Class | StarTeam Namespace | Type.WebCacheType.FindProperty Overload List


FindQuery Method

Borland StarTeam SDK for .NET

Type.WebCacheType.FindQuery Method

find a Query by ID, visible in the user context

Overload List

find a Query by ID, visible in the user context

public virtual WebCacheQuery FindQuery(Int32);

find a Query by name, visible in the user context

public virtual WebCacheQuery FindQuery(String);

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType.FindQuery Method (Int32)

find a Query by ID, visible in the user context

public virtual WebCacheQuery FindQuery(
Int32 queryID
);

Parameters

queryID
the ID

Return Value

a query with the specified ID or NULL

See Also

Type.WebCacheType Class | StarTeam Namespace | Type.WebCacheType.FindQuery Overload List


Type.WebCacheType.FindQuery Method (String)

find a Query by name, visible in the user context

public virtual WebCacheQuery FindQuery(
String queryName
);

Parameters

queryName
the name

Return Value

a query with the specified name or NULL

See Also

Type.WebCacheType Class | StarTeam Namespace | Type.WebCacheType.FindQuery Overload List


Type.WebCacheType.GetHashCode Method

Delegate GetHashCode() to com.starteam.Type.WebCacheType.

public override int GetHashCode();

Return Value

com.starteam.Type.WebCacheType.GetHashCode().

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType.GetRights Method

public virtual WebCacheACE[] GetRights(
Type.WebCacheType typ
);

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType.NewWebCacheFilterEventSource Method

public WebCacheFilterEventSource NewWebCacheFilterEventSource();

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType.NewWebCacheQueryEventSource Method

public WebCacheQueryEventSource NewWebCacheQueryEventSource();

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType.SetRights Method

public virtual void SetRights(
Type.WebCacheType typ,
WebCacheACE[] aces
);

See Also

Type.WebCacheType Class | StarTeam Namespace


Type.WebCacheType.ToString Method

Delegate ToString() to com.starteam.Type.WebCacheType.

public override string ToString();

Return Value

com.starteam.Type.WebCacheType.ToString()

See Also

Type.WebCacheType Class | StarTeam Namespace


TypeCollection Class

A Collection of Types supported by the specified server

For a list of all members of this type, see TypeCollection Members.

System.Object
StarTeamCollection
TypeCollection

public class TypeCollection : StarTeamCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TypeCollection Members | StarTeam Namespace


TypeCollection Members

TypeCollection overview

Public Instance Constructors

TypeCollection Overloaded. Initializes a new instance of the TypeCollection class.

Public Instance Properties

AUDIT |
CHANGE |
CHANGE_PACKAGE |
CHANGE_REQUEST |
CONCEPT |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
FILE |
FOLDER |
GROUP |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsRefreshRequired | [read] true if Type information may be out of date.
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
KANBAN_BOARD |
LABEL |
PLAN |
PROJECT |
PROMOTION_MODEL |
PROMOTION_STATE |
REQUIREMENT |
REVIEW |
SHARE |
SPRINT |
STORY |
SWIMLANE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TASK |
TASK_DEPENDENCY |
TEST |
TEST_RUN |
TOPIC |
TRACE |
USER |
VIEW |
VIEW_MEMBER_REVISION |
WHITE_BOARD |
WORK_RECORD |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Discard | Discards all cached Type information. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Overloaded. Looks up the type information based on a type-number.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Refresh | Refreshes cached Type information to reflect recent changes to the repository. Existing Type and Property objects are modified in place, whenever possible. If MPX is enabled, refreshTypes() is optimized to avoid unnecessary server commands.
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

TypeCollection Class | StarTeam Namespace


TypeCollection Constructor

Construct a Type Collection from an array of Type objects

Overload List

Construct a new, empty, writable type collection

public TypeCollection();

Construct a TypeCollection starting with a specific Type instance

public TypeCollection(Type);

Construct a Type Collection from an array of Type objects

public TypeCollection(Type[]);

See Also

TypeCollection Class | StarTeam Namespace


TypeCollection Constructor (Type[])

Construct a Type Collection from an array of Type objects

public TypeCollection(
Type[] types
);

Parameters

types
the array of types

See Also

TypeCollection Class | StarTeam Namespace | TypeCollection Constructor Overload List


TypeCollection Constructor ()

Construct a new, empty, writable type collection

public TypeCollection();

See Also

TypeCollection Class | StarTeam Namespace | TypeCollection Constructor Overload List


TypeCollection Constructor (Type)

Construct a TypeCollection starting with a specific Type instance

public TypeCollection(
Type type
);

Parameters

type
the Type instance to prime the collection

See Also

TypeCollection Class | StarTeam Namespace | TypeCollection Constructor Overload List


TypeCollection Properties

The properties of the TypeCollection class are listed below. For a complete list of TypeCollection class members, see the TypeCollection Members topic.

Public Instance Properties

AUDIT |
CHANGE |
CHANGE_PACKAGE |
CHANGE_REQUEST |
CONCEPT |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
FILE |
FOLDER |
GROUP |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsRefreshRequired | [read] true if Type information may be out of date.
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
KANBAN_BOARD |
LABEL |
PLAN |
PROJECT |
PROMOTION_MODEL |
PROMOTION_STATE |
REQUIREMENT |
REVIEW |
SHARE |
SPRINT |
STORY |
SWIMLANE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TASK |
TASK_DEPENDENCY |
TEST |
TEST_RUN |
TOPIC |
TRACE |
USER |
VIEW |
VIEW_MEMBER_REVISION |
WHITE_BOARD |
WORK_RECORD |

See Also

TypeCollection Class | StarTeam Namespace


AUDIT Property

Borland StarTeam SDK for .NET

TypeCollection.AUDIT Property

public Audit.Type AUDIT {get;}

See Also

TypeCollection Class | StarTeam Namespace


CHANGE Property

Borland StarTeam SDK for .NET

TypeCollection.CHANGE Property

public Change.Type CHANGE {get;}

See Also

TypeCollection Class | StarTeam Namespace


CHANGE_PACKAGE Property

Borland StarTeam SDK for .NET

TypeCollection.CHANGE_PACKAGE Property

public ChangePackage.Type CHANGE_PACKAGE {get;}

See Also

TypeCollection Class | StarTeam Namespace


CHANGE_REQUEST Property

Borland StarTeam SDK for .NET

TypeCollection.CHANGE_REQUEST Property

public ChangeRequest.Type CHANGE_REQUEST {get;}

See Also

TypeCollection Class | StarTeam Namespace


CONCEPT Property

Borland StarTeam SDK for .NET

TypeCollection.CONCEPT Property

public Concept.Type CONCEPT {get;}

See Also

TypeCollection Class | StarTeam Namespace


FILE Property

Borland StarTeam SDK for .NET

TypeCollection.FILE Property

public File.Type FILE {get;}

See Also

TypeCollection Class | StarTeam Namespace


FOLDER Property

Borland StarTeam SDK for .NET

TypeCollection.FOLDER Property

public Folder.Type FOLDER {get;}

See Also

TypeCollection Class | StarTeam Namespace


GROUP Property

Borland StarTeam SDK for .NET

TypeCollection.GROUP Property

public Group.Type GROUP {get;}

See Also

TypeCollection Class | StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

TypeCollection.IsRefreshRequired Property

[read] true if Type information may be out of date.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if Type information may be out of date.

See Also

TypeCollection Class | StarTeam Namespace


KANBAN_BOARD Property

Borland StarTeam SDK for .NET

TypeCollection.KANBAN_BOARD Property

public KanbanBoard.Type KANBAN_BOARD {get;}

See Also

TypeCollection Class | StarTeam Namespace


LABEL Property

Borland StarTeam SDK for .NET

TypeCollection.LABEL Property

public Label.Type LABEL {get;}

See Also

TypeCollection Class | StarTeam Namespace


PLAN Property

Borland StarTeam SDK for .NET

TypeCollection.PLAN Property

public Plan.Type PLAN {get;}

See Also

TypeCollection Class | StarTeam Namespace


PROJECT Property

Borland StarTeam SDK for .NET

TypeCollection.PROJECT Property

public Project.Type PROJECT {get;}

See Also

TypeCollection Class | StarTeam Namespace


PROMOTION_MODEL Property

Borland StarTeam SDK for .NET

TypeCollection.PROMOTION_MODEL Property

public PromotionModel.Type PROMOTION_MODEL {get;}

See Also

TypeCollection Class | StarTeam Namespace


PROMOTION_STATE Property

Borland StarTeam SDK for .NET

TypeCollection.PROMOTION_STATE Property

public PromotionState.Type PROMOTION_STATE {get;}

See Also

TypeCollection Class | StarTeam Namespace


REQUIREMENT Property

Borland StarTeam SDK for .NET

TypeCollection.REQUIREMENT Property

public Requirement.Type REQUIREMENT {get;}

See Also

TypeCollection Class | StarTeam Namespace


REVIEW Property

Borland StarTeam SDK for .NET

TypeCollection.REVIEW Property

public Review.Type REVIEW {get;}

See Also

TypeCollection Class | StarTeam Namespace


SHARE Property

Borland StarTeam SDK for .NET

TypeCollection.SHARE Property

public Share.Type SHARE {get;}

See Also

TypeCollection Class | StarTeam Namespace


SPRINT Property

Borland StarTeam SDK for .NET

TypeCollection.SPRINT Property

public Sprint.Type SPRINT {get;}

See Also

TypeCollection Class | StarTeam Namespace


STORY Property

Borland StarTeam SDK for .NET

TypeCollection.STORY Property

public Story.Type STORY {get;}

See Also

TypeCollection Class | StarTeam Namespace


SWIMLANE Property

Borland StarTeam SDK for .NET

TypeCollection.SWIMLANE Property

public Swimlane.Type SWIMLANE {get;}

See Also

TypeCollection Class | StarTeam Namespace


TASK Property

Borland StarTeam SDK for .NET

TypeCollection.TASK Property

public Task.Type TASK {get;}

See Also

TypeCollection Class | StarTeam Namespace


TASK_DEPENDENCY Property

Borland StarTeam SDK for .NET

TypeCollection.TASK_DEPENDENCY Property

public TaskDependency.Type TASK_DEPENDENCY {get;}

See Also

TypeCollection Class | StarTeam Namespace


TEST Property

Borland StarTeam SDK for .NET

TypeCollection.TEST Property

public Test.Type TEST {get;}

See Also

TypeCollection Class | StarTeam Namespace


TEST_RUN Property

Borland StarTeam SDK for .NET

TypeCollection.TEST_RUN Property

public TestRun.Type TEST_RUN {get;}

See Also

TypeCollection Class | StarTeam Namespace


TOPIC Property

Borland StarTeam SDK for .NET

TypeCollection.TOPIC Property

public Topic.Type TOPIC {get;}

See Also

TypeCollection Class | StarTeam Namespace


TRACE Property

Borland StarTeam SDK for .NET

TypeCollection.TRACE Property

public Trace.Type TRACE {get;}

See Also

TypeCollection Class | StarTeam Namespace


USER Property

Borland StarTeam SDK for .NET

TypeCollection.USER Property

public User.Type USER {get;}

See Also

TypeCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

TypeCollection.VIEW Property

public View.Type VIEW {get;}

See Also

TypeCollection Class | StarTeam Namespace


VIEW_MEMBER_REVISION Property

Borland StarTeam SDK for .NET

TypeCollection.VIEW_MEMBER_REVISION Property

public ViewMemberRevision.Type VIEW_MEMBER_REVISION {get;}

See Also

TypeCollection Class | StarTeam Namespace


WHITE_BOARD Property

Borland StarTeam SDK for .NET

TypeCollection.WHITE_BOARD Property

public WhiteBoard.Type WHITE_BOARD {get;}

See Also

TypeCollection Class | StarTeam Namespace


WORK_RECORD Property

Borland StarTeam SDK for .NET

TypeCollection.WORK_RECORD Property

public WorkRecord.Type WORK_RECORD {get;}

See Also

TypeCollection Class | StarTeam Namespace


TypeCollection Methods

The methods of the TypeCollection class are listed below. For a complete list of TypeCollection class members, see the TypeCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Discard | Discards all cached Type information. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Overloaded. Looks up the type information based on a type-number.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Refresh | Refreshes cached Type information to reflect recent changes to the repository. Existing Type and Property objects are modified in place, whenever possible. If MPX is enabled, refreshTypes() is optimized to avoid unnecessary server commands.
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

TypeCollection Class | StarTeam Namespace


TypeCollection.Discard Method

Discards all cached Type information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void Discard();

See Also

TypeCollection Class | StarTeam Namespace


Find Method

Borland StarTeam SDK for .NET

TypeCollection.Find Method

Looks up the type information based on a type-number.

Overload List

Looks up the type information based on a type-number.

public virtual Type Find(Int32);

Returns a type instance for a type name, or NULL if one is not found

public virtual Type Find(String);

See Also

TypeCollection Class | StarTeam Namespace | find


TypeCollection.Find Method (Int32)

Looks up the type information based on a type-number.

public virtual Type Find(
Int32 classID
);

Parameters

classID
a server-assigned number that identifies the type

Return Value

the type information for the given type-number

Exceptions

Exception Type | Condition
 | com.starteam.exceptions.TypeNotFoundException

See Also

TypeCollection Class | StarTeam Namespace | TypeCollection.Find Overload List | find


TypeCollection.Find Method (String)

Returns a type instance for a type name, or NULL if one is not found

public virtual Type Find(
String typeName
);

Parameters

typeName
name of type in question. Must not be null.

Return Value

Type object representing the type information

Exceptions

Exception Type | Condition
 | System.ArgumentException

See Also

TypeCollection Class | StarTeam Namespace | TypeCollection.Find Overload List | find


TypeCollection.Refresh Method

Refreshes cached Type information to reflect recent changes to the repository. Existing Type and Property objects are modified in place, whenever possible. If MPX is enabled, refreshTypes() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

TypeCollection Class | StarTeam Namespace | isRefreshRequired | discard | enableMPX


TypedResource Class

This is a parent interface for many instances of StarTeam types (e.g. File, ChangeRequest). The interface describes objects that have property/value pairs. Each TypedResource is associated with the properties from a Type object. A TypedResource has a constraint that only valid Type properties may be used for set/get and that type checking for set will be enforced.

For a list of all members of this type, see TypedResource Members.

System.Object
TypedResource
LiveObject
ViewMemberRevision

public class TypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TypedResource Members | StarTeam Namespace


TypedResource Members

TypedResource overview

Public Instance Properties

CachedProperties | [read] PropertyCollection
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] The unique identifier for this resource.
IsDirty | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty |
IsNew | [read] true if this resource has not yet been stored in the server.
MyType | [read] the type of this resource.
ObjectID | [read] The unique identifier for this resource.
Server | [read] Server the Server instance for this SimpleTypedResource

Public Instance Methods

AddToIntegerArray | Add a new array item to a property whose value is an integer array.
Equals | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue | A type-safe accessor method for returning byte[] valued properties.
GetContentValue | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue | A type-safe accessor method for returning DateTime valued properties.
GetDateValue | A type-safe accessor method for returning Date valued properties.
GetDoubleValue | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue | A type-safe accessor method for returning integer valued properties.
GetLinkValue | A type-safe accessor method for getting LinkValued properties.
GetLongValue | A type-safe accessor method for returning long valued properties.
GetPossibleValues | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value of the specified property.
HasCachedProperties | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray | Remove an array item from a property whose value is an integer array.
SetBooleanValue | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue | A type-safe accessor method for setting byte[] valued properties.
SetContentValue | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue | A type-safe accessor method for setting DateTime valued properties.
SetDateValue | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue | A type-safe accessor method for setting integer valued properties.
SetLinkValue | A type-safe accessor method for setting LinkValued properties.
SetLongValue | A type-safe accessor method for setting long valued properties.
SetStringValue | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue | A type-safe accessor method for setting TimeSpan valued properties.
SetValue | Sets the value of the property specified by property.
ToString | Delegate ToString() to com.starteam.TypedResource.

See Also

TypedResource Class | StarTeam Namespace


TypedResource Properties

The properties of the TypedResource class are listed below. For a complete list of TypedResource class members, see the TypedResource Members topic.

Public Instance Properties

CachedProperties | [read] PropertyCollection
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] The unique identifier for this resource.
IsDirty | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty |
IsNew | [read] true if this resource has not yet been stored in the server.
MyType | [read] the type of this resource.
ObjectID | [read] The unique identifier for this resource.
Server | [read] Server the Server instance for this SimpleTypedResource

See Also

TypedResource Class | StarTeam Namespace


CachedProperties Property

Borland StarTeam SDK for .NET

TypedResource.CachedProperties Property

[read] PropertyCollection

public virtual PropertyCollection CachedProperties {get;}

Property Value

PropertyCollection

See Also

TypedResource Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

TypedResource.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

TypedResource Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TypedResource.ID Property

[read] The unique identifier for this resource.

public virtual Int32 ID {get;}

Property Value

The unique identifier for this resource.

See Also

TypedResource Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

TypedResource.IsDirty Property

[read] true if any of this item's properties have been modified locally and not yet saved.

public virtual Boolean IsDirty {get;}

Property Value

true if any of this item's properties have been modified locally and not yet saved.

See Also

TypedResource Class | StarTeam Namespace


IsDirtyProperty Property

Borland StarTeam SDK for .NET

TypedResource.IsDirtyProperty Property

public virtual Boolean IsDirtyProperty {get;}

See Also

TypedResource Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

TypedResource.IsNew Property

[read] true if this resource has not yet been stored in the server.

public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

TypedResource Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

TypedResource.MyType Property

[read] the type of this resource.

public virtual Type MyType {get;}

Property Value

the type of this resource.

See Also

TypedResource Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

TypedResource.ObjectID Property

[read] The unique identifier for this resource.

public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for this resource.

See Also

TypedResource Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

TypedResource.Server Property

[read] Server the Server instance for this SimpleTypedResource

public virtual Server Server {get;}

Property Value

Server the Server instance for this SimpleTypedResource

See Also

TypedResource Class | StarTeam Namespace


TypedResource Methods

The methods of the TypedResource class are listed below. For a complete list of TypedResource class members, see the TypedResource Members topic.

Public Instance Methods

AddToIntegerArray | Add a new array item to a property whose value is an integer array.
Equals | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue | A type-safe accessor method for returning byte[] valued properties.
GetContentValue | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue | A type-safe accessor method for returning DateTime valued properties.
GetDateValue | A type-safe accessor method for returning Date valued properties.
GetDoubleValue | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue | A type-safe accessor method for returning integer valued properties.
GetLinkValue | A type-safe accessor method for getting LinkValued properties.
GetLongValue | A type-safe accessor method for returning long valued properties.
GetPossibleValues | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Gets the value of the specified property.
HasCachedProperties | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray | Remove an array item from a property whose value is an integer array.
SetBooleanValue | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue | A type-safe accessor method for setting byte[] valued properties.
SetContentValue | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue | A type-safe accessor method for setting DateTime valued properties.
SetDateValue | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue | A type-safe accessor method for setting integer valued properties.
SetLinkValue | A type-safe accessor method for setting LinkValued properties.
SetLongValue | A type-safe accessor method for setting long valued properties.
SetStringValue | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue | A type-safe accessor method for setting TimeSpan valued properties.
SetValue | Sets the value of the property specified by property.
ToString | Delegate ToString() to com.starteam.TypedResource.

See Also

TypedResource Class | StarTeam Namespace


TypedResource.AddToIntegerArray Method

Add a new array item to a property whose value is an integer array.

public virtual void AddToIntegerArray(
Property countProperty,
Property dataProperty,
Int32 value
);

Parameters

countProperty
the property containing the count of values in the array.
dataProperty
the property containing the array.
value
the new item to add to the array.

See Also

TypedResource Class | StarTeam Namespace


TypedResource.Equals Method

Delegate Equals() to com.starteam.TypedResource.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TypedResource.Equals(obj).

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetBooleanValue Method

A type-safe accessor method for returning boolean valued properties.

public virtual bool GetBooleanValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the boolean value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetByteArrayValue Method

A type-safe accessor method for returning byte[] valued properties.

public virtual byte[] GetByteArrayValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the byte array value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetContentValue Method

A type-safe accessor method for returning Content valued properties.

public virtual Content GetContentValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the Content value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetDateTimeValue Method

A type-safe accessor method for returning DateTime valued properties.

public virtual DateTime GetDateTimeValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the String value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetDateValue Method

A type-safe accessor method for returning Date valued properties.

public virtual Date GetDateValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the String value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetDoubleValue Method

A type-safe accessor method for returning double valued properties.

public virtual double GetDoubleValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the double value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetEnumDisplayName Method

A convenience method for returning the display name for a given value of an enumerated property.

public virtual string GetEnumDisplayName(
Property property,
Int32 value
);

Parameters

property
the property
value
one of the possible enumerated values of the indicated property

Return Value

a user-friendly display name for the given value

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetEnumeratedValues Method

A type-safe accessor method for returning Enumerated valued properties.

public virtual EnumeratedValue[] GetEnumeratedValues(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the Enumerated value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetHashCode Method

Delegate GetHashCode() to com.starteam.TypedResource.

public override int GetHashCode();

Return Value

com.starteam.TypedResource.GetHashCode().

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetIntegerArrayValue Method

A type-safe accessor method for returning int[] valued properties.

public virtual int[] GetIntegerArrayValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the int array value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetIntegerValue Method

A type-safe accessor method for returning integer valued properties.

public virtual int GetIntegerValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the integer value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetLinkValue Method

A type-safe accessor method for getting LinkValued properties.

public virtual LinkValue GetLinkValue(
Property property
);

Parameters

property
The property whose value is to be retrieved.

Return Value

The value of this property, as a LinkValue.

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetLongValue Method

A type-safe accessor method for returning long valued properties.

public virtual long GetLongValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the long value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetPossibleValues Method

A convenience method for returning an array of the possible values of an enumerated property.

public virtual EnumeratedValue[] GetPossibleValues(
Property property
);

Parameters

property
the property

Return Value

an array of the possible values for the indicated property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetStringValue Method

A type-safe accessor method for returning String valued properties.

public virtual string GetStringValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the String value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetTimeSpanValue Method

A type-safe accessor method for returning TimeSpan valued properties.

public virtual TimeSpan GetTimeSpanValue(
Property property
);

Parameters

property
the property to be retrieved

Return Value

the TimeSpan value of the specified property

See Also

TypedResource Class | StarTeam Namespace


TypedResource.GetValue Method

Gets the value of the specified property.

public virtual object GetValue(
Property property
);

Parameters

property
The property whose value is to be retrieved.

Return Value

The value of the specified property.

See Also

TypedResource Class | StarTeam Namespace


TypedResource.HasCachedProperties Method

returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client

public virtual bool HasCachedProperties();

Return Value

boolean true if this item has at least one property cached locally

See Also

TypedResource Class | StarTeam Namespace


TypedResource.HasValue Method

returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client

public virtual bool HasValue(
Property property
);

Parameters

property
Property the property to test

Return Value

boolean true if the property is cached locally

See Also

TypedResource Class | StarTeam Namespace


TypedResource.RemoveFromIntegerArray Method

Remove an array item from a property whose value is an integer array.

public virtual void RemoveFromIntegerArray(
Property countProperty,
Property dataProperty,
Int32 value
);

Parameters

countProperty
the property containing the count of values in the array.
dataProperty
the property containing the array.
value
the item to remove from the array.

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetBooleanValue Method

A type-safe accessor method for setting boolean valued properties.

public virtual void SetBooleanValue(
Property property,
Boolean v
);

Parameters

property
the property
v
the boolean value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetByteArrayValue Method

A type-safe accessor method for setting byte[] valued properties.

public virtual void SetByteArrayValue(
Property property,
Byte[] v
);

Parameters

property
the property
v
the byte[] value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetContentValue Method

A type-safe accessor method for setting Content valued properties.

public virtual void SetContentValue(
Property property,
Content v
);

Parameters

property
the property
v
the content value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetDateTimeValue Method

A type-safe accessor method for setting DateTime valued properties.

public virtual void SetDateTimeValue(
Property property,
DateTime v
);

Parameters

property
the property
v
the DateTime value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetDateValue Method

A type-safe accessor method for setting DateTime valued properties.

public virtual void SetDateValue(
Property property,
Date v
);

Parameters

property
the property
v
the DateTime value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetDoubleValue Method

A type-safe accessor method for setting double valued properties.

public virtual void SetDoubleValue(
Property property,
Double v
);

Parameters

property
the property
v
the double value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetEnumeratedValue Method

A type-safe accessor method for setting Enumerated valued properties.

public virtual void SetEnumeratedValue(
Property property,
EnumeratedValue v
);

Parameters

property
the property
v
the Enumerated value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetEnumeratedValues Method

A type-safe accessor method for setting Enumerated valued properties.

public virtual void SetEnumeratedValues(
Property property,
EnumeratedValue[] v
);

Parameters

property
the property
v
the Enumerated values to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetIntegerArrayValue Method

A type-safe accessor method for setting int[] valued properties.

public virtual void SetIntegerArrayValue(
Property property,
Int32[] v
);

Parameters

property
the property
v
the int[] value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetIntegerValue Method

A type-safe accessor method for setting integer valued properties.

public virtual void SetIntegerValue(
Property property,
Int32 v
);

Parameters

property
the property to be retrieved
v
int

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetLinkValue Method

A type-safe accessor method for setting LinkValued properties.

public virtual void SetLinkValue(
Property property,
LinkValue v
);

Parameters

property
the property
v
the double value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetLongValue Method

A type-safe accessor method for setting long valued properties.

public virtual void SetLongValue(
Property property,
Int64 v
);

Parameters

property
the property
v
the long value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetStringValue Method

A type-safe accessor method for setting String valued properties.

public virtual void SetStringValue(
Property property,
String v
);

Parameters

property
the Property
v
the String value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetTimeSpanValue Method

A type-safe accessor method for setting TimeSpan valued properties.

public virtual void SetTimeSpanValue(
Property property,
TimeSpan v
);

Parameters

property
the property
v
the TimeSpan value to be set

See Also

TypedResource Class | StarTeam Namespace


TypedResource.SetValue Method

Sets the value of the property specified by property.

public virtual object SetValue(
Property property,
Object propertyValue
);

Parameters

property
the property to set
propertyValue
the value of the property to set

Return Value

the previous value of the specified property

Exceptions

Exception Type | Condition
 | System.InvalidCastException
 | com.starteam.exceptions.NoSuchPropertyException

See Also

TypedResource Class | StarTeam Namespace


TypedResource.ToString Method

Delegate ToString() to com.starteam.TypedResource.

public override string ToString();

Return Value

com.starteam.TypedResource.ToString()

See Also

TypedResource Class | StarTeam Namespace


TypedResource.BranchState Class

The branch state of a versioned object.

For a list of all members of this type, see TypedResource.BranchState Members.

System.Object
EnumeratedValue
TypedResource.BranchState

public class TypedResource.BranchState : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TypedResource.BranchState Members | StarTeam Namespace


TypedResource.BranchState Members

TypedResource.BranchState overview

Public Static Properties

ALL
BRANCHED
NOT_BRANCHED
NOT_SUPPORTED
ROOT

Public Static Methods

FromID | Gets the BranchState value corresponding to the given ID.
FromValue | Gets the BranchState value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this BranchState value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.TypedResource.BranchState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.BranchState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.TypedResource.BranchState.

See Also

TypedResource.BranchState Class | StarTeam Namespace


TypedResource.BranchState Properties

The properties of the TypedResource.BranchState class are listed below. For a complete list of TypedResource.BranchState class members, see the TypedResource.BranchState Members topic.

Public Static Properties

ALL
BRANCHED
NOT_BRANCHED
NOT_SUPPORTED
ROOT

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this BranchState value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

TypedResource.BranchState Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

TypedResource.BranchState.ALL Property

public static BranchState[] ALL {get;}

See Also

TypedResource.BranchState Class | StarTeam Namespace


BRANCHED Property

Borland StarTeam SDK for .NET

TypedResource.BranchState.BRANCHED Property

public static TypedResource.BranchState BRANCHED {get;}

Property Value

This View Member has branched.

See Also

TypedResource.BranchState Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

TypedResource.BranchState.ID Property

[read] The ID of this BranchState value.

public virtual Int32 ID {get;}

Property Value

The ID of this BranchState value.

See Also

TypedResource.BranchState Class | StarTeam Namespace


NOT_BRANCHED Property

Borland StarTeam SDK for .NET

TypedResource.BranchState.NOT_BRANCHED Property

public static TypedResource.BranchState NOT_BRANCHED {get;}

Property Value

This View Member has not yet branched.

See Also

TypedResource.BranchState Class | StarTeam Namespace


NOT_SUPPORTED Property

Borland StarTeam SDK for .NET

TypedResource.BranchState.NOT_SUPPORTED Property

public static TypedResource.BranchState NOT_SUPPORTED {get;}

Property Value

This View member does not support branching.

See Also

TypedResource.BranchState Class | StarTeam Namespace


ROOT Property

Borland StarTeam SDK for .NET

TypedResource.BranchState.ROOT Property

public static TypedResource.BranchState ROOT {get;}

Property Value

This View member is the root.

See Also

TypedResource.BranchState Class | StarTeam Namespace


TypedResource.BranchState Methods

The methods of the TypedResource.BranchState class are listed below. For a complete list of TypedResource.BranchState class members, see the TypedResource.BranchState Members topic.

Public Static Methods

FromID | Gets the BranchState value corresponding to the given ID.
FromValue | Gets the BranchState value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.TypedResource.BranchState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.BranchState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.TypedResource.BranchState.

See Also

TypedResource.BranchState Class | StarTeam Namespace


TypedResource.BranchState.Equals Method

Delegate Equals() to com.starteam.TypedResource.BranchState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TypedResource.BranchState.Equals(obj).

See Also

TypedResource.BranchState Class | StarTeam Namespace


TypedResource.BranchState.FromID Method

Gets the BranchState value corresponding to the given ID.

public static BranchState FromID(
Int32 id
);

Parameters

id
A BranchState ID.

Return Value

The corresponding BranchState value, or null.

See Also

TypedResource.BranchState Class | StarTeam Namespace


TypedResource.BranchState.FromValue Method

Gets the BranchState value corresponding to the given EnumeratedValue.

public static BranchState FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a BranchStateProperty.

Return Value

The corresponding BranchState value, or null.

See Also

TypedResource.BranchState Class | StarTeam Namespace


TypedResource.BranchState.GetHashCode Method

Delegate GetHashCode() to com.starteam.TypedResource.BranchState.

public override int GetHashCode();

Return Value

com.starteam.TypedResource.BranchState.GetHashCode().

See Also

TypedResource.BranchState Class | StarTeam Namespace


TypedResource.BranchState.ToString Method

Delegate ToString() to com.starteam.TypedResource.BranchState.

public override string ToString();

Return Value

com.starteam.TypedResource.BranchState.ToString()

See Also

TypedResource.BranchState Class | StarTeam Namespace


TypedResource.Type Class

The TypedResource Type

For a list of all members of this type, see TypedResource.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
ViewMemberRevision.Type

public class TypedResource.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TypedResource.Type Members | StarTeam Namespace


TypedResource.Type Members

TypedResource.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TypedResource.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TypedResource.Type.

See Also

TypedResource.Type Class | StarTeam Namespace


TypedResource.Type Properties

The properties of the TypedResource.Type class are listed below. For a complete list of TypedResource.Type class members, see the TypedResource.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

TypedResource.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TypedResource.Type.NAME Property

new public static String NAME {get;}

See Also

TypedResource.Type Class | StarTeam Namespace


TypedResource.Type Methods

The methods of the TypedResource.Type class are listed below. For a complete list of TypedResource.Type class members, see the TypedResource.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.TypedResource.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.TypedResource.Type.

See Also

TypedResource.Type Class | StarTeam Namespace


TypedResource.Type.Equals Method

Delegate Equals() to com.starteam.TypedResource.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TypedResource.Type.Equals(obj).

See Also

TypedResource.Type Class | StarTeam Namespace


TypedResource.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.TypedResource.Type.

public override int GetHashCode();

Return Value

com.starteam.TypedResource.Type.GetHashCode().

See Also

TypedResource.Type Class | StarTeam Namespace


TypedResource.Type.ToString Method

Delegate ToString() to com.starteam.TypedResource.Type.

public override string ToString();

Return Value

com.starteam.TypedResource.Type.ToString()

See Also

TypedResource.Type Class | StarTeam Namespace


TypedResource.Type.BranchStateProperty Class

The property type of the Branch State property.

For a list of all members of this type, see TypedResource.Type.BranchStateProperty Members.

System.Object
Property
EnumeratedProperty
TypedResource.Type.BranchStateProperty

public class TypedResource.Type.BranchStateProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TypedResource.Type.BranchStateProperty Members | StarTeam Namespace


TypedResource.Type.BranchStateProperty Members

TypedResource.Type.BranchStateProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TypedResource.Type.BranchStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.BranchStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TypedResource.Type.BranchStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TypedResource.Type.BranchStateProperty Class | StarTeam Namespace


TypedResource.Type.BranchStateProperty Properties

The properties of the TypedResource.Type.BranchStateProperty class are listed below. For a complete list of TypedResource.Type.BranchStateProperty class members, see the TypedResource.Type.BranchStateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

TypedResource.Type.BranchStateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TypedResource.Type.BranchStateProperty.NAME Property

public static String NAME {get;}

See Also

TypedResource.Type.BranchStateProperty Class | StarTeam Namespace


TypedResource.Type.BranchStateProperty Methods

The methods of the TypedResource.Type.BranchStateProperty class are listed below. For a complete list of TypedResource.Type.BranchStateProperty class members, see the TypedResource.Type.BranchStateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.TypedResource.Type.BranchStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.BranchStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.TypedResource.Type.BranchStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TypedResource.Type.BranchStateProperty Class | StarTeam Namespace


TypedResource.Type.BranchStateProperty.Equals Method

Delegate Equals() to com.starteam.TypedResource.Type.BranchStateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TypedResource.Type.BranchStateProperty.Equals(obj).

See Also

TypedResource.Type.BranchStateProperty Class | StarTeam Namespace


TypedResource.Type.BranchStateProperty.FromValue Method

public virtual EnumeratedValue FromValue(
TypedResource.BranchState value
);

See Also

TypedResource.Type.BranchStateProperty Class | StarTeam Namespace


TypedResource.Type.BranchStateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TypedResource.Type.BranchStateProperty.

public override int GetHashCode();

Return Value

com.starteam.TypedResource.Type.BranchStateProperty.GetHashCode().

See Also

TypedResource.Type.BranchStateProperty Class | StarTeam Namespace


TypedResource.Type.BranchStateProperty.ToString Method

Delegate ToString() to com.starteam.TypedResource.Type.BranchStateProperty.

public override string ToString();

Return Value

com.starteam.TypedResource.Type.BranchStateProperty.ToString()

See Also

TypedResource.Type.BranchStateProperty Class | StarTeam Namespace


TypedResource.Type.IDProperty Class

The property type of the ID property.

For a list of all members of this type, see TypedResource.Type.IDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
TypedResource.Type.IDProperty

public class TypedResource.Type.IDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TypedResource.Type.IDProperty Members | StarTeam Namespace


TypedResource.Type.IDProperty Members

TypedResource.Type.IDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TypedResource.Type.IDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.IDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TypedResource.Type.IDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TypedResource.Type.IDProperty Class | StarTeam Namespace


TypedResource.Type.IDProperty Properties

The properties of the TypedResource.Type.IDProperty class are listed below. For a complete list of TypedResource.Type.IDProperty class members, see the TypedResource.Type.IDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

TypedResource.Type.IDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TypedResource.Type.IDProperty.NAME Property

public static String NAME {get;}

See Also

TypedResource.Type.IDProperty Class | StarTeam Namespace


TypedResource.Type.IDProperty Methods

The methods of the TypedResource.Type.IDProperty class are listed below. For a complete list of TypedResource.Type.IDProperty class members, see the TypedResource.Type.IDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TypedResource.Type.IDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.IDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TypedResource.Type.IDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TypedResource.Type.IDProperty Class | StarTeam Namespace


TypedResource.Type.IDProperty.Equals Method

Delegate Equals() to com.starteam.TypedResource.Type.IDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TypedResource.Type.IDProperty.Equals(obj).

See Also

TypedResource.Type.IDProperty Class | StarTeam Namespace


TypedResource.Type.IDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TypedResource.Type.IDProperty.

public override int GetHashCode();

Return Value

com.starteam.TypedResource.Type.IDProperty.GetHashCode().

See Also

TypedResource.Type.IDProperty Class | StarTeam Namespace


TypedResource.Type.IDProperty.ToString Method

Delegate ToString() to com.starteam.TypedResource.Type.IDProperty.

public override string ToString();

Return Value

com.starteam.TypedResource.Type.IDProperty.ToString()

See Also

TypedResource.Type.IDProperty Class | StarTeam Namespace


TypedResource.Type.ProjectProperty Class

The property type of the Project property.

For a list of all members of this type, see TypedResource.Type.ProjectProperty Members.

System.Object
Property
ObjectProperty
TypedResource.Type.ProjectProperty

public class TypedResource.Type.ProjectProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TypedResource.Type.ProjectProperty Members | StarTeam Namespace


TypedResource.Type.ProjectProperty Members

TypedResource.Type.ProjectProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TypedResource.Type.ProjectProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.ProjectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TypedResource.Type.ProjectProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TypedResource.Type.ProjectProperty Class | StarTeam Namespace


TypedResource.Type.ProjectProperty Properties

The properties of the TypedResource.Type.ProjectProperty class are listed below. For a complete list of TypedResource.Type.ProjectProperty class members, see the TypedResource.Type.ProjectProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

TypedResource.Type.ProjectProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TypedResource.Type.ProjectProperty.NAME Property

public static String NAME {get;}

See Also

TypedResource.Type.ProjectProperty Class | StarTeam Namespace


TypedResource.Type.ProjectProperty Methods

The methods of the TypedResource.Type.ProjectProperty class are listed below. For a complete list of TypedResource.Type.ProjectProperty class members, see the TypedResource.Type.ProjectProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TypedResource.Type.ProjectProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.ProjectProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TypedResource.Type.ProjectProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TypedResource.Type.ProjectProperty Class | StarTeam Namespace


TypedResource.Type.ProjectProperty.Equals Method

Delegate Equals() to com.starteam.TypedResource.Type.ProjectProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TypedResource.Type.ProjectProperty.Equals(obj).

See Also

TypedResource.Type.ProjectProperty Class | StarTeam Namespace


TypedResource.Type.ProjectProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TypedResource.Type.ProjectProperty.

public override int GetHashCode();

Return Value

com.starteam.TypedResource.Type.ProjectProperty.GetHashCode().

See Also

TypedResource.Type.ProjectProperty Class | StarTeam Namespace


TypedResource.Type.ProjectProperty.ToString Method

Delegate ToString() to com.starteam.TypedResource.Type.ProjectProperty.

public override string ToString();

Return Value

com.starteam.TypedResource.Type.ProjectProperty.ToString()

See Also

TypedResource.Type.ProjectProperty Class | StarTeam Namespace


TypedResource.Type.ViewProperty Class

The property type of the View property.

For a list of all members of this type, see TypedResource.Type.ViewProperty Members.

System.Object
Property
ObjectProperty
TypedResource.Type.ViewProperty

public class TypedResource.Type.ViewProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

TypedResource.Type.ViewProperty Members | StarTeam Namespace


TypedResource.Type.ViewProperty Members

TypedResource.Type.ViewProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TypedResource.Type.ViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.ViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TypedResource.Type.ViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TypedResource.Type.ViewProperty Class | StarTeam Namespace


TypedResource.Type.ViewProperty Properties

The properties of the TypedResource.Type.ViewProperty class are listed below. For a complete list of TypedResource.Type.ViewProperty class members, see the TypedResource.Type.ViewProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

TypedResource.Type.ViewProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

TypedResource.Type.ViewProperty.NAME Property

public static String NAME {get;}

See Also

TypedResource.Type.ViewProperty Class | StarTeam Namespace


TypedResource.Type.ViewProperty Methods

The methods of the TypedResource.Type.ViewProperty class are listed below. For a complete list of TypedResource.Type.ViewProperty class members, see the TypedResource.Type.ViewProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.TypedResource.Type.ViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.TypedResource.Type.ViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.TypedResource.Type.ViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

TypedResource.Type.ViewProperty Class | StarTeam Namespace


TypedResource.Type.ViewProperty.Equals Method

Delegate Equals() to com.starteam.TypedResource.Type.ViewProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.TypedResource.Type.ViewProperty.Equals(obj).

See Also

TypedResource.Type.ViewProperty Class | StarTeam Namespace


TypedResource.Type.ViewProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.TypedResource.Type.ViewProperty.

public override int GetHashCode();

Return Value

com.starteam.TypedResource.Type.ViewProperty.GetHashCode().

See Also

TypedResource.Type.ViewProperty Class | StarTeam Namespace


TypedResource.Type.ViewProperty.ToString Method

Delegate ToString() to com.starteam.TypedResource.Type.ViewProperty.

public override string ToString();

Return Value

com.starteam.TypedResource.Type.ViewProperty.ToString()

See Also

TypedResource.Type.ViewProperty Class | StarTeam Namespace


User Class

Represents a StarTeam User. Some of the information is accessible only to users with appropriate permissions. Applications which require only a subset of user data should use {@link com.starteam.Server#getUsers()}.Applications which require the complete account information for all users should use {@link com.starteam.ServerAdministration#getUsers()}. The logged in user however needs to have permission {@link com.starteam.Permission#SERVER_ADMIN_USER_ACCOUNTS} granted for accessing the complete user account information.

For a list of all members of this type, see User Members.

System.Object
TypedResource
LiveObject
TrackedObject
Principal
User

public class User : Principal

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User Members | StarTeam Namespace


User Members

User overview

Public Static Properties

LOGGED_IN_USER

Public Instance Constructors

User Constructor Creates a new User account to be activated on the server. The new account will not actually be created until update() is called.

Public Instance Properties

AccessPolicy | [read/write] this account's access policy
AccountStatus | [read] this account's status.
BLSSlipGuid | [read/write] The Slip ID assigned to this license, or 0 if this User does not have a license managed by the Borland License Server.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DistinguishedName | [read/write] the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.
EmailAddress | [read/write] the User's email address.
EnforceSSOAuthentication | [write] Enforce user to login only using Single Sign-On/Multi-Factor Authentication.
FavoriteProjects | [read/write] the User's Favorite Projects.
FaxNumber | [read/write] the User's fax number.
Groups | [read] all of the groups to which this User belongs.
HasFixedLicense | [read/write] True if this User has a fixed ( named-User ) license; false if this User has a floating ( concurrent ) license. Note that if the StarTeam Server does not support floating licenses, then every User has a fixed license.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBuiltIn | [read] true if this is a built in user
IsDeleted (inherited from Principal) | [read] true if the Principal has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPrimaryDirectoryService | [read/write] True if this user is in the primary directory service, false if secondary.
IsSSOAuthenticationEnforced | [read] true, if the user is required to login using single sign-on/Multi-factor authentcation. false, if the user can choose to login using password based authentcation or SSO.
LastLogoutTime | [read] The time the user last logged out.
LastWebLogoutTime | [read] The time the user last logged out from the webserver.
LicenseType | [read/write] The type of license assigned to this User.
Logins | [read] a history of logins for this User
LogOnCount | [read] the number of times this User is logged in to the server.
LogOnName | [read/write] the logon name or identifier for this account.
MinimumPasswordLength | [read] the minimum required password length.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name (inherited from Principal) | [read/write] the name of this principal
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
PagerNumber | [read/write] the User's pager number.
Password | [write] Sets the password for this account. The password should be passed in as clear text.
PasswordChangeRequired | [read] true if a password change is required during the current session.
PasswordDaysRemaining | [read] The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.
PhoneNumber | [read/write] the User's phone number.
Picture | [read/write] the Content object used to store a picture of this user
PolicyTimeZoneShift | [read/write] this timezone shift for this account's access policy.
PostalAddress | [read/write] the User's postal address.
PresentationID | [read] the unique integer identifier for this user.
Properties | [read] the properties of the User Type
ReturnEmailAddress | [read/write] the email address to be used for spoofing the mail server
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Territory | [read/write] the Territory this User belongs to
ValidateThroughDirectoryService | [read/write] true if the User validates through Directory Service, otherwise false. This property is supported by server release 6.0 and later; ignored for earlier releases. Note that when setting this value to false, a valid password must also be set.
VoiceMailNumber | [read/write] the User's voice mail number.
WebLogOnCount | [read] the number of times this User is logged in via the webserver.
Workstations | [read] a list of workstation names.

Public Instance Methods

AddTo | Adds this User to the specified group. The group cannot be null, must be from the same server as the User and the group account must have already been created on the server. You must call update() to save the changes on the server.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this User object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
ForceLogoff | Forces this User account to be logged off from the server. The effect is immediate ( no need to call the update() method ).
ForcePasswordChange | Forces a password change for this User account. The effect is immediate ( no need to call the update() method ).
GetAccessEndTime1 |
GetAccessEndTime2 |
GetAccessStartTime1 |
GetAccessStartTime2 |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCapacityOverriddenOn | Returns the set of dates for which capacities have been overridden
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDefaultCapacity | Returns the default capacity assigned to a specific project
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetOverriddenCapacity | Return the overridden capacity for the project for the specified week
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasDefaultCapacity | Returns true if this user has a default capacity assigned to a specific project
HasOverriddenCapacity | return true if the default capacity is overwritten for a specified week the date will typically be specified as a Monday, implying the week coverage
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares two User objects.
IsMemberOf | Determines whether or not this user is a member of the given group. note that membership is implied, i.e. a user is considered to be a member of the entire tree of parent groups of the group(s) that the user was explicitly added to
Reactivate | Reactivates this User account. The effect is immediate ( no need to call the update() method ).
Remove (inherited from Principal) | Removes this principal from the StarTeam server, plus any direct or indirect members of this principal.
RemoveFrom | Removes this User from the specified group. The group cannot be null, must be from the same server as the User and the group account must have already been created on the server. You must call update() to save the changes on the server.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetAccessTimes |
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDefaultCapacity | Set the default capacity for a given project.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetOverriddenCapacity | Sets the overridden capacity for the project for the specified week
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
Suspend | Suspend this User account. The effect is immediate ( no need to call the update() method ).
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock | Unlocks this User account. The effect is immediate ( no need to call the update() method ).
Update (inherited from Principal) | Persistently saves the changes to this principal in the server. If the principal is new it will be added, otherwise it will be modified.

See Also

User Class | StarTeam Namespace


User Constructor

Creates a new User account to be activated on the server. The new account will not actually be created until update() is called.

public User(
Server server
);

Parameters

server
the server where the new account is to be created

See Also

User Class | StarTeam Namespace


User Properties

The properties of the User class are listed below. For a complete list of User class members, see the User Members topic.

Public Static Properties

LOGGED_IN_USER

Public Instance Properties

AccessPolicy | [read/write] this account's access policy
AccountStatus | [read] this account's status.
BLSSlipGuid | [read/write] The Slip ID assigned to this license, or 0 if this User does not have a license managed by the Borland License Server.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DistinguishedName | [read/write] the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.
EmailAddress | [read/write] the User's email address.
EnforceSSOAuthentication | [write] Enforce user to login only using Single Sign-On/Multi-Factor Authentication.
FavoriteProjects | [read/write] the User's Favorite Projects.
FaxNumber | [read/write] the User's fax number.
Groups | [read] all of the groups to which this User belongs.
HasFixedLicense | [read/write] True if this User has a fixed ( named-User ) license; false if this User has a floating ( concurrent ) license. Note that if the StarTeam Server does not support floating licenses, then every User has a fixed license.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBuiltIn | [read] true if this is a built in user
IsDeleted (inherited from Principal) | [read] true if the Principal has been deleted.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPrimaryDirectoryService | [read/write] True if this user is in the primary directory service, false if secondary.
IsSSOAuthenticationEnforced | [read] true, if the user is required to login using single sign-on/Multi-factor authentcation. false, if the user can choose to login using password based authentcation or SSO.
LastLogoutTime | [read] The time the user last logged out.
LastWebLogoutTime | [read] The time the user last logged out from the webserver.
LicenseType | [read/write] The type of license assigned to this User.
Logins | [read] a history of logins for this User
LogOnCount | [read] the number of times this User is logged in to the server.
LogOnName | [read/write] the logon name or identifier for this account.
MinimumPasswordLength | [read] the minimum required password length.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name (inherited from Principal) | [read/write] the name of this principal
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
PagerNumber | [read/write] the User's pager number.
Password | [write] Sets the password for this account. The password should be passed in as clear text.
PasswordChangeRequired | [read] true if a password change is required during the current session.
PasswordDaysRemaining | [read] The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.
PhoneNumber | [read/write] the User's phone number.
Picture | [read/write] the Content object used to store a picture of this user
PolicyTimeZoneShift | [read/write] this timezone shift for this account's access policy.
PostalAddress | [read/write] the User's postal address.
PresentationID | [read] the unique integer identifier for this user.
Properties | [read] the properties of the User Type
ReturnEmailAddress | [read/write] the email address to be used for spoofing the mail server
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Territory | [read/write] the Territory this User belongs to
ValidateThroughDirectoryService | [read/write] true if the User validates through Directory Service, otherwise false. This property is supported by server release 6.0 and later; ignored for earlier releases. Note that when setting this value to false, a valid password must also be set.
VoiceMailNumber | [read/write] the User's voice mail number.
WebLogOnCount | [read] the number of times this User is logged in via the webserver.
Workstations | [read] a list of workstation names.

See Also

User Class | StarTeam Namespace


AccessPolicy Property

Borland StarTeam SDK for .NET

User.AccessPolicy Property

[read/write] this account's access policy

public virtual User.LogOnPolicy AccessPolicy {get; set;}

Property Value

this account's access policy

See Also

User Class | StarTeam Namespace


AccountStatus Property

Borland StarTeam SDK for .NET

User.AccountStatus Property

[read] this account's status.

public virtual User.Status AccountStatus {get;}

Property Value

this account's status.

See Also

User Class | StarTeam Namespace


BLSSlipGuid Property

Borland StarTeam SDK for .NET

User.BLSSlipGuid Property

[read/write] The Slip ID assigned to this license, or 0 if this User does not have a license managed by the Borland License Server.

public virtual Int32 BLSSlipGuid {get; set;}

Property Value

The Slip ID assigned to this license, or 0 if this User does not have a license managed by the Borland License Server.

See Also

User Class | StarTeam Namespace


DistinguishedName Property

Borland StarTeam SDK for .NET

User.DistinguishedName Property

[read/write] the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.

public virtual String DistinguishedName {get; set;}

Property Value

the Distinguished Name for Directory Service. This property is supported by server release 6.0 and later; ignored for earlier releases.

See Also

User Class | StarTeam Namespace


EmailAddress Property

Borland StarTeam SDK for .NET

User.EmailAddress Property

[read/write] the User's email address.

public virtual String EmailAddress {get; set;}

Property Value

the User's email address.

See Also

User Class | StarTeam Namespace


EnforceSSOAuthentication Property

Borland StarTeam SDK for .NET

User.EnforceSSOAuthentication Property

[write] Enforce user to login only using Single Sign-On/Multi-Factor Authentication.

public virtual Boolean EnforceSSOAuthentication {set;}

Property Value

Enforce user to login only using Single Sign-On/Multi-Factor Authentication.

See Also

User Class | StarTeam Namespace


FavoriteProjects Property

Borland StarTeam SDK for .NET

User.FavoriteProjects Property

[read/write] the User's Favorite Projects.

public virtual Project[] FavoriteProjects {get; set;}

Property Value

the User's Favorite Projects.

See Also

User Class | StarTeam Namespace


FaxNumber Property

Borland StarTeam SDK for .NET

User.FaxNumber Property

[read/write] the User's fax number.

public virtual String FaxNumber {get; set;}

Property Value

the User's fax number.

See Also

User Class | StarTeam Namespace


Groups Property

Borland StarTeam SDK for .NET

User.Groups Property

[read] all of the groups to which this User belongs.

public virtual Group[] Groups {get;}

Property Value

all of the groups to which this User belongs.

See Also

User Class | StarTeam Namespace


HasFixedLicense Property

Borland StarTeam SDK for .NET

User.HasFixedLicense Property

[read/write] True if this User has a fixed ( named-User ) license; false if this User has a floating ( concurrent ) license. Note that if the StarTeam Server does not support floating licenses, then every User has a fixed license.

public virtual Boolean HasFixedLicense {get; set;}

Property Value

True if this User has a fixed ( named-User ) license; false if this User has a floating ( concurrent ) license. Note that if the StarTeam Server does not support floating licenses, then every User has a fixed license.

See Also

User Class | StarTeam Namespace


IsBuiltIn Property

Borland StarTeam SDK for .NET

User.IsBuiltIn Property

[read] true if this is a built in user

public virtual Boolean IsBuiltIn {get;}

Property Value

true if this is a built in user

See Also

User Class | StarTeam Namespace


IsPrimaryDirectoryService Property

Borland StarTeam SDK for .NET

User.IsPrimaryDirectoryService Property

[read/write] True if this user is in the primary directory service, false if secondary.

public virtual Boolean IsPrimaryDirectoryService {get; set;}

Property Value

True if this user is in the primary directory service, false if secondary.

See Also

User Class | StarTeam Namespace


IsSSOAuthenticationEnforced Property

Borland StarTeam SDK for .NET

User.IsSSOAuthenticationEnforced Property

[read] true, if the user is required to login using single sign-on/Multi-factor authentcation. false, if the user can choose to login using password based authentcation or SSO.

public virtual Boolean IsSSOAuthenticationEnforced {get;}

Property Value

true, if the user is required to login using single sign-on/Multi-factor authentcation. false, if the user can choose to login using password based authentcation or SSO.

See Also

User Class | StarTeam Namespace


LastLogoutTime Property

Borland StarTeam SDK for .NET

User.LastLogoutTime Property

[read] The time the user last logged out.

public virtual DateTime LastLogoutTime {get;}

Property Value

The time the user last logged out.

See Also

User Class | StarTeam Namespace


LastWebLogoutTime Property

Borland StarTeam SDK for .NET

User.LastWebLogoutTime Property

[read] The time the user last logged out from the webserver.

public virtual DateTime LastWebLogoutTime {get;}

Property Value

The time the user last logged out from the webserver.

See Also

User Class | StarTeam Namespace


LicenseType Property

Borland StarTeam SDK for .NET

User.LicenseType Property

[read/write] The type of license assigned to this User.

public virtual User.License LicenseType {get; set;}

Property Value

The type of license assigned to this User.

See Also

User Class | StarTeam Namespace


LOGGED_IN_USER Property

Borland StarTeam SDK for .NET

User.LOGGED_IN_USER Property

public static User LOGGED_IN_USER {get;}

Property Value

The Logged In User.

See Also

User Class | StarTeam Namespace


Logins Property

Borland StarTeam SDK for .NET

User.Logins Property

[read] a history of logins for this User

public virtual LoginHistory[] Logins {get;}

Property Value

a history of logins for this User

See Also

User Class | StarTeam Namespace


LogOnCount Property

Borland StarTeam SDK for .NET

User.LogOnCount Property

[read] the number of times this User is logged in to the server.

public virtual Int32 LogOnCount {get;}

Property Value

the number of times this User is logged in to the server.

See Also

User Class | StarTeam Namespace


LogOnName Property

Borland StarTeam SDK for .NET

User.LogOnName Property

[read/write] the logon name or identifier for this account.

public virtual String LogOnName {get; set;}

Property Value

the logon name or identifier for this account.

See Also

User Class | StarTeam Namespace


MinimumPasswordLength Property

Borland StarTeam SDK for .NET

User.MinimumPasswordLength Property

[read] the minimum required password length.

public virtual Int32 MinimumPasswordLength {get;}

Property Value

the minimum required password length.

See Also

User Class | StarTeam Namespace


PagerNumber Property

Borland StarTeam SDK for .NET

User.PagerNumber Property

[read/write] the User's pager number.

public virtual String PagerNumber {get; set;}

Property Value

the User's pager number.

See Also

User Class | StarTeam Namespace


Password Property

Borland StarTeam SDK for .NET

User.Password Property

[write] Sets the password for this account. The password should be passed in as clear text.

public virtual String Password {set;}

Property Value

Sets the password for this account. The password should be passed in as clear text.

See Also

User Class | StarTeam Namespace


PasswordChangeRequired Property

Borland StarTeam SDK for .NET

User.PasswordChangeRequired Property

[read] true if a password change is required during the current session.

public virtual Boolean PasswordChangeRequired {get;}

Property Value

true if a password change is required during the current session.

See Also

User Class | StarTeam Namespace


PasswordDaysRemaining Property

Borland StarTeam SDK for .NET

User.PasswordDaysRemaining Property

[read] The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.

public virtual Int32 PasswordDaysRemaining {get;}

Property Value

The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.

See Also

User Class | StarTeam Namespace


PhoneNumber Property

Borland StarTeam SDK for .NET

User.PhoneNumber Property

[read/write] the User's phone number.

public virtual String PhoneNumber {get; set;}

Property Value

the User's phone number.

See Also

User Class | StarTeam Namespace


Picture Property

Borland StarTeam SDK for .NET

User.Picture Property

[read/write] the Content object used to store a picture of this user

public virtual Content Picture {get; set;}

Property Value

the Content object used to store a picture of this user

See Also

User Class | StarTeam Namespace


PolicyTimeZoneShift Property

Borland StarTeam SDK for .NET

User.PolicyTimeZoneShift Property

[read/write] this timezone shift for this account's access policy.

public virtual Int32 PolicyTimeZoneShift {get; set;}

Property Value

this timezone shift for this account's access policy.

See Also

User Class | StarTeam Namespace


PostalAddress Property

Borland StarTeam SDK for .NET

User.PostalAddress Property

[read/write] the User's postal address.

public virtual String PostalAddress {get; set;}

Property Value

the User's postal address.

See Also

User Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

User.PresentationID Property

[read] the unique integer identifier for this user.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this user.

See Also

User Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

User.Properties Property

[read] the properties of the User Type

public virtual User.Type.PropertyCollection Properties {get;}

Property Value

the properties of the User Type

See Also

User Class | StarTeam Namespace


ReturnEmailAddress Property

Borland StarTeam SDK for .NET

User.ReturnEmailAddress Property

[read/write] the email address to be used for spoofing the mail server

public virtual String ReturnEmailAddress {get; set;}

Property Value

the email address to be used for spoofing the mail server

See Also

User Class | StarTeam Namespace


Territory Property

Borland StarTeam SDK for .NET

User.Territory Property

[read/write] the Territory this User belongs to

public virtual User.GeographicTerritory Territory {get; set;}

Property Value

the Territory this User belongs to

See Also

User Class | StarTeam Namespace


ValidateThroughDirectoryService Property

Borland StarTeam SDK for .NET

User.ValidateThroughDirectoryService Property

[read/write] true if the User validates through Directory Service, otherwise false. This property is supported by server release 6.0 and later; ignored for earlier releases. Note that when setting this value to false, a valid password must also be set.

public virtual Boolean ValidateThroughDirectoryService {get; set;}

Property Value

true if the User validates through Directory Service, otherwise false. This property is supported by server release 6.0 and later; ignored for earlier releases. Note that when setting this value to false, a valid password must also be set.

See Also

User Class | StarTeam Namespace


VoiceMailNumber Property

Borland StarTeam SDK for .NET

User.VoiceMailNumber Property

[read/write] the User's voice mail number.

public virtual String VoiceMailNumber {get; set;}

Property Value

the User's voice mail number.

See Also

User Class | StarTeam Namespace


WebLogOnCount Property

Borland StarTeam SDK for .NET

User.WebLogOnCount Property

[read] the number of times this User is logged in via the webserver.

public virtual Int32 WebLogOnCount {get;}

Property Value

the number of times this User is logged in via the webserver.

See Also

User Class | StarTeam Namespace


Workstations Property

Borland StarTeam SDK for .NET

User.Workstations Property

[read] a list of workstation names.

public virtual String[] Workstations {get;}

Property Value

a list of workstation names.

See Also

User Class | StarTeam Namespace


User Methods

The methods of the User class are listed below. For a complete list of User class members, see the User Members topic.

Public Instance Methods

AddTo | Adds this User to the specified group. The group cannot be null, must be from the same server as the User and the group account must have already been created on the server. You must call update() to save the changes on the server.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this User object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
ForceLogoff | Forces this User account to be logged off from the server. The effect is immediate ( no need to call the update() method ).
ForcePasswordChange | Forces a password change for this User account. The effect is immediate ( no need to call the update() method ).
GetAccessEndTime1 |
GetAccessEndTime2 |
GetAccessStartTime1 |
GetAccessStartTime2 |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCapacityOverriddenOn | Returns the set of dates for which capacities have been overridden
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDefaultCapacity | Returns the default capacity assigned to a specific project
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetOverriddenCapacity | Return the overridden capacity for the project for the specified week
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasDefaultCapacity | Returns true if this user has a default capacity assigned to a specific project
HasOverriddenCapacity | return true if the default capacity is overwritten for a specified week the date will typically be specified as a Monday, implying the week coverage
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares two User objects.
IsMemberOf | Determines whether or not this user is a member of the given group. note that membership is implied, i.e. a user is considered to be a member of the entire tree of parent groups of the group(s) that the user was explicitly added to
Reactivate | Reactivates this User account. The effect is immediate ( no need to call the update() method ).
Remove (inherited from Principal) | Removes this principal from the StarTeam server, plus any direct or indirect members of this principal.
RemoveFrom | Removes this User from the specified group. The group cannot be null, must be from the same server as the User and the group account must have already been created on the server. You must call update() to save the changes on the server.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetAccessTimes |
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDefaultCapacity | Set the default capacity for a given project.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetOverriddenCapacity | Sets the overridden capacity for the project for the specified week
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
Suspend | Suspend this User account. The effect is immediate ( no need to call the update() method ).
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock | Unlocks this User account. The effect is immediate ( no need to call the update() method ).
Update (inherited from Principal) | Persistently saves the changes to this principal in the server. If the principal is new it will be added, otherwise it will be modified.

See Also

User Class | StarTeam Namespace


User.AddTo Method

Adds this User to the specified group. The group cannot be null, must be from the same server as the User and the group account must have already been created on the server. You must call update() to save the changes on the server.

public virtual void AddTo(
Group group
);

Parameters

group
the group to which this User will be added.

See Also

User Class | StarTeam Namespace


User.Copy Method

Creates a copy of this User object. Useful to applications that want to save a snapshot of the account information in a given state, for example, before calling ServerAdministration.refreshAccounts().

public virtual User Copy();

Return Value

A new copy of this User object.

See Also

User Class | StarTeam Namespace | isEqualTo


User.ForceLogoff Method

Forces this User account to be logged off from the server. The effect is immediate ( no need to call the update() method ).

public virtual void ForceLogoff();

See Also

User Class | StarTeam Namespace | getAccountStatus


User.ForcePasswordChange Method

Forces a password change for this User account. The effect is immediate ( no need to call the update() method ).

public virtual void ForcePasswordChange();

See Also

User Class | StarTeam Namespace


User.GetAccessEndTime1 Method

public virtual int GetAccessEndTime1(
User.DayOfWeek dayOfWeek
);

See Also

User Class | StarTeam Namespace


User.GetAccessEndTime2 Method

public virtual int GetAccessEndTime2(
User.DayOfWeek dayOfWeek
);

See Also

User Class | StarTeam Namespace


User.GetAccessStartTime1 Method

public virtual int GetAccessStartTime1(
User.DayOfWeek dayOfWeek
);

See Also

User Class | StarTeam Namespace


User.GetAccessStartTime2 Method

public virtual int GetAccessStartTime2(
User.DayOfWeek dayOfWeek
);

See Also

User Class | StarTeam Namespace


User.GetCapacityOverriddenOn Method

Returns the set of dates for which capacities have been overridden

public virtual Date[] GetCapacityOverriddenOn(
Project p
);

Parameters

p
the project to test for

Return Value

the set of dates for which capacities have been overridden

See Also

User Class | StarTeam Namespace


User.GetDefaultCapacity Method

Returns the default capacity assigned to a specific project

public virtual double GetDefaultCapacity(
Project p
);

Parameters

p
the project

Return Value

the default capacity assigned to this project or -1 if there is no default capacity

See Also

User Class | StarTeam Namespace


User.GetOverriddenCapacity Method

Return the overridden capacity for the project for the specified week

public virtual double GetOverriddenCapacity(
Project p,
Date d
);

Parameters

p
the project
d
the Monday of the week

Return Value

the capacity for the week or -1 if there is no capacity override

See Also

User Class | StarTeam Namespace


User.HasDefaultCapacity Method

Returns true if this user has a default capacity assigned to a specific project

public virtual bool HasDefaultCapacity(
Project p
);

Parameters

p
the project to test against

Return Value

true if this user has a default capacity assigned to the project

See Also

User Class | StarTeam Namespace


User.HasOverriddenCapacity Method

return true if the default capacity is overwritten for a specified week the date will typically be specified as a Monday, implying the week coverage

public virtual bool HasOverriddenCapacity(
Project p,
Date d
);

Parameters

p
the project
d
the Monday of the week

Return Value

true if the default capacity is overridden for the week

See Also

User Class | StarTeam Namespace


User.IsEqualTo Method

Compares two User objects.

public virtual bool IsEqualTo(
User account
);

Parameters

account
The User to be compared with this one.

Return Value

true if no differences were found.

See Also

User Class | StarTeam Namespace | copy


User.IsMemberOf Method

Determines whether or not this user is a member of the given group. note that membership is implied, i.e. a user is considered to be a member of the entire tree of parent groups of the group(s) that the user was explicitly added to

public virtual bool IsMemberOf(
Group group
);

Parameters

group
The group to be tested.

Return Value

true if this user is a member of the given group; false otherwise.

See Also

User Class | StarTeam Namespace


User.Reactivate Method

Reactivates this User account. The effect is immediate ( no need to call the update() method ).

public virtual void Reactivate();

See Also

User Class | StarTeam Namespace | getAccountStatus


User.RemoveFrom Method

Removes this User from the specified group. The group cannot be null, must be from the same server as the User and the group account must have already been created on the server. You must call update() to save the changes on the server.

public virtual void RemoveFrom(
Group group
);

Parameters

group
the group from which this User will be removed.

See Also

User Class | StarTeam Namespace


User.SetAccessTimes Method

public virtual void SetAccessTimes(
User.DayOfWeek dayOfWeek,
Int32 start1,
Int32 end1,
Int32 start2,
Int32 end2
);

See Also

User Class | StarTeam Namespace


User.SetDefaultCapacity Method

Set the default capacity for a given project.

public virtual void SetDefaultCapacity(
Project p,
Double capacity
);

Parameters

p
the project
capacity
the default capacity to be assigned to this project

See Also

User Class | StarTeam Namespace


User.SetOverriddenCapacity Method

Sets the overridden capacity for the project for the specified week

public virtual void SetOverriddenCapacity(
Project p,
Date d,
Double capacity
);

Parameters

p
the project
d
the Monday of the week
capacity
the capacity for the week

See Also

User Class | StarTeam Namespace


User.Suspend Method

Suspend this User account. The effect is immediate ( no need to call the update() method ).

public virtual void Suspend();

See Also

User Class | StarTeam Namespace | getAccountStatus


User.Unlock Method

Unlocks this User account. The effect is immediate ( no need to call the update() method ).

public virtual void Unlock();

See Also

User Class | StarTeam Namespace


User.DayOfWeek Class

The day of week

For a list of all members of this type, see User.DayOfWeek Members.

System.Object
User.DayOfWeek

public class User.DayOfWeek

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.DayOfWeek Members | StarTeam Namespace


User.DayOfWeek Members

User.DayOfWeek overview

Public Static Properties

ALL
FRIDAY
MONDAY
SATURDAY
SUNDAY
THURSDAY
TUESDAY
WEDNESDAY

Public Static Methods

FromID Gets the DayOfWeek value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this DayOfWeek value.
Name | [read] the friendly name for the day

Public Instance Methods

Equals | Delegate Equals() to com.starteam.User.DayOfWeek.
GetHashCode | Delegate GetHashCode() to com.starteam.User.DayOfWeek.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.User.DayOfWeek.

See Also

User.DayOfWeek Class | StarTeam Namespace


User.DayOfWeek Properties

The properties of the User.DayOfWeek class are listed below. For a complete list of User.DayOfWeek class members, see the User.DayOfWeek Members topic.

Public Static Properties

ALL
FRIDAY
MONDAY
SATURDAY
SUNDAY
THURSDAY
TUESDAY
WEDNESDAY

Public Instance Properties

ID | [read] The ID of this DayOfWeek value.
Name | [read] the friendly name for the day

See Also

User.DayOfWeek Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

User.DayOfWeek.ALL Property

public static DayOfWeek[] ALL {get;}

See Also

User.DayOfWeek Class | StarTeam Namespace


FRIDAY Property

Borland StarTeam SDK for .NET

User.DayOfWeek.FRIDAY Property

public static User.DayOfWeek FRIDAY {get;}

Property Value

Friday

See Also

User.DayOfWeek Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

User.DayOfWeek.ID Property

[read] The ID of this DayOfWeek value.

public virtual Int32 ID {get;}

Property Value

The ID of this DayOfWeek value.

See Also

User.DayOfWeek Class | StarTeam Namespace


MONDAY Property

Borland StarTeam SDK for .NET

User.DayOfWeek.MONDAY Property

public static User.DayOfWeek MONDAY {get;}

Property Value

Monday

See Also

User.DayOfWeek Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

User.DayOfWeek.Name Property

[read] the friendly name for the day

public virtual String Name {get;}

Property Value

the friendly name for the day

See Also

User.DayOfWeek Class | StarTeam Namespace


SATURDAY Property

Borland StarTeam SDK for .NET

User.DayOfWeek.SATURDAY Property

public static User.DayOfWeek SATURDAY {get;}

Property Value

Saturday

See Also

User.DayOfWeek Class | StarTeam Namespace


SUNDAY Property

Borland StarTeam SDK for .NET

User.DayOfWeek.SUNDAY Property

public static User.DayOfWeek SUNDAY {get;}

Property Value

Sunday

See Also

User.DayOfWeek Class | StarTeam Namespace


THURSDAY Property

Borland StarTeam SDK for .NET

User.DayOfWeek.THURSDAY Property

public static User.DayOfWeek THURSDAY {get;}

Property Value

Thursday

See Also

User.DayOfWeek Class | StarTeam Namespace


TUESDAY Property

Borland StarTeam SDK for .NET

User.DayOfWeek.TUESDAY Property

public static User.DayOfWeek TUESDAY {get;}

Property Value

Tuesday

See Also

User.DayOfWeek Class | StarTeam Namespace


WEDNESDAY Property

Borland StarTeam SDK for .NET

User.DayOfWeek.WEDNESDAY Property

public static User.DayOfWeek WEDNESDAY {get;}

Property Value

Wednesday

See Also

User.DayOfWeek Class | StarTeam Namespace


User.DayOfWeek Methods

The methods of the User.DayOfWeek class are listed below. For a complete list of User.DayOfWeek class members, see the User.DayOfWeek Members topic.

Public Static Methods

FromID Gets the DayOfWeek value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.User.DayOfWeek.
GetHashCode | Delegate GetHashCode() to com.starteam.User.DayOfWeek.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.User.DayOfWeek.

See Also

User.DayOfWeek Class | StarTeam Namespace


User.DayOfWeek.Equals Method

Delegate Equals() to com.starteam.User.DayOfWeek.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.DayOfWeek.Equals(obj).

See Also

User.DayOfWeek Class | StarTeam Namespace


User.DayOfWeek.FromID Method

Gets the DayOfWeek value corresponding to the given ID.

public static DayOfWeek FromID(
Int32 id
);

Parameters

id
A DayOfWeek ID.

Return Value

The corresponding DayOfWeek value, or null.

See Also

User.DayOfWeek Class | StarTeam Namespace


User.DayOfWeek.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.DayOfWeek.

public override int GetHashCode();

Return Value

com.starteam.User.DayOfWeek.GetHashCode().

See Also

User.DayOfWeek Class | StarTeam Namespace


User.DayOfWeek.ToString Method

Delegate ToString() to com.starteam.User.DayOfWeek.

public override string ToString();

Return Value

com.starteam.User.DayOfWeek.ToString()

See Also

User.DayOfWeek Class | StarTeam Namespace


User.GeographicTerritory Class

The accessible territory for the logged in User Account.

For a list of all members of this type, see User.GeographicTerritory Members.

System.Object
EnumeratedValue
User.GeographicTerritory

public class User.GeographicTerritory : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.GeographicTerritory Members | StarTeam Namespace


User.GeographicTerritory Members

User.GeographicTerritory overview

Public Static Properties

ALL
AMERICAS
ASIA
EUROPE
UNASSIGNED

Public Static Methods

FromID Gets the GeographicTerritory value corresponding to the given ID.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Territory.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.User.GeographicTerritory.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.User.GeographicTerritory.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.User.GeographicTerritory.

See Also

User.GeographicTerritory Class | StarTeam Namespace


User.GeographicTerritory Properties

The properties of the User.GeographicTerritory class are listed below. For a complete list of User.GeographicTerritory class members, see the User.GeographicTerritory Members topic.

Public Static Properties

ALL
AMERICAS
ASIA
EUROPE
UNASSIGNED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Territory.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

User.GeographicTerritory Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

User.GeographicTerritory.ALL Property

public static GeographicTerritory[] ALL {get;}

See Also

User.GeographicTerritory Class | StarTeam Namespace


AMERICAS Property

Borland StarTeam SDK for .NET

User.GeographicTerritory.AMERICAS Property

public static User.GeographicTerritory AMERICAS {get;}

Property Value

Americas

See Also

User.GeographicTerritory Class | StarTeam Namespace


ASIA Property

Borland StarTeam SDK for .NET

User.GeographicTerritory.ASIA Property

public static User.GeographicTerritory ASIA {get;}

Property Value

Asia

See Also

User.GeographicTerritory Class | StarTeam Namespace


EUROPE Property

Borland StarTeam SDK for .NET

User.GeographicTerritory.EUROPE Property

public static User.GeographicTerritory EUROPE {get;}

Property Value

Europe

See Also

User.GeographicTerritory Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

User.GeographicTerritory.ID Property

[read] The ID of this Territory.

public virtual Int32 ID {get;}

Property Value

The ID of this Territory.

See Also

User.GeographicTerritory Class | StarTeam Namespace


UNASSIGNED Property

Borland StarTeam SDK for .NET

User.GeographicTerritory.UNASSIGNED Property

public static User.GeographicTerritory UNASSIGNED {get;}

Property Value

Territory has not yet been assigned

See Also

User.GeographicTerritory Class | StarTeam Namespace


User.GeographicTerritory Methods

The methods of the User.GeographicTerritory class are listed below. For a complete list of User.GeographicTerritory class members, see the User.GeographicTerritory Members topic.

Public Static Methods

FromID Gets the GeographicTerritory value corresponding to the given ID.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.User.GeographicTerritory.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.User.GeographicTerritory.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.User.GeographicTerritory.

See Also

User.GeographicTerritory Class | StarTeam Namespace


User.GeographicTerritory.Equals Method

Delegate Equals() to com.starteam.User.GeographicTerritory.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.GeographicTerritory.Equals(obj).

See Also

User.GeographicTerritory Class | StarTeam Namespace


User.GeographicTerritory.FromID Method

Gets the GeographicTerritory value corresponding to the given ID.

public static GeographicTerritory FromID(
Int32 id
);

Parameters

id
A GeographicTerritory ID.

Return Value

The corresponding GeographicTerritory value, or null.

See Also

User.GeographicTerritory Class | StarTeam Namespace


User.GeographicTerritory.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.GeographicTerritory.

public override int GetHashCode();

Return Value

com.starteam.User.GeographicTerritory.GetHashCode().

See Also

User.GeographicTerritory Class | StarTeam Namespace


User.GeographicTerritory.ToString Method

Delegate ToString() to com.starteam.User.GeographicTerritory.

public override string ToString();

Return Value

com.starteam.User.GeographicTerritory.ToString()

See Also

User.GeographicTerritory Class | StarTeam Namespace


User.License Class

The current license .

For a list of all members of this type, see User.License Members.

System.Object
EnumeratedValue
User.License

public class User.License : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.License Members | StarTeam Namespace


User.License Members

User.License overview

Public Static Properties

ALL
AUTO_PASS_LICENSE_SERVER
LICENSE_SERVER
STARTEAM
UNASSIGNED

Public Static Methods

FromID Gets the LicenseType value corresponding to the given ID.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this License.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.User.License.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.User.License.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.User.License.

See Also

User.License Class | StarTeam Namespace


User.License Properties

The properties of the User.License class are listed below. For a complete list of User.License class members, see the User.License Members topic.

Public Static Properties

ALL
AUTO_PASS_LICENSE_SERVER
LICENSE_SERVER
STARTEAM
UNASSIGNED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this License.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

User.License Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

User.License.ALL Property

public static License[] ALL {get;}

See Also

User.License Class | StarTeam Namespace


AUTO_PASS_LICENSE_SERVER Property

Borland StarTeam SDK for .NET

User.License.AUTO_PASS_LICENSE_SERVER Property

public static User.License AUTO_PASS_LICENSE_SERVER {get;}

Property Value

AutoPass License Server.

See Also

User.License Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

User.License.ID Property

[read] The ID of this License.

public virtual Int32 ID {get;}

Property Value

The ID of this License.

See Also

User.License Class | StarTeam Namespace


LICENSE_SERVER Property

Borland StarTeam SDK for .NET

User.License.LICENSE_SERVER Property

public static User.License LICENSE_SERVER {get;}

Property Value

Borland License Server (BLS and BLS licenses are provided through Embarcadero Software)

See Also

User.License Class | StarTeam Namespace


STARTEAM Property

Borland StarTeam SDK for .NET

User.License.STARTEAM Property

public static User.License STARTEAM {get;}

Property Value

StarTeam

See Also

User.License Class | StarTeam Namespace


UNASSIGNED Property

Borland StarTeam SDK for .NET

User.License.UNASSIGNED Property

public static User.License UNASSIGNED {get;}

Property Value

License Unassigned

See Also

User.License Class | StarTeam Namespace


User.License Methods

The methods of the User.License class are listed below. For a complete list of User.License class members, see the User.License Members topic.

Public Static Methods

FromID Gets the LicenseType value corresponding to the given ID.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.User.License.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.User.License.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.User.License.

See Also

User.License Class | StarTeam Namespace


User.License.Equals Method

Delegate Equals() to com.starteam.User.License.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.License.Equals(obj).

See Also

User.License Class | StarTeam Namespace


User.License.FromID Method

Gets the LicenseType value corresponding to the given ID.

public static License FromID(
Int32 id
);

Parameters

id
A LicenseType ID.

Return Value

The corresponding LicenseType value, or null.

See Also

User.License Class | StarTeam Namespace


User.License.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.License.

public override int GetHashCode();

Return Value

com.starteam.User.License.GetHashCode().

See Also

User.License Class | StarTeam Namespace


User.License.ToString Method

Delegate ToString() to com.starteam.User.License.

public override string ToString();

Return Value

com.starteam.User.License.ToString()

See Also

User.License Class | StarTeam Namespace


User.LoginHistory Class

A history of User logins introduced with the 12.0 server release

For a list of all members of this type, see User.LoginHistory Members.

System.Object
User.LoginHistory

public class User.LoginHistory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.LoginHistory Members | StarTeam Namespace


User.LoginHistory Members

User.LoginHistory overview

Public Instance Properties

LastAccess | [read] the date and time the User accessed the server
LoginTime | [read] the date and time the User logged in
Workstation | [read] the workstation used to login

Public Instance Methods

Equals | Delegate Equals() to com.starteam.User.LoginHistory.
GetHashCode | Delegate GetHashCode() to com.starteam.User.LoginHistory.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.User.LoginHistory.

See Also

User.LoginHistory Class | StarTeam Namespace


User.LoginHistory Properties

The properties of the User.LoginHistory class are listed below. For a complete list of User.LoginHistory class members, see the User.LoginHistory Members topic.

Public Instance Properties

LastAccess | [read] the date and time the User accessed the server
LoginTime | [read] the date and time the User logged in
Workstation | [read] the workstation used to login

See Also

User.LoginHistory Class | StarTeam Namespace


LastAccess Property

Borland StarTeam SDK for .NET

User.LoginHistory.LastAccess Property

[read] the date and time the User accessed the server

public virtual DateTime LastAccess {get;}

Property Value

the date and time the User accessed the server

See Also

User.LoginHistory Class | StarTeam Namespace


LoginTime Property

Borland StarTeam SDK for .NET

User.LoginHistory.LoginTime Property

[read] the date and time the User logged in

public virtual DateTime LoginTime {get;}

Property Value

the date and time the User logged in

See Also

User.LoginHistory Class | StarTeam Namespace


Workstation Property

Borland StarTeam SDK for .NET

User.LoginHistory.Workstation Property

[read] the workstation used to login

public virtual String Workstation {get;}

Property Value

the workstation used to login

See Also

User.LoginHistory Class | StarTeam Namespace


User.LoginHistory Methods

The methods of the User.LoginHistory class are listed below. For a complete list of User.LoginHistory class members, see the User.LoginHistory Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.User.LoginHistory.
GetHashCode | Delegate GetHashCode() to com.starteam.User.LoginHistory.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.User.LoginHistory.

See Also

User.LoginHistory Class | StarTeam Namespace


User.LoginHistory.Equals Method

Delegate Equals() to com.starteam.User.LoginHistory.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.LoginHistory.Equals(obj).

See Also

User.LoginHistory Class | StarTeam Namespace


User.LoginHistory.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.LoginHistory.

public override int GetHashCode();

Return Value

com.starteam.User.LoginHistory.GetHashCode().

See Also

User.LoginHistory Class | StarTeam Namespace


User.LoginHistory.ToString Method

Delegate ToString() to com.starteam.User.LoginHistory.

public override string ToString();

Return Value

com.starteam.User.LoginHistory.ToString()

See Also

User.LoginHistory Class | StarTeam Namespace


User.LogOnPolicy Class

The current logon access policy of the User Account.

For a list of all members of this type, see User.LogOnPolicy Members.

System.Object
User.LogOnPolicy

public class User.LogOnPolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.LogOnPolicy Members | StarTeam Namespace


User.LogOnPolicy Members

User.LogOnPolicy overview

Public Static Properties

ALL
ALWAYS
CUSTOM
STANDARD

Public Static Methods

FromID Gets the Policy value corresponding to the given ID.

Public Instance Properties

ID | [read] The ID of this Policy.
Name | [read] a friendly name for this logon policy

Public Instance Methods

Equals | Delegate Equals() to com.starteam.User.LogOnPolicy.
GetHashCode | Delegate GetHashCode() to com.starteam.User.LogOnPolicy.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.User.LogOnPolicy.

See Also

User.LogOnPolicy Class | StarTeam Namespace


User.LogOnPolicy Properties

The properties of the User.LogOnPolicy class are listed below. For a complete list of User.LogOnPolicy class members, see the User.LogOnPolicy Members topic.

Public Static Properties

ALL
ALWAYS
CUSTOM
STANDARD

Public Instance Properties

ID | [read] The ID of this Policy.
Name | [read] a friendly name for this logon policy

See Also

User.LogOnPolicy Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

User.LogOnPolicy.ALL Property

public static LogOnPolicy[] ALL {get;}

See Also

User.LogOnPolicy Class | StarTeam Namespace


ALWAYS Property

Borland StarTeam SDK for .NET

User.LogOnPolicy.ALWAYS Property

public static User.LogOnPolicy ALWAYS {get;}

Property Value

Always Allowed to Access

See Also

User.LogOnPolicy Class | StarTeam Namespace


CUSTOM Property

Borland StarTeam SDK for .NET

User.LogOnPolicy.CUSTOM Property

public static User.LogOnPolicy CUSTOM {get;}

Property Value

Custom Access Policy

See Also

User.LogOnPolicy Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

User.LogOnPolicy.ID Property

[read] The ID of this Policy.

public virtual Int32 ID {get;}

Property Value

The ID of this Policy.

See Also

User.LogOnPolicy Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

User.LogOnPolicy.Name Property

[read] a friendly name for this logon policy

public virtual String Name {get;}

Property Value

a friendly name for this logon policy

See Also

User.LogOnPolicy Class | StarTeam Namespace


STANDARD Property

Borland StarTeam SDK for .NET

User.LogOnPolicy.STANDARD Property

public static User.LogOnPolicy STANDARD {get;}

Property Value

Standard Access Policy

See Also

User.LogOnPolicy Class | StarTeam Namespace


User.LogOnPolicy Methods

The methods of the User.LogOnPolicy class are listed below. For a complete list of User.LogOnPolicy class members, see the User.LogOnPolicy Members topic.

Public Static Methods

FromID Gets the Policy value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.User.LogOnPolicy.
GetHashCode | Delegate GetHashCode() to com.starteam.User.LogOnPolicy.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.User.LogOnPolicy.

See Also

User.LogOnPolicy Class | StarTeam Namespace


User.LogOnPolicy.Equals Method

Delegate Equals() to com.starteam.User.LogOnPolicy.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.LogOnPolicy.Equals(obj).

See Also

User.LogOnPolicy Class | StarTeam Namespace


User.LogOnPolicy.FromID Method

Gets the Policy value corresponding to the given ID.

public static LogOnPolicy FromID(
Int32 id
);

Parameters

id
A Policy ID.

Return Value

The corresponding Policy value, or null.

See Also

User.LogOnPolicy Class | StarTeam Namespace


User.LogOnPolicy.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.LogOnPolicy.

public override int GetHashCode();

Return Value

com.starteam.User.LogOnPolicy.GetHashCode().

See Also

User.LogOnPolicy Class | StarTeam Namespace


User.LogOnPolicy.ToString Method

Delegate ToString() to com.starteam.User.LogOnPolicy.

public override string ToString();

Return Value

com.starteam.User.LogOnPolicy.ToString()

See Also

User.LogOnPolicy Class | StarTeam Namespace


User.Status Class

The current status of the User Account.

For a list of all members of this type, see User.Status Members.

System.Object
EnumeratedValue
User.Status

public class User.Status : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Status Members | StarTeam Namespace


User.Status Members

User.Status overview

Public Static Properties

ALL
LOCKED_OUT
NORMAL
PASSWORD_CHANGE_NOTIFIED
PASSWORD_CHANGE_REQUIRED
SUSPENDED

Public Static Methods

FromID Gets the Status value corresponding to the given ID.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.User.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.User.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.User.Status.

See Also

User.Status Class | StarTeam Namespace


User.Status Properties

The properties of the User.Status class are listed below. For a complete list of User.Status class members, see the User.Status Members topic.

Public Static Properties

ALL
LOCKED_OUT
NORMAL
PASSWORD_CHANGE_NOTIFIED
PASSWORD_CHANGE_REQUIRED
SUSPENDED

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Status value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

User.Status Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

User.Status.ALL Property

public static Status[] ALL {get;}

See Also

User.Status Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

User.Status.ID Property

[read] The ID of this Status value.

public virtual Int32 ID {get;}

Property Value

The ID of this Status value.

See Also

User.Status Class | StarTeam Namespace


LOCKED_OUT Property

Borland StarTeam SDK for .NET

User.Status.LOCKED_OUT Property

public static User.Status LOCKED_OUT {get;}

Property Value

Locked Out

See Also

User.Status Class | StarTeam Namespace


NORMAL Property

Borland StarTeam SDK for .NET

User.Status.NORMAL Property

public static User.Status NORMAL {get;}

Property Value

Normal

See Also

User.Status Class | StarTeam Namespace


PASSWORD_CHANGE_NOTIFIED Property

Borland StarTeam SDK for .NET

User.Status.PASSWORD_CHANGE_NOTIFIED Property

public static User.Status PASSWORD_CHANGE_NOTIFIED {get;}

Property Value

Password Change Notified

See Also

User.Status Class | StarTeam Namespace


PASSWORD_CHANGE_REQUIRED Property

Borland StarTeam SDK for .NET

User.Status.PASSWORD_CHANGE_REQUIRED Property

public static User.Status PASSWORD_CHANGE_REQUIRED {get;}

Property Value

password Change Required

See Also

User.Status Class | StarTeam Namespace


SUSPENDED Property

Borland StarTeam SDK for .NET

User.Status.SUSPENDED Property

public static User.Status SUSPENDED {get;}

Property Value

Suspended

See Also

User.Status Class | StarTeam Namespace


User.Status Methods

The methods of the User.Status class are listed below. For a complete list of User.Status class members, see the User.Status Members topic.

Public Static Methods

FromID Gets the Status value corresponding to the given ID.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.User.Status.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.User.Status.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.User.Status.

See Also

User.Status Class | StarTeam Namespace


User.Status.Equals Method

Delegate Equals() to com.starteam.User.Status.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Status.Equals(obj).

See Also

User.Status Class | StarTeam Namespace


User.Status.FromID Method

Gets the Status value corresponding to the given ID.

public static Status FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

User.Status Class | StarTeam Namespace


User.Status.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Status.

public override int GetHashCode();

Return Value

com.starteam.User.Status.GetHashCode().

See Also

User.Status Class | StarTeam Namespace


User.Status.ToString Method

Delegate ToString() to com.starteam.User.Status.

public override string ToString();

Return Value

com.starteam.User.Status.ToString()

See Also

User.Status Class | StarTeam Namespace


User.Type Class

The Type of the User

For a list of all members of this type, see User.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
Principal.Type
User.Type

new public class User.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type Members | StarTeam Namespace


User.Type Members

User.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.User.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.User.Type.

See Also

User.Type Class | StarTeam Namespace


User.Type Properties

The properties of the User.Type class are listed below. For a complete list of User.Type class members, see the User.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

User.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.NAME Property

public static String NAME {get;}

See Also

User.Type Class | StarTeam Namespace


User.Type Methods

The methods of the User.Type class are listed below. For a complete list of User.Type class members, see the User.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.User.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.User.Type.

See Also

User.Type Class | StarTeam Namespace


User.Type.Equals Method

Delegate Equals() to com.starteam.User.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.Equals(obj).

See Also

User.Type Class | StarTeam Namespace


User.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.

public override int GetHashCode();

Return Value

com.starteam.User.Type.GetHashCode().

See Also

User.Type Class | StarTeam Namespace


User.Type.ToString Method

Delegate ToString() to com.starteam.User.Type.

public override string ToString();

Return Value

com.starteam.User.Type.ToString()

See Also

User.Type Class | StarTeam Namespace


User.Type.AccessRestrictionProperty Class

The property type of the Access Restriction property.

For a list of all members of this type, see User.Type.AccessRestrictionProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
User.Type.AccessRestrictionProperty

public class User.Type.AccessRestrictionProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.AccessRestrictionProperty Members | StarTeam Namespace


User.Type.AccessRestrictionProperty Members

User.Type.AccessRestrictionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.AccessRestrictionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.AccessRestrictionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.AccessRestrictionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.AccessRestrictionProperty Class | StarTeam Namespace


User.Type.AccessRestrictionProperty Properties

The properties of the User.Type.AccessRestrictionProperty class are listed below. For a complete list of User.Type.AccessRestrictionProperty class members, see the User.Type.AccessRestrictionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.AccessRestrictionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.AccessRestrictionProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.AccessRestrictionProperty Class | StarTeam Namespace


User.Type.AccessRestrictionProperty Methods

The methods of the User.Type.AccessRestrictionProperty class are listed below. For a complete list of User.Type.AccessRestrictionProperty class members, see the User.Type.AccessRestrictionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.AccessRestrictionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.AccessRestrictionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.AccessRestrictionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.AccessRestrictionProperty Class | StarTeam Namespace


User.Type.AccessRestrictionProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.AccessRestrictionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.AccessRestrictionProperty.Equals(obj).

See Also

User.Type.AccessRestrictionProperty Class | StarTeam Namespace


User.Type.AccessRestrictionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.AccessRestrictionProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.AccessRestrictionProperty.GetHashCode().

See Also

User.Type.AccessRestrictionProperty Class | StarTeam Namespace


User.Type.AccessRestrictionProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.AccessRestrictionProperty.

public override string ToString();

Return Value

com.starteam.User.Type.AccessRestrictionProperty.ToString()

See Also

User.Type.AccessRestrictionProperty Class | StarTeam Namespace


User.Type.AddressProperty Class

The property type of the Address property.

For a list of all members of this type, see User.Type.AddressProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.AddressProperty

public class User.Type.AddressProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.AddressProperty Members | StarTeam Namespace


User.Type.AddressProperty Members

User.Type.AddressProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.AddressProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.AddressProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.AddressProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.AddressProperty Class | StarTeam Namespace


User.Type.AddressProperty Properties

The properties of the User.Type.AddressProperty class are listed below. For a complete list of User.Type.AddressProperty class members, see the User.Type.AddressProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.AddressProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.AddressProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.AddressProperty Class | StarTeam Namespace


User.Type.AddressProperty Methods

The methods of the User.Type.AddressProperty class are listed below. For a complete list of User.Type.AddressProperty class members, see the User.Type.AddressProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.AddressProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.AddressProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.AddressProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.AddressProperty Class | StarTeam Namespace


User.Type.AddressProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.AddressProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.AddressProperty.Equals(obj).

See Also

User.Type.AddressProperty Class | StarTeam Namespace


User.Type.AddressProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.AddressProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.AddressProperty.GetHashCode().

See Also

User.Type.AddressProperty Class | StarTeam Namespace


User.Type.AddressProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.AddressProperty.

public override string ToString();

Return Value

com.starteam.User.Type.AddressProperty.ToString()

See Also

User.Type.AddressProperty Class | StarTeam Namespace


User.Type.DirectoryServiceIDProperty Class

The property type of the Last Logout Time property.

For a list of all members of this type, see User.Type.DirectoryServiceIDProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
User.Type.DirectoryServiceIDProperty

public class User.Type.DirectoryServiceIDProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.DirectoryServiceIDProperty Members | StarTeam Namespace


User.Type.DirectoryServiceIDProperty Members

User.Type.DirectoryServiceIDProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.DirectoryServiceIDProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.DirectoryServiceIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.DirectoryServiceIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.DirectoryServiceIDProperty Class | StarTeam Namespace


User.Type.DirectoryServiceIDProperty Properties

The properties of the User.Type.DirectoryServiceIDProperty class are listed below. For a complete list of User.Type.DirectoryServiceIDProperty class members, see the User.Type.DirectoryServiceIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

User.Type.DirectoryServiceIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.DirectoryServiceIDProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.DirectoryServiceIDProperty Class | StarTeam Namespace


User.Type.DirectoryServiceIDProperty Methods

The methods of the User.Type.DirectoryServiceIDProperty class are listed below. For a complete list of User.Type.DirectoryServiceIDProperty class members, see the User.Type.DirectoryServiceIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.DirectoryServiceIDProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.DirectoryServiceIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.DirectoryServiceIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.DirectoryServiceIDProperty Class | StarTeam Namespace


User.Type.DirectoryServiceIDProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.DirectoryServiceIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.DirectoryServiceIDProperty.Equals(obj).

See Also

User.Type.DirectoryServiceIDProperty Class | StarTeam Namespace


User.Type.DirectoryServiceIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.DirectoryServiceIDProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.DirectoryServiceIDProperty.GetHashCode().

See Also

User.Type.DirectoryServiceIDProperty Class | StarTeam Namespace


User.Type.DirectoryServiceIDProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.DirectoryServiceIDProperty.

public override string ToString();

Return Value

com.starteam.User.Type.DirectoryServiceIDProperty.ToString()

See Also

User.Type.DirectoryServiceIDProperty Class | StarTeam Namespace


User.Type.DistinguishedNameProperty Class

The property type of the Distinguished Name property.

For a list of all members of this type, see User.Type.DistinguishedNameProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.DistinguishedNameProperty

public class User.Type.DistinguishedNameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.DistinguishedNameProperty Members | StarTeam Namespace


User.Type.DistinguishedNameProperty Members

User.Type.DistinguishedNameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.DistinguishedNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.DistinguishedNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.DistinguishedNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.DistinguishedNameProperty Class | StarTeam Namespace


User.Type.DistinguishedNameProperty Properties

The properties of the User.Type.DistinguishedNameProperty class are listed below. For a complete list of User.Type.DistinguishedNameProperty class members, see the User.Type.DistinguishedNameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.DistinguishedNameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.DistinguishedNameProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.DistinguishedNameProperty Class | StarTeam Namespace


User.Type.DistinguishedNameProperty Methods

The methods of the User.Type.DistinguishedNameProperty class are listed below. For a complete list of User.Type.DistinguishedNameProperty class members, see the User.Type.DistinguishedNameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.DistinguishedNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.DistinguishedNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.DistinguishedNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.DistinguishedNameProperty Class | StarTeam Namespace


User.Type.DistinguishedNameProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.DistinguishedNameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.DistinguishedNameProperty.Equals(obj).

See Also

User.Type.DistinguishedNameProperty Class | StarTeam Namespace


User.Type.DistinguishedNameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.DistinguishedNameProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.DistinguishedNameProperty.GetHashCode().

See Also

User.Type.DistinguishedNameProperty Class | StarTeam Namespace


User.Type.DistinguishedNameProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.DistinguishedNameProperty.

public override string ToString();

Return Value

com.starteam.User.Type.DistinguishedNameProperty.ToString()

See Also

User.Type.DistinguishedNameProperty Class | StarTeam Namespace


User.Type.EmailAddressProperty Class

The property type of the Email Address property.

For a list of all members of this type, see User.Type.EmailAddressProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.EmailAddressProperty

public class User.Type.EmailAddressProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.EmailAddressProperty Members | StarTeam Namespace


User.Type.EmailAddressProperty Members

User.Type.EmailAddressProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.EmailAddressProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.EmailAddressProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.EmailAddressProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.EmailAddressProperty Class | StarTeam Namespace


User.Type.EmailAddressProperty Properties

The properties of the User.Type.EmailAddressProperty class are listed below. For a complete list of User.Type.EmailAddressProperty class members, see the User.Type.EmailAddressProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.EmailAddressProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.EmailAddressProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.EmailAddressProperty Class | StarTeam Namespace


User.Type.EmailAddressProperty Methods

The methods of the User.Type.EmailAddressProperty class are listed below. For a complete list of User.Type.EmailAddressProperty class members, see the User.Type.EmailAddressProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.EmailAddressProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.EmailAddressProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.EmailAddressProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.EmailAddressProperty Class | StarTeam Namespace


User.Type.EmailAddressProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.EmailAddressProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.EmailAddressProperty.Equals(obj).

See Also

User.Type.EmailAddressProperty Class | StarTeam Namespace


User.Type.EmailAddressProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.EmailAddressProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.EmailAddressProperty.GetHashCode().

See Also

User.Type.EmailAddressProperty Class | StarTeam Namespace


User.Type.EmailAddressProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.EmailAddressProperty.

public override string ToString();

Return Value

com.starteam.User.Type.EmailAddressProperty.ToString()

See Also

User.Type.EmailAddressProperty Class | StarTeam Namespace


User.Type.FavoriteProjectsProperty Class

The property type of the Favorite Projects property.

For a list of all members of this type, see User.Type.FavoriteProjectsProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
User.Type.FavoriteProjectsProperty

public class User.Type.FavoriteProjectsProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.FavoriteProjectsProperty Members | StarTeam Namespace


User.Type.FavoriteProjectsProperty Members

User.Type.FavoriteProjectsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.FavoriteProjectsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.FavoriteProjectsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.FavoriteProjectsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.FavoriteProjectsProperty Class | StarTeam Namespace


User.Type.FavoriteProjectsProperty Properties

The properties of the User.Type.FavoriteProjectsProperty class are listed below. For a complete list of User.Type.FavoriteProjectsProperty class members, see the User.Type.FavoriteProjectsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

User.Type.FavoriteProjectsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.FavoriteProjectsProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.FavoriteProjectsProperty Class | StarTeam Namespace


User.Type.FavoriteProjectsProperty Methods

The methods of the User.Type.FavoriteProjectsProperty class are listed below. For a complete list of User.Type.FavoriteProjectsProperty class members, see the User.Type.FavoriteProjectsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.FavoriteProjectsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.FavoriteProjectsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.FavoriteProjectsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.FavoriteProjectsProperty Class | StarTeam Namespace


User.Type.FavoriteProjectsProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.FavoriteProjectsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.FavoriteProjectsProperty.Equals(obj).

See Also

User.Type.FavoriteProjectsProperty Class | StarTeam Namespace


User.Type.FavoriteProjectsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.FavoriteProjectsProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.FavoriteProjectsProperty.GetHashCode().

See Also

User.Type.FavoriteProjectsProperty Class | StarTeam Namespace


User.Type.FavoriteProjectsProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.FavoriteProjectsProperty.

public override string ToString();

Return Value

com.starteam.User.Type.FavoriteProjectsProperty.ToString()

See Also

User.Type.FavoriteProjectsProperty Class | StarTeam Namespace


User.Type.FaxProperty Class

The property type of the Fax property.

For a list of all members of this type, see User.Type.FaxProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.FaxProperty

public class User.Type.FaxProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.FaxProperty Members | StarTeam Namespace


User.Type.FaxProperty Members

User.Type.FaxProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.FaxProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.FaxProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.FaxProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.FaxProperty Class | StarTeam Namespace


User.Type.FaxProperty Properties

The properties of the User.Type.FaxProperty class are listed below. For a complete list of User.Type.FaxProperty class members, see the User.Type.FaxProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.FaxProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.FaxProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.FaxProperty Class | StarTeam Namespace


User.Type.FaxProperty Methods

The methods of the User.Type.FaxProperty class are listed below. For a complete list of User.Type.FaxProperty class members, see the User.Type.FaxProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.FaxProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.FaxProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.FaxProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.FaxProperty Class | StarTeam Namespace


User.Type.FaxProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.FaxProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.FaxProperty.Equals(obj).

See Also

User.Type.FaxProperty Class | StarTeam Namespace


User.Type.FaxProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.FaxProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.FaxProperty.GetHashCode().

See Also

User.Type.FaxProperty Class | StarTeam Namespace


User.Type.FaxProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.FaxProperty.

public override string ToString();

Return Value

com.starteam.User.Type.FaxProperty.ToString()

See Also

User.Type.FaxProperty Class | StarTeam Namespace


User.Type.FridayAMProperty Class

The property type of the Friday AM property.

For a list of all members of this type, see User.Type.FridayAMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.FridayAMProperty

public class User.Type.FridayAMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.FridayAMProperty Members | StarTeam Namespace


User.Type.FridayAMProperty Members

User.Type.FridayAMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.FridayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.FridayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.FridayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.FridayAMProperty Class | StarTeam Namespace


User.Type.FridayAMProperty Properties

The properties of the User.Type.FridayAMProperty class are listed below. For a complete list of User.Type.FridayAMProperty class members, see the User.Type.FridayAMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.FridayAMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.FridayAMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.FridayAMProperty Class | StarTeam Namespace


User.Type.FridayAMProperty Methods

The methods of the User.Type.FridayAMProperty class are listed below. For a complete list of User.Type.FridayAMProperty class members, see the User.Type.FridayAMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.FridayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.FridayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.FridayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.FridayAMProperty Class | StarTeam Namespace


User.Type.FridayAMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.FridayAMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.FridayAMProperty.Equals(obj).

See Also

User.Type.FridayAMProperty Class | StarTeam Namespace


User.Type.FridayAMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.FridayAMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.FridayAMProperty.GetHashCode().

See Also

User.Type.FridayAMProperty Class | StarTeam Namespace


User.Type.FridayAMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.FridayAMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.FridayAMProperty.ToString()

See Also

User.Type.FridayAMProperty Class | StarTeam Namespace


User.Type.FridayPMProperty Class

The property type of the Friday PM property.

For a list of all members of this type, see User.Type.FridayPMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.FridayPMProperty

public class User.Type.FridayPMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.FridayPMProperty Members | StarTeam Namespace


User.Type.FridayPMProperty Members

User.Type.FridayPMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.FridayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.FridayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.FridayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.FridayPMProperty Class | StarTeam Namespace


User.Type.FridayPMProperty Properties

The properties of the User.Type.FridayPMProperty class are listed below. For a complete list of User.Type.FridayPMProperty class members, see the User.Type.FridayPMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.FridayPMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.FridayPMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.FridayPMProperty Class | StarTeam Namespace


User.Type.FridayPMProperty Methods

The methods of the User.Type.FridayPMProperty class are listed below. For a complete list of User.Type.FridayPMProperty class members, see the User.Type.FridayPMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.FridayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.FridayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.FridayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.FridayPMProperty Class | StarTeam Namespace


User.Type.FridayPMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.FridayPMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.FridayPMProperty.Equals(obj).

See Also

User.Type.FridayPMProperty Class | StarTeam Namespace


User.Type.FridayPMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.FridayPMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.FridayPMProperty.GetHashCode().

See Also

User.Type.FridayPMProperty Class | StarTeam Namespace


User.Type.FridayPMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.FridayPMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.FridayPMProperty.ToString()

See Also

User.Type.FridayPMProperty Class | StarTeam Namespace


User.Type.IsDirectoryManagedProperty Class

The property type of the Is Active Directory Managed property.

For a list of all members of this type, see User.Type.IsDirectoryManagedProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
User.Type.IsDirectoryManagedProperty

public class User.Type.IsDirectoryManagedProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.IsDirectoryManagedProperty Members | StarTeam Namespace


User.Type.IsDirectoryManagedProperty Members

User.Type.IsDirectoryManagedProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.IsDirectoryManagedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.IsDirectoryManagedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.IsDirectoryManagedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.IsDirectoryManagedProperty Class | StarTeam Namespace


User.Type.IsDirectoryManagedProperty Properties

The properties of the User.Type.IsDirectoryManagedProperty class are listed below. For a complete list of User.Type.IsDirectoryManagedProperty class members, see the User.Type.IsDirectoryManagedProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

User.Type.IsDirectoryManagedProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.IsDirectoryManagedProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.IsDirectoryManagedProperty Class | StarTeam Namespace


User.Type.IsDirectoryManagedProperty Methods

The methods of the User.Type.IsDirectoryManagedProperty class are listed below. For a complete list of User.Type.IsDirectoryManagedProperty class members, see the User.Type.IsDirectoryManagedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.IsDirectoryManagedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.IsDirectoryManagedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.IsDirectoryManagedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.IsDirectoryManagedProperty Class | StarTeam Namespace


User.Type.IsDirectoryManagedProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.IsDirectoryManagedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.IsDirectoryManagedProperty.Equals(obj).

See Also

User.Type.IsDirectoryManagedProperty Class | StarTeam Namespace


User.Type.IsDirectoryManagedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.IsDirectoryManagedProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.IsDirectoryManagedProperty.GetHashCode().

See Also

User.Type.IsDirectoryManagedProperty Class | StarTeam Namespace


User.Type.IsDirectoryManagedProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.IsDirectoryManagedProperty.

public override string ToString();

Return Value

com.starteam.User.Type.IsDirectoryManagedProperty.ToString()

See Also

User.Type.IsDirectoryManagedProperty Class | StarTeam Namespace


User.Type.LastLogoutTimeProperty Class

The property type of the Last Logout Time property.

For a list of all members of this type, see User.Type.LastLogoutTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.LastLogoutTimeProperty

public class User.Type.LastLogoutTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.LastLogoutTimeProperty Members | StarTeam Namespace


User.Type.LastLogoutTimeProperty Members

User.Type.LastLogoutTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LastLogoutTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LastLogoutTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LastLogoutTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LastLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastLogoutTimeProperty Properties

The properties of the User.Type.LastLogoutTimeProperty class are listed below. For a complete list of User.Type.LastLogoutTimeProperty class members, see the User.Type.LastLogoutTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.LastLogoutTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.LastLogoutTimeProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.LastLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastLogoutTimeProperty Methods

The methods of the User.Type.LastLogoutTimeProperty class are listed below. For a complete list of User.Type.LastLogoutTimeProperty class members, see the User.Type.LastLogoutTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LastLogoutTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LastLogoutTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LastLogoutTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LastLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastLogoutTimeProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.LastLogoutTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.LastLogoutTimeProperty.Equals(obj).

See Also

User.Type.LastLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastLogoutTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.LastLogoutTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.LastLogoutTimeProperty.GetHashCode().

See Also

User.Type.LastLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastLogoutTimeProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.LastLogoutTimeProperty.

public override string ToString();

Return Value

com.starteam.User.Type.LastLogoutTimeProperty.ToString()

See Also

User.Type.LastLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastPasswordChangeTimeProperty Class

The property type of the Last Password Change Time property.

For a list of all members of this type, see User.Type.LastPasswordChangeTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.LastPasswordChangeTimeProperty

public class User.Type.LastPasswordChangeTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.LastPasswordChangeTimeProperty Members | StarTeam Namespace


User.Type.LastPasswordChangeTimeProperty Members

User.Type.LastPasswordChangeTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LastPasswordChangeTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LastPasswordChangeTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LastPasswordChangeTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LastPasswordChangeTimeProperty Class | StarTeam Namespace


User.Type.LastPasswordChangeTimeProperty Properties

The properties of the User.Type.LastPasswordChangeTimeProperty class are listed below. For a complete list of User.Type.LastPasswordChangeTimeProperty class members, see the User.Type.LastPasswordChangeTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.LastPasswordChangeTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.LastPasswordChangeTimeProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.LastPasswordChangeTimeProperty Class | StarTeam Namespace


User.Type.LastPasswordChangeTimeProperty Methods

The methods of the User.Type.LastPasswordChangeTimeProperty class are listed below. For a complete list of User.Type.LastPasswordChangeTimeProperty class members, see the User.Type.LastPasswordChangeTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LastPasswordChangeTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LastPasswordChangeTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LastPasswordChangeTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LastPasswordChangeTimeProperty Class | StarTeam Namespace


User.Type.LastPasswordChangeTimeProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.LastPasswordChangeTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.LastPasswordChangeTimeProperty.Equals(obj).

See Also

User.Type.LastPasswordChangeTimeProperty Class | StarTeam Namespace


User.Type.LastPasswordChangeTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.LastPasswordChangeTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.LastPasswordChangeTimeProperty.GetHashCode().

See Also

User.Type.LastPasswordChangeTimeProperty Class | StarTeam Namespace


User.Type.LastPasswordChangeTimeProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.LastPasswordChangeTimeProperty.

public override string ToString();

Return Value

com.starteam.User.Type.LastPasswordChangeTimeProperty.ToString()

See Also

User.Type.LastPasswordChangeTimeProperty Class | StarTeam Namespace


User.Type.LastWebLogoutTimeProperty Class

The property type of the Last Web Logout Time property.

For a list of all members of this type, see User.Type.LastWebLogoutTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.LastWebLogoutTimeProperty

public class User.Type.LastWebLogoutTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.LastWebLogoutTimeProperty Members | StarTeam Namespace


User.Type.LastWebLogoutTimeProperty Members

User.Type.LastWebLogoutTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LastWebLogoutTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LastWebLogoutTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LastWebLogoutTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LastWebLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastWebLogoutTimeProperty Properties

The properties of the User.Type.LastWebLogoutTimeProperty class are listed below. For a complete list of User.Type.LastWebLogoutTimeProperty class members, see the User.Type.LastWebLogoutTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.LastWebLogoutTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.LastWebLogoutTimeProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.LastWebLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastWebLogoutTimeProperty Methods

The methods of the User.Type.LastWebLogoutTimeProperty class are listed below. For a complete list of User.Type.LastWebLogoutTimeProperty class members, see the User.Type.LastWebLogoutTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LastWebLogoutTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LastWebLogoutTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LastWebLogoutTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LastWebLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastWebLogoutTimeProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.LastWebLogoutTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.LastWebLogoutTimeProperty.Equals(obj).

See Also

User.Type.LastWebLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastWebLogoutTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.LastWebLogoutTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.LastWebLogoutTimeProperty.GetHashCode().

See Also

User.Type.LastWebLogoutTimeProperty Class | StarTeam Namespace


User.Type.LastWebLogoutTimeProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.LastWebLogoutTimeProperty.

public override string ToString();

Return Value

com.starteam.User.Type.LastWebLogoutTimeProperty.ToString()

See Also

User.Type.LastWebLogoutTimeProperty Class | StarTeam Namespace


User.Type.LicenseProperty Class

The property type of the License property.

For a list of all members of this type, see User.Type.LicenseProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
User.Type.LicenseProperty

public class User.Type.LicenseProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.LicenseProperty Members | StarTeam Namespace


User.Type.LicenseProperty Members

User.Type.LicenseProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LicenseProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LicenseProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LicenseProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LicenseProperty Class | StarTeam Namespace


User.Type.LicenseProperty Properties

The properties of the User.Type.LicenseProperty class are listed below. For a complete list of User.Type.LicenseProperty class members, see the User.Type.LicenseProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.LicenseProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.LicenseProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.LicenseProperty Class | StarTeam Namespace


User.Type.LicenseProperty Methods

The methods of the User.Type.LicenseProperty class are listed below. For a complete list of User.Type.LicenseProperty class members, see the User.Type.LicenseProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LicenseProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LicenseProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LicenseProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LicenseProperty Class | StarTeam Namespace


User.Type.LicenseProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.LicenseProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.LicenseProperty.Equals(obj).

See Also

User.Type.LicenseProperty Class | StarTeam Namespace


User.Type.LicenseProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.LicenseProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.LicenseProperty.GetHashCode().

See Also

User.Type.LicenseProperty Class | StarTeam Namespace


User.Type.LicenseProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.LicenseProperty.

public override string ToString();

Return Value

com.starteam.User.Type.LicenseProperty.ToString()

See Also

User.Type.LicenseProperty Class | StarTeam Namespace


User.Type.LicenseTypeProperty Class

The property type of the License Type property.

For a list of all members of this type, see User.Type.LicenseTypeProperty Members.

System.Object
Property
EnumeratedProperty
User.Type.LicenseTypeProperty

public class User.Type.LicenseTypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.LicenseTypeProperty Members | StarTeam Namespace


User.Type.LicenseTypeProperty Members

User.Type.LicenseTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.LicenseTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LicenseTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.LicenseTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LicenseTypeProperty Class | StarTeam Namespace


User.Type.LicenseTypeProperty Properties

The properties of the User.Type.LicenseTypeProperty class are listed below. For a complete list of User.Type.LicenseTypeProperty class members, see the User.Type.LicenseTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

User.Type.LicenseTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.LicenseTypeProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.LicenseTypeProperty Class | StarTeam Namespace


User.Type.LicenseTypeProperty Methods

The methods of the User.Type.LicenseTypeProperty class are listed below. For a complete list of User.Type.LicenseTypeProperty class members, see the User.Type.LicenseTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.LicenseTypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LicenseTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.LicenseTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LicenseTypeProperty Class | StarTeam Namespace


User.Type.LicenseTypeProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.LicenseTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.LicenseTypeProperty.Equals(obj).

See Also

User.Type.LicenseTypeProperty Class | StarTeam Namespace


User.Type.LicenseTypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
User.License value
);

See Also

User.Type.LicenseTypeProperty Class | StarTeam Namespace


User.Type.LicenseTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.LicenseTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.LicenseTypeProperty.GetHashCode().

See Also

User.Type.LicenseTypeProperty Class | StarTeam Namespace


User.Type.LicenseTypeProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.LicenseTypeProperty.

public override string ToString();

Return Value

com.starteam.User.Type.LicenseTypeProperty.ToString()

See Also

User.Type.LicenseTypeProperty Class | StarTeam Namespace


User.Type.LockOutTimeProperty Class

The property type of the Lock Out Time property.

For a list of all members of this type, see User.Type.LockOutTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.LockOutTimeProperty

public class User.Type.LockOutTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.LockOutTimeProperty Members | StarTeam Namespace


User.Type.LockOutTimeProperty Members

User.Type.LockOutTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LockOutTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LockOutTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LockOutTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LockOutTimeProperty Class | StarTeam Namespace


User.Type.LockOutTimeProperty Properties

The properties of the User.Type.LockOutTimeProperty class are listed below. For a complete list of User.Type.LockOutTimeProperty class members, see the User.Type.LockOutTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.LockOutTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.LockOutTimeProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.LockOutTimeProperty Class | StarTeam Namespace


User.Type.LockOutTimeProperty Methods

The methods of the User.Type.LockOutTimeProperty class are listed below. For a complete list of User.Type.LockOutTimeProperty class members, see the User.Type.LockOutTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LockOutTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LockOutTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LockOutTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LockOutTimeProperty Class | StarTeam Namespace


User.Type.LockOutTimeProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.LockOutTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.LockOutTimeProperty.Equals(obj).

See Also

User.Type.LockOutTimeProperty Class | StarTeam Namespace


User.Type.LockOutTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.LockOutTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.LockOutTimeProperty.GetHashCode().

See Also

User.Type.LockOutTimeProperty Class | StarTeam Namespace


User.Type.LockOutTimeProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.LockOutTimeProperty.

public override string ToString();

Return Value

com.starteam.User.Type.LockOutTimeProperty.ToString()

See Also

User.Type.LockOutTimeProperty Class | StarTeam Namespace


User.Type.LoginNameProperty Class

The property type of the Login Name property.

For a list of all members of this type, see User.Type.LoginNameProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.LoginNameProperty

public class User.Type.LoginNameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.LoginNameProperty Members | StarTeam Namespace


User.Type.LoginNameProperty Members

User.Type.LoginNameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LoginNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LoginNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LoginNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LoginNameProperty Class | StarTeam Namespace


User.Type.LoginNameProperty Properties

The properties of the User.Type.LoginNameProperty class are listed below. For a complete list of User.Type.LoginNameProperty class members, see the User.Type.LoginNameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.LoginNameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.LoginNameProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.LoginNameProperty Class | StarTeam Namespace


User.Type.LoginNameProperty Methods

The methods of the User.Type.LoginNameProperty class are listed below. For a complete list of User.Type.LoginNameProperty class members, see the User.Type.LoginNameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.LoginNameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.LoginNameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.LoginNameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.LoginNameProperty Class | StarTeam Namespace


User.Type.LoginNameProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.LoginNameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.LoginNameProperty.Equals(obj).

See Also

User.Type.LoginNameProperty Class | StarTeam Namespace


User.Type.LoginNameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.LoginNameProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.LoginNameProperty.GetHashCode().

See Also

User.Type.LoginNameProperty Class | StarTeam Namespace


User.Type.LoginNameProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.LoginNameProperty.

public override string ToString();

Return Value

com.starteam.User.Type.LoginNameProperty.ToString()

See Also

User.Type.LoginNameProperty Class | StarTeam Namespace


User.Type.MondayAMProperty Class

The property type of the Monday AM property.

For a list of all members of this type, see User.Type.MondayAMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.MondayAMProperty

public class User.Type.MondayAMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.MondayAMProperty Members | StarTeam Namespace


User.Type.MondayAMProperty Members

User.Type.MondayAMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.MondayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.MondayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.MondayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.MondayAMProperty Class | StarTeam Namespace


User.Type.MondayAMProperty Properties

The properties of the User.Type.MondayAMProperty class are listed below. For a complete list of User.Type.MondayAMProperty class members, see the User.Type.MondayAMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.MondayAMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.MondayAMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.MondayAMProperty Class | StarTeam Namespace


User.Type.MondayAMProperty Methods

The methods of the User.Type.MondayAMProperty class are listed below. For a complete list of User.Type.MondayAMProperty class members, see the User.Type.MondayAMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.MondayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.MondayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.MondayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.MondayAMProperty Class | StarTeam Namespace


User.Type.MondayAMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.MondayAMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.MondayAMProperty.Equals(obj).

See Also

User.Type.MondayAMProperty Class | StarTeam Namespace


User.Type.MondayAMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.MondayAMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.MondayAMProperty.GetHashCode().

See Also

User.Type.MondayAMProperty Class | StarTeam Namespace


User.Type.MondayAMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.MondayAMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.MondayAMProperty.ToString()

See Also

User.Type.MondayAMProperty Class | StarTeam Namespace


User.Type.MondayPMProperty Class

The property type of the Monday PM property.

For a list of all members of this type, see User.Type.MondayPMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.MondayPMProperty

public class User.Type.MondayPMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.MondayPMProperty Members | StarTeam Namespace


User.Type.MondayPMProperty Members

User.Type.MondayPMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.MondayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.MondayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.MondayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.MondayPMProperty Class | StarTeam Namespace


User.Type.MondayPMProperty Properties

The properties of the User.Type.MondayPMProperty class are listed below. For a complete list of User.Type.MondayPMProperty class members, see the User.Type.MondayPMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.MondayPMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.MondayPMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.MondayPMProperty Class | StarTeam Namespace


User.Type.MondayPMProperty Methods

The methods of the User.Type.MondayPMProperty class are listed below. For a complete list of User.Type.MondayPMProperty class members, see the User.Type.MondayPMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.MondayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.MondayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.MondayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.MondayPMProperty Class | StarTeam Namespace


User.Type.MondayPMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.MondayPMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.MondayPMProperty.Equals(obj).

See Also

User.Type.MondayPMProperty Class | StarTeam Namespace


User.Type.MondayPMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.MondayPMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.MondayPMProperty.GetHashCode().

See Also

User.Type.MondayPMProperty Class | StarTeam Namespace


User.Type.MondayPMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.MondayPMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.MondayPMProperty.ToString()

See Also

User.Type.MondayPMProperty Class | StarTeam Namespace


User.Type.NameProperty Class

The property type of the Name property.

For a list of all members of this type, see User.Type.NameProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.NameProperty

public class User.Type.NameProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.NameProperty Members | StarTeam Namespace


User.Type.NameProperty Members

User.Type.NameProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.NameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.NameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.NameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.NameProperty Class | StarTeam Namespace


User.Type.NameProperty Properties

The properties of the User.Type.NameProperty class are listed below. For a complete list of User.Type.NameProperty class members, see the User.Type.NameProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.NameProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.NameProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.NameProperty Class | StarTeam Namespace


User.Type.NameProperty Methods

The methods of the User.Type.NameProperty class are listed below. For a complete list of User.Type.NameProperty class members, see the User.Type.NameProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.NameProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.NameProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.NameProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.NameProperty Class | StarTeam Namespace


User.Type.NameProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.NameProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.NameProperty.Equals(obj).

See Also

User.Type.NameProperty Class | StarTeam Namespace


User.Type.NameProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.NameProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.NameProperty.GetHashCode().

See Also

User.Type.NameProperty Class | StarTeam Namespace


User.Type.NameProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.NameProperty.

public override string ToString();

Return Value

com.starteam.User.Type.NameProperty.ToString()

See Also

User.Type.NameProperty Class | StarTeam Namespace


User.Type.PagerProperty Class

The property type of the Pager property.

For a list of all members of this type, see User.Type.PagerProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.PagerProperty

public class User.Type.PagerProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.PagerProperty Members | StarTeam Namespace


User.Type.PagerProperty Members

User.Type.PagerProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.PagerProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.PagerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.PagerProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.PagerProperty Class | StarTeam Namespace


User.Type.PagerProperty Properties

The properties of the User.Type.PagerProperty class are listed below. For a complete list of User.Type.PagerProperty class members, see the User.Type.PagerProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.PagerProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.PagerProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.PagerProperty Class | StarTeam Namespace


User.Type.PagerProperty Methods

The methods of the User.Type.PagerProperty class are listed below. For a complete list of User.Type.PagerProperty class members, see the User.Type.PagerProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.PagerProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.PagerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.PagerProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.PagerProperty Class | StarTeam Namespace


User.Type.PagerProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.PagerProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.PagerProperty.Equals(obj).

See Also

User.Type.PagerProperty Class | StarTeam Namespace


User.Type.PagerProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.PagerProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.PagerProperty.GetHashCode().

See Also

User.Type.PagerProperty Class | StarTeam Namespace


User.Type.PagerProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.PagerProperty.

public override string ToString();

Return Value

com.starteam.User.Type.PagerProperty.ToString()

See Also

User.Type.PagerProperty Class | StarTeam Namespace


User.Type.PasswordProperty Class

The property type of the Password property.

For a list of all members of this type, see User.Type.PasswordProperty Members.

System.Object
Property
VectorProperty
BinaryProperty
User.Type.PasswordProperty

public class User.Type.PasswordProperty : BinaryProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.PasswordProperty Members | StarTeam Namespace


User.Type.PasswordProperty Members

User.Type.PasswordProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BinaryProperty) | [read/write] byte[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.PasswordProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.PasswordProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BinaryProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.PasswordProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.PasswordProperty Class | StarTeam Namespace


User.Type.PasswordProperty Properties

The properties of the User.Type.PasswordProperty class are listed below. For a complete list of User.Type.PasswordProperty class members, see the User.Type.PasswordProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BinaryProperty) | [read/write] byte[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.PasswordProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.PasswordProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.PasswordProperty Class | StarTeam Namespace


User.Type.PasswordProperty Methods

The methods of the User.Type.PasswordProperty class are listed below. For a complete list of User.Type.PasswordProperty class members, see the User.Type.PasswordProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.PasswordProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.PasswordProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BinaryProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.PasswordProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.PasswordProperty Class | StarTeam Namespace


User.Type.PasswordProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.PasswordProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.PasswordProperty.Equals(obj).

See Also

User.Type.PasswordProperty Class | StarTeam Namespace


User.Type.PasswordProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.PasswordProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.PasswordProperty.GetHashCode().

See Also

User.Type.PasswordProperty Class | StarTeam Namespace


User.Type.PasswordProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.PasswordProperty.

public override string ToString();

Return Value

com.starteam.User.Type.PasswordProperty.ToString()

See Also

User.Type.PasswordProperty Class | StarTeam Namespace


User.Type.PhoneProperty Class

The property type of the Phone property.

For a list of all members of this type, see User.Type.PhoneProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.PhoneProperty

public class User.Type.PhoneProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.PhoneProperty Members | StarTeam Namespace


User.Type.PhoneProperty Members

User.Type.PhoneProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.PhoneProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.PhoneProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.PhoneProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.PhoneProperty Class | StarTeam Namespace


User.Type.PhoneProperty Properties

The properties of the User.Type.PhoneProperty class are listed below. For a complete list of User.Type.PhoneProperty class members, see the User.Type.PhoneProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.PhoneProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.PhoneProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.PhoneProperty Class | StarTeam Namespace


User.Type.PhoneProperty Methods

The methods of the User.Type.PhoneProperty class are listed below. For a complete list of User.Type.PhoneProperty class members, see the User.Type.PhoneProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.PhoneProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.PhoneProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.PhoneProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.PhoneProperty Class | StarTeam Namespace


User.Type.PhoneProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.PhoneProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.PhoneProperty.Equals(obj).

See Also

User.Type.PhoneProperty Class | StarTeam Namespace


User.Type.PhoneProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.PhoneProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.PhoneProperty.GetHashCode().

See Also

User.Type.PhoneProperty Class | StarTeam Namespace


User.Type.PhoneProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.PhoneProperty.

public override string ToString();

Return Value

com.starteam.User.Type.PhoneProperty.ToString()

See Also

User.Type.PhoneProperty Class | StarTeam Namespace


User.Type.PropertyCollection Class

The property collection of the User type

For a list of all members of this type, see User.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
User.Type.PropertyCollection

public class User.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.PropertyCollection Members | StarTeam Namespace


User.Type.PropertyCollection Members

User.Type.PropertyCollection overview

Public Instance Properties

ACCESS_RESTRICTION |
ADDRESS |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DIRECTORY_SERVICE_ID |
DISTINGUISHED_NAME |
EMAIL_ADDRESS |
FAVORITE_PROJECTS |
FAX |
FLAGS |
FRIDAY_AM |
FRIDAY_PM |
GLOBAL_ID |
ID |
IS_DIRECTORY_MANAGED |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
LAST_LOGOUT_TIME |
LAST_PASSWORD_CHANGE_TIME |
LAST_WEB_LOGOUT_TIME |
LICENSE |
LICENSE_TYPE |
LOCK_OUT_TIME |
LOGIN_NAME |
MODIFIED_BY |
MODIFIED_TIME |
MONDAY_AM |
MONDAY_PM |
NAME |
PAGER |
PASSWORD |
PHONE |
RETURN_EMAIL_ADDRESS |
SATURDAY_AM |
SATURDAY_PM |
STATUS |
SUNDAY_AM |
SUNDAY_PM |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TENANT |
TERRITORY |
THURSDAY_AM |
THURSDAY_PM |
TIME_ZONE_SHIFT |
TUESDAY_AM |
TUESDAY_PM |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
USER_IMAGE |
VOICE_MAIL |
WEDNESDAY_AM |
WEDNESDAY_PM |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.User.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.User.Type.PropertyCollection.

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


User.Type.PropertyCollection Properties

The properties of the User.Type.PropertyCollection class are listed below. For a complete list of User.Type.PropertyCollection class members, see the User.Type.PropertyCollection Members topic.

Public Instance Properties

ACCESS_RESTRICTION |
ADDRESS |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DIRECTORY_SERVICE_ID |
DISTINGUISHED_NAME |
EMAIL_ADDRESS |
FAVORITE_PROJECTS |
FAX |
FLAGS |
FRIDAY_AM |
FRIDAY_PM |
GLOBAL_ID |
ID |
IS_DIRECTORY_MANAGED |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
LAST_LOGOUT_TIME |
LAST_PASSWORD_CHANGE_TIME |
LAST_WEB_LOGOUT_TIME |
LICENSE |
LICENSE_TYPE |
LOCK_OUT_TIME |
LOGIN_NAME |
MODIFIED_BY |
MODIFIED_TIME |
MONDAY_AM |
MONDAY_PM |
NAME |
PAGER |
PASSWORD |
PHONE |
RETURN_EMAIL_ADDRESS |
SATURDAY_AM |
SATURDAY_PM |
STATUS |
SUNDAY_AM |
SUNDAY_PM |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TENANT |
TERRITORY |
THURSDAY_AM |
THURSDAY_PM |
TIME_ZONE_SHIFT |
TUESDAY_AM |
TUESDAY_PM |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
USER_IMAGE |
VOICE_MAIL |
WEDNESDAY_AM |
WEDNESDAY_PM |

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


ACCESS_RESTRICTION Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.ACCESS_RESTRICTION Property

public User.Type.AccessRestrictionProperty ACCESS_RESTRICTION {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


ADDRESS Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.ADDRESS Property

public User.Type.AddressProperty ADDRESS {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


DIRECTORY_SERVICE_ID Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.DIRECTORY_SERVICE_ID Property

public User.Type.DirectoryServiceIDProperty DIRECTORY_SERVICE_ID {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


DISTINGUISHED_NAME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.DISTINGUISHED_NAME Property

public User.Type.DistinguishedNameProperty DISTINGUISHED_NAME {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


EMAIL_ADDRESS Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.EMAIL_ADDRESS Property

public User.Type.EmailAddressProperty EMAIL_ADDRESS {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


FAVORITE_PROJECTS Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.FAVORITE_PROJECTS Property

public User.Type.FavoriteProjectsProperty FAVORITE_PROJECTS {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


FAX Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.FAX Property

public User.Type.FaxProperty FAX {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


FLAGS Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.FLAGS Property

public LiveObject.Type.FlagsProperty FLAGS {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


FRIDAY_AM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.FRIDAY_AM Property

public User.Type.FridayAMProperty FRIDAY_AM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


FRIDAY_PM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.FRIDAY_PM Property

public User.Type.FridayPMProperty FRIDAY_PM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


IS_DIRECTORY_MANAGED Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.IS_DIRECTORY_MANAGED Property

public User.Type.IsDirectoryManagedProperty IS_DIRECTORY_MANAGED {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


LAST_LOGOUT_TIME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.LAST_LOGOUT_TIME Property

public User.Type.LastLogoutTimeProperty LAST_LOGOUT_TIME {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


LAST_PASSWORD_CHANGE_TIME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.LAST_PASSWORD_CHANGE_TIME Property

public User.Type.LastPasswordChangeTimeProperty LAST_PASSWORD_CHANGE_TIME {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


LAST_WEB_LOGOUT_TIME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.LAST_WEB_LOGOUT_TIME Property

public User.Type.LastWebLogoutTimeProperty LAST_WEB_LOGOUT_TIME {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


LICENSE Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.LICENSE Property

public User.Type.LicenseProperty LICENSE {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


LICENSE_TYPE Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.LICENSE_TYPE Property

public User.Type.LicenseTypeProperty LICENSE_TYPE {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


LOCK_OUT_TIME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.LOCK_OUT_TIME Property

public User.Type.LockOutTimeProperty LOCK_OUT_TIME {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


LOGIN_NAME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.LOGIN_NAME Property

public User.Type.LoginNameProperty LOGIN_NAME {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


MONDAY_AM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.MONDAY_AM Property

public User.Type.MondayAMProperty MONDAY_AM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


MONDAY_PM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.MONDAY_PM Property

public User.Type.MondayPMProperty MONDAY_PM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.NAME Property

public User.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


PAGER Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.PAGER Property

public User.Type.PagerProperty PAGER {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


PASSWORD Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.PASSWORD Property

public User.Type.PasswordProperty PASSWORD {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


PHONE Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.PHONE Property

public User.Type.PhoneProperty PHONE {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


RETURN_EMAIL_ADDRESS Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.RETURN_EMAIL_ADDRESS Property

public User.Type.ReturnEmailAddressProperty RETURN_EMAIL_ADDRESS {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


SATURDAY_AM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.SATURDAY_AM Property

public User.Type.SaturdayAMProperty SATURDAY_AM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


SATURDAY_PM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.SATURDAY_PM Property

public User.Type.SaturdayPMProperty SATURDAY_PM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


STATUS Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.STATUS Property

public User.Type.StatusProperty STATUS {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


SUNDAY_AM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.SUNDAY_AM Property

public User.Type.SundayAMProperty SUNDAY_AM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


SUNDAY_PM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.SUNDAY_PM Property

public User.Type.SundayPMProperty SUNDAY_PM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


TENANT Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.TENANT Property

public User.Type.TenantProperty TENANT {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


TERRITORY Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.TERRITORY Property

public User.Type.TerritoryProperty TERRITORY {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


THURSDAY_AM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.THURSDAY_AM Property

public User.Type.ThursdayAMProperty THURSDAY_AM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


THURSDAY_PM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.THURSDAY_PM Property

public User.Type.ThursdayPMProperty THURSDAY_PM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


TIME_ZONE_SHIFT Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.TIME_ZONE_SHIFT Property

public User.Type.TimeZoneShiftProperty TIME_ZONE_SHIFT {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


TUESDAY_AM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.TUESDAY_AM Property

public User.Type.TuesdayAMProperty TUESDAY_AM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


TUESDAY_PM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.TUESDAY_PM Property

public User.Type.TuesdayPMProperty TUESDAY_PM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


USER_IMAGE Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.USER_IMAGE Property

public User.Type.UserImageProperty USER_IMAGE {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


VOICE_MAIL Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.VOICE_MAIL Property

public User.Type.VoiceMailProperty VOICE_MAIL {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


WEDNESDAY_AM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.WEDNESDAY_AM Property

public User.Type.WednesdayAMProperty WEDNESDAY_AM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


WEDNESDAY_PM Property

Borland StarTeam SDK for .NET

User.Type.PropertyCollection.WEDNESDAY_PM Property

public User.Type.WednesdayPMProperty WEDNESDAY_PM {get;}

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


User.Type.PropertyCollection Methods

The methods of the User.Type.PropertyCollection class are listed below. For a complete list of User.Type.PropertyCollection class members, see the User.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.User.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.User.Type.PropertyCollection.

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


User.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.User.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.PropertyCollection.Equals(obj).

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


User.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.User.Type.PropertyCollection.GetHashCode().

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


User.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.User.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.User.Type.PropertyCollection.ToString()

See Also

User.Type.PropertyCollection Class | StarTeam Namespace


User.Type.ReturnEmailAddressProperty Class

The property type of the Email Address property.

For a list of all members of this type, see User.Type.ReturnEmailAddressProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.ReturnEmailAddressProperty

public class User.Type.ReturnEmailAddressProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.ReturnEmailAddressProperty Members | StarTeam Namespace


User.Type.ReturnEmailAddressProperty Members

User.Type.ReturnEmailAddressProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.ReturnEmailAddressProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.ReturnEmailAddressProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.ReturnEmailAddressProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.ReturnEmailAddressProperty Class | StarTeam Namespace


User.Type.ReturnEmailAddressProperty Properties

The properties of the User.Type.ReturnEmailAddressProperty class are listed below. For a complete list of User.Type.ReturnEmailAddressProperty class members, see the User.Type.ReturnEmailAddressProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.ReturnEmailAddressProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.ReturnEmailAddressProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.ReturnEmailAddressProperty Class | StarTeam Namespace


User.Type.ReturnEmailAddressProperty Methods

The methods of the User.Type.ReturnEmailAddressProperty class are listed below. For a complete list of User.Type.ReturnEmailAddressProperty class members, see the User.Type.ReturnEmailAddressProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.ReturnEmailAddressProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.ReturnEmailAddressProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.ReturnEmailAddressProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.ReturnEmailAddressProperty Class | StarTeam Namespace


User.Type.ReturnEmailAddressProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.ReturnEmailAddressProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.ReturnEmailAddressProperty.Equals(obj).

See Also

User.Type.ReturnEmailAddressProperty Class | StarTeam Namespace


User.Type.ReturnEmailAddressProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.ReturnEmailAddressProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.ReturnEmailAddressProperty.GetHashCode().

See Also

User.Type.ReturnEmailAddressProperty Class | StarTeam Namespace


User.Type.ReturnEmailAddressProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.ReturnEmailAddressProperty.

public override string ToString();

Return Value

com.starteam.User.Type.ReturnEmailAddressProperty.ToString()

See Also

User.Type.ReturnEmailAddressProperty Class | StarTeam Namespace


User.Type.SaturdayAMProperty Class

The property type of the Saturday AM property.

For a list of all members of this type, see User.Type.SaturdayAMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.SaturdayAMProperty

public class User.Type.SaturdayAMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.SaturdayAMProperty Members | StarTeam Namespace


User.Type.SaturdayAMProperty Members

User.Type.SaturdayAMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.SaturdayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.SaturdayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.SaturdayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.SaturdayAMProperty Class | StarTeam Namespace


User.Type.SaturdayAMProperty Properties

The properties of the User.Type.SaturdayAMProperty class are listed below. For a complete list of User.Type.SaturdayAMProperty class members, see the User.Type.SaturdayAMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.SaturdayAMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.SaturdayAMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.SaturdayAMProperty Class | StarTeam Namespace


User.Type.SaturdayAMProperty Methods

The methods of the User.Type.SaturdayAMProperty class are listed below. For a complete list of User.Type.SaturdayAMProperty class members, see the User.Type.SaturdayAMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.SaturdayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.SaturdayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.SaturdayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.SaturdayAMProperty Class | StarTeam Namespace


User.Type.SaturdayAMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.SaturdayAMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.SaturdayAMProperty.Equals(obj).

See Also

User.Type.SaturdayAMProperty Class | StarTeam Namespace


User.Type.SaturdayAMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.SaturdayAMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.SaturdayAMProperty.GetHashCode().

See Also

User.Type.SaturdayAMProperty Class | StarTeam Namespace


User.Type.SaturdayAMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.SaturdayAMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.SaturdayAMProperty.ToString()

See Also

User.Type.SaturdayAMProperty Class | StarTeam Namespace


User.Type.SaturdayPMProperty Class

The property type of the Saturday PM property.

For a list of all members of this type, see User.Type.SaturdayPMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.SaturdayPMProperty

public class User.Type.SaturdayPMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.SaturdayPMProperty Members | StarTeam Namespace


User.Type.SaturdayPMProperty Members

User.Type.SaturdayPMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.SaturdayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.SaturdayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.SaturdayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.SaturdayPMProperty Class | StarTeam Namespace


User.Type.SaturdayPMProperty Properties

The properties of the User.Type.SaturdayPMProperty class are listed below. For a complete list of User.Type.SaturdayPMProperty class members, see the User.Type.SaturdayPMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.SaturdayPMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.SaturdayPMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.SaturdayPMProperty Class | StarTeam Namespace


User.Type.SaturdayPMProperty Methods

The methods of the User.Type.SaturdayPMProperty class are listed below. For a complete list of User.Type.SaturdayPMProperty class members, see the User.Type.SaturdayPMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.SaturdayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.SaturdayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.SaturdayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.SaturdayPMProperty Class | StarTeam Namespace


User.Type.SaturdayPMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.SaturdayPMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.SaturdayPMProperty.Equals(obj).

See Also

User.Type.SaturdayPMProperty Class | StarTeam Namespace


User.Type.SaturdayPMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.SaturdayPMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.SaturdayPMProperty.GetHashCode().

See Also

User.Type.SaturdayPMProperty Class | StarTeam Namespace


User.Type.SaturdayPMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.SaturdayPMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.SaturdayPMProperty.ToString()

See Also

User.Type.SaturdayPMProperty Class | StarTeam Namespace


User.Type.StatusProperty Class

The property type of the Status property.

For a list of all members of this type, see User.Type.StatusProperty Members.

System.Object
Property
EnumeratedProperty
User.Type.StatusProperty

public class User.Type.StatusProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.StatusProperty Members | StarTeam Namespace


User.Type.StatusProperty Members

User.Type.StatusProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.StatusProperty Class | StarTeam Namespace


User.Type.StatusProperty Properties

The properties of the User.Type.StatusProperty class are listed below. For a complete list of User.Type.StatusProperty class members, see the User.Type.StatusProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

User.Type.StatusProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.StatusProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.StatusProperty Class | StarTeam Namespace


User.Type.StatusProperty Methods

The methods of the User.Type.StatusProperty class are listed below. For a complete list of User.Type.StatusProperty class members, see the User.Type.StatusProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.StatusProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.StatusProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.StatusProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.StatusProperty Class | StarTeam Namespace


User.Type.StatusProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.StatusProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.StatusProperty.Equals(obj).

See Also

User.Type.StatusProperty Class | StarTeam Namespace


User.Type.StatusProperty.FromValue Method

public virtual EnumeratedValue FromValue(
User.Status value
);

See Also

User.Type.StatusProperty Class | StarTeam Namespace


User.Type.StatusProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.StatusProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.StatusProperty.GetHashCode().

See Also

User.Type.StatusProperty Class | StarTeam Namespace


User.Type.StatusProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.StatusProperty.

public override string ToString();

Return Value

com.starteam.User.Type.StatusProperty.ToString()

See Also

User.Type.StatusProperty Class | StarTeam Namespace


User.Type.SundayAMProperty Class

The property type of the Sunday AM property.

For a list of all members of this type, see User.Type.SundayAMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.SundayAMProperty

public class User.Type.SundayAMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.SundayAMProperty Members | StarTeam Namespace


User.Type.SundayAMProperty Members

User.Type.SundayAMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.SundayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.SundayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.SundayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.SundayAMProperty Class | StarTeam Namespace


User.Type.SundayAMProperty Properties

The properties of the User.Type.SundayAMProperty class are listed below. For a complete list of User.Type.SundayAMProperty class members, see the User.Type.SundayAMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.SundayAMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.SundayAMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.SundayAMProperty Class | StarTeam Namespace


User.Type.SundayAMProperty Methods

The methods of the User.Type.SundayAMProperty class are listed below. For a complete list of User.Type.SundayAMProperty class members, see the User.Type.SundayAMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.SundayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.SundayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.SundayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.SundayAMProperty Class | StarTeam Namespace


User.Type.SundayAMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.SundayAMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.SundayAMProperty.Equals(obj).

See Also

User.Type.SundayAMProperty Class | StarTeam Namespace


User.Type.SundayAMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.SundayAMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.SundayAMProperty.GetHashCode().

See Also

User.Type.SundayAMProperty Class | StarTeam Namespace


User.Type.SundayAMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.SundayAMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.SundayAMProperty.ToString()

See Also

User.Type.SundayAMProperty Class | StarTeam Namespace


User.Type.SundayPMProperty Class

The property type of the Sunday PM property.

For a list of all members of this type, see User.Type.SundayPMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.SundayPMProperty

public class User.Type.SundayPMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.SundayPMProperty Members | StarTeam Namespace


User.Type.SundayPMProperty Members

User.Type.SundayPMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.SundayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.SundayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.SundayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.SundayPMProperty Class | StarTeam Namespace


User.Type.SundayPMProperty Properties

The properties of the User.Type.SundayPMProperty class are listed below. For a complete list of User.Type.SundayPMProperty class members, see the User.Type.SundayPMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.SundayPMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.SundayPMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.SundayPMProperty Class | StarTeam Namespace


User.Type.SundayPMProperty Methods

The methods of the User.Type.SundayPMProperty class are listed below. For a complete list of User.Type.SundayPMProperty class members, see the User.Type.SundayPMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.SundayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.SundayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.SundayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.SundayPMProperty Class | StarTeam Namespace


User.Type.SundayPMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.SundayPMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.SundayPMProperty.Equals(obj).

See Also

User.Type.SundayPMProperty Class | StarTeam Namespace


User.Type.SundayPMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.SundayPMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.SundayPMProperty.GetHashCode().

See Also

User.Type.SundayPMProperty Class | StarTeam Namespace


User.Type.SundayPMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.SundayPMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.SundayPMProperty.ToString()

See Also

User.Type.SundayPMProperty Class | StarTeam Namespace


User.Type.TenantProperty Class

For a list of all members of this type, see User.Type.TenantProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
User.Type.TenantProperty

public class User.Type.TenantProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.TenantProperty Members | StarTeam Namespace


User.Type.TenantProperty Members

User.Type.TenantProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.TenantProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TenantProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.TenantProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TenantProperty Class | StarTeam Namespace


User.Type.TenantProperty Properties

The properties of the User.Type.TenantProperty class are listed below. For a complete list of User.Type.TenantProperty class members, see the User.Type.TenantProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.TenantProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.TenantProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.TenantProperty Class | StarTeam Namespace


User.Type.TenantProperty Methods

The methods of the User.Type.TenantProperty class are listed below. For a complete list of User.Type.TenantProperty class members, see the User.Type.TenantProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.TenantProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TenantProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.TenantProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TenantProperty Class | StarTeam Namespace


User.Type.TenantProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.TenantProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.TenantProperty.Equals(obj).

See Also

User.Type.TenantProperty Class | StarTeam Namespace


User.Type.TenantProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.TenantProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.TenantProperty.GetHashCode().

See Also

User.Type.TenantProperty Class | StarTeam Namespace


User.Type.TenantProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.TenantProperty.

public override string ToString();

Return Value

com.starteam.User.Type.TenantProperty.ToString()

See Also

User.Type.TenantProperty Class | StarTeam Namespace


User.Type.TerritoryProperty Class

The property type of the Territory property.

For a list of all members of this type, see User.Type.TerritoryProperty Members.

System.Object
Property
EnumeratedProperty
User.Type.TerritoryProperty

public class User.Type.TerritoryProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.TerritoryProperty Members | StarTeam Namespace


User.Type.TerritoryProperty Members

User.Type.TerritoryProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.TerritoryProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TerritoryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.TerritoryProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TerritoryProperty Class | StarTeam Namespace


User.Type.TerritoryProperty Properties

The properties of the User.Type.TerritoryProperty class are listed below. For a complete list of User.Type.TerritoryProperty class members, see the User.Type.TerritoryProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

User.Type.TerritoryProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.TerritoryProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.TerritoryProperty Class | StarTeam Namespace


User.Type.TerritoryProperty Methods

The methods of the User.Type.TerritoryProperty class are listed below. For a complete list of User.Type.TerritoryProperty class members, see the User.Type.TerritoryProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.User.Type.TerritoryProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TerritoryProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.User.Type.TerritoryProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TerritoryProperty Class | StarTeam Namespace


User.Type.TerritoryProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.TerritoryProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.TerritoryProperty.Equals(obj).

See Also

User.Type.TerritoryProperty Class | StarTeam Namespace


User.Type.TerritoryProperty.FromValue Method

public virtual EnumeratedValue FromValue(
User.GeographicTerritory value
);

See Also

User.Type.TerritoryProperty Class | StarTeam Namespace


User.Type.TerritoryProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.TerritoryProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.TerritoryProperty.GetHashCode().

See Also

User.Type.TerritoryProperty Class | StarTeam Namespace


User.Type.TerritoryProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.TerritoryProperty.

public override string ToString();

Return Value

com.starteam.User.Type.TerritoryProperty.ToString()

See Also

User.Type.TerritoryProperty Class | StarTeam Namespace


User.Type.ThursdayAMProperty Class

The property type of the Thursday AM property.

For a list of all members of this type, see User.Type.ThursdayAMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.ThursdayAMProperty

public class User.Type.ThursdayAMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.ThursdayAMProperty Members | StarTeam Namespace


User.Type.ThursdayAMProperty Members

User.Type.ThursdayAMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.ThursdayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.ThursdayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.ThursdayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.ThursdayAMProperty Class | StarTeam Namespace


User.Type.ThursdayAMProperty Properties

The properties of the User.Type.ThursdayAMProperty class are listed below. For a complete list of User.Type.ThursdayAMProperty class members, see the User.Type.ThursdayAMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.ThursdayAMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.ThursdayAMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.ThursdayAMProperty Class | StarTeam Namespace


User.Type.ThursdayAMProperty Methods

The methods of the User.Type.ThursdayAMProperty class are listed below. For a complete list of User.Type.ThursdayAMProperty class members, see the User.Type.ThursdayAMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.ThursdayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.ThursdayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.ThursdayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.ThursdayAMProperty Class | StarTeam Namespace


User.Type.ThursdayAMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.ThursdayAMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.ThursdayAMProperty.Equals(obj).

See Also

User.Type.ThursdayAMProperty Class | StarTeam Namespace


User.Type.ThursdayAMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.ThursdayAMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.ThursdayAMProperty.GetHashCode().

See Also

User.Type.ThursdayAMProperty Class | StarTeam Namespace


User.Type.ThursdayAMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.ThursdayAMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.ThursdayAMProperty.ToString()

See Also

User.Type.ThursdayAMProperty Class | StarTeam Namespace


User.Type.ThursdayPMProperty Class

The property type of the Thursday PM property.

For a list of all members of this type, see User.Type.ThursdayPMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.ThursdayPMProperty

public class User.Type.ThursdayPMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.ThursdayPMProperty Members | StarTeam Namespace


User.Type.ThursdayPMProperty Members

User.Type.ThursdayPMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.ThursdayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.ThursdayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.ThursdayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.ThursdayPMProperty Class | StarTeam Namespace


User.Type.ThursdayPMProperty Properties

The properties of the User.Type.ThursdayPMProperty class are listed below. For a complete list of User.Type.ThursdayPMProperty class members, see the User.Type.ThursdayPMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.ThursdayPMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.ThursdayPMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.ThursdayPMProperty Class | StarTeam Namespace


User.Type.ThursdayPMProperty Methods

The methods of the User.Type.ThursdayPMProperty class are listed below. For a complete list of User.Type.ThursdayPMProperty class members, see the User.Type.ThursdayPMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.ThursdayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.ThursdayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.ThursdayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.ThursdayPMProperty Class | StarTeam Namespace


User.Type.ThursdayPMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.ThursdayPMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.ThursdayPMProperty.Equals(obj).

See Also

User.Type.ThursdayPMProperty Class | StarTeam Namespace


User.Type.ThursdayPMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.ThursdayPMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.ThursdayPMProperty.GetHashCode().

See Also

User.Type.ThursdayPMProperty Class | StarTeam Namespace


User.Type.ThursdayPMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.ThursdayPMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.ThursdayPMProperty.ToString()

See Also

User.Type.ThursdayPMProperty Class | StarTeam Namespace


User.Type.TimeZoneShiftProperty Class

The property type of the Time Zone Shift property.

For a list of all members of this type, see User.Type.TimeZoneShiftProperty Members.

System.Object
Property
ScalarProperty
TimeSpanProperty
User.Type.TimeZoneShiftProperty

public class User.Type.TimeZoneShiftProperty : TimeSpanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.TimeZoneShiftProperty Members | StarTeam Namespace


User.Type.TimeZoneShiftProperty Members

User.Type.TimeZoneShiftProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.TimeZoneShiftProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TimeZoneShiftProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.TimeZoneShiftProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TimeZoneShiftProperty Class | StarTeam Namespace


User.Type.TimeZoneShiftProperty Properties

The properties of the User.Type.TimeZoneShiftProperty class are listed below. For a complete list of User.Type.TimeZoneShiftProperty class members, see the User.Type.TimeZoneShiftProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

See Also

User.Type.TimeZoneShiftProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.TimeZoneShiftProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.TimeZoneShiftProperty Class | StarTeam Namespace


User.Type.TimeZoneShiftProperty Methods

The methods of the User.Type.TimeZoneShiftProperty class are listed below. For a complete list of User.Type.TimeZoneShiftProperty class members, see the User.Type.TimeZoneShiftProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.TimeZoneShiftProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TimeZoneShiftProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.TimeZoneShiftProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TimeZoneShiftProperty Class | StarTeam Namespace


User.Type.TimeZoneShiftProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.TimeZoneShiftProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.TimeZoneShiftProperty.Equals(obj).

See Also

User.Type.TimeZoneShiftProperty Class | StarTeam Namespace


User.Type.TimeZoneShiftProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.TimeZoneShiftProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.TimeZoneShiftProperty.GetHashCode().

See Also

User.Type.TimeZoneShiftProperty Class | StarTeam Namespace


User.Type.TimeZoneShiftProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.TimeZoneShiftProperty.

public override string ToString();

Return Value

com.starteam.User.Type.TimeZoneShiftProperty.ToString()

See Also

User.Type.TimeZoneShiftProperty Class | StarTeam Namespace


User.Type.TuesdayAMProperty Class

The property type of the Tuesday AM property.

For a list of all members of this type, see User.Type.TuesdayAMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.TuesdayAMProperty

public class User.Type.TuesdayAMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.TuesdayAMProperty Members | StarTeam Namespace


User.Type.TuesdayAMProperty Members

User.Type.TuesdayAMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.TuesdayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TuesdayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.TuesdayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TuesdayAMProperty Class | StarTeam Namespace


User.Type.TuesdayAMProperty Properties

The properties of the User.Type.TuesdayAMProperty class are listed below. For a complete list of User.Type.TuesdayAMProperty class members, see the User.Type.TuesdayAMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.TuesdayAMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.TuesdayAMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.TuesdayAMProperty Class | StarTeam Namespace


User.Type.TuesdayAMProperty Methods

The methods of the User.Type.TuesdayAMProperty class are listed below. For a complete list of User.Type.TuesdayAMProperty class members, see the User.Type.TuesdayAMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.TuesdayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TuesdayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.TuesdayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TuesdayAMProperty Class | StarTeam Namespace


User.Type.TuesdayAMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.TuesdayAMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.TuesdayAMProperty.Equals(obj).

See Also

User.Type.TuesdayAMProperty Class | StarTeam Namespace


User.Type.TuesdayAMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.TuesdayAMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.TuesdayAMProperty.GetHashCode().

See Also

User.Type.TuesdayAMProperty Class | StarTeam Namespace


User.Type.TuesdayAMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.TuesdayAMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.TuesdayAMProperty.ToString()

See Also

User.Type.TuesdayAMProperty Class | StarTeam Namespace


User.Type.TuesdayPMProperty Class

The property type of the Tuesday PM property.

For a list of all members of this type, see User.Type.TuesdayPMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.TuesdayPMProperty

public class User.Type.TuesdayPMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.TuesdayPMProperty Members | StarTeam Namespace


User.Type.TuesdayPMProperty Members

User.Type.TuesdayPMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.TuesdayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TuesdayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.TuesdayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TuesdayPMProperty Class | StarTeam Namespace


User.Type.TuesdayPMProperty Properties

The properties of the User.Type.TuesdayPMProperty class are listed below. For a complete list of User.Type.TuesdayPMProperty class members, see the User.Type.TuesdayPMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.TuesdayPMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.TuesdayPMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.TuesdayPMProperty Class | StarTeam Namespace


User.Type.TuesdayPMProperty Methods

The methods of the User.Type.TuesdayPMProperty class are listed below. For a complete list of User.Type.TuesdayPMProperty class members, see the User.Type.TuesdayPMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.TuesdayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.TuesdayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.TuesdayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.TuesdayPMProperty Class | StarTeam Namespace


User.Type.TuesdayPMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.TuesdayPMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.TuesdayPMProperty.Equals(obj).

See Also

User.Type.TuesdayPMProperty Class | StarTeam Namespace


User.Type.TuesdayPMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.TuesdayPMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.TuesdayPMProperty.GetHashCode().

See Also

User.Type.TuesdayPMProperty Class | StarTeam Namespace


User.Type.TuesdayPMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.TuesdayPMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.TuesdayPMProperty.ToString()

See Also

User.Type.TuesdayPMProperty Class | StarTeam Namespace


User.Type.UserImageProperty Class

The property type of the Picture property.

For a list of all members of this type, see User.Type.UserImageProperty Members.

System.Object
Property
ContentProperty
User.Type.UserImageProperty

public class User.Type.UserImageProperty : ContentProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.UserImageProperty Members | StarTeam Namespace


User.Type.UserImageProperty Members

User.Type.UserImageProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.UserImageProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.UserImageProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.User.Type.UserImageProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.UserImageProperty Class | StarTeam Namespace


User.Type.UserImageProperty Properties

The properties of the User.Type.UserImageProperty class are listed below. For a complete list of User.Type.UserImageProperty class members, see the User.Type.UserImageProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ContentProperty) | [read/write] Content
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.UserImageProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.UserImageProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.UserImageProperty Class | StarTeam Namespace


User.Type.UserImageProperty Methods

The methods of the User.Type.UserImageProperty class are listed below. For a complete list of User.Type.UserImageProperty class members, see the User.Type.UserImageProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.UserImageProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.UserImageProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
HasDisplayValue (inherited from ContentProperty) | Returns true if this property has meaningful display values that may be included, for example, in an item table.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToContent (inherited from ContentProperty) | Converts a property value to the type that is exposed by default to client applications. Note that if the return type is something that is not natively supported by Variant, then you will have to override toVariant() and fromVariant(), too.
ToString | Delegate ToString() to com.starteam.User.Type.UserImageProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.UserImageProperty Class | StarTeam Namespace


User.Type.UserImageProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.UserImageProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.UserImageProperty.Equals(obj).

See Also

User.Type.UserImageProperty Class | StarTeam Namespace


User.Type.UserImageProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.UserImageProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.UserImageProperty.GetHashCode().

See Also

User.Type.UserImageProperty Class | StarTeam Namespace


User.Type.UserImageProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.UserImageProperty.

public override string ToString();

Return Value

com.starteam.User.Type.UserImageProperty.ToString()

See Also

User.Type.UserImageProperty Class | StarTeam Namespace


User.Type.VoiceMailProperty Class

The property type of the Voice Mail property.

For a list of all members of this type, see User.Type.VoiceMailProperty Members.

System.Object
Property
VectorProperty
TextProperty
User.Type.VoiceMailProperty

public class User.Type.VoiceMailProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.VoiceMailProperty Members | StarTeam Namespace


User.Type.VoiceMailProperty Members

User.Type.VoiceMailProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.VoiceMailProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.VoiceMailProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.VoiceMailProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.VoiceMailProperty Class | StarTeam Namespace


User.Type.VoiceMailProperty Properties

The properties of the User.Type.VoiceMailProperty class are listed below. For a complete list of User.Type.VoiceMailProperty class members, see the User.Type.VoiceMailProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.VoiceMailProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.VoiceMailProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.VoiceMailProperty Class | StarTeam Namespace


User.Type.VoiceMailProperty Methods

The methods of the User.Type.VoiceMailProperty class are listed below. For a complete list of User.Type.VoiceMailProperty class members, see the User.Type.VoiceMailProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.VoiceMailProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.VoiceMailProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.VoiceMailProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.VoiceMailProperty Class | StarTeam Namespace


User.Type.VoiceMailProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.VoiceMailProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.VoiceMailProperty.Equals(obj).

See Also

User.Type.VoiceMailProperty Class | StarTeam Namespace


User.Type.VoiceMailProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.VoiceMailProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.VoiceMailProperty.GetHashCode().

See Also

User.Type.VoiceMailProperty Class | StarTeam Namespace


User.Type.VoiceMailProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.VoiceMailProperty.

public override string ToString();

Return Value

com.starteam.User.Type.VoiceMailProperty.ToString()

See Also

User.Type.VoiceMailProperty Class | StarTeam Namespace


User.Type.WednesdayAMProperty Class

The property type of the Wednesday AM property.

For a list of all members of this type, see User.Type.WednesdayAMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.WednesdayAMProperty

public class User.Type.WednesdayAMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.WednesdayAMProperty Members | StarTeam Namespace


User.Type.WednesdayAMProperty Members

User.Type.WednesdayAMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.WednesdayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.WednesdayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.WednesdayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.WednesdayAMProperty Class | StarTeam Namespace


User.Type.WednesdayAMProperty Properties

The properties of the User.Type.WednesdayAMProperty class are listed below. For a complete list of User.Type.WednesdayAMProperty class members, see the User.Type.WednesdayAMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.WednesdayAMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.WednesdayAMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.WednesdayAMProperty Class | StarTeam Namespace


User.Type.WednesdayAMProperty Methods

The methods of the User.Type.WednesdayAMProperty class are listed below. For a complete list of User.Type.WednesdayAMProperty class members, see the User.Type.WednesdayAMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.WednesdayAMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.WednesdayAMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.WednesdayAMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.WednesdayAMProperty Class | StarTeam Namespace


User.Type.WednesdayAMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.WednesdayAMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.WednesdayAMProperty.Equals(obj).

See Also

User.Type.WednesdayAMProperty Class | StarTeam Namespace


User.Type.WednesdayAMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.WednesdayAMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.WednesdayAMProperty.GetHashCode().

See Also

User.Type.WednesdayAMProperty Class | StarTeam Namespace


User.Type.WednesdayAMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.WednesdayAMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.WednesdayAMProperty.ToString()

See Also

User.Type.WednesdayAMProperty Class | StarTeam Namespace


User.Type.WednesdayPMProperty Class

The property type of the Wednesday PM property.

For a list of all members of this type, see User.Type.WednesdayPMProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
User.Type.WednesdayPMProperty

public class User.Type.WednesdayPMProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.Type.WednesdayPMProperty Members | StarTeam Namespace


User.Type.WednesdayPMProperty Members

User.Type.WednesdayPMProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.WednesdayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.WednesdayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.WednesdayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.WednesdayPMProperty Class | StarTeam Namespace


User.Type.WednesdayPMProperty Properties

The properties of the User.Type.WednesdayPMProperty class are listed below. For a complete list of User.Type.WednesdayPMProperty class members, see the User.Type.WednesdayPMProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

User.Type.WednesdayPMProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

User.Type.WednesdayPMProperty.NAME Property

public static String NAME {get;}

See Also

User.Type.WednesdayPMProperty Class | StarTeam Namespace


User.Type.WednesdayPMProperty Methods

The methods of the User.Type.WednesdayPMProperty class are listed below. For a complete list of User.Type.WednesdayPMProperty class members, see the User.Type.WednesdayPMProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.User.Type.WednesdayPMProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.User.Type.WednesdayPMProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.User.Type.WednesdayPMProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

User.Type.WednesdayPMProperty Class | StarTeam Namespace


User.Type.WednesdayPMProperty.Equals Method

Delegate Equals() to com.starteam.User.Type.WednesdayPMProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.Type.WednesdayPMProperty.Equals(obj).

See Also

User.Type.WednesdayPMProperty Class | StarTeam Namespace


User.Type.WednesdayPMProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.Type.WednesdayPMProperty.

public override int GetHashCode();

Return Value

com.starteam.User.Type.WednesdayPMProperty.GetHashCode().

See Also

User.Type.WednesdayPMProperty Class | StarTeam Namespace


User.Type.WednesdayPMProperty.ToString Method

Delegate ToString() to com.starteam.User.Type.WednesdayPMProperty.

public override string ToString();

Return Value

com.starteam.User.Type.WednesdayPMProperty.ToString()

See Also

User.Type.WednesdayPMProperty Class | StarTeam Namespace


User.WebCacheUser Class

User accessor for cached SDK Users contained objects are obtained from the artifact cache

For a list of all members of this type, see User.WebCacheUser Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
Principal.WebCachePrincipal
User.WebCacheUser

public class User.WebCacheUser : WebCachePrincipal

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

User.WebCacheUser Members | StarTeam Namespace


User.WebCacheUser Members

User.WebCacheUser overview

Public Static Methods

Create

Public Instance Properties

AccessPolicy | [read/write] this account's access policy
AccountStatus | [read] this account's status.
CacheLastUsedAt | [read] the time at which this user last used this cache or DateTime.VALUE_NOT_SET if this user has been logged out of the cache
ClientGUID | [read] the client GUID for this user
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DistinguishedName | [read/write] the Distinguished Name for Directory Service.
EmailAddress | [read/write] the User's email address.
FavoriteProjects | [read/write] the User's Favorite Projects.
FaxNumber | [read/write] the User's fax number.
Groups | [read] all of the groups to which this User belongs.
HasFixedLicense | [read/write] true if the user has a fixed license
ID | [read] the ID of the underlying object
IsBuiltIn | [read] true if this is a built in user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
IsPrimaryDirectoryService | [read/write] True if this user is in the primary directory service, false if secondary.
LastLogoutTime | [read] The time the user last logged out.
LastWebLogoutTime | [read] The time the user last logged out from the webserver.
LicenseType | [read/write] The type of license assigned to this User.
Logins | [read] a history of logins for this User
LogOnName | [read/write] the User's name
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PagerNumber | [read/write] the User's pager number.
Password | [write] Sets the password for this account. The password should be passed in as clear text, but is stored in an encrypted format
PasswordChangeRequired | [read] true if a password change is required during the current session.
PasswordDaysRemaining | [read] The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.
PhoneNumber | [read/write] the User's phone number.
Picture | [read/write] the Content object used to store a picture of this user
PolicyTimeZoneShift | [read/write] this timezone shift for this account's access policy.
PostalAddress | [read/write] the User's postal address.
PresentationID | [read] the unique integer identifier for this user.
ReturnEmailAddress | [read/write] the User's email address for spoofing.
Server | [read] the Server for this cached object
Territory | [read/write] the Territory this User belongs to
VoiceMailNumber | [read/write] the User's voice mail number.

Public Instance Methods

AddTo | Overloaded.
CanAccessContainerForReading |
CanAccessForReading |
CanCreateArtifactType |
CanCreateProject | Returns true if this user has the right to create projects Note that the user must be logged in to ascertain this right
CanDeleteProject |
Equals | Delegate Equals() to com.starteam.User.WebCacheUser.
ForceLogoff | Forces this User account to be logged off from the server. The effect is immediate ( no need to call the update() method ). Only an Administrator can forceLogoff another user. Additionally, this operation can only be conducted in an Administrative context.
ForcePasswordChange | Forces a password change for this User account. The effect is immediate ( no need to call the update() method ). Only an Administrator can forcea password change for another user. Additionally, this operation can only be conducted in an Administrative context.
GetAccessEndTime1 |
GetAccessEndTime2 |
GetAccessStartTime1 |
GetAccessStartTime2 |
GetCapacityOverriddenOn |
GetDefaultCapacity |
GetHashCode | Delegate GetHashCode() to com.starteam.User.WebCacheUser.
GetOverriddenCapacity |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasContainerRight | Overloaded.
HasContainerRights |
HasDefaultCapacity |
HasOverriddenCapacity |
HasRight |
HasRights |
HasValue |
IsMemberOf |
Ping | ping the cache to keep this user session alive.
Reactivate | Reactivates this User account. The effect is immediate ( no need to call the update() method ).
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom | Overloaded.
SetAccessTimes |
SetDefaultCapacity |
SetOverriddenCapacity |
SetValue | Overloaded. set the value of the property as specified by name
Suspend | Suspend this User account. The effect is immediate ( no need to call the update() method ).
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.User.WebCacheUser.
Unlock | Unlocks this User account. The effect is immediate ( no need to call the update() method ).
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser Properties

The properties of the User.WebCacheUser class are listed below. For a complete list of User.WebCacheUser class members, see the User.WebCacheUser Members topic.

Public Instance Properties

AccessPolicy | [read/write] this account's access policy
AccountStatus | [read] this account's status.
CacheLastUsedAt | [read] the time at which this user last used this cache or DateTime.VALUE_NOT_SET if this user has been logged out of the cache
ClientGUID | [read] the client GUID for this user
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DistinguishedName | [read/write] the Distinguished Name for Directory Service.
EmailAddress | [read/write] the User's email address.
FavoriteProjects | [read/write] the User's Favorite Projects.
FaxNumber | [read/write] the User's fax number.
Groups | [read] all of the groups to which this User belongs.
HasFixedLicense | [read/write] true if the user has a fixed license
ID | [read] the ID of the underlying object
IsBuiltIn | [read] true if this is a built in user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
IsPrimaryDirectoryService | [read/write] True if this user is in the primary directory service, false if secondary.
LastLogoutTime | [read] The time the user last logged out.
LastWebLogoutTime | [read] The time the user last logged out from the webserver.
LicenseType | [read/write] The type of license assigned to this User.
Logins | [read] a history of logins for this User
LogOnName | [read/write] the User's name
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PagerNumber | [read/write] the User's pager number.
Password | [write] Sets the password for this account. The password should be passed in as clear text, but is stored in an encrypted format
PasswordChangeRequired | [read] true if a password change is required during the current session.
PasswordDaysRemaining | [read] The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.
PhoneNumber | [read/write] the User's phone number.
Picture | [read/write] the Content object used to store a picture of this user
PolicyTimeZoneShift | [read/write] this timezone shift for this account's access policy.
PostalAddress | [read/write] the User's postal address.
PresentationID | [read] the unique integer identifier for this user.
ReturnEmailAddress | [read/write] the User's email address for spoofing.
Server | [read] the Server for this cached object
Territory | [read/write] the Territory this User belongs to
VoiceMailNumber | [read/write] the User's voice mail number.

See Also

User.WebCacheUser Class | StarTeam Namespace


AccessPolicy Property

Borland StarTeam SDK for .NET

User.WebCacheUser.AccessPolicy Property

[read/write] this account's access policy

public virtual User.LogOnPolicy AccessPolicy {get; set;}

Property Value

this account's access policy

See Also

User.WebCacheUser Class | StarTeam Namespace


AccountStatus Property

Borland StarTeam SDK for .NET

User.WebCacheUser.AccountStatus Property

[read] this account's status.

public virtual User.Status AccountStatus {get;}

Property Value

this account's status.

See Also

User.WebCacheUser Class | StarTeam Namespace


CacheLastUsedAt Property

Borland StarTeam SDK for .NET

User.WebCacheUser.CacheLastUsedAt Property

[read] the time at which this user last used this cache or DateTime.VALUE_NOT_SET if this user has been logged out of the cache

public virtual DateTime CacheLastUsedAt {get;}

Property Value

the time at which this user last used this cache or DateTime.VALUE_NOT_SET if this user has been logged out of the cache

See Also

User.WebCacheUser Class | StarTeam Namespace


ClientGUID Property

Borland StarTeam SDK for .NET

User.WebCacheUser.ClientGUID Property

[read] the client GUID for this user

public virtual GUID ClientGUID {get;}

Property Value

the client GUID for this user

See Also

User.WebCacheUser Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

User.WebCacheUser.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

User.WebCacheUser Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

User.WebCacheUser.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

User.WebCacheUser Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

User.WebCacheUser.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

User.WebCacheUser Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

User.WebCacheUser.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

User.WebCacheUser Class | StarTeam Namespace


DistinguishedName Property

Borland StarTeam SDK for .NET

User.WebCacheUser.DistinguishedName Property

[read/write] the Distinguished Name for Directory Service.

public virtual String DistinguishedName {get; set;}

Property Value

the Distinguished Name for Directory Service.

See Also

User.WebCacheUser Class | StarTeam Namespace


EmailAddress Property

Borland StarTeam SDK for .NET

User.WebCacheUser.EmailAddress Property

[read/write] the User's email address.

public virtual String EmailAddress {get; set;}

Property Value

the User's email address.

See Also

User.WebCacheUser Class | StarTeam Namespace


FavoriteProjects Property

Borland StarTeam SDK for .NET

User.WebCacheUser.FavoriteProjects Property

[read/write] the User's Favorite Projects.

public virtual WebCacheProject[] FavoriteProjects {get; set;}

Property Value

the User's Favorite Projects.

See Also

User.WebCacheUser Class | StarTeam Namespace


FaxNumber Property

Borland StarTeam SDK for .NET

User.WebCacheUser.FaxNumber Property

[read/write] the User's fax number.

public virtual String FaxNumber {get; set;}

Property Value

the User's fax number.

See Also

User.WebCacheUser Class | StarTeam Namespace


Groups Property

Borland StarTeam SDK for .NET

User.WebCacheUser.Groups Property

[read] all of the groups to which this User belongs.

public virtual WebCacheGroup[] Groups {get;}

Property Value

all of the groups to which this User belongs.

See Also

User.WebCacheUser Class | StarTeam Namespace


HasFixedLicense Property

Borland StarTeam SDK for .NET

User.WebCacheUser.HasFixedLicense Property

[read/write] true if the user has a fixed license

public virtual Boolean HasFixedLicense {get; set;}

Property Value

true if the user has a fixed license

See Also

User.WebCacheUser Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

User.WebCacheUser.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

User.WebCacheUser Class | StarTeam Namespace


IsBuiltIn Property

Borland StarTeam SDK for .NET

User.WebCacheUser.IsBuiltIn Property

[read] true if this is a built in user

public virtual Boolean IsBuiltIn {get;}

Property Value

true if this is a built in user

See Also

User.WebCacheUser Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

User.WebCacheUser.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

User.WebCacheUser Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

User.WebCacheUser.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

User.WebCacheUser Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

User.WebCacheUser.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

User.WebCacheUser Class | StarTeam Namespace


IsPrimaryDirectoryService Property

Borland StarTeam SDK for .NET

User.WebCacheUser.IsPrimaryDirectoryService Property

[read/write] True if this user is in the primary directory service, false if secondary.

public virtual Boolean IsPrimaryDirectoryService {get; set;}

Property Value

True if this user is in the primary directory service, false if secondary.

See Also

User.WebCacheUser Class | StarTeam Namespace


LastLogoutTime Property

Borland StarTeam SDK for .NET

User.WebCacheUser.LastLogoutTime Property

[read] The time the user last logged out.

public virtual DateTime LastLogoutTime {get;}

Property Value

The time the user last logged out.

See Also

User.WebCacheUser Class | StarTeam Namespace


LastWebLogoutTime Property

Borland StarTeam SDK for .NET

User.WebCacheUser.LastWebLogoutTime Property

[read] The time the user last logged out from the webserver.

public virtual DateTime LastWebLogoutTime {get;}

Property Value

The time the user last logged out from the webserver.

See Also

User.WebCacheUser Class | StarTeam Namespace


LicenseType Property

Borland StarTeam SDK for .NET

User.WebCacheUser.LicenseType Property

[read/write] The type of license assigned to this User.

public virtual User.License LicenseType {get; set;}

Property Value

The type of license assigned to this User.

See Also

User.WebCacheUser Class | StarTeam Namespace


Logins Property

Borland StarTeam SDK for .NET

User.WebCacheUser.Logins Property

[read] a history of logins for this User

public virtual LoginHistory[] Logins {get;}

Property Value

a history of logins for this User

See Also

User.WebCacheUser Class | StarTeam Namespace


LogOnName Property

Borland StarTeam SDK for .NET

User.WebCacheUser.LogOnName Property

[read/write] the User's name

public virtual String LogOnName {get; set;}

Property Value

the User's name

See Also

User.WebCacheUser Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

User.WebCacheUser.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

User.WebCacheUser Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

User.WebCacheUser.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

User.WebCacheUser Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

User.WebCacheUser.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

User.WebCacheUser Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

User.WebCacheUser.Name Property

new public virtual String Name {get; set;}

See Also

User.WebCacheUser Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

User.WebCacheUser.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

User.WebCacheUser Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

User.WebCacheUser.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

User.WebCacheUser Class | StarTeam Namespace


PagerNumber Property

Borland StarTeam SDK for .NET

User.WebCacheUser.PagerNumber Property

[read/write] the User's pager number.

public virtual String PagerNumber {get; set;}

Property Value

the User's pager number.

See Also

User.WebCacheUser Class | StarTeam Namespace


Password Property

Borland StarTeam SDK for .NET

User.WebCacheUser.Password Property

[write] Sets the password for this account. The password should be passed in as clear text, but is stored in an encrypted format

public virtual String Password {set;}

Property Value

Sets the password for this account. The password should be passed in as clear text, but is stored in an encrypted format

See Also

User.WebCacheUser Class | StarTeam Namespace


PasswordChangeRequired Property

Borland StarTeam SDK for .NET

User.WebCacheUser.PasswordChangeRequired Property

[read] true if a password change is required during the current session.

public virtual Boolean PasswordChangeRequired {get;}

Property Value

true if a password change is required during the current session.

See Also

User.WebCacheUser Class | StarTeam Namespace


PasswordDaysRemaining Property

Borland StarTeam SDK for .NET

User.WebCacheUser.PasswordDaysRemaining Property

[read] The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.

public virtual Int32 PasswordDaysRemaining {get;}

Property Value

The number of days remaining that the user's current password will remain valid, or -1 if the password will not expire.

See Also

User.WebCacheUser Class | StarTeam Namespace


PhoneNumber Property

Borland StarTeam SDK for .NET

User.WebCacheUser.PhoneNumber Property

[read/write] the User's phone number.

public virtual String PhoneNumber {get; set;}

Property Value

the User's phone number.

See Also

User.WebCacheUser Class | StarTeam Namespace


Picture Property

Borland StarTeam SDK for .NET

User.WebCacheUser.Picture Property

[read/write] the Content object used to store a picture of this user

public virtual Content.WebCacheContent Picture {get; set;}

Property Value

the Content object used to store a picture of this user

See Also

User.WebCacheUser Class | StarTeam Namespace


PolicyTimeZoneShift Property

Borland StarTeam SDK for .NET

User.WebCacheUser.PolicyTimeZoneShift Property

[read/write] this timezone shift for this account's access policy.

public virtual Int32 PolicyTimeZoneShift {get; set;}

Property Value

this timezone shift for this account's access policy.

See Also

User.WebCacheUser Class | StarTeam Namespace


PostalAddress Property

Borland StarTeam SDK for .NET

User.WebCacheUser.PostalAddress Property

[read/write] the User's postal address.

public virtual String PostalAddress {get; set;}

Property Value

the User's postal address.

See Also

User.WebCacheUser Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

User.WebCacheUser.PresentationID Property

[read] the unique integer identifier for this user.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this user.

See Also

User.WebCacheUser Class | StarTeam Namespace


ReturnEmailAddress Property

Borland StarTeam SDK for .NET

User.WebCacheUser.ReturnEmailAddress Property

[read/write] the User's email address for spoofing.

public virtual String ReturnEmailAddress {get; set;}

Property Value

the User's email address for spoofing.

See Also

User.WebCacheUser Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

User.WebCacheUser.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

User.WebCacheUser Class | StarTeam Namespace


Territory Property

Borland StarTeam SDK for .NET

User.WebCacheUser.Territory Property

[read/write] the Territory this User belongs to

public virtual User.GeographicTerritory Territory {get; set;}

Property Value

the Territory this User belongs to

See Also

User.WebCacheUser Class | StarTeam Namespace


VoiceMailNumber Property

Borland StarTeam SDK for .NET

User.WebCacheUser.VoiceMailNumber Property

[read/write] the User's voice mail number.

public virtual String VoiceMailNumber {get; set;}

Property Value

the User's voice mail number.

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser Methods

The methods of the User.WebCacheUser class are listed below. For a complete list of User.WebCacheUser class members, see the User.WebCacheUser Members topic.

Public Static Methods

Create

Public Instance Methods

AddTo | Overloaded.
CanAccessContainerForReading |
CanAccessForReading |
CanCreateArtifactType |
CanCreateProject | Returns true if this user has the right to create projects Note that the user must be logged in to ascertain this right
CanDeleteProject |
Equals | Delegate Equals() to com.starteam.User.WebCacheUser.
ForceLogoff | Forces this User account to be logged off from the server. The effect is immediate ( no need to call the update() method ). Only an Administrator can forceLogoff another user. Additionally, this operation can only be conducted in an Administrative context.
ForcePasswordChange | Forces a password change for this User account. The effect is immediate ( no need to call the update() method ). Only an Administrator can forcea password change for another user. Additionally, this operation can only be conducted in an Administrative context.
GetAccessEndTime1 |
GetAccessEndTime2 |
GetAccessStartTime1 |
GetAccessStartTime2 |
GetCapacityOverriddenOn |
GetDefaultCapacity |
GetHashCode | Delegate GetHashCode() to com.starteam.User.WebCacheUser.
GetOverriddenCapacity |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasContainerRight | Overloaded.
HasContainerRights |
HasDefaultCapacity |
HasOverriddenCapacity |
HasRight |
HasRights |
HasValue |
IsMemberOf |
Ping | ping the cache to keep this user session alive.
Reactivate | Reactivates this User account. The effect is immediate ( no need to call the update() method ).
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom | Overloaded.
SetAccessTimes |
SetDefaultCapacity |
SetOverriddenCapacity |
SetValue | Overloaded. set the value of the property as specified by name
Suspend | Suspend this User account. The effect is immediate ( no need to call the update() method ).
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.User.WebCacheUser.
Unlock | Unlocks this User account. The effect is immediate ( no need to call the update() method ).
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

User.WebCacheUser Class | StarTeam Namespace


AddTo Method

Borland StarTeam SDK for .NET

User.WebCacheUser.AddTo Method

Overload List

public virtual void AddTo(Group.WebCacheGroup);

new public virtual void AddTo(ObjectArrayProperty.WebCacheObjectArrayProperty,LiveObject.WebCacheLiveObject);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.AddTo Method (Group#WebCacheGroup)

public virtual void AddTo(
Group.WebCacheGroup group
);

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.AddTo Overload List


User.WebCacheUser.AddTo Method (ObjectArrayProperty#WebCacheObjectArrayProperty, LiveObject#WebCacheLiveObject)

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.AddTo Overload List


User.WebCacheUser.CanAccessContainerForReading Method

new public virtual bool CanAccessContainerForReading(
ArtifactCacheManager.Securable s
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.CanAccessForReading Method

new public virtual bool CanAccessForReading(
ArtifactCacheManager.Securable s
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.CanCreateArtifactType Method

new public virtual bool CanCreateArtifactType(
ArtifactCacheManager.SecurableContainer sc,
Type.WebCacheType t
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.CanCreateProject Method

Returns true if this user has the right to create projects Note that the user must be logged in to ascertain this right

public virtual bool CanCreateProject();

Return Value

true if user can create a project, false if they cannot or are not logged in

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.CanDeleteProject Method

public virtual bool CanDeleteProject(
Project.WebCacheProject wcp
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.Create Method

public static WebCacheUser Create(
ArtifactCacheManager.Context cntxt
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.Equals Method

Delegate Equals() to com.starteam.User.WebCacheUser.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.User.WebCacheUser.Equals(obj).

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.ForceLogoff Method

Forces this User account to be logged off from the server. The effect is immediate ( no need to call the update() method ). Only an Administrator can forceLogoff another user. Additionally, this operation can only be conducted in an Administrative context.

public virtual void ForceLogoff();

See Also

User.WebCacheUser Class | StarTeam Namespace | getAccountStatus


User.WebCacheUser.ForcePasswordChange Method

Forces a password change for this User account. The effect is immediate ( no need to call the update() method ). Only an Administrator can forcea password change for another user. Additionally, this operation can only be conducted in an Administrative context.

public virtual void ForcePasswordChange();

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.GetAccessEndTime1 Method

public virtual int GetAccessEndTime1(
User.DayOfWeek dayOfWeek
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.GetAccessEndTime2 Method

public virtual int GetAccessEndTime2(
User.DayOfWeek dayOfWeek
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.GetAccessStartTime1 Method

public virtual int GetAccessStartTime1(
User.DayOfWeek dayOfWeek
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.GetAccessStartTime2 Method

public virtual int GetAccessStartTime2(
User.DayOfWeek dayOfWeek
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.GetCapacityOverriddenOn Method

public virtual Date[] GetCapacityOverriddenOn(
Project.WebCacheProject p
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.GetDefaultCapacity Method

public virtual double GetDefaultCapacity(
Project.WebCacheProject p
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.GetHashCode Method

Delegate GetHashCode() to com.starteam.User.WebCacheUser.

public override int GetHashCode();

Return Value

com.starteam.User.WebCacheUser.GetHashCode().

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.GetOverriddenCapacity Method

public virtual double GetOverriddenCapacity(
Project.WebCacheProject p,
Date d
);

See Also

User.WebCacheUser Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

User.WebCacheUser.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.GetValue Overload List


User.WebCacheUser.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.GetValue Overload List


HasContainerRight Method

Borland StarTeam SDK for .NET

User.WebCacheUser.HasContainerRight Method

Overload List

new public virtual bool HasContainerRight(ArtifactCacheManager.Securable,Permission);

new public virtual bool HasContainerRight(ArtifactCacheManager.SecurableContainer,Type.WebCacheType,Permission);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.HasContainerRight Method (ArtifactCacheManager#Securable, Permission)

new public virtual bool HasContainerRight(
ArtifactCacheManager.Securable s,
Permission p
);

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.HasContainerRight Overload List


User.WebCacheUser.HasContainerRight Method (ArtifactCacheManager#SecurableContainer, Type#WebCacheType, Permission)

new public virtual bool HasContainerRight(
ArtifactCacheManager.SecurableContainer sc,
Type.WebCacheType t,
Permission p
);

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.HasContainerRight Overload List


User.WebCacheUser.HasContainerRights Method

new public virtual bool HasContainerRights(
ArtifactCacheManager.Securable s,
PermissionCollection pc
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.HasDefaultCapacity Method

public virtual bool HasDefaultCapacity(
Project.WebCacheProject p
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.HasOverriddenCapacity Method

public virtual bool HasOverriddenCapacity(
Project.WebCacheProject p,
Date d
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.HasRight Method

new public virtual bool HasRight(
ArtifactCacheManager.Securable s,
Permission p
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.HasRights Method

new public virtual bool HasRights(
ArtifactCacheManager.Securable s,
PermissionCollection pc
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.IsMemberOf Method

public virtual bool IsMemberOf(
Group.WebCacheGroup group
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.Ping Method

ping the cache to keep this user session alive.

public virtual void Ping();

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.Reactivate Method

Reactivates this User account. The effect is immediate ( no need to call the update() method ).

public virtual void Reactivate();

See Also

User.WebCacheUser Class | StarTeam Namespace | getAccountStatus


User.WebCacheUser.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

User.WebCacheUser Class | StarTeam Namespace | WebCacheViewMemberCollection


RemoveFrom Method

Borland StarTeam SDK for .NET

User.WebCacheUser.RemoveFrom Method

Overload List

public virtual void RemoveFrom(Group.WebCacheGroup);

new public virtual void RemoveFrom(ObjectArrayProperty.WebCacheObjectArrayProperty,LiveObject.WebCacheLiveObject);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.RemoveFrom Method (Group#WebCacheGroup)

public virtual void RemoveFrom(
Group.WebCacheGroup group
);

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.RemoveFrom Overload List


User.WebCacheUser.RemoveFrom Method (ObjectArrayProperty#WebCacheObjectArrayProperty, LiveObject#WebCacheLiveObject)

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.RemoveFrom Overload List


User.WebCacheUser.SetAccessTimes Method

public virtual void SetAccessTimes(
User.DayOfWeek dayOfWeek,
Int32 start1,
Int32 end1,
Int32 start2,
Int32 end2
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.SetDefaultCapacity Method

public virtual void SetDefaultCapacity(
Project.WebCacheProject p,
Double capacity
);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.SetOverriddenCapacity Method

public virtual void SetOverriddenCapacity(
Project.WebCacheProject p,
Date d,
Double capacity
);

See Also

User.WebCacheUser Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

User.WebCacheUser.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.SetValue Overload List


User.WebCacheUser.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

User.WebCacheUser Class | StarTeam Namespace | User.WebCacheUser.SetValue Overload List


User.WebCacheUser.Suspend Method

Suspend this User account. The effect is immediate ( no need to call the update() method ).

public virtual void Suspend();

See Also

User.WebCacheUser Class | StarTeam Namespace | getAccountStatus


User.WebCacheUser.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.ToString Method

Delegate ToString() to com.starteam.User.WebCacheUser.

public override string ToString();

Return Value

com.starteam.User.WebCacheUser.ToString()

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.Unlock Method

Unlocks this User account. The effect is immediate ( no need to call the update() method ).

public virtual void Unlock();

See Also

User.WebCacheUser Class | StarTeam Namespace


User.WebCacheUser.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

User.WebCacheUser Class | StarTeam Namespace | WebCacheViewMemberCollection


VectorProperty Class

A definition for Vector Properties; subclasses include Arrays, Text etc

For a list of all members of this type, see VectorProperty Members.

System.Object
Property
VectorProperty
BinaryProperty
MapProperty
ObjectArrayProperty
TextProperty

public class VectorProperty : Property

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

VectorProperty Members | StarTeam Namespace


VectorProperty Members

VectorProperty overview

Public Instance Properties

AbsoluteMaxLength | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from Property) | [read/write] the property's default value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

VectorProperty Class | StarTeam Namespace


VectorProperty Properties

The properties of the VectorProperty class are listed below. For a complete list of VectorProperty class members, see the VectorProperty Members topic.

Public Instance Properties

AbsoluteMaxLength | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from Property) | [read/write] the property's default value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

VectorProperty Class | StarTeam Namespace


AbsoluteMaxLength Property

Borland StarTeam SDK for .NET

VectorProperty.AbsoluteMaxLength Property

[read] The absolute maximum length supported for this property type.

public virtual Int32 AbsoluteMaxLength {get;}

Property Value

The absolute maximum length supported for this property type.

See Also

VectorProperty Class | StarTeam Namespace


MaxLength Property

Borland StarTeam SDK for .NET

VectorProperty.MaxLength Property

[read/write] The maximum length of a property value.

public virtual Int32 MaxLength {get; set;}

Property Value

The maximum length of a property value.

See Also

VectorProperty Class | StarTeam Namespace


MinLength Property

Borland StarTeam SDK for .NET

VectorProperty.MinLength Property

[read/write] The minimum length of a property value.

public virtual Int32 MinLength {get; set;}

Property Value

The minimum length of a property value.

See Also

VectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty Class

Base accessor for cached SDK objects encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see VectorProperty.WebCacheVectorProperty Members.

System.Object
Property.WebCacheProperty
VectorProperty.WebCacheVectorProperty
BinaryProperty.WebCacheBinaryProperty
MapProperty.WebCacheMapProperty
ObjectArrayProperty.WebCacheObjectArrayProperty
TextProperty.WebCacheTextProperty

public class VectorProperty.WebCacheVectorProperty : WebCacheProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

VectorProperty.WebCacheVectorProperty Members | StarTeam Namespace


VectorProperty.WebCacheVectorProperty Members

VectorProperty.WebCacheVectorProperty overview

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | [read/write] the property's default value.
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.VectorProperty.WebCacheVectorProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VectorProperty.WebCacheVectorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VectorProperty.WebCacheVectorProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty Properties

The properties of the VectorProperty.WebCacheVectorProperty class are listed below. For a complete list of VectorProperty.WebCacheVectorProperty class members, see the VectorProperty.WebCacheVectorProperty Members topic.

Public Instance Properties

Context | [read] the context of this object.
DefaultValue | [read/write] the property's default value.
DisplayName | [read/write] this property's display name.
DisplayNameTranslations | [read/write] a copy of the Display Name Translations
ID | [read] the ID of the underlying object
IsAdvanced | [read] true if the property is considered advanced.
IsCalculated | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated | [read] true if the property is client calculated.
IsDescriptor | [read] true is this property is a descriptor.
IsDirty | [read] true if this object is dirty
IsDisabled | [read] true is the property is flagged as disabled.
IsEnabled | [read/write] true is the property is flagged as enabled.
IsGenericCalculated | [read] true if the property is calculated on the server by the component.
IsHeader | [read] true if this property is stored in a header field in the database
IsItemProperty | [read] true if this property is an item property; false otherwise.
IsPrimaryDescriptor | [read] true if the property if the primary descriptor.
IsRequired | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted | [read] true if this is a restricted property.
IsRevisionIndependent | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated | [read] true if the property if server calculated.
IsSortByTextValueSupported | [read] boolean
IsStored | [read] true if the property is stored in the server's database.
IsSysDefined | [read] true if the property is a built-in StarTeam property.
IsUserCustomized | [read] true if this property is a user defined property.
IsUserDefined | [read] true if the property is user defined.
IsUserModifiable | [read] true is the property is flagged as user modifiable.
IsViewSpecific | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength | [read/write] The maximum length of a property value.
MinLength | [read/write] The minimum length of a property value.
MyType | [read] the type of this resource.
Name |
NameProperty |

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


DefaultValue Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.DefaultValue Property

[read/write] the property's default value.

new public virtual Object DefaultValue {get; set;}

Property Value

the property's default value.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.DisplayName Property

[read/write] this property's display name.

new public virtual String DisplayName {get; set;}

Property Value

this property's display name.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.DisplayNameTranslations Property

[read/write] a copy of the Display Name Translations

new public virtual Translations DisplayNameTranslations {get; set;}

Property Value

a copy of the Display Name Translations

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsAdvanced Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsAdvanced Property

[read] true if the property is considered advanced.

new public virtual Boolean IsAdvanced {get;}

Property Value

true if the property is considered advanced.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsCalculated Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsCalculated Property

[read] true if this property is caclulated by the server rather than stored in the db

new public virtual Boolean IsCalculated {get;}

Property Value

true if this property is caclulated by the server rather than stored in the db

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsClientCalculated Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsClientCalculated Property

[read] true if the property is client calculated.

new public virtual Boolean IsClientCalculated {get;}

Property Value

true if the property is client calculated.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsDescriptor Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsDescriptor Property

[read] true is this property is a descriptor.

new public virtual Boolean IsDescriptor {get;}

Property Value

true is this property is a descriptor.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsDisabled Property

[read] true is the property is flagged as disabled.

new public virtual Boolean IsDisabled {get;}

Property Value

true is the property is flagged as disabled.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsEnabled Property

[read/write] true is the property is flagged as enabled.

new public virtual Boolean IsEnabled {get; set;}

Property Value

true is the property is flagged as enabled.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsGenericCalculated Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsGenericCalculated Property

[read] true if the property is calculated on the server by the component.

new public virtual Boolean IsGenericCalculated {get;}

Property Value

true if the property is calculated on the server by the component.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsHeader Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsHeader Property

[read] true if this property is stored in a header field in the database

new public virtual Boolean IsHeader {get;}

Property Value

true if this property is stored in a header field in the database

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsItemProperty Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsItemProperty Property

[read] true if this property is an item property; false otherwise.

new public virtual Boolean IsItemProperty {get;}

Property Value

true if this property is an item property; false otherwise.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsPrimaryDescriptor Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsPrimaryDescriptor Property

[read] true if the property if the primary descriptor.

new public virtual Boolean IsPrimaryDescriptor {get;}

Property Value

true if the property if the primary descriptor.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsRequired Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsRequired Property

[read/write] true if a value for this property is required; valid for user-defined properties only.

new public virtual Boolean IsRequired {get; set;}

Property Value

true if a value for this property is required; valid for user-defined properties only.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsRestricted Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsRestricted Property

[read] true if this is a restricted property.

new public virtual Boolean IsRestricted {get;}

Property Value

true if this is a restricted property.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsRevisionIndependent Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsRevisionIndependent Property

[read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsRevisionIndependent {get;}

Property Value

true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsServerCalculated Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsServerCalculated Property

[read] true if the property if server calculated.

new public virtual Boolean IsServerCalculated {get;}

Property Value

true if the property if server calculated.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsSortByTextValueSupported Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsSortByTextValueSupported Property

[read] boolean

new public virtual Boolean IsSortByTextValueSupported {get;}

Property Value

boolean

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsStored Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsStored Property

[read] true if the property is stored in the server's database.

new public virtual Boolean IsStored {get;}

Property Value

true if the property is stored in the server's database.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsSysDefined Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsSysDefined Property

[read] true if the property is a built-in StarTeam property.

new public virtual Boolean IsSysDefined {get;}

Property Value

true if the property is a built-in StarTeam property.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsUserCustomized Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsUserCustomized Property

[read] true if this property is a user defined property.

new public virtual Boolean IsUserCustomized {get;}

Property Value

true if this property is a user defined property.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsUserDefined Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsUserDefined Property

[read] true if the property is user defined.

new public virtual Boolean IsUserDefined {get;}

Property Value

true if the property is user defined.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsUserModifiable Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsUserModifiable Property

[read] true is the property is flagged as user modifiable.

new public virtual Boolean IsUserModifiable {get;}

Property Value

true is the property is flagged as user modifiable.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


IsViewSpecific Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.IsViewSpecific Property

[read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

new public virtual Boolean IsViewSpecific {get;}

Property Value

true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


MaxLength Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.MaxLength Property

[read/write] The maximum length of a property value.

public virtual Int32 MaxLength {get; set;}

Property Value

The maximum length of a property value.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


MinLength Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.MinLength Property

[read/write] The minimum length of a property value.

public virtual Int32 MinLength {get; set;}

Property Value

The minimum length of a property value.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.Name Property

new public virtual String Name {get;}

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

VectorProperty.WebCacheVectorProperty.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty Methods

The methods of the VectorProperty.WebCacheVectorProperty class are listed below. For a complete list of VectorProperty.WebCacheVectorProperty class members, see the VectorProperty.WebCacheVectorProperty Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.VectorProperty.WebCacheVectorProperty.
GetDisplayValue | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VectorProperty.WebCacheVectorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalValue | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache
SetDescriptor | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VectorProperty.WebCacheVectorProperty.
ToXml | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update | Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.Equals Method

Delegate Equals() to com.starteam.VectorProperty.WebCacheVectorProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.VectorProperty.WebCacheVectorProperty.Equals(obj).

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.GetDisplayValue Method

Converts the given property value to a string suitable for display.

new public virtual string GetDisplayValue(
Object value
);

Parameters

value
A legal value for this property.

Return Value

A string representation of the value

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.VectorProperty.WebCacheVectorProperty.

public override int GetHashCode();

Return Value

com.starteam.VectorProperty.WebCacheVectorProperty.GetHashCode().

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.IsLegalValue Method

Returns true if the specified object is a legal value for this property.

new public virtual bool IsLegalValue(
Object _object
);

Parameters

_object

Return Value

true is the specified object is a legal value for this property.

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.IsQueryRelationSupported Method

new public virtual bool IsQueryRelationSupported(
QueryPart.Relation _operator
);

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache

new public virtual void Refresh();

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.SetDescriptor Method

Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetDescriptor();

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.SetPrimaryDescriptor Method

Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml

new public virtual void SetPrimaryDescriptor();

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.ToString Method

Delegate ToString() to com.starteam.VectorProperty.WebCacheVectorProperty.

public override string ToString();

Return Value

com.starteam.VectorProperty.WebCacheVectorProperty.ToString()

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.ToXml Method

Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components

new public virtual string ToXml();

Return Value

an xml representation of this property

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VectorProperty.WebCacheVectorProperty.Update Method

Save a property through the connection pool. The property may be new or an existing one that has been modified. The caller is responsible for manipulating properties. New properties are accessed from the underlying Type. Existing properties should be copies of properties from the underling type, primarily to prevent multiple threads from reading dirty data. Properties do not follow the existing CRUD life cycle of other SDK objects such as Items, Projects or Views. This is because properties are stored in the system catalog, cannot be deleted, and can support very minor changes such as display name, enabled/disabled hints, etc. The semantic structure of a property can never change once the property has been created.

new public virtual void Update();

See Also

VectorProperty.WebCacheVectorProperty Class | StarTeam Namespace


VersionedObject Class

A VersionedObject is a TrackedObject that maintains a revision history.

For a list of all members of this type, see VersionedObject Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember

public class VersionedObject : TrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

VersionedObject Members | StarTeam Namespace


VersionedObject Members

VersionedObject overview

Public Static Methods

GetBranchRevision | Computes the "branch revision" from the specified dot notation. The branch revision is the final number in the notation. For example, the branch revision of "1.1" is 1; the branch revision of "1.2.4.7" is 7.
GetViewVersion | Computes the "view version" from the specified dot notation. The view version starts at 1, and increments for each new item revision. For example, the view version of "1.1" is 2; the view version of "1.2.4.7" is 11.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
RevisionNumber | [read] The revision number for this object revision.
RootObjectID | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
ShortComment | [read/write] the ShortComment for this artifact
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

VersionedObject Class | StarTeam Namespace


VersionedObject Properties

The properties of the VersionedObject class are listed below. For a complete list of VersionedObject class members, see the VersionedObject Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
RevisionNumber | [read] The revision number for this object revision.
RootObjectID | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
ShortComment | [read/write] the ShortComment for this artifact
ViewVersion | [read] The view version number of this item.

See Also

VersionedObject Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

VersionedObject.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

VersionedObject Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

VersionedObject.RevisionNumber Property

[read] The revision number for this object revision.

public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

VersionedObject Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

VersionedObject.RootObjectID Property

[read] The root object ID for this resource.

public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

VersionedObject Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

VersionedObject.ShortComment Property

[read/write] the ShortComment for this artifact

public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

VersionedObject Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

VersionedObject.ViewVersion Property

[read] The view version number of this item.

public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

VersionedObject Class | StarTeam Namespace


VersionedObject Methods

The methods of the VersionedObject class are listed below. For a complete list of VersionedObject class members, see the VersionedObject Members topic.

Public Static Methods

GetBranchRevision | Computes the "branch revision" from the specified dot notation. The branch revision is the final number in the notation. For example, the branch revision of "1.1" is 1; the branch revision of "1.2.4.7" is 7.
GetViewVersion | Computes the "view version" from the specified dot notation. The view version starts at 1, and increments for each new item revision. For example, the view version of "1.1" is 2; the view version of "1.2.4.7" is 11.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

VersionedObject Class | StarTeam Namespace


VersionedObject.GetBranchRevision Method

Computes the "branch revision" from the specified dot notation. The branch revision is the final number in the notation. For example, the branch revision of "1.1" is 1; the branch revision of "1.2.4.7" is 7.

public static int GetBranchRevision(
DotNotation dotNotation
);

Parameters

dotNotation
A dot notation.

Return Value

The corresponding branch revision.

See Also

VersionedObject Class | StarTeam Namespace


VersionedObject.GetViewVersion Method

Computes the "view version" from the specified dot notation. The view version starts at 1, and increments for each new item revision. For example, the view version of "1.1" is 2; the view version of "1.2.4.7" is 11.

public static int GetViewVersion(
DotNotation dotNotation
);

Parameters

dotNotation
A dot notation.

Return Value

The corresponding view version.

See Also

VersionedObject Class | StarTeam Namespace


VersionedObject.Type Class

The Type for VersionedObject

For a list of all members of this type, see VersionedObject.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
TaskDependency.Type
ViewMember.Type
WorkRecord.Type

new public class VersionedObject.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

VersionedObject.Type Members | StarTeam Namespace


VersionedObject.Type Members

VersionedObject.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.

See Also

VersionedObject.Type Class | StarTeam Namespace


VersionedObject.Type Properties

The properties of the VersionedObject.Type class are listed below. For a complete list of VersionedObject.Type class members, see the VersionedObject.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

VersionedObject.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

VersionedObject.Type.NAME Property

new public static String NAME {get;}

See Also

VersionedObject.Type Class | StarTeam Namespace


VersionedObject.Type Methods

The methods of the VersionedObject.Type class are listed below. For a complete list of VersionedObject.Type class members, see the VersionedObject.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.

See Also

VersionedObject.Type Class | StarTeam Namespace


VersionedObject.Type.Equals Method

Delegate Equals() to com.starteam.VersionedObject.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.VersionedObject.Type.Equals(obj).

See Also

VersionedObject.Type Class | StarTeam Namespace


VersionedObject.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.VersionedObject.Type.

public override int GetHashCode();

Return Value

com.starteam.VersionedObject.Type.GetHashCode().

See Also

VersionedObject.Type Class | StarTeam Namespace


VersionedObject.Type.ToString Method

Delegate ToString() to com.starteam.VersionedObject.Type.

public override string ToString();

Return Value

com.starteam.VersionedObject.Type.ToString()

See Also

VersionedObject.Type Class | StarTeam Namespace


VersionedObject.Type.CommentIDProperty Class

The property type of the Comment ID property.

For a list of all members of this type, see VersionedObject.Type.CommentIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
VersionedObject.Type.CommentIDProperty

public class VersionedObject.Type.CommentIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

VersionedObject.Type.CommentIDProperty Members | StarTeam Namespace


VersionedObject.Type.CommentIDProperty Members

VersionedObject.Type.CommentIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.CommentIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.CommentIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.CommentIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

VersionedObject.Type.CommentIDProperty Class | StarTeam Namespace


VersionedObject.Type.CommentIDProperty Properties

The properties of the VersionedObject.Type.CommentIDProperty class are listed below. For a complete list of VersionedObject.Type.CommentIDProperty class members, see the VersionedObject.Type.CommentIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

VersionedObject.Type.CommentIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

VersionedObject.Type.CommentIDProperty.NAME Property

public static String NAME {get;}

See Also

VersionedObject.Type.CommentIDProperty Class | StarTeam Namespace


VersionedObject.Type.CommentIDProperty Methods

The methods of the VersionedObject.Type.CommentIDProperty class are listed below. For a complete list of VersionedObject.Type.CommentIDProperty class members, see the VersionedObject.Type.CommentIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.CommentIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.CommentIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.CommentIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

VersionedObject.Type.CommentIDProperty Class | StarTeam Namespace


VersionedObject.Type.CommentIDProperty.Equals Method

Delegate Equals() to com.starteam.VersionedObject.Type.CommentIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.VersionedObject.Type.CommentIDProperty.Equals(obj).

See Also

VersionedObject.Type.CommentIDProperty Class | StarTeam Namespace


VersionedObject.Type.CommentIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.VersionedObject.Type.CommentIDProperty.

public override int GetHashCode();

Return Value

com.starteam.VersionedObject.Type.CommentIDProperty.GetHashCode().

See Also

VersionedObject.Type.CommentIDProperty Class | StarTeam Namespace


VersionedObject.Type.CommentIDProperty.ToString Method

Delegate ToString() to com.starteam.VersionedObject.Type.CommentIDProperty.

public override string ToString();

Return Value

com.starteam.VersionedObject.Type.CommentIDProperty.ToString()

See Also

VersionedObject.Type.CommentIDProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionFlagsProperty Class

The property type of the Revision Flags property.

For a list of all members of this type, see VersionedObject.Type.RevisionFlagsProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
VersionedObject.Type.RevisionFlagsProperty

public class VersionedObject.Type.RevisionFlagsProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

VersionedObject.Type.RevisionFlagsProperty Members | StarTeam Namespace


VersionedObject.Type.RevisionFlagsProperty Members

VersionedObject.Type.RevisionFlagsProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.RevisionFlagsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.RevisionFlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.RevisionFlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

VersionedObject.Type.RevisionFlagsProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionFlagsProperty Properties

The properties of the VersionedObject.Type.RevisionFlagsProperty class are listed below. For a complete list of VersionedObject.Type.RevisionFlagsProperty class members, see the VersionedObject.Type.RevisionFlagsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

VersionedObject.Type.RevisionFlagsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

VersionedObject.Type.RevisionFlagsProperty.NAME Property

public static String NAME {get;}

See Also

VersionedObject.Type.RevisionFlagsProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionFlagsProperty Methods

The methods of the VersionedObject.Type.RevisionFlagsProperty class are listed below. For a complete list of VersionedObject.Type.RevisionFlagsProperty class members, see the VersionedObject.Type.RevisionFlagsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.RevisionFlagsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.RevisionFlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.RevisionFlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

VersionedObject.Type.RevisionFlagsProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionFlagsProperty.Equals Method

Delegate Equals() to com.starteam.VersionedObject.Type.RevisionFlagsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.VersionedObject.Type.RevisionFlagsProperty.Equals(obj).

See Also

VersionedObject.Type.RevisionFlagsProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionFlagsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.VersionedObject.Type.RevisionFlagsProperty.

public override int GetHashCode();

Return Value

com.starteam.VersionedObject.Type.RevisionFlagsProperty.GetHashCode().

See Also

VersionedObject.Type.RevisionFlagsProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionFlagsProperty.ToString Method

Delegate ToString() to com.starteam.VersionedObject.Type.RevisionFlagsProperty.

public override string ToString();

Return Value

com.starteam.VersionedObject.Type.RevisionFlagsProperty.ToString()

See Also

VersionedObject.Type.RevisionFlagsProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionNumberProperty Class

The property type of the Revision Number property.

For a list of all members of this type, see VersionedObject.Type.RevisionNumberProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
VersionedObject.Type.RevisionNumberProperty

public class VersionedObject.Type.RevisionNumberProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

VersionedObject.Type.RevisionNumberProperty Members | StarTeam Namespace


VersionedObject.Type.RevisionNumberProperty Members

VersionedObject.Type.RevisionNumberProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.RevisionNumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.RevisionNumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.RevisionNumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

VersionedObject.Type.RevisionNumberProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionNumberProperty Properties

The properties of the VersionedObject.Type.RevisionNumberProperty class are listed below. For a complete list of VersionedObject.Type.RevisionNumberProperty class members, see the VersionedObject.Type.RevisionNumberProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

VersionedObject.Type.RevisionNumberProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

VersionedObject.Type.RevisionNumberProperty.NAME Property

public static String NAME {get;}

See Also

VersionedObject.Type.RevisionNumberProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionNumberProperty Methods

The methods of the VersionedObject.Type.RevisionNumberProperty class are listed below. For a complete list of VersionedObject.Type.RevisionNumberProperty class members, see the VersionedObject.Type.RevisionNumberProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.RevisionNumberProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.RevisionNumberProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.RevisionNumberProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

VersionedObject.Type.RevisionNumberProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionNumberProperty.Equals Method

Delegate Equals() to com.starteam.VersionedObject.Type.RevisionNumberProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.VersionedObject.Type.RevisionNumberProperty.Equals(obj).

See Also

VersionedObject.Type.RevisionNumberProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionNumberProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.VersionedObject.Type.RevisionNumberProperty.

public override int GetHashCode();

Return Value

com.starteam.VersionedObject.Type.RevisionNumberProperty.GetHashCode().

See Also

VersionedObject.Type.RevisionNumberProperty Class | StarTeam Namespace


VersionedObject.Type.RevisionNumberProperty.ToString Method

Delegate ToString() to com.starteam.VersionedObject.Type.RevisionNumberProperty.

public override string ToString();

Return Value

com.starteam.VersionedObject.Type.RevisionNumberProperty.ToString()

See Also

VersionedObject.Type.RevisionNumberProperty Class | StarTeam Namespace


VersionedObject.Type.ShortCommentProperty Class

The property type of the Short Comment property.

For a list of all members of this type, see VersionedObject.Type.ShortCommentProperty Members.

System.Object
Property
VectorProperty
TextProperty
VersionedObject.Type.ShortCommentProperty

public class VersionedObject.Type.ShortCommentProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

VersionedObject.Type.ShortCommentProperty Members | StarTeam Namespace


VersionedObject.Type.ShortCommentProperty Members

VersionedObject.Type.ShortCommentProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.ShortCommentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.ShortCommentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.ShortCommentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

VersionedObject.Type.ShortCommentProperty Class | StarTeam Namespace


VersionedObject.Type.ShortCommentProperty Properties

The properties of the VersionedObject.Type.ShortCommentProperty class are listed below. For a complete list of VersionedObject.Type.ShortCommentProperty class members, see the VersionedObject.Type.ShortCommentProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

VersionedObject.Type.ShortCommentProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

VersionedObject.Type.ShortCommentProperty.NAME Property

public static String NAME {get;}

See Also

VersionedObject.Type.ShortCommentProperty Class | StarTeam Namespace


VersionedObject.Type.ShortCommentProperty Methods

The methods of the VersionedObject.Type.ShortCommentProperty class are listed below. For a complete list of VersionedObject.Type.ShortCommentProperty class members, see the VersionedObject.Type.ShortCommentProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.VersionedObject.Type.ShortCommentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.Type.ShortCommentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.VersionedObject.Type.ShortCommentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

VersionedObject.Type.ShortCommentProperty Class | StarTeam Namespace


VersionedObject.Type.ShortCommentProperty.Equals Method

Delegate Equals() to com.starteam.VersionedObject.Type.ShortCommentProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.VersionedObject.Type.ShortCommentProperty.Equals(obj).

See Also

VersionedObject.Type.ShortCommentProperty Class | StarTeam Namespace


VersionedObject.Type.ShortCommentProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.VersionedObject.Type.ShortCommentProperty.

public override int GetHashCode();

Return Value

com.starteam.VersionedObject.Type.ShortCommentProperty.GetHashCode().

See Also

VersionedObject.Type.ShortCommentProperty Class | StarTeam Namespace


VersionedObject.Type.ShortCommentProperty.ToString Method

Delegate ToString() to com.starteam.VersionedObject.Type.ShortCommentProperty.

public override string ToString();

Return Value

com.starteam.VersionedObject.Type.ShortCommentProperty.ToString()

See Also

VersionedObject.Type.ShortCommentProperty Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject Class

Tracked Object accessor for cached SDK Objects contained objects are obtained from the artifact cache

For a list of all members of this type, see VersionedObject.WebCacheVersionedObject Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember

public class VersionedObject.WebCacheVersionedObject : WebCacheTrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

VersionedObject.WebCacheVersionedObject Members | StarTeam Namespace


VersionedObject.WebCacheVersionedObject Members

VersionedObject.WebCacheVersionedObject overview

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
RevisionNumber | [read] The revision number for this object revision.
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShortComment | [read/write] the ShortComment for this artifact
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.VersionedObject.WebCacheVersionedObject.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.WebCacheVersionedObject.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.VersionedObject.WebCacheVersionedObject.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject Properties

The properties of the VersionedObject.WebCacheVersionedObject class are listed below. For a complete list of VersionedObject.WebCacheVersionedObject class members, see the VersionedObject.WebCacheVersionedObject Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
RevisionNumber | [read] The revision number for this object revision.
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShortComment | [read/write] the ShortComment for this artifact
ViewVersion | [read] The view version number of this item.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.Name Property

new public virtual String Name {get;}

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.RevisionNumber Property

[read] The revision number for this object revision.

public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.RootObjectID Property

[read] The root object ID for this resource.

public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.ShortComment Property

[read/write] the ShortComment for this artifact

public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.ViewVersion Property

[read] The view version number of this item.

public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject Methods

The methods of the VersionedObject.WebCacheVersionedObject class are listed below. For a complete list of VersionedObject.WebCacheVersionedObject class members, see the VersionedObject.WebCacheVersionedObject Members topic.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.VersionedObject.WebCacheVersionedObject.
GetHashCode | Delegate GetHashCode() to com.starteam.VersionedObject.WebCacheVersionedObject.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.VersionedObject.WebCacheVersionedObject.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject.Equals Method

Delegate Equals() to com.starteam.VersionedObject.WebCacheVersionedObject.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.VersionedObject.WebCacheVersionedObject.Equals(obj).

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject.GetHashCode Method

Delegate GetHashCode() to com.starteam.VersionedObject.WebCacheVersionedObject.

public override int GetHashCode();

Return Value

com.starteam.VersionedObject.WebCacheVersionedObject.GetHashCode().

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace | VersionedObject.WebCacheVersionedObject.GetValue Overload List


VersionedObject.WebCacheVersionedObject.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace | VersionedObject.WebCacheVersionedObject.GetValue Overload List


VersionedObject.WebCacheVersionedObject.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace | WebCacheViewMemberCollection


VersionedObject.WebCacheVersionedObject.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

VersionedObject.WebCacheVersionedObject.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace | VersionedObject.WebCacheVersionedObject.SetValue Overload List


VersionedObject.WebCacheVersionedObject.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace | VersionedObject.WebCacheVersionedObject.SetValue Overload List


VersionedObject.WebCacheVersionedObject.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject.ToString Method

Delegate ToString() to com.starteam.VersionedObject.WebCacheVersionedObject.

public override string ToString();

Return Value

com.starteam.VersionedObject.WebCacheVersionedObject.ToString()

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace


VersionedObject.WebCacheVersionedObject.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

VersionedObject.WebCacheVersionedObject Class | StarTeam Namespace | WebCacheViewMemberCollection


View Class

Represents a StarTeam View.

For a list of all members of this type, see View Members.

System.Object
TypedResource
LiveObject
View
RecycleBin
MergePreview

public class View : LiveObject, ISecurable, ISecurableContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View Members | StarTeam Namespace


View Members

View overview

Public Instance Constructors

View Overloaded. Initializes a new instance of the View class.

Public Instance Properties

ActiveLabels | [read] The active (non-deleted) labels for this view.
AlternatePath | [read/write] the alternate working file path to be used for this view.
BaseConfiguration | [read] the ViewConfiguration from which this View was derived.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackages | [read] ChangePackageCollection
CloneTime | [read/write] clone time of this View
Configuration | [read] this view's configuration.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DefaultPath | [read/write] the default working file path to be used for this view.
DerivedViews | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description | [read/write] the description of this view.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EndDate | [read/write] end date of this View
ExcludedGroups | [read] The groups who are excluded from VCM Commits.
ExcludedUsers | [read] The users who are excluded from VCM Commits.
FileStatusManager | [read] The FileBasedStatusManager for this View.
FullName | [read] the full hierarchical name of this view.
HighestChangePackageID | [read] the value of the most recent change package
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsAccessible | [read] true if the logged on user has access to this view.
IsBranch | [read] true if this view is a Branch view.
IsBranchAll | [read] true if this view's original branching default was set "All".
IsBranchNone | [read] true if this view's original branching default was set "None".
IsBranchOnShare | [read/write] true if this view is set to branch shared items.
IsDeleted | [read] True if the view has been deleted from the server; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsLightWeightWorkView | [read] true if this view is lightweight work view.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsNonDerived | [read] true if this view is Non-Derived view.
IsReadOnly | [read] true if this view is ReadOnly, otherwise false.
IsReference | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired | [read] true if folder information may be out of date.
IsRefreshLabelsRequired | [read] true if label information may be out of date.
IsRefreshRequired | [read] true if view properties may be out of date.
IsRoot | [read] true if this view is a Root view.
IsVCMCodeReviewRequired | [read/write] whether VCM Code reviews are required
IsVCMCommitEnforced | [read/write] whether VCM Commits are enforced for this View
Labels | [read] The labels (both active and deleted) that exist in this view.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of this view.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer | [read] This object's parent container.
ParentView | [read] the parent of this view, or null if there is no parent.
Path | [read] the working file path being used for this view.
PresentationID | [read] the unique integer identifier for this view.
Project | [read] the project to which this view belongs.
PromotionModel | [read] the promotion model associated with this view.
Properties | [read]
RecycleBin | [read] The recycle bin associated with this view.
Rights | [read/write] the access control list for this view or NULL.
RootFolder | [read] The root folder of this view.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
StartDate | [read/write] start date of this View
StatusMethodOverride | [read/write]
Traces | [read] TraceCollection
TypeValue | [read/write] type (Unknown, Main, Sandbox, Release) of this View
ViewID | [read] the unique integer identifier for this view.
WorkspaceModifiedTime | [read] workspace modified time of this View

Public Instance Methods

AddExcludedGroup | Adds the specified group object as an excluded group from VCM Commits.
AddExcludedUser | Adds the specified user object as an excluded user from VCM Commits.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed. A cloned revision label is supported across projects. This provides a mechanism to attach the correct historical revisions to a cloned label in a view that is the target of cross project or cross view folder tree moves.
CloneViewLabel | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed. View labels may only be cloned from other labels in the same view
Close | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateLightWeightWorkView | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. Supported on servers beginning with release 16.4
CreateLightWeightWorkViewWithPulsePullRequests | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. This work view also supports Pull Requests for code reviews in Pulse Supported on servers beginning with release 17.1
CreateRevisionLabel | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed. Use a DateTime created with the special value 0.0 to create the label as of the current server time.
Discard | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FetchAllLabels | Overloaded. Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FindDerivedView | Return an immediate derived view with the specified name or NULL if none exist
FindFolder | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem | Overloaded.
FindLabel | Overloaded. find and return a label given its name
FindViewMember |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisembodiedItem |
GetDisembodiedViewMember |
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetNewNotificationItems |
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetRights | Returns the Access Control List for items of the specified type for this view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
GetViewMembers |
GetWorkflow |
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasNewNotificationItems |
HasPermissions | Overloaded. Returns true if desired permissions are granted for this view
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares the properties of two Views.
NewFolderEventSource |
NewFolderTreeEventSource |
NewFolderUpdateEventSource |
NewItemEventSource | Overloaded.
NewItemIDEventSource | Overloaded.
NewItemListEventSource | Overloaded.
NewItemUpdateEventSource |
NewLabelEventSource |
NewNotificationEventSource | Overloaded.
NewViewEventSource |
NewViewMemberEventSource | Overloaded.
NewViewMemberUpdateEventSource |
Populate | Populates view properties, if they have not already been populated.
Refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel | Refreshes the local cached information about this view's promotion model.
Remove | Removes the view from the server.
RemoveExcludedGroup | Removes the specified group object as an excluded group from VCM Commits.
RemoveExcludedUser | Removes the specified user object as an excluded user from VCM Commits.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveWorkflow | remove all workflow definitions for this view
ResolveLinkEndpoint |
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights | Modifies the Access Control List for items of the specified type for this view. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
SupportsPullRequests | Return true if this view supports pull requests.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Persists this view's properties to its Server.

See Also

View Class | StarTeam Namespace


View Constructor

A constructor used to create a new view.

Overload List

A view "copy" constructor that allows the specification of an arbitrary configuration. This does not really create a new view on the server but rather creates a client side View object set to the specified configuration.

public View(View,ViewConfiguration);

A constructor used to create a new view.

public View(View,Boolean,Boolean,String,String,Folder,String,ViewConfiguration,Boolean);

A constructor used to create a blank view.

public View(View,String,String,String);

See Also

View Class | StarTeam Namespace | ViewConfiguration


View Constructor (View, Boolean, Boolean, String, String, Folder, String, ViewConfiguration, Boolean)

A constructor used to create a new view.

public View(
View parent,
Boolean bIsVariantView,
Boolean bIsROView,
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

Parameters

parent
the new view's parent view.
bIsVariantView
true for a variant view, false for a reference view.
bIsROView
true for a read-only view, false for a normal view.
name
the new view's name.
description
the new view's description.
rootFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.
baseConfig
the ViewConfiguration for the view. For a derived view, specify the parent view's configuration. For a floating view, specify a "current" configuration.
bIsBranched
true for branch on change. Sets initial branching behavior in derived variant views for all items shared during the view creation from the active view. Specify true for default branching, false for default floating.

See Also

View Class | StarTeam Namespace | View Constructor Overload List | ViewConfiguration


View Constructor (View, String, String, String)

A constructor used to create a blank view.

public View(
View parent,
String name,
String description,
String defaultWorkingFolder
);

Parameters

parent
the new view's parent view.
name
the new view's name.
description
the new view's description.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.

See Also

View Class | StarTeam Namespace | View Constructor Overload List


View Constructor (View, ViewConfiguration)

A view "copy" constructor that allows the specification of an arbitrary configuration. This does not really create a new view on the server but rather creates a client side View object set to the specified configuration.

public View(
View view,
ViewConfiguration configuration
);

Parameters

view
the view being configured
configuration
the desired configuration of the specified view.

See Also

View Class | StarTeam Namespace | View Constructor Overload List


View Properties

The properties of the View class are listed below. For a complete list of View class members, see the View Members topic.

Public Instance Properties

ActiveLabels | [read] The active (non-deleted) labels for this view.
AlternatePath | [read/write] the alternate working file path to be used for this view.
BaseConfiguration | [read] the ViewConfiguration from which this View was derived.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackages | [read] ChangePackageCollection
CloneTime | [read/write] clone time of this View
Configuration | [read] this view's configuration.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DefaultPath | [read/write] the default working file path to be used for this view.
DerivedViews | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description | [read/write] the description of this view.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EndDate | [read/write] end date of this View
ExcludedGroups | [read] The groups who are excluded from VCM Commits.
ExcludedUsers | [read] The users who are excluded from VCM Commits.
FileStatusManager | [read] The FileBasedStatusManager for this View.
FullName | [read] the full hierarchical name of this view.
HighestChangePackageID | [read] the value of the most recent change package
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsAccessible | [read] true if the logged on user has access to this view.
IsBranch | [read] true if this view is a Branch view.
IsBranchAll | [read] true if this view's original branching default was set "All".
IsBranchNone | [read] true if this view's original branching default was set "None".
IsBranchOnShare | [read/write] true if this view is set to branch shared items.
IsDeleted | [read] True if the view has been deleted from the server; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsLightWeightWorkView | [read] true if this view is lightweight work view.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsNonDerived | [read] true if this view is Non-Derived view.
IsReadOnly | [read] true if this view is ReadOnly, otherwise false.
IsReference | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired | [read] true if folder information may be out of date.
IsRefreshLabelsRequired | [read] true if label information may be out of date.
IsRefreshRequired | [read] true if view properties may be out of date.
IsRoot | [read] true if this view is a Root view.
IsVCMCodeReviewRequired | [read/write] whether VCM Code reviews are required
IsVCMCommitEnforced | [read/write] whether VCM Commits are enforced for this View
Labels | [read] The labels (both active and deleted) that exist in this view.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the name of this view.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer | [read] This object's parent container.
ParentView | [read] the parent of this view, or null if there is no parent.
Path | [read] the working file path being used for this view.
PresentationID | [read] the unique integer identifier for this view.
Project | [read] the project to which this view belongs.
PromotionModel | [read] the promotion model associated with this view.
Properties | [read]
RecycleBin | [read] The recycle bin associated with this view.
Rights | [read/write] the access control list for this view or NULL.
RootFolder | [read] The root folder of this view.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
StartDate | [read/write] start date of this View
StatusMethodOverride | [read/write]
Traces | [read] TraceCollection
TypeValue | [read/write] type (Unknown, Main, Sandbox, Release) of this View
ViewID | [read] the unique integer identifier for this view.
WorkspaceModifiedTime | [read] workspace modified time of this View

See Also

View Class | StarTeam Namespace


ActiveLabels Property

Borland StarTeam SDK for .NET

View.ActiveLabels Property

[read] The active (non-deleted) labels for this view.

public virtual Label[] ActiveLabels {get;}

Property Value

The active (non-deleted) labels for this view.

See Also

View Class | StarTeam Namespace


AlternatePath Property

Borland StarTeam SDK for .NET

View.AlternatePath Property

[read/write] the alternate working file path to be used for this view.

public virtual String AlternatePath {get; set;}

Property Value

the alternate working file path to be used for this view.

See Also

View Class | StarTeam Namespace


BaseConfiguration Property

Borland StarTeam SDK for .NET

View.BaseConfiguration Property

[read] the ViewConfiguration from which this View was derived.

public virtual ViewConfiguration BaseConfiguration {get;}

Property Value

the ViewConfiguration from which this View was derived.

See Also

View Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

View.ChangePackages Property

[read] ChangePackageCollection

public virtual ChangePackageCollection ChangePackages {get;}

Property Value

ChangePackageCollection

See Also

View Class | StarTeam Namespace


CloneTime Property

Borland StarTeam SDK for .NET

View.CloneTime Property

[read/write] clone time of this View

public virtual DateTime CloneTime {get; set;}

Property Value

clone time of this View

See Also

View Class | StarTeam Namespace


Configuration Property

Borland StarTeam SDK for .NET

View.Configuration Property

[read] this view's configuration.

public virtual ViewConfiguration Configuration {get;}

Property Value

this view's configuration.

See Also

View Class | StarTeam Namespace


DefaultPath Property

Borland StarTeam SDK for .NET

View.DefaultPath Property

[read/write] the default working file path to be used for this view.

public virtual String DefaultPath {get; set;}

Property Value

the default working file path to be used for this view.

See Also

View Class | StarTeam Namespace


DerivedViews Property

Borland StarTeam SDK for .NET

View.DerivedViews Property

[read] The set of views derived from this one. Returns an empty array if there are no derived views.

public virtual View[] DerivedViews {get;}

Property Value

The set of views derived from this one. Returns an empty array if there are no derived views.

See Also

View Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

View.Description Property

[read/write] the description of this view.

public virtual String Description {get; set;}

Property Value

the description of this view.

See Also

View Class | StarTeam Namespace


EndDate Property

Borland StarTeam SDK for .NET

View.EndDate Property

[read/write] end date of this View

public virtual DateTime EndDate {get; set;}

Property Value

end date of this View

See Also

View Class | StarTeam Namespace


ExcludedGroups Property

Borland StarTeam SDK for .NET

View.ExcludedGroups Property

[read] The groups who are excluded from VCM Commits.

public virtual Group[] ExcludedGroups {get;}

Property Value

The groups who are excluded from VCM Commits.

See Also

View Class | StarTeam Namespace


ExcludedUsers Property

Borland StarTeam SDK for .NET

View.ExcludedUsers Property

[read] The users who are excluded from VCM Commits.

public virtual User[] ExcludedUsers {get;}

Property Value

The users who are excluded from VCM Commits.

See Also

View Class | StarTeam Namespace


FileStatusManager Property

Borland StarTeam SDK for .NET

View.FileStatusManager Property

[read] The FileBasedStatusManager for this View.

public virtual FileBasedStatusManager FileStatusManager {get;}

Property Value

The FileBasedStatusManager for this View.

See Also

View Class | StarTeam Namespace


FullName Property

Borland StarTeam SDK for .NET

View.FullName Property

[read] the full hierarchical name of this view.

public virtual String FullName {get;}

Property Value

the full hierarchical name of this view.

See Also

View Class | StarTeam Namespace


HighestChangePackageID Property

Borland StarTeam SDK for .NET

View.HighestChangePackageID Property

[read] the value of the most recent change package

public virtual Int32 HighestChangePackageID {get;}

Property Value

the value of the most recent change package

See Also

View Class | StarTeam Namespace


IsAccessible Property

Borland StarTeam SDK for .NET

View.IsAccessible Property

[read] true if the logged on user has access to this view.

public virtual Boolean IsAccessible {get;}

Property Value

true if the logged on user has access to this view.

See Also

View Class | StarTeam Namespace


IsBranch Property

Borland StarTeam SDK for .NET

View.IsBranch Property

[read] true if this view is a Branch view.

public virtual Boolean IsBranch {get;}

Property Value

true if this view is a Branch view.

See Also

View Class | StarTeam Namespace


IsBranchAll Property

Borland StarTeam SDK for .NET

View.IsBranchAll Property

[read] true if this view's original branching default was set "All".

public virtual Boolean IsBranchAll {get;}

Property Value

true if this view's original branching default was set "All".

See Also

View Class | StarTeam Namespace


IsBranchNone Property

Borland StarTeam SDK for .NET

View.IsBranchNone Property

[read] true if this view's original branching default was set "None".

public virtual Boolean IsBranchNone {get;}

Property Value

true if this view's original branching default was set "None".

See Also

View Class | StarTeam Namespace


IsBranchOnShare Property

Borland StarTeam SDK for .NET

View.IsBranchOnShare Property

[read/write] true if this view is set to branch shared items.

public virtual Boolean IsBranchOnShare {get; set;}

Property Value

true if this view is set to branch shared items.

See Also

View Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

View.IsDeleted Property

[read] True if the view has been deleted from the server; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if the view has been deleted from the server; false otherwise.

Implements

ISecurableContainer.IsDeleted

See Also

View Class | StarTeam Namespace


IsLightWeightWorkView Property

Borland StarTeam SDK for .NET

View.IsLightWeightWorkView Property

[read] true if this view is lightweight work view.

public virtual Boolean IsLightWeightWorkView {get;}

Property Value

true if this view is lightweight work view.

See Also

View Class | StarTeam Namespace


IsNonDerived Property

Borland StarTeam SDK for .NET

View.IsNonDerived Property

[read] true if this view is Non-Derived view.

public virtual Boolean IsNonDerived {get;}

Property Value

true if this view is Non-Derived view.

See Also

View Class | StarTeam Namespace


IsReadOnly Property

Borland StarTeam SDK for .NET

View.IsReadOnly Property

[read] true if this view is ReadOnly, otherwise false.

public virtual Boolean IsReadOnly {get;}

Property Value

true if this view is ReadOnly, otherwise false.

See Also

View Class | StarTeam Namespace


IsReference Property

Borland StarTeam SDK for .NET

View.IsReference Property

[read] true if this is a reference view, otherwise false.

public virtual Boolean IsReference {get;}

Property Value

true if this is a reference view, otherwise false.

See Also

View Class | StarTeam Namespace


IsRefreshActiveLabelsRequired Property

Borland StarTeam SDK for .NET

View.IsRefreshActiveLabelsRequired Property

[read] true if the active label information may be out of date.

public virtual Boolean IsRefreshActiveLabelsRequired {get;}

Property Value

true if the active label information may be out of date.

See Also

View Class | StarTeam Namespace


IsRefreshFoldersRequired Property

Borland StarTeam SDK for .NET

View.IsRefreshFoldersRequired Property

[read] true if folder information may be out of date.

public virtual Boolean IsRefreshFoldersRequired {get;}

Property Value

true if folder information may be out of date.

See Also

View Class | StarTeam Namespace


IsRefreshLabelsRequired Property

Borland StarTeam SDK for .NET

View.IsRefreshLabelsRequired Property

[read] true if label information may be out of date.

public virtual Boolean IsRefreshLabelsRequired {get;}

Property Value

true if label information may be out of date.

See Also

View Class | StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

View.IsRefreshRequired Property

[read] true if view properties may be out of date.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if view properties may be out of date.

See Also

View Class | StarTeam Namespace


IsRoot Property

Borland StarTeam SDK for .NET

View.IsRoot Property

[read] true if this view is a Root view.

public virtual Boolean IsRoot {get;}

Property Value

true if this view is a Root view.

See Also

View Class | StarTeam Namespace


IsVCMCodeReviewRequired Property

Borland StarTeam SDK for .NET

View.IsVCMCodeReviewRequired Property

[read/write] whether VCM Code reviews are required

public virtual Boolean IsVCMCodeReviewRequired {get; set;}

Property Value

whether VCM Code reviews are required

See Also

View Class | StarTeam Namespace


IsVCMCommitEnforced Property

Borland StarTeam SDK for .NET

View.IsVCMCommitEnforced Property

[read/write] whether VCM Commits are enforced for this View

public virtual Boolean IsVCMCommitEnforced {get; set;}

Property Value

whether VCM Commits are enforced for this View

See Also

View Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

View.Labels Property

[read] The labels (both active and deleted) that exist in this view.

public virtual Label[] Labels {get;}

Property Value

The labels (both active and deleted) that exist in this view.

See Also

View Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

View.Name Property

[read/write] the name of this view.

public virtual String Name {get; set;}

Property Value

the name of this view.

See Also

View Class | StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

View.ParentContainer Property

[read] This object's parent container.

public virtual ISecurableContainer ParentContainer {get;}

Property Value

This object's parent container.

Implements

ISecurableContainer.ParentContainer

See Also

View Class | StarTeam Namespace


ParentView Property

Borland StarTeam SDK for .NET

View.ParentView Property

[read] the parent of this view, or null if there is no parent.

public virtual View ParentView {get;}

Property Value

the parent of this view, or null if there is no parent.

See Also

View Class | StarTeam Namespace


Path Property

Borland StarTeam SDK for .NET

View.Path Property

[read] the working file path being used for this view.

public virtual String Path {get;}

Property Value

the working file path being used for this view.

See Also

View Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

View.PresentationID Property

[read] the unique integer identifier for this view.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this view.

See Also

View Class | StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

View.Project Property

[read] the project to which this view belongs.

public virtual Project Project {get;}

Property Value

the project to which this view belongs.

See Also

View Class | StarTeam Namespace


PromotionModel Property

Borland StarTeam SDK for .NET

View.PromotionModel Property

[read] the promotion model associated with this view.

public virtual PromotionModel PromotionModel {get;}

Property Value

the promotion model associated with this view.

See Also

View Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

View.Properties Property

[read]

public virtual View.Type.PropertyCollection Properties {get;}

See Also

View Class | StarTeam Namespace


RecycleBin Property

Borland StarTeam SDK for .NET

View.RecycleBin Property

[read] The recycle bin associated with this view.

public virtual RecycleBin RecycleBin {get;}

Property Value

The recycle bin associated with this view.

See Also

View Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

View.Rights Property

[read/write] the access control list for this view or NULL.

public virtual ACE[] Rights {get; set;}

Property Value

the access control list for this view or NULL.

Implements

ISecurable.Rights

See Also

View Class | StarTeam Namespace


RootFolder Property

Borland StarTeam SDK for .NET

View.RootFolder Property

[read] The root folder of this view.

public virtual Folder RootFolder {get;}

Property Value

The root folder of this view.

See Also

View Class | StarTeam Namespace


StartDate Property

Borland StarTeam SDK for .NET

View.StartDate Property

[read/write] start date of this View

public virtual DateTime StartDate {get; set;}

Property Value

start date of this View

See Also

View Class | StarTeam Namespace


StatusMethodOverride Property

Borland StarTeam SDK for .NET

View.StatusMethodOverride Property

[read/write]

public virtual StatusMethod StatusMethodOverride {get; set;}

See Also

View Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

View.Traces Property

[read] TraceCollection

public virtual TraceCollection Traces {get;}

Property Value

TraceCollection

See Also

View Class | StarTeam Namespace


TypeValue Property

Borland StarTeam SDK for .NET

View.TypeValue Property

[read/write] type (Unknown, Main, Sandbox, Release) of this View

public virtual View.ViewType TypeValue {get; set;}

Property Value

type (Unknown, Main, Sandbox, Release) of this View

See Also

View Class | StarTeam Namespace


ViewID Property

Borland StarTeam SDK for .NET

View.ViewID Property

[read] the unique integer identifier for this view.

public virtual Int32 ViewID {get;}

Property Value

the unique integer identifier for this view.

See Also

View Class | StarTeam Namespace


WorkspaceModifiedTime Property

Borland StarTeam SDK for .NET

View.WorkspaceModifiedTime Property

[read] workspace modified time of this View

public virtual DateTime WorkspaceModifiedTime {get;}

Property Value

workspace modified time of this View

See Also

View Class | StarTeam Namespace


View Methods

The methods of the View class are listed below. For a complete list of View class members, see the View Members topic.

Public Instance Methods

AddExcludedGroup | Adds the specified group object as an excluded group from VCM Commits.
AddExcludedUser | Adds the specified user object as an excluded user from VCM Commits.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed. A cloned revision label is supported across projects. This provides a mechanism to attach the correct historical revisions to a cloned label in a view that is the target of cross project or cross view folder tree moves.
CloneViewLabel | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed. View labels may only be cloned from other labels in the same view
Close | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateLightWeightWorkView | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. Supported on servers beginning with release 16.4
CreateLightWeightWorkViewWithPulsePullRequests | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. This work view also supports Pull Requests for code reviews in Pulse Supported on servers beginning with release 17.1
CreateRevisionLabel | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed. Use a DateTime created with the special value 0.0 to create the label as of the current server time.
Discard | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FetchAllLabels | Overloaded. Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FindDerivedView | Return an immediate derived view with the specified name or NULL if none exist
FindFolder | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem | Overloaded.
FindLabel | Overloaded. find and return a label given its name
FindViewMember |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisembodiedItem |
GetDisembodiedViewMember |
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetNewNotificationItems |
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetRights | Returns the Access Control List for items of the specified type for this view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
GetViewMembers |
GetWorkflow |
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasNewNotificationItems |
HasPermissions | Overloaded. Returns true if desired permissions are granted for this view
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares the properties of two Views.
NewFolderEventSource |
NewFolderTreeEventSource |
NewFolderUpdateEventSource |
NewItemEventSource | Overloaded.
NewItemIDEventSource | Overloaded.
NewItemListEventSource | Overloaded.
NewItemUpdateEventSource |
NewLabelEventSource |
NewNotificationEventSource | Overloaded.
NewViewEventSource |
NewViewMemberEventSource | Overloaded.
NewViewMemberUpdateEventSource |
Populate | Populates view properties, if they have not already been populated.
Refresh | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel | Refreshes the local cached information about this view's promotion model.
Remove | Removes the view from the server.
RemoveExcludedGroup | Removes the specified group object as an excluded group from VCM Commits.
RemoveExcludedUser | Removes the specified user object as an excluded user from VCM Commits.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveWorkflow | remove all workflow definitions for this view
ResolveLinkEndpoint |
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights | Modifies the Access Control List for items of the specified type for this view. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
SupportsPullRequests | Return true if this view supports pull requests.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update | Persists this view's properties to its Server.

See Also

View Class | StarTeam Namespace


View.AddExcludedGroup Method

Adds the specified group object as an excluded group from VCM Commits.

public virtual void AddExcludedGroup(
Group group
);

Parameters

group
the group object to add as an excluded group

See Also

View Class | StarTeam Namespace


View.AddExcludedUser Method

Adds the specified user object as an excluded user from VCM Commits.

public virtual void AddExcludedUser(
User user
);

Parameters

user
the user object to add as an excluded user

See Also

View Class | StarTeam Namespace


View.CloneRevisionLabel Method

Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed. A cloned revision label is supported across projects. This provides a mechanism to attach the correct historical revisions to a cloned label in a view that is the target of cross project or cross view folder tree moves.

public virtual Label CloneRevisionLabel(
Label source,
String name,
String description,
Boolean frozen
);

Parameters

source
the label to be cloned (it must be from the active view)
name
the label name (may not be null)
description
the label description (may not be null)
frozen
true if the label is "frozen" (a frozen label can not be moved from one revision to another)

Return Value

clone of this revision label

See Also

View Class | StarTeam Namespace


View.CloneViewLabel Method

Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed. View labels may only be cloned from other labels in the same view

public virtual Label CloneViewLabel(
Label source,
String name,
String description,
Boolean buildLabel,
Boolean frozen
);

Parameters

source
the label to be cloned (it must be from the active view)
name
the label name (may not be null)
description
the label description (may not be null)
buildLabel
true if the label is to be a "Build Label"
frozen
true if the label is "frozen" (a frozen label can not be moved from one revision to another)

Return Value

clone of this view label

See Also

View Class | StarTeam Namespace


View.Close Method

Frees all cached resources associated with this view, and closes the associated view session.

Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close().

After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.

public virtual void Close();

See Also

View Class | StarTeam Namespace | discard | discardFolders | discardLabels | discardItems | disconnect


View.Copy Method

Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().

public virtual View Copy();

Return Value

A new copy of this View object.

See Also

View Class | StarTeam Namespace | isEqualTo


CreateCheckinManager Method

Borland StarTeam SDK for .NET

View.CreateCheckinManager Method

Constructs a CheckinManager with default options for this view.

Overload List

Constructs a CheckinManager with default options for this view.

public virtual CheckinManager CreateCheckinManager();

Constructs a CheckinManager using a specific set of options. Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckinManager CreateCheckinManager(CheckinOptions);

See Also

View Class | StarTeam Namespace


View.CreateCheckinManager Method ()

Constructs a CheckinManager with default options for this view.

public virtual CheckinManager CreateCheckinManager();

Return Value

CheckinManager created

See Also

View Class | StarTeam Namespace | View.CreateCheckinManager Overload List


View.CreateCheckinManager Method (CheckinOptions)

Constructs a CheckinManager using a specific set of options.

Note that individual options can be overridden on a file-by-file basis by registering a CheckinListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckinManager CreateCheckinManager(
CheckinOptions options
);

Parameters

options
The specific CheckinOptions to be used.

Return Value

CheckinManager created

See Also

View Class | StarTeam Namespace | View.CreateCheckinManager Overload List | CheckinOptions | addCheckinListener | onStartFile


CreateCheckoutManager Method

Borland StarTeam SDK for .NET

View.CreateCheckoutManager Method

Constructs a CheckoutManager with default options for this view.

Overload List

Constructs a CheckoutManager with default options for this view.

public virtual CheckoutManager CreateCheckoutManager();

Constructs a CheckoutManager using a specific set of options. Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckoutManager CreateCheckoutManager(CheckoutOptions);

See Also

View Class | StarTeam Namespace


View.CreateCheckoutManager Method ()

Constructs a CheckoutManager with default options for this view.

public virtual CheckoutManager CreateCheckoutManager();

Return Value

CheckoutManager created

See Also

View Class | StarTeam Namespace | View.CreateCheckoutManager Overload List


View.CreateCheckoutManager Method (CheckoutOptions)

Constructs a CheckoutManager using a specific set of options.

Note that individual options can be overridden on a file-by-file basis by registering a CheckoutListener, and changing options as necessary in the onStartFile event handler.

public virtual CheckoutManager CreateCheckoutManager(
CheckoutOptions options
);

Parameters

options
The specific CheckoutOtions to be used.

Return Value

CheckoutManager created

See Also

View Class | StarTeam Namespace | View.CreateCheckoutManager Overload List | CheckoutOptions | addCheckoutListener | onStartFile


View.CreateChildViewShareAllItems Method

Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.

public virtual View CreateChildViewShareAllItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

Parameters

name
the new view's name.
description
the new view's description.
rootFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.
baseConfig
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view.
bIsBranched
true for branch on change. Sets initial branching behavior for all items shared from this view during view creation. Specify true for default branching, false for default floating.

Return Value

the new variant view.

See Also

View Class | StarTeam Namespace | ViewConfiguration


View.CreateChildViewShareDefaultItems Method

Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.

public virtual View CreateChildViewShareDefaultItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

Parameters

name
the new view's name.
description
the new view's description.
rootFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.
baseConfig
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view.
bIsBranched
true for branch on change. Sets initial branching behavior for all items shared from this view during view creation. Specify true for default branching, false for default floating.

Return Value

the new variant view.

See Also

View Class | StarTeam Namespace | ViewConfiguration


View.CreateChildViewShareNoItems Method

Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.

public virtual View CreateChildViewShareNoItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched
);

Parameters

name
the new view's name.
description
the new view's description.
rootFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.
baseConfig
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view.
bIsBranched
true for branch on change. Sets initial branching behavior for all items shared from this view during view creation. Specify true for default branching, false for default floating.

Return Value

the new variant view.

See Also

View Class | StarTeam Namespace | ViewConfiguration


View.CreateChildViewShareTheseItems Method

Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.

public virtual View CreateChildViewShareTheseItems(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig,
Boolean bIsBranched,
TypeCollection types
);

Parameters

name
the new view's name.
description
the new view's description.
rootFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.
baseConfig
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view.
bIsBranched
true for branch on change. Sets initial branching behavior for all items shared from this view during view creation. Specify true for default branching, false for default floating.
types
an array containing the set of Types of the items that will initially be shared from this view during view creation.

Return Value

the new variant view.

See Also

View Class | StarTeam Namespace | ViewConfiguration | Type


View.CreateLightWeightWorkView Method

Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. Supported on servers beginning with release 16.4

public virtual View CreateLightWeightWorkView(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig
);

Parameters

name
the new view's name.
description
the new view's description.
rootFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.
baseConfig
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view. Only time based configurations are supported for light weight work views.

Return Value

the new lightweight work view.

See Also

View Class | StarTeam Namespace | ViewConfiguration | Type


View.CreateLightWeightWorkViewWithPulsePullRequests Method

Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. This work view also supports Pull Requests for code reviews in Pulse Supported on servers beginning with release 17.1

public virtual View CreateLightWeightWorkViewWithPulsePullRequests(
String name,
String description,
Folder rootFolder,
String defaultWorkingFolder,
ViewConfiguration baseConfig
);

Parameters

name
the new view's name.
description
the new view's description.
rootFolder
the root folder for the view. This must be a valid folder from the specified configuration of the parent view.
defaultWorkingFolder
the default working folder path for the view. This can be overridden on each workstation as needed.
baseConfig
the ViewConfiguration for the view. Specify the configuration of this view that is used as a starting point for the new variant view. Only time based configurations are supported for light weight work views.

Return Value

the new lightweight work view with pull request support for pulse.

See Also

View Class | StarTeam Namespace | ViewConfiguration | Type


View.CreateRevisionLabel Method

Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.

public virtual Label CreateRevisionLabel(
String name,
String description,
Boolean frozen
);

Parameters

name
the label name (may not be null)
description
the label description (may not be null)
frozen
true if the label is "frozen" (a frozen label can not be moved from one revision to another)

Return Value

created revision label

See Also

View Class | StarTeam Namespace


View.CreateViewLabel Method

Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed. Use a DateTime created with the special value 0.0 to create the label as of the current server time.

public virtual Label CreateViewLabel(
String name,
String description,
DateTime time,
Boolean buildLabel,
Boolean frozen
);

Parameters

name
the label name (may not be null)
description
the label description (may not be null)
time
the view configuration time (may not be null)
buildLabel
true if the label is to be a "Build Label"
frozen
true if the label is "frozen" (a frozen label can not be moved from one revision to another)

Return Value

created view label

See Also

View Class | StarTeam Namespace


View.Discard Method

Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled).

If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.

public virtual void Discard();

See Also

View Class | StarTeam Namespace | refresh


View.DiscardActiveLabels Method

Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).

public virtual void DiscardActiveLabels();

See Also

View Class | StarTeam Namespace | getActiveLabels | refreshActiveLabels | enableMPX


View.DiscardFolders Method

Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).

public virtual void DiscardFolders();

See Also

View Class | StarTeam Namespace | getRootFolder | refreshFolders


View.DiscardLabels Method

Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).

public virtual void DiscardLabels();

See Also

View Class | StarTeam Namespace | getLabels | refreshLabels


FetchAllLabels Method

Borland StarTeam SDK for .NET

View.FetchAllLabels Method

Returns all the active (non-deleted) labels for this view.

The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects.

If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.

Overload List

Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.

public virtual Label[] FetchAllLabels();

Returns all the active (non-deleted) labels for any given View The labels are not cached. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. fetchAllLabels() is not MPX-enabled; the labels are always retrieved directly from the repository.

public virtual Label[] FetchAllLabels(View);

See Also

View Class | StarTeam Namespace


View.FetchAllLabels Method ()

Returns all the active (non-deleted) labels for this view.

The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects.

If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.

public virtual Label[] FetchAllLabels();

Return Value

The active (non-deleted) labels for this view. May be empty (but is never null).

See Also

View Class | StarTeam Namespace | View.FetchAllLabels Overload List


View.FetchAllLabels Method (View)

Returns all the active (non-deleted) labels for any given View

The labels are not cached. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects.

fetchAllLabels() is not MPX-enabled; the labels are always retrieved directly from the repository.

public virtual Label[] FetchAllLabels(
View view
);

Parameters

view
the view whose labels are to be fetched

Return Value

The active (non-deleted) labels for the given project and view. May be empty (but is never null).

See Also

View Class | StarTeam Namespace | View.FetchAllLabels Overload List


View.FindDerivedView Method

Return an immediate derived view with the specified name or NULL if none exist

public virtual View FindDerivedView(
String name
);

Parameters

name
the name of an immediate derived view

Return Value

an immediate derived view with the specified name

See Also

View Class | StarTeam Namespace


View.FindFolder Method

Returns a Folder in the View, given its Item ID, or NULL if none found.

public virtual Folder FindFolder(
Int32 itemID
);

Parameters

itemID
the Item ID of the Folder to be retrieved.

Return Value

a Folder in the View, given its Item ID, or NULL if none found.

See Also

View Class | StarTeam Namespace


FindItem Method

Borland StarTeam SDK for .NET

View.FindItem Method

Overload List

public virtual Item FindItem(Item.Type,Int32);

public virtual Item FindItem(Item.Type,String);

See Also

View Class | StarTeam Namespace


View.FindItem Method (Item#Type, Int32)

public virtual Item FindItem(
Item.Type type,
Int32 itemID
);

See Also

View Class | StarTeam Namespace | View.FindItem Overload List


View.FindItem Method (Item#Type, String)

public virtual Item FindItem(
Item.Type type,
String path
);

See Also

View Class | StarTeam Namespace | View.FindItem Overload List


FindLabel Method

Borland StarTeam SDK for .NET

View.FindLabel Method

find and return a Label given it's label ID

Overload List

find and return a Label given it's label ID

public virtual Label FindLabel(Int32);

find and return a label given its name

public virtual Label FindLabel(String);

See Also

View Class | StarTeam Namespace


View.FindLabel Method (Int32)

find and return a Label given it's label ID

public virtual Label FindLabel(
Int32 labelID
);

Parameters

labelID
the ID to query for

Return Value

a Label matching the specified ID, or NULL if none found

See Also

View Class | StarTeam Namespace | View.FindLabel Overload List


View.FindLabel Method (String)

find and return a label given its name

public virtual Label FindLabel(
String labelName
);

Parameters

labelName
the name to query for

Return Value

a label matching the specified name or NULL if none found

See Also

View Class | StarTeam Namespace | View.FindLabel Overload List


View.FindViewMember Method

public virtual ViewMember FindViewMember(
ViewMember.Type type,
Int32 VMID
);

See Also

View Class | StarTeam Namespace


View.GetDisembodiedItem Method

public virtual Item GetDisembodiedItem(
Item.Type type,
Int32 itemID
);

See Also

View Class | StarTeam Namespace


View.GetDisembodiedViewMember Method

public virtual ViewMember GetDisembodiedViewMember(
ViewMember.Type type,
Int32 vmID
);

See Also

View Class | StarTeam Namespace


View.GetNewNotificationItems Method

public virtual ViewMemberCollection GetNewNotificationItems(
Item.Type type
);

See Also

View Class | StarTeam Namespace


View.GetRights Method

Returns the Access Control List for items of the specified type for this view.

public virtual ACE[] GetRights(
Type type
);

Parameters

type
the name of the type being controlled by the returned ACL

Return Value

the access control list for this view or NULL.

Implements

ISecurableContainer.GetRights

See Also

View Class | StarTeam Namespace


View.GetViewMembers Method

public virtual ViewMemberCollection GetViewMembers(
ViewMember.Type type
);

See Also

View Class | StarTeam Namespace


View.GetWorkflow Method

public virtual Workflow GetWorkflow(
ViewMember.Type typ
);

See Also

View Class | StarTeam Namespace


View.HasNewNotificationItems Method

public virtual bool HasNewNotificationItems(
Item.Type type
);

See Also

View Class | StarTeam Namespace


HasPermissions Method

Borland StarTeam SDK for .NET

View.HasPermissions Method

Returns true if desired permissions are granted for this view

Overload List

Returns true if desired permissions are granted for this view

public virtual bool HasPermissions(PermissionCollection);

Returns true if desired permissions are granted for items of the specified type for this view

public virtual bool HasPermissions(PermissionCollection,Type);

See Also

View Class | StarTeam Namespace | Permission


View.HasPermissions Method (PermissionCollection)

Returns true if desired permissions are granted for this view

public virtual bool HasPermissions(
PermissionCollection permissions
);

Parameters

permissions
the desired permissions

Implements

ISecurable.HasPermissions

See Also

View Class | StarTeam Namespace | View.HasPermissions Overload List | Permission


View.HasPermissions Method (PermissionCollection, Type)

Returns true if desired permissions are granted for items of the specified type for this view

public virtual bool HasPermissions(
PermissionCollection permissions,
Type type
);

Parameters

permissions
the desired permissions
type
the type for access to be tested on

Implements

ISecurableContainer.HasPermissions

See Also

View Class | StarTeam Namespace | View.HasPermissions Overload List | Permission


View.IsEqualTo Method

Compares the properties of two Views.

public virtual bool IsEqualTo(
View view
);

Parameters

view
The view to be compared to this one.

Return Value

true if no differences were found.

See Also

View Class | StarTeam Namespace | copy


View.NewFolderEventSource Method

public FolderEventSource NewFolderEventSource();

See Also

View Class | StarTeam Namespace


View.NewFolderTreeEventSource Method

public FolderTreeEventSource NewFolderTreeEventSource();

See Also

View Class | StarTeam Namespace


View.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource();

See Also

View Class | StarTeam Namespace


NewItemEventSource Method

Borland StarTeam SDK for .NET

View.NewItemEventSource Method

Overload List

public ItemEventSource NewItemEventSource(Item.Type);

public ItemEventSource NewItemEventSource(Item.Type,PropertyCollection);

See Also

View Class | StarTeam Namespace


View.NewItemEventSource Method (Item#Type)

public ItemEventSource NewItemEventSource(
Item.Type type
);

See Also

View Class | StarTeam Namespace | View.NewItemEventSource Overload List


View.NewItemEventSource Method (Item#Type, PropertyCollection)

public ItemEventSource NewItemEventSource(
Item.Type type,
PropertyCollection properties
);

See Also

View Class | StarTeam Namespace | View.NewItemEventSource Overload List


NewItemIDEventSource Method

Borland StarTeam SDK for .NET

View.NewItemIDEventSource Method

Overload List

public ItemIDEventSource NewItemIDEventSource(Item.Type);

public ItemIDEventSource NewItemIDEventSource(Item.Type,PropertyCollection);

See Also

View Class | StarTeam Namespace


View.NewItemIDEventSource Method (Item#Type)

public ItemIDEventSource NewItemIDEventSource(
Item.Type type
);

See Also

View Class | StarTeam Namespace | View.NewItemIDEventSource Overload List


View.NewItemIDEventSource Method (Item#Type, PropertyCollection)

public ItemIDEventSource NewItemIDEventSource(
Item.Type type,
PropertyCollection properties
);

See Also

View Class | StarTeam Namespace | View.NewItemIDEventSource Overload List


NewItemListEventSource Method

Borland StarTeam SDK for .NET

View.NewItemListEventSource Method

Overload List

public ItemListEventSource NewItemListEventSource(Item.Type);

public ItemListEventSource NewItemListEventSource(Item.Type,PropertyCollection);

See Also

View Class | StarTeam Namespace


View.NewItemListEventSource Method (Item#Type)

public ItemListEventSource NewItemListEventSource(
Item.Type type
);

See Also

View Class | StarTeam Namespace | View.NewItemListEventSource Overload List


View.NewItemListEventSource Method (Item#Type, PropertyCollection)

public ItemListEventSource NewItemListEventSource(
Item.Type type,
PropertyCollection properties
);

See Also

View Class | StarTeam Namespace | View.NewItemListEventSource Overload List


View.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource(
Item.Type type
);

See Also

View Class | StarTeam Namespace


View.NewLabelEventSource Method

public LabelEventSource NewLabelEventSource();

See Also

View Class | StarTeam Namespace


NewNotificationEventSource Method

Borland StarTeam SDK for .NET

View.NewNotificationEventSource Method

Overload List

public NotificationEventSource NewNotificationEventSource(Item.Type);

public NotificationEventSource NewNotificationEventSource(Item.Type,PropertyCollection);

See Also

View Class | StarTeam Namespace


View.NewNotificationEventSource Method (Item#Type)

public NotificationEventSource NewNotificationEventSource(
Item.Type type
);

See Also

View Class | StarTeam Namespace | View.NewNotificationEventSource Overload List


View.NewNotificationEventSource Method (Item#Type, PropertyCollection)

public NotificationEventSource NewNotificationEventSource(
Item.Type type,
PropertyCollection properties
);

See Also

View Class | StarTeam Namespace | View.NewNotificationEventSource Overload List


View.NewViewEventSource Method

public ViewEventSource NewViewEventSource();

See Also

View Class | StarTeam Namespace


NewViewMemberEventSource Method

Borland StarTeam SDK for .NET

View.NewViewMemberEventSource Method

Overload List

public ViewMemberEventSource NewViewMemberEventSource(ViewMember.Type);

public ViewMemberEventSource NewViewMemberEventSource(ViewMember.Type,PropertyCollection);

See Also

View Class | StarTeam Namespace


View.NewViewMemberEventSource Method (ViewMember#Type)

public ViewMemberEventSource NewViewMemberEventSource(
ViewMember.Type type
);

See Also

View Class | StarTeam Namespace | View.NewViewMemberEventSource Overload List


View.NewViewMemberEventSource Method (ViewMember#Type, PropertyCollection)

public ViewMemberEventSource NewViewMemberEventSource(
ViewMember.Type type,
PropertyCollection properties
);

See Also

View Class | StarTeam Namespace | View.NewViewMemberEventSource Overload List


View.NewViewMemberUpdateEventSource Method

public ViewMemberUpdateEventSource NewViewMemberUpdateEventSource(
ViewMember.Type type
);

See Also

View Class | StarTeam Namespace


View.Populate Method

Populates view properties, if they have not already been populated.

public virtual void Populate();

See Also

View Class | StarTeam Namespace | refresh


View.Refresh Method

Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

View Class | StarTeam Namespace | isRefreshRequired | populate | enableMPX


View.RefreshActiveLabels Method

Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.

public virtual void RefreshActiveLabels();

See Also

View Class | StarTeam Namespace | isRefreshActiveLabelsRequired | getActiveLabels | discardActiveLabels | refreshLabels | enableMPX


View.RefreshFolders Method

Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible.

If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands.

In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.

public virtual void RefreshFolders();

See Also

View Class | StarTeam Namespace | isRefreshFoldersRequired | getRootFolder | discardFolders | enableMPX


View.RefreshLabels Method

Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.

public virtual void RefreshLabels();

See Also

View Class | StarTeam Namespace | isRefreshLabelsRequired | getLabels | discardLabels | enableMPX


View.RefreshPromotionModel Method

Refreshes the local cached information about this view's promotion model.

public virtual void RefreshPromotionModel();

See Also

View Class | StarTeam Namespace


View.Remove Method

Removes the view from the server.

public virtual void Remove();

See Also

View Class | StarTeam Namespace


View.RemoveExcludedGroup Method

Removes the specified group object as an excluded group from VCM Commits.

public virtual void RemoveExcludedGroup(
Group group
);

Parameters

group
the group object to remove as an excluded group.

See Also

View Class | StarTeam Namespace


View.RemoveExcludedUser Method

Removes the specified user object as an excluded user from VCM Commits.

public virtual void RemoveExcludedUser(
User user
);

Parameters

user
the user object to remove as an excluded user.

See Also

View Class | StarTeam Namespace


View.RemoveWorkflow Method

remove all workflow definitions for this view

public virtual void RemoveWorkflow();

See Also

View Class | StarTeam Namespace


View.ResolveLinkEndpoint Method

public virtual Item ResolveLinkEndpoint(
Link.Endpoint endpoint
);

See Also

View Class | StarTeam Namespace


View.SetRights Method

Modifies the Access Control List for items of the specified type for this view. If the ACL is null then the access control list for items of the specified type will be dropped.

public virtual void SetRights(
Type type,
ACE[] acl
);

Parameters

type
the type being controlled by the returned ACL
acl
the new access control list or null if to be dropped

Implements

ISecurableContainer.SetRights

See Also

View Class | StarTeam Namespace


View.SupportsPullRequests Method

Return true if this view supports pull requests.

public virtual bool SupportsPullRequests();

Return Value

true if this view supports pull requests.

See Also

View Class | StarTeam Namespace


View.Update Method

Persists this view's properties to its Server.

public virtual void Update();

See Also

View Class | StarTeam Namespace


View.ScmBranch Interface

For a list of all members of this type, see View.ScmBranch Members.

public interface View.ScmBranch

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.ScmBranch Members | StarTeam Namespace


View.ScmBranch Members

View.ScmBranch overview

Public Instance Properties

Changesets
Id
Name
SubRepository

See Also

View.ScmBranch Interface | StarTeam Namespace


View.ScmBranch Properties

The properties of the View.ScmBranch interface are listed below. For a complete list of View.ScmBranch interface members, see the View.ScmBranch Members topic.

Public Instance Properties

Changesets
Id
Name
SubRepository

See Also

View.ScmBranch Interface | StarTeam Namespace


Changesets Property

Borland StarTeam SDK for .NET

View.ScmBranch.Changesets Property

ScmChangeSet[] Changesets {get;}

See Also

View.ScmBranch Interface | StarTeam Namespace


Id Property

Borland StarTeam SDK for .NET

View.ScmBranch.Id Property

String Id {get;}

See Also

View.ScmBranch Interface | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

View.ScmBranch.Name Property

String Name {get;}

See Also

View.ScmBranch Interface | StarTeam Namespace


SubRepository Property

Borland StarTeam SDK for .NET

View.ScmBranch.SubRepository Property

Project.ScmSubRepository SubRepository {get;}

See Also

View.ScmBranch Interface | StarTeam Namespace


View.Type Class

Type for view

For a list of all members of this type, see View.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
View.Type

new public class View.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type Members | StarTeam Namespace


View.Type Members

View.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.View.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.View.Type.

See Also

View.Type Class | StarTeam Namespace


View.Type Properties

The properties of the View.Type class are listed below. For a complete list of View.Type class members, see the View.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

View.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.NAME Property

new public static String NAME {get;}

See Also

View.Type Class | StarTeam Namespace


View.Type Methods

The methods of the View.Type class are listed below. For a complete list of View.Type class members, see the View.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.View.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.View.Type.

See Also

View.Type Class | StarTeam Namespace


View.Type.Equals Method

Delegate Equals() to com.starteam.View.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.Equals(obj).

See Also

View.Type Class | StarTeam Namespace


View.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.

public override int GetHashCode();

Return Value

com.starteam.View.Type.GetHashCode().

See Also

View.Type Class | StarTeam Namespace


View.Type.ToString Method

Delegate ToString() to com.starteam.View.Type.

public override string ToString();

Return Value

com.starteam.View.Type.ToString()

See Also

View.Type Class | StarTeam Namespace


View.Type.BaseConfigurationDataProperty Class

The property type of the BaseConfigurationData property

For a list of all members of this type, see View.Type.BaseConfigurationDataProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
View.Type.BaseConfigurationDataProperty

public class View.Type.BaseConfigurationDataProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.BaseConfigurationDataProperty Members | StarTeam Namespace


View.Type.BaseConfigurationDataProperty Members

View.Type.BaseConfigurationDataProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.BaseConfigurationDataProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.BaseConfigurationDataProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.BaseConfigurationDataProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.BaseConfigurationDataProperty Class | StarTeam Namespace


View.Type.BaseConfigurationDataProperty Properties

The properties of the View.Type.BaseConfigurationDataProperty class are listed below. For a complete list of View.Type.BaseConfigurationDataProperty class members, see the View.Type.BaseConfigurationDataProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

View.Type.BaseConfigurationDataProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.BaseConfigurationDataProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.BaseConfigurationDataProperty Class | StarTeam Namespace


View.Type.BaseConfigurationDataProperty Methods

The methods of the View.Type.BaseConfigurationDataProperty class are listed below. For a complete list of View.Type.BaseConfigurationDataProperty class members, see the View.Type.BaseConfigurationDataProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.BaseConfigurationDataProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.BaseConfigurationDataProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.BaseConfigurationDataProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.BaseConfigurationDataProperty Class | StarTeam Namespace


View.Type.BaseConfigurationDataProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.BaseConfigurationDataProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.BaseConfigurationDataProperty.Equals(obj).

See Also

View.Type.BaseConfigurationDataProperty Class | StarTeam Namespace


View.Type.BaseConfigurationDataProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.BaseConfigurationDataProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.BaseConfigurationDataProperty.GetHashCode().

See Also

View.Type.BaseConfigurationDataProperty Class | StarTeam Namespace


View.Type.BaseConfigurationDataProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.BaseConfigurationDataProperty.

public override string ToString();

Return Value

com.starteam.View.Type.BaseConfigurationDataProperty.ToString()

See Also

View.Type.BaseConfigurationDataProperty Class | StarTeam Namespace


View.Type.BaseConfigurationTypeProperty Class

The property type of the BaseConfigurationType property

For a list of all members of this type, see View.Type.BaseConfigurationTypeProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
View.Type.BaseConfigurationTypeProperty

public class View.Type.BaseConfigurationTypeProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.BaseConfigurationTypeProperty Members | StarTeam Namespace


View.Type.BaseConfigurationTypeProperty Members

View.Type.BaseConfigurationTypeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.BaseConfigurationTypeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.BaseConfigurationTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.BaseConfigurationTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.BaseConfigurationTypeProperty Class | StarTeam Namespace


View.Type.BaseConfigurationTypeProperty Properties

The properties of the View.Type.BaseConfigurationTypeProperty class are listed below. For a complete list of View.Type.BaseConfigurationTypeProperty class members, see the View.Type.BaseConfigurationTypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

View.Type.BaseConfigurationTypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.BaseConfigurationTypeProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.BaseConfigurationTypeProperty Class | StarTeam Namespace


View.Type.BaseConfigurationTypeProperty Methods

The methods of the View.Type.BaseConfigurationTypeProperty class are listed below. For a complete list of View.Type.BaseConfigurationTypeProperty class members, see the View.Type.BaseConfigurationTypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.BaseConfigurationTypeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.BaseConfigurationTypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.BaseConfigurationTypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.BaseConfigurationTypeProperty Class | StarTeam Namespace


View.Type.BaseConfigurationTypeProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.BaseConfigurationTypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.BaseConfigurationTypeProperty.Equals(obj).

See Also

View.Type.BaseConfigurationTypeProperty Class | StarTeam Namespace


View.Type.BaseConfigurationTypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.BaseConfigurationTypeProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.BaseConfigurationTypeProperty.GetHashCode().

See Also

View.Type.BaseConfigurationTypeProperty Class | StarTeam Namespace


View.Type.BaseConfigurationTypeProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.BaseConfigurationTypeProperty.

public override string ToString();

Return Value

com.starteam.View.Type.BaseConfigurationTypeProperty.ToString()

See Also

View.Type.BaseConfigurationTypeProperty Class | StarTeam Namespace


View.Type.CloneTimeProperty Class

The property type of the Clone Time property This property is available starting from the 16.3 release of the starteam server

For a list of all members of this type, see View.Type.CloneTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
View.Type.CloneTimeProperty

public class View.Type.CloneTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.CloneTimeProperty Members | StarTeam Namespace


View.Type.CloneTimeProperty Members

View.Type.CloneTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.CloneTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.CloneTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.CloneTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.CloneTimeProperty Class | StarTeam Namespace


View.Type.CloneTimeProperty Properties

The properties of the View.Type.CloneTimeProperty class are listed below. For a complete list of View.Type.CloneTimeProperty class members, see the View.Type.CloneTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

View.Type.CloneTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.CloneTimeProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.CloneTimeProperty Class | StarTeam Namespace


View.Type.CloneTimeProperty Methods

The methods of the View.Type.CloneTimeProperty class are listed below. For a complete list of View.Type.CloneTimeProperty class members, see the View.Type.CloneTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.CloneTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.CloneTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.CloneTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.CloneTimeProperty Class | StarTeam Namespace


View.Type.CloneTimeProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.CloneTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.CloneTimeProperty.Equals(obj).

See Also

View.Type.CloneTimeProperty Class | StarTeam Namespace


View.Type.CloneTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.CloneTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.CloneTimeProperty.GetHashCode().

See Also

View.Type.CloneTimeProperty Class | StarTeam Namespace


View.Type.CloneTimeProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.CloneTimeProperty.

public override string ToString();

Return Value

com.starteam.View.Type.CloneTimeProperty.ToString()

See Also

View.Type.CloneTimeProperty Class | StarTeam Namespace


View.Type.EndDateProperty Class

The property type of the End Date property. This property is available starting from the 12.5 release of the Starteam server.

For a list of all members of this type, see View.Type.EndDateProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
View.Type.EndDateProperty

public class View.Type.EndDateProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.EndDateProperty Members | StarTeam Namespace


View.Type.EndDateProperty Members

View.Type.EndDateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.EndDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.EndDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.EndDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.EndDateProperty Class | StarTeam Namespace


View.Type.EndDateProperty Properties

The properties of the View.Type.EndDateProperty class are listed below. For a complete list of View.Type.EndDateProperty class members, see the View.Type.EndDateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

View.Type.EndDateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.EndDateProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.EndDateProperty Class | StarTeam Namespace


View.Type.EndDateProperty Methods

The methods of the View.Type.EndDateProperty class are listed below. For a complete list of View.Type.EndDateProperty class members, see the View.Type.EndDateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.EndDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.EndDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.EndDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.EndDateProperty Class | StarTeam Namespace


View.Type.EndDateProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.EndDateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.EndDateProperty.Equals(obj).

See Also

View.Type.EndDateProperty Class | StarTeam Namespace


View.Type.EndDateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.EndDateProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.EndDateProperty.GetHashCode().

See Also

View.Type.EndDateProperty Class | StarTeam Namespace


View.Type.EndDateProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.EndDateProperty.

public override string ToString();

Return Value

com.starteam.View.Type.EndDateProperty.ToString()

See Also

View.Type.EndDateProperty Class | StarTeam Namespace


View.Type.ExcludedGroupsProperty Class

The property type of the Excluded Groups property

For a list of all members of this type, see View.Type.ExcludedGroupsProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
View.Type.ExcludedGroupsProperty

public class View.Type.ExcludedGroupsProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.ExcludedGroupsProperty Members | StarTeam Namespace


View.Type.ExcludedGroupsProperty Members

View.Type.ExcludedGroupsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ExcludedGroupsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ExcludedGroupsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ExcludedGroupsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ExcludedGroupsProperty Class | StarTeam Namespace


View.Type.ExcludedGroupsProperty Properties

The properties of the View.Type.ExcludedGroupsProperty class are listed below. For a complete list of View.Type.ExcludedGroupsProperty class members, see the View.Type.ExcludedGroupsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

View.Type.ExcludedGroupsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.ExcludedGroupsProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.ExcludedGroupsProperty Class | StarTeam Namespace


View.Type.ExcludedGroupsProperty Methods

The methods of the View.Type.ExcludedGroupsProperty class are listed below. For a complete list of View.Type.ExcludedGroupsProperty class members, see the View.Type.ExcludedGroupsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ExcludedGroupsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ExcludedGroupsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ExcludedGroupsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ExcludedGroupsProperty Class | StarTeam Namespace


View.Type.ExcludedGroupsProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.ExcludedGroupsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.ExcludedGroupsProperty.Equals(obj).

See Also

View.Type.ExcludedGroupsProperty Class | StarTeam Namespace


View.Type.ExcludedGroupsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.ExcludedGroupsProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.ExcludedGroupsProperty.GetHashCode().

See Also

View.Type.ExcludedGroupsProperty Class | StarTeam Namespace


View.Type.ExcludedGroupsProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.ExcludedGroupsProperty.

public override string ToString();

Return Value

com.starteam.View.Type.ExcludedGroupsProperty.ToString()

See Also

View.Type.ExcludedGroupsProperty Class | StarTeam Namespace


View.Type.ExcludedUsersProperty Class

The property type of the Excluded Users property

For a list of all members of this type, see View.Type.ExcludedUsersProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
View.Type.ExcludedUsersProperty

public class View.Type.ExcludedUsersProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.ExcludedUsersProperty Members | StarTeam Namespace


View.Type.ExcludedUsersProperty Members

View.Type.ExcludedUsersProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ExcludedUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ExcludedUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ExcludedUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ExcludedUsersProperty Class | StarTeam Namespace


View.Type.ExcludedUsersProperty Properties

The properties of the View.Type.ExcludedUsersProperty class are listed below. For a complete list of View.Type.ExcludedUsersProperty class members, see the View.Type.ExcludedUsersProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

View.Type.ExcludedUsersProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.ExcludedUsersProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.ExcludedUsersProperty Class | StarTeam Namespace


View.Type.ExcludedUsersProperty Methods

The methods of the View.Type.ExcludedUsersProperty class are listed below. For a complete list of View.Type.ExcludedUsersProperty class members, see the View.Type.ExcludedUsersProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ExcludedUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ExcludedUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ExcludedUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ExcludedUsersProperty Class | StarTeam Namespace


View.Type.ExcludedUsersProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.ExcludedUsersProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.ExcludedUsersProperty.Equals(obj).

See Also

View.Type.ExcludedUsersProperty Class | StarTeam Namespace


View.Type.ExcludedUsersProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.ExcludedUsersProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.ExcludedUsersProperty.GetHashCode().

See Also

View.Type.ExcludedUsersProperty Class | StarTeam Namespace


View.Type.ExcludedUsersProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.ExcludedUsersProperty.

public override string ToString();

Return Value

com.starteam.View.Type.ExcludedUsersProperty.ToString()

See Also

View.Type.ExcludedUsersProperty Class | StarTeam Namespace


View.Type.IsDeleteCompleteProperty Class

The property type of the IsDeleteComplete property

For a list of all members of this type, see View.Type.IsDeleteCompleteProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
View.Type.IsDeleteCompleteProperty

public class View.Type.IsDeleteCompleteProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.IsDeleteCompleteProperty Members | StarTeam Namespace


View.Type.IsDeleteCompleteProperty Members

View.Type.IsDeleteCompleteProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.IsDeleteCompleteProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.IsDeleteCompleteProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.IsDeleteCompleteProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.IsDeleteCompleteProperty Class | StarTeam Namespace


View.Type.IsDeleteCompleteProperty Properties

The properties of the View.Type.IsDeleteCompleteProperty class are listed below. For a complete list of View.Type.IsDeleteCompleteProperty class members, see the View.Type.IsDeleteCompleteProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

View.Type.IsDeleteCompleteProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.IsDeleteCompleteProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.IsDeleteCompleteProperty Class | StarTeam Namespace


View.Type.IsDeleteCompleteProperty Methods

The methods of the View.Type.IsDeleteCompleteProperty class are listed below. For a complete list of View.Type.IsDeleteCompleteProperty class members, see the View.Type.IsDeleteCompleteProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.IsDeleteCompleteProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.IsDeleteCompleteProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.IsDeleteCompleteProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.IsDeleteCompleteProperty Class | StarTeam Namespace


View.Type.IsDeleteCompleteProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.IsDeleteCompleteProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.IsDeleteCompleteProperty.Equals(obj).

See Also

View.Type.IsDeleteCompleteProperty Class | StarTeam Namespace


View.Type.IsDeleteCompleteProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.IsDeleteCompleteProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.IsDeleteCompleteProperty.GetHashCode().

See Also

View.Type.IsDeleteCompleteProperty Class | StarTeam Namespace


View.Type.IsDeleteCompleteProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.IsDeleteCompleteProperty.

public override string ToString();

Return Value

com.starteam.View.Type.IsDeleteCompleteProperty.ToString()

See Also

View.Type.IsDeleteCompleteProperty Class | StarTeam Namespace


View.Type.IsPurgedProperty Class

The property type of the IsPurged property

For a list of all members of this type, see View.Type.IsPurgedProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
View.Type.IsPurgedProperty

public class View.Type.IsPurgedProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.IsPurgedProperty Members | StarTeam Namespace


View.Type.IsPurgedProperty Members

View.Type.IsPurgedProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.IsPurgedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.IsPurgedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.IsPurgedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.IsPurgedProperty Class | StarTeam Namespace


View.Type.IsPurgedProperty Properties

The properties of the View.Type.IsPurgedProperty class are listed below. For a complete list of View.Type.IsPurgedProperty class members, see the View.Type.IsPurgedProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

View.Type.IsPurgedProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.IsPurgedProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.IsPurgedProperty Class | StarTeam Namespace


View.Type.IsPurgedProperty Methods

The methods of the View.Type.IsPurgedProperty class are listed below. For a complete list of View.Type.IsPurgedProperty class members, see the View.Type.IsPurgedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.IsPurgedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.IsPurgedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.IsPurgedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.IsPurgedProperty Class | StarTeam Namespace


View.Type.IsPurgedProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.IsPurgedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.IsPurgedProperty.Equals(obj).

See Also

View.Type.IsPurgedProperty Class | StarTeam Namespace


View.Type.IsPurgedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.IsPurgedProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.IsPurgedProperty.GetHashCode().

See Also

View.Type.IsPurgedProperty Class | StarTeam Namespace


View.Type.IsPurgedProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.IsPurgedProperty.

public override string ToString();

Return Value

com.starteam.View.Type.IsPurgedProperty.ToString()

See Also

View.Type.IsPurgedProperty Class | StarTeam Namespace


View.Type.IsVCMCodeReviewRequiredProperty Class

The property type of the Require VCM Code Review property

For a list of all members of this type, see View.Type.IsVCMCodeReviewRequiredProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
View.Type.IsVCMCodeReviewRequiredProperty

public class View.Type.IsVCMCodeReviewRequiredProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.IsVCMCodeReviewRequiredProperty Members | StarTeam Namespace


View.Type.IsVCMCodeReviewRequiredProperty Members

View.Type.IsVCMCodeReviewRequiredProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.IsVCMCodeReviewRequiredProperty Class | StarTeam Namespace


View.Type.IsVCMCodeReviewRequiredProperty Properties

The properties of the View.Type.IsVCMCodeReviewRequiredProperty class are listed below. For a complete list of View.Type.IsVCMCodeReviewRequiredProperty class members, see the View.Type.IsVCMCodeReviewRequiredProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

View.Type.IsVCMCodeReviewRequiredProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.IsVCMCodeReviewRequiredProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.IsVCMCodeReviewRequiredProperty Class | StarTeam Namespace


View.Type.IsVCMCodeReviewRequiredProperty Methods

The methods of the View.Type.IsVCMCodeReviewRequiredProperty class are listed below. For a complete list of View.Type.IsVCMCodeReviewRequiredProperty class members, see the View.Type.IsVCMCodeReviewRequiredProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.IsVCMCodeReviewRequiredProperty Class | StarTeam Namespace


View.Type.IsVCMCodeReviewRequiredProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.Equals(obj).

See Also

View.Type.IsVCMCodeReviewRequiredProperty Class | StarTeam Namespace


View.Type.IsVCMCodeReviewRequiredProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.GetHashCode().

See Also

View.Type.IsVCMCodeReviewRequiredProperty Class | StarTeam Namespace


View.Type.IsVCMCodeReviewRequiredProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.

public override string ToString();

Return Value

com.starteam.View.Type.IsVCMCodeReviewRequiredProperty.ToString()

See Also

View.Type.IsVCMCodeReviewRequiredProperty Class | StarTeam Namespace


View.Type.IsVCMCommitEnforcedProperty Class

The property type of the Enforce VCM Commits property

For a list of all members of this type, see View.Type.IsVCMCommitEnforcedProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
View.Type.IsVCMCommitEnforcedProperty

public class View.Type.IsVCMCommitEnforcedProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.IsVCMCommitEnforcedProperty Members | StarTeam Namespace


View.Type.IsVCMCommitEnforcedProperty Members

View.Type.IsVCMCommitEnforcedProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.IsVCMCommitEnforcedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.IsVCMCommitEnforcedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.IsVCMCommitEnforcedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.IsVCMCommitEnforcedProperty Class | StarTeam Namespace


View.Type.IsVCMCommitEnforcedProperty Properties

The properties of the View.Type.IsVCMCommitEnforcedProperty class are listed below. For a complete list of View.Type.IsVCMCommitEnforcedProperty class members, see the View.Type.IsVCMCommitEnforcedProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

View.Type.IsVCMCommitEnforcedProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.IsVCMCommitEnforcedProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.IsVCMCommitEnforcedProperty Class | StarTeam Namespace


View.Type.IsVCMCommitEnforcedProperty Methods

The methods of the View.Type.IsVCMCommitEnforcedProperty class are listed below. For a complete list of View.Type.IsVCMCommitEnforcedProperty class members, see the View.Type.IsVCMCommitEnforcedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.IsVCMCommitEnforcedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.IsVCMCommitEnforcedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.IsVCMCommitEnforcedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.IsVCMCommitEnforcedProperty Class | StarTeam Namespace


View.Type.IsVCMCommitEnforcedProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.IsVCMCommitEnforcedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.IsVCMCommitEnforcedProperty.Equals(obj).

See Also

View.Type.IsVCMCommitEnforcedProperty Class | StarTeam Namespace


View.Type.IsVCMCommitEnforcedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.IsVCMCommitEnforcedProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.IsVCMCommitEnforcedProperty.GetHashCode().

See Also

View.Type.IsVCMCommitEnforcedProperty Class | StarTeam Namespace


View.Type.IsVCMCommitEnforcedProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.IsVCMCommitEnforcedProperty.

public override string ToString();

Return Value

com.starteam.View.Type.IsVCMCommitEnforcedProperty.ToString()

See Also

View.Type.IsVCMCommitEnforcedProperty Class | StarTeam Namespace


View.Type.ParentViewProperty Class

The property type of the ParentView property

For a list of all members of this type, see View.Type.ParentViewProperty Members.

System.Object
Property
ObjectProperty
View.Type.ParentViewProperty

public class View.Type.ParentViewProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.ParentViewProperty Members | StarTeam Namespace


View.Type.ParentViewProperty Members

View.Type.ParentViewProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ParentViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ParentViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ParentViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ParentViewProperty Class | StarTeam Namespace


View.Type.ParentViewProperty Properties

The properties of the View.Type.ParentViewProperty class are listed below. For a complete list of View.Type.ParentViewProperty class members, see the View.Type.ParentViewProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

View.Type.ParentViewProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.ParentViewProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.ParentViewProperty Class | StarTeam Namespace


View.Type.ParentViewProperty Methods

The methods of the View.Type.ParentViewProperty class are listed below. For a complete list of View.Type.ParentViewProperty class members, see the View.Type.ParentViewProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ParentViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ParentViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ParentViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ParentViewProperty Class | StarTeam Namespace


View.Type.ParentViewProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.ParentViewProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.ParentViewProperty.Equals(obj).

See Also

View.Type.ParentViewProperty Class | StarTeam Namespace


View.Type.ParentViewProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.ParentViewProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.ParentViewProperty.GetHashCode().

See Also

View.Type.ParentViewProperty Class | StarTeam Namespace


View.Type.ParentViewProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.ParentViewProperty.

public override string ToString();

Return Value

com.starteam.View.Type.ParentViewProperty.ToString()

See Also

View.Type.ParentViewProperty Class | StarTeam Namespace


View.Type.PromotionStateProperty Class

The property type of the PromotionState property

For a list of all members of this type, see View.Type.PromotionStateProperty Members.

System.Object
Property
ObjectProperty
View.Type.PromotionStateProperty

public class View.Type.PromotionStateProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.PromotionStateProperty Members | StarTeam Namespace


View.Type.PromotionStateProperty Members

View.Type.PromotionStateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.PromotionStateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.PromotionStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.PromotionStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.PromotionStateProperty Class | StarTeam Namespace


View.Type.PromotionStateProperty Properties

The properties of the View.Type.PromotionStateProperty class are listed below. For a complete list of View.Type.PromotionStateProperty class members, see the View.Type.PromotionStateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

View.Type.PromotionStateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.PromotionStateProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.PromotionStateProperty Class | StarTeam Namespace


View.Type.PromotionStateProperty Methods

The methods of the View.Type.PromotionStateProperty class are listed below. For a complete list of View.Type.PromotionStateProperty class members, see the View.Type.PromotionStateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.PromotionStateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.PromotionStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.PromotionStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.PromotionStateProperty Class | StarTeam Namespace


View.Type.PromotionStateProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.PromotionStateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.PromotionStateProperty.Equals(obj).

See Also

View.Type.PromotionStateProperty Class | StarTeam Namespace


View.Type.PromotionStateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.PromotionStateProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.PromotionStateProperty.GetHashCode().

See Also

View.Type.PromotionStateProperty Class | StarTeam Namespace


View.Type.PromotionStateProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.PromotionStateProperty.

public override string ToString();

Return Value

com.starteam.View.Type.PromotionStateProperty.ToString()

See Also

View.Type.PromotionStateProperty Class | StarTeam Namespace


View.Type.PropertyCollection Class

The property collection of the View type

For a list of all members of this type, see View.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
View.Type.PropertyCollection

public class View.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.PropertyCollection Members | StarTeam Namespace


View.Type.PropertyCollection Members

View.Type.PropertyCollection overview

Public Instance Properties

BASE_CONFIGURATION_DATA |
BASE_CONFIGURATION_TYPE |
CLONE_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
END_DATE |
EXCLUDED_GROUPS |
EXCLUDED_USERS |
FLAGS |
GLOBAL_ID |
ID |
IS_DELETE_COMPLETE |
IS_PURGED |
IS_VCM_CODE_REVIEW_REQUIRED |
IS_VCM_COMMIT_ENFORCED |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
NAME |
PARENT_VIEW |
PROJECT |
PROMOTION_STATE |
RESOLVED_VIEW |
ROOT_FOLDER_ID |
SHARE_FLAGS |
START_DATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TENANT |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
TYPE |
WORKING_FOLDER |
WORKSPACE_MODIFIED_TIME |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.View.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.View.Type.PropertyCollection.

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


View.Type.PropertyCollection Properties

The properties of the View.Type.PropertyCollection class are listed below. For a complete list of View.Type.PropertyCollection class members, see the View.Type.PropertyCollection Members topic.

Public Instance Properties

BASE_CONFIGURATION_DATA |
BASE_CONFIGURATION_TYPE |
CLONE_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
END_DATE |
EXCLUDED_GROUPS |
EXCLUDED_USERS |
FLAGS |
GLOBAL_ID |
ID |
IS_DELETE_COMPLETE |
IS_PURGED |
IS_VCM_CODE_REVIEW_REQUIRED |
IS_VCM_COMMIT_ENFORCED |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
NAME |
PARENT_VIEW |
PROJECT |
PROMOTION_STATE |
RESOLVED_VIEW |
ROOT_FOLDER_ID |
SHARE_FLAGS |
START_DATE |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TENANT |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
TYPE |
WORKING_FOLDER |
WORKSPACE_MODIFIED_TIME |

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


BASE_CONFIGURATION_DATA Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.BASE_CONFIGURATION_DATA Property

public View.Type.BaseConfigurationDataProperty BASE_CONFIGURATION_DATA {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


BASE_CONFIGURATION_TYPE Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.BASE_CONFIGURATION_TYPE Property

public View.Type.BaseConfigurationTypeProperty BASE_CONFIGURATION_TYPE {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


CLONE_TIME Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.CLONE_TIME Property

public View.Type.CloneTimeProperty CLONE_TIME {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


END_DATE Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.END_DATE Property

public View.Type.EndDateProperty END_DATE {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


EXCLUDED_GROUPS Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.EXCLUDED_GROUPS Property

public View.Type.ExcludedGroupsProperty EXCLUDED_GROUPS {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


EXCLUDED_USERS Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.EXCLUDED_USERS Property

public View.Type.ExcludedUsersProperty EXCLUDED_USERS {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


FLAGS Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.FLAGS Property

public LiveObject.Type.FlagsProperty FLAGS {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


IS_DELETE_COMPLETE Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.IS_DELETE_COMPLETE Property

public View.Type.IsDeleteCompleteProperty IS_DELETE_COMPLETE {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


IS_PURGED Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.IS_PURGED Property

public View.Type.IsPurgedProperty IS_PURGED {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


IS_VCM_CODE_REVIEW_REQUIRED Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.IS_VCM_CODE_REVIEW_REQUIRED Property

public View.Type.IsVCMCodeReviewRequiredProperty IS_VCM_CODE_REVIEW_REQUIRED {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


IS_VCM_COMMIT_ENFORCED Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.IS_VCM_COMMIT_ENFORCED Property

public View.Type.IsVCMCommitEnforcedProperty IS_VCM_COMMIT_ENFORCED {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


PARENT_VIEW Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.PARENT_VIEW Property

public View.Type.ParentViewProperty PARENT_VIEW {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


PROJECT Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.PROJECT Property

public TypedResource.Type.ProjectProperty PROJECT {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


PROMOTION_STATE Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.PROMOTION_STATE Property

public View.Type.PromotionStateProperty PROMOTION_STATE {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


RESOLVED_VIEW Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.RESOLVED_VIEW Property

public View.Type.ResolvedViewProperty RESOLVED_VIEW {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


ROOT_FOLDER_ID Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.ROOT_FOLDER_ID Property

public View.Type.RootFolderIDProperty ROOT_FOLDER_ID {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


SHARE_FLAGS Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.SHARE_FLAGS Property

public View.Type.ShareFlagsProperty SHARE_FLAGS {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


START_DATE Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.START_DATE Property

public View.Type.StartDateProperty START_DATE {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


TENANT Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.TENANT Property

public View.Type.TenantProperty TENANT {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


TYPE Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.TYPE Property

public View.Type.TypeProperty TYPE {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


WORKING_FOLDER Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.WORKING_FOLDER Property

public LiveObject.Type.WorkingFolderProperty WORKING_FOLDER {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


WORKSPACE_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

View.Type.PropertyCollection.WORKSPACE_MODIFIED_TIME Property

public View.Type.WorkspaceModifiedTimeProperty WORKSPACE_MODIFIED_TIME {get;}

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


View.Type.PropertyCollection Methods

The methods of the View.Type.PropertyCollection class are listed below. For a complete list of View.Type.PropertyCollection class members, see the View.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.View.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.View.Type.PropertyCollection.

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


View.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.View.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.PropertyCollection.Equals(obj).

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


View.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.View.Type.PropertyCollection.GetHashCode().

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


View.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.View.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.View.Type.PropertyCollection.ToString()

See Also

View.Type.PropertyCollection Class | StarTeam Namespace


View.Type.ResolvedViewProperty Class

The property type of the ResolvedView property

For a list of all members of this type, see View.Type.ResolvedViewProperty Members.

System.Object
Property
ObjectProperty
View.Type.ResolvedViewProperty

public class View.Type.ResolvedViewProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.ResolvedViewProperty Members | StarTeam Namespace


View.Type.ResolvedViewProperty Members

View.Type.ResolvedViewProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ResolvedViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ResolvedViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ResolvedViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ResolvedViewProperty Class | StarTeam Namespace


View.Type.ResolvedViewProperty Properties

The properties of the View.Type.ResolvedViewProperty class are listed below. For a complete list of View.Type.ResolvedViewProperty class members, see the View.Type.ResolvedViewProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

View.Type.ResolvedViewProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.ResolvedViewProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.ResolvedViewProperty Class | StarTeam Namespace


View.Type.ResolvedViewProperty Methods

The methods of the View.Type.ResolvedViewProperty class are listed below. For a complete list of View.Type.ResolvedViewProperty class members, see the View.Type.ResolvedViewProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ResolvedViewProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ResolvedViewProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ResolvedViewProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ResolvedViewProperty Class | StarTeam Namespace


View.Type.ResolvedViewProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.ResolvedViewProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.ResolvedViewProperty.Equals(obj).

See Also

View.Type.ResolvedViewProperty Class | StarTeam Namespace


View.Type.ResolvedViewProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.ResolvedViewProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.ResolvedViewProperty.GetHashCode().

See Also

View.Type.ResolvedViewProperty Class | StarTeam Namespace


View.Type.ResolvedViewProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.ResolvedViewProperty.

public override string ToString();

Return Value

com.starteam.View.Type.ResolvedViewProperty.ToString()

See Also

View.Type.ResolvedViewProperty Class | StarTeam Namespace


View.Type.RootFolderIDProperty Class

The property type of the RootFolderID property

For a list of all members of this type, see View.Type.RootFolderIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
View.Type.RootFolderIDProperty

public class View.Type.RootFolderIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.RootFolderIDProperty Members | StarTeam Namespace


View.Type.RootFolderIDProperty Members

View.Type.RootFolderIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.RootFolderIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.RootFolderIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.RootFolderIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.RootFolderIDProperty Class | StarTeam Namespace


View.Type.RootFolderIDProperty Properties

The properties of the View.Type.RootFolderIDProperty class are listed below. For a complete list of View.Type.RootFolderIDProperty class members, see the View.Type.RootFolderIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

View.Type.RootFolderIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.RootFolderIDProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.RootFolderIDProperty Class | StarTeam Namespace


View.Type.RootFolderIDProperty Methods

The methods of the View.Type.RootFolderIDProperty class are listed below. For a complete list of View.Type.RootFolderIDProperty class members, see the View.Type.RootFolderIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.RootFolderIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.RootFolderIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.RootFolderIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.RootFolderIDProperty Class | StarTeam Namespace


View.Type.RootFolderIDProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.RootFolderIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.RootFolderIDProperty.Equals(obj).

See Also

View.Type.RootFolderIDProperty Class | StarTeam Namespace


View.Type.RootFolderIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.RootFolderIDProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.RootFolderIDProperty.GetHashCode().

See Also

View.Type.RootFolderIDProperty Class | StarTeam Namespace


View.Type.RootFolderIDProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.RootFolderIDProperty.

public override string ToString();

Return Value

com.starteam.View.Type.RootFolderIDProperty.ToString()

See Also

View.Type.RootFolderIDProperty Class | StarTeam Namespace


View.Type.ShareFlagsProperty Class

The property type of the ShareFlags property

For a list of all members of this type, see View.Type.ShareFlagsProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
View.Type.ShareFlagsProperty

public class View.Type.ShareFlagsProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.ShareFlagsProperty Members | StarTeam Namespace


View.Type.ShareFlagsProperty Members

View.Type.ShareFlagsProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ShareFlagsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ShareFlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ShareFlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ShareFlagsProperty Class | StarTeam Namespace


View.Type.ShareFlagsProperty Properties

The properties of the View.Type.ShareFlagsProperty class are listed below. For a complete list of View.Type.ShareFlagsProperty class members, see the View.Type.ShareFlagsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

View.Type.ShareFlagsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.ShareFlagsProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.ShareFlagsProperty Class | StarTeam Namespace


View.Type.ShareFlagsProperty Methods

The methods of the View.Type.ShareFlagsProperty class are listed below. For a complete list of View.Type.ShareFlagsProperty class members, see the View.Type.ShareFlagsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.ShareFlagsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.ShareFlagsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.ShareFlagsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.ShareFlagsProperty Class | StarTeam Namespace


View.Type.ShareFlagsProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.ShareFlagsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.ShareFlagsProperty.Equals(obj).

See Also

View.Type.ShareFlagsProperty Class | StarTeam Namespace


View.Type.ShareFlagsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.ShareFlagsProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.ShareFlagsProperty.GetHashCode().

See Also

View.Type.ShareFlagsProperty Class | StarTeam Namespace


View.Type.ShareFlagsProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.ShareFlagsProperty.

public override string ToString();

Return Value

com.starteam.View.Type.ShareFlagsProperty.ToString()

See Also

View.Type.ShareFlagsProperty Class | StarTeam Namespace


View.Type.StartDateProperty Class

The property type of the Start Date property.. This property is available starting from the 12.5 release of the Starteam server.

For a list of all members of this type, see View.Type.StartDateProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
View.Type.StartDateProperty

public class View.Type.StartDateProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.StartDateProperty Members | StarTeam Namespace


View.Type.StartDateProperty Members

View.Type.StartDateProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.StartDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.StartDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.StartDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.StartDateProperty Class | StarTeam Namespace


View.Type.StartDateProperty Properties

The properties of the View.Type.StartDateProperty class are listed below. For a complete list of View.Type.StartDateProperty class members, see the View.Type.StartDateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

View.Type.StartDateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.StartDateProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.StartDateProperty Class | StarTeam Namespace


View.Type.StartDateProperty Methods

The methods of the View.Type.StartDateProperty class are listed below. For a complete list of View.Type.StartDateProperty class members, see the View.Type.StartDateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.StartDateProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.StartDateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.StartDateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.StartDateProperty Class | StarTeam Namespace


View.Type.StartDateProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.StartDateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.StartDateProperty.Equals(obj).

See Also

View.Type.StartDateProperty Class | StarTeam Namespace


View.Type.StartDateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.StartDateProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.StartDateProperty.GetHashCode().

See Also

View.Type.StartDateProperty Class | StarTeam Namespace


View.Type.StartDateProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.StartDateProperty.

public override string ToString();

Return Value

com.starteam.View.Type.StartDateProperty.ToString()

See Also

View.Type.StartDateProperty Class | StarTeam Namespace


View.Type.TenantProperty Class

For a list of all members of this type, see View.Type.TenantProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
View.Type.TenantProperty

public class View.Type.TenantProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.TenantProperty Members | StarTeam Namespace


View.Type.TenantProperty Members

View.Type.TenantProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.TenantProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.TenantProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.TenantProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.TenantProperty Class | StarTeam Namespace


View.Type.TenantProperty Properties

The properties of the View.Type.TenantProperty class are listed below. For a complete list of View.Type.TenantProperty class members, see the View.Type.TenantProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

View.Type.TenantProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.TenantProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.TenantProperty Class | StarTeam Namespace


View.Type.TenantProperty Methods

The methods of the View.Type.TenantProperty class are listed below. For a complete list of View.Type.TenantProperty class members, see the View.Type.TenantProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.TenantProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.TenantProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.TenantProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.TenantProperty Class | StarTeam Namespace


View.Type.TenantProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.TenantProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.TenantProperty.Equals(obj).

See Also

View.Type.TenantProperty Class | StarTeam Namespace


View.Type.TenantProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.TenantProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.TenantProperty.GetHashCode().

See Also

View.Type.TenantProperty Class | StarTeam Namespace


View.Type.TenantProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.TenantProperty.

public override string ToString();

Return Value

com.starteam.View.Type.TenantProperty.ToString()

See Also

View.Type.TenantProperty Class | StarTeam Namespace


View.Type.TypeProperty Class

The property type of the Type property.

For a list of all members of this type, see View.Type.TypeProperty Members.

System.Object
Property
EnumeratedProperty
View.Type.TypeProperty

public class View.Type.TypeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.TypeProperty Members | StarTeam Namespace


View.Type.TypeProperty Members

View.Type.TypeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.TypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.TypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.TypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.TypeProperty Class | StarTeam Namespace


View.Type.TypeProperty Properties

The properties of the View.Type.TypeProperty class are listed below. For a complete list of View.Type.TypeProperty class members, see the View.Type.TypeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

View.Type.TypeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.TypeProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.TypeProperty Class | StarTeam Namespace


View.Type.TypeProperty Methods

The methods of the View.Type.TypeProperty class are listed below. For a complete list of View.Type.TypeProperty class members, see the View.Type.TypeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.View.Type.TypeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.TypeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.View.Type.TypeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.TypeProperty Class | StarTeam Namespace


View.Type.TypeProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.TypeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.TypeProperty.Equals(obj).

See Also

View.Type.TypeProperty Class | StarTeam Namespace


View.Type.TypeProperty.FromValue Method

public virtual EnumeratedValue FromValue(
View.ViewType value
);

See Also

View.Type.TypeProperty Class | StarTeam Namespace


View.Type.TypeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.TypeProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.TypeProperty.GetHashCode().

See Also

View.Type.TypeProperty Class | StarTeam Namespace


View.Type.TypeProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.TypeProperty.

public override string ToString();

Return Value

com.starteam.View.Type.TypeProperty.ToString()

See Also

View.Type.TypeProperty Class | StarTeam Namespace


View.Type.WorkspaceModifiedTimeProperty Class

The property type of the Workspace Modified Time property This property is available starting from the 16.0 release of the starteam server

For a list of all members of this type, see View.Type.WorkspaceModifiedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
View.Type.WorkspaceModifiedTimeProperty

public class View.Type.WorkspaceModifiedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.Type.WorkspaceModifiedTimeProperty Members | StarTeam Namespace


View.Type.WorkspaceModifiedTimeProperty Members

View.Type.WorkspaceModifiedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.WorkspaceModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.WorkspaceModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.WorkspaceModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.WorkspaceModifiedTimeProperty Class | StarTeam Namespace


View.Type.WorkspaceModifiedTimeProperty Properties

The properties of the View.Type.WorkspaceModifiedTimeProperty class are listed below. For a complete list of View.Type.WorkspaceModifiedTimeProperty class members, see the View.Type.WorkspaceModifiedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

View.Type.WorkspaceModifiedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

View.Type.WorkspaceModifiedTimeProperty.NAME Property

public static String NAME {get;}

See Also

View.Type.WorkspaceModifiedTimeProperty Class | StarTeam Namespace


View.Type.WorkspaceModifiedTimeProperty Methods

The methods of the View.Type.WorkspaceModifiedTimeProperty class are listed below. For a complete list of View.Type.WorkspaceModifiedTimeProperty class members, see the View.Type.WorkspaceModifiedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.View.Type.WorkspaceModifiedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.View.Type.WorkspaceModifiedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.View.Type.WorkspaceModifiedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

View.Type.WorkspaceModifiedTimeProperty Class | StarTeam Namespace


View.Type.WorkspaceModifiedTimeProperty.Equals Method

Delegate Equals() to com.starteam.View.Type.WorkspaceModifiedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.Type.WorkspaceModifiedTimeProperty.Equals(obj).

See Also

View.Type.WorkspaceModifiedTimeProperty Class | StarTeam Namespace


View.Type.WorkspaceModifiedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.Type.WorkspaceModifiedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.View.Type.WorkspaceModifiedTimeProperty.GetHashCode().

See Also

View.Type.WorkspaceModifiedTimeProperty Class | StarTeam Namespace


View.Type.WorkspaceModifiedTimeProperty.ToString Method

Delegate ToString() to com.starteam.View.Type.WorkspaceModifiedTimeProperty.

public override string ToString();

Return Value

com.starteam.View.Type.WorkspaceModifiedTimeProperty.ToString()

See Also

View.Type.WorkspaceModifiedTimeProperty Class | StarTeam Namespace


View.ViewType Class

Defines the Types of a View This property is new to 12.0+ servers

For a list of all members of this type, see View.ViewType Members.

System.Object
EnumeratedValue
View.ViewType

public class View.ViewType : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.ViewType Members | StarTeam Namespace


View.ViewType Members

View.ViewType overview

Public Static Properties

ALL
MAIN
RELEASE
SANDBOX
UNKNOWN

Public Static Methods

FromID | returns a Type from an integer ID
FromValue | Gets the Type value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.View.ViewType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.View.ViewType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.View.ViewType.

See Also

View.ViewType Class | StarTeam Namespace


View.ViewType Properties

The properties of the View.ViewType class are listed below. For a complete list of View.ViewType class members, see the View.ViewType Members topic.

Public Static Properties

ALL
MAIN
RELEASE
SANDBOX
UNKNOWN

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this Type value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

View.ViewType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

View.ViewType.ALL Property

public static ViewType[] ALL {get;}

See Also

View.ViewType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

View.ViewType.ID Property

[read] The ID of this Type value.

public virtual Int32 ID {get;}

Property Value

The ID of this Type value.

See Also

View.ViewType Class | StarTeam Namespace


MAIN Property

Borland StarTeam SDK for .NET

View.ViewType.MAIN Property

public static View.ViewType MAIN {get;}

Property Value

Defines a "Main" View

See Also

View.ViewType Class | StarTeam Namespace


RELEASE Property

Borland StarTeam SDK for .NET

View.ViewType.RELEASE Property

public static View.ViewType RELEASE {get;}

Property Value

Defines a "Release" View

See Also

View.ViewType Class | StarTeam Namespace


SANDBOX Property

Borland StarTeam SDK for .NET

View.ViewType.SANDBOX Property

public static View.ViewType SANDBOX {get;}

Property Value

Defines a "Sandbox" View

See Also

View.ViewType Class | StarTeam Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

View.ViewType.UNKNOWN Property

public static View.ViewType UNKNOWN {get;}

Property Value

Defines an "Unknown" View

See Also

View.ViewType Class | StarTeam Namespace


View.ViewType Methods

The methods of the View.ViewType class are listed below. For a complete list of View.ViewType class members, see the View.ViewType Members topic.

Public Static Methods

FromID | returns a Type from an integer ID
FromValue | Gets the Type value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.View.ViewType.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.View.ViewType.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.View.ViewType.

See Also

View.ViewType Class | StarTeam Namespace


View.ViewType.Equals Method

Delegate Equals() to com.starteam.View.ViewType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.ViewType.Equals(obj).

See Also

View.ViewType Class | StarTeam Namespace


View.ViewType.FromID Method

returns a Type from an integer ID

public static ViewType FromID(
Int32 id
);

Parameters

id
the id of the Type to look for

Return Value

the equivalent Type

See Also

View.ViewType Class | StarTeam Namespace


View.ViewType.FromValue Method

Gets the Type value corresponding to the given EnumeratedValue.

public static ViewType FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a Type.

Return Value

The corresponding Type value, or null.

See Also

View.ViewType Class | StarTeam Namespace


View.ViewType.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.ViewType.

public override int GetHashCode();

Return Value

com.starteam.View.ViewType.GetHashCode().

See Also

View.ViewType Class | StarTeam Namespace


View.ViewType.ToString Method

Delegate ToString() to com.starteam.View.ViewType.

public override string ToString();

Return Value

com.starteam.View.ViewType.ToString()

See Also

View.ViewType Class | StarTeam Namespace


View.WebCacheView Class

View accessor for cached SDK views contained objects are obtained from the artifact cache

For a list of all members of this type, see View.WebCacheView Members.

System.Object
LiveObject.WebCacheLiveObject
View.WebCacheView

public class View.WebCacheView : WebCacheLiveObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

View.WebCacheView Members | StarTeam Namespace


View.WebCacheView Members

View.WebCacheView overview

Public Static Methods

Create

Public Instance Properties

ActiveLabels | [read] The active (non-deleted) labels for this view.
BaseConfiguration | [read] this view's base configuration.
CachedTypes | [read] the set of types cached in the context of a given view
Changesets | [read] Accessible changesets for this branch
CloneTime | [read/write] clone time of this View
Configuration | [read] this view's configuration.
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DefaultPath | [read/write] the default working file path to be used for this view.
DerivedViews | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description | [read/write] the description of this view.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
EndDate | [read/write] end date of this view.
ExcludedGroups | [read] The groups who are excluded from VCM Commits.
ExcludedUsers | [read] The users who are excluded from VCM Commits.
FullName | [read] the full hierarchical name of this view.
HighestChangePackageID | [read] the value of the most recent change package
Id | [read]
ID | [read] the ID of the underlying object
IsBranch | [read] true if this view is a Branch view.
IsBranchAll | [read] true if this view's original branching default was set "All".
IsBranchNone | [read] true if this view's original branching default was set "None".
IsBranchOnShare | [read] true if this view is set to branch shared items.
IsDeleted | [read] True if the view has been deleted from the server; false otherwise.
IsDirty | [read] true if this object is dirty
IsLightWeightWorkView | [read] true if this view is lightweight work view.
IsNew | [read] true if this resource has not yet been stored in the server.
IsNonDerived | [read] true if this view is Non-Derived view.
IsReadOnly | [read] true if this view is ReadOnly, otherwise false.
IsReference | [read] true if this is a reference view, otherwise false.
IsRoot | [read] true if this view is a Root view.
IsVCMCodeReviewRequired | [read/write] whether VCM Code reviews are required
IsVCMCommitEnforced | [read/write] whether VCM Commits are enforced for this View
Labels | [read] The labels (both active and deleted) that exist in this view.
LastUsedAt | [read] the time at which this view was last used or DateTime.VALUE_NOT_SET if this view has not been used
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
ParentView | [read] the parent of this view, or null if there is no parent.
PresentationID | [read] the unique integer identifier for this resource.
Project | [read] the project to which this view belongs.
PromotionModel | [read] the promotion model associated with this view.
RecycleBin | [read] a Recycle Bin for this view
Rights | [read/write] the access rights assigned to this view
RootFolder | [read] The root folder of this view.
Server | [read] the Server for this cached object
StartDate | [read/write] start date of this View
SubRepository | [read] the container ScmSubRepository
ViewType | [read/write] type (Unknown, Main, Sandbox, Release) of this View
WorkspaceModifiedTime | [read] workspace modified time of this View

Public Instance Methods

AddExcludedGroup |
AddExcludedUser |
AddTo |
CreateCheckinManager | Create and return a CheckinManager
CreateCheckoutManager | Constructs a CheckoutManager
Equals | Delegate Equals() to com.starteam.View.WebCacheView.
Execute | Execute a command (currently supports select or describe queries) using the Command Processor The context of the command is the chosen view. The syntax of the command must conform to the grammar supported by the Command Processor engine, but without either -p or -s examples of valid commands are describe Topic select * from ChangeRequest where Status = Open select access-rights from File select agile-breakdown from Sprint where SprintID = 1234
FindLabel | Overloaded. find and return a label given its name
FindViewMember |
GetCount |
GetHashCode | Delegate GetHashCode() to com.starteam.View.WebCacheView.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
GetViewMembers |
GetWorkflow |
HasValue |
HasViewMemberListener |
NewWebCacheViewMemberEventSource |
QueryDifferences | Overloaded.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveExcludedGroup |
RemoveExcludedUser |
RemoveFrom |
SetRights |
SetValue | Overloaded. set the value of the property as specified by name
ShareItems |
SupportsPullRequests | Return true if this view supports Pull Requests.
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.View.WebCacheView.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView Properties

The properties of the View.WebCacheView class are listed below. For a complete list of View.WebCacheView class members, see the View.WebCacheView Members topic.

Public Instance Properties

ActiveLabels | [read] The active (non-deleted) labels for this view.
BaseConfiguration | [read] this view's base configuration.
CachedTypes | [read] the set of types cached in the context of a given view
Changesets | [read] Accessible changesets for this branch
CloneTime | [read/write] clone time of this View
Configuration | [read] this view's configuration.
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DefaultPath | [read/write] the default working file path to be used for this view.
DerivedViews | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description | [read/write] the description of this view.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
EndDate | [read/write] end date of this view.
ExcludedGroups | [read] The groups who are excluded from VCM Commits.
ExcludedUsers | [read] The users who are excluded from VCM Commits.
FullName | [read] the full hierarchical name of this view.
HighestChangePackageID | [read] the value of the most recent change package
Id | [read]
ID | [read] the ID of the underlying object
IsBranch | [read] true if this view is a Branch view.
IsBranchAll | [read] true if this view's original branching default was set "All".
IsBranchNone | [read] true if this view's original branching default was set "None".
IsBranchOnShare | [read] true if this view is set to branch shared items.
IsDeleted | [read] True if the view has been deleted from the server; false otherwise.
IsDirty | [read] true if this object is dirty
IsLightWeightWorkView | [read] true if this view is lightweight work view.
IsNew | [read] true if this resource has not yet been stored in the server.
IsNonDerived | [read] true if this view is Non-Derived view.
IsReadOnly | [read] true if this view is ReadOnly, otherwise false.
IsReference | [read] true if this is a reference view, otherwise false.
IsRoot | [read] true if this view is a Root view.
IsVCMCodeReviewRequired | [read/write] whether VCM Code reviews are required
IsVCMCommitEnforced | [read/write] whether VCM Commits are enforced for this View
Labels | [read] The labels (both active and deleted) that exist in this view.
LastUsedAt | [read] the time at which this view was last used or DateTime.VALUE_NOT_SET if this view has not been used
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
ParentView | [read] the parent of this view, or null if there is no parent.
PresentationID | [read] the unique integer identifier for this resource.
Project | [read] the project to which this view belongs.
PromotionModel | [read] the promotion model associated with this view.
RecycleBin | [read] a Recycle Bin for this view
Rights | [read/write] the access rights assigned to this view
RootFolder | [read] The root folder of this view.
Server | [read] the Server for this cached object
StartDate | [read/write] start date of this View
SubRepository | [read] the container ScmSubRepository
ViewType | [read/write] type (Unknown, Main, Sandbox, Release) of this View
WorkspaceModifiedTime | [read] workspace modified time of this View

See Also

View.WebCacheView Class | StarTeam Namespace


ActiveLabels Property

Borland StarTeam SDK for .NET

View.WebCacheView.ActiveLabels Property

[read] The active (non-deleted) labels for this view.

public virtual WebCacheLabel[] ActiveLabels {get;}

Property Value

The active (non-deleted) labels for this view.

See Also

View.WebCacheView Class | StarTeam Namespace


BaseConfiguration Property

Borland StarTeam SDK for .NET

View.WebCacheView.BaseConfiguration Property

[read] this view's base configuration.

public virtual ViewConfiguration.WebCacheViewConfiguration BaseConfiguration {get;}

Property Value

this view's base configuration.

See Also

View.WebCacheView Class | StarTeam Namespace


CachedTypes Property

Borland StarTeam SDK for .NET

View.WebCacheView.CachedTypes Property

[read] the set of types cached in the context of a given view

public virtual WebCacheViewMemberType[] CachedTypes {get;}

Property Value

the set of types cached in the context of a given view

See Also

View.WebCacheView Class | StarTeam Namespace


Changesets Property

Borland StarTeam SDK for .NET

View.WebCacheView.Changesets Property

[read] Accessible changesets for this branch

public virtual ScmChangeSet[] Changesets {get;}

Property Value

Accessible changesets for this branch

See Also

View.WebCacheView Class | StarTeam Namespace


CloneTime Property

Borland StarTeam SDK for .NET

View.WebCacheView.CloneTime Property

[read/write] clone time of this View

public virtual DateTime CloneTime {get; set;}

Property Value

clone time of this View

See Also

View.WebCacheView Class | StarTeam Namespace


Configuration Property

Borland StarTeam SDK for .NET

View.WebCacheView.Configuration Property

[read] this view's configuration.

public virtual ViewConfiguration.WebCacheViewConfiguration Configuration {get;}

Property Value

this view's configuration.

See Also

View.WebCacheView Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

View.WebCacheView.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

View.WebCacheView Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

View.WebCacheView.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

View.WebCacheView Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

View.WebCacheView.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

View.WebCacheView Class | StarTeam Namespace


DefaultPath Property

Borland StarTeam SDK for .NET

View.WebCacheView.DefaultPath Property

[read/write] the default working file path to be used for this view.

public virtual String DefaultPath {get; set;}

Property Value

the default working file path to be used for this view.

See Also

View.WebCacheView Class | StarTeam Namespace


DerivedViews Property

Borland StarTeam SDK for .NET

View.WebCacheView.DerivedViews Property

[read] The set of views derived from this one. Returns an empty array if there are no derived views.

public virtual WebCacheView[] DerivedViews {get;}

Property Value

The set of views derived from this one. Returns an empty array if there are no derived views.

See Also

View.WebCacheView Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

View.WebCacheView.Description Property

[read/write] the description of this view.

public virtual String Description {get; set;}

Property Value

the description of this view.

See Also

View.WebCacheView Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

View.WebCacheView.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

View.WebCacheView Class | StarTeam Namespace


EndDate Property

Borland StarTeam SDK for .NET

View.WebCacheView.EndDate Property

[read/write] end date of this view.

public virtual DateTime EndDate {get; set;}

Property Value

end date of this view.

See Also

View.WebCacheView Class | StarTeam Namespace


ExcludedGroups Property

Borland StarTeam SDK for .NET

View.WebCacheView.ExcludedGroups Property

[read] The groups who are excluded from VCM Commits.

public virtual WebCacheGroup[] ExcludedGroups {get;}

Property Value

The groups who are excluded from VCM Commits.

See Also

View.WebCacheView Class | StarTeam Namespace


ExcludedUsers Property

Borland StarTeam SDK for .NET

View.WebCacheView.ExcludedUsers Property

[read] The users who are excluded from VCM Commits.

public virtual WebCacheUser[] ExcludedUsers {get;}

Property Value

The users who are excluded from VCM Commits.

See Also

View.WebCacheView Class | StarTeam Namespace


FullName Property

Borland StarTeam SDK for .NET

View.WebCacheView.FullName Property

[read] the full hierarchical name of this view.

public virtual String FullName {get;}

Property Value

the full hierarchical name of this view.

See Also

View.WebCacheView Class | StarTeam Namespace


HighestChangePackageID Property

Borland StarTeam SDK for .NET

View.WebCacheView.HighestChangePackageID Property

[read] the value of the most recent change package

public virtual Int32 HighestChangePackageID {get;}

Property Value

the value of the most recent change package

See Also

View.WebCacheView Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

View.WebCacheView.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

View.WebCacheView Class | StarTeam Namespace


IsBranch Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsBranch Property

[read] true if this view is a Branch view.

public virtual Boolean IsBranch {get;}

Property Value

true if this view is a Branch view.

See Also

View.WebCacheView Class | StarTeam Namespace


IsBranchAll Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsBranchAll Property

[read] true if this view's original branching default was set "All".

public virtual Boolean IsBranchAll {get;}

Property Value

true if this view's original branching default was set "All".

See Also

View.WebCacheView Class | StarTeam Namespace


IsBranchNone Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsBranchNone Property

[read] true if this view's original branching default was set "None".

public virtual Boolean IsBranchNone {get;}

Property Value

true if this view's original branching default was set "None".

See Also

View.WebCacheView Class | StarTeam Namespace


IsBranchOnShare Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsBranchOnShare Property

[read] true if this view is set to branch shared items.

public virtual Boolean IsBranchOnShare {get;}

Property Value

true if this view is set to branch shared items.

See Also

View.WebCacheView Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsDeleted Property

[read] True if the view has been deleted from the server; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if the view has been deleted from the server; false otherwise.

See Also

View.WebCacheView Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

View.WebCacheView Class | StarTeam Namespace


IsLightWeightWorkView Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsLightWeightWorkView Property

[read] true if this view is lightweight work view.

public virtual Boolean IsLightWeightWorkView {get;}

Property Value

true if this view is lightweight work view.

See Also

View.WebCacheView Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

View.WebCacheView Class | StarTeam Namespace


IsNonDerived Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsNonDerived Property

[read] true if this view is Non-Derived view.

public virtual Boolean IsNonDerived {get;}

Property Value

true if this view is Non-Derived view.

See Also

View.WebCacheView Class | StarTeam Namespace


IsReadOnly Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsReadOnly Property

[read] true if this view is ReadOnly, otherwise false.

public virtual Boolean IsReadOnly {get;}

Property Value

true if this view is ReadOnly, otherwise false.

See Also

View.WebCacheView Class | StarTeam Namespace


IsReference Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsReference Property

[read] true if this is a reference view, otherwise false.

public virtual Boolean IsReference {get;}

Property Value

true if this is a reference view, otherwise false.

See Also

View.WebCacheView Class | StarTeam Namespace


IsRoot Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsRoot Property

[read] true if this view is a Root view.

public virtual Boolean IsRoot {get;}

Property Value

true if this view is a Root view.

See Also

View.WebCacheView Class | StarTeam Namespace


IsVCMCodeReviewRequired Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsVCMCodeReviewRequired Property

[read/write] whether VCM Code reviews are required

public virtual Boolean IsVCMCodeReviewRequired {get; set;}

Property Value

whether VCM Code reviews are required

See Also

View.WebCacheView Class | StarTeam Namespace


IsVCMCommitEnforced Property

Borland StarTeam SDK for .NET

View.WebCacheView.IsVCMCommitEnforced Property

[read/write] whether VCM Commits are enforced for this View

public virtual Boolean IsVCMCommitEnforced {get; set;}

Property Value

whether VCM Commits are enforced for this View

See Also

View.WebCacheView Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

View.WebCacheView.Labels Property

[read] The labels (both active and deleted) that exist in this view.

public virtual WebCacheLabel[] Labels {get;}

Property Value

The labels (both active and deleted) that exist in this view.

See Also

View.WebCacheView Class | StarTeam Namespace


LastUsedAt Property

Borland StarTeam SDK for .NET

View.WebCacheView.LastUsedAt Property

[read] the time at which this view was last used or DateTime.VALUE_NOT_SET if this view has not been used

public virtual DateTime LastUsedAt {get;}

Property Value

the time at which this view was last used or DateTime.VALUE_NOT_SET if this view has not been used

See Also

View.WebCacheView Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

View.WebCacheView.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

View.WebCacheView Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

View.WebCacheView.Name Property

new public virtual String Name {get; set;}

See Also

View.WebCacheView Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

View.WebCacheView.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

View.WebCacheView Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

View.WebCacheView.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

View.WebCacheView Class | StarTeam Namespace


ParentView Property

Borland StarTeam SDK for .NET

View.WebCacheView.ParentView Property

[read] the parent of this view, or null if there is no parent.

public virtual View.WebCacheView ParentView {get;}

Property Value

the parent of this view, or null if there is no parent.

See Also

View.WebCacheView Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

View.WebCacheView.PresentationID Property

[read] the unique integer identifier for this resource.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

View.WebCacheView Class | StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

View.WebCacheView.Project Property

[read] the project to which this view belongs.

public virtual Project.WebCacheProject Project {get;}

Property Value

the project to which this view belongs.

See Also

View.WebCacheView Class | StarTeam Namespace


PromotionModel Property

Borland StarTeam SDK for .NET

View.WebCacheView.PromotionModel Property

[read] the promotion model associated with this view.

public virtual PromotionModel.WebCachePromotionModel PromotionModel {get;}

Property Value

the promotion model associated with this view.

See Also

View.WebCacheView Class | StarTeam Namespace


RecycleBin Property

Borland StarTeam SDK for .NET

View.WebCacheView.RecycleBin Property

[read] a Recycle Bin for this view

public virtual View.WebCacheView RecycleBin {get;}

Property Value

a Recycle Bin for this view

See Also

View.WebCacheView Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

View.WebCacheView.Rights Property

[read/write] the access rights assigned to this view

public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this view

See Also

View.WebCacheView Class | StarTeam Namespace


RootFolder Property

Borland StarTeam SDK for .NET

View.WebCacheView.RootFolder Property

[read] The root folder of this view.

public virtual Folder.WebCacheFolder RootFolder {get;}

Property Value

The root folder of this view.

See Also

View.WebCacheView Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

View.WebCacheView.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

View.WebCacheView Class | StarTeam Namespace


StartDate Property

Borland StarTeam SDK for .NET

View.WebCacheView.StartDate Property

[read/write] start date of this View

public virtual DateTime StartDate {get; set;}

Property Value

start date of this View

See Also

View.WebCacheView Class | StarTeam Namespace


SubRepository Property

Borland StarTeam SDK for .NET

View.WebCacheView.SubRepository Property

[read] the container ScmSubRepository

public virtual Project.ScmSubRepository SubRepository {get;}

Property Value

the container ScmSubRepository

See Also

View.WebCacheView Class | StarTeam Namespace


ViewType Property

Borland StarTeam SDK for .NET

View.WebCacheView.ViewType Property

[read/write] type (Unknown, Main, Sandbox, Release) of this View

public virtual View.ViewType ViewType {get; set;}

Property Value

type (Unknown, Main, Sandbox, Release) of this View

See Also

View.WebCacheView Class | StarTeam Namespace


WorkspaceModifiedTime Property

Borland StarTeam SDK for .NET

View.WebCacheView.WorkspaceModifiedTime Property

[read] workspace modified time of this View

public virtual DateTime WorkspaceModifiedTime {get;}

Property Value

workspace modified time of this View

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView Methods

The methods of the View.WebCacheView class are listed below. For a complete list of View.WebCacheView class members, see the View.WebCacheView Members topic.

Public Static Methods

Create

Public Instance Methods

AddExcludedGroup |
AddExcludedUser |
AddTo |
CreateCheckinManager | Create and return a CheckinManager
CreateCheckoutManager | Constructs a CheckoutManager
Equals | Delegate Equals() to com.starteam.View.WebCacheView.
Execute | Execute a command (currently supports select or describe queries) using the Command Processor The context of the command is the chosen view. The syntax of the command must conform to the grammar supported by the Command Processor engine, but without either -p or -s examples of valid commands are describe Topic select * from ChangeRequest where Status = Open select access-rights from File select agile-breakdown from Sprint where SprintID = 1234
FindLabel | Overloaded. find and return a label given its name
FindViewMember |
GetCount |
GetHashCode | Delegate GetHashCode() to com.starteam.View.WebCacheView.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
GetViewMembers |
GetWorkflow |
HasValue |
HasViewMemberListener |
NewWebCacheViewMemberEventSource |
QueryDifferences | Overloaded.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveExcludedGroup |
RemoveExcludedUser |
RemoveFrom |
SetRights |
SetValue | Overloaded. set the value of the property as specified by name
ShareItems |
SupportsPullRequests | Return true if this view supports Pull Requests.
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.View.WebCacheView.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.AddExcludedGroup Method

public virtual void AddExcludedGroup(
Group.WebCacheGroup group
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.AddExcludedUser Method

public virtual void AddExcludedUser(
User.WebCacheUser user
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.Create Method

public static WebCacheView Create(
ArtifactCacheManager.Context cntxt,
View.WebCacheView parent,
String viewName,
String viewDescription,
Folder.WebCacheFolder root,
ViewConfiguration.WebCacheViewConfiguration baseConfig
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.CreateCheckinManager Method

Create and return a CheckinManager

public virtual WebCacheCheckinManager CreateCheckinManager();

Return Value

a new Checkin Manager

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.CreateCheckoutManager Method

Constructs a CheckoutManager

public virtual WebCacheCheckoutManager CreateCheckoutManager();

Return Value

CheckoutManager created

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.Equals Method

Delegate Equals() to com.starteam.View.WebCacheView.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.View.WebCacheView.Equals(obj).

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.Execute Method

Execute a command (currently supports select or describe queries) using the Command Processor The context of the command is the chosen view. The syntax of the command must conform to the grammar supported by the Command Processor engine, but without either -p or -s examples of valid commands are describe Topic select * from ChangeRequest where Status = Open select access-rights from File select agile-breakdown from Sprint where SprintID = 1234

public virtual string[][] Execute(
String query
);

Parameters

query
the query to execute

Return Value

the output set (results) as a string[][]

See Also

View.WebCacheView Class | StarTeam Namespace


FindLabel Method

Borland StarTeam SDK for .NET

View.WebCacheView.FindLabel Method

Returns a label in this view or NULL

Overload List

Returns a label in this view or NULL

public virtual WebCacheLabel FindLabel(Int32);

find and return a label given its name

public virtual WebCacheLabel FindLabel(String);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.FindLabel Method (Int32)

Returns a label in this view or NULL

public virtual WebCacheLabel FindLabel(
Int32 labelID
);

Parameters

labelID
the ID of the label

Return Value

a label in this view or NULL

See Also

View.WebCacheView Class | StarTeam Namespace | View.WebCacheView.FindLabel Overload List


View.WebCacheView.FindLabel Method (String)

find and return a label given its name

public virtual WebCacheLabel FindLabel(
String labelName
);

Parameters

labelName
the name to query for

Return Value

a label matching the specified name or NULL if none found

See Also

View.WebCacheView Class | StarTeam Namespace | View.WebCacheView.FindLabel Overload List


View.WebCacheView.FindViewMember Method

public virtual WebCacheViewMember FindViewMember(
ViewMember.Type.WebCacheViewMemberType typ,
Int32 vmid
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.GetCount Method

public virtual int GetCount(
ViewMember.Type.WebCacheViewMemberType typ
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.GetHashCode Method

Delegate GetHashCode() to com.starteam.View.WebCacheView.

public override int GetHashCode();

Return Value

com.starteam.View.WebCacheView.GetHashCode().

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.GetRights Method

public virtual WebCacheACE[] GetRights(
Type.WebCacheType typ
);

See Also

View.WebCacheView Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

View.WebCacheView.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

View.WebCacheView Class | StarTeam Namespace | View.WebCacheView.GetValue Overload List


View.WebCacheView.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

View.WebCacheView Class | StarTeam Namespace | View.WebCacheView.GetValue Overload List


View.WebCacheView.GetViewMembers Method

public virtual WebCacheViewMember[] GetViewMembers(
ViewMember.Type.WebCacheViewMemberType typ,
Filter.WebCacheFilter fltr
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.GetWorkflow Method

public virtual WebCacheWorkflow GetWorkflow(
ViewMember.Type.WebCacheViewMemberType typ
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.HasViewMemberListener Method

public virtual bool HasViewMemberListener(
ViewMember.Type.WebCacheViewMemberType typ
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.NewWebCacheViewMemberEventSource Method

public WebCacheViewMemberEventSource NewWebCacheViewMemberEventSource(
ViewMember.Type.WebCacheViewMemberType typ
);

See Also

View.WebCacheView Class | StarTeam Namespace


QueryDifferences Method

Borland StarTeam SDK for .NET

View.WebCacheView.QueryDifferences Method

Overload List

public virtual WebCacheViewMember[] QueryDifferences(WebCacheViewMemberType[],Label.WebCacheLabel);

public virtual WebCacheViewMember[] QueryDifferences(WebCacheViewMemberType[],DateTime);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.QueryDifferences Method (ViewMember#Type#WebCacheViewMemberType[], Label#WebCacheLabel)

public virtual WebCacheViewMember[] QueryDifferences(
WebCacheViewMemberType[] typs,
Label.WebCacheLabel past
);

See Also

View.WebCacheView Class | StarTeam Namespace | View.WebCacheView.QueryDifferences Overload List


View.WebCacheView.QueryDifferences Method (ViewMember#Type#WebCacheViewMemberType[], DateTime)

public virtual WebCacheViewMember[] QueryDifferences(
WebCacheViewMemberType[] typs,
DateTime past
);

See Also

View.WebCacheView Class | StarTeam Namespace | View.WebCacheView.QueryDifferences Overload List


View.WebCacheView.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

View.WebCacheView Class | StarTeam Namespace | WebCacheViewMemberCollection


View.WebCacheView.RemoveExcludedGroup Method

public virtual void RemoveExcludedGroup(
Group.WebCacheGroup group
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.RemoveExcludedUser Method

public virtual void RemoveExcludedUser(
User.WebCacheUser user
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.SetRights Method

public virtual void SetRights(
Type.WebCacheType typ,
WebCacheACE[] aces
);

See Also

View.WebCacheView Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

View.WebCacheView.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

View.WebCacheView Class | StarTeam Namespace | View.WebCacheView.SetValue Overload List


View.WebCacheView.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

View.WebCacheView Class | StarTeam Namespace | View.WebCacheView.SetValue Overload List


View.WebCacheView.ShareItems Method

public virtual void ShareItems(
Item.Type.WebCacheItemType typ
);

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.SupportsPullRequests Method

Return true if this view supports Pull Requests.

public virtual bool SupportsPullRequests();

Return Value

true if this view supports Pull Requests.

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.ToString Method

Delegate ToString() to com.starteam.View.WebCacheView.

public override string ToString();

Return Value

com.starteam.View.WebCacheView.ToString()

See Also

View.WebCacheView Class | StarTeam Namespace


View.WebCacheView.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

View.WebCacheView Class | StarTeam Namespace | WebCacheViewMemberCollection


ViewConfiguration Class

A class that represents the possible configuration states for a View. A StarTeam View can be in one of four different configurations: Current: all items in the view are the most recent or "tip" versions, Label: all items reference the version with the specified label attached, Time: all items reference the version that was tip as of some time, Promotion: like a label-based view but with respect to some promotion state.

For a list of all members of this type, see ViewConfiguration Members.

System.Object
ViewConfiguration

public class ViewConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewConfiguration Members | StarTeam Namespace


ViewConfiguration Members

ViewConfiguration overview

Public Static Methods

CreateFrom | Overloaded. Creates a new ViewConfiguration object that represents a view in the specified label-based configuration.
CreateTip | Creates a new ViewConfiguration object that represents the current or "tip" state of a view.

Public Instance Properties

IsLabelBased | [read] true if this configuration is label-based
IsPromotionStateBased | [read] true if this configuration is PromotionState-based
IsTimeBased | [read] true if this configuration is time-based
IsTip | [read] true if this configuration is tip-based
Label | [read] the label ID for this configuration
PromotionState | [read] the PromotionState ID for this configuration
Time | [read] the as-of time for this configuration

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewConfiguration.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this ViewConfiguration instance can be considered equal to the other
SupportsDeletedItems | Return true if this view configuration can support accessing deleted items. Note that this is separate from whether or not the server itself provides support for accessing deleted items. To successfully access deleted items, both the server and the view configuration must support it.
ToString | Delegate ToString() to com.starteam.ViewConfiguration.

See Also

ViewConfiguration Class | StarTeam Namespace


ViewConfiguration Properties

The properties of the ViewConfiguration class are listed below. For a complete list of ViewConfiguration class members, see the ViewConfiguration Members topic.

Public Instance Properties

IsLabelBased | [read] true if this configuration is label-based
IsPromotionStateBased | [read] true if this configuration is PromotionState-based
IsTimeBased | [read] true if this configuration is time-based
IsTip | [read] true if this configuration is tip-based
Label | [read] the label ID for this configuration
PromotionState | [read] the PromotionState ID for this configuration
Time | [read] the as-of time for this configuration

See Also

ViewConfiguration Class | StarTeam Namespace


IsLabelBased Property

Borland StarTeam SDK for .NET

ViewConfiguration.IsLabelBased Property

[read] true if this configuration is label-based

public virtual Boolean IsLabelBased {get;}

Property Value

true if this configuration is label-based

See Also

ViewConfiguration Class | StarTeam Namespace


IsPromotionStateBased Property

Borland StarTeam SDK for .NET

ViewConfiguration.IsPromotionStateBased Property

[read] true if this configuration is PromotionState-based

public virtual Boolean IsPromotionStateBased {get;}

Property Value

true if this configuration is PromotionState-based

See Also

ViewConfiguration Class | StarTeam Namespace


IsTimeBased Property

Borland StarTeam SDK for .NET

ViewConfiguration.IsTimeBased Property

[read] true if this configuration is time-based

public virtual Boolean IsTimeBased {get;}

Property Value

true if this configuration is time-based

See Also

ViewConfiguration Class | StarTeam Namespace


IsTip Property

Borland StarTeam SDK for .NET

ViewConfiguration.IsTip Property

[read] true if this configuration is tip-based

public virtual Boolean IsTip {get;}

Property Value

true if this configuration is tip-based

See Also

ViewConfiguration Class | StarTeam Namespace


Label Property

Borland StarTeam SDK for .NET

ViewConfiguration.Label Property

[read] the label ID for this configuration

public virtual Label Label {get;}

Property Value

the label ID for this configuration

See Also

ViewConfiguration Class | StarTeam Namespace


PromotionState Property

Borland StarTeam SDK for .NET

ViewConfiguration.PromotionState Property

[read] the PromotionState ID for this configuration

public virtual PromotionState PromotionState {get;}

Property Value

the PromotionState ID for this configuration

See Also

ViewConfiguration Class | StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

ViewConfiguration.Time Property

[read] the as-of time for this configuration

public virtual DateTime Time {get;}

Property Value

the as-of time for this configuration

See Also

ViewConfiguration Class | StarTeam Namespace


ViewConfiguration Methods

The methods of the ViewConfiguration class are listed below. For a complete list of ViewConfiguration class members, see the ViewConfiguration Members topic.

Public Static Methods

CreateFrom | Overloaded. Creates a new ViewConfiguration object that represents a view in the specified label-based configuration.
CreateTip | Creates a new ViewConfiguration object that represents the current or "tip" state of a view.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewConfiguration.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo | returns true if this ViewConfiguration instance can be considered equal to the other
SupportsDeletedItems | Return true if this view configuration can support accessing deleted items. Note that this is separate from whether or not the server itself provides support for accessing deleted items. To successfully access deleted items, both the server and the view configuration must support it.
ToString | Delegate ToString() to com.starteam.ViewConfiguration.

See Also

ViewConfiguration Class | StarTeam Namespace


CreateFrom Method

Borland StarTeam SDK for .NET

ViewConfiguration.CreateFrom Method

Creates a new ViewConfiguration object that represents a view in the specified label-based configuration.

Overload List

Creates a new ViewConfiguration object that represents a view in the specified label-based configuration.

public static ViewConfiguration CreateFrom(Label);

Creates a new ViewConfiguration object that represents a view in the specified PromotionState-based configuration.

public static ViewConfiguration CreateFrom(PromotionState);

Creates a new ViewConfiguration object that represents a view as-of a specified point in time.

public static ViewConfiguration CreateFrom(DateTime);

See Also

ViewConfiguration Class | StarTeam Namespace | getID


ViewConfiguration.CreateFrom Method (Label)

Creates a new ViewConfiguration object that represents a view in the specified label-based configuration.

public static ViewConfiguration CreateFrom(
Label lbl
);

Parameters

lbl
The label from which to base the configuration.

Return Value

a new configuration based on the specified label ID

See Also

ViewConfiguration Class | StarTeam Namespace | ViewConfiguration.CreateFrom Overload List | getID


ViewConfiguration.CreateFrom Method (PromotionState)

Creates a new ViewConfiguration object that represents a view in the specified PromotionState-based configuration.

public static ViewConfiguration CreateFrom(
PromotionState state
);

Parameters

state
The PromotionState from which to base the configuration.

Return Value

a new configuration based on the specified PromotionState ID

See Also

ViewConfiguration Class | StarTeam Namespace | ViewConfiguration.CreateFrom Overload List | getObjectID


ViewConfiguration.CreateFrom Method (DateTime)

Creates a new ViewConfiguration object that represents a view as-of a specified point in time.

public static ViewConfiguration CreateFrom(
DateTime oleTime
);

Parameters

oleTime
the view's as-of time

Return Value

a new configuration of the view as-of the specified time

See Also

ViewConfiguration Class | StarTeam Namespace | ViewConfiguration.CreateFrom Overload List


ViewConfiguration.CreateTip Method

Creates a new ViewConfiguration object that represents the current or "tip" state of a view.

public static ViewConfiguration CreateTip();

Return Value

a new configuration for the tip state.

See Also

ViewConfiguration Class | StarTeam Namespace


ViewConfiguration.Equals Method

Delegate Equals() to com.starteam.ViewConfiguration.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewConfiguration.Equals(obj).

See Also

ViewConfiguration Class | StarTeam Namespace


ViewConfiguration.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewConfiguration.

public override int GetHashCode();

Return Value

com.starteam.ViewConfiguration.GetHashCode().

See Also

ViewConfiguration Class | StarTeam Namespace


ViewConfiguration.IsEqualTo Method

returns true if this ViewConfiguration instance can be considered equal to the other

public virtual bool IsEqualTo(
ViewConfiguration theOther
);

Parameters

theOther
viewConfig ViewConfiguration the view configuration to compare

Return Value

boolean true if this ViewConfiguration instance can be considered equal to the other

See Also

ViewConfiguration Class | StarTeam Namespace


ViewConfiguration.SupportsDeletedItems Method

Return true if this view configuration can support accessing deleted items. Note that this is separate from whether or not the server itself provides support for accessing deleted items. To successfully access deleted items, both the server and the view configuration must support it.

public virtual bool SupportsDeletedItems();

Return Value

true if this view configuration can support accessing deleted items.

See Also

ViewConfiguration Class | StarTeam Namespace


ViewConfiguration.ToString Method

Delegate ToString() to com.starteam.ViewConfiguration.

public override string ToString();

Return Value

com.starteam.ViewConfiguration.ToString()

See Also

ViewConfiguration Class | StarTeam Namespace


ViewConfiguration.WebCacheViewConfiguration Class

A class that represents the possible configuration states for a WebCacheView. A StarTeam WebCacheView can be in one of four different configurations: Current: all items in the view are the most recent or "tip" versions, Label: all items reference the version with the specified label attached, Time: all items reference the version that was tip as of some time, Promotion: like a label-based view but with respect to some promotion state.

For a list of all members of this type, see ViewConfiguration.WebCacheViewConfiguration Members.

System.Object
ViewConfiguration.WebCacheViewConfiguration

public class ViewConfiguration.WebCacheViewConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewConfiguration.WebCacheViewConfiguration Members | StarTeam Namespace


ViewConfiguration.WebCacheViewConfiguration Members

ViewConfiguration.WebCacheViewConfiguration overview

Public Static Methods

CreateFrom | Overloaded.
CreateTip |

Public Instance Properties

IsLabelBased | [read] true if this configuration is label-based
IsPromotionStateBased | [read] true if this configuration is PromotionState-based
IsTimeBased | [read] true if this configuration is time-based
IsTip | [read] true if this configuration is tip-based
Label | [read] the label for this configuration
PromotionState | [read] the PromotionState for this configuration
Time | [read] the as-of time for this configuration

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewConfiguration.WebCacheViewConfiguration.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewConfiguration.WebCacheViewConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
SupportsDeletedItems | Return true if this view configuration can support accessing deleted items. Note that this is separate from whether or not the server itself provides support for accessing deleted items. To successfully access deleted items, both the server and the view configuration must support it.
ToString | Delegate ToString() to com.starteam.ViewConfiguration.WebCacheViewConfiguration.

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


ViewConfiguration.WebCacheViewConfiguration Properties

The properties of the ViewConfiguration.WebCacheViewConfiguration class are listed below. For a complete list of ViewConfiguration.WebCacheViewConfiguration class members, see the ViewConfiguration.WebCacheViewConfiguration Members topic.

Public Instance Properties

IsLabelBased | [read] true if this configuration is label-based
IsPromotionStateBased | [read] true if this configuration is PromotionState-based
IsTimeBased | [read] true if this configuration is time-based
IsTip | [read] true if this configuration is tip-based
Label | [read] the label for this configuration
PromotionState | [read] the PromotionState for this configuration
Time | [read] the as-of time for this configuration

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


IsLabelBased Property

Borland StarTeam SDK for .NET

ViewConfiguration.WebCacheViewConfiguration.IsLabelBased Property

[read] true if this configuration is label-based

public virtual Boolean IsLabelBased {get;}

Property Value

true if this configuration is label-based

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


IsPromotionStateBased Property

Borland StarTeam SDK for .NET

ViewConfiguration.WebCacheViewConfiguration.IsPromotionStateBased Property

[read] true if this configuration is PromotionState-based

public virtual Boolean IsPromotionStateBased {get;}

Property Value

true if this configuration is PromotionState-based

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


IsTimeBased Property

Borland StarTeam SDK for .NET

ViewConfiguration.WebCacheViewConfiguration.IsTimeBased Property

[read] true if this configuration is time-based

public virtual Boolean IsTimeBased {get;}

Property Value

true if this configuration is time-based

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


IsTip Property

Borland StarTeam SDK for .NET

ViewConfiguration.WebCacheViewConfiguration.IsTip Property

[read] true if this configuration is tip-based

public virtual Boolean IsTip {get;}

Property Value

true if this configuration is tip-based

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


Label Property

Borland StarTeam SDK for .NET

ViewConfiguration.WebCacheViewConfiguration.Label Property

[read] the label for this configuration

public virtual Label.WebCacheLabel Label {get;}

Property Value

the label for this configuration

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


PromotionState Property

Borland StarTeam SDK for .NET

ViewConfiguration.WebCacheViewConfiguration.PromotionState Property

[read] the PromotionState for this configuration

public virtual PromotionState.WebCachePromotionState PromotionState {get;}

Property Value

the PromotionState for this configuration

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

ViewConfiguration.WebCacheViewConfiguration.Time Property

[read] the as-of time for this configuration

public virtual DateTime Time {get;}

Property Value

the as-of time for this configuration

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


ViewConfiguration.WebCacheViewConfiguration Methods

The methods of the ViewConfiguration.WebCacheViewConfiguration class are listed below. For a complete list of ViewConfiguration.WebCacheViewConfiguration class members, see the ViewConfiguration.WebCacheViewConfiguration Members topic.

Public Static Methods

CreateFrom | Overloaded.
CreateTip |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewConfiguration.WebCacheViewConfiguration.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewConfiguration.WebCacheViewConfiguration.
GetType (inherited from Object) | Gets the Type of the current instance.
SupportsDeletedItems | Return true if this view configuration can support accessing deleted items. Note that this is separate from whether or not the server itself provides support for accessing deleted items. To successfully access deleted items, both the server and the view configuration must support it.
ToString | Delegate ToString() to com.starteam.ViewConfiguration.WebCacheViewConfiguration.

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


CreateFrom Method

Borland StarTeam SDK for .NET

ViewConfiguration.WebCacheViewConfiguration.CreateFrom Method

Overload List

public static WebCacheViewConfiguration CreateFrom(ArtifactCacheManager.Context,Label.WebCacheLabel);

public static WebCacheViewConfiguration CreateFrom(ArtifactCacheManager.Context,PromotionState.WebCachePromotionState);

public static WebCacheViewConfiguration CreateFrom(ArtifactCacheManager.Context,DateTime);

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


ViewConfiguration.WebCacheViewConfiguration.CreateFrom Method (ArtifactCacheManager#Context, Label#WebCacheLabel)

public static WebCacheViewConfiguration CreateFrom(
ArtifactCacheManager.Context cntxt,
Label.WebCacheLabel lbl
);

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace | ViewConfiguration.WebCacheViewConfiguration.CreateFrom Overload List


ViewConfiguration.WebCacheViewConfiguration.CreateFrom Method (ArtifactCacheManager#Context, PromotionState#WebCachePromotionState)

public static WebCacheViewConfiguration CreateFrom(
ArtifactCacheManager.Context cntxt,
PromotionState.WebCachePromotionState state
);

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace | ViewConfiguration.WebCacheViewConfiguration.CreateFrom Overload List


ViewConfiguration.WebCacheViewConfiguration.CreateFrom Method (ArtifactCacheManager#Context, DateTime)

public static WebCacheViewConfiguration CreateFrom(
ArtifactCacheManager.Context cntxt,
DateTime oleTime
);

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace | ViewConfiguration.WebCacheViewConfiguration.CreateFrom Overload List


ViewConfiguration.WebCacheViewConfiguration.CreateTip Method

public static WebCacheViewConfiguration CreateTip(
ArtifactCacheManager.Context cntxt
);

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


ViewConfiguration.WebCacheViewConfiguration.Equals Method

Delegate Equals() to com.starteam.ViewConfiguration.WebCacheViewConfiguration.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewConfiguration.WebCacheViewConfiguration.Equals(obj).

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


ViewConfiguration.WebCacheViewConfiguration.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewConfiguration.WebCacheViewConfiguration.

public override int GetHashCode();

Return Value

com.starteam.ViewConfiguration.WebCacheViewConfiguration.GetHashCode().

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


ViewConfiguration.WebCacheViewConfiguration.SupportsDeletedItems Method

Return true if this view configuration can support accessing deleted items. Note that this is separate from whether or not the server itself provides support for accessing deleted items. To successfully access deleted items, both the server and the view configuration must support it.

public virtual bool SupportsDeletedItems();

Return Value

true if this view configuration can support accessing deleted items.

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


ViewConfiguration.WebCacheViewConfiguration.ToString Method

Delegate ToString() to com.starteam.ViewConfiguration.WebCacheViewConfiguration.

public override string ToString();

Return Value

com.starteam.ViewConfiguration.WebCacheViewConfiguration.ToString()

See Also

ViewConfiguration.WebCacheViewConfiguration Class | StarTeam Namespace


ViewConfigurationDiffer Class

Used to compare two configurations of a given view, triggering FolderUpdateEvents, ItemUpdateEvents and ViewMemberUpdateEvents describing the changes detected between the two.

Events are triggered only for differences detectable by comparing the two view configurations. For example, if an item was added sometime after the time represented by the first configuration, and then removed sometime before the time represented by the second configuration, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, and for some types of view configurations, it is not currently possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.

For a list of all members of this type, see ViewConfigurationDiffer Members.

System.Object
ViewConfigurationDiffer

public class ViewConfigurationDiffer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewConfigurationDiffer Members | StarTeam Namespace


ViewConfigurationDiffer Members

ViewConfigurationDiffer overview

Public Instance Constructors

ViewConfigurationDiffer Constructor Constructs a new ViewCOnfigurationDiffer.

Public Instance Properties

AllPropertiesRequired [write] Marks all properties as required for a given type. All properties will be populated as items of the given type are compared.

Public Instance Methods

AddRequiredProperties |
AddRequiredProperty |
Close | Frees all cached resources associated with this ViewConfigurationDiffer, and closes the associated view.
Compare | Comnpares the two given configurations of this view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected between the two. The folder tree is always compared. In addition, the items are compared for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
Equals | Delegate Equals() to com.starteam.ViewConfigurationDiffer.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewConfigurationDiffer.
GetType (inherited from Object) | Gets the Type of the current instance.
NewFolderUpdateEventSource |
NewItemUpdateEventSource |
NewViewMemberUpdateEventSource |
ToString | Delegate ToString() to com.starteam.ViewConfigurationDiffer.

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer Constructor

Constructs a new ViewCOnfigurationDiffer.

public ViewConfigurationDiffer(
View view
);

Parameters

view
The view whose configurations are to be compared.

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer Properties

The properties of the ViewConfigurationDiffer class are listed below. For a complete list of ViewConfigurationDiffer class members, see the ViewConfigurationDiffer Members topic.

Public Instance Properties

AllPropertiesRequired [write] Marks all properties as required for a given type. All properties will be populated as items of the given type are compared.

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


AllPropertiesRequired Property

Borland StarTeam SDK for .NET

ViewConfigurationDiffer.AllPropertiesRequired Property

[write] Marks all properties as required for a given type. All properties will be populated as items of the given type are compared.

public virtual ViewMember.Type AllPropertiesRequired {set;}

Property Value

Marks all properties as required for a given type. All properties will be populated as items of the given type are compared.

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer Methods

The methods of the ViewConfigurationDiffer class are listed below. For a complete list of ViewConfigurationDiffer class members, see the ViewConfigurationDiffer Members topic.

Public Instance Methods

AddRequiredProperties |
AddRequiredProperty |
Close | Frees all cached resources associated with this ViewConfigurationDiffer, and closes the associated view.
Compare | Comnpares the two given configurations of this view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected between the two. The folder tree is always compared. In addition, the items are compared for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
Equals | Delegate Equals() to com.starteam.ViewConfigurationDiffer.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewConfigurationDiffer.
GetType (inherited from Object) | Gets the Type of the current instance.
NewFolderUpdateEventSource |
NewItemUpdateEventSource |
NewViewMemberUpdateEventSource |
ToString | Delegate ToString() to com.starteam.ViewConfigurationDiffer.

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer.AddRequiredProperties Method

public virtual void AddRequiredProperties(
ViewMember.Type type,
PropertyCollection pc
);

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer.AddRequiredProperty Method

public virtual void AddRequiredProperty(
ViewMember.Type type,
Property property
);

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer.Close Method

Frees all cached resources associated with this ViewConfigurationDiffer, and closes the associated view.

public virtual void Close();

See Also

ViewConfigurationDiffer Class | StarTeam Namespace | close


ViewConfigurationDiffer.Compare Method

Comnpares the two given configurations of this view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected between the two.

The folder tree is always compared. In addition, the items are compared for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.

public virtual void Compare(
ViewConfiguration config1,
ViewConfiguration config2
);

Parameters

config1
The first (earlier) view configuration.
config2
The second (later) view configuration.

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer.Equals Method

Delegate Equals() to com.starteam.ViewConfigurationDiffer.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewConfigurationDiffer.Equals(obj).

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewConfigurationDiffer.

public override int GetHashCode();

Return Value

com.starteam.ViewConfigurationDiffer.GetHashCode().

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource();

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource(
Item.Type type
);

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer.NewViewMemberUpdateEventSource Method

public ViewMemberUpdateEventSource NewViewMemberUpdateEventSource(
ViewMember.Type type
);

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewConfigurationDiffer.ToString Method

Delegate ToString() to com.starteam.ViewConfigurationDiffer.

public override string ToString();

Return Value

com.starteam.ViewConfigurationDiffer.ToString()

See Also

ViewConfigurationDiffer Class | StarTeam Namespace


ViewMember Class

A VersionedObject that lives in a View.

For a list of all members of this type, see ViewMember Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
ChangePackage
Item
Trace

public class ViewMember : VersionedObject, LockableObject, Lockable, ISecurable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember Members | StarTeam Namespace


ViewMember Members

ViewMember overview

Public Instance Properties

AllLabels | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares | [read] All shares of this view member
AttachedLabels | [read] The labels attached to any version of this resource.
Attachments | [read/write] an array of attachments for this ViewMember
Behavior | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedShares | [read] All deleted shares of this view member
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExclusiveLocker | [read] The User who is the exclusive locker of this resource.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked | [read] boolean
IsBranchable | [read] true if this item is a type that is branchable.
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied | [read] true if this is a disembodied item
IsFloating | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsReadOnly | [read] true if this ViewMember is read-only.
IsRootShare | [read] true if this item is the root share; false otherwise.
IsUnread | [read] boolean
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer | [read] This object's parent container.
ParentRevision | [read] The revision number at which this resource was branched.
PresentationID | [read] the unique integer identifier for this resource.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
View | [read] The View containing this ViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
LockExclusive | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
PutLock |
Remove | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

ViewMember Class | StarTeam Namespace


ViewMember Properties

The properties of the ViewMember class are listed below. For a complete list of ViewMember class members, see the ViewMember Members topic.

Public Instance Properties

AllLabels | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares | [read] All shares of this view member
AttachedLabels | [read] The labels attached to any version of this resource.
Attachments | [read/write] an array of attachments for this ViewMember
Behavior | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Comment | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedShares | [read] All deleted shares of this view member
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExclusiveLocker | [read] The User who is the exclusive locker of this resource.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked | [read] boolean
IsBranchable | [read] true if this item is a type that is branchable.
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied | [read] true if this is a disembodied item
IsFloating | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsReadOnly | [read] true if this ViewMember is read-only.
IsRootShare | [read] true if this item is the root share; false otherwise.
IsUnread | [read] boolean
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer | [read] This object's parent container.
ParentRevision | [read] The revision number at which this resource was branched.
PresentationID | [read] the unique integer identifier for this resource.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
View | [read] The View containing this ViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID | [read] The unique identifier for this ViewMember.

See Also

ViewMember Class | StarTeam Namespace


AllLabels Property

Borland StarTeam SDK for .NET

ViewMember.AllLabels Property

[read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.

public virtual Label[] AllLabels {get;}

Property Value

an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.

See Also

ViewMember Class | StarTeam Namespace


AllShares Property

Borland StarTeam SDK for .NET

ViewMember.AllShares Property

[read] All shares of this view member

public virtual Share[] AllShares {get;}

Property Value

All shares of this view member

See Also

ViewMember Class | StarTeam Namespace


AttachedLabels Property

Borland StarTeam SDK for .NET

ViewMember.AttachedLabels Property

[read] The labels attached to any version of this resource.

public virtual Label[] AttachedLabels {get;}

Property Value

The labels attached to any version of this resource.

See Also

ViewMember Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

ViewMember.Attachments Property

[read/write] an array of attachments for this ViewMember

public virtual Content[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

ViewMember Class | StarTeam Namespace


Behavior Property

Borland StarTeam SDK for .NET

ViewMember.Behavior Property

[read/write] ViewMemberBehavior object associated with this ViewMember

public virtual ViewMemberBehavior Behavior {get; set;}

Property Value

ViewMemberBehavior object associated with this ViewMember

See Also

ViewMember Class | StarTeam Namespace


Cache Property

Borland StarTeam SDK for .NET

ViewMember.Cache Property

[read] CacheService

public virtual CacheService Cache {get;}

Property Value

CacheService

See Also

ViewMember Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

ViewMember.Comment Property

[read/write] The comment describing this revision of the item.

public virtual String Comment {get; set;}

Property Value

The comment describing this revision of the item.

See Also

ViewMember Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

ViewMember.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

public virtual User DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

ViewMember Class | StarTeam Namespace


DeletedShares Property

Borland StarTeam SDK for .NET

ViewMember.DeletedShares Property

[read] All deleted shares of this view member

public virtual Share[] DeletedShares {get;}

Property Value

All deleted shares of this view member

See Also

ViewMember Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

ViewMember.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

ViewMember Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

ViewMember.DotNotation Property

[read] The dot notation identification of this resource version.

public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

ViewMember Class | StarTeam Namespace


ExclusiveLocker Property

Borland StarTeam SDK for .NET

ViewMember.ExclusiveLocker Property

[read] The User who is the exclusive locker of this resource.

public virtual User ExclusiveLocker {get;}

Property Value

The User who is the exclusive locker of this resource.

See Also

ViewMember Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

ViewMember.ExternalID Property

[read/write] The external ID describing this revision of the item.

public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

ViewMember Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

ViewMember.ExternalURL Property

[read/write] The external URL describing this revision of the item.

public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

ViewMember Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

ViewMember.History Property

[read] the past versions of this ViewMember.

public virtual ViewMemberCollection History {get;}

Property Value

the past versions of this ViewMember.

See Also

ViewMember Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

ViewMember.IsBookmarked Property

[read] boolean

public virtual Boolean IsBookmarked {get;}

Property Value

boolean

See Also

ViewMember Class | StarTeam Namespace


IsBranchable Property

Borland StarTeam SDK for .NET

ViewMember.IsBranchable Property

[read] true if this item is a type that is branchable.

public virtual Boolean IsBranchable {get;}

Property Value

true if this item is a type that is branchable.

See Also

ViewMember Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

ViewMember.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

Implements

ISecurable.IsDeleted

See Also

ViewMember Class | StarTeam Namespace


IsDiscarded Property

Borland StarTeam SDK for .NET

ViewMember.IsDiscarded Property

[read] boolean true if all of the cached properties for this Item have been discarded

public virtual Boolean IsDiscarded {get;}

Property Value

boolean true if all of the cached properties for this Item have been discarded

See Also

ViewMember Class | StarTeam Namespace


IsDisembodied Property

Borland StarTeam SDK for .NET

ViewMember.IsDisembodied Property

[read] true if this is a disembodied item

public virtual Boolean IsDisembodied {get;}

Property Value

true if this is a disembodied item

See Also

ViewMember Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

ViewMember.IsFloating Property

[read] true if this artifact is floating

public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

ViewMember Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

ViewMember.IsPinned Property

[read] true if this artifact is pinned

public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

ViewMember Class | StarTeam Namespace


IsReadOnly Property

Borland StarTeam SDK for .NET

ViewMember.IsReadOnly Property

[read] true if this ViewMember is read-only.

public virtual Boolean IsReadOnly {get;}

Property Value

true if this ViewMember is read-only.

See Also

ViewMember Class | StarTeam Namespace


IsRootShare Property

Borland StarTeam SDK for .NET

ViewMember.IsRootShare Property

[read] true if this item is the root share; false otherwise.

public virtual Boolean IsRootShare {get;}

Property Value

true if this item is the root share; false otherwise.

See Also

ViewMember Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

ViewMember.IsUnread Property

[read] boolean

public virtual Boolean IsUnread {get;}

Property Value

boolean

See Also

ViewMember Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

ViewMember.Locker Property

[read] The User object of the exclusive locker of this item.

public virtual User Locker {get;}

Property Value

The User object of the exclusive locker of this item.

Implements

LockableObject.Locker

See Also

ViewMember Class | StarTeam Namespace


MyLockTypeValue Property

Borland StarTeam SDK for .NET

ViewMember.MyLockTypeValue Property

[read] the lock status of the ViewMember for the currently logged in user.

public virtual ViewMember.LockType MyLockTypeValue {get;}

Property Value

the lock status of the ViewMember for the currently logged in user.

Implements

LockableObject.MyLockTypeValue

See Also

ViewMember Class | StarTeam Namespace


ParentContainer Property

Borland StarTeam SDK for .NET

ViewMember.ParentContainer Property

[read] This object's parent container.

public virtual ISecurableContainer ParentContainer {get;}

Property Value

This object's parent container.

Implements

ISecurable.ParentContainer

See Also

ViewMember Class | StarTeam Namespace


ParentRevision Property

Borland StarTeam SDK for .NET

ViewMember.ParentRevision Property

[read] The revision number at which this resource was branched.

public virtual Int32 ParentRevision {get;}

Property Value

The revision number at which this resource was branched.

See Also

ViewMember Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

ViewMember.PresentationID Property

[read] the unique integer identifier for this resource.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

ViewMember Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

ViewMember.Rights Property

[read/write] the access control list for this item or NULL.

public virtual ACE[] Rights {get; set;}

Property Value

the access control list for this item or NULL.

Implements

ISecurable.Rights

See Also

ViewMember Class | StarTeam Namespace


Share Property

Borland StarTeam SDK for .NET

ViewMember.Share Property

[read] The share for this view member.

public virtual Share Share {get;}

Property Value

The share for this view member.

See Also

ViewMember Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

ViewMember.View Property

[read] The View containing this ViewMember.

public virtual View View {get;}

Property Value

The View containing this ViewMember.

See Also

ViewMember Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

ViewMember.ViewMemberRevisions Property

[read] all the revisions for the view member

public virtual ViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

ViewMember Class | StarTeam Namespace


VMID Property

Borland StarTeam SDK for .NET

ViewMember.VMID Property

[read] The unique identifier for this ViewMember.

public virtual Int32 VMID {get;}

Property Value

The unique identifier for this ViewMember.

See Also

ViewMember Class | StarTeam Namespace


ViewMember Methods

The methods of the ViewMember class are listed below. For a complete list of ViewMember class members, see the ViewMember Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo | Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
LockExclusive | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
PutLock |
Remove | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

ViewMember Class | StarTeam Namespace


ViewMember.Copy Method

Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().

public virtual ViewMember Copy();

Return Value

A copy of the ViewMember and all of its properties.

See Also

ViewMember Class | StarTeam Namespace | isEqualTo


ViewMember.FindLinks Method

Gets the links that have this view member as an endpoint.

public virtual Link[] FindLinks();

Return Value

Link[]

See Also

ViewMember Class | StarTeam Namespace


ViewMember.GetDisplayValue Method

Gets the value of a property in a form suitable for display.

public virtual string GetDisplayValue(
Property prop
);

Parameters

prop
A property of this item.

Return Value

The value of the property in a form suitable for display.

See Also

ViewMember Class | StarTeam Namespace


GetFromHistory Method

Borland StarTeam SDK for .NET

ViewMember.GetFromHistory Method

Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.

Overload List

Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.

public virtual ViewMember GetFromHistory(Label);

Gets the version of this resource based on the PromotionState specified. typically, the time at which a label was applied to the promotion state Returns null if no version can be found at that promotion state.

public virtual ViewMember GetFromHistory(PromotionState);

Returns the most recent version of this resource as of the specified date. Returns null if a version is not found that existed as of the given date. Note that this query is not view specific. So it is possible to retrieve a newer revision than the specified one, depending upon the value of the DateTime parameter

public virtual ViewMember GetFromHistory(DateTime);

Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monotonically increases for each new version of the item, even across branches.

public virtual ViewMember GetFromHistory(Int32);

See Also

ViewMember Class | StarTeam Namespace | Label | getHistory


ViewMember.GetFromHistory Method (Label)

Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.

public virtual ViewMember GetFromHistory(
Label label
);

Parameters

label
The desired label.

Return Value

The version of this resource to which the given label is attached, or null.

See Also

ViewMember Class | StarTeam Namespace | ViewMember.GetFromHistory Overload List | Label | getHistory


ViewMember.GetFromHistory Method (PromotionState)

Gets the version of this resource based on the PromotionState specified. typically, the time at which a label was applied to the promotion state Returns null if no version can be found at that promotion state.

public virtual ViewMember GetFromHistory(
PromotionState ps
);

Parameters

ps
The desired promotion state.

Return Value

The version of this resource based on the PromotionState, or null.

See Also

ViewMember Class | StarTeam Namespace | ViewMember.GetFromHistory Overload List | Label | PromotionState | getHistory


ViewMember.GetFromHistory Method (DateTime)

Returns the most recent version of this resource as of the specified date. Returns null if a version is not found that existed as of the given date. Note that this query is not view specific. So it is possible to retrieve a newer revision than the specified one, depending upon the value of the DateTime parameter

public virtual ViewMember GetFromHistory(
DateTime date
);

Parameters

date
The date specifying which historical version to return.

Return Value

The most recent version as of the specified date, or null if the date is prior to the first version of this resource.

See Also

ViewMember Class | StarTeam Namespace | ViewMember.GetFromHistory Overload List


ViewMember.GetFromHistory Method (Int32)

Returns the specified version of this item based on the view version number. Returns null if a version is not found matching the specified version number. The view version number starts with 1 for the first version of the item and monotonically increases for each new version of the item, even across branches.

public virtual ViewMember GetFromHistory(
Int32 viewVersion
);

Parameters

viewVersion
The desired version of the item.

Return Value

The specified version of the item or null if not found.

See Also

ViewMember Class | StarTeam Namespace | ViewMember.GetFromHistory Overload List | getViewVersion | getHistory


ViewMember.GetShare Method

Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.

public virtual Share GetShare(
ViewConfiguration config
);

Parameters

config
the ItemConfig that describes the desired configuration, only "Current" and "Time" configurations are supported.

Return Value

the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted.

See Also

ViewMember Class | StarTeam Namespace | isDisembodied | getAllShares | ViewConfiguration


ViewMember.GetTraces Method

Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.

public virtual TraceCollection GetTraces(
Boolean includeLinks
);

Parameters

includeLinks
if true, links that have this view member as the end point are also included and surface them as if they were traces.

Return Value

collection of traces that reference the given view member

See Also

ViewMember Class | StarTeam Namespace | Link


ViewMember.HasPermissions Method

Returns true if desired permissions are granted

public virtual bool HasPermissions(
PermissionCollection permissions
);

Parameters

permissions
the desired permissions

Implements

ISecurable.HasPermissions

See Also

ViewMember Class | StarTeam Namespace | isDisembodied | Permission


ViewMember.IsEqualTo Method

Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.

public virtual bool IsEqualTo(
ViewMember viewMember
);

Parameters

viewMember
The ViewMember to be compared to this one.

Return Value

true if no differences were found.

See Also

ViewMember Class | StarTeam Namespace | copy


LockExclusive Method

Borland StarTeam SDK for .NET

ViewMember.LockExclusive Method

Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.

Overload List

Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.

public virtual void LockExclusive();

Obtains an exclusive lock on this resource. If breakLock is true, and another user has this resource locked, then an attempt will be made to break that lock. A server exception will be thrown if the lock cannot be obtained.

public virtual void LockExclusive(Boolean);

See Also

ViewMember Class | StarTeam Namespace


ViewMember.LockExclusive Method ()

Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.

public virtual void LockExclusive();

Implements

Lockable.LockExclusive

See Also

ViewMember Class | StarTeam Namespace | ViewMember.LockExclusive Overload List


ViewMember.LockExclusive Method (Boolean)

Obtains an exclusive lock on this resource. If breakLock is true, and another user has this resource locked, then an attempt will be made to break that lock. A server exception will be thrown if the lock cannot be obtained.

public virtual void LockExclusive(
Boolean breakLock
);

Parameters

breakLock
true to break an existing exclusive lock owned by another user

Implements

Lockable.LockExclusive

See Also

ViewMember Class | StarTeam Namespace | ViewMember.LockExclusive Overload List


ViewMember.LockNonExclusive Method

Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.

public virtual void LockNonExclusive();

Implements

Lockable.LockNonExclusive

See Also

ViewMember Class | StarTeam Namespace


ViewMember.ModifyBookmark Method

Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.

public virtual void ModifyBookmark(
Boolean setFlagged
);

Parameters

setFlagged
this item's new flag value

See Also

ViewMember Class | StarTeam Namespace | NAME


ViewMember.ModifyReadStatus Method

Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.

public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

ViewMember Class | StarTeam Namespace | NAME


ViewMember.PutLock Method

public virtual void PutLock(
ViewMember.LockType lockType,
Boolean breakLock
);

See Also

ViewMember Class | StarTeam Namespace


Remove Method

Borland StarTeam SDK for .NET

ViewMember.Remove Method

Removes this ViewMember from the view. This does not affect other shares of the view member.

Overload List

Removes this ViewMember from the view. This does not affect other shares of the view member.

public virtual void Remove();

Remove this ViewMember from the repository This is an atomic operation, not executed in a transaction but running in the context of a ConnectionPool

public virtual void Remove(ConnectionPool,User);

See Also

ViewMember Class | StarTeam Namespace


ViewMember.Remove Method ()

Removes this ViewMember from the view. This does not affect other shares of the view member.

public virtual void Remove();

See Also

ViewMember Class | StarTeam Namespace | ViewMember.Remove Overload List


ViewMember.Remove Method (ConnectionPool, User)

Remove this ViewMember from the repository This is an atomic operation, not executed in a transaction but running in the context of a ConnectionPool

public virtual void Remove(
ConnectionPool cp,
User u
);

Parameters

cp
u

See Also

ViewMember Class | StarTeam Namespace | ViewMember.Remove Overload List | ViewMember


ViewMember.SetBranchOnChange Method

Sets the "Branch On Change" behavior.

public virtual void SetBranchOnChange(
Boolean bBranchOnChange
);

Parameters

bBranchOnChange
true to pin the behavior

See Also

ViewMember Class | StarTeam Namespace | isDisembodied


ViewMember.SetFixedConfiguration Method

Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.

public virtual void SetFixedConfiguration(
ViewConfiguration config
);

Parameters

config
The fixed configuration to be set.

See Also

ViewMember Class | StarTeam Namespace | setFloatingConfiguration | setBehavior | isDisembodied


ViewMember.SetFloatingConfiguration Method

Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.

public virtual void SetFloatingConfiguration();

See Also

ViewMember Class | StarTeam Namespace | setFixedConfiguration | setBehavior | isDisembodied


ViewMember.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

ViewMember Class | StarTeam Namespace


ViewMember.Unlock Method

Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.

public virtual void Unlock();

Implements

Lockable.Unlock

See Also

ViewMember Class | StarTeam Namespace


Update Method

Borland StarTeam SDK for .NET

ViewMember.Update Method

Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.

Overload List

Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.

public virtual void Update();

Save this ViewMember to the Repository If the underlying SDK object is new, create it; otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction, but running in the context of a ConnectionPool

public virtual void Update(ConnectionPool,User);

See Also

ViewMember Class | StarTeam Namespace


ViewMember.Update Method ()

Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.

public virtual void Update();

See Also

ViewMember Class | StarTeam Namespace | ViewMember.Update Overload List


ViewMember.Update Method (ConnectionPool, User)

Save this ViewMember to the Repository If the underlying SDK object is new, create it; otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction, but running in the context of a ConnectionPool

public virtual void Update(
ConnectionPool cp,
User u
);

Parameters

cp
the connection pool
u
the user in whose context the update occurs

See Also

ViewMember Class | StarTeam Namespace | ViewMember.Update Overload List | ViewMember


ViewMember.UpdateRevisionComment Method

This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment (may not be null)

See Also

ViewMember Class | StarTeam Namespace | getObjectID | getRevisionNumber


ViewMember.LockType Class

A representation of the available lock types.

For a list of all members of this type, see ViewMember.LockType Members.

System.Object
ViewMember.LockType

public class ViewMember.LockType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.LockType Members | StarTeam Namespace


ViewMember.LockType Members

ViewMember.LockType overview

Public Static Properties

ALL
EXCLUSIVE
NON_EXCLUSIVE
UNCHANGED
UNLOCKED

Public Static Methods

FromID Gets the LockType that corresponds to the given lock type ID.

Public Instance Properties

ID | [read] the integer value that represents this LockType.
Name | [read] the name

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMember.LockType.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.LockType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ViewMember.LockType.

See Also

ViewMember.LockType Class | StarTeam Namespace


ViewMember.LockType Properties

The properties of the ViewMember.LockType class are listed below. For a complete list of ViewMember.LockType class members, see the ViewMember.LockType Members topic.

Public Static Properties

ALL
EXCLUSIVE
NON_EXCLUSIVE
UNCHANGED
UNLOCKED

Public Instance Properties

ID | [read] the integer value that represents this LockType.
Name | [read] the name

See Also

ViewMember.LockType Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ViewMember.LockType.ALL Property

public static LockType[] ALL {get;}

See Also

ViewMember.LockType Class | StarTeam Namespace


EXCLUSIVE Property

Borland StarTeam SDK for .NET

ViewMember.LockType.EXCLUSIVE Property

public static ViewMember.LockType EXCLUSIVE {get;}

Property Value

LockType EXCLUSIVE.

See Also

ViewMember.LockType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ViewMember.LockType.ID Property

[read] the integer value that represents this LockType.

public virtual Int32 ID {get;}

Property Value

the integer value that represents this LockType.

See Also

ViewMember.LockType Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ViewMember.LockType.Name Property

[read] the name

public virtual String Name {get;}

Property Value

the name

See Also

ViewMember.LockType Class | StarTeam Namespace


NON_EXCLUSIVE Property

Borland StarTeam SDK for .NET

ViewMember.LockType.NON_EXCLUSIVE Property

public static ViewMember.LockType NON_EXCLUSIVE {get;}

Property Value

LockType NON_EXCLUSIVE.

See Also

ViewMember.LockType Class | StarTeam Namespace


UNCHANGED Property

Borland StarTeam SDK for .NET

ViewMember.LockType.UNCHANGED Property

public static ViewMember.LockType UNCHANGED {get;}

Property Value

LockType UNCHANGED.

See Also

ViewMember.LockType Class | StarTeam Namespace


UNLOCKED Property

Borland StarTeam SDK for .NET

ViewMember.LockType.UNLOCKED Property

public static ViewMember.LockType UNLOCKED {get;}

Property Value

LockType UNLOCKED.

See Also

ViewMember.LockType Class | StarTeam Namespace


ViewMember.LockType Methods

The methods of the ViewMember.LockType class are listed below. For a complete list of ViewMember.LockType class members, see the ViewMember.LockType Members topic.

Public Static Methods

FromID Gets the LockType that corresponds to the given lock type ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMember.LockType.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.LockType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ViewMember.LockType.

See Also

ViewMember.LockType Class | StarTeam Namespace


ViewMember.LockType.Equals Method

Delegate Equals() to com.starteam.ViewMember.LockType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.LockType.Equals(obj).

See Also

ViewMember.LockType Class | StarTeam Namespace


ViewMember.LockType.FromID Method

Gets the LockType that corresponds to the given lock type ID.

public static LockType FromID(
Int32 id
);

Parameters

id
The unique ID of some lock type.

Return Value

The Lock type.

See Also

ViewMember.LockType Class | StarTeam Namespace | getID


ViewMember.LockType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.LockType.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.LockType.GetHashCode().

See Also

ViewMember.LockType Class | StarTeam Namespace


ViewMember.LockType.ToString Method

Delegate ToString() to com.starteam.ViewMember.LockType.

public override string ToString();

Return Value

com.starteam.ViewMember.LockType.ToString()

See Also

ViewMember.LockType Class | StarTeam Namespace


ViewMember.MyLock Class

The set of enumerations for a Locked View Member

For a list of all members of this type, see ViewMember.MyLock Members.

System.Object
EnumeratedValue
ViewMember.MyLock

public class ViewMember.MyLock : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.MyLock Members | StarTeam Namespace


ViewMember.MyLock Members

ViewMember.MyLock overview

Public Static Properties

ALL
EXCLUSIVELY_LOCKED_BY_ME
NON_EXCLUSIVELY_LOCKED_BY_ME
NOT_LOCKED_BY_ME

Public Static Methods

FromID | Gets the MyLock value that corresponds to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this MyLock value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ViewMember.MyLock.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.MyLock.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ViewMember.MyLock.

See Also

ViewMember.MyLock Class | StarTeam Namespace


ViewMember.MyLock Properties

The properties of the ViewMember.MyLock class are listed below. For a complete list of ViewMember.MyLock class members, see the ViewMember.MyLock Members topic.

Public Static Properties

ALL
EXCLUSIVELY_LOCKED_BY_ME
NON_EXCLUSIVELY_LOCKED_BY_ME
NOT_LOCKED_BY_ME

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this MyLock value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ViewMember.MyLock Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ViewMember.MyLock.ALL Property

public static MyLock[] ALL {get;}

See Also

ViewMember.MyLock Class | StarTeam Namespace


EXCLUSIVELY_LOCKED_BY_ME Property

Borland StarTeam SDK for .NET

ViewMember.MyLock.EXCLUSIVELY_LOCKED_BY_ME Property

public static ViewMember.MyLock EXCLUSIVELY_LOCKED_BY_ME {get;}

See Also

ViewMember.MyLock Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ViewMember.MyLock.ID Property

[read] The ID of this MyLock value.

public virtual Int32 ID {get;}

Property Value

The ID of this MyLock value.

See Also

ViewMember.MyLock Class | StarTeam Namespace


NON_EXCLUSIVELY_LOCKED_BY_ME Property

Borland StarTeam SDK for .NET

ViewMember.MyLock.NON_EXCLUSIVELY_LOCKED_BY_ME Property

public static ViewMember.MyLock NON_EXCLUSIVELY_LOCKED_BY_ME {get;}

See Also

ViewMember.MyLock Class | StarTeam Namespace


NOT_LOCKED_BY_ME Property

Borland StarTeam SDK for .NET

ViewMember.MyLock.NOT_LOCKED_BY_ME Property

public static ViewMember.MyLock NOT_LOCKED_BY_ME {get;}

See Also

ViewMember.MyLock Class | StarTeam Namespace


ViewMember.MyLock Methods

The methods of the ViewMember.MyLock class are listed below. For a complete list of ViewMember.MyLock class members, see the ViewMember.MyLock Members topic.

Public Static Methods

FromID | Gets the MyLock value that corresponds to the given ID.
FromValue | Gets the Status value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ViewMember.MyLock.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.MyLock.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ViewMember.MyLock.

See Also

ViewMember.MyLock Class | StarTeam Namespace


ViewMember.MyLock.Equals Method

Delegate Equals() to com.starteam.ViewMember.MyLock.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.MyLock.Equals(obj).

See Also

ViewMember.MyLock Class | StarTeam Namespace


ViewMember.MyLock.FromID Method

Gets the MyLock value that corresponds to the given ID.

public static MyLock FromID(
Int32 id
);

Parameters

id
The unique ID of a myLock type.

Return Value

The MyLock value.

See Also

ViewMember.MyLock Class | StarTeam Namespace | getID


ViewMember.MyLock.FromValue Method

Gets the Status value corresponding to the given EnumeratedValue.

public static MyLock FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a StatusProperty.

Return Value

The corresponding Status value, or null.

See Also

ViewMember.MyLock Class | StarTeam Namespace


ViewMember.MyLock.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.MyLock.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.MyLock.GetHashCode().

See Also

ViewMember.MyLock Class | StarTeam Namespace


ViewMember.MyLock.ToString Method

Delegate ToString() to com.starteam.ViewMember.MyLock.

public override string ToString();

Return Value

com.starteam.ViewMember.MyLock.ToString()

See Also

ViewMember.MyLock Class | StarTeam Namespace


ViewMember.ShareState Class

The enumeration of all Share States

For a list of all members of this type, see ViewMember.ShareState Members.

System.Object
EnumeratedValue
ViewMember.ShareState

public class ViewMember.ShareState : EnumeratedValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.ShareState Members | StarTeam Namespace


ViewMember.ShareState Members

ViewMember.ShareState overview

Public Static Properties

ALL
DERIVED_SHARE
NOT_SHARED
ROOT_SHARE

Public Static Methods

FromID | Gets the Compression value corresponding to the given ID.
FromValue | Gets the Compression value corresponding to the given EnumeratedValue.

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this ShareState value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ViewMember.ShareState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.ShareState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ViewMember.ShareState.

See Also

ViewMember.ShareState Class | StarTeam Namespace


ViewMember.ShareState Properties

The properties of the ViewMember.ShareState class are listed below. For a complete list of ViewMember.ShareState class members, see the ViewMember.ShareState Members topic.

Public Static Properties

ALL
DERIVED_SHARE
NOT_SHARED
ROOT_SHARE

Public Instance Properties

After (inherited from EnumeratedValue) | [write] Place (position) this Enumerated Value immediately after the specified predecessor An illegal state exception will be thrown if this Enumerated Value and the specified predecessor belong to different hierarchies If the context of the owning EnumeratedProperty is known to this and its predecessor, then the sort order of the entire forest of values is realigned in accordance with this assignment. If not, then the sort order of this object alone is reassigned
ChildValues (inherited from EnumeratedValue) | [read/write] EnumeratedValue[] of children
Code (inherited from EnumeratedValue) | [read] the enum code for this object.
DebugString (inherited from EnumeratedValue) | [read] a string used mainly for debugging
DepthInHierarchy (inherited from EnumeratedValue) | [read] int the depth of this enumerated value in the presentation hierarchy
DisplayName (inherited from EnumeratedValue) | [read/write] a locale appropriate display name
DisplayNameTranslations (inherited from EnumeratedValue) | [read/write] the display name translations for this enumerated value
ID | [read] The ID of this ShareState value.
InternalName (inherited from EnumeratedValue) | [read/write] the internal name for this object.
IsClosedState (inherited from EnumeratedValue) | [read/write] true if this Enumerated Value represents a Closed State for its Property
IsDisabled (inherited from EnumeratedValue) | [read] true if this enumerated value is disabled.
IsEnabled (inherited from EnumeratedValue) | [read/write] true if this enumerated value is enabled.
IsLeafValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no child values.
IsRootValue (inherited from EnumeratedValue) | [read] boolean true if this enumerated value has no parent value.
IsSelectable (inherited from EnumeratedValue) | [read/write] boolean true if this enumerated value is selectable in a display
Name (inherited from EnumeratedValue) |
NameProperty (inherited from EnumeratedValue) |
ParentValue (inherited from EnumeratedValue) | [read] EnumeratedValue the parent value of this enumerated value or null
SortOrder (inherited from EnumeratedValue) | [read/write] The sort order of this enumerated value.

See Also

ViewMember.ShareState Class | StarTeam Namespace


ALL Property

Borland StarTeam SDK for .NET

ViewMember.ShareState.ALL Property

public static ShareState[] ALL {get;}

See Also

ViewMember.ShareState Class | StarTeam Namespace


DERIVED_SHARE Property

Borland StarTeam SDK for .NET

ViewMember.ShareState.DERIVED_SHARE Property

public static ViewMember.ShareState DERIVED_SHARE {get;}

See Also

ViewMember.ShareState Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ViewMember.ShareState.ID Property

[read] The ID of this ShareState value.

public virtual Int32 ID {get;}

Property Value

The ID of this ShareState value.

See Also

ViewMember.ShareState Class | StarTeam Namespace


NOT_SHARED Property

Borland StarTeam SDK for .NET

ViewMember.ShareState.NOT_SHARED Property

public static ViewMember.ShareState NOT_SHARED {get;}

See Also

ViewMember.ShareState Class | StarTeam Namespace


ROOT_SHARE Property

Borland StarTeam SDK for .NET

ViewMember.ShareState.ROOT_SHARE Property

public static ViewMember.ShareState ROOT_SHARE {get;}

See Also

ViewMember.ShareState Class | StarTeam Namespace


ViewMember.ShareState Methods

The methods of the ViewMember.ShareState class are listed below. For a complete list of ViewMember.ShareState class members, see the ViewMember.ShareState Members topic.

Public Static Methods

FromID | Gets the Compression value corresponding to the given ID.
FromValue | Gets the Compression value corresponding to the given EnumeratedValue.

Public Instance Methods

AddChild (inherited from EnumeratedValue) | Assign a new child to the hierarchy of this Enumerated Value. The provided child may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment If the context of the owning property is known to this parent and its child then the owning property itself is updated to reflect this re-assignment to avoid subsequent calls to setValues()
AssignParent (inherited from EnumeratedValue) | Assign this Enumerated Value to a different parent This enumerated value may either be a root or a child of a different hierarchy The hierarchy tree is changed in accordance with this assignment This method is equivalent to {@link #addChild(EnumeratedValue)} However, if NULL is passed in as the parent parameter, then this EnumeratedValue is promoted to become a root.
Copy (inherited from EnumeratedValue) | Returns a deep copy of this object.
Disable (inherited from EnumeratedValue) | Disable this enumerated value
Enable (inherited from EnumeratedValue) | Enable this enumerated value
Equals | Delegate Equals() to com.starteam.ViewMember.ShareState.
FindChild (inherited from EnumeratedValue) | return a child with the given internal name
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.ShareState.
GetType (inherited from Object) | Gets the Type of the current instance.
HasChildValues (inherited from EnumeratedValue) | Returns true if this enumerated value has any child values (that is, if it is not a leaf value).
IsEqualTo (inherited from EnumeratedValue) | Compares this EnumeratedValue instance with another one. Returns true if their properties match, false otherwise
ToString | Delegate ToString() to com.starteam.ViewMember.ShareState.

See Also

ViewMember.ShareState Class | StarTeam Namespace


ViewMember.ShareState.Equals Method

Delegate Equals() to com.starteam.ViewMember.ShareState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.ShareState.Equals(obj).

See Also

ViewMember.ShareState Class | StarTeam Namespace


ViewMember.ShareState.FromID Method

Gets the Compression value corresponding to the given ID.

public static ShareState FromID(
Int32 id
);

Parameters

id
The ID of a Compression value.

Return Value

The corresponding Compression value, or null.

See Also

ViewMember.ShareState Class | StarTeam Namespace


ViewMember.ShareState.FromValue Method

Gets the Compression value corresponding to the given EnumeratedValue.

public static ShareState FromValue(
EnumeratedValue value
);

Parameters

value
One of the EnumeratedValues of a CompressionProperty.

Return Value

The corresponding Compression value, or null.

See Also

ViewMember.ShareState Class | StarTeam Namespace


ViewMember.ShareState.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.ShareState.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.ShareState.GetHashCode().

See Also

ViewMember.ShareState Class | StarTeam Namespace


ViewMember.ShareState.ToString Method

Delegate ToString() to com.starteam.ViewMember.ShareState.

public override string ToString();

Return Value

com.starteam.ViewMember.ShareState.ToString()

See Also

ViewMember.ShareState Class | StarTeam Namespace


ViewMember.Type Class

The type of the View

For a list of all members of this type, see ViewMember.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
ChangePackage.Type
Item.Type
Trace.Type

new public class ViewMember.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type Members | StarTeam Namespace


ViewMember.Type Members

ViewMember.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ViewMember.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.ViewMember.Type.

See Also

ViewMember.Type Class | StarTeam Namespace


ViewMember.Type Properties

The properties of the ViewMember.Type class are listed below. For a complete list of ViewMember.Type class members, see the ViewMember.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

ViewMember.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.NAME Property

new public static String NAME {get;}

See Also

ViewMember.Type Class | StarTeam Namespace


ViewMember.Type Methods

The methods of the ViewMember.Type class are listed below. For a complete list of ViewMember.Type class members, see the ViewMember.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ViewMember.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.ViewMember.Type.

See Also

ViewMember.Type Class | StarTeam Namespace


ViewMember.Type.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.Equals(obj).

See Also

ViewMember.Type Class | StarTeam Namespace


ViewMember.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.GetHashCode().

See Also

ViewMember.Type Class | StarTeam Namespace


ViewMember.Type.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ToString()

See Also

ViewMember.Type Class | StarTeam Namespace


ViewMember.Type.AttachmentCountProperty Class

The property type of the AttachmentCount property

For a list of all members of this type, see ViewMember.Type.AttachmentCountProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ViewMember.Type.AttachmentCountProperty

public class ViewMember.Type.AttachmentCountProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.AttachmentCountProperty Members | StarTeam Namespace


ViewMember.Type.AttachmentCountProperty Members

ViewMember.Type.AttachmentCountProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.AttachmentCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.AttachmentCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.AttachmentCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.AttachmentCountProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentCountProperty Properties

The properties of the ViewMember.Type.AttachmentCountProperty class are listed below. For a complete list of ViewMember.Type.AttachmentCountProperty class members, see the ViewMember.Type.AttachmentCountProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.AttachmentCountProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.AttachmentCountProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.AttachmentCountProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentCountProperty Methods

The methods of the ViewMember.Type.AttachmentCountProperty class are listed below. For a complete list of ViewMember.Type.AttachmentCountProperty class members, see the ViewMember.Type.AttachmentCountProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.AttachmentCountProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.AttachmentCountProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.AttachmentCountProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.AttachmentCountProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentCountProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.AttachmentCountProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.AttachmentCountProperty.Equals(obj).

See Also

ViewMember.Type.AttachmentCountProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentCountProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.AttachmentCountProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.AttachmentCountProperty.GetHashCode().

See Also

ViewMember.Type.AttachmentCountProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentCountProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.AttachmentCountProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.AttachmentCountProperty.ToString()

See Also

ViewMember.Type.AttachmentCountProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentIDsProperty Class

The property type of the AttachmentIDs property

For a list of all members of this type, see ViewMember.Type.AttachmentIDsProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
ViewMember.Type.AttachmentIDsProperty

public class ViewMember.Type.AttachmentIDsProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.AttachmentIDsProperty Members | StarTeam Namespace


ViewMember.Type.AttachmentIDsProperty Members

ViewMember.Type.AttachmentIDsProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.AttachmentIDsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.AttachmentIDsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.AttachmentIDsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.AttachmentIDsProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentIDsProperty Properties

The properties of the ViewMember.Type.AttachmentIDsProperty class are listed below. For a complete list of ViewMember.Type.AttachmentIDsProperty class members, see the ViewMember.Type.AttachmentIDsProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

ViewMember.Type.AttachmentIDsProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.AttachmentIDsProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.AttachmentIDsProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentIDsProperty Methods

The methods of the ViewMember.Type.AttachmentIDsProperty class are listed below. For a complete list of ViewMember.Type.AttachmentIDsProperty class members, see the ViewMember.Type.AttachmentIDsProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.AttachmentIDsProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.AttachmentIDsProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.AttachmentIDsProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.AttachmentIDsProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentIDsProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.AttachmentIDsProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.AttachmentIDsProperty.Equals(obj).

See Also

ViewMember.Type.AttachmentIDsProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentIDsProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.AttachmentIDsProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.AttachmentIDsProperty.GetHashCode().

See Also

ViewMember.Type.AttachmentIDsProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentIDsProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.AttachmentIDsProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.AttachmentIDsProperty.ToString()

See Also

ViewMember.Type.AttachmentIDsProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentNamesProperty Class

The property type of the AttachmentNames property

For a list of all members of this type, see ViewMember.Type.AttachmentNamesProperty Members.

System.Object
Property
VectorProperty
TextProperty
ViewMember.Type.AttachmentNamesProperty

public class ViewMember.Type.AttachmentNamesProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.AttachmentNamesProperty Members | StarTeam Namespace


ViewMember.Type.AttachmentNamesProperty Members

ViewMember.Type.AttachmentNamesProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.AttachmentNamesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.AttachmentNamesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.AttachmentNamesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.AttachmentNamesProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentNamesProperty Properties

The properties of the ViewMember.Type.AttachmentNamesProperty class are listed below. For a complete list of ViewMember.Type.AttachmentNamesProperty class members, see the ViewMember.Type.AttachmentNamesProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.AttachmentNamesProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.AttachmentNamesProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.AttachmentNamesProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentNamesProperty Methods

The methods of the ViewMember.Type.AttachmentNamesProperty class are listed below. For a complete list of ViewMember.Type.AttachmentNamesProperty class members, see the ViewMember.Type.AttachmentNamesProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.AttachmentNamesProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.AttachmentNamesProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.AttachmentNamesProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.AttachmentNamesProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentNamesProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.AttachmentNamesProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.AttachmentNamesProperty.Equals(obj).

See Also

ViewMember.Type.AttachmentNamesProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentNamesProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.AttachmentNamesProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.AttachmentNamesProperty.GetHashCode().

See Also

ViewMember.Type.AttachmentNamesProperty Class | StarTeam Namespace


ViewMember.Type.AttachmentNamesProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.AttachmentNamesProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.AttachmentNamesProperty.ToString()

See Also

ViewMember.Type.AttachmentNamesProperty Class | StarTeam Namespace


ViewMember.Type.CommentProperty Class

The property type of the Comment property

For a list of all members of this type, see ViewMember.Type.CommentProperty Members.

System.Object
Property
VectorProperty
TextProperty
ViewMember.Type.CommentProperty

public class ViewMember.Type.CommentProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.CommentProperty Members | StarTeam Namespace


ViewMember.Type.CommentProperty Members

ViewMember.Type.CommentProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.CommentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.CommentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.CommentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.CommentProperty Class | StarTeam Namespace


ViewMember.Type.CommentProperty Properties

The properties of the ViewMember.Type.CommentProperty class are listed below. For a complete list of ViewMember.Type.CommentProperty class members, see the ViewMember.Type.CommentProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.CommentProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.CommentProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.CommentProperty Class | StarTeam Namespace


ViewMember.Type.CommentProperty Methods

The methods of the ViewMember.Type.CommentProperty class are listed below. For a complete list of ViewMember.Type.CommentProperty class members, see the ViewMember.Type.CommentProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.CommentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.CommentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.CommentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.CommentProperty Class | StarTeam Namespace


ViewMember.Type.CommentProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.CommentProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.CommentProperty.Equals(obj).

See Also

ViewMember.Type.CommentProperty Class | StarTeam Namespace


ViewMember.Type.CommentProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.CommentProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.CommentProperty.GetHashCode().

See Also

ViewMember.Type.CommentProperty Class | StarTeam Namespace


ViewMember.Type.CommentProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.CommentProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.CommentProperty.ToString()

See Also

ViewMember.Type.CommentProperty Class | StarTeam Namespace


ViewMember.Type.ConfigurationTimeProperty Class

The property type of the ConfigurationTime property

For a list of all members of this type, see ViewMember.Type.ConfigurationTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ViewMember.Type.ConfigurationTimeProperty

public class ViewMember.Type.ConfigurationTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ConfigurationTimeProperty Members | StarTeam Namespace


ViewMember.Type.ConfigurationTimeProperty Members

ViewMember.Type.ConfigurationTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ConfigurationTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ConfigurationTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ConfigurationTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ConfigurationTimeProperty Class | StarTeam Namespace


ViewMember.Type.ConfigurationTimeProperty Properties

The properties of the ViewMember.Type.ConfigurationTimeProperty class are listed below. For a complete list of ViewMember.Type.ConfigurationTimeProperty class members, see the ViewMember.Type.ConfigurationTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.ConfigurationTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ConfigurationTimeProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ConfigurationTimeProperty Class | StarTeam Namespace


ViewMember.Type.ConfigurationTimeProperty Methods

The methods of the ViewMember.Type.ConfigurationTimeProperty class are listed below. For a complete list of ViewMember.Type.ConfigurationTimeProperty class members, see the ViewMember.Type.ConfigurationTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ConfigurationTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ConfigurationTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ConfigurationTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ConfigurationTimeProperty Class | StarTeam Namespace


ViewMember.Type.ConfigurationTimeProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ConfigurationTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ConfigurationTimeProperty.Equals(obj).

See Also

ViewMember.Type.ConfigurationTimeProperty Class | StarTeam Namespace


ViewMember.Type.ConfigurationTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ConfigurationTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ConfigurationTimeProperty.GetHashCode().

See Also

ViewMember.Type.ConfigurationTimeProperty Class | StarTeam Namespace


ViewMember.Type.ConfigurationTimeProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ConfigurationTimeProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ConfigurationTimeProperty.ToString()

See Also

ViewMember.Type.ConfigurationTimeProperty Class | StarTeam Namespace


ViewMember.Type.DotNotationProperty Class

The property type of the DotNotation property

For a list of all members of this type, see ViewMember.Type.DotNotationProperty Members.

System.Object
Property
VectorProperty
TextProperty
ViewMember.Type.DotNotationProperty

public class ViewMember.Type.DotNotationProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.DotNotationProperty Members | StarTeam Namespace


ViewMember.Type.DotNotationProperty Members

ViewMember.Type.DotNotationProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.DotNotationProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.DotNotationProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.DotNotationProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.DotNotationProperty Class | StarTeam Namespace


ViewMember.Type.DotNotationProperty Properties

The properties of the ViewMember.Type.DotNotationProperty class are listed below. For a complete list of ViewMember.Type.DotNotationProperty class members, see the ViewMember.Type.DotNotationProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.DotNotationProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.DotNotationProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.DotNotationProperty Class | StarTeam Namespace


ViewMember.Type.DotNotationProperty Methods

The methods of the ViewMember.Type.DotNotationProperty class are listed below. For a complete list of ViewMember.Type.DotNotationProperty class members, see the ViewMember.Type.DotNotationProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.DotNotationProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.DotNotationProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.DotNotationProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.DotNotationProperty Class | StarTeam Namespace


ViewMember.Type.DotNotationProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.DotNotationProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.DotNotationProperty.Equals(obj).

See Also

ViewMember.Type.DotNotationProperty Class | StarTeam Namespace


ViewMember.Type.DotNotationProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.DotNotationProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.DotNotationProperty.GetHashCode().

See Also

ViewMember.Type.DotNotationProperty Class | StarTeam Namespace


ViewMember.Type.DotNotationProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.DotNotationProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.DotNotationProperty.ToString()

See Also

ViewMember.Type.DotNotationProperty Class | StarTeam Namespace


ViewMember.Type.ExclusiveLockerProperty Class

The property type of the ExclusiveLocker property

For a list of all members of this type, see ViewMember.Type.ExclusiveLockerProperty Members.

System.Object
Property
ObjectProperty
ViewMember.Type.ExclusiveLockerProperty

public class ViewMember.Type.ExclusiveLockerProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ExclusiveLockerProperty Members | StarTeam Namespace


ViewMember.Type.ExclusiveLockerProperty Members

ViewMember.Type.ExclusiveLockerProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ExclusiveLockerProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ExclusiveLockerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ExclusiveLockerProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ExclusiveLockerProperty Class | StarTeam Namespace


ViewMember.Type.ExclusiveLockerProperty Properties

The properties of the ViewMember.Type.ExclusiveLockerProperty class are listed below. For a complete list of ViewMember.Type.ExclusiveLockerProperty class members, see the ViewMember.Type.ExclusiveLockerProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ViewMember.Type.ExclusiveLockerProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ExclusiveLockerProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ExclusiveLockerProperty Class | StarTeam Namespace


ViewMember.Type.ExclusiveLockerProperty Methods

The methods of the ViewMember.Type.ExclusiveLockerProperty class are listed below. For a complete list of ViewMember.Type.ExclusiveLockerProperty class members, see the ViewMember.Type.ExclusiveLockerProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ExclusiveLockerProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ExclusiveLockerProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ExclusiveLockerProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ExclusiveLockerProperty Class | StarTeam Namespace


ViewMember.Type.ExclusiveLockerProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ExclusiveLockerProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ExclusiveLockerProperty.Equals(obj).

See Also

ViewMember.Type.ExclusiveLockerProperty Class | StarTeam Namespace


ViewMember.Type.ExclusiveLockerProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ExclusiveLockerProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ExclusiveLockerProperty.GetHashCode().

See Also

ViewMember.Type.ExclusiveLockerProperty Class | StarTeam Namespace


ViewMember.Type.ExclusiveLockerProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ExclusiveLockerProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ExclusiveLockerProperty.ToString()

See Also

ViewMember.Type.ExclusiveLockerProperty Class | StarTeam Namespace


ViewMember.Type.ExternalIDProperty Class

The property type of the ExternalIDProperty property

For a list of all members of this type, see ViewMember.Type.ExternalIDProperty Members.

System.Object
Property
VectorProperty
TextProperty
ViewMember.Type.ExternalIDProperty

public class ViewMember.Type.ExternalIDProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ExternalIDProperty Members | StarTeam Namespace


ViewMember.Type.ExternalIDProperty Members

ViewMember.Type.ExternalIDProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ExternalIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ExternalIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ExternalIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ExternalIDProperty Class | StarTeam Namespace


ViewMember.Type.ExternalIDProperty Properties

The properties of the ViewMember.Type.ExternalIDProperty class are listed below. For a complete list of ViewMember.Type.ExternalIDProperty class members, see the ViewMember.Type.ExternalIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.ExternalIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ExternalIDProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ExternalIDProperty Class | StarTeam Namespace


ViewMember.Type.ExternalIDProperty Methods

The methods of the ViewMember.Type.ExternalIDProperty class are listed below. For a complete list of ViewMember.Type.ExternalIDProperty class members, see the ViewMember.Type.ExternalIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ExternalIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ExternalIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ExternalIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ExternalIDProperty Class | StarTeam Namespace


ViewMember.Type.ExternalIDProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ExternalIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ExternalIDProperty.Equals(obj).

See Also

ViewMember.Type.ExternalIDProperty Class | StarTeam Namespace


ViewMember.Type.ExternalIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ExternalIDProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ExternalIDProperty.GetHashCode().

See Also

ViewMember.Type.ExternalIDProperty Class | StarTeam Namespace


ViewMember.Type.ExternalIDProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ExternalIDProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ExternalIDProperty.ToString()

See Also

ViewMember.Type.ExternalIDProperty Class | StarTeam Namespace


ViewMember.Type.ExternalURLProperty Class

The property type of the ExternalURLProperty property

For a list of all members of this type, see ViewMember.Type.ExternalURLProperty Members.

System.Object
Property
VectorProperty
TextProperty
ViewMember.Type.ExternalURLProperty

public class ViewMember.Type.ExternalURLProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ExternalURLProperty Members | StarTeam Namespace


ViewMember.Type.ExternalURLProperty Members

ViewMember.Type.ExternalURLProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ExternalURLProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ExternalURLProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ExternalURLProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ExternalURLProperty Class | StarTeam Namespace


ViewMember.Type.ExternalURLProperty Properties

The properties of the ViewMember.Type.ExternalURLProperty class are listed below. For a complete list of ViewMember.Type.ExternalURLProperty class members, see the ViewMember.Type.ExternalURLProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.ExternalURLProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ExternalURLProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ExternalURLProperty Class | StarTeam Namespace


ViewMember.Type.ExternalURLProperty Methods

The methods of the ViewMember.Type.ExternalURLProperty class are listed below. For a complete list of ViewMember.Type.ExternalURLProperty class members, see the ViewMember.Type.ExternalURLProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ExternalURLProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ExternalURLProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ExternalURLProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ExternalURLProperty Class | StarTeam Namespace


ViewMember.Type.ExternalURLProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ExternalURLProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ExternalURLProperty.Equals(obj).

See Also

ViewMember.Type.ExternalURLProperty Class | StarTeam Namespace


ViewMember.Type.ExternalURLProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ExternalURLProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ExternalURLProperty.GetHashCode().

See Also

ViewMember.Type.ExternalURLProperty Class | StarTeam Namespace


ViewMember.Type.ExternalURLProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ExternalURLProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ExternalURLProperty.ToString()

See Also

ViewMember.Type.ExternalURLProperty Class | StarTeam Namespace


ViewMember.Type.FlaggedByUsersProperty Class

The property type of the FlaggedByUsers property

For a list of all members of this type, see ViewMember.Type.FlaggedByUsersProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
ViewMember.Type.FlaggedByUsersProperty

public class ViewMember.Type.FlaggedByUsersProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.FlaggedByUsersProperty Members | StarTeam Namespace


ViewMember.Type.FlaggedByUsersProperty Members

ViewMember.Type.FlaggedByUsersProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.FlaggedByUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.FlaggedByUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.FlaggedByUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.FlaggedByUsersProperty Class | StarTeam Namespace


ViewMember.Type.FlaggedByUsersProperty Properties

The properties of the ViewMember.Type.FlaggedByUsersProperty class are listed below. For a complete list of ViewMember.Type.FlaggedByUsersProperty class members, see the ViewMember.Type.FlaggedByUsersProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

ViewMember.Type.FlaggedByUsersProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.FlaggedByUsersProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.FlaggedByUsersProperty Class | StarTeam Namespace


ViewMember.Type.FlaggedByUsersProperty Methods

The methods of the ViewMember.Type.FlaggedByUsersProperty class are listed below. For a complete list of ViewMember.Type.FlaggedByUsersProperty class members, see the ViewMember.Type.FlaggedByUsersProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.FlaggedByUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.FlaggedByUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.FlaggedByUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.FlaggedByUsersProperty Class | StarTeam Namespace


ViewMember.Type.FlaggedByUsersProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.FlaggedByUsersProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.FlaggedByUsersProperty.Equals(obj).

See Also

ViewMember.Type.FlaggedByUsersProperty Class | StarTeam Namespace


ViewMember.Type.FlaggedByUsersProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.FlaggedByUsersProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.FlaggedByUsersProperty.GetHashCode().

See Also

ViewMember.Type.FlaggedByUsersProperty Class | StarTeam Namespace


ViewMember.Type.FlaggedByUsersProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.FlaggedByUsersProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.FlaggedByUsersProperty.ToString()

See Also

ViewMember.Type.FlaggedByUsersProperty Class | StarTeam Namespace


ViewMember.Type.IsBookmarkedProperty Class

The property type of the IsBookmarked property

For a list of all members of this type, see ViewMember.Type.IsBookmarkedProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
ViewMember.Type.IsBookmarkedProperty

public class ViewMember.Type.IsBookmarkedProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.IsBookmarkedProperty Members | StarTeam Namespace


ViewMember.Type.IsBookmarkedProperty Members

ViewMember.Type.IsBookmarkedProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.IsBookmarkedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.IsBookmarkedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.IsBookmarkedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.IsBookmarkedProperty Class | StarTeam Namespace


ViewMember.Type.IsBookmarkedProperty Properties

The properties of the ViewMember.Type.IsBookmarkedProperty class are listed below. For a complete list of ViewMember.Type.IsBookmarkedProperty class members, see the ViewMember.Type.IsBookmarkedProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ViewMember.Type.IsBookmarkedProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.IsBookmarkedProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.IsBookmarkedProperty Class | StarTeam Namespace


ViewMember.Type.IsBookmarkedProperty Methods

The methods of the ViewMember.Type.IsBookmarkedProperty class are listed below. For a complete list of ViewMember.Type.IsBookmarkedProperty class members, see the ViewMember.Type.IsBookmarkedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.IsBookmarkedProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.IsBookmarkedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.IsBookmarkedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.IsBookmarkedProperty Class | StarTeam Namespace


ViewMember.Type.IsBookmarkedProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.IsBookmarkedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.IsBookmarkedProperty.Equals(obj).

See Also

ViewMember.Type.IsBookmarkedProperty Class | StarTeam Namespace


ViewMember.Type.IsBookmarkedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.IsBookmarkedProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.IsBookmarkedProperty.GetHashCode().

See Also

ViewMember.Type.IsBookmarkedProperty Class | StarTeam Namespace


ViewMember.Type.IsBookmarkedProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.IsBookmarkedProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.IsBookmarkedProperty.ToString()

See Also

ViewMember.Type.IsBookmarkedProperty Class | StarTeam Namespace


ViewMember.Type.IsBranchOnChangeProperty Class

The property type of the IsBranchOnChange property

For a list of all members of this type, see ViewMember.Type.IsBranchOnChangeProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
ViewMember.Type.IsBranchOnChangeProperty

public class ViewMember.Type.IsBranchOnChangeProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.IsBranchOnChangeProperty Members | StarTeam Namespace


ViewMember.Type.IsBranchOnChangeProperty Members

ViewMember.Type.IsBranchOnChangeProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.IsBranchOnChangeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.IsBranchOnChangeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.IsBranchOnChangeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.IsBranchOnChangeProperty Class | StarTeam Namespace


ViewMember.Type.IsBranchOnChangeProperty Properties

The properties of the ViewMember.Type.IsBranchOnChangeProperty class are listed below. For a complete list of ViewMember.Type.IsBranchOnChangeProperty class members, see the ViewMember.Type.IsBranchOnChangeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ViewMember.Type.IsBranchOnChangeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.IsBranchOnChangeProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.IsBranchOnChangeProperty Class | StarTeam Namespace


ViewMember.Type.IsBranchOnChangeProperty Methods

The methods of the ViewMember.Type.IsBranchOnChangeProperty class are listed below. For a complete list of ViewMember.Type.IsBranchOnChangeProperty class members, see the ViewMember.Type.IsBranchOnChangeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.IsBranchOnChangeProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.IsBranchOnChangeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.IsBranchOnChangeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.IsBranchOnChangeProperty Class | StarTeam Namespace


ViewMember.Type.IsBranchOnChangeProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.IsBranchOnChangeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.IsBranchOnChangeProperty.Equals(obj).

See Also

ViewMember.Type.IsBranchOnChangeProperty Class | StarTeam Namespace


ViewMember.Type.IsBranchOnChangeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.IsBranchOnChangeProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.IsBranchOnChangeProperty.GetHashCode().

See Also

ViewMember.Type.IsBranchOnChangeProperty Class | StarTeam Namespace


ViewMember.Type.IsBranchOnChangeProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.IsBranchOnChangeProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.IsBranchOnChangeProperty.ToString()

See Also

ViewMember.Type.IsBranchOnChangeProperty Class | StarTeam Namespace


ViewMember.Type.IsReadOnlyProperty Class

The property type of the IsReadOnly property

For a list of all members of this type, see ViewMember.Type.IsReadOnlyProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
ViewMember.Type.IsReadOnlyProperty

public class ViewMember.Type.IsReadOnlyProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.IsReadOnlyProperty Members | StarTeam Namespace


ViewMember.Type.IsReadOnlyProperty Members

ViewMember.Type.IsReadOnlyProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.IsReadOnlyProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.IsReadOnlyProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.IsReadOnlyProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.IsReadOnlyProperty Class | StarTeam Namespace


ViewMember.Type.IsReadOnlyProperty Properties

The properties of the ViewMember.Type.IsReadOnlyProperty class are listed below. For a complete list of ViewMember.Type.IsReadOnlyProperty class members, see the ViewMember.Type.IsReadOnlyProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ViewMember.Type.IsReadOnlyProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.IsReadOnlyProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.IsReadOnlyProperty Class | StarTeam Namespace


ViewMember.Type.IsReadOnlyProperty Methods

The methods of the ViewMember.Type.IsReadOnlyProperty class are listed below. For a complete list of ViewMember.Type.IsReadOnlyProperty class members, see the ViewMember.Type.IsReadOnlyProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.IsReadOnlyProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.IsReadOnlyProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.IsReadOnlyProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.IsReadOnlyProperty Class | StarTeam Namespace


ViewMember.Type.IsReadOnlyProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.IsReadOnlyProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.IsReadOnlyProperty.Equals(obj).

See Also

ViewMember.Type.IsReadOnlyProperty Class | StarTeam Namespace


ViewMember.Type.IsReadOnlyProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.IsReadOnlyProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.IsReadOnlyProperty.GetHashCode().

See Also

ViewMember.Type.IsReadOnlyProperty Class | StarTeam Namespace


ViewMember.Type.IsReadOnlyProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.IsReadOnlyProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.IsReadOnlyProperty.ToString()

See Also

ViewMember.Type.IsReadOnlyProperty Class | StarTeam Namespace


ViewMember.Type.IsUnreadProperty Class

The property type of the IsUnread property

For a list of all members of this type, see ViewMember.Type.IsUnreadProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
ViewMember.Type.IsUnreadProperty

public class ViewMember.Type.IsUnreadProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.IsUnreadProperty Members | StarTeam Namespace


ViewMember.Type.IsUnreadProperty Members

ViewMember.Type.IsUnreadProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.IsUnreadProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.IsUnreadProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.IsUnreadProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.IsUnreadProperty Class | StarTeam Namespace


ViewMember.Type.IsUnreadProperty Properties

The properties of the ViewMember.Type.IsUnreadProperty class are listed below. For a complete list of ViewMember.Type.IsUnreadProperty class members, see the ViewMember.Type.IsUnreadProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ViewMember.Type.IsUnreadProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.IsUnreadProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.IsUnreadProperty Class | StarTeam Namespace


ViewMember.Type.IsUnreadProperty Methods

The methods of the ViewMember.Type.IsUnreadProperty class are listed below. For a complete list of ViewMember.Type.IsUnreadProperty class members, see the ViewMember.Type.IsUnreadProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.IsUnreadProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.IsUnreadProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.IsUnreadProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.IsUnreadProperty Class | StarTeam Namespace


ViewMember.Type.IsUnreadProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.IsUnreadProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.IsUnreadProperty.Equals(obj).

See Also

ViewMember.Type.IsUnreadProperty Class | StarTeam Namespace


ViewMember.Type.IsUnreadProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.IsUnreadProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.IsUnreadProperty.GetHashCode().

See Also

ViewMember.Type.IsUnreadProperty Class | StarTeam Namespace


ViewMember.Type.IsUnreadProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.IsUnreadProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.IsUnreadProperty.ToString()

See Also

ViewMember.Type.IsUnreadProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedByProperty Class

The property type of the ItemDeletedBy property

For a list of all members of this type, see ViewMember.Type.ItemDeletedByProperty Members.

System.Object
Property
ObjectProperty
ViewMember.Type.ItemDeletedByProperty

public class ViewMember.Type.ItemDeletedByProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ItemDeletedByProperty Members | StarTeam Namespace


ViewMember.Type.ItemDeletedByProperty Members

ViewMember.Type.ItemDeletedByProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ItemDeletedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ItemDeletedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ItemDeletedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ItemDeletedByProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedByProperty Properties

The properties of the ViewMember.Type.ItemDeletedByProperty class are listed below. For a complete list of ViewMember.Type.ItemDeletedByProperty class members, see the ViewMember.Type.ItemDeletedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ViewMember.Type.ItemDeletedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ItemDeletedByProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ItemDeletedByProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedByProperty Methods

The methods of the ViewMember.Type.ItemDeletedByProperty class are listed below. For a complete list of ViewMember.Type.ItemDeletedByProperty class members, see the ViewMember.Type.ItemDeletedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ItemDeletedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ItemDeletedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ItemDeletedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ItemDeletedByProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedByProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ItemDeletedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ItemDeletedByProperty.Equals(obj).

See Also

ViewMember.Type.ItemDeletedByProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ItemDeletedByProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ItemDeletedByProperty.GetHashCode().

See Also

ViewMember.Type.ItemDeletedByProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedByProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ItemDeletedByProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ItemDeletedByProperty.ToString()

See Also

ViewMember.Type.ItemDeletedByProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedTimeProperty Class

The property type of the ItemDeletedTime property

For a list of all members of this type, see ViewMember.Type.ItemDeletedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ViewMember.Type.ItemDeletedTimeProperty

public class ViewMember.Type.ItemDeletedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ItemDeletedTimeProperty Members | StarTeam Namespace


ViewMember.Type.ItemDeletedTimeProperty Members

ViewMember.Type.ItemDeletedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ItemDeletedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ItemDeletedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ItemDeletedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ItemDeletedTimeProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedTimeProperty Properties

The properties of the ViewMember.Type.ItemDeletedTimeProperty class are listed below. For a complete list of ViewMember.Type.ItemDeletedTimeProperty class members, see the ViewMember.Type.ItemDeletedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.ItemDeletedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ItemDeletedTimeProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ItemDeletedTimeProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedTimeProperty Methods

The methods of the ViewMember.Type.ItemDeletedTimeProperty class are listed below. For a complete list of ViewMember.Type.ItemDeletedTimeProperty class members, see the ViewMember.Type.ItemDeletedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ItemDeletedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ItemDeletedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ItemDeletedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ItemDeletedTimeProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedTimeProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ItemDeletedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ItemDeletedTimeProperty.Equals(obj).

See Also

ViewMember.Type.ItemDeletedTimeProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ItemDeletedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ItemDeletedTimeProperty.GetHashCode().

See Also

ViewMember.Type.ItemDeletedTimeProperty Class | StarTeam Namespace


ViewMember.Type.ItemDeletedTimeProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ItemDeletedTimeProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ItemDeletedTimeProperty.ToString()

See Also

ViewMember.Type.ItemDeletedTimeProperty Class | StarTeam Namespace


ViewMember.Type.MyLockProperty Class

The property type of the MyLock property

For a list of all members of this type, see ViewMember.Type.MyLockProperty Members.

System.Object
Property
EnumeratedProperty
ViewMember.Type.MyLockProperty

public class ViewMember.Type.MyLockProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.MyLockProperty Members | StarTeam Namespace


ViewMember.Type.MyLockProperty Members

ViewMember.Type.MyLockProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.MyLockProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.MyLockProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.MyLockProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.MyLockProperty Class | StarTeam Namespace


ViewMember.Type.MyLockProperty Properties

The properties of the ViewMember.Type.MyLockProperty class are listed below. For a complete list of ViewMember.Type.MyLockProperty class members, see the ViewMember.Type.MyLockProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ViewMember.Type.MyLockProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.MyLockProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.MyLockProperty Class | StarTeam Namespace


ViewMember.Type.MyLockProperty Methods

The methods of the ViewMember.Type.MyLockProperty class are listed below. For a complete list of ViewMember.Type.MyLockProperty class members, see the ViewMember.Type.MyLockProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.MyLockProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.MyLockProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.MyLockProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.MyLockProperty Class | StarTeam Namespace


ViewMember.Type.MyLockProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.MyLockProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.MyLockProperty.Equals(obj).

See Also

ViewMember.Type.MyLockProperty Class | StarTeam Namespace


ViewMember.Type.MyLockProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ViewMember.MyLock value
);

See Also

ViewMember.Type.MyLockProperty Class | StarTeam Namespace


ViewMember.Type.MyLockProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.MyLockProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.MyLockProperty.GetHashCode().

See Also

ViewMember.Type.MyLockProperty Class | StarTeam Namespace


ViewMember.Type.MyLockProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.MyLockProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.MyLockProperty.ToString()

See Also

ViewMember.Type.MyLockProperty Class | StarTeam Namespace


ViewMember.Type.NonExclusiveLockersProperty Class

The property type of the NonExclusiveLocker property

For a list of all members of this type, see ViewMember.Type.NonExclusiveLockersProperty Members.

System.Object
Property
VectorProperty
TextProperty
ViewMember.Type.NonExclusiveLockersProperty

public class ViewMember.Type.NonExclusiveLockersProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.NonExclusiveLockersProperty Members | StarTeam Namespace


ViewMember.Type.NonExclusiveLockersProperty Members

ViewMember.Type.NonExclusiveLockersProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.NonExclusiveLockersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.NonExclusiveLockersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.NonExclusiveLockersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.NonExclusiveLockersProperty Class | StarTeam Namespace


ViewMember.Type.NonExclusiveLockersProperty Properties

The properties of the ViewMember.Type.NonExclusiveLockersProperty class are listed below. For a complete list of ViewMember.Type.NonExclusiveLockersProperty class members, see the ViewMember.Type.NonExclusiveLockersProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.NonExclusiveLockersProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.NonExclusiveLockersProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.NonExclusiveLockersProperty Class | StarTeam Namespace


ViewMember.Type.NonExclusiveLockersProperty Methods

The methods of the ViewMember.Type.NonExclusiveLockersProperty class are listed below. For a complete list of ViewMember.Type.NonExclusiveLockersProperty class members, see the ViewMember.Type.NonExclusiveLockersProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.NonExclusiveLockersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.NonExclusiveLockersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.NonExclusiveLockersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.NonExclusiveLockersProperty Class | StarTeam Namespace


ViewMember.Type.NonExclusiveLockersProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.NonExclusiveLockersProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.NonExclusiveLockersProperty.Equals(obj).

See Also

ViewMember.Type.NonExclusiveLockersProperty Class | StarTeam Namespace


ViewMember.Type.NonExclusiveLockersProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.NonExclusiveLockersProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.NonExclusiveLockersProperty.GetHashCode().

See Also

ViewMember.Type.NonExclusiveLockersProperty Class | StarTeam Namespace


ViewMember.Type.NonExclusiveLockersProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.NonExclusiveLockersProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.NonExclusiveLockersProperty.ToString()

See Also

ViewMember.Type.NonExclusiveLockersProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchLengthProperty Class

The property type of the ParentBranchLength property

For a list of all members of this type, see ViewMember.Type.ParentBranchLengthProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ViewMember.Type.ParentBranchLengthProperty

public class ViewMember.Type.ParentBranchLengthProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ParentBranchLengthProperty Members | StarTeam Namespace


ViewMember.Type.ParentBranchLengthProperty Members

ViewMember.Type.ParentBranchLengthProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ParentBranchLengthProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ParentBranchLengthProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ParentBranchLengthProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ParentBranchLengthProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchLengthProperty Properties

The properties of the ViewMember.Type.ParentBranchLengthProperty class are listed below. For a complete list of ViewMember.Type.ParentBranchLengthProperty class members, see the ViewMember.Type.ParentBranchLengthProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.ParentBranchLengthProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ParentBranchLengthProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ParentBranchLengthProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchLengthProperty Methods

The methods of the ViewMember.Type.ParentBranchLengthProperty class are listed below. For a complete list of ViewMember.Type.ParentBranchLengthProperty class members, see the ViewMember.Type.ParentBranchLengthProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ParentBranchLengthProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ParentBranchLengthProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ParentBranchLengthProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ParentBranchLengthProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchLengthProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ParentBranchLengthProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ParentBranchLengthProperty.Equals(obj).

See Also

ViewMember.Type.ParentBranchLengthProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchLengthProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ParentBranchLengthProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ParentBranchLengthProperty.GetHashCode().

See Also

ViewMember.Type.ParentBranchLengthProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchLengthProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ParentBranchLengthProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ParentBranchLengthProperty.ToString()

See Also

ViewMember.Type.ParentBranchLengthProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchRevisionProperty Class

The property type of the ParentBranchRevision property

For a list of all members of this type, see ViewMember.Type.ParentBranchRevisionProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ViewMember.Type.ParentBranchRevisionProperty

public class ViewMember.Type.ParentBranchRevisionProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ParentBranchRevisionProperty Members | StarTeam Namespace


ViewMember.Type.ParentBranchRevisionProperty Members

ViewMember.Type.ParentBranchRevisionProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ParentBranchRevisionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ParentBranchRevisionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ParentBranchRevisionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ParentBranchRevisionProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchRevisionProperty Properties

The properties of the ViewMember.Type.ParentBranchRevisionProperty class are listed below. For a complete list of ViewMember.Type.ParentBranchRevisionProperty class members, see the ViewMember.Type.ParentBranchRevisionProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.ParentBranchRevisionProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ParentBranchRevisionProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ParentBranchRevisionProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchRevisionProperty Methods

The methods of the ViewMember.Type.ParentBranchRevisionProperty class are listed below. For a complete list of ViewMember.Type.ParentBranchRevisionProperty class members, see the ViewMember.Type.ParentBranchRevisionProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ParentBranchRevisionProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ParentBranchRevisionProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ParentBranchRevisionProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ParentBranchRevisionProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchRevisionProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ParentBranchRevisionProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ParentBranchRevisionProperty.Equals(obj).

See Also

ViewMember.Type.ParentBranchRevisionProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchRevisionProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ParentBranchRevisionProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ParentBranchRevisionProperty.GetHashCode().

See Also

ViewMember.Type.ParentBranchRevisionProperty Class | StarTeam Namespace


ViewMember.Type.ParentBranchRevisionProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ParentBranchRevisionProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ParentBranchRevisionProperty.ToString()

See Also

ViewMember.Type.ParentBranchRevisionProperty Class | StarTeam Namespace


ViewMember.Type.ParentObjectIDProperty Class

The property type of the ParentObjectID property

For a list of all members of this type, see ViewMember.Type.ParentObjectIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ViewMember.Type.ParentObjectIDProperty

public class ViewMember.Type.ParentObjectIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ParentObjectIDProperty Members | StarTeam Namespace


ViewMember.Type.ParentObjectIDProperty Members

ViewMember.Type.ParentObjectIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ParentObjectIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ParentObjectIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ParentObjectIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ParentObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.ParentObjectIDProperty Properties

The properties of the ViewMember.Type.ParentObjectIDProperty class are listed below. For a complete list of ViewMember.Type.ParentObjectIDProperty class members, see the ViewMember.Type.ParentObjectIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.ParentObjectIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ParentObjectIDProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ParentObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.ParentObjectIDProperty Methods

The methods of the ViewMember.Type.ParentObjectIDProperty class are listed below. For a complete list of ViewMember.Type.ParentObjectIDProperty class members, see the ViewMember.Type.ParentObjectIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ParentObjectIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ParentObjectIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ParentObjectIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ParentObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.ParentObjectIDProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ParentObjectIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ParentObjectIDProperty.Equals(obj).

See Also

ViewMember.Type.ParentObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.ParentObjectIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ParentObjectIDProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ParentObjectIDProperty.GetHashCode().

See Also

ViewMember.Type.ParentObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.ParentObjectIDProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ParentObjectIDProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ParentObjectIDProperty.ToString()

See Also

ViewMember.Type.ParentObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.PropertyCollection Class

Property Collection for ViewMember

For a list of all members of this type, see ViewMember.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
ChangePackage.Type.PropertyCollection
Item.Type.PropertyCollection
Trace.Type.PropertyCollection

public class ViewMember.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.PropertyCollection Members | StarTeam Namespace


ViewMember.Type.PropertyCollection Members

ViewMember.Type.PropertyCollection overview

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MY_LOCK |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEWMEMBER_ID |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.ViewMember.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.ViewMember.Type.PropertyCollection.

See Also

ViewMember.Type.PropertyCollection Class | StarTeam Namespace


ViewMember.Type.PropertyCollection Properties

The properties of the ViewMember.Type.PropertyCollection class are listed below. For a complete list of ViewMember.Type.PropertyCollection class members, see the ViewMember.Type.PropertyCollection Members topic.

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MY_LOCK |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEWMEMBER_ID |

See Also

ViewMember.Type.PropertyCollection Class | StarTeam Namespace


MY_LOCK Property

Borland StarTeam SDK for .NET

ViewMember.Type.PropertyCollection.MY_LOCK Property

public ViewMember.Type.MyLockProperty MY_LOCK {get;}

See Also

ViewMember.Type.PropertyCollection Class | StarTeam Namespace


VIEWMEMBER_ID Property

Borland StarTeam SDK for .NET

ViewMember.Type.PropertyCollection.VIEWMEMBER_ID Property

public ViewMember.Type.ViewMemberIDProperty VIEWMEMBER_ID {get;}

See Also

ViewMember.Type.PropertyCollection Class | StarTeam Namespace


ViewMember.Type.PropertyCollection Methods

The methods of the ViewMember.Type.PropertyCollection class are listed below. For a complete list of ViewMember.Type.PropertyCollection class members, see the ViewMember.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.ViewMember.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.ViewMember.Type.PropertyCollection.

See Also

ViewMember.Type.PropertyCollection Class | StarTeam Namespace


ViewMember.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.PropertyCollection.Equals(obj).

See Also

ViewMember.Type.PropertyCollection Class | StarTeam Namespace


ViewMember.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.PropertyCollection.GetHashCode().

See Also

ViewMember.Type.PropertyCollection Class | StarTeam Namespace


ViewMember.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.PropertyCollection.ToString()

See Also

ViewMember.Type.PropertyCollection Class | StarTeam Namespace


ViewMember.Type.ResponsibilityProperty Class

The property type of the Responsibility property.

For a list of all members of this type, see ViewMember.Type.ResponsibilityProperty Members.

System.Object
Property
ObjectProperty
ViewMember.Type.ResponsibilityProperty

public class ViewMember.Type.ResponsibilityProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ResponsibilityProperty Members | StarTeam Namespace


ViewMember.Type.ResponsibilityProperty Members

ViewMember.Type.ResponsibilityProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ResponsibilityProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ResponsibilityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ResponsibilityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ResponsibilityProperty Class | StarTeam Namespace


ViewMember.Type.ResponsibilityProperty Properties

The properties of the ViewMember.Type.ResponsibilityProperty class are listed below. For a complete list of ViewMember.Type.ResponsibilityProperty class members, see the ViewMember.Type.ResponsibilityProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ViewMember.Type.ResponsibilityProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ResponsibilityProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ResponsibilityProperty Class | StarTeam Namespace


ViewMember.Type.ResponsibilityProperty Methods

The methods of the ViewMember.Type.ResponsibilityProperty class are listed below. For a complete list of ViewMember.Type.ResponsibilityProperty class members, see the ViewMember.Type.ResponsibilityProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ResponsibilityProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ResponsibilityProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ResponsibilityProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ResponsibilityProperty Class | StarTeam Namespace


ViewMember.Type.ResponsibilityProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ResponsibilityProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ResponsibilityProperty.Equals(obj).

See Also

ViewMember.Type.ResponsibilityProperty Class | StarTeam Namespace


ViewMember.Type.ResponsibilityProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ResponsibilityProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ResponsibilityProperty.GetHashCode().

See Also

ViewMember.Type.ResponsibilityProperty Class | StarTeam Namespace


ViewMember.Type.ResponsibilityProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ResponsibilityProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ResponsibilityProperty.ToString()

See Also

ViewMember.Type.ResponsibilityProperty Class | StarTeam Namespace


ViewMember.Type.RootObjectIDProperty Class

The property type of the RootObjectID property

For a list of all members of this type, see ViewMember.Type.RootObjectIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ViewMember.Type.RootObjectIDProperty

public class ViewMember.Type.RootObjectIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.RootObjectIDProperty Members | StarTeam Namespace


ViewMember.Type.RootObjectIDProperty Members

ViewMember.Type.RootObjectIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.RootObjectIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.RootObjectIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.RootObjectIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.RootObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.RootObjectIDProperty Properties

The properties of the ViewMember.Type.RootObjectIDProperty class are listed below. For a complete list of ViewMember.Type.RootObjectIDProperty class members, see the ViewMember.Type.RootObjectIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.RootObjectIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.RootObjectIDProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.RootObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.RootObjectIDProperty Methods

The methods of the ViewMember.Type.RootObjectIDProperty class are listed below. For a complete list of ViewMember.Type.RootObjectIDProperty class members, see the ViewMember.Type.RootObjectIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.RootObjectIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.RootObjectIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.RootObjectIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.RootObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.RootObjectIDProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.RootObjectIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.RootObjectIDProperty.Equals(obj).

See Also

ViewMember.Type.RootObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.RootObjectIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.RootObjectIDProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.RootObjectIDProperty.GetHashCode().

See Also

ViewMember.Type.RootObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.RootObjectIDProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.RootObjectIDProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.RootObjectIDProperty.ToString()

See Also

ViewMember.Type.RootObjectIDProperty Class | StarTeam Namespace


ViewMember.Type.ShareStateProperty Class

The property type of the ShareState property

For a list of all members of this type, see ViewMember.Type.ShareStateProperty Members.

System.Object
Property
EnumeratedProperty
ViewMember.Type.ShareStateProperty

public class ViewMember.Type.ShareStateProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ShareStateProperty Members | StarTeam Namespace


ViewMember.Type.ShareStateProperty Members

ViewMember.Type.ShareStateProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ShareStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ShareStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ShareStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ShareStateProperty Class | StarTeam Namespace


ViewMember.Type.ShareStateProperty Properties

The properties of the ViewMember.Type.ShareStateProperty class are listed below. For a complete list of ViewMember.Type.ShareStateProperty class members, see the ViewMember.Type.ShareStateProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ViewMember.Type.ShareStateProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ShareStateProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ShareStateProperty Class | StarTeam Namespace


ViewMember.Type.ShareStateProperty Methods

The methods of the ViewMember.Type.ShareStateProperty class are listed below. For a complete list of ViewMember.Type.ShareStateProperty class members, see the ViewMember.Type.ShareStateProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ShareStateProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromValue |
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ShareStateProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ShareStateProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ShareStateProperty Class | StarTeam Namespace


ViewMember.Type.ShareStateProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ShareStateProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ShareStateProperty.Equals(obj).

See Also

ViewMember.Type.ShareStateProperty Class | StarTeam Namespace


ViewMember.Type.ShareStateProperty.FromValue Method

public virtual EnumeratedValue FromValue(
ViewMember.ShareState value
);

See Also

ViewMember.Type.ShareStateProperty Class | StarTeam Namespace


ViewMember.Type.ShareStateProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ShareStateProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ShareStateProperty.GetHashCode().

See Also

ViewMember.Type.ShareStateProperty Class | StarTeam Namespace


ViewMember.Type.ShareStateProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ShareStateProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ShareStateProperty.ToString()

See Also

ViewMember.Type.ShareStateProperty Class | StarTeam Namespace


ViewMember.Type.UnreadByUsersProperty Class

The property type of the UnreadByUsers property

For a list of all members of this type, see ViewMember.Type.UnreadByUsersProperty Members.

System.Object
Property
VectorProperty
ObjectArrayProperty
ViewMember.Type.UnreadByUsersProperty

public class ViewMember.Type.UnreadByUsersProperty : ObjectArrayProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.UnreadByUsersProperty Members | StarTeam Namespace


ViewMember.Type.UnreadByUsersProperty Members

ViewMember.Type.UnreadByUsersProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.UnreadByUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.UnreadByUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.UnreadByUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.UnreadByUsersProperty Class | StarTeam Namespace


ViewMember.Type.UnreadByUsersProperty Properties

The properties of the ViewMember.Type.UnreadByUsersProperty class are listed below. For a complete list of ViewMember.Type.UnreadByUsersProperty class members, see the ViewMember.Type.UnreadByUsersProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectArrayProperty) | [read/write] int[]
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfMembers (inherited from ObjectArrayProperty) | [read] The type of member object referenced by this property value, or null if there is no explicit type (as is the case for ATTACHMENT_IDS).

See Also

ViewMember.Type.UnreadByUsersProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.UnreadByUsersProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.UnreadByUsersProperty Class | StarTeam Namespace


ViewMember.Type.UnreadByUsersProperty Methods

The methods of the ViewMember.Type.UnreadByUsersProperty class are listed below. For a complete list of ViewMember.Type.UnreadByUsersProperty class members, see the ViewMember.Type.UnreadByUsersProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.UnreadByUsersProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.UnreadByUsersProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectArrayProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.UnreadByUsersProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.UnreadByUsersProperty Class | StarTeam Namespace


ViewMember.Type.UnreadByUsersProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.UnreadByUsersProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.UnreadByUsersProperty.Equals(obj).

See Also

ViewMember.Type.UnreadByUsersProperty Class | StarTeam Namespace


ViewMember.Type.UnreadByUsersProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.UnreadByUsersProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.UnreadByUsersProperty.GetHashCode().

See Also

ViewMember.Type.UnreadByUsersProperty Class | StarTeam Namespace


ViewMember.Type.UnreadByUsersProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.UnreadByUsersProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.UnreadByUsersProperty.ToString()

See Also

ViewMember.Type.UnreadByUsersProperty Class | StarTeam Namespace


ViewMember.Type.ViewMemberIDProperty Class

The property type of the ViewMember ID property.

For a list of all members of this type, see ViewMember.Type.ViewMemberIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ViewMember.Type.ViewMemberIDProperty

public class ViewMember.Type.ViewMemberIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.ViewMemberIDProperty Members | StarTeam Namespace


ViewMember.Type.ViewMemberIDProperty Members

ViewMember.Type.ViewMemberIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ViewMemberIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ViewMemberIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ViewMemberIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ViewMemberIDProperty Class | StarTeam Namespace


ViewMember.Type.ViewMemberIDProperty Properties

The properties of the ViewMember.Type.ViewMemberIDProperty class are listed below. For a complete list of ViewMember.Type.ViewMemberIDProperty class members, see the ViewMember.Type.ViewMemberIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMember.Type.ViewMemberIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMember.Type.ViewMemberIDProperty.NAME Property

public static String NAME {get;}

See Also

ViewMember.Type.ViewMemberIDProperty Class | StarTeam Namespace


ViewMember.Type.ViewMemberIDProperty Methods

The methods of the ViewMember.Type.ViewMemberIDProperty class are listed below. For a complete list of ViewMember.Type.ViewMemberIDProperty class members, see the ViewMember.Type.ViewMemberIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMember.Type.ViewMemberIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.ViewMemberIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMember.Type.ViewMemberIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMember.Type.ViewMemberIDProperty Class | StarTeam Namespace


ViewMember.Type.ViewMemberIDProperty.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.ViewMemberIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.ViewMemberIDProperty.Equals(obj).

See Also

ViewMember.Type.ViewMemberIDProperty Class | StarTeam Namespace


ViewMember.Type.ViewMemberIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.ViewMemberIDProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.ViewMemberIDProperty.GetHashCode().

See Also

ViewMember.Type.ViewMemberIDProperty Class | StarTeam Namespace


ViewMember.Type.ViewMemberIDProperty.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.ViewMemberIDProperty.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.ViewMemberIDProperty.ToString()

See Also

ViewMember.Type.ViewMemberIDProperty Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType Class

Base accessor for cached SDK types encapsulating the statefulness of objects obtained from the artifact cache.

For a list of all members of this type, see ViewMember.Type.WebCacheViewMemberType Members.

System.Object
Type.WebCacheType
ViewMember.Type.WebCacheViewMemberType
Item.Type.WebCacheItemType

public class ViewMember.Type.WebCacheViewMemberType : WebCacheType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.Type.WebCacheViewMemberType Members | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType Members

ViewMember.Type.WebCacheViewMemberType overview

Public Instance Properties

Catalog | [read] the Catalog for this type
ComponentGUID | [read] the Component GUID of this type
Context | [read] the context of this object.
DisplayName | [read] a display name for this type.
DisplayNameTranslations | [read]
Filters | [read] the set of filters
ID | [read] the class ID for this type.
Name |
NameProperty |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties | [read] an array of all properties belonging to this type.
Queries | [read] the set of queries
SecondaryDescriptor | [read] The secondary descriptor of this type, or null if this type has no secondary descriptor.
Server | [read] the Server for this cached object

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMember.Type.WebCacheViewMemberType.
FindFilter | Overloaded. find a Filter by ID, visible in the user context
FindProperty | Overloaded. Find and return a property by int iD
FindQuery | Overloaded. find a Query by ID, visible in the user context
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.WebCacheViewMemberType.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
NewBooleanProperty | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty | Creates a new DateProperty
NewDateTimeProperty | Creates a new DateTimeProperty
NewDoubleProperty | Creates a new DoubleProperty
NewEnumeratedProperty | Create a new Enumerated Property
NewGroupArrayProperty | Creates a property on the server.
NewGroupProperty | Creates a property on the server.
NewIntegerProperty | Creates a new IntegerProperty
NewLongIntegerProperty | Creates a new LongIntegerProperty. The new property is dirty; to save changes, you must call Property.update().
NewMapProperty | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewTextProperty | Creates a new TextProperty
NewTimeSpanProperty | Creates a new TimeSpanProperty
NewUserArrayProperty | Creates a property on the server.
NewUserProperty | Creates a property on the server.
NewWebCacheFilterEventSource (inherited from WebCacheType) |
NewWebCacheQueryEventSource (inherited from WebCacheType) |
SetRights |
ToString | Delegate ToString() to com.starteam.ViewMember.Type.WebCacheViewMemberType.

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType Properties

The properties of the ViewMember.Type.WebCacheViewMemberType class are listed below. For a complete list of ViewMember.Type.WebCacheViewMemberType class members, see the ViewMember.Type.WebCacheViewMemberType Members topic.

Public Instance Properties

Catalog | [read] the Catalog for this type
ComponentGUID | [read] the Component GUID of this type
Context | [read] the context of this object.
DisplayName | [read] a display name for this type.
DisplayNameTranslations | [read]
Filters | [read] the set of filters
ID | [read] the class ID for this type.
Name |
NameProperty |
PrimaryDescriptor | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties | [read] an array of all properties belonging to this type.
Queries | [read] the set of queries
SecondaryDescriptor | [read] The secondary descriptor of this type, or null if this type has no secondary descriptor.
Server | [read] the Server for this cached object

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


Catalog Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.Catalog Property

[read] the Catalog for this type

new public virtual Catalog.WebCacheCatalog Catalog {get;}

Property Value

the Catalog for this type

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ComponentGUID Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.ComponentGUID Property

[read] the Component GUID of this type

new public virtual GUID ComponentGUID {get;}

Property Value

the Component GUID of this type

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.DisplayName Property

[read] a display name for this type.

new public virtual String DisplayName {get;}

Property Value

a display name for this type.

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.DisplayNameTranslations Property

[read]

new public virtual Translations DisplayNameTranslations {get;}

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


Filters Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.Filters Property

[read] the set of filters

new public virtual WebCacheFilter[] Filters {get;}

Property Value

the set of filters

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.ID Property

[read] the class ID for this type.

new public virtual Int32 ID {get;}

Property Value

the class ID for this type.

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.Name Property

new public virtual String Name {get;}

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


PrimaryDescriptor Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.PrimaryDescriptor Property

[read] The primary descriptor of this type, or null if this type has no primary descriptor.

new public virtual Property.WebCacheProperty PrimaryDescriptor {get;}

Property Value

The primary descriptor of this type, or null if this type has no primary descriptor.

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.Properties Property

[read] an array of all properties belonging to this type.

new public virtual WebCacheProperty[] Properties {get;}

Property Value

an array of all properties belonging to this type.

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


Queries Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.Queries Property

[read] the set of queries

new public virtual WebCacheQuery[] Queries {get;}

Property Value

the set of queries

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


SecondaryDescriptor Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.SecondaryDescriptor Property

[read] The secondary descriptor of this type, or null if this type has no secondary descriptor.

new public virtual Property.WebCacheProperty SecondaryDescriptor {get;}

Property Value

The secondary descriptor of this type, or null if this type has no secondary descriptor.

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType Methods

The methods of the ViewMember.Type.WebCacheViewMemberType class are listed below. For a complete list of ViewMember.Type.WebCacheViewMemberType class members, see the ViewMember.Type.WebCacheViewMemberType Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMember.Type.WebCacheViewMemberType.
FindFilter | Overloaded. find a Filter by ID, visible in the user context
FindProperty | Overloaded. Find and return a property by int iD
FindQuery | Overloaded. find a Query by ID, visible in the user context
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.Type.WebCacheViewMemberType.
GetRights |
GetType (inherited from Object) | Gets the Type of the current instance.
NewBooleanProperty | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty | Creates a new DateProperty
NewDateTimeProperty | Creates a new DateTimeProperty
NewDoubleProperty | Creates a new DoubleProperty
NewEnumeratedProperty | Create a new Enumerated Property
NewGroupArrayProperty | Creates a property on the server.
NewGroupProperty | Creates a property on the server.
NewIntegerProperty | Creates a new IntegerProperty
NewLongIntegerProperty | Creates a new LongIntegerProperty. The new property is dirty; to save changes, you must call Property.update().
NewMapProperty | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewTextProperty | Creates a new TextProperty
NewTimeSpanProperty | Creates a new TimeSpanProperty
NewUserArrayProperty | Creates a property on the server.
NewUserProperty | Creates a property on the server.
NewWebCacheFilterEventSource (inherited from WebCacheType) |
NewWebCacheQueryEventSource (inherited from WebCacheType) |
SetRights |
ToString | Delegate ToString() to com.starteam.ViewMember.Type.WebCacheViewMemberType.

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.Equals Method

Delegate Equals() to com.starteam.ViewMember.Type.WebCacheViewMemberType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.Type.WebCacheViewMemberType.Equals(obj).

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


FindFilter Method

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.FindFilter Method

find a Filter by ID, visible in the user context

Overload List

find a Filter by ID, visible in the user context

new public virtual WebCacheFilter FindFilter(Int32);

find a Filter by name, visible in the user context

new public virtual WebCacheFilter FindFilter(String);

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.FindFilter Method (Int32)

find a Filter by ID, visible in the user context

new public virtual WebCacheFilter FindFilter(
Int32 filterID
);

Parameters

filterID
the ID

Return Value

a filter with the specified ID or NULL

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace | ViewMember.Type.WebCacheViewMemberType.FindFilter Overload List


ViewMember.Type.WebCacheViewMemberType.FindFilter Method (String)

find a Filter by name, visible in the user context

new public virtual WebCacheFilter FindFilter(
String filterName
);

Parameters

filterName
the name

Return Value

a filter with the specified name or NULL

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace | ViewMember.Type.WebCacheViewMemberType.FindFilter Overload List


FindProperty Method

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.FindProperty Method

Find and return a property by int iD

Overload List

Find and return a property by int iD

new public virtual WebCacheProperty FindProperty(Int32);

Find and return a property by name

new public virtual WebCacheProperty FindProperty(String);

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.FindProperty Method (Int32)

Find and return a property by int iD

new public virtual WebCacheProperty FindProperty(
Int32 propertyID
);

Parameters

propertyID
the integer ID of the property

Return Value

a property with the given ID or NULL

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace | ViewMember.Type.WebCacheViewMemberType.FindProperty Overload List


ViewMember.Type.WebCacheViewMemberType.FindProperty Method (String)

Find and return a property by name

new public virtual WebCacheProperty FindProperty(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

a property with the given name or NULL

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace | ViewMember.Type.WebCacheViewMemberType.FindProperty Overload List


FindQuery Method

Borland StarTeam SDK for .NET

ViewMember.Type.WebCacheViewMemberType.FindQuery Method

find a Query by ID, visible in the user context

Overload List

find a Query by ID, visible in the user context

new public virtual WebCacheQuery FindQuery(Int32);

find a Query by name, visible in the user context

new public virtual WebCacheQuery FindQuery(String);

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.FindQuery Method (Int32)

find a Query by ID, visible in the user context

new public virtual WebCacheQuery FindQuery(
Int32 queryID
);

Parameters

queryID
the ID

Return Value

a query with the specified ID or NULL

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace | ViewMember.Type.WebCacheViewMemberType.FindQuery Overload List


ViewMember.Type.WebCacheViewMemberType.FindQuery Method (String)

find a Query by name, visible in the user context

new public virtual WebCacheQuery FindQuery(
String queryName
);

Parameters

queryName
the name

Return Value

a query with the specified name or NULL

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace | ViewMember.Type.WebCacheViewMemberType.FindQuery Overload List


ViewMember.Type.WebCacheViewMemberType.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.Type.WebCacheViewMemberType.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.Type.WebCacheViewMemberType.GetHashCode().

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.GetRights Method

new public virtual WebCacheACE[] GetRights(
Type.WebCacheType typ
);

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewBooleanProperty Method

Create a new Boolean Property Assigns default display names such that 0=False and 1=True.

public virtual WebCacheBooleanProperty NewBooleanProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new BooleanProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewContentProperty Method

Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().

public virtual WebCacheContentProperty NewContentProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new ContentProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewDateProperty Method

Creates a new DateProperty

public virtual WebCacheDateProperty NewDateProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DateProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewDateTimeProperty Method

Creates a new DateTimeProperty

public virtual WebCacheDateTimeProperty NewDateTimeProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DateTimeProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewDoubleProperty Method

Creates a new DoubleProperty

public virtual WebCacheDoubleProperty NewDoubleProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new DoubleProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewEnumeratedProperty Method

Create a new Enumerated Property

public virtual WebCacheEnumeratedProperty NewEnumeratedProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new EnumeratedProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewGroupArrayProperty Method

Creates a property on the server.

public virtual WebCacheObjectArrayProperty NewGroupArrayProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewGroupProperty Method

Creates a property on the server.

public virtual WebCacheObjectProperty NewGroupProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewIntegerProperty Method

Creates a new IntegerProperty

public virtual WebCacheIntegerProperty NewIntegerProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new IntegerProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewLongIntegerProperty Method

Creates a new LongIntegerProperty. The new property is dirty; to save changes, you must call Property.update().

public virtual WebCacheLongIntegerProperty NewLongIntegerProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new LongIntegerProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewMapProperty Method

Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema

public virtual WebCacheMapProperty NewMapProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new MapProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewTextProperty Method

Creates a new TextProperty

public virtual WebCacheTextProperty NewTextProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new TextProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewTimeSpanProperty Method

Creates a new TimeSpanProperty

public virtual WebCacheTimeSpanProperty NewTimeSpanProperty(
String name
);

Parameters

name
- the name of the property

Return Value

new TimeSpanProperty instance

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewUserArrayProperty Method

Creates a property on the server.

public virtual WebCacheObjectArrayProperty NewUserArrayProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.NewUserProperty Method

Creates a property on the server.

public virtual WebCacheObjectProperty NewUserProperty(
String name
);

Parameters

name
the name of the new property

Return Value

the newly created property

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.SetRights Method

new public virtual void SetRights(
Type.WebCacheType typ,
WebCacheACE[] aces
);

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.Type.WebCacheViewMemberType.ToString Method

Delegate ToString() to com.starteam.ViewMember.Type.WebCacheViewMemberType.

public override string ToString();

Return Value

com.starteam.ViewMember.Type.WebCacheViewMemberType.ToString()

See Also

ViewMember.Type.WebCacheViewMemberType Class | StarTeam Namespace


ViewMember.WebCacheViewMember Class

ViewMember accessor for cached SDK ViewMembers contained objects are obtained from the artifact cache

For a list of all members of this type, see ViewMember.WebCacheViewMember Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
ChangePackage.WebCacheChangePackage
Item.WebCacheItem
Trace.WebCacheTrace

public class ViewMember.WebCacheViewMember : WebCacheVersionedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMember.WebCacheViewMember Members | StarTeam Namespace


ViewMember.WebCacheViewMember Members

ViewMember.WebCacheViewMember overview

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PresentationID | [read] the unique integer identifier for this resource.
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.ViewMember.WebCacheViewMember.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.WebCacheViewMember.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.ViewMember.WebCacheViewMember.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember Properties

The properties of the ViewMember.WebCacheViewMember class are listed below. For a complete list of ViewMember.WebCacheViewMember class members, see the ViewMember.WebCacheViewMember Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
ObjectID | [read] The unique identifier for the underlying object.
PresentationID | [read] the unique integer identifier for this resource.
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Traces | [read] a Trace[] of applicable Traces
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Attachments Property

[read/write] an array of attachments for this ViewMember

public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Comment Property

[read/write] the Comment attached to this view member

public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.DotNotation Property

[read] The dot notation identification of this resource version.

public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ExternalID Property

[read/write] The external ID describing this revision of the item.

public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ExternalURL Property

[read/write] The external URL describing this revision of the item.

public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.History Property

[read] the ViewMemberCollection of historical revisions

public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.IsFloating Property

[read] true if this artifact is floating

public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.IsPinned Property

[read] true if this artifact is pinned

public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Labels Property

[read] an array of labels

public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Links Property

[read] an array of web cache trace objects

public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Locker Property

[read] The User object of the exclusive locker of this item.

public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Name Property

new public virtual String Name {get;}

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.PresentationID Property

[read] the unique integer identifier for this resource.

public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Rights Property

[read/write] the access rights assigned to this filter

public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ShareTree Property

[read] the ShareTree of the view member

public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Traces Property

[read] a Trace[] of applicable Traces

public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.View Property

[read] The WebCacheView containing this WebCacheViewMember.

public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ViewMemberRevisions Property

[read] all the revisions for the view member

public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember Methods

The methods of the ViewMember.WebCacheViewMember class are listed below. For a complete list of ViewMember.WebCacheViewMember class members, see the ViewMember.WebCacheViewMember Members topic.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.ViewMember.WebCacheViewMember.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMember.WebCacheViewMember.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.ViewMember.WebCacheViewMember.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.Equals Method

Delegate Equals() to com.starteam.ViewMember.WebCacheViewMember.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMember.WebCacheViewMember.Equals(obj).

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.GetDisplayValue Method

public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMember.WebCacheViewMember.

public override int GetHashCode();

Return Value

com.starteam.ViewMember.WebCacheViewMember.GetHashCode().

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.GetTracedResources Method

public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | ViewMember.WebCacheViewMember.GetValue Overload List


ViewMember.WebCacheViewMember.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | ViewMember.WebCacheViewMember.GetValue Overload List


ViewMember.WebCacheViewMember.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

public virtual void Lock();

public virtual void Lock(ViewMember.LockType,Boolean);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | WebCacheViewMemberCollection


ViewMember.WebCacheViewMember.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

public virtual void Lock();

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | ViewMember.WebCacheViewMember.Lock Overload List | WebCacheViewMemberCollection


ViewMember.WebCacheViewMember.Lock Method (ViewMember#LockType, Boolean)

public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | ViewMember.WebCacheViewMember.Lock Overload List


ViewMember.WebCacheViewMember.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | NAME


ViewMember.WebCacheViewMember.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | NAME


ViewMember.WebCacheViewMember.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | isFloating | isPinned | unpin


ViewMember.WebCacheViewMember.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | WebCacheViewMemberCollection


ViewMember.WebCacheViewMember.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

ViewMember.WebCacheViewMember.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | ViewMember.WebCacheViewMember.SetValue Overload List


ViewMember.WebCacheViewMember.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | ViewMember.WebCacheViewMember.SetValue Overload List


ViewMember.WebCacheViewMember.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.ToString Method

Delegate ToString() to com.starteam.ViewMember.WebCacheViewMember.

public override string ToString();

Return Value

com.starteam.ViewMember.WebCacheViewMember.ToString()

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMember.WebCacheViewMember.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

public virtual void Unlock();

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | WebCacheViewMemberCollection


ViewMember.WebCacheViewMember.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

public virtual void Unpin();

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | isFloating | isPinned | pinTo


ViewMember.WebCacheViewMember.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace | WebCacheViewMemberCollection


ViewMember.WebCacheViewMember.UpdateRevisionComment Method

Change the revision comment for this view member

public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

ViewMember.WebCacheViewMember Class | StarTeam Namespace


ViewMemberBehavior Class

Represents the behavior of a ViewMember.

For a list of all members of this type, see ViewMemberBehavior Members.

System.Object
ViewMemberBehavior

public class ViewMemberBehavior

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberBehavior Members | StarTeam Namespace


ViewMemberBehavior Members

ViewMemberBehavior overview

Public Instance Constructors

ViewMemberBehavior Constructor Constructs a new ViewMemberBehavior that is a copy of an existing one.

Public Instance Properties

BranchStateValue | [read] The branch state.
Configuration | [read/write] This ViewMemberBehavior's current configuration.
IsBranchOnChange | [read/write] true if this ViewMemberBehavior is set to branch on change; false otherwise.
IsPinned | [read] true if the ViewMember (or its parent ViewMember) has a fixed configuration.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberBehavior.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberBehavior.
GetType (inherited from Object) | Gets the Type of the current instance.
SetFloatingConfiguration | Changes this ViewMemberBehavior to use a floating configuration. Note that in order to apply the resulting behavior to a ViewMember, you must call ViewMember.setBehavior().
ToString | Delegate ToString() to com.starteam.ViewMemberBehavior.

See Also

ViewMemberBehavior Class | StarTeam Namespace


ViewMemberBehavior Constructor

Constructs a new ViewMemberBehavior that is a copy of an existing one.

public ViewMemberBehavior(
ViewMemberBehavior behavior
);

Parameters

behavior
The existing ViewMemberBehavior to be copied.

See Also

ViewMemberBehavior Class | StarTeam Namespace


ViewMemberBehavior Properties

The properties of the ViewMemberBehavior class are listed below. For a complete list of ViewMemberBehavior class members, see the ViewMemberBehavior Members topic.

Public Instance Properties

BranchStateValue | [read] The branch state.
Configuration | [read/write] This ViewMemberBehavior's current configuration.
IsBranchOnChange | [read/write] true if this ViewMemberBehavior is set to branch on change; false otherwise.
IsPinned | [read] true if the ViewMember (or its parent ViewMember) has a fixed configuration.

See Also

ViewMemberBehavior Class | StarTeam Namespace


BranchStateValue Property

Borland StarTeam SDK for .NET

ViewMemberBehavior.BranchStateValue Property

[read] The branch state.

public virtual TypedResource.BranchState BranchStateValue {get;}

Property Value

The branch state.

See Also

ViewMemberBehavior Class | StarTeam Namespace


Configuration Property

Borland StarTeam SDK for .NET

ViewMemberBehavior.Configuration Property

[read/write] This ViewMemberBehavior's current configuration.

public virtual ViewConfiguration Configuration {get; set;}

Property Value

This ViewMemberBehavior's current configuration.

See Also

ViewMemberBehavior Class | StarTeam Namespace


IsBranchOnChange Property

Borland StarTeam SDK for .NET

ViewMemberBehavior.IsBranchOnChange Property

[read/write] true if this ViewMemberBehavior is set to branch on change; false otherwise.

public virtual Boolean IsBranchOnChange {get; set;}

Property Value

true if this ViewMemberBehavior is set to branch on change; false otherwise.

See Also

ViewMemberBehavior Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

ViewMemberBehavior.IsPinned Property

[read] true if the ViewMember (or its parent ViewMember) has a fixed configuration.

public virtual Boolean IsPinned {get;}

Property Value

true if the ViewMember (or its parent ViewMember) has a fixed configuration.

See Also

ViewMemberBehavior Class | StarTeam Namespace


ViewMemberBehavior Methods

The methods of the ViewMemberBehavior class are listed below. For a complete list of ViewMemberBehavior class members, see the ViewMemberBehavior Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberBehavior.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberBehavior.
GetType (inherited from Object) | Gets the Type of the current instance.
SetFloatingConfiguration | Changes this ViewMemberBehavior to use a floating configuration. Note that in order to apply the resulting behavior to a ViewMember, you must call ViewMember.setBehavior().
ToString | Delegate ToString() to com.starteam.ViewMemberBehavior.

See Also

ViewMemberBehavior Class | StarTeam Namespace


ViewMemberBehavior.Equals Method

Delegate Equals() to com.starteam.ViewMemberBehavior.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberBehavior.Equals(obj).

See Also

ViewMemberBehavior Class | StarTeam Namespace


ViewMemberBehavior.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberBehavior.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberBehavior.GetHashCode().

See Also

ViewMemberBehavior Class | StarTeam Namespace


ViewMemberBehavior.SetFloatingConfiguration Method

Changes this ViewMemberBehavior to use a floating configuration. Note that in order to apply the resulting behavior to a ViewMember, you must call ViewMember.setBehavior().

public virtual void SetFloatingConfiguration();

See Also

ViewMemberBehavior Class | StarTeam Namespace | setConfiguration | setBehavior


ViewMemberBehavior.ToString Method

Delegate ToString() to com.starteam.ViewMemberBehavior.

public override string ToString();

Return Value

com.starteam.ViewMemberBehavior.ToString()

See Also

ViewMemberBehavior Class | StarTeam Namespace


ViewMemberCollection Class

A Collection of ViewMembers. The collection can be built up from different types of ViewMembers, or all instances of the same type.

For a list of all members of this type, see ViewMemberCollection Members.

System.Object
StarTeamCollection
ViewMemberCollection
ChangePackageCollection
TraceCollection

public class ViewMemberCollection : StarTeamCollection, Lockable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberCollection Members | StarTeam Namespace


ViewMemberCollection Members

ViewMemberCollection overview

Public Static Methods

SetViewMemberBehavior

Public Instance Constructors

ViewMemberCollection Overloaded. Initializes a new instance of the ViewMemberCollection class.

Public Instance Properties

Cache | [read] CacheService a cache service that can be used to populate, refresh or discard members
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
History | [read] a collection of History collections
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Overloaded. find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetAt | Returns the ViewMember at the given index into the virtual array, or null.
GetEnumerator (inherited from StarTeamCollection) |
GetFromHistory | Overloaded. Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this Label Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewMember | Overloaded. find an element by its primary descriptor (name), using a case insensitive match. Note that the elements in this collection are expected to have unique primary descriptors. If they do not, then the first one found will be returned.
GetViewMemberBehavior | returns the ViewMemberBehavior for a set of ViewMembers
GetViewMembers | return a set of elements by primary descriptor. For example, files with the same name but in different folders
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
LockExclusive | Overloaded. Obtains an exclusive lock on each member of this collection, without attempting to break an existing lock. A server exception will be thrown if any of the locks cannot be obtained.
LockNonExclusive | Obtains a non-exclusive lock on each member of this collection. Other StarTeam users can also acquire a non-exclusive lock on these resources. A server exception will be thrown if any of the locks cannot be obtained.
ModifyBookmark | Modifies this list of member's book mark for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getBookmark() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyReadStatus | Modifies this list of members's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This command is not supported for File items. All Files in the collection will be ignored
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Reverse | returns a collection whose elements are in the reverse order of this one i.e. the order of elements of a call to toArray() on the returned collection will be in reverse order w.r.t. the order of elements of a call to toArray on this collection
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ShareTo | Share the items from this collection to the target view this should be a different view from the view that the items belong to. All the shares will be committed in a single transaction
Sort | Overloaded. returns an array of ViewMembers whose elements are sorted using the provided comparer. Note that the caller should ensure that the properties used for comparison are pre-populated before calling this api, to avoid the overhead of single round trip queries per view member during the compare itself.
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.
Unlock | Removes the current user's lock from each member of this collection. If another user has an exclusive lock on one of the members, that lock will not be removed.

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection Constructor

Construct an empty ViewMemberCollection

Overload List

Construct an empty ViewMemberCollection

public ViewMemberCollection();

Construct a ViewMemberCollection with one contained ViewMember

public ViewMemberCollection(ViewMember);

Construct a ViewMemberCollection from an array of ViewMember

public ViewMemberCollection(ViewMember[]);

Construct a ViewMemberCollection from an array of ViewMember

public ViewMemberCollection(ViewMemberCollection);

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection Constructor ()

Construct an empty ViewMemberCollection

public ViewMemberCollection();

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection Constructor Overload List


ViewMemberCollection Constructor (ViewMember)

Construct a ViewMemberCollection with one contained ViewMember

public ViewMemberCollection(
ViewMember viewMember
);

Parameters

viewMember
the view member to add to the collection

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection Constructor Overload List


ViewMemberCollection Constructor (ViewMember[])

Construct a ViewMemberCollection from an array of ViewMember

public ViewMemberCollection(
ViewMember[] viewMembers
);

Parameters

viewMembers
the objects to add to the collection

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection Constructor Overload List


ViewMemberCollection Constructor (ViewMemberCollection)

Construct a ViewMemberCollection from an array of ViewMember

public ViewMemberCollection(
ViewMemberCollection viewMembers
);

Parameters

viewMembers
the objects to add to the collection

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection Constructor Overload List


ViewMemberCollection Properties

The properties of the ViewMemberCollection class are listed below. For a complete list of ViewMemberCollection class members, see the ViewMemberCollection Members topic.

Public Instance Properties

Cache | [read] CacheService a cache service that can be used to populate, refresh or discard members
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
History | [read] a collection of History collections
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

See Also

ViewMemberCollection Class | StarTeam Namespace


Cache Property

Borland StarTeam SDK for .NET

ViewMemberCollection.Cache Property

[read] CacheService a cache service that can be used to populate, refresh or discard members

public virtual CacheService Cache {get;}

Property Value

CacheService a cache service that can be used to populate, refresh or discard members

See Also

ViewMemberCollection Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

ViewMemberCollection.History Property

[read] a collection of History collections

public virtual ViewMemberCollection.HistoryContainer History {get;}

Property Value

a collection of History collections

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection Methods

The methods of the ViewMemberCollection class are listed below. For a complete list of ViewMemberCollection class members, see the ViewMemberCollection Members topic.

Public Static Methods

SetViewMemberBehavior

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Find | Overloaded. find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetAt | Returns the ViewMember at the given index into the virtual array, or null.
GetEnumerator (inherited from StarTeamCollection) |
GetFromHistory | Overloaded. Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this Label Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewMember | Overloaded. find an element by its primary descriptor (name), using a case insensitive match. Note that the elements in this collection are expected to have unique primary descriptors. If they do not, then the first one found will be returned.
GetViewMemberBehavior | returns the ViewMemberBehavior for a set of ViewMembers
GetViewMembers | return a set of elements by primary descriptor. For example, files with the same name but in different folders
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
LockExclusive | Overloaded. Obtains an exclusive lock on each member of this collection, without attempting to break an existing lock. A server exception will be thrown if any of the locks cannot be obtained.
LockNonExclusive | Obtains a non-exclusive lock on each member of this collection. Other StarTeam users can also acquire a non-exclusive lock on these resources. A server exception will be thrown if any of the locks cannot be obtained.
ModifyBookmark | Modifies this list of member's book mark for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getBookmark() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.
ModifyReadStatus | Modifies this list of members's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This command is not supported for File items. All Files in the collection will be ignored
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Reverse | returns a collection whose elements are in the reverse order of this one i.e. the order of elements of a call to toArray() on the returned collection will be in reverse order w.r.t. the order of elements of a call to toArray on this collection
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ShareTo | Share the items from this collection to the target view this should be a different view from the view that the items belong to. All the shares will be committed in a single transaction
Sort | Overloaded. returns an array of ViewMembers whose elements are sorted using the provided comparer. Note that the caller should ensure that the properties used for comparison are pre-populated before calling this api, to avoid the overhead of single round trip queries per view member during the compare itself.
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.
Unlock | Removes the current user's lock from each member of this collection. If another user has an exclusive lock on one of the members, that lock will not be removed.

See Also

ViewMemberCollection Class | StarTeam Namespace


Find Method

Borland StarTeam SDK for .NET

ViewMemberCollection.Find Method

find an element by its ID

Overload List

find an element by its ID

public virtual ViewMember Find(Int32);

find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned. This overload of {@link #find(String, boolean)} uses the Platform case sensitivity rules

public virtual ViewMember Find(String);

find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned.

public virtual ViewMember Find(String,Boolean);

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.Find Method (Int32)

find an element by its ID

public virtual ViewMember Find(
Int32 ID
);

Parameters

ID
the ID

Return Value

the element

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.Find Overload List


ViewMemberCollection.Find Method (String)

find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned. This overload of {@link #find(String, boolean)} uses the Platform case sensitivity rules

public virtual ViewMember Find(
String name
);

Parameters

name
the primary descriptor

Return Value

the element, if found

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.Find Overload List | find


ViewMemberCollection.Find Method (String, Boolean)

find an element by its primary descriptor. Note that the elements in this collection are expected to have unique primary descriptors If they do not, then the first one found will be returned.

public virtual ViewMember Find(
String name,
Boolean ignoreCase
);

Parameters

name
the primary descriptor
ignoreCase
true if case insensitive

Return Value

the element

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.Find Overload List | find


ViewMemberCollection.GetAt Method

Returns the ViewMember at the given index into the virtual array, or null.

public virtual ViewMember GetAt(
Int32 index
);

Parameters

index
The index into the virtual array of the desired ViewMember.

Return Value

The ViewMember at the given index into the virtual array, or null.

See Also

ViewMemberCollection Class | StarTeam Namespace


GetFromHistory Method

Borland StarTeam SDK for .NET

ViewMemberCollection.GetFromHistory Method

Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this Label Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label

Overload List

Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this Label Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label

public virtual ViewMemberCollection GetFromHistory(Label);

Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this PromotionState Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label attached to the PromotionState

public virtual ViewMemberCollection GetFromHistory(PromotionState);

Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which specofoed. Note that the returned set may be smaller than the set in this collection since some of these items may not have been present in the view at the time

public virtual ViewMemberCollection GetFromHistory(DateTime);

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.GetFromHistory Method (Label)

Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this Label Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label

public virtual ViewMemberCollection GetFromHistory(
Label lbl
);

Parameters

lbl
the Label to base the historical revisions on

Return Value

an equivalent set of historical revisions of ViewMembers

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.GetFromHistory Overload List


ViewMemberCollection.GetFromHistory Method (PromotionState)

Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which they are attached to this PromotionState Note that the returned set may be smaller than the set in this collection since some of these items may not have been attached to the label attached to the PromotionState

public virtual ViewMemberCollection GetFromHistory(
PromotionState ps
);

Parameters

ps
the PromotionState to base the historical revisions on

Return Value

an equivalent set of historical revisions of ViewMembers

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.GetFromHistory Overload List


ViewMemberCollection.GetFromHistory Method (DateTime)

Returns an equivalent set of historical revisions of the ViewMembers from this collection, at the versions at which specofoed. Note that the returned set may be smaller than the set in this collection since some of these items may not have been present in the view at the time

public virtual ViewMemberCollection GetFromHistory(
DateTime dt
);

Parameters

dt
the DateTime to base the historical revisions on

Return Value

an equivalent set of historical revisions of ViewMembers Note that this query is not view specific. So it is possible to retrieve a newer revision than the specified one, depending upon the value of the DateTime parameter

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.GetFromHistory Overload List


GetViewMember Method

Borland StarTeam SDK for .NET

ViewMemberCollection.GetViewMember Method

return an element by ID

Overload List

return an element by ID

public virtual ViewMember GetViewMember(Int32);

find an element by its primary descriptor (name), using a case insensitive match. Note that the elements in this collection are expected to have unique primary descriptors. If they do not, then the first one found will be returned.

public virtual ViewMember GetViewMember(String);

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.GetViewMember Method (Int32)

return an element by ID

public virtual ViewMember GetViewMember(
Int32 ID
);

Parameters

ID
the ID

Return Value

the element

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.GetViewMember Overload List


ViewMemberCollection.GetViewMember Method (String)

find an element by its primary descriptor (name), using a case insensitive match. Note that the elements in this collection are expected to have unique primary descriptors. If they do not, then the first one found will be returned.

public virtual ViewMember GetViewMember(
String name
);

Parameters

name
the name descriptor

Return Value

the element

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.GetViewMember Overload List | find


ViewMemberCollection.GetViewMemberBehavior Method

returns the ViewMemberBehavior for a set of ViewMembers

public virtual BehaviorContainer GetViewMemberBehavior();

Return Value

the ViewMemberBehavior for a set of ViewMembers

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.GetViewMembers Method

return a set of elements by primary descriptor. For example, files with the same name but in different folders

public virtual ViewMember[] GetViewMembers(
String name,
Boolean ignoreCase
);

Parameters

name
the primary descriptor
ignoreCase
true if case insensitive

Return Value

the set of element(s)

See Also

ViewMemberCollection Class | StarTeam Namespace | find


LockExclusive Method

Borland StarTeam SDK for .NET

ViewMemberCollection.LockExclusive Method

Obtains an exclusive lock on each member of this collection, without attempting to break an existing lock. A server exception will be thrown if any of the locks cannot be obtained.

Overload List

Obtains an exclusive lock on each member of this collection, without attempting to break an existing lock. A server exception will be thrown if any of the locks cannot be obtained.

public virtual void LockExclusive();

Obtains an exclusive lock on each member of this collection If breakLock is true, and other users have some of these resources locked, then an attempt will be made to break those locks. A server exception will be thrown if any of the locks cannot be obtained.

public virtual void LockExclusive(Boolean);

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.LockExclusive Method ()

Obtains an exclusive lock on each member of this collection, without attempting to break an existing lock. A server exception will be thrown if any of the locks cannot be obtained.

public virtual void LockExclusive();

Implements

Lockable.LockExclusive

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.LockExclusive Overload List


ViewMemberCollection.LockExclusive Method (Boolean)

Obtains an exclusive lock on each member of this collection If breakLock is true, and other users have some of these resources locked, then an attempt will be made to break those locks. A server exception will be thrown if any of the locks cannot be obtained.

public virtual void LockExclusive(
Boolean breakLock
);

Parameters

breakLock
true to break existing exclusive locks owned by other users

Implements

Lockable.LockExclusive

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.LockExclusive Overload List


ViewMemberCollection.LockNonExclusive Method

Obtains a non-exclusive lock on each member of this collection. Other StarTeam users can also acquire a non-exclusive lock on these resources. A server exception will be thrown if any of the locks cannot be obtained.

public virtual void LockNonExclusive();

Implements

Lockable.LockNonExclusive

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.ModifyBookmark Method

Modifies this list of member's book mark for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getBookmark() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item.

public virtual void ModifyBookmark(
Boolean setFlagged
);

Parameters

setFlagged
this items new book mark

See Also

ViewMemberCollection Class | StarTeam Namespace | isBookmarked


ViewMemberCollection.ModifyReadStatus Method

Modifies this list of members's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getReadStatus() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This command is not supported for File items. All Files in the collection will be ignored

public virtual void ModifyReadStatus(
Boolean markAsRead
);

Parameters

markAsRead
the new read status for the members of this collection

See Also

ViewMemberCollection Class | StarTeam Namespace | isUnread


ViewMemberCollection.Reverse Method

returns a collection whose elements are in the reverse order of this one i.e. the order of elements of a call to toArray() on the returned collection will be in reverse order w.r.t. the order of elements of a call to toArray on this collection

public virtual ViewMemberCollection Reverse();

Return Value

a collection whose elements are in the reverse order of this one

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.SetViewMemberBehavior Method

public static void SetViewMemberBehavior(
ViewMemberCollection.BehaviorContainer cntnr
);

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.ShareTo Method

Share the items from this collection to the target view this should be a different view from the view that the items belong to. All the shares will be committed in a single transaction

public virtual void ShareTo(
View vw
);

Parameters

vw
the target view to share these items to

See Also

ViewMemberCollection Class | StarTeam Namespace


Sort Method

Borland StarTeam SDK for .NET

ViewMemberCollection.Sort Method

sort the collection by VMID

Overload List

sort the collection by VMID

public virtual ViewMember[] Sort();

sort the collection by name

public virtual ViewMember[] Sort(Boolean);

returns an array of ViewMembers whose elements are sorted using the provided comparer. Note that the caller should ensure that the properties used for comparison are pre-populated before calling this api, to avoid the overhead of single round trip queries per view member during the compare itself.

public virtual ViewMember[] Sort(IComparer);

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.Sort Method ()

sort the collection by VMID

public virtual ViewMember[] Sort();

Return Value

a collection sorted by VMID

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.Sort Overload List


ViewMemberCollection.Sort Method (Boolean)

sort the collection by name

public virtual ViewMember[] Sort(
Boolean ignoreCase
);

Parameters

ignoreCase
true if case insensitive sort is desired

Return Value

a collection sorted by name

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.Sort Overload List


ViewMemberCollection.Sort Method (IComparer)

returns an array of ViewMembers whose elements are sorted using the provided comparer. Note that the caller should ensure that the properties used for comparison are pre-populated before calling this api, to avoid the overhead of single round trip queries per view member during the compare itself.

public virtual ViewMember[] Sort(
IComparer sc
);

Parameters

sc
a comparer used for the sort

Return Value

an array of ViewMembers whose elements are sorted using the provided comparer

See Also

ViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.Sort Overload List


ViewMemberCollection.Unlock Method

Removes the current user's lock from each member of this collection. If another user has an exclusive lock on one of the members, that lock will not be removed.

public virtual void Unlock();

Implements

Lockable.Unlock

See Also

ViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.BehaviorContainer Class

A BehaviorContainer can be used to query for ViewMemberBehavior on the underlying collection of ViewMembers. It may also be used to assign Behaviors to a set of ViewMembers. The ViewMembers are queried, retrieved and assigned in bulk. The level of indirection is a requirement of the SDK's contractual obligation, namely, to expose only primitives, native SDK objects, and arrays of objects.

For a list of all members of this type, see ViewMemberCollection.BehaviorContainer Members.

System.Object
ViewMemberCollection.BehaviorContainer

public class ViewMemberCollection.BehaviorContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberCollection.BehaviorContainer Members | StarTeam Namespace


ViewMemberCollection.BehaviorContainer Members

ViewMemberCollection.BehaviorContainer overview

Public Instance Constructors

ViewMemberCollection.BehaviorContainer Constructor create a new BehaviorContainer to assign behavior to view members in bulk

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberCollection.BehaviorContainer.
GetBehavior | Return the ViewMemberBehavior of this view member Note that this ViewMember should be a member of the underlying collection from which this object is derived, for this call to succeed
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberCollection.BehaviorContainer.
GetType (inherited from Object) | Gets the Type of the current instance.
SetBehavior | Sets the new behavior for this view member Note that this call stores the unassigned objects in memory. It will not issue a server command After assigning each new behavior to its view member, call setViewMemberBehavior on the collection to issue the bulk command
ToString | Delegate ToString() to com.starteam.ViewMemberCollection.BehaviorContainer.

See Also

ViewMemberCollection.BehaviorContainer Class | StarTeam Namespace


ViewMemberCollection.BehaviorContainer Constructor

create a new BehaviorContainer to assign behavior to view members in bulk

public ViewMemberCollection.BehaviorContainer();

See Also

ViewMemberCollection.BehaviorContainer Class | StarTeam Namespace


ViewMemberCollection.BehaviorContainer Methods

The methods of the ViewMemberCollection.BehaviorContainer class are listed below. For a complete list of ViewMemberCollection.BehaviorContainer class members, see the ViewMemberCollection.BehaviorContainer Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberCollection.BehaviorContainer.
GetBehavior | Return the ViewMemberBehavior of this view member Note that this ViewMember should be a member of the underlying collection from which this object is derived, for this call to succeed
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberCollection.BehaviorContainer.
GetType (inherited from Object) | Gets the Type of the current instance.
SetBehavior | Sets the new behavior for this view member Note that this call stores the unassigned objects in memory. It will not issue a server command After assigning each new behavior to its view member, call setViewMemberBehavior on the collection to issue the bulk command
ToString | Delegate ToString() to com.starteam.ViewMemberCollection.BehaviorContainer.

See Also

ViewMemberCollection.BehaviorContainer Class | StarTeam Namespace


ViewMemberCollection.BehaviorContainer.Equals Method

Delegate Equals() to com.starteam.ViewMemberCollection.BehaviorContainer.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberCollection.BehaviorContainer.Equals(obj).

See Also

ViewMemberCollection.BehaviorContainer Class | StarTeam Namespace


ViewMemberCollection.BehaviorContainer.GetBehavior Method

Return the ViewMemberBehavior of this view member Note that this ViewMember should be a member of the underlying collection from which this object is derived, for this call to succeed

public virtual ViewMemberBehavior GetBehavior(
ViewMember vm
);

Parameters

vm
the ViewMember whose behavior is required

Return Value

the ViewMemberBehavior

See Also

ViewMemberCollection.BehaviorContainer Class | StarTeam Namespace


ViewMemberCollection.BehaviorContainer.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberCollection.BehaviorContainer.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberCollection.BehaviorContainer.GetHashCode().

See Also

ViewMemberCollection.BehaviorContainer Class | StarTeam Namespace


ViewMemberCollection.BehaviorContainer.SetBehavior Method

Sets the new behavior for this view member Note that this call stores the unassigned objects in memory. It will not issue a server command After assigning each new behavior to its view member, call setViewMemberBehavior on the collection to issue the bulk command

public virtual void SetBehavior(
ViewMember vm,
ViewMemberBehavior vmb
);

Parameters

vm
the view member
vmb
the new behavior to be associated with this view member

See Also

ViewMemberCollection.BehaviorContainer Class | StarTeam Namespace | setViewMemberBehavior


ViewMemberCollection.BehaviorContainer.ToString Method

Delegate ToString() to com.starteam.ViewMemberCollection.BehaviorContainer.

public override string ToString();

Return Value

com.starteam.ViewMemberCollection.BehaviorContainer.ToString()

See Also

ViewMemberCollection.BehaviorContainer Class | StarTeam Namespace


ViewMemberCollection.HistoryContainer Class

a query for History on the underlying collection of ViewMembers returns a collection of ViewMemberCollections. The collection of historical revisions for any individual ViewMember is accessed by member through this History object. The level of indirection is a requirement of the SDK's contractual obligation, namely, to expose only Java primitives, native SDK objects, and arrays of objects. Note also that a query for history on a server that does not support bulk queries will succeed, but at the cost of several non-bulk queries

For a list of all members of this type, see ViewMemberCollection.HistoryContainer Members.

System.Object
ViewMemberCollection.HistoryContainer

public class ViewMemberCollection.HistoryContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberCollection.HistoryContainer Members | StarTeam Namespace


ViewMemberCollection.HistoryContainer Members

ViewMemberCollection.HistoryContainer overview

Public Instance Properties

ViewMembers [read] the set of view members in this container

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberCollection.HistoryContainer.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberCollection.HistoryContainer.
GetHistory | Return the ViewMemberCollection of all historical revisions
GetType (inherited from Object) | Gets the Type of the current instance.
Populate | Fully populate all the properties of the history container Depending upon the number of items and their historical revisions, this may be an expensive operation.
ToString | Delegate ToString() to com.starteam.ViewMemberCollection.HistoryContainer.

See Also

ViewMemberCollection.HistoryContainer Class | StarTeam Namespace


ViewMemberCollection.HistoryContainer Properties

The properties of the ViewMemberCollection.HistoryContainer class are listed below. For a complete list of ViewMemberCollection.HistoryContainer class members, see the ViewMemberCollection.HistoryContainer Members topic.

Public Instance Properties

ViewMembers [read] the set of view members in this container

See Also

ViewMemberCollection.HistoryContainer Class | StarTeam Namespace


ViewMembers Property

Borland StarTeam SDK for .NET

ViewMemberCollection.HistoryContainer.ViewMembers Property

[read] the set of view members in this container

public virtual ViewMember[] ViewMembers {get;}

Property Value

the set of view members in this container

See Also

ViewMemberCollection.HistoryContainer Class | StarTeam Namespace


ViewMemberCollection.HistoryContainer Methods

The methods of the ViewMemberCollection.HistoryContainer class are listed below. For a complete list of ViewMemberCollection.HistoryContainer class members, see the ViewMemberCollection.HistoryContainer Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberCollection.HistoryContainer.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberCollection.HistoryContainer.
GetHistory | Return the ViewMemberCollection of all historical revisions
GetType (inherited from Object) | Gets the Type of the current instance.
Populate | Fully populate all the properties of the history container Depending upon the number of items and their historical revisions, this may be an expensive operation.
ToString | Delegate ToString() to com.starteam.ViewMemberCollection.HistoryContainer.

See Also

ViewMemberCollection.HistoryContainer Class | StarTeam Namespace


ViewMemberCollection.HistoryContainer.Equals Method

Delegate Equals() to com.starteam.ViewMemberCollection.HistoryContainer.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberCollection.HistoryContainer.Equals(obj).

See Also

ViewMemberCollection.HistoryContainer Class | StarTeam Namespace


ViewMemberCollection.HistoryContainer.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberCollection.HistoryContainer.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberCollection.HistoryContainer.GetHashCode().

See Also

ViewMemberCollection.HistoryContainer Class | StarTeam Namespace


ViewMemberCollection.HistoryContainer.GetHistory Method

Return the ViewMemberCollection of all historical revisions

public virtual ViewMemberCollection GetHistory(
ViewMember vmb
);

Parameters

vmb
the ViewMember whose history is required Note that this ViewMember should be a member of the underlying collection from which this object is derived

Return Value

the ViewMemberCollection of all historical revisions

See Also

ViewMemberCollection.HistoryContainer Class | StarTeam Namespace


ViewMemberCollection.HistoryContainer.Populate Method

Fully populate all the properties of the history container Depending upon the number of items and their historical revisions, this may be an expensive operation.

public virtual void Populate();

See Also

ViewMemberCollection.HistoryContainer Class | StarTeam Namespace


ViewMemberCollection.HistoryContainer.ToString Method

Delegate ToString() to com.starteam.ViewMemberCollection.HistoryContainer.

public override string ToString();

Return Value

com.starteam.ViewMemberCollection.HistoryContainer.ToString()

See Also

ViewMemberCollection.HistoryContainer Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection Class

A collection to perform transacted operations on web cache view members. Add web cache view members in various states for creation, update, removal, etc in the repository. Call save to actually perform the operations in explicit (or implicit) transactions, as the case may be. Note that the same viewmember should not be added to the collection through multiple api's or through the same api twice. for example, calling {@link #move(com.starteam.Item.WebCacheItem, com.starteam.Folder.WebCacheFolder)} and {@link #update(WebCacheViewMember)} on the same viewmember will throw an exception. by default, a viewmember is updated as part of a move.

For a list of all members of this type, see ViewMemberCollection.WebCacheViewMemberCollection Members.

System.Object
ViewMemberCollection.WebCacheViewMemberCollection

public class ViewMemberCollection.WebCacheViewMemberCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberCollection.WebCacheViewMemberCollection Members | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection Members

ViewMemberCollection.WebCacheViewMemberCollection overview

Public Static Methods

GetHistory

Public Instance Constructors

ViewMemberCollection.WebCacheViewMemberCollection Constructor

Public Instance Properties

ViewMembers [read] the unique set of un-committed view members in this collection

Public Instance Methods

Create |
Equals | Delegate Equals() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.
Find | return the ViewMember with this id or NULL The Viewmember will have had to have been placed in this collection for it to be found subsequently
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
Lock |
Move | Overloaded.
Remove |
Save | Save the entire set of underlying web cache view members in the collection to the repository All operations are performed in a transaction, i.e. either everything succeeds or everything fails. If the transaction fails, a server exception is thrown back to the caller The sequence of operations is first acquire locks in bulk (implicit transaction), if any then perform all operations in a transaction (explicit transaction) finally release locks in bulk (implicit transaction), if any
Size | return the size of this collection
ToString | Delegate ToString() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.
Unlock |
Update |

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection Constructor

public ViewMemberCollection.WebCacheViewMemberCollection(
ArtifactCacheManager.Context c
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection Properties

The properties of the ViewMemberCollection.WebCacheViewMemberCollection class are listed below. For a complete list of ViewMemberCollection.WebCacheViewMemberCollection class members, see the ViewMemberCollection.WebCacheViewMemberCollection Members topic.

Public Instance Properties

ViewMembers [read] the unique set of un-committed view members in this collection

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMembers Property

Borland StarTeam SDK for .NET

ViewMemberCollection.WebCacheViewMemberCollection.ViewMembers Property

[read] the unique set of un-committed view members in this collection

public virtual WebCacheViewMember[] ViewMembers {get;}

Property Value

the unique set of un-committed view members in this collection

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection Methods

The methods of the ViewMemberCollection.WebCacheViewMemberCollection class are listed below. For a complete list of ViewMemberCollection.WebCacheViewMemberCollection class members, see the ViewMemberCollection.WebCacheViewMemberCollection Members topic.

Public Static Methods

GetHistory

Public Instance Methods

Create |
Equals | Delegate Equals() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.
Find | return the ViewMember with this id or NULL The Viewmember will have had to have been placed in this collection for it to be found subsequently
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
Lock |
Move | Overloaded.
Remove |
Save | Save the entire set of underlying web cache view members in the collection to the repository All operations are performed in a transaction, i.e. either everything succeeds or everything fails. If the transaction fails, a server exception is thrown back to the caller The sequence of operations is first acquire locks in bulk (implicit transaction), if any then perform all operations in a transaction (explicit transaction) finally release locks in bulk (implicit transaction), if any
Size | return the size of this collection
ToString | Delegate ToString() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.
Unlock |
Update |

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.Create Method

public virtual WebCacheViewMemberCollection Create(
ViewMember.WebCacheViewMember vm
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.Equals Method

Delegate Equals() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.Equals(obj).

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.Find Method

return the ViewMember with this id or NULL The Viewmember will have had to have been placed in this collection for it to be found subsequently

public virtual WebCacheViewMember Find(
Int32 vmid
);

Parameters

vmid
the id

Return Value

the ViewMember with this id or NULL

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.GetHashCode().

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.GetHistory Method

public static WebCacheHistoryContainer GetHistory(
ArtifactCacheManager.Context c,
WebCacheViewMember[] vms
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.Lock Method

public virtual WebCacheViewMemberCollection Lock(
ViewMember.WebCacheViewMember vm
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


Move Method

Borland StarTeam SDK for .NET

ViewMemberCollection.WebCacheViewMemberCollection.Move Method

Overload List

public virtual WebCacheViewMemberCollection Move(Item.WebCacheItem,Folder.WebCacheFolder);

public virtual WebCacheViewMemberCollection Move(Item.WebCacheItem,View.WebCacheView);

public virtual WebCacheViewMemberCollection Move(TreeItem.WebCacheTreeItem,TreeItem.WebCacheTreeItem);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.Move Method (Item#WebCacheItem, Folder#WebCacheFolder)

public virtual WebCacheViewMemberCollection Move(
Item.WebCacheItem itm,
Folder.WebCacheFolder destination
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.WebCacheViewMemberCollection.Move Overload List


ViewMemberCollection.WebCacheViewMemberCollection.Move Method (Item#WebCacheItem, View#WebCacheView)

public virtual WebCacheViewMemberCollection Move(
Item.WebCacheItem itm,
View.WebCacheView destination
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.WebCacheViewMemberCollection.Move Overload List


ViewMemberCollection.WebCacheViewMemberCollection.Move Method (TreeItem#WebCacheTreeItem, TreeItem#WebCacheTreeItem)

public virtual WebCacheViewMemberCollection Move(
TreeItem.WebCacheTreeItem itm,
TreeItem.WebCacheTreeItem destination
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace | ViewMemberCollection.WebCacheViewMemberCollection.Move Overload List


ViewMemberCollection.WebCacheViewMemberCollection.Remove Method

public virtual WebCacheViewMemberCollection Remove(
ViewMember.WebCacheViewMember vm
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.Save Method

Save the entire set of underlying web cache view members in the collection to the repository All operations are performed in a transaction, i.e. either everything succeeds or everything fails. If the transaction fails, a server exception is thrown back to the caller The sequence of operations is first acquire locks in bulk (implicit transaction), if any then perform all operations in a transaction (explicit transaction) finally release locks in bulk (implicit transaction), if any

public virtual WebCacheViewMember[] Save();

Return Value

on success, an array of saved WebCacheViewMembers, representing objects from the ArtifactCache

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.Size Method

return the size of this collection

public virtual int Size();

Return Value

the size of this collection

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.ToString Method

Delegate ToString() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.

public override string ToString();

Return Value

com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.ToString()

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.Unlock Method

public virtual WebCacheViewMemberCollection Unlock(
ViewMember.WebCacheViewMember vm
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.Update Method

public virtual WebCacheViewMemberCollection Update(
ViewMember.WebCacheViewMember vm
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Class

a query for History on an array of WebCacheViewMembers returns a collection of WebCacheViewMember[]'s. The collection of historical revisions for any individual WebCacheViewMember is accessed by member through this HistoryContainer object. The level of indirection is a requirement of the SDK's contractual obligation, namely, to expose only Java primitives, native SDK objects, and arrays of objects. Note also that a query for history on a server that does not support bulk queries will succeed, but at the cost of several non-bulk queries

For a list of all members of this type, see ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Members.

System.Object
ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer

public class ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Members | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Members

ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer overview

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.
GetHistory |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.

See Also

ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Methods

The methods of the ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer class are listed below. For a complete list of ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer class members, see the ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.
GetHistory |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.

See Also

ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.Equals Method

Delegate Equals() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.Equals(obj).

See Also

ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.GetHashCode().

See Also

ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.GetHistory Method

public virtual WebCacheViewMember[] GetHistory(
ViewMember.WebCacheViewMember vmb
);

See Also

ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Class | StarTeam Namespace


ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.ToString Method

Delegate ToString() to com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.

public override string ToString();

Return Value

com.starteam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer.ToString()

See Also

ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer Class | StarTeam Namespace


ViewMemberListManager Class

Generates and manages a list of ViewMembers. All ViewMembers in the list have a given type. Items are generated from a list of folders determined by a FolderListManager, (non item) ViewMembers are generated from the view The ViewMember list can be filtered, sorted, refreshed, queried, and so on. ViewMembers are retrieved via getViewMembers(), which is optimized to do as little work as possible. For example, if only the sort order has changed since the last time the ViewMember list was retrieved, then the existing ViewMembers in the list are simply resorted.

For a list of all members of this type, see ViewMemberListManager Members.

System.Object
ViewMemberListManager

public class ViewMemberListManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberListManager Members | StarTeam Namespace


ViewMemberListManager Members

ViewMemberListManager overview

Public Instance Constructors

ViewMemberListManager Overloaded. Initializes a new instance of the ViewMemberListManager class.

Public Instance Properties

AllCachedProperties | [read] The list of properties that will be pre-fetched and cached for members of this viewMember list.
CachedPropertiesForFilter | [read] The list of properties that will be pre-fetched and cached for members of this viewMember list based on Filter criteria.
ExtraCachedProperties | [read/write] The list of "extra" properties that will be pre-fetched and cached for members of this viewMember list.
Filter | [read/write] The filter to be applied to the viewMember list.
FolderListManager | [read] The FolderListManager that determines which folders will be used to generate viewMembers in the item list.
FullDisplay | [read] the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.
IsGrouped | [read] true if this ViewMemberListManager has grouping criteria applied.
IsRefreshRequired | [read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.
Type | [read] The type of viewMember included in the viewMember list.
UserVisibleFoldersOnly | [read/write] true if only ViewMembers in user-visible Folders are included, otherwise false.
View | [read] the view from which the ViewMembers will be culled
ViewMemberGroups | [read] an array of GroupNodes that describes the group membership of all ViewMembers managed by the ViewMemberListManager. May return an empty array.
ViewMembers | [read] The collection of viewMemebrs in the viewMember list, updated, if necessary, to reflect any changes that have been made (in the folder list, filter, sort order, and so on) since the last time the viewMember list was retrieved.
VisibleLines | [read] the number of visible lines in the list, given the current collapsed/expanded state of its nodes.

Public Instance Methods

Close | Close this ViewMemberListManager, release all its resources, and sever its ties to its parent FolderListManager it will automatically be re-opened when needed.
Discard | Discards all relevant cached data. It will be re-fetched from the server the next time the viewMember list is retrieved (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ViewMemberListManager.
FindViewMember | Searches for a given viewMember in the viewMember list.
GetGroupNodeAtLine | Returns the GroupNode at line, given the list's current collapsed/expanded state, or null if that line doesn't contain a GroupNode.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberListManager.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewMemberAtLine | Returns the ViewMember at line, given the list's current collapsed/expanded state, or null if that line doesn't contain an ViewMember.
GetViewMemberID | Returns the VMID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.
GetViewMembers | Returns a collection containing the viewMembers in a Folder and optionally all its descendants.
GroupViewMembers | Determines whether this ViewMemberListManager should group viewMembers when returning them? ViewMembers can only be grouped if sortViewMembers is also set to True ViewMembers will be grouped if the ViewMemberListManager is attached to a Filter that specifies Group Sorting Information A ViewMemberListManager is grouped by default
IsGroupNodeAtLine | Returns true if the object at line is a GroupNode or false if it's an ViewMember, given the list's current collapsed/expanded state.
NewItemEventSource |
NewItemIDEventSource |
NewItemListEventSource |
NewItemUpdateEventSource |
NewNotificationEventSource |
NewViewMemberEventSource |
NewViewMemberUpdateEventSource |
Refresh | Updates the list of viewMembers to reflect recent changes made on the server. Existing ViewMember objects are modified in place whenever possible. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
SelectBy | Overloaded. Gets the subset of viewMembers in the viewMember list to which the given label has been applied.
SortViewMembers | Determines whether this ViewMemberListManager should sort viewMembers when returning them? ViewMembers will be sorted if the ViewMemberListManager is attached to a Filter that specifies Group Sorting Information A ViewMemberListManager is sorted by default
ToString | Delegate ToString() to com.starteam.ViewMemberListManager.

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager Constructor

Overload List

public ViewMemberListManager(Item.Type,FolderListManager);

public ViewMemberListManager(ViewMember.Type,View);

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager Constructor (ViewMember#Type, View)

public ViewMemberListManager(
ViewMember.Type type,
View view
);

See Also

ViewMemberListManager Class | StarTeam Namespace | ViewMemberListManager Constructor Overload List


ViewMemberListManager Constructor (Item#Type, FolderListManager)

public ViewMemberListManager(
Item.Type type,
FolderListManager folders
);

See Also

ViewMemberListManager Class | StarTeam Namespace | ViewMemberListManager Constructor Overload List


ViewMemberListManager Properties

The properties of the ViewMemberListManager class are listed below. For a complete list of ViewMemberListManager class members, see the ViewMemberListManager Members topic.

Public Instance Properties

AllCachedProperties | [read] The list of properties that will be pre-fetched and cached for members of this viewMember list.
CachedPropertiesForFilter | [read] The list of properties that will be pre-fetched and cached for members of this viewMember list based on Filter criteria.
ExtraCachedProperties | [read/write] The list of "extra" properties that will be pre-fetched and cached for members of this viewMember list.
Filter | [read/write] The filter to be applied to the viewMember list.
FolderListManager | [read] The FolderListManager that determines which folders will be used to generate viewMembers in the item list.
FullDisplay | [read] the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.
IsGrouped | [read] true if this ViewMemberListManager has grouping criteria applied.
IsRefreshRequired | [read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.
Type | [read] The type of viewMember included in the viewMember list.
UserVisibleFoldersOnly | [read/write] true if only ViewMembers in user-visible Folders are included, otherwise false.
View | [read] the view from which the ViewMembers will be culled
ViewMemberGroups | [read] an array of GroupNodes that describes the group membership of all ViewMembers managed by the ViewMemberListManager. May return an empty array.
ViewMembers | [read] The collection of viewMemebrs in the viewMember list, updated, if necessary, to reflect any changes that have been made (in the folder list, filter, sort order, and so on) since the last time the viewMember list was retrieved.
VisibleLines | [read] the number of visible lines in the list, given the current collapsed/expanded state of its nodes.

See Also

ViewMemberListManager Class | StarTeam Namespace


AllCachedProperties Property

Borland StarTeam SDK for .NET

ViewMemberListManager.AllCachedProperties Property

[read] The list of properties that will be pre-fetched and cached for members of this viewMember list.

public virtual PropertyCollection AllCachedProperties {get;}

Property Value

The list of properties that will be pre-fetched and cached for members of this viewMember list.

See Also

ViewMemberListManager Class | StarTeam Namespace


CachedPropertiesForFilter Property

Borland StarTeam SDK for .NET

ViewMemberListManager.CachedPropertiesForFilter Property

[read] The list of properties that will be pre-fetched and cached for members of this viewMember list based on Filter criteria.

public virtual PropertyCollection CachedPropertiesForFilter {get;}

Property Value

The list of properties that will be pre-fetched and cached for members of this viewMember list based on Filter criteria.

See Also

ViewMemberListManager Class | StarTeam Namespace


ExtraCachedProperties Property

Borland StarTeam SDK for .NET

ViewMemberListManager.ExtraCachedProperties Property

[read/write] The list of "extra" properties that will be pre-fetched and cached for members of this viewMember list.

public virtual PropertyCollection ExtraCachedProperties {get; set;}

Property Value

The list of "extra" properties that will be pre-fetched and cached for members of this viewMember list.

See Also

ViewMemberListManager Class | StarTeam Namespace


Filter Property

Borland StarTeam SDK for .NET

ViewMemberListManager.Filter Property

[read/write] The filter to be applied to the viewMember list.

public virtual Filter Filter {get; set;}

Property Value

The filter to be applied to the viewMember list.

See Also

ViewMemberListManager Class | StarTeam Namespace


FolderListManager Property

Borland StarTeam SDK for .NET

ViewMemberListManager.FolderListManager Property

[read] The FolderListManager that determines which folders will be used to generate viewMembers in the item list.

public virtual FolderListManager FolderListManager {get;}

Property Value

The FolderListManager that determines which folders will be used to generate viewMembers in the item list.

See Also

ViewMemberListManager Class | StarTeam Namespace


FullDisplay Property

Borland StarTeam SDK for .NET

ViewMemberListManager.FullDisplay Property

[read] the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.

public virtual String[] FullDisplay {get;}

Property Value

the current display state of the list. The '\t' character indicates indents. The '|' character separates column values. Useful for debugging.

See Also

ViewMemberListManager Class | StarTeam Namespace


IsGrouped Property

Borland StarTeam SDK for .NET

ViewMemberListManager.IsGrouped Property

[read] true if this ViewMemberListManager has grouping criteria applied.

public virtual Boolean IsGrouped {get;}

Property Value

true if this ViewMemberListManager has grouping criteria applied.

See Also

ViewMemberListManager Class | StarTeam Namespace


IsRefreshRequired Property

Borland StarTeam SDK for .NET

ViewMemberListManager.IsRefreshRequired Property

[read] true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.

public virtual Boolean IsRefreshRequired {get;}

Property Value

true if a refresh() operation might have resulted in the folder list being updated, and false otherwise.

See Also

ViewMemberListManager Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

ViewMemberListManager.Type Property

[read] The type of viewMember included in the viewMember list.

public virtual ViewMember.Type Type {get;}

Property Value

The type of viewMember included in the viewMember list.

See Also

ViewMemberListManager Class | StarTeam Namespace


UserVisibleFoldersOnly Property

Borland StarTeam SDK for .NET

ViewMemberListManager.UserVisibleFoldersOnly Property

[read/write] true if only ViewMembers in user-visible Folders are included, otherwise false.

public virtual Boolean UserVisibleFoldersOnly {get; set;}

Property Value

true if only ViewMembers in user-visible Folders are included, otherwise false.

See Also

ViewMemberListManager Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

ViewMemberListManager.View Property

[read] the view from which the ViewMembers will be culled

public virtual View View {get;}

Property Value

the view from which the ViewMembers will be culled

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberGroups Property

Borland StarTeam SDK for .NET

ViewMemberListManager.ViewMemberGroups Property

[read] an array of GroupNodes that describes the group membership of all ViewMembers managed by the ViewMemberListManager. May return an empty array.

public virtual GroupNode[] ViewMemberGroups {get;}

Property Value

an array of GroupNodes that describes the group membership of all ViewMembers managed by the ViewMemberListManager. May return an empty array.

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMembers Property

Borland StarTeam SDK for .NET

ViewMemberListManager.ViewMembers Property

[read] The collection of viewMemebrs in the viewMember list, updated, if necessary, to reflect any changes that have been made (in the folder list, filter, sort order, and so on) since the last time the viewMember list was retrieved.

public virtual ViewMemberCollection ViewMembers {get;}

Property Value

The collection of viewMemebrs in the viewMember list, updated, if necessary, to reflect any changes that have been made (in the folder list, filter, sort order, and so on) since the last time the viewMember list was retrieved.

See Also

ViewMemberListManager Class | StarTeam Namespace


VisibleLines Property

Borland StarTeam SDK for .NET

ViewMemberListManager.VisibleLines Property

[read] the number of visible lines in the list, given the current collapsed/expanded state of its nodes.

public virtual Int32 VisibleLines {get;}

Property Value

the number of visible lines in the list, given the current collapsed/expanded state of its nodes.

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager Methods

The methods of the ViewMemberListManager class are listed below. For a complete list of ViewMemberListManager class members, see the ViewMemberListManager Members topic.

Public Instance Methods

Close | Close this ViewMemberListManager, release all its resources, and sever its ties to its parent FolderListManager it will automatically be re-opened when needed.
Discard | Discards all relevant cached data. It will be re-fetched from the server the next time the viewMember list is retrieved (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ViewMemberListManager.
FindViewMember | Searches for a given viewMember in the viewMember list.
GetGroupNodeAtLine | Returns the GroupNode at line, given the list's current collapsed/expanded state, or null if that line doesn't contain a GroupNode.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberListManager.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewMemberAtLine | Returns the ViewMember at line, given the list's current collapsed/expanded state, or null if that line doesn't contain an ViewMember.
GetViewMemberID | Returns the VMID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.
GetViewMembers | Returns a collection containing the viewMembers in a Folder and optionally all its descendants.
GroupViewMembers | Determines whether this ViewMemberListManager should group viewMembers when returning them? ViewMembers can only be grouped if sortViewMembers is also set to True ViewMembers will be grouped if the ViewMemberListManager is attached to a Filter that specifies Group Sorting Information A ViewMemberListManager is grouped by default
IsGroupNodeAtLine | Returns true if the object at line is a GroupNode or false if it's an ViewMember, given the list's current collapsed/expanded state.
NewItemEventSource |
NewItemIDEventSource |
NewItemListEventSource |
NewItemUpdateEventSource |
NewNotificationEventSource |
NewViewMemberEventSource |
NewViewMemberUpdateEventSource |
Refresh | Updates the list of viewMembers to reflect recent changes made on the server. Existing ViewMember objects are modified in place whenever possible. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
SelectBy | Overloaded. Gets the subset of viewMembers in the viewMember list to which the given label has been applied.
SortViewMembers | Determines whether this ViewMemberListManager should sort viewMembers when returning them? ViewMembers will be sorted if the ViewMemberListManager is attached to a Filter that specifies Group Sorting Information A ViewMemberListManager is sorted by default
ToString | Delegate ToString() to com.starteam.ViewMemberListManager.

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.Close Method

Close this ViewMemberListManager, release all its resources, and sever its ties to its parent FolderListManager it will automatically be re-opened when needed.

public virtual void Close();

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.Discard Method

Discards all relevant cached data. It will be re-fetched from the server the next time the viewMember list is retrieved (even when MPX is enabled).

public virtual void Discard();

See Also

ViewMemberListManager Class | StarTeam Namespace | refresh


ViewMemberListManager.Equals Method

Delegate Equals() to com.starteam.ViewMemberListManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberListManager.Equals(obj).

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.FindViewMember Method

Searches for a given viewMember in the viewMember list.

public virtual ViewMember FindViewMember(
Int32 vmID
);

Parameters

vmID
The result of a call to getViewMemberID(item).

Return Value

The viewMember, or null if no viewMember with the given ID was found in the viewMember list.

See Also

ViewMemberListManager Class | StarTeam Namespace | getViewMemberID


ViewMemberListManager.GetGroupNodeAtLine Method

Returns the GroupNode at line, given the list's current collapsed/expanded state, or null if that line doesn't contain a GroupNode.

public virtual GroupNode GetGroupNodeAtLine(
Int32 line
);

Parameters

line
the line to query, given the current collapsed/expanded state of the list.

Return Value

the GroupNode at line, given the list's current collapsed/expanded state, or null if that line doesn't contain a GroupNode.

See Also

ViewMemberListManager Class | StarTeam Namespace | GroupNode


ViewMemberListManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberListManager.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberListManager.GetHashCode().

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.GetViewMemberAtLine Method

Returns the ViewMember at line, given the list's current collapsed/expanded state, or null if that line doesn't contain an ViewMember.

public virtual ViewMember GetViewMemberAtLine(
Int32 line
);

Parameters

line
the line to query, given the current collapsed/expanded state of the list.

Return Value

the ViewMember at line, given the list's current collapsed/expanded state, or null if that line doesn't contain an ViewMember.

See Also

ViewMemberListManager Class | StarTeam Namespace | GroupNode | ViewMember


ViewMemberListManager.GetViewMemberID Method

Returns the VMID for an item; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.

public virtual int GetViewMemberID(
ViewMember item
);

Parameters

item
The viewMember whose VMID is returned.

Return Value

the VMID for a viewMember; if we're managing not-in-view files, this may be a negative, temporary ID that can be used to uniquely identify the not-in-view file object until it's been added to the repository.

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.GetViewMembers Method

Returns a collection containing the viewMembers in a Folder and optionally all its descendants.

public virtual ViewMemberCollection GetViewMembers(
Folder folder,
Boolean bDescendants
);

Parameters

folder
the folder whose viewMembers are returned
bDescendants
true = plus all descendants of folder; false = folder only

Return Value

a collection containing the viewMembers in a Folder and optionally all its descendants.

See Also

ViewMemberListManager Class | StarTeam Namespace | getViewMembers


ViewMemberListManager.GroupViewMembers Method

Determines whether this ViewMemberListManager should group viewMembers when returning them? ViewMembers can only be grouped if sortViewMembers is also set to True ViewMembers will be grouped if the ViewMemberListManager is attached to a Filter that specifies Group Sorting Information A ViewMemberListManager is grouped by default

public virtual void GroupViewMembers(
Boolean bGroup
);

Parameters

bGroup
True to group the viewMembers, False to return them in default order

See Also

ViewMemberListManager Class | StarTeam Namespace | sortViewMembers | getViewMembers


ViewMemberListManager.IsGroupNodeAtLine Method

Returns true if the object at line is a GroupNode or false if it's an ViewMember, given the list's current collapsed/expanded state.

public virtual bool IsGroupNodeAtLine(
Int32 line
);

Parameters

line
the zero-based line to query, given the current collapsed/expanded state of the list.

Return Value

true if the object at line is a GroupNode or false if it's an ViewMember, given the list's current collapsed/expanded state.

See Also

ViewMemberListManager Class | StarTeam Namespace | GroupNode


ViewMemberListManager.NewItemEventSource Method

public ItemEventSource NewItemEventSource();

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.NewItemIDEventSource Method

public ItemIDEventSource NewItemIDEventSource();

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.NewItemListEventSource Method

public ItemListEventSource NewItemListEventSource();

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource();

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.NewNotificationEventSource Method

public NotificationEventSource NewNotificationEventSource();

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.NewViewMemberEventSource Method

public ViewMemberEventSource NewViewMemberEventSource();

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.NewViewMemberUpdateEventSource Method

public ViewMemberUpdateEventSource NewViewMemberUpdateEventSource();

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.Refresh Method

Updates the list of viewMembers to reflect recent changes made on the server. Existing ViewMember objects are modified in place whenever possible. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.

public virtual void Refresh();

See Also

ViewMemberListManager Class | StarTeam Namespace | getViewMembers | isRefreshRequired | discard | isMPXEnabled


SelectBy Method

Borland StarTeam SDK for .NET

ViewMemberListManager.SelectBy Method

Gets the subset of viewMembers in the viewMember list to which the given label has been applied.

Overload List

Gets the subset of viewMembers in the viewMember list to which the given label has been applied.

public virtual ViewMemberCollection SelectBy(Label);

Gets the subset of viewMembers in the viewMember list that match the given query.

public virtual ViewMemberCollection SelectBy(Query);

See Also

ViewMemberListManager Class | StarTeam Namespace | getViewMembers


ViewMemberListManager.SelectBy Method (Label)

Gets the subset of viewMembers in the viewMember list to which the given label has been applied.

public virtual ViewMemberCollection SelectBy(
Label label
);

Parameters

label
The label to be tested.

Return Value

The subset of viewMembers in the viewMember list to which the given label has been applied.

See Also

ViewMemberListManager Class | StarTeam Namespace | ViewMemberListManager.SelectBy Overload List | getViewMembers


ViewMemberListManager.SelectBy Method (Query)

Gets the subset of viewMembers in the viewMember list that match the given query.

public virtual ViewMemberCollection SelectBy(
Query query
);

Parameters

query
The query to be matched.

Return Value

The subset of viewMembers in the viewMember list that match the given query.

See Also

ViewMemberListManager Class | StarTeam Namespace | ViewMemberListManager.SelectBy Overload List


ViewMemberListManager.SortViewMembers Method

Determines whether this ViewMemberListManager should sort viewMembers when returning them? ViewMembers will be sorted if the ViewMemberListManager is attached to a Filter that specifies Group Sorting Information A ViewMemberListManager is sorted by default

public virtual void SortViewMembers(
Boolean bSort
);

Parameters

bSort
True to sort the viewMembers, False to return them in default order

See Also

ViewMemberListManager Class | StarTeam Namespace | getViewMembers


ViewMemberListManager.ToString Method

Delegate ToString() to com.starteam.ViewMemberListManager.

public override string ToString();

Return Value

com.starteam.ViewMemberListManager.ToString()

See Also

ViewMemberListManager Class | StarTeam Namespace


ViewMemberListManager.GroupNode Class

Describes a group of objects that may be a subgroup of a larger, indexable group. Maintains a range mapping into the underlying ordered collection. Each Node may be in an expanded or collapsed state. Note that it is the client's responsibility to ensure valid index ranges relative to the underlying collection.

For a list of all members of this type, see ViewMemberListManager.GroupNode Members.

System.Object
ViewMemberListManager.GroupNode

public class ViewMemberListManager.GroupNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberListManager.GroupNode Members | StarTeam Namespace


ViewMemberListManager.GroupNode Members

ViewMemberListManager.GroupNode overview

Public Instance Properties

Children | [read] the direct subgroups of this group.
DebugString | [read]
Depth | [read] the zero-based depth of this GroupNode in the grouping hierarchy.
IsExpanded | [read/write] true if this GroupNode is expanded.
IsLeafNode | [read] true if this is a leaf-level GroupNode.
Length | [read] the number of contiguous objects spanned in the underlying indexable collection.
Name | [read] the display name of this group.
NumChildren | [read] the number of direct subgroups of this group.
NumVisibleLines | [read] the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.
Parent | [read] the parent GroupNode.
Start | [read] the index of the first leaf object of this node in the associated indexable collection.

Public Instance Methods

AddChild |
Equals | Delegate Equals() to com.starteam.ViewMemberListManager.GroupNode.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberListManager.GroupNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ViewMemberListManager.GroupNode.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


ViewMemberListManager.GroupNode Properties

The properties of the ViewMemberListManager.GroupNode class are listed below. For a complete list of ViewMemberListManager.GroupNode class members, see the ViewMemberListManager.GroupNode Members topic.

Public Instance Properties

Children | [read] the direct subgroups of this group.
DebugString | [read]
Depth | [read] the zero-based depth of this GroupNode in the grouping hierarchy.
IsExpanded | [read/write] true if this GroupNode is expanded.
IsLeafNode | [read] true if this is a leaf-level GroupNode.
Length | [read] the number of contiguous objects spanned in the underlying indexable collection.
Name | [read] the display name of this group.
NumChildren | [read] the number of direct subgroups of this group.
NumVisibleLines | [read] the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.
Parent | [read] the parent GroupNode.
Start | [read] the index of the first leaf object of this node in the associated indexable collection.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


Children Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.Children Property

[read] the direct subgroups of this group.

public virtual GroupNode[] Children {get;}

Property Value

the direct subgroups of this group.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


DebugString Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.DebugString Property

[read]

public virtual String DebugString {get;}

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


Depth Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.Depth Property

[read] the zero-based depth of this GroupNode in the grouping hierarchy.

public virtual Int32 Depth {get;}

Property Value

the zero-based depth of this GroupNode in the grouping hierarchy.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


IsExpanded Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.IsExpanded Property

[read/write] true if this GroupNode is expanded.

public virtual Boolean IsExpanded {get; set;}

Property Value

true if this GroupNode is expanded.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


IsLeafNode Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.IsLeafNode Property

[read] true if this is a leaf-level GroupNode.

public virtual Boolean IsLeafNode {get;}

Property Value

true if this is a leaf-level GroupNode.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


Length Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.Length Property

[read] the number of contiguous objects spanned in the underlying indexable collection.

public virtual Int32 Length {get;}

Property Value

the number of contiguous objects spanned in the underlying indexable collection.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.Name Property

[read] the display name of this group.

public virtual String Name {get;}

Property Value

the display name of this group.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


NumChildren Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.NumChildren Property

[read] the number of direct subgroups of this group.

public virtual Int32 NumChildren {get;}

Property Value

the number of direct subgroups of this group.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


NumVisibleLines Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.NumVisibleLines Property

[read] the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.

public virtual Int32 NumVisibleLines {get;}

Property Value

the number of visible lines represented in this node, based on the current collapsed/expanded state of the hierarchy.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


Parent Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.Parent Property

[read] the parent GroupNode.

public virtual ViewMemberListManager.GroupNode Parent {get;}

Property Value

the parent GroupNode.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


Start Property

Borland StarTeam SDK for .NET

ViewMemberListManager.GroupNode.Start Property

[read] the index of the first leaf object of this node in the associated indexable collection.

public virtual Int32 Start {get;}

Property Value

the index of the first leaf object of this node in the associated indexable collection.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


ViewMemberListManager.GroupNode Methods

The methods of the ViewMemberListManager.GroupNode class are listed below. For a complete list of ViewMemberListManager.GroupNode class members, see the ViewMemberListManager.GroupNode Members topic.

Public Instance Methods

AddChild |
Equals | Delegate Equals() to com.starteam.ViewMemberListManager.GroupNode.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberListManager.GroupNode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ViewMemberListManager.GroupNode.

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


ViewMemberListManager.GroupNode.AddChild Method

public virtual void AddChild(
ViewMemberListManager.GroupNode child
);

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


ViewMemberListManager.GroupNode.Equals Method

Delegate Equals() to com.starteam.ViewMemberListManager.GroupNode.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberListManager.GroupNode.Equals(obj).

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


ViewMemberListManager.GroupNode.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberListManager.GroupNode.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberListManager.GroupNode.GetHashCode().

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


ViewMemberListManager.GroupNode.ToString Method

Delegate ToString() to com.starteam.ViewMemberListManager.GroupNode.

public override string ToString();

Return Value

com.starteam.ViewMemberListManager.GroupNode.ToString()

See Also

ViewMemberListManager.GroupNode Class | StarTeam Namespace


ViewMemberRevision Class

A ViewMemberRevision represents a View member level revision of an item. Such revisions are created when one modifies the view level properties of a particular share of the item. These would be operations like: 1. changing the item branch behavior 2. changing the item configuration 3. branching the item 4. moving the item

For a list of all members of this type, see ViewMemberRevision Members.

System.Object
TypedResource
ViewMemberRevision

public class ViewMemberRevision : TypedResource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision Members | StarTeam Namespace


ViewMemberRevision Members

ViewMemberRevision overview

Public Instance Properties

BranchStateValue | [read] the branch state of this item revision.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy | [read] the User who created this item revision.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBranched | [read] true if this item revision has branched.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ObjectTime | [read] the time of this item revision.
ParentFolderItemID | [read] the parent folder (location) item ID of this item revision.
ParentItemID | [read] the Item ID of the parent for this item revision.
Project | [read] the Project that contains this item revision.
Properties | [read]
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Time | [read] the time of this item revision.
View | [read] the View for this item revision.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

ViewMemberRevision Class | StarTeam Namespace


ViewMemberRevision Properties

The properties of the ViewMemberRevision class are listed below. For a complete list of ViewMemberRevision class members, see the ViewMemberRevision Members topic.

Public Instance Properties

BranchStateValue | [read] the branch state of this item revision.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy | [read] the User who created this item revision.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBranched | [read] true if this item revision has branched.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
MyType (inherited from TypedResource) | [read] the type of this resource.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ObjectTime | [read] the time of this item revision.
ParentFolderItemID | [read] the parent folder (location) item ID of this item revision.
ParentItemID | [read] the Item ID of the parent for this item revision.
Project | [read] the Project that contains this item revision.
Properties | [read]
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Time | [read] the time of this item revision.
View | [read] the View for this item revision.

See Also

ViewMemberRevision Class | StarTeam Namespace


BranchStateValue Property

Borland StarTeam SDK for .NET

ViewMemberRevision.BranchStateValue Property

[read] the branch state of this item revision.

public virtual TypedResource.BranchState BranchStateValue {get;}

Property Value

the branch state of this item revision.

See Also

ViewMemberRevision Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

ViewMemberRevision.CreatedBy Property

[read] the User who created this item revision.

public virtual User CreatedBy {get;}

Property Value

the User who created this item revision.

See Also

ViewMemberRevision Class | StarTeam Namespace


IsBranched Property

Borland StarTeam SDK for .NET

ViewMemberRevision.IsBranched Property

[read] true if this item revision has branched.

public virtual Boolean IsBranched {get;}

Property Value

true if this item revision has branched.

See Also

ViewMemberRevision Class | StarTeam Namespace


ObjectTime Property

Borland StarTeam SDK for .NET

ViewMemberRevision.ObjectTime Property

[read] the time of this item revision.

public virtual DateTime ObjectTime {get;}

Property Value

the time of this item revision.

See Also

ViewMemberRevision Class | StarTeam Namespace


ParentFolderItemID Property

Borland StarTeam SDK for .NET

ViewMemberRevision.ParentFolderItemID Property

[read] the parent folder (location) item ID of this item revision.

public virtual Int32 ParentFolderItemID {get;}

Property Value

the parent folder (location) item ID of this item revision.

See Also

ViewMemberRevision Class | StarTeam Namespace


ParentItemID Property

Borland StarTeam SDK for .NET

ViewMemberRevision.ParentItemID Property

[read] the Item ID of the parent for this item revision.

public virtual Int32 ParentItemID {get;}

Property Value

the Item ID of the parent for this item revision.

See Also

ViewMemberRevision Class | StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Project Property

[read] the Project that contains this item revision.

public virtual Project Project {get;}

Property Value

the Project that contains this item revision.

See Also

ViewMemberRevision Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Properties Property

[read]

public virtual ViewMemberRevision.Type.PropertyCollection Properties {get;}

See Also

ViewMemberRevision Class | StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Time Property

[read] the time of this item revision.

public virtual DateTime Time {get;}

Property Value

the time of this item revision.

See Also

ViewMemberRevision Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

ViewMemberRevision.View Property

[read] the View for this item revision.

public virtual View View {get;}

Property Value

the View for this item revision.

See Also

ViewMemberRevision Class | StarTeam Namespace


ViewMemberRevision.Type Class

The type of the ViewMemberRevision

For a list of all members of this type, see ViewMemberRevision.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
ViewMemberRevision.Type

new public class ViewMemberRevision.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.Type Members | StarTeam Namespace


ViewMemberRevision.Type Members

ViewMemberRevision.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.

See Also

ViewMemberRevision.Type Class | StarTeam Namespace


ViewMemberRevision.Type Properties

The properties of the ViewMemberRevision.Type class are listed below. For a complete list of ViewMemberRevision.Type class members, see the ViewMemberRevision.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

ViewMemberRevision.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.NAME Property

new public static String NAME {get;}

See Also

ViewMemberRevision.Type Class | StarTeam Namespace


ViewMemberRevision.Type Methods

The methods of the ViewMemberRevision.Type class are listed below. For a complete list of ViewMemberRevision.Type class members, see the ViewMemberRevision.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.

See Also

ViewMemberRevision.Type Class | StarTeam Namespace


ViewMemberRevision.Type.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.Type.Equals(obj).

See Also

ViewMemberRevision.Type Class | StarTeam Namespace


ViewMemberRevision.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.Type.GetHashCode().

See Also

ViewMemberRevision.Type Class | StarTeam Namespace


ViewMemberRevision.Type.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.Type.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.Type.ToString()

See Also

ViewMemberRevision.Type Class | StarTeam Namespace


ViewMemberRevision.Type.BranchFlagProperty Class

The property type of the BranchFlag property

For a list of all members of this type, see ViewMemberRevision.Type.BranchFlagProperty Members.

System.Object
Property
EnumeratedProperty
BooleanProperty
ViewMemberRevision.Type.BranchFlagProperty

public class ViewMemberRevision.Type.BranchFlagProperty : BooleanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.Type.BranchFlagProperty Members | StarTeam Namespace


ViewMemberRevision.Type.BranchFlagProperty Members

ViewMemberRevision.Type.BranchFlagProperty overview

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.BranchFlagProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.BranchFlagProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.BranchFlagProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.BranchFlagProperty Class | StarTeam Namespace


ViewMemberRevision.Type.BranchFlagProperty Properties

The properties of the ViewMemberRevision.Type.BranchFlagProperty class are listed below. For a complete list of ViewMemberRevision.Type.BranchFlagProperty class members, see the ViewMemberRevision.Type.BranchFlagProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from BooleanProperty) | [read/write] The default value of this property, as a boolean value.
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
FalseValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
TrueValue (inherited from BooleanProperty) | [read/write] EnumeratedValue
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

ViewMemberRevision.Type.BranchFlagProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.BranchFlagProperty.NAME Property

public static String NAME {get;}

See Also

ViewMemberRevision.Type.BranchFlagProperty Class | StarTeam Namespace


ViewMemberRevision.Type.BranchFlagProperty Methods

The methods of the ViewMemberRevision.Type.BranchFlagProperty class are listed below. For a complete list of ViewMemberRevision.Type.BranchFlagProperty class members, see the ViewMemberRevision.Type.BranchFlagProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.BranchFlagProperty.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.BranchFlagProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from BooleanProperty) | Overloaded.
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.BranchFlagProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.BranchFlagProperty Class | StarTeam Namespace


ViewMemberRevision.Type.BranchFlagProperty.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.Type.BranchFlagProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.Type.BranchFlagProperty.Equals(obj).

See Also

ViewMemberRevision.Type.BranchFlagProperty Class | StarTeam Namespace


ViewMemberRevision.Type.BranchFlagProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.BranchFlagProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.Type.BranchFlagProperty.GetHashCode().

See Also

ViewMemberRevision.Type.BranchFlagProperty Class | StarTeam Namespace


ViewMemberRevision.Type.BranchFlagProperty.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.Type.BranchFlagProperty.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.Type.BranchFlagProperty.ToString()

See Also

ViewMemberRevision.Type.BranchFlagProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedByProperty Class

The property type of the CreatedBy property

For a list of all members of this type, see ViewMemberRevision.Type.CreatedByProperty Members.

System.Object
Property
ObjectProperty
ViewMemberRevision.Type.CreatedByProperty

public class ViewMemberRevision.Type.CreatedByProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.Type.CreatedByProperty Members | StarTeam Namespace


ViewMemberRevision.Type.CreatedByProperty Members

ViewMemberRevision.Type.CreatedByProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.CreatedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.CreatedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.CreatedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.CreatedByProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedByProperty Properties

The properties of the ViewMemberRevision.Type.CreatedByProperty class are listed below. For a complete list of ViewMemberRevision.Type.CreatedByProperty class members, see the ViewMemberRevision.Type.CreatedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

ViewMemberRevision.Type.CreatedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.CreatedByProperty.NAME Property

public static String NAME {get;}

See Also

ViewMemberRevision.Type.CreatedByProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedByProperty Methods

The methods of the ViewMemberRevision.Type.CreatedByProperty class are listed below. For a complete list of ViewMemberRevision.Type.CreatedByProperty class members, see the ViewMemberRevision.Type.CreatedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.CreatedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.CreatedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.CreatedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.CreatedByProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedByProperty.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.Type.CreatedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.Type.CreatedByProperty.Equals(obj).

See Also

ViewMemberRevision.Type.CreatedByProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.CreatedByProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.Type.CreatedByProperty.GetHashCode().

See Also

ViewMemberRevision.Type.CreatedByProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedByProperty.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.Type.CreatedByProperty.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.Type.CreatedByProperty.ToString()

See Also

ViewMemberRevision.Type.CreatedByProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedTimeProperty Class

The property type of the CreatedTime property

For a list of all members of this type, see ViewMemberRevision.Type.CreatedTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ViewMemberRevision.Type.CreatedTimeProperty

public class ViewMemberRevision.Type.CreatedTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.Type.CreatedTimeProperty Members | StarTeam Namespace


ViewMemberRevision.Type.CreatedTimeProperty Members

ViewMemberRevision.Type.CreatedTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.CreatedTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedTimeProperty Properties

The properties of the ViewMemberRevision.Type.CreatedTimeProperty class are listed below. For a complete list of ViewMemberRevision.Type.CreatedTimeProperty class members, see the ViewMemberRevision.Type.CreatedTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMemberRevision.Type.CreatedTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.CreatedTimeProperty.NAME Property

public static String NAME {get;}

See Also

ViewMemberRevision.Type.CreatedTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedTimeProperty Methods

The methods of the ViewMemberRevision.Type.CreatedTimeProperty class are listed below. For a complete list of ViewMemberRevision.Type.CreatedTimeProperty class members, see the ViewMemberRevision.Type.CreatedTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.CreatedTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedTimeProperty.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.Equals(obj).

See Also

ViewMemberRevision.Type.CreatedTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.GetHashCode().

See Also

ViewMemberRevision.Type.CreatedTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.CreatedTimeProperty.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.Type.CreatedTimeProperty.ToString()

See Also

ViewMemberRevision.Type.CreatedTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectIDProperty Class

The property type of the ObjectID property

For a list of all members of this type, see ViewMemberRevision.Type.ObjectIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ViewMemberRevision.Type.ObjectIDProperty

public class ViewMemberRevision.Type.ObjectIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.Type.ObjectIDProperty Members | StarTeam Namespace


ViewMemberRevision.Type.ObjectIDProperty Members

ViewMemberRevision.Type.ObjectIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.ObjectIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ObjectIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.ObjectIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.ObjectIDProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectIDProperty Properties

The properties of the ViewMemberRevision.Type.ObjectIDProperty class are listed below. For a complete list of ViewMemberRevision.Type.ObjectIDProperty class members, see the ViewMemberRevision.Type.ObjectIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMemberRevision.Type.ObjectIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.ObjectIDProperty.NAME Property

public static String NAME {get;}

See Also

ViewMemberRevision.Type.ObjectIDProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectIDProperty Methods

The methods of the ViewMemberRevision.Type.ObjectIDProperty class are listed below. For a complete list of ViewMemberRevision.Type.ObjectIDProperty class members, see the ViewMemberRevision.Type.ObjectIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.ObjectIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ObjectIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.ObjectIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.ObjectIDProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectIDProperty.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.Type.ObjectIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.Type.ObjectIDProperty.Equals(obj).

See Also

ViewMemberRevision.Type.ObjectIDProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ObjectIDProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.Type.ObjectIDProperty.GetHashCode().

See Also

ViewMemberRevision.Type.ObjectIDProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectIDProperty.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.Type.ObjectIDProperty.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.Type.ObjectIDProperty.ToString()

See Also

ViewMemberRevision.Type.ObjectIDProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectTimeProperty Class

The property type of the ObjectTime property

For a list of all members of this type, see ViewMemberRevision.Type.ObjectTimeProperty Members.

System.Object
Property
ScalarProperty
DateTimeProperty
ViewMemberRevision.Type.ObjectTimeProperty

public class ViewMemberRevision.Type.ObjectTimeProperty : DateTimeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.Type.ObjectTimeProperty Members | StarTeam Namespace


ViewMemberRevision.Type.ObjectTimeProperty Members

ViewMemberRevision.Type.ObjectTimeProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.ObjectTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectTimeProperty Properties

The properties of the ViewMemberRevision.Type.ObjectTimeProperty class are listed below. For a complete list of ViewMemberRevision.Type.ObjectTimeProperty class members, see the ViewMemberRevision.Type.ObjectTimeProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateTimeProperty) | [read/write] the default DateTime value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateTimeProperty) | [read/write] the maximum DateTime value for this Property
MinValue (inherited from DateTimeProperty) | [read/write] the minimum DateTime value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMemberRevision.Type.ObjectTimeProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.ObjectTimeProperty.NAME Property

public static String NAME {get;}

See Also

ViewMemberRevision.Type.ObjectTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectTimeProperty Methods

The methods of the ViewMemberRevision.Type.ObjectTimeProperty class are listed below. For a complete list of ViewMemberRevision.Type.ObjectTimeProperty class members, see the ViewMemberRevision.Type.ObjectTimeProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateTimeProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.ObjectTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectTimeProperty.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.Equals(obj).

See Also

ViewMemberRevision.Type.ObjectTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectTimeProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.GetHashCode().

See Also

ViewMemberRevision.Type.ObjectTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ObjectTimeProperty.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.Type.ObjectTimeProperty.ToString()

See Also

ViewMemberRevision.Type.ObjectTimeProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentFolderProperty Class

The property type of the ParentFolder property

For a list of all members of this type, see ViewMemberRevision.Type.ParentFolderProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ViewMemberRevision.Type.ParentFolderProperty

public class ViewMemberRevision.Type.ParentFolderProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.Type.ParentFolderProperty Members | StarTeam Namespace


ViewMemberRevision.Type.ParentFolderProperty Members

ViewMemberRevision.Type.ParentFolderProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.ParentFolderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ParentFolderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.ParentFolderProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.ParentFolderProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentFolderProperty Properties

The properties of the ViewMemberRevision.Type.ParentFolderProperty class are listed below. For a complete list of ViewMemberRevision.Type.ParentFolderProperty class members, see the ViewMemberRevision.Type.ParentFolderProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMemberRevision.Type.ParentFolderProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.ParentFolderProperty.NAME Property

public static String NAME {get;}

See Also

ViewMemberRevision.Type.ParentFolderProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentFolderProperty Methods

The methods of the ViewMemberRevision.Type.ParentFolderProperty class are listed below. For a complete list of ViewMemberRevision.Type.ParentFolderProperty class members, see the ViewMemberRevision.Type.ParentFolderProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.ParentFolderProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ParentFolderProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.ParentFolderProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.ParentFolderProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentFolderProperty.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.Type.ParentFolderProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.Type.ParentFolderProperty.Equals(obj).

See Also

ViewMemberRevision.Type.ParentFolderProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentFolderProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ParentFolderProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.Type.ParentFolderProperty.GetHashCode().

See Also

ViewMemberRevision.Type.ParentFolderProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentFolderProperty.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.Type.ParentFolderProperty.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.Type.ParentFolderProperty.ToString()

See Also

ViewMemberRevision.Type.ParentFolderProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentShareProperty Class

The property type of the ParentShare property

For a list of all members of this type, see ViewMemberRevision.Type.ParentShareProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
ViewMemberRevision.Type.ParentShareProperty

public class ViewMemberRevision.Type.ParentShareProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.Type.ParentShareProperty Members | StarTeam Namespace


ViewMemberRevision.Type.ParentShareProperty Members

ViewMemberRevision.Type.ParentShareProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.ParentShareProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ParentShareProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.ParentShareProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.ParentShareProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentShareProperty Properties

The properties of the ViewMemberRevision.Type.ParentShareProperty class are listed below. For a complete list of ViewMemberRevision.Type.ParentShareProperty class members, see the ViewMemberRevision.Type.ParentShareProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

ViewMemberRevision.Type.ParentShareProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.ParentShareProperty.NAME Property

public static String NAME {get;}

See Also

ViewMemberRevision.Type.ParentShareProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentShareProperty Methods

The methods of the ViewMemberRevision.Type.ParentShareProperty class are listed below. For a complete list of ViewMemberRevision.Type.ParentShareProperty class members, see the ViewMemberRevision.Type.ParentShareProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.ParentShareProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ParentShareProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.ParentShareProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewMemberRevision.Type.ParentShareProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentShareProperty.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.Type.ParentShareProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.Type.ParentShareProperty.Equals(obj).

See Also

ViewMemberRevision.Type.ParentShareProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentShareProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.ParentShareProperty.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.Type.ParentShareProperty.GetHashCode().

See Also

ViewMemberRevision.Type.ParentShareProperty Class | StarTeam Namespace


ViewMemberRevision.Type.ParentShareProperty.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.Type.ParentShareProperty.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.Type.ParentShareProperty.ToString()

See Also

ViewMemberRevision.Type.ParentShareProperty Class | StarTeam Namespace


ViewMemberRevision.Type.PropertyCollection Class

The property collection of the ViewMemberRevision type

For a list of all members of this type, see ViewMemberRevision.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMemberRevision.Type.PropertyCollection

public class ViewMemberRevision.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.Type.PropertyCollection Members | StarTeam Namespace


ViewMemberRevision.Type.PropertyCollection Members

ViewMemberRevision.Type.PropertyCollection overview

Public Instance Properties

BRANCH_FLAG |
BRANCH_STATE |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
OBJECT_ID |
OBJECT_TIME |
PARENT_FOLDER |
PARENT_SHARE |
PROJECT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.PropertyCollection.

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


ViewMemberRevision.Type.PropertyCollection Properties

The properties of the ViewMemberRevision.Type.PropertyCollection class are listed below. For a complete list of ViewMemberRevision.Type.PropertyCollection class members, see the ViewMemberRevision.Type.PropertyCollection Members topic.

Public Instance Properties

BRANCH_FLAG |
BRANCH_STATE |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
OBJECT_ID |
OBJECT_TIME |
PARENT_FOLDER |
PARENT_SHARE |
PROJECT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
VIEW |

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_FLAG Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.BRANCH_FLAG Property

public ViewMemberRevision.Type.BranchFlagProperty BRANCH_FLAG {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.CREATED_BY Property

public ViewMemberRevision.Type.CreatedByProperty CREATED_BY {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.CREATED_TIME Property

public ViewMemberRevision.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


OBJECT_ID Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.OBJECT_ID Property

public ViewMemberRevision.Type.ObjectIDProperty OBJECT_ID {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


OBJECT_TIME Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.OBJECT_TIME Property

public ViewMemberRevision.Type.ObjectTimeProperty OBJECT_TIME {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


PARENT_FOLDER Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.PARENT_FOLDER Property

public ViewMemberRevision.Type.ParentFolderProperty PARENT_FOLDER {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


PARENT_SHARE Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.PARENT_SHARE Property

public ViewMemberRevision.Type.ParentShareProperty PARENT_SHARE {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


PROJECT Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.PROJECT Property

public TypedResource.Type.ProjectProperty PROJECT {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

ViewMemberRevision.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


ViewMemberRevision.Type.PropertyCollection Methods

The methods of the ViewMemberRevision.Type.PropertyCollection class are listed below. For a complete list of ViewMemberRevision.Type.PropertyCollection class members, see the ViewMemberRevision.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.ViewMemberRevision.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.Type.PropertyCollection.

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


ViewMemberRevision.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.Type.PropertyCollection.Equals(obj).

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


ViewMemberRevision.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.Type.PropertyCollection.GetHashCode().

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


ViewMemberRevision.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.Type.PropertyCollection.ToString()

See Also

ViewMemberRevision.Type.PropertyCollection Class | StarTeam Namespace


ViewMemberRevision.WebCacheViewMemberRevision Class

A ViewMemberRevision represents a View member level revision of an item. Such revisions are created when one modifies the view level properties of a particular share of the item. These would be operations like: 1. changing the item branch behavior 2. changing the item configuration 3. branching the item 4. moving the item

For a list of all members of this type, see ViewMemberRevision.WebCacheViewMemberRevision Members.

System.Object
ViewMemberRevision.WebCacheViewMemberRevision

public class ViewMemberRevision.WebCacheViewMemberRevision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberRevision.WebCacheViewMemberRevision Members | StarTeam Namespace


ViewMemberRevision.WebCacheViewMemberRevision Members

ViewMemberRevision.WebCacheViewMemberRevision overview

Public Instance Properties

BranchStateValue | [read] the branch state of this item revision.
CreatedBy | [read] the User who created this item revision.
IsBranched | [read] true if this item revision has branched.
ObjectID | [read] the object ID for this item revision.
ParentFolder | [read] the parent folder (location) of this item revision or NULL.
Project | [read] the Project that contains this item revision.
Time | [read] the time of this item revision, when created.
View | [read] the View for this item revision.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


ViewMemberRevision.WebCacheViewMemberRevision Properties

The properties of the ViewMemberRevision.WebCacheViewMemberRevision class are listed below. For a complete list of ViewMemberRevision.WebCacheViewMemberRevision class members, see the ViewMemberRevision.WebCacheViewMemberRevision Members topic.

Public Instance Properties

BranchStateValue | [read] the branch state of this item revision.
CreatedBy | [read] the User who created this item revision.
IsBranched | [read] true if this item revision has branched.
ObjectID | [read] the object ID for this item revision.
ParentFolder | [read] the parent folder (location) of this item revision or NULL.
Project | [read] the Project that contains this item revision.
Time | [read] the time of this item revision, when created.
View | [read] the View for this item revision.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


BranchStateValue Property

Borland StarTeam SDK for .NET

ViewMemberRevision.WebCacheViewMemberRevision.BranchStateValue Property

[read] the branch state of this item revision.

public virtual TypedResource.BranchState BranchStateValue {get;}

Property Value

the branch state of this item revision.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

ViewMemberRevision.WebCacheViewMemberRevision.CreatedBy Property

[read] the User who created this item revision.

public virtual User.WebCacheUser CreatedBy {get;}

Property Value

the User who created this item revision.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


IsBranched Property

Borland StarTeam SDK for .NET

ViewMemberRevision.WebCacheViewMemberRevision.IsBranched Property

[read] true if this item revision has branched.

public virtual Boolean IsBranched {get;}

Property Value

true if this item revision has branched.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

ViewMemberRevision.WebCacheViewMemberRevision.ObjectID Property

[read] the object ID for this item revision.

public virtual Int32 ObjectID {get;}

Property Value

the object ID for this item revision.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

ViewMemberRevision.WebCacheViewMemberRevision.ParentFolder Property

[read] the parent folder (location) of this item revision or NULL.

public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the parent folder (location) of this item revision or NULL.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


Project Property

Borland StarTeam SDK for .NET

ViewMemberRevision.WebCacheViewMemberRevision.Project Property

[read] the Project that contains this item revision.

public virtual Project.WebCacheProject Project {get;}

Property Value

the Project that contains this item revision.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


Time Property

Borland StarTeam SDK for .NET

ViewMemberRevision.WebCacheViewMemberRevision.Time Property

[read] the time of this item revision, when created.

public virtual DateTime Time {get;}

Property Value

the time of this item revision, when created.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

ViewMemberRevision.WebCacheViewMemberRevision.View Property

[read] the View for this item revision.

public virtual View.WebCacheView View {get;}

Property Value

the View for this item revision.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


ViewMemberRevision.WebCacheViewMemberRevision Methods

The methods of the ViewMemberRevision.WebCacheViewMemberRevision class are listed below. For a complete list of ViewMemberRevision.WebCacheViewMemberRevision class members, see the ViewMemberRevision.WebCacheViewMemberRevision Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


ViewMemberRevision.WebCacheViewMemberRevision.Equals Method

Delegate Equals() to com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.Equals(obj).

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


ViewMemberRevision.WebCacheViewMemberRevision.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.

public override int GetHashCode();

Return Value

com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.GetHashCode().

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


ViewMemberRevision.WebCacheViewMemberRevision.ToString Method

Delegate ToString() to com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.

public override string ToString();

Return Value

com.starteam.ViewMemberRevision.WebCacheViewMemberRevision.ToString()

See Also

ViewMemberRevision.WebCacheViewMemberRevision Class | StarTeam Namespace


ViewPollingAgent Class

Used to periodically poll a given view for recent changes, triggering FolderUpdateEvents, ItemUpdateEvents and ViewMemberUpdateEvents describing the changes detected since the last poll.

Events are triggered only for differences detectable across the polling interval. For example, if an item is added then removed without an intervening refresh, then no events would be triggered for that item.

Events are triggered in an order that reflects the times the change actually occurred, when possible. For some older server versions, it is not possible to determine when a move has occurred. It is also not currently possible to determine when a folder or item was removed. Such events are triggered last.

There are two basic ways to use a ViewPollingAgent. The first way is to create one and keep it around for a long time, periodically calling refresh() to trigger events. This is generally faster than creating a new ViewPollingAgent for each refresh(). However, the ViewPollingAgent consumes memory while it is in use.

The second way is to create a new ViewPollingAgent at each polling interval, call refresh() once to trigger events, and save the time returned by refresh() to use later when creating a ViewPollingAgent for the next poll. This is slower, but uses less memory between polls.

For a list of all members of this type, see ViewPollingAgent Members.

System.Object
ViewPollingAgent

public class ViewPollingAgent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewPollingAgent Members | StarTeam Namespace


ViewPollingAgent Members

ViewPollingAgent overview

Public Instance Constructors

ViewPollingAgent Constructor Constructs a new ViewPollingAgent. Use DateTime.CURRENT_SERVER_TIME to triggers events that occur after the current server time.

Public Instance Properties

AllPropertiesRequired [write] Marks all properties as required for a given type. All refresh operations on that type will include all properties.

Public Instance Methods

AddRequiredProperties |
AddRequiredProperty |
Close | Frees all cached resources associated with this ViewPollingAgent, and closes the associated view.
Equals | Delegate Equals() to com.starteam.ViewPollingAgent.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewPollingAgent.
GetType (inherited from Object) | Gets the Type of the current instance.
NewFolderUpdateEventSource |
NewItemUpdateEventSource |
NewViewMemberUpdateEventSource |
Refresh | Refreshes the view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected since the previous refresh (or since the start ViewPollingAgent's start time, if this is the first refresh). The folder tree is always refreshed. In addition, all items a refreshed for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
ToString | Delegate ToString() to com.starteam.ViewPollingAgent.

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent Constructor

Constructs a new ViewPollingAgent. Use DateTime.CURRENT_SERVER_TIME to triggers events that occur after the current server time.

public ViewPollingAgent(
View view,
DateTime startTime
);

Parameters

view
The view whose changes are to be monitored.
startTime
The start time for detecting changes. Often the same as the time returned by the last call to refresh() from a previously instantiated ViewPollingAgent.

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent Properties

The properties of the ViewPollingAgent class are listed below. For a complete list of ViewPollingAgent class members, see the ViewPollingAgent Members topic.

Public Instance Properties

AllPropertiesRequired [write] Marks all properties as required for a given type. All refresh operations on that type will include all properties.

See Also

ViewPollingAgent Class | StarTeam Namespace


AllPropertiesRequired Property

Borland StarTeam SDK for .NET

ViewPollingAgent.AllPropertiesRequired Property

[write] Marks all properties as required for a given type. All refresh operations on that type will include all properties.

public virtual ViewMember.Type AllPropertiesRequired {set;}

Property Value

Marks all properties as required for a given type. All refresh operations on that type will include all properties.

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent Methods

The methods of the ViewPollingAgent class are listed below. For a complete list of ViewPollingAgent class members, see the ViewPollingAgent Members topic.

Public Instance Methods

AddRequiredProperties |
AddRequiredProperty |
Close | Frees all cached resources associated with this ViewPollingAgent, and closes the associated view.
Equals | Delegate Equals() to com.starteam.ViewPollingAgent.
GetHashCode | Delegate GetHashCode() to com.starteam.ViewPollingAgent.
GetType (inherited from Object) | Gets the Type of the current instance.
NewFolderUpdateEventSource |
NewItemUpdateEventSource |
NewViewMemberUpdateEventSource |
Refresh | Refreshes the view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected since the previous refresh (or since the start ViewPollingAgent's start time, if this is the first refresh). The folder tree is always refreshed. In addition, all items a refreshed for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.
ToString | Delegate ToString() to com.starteam.ViewPollingAgent.

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent.AddRequiredProperties Method

public virtual void AddRequiredProperties(
ViewMember.Type type,
PropertyCollection pc
);

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent.AddRequiredProperty Method

public virtual void AddRequiredProperty(
ViewMember.Type type,
Property property
);

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent.Close Method

Frees all cached resources associated with this ViewPollingAgent, and closes the associated view.

public virtual void Close();

See Also

ViewPollingAgent Class | StarTeam Namespace | close


ViewPollingAgent.Equals Method

Delegate Equals() to com.starteam.ViewPollingAgent.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.ViewPollingAgent.Equals(obj).

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent.GetHashCode Method

Delegate GetHashCode() to com.starteam.ViewPollingAgent.

public override int GetHashCode();

Return Value

com.starteam.ViewPollingAgent.GetHashCode().

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent.NewFolderUpdateEventSource Method

public FolderUpdateEventSource NewFolderUpdateEventSource();

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent.NewItemUpdateEventSource Method

public ItemUpdateEventSource NewItemUpdateEventSource(
Item.Type type
);

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent.NewViewMemberUpdateEventSource Method

public ViewMemberUpdateEventSource NewViewMemberUpdateEventSource(
ViewMember.Type type
);

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent.Refresh Method

Refreshes the view, triggering FolderUpdateEvents and ItemUpdateEvents for all changes detected since the previous refresh (or since the start ViewPollingAgent's start time, if this is the first refresh).

The folder tree is always refreshed. In addition, all items a refreshed for each item type that the application has shown an interest in, either by adding an ItemUpdateListener for that item type, or by calling addRequiredPropertyName() with that item type.

public virtual DateTime Refresh();

Return Value

The poll time used for this refresh operation. You can continue to refresh using this ViewPollingAgent, or use this poll time as the start time for a new ViewPollingAgent to pick up where this one left off.

See Also

ViewPollingAgent Class | StarTeam Namespace


ViewPollingAgent.ToString Method

Delegate ToString() to com.starteam.ViewPollingAgent.

public override string ToString();

Return Value

com.starteam.ViewPollingAgent.ToString()

See Also

ViewPollingAgent Class | StarTeam Namespace


WhiteBoard Class

A WhiteBoard is a collection of concepts.

For a list of all members of this type, see WhiteBoard Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
WhiteBoard

public class WhiteBoard : Item

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WhiteBoard Members | StarTeam Namespace


WhiteBoard Members

WhiteBoard overview

Public Static Methods

Create Create a WhiteBoard in the specified parent folder.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Color | [read/write] the Color of this WhiteBoard.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the text in the "Description" property for this WhiteBoard.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this WhiteBoard.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Tags | [read/write] the tags, if any attached to this story
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WhiteBoardID | [read] the whiteboard id.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

WhiteBoard Class | StarTeam Namespace


WhiteBoard Properties

The properties of the WhiteBoard class are listed below. For a complete list of WhiteBoard class members, see the WhiteBoard Members topic.

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
Color | [read/write] the Color of this WhiteBoard.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the text in the "Description" property for this WhiteBoard.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name | [read/write] the Name of this WhiteBoard.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Item) | [read] the folder in which this item exists.
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties | [read] the PropertyCollection of its Type
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
Tags | [read/write] the tags, if any attached to this story
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.
WhiteBoardID | [read] the whiteboard id.

See Also

WhiteBoard Class | StarTeam Namespace


Color Property

Borland StarTeam SDK for .NET

WhiteBoard.Color Property

[read/write] the Color of this WhiteBoard.

public virtual String Color {get; set;}

Property Value

the Color of this WhiteBoard.

See Also

WhiteBoard Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

WhiteBoard.Description Property

[read/write] the text in the "Description" property for this WhiteBoard.

public virtual String Description {get; set;}

Property Value

the text in the "Description" property for this WhiteBoard.

See Also

WhiteBoard Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

WhiteBoard.Name Property

[read/write] the Name of this WhiteBoard.

public virtual String Name {get; set;}

Property Value

the Name of this WhiteBoard.

See Also

WhiteBoard Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

WhiteBoard.Properties Property

[read] the PropertyCollection of its Type

public virtual WhiteBoard.Type.PropertyCollection Properties {get;}

Property Value

the PropertyCollection of its Type

See Also

WhiteBoard Class | StarTeam Namespace


Tags Property

Borland StarTeam SDK for .NET

WhiteBoard.Tags Property

[read/write] the tags, if any attached to this story

public virtual EnumeratedValue[] Tags {get; set;}

Property Value

the tags, if any attached to this story

See Also

WhiteBoard Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

WhiteBoard.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

WhiteBoard Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

WhiteBoard.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

WhiteBoard Class | StarTeam Namespace


WhiteBoardID Property

Borland StarTeam SDK for .NET

WhiteBoard.WhiteBoardID Property

[read] the whiteboard id.

public virtual Int32 WhiteBoardID {get;}

Property Value

the whiteboard id.

See Also

WhiteBoard Class | StarTeam Namespace


WhiteBoard Methods

The methods of the WhiteBoard class are listed below. For a complete list of WhiteBoard class members, see the WhiteBoard Members topic.

Public Static Methods

Create Create a WhiteBoard in the specified parent folder.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from ViewMember) | Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Item) | Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

WhiteBoard Class | StarTeam Namespace


WhiteBoard.Create Method

Create a WhiteBoard in the specified parent folder.

public static WhiteBoard Create(
Folder prnt
);

Parameters

prnt
the parent folder

Return Value

a new WhiteBoard Object.

See Also

WhiteBoard Class | StarTeam Namespace


WhiteBoard.Type Class

Type meta-data (schema) for WhiteBoard object instances.

For a list of all members of this type, see WhiteBoard.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
WhiteBoard.Type

new public class WhiteBoard.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WhiteBoard.Type Members | StarTeam Namespace


WhiteBoard.Type Members

WhiteBoard.Type overview

Public Static Properties

NAME

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.WhiteBoard.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.WhiteBoard.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type Properties

The properties of the WhiteBoard.Type class are listed below. For a complete list of WhiteBoard.Type class members, see the WhiteBoard.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

AssignableProperty | [read] a user property if this type is assignable or NULL
Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DescriptionPropertyEx | [read] a description property if this type provides it or NULL
DisplayName | [write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server
DisplayNameTranslations | [write] Sets a copy of the display name translations for this type. Only supported for custom components
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsEnabled | [read/write] true if this type is enabled
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsNew | [read] true if this is a new type
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
MetaProperties | [read/write] a java.util.Map containing meta properties defined by the client application
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
PriorityPropertyEx | [read] a priority property if this type provides it or NULL
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
PropertiesEx | [write]
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.
StatusPropertyEx | [read] a status property if this type provides status or NULL
SubTypePropertyEx | [read] a sub type property if this type provides it or NULL
SummaryPropertyEx | [read] a summary property if this type provides it or NULL

See Also

WhiteBoard.Type Class | StarTeam Namespace


AssignableProperty Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.AssignableProperty Property

[read] a user property if this type is assignable or NULL

new public virtual Property AssignableProperty {get;}

Property Value

a user property if this type is assignable or NULL

See Also

WhiteBoard.Type Class | StarTeam Namespace


DescriptionPropertyEx Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.DescriptionPropertyEx Property

[read] a description property if this type provides it or NULL

new public virtual TextProperty DescriptionPropertyEx {get;}

Property Value

a description property if this type provides it or NULL

See Also

WhiteBoard.Type Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.DisplayName Property

[write] Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

new public virtual String DisplayName {set;}

Property Value

Sets the display name for this type. Only supported for custom components This feature was first introduced in the 12.0 server

See Also

WhiteBoard.Type Class | StarTeam Namespace


DisplayNameTranslations Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.DisplayNameTranslations Property

[write] Sets a copy of the display name translations for this type. Only supported for custom components

new public virtual Translations DisplayNameTranslations {set;}

Property Value

Sets a copy of the display name translations for this type. Only supported for custom components

See Also

WhiteBoard.Type Class | StarTeam Namespace


IsEnabled Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.IsEnabled Property

[read/write] true if this type is enabled

new public virtual Boolean IsEnabled {get; set;}

Property Value

true if this type is enabled

See Also

WhiteBoard.Type Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.IsNew Property

[read] true if this is a new type

new public virtual Boolean IsNew {get;}

Property Value

true if this is a new type

See Also

WhiteBoard.Type Class | StarTeam Namespace


MetaProperties Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.MetaProperties Property

[read/write] a java.util.Map containing meta properties defined by the client application

new public virtual Map MetaProperties {get; set;}

Property Value

a java.util.Map containing meta properties defined by the client application

See Also

WhiteBoard.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.NAME Property

new public static String NAME {get;}

See Also

WhiteBoard.Type Class | StarTeam Namespace


PriorityPropertyEx Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PriorityPropertyEx Property

[read] a priority property if this type provides it or NULL

new public virtual Property PriorityPropertyEx {get;}

Property Value

a priority property if this type provides it or NULL

See Also

WhiteBoard.Type Class | StarTeam Namespace


PropertiesEx Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertiesEx Property

[write]

new public virtual PropertyCollection PropertiesEx {set;}

See Also

WhiteBoard.Type Class | StarTeam Namespace


StatusPropertyEx Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.StatusPropertyEx Property

[read] a status property if this type provides status or NULL

new public virtual EnumeratedProperty StatusPropertyEx {get;}

Property Value

a status property if this type provides status or NULL

See Also

WhiteBoard.Type Class | StarTeam Namespace


SubTypePropertyEx Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.SubTypePropertyEx Property

[read] a sub type property if this type provides it or NULL

new public virtual Property SubTypePropertyEx {get;}

Property Value

a sub type property if this type provides it or NULL

See Also

WhiteBoard.Type Class | StarTeam Namespace


SummaryPropertyEx Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.SummaryPropertyEx Property

[read] a summary property if this type provides it or NULL

new public virtual TextProperty SummaryPropertyEx {get;}

Property Value

a summary property if this type provides it or NULL

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type Methods

The methods of the WhiteBoard.Type class are listed below. For a complete list of WhiteBoard.Type class members, see the WhiteBoard.Type Members topic.

Public Static Methods

FromXml Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

Public Instance Methods

CloneComponentDefinition | Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.
Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
CreateItem | Creates a new StarTeam item of this type.
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.WhiteBoard.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.WhiteBoard.Type.
ToXml | Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.
Update | Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type.CloneComponentDefinition Method

Returns a component definition (xml) which is a based on this item type. The xml definition can be used to build a new custom component based on this item type. Note that header and client/server calculated properties will not exported.

new public virtual string CloneComponentDefinition(
String typeName,
String displayName
);

Parameters

typeName
name of the new custom component.
displayName
display name of the new custom component.

Return Value

an cloned xml representation of this type.

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type.CreateItem Method

Creates a new StarTeam item of this type.

new public virtual Item CreateItem(
Folder parent
);

Parameters

parent
The folder in which the new item will be created.

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type.Equals Method

Delegate Equals() to com.starteam.WhiteBoard.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WhiteBoard.Type.Equals(obj).

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type.FromXml Method

Create a Type from a specified xml definition. The returned Type object is new, i.e. it is not a server object. It simply represents a data structure mapping Type and Properties to the underlying xml representation. An application may use thus api as a convenient method of serializing xml representations of types out to disk and back, until ready to actually create the type on the server. Note that once a Type has been created on the server, its rendering .xml can no longer be used to manipulate that same type. It could however be used (with appropriate changes to type name, display name, etc) to create a completely different type.

new public static Type FromXml(
Server s,
String xmlDefinition
);

Parameters

s
The server in whose context the type and its properties is being defined
xmlDefinition
an xml representation of the type, possibly created using Type and Property objects, then serialized out as an .xml file to disk

Return Value

an Item or Tree Item type as the case may be

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.WhiteBoard.Type.

public override int GetHashCode();

Return Value

com.starteam.WhiteBoard.Type.GetHashCode().

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type.ToString Method

Delegate ToString() to com.starteam.WhiteBoard.Type.

public override string ToString();

Return Value

com.starteam.WhiteBoard.Type.ToString()

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type.ToXml Method

Returns an xml representation of this type The xml representation is used to specify the type definition when creating custom components.

new public virtual string ToXml();

Return Value

an xml representation of this type

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type.Update Method

Saves changes to the repository. If this is a newly created type, then construct the xml representation and stream that over else Saves changes to the repository. Currently, only the display name and it's translations may be changed

new public virtual void Update();

See Also

WhiteBoard.Type Class | StarTeam Namespace


WhiteBoard.Type.ColorProperty Class

The property type of the Color property

For a list of all members of this type, see WhiteBoard.Type.ColorProperty Members.

System.Object
Property
VectorProperty
TextProperty
WhiteBoard.Type.ColorProperty

public class WhiteBoard.Type.ColorProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WhiteBoard.Type.ColorProperty Members | StarTeam Namespace


WhiteBoard.Type.ColorProperty Members

WhiteBoard.Type.ColorProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WhiteBoard.Type.ColorProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.Type.ColorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WhiteBoard.Type.ColorProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WhiteBoard.Type.ColorProperty Class | StarTeam Namespace


WhiteBoard.Type.ColorProperty Properties

The properties of the WhiteBoard.Type.ColorProperty class are listed below. For a complete list of WhiteBoard.Type.ColorProperty class members, see the WhiteBoard.Type.ColorProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

WhiteBoard.Type.ColorProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.ColorProperty.NAME Property

public static String NAME {get;}

See Also

WhiteBoard.Type.ColorProperty Class | StarTeam Namespace


WhiteBoard.Type.ColorProperty Methods

The methods of the WhiteBoard.Type.ColorProperty class are listed below. For a complete list of WhiteBoard.Type.ColorProperty class members, see the WhiteBoard.Type.ColorProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WhiteBoard.Type.ColorProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.Type.ColorProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WhiteBoard.Type.ColorProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WhiteBoard.Type.ColorProperty Class | StarTeam Namespace


WhiteBoard.Type.ColorProperty.Equals Method

Delegate Equals() to com.starteam.WhiteBoard.Type.ColorProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WhiteBoard.Type.ColorProperty.Equals(obj).

See Also

WhiteBoard.Type.ColorProperty Class | StarTeam Namespace


WhiteBoard.Type.ColorProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.WhiteBoard.Type.ColorProperty.

public override int GetHashCode();

Return Value

com.starteam.WhiteBoard.Type.ColorProperty.GetHashCode().

See Also

WhiteBoard.Type.ColorProperty Class | StarTeam Namespace


WhiteBoard.Type.ColorProperty.ToString Method

Delegate ToString() to com.starteam.WhiteBoard.Type.ColorProperty.

public override string ToString();

Return Value

com.starteam.WhiteBoard.Type.ColorProperty.ToString()

See Also

WhiteBoard.Type.ColorProperty Class | StarTeam Namespace


WhiteBoard.Type.PropertyCollection Class

The PropertyCollection of a WhiteBoard

For a list of all members of this type, see WhiteBoard.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
WhiteBoard.Type.PropertyCollection

new public class WhiteBoard.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WhiteBoard.Type.PropertyCollection Members | StarTeam Namespace


WhiteBoard.Type.PropertyCollection Members

WhiteBoard.Type.PropertyCollection overview

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COLOR |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAG |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WHITE_BOARD_ID |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.WhiteBoard.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.WhiteBoard.Type.PropertyCollection.

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


WhiteBoard.Type.PropertyCollection Properties

The properties of the WhiteBoard.Type.PropertyCollection class are listed below. For a complete list of WhiteBoard.Type.PropertyCollection class members, see the WhiteBoard.Type.PropertyCollection Members topic.

Public Instance Properties

ATTACHMENT_COUNT |
ATTACHMENT_IDS |
ATTACHMENT_NAMES |
BRANCH_STATE |
COLOR |
COMMENT |
COMMENT_ID |
CONFIGURATION_TIME |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DEFAULT_ACTION (inherited from PropertyCollection) |
DELETED_BY |
DELETED_TIME |
DESCRIPTION |
DIFFERENCE_TYPE (inherited from PropertyCollection) |
DOT_NOTATION |
END_MODIFIED_TIME |
EXCLUSIVE_LOCKER |
EXTERNAL_ID |
EXTERNAL_URL |
FLAGGED_BY_USERS |
GLOBAL_ID |
ID |
IS_ACTION_OVERRIDDEN (inherited from PropertyCollection) |
IS_BRANCH_ON_CHANGE |
IS_CHECKED (inherited from PropertyCollection) |
IS_READ_ONLY |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
ITEM_DELETED_BY |
ITEM_DELETED_TIME |
MERGE_ACTION (inherited from PropertyCollection) |
MERGE_STATUS (inherited from PropertyCollection) |
MODIFIED_BY |
MODIFIED_TIME |
MY_LOCK (inherited from PropertyCollection) |
NAME |
NON_EXCLUSIVE_LOCKERS |
NOTIFICATION_COUNT |
NOTIFICATION_IDS |
PARENT_BRANCH_LENGTH |
PARENT_BRANCH_REVISION |
PARENT_OBJECT_ID |
REVISION_FLAGS |
REVISION_NUMBER |
ROOT_OBJECT_ID |
SHARE_STATE |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TAG |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
UNREAD_BY_USERS |
VERSION_METADATA |
VERSION_METADATA_IDS |
VIEW |
VIEWMEMBER_ID (inherited from PropertyCollection) |
WHITE_BOARD_ID |

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_COUNT Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.ATTACHMENT_COUNT Property

public ViewMember.Type.AttachmentCountProperty ATTACHMENT_COUNT {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_IDS Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.ATTACHMENT_IDS Property

public ViewMember.Type.AttachmentIDsProperty ATTACHMENT_IDS {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


ATTACHMENT_NAMES Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.ATTACHMENT_NAMES Property

public ViewMember.Type.AttachmentNamesProperty ATTACHMENT_NAMES {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


BRANCH_STATE Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.BRANCH_STATE Property

public TypedResource.Type.BranchStateProperty BRANCH_STATE {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


COLOR Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.COLOR Property

public WhiteBoard.Type.ColorProperty COLOR {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.COMMENT Property

public ViewMember.Type.CommentProperty COMMENT {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


CONFIGURATION_TIME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.CONFIGURATION_TIME Property

public ViewMember.Type.ConfigurationTimeProperty CONFIGURATION_TIME {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


DESCRIPTION Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.DESCRIPTION Property

public LiveObject.Type.DescriptionProperty DESCRIPTION {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


DOT_NOTATION Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.DOT_NOTATION Property

public ViewMember.Type.DotNotationProperty DOT_NOTATION {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


EXCLUSIVE_LOCKER Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.EXCLUSIVE_LOCKER Property

public ViewMember.Type.ExclusiveLockerProperty EXCLUSIVE_LOCKER {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_ID Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.EXTERNAL_ID Property

public ViewMember.Type.ExternalIDProperty EXTERNAL_ID {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


EXTERNAL_URL Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.EXTERNAL_URL Property

public ViewMember.Type.ExternalURLProperty EXTERNAL_URL {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


FLAGGED_BY_USERS Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.FLAGGED_BY_USERS Property

public ViewMember.Type.FlaggedByUsersProperty FLAGGED_BY_USERS {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


GLOBAL_ID Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.GLOBAL_ID Property

public LiveObject.Type.GlobalIDProperty GLOBAL_ID {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


IS_BRANCH_ON_CHANGE Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.IS_BRANCH_ON_CHANGE Property

public ViewMember.Type.IsBranchOnChangeProperty IS_BRANCH_ON_CHANGE {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


IS_READ_ONLY Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.IS_READ_ONLY Property

public ViewMember.Type.IsReadOnlyProperty IS_READ_ONLY {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_BY Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.ITEM_DELETED_BY Property

public ViewMember.Type.ItemDeletedByProperty ITEM_DELETED_BY {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


ITEM_DELETED_TIME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.ITEM_DELETED_TIME Property

public ViewMember.Type.ItemDeletedTimeProperty ITEM_DELETED_TIME {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.NAME Property

public LiveObject.Type.NameProperty NAME {get;}

Property Value

The internal name of the property

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


NON_EXCLUSIVE_LOCKERS Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.NON_EXCLUSIVE_LOCKERS Property

public ViewMember.Type.NonExclusiveLockersProperty NON_EXCLUSIVE_LOCKERS {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_COUNT Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.NOTIFICATION_COUNT Property

public Item.Type.NotificationCountProperty NOTIFICATION_COUNT {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


NOTIFICATION_IDS Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.NOTIFICATION_IDS Property

public Item.Type.NotificationIDsProperty NOTIFICATION_IDS {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_LENGTH Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.PARENT_BRANCH_LENGTH Property

public ViewMember.Type.ParentBranchLengthProperty PARENT_BRANCH_LENGTH {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


PARENT_BRANCH_REVISION Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.PARENT_BRANCH_REVISION Property

public ViewMember.Type.ParentBranchRevisionProperty PARENT_BRANCH_REVISION {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


PARENT_OBJECT_ID Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.PARENT_OBJECT_ID Property

public ViewMember.Type.ParentObjectIDProperty PARENT_OBJECT_ID {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


ROOT_OBJECT_ID Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.ROOT_OBJECT_ID Property

public ViewMember.Type.RootObjectIDProperty ROOT_OBJECT_ID {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


SHARE_STATE Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.SHARE_STATE Property

public ViewMember.Type.ShareStateProperty SHARE_STATE {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


TAG Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.TAG Property

public Item.Type.TagProperty TAG {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


UNREAD_BY_USERS Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.UNREAD_BY_USERS Property

public ViewMember.Type.UnreadByUsersProperty UNREAD_BY_USERS {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.VERSION_METADATA Property

public Item.Type.VersionMetadataProperty VERSION_METADATA {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


VERSION_METADATA_IDS Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.VERSION_METADATA_IDS Property

public Item.Type.VersionMetadataIDsProperty VERSION_METADATA_IDS {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


VIEW Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.VIEW Property

public TypedResource.Type.ViewProperty VIEW {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


WHITE_BOARD_ID Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.PropertyCollection.WHITE_BOARD_ID Property

public WhiteBoard.Type.WhiteBoardIDProperty WHITE_BOARD_ID {get;}

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


WhiteBoard.Type.PropertyCollection Methods

The methods of the WhiteBoard.Type.PropertyCollection class are listed below. For a complete list of WhiteBoard.Type.PropertyCollection class members, see the WhiteBoard.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.WhiteBoard.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.WhiteBoard.Type.PropertyCollection.

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


WhiteBoard.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.WhiteBoard.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WhiteBoard.Type.PropertyCollection.Equals(obj).

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


WhiteBoard.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.WhiteBoard.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.WhiteBoard.Type.PropertyCollection.GetHashCode().

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


WhiteBoard.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.WhiteBoard.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.WhiteBoard.Type.PropertyCollection.ToString()

See Also

WhiteBoard.Type.PropertyCollection Class | StarTeam Namespace


WhiteBoard.Type.WhiteBoardIDProperty Class

The property type of the WhiteboardID property

For a list of all members of this type, see WhiteBoard.Type.WhiteBoardIDProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
WhiteBoard.Type.WhiteBoardIDProperty

public class WhiteBoard.Type.WhiteBoardIDProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WhiteBoard.Type.WhiteBoardIDProperty Members | StarTeam Namespace


WhiteBoard.Type.WhiteBoardIDProperty Members

WhiteBoard.Type.WhiteBoardIDProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WhiteBoard.Type.WhiteBoardIDProperty Class | StarTeam Namespace


WhiteBoard.Type.WhiteBoardIDProperty Properties

The properties of the WhiteBoard.Type.WhiteBoardIDProperty class are listed below. For a complete list of WhiteBoard.Type.WhiteBoardIDProperty class members, see the WhiteBoard.Type.WhiteBoardIDProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

WhiteBoard.Type.WhiteBoardIDProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WhiteBoard.Type.WhiteBoardIDProperty.NAME Property

public static String NAME {get;}

See Also

WhiteBoard.Type.WhiteBoardIDProperty Class | StarTeam Namespace


WhiteBoard.Type.WhiteBoardIDProperty Methods

The methods of the WhiteBoard.Type.WhiteBoardIDProperty class are listed below. For a complete list of WhiteBoard.Type.WhiteBoardIDProperty class members, see the WhiteBoard.Type.WhiteBoardIDProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WhiteBoard.Type.WhiteBoardIDProperty Class | StarTeam Namespace


WhiteBoard.Type.WhiteBoardIDProperty.Equals Method

Delegate Equals() to com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.Equals(obj).

See Also

WhiteBoard.Type.WhiteBoardIDProperty Class | StarTeam Namespace


WhiteBoard.Type.WhiteBoardIDProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.

public override int GetHashCode();

Return Value

com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.GetHashCode().

See Also

WhiteBoard.Type.WhiteBoardIDProperty Class | StarTeam Namespace


WhiteBoard.Type.WhiteBoardIDProperty.ToString Method

Delegate ToString() to com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.

public override string ToString();

Return Value

com.starteam.WhiteBoard.Type.WhiteBoardIDProperty.ToString()

See Also

WhiteBoard.Type.WhiteBoardIDProperty Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard Class

Item accessor for cached SDK WhiteBoard items contained objects are obtained from the artifact cache

For a list of all members of this type, see WhiteBoard.WebCacheWhiteBoard Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
WhiteBoard.WebCacheWhiteBoard

public class WhiteBoard.WebCacheWhiteBoard : WebCacheItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WhiteBoard.WebCacheWhiteBoard Members | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard Members

WhiteBoard.WebCacheWhiteBoard overview

Public Static Methods

Create Overloaded.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Color | [read/write] the color of this WhiteBoard.
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this WhiteBoard.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Tags | [read/write] the tags, if any attached to this story instance
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WhiteBoardID | [read] the whiteboard id.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.WhiteBoard.WebCacheWhiteBoard.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.WebCacheWhiteBoard.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.WhiteBoard.WebCacheWhiteBoard.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard Properties

The properties of the WhiteBoard.WebCacheWhiteBoard class are listed below. For a complete list of WhiteBoard.WebCacheWhiteBoard class members, see the WhiteBoard.WebCacheWhiteBoard Members topic.

Public Instance Properties

Attachments | [read/write] an array of attachments for this ViewMember
ChangePackages | [read] the Change Packages linked to this process item
Color | [read/write] the color of this WhiteBoard.
Comment | [read/write] the Comment attached to this view member
Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DeletedBy | [read] The User object of the user who deleted this view member, or null.
DeletedTime | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description | [read/write] the description of this WhiteBoard.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation | [read] The dot notation identification of this resource version.
ExternalID | [read/write] The external ID describing this revision of the item.
ExternalURL | [read/write] The external URL describing this revision of the item.
History | [read] the ViewMemberCollection of historical revisions
ID | [read] the ID of the underlying object
Identifier | [read] the integer identifier value of this live object instance
IdentifierProperty | [read] the identifier property for this item type
IsBookmarked | [read] boolean true if this artifact has been flagged by this user
IsDeleted | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty | [read] true if this object is dirty
IsFloating | [read] true if this artifact is floating
IsFromHistory | [read] true if this is a historical resource obtained from the history.
IsNew | [read] true if this resource has not yet been stored in the server.
IsPinned | [read] true if this artifact is pinned
IsUnread | [read] boolean false if this artifact has been marked as read in this user context
Labels | [read] an array of labels
Links | [read] an array of web cache trace objects
Locker | [read] The User object of the exclusive locker of this item.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
NotifiedUsers | [read] The users who are notified.
ObjectID | [read] The unique identifier for the underlying object.
ParentFolder | [read] the folder in which this item exists.
PresentationID | [read] the unique integer identifier for this resource.
RestoredShare | [read] a 'restored' share from the tip matching the share tree of a deleted item
RevisionNumber | [read] The revision number for this object revision.
Rights | [read/write] the access rights assigned to this filter
RootObjectID | [read] The root object ID for this resource.
Server | [read] the Server for this cached object
ShareTree | [read] the ShareTree of the view member
ShortComment | [read/write] the ShortComment for this artifact
Tags | [read/write] the tags, if any attached to this story instance
Traces | [read] a Trace[] of applicable Traces
VersionMetadata | [read] the version metadata of this revision
VersionMetadataIDs | [read] the version metadata of this revision
View | [read] The WebCacheView containing this WebCacheViewMember.
ViewMemberRevisions | [read] all the revisions for the view member
ViewVersion | [read] The view version number of this item.
WhiteBoardID | [read] the whiteboard id.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Attachments Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Attachments Property

[read/write] an array of attachments for this ViewMember

new public virtual WebCacheContent[] Attachments {get; set;}

Property Value

an array of attachments for this ViewMember

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ChangePackages Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ChangePackages Property

[read] the Change Packages linked to this process item

new public virtual WebCacheChangePackage[] ChangePackages {get;}

Property Value

the Change Packages linked to this process item

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Color Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Color Property

[read/write] the color of this WhiteBoard.

public virtual String Color {get; set;}

Property Value

the color of this WhiteBoard.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Comment Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Comment Property

[read/write] the Comment attached to this view member

new public virtual String Comment {get; set;}

Property Value

the Comment attached to this view member

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


DeletedBy Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.DeletedBy Property

[read] The User object of the user who deleted this view member, or null.

new public virtual User.WebCacheUser DeletedBy {get;}

Property Value

The User object of the user who deleted this view member, or null.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


DeletedTime Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.DeletedTime Property

[read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

new public virtual DateTime DeletedTime {get;}

Property Value

The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Description Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Description Property

[read/write] the description of this WhiteBoard.

public virtual String Description {get; set;}

Property Value

the description of this WhiteBoard.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


DotNotation Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.DotNotation Property

[read] The dot notation identification of this resource version.

new public virtual DotNotation DotNotation {get;}

Property Value

The dot notation identification of this resource version.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ExternalID Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ExternalID Property

[read/write] The external ID describing this revision of the item.

new public virtual String ExternalID {get; set;}

Property Value

The external ID describing this revision of the item.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ExternalURL Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ExternalURL Property

[read/write] The external URL describing this revision of the item.

new public virtual String ExternalURL {get; set;}

Property Value

The external URL describing this revision of the item.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


History Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.History Property

[read] the ViewMemberCollection of historical revisions

new public virtual WebCacheViewMember[] History {get;}

Property Value

the ViewMemberCollection of historical revisions

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Identifier Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Identifier Property

[read] the integer identifier value of this live object instance

new public virtual Int32 Identifier {get;}

Property Value

the integer identifier value of this live object instance

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


IdentifierProperty Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.IdentifierProperty Property

[read] the identifier property for this item type

new public virtual IntegerProperty.WebCacheIntegerProperty IdentifierProperty {get;}

Property Value

the identifier property for this item type

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


IsBookmarked Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.IsBookmarked Property

[read] boolean true if this artifact has been flagged by this user

new public virtual Boolean IsBookmarked {get;}

Property Value

boolean true if this artifact has been flagged by this user

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.IsDeleted Property

[read] True if this view member is known to have been deleted; false otherwise.

new public virtual Boolean IsDeleted {get;}

Property Value

True if this view member is known to have been deleted; false otherwise.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


IsFloating Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.IsFloating Property

[read] true if this artifact is floating

new public virtual Boolean IsFloating {get;}

Property Value

true if this artifact is floating

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


IsFromHistory Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.IsFromHistory Property

[read] true if this is a historical resource obtained from the history.

new public virtual Boolean IsFromHistory {get;}

Property Value

true if this is a historical resource obtained from the history.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


IsPinned Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.IsPinned Property

[read] true if this artifact is pinned

new public virtual Boolean IsPinned {get;}

Property Value

true if this artifact is pinned

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


IsUnread Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.IsUnread Property

[read] boolean false if this artifact has been marked as read in this user context

new public virtual Boolean IsUnread {get;}

Property Value

boolean false if this artifact has been marked as read in this user context

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Labels Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Labels Property

[read] an array of labels

new public virtual WebCacheLabel[] Labels {get;}

Property Value

an array of labels

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Links Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Links Property

[read] an array of web cache trace objects

new public virtual WebCacheTrace[] Links {get;}

Property Value

an array of web cache trace objects

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Locker Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Locker Property

[read] The User object of the exclusive locker of this item.

new public virtual User.WebCacheUser Locker {get;}

Property Value

The User object of the exclusive locker of this item.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Name Property

new public virtual String Name {get; set;}

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


NotifiedUsers Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.NotifiedUsers Property

[read] The users who are notified.

new public virtual WebCacheUser[] NotifiedUsers {get;}

Property Value

The users who are notified.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ParentFolder Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ParentFolder Property

[read] the folder in which this item exists.

new public virtual Folder.WebCacheFolder ParentFolder {get;}

Property Value

the folder in which this item exists.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


PresentationID Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.PresentationID Property

[read] the unique integer identifier for this resource.

new public virtual Int32 PresentationID {get;}

Property Value

the unique integer identifier for this resource.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


RestoredShare Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.RestoredShare Property

[read] a 'restored' share from the tip matching the share tree of a deleted item

new public virtual Item.WebCacheItem RestoredShare {get;}

Property Value

a 'restored' share from the tip matching the share tree of a deleted item

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


RevisionNumber Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.RevisionNumber Property

[read] The revision number for this object revision.

new public virtual Int32 RevisionNumber {get;}

Property Value

The revision number for this object revision.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Rights Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Rights Property

[read/write] the access rights assigned to this filter

new public virtual WebCacheACE[] Rights {get; set;}

Property Value

the access rights assigned to this filter

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


RootObjectID Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.RootObjectID Property

[read] The root object ID for this resource.

new public virtual Int32 RootObjectID {get;}

Property Value

The root object ID for this resource.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ShareTree Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ShareTree Property

[read] the ShareTree of the view member

new public virtual WebCacheShare[] ShareTree {get;}

Property Value

the ShareTree of the view member

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ShortComment Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ShortComment Property

[read/write] the ShortComment for this artifact

new public virtual String ShortComment {get; set;}

Property Value

the ShortComment for this artifact

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Tags Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Tags Property

[read/write] the tags, if any attached to this story instance

public virtual EnumeratedValue[] Tags {get; set;}

Property Value

the tags, if any attached to this story instance

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Traces Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Traces Property

[read] a Trace[] of applicable Traces

new public virtual WebCacheTrace[] Traces {get;}

Property Value

a Trace[] of applicable Traces

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


VersionMetadata Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.VersionMetadata Property

[read] the version metadata of this revision

public virtual String VersionMetadata {get;}

Property Value

the version metadata of this revision

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


VersionMetadataIDs Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.VersionMetadataIDs Property

[read] the version metadata of this revision

public virtual String VersionMetadataIDs {get;}

Property Value

the version metadata of this revision

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


View Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.View Property

[read] The WebCacheView containing this WebCacheViewMember.

new public virtual View.WebCacheView View {get;}

Property Value

The WebCacheView containing this WebCacheViewMember.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ViewMemberRevisions Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ViewMemberRevisions Property

[read] all the revisions for the view member

new public virtual WebCacheViewMemberRevision[] ViewMemberRevisions {get;}

Property Value

all the revisions for the view member

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


ViewVersion Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.ViewVersion Property

[read] The view version number of this item.

new public virtual Int32 ViewVersion {get;}

Property Value

The view version number of this item.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoardID Property

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.WhiteBoardID Property

[read] the whiteboard id.

public virtual Int32 WhiteBoardID {get;}

Property Value

the whiteboard id.

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard Methods

The methods of the WhiteBoard.WebCacheWhiteBoard class are listed below. For a complete list of WhiteBoard.WebCacheWhiteBoard class members, see the WhiteBoard.WebCacheWhiteBoard Members topic.

Public Static Methods

Create Overloaded.

Public Instance Methods

AddNotifiedUser |
AddTo |
Copy |
Equals | Delegate Equals() to com.starteam.WhiteBoard.WebCacheWhiteBoard.
GetDisplayValue |
GetHashCode | Delegate GetHashCode() to com.starteam.WhiteBoard.WebCacheWhiteBoard.
GetTracedResources |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Lock | Overloaded.
ModifyBookmark | Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.
ModifyReadStatus | Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.
MoveTo | Overloaded.
PinTo | Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
RemoveNotifiedUser |
SetValue | Overloaded. set the value of the property as specified by name
ShareTo |
ToRESTUrl | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.WhiteBoard.WebCacheWhiteBoard.
Unlock | unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted
Unpin | Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction
UpdateRevisionComment | Change the revision comment for this view member

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.AddNotifiedUser Method

new public virtual void AddNotifiedUser(
User.WebCacheUser user
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.Copy Method

new public virtual WebCacheItem Copy(
Folder.WebCacheFolder destination,
Boolean deep
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Create Method

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Create Method

Overload List

public static WebCacheWhiteBoard Create(ArtifactCacheManager.Context,Folder.WebCacheFolder);

new public static WebCacheItem Create(ArtifactCacheManager.Context,Folder.WebCacheFolder,Item.Type.WebCacheItemType);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder)

public static WebCacheWhiteBoard Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.Create Overload List


WhiteBoard.WebCacheWhiteBoard.Create Method (ArtifactCacheManager#Context, Folder#WebCacheFolder, Item#Type#WebCacheItemType)

new public static WebCacheItem Create(
ArtifactCacheManager.Context cntxt,
Folder.WebCacheFolder parent,
Item.Type.WebCacheItemType typ
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.Create Overload List


WhiteBoard.WebCacheWhiteBoard.Equals Method

Delegate Equals() to com.starteam.WhiteBoard.WebCacheWhiteBoard.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WhiteBoard.WebCacheWhiteBoard.Equals(obj).

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.GetDisplayValue Method

new public virtual string GetDisplayValue(
Property.WebCacheProperty prop
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.GetHashCode Method

Delegate GetHashCode() to com.starteam.WhiteBoard.WebCacheWhiteBoard.

public override int GetHashCode();

Return Value

com.starteam.WhiteBoard.WebCacheWhiteBoard.GetHashCode().

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.GetTracedResources Method

new public virtual WebCacheViewMember[] GetTracedResources(
ViewMember.Type.WebCacheViewMemberType typ,
Boolean direction,
Filter.WebCacheFilter fltr
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.GetValue Overload List


WhiteBoard.WebCacheWhiteBoard.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.GetValue Overload List


WhiteBoard.WebCacheWhiteBoard.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Lock Method

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.Lock Method

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

Overload List

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

new public virtual void Lock(ViewMember.LockType,Boolean);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WebCacheViewMemberCollection


WhiteBoard.WebCacheWhiteBoard.Lock Method ()

lock the underlying viewmember using a pooled connection An exclusive lock is acquired on this viewmember alone, and is not transacted In the process, break a lock owned by another user, if any.

new public virtual void Lock();

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.Lock Overload List | WebCacheViewMemberCollection


WhiteBoard.WebCacheWhiteBoard.Lock Method (ViewMember#LockType, Boolean)

new public virtual void Lock(
ViewMember.LockType lt,
Boolean breakLock
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.Lock Overload List


WhiteBoard.WebCacheWhiteBoard.ModifyBookmark Method

Flags (bookmarks) this artifact for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. Folders cannot be bookmarked.

new public virtual void ModifyBookmark(
Boolean flag
);

Parameters

flag
this item's new bookmark status

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | NAME


WhiteBoard.WebCacheWhiteBoard.ModifyReadStatus Method

Modifies this item's read status for the user in this context. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the user in this context is affected. File or Folder items cannot be marked as read.

new public virtual void ModifyReadStatus(
Boolean bSetAsRead
);

Parameters

bSetAsRead
this item's new read status

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | NAME


MoveTo Method

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.MoveTo Method

Overload List

new public virtual void MoveTo(Folder.WebCacheFolder);

new public virtual void MoveTo(View.WebCacheView);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.MoveTo Method (Folder#WebCacheFolder)

new public virtual void MoveTo(
Folder.WebCacheFolder parent
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.MoveTo Overload List


WhiteBoard.WebCacheWhiteBoard.MoveTo Method (View#WebCacheView)

new public virtual void MoveTo(
View.WebCacheView parent
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.MoveTo Overload List


WhiteBoard.WebCacheWhiteBoard.PinTo Method

Changes the behavior of this artifact such that it is pinned to the specified time. Specify NULL to have the artifact float at the tip The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void PinTo(
DateTime dt
);

Parameters

dt
The time at which the configuration is pinned or NULL for this artifact to float at the tip

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | isFloating | isPinned | unpin


WhiteBoard.WebCacheWhiteBoard.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WebCacheViewMemberCollection


WhiteBoard.WebCacheWhiteBoard.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.RemoveNotifiedUser Method

new public virtual void RemoveNotifiedUser(
User.WebCacheUser user
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

WhiteBoard.WebCacheWhiteBoard.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.SetValue Overload List


WhiteBoard.WebCacheWhiteBoard.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WhiteBoard.WebCacheWhiteBoard.SetValue Overload List


WhiteBoard.WebCacheWhiteBoard.ShareTo Method

new public virtual WebCacheItem ShareTo(
Folder.WebCacheFolder toFolder
);

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.ToRESTUrl Method

Resolves this StarTeam view member to a corresponding URL using an ID based scheme

new public virtual string ToRESTUrl();

Return Value

a String URL that uniquely identifies the resource

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.ToString Method

Delegate ToString() to com.starteam.WhiteBoard.WebCacheWhiteBoard.

public override string ToString();

Return Value

com.starteam.WhiteBoard.WebCacheWhiteBoard.ToString()

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


WhiteBoard.WebCacheWhiteBoard.Unlock Method

unlock the underlying viewmember using a pooled connection The lock is released on this viewmember alone, and is not transacted

new public virtual void Unlock();

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WebCacheViewMemberCollection


WhiteBoard.WebCacheWhiteBoard.Unpin Method

Changes the behavior of this artifact such that it floats at the tip. The change is saved to the repository immediately; No subsequent call to update() is required.

new public virtual void Unpin();

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | isFloating | isPinned | pinTo


WhiteBoard.WebCacheWhiteBoard.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace | WebCacheViewMemberCollection


WhiteBoard.WebCacheWhiteBoard.UpdateRevisionComment Method

Change the revision comment for this view member

new public virtual void UpdateRevisionComment(
String comment
);

Parameters

comment
the new revision comment

See Also

WhiteBoard.WebCacheWhiteBoard Class | StarTeam Namespace


Workflow Class

Workflow specifies a set of states (steps) and state transitions Workflow also specifies a set of rules Some rules are relevant in all states. others are relevant in a particular state Workflow is described in .xml files in the starflow extensions project

For a list of all members of this type, see Workflow Members.

System.Object
Workflow

public class Workflow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Workflow Members | StarTeam Namespace


Workflow Members

Workflow overview

Public Static Methods

FromStarFlowExtensions Load the workflow from StarFlow Extensions Once loaded, the rules validate state transitions, provide appropriate initialization defaults when entering new states, etc. Workflow is stored in StarFlow Extensions by default The schema is a folder called "projects" expected to be found in the root view of the project called "StarFlow Extensions" Project Specific Workflow may be located in sub-folders of "projects" identified by project name View specific workflow may be located in sub-folders of a specific project identified by view name The workflow is loaded for all types that it is available for for this view, it's parent project and the server If the xml is not well formed, or does not conform to the expected grammar, an SDK Runtime Exception will be thrown

Public Instance Properties

IsDisabled | [read] true if this workflow definition has been disabled
StartingStep | [read] the first step in the workflow
Steps | [read] the set of steps in the workflow
Type | [read] the Type in whose context this workflow definition executes
Version | [read] the version of this workflow definition
WorkflowProperty | [read] the workflow property

Public Instance Methods

CanUpdate | Returns true if this artifact can be updated, in the context of this workflow, i.e. there are no required properties left unpopulated with this item in it's current state
Equals | Delegate Equals() to com.starteam.Workflow.
GetCurrentStep | return the step that this artifact is in w.r. t. its workflow
GetHashCode | Delegate GetHashCode() to com.starteam.Workflow.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Workflow.

See Also

Workflow Class | StarTeam Namespace


Workflow Properties

The properties of the Workflow class are listed below. For a complete list of Workflow class members, see the Workflow Members topic.

Public Instance Properties

IsDisabled | [read] true if this workflow definition has been disabled
StartingStep | [read] the first step in the workflow
Steps | [read] the set of steps in the workflow
Type | [read] the Type in whose context this workflow definition executes
Version | [read] the version of this workflow definition
WorkflowProperty | [read] the workflow property

See Also

Workflow Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

Workflow.IsDisabled Property

[read] true if this workflow definition has been disabled

public virtual Boolean IsDisabled {get;}

Property Value

true if this workflow definition has been disabled

See Also

Workflow Class | StarTeam Namespace


StartingStep Property

Borland StarTeam SDK for .NET

Workflow.StartingStep Property

[read] the first step in the workflow

public virtual Workflow.Step StartingStep {get;}

Property Value

the first step in the workflow

See Also

Workflow Class | StarTeam Namespace


Steps Property

Borland StarTeam SDK for .NET

Workflow.Steps Property

[read] the set of steps in the workflow

public virtual Step[] Steps {get;}

Property Value

the set of steps in the workflow

See Also

Workflow Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Workflow.Type Property

[read] the Type in whose context this workflow definition executes

public virtual ViewMember.Type Type {get;}

Property Value

the Type in whose context this workflow definition executes

See Also

Workflow Class | StarTeam Namespace


Version Property

Borland StarTeam SDK for .NET

Workflow.Version Property

[read] the version of this workflow definition

public virtual String Version {get;}

Property Value

the version of this workflow definition

See Also

Workflow Class | StarTeam Namespace


WorkflowProperty Property

Borland StarTeam SDK for .NET

Workflow.WorkflowProperty Property

[read] the workflow property

public virtual EnumeratedProperty WorkflowProperty {get;}

Property Value

the workflow property

See Also

Workflow Class | StarTeam Namespace


Workflow Methods

The methods of the Workflow class are listed below. For a complete list of Workflow class members, see the Workflow Members topic.

Public Static Methods

FromStarFlowExtensions Load the workflow from StarFlow Extensions Once loaded, the rules validate state transitions, provide appropriate initialization defaults when entering new states, etc. Workflow is stored in StarFlow Extensions by default The schema is a folder called "projects" expected to be found in the root view of the project called "StarFlow Extensions" Project Specific Workflow may be located in sub-folders of "projects" identified by project name View specific workflow may be located in sub-folders of a specific project identified by view name The workflow is loaded for all types that it is available for for this view, it's parent project and the server If the xml is not well formed, or does not conform to the expected grammar, an SDK Runtime Exception will be thrown

Public Instance Methods

CanUpdate | Returns true if this artifact can be updated, in the context of this workflow, i.e. there are no required properties left unpopulated with this item in it's current state
Equals | Delegate Equals() to com.starteam.Workflow.
GetCurrentStep | return the step that this artifact is in w.r. t. its workflow
GetHashCode | Delegate GetHashCode() to com.starteam.Workflow.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Workflow.

See Also

Workflow Class | StarTeam Namespace


Workflow.CanUpdate Method

Returns true if this artifact can be updated, in the context of this workflow, i.e. there are no required properties left unpopulated with this item in it's current state

public virtual bool CanUpdate(
ViewMember artifact
);

Parameters

artifact
the ViewMember which is about to be updated to the StarTeam repository

Return Value

true if this artifact can be updated in the context of this workflow

See Also

Workflow Class | StarTeam Namespace


Workflow.Equals Method

Delegate Equals() to com.starteam.Workflow.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Workflow.Equals(obj).

See Also

Workflow Class | StarTeam Namespace


Workflow.FromStarFlowExtensions Method

Load the workflow from StarFlow Extensions Once loaded, the rules validate state transitions, provide appropriate initialization defaults when entering new states, etc. Workflow is stored in StarFlow Extensions by default The schema is a folder called "projects" expected to be found in the root view of the project called "StarFlow Extensions" Project Specific Workflow may be located in sub-folders of "projects" identified by project name View specific workflow may be located in sub-folders of a specific project identified by view name The workflow is loaded for all types that it is available for for this view, it's parent project and the server If the xml is not well formed, or does not conform to the expected grammar, an SDK Runtime Exception will be thrown

public static void FromStarFlowExtensions(
View vw
);

Parameters

vw
the view whose workflow will be loaded for all workflow aware types

See Also

Workflow Class | StarTeam Namespace


Workflow.GetCurrentStep Method

return the step that this artifact is in w.r. t. its workflow

public virtual Step GetCurrentStep(
ViewMember artifact
);

Parameters

artifact
the view memebr to test

Return Value

the step that this artifact is in

See Also

Workflow Class | StarTeam Namespace


Workflow.GetHashCode Method

Delegate GetHashCode() to com.starteam.Workflow.

public override int GetHashCode();

Return Value

com.starteam.Workflow.GetHashCode().

See Also

Workflow Class | StarTeam Namespace


Workflow.ToString Method

Delegate ToString() to com.starteam.Workflow.

public override string ToString();

Return Value

com.starteam.Workflow.ToString()

See Also

Workflow Class | StarTeam Namespace


Workflow.Step Class

A Step represents a State in the Workflow State Machine Each step represents an EnmeratedValue from the legal set for the workflow definition's EnumeratedProperty

For a list of all members of this type, see Workflow.Step Members.

System.Object
Workflow.Step

public class Workflow.Step

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Workflow.Step Members | StarTeam Namespace


Workflow.Step Members

Workflow.Step overview

Public Instance Properties

RequiredProperties | [read] the set of required properties at this step
SourceProperties | [read] the set of source properties that trigger dynamic defaults
Value | [read] the value of this step

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Workflow.Step.
GetAccessDeniedProperties | returns the set of properties that must be denied access (hidden) when the workflow property for the specified artifact is in this state
GetAccessGrantedProperties | returns the set of properties that may be granted read only access when the workflow property for the specified artifact is in this state
GetAssignableValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Workflow.Step.
GetInitializedProperties | returns the set of properties whose values were automatically initialized when the workflow entered this step.
GetNextSteps | returns the set of steps that can be transitioned to from this step
GetPermittedStateTransitions | returns the set of Enumerated Values that this artifact may transition to from this state
GetPermittedUsers | Returns the set of users who are possible legal values for this property in this state
GetRequiredProperties | returns the set of properties that require non-null or non-empty values when the workflow property for the specified artifact is in this state
GetSelectableValues | Returns the (sub)set of enumerated values of the target property that are selectable, or specifically candidates for allowable values when the source property changes to the new state once again, based on dynamic default initialization note that setting state to NULL is a special case meaning the 'otherwise' or default condition
GetTargetProperties | Returns the set of target properties whose values will change, triggered by a change of the source property to the new state based on dynamic default initialization note that setting state to NULL is a special case meaning the 'otherwise' or default condition The returned set of target properties can be of any type, e.g. Text, User, Enumerated etc.
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeSelectedValue | Returns true if the client should retain a field's previously selected value false if the client should remove a field's previously selected value in the event that the selected value does not appear in the current list of available selections note that setting state to NULL is a special case meaning the 'otherwise' or default condition This boolean is primarily a hint to the UI
IsAuthorized | returns true if the logged in user is authorized to transition this artifact to its next step
ToString | Delegate ToString() to com.starteam.Workflow.Step.

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step Properties

The properties of the Workflow.Step class are listed below. For a complete list of Workflow.Step class members, see the Workflow.Step Members topic.

Public Instance Properties

RequiredProperties | [read] the set of required properties at this step
SourceProperties | [read] the set of source properties that trigger dynamic defaults
Value | [read] the value of this step

See Also

Workflow.Step Class | StarTeam Namespace


RequiredProperties Property

Borland StarTeam SDK for .NET

Workflow.Step.RequiredProperties Property

[read] the set of required properties at this step

public virtual PropertyCollection RequiredProperties {get;}

Property Value

the set of required properties at this step

See Also

Workflow.Step Class | StarTeam Namespace


SourceProperties Property

Borland StarTeam SDK for .NET

Workflow.Step.SourceProperties Property

[read] the set of source properties that trigger dynamic defaults

public virtual PropertyCollection SourceProperties {get;}

Property Value

the set of source properties that trigger dynamic defaults

See Also

Workflow.Step Class | StarTeam Namespace


Value Property

Borland StarTeam SDK for .NET

Workflow.Step.Value Property

[read] the value of this step

public virtual EnumeratedValue Value {get;}

Property Value

the value of this step

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step Methods

The methods of the Workflow.Step class are listed below. For a complete list of Workflow.Step class members, see the Workflow.Step Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Workflow.Step.
GetAccessDeniedProperties | returns the set of properties that must be denied access (hidden) when the workflow property for the specified artifact is in this state
GetAccessGrantedProperties | returns the set of properties that may be granted read only access when the workflow property for the specified artifact is in this state
GetAssignableValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Workflow.Step.
GetInitializedProperties | returns the set of properties whose values were automatically initialized when the workflow entered this step.
GetNextSteps | returns the set of steps that can be transitioned to from this step
GetPermittedStateTransitions | returns the set of Enumerated Values that this artifact may transition to from this state
GetPermittedUsers | Returns the set of users who are possible legal values for this property in this state
GetRequiredProperties | returns the set of properties that require non-null or non-empty values when the workflow property for the specified artifact is in this state
GetSelectableValues | Returns the (sub)set of enumerated values of the target property that are selectable, or specifically candidates for allowable values when the source property changes to the new state once again, based on dynamic default initialization note that setting state to NULL is a special case meaning the 'otherwise' or default condition
GetTargetProperties | Returns the set of target properties whose values will change, triggered by a change of the source property to the new state based on dynamic default initialization note that setting state to NULL is a special case meaning the 'otherwise' or default condition The returned set of target properties can be of any type, e.g. Text, User, Enumerated etc.
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeSelectedValue | Returns true if the client should retain a field's previously selected value false if the client should remove a field's previously selected value in the event that the selected value does not appear in the current list of available selections note that setting state to NULL is a special case meaning the 'otherwise' or default condition This boolean is primarily a hint to the UI
IsAuthorized | returns true if the logged in user is authorized to transition this artifact to its next step
ToString | Delegate ToString() to com.starteam.Workflow.Step.

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.Equals Method

Delegate Equals() to com.starteam.Workflow.Step.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Workflow.Step.Equals(obj).

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetAccessDeniedProperties Method

returns the set of properties that must be denied access (hidden) when the workflow property for the specified artifact is in this state

public virtual PropertyCollection GetAccessDeniedProperties(
ViewMember artifact
);

Parameters

artifact
the ViewMember whose properties need to be hidden in this state

Return Value

the set of properties that must be denied access

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetAccessGrantedProperties Method

returns the set of properties that may be granted read only access when the workflow property for the specified artifact is in this state

public virtual PropertyCollection GetAccessGrantedProperties(
ViewMember artifact
);

Parameters

artifact
the ViewMember whose properties need to be shown in this state

Return Value

the set of properties that may be granted read only access

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetAssignableValue Method

public virtual object GetAssignableValue(
Property src,
Object state,
Property trgt,
Boolean interpret
);

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetHashCode Method

Delegate GetHashCode() to com.starteam.Workflow.Step.

public override int GetHashCode();

Return Value

com.starteam.Workflow.Step.GetHashCode().

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetInitializedProperties Method

returns the set of properties whose values were automatically initialized when the workflow entered this step.

public virtual PropertyCollection GetInitializedProperties(
ViewMember artifact
);

Parameters

artifact
the ViewMember in this state

Return Value

the set of properties whose values were initialized in this step

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetNextSteps Method

returns the set of steps that can be transitioned to from this step

public virtual Step[] GetNextSteps(
ViewMember artifact
);

Parameters

artifact
the ViewMember at a given step (possibly ready to transition to the next step)

Return Value

the set of steps that can be transitioned to from this step

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetPermittedStateTransitions Method

returns the set of Enumerated Values that this artifact may transition to from this state

public virtual EnumeratedValue[] GetPermittedStateTransitions(
ViewMember artifact
);

Parameters

artifact
the ViewMember which is about to transition to the next step

Return Value

the set of Enumerated Values that this artifact may transition to

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetPermittedUsers Method

Returns the set of users who are possible legal values for this property in this state

public virtual User[] GetPermittedUsers(
ViewMember artifact,
ObjectProperty prprty
);

Parameters

artifact
the ViewMember whose user property is about to be assigned
prprty
the property which is about to transition to the next step

Return Value

the set of users who are possible legal values for this property in this state

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetRequiredProperties Method

returns the set of properties that require non-null or non-empty values when the workflow property for the specified artifact is in this state

public virtual PropertyCollection GetRequiredProperties(
ViewMember artifact
);

Parameters

artifact
the ViewMember whose properties need to be validated in this state

Return Value

the set of properties that require non-null or non-empty values

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetSelectableValues Method

Returns the (sub)set of enumerated values of the target property that are selectable, or specifically candidates for allowable values when the source property changes to the new state once again, based on dynamic default initialization note that setting state to NULL is a special case meaning the 'otherwise' or default condition

public virtual EnumeratedValue[] GetSelectableValues(
Property src,
Object state,
EnumeratedProperty trgt
);

Parameters

src
The source property
state
the new state that the source property can transition to
trgt
The affected target enumerated property, which can now transition to a subset of selectable states (also defined as the enumLimitation set in the workflow designer .xml)

Return Value

the allowed subset of enumerated values for the target property

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.GetTargetProperties Method

Returns the set of target properties whose values will change, triggered by a change of the source property to the new state based on dynamic default initialization note that setting state to NULL is a special case meaning the 'otherwise' or default condition The returned set of target properties can be of any type, e.g. Text, User, Enumerated etc.

public virtual PropertyCollection GetTargetProperties(
Property src,
Object state
);

Parameters

src
the source property
state
the new state that the source property can transition to

Return Value

the set of target properties affected by the transition of the source property to the new state

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.IncludeSelectedValue Method

Returns true if the client should retain a field's previously selected value false if the client should remove a field's previously selected value in the event that the selected value does not appear in the current list of available selections note that setting state to NULL is a special case meaning the 'otherwise' or default condition This boolean is primarily a hint to the UI

public virtual bool IncludeSelectedValue(
Property src,
Object state,
EnumeratedProperty trgt
);

Parameters

src
The source property
state
the new state that the source property can transition to
trgt
The affected target enumerated property (the include_selected xml attribute of the enumLimitations node in the workflow designer .xml)

Return Value

true if the client should retain a field's previously selected value

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.IsAuthorized Method

returns true if the logged in user is authorized to transition this artifact to its next step

public virtual bool IsAuthorized(
ViewMember artifact
);

Parameters

artifact
the ViewMember which is about to transition to the next step

Return Value

true if the logged in user is authorized

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.ToString Method

Delegate ToString() to com.starteam.Workflow.Step.

public override string ToString();

Return Value

com.starteam.Workflow.Step.ToString()

See Also

Workflow.Step Class | StarTeam Namespace


Workflow.Step.WebCacheStep Class

A Step Accessor for the Web Cache Object Model

For a list of all members of this type, see Workflow.Step.WebCacheStep Members.

System.Object
Workflow.Step.WebCacheStep

public class Workflow.Step.WebCacheStep

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Workflow.Step.WebCacheStep Members | StarTeam Namespace


Workflow.Step.WebCacheStep Members

Workflow.Step.WebCacheStep overview

Public Instance Properties

RequiredProperties | [read] the set of required properties at this step
SourceProperties | [read] the set of source properties that trigger dynamic defaults
Value | [read] the value of this step

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Workflow.Step.WebCacheStep.
GetAccessDeniedProperties |
GetAccessGrantedProperties |
GetAssignableValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Workflow.Step.WebCacheStep.
GetInitializedProperties |
GetNextSteps |
GetPermittedStateTransitions |
GetPermittedUsers |
GetRequiredProperties |
GetSelectableValues |
GetTargetProperties |
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeSelectedValue |
IsAuthorized |
ToString | Delegate ToString() to com.starteam.Workflow.Step.WebCacheStep.

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep Properties

The properties of the Workflow.Step.WebCacheStep class are listed below. For a complete list of Workflow.Step.WebCacheStep class members, see the Workflow.Step.WebCacheStep Members topic.

Public Instance Properties

RequiredProperties | [read] the set of required properties at this step
SourceProperties | [read] the set of source properties that trigger dynamic defaults
Value | [read] the value of this step

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


RequiredProperties Property

Borland StarTeam SDK for .NET

Workflow.Step.WebCacheStep.RequiredProperties Property

[read] the set of required properties at this step

public virtual WebCacheProperty[] RequiredProperties {get;}

Property Value

the set of required properties at this step

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


SourceProperties Property

Borland StarTeam SDK for .NET

Workflow.Step.WebCacheStep.SourceProperties Property

[read] the set of source properties that trigger dynamic defaults

public virtual WebCacheProperty[] SourceProperties {get;}

Property Value

the set of source properties that trigger dynamic defaults

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Value Property

Borland StarTeam SDK for .NET

Workflow.Step.WebCacheStep.Value Property

[read] the value of this step

public virtual EnumeratedValue Value {get;}

Property Value

the value of this step

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep Methods

The methods of the Workflow.Step.WebCacheStep class are listed below. For a complete list of Workflow.Step.WebCacheStep class members, see the Workflow.Step.WebCacheStep Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.Workflow.Step.WebCacheStep.
GetAccessDeniedProperties |
GetAccessGrantedProperties |
GetAssignableValue |
GetHashCode | Delegate GetHashCode() to com.starteam.Workflow.Step.WebCacheStep.
GetInitializedProperties |
GetNextSteps |
GetPermittedStateTransitions |
GetPermittedUsers |
GetRequiredProperties |
GetSelectableValues |
GetTargetProperties |
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeSelectedValue |
IsAuthorized |
ToString | Delegate ToString() to com.starteam.Workflow.Step.WebCacheStep.

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.Equals Method

Delegate Equals() to com.starteam.Workflow.Step.WebCacheStep.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Workflow.Step.WebCacheStep.Equals(obj).

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetAccessDeniedProperties Method

public virtual WebCacheProperty[] GetAccessDeniedProperties(
ViewMember.WebCacheViewMember artifact
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetAccessGrantedProperties Method

public virtual WebCacheProperty[] GetAccessGrantedProperties(
ViewMember.WebCacheViewMember artifact
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetAssignableValue Method

public virtual object GetAssignableValue(
Property.WebCacheProperty src,
Object state,
Property.WebCacheProperty trgt,
Boolean interpret
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetHashCode Method

Delegate GetHashCode() to com.starteam.Workflow.Step.WebCacheStep.

public override int GetHashCode();

Return Value

com.starteam.Workflow.Step.WebCacheStep.GetHashCode().

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetInitializedProperties Method

public virtual WebCacheProperty[] GetInitializedProperties(
ViewMember.WebCacheViewMember artifact
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetNextSteps Method

public virtual WebCacheStep[] GetNextSteps(
ViewMember.WebCacheViewMember artifact
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetPermittedStateTransitions Method

public virtual EnumeratedValue[] GetPermittedStateTransitions(
ViewMember.WebCacheViewMember artifact
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetPermittedUsers Method

public virtual WebCacheUser[] GetPermittedUsers(
ViewMember.WebCacheViewMember artifact,
ObjectProperty.WebCacheObjectProperty prprty
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetRequiredProperties Method

public virtual WebCacheProperty[] GetRequiredProperties(
ViewMember.WebCacheViewMember artifact
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetSelectableValues Method

public virtual EnumeratedValue[] GetSelectableValues(
Property.WebCacheProperty src,
Object state,
EnumeratedProperty.WebCacheEnumeratedProperty trgt
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.GetTargetProperties Method

public virtual WebCacheProperty[] GetTargetProperties(
Property.WebCacheProperty src,
Object state
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.IncludeSelectedValue Method

public virtual bool IncludeSelectedValue(
Property.WebCacheProperty src,
Object state,
EnumeratedProperty.WebCacheEnumeratedProperty trgt
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.IsAuthorized Method

public virtual bool IsAuthorized(
ViewMember.WebCacheViewMember artifact
);

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.Step.WebCacheStep.ToString Method

Delegate ToString() to com.starteam.Workflow.Step.WebCacheStep.

public override string ToString();

Return Value

com.starteam.Workflow.Step.WebCacheStep.ToString()

See Also

Workflow.Step.WebCacheStep Class | StarTeam Namespace


Workflow.WebCacheWorkflow Class

A Workflow Accessor for the Web Cache Object Model

For a list of all members of this type, see Workflow.WebCacheWorkflow Members.

System.Object
Workflow.WebCacheWorkflow

public class Workflow.WebCacheWorkflow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

Workflow.WebCacheWorkflow Members | StarTeam Namespace


Workflow.WebCacheWorkflow Members

Workflow.WebCacheWorkflow overview

Public Static Methods

FromStarFlowExtensions

Public Instance Properties

IsDisabled | [read] true if this workflow definition has been disabled
StartingStep | [read] the first step in the workflow
Steps | [read] the set of steps in the workflow
Type | [read] the Type in whose context this workflow definition executes
Version | [read] the version of this workflow definition
WorkflowProperty | [read] the workflow property

Public Instance Methods

CanUpdate |
Equals | Delegate Equals() to com.starteam.Workflow.WebCacheWorkflow.
GetCurrentStep |
GetHashCode | Delegate GetHashCode() to com.starteam.Workflow.WebCacheWorkflow.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Workflow.WebCacheWorkflow.

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Workflow.WebCacheWorkflow Properties

The properties of the Workflow.WebCacheWorkflow class are listed below. For a complete list of Workflow.WebCacheWorkflow class members, see the Workflow.WebCacheWorkflow Members topic.

Public Instance Properties

IsDisabled | [read] true if this workflow definition has been disabled
StartingStep | [read] the first step in the workflow
Steps | [read] the set of steps in the workflow
Type | [read] the Type in whose context this workflow definition executes
Version | [read] the version of this workflow definition
WorkflowProperty | [read] the workflow property

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


IsDisabled Property

Borland StarTeam SDK for .NET

Workflow.WebCacheWorkflow.IsDisabled Property

[read] true if this workflow definition has been disabled

public virtual Boolean IsDisabled {get;}

Property Value

true if this workflow definition has been disabled

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


StartingStep Property

Borland StarTeam SDK for .NET

Workflow.WebCacheWorkflow.StartingStep Property

[read] the first step in the workflow

public virtual Workflow.Step.WebCacheStep StartingStep {get;}

Property Value

the first step in the workflow

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Steps Property

Borland StarTeam SDK for .NET

Workflow.WebCacheWorkflow.Steps Property

[read] the set of steps in the workflow

public virtual WebCacheStep[] Steps {get;}

Property Value

the set of steps in the workflow

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Type Property

Borland StarTeam SDK for .NET

Workflow.WebCacheWorkflow.Type Property

[read] the Type in whose context this workflow definition executes

public virtual ViewMember.Type.WebCacheViewMemberType Type {get;}

Property Value

the Type in whose context this workflow definition executes

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Version Property

Borland StarTeam SDK for .NET

Workflow.WebCacheWorkflow.Version Property

[read] the version of this workflow definition

public virtual String Version {get;}

Property Value

the version of this workflow definition

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


WorkflowProperty Property

Borland StarTeam SDK for .NET

Workflow.WebCacheWorkflow.WorkflowProperty Property

[read] the workflow property

public virtual EnumeratedProperty.WebCacheEnumeratedProperty WorkflowProperty {get;}

Property Value

the workflow property

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Workflow.WebCacheWorkflow Methods

The methods of the Workflow.WebCacheWorkflow class are listed below. For a complete list of Workflow.WebCacheWorkflow class members, see the Workflow.WebCacheWorkflow Members topic.

Public Static Methods

FromStarFlowExtensions

Public Instance Methods

CanUpdate |
Equals | Delegate Equals() to com.starteam.Workflow.WebCacheWorkflow.
GetCurrentStep |
GetHashCode | Delegate GetHashCode() to com.starteam.Workflow.WebCacheWorkflow.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.Workflow.WebCacheWorkflow.

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Workflow.WebCacheWorkflow.CanUpdate Method

public virtual bool CanUpdate(
ViewMember.WebCacheViewMember artifact
);

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Workflow.WebCacheWorkflow.Equals Method

Delegate Equals() to com.starteam.Workflow.WebCacheWorkflow.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.Workflow.WebCacheWorkflow.Equals(obj).

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Workflow.WebCacheWorkflow.FromStarFlowExtensions Method

public static void FromStarFlowExtensions(
View.WebCacheView vw
);

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Workflow.WebCacheWorkflow.GetCurrentStep Method

public virtual WebCacheStep GetCurrentStep(
ViewMember.WebCacheViewMember artifact
);

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Workflow.WebCacheWorkflow.GetHashCode Method

Delegate GetHashCode() to com.starteam.Workflow.WebCacheWorkflow.

public override int GetHashCode();

Return Value

com.starteam.Workflow.WebCacheWorkflow.GetHashCode().

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


Workflow.WebCacheWorkflow.ToString Method

Delegate ToString() to com.starteam.Workflow.WebCacheWorkflow.

public override string ToString();

Return Value

com.starteam.Workflow.WebCacheWorkflow.ToString()

See Also

Workflow.WebCacheWorkflow Class | StarTeam Namespace


WorkRecord Class

Record of a period of work expended for a task.

  1. Work records are mutable and versioned, but there is no way to identify a version of a work record since the server does not send this information.
  2. The work record contains the ID of the task it is associated with, but not the version number, so there is no way to deduce the task version it is associated with.
  3. The task ID is a mutable property, but the semantics of changing it is unknown.

For a list of all members of this type, see WorkRecord Members.

System.Object
TypedResource
LiveObject
TrackedObject
WorkRecord

public class WorkRecord : TrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord Members | StarTeam Namespace


WorkRecord Members

WorkRecord overview

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DateWorkedOn | [read/write] the date on which the work was begun.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EstimatedTimeRemaining | [read/write] the estimated time remaining to complete the task after this period.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Notes | [read/write] the notes about this work record.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Properties | [read]
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
TimeWorked | [read/write] the time spent on the task during this period.
WorkPerformedBy | [read/write] the user who performed the work.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this workrecord object.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

WorkRecord Class | StarTeam Namespace


WorkRecord Properties

The properties of the WorkRecord class are listed below. For a complete list of WorkRecord class members, see the WorkRecord Members topic.

Public Instance Properties

CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DateWorkedOn | [read/write] the date on which the work was begun.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EstimatedTimeRemaining | [read/write] the estimated time remaining to complete the task after this period.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyType (inherited from TypedResource) | [read] the type of this resource.
Notes | [read/write] the notes about this work record.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
Properties | [read]
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
TimeWorked | [read/write] the time spent on the task during this period.
WorkPerformedBy | [read/write] the user who performed the work.

See Also

WorkRecord Class | StarTeam Namespace


DateWorkedOn Property

Borland StarTeam SDK for .NET

WorkRecord.DateWorkedOn Property

[read/write] the date on which the work was begun.

public virtual Date DateWorkedOn {get; set;}

Property Value

the date on which the work was begun.

See Also

WorkRecord Class | StarTeam Namespace


EstimatedTimeRemaining Property

Borland StarTeam SDK for .NET

WorkRecord.EstimatedTimeRemaining Property

[read/write] the estimated time remaining to complete the task after this period.

public virtual TimeSpan EstimatedTimeRemaining {get; set;}

Property Value

the estimated time remaining to complete the task after this period.

See Also

WorkRecord Class | StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

WorkRecord.Notes Property

[read/write] the notes about this work record.

public virtual String Notes {get; set;}

Property Value

the notes about this work record.

See Also

WorkRecord Class | StarTeam Namespace


Properties Property

Borland StarTeam SDK for .NET

WorkRecord.Properties Property

[read]

public virtual WorkRecord.Type.PropertyCollection Properties {get;}

See Also

WorkRecord Class | StarTeam Namespace


TimeWorked Property

Borland StarTeam SDK for .NET

WorkRecord.TimeWorked Property

[read/write] the time spent on the task during this period.

public virtual TimeSpan TimeWorked {get; set;}

Property Value

the time spent on the task during this period.

See Also

WorkRecord Class | StarTeam Namespace


WorkPerformedBy Property

Borland StarTeam SDK for .NET

WorkRecord.WorkPerformedBy Property

[read/write] the user who performed the work.

public virtual User WorkPerformedBy {get; set;}

Property Value

the user who performed the work.

See Also

WorkRecord Class | StarTeam Namespace


WorkRecord Methods

The methods of the WorkRecord class are listed below. For a complete list of WorkRecord class members, see the WorkRecord Members topic.

Public Instance Methods

AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy | Creates a copy of this workrecord object.
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.

See Also

WorkRecord Class | StarTeam Namespace


WorkRecord.Copy Method

Creates a copy of this workrecord object.

public virtual WorkRecord Copy();

Return Value

A new copy of this workrecord object.

See Also

WorkRecord Class | StarTeam Namespace


WorkRecord.Type Class

The type of the WorkRecord

For a list of all members of this type, see WorkRecord.Type Members.

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
WorkRecord.Type

new public class WorkRecord.Type : Type

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord.Type Members | StarTeam Namespace


WorkRecord.Type Members

WorkRecord.Type overview

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.

See Also

WorkRecord.Type Class | StarTeam Namespace


WorkRecord.Type Properties

The properties of the WorkRecord.Type class are listed below. For a complete list of WorkRecord.Type class members, see the WorkRecord.Type Members topic.

Public Static Properties

NAME

Public Instance Properties

Catalog (inherited from Type) | [read] the catalog for this type or null if this Type does not have a Catalog
ClassID (inherited from Type) | [read] the class ID for this type.
ComponentACL (inherited from Type) | [read/write] the access control list for this type. May return null.
ComponentGUID (inherited from Type) | [read] The server-defined component GUID, or null if this Type does not represent a component type.
DebugString (inherited from Type) | [read] a debug string for this type.
DisplayName (inherited from Type) | [read] a display name for this type.
DisplayNameTranslations (inherited from Type) | [read]
FilterACL (inherited from Type) | [read/write] the access control list for this type. May return null.
Filters (inherited from Type) | [read] an array of all Filters for this type.
ID (inherited from Type) | [read] the class ID for this type.
IsAttachmentContainer (inherited from Type) | [read] true if this type can have attachments.
IsBranchable (inherited from Type) | [read] true if this type is branchable.
IsComponentType (inherited from Type) | [read] true if this Type corresponds to a StarTeam component (FILE, CHANGEREQUEST, TASK, TOPIC, AUDIT or PROJECT).
IsDeleted (inherited from Type) | [read]
IsMPXSupported (inherited from Type) | [read] true if this Type supports MPX (that is, if instances of this Type benefit from improved refresh performance on an MPX-enabled server, and can be monitored via event-handling APIs).
IsRefreshFiltersAndQueriesRequired (inherited from Type) | [read] true if Filter or QueryManager information may be out of date.
Name (inherited from Type) | [read] the name of this type
ParentContainer (inherited from Type) | [read] null.
PrimaryDescriptor (inherited from Type) | [read] The primary descriptor of this type, or null if this type has no primary descriptor.
Properties (inherited from Type) | [read] an array of all properties belonging to this type.
Queries (inherited from Type) | [read] an array of all Query for this type.
QueryACL (inherited from Type) | [read/write] the access control list for this type. May return null.
SecondaryDescriptor (inherited from Type) | [read] A secondary descriptor of this type, or null if this type has no secondary descriptor.
SecondaryDescriptors (inherited from Type) | [read] the set of all secondary descriptors for this type
Server (inherited from Type) | [read] the Server object containing this Type.

See Also

WorkRecord.Type Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.NAME Property

new public static String NAME {get;}

See Also

WorkRecord.Type Class | StarTeam Namespace


WorkRecord.Type Methods

The methods of the WorkRecord.Type class are listed below. For a complete list of WorkRecord.Type class members, see the WorkRecord.Type Members topic.

Public Instance Methods

Copy (inherited from Type) | Creates a copy of a given Type object. Copies associated Properties. Does not copy any associated Filter or Query objects. Useful to applications that want to save a snapshot of the Type in a given state, for example, before calling Server.refreshTypes().
Discard (inherited from Type) | discards local changes made to cached properties
DiscardFiltersAndQueries (inherited from Type) | Discards all cached filter and query information associated with this Type. It will be re-fetched from the server on demand (even when MPX is enabled).
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.
GetFilter (inherited from Type) | Overloaded. Returns the cached Filter object belonging to this type with the specified filter name. This will not return null, but will throw an IllegalArgumentException if the filter is not found.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.
GetQuery (inherited from Type) | Overloaded. Returns the cached Query object belonging to this type with the specified Query name. This will not return null, but will throw an IllegalArgumentException if the Query is not found.
GetRights (inherited from Type) | Returns the Access Control List for items of the specified type for this type.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFilter (inherited from Type) | Overloaded. Returns true if the cache contains a Filter with the provided name.
HasPermissions (inherited from Type) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this type. If the type itself is a non-"Item" type, it always returns false.
HasQuery (inherited from Type) | Overloaded. Returns true if the cache contains a Query with the provided name.
IsEqualTo (inherited from Type) | Compares two Type objects. Does not compare any associated Property, Filter or QueryManager objects.
NewBooleanProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=False and 1=True.
NewContentProperty (inherited from Type) | Creates a new ContentProperty. The new property is dirty; to save changes, you must call Property.update().
NewDateProperty (inherited from Type) | Creates a new DateProperty
NewDateTimeProperty (inherited from Type) | Creates a new DateTimeProperty
NewDoubleProperty (inherited from Type) | Creates a new DoubleProperty
NewEnumeratedProperty (inherited from Type) | Create a new Enumerated Property
NewFilterEventSource (inherited from Type) |
NewIntegerProperty (inherited from Type) | Creates a new IntegerProperty
NewLongIntegerProperty (inherited from Type) | Creates a new LongIntegerProperty
NewMapProperty (inherited from Type) | Creates a new MapProperty. A Map Property supports the assignment of a java Map (i.e. an arbitrary set of key value pairs) as a property value. Currently, the underlying implementation is a text property with the map serialized into a simple xml schema
NewObjectArrayProperty (inherited from Type) |
NewObjectProperty (inherited from Type) |
NewOnOffProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=Off and 1=On.
NewQueryEventSource (inherited from Type) |
NewTextProperty (inherited from Type) | Creates a new TextProperty
NewTimeSpanProperty (inherited from Type) | Creates a new TimeSpanProperty
NewTypeEventSource (inherited from Type) |
NewYesNoProperty (inherited from Type) | Create a new Boolean Property Assigns default display names such that 0=No and 1=Yes.
Refresh (inherited from Type) | Updates cached properties to reflect recent changes made on the server. This is an expensive operation, since it will always execute a server command
RefreshFiltersAndQueries (inherited from Type) | Refreshes cached Filter and QueryManager information to reflect recent changes to the repository. Modifies existing Filter and QueryManager objects in place, whenever possible. If MPX is enabled, refreshFiltersAndQueries() is optimized to avoid unnecessary server commands.
SetRights (inherited from Type) | Modifies the Access Control List for items of the specified type for this type. If the ACL is null then the access control list for items of the specified type will be dropped. If typeName does not specify the type itself, an exception will be thrown.
SupportsTraceVersioning (inherited from Type) | Returns true if this type supports endpoint versioning with traces This feature was introduced in the 16.2 server
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.

See Also

WorkRecord.Type Class | StarTeam Namespace


WorkRecord.Type.Equals Method

Delegate Equals() to com.starteam.WorkRecord.Type.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WorkRecord.Type.Equals(obj).

See Also

WorkRecord.Type Class | StarTeam Namespace


WorkRecord.Type.GetHashCode Method

Delegate GetHashCode() to com.starteam.WorkRecord.Type.

public override int GetHashCode();

Return Value

com.starteam.WorkRecord.Type.GetHashCode().

See Also

WorkRecord.Type Class | StarTeam Namespace


WorkRecord.Type.ToString Method

Delegate ToString() to com.starteam.WorkRecord.Type.

public override string ToString();

Return Value

com.starteam.WorkRecord.Type.ToString()

See Also

WorkRecord.Type Class | StarTeam Namespace


WorkRecord.Type.CommentProperty Class

The property type of the Comment property

For a list of all members of this type, see WorkRecord.Type.CommentProperty Members.

System.Object
Property
VectorProperty
TextProperty
WorkRecord.Type.CommentProperty

public class WorkRecord.Type.CommentProperty : TextProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord.Type.CommentProperty Members | StarTeam Namespace


WorkRecord.Type.CommentProperty Members

WorkRecord.Type.CommentProperty overview

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.CommentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.CommentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.CommentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.CommentProperty Class | StarTeam Namespace


WorkRecord.Type.CommentProperty Properties

The properties of the WorkRecord.Type.CommentProperty class are listed below. For a complete list of WorkRecord.Type.CommentProperty class members, see the WorkRecord.Type.CommentProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

AbsoluteMaxLength (inherited from VectorProperty) | [read] The absolute maximum length supported for this property type.
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TextProperty) | [read/write] String
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxLength (inherited from VectorProperty) | [read/write] The maximum length of a property value.
MinLength (inherited from VectorProperty) | [read/write] The minimum length of a property value.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

WorkRecord.Type.CommentProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.CommentProperty.NAME Property

public static String NAME {get;}

See Also

WorkRecord.Type.CommentProperty Class | StarTeam Namespace


WorkRecord.Type.CommentProperty Methods

The methods of the WorkRecord.Type.CommentProperty class are listed below. For a complete list of WorkRecord.Type.CommentProperty class members, see the WorkRecord.Type.CommentProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.CommentProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.CommentProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TextProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.CommentProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.CommentProperty Class | StarTeam Namespace


WorkRecord.Type.CommentProperty.Equals Method

Delegate Equals() to com.starteam.WorkRecord.Type.CommentProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WorkRecord.Type.CommentProperty.Equals(obj).

See Also

WorkRecord.Type.CommentProperty Class | StarTeam Namespace


WorkRecord.Type.CommentProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.WorkRecord.Type.CommentProperty.

public override int GetHashCode();

Return Value

com.starteam.WorkRecord.Type.CommentProperty.GetHashCode().

See Also

WorkRecord.Type.CommentProperty Class | StarTeam Namespace


WorkRecord.Type.CommentProperty.ToString Method

Delegate ToString() to com.starteam.WorkRecord.Type.CommentProperty.

public override string ToString();

Return Value

com.starteam.WorkRecord.Type.CommentProperty.ToString()

See Also

WorkRecord.Type.CommentProperty Class | StarTeam Namespace


WorkRecord.Type.ParentTaskProperty Class

The property type of the ParentTask property

For a list of all members of this type, see WorkRecord.Type.ParentTaskProperty Members.

System.Object
Property
ScalarProperty
IntegerProperty
WorkRecord.Type.ParentTaskProperty

public class WorkRecord.Type.ParentTaskProperty : IntegerProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord.Type.ParentTaskProperty Members | StarTeam Namespace


WorkRecord.Type.ParentTaskProperty Members

WorkRecord.Type.ParentTaskProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.ParentTaskProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.ParentTaskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.ParentTaskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.ParentTaskProperty Class | StarTeam Namespace


WorkRecord.Type.ParentTaskProperty Properties

The properties of the WorkRecord.Type.ParentTaskProperty class are listed below. For a complete list of WorkRecord.Type.ParentTaskProperty class members, see the WorkRecord.Type.ParentTaskProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from IntegerProperty) | [read/write] int the default integer value
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsRollupProperty (inherited from IntegerProperty) | [read/write] true if this Integer Property can be rolled up
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from IntegerProperty) | [read/write] int the maximum integer value
MinValue (inherited from IntegerProperty) | [read/write] int the minimum integer value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

WorkRecord.Type.ParentTaskProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.ParentTaskProperty.NAME Property

public static String NAME {get;}

See Also

WorkRecord.Type.ParentTaskProperty Class | StarTeam Namespace


WorkRecord.Type.ParentTaskProperty Methods

The methods of the WorkRecord.Type.ParentTaskProperty class are listed below. For a complete list of WorkRecord.Type.ParentTaskProperty class members, see the WorkRecord.Type.ParentTaskProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.ParentTaskProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.ParentTaskProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from IntegerProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.ParentTaskProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.ParentTaskProperty Class | StarTeam Namespace


WorkRecord.Type.ParentTaskProperty.Equals Method

Delegate Equals() to com.starteam.WorkRecord.Type.ParentTaskProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WorkRecord.Type.ParentTaskProperty.Equals(obj).

See Also

WorkRecord.Type.ParentTaskProperty Class | StarTeam Namespace


WorkRecord.Type.ParentTaskProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.WorkRecord.Type.ParentTaskProperty.

public override int GetHashCode();

Return Value

com.starteam.WorkRecord.Type.ParentTaskProperty.GetHashCode().

See Also

WorkRecord.Type.ParentTaskProperty Class | StarTeam Namespace


WorkRecord.Type.ParentTaskProperty.ToString Method

Delegate ToString() to com.starteam.WorkRecord.Type.ParentTaskProperty.

public override string ToString();

Return Value

com.starteam.WorkRecord.Type.ParentTaskProperty.ToString()

See Also

WorkRecord.Type.ParentTaskProperty Class | StarTeam Namespace


WorkRecord.Type.PerformedByProperty Class

The property type of the PerformedBy property

For a list of all members of this type, see WorkRecord.Type.PerformedByProperty Members.

System.Object
Property
ObjectProperty
WorkRecord.Type.PerformedByProperty

public class WorkRecord.Type.PerformedByProperty : ObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord.Type.PerformedByProperty Members | StarTeam Namespace


WorkRecord.Type.PerformedByProperty Members

WorkRecord.Type.PerformedByProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.PerformedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.PerformedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.PerformedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.PerformedByProperty Class | StarTeam Namespace


WorkRecord.Type.PerformedByProperty Properties

The properties of the WorkRecord.Type.PerformedByProperty class are listed below. For a complete list of WorkRecord.Type.PerformedByProperty class members, see the WorkRecord.Type.PerformedByProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from ObjectProperty) | [read/write] int
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
TypeOfValue (inherited from ObjectProperty) | [read] Type the Type object representing the type of a property value.

See Also

WorkRecord.Type.PerformedByProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PerformedByProperty.NAME Property

public static String NAME {get;}

See Also

WorkRecord.Type.PerformedByProperty Class | StarTeam Namespace


WorkRecord.Type.PerformedByProperty Methods

The methods of the WorkRecord.Type.PerformedByProperty class are listed below. For a complete list of WorkRecord.Type.PerformedByProperty class members, see the WorkRecord.Type.PerformedByProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.PerformedByProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.PerformedByProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from ObjectProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.PerformedByProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.PerformedByProperty Class | StarTeam Namespace


WorkRecord.Type.PerformedByProperty.Equals Method

Delegate Equals() to com.starteam.WorkRecord.Type.PerformedByProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WorkRecord.Type.PerformedByProperty.Equals(obj).

See Also

WorkRecord.Type.PerformedByProperty Class | StarTeam Namespace


WorkRecord.Type.PerformedByProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.WorkRecord.Type.PerformedByProperty.

public override int GetHashCode();

Return Value

com.starteam.WorkRecord.Type.PerformedByProperty.GetHashCode().

See Also

WorkRecord.Type.PerformedByProperty Class | StarTeam Namespace


WorkRecord.Type.PerformedByProperty.ToString Method

Delegate ToString() to com.starteam.WorkRecord.Type.PerformedByProperty.

public override string ToString();

Return Value

com.starteam.WorkRecord.Type.PerformedByProperty.ToString()

See Also

WorkRecord.Type.PerformedByProperty Class | StarTeam Namespace


WorkRecord.Type.PropertyCollection Class

The property collection of the WorkRecord type

For a list of all members of this type, see WorkRecord.Type.PropertyCollection Members.

System.Object
StarTeamCollection
PropertyCollection
WorkRecord.Type.PropertyCollection

public class WorkRecord.Type.PropertyCollection : PropertyCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord.Type.PropertyCollection Members | StarTeam Namespace


WorkRecord.Type.PropertyCollection Members

WorkRecord.Type.PropertyCollection overview

Public Instance Properties

COMMENT |
COMMENT_ID |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
END_MODIFIED_TIME |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MODIFIED_BY |
MODIFIED_TIME |
PARENT_TASK |
PERFORMED_BY |
REVISION_FLAGS |
REVISION_NUMBER |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TIME_REMAINING |
TIME_WORKED |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
WORKED_ON |

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.PropertyCollection.

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


WorkRecord.Type.PropertyCollection Properties

The properties of the WorkRecord.Type.PropertyCollection class are listed below. For a complete list of WorkRecord.Type.PropertyCollection class members, see the WorkRecord.Type.PropertyCollection Members topic.

Public Instance Properties

COMMENT |
COMMENT_ID |
Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
CREATED_BY |
CREATED_TIME |
DELETED_BY |
DELETED_TIME |
END_MODIFIED_TIME |
ID |
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
MODIFIED_BY |
MODIFIED_TIME |
PARENT_TASK |
PERFORMED_BY |
REVISION_FLAGS |
REVISION_NUMBER |
SHORT_COMMENT |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection
TIME_REMAINING |
TIME_WORKED |
Type (inherited from PropertyCollection) | [read] the Type associated with this set of properties
WORKED_ON |

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


COMMENT Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.COMMENT Property

public WorkRecord.Type.CommentProperty COMMENT {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


COMMENT_ID Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.COMMENT_ID Property

public VersionedObject.Type.CommentIDProperty COMMENT_ID {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


CREATED_BY Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.CREATED_BY Property

public LiveObject.Type.CreatedByProperty CREATED_BY {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


CREATED_TIME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.CREATED_TIME Property

public LiveObject.Type.CreatedTimeProperty CREATED_TIME {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


DELETED_BY Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.DELETED_BY Property

public LiveObject.Type.DeletedByProperty DELETED_BY {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


DELETED_TIME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.DELETED_TIME Property

public LiveObject.Type.DeletedTimeProperty DELETED_TIME {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


END_MODIFIED_TIME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.END_MODIFIED_TIME Property

public TrackedObject.Type.EndModifiedTimeProperty END_MODIFIED_TIME {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.ID Property

public TypedResource.Type.IDProperty ID {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_BY Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.MODIFIED_BY Property

public TrackedObject.Type.ModifiedByProperty MODIFIED_BY {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


MODIFIED_TIME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.MODIFIED_TIME Property

public TrackedObject.Type.ModifiedTimeProperty MODIFIED_TIME {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


PARENT_TASK Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.PARENT_TASK Property

public WorkRecord.Type.ParentTaskProperty PARENT_TASK {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


PERFORMED_BY Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.PERFORMED_BY Property

public WorkRecord.Type.PerformedByProperty PERFORMED_BY {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


REVISION_FLAGS Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.REVISION_FLAGS Property

public VersionedObject.Type.RevisionFlagsProperty REVISION_FLAGS {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


REVISION_NUMBER Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.REVISION_NUMBER Property

public VersionedObject.Type.RevisionNumberProperty REVISION_NUMBER {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


SHORT_COMMENT Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.SHORT_COMMENT Property

public VersionedObject.Type.ShortCommentProperty SHORT_COMMENT {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


TIME_REMAINING Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.TIME_REMAINING Property

public WorkRecord.Type.TimeRemainingProperty TIME_REMAINING {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


TIME_WORKED Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.TIME_WORKED Property

public WorkRecord.Type.TimeWorkedProperty TIME_WORKED {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


WORKED_ON Property

Borland StarTeam SDK for .NET

WorkRecord.Type.PropertyCollection.WORKED_ON Property

public WorkRecord.Type.WorkedOnProperty WORKED_ON {get;}

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


WorkRecord.Type.PropertyCollection Methods

The methods of the WorkRecord.Type.PropertyCollection class are listed below. For a complete list of WorkRecord.Type.PropertyCollection class members, see the WorkRecord.Type.PropertyCollection Members topic.

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.PropertyCollection.
Find (inherited from PropertyCollection) | Overloaded. Return the Property object belonging to this type with the specified property name. This will return null if the property is not found.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.PropertyCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.PropertyCollection.

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


WorkRecord.Type.PropertyCollection.Equals Method

Delegate Equals() to com.starteam.WorkRecord.Type.PropertyCollection.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WorkRecord.Type.PropertyCollection.Equals(obj).

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


WorkRecord.Type.PropertyCollection.GetHashCode Method

Delegate GetHashCode() to com.starteam.WorkRecord.Type.PropertyCollection.

public override int GetHashCode();

Return Value

com.starteam.WorkRecord.Type.PropertyCollection.GetHashCode().

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


WorkRecord.Type.PropertyCollection.ToString Method

Delegate ToString() to com.starteam.WorkRecord.Type.PropertyCollection.

public override string ToString();

Return Value

com.starteam.WorkRecord.Type.PropertyCollection.ToString()

See Also

WorkRecord.Type.PropertyCollection Class | StarTeam Namespace


WorkRecord.Type.TimeRemainingProperty Class

The property type of the TimeRemaining property

For a list of all members of this type, see WorkRecord.Type.TimeRemainingProperty Members.

System.Object
Property
ScalarProperty
TimeSpanProperty
WorkRecord.Type.TimeRemainingProperty

public class WorkRecord.Type.TimeRemainingProperty : TimeSpanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord.Type.TimeRemainingProperty Members | StarTeam Namespace


WorkRecord.Type.TimeRemainingProperty Members

WorkRecord.Type.TimeRemainingProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.TimeRemainingProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.TimeRemainingProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.TimeRemainingProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.TimeRemainingProperty Class | StarTeam Namespace


WorkRecord.Type.TimeRemainingProperty Properties

The properties of the WorkRecord.Type.TimeRemainingProperty class are listed below. For a complete list of WorkRecord.Type.TimeRemainingProperty class members, see the WorkRecord.Type.TimeRemainingProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

See Also

WorkRecord.Type.TimeRemainingProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.TimeRemainingProperty.NAME Property

public static String NAME {get;}

See Also

WorkRecord.Type.TimeRemainingProperty Class | StarTeam Namespace


WorkRecord.Type.TimeRemainingProperty Methods

The methods of the WorkRecord.Type.TimeRemainingProperty class are listed below. For a complete list of WorkRecord.Type.TimeRemainingProperty class members, see the WorkRecord.Type.TimeRemainingProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.TimeRemainingProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.TimeRemainingProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.TimeRemainingProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.TimeRemainingProperty Class | StarTeam Namespace


WorkRecord.Type.TimeRemainingProperty.Equals Method

Delegate Equals() to com.starteam.WorkRecord.Type.TimeRemainingProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WorkRecord.Type.TimeRemainingProperty.Equals(obj).

See Also

WorkRecord.Type.TimeRemainingProperty Class | StarTeam Namespace


WorkRecord.Type.TimeRemainingProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.WorkRecord.Type.TimeRemainingProperty.

public override int GetHashCode();

Return Value

com.starteam.WorkRecord.Type.TimeRemainingProperty.GetHashCode().

See Also

WorkRecord.Type.TimeRemainingProperty Class | StarTeam Namespace


WorkRecord.Type.TimeRemainingProperty.ToString Method

Delegate ToString() to com.starteam.WorkRecord.Type.TimeRemainingProperty.

public override string ToString();

Return Value

com.starteam.WorkRecord.Type.TimeRemainingProperty.ToString()

See Also

WorkRecord.Type.TimeRemainingProperty Class | StarTeam Namespace


WorkRecord.Type.TimeWorkedProperty Class

The property type of the TimeWorked property

For a list of all members of this type, see WorkRecord.Type.TimeWorkedProperty Members.

System.Object
Property
ScalarProperty
TimeSpanProperty
WorkRecord.Type.TimeWorkedProperty

public class WorkRecord.Type.TimeWorkedProperty : TimeSpanProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord.Type.TimeWorkedProperty Members | StarTeam Namespace


WorkRecord.Type.TimeWorkedProperty Members

WorkRecord.Type.TimeWorkedProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.TimeWorkedProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.TimeWorkedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.TimeWorkedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.TimeWorkedProperty Class | StarTeam Namespace


WorkRecord.Type.TimeWorkedProperty Properties

The properties of the WorkRecord.Type.TimeWorkedProperty class are listed below. For a complete list of WorkRecord.Type.TimeWorkedProperty class members, see the WorkRecord.Type.TimeWorkedProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayFormat (inherited from TimeSpanProperty) | [read/write] String
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
MinValue (inherited from TimeSpanProperty) | [read/write] TimeSpan
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.
Units (inherited from TimeSpanProperty) | [read/write] TimeSpan

See Also

WorkRecord.Type.TimeWorkedProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.TimeWorkedProperty.NAME Property

public static String NAME {get;}

See Also

WorkRecord.Type.TimeWorkedProperty Class | StarTeam Namespace


WorkRecord.Type.TimeWorkedProperty Methods

The methods of the WorkRecord.Type.TimeWorkedProperty class are listed below. For a complete list of WorkRecord.Type.TimeWorkedProperty class members, see the WorkRecord.Type.TimeWorkedProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.TimeWorkedProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.TimeWorkedProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from TimeSpanProperty) |
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.TimeWorkedProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.TimeWorkedProperty Class | StarTeam Namespace


WorkRecord.Type.TimeWorkedProperty.Equals Method

Delegate Equals() to com.starteam.WorkRecord.Type.TimeWorkedProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WorkRecord.Type.TimeWorkedProperty.Equals(obj).

See Also

WorkRecord.Type.TimeWorkedProperty Class | StarTeam Namespace


WorkRecord.Type.TimeWorkedProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.WorkRecord.Type.TimeWorkedProperty.

public override int GetHashCode();

Return Value

com.starteam.WorkRecord.Type.TimeWorkedProperty.GetHashCode().

See Also

WorkRecord.Type.TimeWorkedProperty Class | StarTeam Namespace


WorkRecord.Type.TimeWorkedProperty.ToString Method

Delegate ToString() to com.starteam.WorkRecord.Type.TimeWorkedProperty.

public override string ToString();

Return Value

com.starteam.WorkRecord.Type.TimeWorkedProperty.ToString()

See Also

WorkRecord.Type.TimeWorkedProperty Class | StarTeam Namespace


WorkRecord.Type.WorkedOnProperty Class

The property type of the WorkedOn property

For a list of all members of this type, see WorkRecord.Type.WorkedOnProperty Members.

System.Object
Property
ScalarProperty
DateProperty
WorkRecord.Type.WorkedOnProperty

public class WorkRecord.Type.WorkedOnProperty : DateProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord.Type.WorkedOnProperty Members | StarTeam Namespace


WorkRecord.Type.WorkedOnProperty Members

WorkRecord.Type.WorkedOnProperty overview

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.WorkedOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.WorkedOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.WorkedOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.WorkedOnProperty Class | StarTeam Namespace


WorkRecord.Type.WorkedOnProperty Properties

The properties of the WorkRecord.Type.WorkedOnProperty class are listed below. For a complete list of WorkRecord.Type.WorkedOnProperty class members, see the WorkRecord.Type.WorkedOnProperty Members topic.

Public Static Properties

NAME

Public Instance Properties

DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from DateProperty) | [read/write] the default Date value for this Property
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
MaxValue (inherited from DateProperty) | [read/write] the maximum Date value for this Property
MinValue (inherited from DateProperty) | [read/write] the minimum Date value for this Property
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
Type (inherited from Property) | [read] the Type object that "owns" this property.

See Also

WorkRecord.Type.WorkedOnProperty Class | StarTeam Namespace


NAME Property

Borland StarTeam SDK for .NET

WorkRecord.Type.WorkedOnProperty.NAME Property

public static String NAME {get;}

See Also

WorkRecord.Type.WorkedOnProperty Class | StarTeam Namespace


WorkRecord.Type.WorkedOnProperty Methods

The methods of the WorkRecord.Type.WorkedOnProperty class are listed below. For a complete list of WorkRecord.Type.WorkedOnProperty class members, see the WorkRecord.Type.WorkedOnProperty Members topic.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
Equals | Delegate Equals() to com.starteam.WorkRecord.Type.WorkedOnProperty.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.Type.WorkedOnProperty.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from DateProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToString | Delegate ToString() to com.starteam.WorkRecord.Type.WorkedOnProperty.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

WorkRecord.Type.WorkedOnProperty Class | StarTeam Namespace


WorkRecord.Type.WorkedOnProperty.Equals Method

Delegate Equals() to com.starteam.WorkRecord.Type.WorkedOnProperty.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WorkRecord.Type.WorkedOnProperty.Equals(obj).

See Also

WorkRecord.Type.WorkedOnProperty Class | StarTeam Namespace


WorkRecord.Type.WorkedOnProperty.GetHashCode Method

Delegate GetHashCode() to com.starteam.WorkRecord.Type.WorkedOnProperty.

public override int GetHashCode();

Return Value

com.starteam.WorkRecord.Type.WorkedOnProperty.GetHashCode().

See Also

WorkRecord.Type.WorkedOnProperty Class | StarTeam Namespace


WorkRecord.Type.WorkedOnProperty.ToString Method

Delegate ToString() to com.starteam.WorkRecord.Type.WorkedOnProperty.

public override string ToString();

Return Value

com.starteam.WorkRecord.Type.WorkedOnProperty.ToString()

See Also

WorkRecord.Type.WorkedOnProperty Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord Class

Item accessor for cached SDK WorkRecords contained objects are obtained from the artifact cache

For a list of all members of this type, see WorkRecord.WebCacheWorkRecord Members.

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
WorkRecord.WebCacheWorkRecord

public class WorkRecord.WebCacheWorkRecord : WebCacheTrackedObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkRecord.WebCacheWorkRecord Members | StarTeam Namespace


WorkRecord.WebCacheWorkRecord Members

WorkRecord.WebCacheWorkRecord overview

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DateWorkedOn | [read/write] the date on which the work was begun.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
EstimatedTimeRemaining | [read/write] the estimated time remaining to complete the task after this period.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
Notes | [read/write] the notes about this work record.
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object
TimeWorked | [read/write] the time spent on the task during this period.
WorkPerformedBy | [read/write] the user who performed the work.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.WorkRecord.WebCacheWorkRecord.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.WebCacheWorkRecord.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.WorkRecord.WebCacheWorkRecord.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord Properties

The properties of the WorkRecord.WebCacheWorkRecord class are listed below. For a complete list of WorkRecord.WebCacheWorkRecord class members, see the WorkRecord.WebCacheWorkRecord Members topic.

Public Instance Properties

Context | [read] the context of this object.
CreatedBy | [read] The user who created this object.
CreatedTime | [read] The date and time at which this object was created.
DateWorkedOn | [read/write] the date on which the work was begun.
DisplayName | [read] A short string that can be used to refer to this item in an application's user interface.
EstimatedTimeRemaining | [read/write] the estimated time remaining to complete the task after this period.
ID | [read] the ID of the underlying object
IsDirty | [read] true if this object is dirty
IsNew | [read] true if this resource has not yet been stored in the server.
ModifiedBy | [read] The user who last modified this object.
ModifiedTime | [read] The date and time at which this object was last modified.
MyType | [read] the type of this resource.
Name |
NameProperty |
Notes | [read/write] the notes about this work record.
ObjectID | [read] The unique identifier for the underlying object.
Server | [read] the Server for this cached object
TimeWorked | [read/write] the time spent on the task during this period.
WorkPerformedBy | [read/write] the user who performed the work.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


Context Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.Context Property

[read] the context of this object.

new public virtual ArtifactCacheManager.Context Context {get;}

Property Value

the context of this object.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


CreatedBy Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.CreatedBy Property

[read] The user who created this object.

new public virtual User.WebCacheUser CreatedBy {get;}

Property Value

The user who created this object.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


CreatedTime Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.CreatedTime Property

[read] The date and time at which this object was created.

new public virtual DateTime CreatedTime {get;}

Property Value

The date and time at which this object was created.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


DateWorkedOn Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.DateWorkedOn Property

[read/write] the date on which the work was begun.

public virtual Date DateWorkedOn {get; set;}

Property Value

the date on which the work was begun.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


DisplayName Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.DisplayName Property

[read] A short string that can be used to refer to this item in an application's user interface.

new public virtual String DisplayName {get;}

Property Value

A short string that can be used to refer to this item in an application's user interface.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


EstimatedTimeRemaining Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.EstimatedTimeRemaining Property

[read/write] the estimated time remaining to complete the task after this period.

public virtual TimeSpan EstimatedTimeRemaining {get; set;}

Property Value

the estimated time remaining to complete the task after this period.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


ID Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.ID Property

[read] the ID of the underlying object

new public virtual Int32 ID {get;}

Property Value

the ID of the underlying object

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


IsDirty Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.IsDirty Property

[read] true if this object is dirty

new public virtual Boolean IsDirty {get;}

Property Value

true if this object is dirty

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


IsNew Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.IsNew Property

[read] true if this resource has not yet been stored in the server.

new public virtual Boolean IsNew {get;}

Property Value

true if this resource has not yet been stored in the server.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


ModifiedBy Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.ModifiedBy Property

[read] The user who last modified this object.

new public virtual User.WebCacheUser ModifiedBy {get;}

Property Value

The user who last modified this object.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


ModifiedTime Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.ModifiedTime Property

[read] The date and time at which this object was last modified.

new public virtual DateTime ModifiedTime {get;}

Property Value

The date and time at which this object was last modified.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


MyType Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.MyType Property

[read] the type of this resource.

new public virtual Type.WebCacheType MyType {get;}

Property Value

the type of this resource.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


Name Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.Name Property

new public virtual String Name {get;}

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


NameProperty Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.NameProperty Property

new public virtual TextProperty.WebCacheTextProperty NameProperty {get;}

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


Notes Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.Notes Property

[read/write] the notes about this work record.

public virtual String Notes {get; set;}

Property Value

the notes about this work record.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


ObjectID Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.ObjectID Property

[read] The unique identifier for the underlying object.

new public virtual Int32 ObjectID {get;}

Property Value

The unique identifier for the underlying object.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


Server Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.Server Property

[read] the Server for this cached object

new public virtual Server.WebCacheServer Server {get;}

Property Value

the Server for this cached object

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


TimeWorked Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.TimeWorked Property

[read/write] the time spent on the task during this period.

public virtual TimeSpan TimeWorked {get; set;}

Property Value

the time spent on the task during this period.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkPerformedBy Property

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.WorkPerformedBy Property

[read/write] the user who performed the work.

public virtual User.WebCacheUser WorkPerformedBy {get; set;}

Property Value

the user who performed the work.

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord Methods

The methods of the WorkRecord.WebCacheWorkRecord class are listed below. For a complete list of WorkRecord.WebCacheWorkRecord class members, see the WorkRecord.WebCacheWorkRecord Members topic.

Public Instance Methods

AddTo |
Equals | Delegate Equals() to com.starteam.WorkRecord.WebCacheWorkRecord.
GetHashCode | Delegate GetHashCode() to com.starteam.WorkRecord.WebCacheWorkRecord.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue | Overloaded. get the value of the property as specified by name
HasValue |
Refresh | replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances
Remove | Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction
RemoveFrom |
SetValue | Overloaded. set the value of the property as specified by name
ToStarTeamURL | Resolves this StarTeam resource to a corresponding URL using an ID based scheme
ToString | Delegate ToString() to com.starteam.WorkRecord.WebCacheWorkRecord.
Update | Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord.AddTo Method

new public virtual void AddTo(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord.Equals Method

Delegate Equals() to com.starteam.WorkRecord.WebCacheWorkRecord.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.WorkRecord.WebCacheWorkRecord.Equals(obj).

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord.GetHashCode Method

Delegate GetHashCode() to com.starteam.WorkRecord.WebCacheWorkRecord.

public override int GetHashCode();

Return Value

com.starteam.WorkRecord.WebCacheWorkRecord.GetHashCode().

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


GetValue Method

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.GetValue Method

Overload List

new public virtual object GetValue(Property.WebCacheProperty);

get the value of the property as specified by name

new public virtual object GetValue(String);

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord.GetValue Method (Property#WebCacheProperty)

new public virtual object GetValue(
Property.WebCacheProperty p
);

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace | WorkRecord.WebCacheWorkRecord.GetValue Overload List


WorkRecord.WebCacheWorkRecord.GetValue Method (String)

get the value of the property as specified by name

new public virtual object GetValue(
String propertyName
);

Parameters

propertyName
the name of the property

Return Value

the value of the property

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace | WorkRecord.WebCacheWorkRecord.GetValue Overload List


WorkRecord.WebCacheWorkRecord.HasValue Method

new public virtual bool HasValue(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord.Refresh Method

replace the (possibly out-dated) instance of the contained live object with an appropriate read only instance from the ArtifactCache will no-op for new (unsaved) artifact instances

new public virtual void Refresh();

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord.Remove Method

Remove this LiveObject from the repository This is an atomic operation, not executed in a transaction

new public virtual void Remove();

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace | WebCacheViewMemberCollection


WorkRecord.WebCacheWorkRecord.RemoveFrom Method

new public virtual void RemoveFrom(
ObjectArrayProperty.WebCacheObjectArrayProperty property,
LiveObject.WebCacheLiveObject _object
);

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


SetValue Method

Borland StarTeam SDK for .NET

WorkRecord.WebCacheWorkRecord.SetValue Method

Overload List

new public virtual void SetValue(Property.WebCacheProperty,Object);

set the value of the property as specified by name

new public virtual void SetValue(String,Object);

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord.SetValue Method (Property#WebCacheProperty, Object)

new public virtual void SetValue(
Property.WebCacheProperty p,
Object value
);

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace | WorkRecord.WebCacheWorkRecord.SetValue Overload List


WorkRecord.WebCacheWorkRecord.SetValue Method (String, Object)

set the value of the property as specified by name

new public virtual void SetValue(
String propertyName,
Object value
);

Parameters

propertyName
the name of the property
value
the value to set

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace | WorkRecord.WebCacheWorkRecord.SetValue Overload List


WorkRecord.WebCacheWorkRecord.ToStarTeamURL Method

Resolves this StarTeam resource to a corresponding URL using an ID based scheme

new public virtual string ToStarTeamURL();

Return Value

a String URL that uniquely identifies this resource

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord.ToString Method

Delegate ToString() to com.starteam.WorkRecord.WebCacheWorkRecord.

public override string ToString();

Return Value

com.starteam.WorkRecord.WebCacheWorkRecord.ToString()

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace


WorkRecord.WebCacheWorkRecord.Update Method

Save this LiveObject to the Repository If the underlying SDK object is new, create it Otherwise, if it has changed, update it This is an atomic operation, not executed in a transaction

new public virtual void Update();

See Also

WorkRecord.WebCacheWorkRecord Class | StarTeam Namespace | WebCacheViewMemberCollection


StarTeam.Diff

Borland StarTeam SDK for .NET

StarTeam.Diff Namespace

Namespace hierarchy

Classes

Class | Description
BasicCompare | BasicCompare is a implementation of the DiffCompare interface that can be used to compare two files with many different options. This class supports column masking (ignoring chars in a column), ignoring case and different white space ignore options. See also DiffOptions for case and whitespace options.
ColumnMask | This class supports masks defined as a column range (e.g. columns 2-4) an optionally require the first character to be numeric. This is a common type of mask and is used by PVCS.
ConsoleWriter | This interface can be used when reconstructing a target from a source and a delta
DiffCompare | The DiffCompare interface can be used to delegate the comparison of objects. It is used to compute a has value for an object and compare two objects for equality.
DiffException |
Edit | An Edit
EditCollection | A collection of Edits managed by the differencing engine
EditListWriter | This interface can be used when reconstructing a target from a source and a delta
HTMLDiffWriter | Writes a simple HTML page showing the differences between two text files.
HTMLInterleavedDiffWriter | Writes a simple HTML page showing the differences between two text files.
HTMLStereoDiffWriter | Writes a simple HTML page showing the differences between two text files.
HTMLTableDiffWriter | Shared implementation for HTMLInterleavedDiffWriter and HTMLStereoDiffWriter.
IntralineSequence | Represents a sequence of characters within a line.
LineIterator | This class iterates over characters in a line. It actually iterates from the back forward.
ParsedCharSequence | A ParsedChar Sequence
SharedCharSequence | An implementation of the ByteSequence interface that uses an underlying byte array along with an offset and length parameter.
StarTeamDiff | The standard StarTeam Differencing Engine
StarTeamMerge | Run a simple merge
StarTeamMerge.FileDetails | Details of the file involved in the merge.
StringCharSequence | A String Char Sequence
StringCompare | Compares two strings using the differencing engine

Interfaces

Interface | Description
CharSequence | The ByteSequence interface is used by the diff engine. The intention is that a file be broken down into "lines" which are exposed as a ByteSequence. The interface is quite simple, it need only support the ability to determine the length of the sequence and the ability to get a byte at a specific location (0 based). In this respect is very similar to a byte array.
Sequence | A sequence of objects.


BasicCompare Class

BasicCompare is a implementation of the DiffCompare interface that can be used to compare two files with many different options. This class supports column masking (ignoring chars in a column), ignoring case and different white space ignore options. See also DiffOptions for case and whitespace options.

For a list of all members of this type, see BasicCompare Members.

System.Object
DiffCompare
BasicCompare

public class BasicCompare : DiffCompare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

BasicCompare Members | StarTeam.Diff Namespace


BasicCompare Members

BasicCompare overview

Public Static Properties

COMPARE_EOL
DIFF_B_WS
DIFF_W_WS
IGNORE_CASE
INTERIOR_WS_EQUIV
INTERIOR_WS_IGNORE
LEADING_WS_EQUIV
LEADING_WS_IGNORE
PVCS_WS
TRAILING_WS_EQUIV
TRAILING_WS_IGNORE
VSS_WS

Public Instance Constructors

BasicCompare Overloaded. Initializes a new instance of the BasicCompare class.

Public Instance Methods

Equals (inherited from DiffCompare) | Delegate Equals() to com.starteam.diff.DiffCompare.
GetHashCode (inherited from DiffCompare) | Delegate GetHashCode() to com.starteam.diff.DiffCompare.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DiffCompare) | Delegate ToString() to com.starteam.diff.DiffCompare.

See Also

BasicCompare Class | StarTeam.Diff Namespace


BasicCompare Constructor

columnMask is an array of column numbers to ignore. It can be null.

Overload List

Can be used for binary comparison. Does no case folding, white space ignore nor column masking.

public BasicCompare();

columnMask is an array of column numbers to ignore. It can be null.

public BasicCompare(Int32,ColumnMask[]);

See Also

BasicCompare Class | StarTeam.Diff Namespace


BasicCompare Constructor (Int32, ColumnMask[])

columnMask is an array of column numbers to ignore. It can be null.

public BasicCompare(
Int32 flags,
ColumnMask[] columnMask
);

Parameters

flags
mask flags to apply
columnMask
an array of column masks

See Also

BasicCompare Class | StarTeam.Diff Namespace | BasicCompare Constructor Overload List


BasicCompare Constructor ()

Can be used for binary comparison. Does no case folding, white space ignore nor column masking.

public BasicCompare();

See Also

BasicCompare Class | StarTeam.Diff Namespace | BasicCompare Constructor Overload List


BasicCompare Properties

The properties of the BasicCompare class are listed below. For a complete list of BasicCompare class members, see the BasicCompare Members topic.

Public Static Properties

COMPARE_EOL
DIFF_B_WS
DIFF_W_WS
IGNORE_CASE
INTERIOR_WS_EQUIV
INTERIOR_WS_IGNORE
LEADING_WS_EQUIV
LEADING_WS_IGNORE
PVCS_WS
TRAILING_WS_EQUIV
TRAILING_WS_IGNORE
VSS_WS

See Also

BasicCompare Class | StarTeam.Diff Namespace


COMPARE_EOL Property

Borland StarTeam SDK for .NET

BasicCompare.COMPARE_EOL Property

public static Int32 COMPARE_EOL {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


DIFF_B_WS Property

Borland StarTeam SDK for .NET

BasicCompare.DIFF_B_WS Property

public static Int32 DIFF_B_WS {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


DIFF_W_WS Property

Borland StarTeam SDK for .NET

BasicCompare.DIFF_W_WS Property

public static Int32 DIFF_W_WS {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


IGNORE_CASE Property

Borland StarTeam SDK for .NET

BasicCompare.IGNORE_CASE Property

public static Int32 IGNORE_CASE {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


INTERIOR_WS_EQUIV Property

Borland StarTeam SDK for .NET

BasicCompare.INTERIOR_WS_EQUIV Property

public static Int32 INTERIOR_WS_EQUIV {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


INTERIOR_WS_IGNORE Property

Borland StarTeam SDK for .NET

BasicCompare.INTERIOR_WS_IGNORE Property

public static Int32 INTERIOR_WS_IGNORE {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


LEADING_WS_EQUIV Property

Borland StarTeam SDK for .NET

BasicCompare.LEADING_WS_EQUIV Property

public static Int32 LEADING_WS_EQUIV {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


LEADING_WS_IGNORE Property

Borland StarTeam SDK for .NET

BasicCompare.LEADING_WS_IGNORE Property

public static Int32 LEADING_WS_IGNORE {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


PVCS_WS Property

Borland StarTeam SDK for .NET

BasicCompare.PVCS_WS Property

public static Int32 PVCS_WS {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


TRAILING_WS_EQUIV Property

Borland StarTeam SDK for .NET

BasicCompare.TRAILING_WS_EQUIV Property

public static Int32 TRAILING_WS_EQUIV {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


TRAILING_WS_IGNORE Property

Borland StarTeam SDK for .NET

BasicCompare.TRAILING_WS_IGNORE Property

public static Int32 TRAILING_WS_IGNORE {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


VSS_WS Property

Borland StarTeam SDK for .NET

BasicCompare.VSS_WS Property

public static Int32 VSS_WS {get;}

See Also

BasicCompare Class | StarTeam.Diff Namespace


CharSequence Interface

The ByteSequence interface is used by the diff engine. The intention is that a file be broken down into "lines" which are exposed as a ByteSequence. The interface is quite simple, it need only support the ability to determine the length of the sequence and the ability to get a byte at a specific location (0 based). In this respect is very similar to a byte array.

For a list of all members of this type, see CharSequence Members.

public interface CharSequence

Types that implement CharSequence

Type | Description
SharedCharSequence | An implementation of the ByteSequence interface that uses an underlying byte array along with an offset and length parameter.
StringCharSequence | A String Char Sequence

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

CharSequence Members | StarTeam.Diff Namespace


CharSequence Members

CharSequence overview

Public Instance Properties

Length [read] the length of the sequence

Public Instance Methods

CharAt Returns the char located at the nth position (zero-based).

See Also

CharSequence Interface | StarTeam.Diff Namespace


CharSequence Properties

The properties of the CharSequence interface are listed below. For a complete list of CharSequence interface members, see the CharSequence Members topic.

Public Instance Properties

Length [read] the length of the sequence

See Also

CharSequence Interface | StarTeam.Diff Namespace


Length Property

Borland StarTeam SDK for .NET

CharSequence.Length Property

[read] the length of the sequence

Int32 Length {get;}

Property Value

the length of the sequence

See Also

CharSequence Interface | StarTeam.Diff Namespace


CharSequence Methods

The methods of the CharSequence interface are listed below. For a complete list of CharSequence interface members, see the CharSequence Members topic.

Public Instance Methods

CharAt Returns the char located at the nth position (zero-based).

See Also

CharSequence Interface | StarTeam.Diff Namespace


CharSequence.CharAt Method

Returns the char located at the nth position (zero-based).

char CharAt(
Int32 n
);

Parameters

n
the nth position

Return Value

the char at that position

See Also

CharSequence Interface | StarTeam.Diff Namespace


ColumnMask Class

This class supports masks defined as a column range (e.g. columns 2-4) an optionally require the first character to be numeric. This is a common type of mask and is used by PVCS.

For a list of all members of this type, see ColumnMask Members.

System.Object
ColumnMask

public class ColumnMask

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

ColumnMask Members | StarTeam.Diff Namespace


ColumnMask Members

ColumnMask overview

Public Instance Constructors

ColumnMask Constructor Construct a new BasiColumn mask from first to last (inclusive). If numeric is true then the column will only be masked if the character in the first column is a digit.

Public Instance Properties

DebugString [read] a string used for debugging

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.ColumnMask.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.ColumnMask.
GetType (inherited from Object) | Gets the Type of the current instance.
SkipBy | return distance to skip from column if this ColumnMask includes this column. Should return 0 if not skipped.
ToString | Delegate ToString() to com.starteam.diff.ColumnMask.

See Also

ColumnMask Class | StarTeam.Diff Namespace


ColumnMask Constructor

Construct a new BasiColumn mask from first to last (inclusive). If numeric is true then the column will only be masked if the character in the first column is a digit.

public ColumnMask(
Int32 first,
Int32 last,
Boolean numeric
);

Parameters

first
from the first column
last
to the last column
numeric
the type of mask

See Also

ColumnMask Class | StarTeam.Diff Namespace


ColumnMask Properties

The properties of the ColumnMask class are listed below. For a complete list of ColumnMask class members, see the ColumnMask Members topic.

Public Instance Properties

DebugString [read] a string used for debugging

See Also

ColumnMask Class | StarTeam.Diff Namespace


DebugString Property

Borland StarTeam SDK for .NET

ColumnMask.DebugString Property

[read] a string used for debugging

public virtual String DebugString {get;}

Property Value

a string used for debugging

See Also

ColumnMask Class | StarTeam.Diff Namespace


ColumnMask Methods

The methods of the ColumnMask class are listed below. For a complete list of ColumnMask class members, see the ColumnMask Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.ColumnMask.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.ColumnMask.
GetType (inherited from Object) | Gets the Type of the current instance.
SkipBy | return distance to skip from column if this ColumnMask includes this column. Should return 0 if not skipped.
ToString | Delegate ToString() to com.starteam.diff.ColumnMask.

See Also

ColumnMask Class | StarTeam.Diff Namespace


ColumnMask.Equals Method

Delegate Equals() to com.starteam.diff.ColumnMask.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.diff.ColumnMask.Equals(obj).

See Also

ColumnMask Class | StarTeam.Diff Namespace


ColumnMask.GetHashCode Method

Delegate GetHashCode() to com.starteam.diff.ColumnMask.

public override int GetHashCode();

Return Value

com.starteam.diff.ColumnMask.GetHashCode().

See Also

ColumnMask Class | StarTeam.Diff Namespace


ColumnMask.SkipBy Method

return distance to skip from column if this ColumnMask includes this column. Should return 0 if not skipped.

public virtual int SkipBy(
Int32 column,
CharSequence sequence
);

Parameters

column
the column to skip
sequence
the char sequence to apply

See Also

ColumnMask Class | StarTeam.Diff Namespace


ColumnMask.ToString Method

Delegate ToString() to com.starteam.diff.ColumnMask.

public override string ToString();

Return Value

com.starteam.diff.ColumnMask.ToString()

See Also

ColumnMask Class | StarTeam.Diff Namespace


ConsoleWriter Class

This interface can be used when reconstructing a target from a source and a delta

For a list of all members of this type, see ConsoleWriter Members.

System.Object
EditListWriter
ConsoleWriter

public class ConsoleWriter : EditListWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

ConsoleWriter Members | StarTeam.Diff Namespace


ConsoleWriter Members

ConsoleWriter overview

Public Instance Constructors

ConsoleWriter Constructor

Public Instance Methods

DeleteLines (inherited from EditListWriter) | called when lines are deleted
Equals (inherited from EditListWriter) | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish (inherited from EditListWriter) | called when the last lines are being processed
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) | called when lines are inserted
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) | write to the list

See Also

ConsoleWriter Class | StarTeam.Diff Namespace


ConsoleWriter Constructor

public ConsoleWriter(
TextWriter output,
Boolean lineNumbers,
Int32 tabs,
Int32 contextLines,
ParsedCharSequence source,
ParsedCharSequence target
);

See Also

ConsoleWriter Class | StarTeam.Diff Namespace


DiffCompare Class

The DiffCompare interface can be used to delegate the comparison of objects. It is used to compute a has value for an object and compare two objects for equality.

For a list of all members of this type, see DiffCompare Members.

System.Object
DiffCompare
BasicCompare
StringCompare

public class DiffCompare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

DiffCompare Members | StarTeam.Diff Namespace


DiffCompare Members

DiffCompare overview

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.DiffCompare.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.DiffCompare.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.DiffCompare.

See Also

DiffCompare Class | StarTeam.Diff Namespace


DiffCompare Methods

The methods of the DiffCompare class are listed below. For a complete list of DiffCompare class members, see the DiffCompare Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.DiffCompare.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.DiffCompare.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.DiffCompare.

See Also

DiffCompare Class | StarTeam.Diff Namespace


DiffCompare.Equals Method

Delegate Equals() to com.starteam.diff.DiffCompare.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.diff.DiffCompare.Equals(obj).

See Also

DiffCompare Class | StarTeam.Diff Namespace


DiffCompare.GetHashCode Method

Delegate GetHashCode() to com.starteam.diff.DiffCompare.

public override int GetHashCode();

Return Value

com.starteam.diff.DiffCompare.GetHashCode().

See Also

DiffCompare Class | StarTeam.Diff Namespace


DiffCompare.ToString Method

Delegate ToString() to com.starteam.diff.DiffCompare.

public override string ToString();

Return Value

com.starteam.diff.DiffCompare.ToString()

See Also

DiffCompare Class | StarTeam.Diff Namespace


DiffException Class

For a list of all members of this type, see DiffException Members.

System.Object
Exception
DiffException

public class DiffException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

DiffException Members | StarTeam.Diff Namespace


DiffException Members

DiffException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.DiffException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.DiffException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.DiffException.

See Also

DiffException Class | StarTeam.Diff Namespace


DiffException Methods

The methods of the DiffException class are listed below. For a complete list of DiffException class members, see the DiffException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.DiffException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.DiffException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.DiffException.

See Also

DiffException Class | StarTeam.Diff Namespace


DiffException.Equals Method

Delegate Equals() to com.starteam.diff.DiffException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.diff.DiffException.Equals(obj).

See Also

DiffException Class | StarTeam.Diff Namespace


DiffException.GetHashCode Method

Delegate GetHashCode() to com.starteam.diff.DiffException.

public override int GetHashCode();

Return Value

com.starteam.diff.DiffException.GetHashCode().

See Also

DiffException Class | StarTeam.Diff Namespace


DiffException.ToString Method

Delegate ToString() to com.starteam.diff.DiffException.

public override string ToString();

Return Value

com.starteam.diff.DiffException.ToString()

See Also

DiffException Class | StarTeam.Diff Namespace


Edit Class

An Edit

For a list of all members of this type, see Edit Members.

System.Object
Edit

public class Edit

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

Edit Members | StarTeam.Diff Namespace


Edit Members

Edit overview

Public Static Properties

DELETE
INSERT
REPLACE
UNCHANGED

Public Instance Constructors

Edit Constructor Create an Edit

Public Instance Properties

Action | [read] the action
EndSource | [read] the end source
EndTarget | [read] the end target
NumSourceChanges | [read] the number of source changes
NumTargetChanges | [read] the number of target changes
SourceChanges | [read] the source changes
StartSource | [read] the start source
StartTarget | [read] the start target
TargetChanges | [read] the target changes

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.Edit.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.Edit.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.Edit.

See Also

Edit Class | StarTeam.Diff Namespace


Edit Constructor

Create an Edit

public Edit(
Int32 eAction,
Int32 nStartSource,
Int32 nEndSource,
Int32 nStartTarget,
Int32 nEndTarget
);

Parameters

eAction
the action to apply
nStartSource
the source state
nEndSource
the source end
nStartTarget
the target start
nEndTarget
the target end

See Also

Edit Class | StarTeam.Diff Namespace


Edit Properties

The properties of the Edit class are listed below. For a complete list of Edit class members, see the Edit Members topic.

Public Static Properties

DELETE
INSERT
REPLACE
UNCHANGED

Public Instance Properties

Action | [read] the action
EndSource | [read] the end source
EndTarget | [read] the end target
NumSourceChanges | [read] the number of source changes
NumTargetChanges | [read] the number of target changes
SourceChanges | [read] the source changes
StartSource | [read] the start source
StartTarget | [read] the start target
TargetChanges | [read] the target changes

See Also

Edit Class | StarTeam.Diff Namespace


Action Property

Borland StarTeam SDK for .NET

Edit.Action Property

[read] the action

public virtual Int32 Action {get;}

Property Value

the action

See Also

Edit Class | StarTeam.Diff Namespace


DELETE Property

Borland StarTeam SDK for .NET

Edit.DELETE Property

public static Int32 DELETE {get;}

See Also

Edit Class | StarTeam.Diff Namespace


EndSource Property

Borland StarTeam SDK for .NET

Edit.EndSource Property

[read] the end source

public virtual Int32 EndSource {get;}

Property Value

the end source

See Also

Edit Class | StarTeam.Diff Namespace


EndTarget Property

Borland StarTeam SDK for .NET

Edit.EndTarget Property

[read] the end target

public virtual Int32 EndTarget {get;}

Property Value

the end target

See Also

Edit Class | StarTeam.Diff Namespace


INSERT Property

Borland StarTeam SDK for .NET

Edit.INSERT Property

public static Int32 INSERT {get;}

See Also

Edit Class | StarTeam.Diff Namespace


NumSourceChanges Property

Borland StarTeam SDK for .NET

Edit.NumSourceChanges Property

[read] the number of source changes

public virtual Int32 NumSourceChanges {get;}

Property Value

the number of source changes

See Also

Edit Class | StarTeam.Diff Namespace


NumTargetChanges Property

Borland StarTeam SDK for .NET

Edit.NumTargetChanges Property

[read] the number of target changes

public virtual Int32 NumTargetChanges {get;}

Property Value

the number of target changes

See Also

Edit Class | StarTeam.Diff Namespace


REPLACE Property

Borland StarTeam SDK for .NET

Edit.REPLACE Property

public static Int32 REPLACE {get;}

See Also

Edit Class | StarTeam.Diff Namespace


SourceChanges Property

Borland StarTeam SDK for .NET

Edit.SourceChanges Property

[read] the source changes

public virtual Int32 SourceChanges {get;}

Property Value

the source changes

See Also

Edit Class | StarTeam.Diff Namespace


StartSource Property

Borland StarTeam SDK for .NET

Edit.StartSource Property

[read] the start source

public virtual Int32 StartSource {get;}

Property Value

the start source

See Also

Edit Class | StarTeam.Diff Namespace


StartTarget Property

Borland StarTeam SDK for .NET

Edit.StartTarget Property

[read] the start target

public virtual Int32 StartTarget {get;}

Property Value

the start target

See Also

Edit Class | StarTeam.Diff Namespace


TargetChanges Property

Borland StarTeam SDK for .NET

Edit.TargetChanges Property

[read] the target changes

public virtual Int32 TargetChanges {get;}

Property Value

the target changes

See Also

Edit Class | StarTeam.Diff Namespace


UNCHANGED Property

Borland StarTeam SDK for .NET

Edit.UNCHANGED Property

public static Int32 UNCHANGED {get;}

See Also

Edit Class | StarTeam.Diff Namespace


Edit Methods

The methods of the Edit class are listed below. For a complete list of Edit class members, see the Edit Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.Edit.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.Edit.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.Edit.

See Also

Edit Class | StarTeam.Diff Namespace


Edit.Equals Method

Delegate Equals() to com.starteam.diff.Edit.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.diff.Edit.Equals(obj).

See Also

Edit Class | StarTeam.Diff Namespace


Edit.GetHashCode Method

Delegate GetHashCode() to com.starteam.diff.Edit.

public override int GetHashCode();

Return Value

com.starteam.diff.Edit.GetHashCode().

See Also

Edit Class | StarTeam.Diff Namespace


Edit.ToString Method

Delegate ToString() to com.starteam.diff.Edit.

public override string ToString();

Return Value

com.starteam.diff.Edit.ToString()

See Also

Edit Class | StarTeam.Diff Namespace


EditCollection Class

A collection of Edits managed by the differencing engine

For a list of all members of this type, see EditCollection Members.

System.Object
StarTeamCollection
EditCollection

public class EditCollection : StarTeamCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

EditCollection Members | StarTeam.Diff Namespace


EditCollection Members

EditCollection overview

Public Instance Constructors

EditCollection Constructor Construct a default Edit Collection

Public Instance Properties

Count (inherited from StarTeamCollection) | [read] the number of elements in this collection
IsEmpty (inherited from StarTeamCollection) | [read] true if this collection contains no elements
IsFixedSize (inherited from StarTeamCollection) | [read] true if this collection has a fixed size
IsModified (inherited from StarTeamCollection) | [read] true if this collection has been modified
IsReadOnly (inherited from StarTeamCollection) | [read] true if this collection is read only
IsSynchronized (inherited from StarTeamCollection) | [read] true if access to this collection is synchronized
Item (inherited from StarTeamCollection) |
SyncRoot (inherited from StarTeamCollection) | [read] an object that can be used to synchronize this collection

Public Instance Methods

Add (inherited from StarTeamCollection) | add an object to this collection
AddTo (inherited from StarTeamCollection) | Add the specified element to the collection.
Clear (inherited from StarTeamCollection) | Removes all of the elements from this collection.
Contains (inherited from StarTeamCollection) | Returns true if the specified object is a member of this collection
CopyTo (inherited from StarTeamCollection) | Copies a subset of the objects of this collection into the given array starting at the specified index. Copies a subset of the objects of this collection into the given array
Equals (inherited from StarTeamCollection) | Delegate Equals() to com.starteam.StarTeamCollection.
Get (inherited from StarTeamCollection) | Gets the object at the given index.
GetEnumerator (inherited from StarTeamCollection) |
GetHashCode (inherited from StarTeamCollection) | Delegate GetHashCode() to com.starteam.StarTeamCollection.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from StarTeamCollection) | returns the index of the object in this collection
Insert (inherited from StarTeamCollection) | insert the object into the collection at the specified index
PositionOf (inherited from StarTeamCollection) | returns the position of the object instance in this collection to locate this object, an identity comparison is made with every other object in the collection
Remove (inherited from StarTeamCollection) | remove the object from the collection
RemoveAt (inherited from StarTeamCollection) | remove the object at the specified index
ResetCapacity (inherited from StarTeamCollection) | Reset the collection, and change its initial loading capacity
Set (inherited from StarTeamCollection) | Sets the object at a given index in the collection, and removes the (existing) object at that index in the collection, provided that the object does not already exist in the collection
ToString (inherited from StarTeamCollection) | Delegate ToString() to com.starteam.StarTeamCollection.

See Also

EditCollection Class | StarTeam.Diff Namespace


EditCollection Constructor

Construct a default Edit Collection

public EditCollection();

See Also

EditCollection Class | StarTeam.Diff Namespace


EditListWriter Class

This interface can be used when reconstructing a target from a source and a delta

For a list of all members of this type, see EditListWriter Members.

System.Object
EditListWriter
ConsoleWriter
HTMLDiffWriter

public class EditListWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

EditListWriter Members | StarTeam.Diff Namespace


EditListWriter Members

EditListWriter overview

Public Instance Methods

DeleteLines | called when lines are deleted
Equals | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish | called when the last lines are being processed
GetHashCode | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines | called when lines are inserted
ReplaceLines | Called when lines in the source are replaced by lines in the target.
Start | Called to tell writer where it can get the source for the lines.
ToString | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines | When an original line from the source carries over into the rebuilt output
Write | write to the list

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter Methods

The methods of the EditListWriter class are listed below. For a complete list of EditListWriter class members, see the EditListWriter Members topic.

Public Instance Methods

DeleteLines | called when lines are deleted
Equals | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish | called when the last lines are being processed
GetHashCode | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines | called when lines are inserted
ReplaceLines | Called when lines in the source are replaced by lines in the target.
Start | Called to tell writer where it can get the source for the lines.
ToString | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines | When an original line from the source carries over into the rebuilt output
Write | write to the list

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.DeleteLines Method

called when lines are deleted

public virtual void DeleteLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

Parameters

sourceStart
the start line in the source
targetStart
the start line in the target
length
the number of lines to delete

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.Equals Method

Delegate Equals() to com.starteam.diff.EditListWriter.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.diff.EditListWriter.Equals(obj).

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.Finish Method

called when the last lines are being processed

public virtual void Finish();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.GetHashCode Method

Delegate GetHashCode() to com.starteam.diff.EditListWriter.

public override int GetHashCode();

Return Value

com.starteam.diff.EditListWriter.GetHashCode().

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.InsertLines Method

called when lines are inserted

public virtual void InsertLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

Parameters

sourceStart
the start line in the source
targetStart
the start line in the target
length
the number of lines to insert

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.ReplaceLines Method

Called when lines in the source are replaced by lines in the target.

public virtual void ReplaceLines(
Int32 sourceStart,
Int32 sourceLen,
Int32 targetStart,
Int32 targetLen
);

Parameters

sourceStart
the start line in the source
sourceLen
the length of the source
targetStart
the start line in the target
targetLen
the length of the target

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.Start Method

Called to tell writer where it can get the source for the lines.

public virtual void Start();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.ToString Method

Delegate ToString() to com.starteam.diff.EditListWriter.

public override string ToString();

Return Value

com.starteam.diff.EditListWriter.ToString()

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.UnchangedLines Method

When an original line from the source carries over into the rebuilt output

public virtual void UnchangedLines(
Int32 sourceStart,
Int32 targetStart,
Int32 length
);

Parameters

sourceStart
the start line in the source
targetStart
the start line in the target
length
the length of lines to leave unchanged

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | StarTeam.Diff Namespace


EditListWriter.Write Method

write to the list

public virtual void Write(
EditCollection list,
Int32 sourceLen,
Int32 destLen
);

Parameters

list
the collection to write to
sourceLen
the length of the source
destLen
the length of the destination

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

EditListWriter Class | StarTeam.Diff Namespace


HTMLDiffWriter Class

Writes a simple HTML page showing the differences between two text files.

For a list of all members of this type, see HTMLDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter

public class HTMLDiffWriter : EditListWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

HTMLDiffWriter Members | StarTeam.Diff Namespace


HTMLDiffWriter Members

HTMLDiffWriter overview

Public Static Properties

DEFAULT_SPACES_PER_TAB

Public Static Methods

SimpleDiff Compares two text files, and generates a simple HTML file describing the differences. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

Public Instance Constructors

HTMLDiffWriter Overloaded. Initializes a new instance of the HTMLDiffWriter class.

Public Instance Properties

AddedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL | [read/write] The base URL of the output HTML page.
PageTitle | [read/write] The title of the output HTML page.
ReplacedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

Public Instance Methods

DeleteLines (inherited from EditListWriter) | called when lines are deleted
Equals (inherited from EditListWriter) | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish (inherited from EditListWriter) | called when the last lines are being processed
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) | called when lines are inserted
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) | write to the list

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


HTMLDiffWriter Constructor

Constructs a simple HTMLDiffWriter, writing output to the specified file.

Overload List

Constructs a simple HTMLDiffWriter, writing output to the specified file.

public HTMLDiffWriter(ParsedCharSequence,ParsedCharSequence,FileInfo);

Constructs a simple HTMLDiffWriter, writing output to the specified file.

public HTMLDiffWriter(ParsedCharSequence,ParsedCharSequence,TextWriter);

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace | ParsedCharSequence


HTMLDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, FileInfo)

Constructs a simple HTMLDiffWriter, writing output to the specified file.

public HTMLDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
FileInfo output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace | HTMLDiffWriter Constructor Overload List | ParsedCharSequence


HTMLDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, TextWriter)

Constructs a simple HTMLDiffWriter, writing output to the specified file.

public HTMLDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
TextWriter output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace | HTMLDiffWriter Constructor Overload List | ParsedCharSequence


HTMLDiffWriter Properties

The properties of the HTMLDiffWriter class are listed below. For a complete list of HTMLDiffWriter class members, see the HTMLDiffWriter Members topic.

Public Static Properties

DEFAULT_SPACES_PER_TAB

Public Instance Properties

AddedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL | [read/write] The base URL of the output HTML page.
PageTitle | [read/write] The title of the output HTML page.
ReplacedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


AddedSymbolHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.AddedSymbolHTML Property

[read/write] The HTML text used to draw the symbol that indicates an "added" line.

public virtual String AddedSymbolHTML {get; set;}

Property Value

The HTML text used to draw the symbol that indicates an "added" line.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


ApplicationFooterHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ApplicationFooterHTML Property

[read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.

public virtual String ApplicationFooterHTML {get; set;}

Property Value

Application-specific HTML text to be drawn at the bottom of the output HTML page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


ApplicationHeaderHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ApplicationHeaderHTML Property

[read/write] Application-specific HTML text to be drawn at the top of the output HTML page.

public virtual String ApplicationHeaderHTML {get; set;}

Property Value

Application-specific HTML text to be drawn at the top of the output HTML page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


CRHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.CRHTML Property

[read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".

public virtual String CRHTML {get; set;}

Property Value

The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


DEFAULT_SPACES_PER_TAB Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.DEFAULT_SPACES_PER_TAB Property

public static Int32 DEFAULT_SPACES_PER_TAB {get;}

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


DeletedSymbolHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.DeletedSymbolHTML Property

[read/write] The HTML text used to draw the symbol that indicates a "deleted" line.

public virtual String DeletedSymbolHTML {get; set;}

Property Value

The HTML text used to draw the symbol that indicates a "deleted" line.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


EmbedDefaultStyles Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.EmbedDefaultStyles Property

[read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.

public virtual Boolean EmbedDefaultStyles {get; set;}

Property Value

true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


GotoBlankHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoBlankHTML Property

[read/write] The HTML text used to draw whitespace the same width as a naviation control.

public virtual String GotoBlankHTML {get; set;}

Property Value

The HTML text used to draw whitespace the same width as a naviation control.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


GotoBottomHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoBottomHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.

public virtual String GotoBottomHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


GotoFirstDiffHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoFirstDiffHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.

public virtual String GotoFirstDiffHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


GotoLastDiffHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoLastDiffHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.

public virtual String GotoLastDiffHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


GotoNextDiffHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoNextDiffHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.

public virtual String GotoNextDiffHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


GotoPrevDiffHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoPrevDiffHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.

public virtual String GotoPrevDiffHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


GotoTopHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.GotoTopHTML Property

[read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.

public virtual String GotoTopHTML {get; set;}

Property Value

The HTML text used to draw the navigation symbol that jumps to the top of the output page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


InlineDeleteMarkHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.InlineDeleteMarkHTML Property

[read/write] The HTML text used to mark an in-line deletion point within a source line.

public virtual String InlineDeleteMarkHTML {get; set;}

Property Value

The HTML text used to mark an in-line deletion point within a source line.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


InlineInsertMarkHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.InlineInsertMarkHTML Property

[read/write] The HTML text used to mark an in-line insertion point within a source line.

public virtual String InlineInsertMarkHTML {get; set;}

Property Value

The HTML text used to mark an in-line insertion point within a source line.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


LFHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.LFHTML Property

[read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".

public virtual String LFHTML {get; set;}

Property Value

The string representation of the line-feed character in the HTML document. The default value is "[LF]".

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


NavigateOnEveryChangedLine Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.NavigateOnEveryChangedLine Property

[read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.

public virtual Boolean NavigateOnEveryChangedLine {get; set;}

Property Value

true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


NumContextLines Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.NumContextLines Property

[read/write] The maximum number of unchanged lines displayed before and after each changed line.

public virtual Int32 NumContextLines {get; set;}

Property Value

The maximum number of unchanged lines displayed before and after each changed line.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


PageBaseURL Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.PageBaseURL Property

[read/write] The base URL of the output HTML page.

public virtual String PageBaseURL {get; set;}

Property Value

The base URL of the output HTML page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


PageTitle Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.PageTitle Property

[read/write] The title of the output HTML page.

public virtual String PageTitle {get; set;}

Property Value

The title of the output HTML page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


ReplacedSymbolHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ReplacedSymbolHTML Property

[read/write] The HTML text used to draw the symbol that indicates a "replaced" line.

public virtual String ReplacedSymbolHTML {get; set;}

Property Value

The HTML text used to draw the symbol that indicates a "replaced" line.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


ShowEOLs Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ShowEOLs Property

[read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.

public virtual Boolean ShowEOLs {get; set;}

Property Value

true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


ShowInlineDiffs Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ShowInlineDiffs Property

[read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.

public virtual Boolean ShowInlineDiffs {get; set;}

Property Value

true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


ShowLineNumbers Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ShowLineNumbers Property

[read/write] true (the default) to embed line numbers in the HTML output; false otherwise.

public virtual Boolean ShowLineNumbers {get; set;}

Property Value

true (the default) to embed line numbers in the HTML output; false otherwise.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


ShowUnchangedLines Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.ShowUnchangedLines Property

[read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.

public virtual Boolean ShowUnchangedLines {get; set;}

Property Value

true (the default) to display unchanged lines in the HTML output; false otherwise.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


SourceFileHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.SourceFileHTML Property

[read/write] The HTML text used to display the name of the source file on the output page.

public virtual String SourceFileHTML {get; set;}

Property Value

The HTML text used to display the name of the source file on the output page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


SourceFileURL Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.SourceFileURL Property

[read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.

public virtual String SourceFileURL {get; set;}

Property Value

The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


SpacesPerTab Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.SpacesPerTab Property

[read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.

public virtual Int32 SpacesPerTab {get; set;}

Property Value

The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


StyleSheetURL Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.StyleSheetURL Property

[read/write] The URL used to reference a linked style sheet.

public virtual String StyleSheetURL {get; set;}

Property Value

The URL used to reference a linked style sheet.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


TargetFileHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.TargetFileHTML Property

[read/write] The HTML text used to display the name of the target file on the output page.

public virtual String TargetFileHTML {get; set;}

Property Value

The HTML text used to display the name of the target file on the output page.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


TargetFileURL Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.TargetFileURL Property

[read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.

public virtual String TargetFileURL {get; set;}

Property Value

The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


UnchangedSymbolHTML Property

Borland StarTeam SDK for .NET

HTMLDiffWriter.UnchangedSymbolHTML Property

[read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

public virtual String UnchangedSymbolHTML {get; set;}

Property Value

The HTML text used to draw the symbol that indicates an "unchanged" line.

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


HTMLDiffWriter Methods

The methods of the HTMLDiffWriter class are listed below. For a complete list of HTMLDiffWriter class members, see the HTMLDiffWriter Members topic.

Public Static Methods

SimpleDiff Compares two text files, and generates a simple HTML file describing the differences. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

Public Instance Methods

DeleteLines (inherited from EditListWriter) | called when lines are deleted
Equals (inherited from EditListWriter) | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish (inherited from EditListWriter) | called when the last lines are being processed
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) | called when lines are inserted
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) | write to the list

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


HTMLDiffWriter.SimpleDiff Method

Compares two text files, and generates a simple HTML file describing the differences.

Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void SimpleDiff(
FileInfo source,
FileInfo target,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starteam.diff.DiffException

See Also

HTMLDiffWriter Class | StarTeam.Diff Namespace


HTMLInterleavedDiffWriter Class

Writes a simple HTML page showing the differences between two text files.

For a list of all members of this type, see HTMLInterleavedDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter
HTMLInterleavedDiffWriter

public class HTMLInterleavedDiffWriter : HTMLTableDiffWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

HTMLInterleavedDiffWriter Members | StarTeam.Diff Namespace


HTMLInterleavedDiffWriter Members

HTMLInterleavedDiffWriter overview

Public Static Methods

Diff Overloaded. Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

Public Instance Constructors

HTMLInterleavedDiffWriter Overloaded. Initializes a new instance of the HTMLInterleavedDiffWriter class.

Public Instance Properties

AddedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines (inherited from HTMLDiffWriter) | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL (inherited from HTMLDiffWriter) | [read/write] The base URL of the output HTML page.
PageTitle (inherited from HTMLDiffWriter) | [read/write] The title of the output HTML page.
ReplacedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs (inherited from HTMLDiffWriter) | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs (inherited from HTMLDiffWriter) | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines (inherited from HTMLDiffWriter) | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab (inherited from HTMLDiffWriter) | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL (inherited from HTMLDiffWriter) | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

Public Instance Methods

DeleteLines (inherited from EditListWriter) | called when lines are deleted
Equals (inherited from EditListWriter) | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish (inherited from EditListWriter) | called when the last lines are being processed
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) | called when lines are inserted
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) | write to the list

See Also

HTMLInterleavedDiffWriter Class | StarTeam.Diff Namespace


HTMLInterleavedDiffWriter Constructor

Constructs an interleaved HTMLDiffWriter, writing output to the specified file.

Overload List

Constructs an interleaved HTMLDiffWriter, writing output to the specified file.

public HTMLInterleavedDiffWriter(ParsedCharSequence,ParsedCharSequence,FileInfo);

Constructs an interleaved HTMLDiffWriter, writing output to the specified file.

public HTMLInterleavedDiffWriter(ParsedCharSequence,ParsedCharSequence,TextWriter);

See Also

HTMLInterleavedDiffWriter Class | StarTeam.Diff Namespace | ParsedCharSequence


HTMLInterleavedDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, FileInfo)

Constructs an interleaved HTMLDiffWriter, writing output to the specified file.

public HTMLInterleavedDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
FileInfo output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLInterleavedDiffWriter Class | StarTeam.Diff Namespace | HTMLInterleavedDiffWriter Constructor Overload List | ParsedCharSequence


HTMLInterleavedDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, TextWriter)

Constructs an interleaved HTMLDiffWriter, writing output to the specified file.

public HTMLInterleavedDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
TextWriter output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLInterleavedDiffWriter Class | StarTeam.Diff Namespace | HTMLInterleavedDiffWriter Constructor Overload List | ParsedCharSequence


HTMLInterleavedDiffWriter Methods

The methods of the HTMLInterleavedDiffWriter class are listed below. For a complete list of HTMLInterleavedDiffWriter class members, see the HTMLInterleavedDiffWriter Members topic.

Public Static Methods

Diff Overloaded. Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

Public Instance Methods

DeleteLines (inherited from EditListWriter) | called when lines are deleted
Equals (inherited from EditListWriter) | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish (inherited from EditListWriter) | called when the last lines are being processed
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) | called when lines are inserted
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) | write to the list

See Also

HTMLInterleavedDiffWriter Class | StarTeam.Diff Namespace


Diff Method

Borland StarTeam SDK for .NET

HTMLInterleavedDiffWriter.Diff Method

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

Overload List

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

public static void Diff(FileInfo,FileInfo,DiffCompare,FileInfo);

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined by via a set of BasicCompare flags (e.g., LEADING_WS_IGNORE, INTERIOR_WS_EQUIV, and so on).

public static void Diff(FileInfo,FileInfo,Int32,FileInfo);

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void Diff(FileInfo,FileInfo,FileInfo);

See Also

HTMLInterleavedDiffWriter Class | StarTeam.Diff Namespace | DiffCompare


HTMLInterleavedDiffWriter.Diff Method (FileInfo, FileInfo, DiffCompare, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

public static void Diff(
FileInfo source,
FileInfo target,
DiffCompare compare,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
compare
Text comparison algorithm.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starteam.diff.DiffException

See Also

HTMLInterleavedDiffWriter Class | StarTeam.Diff Namespace | HTMLInterleavedDiffWriter.Diff Overload List | DiffCompare


HTMLInterleavedDiffWriter.Diff Method (FileInfo, FileInfo, Int32, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion. Uses a text comparison algorithm defined by via a set of BasicCompare flags (e.g., LEADING_WS_IGNORE, INTERIOR_WS_EQUIV, and so on).

public static void Diff(
FileInfo source,
FileInfo target,
Int32 compareFlags,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
compareFlags
Flags that define the text comparison algorithm.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starteam.diff.DiffException

See Also

HTMLInterleavedDiffWriter Class | StarTeam.Diff Namespace | HTMLInterleavedDiffWriter.Diff Overload List | BasicCompare


HTMLInterleavedDiffWriter.Diff Method (FileInfo, FileInfo, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in an interleaved fashion.

Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void Diff(
FileInfo source,
FileInfo target,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starteam.diff.DiffException

See Also

HTMLInterleavedDiffWriter Class | StarTeam.Diff Namespace | HTMLInterleavedDiffWriter.Diff Overload List


HTMLStereoDiffWriter Class

Writes a simple HTML page showing the differences between two text files.

For a list of all members of this type, see HTMLStereoDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter
HTMLStereoDiffWriter

public class HTMLStereoDiffWriter : HTMLTableDiffWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

HTMLStereoDiffWriter Members | StarTeam.Diff Namespace


HTMLStereoDiffWriter Members

HTMLStereoDiffWriter overview

Public Static Methods

Diff Overloaded. Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

Public Instance Constructors

HTMLStereoDiffWriter Overloaded. Initializes a new instance of the HTMLStereoDiffWriter class.

Public Instance Properties

AddedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines (inherited from HTMLDiffWriter) | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL (inherited from HTMLDiffWriter) | [read/write] The base URL of the output HTML page.
PageTitle (inherited from HTMLDiffWriter) | [read/write] The title of the output HTML page.
ReplacedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs (inherited from HTMLDiffWriter) | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs (inherited from HTMLDiffWriter) | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines (inherited from HTMLDiffWriter) | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab (inherited from HTMLDiffWriter) | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL (inherited from HTMLDiffWriter) | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

Public Instance Methods

DeleteLines (inherited from EditListWriter) | called when lines are deleted
Equals (inherited from EditListWriter) | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish (inherited from EditListWriter) | called when the last lines are being processed
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) | called when lines are inserted
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) | write to the list

See Also

HTMLStereoDiffWriter Class | StarTeam.Diff Namespace


HTMLStereoDiffWriter Constructor

Constructs a side-by-side HTMLDiffWriter, writing output to the specified file.

Overload List

Constructs a side-by-side HTMLDiffWriter, writing output to the specified file.

public HTMLStereoDiffWriter(ParsedCharSequence,ParsedCharSequence,FileInfo);

Constructs a side-by-side HTMLDiffWriter, writing output to the specified file.

public HTMLStereoDiffWriter(ParsedCharSequence,ParsedCharSequence,TextWriter);

See Also

HTMLStereoDiffWriter Class | StarTeam.Diff Namespace | ParsedCharSequence


HTMLStereoDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, FileInfo)

Constructs a side-by-side HTMLDiffWriter, writing output to the specified file.

public HTMLStereoDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
FileInfo output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLStereoDiffWriter Class | StarTeam.Diff Namespace | HTMLStereoDiffWriter Constructor Overload List | ParsedCharSequence


HTMLStereoDiffWriter Constructor (ParsedCharSequence, ParsedCharSequence, TextWriter)

Constructs a side-by-side HTMLDiffWriter, writing output to the specified file.

public HTMLStereoDiffWriter(
ParsedCharSequence source,
ParsedCharSequence target,
TextWriter output
);

Parameters

source
A parsed representation of the source text file.
target
A parsed representation of the target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

HTMLStereoDiffWriter Class | StarTeam.Diff Namespace | HTMLStereoDiffWriter Constructor Overload List | ParsedCharSequence


HTMLStereoDiffWriter Methods

The methods of the HTMLStereoDiffWriter class are listed below. For a complete list of HTMLStereoDiffWriter class members, see the HTMLStereoDiffWriter Members topic.

Public Static Methods

Diff Overloaded. Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

Public Instance Methods

DeleteLines (inherited from EditListWriter) | called when lines are deleted
Equals (inherited from EditListWriter) | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish (inherited from EditListWriter) | called when the last lines are being processed
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) | called when lines are inserted
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) | write to the list

See Also

HTMLStereoDiffWriter Class | StarTeam.Diff Namespace


Diff Method

Borland StarTeam SDK for .NET

HTMLStereoDiffWriter.Diff Method

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

Overload List

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

public static void Diff(FileInfo,FileInfo,DiffCompare,FileInfo);

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a set of BasicCompare flags (e.g., LEADING_WS_IGNORE, INTERIOR_WS_EQUIV, and so on).

public static void Diff(FileInfo,FileInfo,Int32,FileInfo);

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void Diff(FileInfo,FileInfo,FileInfo);

See Also

HTMLStereoDiffWriter Class | StarTeam.Diff Namespace | DiffCompare


HTMLStereoDiffWriter.Diff Method (FileInfo, FileInfo, DiffCompare, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a DiffCompare interface.

public static void Diff(
FileInfo source,
FileInfo target,
DiffCompare compare,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
compare
Text comparison algorithm.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starteam.diff.DiffException

See Also

HTMLStereoDiffWriter Class | StarTeam.Diff Namespace | HTMLStereoDiffWriter.Diff Overload List | DiffCompare


HTMLStereoDiffWriter.Diff Method (FileInfo, FileInfo, Int32, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion. Uses a text comparison algorithm defined via a set of BasicCompare flags (e.g., LEADING_WS_IGNORE, INTERIOR_WS_EQUIV, and so on).

public static void Diff(
FileInfo source,
FileInfo target,
Int32 compareFlags,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
compareFlags
Flags that define the text comparison algorithm.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starteam.diff.DiffException

See Also

HTMLStereoDiffWriter Class | StarTeam.Diff Namespace | HTMLStereoDiffWriter.Diff Overload List | BasicCompare


HTMLStereoDiffWriter.Diff Method (FileInfo, FileInfo, FileInfo)

Compares two text files, and generates an HTML file describing the differences. The text of the two files is drawn in a side-by-side fashion.

Uses a default text comparison algorithm: leading and trailing whitespace is ignored, and sequential whitespace characters within a line are treated as equivalent to a single space character.

public static void Diff(
FileInfo source,
FileInfo target,
FileInfo output
);

Parameters

source
The source text file.
target
The target text file.
output
The output file to generate.

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starteam.diff.DiffException

See Also

HTMLStereoDiffWriter Class | StarTeam.Diff Namespace | HTMLStereoDiffWriter.Diff Overload List


HTMLTableDiffWriter Class

Shared implementation for HTMLInterleavedDiffWriter and HTMLStereoDiffWriter.

For a list of all members of this type, see HTMLTableDiffWriter Members.

System.Object
EditListWriter
HTMLDiffWriter
HTMLTableDiffWriter
HTMLInterleavedDiffWriter
HTMLStereoDiffWriter

public class HTMLTableDiffWriter : HTMLDiffWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

HTMLTableDiffWriter Members | StarTeam.Diff Namespace


HTMLTableDiffWriter Members

HTMLTableDiffWriter overview

Public Instance Properties

AddedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "added" line.
ApplicationFooterHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the bottom of the output HTML page.
ApplicationHeaderHTML (inherited from HTMLDiffWriter) | [read/write] Application-specific HTML text to be drawn at the top of the output HTML page.
CRHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the Carriage-return character in the HTML document. The default value is "[CR]".
DeletedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "deleted" line.
EmbedDefaultStyles (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed a default style sheet in the HTML output; false to insert a link to an external style sheet file.
GotoBlankHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw whitespace the same width as a naviation control.
GotoBottomHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the bottom of the output page.
GotoFirstDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the first difference on the output page.
GotoLastDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the last difference on the output page.
GotoNextDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the next difference on the output page.
GotoPrevDiffHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the previous difference on the output page.
GotoTopHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the navigation symbol that jumps to the top of the output page.
InlineDeleteMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line deletion point within a source line.
InlineInsertMarkHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to mark an in-line insertion point within a source line.
LFHTML (inherited from HTMLDiffWriter) | [read/write] The string representation of the line-feed character in the HTML document. The default value is "[LF]".
NavigateOnEveryChangedLine (inherited from HTMLDiffWriter) | [read/write] true to draw navigation symbols on every changed line; false (the default) to draw navigation symbols only on the first line of multi-line changes.
NumContextLines (inherited from HTMLDiffWriter) | [read/write] The maximum number of unchanged lines displayed before and after each changed line.
PageBaseURL (inherited from HTMLDiffWriter) | [read/write] The base URL of the output HTML page.
PageTitle (inherited from HTMLDiffWriter) | [read/write] The title of the output HTML page.
ReplacedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates a "replaced" line.
ShowEOLs (inherited from HTMLDiffWriter) | [read/write] true if EOL characters are displayed in HTML document when compared differently; false (the default) they are not displayed at all.
ShowInlineDiffs (inherited from HTMLDiffWriter) | [read/write] true (the default) if "replaced" lines show markup within the line; false if each replaced line is shown as an inserted line followed by a deleted line.
ShowLineNumbers (inherited from HTMLDiffWriter) | [read/write] true (the default) to embed line numbers in the HTML output; false otherwise.
ShowUnchangedLines (inherited from HTMLDiffWriter) | [read/write] true (the default) to display unchanged lines in the HTML output; false otherwise.
SourceFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the source file on the output page.
SourceFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the source file from the output HTML page, or null if no links to the source file should be created.
SpacesPerTab (inherited from HTMLDiffWriter) | [read/write] The number of space characters represented by a single tab character, or zero if tabs are not expanded to spaces in the HTML output.
StyleSheetURL (inherited from HTMLDiffWriter) | [read/write] The URL used to reference a linked style sheet.
TargetFileHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to display the name of the target file on the output page.
TargetFileURL (inherited from HTMLDiffWriter) | [read/write] The URL used to link to the target file from the output HTML page, or null if no links to the target file should be created.
UnchangedSymbolHTML (inherited from HTMLDiffWriter) | [read/write] The HTML text used to draw the symbol that indicates an "unchanged" line.

Public Instance Methods

DeleteLines (inherited from EditListWriter) | called when lines are deleted
Equals (inherited from EditListWriter) | Delegate Equals() to com.starteam.diff.EditListWriter.
Finish (inherited from EditListWriter) | called when the last lines are being processed
GetHashCode (inherited from EditListWriter) | Delegate GetHashCode() to com.starteam.diff.EditListWriter.
GetType (inherited from Object) | Gets the Type of the current instance.
InsertLines (inherited from EditListWriter) | called when lines are inserted
ReplaceLines (inherited from EditListWriter) | Called when lines in the source are replaced by lines in the target.
Start (inherited from EditListWriter) | Called to tell writer where it can get the source for the lines.
ToString (inherited from EditListWriter) | Delegate ToString() to com.starteam.diff.EditListWriter.
UnchangedLines (inherited from EditListWriter) | When an original line from the source carries over into the rebuilt output
Write (inherited from EditListWriter) | write to the list

See Also

HTMLTableDiffWriter Class | StarTeam.Diff Namespace


IntralineSequence Class

Represents a sequence of characters within a line.

For a list of all members of this type, see IntralineSequence Members.

System.Object
IntralineSequence

public class IntralineSequence : Sequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

IntralineSequence Members | StarTeam.Diff Namespace


IntralineSequence Members

IntralineSequence overview

Public Static Properties

DiffCompare [read] A DiffCompare interface appropriate for comparing members of an intraline sequence.

Public Instance Constructors

IntralineSequence Overloaded. Initializes a new instance of the IntralineSequence class.

Public Instance Properties

Item
Size

Public Instance Methods

Add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IntralineSequence Class | StarTeam.Diff Namespace


IntralineSequence Constructor

Constructs an intraline sequence based on a sequence of characters from a single line of text. A word-based sequence is created by default.

Overload List

Constructs an intraline sequence based on a sequence of characters from a single line of text. A word-based sequence is created by default.

public IntralineSequence(CharSequence);

Constructs an intraline sequence based on a sequence of characters from a single line of text. Creates a word-based or a character-based sequence, depending on the value of the bCharacterBased parameter.

public IntralineSequence(CharSequence,Boolean);

See Also

IntralineSequence Class | StarTeam.Diff Namespace


IntralineSequence Constructor (CharSequence)

Constructs an intraline sequence based on a sequence of characters from a single line of text. A word-based sequence is created by default.

public IntralineSequence(
CharSequence chars
);

Parameters

chars
The underlying character sequence.

See Also

IntralineSequence Class | StarTeam.Diff Namespace | IntralineSequence Constructor Overload List


IntralineSequence Constructor (CharSequence, Boolean)

Constructs an intraline sequence based on a sequence of characters from a single line of text. Creates a word-based or a character-based sequence, depending on the value of the bCharacterBased parameter.

public IntralineSequence(
CharSequence chars,
Boolean bCharacterBased
);

Parameters

chars
The underlying character sequence.
bCharacterBased
true to create a character-based sequence (for deep comparison); false to create a word-based sequence (for comparisons that are likely to appear more natural to the user).

See Also

IntralineSequence Class | StarTeam.Diff Namespace | IntralineSequence Constructor Overload List


IntralineSequence Properties

The properties of the IntralineSequence class are listed below. For a complete list of IntralineSequence class members, see the IntralineSequence Members topic.

Public Static Properties

DiffCompare [read] A DiffCompare interface appropriate for comparing members of an intraline sequence.

Public Instance Properties

Item
Size

See Also

IntralineSequence Class | StarTeam.Diff Namespace


DiffCompare Property

Borland StarTeam SDK for .NET

IntralineSequence.DiffCompare Property

[read] A DiffCompare interface appropriate for comparing members of an intraline sequence.

public static DiffCompare DiffCompare {get;}

Property Value

A DiffCompare interface appropriate for comparing members of an intraline sequence.

See Also

IntralineSequence Class | StarTeam.Diff Namespace


Item Property

Borland StarTeam SDK for .NET

IntralineSequence.Item Property

public Object this[
Int32 index
] {get;}

Implements

Sequence.Item

See Also

IntralineSequence Class | StarTeam.Diff Namespace


Size Property

Borland StarTeam SDK for .NET

IntralineSequence.Size Property

public virtual Int32 Size {get;}

Implements

Sequence.Size

See Also

IntralineSequence Class | StarTeam.Diff Namespace


IntralineSequence Methods

The methods of the IntralineSequence class are listed below. For a complete list of IntralineSequence class members, see the IntralineSequence Members topic.

Public Instance Methods

Add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IntralineSequence Class | StarTeam.Diff Namespace


IntralineSequence.Add Method

public virtual bool Add(
Object o
);

Implements

Sequence.Add

See Also

IntralineSequence Class | StarTeam.Diff Namespace


IntralineSequence.Get Method

public virtual object Get(
Int32 index
);

See Also

IntralineSequence Class | StarTeam.Diff Namespace


LineIterator Class

This class iterates over characters in a line. It actually iterates from the back forward.

For a list of all members of this type, see LineIterator Members.

System.Object
LineIterator

public class LineIterator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

LineIterator Members | StarTeam.Diff Namespace


LineIterator Members

LineIterator overview

Public Instance Constructors

LineIterator Constructor Construct a Line Iterator+

Public Instance Properties

HasNext | [read]
Index | [read] -1 if nextChar() has not been called.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.LineIterator.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.LineIterator.
GetType (inherited from Object) | Gets the Type of the current instance.
NextChar | Returns the next char in the underlying sequence.
ToString | Delegate ToString() to com.starteam.diff.LineIterator.

See Also

LineIterator Class | StarTeam.Diff Namespace


LineIterator Constructor

Construct a Line Iterator+

public LineIterator(
CharSequence sequence,
Int32 flags,
ColumnMask[] mask
);

Parameters

sequence
the char sequence
flags
the flags to apply
mask
an array of column masks

See Also

LineIterator Class | StarTeam.Diff Namespace


LineIterator Properties

The properties of the LineIterator class are listed below. For a complete list of LineIterator class members, see the LineIterator Members topic.

Public Instance Properties

HasNext | [read]
Index | [read] -1 if nextChar() has not been called.

See Also

LineIterator Class | StarTeam.Diff Namespace


HasNext Property

Borland StarTeam SDK for .NET

LineIterator.HasNext Property

[read]

public virtual Boolean HasNext {get;}

See Also

LineIterator Class | StarTeam.Diff Namespace


Index Property

Borland StarTeam SDK for .NET

LineIterator.Index Property

[read] -1 if nextChar() has not been called.

public virtual Int32 Index {get;}

Property Value

-1 if nextChar() has not been called.

See Also

LineIterator Class | StarTeam.Diff Namespace


LineIterator Methods

The methods of the LineIterator class are listed below. For a complete list of LineIterator class members, see the LineIterator Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.LineIterator.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.LineIterator.
GetType (inherited from Object) | Gets the Type of the current instance.
NextChar | Returns the next char in the underlying sequence.
ToString | Delegate ToString() to com.starteam.diff.LineIterator.

See Also

LineIterator Class | StarTeam.Diff Namespace


LineIterator.Equals Method

Delegate Equals() to com.starteam.diff.LineIterator.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.diff.LineIterator.Equals(obj).

See Also

LineIterator Class | StarTeam.Diff Namespace


LineIterator.GetHashCode Method

Delegate GetHashCode() to com.starteam.diff.LineIterator.

public override int GetHashCode();

Return Value

com.starteam.diff.LineIterator.GetHashCode().

See Also

LineIterator Class | StarTeam.Diff Namespace


LineIterator.NextChar Method

Returns the next char in the underlying sequence.

public virtual char NextChar();

See Also

LineIterator Class | StarTeam.Diff Namespace


LineIterator.ToString Method

Delegate ToString() to com.starteam.diff.LineIterator.

public override string ToString();

Return Value

com.starteam.diff.LineIterator.ToString()

See Also

LineIterator Class | StarTeam.Diff Namespace


ParsedCharSequence Class

A ParsedChar Sequence

For a list of all members of this type, see ParsedCharSequence Members.

System.Object
ParsedCharSequence

public class ParsedCharSequence : Sequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

ParsedCharSequence Members | StarTeam.Diff Namespace


ParsedCharSequence Members

ParsedCharSequence overview

Public Instance Constructors

ParsedCharSequence Overloaded. Initializes a new instance of the ParsedCharSequence class.

Public Instance Properties

Item
Size

Public Instance Methods

Add |
AddLine | Add a Char Sequence
EndsWithEOL | Returns true if the content being parsed ends with an EOL character
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLine | returns the CharSequence at a given line
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


ParsedCharSequence Constructor

Construct a Parsed Char Sequence

Overload List

Construct a Parsed Char Sequence

public ParsedCharSequence(CharSequence);

construct a parsed char sequence

public ParsedCharSequence(CharSequence,Char);

public ParsedCharSequence(LineReader);

Construct a Parsed Char Sequence

public ParsedCharSequence(FileInfo);

Construct a Parsed Char Sequence

public ParsedCharSequence(FileInfo,Encoding);

Construct a Parsed Char Sequence

public ParsedCharSequence(FileInfo,Encoding,Boolean);

Construct a Parsed Char Sequence

public ParsedCharSequence(FileInfo,Boolean);

public ParsedCharSequence(TextReader);

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


ParsedCharSequence Constructor (CharSequence)

Construct a Parsed Char Sequence

public ParsedCharSequence(
CharSequence sequence
);

Parameters

sequence
the sequence

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (CharSequence, Char)

construct a parsed char sequence

public ParsedCharSequence(
CharSequence sequence,
Char delimiter
);

Parameters

sequence
the char sequence
delimiter
the delimiter to use

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (TextReader)

public ParsedCharSequence(
TextReader reader
);

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (LineReader)

public ParsedCharSequence(
LineReader reader
);

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (FileInfo)

Construct a Parsed Char Sequence

public ParsedCharSequence(
FileInfo source
);

Parameters

source
a source file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (FileInfo, Encoding)

Construct a Parsed Char Sequence

public ParsedCharSequence(
FileInfo source,
Encoding encoding
);

Parameters

source
a source file
encoding
an Encoding

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (FileInfo, Boolean)

Construct a Parsed Char Sequence

public ParsedCharSequence(
FileInfo source,
Boolean bIgnoreEOLs
);

Parameters

source
a source file
bIgnoreEOLs
true to ignore EOLs

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Constructor (FileInfo, Encoding, Boolean)

Construct a Parsed Char Sequence

public ParsedCharSequence(
FileInfo source,
Encoding encoding,
Boolean bIgnoreEOLs
);

Parameters

source
the source file
encoding
the encoding
bIgnoreEOLs
true to ignore EOLs

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace | ParsedCharSequence Constructor Overload List


ParsedCharSequence Properties

The properties of the ParsedCharSequence class are listed below. For a complete list of ParsedCharSequence class members, see the ParsedCharSequence Members topic.

Public Instance Properties

Item
Size

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


Item Property

Borland StarTeam SDK for .NET

ParsedCharSequence.Item Property

public Object this[
Int32 index
] {get;}

Implements

Sequence.Item

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


Size Property

Borland StarTeam SDK for .NET

ParsedCharSequence.Size Property

public virtual Int32 Size {get;}

Implements

Sequence.Size

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


ParsedCharSequence Methods

The methods of the ParsedCharSequence class are listed below. For a complete list of ParsedCharSequence class members, see the ParsedCharSequence Members topic.

Public Instance Methods

Add |
AddLine | Add a Char Sequence
EndsWithEOL | Returns true if the content being parsed ends with an EOL character
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLine | returns the CharSequence at a given line
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


ParsedCharSequence.Add Method

public virtual bool Add(
Object o
);

Implements

Sequence.Add

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


ParsedCharSequence.AddLine Method

Add a Char Sequence

public virtual void AddLine(
CharSequence aLine
);

Parameters

aLine
the char sequence

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


ParsedCharSequence.EndsWithEOL Method

Returns true if the content being parsed ends with an EOL character

public virtual bool EndsWithEOL();

Return Value

boolean true if the content being parsed ends with an EOL character

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


ParsedCharSequence.Get Method

public virtual object Get(
Int32 index
);

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


ParsedCharSequence.GetLine Method

returns the CharSequence at a given line

public virtual CharSequence GetLine(
Int32 n
);

Parameters

n
the index of the given line

Return Value

the char sequence

See Also

ParsedCharSequence Class | StarTeam.Diff Namespace


Sequence Interface

A sequence of objects.

For a list of all members of this type, see Sequence Members.

public interface Sequence

Types that implement Sequence

Type | Description
IntralineSequence | Represents a sequence of characters within a line.
ParsedCharSequence | A ParsedChar Sequence

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

Sequence Members | StarTeam.Diff Namespace


Sequence Members

Sequence overview

Public Instance Properties

Item |
Size | [read] size of the sequence

Public Instance Methods

Add Add the object to the sequence

See Also

Sequence Interface | StarTeam.Diff Namespace


Sequence Properties

The properties of the Sequence interface are listed below. For a complete list of Sequence interface members, see the Sequence Members topic.

Public Instance Properties

Item |
Size | [read] size of the sequence

See Also

Sequence Interface | StarTeam.Diff Namespace


Item Property

Borland StarTeam SDK for .NET

Sequence.Item Property

Object this[
Int32 index
] {get;}

See Also

Sequence Interface | StarTeam.Diff Namespace


Size Property

Borland StarTeam SDK for .NET

Sequence.Size Property

[read] size of the sequence

Int32 Size {get;}

Property Value

size of the sequence

See Also

Sequence Interface | StarTeam.Diff Namespace


Sequence Methods

The methods of the Sequence interface are listed below. For a complete list of Sequence interface members, see the Sequence Members topic.

Public Instance Methods

Add Add the object to the sequence

See Also

Sequence Interface | StarTeam.Diff Namespace


Sequence.Add Method

Add the object to the sequence

bool Add(
Object o
);

Parameters

o
Object to be added to the sequence

Return Value

true if addition of the object to the sequence was successful.

See Also

Sequence Interface | StarTeam.Diff Namespace


SharedCharSequence Class

An implementation of the ByteSequence interface that uses an underlying byte array along with an offset and length parameter.

For a list of all members of this type, see SharedCharSequence Members.

System.Object
SharedCharSequence

public class SharedCharSequence : CharSequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

SharedCharSequence Members | StarTeam.Diff Namespace


SharedCharSequence Members

SharedCharSequence overview

Public Instance Constructors

SharedCharSequence Constructor Create a new sequence using the underlying data. The sequence begins at start and has the specified length.

Public Instance Properties

Length

Public Instance Methods

CharAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SharedCharSequence Class | StarTeam.Diff Namespace


SharedCharSequence Constructor

Create a new sequence using the underlying data. The sequence begins at start and has the specified length.

public SharedCharSequence(
CharSequence data,
Int32 start,
Int32 length
);

Parameters

data
the char sequence
start
the start position
length
the length of the sequence

See Also

SharedCharSequence Class | StarTeam.Diff Namespace


SharedCharSequence Properties

The properties of the SharedCharSequence class are listed below. For a complete list of SharedCharSequence class members, see the SharedCharSequence Members topic.

Public Instance Properties

Length

See Also

SharedCharSequence Class | StarTeam.Diff Namespace


Length Property

Borland StarTeam SDK for .NET

SharedCharSequence.Length Property

public virtual Int32 Length {get;}

Implements

CharSequence.Length

See Also

SharedCharSequence Class | StarTeam.Diff Namespace


SharedCharSequence Methods

The methods of the SharedCharSequence class are listed below. For a complete list of SharedCharSequence class members, see the SharedCharSequence Members topic.

Public Instance Methods

CharAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SharedCharSequence Class | StarTeam.Diff Namespace


SharedCharSequence.CharAt Method

public virtual char CharAt(
Int32 n
);

Implements

CharSequence.CharAt

See Also

SharedCharSequence Class | StarTeam.Diff Namespace


StarTeamDiff Class

The standard StarTeam Differencing Engine

For a list of all members of this type, see StarTeamDiff Members.

System.Object
StarTeamDiff

public class StarTeamDiff

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeamDiff Members | StarTeam.Diff Namespace


StarTeamDiff Members

StarTeamDiff overview

Public Instance Constructors

StarTeamDiff Constructor Construct an empty StarTeamDiff instance

Public Instance Methods

Diff | execute a diff
Equals | Delegate Equals() to com.starteam.diff.StarTeamDiff.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.StarTeamDiff.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.StarTeamDiff.

See Also

StarTeamDiff Class | StarTeam.Diff Namespace


StarTeamDiff Constructor

Construct an empty StarTeamDiff instance

public StarTeamDiff();

See Also

StarTeamDiff Class | StarTeam.Diff Namespace


StarTeamDiff Methods

The methods of the StarTeamDiff class are listed below. For a complete list of StarTeamDiff class members, see the StarTeamDiff Members topic.

Public Instance Methods

Diff | execute a diff
Equals | Delegate Equals() to com.starteam.diff.StarTeamDiff.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.StarTeamDiff.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.StarTeamDiff.

See Also

StarTeamDiff Class | StarTeam.Diff Namespace


StarTeamDiff.Diff Method

execute a diff

public virtual EditCollection Diff(
Sequence source,
Sequence target,
DiffCompare compare
);

Parameters

source
the source sequence
target
the target sequence
compare
the comparator

Exceptions

Exception Type | Condition
 | com.starteam.diff.DiffException

See Also

StarTeamDiff Class | StarTeam.Diff Namespace


StarTeamDiff.Equals Method

Delegate Equals() to com.starteam.diff.StarTeamDiff.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.diff.StarTeamDiff.Equals(obj).

See Also

StarTeamDiff Class | StarTeam.Diff Namespace


StarTeamDiff.GetHashCode Method

Delegate GetHashCode() to com.starteam.diff.StarTeamDiff.

public override int GetHashCode();

Return Value

com.starteam.diff.StarTeamDiff.GetHashCode().

See Also

StarTeamDiff Class | StarTeam.Diff Namespace


StarTeamDiff.ToString Method

Delegate ToString() to com.starteam.diff.StarTeamDiff.

public override string ToString();

Return Value

com.starteam.diff.StarTeamDiff.ToString()

See Also

StarTeamDiff Class | StarTeam.Diff Namespace


StarTeamMerge Class

Run a simple merge

For a list of all members of this type, see StarTeamMerge Members.

System.Object
StarTeamMerge

public class StarTeamMerge

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeamMerge Members | StarTeam.Diff Namespace


StarTeamMerge Members

StarTeamMerge overview

Public Static Methods

Rollback rollback a revision of a file 'somewhere in the middle' of the set of all revisions

Public Instance Constructors

StarTeamMerge Constructor Initializes a new instance of the StarTeamMerge class.

Public Instance Properties

Comparer | [read/write] the comparer being used
EOL | [read/write] the eolFormat being used
OverlapOnly | [read/write] true if overlapping content is being output
ShowFromCommon | [read/write] true to include changed lines from the common file

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.StarTeamMerge.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.StarTeamMerge.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge |
ToString | Delegate ToString() to com.starteam.diff.StarTeamMerge.

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


StarTeamMerge Constructor

Initializes a new instance of the StarTeamMerge class.

public StarTeamMerge();

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


StarTeamMerge Properties

The properties of the StarTeamMerge class are listed below. For a complete list of StarTeamMerge class members, see the StarTeamMerge Members topic.

Public Instance Properties

Comparer | [read/write] the comparer being used
EOL | [read/write] the eolFormat being used
OverlapOnly | [read/write] true if overlapping content is being output
ShowFromCommon | [read/write] true to include changed lines from the common file

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


Comparer Property

Borland StarTeam SDK for .NET

StarTeamMerge.Comparer Property

[read/write] the comparer being used

public virtual DiffCompare Comparer {get; set;}

Property Value

the comparer being used

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


EOL Property

Borland StarTeam SDK for .NET

StarTeamMerge.EOL Property

[read/write] the eolFormat being used

public virtual File.EOLFormat EOL {get; set;}

Property Value

the eolFormat being used

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


OverlapOnly Property

Borland StarTeam SDK for .NET

StarTeamMerge.OverlapOnly Property

[read/write] true if overlapping content is being output

public virtual Boolean OverlapOnly {get; set;}

Property Value

true if overlapping content is being output

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


ShowFromCommon Property

Borland StarTeam SDK for .NET

StarTeamMerge.ShowFromCommon Property

[read/write] true to include changed lines from the common file

public virtual Boolean ShowFromCommon {get; set;}

Property Value

true to include changed lines from the common file

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


StarTeamMerge Methods

The methods of the StarTeamMerge class are listed below. For a complete list of StarTeamMerge class members, see the StarTeamMerge Members topic.

Public Static Methods

Rollback rollback a revision of a file 'somewhere in the middle' of the set of all revisions

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.StarTeamMerge.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.StarTeamMerge.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge |
ToString | Delegate ToString() to com.starteam.diff.StarTeamMerge.

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


StarTeamMerge.Equals Method

Delegate Equals() to com.starteam.diff.StarTeamMerge.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.diff.StarTeamMerge.Equals(obj).

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


StarTeamMerge.GetHashCode Method

Delegate GetHashCode() to com.starteam.diff.StarTeamMerge.

public override int GetHashCode();

Return Value

com.starteam.diff.StarTeamMerge.GetHashCode().

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


StarTeamMerge.Merge Method

public virtual bool Merge(
StarTeamMerge.FileDetails mine,
StarTeamMerge.FileDetails common,
StarTeamMerge.FileDetails yours,
StarTeamMerge.FileDetails output
);

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


StarTeamMerge.Rollback Method

rollback a revision of a file 'somewhere in the middle' of the set of all revisions

public static EditCollection Rollback(
FileInfo tip,
FileInfo skipRevision,
FileInfo reference,
String encoding,
FileInfo merged
);

Parameters

tip
, the 'tip' content of the file w.r.t. which the revision needs to be rolled back
skipRevision
the revision of the file representing the content to be rolled back
reference
the revision of the file not containing the revision to be skipped, (this would be expectedly the revision prior to the revision to be skipped)
encoding
an encoding specified by the caller, or null to signify the platform encoding
merged
the tip file with the relevant content removed

Return Value

a reference to the edit collection of unresolved, unmatched edits

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


StarTeamMerge.ToString Method

Delegate ToString() to com.starteam.diff.StarTeamMerge.

public override string ToString();

Return Value

com.starteam.diff.StarTeamMerge.ToString()

See Also

StarTeamMerge Class | StarTeam.Diff Namespace


StarTeamMerge.FileDetails Class

Details of the file involved in the merge.

For a list of all members of this type, see StarTeamMerge.FileDetails Members.

System.Object
StarTeamMerge.FileDetails

public class StarTeamMerge.FileDetails

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeamMerge.FileDetails Members | StarTeam.Diff Namespace


StarTeamMerge.FileDetails Members

StarTeamMerge.FileDetails overview

Public Instance Constructors

StarTeamMerge.FileDetails Overloaded. Initializes a new instance of the StarTeamMerge.FileDetails class.

Public Instance Properties

Encoding | [read] the file's encoding
File | [read] the associated file
Label | [read] the label to identify the file

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.StarTeamMerge.FileDetails.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.StarTeamMerge.FileDetails.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.StarTeamMerge.FileDetails.

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


StarTeamMerge.FileDetails Constructor

Constructs the file details required for the merge.

Overload List

Constructs the file details required for the merge. The file is assumed to use the ISO-8859-1 encoding.

public StarTeamMerge.FileDetails(FileInfo);

Constructs the file details required for the merge.

public StarTeamMerge.FileDetails(FileInfo,Encoding);

Constructs the file details required for the merge.

public StarTeamMerge.FileDetails(FileInfo,Encoding,String);

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


StarTeamMerge.FileDetails Constructor (FileInfo, Encoding, String)

Constructs the file details required for the merge.

public StarTeamMerge.FileDetails(
FileInfo file,
Encoding encoding,
String label
);

Parameters

file
file involved in the merge
encoding
The file's encoding.
label
A label to be used to identify this file in the markup text.

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace | StarTeamMerge.FileDetails Constructor Overload List


StarTeamMerge.FileDetails Constructor (FileInfo, Encoding)

Constructs the file details required for the merge.

public StarTeamMerge.FileDetails(
FileInfo file,
Encoding encoding
);

Parameters

file
file involved in the merge
encoding
The file's encoding.

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace | StarTeamMerge.FileDetails Constructor Overload List


StarTeamMerge.FileDetails Constructor (FileInfo)

Constructs the file details required for the merge. The file is assumed to use the ISO-8859-1 encoding.

public StarTeamMerge.FileDetails(
FileInfo file
);

Parameters

file
file involved in the merge

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace | StarTeamMerge.FileDetails Constructor Overload List


StarTeamMerge.FileDetails Properties

The properties of the StarTeamMerge.FileDetails class are listed below. For a complete list of StarTeamMerge.FileDetails class members, see the StarTeamMerge.FileDetails Members topic.

Public Instance Properties

Encoding | [read] the file's encoding
File | [read] the associated file
Label | [read] the label to identify the file

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


Encoding Property

Borland StarTeam SDK for .NET

StarTeamMerge.FileDetails.Encoding Property

[read] the file's encoding

public virtual Encoding Encoding {get;}

Property Value

the file's encoding

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


File Property

Borland StarTeam SDK for .NET

StarTeamMerge.FileDetails.File Property

[read] the associated file

public virtual FileInfo File {get;}

Property Value

the associated file

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


Label Property

Borland StarTeam SDK for .NET

StarTeamMerge.FileDetails.Label Property

[read] the label to identify the file

public virtual String Label {get;}

Property Value

the label to identify the file

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


StarTeamMerge.FileDetails Methods

The methods of the StarTeamMerge.FileDetails class are listed below. For a complete list of StarTeamMerge.FileDetails class members, see the StarTeamMerge.FileDetails Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.diff.StarTeamMerge.FileDetails.
GetHashCode | Delegate GetHashCode() to com.starteam.diff.StarTeamMerge.FileDetails.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.diff.StarTeamMerge.FileDetails.

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


StarTeamMerge.FileDetails.Equals Method

Delegate Equals() to com.starteam.diff.StarTeamMerge.FileDetails.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.diff.StarTeamMerge.FileDetails.Equals(obj).

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


StarTeamMerge.FileDetails.GetHashCode Method

Delegate GetHashCode() to com.starteam.diff.StarTeamMerge.FileDetails.

public override int GetHashCode();

Return Value

com.starteam.diff.StarTeamMerge.FileDetails.GetHashCode().

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


StarTeamMerge.FileDetails.ToString Method

Delegate ToString() to com.starteam.diff.StarTeamMerge.FileDetails.

public override string ToString();

Return Value

com.starteam.diff.StarTeamMerge.FileDetails.ToString()

See Also

StarTeamMerge.FileDetails Class | StarTeam.Diff Namespace


StringCharSequence Class

A String Char Sequence

For a list of all members of this type, see StringCharSequence Members.

System.Object
StringCharSequence

public class StringCharSequence : CharSequence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

StringCharSequence Members | StarTeam.Diff Namespace


StringCharSequence Members

StringCharSequence overview

Public Instance Constructors

StringCharSequence Constructor Construct a String Char Sequence

Public Instance Properties

Length

Public Instance Methods

CharAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringCharSequence Class | StarTeam.Diff Namespace


StringCharSequence Constructor

Construct a String Char Sequence

public StringCharSequence(
String src
);

Parameters

src
the string

See Also

StringCharSequence Class | StarTeam.Diff Namespace


StringCharSequence Properties

The properties of the StringCharSequence class are listed below. For a complete list of StringCharSequence class members, see the StringCharSequence Members topic.

Public Instance Properties

Length

See Also

StringCharSequence Class | StarTeam.Diff Namespace


Length Property

Borland StarTeam SDK for .NET

StringCharSequence.Length Property

public virtual Int32 Length {get;}

Implements

CharSequence.Length

See Also

StringCharSequence Class | StarTeam.Diff Namespace


StringCharSequence Methods

The methods of the StringCharSequence class are listed below. For a complete list of StringCharSequence class members, see the StringCharSequence Members topic.

Public Instance Methods

CharAt |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringCharSequence Class | StarTeam.Diff Namespace


StringCharSequence.CharAt Method

public virtual char CharAt(
Int32 n
);

Implements

CharSequence.CharAt

See Also

StringCharSequence Class | StarTeam.Diff Namespace


StringCompare Class

Compares two strings using the differencing engine

For a list of all members of this type, see StringCompare Members.

System.Object
DiffCompare
StringCompare

public class StringCompare : DiffCompare

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Diff

Assembly: StarTeam (in StarTeam.dll)

See Also

StringCompare Members | StarTeam.Diff Namespace


StringCompare Members

StringCompare overview

Public Instance Constructors

StringCompare Constructor Initializes a new instance of the StringCompare class.

Public Instance Methods

Equals (inherited from DiffCompare) | Delegate Equals() to com.starteam.diff.DiffCompare.
GetHashCode (inherited from DiffCompare) | Delegate GetHashCode() to com.starteam.diff.DiffCompare.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from DiffCompare) | Delegate ToString() to com.starteam.diff.DiffCompare.

See Also

StringCompare Class | StarTeam.Diff Namespace


StringCompare Constructor

Initializes a new instance of the StringCompare class.

public StringCompare();

See Also

StringCompare Class | StarTeam.Diff Namespace


StarTeam.Events

Borland StarTeam SDK for .NET

StarTeam.Events Namespace

Namespace hierarchy

Classes

Class | Description
CacheAgentEventArgs |
CacheAgentEventSource |
CheckinEventArgs |
CheckinEventSource |
CheckoutEventArgs |
CheckoutEventSource |
CommandProcessorCheckinEventArgs |
CommandProcessorCheckoutEventArgs |
CommandProcessorEventSource |
CommandProcessorPasswordEventArgs |
CommandProcessorStatusEventArgs |
FilterEventArgs |
FilterEventSource |
FolderEventArgs |
FolderEventSource |
FolderTreeEventArgs |
FolderTreeEventSource |
FolderUpdateEventArgs |
FolderUpdateEventSource |
GroupEventArgs |
GroupEventSource |
ItemEventArgs |
ItemEventSource |
ItemIDEventArgs |
ItemIDEventSource |
ItemListEventArgs |
ItemListEventSource |
ItemUpdateEventArgs |
ItemUpdateEventSource |
LabelEventArgs |
LabelEventSource |
LinkUpdateEventArgs |
LinkUpdateEventSource |
MPXMessageEventArgs |
MPXMessageEventSource |
MPXStatusEventArgs |
MPXStatusEventSource |
NotificationEventArgs |
NotificationEventSource |
ProjectEventArgs |
ProjectEventSource |
QueryEventArgs |
QueryEventSource |
ServerCommandEventArgs |
ServerCommandEventSource |
ServerControlEventArgs |
ServerControlEventSource |
TraceEventArgs |
TraceEventSource |
TypedResourceEventArgs |
TypedResourceEventSource |
TypeEventArgs |
TypeEventSource |
UserEventArgs |
UserEventSource |
ViewEventArgs |
ViewEventSource |
ViewMemberEventArgs |
ViewMemberEventSource |
ViewMemberUpdateEventArgs |
ViewMemberUpdateEventSource |
WebCacheAccessRightsEventArgs |
WebCacheAccessRightsEventSource |
WebCacheCheckinEventArgs |
WebCacheCheckinEventSource |
WebCacheCheckoutEventArgs |
WebCacheCheckoutEventSource |
WebCacheFilterEventArgs |
WebCacheFilterEventSource |
WebCacheGroupEventArgs |
WebCacheGroupEventSource |
WebCacheLabelEventArgs |
WebCacheLabelEventSource |
WebCacheLiveObjectEventArgs |
WebCacheLiveObjectEventSource |
WebCacheMPXStatusEventArgs |
WebCacheMPXStatusEventSource |
WebCacheProjectEventArgs |
WebCacheProjectEventSource |
WebCacheQueryEventArgs |
WebCacheQueryEventSource |
WebCacheServerControlEventArgs |
WebCacheServerControlEventSource |
WebCacheTypeEventArgs |
WebCacheTypeEventSource |
WebCacheUserEventArgs |
WebCacheUserEventSource |
WebCacheViewEventArgs |
WebCacheViewEventSource |
WebCacheViewMemberEventArgs |
WebCacheViewMemberEventSource |

Delegates

Delegate | Description
CacheAgentEventSource.Handler |
CheckinEventSource.Handler |
CheckoutEventSource.Handler |
CommandProcessorEventSource.CheckinHandler |
CommandProcessorEventSource.CheckoutHandler |
CommandProcessorEventSource.PasswordHandler |
CommandProcessorEventSource.StatusHandler |
FilterEventSource.Handler |
FolderEventSource.Handler |
FolderTreeEventSource.Handler |
FolderUpdateEventSource.Handler |
GroupEventSource.Handler |
ItemEventSource.Handler |
ItemIDEventSource.Handler |
ItemListEventSource.Handler |
ItemUpdateEventSource.Handler |
LabelEventSource.Handler |
LinkUpdateEventSource.Handler |
MPXMessageEventSource.Handler |
MPXStatusEventSource.Handler |
NotificationEventSource.Handler |
ProjectEventSource.Handler |
QueryEventSource.Handler |
ServerCommandEventSource.Handler |
ServerControlEventSource.Handler |
TraceEventSource.Handler |
TypedResourceEventSource.Handler |
TypeEventSource.Handler |
UserEventSource.Handler |
ViewEventSource.Handler |
ViewMemberEventSource.Handler |
ViewMemberUpdateEventSource.Handler |
WebCacheAccessRightsEventSource.Handler |
WebCacheCheckinEventSource.Handler |
WebCacheCheckoutEventSource.Handler |
WebCacheFilterEventSource.Handler |
WebCacheGroupEventSource.Handler |
WebCacheLabelEventSource.Handler |
WebCacheLiveObjectEventSource.Handler |
WebCacheMPXStatusEventSource.Handler |
WebCacheProjectEventSource.Handler |
WebCacheQueryEventSource.Handler |
WebCacheServerControlEventSource.Handler |
WebCacheTypeEventSource.Handler |
WebCacheUserEventSource.Handler |
WebCacheViewEventSource.Handler |
WebCacheViewMemberEventSource.Handler |


CacheAgentEventArgs Class

For a list of all members of this type, see CacheAgentEventArgs Members.

System.Object
EventArgs
CacheAgentEventArgs

public class CacheAgentEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CacheAgentEventArgs Members | StarTeam.Events Namespace


CacheAgentEventArgs Members

CacheAgentEventArgs overview

Public Instance Properties

BytesReceived
DebugString
ExecutionTime
IsFileContent
IsObjectPropertyContent
ItemID
MissingProperties
Type

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


CacheAgentEventArgs Properties

The properties of the CacheAgentEventArgs class are listed below. For a complete list of CacheAgentEventArgs class members, see the CacheAgentEventArgs Members topic.

Public Instance Properties

BytesReceived
DebugString
ExecutionTime
IsFileContent
IsObjectPropertyContent
ItemID
MissingProperties
Type

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


BytesReceived Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.BytesReceived Property

public virtual Int64 BytesReceived {get;}

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


DebugString Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.DebugString Property

public virtual String DebugString {get;}

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


ExecutionTime Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.ExecutionTime Property

public virtual Int32 ExecutionTime {get;}

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


IsFileContent Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.IsFileContent Property

public virtual Boolean IsFileContent {get;}

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


IsObjectPropertyContent Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.IsObjectPropertyContent Property

public virtual Boolean IsObjectPropertyContent {get;}

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


ItemID Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.ItemID Property

public virtual Int32 ItemID {get;}

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


MissingProperties Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.MissingProperties Property

public virtual PropertyCollection MissingProperties {get;}

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


Type Property

Borland StarTeam SDK for .NET

CacheAgentEventArgs.Type Property

public virtual Type Type {get;}

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


CacheAgentEventArgs Methods

The methods of the CacheAgentEventArgs class are listed below. For a complete list of CacheAgentEventArgs class members, see the CacheAgentEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


CacheAgentEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


CacheAgentEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


CacheAgentEventArgs.ToString Method

public override string ToString();

See Also

CacheAgentEventArgs Class | StarTeam.Events Namespace


CacheAgentEventSource Class

For a list of all members of this type, see CacheAgentEventSource Members.

System.Object
CacheAgentEventSource

public class CacheAgentEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CacheAgentEventSource Members | StarTeam.Events Namespace


CacheAgentEventSource Members

CacheAgentEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnItemMissed
OnItemReceived

See Also

CacheAgentEventSource Class | StarTeam.Events Namespace


CacheAgentEventSource Properties

The properties of the CacheAgentEventSource class are listed below. For a complete list of CacheAgentEventSource class members, see the CacheAgentEventSource Members topic.

Public Instance Properties

Parent

See Also

CacheAgentEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

CacheAgentEventSource.Parent Property

public Object Parent {get;}

See Also

CacheAgentEventSource Class | StarTeam.Events Namespace


CacheAgentEventSource Events

The events of the CacheAgentEventSource class are listed below. For a complete list of CacheAgentEventSource class members, see the CacheAgentEventSource Members topic.

Public Instance Events

OnItemMissed
OnItemReceived

See Also

CacheAgentEventSource Class | StarTeam.Events Namespace


CacheAgentEventSource.OnItemMissed Event

public event CacheAgentEventSource.Handler OnItemMissed;

See Also

CacheAgentEventSource Class | StarTeam.Events Namespace


CacheAgentEventSource.OnItemReceived Event

public event CacheAgentEventSource.Handler OnItemReceived;

See Also

CacheAgentEventSource Class | StarTeam.Events Namespace


CacheAgentEventSource.Handler Delegate

public delegate void CacheAgentEventSource.Handler(
CacheAgentEventSource source,
CacheAgentEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


CheckinEventArgs Class

For a list of all members of this type, see CheckinEventArgs Members.

System.Object
EventArgs
CheckinEventArgs

public class CheckinEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckinEventArgs Members | StarTeam.Events Namespace


CheckinEventArgs Members

CheckinEventArgs overview

Public Instance Properties

CheckinManager
CheckinResult
CurrentFile
CurrentWorkingFile
Error
ErrorMessage
IsCanceled
IsFinished
IsSuccessful
Options

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CheckinEventArgs Properties

The properties of the CheckinEventArgs class are listed below. For a complete list of CheckinEventArgs class members, see the CheckinEventArgs Members topic.

Public Instance Properties

CheckinManager
CheckinResult
CurrentFile
CurrentWorkingFile
Error
ErrorMessage
IsCanceled
IsFinished
IsSuccessful
Options

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CheckinManager Property

Borland StarTeam SDK for .NET

CheckinEventArgs.CheckinManager Property

public virtual CheckinManager CheckinManager {get;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CheckinResult Property

Borland StarTeam SDK for .NET

CheckinEventArgs.CheckinResult Property

public virtual File.CheckInResult CheckinResult {get;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CurrentFile Property

Borland StarTeam SDK for .NET

CheckinEventArgs.CurrentFile Property

public virtual File CurrentFile {get;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CurrentWorkingFile Property

Borland StarTeam SDK for .NET

CheckinEventArgs.CurrentWorkingFile Property

public virtual FileInfo CurrentWorkingFile {get; set;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


Error Property

Borland StarTeam SDK for .NET

CheckinEventArgs.Error Property

public virtual Exception Error {get;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


ErrorMessage Property

Borland StarTeam SDK for .NET

CheckinEventArgs.ErrorMessage Property

public virtual String ErrorMessage {get;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CheckinEventArgs.IsCanceled Property

public virtual Boolean IsCanceled {get;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


IsFinished Property

Borland StarTeam SDK for .NET

CheckinEventArgs.IsFinished Property

public virtual Boolean IsFinished {get;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


IsSuccessful Property

Borland StarTeam SDK for .NET

CheckinEventArgs.IsSuccessful Property

public virtual Boolean IsSuccessful {get;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


Options Property

Borland StarTeam SDK for .NET

CheckinEventArgs.Options Property

public virtual CheckinOptions Options {get;}

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CheckinEventArgs Methods

The methods of the CheckinEventArgs class are listed below. For a complete list of CheckinEventArgs class members, see the CheckinEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CheckinEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CheckinEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CheckinEventArgs.ToString Method

public override string ToString();

See Also

CheckinEventArgs Class | StarTeam.Events Namespace


CheckinEventSource Class

For a list of all members of this type, see CheckinEventSource Members.

System.Object
CheckinEventSource

public class CheckinEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckinEventSource Members | StarTeam.Events Namespace


CheckinEventSource Members

CheckinEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnNotifyProgress
OnStartFile

See Also

CheckinEventSource Class | StarTeam.Events Namespace


CheckinEventSource Properties

The properties of the CheckinEventSource class are listed below. For a complete list of CheckinEventSource class members, see the CheckinEventSource Members topic.

Public Instance Properties

Parent

See Also

CheckinEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

CheckinEventSource.Parent Property

public Object Parent {get;}

See Also

CheckinEventSource Class | StarTeam.Events Namespace


CheckinEventSource Events

The events of the CheckinEventSource class are listed below. For a complete list of CheckinEventSource class members, see the CheckinEventSource Members topic.

Public Instance Events

OnNotifyProgress
OnStartFile

See Also

CheckinEventSource Class | StarTeam.Events Namespace


CheckinEventSource.OnNotifyProgress Event

public event CheckinEventSource.Handler OnNotifyProgress;

See Also

CheckinEventSource Class | StarTeam.Events Namespace


CheckinEventSource.OnStartFile Event

public event CheckinEventSource.Handler OnStartFile;

See Also

CheckinEventSource Class | StarTeam.Events Namespace


CheckinEventSource.Handler Delegate

public delegate void CheckinEventSource.Handler(
CheckinEventSource source,
CheckinEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


CheckoutEventArgs Class

For a list of all members of this type, see CheckoutEventArgs Members.

System.Object
EventArgs
CheckoutEventArgs

public class CheckoutEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutEventArgs Members | StarTeam.Events Namespace


CheckoutEventArgs Members

CheckoutEventArgs overview

Public Instance Properties

CheckoutManager
CheckoutResult
CheckoutRevision
CheckoutThreadIndex
CurrentBytesExpected
CurrentBytesSoFar
CurrentWorkingFile
Error
ErrorMessage
IsCanceled
IsDeleted
IsFinished
IsMoved
IsMPXCacheAgentThread
IsSuccessful
Options
OriginalRevision
OriginalWorkingFile

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutEventArgs Properties

The properties of the CheckoutEventArgs class are listed below. For a complete list of CheckoutEventArgs class members, see the CheckoutEventArgs Members topic.

Public Instance Properties

CheckoutManager
CheckoutResult
CheckoutRevision
CheckoutThreadIndex
CurrentBytesExpected
CurrentBytesSoFar
CurrentWorkingFile
Error
ErrorMessage
IsCanceled
IsDeleted
IsFinished
IsMoved
IsMPXCacheAgentThread
IsSuccessful
Options
OriginalRevision
OriginalWorkingFile

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutManager Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CheckoutManager Property

public virtual CheckoutManager CheckoutManager {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutResult Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CheckoutResult Property

public virtual File.CheckOutResult CheckoutResult {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutRevision Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CheckoutRevision Property

public virtual File CheckoutRevision {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutThreadIndex Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CheckoutThreadIndex Property

public virtual Int32 CheckoutThreadIndex {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CurrentBytesExpected Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CurrentBytesExpected Property

public virtual Int64 CurrentBytesExpected {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CurrentBytesSoFar Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CurrentBytesSoFar Property

public virtual Int64 CurrentBytesSoFar {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CurrentWorkingFile Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.CurrentWorkingFile Property

public virtual FileInfo CurrentWorkingFile {get; set;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


Error Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.Error Property

public virtual Exception Error {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


ErrorMessage Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.ErrorMessage Property

public virtual String ErrorMessage {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsCanceled Property

public virtual Boolean IsCanceled {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


IsDeleted Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsDeleted Property

public virtual Boolean IsDeleted {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


IsFinished Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsFinished Property

public virtual Boolean IsFinished {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


IsMoved Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsMoved Property

public virtual Boolean IsMoved {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


IsMPXCacheAgentThread Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsMPXCacheAgentThread Property

public virtual Boolean IsMPXCacheAgentThread {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


IsSuccessful Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.IsSuccessful Property

public virtual Boolean IsSuccessful {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


Options Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.Options Property

public virtual CheckoutOptions Options {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


OriginalRevision Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.OriginalRevision Property

public virtual File OriginalRevision {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


OriginalWorkingFile Property

Borland StarTeam SDK for .NET

CheckoutEventArgs.OriginalWorkingFile Property

public virtual FileInfo OriginalWorkingFile {get;}

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutEventArgs Methods

The methods of the CheckoutEventArgs class are listed below. For a complete list of CheckoutEventArgs class members, see the CheckoutEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutEventArgs.ToString Method

public override string ToString();

See Also

CheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutEventSource Class

For a list of all members of this type, see CheckoutEventSource Members.

System.Object
CheckoutEventSource

public class CheckoutEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CheckoutEventSource Members | StarTeam.Events Namespace


CheckoutEventSource Members

CheckoutEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnNotifyProgress
OnStartFile

See Also

CheckoutEventSource Class | StarTeam.Events Namespace


CheckoutEventSource Properties

The properties of the CheckoutEventSource class are listed below. For a complete list of CheckoutEventSource class members, see the CheckoutEventSource Members topic.

Public Instance Properties

Parent

See Also

CheckoutEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

CheckoutEventSource.Parent Property

public Object Parent {get;}

See Also

CheckoutEventSource Class | StarTeam.Events Namespace


CheckoutEventSource Events

The events of the CheckoutEventSource class are listed below. For a complete list of CheckoutEventSource class members, see the CheckoutEventSource Members topic.

Public Instance Events

OnNotifyProgress
OnStartFile

See Also

CheckoutEventSource Class | StarTeam.Events Namespace


CheckoutEventSource.OnNotifyProgress Event

public event CheckoutEventSource.Handler OnNotifyProgress;

See Also

CheckoutEventSource Class | StarTeam.Events Namespace


CheckoutEventSource.OnStartFile Event

public event CheckoutEventSource.Handler OnStartFile;

See Also

CheckoutEventSource Class | StarTeam.Events Namespace


CheckoutEventSource.Handler Delegate

public delegate void CheckoutEventSource.Handler(
CheckoutEventSource source,
CheckoutEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


CommandProcessorCheckinEventArgs Class

For a list of all members of this type, see CommandProcessorCheckinEventArgs Members.

System.Object
EventArgs
CommandProcessorCheckinEventArgs

public class CommandProcessorCheckinEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CommandProcessorCheckinEventArgs Members | StarTeam.Events Namespace


CommandProcessorCheckinEventArgs Members

CommandProcessorCheckinEventArgs overview

Public Instance Properties

File
IsSkipped

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
Skip |
ToString |

See Also

CommandProcessorCheckinEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckinEventArgs Properties

The properties of the CommandProcessorCheckinEventArgs class are listed below. For a complete list of CommandProcessorCheckinEventArgs class members, see the CommandProcessorCheckinEventArgs Members topic.

Public Instance Properties

File
IsSkipped

See Also

CommandProcessorCheckinEventArgs Class | StarTeam.Events Namespace


File Property

Borland StarTeam SDK for .NET

CommandProcessorCheckinEventArgs.File Property

public virtual File File {get;}

See Also

CommandProcessorCheckinEventArgs Class | StarTeam.Events Namespace


IsSkipped Property

Borland StarTeam SDK for .NET

CommandProcessorCheckinEventArgs.IsSkipped Property

public virtual Boolean IsSkipped {get;}

See Also

CommandProcessorCheckinEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckinEventArgs Methods

The methods of the CommandProcessorCheckinEventArgs class are listed below. For a complete list of CommandProcessorCheckinEventArgs class members, see the CommandProcessorCheckinEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
Skip |
ToString |

See Also

CommandProcessorCheckinEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckinEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CommandProcessorCheckinEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckinEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CommandProcessorCheckinEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckinEventArgs.Skip Method

public virtual void Skip();

See Also

CommandProcessorCheckinEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckinEventArgs.ToString Method

public override string ToString();

See Also

CommandProcessorCheckinEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckoutEventArgs Class

For a list of all members of this type, see CommandProcessorCheckoutEventArgs Members.

System.Object
EventArgs
CommandProcessorCheckoutEventArgs

public class CommandProcessorCheckoutEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CommandProcessorCheckoutEventArgs Members | StarTeam.Events Namespace


CommandProcessorCheckoutEventArgs Members

CommandProcessorCheckoutEventArgs overview

Public Instance Properties

IsCanceled
IsSkipped
OriginalFile

Public Instance Methods

Cancel |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
Skip |
ToString |

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckoutEventArgs Properties

The properties of the CommandProcessorCheckoutEventArgs class are listed below. For a complete list of CommandProcessorCheckoutEventArgs class members, see the CommandProcessorCheckoutEventArgs Members topic.

Public Instance Properties

IsCanceled
IsSkipped
OriginalFile

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CommandProcessorCheckoutEventArgs.IsCanceled Property

public virtual Boolean IsCanceled {get;}

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


IsSkipped Property

Borland StarTeam SDK for .NET

CommandProcessorCheckoutEventArgs.IsSkipped Property

public virtual Boolean IsSkipped {get;}

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


OriginalFile Property

Borland StarTeam SDK for .NET

CommandProcessorCheckoutEventArgs.OriginalFile Property

public virtual FileInfo OriginalFile {get;}

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckoutEventArgs Methods

The methods of the CommandProcessorCheckoutEventArgs class are listed below. For a complete list of CommandProcessorCheckoutEventArgs class members, see the CommandProcessorCheckoutEventArgs Members topic.

Public Instance Methods

Cancel |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
Skip |
ToString |

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckoutEventArgs.Cancel Method

public virtual void Cancel();

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckoutEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckoutEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckoutEventArgs.Skip Method

public virtual void Skip();

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


CommandProcessorCheckoutEventArgs.ToString Method

public override string ToString();

See Also

CommandProcessorCheckoutEventArgs Class | StarTeam.Events Namespace


CommandProcessorEventSource Class

For a list of all members of this type, see CommandProcessorEventSource Members.

System.Object
CommandProcessorEventSource

public class CommandProcessorEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CommandProcessorEventSource Members | StarTeam.Events Namespace


CommandProcessorEventSource Members

CommandProcessorEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnNotifyCheckin
OnNotifyCheckout
OnNotifyPassword
OnNotifyStatus

See Also

CommandProcessorEventSource Class | StarTeam.Events Namespace


CommandProcessorEventSource Properties

The properties of the CommandProcessorEventSource class are listed below. For a complete list of CommandProcessorEventSource class members, see the CommandProcessorEventSource Members topic.

Public Instance Properties

Parent

See Also

CommandProcessorEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

CommandProcessorEventSource.Parent Property

public Object Parent {get;}

See Also

CommandProcessorEventSource Class | StarTeam.Events Namespace


CommandProcessorEventSource Events

The events of the CommandProcessorEventSource class are listed below. For a complete list of CommandProcessorEventSource class members, see the CommandProcessorEventSource Members topic.

Public Instance Events

OnNotifyCheckin
OnNotifyCheckout
OnNotifyPassword
OnNotifyStatus

See Also

CommandProcessorEventSource Class | StarTeam.Events Namespace


CommandProcessorEventSource.OnNotifyCheckin Event

public event CommandProcessorEventSource.CheckinHandler OnNotifyCheckin;

See Also

CommandProcessorEventSource Class | StarTeam.Events Namespace


CommandProcessorEventSource.OnNotifyCheckout Event

public event CommandProcessorEventSource.CheckoutHandler OnNotifyCheckout;

See Also

CommandProcessorEventSource Class | StarTeam.Events Namespace


CommandProcessorEventSource.OnNotifyPassword Event

public event CommandProcessorEventSource.PasswordHandler OnNotifyPassword;

See Also

CommandProcessorEventSource Class | StarTeam.Events Namespace


CommandProcessorEventSource.OnNotifyStatus Event

public event CommandProcessorEventSource.StatusHandler OnNotifyStatus;

See Also

CommandProcessorEventSource Class | StarTeam.Events Namespace


CommandProcessorEventSource.CheckinHandler Delegate

public delegate void CommandProcessorEventSource.CheckinHandler(
CommandProcessorEventSource source,
CommandProcessorCheckinEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


CommandProcessorEventSource.CheckoutHandler Delegate

public delegate void CommandProcessorEventSource.CheckoutHandler(
CommandProcessorEventSource source,
CommandProcessorCheckoutEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


CommandProcessorEventSource.PasswordHandler Delegate

public delegate void CommandProcessorEventSource.PasswordHandler(
CommandProcessorEventSource source,
CommandProcessorPasswordEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


CommandProcessorEventSource.StatusHandler Delegate

public delegate void CommandProcessorEventSource.StatusHandler(
CommandProcessorEventSource source,
CommandProcessorStatusEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


CommandProcessorPasswordEventArgs Class

For a list of all members of this type, see CommandProcessorPasswordEventArgs Members.

System.Object
EventArgs
CommandProcessorPasswordEventArgs

public class CommandProcessorPasswordEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CommandProcessorPasswordEventArgs Members | StarTeam.Events Namespace


CommandProcessorPasswordEventArgs Members

CommandProcessorPasswordEventArgs overview

Public Instance Properties

Password

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

CommandProcessorPasswordEventArgs Class | StarTeam.Events Namespace


CommandProcessorPasswordEventArgs Properties

The properties of the CommandProcessorPasswordEventArgs class are listed below. For a complete list of CommandProcessorPasswordEventArgs class members, see the CommandProcessorPasswordEventArgs Members topic.

Public Instance Properties

Password

See Also

CommandProcessorPasswordEventArgs Class | StarTeam.Events Namespace


Password Property

Borland StarTeam SDK for .NET

CommandProcessorPasswordEventArgs.Password Property

public virtual String Password {get; set;}

See Also

CommandProcessorPasswordEventArgs Class | StarTeam.Events Namespace


CommandProcessorPasswordEventArgs Methods

The methods of the CommandProcessorPasswordEventArgs class are listed below. For a complete list of CommandProcessorPasswordEventArgs class members, see the CommandProcessorPasswordEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

CommandProcessorPasswordEventArgs Class | StarTeam.Events Namespace


CommandProcessorPasswordEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CommandProcessorPasswordEventArgs Class | StarTeam.Events Namespace


CommandProcessorPasswordEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CommandProcessorPasswordEventArgs Class | StarTeam.Events Namespace


CommandProcessorPasswordEventArgs.ToString Method

public override string ToString();

See Also

CommandProcessorPasswordEventArgs Class | StarTeam.Events Namespace


CommandProcessorStatusEventArgs Class

For a list of all members of this type, see CommandProcessorStatusEventArgs Members.

System.Object
EventArgs
CommandProcessorStatusEventArgs

public class CommandProcessorStatusEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

CommandProcessorStatusEventArgs Members | StarTeam.Events Namespace


CommandProcessorStatusEventArgs Members

CommandProcessorStatusEventArgs overview

Public Instance Properties

IsCanceled
IsForced
IsSkipped
Status
WorkingFileOnDisk

Public Instance Methods

Cancel |
Equals |
Force |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
Skip |
ToString |

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


CommandProcessorStatusEventArgs Properties

The properties of the CommandProcessorStatusEventArgs class are listed below. For a complete list of CommandProcessorStatusEventArgs class members, see the CommandProcessorStatusEventArgs Members topic.

Public Instance Properties

IsCanceled
IsForced
IsSkipped
Status
WorkingFileOnDisk

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

CommandProcessorStatusEventArgs.IsCanceled Property

public virtual Boolean IsCanceled {get;}

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


IsForced Property

Borland StarTeam SDK for .NET

CommandProcessorStatusEventArgs.IsForced Property

public virtual Boolean IsForced {get;}

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


IsSkipped Property

Borland StarTeam SDK for .NET

CommandProcessorStatusEventArgs.IsSkipped Property

public virtual Boolean IsSkipped {get;}

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


Status Property

Borland StarTeam SDK for .NET

CommandProcessorStatusEventArgs.Status Property

public virtual File.Status Status {get;}

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


WorkingFileOnDisk Property

Borland StarTeam SDK for .NET

CommandProcessorStatusEventArgs.WorkingFileOnDisk Property

public virtual FileInfo WorkingFileOnDisk {get;}

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


CommandProcessorStatusEventArgs Methods

The methods of the CommandProcessorStatusEventArgs class are listed below. For a complete list of CommandProcessorStatusEventArgs class members, see the CommandProcessorStatusEventArgs Members topic.

Public Instance Methods

Cancel |
Equals |
Force |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
Skip |
ToString |

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


CommandProcessorStatusEventArgs.Cancel Method

public virtual void Cancel();

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


CommandProcessorStatusEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


CommandProcessorStatusEventArgs.Force Method

public virtual void Force();

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


CommandProcessorStatusEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


CommandProcessorStatusEventArgs.Skip Method

public virtual void Skip();

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


CommandProcessorStatusEventArgs.ToString Method

public override string ToString();

See Also

CommandProcessorStatusEventArgs Class | StarTeam.Events Namespace


FilterEventArgs Class

For a list of all members of this type, see FilterEventArgs Members.

System.Object
EventArgs
FilterEventArgs

public class FilterEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

FilterEventArgs Members | StarTeam.Events Namespace


FilterEventArgs Members

FilterEventArgs overview

Public Instance Properties

Filter

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FilterEventArgs Class | StarTeam.Events Namespace


FilterEventArgs Properties

The properties of the FilterEventArgs class are listed below. For a complete list of FilterEventArgs class members, see the FilterEventArgs Members topic.

Public Instance Properties

Filter

See Also

FilterEventArgs Class | StarTeam.Events Namespace


Filter Property

Borland StarTeam SDK for .NET

FilterEventArgs.Filter Property

public virtual Filter Filter {get;}

See Also

FilterEventArgs Class | StarTeam.Events Namespace


FilterEventArgs Methods

The methods of the FilterEventArgs class are listed below. For a complete list of FilterEventArgs class members, see the FilterEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FilterEventArgs Class | StarTeam.Events Namespace


FilterEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

FilterEventArgs Class | StarTeam.Events Namespace


FilterEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

FilterEventArgs Class | StarTeam.Events Namespace


FilterEventArgs.ToString Method

public override string ToString();

See Also

FilterEventArgs Class | StarTeam.Events Namespace


FilterEventSource Class

For a list of all members of this type, see FilterEventSource Members.

System.Object
FilterEventSource

public class FilterEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

FilterEventSource Members | StarTeam.Events Namespace


FilterEventSource Members

FilterEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnFilterAdded
OnFilterChanged
OnFilterDeleted

See Also

FilterEventSource Class | StarTeam.Events Namespace


FilterEventSource Properties

The properties of the FilterEventSource class are listed below. For a complete list of FilterEventSource class members, see the FilterEventSource Members topic.

Public Instance Properties

Parent

See Also

FilterEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

FilterEventSource.Parent Property

public Object Parent {get;}

See Also

FilterEventSource Class | StarTeam.Events Namespace


FilterEventSource Events

The events of the FilterEventSource class are listed below. For a complete list of FilterEventSource class members, see the FilterEventSource Members topic.

Public Instance Events

OnFilterAdded
OnFilterChanged
OnFilterDeleted

See Also

FilterEventSource Class | StarTeam.Events Namespace


FilterEventSource.OnFilterAdded Event

public event FilterEventSource.Handler OnFilterAdded;

See Also

FilterEventSource Class | StarTeam.Events Namespace


FilterEventSource.OnFilterChanged Event

public event FilterEventSource.Handler OnFilterChanged;

See Also

FilterEventSource Class | StarTeam.Events Namespace


FilterEventSource.OnFilterDeleted Event

public event FilterEventSource.Handler OnFilterDeleted;

See Also

FilterEventSource Class | StarTeam.Events Namespace


FilterEventSource.Handler Delegate

public delegate void FilterEventSource.Handler(
FilterEventSource source,
FilterEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


FolderEventArgs Class

For a list of all members of this type, see FolderEventArgs Members.

System.Object
EventArgs
FolderEventArgs

public class FolderEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

FolderEventArgs Members | StarTeam.Events Namespace


FolderEventArgs Members

FolderEventArgs overview

Public Instance Properties

NewFolder
OldFolder

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FolderEventArgs Class | StarTeam.Events Namespace


FolderEventArgs Properties

The properties of the FolderEventArgs class are listed below. For a complete list of FolderEventArgs class members, see the FolderEventArgs Members topic.

Public Instance Properties

NewFolder
OldFolder

See Also

FolderEventArgs Class | StarTeam.Events Namespace


NewFolder Property

Borland StarTeam SDK for .NET

FolderEventArgs.NewFolder Property

public virtual Folder NewFolder {get;}

See Also

FolderEventArgs Class | StarTeam.Events Namespace


OldFolder Property

Borland StarTeam SDK for .NET

FolderEventArgs.OldFolder Property

public virtual Folder OldFolder {get;}

See Also

FolderEventArgs Class | StarTeam.Events Namespace


FolderEventArgs Methods

The methods of the FolderEventArgs class are listed below. For a complete list of FolderEventArgs class members, see the FolderEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FolderEventArgs Class | StarTeam.Events Namespace


FolderEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

FolderEventArgs Class | StarTeam.Events Namespace


FolderEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

FolderEventArgs Class | StarTeam.Events Namespace


FolderEventArgs.ToString Method

public override string ToString();

See Also

FolderEventArgs Class | StarTeam.Events Namespace


FolderEventSource Class

For a list of all members of this type, see FolderEventSource Members.

System.Object
FolderEventSource

public class FolderEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

FolderEventSource Members | StarTeam.Events Namespace


FolderEventSource Members

FolderEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnFolderAdded
OnFolderChanged
OnFolderMoved
OnFolderRemoved

See Also

FolderEventSource Class | StarTeam.Events Namespace


FolderEventSource Properties

The properties of the FolderEventSource class are listed below. For a complete list of FolderEventSource class members, see the FolderEventSource Members topic.

Public Instance Properties

Parent

See Also

FolderEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

FolderEventSource.Parent Property

public Object Parent {get;}

See Also

FolderEventSource Class | StarTeam.Events Namespace


FolderEventSource Events

The events of the FolderEventSource class are listed below. For a complete list of FolderEventSource class members, see the FolderEventSource Members topic.

Public Instance Events

OnFolderAdded
OnFolderChanged
OnFolderMoved
OnFolderRemoved

See Also

FolderEventSource Class | StarTeam.Events Namespace


FolderEventSource.OnFolderAdded Event

public event FolderEventSource.Handler OnFolderAdded;

See Also

FolderEventSource Class | StarTeam.Events Namespace


FolderEventSource.OnFolderChanged Event

public event FolderEventSource.Handler OnFolderChanged;

See Also

FolderEventSource Class | StarTeam.Events Namespace


FolderEventSource.OnFolderMoved Event

public event FolderEventSource.Handler OnFolderMoved;

See Also

FolderEventSource Class | StarTeam.Events Namespace


FolderEventSource.OnFolderRemoved Event

public event FolderEventSource.Handler OnFolderRemoved;

See Also

FolderEventSource Class | StarTeam.Events Namespace


FolderEventSource.Handler Delegate

public delegate void FolderEventSource.Handler(
FolderEventSource source,
FolderEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


FolderTreeEventArgs Class

For a list of all members of this type, see FolderTreeEventArgs Members.

System.Object
EventArgs
FolderTreeEventArgs

public class FolderTreeEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

FolderTreeEventArgs Members | StarTeam.Events Namespace


FolderTreeEventArgs Members

FolderTreeEventArgs overview

Public Instance Properties

Folder

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FolderTreeEventArgs Class | StarTeam.Events Namespace


FolderTreeEventArgs Properties

The properties of the FolderTreeEventArgs class are listed below. For a complete list of FolderTreeEventArgs class members, see the FolderTreeEventArgs Members topic.

Public Instance Properties

Folder

See Also

FolderTreeEventArgs Class | StarTeam.Events Namespace


Folder Property

Borland StarTeam SDK for .NET

FolderTreeEventArgs.Folder Property

public virtual Folder Folder {get;}

See Also

FolderTreeEventArgs Class | StarTeam.Events Namespace


FolderTreeEventArgs Methods

The methods of the FolderTreeEventArgs class are listed below. For a complete list of FolderTreeEventArgs class members, see the FolderTreeEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FolderTreeEventArgs Class | StarTeam.Events Namespace


FolderTreeEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

FolderTreeEventArgs Class | StarTeam.Events Namespace


FolderTreeEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

FolderTreeEventArgs Class | StarTeam.Events Namespace


FolderTreeEventArgs.ToString Method

public override string ToString();

See Also

FolderTreeEventArgs Class | StarTeam.Events Namespace


FolderTreeEventSource Class

For a list of all members of this type, see FolderTreeEventSource Members.

System.Object
FolderTreeEventSource

public class FolderTreeEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

FolderTreeEventSource Members | StarTeam.Events Namespace


FolderTreeEventSource Members

FolderTreeEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnFolderTreeChanged

See Also

FolderTreeEventSource Class | StarTeam.Events Namespace


FolderTreeEventSource Properties

The properties of the FolderTreeEventSource class are listed below. For a complete list of FolderTreeEventSource class members, see the FolderTreeEventSource Members topic.

Public Instance Properties

Parent

See Also

FolderTreeEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

FolderTreeEventSource.Parent Property

public Object Parent {get;}

See Also

FolderTreeEventSource Class | StarTeam.Events Namespace


FolderTreeEventSource Events

The events of the FolderTreeEventSource class are listed below. For a complete list of FolderTreeEventSource class members, see the FolderTreeEventSource Members topic.

Public Instance Events

OnFolderTreeChanged

See Also

FolderTreeEventSource Class | StarTeam.Events Namespace


FolderTreeEventSource.OnFolderTreeChanged Event

public event FolderTreeEventSource.Handler OnFolderTreeChanged;

See Also

FolderTreeEventSource Class | StarTeam.Events Namespace


FolderTreeEventSource.Handler Delegate

public delegate void FolderTreeEventSource.Handler(
FolderTreeEventSource source,
FolderTreeEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


FolderUpdateEventArgs Class

For a list of all members of this type, see FolderUpdateEventArgs Members.

System.Object
EventArgs
FolderUpdateEventArgs

public class FolderUpdateEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

FolderUpdateEventArgs Members | StarTeam.Events Namespace


FolderUpdateEventArgs Members

FolderUpdateEventArgs overview

Public Instance Constructors

FolderUpdateEventArgs Constructor

Public Instance Properties

NewFolder
OldFolder

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FolderUpdateEventArgs Class | StarTeam.Events Namespace


FolderUpdateEventArgs Constructor

public FolderUpdateEventArgs(
Folder oldFolder,
Folder newFolder
);

See Also

FolderUpdateEventArgs Class | StarTeam.Events Namespace


FolderUpdateEventArgs Properties

The properties of the FolderUpdateEventArgs class are listed below. For a complete list of FolderUpdateEventArgs class members, see the FolderUpdateEventArgs Members topic.

Public Instance Properties

NewFolder
OldFolder

See Also

FolderUpdateEventArgs Class | StarTeam.Events Namespace


NewFolder Property

Borland StarTeam SDK for .NET

FolderUpdateEventArgs.NewFolder Property

public virtual Folder NewFolder {get;}

See Also

FolderUpdateEventArgs Class | StarTeam.Events Namespace


OldFolder Property

Borland StarTeam SDK for .NET

FolderUpdateEventArgs.OldFolder Property

public virtual Folder OldFolder {get;}

See Also

FolderUpdateEventArgs Class | StarTeam.Events Namespace


FolderUpdateEventArgs Methods

The methods of the FolderUpdateEventArgs class are listed below. For a complete list of FolderUpdateEventArgs class members, see the FolderUpdateEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

FolderUpdateEventArgs Class | StarTeam.Events Namespace


FolderUpdateEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

FolderUpdateEventArgs Class | StarTeam.Events Namespace


FolderUpdateEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

FolderUpdateEventArgs Class | StarTeam.Events Namespace


FolderUpdateEventArgs.ToString Method

public override string ToString();

See Also

FolderUpdateEventArgs Class | StarTeam.Events Namespace


FolderUpdateEventSource Class

For a list of all members of this type, see FolderUpdateEventSource Members.

System.Object
FolderUpdateEventSource

public class FolderUpdateEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

FolderUpdateEventSource Members | StarTeam.Events Namespace


FolderUpdateEventSource Members

FolderUpdateEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnFolderAdded
OnFolderChanged
OnFolderMoved
OnFolderRemoved

See Also

FolderUpdateEventSource Class | StarTeam.Events Namespace


FolderUpdateEventSource Properties

The properties of the FolderUpdateEventSource class are listed below. For a complete list of FolderUpdateEventSource class members, see the FolderUpdateEventSource Members topic.

Public Instance Properties

Parent

See Also

FolderUpdateEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

FolderUpdateEventSource.Parent Property

public Object Parent {get;}

See Also

FolderUpdateEventSource Class | StarTeam.Events Namespace


FolderUpdateEventSource Events

The events of the FolderUpdateEventSource class are listed below. For a complete list of FolderUpdateEventSource class members, see the FolderUpdateEventSource Members topic.

Public Instance Events

OnFolderAdded
OnFolderChanged
OnFolderMoved
OnFolderRemoved

See Also

FolderUpdateEventSource Class | StarTeam.Events Namespace


FolderUpdateEventSource.OnFolderAdded Event

public event FolderUpdateEventSource.Handler OnFolderAdded;

See Also

FolderUpdateEventSource Class | StarTeam.Events Namespace


FolderUpdateEventSource.OnFolderChanged Event

public event FolderUpdateEventSource.Handler OnFolderChanged;

See Also

FolderUpdateEventSource Class | StarTeam.Events Namespace


FolderUpdateEventSource.OnFolderMoved Event

public event FolderUpdateEventSource.Handler OnFolderMoved;

See Also

FolderUpdateEventSource Class | StarTeam.Events Namespace


FolderUpdateEventSource.OnFolderRemoved Event

public event FolderUpdateEventSource.Handler OnFolderRemoved;

See Also

FolderUpdateEventSource Class | StarTeam.Events Namespace


FolderUpdateEventSource.Handler Delegate

public delegate void FolderUpdateEventSource.Handler(
FolderUpdateEventSource source,
FolderUpdateEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


GroupEventArgs Class

For a list of all members of this type, see GroupEventArgs Members.

System.Object
EventArgs
GroupEventArgs

public class GroupEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

GroupEventArgs Members | StarTeam.Events Namespace


GroupEventArgs Members

GroupEventArgs overview

Public Instance Properties

Group

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

GroupEventArgs Class | StarTeam.Events Namespace


GroupEventArgs Properties

The properties of the GroupEventArgs class are listed below. For a complete list of GroupEventArgs class members, see the GroupEventArgs Members topic.

Public Instance Properties

Group

See Also

GroupEventArgs Class | StarTeam.Events Namespace


Group Property

Borland StarTeam SDK for .NET

GroupEventArgs.Group Property

public virtual Group Group {get;}

See Also

GroupEventArgs Class | StarTeam.Events Namespace


GroupEventArgs Methods

The methods of the GroupEventArgs class are listed below. For a complete list of GroupEventArgs class members, see the GroupEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

GroupEventArgs Class | StarTeam.Events Namespace


GroupEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

GroupEventArgs Class | StarTeam.Events Namespace


GroupEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

GroupEventArgs Class | StarTeam.Events Namespace


GroupEventArgs.ToString Method

public override string ToString();

See Also

GroupEventArgs Class | StarTeam.Events Namespace


GroupEventSource Class

For a list of all members of this type, see GroupEventSource Members.

System.Object
GroupEventSource

public class GroupEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

GroupEventSource Members | StarTeam.Events Namespace


GroupEventSource Members

GroupEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnGroupAdded
OnGroupChanged
OnGroupDeleted

See Also

GroupEventSource Class | StarTeam.Events Namespace


GroupEventSource Properties

The properties of the GroupEventSource class are listed below. For a complete list of GroupEventSource class members, see the GroupEventSource Members topic.

Public Instance Properties

Parent

See Also

GroupEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

GroupEventSource.Parent Property

public Object Parent {get;}

See Also

GroupEventSource Class | StarTeam.Events Namespace


GroupEventSource Events

The events of the GroupEventSource class are listed below. For a complete list of GroupEventSource class members, see the GroupEventSource Members topic.

Public Instance Events

OnGroupAdded
OnGroupChanged
OnGroupDeleted

See Also

GroupEventSource Class | StarTeam.Events Namespace


GroupEventSource.OnGroupAdded Event

public event GroupEventSource.Handler OnGroupAdded;

See Also

GroupEventSource Class | StarTeam.Events Namespace


GroupEventSource.OnGroupChanged Event

public event GroupEventSource.Handler OnGroupChanged;

See Also

GroupEventSource Class | StarTeam.Events Namespace


GroupEventSource.OnGroupDeleted Event

public event GroupEventSource.Handler OnGroupDeleted;

See Also

GroupEventSource Class | StarTeam.Events Namespace


GroupEventSource.Handler Delegate

public delegate void GroupEventSource.Handler(
GroupEventSource source,
GroupEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ItemEventArgs Class

For a list of all members of this type, see ItemEventArgs Members.

System.Object
EventArgs
ItemEventArgs

public class ItemEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemEventArgs Members | StarTeam.Events Namespace


ItemEventArgs Members

ItemEventArgs overview

Public Instance Properties

NewItem
OldItem

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ItemEventArgs Class | StarTeam.Events Namespace


ItemEventArgs Properties

The properties of the ItemEventArgs class are listed below. For a complete list of ItemEventArgs class members, see the ItemEventArgs Members topic.

Public Instance Properties

NewItem
OldItem

See Also

ItemEventArgs Class | StarTeam.Events Namespace


NewItem Property

Borland StarTeam SDK for .NET

ItemEventArgs.NewItem Property

public virtual Item NewItem {get;}

See Also

ItemEventArgs Class | StarTeam.Events Namespace


OldItem Property

Borland StarTeam SDK for .NET

ItemEventArgs.OldItem Property

public virtual Item OldItem {get;}

See Also

ItemEventArgs Class | StarTeam.Events Namespace


ItemEventArgs Methods

The methods of the ItemEventArgs class are listed below. For a complete list of ItemEventArgs class members, see the ItemEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ItemEventArgs Class | StarTeam.Events Namespace


ItemEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ItemEventArgs Class | StarTeam.Events Namespace


ItemEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ItemEventArgs Class | StarTeam.Events Namespace


ItemEventArgs.ToString Method

public override string ToString();

See Also

ItemEventArgs Class | StarTeam.Events Namespace


ItemEventSource Class

For a list of all members of this type, see ItemEventSource Members.

System.Object
ItemEventSource

public class ItemEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemEventSource Members | StarTeam.Events Namespace


ItemEventSource Members

ItemEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnItemAdded
OnItemChanged
OnItemMoved
OnItemRemoved

See Also

ItemEventSource Class | StarTeam.Events Namespace


ItemEventSource Properties

The properties of the ItemEventSource class are listed below. For a complete list of ItemEventSource class members, see the ItemEventSource Members topic.

Public Instance Properties

Parent

See Also

ItemEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ItemEventSource.Parent Property

public Object Parent {get;}

See Also

ItemEventSource Class | StarTeam.Events Namespace


ItemEventSource Events

The events of the ItemEventSource class are listed below. For a complete list of ItemEventSource class members, see the ItemEventSource Members topic.

Public Instance Events

OnItemAdded
OnItemChanged
OnItemMoved
OnItemRemoved

See Also

ItemEventSource Class | StarTeam.Events Namespace


ItemEventSource.OnItemAdded Event

public event ItemEventSource.Handler OnItemAdded;

See Also

ItemEventSource Class | StarTeam.Events Namespace


ItemEventSource.OnItemChanged Event

public event ItemEventSource.Handler OnItemChanged;

See Also

ItemEventSource Class | StarTeam.Events Namespace


ItemEventSource.OnItemMoved Event

public event ItemEventSource.Handler OnItemMoved;

See Also

ItemEventSource Class | StarTeam.Events Namespace


ItemEventSource.OnItemRemoved Event

public event ItemEventSource.Handler OnItemRemoved;

See Also

ItemEventSource Class | StarTeam.Events Namespace


ItemEventSource.Handler Delegate

public delegate void ItemEventSource.Handler(
ItemEventSource source,
ItemEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ItemIDEventArgs Class

For a list of all members of this type, see ItemIDEventArgs Members.

System.Object
EventArgs
ItemIDEventArgs

public class ItemIDEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemIDEventArgs Members | StarTeam.Events Namespace


ItemIDEventArgs Members

ItemIDEventArgs overview

Public Instance Properties

ItemID

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ItemIDEventArgs Class | StarTeam.Events Namespace


ItemIDEventArgs Properties

The properties of the ItemIDEventArgs class are listed below. For a complete list of ItemIDEventArgs class members, see the ItemIDEventArgs Members topic.

Public Instance Properties

ItemID

See Also

ItemIDEventArgs Class | StarTeam.Events Namespace


ItemID Property

Borland StarTeam SDK for .NET

ItemIDEventArgs.ItemID Property

public virtual Int32 ItemID {get;}

See Also

ItemIDEventArgs Class | StarTeam.Events Namespace


ItemIDEventArgs Methods

The methods of the ItemIDEventArgs class are listed below. For a complete list of ItemIDEventArgs class members, see the ItemIDEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ItemIDEventArgs Class | StarTeam.Events Namespace


ItemIDEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ItemIDEventArgs Class | StarTeam.Events Namespace


ItemIDEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ItemIDEventArgs Class | StarTeam.Events Namespace


ItemIDEventArgs.ToString Method

public override string ToString();

See Also

ItemIDEventArgs Class | StarTeam.Events Namespace


ItemIDEventSource Class

For a list of all members of this type, see ItemIDEventSource Members.

System.Object
ItemIDEventSource

public class ItemIDEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemIDEventSource Members | StarTeam.Events Namespace


ItemIDEventSource Members

ItemIDEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnItemAdded
OnItemChanged
OnItemRemoved

See Also

ItemIDEventSource Class | StarTeam.Events Namespace


ItemIDEventSource Properties

The properties of the ItemIDEventSource class are listed below. For a complete list of ItemIDEventSource class members, see the ItemIDEventSource Members topic.

Public Instance Properties

Parent

See Also

ItemIDEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ItemIDEventSource.Parent Property

public Object Parent {get;}

See Also

ItemIDEventSource Class | StarTeam.Events Namespace


ItemIDEventSource Events

The events of the ItemIDEventSource class are listed below. For a complete list of ItemIDEventSource class members, see the ItemIDEventSource Members topic.

Public Instance Events

OnItemAdded
OnItemChanged
OnItemRemoved

See Also

ItemIDEventSource Class | StarTeam.Events Namespace


ItemIDEventSource.OnItemAdded Event

public event ItemIDEventSource.Handler OnItemAdded;

See Also

ItemIDEventSource Class | StarTeam.Events Namespace


ItemIDEventSource.OnItemChanged Event

public event ItemIDEventSource.Handler OnItemChanged;

See Also

ItemIDEventSource Class | StarTeam.Events Namespace


ItemIDEventSource.OnItemRemoved Event

public event ItemIDEventSource.Handler OnItemRemoved;

See Also

ItemIDEventSource Class | StarTeam.Events Namespace


ItemIDEventSource.Handler Delegate

public delegate void ItemIDEventSource.Handler(
ItemIDEventSource source,
ItemIDEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ItemListEventArgs Class

For a list of all members of this type, see ItemListEventArgs Members.

System.Object
EventArgs
ItemListEventArgs

public class ItemListEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemListEventArgs Members | StarTeam.Events Namespace


ItemListEventArgs Members

ItemListEventArgs overview

Public Instance Properties

Folder
Type

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ItemListEventArgs Class | StarTeam.Events Namespace


ItemListEventArgs Properties

The properties of the ItemListEventArgs class are listed below. For a complete list of ItemListEventArgs class members, see the ItemListEventArgs Members topic.

Public Instance Properties

Folder
Type

See Also

ItemListEventArgs Class | StarTeam.Events Namespace


Folder Property

Borland StarTeam SDK for .NET

ItemListEventArgs.Folder Property

public virtual Folder Folder {get;}

See Also

ItemListEventArgs Class | StarTeam.Events Namespace


Type Property

Borland StarTeam SDK for .NET

ItemListEventArgs.Type Property

public virtual Item.Type Type {get;}

See Also

ItemListEventArgs Class | StarTeam.Events Namespace


ItemListEventArgs Methods

The methods of the ItemListEventArgs class are listed below. For a complete list of ItemListEventArgs class members, see the ItemListEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ItemListEventArgs Class | StarTeam.Events Namespace


ItemListEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ItemListEventArgs Class | StarTeam.Events Namespace


ItemListEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ItemListEventArgs Class | StarTeam.Events Namespace


ItemListEventArgs.ToString Method

public override string ToString();

See Also

ItemListEventArgs Class | StarTeam.Events Namespace


ItemListEventSource Class

For a list of all members of this type, see ItemListEventSource Members.

System.Object
ItemListEventSource

public class ItemListEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemListEventSource Members | StarTeam.Events Namespace


ItemListEventSource Members

ItemListEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnItemsChanged

See Also

ItemListEventSource Class | StarTeam.Events Namespace


ItemListEventSource Properties

The properties of the ItemListEventSource class are listed below. For a complete list of ItemListEventSource class members, see the ItemListEventSource Members topic.

Public Instance Properties

Parent

See Also

ItemListEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ItemListEventSource.Parent Property

public Object Parent {get;}

See Also

ItemListEventSource Class | StarTeam.Events Namespace


ItemListEventSource Events

The events of the ItemListEventSource class are listed below. For a complete list of ItemListEventSource class members, see the ItemListEventSource Members topic.

Public Instance Events

OnItemsChanged

See Also

ItemListEventSource Class | StarTeam.Events Namespace


ItemListEventSource.OnItemsChanged Event

public event ItemListEventSource.Handler OnItemsChanged;

See Also

ItemListEventSource Class | StarTeam.Events Namespace


ItemListEventSource.Handler Delegate

public delegate void ItemListEventSource.Handler(
ItemListEventSource source,
ItemListEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ItemUpdateEventArgs Class

For a list of all members of this type, see ItemUpdateEventArgs Members.

System.Object
EventArgs
ItemUpdateEventArgs

public class ItemUpdateEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemUpdateEventArgs Members | StarTeam.Events Namespace


ItemUpdateEventArgs Members

ItemUpdateEventArgs overview

Public Instance Constructors

ItemUpdateEventArgs Constructor

Public Instance Properties

NewItem
OldItem

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ItemUpdateEventArgs Class | StarTeam.Events Namespace


ItemUpdateEventArgs Constructor

public ItemUpdateEventArgs(
Item oldItem,
Item newItem
);

See Also

ItemUpdateEventArgs Class | StarTeam.Events Namespace


ItemUpdateEventArgs Properties

The properties of the ItemUpdateEventArgs class are listed below. For a complete list of ItemUpdateEventArgs class members, see the ItemUpdateEventArgs Members topic.

Public Instance Properties

NewItem
OldItem

See Also

ItemUpdateEventArgs Class | StarTeam.Events Namespace


NewItem Property

Borland StarTeam SDK for .NET

ItemUpdateEventArgs.NewItem Property

public virtual Item NewItem {get;}

See Also

ItemUpdateEventArgs Class | StarTeam.Events Namespace


OldItem Property

Borland StarTeam SDK for .NET

ItemUpdateEventArgs.OldItem Property

public virtual Item OldItem {get;}

See Also

ItemUpdateEventArgs Class | StarTeam.Events Namespace


ItemUpdateEventArgs Methods

The methods of the ItemUpdateEventArgs class are listed below. For a complete list of ItemUpdateEventArgs class members, see the ItemUpdateEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ItemUpdateEventArgs Class | StarTeam.Events Namespace


ItemUpdateEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ItemUpdateEventArgs Class | StarTeam.Events Namespace


ItemUpdateEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ItemUpdateEventArgs Class | StarTeam.Events Namespace


ItemUpdateEventArgs.ToString Method

public override string ToString();

See Also

ItemUpdateEventArgs Class | StarTeam.Events Namespace


ItemUpdateEventSource Class

For a list of all members of this type, see ItemUpdateEventSource Members.

System.Object
ItemUpdateEventSource

public class ItemUpdateEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemUpdateEventSource Members | StarTeam.Events Namespace


ItemUpdateEventSource Members

ItemUpdateEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnItemAdded
OnItemChanged
OnItemMoved
OnItemRemoved

See Also

ItemUpdateEventSource Class | StarTeam.Events Namespace


ItemUpdateEventSource Properties

The properties of the ItemUpdateEventSource class are listed below. For a complete list of ItemUpdateEventSource class members, see the ItemUpdateEventSource Members topic.

Public Instance Properties

Parent

See Also

ItemUpdateEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ItemUpdateEventSource.Parent Property

public Object Parent {get;}

See Also

ItemUpdateEventSource Class | StarTeam.Events Namespace


ItemUpdateEventSource Events

The events of the ItemUpdateEventSource class are listed below. For a complete list of ItemUpdateEventSource class members, see the ItemUpdateEventSource Members topic.

Public Instance Events

OnItemAdded
OnItemChanged
OnItemMoved
OnItemRemoved

See Also

ItemUpdateEventSource Class | StarTeam.Events Namespace


ItemUpdateEventSource.OnItemAdded Event

public event ItemUpdateEventSource.Handler OnItemAdded;

See Also

ItemUpdateEventSource Class | StarTeam.Events Namespace


ItemUpdateEventSource.OnItemChanged Event

public event ItemUpdateEventSource.Handler OnItemChanged;

See Also

ItemUpdateEventSource Class | StarTeam.Events Namespace


ItemUpdateEventSource.OnItemMoved Event

public event ItemUpdateEventSource.Handler OnItemMoved;

See Also

ItemUpdateEventSource Class | StarTeam.Events Namespace


ItemUpdateEventSource.OnItemRemoved Event

public event ItemUpdateEventSource.Handler OnItemRemoved;

See Also

ItemUpdateEventSource Class | StarTeam.Events Namespace


ItemUpdateEventSource.Handler Delegate

public delegate void ItemUpdateEventSource.Handler(
ItemUpdateEventSource source,
ItemUpdateEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


LabelEventArgs Class

For a list of all members of this type, see LabelEventArgs Members.

System.Object
EventArgs
LabelEventArgs

public class LabelEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

LabelEventArgs Members | StarTeam.Events Namespace


LabelEventArgs Members

LabelEventArgs overview

Public Instance Properties

Label

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

LabelEventArgs Class | StarTeam.Events Namespace


LabelEventArgs Properties

The properties of the LabelEventArgs class are listed below. For a complete list of LabelEventArgs class members, see the LabelEventArgs Members topic.

Public Instance Properties

Label

See Also

LabelEventArgs Class | StarTeam.Events Namespace


Label Property

Borland StarTeam SDK for .NET

LabelEventArgs.Label Property

public virtual Label Label {get;}

See Also

LabelEventArgs Class | StarTeam.Events Namespace


LabelEventArgs Methods

The methods of the LabelEventArgs class are listed below. For a complete list of LabelEventArgs class members, see the LabelEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

LabelEventArgs Class | StarTeam.Events Namespace


LabelEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

LabelEventArgs Class | StarTeam.Events Namespace


LabelEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

LabelEventArgs Class | StarTeam.Events Namespace


LabelEventArgs.ToString Method

public override string ToString();

See Also

LabelEventArgs Class | StarTeam.Events Namespace


LabelEventSource Class

For a list of all members of this type, see LabelEventSource Members.

System.Object
LabelEventSource

public class LabelEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

LabelEventSource Members | StarTeam.Events Namespace


LabelEventSource Members

LabelEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnLabelAdded
OnLabelChanged
OnLabelDeleted

See Also

LabelEventSource Class | StarTeam.Events Namespace


LabelEventSource Properties

The properties of the LabelEventSource class are listed below. For a complete list of LabelEventSource class members, see the LabelEventSource Members topic.

Public Instance Properties

Parent

See Also

LabelEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

LabelEventSource.Parent Property

public Object Parent {get;}

See Also

LabelEventSource Class | StarTeam.Events Namespace


LabelEventSource Events

The events of the LabelEventSource class are listed below. For a complete list of LabelEventSource class members, see the LabelEventSource Members topic.

Public Instance Events

OnLabelAdded
OnLabelChanged
OnLabelDeleted

See Also

LabelEventSource Class | StarTeam.Events Namespace


LabelEventSource.OnLabelAdded Event

public event LabelEventSource.Handler OnLabelAdded;

See Also

LabelEventSource Class | StarTeam.Events Namespace


LabelEventSource.OnLabelChanged Event

public event LabelEventSource.Handler OnLabelChanged;

See Also

LabelEventSource Class | StarTeam.Events Namespace


LabelEventSource.OnLabelDeleted Event

public event LabelEventSource.Handler OnLabelDeleted;

See Also

LabelEventSource Class | StarTeam.Events Namespace


LabelEventSource.Handler Delegate

public delegate void LabelEventSource.Handler(
LabelEventSource source,
LabelEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


LinkUpdateEventArgs Class

For a list of all members of this type, see LinkUpdateEventArgs Members.

System.Object
EventArgs
LinkUpdateEventArgs

public class LinkUpdateEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

LinkUpdateEventArgs Members | StarTeam.Events Namespace


LinkUpdateEventArgs Members

LinkUpdateEventArgs overview

Public Instance Constructors

LinkUpdateEventArgs Constructor

Public Instance Properties

NewLink
OldLink

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

LinkUpdateEventArgs Class | StarTeam.Events Namespace


LinkUpdateEventArgs Constructor

public LinkUpdateEventArgs(
Link oldLink,
Link newLink
);

See Also

LinkUpdateEventArgs Class | StarTeam.Events Namespace


LinkUpdateEventArgs Properties

The properties of the LinkUpdateEventArgs class are listed below. For a complete list of LinkUpdateEventArgs class members, see the LinkUpdateEventArgs Members topic.

Public Instance Properties

NewLink
OldLink

See Also

LinkUpdateEventArgs Class | StarTeam.Events Namespace


NewLink Property

Borland StarTeam SDK for .NET

LinkUpdateEventArgs.NewLink Property

public virtual Link NewLink {get;}

See Also

LinkUpdateEventArgs Class | StarTeam.Events Namespace


OldLink Property

Borland StarTeam SDK for .NET

LinkUpdateEventArgs.OldLink Property

public virtual Link OldLink {get;}

See Also

LinkUpdateEventArgs Class | StarTeam.Events Namespace


LinkUpdateEventArgs Methods

The methods of the LinkUpdateEventArgs class are listed below. For a complete list of LinkUpdateEventArgs class members, see the LinkUpdateEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

LinkUpdateEventArgs Class | StarTeam.Events Namespace


LinkUpdateEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

LinkUpdateEventArgs Class | StarTeam.Events Namespace


LinkUpdateEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

LinkUpdateEventArgs Class | StarTeam.Events Namespace


LinkUpdateEventArgs.ToString Method

public override string ToString();

See Also

LinkUpdateEventArgs Class | StarTeam.Events Namespace


LinkUpdateEventSource Class

For a list of all members of this type, see LinkUpdateEventSource Members.

System.Object
LinkUpdateEventSource

public class LinkUpdateEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

LinkUpdateEventSource Members | StarTeam.Events Namespace


LinkUpdateEventSource Members

LinkUpdateEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnLinkAdded
OnLinkChanged
OnLinkRemoved

See Also

LinkUpdateEventSource Class | StarTeam.Events Namespace


LinkUpdateEventSource Properties

The properties of the LinkUpdateEventSource class are listed below. For a complete list of LinkUpdateEventSource class members, see the LinkUpdateEventSource Members topic.

Public Instance Properties

Parent

See Also

LinkUpdateEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

LinkUpdateEventSource.Parent Property

public Object Parent {get;}

See Also

LinkUpdateEventSource Class | StarTeam.Events Namespace


LinkUpdateEventSource Events

The events of the LinkUpdateEventSource class are listed below. For a complete list of LinkUpdateEventSource class members, see the LinkUpdateEventSource Members topic.

Public Instance Events

OnLinkAdded
OnLinkChanged
OnLinkRemoved

See Also

LinkUpdateEventSource Class | StarTeam.Events Namespace


LinkUpdateEventSource.OnLinkAdded Event

public event LinkUpdateEventSource.Handler OnLinkAdded;

See Also

LinkUpdateEventSource Class | StarTeam.Events Namespace


LinkUpdateEventSource.OnLinkChanged Event

public event LinkUpdateEventSource.Handler OnLinkChanged;

See Also

LinkUpdateEventSource Class | StarTeam.Events Namespace


LinkUpdateEventSource.OnLinkRemoved Event

public event LinkUpdateEventSource.Handler OnLinkRemoved;

See Also

LinkUpdateEventSource Class | StarTeam.Events Namespace


LinkUpdateEventSource.Handler Delegate

public delegate void LinkUpdateEventSource.Handler(
LinkUpdateEventSource source,
LinkUpdateEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


MPXMessageEventArgs Class

For a list of all members of this type, see MPXMessageEventArgs Members.

System.Object
EventArgs
MPXMessageEventArgs

public class MPXMessageEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

MPXMessageEventArgs Members | StarTeam.Events Namespace


MPXMessageEventArgs Members

MPXMessageEventArgs overview

Public Instance Properties

ClassName
EventSubtype
EventType
EventVerb
ServerGUID
ViewID

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


MPXMessageEventArgs Properties

The properties of the MPXMessageEventArgs class are listed below. For a complete list of MPXMessageEventArgs class members, see the MPXMessageEventArgs Members topic.

Public Instance Properties

ClassName
EventSubtype
EventType
EventVerb
ServerGUID
ViewID

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


ClassName Property

Borland StarTeam SDK for .NET

MPXMessageEventArgs.ClassName Property

public virtual String ClassName {get;}

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


EventSubtype Property

Borland StarTeam SDK for .NET

MPXMessageEventArgs.EventSubtype Property

public virtual String EventSubtype {get;}

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


EventType Property

Borland StarTeam SDK for .NET

MPXMessageEventArgs.EventType Property

public virtual String EventType {get;}

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


EventVerb Property

Borland StarTeam SDK for .NET

MPXMessageEventArgs.EventVerb Property

public virtual String EventVerb {get;}

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


ServerGUID Property

Borland StarTeam SDK for .NET

MPXMessageEventArgs.ServerGUID Property

public virtual String ServerGUID {get;}

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


ViewID Property

Borland StarTeam SDK for .NET

MPXMessageEventArgs.ViewID Property

public virtual Int32 ViewID {get;}

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


MPXMessageEventArgs Methods

The methods of the MPXMessageEventArgs class are listed below. For a complete list of MPXMessageEventArgs class members, see the MPXMessageEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


MPXMessageEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


MPXMessageEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


MPXMessageEventArgs.ToString Method

public override string ToString();

See Also

MPXMessageEventArgs Class | StarTeam.Events Namespace


MPXMessageEventSource Class

For a list of all members of this type, see MPXMessageEventSource Members.

System.Object
MPXMessageEventSource

public class MPXMessageEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

MPXMessageEventSource Members | StarTeam.Events Namespace


MPXMessageEventSource Members

MPXMessageEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnReceived

See Also

MPXMessageEventSource Class | StarTeam.Events Namespace


MPXMessageEventSource Properties

The properties of the MPXMessageEventSource class are listed below. For a complete list of MPXMessageEventSource class members, see the MPXMessageEventSource Members topic.

Public Instance Properties

Parent

See Also

MPXMessageEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

MPXMessageEventSource.Parent Property

public Object Parent {get;}

See Also

MPXMessageEventSource Class | StarTeam.Events Namespace


MPXMessageEventSource Events

The events of the MPXMessageEventSource class are listed below. For a complete list of MPXMessageEventSource class members, see the MPXMessageEventSource Members topic.

Public Instance Events

OnReceived

See Also

MPXMessageEventSource Class | StarTeam.Events Namespace


MPXMessageEventSource.OnReceived Event

public event MPXMessageEventSource.Handler OnReceived;

See Also

MPXMessageEventSource Class | StarTeam.Events Namespace


MPXMessageEventSource.Handler Delegate

public delegate void MPXMessageEventSource.Handler(
MPXMessageEventSource source,
MPXMessageEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


MPXStatusEventArgs Class

For a list of all members of this type, see MPXStatusEventArgs Members.

System.Object
EventArgs
MPXStatusEventArgs

public class MPXStatusEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

MPXStatusEventArgs Members | StarTeam.Events Namespace


MPXStatusEventArgs Members

MPXStatusEventArgs overview

Public Instance Properties

Exception
Server

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

MPXStatusEventArgs Class | StarTeam.Events Namespace


MPXStatusEventArgs Properties

The properties of the MPXStatusEventArgs class are listed below. For a complete list of MPXStatusEventArgs class members, see the MPXStatusEventArgs Members topic.

Public Instance Properties

Exception
Server

See Also

MPXStatusEventArgs Class | StarTeam.Events Namespace


Exception Property

Borland StarTeam SDK for .NET

MPXStatusEventArgs.Exception Property

public virtual MPXException Exception {get;}

See Also

MPXStatusEventArgs Class | StarTeam.Events Namespace


Server Property

Borland StarTeam SDK for .NET

MPXStatusEventArgs.Server Property

public virtual Server Server {get;}

See Also

MPXStatusEventArgs Class | StarTeam.Events Namespace


MPXStatusEventArgs Methods

The methods of the MPXStatusEventArgs class are listed below. For a complete list of MPXStatusEventArgs class members, see the MPXStatusEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

MPXStatusEventArgs Class | StarTeam.Events Namespace


MPXStatusEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

MPXStatusEventArgs Class | StarTeam.Events Namespace


MPXStatusEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

MPXStatusEventArgs Class | StarTeam.Events Namespace


MPXStatusEventArgs.ToString Method

public override string ToString();

See Also

MPXStatusEventArgs Class | StarTeam.Events Namespace


MPXStatusEventSource Class

For a list of all members of this type, see MPXStatusEventSource Members.

System.Object
MPXStatusEventSource

public class MPXStatusEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

MPXStatusEventSource Members | StarTeam.Events Namespace


MPXStatusEventSource Members

MPXStatusEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnDisabled
OnEnabled
OnException
OnOffline
OnOnline

See Also

MPXStatusEventSource Class | StarTeam.Events Namespace


MPXStatusEventSource Properties

The properties of the MPXStatusEventSource class are listed below. For a complete list of MPXStatusEventSource class members, see the MPXStatusEventSource Members topic.

Public Instance Properties

Parent

See Also

MPXStatusEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

MPXStatusEventSource.Parent Property

public Object Parent {get;}

See Also

MPXStatusEventSource Class | StarTeam.Events Namespace


MPXStatusEventSource Events

The events of the MPXStatusEventSource class are listed below. For a complete list of MPXStatusEventSource class members, see the MPXStatusEventSource Members topic.

Public Instance Events

OnDisabled
OnEnabled
OnException
OnOffline
OnOnline

See Also

MPXStatusEventSource Class | StarTeam.Events Namespace


MPXStatusEventSource.OnDisabled Event

public event MPXStatusEventSource.Handler OnDisabled;

See Also

MPXStatusEventSource Class | StarTeam.Events Namespace


MPXStatusEventSource.OnEnabled Event

public event MPXStatusEventSource.Handler OnEnabled;

See Also

MPXStatusEventSource Class | StarTeam.Events Namespace


MPXStatusEventSource.OnException Event

public event MPXStatusEventSource.Handler OnException;

See Also

MPXStatusEventSource Class | StarTeam.Events Namespace


MPXStatusEventSource.OnOffline Event

public event MPXStatusEventSource.Handler OnOffline;

See Also

MPXStatusEventSource Class | StarTeam.Events Namespace


MPXStatusEventSource.OnOnline Event

public event MPXStatusEventSource.Handler OnOnline;

See Also

MPXStatusEventSource Class | StarTeam.Events Namespace


MPXStatusEventSource.Handler Delegate

public delegate void MPXStatusEventSource.Handler(
MPXStatusEventSource source,
MPXStatusEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


NotificationEventArgs Class

For a list of all members of this type, see NotificationEventArgs Members.

System.Object
EventArgs
NotificationEventArgs

public class NotificationEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

NotificationEventArgs Members | StarTeam.Events Namespace


NotificationEventArgs Members

NotificationEventArgs overview

Public Instance Properties

Item

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

NotificationEventArgs Class | StarTeam.Events Namespace


NotificationEventArgs Properties

The properties of the NotificationEventArgs class are listed below. For a complete list of NotificationEventArgs class members, see the NotificationEventArgs Members topic.

Public Instance Properties

Item

See Also

NotificationEventArgs Class | StarTeam.Events Namespace


Item Property

Borland StarTeam SDK for .NET

NotificationEventArgs.Item Property

public virtual Item Item {get;}

See Also

NotificationEventArgs Class | StarTeam.Events Namespace


NotificationEventArgs Methods

The methods of the NotificationEventArgs class are listed below. For a complete list of NotificationEventArgs class members, see the NotificationEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

NotificationEventArgs Class | StarTeam.Events Namespace


NotificationEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

NotificationEventArgs Class | StarTeam.Events Namespace


NotificationEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

NotificationEventArgs Class | StarTeam.Events Namespace


NotificationEventArgs.ToString Method

public override string ToString();

See Also

NotificationEventArgs Class | StarTeam.Events Namespace


NotificationEventSource Class

For a list of all members of this type, see NotificationEventSource Members.

System.Object
NotificationEventSource

public class NotificationEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

NotificationEventSource Members | StarTeam.Events Namespace


NotificationEventSource Members

NotificationEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnNotify

See Also

NotificationEventSource Class | StarTeam.Events Namespace


NotificationEventSource Properties

The properties of the NotificationEventSource class are listed below. For a complete list of NotificationEventSource class members, see the NotificationEventSource Members topic.

Public Instance Properties

Parent

See Also

NotificationEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

NotificationEventSource.Parent Property

public Object Parent {get;}

See Also

NotificationEventSource Class | StarTeam.Events Namespace


NotificationEventSource Events

The events of the NotificationEventSource class are listed below. For a complete list of NotificationEventSource class members, see the NotificationEventSource Members topic.

Public Instance Events

OnNotify

See Also

NotificationEventSource Class | StarTeam.Events Namespace


NotificationEventSource.OnNotify Event

public event NotificationEventSource.Handler OnNotify;

See Also

NotificationEventSource Class | StarTeam.Events Namespace


NotificationEventSource.Handler Delegate

public delegate void NotificationEventSource.Handler(
NotificationEventSource source,
NotificationEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ProjectEventArgs Class

For a list of all members of this type, see ProjectEventArgs Members.

System.Object
EventArgs
ProjectEventArgs

public class ProjectEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ProjectEventArgs Members | StarTeam.Events Namespace


ProjectEventArgs Members

ProjectEventArgs overview

Public Instance Properties

Project

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ProjectEventArgs Class | StarTeam.Events Namespace


ProjectEventArgs Properties

The properties of the ProjectEventArgs class are listed below. For a complete list of ProjectEventArgs class members, see the ProjectEventArgs Members topic.

Public Instance Properties

Project

See Also

ProjectEventArgs Class | StarTeam.Events Namespace


Project Property

Borland StarTeam SDK for .NET

ProjectEventArgs.Project Property

public virtual Project Project {get;}

See Also

ProjectEventArgs Class | StarTeam.Events Namespace


ProjectEventArgs Methods

The methods of the ProjectEventArgs class are listed below. For a complete list of ProjectEventArgs class members, see the ProjectEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ProjectEventArgs Class | StarTeam.Events Namespace


ProjectEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ProjectEventArgs Class | StarTeam.Events Namespace


ProjectEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ProjectEventArgs Class | StarTeam.Events Namespace


ProjectEventArgs.ToString Method

public override string ToString();

See Also

ProjectEventArgs Class | StarTeam.Events Namespace


ProjectEventSource Class

For a list of all members of this type, see ProjectEventSource Members.

System.Object
ProjectEventSource

public class ProjectEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ProjectEventSource Members | StarTeam.Events Namespace


ProjectEventSource Members

ProjectEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnProjectAdded
OnProjectChanged
OnProjectDeleted

See Also

ProjectEventSource Class | StarTeam.Events Namespace


ProjectEventSource Properties

The properties of the ProjectEventSource class are listed below. For a complete list of ProjectEventSource class members, see the ProjectEventSource Members topic.

Public Instance Properties

Parent

See Also

ProjectEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ProjectEventSource.Parent Property

public Object Parent {get;}

See Also

ProjectEventSource Class | StarTeam.Events Namespace


ProjectEventSource Events

The events of the ProjectEventSource class are listed below. For a complete list of ProjectEventSource class members, see the ProjectEventSource Members topic.

Public Instance Events

OnProjectAdded
OnProjectChanged
OnProjectDeleted

See Also

ProjectEventSource Class | StarTeam.Events Namespace


ProjectEventSource.OnProjectAdded Event

public event ProjectEventSource.Handler OnProjectAdded;

See Also

ProjectEventSource Class | StarTeam.Events Namespace


ProjectEventSource.OnProjectChanged Event

public event ProjectEventSource.Handler OnProjectChanged;

See Also

ProjectEventSource Class | StarTeam.Events Namespace


ProjectEventSource.OnProjectDeleted Event

public event ProjectEventSource.Handler OnProjectDeleted;

See Also

ProjectEventSource Class | StarTeam.Events Namespace


ProjectEventSource.Handler Delegate

public delegate void ProjectEventSource.Handler(
ProjectEventSource source,
ProjectEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


QueryEventArgs Class

For a list of all members of this type, see QueryEventArgs Members.

System.Object
EventArgs
QueryEventArgs

public class QueryEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

QueryEventArgs Members | StarTeam.Events Namespace


QueryEventArgs Members

QueryEventArgs overview

Public Instance Properties

Query

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

QueryEventArgs Class | StarTeam.Events Namespace


QueryEventArgs Properties

The properties of the QueryEventArgs class are listed below. For a complete list of QueryEventArgs class members, see the QueryEventArgs Members topic.

Public Instance Properties

Query

See Also

QueryEventArgs Class | StarTeam.Events Namespace


Query Property

Borland StarTeam SDK for .NET

QueryEventArgs.Query Property

public virtual Query Query {get;}

See Also

QueryEventArgs Class | StarTeam.Events Namespace


QueryEventArgs Methods

The methods of the QueryEventArgs class are listed below. For a complete list of QueryEventArgs class members, see the QueryEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

QueryEventArgs Class | StarTeam.Events Namespace


QueryEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

QueryEventArgs Class | StarTeam.Events Namespace


QueryEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

QueryEventArgs Class | StarTeam.Events Namespace


QueryEventArgs.ToString Method

public override string ToString();

See Also

QueryEventArgs Class | StarTeam.Events Namespace


QueryEventSource Class

For a list of all members of this type, see QueryEventSource Members.

System.Object
QueryEventSource

public class QueryEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

QueryEventSource Members | StarTeam.Events Namespace


QueryEventSource Members

QueryEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnQueryAdded
OnQueryChanged
OnQueryDeleted

See Also

QueryEventSource Class | StarTeam.Events Namespace


QueryEventSource Properties

The properties of the QueryEventSource class are listed below. For a complete list of QueryEventSource class members, see the QueryEventSource Members topic.

Public Instance Properties

Parent

See Also

QueryEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

QueryEventSource.Parent Property

public Object Parent {get;}

See Also

QueryEventSource Class | StarTeam.Events Namespace


QueryEventSource Events

The events of the QueryEventSource class are listed below. For a complete list of QueryEventSource class members, see the QueryEventSource Members topic.

Public Instance Events

OnQueryAdded
OnQueryChanged
OnQueryDeleted

See Also

QueryEventSource Class | StarTeam.Events Namespace


QueryEventSource.OnQueryAdded Event

public event QueryEventSource.Handler OnQueryAdded;

See Also

QueryEventSource Class | StarTeam.Events Namespace


QueryEventSource.OnQueryChanged Event

public event QueryEventSource.Handler OnQueryChanged;

See Also

QueryEventSource Class | StarTeam.Events Namespace


QueryEventSource.OnQueryDeleted Event

public event QueryEventSource.Handler OnQueryDeleted;

See Also

QueryEventSource Class | StarTeam.Events Namespace


QueryEventSource.Handler Delegate

public delegate void QueryEventSource.Handler(
QueryEventSource source,
QueryEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ServerCommandEventArgs Class

For a list of all members of this type, see ServerCommandEventArgs Members.

System.Object
EventArgs
ServerCommandEventArgs

public class ServerCommandEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerCommandEventArgs Members | StarTeam.Events Namespace


ServerCommandEventArgs Members

ServerCommandEventArgs overview

Public Instance Properties

BytesReceived
BytesSent
CommandCount
CommandID
CommandName
CommandTime
Error
IsCommandFinished
IsPropertyFetchTriggered
IsSuccessful
ItemsExpected
ItemsSoFar
PendingCommandCount
PropertyNameBeingFetched
Server
ServerThreadID
SessionID
Type

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


ServerCommandEventArgs Properties

The properties of the ServerCommandEventArgs class are listed below. For a complete list of ServerCommandEventArgs class members, see the ServerCommandEventArgs Members topic.

Public Instance Properties

BytesReceived
BytesSent
CommandCount
CommandID
CommandName
CommandTime
Error
IsCommandFinished
IsPropertyFetchTriggered
IsSuccessful
ItemsExpected
ItemsSoFar
PendingCommandCount
PropertyNameBeingFetched
Server
ServerThreadID
SessionID
Type

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


BytesReceived Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.BytesReceived Property

public virtual Int64 BytesReceived {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


BytesSent Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.BytesSent Property

public virtual Int64 BytesSent {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


CommandCount Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.CommandCount Property

public virtual Int32 CommandCount {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


CommandID Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.CommandID Property

public virtual Int32 CommandID {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


CommandName Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.CommandName Property

public virtual String CommandName {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


CommandTime Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.CommandTime Property

public virtual Int64 CommandTime {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


Error Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.Error Property

public virtual Exception Error {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


IsCommandFinished Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.IsCommandFinished Property

public virtual Boolean IsCommandFinished {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


IsPropertyFetchTriggered Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.IsPropertyFetchTriggered Property

public virtual Boolean IsPropertyFetchTriggered {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


IsSuccessful Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.IsSuccessful Property

public virtual Boolean IsSuccessful {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


ItemsExpected Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.ItemsExpected Property

public virtual Int32 ItemsExpected {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


ItemsSoFar Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.ItemsSoFar Property

public virtual Int32 ItemsSoFar {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


PendingCommandCount Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.PendingCommandCount Property

public virtual Int32 PendingCommandCount {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


PropertyNameBeingFetched Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.PropertyNameBeingFetched Property

public virtual String PropertyNameBeingFetched {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


Server Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.Server Property

public virtual Server Server {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


ServerThreadID Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.ServerThreadID Property

public virtual Int32 ServerThreadID {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


SessionID Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.SessionID Property

public virtual Int32 SessionID {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


Type Property

Borland StarTeam SDK for .NET

ServerCommandEventArgs.Type Property

public virtual Type Type {get;}

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


ServerCommandEventArgs Methods

The methods of the ServerCommandEventArgs class are listed below. For a complete list of ServerCommandEventArgs class members, see the ServerCommandEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


ServerCommandEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


ServerCommandEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


ServerCommandEventArgs.ToString Method

public override string ToString();

See Also

ServerCommandEventArgs Class | StarTeam.Events Namespace


ServerCommandEventSource Class

For a list of all members of this type, see ServerCommandEventSource Members.

System.Object
ServerCommandEventSource

public class ServerCommandEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerCommandEventSource Members | StarTeam.Events Namespace


ServerCommandEventSource Members

ServerCommandEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnEnd
OnError
OnStart

See Also

ServerCommandEventSource Class | StarTeam.Events Namespace


ServerCommandEventSource Properties

The properties of the ServerCommandEventSource class are listed below. For a complete list of ServerCommandEventSource class members, see the ServerCommandEventSource Members topic.

Public Instance Properties

Parent

See Also

ServerCommandEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ServerCommandEventSource.Parent Property

public Object Parent {get;}

See Also

ServerCommandEventSource Class | StarTeam.Events Namespace


ServerCommandEventSource Events

The events of the ServerCommandEventSource class are listed below. For a complete list of ServerCommandEventSource class members, see the ServerCommandEventSource Members topic.

Public Instance Events

OnEnd
OnError
OnStart

See Also

ServerCommandEventSource Class | StarTeam.Events Namespace


ServerCommandEventSource.OnEnd Event

public event ServerCommandEventSource.Handler OnEnd;

See Also

ServerCommandEventSource Class | StarTeam.Events Namespace


ServerCommandEventSource.OnError Event

public event ServerCommandEventSource.Handler OnError;

See Also

ServerCommandEventSource Class | StarTeam.Events Namespace


ServerCommandEventSource.OnStart Event

public event ServerCommandEventSource.Handler OnStart;

See Also

ServerCommandEventSource Class | StarTeam.Events Namespace


ServerCommandEventSource.Handler Delegate

public delegate void ServerCommandEventSource.Handler(
ServerCommandEventSource source,
ServerCommandEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ServerControlEventArgs Class

For a list of all members of this type, see ServerControlEventArgs Members.

System.Object
EventArgs
ServerControlEventArgs

public class ServerControlEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerControlEventArgs Members | StarTeam.Events Namespace


ServerControlEventArgs Members

ServerControlEventArgs overview

Public Instance Properties

Server

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ServerControlEventArgs Class | StarTeam.Events Namespace


ServerControlEventArgs Properties

The properties of the ServerControlEventArgs class are listed below. For a complete list of ServerControlEventArgs class members, see the ServerControlEventArgs Members topic.

Public Instance Properties

Server

See Also

ServerControlEventArgs Class | StarTeam.Events Namespace


Server Property

Borland StarTeam SDK for .NET

ServerControlEventArgs.Server Property

public virtual Server Server {get;}

See Also

ServerControlEventArgs Class | StarTeam.Events Namespace


ServerControlEventArgs Methods

The methods of the ServerControlEventArgs class are listed below. For a complete list of ServerControlEventArgs class members, see the ServerControlEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ServerControlEventArgs Class | StarTeam.Events Namespace


ServerControlEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ServerControlEventArgs Class | StarTeam.Events Namespace


ServerControlEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ServerControlEventArgs Class | StarTeam.Events Namespace


ServerControlEventArgs.ToString Method

public override string ToString();

See Also

ServerControlEventArgs Class | StarTeam.Events Namespace


ServerControlEventSource Class

For a list of all members of this type, see ServerControlEventSource Members.

System.Object
ServerControlEventSource

public class ServerControlEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerControlEventSource Members | StarTeam.Events Namespace


ServerControlEventSource Members

ServerControlEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnServerStarted
OnServerStopped

See Also

ServerControlEventSource Class | StarTeam.Events Namespace


ServerControlEventSource Properties

The properties of the ServerControlEventSource class are listed below. For a complete list of ServerControlEventSource class members, see the ServerControlEventSource Members topic.

Public Instance Properties

Parent

See Also

ServerControlEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ServerControlEventSource.Parent Property

public Object Parent {get;}

See Also

ServerControlEventSource Class | StarTeam.Events Namespace


ServerControlEventSource Events

The events of the ServerControlEventSource class are listed below. For a complete list of ServerControlEventSource class members, see the ServerControlEventSource Members topic.

Public Instance Events

OnServerStarted
OnServerStopped

See Also

ServerControlEventSource Class | StarTeam.Events Namespace


ServerControlEventSource.OnServerStarted Event

public event ServerControlEventSource.Handler OnServerStarted;

See Also

ServerControlEventSource Class | StarTeam.Events Namespace


ServerControlEventSource.OnServerStopped Event

public event ServerControlEventSource.Handler OnServerStopped;

See Also

ServerControlEventSource Class | StarTeam.Events Namespace


ServerControlEventSource.Handler Delegate

public delegate void ServerControlEventSource.Handler(
ServerControlEventSource source,
ServerControlEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


TraceEventArgs Class

For a list of all members of this type, see TraceEventArgs Members.

System.Object
EventArgs
TraceEventArgs

public class TraceEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

TraceEventArgs Members | StarTeam.Events Namespace


TraceEventArgs Members

TraceEventArgs overview

Public Instance Properties

Failure
IsCanceled
IsSuccessful
Server
TotalWork
Traces
WorkCompleted

Public Instance Methods

Cancel |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

TraceEventArgs Class | StarTeam.Events Namespace


TraceEventArgs Properties

The properties of the TraceEventArgs class are listed below. For a complete list of TraceEventArgs class members, see the TraceEventArgs Members topic.

Public Instance Properties

Failure
IsCanceled
IsSuccessful
Server
TotalWork
Traces
WorkCompleted

See Also

TraceEventArgs Class | StarTeam.Events Namespace


Failure Property

Borland StarTeam SDK for .NET

TraceEventArgs.Failure Property

public virtual Exception Failure {get;}

See Also

TraceEventArgs Class | StarTeam.Events Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

TraceEventArgs.IsCanceled Property

public virtual Boolean IsCanceled {get;}

See Also

TraceEventArgs Class | StarTeam.Events Namespace


IsSuccessful Property

Borland StarTeam SDK for .NET

TraceEventArgs.IsSuccessful Property

public virtual Boolean IsSuccessful {get;}

See Also

TraceEventArgs Class | StarTeam.Events Namespace


Server Property

Borland StarTeam SDK for .NET

TraceEventArgs.Server Property

public virtual Server Server {get;}

See Also

TraceEventArgs Class | StarTeam.Events Namespace


TotalWork Property

Borland StarTeam SDK for .NET

TraceEventArgs.TotalWork Property

public virtual Int32 TotalWork {get;}

See Also

TraceEventArgs Class | StarTeam.Events Namespace


Traces Property

Borland StarTeam SDK for .NET

TraceEventArgs.Traces Property

public virtual TraceCollection Traces {get;}

See Also

TraceEventArgs Class | StarTeam.Events Namespace


WorkCompleted Property

Borland StarTeam SDK for .NET

TraceEventArgs.WorkCompleted Property

public virtual Int32 WorkCompleted {get;}

See Also

TraceEventArgs Class | StarTeam.Events Namespace


TraceEventArgs Methods

The methods of the TraceEventArgs class are listed below. For a complete list of TraceEventArgs class members, see the TraceEventArgs Members topic.

Public Instance Methods

Cancel |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

TraceEventArgs Class | StarTeam.Events Namespace


TraceEventArgs.Cancel Method

public virtual void Cancel();

See Also

TraceEventArgs Class | StarTeam.Events Namespace


TraceEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

TraceEventArgs Class | StarTeam.Events Namespace


TraceEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

TraceEventArgs Class | StarTeam.Events Namespace


TraceEventArgs.ToString Method

public override string ToString();

See Also

TraceEventArgs Class | StarTeam.Events Namespace


TraceEventSource Class

For a list of all members of this type, see TraceEventSource Members.

System.Object
TraceEventSource

public class TraceEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

TraceEventSource Members | StarTeam.Events Namespace


TraceEventSource Members

TraceEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnErrorOccured
OnTracesFound

See Also

TraceEventSource Class | StarTeam.Events Namespace


TraceEventSource Properties

The properties of the TraceEventSource class are listed below. For a complete list of TraceEventSource class members, see the TraceEventSource Members topic.

Public Instance Properties

Parent

See Also

TraceEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

TraceEventSource.Parent Property

public Object Parent {get;}

See Also

TraceEventSource Class | StarTeam.Events Namespace


TraceEventSource Events

The events of the TraceEventSource class are listed below. For a complete list of TraceEventSource class members, see the TraceEventSource Members topic.

Public Instance Events

OnErrorOccured
OnTracesFound

See Also

TraceEventSource Class | StarTeam.Events Namespace


TraceEventSource.OnErrorOccured Event

public event TraceEventSource.Handler OnErrorOccured;

See Also

TraceEventSource Class | StarTeam.Events Namespace


TraceEventSource.OnTracesFound Event

public event TraceEventSource.Handler OnTracesFound;

See Also

TraceEventSource Class | StarTeam.Events Namespace


TraceEventSource.Handler Delegate

public delegate void TraceEventSource.Handler(
TraceEventSource source,
TraceEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


TypedResourceEventArgs Class

For a list of all members of this type, see TypedResourceEventArgs Members.

System.Object
EventArgs
TypedResourceEventArgs

public class TypedResourceEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

TypedResourceEventArgs Members | StarTeam.Events Namespace


TypedResourceEventArgs Members

TypedResourceEventArgs overview

Public Instance Properties

ContainedType
ContainerItemID
Type
TypedResource

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


TypedResourceEventArgs Properties

The properties of the TypedResourceEventArgs class are listed below. For a complete list of TypedResourceEventArgs class members, see the TypedResourceEventArgs Members topic.

Public Instance Properties

ContainedType
ContainerItemID
Type
TypedResource

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


ContainedType Property

Borland StarTeam SDK for .NET

TypedResourceEventArgs.ContainedType Property

public virtual Type ContainedType {get;}

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


ContainerItemID Property

Borland StarTeam SDK for .NET

TypedResourceEventArgs.ContainerItemID Property

public virtual Int32 ContainerItemID {get;}

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


Type Property

Borland StarTeam SDK for .NET

TypedResourceEventArgs.Type Property

public virtual Type Type {get;}

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


TypedResource Property

Borland StarTeam SDK for .NET

TypedResourceEventArgs.TypedResource Property

public virtual TypedResource TypedResource {get;}

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


TypedResourceEventArgs Methods

The methods of the TypedResourceEventArgs class are listed below. For a complete list of TypedResourceEventArgs class members, see the TypedResourceEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


TypedResourceEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


TypedResourceEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


TypedResourceEventArgs.ToString Method

public override string ToString();

See Also

TypedResourceEventArgs Class | StarTeam.Events Namespace


TypedResourceEventSource Class

For a list of all members of this type, see TypedResourceEventSource Members.

System.Object
TypedResourceEventSource

public class TypedResourceEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

TypedResourceEventSource Members | StarTeam.Events Namespace


TypedResourceEventSource Members

TypedResourceEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnContainerChanged
OnResourceAdded
OnResourceChanged
OnResourceRemoved

See Also

TypedResourceEventSource Class | StarTeam.Events Namespace


TypedResourceEventSource Properties

The properties of the TypedResourceEventSource class are listed below. For a complete list of TypedResourceEventSource class members, see the TypedResourceEventSource Members topic.

Public Instance Properties

Parent

See Also

TypedResourceEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

TypedResourceEventSource.Parent Property

public Object Parent {get;}

See Also

TypedResourceEventSource Class | StarTeam.Events Namespace


TypedResourceEventSource Events

The events of the TypedResourceEventSource class are listed below. For a complete list of TypedResourceEventSource class members, see the TypedResourceEventSource Members topic.

Public Instance Events

OnContainerChanged
OnResourceAdded
OnResourceChanged
OnResourceRemoved

See Also

TypedResourceEventSource Class | StarTeam.Events Namespace


TypedResourceEventSource.OnContainerChanged Event

public event TypedResourceEventSource.Handler OnContainerChanged;

See Also

TypedResourceEventSource Class | StarTeam.Events Namespace


TypedResourceEventSource.OnResourceAdded Event

public event TypedResourceEventSource.Handler OnResourceAdded;

See Also

TypedResourceEventSource Class | StarTeam.Events Namespace


TypedResourceEventSource.OnResourceChanged Event

public event TypedResourceEventSource.Handler OnResourceChanged;

See Also

TypedResourceEventSource Class | StarTeam.Events Namespace


TypedResourceEventSource.OnResourceRemoved Event

public event TypedResourceEventSource.Handler OnResourceRemoved;

See Also

TypedResourceEventSource Class | StarTeam.Events Namespace


TypedResourceEventSource.Handler Delegate

public delegate void TypedResourceEventSource.Handler(
TypedResourceEventSource source,
TypedResourceEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


TypeEventArgs Class

For a list of all members of this type, see TypeEventArgs Members.

System.Object
EventArgs
TypeEventArgs

public class TypeEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

TypeEventArgs Members | StarTeam.Events Namespace


TypeEventArgs Members

TypeEventArgs overview

Public Instance Properties

Type

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

TypeEventArgs Class | StarTeam.Events Namespace


TypeEventArgs Properties

The properties of the TypeEventArgs class are listed below. For a complete list of TypeEventArgs class members, see the TypeEventArgs Members topic.

Public Instance Properties

Type

See Also

TypeEventArgs Class | StarTeam.Events Namespace


Type Property

Borland StarTeam SDK for .NET

TypeEventArgs.Type Property

public virtual Type Type {get;}

See Also

TypeEventArgs Class | StarTeam.Events Namespace


TypeEventArgs Methods

The methods of the TypeEventArgs class are listed below. For a complete list of TypeEventArgs class members, see the TypeEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

TypeEventArgs Class | StarTeam.Events Namespace


TypeEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

TypeEventArgs Class | StarTeam.Events Namespace


TypeEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

TypeEventArgs Class | StarTeam.Events Namespace


TypeEventArgs.ToString Method

public override string ToString();

See Also

TypeEventArgs Class | StarTeam.Events Namespace


TypeEventSource Class

For a list of all members of this type, see TypeEventSource Members.

System.Object
TypeEventSource

public class TypeEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

TypeEventSource Members | StarTeam.Events Namespace


TypeEventSource Members

TypeEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnTypeAdded
OnTypeChanged

See Also

TypeEventSource Class | StarTeam.Events Namespace


TypeEventSource Properties

The properties of the TypeEventSource class are listed below. For a complete list of TypeEventSource class members, see the TypeEventSource Members topic.

Public Instance Properties

Parent

See Also

TypeEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

TypeEventSource.Parent Property

public Object Parent {get;}

See Also

TypeEventSource Class | StarTeam.Events Namespace


TypeEventSource Events

The events of the TypeEventSource class are listed below. For a complete list of TypeEventSource class members, see the TypeEventSource Members topic.

Public Instance Events

OnTypeAdded
OnTypeChanged

See Also

TypeEventSource Class | StarTeam.Events Namespace


TypeEventSource.OnTypeAdded Event

public event TypeEventSource.Handler OnTypeAdded;

See Also

TypeEventSource Class | StarTeam.Events Namespace


TypeEventSource.OnTypeChanged Event

public event TypeEventSource.Handler OnTypeChanged;

See Also

TypeEventSource Class | StarTeam.Events Namespace


TypeEventSource.Handler Delegate

public delegate void TypeEventSource.Handler(
TypeEventSource source,
TypeEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


UserEventArgs Class

For a list of all members of this type, see UserEventArgs Members.

System.Object
EventArgs
UserEventArgs

public class UserEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

UserEventArgs Members | StarTeam.Events Namespace


UserEventArgs Members

UserEventArgs overview

Public Instance Properties

User

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

UserEventArgs Class | StarTeam.Events Namespace


UserEventArgs Properties

The properties of the UserEventArgs class are listed below. For a complete list of UserEventArgs class members, see the UserEventArgs Members topic.

Public Instance Properties

User

See Also

UserEventArgs Class | StarTeam.Events Namespace


User Property

Borland StarTeam SDK for .NET

UserEventArgs.User Property

public virtual User User {get;}

See Also

UserEventArgs Class | StarTeam.Events Namespace


UserEventArgs Methods

The methods of the UserEventArgs class are listed below. For a complete list of UserEventArgs class members, see the UserEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

UserEventArgs Class | StarTeam.Events Namespace


UserEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

UserEventArgs Class | StarTeam.Events Namespace


UserEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

UserEventArgs Class | StarTeam.Events Namespace


UserEventArgs.ToString Method

public override string ToString();

See Also

UserEventArgs Class | StarTeam.Events Namespace


UserEventSource Class

For a list of all members of this type, see UserEventSource Members.

System.Object
UserEventSource

public class UserEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

UserEventSource Members | StarTeam.Events Namespace


UserEventSource Members

UserEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnUserAdded
OnUserChanged
OnUserDeleted

See Also

UserEventSource Class | StarTeam.Events Namespace


UserEventSource Properties

The properties of the UserEventSource class are listed below. For a complete list of UserEventSource class members, see the UserEventSource Members topic.

Public Instance Properties

Parent

See Also

UserEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

UserEventSource.Parent Property

public Object Parent {get;}

See Also

UserEventSource Class | StarTeam.Events Namespace


UserEventSource Events

The events of the UserEventSource class are listed below. For a complete list of UserEventSource class members, see the UserEventSource Members topic.

Public Instance Events

OnUserAdded
OnUserChanged
OnUserDeleted

See Also

UserEventSource Class | StarTeam.Events Namespace


UserEventSource.OnUserAdded Event

public event UserEventSource.Handler OnUserAdded;

See Also

UserEventSource Class | StarTeam.Events Namespace


UserEventSource.OnUserChanged Event

public event UserEventSource.Handler OnUserChanged;

See Also

UserEventSource Class | StarTeam.Events Namespace


UserEventSource.OnUserDeleted Event

public event UserEventSource.Handler OnUserDeleted;

See Also

UserEventSource Class | StarTeam.Events Namespace


UserEventSource.Handler Delegate

public delegate void UserEventSource.Handler(
UserEventSource source,
UserEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ViewEventArgs Class

For a list of all members of this type, see ViewEventArgs Members.

System.Object
EventArgs
ViewEventArgs

public class ViewEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewEventArgs Members | StarTeam.Events Namespace


ViewEventArgs Members

ViewEventArgs overview

Public Instance Properties

View

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ViewEventArgs Class | StarTeam.Events Namespace


ViewEventArgs Properties

The properties of the ViewEventArgs class are listed below. For a complete list of ViewEventArgs class members, see the ViewEventArgs Members topic.

Public Instance Properties

View

See Also

ViewEventArgs Class | StarTeam.Events Namespace


View Property

Borland StarTeam SDK for .NET

ViewEventArgs.View Property

public virtual View View {get;}

See Also

ViewEventArgs Class | StarTeam.Events Namespace


ViewEventArgs Methods

The methods of the ViewEventArgs class are listed below. For a complete list of ViewEventArgs class members, see the ViewEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ViewEventArgs Class | StarTeam.Events Namespace


ViewEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ViewEventArgs Class | StarTeam.Events Namespace


ViewEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ViewEventArgs Class | StarTeam.Events Namespace


ViewEventArgs.ToString Method

public override string ToString();

See Also

ViewEventArgs Class | StarTeam.Events Namespace


ViewEventSource Class

For a list of all members of this type, see ViewEventSource Members.

System.Object
ViewEventSource

public class ViewEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewEventSource Members | StarTeam.Events Namespace


ViewEventSource Members

ViewEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnViewAdded
OnViewChanged
OnViewDeleted

See Also

ViewEventSource Class | StarTeam.Events Namespace


ViewEventSource Properties

The properties of the ViewEventSource class are listed below. For a complete list of ViewEventSource class members, see the ViewEventSource Members topic.

Public Instance Properties

Parent

See Also

ViewEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ViewEventSource.Parent Property

public Object Parent {get;}

See Also

ViewEventSource Class | StarTeam.Events Namespace


ViewEventSource Events

The events of the ViewEventSource class are listed below. For a complete list of ViewEventSource class members, see the ViewEventSource Members topic.

Public Instance Events

OnViewAdded
OnViewChanged
OnViewDeleted

See Also

ViewEventSource Class | StarTeam.Events Namespace


ViewEventSource.OnViewAdded Event

public event ViewEventSource.Handler OnViewAdded;

See Also

ViewEventSource Class | StarTeam.Events Namespace


ViewEventSource.OnViewChanged Event

public event ViewEventSource.Handler OnViewChanged;

See Also

ViewEventSource Class | StarTeam.Events Namespace


ViewEventSource.OnViewDeleted Event

public event ViewEventSource.Handler OnViewDeleted;

See Also

ViewEventSource Class | StarTeam.Events Namespace


ViewEventSource.Handler Delegate

public delegate void ViewEventSource.Handler(
ViewEventSource source,
ViewEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ViewMemberEventArgs Class

For a list of all members of this type, see ViewMemberEventArgs Members.

System.Object
EventArgs
ViewMemberEventArgs

public class ViewMemberEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberEventArgs Members | StarTeam.Events Namespace


ViewMemberEventArgs Members

ViewMemberEventArgs overview

Public Instance Properties

NewViewMember
OldViewMember

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ViewMemberEventArgs Class | StarTeam.Events Namespace


ViewMemberEventArgs Properties

The properties of the ViewMemberEventArgs class are listed below. For a complete list of ViewMemberEventArgs class members, see the ViewMemberEventArgs Members topic.

Public Instance Properties

NewViewMember
OldViewMember

See Also

ViewMemberEventArgs Class | StarTeam.Events Namespace


NewViewMember Property

Borland StarTeam SDK for .NET

ViewMemberEventArgs.NewViewMember Property

public virtual ViewMember NewViewMember {get;}

See Also

ViewMemberEventArgs Class | StarTeam.Events Namespace


OldViewMember Property

Borland StarTeam SDK for .NET

ViewMemberEventArgs.OldViewMember Property

public virtual ViewMember OldViewMember {get;}

See Also

ViewMemberEventArgs Class | StarTeam.Events Namespace


ViewMemberEventArgs Methods

The methods of the ViewMemberEventArgs class are listed below. For a complete list of ViewMemberEventArgs class members, see the ViewMemberEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ViewMemberEventArgs Class | StarTeam.Events Namespace


ViewMemberEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ViewMemberEventArgs Class | StarTeam.Events Namespace


ViewMemberEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ViewMemberEventArgs Class | StarTeam.Events Namespace


ViewMemberEventArgs.ToString Method

public override string ToString();

See Also

ViewMemberEventArgs Class | StarTeam.Events Namespace


ViewMemberEventSource Class

For a list of all members of this type, see ViewMemberEventSource Members.

System.Object
ViewMemberEventSource

public class ViewMemberEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberEventSource Members | StarTeam.Events Namespace


ViewMemberEventSource Members

ViewMemberEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnViewMemberAdded
OnViewMemberChanged
OnViewMemberRemoved

See Also

ViewMemberEventSource Class | StarTeam.Events Namespace


ViewMemberEventSource Properties

The properties of the ViewMemberEventSource class are listed below. For a complete list of ViewMemberEventSource class members, see the ViewMemberEventSource Members topic.

Public Instance Properties

Parent

See Also

ViewMemberEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ViewMemberEventSource.Parent Property

public Object Parent {get;}

See Also

ViewMemberEventSource Class | StarTeam.Events Namespace


ViewMemberEventSource Events

The events of the ViewMemberEventSource class are listed below. For a complete list of ViewMemberEventSource class members, see the ViewMemberEventSource Members topic.

Public Instance Events

OnViewMemberAdded
OnViewMemberChanged
OnViewMemberRemoved

See Also

ViewMemberEventSource Class | StarTeam.Events Namespace


ViewMemberEventSource.OnViewMemberAdded Event

public event ViewMemberEventSource.Handler OnViewMemberAdded;

See Also

ViewMemberEventSource Class | StarTeam.Events Namespace


ViewMemberEventSource.OnViewMemberChanged Event

public event ViewMemberEventSource.Handler OnViewMemberChanged;

See Also

ViewMemberEventSource Class | StarTeam.Events Namespace


ViewMemberEventSource.OnViewMemberRemoved Event

public event ViewMemberEventSource.Handler OnViewMemberRemoved;

See Also

ViewMemberEventSource Class | StarTeam.Events Namespace


ViewMemberEventSource.Handler Delegate

public delegate void ViewMemberEventSource.Handler(
ViewMemberEventSource source,
ViewMemberEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


ViewMemberUpdateEventArgs Class

For a list of all members of this type, see ViewMemberUpdateEventArgs Members.

System.Object
EventArgs
ViewMemberUpdateEventArgs

public class ViewMemberUpdateEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberUpdateEventArgs Members | StarTeam.Events Namespace


ViewMemberUpdateEventArgs Members

ViewMemberUpdateEventArgs overview

Public Instance Constructors

ViewMemberUpdateEventArgs Constructor

Public Instance Properties

NewViewMember
OldViewMember

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ViewMemberUpdateEventArgs Class | StarTeam.Events Namespace


ViewMemberUpdateEventArgs Constructor

public ViewMemberUpdateEventArgs(
ViewMember oldViewMember,
ViewMember newViewMember
);

See Also

ViewMemberUpdateEventArgs Class | StarTeam.Events Namespace


ViewMemberUpdateEventArgs Properties

The properties of the ViewMemberUpdateEventArgs class are listed below. For a complete list of ViewMemberUpdateEventArgs class members, see the ViewMemberUpdateEventArgs Members topic.

Public Instance Properties

NewViewMember
OldViewMember

See Also

ViewMemberUpdateEventArgs Class | StarTeam.Events Namespace


NewViewMember Property

Borland StarTeam SDK for .NET

ViewMemberUpdateEventArgs.NewViewMember Property

public virtual ViewMember NewViewMember {get;}

See Also

ViewMemberUpdateEventArgs Class | StarTeam.Events Namespace


OldViewMember Property

Borland StarTeam SDK for .NET

ViewMemberUpdateEventArgs.OldViewMember Property

public virtual ViewMember OldViewMember {get;}

See Also

ViewMemberUpdateEventArgs Class | StarTeam.Events Namespace


ViewMemberUpdateEventArgs Methods

The methods of the ViewMemberUpdateEventArgs class are listed below. For a complete list of ViewMemberUpdateEventArgs class members, see the ViewMemberUpdateEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

ViewMemberUpdateEventArgs Class | StarTeam.Events Namespace


ViewMemberUpdateEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

ViewMemberUpdateEventArgs Class | StarTeam.Events Namespace


ViewMemberUpdateEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

ViewMemberUpdateEventArgs Class | StarTeam.Events Namespace


ViewMemberUpdateEventArgs.ToString Method

public override string ToString();

See Also

ViewMemberUpdateEventArgs Class | StarTeam.Events Namespace


ViewMemberUpdateEventSource Class

For a list of all members of this type, see ViewMemberUpdateEventSource Members.

System.Object
ViewMemberUpdateEventSource

public class ViewMemberUpdateEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewMemberUpdateEventSource Members | StarTeam.Events Namespace


ViewMemberUpdateEventSource Members

ViewMemberUpdateEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnAdded
OnChanged
OnRemoved

See Also

ViewMemberUpdateEventSource Class | StarTeam.Events Namespace


ViewMemberUpdateEventSource Properties

The properties of the ViewMemberUpdateEventSource class are listed below. For a complete list of ViewMemberUpdateEventSource class members, see the ViewMemberUpdateEventSource Members topic.

Public Instance Properties

Parent

See Also

ViewMemberUpdateEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

ViewMemberUpdateEventSource.Parent Property

public Object Parent {get;}

See Also

ViewMemberUpdateEventSource Class | StarTeam.Events Namespace


ViewMemberUpdateEventSource Events

The events of the ViewMemberUpdateEventSource class are listed below. For a complete list of ViewMemberUpdateEventSource class members, see the ViewMemberUpdateEventSource Members topic.

Public Instance Events

OnAdded
OnChanged
OnRemoved

See Also

ViewMemberUpdateEventSource Class | StarTeam.Events Namespace


ViewMemberUpdateEventSource.OnAdded Event

public event ViewMemberUpdateEventSource.Handler OnAdded;

See Also

ViewMemberUpdateEventSource Class | StarTeam.Events Namespace


ViewMemberUpdateEventSource.OnChanged Event

public event ViewMemberUpdateEventSource.Handler OnChanged;

See Also

ViewMemberUpdateEventSource Class | StarTeam.Events Namespace


ViewMemberUpdateEventSource.OnRemoved Event

public event ViewMemberUpdateEventSource.Handler OnRemoved;

See Also

ViewMemberUpdateEventSource Class | StarTeam.Events Namespace


ViewMemberUpdateEventSource.Handler Delegate

public delegate void ViewMemberUpdateEventSource.Handler(
ViewMemberUpdateEventSource source,
ViewMemberUpdateEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheAccessRightsEventArgs Class

For a list of all members of this type, see WebCacheAccessRightsEventArgs Members.

System.Object
EventArgs
WebCacheAccessRightsEventArgs

public class WebCacheAccessRightsEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheAccessRightsEventArgs Members | StarTeam.Events Namespace


WebCacheAccessRightsEventArgs Members

WebCacheAccessRightsEventArgs overview

Public Instance Properties

AccessRights
Securable
SecurableContainer
Type

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


WebCacheAccessRightsEventArgs Properties

The properties of the WebCacheAccessRightsEventArgs class are listed below. For a complete list of WebCacheAccessRightsEventArgs class members, see the WebCacheAccessRightsEventArgs Members topic.

Public Instance Properties

AccessRights
Securable
SecurableContainer
Type

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


AccessRights Property

Borland StarTeam SDK for .NET

WebCacheAccessRightsEventArgs.AccessRights Property

public virtual WebCacheACE[] AccessRights {get;}

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


Securable Property

Borland StarTeam SDK for .NET

WebCacheAccessRightsEventArgs.Securable Property

public virtual ArtifactCacheManager.Securable Securable {get;}

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


SecurableContainer Property

Borland StarTeam SDK for .NET

WebCacheAccessRightsEventArgs.SecurableContainer Property

public virtual ArtifactCacheManager.SecurableContainer SecurableContainer {get;}

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


Type Property

Borland StarTeam SDK for .NET

WebCacheAccessRightsEventArgs.Type Property

public virtual Type.WebCacheType Type {get;}

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


WebCacheAccessRightsEventArgs Methods

The methods of the WebCacheAccessRightsEventArgs class are listed below. For a complete list of WebCacheAccessRightsEventArgs class members, see the WebCacheAccessRightsEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


WebCacheAccessRightsEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


WebCacheAccessRightsEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


WebCacheAccessRightsEventArgs.ToString Method

public override string ToString();

See Also

WebCacheAccessRightsEventArgs Class | StarTeam.Events Namespace


WebCacheAccessRightsEventSource Class

For a list of all members of this type, see WebCacheAccessRightsEventSource Members.

System.Object
WebCacheAccessRightsEventSource

public class WebCacheAccessRightsEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheAccessRightsEventSource Members | StarTeam.Events Namespace


WebCacheAccessRightsEventSource Members

WebCacheAccessRightsEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnAccessRightsChanged

See Also

WebCacheAccessRightsEventSource Class | StarTeam.Events Namespace


WebCacheAccessRightsEventSource Properties

The properties of the WebCacheAccessRightsEventSource class are listed below. For a complete list of WebCacheAccessRightsEventSource class members, see the WebCacheAccessRightsEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheAccessRightsEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheAccessRightsEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheAccessRightsEventSource Class | StarTeam.Events Namespace


WebCacheAccessRightsEventSource Events

The events of the WebCacheAccessRightsEventSource class are listed below. For a complete list of WebCacheAccessRightsEventSource class members, see the WebCacheAccessRightsEventSource Members topic.

Public Instance Events

OnAccessRightsChanged

See Also

WebCacheAccessRightsEventSource Class | StarTeam.Events Namespace


WebCacheAccessRightsEventSource.OnAccessRightsChanged Event

public event WebCacheAccessRightsEventSource.Handler OnAccessRightsChanged;

See Also

WebCacheAccessRightsEventSource Class | StarTeam.Events Namespace


WebCacheAccessRightsEventSource.Handler Delegate

public delegate void WebCacheAccessRightsEventSource.Handler(
WebCacheAccessRightsEventSource source,
WebCacheAccessRightsEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheCheckinEventArgs Class

For a list of all members of this type, see WebCacheCheckinEventArgs Members.

System.Object
EventArgs
WebCacheCheckinEventArgs

public class WebCacheCheckinEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheCheckinEventArgs Members | StarTeam.Events Namespace


WebCacheCheckinEventArgs Members

WebCacheCheckinEventArgs overview

Public Instance Properties

CheckinManager
CheckinResult
CurrentFile
CurrentWorkingFile
Error
ErrorMessage
IsCanceled
IsFinished
IsSuccessful
Options

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


WebCacheCheckinEventArgs Properties

The properties of the WebCacheCheckinEventArgs class are listed below. For a complete list of WebCacheCheckinEventArgs class members, see the WebCacheCheckinEventArgs Members topic.

Public Instance Properties

CheckinManager
CheckinResult
CurrentFile
CurrentWorkingFile
Error
ErrorMessage
IsCanceled
IsFinished
IsSuccessful
Options

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


CheckinManager Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.CheckinManager Property

public virtual CheckinManager.WebCacheCheckinManager CheckinManager {get;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


CheckinResult Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.CheckinResult Property

public virtual File.CheckInResult CheckinResult {get;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


CurrentFile Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.CurrentFile Property

public virtual File.WebCacheFile CurrentFile {get;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


CurrentWorkingFile Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.CurrentWorkingFile Property

public virtual FileInfo CurrentWorkingFile {get; set;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


Error Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.Error Property

public virtual Exception Error {get;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


ErrorMessage Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.ErrorMessage Property

public virtual String ErrorMessage {get;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.IsCanceled Property

public virtual Boolean IsCanceled {get;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


IsFinished Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.IsFinished Property

public virtual Boolean IsFinished {get;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


IsSuccessful Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.IsSuccessful Property

public virtual Boolean IsSuccessful {get;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


Options Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventArgs.Options Property

public virtual CheckinOptions.WebCacheCheckinOptions Options {get;}

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


WebCacheCheckinEventArgs Methods

The methods of the WebCacheCheckinEventArgs class are listed below. For a complete list of WebCacheCheckinEventArgs class members, see the WebCacheCheckinEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


WebCacheCheckinEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


WebCacheCheckinEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


WebCacheCheckinEventArgs.ToString Method

public override string ToString();

See Also

WebCacheCheckinEventArgs Class | StarTeam.Events Namespace


WebCacheCheckinEventSource Class

For a list of all members of this type, see WebCacheCheckinEventSource Members.

System.Object
WebCacheCheckinEventSource

public class WebCacheCheckinEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheCheckinEventSource Members | StarTeam.Events Namespace


WebCacheCheckinEventSource Members

WebCacheCheckinEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnNotifyProgress
OnStartFile

See Also

WebCacheCheckinEventSource Class | StarTeam.Events Namespace


WebCacheCheckinEventSource Properties

The properties of the WebCacheCheckinEventSource class are listed below. For a complete list of WebCacheCheckinEventSource class members, see the WebCacheCheckinEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheCheckinEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheCheckinEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheCheckinEventSource Class | StarTeam.Events Namespace


WebCacheCheckinEventSource Events

The events of the WebCacheCheckinEventSource class are listed below. For a complete list of WebCacheCheckinEventSource class members, see the WebCacheCheckinEventSource Members topic.

Public Instance Events

OnNotifyProgress
OnStartFile

See Also

WebCacheCheckinEventSource Class | StarTeam.Events Namespace


WebCacheCheckinEventSource.OnNotifyProgress Event

public event WebCacheCheckinEventSource.Handler OnNotifyProgress;

See Also

WebCacheCheckinEventSource Class | StarTeam.Events Namespace


WebCacheCheckinEventSource.OnStartFile Event

public event WebCacheCheckinEventSource.Handler OnStartFile;

See Also

WebCacheCheckinEventSource Class | StarTeam.Events Namespace


WebCacheCheckinEventSource.Handler Delegate

public delegate void WebCacheCheckinEventSource.Handler(
WebCacheCheckinEventSource source,
WebCacheCheckinEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheCheckoutEventArgs Class

For a list of all members of this type, see WebCacheCheckoutEventArgs Members.

System.Object
EventArgs
WebCacheCheckoutEventArgs

public class WebCacheCheckoutEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheCheckoutEventArgs Members | StarTeam.Events Namespace


WebCacheCheckoutEventArgs Members

WebCacheCheckoutEventArgs overview

Public Instance Properties

CheckoutManager
CheckoutResult
CheckoutRevision
CheckoutThreadIndex
CurrentBytesExpected
CurrentBytesSoFar
CurrentWorkingFile
Error
ErrorMessage
IsCanceled
IsFinished
IsMPXCacheAgentThread
IsSuccessful
Options
OriginalRevision

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


WebCacheCheckoutEventArgs Properties

The properties of the WebCacheCheckoutEventArgs class are listed below. For a complete list of WebCacheCheckoutEventArgs class members, see the WebCacheCheckoutEventArgs Members topic.

Public Instance Properties

CheckoutManager
CheckoutResult
CheckoutRevision
CheckoutThreadIndex
CurrentBytesExpected
CurrentBytesSoFar
CurrentWorkingFile
Error
ErrorMessage
IsCanceled
IsFinished
IsMPXCacheAgentThread
IsSuccessful
Options
OriginalRevision

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutManager Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.CheckoutManager Property

public virtual CheckoutManager.WebCacheCheckoutManager CheckoutManager {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutResult Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.CheckoutResult Property

public virtual File.CheckOutResult CheckoutResult {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutRevision Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.CheckoutRevision Property

public virtual File.WebCacheFile CheckoutRevision {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


CheckoutThreadIndex Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.CheckoutThreadIndex Property

public virtual Int32 CheckoutThreadIndex {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


CurrentBytesExpected Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.CurrentBytesExpected Property

public virtual Int64 CurrentBytesExpected {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


CurrentBytesSoFar Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.CurrentBytesSoFar Property

public virtual Int64 CurrentBytesSoFar {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


CurrentWorkingFile Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.CurrentWorkingFile Property

public virtual FileInfo CurrentWorkingFile {get; set;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


Error Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.Error Property

public virtual Exception Error {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


ErrorMessage Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.ErrorMessage Property

public virtual String ErrorMessage {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


IsCanceled Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.IsCanceled Property

public virtual Boolean IsCanceled {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


IsFinished Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.IsFinished Property

public virtual Boolean IsFinished {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


IsMPXCacheAgentThread Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.IsMPXCacheAgentThread Property

public virtual Boolean IsMPXCacheAgentThread {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


IsSuccessful Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.IsSuccessful Property

public virtual Boolean IsSuccessful {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


Options Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.Options Property

public virtual CheckoutOptions.WebCacheCheckoutOptions Options {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


OriginalRevision Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventArgs.OriginalRevision Property

public virtual File.WebCacheFile OriginalRevision {get;}

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


WebCacheCheckoutEventArgs Methods

The methods of the WebCacheCheckoutEventArgs class are listed below. For a complete list of WebCacheCheckoutEventArgs class members, see the WebCacheCheckoutEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


WebCacheCheckoutEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


WebCacheCheckoutEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


WebCacheCheckoutEventArgs.ToString Method

public override string ToString();

See Also

WebCacheCheckoutEventArgs Class | StarTeam.Events Namespace


WebCacheCheckoutEventSource Class

For a list of all members of this type, see WebCacheCheckoutEventSource Members.

System.Object
WebCacheCheckoutEventSource

public class WebCacheCheckoutEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheCheckoutEventSource Members | StarTeam.Events Namespace


WebCacheCheckoutEventSource Members

WebCacheCheckoutEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnNotifyProgress
OnStartFile

See Also

WebCacheCheckoutEventSource Class | StarTeam.Events Namespace


WebCacheCheckoutEventSource Properties

The properties of the WebCacheCheckoutEventSource class are listed below. For a complete list of WebCacheCheckoutEventSource class members, see the WebCacheCheckoutEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheCheckoutEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheCheckoutEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheCheckoutEventSource Class | StarTeam.Events Namespace


WebCacheCheckoutEventSource Events

The events of the WebCacheCheckoutEventSource class are listed below. For a complete list of WebCacheCheckoutEventSource class members, see the WebCacheCheckoutEventSource Members topic.

Public Instance Events

OnNotifyProgress
OnStartFile

See Also

WebCacheCheckoutEventSource Class | StarTeam.Events Namespace


WebCacheCheckoutEventSource.OnNotifyProgress Event

public event WebCacheCheckoutEventSource.Handler OnNotifyProgress;

See Also

WebCacheCheckoutEventSource Class | StarTeam.Events Namespace


WebCacheCheckoutEventSource.OnStartFile Event

public event WebCacheCheckoutEventSource.Handler OnStartFile;

See Also

WebCacheCheckoutEventSource Class | StarTeam.Events Namespace


WebCacheCheckoutEventSource.Handler Delegate

public delegate void WebCacheCheckoutEventSource.Handler(
WebCacheCheckoutEventSource source,
WebCacheCheckoutEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheFilterEventArgs Class

For a list of all members of this type, see WebCacheFilterEventArgs Members.

System.Object
EventArgs
WebCacheFilterEventArgs

public class WebCacheFilterEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheFilterEventArgs Members | StarTeam.Events Namespace


WebCacheFilterEventArgs Members

WebCacheFilterEventArgs overview

Public Instance Properties

Filter

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheFilterEventArgs Class | StarTeam.Events Namespace


WebCacheFilterEventArgs Properties

The properties of the WebCacheFilterEventArgs class are listed below. For a complete list of WebCacheFilterEventArgs class members, see the WebCacheFilterEventArgs Members topic.

Public Instance Properties

Filter

See Also

WebCacheFilterEventArgs Class | StarTeam.Events Namespace


Filter Property

Borland StarTeam SDK for .NET

WebCacheFilterEventArgs.Filter Property

public virtual Filter.WebCacheFilter Filter {get;}

See Also

WebCacheFilterEventArgs Class | StarTeam.Events Namespace


WebCacheFilterEventArgs Methods

The methods of the WebCacheFilterEventArgs class are listed below. For a complete list of WebCacheFilterEventArgs class members, see the WebCacheFilterEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheFilterEventArgs Class | StarTeam.Events Namespace


WebCacheFilterEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheFilterEventArgs Class | StarTeam.Events Namespace


WebCacheFilterEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheFilterEventArgs Class | StarTeam.Events Namespace


WebCacheFilterEventArgs.ToString Method

public override string ToString();

See Also

WebCacheFilterEventArgs Class | StarTeam.Events Namespace


WebCacheFilterEventSource Class

For a list of all members of this type, see WebCacheFilterEventSource Members.

System.Object
WebCacheFilterEventSource

public class WebCacheFilterEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheFilterEventSource Members | StarTeam.Events Namespace


WebCacheFilterEventSource Members

WebCacheFilterEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnFilterAdded
OnFilterChanged
OnFilterDeleted

See Also

WebCacheFilterEventSource Class | StarTeam.Events Namespace


WebCacheFilterEventSource Properties

The properties of the WebCacheFilterEventSource class are listed below. For a complete list of WebCacheFilterEventSource class members, see the WebCacheFilterEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheFilterEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheFilterEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheFilterEventSource Class | StarTeam.Events Namespace


WebCacheFilterEventSource Events

The events of the WebCacheFilterEventSource class are listed below. For a complete list of WebCacheFilterEventSource class members, see the WebCacheFilterEventSource Members topic.

Public Instance Events

OnFilterAdded
OnFilterChanged
OnFilterDeleted

See Also

WebCacheFilterEventSource Class | StarTeam.Events Namespace


WebCacheFilterEventSource.OnFilterAdded Event

public event WebCacheFilterEventSource.Handler OnFilterAdded;

See Also

WebCacheFilterEventSource Class | StarTeam.Events Namespace


WebCacheFilterEventSource.OnFilterChanged Event

public event WebCacheFilterEventSource.Handler OnFilterChanged;

See Also

WebCacheFilterEventSource Class | StarTeam.Events Namespace


WebCacheFilterEventSource.OnFilterDeleted Event

public event WebCacheFilterEventSource.Handler OnFilterDeleted;

See Also

WebCacheFilterEventSource Class | StarTeam.Events Namespace


WebCacheFilterEventSource.Handler Delegate

public delegate void WebCacheFilterEventSource.Handler(
WebCacheFilterEventSource source,
WebCacheFilterEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheGroupEventArgs Class

For a list of all members of this type, see WebCacheGroupEventArgs Members.

System.Object
EventArgs
WebCacheGroupEventArgs

public class WebCacheGroupEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheGroupEventArgs Members | StarTeam.Events Namespace


WebCacheGroupEventArgs Members

WebCacheGroupEventArgs overview

Public Instance Properties

Group

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheGroupEventArgs Class | StarTeam.Events Namespace


WebCacheGroupEventArgs Properties

The properties of the WebCacheGroupEventArgs class are listed below. For a complete list of WebCacheGroupEventArgs class members, see the WebCacheGroupEventArgs Members topic.

Public Instance Properties

Group

See Also

WebCacheGroupEventArgs Class | StarTeam.Events Namespace


Group Property

Borland StarTeam SDK for .NET

WebCacheGroupEventArgs.Group Property

public virtual Group.WebCacheGroup Group {get;}

See Also

WebCacheGroupEventArgs Class | StarTeam.Events Namespace


WebCacheGroupEventArgs Methods

The methods of the WebCacheGroupEventArgs class are listed below. For a complete list of WebCacheGroupEventArgs class members, see the WebCacheGroupEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheGroupEventArgs Class | StarTeam.Events Namespace


WebCacheGroupEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheGroupEventArgs Class | StarTeam.Events Namespace


WebCacheGroupEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheGroupEventArgs Class | StarTeam.Events Namespace


WebCacheGroupEventArgs.ToString Method

public override string ToString();

See Also

WebCacheGroupEventArgs Class | StarTeam.Events Namespace


WebCacheGroupEventSource Class

For a list of all members of this type, see WebCacheGroupEventSource Members.

System.Object
WebCacheGroupEventSource

public class WebCacheGroupEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheGroupEventSource Members | StarTeam.Events Namespace


WebCacheGroupEventSource Members

WebCacheGroupEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnGroupAdded
OnGroupChanged
OnGroupDeleted

See Also

WebCacheGroupEventSource Class | StarTeam.Events Namespace


WebCacheGroupEventSource Properties

The properties of the WebCacheGroupEventSource class are listed below. For a complete list of WebCacheGroupEventSource class members, see the WebCacheGroupEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheGroupEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheGroupEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheGroupEventSource Class | StarTeam.Events Namespace


WebCacheGroupEventSource Events

The events of the WebCacheGroupEventSource class are listed below. For a complete list of WebCacheGroupEventSource class members, see the WebCacheGroupEventSource Members topic.

Public Instance Events

OnGroupAdded
OnGroupChanged
OnGroupDeleted

See Also

WebCacheGroupEventSource Class | StarTeam.Events Namespace


WebCacheGroupEventSource.OnGroupAdded Event

public event WebCacheGroupEventSource.Handler OnGroupAdded;

See Also

WebCacheGroupEventSource Class | StarTeam.Events Namespace


WebCacheGroupEventSource.OnGroupChanged Event

public event WebCacheGroupEventSource.Handler OnGroupChanged;

See Also

WebCacheGroupEventSource Class | StarTeam.Events Namespace


WebCacheGroupEventSource.OnGroupDeleted Event

public event WebCacheGroupEventSource.Handler OnGroupDeleted;

See Also

WebCacheGroupEventSource Class | StarTeam.Events Namespace


WebCacheGroupEventSource.Handler Delegate

public delegate void WebCacheGroupEventSource.Handler(
WebCacheGroupEventSource source,
WebCacheGroupEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheLabelEventArgs Class

For a list of all members of this type, see WebCacheLabelEventArgs Members.

System.Object
EventArgs
WebCacheLabelEventArgs

public class WebCacheLabelEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheLabelEventArgs Members | StarTeam.Events Namespace


WebCacheLabelEventArgs Members

WebCacheLabelEventArgs overview

Public Instance Properties

Label

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheLabelEventArgs Class | StarTeam.Events Namespace


WebCacheLabelEventArgs Properties

The properties of the WebCacheLabelEventArgs class are listed below. For a complete list of WebCacheLabelEventArgs class members, see the WebCacheLabelEventArgs Members topic.

Public Instance Properties

Label

See Also

WebCacheLabelEventArgs Class | StarTeam.Events Namespace


Label Property

Borland StarTeam SDK for .NET

WebCacheLabelEventArgs.Label Property

public virtual Label.WebCacheLabel Label {get;}

See Also

WebCacheLabelEventArgs Class | StarTeam.Events Namespace


WebCacheLabelEventArgs Methods

The methods of the WebCacheLabelEventArgs class are listed below. For a complete list of WebCacheLabelEventArgs class members, see the WebCacheLabelEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheLabelEventArgs Class | StarTeam.Events Namespace


WebCacheLabelEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheLabelEventArgs Class | StarTeam.Events Namespace


WebCacheLabelEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheLabelEventArgs Class | StarTeam.Events Namespace


WebCacheLabelEventArgs.ToString Method

public override string ToString();

See Also

WebCacheLabelEventArgs Class | StarTeam.Events Namespace


WebCacheLabelEventSource Class

For a list of all members of this type, see WebCacheLabelEventSource Members.

System.Object
WebCacheLabelEventSource

public class WebCacheLabelEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheLabelEventSource Members | StarTeam.Events Namespace


WebCacheLabelEventSource Members

WebCacheLabelEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnLabelAdded
OnLabelChanged
OnLabelDeleted

See Also

WebCacheLabelEventSource Class | StarTeam.Events Namespace


WebCacheLabelEventSource Properties

The properties of the WebCacheLabelEventSource class are listed below. For a complete list of WebCacheLabelEventSource class members, see the WebCacheLabelEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheLabelEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheLabelEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheLabelEventSource Class | StarTeam.Events Namespace


WebCacheLabelEventSource Events

The events of the WebCacheLabelEventSource class are listed below. For a complete list of WebCacheLabelEventSource class members, see the WebCacheLabelEventSource Members topic.

Public Instance Events

OnLabelAdded
OnLabelChanged
OnLabelDeleted

See Also

WebCacheLabelEventSource Class | StarTeam.Events Namespace


WebCacheLabelEventSource.OnLabelAdded Event

public event WebCacheLabelEventSource.Handler OnLabelAdded;

See Also

WebCacheLabelEventSource Class | StarTeam.Events Namespace


WebCacheLabelEventSource.OnLabelChanged Event

public event WebCacheLabelEventSource.Handler OnLabelChanged;

See Also

WebCacheLabelEventSource Class | StarTeam.Events Namespace


WebCacheLabelEventSource.OnLabelDeleted Event

public event WebCacheLabelEventSource.Handler OnLabelDeleted;

See Also

WebCacheLabelEventSource Class | StarTeam.Events Namespace


WebCacheLabelEventSource.Handler Delegate

public delegate void WebCacheLabelEventSource.Handler(
WebCacheLabelEventSource source,
WebCacheLabelEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheLiveObjectEventArgs Class

For a list of all members of this type, see WebCacheLiveObjectEventArgs Members.

System.Object
EventArgs
WebCacheLiveObjectEventArgs

public class WebCacheLiveObjectEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheLiveObjectEventArgs Members | StarTeam.Events Namespace


WebCacheLiveObjectEventArgs Members

WebCacheLiveObjectEventArgs overview

Public Instance Properties

ContainedType
ContainerItemID
LiveObject
Type

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


WebCacheLiveObjectEventArgs Properties

The properties of the WebCacheLiveObjectEventArgs class are listed below. For a complete list of WebCacheLiveObjectEventArgs class members, see the WebCacheLiveObjectEventArgs Members topic.

Public Instance Properties

ContainedType
ContainerItemID
LiveObject
Type

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


ContainedType Property

Borland StarTeam SDK for .NET

WebCacheLiveObjectEventArgs.ContainedType Property

public virtual Type.WebCacheType ContainedType {get;}

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


ContainerItemID Property

Borland StarTeam SDK for .NET

WebCacheLiveObjectEventArgs.ContainerItemID Property

public virtual Int32 ContainerItemID {get;}

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


LiveObject Property

Borland StarTeam SDK for .NET

WebCacheLiveObjectEventArgs.LiveObject Property

public virtual LiveObject.WebCacheLiveObject LiveObject {get;}

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


Type Property

Borland StarTeam SDK for .NET

WebCacheLiveObjectEventArgs.Type Property

public virtual Type.WebCacheType Type {get;}

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


WebCacheLiveObjectEventArgs Methods

The methods of the WebCacheLiveObjectEventArgs class are listed below. For a complete list of WebCacheLiveObjectEventArgs class members, see the WebCacheLiveObjectEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


WebCacheLiveObjectEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


WebCacheLiveObjectEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


WebCacheLiveObjectEventArgs.ToString Method

public override string ToString();

See Also

WebCacheLiveObjectEventArgs Class | StarTeam.Events Namespace


WebCacheLiveObjectEventSource Class

For a list of all members of this type, see WebCacheLiveObjectEventSource Members.

System.Object
WebCacheLiveObjectEventSource

public class WebCacheLiveObjectEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheLiveObjectEventSource Members | StarTeam.Events Namespace


WebCacheLiveObjectEventSource Members

WebCacheLiveObjectEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnContainerChanged
OnLiveObjectAdded
OnLiveObjectChanged
OnLiveObjectRemoved

See Also

WebCacheLiveObjectEventSource Class | StarTeam.Events Namespace


WebCacheLiveObjectEventSource Properties

The properties of the WebCacheLiveObjectEventSource class are listed below. For a complete list of WebCacheLiveObjectEventSource class members, see the WebCacheLiveObjectEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheLiveObjectEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheLiveObjectEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheLiveObjectEventSource Class | StarTeam.Events Namespace


WebCacheLiveObjectEventSource Events

The events of the WebCacheLiveObjectEventSource class are listed below. For a complete list of WebCacheLiveObjectEventSource class members, see the WebCacheLiveObjectEventSource Members topic.

Public Instance Events

OnContainerChanged
OnLiveObjectAdded
OnLiveObjectChanged
OnLiveObjectRemoved

See Also

WebCacheLiveObjectEventSource Class | StarTeam.Events Namespace


WebCacheLiveObjectEventSource.OnContainerChanged Event

public event WebCacheLiveObjectEventSource.Handler OnContainerChanged;

See Also

WebCacheLiveObjectEventSource Class | StarTeam.Events Namespace


WebCacheLiveObjectEventSource.OnLiveObjectAdded Event

public event WebCacheLiveObjectEventSource.Handler OnLiveObjectAdded;

See Also

WebCacheLiveObjectEventSource Class | StarTeam.Events Namespace


WebCacheLiveObjectEventSource.OnLiveObjectChanged Event

public event WebCacheLiveObjectEventSource.Handler OnLiveObjectChanged;

See Also

WebCacheLiveObjectEventSource Class | StarTeam.Events Namespace


WebCacheLiveObjectEventSource.OnLiveObjectRemoved Event

public event WebCacheLiveObjectEventSource.Handler OnLiveObjectRemoved;

See Also

WebCacheLiveObjectEventSource Class | StarTeam.Events Namespace


WebCacheLiveObjectEventSource.Handler Delegate

public delegate void WebCacheLiveObjectEventSource.Handler(
WebCacheLiveObjectEventSource source,
WebCacheLiveObjectEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheMPXStatusEventArgs Class

For a list of all members of this type, see WebCacheMPXStatusEventArgs Members.

System.Object
EventArgs
WebCacheMPXStatusEventArgs

public class WebCacheMPXStatusEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheMPXStatusEventArgs Members | StarTeam.Events Namespace


WebCacheMPXStatusEventArgs Members

WebCacheMPXStatusEventArgs overview

Public Instance Properties

Exception
Server

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheMPXStatusEventArgs Class | StarTeam.Events Namespace


WebCacheMPXStatusEventArgs Properties

The properties of the WebCacheMPXStatusEventArgs class are listed below. For a complete list of WebCacheMPXStatusEventArgs class members, see the WebCacheMPXStatusEventArgs Members topic.

Public Instance Properties

Exception
Server

See Also

WebCacheMPXStatusEventArgs Class | StarTeam.Events Namespace


Exception Property

Borland StarTeam SDK for .NET

WebCacheMPXStatusEventArgs.Exception Property

public virtual MPXException Exception {get;}

See Also

WebCacheMPXStatusEventArgs Class | StarTeam.Events Namespace


Server Property

Borland StarTeam SDK for .NET

WebCacheMPXStatusEventArgs.Server Property

public virtual Server.WebCacheServer Server {get;}

See Also

WebCacheMPXStatusEventArgs Class | StarTeam.Events Namespace


WebCacheMPXStatusEventArgs Methods

The methods of the WebCacheMPXStatusEventArgs class are listed below. For a complete list of WebCacheMPXStatusEventArgs class members, see the WebCacheMPXStatusEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheMPXStatusEventArgs Class | StarTeam.Events Namespace


WebCacheMPXStatusEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheMPXStatusEventArgs Class | StarTeam.Events Namespace


WebCacheMPXStatusEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheMPXStatusEventArgs Class | StarTeam.Events Namespace


WebCacheMPXStatusEventArgs.ToString Method

public override string ToString();

See Also

WebCacheMPXStatusEventArgs Class | StarTeam.Events Namespace


WebCacheMPXStatusEventSource Class

For a list of all members of this type, see WebCacheMPXStatusEventSource Members.

System.Object
WebCacheMPXStatusEventSource

public class WebCacheMPXStatusEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheMPXStatusEventSource Members | StarTeam.Events Namespace


WebCacheMPXStatusEventSource Members

WebCacheMPXStatusEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnDisabled
OnEnabled
OnException
OnOffline
OnOnline

See Also

WebCacheMPXStatusEventSource Class | StarTeam.Events Namespace


WebCacheMPXStatusEventSource Properties

The properties of the WebCacheMPXStatusEventSource class are listed below. For a complete list of WebCacheMPXStatusEventSource class members, see the WebCacheMPXStatusEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheMPXStatusEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheMPXStatusEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheMPXStatusEventSource Class | StarTeam.Events Namespace


WebCacheMPXStatusEventSource Events

The events of the WebCacheMPXStatusEventSource class are listed below. For a complete list of WebCacheMPXStatusEventSource class members, see the WebCacheMPXStatusEventSource Members topic.

Public Instance Events

OnDisabled
OnEnabled
OnException
OnOffline
OnOnline

See Also

WebCacheMPXStatusEventSource Class | StarTeam.Events Namespace


WebCacheMPXStatusEventSource.OnDisabled Event

public event WebCacheMPXStatusEventSource.Handler OnDisabled;

See Also

WebCacheMPXStatusEventSource Class | StarTeam.Events Namespace


WebCacheMPXStatusEventSource.OnEnabled Event

public event WebCacheMPXStatusEventSource.Handler OnEnabled;

See Also

WebCacheMPXStatusEventSource Class | StarTeam.Events Namespace


WebCacheMPXStatusEventSource.OnException Event

public event WebCacheMPXStatusEventSource.Handler OnException;

See Also

WebCacheMPXStatusEventSource Class | StarTeam.Events Namespace


WebCacheMPXStatusEventSource.OnOffline Event

public event WebCacheMPXStatusEventSource.Handler OnOffline;

See Also

WebCacheMPXStatusEventSource Class | StarTeam.Events Namespace


WebCacheMPXStatusEventSource.OnOnline Event

public event WebCacheMPXStatusEventSource.Handler OnOnline;

See Also

WebCacheMPXStatusEventSource Class | StarTeam.Events Namespace


WebCacheMPXStatusEventSource.Handler Delegate

public delegate void WebCacheMPXStatusEventSource.Handler(
WebCacheMPXStatusEventSource source,
WebCacheMPXStatusEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheProjectEventArgs Class

For a list of all members of this type, see WebCacheProjectEventArgs Members.

System.Object
EventArgs
WebCacheProjectEventArgs

public class WebCacheProjectEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheProjectEventArgs Members | StarTeam.Events Namespace


WebCacheProjectEventArgs Members

WebCacheProjectEventArgs overview

Public Instance Properties

Project

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheProjectEventArgs Class | StarTeam.Events Namespace


WebCacheProjectEventArgs Properties

The properties of the WebCacheProjectEventArgs class are listed below. For a complete list of WebCacheProjectEventArgs class members, see the WebCacheProjectEventArgs Members topic.

Public Instance Properties

Project

See Also

WebCacheProjectEventArgs Class | StarTeam.Events Namespace


Project Property

Borland StarTeam SDK for .NET

WebCacheProjectEventArgs.Project Property

public virtual Project.WebCacheProject Project {get;}

See Also

WebCacheProjectEventArgs Class | StarTeam.Events Namespace


WebCacheProjectEventArgs Methods

The methods of the WebCacheProjectEventArgs class are listed below. For a complete list of WebCacheProjectEventArgs class members, see the WebCacheProjectEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheProjectEventArgs Class | StarTeam.Events Namespace


WebCacheProjectEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheProjectEventArgs Class | StarTeam.Events Namespace


WebCacheProjectEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheProjectEventArgs Class | StarTeam.Events Namespace


WebCacheProjectEventArgs.ToString Method

public override string ToString();

See Also

WebCacheProjectEventArgs Class | StarTeam.Events Namespace


WebCacheProjectEventSource Class

For a list of all members of this type, see WebCacheProjectEventSource Members.

System.Object
WebCacheProjectEventSource

public class WebCacheProjectEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheProjectEventSource Members | StarTeam.Events Namespace


WebCacheProjectEventSource Members

WebCacheProjectEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnProjectAdded
OnProjectChanged
OnProjectDeleted

See Also

WebCacheProjectEventSource Class | StarTeam.Events Namespace


WebCacheProjectEventSource Properties

The properties of the WebCacheProjectEventSource class are listed below. For a complete list of WebCacheProjectEventSource class members, see the WebCacheProjectEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheProjectEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheProjectEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheProjectEventSource Class | StarTeam.Events Namespace


WebCacheProjectEventSource Events

The events of the WebCacheProjectEventSource class are listed below. For a complete list of WebCacheProjectEventSource class members, see the WebCacheProjectEventSource Members topic.

Public Instance Events

OnProjectAdded
OnProjectChanged
OnProjectDeleted

See Also

WebCacheProjectEventSource Class | StarTeam.Events Namespace


WebCacheProjectEventSource.OnProjectAdded Event

public event WebCacheProjectEventSource.Handler OnProjectAdded;

See Also

WebCacheProjectEventSource Class | StarTeam.Events Namespace


WebCacheProjectEventSource.OnProjectChanged Event

public event WebCacheProjectEventSource.Handler OnProjectChanged;

See Also

WebCacheProjectEventSource Class | StarTeam.Events Namespace


WebCacheProjectEventSource.OnProjectDeleted Event

public event WebCacheProjectEventSource.Handler OnProjectDeleted;

See Also

WebCacheProjectEventSource Class | StarTeam.Events Namespace


WebCacheProjectEventSource.Handler Delegate

public delegate void WebCacheProjectEventSource.Handler(
WebCacheProjectEventSource source,
WebCacheProjectEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheQueryEventArgs Class

For a list of all members of this type, see WebCacheQueryEventArgs Members.

System.Object
EventArgs
WebCacheQueryEventArgs

public class WebCacheQueryEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheQueryEventArgs Members | StarTeam.Events Namespace


WebCacheQueryEventArgs Members

WebCacheQueryEventArgs overview

Public Instance Properties

Query

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheQueryEventArgs Class | StarTeam.Events Namespace


WebCacheQueryEventArgs Properties

The properties of the WebCacheQueryEventArgs class are listed below. For a complete list of WebCacheQueryEventArgs class members, see the WebCacheQueryEventArgs Members topic.

Public Instance Properties

Query

See Also

WebCacheQueryEventArgs Class | StarTeam.Events Namespace


Query Property

Borland StarTeam SDK for .NET

WebCacheQueryEventArgs.Query Property

public virtual Query.WebCacheQuery Query {get;}

See Also

WebCacheQueryEventArgs Class | StarTeam.Events Namespace


WebCacheQueryEventArgs Methods

The methods of the WebCacheQueryEventArgs class are listed below. For a complete list of WebCacheQueryEventArgs class members, see the WebCacheQueryEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheQueryEventArgs Class | StarTeam.Events Namespace


WebCacheQueryEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheQueryEventArgs Class | StarTeam.Events Namespace


WebCacheQueryEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheQueryEventArgs Class | StarTeam.Events Namespace


WebCacheQueryEventArgs.ToString Method

public override string ToString();

See Also

WebCacheQueryEventArgs Class | StarTeam.Events Namespace


WebCacheQueryEventSource Class

For a list of all members of this type, see WebCacheQueryEventSource Members.

System.Object
WebCacheQueryEventSource

public class WebCacheQueryEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheQueryEventSource Members | StarTeam.Events Namespace


WebCacheQueryEventSource Members

WebCacheQueryEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnQueryAdded
OnQueryChanged
OnQueryDeleted

See Also

WebCacheQueryEventSource Class | StarTeam.Events Namespace


WebCacheQueryEventSource Properties

The properties of the WebCacheQueryEventSource class are listed below. For a complete list of WebCacheQueryEventSource class members, see the WebCacheQueryEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheQueryEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheQueryEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheQueryEventSource Class | StarTeam.Events Namespace


WebCacheQueryEventSource Events

The events of the WebCacheQueryEventSource class are listed below. For a complete list of WebCacheQueryEventSource class members, see the WebCacheQueryEventSource Members topic.

Public Instance Events

OnQueryAdded
OnQueryChanged
OnQueryDeleted

See Also

WebCacheQueryEventSource Class | StarTeam.Events Namespace


WebCacheQueryEventSource.OnQueryAdded Event

public event WebCacheQueryEventSource.Handler OnQueryAdded;

See Also

WebCacheQueryEventSource Class | StarTeam.Events Namespace


WebCacheQueryEventSource.OnQueryChanged Event

public event WebCacheQueryEventSource.Handler OnQueryChanged;

See Also

WebCacheQueryEventSource Class | StarTeam.Events Namespace


WebCacheQueryEventSource.OnQueryDeleted Event

public event WebCacheQueryEventSource.Handler OnQueryDeleted;

See Also

WebCacheQueryEventSource Class | StarTeam.Events Namespace


WebCacheQueryEventSource.Handler Delegate

public delegate void WebCacheQueryEventSource.Handler(
WebCacheQueryEventSource source,
WebCacheQueryEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheServerControlEventArgs Class

For a list of all members of this type, see WebCacheServerControlEventArgs Members.

System.Object
EventArgs
WebCacheServerControlEventArgs

public class WebCacheServerControlEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheServerControlEventArgs Members | StarTeam.Events Namespace


WebCacheServerControlEventArgs Members

WebCacheServerControlEventArgs overview

Public Instance Properties

Server

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheServerControlEventArgs Class | StarTeam.Events Namespace


WebCacheServerControlEventArgs Properties

The properties of the WebCacheServerControlEventArgs class are listed below. For a complete list of WebCacheServerControlEventArgs class members, see the WebCacheServerControlEventArgs Members topic.

Public Instance Properties

Server

See Also

WebCacheServerControlEventArgs Class | StarTeam.Events Namespace


Server Property

Borland StarTeam SDK for .NET

WebCacheServerControlEventArgs.Server Property

public virtual Server.WebCacheServer Server {get;}

See Also

WebCacheServerControlEventArgs Class | StarTeam.Events Namespace


WebCacheServerControlEventArgs Methods

The methods of the WebCacheServerControlEventArgs class are listed below. For a complete list of WebCacheServerControlEventArgs class members, see the WebCacheServerControlEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheServerControlEventArgs Class | StarTeam.Events Namespace


WebCacheServerControlEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheServerControlEventArgs Class | StarTeam.Events Namespace


WebCacheServerControlEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheServerControlEventArgs Class | StarTeam.Events Namespace


WebCacheServerControlEventArgs.ToString Method

public override string ToString();

See Also

WebCacheServerControlEventArgs Class | StarTeam.Events Namespace


WebCacheServerControlEventSource Class

For a list of all members of this type, see WebCacheServerControlEventSource Members.

System.Object
WebCacheServerControlEventSource

public class WebCacheServerControlEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheServerControlEventSource Members | StarTeam.Events Namespace


WebCacheServerControlEventSource Members

WebCacheServerControlEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnServerStarted
OnServerStopped

See Also

WebCacheServerControlEventSource Class | StarTeam.Events Namespace


WebCacheServerControlEventSource Properties

The properties of the WebCacheServerControlEventSource class are listed below. For a complete list of WebCacheServerControlEventSource class members, see the WebCacheServerControlEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheServerControlEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheServerControlEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheServerControlEventSource Class | StarTeam.Events Namespace


WebCacheServerControlEventSource Events

The events of the WebCacheServerControlEventSource class are listed below. For a complete list of WebCacheServerControlEventSource class members, see the WebCacheServerControlEventSource Members topic.

Public Instance Events

OnServerStarted
OnServerStopped

See Also

WebCacheServerControlEventSource Class | StarTeam.Events Namespace


WebCacheServerControlEventSource.OnServerStarted Event

public event WebCacheServerControlEventSource.Handler OnServerStarted;

See Also

WebCacheServerControlEventSource Class | StarTeam.Events Namespace


WebCacheServerControlEventSource.OnServerStopped Event

public event WebCacheServerControlEventSource.Handler OnServerStopped;

See Also

WebCacheServerControlEventSource Class | StarTeam.Events Namespace


WebCacheServerControlEventSource.Handler Delegate

public delegate void WebCacheServerControlEventSource.Handler(
WebCacheServerControlEventSource source,
WebCacheServerControlEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheTypeEventArgs Class

For a list of all members of this type, see WebCacheTypeEventArgs Members.

System.Object
EventArgs
WebCacheTypeEventArgs

public class WebCacheTypeEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheTypeEventArgs Members | StarTeam.Events Namespace


WebCacheTypeEventArgs Members

WebCacheTypeEventArgs overview

Public Instance Properties

Type

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheTypeEventArgs Class | StarTeam.Events Namespace


WebCacheTypeEventArgs Properties

The properties of the WebCacheTypeEventArgs class are listed below. For a complete list of WebCacheTypeEventArgs class members, see the WebCacheTypeEventArgs Members topic.

Public Instance Properties

Type

See Also

WebCacheTypeEventArgs Class | StarTeam.Events Namespace


Type Property

Borland StarTeam SDK for .NET

WebCacheTypeEventArgs.Type Property

public virtual Type.WebCacheType Type {get;}

See Also

WebCacheTypeEventArgs Class | StarTeam.Events Namespace


WebCacheTypeEventArgs Methods

The methods of the WebCacheTypeEventArgs class are listed below. For a complete list of WebCacheTypeEventArgs class members, see the WebCacheTypeEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheTypeEventArgs Class | StarTeam.Events Namespace


WebCacheTypeEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheTypeEventArgs Class | StarTeam.Events Namespace


WebCacheTypeEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheTypeEventArgs Class | StarTeam.Events Namespace


WebCacheTypeEventArgs.ToString Method

public override string ToString();

See Also

WebCacheTypeEventArgs Class | StarTeam.Events Namespace


WebCacheTypeEventSource Class

For a list of all members of this type, see WebCacheTypeEventSource Members.

System.Object
WebCacheTypeEventSource

public class WebCacheTypeEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheTypeEventSource Members | StarTeam.Events Namespace


WebCacheTypeEventSource Members

WebCacheTypeEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnTypeAdded
OnTypeChanged

See Also

WebCacheTypeEventSource Class | StarTeam.Events Namespace


WebCacheTypeEventSource Properties

The properties of the WebCacheTypeEventSource class are listed below. For a complete list of WebCacheTypeEventSource class members, see the WebCacheTypeEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheTypeEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheTypeEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheTypeEventSource Class | StarTeam.Events Namespace


WebCacheTypeEventSource Events

The events of the WebCacheTypeEventSource class are listed below. For a complete list of WebCacheTypeEventSource class members, see the WebCacheTypeEventSource Members topic.

Public Instance Events

OnTypeAdded
OnTypeChanged

See Also

WebCacheTypeEventSource Class | StarTeam.Events Namespace


WebCacheTypeEventSource.OnTypeAdded Event

public event WebCacheTypeEventSource.Handler OnTypeAdded;

See Also

WebCacheTypeEventSource Class | StarTeam.Events Namespace


WebCacheTypeEventSource.OnTypeChanged Event

public event WebCacheTypeEventSource.Handler OnTypeChanged;

See Also

WebCacheTypeEventSource Class | StarTeam.Events Namespace


WebCacheTypeEventSource.Handler Delegate

public delegate void WebCacheTypeEventSource.Handler(
WebCacheTypeEventSource source,
WebCacheTypeEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheUserEventArgs Class

For a list of all members of this type, see WebCacheUserEventArgs Members.

System.Object
EventArgs
WebCacheUserEventArgs

public class WebCacheUserEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheUserEventArgs Members | StarTeam.Events Namespace


WebCacheUserEventArgs Members

WebCacheUserEventArgs overview

Public Instance Properties

User

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheUserEventArgs Class | StarTeam.Events Namespace


WebCacheUserEventArgs Properties

The properties of the WebCacheUserEventArgs class are listed below. For a complete list of WebCacheUserEventArgs class members, see the WebCacheUserEventArgs Members topic.

Public Instance Properties

User

See Also

WebCacheUserEventArgs Class | StarTeam.Events Namespace


User Property

Borland StarTeam SDK for .NET

WebCacheUserEventArgs.User Property

public virtual User.WebCacheUser User {get;}

See Also

WebCacheUserEventArgs Class | StarTeam.Events Namespace


WebCacheUserEventArgs Methods

The methods of the WebCacheUserEventArgs class are listed below. For a complete list of WebCacheUserEventArgs class members, see the WebCacheUserEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheUserEventArgs Class | StarTeam.Events Namespace


WebCacheUserEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheUserEventArgs Class | StarTeam.Events Namespace


WebCacheUserEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheUserEventArgs Class | StarTeam.Events Namespace


WebCacheUserEventArgs.ToString Method

public override string ToString();

See Also

WebCacheUserEventArgs Class | StarTeam.Events Namespace


WebCacheUserEventSource Class

For a list of all members of this type, see WebCacheUserEventSource Members.

System.Object
WebCacheUserEventSource

public class WebCacheUserEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheUserEventSource Members | StarTeam.Events Namespace


WebCacheUserEventSource Members

WebCacheUserEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnUserAdded
OnUserChanged
OnUserDeleted

See Also

WebCacheUserEventSource Class | StarTeam.Events Namespace


WebCacheUserEventSource Properties

The properties of the WebCacheUserEventSource class are listed below. For a complete list of WebCacheUserEventSource class members, see the WebCacheUserEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheUserEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheUserEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheUserEventSource Class | StarTeam.Events Namespace


WebCacheUserEventSource Events

The events of the WebCacheUserEventSource class are listed below. For a complete list of WebCacheUserEventSource class members, see the WebCacheUserEventSource Members topic.

Public Instance Events

OnUserAdded
OnUserChanged
OnUserDeleted

See Also

WebCacheUserEventSource Class | StarTeam.Events Namespace


WebCacheUserEventSource.OnUserAdded Event

public event WebCacheUserEventSource.Handler OnUserAdded;

See Also

WebCacheUserEventSource Class | StarTeam.Events Namespace


WebCacheUserEventSource.OnUserChanged Event

public event WebCacheUserEventSource.Handler OnUserChanged;

See Also

WebCacheUserEventSource Class | StarTeam.Events Namespace


WebCacheUserEventSource.OnUserDeleted Event

public event WebCacheUserEventSource.Handler OnUserDeleted;

See Also

WebCacheUserEventSource Class | StarTeam.Events Namespace


WebCacheUserEventSource.Handler Delegate

public delegate void WebCacheUserEventSource.Handler(
WebCacheUserEventSource source,
WebCacheUserEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheViewEventArgs Class

For a list of all members of this type, see WebCacheViewEventArgs Members.

System.Object
EventArgs
WebCacheViewEventArgs

public class WebCacheViewEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheViewEventArgs Members | StarTeam.Events Namespace


WebCacheViewEventArgs Members

WebCacheViewEventArgs overview

Public Instance Properties

View

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheViewEventArgs Class | StarTeam.Events Namespace


WebCacheViewEventArgs Properties

The properties of the WebCacheViewEventArgs class are listed below. For a complete list of WebCacheViewEventArgs class members, see the WebCacheViewEventArgs Members topic.

Public Instance Properties

View

See Also

WebCacheViewEventArgs Class | StarTeam.Events Namespace


View Property

Borland StarTeam SDK for .NET

WebCacheViewEventArgs.View Property

public virtual View.WebCacheView View {get;}

See Also

WebCacheViewEventArgs Class | StarTeam.Events Namespace


WebCacheViewEventArgs Methods

The methods of the WebCacheViewEventArgs class are listed below. For a complete list of WebCacheViewEventArgs class members, see the WebCacheViewEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheViewEventArgs Class | StarTeam.Events Namespace


WebCacheViewEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheViewEventArgs Class | StarTeam.Events Namespace


WebCacheViewEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheViewEventArgs Class | StarTeam.Events Namespace


WebCacheViewEventArgs.ToString Method

public override string ToString();

See Also

WebCacheViewEventArgs Class | StarTeam.Events Namespace


WebCacheViewEventSource Class

For a list of all members of this type, see WebCacheViewEventSource Members.

System.Object
WebCacheViewEventSource

public class WebCacheViewEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheViewEventSource Members | StarTeam.Events Namespace


WebCacheViewEventSource Members

WebCacheViewEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnViewAdded
OnViewChanged
OnViewDeleted

See Also

WebCacheViewEventSource Class | StarTeam.Events Namespace


WebCacheViewEventSource Properties

The properties of the WebCacheViewEventSource class are listed below. For a complete list of WebCacheViewEventSource class members, see the WebCacheViewEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheViewEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheViewEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheViewEventSource Class | StarTeam.Events Namespace


WebCacheViewEventSource Events

The events of the WebCacheViewEventSource class are listed below. For a complete list of WebCacheViewEventSource class members, see the WebCacheViewEventSource Members topic.

Public Instance Events

OnViewAdded
OnViewChanged
OnViewDeleted

See Also

WebCacheViewEventSource Class | StarTeam.Events Namespace


WebCacheViewEventSource.OnViewAdded Event

public event WebCacheViewEventSource.Handler OnViewAdded;

See Also

WebCacheViewEventSource Class | StarTeam.Events Namespace


WebCacheViewEventSource.OnViewChanged Event

public event WebCacheViewEventSource.Handler OnViewChanged;

See Also

WebCacheViewEventSource Class | StarTeam.Events Namespace


WebCacheViewEventSource.OnViewDeleted Event

public event WebCacheViewEventSource.Handler OnViewDeleted;

See Also

WebCacheViewEventSource Class | StarTeam.Events Namespace


WebCacheViewEventSource.Handler Delegate

public delegate void WebCacheViewEventSource.Handler(
WebCacheViewEventSource source,
WebCacheViewEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


WebCacheViewMemberEventArgs Class

For a list of all members of this type, see WebCacheViewMemberEventArgs Members.

System.Object
EventArgs
WebCacheViewMemberEventArgs

public class WebCacheViewMemberEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheViewMemberEventArgs Members | StarTeam.Events Namespace


WebCacheViewMemberEventArgs Members

WebCacheViewMemberEventArgs overview

Public Instance Properties

ViewMember

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheViewMemberEventArgs Class | StarTeam.Events Namespace


WebCacheViewMemberEventArgs Properties

The properties of the WebCacheViewMemberEventArgs class are listed below. For a complete list of WebCacheViewMemberEventArgs class members, see the WebCacheViewMemberEventArgs Members topic.

Public Instance Properties

ViewMember

See Also

WebCacheViewMemberEventArgs Class | StarTeam.Events Namespace


ViewMember Property

Borland StarTeam SDK for .NET

WebCacheViewMemberEventArgs.ViewMember Property

public virtual ViewMember.WebCacheViewMember ViewMember {get;}

See Also

WebCacheViewMemberEventArgs Class | StarTeam.Events Namespace


WebCacheViewMemberEventArgs Methods

The methods of the WebCacheViewMemberEventArgs class are listed below. For a complete list of WebCacheViewMemberEventArgs class members, see the WebCacheViewMemberEventArgs Members topic.

Public Instance Methods

Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

See Also

WebCacheViewMemberEventArgs Class | StarTeam.Events Namespace


WebCacheViewMemberEventArgs.Equals Method

public override bool Equals(
Object obj
);

See Also

WebCacheViewMemberEventArgs Class | StarTeam.Events Namespace


WebCacheViewMemberEventArgs.GetHashCode Method

public override int GetHashCode();

See Also

WebCacheViewMemberEventArgs Class | StarTeam.Events Namespace


WebCacheViewMemberEventArgs.ToString Method

public override string ToString();

See Also

WebCacheViewMemberEventArgs Class | StarTeam.Events Namespace


WebCacheViewMemberEventSource Class

For a list of all members of this type, see WebCacheViewMemberEventSource Members.

System.Object
WebCacheViewMemberEventSource

public class WebCacheViewMemberEventSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

WebCacheViewMemberEventSource Members | StarTeam.Events Namespace


WebCacheViewMemberEventSource Members

WebCacheViewMemberEventSource overview

Public Instance Properties

Parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnViewMemberAdded
OnViewMemberChanged
OnViewMemberMoved
OnViewMemberRemoved

See Also

WebCacheViewMemberEventSource Class | StarTeam.Events Namespace


WebCacheViewMemberEventSource Properties

The properties of the WebCacheViewMemberEventSource class are listed below. For a complete list of WebCacheViewMemberEventSource class members, see the WebCacheViewMemberEventSource Members topic.

Public Instance Properties

Parent

See Also

WebCacheViewMemberEventSource Class | StarTeam.Events Namespace


Parent Property

Borland StarTeam SDK for .NET

WebCacheViewMemberEventSource.Parent Property

public Object Parent {get;}

See Also

WebCacheViewMemberEventSource Class | StarTeam.Events Namespace


WebCacheViewMemberEventSource Events

The events of the WebCacheViewMemberEventSource class are listed below. For a complete list of WebCacheViewMemberEventSource class members, see the WebCacheViewMemberEventSource Members topic.

Public Instance Events

OnViewMemberAdded
OnViewMemberChanged
OnViewMemberMoved
OnViewMemberRemoved

See Also

WebCacheViewMemberEventSource Class | StarTeam.Events Namespace


WebCacheViewMemberEventSource.OnViewMemberAdded Event

public event WebCacheViewMemberEventSource.Handler OnViewMemberAdded;

See Also

WebCacheViewMemberEventSource Class | StarTeam.Events Namespace


WebCacheViewMemberEventSource.OnViewMemberChanged Event

public event WebCacheViewMemberEventSource.Handler OnViewMemberChanged;

See Also

WebCacheViewMemberEventSource Class | StarTeam.Events Namespace


WebCacheViewMemberEventSource.OnViewMemberMoved Event

public event WebCacheViewMemberEventSource.Handler OnViewMemberMoved;

See Also

WebCacheViewMemberEventSource Class | StarTeam.Events Namespace


WebCacheViewMemberEventSource.OnViewMemberRemoved Event

public event WebCacheViewMemberEventSource.Handler OnViewMemberRemoved;

See Also

WebCacheViewMemberEventSource Class | StarTeam.Events Namespace


WebCacheViewMemberEventSource.Handler Delegate

public delegate void WebCacheViewMemberEventSource.Handler(
WebCacheViewMemberEventSource source,
WebCacheViewMemberEventArgs e
);

Requirements

Namespace: StarTeam.Events

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeam.Events Namespace


StarTeam.Exceptions

Borland StarTeam SDK for .NET

StarTeam.Exceptions Namespace

Namespace hierarchy

Classes

Class | Description
CommandAbortedException |
CommandException |
ConnectionException |
DisembodiedException |
DuplicateServerListEntryException |
FileMergeException |
ItemNotFoundException |
ItemRevisionNotFoundException |
LockingException |
LogonException |
MPXException |
MPXException.ErrorCode | A Collection of MPX Error Codes
NoSuchPropertyException |
PasswordExpiredException |
PropertyMergeException |
PropertyNotWritableException |
SDKRuntimeException |
ServerException |
ServerUnavailableException |
TypeNotFoundException |
WorkStationException |


CommandAbortedException Class

For a list of all members of this type, see CommandAbortedException Members.

System.Object
Exception
ServerException
CommandAbortedException

public class CommandAbortedException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

CommandAbortedException Members | StarTeam.Exceptions Namespace


CommandAbortedException Members

CommandAbortedException overview

Public Instance Constructors

CommandAbortedException Constructor

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Server (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starteam.exceptions.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starteam.exceptions.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starteam.exceptions.ServerException.

See Also

CommandAbortedException Class | StarTeam.Exceptions Namespace


CommandAbortedException Constructor

public CommandAbortedException(
String sErrorMessage
);

See Also

CommandAbortedException Class | StarTeam.Exceptions Namespace


CommandException Class

For a list of all members of this type, see CommandException Members.

System.Object
Exception
CommandException
ConnectionException

public class CommandException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

CommandException Members | StarTeam.Exceptions Namespace


CommandException Members

CommandException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IOException |
Message (inherited from Exception) | Gets a message that describes the current exception.
Server |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.CommandException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.CommandException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.CommandException.

See Also

CommandException Class | StarTeam.Exceptions Namespace


CommandException Properties

The properties of the CommandException class are listed below. For a complete list of CommandException class members, see the CommandException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IOException |
Message (inherited from Exception) | Gets a message that describes the current exception.
Server |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

CommandException Class | StarTeam.Exceptions Namespace


IOException Property

Borland StarTeam SDK for .NET

CommandException.IOException Property

public virtual IOException IOException {get;}

See Also

CommandException Class | StarTeam.Exceptions Namespace


Server Property

Borland StarTeam SDK for .NET

CommandException.Server Property

public virtual Server Server {get;}

See Also

CommandException Class | StarTeam.Exceptions Namespace


CommandException Methods

The methods of the CommandException class are listed below. For a complete list of CommandException class members, see the CommandException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.CommandException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.CommandException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.CommandException.

See Also

CommandException Class | StarTeam.Exceptions Namespace


CommandException.Equals Method

Delegate Equals() to com.starteam.exceptions.CommandException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.CommandException.Equals(obj).

See Also

CommandException Class | StarTeam.Exceptions Namespace


CommandException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.CommandException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.CommandException.GetHashCode().

See Also

CommandException Class | StarTeam.Exceptions Namespace


CommandException.ToString Method

Delegate ToString() to com.starteam.exceptions.CommandException.

public override string ToString();

Return Value

com.starteam.exceptions.CommandException.ToString()

See Also

CommandException Class | StarTeam.Exceptions Namespace


ConnectionException Class

For a list of all members of this type, see ConnectionException Members.

System.Object
Exception
CommandException
ConnectionException

public class ConnectionException : CommandException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

ConnectionException Members | StarTeam.Exceptions Namespace


ConnectionException Members

ConnectionException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IOException (inherited from CommandException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
ReconnectAttemptCount |
ReconnectExceptions |
Server (inherited from CommandException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from CommandException) | Delegate Equals() to com.starteam.exceptions.CommandException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from CommandException) | Delegate GetHashCode() to com.starteam.exceptions.CommandException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from CommandException) | Delegate ToString() to com.starteam.exceptions.CommandException.

See Also

ConnectionException Class | StarTeam.Exceptions Namespace


ConnectionException Properties

The properties of the ConnectionException class are listed below. For a complete list of ConnectionException class members, see the ConnectionException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IOException (inherited from CommandException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
ReconnectAttemptCount |
ReconnectExceptions |
Server (inherited from CommandException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

ConnectionException Class | StarTeam.Exceptions Namespace


ReconnectAttemptCount Property

Borland StarTeam SDK for .NET

ConnectionException.ReconnectAttemptCount Property

public virtual Int32 ReconnectAttemptCount {get;}

See Also

ConnectionException Class | StarTeam.Exceptions Namespace


ReconnectExceptions Property

Borland StarTeam SDK for .NET

ConnectionException.ReconnectExceptions Property

public virtual IOException[] ReconnectExceptions {get;}

See Also

ConnectionException Class | StarTeam.Exceptions Namespace


DisembodiedException Class

For a list of all members of this type, see DisembodiedException Members.

System.Object
Exception
DisembodiedException

public class DisembodiedException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

DisembodiedException Members | StarTeam.Exceptions Namespace


DisembodiedException Members

DisembodiedException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ViewMember |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.DisembodiedException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.DisembodiedException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.DisembodiedException.

See Also

DisembodiedException Class | StarTeam.Exceptions Namespace


DisembodiedException Properties

The properties of the DisembodiedException class are listed below. For a complete list of DisembodiedException class members, see the DisembodiedException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
ViewMember |

See Also

DisembodiedException Class | StarTeam.Exceptions Namespace


Item Property

Borland StarTeam SDK for .NET

DisembodiedException.Item Property

public virtual Item Item {get;}

See Also

DisembodiedException Class | StarTeam.Exceptions Namespace


ViewMember Property

Borland StarTeam SDK for .NET

DisembodiedException.ViewMember Property

public virtual ViewMember ViewMember {get;}

See Also

DisembodiedException Class | StarTeam.Exceptions Namespace


DisembodiedException Methods

The methods of the DisembodiedException class are listed below. For a complete list of DisembodiedException class members, see the DisembodiedException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.DisembodiedException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.DisembodiedException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.DisembodiedException.

See Also

DisembodiedException Class | StarTeam.Exceptions Namespace


DisembodiedException.Equals Method

Delegate Equals() to com.starteam.exceptions.DisembodiedException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.DisembodiedException.Equals(obj).

See Also

DisembodiedException Class | StarTeam.Exceptions Namespace


DisembodiedException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.DisembodiedException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.DisembodiedException.GetHashCode().

See Also

DisembodiedException Class | StarTeam.Exceptions Namespace


DisembodiedException.ToString Method

Delegate ToString() to com.starteam.exceptions.DisembodiedException.

public override string ToString();

Return Value

com.starteam.exceptions.DisembodiedException.ToString()

See Also

DisembodiedException Class | StarTeam.Exceptions Namespace


DuplicateServerListEntryException Class

For a list of all members of this type, see DuplicateServerListEntryException Members.

System.Object
Exception
DuplicateServerListEntryException

public class DuplicateServerListEntryException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

DuplicateServerListEntryException Members | StarTeam.Exceptions Namespace


DuplicateServerListEntryException Members

DuplicateServerListEntryException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.DuplicateServerListEntryException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.DuplicateServerListEntryException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.DuplicateServerListEntryException.

See Also

DuplicateServerListEntryException Class | StarTeam.Exceptions Namespace


DuplicateServerListEntryException Methods

The methods of the DuplicateServerListEntryException class are listed below. For a complete list of DuplicateServerListEntryException class members, see the DuplicateServerListEntryException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.DuplicateServerListEntryException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.DuplicateServerListEntryException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.DuplicateServerListEntryException.

See Also

DuplicateServerListEntryException Class | StarTeam.Exceptions Namespace


DuplicateServerListEntryException.Equals Method

Delegate Equals() to com.starteam.exceptions.DuplicateServerListEntryException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.DuplicateServerListEntryException.Equals(obj).

See Also

DuplicateServerListEntryException Class | StarTeam.Exceptions Namespace


DuplicateServerListEntryException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.DuplicateServerListEntryException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.DuplicateServerListEntryException.GetHashCode().

See Also

DuplicateServerListEntryException Class | StarTeam.Exceptions Namespace


DuplicateServerListEntryException.ToString Method

Delegate ToString() to com.starteam.exceptions.DuplicateServerListEntryException.

public override string ToString();

Return Value

com.starteam.exceptions.DuplicateServerListEntryException.ToString()

See Also

DuplicateServerListEntryException Class | StarTeam.Exceptions Namespace


FileMergeException Class

For a list of all members of this type, see FileMergeException Members.

System.Object
Exception
FileMergeException

public class FileMergeException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

FileMergeException Members | StarTeam.Exceptions Namespace


FileMergeException Members

FileMergeException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.FileMergeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.FileMergeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.FileMergeException.

See Also

FileMergeException Class | StarTeam.Exceptions Namespace


FileMergeException Methods

The methods of the FileMergeException class are listed below. For a complete list of FileMergeException class members, see the FileMergeException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.FileMergeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.FileMergeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.FileMergeException.

See Also

FileMergeException Class | StarTeam.Exceptions Namespace


FileMergeException.Equals Method

Delegate Equals() to com.starteam.exceptions.FileMergeException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.FileMergeException.Equals(obj).

See Also

FileMergeException Class | StarTeam.Exceptions Namespace


FileMergeException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.FileMergeException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.FileMergeException.GetHashCode().

See Also

FileMergeException Class | StarTeam.Exceptions Namespace


FileMergeException.ToString Method

Delegate ToString() to com.starteam.exceptions.FileMergeException.

public override string ToString();

Return Value

com.starteam.exceptions.FileMergeException.ToString()

See Also

FileMergeException Class | StarTeam.Exceptions Namespace


ItemNotFoundException Class

For a list of all members of this type, see ItemNotFoundException Members.

System.Object
Exception
ServerException
ItemNotFoundException

public class ItemNotFoundException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemNotFoundException Members | StarTeam.Exceptions Namespace


ItemNotFoundException Members

ItemNotFoundException overview

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Server (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starteam.exceptions.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starteam.exceptions.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starteam.exceptions.ServerException.

See Also

ItemNotFoundException Class | StarTeam.Exceptions Namespace


ItemRevisionNotFoundException Class

For a list of all members of this type, see ItemRevisionNotFoundException Members.

System.Object
Exception
ItemRevisionNotFoundException

public class ItemRevisionNotFoundException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemRevisionNotFoundException Members | StarTeam.Exceptions Namespace


ItemRevisionNotFoundException Members

ItemRevisionNotFoundException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.ItemRevisionNotFoundException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.ItemRevisionNotFoundException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.ItemRevisionNotFoundException.

See Also

ItemRevisionNotFoundException Class | StarTeam.Exceptions Namespace


ItemRevisionNotFoundException Properties

The properties of the ItemRevisionNotFoundException class are listed below. For a complete list of ItemRevisionNotFoundException class members, see the ItemRevisionNotFoundException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

ItemRevisionNotFoundException Class | StarTeam.Exceptions Namespace


Item Property

Borland StarTeam SDK for .NET

ItemRevisionNotFoundException.Item Property

public virtual Item Item {get;}

See Also

ItemRevisionNotFoundException Class | StarTeam.Exceptions Namespace


ItemRevisionNotFoundException Methods

The methods of the ItemRevisionNotFoundException class are listed below. For a complete list of ItemRevisionNotFoundException class members, see the ItemRevisionNotFoundException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.ItemRevisionNotFoundException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.ItemRevisionNotFoundException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.ItemRevisionNotFoundException.

See Also

ItemRevisionNotFoundException Class | StarTeam.Exceptions Namespace


ItemRevisionNotFoundException.Equals Method

Delegate Equals() to com.starteam.exceptions.ItemRevisionNotFoundException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.ItemRevisionNotFoundException.Equals(obj).

See Also

ItemRevisionNotFoundException Class | StarTeam.Exceptions Namespace


ItemRevisionNotFoundException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.ItemRevisionNotFoundException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.ItemRevisionNotFoundException.GetHashCode().

See Also

ItemRevisionNotFoundException Class | StarTeam.Exceptions Namespace


ItemRevisionNotFoundException.ToString Method

Delegate ToString() to com.starteam.exceptions.ItemRevisionNotFoundException.

public override string ToString();

Return Value

com.starteam.exceptions.ItemRevisionNotFoundException.ToString()

See Also

ItemRevisionNotFoundException Class | StarTeam.Exceptions Namespace


LockingException Class

For a list of all members of this type, see LockingException Members.

System.Object
Exception
ServerException
LockingException

public class LockingException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

LockingException Members | StarTeam.Exceptions Namespace


LockingException Members

LockingException overview

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Server (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |
ViewMember |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starteam.exceptions.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starteam.exceptions.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starteam.exceptions.ServerException.

See Also

LockingException Class | StarTeam.Exceptions Namespace


LockingException Properties

The properties of the LockingException class are listed below. For a complete list of LockingException class members, see the LockingException Members topic.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Server (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |
ViewMember |

See Also

LockingException Class | StarTeam.Exceptions Namespace


ViewMember Property

Borland StarTeam SDK for .NET

LockingException.ViewMember Property

public virtual ViewMember ViewMember {get;}

See Also

LockingException Class | StarTeam.Exceptions Namespace


LogonException Class

For a list of all members of this type, see LogonException Members.

System.Object
Exception
ServerException
LogonException
PasswordExpiredException

public class LogonException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

LogonException Members | StarTeam.Exceptions Namespace


LogonException Members

LogonException overview

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
IsUserNameValid |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Server (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starteam.exceptions.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starteam.exceptions.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starteam.exceptions.ServerException.

See Also

LogonException Class | StarTeam.Exceptions Namespace


LogonException Properties

The properties of the LogonException class are listed below. For a complete list of LogonException class members, see the LogonException Members topic.

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
IsUserNameValid |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Server (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

See Also

LogonException Class | StarTeam.Exceptions Namespace


IsUserNameValid Property

Borland StarTeam SDK for .NET

LogonException.IsUserNameValid Property

public virtual Boolean IsUserNameValid {get;}

See Also

LogonException Class | StarTeam.Exceptions Namespace


MPXException Class

For a list of all members of this type, see MPXException Members.

System.Object
Exception
MPXException

public class MPXException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

MPXException Members | StarTeam.Exceptions Namespace


MPXException Members

MPXException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCodeValue |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.MPXException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.MPXException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.MPXException.

See Also

MPXException Class | StarTeam.Exceptions Namespace


MPXException Properties

The properties of the MPXException class are listed below. For a complete list of MPXException class members, see the MPXException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCodeValue |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

MPXException Class | StarTeam.Exceptions Namespace


ErrorCodeValue Property

Borland StarTeam SDK for .NET

MPXException.ErrorCodeValue Property

public virtual MPXException.ErrorCode ErrorCodeValue {get;}

See Also

MPXException Class | StarTeam.Exceptions Namespace


MPXException Methods

The methods of the MPXException class are listed below. For a complete list of MPXException class members, see the MPXException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.MPXException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.MPXException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.MPXException.

See Also

MPXException Class | StarTeam.Exceptions Namespace


MPXException.Equals Method

Delegate Equals() to com.starteam.exceptions.MPXException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.MPXException.Equals(obj).

See Also

MPXException Class | StarTeam.Exceptions Namespace


MPXException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.MPXException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.MPXException.GetHashCode().

See Also

MPXException Class | StarTeam.Exceptions Namespace


MPXException.ToString Method

Delegate ToString() to com.starteam.exceptions.MPXException.

public override string ToString();

Return Value

com.starteam.exceptions.MPXException.ToString()

See Also

MPXException Class | StarTeam.Exceptions Namespace


MPXException.ErrorCode Class

A Collection of MPX Error Codes

For a list of all members of this type, see MPXException.ErrorCode Members.

System.Object
MPXException.ErrorCode

public class MPXException.ErrorCode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

MPXException.ErrorCode Members | StarTeam.Exceptions Namespace


MPXException.ErrorCode Members

MPXException.ErrorCode overview

Public Static Properties

ALL
CANNOT_CONNECT
FAILED
MPX_BASE
MULTICAST_NOT_SUPPORTED
NO_DEFAULT_PROFILE
NO_MESSAGE_THREAD
NO_RESPONSE
NO_SUCH_PROFILE
NO_TRANSMITTER
NOT_CONNECTED
NOT_INSTALLED
NOT_SUPPORTED
UNEXPECTED

Public Static Methods

FromID Gets the Status value corresponding to the given ID.

Public Instance Properties

ID [read] int the iD of an error

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.MPXException.ErrorCode.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.MPXException.ErrorCode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.MPXException.ErrorCode.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


MPXException.ErrorCode Properties

The properties of the MPXException.ErrorCode class are listed below. For a complete list of MPXException.ErrorCode class members, see the MPXException.ErrorCode Members topic.

Public Static Properties

ALL
CANNOT_CONNECT
FAILED
MPX_BASE
MULTICAST_NOT_SUPPORTED
NO_DEFAULT_PROFILE
NO_MESSAGE_THREAD
NO_RESPONSE
NO_SUCH_PROFILE
NO_TRANSMITTER
NOT_CONNECTED
NOT_INSTALLED
NOT_SUPPORTED
UNEXPECTED

Public Instance Properties

ID [read] int the iD of an error

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


ALL Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.ALL Property

public static ErrorCode[] ALL {get;}

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


CANNOT_CONNECT Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.CANNOT_CONNECT Property

public static MPXException.ErrorCode CANNOT_CONNECT {get;}

Property Value

A problem was encountered connecting to the MPX Message Broker.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


FAILED Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.FAILED Property

public static MPXException.ErrorCode FAILED {get;}

Property Value

An unknown exception has occurred.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


ID Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.ID Property

[read] int the iD of an error

public virtual Int32 ID {get;}

Property Value

int the iD of an error

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


MPX_BASE Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.MPX_BASE Property

public static MPXException.ErrorCode MPX_BASE {get;}

Property Value

This error has been reported by the Message Broker.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


MULTICAST_NOT_SUPPORTED Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.MULTICAST_NOT_SUPPORTED Property

public static MPXException.ErrorCode MULTICAST_NOT_SUPPORTED {get;}

Property Value

MPX Multicast is not supported in this release of the SDK.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


NO_DEFAULT_PROFILE Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.NO_DEFAULT_PROFILE Property

public static MPXException.ErrorCode NO_DEFAULT_PROFILE {get;}

Property Value

There is no default client MPX profile defined on this server.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


NO_MESSAGE_THREAD Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.NO_MESSAGE_THREAD Property

public static MPXException.ErrorCode NO_MESSAGE_THREAD {get;}

Property Value

The thread that processes MPX Messages is no longer running.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


NO_RESPONSE Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.NO_RESPONSE Property

public static MPXException.ErrorCode NO_RESPONSE {get;}

Property Value

The MPX Message Broker is not responding.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


NO_SUCH_PROFILE Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.NO_SUCH_PROFILE Property

public static MPXException.ErrorCode NO_SUCH_PROFILE {get;}

Property Value

There is no MPX profile with the specified name on this server.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


NO_TRANSMITTER Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.NO_TRANSMITTER Property

public static MPXException.ErrorCode NO_TRANSMITTER {get;}

Property Value

The MPX Event Transmitter is not responding.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


NOT_CONNECTED Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.NOT_CONNECTED Property

public static MPXException.ErrorCode NOT_CONNECTED {get;}

Property Value

The MPX Message Broker is not connected.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


NOT_INSTALLED Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.NOT_INSTALLED Property

public static MPXException.ErrorCode NOT_INSTALLED {get;}

Property Value

MPX is not installed on this server.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


NOT_SUPPORTED Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.NOT_SUPPORTED Property

public static MPXException.ErrorCode NOT_SUPPORTED {get;}

Property Value

The StarTeam SDK supports MPX on StarTeam Servers version 5.2 and later.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


UNEXPECTED Property

Borland StarTeam SDK for .NET

MPXException.ErrorCode.UNEXPECTED Property

public static MPXException.ErrorCode UNEXPECTED {get;}

Property Value

An unexpected error internal error occurred.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


MPXException.ErrorCode Methods

The methods of the MPXException.ErrorCode class are listed below. For a complete list of MPXException.ErrorCode class members, see the MPXException.ErrorCode Members topic.

Public Static Methods

FromID Gets the Status value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.MPXException.ErrorCode.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.MPXException.ErrorCode.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.MPXException.ErrorCode.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


MPXException.ErrorCode.Equals Method

Delegate Equals() to com.starteam.exceptions.MPXException.ErrorCode.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.MPXException.ErrorCode.Equals(obj).

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


MPXException.ErrorCode.FromID Method

Gets the Status value corresponding to the given ID.

public static ErrorCode FromID(
Int32 id
);

Parameters

id
A Status ID.

Return Value

The corresponding Status value, or null.

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


MPXException.ErrorCode.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.MPXException.ErrorCode.

public override int GetHashCode();

Return Value

com.starteam.exceptions.MPXException.ErrorCode.GetHashCode().

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


MPXException.ErrorCode.ToString Method

Delegate ToString() to com.starteam.exceptions.MPXException.ErrorCode.

public override string ToString();

Return Value

com.starteam.exceptions.MPXException.ErrorCode.ToString()

See Also

MPXException.ErrorCode Class | StarTeam.Exceptions Namespace


NoSuchPropertyException Class

For a list of all members of this type, see NoSuchPropertyException Members.

System.Object
Exception
NoSuchPropertyException

public class NoSuchPropertyException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

NoSuchPropertyException Members | StarTeam.Exceptions Namespace


NoSuchPropertyException Members

NoSuchPropertyException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
PropertyID |
PropertyName |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.NoSuchPropertyException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.NoSuchPropertyException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.NoSuchPropertyException.

See Also

NoSuchPropertyException Class | StarTeam.Exceptions Namespace


NoSuchPropertyException Properties

The properties of the NoSuchPropertyException class are listed below. For a complete list of NoSuchPropertyException class members, see the NoSuchPropertyException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
PropertyID |
PropertyName |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

NoSuchPropertyException Class | StarTeam.Exceptions Namespace


PropertyID Property

Borland StarTeam SDK for .NET

NoSuchPropertyException.PropertyID Property

public virtual Int32 PropertyID {get;}

See Also

NoSuchPropertyException Class | StarTeam.Exceptions Namespace


PropertyName Property

Borland StarTeam SDK for .NET

NoSuchPropertyException.PropertyName Property

public virtual String PropertyName {get;}

See Also

NoSuchPropertyException Class | StarTeam.Exceptions Namespace


NoSuchPropertyException Methods

The methods of the NoSuchPropertyException class are listed below. For a complete list of NoSuchPropertyException class members, see the NoSuchPropertyException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.NoSuchPropertyException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.NoSuchPropertyException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.NoSuchPropertyException.

See Also

NoSuchPropertyException Class | StarTeam.Exceptions Namespace


NoSuchPropertyException.Equals Method

Delegate Equals() to com.starteam.exceptions.NoSuchPropertyException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.NoSuchPropertyException.Equals(obj).

See Also

NoSuchPropertyException Class | StarTeam.Exceptions Namespace


NoSuchPropertyException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.NoSuchPropertyException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.NoSuchPropertyException.GetHashCode().

See Also

NoSuchPropertyException Class | StarTeam.Exceptions Namespace


NoSuchPropertyException.ToString Method

Delegate ToString() to com.starteam.exceptions.NoSuchPropertyException.

public override string ToString();

Return Value

com.starteam.exceptions.NoSuchPropertyException.ToString()

See Also

NoSuchPropertyException Class | StarTeam.Exceptions Namespace


PasswordExpiredException Class

For a list of all members of this type, see PasswordExpiredException Members.

System.Object
Exception
ServerException
LogonException
PasswordExpiredException

public class PasswordExpiredException : LogonException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

PasswordExpiredException Members | StarTeam.Exceptions Namespace


PasswordExpiredException Members

PasswordExpiredException overview

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
IsUserNameValid (inherited from LogonException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Server (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starteam.exceptions.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starteam.exceptions.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starteam.exceptions.ServerException.

See Also

PasswordExpiredException Class | StarTeam.Exceptions Namespace


PropertyMergeException Class

For a list of all members of this type, see PropertyMergeException Members.

System.Object
Exception
PropertyMergeException

public class PropertyMergeException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

PropertyMergeException Members | StarTeam.Exceptions Namespace


PropertyMergeException Members

PropertyMergeException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Property |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.PropertyMergeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.PropertyMergeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.PropertyMergeException.

See Also

PropertyMergeException Class | StarTeam.Exceptions Namespace


PropertyMergeException Properties

The properties of the PropertyMergeException class are listed below. For a complete list of PropertyMergeException class members, see the PropertyMergeException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Property |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

PropertyMergeException Class | StarTeam.Exceptions Namespace


Property Property

Borland StarTeam SDK for .NET

PropertyMergeException.Property Property

public virtual Property Property {get;}

See Also

PropertyMergeException Class | StarTeam.Exceptions Namespace


PropertyMergeException Methods

The methods of the PropertyMergeException class are listed below. For a complete list of PropertyMergeException class members, see the PropertyMergeException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.PropertyMergeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.PropertyMergeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.PropertyMergeException.

See Also

PropertyMergeException Class | StarTeam.Exceptions Namespace


PropertyMergeException.Equals Method

Delegate Equals() to com.starteam.exceptions.PropertyMergeException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.PropertyMergeException.Equals(obj).

See Also

PropertyMergeException Class | StarTeam.Exceptions Namespace


PropertyMergeException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.PropertyMergeException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.PropertyMergeException.GetHashCode().

See Also

PropertyMergeException Class | StarTeam.Exceptions Namespace


PropertyMergeException.ToString Method

Delegate ToString() to com.starteam.exceptions.PropertyMergeException.

public override string ToString();

Return Value

com.starteam.exceptions.PropertyMergeException.ToString()

See Also

PropertyMergeException Class | StarTeam.Exceptions Namespace


PropertyNotWritableException Class

For a list of all members of this type, see PropertyNotWritableException Members.

System.Object
Exception
PropertyNotWritableException

public class PropertyNotWritableException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

PropertyNotWritableException Members | StarTeam.Exceptions Namespace


PropertyNotWritableException Members

PropertyNotWritableException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Property |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.PropertyNotWritableException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.PropertyNotWritableException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.PropertyNotWritableException.

See Also

PropertyNotWritableException Class | StarTeam.Exceptions Namespace


PropertyNotWritableException Properties

The properties of the PropertyNotWritableException class are listed below. For a complete list of PropertyNotWritableException class members, see the PropertyNotWritableException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Property |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

PropertyNotWritableException Class | StarTeam.Exceptions Namespace


Property Property

Borland StarTeam SDK for .NET

PropertyNotWritableException.Property Property

public virtual Property Property {get;}

See Also

PropertyNotWritableException Class | StarTeam.Exceptions Namespace


PropertyNotWritableException Methods

The methods of the PropertyNotWritableException class are listed below. For a complete list of PropertyNotWritableException class members, see the PropertyNotWritableException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.PropertyNotWritableException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.PropertyNotWritableException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.PropertyNotWritableException.

See Also

PropertyNotWritableException Class | StarTeam.Exceptions Namespace


PropertyNotWritableException.Equals Method

Delegate Equals() to com.starteam.exceptions.PropertyNotWritableException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.PropertyNotWritableException.Equals(obj).

See Also

PropertyNotWritableException Class | StarTeam.Exceptions Namespace


PropertyNotWritableException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.PropertyNotWritableException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.PropertyNotWritableException.GetHashCode().

See Also

PropertyNotWritableException Class | StarTeam.Exceptions Namespace


PropertyNotWritableException.ToString Method

Delegate ToString() to com.starteam.exceptions.PropertyNotWritableException.

public override string ToString();

Return Value

com.starteam.exceptions.PropertyNotWritableException.ToString()

See Also

PropertyNotWritableException Class | StarTeam.Exceptions Namespace


SDKRuntimeException Class

For a list of all members of this type, see SDKRuntimeException Members.

System.Object
Exception
SDKRuntimeException

public class SDKRuntimeException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

SDKRuntimeException Members | StarTeam.Exceptions Namespace


SDKRuntimeException Members

SDKRuntimeException overview

Public Static Methods

IsInternalApplicationError

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode |
Exception |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsInternalError |
Message (inherited from Exception) | Gets a message that describes the current exception.
Reason |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.SDKRuntimeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.SDKRuntimeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.SDKRuntimeException.

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


SDKRuntimeException Properties

The properties of the SDKRuntimeException class are listed below. For a complete list of SDKRuntimeException class members, see the SDKRuntimeException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode |
Exception |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsInternalError |
Message (inherited from Exception) | Gets a message that describes the current exception.
Reason |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


ErrorCode Property

Borland StarTeam SDK for .NET

SDKRuntimeException.ErrorCode Property

public virtual String ErrorCode {get;}

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


Exception Property

Borland StarTeam SDK for .NET

SDKRuntimeException.Exception Property

public virtual Exception Exception {get;}

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace | SDKRuntimeException.Exception Overload List


IsInternalError Property

Borland StarTeam SDK for .NET

SDKRuntimeException.IsInternalError Property

public virtual Boolean IsInternalError {get;}

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


Reason Property

Borland StarTeam SDK for .NET

SDKRuntimeException.Reason Property

public virtual Object Reason {get;}

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


SDKRuntimeException Methods

The methods of the SDKRuntimeException class are listed below. For a complete list of SDKRuntimeException class members, see the SDKRuntimeException Members topic.

Public Static Methods

IsInternalApplicationError

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.SDKRuntimeException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.SDKRuntimeException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.SDKRuntimeException.

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


SDKRuntimeException.Equals Method

Delegate Equals() to com.starteam.exceptions.SDKRuntimeException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.SDKRuntimeException.Equals(obj).

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


SDKRuntimeException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.SDKRuntimeException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.SDKRuntimeException.GetHashCode().

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


SDKRuntimeException.IsInternalApplicationError Method

public static bool IsInternalApplicationError(
Exception throwable
);

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


SDKRuntimeException.ToString Method

Delegate ToString() to com.starteam.exceptions.SDKRuntimeException.

public override string ToString();

Return Value

com.starteam.exceptions.SDKRuntimeException.ToString()

See Also

SDKRuntimeException Class | StarTeam.Exceptions Namespace


ServerException Class

For a list of all members of this type, see ServerException Members.

System.Object
Exception
ServerException
CommandAbortedException
ItemNotFoundException
LockingException
LogonException
ServerUnavailableException

public class ServerException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerException Members | StarTeam.Exceptions Namespace


ServerException Members

ServerException overview

Public Instance Properties

AuxKeys |
ClassName |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode |
ErrorMessage |
ErrorSource |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged |
LogEntry |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage |
Server |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.ServerException.
GetAuxData |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.ServerException.

See Also

ServerException Class | StarTeam.Exceptions Namespace


ServerException Properties

The properties of the ServerException class are listed below. For a complete list of ServerException class members, see the ServerException Members topic.

Public Instance Properties

AuxKeys |
ClassName |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode |
ErrorMessage |
ErrorSource |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged |
LogEntry |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage |
Server |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged |

See Also

ServerException Class | StarTeam.Exceptions Namespace


AuxKeys Property

Borland StarTeam SDK for .NET

ServerException.AuxKeys Property

public virtual String[] AuxKeys {get;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


ClassName Property

Borland StarTeam SDK for .NET

ServerException.ClassName Property

public virtual String ClassName {get;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


ErrorCode Property

Borland StarTeam SDK for .NET

ServerException.ErrorCode Property

public virtual Int32 ErrorCode {get;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


ErrorMessage Property

Borland StarTeam SDK for .NET

ServerException.ErrorMessage Property

public virtual String ErrorMessage {get; set;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


ErrorSource Property

Borland StarTeam SDK for .NET

ServerException.ErrorSource Property

public virtual String ErrorSource {get;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


IsLogged Property

Borland StarTeam SDK for .NET

ServerException.IsLogged Property

public virtual Boolean IsLogged {get;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


LogEntry Property

Borland StarTeam SDK for .NET

ServerException.LogEntry Property

public virtual Int32 LogEntry {get;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


NonLocalizedMessage Property

Borland StarTeam SDK for .NET

ServerException.NonLocalizedMessage Property

public virtual String NonLocalizedMessage {get;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


Server Property

Borland StarTeam SDK for .NET

ServerException.Server Property

public virtual Server Server {get;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


TimeLogged Property

Borland StarTeam SDK for .NET

ServerException.TimeLogged Property

public virtual DateTime TimeLogged {get;}

See Also

ServerException Class | StarTeam.Exceptions Namespace


ServerException Methods

The methods of the ServerException class are listed below. For a complete list of ServerException class members, see the ServerException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.ServerException.
GetAuxData |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.ServerException.

See Also

ServerException Class | StarTeam.Exceptions Namespace


ServerException.Equals Method

Delegate Equals() to com.starteam.exceptions.ServerException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.ServerException.Equals(obj).

See Also

ServerException Class | StarTeam.Exceptions Namespace


ServerException.GetAuxData Method

public virtual object GetAuxData(
String key
);

See Also

ServerException Class | StarTeam.Exceptions Namespace


ServerException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.ServerException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.ServerException.GetHashCode().

See Also

ServerException Class | StarTeam.Exceptions Namespace


ServerException.ToString Method

Delegate ToString() to com.starteam.exceptions.ServerException.

public override string ToString();

Return Value

com.starteam.exceptions.ServerException.ToString()

See Also

ServerException Class | StarTeam.Exceptions Namespace


ServerUnavailableException Class

For a list of all members of this type, see ServerUnavailableException Members.

System.Object
Exception
ServerException
ServerUnavailableException

public class ServerUnavailableException : ServerException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

ServerUnavailableException Members | StarTeam.Exceptions Namespace


ServerUnavailableException Members

ServerUnavailableException overview

Public Instance Properties

AuxKeys (inherited from ServerException) |
ClassName (inherited from ServerException) |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode (inherited from ServerException) |
ErrorMessage (inherited from ServerException) |
ErrorSource (inherited from ServerException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsLogged (inherited from ServerException) |
LogEntry (inherited from ServerException) |
Message (inherited from Exception) | Gets a message that describes the current exception.
NonLocalizedMessage (inherited from ServerException) |
Server (inherited from ServerException) |
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TimeLogged (inherited from ServerException) |

Public Instance Methods

Equals (inherited from ServerException) | Delegate Equals() to com.starteam.exceptions.ServerException.
GetAuxData (inherited from ServerException) |
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from ServerException) | Delegate GetHashCode() to com.starteam.exceptions.ServerException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from ServerException) | Delegate ToString() to com.starteam.exceptions.ServerException.

See Also

ServerUnavailableException Class | StarTeam.Exceptions Namespace


TypeNotFoundException Class

For a list of all members of this type, see TypeNotFoundException Members.

System.Object
Exception
TypeNotFoundException

public class TypeNotFoundException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

TypeNotFoundException Members | StarTeam.Exceptions Namespace


TypeNotFoundException Members

TypeNotFoundException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TypeID |
TypeName |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.TypeNotFoundException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.TypeNotFoundException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.TypeNotFoundException.

See Also

TypeNotFoundException Class | StarTeam.Exceptions Namespace


TypeNotFoundException Properties

The properties of the TypeNotFoundException class are listed below. For a complete list of TypeNotFoundException class members, see the TypeNotFoundException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
TypeID |
TypeName |

See Also

TypeNotFoundException Class | StarTeam.Exceptions Namespace


TypeID Property

Borland StarTeam SDK for .NET

TypeNotFoundException.TypeID Property

public virtual Int32 TypeID {get;}

See Also

TypeNotFoundException Class | StarTeam.Exceptions Namespace


TypeName Property

Borland StarTeam SDK for .NET

TypeNotFoundException.TypeName Property

public virtual String TypeName {get;}

See Also

TypeNotFoundException Class | StarTeam.Exceptions Namespace


TypeNotFoundException Methods

The methods of the TypeNotFoundException class are listed below. For a complete list of TypeNotFoundException class members, see the TypeNotFoundException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.TypeNotFoundException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.TypeNotFoundException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.TypeNotFoundException.

See Also

TypeNotFoundException Class | StarTeam.Exceptions Namespace


TypeNotFoundException.Equals Method

Delegate Equals() to com.starteam.exceptions.TypeNotFoundException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.TypeNotFoundException.Equals(obj).

See Also

TypeNotFoundException Class | StarTeam.Exceptions Namespace


TypeNotFoundException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.TypeNotFoundException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.TypeNotFoundException.GetHashCode().

See Also

TypeNotFoundException Class | StarTeam.Exceptions Namespace


TypeNotFoundException.ToString Method

Delegate ToString() to com.starteam.exceptions.TypeNotFoundException.

public override string ToString();

Return Value

com.starteam.exceptions.TypeNotFoundException.ToString()

See Also

TypeNotFoundException Class | StarTeam.Exceptions Namespace


WorkStationException Class

For a list of all members of this type, see WorkStationException Members.

System.Object
Exception
WorkStationException

public class WorkStationException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Exceptions

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkStationException Members | StarTeam.Exceptions Namespace


WorkStationException Members

WorkStationException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.WorkStationException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.WorkStationException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.WorkStationException.

See Also

WorkStationException Class | StarTeam.Exceptions Namespace


WorkStationException Methods

The methods of the WorkStationException class are listed below. For a complete list of WorkStationException class members, see the WorkStationException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.exceptions.WorkStationException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.exceptions.WorkStationException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.exceptions.WorkStationException.

See Also

WorkStationException Class | StarTeam.Exceptions Namespace


WorkStationException.Equals Method

Delegate Equals() to com.starteam.exceptions.WorkStationException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.exceptions.WorkStationException.Equals(obj).

See Also

WorkStationException Class | StarTeam.Exceptions Namespace


WorkStationException.GetHashCode Method

Delegate GetHashCode() to com.starteam.exceptions.WorkStationException.

public override int GetHashCode();

Return Value

com.starteam.exceptions.WorkStationException.GetHashCode().

See Also

WorkStationException Class | StarTeam.Exceptions Namespace


WorkStationException.ToString Method

Delegate ToString() to com.starteam.exceptions.WorkStationException.

public override string ToString();

Return Value

com.starteam.exceptions.WorkStationException.ToString()

See Also

WorkStationException Class | StarTeam.Exceptions Namespace


StarTeam.Util

Borland StarTeam SDK for .NET

StarTeam.Util Namespace

Namespace hierarchy

Classes

Class | Description
Base64 | A utility class for encoding and decoding binary data in base64. More information on base64 encoding can be found in RFC 2045 - Multipurpose Internet Mail Extensions (MIME) part one.
Date | An SDK implementation of Date which closely mirrors java.util.GregorianCalendar but only supports day, month and year Note that, unlike the Microsoft.NET System.DateTime, the values for Month range from 0 (January) to 11 (December) This is in keeping with java.util.Date and java.util.GregorianCalendar
DotNotation | Represents a DotNotation (e.g., 1.25.1.0).
Encoding | A platform-independent representation of a character encoding, with methods for enumerating encodings, determining which are supported by the current platform, etc.
EOLReader |
FileAccess |
FileAccess.Attributes | Attributes of a working file on disk
FileUtils | Utility class for accessing file info.
GUID | Generates a Globally unique identifier
ISO8601 | A utility class for encoding and parsing ISO8601 date/time format strings. The following sites have more information: W3C NOTE - Date and Time Formated Appendix 2 of the WebDAV specification. Discussion by Markus Kuhn
LineProcessor |
LineReader |
LogManager | provide a simple model for logging debug messages from the sdk the caller is responsible for implementing the interfaces
MD5 | A 16 byte hash that uniquely identifies content across space and time
MD5.Stream |
Platform | Information about the current platform.
Platform.EOL | The end-of-line sequence on different platforms
ReadWriteLock |
Registry | Provides functions for accessing the Windows Registry via a JNI library. Typically useful for applications that run on Windows platforms
UTF8 | Implements UTF-8 conversion routines as described by RFC-2279
XMLUtils | A class with XML related utility methods.

Interfaces

Interface | Description
LogManager.LogFactory | A LogFactory returns a Logger for a given class Client applications must implement this interface
LogManager.Logger | A Logger accepts a string as input and decides whether or not to log that string Client applications must implement this interface
Platform.WorkStationOptions |


Base64 Class

A utility class for encoding and decoding binary data in base64. More information on base64 encoding can be found in RFC 2045 - Multipurpose Internet Mail Extensions (MIME) part one.

For a list of all members of this type, see Base64 Members.

System.Object
Base64

public class Base64

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

Base64 Members | StarTeam.Util Namespace


Base64 Members

Base64 overview

Public Static Methods

Decode | Returns the byte array represented by the specified base64 encoded data.
DecodeAsString | Returns the String decoding of the specified base64 encoded data. Since decoding really should return a byte array this method simply treats each byte as the corresponding UNICODE character with the high byte set to zero. This is equivalent to treating the decoded bytes as the ISO-8859-1 encoding of the returned string.
DecodeToFile | Decodes the specified base64 encoded data but puts the output in to the specified File.
DecodeToStream |
Encode | Returns a String encoding of the specified data in base64.
EncodeBytes | Returns a byte array encoding of the specified data in base64.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Base64.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Base64.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.Base64.

See Also

Base64 Class | StarTeam.Util Namespace


Base64 Methods

The methods of the Base64 class are listed below. For a complete list of Base64 class members, see the Base64 Members topic.

Public Static Methods

Decode | Returns the byte array represented by the specified base64 encoded data.
DecodeAsString | Returns the String decoding of the specified base64 encoded data. Since decoding really should return a byte array this method simply treats each byte as the corresponding UNICODE character with the high byte set to zero. This is equivalent to treating the decoded bytes as the ISO-8859-1 encoding of the returned string.
DecodeToFile | Decodes the specified base64 encoded data but puts the output in to the specified File.
DecodeToStream |
Encode | Returns a String encoding of the specified data in base64.
EncodeBytes | Returns a byte array encoding of the specified data in base64.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Base64.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Base64.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.Base64.

See Also

Base64 Class | StarTeam.Util Namespace


Base64.Decode Method

Returns the byte array represented by the specified base64 encoded data.

public static byte[] Decode(
String data
);

Parameters

data
the base64 data to be decoded

Return Value

the decoded data

See Also

Base64 Class | StarTeam.Util Namespace


Base64.DecodeAsString Method

Returns the String decoding of the specified base64 encoded data. Since decoding really should return a byte array this method simply treats each byte as the corresponding UNICODE character with the high byte set to zero. This is equivalent to treating the decoded bytes as the ISO-8859-1 encoding of the returned string.

public static string DecodeAsString(
String data
);

Parameters

data
the base64 encoded data to be decoded

Return Value

the decoded data represented as a String

See Also

Base64 Class | StarTeam.Util Namespace


Base64.DecodeToFile Method

Decodes the specified base64 encoded data but puts the output in to the specified File.

public static void DecodeToFile(
String data,
FileInfo outFile
);

Parameters

data
a base64 encoding of some data
outFile
the file to which the decoded data is to be written

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Base64 Class | StarTeam.Util Namespace


Base64.DecodeToStream Method

public static void DecodeToStream(
String data,
Stream _out
);

See Also

Base64 Class | StarTeam.Util Namespace


Base64.Encode Method

Returns a String encoding of the specified data in base64.

public static string Encode(
Byte[] data
);

Parameters

data
the data to be encoded

Return Value

the base64 encoding of the specified data

See Also

Base64 Class | StarTeam.Util Namespace


Base64.EncodeBytes Method

Returns a byte array encoding of the specified data in base64.

public static byte[] EncodeBytes(
Byte[] data,
Int32 pos,
Int32 len
);

Parameters

data
the data to be encoded
pos
the starting position of the data to be encoded
len
the length of data to be encoded

Return Value

the base64 encoding of the specified data as a byte array

See Also

Base64 Class | StarTeam.Util Namespace


Base64.Equals Method

Delegate Equals() to com.starteam.util.Base64.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.Base64.Equals(obj).

See Also

Base64 Class | StarTeam.Util Namespace


Base64.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.Base64.

public override int GetHashCode();

Return Value

com.starteam.util.Base64.GetHashCode().

See Also

Base64 Class | StarTeam.Util Namespace


Base64.ToString Method

Delegate ToString() to com.starteam.util.Base64.

public override string ToString();

Return Value

com.starteam.util.Base64.ToString()

See Also

Base64 Class | StarTeam.Util Namespace


Date Class

An SDK implementation of Date which closely mirrors java.util.GregorianCalendar but only supports day, month and year Note that, unlike the Microsoft.NET System.DateTime, the values for Month range from 0 (January) to 11 (December) This is in keeping with java.util.Date and java.util.GregorianCalendar

For a list of all members of this type, see Date Members.

System.Object
Date

public class Date

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

Date Members | StarTeam.Util Namespace


Date Members

Date overview

Public Static Properties

DATE_VALUE_NOT_SET
MAX_VALUE
MIN_VALUE
VALUE_NOT_SET

Public Static Methods

GetElapsedTime | Returns the elapsed time between two Date instances.
Today | returns the Date value of today using current time in GMT

Public Instance Constructors

Date Overloaded. Initializes a new instance of the Date class.

Public Instance Properties

DayOfMonth | [read] int the day of month
DebugString | [read] a string representation of the content of this object instance
Month | [read] int the month
Year | [read] int the year

Public Instance Methods

AddDays | Returns a new Date that is nDays after this one.
CompareTo |
DiffInDays | Subtracts a date from this one, returning the difference in days.
Equals | Delegate Equals() to com.starteam.util.Date.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Date.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAfter | Returns true if the given date is after this one in time
IsBefore | Returns true if the given date is before this one in time
IsEqualTo | Returns true if the given date is the same as this one
ToDateTime | returns a DateTime instance of this date centered at UTC noon
ToLocalString | returns a String representation of this Date instance formatted for the default locale
ToSQLString | Returns the date in the standard 'SQL' format, i.e. 'yyyy-mm-dd', e.g. "2005-01-28", where 01=January thru 12=December Note also that the String representation of the date displays months between 1 and 12, whereas the constructor expects months to be described between 0 and 11.
ToString | Delegate ToString() to com.starteam.util.Date.

See Also

Date Class | StarTeam.Util Namespace


Date Constructor

Create a new Date from a Year, Month and DayOfMonth

Overload List

Creates a new Date using current time in GMT.

public Date();

Create a new Date from a Year, Month and DayOfMonth

public Date(Int32,Int32,Int32);

Constructs a Date from a string specified in the standard SQL format i.e. 'yyyy-mm-dd', e.g. "2005-01-28", where 01=January thru 12=December

public Date(String);

See Also

Date Class | StarTeam.Util Namespace


Date Constructor (Int32, Int32, Int32)

Create a new Date from a Year, Month and DayOfMonth

public Date(
Int32 year,
Int32 month,
Int32 dayOfMonth
);

Parameters

year
1900 - 9999
month
0 - 11
dayOfMonth
1 - 31

See Also

Date Class | StarTeam.Util Namespace | Date Constructor Overload List


Date Constructor ()

Creates a new Date using current time in GMT.

public Date();

See Also

Date Class | StarTeam.Util Namespace | Date Constructor Overload List


Date Constructor (String)

Constructs a Date from a string specified in the standard SQL format i.e. 'yyyy-mm-dd', e.g. "2005-01-28", where 01=January thru 12=December

public Date(
String s
);

Parameters

s
a string specified in the standard SQL format

See Also

Date Class | StarTeam.Util Namespace | Date Constructor Overload List


Date Properties

The properties of the Date class are listed below. For a complete list of Date class members, see the Date Members topic.

Public Static Properties

DATE_VALUE_NOT_SET
MAX_VALUE
MIN_VALUE
VALUE_NOT_SET

Public Instance Properties

DayOfMonth | [read] int the day of month
DebugString | [read] a string representation of the content of this object instance
Month | [read] int the month
Year | [read] int the year

See Also

Date Class | StarTeam.Util Namespace


DATE_VALUE_NOT_SET Property

Borland StarTeam SDK for .NET

Date.DATE_VALUE_NOT_SET Property

public static Int32 DATE_VALUE_NOT_SET {get;}

See Also

Date Class | StarTeam.Util Namespace


DayOfMonth Property

Borland StarTeam SDK for .NET

Date.DayOfMonth Property

[read] int the day of month

public virtual Int32 DayOfMonth {get;}

Property Value

int the day of month

See Also

Date Class | StarTeam.Util Namespace


DebugString Property

Borland StarTeam SDK for .NET

Date.DebugString Property

[read] a string representation of the content of this object instance

public virtual String DebugString {get;}

Property Value

a string representation of the content of this object instance

See Also

Date Class | StarTeam.Util Namespace


MAX_VALUE Property

Borland StarTeam SDK for .NET

Date.MAX_VALUE Property

public static Date MAX_VALUE {get;}

Property Value

11:59:59 P.M., December 31, 4636 A.D.

See Also

Date Class | StarTeam.Util Namespace


MIN_VALUE Property

Borland StarTeam SDK for .NET

Date.MIN_VALUE Property

public static Date MIN_VALUE {get;}

Property Value

Jan 1, 1900 AD 12:00:00

See Also

Date Class | StarTeam.Util Namespace


Month Property

Borland StarTeam SDK for .NET

Date.Month Property

[read] int the month

public virtual Int32 Month {get;}

Property Value

int the month

See Also

Date Class | StarTeam.Util Namespace


VALUE_NOT_SET Property

Borland StarTeam SDK for .NET

Date.VALUE_NOT_SET Property

public static Date VALUE_NOT_SET {get;}

Property Value

Date used in some properties to indicate this date value has not been set.

See Also

Date Class | StarTeam.Util Namespace


Year Property

Borland StarTeam SDK for .NET

Date.Year Property

[read] int the year

public virtual Int32 Year {get;}

Property Value

int the year

See Also

Date Class | StarTeam.Util Namespace


Date Methods

The methods of the Date class are listed below. For a complete list of Date class members, see the Date Members topic.

Public Static Methods

GetElapsedTime | Returns the elapsed time between two Date instances.
Today | returns the Date value of today using current time in GMT

Public Instance Methods

AddDays | Returns a new Date that is nDays after this one.
CompareTo |
DiffInDays | Subtracts a date from this one, returning the difference in days.
Equals | Delegate Equals() to com.starteam.util.Date.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Date.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAfter | Returns true if the given date is after this one in time
IsBefore | Returns true if the given date is before this one in time
IsEqualTo | Returns true if the given date is the same as this one
ToDateTime | returns a DateTime instance of this date centered at UTC noon
ToLocalString | returns a String representation of this Date instance formatted for the default locale
ToSQLString | Returns the date in the standard 'SQL' format, i.e. 'yyyy-mm-dd', e.g. "2005-01-28", where 01=January thru 12=December Note also that the String representation of the date displays months between 1 and 12, whereas the constructor expects months to be described between 0 and 11.
ToString | Delegate ToString() to com.starteam.util.Date.

See Also

Date Class | StarTeam.Util Namespace


Date.AddDays Method

Returns a new Date that is nDays after this one.

public virtual Date AddDays(
Int32 nDays
);

Parameters

nDays
- the number of days to add

Return Value

a new date

See Also

Date Class | StarTeam.Util Namespace


Date.CompareTo Method

public virtual int CompareTo(
Date date
);

See Also

Date Class | StarTeam.Util Namespace


Date.DiffInDays Method

Subtracts a date from this one, returning the difference in days.

public virtual int DiffInDays(
Date other
);

Parameters

other
- the Date instance to subtract from this one

Return Value

the difference as a number of days

See Also

Date Class | StarTeam.Util Namespace


Date.Equals Method

Delegate Equals() to com.starteam.util.Date.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.Date.Equals(obj).

See Also

Date Class | StarTeam.Util Namespace


Date.GetElapsedTime Method

Returns the elapsed time between two Date instances.

public static TimeSpan GetElapsedTime(
Date before,
Date after
);

Parameters

before
Date
after
Date

Return Value

TimeSpan; the elapsed time between two Date instances.

See Also

Date Class | StarTeam.Util Namespace


Date.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.Date.

public override int GetHashCode();

Return Value

com.starteam.util.Date.GetHashCode().

See Also

Date Class | StarTeam.Util Namespace


Date.IsAfter Method

Returns true if the given date is after this one in time

public virtual bool IsAfter(
Date date
);

Parameters

date
- the Date instance to compare with this one

Return Value

true if the given date is after this one in time

See Also

Date Class | StarTeam.Util Namespace


Date.IsBefore Method

Returns true if the given date is before this one in time

public virtual bool IsBefore(
Date date
);

Parameters

date
- the Date instance to compare with this one

Return Value

true if the given date is before this one in time

See Also

Date Class | StarTeam.Util Namespace


Date.IsEqualTo Method

Returns true if the given date is the same as this one

public virtual bool IsEqualTo(
Date date
);

Parameters

date
- the Date instance to compare with this one

Return Value

true if the given date is the same as this one

See Also

Date Class | StarTeam.Util Namespace


Date.ToDateTime Method

returns a DateTime instance of this date centered at UTC noon

public virtual DateTime ToDateTime();

Return Value

a DateTime instance of this date centered at UTC noon

See Also

Date Class | StarTeam.Util Namespace


Date.Today Method

returns the Date value of today using current time in GMT

public static Date Today();

Return Value

the Date value of today using current time in GMT

See Also

Date Class | StarTeam.Util Namespace


Date.ToLocalString Method

returns a String representation of this Date instance formatted for the default locale

public virtual string ToLocalString(
Int32 dateFormat
);

Parameters

dateFormat
a date format descriptor

Return Value

a String representation of this DateTime instance formatted for the default locale

See Also

Date Class | StarTeam.Util Namespace


Date.ToSQLString Method

Returns the date in the standard 'SQL' format, i.e. 'yyyy-mm-dd', e.g. "2005-01-28", where 01=January thru 12=December Note also that the String representation of the date displays months between 1 and 12, whereas the constructor expects months to be described between 0 and 11.

public virtual string ToSQLString();

Return Value

the string representation of a date in standard 'SQL' format

See Also

Date Class | StarTeam.Util Namespace


Date.ToString Method

Delegate ToString() to com.starteam.util.Date.

public override string ToString();

Return Value

com.starteam.util.Date.ToString()

See Also

Date Class | StarTeam.Util Namespace


DotNotation Class

Represents a DotNotation (e.g., 1.25.1.0).

For a list of all members of this type, see DotNotation Members.

System.Object
DotNotation

public class DotNotation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

DotNotation Members | StarTeam.Util Namespace


DotNotation Members

DotNotation overview

Public Static Methods

Compare Compares two DotNotations.

Public Instance Constructors

DotNotation Overloaded. Initializes a new instance of the DotNotation class.

Public Instance Properties

BranchRevision | [read] The revision number of this DotNotation within its branch.
BranchRoot | [read] The DotNotation representing the root of this branch.
HistoryLength | [read] The total number of revisions in the history of an artifact with this DotNotation.
IsBranched | [read] true if this DotNotation has branched; false otherwise.
Next | [read] The next DotNotation in this branch.
Parent | [read] The patent branch point of this DotNotation, or null if this DotNotation has not branched.
Previous | [read] The previous DotNotation in the revision history, or null.

Public Instance Methods

CompareTo | Compares this DotNotation to another one.
Equals | Delegate Equals() to com.starteam.util.DotNotation.
GetCommonAncestor | Determines the common ancestor between this DotNotation and another one.
GetHashCode | Delegate GetHashCode() to com.starteam.util.DotNotation.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAncestorOf | Determines whether or not this DotNotation is an ancestor of the given one. Note that a DotNotation is considered an ancestor of itself.
IsOnSameBranchAs | Determines whether or not this DotNotation is on the same branch as another one.
ToString | Delegate ToString() to com.starteam.util.DotNotation.

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation Constructor

Constructs a new DotNotation.

Overload List

Constructs a new DotNotation that is a copy of another one.

public DotNotation(DotNotation);

Constructs a new DotNotation.

public DotNotation(String);

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation Constructor (String)

Constructs a new DotNotation.

public DotNotation(
String s
);

Parameters

s
A DotNotation in string form (e.g., "1.25.1.0").

See Also

DotNotation Class | StarTeam.Util Namespace | DotNotation Constructor Overload List


DotNotation Constructor (DotNotation)

Constructs a new DotNotation that is a copy of another one.

public DotNotation(
DotNotation n
);

Parameters

n
The DotNotation to be copied.

See Also

DotNotation Class | StarTeam.Util Namespace | DotNotation Constructor Overload List


DotNotation Properties

The properties of the DotNotation class are listed below. For a complete list of DotNotation class members, see the DotNotation Members topic.

Public Instance Properties

BranchRevision | [read] The revision number of this DotNotation within its branch.
BranchRoot | [read] The DotNotation representing the root of this branch.
HistoryLength | [read] The total number of revisions in the history of an artifact with this DotNotation.
IsBranched | [read] true if this DotNotation has branched; false otherwise.
Next | [read] The next DotNotation in this branch.
Parent | [read] The patent branch point of this DotNotation, or null if this DotNotation has not branched.
Previous | [read] The previous DotNotation in the revision history, or null.

See Also

DotNotation Class | StarTeam.Util Namespace


BranchRevision Property

Borland StarTeam SDK for .NET

DotNotation.BranchRevision Property

[read] The revision number of this DotNotation within its branch.

public virtual Int32 BranchRevision {get;}

Property Value

The revision number of this DotNotation within its branch.

See Also

DotNotation Class | StarTeam.Util Namespace


BranchRoot Property

Borland StarTeam SDK for .NET

DotNotation.BranchRoot Property

[read] The DotNotation representing the root of this branch.

public virtual DotNotation BranchRoot {get;}

Property Value

The DotNotation representing the root of this branch.

See Also

DotNotation Class | StarTeam.Util Namespace


HistoryLength Property

Borland StarTeam SDK for .NET

DotNotation.HistoryLength Property

[read] The total number of revisions in the history of an artifact with this DotNotation.

public virtual Int32 HistoryLength {get;}

Property Value

The total number of revisions in the history of an artifact with this DotNotation.

See Also

DotNotation Class | StarTeam.Util Namespace


IsBranched Property

Borland StarTeam SDK for .NET

DotNotation.IsBranched Property

[read] true if this DotNotation has branched; false otherwise.

public virtual Boolean IsBranched {get;}

Property Value

true if this DotNotation has branched; false otherwise.

See Also

DotNotation Class | StarTeam.Util Namespace


Next Property

Borland StarTeam SDK for .NET

DotNotation.Next Property

[read] The next DotNotation in this branch.

public virtual DotNotation Next {get;}

Property Value

The next DotNotation in this branch.

See Also

DotNotation Class | StarTeam.Util Namespace


Parent Property

Borland StarTeam SDK for .NET

DotNotation.Parent Property

[read] The patent branch point of this DotNotation, or null if this DotNotation has not branched.

public virtual DotNotation Parent {get;}

Property Value

The patent branch point of this DotNotation, or null if this DotNotation has not branched.

See Also

DotNotation Class | StarTeam.Util Namespace


Previous Property

Borland StarTeam SDK for .NET

DotNotation.Previous Property

[read] The previous DotNotation in the revision history, or null.

public virtual DotNotation Previous {get;}

Property Value

The previous DotNotation in the revision history, or null.

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation Methods

The methods of the DotNotation class are listed below. For a complete list of DotNotation class members, see the DotNotation Members topic.

Public Static Methods

Compare Compares two DotNotations.

Public Instance Methods

CompareTo | Compares this DotNotation to another one.
Equals | Delegate Equals() to com.starteam.util.DotNotation.
GetCommonAncestor | Determines the common ancestor between this DotNotation and another one.
GetHashCode | Delegate GetHashCode() to com.starteam.util.DotNotation.
GetType (inherited from Object) | Gets the Type of the current instance.
IsAncestorOf | Determines whether or not this DotNotation is an ancestor of the given one. Note that a DotNotation is considered an ancestor of itself.
IsOnSameBranchAs | Determines whether or not this DotNotation is on the same branch as another one.
ToString | Delegate ToString() to com.starteam.util.DotNotation.

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation.Compare Method

Compares two DotNotations.

public static int Compare(
DotNotation n1,
DotNotation n2
);

Parameters

n1
The first DotNotation to be compared.
n2
The second DotNotation to be compared.

Return Value

-1 if n1 is less than the given one; 0 if n1 and n2 are equal; 1 if n1 is greater than n2.

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation.CompareTo Method

Compares this DotNotation to another one.

public virtual int CompareTo(
DotNotation n
);

Parameters

n
The DotNotation to be compared.

Return Value

-1 if this DotNotation is less than the given one; 0 if this DotNotation and the given one are equal; 1 if this DotNotation is greater than the given one.

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation.Equals Method

Delegate Equals() to com.starteam.util.DotNotation.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.DotNotation.Equals(obj).

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation.GetCommonAncestor Method

Determines the common ancestor between this DotNotation and another one.

public virtual DotNotation GetCommonAncestor(
DotNotation other
);

Parameters

other
The DotNotation to be compared.

Return Value

The DotNotation that is the common ancestor, or null if the two DotNotations have no common ancestor.

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.DotNotation.

public override int GetHashCode();

Return Value

com.starteam.util.DotNotation.GetHashCode().

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation.IsAncestorOf Method

Determines whether or not this DotNotation is an ancestor of the given one. Note that a DotNotation is considered an ancestor of itself.

public virtual bool IsAncestorOf(
DotNotation other
);

Parameters

other
The DotNotation to be compared.

Return Value

true if this DotNotation is equal to or is an ancestor of the given one; false otherwise.

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation.IsOnSameBranchAs Method

Determines whether or not this DotNotation is on the same branch as another one.

public virtual bool IsOnSameBranchAs(
DotNotation other
);

Parameters

other
The DotNotation to be compared.

Return Value

True if the two DotNotations are on the same branch; false otherwise.

See Also

DotNotation Class | StarTeam.Util Namespace


DotNotation.ToString Method

Delegate ToString() to com.starteam.util.DotNotation.

public override string ToString();

Return Value

com.starteam.util.DotNotation.ToString()

See Also

DotNotation Class | StarTeam.Util Namespace


Encoding Class

A platform-independent representation of a character encoding, with methods for enumerating encodings, determining which are supported by the current platform, etc.

For a list of all members of this type, see Encoding Members.

System.Object
Encoding

public class Encoding

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

Encoding Members | StarTeam.Util Namespace


Encoding Members

Encoding overview

Public Static Properties

AllKnownEncodings | [read] A list of all known encodings, including ones that are not supported by the current platform. The encodings are sorted by name.
CODEPAGE_UNKNOWN |
DefaultPlatformEncoding | [read] The default platform encoding. Never returns null.
DefaultStarTeamEncoding | [read/write] The default StarTeam encoding. Never returns null.
ID_UNKNOWN |
ISO_8859_1 |
ReadableEncodings | [read] A list of all known encodings that are supported for reading (and possibly also writing) by the current platform. The encodings are sorted by the name used for reading on this platform.
STARTEAM_PROPERTY |
SupportedEncodings | [read] A list of all known encodings that are fully supported (for both reading and writing) by the current platform. The encodings are sorted by the name they are known by on this platform.
US_ASCII |
UTF_16 |
UTF_16BE |
UTF_16LE |
UTF_32 |
UTF_32BE |
UTF_32LE |
UTF_8 |
WritableEncodings | [read] A list of all known encodings that are supported for writing (and possibly also reading) by the current platform. The encodings are sorted by the name used for writing on this platform.

Public Static Methods

ForCodePage | Gets the encoding corresponding to the given code page.
ForID | Gets the encoding registered under the given unique ID with the Internet Assigned Numbers Authority (IANA).
ForName | Gets the encoding with the given name.

Public Instance Properties

AllNames | [read] The list of known names for this encoding. The first name is always the common name. If this encoding has both a preferred MIME name and a regsitered IANA name, and they are different, then the second entry is the regsitered IANA name. Other names appear in an arbitrary order.
CodePage | [read] The code page of this encoding, or CODEPAGE_UNKNOWN (-1) if this encoding does not have a corresponding code page, or if the code page cannot be represented by a number (e.g., "Cp949C").
IsReadingSupported | [read] true if this encoding is supported for reading by this platform; false otherwise.
IsSupported | [read] true if this encoding is fully supported (for both reading and writing) by this platform; false otherwise.
IsWritingSupported | [read] true if this encoding is supported for writing by this platform; false otherwise.
MimeName | [read] The preferred MIME name of this encoding, or null if this encoding does not have a preferred MIME name.
Name | [read] The common name of this encoding. If this encoding has a preferred MIME name, then that is always used as the common name. Otherwise, if the encoding is registered with IANA, then that is used as the common name. Otherwise, the common name is the preferred Java alias for this encoding.
PlatformName | [read] The name by which this encoding is known on this platform. If the encoding is known by multiple names, then the preferred name is returned. Returns null if this encoding is not fully supported (for both reading and writing) by this platform.
PlatformNameForReading | [read] A name that can be used to read this encoding on this platform. If multiple names can be used to read this encoding, then the preferred name for reading is returned. Returns null if reading is not supported for this encoding by this platform.
PlatformNameForWriting | [read] A name that can be used to write this encoding on this platform. If multiple names can be used to write this encoding, then the preferred name for writing is returned. Returns null if writing is not supported for this encoding by this platform.
RegisteredID | [read] The registered name of this encoding, or ID_UNKNOWN (-1) if this encoding is not registered with IANA, or was not assigned a unique ID.
RegisteredName | [read] The registered name of this encoding, or null if this encoding is not registered with IANA.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Encoding.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Encoding.
GetType (inherited from Object) | Gets the Type of the current instance.
IsNamed | Determines whether or not the given name refers to this encoding.
ToString | Delegate ToString() to com.starteam.util.Encoding.

See Also

Encoding Class | StarTeam.Util Namespace


Encoding Properties

The properties of the Encoding class are listed below. For a complete list of Encoding class members, see the Encoding Members topic.

Public Static Properties

AllKnownEncodings | [read] A list of all known encodings, including ones that are not supported by the current platform. The encodings are sorted by name.
CODEPAGE_UNKNOWN |
DefaultPlatformEncoding | [read] The default platform encoding. Never returns null.
DefaultStarTeamEncoding | [read/write] The default StarTeam encoding. Never returns null.
ID_UNKNOWN |
ISO_8859_1 |
ReadableEncodings | [read] A list of all known encodings that are supported for reading (and possibly also writing) by the current platform. The encodings are sorted by the name used for reading on this platform.
STARTEAM_PROPERTY |
SupportedEncodings | [read] A list of all known encodings that are fully supported (for both reading and writing) by the current platform. The encodings are sorted by the name they are known by on this platform.
US_ASCII |
UTF_16 |
UTF_16BE |
UTF_16LE |
UTF_32 |
UTF_32BE |
UTF_32LE |
UTF_8 |
WritableEncodings | [read] A list of all known encodings that are supported for writing (and possibly also reading) by the current platform. The encodings are sorted by the name used for writing on this platform.

Public Instance Properties

AllNames | [read] The list of known names for this encoding. The first name is always the common name. If this encoding has both a preferred MIME name and a regsitered IANA name, and they are different, then the second entry is the regsitered IANA name. Other names appear in an arbitrary order.
CodePage | [read] The code page of this encoding, or CODEPAGE_UNKNOWN (-1) if this encoding does not have a corresponding code page, or if the code page cannot be represented by a number (e.g., "Cp949C").
IsReadingSupported | [read] true if this encoding is supported for reading by this platform; false otherwise.
IsSupported | [read] true if this encoding is fully supported (for both reading and writing) by this platform; false otherwise.
IsWritingSupported | [read] true if this encoding is supported for writing by this platform; false otherwise.
MimeName | [read] The preferred MIME name of this encoding, or null if this encoding does not have a preferred MIME name.
Name | [read] The common name of this encoding. If this encoding has a preferred MIME name, then that is always used as the common name. Otherwise, if the encoding is registered with IANA, then that is used as the common name. Otherwise, the common name is the preferred Java alias for this encoding.
PlatformName | [read] The name by which this encoding is known on this platform. If the encoding is known by multiple names, then the preferred name is returned. Returns null if this encoding is not fully supported (for both reading and writing) by this platform.
PlatformNameForReading | [read] A name that can be used to read this encoding on this platform. If multiple names can be used to read this encoding, then the preferred name for reading is returned. Returns null if reading is not supported for this encoding by this platform.
PlatformNameForWriting | [read] A name that can be used to write this encoding on this platform. If multiple names can be used to write this encoding, then the preferred name for writing is returned. Returns null if writing is not supported for this encoding by this platform.
RegisteredID | [read] The registered name of this encoding, or ID_UNKNOWN (-1) if this encoding is not registered with IANA, or was not assigned a unique ID.
RegisteredName | [read] The registered name of this encoding, or null if this encoding is not registered with IANA.

See Also

Encoding Class | StarTeam.Util Namespace


AllKnownEncodings Property

Borland StarTeam SDK for .NET

Encoding.AllKnownEncodings Property

[read] A list of all known encodings, including ones that are not supported by the current platform. The encodings are sorted by name.

public static Encoding[] AllKnownEncodings {get;}

Property Value

A list of all known encodings, including ones that are not supported by the current platform. The encodings are sorted by name.

See Also

Encoding Class | StarTeam.Util Namespace


AllNames Property

Borland StarTeam SDK for .NET

Encoding.AllNames Property

[read] The list of known names for this encoding. The first name is always the common name. If this encoding has both a preferred MIME name and a regsitered IANA name, and they are different, then the second entry is the regsitered IANA name. Other names appear in an arbitrary order.

public virtual String[] AllNames {get;}

Property Value

The list of known names for this encoding. The first name is always the common name. If this encoding has both a preferred MIME name and a regsitered IANA name, and they are different, then the second entry is the regsitered IANA name. Other names appear in an arbitrary order.

See Also

Encoding Class | StarTeam.Util Namespace


CodePage Property

Borland StarTeam SDK for .NET

Encoding.CodePage Property

[read] The code page of this encoding, or CODEPAGE_UNKNOWN (-1) if this encoding does not have a corresponding code page, or if the code page cannot be represented by a number (e.g., "Cp949C").

public virtual Int32 CodePage {get;}

Property Value

The code page of this encoding, or CODEPAGE_UNKNOWN (-1) if this encoding does not have a corresponding code page, or if the code page cannot be represented by a number (e.g., "Cp949C").

See Also

Encoding Class | StarTeam.Util Namespace


CODEPAGE_UNKNOWN Property

Borland StarTeam SDK for .NET

Encoding.CODEPAGE_UNKNOWN Property

public static Int32 CODEPAGE_UNKNOWN {get;}

See Also

Encoding Class | StarTeam.Util Namespace


DefaultPlatformEncoding Property

Borland StarTeam SDK for .NET

Encoding.DefaultPlatformEncoding Property

[read] The default platform encoding. Never returns null.

public static Encoding DefaultPlatformEncoding {get;}

Property Value

The default platform encoding. Never returns null.

See Also

Encoding Class | StarTeam.Util Namespace


DefaultStarTeamEncoding Property

Borland StarTeam SDK for .NET

Encoding.DefaultStarTeamEncoding Property

[read/write] The default StarTeam encoding. Never returns null.

public static Encoding DefaultStarTeamEncoding {get; set;}

Property Value

The default StarTeam encoding. Never returns null.

See Also

Encoding Class | StarTeam.Util Namespace


ID_UNKNOWN Property

Borland StarTeam SDK for .NET

Encoding.ID_UNKNOWN Property

public static Int32 ID_UNKNOWN {get;}

See Also

Encoding Class | StarTeam.Util Namespace


ISO_8859_1 Property

Borland StarTeam SDK for .NET

Encoding.ISO_8859_1 Property

public static Encoding ISO_8859_1 {get;}

Property Value

ISO Latin Alphabet 1 (ISO-LATIN-1).

See Also

Encoding Class | StarTeam.Util Namespace


IsReadingSupported Property

Borland StarTeam SDK for .NET

Encoding.IsReadingSupported Property

[read] true if this encoding is supported for reading by this platform; false otherwise.

public virtual Boolean IsReadingSupported {get;}

Property Value

true if this encoding is supported for reading by this platform; false otherwise.

See Also

Encoding Class | StarTeam.Util Namespace


IsSupported Property

Borland StarTeam SDK for .NET

Encoding.IsSupported Property

[read] true if this encoding is fully supported (for both reading and writing) by this platform; false otherwise.

public virtual Boolean IsSupported {get;}

Property Value

true if this encoding is fully supported (for both reading and writing) by this platform; false otherwise.

See Also

Encoding Class | StarTeam.Util Namespace


IsWritingSupported Property

Borland StarTeam SDK for .NET

Encoding.IsWritingSupported Property

[read] true if this encoding is supported for writing by this platform; false otherwise.

public virtual Boolean IsWritingSupported {get;}

Property Value

true if this encoding is supported for writing by this platform; false otherwise.

See Also

Encoding Class | StarTeam.Util Namespace


MimeName Property

Borland StarTeam SDK for .NET

Encoding.MimeName Property

[read] The preferred MIME name of this encoding, or null if this encoding does not have a preferred MIME name.

public virtual String MimeName {get;}

Property Value

The preferred MIME name of this encoding, or null if this encoding does not have a preferred MIME name.

See Also

Encoding Class | StarTeam.Util Namespace


Name Property

Borland StarTeam SDK for .NET

Encoding.Name Property

[read] The common name of this encoding. If this encoding has a preferred MIME name, then that is always used as the common name. Otherwise, if the encoding is registered with IANA, then that is used as the common name. Otherwise, the common name is the preferred Java alias for this encoding.

public virtual String Name {get;}

Property Value

The common name of this encoding. If this encoding has a preferred MIME name, then that is always used as the common name. Otherwise, if the encoding is registered with IANA, then that is used as the common name. Otherwise, the common name is the preferred Java alias for this encoding.

See Also

Encoding Class | StarTeam.Util Namespace


PlatformName Property

Borland StarTeam SDK for .NET

Encoding.PlatformName Property

[read] The name by which this encoding is known on this platform. If the encoding is known by multiple names, then the preferred name is returned. Returns null if this encoding is not fully supported (for both reading and writing) by this platform.

public virtual String PlatformName {get;}

Property Value

The name by which this encoding is known on this platform. If the encoding is known by multiple names, then the preferred name is returned. Returns null if this encoding is not fully supported (for both reading and writing) by this platform.

See Also

Encoding Class | StarTeam.Util Namespace


PlatformNameForReading Property

Borland StarTeam SDK for .NET

Encoding.PlatformNameForReading Property

[read] A name that can be used to read this encoding on this platform. If multiple names can be used to read this encoding, then the preferred name for reading is returned. Returns null if reading is not supported for this encoding by this platform.

public virtual String PlatformNameForReading {get;}

Property Value

A name that can be used to read this encoding on this platform. If multiple names can be used to read this encoding, then the preferred name for reading is returned. Returns null if reading is not supported for this encoding by this platform.

See Also

Encoding Class | StarTeam.Util Namespace


PlatformNameForWriting Property

Borland StarTeam SDK for .NET

Encoding.PlatformNameForWriting Property

[read] A name that can be used to write this encoding on this platform. If multiple names can be used to write this encoding, then the preferred name for writing is returned. Returns null if writing is not supported for this encoding by this platform.

public virtual String PlatformNameForWriting {get;}

Property Value

A name that can be used to write this encoding on this platform. If multiple names can be used to write this encoding, then the preferred name for writing is returned. Returns null if writing is not supported for this encoding by this platform.

See Also

Encoding Class | StarTeam.Util Namespace


ReadableEncodings Property

Borland StarTeam SDK for .NET

Encoding.ReadableEncodings Property

[read] A list of all known encodings that are supported for reading (and possibly also writing) by the current platform. The encodings are sorted by the name used for reading on this platform.

public static Encoding[] ReadableEncodings {get;}

Property Value

A list of all known encodings that are supported for reading (and possibly also writing) by the current platform. The encodings are sorted by the name used for reading on this platform.

See Also

Encoding Class | StarTeam.Util Namespace


RegisteredID Property

Borland StarTeam SDK for .NET

Encoding.RegisteredID Property

[read] The registered name of this encoding, or ID_UNKNOWN (-1) if this encoding is not registered with IANA, or was not assigned a unique ID.

public virtual Int32 RegisteredID {get;}

Property Value

The registered name of this encoding, or ID_UNKNOWN (-1) if this encoding is not registered with IANA, or was not assigned a unique ID.

See Also

Encoding Class | StarTeam.Util Namespace


RegisteredName Property

Borland StarTeam SDK for .NET

Encoding.RegisteredName Property

[read] The registered name of this encoding, or null if this encoding is not registered with IANA.

public virtual String RegisteredName {get;}

Property Value

The registered name of this encoding, or null if this encoding is not registered with IANA.

See Also

Encoding Class | StarTeam.Util Namespace


STARTEAM_PROPERTY Property

Borland StarTeam SDK for .NET

Encoding.STARTEAM_PROPERTY Property

public static String STARTEAM_PROPERTY {get;}

See Also

Encoding Class | StarTeam.Util Namespace


SupportedEncodings Property

Borland StarTeam SDK for .NET

Encoding.SupportedEncodings Property

[read] A list of all known encodings that are fully supported (for both reading and writing) by the current platform. The encodings are sorted by the name they are known by on this platform.

public static Encoding[] SupportedEncodings {get;}

Property Value

A list of all known encodings that are fully supported (for both reading and writing) by the current platform. The encodings are sorted by the name they are known by on this platform.

See Also

Encoding Class | StarTeam.Util Namespace


US_ASCII Property

Borland StarTeam SDK for .NET

Encoding.US_ASCII Property

public static Encoding US_ASCII {get;}

Property Value

Seven-bit ASCII (ISO646-US, the Basic Latin block of the Unicode character set).

See Also

Encoding Class | StarTeam.Util Namespace


UTF_16 Property

Borland StarTeam SDK for .NET

Encoding.UTF_16 Property

public static Encoding UTF_16 {get;}

Property Value

Sixteen-bit UCS Transformation Format, byte-order identified by an optional byte-order mark.

See Also

Encoding Class | StarTeam.Util Namespace


UTF_16BE Property

Borland StarTeam SDK for .NET

Encoding.UTF_16BE Property

public static Encoding UTF_16BE {get;}

Property Value

Sixteen-bit UCS Transformation Format, big-endian byte-order.

See Also

Encoding Class | StarTeam.Util Namespace


UTF_16LE Property

Borland StarTeam SDK for .NET

Encoding.UTF_16LE Property

public static Encoding UTF_16LE {get;}

Property Value

Sixteen-bit UCS Transformation Format, little-endian byte-order.

See Also

Encoding Class | StarTeam.Util Namespace


UTF_32 Property

Borland StarTeam SDK for .NET

Encoding.UTF_32 Property

public static Encoding UTF_32 {get;}

Property Value

32-bit UCS Transformation Format, byte-order identified by an optional byte-order mark.

See Also

Encoding Class | StarTeam.Util Namespace


UTF_32BE Property

Borland StarTeam SDK for .NET

Encoding.UTF_32BE Property

public static Encoding UTF_32BE {get;}

Property Value

32-bit UCS Transformation Format, big-endian byte-order.

See Also

Encoding Class | StarTeam.Util Namespace


UTF_32LE Property

Borland StarTeam SDK for .NET

Encoding.UTF_32LE Property

public static Encoding UTF_32LE {get;}

Property Value

32-bit UCS Transformation Format, little-endian byte-order.

See Also

Encoding Class | StarTeam.Util Namespace


UTF_8 Property

Borland StarTeam SDK for .NET

Encoding.UTF_8 Property

public static Encoding UTF_8 {get;}

Property Value

Eight-bit UCS Transformation Format.

See Also

Encoding Class | StarTeam.Util Namespace


WritableEncodings Property

Borland StarTeam SDK for .NET

Encoding.WritableEncodings Property

[read] A list of all known encodings that are supported for writing (and possibly also reading) by the current platform. The encodings are sorted by the name used for writing on this platform.

public static Encoding[] WritableEncodings {get;}

Property Value

A list of all known encodings that are supported for writing (and possibly also reading) by the current platform. The encodings are sorted by the name used for writing on this platform.

See Also

Encoding Class | StarTeam.Util Namespace


Encoding Methods

The methods of the Encoding class are listed below. For a complete list of Encoding class members, see the Encoding Members topic.

Public Static Methods

ForCodePage | Gets the encoding corresponding to the given code page.
ForID | Gets the encoding registered under the given unique ID with the Internet Assigned Numbers Authority (IANA).
ForName | Gets the encoding with the given name.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Encoding.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Encoding.
GetType (inherited from Object) | Gets the Type of the current instance.
IsNamed | Determines whether or not the given name refers to this encoding.
ToString | Delegate ToString() to com.starteam.util.Encoding.

See Also

Encoding Class | StarTeam.Util Namespace


Encoding.Equals Method

Delegate Equals() to com.starteam.util.Encoding.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.Encoding.Equals(obj).

See Also

Encoding Class | StarTeam.Util Namespace


Encoding.ForCodePage Method

Gets the encoding corresponding to the given code page.

public static Encoding ForCodePage(
Int32 cp
);

Parameters

cp
The code page of the desired encoding.

Return Value

The corresponding code page, or null if there is no such encoding.

See Also

Encoding Class | StarTeam.Util Namespace | getCodePage


Encoding.ForID Method

Gets the encoding registered under the given unique ID with the Internet Assigned Numbers Authority (IANA).

public static Encoding ForID(
Int32 id
);

Parameters

id
The MIBenum of the desired encoding, as registered with IANA.

Return Value

The corresponding encoding, or null if there is no such encoding.

See Also

Encoding Class | StarTeam.Util Namespace | getRegisteredID


Encoding.ForName Method

Gets the encoding with the given name.

public static Encoding ForName(
String name
);

Parameters

name
An encoding name. May be the common name, the registered IANA name, or any known alias. Encoding names are not case sensitive.

Return Value

The corresponding encoding, or null if there is no such encoding.

See Also

Encoding Class | StarTeam.Util Namespace | getAllNames


Encoding.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.Encoding.

public override int GetHashCode();

Return Value

com.starteam.util.Encoding.GetHashCode().

See Also

Encoding Class | StarTeam.Util Namespace


Encoding.IsNamed Method

Determines whether or not the given name refers to this encoding.

public virtual bool IsNamed(
String name
);

Parameters

name
The name to be tested. Encoding names are not case sensitive.

Return Value

true if the given name refers to this encoding; false otherwise.

See Also

Encoding Class | StarTeam.Util Namespace | getAllNames


Encoding.ToString Method

Delegate ToString() to com.starteam.util.Encoding.

public override string ToString();

Return Value

com.starteam.util.Encoding.ToString()

See Also

Encoding Class | StarTeam.Util Namespace


EOLReader Class

For a list of all members of this type, see EOLReader Members.

System.Object
LineProcessor
EOLReader

public class EOLReader : LineProcessor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

EOLReader Members | StarTeam.Util Namespace


EOLReader Members

EOLReader overview

Public Instance Constructors

EOLReader Constructor

Public Instance Methods

EndofInput (inherited from LineProcessor) |
Equals (inherited from LineProcessor) | Delegate Equals() to com.starteam.util.LineProcessor.
GetHashCode (inherited from LineProcessor) | Delegate GetHashCode() to com.starteam.util.LineProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine (inherited from LineProcessor) |
ToString (inherited from LineProcessor) | Delegate ToString() to com.starteam.util.LineProcessor.

See Also

EOLReader Class | StarTeam.Util Namespace


EOLReader Constructor

public EOLReader(
LineReader source,
String newEOL
);

See Also

EOLReader Class | StarTeam.Util Namespace


FileAccess Class

For a list of all members of this type, see FileAccess Members.

System.Object
FileAccess

public class FileAccess

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

FileAccess Members | StarTeam.Util Namespace


FileAccess Members

FileAccess overview

Public Instance Methods

CreateSymbolicLink |
Equals | Delegate Equals() to com.starteam.util.FileAccess.
GetCanWrite |
GetFileLength |
GetHashCode | Delegate GetHashCode() to com.starteam.util.FileAccess.
GetIsExecutable |
GetLastModified |
GetSymbolicLinkTarget |
GetType (inherited from Object) | Gets the Type of the current instance.
IsRemoteDrive |
IsSymbolicLink |
LoadFileAttributes |
SetCanWrite |
SetIsExecutable |
SetLastModified |
ToString | Delegate ToString() to com.starteam.util.FileAccess.

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess Methods

The methods of the FileAccess class are listed below. For a complete list of FileAccess class members, see the FileAccess Members topic.

Public Instance Methods

CreateSymbolicLink |
Equals | Delegate Equals() to com.starteam.util.FileAccess.
GetCanWrite |
GetFileLength |
GetHashCode | Delegate GetHashCode() to com.starteam.util.FileAccess.
GetIsExecutable |
GetLastModified |
GetSymbolicLinkTarget |
GetType (inherited from Object) | Gets the Type of the current instance.
IsRemoteDrive |
IsSymbolicLink |
LoadFileAttributes |
SetCanWrite |
SetIsExecutable |
SetLastModified |
ToString | Delegate ToString() to com.starteam.util.FileAccess.

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.CreateSymbolicLink Method

public virtual void CreateSymbolicLink(
String link,
String targetPath
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.Equals Method

Delegate Equals() to com.starteam.util.FileAccess.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.FileAccess.Equals(obj).

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.GetCanWrite Method

public virtual bool GetCanWrite(
String file
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.GetFileLength Method

public virtual long GetFileLength(
String file
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.FileAccess.

public override int GetHashCode();

Return Value

com.starteam.util.FileAccess.GetHashCode().

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.GetIsExecutable Method

public virtual bool GetIsExecutable(
String file
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.GetLastModified Method

public virtual long GetLastModified(
String file
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.GetSymbolicLinkTarget Method

public virtual string GetSymbolicLinkTarget(
String absolutePath
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.IsRemoteDrive Method

public virtual bool IsRemoteDrive(
String file
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.IsSymbolicLink Method

public virtual bool IsSymbolicLink(
String absolutePath
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.LoadFileAttributes Method

public virtual void LoadFileAttributes(
Attributes[] attributes
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.SetCanWrite Method

public virtual void SetCanWrite(
String file,
Boolean value
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.SetIsExecutable Method

public virtual void SetIsExecutable(
String file,
Boolean executable
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.SetLastModified Method

public virtual void SetLastModified(
String file,
Int64 time
);

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.ToString Method

Delegate ToString() to com.starteam.util.FileAccess.

public override string ToString();

Return Value

com.starteam.util.FileAccess.ToString()

See Also

FileAccess Class | StarTeam.Util Namespace


FileAccess.Attributes Class

Attributes of a working file on disk

For a list of all members of this type, see FileAccess.Attributes Members.

System.Object
FileAccess.Attributes

public class FileAccess.Attributes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

FileAccess.Attributes Members | StarTeam.Util Namespace


FileAccess.Attributes Members

FileAccess.Attributes overview

Public Instance Constructors

FileAccess.Attributes Constructor Create a new instance

Public Instance Properties

creationTime
fileName
isDirectory
lastAccessTime
lastModifiedTime
size

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.FileAccess.Attributes.
GetHashCode | Delegate GetHashCode() to com.starteam.util.FileAccess.Attributes.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.FileAccess.Attributes.

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


FileAccess.Attributes Constructor

Create a new instance

public FileAccess.Attributes();

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


FileAccess.Attributes Properties

The properties of the FileAccess.Attributes class are listed below. For a complete list of FileAccess.Attributes class members, see the FileAccess.Attributes Members topic.

Public Instance Properties

creationTime
fileName
isDirectory
lastAccessTime
lastModifiedTime
size

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


creationTime Property

Borland StarTeam SDK for .NET

FileAccess.Attributes.creationTime Property

public Int64 creationTime {get; set;}

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


fileName Property

Borland StarTeam SDK for .NET

FileAccess.Attributes.fileName Property

public String fileName {get; set;}

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


isDirectory Property

Borland StarTeam SDK for .NET

FileAccess.Attributes.isDirectory Property

public Boolean isDirectory {get; set;}

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


lastAccessTime Property

Borland StarTeam SDK for .NET

FileAccess.Attributes.lastAccessTime Property

public Int64 lastAccessTime {get; set;}

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


lastModifiedTime Property

Borland StarTeam SDK for .NET

FileAccess.Attributes.lastModifiedTime Property

public Int64 lastModifiedTime {get; set;}

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


size Property

Borland StarTeam SDK for .NET

FileAccess.Attributes.size Property

public Int64 size {get; set;}

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


FileAccess.Attributes Methods

The methods of the FileAccess.Attributes class are listed below. For a complete list of FileAccess.Attributes class members, see the FileAccess.Attributes Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.FileAccess.Attributes.
GetHashCode | Delegate GetHashCode() to com.starteam.util.FileAccess.Attributes.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.FileAccess.Attributes.

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


FileAccess.Attributes.Equals Method

Delegate Equals() to com.starteam.util.FileAccess.Attributes.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.FileAccess.Attributes.Equals(obj).

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


FileAccess.Attributes.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.FileAccess.Attributes.

public override int GetHashCode();

Return Value

com.starteam.util.FileAccess.Attributes.GetHashCode().

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


FileAccess.Attributes.ToString Method

Delegate ToString() to com.starteam.util.FileAccess.Attributes.

public override string ToString();

Return Value

com.starteam.util.FileAccess.Attributes.ToString()

See Also

FileAccess.Attributes Class | StarTeam.Util Namespace


FileUtils Class

Utility class for accessing file info.

For a list of all members of this type, see FileUtils Members.

System.Object
FileUtils

public class FileUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

FileUtils Members | StarTeam.Util Namespace


FileUtils Members

FileUtils overview

Public Static Methods

Cmp | compare two files
CondenseFilePaths | Compares the two paths and returns a relative path that represents the childFolderPath relative to parentFolderPath or null if either of the paths passed in are already relative or invalid, or if childFolderPath cannot be expressed relative to parentFolderPath. Both c: and \folderName are invalid paths for the purposes of this function. GetCanonicalPathName is called on both paths prior to comparison. This function is essentially Windows-specific, but should work correctly with at least Unix paths.
ConvertUnicodeEol | Convert an end-of-line string that is assumed to be in ANSI format, to one of our known and supported Unicode encodings. If we're unable to confidently convert it, the original string is returned.
FullyResolvedPath | returns a fully resolved path name
GetAbsolutePath | Returns the absolute pathname of the given pathname. If the pathname is an absolute pathname, then return the pathname. Otherwise, return a pathname that is a concatenation of the current user directory, the separator character, and the pathname of this file object. The system property user.dir contains the current user directory.
GetCanonicalPathName | returns the canonical path name
GetCharacterSet | Determines the character set used by the given file.
GetEncoding | Overloaded. Return the detected encoding for the byte buffer, or US_ASCII if we can't determine the encoding.
GetName | Returns the name of the file represented by this pathname. The name is everything in the pathame after the last occurrence of the separator character.
GetParent | Returns the parent part of the given pathname, or null if the name has no parent part. The parent part is generally everything leading up to the last occurrence of the separator character, although the precise definition is system dependent. On UNIX, for example, the parent part of "/usr/lib" is "/usr", whose parent part is "/", which in turn has no parent. On Windows platforms, the parent part of "c:\java" is "c:\", which in turn has no parent.
IsAbsolute | Tests if the given pathname is an absolute pathname. The definition of an absolute pathname is system dependent. For example, on UNIX, a pathname is absolute if its first character is the separator character. On Windows platforms, a pathname is absolute if its first character is an ASCII '\' or '/', or if it begins with a letter followed by a colon.
IsBinary | Returns true if the file is considered to be binary. The definition of binary is that the file has at least one null (0x0) character and has not been identified as a unicode text file.
IsUnicode | Overloaded. Returns true if the byte buffer indicates Unicode.
Match | match the file name to the pattern
MatchesAnyPattern | match a file name against a set of patterns
MatchPatternList | match a file name against a set of patterns
ParsePatternList | parse the given comma, space or semicolon delimited pattern list

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.FileUtils.
GetHashCode | Delegate GetHashCode() to com.starteam.util.FileUtils.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.FileUtils.

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils Methods

The methods of the FileUtils class are listed below. For a complete list of FileUtils class members, see the FileUtils Members topic.

Public Static Methods

Cmp | compare two files
CondenseFilePaths | Compares the two paths and returns a relative path that represents the childFolderPath relative to parentFolderPath or null if either of the paths passed in are already relative or invalid, or if childFolderPath cannot be expressed relative to parentFolderPath. Both c: and \folderName are invalid paths for the purposes of this function. GetCanonicalPathName is called on both paths prior to comparison. This function is essentially Windows-specific, but should work correctly with at least Unix paths.
ConvertUnicodeEol | Convert an end-of-line string that is assumed to be in ANSI format, to one of our known and supported Unicode encodings. If we're unable to confidently convert it, the original string is returned.
FullyResolvedPath | returns a fully resolved path name
GetAbsolutePath | Returns the absolute pathname of the given pathname. If the pathname is an absolute pathname, then return the pathname. Otherwise, return a pathname that is a concatenation of the current user directory, the separator character, and the pathname of this file object. The system property user.dir contains the current user directory.
GetCanonicalPathName | returns the canonical path name
GetCharacterSet | Determines the character set used by the given file.
GetEncoding | Overloaded. Return the detected encoding for the byte buffer, or US_ASCII if we can't determine the encoding.
GetName | Returns the name of the file represented by this pathname. The name is everything in the pathame after the last occurrence of the separator character.
GetParent | Returns the parent part of the given pathname, or null if the name has no parent part. The parent part is generally everything leading up to the last occurrence of the separator character, although the precise definition is system dependent. On UNIX, for example, the parent part of "/usr/lib" is "/usr", whose parent part is "/", which in turn has no parent. On Windows platforms, the parent part of "c:\java" is "c:\", which in turn has no parent.
IsAbsolute | Tests if the given pathname is an absolute pathname. The definition of an absolute pathname is system dependent. For example, on UNIX, a pathname is absolute if its first character is the separator character. On Windows platforms, a pathname is absolute if its first character is an ASCII '\' or '/', or if it begins with a letter followed by a colon.
IsBinary | Returns true if the file is considered to be binary. The definition of binary is that the file has at least one null (0x0) character and has not been identified as a unicode text file.
IsUnicode | Overloaded. Returns true if the byte buffer indicates Unicode.
Match | match the file name to the pattern
MatchesAnyPattern | match a file name against a set of patterns
MatchPatternList | match a file name against a set of patterns
ParsePatternList | parse the given comma, space or semicolon delimited pattern list

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.FileUtils.
GetHashCode | Delegate GetHashCode() to com.starteam.util.FileUtils.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.FileUtils.

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.Cmp Method

compare two files

public static long Cmp(
FileInfo f1,
FileInfo f2
);

Parameters

f1
the first file
f2
the second file

Return Value

the position where the two files differ or -1

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.CondenseFilePaths Method

Compares the two paths and returns a relative path that represents the childFolderPath relative to parentFolderPath or null if either of the paths passed in are already relative or invalid, or if childFolderPath cannot be expressed relative to parentFolderPath.

Both c: and \folderName are invalid paths for the purposes of this function. GetCanonicalPathName is called on both paths prior to comparison. This function is essentially Windows-specific, but should work correctly with at least Unix paths.

public static string CondenseFilePaths(
String parentFolderPath,
String childFolderPath,
Boolean caseSensitive,
String delimiter
);

Parameters

parentFolderPath
the parent path
childFolderPath
the child path
caseSensitive
true for a case sensistive comparison
delimiter
the inter path separator

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.ConvertUnicodeEol Method

Convert an end-of-line string that is assumed to be in ANSI format, to one of our known and supported Unicode encodings. If we're unable to confidently convert it, the original string is returned.

public static string ConvertUnicodeEol(
String eol,
Encoding enc
);

Parameters

eol
an end-of-line string in ANSI format. Should be one of "\r\n", "\r", "\n".
enc
the encoding to convert to. Must be one of UTF-16LE, UTF-16BE, UTF-32LE or UTF-32BE to be converted.

Return Value

the converted end-of-line string.

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.Equals Method

Delegate Equals() to com.starteam.util.FileUtils.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.FileUtils.Equals(obj).

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.FullyResolvedPath Method

returns a fully resolved path name

public static string FullyResolvedPath(
String name,
String pathDelim
);

Parameters

name
the file name
pathDelim
a path delimiter

Return Value

a fully resolved canonical path name

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.GetAbsolutePath Method

Returns the absolute pathname of the given pathname. If the pathname is an absolute pathname, then return the pathname. Otherwise, return a pathname that is a concatenation of the current user directory, the separator character, and the pathname of this file object.

The system property user.dir contains the current user directory.

public static string GetAbsolutePath(
String path
);

Parameters

path
A pathname.

Return Value

a system-dependent absolute pathname.

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.GetCanonicalPathName Method

returns the canonical path name

public static string GetCanonicalPathName(
String aPathName,
Boolean bCaseSensitive
);

Parameters

aPathName
the relative path name
bCaseSensitive
true if case sensitive comparison

Return Value

the canonical path name

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.GetCharacterSet Method

Determines the character set used by the given file.

public static CharacterSet GetCharacterSet(
FileInfo f
);

Parameters

f
File

Return Value

A CharacterSet.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileUtils Class | StarTeam.Util Namespace


GetEncoding Method

Borland StarTeam SDK for .NET

FileUtils.GetEncoding Method

Return the detected encoding for the byte buffer, or US_ASCII if we can't determine the encoding.

Overload List

Return the detected encoding for the byte buffer, or US_ASCII if we can't determine the encoding.

public static Encoding GetEncoding(Byte[],Int32);

Return the detected encoding for the file

public static Encoding GetEncoding(FileInfo);

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.GetEncoding Method (Byte[], Int32)

Return the detected encoding for the byte buffer, or US_ASCII if we can't determine the encoding.

public static Encoding GetEncoding(
Byte[] buf,
Int32 count
);

Parameters

buf
the byte buffer to check.
count
length of the buffer.

Return Value

the detected encoding.

See Also

FileUtils Class | StarTeam.Util Namespace | FileUtils.GetEncoding Overload List


FileUtils.GetEncoding Method (FileInfo)

Return the detected encoding for the file

public static Encoding GetEncoding(
FileInfo f
);

Parameters

f
A file whose encoding will be detected

Return Value

the Encoding as determined for the file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileUtils Class | StarTeam.Util Namespace | FileUtils.GetEncoding Overload List


FileUtils.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.FileUtils.

public override int GetHashCode();

Return Value

com.starteam.util.FileUtils.GetHashCode().

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.GetName Method

Returns the name of the file represented by this pathname. The name is everything in the pathame after the last occurrence of the separator character.

public static string GetName(
String path,
String pathDelim
);

Parameters

path
A pathname.
pathDelim
The path delimiter.

Return Value

the name of the file (without any directory components) represented by this pathname.

See Also

FileUtils Class | StarTeam.Util Namespace | getParent


FileUtils.GetParent Method

Returns the parent part of the given pathname, or null if the name has no parent part. The parent part is generally everything leading up to the last occurrence of the separator character, although the precise definition is system dependent. On UNIX, for example, the parent part of "/usr/lib" is "/usr", whose parent part is "/", which in turn has no parent. On Windows platforms, the parent part of "c:\java" is "c:\", which in turn has no parent.

public static string GetParent(
String path,
String pathDelim
);

Parameters

path
A pathname.
pathDelim
The path delimiter.

Return Value

The parent part of the pathname, or null if the name has no parent part.

See Also

FileUtils Class | StarTeam.Util Namespace | getName


FileUtils.IsAbsolute Method

Tests if the given pathname is an absolute pathname. The definition of an absolute pathname is system dependent. For example, on UNIX, a pathname is absolute if its first character is the separator character. On Windows platforms, a pathname is absolute if its first character is an ASCII '\' or '/', or if it begins with a letter followed by a colon.

public static bool IsAbsolute(
String path
);

Parameters

path
A pathname.

Return Value

true if the pathname indicated by the File object is an absolute pathname; false otherwise.

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.IsBinary Method

Returns true if the file is considered to be binary. The definition of binary is that the file has at least one null (0x0) character and has not been identified as a unicode text file.

public static bool IsBinary(
FileInfo f
);

Parameters

f
the file to test

Return Value

true if the file is considered binary

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileUtils Class | StarTeam.Util Namespace


IsUnicode Method

Borland StarTeam SDK for .NET

FileUtils.IsUnicode Method

Returns true if the byte buffer indicates Unicode.

Overload List

Returns true if the byte buffer indicates Unicode.

public static bool IsUnicode(Byte[],Int32);

Returns true if the file is considered to be Unicode.

public static bool IsUnicode(FileInfo);

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.IsUnicode Method (Byte[], Int32)

Returns true if the byte buffer indicates Unicode.

public static bool IsUnicode(
Byte[] buf,
Int32 count
);

Parameters

buf
the byte buffer to check.
count
length of the buffer.

Return Value

true if the buffer indicates Unicode.

See Also

FileUtils Class | StarTeam.Util Namespace | FileUtils.IsUnicode Overload List


FileUtils.IsUnicode Method (FileInfo)

Returns true if the file is considered to be Unicode.

public static bool IsUnicode(
FileInfo f
);

Parameters

f
the file to test

Return Value

true if the file is considered unicode

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileUtils Class | StarTeam.Util Namespace | FileUtils.IsUnicode Overload List


FileUtils.Match Method

match the file name to the pattern

public static bool Match(
String pattern,
String file,
Boolean caseSensitive
);

Parameters

pattern
the pattern
file
the file name
caseSensitive
true if case sensitive comaprison is required

Return Value

true if a match is discovered

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.MatchesAnyPattern Method

match a file name against a set of patterns

public static bool MatchesAnyPattern(
String filename,
String[] patterns,
Boolean caseSensitive
);

Parameters

filename
the file name
patterns
a set of patterns
caseSensitive
true if case sensitive

Return Value

true if at least one match is discovered

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.MatchPatternList Method

match a file name against a set of patterns

public static bool MatchPatternList(
String filename,
String patternList,
Boolean caseSensitive
);

Parameters

filename
the file name
patternList
a list of patterns
caseSensitive
true if case sensitive

Return Value

true if at least one match is discovered

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.ParsePatternList Method

parse the given comma, space or semicolon delimited pattern list

public static string[] ParsePatternList(
String patternList
);

Parameters

patternList
the pattern list

Return Value

an array of patterns

See Also

FileUtils Class | StarTeam.Util Namespace


FileUtils.ToString Method

Delegate ToString() to com.starteam.util.FileUtils.

public override string ToString();

Return Value

com.starteam.util.FileUtils.ToString()

See Also

FileUtils Class | StarTeam.Util Namespace


GUID Class

Generates a Globally unique identifier

For a list of all members of this type, see GUID Members.

System.Object
GUID

public class GUID

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

GUID Members | StarTeam.Util Namespace


GUID Members

GUID overview

Public Instance Constructors

GUID Overloaded. Initializes a new instance of the GUID class.

Public Instance Properties

ByteString | [read] hex representation of the GUID
CanonicalFormat | [read]
Data | [read]
DebugString | [read] canonical string

Public Instance Methods

Create |
Equals | Delegate Equals() to com.starteam.util.GUID.
GetHashCode | Delegate GetHashCode() to com.starteam.util.GUID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.GUID.

See Also

GUID Class | StarTeam.Util Namespace


GUID Constructor

Creates a GUID isntance

Overload List

Creates a GUID isntance

public GUID();

Creates a GUID based on the byte array

public GUID(Byte[]);

Creates a GUID based on the given specification

public GUID(String);

See Also

GUID Class | StarTeam.Util Namespace


GUID Constructor ()

Creates a GUID isntance

public GUID();

See Also

GUID Class | StarTeam.Util Namespace | GUID Constructor Overload List


GUID Constructor (Byte[])

Creates a GUID based on the byte array

public GUID(
Byte[] source
);

Parameters

source
byte array

See Also

GUID Class | StarTeam.Util Namespace | GUID Constructor Overload List


GUID Constructor (String)

Creates a GUID based on the given specification

public GUID(
String spec
);

Parameters

spec
specification

See Also

GUID Class | StarTeam.Util Namespace | GUID Constructor Overload List


GUID Properties

The properties of the GUID class are listed below. For a complete list of GUID class members, see the GUID Members topic.

Public Instance Properties

ByteString | [read] hex representation of the GUID
CanonicalFormat | [read]
Data | [read]
DebugString | [read] canonical string

See Also

GUID Class | StarTeam.Util Namespace


ByteString Property

Borland StarTeam SDK for .NET

GUID.ByteString Property

[read] hex representation of the GUID

public virtual String ByteString {get;}

Property Value

hex representation of the GUID

See Also

GUID Class | StarTeam.Util Namespace


CanonicalFormat Property

Borland StarTeam SDK for .NET

GUID.CanonicalFormat Property

[read]

public virtual String CanonicalFormat {get;}

See Also

GUID Class | StarTeam.Util Namespace


Data Property

Borland StarTeam SDK for .NET

GUID.Data Property

[read]

public virtual Byte[] Data {get;}

See Also

GUID Class | StarTeam.Util Namespace


DebugString Property

Borland StarTeam SDK for .NET

GUID.DebugString Property

[read] canonical string

public virtual String DebugString {get;}

Property Value

canonical string

See Also

GUID Class | StarTeam.Util Namespace


GUID Methods

The methods of the GUID class are listed below. For a complete list of GUID class members, see the GUID Members topic.

Public Instance Methods

Create |
Equals | Delegate Equals() to com.starteam.util.GUID.
GetHashCode | Delegate GetHashCode() to com.starteam.util.GUID.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.GUID.

See Also

GUID Class | StarTeam.Util Namespace


GUID.Create Method

public virtual void Create();

See Also

GUID Class | StarTeam.Util Namespace


GUID.Equals Method

Delegate Equals() to com.starteam.util.GUID.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.GUID.Equals(obj).

See Also

GUID Class | StarTeam.Util Namespace


GUID.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.GUID.

public override int GetHashCode();

Return Value

com.starteam.util.GUID.GetHashCode().

See Also

GUID Class | StarTeam.Util Namespace


GUID.ToString Method

Delegate ToString() to com.starteam.util.GUID.

public override string ToString();

Return Value

com.starteam.util.GUID.ToString()

See Also

GUID Class | StarTeam.Util Namespace


ISO8601 Class

A utility class for encoding and parsing ISO8601 date/time format strings. The following sites have more information:

W3C NOTE - Date and Time Formated

Appendix 2 of the WebDAV specification.

Discussion by Markus Kuhn

For a list of all members of this type, see ISO8601 Members.

System.Object
ISO8601

public class ISO8601

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

ISO8601 Members | StarTeam.Util Namespace


ISO8601 Members

ISO8601 overview

Public Static Methods

Parse Parses the provided IS08601 formated string abd returns the corresponding Java time. Some example formats:
  • 1999-06-17T16:43:07.982Z
  • 1999-06-17T16:43:07Z
  • 1999-06-17T16:43:07.982+02:00
ToGMTString | Returns the ISO8601 date/time format for the specified time. E.g: "1999-06-17T16:43:07.982Z"
ToLocalString | Returns the ISO8601 date/time string for the specified Java time with respect to the local timezone.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.ISO8601.
GetHashCode | Delegate GetHashCode() to com.starteam.util.ISO8601.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.ISO8601.

See Also

ISO8601 Class | StarTeam.Util Namespace


ISO8601 Methods

The methods of the ISO8601 class are listed below. For a complete list of ISO8601 class members, see the ISO8601 Members topic.

Public Static Methods

Parse Parses the provided IS08601 formated string abd returns the corresponding Java time. Some example formats:
  • 1999-06-17T16:43:07.982Z
  • 1999-06-17T16:43:07Z
  • 1999-06-17T16:43:07.982+02:00
ToGMTString | Returns the ISO8601 date/time format for the specified time. E.g: "1999-06-17T16:43:07.982Z"
ToLocalString | Returns the ISO8601 date/time string for the specified Java time with respect to the local timezone.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.ISO8601.
GetHashCode | Delegate GetHashCode() to com.starteam.util.ISO8601.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.ISO8601.

See Also

ISO8601 Class | StarTeam.Util Namespace


ISO8601.Equals Method

Delegate Equals() to com.starteam.util.ISO8601.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.ISO8601.Equals(obj).

See Also

ISO8601 Class | StarTeam.Util Namespace


ISO8601.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.ISO8601.

public override int GetHashCode();

Return Value

com.starteam.util.ISO8601.GetHashCode().

See Also

ISO8601 Class | StarTeam.Util Namespace


ISO8601.Parse Method

Parses the provided IS08601 formated string abd returns the corresponding Java time. Some example formats:

  • 1999-06-17T16:43:07.982Z
  • 1999-06-17T16:43:07Z
  • 1999-06-17T16:43:07.982+02:00

public static long Parse(
String spec
);

Parameters

spec
the IS08601 date/time specification string

Return Value

the Java time value represented by the specified format string

See Also

ISO8601 Class | StarTeam.Util Namespace


ISO8601.ToGMTString Method

Returns the ISO8601 date/time format for the specified time. E.g: "1999-06-17T16:43:07.982Z"

public static string ToGMTString(
Int64 time
);

Parameters

time
the Java time value to represent as a String

Return Value

the IS08601 time format for the specified time

See Also

ISO8601 Class | StarTeam.Util Namespace


ISO8601.ToLocalString Method

Returns the ISO8601 date/time string for the specified Java time with respect to the local timezone.

public static string ToLocalString(
Int64 time
);

Parameters

time
Java time value to represent as a string

Return Value

the IS08601 time format for the specified time

See Also

ISO8601 Class | StarTeam.Util Namespace


ISO8601.ToString Method

Delegate ToString() to com.starteam.util.ISO8601.

public override string ToString();

Return Value

com.starteam.util.ISO8601.ToString()

See Also

ISO8601 Class | StarTeam.Util Namespace


LineProcessor Class

For a list of all members of this type, see LineProcessor Members.

System.Object
LineProcessor
File.KeywordReader
EOLReader

public class LineProcessor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

LineProcessor Members | StarTeam.Util Namespace


LineProcessor Members

LineProcessor overview

Public Instance Methods

EndofInput |
Equals | Delegate Equals() to com.starteam.util.LineProcessor.
GetHashCode | Delegate GetHashCode() to com.starteam.util.LineProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine |
ToString | Delegate ToString() to com.starteam.util.LineProcessor.

See Also

LineProcessor Class | StarTeam.Util Namespace


LineProcessor Methods

The methods of the LineProcessor class are listed below. For a complete list of LineProcessor class members, see the LineProcessor Members topic.

Public Instance Methods

EndofInput |
Equals | Delegate Equals() to com.starteam.util.LineProcessor.
GetHashCode | Delegate GetHashCode() to com.starteam.util.LineProcessor.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessLine |
ToString | Delegate ToString() to com.starteam.util.LineProcessor.

See Also

LineProcessor Class | StarTeam.Util Namespace


LineProcessor.EndofInput Method

public virtual TextReader EndofInput();

See Also

LineProcessor Class | StarTeam.Util Namespace


LineProcessor.Equals Method

Delegate Equals() to com.starteam.util.LineProcessor.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.LineProcessor.Equals(obj).

See Also

LineProcessor Class | StarTeam.Util Namespace


LineProcessor.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.LineProcessor.

public override int GetHashCode();

Return Value

com.starteam.util.LineProcessor.GetHashCode().

See Also

LineProcessor Class | StarTeam.Util Namespace


LineProcessor.ProcessLine Method

public virtual TextReader ProcessLine(
String line,
Int32 eol
);

See Also

LineProcessor Class | StarTeam.Util Namespace


LineProcessor.ToString Method

Delegate ToString() to com.starteam.util.LineProcessor.

public override string ToString();

Return Value

com.starteam.util.LineProcessor.ToString()

See Also

LineProcessor Class | StarTeam.Util Namespace


LineReader Class

For a list of all members of this type, see LineReader Members.

System.Object
LineReader

public class LineReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

LineReader Members | StarTeam.Util Namespace


LineReader Members

LineReader overview

Public Instance Constructors

LineReader Overloaded. Initializes a new instance of the LineReader class.

Public Instance Properties

EOLFormat
LastEOL

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.LineReader.
GetHashCode | Delegate GetHashCode() to com.starteam.util.LineReader.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadLine |
ToString | Delegate ToString() to com.starteam.util.LineReader.

See Also

LineReader Class | StarTeam.Util Namespace


LineReader Constructor

Overload List

public LineReader(TextReader);

public LineReader(TextReader,Int32);

See Also

LineReader Class | StarTeam.Util Namespace


LineReader Constructor (TextReader, Int32)

public LineReader(
TextReader _in,
Int32 sz
);

See Also

LineReader Class | StarTeam.Util Namespace | LineReader Constructor Overload List


LineReader Constructor (TextReader)

public LineReader(
TextReader _in
);

See Also

LineReader Class | StarTeam.Util Namespace | LineReader Constructor Overload List


LineReader Properties

The properties of the LineReader class are listed below. For a complete list of LineReader class members, see the LineReader Members topic.

Public Instance Properties

EOLFormat
LastEOL

See Also

LineReader Class | StarTeam.Util Namespace


EOLFormat Property

Borland StarTeam SDK for .NET

LineReader.EOLFormat Property

public virtual File.EOLFormat EOLFormat {get;}

See Also

LineReader Class | StarTeam.Util Namespace


LastEOL Property

Borland StarTeam SDK for .NET

LineReader.LastEOL Property

public virtual Int32 LastEOL {get;}

See Also

LineReader Class | StarTeam.Util Namespace


LineReader Methods

The methods of the LineReader class are listed below. For a complete list of LineReader class members, see the LineReader Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.LineReader.
GetHashCode | Delegate GetHashCode() to com.starteam.util.LineReader.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadLine |
ToString | Delegate ToString() to com.starteam.util.LineReader.

See Also

LineReader Class | StarTeam.Util Namespace


LineReader.Equals Method

Delegate Equals() to com.starteam.util.LineReader.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.LineReader.Equals(obj).

See Also

LineReader Class | StarTeam.Util Namespace


LineReader.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.LineReader.

public override int GetHashCode();

Return Value

com.starteam.util.LineReader.GetHashCode().

See Also

LineReader Class | StarTeam.Util Namespace


LineReader.ReadLine Method

public virtual string ReadLine();

See Also

LineReader Class | StarTeam.Util Namespace


LineReader.ToString Method

Delegate ToString() to com.starteam.util.LineReader.

public override string ToString();

Return Value

com.starteam.util.LineReader.ToString()

See Also

LineReader Class | StarTeam.Util Namespace


LogManager Class

provide a simple model for logging debug messages from the sdk the caller is responsible for implementing the interfaces

For a list of all members of this type, see LogManager Members.

System.Object
LogManager

public class LogManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

LogManager Members | StarTeam.Util Namespace


LogManager Members

LogManager overview

Public Static Methods

Attach |
Log | Overloaded.

Public Instance Constructors

LogManager Constructor Initializes a new instance of the LogManager class.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.LogManager.
GetHashCode | Delegate GetHashCode() to com.starteam.util.LogManager.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.LogManager.

See Also

LogManager Class | StarTeam.Util Namespace


LogManager Constructor

Initializes a new instance of the LogManager class.

public LogManager();

See Also

LogManager Class | StarTeam.Util Namespace


LogManager Methods

The methods of the LogManager class are listed below. For a complete list of LogManager class members, see the LogManager Members topic.

Public Static Methods

Attach |
Log | Overloaded.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.LogManager.
GetHashCode | Delegate GetHashCode() to com.starteam.util.LogManager.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.LogManager.

See Also

LogManager Class | StarTeam.Util Namespace


LogManager.Attach Method

public static void Attach(
LogManager.LogFactory factory
);

See Also

LogManager Class | StarTeam.Util Namespace


LogManager.Equals Method

Delegate Equals() to com.starteam.util.LogManager.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.LogManager.Equals(obj).

See Also

LogManager Class | StarTeam.Util Namespace


LogManager.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.LogManager.

public override int GetHashCode();

Return Value

com.starteam.util.LogManager.GetHashCode().

See Also

LogManager Class | StarTeam.Util Namespace


Log Method

Borland StarTeam SDK for .NET

LogManager.Log Method

Overload List

public static void Log(Type);

public static void Log(Type,Exception);

public static void Log(Type,String);

public static void Log(Type,String[]);

See Also

LogManager Class | StarTeam.Util Namespace


LogManager.Log Method (Type)

public static void Log(
Type clazz
);

See Also

LogManager Class | StarTeam.Util Namespace | LogManager.Log Overload List


LogManager.Log Method (Type, Exception)

public static void Log(
Type clazz,
Exception t
);

See Also

LogManager Class | StarTeam.Util Namespace | LogManager.Log Overload List


LogManager.Log Method (Type, String)

public static void Log(
Type clazz,
String msg
);

See Also

LogManager Class | StarTeam.Util Namespace | LogManager.Log Overload List


LogManager.Log Method (Type, String[])

public static void Log(
Type clazz,
String[] msgs
);

See Also

LogManager Class | StarTeam.Util Namespace | LogManager.Log Overload List


LogManager.ToString Method

Delegate ToString() to com.starteam.util.LogManager.

public override string ToString();

Return Value

com.starteam.util.LogManager.ToString()

See Also

LogManager Class | StarTeam.Util Namespace


LogManager.LogFactory Interface

A LogFactory returns a Logger for a given class Client applications must implement this interface

For a list of all members of this type, see LogManager.LogFactory Members.

public interface LogManager.LogFactory

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

LogManager.LogFactory Members | StarTeam.Util Namespace


LogManager.LogFactory Members

LogManager.LogFactory overview

Public Instance Methods

GetLogger

See Also

LogManager.LogFactory Interface | StarTeam.Util Namespace


LogManager.LogFactory Methods

The methods of the LogManager.LogFactory interface are listed below. For a complete list of LogManager.LogFactory interface members, see the LogManager.LogFactory Members topic.

Public Instance Methods

GetLogger

See Also

LogManager.LogFactory Interface | StarTeam.Util Namespace


LogManager.LogFactory.GetLogger Method

Logger GetLogger(
Type clazz
);

See Also

LogManager.LogFactory Interface | StarTeam.Util Namespace


LogManager.Logger Interface

A Logger accepts a string as input and decides whether or not to log that string Client applications must implement this interface

For a list of all members of this type, see LogManager.Logger Members.

public interface LogManager.Logger

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

LogManager.Logger Members | StarTeam.Util Namespace


LogManager.Logger Members

LogManager.Logger overview

Public Instance Methods

Log log the message

See Also

LogManager.Logger Interface | StarTeam.Util Namespace


LogManager.Logger Methods

The methods of the LogManager.Logger interface are listed below. For a complete list of LogManager.Logger interface members, see the LogManager.Logger Members topic.

Public Instance Methods

Log log the message

See Also

LogManager.Logger Interface | StarTeam.Util Namespace


LogManager.Logger.Log Method

log the message

void Log(
String message
);

Parameters

message
the string to log

See Also

LogManager.Logger Interface | StarTeam.Util Namespace


MD5 Class

A 16 byte hash that uniquely identifies content across space and time

For a list of all members of this type, see MD5 Members.

System.Object
MD5

public class MD5

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

MD5 Members | StarTeam.Util Namespace


MD5 Members

MD5 overview

Public Instance Constructors

MD5 Overloaded. Initializes a new instance of the MD5 class.

Public Instance Properties

Data [read/write] The 16-byte array containing this object's raw binary value.

Public Instance Methods

ComputeBufferMD5 | Compute MD5 for a byte array.
ComputeFileMD5 | Compute MD5 on a file and return file length.
ComputeStreamMD5 |
Equals | Delegate Equals() to com.starteam.util.MD5.
GetHashCode | Delegate GetHashCode() to com.starteam.util.MD5.
GetType (inherited from Object) | Gets the Type of the current instance.
ToHexString | Return the a 32-character String equal to the hex equivalent of this MD5 value.
ToString | Delegate ToString() to com.starteam.util.MD5.

See Also

MD5 Class | StarTeam.Util Namespace


MD5 Constructor

Construct an MD5

Overload List

Construct an MD5

public MD5();

Construct an MD5 from another

public MD5(MD5);

This constructor is expecting (previously computed) MD5 bytes themselves. If you need to construct an MD5 for given content, you should be using computeBufferMD5(byte[]).

public MD5(Byte[]);

Construct a new MD5 with the given String value.

public MD5(String);

See Also

MD5 Class | StarTeam.Util Namespace


MD5 Constructor ()

Construct an MD5

public MD5();

See Also

MD5 Class | StarTeam.Util Namespace | MD5 Constructor Overload List


MD5 Constructor (Byte[])

This constructor is expecting (previously computed) MD5 bytes themselves. If you need to construct an MD5 for given content, you should be using computeBufferMD5(byte[]).

public MD5(
Byte[] aSourceBytes
);

Parameters

aSourceBytes
byte[] from previously computed MD5 bytes

See Also

MD5 Class | StarTeam.Util Namespace | MD5 Constructor Overload List


MD5 Constructor (MD5)

Construct an MD5 from another

public MD5(
MD5 aMD5
);

Parameters

aMD5
another MD5

See Also

MD5 Class | StarTeam.Util Namespace | MD5 Constructor Overload List


MD5 Constructor (String)

Construct a new MD5 with the given String value.

public MD5(
String stringMD5
);

Parameters

stringMD5
A 32-character hex value of an MD5 value.

See Also

MD5 Class | StarTeam.Util Namespace | MD5 Constructor Overload List


MD5 Properties

The properties of the MD5 class are listed below. For a complete list of MD5 class members, see the MD5 Members topic.

Public Instance Properties

Data [read/write] The 16-byte array containing this object's raw binary value.

See Also

MD5 Class | StarTeam.Util Namespace


Data Property

Borland StarTeam SDK for .NET

MD5.Data Property

[read/write] The 16-byte array containing this object's raw binary value.

public virtual Byte[] Data {get; set;}

Property Value

The 16-byte array containing this object's raw binary value.

See Also

MD5 Class | StarTeam.Util Namespace


MD5 Methods

The methods of the MD5 class are listed below. For a complete list of MD5 class members, see the MD5 Members topic.

Public Instance Methods

ComputeBufferMD5 | Compute MD5 for a byte array.
ComputeFileMD5 | Compute MD5 on a file and return file length.
ComputeStreamMD5 |
Equals | Delegate Equals() to com.starteam.util.MD5.
GetHashCode | Delegate GetHashCode() to com.starteam.util.MD5.
GetType (inherited from Object) | Gets the Type of the current instance.
ToHexString | Return the a 32-character String equal to the hex equivalent of this MD5 value.
ToString | Delegate ToString() to com.starteam.util.MD5.

See Also

MD5 Class | StarTeam.Util Namespace


MD5.ComputeBufferMD5 Method

Compute MD5 for a byte array.

public virtual void ComputeBufferMD5(
Byte[] data
);

Parameters

data
the byte[] to compute and encode into an MD5

See Also

MD5 Class | StarTeam.Util Namespace


MD5.ComputeFileMD5 Method

Compute MD5 on a file and return file length.

public virtual long ComputeFileMD5(
FileInfo file
);

Parameters

file
the file whose md5 is to be computed

Return Value

the file length

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

MD5 Class | StarTeam.Util Namespace


MD5.ComputeStreamMD5 Method

public virtual long ComputeStreamMD5(
Stream _in
);

See Also

MD5 Class | StarTeam.Util Namespace


MD5.Equals Method

Delegate Equals() to com.starteam.util.MD5.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.MD5.Equals(obj).

See Also

MD5 Class | StarTeam.Util Namespace


MD5.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.MD5.

public override int GetHashCode();

Return Value

com.starteam.util.MD5.GetHashCode().

See Also

MD5 Class | StarTeam.Util Namespace


MD5.ToHexString Method

Return the a 32-character String equal to the hex equivalent of this MD5 value.

public virtual string ToHexString();

Return Value

A 32-character String equal to the hex equivalent of this MD5 value.

See Also

MD5 Class | StarTeam.Util Namespace


MD5.ToString Method

Delegate ToString() to com.starteam.util.MD5.

public override string ToString();

Return Value

com.starteam.util.MD5.ToString()

See Also

MD5 Class | StarTeam.Util Namespace


MD5.Stream Class

For a list of all members of this type, see MD5.Stream Members.

System.Object
MD5.Stream

public class MD5.Stream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

MD5.Stream Members | StarTeam.Util Namespace


MD5.Stream Members

MD5.Stream overview

Public Instance Constructors

MD5.Stream Constructor

Public Instance Properties

MD5

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.MD5.Stream.
GetHashCode | Delegate GetHashCode() to com.starteam.util.MD5.Stream.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.MD5.Stream.

See Also

MD5.Stream Class | StarTeam.Util Namespace


MD5.Stream Constructor

public MD5.Stream(
Stream _out
);

See Also

MD5.Stream Class | StarTeam.Util Namespace


MD5.Stream Properties

The properties of the MD5.Stream class are listed below. For a complete list of MD5.Stream class members, see the MD5.Stream Members topic.

Public Instance Properties

MD5

See Also

MD5.Stream Class | StarTeam.Util Namespace


MD5 Property

Borland StarTeam SDK for .NET

MD5.Stream.MD5 Property

public virtual Byte[] MD5 {get;}

See Also

MD5.Stream Class | StarTeam.Util Namespace


MD5.Stream Methods

The methods of the MD5.Stream class are listed below. For a complete list of MD5.Stream class members, see the MD5.Stream Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.MD5.Stream.
GetHashCode | Delegate GetHashCode() to com.starteam.util.MD5.Stream.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.MD5.Stream.

See Also

MD5.Stream Class | StarTeam.Util Namespace


MD5.Stream.Equals Method

Delegate Equals() to com.starteam.util.MD5.Stream.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.MD5.Stream.Equals(obj).

See Also

MD5.Stream Class | StarTeam.Util Namespace


MD5.Stream.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.MD5.Stream.

public override int GetHashCode();

Return Value

com.starteam.util.MD5.Stream.GetHashCode().

See Also

MD5.Stream Class | StarTeam.Util Namespace


MD5.Stream.ToString Method

Delegate ToString() to com.starteam.util.MD5.Stream.

public override string ToString();

Return Value

com.starteam.util.MD5.Stream.ToString()

See Also

MD5.Stream Class | StarTeam.Util Namespace


Platform Class

Information about the current platform.

For a list of all members of this type, see Platform Members.

System.Object
Platform

public class Platform

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

Platform Members | StarTeam.Util Namespace


Platform Members

Platform overview

Public Static Properties

CaseSensitiveFileNames | [read] true if file names are case sensitive.
CurrentThreadID | [read] the ID of the current thread
EOLValue | [read]
FilePathDelimiter | [read]
HostAddress | [read]
IsDotNET | [read] true if we are running in a .NET environment.
IsWin32 | [read] true if running under Win32.
MachineName | [read]
OSName | [read] A descriptive name for the operating system.
SetReadOnlyCmd | [read] the 'set read only' command
SetWritableCmd | [read] the 'set writable' command
StackTrace | [read] a runtime specific implementation of the stack trace
TempDirectoryPath | [read] the path to the temp directory, if available, or to the local directory if not
TouchCmd | [read] the touch command
WorkStationID | [read] the Workstation GUID
WSOptions | [read]

Public Static Methods

Base64UrlEncode | Return a Base64 URL encoded string
CreateSymbolicLink | Creates a symbolic link to the target path specified.
GetEnvironmentVariable |
GetFileExecutable | Return true if the file is "executable" by the user. The interpretation of what this means will vary by platform.
GetFileLastModified | Overloaded. returns the last modified time for the given file via a native platform call
GetFileLength |
GetFileWritable | return true if the file is writable
GetLastModified | Overloaded. returns the last modified time for the given file via a native platform call
GetStackTrace |
GetSymbolicLinkTarget | Returns target path for specified symbolic link.
IsRemoteDrive |
IsSymbolicLink | Returns true if the specified file is a symbolic link.
LoadFileAttributes |
Parse | Parse the given payload using a regular expression pattern Picks an appropriate platform specific pattern matcher, i.e, this implementation depends upon a core-edge strategy using the Pattern class in java and the RegEx class in .NET
SetFileExecutable | Change whether or not the specified file should be marked "executable".
SetFileLastModified | Set the last modification time for the file
SetFileWritable | set the file writable bit
UrlEncode | Return a URL encoded string

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Platform.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Platform.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.Platform.

See Also

Platform Class | StarTeam.Util Namespace


Platform Properties

The properties of the Platform class are listed below. For a complete list of Platform class members, see the Platform Members topic.

Public Static Properties

CaseSensitiveFileNames | [read] true if file names are case sensitive.
CurrentThreadID | [read] the ID of the current thread
EOLValue | [read]
FilePathDelimiter | [read]
HostAddress | [read]
IsDotNET | [read] true if we are running in a .NET environment.
IsWin32 | [read] true if running under Win32.
MachineName | [read]
OSName | [read] A descriptive name for the operating system.
SetReadOnlyCmd | [read] the 'set read only' command
SetWritableCmd | [read] the 'set writable' command
StackTrace | [read] a runtime specific implementation of the stack trace
TempDirectoryPath | [read] the path to the temp directory, if available, or to the local directory if not
TouchCmd | [read] the touch command
WorkStationID | [read] the Workstation GUID
WSOptions | [read]

See Also

Platform Class | StarTeam.Util Namespace


CaseSensitiveFileNames Property

Borland StarTeam SDK for .NET

Platform.CaseSensitiveFileNames Property

[read] true if file names are case sensitive.

public static Boolean CaseSensitiveFileNames {get;}

Property Value

true if file names are case sensitive.

See Also

Platform Class | StarTeam.Util Namespace


CurrentThreadID Property

Borland StarTeam SDK for .NET

Platform.CurrentThreadID Property

[read] the ID of the current thread

public static Int64 CurrentThreadID {get;}

Property Value

the ID of the current thread

See Also

Platform Class | StarTeam.Util Namespace


EOLValue Property

Borland StarTeam SDK for .NET

Platform.EOLValue Property

[read]

public static String EOLValue {get;}

See Also

Platform Class | StarTeam.Util Namespace


FilePathDelimiter Property

Borland StarTeam SDK for .NET

Platform.FilePathDelimiter Property

[read]

public static String FilePathDelimiter {get;}

See Also

Platform Class | StarTeam.Util Namespace


HostAddress Property

Borland StarTeam SDK for .NET

Platform.HostAddress Property

[read]

public static String HostAddress {get;}

See Also

Platform Class | StarTeam.Util Namespace


IsDotNET Property

Borland StarTeam SDK for .NET

Platform.IsDotNET Property

[read] true if we are running in a .NET environment.

public static Boolean IsDotNET {get;}

Property Value

true if we are running in a .NET environment.

See Also

Platform Class | StarTeam.Util Namespace


IsWin32 Property

Borland StarTeam SDK for .NET

Platform.IsWin32 Property

[read] true if running under Win32.

public static Boolean IsWin32 {get;}

Property Value

true if running under Win32.

See Also

Platform Class | StarTeam.Util Namespace


MachineName Property

Borland StarTeam SDK for .NET

Platform.MachineName Property

[read]

public static String MachineName {get;}

See Also

Platform Class | StarTeam.Util Namespace


OSName Property

Borland StarTeam SDK for .NET

Platform.OSName Property

[read] A descriptive name for the operating system.

public static String OSName {get;}

Property Value

A descriptive name for the operating system.

See Also

Platform Class | StarTeam.Util Namespace


SetReadOnlyCmd Property

Borland StarTeam SDK for .NET

Platform.SetReadOnlyCmd Property

[read] the 'set read only' command

public static String SetReadOnlyCmd {get;}

Property Value

the 'set read only' command

See Also

Platform Class | StarTeam.Util Namespace


SetWritableCmd Property

Borland StarTeam SDK for .NET

Platform.SetWritableCmd Property

[read] the 'set writable' command

public static String SetWritableCmd {get;}

Property Value

the 'set writable' command

See Also

Platform Class | StarTeam.Util Namespace


StackTrace Property

Borland StarTeam SDK for .NET

Platform.StackTrace Property

[read] a runtime specific implementation of the stack trace

public static String[] StackTrace {get;}

Property Value

a runtime specific implementation of the stack trace

See Also

Platform Class | StarTeam.Util Namespace


TempDirectoryPath Property

Borland StarTeam SDK for .NET

Platform.TempDirectoryPath Property

[read] the path to the temp directory, if available, or to the local directory if not

public static String TempDirectoryPath {get;}

Property Value

the path to the temp directory, if available, or to the local directory if not

See Also

Platform Class | StarTeam.Util Namespace


TouchCmd Property

Borland StarTeam SDK for .NET

Platform.TouchCmd Property

[read] the touch command

public static String TouchCmd {get;}

Property Value

the touch command

See Also

Platform Class | StarTeam.Util Namespace


WorkStationID Property

Borland StarTeam SDK for .NET

Platform.WorkStationID Property

[read] the Workstation GUID

public static GUID WorkStationID {get;}

Property Value

the Workstation GUID

See Also

Platform Class | StarTeam.Util Namespace


WSOptions Property

Borland StarTeam SDK for .NET

Platform.WSOptions Property

[read]

public static Platform.WorkStationOptions WSOptions {get;}

See Also

Platform Class | StarTeam.Util Namespace


Platform Methods

The methods of the Platform class are listed below. For a complete list of Platform class members, see the Platform Members topic.

Public Static Methods

Base64UrlEncode | Return a Base64 URL encoded string
CreateSymbolicLink | Creates a symbolic link to the target path specified.
GetEnvironmentVariable |
GetFileExecutable | Return true if the file is "executable" by the user. The interpretation of what this means will vary by platform.
GetFileLastModified | Overloaded. returns the last modified time for the given file via a native platform call
GetFileLength |
GetFileWritable | return true if the file is writable
GetLastModified | Overloaded. returns the last modified time for the given file via a native platform call
GetStackTrace |
GetSymbolicLinkTarget | Returns target path for specified symbolic link.
IsRemoteDrive |
IsSymbolicLink | Returns true if the specified file is a symbolic link.
LoadFileAttributes |
Parse | Parse the given payload using a regular expression pattern Picks an appropriate platform specific pattern matcher, i.e, this implementation depends upon a core-edge strategy using the Pattern class in java and the RegEx class in .NET
SetFileExecutable | Change whether or not the specified file should be marked "executable".
SetFileLastModified | Set the last modification time for the file
SetFileWritable | set the file writable bit
UrlEncode | Return a URL encoded string

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Platform.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Platform.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.Platform.

See Also

Platform Class | StarTeam.Util Namespace


Platform.Base64UrlEncode Method

Return a Base64 URL encoded string

public static string Base64UrlEncode(
String payload
);

Parameters

payload
the string to encode

Return Value

the url encoded string

See Also

Platform Class | StarTeam.Util Namespace


Platform.CreateSymbolicLink Method

Creates a symbolic link to the target path specified.

public static void CreateSymbolicLink(
String link,
String target
);

Parameters

link
the path to symbolic link
target
the target path to reference.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace


Platform.Equals Method

Delegate Equals() to com.starteam.util.Platform.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.Platform.Equals(obj).

See Also

Platform Class | StarTeam.Util Namespace


Platform.GetEnvironmentVariable Method

public static string GetEnvironmentVariable(
String s
);

Parameters

s

See Also

Platform Class | StarTeam.Util Namespace


Platform.GetFileExecutable Method

Return true if the file is "executable" by the user. The interpretation of what this means will vary by platform.

public static bool GetFileExecutable(
FileInfo file
);

Parameters

file
the specified file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace


GetFileLastModified Method

Borland StarTeam SDK for .NET

Platform.GetFileLastModified Method

returns the last modified time for the given file via a native platform call

Overload List

returns the last modified time for the given file via a native platform call

public static DateTime GetFileLastModified(FileInfo);

returns the last modified time for the given file via a native platform call

public static DateTime GetFileLastModified(String);

See Also

Platform Class | StarTeam.Util Namespace


Platform.GetFileLastModified Method (FileInfo)

returns the last modified time for the given file via a native platform call

public static DateTime GetFileLastModified(
FileInfo file
);

Parameters

file
File

Return Value

double the last modified time converted to an OLE double

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace | Platform.GetFileLastModified Overload List


Platform.GetFileLastModified Method (String)

returns the last modified time for the given file via a native platform call

public static DateTime GetFileLastModified(
String fileName
);

Parameters

fileName
String the absolute path to the file

Return Value

double the last modified time converted to an OLE double

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace | Platform.GetFileLastModified Overload List


Platform.GetFileLength Method

public static long GetFileLength(
String fileName
);

Parameters

fileName
the name of the specified file

Return Value

The length of the file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace


Platform.GetFileWritable Method

return true if the file is writable

public static bool GetFileWritable(
FileInfo file
);

Parameters

file
the file

Return Value

true if the file is writable

See Also

Platform Class | StarTeam.Util Namespace


Platform.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.Platform.

public override int GetHashCode();

Return Value

com.starteam.util.Platform.GetHashCode().

See Also

Platform Class | StarTeam.Util Namespace


GetLastModified Method

Borland StarTeam SDK for .NET

Platform.GetLastModified Method

returns the last modified time for the given file via a native platform call

Overload List

returns the last modified time for the given file via a native platform call

public static long GetLastModified(FileInfo);

returns the last modified time for the given file via a native platform call

public static long GetLastModified(String);

See Also

Platform Class | StarTeam.Util Namespace


Platform.GetLastModified Method (FileInfo)

returns the last modified time for the given file via a native platform call

public static long GetLastModified(
FileInfo file
);

Parameters

file
File

Return Value

long the last modified time

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace | Platform.GetLastModified Overload List


Platform.GetLastModified Method (String)

returns the last modified time for the given file via a native platform call

public static long GetLastModified(
String fileName
);

Parameters

fileName
String the absolute path to the file

Return Value

long the last modified time

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace | Platform.GetLastModified Overload List


Platform.GetStackTrace Method

public static string[] GetStackTrace(
Exception t
);

See Also

Platform Class | StarTeam.Util Namespace


Platform.GetSymbolicLinkTarget Method

Returns target path for specified symbolic link.

public static string GetSymbolicLinkTarget(
FileInfo file
);

Parameters

file
the specified file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace


Platform.IsRemoteDrive Method

public static bool IsRemoteDrive(
String fileName
);

Parameters

fileName
the fully qualified name of the specified file

Return Value

true if the path represented by the file is a remote drive only supported on Windows patforms

See Also

Platform Class | StarTeam.Util Namespace


Platform.IsSymbolicLink Method

Returns true if the specified file is a symbolic link.

public static bool IsSymbolicLink(
FileInfo file
);

Parameters

file
the specified file

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace


Platform.LoadFileAttributes Method

public static void LoadFileAttributes(
Attributes[] attributes
);

See Also

Platform Class | StarTeam.Util Namespace


Platform.Parse Method

Parse the given payload using a regular expression pattern Picks an appropriate platform specific pattern matcher, i.e, this implementation depends upon a core-edge strategy using the Pattern class in java and the RegEx class in .NET

public static string[] Parse(
String payload,
String pattern
);

Parameters

payload
the string to be parsed
pattern
the regular expression to match

Return Value

an array of matches (if any), which may be empty, but never NULL

See Also

Platform Class | StarTeam.Util Namespace


Platform.SetFileExecutable Method

Change whether or not the specified file should be marked "executable".

public static void SetFileExecutable(
FileInfo file,
Boolean executable
);

Parameters

file
the specified file
executable
true if the file should be marked executable

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace


Platform.SetFileLastModified Method

Set the last modification time for the file

public static void SetFileLastModified(
FileInfo file,
Double oletime
);

Parameters

file
the file
oletime
the last modified time

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace


Platform.SetFileWritable Method

set the file writable bit

public static void SetFileWritable(
FileInfo file,
Boolean val
);

Parameters

file
the file
val
true to mark the file as writable

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Platform Class | StarTeam.Util Namespace


Platform.ToString Method

Delegate ToString() to com.starteam.util.Platform.

public override string ToString();

Return Value

com.starteam.util.Platform.ToString()

See Also

Platform Class | StarTeam.Util Namespace


Platform.UrlEncode Method

Return a URL encoded string

public static string UrlEncode(
String payload,
String charset
);

Parameters

payload
the string to encode
charset
the character set to use

Return Value

the url encoded string

See Also

Platform Class | StarTeam.Util Namespace


Platform.EOL Class

The end-of-line sequence on different platforms

For a list of all members of this type, see Platform.EOL Members.

System.Object
Platform.EOL

public class Platform.EOL

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

Platform.EOL Members | StarTeam.Util Namespace


Platform.EOL Members

Platform.EOL overview

Public Static Properties

ALL
CR
CRLF
LF
MAC
UNIX
UNKNOWN
WINDOWS

Public Static Methods

FromEOL | Determines the EOL whose end-of-line character sequence matches the given one. Returns UNKNOWN if the given eol doesn't match any of the known EOLs.
FromID | Gets the end-of-line sequence value corresponding to the given ID.

Public Instance Properties

EOLValue | [read] String
ID | [read] The ID of this end of line sequence.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Platform.EOL.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Platform.EOL.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.Platform.EOL.

See Also

Platform.EOL Class | StarTeam.Util Namespace


Platform.EOL Properties

The properties of the Platform.EOL class are listed below. For a complete list of Platform.EOL class members, see the Platform.EOL Members topic.

Public Static Properties

ALL
CR
CRLF
LF
MAC
UNIX
UNKNOWN
WINDOWS

Public Instance Properties

EOLValue | [read] String
ID | [read] The ID of this end of line sequence.

See Also

Platform.EOL Class | StarTeam.Util Namespace


ALL Property

Borland StarTeam SDK for .NET

Platform.EOL.ALL Property

public static EOL[] ALL {get;}

See Also

Platform.EOL Class | StarTeam.Util Namespace


CR Property

Borland StarTeam SDK for .NET

Platform.EOL.CR Property

public static Platform.EOL CR {get;}

Property Value

Carriage-return end-of-line sequence (i.e., "\r").

See Also

Platform.EOL Class | StarTeam.Util Namespace


CRLF Property

Borland StarTeam SDK for .NET

Platform.EOL.CRLF Property

public static Platform.EOL CRLF {get;}

Property Value

Carriage-return + Line-feed end-of-line sequence (i.e., "\r\n").

See Also

Platform.EOL Class | StarTeam.Util Namespace


EOLValue Property

Borland StarTeam SDK for .NET

Platform.EOL.EOLValue Property

[read] String

public virtual String EOLValue {get;}

Property Value

String

See Also

Platform.EOL Class | StarTeam.Util Namespace


ID Property

Borland StarTeam SDK for .NET

Platform.EOL.ID Property

[read] The ID of this end of line sequence.

public virtual Int32 ID {get;}

Property Value

The ID of this end of line sequence.

See Also

Platform.EOL Class | StarTeam.Util Namespace


LF Property

Borland StarTeam SDK for .NET

Platform.EOL.LF Property

public static Platform.EOL LF {get;}

Property Value

Line-feed end-of-line sequence (i.e., "\n").

See Also

Platform.EOL Class | StarTeam.Util Namespace


MAC Property

Borland StarTeam SDK for .NET

Platform.EOL.MAC Property

public static Platform.EOL MAC {get;}

Property Value

End of line sequence commonly used on the MacIntosh.

See Also

Platform.EOL Class | StarTeam.Util Namespace


UNIX Property

Borland StarTeam SDK for .NET

Platform.EOL.UNIX Property

public static Platform.EOL UNIX {get;}

Property Value

End of line sequence commonly used on Unix/Linux/Solaris.

See Also

Platform.EOL Class | StarTeam.Util Namespace


UNKNOWN Property

Borland StarTeam SDK for .NET

Platform.EOL.UNKNOWN Property

public static Platform.EOL UNKNOWN {get;}

Property Value

The end-of-line sequence has not been determined.

See Also

Platform.EOL Class | StarTeam.Util Namespace


WINDOWS Property

Borland StarTeam SDK for .NET

Platform.EOL.WINDOWS Property

public static Platform.EOL WINDOWS {get;}

Property Value

End of line sequence commonly used on Windows.

See Also

Platform.EOL Class | StarTeam.Util Namespace


Platform.EOL Methods

The methods of the Platform.EOL class are listed below. For a complete list of Platform.EOL class members, see the Platform.EOL Members topic.

Public Static Methods

FromEOL | Determines the EOL whose end-of-line character sequence matches the given one. Returns UNKNOWN if the given eol doesn't match any of the known EOLs.
FromID | Gets the end-of-line sequence value corresponding to the given ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Platform.EOL.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Platform.EOL.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.Platform.EOL.

See Also

Platform.EOL Class | StarTeam.Util Namespace


Platform.EOL.Equals Method

Delegate Equals() to com.starteam.util.Platform.EOL.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.Platform.EOL.Equals(obj).

See Also

Platform.EOL Class | StarTeam.Util Namespace


Platform.EOL.FromEOL Method

Determines the EOL whose end-of-line character sequence matches the given one. Returns UNKNOWN if the given eol doesn't match any of the known EOLs.

public static EOL FromEOL(
String eol
);

Parameters

eol
String

Return Value

EOLFormat

See Also

Platform.EOL Class | StarTeam.Util Namespace


Platform.EOL.FromID Method

Gets the end-of-line sequence value corresponding to the given ID.

public static EOL FromID(
Int32 id
);

Parameters

id
The ID of an end of line sequence.

Return Value

The corresponding EOL value, or null.

See Also

Platform.EOL Class | StarTeam.Util Namespace


Platform.EOL.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.Platform.EOL.

public override int GetHashCode();

Return Value

com.starteam.util.Platform.EOL.GetHashCode().

See Also

Platform.EOL Class | StarTeam.Util Namespace


Platform.EOL.ToString Method

Delegate ToString() to com.starteam.util.Platform.EOL.

public override string ToString();

Return Value

com.starteam.util.Platform.EOL.ToString()

See Also

Platform.EOL Class | StarTeam.Util Namespace


Platform.WorkStationOptions Interface

For a list of all members of this type, see Platform.WorkStationOptions Members.

public interface Platform.WorkStationOptions

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

Platform.WorkStationOptions Members | StarTeam.Util Namespace


Platform.WorkStationOptions Members

Platform.WorkStationOptions overview

Public Instance Properties

LocationMsg [read] an English readable string descriing the location of the option file

Public Instance Methods

GetOption | Returns the value stored for the option
SetOption | sets a value for a specified option (key)

See Also

Platform.WorkStationOptions Interface | StarTeam.Util Namespace


Platform.WorkStationOptions Properties

The properties of the Platform.WorkStationOptions interface are listed below. For a complete list of Platform.WorkStationOptions interface members, see the Platform.WorkStationOptions Members topic.

Public Instance Properties

LocationMsg [read] an English readable string descriing the location of the option file

See Also

Platform.WorkStationOptions Interface | StarTeam.Util Namespace


LocationMsg Property

Borland StarTeam SDK for .NET

Platform.WorkStationOptions.LocationMsg Property

[read] an English readable string descriing the location of the option file

String LocationMsg {get;}

Property Value

an English readable string descriing the location of the option file

See Also

Platform.WorkStationOptions Interface | StarTeam.Util Namespace


Platform.WorkStationOptions Methods

The methods of the Platform.WorkStationOptions interface are listed below. For a complete list of Platform.WorkStationOptions interface members, see the Platform.WorkStationOptions Members topic.

Public Instance Methods

GetOption | Returns the value stored for the option
SetOption | sets a value for a specified option (key)

See Also

Platform.WorkStationOptions Interface | StarTeam.Util Namespace


Platform.WorkStationOptions.GetOption Method

Returns the value stored for the option

string GetOption(
String option
);

Parameters

option
the key to look for

Return Value

its string based value

See Also

Platform.WorkStationOptions Interface | StarTeam.Util Namespace


Platform.WorkStationOptions.SetOption Method

sets a value for a specified option (key)

void SetOption(
String option,
String value
);

Parameters

option
the option to set
value
the value of that option

See Also

Platform.WorkStationOptions Interface | StarTeam.Util Namespace


ReadWriteLock Class

For a list of all members of this type, see ReadWriteLock Members.

System.Object
ReadWriteLock

public class ReadWriteLock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

ReadWriteLock Members | StarTeam.Util Namespace


ReadWriteLock Members

ReadWriteLock overview

Public Instance Constructors

ReadWriteLock Constructor Construct a ReadWrite Lock

Public Instance Methods

AcquireReadLock | Overloaded. Try to acquire a read lock, wait for the specified time in seconds
AcquireWriteLock | Overloaded. Try to acquire a write lock, wait for the specified time in seconds
Equals | Delegate Equals() to com.starteam.util.ReadWriteLock.
GetHashCode | Delegate GetHashCode() to com.starteam.util.ReadWriteLock.
GetType (inherited from Object) | Gets the Type of the current instance.
ReleaseReadLock | Release the read lock
ReleaseWriteLock | Release the write lock
ToString | Delegate ToString() to com.starteam.util.ReadWriteLock.

See Also

ReadWriteLock Class | StarTeam.Util Namespace


ReadWriteLock Constructor

Construct a ReadWrite Lock

public ReadWriteLock();

See Also

ReadWriteLock Class | StarTeam.Util Namespace


ReadWriteLock Methods

The methods of the ReadWriteLock class are listed below. For a complete list of ReadWriteLock class members, see the ReadWriteLock Members topic.

Public Instance Methods

AcquireReadLock | Overloaded. Try to acquire a read lock, wait for the specified time in seconds
AcquireWriteLock | Overloaded. Try to acquire a write lock, wait for the specified time in seconds
Equals | Delegate Equals() to com.starteam.util.ReadWriteLock.
GetHashCode | Delegate GetHashCode() to com.starteam.util.ReadWriteLock.
GetType (inherited from Object) | Gets the Type of the current instance.
ReleaseReadLock | Release the read lock
ReleaseWriteLock | Release the write lock
ToString | Delegate ToString() to com.starteam.util.ReadWriteLock.

See Also

ReadWriteLock Class | StarTeam.Util Namespace


AcquireReadLock Method

Borland StarTeam SDK for .NET

ReadWriteLock.AcquireReadLock Method

Acquire a read lock, wait indefinitely

Overload List

Acquire a read lock, wait indefinitely

public virtual void AcquireReadLock();

Try to acquire a read lock, wait for the specified time in seconds

public virtual bool AcquireReadLock(Int32);

See Also

ReadWriteLock Class | StarTeam.Util Namespace


ReadWriteLock.AcquireReadLock Method ()

Acquire a read lock, wait indefinitely

public virtual void AcquireReadLock();

See Also

ReadWriteLock Class | StarTeam.Util Namespace | ReadWriteLock.AcquireReadLock Overload List


ReadWriteLock.AcquireReadLock Method (Int32)

Try to acquire a read lock, wait for the specified time in seconds

public virtual bool AcquireReadLock(
Int32 waitTime
);

Parameters

waitTime
the waitTime in seconds

See Also

ReadWriteLock Class | StarTeam.Util Namespace | ReadWriteLock.AcquireReadLock Overload List


AcquireWriteLock Method

Borland StarTeam SDK for .NET

ReadWriteLock.AcquireWriteLock Method

Acquire a write lock, wait indefinitely

Overload List

Acquire a write lock, wait indefinitely

public virtual void AcquireWriteLock();

Try to acquire a write lock, wait for the specified time in seconds

public virtual bool AcquireWriteLock(Int32);

See Also

ReadWriteLock Class | StarTeam.Util Namespace


ReadWriteLock.AcquireWriteLock Method ()

Acquire a write lock, wait indefinitely

public virtual void AcquireWriteLock();

See Also

ReadWriteLock Class | StarTeam.Util Namespace | ReadWriteLock.AcquireWriteLock Overload List


ReadWriteLock.AcquireWriteLock Method (Int32)

Try to acquire a write lock, wait for the specified time in seconds

public virtual bool AcquireWriteLock(
Int32 waitTime
);

Parameters

waitTime
the waitTime in seconds

See Also

ReadWriteLock Class | StarTeam.Util Namespace | ReadWriteLock.AcquireWriteLock Overload List


ReadWriteLock.Equals Method

Delegate Equals() to com.starteam.util.ReadWriteLock.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.ReadWriteLock.Equals(obj).

See Also

ReadWriteLock Class | StarTeam.Util Namespace


ReadWriteLock.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.ReadWriteLock.

public override int GetHashCode();

Return Value

com.starteam.util.ReadWriteLock.GetHashCode().

See Also

ReadWriteLock Class | StarTeam.Util Namespace


ReadWriteLock.ReleaseReadLock Method

Release the read lock

public virtual void ReleaseReadLock();

See Also

ReadWriteLock Class | StarTeam.Util Namespace


ReadWriteLock.ReleaseWriteLock Method

Release the write lock

public virtual void ReleaseWriteLock();

See Also

ReadWriteLock Class | StarTeam.Util Namespace


ReadWriteLock.ToString Method

Delegate ToString() to com.starteam.util.ReadWriteLock.

public override string ToString();

Return Value

com.starteam.util.ReadWriteLock.ToString()

See Also

ReadWriteLock Class | StarTeam.Util Namespace


Registry Class

Provides functions for accessing the Windows Registry via a JNI library. Typically useful for applications that run on Windows platforms

For a list of all members of this type, see Registry Members.

System.Object
Registry

public class Registry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

Registry Members | StarTeam.Util Namespace


Registry Members

Registry overview

Public Static Properties

HKEY_CLASSES_ROOT
HKEY_CURRENT_USER
HKEY_LOCAL_MACHINE

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Registry.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Registry.
GetStringKey | Function to get a string value for a specific registry key.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.Registry.

See Also

Registry Class | StarTeam.Util Namespace


Registry Properties

The properties of the Registry class are listed below. For a complete list of Registry class members, see the Registry Members topic.

Public Static Properties

HKEY_CLASSES_ROOT
HKEY_CURRENT_USER
HKEY_LOCAL_MACHINE

See Also

Registry Class | StarTeam.Util Namespace


HKEY_CLASSES_ROOT Property

Borland StarTeam SDK for .NET

Registry.HKEY_CLASSES_ROOT Property

public static Registry HKEY_CLASSES_ROOT {get;}

Property Value

The Registry Hive HKEY_CLASSES_ROOT

See Also

Registry Class | StarTeam.Util Namespace


HKEY_CURRENT_USER Property

Borland StarTeam SDK for .NET

Registry.HKEY_CURRENT_USER Property

public static Registry HKEY_CURRENT_USER {get;}

Property Value

The Registry Hive HKEY_CURENT_USER

See Also

Registry Class | StarTeam.Util Namespace


HKEY_LOCAL_MACHINE Property

Borland StarTeam SDK for .NET

Registry.HKEY_LOCAL_MACHINE Property

public static Registry HKEY_LOCAL_MACHINE {get;}

Property Value

The Registry Hive HKEY_LOCAL_MACHINE

See Also

Registry Class | StarTeam.Util Namespace


Registry Methods

The methods of the Registry class are listed below. For a complete list of Registry class members, see the Registry Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.Registry.
GetHashCode | Delegate GetHashCode() to com.starteam.util.Registry.
GetStringKey | Function to get a string value for a specific registry key.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.Registry.

See Also

Registry Class | StarTeam.Util Namespace


Registry.Equals Method

Delegate Equals() to com.starteam.util.Registry.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.Registry.Equals(obj).

See Also

Registry Class | StarTeam.Util Namespace


Registry.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.Registry.

public override int GetHashCode();

Return Value

com.starteam.util.Registry.GetHashCode().

See Also

Registry Class | StarTeam.Util Namespace


Registry.GetStringKey Method

Function to get a string value for a specific registry key.

public virtual string GetStringKey(
String keyPath,
String keyName
);

Parameters

keyPath
Full path name to string-valued registry key (e.g. "Software\Starbase\SBToolbar\Options").
keyName
Name of string-valued key to get value of (e.g. "DisplayAtStartup").

Return Value

String value, if it exists, otherwise null.

See Also

Registry Class | StarTeam.Util Namespace


Registry.ToString Method

Delegate ToString() to com.starteam.util.Registry.

public override string ToString();

Return Value

com.starteam.util.Registry.ToString()

See Also

Registry Class | StarTeam.Util Namespace


UTF8 Class

Implements UTF-8 conversion routines as described by RFC-2279

For a list of all members of this type, see UTF8 Members.

System.Object
UTF8

public class UTF8

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

UTF8 Members | StarTeam.Util Namespace


UTF8 Members

UTF8 overview

Public Static Methods

StringToUtf8 | Converts a string to an array of UTF-8 characters.
Utf16ToUtf8 | Converts an array of characters in UTF-16/Unicode format to an array of characters in UTF-8 characters.
Utf8ToString | Converts an array of characters in UTF-8 format to a Unicode string.
Utf8ToUtf16 | Converts an array of characters in UTF-8 format to an array of UTF-16/Unicode characters.
Utf8ToUtf16Char |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.UTF8.
GetHashCode | Delegate GetHashCode() to com.starteam.util.UTF8.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.UTF8.

See Also

UTF8 Class | StarTeam.Util Namespace


UTF8 Methods

The methods of the UTF8 class are listed below. For a complete list of UTF8 class members, see the UTF8 Members topic.

Public Static Methods

StringToUtf8 | Converts a string to an array of UTF-8 characters.
Utf16ToUtf8 | Converts an array of characters in UTF-16/Unicode format to an array of characters in UTF-8 characters.
Utf8ToString | Converts an array of characters in UTF-8 format to a Unicode string.
Utf8ToUtf16 | Converts an array of characters in UTF-8 format to an array of UTF-16/Unicode characters.
Utf8ToUtf16Char |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.UTF8.
GetHashCode | Delegate GetHashCode() to com.starteam.util.UTF8.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.UTF8.

See Also

UTF8 Class | StarTeam.Util Namespace


UTF8.Equals Method

Delegate Equals() to com.starteam.util.UTF8.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.UTF8.Equals(obj).

See Also

UTF8 Class | StarTeam.Util Namespace


UTF8.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.UTF8.

public override int GetHashCode();

Return Value

com.starteam.util.UTF8.GetHashCode().

See Also

UTF8 Class | StarTeam.Util Namespace


UTF8.StringToUtf8 Method

Converts a string to an array of UTF-8 characters.

public static byte[] StringToUtf8(
String src
);

Parameters

src
Source string.

Return Value

The translated array of characters in UTF-8 format.

See Also

UTF8 Class | StarTeam.Util Namespace


UTF8.ToString Method

Delegate ToString() to com.starteam.util.UTF8.

public override string ToString();

Return Value

com.starteam.util.UTF8.ToString()

See Also

UTF8 Class | StarTeam.Util Namespace


UTF8.Utf16ToUtf8 Method

Converts an array of characters in UTF-16/Unicode format to an array of characters in UTF-8 characters.

public static int Utf16ToUtf8(
Char[] src,
Byte[] dst
);

Parameters

src
Source string, in unicode format.
dst
Output buffer for utf-8 characters.

Return Value

The number of bytes written. If dst is null, then only returns the number of bytes needed.

See Also

UTF8 Class | StarTeam.Util Namespace


UTF8.Utf8ToString Method

Converts an array of characters in UTF-8 format to a Unicode string.

public static string Utf8ToString(
Byte[] src
);

Parameters

src
Source string, in UTF-8 format.

Return Value

The translated string.

See Also

UTF8 Class | StarTeam.Util Namespace


UTF8.Utf8ToUtf16 Method

Converts an array of characters in UTF-8 format to an array of UTF-16/Unicode characters.

public static int Utf8ToUtf16(
Byte[] src,
Char[] dst
);

Parameters

src
Source string, in UTF-8 format.
dst
Output buffer for unicode characters.

Return Value

The number of characters written. If dst is null, then only returns the number of chars needed.

See Also

UTF8 Class | StarTeam.Util Namespace


UTF8.Utf8ToUtf16Char Method

public static int Utf8ToUtf16Char(
Stream src
);

See Also

UTF8 Class | StarTeam.Util Namespace


XMLUtils Class

A class with XML related utility methods.

For a list of all members of this type, see XMLUtils Members.

System.Object
XMLUtils

public class XMLUtils

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Util

Assembly: StarTeam (in StarTeam.dll)

See Also

XMLUtils Members | StarTeam.Util Namespace


XMLUtils Members

XMLUtils overview

Public Static Methods

Escape | Returns the specified arbitrary text reformated in a form suitable for the contents of an XML element. In particular the following characters will be escaped: ", ', >, <, &
IsXML |
WriteEscaped | Overloaded.
WriteEscapedAttributeValue |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.XMLUtils.
GetHashCode | Delegate GetHashCode() to com.starteam.util.XMLUtils.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.XMLUtils.

See Also

XMLUtils Class | StarTeam.Util Namespace


XMLUtils Methods

The methods of the XMLUtils class are listed below. For a complete list of XMLUtils class members, see the XMLUtils Members topic.

Public Static Methods

Escape | Returns the specified arbitrary text reformated in a form suitable for the contents of an XML element. In particular the following characters will be escaped: ", ', >, <, &
IsXML |
WriteEscaped | Overloaded.
WriteEscapedAttributeValue |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.util.XMLUtils.
GetHashCode | Delegate GetHashCode() to com.starteam.util.XMLUtils.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.util.XMLUtils.

See Also

XMLUtils Class | StarTeam.Util Namespace


XMLUtils.Equals Method

Delegate Equals() to com.starteam.util.XMLUtils.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.util.XMLUtils.Equals(obj).

See Also

XMLUtils Class | StarTeam.Util Namespace


XMLUtils.Escape Method

Returns the specified arbitrary text reformated in a form suitable for the contents of an XML element. In particular the following characters will be escaped: ", ', >, <, &

public static string Escape(
String rawText
);

Parameters

rawText
the raw text to be encoded for XML output

See Also

XMLUtils Class | StarTeam.Util Namespace


XMLUtils.GetHashCode Method

Delegate GetHashCode() to com.starteam.util.XMLUtils.

public override int GetHashCode();

Return Value

com.starteam.util.XMLUtils.GetHashCode().

See Also

XMLUtils Class | StarTeam.Util Namespace


XMLUtils.IsXML Method

public static bool IsXML(
FileInfo file
);

See Also

XMLUtils Class | StarTeam.Util Namespace


XMLUtils.ToString Method

Delegate ToString() to com.starteam.util.XMLUtils.

public override string ToString();

Return Value

com.starteam.util.XMLUtils.ToString()

See Also

XMLUtils Class | StarTeam.Util Namespace


WriteEscaped Method

Borland StarTeam SDK for .NET

XMLUtils.WriteEscaped Method

Overload List

public static void WriteEscaped(String,TextWriter);

public static void WriteEscaped(String,StringBuilder);

See Also

XMLUtils Class | StarTeam.Util Namespace


XMLUtils.WriteEscaped Method (String, TextWriter)

public static void WriteEscaped(
String rawText,
TextWriter _out
);

See Also

XMLUtils Class | StarTeam.Util Namespace | XMLUtils.WriteEscaped Overload List


XMLUtils.WriteEscaped Method (String, StringBuilder)

public static void WriteEscaped(
String rawText,
StringBuilder _out
);

See Also

XMLUtils Class | StarTeam.Util Namespace | XMLUtils.WriteEscaped Overload List


XMLUtils.WriteEscapedAttributeValue Method

public static void WriteEscapedAttributeValue(
String rawText,
TextWriter _out
);

See Also

XMLUtils Class | StarTeam.Util Namespace


StarTeam.ViewCompareMerge

Borland StarTeam SDK for .NET

StarTeam.ViewCompareMerge Namespace

Namespace hierarchy

Classes

Class | Description
ActionOverride

Title: Starteam SDK

An object that provides a MergeState|DifferenceType / MergeAction pair

AmbiguousMatchException
AnyScope | Combines multiple scopes. An item is considered in scope if it is included in at least one member scope.
ChangePackageScope | A class that describes a ChangePackage scoped compare between two views to determine whether or not a full scoped merge may be reduced to a set of change packages since a last, predetermined compare.
CustomThreeWayMergeAdapter Facilitates the use of an external merge tool to resolve a Three-way file merge condition. For example:
 String app = "C:\\MyApp\\MyApp.exe"; String commandline = "-s $source -t $target -a $ancestor -out $result"; Note that each replaceable parameter (e.g. $source) must be separated from the next using the string separator ' \t', i.e. Blank space followed by TAB so for instance the example above needs to be annotated thus... ... -s \t$source \t -t \t $target \t ... FileMergeAdapter tool = new CustomThreeWayMergeAdapter(diff, app, commandline); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("MyApp failed with exit code: " + exitCode); }
DefaultActionProperty | Client-calculated property whose value is the default action of the ItemDifference associated with this item. For an item that has no associated ItemDifference, or that is not owned by the MergePreview of a View Compare/Merge session, the value of the DefaultActionActionProperty is always VALUE_NOT_SET (or the null EnumeratedValue).
DifferenceType | Classifies the relationship between a source item and a target item.
DifferenceTypeProperty | Client-calculated property whose value describes the relationship between the item in the source view and the corresponding item in the target view, within the context of the current View Compare/Merge session. For an item that is not owned by the MergePreview of a View Compare/Merge session, the value of the DifferenceTypeProperty is always VALUE_NOT_SET (or the null EnumeratedValue).
EveryScope | Combines multiple scopes. An item is considered in scope if it is included in every member scope.
FileMergeAdapter | An abstract class designed to facilitate the use of an external tool for resolving a file merge condition.
FolderScope | Allows folders to be included or excluded from the scope of the view compare/merge operation in a flexible way.
IsActionOverriddenProperty | Client-calculated property whose value is the current action of the ItemDifference associated with this item. For an item that has no associated ItemDifference, or that is not owned by the MergePreview of a View Compare/Merge session, the value of the IsActionOverriddenProperty is always VALUE_NOT_SET (or the null EnumeratedValue).
IsCheckedProperty | Client-calculated property whose value is the current check state of the ItemDifference associated with this item. For an item that has no associated ItemDifference, or that is not owned by the MergePreview of a View Compare/Merge session, the value of the IsCheckedProperty is always VALUE_NOT_SET (or the null EnumeratedValue).
ItemDifference | Represents the difference between a given item from the source view and the corresponding item in the target view.
ItemListScope | Allows items to be included or excluded from the scope of the view compare/merge operation in a flexible way.
ItemTypeScope | Allows item types to be included or excluded from the scope of the view compare/merge operation. Note that folders are always included in the view compare/merge operation, whether or not the ItemTypeScope explicitly reports indicates that they should be included.
MatchState | Describes the relationship between an item in the source view and an item in the target view.
MergeAction | An action that may be used to resolve a merge condition.
MergeActionProperty | Client-calculated property whose value is the current action of the ItemDifference associated with this item. For an item that has no associated ItemDifference, or that is not owned by the MergePreview of a View Compare/Merge session, the value of the MergeActionProperty is always VALUE_NOT_SET (or the null EnumeratedValue).
MergePreview

Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides

MergeStatusProperty | Client-calculated property whose value describes the status of an item relative to the current View Compare/Merge session. For an item that is not owned by the MergePreview of a View Compare/Merge session, the value of the MergeStatusProperty is always VALUE_NOT_SET (or the null EnumeratedValue).
MergeType | The type of view compare/merge operation to be performed.
Options | A set of user preferences that guide a view compare/merge operation. For any invocation of view compare and/or merge, these preferences may be overridden. The intent is that this set of preferences can be stored persistently and retrieved when setting up a view compare/merge operation, and that the set of options reflects what this user will usually want for the operation.
ProcessItemScope | Includes a process item, and the items that are linked and pinned to it, in the scope of a session.
Progress | Information on the progress of a Merge operation from ViewMerger. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use ViewMerger.getProgress().
RevisionLabelScope | Includes all item revisions with a given revision label in the scope of the view compare/merge session.
Scope

Provides a client application a flexible way to specify the scope of a view compare/merge operation.

The View Compare/Merge engine provides implementations of Scope that should suffice for most applications. In each case, the implementation is public, and may be re-used in the development of custom Scopes.
Session

A view compare/merge (VCM) session.

Each VCM session has associated source view and target views. {@linkplain #compare() Comparing} the two generates a set of {@linkplain #getDifferences() differences}. For each difference, you can detect {@linkplain ItemDifference#isConflictDetected conflicts}, {@linkplain ItemDifference#setAction override} default actions, and so on.

Conflicts may be resolved by merging {@linkplain ItemDifference#setMergedPropertyValue(com.starteam.Property, Object) item properties} or {@linkplain ItemDifference#setMergedFileContent(java.io.File) file content}. Alternatively, you can set property values or checkin new file revisions via the {@linkplain #getMergePreview merge preview}, which shows what the target view would look like were the session to be committed in its current state.

When ready, you can {@linkplain #commit() commit} the changes, which updates the target view.

For general information on using the VCM APIs, see com.starteam.viewcomparemerge.
Session.State | The state of the sesion. A session may be in one and only one of these states at any given time.
StarTeamFileMergeAdapter Facilitates the use of the StarTeam File Compare / Merge tool (also known as "DeltaII") to resolve a file merge condition. Used as follows:
 FileMergeAdapter tool = new StarTeamFileMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("Merge failed with exit code: " + exitCode); }
Note that StarTeam File Compare / Merge is the default file merge tool in StarTeam 9.0 and later. It replaces VisMerge.exe, which is now obsolete.
VCMFolder | A folder belonging to the Merge Preview It has all the characteristics of a regular StarTeam Folder, and describes the Preview State of its constituent Items and/or Sub-Folders
VCMFolder.PreviewState | The preview state represents a highest precedence summary of all contained items and sub-folders and their contents. "has conflicts" is higher than "has changes" which is higher than "has compared items" which is higher than "has no compared items". A folder, for example, may contain items (directly or via sub-folders) in each of the four states, but the current value represents the highest precedence.
ViewCompareMergeProperty | A client-calculated property meaningful only in the context of view compare/merge. All view compare/merge properties derive from this class.
VisMergeAdapter Facilitates the use of the StarTeam VisMerge tool to resolve a file merge condition. Used as follows:
 VisMergeAdapter tool = new VisMergeAdapter(diff); tool.setIgnoreWhiteSpace(true); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("VisMerge failed with exit code: " + exitCode); }
Note that VisMerge was the default file merge tool in StarTeam 8.0 and earlier.
WorkstationDefaultMergeAdapter Uses the workstation default merge tool to resolve a file merge condition. For example:
 FileMergeAdapter tool = new WorkstationDefaultMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("The merge failed with exit code: " + exitCode); }
Note that if no file merge tool is registered in starteam-client-options.xml, then StarTeam File Compare / Merge (also known as "Delta II") is used by default.


ActionOverride Class

Title: Starteam SDK

An object that provides a MergeState|DifferenceType / MergeAction pair

For a list of all members of this type, see ActionOverride Members.

System.Object
ActionOverride

public class ActionOverride

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

ActionOverride Members | StarTeam.ViewCompareMerge Namespace


ActionOverride Members

ActionOverride overview

Public Instance Properties

DifferenceType | [read] DifferenceType the DifferenceType contained within this ActionOverride
MatchState | [read] MatchState the MatchState contained within this ActionOverride
MergeAction | [read] MergeAction the MergeAction contained within this ActionOverride

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.ActionOverride.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.ActionOverride.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.ActionOverride.

See Also

ActionOverride Class | StarTeam.ViewCompareMerge Namespace


ActionOverride Properties

The properties of the ActionOverride class are listed below. For a complete list of ActionOverride class members, see the ActionOverride Members topic.

Public Instance Properties

DifferenceType | [read] DifferenceType the DifferenceType contained within this ActionOverride
MatchState | [read] MatchState the MatchState contained within this ActionOverride
MergeAction | [read] MergeAction the MergeAction contained within this ActionOverride

See Also

ActionOverride Class | StarTeam.ViewCompareMerge Namespace


DifferenceType Property

Borland StarTeam SDK for .NET

ActionOverride.DifferenceType Property

[read] DifferenceType the DifferenceType contained within this ActionOverride

public virtual DifferenceType DifferenceType {get;}

Property Value

DifferenceType the DifferenceType contained within this ActionOverride

See Also

ActionOverride Class | StarTeam.ViewCompareMerge Namespace


MatchState Property

Borland StarTeam SDK for .NET

ActionOverride.MatchState Property

[read] MatchState the MatchState contained within this ActionOverride

public virtual MatchState MatchState {get;}

Property Value

MatchState the MatchState contained within this ActionOverride

See Also

ActionOverride Class | StarTeam.ViewCompareMerge Namespace


MergeAction Property

Borland StarTeam SDK for .NET

ActionOverride.MergeAction Property

[read] MergeAction the MergeAction contained within this ActionOverride

public virtual MergeAction MergeAction {get;}

Property Value

MergeAction the MergeAction contained within this ActionOverride

See Also

ActionOverride Class | StarTeam.ViewCompareMerge Namespace


ActionOverride Methods

The methods of the ActionOverride class are listed below. For a complete list of ActionOverride class members, see the ActionOverride Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.ActionOverride.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.ActionOverride.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.ActionOverride.

See Also

ActionOverride Class | StarTeam.ViewCompareMerge Namespace


ActionOverride.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.ActionOverride.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.ActionOverride.Equals(obj).

See Also

ActionOverride Class | StarTeam.ViewCompareMerge Namespace


ActionOverride.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.ActionOverride.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.ActionOverride.GetHashCode().

See Also

ActionOverride Class | StarTeam.ViewCompareMerge Namespace


ActionOverride.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.ActionOverride.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.ActionOverride.ToString()

See Also

ActionOverride Class | StarTeam.ViewCompareMerge Namespace


AmbiguousMatchException Class

For a list of all members of this type, see AmbiguousMatchException Members.

System.Object
Exception
AmbiguousMatchException

public class AmbiguousMatchException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

AmbiguousMatchException Members | StarTeam.ViewCompareMerge Namespace


AmbiguousMatchException Members

AmbiguousMatchException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsItemFromSourceView |
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.AmbiguousMatchException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.AmbiguousMatchException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.AmbiguousMatchException.

See Also

AmbiguousMatchException Class | StarTeam.ViewCompareMerge Namespace


AmbiguousMatchException Properties

The properties of the AmbiguousMatchException class are listed below. For a complete list of AmbiguousMatchException class members, see the AmbiguousMatchException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
IsItemFromSourceView |
Item |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

AmbiguousMatchException Class | StarTeam.ViewCompareMerge Namespace


IsItemFromSourceView Property

Borland StarTeam SDK for .NET

AmbiguousMatchException.IsItemFromSourceView Property

public virtual Boolean IsItemFromSourceView {get;}

See Also

AmbiguousMatchException Class | StarTeam.ViewCompareMerge Namespace


Item Property

Borland StarTeam SDK for .NET

AmbiguousMatchException.Item Property

public virtual Item Item {get;}

See Also

AmbiguousMatchException Class | StarTeam.ViewCompareMerge Namespace


AmbiguousMatchException Methods

The methods of the AmbiguousMatchException class are listed below. For a complete list of AmbiguousMatchException class members, see the AmbiguousMatchException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.AmbiguousMatchException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.AmbiguousMatchException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.AmbiguousMatchException.

See Also

AmbiguousMatchException Class | StarTeam.ViewCompareMerge Namespace


AmbiguousMatchException.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.AmbiguousMatchException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.AmbiguousMatchException.Equals(obj).

See Also

AmbiguousMatchException Class | StarTeam.ViewCompareMerge Namespace


AmbiguousMatchException.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.AmbiguousMatchException.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.AmbiguousMatchException.GetHashCode().

See Also

AmbiguousMatchException Class | StarTeam.ViewCompareMerge Namespace


AmbiguousMatchException.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.AmbiguousMatchException.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.AmbiguousMatchException.ToString()

See Also

AmbiguousMatchException Class | StarTeam.ViewCompareMerge Namespace


AnyScope Class

Combines multiple scopes. An item is considered in scope if it is included in at least one member scope.

For a list of all members of this type, see AnyScope Members.

System.Object
Scope
AnyScope

public class AnyScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

AnyScope Members | StarTeam.ViewCompareMerge Namespace


AnyScope Members

AnyScope overview

Public Instance Constructors

AnyScope Overloaded. Initializes a new instance of the AnyScope class.

Public Instance Properties

Description (inherited from Scope) | [read] a String that provides a description of this scope.
ItemTypes (inherited from Scope) | [read] The list of types to be processed.

Public Instance Methods

Add | Adds the given member scope.
Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope (inherited from Scope) |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Remove | Removes the given member scope.
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

AnyScope Class | StarTeam.ViewCompareMerge Namespace


AnyScope Constructor

Creates an empty scope.

Overload List

Creates an empty scope.

public AnyScope();

Creates a scope that initially contains the given members.

public AnyScope(Scope[]);

See Also

AnyScope Class | StarTeam.ViewCompareMerge Namespace


AnyScope Constructor ()

Creates an empty scope.

public AnyScope();

See Also

AnyScope Class | StarTeam.ViewCompareMerge Namespace | AnyScope Constructor Overload List


AnyScope Constructor (Scope[])

Creates a scope that initially contains the given members.

public AnyScope(
Scope[] scopes
);

Parameters

scopes
an array of scopes to include

See Also

AnyScope Class | StarTeam.ViewCompareMerge Namespace | AnyScope Constructor Overload List


AnyScope Methods

The methods of the AnyScope class are listed below. For a complete list of AnyScope class members, see the AnyScope Members topic.

Public Instance Methods

Add | Adds the given member scope.
Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope (inherited from Scope) |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Remove | Removes the given member scope.
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

AnyScope Class | StarTeam.ViewCompareMerge Namespace


AnyScope.Add Method

Adds the given member scope.

public virtual void Add(
Scope scope
);

Parameters

scope
The scope to be added.

See Also

AnyScope Class | StarTeam.ViewCompareMerge Namespace


AnyScope.Remove Method

Removes the given member scope.

public virtual void Remove(
Scope scope
);

Parameters

scope
The scope to be removed.

See Also

AnyScope Class | StarTeam.ViewCompareMerge Namespace


ChangePackageScope Class

A class that describes a ChangePackage scoped compare between two views to determine whether or not a full scoped merge may be reduced to a set of change packages since a last, predetermined compare.

For a list of all members of this type, see ChangePackageScope Members.

System.Object
ChangePackageScope

public class ChangePackageScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

ChangePackageScope Members | StarTeam.ViewCompareMerge Namespace


ChangePackageScope Members

ChangePackageScope overview

Public Instance Constructors

ChangePackageScope Constructor Construct a Scope Helper

Public Instance Properties

SourceCPs | [read] a set of ChangePackage's that need to be merged.
TargetCP | [read] a ChangePackage from the target view or NULL

Public Instance Methods

AreChangePackagesEnforced | returns TRUE if the containing project enforces workspace change packages
Equals | Delegate Equals() to com.starteam.viewcomparemerge.ChangePackageScope.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.ChangePackageScope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.ChangePackageScope.

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


ChangePackageScope Constructor

Construct a Scope Helper

public ChangePackageScope(
MergeType mergeType,
View source,
View target
);

Parameters

mergeType
the merge type
source
the source view
target
the target view

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


ChangePackageScope Properties

The properties of the ChangePackageScope class are listed below. For a complete list of ChangePackageScope class members, see the ChangePackageScope Members topic.

Public Instance Properties

SourceCPs | [read] a set of ChangePackage's that need to be merged.
TargetCP | [read] a ChangePackage from the target view or NULL

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


SourceCPs Property

Borland StarTeam SDK for .NET

ChangePackageScope.SourceCPs Property

[read] a set of ChangePackage's that need to be merged.

public virtual ChangePackage[] SourceCPs {get;}

Property Value

a set of ChangePackage's that need to be merged.

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


TargetCP Property

Borland StarTeam SDK for .NET

ChangePackageScope.TargetCP Property

[read] a ChangePackage from the target view or NULL

public virtual ChangePackage TargetCP {get;}

Property Value

a ChangePackage from the target view or NULL

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


ChangePackageScope Methods

The methods of the ChangePackageScope class are listed below. For a complete list of ChangePackageScope class members, see the ChangePackageScope Members topic.

Public Instance Methods

AreChangePackagesEnforced | returns TRUE if the containing project enforces workspace change packages
Equals | Delegate Equals() to com.starteam.viewcomparemerge.ChangePackageScope.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.ChangePackageScope.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.ChangePackageScope.

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


ChangePackageScope.AreChangePackagesEnforced Method

returns TRUE if the containing project enforces workspace change packages

public virtual bool AreChangePackagesEnforced();

Return Value

TRUE if the containing project enforces workspace change packages

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


ChangePackageScope.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.ChangePackageScope.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.ChangePackageScope.Equals(obj).

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


ChangePackageScope.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.ChangePackageScope.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.ChangePackageScope.GetHashCode().

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


ChangePackageScope.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.ChangePackageScope.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.ChangePackageScope.ToString()

See Also

ChangePackageScope Class | StarTeam.ViewCompareMerge Namespace


CustomThreeWayMergeAdapter Class

Facilitates the use of an external merge tool to resolve a Three-way file merge condition. For example:

 String app = "C:\\MyApp\\MyApp.exe"; String commandline = "-s $source -t $target -a $ancestor -out $result"; Note that each replaceable parameter (e.g. $source) must be separated from the next using the string separator ' \t', i.e. Blank space followed by TAB so for instance the example above needs to be annotated thus... ... -s \t$source \t -t \t $target \t ... FileMergeAdapter tool = new CustomThreeWayMergeAdapter(diff, app, commandline); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("MyApp failed with exit code: " + exitCode); }

For a list of all members of this type, see CustomThreeWayMergeAdapter Members.

System.Object
FileMergeAdapter
CustomThreeWayMergeAdapter

public class CustomThreeWayMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

CustomThreeWayMergeAdapter Members | StarTeam.ViewCompareMerge Namespace


CustomThreeWayMergeAdapter Members

CustomThreeWayMergeAdapter overview

Public Instance Constructors

CustomThreeWayMergeAdapter Constructor Constructs an adapter for resolving a given file merge condition.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starteam.viewcomparemerge.FileMergeAdapter.

See Also

CustomThreeWayMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


CustomThreeWayMergeAdapter Constructor

Constructs an adapter for resolving a given file merge condition.

public CustomThreeWayMergeAdapter(
ItemDifference diff,
String application,
String commandline
);

Parameters

diff
The ItemDifference whose file merge condition is to be resolved.
application
The path to the external application to be run.
commandline
The paramaters to be passed to the application on the command line. May contain the special command-line symbols defined in FileMergeAdapter, which are expanded to file names before the application is executed.

See Also

CustomThreeWayMergeAdapter Class | StarTeam.ViewCompareMerge Namespace | PARAM_SOURCE_FILE | PARAM_TARGET_FILE | PARAM_COMMON_ANCESTOR | PARAM_OUTPUT_FILE


DefaultActionProperty Class

Client-calculated property whose value is the default action of the ItemDifference associated with this item. For an item that has no associated ItemDifference, or that is not owned by the MergePreview of a View Compare/Merge session, the value of the DefaultActionActionProperty is always VALUE_NOT_SET (or the null EnumeratedValue).

For a list of all members of this type, see DefaultActionProperty Members.

System.Object
Property
EnumeratedProperty
ViewCompareMergeProperty
MergeActionProperty
DefaultActionProperty

public class DefaultActionProperty : MergeActionProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

DefaultActionProperty Members | StarTeam.ViewCompareMerge Namespace


DefaultActionProperty Members

DefaultActionProperty overview

Public Static Properties

ID
NAME

Public Instance Constructors

DefaultActionProperty Constructor Creates a new MergeActionProperty.

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromMergeAction (inherited from MergeActionProperty) | Gets the EnumeratedValue corresponding to a given MergeAction.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

DefaultActionProperty Class | StarTeam.ViewCompareMerge Namespace


DefaultActionProperty Constructor

Creates a new MergeActionProperty.

public DefaultActionProperty(
Type type
);

Parameters

type
The associated Type.

See Also

DefaultActionProperty Class | StarTeam.ViewCompareMerge Namespace


DefaultActionProperty Properties

The properties of the DefaultActionProperty class are listed below. For a complete list of DefaultActionProperty class members, see the DefaultActionProperty Members topic.

Public Static Properties

ID
NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

DefaultActionProperty Class | StarTeam.ViewCompareMerge Namespace


ID Property

Borland StarTeam SDK for .NET

DefaultActionProperty.ID Property

new public static Int32 ID {get;}

See Also

DefaultActionProperty Class | StarTeam.ViewCompareMerge Namespace


NAME Property

Borland StarTeam SDK for .NET

DefaultActionProperty.NAME Property

new public static String NAME {get;}

See Also

DefaultActionProperty Class | StarTeam.ViewCompareMerge Namespace


DifferenceType Class

Classifies the relationship between a source item and a target item.

For a list of all members of this type, see DifferenceType Members.

System.Object
DifferenceType

public class DifferenceType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

DifferenceType Members | StarTeam.ViewCompareMerge Namespace


DifferenceType Members

DifferenceType overview

Public Static Properties

All [read] A list of all defined DifferenceTypes.

Public Static Methods

FromID | Finds a DifferenceType by ID.
Lookup | Searches the list of known difference types, returning the one that describes the given match state.

Public Instance Properties

DefaultAction | [read] The default action for this difference type.
Description | [read] A description of this DifferenceType.
ID | [read] The unique ID associated with this DifferenceType.
IsDifference | [read] True if this difference type should really be considered a difference; false otherwise.
LegalActions | [read] The set of all possible legal actions for a given merge type.
MatchState | [read] A copy of the MatchState associated with this DifferenceType.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.DifferenceType.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.DifferenceType.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalAction | Determines whether or not the given action is a legal action for this difference type.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.DifferenceType.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DifferenceType Properties

The properties of the DifferenceType class are listed below. For a complete list of DifferenceType class members, see the DifferenceType Members topic.

Public Static Properties

All [read] A list of all defined DifferenceTypes.

Public Instance Properties

DefaultAction | [read] The default action for this difference type.
Description | [read] A description of this DifferenceType.
ID | [read] The unique ID associated with this DifferenceType.
IsDifference | [read] True if this difference type should really be considered a difference; false otherwise.
LegalActions | [read] The set of all possible legal actions for a given merge type.
MatchState | [read] A copy of the MatchState associated with this DifferenceType.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


All Property

Borland StarTeam SDK for .NET

DifferenceType.All Property

[read] A list of all defined DifferenceTypes.

public static DifferenceType[] All {get;}

Property Value

A list of all defined DifferenceTypes.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DefaultAction Property

Borland StarTeam SDK for .NET

DifferenceType.DefaultAction Property

[read] The default action for this difference type.

public virtual MergeAction DefaultAction {get;}

Property Value

The default action for this difference type.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


Description Property

Borland StarTeam SDK for .NET

DifferenceType.Description Property

[read] A description of this DifferenceType.

public virtual String Description {get;}

Property Value

A description of this DifferenceType.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


ID Property

Borland StarTeam SDK for .NET

DifferenceType.ID Property

[read] The unique ID associated with this DifferenceType.

public virtual Int32 ID {get;}

Property Value

The unique ID associated with this DifferenceType.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


IsDifference Property

Borland StarTeam SDK for .NET

DifferenceType.IsDifference Property

[read] True if this difference type should really be considered a difference; false otherwise.

public virtual Boolean IsDifference {get;}

Property Value

True if this difference type should really be considered a difference; false otherwise.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


LegalActions Property

Borland StarTeam SDK for .NET

DifferenceType.LegalActions Property

[read] The set of all possible legal actions for a given merge type.

public virtual MergeAction[] LegalActions {get;}

Property Value

The set of all possible legal actions for a given merge type.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


MatchState Property

Borland StarTeam SDK for .NET

DifferenceType.MatchState Property

[read] A copy of the MatchState associated with this DifferenceType.

public virtual MatchState MatchState {get;}

Property Value

A copy of the MatchState associated with this DifferenceType.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DifferenceType Methods

The methods of the DifferenceType class are listed below. For a complete list of DifferenceType class members, see the DifferenceType Members topic.

Public Static Methods

FromID | Finds a DifferenceType by ID.
Lookup | Searches the list of known difference types, returning the one that describes the given match state.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.DifferenceType.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.DifferenceType.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalAction | Determines whether or not the given action is a legal action for this difference type.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.DifferenceType.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DifferenceType.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.DifferenceType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.DifferenceType.Equals(obj).

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DifferenceType.FromID Method

Finds a DifferenceType by ID.

public static DifferenceType FromID(
Int32 id
);

Parameters

id
int

Return Value

DifferenceType

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DifferenceType.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.DifferenceType.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.DifferenceType.GetHashCode().

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DifferenceType.IsLegalAction Method

Determines whether or not the given action is a legal action for this difference type.

public virtual bool IsLegalAction(
MergeAction action
);

Parameters

action
The MergeAction to be tested.

Return Value

True if the action is legal for this difference type; false otherwise.

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DifferenceType.Lookup Method

Searches the list of known difference types, returning the one that describes the given match state.

public static DifferenceType Lookup(
MatchState state
);

Parameters

state
the Match State to look for

Return Value

the Difference Type

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DifferenceType.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.DifferenceType.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.DifferenceType.ToString()

See Also

DifferenceType Class | StarTeam.ViewCompareMerge Namespace


DifferenceTypeProperty Class

Client-calculated property whose value describes the relationship between the item in the source view and the corresponding item in the target view, within the context of the current View Compare/Merge session. For an item that is not owned by the MergePreview of a View Compare/Merge session, the value of the DifferenceTypeProperty is always VALUE_NOT_SET (or the null EnumeratedValue).

For a list of all members of this type, see DifferenceTypeProperty Members.

System.Object
Property
EnumeratedProperty
ViewCompareMergeProperty
DifferenceTypeProperty

public class DifferenceTypeProperty : ViewCompareMergeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

DifferenceTypeProperty Members | StarTeam.ViewCompareMerge Namespace


DifferenceTypeProperty Members

DifferenceTypeProperty overview

Public Static Properties

ID
NAME

Public Static Methods

ToDifferenceType Gets the DifferenceType corresponding to a given EnumeratedValue.

Public Instance Constructors

DifferenceTypeProperty Constructor Creates a new DifferenceTypeProperty.

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromDifferenceType | Gets the EnumeratedValue corresponding to a given DifferenceType.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

DifferenceTypeProperty Class | StarTeam.ViewCompareMerge Namespace


DifferenceTypeProperty Constructor

Creates a new DifferenceTypeProperty.

public DifferenceTypeProperty(
Type type
);

Parameters

type
The associated Type.

See Also

DifferenceTypeProperty Class | StarTeam.ViewCompareMerge Namespace


DifferenceTypeProperty Properties

The properties of the DifferenceTypeProperty class are listed below. For a complete list of DifferenceTypeProperty class members, see the DifferenceTypeProperty Members topic.

Public Static Properties

ID
NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

DifferenceTypeProperty Class | StarTeam.ViewCompareMerge Namespace


ID Property

Borland StarTeam SDK for .NET

DifferenceTypeProperty.ID Property

new public static Int32 ID {get;}

See Also

DifferenceTypeProperty Class | StarTeam.ViewCompareMerge Namespace


NAME Property

Borland StarTeam SDK for .NET

DifferenceTypeProperty.NAME Property

public static String NAME {get;}

See Also

DifferenceTypeProperty Class | StarTeam.ViewCompareMerge Namespace


DifferenceTypeProperty Methods

The methods of the DifferenceTypeProperty class are listed below. For a complete list of DifferenceTypeProperty class members, see the DifferenceTypeProperty Members topic.

Public Static Methods

ToDifferenceType Gets the DifferenceType corresponding to a given EnumeratedValue.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromDifferenceType | Gets the EnumeratedValue corresponding to a given DifferenceType.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

DifferenceTypeProperty Class | StarTeam.ViewCompareMerge Namespace


DifferenceTypeProperty.FromDifferenceType Method

Gets the EnumeratedValue corresponding to a given DifferenceType.

public virtual EnumeratedValue FromDifferenceType(
DifferenceType difftype
);

Parameters

difftype
A DifferenceType.

Return Value

The corresponding EnumeratedValue.

See Also

DifferenceTypeProperty Class | StarTeam.ViewCompareMerge Namespace | DifferenceType


DifferenceTypeProperty.ToDifferenceType Method

Gets the DifferenceType corresponding to a given EnumeratedValue.

public static DifferenceType ToDifferenceType(
EnumeratedValue value
);

Parameters

value
An EnumeratedValue.

Return Value

The corresponding DifferenceType.

See Also

DifferenceTypeProperty Class | StarTeam.ViewCompareMerge Namespace | DifferenceType


EveryScope Class

Combines multiple scopes. An item is considered in scope if it is included in every member scope.

For a list of all members of this type, see EveryScope Members.

System.Object
Scope
EveryScope

public class EveryScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

EveryScope Members | StarTeam.ViewCompareMerge Namespace


EveryScope Members

EveryScope overview

Public Instance Constructors

EveryScope Overloaded. Initializes a new instance of the EveryScope class.

Public Instance Properties

Description (inherited from Scope) | [read] a String that provides a description of this scope.
ItemTypes (inherited from Scope) | [read] The list of types to be processed.

Public Instance Methods

Add | Adds the given member scope.
Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope (inherited from Scope) |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Remove | Removes the given member scope.
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

EveryScope Class | StarTeam.ViewCompareMerge Namespace


EveryScope Constructor

Creates an empty scope.

Overload List

Creates an empty scope.

public EveryScope();

Creates a scope that initially contains the given members.

public EveryScope(Scope[]);

See Also

EveryScope Class | StarTeam.ViewCompareMerge Namespace


EveryScope Constructor ()

Creates an empty scope.

public EveryScope();

See Also

EveryScope Class | StarTeam.ViewCompareMerge Namespace | EveryScope Constructor Overload List


EveryScope Constructor (Scope[])

Creates a scope that initially contains the given members.

public EveryScope(
Scope[] scopes
);

Parameters

scopes
the scopes to include

See Also

EveryScope Class | StarTeam.ViewCompareMerge Namespace | EveryScope Constructor Overload List


EveryScope Methods

The methods of the EveryScope class are listed below. For a complete list of EveryScope class members, see the EveryScope Members topic.

Public Instance Methods

Add | Adds the given member scope.
Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope (inherited from Scope) |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Remove | Removes the given member scope.
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

EveryScope Class | StarTeam.ViewCompareMerge Namespace


EveryScope.Add Method

Adds the given member scope.

public virtual void Add(
Scope scope
);

Parameters

scope
The scope to be added.

See Also

EveryScope Class | StarTeam.ViewCompareMerge Namespace


EveryScope.Remove Method

Removes the given member scope.

public virtual void Remove(
Scope scope
);

Parameters

scope
The scope to be removed.

See Also

EveryScope Class | StarTeam.ViewCompareMerge Namespace


FileMergeAdapter Class

An abstract class designed to facilitate the use of an external tool for resolving a file merge condition.

For a list of all members of this type, see FileMergeAdapter Members.

System.Object
FileMergeAdapter
CustomThreeWayMergeAdapter
StarTeamFileMergeAdapter
VisMergeAdapter
WorkstationDefaultMergeAdapter

public class FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

FileMergeAdapter Members | StarTeam.ViewCompareMerge Namespace


FileMergeAdapter Members

FileMergeAdapter overview

Public Static Properties

PARAM_COMMON_ANCESTOR
PARAM_OUTPUT_FILE
PARAM_SOURCE_ANCESTOR
PARAM_SOURCE_FILE
PARAM_TARGET_ANCESTOR
PARAM_TARGET_FILE

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.FileMergeAdapter.

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


FileMergeAdapter Properties

The properties of the FileMergeAdapter class are listed below. For a complete list of FileMergeAdapter class members, see the FileMergeAdapter Members topic.

Public Static Properties

PARAM_COMMON_ANCESTOR
PARAM_OUTPUT_FILE
PARAM_SOURCE_ANCESTOR
PARAM_SOURCE_FILE
PARAM_TARGET_ANCESTOR
PARAM_TARGET_FILE

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


PARAM_COMMON_ANCESTOR Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_COMMON_ANCESTOR Property

public static String PARAM_COMMON_ANCESTOR {get;}

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


PARAM_OUTPUT_FILE Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_OUTPUT_FILE Property

public static String PARAM_OUTPUT_FILE {get;}

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


PARAM_SOURCE_ANCESTOR Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_SOURCE_ANCESTOR Property

public static String PARAM_SOURCE_ANCESTOR {get;}

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


PARAM_SOURCE_FILE Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_SOURCE_FILE Property

public static String PARAM_SOURCE_FILE {get;}

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


PARAM_TARGET_ANCESTOR Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_TARGET_ANCESTOR Property

public static String PARAM_TARGET_ANCESTOR {get;}

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


PARAM_TARGET_FILE Property

Borland StarTeam SDK for .NET

FileMergeAdapter.PARAM_TARGET_FILE Property

public static String PARAM_TARGET_FILE {get;}

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


FileMergeAdapter Methods

The methods of the FileMergeAdapter class are listed below. For a complete list of FileMergeAdapter class members, see the FileMergeAdapter Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.FileMergeAdapter.

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


FileMergeAdapter.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.FileMergeAdapter.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.FileMergeAdapter.Equals(obj).

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


FileMergeAdapter.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.FileMergeAdapter.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.FileMergeAdapter.GetHashCode().

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


FileMergeAdapter.Merge Method

Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference.

If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved.

Any temporary files created during the process are automatically removed.

public virtual int Merge();

Return Value

The tool's exit code. Zero on success.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


FileMergeAdapter.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.FileMergeAdapter.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.FileMergeAdapter.ToString()

See Also

FileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


FolderScope Class

Allows folders to be included or excluded from the scope of the view compare/merge operation in a flexible way.

For a list of all members of this type, see FolderScope Members.

System.Object
Scope
FolderScope

public class FolderScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

FolderScope Members | StarTeam.ViewCompareMerge Namespace


FolderScope Members

FolderScope overview

Public Instance Constructors

FolderScope Overloaded. Initializes a new instance of the FolderScope class.

Public Instance Properties

Description (inherited from Scope) | [read] a String that provides a description of this scope.
ItemTypes (inherited from Scope) | [read] The list of types to be processed.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope (inherited from Scope) |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace


FolderScope Constructor

Creates a new FolderScope that includes the files in the given source folder.

Overload List

Creates a new FolderScope that includes the files in the given source folder.

public FolderScope(Folder);

public FolderScope(Folder,Item.Type);

Creates a new FolderScope that includes the items of all of the given types in the given source folder.

public FolderScope(Folder,TypeCollection);

Creates a new FolderScope that includes the files in the given source folder, and optionally in all of its child folders at any depth.

public FolderScope(Folder,Boolean);

public FolderScope(Folder,Boolean,Item.Type);

Construct a folder scope

public FolderScope(Folder,Boolean,TypeCollection);

Creates a new FolderScope that includes all of the folders indicated by the given FolderListManager. The client application is free to include or exclude folders from the FolderListManager at any time. Changes will be reflected in the scope after the next refresh().

public FolderScope(FolderListManager);

public FolderScope(FolderListManager,Item.Type);

Construct a Folder Scope

public FolderScope(FolderListManager,TypeCollection);

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace


FolderScope Constructor (Folder)

Creates a new FolderScope that includes the files in the given source folder.

public FolderScope(
Folder f
);

Parameters

f
A folder in the source view.

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, Item#Type)

public FolderScope(
Folder f,
Item.Type type
);

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, TypeCollection)

Creates a new FolderScope that includes the items of all of the given types in the given source folder.

public FolderScope(
Folder f,
TypeCollection types
);

Parameters

f
A folder in the source view.
types
A list of item types.

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, Boolean)

Creates a new FolderScope that includes the files in the given source folder, and optionally in all of its child folders at any depth.

public FolderScope(
Folder f,
Boolean bIncludeSubfolders
);

Parameters

f
A folder in the source view.
bIncludeSubfolders
true to include files in child folders; false to include only the files in the folder itself.

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, Boolean, Item#Type)

public FolderScope(
Folder f,
Boolean bIncludeSubfolders,
Item.Type type
);

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (Folder, Boolean, TypeCollection)

Construct a folder scope

public FolderScope(
Folder f,
Boolean bIncludeSubfolders,
TypeCollection tc
);

Parameters

f
the folder to include
bIncludeSubfolders
true to include sub folders
tc
the types of the items included in scope

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (FolderListManager)

Creates a new FolderScope that includes all of the folders indicated by the given FolderListManager.

The client application is free to include or exclude folders from the FolderListManager at any time. Changes will be reflected in the scope after the next refresh().

public FolderScope(
FolderListManager folders
);

Parameters

folders
The FolderListManager that describes the scope.

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace | FolderScope Constructor Overload List | FolderListManager


FolderScope Constructor (FolderListManager, Item#Type)

public FolderScope(
FolderListManager folders,
Item.Type type
);

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace | FolderScope Constructor Overload List


FolderScope Constructor (FolderListManager, TypeCollection)

Construct a Folder Scope

public FolderScope(
FolderListManager folders,
TypeCollection tc
);

Parameters

folders
the folders to include
tc
the types to include

See Also

FolderScope Class | StarTeam.ViewCompareMerge Namespace | FolderScope Constructor Overload List


IsActionOverriddenProperty Class

Client-calculated property whose value is the current action of the ItemDifference associated with this item. For an item that has no associated ItemDifference, or that is not owned by the MergePreview of a View Compare/Merge session, the value of the IsActionOverriddenProperty is always VALUE_NOT_SET (or the null EnumeratedValue).

For a list of all members of this type, see IsActionOverriddenProperty Members.

System.Object
Property
EnumeratedProperty
ViewCompareMergeProperty
IsActionOverriddenProperty

public class IsActionOverriddenProperty : ViewCompareMergeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

IsActionOverriddenProperty Members | StarTeam.ViewCompareMerge Namespace


IsActionOverriddenProperty Members

IsActionOverriddenProperty overview

Public Static Properties

ID
NAME

Public Instance Constructors

IsActionOverriddenProperty Constructor Creates a new MergeActionProperty.

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
NO_VALUE |
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.
YES_VALUE |

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

IsActionOverriddenProperty Class | StarTeam.ViewCompareMerge Namespace


IsActionOverriddenProperty Constructor

Creates a new MergeActionProperty.

public IsActionOverriddenProperty(
Type type
);

Parameters

type
The associated Type.

See Also

IsActionOverriddenProperty Class | StarTeam.ViewCompareMerge Namespace


IsActionOverriddenProperty Properties

The properties of the IsActionOverriddenProperty class are listed below. For a complete list of IsActionOverriddenProperty class members, see the IsActionOverriddenProperty Members topic.

Public Static Properties

ID
NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
NO_VALUE |
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.
YES_VALUE |

See Also

IsActionOverriddenProperty Class | StarTeam.ViewCompareMerge Namespace


ID Property

Borland StarTeam SDK for .NET

IsActionOverriddenProperty.ID Property

new public static Int32 ID {get;}

See Also

IsActionOverriddenProperty Class | StarTeam.ViewCompareMerge Namespace


NAME Property

Borland StarTeam SDK for .NET

IsActionOverriddenProperty.NAME Property

public static String NAME {get;}

See Also

IsActionOverriddenProperty Class | StarTeam.ViewCompareMerge Namespace


NO_VALUE Property

Borland StarTeam SDK for .NET

IsActionOverriddenProperty.NO_VALUE Property

public EnumeratedValue NO_VALUE {get;}

See Also

IsActionOverriddenProperty Class | StarTeam.ViewCompareMerge Namespace


YES_VALUE Property

Borland StarTeam SDK for .NET

IsActionOverriddenProperty.YES_VALUE Property

public EnumeratedValue YES_VALUE {get;}

See Also

IsActionOverriddenProperty Class | StarTeam.ViewCompareMerge Namespace


IsCheckedProperty Class

Client-calculated property whose value is the current check state of the ItemDifference associated with this item. For an item that has no associated ItemDifference, or that is not owned by the MergePreview of a View Compare/Merge session, the value of the IsCheckedProperty is always VALUE_NOT_SET (or the null EnumeratedValue).

For a list of all members of this type, see IsCheckedProperty Members.

System.Object
Property
EnumeratedProperty
ViewCompareMergeProperty
IsCheckedProperty

public class IsCheckedProperty : ViewCompareMergeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

IsCheckedProperty Members | StarTeam.ViewCompareMerge Namespace


IsCheckedProperty Members

IsCheckedProperty overview

Public Static Properties

ID
NAME

Public Instance Constructors

IsCheckedProperty Constructor Creates a new MergeActionProperty.

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
NO_VALUE |
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.
YES_VALUE |

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

IsCheckedProperty Class | StarTeam.ViewCompareMerge Namespace


IsCheckedProperty Constructor

Creates a new MergeActionProperty.

public IsCheckedProperty(
Type type
);

Parameters

type
The associated Type.

See Also

IsCheckedProperty Class | StarTeam.ViewCompareMerge Namespace


IsCheckedProperty Properties

The properties of the IsCheckedProperty class are listed below. For a complete list of IsCheckedProperty class members, see the IsCheckedProperty Members topic.

Public Static Properties

ID
NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
NO_VALUE |
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.
YES_VALUE |

See Also

IsCheckedProperty Class | StarTeam.ViewCompareMerge Namespace


ID Property

Borland StarTeam SDK for .NET

IsCheckedProperty.ID Property

new public static Int32 ID {get;}

See Also

IsCheckedProperty Class | StarTeam.ViewCompareMerge Namespace


NAME Property

Borland StarTeam SDK for .NET

IsCheckedProperty.NAME Property

public static String NAME {get;}

See Also

IsCheckedProperty Class | StarTeam.ViewCompareMerge Namespace


NO_VALUE Property

Borland StarTeam SDK for .NET

IsCheckedProperty.NO_VALUE Property

public EnumeratedValue NO_VALUE {get;}

See Also

IsCheckedProperty Class | StarTeam.ViewCompareMerge Namespace


YES_VALUE Property

Borland StarTeam SDK for .NET

IsCheckedProperty.YES_VALUE Property

public EnumeratedValue YES_VALUE {get;}

See Also

IsCheckedProperty Class | StarTeam.ViewCompareMerge Namespace


ItemDifference Class

Represents the difference between a given item from the source view and the corresponding item in the target view.

For a list of all members of this type, see ItemDifference Members.

System.Object
ItemDifference

public class ItemDifference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemDifference Members | StarTeam.ViewCompareMerge Namespace


ItemDifference Members

ItemDifference overview

Public Instance Properties

Action | [read/write] The action that will be performed at commit time.
Checked | [read/write] true if this difference has been checked
DefaultAction | [read] The default action recommended when merging this difference to the target view.
Description | [read] A user-friendly description of this difference.
DifferenceType | [read] The difference type associated with this difference.
IsCommitted | [read] true if this difference has been committed.
IsConflictDetected | [read] true if this difference represents a merge conflict, and false otherwise.
IsFileCheckin | [read] true if applying the current action would result in a file checkin.
IsFileMerge | [read] true if this difference represents an file merge condition.
IsNonTipReverseShare | [read] true if committing this difference resulted in a reverse share from a non-tip revision.
IsPropertyMerge | [read] true if there is at least one item property requiring a merge, whether or not the merge condition has already been resolved.
IsUnresolved | [read] true if this difference has an unresolved merge condition, and false otherwise.
IsUnresolvedFileMerge | [read] true if this difference represents an unresolved file merge condition.
IsUnresolvedPropertyMerge | [read] true if there is at least one item property with a merge condition that has not yet been resolved.
LegalActions | [read] The list of merge actions that are legal for this difference.
MergedFileContent | [read/write] The path to the file where the merged file content for this difference resides.
MergedFileContentItem | [read/write] The StarTeam file revision whose content was used as the merged file content for this difference.
MergedItem | [read] An item that closely approximates the state the target item after the merge, if the session were to be committed in its current state.
Session | [read] The VCM session to which this difference belongs.
SourceAncestor | [read] The item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.
SourceItem | [read] The source item associated with this difference, or null.
SourceItemForCompare | [read] The source item associated with this difference, or null
TargetAncestor | [read] The item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.
TargetItem | [read] The target item associated with this difference, or null.
TargetItemForCompare | [read] The target item associated with this difference, or null
Type | [read] The item type of the source and target items in this difference.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.ItemDifference.
GetAffectedDifferences | Determines which differences would be affected if the merge action for this difference were changed to the given one. For example, consider a folder that is "New in source". Changing the action from {@linkplain MergeAction#REVERSE_SHARE reverse share} to {@linkplain MergeAction#IGNORE ignore} would also affect the differences for any "New in source" files in that folder. (If the folder isn't shared, its children won't be either.) This method does not actually change the actions of any differences; the changes would not occur unless {@link #setAction setAction} were called.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.ItemDifference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalAction | Determines whether or not the given action is a legal action for this item difference.
IsPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
IsUnresolvedPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.
SetMergedPropertyValue | Sets the value of the specified property on the merged item. This is the property value that will be saved to the target item at commit time. Setting the property value resolves any outstanding merge conflict associated with this property. Alternatively, an application can change the property value using the normal {@link TypedResource#setValue(Property,Object) setValue} and {@link Item#update() update} methods available on the {@linkplain #getMergedItem merged item}.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.ItemDifference.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


ItemDifference Properties

The properties of the ItemDifference class are listed below. For a complete list of ItemDifference class members, see the ItemDifference Members topic.

Public Instance Properties

Action | [read/write] The action that will be performed at commit time.
Checked | [read/write] true if this difference has been checked
DefaultAction | [read] The default action recommended when merging this difference to the target view.
Description | [read] A user-friendly description of this difference.
DifferenceType | [read] The difference type associated with this difference.
IsCommitted | [read] true if this difference has been committed.
IsConflictDetected | [read] true if this difference represents a merge conflict, and false otherwise.
IsFileCheckin | [read] true if applying the current action would result in a file checkin.
IsFileMerge | [read] true if this difference represents an file merge condition.
IsNonTipReverseShare | [read] true if committing this difference resulted in a reverse share from a non-tip revision.
IsPropertyMerge | [read] true if there is at least one item property requiring a merge, whether or not the merge condition has already been resolved.
IsUnresolved | [read] true if this difference has an unresolved merge condition, and false otherwise.
IsUnresolvedFileMerge | [read] true if this difference represents an unresolved file merge condition.
IsUnresolvedPropertyMerge | [read] true if there is at least one item property with a merge condition that has not yet been resolved.
LegalActions | [read] The list of merge actions that are legal for this difference.
MergedFileContent | [read/write] The path to the file where the merged file content for this difference resides.
MergedFileContentItem | [read/write] The StarTeam file revision whose content was used as the merged file content for this difference.
MergedItem | [read] An item that closely approximates the state the target item after the merge, if the session were to be committed in its current state.
Session | [read] The VCM session to which this difference belongs.
SourceAncestor | [read] The item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.
SourceItem | [read] The source item associated with this difference, or null.
SourceItemForCompare | [read] The source item associated with this difference, or null
TargetAncestor | [read] The item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.
TargetItem | [read] The target item associated with this difference, or null.
TargetItemForCompare | [read] The target item associated with this difference, or null
Type | [read] The item type of the source and target items in this difference.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


Action Property

Borland StarTeam SDK for .NET

ItemDifference.Action Property

[read/write] The action that will be performed at commit time.

public virtual MergeAction Action {get; set;}

Property Value

The action that will be performed at commit time.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


Checked Property

Borland StarTeam SDK for .NET

ItemDifference.Checked Property

[read/write] true if this difference has been checked

public virtual Boolean Checked {get; set;}

Property Value

true if this difference has been checked

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


DefaultAction Property

Borland StarTeam SDK for .NET

ItemDifference.DefaultAction Property

[read] The default action recommended when merging this difference to the target view.

public virtual MergeAction DefaultAction {get;}

Property Value

The default action recommended when merging this difference to the target view.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


Description Property

Borland StarTeam SDK for .NET

ItemDifference.Description Property

[read] A user-friendly description of this difference.

public virtual String Description {get;}

Property Value

A user-friendly description of this difference.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


DifferenceType Property

Borland StarTeam SDK for .NET

ItemDifference.DifferenceType Property

[read] The difference type associated with this difference.

public virtual DifferenceType DifferenceType {get;}

Property Value

The difference type associated with this difference.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


IsCommitted Property

Borland StarTeam SDK for .NET

ItemDifference.IsCommitted Property

[read] true if this difference has been committed.

public virtual Boolean IsCommitted {get;}

Property Value

true if this difference has been committed.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


IsConflictDetected Property

Borland StarTeam SDK for .NET

ItemDifference.IsConflictDetected Property

[read] true if this difference represents a merge conflict, and false otherwise.

public virtual Boolean IsConflictDetected {get;}

Property Value

true if this difference represents a merge conflict, and false otherwise.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


IsFileCheckin Property

Borland StarTeam SDK for .NET

ItemDifference.IsFileCheckin Property

[read] true if applying the current action would result in a file checkin.

public virtual Boolean IsFileCheckin {get;}

Property Value

true if applying the current action would result in a file checkin.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


IsFileMerge Property

Borland StarTeam SDK for .NET

ItemDifference.IsFileMerge Property

[read] true if this difference represents an file merge condition.

public virtual Boolean IsFileMerge {get;}

Property Value

true if this difference represents an file merge condition.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


IsNonTipReverseShare Property

Borland StarTeam SDK for .NET

ItemDifference.IsNonTipReverseShare Property

[read] true if committing this difference resulted in a reverse share from a non-tip revision.

public virtual Boolean IsNonTipReverseShare {get;}

Property Value

true if committing this difference resulted in a reverse share from a non-tip revision.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


IsPropertyMerge Property

Borland StarTeam SDK for .NET

ItemDifference.IsPropertyMerge Property

[read] true if there is at least one item property requiring a merge, whether or not the merge condition has already been resolved.

public virtual Boolean IsPropertyMerge {get;}

Property Value

true if there is at least one item property requiring a merge, whether or not the merge condition has already been resolved.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


IsUnresolved Property

Borland StarTeam SDK for .NET

ItemDifference.IsUnresolved Property

[read] true if this difference has an unresolved merge condition, and false otherwise.

public virtual Boolean IsUnresolved {get;}

Property Value

true if this difference has an unresolved merge condition, and false otherwise.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


IsUnresolvedFileMerge Property

Borland StarTeam SDK for .NET

ItemDifference.IsUnresolvedFileMerge Property

[read] true if this difference represents an unresolved file merge condition.

public virtual Boolean IsUnresolvedFileMerge {get;}

Property Value

true if this difference represents an unresolved file merge condition.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


IsUnresolvedPropertyMerge Property

Borland StarTeam SDK for .NET

ItemDifference.IsUnresolvedPropertyMerge Property

[read] true if there is at least one item property with a merge condition that has not yet been resolved.

public virtual Boolean IsUnresolvedPropertyMerge {get;}

Property Value

true if there is at least one item property with a merge condition that has not yet been resolved.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


LegalActions Property

Borland StarTeam SDK for .NET

ItemDifference.LegalActions Property

[read] The list of merge actions that are legal for this difference.

public virtual MergeAction[] LegalActions {get;}

Property Value

The list of merge actions that are legal for this difference.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


MergedFileContent Property

Borland StarTeam SDK for .NET

ItemDifference.MergedFileContent Property

[read/write] The path to the file where the merged file content for this difference resides.

public virtual FileInfo MergedFileContent {get; set;}

Property Value

The path to the file where the merged file content for this difference resides.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


MergedFileContentItem Property

Borland StarTeam SDK for .NET

ItemDifference.MergedFileContentItem Property

[read/write] The StarTeam file revision whose content was used as the merged file content for this difference.

public virtual File MergedFileContentItem {get; set;}

Property Value

The StarTeam file revision whose content was used as the merged file content for this difference.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


MergedItem Property

Borland StarTeam SDK for .NET

ItemDifference.MergedItem Property

[read] An item that closely approximates the state the target item after the merge, if the session were to be committed in its current state.

public virtual Item MergedItem {get;}

Property Value

An item that closely approximates the state the target item after the merge, if the session were to be committed in its current state.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


Session Property

Borland StarTeam SDK for .NET

ItemDifference.Session Property

[read] The VCM session to which this difference belongs.

public virtual Session Session {get;}

Property Value

The VCM session to which this difference belongs.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


SourceAncestor Property

Borland StarTeam SDK for .NET

ItemDifference.SourceAncestor Property

[read] The item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.

public virtual Item SourceAncestor {get;}

Property Value

The item from the source item's history that was used to determine whether the source item has changed or moved since the last merge operation.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


SourceItem Property

Borland StarTeam SDK for .NET

ItemDifference.SourceItem Property

[read] The source item associated with this difference, or null.

public virtual Item SourceItem {get;}

Property Value

The source item associated with this difference, or null.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


SourceItemForCompare Property

Borland StarTeam SDK for .NET

ItemDifference.SourceItemForCompare Property

[read] The source item associated with this difference, or null

public virtual Item SourceItemForCompare {get;}

Property Value

The source item associated with this difference, or null

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


TargetAncestor Property

Borland StarTeam SDK for .NET

ItemDifference.TargetAncestor Property

[read] The item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.

public virtual Item TargetAncestor {get;}

Property Value

The item from the target item's history that was used to determine whether the target item has changed or moved since the last merge operation.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


TargetItem Property

Borland StarTeam SDK for .NET

ItemDifference.TargetItem Property

[read] The target item associated with this difference, or null.

public virtual Item TargetItem {get;}

Property Value

The target item associated with this difference, or null.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


TargetItemForCompare Property

Borland StarTeam SDK for .NET

ItemDifference.TargetItemForCompare Property

[read] The target item associated with this difference, or null

public virtual Item TargetItemForCompare {get;}

Property Value

The target item associated with this difference, or null

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


Type Property

Borland StarTeam SDK for .NET

ItemDifference.Type Property

[read] The item type of the source and target items in this difference.

public virtual Item.Type Type {get;}

Property Value

The item type of the source and target items in this difference.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


ItemDifference Methods

The methods of the ItemDifference class are listed below. For a complete list of ItemDifference class members, see the ItemDifference Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.ItemDifference.
GetAffectedDifferences | Determines which differences would be affected if the merge action for this difference were changed to the given one. For example, consider a folder that is "New in source". Changing the action from {@linkplain MergeAction#REVERSE_SHARE reverse share} to {@linkplain MergeAction#IGNORE ignore} would also affect the differences for any "New in source" files in that folder. (If the folder isn't shared, its children won't be either.) This method does not actually change the actions of any differences; the changes would not occur unless {@link #setAction setAction} were called.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.ItemDifference.
GetType (inherited from Object) | Gets the Type of the current instance.
IsLegalAction | Determines whether or not the given action is a legal action for this item difference.
IsPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.
IsUnresolvedPropertyMergeFor | Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.
SetMergedPropertyValue | Sets the value of the specified property on the merged item. This is the property value that will be saved to the target item at commit time. Setting the property value resolves any outstanding merge conflict associated with this property. Alternatively, an application can change the property value using the normal {@link TypedResource#setValue(Property,Object) setValue} and {@link Item#update() update} methods available on the {@linkplain #getMergedItem merged item}.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.ItemDifference.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


ItemDifference.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.ItemDifference.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.ItemDifference.Equals(obj).

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


ItemDifference.GetAffectedDifferences Method

Determines which differences would be affected if the merge action for this difference were changed to the given one.

For example, consider a folder that is "New in source". Changing the action from {@linkplain MergeAction#REVERSE_SHARE reverse share} to {@linkplain MergeAction#IGNORE ignore} would also affect the differences for any "New in source" files in that folder. (If the folder isn't shared, its children won't be either.)

This method does not actually change the actions of any differences; the changes would not occur unless {@link #setAction setAction} were called.

public virtual ItemDifference[] GetAffectedDifferences(
MergeAction newAction
);

Parameters

newAction
the action to test against

Return Value

A list of the effected differences. The list is empty (zero length) if the action isn't changing, or isn't legal for this difference.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace | setAction | getLegalActions


ItemDifference.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.ItemDifference.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.ItemDifference.GetHashCode().

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


ItemDifference.IsLegalAction Method

Determines whether or not the given action is a legal action for this item difference.

public virtual bool IsLegalAction(
MergeAction action
);

Parameters

action
The MergeAction to be tested.

Return Value

True if the action is legal for this item difference; false otherwise.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace | isLegalAction | getLegalActions


ItemDifference.IsPropertyMergeFor Method

Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition. Note that the merge condition may or may not have been resolved.

public virtual bool IsPropertyMergeFor(
Property property
);

Parameters

property
An item property.

Return Value

true if the given item property requires a merge, whether or not the merge condition has already been resolved.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace | isPropertyMerge | isUnresolvedPropertyMergeFor | setMergedPropertyValue


ItemDifference.IsUnresolvedPropertyMergeFor Method

Determines whether or not the given property has changed in both the source item and target item in such a way as to create a merge condition, and that merge condition has not yet been resolved.

public virtual bool IsUnresolvedPropertyMergeFor(
Property property
);

Parameters

property
An item property.

Return Value

true if the given item property has a merge condition that has not yet been resolved.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace | isUnresolvedPropertyMerge | isPropertyMergeFor | setMergedPropertyValue


ItemDifference.SetMergedPropertyValue Method

Sets the value of the specified property on the merged item. This is the property value that will be saved to the target item at commit time.

Setting the property value resolves any outstanding merge conflict associated with this property.

Alternatively, an application can change the property value using the normal {@link TypedResource#setValue(Property,Object) setValue} and {@link Item#update() update} methods available on the {@linkplain #getMergedItem merged item}.

public virtual object SetMergedPropertyValue(
Property property,
Object value
);

Parameters

property
The property whose value is to be changed.
value
The new property value.

Return Value

The previous value of the property.

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace | isPropertyMerge | isPropertyMergeFor | getMergedItem | setValue | update


ItemDifference.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.ItemDifference.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.ItemDifference.ToString()

See Also

ItemDifference Class | StarTeam.ViewCompareMerge Namespace


ItemListScope Class

Allows items to be included or excluded from the scope of the view compare/merge operation in a flexible way.

For a list of all members of this type, see ItemListScope Members.

System.Object
Scope
ItemListScope

public class ItemListScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemListScope Members | StarTeam.ViewCompareMerge Namespace


ItemListScope Members

ItemListScope overview

Public Instance Constructors

ItemListScope Overloaded. Initializes a new instance of the ItemListScope class.

Public Instance Properties

Description (inherited from Scope) | [read] a String that provides a description of this scope.
ItemTypes (inherited from Scope) | [read] The list of types to be processed.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope (inherited from Scope) |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

ItemListScope Class | StarTeam.ViewCompareMerge Namespace


ItemListScope Constructor

Create an ItemListScope for the specified Item

Overload List

Create an ItemListScope for the specified Item

public ItemListScope(Item);

Create an ItemListScope from an array of Items

public ItemListScope(ViewMemberCollection);

See Also

ItemListScope Class | StarTeam.ViewCompareMerge Namespace


ItemListScope Constructor (Item)

Create an ItemListScope for the specified Item

public ItemListScope(
Item item
);

Parameters

item
Item the Item to be included in this scope

See Also

ItemListScope Class | StarTeam.ViewCompareMerge Namespace | ItemListScope Constructor Overload List


ItemListScope Constructor (ViewMemberCollection)

Create an ItemListScope from an array of Items

public ItemListScope(
ViewMemberCollection items
);

Parameters

items
Item[] an array of Items

See Also

ItemListScope Class | StarTeam.ViewCompareMerge Namespace | ItemListScope Constructor Overload List


ItemTypeScope Class

Allows item types to be included or excluded from the scope of the view compare/merge operation. Note that folders are always included in the view compare/merge operation, whether or not the ItemTypeScope explicitly reports indicates that they should be included.

For a list of all members of this type, see ItemTypeScope Members.

System.Object
Scope
ItemTypeScope

public class ItemTypeScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

ItemTypeScope Members | StarTeam.ViewCompareMerge Namespace


ItemTypeScope Members

ItemTypeScope overview

Public Static Methods

ForAllTypes | Gets an ItemTypeScope containing all supported item types.
ForDefaultTypes | Gets an ItemTypeScope containing the default types (files and folders).

Public Instance Constructors

ItemTypeScope Overloaded. Initializes a new instance of the ItemTypeScope class.

Public Instance Properties

Description (inherited from Scope) | [read] a String that provides a description of this scope.
ItemTypes | [write] Sets the item types that are to be included in the view compare/merge operation.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
ExcludeItemType |
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeItemType |
IsFullScope (inherited from Scope) |
IsIncluded |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


ItemTypeScope Constructor

Creates an empty ItemTypeScope.

Overload List

Creates an empty ItemTypeScope.

public ItemTypeScope();

public ItemTypeScope(Item.Type);

Creates an ItemTypeScope that includes the given list of types.

public ItemTypeScope(TypeCollection);

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


ItemTypeScope Constructor ()

Creates an empty ItemTypeScope.

public ItemTypeScope();

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace | ItemTypeScope Constructor Overload List


ItemTypeScope Constructor (Item#Type)

public ItemTypeScope(
Item.Type type
);

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace | ItemTypeScope Constructor Overload List


ItemTypeScope Constructor (TypeCollection)

Creates an ItemTypeScope that includes the given list of types.

public ItemTypeScope(
TypeCollection types
);

Parameters

types
The list of types to be included.

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace | ItemTypeScope Constructor Overload List


ItemTypeScope Properties

The properties of the ItemTypeScope class are listed below. For a complete list of ItemTypeScope class members, see the ItemTypeScope Members topic.

Public Instance Properties

Description (inherited from Scope) | [read] a String that provides a description of this scope.
ItemTypes | [write] Sets the item types that are to be included in the view compare/merge operation.

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


ItemTypes Property

Borland StarTeam SDK for .NET

ItemTypeScope.ItemTypes Property

[write] Sets the item types that are to be included in the view compare/merge operation.

new public virtual TypeCollection ItemTypes {set;}

Property Value

Sets the item types that are to be included in the view compare/merge operation.

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


ItemTypeScope Methods

The methods of the ItemTypeScope class are listed below. For a complete list of ItemTypeScope class members, see the ItemTypeScope Members topic.

Public Static Methods

ForAllTypes | Gets an ItemTypeScope containing all supported item types.
ForDefaultTypes | Gets an ItemTypeScope containing the default types (files and folders).

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
ExcludeItemType |
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IncludeItemType |
IsFullScope (inherited from Scope) |
IsIncluded |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


ItemTypeScope.ExcludeItemType Method

public virtual void ExcludeItemType(
Item.Type type
);

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


ItemTypeScope.ForAllTypes Method

Gets an ItemTypeScope containing all supported item types.

public static ItemTypeScope ForAllTypes(
Server s
);

Parameters

s
The server.

Return Value

An ItemTypeScope containing all supported item types.

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


ItemTypeScope.ForDefaultTypes Method

Gets an ItemTypeScope containing the default types (files and folders).

public static ItemTypeScope ForDefaultTypes(
Server s
);

Parameters

s
The server.

Return Value

An ItemTypeScope containing the default types (files and folders).

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


ItemTypeScope.IncludeItemType Method

public virtual void IncludeItemType(
Item.Type type
);

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


ItemTypeScope.IsIncluded Method

public virtual bool IsIncluded(
Item.Type type
);

See Also

ItemTypeScope Class | StarTeam.ViewCompareMerge Namespace


MatchState Class

Describes the relationship between an item in the source view and an item in the target view.

For a list of all members of this type, see MatchState Members.

System.Object
MatchState

public class MatchState

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

MatchState Members | StarTeam.ViewCompareMerge Namespace


MatchState Members

MatchState overview

Public Instance Constructors

MatchState Overloaded. Initializes a new instance of the MatchState class.

Public Instance Properties

ItemDeletedInSource | [read/write] Boolean.TRUE if the item is deleted in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemDeletedInTarget | [read/write] Boolean.TRUE if the item is deleted in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemIsBinaryFile | [read/write] Boolean.TRUE if the item is a binary file. Default value is null ("Don't Know" / "Don't Care").
ItemModifiedInSource | [read/write] Boolean.TRUE if the item is modified in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemModifiedInTarget | [read/write] Boolean.TRUE if the item is modified in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemMovedInSource | [read/write] Boolean.TRUE if the item is moved in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemMovedInTarget | [read/write] Boolean.TRUE if the item is moved in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemPresentInSource | [read/write] Boolean.TRUE if the item is present in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemPresentInTarget | [read/write] Boolean.TRUE if the item is present in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemReadOnlyInTarget | [read/write] Boolean.TRUE if the item is read-only in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemsHaveSameContent | [read/write] Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").
ItemsInDifferentBranches | [read/write] Boolean.TRUE if the items are in different branches. Default value is null ("Don't Know" / "Don't Care").
ItemType | [read/write] The item type. Default value is null, indicating that any type is acceptable.
MergeType | [read/write] The merge type. Default value is null, indicating that any merge type is acceptable.
ParentFolderFailed | [read/write] Boolean.TRUE if the target item's parent folder failed to be reconciled. Default value is null ("Don't Know" / "Don't Care").
ParentFolderIgnored | [read/write] Boolean.TRUE if the target item's parent folder is ignored. Default value is null ("Don't Know" / "Don't Care").
SomeChangedPropertiesExcludedFromMerge | [read/write] Boolean.TRUE if at least one changed property has been excluded from the merge. Default value is null ("Don't Know" / "Don't Care").
SourceChildShareOfTarget | [read/write] Boolean.TRUE if the source item is a child share of the target item. Default value is null ("Don't Know" / "Don't Care").
SourceIsFloating | [read/write] Boolean.TRUE if the source item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").
SourceItemHasAHigherRevisionMerged | [read/write] true if the Source Item has a higher revision already merged
SourceItemIsNonTipRevision | [write] Indicates whether or not the source item is from history
SourceItemIsNotTipRevision | [read] true if the Source Item is a historical revision
SourceItemOnRootBranch | [read/write] Boolean.TRUE if the source item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").
TargetChildShareOfSource | [read/write] Boolean.TRUE if the target item is a child share of the source item. Default value is null ("Don't Know" / "Don't Care").
TargetFolderHasFloatingShares | [read/write] Boolean.TRUE if the target item's parent folder has floating child shares. Default value is null ("Don't Know" / "Don't Care").
TargetIsFloating | [read/write] Boolean.TRUE if the target item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").
TargetItemOnRootBranch | [read/write] Boolean.TRUE if the target item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").
TargetViewHasMultipleFloatingSharesWithSameOID | [read/write] true if the Target View has Multiple Floating Shares with the same Object ID

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.MatchState.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.MatchState.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches | Determines whether or not this MatchState matches the conditions specified by the given pattern. "Don't Care" values in the pattern are ignored; other values in the pattern must match exactly.
SetItemDeletedInSource | Indicates whether or not the item in question is deleted in the source view.
SetItemDeletedInTarget | Indicates whether or not the item in question is deleted in the target view.
SetItemIsBinaryFile | Indicates whether or not the item in question is a binary file.
SetItemModifiedInSource | Indicates whether or not the item in question is modified in the source view.
SetItemModifiedInTarget | Indicates whether or not the item in question is modified in the target view.
SetItemMovedInSource | Indicates whether or not the item in question is moved in the source view.
SetItemMovedInTarget | Indicates whether or not the item in question is moved in the target view.
SetItemPresentInSource | Indicates whether or not the item in question is present in the source view.
SetItemPresentInTarget | Indicates whether or not the item in question is present in the target view.
SetItemReadOnlyInTarget | Indicates whether or not the item in question is read-only in the target view.
SetItemsHaveSameContent | Indicates whether or not the source and target items have identical content.
SetItemsInDifferentBranches | Indicates whether or not the source and target items are in different branches of the object's version tree.
SetParentFolderFailed | Indicates whether or not the target item's parent folder failed to be reconciled.
SetParentFolderIgnored | Indicates whether or not the target item's parent folder is ignored.
SetSomeChangedPropertiesExcludedFromMerge | Indicates whether or not at least one changed property has been excluded from the merge.
SetSourceChildShareOfTarget | Indicates whether or not the source item is a child share of the target item.
SetSourceIsFloating | Indicates whether or not the source item has a floating configuration.
SetSourceItemHasAHigherRevisionMerged | Indicates whether or not the source item has a higher revision already merged
SetSourceItemIsNonTipRevision | Indicates whether or not the source item is from history
SetSourceItemOnRootBranch | Indicates whether or not the source item is on the root branch of the share tree.
SetTargetChildShareOfSource | Indicates whether or not the target item is a child share of the source item.
SetTargetFolderHasFloatingShares | Indicates whether or not the target item's parent folder has floating child shares.
SetTargetIsFloating | Indicates whether or not the target item has a floating configuration.
SetTargetItemOnRootBranch | Indicates whether or not the target item is on the root branch of the share tree.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.MatchState.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


MatchState Constructor

Constructs a new MatchState. Properties are initialized to their "Don't Know" / "Don't Care" values.

Overload List

Constructs a new MatchState. Properties are initialized to their "Don't Know" / "Don't Care" values.

public MatchState();

Constructs a new MatchState that is a copy of an existing one.

public MatchState(MatchState);

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


MatchState Constructor ()

Constructs a new MatchState. Properties are initialized to their "Don't Know" / "Don't Care" values.

public MatchState();

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | MatchState Constructor Overload List


MatchState Constructor (MatchState)

Constructs a new MatchState that is a copy of an existing one.

public MatchState(
MatchState state
);

Parameters

state
the MatchState to use to construct this one

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | MatchState Constructor Overload List


MatchState Properties

The properties of the MatchState class are listed below. For a complete list of MatchState class members, see the MatchState Members topic.

Public Instance Properties

ItemDeletedInSource | [read/write] Boolean.TRUE if the item is deleted in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemDeletedInTarget | [read/write] Boolean.TRUE if the item is deleted in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemIsBinaryFile | [read/write] Boolean.TRUE if the item is a binary file. Default value is null ("Don't Know" / "Don't Care").
ItemModifiedInSource | [read/write] Boolean.TRUE if the item is modified in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemModifiedInTarget | [read/write] Boolean.TRUE if the item is modified in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemMovedInSource | [read/write] Boolean.TRUE if the item is moved in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemMovedInTarget | [read/write] Boolean.TRUE if the item is moved in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemPresentInSource | [read/write] Boolean.TRUE if the item is present in the source view. Default value is null ("Don't Know" / "Don't Care").
ItemPresentInTarget | [read/write] Boolean.TRUE if the item is present in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemReadOnlyInTarget | [read/write] Boolean.TRUE if the item is read-only in the target view. Default value is null ("Don't Know" / "Don't Care").
ItemsHaveSameContent | [read/write] Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").
ItemsInDifferentBranches | [read/write] Boolean.TRUE if the items are in different branches. Default value is null ("Don't Know" / "Don't Care").
ItemType | [read/write] The item type. Default value is null, indicating that any type is acceptable.
MergeType | [read/write] The merge type. Default value is null, indicating that any merge type is acceptable.
ParentFolderFailed | [read/write] Boolean.TRUE if the target item's parent folder failed to be reconciled. Default value is null ("Don't Know" / "Don't Care").
ParentFolderIgnored | [read/write] Boolean.TRUE if the target item's parent folder is ignored. Default value is null ("Don't Know" / "Don't Care").
SomeChangedPropertiesExcludedFromMerge | [read/write] Boolean.TRUE if at least one changed property has been excluded from the merge. Default value is null ("Don't Know" / "Don't Care").
SourceChildShareOfTarget | [read/write] Boolean.TRUE if the source item is a child share of the target item. Default value is null ("Don't Know" / "Don't Care").
SourceIsFloating | [read/write] Boolean.TRUE if the source item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").
SourceItemHasAHigherRevisionMerged | [read/write] true if the Source Item has a higher revision already merged
SourceItemIsNonTipRevision | [write] Indicates whether or not the source item is from history
SourceItemIsNotTipRevision | [read] true if the Source Item is a historical revision
SourceItemOnRootBranch | [read/write] Boolean.TRUE if the source item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").
TargetChildShareOfSource | [read/write] Boolean.TRUE if the target item is a child share of the source item. Default value is null ("Don't Know" / "Don't Care").
TargetFolderHasFloatingShares | [read/write] Boolean.TRUE if the target item's parent folder has floating child shares. Default value is null ("Don't Know" / "Don't Care").
TargetIsFloating | [read/write] Boolean.TRUE if the target item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").
TargetItemOnRootBranch | [read/write] Boolean.TRUE if the target item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").
TargetViewHasMultipleFloatingSharesWithSameOID | [read/write] true if the Target View has Multiple Floating Shares with the same Object ID

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemDeletedInSource Property

Borland StarTeam SDK for .NET

MatchState.ItemDeletedInSource Property

[read/write] Boolean.TRUE if the item is deleted in the source view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemDeletedInSource {get; set;}

Property Value

Boolean.TRUE if the item is deleted in the source view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemDeletedInTarget Property

Borland StarTeam SDK for .NET

MatchState.ItemDeletedInTarget Property

[read/write] Boolean.TRUE if the item is deleted in the target view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemDeletedInTarget {get; set;}

Property Value

Boolean.TRUE if the item is deleted in the target view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemIsBinaryFile Property

Borland StarTeam SDK for .NET

MatchState.ItemIsBinaryFile Property

[read/write] Boolean.TRUE if the item is a binary file. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemIsBinaryFile {get; set;}

Property Value

Boolean.TRUE if the item is a binary file. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemModifiedInSource Property

Borland StarTeam SDK for .NET

MatchState.ItemModifiedInSource Property

[read/write] Boolean.TRUE if the item is modified in the source view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemModifiedInSource {get; set;}

Property Value

Boolean.TRUE if the item is modified in the source view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemModifiedInTarget Property

Borland StarTeam SDK for .NET

MatchState.ItemModifiedInTarget Property

[read/write] Boolean.TRUE if the item is modified in the target view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemModifiedInTarget {get; set;}

Property Value

Boolean.TRUE if the item is modified in the target view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemMovedInSource Property

Borland StarTeam SDK for .NET

MatchState.ItemMovedInSource Property

[read/write] Boolean.TRUE if the item is moved in the source view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemMovedInSource {get; set;}

Property Value

Boolean.TRUE if the item is moved in the source view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemMovedInTarget Property

Borland StarTeam SDK for .NET

MatchState.ItemMovedInTarget Property

[read/write] Boolean.TRUE if the item is moved in the target view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemMovedInTarget {get; set;}

Property Value

Boolean.TRUE if the item is moved in the target view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemPresentInSource Property

Borland StarTeam SDK for .NET

MatchState.ItemPresentInSource Property

[read/write] Boolean.TRUE if the item is present in the source view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemPresentInSource {get; set;}

Property Value

Boolean.TRUE if the item is present in the source view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemPresentInTarget Property

Borland StarTeam SDK for .NET

MatchState.ItemPresentInTarget Property

[read/write] Boolean.TRUE if the item is present in the target view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemPresentInTarget {get; set;}

Property Value

Boolean.TRUE if the item is present in the target view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemReadOnlyInTarget Property

Borland StarTeam SDK for .NET

MatchState.ItemReadOnlyInTarget Property

[read/write] Boolean.TRUE if the item is read-only in the target view. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemReadOnlyInTarget {get; set;}

Property Value

Boolean.TRUE if the item is read-only in the target view. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemsHaveSameContent Property

Borland StarTeam SDK for .NET

MatchState.ItemsHaveSameContent Property

[read/write] Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemsHaveSameContent {get; set;}

Property Value

Boolean.TRUE if the source and target items have identical content. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemsInDifferentBranches Property

Borland StarTeam SDK for .NET

MatchState.ItemsInDifferentBranches Property

[read/write] Boolean.TRUE if the items are in different branches. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ItemsInDifferentBranches {get; set;}

Property Value

Boolean.TRUE if the items are in different branches. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ItemType Property

Borland StarTeam SDK for .NET

MatchState.ItemType Property

[read/write] The item type. Default value is null, indicating that any type is acceptable.

public virtual Item.Type ItemType {get; set;}

Property Value

The item type. Default value is null, indicating that any type is acceptable.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


MergeType Property

Borland StarTeam SDK for .NET

MatchState.MergeType Property

[read/write] The merge type. Default value is null, indicating that any merge type is acceptable.

public virtual MergeType MergeType {get; set;}

Property Value

The merge type. Default value is null, indicating that any merge type is acceptable.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ParentFolderFailed Property

Borland StarTeam SDK for .NET

MatchState.ParentFolderFailed Property

[read/write] Boolean.TRUE if the target item's parent folder failed to be reconciled. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ParentFolderFailed {get; set;}

Property Value

Boolean.TRUE if the target item's parent folder failed to be reconciled. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


ParentFolderIgnored Property

Borland StarTeam SDK for .NET

MatchState.ParentFolderIgnored Property

[read/write] Boolean.TRUE if the target item's parent folder is ignored. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean ParentFolderIgnored {get; set;}

Property Value

Boolean.TRUE if the target item's parent folder is ignored. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


SomeChangedPropertiesExcludedFromMerge Property

Borland StarTeam SDK for .NET

MatchState.SomeChangedPropertiesExcludedFromMerge Property

[read/write] Boolean.TRUE if at least one changed property has been excluded from the merge. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean SomeChangedPropertiesExcludedFromMerge {get; set;}

Property Value

Boolean.TRUE if at least one changed property has been excluded from the merge. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


SourceChildShareOfTarget Property

Borland StarTeam SDK for .NET

MatchState.SourceChildShareOfTarget Property

[read/write] Boolean.TRUE if the source item is a child share of the target item. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean SourceChildShareOfTarget {get; set;}

Property Value

Boolean.TRUE if the source item is a child share of the target item. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


SourceIsFloating Property

Borland StarTeam SDK for .NET

MatchState.SourceIsFloating Property

[read/write] Boolean.TRUE if the source item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean SourceIsFloating {get; set;}

Property Value

Boolean.TRUE if the source item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


SourceItemHasAHigherRevisionMerged Property

Borland StarTeam SDK for .NET

MatchState.SourceItemHasAHigherRevisionMerged Property

[read/write] true if the Source Item has a higher revision already merged

public virtual Boolean SourceItemHasAHigherRevisionMerged {get; set;}

Property Value

true if the Source Item has a higher revision already merged

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


SourceItemIsNonTipRevision Property

Borland StarTeam SDK for .NET

MatchState.SourceItemIsNonTipRevision Property

[write] Indicates whether or not the source item is from history

public virtual Boolean SourceItemIsNonTipRevision {set;}

Property Value

Indicates whether or not the source item is from history

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


SourceItemIsNotTipRevision Property

Borland StarTeam SDK for .NET

MatchState.SourceItemIsNotTipRevision Property

[read] true if the Source Item is a historical revision

public virtual Boolean SourceItemIsNotTipRevision {get;}

Property Value

true if the Source Item is a historical revision

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


SourceItemOnRootBranch Property

Borland StarTeam SDK for .NET

MatchState.SourceItemOnRootBranch Property

[read/write] Boolean.TRUE if the source item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean SourceItemOnRootBranch {get; set;}

Property Value

Boolean.TRUE if the source item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


TargetChildShareOfSource Property

Borland StarTeam SDK for .NET

MatchState.TargetChildShareOfSource Property

[read/write] Boolean.TRUE if the target item is a child share of the source item. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean TargetChildShareOfSource {get; set;}

Property Value

Boolean.TRUE if the target item is a child share of the source item. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


TargetFolderHasFloatingShares Property

Borland StarTeam SDK for .NET

MatchState.TargetFolderHasFloatingShares Property

[read/write] Boolean.TRUE if the target item's parent folder has floating child shares. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean TargetFolderHasFloatingShares {get; set;}

Property Value

Boolean.TRUE if the target item's parent folder has floating child shares. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


TargetIsFloating Property

Borland StarTeam SDK for .NET

MatchState.TargetIsFloating Property

[read/write] Boolean.TRUE if the target item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean TargetIsFloating {get; set;}

Property Value

Boolean.TRUE if the target item has a floating configuration. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


TargetItemOnRootBranch Property

Borland StarTeam SDK for .NET

MatchState.TargetItemOnRootBranch Property

[read/write] Boolean.TRUE if the target item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

public virtual Boolean TargetItemOnRootBranch {get; set;}

Property Value

Boolean.TRUE if the target item is on the root branch of the share tree. Default value is null ("Don't Know" / "Don't Care").

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


TargetViewHasMultipleFloatingSharesWithSameOID Property

Borland StarTeam SDK for .NET

MatchState.TargetViewHasMultipleFloatingSharesWithSameOID Property

[read/write] true if the Target View has Multiple Floating Shares with the same Object ID

public virtual Boolean TargetViewHasMultipleFloatingSharesWithSameOID {get; set;}

Property Value

true if the Target View has Multiple Floating Shares with the same Object ID

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


MatchState Methods

The methods of the MatchState class are listed below. For a complete list of MatchState class members, see the MatchState Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.MatchState.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.MatchState.
GetType (inherited from Object) | Gets the Type of the current instance.
Matches | Determines whether or not this MatchState matches the conditions specified by the given pattern. "Don't Care" values in the pattern are ignored; other values in the pattern must match exactly.
SetItemDeletedInSource | Indicates whether or not the item in question is deleted in the source view.
SetItemDeletedInTarget | Indicates whether or not the item in question is deleted in the target view.
SetItemIsBinaryFile | Indicates whether or not the item in question is a binary file.
SetItemModifiedInSource | Indicates whether or not the item in question is modified in the source view.
SetItemModifiedInTarget | Indicates whether or not the item in question is modified in the target view.
SetItemMovedInSource | Indicates whether or not the item in question is moved in the source view.
SetItemMovedInTarget | Indicates whether or not the item in question is moved in the target view.
SetItemPresentInSource | Indicates whether or not the item in question is present in the source view.
SetItemPresentInTarget | Indicates whether or not the item in question is present in the target view.
SetItemReadOnlyInTarget | Indicates whether or not the item in question is read-only in the target view.
SetItemsHaveSameContent | Indicates whether or not the source and target items have identical content.
SetItemsInDifferentBranches | Indicates whether or not the source and target items are in different branches of the object's version tree.
SetParentFolderFailed | Indicates whether or not the target item's parent folder failed to be reconciled.
SetParentFolderIgnored | Indicates whether or not the target item's parent folder is ignored.
SetSomeChangedPropertiesExcludedFromMerge | Indicates whether or not at least one changed property has been excluded from the merge.
SetSourceChildShareOfTarget | Indicates whether or not the source item is a child share of the target item.
SetSourceIsFloating | Indicates whether or not the source item has a floating configuration.
SetSourceItemHasAHigherRevisionMerged | Indicates whether or not the source item has a higher revision already merged
SetSourceItemIsNonTipRevision | Indicates whether or not the source item is from history
SetSourceItemOnRootBranch | Indicates whether or not the source item is on the root branch of the share tree.
SetTargetChildShareOfSource | Indicates whether or not the target item is a child share of the source item.
SetTargetFolderHasFloatingShares | Indicates whether or not the target item's parent folder has floating child shares.
SetTargetIsFloating | Indicates whether or not the target item has a floating configuration.
SetTargetItemOnRootBranch | Indicates whether or not the target item is on the root branch of the share tree.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.MatchState.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


MatchState.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.MatchState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.MatchState.Equals(obj).

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


MatchState.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.MatchState.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.MatchState.GetHashCode().

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


MatchState.Matches Method

Determines whether or not this MatchState matches the conditions specified by the given pattern. "Don't Care" values in the pattern are ignored; other values in the pattern must match exactly.

public virtual bool Matches(
MatchState pattern
);

Parameters

pattern
The pattern to be matched.

Return Value

true if this MatchState matches the given pattern; false otherwise.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


MatchState.SetItemDeletedInSource Method

Indicates whether or not the item in question is deleted in the source view.

public virtual void SetItemDeletedInSource(
Boolean isDeleted
);

Parameters

isDeleted
True if the item is deleted in the source view.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemDeletedInSource


MatchState.SetItemDeletedInTarget Method

Indicates whether or not the item in question is deleted in the target view.

public virtual void SetItemDeletedInTarget(
Boolean isDeleted
);

Parameters

isDeleted
True if the item is deleted in the target view.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemDeletedInTarget


MatchState.SetItemIsBinaryFile Method

Indicates whether or not the item in question is a binary file.

public virtual void SetItemIsBinaryFile(
Boolean isBinary
);

Parameters

isBinary
True if the item is a binary file.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemIsBinaryFile


MatchState.SetItemModifiedInSource Method

Indicates whether or not the item in question is modified in the source view.

public virtual void SetItemModifiedInSource(
Boolean isModified
);

Parameters

isModified
True if the item is modified in the source view.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemModifiedInSource


MatchState.SetItemModifiedInTarget Method

Indicates whether or not the item in question is modified in the target view.

public virtual void SetItemModifiedInTarget(
Boolean isModified
);

Parameters

isModified
True if the item is modified in the target view.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemModifiedInTarget


MatchState.SetItemMovedInSource Method

Indicates whether or not the item in question is moved in the source view.

public virtual void SetItemMovedInSource(
Boolean isMoved
);

Parameters

isMoved
True if the item is moved in the source view.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemMovedInSource


MatchState.SetItemMovedInTarget Method

Indicates whether or not the item in question is moved in the target view.

public virtual void SetItemMovedInTarget(
Boolean isMoved
);

Parameters

isMoved
True if the item is moved in the target view.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemMovedInTarget


MatchState.SetItemPresentInSource Method

Indicates whether or not the item in question is present in the source view.

public virtual void SetItemPresentInSource(
Boolean isPresent
);

Parameters

isPresent
True if the item is present in the source view.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemPresentInSource


MatchState.SetItemPresentInTarget Method

Indicates whether or not the item in question is present in the target view.

public virtual void SetItemPresentInTarget(
Boolean isPresent
);

Parameters

isPresent
True if the item is present in the target view.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemPresentInTarget


MatchState.SetItemReadOnlyInTarget Method

Indicates whether or not the item in question is read-only in the target view.

public virtual void SetItemReadOnlyInTarget(
Boolean isPresent
);

Parameters

isPresent
True if the item is read-only in the target view.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemPresentInTarget


MatchState.SetItemsHaveSameContent Method

Indicates whether or not the source and target items have identical content.

public virtual void SetItemsHaveSameContent(
Boolean isSame
);

Parameters

isSame
True if the source and target items have identical content.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemsHaveSameContent


MatchState.SetItemsInDifferentBranches Method

Indicates whether or not the source and target items are in different branches of the object's version tree.

public virtual void SetItemsInDifferentBranches(
Boolean isDifferent
);

Parameters

isDifferent
True if the items are in different branches.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setItemsInDifferentBranches


MatchState.SetParentFolderFailed Method

Indicates whether or not the target item's parent folder failed to be reconciled.

public virtual void SetParentFolderFailed(
Boolean isFailed
);

Parameters

isFailed
True if the target item's parent folder failed to be reconciled.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setParentFolderFailed


MatchState.SetParentFolderIgnored Method

Indicates whether or not the target item's parent folder is ignored.

public virtual void SetParentFolderIgnored(
Boolean isIgnored
);

Parameters

isIgnored
True if the target item's parent folder is ignored.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setParentFolderIgnored


MatchState.SetSomeChangedPropertiesExcludedFromMerge Method

Indicates whether or not at least one changed property has been excluded from the merge.

public virtual void SetSomeChangedPropertiesExcludedFromMerge(
Boolean isChangeExcluded
);

Parameters

isChangeExcluded
True if at least one changed property has been excluded from the merge.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setSomeChangedPropertiesExcludedFromMerge


MatchState.SetSourceChildShareOfTarget Method

Indicates whether or not the source item is a child share of the target item.

public virtual void SetSourceChildShareOfTarget(
Boolean isChildShare
);

Parameters

isChildShare
True if the source item is a child share of the target item.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setSourceChildShareOfTarget


MatchState.SetSourceIsFloating Method

Indicates whether or not the source item has a floating configuration.

public virtual void SetSourceIsFloating(
Boolean isFloating
);

Parameters

isFloating
True if the source item has a floating configuration.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setSourceIsFloating


MatchState.SetSourceItemHasAHigherRevisionMerged Method

Indicates whether or not the source item has a higher revision already merged

public virtual void SetSourceItemHasAHigherRevisionMerged(
Boolean hasHigherRevision
);

Parameters

hasHigherRevision
true if a higher revision has been merged

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setSourceItemHasAHigherRevisionMerged


MatchState.SetSourceItemIsNonTipRevision Method

Indicates whether or not the source item is from history

public virtual void SetSourceItemIsNonTipRevision(
Boolean isNonTip
);

Parameters

isNonTip
true if the source item is from history

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setSourceItemIsNonTipRevision


MatchState.SetSourceItemOnRootBranch Method

Indicates whether or not the source item is on the root branch of the share tree.

public virtual void SetSourceItemOnRootBranch(
Boolean isOnRootBranch
);

Parameters

isOnRootBranch
True if the source item is on the root branch of the share tree.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setSourceItemOnRootBranch


MatchState.SetTargetChildShareOfSource Method

Indicates whether or not the target item is a child share of the source item.

public virtual void SetTargetChildShareOfSource(
Boolean isChildShare
);

Parameters

isChildShare
True if the target item is a child share of the source item.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setTargetChildShareOfSource


MatchState.SetTargetFolderHasFloatingShares Method

Indicates whether or not the target item's parent folder has floating child shares.

public virtual void SetTargetFolderHasFloatingShares(
Boolean hasFloatingShares
);

Parameters

hasFloatingShares
True if the target item's parent folder has floating child shares.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setTargetFolderHasFloatingShares


MatchState.SetTargetIsFloating Method

Indicates whether or not the target item has a floating configuration.

public virtual void SetTargetIsFloating(
Boolean isFloating
);

Parameters

isFloating
True if the target item has a floating configuration.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setTargetIsFloating


MatchState.SetTargetItemOnRootBranch Method

Indicates whether or not the target item is on the root branch of the share tree.

public virtual void SetTargetItemOnRootBranch(
Boolean isOnRootBranch
);

Parameters

isOnRootBranch
True if the target item is on the root branch of the share tree.

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace | setTargetItemOnRootBranch


MatchState.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.MatchState.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.MatchState.ToString()

See Also

MatchState Class | StarTeam.ViewCompareMerge Namespace


MergeAction Class

An action that may be used to resolve a merge condition.

For a list of all members of this type, see MergeAction Members.

System.Object
MergeAction

public class MergeAction

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

MergeAction Members | StarTeam.ViewCompareMerge Namespace


MergeAction Members

MergeAction overview

Public Static Properties

ADD |
ADDED |
AllActions | [read] MergeAction[] an array of all MergeAction instances
AllPrimitiveActions | [read] MergeAction[] an array of all primitive MergeAction instances
CHECKIN |
CHECKIN_AND_OVERWRITE |
CHECKOUT |
CHECKOUT_AND_OVERWRITE |
DELETE |
DELETE_AND_REVERSE_SHARE |
DELETE_AND_SHARE |
IGNORE |
MARK_RESOLVED |
MERGE |
MODIFIED |
MOVE |
MOVE_AND_MERGE |
MOVE_AND_OVERWRITE |
MOVE_AND_RE_PIN |
MOVE_BACK |
NEEDS_REVIEW |
OVERWRITE |
RE_PIN |
REMOVED |
RENAMED |
RENAMED_AND_MODIFIED |
REVERSE_SHARE |
SHARE |
UNDEFINED |

Public Static Methods

FromID Gets the MergeAction that corresponds to the given action ID.

Public Instance Properties

ID | [read] The unique ID associated with this action.
Name | [read] String a String representation of this merge action

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.MergeAction.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.MergeAction.
GetType (inherited from Object) | Gets the Type of the current instance.
Includes | Determines whether or not this action includes the primitives specified in the given action, in any order.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.MergeAction.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MergeAction Properties

The properties of the MergeAction class are listed below. For a complete list of MergeAction class members, see the MergeAction Members topic.

Public Static Properties

ADD |
ADDED |
AllActions | [read] MergeAction[] an array of all MergeAction instances
AllPrimitiveActions | [read] MergeAction[] an array of all primitive MergeAction instances
CHECKIN |
CHECKIN_AND_OVERWRITE |
CHECKOUT |
CHECKOUT_AND_OVERWRITE |
DELETE |
DELETE_AND_REVERSE_SHARE |
DELETE_AND_SHARE |
IGNORE |
MARK_RESOLVED |
MERGE |
MODIFIED |
MOVE |
MOVE_AND_MERGE |
MOVE_AND_OVERWRITE |
MOVE_AND_RE_PIN |
MOVE_BACK |
NEEDS_REVIEW |
OVERWRITE |
RE_PIN |
REMOVED |
RENAMED |
RENAMED_AND_MODIFIED |
REVERSE_SHARE |
SHARE |
UNDEFINED |

Public Instance Properties

ID | [read] The unique ID associated with this action.
Name | [read] String a String representation of this merge action

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


ADD Property

Borland StarTeam SDK for .NET

MergeAction.ADD Property

public static MergeAction ADD {get;}

Property Value

Add.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


ADDED Property

Borland StarTeam SDK for .NET

MergeAction.ADDED Property

public static MergeAction ADDED {get;}

Property Value

Added.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


AllActions Property

Borland StarTeam SDK for .NET

MergeAction.AllActions Property

[read] MergeAction[] an array of all MergeAction instances

public static MergeAction[] AllActions {get;}

Property Value

MergeAction[] an array of all MergeAction instances

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


AllPrimitiveActions Property

Borland StarTeam SDK for .NET

MergeAction.AllPrimitiveActions Property

[read] MergeAction[] an array of all primitive MergeAction instances

public static MergeAction[] AllPrimitiveActions {get;}

Property Value

MergeAction[] an array of all primitive MergeAction instances

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


CHECKIN Property

Borland StarTeam SDK for .NET

MergeAction.CHECKIN Property

public static MergeAction CHECKIN {get;}

Property Value

Checkin.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


CHECKIN_AND_OVERWRITE Property

Borland StarTeam SDK for .NET

MergeAction.CHECKIN_AND_OVERWRITE Property

public static MergeAction CHECKIN_AND_OVERWRITE {get;}

Property Value

Equivalent to a Force CHECKIN.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


CHECKOUT Property

Borland StarTeam SDK for .NET

MergeAction.CHECKOUT Property

public static MergeAction CHECKOUT {get;}

Property Value

Checkout.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


CHECKOUT_AND_OVERWRITE Property

Borland StarTeam SDK for .NET

MergeAction.CHECKOUT_AND_OVERWRITE Property

public static MergeAction CHECKOUT_AND_OVERWRITE {get;}

Property Value

Equivalent to a Force CHECKOUT.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


DELETE Property

Borland StarTeam SDK for .NET

MergeAction.DELETE Property

public static MergeAction DELETE {get;}

Property Value

Delete the target item.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


DELETE_AND_REVERSE_SHARE Property

Borland StarTeam SDK for .NET

MergeAction.DELETE_AND_REVERSE_SHARE Property

public static MergeAction DELETE_AND_REVERSE_SHARE {get;}

Property Value

Equivalent to a DELETE followed by a REVERSE_SHARE.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


DELETE_AND_SHARE Property

Borland StarTeam SDK for .NET

MergeAction.DELETE_AND_SHARE Property

public static MergeAction DELETE_AND_SHARE {get;}

Property Value

Equivalent to a DELETE followed by a SHARE.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


ID Property

Borland StarTeam SDK for .NET

MergeAction.ID Property

[read] The unique ID associated with this action.

public virtual Int32 ID {get;}

Property Value

The unique ID associated with this action.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


IGNORE Property

Borland StarTeam SDK for .NET

MergeAction.IGNORE Property

public static MergeAction IGNORE {get;}

Property Value

No action.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MARK_RESOLVED Property

Borland StarTeam SDK for .NET

MergeAction.MARK_RESOLVED Property

public static MergeAction MARK_RESOLVED {get;}

Property Value

Just mark the difference as resolved by creating a merge point.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MERGE Property

Borland StarTeam SDK for .NET

MergeAction.MERGE Property

public static MergeAction MERGE {get;}

Property Value

Merge the source and target items.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MODIFIED Property

Borland StarTeam SDK for .NET

MergeAction.MODIFIED Property

public static MergeAction MODIFIED {get;}

Property Value

Modified.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MOVE Property

Borland StarTeam SDK for .NET

MergeAction.MOVE Property

public static MergeAction MOVE {get;}

Property Value

Move the target item to another folder.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MOVE_AND_MERGE Property

Borland StarTeam SDK for .NET

MergeAction.MOVE_AND_MERGE Property

public static MergeAction MOVE_AND_MERGE {get;}

Property Value

Equivalent to a MOVE followed by a MERGE.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MOVE_AND_OVERWRITE Property

Borland StarTeam SDK for .NET

MergeAction.MOVE_AND_OVERWRITE Property

public static MergeAction MOVE_AND_OVERWRITE {get;}

Property Value

Equivalent to a MOVE followed by an OVERWRITE.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MOVE_AND_RE_PIN Property

Borland StarTeam SDK for .NET

MergeAction.MOVE_AND_RE_PIN Property

public static MergeAction MOVE_AND_RE_PIN {get;}

Property Value

Equivalent to a MOVE followed by a RE_PIN.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MOVE_BACK Property

Borland StarTeam SDK for .NET

MergeAction.MOVE_BACK Property

public static MergeAction MOVE_BACK {get;}

Property Value

Move Back.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


Name Property

Borland StarTeam SDK for .NET

MergeAction.Name Property

[read] String a String representation of this merge action

public virtual String Name {get;}

Property Value

String a String representation of this merge action

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


NEEDS_REVIEW Property

Borland StarTeam SDK for .NET

MergeAction.NEEDS_REVIEW Property

public static MergeAction NEEDS_REVIEW {get;}

Property Value

Needs review -- don't allow commit while this action is selected.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


OVERWRITE Property

Borland StarTeam SDK for .NET

MergeAction.OVERWRITE Property

public static MergeAction OVERWRITE {get;}

Property Value

Overwrite the target with the content of the source.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


RE_PIN Property

Borland StarTeam SDK for .NET

MergeAction.RE_PIN Property

public static MergeAction RE_PIN {get;}

Property Value

Change the revision to which the target item is pinned to match the source item.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


REMOVED Property

Borland StarTeam SDK for .NET

MergeAction.REMOVED Property

public static MergeAction REMOVED {get;}

Property Value

Removed.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


RENAMED Property

Borland StarTeam SDK for .NET

MergeAction.RENAMED Property

public static MergeAction RENAMED {get;}

Property Value

Modified.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


RENAMED_AND_MODIFIED Property

Borland StarTeam SDK for .NET

MergeAction.RENAMED_AND_MODIFIED Property

public static MergeAction RENAMED_AND_MODIFIED {get;}

Property Value

Renamed and Modified.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


REVERSE_SHARE Property

Borland StarTeam SDK for .NET

MergeAction.REVERSE_SHARE Property

public static MergeAction REVERSE_SHARE {get;}

Property Value

Move the source item to the target and share it back to the source.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


SHARE Property

Borland StarTeam SDK for .NET

MergeAction.SHARE Property

public static MergeAction SHARE {get;}

Property Value

Share the source item to the target.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


UNDEFINED Property

Borland StarTeam SDK for .NET

MergeAction.UNDEFINED Property

public static MergeAction UNDEFINED {get;}

Property Value

Removed.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MergeAction Methods

The methods of the MergeAction class are listed below. For a complete list of MergeAction class members, see the MergeAction Members topic.

Public Static Methods

FromID Gets the MergeAction that corresponds to the given action ID.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.MergeAction.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.MergeAction.
GetType (inherited from Object) | Gets the Type of the current instance.
Includes | Determines whether or not this action includes the primitives specified in the given action, in any order.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.MergeAction.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MergeAction.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.MergeAction.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.MergeAction.Equals(obj).

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MergeAction.FromID Method

Gets the MergeAction that corresponds to the given action ID.

public static MergeAction FromID(
Int32 actionID
);

Parameters

actionID
The unique ID of some merge action.

Return Value

The merge action.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace | getID


MergeAction.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.MergeAction.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.MergeAction.GetHashCode().

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MergeAction.Includes Method

Determines whether or not this action includes the primitives specified in the given action, in any order.

public virtual bool Includes(
MergeAction action
);

Parameters

action
The MergeAction to be found.

Return Value

True if this action includes all the primitives specified in the given action, in any order; false otherwise.

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MergeAction.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.MergeAction.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.MergeAction.ToString()

See Also

MergeAction Class | StarTeam.ViewCompareMerge Namespace


MergeActionProperty Class

Client-calculated property whose value is the current action of the ItemDifference associated with this item. For an item that has no associated ItemDifference, or that is not owned by the MergePreview of a View Compare/Merge session, the value of the MergeActionProperty is always VALUE_NOT_SET (or the null EnumeratedValue).

For a list of all members of this type, see MergeActionProperty Members.

System.Object
Property
EnumeratedProperty
ViewCompareMergeProperty
MergeActionProperty
DefaultActionProperty

public class MergeActionProperty : ViewCompareMergeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

MergeActionProperty Members | StarTeam.ViewCompareMerge Namespace


MergeActionProperty Members

MergeActionProperty overview

Public Static Properties

ID
NAME

Public Static Methods

ToMergeAction Gets the MergeAction corresponding to a given EnumeratedValue.

Public Instance Constructors

MergeActionProperty Constructor Creates a new MergeActionProperty.

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromMergeAction | Gets the EnumeratedValue corresponding to a given MergeAction.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

MergeActionProperty Class | StarTeam.ViewCompareMerge Namespace


MergeActionProperty Constructor

Creates a new MergeActionProperty.

public MergeActionProperty(
Type type
);

Parameters

type
The associated Type.

See Also

MergeActionProperty Class | StarTeam.ViewCompareMerge Namespace


MergeActionProperty Properties

The properties of the MergeActionProperty class are listed below. For a complete list of MergeActionProperty class members, see the MergeActionProperty Members topic.

Public Static Properties

ID
NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

MergeActionProperty Class | StarTeam.ViewCompareMerge Namespace


ID Property

Borland StarTeam SDK for .NET

MergeActionProperty.ID Property

new public static Int32 ID {get;}

See Also

MergeActionProperty Class | StarTeam.ViewCompareMerge Namespace


NAME Property

Borland StarTeam SDK for .NET

MergeActionProperty.NAME Property

public static String NAME {get;}

See Also

MergeActionProperty Class | StarTeam.ViewCompareMerge Namespace


MergeActionProperty Methods

The methods of the MergeActionProperty class are listed below. For a complete list of MergeActionProperty class members, see the MergeActionProperty Members topic.

Public Static Methods

ToMergeAction Gets the MergeAction corresponding to a given EnumeratedValue.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
FromMergeAction | Gets the EnumeratedValue corresponding to a given MergeAction.
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

MergeActionProperty Class | StarTeam.ViewCompareMerge Namespace


MergeActionProperty.FromMergeAction Method

Gets the EnumeratedValue corresponding to a given MergeAction.

public virtual EnumeratedValue FromMergeAction(
MergeAction action
);

Parameters

action
A MergeAction.

Return Value

The corresponding EnumeratedValue.

See Also

MergeActionProperty Class | StarTeam.ViewCompareMerge Namespace | MergeAction


MergeActionProperty.ToMergeAction Method

Gets the MergeAction corresponding to a given EnumeratedValue.

public static MergeAction ToMergeAction(
EnumeratedValue value
);

Parameters

value
An EnumeratedValue.

Return Value

The corresponding MergeAction.

See Also

MergeActionProperty Class | StarTeam.ViewCompareMerge Namespace | DifferenceType


MergePreview Class

Description: A MergePreview is a read-only reference View with additional properties, and some local, context specific overrides

For a list of all members of this type, see MergePreview Members.

System.Object
TypedResource
LiveObject
View
MergePreview

public class MergePreview : View

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

MergePreview Members | StarTeam.ViewCompareMerge Namespace


MergePreview Members

MergePreview overview

Public Instance Properties

ActiveLabels (inherited from View) | [read] The active (non-deleted) labels for this view.
AlternatePath (inherited from View) | [read/write] the alternate working file path to be used for this view.
BaseConfiguration (inherited from View) | [read] the ViewConfiguration from which this View was derived.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackages (inherited from View) | [read] ChangePackageCollection
CloneTime (inherited from View) | [read/write] clone time of this View
Configuration (inherited from View) | [read] this view's configuration.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DefaultPath (inherited from View) | [read/write] the default working file path to be used for this view.
DerivedViews (inherited from View) | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description (inherited from View) | [read/write] the description of this view.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EndDate (inherited from View) | [read/write] end date of this View
ExcludedGroups (inherited from View) | [read] The groups who are excluded from VCM Commits.
ExcludedUsers (inherited from View) | [read] The users who are excluded from VCM Commits.
FileStatusManager (inherited from View) | [read] The FileBasedStatusManager for this View.
FullName (inherited from View) | [read] the full hierarchical name of this view.
HaveAccessRights | [read] true.
HighestChangePackageID (inherited from View) | [read] the value of the most recent change package
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsAccessible (inherited from View) | [read] true if the logged on user has access to this view.
IsBranch (inherited from View) | [read] true if this view is a Branch view.
IsBranchAll (inherited from View) | [read] true if this view's original branching default was set "All".
IsBranchNone (inherited from View) | [read] true if this view's original branching default was set "None".
IsBranchOnShare (inherited from View) | [read/write] true if this view is set to branch shared items.
IsDeleted (inherited from View) | [read] True if the view has been deleted from the server; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsLightWeightWorkView (inherited from View) | [read] true if this view is lightweight work view.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsNonDerived (inherited from View) | [read] true if this view is Non-Derived view.
IsReadOnly (inherited from View) | [read] true if this view is ReadOnly, otherwise false.
IsReference (inherited from View) | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired (inherited from View) | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired (inherited from View) | [read] true if folder information may be out of date.
IsRefreshLabelsRequired (inherited from View) | [read] true if label information may be out of date.
IsRefreshRequired (inherited from View) | [read] true if view properties may be out of date.
IsRoot (inherited from View) | [read] true if this view is a Root view.
IsVCMCodeReviewRequired (inherited from View) | [read/write] whether VCM Code reviews are required
IsVCMCommitEnforced (inherited from View) | [read/write] whether VCM Commits are enforced for this View
Labels (inherited from View) | [read] The labels (both active and deleted) that exist in this view.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name (inherited from View) | [read/write] the name of this view.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from View) | [read] This object's parent container.
ParentView (inherited from View) | [read] the parent of this view, or null if there is no parent.
Path (inherited from View) | [read] the working file path being used for this view.
PresentationID (inherited from View) | [read] the unique integer identifier for this view.
Project (inherited from View) | [read] the project to which this view belongs.
PromotionModel (inherited from View) | [read] the promotion model associated with this view.
Properties (inherited from View) | [read]
RecycleBin (inherited from View) | [read] The recycle bin associated with this view.
Rights (inherited from View) | [read/write] the access control list for this view or NULL.
RootFolder (inherited from View) | [read] The root folder of this view.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Session | [read] Session the Session that this view belongs to
StartDate (inherited from View) | [read/write] start date of this View
StatusMethodOverride (inherited from View) | [read/write]
TargetView | [read] the underlying target view represented by this merge preview
Traces (inherited from View) | [read] TraceCollection
TypeValue (inherited from View) | [read/write] type (Unknown, Main, Sandbox, Release) of this View
ViewID (inherited from View) | [read] the unique integer identifier for this view.
WorkspaceModifiedTime (inherited from View) | [read] workspace modified time of this View

Public Instance Methods

AddExcludedGroup (inherited from View) | Adds the specified group object as an excluded group from VCM Commits.
AddExcludedUser (inherited from View) | Adds the specified user object as an excluded user from VCM Commits.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel (inherited from View) | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed. A cloned revision label is supported across projects. This provides a mechanism to attach the correct historical revisions to a cloned label in a view that is the target of cross project or cross view folder tree moves.
CloneViewLabel (inherited from View) | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed. View labels may only be cloned from other labels in the same view
Close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems (inherited from View) | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateLightWeightWorkView (inherited from View) | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. Supported on servers beginning with release 16.4
CreateLightWeightWorkViewWithPulsePullRequests (inherited from View) | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. This work view also supports Pull Requests for code reviews in Pulse Supported on servers beginning with release 17.1
CreateRevisionLabel (inherited from View) | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel (inherited from View) | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed. Use a DateTime created with the special value 0.0 to create the label as of the current server time.
Discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FetchAllLabels (inherited from View) | Overloaded. Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FindDerivedView (inherited from View) | Return an immediate derived view with the specified name or NULL if none exist
FindFolder (inherited from View) | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem (inherited from View) | Overloaded.
FindLabel (inherited from View) | Overloaded. find and return a label given its name
FindViewMember (inherited from View) |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisembodiedItem (inherited from View) |
GetDisembodiedViewMember (inherited from View) |
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetNewNotificationItems (inherited from View) |
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetRights (inherited from View) | Returns the Access Control List for items of the specified type for this view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
GetViewMembers (inherited from View) |
GetWorkflow (inherited from View) |
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasNewNotificationItems (inherited from View) |
HasPermission | Overloaded. Always returns false
HasPermissions (inherited from View) | Overloaded. Returns true if desired permissions are granted for this view
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from View) | Compares the properties of two Views.
NewFolderEventSource (inherited from View) |
NewFolderTreeEventSource (inherited from View) |
NewFolderUpdateEventSource (inherited from View) |
NewItemEventSource (inherited from View) | Overloaded.
NewItemIDEventSource (inherited from View) | Overloaded.
NewItemListEventSource (inherited from View) | Overloaded.
NewItemUpdateEventSource (inherited from View) |
NewLabelEventSource (inherited from View) |
NewNotificationEventSource (inherited from View) | Overloaded.
NewViewEventSource (inherited from View) |
NewViewMemberEventSource (inherited from View) | Overloaded.
NewViewMemberUpdateEventSource (inherited from View) |
Populate (inherited from View) | Populates view properties, if they have not already been populated.
Refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
Remove (inherited from View) | Removes the view from the server.
RemoveExcludedGroup (inherited from View) | Removes the specified group object as an excluded group from VCM Commits.
RemoveExcludedUser (inherited from View) | Removes the specified user object as an excluded user from VCM Commits.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveWorkflow (inherited from View) | remove all workflow definitions for this view
ResolveLinkEndpoint (inherited from View) |
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights (inherited from View) | Modifies the Access Control List for items of the specified type for this view. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
SupportsPullRequests (inherited from View) | Return true if this view supports pull requests.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update (inherited from View) | Persists this view's properties to its Server.

See Also

MergePreview Class | StarTeam.ViewCompareMerge Namespace


MergePreview Properties

The properties of the MergePreview class are listed below. For a complete list of MergePreview class members, see the MergePreview Members topic.

Public Instance Properties

ActiveLabels (inherited from View) | [read] The active (non-deleted) labels for this view.
AlternatePath (inherited from View) | [read/write] the alternate working file path to be used for this view.
BaseConfiguration (inherited from View) | [read] the ViewConfiguration from which this View was derived.
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
ChangePackages (inherited from View) | [read] ChangePackageCollection
CloneTime (inherited from View) | [read/write] clone time of this View
Configuration (inherited from View) | [read] this view's configuration.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DefaultPath (inherited from View) | [read/write] the default working file path to be used for this view.
DerivedViews (inherited from View) | [read] The set of views derived from this one. Returns an empty array if there are no derived views.
Description (inherited from View) | [read/write] the description of this view.
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
EndDate (inherited from View) | [read/write] end date of this View
ExcludedGroups (inherited from View) | [read] The groups who are excluded from VCM Commits.
ExcludedUsers (inherited from View) | [read] The users who are excluded from VCM Commits.
FileStatusManager (inherited from View) | [read] The FileBasedStatusManager for this View.
FullName (inherited from View) | [read] the full hierarchical name of this view.
HaveAccessRights | [read] true.
HighestChangePackageID (inherited from View) | [read] the value of the most recent change package
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsAccessible (inherited from View) | [read] true if the logged on user has access to this view.
IsBranch (inherited from View) | [read] true if this view is a Branch view.
IsBranchAll (inherited from View) | [read] true if this view's original branching default was set "All".
IsBranchNone (inherited from View) | [read] true if this view's original branching default was set "None".
IsBranchOnShare (inherited from View) | [read/write] true if this view is set to branch shared items.
IsDeleted (inherited from View) | [read] True if the view has been deleted from the server; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsLightWeightWorkView (inherited from View) | [read] true if this view is lightweight work view.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsNonDerived (inherited from View) | [read] true if this view is Non-Derived view.
IsReadOnly (inherited from View) | [read] true if this view is ReadOnly, otherwise false.
IsReference (inherited from View) | [read] true if this is a reference view, otherwise false.
IsRefreshActiveLabelsRequired (inherited from View) | [read] true if the active label information may be out of date.
IsRefreshFoldersRequired (inherited from View) | [read] true if folder information may be out of date.
IsRefreshLabelsRequired (inherited from View) | [read] true if label information may be out of date.
IsRefreshRequired (inherited from View) | [read] true if view properties may be out of date.
IsRoot (inherited from View) | [read] true if this view is a Root view.
IsVCMCodeReviewRequired (inherited from View) | [read/write] whether VCM Code reviews are required
IsVCMCommitEnforced (inherited from View) | [read/write] whether VCM Commits are enforced for this View
Labels (inherited from View) | [read] The labels (both active and deleted) that exist in this view.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name (inherited from View) | [read/write] the name of this view.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from View) | [read] This object's parent container.
ParentView (inherited from View) | [read] the parent of this view, or null if there is no parent.
Path (inherited from View) | [read] the working file path being used for this view.
PresentationID (inherited from View) | [read] the unique integer identifier for this view.
Project (inherited from View) | [read] the project to which this view belongs.
PromotionModel (inherited from View) | [read] the promotion model associated with this view.
Properties (inherited from View) | [read]
RecycleBin (inherited from View) | [read] The recycle bin associated with this view.
Rights (inherited from View) | [read/write] the access control list for this view or NULL.
RootFolder (inherited from View) | [read] The root folder of this view.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Session | [read] Session the Session that this view belongs to
StartDate (inherited from View) | [read/write] start date of this View
StatusMethodOverride (inherited from View) | [read/write]
TargetView | [read] the underlying target view represented by this merge preview
Traces (inherited from View) | [read] TraceCollection
TypeValue (inherited from View) | [read/write] type (Unknown, Main, Sandbox, Release) of this View
ViewID (inherited from View) | [read] the unique integer identifier for this view.
WorkspaceModifiedTime (inherited from View) | [read] workspace modified time of this View

See Also

MergePreview Class | StarTeam.ViewCompareMerge Namespace


HaveAccessRights Property

Borland StarTeam SDK for .NET

MergePreview.HaveAccessRights Property

[read] true.

public virtual Boolean HaveAccessRights {get;}

Property Value

true.

See Also

MergePreview Class | StarTeam.ViewCompareMerge Namespace


Session Property

Borland StarTeam SDK for .NET

MergePreview.Session Property

[read] Session the Session that this view belongs to

public virtual Session Session {get;}

Property Value

Session the Session that this view belongs to

See Also

MergePreview Class | StarTeam.ViewCompareMerge Namespace


TargetView Property

Borland StarTeam SDK for .NET

MergePreview.TargetView Property

[read] the underlying target view represented by this merge preview

public virtual View TargetView {get;}

Property Value

the underlying target view represented by this merge preview

See Also

MergePreview Class | StarTeam.ViewCompareMerge Namespace


MergePreview Methods

The methods of the MergePreview class are listed below. For a complete list of MergePreview class members, see the MergePreview Members topic.

Public Instance Methods

AddExcludedGroup (inherited from View) | Adds the specified group object as an excluded group from VCM Commits.
AddExcludedUser (inherited from View) | Adds the specified user object as an excluded user from VCM Commits.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
CloneRevisionLabel (inherited from View) | Clones the specified "Revision" label. This method creates the label on the server so a call to update() is not needed. A cloned revision label is supported across projects. This provides a mechanism to attach the correct historical revisions to a cloned label in a view that is the target of cross project or cross view folder tree moves.
CloneViewLabel (inherited from View) | Clones the specified "View" label. This method creates the label on the server so a call to update() is not needed. View labels may only be cloned from other labels in the same view
Close (inherited from View) | Frees all cached resources associated with this view, and closes the associated view session. Many view-related resources, such as the folder tree, item lists and so on, can be discarded separately. Others, however, are freed only by an explicit call to close(). After a view is closed, the view object is still useful. The view session is automatically re-opened when needed, and data is re-fetched from the server on demand.
Copy (inherited from View) | Creates a copy of this View object, with view properties fully populated. Useful to applications that want to save a snapshot of the View in a given state, for example, before calling refresh().
CreateCheckinManager (inherited from View) | Overloaded. Constructs a CheckinManager with default options for this view.
CreateCheckoutManager (inherited from View) | Overloaded. Constructs a CheckoutManager with default options for this view.
CreateChildViewShareAllItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of all item types supported on this server.
CreateChildViewShareDefaultItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items of the default set of item types defined for this view's Project.
CreateChildViewShareNoItems (inherited from View) | Create a new variant view as a child of this view, that initially shares no items. Supported on servers beginning with release 10.3.
CreateChildViewShareTheseItems (inherited from View) | Create a new variant view as a child of this view, that initially shares items based on the set of item Types provided. Supported on servers beginning with release 10.3.
CreateLightWeightWorkView (inherited from View) | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. Supported on servers beginning with release 16.4
CreateLightWeightWorkViewWithPulsePullRequests (inherited from View) | Create a new lightweight work view as a child of this view. The work view does not share any items from the parent during creation, but rather shares it on demand when there are file and folder operations. This work view also supports Pull Requests for code reviews in Pulse Supported on servers beginning with release 17.1
CreateRevisionLabel (inherited from View) | Create a new "Revision" label with the specified properties. This method creates the label on the server so a call to update() is not needed.
CreateViewLabel (inherited from View) | Create a new "View" label with the specified properties. This method creates the label on the server so a call to update() is not needed. Use a DateTime created with the special value 0.0 to create the label as of the current server time.
Discard (inherited from View) | Discards all of the cached properties for this view. They will be re-fetched from the server on demand (even when MPX is enabled). If the properties of a view are changed, and discard() is called without first calling update(), the changes will be lost.
DiscardActiveLabels (inherited from View) | Discard any cached active (non-deleted) labels. Subsequent calls to getActiveLabels() will fetch the label information from the StarTeam Server (even when MPX is enabled).
DiscardFolders (inherited from View) | Discards all cached Folder information. It will be re-fetched from the server on demand (even when MPX is enabled).
DiscardLabels (inherited from View) | Discards cached Label information. The next call to getLabels() will re-fetch the label information from the StarTeam Server (even when MPX is enabled).
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FetchAllLabels (inherited from View) | Overloaded. Returns all the active (non-deleted) labels for this view. The labels are not cached in the View object. Each call to fetchAllLabels() returns an up-to-date list consisting of newly allocated Label objects. If MPX is enabled, fetchAllLabels() is optimized to avoid unnecessary server commands.
FindDerivedView (inherited from View) | Return an immediate derived view with the specified name or NULL if none exist
FindFolder (inherited from View) | Returns a Folder in the View, given its Item ID, or NULL if none found.
FindItem (inherited from View) | Overloaded.
FindLabel (inherited from View) | Overloaded. find and return a label given its name
FindViewMember (inherited from View) |
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisembodiedItem (inherited from View) |
GetDisembodiedViewMember (inherited from View) |
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetNewNotificationItems (inherited from View) |
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetRights (inherited from View) | Returns the Access Control List for items of the specified type for this view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
GetViewMembers (inherited from View) |
GetWorkflow (inherited from View) |
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasNewNotificationItems (inherited from View) |
HasPermission | Overloaded. Always returns false
HasPermissions (inherited from View) | Overloaded. Returns true if desired permissions are granted for this view
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsEqualTo (inherited from View) | Compares the properties of two Views.
NewFolderEventSource (inherited from View) |
NewFolderTreeEventSource (inherited from View) |
NewFolderUpdateEventSource (inherited from View) |
NewItemEventSource (inherited from View) | Overloaded.
NewItemIDEventSource (inherited from View) | Overloaded.
NewItemListEventSource (inherited from View) | Overloaded.
NewItemUpdateEventSource (inherited from View) |
NewLabelEventSource (inherited from View) |
NewNotificationEventSource (inherited from View) | Overloaded.
NewViewEventSource (inherited from View) |
NewViewMemberEventSource (inherited from View) | Overloaded.
NewViewMemberUpdateEventSource (inherited from View) |
Populate (inherited from View) | Populates view properties, if they have not already been populated.
Refresh (inherited from View) | Updates cached properties to reflect recent changes made on the server. If MPX is enabled, refresh() is optimized to avoid unnecessary server commands.
RefreshActiveLabels (inherited from View) | Refreshes cached Label information for active (non-deleted) labels to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshActiveLabels() is optimized to avoid unnecessary server commands.
RefreshFolders (inherited from View) | Updates cached Folder information to reflect recent changes to the server. Existing Folder objects are modified in place whenever possible. If MPX is enabled, refreshFolders() is optimized to avoid unnecessary server commands. In all cases, refreshFolders() has the side effect of clearing any Item lists that have already been populated. Thus, the next attempt to retrieve the Items will return an up-to-date list consisting of newly allocated Item objects. If MPX is enabled, the process of re-populating the Item lists is optimized to avoid unnecessary server commands.
RefreshLabels (inherited from View) | Refreshes cached Label information to reflect recent changes to the repository. Modifies existing Label objects in place whenever possible. If MPX is enabled, refreshLabels() is optimized to avoid unnecessary server commands.
RefreshPromotionModel (inherited from View) | Refreshes the local cached information about this view's promotion model.
Remove (inherited from View) | Removes the view from the server.
RemoveExcludedGroup (inherited from View) | Removes the specified group object as an excluded group from VCM Commits.
RemoveExcludedUser (inherited from View) | Removes the specified user object as an excluded user from VCM Commits.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveWorkflow (inherited from View) | remove all workflow definitions for this view
ResolveLinkEndpoint (inherited from View) |
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights (inherited from View) | Modifies the Access Control List for items of the specified type for this view. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
SupportsPullRequests (inherited from View) | Return true if this view supports pull requests.
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Update (inherited from View) | Persists this view's properties to its Server.

See Also

MergePreview Class | StarTeam.ViewCompareMerge Namespace


HasPermission Method

Borland StarTeam SDK for .NET

MergePreview.HasPermission Method

Always returns false

Overload List

Always returns false

public virtual bool HasPermission(PermissionCollection);

Always returns false

public virtual bool HasPermission(PermissionCollection,Type);

See Also

MergePreview Class | StarTeam.ViewCompareMerge Namespace | Permission


MergePreview.HasPermission Method (PermissionCollection)

Always returns false

public virtual bool HasPermission(
PermissionCollection permissions
);

Parameters

permissions
the desired permissions

Return Value

false.

See Also

MergePreview Class | StarTeam.ViewCompareMerge Namespace | MergePreview.HasPermission Overload List | Permission


MergePreview.HasPermission Method (PermissionCollection, Type)

Always returns false

public virtual bool HasPermission(
PermissionCollection permissions,
Type type
);

Parameters

permissions
the desired permissions
type
the type for access to be tested on

Return Value

false.

See Also

MergePreview Class | StarTeam.ViewCompareMerge Namespace | MergePreview.HasPermission Overload List | Permission


MergeStatusProperty Class

Client-calculated property whose value describes the status of an item relative to the current View Compare/Merge session. For an item that is not owned by the MergePreview of a View Compare/Merge session, the value of the MergeStatusProperty is always VALUE_NOT_SET (or the null EnumeratedValue).

For a list of all members of this type, see MergeStatusProperty Members.

System.Object
Property
EnumeratedProperty
ViewCompareMergeProperty
MergeStatusProperty

public class MergeStatusProperty : ViewCompareMergeProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

MergeStatusProperty Members | StarTeam.ViewCompareMerge Namespace


MergeStatusProperty Members

MergeStatusProperty overview

Public Static Properties

ID
ID_CHANGED
ID_NOT_COMPARED
ID_RESOLVED
ID_UNCHANGED
ID_UNRESOLVED
NAME

Public Instance Constructors

MergeStatusProperty Constructor Creates a new MergeStatusProperty.

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
VALUE_CHANGED |
VALUE_NOT_COMPARED |
VALUE_RESOLVED |
VALUE_UNCHANGED |
VALUE_UNRESOLVED |
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


MergeStatusProperty Constructor

Creates a new MergeStatusProperty.

public MergeStatusProperty(
Type type
);

Parameters

type
The associated Type.

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


MergeStatusProperty Properties

The properties of the MergeStatusProperty class are listed below. For a complete list of MergeStatusProperty class members, see the MergeStatusProperty Members topic.

Public Static Properties

ID
ID_CHANGED
ID_NOT_COMPARED
ID_RESOLVED
ID_UNCHANGED
ID_UNRESOLVED
NAME

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
VALUE_CHANGED |
VALUE_NOT_COMPARED |
VALUE_RESOLVED |
VALUE_UNCHANGED |
VALUE_UNRESOLVED |
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


ID Property

Borland StarTeam SDK for .NET

MergeStatusProperty.ID Property

new public static Int32 ID {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


ID_CHANGED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.ID_CHANGED Property

public static Int32 ID_CHANGED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


ID_NOT_COMPARED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.ID_NOT_COMPARED Property

public static Int32 ID_NOT_COMPARED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


ID_RESOLVED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.ID_RESOLVED Property

public static Int32 ID_RESOLVED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


ID_UNCHANGED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.ID_UNCHANGED Property

public static Int32 ID_UNCHANGED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


ID_UNRESOLVED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.ID_UNRESOLVED Property

public static Int32 ID_UNRESOLVED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


NAME Property

Borland StarTeam SDK for .NET

MergeStatusProperty.NAME Property

public static String NAME {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


VALUE_CHANGED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.VALUE_CHANGED Property

public EnumeratedValue VALUE_CHANGED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


VALUE_NOT_COMPARED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.VALUE_NOT_COMPARED Property

public EnumeratedValue VALUE_NOT_COMPARED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


VALUE_RESOLVED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.VALUE_RESOLVED Property

public EnumeratedValue VALUE_RESOLVED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


VALUE_UNCHANGED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.VALUE_UNCHANGED Property

public EnumeratedValue VALUE_UNCHANGED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


VALUE_UNRESOLVED Property

Borland StarTeam SDK for .NET

MergeStatusProperty.VALUE_UNRESOLVED Property

public EnumeratedValue VALUE_UNRESOLVED {get;}

See Also

MergeStatusProperty Class | StarTeam.ViewCompareMerge Namespace


MergeType Class

The type of view compare/merge operation to be performed.

For a list of all members of this type, see MergeType Members.

System.Object
MergeType

public class MergeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

MergeType Members | StarTeam.ViewCompareMerge Namespace


MergeType Members

MergeType overview

Public Static Properties

COMPARE
PROMOTE
REBASE
REPLICATE

Public Instance Properties

AllMergeTypes | [read] A list of all supported merge types.
Name | [read] The user-friendly name of this merge type.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.MergeType.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.MergeType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToInt | Gets an integer ID that is unique for each merge type.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.MergeType.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


MergeType Properties

The properties of the MergeType class are listed below. For a complete list of MergeType class members, see the MergeType Members topic.

Public Static Properties

COMPARE
PROMOTE
REBASE
REPLICATE

Public Instance Properties

AllMergeTypes | [read] A list of all supported merge types.
Name | [read] The user-friendly name of this merge type.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


AllMergeTypes Property

Borland StarTeam SDK for .NET

MergeType.AllMergeTypes Property

[read] A list of all supported merge types.

public virtual MergeType[] AllMergeTypes {get;}

Property Value

A list of all supported merge types.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


COMPARE Property

Borland StarTeam SDK for .NET

MergeType.COMPARE Property

public static MergeType COMPARE {get;}

Property Value

The source and target views are compared, but no merging is performed.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


Name Property

Borland StarTeam SDK for .NET

MergeType.Name Property

[read] The user-friendly name of this merge type.

public virtual String Name {get;}

Property Value

The user-friendly name of this merge type.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


PROMOTE Property

Borland StarTeam SDK for .NET

MergeType.PROMOTE Property

public static MergeType PROMOTE {get;}

Property Value

Changes are promoted from the source view to the target view.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


REBASE Property

Borland StarTeam SDK for .NET

MergeType.REBASE Property

public static MergeType REBASE {get;}

Property Value

Changes are rebased from the source view to the target view.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


REPLICATE Property

Borland StarTeam SDK for .NET

MergeType.REPLICATE Property

public static MergeType REPLICATE {get;}

Property Value

Changes are replicated from the source view to the target view.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


MergeType Methods

The methods of the MergeType class are listed below. For a complete list of MergeType class members, see the MergeType Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.MergeType.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.MergeType.
GetType (inherited from Object) | Gets the Type of the current instance.
ToInt | Gets an integer ID that is unique for each merge type.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.MergeType.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


MergeType.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.MergeType.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.MergeType.Equals(obj).

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


MergeType.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.MergeType.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.MergeType.GetHashCode().

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


MergeType.ToInt Method

Gets an integer ID that is unique for each merge type.

public virtual int ToInt();

Return Value

An integer ID that is unique for each merge type.

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


MergeType.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.MergeType.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.MergeType.ToString()

See Also

MergeType Class | StarTeam.ViewCompareMerge Namespace


Options Class

A set of user preferences that guide a view compare/merge operation. For any invocation of view compare and/or merge, these preferences may be overridden. The intent is that this set of preferences can be stored persistently and retrieved when setting up a view compare/merge operation, and that the set of options reflects what this user will usually want for the operation.

For a list of all members of this type, see Options Members.

System.Object
Options

public class Options

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

Options Members | StarTeam.ViewCompareMerge Namespace


Options Members

Options overview

Public Static Properties

WorkstationDefault [read] the default Options for this workstation

Public Static Methods

GetCustomOptions | Look for a custom merge type by name on the specified server, return a fully configured set of options after parsing the .xml.
GetExcludablePropertiesForMerge |

Public Instance Constructors

Options Overloaded. Initializes a new instance of the Options class.

Public Instance Properties

ActionOverrides | [read] ActionOverride[] An array of ActionOverride's, returned in the order in which they were entered
AutoMergeFiles | [read/write] true if file pairs that have no conflicts will be automatically merged.
AutoMergeProperties | [read/write] true if property pairs that have no conflicts will be automatically merged.
BreakLocksAutomatically | [read/write] true if locks will automatically be broken as needed to check in merged revisions.
CheckinOptions | [read/write] the CheckinOptions to be used for committing the workspace session
CheckoutOptions | [read/write] the CheckoutOptions to be used for committing the workspace session
CheckTargetFoldersForFloatingShares | [read/write] true if VCM will check target folders for floating child shares, and fail if any are found. Enabled by default.
FindNotInViewFolders | [read/write] true if not in view folders should be considered during a workspace compare
FixFloatingChildShares | [read/write] true if shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit; false otherwise.
IgnoreMergePoints | [read/write] true if all merge points should be ignored for comparisons, false if merge points should be used.
LockSourceForDifference | [read/write] true if a source item will be locked when a difference is detected.
LockTargetForDifference | [read/write] true if a target item will be locked when a difference is detected.
MatchFilesByFileName | [read/write] true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match.
PropertiesExcludedForMerge | [read] The set of properties excluded from a VCM Merge
PropertyNames | [read] String[] the array of all the keys in this property list
TreatFileNamesAsCaseSensitive | [read/write] true if file (or folder) names are compared in a case-sensitive manner.
VerboseProcessLinks | [read/write] true if commit operations should create process links for all file and folder operations that add or modify target items; false if process links are created only for file checkins (which is consistent with the rest of StarTeam). Verbose process links are enabled by default.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.Options.
ExcludePropertyFromMerge |
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.Options.
GetProperty | Searches for the property with the specified key in this property list.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVerboseDifferences |
IsExcludedFromMerge | returns true if the specified property has been excluded from the merge
SetDefaultAction | Overloaded. Changes the default action in a given situation. Note that there may be one and only one default action for a given DifferenceType
SetExcludePropertyFromMerge |
SetProperty | Sets a value for the property identified by the specified key
SetVerboseDifferences |
SetWorkstationDefault | Saves the current set of options as the defaults for this workstation.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.Options.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options Constructor

Constructs a set of Options with default values.

Overload List

Constructs a set of Options with default values.

public Options();

Create an Options instance by copying the contents of another

public Options(Options);

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options Constructor ()

Constructs a set of Options with default values.

public Options();

See Also

Options Class | StarTeam.ViewCompareMerge Namespace | Options Constructor Overload List


Options Constructor (Options)

Create an Options instance by copying the contents of another

public Options(
Options theOther
);

Parameters

theOther
Options the other Options instance

See Also

Options Class | StarTeam.ViewCompareMerge Namespace | Options Constructor Overload List


Options Properties

The properties of the Options class are listed below. For a complete list of Options class members, see the Options Members topic.

Public Static Properties

WorkstationDefault [read] the default Options for this workstation

Public Instance Properties

ActionOverrides | [read] ActionOverride[] An array of ActionOverride's, returned in the order in which they were entered
AutoMergeFiles | [read/write] true if file pairs that have no conflicts will be automatically merged.
AutoMergeProperties | [read/write] true if property pairs that have no conflicts will be automatically merged.
BreakLocksAutomatically | [read/write] true if locks will automatically be broken as needed to check in merged revisions.
CheckinOptions | [read/write] the CheckinOptions to be used for committing the workspace session
CheckoutOptions | [read/write] the CheckoutOptions to be used for committing the workspace session
CheckTargetFoldersForFloatingShares | [read/write] true if VCM will check target folders for floating child shares, and fail if any are found. Enabled by default.
FindNotInViewFolders | [read/write] true if not in view folders should be considered during a workspace compare
FixFloatingChildShares | [read/write] true if shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit; false otherwise.
IgnoreMergePoints | [read/write] true if all merge points should be ignored for comparisons, false if merge points should be used.
LockSourceForDifference | [read/write] true if a source item will be locked when a difference is detected.
LockTargetForDifference | [read/write] true if a target item will be locked when a difference is detected.
MatchFilesByFileName | [read/write] true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match.
PropertiesExcludedForMerge | [read] The set of properties excluded from a VCM Merge
PropertyNames | [read] String[] the array of all the keys in this property list
TreatFileNamesAsCaseSensitive | [read/write] true if file (or folder) names are compared in a case-sensitive manner.
VerboseProcessLinks | [read/write] true if commit operations should create process links for all file and folder operations that add or modify target items; false if process links are created only for file checkins (which is consistent with the rest of StarTeam). Verbose process links are enabled by default.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


ActionOverrides Property

Borland StarTeam SDK for .NET

Options.ActionOverrides Property

[read] ActionOverride[] An array of ActionOverride's, returned in the order in which they were entered

public virtual ActionOverride[] ActionOverrides {get;}

Property Value

ActionOverride[] An array of ActionOverride's, returned in the order in which they were entered

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


AutoMergeFiles Property

Borland StarTeam SDK for .NET

Options.AutoMergeFiles Property

[read/write] true if file pairs that have no conflicts will be automatically merged.

public virtual Boolean AutoMergeFiles {get; set;}

Property Value

true if file pairs that have no conflicts will be automatically merged.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


AutoMergeProperties Property

Borland StarTeam SDK for .NET

Options.AutoMergeProperties Property

[read/write] true if property pairs that have no conflicts will be automatically merged.

public virtual Boolean AutoMergeProperties {get; set;}

Property Value

true if property pairs that have no conflicts will be automatically merged.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


BreakLocksAutomatically Property

Borland StarTeam SDK for .NET

Options.BreakLocksAutomatically Property

[read/write] true if locks will automatically be broken as needed to check in merged revisions.

public virtual Boolean BreakLocksAutomatically {get; set;}

Property Value

true if locks will automatically be broken as needed to check in merged revisions.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


CheckinOptions Property

Borland StarTeam SDK for .NET

Options.CheckinOptions Property

[read/write] the CheckinOptions to be used for committing the workspace session

public virtual CheckinOptions CheckinOptions {get; set;}

Property Value

the CheckinOptions to be used for committing the workspace session

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


CheckoutOptions Property

Borland StarTeam SDK for .NET

Options.CheckoutOptions Property

[read/write] the CheckoutOptions to be used for committing the workspace session

public virtual CheckoutOptions CheckoutOptions {get; set;}

Property Value

the CheckoutOptions to be used for committing the workspace session

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


CheckTargetFoldersForFloatingShares Property

Borland StarTeam SDK for .NET

Options.CheckTargetFoldersForFloatingShares Property

[read/write] true if VCM will check target folders for floating child shares, and fail if any are found. Enabled by default.

public virtual Boolean CheckTargetFoldersForFloatingShares {get; set;}

Property Value

true if VCM will check target folders for floating child shares, and fail if any are found. Enabled by default.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


FindNotInViewFolders Property

Borland StarTeam SDK for .NET

Options.FindNotInViewFolders Property

[read/write] true if not in view folders should be considered during a workspace compare

public virtual Boolean FindNotInViewFolders {get; set;}

Property Value

true if not in view folders should be considered during a workspace compare

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


FixFloatingChildShares Property

Borland StarTeam SDK for .NET

Options.FixFloatingChildShares Property

[read/write] true if shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit; false otherwise.

public virtual Boolean FixFloatingChildShares {get; set;}

Property Value

true if shares that float from the source view to the target view will automatically be detected during the compare phase and fixed during the commit; false otherwise.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


IgnoreMergePoints Property

Borland StarTeam SDK for .NET

Options.IgnoreMergePoints Property

[read/write] true if all merge points should be ignored for comparisons, false if merge points should be used.

public virtual Boolean IgnoreMergePoints {get; set;}

Property Value

true if all merge points should be ignored for comparisons, false if merge points should be used.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


LockSourceForDifference Property

Borland StarTeam SDK for .NET

Options.LockSourceForDifference Property

[read/write] true if a source item will be locked when a difference is detected.

public virtual Boolean LockSourceForDifference {get; set;}

Property Value

true if a source item will be locked when a difference is detected.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


LockTargetForDifference Property

Borland StarTeam SDK for .NET

Options.LockTargetForDifference Property

[read/write] true if a target item will be locked when a difference is detected.

public virtual Boolean LockTargetForDifference {get; set;}

Property Value

true if a target item will be locked when a difference is detected.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


MatchFilesByFileName Property

Borland StarTeam SDK for .NET

Options.MatchFilesByFileName Property

[read/write] true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match.

public virtual Boolean MatchFilesByFileName {get; set;}

Property Value

true if files (or folders) with the same name are to be considered matched, even if their object and/or item ids do not match.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


PropertiesExcludedForMerge Property

Borland StarTeam SDK for .NET

Options.PropertiesExcludedForMerge Property

[read] The set of properties excluded from a VCM Merge

public virtual PropertyCollection PropertiesExcludedForMerge {get;}

Property Value

The set of properties excluded from a VCM Merge

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


PropertyNames Property

Borland StarTeam SDK for .NET

Options.PropertyNames Property

[read] String[] the array of all the keys in this property list

public virtual String[] PropertyNames {get;}

Property Value

String[] the array of all the keys in this property list

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


TreatFileNamesAsCaseSensitive Property

Borland StarTeam SDK for .NET

Options.TreatFileNamesAsCaseSensitive Property

[read/write] true if file (or folder) names are compared in a case-sensitive manner.

public virtual Boolean TreatFileNamesAsCaseSensitive {get; set;}

Property Value

true if file (or folder) names are compared in a case-sensitive manner.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


VerboseProcessLinks Property

Borland StarTeam SDK for .NET

Options.VerboseProcessLinks Property

[read/write] true if commit operations should create process links for all file and folder operations that add or modify target items; false if process links are created only for file checkins (which is consistent with the rest of StarTeam). Verbose process links are enabled by default.

public virtual Boolean VerboseProcessLinks {get; set;}

Property Value

true if commit operations should create process links for all file and folder operations that add or modify target items; false if process links are created only for file checkins (which is consistent with the rest of StarTeam). Verbose process links are enabled by default.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


WorkstationDefault Property

Borland StarTeam SDK for .NET

Options.WorkstationDefault Property

[read] the default Options for this workstation

public static Options WorkstationDefault {get;}

Property Value

the default Options for this workstation

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options Methods

The methods of the Options class are listed below. For a complete list of Options class members, see the Options Members topic.

Public Static Methods

GetCustomOptions | Look for a custom merge type by name on the specified server, return a fully configured set of options after parsing the .xml.
GetExcludablePropertiesForMerge |

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.Options.
ExcludePropertyFromMerge |
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.Options.
GetProperty | Searches for the property with the specified key in this property list.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVerboseDifferences |
IsExcludedFromMerge | returns true if the specified property has been excluded from the merge
SetDefaultAction | Overloaded. Changes the default action in a given situation. Note that there may be one and only one default action for a given DifferenceType
SetExcludePropertyFromMerge |
SetProperty | Sets a value for the property identified by the specified key
SetVerboseDifferences |
SetWorkstationDefault | Saves the current set of options as the defaults for this workstation.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.Options.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.Options.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.Options.Equals(obj).

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.ExcludePropertyFromMerge Method

public virtual void ExcludePropertyFromMerge(
Property p
);

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.GetCustomOptions Method

Look for a custom merge type by name on the specified server, return a fully configured set of options after parsing the .xml.

public static Options GetCustomOptions(
Server s,
String name
);

Parameters

s
the logged in server on which to find the custom vcm .xml in the StarFlow Extensions Project
name
the name of a custom merge type to lookup

Return Value

a fully configured set of options for the specified custom merge or NULL if the name cannot be found. The caller can then apply the defaults specified in the returned options to a vcm session. Useful for vcmutility where the default actions per difference type should be overridden to support ui free command line merges

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.GetExcludablePropertiesForMerge Method

public static PropertyCollection GetExcludablePropertiesForMerge(
Item.Type type
);

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.Options.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.Options.GetHashCode().

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.GetProperty Method

Searches for the property with the specified key in this property list.

public virtual string GetProperty(
String key
);

Parameters

key
String the key to search for

Return Value

String the stored property value for the specified key

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.GetVerboseDifferences Method

public virtual bool GetVerboseDifferences(
Item.Type type
);

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.IsExcludedFromMerge Method

returns true if the specified property has been excluded from the merge

public virtual bool IsExcludedFromMerge(
Property p
);

Parameters

p
a property to test

Return Value

true if the specified property has been excluded from the merge

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


SetDefaultAction Method

Borland StarTeam SDK for .NET

Options.SetDefaultAction Method

Changes the default action in a given situation.

Note that there may be one and only one default action for a given DifferenceType

Overload List

Changes the default action in a given situation. Note that there may be one and only one default action for a given DifferenceType

public virtual void SetDefaultAction(DifferenceType,MergeAction);

Changes the default action in a given situation. Note that if multiple calls to setDefaultAction() are made, the order is significant. If two overrides are both relevant to a given ItemDifference, the most recently specified one takes precedence.

public virtual void SetDefaultAction(MatchState,MergeAction);

See Also

Options Class | StarTeam.ViewCompareMerge Namespace | MergeAction


Options.SetDefaultAction Method (DifferenceType, MergeAction)

Changes the default action in a given situation.

Note that there may be one and only one default action for a given DifferenceType

public virtual void SetDefaultAction(
DifferenceType type,
MergeAction action
);

Parameters

type
The DifferenceType for which the default action is to be changed.
action
The new default action for the given DifferenceType, or null to restore the default action to the engine's default value.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace | Options.SetDefaultAction Overload List | MergeAction


Options.SetDefaultAction Method (MatchState, MergeAction)

Changes the default action in a given situation.

Note that if multiple calls to setDefaultAction() are made, the order is significant. If two overrides are both relevant to a given ItemDifference, the most recently specified one takes precedence.

public virtual void SetDefaultAction(
MatchState state,
MergeAction action
);

Parameters

state
The MatchState for which the default action is to be changed.
action
The new default action for the given MatchState, or null to restore the default action to the engine's default value.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace | Options.SetDefaultAction Overload List | MergeAction


Options.SetExcludePropertyFromMerge Method

public virtual void SetExcludePropertyFromMerge(
Property p,
Boolean exclude
);

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.SetProperty Method

Sets a value for the property identified by the specified key

public virtual object SetProperty(
String key,
String value
);

Parameters

key
String the key for which a value needs to be set
value
String the value to set

Return Value

Object he previous value of the specified key in this property list, or null if it did not have one.

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.SetVerboseDifferences Method

public virtual void SetVerboseDifferences(
Item.Type type,
Boolean bVerbose
);

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.SetWorkstationDefault Method

Saves the current set of options as the defaults for this workstation.

public virtual void SetWorkstationDefault();

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


Options.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.Options.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.Options.ToString()

See Also

Options Class | StarTeam.ViewCompareMerge Namespace


ProcessItemScope Class

Includes a process item, and the items that are linked and pinned to it, in the scope of a session.

For a list of all members of this type, see ProcessItemScope Members.

System.Object
Scope
ProcessItemScope

public class ProcessItemScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

ProcessItemScope Members | StarTeam.ViewCompareMerge Namespace


ProcessItemScope Members

ProcessItemScope overview

Public Instance Constructors

ProcessItemScope Overloaded. Initializes a new instance of the ProcessItemScope class.

Public Instance Properties

Description (inherited from Scope) | [read] a String that provides a description of this scope.
ItemTypes (inherited from Scope) | [read] The list of types to be processed.
Rollup | [read/write] true if rollup is assigned

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope (inherited from Scope) |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

ProcessItemScope Class | StarTeam.ViewCompareMerge Namespace


ProcessItemScope Constructor

Creates a new ProcessItemScope.

Overload List

Creates a new ProcessItemScope.

public ProcessItemScope(Item,Boolean);

Creates a new ProcessItemScope.

public ProcessItemScope(ViewMember);

See Also

ProcessItemScope Class | StarTeam.ViewCompareMerge Namespace


ProcessItemScope Constructor (ViewMember)

Creates a new ProcessItemScope.

public ProcessItemScope(
ViewMember vm
);

Parameters

vm
A process item. If the item resides in the source view of the session, then the process item itself is in scope. Any file revisions from the source view that are linked via process links to this process item (pinned to a specific revision at both endpoints) are also in scope.

See Also

ProcessItemScope Class | StarTeam.ViewCompareMerge Namespace | ProcessItemScope Constructor Overload List


ProcessItemScope Constructor (Item, Boolean)

Creates a new ProcessItemScope.

public ProcessItemScope(
Item item,
Boolean bLinksOnly
);

Parameters

item
A process item. Any file revisions from the source view that are linked via process links to this process item (pinned to a specific revision at both endpoints) are in scope.
bLinksOnly
If false, then the process item itself will be included in the scope (provided that it resides in the source view). Otherwise, only linked files are included.

See Also

ProcessItemScope Class | StarTeam.ViewCompareMerge Namespace | ProcessItemScope Constructor Overload List


ProcessItemScope Properties

The properties of the ProcessItemScope class are listed below. For a complete list of ProcessItemScope class members, see the ProcessItemScope Members topic.

Public Instance Properties

Description (inherited from Scope) | [read] a String that provides a description of this scope.
ItemTypes (inherited from Scope) | [read] The list of types to be processed.
Rollup | [read/write] true if rollup is assigned

See Also

ProcessItemScope Class | StarTeam.ViewCompareMerge Namespace


Rollup Property

Borland StarTeam SDK for .NET

ProcessItemScope.Rollup Property

[read/write] true if rollup is assigned

public virtual Boolean Rollup {get; set;}

Property Value

true if rollup is assigned

See Also

ProcessItemScope Class | StarTeam.ViewCompareMerge Namespace


Progress Class

Information on the progress of a Merge operation from ViewMerger. This provides a snapshot of the progress at the time of request. The values in this class do not change again once the class is created. To retrieve the current progress, use ViewMerger.getProgress().

For a list of all members of this type, see Progress Members.

System.Object
Progress

public class Progress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

Progress Members | StarTeam.ViewCompareMerge Namespace


Progress Members

Progress overview

Public Instance Properties

Description | [read] String a description of the current state of the session
EstimatedPercentComplete | [read] a percentage estimate of how complete the current operation is.
EstimatedTimeRemaining | [read] an estimate of the time that remains to complete the current compare operation.
IsInTransaction | [read] true if the Commit Transaction has begun for this session
RemainingUnitsOfWork | [read] Return the total number of operations yet to be completed..
TotalTimeSpent | [read] Return the total time spent so far (in milliseconds).
TotalUnitsOfWorkCompleted | [read] Return the total number of operations completed.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.Progress.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.Progress.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.Progress.

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


Progress Properties

The properties of the Progress class are listed below. For a complete list of Progress class members, see the Progress Members topic.

Public Instance Properties

Description | [read] String a description of the current state of the session
EstimatedPercentComplete | [read] a percentage estimate of how complete the current operation is.
EstimatedTimeRemaining | [read] an estimate of the time that remains to complete the current compare operation.
IsInTransaction | [read] true if the Commit Transaction has begun for this session
RemainingUnitsOfWork | [read] Return the total number of operations yet to be completed..
TotalTimeSpent | [read] Return the total time spent so far (in milliseconds).
TotalUnitsOfWorkCompleted | [read] Return the total number of operations completed.

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


Description Property

Borland StarTeam SDK for .NET

Progress.Description Property

[read] String a description of the current state of the session

public virtual String Description {get;}

Property Value

String a description of the current state of the session

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


EstimatedPercentComplete Property

Borland StarTeam SDK for .NET

Progress.EstimatedPercentComplete Property

[read] a percentage estimate of how complete the current operation is.

public virtual Int32 EstimatedPercentComplete {get;}

Property Value

a percentage estimate of how complete the current operation is.

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


EstimatedTimeRemaining Property

Borland StarTeam SDK for .NET

Progress.EstimatedTimeRemaining Property

[read] an estimate of the time that remains to complete the current compare operation.

public virtual Int64 EstimatedTimeRemaining {get;}

Property Value

an estimate of the time that remains to complete the current compare operation.

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


IsInTransaction Property

Borland StarTeam SDK for .NET

Progress.IsInTransaction Property

[read] true if the Commit Transaction has begun for this session

public virtual Boolean IsInTransaction {get;}

Property Value

true if the Commit Transaction has begun for this session

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


RemainingUnitsOfWork Property

Borland StarTeam SDK for .NET

Progress.RemainingUnitsOfWork Property

[read] Return the total number of operations yet to be completed..

public virtual Int32 RemainingUnitsOfWork {get;}

Property Value

Return the total number of operations yet to be completed..

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


TotalTimeSpent Property

Borland StarTeam SDK for .NET

Progress.TotalTimeSpent Property

[read] Return the total time spent so far (in milliseconds).

public virtual Int64 TotalTimeSpent {get;}

Property Value

Return the total time spent so far (in milliseconds).

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


TotalUnitsOfWorkCompleted Property

Borland StarTeam SDK for .NET

Progress.TotalUnitsOfWorkCompleted Property

[read] Return the total number of operations completed.

public virtual Int32 TotalUnitsOfWorkCompleted {get;}

Property Value

Return the total number of operations completed.

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


Progress Methods

The methods of the Progress class are listed below. For a complete list of Progress class members, see the Progress Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.Progress.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.Progress.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.Progress.

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


Progress.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.Progress.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.Progress.Equals(obj).

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


Progress.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.Progress.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.Progress.GetHashCode().

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


Progress.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.Progress.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.Progress.ToString()

See Also

Progress Class | StarTeam.ViewCompareMerge Namespace


RevisionLabelScope Class

Includes all item revisions with a given revision label in the scope of the view compare/merge session.

For a list of all members of this type, see RevisionLabelScope Members.

System.Object
Scope
RevisionLabelScope

public class RevisionLabelScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

RevisionLabelScope Members | StarTeam.ViewCompareMerge Namespace


RevisionLabelScope Members

RevisionLabelScope overview

Public Instance Constructors

RevisionLabelScope Overloaded. Initializes a new instance of the RevisionLabelScope class.

Public Instance Properties

Description (inherited from Scope) | [read] a String that provides a description of this scope.
ItemTypes (inherited from Scope) | [read] The list of types to be processed.

Public Instance Methods

Equals (inherited from Scope) | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode (inherited from Scope) | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision (inherited from Scope) | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope (inherited from Scope) |
Refresh (inherited from Scope) | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Resolve (inherited from Scope) | resolve the specified file to the revisions produced by any/all process items in this scope
ToString (inherited from Scope) | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

RevisionLabelScope Class | StarTeam.ViewCompareMerge Namespace


RevisionLabelScope Constructor

Creates a new RevisionLabelScope.

Overload List

Creates a new RevisionLabelScope.

public RevisionLabelScope(Label);

public RevisionLabelScope(Label,Item.Type);

Creates a new RevisionLabelScope.

public RevisionLabelScope(Label,TypeCollection);

See Also

RevisionLabelScope Class | StarTeam.ViewCompareMerge Namespace


RevisionLabelScope Constructor (Label)

Creates a new RevisionLabelScope.

public RevisionLabelScope(
Label label
);

Parameters

label
A revision label. All item revisions with this label are included in the scope of the view compare/merge session.

See Also

RevisionLabelScope Class | StarTeam.ViewCompareMerge Namespace | RevisionLabelScope Constructor Overload List


RevisionLabelScope Constructor (Label, Item#Type)

public RevisionLabelScope(
Label label,
Item.Type type
);

See Also

RevisionLabelScope Class | StarTeam.ViewCompareMerge Namespace | RevisionLabelScope Constructor Overload List


RevisionLabelScope Constructor (Label, TypeCollection)

Creates a new RevisionLabelScope.

public RevisionLabelScope(
Label label,
TypeCollection types
);

Parameters

label
A revision label. Item revisions with this label are included in the scope of the view compare/merge session.
types
A list of item types. Only items with these types are included.

See Also

RevisionLabelScope Class | StarTeam.ViewCompareMerge Namespace | RevisionLabelScope Constructor Overload List


Scope Class

Provides a client application a flexible way to specify the scope of a view compare/merge operation.

The View Compare/Merge engine provides implementations of Scope that should suffice for most applications. In each case, the implementation is public, and may be re-used in the development of custom Scopes.

For a list of all members of this type, see Scope Members.

System.Object
Scope
Derived types

public class Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

Scope Members | StarTeam.ViewCompareMerge Namespace


Scope Members

Scope overview

Public Instance Properties

Description | [read] a String that provides a description of this scope.
ItemTypes | [read] The list of types to be processed.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope |
Refresh | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Resolve | resolve the specified file to the revisions produced by any/all process items in this scope
ToString | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Scope Properties

The properties of the Scope class are listed below. For a complete list of Scope class members, see the Scope Members topic.

Public Instance Properties

Description | [read] a String that provides a description of this scope.
ItemTypes | [read] The list of types to be processed.

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Description Property

Borland StarTeam SDK for .NET

Scope.Description Property

[read] a String that provides a description of this scope.

public virtual String Description {get;}

Property Value

a String that provides a description of this scope.

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


ItemTypes Property

Borland StarTeam SDK for .NET

Scope.ItemTypes Property

[read] The list of types to be processed.

public virtual TypeCollection ItemTypes {get;}

Property Value

The list of types to be processed.

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Scope Methods

The methods of the Scope class are listed below. For a complete list of Scope class members, see the Scope Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.Scope.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.
GetIncludedRevision | Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision. During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope. Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope. Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).
GetType (inherited from Object) | Gets the Type of the current instance.
IsFullScope |
Refresh | Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa. The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().
Resolve | resolve the specified file to the revisions produced by any/all process items in this scope
ToString | Delegate ToString() to com.starteam.viewcomparemerge.Scope.

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Scope.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.Scope.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.Scope.Equals(obj).

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Scope.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.Scope.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.Scope.GetHashCode().

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Scope.GetIncludedRevision Method

Determines whether or not the given source item is in scope for the current view compare/merge operation, and, if so, returns the item revision that should be used for comparision.

During a compare operation, the getIncludedRevision() method is called for every source folder whose parent is in scope, and for every item whose type and parent folder are in scope.

Each implementation of Scope must guarantee that if getIncludedRevision() is called again on the same item, without an intervening call to refresh(), the result is the same between calls. That is, until a refresh() is called, a given item must be consistently in scope or out of scope.

Scope implementations may assume that getIncludedRevision() is called only for types that are in scope (and folders).

public virtual Item GetIncludedRevision(
Item item
);

Parameters

item
Item the item to test for inclusion

Return Value

Item the included revision, if any

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Scope.IsFullScope Method

public virtual bool IsFullScope(
Item.Type type
);

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Scope.Refresh Method

Provides a scope the opportunity to initialize or refresh its state. As a result, some Items that were previously in scope may now be out of scope, and vice versa.

The view compare/merge engine calls refresh() once at the start of Session.compare(), and once for each call to Session.refresh().

public virtual void Refresh(
Session session
);

Parameters

session
the session to refresh

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Scope.Resolve Method

resolve the specified file to the revisions produced by any/all process items in this scope

public virtual ViewMemberCollection Resolve(
File fl
);

Parameters

fl
the FIle to resolve

Return Value

a collection of revisions produced by process items in this sessions

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Scope.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.Scope.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.Scope.ToString()

See Also

Scope Class | StarTeam.ViewCompareMerge Namespace


Session Class

A view compare/merge (VCM) session.

Each VCM session has associated source view and target views. {@linkplain #compare() Comparing} the two generates a set of {@linkplain #getDifferences() differences}. For each difference, you can detect {@linkplain ItemDifference#isConflictDetected conflicts}, {@linkplain ItemDifference#setAction override} default actions, and so on.

Conflicts may be resolved by merging {@linkplain ItemDifference#setMergedPropertyValue(com.starteam.Property, Object) item properties} or {@linkplain ItemDifference#setMergedFileContent(java.io.File) file content}. Alternatively, you can set property values or checkin new file revisions via the {@linkplain #getMergePreview merge preview}, which shows what the target view would look like were the session to be committed in its current state.

When ready, you can {@linkplain #commit() commit} the changes, which updates the target view.

For general information on using the VCM APIs, see com.starteam.viewcomparemerge.

For a list of all members of this type, see Session Members.

System.Object
ChangeSession
Session

public class Session : ChangeSession

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

Session Members | StarTeam.ViewCompareMerge Namespace


Session Members

Session overview

Public Static Methods

ForPromote | Overloaded. Creates a new VCM session for promoting the given view to its parent.
ForRebase | Creates a new VCM session for rebasing the given view from its parent.
ForReplay | Creates a new VCM session for replaying the given change package to a new target view.
ForRollback | Create a new VCM session for rolling back the changes associated with the revisions of files attached to this ChangePackage
GetMatchHint | Determines whether or not a match hint is available that indicates which item in the given target view should be matched to the specified source item.
Remove | Overloaded. Remove the temporary folder tree associated with the specified session file.
Resolve | Resolve a saved session file for a committed session (such as you'd find attached to a process task in the target view), to return a list of all the relevant target item revisions from the ItemDifferences that resulted in changes (i.e., everything except Ignore).
RestoreFrom Overloaded. Restores a saved session from a file. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
SetMatchHint | Saves a match hint, indicating that the given source item corresponds to the given target item, even though the two might otherwise be unrelated. Internally, the match hint is represented by a StarTeam link.

Public Instance Constructors

Session Overloaded. Initializes a new instance of the Session class.

Public Instance Properties

ApplicationObject | [read/write] An application-specific object associated with this session, or null.
CanCommit | [read] boolean true if this session can be committed in its current state, and false otherwise.
ChangePackage (inherited from ChangeSession) | [read] ChangePackage
DefaultComment | [read/write] The default checkin comment.
DefaultDescription | [read] the default description for this session.
DefaultName (inherited from ChangeSession) | [read] A default name for this session.
Description (inherited from ChangeSession) | [read/write] The description of the ChangePackage for this session, or a proposed default description.
Differences | [read] An iterator over the set of differences.
HasDifferences | [read] True if there were differences detected, and false otherwise.
HasLocks (inherited from ChangeSession) | [read] true if any source or target items are currently locked on behalf of this session.
IsActive (inherited from ChangeSession) | [read] boolean
IsCommitted (inherited from ChangeSession) | [read] boolean
IsDirty | [read] true if this session has been changed since it was last saved or restored, and false if it has not been changed.
IsPostCommitRevisionLabelEnabled | [read/write] true if the post-commit revision label will be created, and false otherwise.
IsPostCommitViewLabelEnabled | [read/write] true if the post-commit view label will be created, and false otherwise.
IsPreCommitRevisionLabelEnabled | [read/write] true if the pre-commit revision label will be created, and false otherwise.
IsPreCommitViewLabelEnabled | [read/write] true if the pre-commit view label will be created, and false otherwise.
IsReadOnly (inherited from ChangeSession) | [read] boolean
IsRollbackSession | [read] true if this is a rollback session
IsVerbosePreview | [read/write] true if verbose preview mode is enabled; false if it is disabled.
ItemTypes | [read] The list of types included in the view compare/merge operation.
LockCount (inherited from ChangeSession) | [read] The number of source or target items that are currently locked on behalf of this session.
MergePreview | [read] A preview of the merge results for this session.
MergeType | [read] The merge type of this session.
Name (inherited from ChangeSession) | [read/write] The name of the ChangePackage for this session, or a proposed default name.
NeedsCodeReview | [read] true if this session needs to be code reviewed prior to commit
Options | [read/write] Options that influence the behavior of compare or merge operations.
OriginalDefaultComment | [read] The default checkin comment.
PostCommitRevisionLabelName | [read/write] The name of the post-commit revision label.
PostCommitViewLabelName | [read/write] The name of the post-commit view label.
PreCommitRevisionLabelName | [read/write] The name of the pre-commit revision label.
PreCommitViewLabelName | [read/write] The name of the pre-commit view label.
Progress | [read] A snapshot of the state of the current compare or commit operation.
ReviewValue | [read] Review a pulse review or null
RootDirectory | [read] The path to the temporary folder on disk used by this session.
Scope | [read/write] A scope specifier, indicating which source items are compared against the target in this view compare/merge session, or null for a full-scope compare of files and folders.
Server | [read] The Server instance from which this session was constructed.
ServerInfo | [read] ServerInfo The ServerInfo associated with this session.
SessionState | [read] The current state of this session.
SessionTypeValue | [read] the SessionType of this session, or null for a compare-only session.
SourceView (inherited from ChangeSession) | [read] The source view associated with this session.
SourceViewForCompare | [read] The version of the source view used for comparison.
TargetView (inherited from ChangeSession) | [read] The target view associated with this session.
TargetViewForCompare | [read] The version of the target view used for comparison.

Public Instance Methods

Cancel | Cancels a compare or commit operation that is currently in progress. The {@link #compare compare} and {@link #commit commit} methods return when complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread. If a commit that is being executed as an atomic transaction is canceled before it is completed, then the transaction is rolled back. The source and target views are left in the state they were in prior to the start of the commit.
Close (inherited from ChangeSession) | Overloaded. Closes this change session, and releases the exclusive lock on the corresponding change package, if necessary.
Commit | Commits changes to the target view. Note that this method returns when the commit is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
Compare | Compares the source and target views. Note that this method returns when the compare is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
Connect (inherited from ChangeSession) Connects a restored session to a server instance. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link Session#getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
Equals (inherited from ChangeSession) | Delegate Equals() to com.starteam.ChangeSession.
GenerateDifferenceReport | Overloaded. Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.
GenerateSummary | Generates a summary session report for this session. The report is in HTML format.
GenerateUpdateReport | Generates an update report for this session. This report lists items that were added, changed or removed when the session was committed. The report is in HTML format.
GetDifferencesForMergedItem | Gets the ItemDifference that corresponds to a given merge item. The merged item may have been obtained through {@link ItemDifference#getMergedItem getMergeItem}, or it may have been obtained via the {@linkplain #getMergePreview merge preview}.
GetDifferencesForSourceItem | Gets the ItemDifference that corresponds to a given source item.
GetDifferencesForTargetItem | Gets the ItemDifference that corresponds to a given target item.
GetHashCode (inherited from ChangeSession) | Delegate GetHashCode() to com.starteam.ChangeSession.
GetSourceMatchesForTargetItems | Finds the source items that are the best matches for the given target items. The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchesForTargetItems() may be used by an application that wants to define the scope starting with a set of target items. To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
GetSourceMatchForTargetItem | Finds the source item that is the best match for the given target item. The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchForTargetItem() may be used by an application that wants to define the scope starting with a target item. To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
GetType (inherited from Object) | Gets the Type of the current instance.
HasAlternatePathSet | Returns true if the session has an alternate path set for its merge preview
IsFullScope
IsIncluded | Overloaded.
NewCheckinEventSource
NewCheckoutEventSource
Remove | Overloaded. Removes this session and any associated temporary files on disk.
RemoveLocks (inherited from ChangeSession) | Unlocks any source or target items that were locked on behalf of this session. If the session is in a disconnected state removeLocks will inspect the XML representation of the session to identify and unlock the locked items
Restart (inherited from ChangeSession) | Restart this session The session is opened for writing, and is ready to re-run a compare in the current context of the source and target views
Save (inherited from ChangeSession) | Saves the current state of this session. The session must be in an active state. If the session was not previously saved, a new active change package is created.
SaveTo | Save this session to a file. If copyContent is false, then merged file content is stored in a session-specific temporary file on disk. This results in smaller session files, but means that they are generally useful only from the computer where they were generated. If copyContent is true, then merged file content is copied into the session file. This may result in very large session files, but allows them to be used from any computer, attached to email messages, and so on.
SetMatch | Tells the VCM engine to match a specific source item to a specific target item. This overrides the normal comparison logic. A client application can call setMatch() before calling compare() to avoid an AmbiguousMatchException.
ToString (inherited from ChangeSession) | Delegate ToString() to com.starteam.ChangeSession.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session Constructor

Constructs a new VCM session for comparing and merging changes from the desktop (workspace) to the given view

Overload List

Constructs a new VCM session for comparing and merging changes from the desktop (workspace) to the given view

public Session(View);

Constructs a new VCM session, for comparing and merging changes from a given source view to a given target view.

public Session(MergeType,View,View);

Constructs a new VCM session, for comparing and merging changes from a given source view to a given target view.

public Session(MergeType,View,View,Options);

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session Constructor (View)

Constructs a new VCM session for comparing and merging changes from the desktop (workspace) to the given view

public Session(
View view
);

Parameters

view
the target view

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session Constructor Overload List


Session Constructor (MergeType, View, View)

Constructs a new VCM session, for comparing and merging changes from a given source view to a given target view.

public Session(
MergeType mergeType,
View source,
View target
);

Parameters

mergeType
The type of compare/merge to be performed.
source
The source view.
target
The target view.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session Constructor Overload List | Session | getMergeType | getSourceView | getTargetView


Session Constructor (MergeType, View, View, Options)

Constructs a new VCM session, for comparing and merging changes from a given source view to a given target view.

public Session(
MergeType mergeType,
View source,
View target,
Options options
);

Parameters

mergeType
The type of compare/merge to be performed.
source
The source view.
target
The target view.
options
Options that influence the behavior of the compare or merge operations.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session Constructor Overload List | Session | getMergeType | getSourceView | getTargetView | getOptions


Session Properties

The properties of the Session class are listed below. For a complete list of Session class members, see the Session Members topic.

Public Instance Properties

ApplicationObject | [read/write] An application-specific object associated with this session, or null.
CanCommit | [read] boolean true if this session can be committed in its current state, and false otherwise.
ChangePackage (inherited from ChangeSession) | [read] ChangePackage
DefaultComment | [read/write] The default checkin comment.
DefaultDescription | [read] the default description for this session.
DefaultName (inherited from ChangeSession) | [read] A default name for this session.
Description (inherited from ChangeSession) | [read/write] The description of the ChangePackage for this session, or a proposed default description.
Differences | [read] An iterator over the set of differences.
HasDifferences | [read] True if there were differences detected, and false otherwise.
HasLocks (inherited from ChangeSession) | [read] true if any source or target items are currently locked on behalf of this session.
IsActive (inherited from ChangeSession) | [read] boolean
IsCommitted (inherited from ChangeSession) | [read] boolean
IsDirty | [read] true if this session has been changed since it was last saved or restored, and false if it has not been changed.
IsPostCommitRevisionLabelEnabled | [read/write] true if the post-commit revision label will be created, and false otherwise.
IsPostCommitViewLabelEnabled | [read/write] true if the post-commit view label will be created, and false otherwise.
IsPreCommitRevisionLabelEnabled | [read/write] true if the pre-commit revision label will be created, and false otherwise.
IsPreCommitViewLabelEnabled | [read/write] true if the pre-commit view label will be created, and false otherwise.
IsReadOnly (inherited from ChangeSession) | [read] boolean
IsRollbackSession | [read] true if this is a rollback session
IsVerbosePreview | [read/write] true if verbose preview mode is enabled; false if it is disabled.
ItemTypes | [read] The list of types included in the view compare/merge operation.
LockCount (inherited from ChangeSession) | [read] The number of source or target items that are currently locked on behalf of this session.
MergePreview | [read] A preview of the merge results for this session.
MergeType | [read] The merge type of this session.
Name (inherited from ChangeSession) | [read/write] The name of the ChangePackage for this session, or a proposed default name.
NeedsCodeReview | [read] true if this session needs to be code reviewed prior to commit
Options | [read/write] Options that influence the behavior of compare or merge operations.
OriginalDefaultComment | [read] The default checkin comment.
PostCommitRevisionLabelName | [read/write] The name of the post-commit revision label.
PostCommitViewLabelName | [read/write] The name of the post-commit view label.
PreCommitRevisionLabelName | [read/write] The name of the pre-commit revision label.
PreCommitViewLabelName | [read/write] The name of the pre-commit view label.
Progress | [read] A snapshot of the state of the current compare or commit operation.
ReviewValue | [read] Review a pulse review or null
RootDirectory | [read] The path to the temporary folder on disk used by this session.
Scope | [read/write] A scope specifier, indicating which source items are compared against the target in this view compare/merge session, or null for a full-scope compare of files and folders.
Server | [read] The Server instance from which this session was constructed.
ServerInfo | [read] ServerInfo The ServerInfo associated with this session.
SessionState | [read] The current state of this session.
SessionTypeValue | [read] the SessionType of this session, or null for a compare-only session.
SourceView (inherited from ChangeSession) | [read] The source view associated with this session.
SourceViewForCompare | [read] The version of the source view used for comparison.
TargetView (inherited from ChangeSession) | [read] The target view associated with this session.
TargetViewForCompare | [read] The version of the target view used for comparison.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


ApplicationObject Property

Borland StarTeam SDK for .NET

Session.ApplicationObject Property

[read/write] An application-specific object associated with this session, or null.

public virtual Object ApplicationObject {get; set;}

Property Value

An application-specific object associated with this session, or null.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


CanCommit Property

Borland StarTeam SDK for .NET

Session.CanCommit Property

[read] boolean true if this session can be committed in its current state, and false otherwise.

public virtual Boolean CanCommit {get;}

Property Value

boolean true if this session can be committed in its current state, and false otherwise.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


DefaultComment Property

Borland StarTeam SDK for .NET

Session.DefaultComment Property

[read/write] The default checkin comment.

public virtual String DefaultComment {get; set;}

Property Value

The default checkin comment.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


DefaultDescription Property

Borland StarTeam SDK for .NET

Session.DefaultDescription Property

[read] the default description for this session.

public virtual String DefaultDescription {get;}

Property Value

the default description for this session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Differences Property

Borland StarTeam SDK for .NET

Session.Differences Property

[read] An iterator over the set of differences.

public virtual ItemDifference[] Differences {get;}

Property Value

An iterator over the set of differences.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


HasDifferences Property

Borland StarTeam SDK for .NET

Session.HasDifferences Property

[read] True if there were differences detected, and false otherwise.

public virtual Boolean HasDifferences {get;}

Property Value

True if there were differences detected, and false otherwise.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


IsDirty Property

Borland StarTeam SDK for .NET

Session.IsDirty Property

[read] true if this session has been changed since it was last saved or restored, and false if it has not been changed.

public virtual Boolean IsDirty {get;}

Property Value

true if this session has been changed since it was last saved or restored, and false if it has not been changed.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


IsPostCommitRevisionLabelEnabled Property

Borland StarTeam SDK for .NET

Session.IsPostCommitRevisionLabelEnabled Property

[read/write] true if the post-commit revision label will be created, and false otherwise.

public virtual Boolean IsPostCommitRevisionLabelEnabled {get; set;}

Property Value

true if the post-commit revision label will be created, and false otherwise.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


IsPostCommitViewLabelEnabled Property

Borland StarTeam SDK for .NET

Session.IsPostCommitViewLabelEnabled Property

[read/write] true if the post-commit view label will be created, and false otherwise.

public virtual Boolean IsPostCommitViewLabelEnabled {get; set;}

Property Value

true if the post-commit view label will be created, and false otherwise.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


IsPreCommitRevisionLabelEnabled Property

Borland StarTeam SDK for .NET

Session.IsPreCommitRevisionLabelEnabled Property

[read/write] true if the pre-commit revision label will be created, and false otherwise.

public virtual Boolean IsPreCommitRevisionLabelEnabled {get; set;}

Property Value

true if the pre-commit revision label will be created, and false otherwise.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


IsPreCommitViewLabelEnabled Property

Borland StarTeam SDK for .NET

Session.IsPreCommitViewLabelEnabled Property

[read/write] true if the pre-commit view label will be created, and false otherwise.

public virtual Boolean IsPreCommitViewLabelEnabled {get; set;}

Property Value

true if the pre-commit view label will be created, and false otherwise.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


IsRollbackSession Property

Borland StarTeam SDK for .NET

Session.IsRollbackSession Property

[read] true if this is a rollback session

public virtual Boolean IsRollbackSession {get;}

Property Value

true if this is a rollback session

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


IsVerbosePreview Property

Borland StarTeam SDK for .NET

Session.IsVerbosePreview Property

[read/write] true if verbose preview mode is enabled; false if it is disabled.

public virtual Boolean IsVerbosePreview {get; set;}

Property Value

true if verbose preview mode is enabled; false if it is disabled.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


ItemTypes Property

Borland StarTeam SDK for .NET

Session.ItemTypes Property

[read] The list of types included in the view compare/merge operation.

public virtual TypeCollection ItemTypes {get;}

Property Value

The list of types included in the view compare/merge operation.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


MergePreview Property

Borland StarTeam SDK for .NET

Session.MergePreview Property

[read] A preview of the merge results for this session.

public virtual View MergePreview {get;}

Property Value

A preview of the merge results for this session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


MergeType Property

Borland StarTeam SDK for .NET

Session.MergeType Property

[read] The merge type of this session.

public virtual MergeType MergeType {get;}

Property Value

The merge type of this session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


NeedsCodeReview Property

Borland StarTeam SDK for .NET

Session.NeedsCodeReview Property

[read] true if this session needs to be code reviewed prior to commit

public virtual Boolean NeedsCodeReview {get;}

Property Value

true if this session needs to be code reviewed prior to commit

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Options Property

Borland StarTeam SDK for .NET

Session.Options Property

[read/write] Options that influence the behavior of compare or merge operations.

public virtual Options Options {get; set;}

Property Value

Options that influence the behavior of compare or merge operations.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


OriginalDefaultComment Property

Borland StarTeam SDK for .NET

Session.OriginalDefaultComment Property

[read] The default checkin comment.

public virtual String OriginalDefaultComment {get;}

Property Value

The default checkin comment.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


PostCommitRevisionLabelName Property

Borland StarTeam SDK for .NET

Session.PostCommitRevisionLabelName Property

[read/write] The name of the post-commit revision label.

public virtual String PostCommitRevisionLabelName {get; set;}

Property Value

The name of the post-commit revision label.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


PostCommitViewLabelName Property

Borland StarTeam SDK for .NET

Session.PostCommitViewLabelName Property

[read/write] The name of the post-commit view label.

public virtual String PostCommitViewLabelName {get; set;}

Property Value

The name of the post-commit view label.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


PreCommitRevisionLabelName Property

Borland StarTeam SDK for .NET

Session.PreCommitRevisionLabelName Property

[read/write] The name of the pre-commit revision label.

public virtual String PreCommitRevisionLabelName {get; set;}

Property Value

The name of the pre-commit revision label.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


PreCommitViewLabelName Property

Borland StarTeam SDK for .NET

Session.PreCommitViewLabelName Property

[read/write] The name of the pre-commit view label.

public virtual String PreCommitViewLabelName {get; set;}

Property Value

The name of the pre-commit view label.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Progress Property

Borland StarTeam SDK for .NET

Session.Progress Property

[read] A snapshot of the state of the current compare or commit operation.

public virtual Progress Progress {get;}

Property Value

A snapshot of the state of the current compare or commit operation.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


ReviewValue Property

Borland StarTeam SDK for .NET

Session.ReviewValue Property

[read] Review a pulse review or null

public virtual Review ReviewValue {get;}

Property Value

Review a pulse review or null

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


RootDirectory Property

Borland StarTeam SDK for .NET

Session.RootDirectory Property

[read] The path to the temporary folder on disk used by this session.

public virtual String RootDirectory {get;}

Property Value

The path to the temporary folder on disk used by this session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Scope Property

Borland StarTeam SDK for .NET

Session.Scope Property

[read/write] A scope specifier, indicating which source items are compared against the target in this view compare/merge session, or null for a full-scope compare of files and folders.

public virtual Scope Scope {get; set;}

Property Value

A scope specifier, indicating which source items are compared against the target in this view compare/merge session, or null for a full-scope compare of files and folders.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Server Property

Borland StarTeam SDK for .NET

Session.Server Property

[read] The Server instance from which this session was constructed.

public virtual Server Server {get;}

Property Value

The Server instance from which this session was constructed.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


ServerInfo Property

Borland StarTeam SDK for .NET

Session.ServerInfo Property

[read] ServerInfo The ServerInfo associated with this session.

public virtual ServerInfo ServerInfo {get;}

Property Value

ServerInfo The ServerInfo associated with this session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


SessionState Property

Borland StarTeam SDK for .NET

Session.SessionState Property

[read] The current state of this session.

public virtual Session.State SessionState {get;}

Property Value

The current state of this session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


SessionTypeValue Property

Borland StarTeam SDK for .NET

Session.SessionTypeValue Property

[read] the SessionType of this session, or null for a compare-only session.

public virtual ChangePackage.SessionType SessionTypeValue {get;}

Property Value

the SessionType of this session, or null for a compare-only session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


SourceViewForCompare Property

Borland StarTeam SDK for .NET

Session.SourceViewForCompare Property

[read] The version of the source view used for comparison.

public virtual View SourceViewForCompare {get;}

Property Value

The version of the source view used for comparison.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


TargetViewForCompare Property

Borland StarTeam SDK for .NET

Session.TargetViewForCompare Property

[read] The version of the target view used for comparison.

public virtual View TargetViewForCompare {get;}

Property Value

The version of the target view used for comparison.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session Methods

The methods of the Session class are listed below. For a complete list of Session class members, see the Session Members topic.

Public Static Methods

ForPromote | Overloaded. Creates a new VCM session for promoting the given view to its parent.
ForRebase | Creates a new VCM session for rebasing the given view from its parent.
ForReplay | Creates a new VCM session for replaying the given change package to a new target view.
ForRollback | Create a new VCM session for rolling back the changes associated with the revisions of files attached to this ChangePackage
GetMatchHint | Determines whether or not a match hint is available that indicates which item in the given target view should be matched to the specified source item.
Remove | Overloaded. Remove the temporary folder tree associated with the specified session file.
Resolve | Resolve a saved session file for a committed session (such as you'd find attached to a process task in the target view), to return a list of all the relevant target item revisions from the ItemDifferences that resulted in changes (i.e., everything except Ignore).
RestoreFrom Overloaded. Restores a saved session from a file. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
SetMatchHint | Saves a match hint, indicating that the given source item corresponds to the given target item, even though the two might otherwise be unrelated. Internally, the match hint is represented by a StarTeam link.

Public Instance Methods

Cancel | Cancels a compare or commit operation that is currently in progress. The {@link #compare compare} and {@link #commit commit} methods return when complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread. If a commit that is being executed as an atomic transaction is canceled before it is completed, then the transaction is rolled back. The source and target views are left in the state they were in prior to the start of the commit.
Close (inherited from ChangeSession) | Overloaded. Closes this change session, and releases the exclusive lock on the corresponding change package, if necessary.
Commit | Commits changes to the target view. Note that this method returns when the commit is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
Compare | Compares the source and target views. Note that this method returns when the compare is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.
Connect (inherited from ChangeSession) Connects a restored session to a server instance. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link Session#getServerInfo getServerInfo}. For example:
 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .
Equals (inherited from ChangeSession) | Delegate Equals() to com.starteam.ChangeSession.
GenerateDifferenceReport | Overloaded. Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.
GenerateSummary | Generates a summary session report for this session. The report is in HTML format.
GenerateUpdateReport | Generates an update report for this session. This report lists items that were added, changed or removed when the session was committed. The report is in HTML format.
GetDifferencesForMergedItem | Gets the ItemDifference that corresponds to a given merge item. The merged item may have been obtained through {@link ItemDifference#getMergedItem getMergeItem}, or it may have been obtained via the {@linkplain #getMergePreview merge preview}.
GetDifferencesForSourceItem | Gets the ItemDifference that corresponds to a given source item.
GetDifferencesForTargetItem | Gets the ItemDifference that corresponds to a given target item.
GetHashCode (inherited from ChangeSession) | Delegate GetHashCode() to com.starteam.ChangeSession.
GetSourceMatchesForTargetItems | Finds the source items that are the best matches for the given target items. The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchesForTargetItems() may be used by an application that wants to define the scope starting with a set of target items. To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
GetSourceMatchForTargetItem | Finds the source item that is the best match for the given target item. The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchForTargetItem() may be used by an application that wants to define the scope starting with a target item. To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.
GetType (inherited from Object) | Gets the Type of the current instance.
HasAlternatePathSet | Returns true if the session has an alternate path set for its merge preview
IsFullScope
IsIncluded | Overloaded.
NewCheckinEventSource
NewCheckoutEventSource
Remove | Overloaded. Removes this session and any associated temporary files on disk.
RemoveLocks (inherited from ChangeSession) | Unlocks any source or target items that were locked on behalf of this session. If the session is in a disconnected state removeLocks will inspect the XML representation of the session to identify and unlock the locked items
Restart (inherited from ChangeSession) | Restart this session The session is opened for writing, and is ready to re-run a compare in the current context of the source and target views
Save (inherited from ChangeSession) | Saves the current state of this session. The session must be in an active state. If the session was not previously saved, a new active change package is created.
SaveTo | Save this session to a file. If copyContent is false, then merged file content is stored in a session-specific temporary file on disk. This results in smaller session files, but means that they are generally useful only from the computer where they were generated. If copyContent is true, then merged file content is copied into the session file. This may result in very large session files, but allows them to be used from any computer, attached to email messages, and so on.
SetMatch | Tells the VCM engine to match a specific source item to a specific target item. This overrides the normal comparison logic. A client application can call setMatch() before calling compare() to avoid an AmbiguousMatchException.
ToString (inherited from ChangeSession) | Delegate ToString() to com.starteam.ChangeSession.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.Cancel Method

Cancels a compare or commit operation that is currently in progress.

The {@link #compare compare} and {@link #commit commit} methods return when complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.

If a commit that is being executed as an atomic transaction is canceled before it is completed, then the transaction is rolled back. The source and target views are left in the state they were in prior to the start of the commit.

public virtual void Cancel();

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | compare | commit | getProgress


Session.Commit Method

Commits changes to the target view.

Note that this method returns when the commit is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.

public virtual void Commit();

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | canCommit | getProgress | cancel


Session.Compare Method

Compares the source and target views.

Note that this method returns when the compare is complete. An application that wants to monitor progress or cancel the operation must do so from a separate thread.

public virtual void Compare();

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | getProgress | cancel


ForPromote Method

Borland StarTeam SDK for .NET

Session.ForPromote Method

Creates a new VCM session for replaying the given change package to its parent view.

Overload List

Creates a new VCM session for replaying the given change package to its parent view.

public static Session ForPromote(ChangePackage);

Creates a new VCM session for promoting the given view to its parent.

public static Session ForPromote(View);

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.ForPromote Method (ChangePackage)

Creates a new VCM session for replaying the given change package to its parent view.

public static Session ForPromote(
ChangePackage cp
);

Parameters

cp
The change package to be replayed.

Return Value

A newly constructed promote session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.ForPromote Overload List


Session.ForPromote Method (View)

Creates a new VCM session for promoting the given view to its parent.

public static Session ForPromote(
View source
);

Parameters

source
The view to be promoted.

Return Value

A newly constructed promote session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.ForPromote Overload List | PROMOTE


Session.ForRebase Method

Creates a new VCM session for rebasing the given view from its parent.

public static Session ForRebase(
View target
);

Parameters

target
The view to be rebased.

Return Value

A newly constructed rebase session.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | REBASE


Session.ForReplay Method

Creates a new VCM session for replaying the given change package to a new target view.

public static Session ForReplay(
ChangePackage cp,
View target
);

Parameters

cp
The change package to be replayed.
target
The new target view.

Return Value

A newly constructed session with the appropriate merge type.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.ForRollback Method

Create a new VCM session for rolling back the changes associated with the revisions of files attached to this ChangePackage

public static Session ForRollback(
ChangePackage cp
);

Parameters

cp
The ChangePackage to be rolled back

Return Value

a newly constructed, 'compared' session

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


GenerateDifferenceReport Method

Borland StarTeam SDK for .NET

Session.GenerateDifferenceReport Method

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

Overload List

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void GenerateDifferenceReport(FileInfo);

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void GenerateDifferenceReport(FileInfo,Boolean);

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.GenerateDifferenceReport Method (FileInfo)

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void GenerateDifferenceReport(
FileInfo reportFile
);

Parameters

reportFile
The report output file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.GenerateDifferenceReport Overload List


Session.GenerateDifferenceReport Method (FileInfo, Boolean)

Generates a difference report for this session. This report lists differences that were detected when the source and target views were compared. The report is in HTML format.

public virtual void GenerateDifferenceReport(
FileInfo reportFile,
Boolean bListItemsInMovedFolders
);

Parameters

reportFile
The report output file.
bListItemsInMovedFolders
true to list items whose parent folder has moved in either the source or target, even if the items themselves have no true differences.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.GenerateDifferenceReport Overload List


Session.GenerateSummary Method

Generates a summary session report for this session. The report is in HTML format.

public virtual void GenerateSummary(
FileInfo reportFile,
Boolean bIncludeHeading
);

Parameters

reportFile
The report output file.
bIncludeHeading
false to suppress the generation of the heading.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.GenerateUpdateReport Method

Generates an update report for this session. This report lists items that were added, changed or removed when the session was committed. The report is in HTML format.

public virtual void GenerateUpdateReport(
FileInfo reportFile
);

Parameters

reportFile
The report output file.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.GetDifferencesForMergedItem Method

Gets the ItemDifference that corresponds to a given merge item.

The merged item may have been obtained through {@link ItemDifference#getMergedItem getMergeItem}, or it may have been obtained via the {@linkplain #getMergePreview merge preview}.

public virtual ItemDifference GetDifferencesForMergedItem(
Item item
);

Parameters

item
A merged item.

Return Value

The associated ItemDifference, or null if the given item is not a recognized merged item.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | getMergedItem | getMergePreview


Session.GetDifferencesForSourceItem Method

Gets the ItemDifference that corresponds to a given source item.

public virtual ItemDifference GetDifferencesForSourceItem(
Item item
);

Parameters

item
A source item.

Return Value

The associated ItemDifference, or null if the given item is not a source item with an associated difference.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | getSourceItem


Session.GetDifferencesForTargetItem Method

Gets the ItemDifference that corresponds to a given target item.

public virtual ItemDifference GetDifferencesForTargetItem(
Item item
);

Parameters

item
A target item.

Return Value

The associated ItemDifference, or null if the given item is not a target item with an associated difference.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | getTargetItem


Session.GetMatchHint Method

Determines whether or not a match hint is available that indicates which item in the given target view should be matched to the specified source item.

public static Item GetMatchHint(
Item source,
View target
);

Parameters

source
A source item.
target
The desired target view.

Return Value

The matching item in the target view, or null if no match hint has been saved for this source item.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.GetSourceMatchesForTargetItems Method

Finds the source items that are the best matches for the given target items.

The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchesForTargetItems() may be used by an application that wants to define the scope starting with a set of target items.

To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.

public virtual ViewMemberCollection GetSourceMatchesForTargetItems(
ViewMemberCollection targetItems
);

Parameters

targetItems
Item collection

Return Value

The matching source item, or null.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.GetSourceMatchForTargetItem Method

Finds the source item that is the best match for the given target item.

The scope of the view compare/merge operation is always defined in terms of the source. getSourceMatchForTargetItem() may be used by an application that wants to define the scope starting with a target item.

To find source matches for multiple target items, use getSourceMatchesForTargetItems(), which will result in better performance.

public virtual Item GetSourceMatchForTargetItem(
Item targetItem
);

Parameters

targetItem
Item

Return Value

The matching source item, or null.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.HasAlternatePathSet Method

Returns true if the session has an alternate path set for its merge preview

public virtual bool HasAlternatePathSet();

Return Value

true if the session has an alternate path set for its merge preview

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.IsFullScope Method

public virtual bool IsFullScope(
Item.Type type
);

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


IsIncluded Method

Borland StarTeam SDK for .NET

Session.IsIncluded Method

Overload List

public virtual bool IsIncluded(Item.Type);

Determines whether or not the given item is in scope for the current view compare/merge operation.

public virtual bool IsIncluded(Item);

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.IsIncluded Method (Item#Type)

public virtual bool IsIncluded(
Item.Type type
);

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.IsIncluded Overload List


Session.IsIncluded Method (Item)

Determines whether or not the given item is in scope for the current view compare/merge operation.

public virtual bool IsIncluded(
Item item
);

Parameters

item
The item to be tested.

Return Value

true if the item is in scope; false otherwise.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.IsIncluded Overload List | setScope


Session.NewCheckinEventSource Method

public CheckinEventSource NewCheckinEventSource();

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.NewCheckoutEventSource Method

public CheckoutEventSource NewCheckoutEventSource();

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Remove Method

Borland StarTeam SDK for .NET

Session.Remove Method

Removes this session and any associated temporary files on disk.

Overload List

Removes this session and any associated temporary files on disk.

public virtual void Remove();

Remove the temporary folder tree associated with the specified session file.

public static void Remove(FileInfo);

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | remove | getRootDirectory


Session.Remove Method ()

Removes this session and any associated temporary files on disk.

public virtual void Remove();

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.Remove Overload List | remove | getRootDirectory


Session.Remove Method (FileInfo)

Remove the temporary folder tree associated with the specified session file.

public static void Remove(
FileInfo theSession
);

Parameters

theSession
A saved session file.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.Remove Overload List | remove | getRootDirectory


Session.Resolve Method

Resolve a saved session file for a committed session (such as you'd find attached to a process task in the target view), to return a list of all the relevant target item revisions from the ItemDifferences that resulted in changes (i.e., everything except Ignore).

public static ViewMemberCollection Resolve(
View target,
FileInfo file
);

Parameters

target
View the target view to resolve to
file
File the java.io.File containing the saved session

Return Value

Collection of ViewMembers resolved to the specified target View

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


RestoreFrom Method

Borland StarTeam SDK for .NET

Session.RestoreFrom Method

Restores a saved session from a file.

When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}.

For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

Overload List

Restores a saved session from a file. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public static Session RestoreFrom(FileInfo);

Restores a saved session from a file. When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}. For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public static Session RestoreFrom(FileInfo,Boolean);

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | restoreFrom | saveTo | getSessionState | connect | restart | DISCONNECTED


Session.RestoreFrom Method (FileInfo)

Restores a saved session from a file.

When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}.

For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public static Session RestoreFrom(
FileInfo file
);

Parameters

file
The session file. The file must have been previously saved using {@link #saveTo saveTo}.

Return Value

A new session in the disconnected state.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.RestoreFrom Overload List | restoreFrom | saveTo | getSessionState | connect | restart | DISCONNECTED


Session.RestoreFrom Method (FileInfo, Boolean)

Restores a saved session from a file.

When a session is first restored, it is in a disconnected state. It is not fully functional until it is connected to a server instance that references the correct repository. To determine which server is required, use {@link #getServerInfo getServerInfo}.

For example:

 Session session = Session.restoreFrom("MySession.vcmx"); Server server = new Server(session.getServerInfo()); server.logOn(user, password); session.connect(server); . . .

public static Session RestoreFrom(
FileInfo file,
Boolean willPersist
);

Parameters

file
The session file. The file must have been previously saved using {@link #saveTo saveTo}.
willPersist
True if the session will remain persisted on disk; false if it is a temporary session that will be removed. When a temporary session is closed, its working files on disk are automatically removed.

Return Value

A new session in the disconnected state.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | Session.RestoreFrom Overload List | restoreFrom | saveTo | getSessionState | connect | close | DISCONNECTED


Session.SaveTo Method

Save this session to a file.

If copyContent is false, then merged file content is stored in a session-specific temporary file on disk. This results in smaller session files, but means that they are generally useful only from the computer where they were generated.

If copyContent is true, then merged file content is copied into the session file. This may result in very large session files, but allows them to be used from any computer, attached to email messages, and so on.

public virtual void SaveTo(
FileInfo file,
Boolean copyContent
);

Parameters

file
The output file.
copyContent
True to copy merged file content into the session file; false to reference files stored on the local disk.

Exceptions

Exception Type | Condition
 | System.IO.IOException

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | restoreFrom | getRootDirectory


Session.SetMatch Method

Tells the VCM engine to match a specific source item to a specific target item. This overrides the normal comparison logic.

A client application can call setMatch() before calling compare() to avoid an AmbiguousMatchException.

public virtual void SetMatch(
Item source,
Item target
);

Parameters

source
An item from the source view.
target
The corresponding item from the target view.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace | compare


Session.SetMatchHint Method

Saves a match hint, indicating that the given source item corresponds to the given target item, even though the two might otherwise be unrelated.

Internally, the match hint is represented by a StarTeam link.

public static void SetMatchHint(
Item source,
Item target
);

Parameters

source
A source item.
target
The matching target item.

See Also

Session Class | StarTeam.ViewCompareMerge Namespace


Session.State Class

The state of the sesion. A session may be in one and only one of these states at any given time.

For a list of all members of this type, see Session.State Members.

System.Object
Session.State

public class Session.State

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

Session.State Members | StarTeam.ViewCompareMerge Namespace


Session.State Members

Session.State overview

Public Static Properties

ALL
CLOSED
COMMITTED
COMPARED
CONNECTED
DISCONNECTED

Public Instance Properties

Name [read] the name of this session state as a string.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.Session.State.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.Session.State.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.Session.State.

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


Session.State Properties

The properties of the Session.State class are listed below. For a complete list of Session.State class members, see the Session.State Members topic.

Public Static Properties

ALL
CLOSED
COMMITTED
COMPARED
CONNECTED
DISCONNECTED

Public Instance Properties

Name [read] the name of this session state as a string.

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


ALL Property

Borland StarTeam SDK for .NET

Session.State.ALL Property

public static State[] ALL {get;}

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


CLOSED Property

Borland StarTeam SDK for .NET

Session.State.CLOSED Property

public static Session.State CLOSED {get;}

Property Value

Session.close() has been called, so all intermediate results; e.g.

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


COMMITTED Property

Borland StarTeam SDK for .NET

Session.State.COMMITTED Property

public static Session.State COMMITTED {get;}

Property Value

New and restored sessions have this state if commit() was successfully called (hence cannot be called again).

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


COMPARED Property

Borland StarTeam SDK for .NET

Session.State.COMPARED Property

public static Session.State COMPARED {get;}

Property Value

New and/or restored sessions have this state if compare() successfully completed (hence cannot be called again), but commit() was never successfully called.

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


CONNECTED Property

Borland StarTeam SDK for .NET

Session.State.CONNECTED Property

public static Session.State CONNECTED {get;}

Property Value

A session has this state before compare() has been called.

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


DISCONNECTED Property

Borland StarTeam SDK for .NET

Session.State.DISCONNECTED Property

public static Session.State DISCONNECTED {get;}

Property Value

A session is in this state when it has been restored (from a serialized stream) but not yet connected.

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


Name Property

Borland StarTeam SDK for .NET

Session.State.Name Property

[read] the name of this session state as a string.

public virtual String Name {get;}

Property Value

the name of this session state as a string.

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


Session.State Methods

The methods of the Session.State class are listed below. For a complete list of Session.State class members, see the Session.State Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.Session.State.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.Session.State.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.viewcomparemerge.Session.State.

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


Session.State.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.Session.State.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.Session.State.Equals(obj).

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


Session.State.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.Session.State.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.Session.State.GetHashCode().

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


Session.State.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.Session.State.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.Session.State.ToString()

See Also

Session.State Class | StarTeam.ViewCompareMerge Namespace


StarTeamFileMergeAdapter Class

Facilitates the use of the StarTeam File Compare / Merge tool (also known as "DeltaII") to resolve a file merge condition. Used as follows:

 FileMergeAdapter tool = new StarTeamFileMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("Merge failed with exit code: " + exitCode); }
Note that StarTeam File Compare / Merge is the default file merge tool in StarTeam 9.0 and later. It replaces VisMerge.exe, which is now obsolete.

For a list of all members of this type, see StarTeamFileMergeAdapter Members.

System.Object
FileMergeAdapter
StarTeamFileMergeAdapter

public class StarTeamFileMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

StarTeamFileMergeAdapter Members | StarTeam.ViewCompareMerge Namespace


StarTeamFileMergeAdapter Members

StarTeamFileMergeAdapter overview

Public Instance Constructors

StarTeamFileMergeAdapter Constructor Constructs a VisMerge adapter for resolving a given file merge condition.

Public Instance Properties

AutoMergeLinesWithNoConflicts [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starteam.viewcomparemerge.FileMergeAdapter.

See Also

StarTeamFileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


StarTeamFileMergeAdapter Constructor

Constructs a VisMerge adapter for resolving a given file merge condition.

public StarTeamFileMergeAdapter(
ItemDifference diff
);

Parameters

diff
The ItemDifference whose file merge condition is to be resolved.

See Also

StarTeamFileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


StarTeamFileMergeAdapter Properties

The properties of the StarTeamFileMergeAdapter class are listed below. For a complete list of StarTeamFileMergeAdapter class members, see the StarTeamFileMergeAdapter Members topic.

Public Instance Properties

AutoMergeLinesWithNoConflicts [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

See Also

StarTeamFileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


AutoMergeLinesWithNoConflicts Property

Borland StarTeam SDK for .NET

StarTeamFileMergeAdapter.AutoMergeLinesWithNoConflicts Property

[read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

public virtual Boolean AutoMergeLinesWithNoConflicts {get; set;}

Property Value

true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

See Also

StarTeamFileMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


VCMFolder Class

A folder belonging to the Merge Preview It has all the characteristics of a regular StarTeam Folder, and describes the Preview State of its constituent Items and/or Sub-Folders

For a list of all members of this type, see VCMFolder Members.

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Folder
VCMFolder

public class VCMFolder : Folder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

VCMFolder Members | StarTeam.ViewCompareMerge Namespace


VCMFolder Members

VCMFolder overview

Public Instance Properties

AllLabels (inherited from ViewMember) | [read] an array of labels attached to any version of this resource. Will not return null but an empty array if no labels are attached.
AllShares (inherited from ViewMember) | [read] All shares of this view member
AlternatePathFragment (inherited from Folder) | [read/write] the alternate or overridden working path for this folder.
AttachedLabels (inherited from ViewMember) | [read] The labels attached to any version of this resource.
Attachments (inherited from ViewMember) | [read/write] an array of attachments for this ViewMember
Behavior (inherited from ViewMember) | [read/write] ViewMemberBehavior object associated with this ViewMember
Cache (inherited from ViewMember) | [read] CacheService
CachedProperties (inherited from TypedResource) | [read] PropertyCollection
CaseSensitiveFileNames (inherited from Folder) | [read] True if the names of files in this folder are case sensitive, and false otherwise.
Comment (inherited from ViewMember) | [read/write] The comment describing this revision of the item.
CreatedBy (inherited from LiveObject) | [read] The user who created this object.
CreatedTime (inherited from LiveObject) | [read] The date and time at which this object was created.
DebugString (inherited from Item) | [read] a debug string for this item
DefaultPathFragment (inherited from Folder) | [read/write] this folder's specified working path.
DeletedBy (inherited from ViewMember) | [read] The User object of the user who deleted this view member, or null.
DeletedShares (inherited from ViewMember) | [read] All deleted shares of this view member
DeletedTime (inherited from ViewMember) | [read] The time when this item was deleted, or DateTimeProperty.VALUE_NOT_SET.
Description (inherited from Folder) | [read/write] the description of this folder.
DisplayableProperties (inherited from Item) | [read] the set of displayable properties
DisplayName (inherited from TypedResource) | [read] A short string that can be used to refer to this item in an application's user interface.
DotNotation (inherited from ViewMember) | [read] The dot notation identification of this resource version.
EffectiveExcludeList (inherited from Folder) | [read] the fully resolved exclude list for this folder.
EffectiveUserVisible (inherited from Folder) | [read] false if this folder or any parent is set to be not visible
ExcludeFlagsValue (inherited from Folder) | [read/write] the exclude type being used for this folder's exclude list
ExcludeList (inherited from Folder) | [read/write] the portion of the exclude list that this folder contributes.
ExclusiveLocker (inherited from ViewMember) | [read] The User who is the exclusive locker of this resource.
ExternalID (inherited from ViewMember) | [read/write] The external ID describing this revision of the item.
ExternalURL (inherited from ViewMember) | [read/write] The external URL describing this revision of the item.
FileEOL (inherited from Folder) | [read] The end-of-line character sequence to be used for text files in this folder.
FolderHierarchy (inherited from Folder) | [read] The fully-qualified name of this folder.
HasParentFolder (inherited from Folder) | [read] true if this folder has a parent folder.
History (inherited from ViewMember) | [read] the past versions of this ViewMember.
ID (inherited from TypedResource) | [read] The unique identifier for this resource.
IsBookmarked (inherited from ViewMember) | [read] boolean
IsBranchable (inherited from ViewMember) | [read] true if this item is a type that is branchable.
IsDeleted (inherited from ViewMember) | [read] True if this view member is known to have been deleted; false otherwise.
IsDirty (inherited from TypedResource) | [read] true if any of this item's properties have been modified locally and not yet saved.
IsDirtyProperty (inherited from TypedResource) |
IsDiscarded (inherited from ViewMember) | [read] boolean true if all of the cached properties for this Item have been discarded
IsDisembodied (inherited from ViewMember) | [read] true if this is a disembodied item
IsFloating (inherited from ViewMember) | [read] true if this artifact is floating
IsFromHistory (inherited from VersionedObject) | [read] true if this is a historical resource obtained from the history.
IsNew (inherited from TypedResource) | [read] true if this resource has not yet been stored in the server.
IsPinned (inherited from ViewMember) | [read] true if this artifact is pinned
IsReadOnly (inherited from ViewMember) | [read] true if this ViewMember is read-only.
IsRootShare (inherited from ViewMember) | [read] true if this item is the root share; false otherwise.
IsUnread (inherited from ViewMember) | [read] boolean
ItemID (inherited from Item) | [read] the unique item ID for this item.
Locker (inherited from ViewMember) | [read] The User object of the exclusive locker of this item.
MergeHistory (inherited from Item) | [read] the merge points for this item
ModifiedBy (inherited from TrackedObject) | [read] The user who last modified this object.
ModifiedTime (inherited from TrackedObject) | [read] The date and time at which this object was last modified.
MyLockTypeValue (inherited from ViewMember) | [read] the lock status of the ViewMember for the currently logged in user.
MyType (inherited from TypedResource) | [read] the type of this resource.
Name (inherited from Folder) | [read/write] the name of the folder.
NewRevisionComment (inherited from Item) | [read] the empty string.
NotifiedUsers (inherited from Item) | [read] The users who are notified.
NotInViewFiles (inherited from Folder) | [read] an array of "not in view" File objects in this Folder, applying exclusions as appropriate.
ObjectID (inherited from TypedResource) | [read] The unique identifier for this resource.
ParentContainer (inherited from ViewMember) | [read] This object's parent container.
ParentFolder (inherited from Folder) |
ParentFolderHierarchy (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentFolderName (inherited from Item) | [read] the name of the item's parent folder.
ParentFolderPath (inherited from Item) | [read] the working directory path for the item's parent folder.
ParentFolderQualifiedName (inherited from Item) | [read] The fully-qualified name of this item's parent folder.
ParentRevision (inherited from ViewMember) | [read] The revision number at which this resource was branched.
Path (inherited from Folder) | [read] the local working folder path being used for this folder.
PathFragment (inherited from Folder) | [read] the path fragment to use for this folder.
PresentationID (inherited from ViewMember) | [read] the unique integer identifier for this resource.
Properties (inherited from Folder) | [read] the properties for the folder type
QualifiedName (inherited from Folder) | [read] The fully-qualified name of this folder.
RevisionNumber (inherited from VersionedObject) | [read] The revision number for this object revision.
Rights (inherited from ViewMember) | [read/write] the access control list for this item or NULL.
RootObjectID (inherited from VersionedObject) | [read] The root object ID for this resource.
Server (inherited from TypedResource) | [read] Server the Server instance for this SimpleTypedResource
Share (inherited from ViewMember) | [read] The share for this view member.
ShortComment (inherited from VersionedObject) | [read/write] the ShortComment for this artifact
StatusValue (inherited from Folder) | [read] The current status of this folder.
SubFolders (inherited from Folder) | [read] the sub-folders of this folder. Will not return null but may return an empty array if the folder has no subfolders.
UserVisible (inherited from Folder) | [read/write]
View (inherited from ViewMember) | [read] The View containing this ViewMember.
ViewMemberRevisions (inherited from ViewMember) | [read] all the revisions for the view member
ViewVersion (inherited from VersionedObject) | [read] The view version number of this item.
VMID (inherited from ViewMember) | [read] The unique identifier for this ViewMember.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CopyFolderTree (inherited from Folder) | Copies a folder tree. Does not populate any properties or copy any cached items.
CountItems (inherited from Folder)
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
DiscardItems (inherited from Folder)
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
FindSubFolder (inherited from Folder) | Find an immediate sub folder with the given name
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFilePath (inherited from Folder) | For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.
GetFolderTree (inherited from Folder)
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetItems (inherited from Folder)
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPreviewState
GetRights (inherited from Folder) | Returns the Access Control List for items of the specified type for this folder. This will return null if this folder has no access control list for the specified type. The access control list is not cached, and will be fetched from the server on demand Cached lists are accessible via the AccessRightsManager
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from Folder) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this Folder
HasPermissions (inherited from ViewMember) | Overloaded. Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsDescendantOf (inherited from Folder) | Returns true if this folder is a child of the specified ancestor
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsExcluded (inherited from Folder) | Determines if the given file name is one that will be excluded (Matches the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.
IsPopulated (inherited from Folder)
IsRefreshItemsRequired (inherited from Folder)
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
NewFolderEventSource (inherited from Folder)
NewFolderTreeEventSource (inherited from Folder)
NewFolderUpdateEventSource (inherited from Folder)
NewItemEventSource (inherited from Folder) | Overloaded.
NewItemIDEventSource (inherited from Folder) | Overloaded.
NewItemListEventSource (inherited from Folder) | Overloaded.
NewItemUpdateEventSource (inherited from Folder)
NewNotificationEventSource (inherited from Folder) | Overloaded.
Populate (inherited from Folder) | Overloaded.
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
RefreshItems (inherited from Folder)
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Folder) | Overloaded. Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights (inherited from Folder) | Modifies the Access Control List for items of the specified type for this folder. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Folder) | Overloaded. Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ShareTo (inherited from Item) | Overloaded. Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from Folder) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateFolderTree (inherited from Folder) | Calls update() on itself, and recursively calls Folder.updateFolderTree() on Folders returned from getSubFolders().
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

VCMFolder Class | StarTeam.ViewCompareMerge Namespace


VCMFolder Methods

The methods of the VCMFolder class are listed below. For a complete list of VCMFolder class members, see the VCMFolder Members topic.

Public Instance Methods

AddNotifiedUser (inherited from Item) | Adds the specified user object as one to be notified.
AddToIntegerArray (inherited from TypedResource) | Add a new array item to a property whose value is an integer array.
Copy (inherited from ViewMember) | Creates a copy of the ViewMember and all of its properties. Does not copy the type, etc. Useful to applications that want to save a snapshot of the ViewMember in a given state, for example, before calling refresh().
CopyFolderTree (inherited from Folder) | Copies a folder tree. Does not populate any properties or copy any cached items.
CountItems (inherited from Folder)
DeleteMergePoint (inherited from Item) | Deletes the specified merge point for this item.
DiscardItems (inherited from Folder)
Equals (inherited from TypedResource) | Delegate Equals() to com.starteam.TypedResource.
FindLinks (inherited from ViewMember) | Gets the links that have this view member as an endpoint.
FindSubFolder (inherited from Folder) | Find an immediate sub folder with the given name
GetBooleanValue (inherited from TypedResource) | A type-safe accessor method for returning boolean valued properties.
GetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for returning byte[] valued properties.
GetCommonAncestor (inherited from Item) | Gets the most recent common ancestor between this item and the given item. The common ancestor is taken from this item's history.
GetContentValue (inherited from TypedResource) | A type-safe accessor method for returning Content valued properties.
GetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for returning DateTime valued properties.
GetDateValue (inherited from TypedResource) | A type-safe accessor method for returning Date valued properties.
GetDisplayValue (inherited from ViewMember) | Gets the value of a property in a form suitable for display.
GetDoubleValue (inherited from TypedResource) | A type-safe accessor method for returning double valued properties.
GetEnumDisplayName (inherited from TypedResource) | A convenience method for returning the display name for a given value of an enumerated property.
GetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for returning Enumerated valued properties.
GetFilePath (inherited from Folder) | For a given file name, this method returns the concatenation of the file name and the working directory path of this folder.
GetFolderTree (inherited from Folder)
GetFromHistory (inherited from ViewMember) | Overloaded. Gets the version of this resource to which the given label is attached. Returns null if no version has the given label.
GetHashCode (inherited from TypedResource) | Delegate GetHashCode() to com.starteam.TypedResource.
GetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for returning int[] valued properties.
GetIntegerValue (inherited from TypedResource) | A type-safe accessor method for returning integer valued properties.
GetItems (inherited from Folder)
GetLinkValue (inherited from TypedResource) | A type-safe accessor method for getting LinkValued properties.
GetLongValue (inherited from TypedResource) | A type-safe accessor method for returning long valued properties.
GetPossibleValues (inherited from TypedResource) | A convenience method for returning an array of the possible values of an enumerated property.
GetPreviewState
GetRights (inherited from Folder) | Returns the Access Control List for items of the specified type for this folder. This will return null if this folder has no access control list for the specified type. The access control list is not cached, and will be fetched from the server on demand Cached lists are accessible via the AccessRightsManager
GetShare (inherited from ViewMember) | Returns the Share for this item, as of the configuration specified by the config argument, whether the item is live or deleted. Note that the Share that is returned is "disembodied", containing no information about its parent or children.
GetSharedChangePackages (inherited from Item) | Returns the set of change packages visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that ChangePackages are view members.
GetSharedTraces (inherited from Item) | Returns the set of traces visible across the specified target views across the share tree of this item, as resolved to those target views The goal is to match old style server wide link visibility rules, constrained, however, by the fact that Traces are view members. In any given view, the first call to this api will typically be expensive and slow since the Traces for that view will need to be cached in client memory. All subsequent calls will be cheap, even across other items in the same view. Each call to this api requires at most one server call, to query the share tree. Note that this implementation does require a small run-time memory penalty to be paid. namely, the cache size grows with the number of traces in a view.
GetStringValue (inherited from TypedResource) | A type-safe accessor method for returning String valued properties.
GetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for returning TimeSpan valued properties.
GetTraces (inherited from ViewMember) | Gets all traces that reference any revision of this view member either as the source or the target that are stored on the same server as this view member.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from TypedResource) | Gets the value of the specified property.
HasCachedProperties (inherited from TypedResource) | returns true if this item has at least one property cached locally either retrieved from persistent store or set up by the client
HasPermissions (inherited from Folder) | Overloaded. Returns true if desired permissions are granted for items of the specified type for this Folder
HasPermissions (inherited from ViewMember) | Overloaded. Returns true if desired permissions are granted
HasValue (inherited from TypedResource) | returns true if this property is cached locally, i.e either retrieved from persistent store or set up by the client
IsDescendantOf (inherited from Folder) | Returns true if this folder is a child of the specified ancestor
IsEqualTo (inherited from Item) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsEqualTo (inherited from ViewMember) | Overloaded. Compares two ViewMembers. They are considered equal if: They have the same Type. Types are compared by ClassID. They have the same VMID, or are both new ViewMembers. They belong to the same view. Views are compared by ID. For all properties, the property values must be equal.
IsExcluded (inherited from Folder) | Determines if the given file name is one that will be excluded (Matches the exclude list criteria) from operations in the working directory. Most StarTeam clients make use of a folder's exclude list by not allowing excluded files to be added to the repository. Nothing in the StarTeam SDK prevents any file being added to a repository it must be implemented as specific client-side logic. For example, the StarTeam GUI will not display any excluded files whose status is "Not In View" in the list control.
IsPopulated (inherited from Folder)
IsRefreshItemsRequired (inherited from Folder)
IsReverseShareRecommended (inherited from Item) | Determines whether share or reverse-share is the more appropriate operation when sharing this item to the given target folder.
LockExclusive (inherited from ViewMember) | Overloaded. Obtains an exclusive lock on this resource without attempting to break an existing lock. A server exception will be thrown if the lock cannot be obtained.
LockNonExclusive (inherited from ViewMember) | Obtains a non-exclusive lock on this resource without attempting to break an existing lock. Other StarTeam users can also acquire a non-exclusive lock on this resource. A server exception will be thrown if the lock cannot be obtained.
ModifyBookmark (inherited from ViewMember) | Modifies this item's flag for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of getFlag() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for Folder items.
ModifyReadStatus (inherited from ViewMember) | Modifies this item's read status for the logged-in user. Note that this is an "immediate" command, i.e., no update() call is required. Note also that only the currently logged-in user is affected. The result of isUnread() after this call may not be changed because its value will be based on cached information. To get the most up to date property values you should first call discard() on the item. This is not supported for File or Folder items.
MoveTo (inherited from Item) | Overloaded. Moves this item to the specified folder. This item will be removed from its current folder and added to the toFolder. However, if the new parent folder (toFolder) is floating, then the item will receive a new item id, which will be updated in place In this case too, if this item is a folder, then all it's contained items (prior to its move) will receive new item ids (after the move). Under these circumstances, the client application should refresh those contained types (in this folder) that it cares about
NewFolderEventSource (inherited from Folder)
NewFolderTreeEventSource (inherited from Folder)
NewFolderUpdateEventSource (inherited from Folder)
NewItemEventSource (inherited from Folder) | Overloaded.
NewItemIDEventSource (inherited from Folder) | Overloaded.
NewItemListEventSource (inherited from Folder) | Overloaded.
NewItemUpdateEventSource (inherited from Folder)
NewNotificationEventSource (inherited from Folder) | Overloaded.
Populate (inherited from Folder) | Overloaded.
PutLock (inherited from ViewMember)
RecordMergePoint (inherited from Item) | Records the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
RefreshItems (inherited from Folder)
Remove (inherited from ViewMember) | Overloaded. Removes this ViewMember from the view. This does not affect other shares of the view member.
RemoveFromIntegerArray (inherited from TypedResource) | Remove an array item from a property whose value is an integer array.
RemoveNotifiedUser (inherited from Item) | Removes the specified user object as one to be notified.
Resolve (inherited from Item) | Gets a full-resolved version of this item. If the item is already fully resolved, the item itself is returned. This is a potentially expensive API, possibly involving the execution of several server commands
ResolveMergePoint (inherited from Item) | Returns the merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ResolveMergePointEx (inherited from Item) | Returns the real or simulated (change) merge point used to create this revision of the item with respect to the specified source item. The source item cannot be null, must be of the same type as this item and reside in the same repository as this item.
ReverseShareTo (inherited from Folder) | Overloaded. Reverse shares this folder to a new parent folder. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ReverseShareTo (inherited from Item) | Overloaded. Transfers ownership of the root share of an item to a new view or folder, sharing a copy back to the original location. In its basic form, this is simply a move followed by a share. However, reverse share is permitted from a rolled-back view. This is supported by finding the corresponding item in the tip view configuration, and reverse sharing that one. When reverse sharing from a rolled back view, it is possible that the desired item revision in the target is not the tip revision of the item being shared. The reverse share operation compensates for this by moving the item to the target, sharing it back to the source, and then rolling back the target by creating a new revision whose user-modifiable properties (and content, if applicable) match the desired revision. Sharing replaces the original item in the source view with a new share of the same underlying object. Since this is a new item with a new item ID, it initially has no attached labels. The reverse share operation will attempt to apply the same labels to the corresponding revisions of the new item. However, the label operations may be unsuccessful (for example, because of access rights, or because a label may be frozen). Any server exceptions that occur while re-applying labels to the new share are silently ignored, and will not cause the reverse share operation to fail.
SetBooleanValue (inherited from TypedResource) | A type-safe accessor method for setting boolean valued properties.
SetBranchOnChange (inherited from ViewMember) | Sets the "Branch On Change" behavior.
SetByteArrayValue (inherited from TypedResource) | A type-safe accessor method for setting byte[] valued properties.
SetContentValue (inherited from TypedResource) | A type-safe accessor method for setting Content valued properties.
SetDateTimeValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDateValue (inherited from TypedResource) | A type-safe accessor method for setting DateTime valued properties.
SetDoubleValue (inherited from TypedResource) | A type-safe accessor method for setting double valued properties.
SetEnumeratedValue (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetEnumeratedValues (inherited from TypedResource) | A type-safe accessor method for setting Enumerated valued properties.
SetFixedConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember such that it is fixed at the given configuration. The change is saved to the repository immediately; no call to update() is required.
SetFloatingConfiguration (inherited from ViewMember) | Changes the behavior of this ViewMember to "floating". The change is saved to the repository immediately; no call to update() is required.
SetIntegerArrayValue (inherited from TypedResource) | A type-safe accessor method for setting int[] valued properties.
SetIntegerValue (inherited from TypedResource) | A type-safe accessor method for setting integer valued properties.
SetLinkValue (inherited from TypedResource) | A type-safe accessor method for setting LinkValued properties.
SetLongValue (inherited from TypedResource) | A type-safe accessor method for setting long valued properties.
SetRights (inherited from Folder) | Modifies the Access Control List for items of the specified type for this folder. If the ACL is null then the access control list for items of the specified type will be dropped.
SetStringValue (inherited from TypedResource) | A type-safe accessor method for setting String valued properties.
SetTimeSpanValue (inherited from TypedResource) | A type-safe accessor method for setting TimeSpan valued properties.
SetValue (inherited from TypedResource) | Sets the value of the property specified by property.
ShareTo (inherited from Folder) | Overloaded. Shares this folder to a new parent folder. The shared folder will still exist in its original parent folder as well as in the new one. If bThisFolderOnly is true, then this folder is shared without sharing any of its contained items. Such shares are supported by StarTeam server versions 9.0 and later. On older servers, this is simulated by first moving the contained items to a temporary folder, and moving them back after the share.
ShareTo (inherited from Item) | Overloaded. Shares this item to a new folder. The shared item will still exist in its original folder as well as in the new one. If this is a deleted item, shareTo() will create a new item with the same properties, but in the state it was in prior to being deleted. This provides a way to recover content from the recycle bin.
SmartShareTo (inherited from Item) | Shares or reverse-shares this item to the given target folder, as appropriate. The new share uses a time-based configuration, and, if branchable, is set to branch on change.
ToRESTUrl (inherited from ViewMember) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToStarTeamURL (inherited from LiveObject) | Resolves this StarTeam view member to a corresponding URL using an ID based scheme
ToString (inherited from TypedResource) | Delegate ToString() to com.starteam.TypedResource.
Unlock (inherited from ViewMember) | Removes the current user's lock from this resource. If another user has an exclusive lock on the resource this method will not remove that lock.
Update (inherited from Folder) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
Update (inherited from ViewMember) | Overloaded. Stores the underlying entity in the server. If the ViewMember is new it will be created otherwise an existing ViewMember will be modified.
UpdateFolderTree (inherited from Folder) | Calls update() on itself, and recursively calls Folder.updateFolderTree() on Folders returned from getSubFolders().
UpdateRevisionComment (inherited from ViewMember) | This method changes the stored revision comment on the specified item revision. Its effects are immediate, there is no need to call update(). The changed revision is based on the item's object ID and revision number. This method may not be called on an item not yet stored in the repository.

See Also

VCMFolder Class | StarTeam.ViewCompareMerge Namespace


VCMFolder.GetPreviewState Method

public virtual PreviewState GetPreviewState(
Item.Type type
);

See Also

VCMFolder Class | StarTeam.ViewCompareMerge Namespace


VCMFolder.PreviewState Class

The preview state represents a highest precedence summary of all contained items and sub-folders and their contents. "has conflicts" is higher than "has changes" which is higher than "has compared items" which is higher than "has no compared items". A folder, for example, may contain items (directly or via sub-folders) in each of the four states, but the current value represents the highest precedence.

For a list of all members of this type, see VCMFolder.PreviewState Members.

System.Object
VCMFolder.PreviewState

public class VCMFolder.PreviewState

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

VCMFolder.PreviewState Members | StarTeam.ViewCompareMerge Namespace


VCMFolder.PreviewState Members

VCMFolder.PreviewState overview

Public Static Properties

ALL
HAS_CHANGES
HAS_COMPARED_ITEMS
HAS_CONFLICTS
HAS_NO_COMPARED_ITEMS

Public Instance Properties

Name [read] a string representation of the preview state.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.VCMFolder.PreviewState.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.VCMFolder.PreviewState.
GetType (inherited from Object) | Gets the Type of the current instance.
ToInt | Returns an Integer representation of this preview state
ToString | Delegate ToString() to com.starteam.viewcomparemerge.VCMFolder.PreviewState.

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


VCMFolder.PreviewState Properties

The properties of the VCMFolder.PreviewState class are listed below. For a complete list of VCMFolder.PreviewState class members, see the VCMFolder.PreviewState Members topic.

Public Static Properties

ALL
HAS_CHANGES
HAS_COMPARED_ITEMS
HAS_CONFLICTS
HAS_NO_COMPARED_ITEMS

Public Instance Properties

Name [read] a string representation of the preview state.

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


ALL Property

Borland StarTeam SDK for .NET

VCMFolder.PreviewState.ALL Property

public static PreviewState[] ALL {get;}

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


HAS_CHANGES Property

Borland StarTeam SDK for .NET

VCMFolder.PreviewState.HAS_CHANGES Property

public static VCMFolder.PreviewState HAS_CHANGES {get;}

Property Value

Has Changes.

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


HAS_COMPARED_ITEMS Property

Borland StarTeam SDK for .NET

VCMFolder.PreviewState.HAS_COMPARED_ITEMS Property

public static VCMFolder.PreviewState HAS_COMPARED_ITEMS {get;}

Property Value

Has Compared Items.

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


HAS_CONFLICTS Property

Borland StarTeam SDK for .NET

VCMFolder.PreviewState.HAS_CONFLICTS Property

public static VCMFolder.PreviewState HAS_CONFLICTS {get;}

Property Value

Has Conflicts.

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


HAS_NO_COMPARED_ITEMS Property

Borland StarTeam SDK for .NET

VCMFolder.PreviewState.HAS_NO_COMPARED_ITEMS Property

public static VCMFolder.PreviewState HAS_NO_COMPARED_ITEMS {get;}

Property Value

Has No Compared Items.

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


Name Property

Borland StarTeam SDK for .NET

VCMFolder.PreviewState.Name Property

[read] a string representation of the preview state.

public virtual String Name {get;}

Property Value

a string representation of the preview state.

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


VCMFolder.PreviewState Methods

The methods of the VCMFolder.PreviewState class are listed below. For a complete list of VCMFolder.PreviewState class members, see the VCMFolder.PreviewState Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.viewcomparemerge.VCMFolder.PreviewState.
GetHashCode | Delegate GetHashCode() to com.starteam.viewcomparemerge.VCMFolder.PreviewState.
GetType (inherited from Object) | Gets the Type of the current instance.
ToInt | Returns an Integer representation of this preview state
ToString | Delegate ToString() to com.starteam.viewcomparemerge.VCMFolder.PreviewState.

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


VCMFolder.PreviewState.Equals Method

Delegate Equals() to com.starteam.viewcomparemerge.VCMFolder.PreviewState.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.viewcomparemerge.VCMFolder.PreviewState.Equals(obj).

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


VCMFolder.PreviewState.GetHashCode Method

Delegate GetHashCode() to com.starteam.viewcomparemerge.VCMFolder.PreviewState.

public override int GetHashCode();

Return Value

com.starteam.viewcomparemerge.VCMFolder.PreviewState.GetHashCode().

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


VCMFolder.PreviewState.ToInt Method

Returns an Integer representation of this preview state

public virtual int ToInt();

Return Value

int an Integer representation of this preview state

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


VCMFolder.PreviewState.ToString Method

Delegate ToString() to com.starteam.viewcomparemerge.VCMFolder.PreviewState.

public override string ToString();

Return Value

com.starteam.viewcomparemerge.VCMFolder.PreviewState.ToString()

See Also

VCMFolder.PreviewState Class | StarTeam.ViewCompareMerge Namespace


ViewCompareMergeProperty Class

A client-calculated property meaningful only in the context of view compare/merge. All view compare/merge properties derive from this class.

For a list of all members of this type, see ViewCompareMergeProperty Members.

System.Object
Property
EnumeratedProperty
ViewCompareMergeProperty
DifferenceTypeProperty
IsActionOverriddenProperty
IsCheckedProperty
MergeActionProperty
MergeStatusProperty

public class ViewCompareMergeProperty : EnumeratedProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

ViewCompareMergeProperty Members | StarTeam.ViewCompareMerge Namespace


ViewCompareMergeProperty Members

ViewCompareMergeProperty overview

Public Instance Properties

AllValues (inherited from EnumeratedProperty) | [read] an array of the possible values for the indicated property
DebugString (inherited from Property) | [read] a debug string for this property.
DefaultValue (inherited from EnumeratedProperty) | [read/write] the default EnumeratedValues
DependentProperties (inherited from Property) | [read] the properties that this property depends upon
DisplayName (inherited from Property) | [read/write] this property's display name.
DisplayNameTranslations (inherited from Property) | [read/write] a copy of the Display Name Translations
ID (inherited from Property) | [read] this property's internal ID.
IsAdvanced (inherited from Property) | [read] true if the property is considered advanced.
IsCalculated (inherited from Property) | [read] true if this property is caclulated by the server rather than stored in the db
IsClientCalculated (inherited from Property) | [read] true if the property is client calculated.
IsDescriptor (inherited from Property) | [read] true is this property is a descriptor.
IsDirty (inherited from Property) | [read] true if the property is dirty
IsDisabled (inherited from Property) | [read] true is the property is flagged as disabled.
IsEnabled (inherited from Property) | [read/write] true is the property is flagged as enabled.
IsGenericCalculated (inherited from Property) | [read] true if the property is calculated on the server by the component.
IsHeader (inherited from Property) | [read] true if this property is stored in a header field in the database
IsHierarchicalEnumeration (inherited from EnumeratedProperty) | [read] boolean true if at least one of the enumerated values has child values
IsItemProperty (inherited from Property) | [read] true if this property is an item property; false otherwise.
IsMultiSelectable (inherited from EnumeratedProperty) | [read] true if this Enumerated Property supports selecting multiple enumerations
IsNew (inherited from Property) | [read] true if the property is new
IsPrimaryDescriptor (inherited from Property) | [read] true if the property if the primary descriptor.
IsRequired (inherited from Property) | [read/write] true if a value for this property is required; valid for user-defined properties only.
IsRestricted (inherited from Property) | [read] true if this is a restricted property.
IsRevisionIndependent (inherited from Property) | [read] true if this property is revision-independent (for example, "FlagUserList", "ReadStatusUserList"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
IsServerCalculated (inherited from Property) | [read] true if the property if server calculated.
IsSortByTextValueSupported (inherited from Property) | [read] boolean
IsStatusProperty (inherited from EnumeratedProperty) | [read/write] true if this Enumerated Property supports selecting multiple enumerations
IsStored (inherited from Property) | [read] true if the property is stored in the server's database.
IsSysDefined (inherited from Property) | [read] true if the property is a built-in StarTeam property.
IsUserCustomized (inherited from Property) | [read] true if this property is a user defined property.
IsUserDefined (inherited from Property) | [read] true if the property is user defined.
IsUserModifiable (inherited from Property) | [read] true is the property is flagged as user modifiable.
IsViewSpecific (inherited from Property) | [read] true if this property is view-specific (for example, "ExclusiveLocker", "BranchOnChange"). Used only for server-calculated properties. Available only for StarTeam server versions 5.1 and later.
Name (inherited from Property) | [read] this property's internal name.
Server (inherited from Property) | [read] the Server that this property belongs to
SortedValues (inherited from EnumeratedProperty) | [read] a sorted array of all the enumerated values for this property
Type (inherited from Property) | [read] the Type object that "owns" this property.
Values (inherited from EnumeratedProperty) | [read/write] An array of the enumerated values of this property.

Public Instance Methods

Copy (inherited from Property) | Creates a copy of this property object. Useful to applications that want to save a snapshot of the Property in a given state, for example, before calling Server.refreshTypes(). The copied property will have the same parent Type as the original property. The Type object is not copied. For enumerated properties, the enumerated values are copied. For client-calculated properties, the individual property objects that are included in the list of dependent properties are not copied.
CreateValue (inherited from EnumeratedProperty) | Create a new Enumerated Value for this property. Automatically assign the next sequential enum code to this new enum and assign the context of the enumerated property to simplify usage of the SDK api's, and eliminate the overhead of the call to setValues(), which requires client tracking the state of all changes to Enumerated Values
Equals (inherited from Property) | Delegate Equals() to com.starteam.Property.
FindValue (inherited from EnumeratedProperty) | Overloaded. Finds an existing EnumeratedValue by code. Returns null if there is no such value. Returns the Enumerated Value instance associated with this EnumeratedProperty, not a copy. An application developer who wishes to modify the returned EnumeratedValue must make a copy of it first. Changing this EnumeratedValue in place has non-deterministic side effects on {@link #setValues()} and {@link #update()}
GetDisplayValue (inherited from Property) | Converts the given property value to a string suitable for display.
GetEnumDisplayName (inherited from EnumeratedProperty) | A convenience method for returning the display name for a given value of an enumerated property. This will throw an IllegalArgumentException if the code is not valid for this Property.
GetHashCode (inherited from Property) | Delegate GetHashCode() to com.starteam.Property.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEqualTo (inherited from Property) | Compares two Property objects. The parent Types are compared by ClassID. For enumerated properties, the enumerated values are compared using a deep comparison. For client-calculated properties, the two Property objects must have the same dependents. Dependent properties are compared by property ID.
IsLegalValue (inherited from Property) | Returns true if the specified object is a legal value for this property.
IsQueryRelationSupported (inherited from Property) |
NewQueryPart (inherited from EnumeratedProperty) | Overloaded.
SetDescriptor (inherited from Property) | Assign this property as a (non-primary) Descriptor Several properties on a type can be descriptors for that type This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
SetPrimaryDescriptor (inherited from Property) | Assign this property as the Primary Descriptor Only 1 property on a type can be the primary descriptor for the type If more than 1 property is assigned to be the primary descriptor, the server will throw an exception This assignment may be made for a new type that has not been saved to the server and the value is used simply to ensure the construction of the type xml
ToBooleanProperty (inherited from EnumeratedProperty) | Convert an existing EnumeratedProperty into a BooleanProperty The old EnumeratedProperty is replaced by the new BooleanProperty within the parent Type's properties collection. The new property is dirty; to save changes, you must call Property.update(). The old property is invalid and should be discarded.
ToString (inherited from Property) | Delegate ToString() to com.starteam.Property.
ToXml (inherited from Property) | Returns an xml representation of this property The xml representation is used to specify the property definition when creating custom components
Update (inherited from Property) | If this property is new or dirty, saves changes to the repository

See Also

ViewCompareMergeProperty Class | StarTeam.ViewCompareMerge Namespace


VisMergeAdapter Class

Facilitates the use of the StarTeam VisMerge tool to resolve a file merge condition. Used as follows:

 VisMergeAdapter tool = new VisMergeAdapter(diff); tool.setIgnoreWhiteSpace(true); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("VisMerge failed with exit code: " + exitCode); }
Note that VisMerge was the default file merge tool in StarTeam 8.0 and earlier.

For a list of all members of this type, see VisMergeAdapter Members.

System.Object
FileMergeAdapter
VisMergeAdapter

public class VisMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

VisMergeAdapter Members | StarTeam.ViewCompareMerge Namespace


VisMergeAdapter Members

VisMergeAdapter overview

Public Instance Constructors

VisMergeAdapter Constructor Constructs a VisMerge adapter for resolving a given file merge condition.

Public Instance Properties

AutoMergeLinesWithNoConflicts | [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.
IgnoreWhiteSpace | [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starteam.viewcomparemerge.FileMergeAdapter.

See Also

VisMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


VisMergeAdapter Constructor

Constructs a VisMerge adapter for resolving a given file merge condition.

public VisMergeAdapter(
ItemDifference diff
);

Parameters

diff
The ItemDifference whose file merge condition is to be resolved.

See Also

VisMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


VisMergeAdapter Properties

The properties of the VisMergeAdapter class are listed below. For a complete list of VisMergeAdapter class members, see the VisMergeAdapter Members topic.

Public Instance Properties

AutoMergeLinesWithNoConflicts | [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.
IgnoreWhiteSpace | [read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

See Also

VisMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


AutoMergeLinesWithNoConflicts Property

Borland StarTeam SDK for .NET

VisMergeAdapter.AutoMergeLinesWithNoConflicts Property

[read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

public virtual Boolean AutoMergeLinesWithNoConflicts {get; set;}

Property Value

true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

See Also

VisMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


IgnoreWhiteSpace Property

Borland StarTeam SDK for .NET

VisMergeAdapter.IgnoreWhiteSpace Property

[read/write] true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

public virtual Boolean IgnoreWhiteSpace {get; set;}

Property Value

true to automatically merge lines with no conflicts; false if all changes must be merged manually. Automatic merging is enabled by default.

See Also

VisMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


WorkstationDefaultMergeAdapter Class

Uses the workstation default merge tool to resolve a file merge condition. For example:

 FileMergeAdapter tool = new WorkstationDefaultMergeAdapter(diff); int exitCode = tool.merge(); if (exitCode == 0) { System.out.println("The merge was successful!"); } else { System.out.println("The merge failed with exit code: " + exitCode); }
Note that if no file merge tool is registered in starteam-client-options.xml, then StarTeam File Compare / Merge (also known as "Delta II") is used by default.

For a list of all members of this type, see WorkstationDefaultMergeAdapter Members.

System.Object
FileMergeAdapter
WorkstationDefaultMergeAdapter

public class WorkstationDefaultMergeAdapter : FileMergeAdapter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.ViewCompareMerge

Assembly: StarTeam (in StarTeam.dll)

See Also

WorkstationDefaultMergeAdapter Members | StarTeam.ViewCompareMerge Namespace


WorkstationDefaultMergeAdapter Members

WorkstationDefaultMergeAdapter overview

Public Instance Constructors

WorkstationDefaultMergeAdapter Constructor Constructs an adapter for resolving a given file merge condition.

Public Instance Methods

Equals (inherited from FileMergeAdapter) | Delegate Equals() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetHashCode (inherited from FileMergeAdapter) | Delegate GetHashCode() to com.starteam.viewcomparemerge.FileMergeAdapter.
GetType (inherited from Object) | Gets the Type of the current instance.
Merge (inherited from FileMergeAdapter) | Runs the external merge tool with parameters that are appropriate for resolving the merge condition of this adapter's ItemDifference. If the merge is successful, then the adapter applies the output merged file content to the ItemDifference, and marks the merge condition as resolved. Any temporary files created during the process are automatically removed.
ToString (inherited from FileMergeAdapter) | Delegate ToString() to com.starteam.viewcomparemerge.FileMergeAdapter.

See Also

WorkstationDefaultMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


WorkstationDefaultMergeAdapter Constructor

Constructs an adapter for resolving a given file merge condition.

public WorkstationDefaultMergeAdapter(
ItemDifference diff
);

Parameters

diff
The ItemDifference whose file merge condition is to be resolved.

See Also

WorkstationDefaultMergeAdapter Class | StarTeam.ViewCompareMerge Namespace


StarTeam.Xml

Borland StarTeam SDK for .NET

StarTeam.Xml Namespace

Namespace hierarchy

Classes

Class | Description
XMLAttribute | An XML attribute.
XMLDocument | A simple XML document object model (DOM), with methods for parsing and writing XML. If the boolean retainDOM is set to true, then the structure of the DOM is maintained, so that a subsequent call to write(...) would reproduce the input to build(...) However, if set to false, then a subsequent call to write(...) would produce an empty DOM. Note that if retainDOM is set to true, then the XMLDocument maintains two versions of the DOM in memory - an XML representation and an SDK representation This is probably acceptable for small, short lived DOMs.
XMLElement | An element in an XML document.
XMLException |
XMLParseException |


XMLAttribute Class

An XML attribute.

For a list of all members of this type, see XMLAttribute Members.

System.Object
XMLAttribute

public class XMLAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Xml

Assembly: StarTeam (in StarTeam.dll)

See Also

XMLAttribute Members | StarTeam.Xml Namespace


XMLAttribute Members

XMLAttribute overview

Public Instance Properties

Name | [read] The local name of this attribute.
Parent | [read] The parent element of this attribute.
QualifiedName | [read] The qualified name of this attribute.
Value | [read] The value of this attribute.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.xml.XMLAttribute.
GetHashCode | Delegate GetHashCode() to com.starteam.xml.XMLAttribute.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.xml.XMLAttribute.

See Also

XMLAttribute Class | StarTeam.Xml Namespace


XMLAttribute Properties

The properties of the XMLAttribute class are listed below. For a complete list of XMLAttribute class members, see the XMLAttribute Members topic.

Public Instance Properties

Name | [read] The local name of this attribute.
Parent | [read] The parent element of this attribute.
QualifiedName | [read] The qualified name of this attribute.
Value | [read] The value of this attribute.

See Also

XMLAttribute Class | StarTeam.Xml Namespace


Name Property

Borland StarTeam SDK for .NET

XMLAttribute.Name Property

[read] The local name of this attribute.

public virtual String Name {get;}

Property Value

The local name of this attribute.

See Also

XMLAttribute Class | StarTeam.Xml Namespace


Parent Property

Borland StarTeam SDK for .NET

XMLAttribute.Parent Property

[read] The parent element of this attribute.

public virtual XMLElement Parent {get;}

Property Value

The parent element of this attribute.

See Also

XMLAttribute Class | StarTeam.Xml Namespace


QualifiedName Property

Borland StarTeam SDK for .NET

XMLAttribute.QualifiedName Property

[read] The qualified name of this attribute.

public virtual String QualifiedName {get;}

Property Value

The qualified name of this attribute.

See Also

XMLAttribute Class | StarTeam.Xml Namespace


Value Property

Borland StarTeam SDK for .NET

XMLAttribute.Value Property

[read] The value of this attribute.

public virtual String Value {get;}

Property Value

The value of this attribute.

See Also

XMLAttribute Class | StarTeam.Xml Namespace


XMLAttribute Methods

The methods of the XMLAttribute class are listed below. For a complete list of XMLAttribute class members, see the XMLAttribute Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.xml.XMLAttribute.
GetHashCode | Delegate GetHashCode() to com.starteam.xml.XMLAttribute.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.xml.XMLAttribute.

See Also

XMLAttribute Class | StarTeam.Xml Namespace


XMLAttribute.Equals Method

Delegate Equals() to com.starteam.xml.XMLAttribute.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.xml.XMLAttribute.Equals(obj).

See Also

XMLAttribute Class | StarTeam.Xml Namespace


XMLAttribute.GetHashCode Method

Delegate GetHashCode() to com.starteam.xml.XMLAttribute.

public override int GetHashCode();

Return Value

com.starteam.xml.XMLAttribute.GetHashCode().

See Also

XMLAttribute Class | StarTeam.Xml Namespace


XMLAttribute.ToString Method

Delegate ToString() to com.starteam.xml.XMLAttribute.

public override string ToString();

Return Value

com.starteam.xml.XMLAttribute.ToString()

See Also

XMLAttribute Class | StarTeam.Xml Namespace


XMLDocument Class

A simple XML document object model (DOM), with methods for parsing and writing XML. If the boolean retainDOM is set to true, then the structure of the DOM is maintained, so that a subsequent call to write(...) would reproduce the input to build(...) However, if set to false, then a subsequent call to write(...) would produce an empty DOM. Note that if retainDOM is set to true, then the XMLDocument maintains two versions of the DOM in memory - an XML representation and an SDK representation This is probably acceptable for small, short lived DOMs.

For a list of all members of this type, see XMLDocument Members.

System.Object
XMLDocument

public class XMLDocument

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Xml

Assembly: StarTeam (in StarTeam.dll)

See Also

XMLDocument Members | StarTeam.Xml Namespace


XMLDocument Members

XMLDocument overview

Public Static Methods

Build Overloaded. Parses the XML document in the given source bytes.

Public Instance Properties

RootElement [read] The root element of this document.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.xml.XMLDocument.
GetHashCode | Delegate GetHashCode() to com.starteam.xml.XMLDocument.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.xml.XMLDocument.
Write | Overloaded. Writes an XML representation of this document to the given file.

See Also

XMLDocument Class | StarTeam.Xml Namespace


XMLDocument Properties

The properties of the XMLDocument class are listed below. For a complete list of XMLDocument class members, see the XMLDocument Members topic.

Public Instance Properties

RootElement [read] The root element of this document.

See Also

XMLDocument Class | StarTeam.Xml Namespace


RootElement Property

Borland StarTeam SDK for .NET

XMLDocument.RootElement Property

[read] The root element of this document.

public virtual XMLElement RootElement {get;}

Property Value

The root element of this document.

See Also

XMLDocument Class | StarTeam.Xml Namespace


XMLDocument Methods

The methods of the XMLDocument class are listed below. For a complete list of XMLDocument class members, see the XMLDocument Members topic.

Public Static Methods

Build Overloaded. Parses the XML document in the given source bytes.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.xml.XMLDocument.
GetHashCode | Delegate GetHashCode() to com.starteam.xml.XMLDocument.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Delegate ToString() to com.starteam.xml.XMLDocument.
Write | Overloaded. Writes an XML representation of this document to the given file.

See Also

XMLDocument Class | StarTeam.Xml Namespace


Build Method

Borland StarTeam SDK for .NET

XMLDocument.Build Method

Parses the XML document in the given source bytes.

Overload List

Parses the XML document in the given source bytes.

public static XMLDocument Build(Byte[],Boolean);

Parses the XML document in the given source bytes.

public static XMLDocument Build(FileInfo,Boolean);

Parses the XML document in the given source bytes.

public static XMLDocument Build(Stream,Boolean);

See Also

XMLDocument Class | StarTeam.Xml Namespace


XMLDocument.Build Method (Byte[], Boolean)

Parses the XML document in the given source bytes.

public static XMLDocument Build(
Byte[] source,
Boolean retainDOM
);

Parameters

source
An XML document.
retainDOM
True to retain the structure of the internal DOM, false to shred it

Return Value

A parsed DOM representation of the XML document.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.starteam.xml.XMLException

See Also

XMLDocument Class | StarTeam.Xml Namespace | XMLDocument.Build Overload List


XMLDocument.Build Method (FileInfo, Boolean)

Parses the XML document in the given source bytes.

public static XMLDocument Build(
FileInfo source,
Boolean retainDOM
);

Parameters

source
An XML document.
retainDOM
True to retain the structure of the internal DOM, false to shred it

Return Value

A parsed DOM representation of the XML document.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.starteam.xml.XMLException

See Also

XMLDocument Class | StarTeam.Xml Namespace | XMLDocument.Build Overload List


XMLDocument.Build Method (Stream, Boolean)

Parses the XML document in the given source bytes.

public static XMLDocument Build(
Stream source,
Boolean retainDOM
);

Parameters

source
An XML document.
retainDOM
True to retain the structure of the internal DOM, false to shred it

Return Value

A parsed DOM representation of the XML document.

Exceptions

Exception Type | Condition
 | System.IO.IOException
 | com.starteam.xml.XMLException

See Also

XMLDocument Class | StarTeam.Xml Namespace | XMLDocument.Build Overload List


XMLDocument.Equals Method

Delegate Equals() to com.starteam.xml.XMLDocument.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.xml.XMLDocument.Equals(obj).

See Also

XMLDocument Class | StarTeam.Xml Namespace


XMLDocument.GetHashCode Method

Delegate GetHashCode() to com.starteam.xml.XMLDocument.

public override int GetHashCode();

Return Value

com.starteam.xml.XMLDocument.GetHashCode().

See Also

XMLDocument Class | StarTeam.Xml Namespace


XMLDocument.ToString Method

Delegate ToString() to com.starteam.xml.XMLDocument.

public override string ToString();

Return Value

com.starteam.xml.XMLDocument.ToString()

See Also

XMLDocument Class | StarTeam.Xml Namespace


Write Method

Borland StarTeam SDK for .NET

XMLDocument.Write Method

Writes an XML representation of this document to the given file.

Overload List

Writes an XML representation of this document to the given file.

public virtual void Write(FileInfo);

Writes an XML representation of this document to the given file.

public virtual void Write(Stream);

See Also

XMLDocument Class | StarTeam.Xml Namespace


XMLDocument.Write Method (FileInfo)

Writes an XML representation of this document to the given file.

public virtual void Write(
FileInfo _out
);

Parameters

_out

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starteam.xml.XMLException

See Also

XMLDocument Class | StarTeam.Xml Namespace | XMLDocument.Write Overload List


XMLDocument.Write Method (Stream)

Writes an XML representation of this document to the given file.

public virtual void Write(
Stream _out
);

Parameters

_out

Exceptions

Exception Type | Condition
 | System.IO.FileNotFoundException
 | System.IO.IOException
 | com.starteam.xml.XMLException

See Also

XMLDocument Class | StarTeam.Xml Namespace | XMLDocument.Write Overload List


XMLElement Class

An element in an XML document.

For a list of all members of this type, see XMLElement Members.

System.Object
XMLElement

public class XMLElement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Xml

Assembly: StarTeam (in StarTeam.dll)

See Also

XMLElement Members | StarTeam.Xml Namespace


XMLElement Members

XMLElement overview

Public Instance Properties

Attributes | [read] The attributes associated with this element, or an empty array if there are none.
Children | [read] A list of all the direct child elements of this element.
Name | [read] The local name of this element.
Parent | [read] the parent of this element
QualifiedName | [read] The qualified name of this element.
Text | [read] The textual content of this element.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.xml.XMLElement.
GetAttributeValue | Gets the value of the attribute with the given name (and that does not belong to a namespace). If this element has no such attribute, then null is returned.
GetChild | Gets the first child element nested directly within this element that has the given name (and does not belong to a namespace). If this element has no such children, then null is returned.
GetChildren | Gets a list of all the child elements nested directly (that is, one level deep) within this element whose names match the given name (and that do not belong to a namespace). If this element has no such child elements, an empty list is returned.
GetHashCode | Delegate GetHashCode() to com.starteam.xml.XMLElement.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveChild | Remove a child element from this collection. Useful for applications that need to process large DOMs, but maintain a constant amount of memory This operation affects the SDK representation of the DOM alone It does not affect the underlying w3c XML Document nodes, if the DOM has been preserved. Once (at least one) element has been removed, the underlying XML representation no longer resembles the original DOM loaded from the File or Stream
ToString | Delegate ToString() to com.starteam.xml.XMLElement.

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLElement Properties

The properties of the XMLElement class are listed below. For a complete list of XMLElement class members, see the XMLElement Members topic.

Public Instance Properties

Attributes | [read] The attributes associated with this element, or an empty array if there are none.
Children | [read] A list of all the direct child elements of this element.
Name | [read] The local name of this element.
Parent | [read] the parent of this element
QualifiedName | [read] The qualified name of this element.
Text | [read] The textual content of this element.

See Also

XMLElement Class | StarTeam.Xml Namespace


Attributes Property

Borland StarTeam SDK for .NET

XMLElement.Attributes Property

[read] The attributes associated with this element, or an empty array if there are none.

public virtual XMLAttribute[] Attributes {get;}

Property Value

The attributes associated with this element, or an empty array if there are none.

See Also

XMLElement Class | StarTeam.Xml Namespace


Children Property

Borland StarTeam SDK for .NET

XMLElement.Children Property

[read] A list of all the direct child elements of this element.

public virtual XMLElement[] Children {get;}

Property Value

A list of all the direct child elements of this element.

See Also

XMLElement Class | StarTeam.Xml Namespace


Name Property

Borland StarTeam SDK for .NET

XMLElement.Name Property

[read] The local name of this element.

public virtual String Name {get;}

Property Value

The local name of this element.

See Also

XMLElement Class | StarTeam.Xml Namespace


Parent Property

Borland StarTeam SDK for .NET

XMLElement.Parent Property

[read] the parent of this element

public virtual XMLElement Parent {get;}

Property Value

the parent of this element

See Also

XMLElement Class | StarTeam.Xml Namespace


QualifiedName Property

Borland StarTeam SDK for .NET

XMLElement.QualifiedName Property

[read] The qualified name of this element.

public virtual String QualifiedName {get;}

Property Value

The qualified name of this element.

See Also

XMLElement Class | StarTeam.Xml Namespace


Text Property

Borland StarTeam SDK for .NET

XMLElement.Text Property

[read] The textual content of this element.

public virtual String Text {get;}

Property Value

The textual content of this element.

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLElement Methods

The methods of the XMLElement class are listed below. For a complete list of XMLElement class members, see the XMLElement Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.xml.XMLElement.
GetAttributeValue | Gets the value of the attribute with the given name (and that does not belong to a namespace). If this element has no such attribute, then null is returned.
GetChild | Gets the first child element nested directly within this element that has the given name (and does not belong to a namespace). If this element has no such children, then null is returned.
GetChildren | Gets a list of all the child elements nested directly (that is, one level deep) within this element whose names match the given name (and that do not belong to a namespace). If this element has no such child elements, an empty list is returned.
GetHashCode | Delegate GetHashCode() to com.starteam.xml.XMLElement.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveChild | Remove a child element from this collection. Useful for applications that need to process large DOMs, but maintain a constant amount of memory This operation affects the SDK representation of the DOM alone It does not affect the underlying w3c XML Document nodes, if the DOM has been preserved. Once (at least one) element has been removed, the underlying XML representation no longer resembles the original DOM loaded from the File or Stream
ToString | Delegate ToString() to com.starteam.xml.XMLElement.

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLElement.Equals Method

Delegate Equals() to com.starteam.xml.XMLElement.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.xml.XMLElement.Equals(obj).

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLElement.GetAttributeValue Method

Gets the value of the attribute with the given name (and that does not belong to a namespace). If this element has no such attribute, then null is returned.

public virtual string GetAttributeValue(
String name
);

Parameters

name
The attribute name.

Return Value

The value of the attribute, or null.

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLElement.GetChild Method

Gets the first child element nested directly within this element that has the given name (and does not belong to a namespace). If this element has no such children, then null is returned.

public virtual XMLElement GetChild(
String name
);

Parameters

name
the name to look for

Return Value

The first child element with the given name, or null.

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLElement.GetChildren Method

Gets a list of all the child elements nested directly (that is, one level deep) within this element whose names match the given name (and that do not belong to a namespace). If this element has no such child elements, an empty list is returned.

public virtual XMLElement[] GetChildren(
String name
);

Parameters

name
The element name.

Return Value

A list of all the direct child elements with the given name.

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLElement.GetHashCode Method

Delegate GetHashCode() to com.starteam.xml.XMLElement.

public override int GetHashCode();

Return Value

com.starteam.xml.XMLElement.GetHashCode().

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLElement.RemoveChild Method

Remove a child element from this collection. Useful for applications that need to process large DOMs, but maintain a constant amount of memory This operation affects the SDK representation of the DOM alone It does not affect the underlying w3c XML Document nodes, if the DOM has been preserved. Once (at least one) element has been removed, the underlying XML representation no longer resembles the original DOM loaded from the File or Stream

public virtual void RemoveChild(
XMLElement node
);

Parameters

node
XMLElement the child element to be removed

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLElement.ToString Method

Delegate ToString() to com.starteam.xml.XMLElement.

public override string ToString();

Return Value

com.starteam.xml.XMLElement.ToString()

See Also

XMLElement Class | StarTeam.Xml Namespace


XMLException Class

For a list of all members of this type, see XMLException Members.

System.Object
Exception
XMLException
XMLParseException

public class XMLException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Xml

Assembly: StarTeam (in StarTeam.dll)

See Also

XMLException Members | StarTeam.Xml Namespace


XMLException Members

XMLException overview

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.xml.XMLException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.xml.XMLException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.xml.XMLException.

See Also

XMLException Class | StarTeam.Xml Namespace


XMLException Properties

The properties of the XMLException class are listed below. For a complete list of XMLException class members, see the XMLException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

XMLException Class | StarTeam.Xml Namespace


Exception Property

Borland StarTeam SDK for .NET

XMLException.Exception Property

public virtual Exception Exception {get;}

See Also

XMLException Class | StarTeam.Xml Namespace | XMLException.Exception Overload List


XMLException Methods

The methods of the XMLException class are listed below. For a complete list of XMLException class members, see the XMLException Members topic.

Public Instance Methods

Equals | Delegate Equals() to com.starteam.xml.XMLException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode | Delegate GetHashCode() to com.starteam.xml.XMLException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Delegate ToString() to com.starteam.xml.XMLException.

See Also

XMLException Class | StarTeam.Xml Namespace


XMLException.Equals Method

Delegate Equals() to com.starteam.xml.XMLException.

public override bool Equals(
Object obj
);

Parameters

obj
Object to compare.

Return Value

com.starteam.xml.XMLException.Equals(obj).

See Also

XMLException Class | StarTeam.Xml Namespace


XMLException.GetHashCode Method

Delegate GetHashCode() to com.starteam.xml.XMLException.

public override int GetHashCode();

Return Value

com.starteam.xml.XMLException.GetHashCode().

See Also

XMLException Class | StarTeam.Xml Namespace


XMLException.ToString Method

Delegate ToString() to com.starteam.xml.XMLException.

public override string ToString();

Return Value

com.starteam.xml.XMLException.ToString()

See Also

XMLException Class | StarTeam.Xml Namespace


XMLParseException Class

For a list of all members of this type, see XMLParseException Members.

System.Object
Exception
XMLException
XMLParseException

public class XMLParseException : XMLException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: StarTeam.Xml

Assembly: StarTeam (in StarTeam.dll)

See Also

XMLParseException Members | StarTeam.Xml Namespace


XMLParseException Members

XMLParseException overview

Public Instance Properties

ColumnNumber |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception (inherited from XMLException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
LineNumber |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from XMLException) | Delegate Equals() to com.starteam.xml.XMLException.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from XMLException) | Delegate GetHashCode() to com.starteam.xml.XMLException.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from XMLException) | Delegate ToString() to com.starteam.xml.XMLException.

See Also

XMLParseException Class | StarTeam.Xml Namespace


XMLParseException Properties

The properties of the XMLParseException class are listed below. For a complete list of XMLParseException class members, see the XMLParseException Members topic.

Public Instance Properties

ColumnNumber |
Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Exception (inherited from XMLException) |
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
LineNumber |
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

XMLParseException Class | StarTeam.Xml Namespace


ColumnNumber Property

Borland StarTeam SDK for .NET

XMLParseException.ColumnNumber Property

public virtual Int32 ColumnNumber {get;}

See Also

XMLParseException Class | StarTeam.Xml Namespace


LineNumber Property

Borland StarTeam SDK for .NET

XMLParseException.LineNumber Property

public virtual Int32 LineNumber {get;}

See Also

XMLParseException Class | StarTeam.Xml Namespace


BooleanProperty Hierarchy

System.Object
Property
EnumeratedProperty
BooleanProperty
File.Type.IsExecutableProperty
File.Type.IsSyncInRevisionHistoryProperty
File.Type.IsSyncKnownProperty
File.Type.IsWorkingFileAvailableProperty
File.Type.IsWorkingFileExecutableProperty
KanbanBoard.Type.EnforceAgeProperty
KanbanBoard.Type.EnforceWIPProperty
KanbanBoard.Type.InTeamRoomProperty
Project.Type.ForceCheckinReasonProperty
Project.Type.IsProcessItemRequiredProperty
Project.Type.MarkUnlockedFilesReadOnlyProperty
Project.Type.MergeHistoryDuringVCMSessionProperty
Project.Type.RequireLockForCheckinProperty
Project.Type.UseKeywordsProperty
Requirement.Type.AmIResponsibleProperty
Requirement.Type.IsDisabledProperty
Story.Type.IsCarriedOverProperty
Swimlane.Type.EnabledProperty
Task.Type.BlockedProperty
Task.Type.IsMyTaskProperty
Task.Type.MilestoneProperty
Task.Type.NeedsAttentionProperty
TestRun.Type.IsBlockedProperty
Topic.Type.AmIRecipientProperty
Trace.Type.IsSuspectProperty
TreeItem.Type.IsLeafProperty
User.Type.DirectoryServiceIDProperty
User.Type.IsDirectoryManagedProperty
View.Type.IsDeleteCompleteProperty
View.Type.IsPurgedProperty
View.Type.IsVCMCodeReviewRequiredProperty
View.Type.IsVCMCommitEnforcedProperty
ViewMember.Type.IsBookmarkedProperty
ViewMember.Type.IsBranchOnChangeProperty
ViewMember.Type.IsReadOnlyProperty
ViewMember.Type.IsUnreadProperty
ViewMemberRevision.Type.BranchFlagProperty

See Also

BooleanProperty Class | BooleanProperty Members | StarTeam Namespace


ContentProperty Hierarchy

System.Object
Property
ContentProperty
Concept.Type.ContentProperty
Item.Type.DiagramSourceProperty
Test.Type.DescriptionProperty
TestRun.Type.DescriptionProperty
TreeItem.Type.RichDescriptionProperty
User.Type.UserImageProperty

See Also

ContentProperty Class | ContentProperty Members | StarTeam Namespace


DateProperty Hierarchy

System.Object
Property
ScalarProperty
DateProperty
Sprint.Type.EndDateProperty
Sprint.Type.StartDateProperty
Task.Type.ActualFinishProperty
Task.Type.ActualStartProperty
Task.Type.EstimatedFinishProperty
Task.Type.EstimatedStartProperty
WorkRecord.Type.WorkedOnProperty

See Also

DateProperty Class | DateProperty Members | StarTeam Namespace


DateTimeProperty Hierarchy

System.Object
Property
ScalarProperty
DateTimeProperty
Audit.Type.RevisionTime1Property
Audit.Type.RevisionTime2Property
Audit.Type.RevisionTime3Property
ChangePackage.Type.CommittedTimeProperty
ChangePackage.Type.ExternalCreatedTimeProperty
ChangeRequest.Type.ClosedOnProperty
ChangeRequest.Type.EnteredOnProperty
ChangeRequest.Type.ResolvedOnProperty
ChangeRequest.Type.VerifiedOnProperty
File.Type.ContentModifiedTimeProperty
File.Type.SyncModifiedTimeProperty
File.Type.WorkingFileModifiedTimeProperty
Label.Type.LabelTimeProperty
LiveObject.Type.CreatedTimeProperty
LiveObject.Type.DeletedTimeProperty
Plan.Type.EndDateProperty
Plan.Type.StartDateProperty
Project.Type.CheckinChangePackageLastUpdateProperty
Task.Type.ConstraintDateProperty
Task.Type.MSProjectLastUpdateProperty
Task.Type.WorkDependencyLastUpdateProperty
TestRun.Type.ExecutedAtProperty
TrackedObject.Type.EndModifiedTimeProperty
TrackedObject.Type.ModifiedTimeProperty
User.Type.FridayAMProperty
User.Type.FridayPMProperty
User.Type.LastLogoutTimeProperty
User.Type.LastPasswordChangeTimeProperty
User.Type.LastWebLogoutTimeProperty
User.Type.LockOutTimeProperty
User.Type.MondayAMProperty
User.Type.MondayPMProperty
User.Type.SaturdayAMProperty
User.Type.SaturdayPMProperty
User.Type.SundayAMProperty
User.Type.SundayPMProperty
User.Type.ThursdayAMProperty
User.Type.ThursdayPMProperty
User.Type.TuesdayAMProperty
User.Type.TuesdayPMProperty
User.Type.WednesdayAMProperty
User.Type.WednesdayPMProperty
View.Type.BaseConfigurationDataProperty
View.Type.CloneTimeProperty
View.Type.EndDateProperty
View.Type.StartDateProperty
View.Type.WorkspaceModifiedTimeProperty
ViewMember.Type.ConfigurationTimeProperty
ViewMember.Type.ItemDeletedTimeProperty
ViewMemberRevision.Type.CreatedTimeProperty
ViewMemberRevision.Type.ObjectTimeProperty

See Also

DateTimeProperty Class | DateTimeProperty Members | StarTeam Namespace


StarTeam.DiffHierarchy

Borland StarTeam SDK for .NET

StarTeam.Diff Hierarchy

System.Object
StarTeam.Diff.CharSequence
StarTeam.Diff.ColumnMask
StarTeam.Diff.DiffCompare
StarTeam.Diff.BasicCompare
StarTeam.Diff.StringCompare
StarTeam.Diff.Edit
StarTeam.Diff.EditListWriter
StarTeam.Diff.ConsoleWriter
StarTeam.Diff.HTMLDiffWriter
StarTeam.Diff.HTMLTableDiffWriter
StarTeam.Diff.HTMLInterleavedDiffWriter
StarTeam.Diff.HTMLStereoDiffWriter
StarTeam.Diff.IntralineSequence ---- StarTeam.Diff.Sequence
StarTeam.Diff.LineIterator
StarTeam.Diff.ParsedCharSequence ---- StarTeam.Diff.Sequence
StarTeam.Diff.Sequence
StarTeam.Diff.SharedCharSequence ---- StarTeam.Diff.CharSequence
StarTeam.Diff.StarTeamDiff
StarTeam.Diff.StarTeamMerge
StarTeam.Diff.StarTeamMerge.FileDetails
StarTeam.Diff.StringCharSequence ---- StarTeam.Diff.CharSequence
StarTeam.StarTeamCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
StarTeam.Diff.EditCollection
System.Exception ---- System.Runtime.Serialization.ISerializable
StarTeam.Diff.DiffException

See Also

StarTeam.Diff Namespace


DoubleProperty Hierarchy

System.Object
Property
ScalarProperty
DoubleProperty
Plan.Type.WeeklyCapacityProperty
Requirement.Type.OrderProperty
Requirement.Type.RankProperty
Story.Type.EstimatedPointsProperty
Story.Type.RankProperty
Story.Type.StoryOrderProperty
Task.Type.EstimatedHoursVarianceProperty
Task.Type.OrderProperty
Trace.Type.OrderProperty

See Also

DoubleProperty Class | DoubleProperty Members | StarTeam Namespace


EnumeratedProperty Hierarchy

System.Object
Property
EnumeratedProperty
Audit.Type.EventIDProperty
BooleanProperty
Change.Type.ActionProperty
Change.Type.ChangeTypeProperty
ChangePackage.Type.SessionTypeProperty
ChangePackage.Type.StateProperty
ChangeRequest.Type.ChangeRequestTypeProperty
ChangeRequest.Type.PlatformProperty
ChangeRequest.Type.PriorityProperty
ChangeRequest.Type.SeverityProperty
ChangeRequest.Type.StarFlowStatusProperty
ChangeRequest.Type.StatusProperty
ChangeRequest.Type.StreamStateProperty
File.Type.CharacterSetProperty
File.Type.CompressionProperty
File.Type.EOLFormatProperty
File.Type.KeywordFlagProperty
File.Type.StatusProperty
File.Type.StorageTypeProperty
Folder.Type.ExcludeFlagsProperty
Folder.Type.StatusProperty
Group.Type.TypeProperty
Item.Type.TagProperty
KanbanBoard.Type.InputTypeProperty
KanbanBoard.Type.ItemTypeProperty
Plan.Type.PlanTypeProperty
Project.Type.EncryptionAlgorithmProperty
Project.Type.MethodologyProperty
Project.Type.StatusProperty
Requirement.Type.AtlasWorkflowStatusProperty
Requirement.Type.PriorityProperty
Requirement.Type.RequirementTypeProperty
Requirement.Type.StatusProperty
Requirement.Type.StreamStateProperty
Requirement.Type.UDAGroupingProperty
Review.Type.ReviewTypeProperty
Review.Type.StatusProperty
Story.Type.IncomingStreamProperty
Story.Type.RiskProperty
Story.Type.StatusProperty
Story.Type.StoryTypeProperty
Story.Type.StoryValueProperty
Story.Type.StreamStateProperty
Task.Type.ConstraintProperty
Task.Type.LifeCycleTypeProperty
Task.Type.OriginProperty
Task.Type.PriorityProperty
Task.Type.ProcessUsageProperty
Task.Type.StatusProperty
Task.Type.TaskTypeProperty
TaskDependency.Type.PredecessorTypeProperty
Topic.Type.PriorityProperty
Topic.Type.StatusProperty
Topic.Type.TaxonomyProperty
Topic.Type.TopicTypeProperty
Trace.Type.StatusProperty
Trace.Type.TraceTypeProperty
TreeItem.Type.MoSCoWProperty
TypedResource.Type.BranchStateProperty
User.Type.LicenseTypeProperty
User.Type.StatusProperty
User.Type.TerritoryProperty
View.Type.TypeProperty
ViewCompareMergeProperty
ViewMember.Type.MyLockProperty
ViewMember.Type.ShareStateProperty

See Also

EnumeratedProperty Class | EnumeratedProperty Members | StarTeam Namespace


EnumeratedValue Hierarchy

System.Object
EnumeratedValue
Audit.EventID
Change.ChangeType
Change.CommitAction
ChangePackage.SessionType
ChangePackage.State
ChangeRequest.ChangeRequestType
ChangeRequest.Platform
ChangeRequest.Priority
ChangeRequest.Severity
ChangeRequest.StarFlowStatus
ChangeRequest.Status
ChangeRequest.StreamState
File.CharacterSet
File.Compression
File.EOLFormat
File.KeywordFlag
File.Status
File.StorageType
Folder.ExcludeFlags
Folder.Status
Group.GroupType
KanbanBoard.InputType
KanbanBoard.ItemType
Plan.PlanType
Project.Methodology
Project.Status
Requirement.AtlasWorkflowStatus
Requirement.Priority
Requirement.RequirementType
Requirement.Status
Requirement.StreamState
Review.ReviewType
Review.Status
Server.EncryptionAlgorithm
Story.Risk
Story.Status
Story.StoryType
Story.StoryValue
Story.StreamState
Task.Constraint
Task.LifeCycleType
Task.Origin
Task.Priority
Task.ProcessUsage
Task.Status
Task.TaskType
TaskDependency.PredecessorType
Topic.Priority
Topic.Status
Topic.TopicType
Trace.Status
Trace.TraceType
TreeItem.MoSCoW
TypedResource.BranchState
User.GeographicTerritory
User.License
User.Status
View.ViewType
ViewMember.MyLock
ViewMember.ShareState

See Also

EnumeratedValue Class | EnumeratedValue Members | StarTeam Namespace


StarTeam.EventsHierarchy

Borland StarTeam SDK for .NET

StarTeam.Events Hierarchy

System.Object
StarTeam.Events.CacheAgentEventSource
StarTeam.Events.CheckinEventSource
StarTeam.Events.CheckoutEventSource
StarTeam.Events.CommandProcessorEventSource
StarTeam.Events.FilterEventSource
StarTeam.Events.FolderEventSource
StarTeam.Events.FolderTreeEventSource
StarTeam.Events.FolderUpdateEventSource
StarTeam.Events.GroupEventSource
StarTeam.Events.ItemEventSource
StarTeam.Events.ItemIDEventSource
StarTeam.Events.ItemListEventSource
StarTeam.Events.ItemUpdateEventSource
StarTeam.Events.LabelEventSource
StarTeam.Events.LinkUpdateEventSource
StarTeam.Events.MPXMessageEventSource
StarTeam.Events.MPXStatusEventSource
StarTeam.Events.NotificationEventSource
StarTeam.Events.ProjectEventSource
StarTeam.Events.QueryEventSource
StarTeam.Events.ServerCommandEventSource
StarTeam.Events.ServerControlEventSource
StarTeam.Events.TraceEventSource
StarTeam.Events.TypedResourceEventSource
StarTeam.Events.TypeEventSource
StarTeam.Events.UserEventSource
StarTeam.Events.ViewEventSource
StarTeam.Events.ViewMemberEventSource
StarTeam.Events.ViewMemberUpdateEventSource
StarTeam.Events.WebCacheAccessRightsEventSource
StarTeam.Events.WebCacheCheckinEventSource
StarTeam.Events.WebCacheCheckoutEventSource
StarTeam.Events.WebCacheFilterEventSource
StarTeam.Events.WebCacheGroupEventSource
StarTeam.Events.WebCacheLabelEventSource
StarTeam.Events.WebCacheLiveObjectEventSource
StarTeam.Events.WebCacheMPXStatusEventSource
StarTeam.Events.WebCacheProjectEventSource
StarTeam.Events.WebCacheQueryEventSource
StarTeam.Events.WebCacheServerControlEventSource
StarTeam.Events.WebCacheTypeEventSource
StarTeam.Events.WebCacheUserEventSource
StarTeam.Events.WebCacheViewEventSource
StarTeam.Events.WebCacheViewMemberEventSource
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
StarTeam.Events.CacheAgentEventSource.Handler
StarTeam.Events.CheckinEventSource.Handler
StarTeam.Events.CheckoutEventSource.Handler
StarTeam.Events.CommandProcessorEventSource.CheckinHandler
StarTeam.Events.CommandProcessorEventSource.CheckoutHandler
StarTeam.Events.CommandProcessorEventSource.PasswordHandler
StarTeam.Events.CommandProcessorEventSource.StatusHandler
StarTeam.Events.FilterEventSource.Handler
StarTeam.Events.FolderEventSource.Handler
StarTeam.Events.FolderTreeEventSource.Handler
StarTeam.Events.FolderUpdateEventSource.Handler
StarTeam.Events.GroupEventSource.Handler
StarTeam.Events.ItemEventSource.Handler
StarTeam.Events.ItemIDEventSource.Handler
StarTeam.Events.ItemListEventSource.Handler
StarTeam.Events.ItemUpdateEventSource.Handler
StarTeam.Events.LabelEventSource.Handler
StarTeam.Events.LinkUpdateEventSource.Handler
StarTeam.Events.MPXMessageEventSource.Handler
StarTeam.Events.MPXStatusEventSource.Handler
StarTeam.Events.NotificationEventSource.Handler
StarTeam.Events.ProjectEventSource.Handler
StarTeam.Events.QueryEventSource.Handler
StarTeam.Events.ServerCommandEventSource.Handler
StarTeam.Events.ServerControlEventSource.Handler
StarTeam.Events.TraceEventSource.Handler
StarTeam.Events.TypedResourceEventSource.Handler
StarTeam.Events.TypeEventSource.Handler
StarTeam.Events.UserEventSource.Handler
StarTeam.Events.ViewEventSource.Handler
StarTeam.Events.ViewMemberEventSource.Handler
StarTeam.Events.ViewMemberUpdateEventSource.Handler
StarTeam.Events.WebCacheAccessRightsEventSource.Handler
StarTeam.Events.WebCacheCheckinEventSource.Handler
StarTeam.Events.WebCacheCheckoutEventSource.Handler
StarTeam.Events.WebCacheFilterEventSource.Handler
StarTeam.Events.WebCacheGroupEventSource.Handler
StarTeam.Events.WebCacheLabelEventSource.Handler
StarTeam.Events.WebCacheLiveObjectEventSource.Handler
StarTeam.Events.WebCacheMPXStatusEventSource.Handler
StarTeam.Events.WebCacheProjectEventSource.Handler
StarTeam.Events.WebCacheQueryEventSource.Handler
StarTeam.Events.WebCacheServerControlEventSource.Handler
StarTeam.Events.WebCacheTypeEventSource.Handler
StarTeam.Events.WebCacheUserEventSource.Handler
StarTeam.Events.WebCacheViewEventSource.Handler
StarTeam.Events.WebCacheViewMemberEventSource.Handler
System.EventArgs
StarTeam.Events.CacheAgentEventArgs
StarTeam.Events.CheckinEventArgs
StarTeam.Events.CheckoutEventArgs
StarTeam.Events.CommandProcessorCheckinEventArgs
StarTeam.Events.CommandProcessorCheckoutEventArgs
StarTeam.Events.CommandProcessorPasswordEventArgs
StarTeam.Events.CommandProcessorStatusEventArgs
StarTeam.Events.FilterEventArgs
StarTeam.Events.FolderEventArgs
StarTeam.Events.FolderTreeEventArgs
StarTeam.Events.FolderUpdateEventArgs
StarTeam.Events.GroupEventArgs
StarTeam.Events.ItemEventArgs
StarTeam.Events.ItemIDEventArgs
StarTeam.Events.ItemListEventArgs
StarTeam.Events.ItemUpdateEventArgs
StarTeam.Events.LabelEventArgs
StarTeam.Events.LinkUpdateEventArgs
StarTeam.Events.MPXMessageEventArgs
StarTeam.Events.MPXStatusEventArgs
StarTeam.Events.NotificationEventArgs
StarTeam.Events.ProjectEventArgs
StarTeam.Events.QueryEventArgs
StarTeam.Events.ServerCommandEventArgs
StarTeam.Events.ServerControlEventArgs
StarTeam.Events.TraceEventArgs
StarTeam.Events.TypedResourceEventArgs
StarTeam.Events.TypeEventArgs
StarTeam.Events.UserEventArgs
StarTeam.Events.ViewEventArgs
StarTeam.Events.ViewMemberEventArgs
StarTeam.Events.ViewMemberUpdateEventArgs
StarTeam.Events.WebCacheAccessRightsEventArgs
StarTeam.Events.WebCacheCheckinEventArgs
StarTeam.Events.WebCacheCheckoutEventArgs
StarTeam.Events.WebCacheFilterEventArgs
StarTeam.Events.WebCacheGroupEventArgs
StarTeam.Events.WebCacheLabelEventArgs
StarTeam.Events.WebCacheLiveObjectEventArgs
StarTeam.Events.WebCacheMPXStatusEventArgs
StarTeam.Events.WebCacheProjectEventArgs
StarTeam.Events.WebCacheQueryEventArgs
StarTeam.Events.WebCacheServerControlEventArgs
StarTeam.Events.WebCacheTypeEventArgs
StarTeam.Events.WebCacheUserEventArgs
StarTeam.Events.WebCacheViewEventArgs
StarTeam.Events.WebCacheViewMemberEventArgs

See Also

StarTeam.Events Namespace


StarTeam.ExceptionsHierarchy

Borland StarTeam SDK for .NET

StarTeam.Exceptions Hierarchy

System.Object
StarTeam.Exceptions.MPXException.ErrorCode
System.Exception ---- System.Runtime.Serialization.ISerializable
StarTeam.Exceptions.CommandException
StarTeam.Exceptions.ConnectionException
StarTeam.Exceptions.DisembodiedException
StarTeam.Exceptions.DuplicateServerListEntryException
StarTeam.Exceptions.FileMergeException
StarTeam.Exceptions.ItemRevisionNotFoundException
StarTeam.Exceptions.MPXException
StarTeam.Exceptions.NoSuchPropertyException
StarTeam.Exceptions.PropertyMergeException
StarTeam.Exceptions.PropertyNotWritableException
StarTeam.Exceptions.SDKRuntimeException
StarTeam.Exceptions.ServerException
StarTeam.Exceptions.CommandAbortedException
StarTeam.Exceptions.ItemNotFoundException
StarTeam.Exceptions.LockingException
StarTeam.Exceptions.LogonException
StarTeam.Exceptions.PasswordExpiredException
StarTeam.Exceptions.ServerUnavailableException
StarTeam.Exceptions.TypeNotFoundException
StarTeam.Exceptions.WorkStationException

See Also

StarTeam.Exceptions Namespace


IntegerProperty Hierarchy

System.Object
Property
ScalarProperty
IntegerProperty
Audit.Type.ClassID1Property
Audit.Type.ClassID2Property
Audit.Type.ClassID3Property
Audit.Type.FolderIDProperty
Audit.Type.ObjectID1Property
Audit.Type.ObjectID2Property
Audit.Type.ObjectID3Property
Change.Type.FlagsProperty
ChangePackage.Type.FullScopeProperty
ChangeRequest.Type.ChangeNumberProperty
Concept.Type.ConceptIDProperty
File.Type.ContentVersionProperty
File.Type.HiveProperty
File.Type.SyncBranchVersionProperty
File.Type.SyncContentVersionProperty
File.Type.SyncViewVersionProperty
File.Type.VaultVersionProperty
File.Type.ViewVersionProperty
Group.Type.PrivilegeMaskProperty
Group.Type.TenantProperty
Item.Type.NotificationCountProperty
KanbanBoard.Type.InputIDProperty
Label.Type.MemberIDProperty
LiveObject.Type.FlagsProperty
Plan.Type.PlanIDProperty
Project.Type.CanCreateCheckinChangePackageProperty
Project.Type.CompactionProperty
Project.Type.MailProperty
Project.Type.TenantProperty
PromotionModel.Type.NumberOfStatesProperty
Requirement.Type.AmbiguitiesCountProperty
Requirement.Type.ChildrenCountProperty
Requirement.Type.ChildTypeProperty
Requirement.Type.ExpectedEffortProperty
Requirement.Type.ExplicitRankProperty
Requirement.Type.HighEffortProperty
Requirement.Type.LowEffortProperty
Requirement.Type.ParentRequirementIDProperty
Requirement.Type.RequirementNumberProperty
Requirement.Type.ResponsibleCountProperty
Review.Type.ReviewIDProperty
Share.Type.FolderIDProperty
Share.Type.ItemIDProperty
Share.Type.NumberOfDerivedSharesProperty
Share.Type.ObjectIDProperty
Sprint.Type.SprintIDProperty
Story.Type.StoryIDProperty
Swimlane.Type.ScheduleStatusProperty
Swimlane.Type.WorkInProgressProperty
Task.Type.ChildrenCountProperty
Task.Type.EstimatedFinishVarianceProperty
Task.Type.EstimatedStartVarianceProperty
Task.Type.IsReplicatedProperty
Task.Type.NumberProperty
Task.Type.ParentTaskIDProperty
Task.Type.PercentCompleteProperty
Task.Type.ResourceCountProperty
Task.Type.UniqueIDProperty
Task.Type.WorkRecordCountProperty
TaskDependency.Type.LagTimeProperty
TaskDependency.Type.PredecessorProperty
TaskDependency.Type.TaskProperty
Test.Type.TestIDProperty
TestRun.Type.TestRunIDProperty
Topic.Type.ChildrenCountProperty
Topic.Type.ParentTopicIDProperty
Topic.Type.RecipientCountProperty
Topic.Type.TopicNumberProperty
TrackedObject.Type.TransactionIDProperty
TreeItem.Type.ParentIDProperty
TypedResource.Type.IDProperty
User.Type.AccessRestrictionProperty
User.Type.LicenseProperty
User.Type.TenantProperty
VersionedObject.Type.CommentIDProperty
VersionedObject.Type.RevisionFlagsProperty
VersionedObject.Type.RevisionNumberProperty
View.Type.BaseConfigurationTypeProperty
View.Type.RootFolderIDProperty
View.Type.ShareFlagsProperty
View.Type.TenantProperty
ViewMember.Type.AttachmentCountProperty
ViewMember.Type.ParentBranchLengthProperty
ViewMember.Type.ParentBranchRevisionProperty
ViewMember.Type.ParentObjectIDProperty
ViewMember.Type.RootObjectIDProperty
ViewMember.Type.ViewMemberIDProperty
ViewMemberRevision.Type.ObjectIDProperty
ViewMemberRevision.Type.ParentFolderProperty
ViewMemberRevision.Type.ParentShareProperty
WhiteBoard.Type.WhiteBoardIDProperty
WorkRecord.Type.ParentTaskProperty

See Also

IntegerProperty Class | IntegerProperty Members | StarTeam Namespace


Item.Type.PropertyCollection Hierarchy

System.Object
StarTeamCollection
PropertyCollection
ViewMember.Type.PropertyCollection
Item.Type.PropertyCollection
ChangeRequest.Type.PropertyCollection
Concept.Type.PropertyCollection
File.Type.PropertyCollection
Folder.Type.PropertyCollection
KanbanBoard.Type.PropertyCollection
Plan.Type.PropertyCollection
Requirement.Type.PropertyCollection
Review.Type.PropertyCollection
Sprint.Type.PropertyCollection
Story.Type.PropertyCollection
Swimlane.Type.PropertyCollection
Task.Type.PropertyCollection
Test.Type.PropertyCollection
TestRun.Type.PropertyCollection
Topic.Type.PropertyCollection
WhiteBoard.Type.PropertyCollection

See Also

Item.Type.PropertyCollection Class | Item.Type.PropertyCollection Members | StarTeam Namespace


Item.Type Hierarchy

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
TrackedObject.Type
VersionedObject.Type
ViewMember.Type
Item.Type
Audit.Type
ChangeRequest.Type
Concept.Type
File.Type
Folder.Type
KanbanBoard.Type
Plan.Type
Review.Type
Sprint.Type
Swimlane.Type
TestRun.Type
TreeItem.Type
WhiteBoard.Type

See Also

Item.Type Class | Item.Type Members | StarTeam Namespace


Item.WebCacheItem Hierarchy

System.Object
LiveObject.WebCacheLiveObject
TrackedObject.WebCacheTrackedObject
VersionedObject.WebCacheVersionedObject
ViewMember.WebCacheViewMember
Item.WebCacheItem
ChangeRequest.WebCacheChangeRequest
Concept.WebCacheConcept
File.WebCacheFile
Folder.WebCacheFolder
KanbanBoard.WebCacheKanbanBoard
Plan.WebCachePlan
Review.WebCacheReview
Sprint.WebCacheSprint
Swimlane.WebCacheSwimlane
TestRun.WebCacheTestRun
TreeItem.WebCacheTreeItem
WhiteBoard.WebCacheWhiteBoard

See Also

Item.WebCacheItem Class | Item.WebCacheItem Members | StarTeam Namespace


Item Hierarchy

System.Object
TypedResource
LiveObject
TrackedObject
VersionedObject
ViewMember
Item
Audit
ChangeRequest
Concept
File
Folder
KanbanBoard
Plan
Review
Sprint
Swimlane
TestRun
TreeItem
WhiteBoard

See Also

Item Class | Item Members | StarTeam Namespace


LiveObject.Type Hierarchy

System.Object
NamedCacheRef
Type
TypedResource.Type
LiveObject.Type
Change.Type
Project.Type
PromotionModel.Type
PromotionState.Type
TrackedObject.Type
View.Type

See Also

LiveObject.Type Class | LiveObject.Type Members | StarTeam Namespace


LiveObject.WebCacheLiveObject Hierarchy

System.Object
LiveObject.WebCacheLiveObject
Change.WebCacheChange
Project.WebCacheProject
PromotionModel.WebCachePromotionModel
PromotionState.WebCachePromotionState
TrackedObject.WebCacheTrackedObject
View.WebCacheView

See Also

LiveObject.WebCacheLiveObject Class | LiveObject.WebCacheLiveObject Members | StarTeam Namespace


LiveObject Hierarchy

System.Object
TypedResource
LiveObject
Change
Project
PromotionModel
PromotionState
TrackedObject
View

See Also

LiveObject Class | LiveObject Members | StarTeam Namespace


ObjectArrayProperty Hierarchy

System.Object
Property
VectorProperty
ObjectArrayProperty
Item.Type.NotificationIDsProperty
Project.Type.DefaultTypesProperty
PromotionModel.Type.PromotionStatesProperty
Requirement.Type.ResponsibleUsersProperty
Requirement.Type.ReviewedByProperty
Review.Type.AcceptorsProperty
Review.Type.AuthorsProperty
Review.Type.RejectorsProperty
Review.Type.ReviewersProperty
Review.Type.WatchersProperty
Sprint.Type.TargetReleasesProperty
Story.Type.TargetReleasesProperty
Task.Type.ResourcesProperty
Topic.Type.RecipientsProperty
Topic.Type.UserDislikesProperty
Topic.Type.UserLikesProperty
User.Type.FavoriteProjectsProperty
View.Type.ExcludedGroupsProperty
View.Type.ExcludedUsersProperty
ViewMember.Type.AttachmentIDsProperty
ViewMember.Type.FlaggedByUsersProperty
ViewMember.Type.UnreadByUsersProperty

See Also

ObjectArrayProperty Class | ObjectArrayProperty Members | StarTeam Namespace


ObjectProperty Hierarchy

System.Object
Property
ObjectProperty
Audit.Type.UserProperty
Change.Type.ChangePackageProperty
ChangePackage.Type.CommittedByProperty
ChangePackage.Type.CommittedInBuildProperty
ChangePackage.Type.PostCommitRevisionLabelProperty
ChangePackage.Type.PostCommitViewLabelProperty
ChangePackage.Type.PreCommitRevisionLabelProperty
ChangePackage.Type.PreCommitViewLabelProperty
ChangePackage.Type.SourceViewProperty
ChangePackage.Type.TargetViewProperty
ChangeRequest.Type.AddressedByProperty
ChangeRequest.Type.AddressedInProperty
ChangeRequest.Type.AddressedInViewProperty
ChangeRequest.Type.EnteredByProperty
ChangeRequest.Type.LastBuildTestedProperty
Folder.Type.ProjectProperty
Group.Type.ParentProperty
LiveObject.Type.CreatedByProperty
LiveObject.Type.DeletedByProperty
Project.Type.DefaultViewProperty
PromotionState.Type.LabelProperty
Requirement.Type.OwnerProperty
Requirement.Type.PlanProperty
Share.Type.ProjectProperty
Share.Type.ViewProperty
Sprint.Type.OwnerProperty
Sprint.Type.PlanProperty
Story.Type.PlanProperty
Story.Type.SponsorProperty
Story.Type.SprintProperty
Task.Type.ResponsibilityProperty
Task.Type.StoryProperty
TrackedObject.Type.ModifiedByProperty
TypedResource.Type.ProjectProperty
TypedResource.Type.ViewProperty
View.Type.ParentViewProperty
View.Type.PromotionStateProperty
View.Type.ResolvedViewProperty
ViewMember.Type.ExclusiveLockerProperty
ViewMember.Type.ItemDeletedByProperty
ViewMember.Type.ResponsibilityProperty
ViewMemberRevision.Type.CreatedByProperty
WorkRecord.Type.PerformedByProperty

See Also

ObjectProperty Class | ObjectProperty Members | StarTeam Namespace


Property.WebCacheProperty Hierarchy

System.Object
Property.WebCacheProperty
BooleanProperty.WebCacheBooleanProperty
ContentProperty.WebCacheContentProperty
EnumeratedProperty.WebCacheEnumeratedProperty
LinkProperty.WebCacheLinkProperty
ObjectProperty.WebCacheObjectProperty
ScalarProperty.WebCacheScalarProperty
VectorProperty.WebCacheVectorProperty

See Also

Property.WebCacheProperty Class | Property.WebCacheProperty Members | StarTeam Namespace


PropertyCollection Hierarchy

System.Object
StarTeamCollection
PropertyCollection
Audit.Type.PropertyCollection
Change.Type.PropertyCollection
Group.Type.PropertyCollection
Label.Type.PropertyCollection
Project.Type.PropertyCollection
PromotionModel.Type.PropertyCollection
PromotionState.Type.PropertyCollection
Share.Type.PropertyCollection
TaskDependency.Type.PropertyCollection
User.Type.PropertyCollection
View.Type.PropertyCollection
ViewMember.Type.PropertyCollection
ViewMemberRevision.Type.PropertyCollection
WorkRecord.Type.PropertyCollection

See Also

PropertyCollection Class | PropertyCollection Members | StarTeam Namespace


Property Hierarchy

System.Object
Property
ContentProperty
EnumeratedProperty
LinkProperty
ObjectProperty
ScalarProperty
VectorProperty

See Also

Property Class | Property Members | StarTeam Namespace


ScalarProperty.WebCacheScalarProperty Hierarchy

System.Object
Property.WebCacheProperty
ScalarProperty.WebCacheScalarProperty
DateProperty.WebCacheDateProperty
DateTimeProperty.WebCacheDateTimeProperty
DoubleProperty.WebCacheDoubleProperty
IntegerProperty.WebCacheIntegerProperty
LongIntegerProperty.WebCacheLongIntegerProperty
TimeSpanProperty.WebCacheTimeSpanProperty

See Also

ScalarProperty.WebCacheScalarProperty Class | ScalarProperty.WebCacheScalarProperty Members | StarTeam Namespace


ScalarProperty Hierarchy

System.Object
Property
ScalarProperty
DateProperty
DateTimeProperty
DoubleProperty
IntegerProperty
LongIntegerProperty
TimeSpanProperty

See Also

ScalarProperty Class | ScalarProperty Members | StarTeam Namespace


StarTeamCollection Hierarchy

System.Object
StarTeamCollection
ChangeCollection
EditCollection
PermissionCollection
PropertyCollection
ServerInfoCollection
TypeCollection
ViewMemberCollection

See Also

StarTeamCollection Class | StarTeamCollection Members | StarTeam Namespace


TextProperty Hierarchy

System.Object
Property
VectorProperty
TextProperty
Audit.Type.ClassName1Property
Audit.Type.ClassName2Property
Audit.Type.ClassName3Property
Audit.Type.Descriptor1Property
Audit.Type.Descriptor2Property
Audit.Type.Descriptor3Property
Audit.Type.Info1Property
Audit.Type.Info2Property
Audit.Type.Info3Property
Change.Type.ItemTypeProperty
Change.Type.SourceVersionProperty
Change.Type.TargetVersionProperty
ChangePackage.Type.ExternalBranchURLProperty
ChangePackage.Type.ExternalCreatedByProperty
ChangePackage.Type.ExternalRepositoryURIProperty
ChangeRequest.Type.CategoryProperty
ChangeRequest.Type.ComponentProperty
ChangeRequest.Type.FixProperty
ChangeRequest.Type.SynopsisProperty
ChangeRequest.Type.TestCommandProperty
ChangeRequest.Type.WorkAroundProperty
File.Type.ArchiveNameProperty
File.Type.ExtensionProperty
File.Type.NotificationUsersProperty
File.Type.SymbolicLinkTargetProperty
File.Type.WorkingFileNameProperty
File.Type.WorkingFilePathProperty
File.Type.WorkingFolderPathProperty
Folder.Type.ExcludeSpecProperty
Folder.Type.WorkingFolderPathProperty
Group.Type.DescriptionProperty
Group.Type.NameProperty
Item.Type.ExternalReferenceProperty
Item.Type.FolderProperty
Item.Type.NewRevisionCommentProperty
Item.Type.TeamProperty
Item.Type.VersionMetadataIDsProperty
Item.Type.VersionMetadataProperty
KanbanBoard.Type.InboxLaneProperty
LiveObject.Type.DescriptionProperty
LiveObject.Type.NameProperty
LiveObject.Type.WorkingFolderProperty
Project.Type.GUIDProperty
Project.Type.KeywordFileExtensionsProperty
Requirement.Type.CommentsProperty
Requirement.Type.NotesProperty
Requirement.Type.ResponsibleNamesProperty
Requirement.Type.RevisedDescriptionProperty
Review.Type.PulseLabelProperty
Share.Type.ItemRevisionProperty
Share.Type.ProjectNameProperty
Share.Type.ViewPathProperty
Story.Type.AcceptanceCriteriaProperty
Story.Type.GeneralProperty
Story.Type.NotesProperty
Swimlane.Type.ColorProperty
Task.Type.AttentionNotesProperty
Task.Type.DescriptionProperty
Task.Type.GUIDProperty
Task.Type.MSProjectFileNameProperty
Task.Type.NameProperty
Task.Type.NotesProperty
Task.Type.ResourceNamesProperty
Task.Type.WBSCodeProperty
Test.Type.PathProperty
TestRun.Type.BuildProperty
TestRun.Type.ExecutedByProperty
TestRun.Type.ProductProperty
TestRun.Type.StatusProperty
TestRun.Type.StatusReasonProperty
TestRun.Type.TestNameProperty
TestRun.Type.TestVersionProperty
Topic.Type.ContextRangeProperty
Topic.Type.RecipientNamesProperty
Topic.Type.TitleProperty
Trace.Type.SourceVersionsProperty
TrackedObject.Type.FolderPathProperty
TrackedObject.Type.ParentFolderNameProperty
TreeItem.Type.ExternalTestIDProperty
TreeItem.Type.ExternalTestProjectURLProperty
TreeItem.Type.ExternalTestURLProperty
User.Type.AddressProperty
User.Type.DistinguishedNameProperty
User.Type.EmailAddressProperty
User.Type.FaxProperty
User.Type.LoginNameProperty
User.Type.NameProperty
User.Type.PagerProperty
User.Type.PhoneProperty
User.Type.ReturnEmailAddressProperty
User.Type.VoiceMailProperty
VersionedObject.Type.ShortCommentProperty
ViewMember.Type.AttachmentNamesProperty
ViewMember.Type.CommentProperty
ViewMember.Type.DotNotationProperty
ViewMember.Type.ExternalIDProperty
ViewMember.Type.ExternalURLProperty
ViewMember.Type.NonExclusiveLockersProperty
WhiteBoard.Type.ColorProperty
WorkRecord.Type.CommentProperty

See Also

TextProperty Class | TextProperty Members | StarTeam Namespace


TimeSpanProperty Hierarchy

System.Object
Property
ScalarProperty
TimeSpanProperty
Swimlane.Type.AgeLimitProperty
Task.Type.ActualHoursProperty
Task.Type.DurationProperty
Task.Type.EstimatedHoursProperty
TestRun.Type.DurationProperty
User.Type.TimeZoneShiftProperty
WorkRecord.Type.TimeRemainingProperty
WorkRecord.Type.TimeWorkedProperty

See Also

TimeSpanProperty Class | TimeSpanProperty Members | StarTeam Namespace


TrackedObject Hierarchy

System.Object
TypedResource
LiveObject
TrackedObject
Label
Principal
Share
TaskDependency
VersionedObject
WorkRecord

See Also

TrackedObject Class | TrackedObject Members | StarTeam Namespace


StarTeam.UtilHierarchy

Borland StarTeam SDK for .NET

StarTeam.Util Hierarchy

System.Object
StarTeam.Util.Base64
StarTeam.Util.Date
StarTeam.Util.DotNotation
StarTeam.Util.Encoding
StarTeam.Util.FileAccess
StarTeam.Util.FileAccess.Attributes
StarTeam.Util.FileUtils
StarTeam.Util.GUID
StarTeam.Util.ISO8601
StarTeam.Util.LineProcessor
StarTeam.Util.EOLReader
StarTeam.Util.LineReader
StarTeam.Util.LogManager
StarTeam.Util.LogManager.LogFactory
StarTeam.Util.LogManager.Logger
StarTeam.Util.MD5
StarTeam.Util.MD5.Stream
StarTeam.Util.Platform
StarTeam.Util.Platform.EOL
StarTeam.Util.Platform.WorkStationOptions
StarTeam.Util.ReadWriteLock
StarTeam.Util.Registry
StarTeam.Util.UTF8
StarTeam.Util.XMLUtils

See Also

StarTeam.Util Namespace


Scope Hierarchy

System.Object
Scope
AnyScope
EveryScope
FolderScope
ItemListScope
ItemTypeScope
ProcessItemScope
RevisionLabelScope

See Also

Scope Class | Scope Members | StarTeam.ViewCompareMerge Namespace


StarTeam.ViewCompareMergeHierarchy

Borland StarTeam SDK for .NET

StarTeam.ViewCompareMerge Hierarchy

System.Object
StarTeam.ChangeSession
StarTeam.ViewCompareMerge.Session
StarTeam.Property
StarTeam.EnumeratedProperty
StarTeam.ViewCompareMerge.ViewCompareMergeProperty
StarTeam.ViewCompareMerge.DifferenceTypeProperty
StarTeam.ViewCompareMerge.IsActionOverriddenProperty
StarTeam.ViewCompareMerge.IsCheckedProperty
StarTeam.ViewCompareMerge.MergeActionProperty
StarTeam.ViewCompareMerge.DefaultActionProperty
StarTeam.ViewCompareMerge.MergeStatusProperty
StarTeam.TypedResource
StarTeam.LiveObject
StarTeam.TrackedObject
StarTeam.VersionedObject
StarTeam.ViewMember ---- StarTeam.ISecurable, StarTeam.Lockable, StarTeam.LockableObject
StarTeam.Item
StarTeam.Folder ---- StarTeam.ISecurableContainer
StarTeam.ViewCompareMerge.VCMFolder
StarTeam.View ---- StarTeam.ISecurable, StarTeam.ISecurableContainer
StarTeam.ViewCompareMerge.MergePreview
StarTeam.ViewCompareMerge.ActionOverride
StarTeam.ViewCompareMerge.ChangePackageScope
StarTeam.ViewCompareMerge.DifferenceType
StarTeam.ViewCompareMerge.FileMergeAdapter
StarTeam.ViewCompareMerge.CustomThreeWayMergeAdapter
StarTeam.ViewCompareMerge.StarTeamFileMergeAdapter
StarTeam.ViewCompareMerge.VisMergeAdapter
StarTeam.ViewCompareMerge.WorkstationDefaultMergeAdapter
StarTeam.ViewCompareMerge.ItemDifference
StarTeam.ViewCompareMerge.MatchState
StarTeam.ViewCompareMerge.MergeAction
StarTeam.ViewCompareMerge.MergeType
StarTeam.ViewCompareMerge.Options
StarTeam.ViewCompareMerge.Progress
StarTeam.ViewCompareMerge.Scope
StarTeam.ViewCompareMerge.AnyScope
StarTeam.ViewCompareMerge.EveryScope
StarTeam.ViewCompareMerge.FolderScope
StarTeam.ViewCompareMerge.ItemListScope
StarTeam.ViewCompareMerge.ItemTypeScope
StarTeam.ViewCompareMerge.ProcessItemScope
StarTeam.ViewCompareMerge.RevisionLabelScope
StarTeam.ViewCompareMerge.Session.State
StarTeam.ViewCompareMerge.VCMFolder.PreviewState
System.Exception ---- System.Runtime.Serialization.ISerializable
StarTeam.ViewCompareMerge.AmbiguousMatchException

See Also

StarTeam.ViewCompareMerge Namespace


StarTeam.XmlHierarchy

Borland StarTeam SDK for .NET

StarTeam.Xml Hierarchy

System.Object
StarTeam.Xml.XMLAttribute
StarTeam.Xml.XMLDocument
StarTeam.Xml.XMLElement
System.Exception ---- System.Runtime.Serialization.ISerializable
StarTeam.Xml.XMLException
StarTeam.Xml.XMLParseException

See Also

StarTeam.Xml Namespace


StarTeamHierarchy

Borland StarTeam SDK for .NET

StarTeam Hierarchy

System.Object
StarTeam.AccessRightsManager
StarTeam.AccessRightsManager.AccessTestResults
StarTeam.ACE
StarTeam.EffectiveACE
StarTeam.ACE.WebCacheACE
StarTeam.Application
StarTeam.Application.ResolveOptions
StarTeam.ArtifactCache
StarTeam.ArtifactCacheManager
StarTeam.ArtifactCacheManager.Client
StarTeam.ArtifactCacheManager.Context
StarTeam.ArtifactCacheManager.Identifiable
StarTeam.ArtifactCacheManager.Nameable
StarTeam.ArtifactCacheManager.Securable
StarTeam.ArtifactCacheManager.SecurableContainer
StarTeam.BuildNumber
StarTeam.CacheAgent
StarTeam.CacheService
StarTeam.Catalog
StarTeam.Catalog.WebCacheCatalog
StarTeam.Change.ChangeAtomType
StarTeam.Change.ScmChangeAtom
StarTeam.ChangePackage.ScmChangeSet
StarTeam.ChangePackageReplayGraph
StarTeam.ChangeSession
StarTeam.CheckinManager
StarTeam.CheckinManager.Progress
StarTeam.CheckinManager.Progress.Phase
StarTeam.CheckinManager.WebCacheCheckinManager
StarTeam.CheckinOptions
StarTeam.CheckinOptions.WebCacheCheckinOptions
StarTeam.CheckoutManager
StarTeam.CheckoutManager.Progress
StarTeam.CheckoutManager.Progress.Phase
StarTeam.CheckoutManager.Progress.Statistics
StarTeam.CheckoutManager.WebCacheCheckoutManager
StarTeam.CheckoutOptions
StarTeam.CheckoutOptions.ContentFilter
StarTeam.CheckoutOptions.WebCacheCheckoutOptions
StarTeam.ClientContext
StarTeam.ClientContext.DirectoryOverrides
StarTeam.CommandProcessor
StarTeam.ConfigFiles
StarTeam.ConnectionPool
StarTeam.Content
StarTeam.Content.AcceptedTypes
StarTeam.Content.Type
StarTeam.Content.WebCacheContent
StarTeam.EnumeratedValue
StarTeam.Audit.EventID
StarTeam.Change.ChangeType
StarTeam.Change.CommitAction
StarTeam.ChangePackage.SessionType
StarTeam.ChangePackage.State
StarTeam.ChangeRequest.ChangeRequestType
StarTeam.ChangeRequest.Platform
StarTeam.ChangeRequest.Priority
StarTeam.ChangeRequest.Severity
StarTeam.ChangeRequest.StarFlowStatus
StarTeam.ChangeRequest.Status
StarTeam.ChangeRequest.StreamState
StarTeam.File.CharacterSet
StarTeam.File.Compression
StarTeam.File.EOLFormat
StarTeam.File.KeywordFlag
StarTeam.File.Status
StarTeam.File.StorageType
StarTeam.Folder.ExcludeFlags
StarTeam.Folder.Status
StarTeam.Group.GroupType
StarTeam.KanbanBoard.InputType
StarTeam.KanbanBoard.ItemType
StarTeam.Plan.PlanType
StarTeam.Project.Methodology
StarTeam.Project.Status
StarTeam.Requirement.AtlasWorkflowStatus
StarTeam.Requirement.Priority
StarTeam.Requirement.RequirementType
StarTeam.Requirement.Status
StarTeam.Requirement.StreamState
StarTeam.Review.ReviewType
StarTeam.Review.Status
StarTeam.Server.EncryptionAlgorithm
StarTeam.Story.Risk
StarTeam.Story.Status
StarTeam.Story.StoryType
StarTeam.Story.StoryValue
StarTeam.Story.StreamState
StarTeam.Task.Constraint
StarTeam.Task.LifeCycleType
StarTeam.Task.Origin
StarTeam.Task.Priority
StarTeam.Task.ProcessUsage
StarTeam.Task.Status
StarTeam.Task.TaskType
StarTeam.TaskDependency.PredecessorType
StarTeam.Topic.Priority
StarTeam.Topic.Status
StarTeam.Topic.TopicType
StarTeam.Trace.Status
StarTeam.Trace.TraceType
StarTeam.TreeItem.MoSCoW
StarTeam.TypedResource.BranchState
StarTeam.User.GeographicTerritory
StarTeam.User.License
StarTeam.User.Status
StarTeam.View.ViewType
StarTeam.ViewMember.MyLock
StarTeam.ViewMember.ShareState
StarTeam.EventHandlerInfo
StarTeam.EventHandlerProfile
StarTeam.File.Digest
StarTeam.File.Keyword
StarTeam.File.Operation
StarTeam.File.Result
StarTeam.File.AddResult
StarTeam.File.CheckInResult
StarTeam.File.CheckOutResult
StarTeam.File.Revision
StarTeam.File.Stream
StarTeam.File.SyncRecord ---- StarTeam.File.WorkspaceSync
StarTeam.File.WebCacheWorkSpaceSync ---- StarTeam.File.WorkspaceSync
StarTeam.File.WorkspaceSync
StarTeam.FileBasedStatusManager
StarTeam.Filter.Column
StarTeam.Filter.Column.WebCacheColumn
StarTeam.Filter.Context
StarTeam.Filter.Grouping
StarTeam.Filter.Grouping.WebCacheGrouping
StarTeam.Filter.WebCacheFilter
StarTeam.FolderListManager
StarTeam.HiveInfo
StarTeam.HiveInfo.HiveType
StarTeam.HiveManager
StarTeam.ImpersonateUser
StarTeam.IPRange
StarTeam.ISecurable
StarTeam.ISecurableContainer
StarTeam.Label.Scope
StarTeam.Link
StarTeam.Link.Endpoint
StarTeam.LinkCache
StarTeam.LinkValue
StarTeam.LinkValue.WebCacheLinkValue
StarTeam.LiveObject.WebCacheLiveObject
StarTeam.Change.WebCacheChange
StarTeam.Project.WebCacheProject
StarTeam.PromotionModel.WebCachePromotionModel
StarTeam.PromotionState.WebCachePromotionState
StarTeam.TrackedObject.WebCacheTrackedObject
StarTeam.Label.WebCacheLabel
StarTeam.Principal.WebCachePrincipal
StarTeam.Group.WebCacheGroup
StarTeam.User.WebCacheUser
StarTeam.TaskDependency.WebCacheTaskDependency
StarTeam.VersionedObject.WebCacheVersionedObject
StarTeam.ViewMember.WebCacheViewMember
StarTeam.ChangePackage.WebCacheChangePackage
StarTeam.Item.WebCacheItem
StarTeam.ChangeRequest.WebCacheChangeRequest
StarTeam.Concept.WebCacheConcept
StarTeam.File.WebCacheFile
StarTeam.Folder.WebCacheFolder
StarTeam.KanbanBoard.WebCacheKanbanBoard
StarTeam.Plan.WebCachePlan
StarTeam.Review.WebCacheReview
StarTeam.Sprint.WebCacheSprint
StarTeam.Swimlane.WebCacheSwimlane
StarTeam.TestRun.WebCacheTestRun
StarTeam.TreeItem.WebCacheTreeItem
StarTeam.Requirement.WebCacheRequirement
StarTeam.Story.WebCacheStory
StarTeam.Task.WebCacheTask
StarTeam.Test.WebCacheTest
StarTeam.Topic.WebCacheTopic
StarTeam.WhiteBoard.WebCacheWhiteBoard
StarTeam.Trace.WebCacheTrace
StarTeam.WorkRecord.WebCacheWorkRecord
StarTeam.View.WebCacheView
StarTeam.LocalFileSystemPropertyProvider
StarTeam.Lockable
StarTeam.LockableObject ---- StarTeam.Lockable
StarTeam.MatchedACE
StarTeam.MergePoint
StarTeam.MergePoint.Revision
StarTeam.NamedCacheRef
StarTeam.Filter ---- StarTeam.ISecurable
StarTeam.Query ---- StarTeam.ISecurable
StarTeam.Type ---- StarTeam.ISecurableContainer
StarTeam.TypedResource.Type
StarTeam.LiveObject.Type
StarTeam.Change.Type
StarTeam.Project.Type
StarTeam.PromotionModel.Type
StarTeam.PromotionState.Type
StarTeam.TrackedObject.Type
StarTeam.Label.Type
StarTeam.Principal.Type
StarTeam.Group.Type
StarTeam.User.Type
StarTeam.Share.Type
StarTeam.VersionedObject.Type
StarTeam.TaskDependency.Type
StarTeam.ViewMember.Type
StarTeam.ChangePackage.Type
StarTeam.Item.Type
StarTeam.Audit.Type
StarTeam.ChangeRequest.Type
StarTeam.Concept.Type
StarTeam.File.Type
StarTeam.Folder.Type
StarTeam.KanbanBoard.Type
StarTeam.Plan.Type
StarTeam.Review.Type
StarTeam.Sprint.Type
StarTeam.Swimlane.Type
StarTeam.TestRun.Type
StarTeam.TreeItem.Type
StarTeam.Requirement.Type
StarTeam.Story.Type
StarTeam.Task.Type
StarTeam.Test.Type
StarTeam.Topic.Type
StarTeam.WhiteBoard.Type
StarTeam.Trace.Type
StarTeam.WorkRecord.Type
StarTeam.View.Type
StarTeam.ViewMemberRevision.Type
StarTeam.NetMonitor
StarTeam.Oauth2ServiceProvider
StarTeam.Oauth2ServiceProvider.WebCacheOauth2ServiceProvider
StarTeam.Permission
StarTeam.ProcessItem
StarTeam.Project.ScmSubRepository
StarTeam.Property
StarTeam.ContentProperty
StarTeam.Concept.Type.ContentProperty
StarTeam.Item.Type.DiagramSourceProperty
StarTeam.Test.Type.DescriptionProperty
StarTeam.TestRun.Type.DescriptionProperty
StarTeam.TreeItem.Type.RichDescriptionProperty
StarTeam.User.Type.UserImageProperty
StarTeam.EnumeratedProperty
StarTeam.Audit.Type.EventIDProperty
StarTeam.BooleanProperty
StarTeam.File.Type.IsExecutableProperty
StarTeam.File.Type.IsSyncInRevisionHistoryProperty
StarTeam.File.Type.IsSyncKnownProperty
StarTeam.File.Type.IsWorkingFileAvailableProperty
StarTeam.File.Type.IsWorkingFileExecutableProperty
StarTeam.KanbanBoard.Type.EnforceAgeProperty
StarTeam.KanbanBoard.Type.EnforceWIPProperty
StarTeam.KanbanBoard.Type.InTeamRoomProperty
StarTeam.Project.Type.ForceCheckinReasonProperty
StarTeam.Project.Type.IsProcessItemRequiredProperty
StarTeam.Project.Type.MarkUnlockedFilesReadOnlyProperty
StarTeam.Project.Type.MergeHistoryDuringVCMSessionProperty
StarTeam.Project.Type.RequireLockForCheckinProperty
StarTeam.Project.Type.UseKeywordsProperty
StarTeam.Requirement.Type.AmIResponsibleProperty
StarTeam.Requirement.Type.IsDisabledProperty
StarTeam.Story.Type.IsCarriedOverProperty
StarTeam.Swimlane.Type.EnabledProperty
StarTeam.Task.Type.BlockedProperty
StarTeam.Task.Type.IsMyTaskProperty
StarTeam.Task.Type.MilestoneProperty
StarTeam.Task.Type.NeedsAttentionProperty
StarTeam.TestRun.Type.IsBlockedProperty
StarTeam.Topic.Type.AmIRecipientProperty
StarTeam.Trace.Type.IsSuspectProperty
StarTeam.TreeItem.Type.IsLeafProperty
StarTeam.User.Type.DirectoryServiceIDProperty
StarTeam.User.Type.IsDirectoryManagedProperty
StarTeam.View.Type.IsDeleteCompleteProperty
StarTeam.View.Type.IsPurgedProperty
StarTeam.View.Type.IsVCMCodeReviewRequiredProperty
StarTeam.View.Type.IsVCMCommitEnforcedProperty
StarTeam.ViewMember.Type.IsBookmarkedProperty
StarTeam.ViewMember.Type.IsBranchOnChangeProperty
StarTeam.ViewMember.Type.IsReadOnlyProperty
StarTeam.ViewMember.Type.IsUnreadProperty
StarTeam.ViewMemberRevision.Type.BranchFlagProperty
StarTeam.Change.Type.ActionProperty
StarTeam.Change.Type.ChangeTypeProperty
StarTeam.ChangePackage.Type.SessionTypeProperty
StarTeam.ChangePackage.Type.StateProperty
StarTeam.ChangeRequest.Type.ChangeRequestTypeProperty
StarTeam.ChangeRequest.Type.PlatformProperty
StarTeam.ChangeRequest.Type.PriorityProperty
StarTeam.ChangeRequest.Type.SeverityProperty
StarTeam.ChangeRequest.Type.StarFlowStatusProperty
StarTeam.ChangeRequest.Type.StatusProperty
StarTeam.ChangeRequest.Type.StreamStateProperty
StarTeam.File.Type.CharacterSetProperty
StarTeam.File.Type.CompressionProperty
StarTeam.File.Type.EOLFormatProperty
StarTeam.File.Type.KeywordFlagProperty
StarTeam.File.Type.StatusProperty
StarTeam.File.Type.StorageTypeProperty
StarTeam.Folder.Type.ExcludeFlagsProperty
StarTeam.Folder.Type.StatusProperty
StarTeam.Group.Type.TypeProperty
StarTeam.Item.Type.TagProperty
StarTeam.KanbanBoard.Type.InputTypeProperty
StarTeam.KanbanBoard.Type.ItemTypeProperty
StarTeam.Plan.Type.PlanTypeProperty
StarTeam.Project.Type.EncryptionAlgorithmProperty
StarTeam.Project.Type.MethodologyProperty
StarTeam.Project.Type.StatusProperty
StarTeam.Requirement.Type.AtlasWorkflowStatusProperty
StarTeam.Requirement.Type.PriorityProperty
StarTeam.Requirement.Type.RequirementTypeProperty
StarTeam.Requirement.Type.StatusProperty
StarTeam.Requirement.Type.StreamStateProperty
StarTeam.Requirement.Type.UDAGroupingProperty
StarTeam.Review.Type.ReviewTypeProperty
StarTeam.Review.Type.StatusProperty
StarTeam.Story.Type.IncomingStreamProperty
StarTeam.Story.Type.RiskProperty
StarTeam.Story.Type.StatusProperty
StarTeam.Story.Type.StoryTypeProperty
StarTeam.Story.Type.StoryValueProperty
StarTeam.Story.Type.StreamStateProperty
StarTeam.Task.Type.ConstraintProperty
StarTeam.Task.Type.LifeCycleTypeProperty
StarTeam.Task.Type.OriginProperty
StarTeam.Task.Type.PriorityProperty
StarTeam.Task.Type.ProcessUsageProperty
StarTeam.Task.Type.StatusProperty
StarTeam.Task.Type.TaskTypeProperty
StarTeam.TaskDependency.Type.PredecessorTypeProperty
StarTeam.Topic.Type.PriorityProperty
StarTeam.Topic.Type.StatusProperty
StarTeam.Topic.Type.TaxonomyProperty
StarTeam.Topic.Type.TopicTypeProperty
StarTeam.Trace.Type.StatusProperty
StarTeam.Trace.Type.TraceTypeProperty
StarTeam.TreeItem.Type.MoSCoWProperty
StarTeam.TypedResource.Type.BranchStateProperty
StarTeam.User.Type.LicenseTypeProperty
StarTeam.User.Type.StatusProperty
StarTeam.User.Type.TerritoryProperty
StarTeam.View.Type.TypeProperty
StarTeam.ViewMember.Type.MyLockProperty
StarTeam.ViewMember.Type.ShareStateProperty
StarTeam.LinkProperty
StarTeam.ChangePackage.Type.ProcessItemProperty
StarTeam.LiveObject.Type.SourceProperty
StarTeam.LiveObject.Type.TargetProperty
StarTeam.ObjectProperty
StarTeam.Audit.Type.UserProperty
StarTeam.Change.Type.ChangePackageProperty
StarTeam.ChangePackage.Type.CommittedByProperty
StarTeam.ChangePackage.Type.CommittedInBuildProperty
StarTeam.ChangePackage.Type.PostCommitRevisionLabelProperty
StarTeam.ChangePackage.Type.PostCommitViewLabelProperty
StarTeam.ChangePackage.Type.PreCommitRevisionLabelProperty
StarTeam.ChangePackage.Type.PreCommitViewLabelProperty
StarTeam.ChangePackage.Type.SourceViewProperty
StarTeam.ChangePackage.Type.TargetViewProperty
StarTeam.ChangeRequest.Type.AddressedByProperty
StarTeam.ChangeRequest.Type.AddressedInProperty
StarTeam.ChangeRequest.Type.AddressedInViewProperty
StarTeam.ChangeRequest.Type.EnteredByProperty
StarTeam.ChangeRequest.Type.LastBuildTestedProperty
StarTeam.Folder.Type.ProjectProperty
StarTeam.Group.Type.ParentProperty
StarTeam.LiveObject.Type.CreatedByProperty
StarTeam.LiveObject.Type.DeletedByProperty
StarTeam.Project.Type.DefaultViewProperty
StarTeam.PromotionState.Type.LabelProperty
StarTeam.Requirement.Type.OwnerProperty
StarTeam.Requirement.Type.PlanProperty
StarTeam.Share.Type.ProjectProperty
StarTeam.Share.Type.ViewProperty
StarTeam.Sprint.Type.OwnerProperty
StarTeam.Sprint.Type.PlanProperty
StarTeam.Story.Type.PlanProperty
StarTeam.Story.Type.SponsorProperty
StarTeam.Story.Type.SprintProperty
StarTeam.Task.Type.ResponsibilityProperty
StarTeam.Task.Type.StoryProperty
StarTeam.TrackedObject.Type.ModifiedByProperty
StarTeam.TypedResource.Type.ProjectProperty
StarTeam.TypedResource.Type.ViewProperty
StarTeam.View.Type.ParentViewProperty
StarTeam.View.Type.PromotionStateProperty
StarTeam.View.Type.ResolvedViewProperty
StarTeam.ViewMember.Type.ExclusiveLockerProperty
StarTeam.ViewMember.Type.ItemDeletedByProperty
StarTeam.ViewMember.Type.ResponsibilityProperty
StarTeam.ViewMemberRevision.Type.CreatedByProperty
StarTeam.WorkRecord.Type.PerformedByProperty
StarTeam.ScalarProperty
StarTeam.DateProperty
StarTeam.Sprint.Type.EndDateProperty
StarTeam.Sprint.Type.StartDateProperty
StarTeam.Task.Type.ActualFinishProperty
StarTeam.Task.Type.ActualStartProperty
StarTeam.Task.Type.EstimatedFinishProperty
StarTeam.Task.Type.EstimatedStartProperty
StarTeam.WorkRecord.Type.WorkedOnProperty
StarTeam.DateTimeProperty
StarTeam.Audit.Type.RevisionTime1Property
StarTeam.Audit.Type.RevisionTime2Property
StarTeam.Audit.Type.RevisionTime3Property
StarTeam.ChangePackage.Type.CommittedTimeProperty
StarTeam.ChangePackage.Type.ExternalCreatedTimeProperty
StarTeam.ChangeRequest.Type.ClosedOnProperty
StarTeam.ChangeRequest.Type.EnteredOnProperty
StarTeam.ChangeRequest.Type.ResolvedOnProperty
StarTeam.ChangeRequest.Type.VerifiedOnProperty
StarTeam.File.Type.ContentModifiedTimeProperty
StarTeam.File.Type.SyncModifiedTimeProperty
StarTeam.File.Type.WorkingFileModifiedTimeProperty
StarTeam.Label.Type.LabelTimeProperty
StarTeam.LiveObject.Type.CreatedTimeProperty
StarTeam.LiveObject.Type.DeletedTimeProperty
StarTeam.Plan.Type.EndDateProperty
StarTeam.Plan.Type.StartDateProperty
StarTeam.Project.Type.CheckinChangePackageLastUpdateProperty
StarTeam.Task.Type.ConstraintDateProperty
StarTeam.Task.Type.MSProjectLastUpdateProperty
StarTeam.Task.Type.WorkDependencyLastUpdateProperty
StarTeam.TestRun.Type.ExecutedAtProperty
StarTeam.TrackedObject.Type.EndModifiedTimeProperty
StarTeam.TrackedObject.Type.ModifiedTimeProperty
StarTeam.User.Type.FridayAMProperty
StarTeam.User.Type.FridayPMProperty
StarTeam.User.Type.LastLogoutTimeProperty
StarTeam.User.Type.LastPasswordChangeTimeProperty
StarTeam.User.Type.LastWebLogoutTimeProperty
StarTeam.User.Type.LockOutTimeProperty
StarTeam.User.Type.MondayAMProperty
StarTeam.User.Type.MondayPMProperty
StarTeam.User.Type.SaturdayAMProperty
StarTeam.User.Type.SaturdayPMProperty
StarTeam.User.Type.SundayAMProperty
StarTeam.User.Type.SundayPMProperty
StarTeam.User.Type.ThursdayAMProperty
StarTeam.User.Type.ThursdayPMProperty
StarTeam.User.Type.TuesdayAMProperty
StarTeam.User.Type.TuesdayPMProperty
StarTeam.User.Type.WednesdayAMProperty
StarTeam.User.Type.WednesdayPMProperty
StarTeam.View.Type.BaseConfigurationDataProperty
StarTeam.View.Type.CloneTimeProperty
StarTeam.View.Type.EndDateProperty
StarTeam.View.Type.StartDateProperty
StarTeam.View.Type.WorkspaceModifiedTimeProperty
StarTeam.ViewMember.Type.ConfigurationTimeProperty
StarTeam.ViewMember.Type.ItemDeletedTimeProperty
StarTeam.ViewMemberRevision.Type.CreatedTimeProperty
StarTeam.ViewMemberRevision.Type.ObjectTimeProperty
StarTeam.DoubleProperty
StarTeam.Plan.Type.WeeklyCapacityProperty
StarTeam.Requirement.Type.OrderProperty
StarTeam.Requirement.Type.RankProperty
StarTeam.Story.Type.EstimatedPointsProperty
StarTeam.Story.Type.RankProperty
StarTeam.Story.Type.StoryOrderProperty
StarTeam.Task.Type.EstimatedHoursVarianceProperty
StarTeam.Task.Type.OrderProperty
StarTeam.Trace.Type.OrderProperty
StarTeam.IntegerProperty
StarTeam.Audit.Type.ClassID1Property
StarTeam.Audit.Type.ClassID2Property
StarTeam.Audit.Type.ClassID3Property
StarTeam.Audit.Type.FolderIDProperty
StarTeam.Audit.Type.ObjectID1Property
StarTeam.Audit.Type.ObjectID2Property
StarTeam.Audit.Type.ObjectID3Property
StarTeam.Change.Type.FlagsProperty
StarTeam.ChangePackage.Type.FullScopeProperty
StarTeam.ChangeRequest.Type.ChangeNumberProperty
StarTeam.Concept.Type.ConceptIDProperty
StarTeam.File.Type.ContentVersionProperty
StarTeam.File.Type.HiveProperty
StarTeam.File.Type.SyncBranchVersionProperty
StarTeam.File.Type.SyncContentVersionProperty
StarTeam.File.Type.SyncViewVersionProperty
StarTeam.File.Type.VaultVersionProperty
StarTeam.File.Type.ViewVersionProperty
StarTeam.Group.Type.PrivilegeMaskProperty
StarTeam.Group.Type.TenantProperty
StarTeam.Item.Type.NotificationCountProperty
StarTeam.KanbanBoard.Type.InputIDProperty
StarTeam.Label.Type.MemberIDProperty
StarTeam.LiveObject.Type.FlagsProperty
StarTeam.Plan.Type.PlanIDProperty
StarTeam.Project.Type.CanCreateCheckinChangePackageProperty
StarTeam.Project.Type.CompactionProperty
StarTeam.Project.Type.MailProperty
StarTeam.Project.Type.TenantProperty
StarTeam.PromotionModel.Type.NumberOfStatesProperty
StarTeam.Requirement.Type.AmbiguitiesCountProperty
StarTeam.Requirement.Type.ChildrenCountProperty
StarTeam.Requirement.Type.ChildTypeProperty
StarTeam.Requirement.Type.ExpectedEffortProperty
StarTeam.Requirement.Type.ExplicitRankProperty
StarTeam.Requirement.Type.HighEffortProperty
StarTeam.Requirement.Type.LowEffortProperty
StarTeam.Requirement.Type.ParentRequirementIDProperty
StarTeam.Requirement.Type.RequirementNumberProperty
StarTeam.Requirement.Type.ResponsibleCountProperty
StarTeam.Review.Type.ReviewIDProperty
StarTeam.Share.Type.FolderIDProperty
StarTeam.Share.Type.ItemIDProperty
StarTeam.Share.Type.NumberOfDerivedSharesProperty
StarTeam.Share.Type.ObjectIDProperty
StarTeam.Sprint.Type.SprintIDProperty
StarTeam.Story.Type.StoryIDProperty
StarTeam.Swimlane.Type.ScheduleStatusProperty
StarTeam.Swimlane.Type.WorkInProgressProperty
StarTeam.Task.Type.ChildrenCountProperty
StarTeam.Task.Type.EstimatedFinishVarianceProperty
StarTeam.Task.Type.EstimatedStartVarianceProperty
StarTeam.Task.Type.IsReplicatedProperty
StarTeam.Task.Type.NumberProperty
StarTeam.Task.Type.ParentTaskIDProperty
StarTeam.Task.Type.PercentCompleteProperty
StarTeam.Task.Type.ResourceCountProperty
StarTeam.Task.Type.UniqueIDProperty
StarTeam.Task.Type.WorkRecordCountProperty
StarTeam.TaskDependency.Type.LagTimeProperty
StarTeam.TaskDependency.Type.PredecessorProperty
StarTeam.TaskDependency.Type.TaskProperty
StarTeam.Test.Type.TestIDProperty
StarTeam.TestRun.Type.TestRunIDProperty
StarTeam.Topic.Type.ChildrenCountProperty
StarTeam.Topic.Type.ParentTopicIDProperty
StarTeam.Topic.Type.RecipientCountProperty
StarTeam.Topic.Type.TopicNumberProperty
StarTeam.TrackedObject.Type.TransactionIDProperty
StarTeam.TreeItem.Type.ParentIDProperty
StarTeam.TypedResource.Type.IDProperty
StarTeam.User.Type.AccessRestrictionProperty
StarTeam.User.Type.LicenseProperty
StarTeam.User.Type.TenantProperty
StarTeam.VersionedObject.Type.CommentIDProperty
StarTeam.VersionedObject.Type.RevisionFlagsProperty
StarTeam.VersionedObject.Type.RevisionNumberProperty
StarTeam.View.Type.BaseConfigurationTypeProperty
StarTeam.View.Type.RootFolderIDProperty
StarTeam.View.Type.ShareFlagsProperty
StarTeam.View.Type.TenantProperty
StarTeam.ViewMember.Type.AttachmentCountProperty
StarTeam.ViewMember.Type.ParentBranchLengthProperty
StarTeam.ViewMember.Type.ParentBranchRevisionProperty
StarTeam.ViewMember.Type.ParentObjectIDProperty
StarTeam.ViewMember.Type.RootObjectIDProperty
StarTeam.ViewMember.Type.ViewMemberIDProperty
StarTeam.ViewMemberRevision.Type.ObjectIDProperty
StarTeam.ViewMemberRevision.Type.ParentFolderProperty
StarTeam.ViewMemberRevision.Type.ParentShareProperty
StarTeam.WhiteBoard.Type.WhiteBoardIDProperty
StarTeam.WorkRecord.Type.ParentTaskProperty
StarTeam.LongIntegerProperty
StarTeam.File.Type.SizeProperty
StarTeam.File.Type.SyncSizeProperty
StarTeam.File.Type.WorkingFileSizeProperty
StarTeam.LiveObject.Type.GlobalIDProperty
StarTeam.TimeSpanProperty
StarTeam.Swimlane.Type.AgeLimitProperty
StarTeam.Task.Type.ActualHoursProperty
StarTeam.Task.Type.DurationProperty
StarTeam.Task.Type.EstimatedHoursProperty
StarTeam.TestRun.Type.DurationProperty
StarTeam.User.Type.TimeZoneShiftProperty
StarTeam.WorkRecord.Type.TimeRemainingProperty
StarTeam.WorkRecord.Type.TimeWorkedProperty
StarTeam.VectorProperty
StarTeam.BinaryProperty
StarTeam.File.Type.MD5Property
StarTeam.File.Type.SyncMD5Property
StarTeam.User.Type.PasswordProperty
StarTeam.MapProperty
StarTeam.ObjectArrayProperty
StarTeam.Item.Type.NotificationIDsProperty
StarTeam.Project.Type.DefaultTypesProperty
StarTeam.PromotionModel.Type.PromotionStatesProperty
StarTeam.Requirement.Type.ResponsibleUsersProperty
StarTeam.Requirement.Type.ReviewedByProperty
StarTeam.Review.Type.AcceptorsProperty
StarTeam.Review.Type.AuthorsProperty
StarTeam.Review.Type.RejectorsProperty
StarTeam.Review.Type.ReviewersProperty
StarTeam.Review.Type.WatchersProperty
StarTeam.Sprint.Type.TargetReleasesProperty
StarTeam.Story.Type.TargetReleasesProperty
StarTeam.Task.Type.ResourcesProperty
StarTeam.Topic.Type.RecipientsProperty
StarTeam.Topic.Type.UserDislikesProperty
StarTeam.Topic.Type.UserLikesProperty
StarTeam.User.Type.FavoriteProjectsProperty
StarTeam.View.Type.ExcludedGroupsProperty
StarTeam.View.Type.ExcludedUsersProperty
StarTeam.ViewMember.Type.AttachmentIDsProperty
StarTeam.ViewMember.Type.FlaggedByUsersProperty
StarTeam.ViewMember.Type.UnreadByUsersProperty
StarTeam.TextProperty
StarTeam.Audit.Type.ClassName1Property
StarTeam.Audit.Type.ClassName2Property
StarTeam.Audit.Type.ClassName3Property
StarTeam.Audit.Type.Descriptor1Property
StarTeam.Audit.Type.Descriptor2Property
StarTeam.Audit.Type.Descriptor3Property
StarTeam.Audit.Type.Info1Property
StarTeam.Audit.Type.Info2Property
StarTeam.Audit.Type.Info3Property
StarTeam.Change.Type.ItemTypeProperty
StarTeam.Change.Type.SourceVersionProperty
StarTeam.Change.Type.TargetVersionProperty
StarTeam.ChangePackage.Type.ExternalBranchURLProperty
StarTeam.ChangePackage.Type.ExternalCreatedByProperty
StarTeam.ChangePackage.Type.ExternalRepositoryURIProperty
StarTeam.ChangeRequest.Type.CategoryProperty
StarTeam.ChangeRequest.Type.ComponentProperty
StarTeam.ChangeRequest.Type.FixProperty
StarTeam.ChangeRequest.Type.SynopsisProperty
StarTeam.ChangeRequest.Type.TestCommandProperty
StarTeam.ChangeRequest.Type.WorkAroundProperty
StarTeam.File.Type.ArchiveNameProperty
StarTeam.File.Type.ExtensionProperty
StarTeam.File.Type.NotificationUsersProperty
StarTeam.File.Type.SymbolicLinkTargetProperty
StarTeam.File.Type.WorkingFileNameProperty
StarTeam.File.Type.WorkingFilePathProperty
StarTeam.File.Type.WorkingFolderPathProperty
StarTeam.Folder.Type.ExcludeSpecProperty
StarTeam.Folder.Type.WorkingFolderPathProperty
StarTeam.Group.Type.DescriptionProperty
StarTeam.Group.Type.NameProperty
StarTeam.Item.Type.ExternalReferenceProperty
StarTeam.Item.Type.FolderProperty
StarTeam.Item.Type.NewRevisionCommentProperty
StarTeam.Item.Type.TeamProperty
StarTeam.Item.Type.VersionMetadataIDsProperty
StarTeam.Item.Type.VersionMetadataProperty
StarTeam.KanbanBoard.Type.InboxLaneProperty
StarTeam.LiveObject.Type.DescriptionProperty
StarTeam.LiveObject.Type.NameProperty
StarTeam.LiveObject.Type.WorkingFolderProperty
StarTeam.Project.Type.GUIDProperty
StarTeam.Project.Type.KeywordFileExtensionsProperty
StarTeam.Requirement.Type.CommentsProperty
StarTeam.Requirement.Type.NotesProperty
StarTeam.Requirement.Type.ResponsibleNamesProperty
StarTeam.Requirement.Type.RevisedDescriptionProperty
StarTeam.Review.Type.PulseLabelProperty
StarTeam.Share.Type.ItemRevisionProperty
StarTeam.Share.Type.ProjectNameProperty
StarTeam.Share.Type.ViewPathProperty
StarTeam.Story.Type.AcceptanceCriteriaProperty
StarTeam.Story.Type.GeneralProperty
StarTeam.Story.Type.NotesProperty
StarTeam.Swimlane.Type.ColorProperty
StarTeam.Task.Type.AttentionNotesProperty
StarTeam.Task.Type.DescriptionProperty
StarTeam.Task.Type.GUIDProperty
StarTeam.Task.Type.MSProjectFileNameProperty
StarTeam.Task.Type.NameProperty
StarTeam.Task.Type.NotesProperty
StarTeam.Task.Type.ResourceNamesProperty
StarTeam.Task.Type.WBSCodeProperty
StarTeam.Test.Type.PathProperty
StarTeam.TestRun.Type.BuildProperty
StarTeam.TestRun.Type.ExecutedByProperty
StarTeam.TestRun.Type.ProductProperty
StarTeam.TestRun.Type.StatusProperty
StarTeam.TestRun.Type.StatusReasonProperty
StarTeam.TestRun.Type.TestNameProperty
StarTeam.TestRun.Type.TestVersionProperty
StarTeam.Topic.Type.ContextRangeProperty
StarTeam.Topic.Type.RecipientNamesProperty
StarTeam.Topic.Type.TitleProperty
StarTeam.Trace.Type.SourceVersionsProperty
StarTeam.TrackedObject.Type.FolderPathProperty
StarTeam.TrackedObject.Type.ParentFolderNameProperty
StarTeam.TreeItem.Type.ExternalTestIDProperty
StarTeam.TreeItem.Type.ExternalTestProjectURLProperty
StarTeam.TreeItem.Type.ExternalTestURLProperty
StarTeam.User.Type.AddressProperty
StarTeam.User.Type.DistinguishedNameProperty
StarTeam.User.Type.EmailAddressProperty
StarTeam.User.Type.FaxProperty
StarTeam.User.Type.LoginNameProperty
StarTeam.User.Type.NameProperty
StarTeam.User.Type.PagerProperty
StarTeam.User.Type.PhoneProperty
StarTeam.User.Type.ReturnEmailAddressProperty
StarTeam.User.Type.VoiceMailProperty
StarTeam.VersionedObject.Type.ShortCommentProperty
StarTeam.ViewMember.Type.AttachmentNamesProperty
StarTeam.ViewMember.Type.CommentProperty
StarTeam.ViewMember.Type.DotNotationProperty
StarTeam.ViewMember.Type.ExternalIDProperty
StarTeam.ViewMember.Type.ExternalURLProperty
StarTeam.ViewMember.Type.NonExclusiveLockersProperty
StarTeam.WhiteBoard.Type.ColorProperty
StarTeam.WorkRecord.Type.CommentProperty
StarTeam.Property.MetaData
StarTeam.Property.WebCacheProperty
StarTeam.BooleanProperty.WebCacheBooleanProperty
StarTeam.ContentProperty.WebCacheContentProperty
StarTeam.EnumeratedProperty.WebCacheEnumeratedProperty
StarTeam.LinkProperty.WebCacheLinkProperty
StarTeam.ObjectProperty.WebCacheObjectProperty
StarTeam.ScalarProperty.WebCacheScalarProperty
StarTeam.DateProperty.WebCacheDateProperty
StarTeam.DateTimeProperty.WebCacheDateTimeProperty
StarTeam.DoubleProperty.WebCacheDoubleProperty
StarTeam.IntegerProperty.WebCacheIntegerProperty
StarTeam.LongIntegerProperty.WebCacheLongIntegerProperty
StarTeam.TimeSpanProperty.WebCacheTimeSpanProperty
StarTeam.VectorProperty.WebCacheVectorProperty
StarTeam.BinaryProperty.WebCacheBinaryProperty
StarTeam.MapProperty.WebCacheMapProperty
StarTeam.ObjectArrayProperty.WebCacheObjectArrayProperty
StarTeam.TextProperty.WebCacheTextProperty
StarTeam.PurgeController
StarTeam.PurgeController.Status
StarTeam.Query.Context
StarTeam.Query.WebCacheQuery
StarTeam.QueryNode
StarTeam.QueryNode.Operator
StarTeam.QueryNode.WebCacheQueryNode
StarTeam.QueryPart
StarTeam.QueryPart.Relation
StarTeam.QueryPart.WebCacheQueryPart
StarTeam.RollbackSession
StarTeam.RollbackSession.Change
StarTeam.RollbackSession.MergeAction
StarTeam.Server
StarTeam.Server.CacheController
StarTeam.Server.EmailAttachment
StarTeam.Server.ProductCode
StarTeam.Server.Session
StarTeam.Server.WebCacheServer
StarTeam.ServerAdministration
StarTeam.ServerAdministration.License
StarTeam.ServerAdministration.License.AutoPassLicense
StarTeam.ServerAdministration.License.BLS
StarTeam.ServerAdministration.LockStatus
StarTeam.ServerAdministration.SecurityLogEntry
StarTeam.ServerAdministration.SecurityLogEntry.AccessCheck
StarTeam.ServerAdministration.SecurityLogEntry.ContainerACL
StarTeam.ServerAdministration.SecurityLogEntry.EventType
StarTeam.ServerAdministration.SecurityLogEntry.ObjectACL
StarTeam.ServerAdministration.SecurityLogEntry.UserGroup
StarTeam.ServerAdministration.SecurityLogEntry.Workstation
StarTeam.ServerAdministration.ServerLogMode
StarTeam.ServerAdministration.ServerLogType
StarTeam.ServerConfiguration
StarTeam.ServerConfiguration.AuthenticationType
StarTeam.ServerConfiguration.DatabaseType
StarTeam.ServerConfiguration.DirectoryServiceSecurityType
StarTeam.ServerConfiguration.NotificationType
StarTeam.ServerConfiguration.WebCacheServerConfiguration
StarTeam.ServerInfo
StarTeam.Share.WebCacheShare
StarTeam.StarTeamClientOptions
StarTeam.StarTeamCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
StarTeam.ChangeCollection
StarTeam.PermissionCollection
StarTeam.PropertyCollection
StarTeam.Audit.Type.PropertyCollection
StarTeam.Change.Type.PropertyCollection
StarTeam.Group.Type.PropertyCollection
StarTeam.Label.Type.PropertyCollection
StarTeam.Project.Type.PropertyCollection
StarTeam.PromotionModel.Type.PropertyCollection
StarTeam.PromotionState.Type.PropertyCollection
StarTeam.Share.Type.PropertyCollection
StarTeam.TaskDependency.Type.PropertyCollection
StarTeam.User.Type.PropertyCollection
StarTeam.View.Type.PropertyCollection
StarTeam.ViewMember.Type.PropertyCollection
StarTeam.ChangePackage.Type.PropertyCollection
StarTeam.Item.Type.PropertyCollection
StarTeam.ChangeRequest.Type.PropertyCollection
StarTeam.Concept.Type.PropertyCollection
StarTeam.File.Type.PropertyCollection
StarTeam.Folder.Type.PropertyCollection
StarTeam.KanbanBoard.Type.PropertyCollection
StarTeam.Plan.Type.PropertyCollection
StarTeam.Requirement.Type.PropertyCollection
StarTeam.Review.Type.PropertyCollection
StarTeam.Sprint.Type.PropertyCollection
StarTeam.Story.Type.PropertyCollection
StarTeam.Swimlane.Type.PropertyCollection
StarTeam.Task.Type.PropertyCollection
StarTeam.Test.Type.PropertyCollection
StarTeam.TestRun.Type.PropertyCollection
StarTeam.Topic.Type.PropertyCollection
StarTeam.WhiteBoard.Type.PropertyCollection
StarTeam.Trace.Type.PropertyCollection
StarTeam.ViewMemberRevision.Type.PropertyCollection
StarTeam.WorkRecord.Type.PropertyCollection
StarTeam.ServerInfoCollection
StarTeam.TypeCollection
StarTeam.ViewMemberCollection ---- StarTeam.Lockable
StarTeam.ChangePackageCollection
StarTeam.TraceCollection
StarTeam.StarTeamRepositoryIDs
StarTeam.StarTeamURL
StarTeam.StatusMethod
StarTeam.StatusMethod.FileStatus
StarTeam.SupportedFeatures
StarTeam.SystemPolicy
StarTeam.SystemPolicy.WebCacheSystemPolicy
StarTeam.TraceFinder
StarTeam.TraceFinder.Direction
StarTeam.TraceFinder.PinType
StarTeam.Transaction
StarTeam.Transaction.WebCacheTransaction
StarTeam.Translations
StarTeam.Type.MetaData
StarTeam.Type.WebCacheType
StarTeam.ViewMember.Type.WebCacheViewMemberType
StarTeam.Item.Type.WebCacheItemType
StarTeam.TreeItem.Type.WebCacheTreeItemType
StarTeam.TypedResource
StarTeam.LiveObject
StarTeam.Change
StarTeam.Project ---- StarTeam.ISecurable, StarTeam.ISecurableContainer
StarTeam.PromotionModel
StarTeam.PromotionState ---- StarTeam.ISecurable
StarTeam.TrackedObject
StarTeam.Label
StarTeam.Principal
StarTeam.Group
StarTeam.User
StarTeam.Share
StarTeam.TaskDependency
StarTeam.VersionedObject
StarTeam.ViewMember ---- StarTeam.ISecurable, StarTeam.Lockable, StarTeam.LockableObject
StarTeam.ChangePackage
StarTeam.Item
StarTeam.Audit
StarTeam.ChangeRequest
StarTeam.Concept
StarTeam.File
StarTeam.Folder ---- StarTeam.ISecurableContainer
StarTeam.KanbanBoard
StarTeam.Plan
StarTeam.Review
StarTeam.Sprint
StarTeam.Swimlane
StarTeam.TestRun
StarTeam.TreeItem
StarTeam.Requirement
StarTeam.Story
StarTeam.Task
StarTeam.Test
StarTeam.Topic
StarTeam.WhiteBoard
StarTeam.Trace
StarTeam.LinkToTraceAdapter
StarTeam.WorkRecord
StarTeam.View ---- StarTeam.ISecurable, StarTeam.ISecurableContainer
StarTeam.RecycleBin
StarTeam.ViewMemberRevision
StarTeam.User.DayOfWeek
StarTeam.User.LoginHistory
StarTeam.User.LogOnPolicy
StarTeam.Util.LineProcessor
StarTeam.File.KeywordReader
StarTeam.View.ScmBranch
StarTeam.ViewConfiguration
StarTeam.ViewConfiguration.WebCacheViewConfiguration
StarTeam.ViewConfigurationDiffer
StarTeam.ViewMember.LockType
StarTeam.ViewMemberBehavior
StarTeam.ViewMemberCollection.BehaviorContainer
StarTeam.ViewMemberCollection.HistoryContainer
StarTeam.ViewMemberCollection.WebCacheViewMemberCollection
StarTeam.ViewMemberCollection.WebCacheViewMemberCollection.WebCacheHistoryContainer
StarTeam.ViewMemberListManager
StarTeam.ViewMemberListManager.GroupNode
StarTeam.ViewMemberRevision.WebCacheViewMemberRevision
StarTeam.ViewPollingAgent
StarTeam.Workflow
StarTeam.Workflow.Step
StarTeam.Workflow.Step.WebCacheStep
StarTeam.Workflow.WebCacheWorkflow

See Also

StarTeam Namespace